APEX BasicFS Module: Class List

  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
nvidia::apex::AttractorFSActor | AttractorFS Actor class
nvidia::apex::AttractorFSPreview | This class provides the asset preview for APEX AttractorFS Assets. The class provides multiple levels of prevew detail that can be selected individually
nvidia::apex::BasicFSAsset | BasicFS Asset class
nvidia::apex::BasicFSAssetAuthoring | BasicFS Asset Authoring class
nvidia::apex::JetFSActor | JetFS Actor class
nvidia::apex::JetFSPreview | This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually
nvidia::apex::ModuleBasicFS | BasicFS module class
nvidia::apex::NoiseFSActor | JetFS Actor class
nvidia::apex::NoiseFSPreview | This class provides the asset preview for APEX NoiseFS Assets. The class provides multiple levels of prevew detail that can be selected individually
nvidia::apex::VortexFSActor | VortexFS Actor class
nvidia::apex::VortexFSPreview | This class provides the asset preview for APEX VortexFS Assets. The class provides multiple levels of prevew detail that can be selected individually
nvidia::apex::WindFSActor | WindFS Actor class
nvidia::apex::WindFSPreview | This class provides the asset preview for APEX WindFS Assets. The class provides multiple levels of prevew detail that can be selected individually
Generated on Sat Dec 1 2018 10:18:17

Copyright © 2012-2018 NVIDIA Corporation, 2701 San Tomas Expressway, Santa Clara, CA 95050 U.S.A. All rights reserved.


APEX BasicFS Module: nvidia::apex::AttractorFSActor Class Reference

  • Files
  • Class List
  • Class Members
  • nvidia
  • apex
  • AttractorFSActor
Public Member Functions | Protected Member Functions
nvidia::apex::AttractorFSActor Class Reference

AttractorFS Actor class. More...

#include <AttractorFSActor.h>

List of all members.

Public Member Functions

virtual BasicFSAsset * | getAttractorFSAsset () const =0
Returns the asset the instance has been created from.
virtual PxVec3 | getCurrentPosition () const =0
Gets the current position of the actor.
virtual void | setCurrentPosition (const PxVec3 &pos)=0
Sets the current position of the actor.
virtual void | setFieldRadius (float)=0
Sets the attracting radius of the field.
virtual void | setConstFieldStrength (float)=0
Sets strength of the constant part of attracting field.
virtual void | setVariableFieldStrength (float)=0
Sets strength coefficient for variable part of attracting field.
virtual void | setEnabled (bool isEnabled)=0
Enable/Disable the field simulation.
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.

Protected Member Functions

virtual | ~AttractorFSActor ()

Detailed Description

AttractorFS Actor class.

Constructor & Destructor Documentation

virtual nvidia::apex::AttractorFSActor::~AttractorFSActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual BasicFSAsset* nvidia::apex::AttractorFSActor::getAttractorFSAsset ( ) const [pure virtual]

Returns the asset the instance has been created from.

virtual PxVec3 nvidia::apex::AttractorFSActor::getCurrentPosition ( ) const [pure virtual]

Gets the current position of the actor.

virtual float nvidia::apex::AttractorFSActor::getCurrentScale ( void ) const [pure virtual]

Retrieves the uniform overall object scale.

virtual void nvidia::apex::AttractorFSActor::setConstFieldStrength ( float ) [pure virtual]

Sets strength of the constant part of attracting field.

virtual void nvidia::apex::AttractorFSActor::setCurrentPosition ( const PxVec3 & pos ) [pure virtual]

Sets the current position of the actor.

virtual void nvidia::apex::AttractorFSActor::setCurrentScale ( float scale ) [pure virtual]

Sets the uniform overall object scale.

virtual void nvidia::apex::AttractorFSActor::setEnabled ( bool isEnabled ) [pure virtual]

Enable/Disable the field simulation.

virtual void nvidia::apex::AttractorFSActor::setFieldRadius ( float ) [pure virtual]

Sets the attracting radius of the field.

virtual void nvidia::apex::AttractorFSActor::setVariableFieldStrength ( float ) [pure virtual]

Sets strength coefficient for variable part of attracting field.

The documentation for this class was generated from the following file:
  • AttractorFSActor.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::AttractorFSPreview Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • AttractorFSPreview
Public Member Functions
nvidia::apex::AttractorFSPreview Class Reference

This class provides the asset preview for APEX AttractorFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

#include <AttractorFSPreview.h>

List of all members.

Public Member Functions

virtual void | setRadius (float radius)=0
Set the radius of the attractor.
virtual void | setDetailLevel (uint32_t detail)=0

Detailed Description

This class provides the asset preview for APEX AttractorFS Assets. The class provides multiple levels of prevew detail that can be selected individually.

Member Function Documentation

virtual void nvidia::apex::AttractorFSPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable.
Any, all, or none of the following masks may be added together to select what should be drawn.
The defines for the individual items are:
ATTRACT_DRAW_NOTHING - draw nothing
ATTRACT_DRAW_SHAPE - draw the shape
ATTRACT_DRAW_ASSET_INFO - draw the turbulencefs asset info in the screen space
ATTRACT_DRAW_FULL_DETAIL - draw all components of the turbulencefs preview
All items may be drawn using the macro DRAW_FULL_DETAIL.

virtual void nvidia::apex::AttractorFSPreview::setRadius ( float radius ) [pure virtual]

Set the radius of the attractor.

The documentation for this class was generated from the following file:
  • AttractorFSPreview.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::BasicFSAsset Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • BasicFSAsset
Protected Member Functions
nvidia::apex::BasicFSAsset Class Reference

BasicFS Asset class. More...

#include <BasicFSAsset.h>

List of all members.

Protected Member Functions

virtual ~BasicFSAsset ()

Detailed Description

BasicFS Asset class.

Constructor & Destructor Documentation

virtual nvidia::apex::BasicFSAsset::~BasicFSAsset ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • BasicFSAsset.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::BasicFSAssetAuthoring Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • BasicFSAssetAuthoring
Protected Member Functions
nvidia::apex::BasicFSAssetAuthoring Class Reference

BasicFS Asset Authoring class. More...

#include <BasicFSAsset.h>

List of all members.

Protected Member Functions

virtual ~BasicFSAssetAuthoring ()

Detailed Description

BasicFS Asset Authoring class.

Constructor & Destructor Documentation

virtual nvidia::apex::BasicFSAssetAuthoring::~BasicFSAssetAuthoring ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • BasicFSAsset.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::JetFSActor Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • JetFSActor
Public Member Functions | Protected Member Functions
nvidia::apex::JetFSActor Class Reference

JetFS Actor class. More...

#include <JetFSActor.h>

List of all members.

Public Member Functions

virtual BasicFSAsset * | getJetFSAsset () const =0
Returns the asset the instance has been created from.
virtual PxMat44 | getCurrentPose () const =0
Gets the current pose of the actor.
virtual void | setCurrentPose (const PxTransform &pose)=0
Sets the current pose of the actor.
virtual PxVec3 | getCurrentPosition () const =0
Gets the current position of the actor.
virtual void | setCurrentPosition (const PxVec3 &pos)=0
Sets the current position of the actor.
virtual float | getCurrentScale () const =0
Gets the current scale of the actor.
virtual void | setCurrentScale (const float &scale)=0
Sets the current scale of the actor.
virtual void | setFieldStrength (float)=0
Sets the field strength.
virtual void | setFieldDirection (const PxVec3 &)=0
Sets the field direction.
virtual void | setEnabled (bool isEnabled)=0
Enable/Disable the field simulation.

Protected Member Functions

virtual | ~JetFSActor ()

Detailed Description

JetFS Actor class.

Constructor & Destructor Documentation

virtual nvidia::apex::JetFSActor::~JetFSActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual PxMat44 nvidia::apex::JetFSActor::getCurrentPose ( ) const [pure virtual]

Gets the current pose of the actor.

virtual PxVec3 nvidia::apex::JetFSActor::getCurrentPosition ( ) const [pure virtual]

Gets the current position of the actor.

virtual float nvidia::apex::JetFSActor::getCurrentScale ( ) const [pure virtual]

Gets the current scale of the actor.

virtual BasicFSAsset* nvidia::apex::JetFSActor::getJetFSAsset ( ) const [pure virtual]

Returns the asset the instance has been created from.

virtual void nvidia::apex::JetFSActor::setCurrentPose ( const PxTransform & pose ) [pure virtual]

Sets the current pose of the actor.

virtual void nvidia::apex::JetFSActor::setCurrentPosition ( const PxVec3 & pos ) [pure virtual]

Sets the current position of the actor.

virtual void nvidia::apex::JetFSActor::setCurrentScale ( const float & scale ) [pure virtual]

Sets the current scale of the actor.

virtual void nvidia::apex::JetFSActor::setEnabled ( bool isEnabled ) [pure virtual]

Enable/Disable the field simulation.

virtual void nvidia::apex::JetFSActor::setFieldDirection ( const PxVec3 & ) [pure virtual]

Sets the field direction.

virtual void nvidia::apex::JetFSActor::setFieldStrength ( float ) [pure virtual]

Sets the field strength.

The documentation for this class was generated from the following file:
  • JetFSActor.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::JetFSPreview Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • JetFSPreview
Public Member Functions
nvidia::apex::JetFSPreview Class Reference

This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

#include <JetFSPreview.h>

List of all members.

Public Member Functions

virtual void setDetailLevel (uint32_t detail)=0

Detailed Description

This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually.

Member Function Documentation

virtual void nvidia::apex::JetFSPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable.
Any, all, or none of the following masks may be added together to select what should be drawn.
The defines for the individual items are:
JET_DRAW_NOTHING - draw nothing
JET_DRAW_SHAPE - draw the shape
JET_DRAW_ASSET_INFO - draw the turbulencefs asset info in the screen space
JET_DRAW_FULL_DETAIL - draw all components of the turbulencefs preview
All items may be drawn using the macro DRAW_FULL_DETAIL.

The documentation for this class was generated from the following file:
  • JetFSPreview.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::ModuleBasicFS Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • ModuleBasicFS
Protected Member Functions
nvidia::apex::ModuleBasicFS Class Reference

BasicFS module class. More...

#include <ModuleBasicFS.h>

List of all members.

Protected Member Functions

virtual ~ModuleBasicFS ()

Detailed Description

BasicFS module class.

Constructor & Destructor Documentation

virtual nvidia::apex::ModuleBasicFS::~ModuleBasicFS ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • ModuleBasicFS.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::NoiseFSActor Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • NoiseFSActor
Public Member Functions | Protected Member Functions
nvidia::apex::NoiseFSActor Class Reference

JetFS Actor class. More...

#include <NoiseFSActor.h>

List of all members.

Public Member Functions

virtual BasicFSAsset * | getNoiseFSAsset () const =0
Returns the asset the instance has been created from.
virtual PxMat44 | getCurrentPose () const =0
Gets the current pose of the actor.
virtual void | setCurrentPose (const PxTransform &pose)=0
Sets the current pose of the actor.
virtual PxVec3 | getCurrentPosition () const =0
Gets the current position of the actor.
virtual void | setCurrentPosition (const PxVec3 &pos)=0
Sets the current position of the actor.
virtual float | getCurrentScale () const =0
Gets the current scale of the actor.
virtual void | setCurrentScale (const float &scale)=0
Sets the current scale of the actor.
virtual void | setNoiseStrength (float)=0
Sets the noise strength.
virtual void | setEnabled (bool isEnabled)=0
Enable/Disable the field simulation.

Protected Member Functions

virtual | ~NoiseFSActor ()

Detailed Description

JetFS Actor class.

Constructor & Destructor Documentation

virtual nvidia::apex::NoiseFSActor::~NoiseFSActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual PxMat44 nvidia::apex::NoiseFSActor::getCurrentPose ( ) const [pure virtual]

Gets the current pose of the actor.

virtual PxVec3 nvidia::apex::NoiseFSActor::getCurrentPosition ( ) const [pure virtual]

Gets the current position of the actor.

virtual float nvidia::apex::NoiseFSActor::getCurrentScale ( ) const [pure virtual]

Gets the current scale of the actor.

virtual BasicFSAsset* nvidia::apex::NoiseFSActor::getNoiseFSAsset ( ) const [pure virtual]

Returns the asset the instance has been created from.

virtual void nvidia::apex::NoiseFSActor::setCurrentPose ( const PxTransform & pose ) [pure virtual]

Sets the current pose of the actor.

virtual void nvidia::apex::NoiseFSActor::setCurrentPosition ( const PxVec3 & pos ) [pure virtual]

Sets the current position of the actor.

virtual void nvidia::apex::NoiseFSActor::setCurrentScale ( const float & scale ) [pure virtual]

Sets the current scale of the actor.

virtual void nvidia::apex::NoiseFSActor::setEnabled ( bool isEnabled ) [pure virtual]

Enable/Disable the field simulation.

virtual void nvidia::apex::NoiseFSActor::setNoiseStrength ( float ) [pure virtual]

Sets the noise strength.

The documentation for this class was generated from the following file:
  • NoiseFSActor.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::NoiseFSPreview Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • NoiseFSPreview
Public Member Functions
nvidia::apex::NoiseFSPreview Class Reference

This class provides the asset preview for APEX NoiseFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

#include <NoiseFSPreview.h>

List of all members.

Public Member Functions

virtual void setDetailLevel (uint32_t detail)=0

Detailed Description

This class provides the asset preview for APEX NoiseFS Assets. The class provides multiple levels of prevew detail that can be selected individually.

Member Function Documentation

virtual void nvidia::apex::NoiseFSPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable.
Any, all, or none of the following masks may be added together to select what should be drawn.
The defines for the individual items are:
NOISE_DRAW_NOTHING - draw nothing
NOISE_DRAW_SHAPE - draw the shape
NOISE_DRAW_ASSET_INFO - draw the asset info in the screen space
NOISE_DRAW_FULL_DETAIL - draw all components of the asset preview
All items may be drawn using the macro DRAW_FULL_DETAIL.

The documentation for this class was generated from the following file:
  • NoiseFSPreview.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::VortexFSActor Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • VortexFSActor
Public Member Functions | Protected Member Functions
nvidia::apex::VortexFSActor Class Reference

VortexFS Actor class. More...

#include <VortexFSActor.h>

List of all members.

Public Member Functions

virtual BasicFSAsset * | getVortexFSAsset () const =0
Returns the asset the instance has been created from.
virtual PxMat44 | getCurrentPose () const =0
Gets the current pose of the actor.
virtual void | setCurrentPose (const PxTransform &pose)=0
Sets the current pose of the actor.
virtual PxVec3 | getCurrentPosition () const =0
Gets the current position of the actor.
virtual void | setCurrentPosition (const PxVec3 &pos)=0
Sets the current position of the actor.
virtual void | setAxis (const PxVec3 &)=0
Sets the axis of the capsule in local coordinate system.
virtual void | setHeight (float)=0
Sets the height of the capsule.
virtual void | setBottomRadius (float)=0
Sets the bottom radius of the capsule.
virtual void | setTopRadius (float)=0
Sets the top radius of the capsule.
virtual void | setBottomSphericalForce (bool)=0
Sets the bottom spherical force of the capsule.
virtual void | setTopSphericalForce (bool)=0
Sets the top spherical force of the capsule.
virtual void | setRotationalStrength (float)=0
Sets strength of the rotational part of vortex field.
virtual void | setRadialStrength (float)=0
Sets strength of the radial part of vortex field.
virtual void | setLiftStrength (float)=0
Sets strength of the lifting part of vortex field.
virtual void | setEnabled (bool isEnabled)=0
Enable/Disable the field simulation.
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.

Protected Member Functions

virtual | ~VortexFSActor ()

Detailed Description

VortexFS Actor class.

Constructor & Destructor Documentation

virtual nvidia::apex::VortexFSActor::~VortexFSActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual PxMat44 nvidia::apex::VortexFSActor::getCurrentPose ( ) const [pure virtual]

Gets the current pose of the actor.

virtual PxVec3 nvidia::apex::VortexFSActor::getCurrentPosition ( ) const [pure virtual]

Gets the current position of the actor.

virtual float nvidia::apex::VortexFSActor::getCurrentScale ( void ) const [pure virtual]

Retrieves the uniform overall object scale.

virtual BasicFSAsset* nvidia::apex::VortexFSActor::getVortexFSAsset ( ) const [pure virtual]

Returns the asset the instance has been created from.

virtual void nvidia::apex::VortexFSActor::setAxis ( const PxVec3 & ) [pure virtual]

Sets the axis of the capsule in local coordinate system.

virtual void nvidia::apex::VortexFSActor::setBottomRadius ( float ) [pure virtual]

Sets the bottom radius of the capsule.

virtual void nvidia::apex::VortexFSActor::setBottomSphericalForce ( bool ) [pure virtual]

Sets the bottom spherical force of the capsule.

virtual void nvidia::apex::VortexFSActor::setCurrentPose ( const PxTransform & pose ) [pure virtual]

Sets the current pose of the actor.

virtual void nvidia::apex::VortexFSActor::setCurrentPosition ( const PxVec3 & pos ) [pure virtual]

Sets the current position of the actor.

virtual void nvidia::apex::VortexFSActor::setCurrentScale ( float scale ) [pure virtual]

Sets the uniform overall object scale.

virtual void nvidia::apex::VortexFSActor::setEnabled ( bool isEnabled ) [pure virtual]

Enable/Disable the field simulation.

virtual void nvidia::apex::VortexFSActor::setHeight ( float ) [pure virtual]

Sets the height of the capsule.

virtual void nvidia::apex::VortexFSActor::setLiftStrength ( float ) [pure virtual]

Sets strength of the lifting part of vortex field.

virtual void nvidia::apex::VortexFSActor::setRadialStrength ( float ) [pure virtual]

Sets strength of the radial part of vortex field.

virtual void nvidia::apex::VortexFSActor::setRotationalStrength ( float ) [pure virtual]

Sets strength of the rotational part of vortex field.

virtual void nvidia::apex::VortexFSActor::setTopRadius ( float ) [pure virtual]

Sets the top radius of the capsule.

virtual void nvidia::apex::VortexFSActor::setTopSphericalForce ( bool ) [pure virtual]

Sets the top spherical force of the capsule.

The documentation for this class was generated from the following file:
  • VortexFSActor.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::VortexFSPreview Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • VortexFSPreview
Public Member Functions
nvidia::apex::VortexFSPreview Class Reference

This class provides the asset preview for APEX VortexFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

#include <VortexFSPreview.h>

List of all members.

Public Member Functions

virtual void | setRadius (float radius)=0
Set the radius of the vortex.
virtual void | setDetailLevel (uint32_t detail)=0

Detailed Description

This class provides the asset preview for APEX VortexFS Assets. The class provides multiple levels of prevew detail that can be selected individually.

Member Function Documentation

virtual void nvidia::apex::VortexFSPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable.
Any, all, or none of the following masks may be added together to select what should be drawn.
The defines for the individual items are:
VORTEX_DRAW_NOTHING - draw nothing
VORTEX_DRAW_SHAPE - draw the shape
VORTEX_DRAW_ASSET_INFO - draw the turbulencefs asset info in the screen space
VORTEX_DRAW_FULL_DETAIL - draw all components of the turbulencefs preview
All items may be drawn using the macro DRAW_FULL_DETAIL.

virtual void nvidia::apex::VortexFSPreview::setRadius ( float radius ) [pure virtual]

Set the radius of the vortex.

The documentation for this class was generated from the following file:
  • VortexFSPreview.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::WindFSActor Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • WindFSActor
Public Member Functions | Protected Member Functions
nvidia::apex::WindFSActor Class Reference

WindFS Actor class. More...

#include <WindFSActor.h>

List of all members.

Public Member Functions

virtual BasicFSAsset * | getWindFSAsset () const =0
Returns the asset the instance has been created from.
virtual PxMat44 | getCurrentPose () const =0
Gets the current pose of the actor.
virtual void | setCurrentPose (const PxTransform &pose)=0
Sets the current pose of the actor.
virtual PxVec3 | getCurrentPosition () const =0
Gets the current position of the actor.
virtual void | setCurrentPosition (const PxVec3 &pos)=0
Sets the current position of the actor.
virtual void | setFieldStrength (float)=0
Sets the field strength.
virtual void | setFieldDirection (const PxVec3 &)=0
Sets the field direction.
virtual void | setEnabled (bool isEnabled)=0
Enable/Disable the field simulation.
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.

Protected Member Functions

virtual | ~WindFSActor ()

Detailed Description

WindFS Actor class.

Constructor & Destructor Documentation

virtual nvidia::apex::WindFSActor::~WindFSActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual PxMat44 nvidia::apex::WindFSActor::getCurrentPose ( ) const [pure virtual]

Gets the current pose of the actor.

virtual PxVec3 nvidia::apex::WindFSActor::getCurrentPosition ( ) const [pure virtual]

Gets the current position of the actor.

virtual float nvidia::apex::WindFSActor::getCurrentScale ( void ) const [pure virtual]

Retrieves the uniform overall object scale.

virtual BasicFSAsset* nvidia::apex::WindFSActor::getWindFSAsset ( ) const [pure virtual]

Returns the asset the instance has been created from.

virtual void nvidia::apex::WindFSActor::setCurrentPose ( const PxTransform & pose ) [pure virtual]

Sets the current pose of the actor.

virtual void nvidia::apex::WindFSActor::setCurrentPosition ( const PxVec3 & pos ) [pure virtual]

Sets the current position of the actor.

virtual void nvidia::apex::WindFSActor::setCurrentScale ( float scale ) [pure virtual]

Sets the uniform overall object scale.

virtual void nvidia::apex::WindFSActor::setEnabled ( bool isEnabled ) [pure virtual]

Enable/Disable the field simulation.

virtual void nvidia::apex::WindFSActor::setFieldDirection ( const PxVec3 & ) [pure virtual]

Sets the field direction.

virtual void nvidia::apex::WindFSActor::setFieldStrength ( float ) [pure virtual]

Sets the field strength.

The documentation for this class was generated from the following file:
  • WindFSActor.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::WindFSPreview Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • WindFSPreview
Public Member Functions
nvidia::apex::WindFSPreview Class Reference

This class provides the asset preview for APEX WindFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

#include <WindFSPreview.h>

List of all members.

Public Member Functions

virtual void setDetailLevel (uint32_t detail)=0

Detailed Description

This class provides the asset preview for APEX WindFS Assets. The class provides multiple levels of prevew detail that can be selected individually.

Member Function Documentation

virtual void nvidia::apex::WindFSPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable.
Any, all, or none of the following masks may be added together to select what should be drawn.
The defines for the individual items are:
WIND_DRAW_NOTHING - draw nothing
WIND_DRAW_ASSET_INFO - draw the asset info in the screen space
WIND_DRAW_FULL_DETAIL - draw all components of the asset preview
All items may be drawn using the macro DRAW_FULL_DETAIL.

The documentation for this class was generated from the following file:
  • WindFSPreview.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Class Index

  • Class List
  • Class Members
Class Index
A | B | J | M | N | V | W
A
BasicFSAsset (nvidia::apex) JetFSPreview (nvidia::apex) NoiseFSActor (nvidia::apex) VortexFSPreview (nvidia::apex)
AttractorFSActor (nvidia::apex) BasicFSAssetAuthoring (nvidia::apex)
M
NoiseFSPreview (nvidia::apex)
W
AttractorFSPreview (nvidia::apex)
J
ModuleBasicFS (nvidia::apex)
V
WindFSActor (nvidia::apex)
B
JetFSActor (nvidia::apex)
N
VortexFSActor (nvidia::apex) WindFSPreview (nvidia::apex)
A | B | J | M | N | V | W
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Class Members

  • Class List
  • Class Members
  • All
  • Functions
  • g
  • s
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • getAttractorFSAsset() : nvidia::apex::AttractorFSActor
  • getCurrentPose()
: nvidia::apex::JetFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::NoiseFSActor
  • getCurrentPosition()
: nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
  • getCurrentScale()
: nvidia::apex::NoiseFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
  • getJetFSAsset() : nvidia::apex::JetFSActor
  • getNoiseFSAsset() : nvidia::apex::NoiseFSActor
  • getVortexFSAsset() : nvidia::apex::VortexFSActor
  • getWindFSAsset() : nvidia::apex::WindFSActor

- s -

  • setAxis() : nvidia::apex::VortexFSActor
  • setBottomRadius() : nvidia::apex::VortexFSActor
  • setBottomSphericalForce() : nvidia::apex::VortexFSActor
  • setConstFieldStrength() : nvidia::apex::AttractorFSActor
  • setCurrentPose()
: nvidia::apex::WindFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
  • setCurrentPosition()
: nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
  • setCurrentScale()
: nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
  • setDetailLevel()
: nvidia::apex::AttractorFSPreview
, nvidia::apex::JetFSPreview
, nvidia::apex::NoiseFSPreview
, nvidia::apex::VortexFSPreview
, nvidia::apex::WindFSPreview
  • setEnabled()
: nvidia::apex::VortexFSActor
, nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::WindFSActor
  • setFieldDirection()
: nvidia::apex::JetFSActor
, nvidia::apex::WindFSActor
  • setFieldRadius() : nvidia::apex::AttractorFSActor
  • setFieldStrength()
: nvidia::apex::WindFSActor
, nvidia::apex::JetFSActor
  • setHeight() : nvidia::apex::VortexFSActor
  • setLiftStrength() : nvidia::apex::VortexFSActor
  • setNoiseStrength() : nvidia::apex::NoiseFSActor
  • setRadialStrength() : nvidia::apex::VortexFSActor
  • setRadius()
: nvidia::apex::AttractorFSPreview
, nvidia::apex::VortexFSPreview
  • setRotationalStrength() : nvidia::apex::VortexFSActor
  • setTopRadius() : nvidia::apex::VortexFSActor
  • setTopSphericalForce() : nvidia::apex::VortexFSActor
  • setVariableFieldStrength() : nvidia::apex::AttractorFSActor

- ~ -

  • ~AttractorFSActor() : nvidia::apex::AttractorFSActor
  • ~BasicFSAsset() : nvidia::apex::BasicFSAsset
  • ~BasicFSAssetAuthoring() : nvidia::apex::BasicFSAssetAuthoring
  • ~JetFSActor() : nvidia::apex::JetFSActor
  • ~ModuleBasicFS() : nvidia::apex::ModuleBasicFS
  • ~NoiseFSActor() : nvidia::apex::NoiseFSActor
  • ~VortexFSActor() : nvidia::apex::VortexFSActor
  • ~WindFSActor() : nvidia::apex::WindFSActor
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Namespace List

  • Namespace List
Namespace List
Here is a list of all namespaces with brief descriptions:
nvidia |
nvidia::apex |
nvidia::apex::APEX_ATTRACT | The APEX_ATTRACT namespace contains the defines for setting the preview detail levels
nvidia::apex::APEX_JET | The APEX_JET namespace contains the defines for setting the preview detail levels
nvidia::apex::APEX_NOISE | The APEX_NOISE namespace contains the defines for setting the preview detail levels
nvidia::apex::APEX_VORTEX | The APEX_VORTEX namespace contains the defines for setting the preview detail levels
nvidia::apex::APEX_WIND | The APEX_WIND namespace contains the defines for setting the preview detail levels
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia Namespace Reference

  • Namespace List
Namespaces
nvidia Namespace Reference

Namespaces

namespace apex
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex Namespace Reference

  • Namespace List
  • nvidia
  • apex
Namespaces | Classes
nvidia::apex Namespace Reference

Namespaces

namespace | APEX_ATTRACT

The APEX_ATTRACT namespace contains the defines for setting the preview detail levels.

namespace | APEX_JET

The APEX_JET namespace contains the defines for setting the preview detail levels.

namespace | APEX_NOISE

The APEX_NOISE namespace contains the defines for setting the preview detail levels.

namespace | APEX_VORTEX

The APEX_VORTEX namespace contains the defines for setting the preview detail levels.

namespace | APEX_WIND

The APEX_WIND namespace contains the defines for setting the preview detail levels.

Classes

class | AttractorFSActor
AttractorFS Actor class. More...
class | AttractorFSPreview
This class provides the asset preview for APEX AttractorFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...
class | BasicFSAsset
BasicFS Asset class. More...
class | BasicFSAssetAuthoring
BasicFS Asset Authoring class. More...
class | JetFSActor
JetFS Actor class. More...
class | JetFSPreview
This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...
class | ModuleBasicFS
BasicFS module class. More...
class | NoiseFSActor
JetFS Actor class. More...
class | NoiseFSPreview
This class provides the asset preview for APEX NoiseFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...
class | VortexFSActor
VortexFS Actor class. More...
class | VortexFSPreview
This class provides the asset preview for APEX VortexFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...
class | WindFSActor
WindFS Actor class. More...
class | WindFSPreview
This class provides the asset preview for APEX WindFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::APEX_ATTRACT Namespace Reference

  • Namespace List
  • nvidia
  • apex
  • APEX_ATTRACT
nvidia::apex::APEX_ATTRACT Namespace Reference

The APEX_ATTRACT namespace contains the defines for setting the preview detail levels. More...

Detailed Description

The APEX_ATTRACT namespace contains the defines for setting the preview detail levels.

ATTRACT_DRAW_NOTHING - draw nothing
ATTRACT_DRAW_SHAPE - draw the attractor shape
ATTRACT_DRAW_ASSET_INFO - draw the asset info in the screen space
ATTRACT_DRAW_FULL_DETAIL - draw all components of the preview

Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::APEX_JET Namespace Reference

  • Namespace List
  • nvidia
  • apex
  • APEX_JET
nvidia::apex::APEX_JET Namespace Reference

The APEX_JET namespace contains the defines for setting the preview detail levels. More...

Detailed Description

The APEX_JET namespace contains the defines for setting the preview detail levels.

JET_DRAW_NOTHING - draw nothing
JET_DRAW_SHAPE - draw the shape
JET_DRAW_ASSET_INFO - draw the asset info in the screen space
JET_DRAW_FULL_DETAIL - draw all components of the preview

Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::APEX_NOISE Namespace Reference

  • Namespace List
  • nvidia
  • apex
  • APEX_NOISE
nvidia::apex::APEX_NOISE Namespace Reference

The APEX_NOISE namespace contains the defines for setting the preview detail levels. More...

Detailed Description

The APEX_NOISE namespace contains the defines for setting the preview detail levels.

NOISE_DRAW_NOTHING - draw nothing
NOISE_DRAW_SHAPE - draw the shape
NOISE_DRAW_ASSET_INFO - draw the asset info in the screen space
NOISE_DRAW_FULL_DETAIL - draw all components of the preview

Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::APEX_VORTEX Namespace Reference

  • Namespace List
  • nvidia
  • apex
  • APEX_VORTEX
nvidia::apex::APEX_VORTEX Namespace Reference

The APEX_VORTEX namespace contains the defines for setting the preview detail levels. More...

Detailed Description

The APEX_VORTEX namespace contains the defines for setting the preview detail levels.

VORTEX_DRAW_NOTHING - draw nothing
VORTEX_DRAW_SHAPE - draw the Vortex shape
VORTEX_DRAW_ASSET_INFO - draw the asset info in the screen space
VORTEX_DRAW_FULL_DETAIL - draw all components of the preview

Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: nvidia::apex::APEX_WIND Namespace Reference

  • Namespace List
  • nvidia
  • apex
  • APEX_WIND
nvidia::apex::APEX_WIND Namespace Reference

The APEX_WIND namespace contains the defines for setting the preview detail levels. More...

Detailed Description

The APEX_WIND namespace contains the defines for setting the preview detail levels.

WIND_DRAW_NOTHING - draw nothing
WIND_DRAW_ASSET_INFO - draw the asset info in the screen space
WIND_DRAW_FULL_DETAIL - draw all components of the preview

Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
AttractorFSActor.h [code]
AttractorFSPreview.h [code]
BasicFSAsset.h [code]
JetFSActor.h [code]
JetFSPreview.h [code]
ModuleBasicFS.h [code]
NoiseFSActor.h [code]
NoiseFSPreview.h [code]
VortexFSActor.h [code]
VortexFSPreview.h [code]
WindFSActor.h [code]
WindFSPreview.h [code]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: AttractorFSActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
AttractorFSActor.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::AttractorFSActor
AttractorFS Actor class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: AttractorFSPreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
AttractorFSPreview.h File Reference
#include "Apex.h"
#include "AssetPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::AttractorFSPreview
This class provides the asset preview for APEX AttractorFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
namespace | nvidia::apex::APEX_ATTRACT

The APEX_ATTRACT namespace contains the defines for setting the preview detail levels.

Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: BasicFSAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
BasicFSAsset.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::BasicFSAsset
BasicFS Asset class. More...
class | nvidia::apex::BasicFSAssetAuthoring
BasicFS Asset Authoring class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | JET_FS_AUTHORING_TYPE_NAME "JetFSAsset"
#define | ATTRACTOR_FS_AUTHORING_TYPE_NAME "AttractorFSAsset"
#define | VORTEX_FS_AUTHORING_TYPE_NAME "VortexFSAsset"
#define | NOISE_FS_AUTHORING_TYPE_NAME "NoiseFSAsset"
#define | WIND_FS_AUTHORING_TYPE_NAME "WindFSAsset"

Define Documentation

#define ATTRACTOR_FS_AUTHORING_TYPE_NAME "AttractorFSAsset"
#define JET_FS_AUTHORING_TYPE_NAME "JetFSAsset"
#define NOISE_FS_AUTHORING_TYPE_NAME "NoiseFSAsset"
#define VORTEX_FS_AUTHORING_TYPE_NAME "VortexFSAsset"
#define WIND_FS_AUTHORING_TYPE_NAME "WindFSAsset"
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: JetFSActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
JetFSActor.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::JetFSActor
JetFS Actor class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: JetFSPreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
JetFSPreview.h File Reference
#include "Apex.h"
#include "AssetPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::JetFSPreview
This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
namespace | nvidia::apex::APEX_JET

The APEX_JET namespace contains the defines for setting the preview detail levels.

Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: ModuleBasicFS.h File Reference

  • File List
  • File Members
Classes | Namespaces
ModuleBasicFS.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ModuleBasicFS
BasicFS module class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: NoiseFSActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
NoiseFSActor.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::NoiseFSActor
JetFS Actor class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: NoiseFSPreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
NoiseFSPreview.h File Reference
#include "Apex.h"
#include "AssetPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::NoiseFSPreview
This class provides the asset preview for APEX NoiseFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
namespace | nvidia::apex::APEX_NOISE

The APEX_NOISE namespace contains the defines for setting the preview detail levels.

Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: VortexFSActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
VortexFSActor.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::VortexFSActor
VortexFS Actor class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: VortexFSPreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
VortexFSPreview.h File Reference
#include "Apex.h"
#include "AssetPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::VortexFSPreview
This class provides the asset preview for APEX VortexFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
namespace | nvidia::apex::APEX_VORTEX

The APEX_VORTEX namespace contains the defines for setting the preview detail levels.

Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: WindFSActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
WindFSActor.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::WindFSActor
WindFS Actor class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: WindFSPreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
WindFSPreview.h File Reference
#include "Apex.h"
#include "AssetPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::WindFSPreview
This class provides the asset preview for APEX WindFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
namespace | nvidia::apex::APEX_WIND

The APEX_WIND namespace contains the defines for setting the preview detail levels.

Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: File Members

  • File List
  • File Members
  • All
  • Defines
Here is a list of all file members with links to the files they belong to:
  • ATTRACTOR_FS_AUTHORING_TYPE_NAME : BasicFSAsset.h
  • JET_FS_AUTHORING_TYPE_NAME : BasicFSAsset.h
  • NOISE_FS_AUTHORING_TYPE_NAME : BasicFSAsset.h
  • VORTEX_FS_AUTHORING_TYPE_NAME : BasicFSAsset.h
  • WIND_FS_AUTHORING_TYPE_NAME : BasicFSAsset.h
Generated on Sat Dec 1 2018 10:18:17


Navigation

  • next
  • NVIDIA APEX Documentation »

NVIDIA(R) APEX(TM) SDK Documentation (APEX SDK has been deprecated)

Note: APEX SDK has been deprecated

(NVIDIA(R) PhysX(R) SDK 3.X)

Contents:

  • APEX Framework
    • APEX Programmers Guide
    • ParamTool
    • API
  • APEX Clothing Module
    • Module Documentation
    • Programmers Guide
    • Clothing Tool
    • API
  • APEX Destruction Module
    • Destruction Introduction
    • Destruction Authoring with PhysXLab
    • FractureTool
    • API
  • APEX Particles Module
    • Note
    • Users Guide
    • Programmers Guide
    • Examples
    • API
  • APEX Turbulence Module
    • Turbulence Introduction
    • API
  • APEX ForceField Module
    • Force Field Introduction
    • API
  • APEX 1.3 to 1.4 Migration Guide
    • General
  • NVIDIA Copyright Notice

APEX NvParameterized Classes

  • Class List

Navigation

  • next
  • NVIDIA APEX Documentation »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


APEX BasicFS Module: AttractorFSActor.h Source File

  • File List
  • File Members
AttractorFSActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef ATTRACTOR_FSACTOR_H
00031 #define ATTRACTOR_FSACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class BasicFSAsset;
00043
00044
00048 class AttractorFSActor : public Actor, public Renderable
00049 {
00050 protected:
00051     virtual ~AttractorFSActor() {}
00052
00053 public:
00057     virtual BasicFSAsset*       getAttractorFSAsset() const = 0;
00058
00062     virtual PxVec3              getCurrentPosition() const = 0;
00063
00067     virtual void                setCurrentPosition(const PxVec3& pos) = 0;
00068
00072     virtual void                setFieldRadius(float) = 0;
00073
00077     virtual void                setConstFieldStrength(float) = 0;
00078
00082     virtual void                setVariableFieldStrength(float) = 0;
00083
00087     virtual void                setEnabled(bool isEnabled) = 0;
00088
00092     virtual void                setCurrentScale(float scale) = 0;
00093
00097     virtual float               getCurrentScale(void) const = 0;
00098
00099 };
00100
00101 PX_POP_PACK
00102
00103 }
00104 } // end namespace nvidia::apex
00105
00106 #endif // ATTRACTOR_FSACTOR_H
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: AttractorFSPreview.h Source File

  • File List
  • File Members
AttractorFSPreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef ATTRACTOR_FSPREVIEW_H
00030 #define ATTRACTOR_FSPREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class RenderDebugInterface;
00043
00052 namespace APEX_ATTRACT
00053 {
00058 static const uint32_t ATTRACT_DRAW_NOTHING = 0x00;
00063 static const uint32_t ATTRACT_DRAW_SHAPE = 0x01;
00070 static const uint32_t ATTRACT_DRAW_ASSET_INFO = 0x02;
00075 static const uint32_t ATTRACT_DRAW_FULL_DETAIL = (ATTRACT_DRAW_SHAPE + ATTRACT_DRAW_ASSET_INFO);
00076 }
00077
00082 class AttractorFSPreview : public AssetPreview
00083 {
00084 public:
00088     virtual void    setRadius(float radius) = 0;
00089
00100     virtual void    setDetailLevel(uint32_t detail) = 0;
00101 };
00102
00103
00104 PX_POP_PACK
00105
00106 }
00107 } // namespace nvidia
00108
00109 #endif // ATTRACTOR_FS_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: BasicFSAsset.h Source File

  • File List
  • File Members
BasicFSAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef BASIC_FSASSET_H
00030 #define BASIC_FSASSET_H
00031
00032 #include "Apex.h"
00033
00034 namespace nvidia
00035 {
00036 namespace apex
00037 {
00038
00039 PX_PUSH_PACK_DEFAULT
00040
00041 #define JET_FS_AUTHORING_TYPE_NAME  "JetFSAsset"
00042 #define ATTRACTOR_FS_AUTHORING_TYPE_NAME    "AttractorFSAsset"
00043 #define VORTEX_FS_AUTHORING_TYPE_NAME   "VortexFSAsset"
00044 #define NOISE_FS_AUTHORING_TYPE_NAME "NoiseFSAsset"
00045 #define WIND_FS_AUTHORING_TYPE_NAME "WindFSAsset"
00046
00050 class BasicFSAsset : public Asset
00051 {
00052 protected:
00053     virtual ~BasicFSAsset() {}
00054
00055 public:
00056 };
00057
00061 class BasicFSAssetAuthoring : public AssetAuthoring
00062 {
00063 protected:
00064     virtual ~BasicFSAssetAuthoring() {}
00065
00066 public:
00067 };
00068
00069
00070 PX_POP_PACK
00071
00072 }
00073 } // end namespace nvidia::apex
00074
00075 #endif // BASIC_FSASSET_H
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • AttractorFSActor
nvidia::apex::AttractorFSActor Member List
This is the complete list of members for nvidia::apex::AttractorFSActor, including all inherited members.
getAttractorFSAsset() const =0 | nvidia::apex::AttractorFSActor | [pure virtual]
getCurrentPosition() const =0 | nvidia::apex::AttractorFSActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::AttractorFSActor | [pure virtual]
setConstFieldStrength(float)=0 | nvidia::apex::AttractorFSActor | [pure virtual]
setCurrentPosition(const PxVec3 &pos)=0 | nvidia::apex::AttractorFSActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::AttractorFSActor | [pure virtual]
setEnabled(bool isEnabled)=0 | nvidia::apex::AttractorFSActor | [pure virtual]
setFieldRadius(float)=0 | nvidia::apex::AttractorFSActor | [pure virtual]
setVariableFieldStrength(float)=0 | nvidia::apex::AttractorFSActor | [pure virtual]
~AttractorFSActor() | nvidia::apex::AttractorFSActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • AttractorFSPreview
nvidia::apex::AttractorFSPreview Member List
This is the complete list of members for nvidia::apex::AttractorFSPreview, including all inherited members.
setDetailLevel(uint32_t detail)=0 | nvidia::apex::AttractorFSPreview | [pure virtual]
setRadius(float radius)=0 | nvidia::apex::AttractorFSPreview | [pure virtual]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • BasicFSAsset
nvidia::apex::BasicFSAsset Member List
This is the complete list of members for nvidia::apex::BasicFSAsset, including all inherited members.
~BasicFSAsset() nvidia::apex::BasicFSAsset [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • BasicFSAssetAuthoring
nvidia::apex::BasicFSAssetAuthoring Member List
This is the complete list of members for nvidia::apex::BasicFSAssetAuthoring, including all inherited members.
~BasicFSAssetAuthoring() nvidia::apex::BasicFSAssetAuthoring [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • JetFSActor
nvidia::apex::JetFSActor Member List
This is the complete list of members for nvidia::apex::JetFSActor, including all inherited members.
getCurrentPose() const =0 | nvidia::apex::JetFSActor | [pure virtual]
getCurrentPosition() const =0 | nvidia::apex::JetFSActor | [pure virtual]
getCurrentScale() const =0 | nvidia::apex::JetFSActor | [pure virtual]
getJetFSAsset() const =0 | nvidia::apex::JetFSActor | [pure virtual]
setCurrentPose(const PxTransform &pose)=0 | nvidia::apex::JetFSActor | [pure virtual]
setCurrentPosition(const PxVec3 &pos)=0 | nvidia::apex::JetFSActor | [pure virtual]
setCurrentScale(const float &scale)=0 | nvidia::apex::JetFSActor | [pure virtual]
setEnabled(bool isEnabled)=0 | nvidia::apex::JetFSActor | [pure virtual]
setFieldDirection(const PxVec3 &)=0 | nvidia::apex::JetFSActor | [pure virtual]
setFieldStrength(float)=0 | nvidia::apex::JetFSActor | [pure virtual]
~JetFSActor() | nvidia::apex::JetFSActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • JetFSPreview
nvidia::apex::JetFSPreview Member List
This is the complete list of members for nvidia::apex::JetFSPreview, including all inherited members.
setDetailLevel(uint32_t detail)=0 nvidia::apex::JetFSPreview [pure virtual]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • ModuleBasicFS
nvidia::apex::ModuleBasicFS Member List
This is the complete list of members for nvidia::apex::ModuleBasicFS, including all inherited members.
~ModuleBasicFS() nvidia::apex::ModuleBasicFS [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • NoiseFSActor
nvidia::apex::NoiseFSActor Member List
This is the complete list of members for nvidia::apex::NoiseFSActor, including all inherited members.
getCurrentPose() const =0 | nvidia::apex::NoiseFSActor | [pure virtual]
getCurrentPosition() const =0 | nvidia::apex::NoiseFSActor | [pure virtual]
getCurrentScale() const =0 | nvidia::apex::NoiseFSActor | [pure virtual]
getNoiseFSAsset() const =0 | nvidia::apex::NoiseFSActor | [pure virtual]
setCurrentPose(const PxTransform &pose)=0 | nvidia::apex::NoiseFSActor | [pure virtual]
setCurrentPosition(const PxVec3 &pos)=0 | nvidia::apex::NoiseFSActor | [pure virtual]
setCurrentScale(const float &scale)=0 | nvidia::apex::NoiseFSActor | [pure virtual]
setEnabled(bool isEnabled)=0 | nvidia::apex::NoiseFSActor | [pure virtual]
setNoiseStrength(float)=0 | nvidia::apex::NoiseFSActor | [pure virtual]
~NoiseFSActor() | nvidia::apex::NoiseFSActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • NoiseFSPreview
nvidia::apex::NoiseFSPreview Member List
This is the complete list of members for nvidia::apex::NoiseFSPreview, including all inherited members.
setDetailLevel(uint32_t detail)=0 nvidia::apex::NoiseFSPreview [pure virtual]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • VortexFSActor
nvidia::apex::VortexFSActor Member List
This is the complete list of members for nvidia::apex::VortexFSActor, including all inherited members.
getCurrentPose() const =0 | nvidia::apex::VortexFSActor | [pure virtual]
getCurrentPosition() const =0 | nvidia::apex::VortexFSActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::VortexFSActor | [pure virtual]
getVortexFSAsset() const =0 | nvidia::apex::VortexFSActor | [pure virtual]
setAxis(const PxVec3 &)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setBottomRadius(float)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setBottomSphericalForce(bool)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setCurrentPose(const PxTransform &pose)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setCurrentPosition(const PxVec3 &pos)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setEnabled(bool isEnabled)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setHeight(float)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setLiftStrength(float)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setRadialStrength(float)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setRotationalStrength(float)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setTopRadius(float)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setTopSphericalForce(bool)=0 | nvidia::apex::VortexFSActor | [pure virtual]
~VortexFSActor() | nvidia::apex::VortexFSActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • VortexFSPreview
nvidia::apex::VortexFSPreview Member List
This is the complete list of members for nvidia::apex::VortexFSPreview, including all inherited members.
setDetailLevel(uint32_t detail)=0 | nvidia::apex::VortexFSPreview | [pure virtual]
setRadius(float radius)=0 | nvidia::apex::VortexFSPreview | [pure virtual]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • WindFSActor
nvidia::apex::WindFSActor Member List
This is the complete list of members for nvidia::apex::WindFSActor, including all inherited members.
getCurrentPose() const =0 | nvidia::apex::WindFSActor | [pure virtual]
getCurrentPosition() const =0 | nvidia::apex::WindFSActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::WindFSActor | [pure virtual]
getWindFSAsset() const =0 | nvidia::apex::WindFSActor | [pure virtual]
setCurrentPose(const PxTransform &pose)=0 | nvidia::apex::WindFSActor | [pure virtual]
setCurrentPosition(const PxVec3 &pos)=0 | nvidia::apex::WindFSActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::WindFSActor | [pure virtual]
setEnabled(bool isEnabled)=0 | nvidia::apex::WindFSActor | [pure virtual]
setFieldDirection(const PxVec3 &)=0 | nvidia::apex::WindFSActor | [pure virtual]
setFieldStrength(float)=0 | nvidia::apex::WindFSActor | [pure virtual]
~WindFSActor() | nvidia::apex::WindFSActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • WindFSPreview
nvidia::apex::WindFSPreview Member List
This is the complete list of members for nvidia::apex::WindFSPreview, including all inherited members.
setDetailLevel(uint32_t detail)=0 nvidia::apex::WindFSPreview [pure virtual]
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Class Members - Functions

  • Class List
  • Class Members
  • All
  • Functions
  • g
  • s
  • ~

- g -

  • getAttractorFSAsset() : nvidia::apex::AttractorFSActor
  • getCurrentPose()
: nvidia::apex::JetFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::NoiseFSActor
  • getCurrentPosition()
: nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
  • getCurrentScale()
: nvidia::apex::NoiseFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
  • getJetFSAsset() : nvidia::apex::JetFSActor
  • getNoiseFSAsset() : nvidia::apex::NoiseFSActor
  • getVortexFSAsset() : nvidia::apex::VortexFSActor
  • getWindFSAsset() : nvidia::apex::WindFSActor

- s -

  • setAxis() : nvidia::apex::VortexFSActor
  • setBottomRadius() : nvidia::apex::VortexFSActor
  • setBottomSphericalForce() : nvidia::apex::VortexFSActor
  • setConstFieldStrength() : nvidia::apex::AttractorFSActor
  • setCurrentPose()
: nvidia::apex::WindFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
  • setCurrentPosition()
: nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
  • setCurrentScale()
: nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
  • setDetailLevel()
: nvidia::apex::AttractorFSPreview
, nvidia::apex::JetFSPreview
, nvidia::apex::NoiseFSPreview
, nvidia::apex::VortexFSPreview
, nvidia::apex::WindFSPreview
  • setEnabled()
: nvidia::apex::VortexFSActor
, nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::WindFSActor
  • setFieldDirection()
: nvidia::apex::JetFSActor
, nvidia::apex::WindFSActor
  • setFieldRadius() : nvidia::apex::AttractorFSActor
  • setFieldStrength()
: nvidia::apex::WindFSActor
, nvidia::apex::JetFSActor
  • setHeight() : nvidia::apex::VortexFSActor
  • setLiftStrength() : nvidia::apex::VortexFSActor
  • setNoiseStrength() : nvidia::apex::NoiseFSActor
  • setRadialStrength() : nvidia::apex::VortexFSActor
  • setRadius()
: nvidia::apex::AttractorFSPreview
, nvidia::apex::VortexFSPreview
  • setRotationalStrength() : nvidia::apex::VortexFSActor
  • setTopRadius() : nvidia::apex::VortexFSActor
  • setTopSphericalForce() : nvidia::apex::VortexFSActor
  • setVariableFieldStrength() : nvidia::apex::AttractorFSActor

- ~ -

  • ~AttractorFSActor() : nvidia::apex::AttractorFSActor
  • ~BasicFSAsset() : nvidia::apex::BasicFSAsset
  • ~BasicFSAssetAuthoring() : nvidia::apex::BasicFSAssetAuthoring
  • ~JetFSActor() : nvidia::apex::JetFSActor
  • ~ModuleBasicFS() : nvidia::apex::ModuleBasicFS
  • ~NoiseFSActor() : nvidia::apex::NoiseFSActor
  • ~VortexFSActor() : nvidia::apex::VortexFSActor
  • ~WindFSActor() : nvidia::apex::WindFSActor
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: File Members

  • File List
  • File Members
  • All
  • Defines
  • ATTRACTOR_FS_AUTHORING_TYPE_NAME : BasicFSAsset.h
  • JET_FS_AUTHORING_TYPE_NAME : BasicFSAsset.h
  • NOISE_FS_AUTHORING_TYPE_NAME : BasicFSAsset.h
  • VORTEX_FS_AUTHORING_TYPE_NAME : BasicFSAsset.h
  • WIND_FS_AUTHORING_TYPE_NAME : BasicFSAsset.h
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: Main Page

APEX BasicFS Module Documentation
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: JetFSActor.h Source File

  • File List
  • File Members
JetFSActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef JET_FSACTOR_H
00031 #define JET_FSACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class BasicFSAsset;
00043
00044
00048 class JetFSActor : public Actor, public Renderable
00049 {
00050 protected:
00051     virtual ~JetFSActor() {}
00052
00053 public:
00054
00058     virtual BasicFSAsset*       getJetFSAsset() const = 0;
00059
00063     virtual PxMat44             getCurrentPose() const = 0;
00064
00068     virtual void                setCurrentPose(const PxTransform& pose) = 0;
00069
00073     virtual PxVec3              getCurrentPosition() const = 0;
00074
00078     virtual void                setCurrentPosition(const PxVec3& pos) = 0;
00079
00083     virtual float               getCurrentScale() const = 0;
00084
00088     virtual void                setCurrentScale(const float& scale) = 0;
00089
00093     virtual void                setFieldStrength(float) = 0;
00094
00098     virtual void                setFieldDirection(const PxVec3&) = 0;
00099
00103     virtual void                setEnabled(bool isEnabled) = 0;
00104
00105 };
00106
00107 PX_POP_PACK
00108
00109 }
00110 } // end namespace nvidia::apex
00111
00112 #endif // JET_FSACTOR_H
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: JetFSPreview.h Source File

  • File List
  • File Members
JetFSPreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef JET_FSPREVIEW_H
00030 #define JET_FSPREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class RenderDebugInterface;
00043
00052 namespace APEX_JET
00053 {
00058 static const uint32_t JET_DRAW_NOTHING = 0x00;
00063 static const uint32_t JET_DRAW_SHAPE = 0x01;
00069 static const uint32_t JET_DRAW_ASSET_INFO = 0x02;
00074 static const uint32_t JET_DRAW_FULL_DETAIL = (JET_DRAW_SHAPE + JET_DRAW_ASSET_INFO);
00075 }
00076
00081 class JetFSPreview : public AssetPreview
00082 {
00083 public:
00094     virtual void    setDetailLevel(uint32_t detail) = 0;
00095 };
00096
00097
00098 PX_POP_PACK
00099
00100 }
00101 } // namespace nvidia
00102
00103 #endif // JET_FSPREVIEW_H
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: ModuleBasicFS.h Source File

  • File List
  • File Members
ModuleBasicFS.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef MODULE_BASIC_FS_H
00030 #define MODULE_BASIC_FS_H
00031
00032 #include "Apex.h"
00033
00034 namespace nvidia
00035 {
00036 namespace apex
00037 {
00038
00039 PX_PUSH_PACK_DEFAULT
00040
00041 class BasicFSAsset;
00042 class BasicFSAssetAuthoring;
00043
00044
00048 class ModuleBasicFS : public Module
00049 {
00050 public:
00051
00052 protected:
00053     virtual ~ModuleBasicFS() {}
00054 };
00055
00056
00057 PX_POP_PACK
00058
00059 }
00060 } // end namespace nvidia::apex
00061
00062 #endif // MODULE_BASIC_FS_H
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: NoiseFSActor.h Source File

  • File List
  • File Members
NoiseFSActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef NOISE_FSACTOR_H
00031 #define NOISE_FSACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class BasicFSAsset;
00043
00044
00048 class NoiseFSActor : public Actor, public Renderable
00049 {
00050 protected:
00051     virtual ~NoiseFSActor() {}
00052
00053 public:
00054
00058     virtual BasicFSAsset*       getNoiseFSAsset() const = 0;
00059
00063     virtual PxMat44             getCurrentPose() const = 0;
00064
00068     virtual void                setCurrentPose(const PxTransform& pose) = 0;
00069
00073     virtual PxVec3              getCurrentPosition() const = 0;
00074
00078     virtual void                setCurrentPosition(const PxVec3& pos) = 0;
00079
00083     virtual float               getCurrentScale() const = 0;
00084
00088     virtual void                setCurrentScale(const float& scale) = 0;
00089
00093     virtual void                setNoiseStrength(float) = 0;
00094
00098     virtual void                setEnabled(bool isEnabled) = 0;
00099
00100 };
00101
00102 PX_POP_PACK
00103
00104 }
00105 } // end namespace nvidia::apex
00106
00107 #endif // NOISE_FSACTOR_H
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: NoiseFSPreview.h Source File

  • File List
  • File Members
NoiseFSPreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef NOISE_FSPREVIEW_H
00030 #define NOISE_FSPREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class RenderDebugInterface;
00043
00052 namespace APEX_NOISE
00053 {
00058 static const uint32_t NOISE_DRAW_NOTHING = 0x00;
00063 static const uint32_t NOISE_DRAW_SHAPE = 0x01;
00069 static const uint32_t NOISE_DRAW_ASSET_INFO = 0x02;
00074 static const uint32_t NOISE_DRAW_FULL_DETAIL = (NOISE_DRAW_SHAPE + NOISE_DRAW_ASSET_INFO);
00075 }
00076
00081 class NoiseFSPreview : public AssetPreview
00082 {
00083 public:
00094     virtual void    setDetailLevel(uint32_t detail) = 0;
00095 };
00096
00097
00098 PX_POP_PACK
00099
00100 }
00101 } // namespace nvidia
00102
00103 #endif // NOISE_FSPREVIEW_H
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: VortexFSActor.h Source File

  • File List
  • File Members
VortexFSActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef VORTEX_FSACTOR_H
00031 #define VORTEX_FSACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class BasicFSAsset;
00043
00044
00048 class VortexFSActor : public Actor, public Renderable
00049 {
00050 protected:
00051     virtual ~VortexFSActor() {}
00052
00053 public:
00054
00058     virtual BasicFSAsset*       getVortexFSAsset() const = 0;
00059
00063     virtual PxMat44             getCurrentPose() const = 0;
00064
00068     virtual void                setCurrentPose(const PxTransform& pose) = 0;
00069
00073     virtual PxVec3              getCurrentPosition() const = 0;
00074
00078     virtual void                setCurrentPosition(const PxVec3& pos) = 0;
00079
00083     virtual void                setAxis(const PxVec3&) = 0;
00084
00088     virtual void                setHeight(float) = 0;
00089
00093     virtual void                setBottomRadius(float) = 0;
00094
00098     virtual void                setTopRadius(float) = 0;
00099
00103     virtual void                setBottomSphericalForce(bool) = 0;
00104
00108     virtual void                setTopSphericalForce(bool) = 0;
00109
00113     virtual void                setRotationalStrength(float) = 0;
00114
00118     virtual void                setRadialStrength(float) = 0;
00119
00123     virtual void                setLiftStrength(float) = 0;
00124
00128     virtual void                setEnabled(bool isEnabled) = 0;
00129
00130
00134     virtual void                setCurrentScale(float scale) = 0;
00135
00139     virtual float               getCurrentScale(void) const = 0;
00140
00141 };
00142
00143 PX_POP_PACK
00144
00145 }
00146 } // end namespace nvidia::apex
00147
00148 #endif // VORTEX_FSACTOR_H
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: VortexFSPreview.h Source File

  • File List
  • File Members
VortexFSPreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef VORTEX_FSPREVIEW_H
00030 #define VORTEX_FSPREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class RenderDebugInterface;
00043
00052 namespace APEX_VORTEX
00053 {
00058 static const uint32_t VORTEX_DRAW_NOTHING = 0x00;
00063 static const uint32_t VORTEX_DRAW_SHAPE = 0x01;
00070 static const uint32_t VORTEX_DRAW_ASSET_INFO = 0x02;
00075 static const uint32_t VORTEX_DRAW_FULL_DETAIL = (VORTEX_DRAW_SHAPE + VORTEX_DRAW_ASSET_INFO);
00076 }
00077
00082 class VortexFSPreview : public AssetPreview
00083 {
00084 public:
00088     virtual void    setRadius(float radius) = 0;
00099     virtual void    setDetailLevel(uint32_t detail) = 0;
00100 };
00101
00102
00103 PX_POP_PACK
00104
00105 }
00106 } // namespace nvidia
00107
00108 #endif // VORTEX_FS_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: WindFSActor.h Source File

  • File List
  • File Members
WindFSActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef WIND_FSACTOR_H
00031 #define WIND_FSACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class BasicFSAsset;
00043
00044
00048 class WindFSActor : public Actor, public Renderable
00049 {
00050 protected:
00051     virtual ~WindFSActor() {}
00052
00053 public:
00054
00058     virtual BasicFSAsset*       getWindFSAsset() const = 0;
00059
00063     virtual PxMat44             getCurrentPose() const = 0;
00064
00068     virtual void                setCurrentPose(const PxTransform& pose) = 0;
00069
00073     virtual PxVec3              getCurrentPosition() const = 0;
00074
00078     virtual void                setCurrentPosition(const PxVec3& pos) = 0;
00079
00083     virtual void                setFieldStrength(float) = 0;
00084
00088     virtual void                setFieldDirection(const PxVec3&) = 0;
00089
00093     virtual void                setEnabled(bool isEnabled) = 0;
00094
00098     virtual void                setCurrentScale(float scale) = 0;
00099
00103     virtual float               getCurrentScale(void) const = 0;
00104 };
00105
00106 PX_POP_PACK
00107
00108 }
00109 } // end namespace nvidia::apex
00110
00111 #endif // WIND_FSACTOR_H
Generated on Sat Dec 1 2018 10:18:17


APEX BasicFS Module: WindFSPreview.h Source File

  • File List
  • File Members
WindFSPreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef WIND_FSPREVIEW_H
00030 #define WIND_FSPREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class RenderDebugInterface;
00043
00051 namespace APEX_WIND
00052 {
00057 static const uint32_t WIND_DRAW_NOTHING = 0x00;
00063 static const uint32_t WIND_DRAW_ASSET_INFO = 0x02;
00068 static const uint32_t WIND_DRAW_FULL_DETAIL = (WIND_DRAW_ASSET_INFO);
00069 }
00070
00075 class WindFSPreview : public AssetPreview
00076 {
00077 public:
00087     virtual void    setDetailLevel(uint32_t detail) = 0;
00088 };
00089
00090
00091 PX_POP_PACK
00092
00093 }
00094 } // namespace nvidia
00095
00096 #endif // WIND_FSPREVIEW_H
Generated on Sat Dec 1 2018 10:18:17


APEX BasicIOS Module: Class List

  • Class List
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
nvidia::apex::BasicIosActor | BasicIOS Actor. A simple actor that simulates a particle system
nvidia::apex::BasicIosAsset | APEX Particle System Asset
nvidia::apex::BasicIosAssetAuthoring | APEX Particle System Asset Authoring class
nvidia::apex::ModuleBasicIos | BasicIOS Module
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: BasicIosActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
BasicIosActor.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::BasicIosActor
BasicIOS Actor. A simple actor that simulates a particle system. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: BasicIosActor.h Source File

  • File List
  • File Members
BasicIosActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef BASIC_IOS_ACTOR_H
00031 #define BASIC_IOS_ACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00045 class BasicIosActor : public Actor
00046 {
00047 public:
00048
00050     virtual float                       getParticleRadius() const = 0;
00051
00053     virtual float                       getRestDensity() const = 0;
00054
00056     virtual uint32_t                    getParticleCount() const = 0;
00057
00058 protected:
00059
00060     virtual ~BasicIosActor()    {}
00061 };
00062
00063 PX_POP_PACK
00064
00065 }
00066 } // namespace nvidia
00067
00068 #endif // BASIC_IOS_ACTOR_H
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: BasicIosAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
BasicIosAsset.h File Reference
#include "Apex.h"
#include <limits.h>

Go to the source code of this file.

Classes

class | nvidia::apex::BasicIosAsset
APEX Particle System Asset. More...
class | nvidia::apex::BasicIosAssetAuthoring
APEX Particle System Asset Authoring class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | BASIC_IOS_AUTHORING_TYPE_NAME "BasicIosAsset"

Define Documentation

#define BASIC_IOS_AUTHORING_TYPE_NAME "BasicIosAsset"
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: BasicIosAsset.h Source File

  • File List
  • File Members
BasicIosAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef BASIC_IOS_ASSET_H
00031 #define BASIC_IOS_ASSET_H
00032
00033 #include "Apex.h"
00034 #include <limits.h>
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define BASIC_IOS_AUTHORING_TYPE_NAME "BasicIosAsset"
00044
00048 class BasicIosAsset : public IosAsset
00049 {
00050 public:
00051
00053     virtual float                       getParticleRadius() const = 0;
00054
00056     virtual float                       getRestDensity() const = 0;
00057
00059     virtual float                       getMaxInjectedParticleCount() const = 0;
00060
00062     virtual uint32_t                    getMaxParticleCount() const = 0;
00063
00065     virtual float                       getParticleMass() const = 0;
00066
00067 protected:
00068     virtual ~BasicIosAsset()    {}
00069 };
00070
00074 class BasicIosAssetAuthoring : public AssetAuthoring
00075 {
00076 public:
00077
00079     virtual void setParticleRadius(float) = 0;
00080
00082     virtual void setRestDensity(float) = 0;
00083
00085     virtual void setMaxInjectedParticleCount(float count) = 0;
00086
00088     virtual void setMaxParticleCount(uint32_t count) = 0;
00089
00091     virtual void setParticleMass(float) = 0;
00092
00094     virtual void setCollisionGroupName(const char* collisionGroupName) = 0;
00095
00097     virtual void setCollisionGroupMaskName(const char* collisionGroupMaskName) = 0;
00098
00099 protected:
00100     virtual ~BasicIosAssetAuthoring()   {}
00101 };
00102
00103 PX_POP_PACK
00104
00105 }
00106 } // namespace nvidia
00107
00108 #endif // BASIC_IOS_ASSET_H
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: Class Index

  • Class List
  • Class Members
Class Index
B | M
B
BasicIosAsset (nvidia::apex) BasicIosAssetAuthoring (nvidia::apex)
M
ModuleBasicIos (nvidia::apex)
BasicIosActor (nvidia::apex)
B | M
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: nvidia::apex::BasicIosActor Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • BasicIosActor
Public Member Functions | Protected Member Functions
nvidia::apex::BasicIosActor Class Reference

BasicIOS Actor. A simple actor that simulates a particle system. More...

#include <BasicIosActor.h>

List of all members.

Public Member Functions

virtual float | getParticleRadius () const =0
Get the particle radius.
virtual float | getRestDensity () const =0
Get the particle rest density.
virtual uint32_t | getParticleCount () const =0
Get the current number of particles.

Protected Member Functions

virtual | ~BasicIosActor ()

Detailed Description

BasicIOS Actor. A simple actor that simulates a particle system.

Constructor & Destructor Documentation

virtual nvidia::apex::BasicIosActor::~BasicIosActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual uint32_t nvidia::apex::BasicIosActor::getParticleCount ( ) const [pure virtual]

Get the current number of particles.

virtual float nvidia::apex::BasicIosActor::getParticleRadius ( ) const [pure virtual]

Get the particle radius.

virtual float nvidia::apex::BasicIosActor::getRestDensity ( ) const [pure virtual]

Get the particle rest density.

The documentation for this class was generated from the following file:
  • BasicIosActor.h
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • BasicIosActor
nvidia::apex::BasicIosActor Member List
This is the complete list of members for nvidia::apex::BasicIosActor, including all inherited members.
getParticleCount() const =0 | nvidia::apex::BasicIosActor | [pure virtual]
getParticleRadius() const =0 | nvidia::apex::BasicIosActor | [pure virtual]
getRestDensity() const =0 | nvidia::apex::BasicIosActor | [pure virtual]
~BasicIosActor() | nvidia::apex::BasicIosActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: nvidia::apex::BasicIosAsset Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • BasicIosAsset
Public Member Functions | Protected Member Functions
nvidia::apex::BasicIosAsset Class Reference

APEX Particle System Asset. More...

#include <BasicIosAsset.h>

List of all members.

Public Member Functions

virtual float | getParticleRadius () const =0
Get the radius of a particle.
virtual float | getRestDensity () const =0
Get the rest density of a particle.
virtual float | getMaxInjectedParticleCount () const =0
Get the maximum number of particles that are allowed to be newly created on each frame.
virtual uint32_t | getMaxParticleCount () const =0
Get the maximum number of particles that this IOS can simulate.
virtual float | getParticleMass () const =0
Get the mass of a particle.

Protected Member Functions

virtual | ~BasicIosAsset ()

Detailed Description

APEX Particle System Asset.

Constructor & Destructor Documentation

virtual nvidia::apex::BasicIosAsset::~BasicIosAsset ( ) [inline, protected, virtual]

Member Function Documentation

virtual float nvidia::apex::BasicIosAsset::getMaxInjectedParticleCount ( ) const [pure virtual]

Get the maximum number of particles that are allowed to be newly created on each frame.

virtual uint32_t nvidia::apex::BasicIosAsset::getMaxParticleCount ( ) const [pure virtual]

Get the maximum number of particles that this IOS can simulate.

virtual float nvidia::apex::BasicIosAsset::getParticleMass ( ) const [pure virtual]

Get the mass of a particle.

virtual float nvidia::apex::BasicIosAsset::getParticleRadius ( ) const [pure virtual]

Get the radius of a particle.

virtual float nvidia::apex::BasicIosAsset::getRestDensity ( ) const [pure virtual]

Get the rest density of a particle.

The documentation for this class was generated from the following file:
  • BasicIosAsset.h
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • BasicIosAsset
nvidia::apex::BasicIosAsset Member List
This is the complete list of members for nvidia::apex::BasicIosAsset, including all inherited members.
getMaxInjectedParticleCount() const =0 | nvidia::apex::BasicIosAsset | [pure virtual]
getMaxParticleCount() const =0 | nvidia::apex::BasicIosAsset | [pure virtual]
getParticleMass() const =0 | nvidia::apex::BasicIosAsset | [pure virtual]
getParticleRadius() const =0 | nvidia::apex::BasicIosAsset | [pure virtual]
getRestDensity() const =0 | nvidia::apex::BasicIosAsset | [pure virtual]
~BasicIosAsset() | nvidia::apex::BasicIosAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: nvidia::apex::BasicIosAssetAuthoring Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • BasicIosAssetAuthoring
Public Member Functions | Protected Member Functions
nvidia::apex::BasicIosAssetAuthoring Class Reference

APEX Particle System Asset Authoring class. More...

#include <BasicIosAsset.h>

List of all members.

Public Member Functions

virtual void | setParticleRadius (float)=0
Set the radius of a particle.
virtual void | setRestDensity (float)=0
Set the rest density of a particle.
virtual void | setMaxInjectedParticleCount (float count)=0
Set the maximum number of particles that are allowed to be newly created on each frame.
virtual void | setMaxParticleCount (uint32_t count)=0
Set the maximum number of particles that this IOS can simulate.
virtual void | setParticleMass (float)=0
Set the mass of a particle.
virtual void | setCollisionGroupName (const char *collisionGroupName)=0
Set the (NRP) name for the collision group.
virtual void | setCollisionGroupMaskName (const char *collisionGroupMaskName)=0
Set the (NRP) name for the collision group mask.

Protected Member Functions

virtual | ~BasicIosAssetAuthoring ()

Detailed Description

APEX Particle System Asset Authoring class.

Constructor & Destructor Documentation

virtual nvidia::apex::BasicIosAssetAuthoring::~BasicIosAssetAuthoring ( ) [inline, protected, virtual]

Member Function Documentation

virtual void nvidia::apex::BasicIosAssetAuthoring::setCollisionGroupMaskName ( const char * collisionGroupMaskName ) [pure virtual]

Set the (NRP) name for the collision group mask.

virtual void nvidia::apex::BasicIosAssetAuthoring::setCollisionGroupName ( const char * collisionGroupName ) [pure virtual]

Set the (NRP) name for the collision group.

virtual void nvidia::apex::BasicIosAssetAuthoring::setMaxInjectedParticleCount ( float count ) [pure virtual]

Set the maximum number of particles that are allowed to be newly created on each frame.

virtual void nvidia::apex::BasicIosAssetAuthoring::setMaxParticleCount ( uint32_t count ) [pure virtual]

Set the maximum number of particles that this IOS can simulate.

virtual void nvidia::apex::BasicIosAssetAuthoring::setParticleMass ( float ) [pure virtual]

Set the mass of a particle.

virtual void nvidia::apex::BasicIosAssetAuthoring::setParticleRadius ( float ) [pure virtual]

Set the radius of a particle.

virtual void nvidia::apex::BasicIosAssetAuthoring::setRestDensity ( float ) [pure virtual]

Set the rest density of a particle.

The documentation for this class was generated from the following file:
  • BasicIosAsset.h
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • BasicIosAssetAuthoring
nvidia::apex::BasicIosAssetAuthoring Member List
This is the complete list of members for nvidia::apex::BasicIosAssetAuthoring, including all inherited members.
setCollisionGroupMaskName(const char *collisionGroupMaskName)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
setCollisionGroupName(const char *collisionGroupName)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
setMaxInjectedParticleCount(float count)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
setMaxParticleCount(uint32_t count)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
setParticleMass(float)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
setParticleRadius(float)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
setRestDensity(float)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
~BasicIosAssetAuthoring() | nvidia::apex::BasicIosAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: nvidia::apex::ModuleBasicIos Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • ModuleBasicIos
Public Member Functions | Protected Member Functions
nvidia::apex::ModuleBasicIos Class Reference

BasicIOS Module. More...

#include <ModuleBasicIos.h>

List of all members.

Public Member Functions

virtual const char * | getBasicIosTypeName ()=0
Get BasicIOS authoring type name.
virtual const TestBase * | getTestBase (Scene *apexScene) const =0
Get TestBase implementation of BasicIos scene.

Protected Member Functions

virtual | ~ModuleBasicIos ()

Detailed Description

BasicIOS Module.

Constructor & Destructor Documentation

virtual nvidia::apex::ModuleBasicIos::~ModuleBasicIos ( ) [inline, protected, virtual]

Member Function Documentation

virtual const char* nvidia::apex::ModuleBasicIos::getBasicIosTypeName ( ) [pure virtual]

Get BasicIOS authoring type name.

virtual const TestBase* nvidia::apex::ModuleBasicIos::getTestBase ( Scene * apexScene ) const [pure virtual]

Get TestBase implementation of BasicIos scene.

The documentation for this class was generated from the following file:
  • ModuleBasicIos.h
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • ModuleBasicIos
nvidia::apex::ModuleBasicIos Member List
This is the complete list of members for nvidia::apex::ModuleBasicIos, including all inherited members.
getBasicIosTypeName()=0 | nvidia::apex::ModuleBasicIos | [pure virtual]
getTestBase(Scene *apexScene) const =0 | nvidia::apex::ModuleBasicIos | [pure virtual]
~ModuleBasicIos() | nvidia::apex::ModuleBasicIos | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
BasicIosActor.h [code]
BasicIosAsset.h [code]
ModuleBasicIos.h [code]
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: Class Members

  • Class List
  • Class Members
  • All
  • Functions
Here is a list of all class members with links to the classes they belong to:
  • getBasicIosTypeName() : nvidia::apex::ModuleBasicIos
  • getMaxInjectedParticleCount() : nvidia::apex::BasicIosAsset
  • getMaxParticleCount() : nvidia::apex::BasicIosAsset
  • getParticleCount() : nvidia::apex::BasicIosActor
  • getParticleMass() : nvidia::apex::BasicIosAsset
  • getParticleRadius()
: nvidia::apex::BasicIosAsset
, nvidia::apex::BasicIosActor
  • getRestDensity()
: nvidia::apex::BasicIosActor
, nvidia::apex::BasicIosAsset
  • getTestBase() : nvidia::apex::ModuleBasicIos
  • setCollisionGroupMaskName() : nvidia::apex::BasicIosAssetAuthoring
  • setCollisionGroupName() : nvidia::apex::BasicIosAssetAuthoring
  • setMaxInjectedParticleCount() : nvidia::apex::BasicIosAssetAuthoring
  • setMaxParticleCount() : nvidia::apex::BasicIosAssetAuthoring
  • setParticleMass() : nvidia::apex::BasicIosAssetAuthoring
  • setParticleRadius() : nvidia::apex::BasicIosAssetAuthoring
  • setRestDensity() : nvidia::apex::BasicIosAssetAuthoring
  • ~BasicIosActor() : nvidia::apex::BasicIosActor
  • ~BasicIosAsset() : nvidia::apex::BasicIosAsset
  • ~BasicIosAssetAuthoring() : nvidia::apex::BasicIosAssetAuthoring
  • ~ModuleBasicIos() : nvidia::apex::ModuleBasicIos
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: Class Members - Functions

  • Class List
  • Class Members
  • All
  • Functions
  • getBasicIosTypeName() : nvidia::apex::ModuleBasicIos
  • getMaxInjectedParticleCount() : nvidia::apex::BasicIosAsset
  • getMaxParticleCount() : nvidia::apex::BasicIosAsset
  • getParticleCount() : nvidia::apex::BasicIosActor
  • getParticleMass() : nvidia::apex::BasicIosAsset
  • getParticleRadius()
: nvidia::apex::BasicIosAsset
, nvidia::apex::BasicIosActor
  • getRestDensity()
: nvidia::apex::BasicIosActor
, nvidia::apex::BasicIosAsset
  • getTestBase() : nvidia::apex::ModuleBasicIos
  • setCollisionGroupMaskName() : nvidia::apex::BasicIosAssetAuthoring
  • setCollisionGroupName() : nvidia::apex::BasicIosAssetAuthoring
  • setMaxInjectedParticleCount() : nvidia::apex::BasicIosAssetAuthoring
  • setMaxParticleCount() : nvidia::apex::BasicIosAssetAuthoring
  • setParticleMass() : nvidia::apex::BasicIosAssetAuthoring
  • setParticleRadius() : nvidia::apex::BasicIosAssetAuthoring
  • setRestDensity() : nvidia::apex::BasicIosAssetAuthoring
  • ~BasicIosActor() : nvidia::apex::BasicIosActor
  • ~BasicIosAsset() : nvidia::apex::BasicIosAsset
  • ~BasicIosAssetAuthoring() : nvidia::apex::BasicIosAssetAuthoring
  • ~ModuleBasicIos() : nvidia::apex::ModuleBasicIos
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: File Members

  • File List
  • File Members
  • All
  • Defines
Here is a list of all file members with links to the files they belong to:
  • BASIC_IOS_AUTHORING_TYPE_NAME : BasicIosAsset.h
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: File Members

  • File List
  • File Members
  • All
  • Defines
  • BASIC_IOS_AUTHORING_TYPE_NAME : BasicIosAsset.h
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: Main Page

APEX BasicIOS Module Documentation
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: ModuleBasicIos.h File Reference

  • File List
  • File Members
Classes | Namespaces
ModuleBasicIos.h File Reference
#include "Apex.h"
#include "TestBase.h"
#include <limits.h>

Go to the source code of this file.

Classes

class | nvidia::apex::ModuleBasicIos
BasicIOS Module. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: ModuleBasicIos.h Source File

  • File List
  • File Members
ModuleBasicIos.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_BASIC_IOS_H
00031 #define MODULE_BASIC_IOS_H
00032
00033 #include "Apex.h"
00034 #include "TestBase.h"
00035 #include <limits.h>
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00042 PX_PUSH_PACK_DEFAULT
00043
00044 class Scene;
00045 class BasicIosAsset;
00046 class BasicIosActor;
00047 class BasicIosAssetAuthoring;
00048
00052 class ModuleBasicIos : public Module
00053 {
00054 protected:
00055     virtual                                     ~ModuleBasicIos() {}
00056
00057 public:
00059     virtual const char*                         getBasicIosTypeName() = 0;
00060
00062     virtual const TestBase*                     getTestBase(Scene* apexScene) const = 0;
00063
00064 };
00065
00066
00067 PX_POP_PACK
00068
00069 }
00070 } // namespace nvidia
00071
00072 #endif // MODULE_BASIC_IOS_H
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: nvidia Namespace Reference

  • Namespace List
Namespaces
nvidia Namespace Reference

Namespaces

namespace apex
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: nvidia::apex Namespace Reference

  • Namespace List
  • nvidia
  • apex
Classes
nvidia::apex Namespace Reference

Classes

class | BasicIosActor
BasicIOS Actor. A simple actor that simulates a particle system. More...
class | BasicIosAsset
APEX Particle System Asset. More...
class | BasicIosAssetAuthoring
APEX Particle System Asset Authoring class. More...
class | ModuleBasicIos
BasicIOS Module. More...
Generated on Sat Dec 1 2018 10:18:18


APEX BasicIOS Module: Namespace List

  • Namespace List
Namespace List
Here is a list of all namespaces with brief descriptions:
nvidia
nvidia::apex
Generated on Sat Dec 1 2018 10:18:18


APEX Clothing Module: Class List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
nvidia::apex::ClothingActor | Instance of ClothingAsset. Can be positioned, animated, updated and rendered
nvidia::apex::ClothingAsset | A clothing asset. It contains all the static and shared data for a given piece of clothing
nvidia::apex::ClothingAssetAuthoring | The clothing authoring asset. This is used to generate streams that can then be deserialized into a regular asset
nvidia::apex::ClothingCapsule | Capsule collision of a clothing actor
nvidia::apex::ClothingCollision | Base class of all clothing collision types
nvidia::apex::ClothingCollisionType | Type of the ClothingCollision
nvidia::apex::ClothingConstrainCoefficients | Constrain coefficients of the physical mesh vertices
nvidia::apex::ClothingConvex | Convex collision of a clothing actor
nvidia::apex::ClothingMeshSkinningMap | Maps from a triangle of the simulated mesh to a vertex of the rendered mesh. The barycentric coordinates describe the position of a point in space relative to a simulated triangle. The actual z-coordinate is computed by bary.z = 1 - bary.x - bary.y. The z part of the vector contains the height of the skinned vertex along the normal of the simulated triangle
nvidia::apex::ClothingPhysicalMesh | Holder for a physical mesh, this can be generated through various ways (see single- and multi-layered clothing) or hand crafted
nvidia::apex::ClothingPhysicalMeshStats | Contains the data for handing out statistics about a ClothingPhysicalMesh
nvidia::apex::ClothingPlane | Plane collision of a clothing actor
nvidia::apex::ClothingPreview | A lightweight preview of a ClothingActor that will not perform any simulation
nvidia::apex::ClothingRenderProxy | Instance of ClothingRenderProxy. This is the renderable of a clothing actor. The data in this object is consistent until it is returned to APEX with the release() call
nvidia::apex::ClothingSphere | Sphere collision of a clothing actor
nvidia::apex::ClothingTeleportMode | Selects the mode the clothing actor will be in the simulation frame
nvidia::apex::ClothingTriangleMesh | Triangle mesh collision of a clothing actor
nvidia::apex::ClothingVelocityCallback | Container class for the velocity shader callback
nvidia::apex::ClothSolverMode | Describes the solver that is used to simulate the clothing actor
nvidia::apex::ModuleClothing | APEX Clothing Module
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Class Index

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
Class Index
C | M
C
ClothingCollision (nvidia::apex) ClothingPhysicalMesh (nvidia::apex) ClothingRenderProxy (nvidia::apex) ClothingVelocityCallback (nvidia::apex)
ClothingActor (nvidia::apex) | ClothingCollisionType (nvidia::apex) | ClothingPhysicalMeshStats (nvidia::apex) | ClothingSphere (nvidia::apex) | ClothSolverMode (nvidia::apex)
ClothingAsset (nvidia::apex) ClothingConstrainCoefficients (nvidia::apex) ClothingPlane (nvidia::apex) ClothingTeleportMode (nvidia::apex)
M
ClothingAssetAuthoring (nvidia::apex) | ClothingConvex (nvidia::apex) | ClothingPreview (nvidia::apex) | ClothingTriangleMesh (nvidia::apex) | ModuleClothing (nvidia::apex)
ClothingCapsule (nvidia::apex) | ClothingMeshSkinningMap (nvidia::apex)
C | M
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingActor Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingActor
Public Member Functions
nvidia::apex::ClothingActor Class Reference

Instance of ClothingAsset. Can be positioned, animated, updated and rendered. More...

#include <ClothingActor.h>

List of all members.

Public Member Functions

virtual
::NvParameterized::Interface * 		getActorDesc ()=0
Returns a reference to the actor descriptor as it is held by the ClothingActor.
virtual void | updateState (const PxMat44 &globalPose, const PxMat44 *newBoneMatrices, uint32_t boneMatricesByteStride, uint32_t numBoneMatrices, ClothingTeleportMode::Enum teleportMode)=0
Updates all internal bone matrices. This should be called with updated information before apex scenes start simulating.
virtual void | updateMaxDistanceScale (float scale, bool multipliable)=0
Change the max distance of all active vertices with a scalar parameter.
virtual const PxMat44 & | getGlobalPose () const =0
returns the globalPose that was set with ClothingActor::updateState()
virtual void | setWind (float windAdaption, const PxVec3 &windVelocity)=0
Sets the wind strength and direction, can be called any time.
virtual void | setMaxDistanceBlendTime (float blendTime)=0
DEPRECATED Time in seconds how long it takes to go from 0 maxDistance to full maxDistance
virtual float | getMaxDistanceBlendTime () const =0
DEPRECATED Time in seconds how long it takes to go from 0 maxDistance to full maxDistance
virtual void | setVisible (bool enable)=0
Tells the actor if it will be rendered or not. If an actor is simulated, but not rendered, some computations (skinning, normal and tangent calculation) doesn't need to be done.
virtual bool | isVisible () const =0
Returns the current visibility setting. The most recently set value is returned (i.e. the buffered value, not the actual value).
virtual void | setFrozen (bool enable)=0
Stops simulating the actor.
virtual bool | isFrozen () const =0
Returns if the simulation is currently stopped for this actor.
virtual ClothSolverMode::Enum | getClothSolverMode () const =0
Returns whether the actor is simulated using the 2.8.x or the 3.x cloth solver.
virtual void | setGraphicalLOD (uint32_t lod)=0
sets the graphical Lod This chooses the graphical mesh of all the meshes stored in the asset to be rendered. It has to be set before the simulate call to take effect for the next time the actor is rendered. Otherwise, the given value will be buffered and used as soon as possible.
virtual uint32_t | getGraphicalLod ()=0
returns the graphical Lod This returns the buffered most recently set graphical lod, even if it's not active yet.
virtual bool | rayCast (const PxVec3 &worldOrigin, const PxVec3 &worldDirection, float &time, PxVec3 &normal, uint32_t &vertexIndex)=0
Raycasts against the ClothingActor.
virtual void | attachVertexToGlobalPosition (uint32_t vertexIndex, const PxVec3 &globalPosition)=0
Attach a vertex to a global position.
virtual void | freeVertex (uint32_t vertexIndex)=0
Free a previously attached vertex.
virtual uint32_t | getClothingMaterial () const =0
Returns the actively selected material.
virtual void | setClothingMaterial (uint32_t index)=0
Sets which clothing material is used from the assets library.
virtual void | setOverrideMaterial (uint32_t submeshIndex, const char *overrideMaterialName)=0
Sets the override material for the submesh with the given index.
virtual void | setVelocityCallback (ClothingVelocityCallback *callback)=0
sets the velocity callback for an individual actor, turned off when NULL
virtual void | getPhysicalMeshPositions (void *buffer, uint32_t byteStride)=0
Returns the current position of all physics vertices.
virtual void | getPhysicalMeshNormals (void *buffer, uint32_t byteStride)=0
Returns the current normals of all physics vertices.
virtual float | getMaximumSimulationBudget () const =0
Returns how much an Actor will cost at maximum.
virtual uint32_t | getNumSimulationVertices () const =0
Returns the number of currently simulation vertices.
virtual const PxVec3 * | getSimulationPositions ()=0
Returns a pointer to the internal positions array of the simulated physics mesh Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)
virtual const PxVec3 * | getSimulationNormals ()=0
Returns a pointer to the internal normals array of the simulated physics mesh Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)
virtual bool | getSimulationVelocities (PxVec3 *velocities)=0
Writes the current velocities of the simulated vertices into the provided array. A buffer of getNumSimulationVertices() PxVec3's needs to be provided. The function cannot be called during simulation. Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)
virtual uint32_t | getNumGraphicalVerticesActive (uint32_t submeshIndex) const =0
Returns the number of the graphical vertices that need to be skinned to the simulation mesh [0, numGraphicalVerticesActive)
virtual PxMat44 | getRenderGlobalPose () const =0
Returns the transform that needs to be applied to the rendered mesh.
virtual const PxMat44 * | getCurrentBoneSkinningMatrices () const =0
Returns the current skinning matrices. The skinning matrices already contain the global pose of the actor.
virtual bool | isHalfPrecisionAllowed () const =0
return whether GPU solver can use half precision for storing positions.
virtual void | setHalfPrecision (bool isAllowed)=0
allow GPU solver to use half precision for storing positions.
virtual ClothingPlane * | createCollisionPlane (const PxPlane &plane)=0
Create a collision plane for the actor.
virtual ClothingConvex * | createCollisionConvex (ClothingPlane **planes, uint32_t numPlanes)=0
Create a collision convex for the actor, defined by planes.
virtual ClothingSphere * | createCollisionSphere (const PxVec3 &position, float radius)=0
Create a collision sphere for the actor.
virtual ClothingCapsule * | createCollisionCapsule (ClothingSphere &sphere1, ClothingSphere &sphere2)=0
Create a tapered collision capsule for the actor, defined by two spheres.
virtual ClothingTriangleMesh * | createCollisionTriangleMesh ()=0
Create a collision triangle mesh for the actor.
virtual ClothingRenderProxy * | acquireRenderProxy ()=0
Returns the Render Proxy for this clothing actor.

Detailed Description

Instance of ClothingAsset. Can be positioned, animated, updated and rendered.

Member Function Documentation

virtual ClothingRenderProxy* nvidia::apex::ClothingActor::acquireRenderProxy ( ) [pure virtual]

Returns the Render Proxy for this clothing actor.

Call this function after fetchResults to get the ClothingRenderProxy object that can be used to render the simulation reset. The render proxy can be acquired at any time, it contains the result from the last fetchResults call. It is recommended to acquire the render proxy after fetchResults and to release it before the next simulate call to prevent the memory overhead of buffering the render data. The data in the render proxy remains consistent until it is released (release returns the object into a pool from which it can be reused). The ClothingRenderProxy object is valid even after the release of the clothing actor. However it becomes invalid when the corresponding asset is released. Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)

Returns:
ClothingRenderProxy object with static render data. Can be acquired only once per frame, otherwise NULL is returned.
virtual ::NvParameterized::Interface* nvidia::apex::ClothingActor::getActorDesc ( ) [pure virtual]

Returns a reference to the actor descriptor as it is held by the ClothingActor.

This descriptor can be modified at any time, changes will only be read during the first part of the simulation.

virtual const PxMat44* nvidia::apex::ClothingActor::getCurrentBoneSkinningMatrices ( ) const [pure virtual]

Returns the current skinning matrices. The skinning matrices already contain the global pose of the actor.

Note:
Only valid after simulate.
virtual float nvidia::apex::ClothingActor::getMaxDistanceBlendTime ( ) const [pure virtual]

DEPRECATED Time in seconds how long it takes to go from 0 maxDistance to full maxDistance

Deprecated:
Use ClothingActor::getActorDesc() and read the maxDistanceBlendTime part of it
virtual uint32_t nvidia::apex::ClothingActor::getNumGraphicalVerticesActive ( uint32_t submeshIndex ) const [pure virtual]

Returns the number of the graphical vertices that need to be skinned to the simulation mesh [0, numGraphicalVerticesActive)

The rest must be regularly skinned to bones [numGraphicalVerticesActive, numVertices)

Note:
Only valid after simulate.
virtual uint32_t nvidia::apex::ClothingActor::getNumSimulationVertices ( ) const [pure virtual]

Returns the number of currently simulation vertices.

Note:
This is not to be used for getPhysicalMeshPositions. getNumSimulatedVertices returns the number of actually simulated verts, while getPhysicalMeshPositions returns the complete physical mesh, regardless of the current physical lod
virtual void nvidia::apex::ClothingActor::getPhysicalMeshNormals | ( | void * | buffer,
 |  | uint32_t | byteStride
 | ) |  | [pure virtual]

Returns the current normals of all physics vertices.

This method provides the normals of the currently simulated part of the physics mesh and skins the non-simulated part with the current bone positions.

Note:
This should usually not be needed other than for rendering the physics mesh yourself
Must be called in between Scene::fetchResults and Scene::simulate.
virtual void nvidia::apex::ClothingActor::getPhysicalMeshPositions | ( | void * | buffer,
 |  | uint32_t | byteStride
 | ) |  | [pure virtual]

Returns the current position of all physics vertices.

This method provides the positions of the currently simulated part of the physics mesh and skins the non-simulated part with the current bone positions.

Note:
This should usually not be needed other than for rendering the physics mesh yourself
Must be called in between Scene::fetchResults and Scene::simulate.
virtual PxMat44 nvidia::apex::ClothingActor::getRenderGlobalPose ( ) const [pure virtual]

Returns the transform that needs to be applied to the rendered mesh.

Note:
Only valid after simulate.
virtual const PxVec3* nvidia::apex::ClothingActor::getSimulationNormals ( ) [pure virtual]

Returns a pointer to the internal normals array of the simulated physics mesh Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)

Returns:
Pointer the simulation mesh normals
virtual const PxVec3* nvidia::apex::ClothingActor::getSimulationPositions ( ) [pure virtual]

Returns a pointer to the internal positions array of the simulated physics mesh Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)

Returns:
Pointer the simulation mesh positions
virtual bool nvidia::apex::ClothingActor::getSimulationVelocities ( PxVec3 * velocities ) [pure virtual]

Writes the current velocities of the simulated vertices into the provided array. A buffer of getNumSimulationVertices() PxVec3's needs to be provided. The function cannot be called during simulation. Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)

Returns:
true if a simulation is available and the velocities have been written
virtual bool nvidia::apex::ClothingActor::isHalfPrecisionAllowed ( ) const [pure virtual]

return whether GPU solver can use half precision for storing positions.

Note:
If allowed half precision will be activated only when actors cannot be fitted to shared memory with float precision.
virtual bool nvidia::apex::ClothingActor::rayCast | ( | const PxVec3 & | worldOrigin,
 |  | const PxVec3 & | worldDirection,
 |  | float & | time,
 |  | PxVec3 & | normal,
 |  | uint32_t & | vertexIndex
 | ) |  | [pure virtual]

Raycasts against the ClothingActor.

Parameters:
[in] | worldOrigin | The world ray's origin
[in] | worldDirection | The world ray's direction, needs not to be normalized
[out] | time | Impact time
[out] | normal | Impact normal in world space
[out] | vertexIndex | Vertex index that was hit
Returns:
true if this actor is hit
virtual void nvidia::apex::ClothingActor::setGraphicalLOD ( uint32_t lod ) [pure virtual]

sets the graphical Lod This chooses the graphical mesh of all the meshes stored in the asset to be rendered. It has to be set before the simulate call to take effect for the next time the actor is rendered. Otherwise, the given value will be buffered and used as soon as possible.

Parameters:
[in] lod lod used to render the mesh
Note:
It is safe to call this even during simulation
virtual void nvidia::apex::ClothingActor::setHalfPrecision ( bool isAllowed ) [pure virtual]

allow GPU solver to use half precision for storing positions.

Note:
This option will be activated only when actors cannot be fitted to shared memory with float precision. Be aware half precision might be insufficient for some cloth simulation. Especially simulation with extensive self collisions sensitive to precision.
Parameters:
[in] isAllowed true - allow GPU solver to use half precision, false - don't allow
virtual void nvidia::apex::ClothingActor::setMaxDistanceBlendTime ( float blendTime ) [pure virtual]

DEPRECATED Time in seconds how long it takes to go from 0 maxDistance to full maxDistance

Deprecated:
Use ClothingActor::getActorDesc() and modify the maxDistanceBlendTime part of it Default: 1.0
Note:
This also influences how quickly different physical LoDs can be switched
It is safe to call this even during simulation.
virtual void nvidia::apex::ClothingActor::setVisible ( bool enable ) [pure virtual]

Tells the actor if it will be rendered or not. If an actor is simulated, but not rendered, some computations (skinning, normal and tangent calculation) doesn't need to be done.

disabling is set immediately, disabling is buffered for the next frame.

virtual void nvidia::apex::ClothingActor::setWind | ( | float | windAdaption,
 |  | const PxVec3 & | windVelocity
 | ) |  | [pure virtual]

Sets the wind strength and direction, can be called any time.

Deprecated:
Use ClothingActor::getActorDesc() and modify the wind part of it
Parameters:
[in] | windAdaption | The rate of adaption. The higher this value, the faster the cloth reaches the wind velocity. Set to 0 to turn off wind
[in] | windVelocity | The target velocity each vertex tries to achieve.
Note:
It is safe to call this even during simulation, but it will only have an effect after the next call to Scene::simulate()
virtual void nvidia::apex::ClothingActor::updateMaxDistanceScale | ( | float | scale,
 |  | bool | multipliable
 | ) |  | [pure virtual]

Change the max distance of all active vertices with a scalar parameter.

Parameters:
[in] | scale | Must be in [0,1] range
[in] | multipliable | Setting to define how the scale is applied. True will multiply the scale on top of the max distance, False will subtract the maximum max distance.
virtual void nvidia::apex::ClothingActor::updateState | ( | const PxMat44 & | globalPose,
 |  | const PxMat44 * | newBoneMatrices,
 |  | uint32_t | boneMatricesByteStride,
 |  | uint32_t | numBoneMatrices,
 |  | ClothingTeleportMode::Enum | teleportMode
 | ) |  | [pure virtual]

Updates all internal bone matrices. This should be called with updated information before apex scenes start simulating.

Parameters:
[in] | globalPose | The new location of the actor
[in] | newBoneMatrices | Pointer to the array of transformations that contain the composite bone transformations for the current frame
[in] | boneMatricesByteStride | stride of the bone matrices, must be bigger than sizeof(PxMat44)
[in] | numBoneMatrices | number of bone matrices available. This should correspond with the number of bones present in the asset
[in] | teleportMode | Setting this to anything but TM_Continuous will force apply a teleport and optionally a reset.
Note:
This must be called before Scene::simulate is called
The documentation for this class was generated from the following file:
  • ClothingActor.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingActor
nvidia::apex::ClothingActor Member List
This is the complete list of members for nvidia::apex::ClothingActor, including all inherited members.
acquireRenderProxy()=0 | nvidia::apex::ClothingActor | [pure virtual]
attachVertexToGlobalPosition(uint32_t vertexIndex, const PxVec3 &globalPosition)=0 | nvidia::apex::ClothingActor | [pure virtual]
createCollisionCapsule(ClothingSphere &sphere1, ClothingSphere &sphere2)=0 | nvidia::apex::ClothingActor | [pure virtual]
createCollisionConvex(ClothingPlane **planes, uint32_t numPlanes)=0 | nvidia::apex::ClothingActor | [pure virtual]
createCollisionPlane(const PxPlane &plane)=0 | nvidia::apex::ClothingActor | [pure virtual]
createCollisionSphere(const PxVec3 &position, float radius)=0 | nvidia::apex::ClothingActor | [pure virtual]
createCollisionTriangleMesh()=0 | nvidia::apex::ClothingActor | [pure virtual]
freeVertex(uint32_t vertexIndex)=0 | nvidia::apex::ClothingActor | [pure virtual]
getActorDesc()=0 | nvidia::apex::ClothingActor | [pure virtual]
getClothingMaterial() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getClothSolverMode() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getCurrentBoneSkinningMatrices() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getGlobalPose() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getGraphicalLod()=0 | nvidia::apex::ClothingActor | [pure virtual]
getMaxDistanceBlendTime() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getMaximumSimulationBudget() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getNumGraphicalVerticesActive(uint32_t submeshIndex) const =0 | nvidia::apex::ClothingActor | [pure virtual]
getNumSimulationVertices() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getPhysicalMeshNormals(void *buffer, uint32_t byteStride)=0 | nvidia::apex::ClothingActor | [pure virtual]
getPhysicalMeshPositions(void *buffer, uint32_t byteStride)=0 | nvidia::apex::ClothingActor | [pure virtual]
getRenderGlobalPose() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getSimulationNormals()=0 | nvidia::apex::ClothingActor | [pure virtual]
getSimulationPositions()=0 | nvidia::apex::ClothingActor | [pure virtual]
getSimulationVelocities(PxVec3 *velocities)=0 | nvidia::apex::ClothingActor | [pure virtual]
isFrozen() const =0 | nvidia::apex::ClothingActor | [pure virtual]
isHalfPrecisionAllowed() const =0 | nvidia::apex::ClothingActor | [pure virtual]
isVisible() const =0 | nvidia::apex::ClothingActor | [pure virtual]
rayCast(const PxVec3 &worldOrigin, const PxVec3 &worldDirection, float &time, PxVec3 &normal, uint32_t &vertexIndex)=0 | nvidia::apex::ClothingActor | [pure virtual]
setClothingMaterial(uint32_t index)=0 | nvidia::apex::ClothingActor | [pure virtual]
setFrozen(bool enable)=0 | nvidia::apex::ClothingActor | [pure virtual]
setGraphicalLOD(uint32_t lod)=0 | nvidia::apex::ClothingActor | [pure virtual]
setHalfPrecision(bool isAllowed)=0 | nvidia::apex::ClothingActor | [pure virtual]
setMaxDistanceBlendTime(float blendTime)=0 | nvidia::apex::ClothingActor | [pure virtual]
setOverrideMaterial(uint32_t submeshIndex, const char *overrideMaterialName)=0 | nvidia::apex::ClothingActor | [pure virtual]
setVelocityCallback(ClothingVelocityCallback *callback)=0 | nvidia::apex::ClothingActor | [pure virtual]
setVisible(bool enable)=0 | nvidia::apex::ClothingActor | [pure virtual]
setWind(float windAdaption, const PxVec3 &windVelocity)=0 | nvidia::apex::ClothingActor | [pure virtual]
updateMaxDistanceScale(float scale, bool multipliable)=0 | nvidia::apex::ClothingActor | [pure virtual]
updateState(const PxMat44 &globalPose, const PxMat44 *newBoneMatrices, uint32_t boneMatricesByteStride, uint32_t numBoneMatrices, ClothingTeleportMode::Enum teleportMode)=0 | nvidia::apex::ClothingActor | [pure virtual]
~ClothingActor() (defined in nvidia::apex::ClothingActor) | nvidia::apex::ClothingActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingAsset Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingAsset
Public Member Functions
nvidia::apex::ClothingAsset Class Reference

A clothing asset. It contains all the static and shared data for a given piece of clothing. More...

#include <ClothingAsset.h>

List of all members.

Public Member Functions

virtual uint32_t | getNumActors () const =0
Returns the number of ClothingActors this asset has created.
virtual ClothingActor * | getActor (uint32_t index)=0
Returns the index'th ClothingActor.
virtual PxBounds3 | getBoundingBox () const =0
Returns the bounding box for the asset.
virtual uint32_t | getNumGraphicalLodLevels () const =0
returns the number of LOD levels present in this asset
virtual uint32_t | getGraphicalLodValue (uint32_t lodLevel) const =0
returns the actual LOD value of any particular level, normally this is just the identity map
virtual float | getBiggestMaxDistance () const =0
returns the biggest max distance of any vertex in any physical mesh
virtual ClothSolverMode::Enum | getClothSolverMode () const =0
returns for which solver the asset has been cooked for.
virtual bool | remapBoneIndex (const char *name, uint32_t newIndex)=0
remaps bone with given name to a new index for updateState calls
virtual uint32_t | getNumBones () const =0
Returns the number of bones.
virtual uint32_t | getNumUsedBones () const =0
Returns the number of bones that are actually used. They are the first ones internally.
virtual const char * | getBoneName (uint32_t internalIndex) const =0
Returns the name of the bone at the given internal index.
virtual bool | getBoneBasePose (uint32_t internalIndex, PxMat44 &result) const =0
Returns the bind pose transform for this bone.
virtual void | getBoneMapping (uint32_t *internal2externalMap) const =0
returns the mapping from internal to external indices for a given asset.
virtual const RenderMeshAsset * | getRenderMeshAsset (uint32_t lodLevel) const =0
Gets the RenderMeshAsset associated with this asset.
virtual uint32_t | prepareMorphTargetMapping (const PxVec3 *originalPositions, uint32_t numPositions, float epsilon)=0
Prepares the asset for use with morph target.
virtual uint32_t | getMeshSkinningMapSize (uint32_t lod)=0
Returns the size of the mesh skinning map.
virtual void | getMeshSkinningMap (uint32_t lod, ClothingMeshSkinningMap *map)=0
Provides the mesh to mesh skinning map.
virtual bool | releaseGraphicalData ()=0
Releases all data needed to compute render data in apex clothing.

Detailed Description

A clothing asset. It contains all the static and shared data for a given piece of clothing.

Member Function Documentation

virtual void nvidia::apex::ClothingAsset::getBoneMapping ( uint32_t * internal2externalMap ) const [pure virtual]

returns the mapping from internal to external indices for a given asset.

Use this map to transform all the boneIndices returned from the ClothingPhysicalMesh into the order you specified initially

virtual void nvidia::apex::ClothingAsset::getMeshSkinningMap | ( | uint32_t | lod,
 |  | ClothingMeshSkinningMap * | map
 | ) |  | [pure virtual]

Provides the mesh to mesh skinning map.

This map stores for each graphics mesh vertex the corresponding triangle indices of the physics mesh and barycentric coordinates to skin the vertex position, normal and tangent.

Note:
This call has the side effect of merging the immediate map into the mesh skinning map. This might affect skinning performance done by APEX.
Parameters:
[in] | lod | lod for which the map is requested
[out] | map | Skinning map
virtual uint32_t nvidia::apex::ClothingAsset::getMeshSkinningMapSize ( uint32_t lod ) [pure virtual]

Returns the size of the mesh skinning map.

Note:
This call has the side effect of merging the immediate map into the mesh skinning map. This might affect skinning performance done by APEX.
Returns:
Number of entries in the map
virtual const RenderMeshAsset* nvidia::apex::ClothingAsset::getRenderMeshAsset ( uint32_t lodLevel ) const [pure virtual]

Gets the RenderMeshAsset associated with this asset.

Parameters:
[in] lodLevel The LoD level of the render mesh asset
Returns:
NULL if lodLevel is not valid
See also:
ClothingAsset::getNumGraphicalLodLevels()
virtual uint32_t nvidia::apex::ClothingAsset::prepareMorphTargetMapping | ( | const PxVec3 * | originalPositions,
 |  | uint32_t | numPositions,
 |  | float | epsilon
 | ) |  | [pure virtual]

Prepares the asset for use with morph target.

When setting morph target displacements, the asset needs to create a mapping of external to internal vertex order. These positions will be matched with the internal mesh positions with a smallest distance criterion.

Parameters:
[in] | originalPositions | Array of positions before the morphing is applied.
[in] | numPositions | Length of the Array
[in] | epsilon | Difference two vertices can have before being reported
Returns:
Number of vertices for which the distance to the next originalPosition was larger than epsilon
virtual bool nvidia::apex::ClothingAsset::remapBoneIndex | ( | const char * | name,
 |  | uint32_t | newIndex
 | ) |  | [pure virtual]

remaps bone with given name to a new index for updateState calls

This is needed when the order of bones differs from authoring tool to runtime

Note:
must be called after asset is deserialized. Changing this any later, especially after the first ClothingActor::updateState call will lead to ill-defined behavior.
The documentation for this class was generated from the following file:
  • ClothingAsset.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingAsset
nvidia::apex::ClothingAsset Member List
This is the complete list of members for nvidia::apex::ClothingAsset, including all inherited members.
getActor(uint32_t index)=0 | nvidia::apex::ClothingAsset | [pure virtual]
getBiggestMaxDistance() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getBoneBasePose(uint32_t internalIndex, PxMat44 &result) const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getBoneMapping(uint32_t *internal2externalMap) const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getBoneName(uint32_t internalIndex) const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getBoundingBox() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getClothSolverMode() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getGraphicalLodValue(uint32_t lodLevel) const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getMeshSkinningMap(uint32_t lod, ClothingMeshSkinningMap *map)=0 | nvidia::apex::ClothingAsset | [pure virtual]
getMeshSkinningMapSize(uint32_t lod)=0 | nvidia::apex::ClothingAsset | [pure virtual]
getNumActors() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getNumBones() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getNumGraphicalLodLevels() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getNumUsedBones() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getRenderMeshAsset(uint32_t lodLevel) const =0 | nvidia::apex::ClothingAsset | [pure virtual]
prepareMorphTargetMapping(const PxVec3 *originalPositions, uint32_t numPositions, float epsilon)=0 | nvidia::apex::ClothingAsset | [pure virtual]
releaseGraphicalData()=0 | nvidia::apex::ClothingAsset | [pure virtual]
remapBoneIndex(const char *name, uint32_t newIndex)=0 | nvidia::apex::ClothingAsset | [pure virtual]
~ClothingAsset() (defined in nvidia::apex::ClothingAsset) | nvidia::apex::ClothingAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingAssetAuthoring Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingAssetAuthoring
Public Member Functions
nvidia::apex::ClothingAssetAuthoring Class Reference

The clothing authoring asset. This is used to generate streams that can then be deserialized into a regular asset. More...

#include <ClothingAssetAuthoring.h>

List of all members.

Public Member Functions

virtual void | setDefaultConstrainCoefficients (const ClothingConstrainCoefficients &coeff)=0
set the default value for all coefficients if none is available
virtual void | setInvalidConstrainCoefficients (const ClothingConstrainCoefficients &coeff)=0
set the value which is considered invalid when painting
virtual void | setMeshes (uint32_t lod, RenderMeshAssetAuthoring *graphicalMesh, ClothingPhysicalMesh *physicalMesh, float normalResemblance=25, bool ignoreUnusedVertices=true, IProgressListener *progress=NULL)=0
Sets the graphical and physical mesh for the given graphical lod level.
virtual bool | addPlatformToGraphicalLod (uint32_t lod, PlatformTag platform)=0
Assigns a platform tag to a graphical lod.
virtual bool | removePlatform (uint32_t lod, PlatformTag platform)=0
Removes a platform tag from a graphical lod.
virtual uint32_t | getNumPlatforms (uint32_t lod) const =0
Get number of platform tags for a given lod.
virtual PlatformTag | getPlatform (uint32_t lod, uint32_t i) const =0
Get i-th platform tag of given lod;.
virtual uint32_t | getNumLods () const =0
Returns the number of LoDs that have been set in the ClothingAssetAuthoring::setMeshes call.
virtual int32_t | getLodValue (uint32_t lod) const =0
Returns the n-th LoD value from the ClothingAssetAuthoring::setMeshes call.
virtual void | clearMeshes ()=0
Clears all lods and meshes.
virtual ClothingPhysicalMesh * | getClothingPhysicalMesh (uint32_t graphicalLod) const =0
Returns a reference to the internal copy of the physical mesh for the given graphical lod. Returned object MUST be destroyed by the user immediately after use.
virtual void | setBoneInfo (uint32_t boneIndex, const char *boneName, const PxMat44 &bindPose, int32_t parentIndex)=0
assigns name and bindpose to a bone. This needs to be called for every bone at least once
virtual void | setRootBone (const char *boneName)=0
Specifies the root bone.
virtual uint32_t | addBoneConvex (const char *boneName, const PxVec3 *positions, uint32_t numPositions)=0
add a convex collision representation to a bone, vertices must be in bone-bind-pose space!
virtual uint32_t | addBoneConvex (uint32_t boneIndex, const PxVec3 *positions, uint32_t numPositions)=0
add a convex collision representation to a bone, vertices must be in bone-bind-pose space!
virtual void | addBoneCapsule (const char *boneName, float capsuleRadius, float capsuleHeight, const PxMat44 &localPose)=0
add a capsule to the bone's collision. all relative to bone-bind-pose space!
virtual void | addBoneCapsule (uint32_t boneIndex, float capsuleRadius, float capsuleHeight, const PxMat44 &localPose)=0
add a capsule to the bone's collision. all relative to bone-bind-pose space!
virtual void | clearBoneActors (const char *boneName)=0
clear all collision information for a given bone name
virtual void | clearBoneActors (uint32_t boneIndex)=0
clear all collision information for a given bone index
virtual void | clearAllBoneActors ()=0
clear all collision information for any bone
virtual void | setCollision (const char **boneNames, float *radii, PxVec3 *localPositions, uint32_t numSpheres, uint16_t *pairs, uint32_t numIndices)=0
Set up the collision volumes for PhysX3. The boneNames, radii and localPositions array need to be of size numSpheres, each triplet describes a sphere that is attached to a bone. The pairs array describes connections between pairs of spheres. It defines capsules with 2 radii.
virtual void | setCollision (uint32_t *boneIndices, float *radii, PxVec3 *localPositions, uint32_t numSpheres, uint16_t *pairs, uint32_t numIndices)=0
Set up the collision volumes for PhysX3.
virtual void | clearCollision ()=0
Clear the collision volumes for PhysX3.
virtual void | setSimulationHierarchicalLevels (uint32_t levels)=0
Number of hierarchical levels. 0 to turn off.
virtual void | setSimulationThickness (float thickness)=0
The radius of the cloth/softbody particles.
virtual void | setSimulationVirtualParticleDensity (float density)=0
The amount of virtual particles created. 0 means none, 1 means 2 or 3 per triangle.
virtual void | setSimulationSleepLinearVelocity (float sleep)=0
The sleep velocity. If all vertices of a cloth/softbody are below this velocity for some time, it falls asleep.
virtual void | setSimulationGravityDirection (const PxVec3 &gravity)=0
The direction of gravity. Can be used for cooking.
virtual void | setSimulationDisableCCD (bool disable)=0
Turn off Continuous collision detection for clothing.
virtual void | setSimulationTwowayInteraction (bool enable)=0
Turns on twoway interaction with rigid body. Only of limited use for clothing.
virtual void | setSimulationUntangling (bool enable)=0
EXPERIMENTAL: Turns on local untangling.
virtual void | setSimulationRestLengthScale (float scale)=0
The scale of the cloth rest length.
virtual void | setExportScale (float scale)=0
Provide a scaling to the serialize functionality.
virtual void | applyTransformation (const PxMat44 &transformation, float scale, bool applyToGraphics, bool applyToPhysics)=0
Apply an arbitrary transformation to either the physical, the graphical mesh or both.
virtual void | updateBindPoses (const PxMat44 *newBindPoses, uint32_t newBindPosesCount, bool isInternalOrder, bool maintainCollisionWorldSpace)=0
Move every bone bind pose to a new position.
virtual void | setDeriveNormalsFromBones (bool enable)=0
If enabled, the normals of the physical mesh are derived from the directions of the physical vertex to the bind poses of the assigned bones.
virtual
NvParameterized::Interface * 		getMaterialLibrary ()=0
Returns the material interface.
virtual bool | setMaterialLibrary (NvParameterized::Interface *materialLibrary, uint32_t materialIndex, bool transferOwnership)=0
Adds a new material library to the asset.
virtual
::NvParameterized::Interface * 		getRenderMeshAssetAuthoring (uint32_t lodLevel) const =0
Gets the parameterized render mesh associated with this asset.
virtual bool | getBoneBindPose (uint32_t boneIndex, PxMat44 &bindPose) const =0
Retrieves the bind pose transform of this bone.
virtual bool | setBoneBindPose (uint32_t boneIndex, const PxMat44 &bindPose)=0
Directly sets the bind pose transform of this bone.

Detailed Description

The clothing authoring asset. This is used to generate streams that can then be deserialized into a regular asset.

Member Function Documentation

virtual void nvidia::apex::ClothingAssetAuthoring::addBoneCapsule | ( | const char * | boneName,
 |  | float | capsuleRadius,
 |  | float | capsuleHeight,
 |  | const PxMat44 & | localPose
 | ) |  | [pure virtual]

add a capsule to the bone's collision. all relative to bone-bind-pose space!

Parameters:
[in] | boneName | name of the bone this collision info is for.
[in] | capsuleRadius | The radius of the capsule. if set to 0, bone collision will default back to convex
[in] | capsuleHeight | The height of the capsule
[in] | localPose | The frame of the capsule relative to the frame of the bone (not world space)
virtual void nvidia::apex::ClothingAssetAuthoring::addBoneCapsule | ( | uint32_t | boneIndex,
 |  | float | capsuleRadius,
 |  | float | capsuleHeight,
 |  | const PxMat44 & | localPose
 | ) |  | [pure virtual]

add a capsule to the bone's collision. all relative to bone-bind-pose space!

Parameters:
[in] | boneIndex | index of the bone this collision info is for.
[in] | capsuleRadius | if set to 0, bone collision will default back to convex
[in] | capsuleHeight | The height of the capsule
[in] | localPose | The frame of the capsule relative to the frame of the bone (not world space)
virtual uint32_t nvidia::apex::ClothingAssetAuthoring::addBoneConvex | ( | const char * | boneName,
 |  | const PxVec3 * | positions,
 |  | uint32_t | numPositions
 | ) |  | [pure virtual]

add a convex collision representation to a bone, vertices must be in bone-bind-pose space!

Parameters:
[in] | boneName | name of the bone this collision info is for.
[in] | positions | array of vertices with the positions.
[in] | numPositions | number of elements in positions array. if set to 0, bone collision will be capsule.
virtual uint32_t nvidia::apex::ClothingAssetAuthoring::addBoneConvex | ( | uint32_t | boneIndex,
 |  | const PxVec3 * | positions,
 |  | uint32_t | numPositions
 | ) |  | [pure virtual]

add a convex collision representation to a bone, vertices must be in bone-bind-pose space!

Parameters:
[in] | boneIndex | index of the bone this collision info is for.
[in] | positions | array of vertices with the positions.
[in] | numPositions | number of elements in positions array. if set to 0, bone collision will be capsule.
virtual void nvidia::apex::ClothingAssetAuthoring::applyTransformation | ( | const PxMat44 & | transformation,
 |  | float | scale,
 |  | bool | applyToGraphics,
 |  | bool | applyToPhysics
 | ) |  | [pure virtual]

Apply an arbitrary transformation to either the physical, the graphical mesh or both.

This is a permanent transformation and it changes the object state. Should only be called immediately before serialization and without further modifying the object later on.

Parameters:
transformation | This matrix is allowed to contain a translation and a rotation.
scale | Apply a uniform scaling as well
applyToGraphics | Apply the transformation and scale to the graphical part of the asset
applyToPhysics | Apply the transformation and scale to the physical part of the asset
Note:
if the 3x3 part of the transformation parameter contains mirroring of axis (= negative determinant) some additional processing is done. This includes flipping of simulation triangles and adaption of the mesh-mesh skinning.
virtual int32_t nvidia::apex::ClothingAssetAuthoring::getLodValue ( uint32_t lod ) const [pure virtual]

Returns the n-th LoD value from the ClothingAssetAuthoring::setMeshes call.

Note:
These values do not have to be a continuous list
virtual ::NvParameterized::Interface* nvidia::apex::ClothingAssetAuthoring::getRenderMeshAssetAuthoring ( uint32_t lodLevel ) const [pure virtual]

Gets the parameterized render mesh associated with this asset.

Parameters:
[in] lodLevel The LoD level of the render mesh asset
Returns:
NULL if lodLevel is not valid
See also:
ClothingAssetAuthoring::getNumLods()
Note:
Under no circumstances you should modify the positions of the render mesh asset's vertices. This will certainly break clothing
virtual void nvidia::apex::ClothingAssetAuthoring::setBoneInfo | ( | uint32_t | boneIndex,
 |  | const char * | boneName,
 |  | const PxMat44 & | bindPose,
 |  | int32_t | parentIndex
 | ) |  | [pure virtual]

assigns name and bindpose to a bone. This needs to be called for every bone at least once

Parameters:
[in] | boneIndex | The bone index the information is provided for.
[in] | boneName | The bone name. An internal copy of this string will be made.
[in] | bindPose | The bind or rest pose of this bone.
[in] | parentIndex | The bone index of the parent bone, -1 for root bones.
virtual void nvidia::apex::ClothingAssetAuthoring::setCollision | ( | const char ** | boneNames,
 |  | float * | radii,
 |  | PxVec3 * | localPositions,
 |  | uint32_t | numSpheres,
 |  | uint16_t * | pairs,
 |  | uint32_t | numIndices
 | ) |  | [pure virtual]

Set up the collision volumes for PhysX3. The boneNames, radii and localPositions array need to be of size numSpheres, each triplet describes a sphere that is attached to a bone. The pairs array describes connections between pairs of spheres. It defines capsules with 2 radii.

Parameters:
[in] | boneNames | names of the bones to which a spheres are added
[in] | radii | radii of the spheres
[in] | localPositions | sphere positions relative to the bone
[in] | numSpheres | number of spheres that are being defined
[in] | pairs | pairs of indices that reference 2 spheres to define a capsule with 2 radii
[in] | numIndices | size of the pairs array
virtual void nvidia::apex::ClothingAssetAuthoring::setExportScale ( float scale ) [pure virtual]

Provide a scaling to the serialize functionality.

This is useful when the game runs in a different scale than the tool this asset was created in

Deprecated:
Only works with deprecated serialization, use applyTransformation instead!
virtual bool nvidia::apex::ClothingAssetAuthoring::setMaterialLibrary | ( | NvParameterized::Interface * | materialLibrary,
 |  | uint32_t | materialIndex,
 |  | bool | transferOwnership
 | ) |  | [pure virtual]

Adds a new material library to the asset.

Parameters:
[in] | materialLibrary | User-generated material library object.
[in] | materialIndex | Default value for the Actor to know which material to use in the library
[in] | transferOwnership | Hands ownership to the authoring asset.
virtual void nvidia::apex::ClothingAssetAuthoring::setMeshes | ( | uint32_t | lod,
 |  | RenderMeshAssetAuthoring * | graphicalMesh,
 |  | ClothingPhysicalMesh * | physicalMesh,
 |  | float | normalResemblance = 25,
 |  | bool | ignoreUnusedVertices = true,
 |  | IProgressListener * | progress = NULL
 | ) |  | [pure virtual]

Sets the graphical and physical mesh for the given graphical lod level.

Parameters:
[in] | lod | Identifier for that lod level.
[in] | graphicalMesh | The graphical mesh to be rendered in that lod level.
[in] physicalMesh The physical mesh to be simulated on that lod level. The reference to the same physical mesh can be given for different graphical lods. It is copied internally.
Note: If the same physical mesh is used several time, the paint values are copied from the graphical mesh the first time the physical mesh is passed in here.
[in] | normalResemblance | This angle (in degrees) specifies how similar the normal from the physical and graphical mesh need to be in order for them to be accepted as immediate mode skinning pairs. Use 90 or bigger for any resemblance. Must be in range (0, 90], but it's highly recommended to use more than 5 degrees.
[in] | ignoreUnusedVertices | All Vertices that have the 'usedForPhysics' property set to false will be ignored when transferring the painted values from the graphical to the physical mesh
[in] | progress | Progress bar callback class.
virtual void nvidia::apex::ClothingAssetAuthoring::setRootBone ( const char * boneName ) [pure virtual]

Specifies the root bone.

Parameters:
[in] boneName The bone name.
virtual void nvidia::apex::ClothingAssetAuthoring::setSimulationDisableCCD ( bool disable ) [pure virtual]

Turn off Continuous collision detection for clothing.

Fast moving objects can cause massive forces to the cloth, especially when some kinematic actors move large distances within one frame. Without CCD those collisions are not detected and thus don't influence the cloth.

Note:
Whenever the isContinuous parameter in ClothingActor::updateState is set to false, cloth CCD will be temporarily disabled as well
virtual void nvidia::apex::ClothingAssetAuthoring::setSimulationHierarchicalLevels ( uint32_t levels ) [pure virtual]

Number of hierarchical levels. 0 to turn off.

If either the hierarchical solver iterations or the hierarchical levels are set to 0, this feature is turned off

virtual void nvidia::apex::ClothingAssetAuthoring::setSimulationUntangling ( bool enable ) [pure virtual]

EXPERIMENTAL: Turns on local untangling.

See also:
CLF_UNTANGLING
virtual void nvidia::apex::ClothingAssetAuthoring::updateBindPoses | ( | const PxMat44 * | newBindPoses,
 |  | uint32_t | newBindPosesCount,
 |  | bool | isInternalOrder,
 |  | bool | maintainCollisionWorldSpace
 | ) |  | [pure virtual]

Move every bone bind pose to a new position.

Parameters:
newBindPoses | array of matrices for the new bind poses. This must be in object space (not relative to the parent bone!)
newBindPosesCount | number of matrices in the specified array
isInternalOrder | using internal numbering or external numbering?
maintainCollisionWorldSpace | The collision volumes do not move to the new bone bind pose
The documentation for this class was generated from the following file:
  • ClothingAssetAuthoring.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingAssetAuthoring
nvidia::apex::ClothingAssetAuthoring Member List
This is the complete list of members for nvidia::apex::ClothingAssetAuthoring, including all inherited members.
addBoneCapsule(const char *boneName, float capsuleRadius, float capsuleHeight, const PxMat44 &localPose)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
addBoneCapsule(uint32_t boneIndex, float capsuleRadius, float capsuleHeight, const PxMat44 &localPose)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
addBoneConvex(const char *boneName, const PxVec3 *positions, uint32_t numPositions)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
addBoneConvex(uint32_t boneIndex, const PxVec3 *positions, uint32_t numPositions)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
addPlatformToGraphicalLod(uint32_t lod, PlatformTag platform)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
applyTransformation(const PxMat44 &transformation, float scale, bool applyToGraphics, bool applyToPhysics)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
clearAllBoneActors()=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
clearBoneActors(const char *boneName)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
clearBoneActors(uint32_t boneIndex)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
clearCollision()=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
clearMeshes()=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getBoneBindPose(uint32_t boneIndex, PxMat44 &bindPose) const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getClothingPhysicalMesh(uint32_t graphicalLod) const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getLodValue(uint32_t lod) const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getMaterialLibrary()=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getNumLods() const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getNumPlatforms(uint32_t lod) const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getPlatform(uint32_t lod, uint32_t i) const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getRenderMeshAssetAuthoring(uint32_t lodLevel) const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
removePlatform(uint32_t lod, PlatformTag platform)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setBoneBindPose(uint32_t boneIndex, const PxMat44 &bindPose)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setBoneInfo(uint32_t boneIndex, const char *boneName, const PxMat44 &bindPose, int32_t parentIndex)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setCollision(const char **boneNames, float *radii, PxVec3 *localPositions, uint32_t numSpheres, uint16_t *pairs, uint32_t numIndices)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setCollision(uint32_t *boneIndices, float *radii, PxVec3 *localPositions, uint32_t numSpheres, uint16_t *pairs, uint32_t numIndices)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setDefaultConstrainCoefficients(const ClothingConstrainCoefficients &coeff)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setDeriveNormalsFromBones(bool enable)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setExportScale(float scale)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setInvalidConstrainCoefficients(const ClothingConstrainCoefficients &coeff)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setMaterialLibrary(NvParameterized::Interface *materialLibrary, uint32_t materialIndex, bool transferOwnership)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setMeshes(uint32_t lod, RenderMeshAssetAuthoring *graphicalMesh, ClothingPhysicalMesh *physicalMesh, float normalResemblance=25, bool ignoreUnusedVertices=true, IProgressListener *progress=NULL)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setRootBone(const char *boneName)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationDisableCCD(bool disable)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationGravityDirection(const PxVec3 &gravity)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationHierarchicalLevels(uint32_t levels)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationRestLengthScale(float scale)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationSleepLinearVelocity(float sleep)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationThickness(float thickness)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationTwowayInteraction(bool enable)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationUntangling(bool enable)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationVirtualParticleDensity(float density)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
updateBindPoses(const PxMat44 *newBindPoses, uint32_t newBindPosesCount, bool isInternalOrder, bool maintainCollisionWorldSpace)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingCapsule Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingCapsule
Public Member Functions
nvidia::apex::ClothingCapsule Class Reference

Capsule collision of a clothing actor. More...

#include <ClothingCollision.h>

Inheritance diagram for nvidia::apex::ClothingCapsule:
nvidia::apex::ClothingCollision

List of all members.

Public Member Functions

virtual ClothingSphere ** | getSpheres ()=0
Returns the pointers to the two spheres that represent this capsule.
virtual void | releaseWithSpheres ()=0
Releases this sphere and its two spheres.

Detailed Description

Capsule collision of a clothing actor.

A capsule is represented by two ClothingSpheres.

Member Function Documentation

virtual void nvidia::apex::ClothingCapsule::releaseWithSpheres ( ) [pure virtual]

Releases this sphere and its two spheres.

Note:
Only use releaseWithSpheres if the 2 spheres are used exclusively by this capsule. Spheres referenced by other convexes will not be released.
The documentation for this class was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingCapsule
nvidia::apex::ClothingCapsule Member List
This is the complete list of members for nvidia::apex::ClothingCapsule, including all inherited members.
getSpheres()=0 | nvidia::apex::ClothingCapsule | [pure virtual]
getType() const =0 | nvidia::apex::ClothingCollision | [pure virtual]
isCapsule()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isConvex()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isPlane()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isSphere()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isTriangleMesh()=0 | nvidia::apex::ClothingCollision | [pure virtual]
releaseWithSpheres()=0 | nvidia::apex::ClothingCapsule | [pure virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingCollision Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingCollision
Public Member Functions
nvidia::apex::ClothingCollision Class Reference

Base class of all clothing collision types. More...

#include <ClothingCollision.h>

Inheritance diagram for nvidia::apex::ClothingCollision:
nvidia::apex::ClothingCapsule nvidia::apex::ClothingConvex nvidia::apex::ClothingPlane nvidia::apex::ClothingSphere nvidia::apex::ClothingTriangleMesh

List of all members.

Public Member Functions

virtual ClothingCollisionType::Enum | getType () const =0
Returns the Type of this collision object.
virtual ClothingPlane * | isPlane ()=0
Returns the pointer to this object if it is a plane, NULL otherwise.
virtual ClothingConvex * | isConvex ()=0
Returns the pointer to this object if it is a convex, NULL otherwise.
virtual ClothingSphere * | isSphere ()=0
Returns the pointer to this object if it is a sphere, NULL otherwise.
virtual ClothingCapsule * | isCapsule ()=0
Returns the pointer to this object if it is a capsule, NULL otherwise.
virtual ClothingTriangleMesh * | isTriangleMesh ()=0
Returns the pointer to this object if it is a triangle mesh, NULL otherwise.

Detailed Description

Base class of all clothing collision types.

The documentation for this class was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingCollision
nvidia::apex::ClothingCollision Member List
This is the complete list of members for nvidia::apex::ClothingCollision, including all inherited members.
getType() const =0 | nvidia::apex::ClothingCollision | [pure virtual]
isCapsule()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isConvex()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isPlane()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isSphere()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isTriangleMesh()=0 | nvidia::apex::ClothingCollision | [pure virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingConvex Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingConvex
Public Member Functions
nvidia::apex::ClothingConvex Class Reference

Convex collision of a clothing actor. More...

#include <ClothingCollision.h>

Inheritance diagram for nvidia::apex::ClothingConvex:
nvidia::apex::ClothingCollision

List of all members.

Public Member Functions

virtual uint32_t | getNumPlanes ()=0
Returns the number of planes that define this convex.
virtual ClothingPlane ** | getPlanes ()=0
Returns pointer to the planes that define this convex.
virtual void | releaseWithPlanes ()=0
Releases this convex and all its planes.

Detailed Description

Convex collision of a clothing actor.

A convex is represented by a list of ClothingPlanes.

Member Function Documentation

virtual void nvidia::apex::ClothingConvex::releaseWithPlanes ( ) [pure virtual]

Releases this convex and all its planes.

Note:
Only use this if the planes are used exclusively by this convex. Planes referenced by other convexes will not be released.
The documentation for this class was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingConvex
nvidia::apex::ClothingConvex Member List
This is the complete list of members for nvidia::apex::ClothingConvex, including all inherited members.
getNumPlanes()=0 | nvidia::apex::ClothingConvex | [pure virtual]
getPlanes()=0 | nvidia::apex::ClothingConvex | [pure virtual]
getType() const =0 | nvidia::apex::ClothingCollision | [pure virtual]
isCapsule()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isConvex()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isPlane()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isSphere()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isTriangleMesh()=0 | nvidia::apex::ClothingCollision | [pure virtual]
releaseWithPlanes()=0 | nvidia::apex::ClothingConvex | [pure virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingPhysicalMesh Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPhysicalMesh
Public Member Functions
nvidia::apex::ClothingPhysicalMesh Class Reference

Holder for a physical mesh, this can be generated through various ways (see single- and multi-layered clothing) or hand crafted. More...

#include <ClothingPhysicalMesh.h>

List of all members.

Public Member Functions

virtual uint32_t | getNumVertices () const =0
returns the number of vertices
virtual uint32_t | getNumSimulatedVertices () const =0
returns the number of simulated vertices
virtual uint32_t | getNumMaxDistance0Vertices () const =0
returns the number of vertices with zero max distance
virtual uint32_t | getNumIndices () const =0
returns the number of indices
virtual uint32_t | getNumSimulatedIndices () const =0
returns the number of simulated indices
virtual void | getIndices (void *indexDestination, uint32_t byteStride, uint32_t numIndices) const =0
writes the indices to a destination buffer
virtual bool | isTetrahedralMesh () const =0
returns whether the mesh is built out of tetrahedra or triangles
virtual void | simplify (uint32_t subdivisions, int32_t maxSteps, float maxError, IProgressListener *progress)=0
This will simplify the current mesh.
virtual void | setGeometry (bool tetraMesh, uint32_t numVertices, uint32_t vertexByteStride, const void *vertices, const uint32_t *driveChannels, uint32_t numIndices, uint32_t indexByteStride, const void *indices)=0
Create a physical mesh from scratch.
virtual bool | getIndices (uint32_t *indices, uint32_t byteStride) const =0
writes the indices into a user specified buffer.
virtual bool | getVertices (PxVec3 *vertices, uint32_t byteStride) const =0
Writes the vertex positions into a user specified buffer.
virtual bool | getNormals (PxVec3 *normals, uint32_t byteStride) const =0
Writes the normals into a user specified buffer.
virtual uint32_t | getNumBonesPerVertex () const =0
Returns the number of bones per vertex.
virtual bool | getBoneIndices (uint16_t *boneIndices, uint32_t byteStride) const =0
Writes the bone indices into a user specified buffer.
virtual bool | getBoneWeights (float *boneWeights, uint32_t byteStride) const =0
Writes the bone weights into a user specified buffer.
virtual void | allocateMasterFlagsBuffer ()=0
Allocates and initializes the drive channels (master flags) of the physics mesh.
virtual uint32_t * | getMasterFlagsBuffer ()=0
Returns the masterFlag buffer pointer in order to edit the values.
virtual void | allocateConstrainCoefficientBuffer ()=0
Allocates and initializes the constrain coefficients of the physics mesh.
virtual
ClothingConstrainCoefficients * 		getConstrainCoefficientBuffer () const =0
Returns the constrain coefficient buffer pointer in order to edit the values.
virtual bool | getConstrainCoefficients (ClothingConstrainCoefficients *coeffs, uint32_t byteStride) const =0
Writes the cloth constrain coefficients into a user specified buffer.
virtual void | getStats (ClothingPhysicalMeshStats &stats) const =0
Returns stats (sizes, counts) for the asset. See ClothingPhysicalMeshStats.

Detailed Description

Holder for a physical mesh, this can be generated through various ways (see single- and multi-layered clothing) or hand crafted.

Member Function Documentation

virtual void nvidia::apex::ClothingPhysicalMesh::allocateConstrainCoefficientBuffer ( ) [pure virtual]

Allocates and initializes the constrain coefficients of the physics mesh.

This allows to set the constrain coefficients like maxDistance directly on the physics mesh. If this is not called by the authoring tool, the constrain coefficients are read from the graphical mesh.

virtual void nvidia::apex::ClothingPhysicalMesh::allocateMasterFlagsBuffer ( ) [pure virtual]

Allocates and initializes the drive channels (master flags) of the physics mesh.

This allows to set the drive channels directly on the physics mesh.

virtual bool nvidia::apex::ClothingPhysicalMesh::getBoneIndices | ( | uint16_t * | boneIndices,
 |  | uint32_t | byteStride
 | ) |  | const [pure virtual]

Writes the bone indices into a user specified buffer.

Returns false if the buffer doesn't exist. The buffer must be bigger than sizeof(uint16_t) * getNumVertices() * getNumBonesPerVertex(). (numBonesPerVertex is the same as in the graphical mesh for LOD 0)

The bytestride is applied only after writing numBonesPerVertex and thus must be >= sizoef(uint16_t) * numBonesPerVertex

virtual bool nvidia::apex::ClothingPhysicalMesh::getBoneWeights | ( | float * | boneWeights,
 |  | uint32_t | byteStride
 | ) |  | const [pure virtual]

Writes the bone weights into a user specified buffer.

Returns false if the buffer doesn't exist. The buffer must be bigger than sizeof(float) * getNumVertices() * getNumBonesPerVertex(). (numBonesPerVertex is the same as in the graphical mesh for LOD 0) The bytestride is applied only after writing numBonesPerVertex and thus must be >= sizoef(float) * numBonesPerVertex

virtual ClothingConstrainCoefficients* nvidia::apex::ClothingPhysicalMesh::getConstrainCoefficientBuffer ( ) const [pure virtual]

Returns the constrain coefficient buffer pointer in order to edit the values.

This allows to set the constrain coefficients like maxDistance directly on the physics mesh.

virtual bool nvidia::apex::ClothingPhysicalMesh::getConstrainCoefficients | ( | ClothingConstrainCoefficients * | coeffs,
 |  | uint32_t | byteStride
 | ) |  | const [pure virtual]

Writes the cloth constrain coefficients into a user specified buffer.

Returns false if the buffer doesn't exist. The buffer must be bigger than sizeof(ClothingConstrainCoefficients) * getNumVertices().

virtual bool nvidia::apex::ClothingPhysicalMesh::getIndices | ( | uint32_t * | indices,
 |  | uint32_t | byteStride
 | ) |  | const [pure virtual]

writes the indices into a user specified buffer.

Returns false if the buffer doesn't exist. The buffer must be bigger than sizeof(uint32_t) * getNumIndices()

virtual void nvidia::apex::ClothingPhysicalMesh::getIndices | ( | void * | indexDestination,
 |  | uint32_t | byteStride,
 |  | uint32_t | numIndices
 | ) |  | const [pure virtual]

writes the indices to a destination buffer

Parameters:
[out] | indexDestination | destination buffer where to write the indices
[in] | byteStride | stride of the destination buffer
[in] | numIndices | number of indices the buffer can hold. This can be smaller than getNumIndices()
virtual uint32_t* nvidia::apex::ClothingPhysicalMesh::getMasterFlagsBuffer ( ) [pure virtual]

Returns the masterFlag buffer pointer in order to edit the values.

This allows to set values directly on the physics mesh.

virtual bool nvidia::apex::ClothingPhysicalMesh::getNormals | ( | PxVec3 * | normals,
 |  | uint32_t | byteStride
 | ) |  | const [pure virtual]

Writes the normals into a user specified buffer.

Returns false if the buffer doesn't exist. The buffer must be bigger than sizeof(PxVec3) * getNumVertices()

virtual bool nvidia::apex::ClothingPhysicalMesh::getVertices | ( | PxVec3 * | vertices,
 |  | uint32_t | byteStride
 | ) |  | const [pure virtual]

Writes the vertex positions into a user specified buffer.

Returns false if the buffer doesn't exist. The buffer must be bigger than sizeof(PxVec3) * getNumVertices()

virtual void nvidia::apex::ClothingPhysicalMesh::setGeometry | ( | bool | tetraMesh,
 |  | uint32_t | numVertices,
 |  | uint32_t | vertexByteStride,
 |  | const void * | vertices,
 |  | const uint32_t * | driveChannels,
 |  | uint32_t | numIndices,
 |  | uint32_t | indexByteStride,
 |  | const void * | indices
 | ) |  | [pure virtual]

Create a physical mesh from scratch.

Overwrites all vertices/indices, and invalidates all misc vertex buffers. vertices must be PxVec3 and indices uint32_t. If driveChannels is NULL, all vertices are assigned to all drive channels (initialized to 0xffffffff)

virtual void nvidia::apex::ClothingPhysicalMesh::simplify | ( | uint32_t | subdivisions,
 |  | int32_t | maxSteps,
 |  | float | maxError,
 |  | IProgressListener * | progress
 | ) |  | [pure virtual]

This will simplify the current mesh.

Parameters:
[in] subdivisions used to derive the maximal length a new edge can get.
Divide the bounding box diagonal by this value to get the maximal edge length for newly created edges
Use 0 to not restrict the maximal edge length
[in] maxSteps The maximum number of edges to be considered for simplification.
Use 0 to turn off
[in] maxError The maximal quadric error an edge can cause to be considered simplifyable.
Use any value < 0 to turn off
[in] progress Callback class that will be fired every now and then to update a progress bar in the gui.
Returns:
The number of edges collapsed
The documentation for this class was generated from the following file:
  • ClothingPhysicalMesh.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPhysicalMesh
nvidia::apex::ClothingPhysicalMesh Member List
This is the complete list of members for nvidia::apex::ClothingPhysicalMesh, including all inherited members.
allocateConstrainCoefficientBuffer()=0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
allocateMasterFlagsBuffer()=0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getBoneIndices(uint16_t *boneIndices, uint32_t byteStride) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getBoneWeights(float *boneWeights, uint32_t byteStride) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getConstrainCoefficientBuffer() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getConstrainCoefficients(ClothingConstrainCoefficients *coeffs, uint32_t byteStride) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getIndices(void *indexDestination, uint32_t byteStride, uint32_t numIndices) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getIndices(uint32_t *indices, uint32_t byteStride) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getMasterFlagsBuffer()=0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNormals(PxVec3 *normals, uint32_t byteStride) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNumBonesPerVertex() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNumIndices() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNumMaxDistance0Vertices() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNumSimulatedIndices() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNumSimulatedVertices() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNumVertices() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getStats(ClothingPhysicalMeshStats &stats) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getVertices(PxVec3 *vertices, uint32_t byteStride) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
isTetrahedralMesh() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
setGeometry(bool tetraMesh, uint32_t numVertices, uint32_t vertexByteStride, const void *vertices, const uint32_t *driveChannels, uint32_t numIndices, uint32_t indexByteStride, const void *indices)=0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
simplify(uint32_t subdivisions, int32_t maxSteps, float maxError, IProgressListener *progress)=0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingPlane Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPlane
Public Member Functions
nvidia::apex::ClothingPlane Class Reference

Plane collision of a clothing actor. More...

#include <ClothingCollision.h>

Inheritance diagram for nvidia::apex::ClothingPlane:
nvidia::apex::ClothingCollision

List of all members.

Public Member Functions

virtual void | setPlane (const PxPlane &plane)=0
Sets the plane equation of the plane.
virtual const PxPlane & | getPlane ()=0
Returns the plane equation of the plane.
virtual uint32_t | getRefCount () const =0
Returns the number of convexes that reference this plane.

Detailed Description

Plane collision of a clothing actor.

The documentation for this class was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPlane
nvidia::apex::ClothingPlane Member List
This is the complete list of members for nvidia::apex::ClothingPlane, including all inherited members.
getPlane()=0 | nvidia::apex::ClothingPlane | [pure virtual]
getRefCount() const =0 | nvidia::apex::ClothingPlane | [pure virtual]
getType() const =0 | nvidia::apex::ClothingCollision | [pure virtual]
isCapsule()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isConvex()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isPlane()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isSphere()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isTriangleMesh()=0 | nvidia::apex::ClothingCollision | [pure virtual]
setPlane(const PxPlane &plane)=0 | nvidia::apex::ClothingPlane | [pure virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingPreview Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPreview
Public Member Functions
nvidia::apex::ClothingPreview Class Reference

A lightweight preview of a ClothingActor that will not perform any simulation. More...

#include <ClothingPreview.h>

List of all members.

Public Member Functions

virtual void updateState (const PxMat44 &globalPose, const PxMat44 *newBoneMatrices, uint32_t boneMatricesByteStride, uint32_t numBoneMatrices)=0
Updates all internal bone matrices.

Detailed Description

A lightweight preview of a ClothingActor that will not perform any simulation.

Member Function Documentation

virtual void nvidia::apex::ClothingPreview::updateState | ( | const PxMat44 & | globalPose,
 |  | const PxMat44 * | newBoneMatrices,
 |  | uint32_t | boneMatricesByteStride,
 |  | uint32_t | numBoneMatrices
 | ) |  | [pure virtual]

Updates all internal bone matrices.

See also:
ClothingActor::updateState
The documentation for this class was generated from the following file:
  • ClothingPreview.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPreview
nvidia::apex::ClothingPreview Member List
This is the complete list of members for nvidia::apex::ClothingPreview, including all inherited members.
updateState(const PxMat44 &globalPose, const PxMat44 *newBoneMatrices, uint32_t boneMatricesByteStride, uint32_t numBoneMatrices)=0 nvidia::apex::ClothingPreview [pure virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingRenderProxy Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingRenderProxy
Public Member Functions
nvidia::apex::ClothingRenderProxy Class Reference

Instance of ClothingRenderProxy. This is the renderable of a clothing actor. The data in this object is consistent until it is returned to APEX with the release() call. More...

#include <ClothingRenderProxy.h>

List of all members.

Public Member Functions

virtual bool hasSimulatedData () const =0
True if the render proxy contains simulated data, false if it is purely animated.

Detailed Description

Instance of ClothingRenderProxy. This is the renderable of a clothing actor. The data in this object is consistent until it is returned to APEX with the release() call.

The documentation for this class was generated from the following file:
  • ClothingRenderProxy.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingRenderProxy
nvidia::apex::ClothingRenderProxy Member List
This is the complete list of members for nvidia::apex::ClothingRenderProxy, including all inherited members.
hasSimulatedData() const =0 | nvidia::apex::ClothingRenderProxy | [pure virtual]
~ClothingRenderProxy() (defined in nvidia::apex::ClothingRenderProxy) | nvidia::apex::ClothingRenderProxy | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingSphere Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingSphere
Public Member Functions
nvidia::apex::ClothingSphere Class Reference

Sphere collision of a clothing actor. More...

#include <ClothingCollision.h>

Inheritance diagram for nvidia::apex::ClothingSphere:
nvidia::apex::ClothingCollision

List of all members.

Public Member Functions

virtual void | setPosition (const PxVec3 &position)=0
Sets the position of this sphere.
virtual const PxVec3 & | getPosition () const =0
Returns the position of this sphere.
virtual void | setRadius (float radius)=0
Sets the radius of this sphere.
virtual float | getRadius () const =0
Returns the Radius of this sphere.
virtual uint32_t | getRefCount () const =0
Returns the number of capsules that reference this plane.

Detailed Description

Sphere collision of a clothing actor.

Member Function Documentation

virtual void nvidia::apex::ClothingSphere::setRadius ( float radius ) [pure virtual]

Sets the radius of this sphere.

Sets the Radius of this sphere.

The documentation for this class was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingSphere
nvidia::apex::ClothingSphere Member List
This is the complete list of members for nvidia::apex::ClothingSphere, including all inherited members.
getPosition() const =0 | nvidia::apex::ClothingSphere | [pure virtual]
getRadius() const =0 | nvidia::apex::ClothingSphere | [pure virtual]
getRefCount() const =0 | nvidia::apex::ClothingSphere | [pure virtual]
getType() const =0 | nvidia::apex::ClothingCollision | [pure virtual]
isCapsule()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isConvex()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isPlane()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isSphere()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isTriangleMesh()=0 | nvidia::apex::ClothingCollision | [pure virtual]
setPosition(const PxVec3 &position)=0 | nvidia::apex::ClothingSphere | [pure virtual]
setRadius(float radius)=0 | nvidia::apex::ClothingSphere | [pure virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingTriangleMesh Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingTriangleMesh
Public Member Functions
nvidia::apex::ClothingTriangleMesh Class Reference

Triangle mesh collision of a clothing actor. More...

#include <ClothingCollision.h>

Inheritance diagram for nvidia::apex::ClothingTriangleMesh:
nvidia::apex::ClothingCollision

List of all members.

Public Member Functions

virtual uint32_t | lockTriangles (const uint32_t **ids, const PxVec3 **triangles)=0
Read access to the current triangles of the mesh. unlockTriangles needs to be called when done reading.
virtual uint32_t | lockTrianglesWrite (const uint32_t **ids, PxVec3 **triangles)=0
Write access to the current triangles of the mesh. Changing Ids is not allowed. unlockTriangles needs to be called when done editing.
virtual void | unlockTriangles ()=0
Unlock the mesh data after editing or reading.
virtual void | addTriangle (uint32_t id, const PxVec3 &v0, const PxVec3 &v1, const PxVec3 &v2)=0
Adds a triangle to the mesh. Clockwise winding. If a triangle with a given id already exists, it will update that triangle with the new values. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.
virtual void | addTriangles (const uint32_t *ids, const PxVec3 *triangleVertices, uint32_t numTriangles)=0
Adds a list of triangles to the mesh. Clockwise winding. If a triangle with a given id already exists, it will update that triangle with the new values. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.
virtual void | removeTriangle (uint32_t id)=0
Removes triangle with given id. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.
virtual void | removeTriangles (const uint32_t *ids, uint32_t numTriangles)=0
Removes triangles. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.
virtual void | clearTriangles ()=0
Clear all triangles to start with an empty mesh.
virtual void | setPose (PxMat44 pose)=0
Sets the global pose of the mesh.
virtual const PxMat44 & | getPose () const =0
Returns the global pose of the mesh.

Detailed Description

Triangle mesh collision of a clothing actor.

Member Function Documentation

virtual void nvidia::apex::ClothingTriangleMesh::addTriangle | ( | uint32_t | id,
 |  | const PxVec3 & | v0,
 |  | const PxVec3 & | v1,
 |  | const PxVec3 & | v2
 | ) |  | [pure virtual]

Adds a triangle to the mesh. Clockwise winding. If a triangle with a given id already exists, it will update that triangle with the new values. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.

Parameters:
[in] | id | User provided triangle id that allows identifing and removing the triangle.
[in] | v0 | First vertex of triangle
[in] | v1 | Second vertex of triangle
[in] | v2 | Third vertex of triangle
virtual void nvidia::apex::ClothingTriangleMesh::addTriangles | ( | const uint32_t * | ids,
 |  | const PxVec3 * | triangleVertices,
 |  | uint32_t | numTriangles
 | ) |  | [pure virtual]

Adds a list of triangles to the mesh. Clockwise winding. If a triangle with a given id already exists, it will update that triangle with the new values. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.

Parameters:
[in] | ids | User provided triangle indices that allows identifing and removing the triangle. Needs to contain numTriangles indices.
[in] | triangleVertices | Triangle vertices to add. Needs to contain 3*numTriangles vertex positions
[in] | numTriangles | Number of triangles to add
virtual uint32_t nvidia::apex::ClothingTriangleMesh::lockTriangles | ( | const uint32_t ** | ids,
 |  | const PxVec3 ** | triangles
 | ) |  | [pure virtual]

Read access to the current triangles of the mesh. unlockTriangles needs to be called when done reading.

Parameters:
[out] | ids | Pointer to the triangle ids. Not written if NULL is provided.
[out] | triangles | Pointer to the triangles. Contains (3*number of triangles) vertex positions. Not written if NULL is provided.
Returns:
Current number of triangles
virtual uint32_t nvidia::apex::ClothingTriangleMesh::lockTrianglesWrite | ( | const uint32_t ** | ids,
 |  | PxVec3 ** | triangles
 | ) |  | [pure virtual]

Write access to the current triangles of the mesh. Changing Ids is not allowed. unlockTriangles needs to be called when done editing.

Parameters:
[out] | ids | pointer to the triangle ids. not written if NULL is provided.
[out] | triangles | pointer to the triangles. Contains (3*number of triangles) vertex positions. Not written if NULL is provided.
Returns:
Current number of triangles
virtual void nvidia::apex::ClothingTriangleMesh::removeTriangle ( uint32_t id ) [pure virtual]

Removes triangle with given id. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.

Parameters:
[in] id id of the triangle to be removed
virtual void nvidia::apex::ClothingTriangleMesh::removeTriangles | ( | const uint32_t * | ids,
 |  | uint32_t | numTriangles
 | ) |  | [pure virtual]

Removes triangles. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.

Parameters:
[in] | ids | ids of the triangles to be removed. Needs to contain numTriangle indices.
[in] | numTriangles | Number of triangles to remove
The documentation for this class was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingTriangleMesh
nvidia::apex::ClothingTriangleMesh Member List
This is the complete list of members for nvidia::apex::ClothingTriangleMesh, including all inherited members.
addTriangle(uint32_t id, const PxVec3 &v0, const PxVec3 &v1, const PxVec3 &v2)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
addTriangles(const uint32_t *ids, const PxVec3 *triangleVertices, uint32_t numTriangles)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
clearTriangles()=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
getPose() const =0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
getType() const =0 | nvidia::apex::ClothingCollision | [pure virtual]
isCapsule()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isConvex()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isPlane()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isSphere()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isTriangleMesh()=0 | nvidia::apex::ClothingCollision | [pure virtual]
lockTriangles(const uint32_t **ids, const PxVec3 **triangles)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
lockTrianglesWrite(const uint32_t **ids, PxVec3 **triangles)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
removeTriangle(uint32_t id)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
removeTriangles(const uint32_t *ids, uint32_t numTriangles)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
unlockTriangles()=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingVelocityCallback Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingVelocityCallback
Public Member Functions
nvidia::apex::ClothingVelocityCallback Class Reference

container class for the velocity shader callback. More...

#include <ClothingVelocityCallback.h>

List of all members.

Public Member Functions

virtual bool velocityShader (PxVec3 *velocities, const PxVec3 *positions, uint32_t numParticles)=0
This callback will be fired in Apex threads. It must not address any user data, just operate on the data.

Detailed Description

container class for the velocity shader callback.

Member Function Documentation

virtual bool nvidia::apex::ClothingVelocityCallback::velocityShader | ( | PxVec3 * | velocities,
 |  | const PxVec3 * | positions,
 |  | uint32_t | numParticles
 | ) |  | [pure virtual]

This callback will be fired in Apex threads. It must not address any user data, just operate on the data.

Parameters:
[in,out] | velocities | The velocities of the cloth. These can be modified if necessary, but then the method needs to return true!
[in] | positions | The positions of the cloth. Must not be modified, only read.
[in] | numParticles | Size of the velocities and positions array.
Returns:
return true if the velocities have been altered, false if they just have been read
The documentation for this class was generated from the following file:
  • ClothingVelocityCallback.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingVelocityCallback
nvidia::apex::ClothingVelocityCallback Member List
This is the complete list of members for nvidia::apex::ClothingVelocityCallback, including all inherited members.
velocityShader(PxVec3 *velocities, const PxVec3 *positions, uint32_t numParticles)=0 nvidia::apex::ClothingVelocityCallback [pure virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ModuleClothing Class Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleClothing
Public Member Functions
nvidia::apex::ModuleClothing Class Reference

APEX Clothing Module. More...

#include <ModuleClothing.h>

List of all members.

Public Member Functions

virtual ClothingPhysicalMesh * | createEmptyPhysicalMesh ()=0
creates an empty physical mesh. A custom mesh can be assigned to it.
virtual ClothingPhysicalMesh * | createSingleLayeredMesh (RenderMeshAssetAuthoring *asset, uint32_t subdivision, bool mergeVertices, bool closeHoles, IProgressListener *progress)=0
creates a physical mesh based on a render mesh asset. This will be a 1 to 1 copy of the render mesh

Detailed Description

APEX Clothing Module.

Used to generate simulated clothing on (mostly humanoid) characters.

Member Function Documentation

virtual ClothingPhysicalMesh* nvidia::apex::ModuleClothing::createSingleLayeredMesh | ( | RenderMeshAssetAuthoring * | asset,
 |  | uint32_t | subdivision,
 |  | bool | mergeVertices,
 |  | bool | closeHoles,
 |  | IProgressListener * | progress
 | ) |  | [pure virtual]

creates a physical mesh based on a render mesh asset. This will be a 1 to 1 copy of the render mesh

Parameters:
[in] | asset | The render mesh that is used as source for the physical mesh
[in] | subdivision | Modify the physical mesh such that all edges that are longer than (bounding box diagonal / subdivision) are split up. Must be <= 200
[in] | mergeVertices | All vertices with the same position will be welded together.
[in] | closeHoles | Close any hole found in the mesh.
[in] | progress | An optional callback for progress display.
The documentation for this class was generated from the following file:
  • ModuleClothing.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleClothing
nvidia::apex::ModuleClothing Member List
This is the complete list of members for nvidia::apex::ModuleClothing, including all inherited members.
createEmptyPhysicalMesh()=0 | nvidia::apex::ModuleClothing | [pure virtual]
createSingleLayeredMesh(RenderMeshAssetAuthoring *asset, uint32_t subdivision, bool mergeVertices, bool closeHoles, IProgressListener *progress)=0 | nvidia::apex::ModuleClothing | [pure virtual]
~ModuleClothing() (defined in nvidia::apex::ModuleClothing) | nvidia::apex::ModuleClothing | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: ClothingActor.h Source File

  • Related Pages
  • File List
ClothingActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_ACTOR_H
00031 #define CLOTHING_ACTOR_H
00032
00033 #include "Actor.h"
00034 #include "Renderable.h"
00035 #include "ClothingAsset.h"
00036
00037 namespace NvParameterized
00038 {
00039 class Interface;
00040 }
00041
00042 namespace nvidia
00043 {
00044 namespace apex
00045 {
00046
00047 PX_PUSH_PACK_DEFAULT
00048
00049 class ClothingVelocityCallback;
00050 class ClothingPlane;
00051 class ClothingConvex;
00052 class ClothingSphere;
00053 class ClothingCapsule;
00054 class ClothingTriangleMesh;
00055 class ClothingRenderProxy;
00056
00057
00061 struct ClothingTeleportMode
00062 {
00064     enum Enum
00065     {
00069         Continuous,
00070
00076         Teleport,
00077
00083         TeleportAndReset,
00084     };
00085 };
00086
00087
00088
00092 class ClothingActor : public Actor, public Renderable
00093 {
00094 protected:
00095     virtual ~ClothingActor() {}
00096 public:
00097
00103     virtual ::NvParameterized::Interface* getActorDesc() = 0;
00104
00117     virtual void updateState(const PxMat44& globalPose, const PxMat44* newBoneMatrices, uint32_t boneMatricesByteStride, uint32_t numBoneMatrices, ClothingTeleportMode::Enum teleportMode) = 0;
00118
00125     virtual void updateMaxDistanceScale(float scale, bool multipliable) = 0;
00126
00130     virtual const PxMat44& getGlobalPose() const = 0;
00131
00142     virtual void setWind(float windAdaption, const PxVec3& windVelocity) = 0;
00143
00152     virtual void setMaxDistanceBlendTime(float blendTime) = 0;
00153
00159     virtual float getMaxDistanceBlendTime() const = 0;
00160
00168     virtual void setVisible(bool enable) = 0;
00169
00174     virtual bool isVisible() const = 0;
00175
00179     virtual void setFrozen(bool enable) = 0;
00180
00184     virtual bool isFrozen() const = 0;
00185
00189     virtual ClothSolverMode::Enum getClothSolverMode() const = 0;
00190
00201     virtual void setGraphicalLOD(uint32_t lod) = 0;
00202
00207     virtual uint32_t getGraphicalLod() = 0;
00208
00220     virtual bool rayCast(const PxVec3& worldOrigin, const PxVec3& worldDirection, float& time, PxVec3& normal, uint32_t& vertexIndex) = 0;
00221
00225     virtual void attachVertexToGlobalPosition(uint32_t vertexIndex, const PxVec3& globalPosition) = 0;
00226
00230     virtual void freeVertex(uint32_t vertexIndex) = 0;
00231
00235     virtual uint32_t getClothingMaterial() const = 0;
00236
00240     virtual void setClothingMaterial(uint32_t index) = 0;
00241
00245     virtual void setOverrideMaterial(uint32_t submeshIndex, const char* overrideMaterialName) = 0;
00246
00250     virtual void setVelocityCallback(ClothingVelocityCallback* callback) = 0;
00251
00261     virtual void getPhysicalMeshPositions(void* buffer, uint32_t byteStride) = 0;
00262
00272     virtual void getPhysicalMeshNormals(void* buffer, uint32_t byteStride) = 0;
00273
00277     virtual float getMaximumSimulationBudget() const = 0;
00278
00287     virtual uint32_t getNumSimulationVertices() const = 0;
00288
00289
00297     virtual const PxVec3* getSimulationPositions() = 0;
00298
00306     virtual const PxVec3* getSimulationNormals() = 0;
00307
00317     virtual bool getSimulationVelocities(PxVec3* velocities) = 0;
00318
00326     virtual uint32_t getNumGraphicalVerticesActive(uint32_t submeshIndex) const = 0;
00327
00333     virtual PxMat44 getRenderGlobalPose() const = 0;
00334
00341     virtual const PxMat44* getCurrentBoneSkinningMatrices() const = 0;
00342
00343
00349     virtual bool isHalfPrecisionAllowed() const = 0;
00350
00360     virtual void setHalfPrecision(bool isAllowed) = 0;
00361
00362
00366     virtual ClothingPlane* createCollisionPlane(const PxPlane& plane) = 0;
00367
00371     virtual ClothingConvex* createCollisionConvex(ClothingPlane** planes, uint32_t numPlanes) = 0;
00372
00376     virtual ClothingSphere* createCollisionSphere(const PxVec3& position, float radius) = 0;
00377
00381     virtual ClothingCapsule* createCollisionCapsule(ClothingSphere& sphere1, ClothingSphere& sphere2) = 0;
00382
00386     virtual ClothingTriangleMesh* createCollisionTriangleMesh() = 0;
00387
00404     virtual ClothingRenderProxy* acquireRenderProxy() = 0;
00405
00406 #if APEX_UE4
00407
00408     virtual void simulate(PxF32 dt) = 0;
00409 #endif
00410 };
00411
00412 PX_POP_PACK
00413
00414 }
00415 } // namespace nvidia
00416
00417 #endif // CLOTHING_ACTOR_H
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: ClothingAsset.h Source File

  • Related Pages
  • File List
ClothingAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_ASSET_H
00031 #define CLOTHING_ASSET_H
00032
00033 #include "Asset.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class ClothingActor;
00043 class ClothingPreview;
00044
00045 #define CLOTHING_AUTHORING_TYPE_NAME "ClothingAsset"
00046
00047
00051 struct ClothSolverMode
00052 {
00054     enum Enum
00055     {
00059         v3,
00060     };
00061 };
00062
00063
00092 struct ClothingMeshSkinningMap
00093 {
00098     PxVec3 positionBary;
00099
00103     uint32_t vertexIndex0;
00104
00110     PxVec3 normalBary;
00111
00115     uint32_t vertexIndex1;
00116
00122     PxVec3 tangentBary;
00123
00127     uint32_t vertexIndex2;
00128 };
00129
00133 class ClothingAsset : public Asset
00134 {
00135 protected:
00136     // do not manually delete this object
00137     virtual ~ClothingAsset() {}
00138 public:
00142     virtual uint32_t getNumActors() const = 0;
00143
00147     virtual ClothingActor* getActor(uint32_t index) = 0;
00148
00152     virtual PxBounds3 getBoundingBox() const = 0;
00153
00157     virtual uint32_t getNumGraphicalLodLevels() const = 0;
00158
00162     virtual uint32_t getGraphicalLodValue(uint32_t lodLevel) const = 0;
00163
00167     virtual float getBiggestMaxDistance() const = 0;
00168
00172     virtual ClothSolverMode::Enum getClothSolverMode() const = 0;
00173
00182     virtual bool remapBoneIndex(const char* name, uint32_t newIndex) = 0;
00183
00187     virtual uint32_t getNumBones() const = 0;
00188
00192     virtual uint32_t getNumUsedBones() const = 0;
00193
00197     virtual const char* getBoneName(uint32_t internalIndex) const = 0;
00198
00202     virtual bool getBoneBasePose(uint32_t internalIndex, PxMat44& result) const = 0;
00203
00209     virtual void getBoneMapping(uint32_t* internal2externalMap) const = 0;
00210
00218     virtual const RenderMeshAsset*  getRenderMeshAsset(uint32_t lodLevel) const = 0;
00219
00231     virtual uint32_t prepareMorphTargetMapping(const PxVec3* originalPositions, uint32_t numPositions, float epsilon) = 0;
00232
00239     virtual uint32_t getMeshSkinningMapSize(uint32_t lod) = 0;
00240
00251     virtual void getMeshSkinningMap(uint32_t lod, ClothingMeshSkinningMap* map) = 0;
00252
00256     virtual bool releaseGraphicalData() = 0;
00257 };
00258
00259 PX_POP_PACK
00260
00261 } // namespace nvidia
00262 } // namespace nvidia
00263
00264 #endif // CLOTHING_ASSET_H
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: ClothingAssetAuthoring.h Source File

  • Related Pages
  • File List
ClothingAssetAuthoring.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_ASSET_AUTHORING_H
00031 #define CLOTHING_ASSET_AUTHORING_H
00032
00033 #include "Asset.h"
00034 #include "IProgressListener.h"
00035 #include "ClothingPhysicalMesh.h"
00036
00037
00038 namespace nvidia
00039 {
00040 namespace apex
00041 {
00042
00043 PX_PUSH_PACK_DEFAULT
00044
00045
00046 class ClothingPhysicalMesh;
00047
00048
00052 class ClothingAssetAuthoring : public AssetAuthoring
00053 {
00054 public:
00055
00059     virtual void setDefaultConstrainCoefficients(const ClothingConstrainCoefficients& coeff) = 0;
00060
00064     virtual void setInvalidConstrainCoefficients(const ClothingConstrainCoefficients& coeff) = 0;
00065
00081     virtual void setMeshes(uint32_t lod, RenderMeshAssetAuthoring* graphicalMesh, ClothingPhysicalMesh* physicalMesh,
00082                            float normalResemblance = 25, bool ignoreUnusedVertices = true, IProgressListener* progress = NULL) = 0;
00083
00084
00088     virtual bool addPlatformToGraphicalLod(uint32_t lod, PlatformTag platform) = 0;
00089
00093     virtual bool removePlatform(uint32_t lod,  PlatformTag platform) = 0;
00094
00098     virtual uint32_t getNumPlatforms(uint32_t lod) const = 0;
00099
00103     virtual PlatformTag getPlatform(uint32_t lod, uint32_t i) const = 0;
00104
00108     virtual uint32_t getNumLods() const = 0;
00109
00115     virtual int32_t getLodValue(uint32_t lod) const = 0;
00116
00120     virtual void clearMeshes() = 0;
00121
00125     virtual ClothingPhysicalMesh* getClothingPhysicalMesh(uint32_t graphicalLod) const = 0;
00126
00135     virtual void setBoneInfo(uint32_t boneIndex, const char* boneName, const PxMat44& bindPose, int32_t parentIndex) = 0;
00136
00142     virtual void setRootBone(const char* boneName) = 0;
00143
00151     virtual uint32_t addBoneConvex(const char* boneName, const PxVec3* positions, uint32_t numPositions) = 0;
00152
00160     virtual uint32_t addBoneConvex(uint32_t boneIndex, const PxVec3* positions, uint32_t numPositions) = 0;
00161
00170     virtual void addBoneCapsule(const char* boneName, float capsuleRadius, float capsuleHeight, const PxMat44& localPose) = 0;
00171
00180     virtual void addBoneCapsule(uint32_t boneIndex, float capsuleRadius, float capsuleHeight, const PxMat44& localPose) = 0;
00181
00185     virtual void clearBoneActors(const char* boneName) = 0;
00186
00190     virtual void clearBoneActors(uint32_t boneIndex) = 0;
00191
00195     virtual void clearAllBoneActors() = 0;
00196
00209     virtual void setCollision(const char** boneNames, float* radii, PxVec3* localPositions, uint32_t numSpheres, uint16_t* pairs, uint32_t numIndices) = 0;
00210
00214     virtual void setCollision(uint32_t* boneIndices, float* radii, PxVec3* localPositions, uint32_t numSpheres, uint16_t* pairs, uint32_t numIndices) = 0;
00215
00219     virtual void clearCollision() = 0;
00220
00226     virtual void setSimulationHierarchicalLevels(uint32_t levels) = 0;
00227
00228
00232     virtual void setSimulationThickness(float thickness) = 0;
00233
00237     virtual void setSimulationVirtualParticleDensity(float density) = 0;
00238
00242     virtual void setSimulationSleepLinearVelocity(float sleep) = 0;
00243
00247     virtual void setSimulationGravityDirection(const PxVec3& gravity) = 0;
00248
00257     virtual void setSimulationDisableCCD(bool disable) = 0;
00258
00262     virtual void setSimulationTwowayInteraction(bool enable) = 0;
00263
00269     virtual void setSimulationUntangling(bool enable) = 0;
00270
00274     virtual void setSimulationRestLengthScale(float scale) = 0;
00275
00283     virtual void setExportScale(float scale) = 0;
00284
00299     virtual void applyTransformation(const PxMat44& transformation, float scale, bool applyToGraphics, bool applyToPhysics) = 0;
00300
00309     virtual void updateBindPoses(const PxMat44* newBindPoses, uint32_t newBindPosesCount, bool isInternalOrder, bool maintainCollisionWorldSpace) = 0;
00310
00315     virtual void setDeriveNormalsFromBones(bool enable) = 0;
00316
00320     virtual NvParameterized::Interface* getMaterialLibrary() = 0;
00321
00329     virtual bool setMaterialLibrary(NvParameterized::Interface* materialLibrary, uint32_t materialIndex, bool transferOwnership) = 0;
00330
00342     virtual ::NvParameterized::Interface*   getRenderMeshAssetAuthoring(uint32_t lodLevel) const = 0;
00343
00347     virtual bool getBoneBindPose(uint32_t boneIndex, PxMat44& bindPose) const = 0;
00348
00352     virtual bool setBoneBindPose(uint32_t boneIndex, const PxMat44& bindPose) = 0;
00353 };
00354
00355 PX_POP_PACK
00356
00357 } // namespace nvidia
00358 } // namespace nvidia
00359
00360 #endif // CLOTHING_ASSET_AUTHORING_H
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: ClothingCollision.h File Reference

  • Related Pages
  • File List
Classes
ClothingCollision.h File Reference

classes ClothingCollision, ClothingPlane, ClothingConvex, ClothingSphere, ClothingCapsule, ClothingTriangleMesh More...

#include "ApexInterface.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::ClothingCollisionType
Type of the ClothingCollision. More...
class | nvidia::apex::ClothingCollision
Base class of all clothing collision types. More...
class | nvidia::apex::ClothingPlane
Plane collision of a clothing actor. More...
class | nvidia::apex::ClothingConvex
Convex collision of a clothing actor. More...
class | nvidia::apex::ClothingSphere
Sphere collision of a clothing actor. More...
class | nvidia::apex::ClothingCapsule
Capsule collision of a clothing actor. More...
class | nvidia::apex::ClothingTriangleMesh
Triangle mesh collision of a clothing actor. More...

Detailed Description

classes ClothingCollision, ClothingPlane, ClothingConvex, ClothingSphere, ClothingCapsule, ClothingTriangleMesh

Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: ClothingCollision.h Source File

  • Related Pages
  • File List
ClothingCollision.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_COLLISION_H
00031 #define CLOTHING_COLLISION_H
00032
00038 #include "ApexInterface.h"
00039
00040 namespace nvidia
00041 {
00042
00043 namespace apex
00044 {
00045 PX_PUSH_PACK_DEFAULT
00046
00047
00051 struct ClothingCollisionType
00052 {
00056     enum Enum
00057     {
00058         Plane,
00059         Convex,
00060         Sphere,
00061         Capsule,
00062         TriangleMesh
00063     };
00064 };
00065
00066
00067
00068 class ClothingPlane;
00069 class ClothingConvex;
00070 class ClothingSphere;
00071 class ClothingCapsule;
00072 class ClothingTriangleMesh;
00073
00077 class ClothingCollision : public ApexInterface
00078 {
00079 public:
00083     virtual ClothingCollisionType::Enum getType() const = 0;
00084
00088     virtual ClothingPlane* isPlane() = 0;
00089
00093     virtual ClothingConvex* isConvex() = 0;
00094
00098     virtual ClothingSphere* isSphere() = 0;
00099
00103     virtual ClothingCapsule* isCapsule() = 0;
00104
00108     virtual ClothingTriangleMesh* isTriangleMesh() = 0;
00109 };
00110
00111
00112
00116 class ClothingPlane : public ClothingCollision
00117 {
00118 public:
00122     virtual void setPlane(const PxPlane& plane) = 0;
00123
00127     virtual const PxPlane& getPlane() = 0;
00128
00132     virtual uint32_t getRefCount() const = 0;
00133 };
00134
00135
00136
00142 class ClothingConvex : public ClothingCollision
00143 {
00144 public:
00148     virtual uint32_t getNumPlanes() = 0;
00149
00153     virtual ClothingPlane** getPlanes() = 0;
00154
00160     virtual void releaseWithPlanes() = 0;
00161 };
00162
00163
00164
00168 class ClothingSphere : public ClothingCollision
00169 {
00170 public:
00174     virtual void setPosition(const PxVec3& position) = 0;
00175
00179     virtual const PxVec3& getPosition() const = 0;
00180
00188     virtual void setRadius(float radius) = 0;
00189
00193     virtual float getRadius() const = 0;
00194
00198     virtual uint32_t getRefCount() const = 0;
00199 };
00200
00201
00202
00208 class ClothingCapsule : public ClothingCollision
00209 {
00210 public:
00214     virtual ClothingSphere** getSpheres() = 0;
00215
00221     virtual void releaseWithSpheres() = 0;
00222 };
00223
00224
00225
00229 class ClothingTriangleMesh : public ClothingCollision
00230 {
00231 public:
00239     virtual uint32_t lockTriangles(const uint32_t** ids, const PxVec3** triangles) = 0;
00240
00248     virtual uint32_t lockTrianglesWrite(const uint32_t** ids, PxVec3** triangles) = 0;
00249
00253     virtual void unlockTriangles() = 0;
00254
00265     virtual void addTriangle(uint32_t id, const PxVec3& v0, const PxVec3& v1, const PxVec3& v2) = 0;
00266
00277     virtual void addTriangles(const uint32_t* ids, const PxVec3* triangleVertices, uint32_t numTriangles) = 0;
00278
00285     virtual void removeTriangle(uint32_t id) = 0;
00286
00294     virtual void removeTriangles(const uint32_t* ids, uint32_t numTriangles) = 0;
00295
00299     virtual void clearTriangles() = 0;
00300
00304     virtual void setPose(PxMat44 pose) = 0;
00305
00309     virtual const PxMat44& getPose() const = 0;
00310 };
00311
00312
00313
00314 PX_POP_PACK
00315 } // namespace nvidia
00316 } // namespace nvidia
00317
00318
00319 #endif // CLOTHING_COLLISION_H
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: ClothingPhysicalMesh.h Source File

  • Related Pages
  • File List
ClothingPhysicalMesh.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_PHYSICAL_MESH_H
00031 #define CLOTHING_PHYSICAL_MESH_H
00032
00033 #include "ApexInterface.h"
00034 #include "IProgressListener.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041
00045 struct ClothingConstrainCoefficients
00046 {
00047     float maxDistance;
00048     float collisionSphereRadius;
00049     float collisionSphereDistance;
00050 };
00051
00052
00053 PX_PUSH_PACK_DEFAULT
00054
00058 struct ClothingPhysicalMeshStats
00059 {
00061     uint32_t    totalBytes;
00063     uint32_t    numVertices;
00065     uint32_t    numIndices;
00066 };
00067
00068
00072 class ClothingPhysicalMesh : public ApexInterface
00073 {
00074 public:
00078     virtual uint32_t getNumVertices() const = 0;
00079
00083     virtual uint32_t getNumSimulatedVertices() const = 0;
00084
00088     virtual uint32_t getNumMaxDistance0Vertices() const = 0;
00089
00093     virtual uint32_t getNumIndices() const = 0;
00094
00098     virtual uint32_t getNumSimulatedIndices() const = 0;
00099
00107     virtual void getIndices(void* indexDestination, uint32_t byteStride, uint32_t numIndices) const = 0;
00108
00112     virtual bool isTetrahedralMesh() const = 0;
00113
00127     virtual void simplify(uint32_t subdivisions, int32_t maxSteps, float maxError, IProgressListener* progress) = 0;
00128
00135     virtual void setGeometry(bool tetraMesh, uint32_t numVertices, uint32_t vertexByteStride, const void* vertices, const uint32_t* driveChannels,
00136                             uint32_t numIndices, uint32_t indexByteStride, const void* indices) = 0;
00137
00138     // direct access to specific buffers
00145     virtual bool getIndices(uint32_t* indices, uint32_t byteStride) const = 0;
00146
00153     virtual bool getVertices(PxVec3* vertices, uint32_t byteStride) const = 0;
00154
00161     virtual bool getNormals(PxVec3* normals, uint32_t byteStride) const = 0;
00162
00166     virtual uint32_t getNumBonesPerVertex() const = 0;
00167
00177     virtual bool getBoneIndices(uint16_t* boneIndices, uint32_t byteStride) const = 0;
00178
00187     virtual bool getBoneWeights(float* boneWeights, uint32_t byteStride) const = 0;
00188
00194     virtual void allocateMasterFlagsBuffer() = 0;
00195
00201     virtual uint32_t* getMasterFlagsBuffer() = 0;
00202
00210     virtual void allocateConstrainCoefficientBuffer() = 0;
00211
00217     virtual ClothingConstrainCoefficients* getConstrainCoefficientBuffer() const = 0;
00218
00224     virtual bool getConstrainCoefficients(ClothingConstrainCoefficients* coeffs, uint32_t byteStride) const = 0;
00225
00229     virtual void getStats(ClothingPhysicalMeshStats& stats) const = 0;
00230
00231 };
00232
00233 PX_POP_PACK
00234
00235 }
00236 } // namespace nvidia
00237
00238 #endif // CLOTHING_PHYSICAL_MESH_H
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: ClothingPreview.h Source File

  • Related Pages
  • File List
ClothingPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_PREVIEW_H
00031 #define CLOTHING_PREVIEW_H
00032
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042
00043
00047 class ClothingPreview : public AssetPreview
00048 {
00049
00050 public:
00051
00056     virtual void updateState(const PxMat44& globalPose, const PxMat44* newBoneMatrices, uint32_t boneMatricesByteStride, uint32_t numBoneMatrices) = 0;
00057
00058 };
00059
00060
00061 PX_POP_PACK
00062
00063 }
00064 } // namespace nvidia
00065
00066 #endif // CLOTHING_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: ClothingRenderProxy.h Source File

  • Related Pages
  • File List
ClothingRenderProxy.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_RENDER_PROXY_H
00031 #define CLOTHING_RENDER_PROXY_H
00032
00033 #include "Renderable.h"
00034 #include "ApexInterface.h"
00035
00036 namespace NvParameterized
00037 {
00038 class Interface;
00039 }
00040
00041 namespace nvidia
00042 {
00043 namespace apex
00044 {
00045
00046 PX_PUSH_PACK_DEFAULT
00047
00053 class ClothingRenderProxy : public ApexInterface, public Renderable
00054 {
00055 protected:
00056     virtual ~ClothingRenderProxy() {}
00057
00058 public:
00062     virtual bool hasSimulatedData() const = 0;
00063 };
00064
00065 PX_POP_PACK
00066
00067 }
00068 } // namespace nvidia
00069
00070 #endif // CLOTHING_RENDER_PROXY_H
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: ClothingVelocityCallback.h Source File

  • Related Pages
  • File List
ClothingVelocityCallback.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_VELOCITY_CALLBACK_H
00031 #define CLOTHING_VELOCITY_CALLBACK_H
00032
00033 #include "ApexUsingNamespace.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00043 class ClothingVelocityCallback
00044 {
00045 public:
00054     virtual bool velocityShader(PxVec3* velocities, const PxVec3* positions, uint32_t numParticles) = 0;
00055 };
00056
00057 } // namespace nvidia
00058 } // namespace nvidia
00059
00060 #endif // CLOTHING_VELOCITY_CALLBACK_H
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Deprecated List

  • Related Pages
Deprecated List

Member nvidia::apex::ClothingActor::getMaxDistanceBlendTime () const =0
Use ClothingActor::getActorDesc() and read the maxDistanceBlendTime part of it

Member nvidia::apex::ClothingActor::setMaxDistanceBlendTime (float blendTime)=0
Use ClothingActor::getActorDesc() and modify the maxDistanceBlendTime part of it Default: 1.0

Member nvidia::apex::ClothingActor::setWind (float windAdaption, const PxVec3 &windVelocity)=0
Use ClothingActor::getActorDesc() and modify the wind part of it

Member nvidia::apex::ClothingAssetAuthoring::setExportScale (float scale)=0
Only works with deprecated serialization, use applyTransformation instead!
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: File List

  • Related Pages
  • File List
File List
Here is a list of all documented files with brief descriptions:
ClothingActor.h [code] |
ClothingAsset.h [code] |
ClothingAssetAuthoring.h [code] |
ClothingCollision.h [code] | Classes ClothingCollision, ClothingPlane, ClothingConvex, ClothingSphere, ClothingCapsule, ClothingTriangleMesh
ClothingPhysicalMesh.h [code] |
ClothingPreview.h [code] |
ClothingRenderProxy.h [code] |
ClothingVelocityCallback.h [code] |
ModuleClothing.h [code] |
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Class Members

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • acquireRenderProxy() : nvidia::apex::ClothingActor
  • addBoneCapsule() : nvidia::apex::ClothingAssetAuthoring
  • addBoneConvex() : nvidia::apex::ClothingAssetAuthoring
  • addPlatformToGraphicalLod() : nvidia::apex::ClothingAssetAuthoring
  • addTriangle() : nvidia::apex::ClothingTriangleMesh
  • addTriangles() : nvidia::apex::ClothingTriangleMesh
  • allocateConstrainCoefficientBuffer() : nvidia::apex::ClothingPhysicalMesh
  • allocateMasterFlagsBuffer() : nvidia::apex::ClothingPhysicalMesh
  • applyTransformation() : nvidia::apex::ClothingAssetAuthoring
  • attachVertexToGlobalPosition() : nvidia::apex::ClothingActor

- c -

  • clearAllBoneActors() : nvidia::apex::ClothingAssetAuthoring
  • clearBoneActors() : nvidia::apex::ClothingAssetAuthoring
  • clearCollision() : nvidia::apex::ClothingAssetAuthoring
  • clearMeshes() : nvidia::apex::ClothingAssetAuthoring
  • clearTriangles() : nvidia::apex::ClothingTriangleMesh
  • collisionSphereDistance : nvidia::apex::ClothingConstrainCoefficients
  • collisionSphereRadius : nvidia::apex::ClothingConstrainCoefficients
  • Continuous : nvidia::apex::ClothingTeleportMode
  • createCollisionCapsule() : nvidia::apex::ClothingActor
  • createCollisionConvex() : nvidia::apex::ClothingActor
  • createCollisionPlane() : nvidia::apex::ClothingActor
  • createCollisionSphere() : nvidia::apex::ClothingActor
  • createCollisionTriangleMesh() : nvidia::apex::ClothingActor
  • createEmptyPhysicalMesh() : nvidia::apex::ModuleClothing
  • createSingleLayeredMesh() : nvidia::apex::ModuleClothing

- e -

  • Enum
: nvidia::apex::ClothingTeleportMode
, nvidia::apex::ClothingCollisionType
, nvidia::apex::ClothSolverMode

- f -

  • freeVertex() : nvidia::apex::ClothingActor

- g -

  • getActor() : nvidia::apex::ClothingAsset
  • getActorDesc() : nvidia::apex::ClothingActor
  • getBiggestMaxDistance() : nvidia::apex::ClothingAsset
  • getBoneBasePose() : nvidia::apex::ClothingAsset
  • getBoneBindPose() : nvidia::apex::ClothingAssetAuthoring
  • getBoneIndices() : nvidia::apex::ClothingPhysicalMesh
  • getBoneMapping() : nvidia::apex::ClothingAsset
  • getBoneName() : nvidia::apex::ClothingAsset
  • getBoneWeights() : nvidia::apex::ClothingPhysicalMesh
  • getBoundingBox() : nvidia::apex::ClothingAsset
  • getClothingMaterial() : nvidia::apex::ClothingActor
  • getClothingPhysicalMesh() : nvidia::apex::ClothingAssetAuthoring
  • getClothSolverMode()
: nvidia::apex::ClothingActor
, nvidia::apex::ClothingAsset
  • getConstrainCoefficientBuffer() : nvidia::apex::ClothingPhysicalMesh
  • getConstrainCoefficients() : nvidia::apex::ClothingPhysicalMesh
  • getCurrentBoneSkinningMatrices() : nvidia::apex::ClothingActor
  • getGlobalPose() : nvidia::apex::ClothingActor
  • getGraphicalLod() : nvidia::apex::ClothingActor
  • getGraphicalLodValue() : nvidia::apex::ClothingAsset
  • getIndices() : nvidia::apex::ClothingPhysicalMesh
  • getLodValue() : nvidia::apex::ClothingAssetAuthoring
  • getMasterFlagsBuffer() : nvidia::apex::ClothingPhysicalMesh
  • getMaterialLibrary() : nvidia::apex::ClothingAssetAuthoring
  • getMaxDistanceBlendTime() : nvidia::apex::ClothingActor
  • getMaximumSimulationBudget() : nvidia::apex::ClothingActor
  • getMeshSkinningMap() : nvidia::apex::ClothingAsset
  • getMeshSkinningMapSize() : nvidia::apex::ClothingAsset
  • getNormals() : nvidia::apex::ClothingPhysicalMesh
  • getNumActors() : nvidia::apex::ClothingAsset
  • getNumBones() : nvidia::apex::ClothingAsset
  • getNumBonesPerVertex() : nvidia::apex::ClothingPhysicalMesh
  • getNumGraphicalLodLevels() : nvidia::apex::ClothingAsset
  • getNumGraphicalVerticesActive() : nvidia::apex::ClothingActor
  • getNumIndices() : nvidia::apex::ClothingPhysicalMesh
  • getNumLods() : nvidia::apex::ClothingAssetAuthoring
  • getNumMaxDistance0Vertices() : nvidia::apex::ClothingPhysicalMesh
  • getNumPlanes() : nvidia::apex::ClothingConvex
  • getNumPlatforms() : nvidia::apex::ClothingAssetAuthoring
  • getNumSimulatedIndices() : nvidia::apex::ClothingPhysicalMesh
  • getNumSimulatedVertices() : nvidia::apex::ClothingPhysicalMesh
  • getNumSimulationVertices() : nvidia::apex::ClothingActor
  • getNumUsedBones() : nvidia::apex::ClothingAsset
  • getNumVertices() : nvidia::apex::ClothingPhysicalMesh
  • getPhysicalMeshNormals() : nvidia::apex::ClothingActor
  • getPhysicalMeshPositions() : nvidia::apex::ClothingActor
  • getPlane() : nvidia::apex::ClothingPlane
  • getPlanes() : nvidia::apex::ClothingConvex
  • getPlatform() : nvidia::apex::ClothingAssetAuthoring
  • getPose() : nvidia::apex::ClothingTriangleMesh
  • getPosition() : nvidia::apex::ClothingSphere
  • getRadius() : nvidia::apex::ClothingSphere
  • getRefCount()
: nvidia::apex::ClothingSphere
, nvidia::apex::ClothingPlane
  • getRenderGlobalPose() : nvidia::apex::ClothingActor
  • getRenderMeshAsset() : nvidia::apex::ClothingAsset
  • getRenderMeshAssetAuthoring() : nvidia::apex::ClothingAssetAuthoring
  • getSimulationNormals() : nvidia::apex::ClothingActor
  • getSimulationPositions() : nvidia::apex::ClothingActor
  • getSimulationVelocities() : nvidia::apex::ClothingActor
  • getSpheres() : nvidia::apex::ClothingCapsule
  • getStats() : nvidia::apex::ClothingPhysicalMesh
  • getType() : nvidia::apex::ClothingCollision
  • getVertices() : nvidia::apex::ClothingPhysicalMesh

- h -

  • hasSimulatedData() : nvidia::apex::ClothingRenderProxy

- i -

  • isCapsule() : nvidia::apex::ClothingCollision
  • isConvex() : nvidia::apex::ClothingCollision
  • isFrozen() : nvidia::apex::ClothingActor
  • isHalfPrecisionAllowed() : nvidia::apex::ClothingActor
  • isPlane() : nvidia::apex::ClothingCollision
  • isSphere() : nvidia::apex::ClothingCollision
  • isTetrahedralMesh() : nvidia::apex::ClothingPhysicalMesh
  • isTriangleMesh() : nvidia::apex::ClothingCollision
  • isVisible() : nvidia::apex::ClothingActor

- l -

  • lockTriangles() : nvidia::apex::ClothingTriangleMesh
  • lockTrianglesWrite() : nvidia::apex::ClothingTriangleMesh

- m -

  • maxDistance : nvidia::apex::ClothingConstrainCoefficients

- n -

  • normalBary : nvidia::apex::ClothingMeshSkinningMap
  • numIndices : nvidia::apex::ClothingPhysicalMeshStats
  • numVertices : nvidia::apex::ClothingPhysicalMeshStats

- p -

  • positionBary : nvidia::apex::ClothingMeshSkinningMap
  • prepareMorphTargetMapping() : nvidia::apex::ClothingAsset

- r -

  • rayCast() : nvidia::apex::ClothingActor
  • releaseGraphicalData() : nvidia::apex::ClothingAsset
  • releaseWithPlanes() : nvidia::apex::ClothingConvex
  • releaseWithSpheres() : nvidia::apex::ClothingCapsule
  • remapBoneIndex() : nvidia::apex::ClothingAsset
  • removePlatform() : nvidia::apex::ClothingAssetAuthoring
  • removeTriangle() : nvidia::apex::ClothingTriangleMesh
  • removeTriangles() : nvidia::apex::ClothingTriangleMesh

- s -

  • setBoneBindPose() : nvidia::apex::ClothingAssetAuthoring
  • setBoneInfo() : nvidia::apex::ClothingAssetAuthoring
  • setClothingMaterial() : nvidia::apex::ClothingActor
  • setCollision() : nvidia::apex::ClothingAssetAuthoring
  • setDefaultConstrainCoefficients() : nvidia::apex::ClothingAssetAuthoring
  • setDeriveNormalsFromBones() : nvidia::apex::ClothingAssetAuthoring
  • setExportScale() : nvidia::apex::ClothingAssetAuthoring
  • setFrozen() : nvidia::apex::ClothingActor
  • setGeometry() : nvidia::apex::ClothingPhysicalMesh
  • setGraphicalLOD() : nvidia::apex::ClothingActor
  • setHalfPrecision() : nvidia::apex::ClothingActor
  • setInvalidConstrainCoefficients() : nvidia::apex::ClothingAssetAuthoring
  • setMaterialLibrary() : nvidia::apex::ClothingAssetAuthoring
  • setMaxDistanceBlendTime() : nvidia::apex::ClothingActor
  • setMeshes() : nvidia::apex::ClothingAssetAuthoring
  • setOverrideMaterial() : nvidia::apex::ClothingActor
  • setPlane() : nvidia::apex::ClothingPlane
  • setPose() : nvidia::apex::ClothingTriangleMesh
  • setPosition() : nvidia::apex::ClothingSphere
  • setRadius() : nvidia::apex::ClothingSphere
  • setRootBone() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationDisableCCD() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationGravityDirection() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationHierarchicalLevels() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationRestLengthScale() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationSleepLinearVelocity() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationThickness() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationTwowayInteraction() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationUntangling() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationVirtualParticleDensity() : nvidia::apex::ClothingAssetAuthoring
  • setVelocityCallback() : nvidia::apex::ClothingActor
  • setVisible() : nvidia::apex::ClothingActor
  • setWind() : nvidia::apex::ClothingActor
  • simplify() : nvidia::apex::ClothingPhysicalMesh

- t -

  • tangentBary : nvidia::apex::ClothingMeshSkinningMap
  • Teleport : nvidia::apex::ClothingTeleportMode
  • TeleportAndReset : nvidia::apex::ClothingTeleportMode
  • totalBytes : nvidia::apex::ClothingPhysicalMeshStats

- u -

  • unlockTriangles() : nvidia::apex::ClothingTriangleMesh
  • updateBindPoses() : nvidia::apex::ClothingAssetAuthoring
  • updateMaxDistanceScale() : nvidia::apex::ClothingActor
  • updateState()
: nvidia::apex::ClothingActor
, nvidia::apex::ClothingPreview

- v -

  • v3 : nvidia::apex::ClothSolverMode
  • velocityShader() : nvidia::apex::ClothingVelocityCallback
  • vertexIndex0 : nvidia::apex::ClothingMeshSkinningMap
  • vertexIndex1 : nvidia::apex::ClothingMeshSkinningMap
  • vertexIndex2 : nvidia::apex::ClothingMeshSkinningMap
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Class Members - Enumerations

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Enum
: nvidia::apex::ClothingTeleportMode
, nvidia::apex::ClothingCollisionType
, nvidia::apex::ClothSolverMode
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Class Members - Enumerator

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Continuous : nvidia::apex::ClothingTeleportMode
  • Teleport : nvidia::apex::ClothingTeleportMode
  • TeleportAndReset : nvidia::apex::ClothingTeleportMode
  • v3 : nvidia::apex::ClothSolverMode
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Class Members - Functions

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • c
  • f
  • g
  • h
  • i
  • l
  • p
  • r
  • s
  • u
  • v

- a -

  • acquireRenderProxy() : nvidia::apex::ClothingActor
  • addBoneCapsule() : nvidia::apex::ClothingAssetAuthoring
  • addBoneConvex() : nvidia::apex::ClothingAssetAuthoring
  • addPlatformToGraphicalLod() : nvidia::apex::ClothingAssetAuthoring
  • addTriangle() : nvidia::apex::ClothingTriangleMesh
  • addTriangles() : nvidia::apex::ClothingTriangleMesh
  • allocateConstrainCoefficientBuffer() : nvidia::apex::ClothingPhysicalMesh
  • allocateMasterFlagsBuffer() : nvidia::apex::ClothingPhysicalMesh
  • applyTransformation() : nvidia::apex::ClothingAssetAuthoring
  • attachVertexToGlobalPosition() : nvidia::apex::ClothingActor

- c -

  • clearAllBoneActors() : nvidia::apex::ClothingAssetAuthoring
  • clearBoneActors() : nvidia::apex::ClothingAssetAuthoring
  • clearCollision() : nvidia::apex::ClothingAssetAuthoring
  • clearMeshes() : nvidia::apex::ClothingAssetAuthoring
  • clearTriangles() : nvidia::apex::ClothingTriangleMesh
  • createCollisionCapsule() : nvidia::apex::ClothingActor
  • createCollisionConvex() : nvidia::apex::ClothingActor
  • createCollisionPlane() : nvidia::apex::ClothingActor
  • createCollisionSphere() : nvidia::apex::ClothingActor
  • createCollisionTriangleMesh() : nvidia::apex::ClothingActor
  • createEmptyPhysicalMesh() : nvidia::apex::ModuleClothing
  • createSingleLayeredMesh() : nvidia::apex::ModuleClothing

- f -

  • freeVertex() : nvidia::apex::ClothingActor

- g -

  • getActor() : nvidia::apex::ClothingAsset
  • getActorDesc() : nvidia::apex::ClothingActor
  • getBiggestMaxDistance() : nvidia::apex::ClothingAsset
  • getBoneBasePose() : nvidia::apex::ClothingAsset
  • getBoneBindPose() : nvidia::apex::ClothingAssetAuthoring
  • getBoneIndices() : nvidia::apex::ClothingPhysicalMesh
  • getBoneMapping() : nvidia::apex::ClothingAsset
  • getBoneName() : nvidia::apex::ClothingAsset
  • getBoneWeights() : nvidia::apex::ClothingPhysicalMesh
  • getBoundingBox() : nvidia::apex::ClothingAsset
  • getClothingMaterial() : nvidia::apex::ClothingActor
  • getClothingPhysicalMesh() : nvidia::apex::ClothingAssetAuthoring
  • getClothSolverMode()
: nvidia::apex::ClothingActor
, nvidia::apex::ClothingAsset
  • getConstrainCoefficientBuffer() : nvidia::apex::ClothingPhysicalMesh
  • getConstrainCoefficients() : nvidia::apex::ClothingPhysicalMesh
  • getCurrentBoneSkinningMatrices() : nvidia::apex::ClothingActor
  • getGlobalPose() : nvidia::apex::ClothingActor
  • getGraphicalLod() : nvidia::apex::ClothingActor
  • getGraphicalLodValue() : nvidia::apex::ClothingAsset
  • getIndices() : nvidia::apex::ClothingPhysicalMesh
  • getLodValue() : nvidia::apex::ClothingAssetAuthoring
  • getMasterFlagsBuffer() : nvidia::apex::ClothingPhysicalMesh
  • getMaterialLibrary() : nvidia::apex::ClothingAssetAuthoring
  • getMaxDistanceBlendTime() : nvidia::apex::ClothingActor
  • getMaximumSimulationBudget() : nvidia::apex::ClothingActor
  • getMeshSkinningMap() : nvidia::apex::ClothingAsset
  • getMeshSkinningMapSize() : nvidia::apex::ClothingAsset
  • getNormals() : nvidia::apex::ClothingPhysicalMesh
  • getNumActors() : nvidia::apex::ClothingAsset
  • getNumBones() : nvidia::apex::ClothingAsset
  • getNumBonesPerVertex() : nvidia::apex::ClothingPhysicalMesh
  • getNumGraphicalLodLevels() : nvidia::apex::ClothingAsset
  • getNumGraphicalVerticesActive() : nvidia::apex::ClothingActor
  • getNumIndices() : nvidia::apex::ClothingPhysicalMesh
  • getNumLods() : nvidia::apex::ClothingAssetAuthoring
  • getNumMaxDistance0Vertices() : nvidia::apex::ClothingPhysicalMesh
  • getNumPlanes() : nvidia::apex::ClothingConvex
  • getNumPlatforms() : nvidia::apex::ClothingAssetAuthoring
  • getNumSimulatedIndices() : nvidia::apex::ClothingPhysicalMesh
  • getNumSimulatedVertices() : nvidia::apex::ClothingPhysicalMesh
  • getNumSimulationVertices() : nvidia::apex::ClothingActor
  • getNumUsedBones() : nvidia::apex::ClothingAsset
  • getNumVertices() : nvidia::apex::ClothingPhysicalMesh
  • getPhysicalMeshNormals() : nvidia::apex::ClothingActor
  • getPhysicalMeshPositions() : nvidia::apex::ClothingActor
  • getPlane() : nvidia::apex::ClothingPlane
  • getPlanes() : nvidia::apex::ClothingConvex
  • getPlatform() : nvidia::apex::ClothingAssetAuthoring
  • getPose() : nvidia::apex::ClothingTriangleMesh
  • getPosition() : nvidia::apex::ClothingSphere
  • getRadius() : nvidia::apex::ClothingSphere
  • getRefCount()
: nvidia::apex::ClothingSphere
, nvidia::apex::ClothingPlane
  • getRenderGlobalPose() : nvidia::apex::ClothingActor
  • getRenderMeshAsset() : nvidia::apex::ClothingAsset
  • getRenderMeshAssetAuthoring() : nvidia::apex::ClothingAssetAuthoring
  • getSimulationNormals() : nvidia::apex::ClothingActor
  • getSimulationPositions() : nvidia::apex::ClothingActor
  • getSimulationVelocities() : nvidia::apex::ClothingActor
  • getSpheres() : nvidia::apex::ClothingCapsule
  • getStats() : nvidia::apex::ClothingPhysicalMesh
  • getType() : nvidia::apex::ClothingCollision
  • getVertices() : nvidia::apex::ClothingPhysicalMesh

- h -

  • hasSimulatedData() : nvidia::apex::ClothingRenderProxy

- i -

  • isCapsule() : nvidia::apex::ClothingCollision
  • isConvex() : nvidia::apex::ClothingCollision
  • isFrozen() : nvidia::apex::ClothingActor
  • isHalfPrecisionAllowed() : nvidia::apex::ClothingActor
  • isPlane() : nvidia::apex::ClothingCollision
  • isSphere() : nvidia::apex::ClothingCollision
  • isTetrahedralMesh() : nvidia::apex::ClothingPhysicalMesh
  • isTriangleMesh() : nvidia::apex::ClothingCollision
  • isVisible() : nvidia::apex::ClothingActor

- l -

  • lockTriangles() : nvidia::apex::ClothingTriangleMesh
  • lockTrianglesWrite() : nvidia::apex::ClothingTriangleMesh

- p -

  • prepareMorphTargetMapping() : nvidia::apex::ClothingAsset

- r -

  • rayCast() : nvidia::apex::ClothingActor
  • releaseGraphicalData() : nvidia::apex::ClothingAsset
  • releaseWithPlanes() : nvidia::apex::ClothingConvex
  • releaseWithSpheres() : nvidia::apex::ClothingCapsule
  • remapBoneIndex() : nvidia::apex::ClothingAsset
  • removePlatform() : nvidia::apex::ClothingAssetAuthoring
  • removeTriangle() : nvidia::apex::ClothingTriangleMesh
  • removeTriangles() : nvidia::apex::ClothingTriangleMesh

- s -

  • setBoneBindPose() : nvidia::apex::ClothingAssetAuthoring
  • setBoneInfo() : nvidia::apex::ClothingAssetAuthoring
  • setClothingMaterial() : nvidia::apex::ClothingActor
  • setCollision() : nvidia::apex::ClothingAssetAuthoring
  • setDefaultConstrainCoefficients() : nvidia::apex::ClothingAssetAuthoring
  • setDeriveNormalsFromBones() : nvidia::apex::ClothingAssetAuthoring
  • setExportScale() : nvidia::apex::ClothingAssetAuthoring
  • setFrozen() : nvidia::apex::ClothingActor
  • setGeometry() : nvidia::apex::ClothingPhysicalMesh
  • setGraphicalLOD() : nvidia::apex::ClothingActor
  • setHalfPrecision() : nvidia::apex::ClothingActor
  • setInvalidConstrainCoefficients() : nvidia::apex::ClothingAssetAuthoring
  • setMaterialLibrary() : nvidia::apex::ClothingAssetAuthoring
  • setMaxDistanceBlendTime() : nvidia::apex::ClothingActor
  • setMeshes() : nvidia::apex::ClothingAssetAuthoring
  • setOverrideMaterial() : nvidia::apex::ClothingActor
  • setPlane() : nvidia::apex::ClothingPlane
  • setPose() : nvidia::apex::ClothingTriangleMesh
  • setPosition() : nvidia::apex::ClothingSphere
  • setRadius() : nvidia::apex::ClothingSphere
  • setRootBone() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationDisableCCD() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationGravityDirection() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationHierarchicalLevels() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationRestLengthScale() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationSleepLinearVelocity() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationThickness() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationTwowayInteraction() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationUntangling() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationVirtualParticleDensity() : nvidia::apex::ClothingAssetAuthoring
  • setVelocityCallback() : nvidia::apex::ClothingActor
  • setVisible() : nvidia::apex::ClothingActor
  • setWind() : nvidia::apex::ClothingActor
  • simplify() : nvidia::apex::ClothingPhysicalMesh

- u -

  • unlockTriangles() : nvidia::apex::ClothingTriangleMesh
  • updateBindPoses() : nvidia::apex::ClothingAssetAuthoring
  • updateMaxDistanceScale() : nvidia::apex::ClothingActor
  • updateState()
: nvidia::apex::ClothingActor
, nvidia::apex::ClothingPreview

- v -

  • velocityShader() : nvidia::apex::ClothingVelocityCallback
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Class Members - Variables

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • collisionSphereDistance : nvidia::apex::ClothingConstrainCoefficients
  • collisionSphereRadius : nvidia::apex::ClothingConstrainCoefficients
  • maxDistance : nvidia::apex::ClothingConstrainCoefficients
  • normalBary : nvidia::apex::ClothingMeshSkinningMap
  • numIndices : nvidia::apex::ClothingPhysicalMeshStats
  • numVertices : nvidia::apex::ClothingPhysicalMeshStats
  • positionBary : nvidia::apex::ClothingMeshSkinningMap
  • tangentBary : nvidia::apex::ClothingMeshSkinningMap
  • totalBytes : nvidia::apex::ClothingPhysicalMeshStats
  • vertexIndex0 : nvidia::apex::ClothingMeshSkinningMap
  • vertexIndex1 : nvidia::apex::ClothingMeshSkinningMap
  • vertexIndex2 : nvidia::apex::ClothingMeshSkinningMap
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Class Hierarchy

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
  • nvidia::apex::ClothingActor
  • nvidia::apex::ClothingAsset
  • nvidia::apex::ClothingAssetAuthoring
  • nvidia::apex::ClothingCollision
    • nvidia::apex::ClothingCapsule
    • nvidia::apex::ClothingConvex
    • nvidia::apex::ClothingPlane
    • nvidia::apex::ClothingSphere
    • nvidia::apex::ClothingTriangleMesh
  • nvidia::apex::ClothingCollisionType
  • nvidia::apex::ClothingConstrainCoefficients
  • nvidia::apex::ClothingMeshSkinningMap
  • nvidia::apex::ClothingPhysicalMesh
  • nvidia::apex::ClothingPhysicalMeshStats
  • nvidia::apex::ClothingPreview
  • nvidia::apex::ClothingRenderProxy
  • nvidia::apex::ClothingTeleportMode
  • nvidia::apex::ClothingVelocityCallback
  • nvidia::apex::ClothSolverMode
  • nvidia::apex::ModuleClothing
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: APEX Clothing API Documentation

  • Related Pages
APEX Clothing API Documentation

Overview

This document contains a full API documentation for all public classes.

Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: ModuleClothing.h Source File

  • Related Pages
  • File List
ModuleClothing.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_CLOTHING_H
00031 #define MODULE_CLOTHING_H
00032
00033 #include "Module.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class ClothingAsset;
00043 class ClothingAssetAuthoring;
00044 class ClothingPhysicalMesh;
00045
00046 class IProgressListener;
00047 class RenderMeshAssetAuthoring;
00048
00064 class ModuleClothing : public Module
00065 {
00066 public:
00070     virtual ClothingPhysicalMesh* createEmptyPhysicalMesh() = 0;
00071
00081     virtual ClothingPhysicalMesh* createSingleLayeredMesh(RenderMeshAssetAuthoring* asset, uint32_t subdivision, bool mergeVertices, bool closeHoles, IProgressListener* progress) = 0;
00082
00083 protected:
00084     virtual ~ModuleClothing() {}
00085 };
00086
00087 #if !defined(_USRDLL)
00088
00092 void instantiateModuleClothing();
00093 #endif
00094
00095
00096 PX_POP_PACK
00097
00098 }
00099 } // namespace nvidia
00100
00101 #endif // MODULE_CLOTHING_H
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Related Pages

  • Related Pages
Related Pages
Here is a list of all related documentation pages:
  • Deprecated List
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingCollisionType Struct Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingCollisionType
Public Types
nvidia::apex::ClothingCollisionType Struct Reference

Type of the ClothingCollision. More...

#include <ClothingCollision.h>

List of all members.

Public Types

enum Enum {
Plane,
Convex,
Sphere,
Capsule,
TriangleMesh
}
Enum.

Detailed Description

Type of the ClothingCollision.

The documentation for this struct was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingCollisionType
nvidia::apex::ClothingCollisionType Member List
This is the complete list of members for nvidia::apex::ClothingCollisionType, including all inherited members.
Capsule enum value (defined in nvidia::apex::ClothingCollisionType) | nvidia::apex::ClothingCollisionType
Convex enum value (defined in nvidia::apex::ClothingCollisionType) | nvidia::apex::ClothingCollisionType
Enum enum name | nvidia::apex::ClothingCollisionType
Plane enum value (defined in nvidia::apex::ClothingCollisionType) | nvidia::apex::ClothingCollisionType
Sphere enum value (defined in nvidia::apex::ClothingCollisionType) | nvidia::apex::ClothingCollisionType
TriangleMesh enum value (defined in nvidia::apex::ClothingCollisionType) | nvidia::apex::ClothingCollisionType
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingConstrainCoefficients Struct Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingConstrainCoefficients
Public Attributes
nvidia::apex::ClothingConstrainCoefficients Struct Reference

Constrain coefficients of the physical mesh vertices. More...

#include <ClothingPhysicalMesh.h>

List of all members.

Public Attributes

float | maxDistance
Maximum distance a vertex is allowed to move.
float | collisionSphereRadius
Backstop sphere radius.
float | collisionSphereDistance
Backstop sphere distance.

Detailed Description

Constrain coefficients of the physical mesh vertices.

The documentation for this struct was generated from the following file:
  • ClothingPhysicalMesh.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingConstrainCoefficients
nvidia::apex::ClothingConstrainCoefficients Member List
This is the complete list of members for nvidia::apex::ClothingConstrainCoefficients, including all inherited members.
collisionSphereDistance | nvidia::apex::ClothingConstrainCoefficients
collisionSphereRadius | nvidia::apex::ClothingConstrainCoefficients
maxDistance | nvidia::apex::ClothingConstrainCoefficients
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingMeshSkinningMap Struct Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingMeshSkinningMap
Public Attributes
nvidia::apex::ClothingMeshSkinningMap Struct Reference

Maps from a triangle of the simulated mesh to a vertex of the rendered mesh. The barycentric coordinates describe the position of a point in space relative to a simulated triangle. The actual z-coordinate is computed by bary.z = 1 - bary.x - bary.y. The z part of the vector contains the height of the skinned vertex along the normal of the simulated triangle. More...

#include <ClothingAsset.h>

List of all members.

Public Attributes

PxVec3 | positionBary
Barycentric coordinates of the graphical vertex relative to the simulated triangle.
uint32_t | vertexIndex0
First vertex of the simulated triangle.
PxVec3 | normalBary
Barycentric coordinates of a point that represents the normal. The actual normal can be extracted by subtracting the skinned position from this point.
uint32_t | vertexIndex1
Second vertex of the simulated triangle.
PxVec3 | tangentBary
Barycentric coordinates of a point that represents the tangent. The actual tangent can be extracted by subtracting the skinned position from this point.
uint32_t | vertexIndex2
Third vertex of the simulated triangle.

Detailed Description

Maps from a triangle of the simulated mesh to a vertex of the rendered mesh. The barycentric coordinates describe the position of a point in space relative to a simulated triangle. The actual z-coordinate is computed by bary.z = 1 - bary.x - bary.y. The z part of the vector contains the height of the skinned vertex along the normal of the simulated triangle.

So, the following computes the new skinned position:

uint32_t i0 = map[mapId].vertexIndex0; uint32_t i1 = map[mapId].vertexIndex1; uint32_t i2 = map[mapId].vertexIndex2;

PxVec3 bary = map[mapId].positionBary; float heightOffset = bary.z * actorScale; bary.z = (1 - bary.x - bary.y);

PxVec3 posOnTriangle = physPositions[i0] * bary.x + physPositions[i1] * bary.y + physPositions[i2] * bary.z;

offsetFromTriangle = (physNormals[i0] * bary.x + physNormals[i1] * bary.y + physNormals[i2] * bary.z) heightOffset;

skinnedPos = posOnTriangle + offsetFromTriangle;

Member Data Documentation

PxVec3 nvidia::apex::ClothingMeshSkinningMap::normalBary

Barycentric coordinates of a point that represents the normal. The actual normal can be extracted by subtracting the skinned position from this point.

Note:
PX_MAX_F32 values represent invalid coordinates.
PxVec3 nvidia::apex::ClothingMeshSkinningMap::positionBary

Barycentric coordinates of the graphical vertex relative to the simulated triangle.

Note:
PX_MAX_F32 values represent invalid coordinates.
PxVec3 nvidia::apex::ClothingMeshSkinningMap::tangentBary

Barycentric coordinates of a point that represents the tangent. The actual tangent can be extracted by subtracting the skinned position from this point.

Note:
PX_MAX_F32 values represent invalid coordinates.
The documentation for this struct was generated from the following file:
  • ClothingAsset.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingMeshSkinningMap
nvidia::apex::ClothingMeshSkinningMap Member List
This is the complete list of members for nvidia::apex::ClothingMeshSkinningMap, including all inherited members.
normalBary | nvidia::apex::ClothingMeshSkinningMap
positionBary | nvidia::apex::ClothingMeshSkinningMap
tangentBary | nvidia::apex::ClothingMeshSkinningMap
vertexIndex0 | nvidia::apex::ClothingMeshSkinningMap
vertexIndex1 | nvidia::apex::ClothingMeshSkinningMap
vertexIndex2 | nvidia::apex::ClothingMeshSkinningMap
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingPhysicalMeshStats Struct Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPhysicalMeshStats
Public Attributes
nvidia::apex::ClothingPhysicalMeshStats Struct Reference

Contains the data for handing out statistics about a ClothingPhysicalMesh. More...

#include <ClothingPhysicalMesh.h>

List of all members.

Public Attributes

uint32_t | totalBytes
the number of bytes allocated for the physical mesh
uint32_t | numVertices
the number of vertices
uint32_t | numIndices
the number of indices

Detailed Description

Contains the data for handing out statistics about a ClothingPhysicalMesh.

The documentation for this struct was generated from the following file:
  • ClothingPhysicalMesh.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPhysicalMeshStats
nvidia::apex::ClothingPhysicalMeshStats Member List
This is the complete list of members for nvidia::apex::ClothingPhysicalMeshStats, including all inherited members.
numIndices | nvidia::apex::ClothingPhysicalMeshStats
numVertices | nvidia::apex::ClothingPhysicalMeshStats
totalBytes | nvidia::apex::ClothingPhysicalMeshStats
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothingTeleportMode Struct Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingTeleportMode
Public Types
nvidia::apex::ClothingTeleportMode Struct Reference

selects the mode the clothing actor will be in the simulation frame More...

#include <ClothingActor.h>

List of all members.

Public Types

enum Enum {
Continuous,
Teleport,
TeleportAndReset
}
the enum type More...

Detailed Description

selects the mode the clothing actor will be in the simulation frame

Member Enumeration Documentation

enum nvidia::apex::ClothingTeleportMode::Enum

the enum type

Enumerator:
Continuous

Simulation continues smoothly. This is the most commonly used mode.

Teleport

Transforms the current simulation state from the old global pose to the new global pose.

This will transform positions and velocities and thus keep the simulation state, just translate it to a new pose.

TeleportAndReset

Forces the cloth to the animated position in the next frame.

This can be used to reset it from a bad state or by a teleport where the old state is not important anymore.

The documentation for this struct was generated from the following file:
  • ClothingActor.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingTeleportMode
nvidia::apex::ClothingTeleportMode Member List
This is the complete list of members for nvidia::apex::ClothingTeleportMode, including all inherited members.
Continuous enum value | nvidia::apex::ClothingTeleportMode
Enum enum name | nvidia::apex::ClothingTeleportMode
Teleport enum value | nvidia::apex::ClothingTeleportMode
TeleportAndReset enum value | nvidia::apex::ClothingTeleportMode
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: nvidia::apex::ClothSolverMode Struct Reference

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothSolverMode
Public Types
nvidia::apex::ClothSolverMode Struct Reference

Describes the solver that is used to simulate the clothing actor. More...

#include <ClothingAsset.h>

List of all members.

Public Types

enum Enum { v3 }
the enum type More...

Detailed Description

Describes the solver that is used to simulate the clothing actor.

Member Enumeration Documentation

enum nvidia::apex::ClothSolverMode::Enum

the enum type

Enumerator:
v3

The actor is simulated using the 3.x cloth solver.

The documentation for this struct was generated from the following file:
  • ClothingAsset.h
Generated on Sat Dec 1 2018 10:18:19


APEX Clothing Module: Member List

  • Related Pages
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothSolverMode
nvidia::apex::ClothSolverMode Member List
This is the complete list of members for nvidia::apex::ClothSolverMode, including all inherited members.
Enum enum name | nvidia::apex::ClothSolverMode
v3 enum value | nvidia::apex::ClothSolverMode
Generated on Sat Dec 1 2018 10:18:19


APEX Destructible Module: Class List

  • Class List
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
nvidia::apex::ApexChunkFlag |
nvidia::apex::BSPOpenMode |
nvidia::apex::ChunkData |
nvidia::apex::ChunkParticleReportData |
nvidia::apex::ChunkStateEventData |
nvidia::apex::ChunkTransformHeader |
nvidia::apex::ChunkTransformUnit |
nvidia::apex::CollisionDesc |
nvidia::apex::CollisionVolumeDesc |
nvidia::apex::ExplicitHierarchicalMesh::ConvexHull |
FractureTools::CutoutParameters |
FractureTools::CutoutSet |
nvidia::apex::DamageEventCoreData |
nvidia::apex::DamageEventHeader |
nvidia::apex::DamageEventReportData |
nvidia::apex::DamageEventUnit |
nvidia::apex::DamageSpreadFunction |
nvidia::apex::DestructibleActor |
nvidia::apex::DestructibleActorChunkFlags |
nvidia::apex::DestructibleActorJoint |
nvidia::apex::DestructibleActorJointDesc |
nvidia::apex::DestructibleActorMeshType |
nvidia::apex::DestructibleActorRaycastFlags |
nvidia::apex::DestructibleActorSyncFlags |
nvidia::apex::DestructibleActorSyncState |
nvidia::apex::DestructibleAsset |
nvidia::apex::DestructibleAssetAuthoring |
nvidia::apex::DestructibleAssetCookingDesc |
nvidia::apex::DestructibleAssetStats |
nvidia::apex::DestructibleBehaviorGroupDesc |
nvidia::apex::DestructibleCallbackSchedule |
nvidia::apex::DestructibleChunkDesc |
nvidia::apex::DestructibleChunkEvent |
nvidia::apex::DestructibleChunkSyncState |
nvidia::apex::DestructibleDepthParameters |
nvidia::apex::DestructibleDepthParametersFlag | PX_PS4
nvidia::apex::DestructibleEmitterType |
nvidia::apex::DestructibleGeometryDesc |
nvidia::apex::DestructibleHitChunk |
nvidia::apex::DestructibleInitParameters |
nvidia::apex::DestructibleInitParametersFlag |
nvidia::apex::DestructibleParameterizedType |
nvidia::apex::DestructibleParameters |
nvidia::apex::DestructibleParametersFlag |
nvidia::apex::DestructiblePhysXActorQueryFlags |
nvidia::apex::DestructiblePreview | Destructible module's derivation AssetPreview
nvidia::apex::DestructibleRenderable |
nvidia::apex::DestructibleRTFractureParameters |
nvidia::apex::DisplacementMapVolume |
nvidia::apex::ExplicitHierarchicalMesh::Embedding |
nvidia::apex::ExplicitHierarchicalMesh |
nvidia::apex::ExplicitSubmeshData |
nvidia::apex::ExplicitVertexFormat |
nvidia::apex::DestructibleRTFractureParameters::FractureAttachment |
FractureTools::FractureCutoutDesc |
nvidia::apex::FractureEventHeader |
nvidia::apex::FractureEventUnit |
nvidia::apex::DestructibleRTFractureParameters::FractureGlass |
nvidia::apex::FractureMaterialDesc |
nvidia::apex::FractureMethod |
FractureTools::FractureSliceDesc |
nvidia::apex::FractureToolsAPI |
FractureTools::FractureVoronoiDesc |
nvidia::apex::ImpactDamageEventData |
nvidia::apex::MaterialFrame |
FractureTools::MeshProcessingParameters |
nvidia::apex::ModuleDestructible |
nvidia::apex::ModuleDestructibleConst |
FractureTools::NoiseParameters |
FractureTools::SliceParameters |
nvidia::apex::UserChunkParticleReport |
nvidia::apex::UserChunkReport |
nvidia::apex::UserDestructiblePhysXActorReport |
nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > |
nvidia::apex::UserImpactDamageReport |
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Index

  • Class List
  • Class Hierarchy
  • Class Members
Class Index
A | B | C | D | E | F | I | M | N | S | U
A
DamageEventReportData (nvidia::apex) DestructibleChunkDesc (nvidia::apex) DisplacementMapVolume (nvidia::apex)
I
ApexChunkFlag (nvidia::apex) DamageEventUnit (nvidia::apex) DestructibleChunkEvent (nvidia::apex)
E
ImpactDamageEventData (nvidia::apex)
B
DamageSpreadFunction (nvidia::apex) DestructibleChunkSyncState (nvidia::apex) ExplicitHierarchicalMesh::Embedding (nvidia::apex)
M
BSPOpenMode (nvidia::apex) DestructibleActor (nvidia::apex) DestructibleDepthParameters (nvidia::apex) ExplicitHierarchicalMesh (nvidia::apex) MaterialFrame (nvidia::apex)
C
DestructibleActorChunkFlags (nvidia::apex) DestructibleDepthParametersFlag (nvidia::apex) ExplicitSubmeshData (nvidia::apex) MeshProcessingParameters (FractureTools)
ChunkData (nvidia::apex) DestructibleActorJoint (nvidia::apex) DestructibleEmitterType (nvidia::apex) ExplicitVertexFormat (nvidia::apex) ModuleDestructible (nvidia::apex)
ChunkParticleReportData (nvidia::apex) DestructibleActorJointDesc (nvidia::apex) DestructibleGeometryDesc (nvidia::apex)
F
ModuleDestructibleConst (nvidia::apex)
ChunkStateEventData (nvidia::apex) DestructibleActorMeshType (nvidia::apex) DestructibleHitChunk (nvidia::apex) DestructibleRTFractureParameters::FractureAttachment (nvidia::apex)
N
ChunkTransformHeader (nvidia::apex) DestructibleActorRaycastFlags (nvidia::apex) DestructibleInitParameters (nvidia::apex) FractureCutoutDesc (FractureTools) NoiseParameters (FractureTools)
ChunkTransformUnit (nvidia::apex) DestructibleActorSyncFlags (nvidia::apex) DestructibleInitParametersFlag (nvidia::apex) FractureEventHeader (nvidia::apex)
S
CollisionDesc (nvidia::apex) DestructibleActorSyncState (nvidia::apex) DestructibleParameterizedType (nvidia::apex) FractureEventUnit (nvidia::apex) SliceParameters (FractureTools)
CollisionVolumeDesc (nvidia::apex) DestructibleAsset (nvidia::apex) DestructibleParameters (nvidia::apex) DestructibleRTFractureParameters::FractureGlass (nvidia::apex)
U
ExplicitHierarchicalMesh::ConvexHull (nvidia::apex) DestructibleAssetAuthoring (nvidia::apex) DestructibleParametersFlag (nvidia::apex) FractureMaterialDesc (nvidia::apex) UserChunkParticleReport (nvidia::apex)
CutoutParameters (FractureTools) DestructibleAssetCookingDesc (nvidia::apex) DestructiblePhysXActorQueryFlags (nvidia::apex) FractureMethod (nvidia::apex) UserChunkReport (nvidia::apex)
CutoutSet (FractureTools) DestructibleAssetStats (nvidia::apex) DestructiblePreview (nvidia::apex) FractureSliceDesc (FractureTools) UserDestructiblePhysXActorReport (nvidia::apex)
D
DestructibleBehaviorGroupDesc (nvidia::apex) DestructibleRenderable (nvidia::apex) FractureToolsAPI (nvidia::apex) UserDestructibleSyncHandler (nvidia::apex)
DamageEventCoreData (nvidia::apex) DestructibleCallbackSchedule (nvidia::apex) DestructibleRTFractureParameters (nvidia::apex) FractureVoronoiDesc (FractureTools) UserImpactDamageReport (nvidia::apex)
DamageEventHeader (nvidia::apex)
A | B | C | D | E | F | I | M | N | S | U
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: FractureTools::CutoutSet Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • CutoutSet
Public Member Functions | Protected Member Functions
FractureTools::CutoutSet Class Reference

#include <FractureToolsStructs.h>

List of all members.

Public Member Functions

virtual uint32_t | getCutoutCount () const =0
virtual uint32_t | getCutoutVertexCount (uint32_t cutoutIndex) const =0
virtual uint32_t | getCutoutLoopCount (uint32_t cutoutIndex) const =0
virtual const physx::PxVec3 & | getCutoutVertex (uint32_t cutoutIndex, uint32_t vertexIndex) const =0
virtual uint32_t | getCutoutLoopSize (uint32_t coutoutIndex, uint32_t loopIndex) const =0
virtual uint32_t | getCutoutLoopVertexIndex (uint32_t cutoutIndex, uint32_t loopIndex, uint32_t vertexNum) const =0
virtual uint32_t | getCutoutLoopVertexFlags (uint32_t cutoutIndex, uint32_t loopIndex, uint32_t vertexNum) const =0
virtual bool | isPeriodic () const =0
virtual const physx::PxVec2 & | getDimensions () const =0
virtual void | release ()=0

Protected Member Functions

virtual | ~CutoutSet ()

Detailed Description

Interface to a "cutout set," used with chippable fracturing. A cutout set is created from a bitmap. The result is turned into cutouts which are applied to the mesh. For example, a bitmap which looks like a brick pattern will generate a cutout for each "brick," forming the cutout set.

Each cutout is a 2D entity, meant to be projected onto various faces of a mesh. They are represented by a set of 2D vertices, which form closed loops. More than one loop may represent a single cutout, if the loops are forced to be convex. Otherwise, a cutout is represented by a single loop.

Constructor & Destructor Documentation

virtual FractureTools::CutoutSet::~CutoutSet ( ) [inline, protected, virtual]

Protected destructor. Use the release() method.

Member Function Documentation

virtual uint32_t FractureTools::CutoutSet::getCutoutCount ( ) const [pure virtual]

Returns the number of cutouts in the set.

virtual uint32_t FractureTools::CutoutSet::getCutoutLoopCount ( uint32_t cutoutIndex ) const [pure virtual]

Applies to the cutout indexed by cutoutIndex: Returns the number of loops in this cutout.

virtual uint32_t FractureTools::CutoutSet::getCutoutLoopSize | ( | uint32_t | coutoutIndex,
 |  | uint32_t | loopIndex
 | ) |  | const [pure virtual]

Applies to the cutout indexed by cutoutIndex: Returns the number of vertices in the loop indexed by loopIndex.

virtual uint32_t FractureTools::CutoutSet::getCutoutLoopVertexFlags | ( | uint32_t | cutoutIndex,
 |  | uint32_t | loopIndex,
 |  | uint32_t | vertexNum
 | ) |  | const [pure virtual]

Applies to the cutout indexed by cutoutIndex: Returns the flags of the vertex indexed by vertexNum, in the loop indexed by loopIndex.

virtual uint32_t FractureTools::CutoutSet::getCutoutLoopVertexIndex | ( | uint32_t | cutoutIndex,
 |  | uint32_t | loopIndex,
 |  | uint32_t | vertexNum
 | ) |  | const [pure virtual]

Applies to the cutout indexed by cutoutIndex: Returns the vertex index of the vertex indexed by vertexNum, in the loop indexed by loopIndex.

virtual const physx::PxVec3& FractureTools::CutoutSet::getCutoutVertex | ( | uint32_t | cutoutIndex,
 |  | uint32_t | vertexIndex
 | ) |  | const [pure virtual]

Applies to the cutout indexed by cutoutIndex: Returns the vertex indexed by vertexIndex. (Only the X and Y coordinates are used.)

virtual uint32_t FractureTools::CutoutSet::getCutoutVertexCount ( uint32_t cutoutIndex ) const [pure virtual]

Applies to the cutout indexed by cutoutIndex: Returns the number of vertices in the cutout.

virtual const physx::PxVec2& FractureTools::CutoutSet::getDimensions ( ) const [pure virtual]

The dimensions of the fracture map used to create the cutout set.

virtual bool FractureTools::CutoutSet::isPeriodic ( ) const [pure virtual]

Whether or not this cutout set is to be tiled.

virtual void FractureTools::CutoutSet::release ( ) [pure virtual]

Serialization Releases all memory and deletes itself.

The documentation for this class was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • CutoutSet
FractureTools::CutoutSet Member List
This is the complete list of members for FractureTools::CutoutSet, including all inherited members.
getCutoutCount() const =0 | FractureTools::CutoutSet | [pure virtual]
getCutoutLoopCount(uint32_t cutoutIndex) const =0 | FractureTools::CutoutSet | [pure virtual]
getCutoutLoopSize(uint32_t coutoutIndex, uint32_t loopIndex) const =0 | FractureTools::CutoutSet | [pure virtual]
getCutoutLoopVertexFlags(uint32_t cutoutIndex, uint32_t loopIndex, uint32_t vertexNum) const =0 | FractureTools::CutoutSet | [pure virtual]
getCutoutLoopVertexIndex(uint32_t cutoutIndex, uint32_t loopIndex, uint32_t vertexNum) const =0 | FractureTools::CutoutSet | [pure virtual]
getCutoutVertex(uint32_t cutoutIndex, uint32_t vertexIndex) const =0 | FractureTools::CutoutSet | [pure virtual]
getCutoutVertexCount(uint32_t cutoutIndex) const =0 | FractureTools::CutoutSet | [pure virtual]
getDimensions() const =0 | FractureTools::CutoutSet | [pure virtual]
isPeriodic() const =0 | FractureTools::CutoutSet | [pure virtual]
release()=0 | FractureTools::CutoutSet | [pure virtual]
~CutoutSet() | FractureTools::CutoutSet | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleActor Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActor
Public Member Functions | Protected Member Functions
nvidia::apex::DestructibleActor Class Reference

#include <DestructibleActor.h>

List of all members.

Public Member Functions

virtual const RenderMeshActor * | getRenderMeshActor (DestructibleActorMeshType::Enum type=DestructibleActorMeshType::Skinned) const =0
virtual const
DestructibleParameters & 		getDestructibleParameters () const =0
virtual void | setDestructibleParameters (const DestructibleParameters &destructibleParameters)=0
virtual PxMat44 | getInitialGlobalPose () const =0
virtual void | setInitialGlobalPose (const PxMat44 &pose)=0
virtual PxVec3 | getScale () const =0
virtual bool | isInitiallyDynamic () const =0
virtual void | getChunkVisibilities (uint8_t *visibilityArray, uint32_t visibilityArraySize) const =0
virtual uint32_t | getNumVisibleChunks () const =0
virtual const uint16_t * | getVisibleChunks () const =0
virtual bool | acquireChunkEventBuffer (const nvidia::DestructibleChunkEvent *&buffer, uint32_t &bufferSize)=0
virtual bool | releaseChunkEventBuffer (bool clearBuffer=true)=0
virtual bool | acquirePhysXActorBuffer (physx::PxRigidDynamic **&buffer, uint32_t &bufferSize, uint32_t flags=DestructiblePhysXActorQueryFlags::AllStates)=0
virtual bool | releasePhysXActorBuffer ()=0
virtual physx::PxRigidDynamic * | getChunkPhysXActor (uint32_t chunkIndex)=0
virtual uint32_t | getChunkPhysXShapes (physx::PxShape **&shapes, uint32_t chunkIndex) const =0
virtual PxTransform | getChunkPose (uint32_t chunkIndex) const =0
virtual PxTransform | getChunkTransform (uint32_t chunkIndex) const =0
virtual PxVec3 | getChunkLinearVelocity (uint32_t chunkIndex) const =0
virtual PxVec3 | getChunkAngularVelocity (uint32_t chunkIndex) const =0
virtual const PxMat44 | getChunkTM (uint32_t chunkIndex) const =0
virtual int32_t | getChunkBehaviorGroupIndex (uint32_t chunkIndex) const =0
virtual uint32_t | getChunkActorFlags (uint32_t chunkIndex) const =0
virtual void | setGlobalPose (const PxMat44 &pose)=0
virtual bool | getGlobalPose (PxMat44 &pose)=0
virtual void | setLinearVelocity (const PxVec3 &linearVelocity)=0
virtual void | setAngularVelocity (const PxVec3 &angularVelocity)=0
virtual void | setDynamic (int32_t chunkIndex=ModuleDestructibleConst::INVALID_CHUNK_INDEX)=0
virtual bool | isDynamic (uint32_t chunkIndex) const =0
virtual void | enableHardSleeping ()=0
virtual void | disableHardSleeping (bool wake=false)=0
virtual bool | isHardSleepingEnabled () const =0
virtual bool | setChunkPhysXActorAwakeState (uint32_t chunkIndex, bool awake)=0
virtual bool | addForce (uint32_t chunkIndex, const PxVec3 &force, physx::PxForceMode::Enum mode, const PxVec3 *position=NULL, bool wakeup=true)=0
virtual void | setSkinnedOverrideMaterial (uint32_t submeshIndex, const char *overrideMaterialName)=0
virtual void | setStaticOverrideMaterial (uint32_t submeshIndex, const char *overrideMaterialName)=0
virtual void | setRuntimeFractureOverridePattern (const char *overridePatternName)=0
virtual void | applyDamage (float damage, float momentum, const PxVec3 &position, const PxVec3 &direction, int32_t chunkIndex=ModuleDestructibleConst::INVALID_CHUNK_INDEX, void *damageUserData=NULL)=0
virtual void | applyRadiusDamage (float damage, float momentum, const PxVec3 &position, float radius, bool falloff, void *damageUserData=NULL)=0
virtual void | takeImpact (const PxVec3 &force, const PxVec3 &position, uint16_t chunkIndex, PxActor const *damageImpactActor)=0
virtual int32_t | rayCast (float &time, PxVec3 &normal, const PxVec3 &worldRayOrig, const PxVec3 &worldRayDir, DestructibleActorRaycastFlags::Enum flags, int32_t parentChunkIndex=ModuleDestructibleConst::INVALID_CHUNK_INDEX) const =0
virtual int32_t | obbSweep (float &time, PxVec3 &normal, const PxVec3 &worldBoxCenter, const PxVec3 &worldBoxExtents, const PxMat33 &worldBoxRot, const PxVec3 &worldDisplacement, DestructibleActorRaycastFlags::Enum flags) const =0
virtual void | setCrumbleEmitterState (bool enable)=0
virtual void | setDustEmitterState (bool enable)=0
virtual void | setPreferredRenderVolume (RenderVolume *volume, DestructibleEmitterType::Enum type)=0
virtual EmitterActor * | getApexEmitter (DestructibleEmitterType::Enum type)=0
virtual bool | recreateApexEmitter (DestructibleEmitterType::Enum type)=0
virtual const
::NvParameterized::Interface * 		getNvParameterized (DestructibleParameterizedType::Enum type=DestructibleParameterizedType::State) const =0
Returns the actor's NvParamaterized interface This cannot be directly modified! It is read only to the user. This handle can be used to directly serialize the complete actor state.
virtual void | setNvParameterized (::NvParameterized::Interface *)=0
Sets the actor's state via the NvParameterized object This can be used to update the state from deserialized data. The actor assumes control of the interface.
virtual bool | setSyncParams (uint32_t userActorID, uint32_t actorSyncFlags=0, const DestructibleActorSyncState *actorSyncState=NULL, const DestructibleChunkSyncState *chunkSyncState=NULL)=0
virtual bool | setHitChunkTrackingParams (bool flushHistory, bool startTracking, uint32_t trackingDepth, bool trackAllChunks=true)=0
virtual bool | getHitChunkHistory (const DestructibleHitChunk *&hitChunkContainer, uint32_t &hitChunkCount) const =0
virtual bool | forceChunkHits (const DestructibleHitChunk *hitChunkContainer, uint32_t hitChunkCount, bool removeChunks=true, bool deferredEvent=false, PxVec3 damagePosition=PxVec3(0.0f), PxVec3 damageDirection=PxVec3(0.0f))=0
virtual bool | getDamageColoringHistory (const DamageEventCoreData *&damageEventCoreDataContainer, uint32_t &damageEventCoreDataCount) const =0
virtual bool | forceDamageColoring (const DamageEventCoreData *damageEventCoreDataContainer, uint32_t damageEventCoreDataCount)=0
virtual PxBounds3 | getLocalBounds () const =0
virtual PxBounds3 | getOriginalBounds () const =0
virtual bool | isChunkSolitary (int32_t chunkIndex) const =0
virtual PxBounds3 | getChunkBounds (uint32_t chunkIndex) const =0
virtual PxBounds3 | getChunkLocalBounds (uint32_t chunkIndex) const =0
virtual bool | isChunkDestroyed (int32_t chunkIndex) const =0
virtual uint32_t | getSupportDepthChunkIndices (uint32_t *const OutChunkIndices, uint32_t MaxOutIndices) const =0
virtual uint32_t | getSupportDepth () const =0
virtual void | setDeleteFracturedChunks (bool inDeleteChunkMode)=0
virtual DestructibleRenderable * | acquireRenderableReference ()=0
virtual uint32_t | getCustomBehaviorGroupCount () const =0
virtual bool | getBehaviorGroup (nvidia::DestructibleBehaviorGroupDesc &behaviorGroupDesc, int32_t index=-1) const =0

Protected Member Functions

virtual | ~DestructibleActor ()

Detailed Description

Destructible actor API. The destructible actor is instanced from an DestructibleAsset.

Constructor & Destructor Documentation

virtual nvidia::apex::DestructibleActor::~DestructibleActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual bool nvidia::apex::DestructibleActor::acquireChunkEventBuffer | ( | const nvidia::DestructibleChunkEvent *& | buffer,
 |  | uint32_t & | bufferSize
 | ) |  | [pure virtual]

Locks the chunk event buffer, and (if successful) returns the head of the chunk event buffer in the buffer field and the length of the buffer (the number of events) in the bufferSize field. To unlock the buffer, use releaseChunkEventBuffer(). See DestructibleChunkEvent. This buffer is filled with chunk events if the DestructibleActor parameter createChunkEvents is set to true. This buffer is not automatically cleared by APEX. The user must clear it using releaseChunkEventBuffer(true).

N.B. This function only works when the user has *not* requested chunk event callbacks via ModuleDestructible::scheduleChunkStateEventCallback.

Returns:
Returns true if successful, false otherwise.
virtual bool nvidia::apex::DestructibleActor::acquirePhysXActorBuffer | ( | physx::PxRigidDynamic **& | buffer,
 |  | uint32_t & | bufferSize,
 |  | uint32_t | flags = DestructiblePhysXActorQueryFlags::AllStates
 | ) |  | [pure virtual]

Locks a PhysX actor buffer, and (if successful) returns the head of the buffer in the buffer field and the length of the buffer (the number of PhysX actors) in the bufferSize field. To unlock the buffer, use releasePhysXActorBuffer(). The user must release this buffer before another call to releasePhysXActorBuffer.

Parameters:
buffer | returned buffer, if successful
bufferSize | returned buffer size, if successful
flags | flags which control which actors are returned. See DestructiblePhysXActorQueryFlags.
Returns:
Returns true if successful, false otherwise.
virtual DestructibleRenderable* nvidia::apex::DestructibleActor::acquireRenderableReference ( ) [pure virtual]

Acquire a pointer to the destructible's renderable proxy and increment its reference count. The DestructibleRenderable will only be deleted when its reference count is zero. Calls to DestructibleRenderable::release decrement the reference count, as does a call to DestructibleActor::release(). .

virtual bool nvidia::apex::DestructibleActor::addForce | ( | uint32_t | chunkIndex,
 |  | const PxVec3 & | force,
 |  | physx::PxForceMode::Enum | mode,
 |  | const PxVec3 * | position = NULL,
 |  | bool | wakeup = true
 | ) |  | [pure virtual]

Apply force to chunk's actor

Parameters:
chunkIndex | the chunk index within the actor
force | force, impulse, velocity change, or acceleration (depending on value of mode)
mode | PhysX force mode (PxForceMode::Enum)
position | if not null, applies force at position. Otherwise applies force at center of mass
wakeup | if true, the actor is awakened

Returns true iff successful.

virtual void nvidia::apex::DestructibleActor::applyDamage | ( | float | damage,
 |  | float | momentum,
 |  | const PxVec3 & | position,
 |  | const PxVec3 & | direction,
 |  | int32_t | chunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX,
 |  | void * | damageUserData = NULL
 | ) |  | [pure virtual]

Damage Apply damage at a point. Damage will be propagated into the destructible based upon its DestructibleParameters.

Parameters:
damage | the amount of damage at the damage point
momentum | the magnitude of the impulse to transfer to the actor
position | the damage location
direction | direction of impact. This is valid even if momentum = 0, for use in deformation calculations.
chunkIndex | which chunk to damage (returned by rayCast and ModuleDestructible::getDestructibleAndChunk). If chunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX, then the nearest visible chunk hit is found.
damageUserData | pointer which will be returned in damage and fracture event callbacks
virtual void nvidia::apex::DestructibleActor::applyRadiusDamage | ( | float | damage,
 |  | float | momentum,
 |  | const PxVec3 & | position,
 |  | float | radius,
 |  | bool | falloff,
 |  | void * | damageUserData = NULL
 | ) |  | [pure virtual]

Apply damage to all chunks within a radius. Damage will also propagate into the destructible based upon its DestructibleParameters.

Parameters:
damage | the amount of damage at the damage point
momentum | the magnitude of the impulse to transfer to each chunk
position | the damage location
radius | distance from damage location at which chunks will be affected
falloff | whether or not to decrease damage with distance from the damage location. If true, damage will decrease linearly from the full damage (at zero distance) to zero damage (at radius). If false, full damage is applied to all chunks within the radius.
damageUserData | pointer which will be returned in damage and fracture event callbacks
virtual void nvidia::apex::DestructibleActor::disableHardSleeping ( bool wake = false ) [pure virtual]

See the comments for enableHardSleeping() for a description of this feature. The disableHardSleeping function takes a "wake" parameter, which (if true) will not only turn kinematic-sleeping actors dynamic, but wake them as well.

virtual void nvidia::apex::DestructibleActor::enableHardSleeping ( ) [pure virtual]

If "hard sleeping" is enabled, physx actors for chunk islands that go to sleep will be turned kinematic. If a chunk island has chunks from more than one DestructibleActor, then hard sleeping will be used if ANY of the destructibles have hard sleeping enabled.

virtual bool nvidia::apex::DestructibleActor::forceChunkHits | ( | const DestructibleHitChunk * | hitChunkContainer,
 |  | uint32_t | hitChunkCount,
 |  | bool | removeChunks = true,
 |  | bool | deferredEvent = false,
 |  | PxVec3 | damagePosition = PxVec3(0.0f),
 |  | PxVec3 | damageDirection = PxVec3(0.0f)
 | ) |  | [pure virtual]

Force the actor to register chunk hits.

Parameters:
hitChunkContainer | should take in an argument that was generated from another destructible actor. See getHitChunkHistory()
hitChunkCount | hit chunk count
removeChunks | removeChunks == true indicates that the chunks given by hitChunkContainer will be forcibly removed.
deferredEvent | whether to enable deferred event mode. If true, fracture events won't get processed until the next tick.
damagePosition | passed through to ApexDamageEventReportData::hitPosition and hitDirection in the damage notify output by APEX.
damageDirection | passed through to ApexDamageEventReportData::hitPosition and hitDirection in the damage notify output by APEX.
virtual bool nvidia::apex::DestructibleActor::forceDamageColoring | ( | const DamageEventCoreData * | damageEventCoreDataContainer,
 |  | uint32_t | damageEventCoreDataCount
 | ) |  | [pure virtual]

Force the actor to register damage coloring.

Parameters:
damageEventCoreDataContainer | should take in an argument that was generated from another destructible actor. See getDamageColoringHistory()
damageEventCoreDataCount | the count of damageEventCoreDataContainer.
Returns:
Returns true if the function executes correctly with the given arguments.
virtual EmitterActor* nvidia::apex::DestructibleActor::getApexEmitter ( DestructibleEmitterType::Enum type ) [pure virtual]

Returns the EmitterActor of either a dust or crumble emitter Note - only crumble emitters are implemented in 1.2.0

virtual bool nvidia::apex::DestructibleActor::getBehaviorGroup | ( | nvidia::DestructibleBehaviorGroupDesc & | behaviorGroupDesc,
 |  | int32_t | index = -1
 | ) |  | const [pure virtual]

Access to behavior groups created for this actor. Each chunk has a behavior group index associated with it.

This returns the indexed behavior group. The index must be either -1 (for the default group) or in the range [0, getCustomBehaviorGroupCount()-1]. If any other index is given, this function returns false. Otherwise it returns true and the behavior descriptor is filled in.

virtual uint32_t nvidia::apex::DestructibleActor::getChunkActorFlags ( uint32_t chunkIndex ) const [pure virtual]

Returns the DestructibleActorChunkFlags for a chunk. These are flags that describe aspects of the chunk that can only be determined at runtime.

Parameters:
chunkIndex the chunk index within the actor
virtual PxVec3 nvidia::apex::DestructibleActor::getChunkAngularVelocity ( uint32_t chunkIndex ) const [pure virtual]

Returns a chunk's angular velocity in world space.

Parameters:
chunkIndex the chunk index within the actor
virtual int32_t nvidia::apex::DestructibleActor::getChunkBehaviorGroupIndex ( uint32_t chunkIndex ) const [pure virtual]

Returns the behavior group index associated with the chunk. Use getBehaviorGroup() to access the behavior group data. The index will either be -1, in which case it is the default behavior group, or in the range [0, getCustomBehaviorGroupCount()-1]. Any of those values is valid for getBehaviorGroup().

Parameters:
chunkIndex the chunk index within the actor
virtual PxBounds3 nvidia::apex::DestructibleActor::getChunkBounds ( uint32_t chunkIndex ) const [pure virtual]

Accessor to query the axis aligned bounding box of a given chunk in world-space.

virtual PxVec3 nvidia::apex::DestructibleActor::getChunkLinearVelocity ( uint32_t chunkIndex ) const [pure virtual]

Returns a chunk's linear velocity in world space.

Parameters:
chunkIndex the chunk index within the actor
virtual PxBounds3 nvidia::apex::DestructibleActor::getChunkLocalBounds ( uint32_t chunkIndex ) const [pure virtual]

Accessor to query the axis aligned bounding box of a given chunk in chunk local-space.

virtual physx::PxRigidDynamic* nvidia::apex::DestructibleActor::getChunkPhysXActor ( uint32_t chunkIndex ) [pure virtual]

Returns the PhysX actor associated with the given chunk. Note, more than one chunk may be associated with a given PhysX actor, and chunks from different DestructibleActors may even be associated with the same PhysX actor. Caution is recommended when using this function. During APEX scene simulate/fetchResults, this actor may be deleted, replaced, or tampered with. When the chunk in question is not visible, but an ancestor of a visible chunk, the visible ancestor's shapes are returned.

Parameters:
chunkIndex the chunk index within the actor
virtual uint32_t nvidia::apex::DestructibleActor::getChunkPhysXShapes | ( | physx::PxShape **& | shapes,
 |  | uint32_t | chunkIndex
 | ) |  | const [pure virtual]

Returns the PhysX shapes associated with the given chunk. Caution is recommended when using this function. During APEX scene simulate/fetchResults, this actor may be deleted, replaced, or tampered with. It is safe to use the results of this function during the chunk event callback (see ModuleDestructible::setChunkReport).

Parameters:
shapes | returned pointer to array of shapes. May be NULL.
chunkIndex | the chunk index within the actor
Returns:
size of array pointed to by shapes pointer. 0 if shapes == NULL.
virtual PxTransform nvidia::apex::DestructibleActor::getChunkPose ( uint32_t chunkIndex ) const [pure virtual]

Returns current pose of a chunk's reference frame, without scaling. This pose can be used to transform the chunk's hull data from the asset into global space.

Parameters:
chunkIndex the chunk index within the actor
Note:
This pose's translation might not be inside the chunk. Use getChunkBounds to get a better representation of where the chunk is located.
virtual const PxMat44 nvidia::apex::DestructibleActor::getChunkTM ( uint32_t chunkIndex ) const [pure virtual]

Returns the transform of the chunk's graphical representation. This may have a scale component.

Parameters:
chunkIndex the chunk index within the actor
virtual PxTransform nvidia::apex::DestructibleActor::getChunkTransform ( uint32_t chunkIndex ) const [pure virtual]

Returns current pose of a chunk's reference frame, without scaling. This pose can be used to transform the chunk's hull data from the asset into global space.

Parameters:
chunkIndex the chunk index within the actor
Note:
This pose's translation might not be inside the chunk. Use getChunkBounds to get a better representation of where the chunk is located.
virtual void nvidia::apex::DestructibleActor::getChunkVisibilities | ( | uint8_t * | visibilityArray,
 |  | uint32_t | visibilityArraySize
 | ) |  | const [pure virtual]

Returns an array of visibility data for each chunk. Each byte in the array is 0 if the corresponding chunkIndex is invisible, 1 if visibile.

Parameters:
visibilityArray | a pointer to the byte buffer to hold the visibility values.
visibilityArraySize | the size of the visibilityArray
virtual uint32_t nvidia::apex::DestructibleActor::getCustomBehaviorGroupCount ( ) const [pure virtual]

Access to behavior groups created for this actor. Each chunk has a behavior group index associated with it.

Returns:
This returns the number of custom (non-default) behavior groups.
virtual bool nvidia::apex::DestructibleActor::getDamageColoringHistory | ( | const DamageEventCoreData *& | damageEventCoreDataContainer,
 |  | uint32_t & | damageEventCoreDataCount
 | ) |  | const [pure virtual]

Get the damage coloring history of the actor. To start caching damage coloring, see setHitChunkTrackingParams()

Returns:
Returns true if the function executes correctly with the given arguments.
virtual const DestructibleParameters& nvidia::apex::DestructibleActor::getDestructibleParameters ( ) const [pure virtual]

Gets the destructible's DestructibleParameter block of parameters. These are initially set from the asset.

virtual bool nvidia::apex::DestructibleActor::getGlobalPose ( PxMat44 & pose ) [pure virtual]

Get the destructible actor's global pose. This will be the pose of the physx PxActor or PxActor for the static chunks in the structure containing this actor, if there are static chunks. If there are no static chunks in the structure, pose will not be modified and false will be returned. Otherwise pose will be filled in with a scale-free transform, and true is returned.

virtual bool nvidia::apex::DestructibleActor::getHitChunkHistory | ( | const DestructibleHitChunk *& | hitChunkContainer,
 |  | uint32_t & | hitChunkCount
 | ) |  | const [pure virtual]

Get the chunk hit history of the actor. To start caching chunk hits, see setHitChunkTrackingParams()

Returns:
Returns true if the function executes correctly with the given arguments.
virtual PxMat44 nvidia::apex::DestructibleActor::getInitialGlobalPose ( ) const [pure virtual]

Gets the global pose used when the actor is added to the scene, in the DestructibleActorDesc

virtual PxBounds3 nvidia::apex::DestructibleActor::getLocalBounds ( ) const [pure virtual]

Accessor to get the initial locally-aligned bounding box of a destructible actor.

virtual uint32_t nvidia::apex::DestructibleActor::getNumVisibleChunks ( ) const [pure virtual]

Returns the number of visible chunks. This is the number of 1's written to the visibilityArray by getChunkVisibilities.

virtual const ::NvParameterized::Interface* nvidia::apex::DestructibleActor::getNvParameterized ( DestructibleParameterizedType::Enum type = DestructibleParameterizedType::State ) const [pure virtual]

Returns the actor's NvParamaterized interface This cannot be directly modified! It is read only to the user. This handle can be used to directly serialize the complete actor state.

virtual PxBounds3 nvidia::apex::DestructibleActor::getOriginalBounds ( ) const [pure virtual]

Accessor to get the initial world axis-aligned bounding box of a destructible actor.

virtual const RenderMeshActor* nvidia::apex::DestructibleActor::getRenderMeshActor ( DestructibleActorMeshType::Enum type = DestructibleActorMeshType::Skinned ) const [pure virtual]

Get the render mesh actor for the specified mesh type.

virtual PxVec3 nvidia::apex::DestructibleActor::getScale ( ) const [pure virtual]

Gets the destructible actor's 3D (possibly nonuniform) scale

virtual uint32_t nvidia::apex::DestructibleActor::getSupportDepth ( ) const [pure virtual]

Query the actor's support depth.

virtual uint32_t nvidia::apex::DestructibleActor::getSupportDepthChunkIndices | ( | uint32_t *const | OutChunkIndices,
 |  | uint32_t | MaxOutIndices
 | ) |  | const [pure virtual]

Accessor to get the array of chunk indices at the support depth.

virtual const uint16_t* nvidia::apex::DestructibleActor::getVisibleChunks ( ) const [pure virtual]

Returns a pointer to an array of visible chunk indices.

virtual bool nvidia::apex::DestructibleActor::isChunkDestroyed ( int32_t chunkIndex ) const [pure virtual]

Accessor to query if a chunk has been destroyed.

virtual bool nvidia::apex::DestructibleActor::isChunkSolitary ( int32_t chunkIndex ) const [pure virtual]

Accessor to query if a chunk is part of a detached island.

virtual bool nvidia::apex::DestructibleActor::isDynamic ( uint32_t chunkIndex ) const [pure virtual]

Returns true if the chunkIndex is valid, and the indexed chunk is dynamic. Returns false otherwise.

virtual bool nvidia::apex::DestructibleActor::isHardSleepingEnabled ( ) const [pure virtual]

Returns true iff hard sleeping is selected for this DestructibleActor.

virtual bool nvidia::apex::DestructibleActor::isInitiallyDynamic ( ) const [pure virtual]

Returns true iff the destructible actor starts off life dynamic.

virtual int32_t nvidia::apex::DestructibleActor::obbSweep | ( | float & | time,
 |  | PxVec3 & | normal,
 |  | const PxVec3 & | worldBoxCenter,
 |  | const PxVec3 & | worldBoxExtents,
 |  | const PxMat33 & | worldBoxRot,
 |  | const PxVec3 & | worldDisplacement,
 |  | DestructibleActorRaycastFlags::Enum | flags
 | ) |  | const [pure virtual]

Physx SDK 3.X. Returns the index of the first visible chunk hit in the actor by swept oriented bounding box, if any. Otherwise returns ModuleDestructibleConst::INVALID_CHUNK_INDEX. If a chunk is hit, the time and normal fields are modified.

Parameters:
[out] | time | (return value) of the time to the hit chunk, if any.
[out] | normal | (return value) the surface normal of the hit chunk's collision volume, if any.
worldBoxCenter | the center of the obb to sweep against the actor, oriented in world space
worldBoxExtents | the extents of the obb to sweep against the actor, oriented in world space
worldBoxRot | the rotation of the obb to sweep against the actor, oriented in world space
worldDisplacement | the displacement of the center of the worldBox through the sweep, in world space
flags | raycast control flags (see DestructibleActorRaycastFlags)
virtual int32_t nvidia::apex::DestructibleActor::rayCast | ( | float & | time,
 |  | PxVec3 & | normal,
 |  | const PxVec3 & | worldRayOrig,
 |  | const PxVec3 & | worldRayDir,
 |  | DestructibleActorRaycastFlags::Enum | flags,
 |  | int32_t | parentChunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX
 | ) |  | const [pure virtual]

PhysX SDK 3.X. Returns the index of the first visible chunk hit in the actor by worldRay, if any. Otherwise returns ModuleDestructibleConst::INVALID_CHUNK_INDEX. If a chunk is hit, the time and normal fields are modified.

Parameters:
[out] | time | (return value) of the time to the hit chunk, if any.
[out] | normal | (return value) the surface normal of the hit chunk's collision volume, if any.
worldRayOrig | origin of the ray to fire at the actor (the direction need not be normalized)
worldRayDir | direction of the ray to fire at the actor (the direction need not be normalized)
flags | raycast control flags (see DestructibleActorRaycastFlags)
parentChunkIndex | (if not equal to ModuleDestructibleConst::INVALID_CHUNK_INDEX) the chunk subhierarchy in which to confine the raycast. If parentChunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX, then the whole actor is searched.
virtual bool nvidia::apex::DestructibleActor::recreateApexEmitter ( DestructibleEmitterType::Enum type ) [pure virtual]

Recreates the Apex Emitter, if necessary. Use this method to re-initialize the crumble or dust emitter after a change has been made to a dependent asset Note - only crumble emitters are implemented in 1.2.0

virtual bool nvidia::apex::DestructibleActor::releaseChunkEventBuffer ( bool clearBuffer = true ) [pure virtual]

Releases the chunk event buffer, which may have been locked by acquireChunkEventBuffer(). If clearBuffer is true, the buffer will be erased before it is unlocked.

Returns:
Returns true if successful, false otherwise.
virtual bool nvidia::apex::DestructibleActor::releasePhysXActorBuffer ( ) [pure virtual]

Releases the PhysX actor buffer, which may have been locked by acquirePhysXActorBuffer(). The buffer will be erased before it is unlocked.

Returns:
Returns true if successful, false otherwise.
virtual void nvidia::apex::DestructibleActor::setAngularVelocity ( const PxVec3 & angularVelocity ) [pure virtual]

Sets the angular velocity of every dynamic chunk to the given value.

virtual bool nvidia::apex::DestructibleActor::setChunkPhysXActorAwakeState | ( | uint32_t | chunkIndex,
 |  | bool | awake
 | ) |  | [pure virtual]

Puts the PxActor associated with the given chunk to sleep, or wakes it up, depending upon the value of the 'awake' bool.

Parameters:
chunkIndex | the chunk index within the actor
awake | if true, wakes the actor, otherwise puts the actor to sleep

Returns true iff successful.

virtual void nvidia::apex::DestructibleActor::setCrumbleEmitterState ( bool enable ) [pure virtual]

Enable/disable the crumble emitter

virtual void nvidia::apex::DestructibleActor::setDeleteFracturedChunks ( bool inDeleteChunkMode ) [pure virtual]

Set the actor to delete its fractured chunks instead of simulating them.

virtual void nvidia::apex::DestructibleActor::setDestructibleParameters ( const DestructibleParameters & destructibleParameters ) [pure virtual]

Sets the destructible's DestructibleParameter block of parameters. These may be set at runtime.

virtual void nvidia::apex::DestructibleActor::setDustEmitterState ( bool enable ) [pure virtual]

Enable/disable the dust emitter Note - this is a placeholder API. The dust feature is disabled in 1.2.0.

virtual void nvidia::apex::DestructibleActor::setDynamic ( int32_t chunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX ) [pure virtual]

If the indexed chunk is visible, it is made dynamic (if it is not already). If ModuleDestructibleConst::INVALID_CHUNK_INDEX is passed in, all visible chunks in the destructible actor are made dynamic, if they are not already.

virtual void nvidia::apex::DestructibleActor::setGlobalPose ( const PxMat44 & pose ) [pure virtual]

Set the destructible actor's global pose. This will only be applied to the physx PxActor or PxActor for the static chunks, and therefore will apply to all static chunks in the structure which contains the this destructible actor. This pose should not contain scale, as the scale is already contained in the actor's scale parameter.

virtual bool nvidia::apex::DestructibleActor::setHitChunkTrackingParams | ( | bool | flushHistory,
 |  | bool | startTracking,
 |  | uint32_t | trackingDepth,
 |  | bool | trackAllChunks = true
 | ) |  | [pure virtual]

Set the tracking properties of the actor for chunks that are hit. Chunks that are hit are chunks directly affected by fracture events.

Parameters:
flushHistory | flushHistory == true indicates that both the cached chunk hit history and the cached damage event core data will be cleared. To get the chunk hit history of this actor, see getHitChunkHistory() To get the damage coloring history of this actor, see getDamageColoringHistory()
startTracking | startTracking == true indicates that chunk hits and damage coloring will begin caching internally. The actor does not cache chunk hits by default.
trackingDepth | the depth at which hit chunks will be cached. This value should not exceed the maximum depth level.
trackAllChunks | trackAllChunks == true indicates that all the chunks will be cached, trackAllChunks == false indicates that only static chunks will be cached.

Returns true if the function executes correctly with the given arguments.

virtual void nvidia::apex::DestructibleActor::setInitialGlobalPose ( const PxMat44 & pose ) [pure virtual]

Resets the initial global pose used for support calculations when the first simulation step is run.

virtual void nvidia::apex::DestructibleActor::setLinearVelocity ( const PxVec3 & linearVelocity ) [pure virtual]

Sets the linear velocity of every dynamic chunk to the given value.

virtual void nvidia::apex::DestructibleActor::setNvParameterized ( ::NvParameterized::Interface * ) [pure virtual]

Sets the actor's state via the NvParameterized object This can be used to update the state from deserialized data. The actor assumes control of the interface.

virtual void nvidia::apex::DestructibleActor::setPreferredRenderVolume | ( | RenderVolume * | volume,
 |  | DestructibleEmitterType::Enum | type
 | ) |  | [pure virtual]

Sets a preferred render volume for a dust or crumble emitter Note - only crumble emitters are implemented in 1.2.0

virtual void nvidia::apex::DestructibleActor::setRuntimeFractureOverridePattern ( const char * overridePatternName ) [pure virtual]

Sets the override fracture pattern.

virtual void nvidia::apex::DestructibleActor::setSkinnedOverrideMaterial | ( | uint32_t | submeshIndex,
 |  | const char * | overrideMaterialName
 | ) |  | [pure virtual]

Sets the override material.

virtual void nvidia::apex::DestructibleActor::setStaticOverrideMaterial | ( | uint32_t | submeshIndex,
 |  | const char * | overrideMaterialName
 | ) |  | [pure virtual]

Sets the override material.

virtual bool nvidia::apex::DestructibleActor::setSyncParams | ( | uint32_t | userActorID,
 |  | uint32_t | actorSyncFlags = 0,
 |  | const DestructibleActorSyncState * | actorSyncState = NULL,
 |  | const DestructibleChunkSyncState * | chunkSyncState = NULL
 | ) |  | [pure virtual]

Set the syncing properties of the destructible actor.

Parameters:
userActorID | user-defined value used to identify the syncing actor. This value will be used to identify destructible actors between the server and client. userActorID = 0 is used for unregistering the actor as a syncing actor, and is the default value. The other arguments will then be forcibly set to the default (non-participating) values. userActorID != 0 registers the actor as a participating syncing actor. userActorID can be overwritten. In this case, the destructible actor which used to hold this userActorID will behave exactly like a call to set userActorID to 0.
actorSyncFlags | describes the kind of actor information that participates in syncing. See struct DestructibleActorSyncFlags
actorSyncState | describes information that allows finer control over the actor that participates in syncing. See struct DestructibleActorSyncState
chunkSyncState | describes information that allows finer control over the chunk that participates in syncing. See struct DestructibleChunkSyncState
Returns:
Returns true if arguments are accepted. Any one invalid argument will cause a return false. In such a case, no changes are made.
virtual void nvidia::apex::DestructibleActor::takeImpact | ( | const PxVec3 & | force,
 |  | const PxVec3 & | position,
 |  | uint16_t | chunkIndex,
 |  | PxActor const * | damageImpactActor
 | ) |  | [pure virtual]

Register a rigid body impact for impact-based damage. Much like applyDamage, but multplies the input 'force' by the destructible's forceToDamage parameter, and also allows the user to report the impacting PhysX actor

The documentation for this class was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActor
nvidia::apex::DestructibleActor Member List
This is the complete list of members for nvidia::apex::DestructibleActor, including all inherited members.
acquireChunkEventBuffer(const nvidia::DestructibleChunkEvent *&buffer, uint32_t &bufferSize)=0 | nvidia::apex::DestructibleActor | [pure virtual]
acquirePhysXActorBuffer(physx::PxRigidDynamic **&buffer, uint32_t &bufferSize, uint32_t flags=DestructiblePhysXActorQueryFlags::AllStates)=0 | nvidia::apex::DestructibleActor | [pure virtual]
acquireRenderableReference()=0 | nvidia::apex::DestructibleActor | [pure virtual]
addForce(uint32_t chunkIndex, const PxVec3 &force, physx::PxForceMode::Enum mode, const PxVec3 *position=NULL, bool wakeup=true)=0 | nvidia::apex::DestructibleActor | [pure virtual]
applyDamage(float damage, float momentum, const PxVec3 &position, const PxVec3 &direction, int32_t chunkIndex=ModuleDestructibleConst::INVALID_CHUNK_INDEX, void *damageUserData=NULL)=0 | nvidia::apex::DestructibleActor | [pure virtual]
applyRadiusDamage(float damage, float momentum, const PxVec3 &position, float radius, bool falloff, void *damageUserData=NULL)=0 | nvidia::apex::DestructibleActor | [pure virtual]
disableHardSleeping(bool wake=false)=0 | nvidia::apex::DestructibleActor | [pure virtual]
enableHardSleeping()=0 | nvidia::apex::DestructibleActor | [pure virtual]
forceChunkHits(const DestructibleHitChunk *hitChunkContainer, uint32_t hitChunkCount, bool removeChunks=true, bool deferredEvent=false, PxVec3 damagePosition=PxVec3(0.0f), PxVec3 damageDirection=PxVec3(0.0f))=0 | nvidia::apex::DestructibleActor | [pure virtual]
forceDamageColoring(const DamageEventCoreData *damageEventCoreDataContainer, uint32_t damageEventCoreDataCount)=0 | nvidia::apex::DestructibleActor | [pure virtual]
getApexEmitter(DestructibleEmitterType::Enum type)=0 | nvidia::apex::DestructibleActor | [pure virtual]
getBehaviorGroup(nvidia::DestructibleBehaviorGroupDesc &behaviorGroupDesc, int32_t index=-1) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkActorFlags(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkAngularVelocity(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkBehaviorGroupIndex(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkBounds(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkLinearVelocity(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkLocalBounds(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkPhysXActor(uint32_t chunkIndex)=0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkPhysXShapes(physx::PxShape **&shapes, uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkPose(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkTM(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkTransform(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkVisibilities(uint8_t *visibilityArray, uint32_t visibilityArraySize) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getCustomBehaviorGroupCount() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getDamageColoringHistory(const DamageEventCoreData *&damageEventCoreDataContainer, uint32_t &damageEventCoreDataCount) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getDestructibleParameters() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getGlobalPose(PxMat44 &pose)=0 | nvidia::apex::DestructibleActor | [pure virtual]
getHitChunkHistory(const DestructibleHitChunk *&hitChunkContainer, uint32_t &hitChunkCount) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getInitialGlobalPose() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getLocalBounds() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getNumVisibleChunks() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getNvParameterized(DestructibleParameterizedType::Enum type=DestructibleParameterizedType::State) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getOriginalBounds() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getRenderMeshActor(DestructibleActorMeshType::Enum type=DestructibleActorMeshType::Skinned) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getScale() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getSupportDepth() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getSupportDepthChunkIndices(uint32_t *const OutChunkIndices, uint32_t MaxOutIndices) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getVisibleChunks() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
isChunkDestroyed(int32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
isChunkSolitary(int32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
isDynamic(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
isHardSleepingEnabled() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
isInitiallyDynamic() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
obbSweep(float &time, PxVec3 &normal, const PxVec3 &worldBoxCenter, const PxVec3 &worldBoxExtents, const PxMat33 &worldBoxRot, const PxVec3 &worldDisplacement, DestructibleActorRaycastFlags::Enum flags) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
rayCast(float &time, PxVec3 &normal, const PxVec3 &worldRayOrig, const PxVec3 &worldRayDir, DestructibleActorRaycastFlags::Enum flags, int32_t parentChunkIndex=ModuleDestructibleConst::INVALID_CHUNK_INDEX) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
recreateApexEmitter(DestructibleEmitterType::Enum type)=0 | nvidia::apex::DestructibleActor | [pure virtual]
releaseChunkEventBuffer(bool clearBuffer=true)=0 | nvidia::apex::DestructibleActor | [pure virtual]
releasePhysXActorBuffer()=0 | nvidia::apex::DestructibleActor | [pure virtual]
setAngularVelocity(const PxVec3 &angularVelocity)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setChunkPhysXActorAwakeState(uint32_t chunkIndex, bool awake)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setCrumbleEmitterState(bool enable)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setDeleteFracturedChunks(bool inDeleteChunkMode)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setDestructibleParameters(const DestructibleParameters &destructibleParameters)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setDustEmitterState(bool enable)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setDynamic(int32_t chunkIndex=ModuleDestructibleConst::INVALID_CHUNK_INDEX)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setGlobalPose(const PxMat44 &pose)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setHitChunkTrackingParams(bool flushHistory, bool startTracking, uint32_t trackingDepth, bool trackAllChunks=true)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setInitialGlobalPose(const PxMat44 &pose)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setLinearVelocity(const PxVec3 &linearVelocity)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setNvParameterized(::NvParameterized::Interface *)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setPreferredRenderVolume(RenderVolume *volume, DestructibleEmitterType::Enum type)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setRuntimeFractureOverridePattern(const char *overridePatternName)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setSkinnedOverrideMaterial(uint32_t submeshIndex, const char *overrideMaterialName)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setStaticOverrideMaterial(uint32_t submeshIndex, const char *overrideMaterialName)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setSyncParams(uint32_t userActorID, uint32_t actorSyncFlags=0, const DestructibleActorSyncState *actorSyncState=NULL, const DestructibleChunkSyncState *chunkSyncState=NULL)=0 | nvidia::apex::DestructibleActor | [pure virtual]
takeImpact(const PxVec3 &force, const PxVec3 &position, uint16_t chunkIndex, PxActor const *damageImpactActor)=0 | nvidia::apex::DestructibleActor | [pure virtual]
~DestructibleActor() | nvidia::apex::DestructibleActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleActorJoint Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorJoint
Public Member Functions | Protected Member Functions
nvidia::apex::DestructibleActorJoint Class Reference

#include <DestructibleActorJoint.h>

List of all members.

Public Member Functions

virtual PxJoint * | joint ()=0

Protected Member Functions

virtual | ~DestructibleActorJoint ()

Detailed Description

Destructible actor joint - a wrapper for an PxJoint. This needs to be used because APEX may need to replace an PxJoint when fracturing occurs. Always use the joint() method to get the currently valid joint.

Constructor & Destructor Documentation

virtual nvidia::apex::DestructibleActorJoint::~DestructibleActorJoint ( ) [inline, protected, virtual]

Member Function Documentation

virtual PxJoint* nvidia::apex::DestructibleActorJoint::joint ( ) [pure virtual]

PhysX SDK 3.X Access to the {xJoint represented by the DestructibleActorJoint. This is a temporary interface, and there are some shortcomings and restrictions: 1) The user will have to upcast the result of joint() to the correct joint type in order to access the interface for derived joints. 2) The user must never delete the joint using the PhysX SDK. To release this joint, simply use the release() method of this object (defined in the ApexInterface base class).

The documentation for this class was generated from the following file:
  • DestructibleActorJoint.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorJoint
nvidia::apex::DestructibleActorJoint Member List
This is the complete list of members for nvidia::apex::DestructibleActorJoint, including all inherited members.
joint()=0 | nvidia::apex::DestructibleActorJoint | [pure virtual]
~DestructibleActorJoint() | nvidia::apex::DestructibleActorJoint | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleActorJointDesc Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorJointDesc
Public Member Functions | Public Attributes
nvidia::apex::DestructibleActorJointDesc Class Reference

#include <DestructibleActorJoint.h>

List of all members.

Public Member Functions

PX_INLINE | DestructibleActorJointDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
Resets descriptor to default settings.
PX_INLINE bool | isValid () const

Public Attributes

physx::PxJointConcreteType::Enum | type
PxRigidActor * | actor [2]
PxVec3 | localAxis [2]
PxVec3 | localAnchor [2]
PxVec3 | localNormal [2]
DestructibleActor * | destructible [2]
int32_t | attachmentChunkIndex [2]
PxVec3 | globalAnchor [2]
global attachment positions
PxVec3 | globalAxis [2]
global axes
PxVec3 | globalNormal [2]
global normals

Detailed Description

Descriptor used to create the Destructible actor joint.

Constructor & Destructor Documentation

PX_INLINE nvidia::apex::DestructibleActorJointDesc::DestructibleActorJointDesc ( )

constructor sets to default.

Member Function Documentation

PX_INLINE bool nvidia::apex::DestructibleActorJointDesc::isValid ( ) const

Returns true iff an object can be created using this descriptor.

PX_INLINE void nvidia::apex::DestructibleActorJointDesc::setToDefault ( )

Resets descriptor to default settings.

Member Data Documentation

PxRigidActor* nvidia::apex::DestructibleActorJointDesc::actor[2]

PhysX SDK 3.X only.

int32_t nvidia::apex::DestructibleActorJointDesc::attachmentChunkIndex[2]

If destructible[i] is not NULL and attachmentChunkIndex[i] is a valid chunk index within that destructible, then that chunk will be used for attachment. If destructible[i] is not NULL and attachmentChunkIndex[i] is NOT a valid chunk index (such as the default ModuleDestructibleConst::INVALID_CHUNK_INDEX), then the nearest chunk to globalAnchor[i] is used instead. Once a chunk is determined, the chunk's associated PxActor will be the PxJoint's attachment actor.

DestructibleActor* nvidia::apex::DestructibleActorJointDesc::destructible[2]

If destructible[i] is not NULL, it will effectively replace the actor[i] in jointDesc. At least one must be non-NULL.

PxVec3 nvidia::apex::DestructibleActorJointDesc::globalAnchor[2]

global attachment positions

Global attachment data. Since destructibles come apart, there is no single referece frame associated with them. Therefore it makes more sense to use a global reference frame when describing the attachment positions and axes.

PxVec3 nvidia::apex::DestructibleActorJointDesc::globalAxis[2]

global axes

PxVec3 nvidia::apex::DestructibleActorJointDesc::globalNormal[2]

global normals

PxVec3 nvidia::apex::DestructibleActorJointDesc::localAnchor[2]

PhysX SDK 3.X only.

PxVec3 nvidia::apex::DestructibleActorJointDesc::localAxis[2]

PhysX SDK 3.X only.

PxVec3 nvidia::apex::DestructibleActorJointDesc::localNormal[2]

PhysX SDK 3.X only.

physx::PxJointConcreteType::Enum nvidia::apex::DestructibleActorJointDesc::type

PhysX SDK 3.X only.

The documentation for this class was generated from the following file:
  • DestructibleActorJoint.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorJointDesc
nvidia::apex::DestructibleActorJointDesc Member List
This is the complete list of members for nvidia::apex::DestructibleActorJointDesc, including all inherited members.
actor | nvidia::apex::DestructibleActorJointDesc
attachmentChunkIndex | nvidia::apex::DestructibleActorJointDesc
destructible | nvidia::apex::DestructibleActorJointDesc
DestructibleActorJointDesc() | nvidia::apex::DestructibleActorJointDesc
globalAnchor | nvidia::apex::DestructibleActorJointDesc
globalAxis | nvidia::apex::DestructibleActorJointDesc
globalNormal | nvidia::apex::DestructibleActorJointDesc
isValid() const | nvidia::apex::DestructibleActorJointDesc
localAnchor | nvidia::apex::DestructibleActorJointDesc
localAxis | nvidia::apex::DestructibleActorJointDesc
localNormal | nvidia::apex::DestructibleActorJointDesc
setToDefault() | nvidia::apex::DestructibleActorJointDesc
type | nvidia::apex::DestructibleActorJointDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleAsset Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAsset
Public Types | Public Member Functions | Protected Member Functions
nvidia::apex::DestructibleAsset Class Reference

#include <DestructibleAsset.h>

List of all members.

Public Types

enum ChunkFlags {
ChunkEnvironmentallySupported = (1 << 0),
ChunkAndDescendentsDoNotFracture = (1 << 1),
ChunkDoesNotFracture = (1 << 2),
ChunkDoesNotCrumble = (1 << 3),
ChunkRuntimeFracture = (1 << 4),
ChunkIsInstanced = (1 << 16)
}

Public Member Functions

virtual void | releaseDestructibleActor (DestructibleActor &actor)=0
virtual DestructibleActor * | createDestructibleActorFromDeserializedState (::NvParameterized::Interface *actorParams, Scene &apexScene)=0
virtual DestructibleParameters | getDestructibleParameters () const =0
virtual DestructibleInitParameters | getDestructibleInitParameters () const =0
virtual const char * | getCrumbleEmitterName () const =0
virtual const char * | getDustEmitterName () const =0
virtual uint32_t | getChunkCount () const =0
virtual uint32_t | getDepthCount () const =0
virtual const RenderMeshAsset * | getRenderMeshAsset () const =0
virtual bool | setRenderMeshAsset (RenderMeshAsset *)=0
virtual uint32_t | getScatterMeshAssetCount () const =0
virtual RenderMeshAsset *const | getScatterMeshAssets () const =0
virtual uint32_t | getInstancedChunkMeshCount () const =0
virtual void | getStats (DestructibleAssetStats &stats) const =0
virtual void | cacheChunkOverlapsUpToDepth (int32_t depth=-1)=0
virtual void | clearChunkOverlaps (int32_t depth=-1, bool keepCachedFlag=false)=0
virtual void | addChunkOverlaps (IntPair *supportGraphEdges, uint32_t numSupportGraphEdges)=0
virtual void | removeChunkOverlaps (IntPair *supportGraphEdges, uint32_t numSupportGraphEdges, bool keepCachedFlagIfEmpty)=0
virtual uint32_t | getCachedOverlapCountAtDepth (uint32_t depth) const =0
virtual const IntPair * | getCachedOverlapsAtDepth (uint32_t depth) const =0
virtual PxVec3 | getChunkPositionOffset (uint32_t chunkIndex) const =0
virtual PxVec2 | getChunkUVOffset (uint32_t chunkIndex) const =0
virtual uint32_t | getChunkFlags (uint32_t chunkIndex) const =0
virtual uint16_t | getChunkDepth (uint32_t chunkIndex) const =0
virtual int32_t | getChunkParentIndex (uint32_t chunkIndex) const =0
virtual PxBounds3 | getChunkActorLocalBounds (uint32_t chunkIndex) const =0
virtual uint32_t | getPartIndex (uint32_t chunkIndex) const =0
virtual uint32_t | getPartConvexHullCount (const uint32_t partIndex) const =0
virtual
NvParameterized::Interface ** 		getPartConvexHullArray (const uint32_t partIndex) const =0
virtual uint32_t | getActorTransformCount () const =0
Returns the size of the actor transform array. See getActorTransforms() for a description of this data.
virtual const PxMat44 * | getActorTransforms () const =0
Returns the head of the actor transform array. This list is a convenience for placing actors in a level from poses authored in a level editor. The transforms may contain scaling.
virtual void | applyTransformation (const PxMat44 &transformation, float scale)=0
Apply a transformation to destructible asset.
virtual void | applyTransformation (const PxMat44 &transformation)=0
Apply an arbitrary affine transformation to destructible asset.
virtual bool | rebuildCollisionGeometry (uint32_t partIndex, const DestructibleGeometryDesc &geometryDesc)=0

Protected Member Functions

virtual | ~DestructibleAsset ()

Detailed Description

Destructible asset API. Destructible actors are instanced from destructible assets.

Member Enumeration Documentation

enum nvidia::apex::DestructibleAsset::ChunkFlags

Enum of chunk flags

Enumerator:
ChunkEnvironmentallySupported
ChunkAndDescendentsDoNotFracture
ChunkDoesNotFracture
ChunkDoesNotCrumble
ChunkRuntimeFracture
ChunkIsInstanced

Constructor & Destructor Documentation

virtual nvidia::apex::DestructibleAsset::~DestructibleAsset ( ) [inline, protected, virtual]

Hidden destructor. Use release().

Member Function Documentation

virtual void nvidia::apex::DestructibleAsset::addChunkOverlaps | ( | IntPair * | supportGraphEdges,
 |  | uint32_t | numSupportGraphEdges
 | ) |  | [pure virtual]

Adds edges to the support graph. Edges must connect chunks of equal depth. The indices refer to the reordered chunk array, a mapping is provided in cookChunks.

Parameters:
supportGraphEdges | Integer pairs representing indices to chunks that are linked
numSupportGraphEdges | Number of provided integer pairs.
virtual void nvidia::apex::DestructibleAsset::applyTransformation | ( | const PxMat44 & | transformation,
 |  | float | scale
 | ) |  | [pure virtual]

Apply a transformation to destructible asset.

This is a permanent transformation and it changes the object state. Should only be called immediately before serialization and without further modifying the object later on.

Parameters:
transformation | This matrix is allowed to contain a translation and a rotation
scale | Apply a uniform scaling as well
virtual void nvidia::apex::DestructibleAsset::applyTransformation ( const PxMat44 & transformation ) [pure virtual]

Apply an arbitrary affine transformation to destructible asset.

This is a permanent transformation and it changes the object state. Should only be called immediately before serialization and without further modifying the object later on.

Parameters:
transformation This matrix is allowed to contain translation, rotation, scale and skew
virtual void nvidia::apex::DestructibleAsset::cacheChunkOverlapsUpToDepth ( int32_t depth = -1 ) [pure virtual]

Ensures that the asset has chunk overlap information cached up to the given depth. If depth < 0 (as it is by default), the depth will be taken to be the supportDepth given in the asset's destructibleParameters. It is ok to pass in a depth greater than any chunk depth in the asset.

virtual void nvidia::apex::DestructibleAsset::clearChunkOverlaps | ( | int32_t | depth = -1,
 |  | bool | keepCachedFlag = false
 | ) |  | [pure virtual]

Clears the chunk overlap cache. If depth < 0 (as it is by default), it clears the cache for each depth.

Parameters:
depth | Depth to be cleared. -1 for all depths.
keepCachedFlag | If the flag is set, the depth is considered to be cached even if the overlaps list is empty.
virtual DestructibleActor* nvidia::apex::DestructibleAsset::createDestructibleActorFromDeserializedState | ( | ::NvParameterized::Interface * | actorParams,
 |  | Scene & | apexScene
 | ) |  | [pure virtual]

General Create a destructible actor representing the destructible asset in a scene. Unlike a call to createApexActor, here the created actor takes explicit ownership of the provided actorParams. This can represent either the destructible descriptor or previously serialized destructible state. Note: The client should not attempt to use the provided actorParams after calling this method.

virtual uint32_t nvidia::apex::DestructibleAsset::getActorTransformCount ( ) const [pure virtual]

Returns the size of the actor transform array. See getActorTransforms() for a description of this data.

virtual const PxMat44* nvidia::apex::DestructibleAsset::getActorTransforms ( ) const [pure virtual]

Returns the head of the actor transform array. This list is a convenience for placing actors in a level from poses authored in a level editor. The transforms may contain scaling.

virtual uint32_t nvidia::apex::DestructibleAsset::getCachedOverlapCountAtDepth ( uint32_t depth ) const [pure virtual]

The size of the array returned by getCachedOverlapsAtDepth(depth) (see below). Note: this function will not trigger overlap caching for the given depth.

virtual const IntPair* nvidia::apex::DestructibleAsset::getCachedOverlapsAtDepth ( uint32_t depth ) const [pure virtual]

Array of integer pairs, indexing chunk pairs which touch at a given depth in the hierarchy. The size of the array is given by getCachedOverlapCountAtDepth(depth). Note: this function will not trigger overlap caching for the given depth. If no overlaps have been calculated for the depth given, this function returns NULL.

virtual PxBounds3 nvidia::apex::DestructibleAsset::getChunkActorLocalBounds ( uint32_t chunkIndex ) const [pure virtual]

Returns the chunk bounds in the asset (local) space.

virtual uint32_t nvidia::apex::DestructibleAsset::getChunkCount ( ) const [pure virtual]

The total number of chunks in the asset.

virtual uint16_t nvidia::apex::DestructibleAsset::getChunkDepth ( uint32_t chunkIndex ) const [pure virtual]

Accessor to query the depth of a given chunk.

virtual uint32_t nvidia::apex::DestructibleAsset::getChunkFlags ( uint32_t chunkIndex ) const [pure virtual]

Retrieve flags (see ChunkFlags) for the given chunk.

virtual int32_t nvidia::apex::DestructibleAsset::getChunkParentIndex ( uint32_t chunkIndex ) const [pure virtual]

Returns the index of the given chunk's parent. If the chunk has no parent (is the root of the fracture hierarchy), then -1 is returned.

virtual PxVec3 nvidia::apex::DestructibleAsset::getChunkPositionOffset ( uint32_t chunkIndex ) const [pure virtual]

If this chunk is instanced within the same asset, then this provides the instancing position offset. Otherwise, this function returns (0,0,0).

virtual PxVec2 nvidia::apex::DestructibleAsset::getChunkUVOffset ( uint32_t chunkIndex ) const [pure virtual]

If this chunk is instanced within the same asset, then this provides the instancing UV offset. Otherwise, this function returns (0,0).

virtual const char* nvidia::apex::DestructibleAsset::getCrumbleEmitterName ( ) const [pure virtual]

The name of the emitter to use when generating crumble particles. Returns NULL if no emitter is configured.

virtual uint32_t nvidia::apex::DestructibleAsset::getDepthCount ( ) const [pure virtual]

The total number of fracture hierarchy depth levels in the asset.

virtual DestructibleInitParameters nvidia::apex::DestructibleAsset::getDestructibleInitParameters ( ) const [pure virtual]

The parameters used for default destructible initialization. See DestructibleInitParameters.

virtual DestructibleParameters nvidia::apex::DestructibleAsset::getDestructibleParameters ( ) const [pure virtual]

The DestructibleParameters which describe the default fracturing behavior for instanced DestructibleActors.

virtual const char* nvidia::apex::DestructibleAsset::getDustEmitterName ( ) const [pure virtual]

The name of the emitter to use when generating fracture-line dust particles. Returns NULL if no emitter is configured.

virtual uint32_t nvidia::apex::DestructibleAsset::getInstancedChunkMeshCount ( ) const [pure virtual]

Get the number of instanced chunk meshes in this asset.

virtual NvParameterized::Interface** nvidia::apex::DestructibleAsset::getPartConvexHullArray ( const uint32_t partIndex ) const [pure virtual]

Returns the head of an array to convex hull NvParamterized::Interface* pointers for a given part.

virtual uint32_t nvidia::apex::DestructibleAsset::getPartConvexHullCount ( const uint32_t partIndex ) const [pure virtual]

The number of convex hulls associated with a given part.

virtual uint32_t nvidia::apex::DestructibleAsset::getPartIndex ( uint32_t chunkIndex ) const [pure virtual]

The render mesh asset part index associated with this chunk.

virtual const RenderMeshAsset* nvidia::apex::DestructibleAsset::getRenderMeshAsset ( ) const [pure virtual]

Gets the RenderMeshAsset associated with this asset.

virtual uint32_t nvidia::apex::DestructibleAsset::getScatterMeshAssetCount ( ) const [pure virtual]

Retrieve the number of scatter mesh assets

virtual RenderMeshAsset* const nvidia::apex::DestructibleAsset::getScatterMeshAssets ( ) const [pure virtual]

Retrieve the scatter mesh asset array

virtual void nvidia::apex::DestructibleAsset::getStats ( DestructibleAssetStats & stats ) const [pure virtual]

Returns stats (sizes, counts) for the asset. See DestructibleAssetStats.

virtual bool nvidia::apex::DestructibleAsset::rebuildCollisionGeometry | ( | uint32_t | partIndex,
 |  | const DestructibleGeometryDesc & | geometryDesc
 | ) |  | [pure virtual]

Rebuild the collision volumes for the given chunk, using the geometryDesc (see DestructibleGeometryDesc). Returns true iff successful.

virtual void nvidia::apex::DestructibleAsset::releaseDestructibleActor ( DestructibleActor & actor ) [pure virtual]

Instancing Instances the DestructibleAsset, creating an DestructibleActor, using the DestructibleActorDesc. See DestructibleActor and DestructibleActorDesc. This asset will own the DestructibleActor, so that any DestructibleActor created by it will be released when this asset is released. You may also call the DestructibleActor's release() method at any time.

virtual void nvidia::apex::DestructibleAsset::removeChunkOverlaps | ( | IntPair * | supportGraphEdges,
 |  | uint32_t | numSupportGraphEdges,
 |  | bool | keepCachedFlagIfEmpty
 | ) |  | [pure virtual]

Removes edges from support graph. The indices refer to the reordered chunk array, a mapping is provided in cookChunks.

Parameters:
supportGraphEdges | Integer pairs representing indices to chunks that are linked
numSupportGraphEdges | Number of provided integer pairs.
keepCachedFlagIfEmpty | If the flag is set, the depth is considered to be cached even if the overlaps list is empty.
virtual bool nvidia::apex::DestructibleAsset::setRenderMeshAsset ( RenderMeshAsset * ) [pure virtual]

Set the RenderMeshAsset associated with this asset. This is the asset used for non-instanced rendering. NULL is a valid argument, and can be used to clear the internal mesh data. Returns true if successful.

The documentation for this class was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAsset
nvidia::apex::DestructibleAsset Member List
This is the complete list of members for nvidia::apex::DestructibleAsset, including all inherited members.
addChunkOverlaps(IntPair *supportGraphEdges, uint32_t numSupportGraphEdges)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
applyTransformation(const PxMat44 &transformation, float scale)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
applyTransformation(const PxMat44 &transformation)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
cacheChunkOverlapsUpToDepth(int32_t depth=-1)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
ChunkAndDescendentsDoNotFracture enum value | nvidia::apex::DestructibleAsset |
ChunkDoesNotCrumble enum value | nvidia::apex::DestructibleAsset |
ChunkDoesNotFracture enum value | nvidia::apex::DestructibleAsset |
ChunkEnvironmentallySupported enum value | nvidia::apex::DestructibleAsset |
ChunkFlags enum name | nvidia::apex::DestructibleAsset |
ChunkIsInstanced enum value | nvidia::apex::DestructibleAsset |
ChunkRuntimeFracture enum value | nvidia::apex::DestructibleAsset |
clearChunkOverlaps(int32_t depth=-1, bool keepCachedFlag=false)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
createDestructibleActorFromDeserializedState(::NvParameterized::Interface *actorParams, Scene &apexScene)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
getActorTransformCount() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getActorTransforms() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getCachedOverlapCountAtDepth(uint32_t depth) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getCachedOverlapsAtDepth(uint32_t depth) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkActorLocalBounds(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkCount() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkDepth(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkFlags(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkParentIndex(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkPositionOffset(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkUVOffset(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getCrumbleEmitterName() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getDepthCount() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getDestructibleInitParameters() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getDestructibleParameters() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getDustEmitterName() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getInstancedChunkMeshCount() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getPartConvexHullArray(const uint32_t partIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getPartConvexHullCount(const uint32_t partIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getPartIndex(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getRenderMeshAsset() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getScatterMeshAssetCount() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getScatterMeshAssets() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getStats(DestructibleAssetStats &stats) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
rebuildCollisionGeometry(uint32_t partIndex, const DestructibleGeometryDesc &geometryDesc)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
releaseDestructibleActor(DestructibleActor &actor)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
removeChunkOverlaps(IntPair *supportGraphEdges, uint32_t numSupportGraphEdges, bool keepCachedFlagIfEmpty)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
setRenderMeshAsset(RenderMeshAsset *)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
~DestructibleAsset() | nvidia::apex::DestructibleAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleAssetAuthoring Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAssetAuthoring
Public Member Functions
nvidia::apex::DestructibleAssetAuthoring Class Reference

#include <DestructibleAsset.h>

List of all members.

Public Member Functions

virtual ExplicitHierarchicalMesh & | getExplicitHierarchicalMesh ()=0
virtual ExplicitHierarchicalMesh & | getCoreExplicitHierarchicalMesh ()=0
virtual FractureTools::CutoutSet & | getCutoutSet ()=0
virtual uint32_t | partitionMeshByIslands (nvidia::ExplicitRenderTriangle *mesh, uint32_t meshTriangleCount, uint32_t *meshPartition, uint32_t meshPartitionMaxCount, float padding=0.0001f)=0
virtual bool | setRootMesh (const ExplicitRenderTriangle *meshTriangles, uint32_t meshTriangleCount, const ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0, int32_t *parentIndices=NULL, uint32_t parentIndexCount=0)=0
virtual bool | importRenderMeshAssetToRootMesh (const nvidia::RenderMeshAsset &renderMeshAsset, uint32_t maxRootDepth=UINT32_MAX)=0
virtual bool | importDestructibleAssetToRootMesh (const nvidia::DestructibleAsset &destructibleAsset, uint32_t maxRootDepth=UINT32_MAX)=0
virtual bool | setCoreMesh (const ExplicitRenderTriangle *mesh, uint32_t meshTriangleCount, const ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0)=0
virtual bool | buildExplicitHierarchicalMesh (ExplicitHierarchicalMesh &hMesh, const ExplicitRenderTriangle *meshTriangles, uint32_t meshTriangleCount, const ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0, int32_t *parentIndices=NULL, uint32_t parentIndexCount=0)=0
virtual bool | createHierarchicallySplitMesh (const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, uint32_t randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual bool | createChippedMesh (const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureCutoutDesc &desc, const FractureTools::CutoutSet &cutoutSet, const FractureTools::FractureSliceDesc &sliceDesc, const FractureTools::FractureVoronoiDesc &voronoiDesc, const CollisionDesc &collisionDesc, uint32_t randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual void | buildCutoutSet (const uint8_t *pixelBuffer, uint32_t bufferWidth, uint32_t bufferHeight, float snapThreshold, bool periodic)=0
virtual bool | calculateCutoutUVMapping (PxMat33 &mapping, const nvidia::ExplicitRenderTriangle &triangle)=0
virtual bool | calculateCutoutUVMapping (PxMat33 &mapping, const PxVec3 &targetDirection)=0
virtual bool | createVoronoiSplitMesh (const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, uint32_t randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual uint32_t | createVoronoiSitesInsideMesh (PxVec3 *siteBuffer, uint32_t *siteChunkIndices, uint32_t siteCount, uint32_t *randomSeed, uint32_t *microgridSize, BSPOpenMode::Enum meshMode, IProgressListener &progressListener, uint32_t chunkIndex=0xFFFFFFFF)=0
virtual uint32_t | createScatterMeshSites (uint8_t *meshIndices, PxMat44 *relativeTransforms, uint32_t *chunkMeshStarts, uint32_t scatterMeshInstancesBufferSize, uint32_t targetChunkCount, const uint16_t *targetChunkIndices, uint32_t *randomSeed, uint32_t scatterMeshAssetCount, nvidia::RenderMeshAsset **scatterMeshAssets, const uint32_t *minCount, const uint32_t *maxCount, const float *minScales, const float *maxScales, const float *maxAngles)=0
virtual void | visualizeVoronoiCells (nvidia::RenderDebugInterface &debugRender, const PxVec3 *sites, uint32_t siteCount, const uint32_t *cellColors, uint32_t cellColorCount, const PxBounds3 &bounds, uint32_t cellIndex=0xFFFFFFFF)=0
virtual bool | hierarchicallySplitChunk (uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual bool | voronoiSplitChunk (uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual void | setBSPTolerances (float linearTolerance, float angularTolerance, float baseTolerance, float clipTolerance, float cleaningTolerance)=0
virtual void | setBSPBuildParameters (float logAreaSigmaThreshold, uint32_t testSetSize, float splitWeight, float imbalanceWeight)=0
virtual
ExplicitHierarchicalMesh::ConvexHull * 		createExplicitHierarchicalMeshConvexHull ()=0
virtual uint32_t | buildSliceMesh (const ExplicitRenderTriangle *&mesh, const FractureTools::NoiseParameters &noiseParameters, const PxPlane &slicePlane, uint32_t randomSeed)=0
virtual void | serializeFractureToolState (PxFileBuf &stream, nvidia::ExplicitHierarchicalMesh::Embedding &embedding) const =0
virtual void | deserializeFractureToolState (PxFileBuf &stream, nvidia::ExplicitHierarchicalMesh::Embedding &embedding)=0
virtual void | setChunkOverlapsCacheDepth (int32_t depth=-1)=0
virtual const RenderMeshAsset * | getRenderMeshAsset () const =0
virtual bool | setRenderMeshAsset (RenderMeshAsset *)=0
virtual bool | setScatterMeshAssets (RenderMeshAsset **scatterMeshAssetArray, uint32_t scatterMeshAssetArraySize)=0
virtual uint32_t | getScatterMeshAssetCount () const =0
virtual RenderMeshAsset *const | getScatterMeshAssets () const =0
virtual uint32_t | getInstancedChunkMeshCount () const =0
virtual void | setDestructibleParameters (const DestructibleParameters &)=0
virtual DestructibleParameters | getDestructibleParameters () const =0
virtual void | setDestructibleInitParameters (const DestructibleInitParameters &)=0
virtual DestructibleInitParameters | getDestructibleInitParameters () const =0
virtual void | setCrumbleEmitterName (const char *)=0
virtual void | setDustEmitterName (const char *)=0
virtual void | setFracturePatternName (const char *)=0
virtual void | setNeighborPadding (float neighborPadding)=0
virtual float | getNeighborPadding () const =0
virtual void | cookChunks (const DestructibleAssetCookingDesc &cookingDesc, bool cacheOverlaps=true, uint32_t *chunkIndexMapUser2Apex=NULL, uint32_t *chunkIndexMapApex2User=NULL, uint32_t chunkIndexMapCount=0)=0
virtual float | getFractureImpulseScale () const =0
virtual float | getImpactVelocityThreshold () const =0
virtual uint32_t | getChunkCount () const =0
virtual uint32_t | getDepthCount () const =0
virtual uint32_t | getChunkChildCount (uint32_t chunkIndex) const =0
virtual int32_t | getChunkChild (uint32_t chunkIndex, uint32_t childIndex) const =0
virtual PxVec3 | getChunkPositionOffset (uint32_t chunkIndex) const =0
virtual PxVec2 | getChunkUVOffset (uint32_t chunkIndex) const =0
virtual uint32_t | getPartIndex (uint32_t chunkIndex) const =0
virtual void | trimCollisionGeometry (const uint32_t *partIndices, uint32_t partIndexCount, float maxTrimFraction=0.2f)=0
virtual void | getStats (DestructibleAssetStats &stats) const =0
virtual void | cacheChunkOverlapsUpToDepth (int32_t depth=-1)=0
virtual void | clearChunkOverlaps (int32_t depth=-1, bool keepCachedFlag=false)=0
virtual void | addChunkOverlaps (IntPair *supportGraphEdges, uint32_t numSupportGraphEdges)=0
virtual void | removeChunkOverlaps (IntPair *supportGraphEdges, uint32_t numSupportGraphEdges, bool keepCachedFlagIfEmpty)=0
virtual uint32_t | getCachedOverlapCountAtDepth (uint32_t depth)=0
virtual const IntPair * | getCachedOverlapsAtDepth (uint32_t depth)=0
virtual void | applyTransformation (const PxMat44 &transformation, float scale)=0
Apply a transformation to destructible asset.
virtual void | applyTransformation (const PxMat44 &transformation)=0
Apply an arbitrary affine transformation to destructible asset.
virtual bool | setPlatformMaxDepth (PlatformTag platform, uint32_t maxDepth)=0
Set a maximum fracture depth for a given platform string.
virtual bool | removePlatformMaxDepth (PlatformTag platform)=0
Removes the maximum fracture depth limit for a given platform string.
virtual uint32_t | getActorTransformCount () const =0
Returns the size of the actor transform array. See getActorTransforms() for a description of this data.
virtual const PxMat44 * | getActorTransforms () const =0
Returns the head of the actor transform array. This list is a convenience for placing actors in a level from poses authored in a level editor. The transforms may contain scaling.
virtual void | appendActorTransforms (const PxMat44 *transforms, uint32_t transformCount)=0
Append transforms to the actor transform list. See getActorTransforms() for a description of this data.
virtual void | clearActorTransforms ()=0
Clear the actor transform array. See getActorTransforms() for a description of this data.

Detailed Description

Authoring API for a destructible asset.

Member Function Documentation

virtual void nvidia::apex::DestructibleAssetAuthoring::addChunkOverlaps | ( | IntPair * | supportGraphEdges,
 |  | uint32_t | numSupportGraphEdges
 | ) |  | [pure virtual]

Adds edges to the support graph. Edges must connect chunks of equal depth. The indices refer to the reordered chunk array, a mapping is provided in cookChunks.

virtual void nvidia::apex::DestructibleAssetAuthoring::appendActorTransforms | ( | const PxMat44 * | transforms,
 |  | uint32_t | transformCount
 | ) |  | [pure virtual]

Append transforms to the actor transform list. See getActorTransforms() for a description of this data.

Parameters:
transforms | Head of an array of transforms
transformCount | Size of transforms
virtual void nvidia::apex::DestructibleAssetAuthoring::applyTransformation | ( | const PxMat44 & | transformation,
 |  | float | scale
 | ) |  | [pure virtual]

Apply a transformation to destructible asset.

This is a permanent transformation and it changes the object state. Should only be called immediately before serialization and without further modifying the object later on.

Parameters:
transformation | This matrix is allowed to contain a translation and a rotation
scale | Apply a uniform scaling as well
virtual void nvidia::apex::DestructibleAssetAuthoring::applyTransformation ( const PxMat44 & transformation ) [pure virtual]

Apply an arbitrary affine transformation to destructible asset.

This is a permanent transformation and it changes the object state. Should only be called immediately before serialization and without further modifying the object later on.

Parameters:
transformation This matrix is allowed to contain translation, rotation, scale and skew
virtual void nvidia::apex::DestructibleAssetAuthoring::buildCutoutSet | ( | const uint8_t * | pixelBuffer,
 |  | uint32_t | bufferWidth,
 |  | uint32_t | bufferHeight,
 |  | float | snapThreshold,
 |  | bool | periodic
 | ) |  | [pure virtual]

Builds an internal cutout set.

Parameters:
pixelBuffer | pointer to be beginning of the pixel buffer
bufferWidth | the width of the buffer in pixels
bufferHeight | the height of the buffer in pixels
snapThreshold | the pixel distance at which neighboring cutout vertices and segments may be fudged into alignment.
periodic | whether or not to use periodic boundary conditions when creating cutouts from the map
virtual bool nvidia::apex::DestructibleAssetAuthoring::buildExplicitHierarchicalMesh | ( | ExplicitHierarchicalMesh & | hMesh,
 |  | const ExplicitRenderTriangle * | meshTriangles,
 |  | uint32_t | meshTriangleCount,
 |  | const ExplicitSubmeshData * | submeshData,
 |  | uint32_t | submeshCount,
 |  | uint32_t * | meshPartition = NULL,
 |  | uint32_t | meshPartitionCount = 0,
 |  | int32_t * | parentIndices = NULL,
 |  | uint32_t | parentIndexCount = 0
 | ) |  | [pure virtual]

Builds a new ExplicitHierarchicalMesh from an array of triangles, externally provided by the user. Note: setRootMesh and setCoreMesh may be implemented as follows: setRootMesh(x) <-> buildExplicitHierarchicalMesh( getExplicitHierarchicalMesh(), x) setCoreMesh(x) <-> buildExplicitHierarchicalMesh( getCoreExplicitHierarchicalMesh(), x)

Parameters:
hMesh | new ExplicitHierarchicalMesh
meshTriangles | pointer to array of ExplicitRenderTriangles which make up the mesh
meshTriangleCount | the size of the meshTriangles array
submeshData | pointer to array of ExplicitSubmeshData, describing the submeshes
submeshCount | the size of the submeshData array
meshPartition | if not NULL, an array of size meshPartitionCount, giving the end elements of contiguous subsets of meshTriangles. If meshPartition is NULL, one partition is assumed. When there is one partition, these triangles become the level 0 part. When there is more than one partition, these triangles become level 1 parts, while the union of the parts will be the level 0 part.
meshPartitionCount | if meshPartition is not NULL, this is the size of the meshPartition array.
parentIndices | if not NULL, the parent indices for each chunk (corresponding to a partition in the mesh partition).
parentIndexCount | the size of the parentIndices array. This does not need to match meshPartitionCount. If a mesh partition has an index beyond the end of parentIndices, then the parentIndex is considered to be 0. Therefore, if parentIndexCount = 0, all parents are 0 and so all chunks created will be depth 1. This will cause a depth 0 chunk to be created that is the aggregate of the depth 1 chunks. If parentIndexCount > 0, then the depth-0 chunk must have a parentIndex of -1. To reproduce the effect of the old parameter 'firstPartitionIsDepthZero' = true, set parentIndices to the address of a int32_t containing the value -1, and set parentIndexCount = 1. To reproduce the effect of the old parameter 'firstPartitionIsDepthZero' = false, set parentIndexCount = 0. Note: if parent indices are given, the first one must be -1, and *only* that index may be negative. That is, there may be only one depth-0 mesh and it must be the first mesh.
virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::buildSliceMesh | ( | const ExplicitRenderTriangle *& | mesh,
 |  | const FractureTools::NoiseParameters & | noiseParameters,
 |  | const PxPlane & | slicePlane,
 |  | uint32_t | randomSeed
 | ) |  | [pure virtual]

Builds a mesh used for slice fracturing, given the noise parameters and random seed. This function is mostly intended for visualization - to give the user a "typical" slice surface used for fracturing.

Returns:
Returns the head of an array of ExplicitRenderTriangles, of length given by the return value.
virtual void nvidia::apex::DestructibleAssetAuthoring::cacheChunkOverlapsUpToDepth ( int32_t depth = -1 ) [pure virtual]

Ensures that the asset has chunk overlap information cached up to the given depth. If depth < 0 (as it is by default), the depth will be taken to be the supportDepth given in the asset's destructibleParameters. It is ok to pass in a depth greater than any chunk depth in the asset.

virtual bool nvidia::apex::DestructibleAssetAuthoring::calculateCutoutUVMapping | ( | PxMat33 & | mapping,
 |  | const nvidia::ExplicitRenderTriangle & | triangle
 | ) |  | [pure virtual]

Calculate the mapping between a cutout fracture map and a given triangle. The result is a 3 by 3 matrix M composed by an affine transformation and a rotation, we can get the 3-D projection for a texture coordinate pair (u,v) with such a formula: (x,y,z) = M*PxVec3(u,v,1)

Parameters:
mapping | resulted mapping, composed by an affine transformation and a rotation
triangle | triangle
virtual bool nvidia::apex::DestructibleAssetAuthoring::calculateCutoutUVMapping | ( | PxMat33 & | mapping,
 |  | const PxVec3 & | targetDirection
 | ) |  | [pure virtual]

Uses the passed-in target direction to find the best triangle in the root mesh with normal near the given targetDirection. If triangles exist with normals within one degree of the given target direction, then one with the greatest area of such triangles is used. Otherwise, the triangle with normal closest to the given target direction is used. The resulting triangle is used to calculate a UV mapping as in the function calculateCutoutUVMapping (above).

The assumption is that there exists a single mapping for all triangles on a specified face, for this feature to be useful.

Parameters:
mapping resulted mapping, composed by an affine transformation and a rotation
targetDirection,: the target face's normal
virtual void nvidia::apex::DestructibleAssetAuthoring::clearActorTransforms ( ) [pure virtual]

Clear the actor transform array. See getActorTransforms() for a description of this data.

virtual void nvidia::apex::DestructibleAssetAuthoring::clearChunkOverlaps | ( | int32_t | depth = -1,
 |  | bool | keepCachedFlag = false
 | ) |  | [pure virtual]

Clears the chunk overlap cache.

Parameters:
depth | Depth to be cleared. -1 for all depths.
keepCachedFlag | If the flag is set, the depth is considered to be cached even if the overlaps list is empty.
virtual void nvidia::apex::DestructibleAssetAuthoring::cookChunks | ( | const DestructibleAssetCookingDesc & | cookingDesc,
 |  | bool | cacheOverlaps = true,
 |  | uint32_t * | chunkIndexMapUser2Apex = NULL,
 |  | uint32_t * | chunkIndexMapApex2User = NULL,
 |  | uint32_t | chunkIndexMapCount = 0
 | ) |  | [pure virtual]

Once the internal ExplicitHierarchicalMesh is built using the fracture tools functions and all emitter names and parameters set, this functions builds the destructible asset. Every chunk (corresponding to a part in the ExplicitHierarchicalMesh) must have destruction-specific data set through the descriptor passed into this function. See DestructibleAssetCookingDesc.

Parameters:
cookingDesc | cooking setup
cacheOverlaps | whether the chunk overlaps up to chunkOverlapCacheDepth should be cached in this call
chunkIndexMapUser2Apex | optional user provided uint32_t array that will contains the mapping from user chunk indices (referring to chunks in cookingDesc) to Apex internal chunk indices (referring to chunk is internal chunk array)
chunkIndexMapApex2User | same as chunkIndexMapUser2Apex, but opposite direction
chunkIndexMapCount | size of the user provided mapping arrays
virtual bool nvidia::apex::DestructibleAssetAuthoring::createChippedMesh | ( | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureCutoutDesc & | desc,
 |  | const FractureTools::CutoutSet & | cutoutSet,
 |  | const FractureTools::FractureSliceDesc & | sliceDesc,
 |  | const FractureTools::FractureVoronoiDesc & | voronoiDesc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t | randomSeed,
 |  | IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the mesh in chunk[0], forming a hierarchy of fractured meshes in chunks[1...] using cutout-mode (chippable) fracturing.

Parameters:
meshProcessingParams | describes generic mesh processing directives
desc | describes the slicing surfaces (see FractureCutoutDesc)
cutoutSet | the cutout set to use for fracturing (see CutoutSet)
sliceDesc | used if desc.chunkFracturingMethod = SliceFractureCutoutChunks
voronoiDesc | used if desc.chunkFracturingMethod = VoronoiFractureCutoutChunks
collisionDesc | convex hulls will be generated for each chunk using the method See CollisionDesc.
randomSeed | seed for the random number generator, to ensure reproducibility.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual ExplicitHierarchicalMesh::ConvexHull* nvidia::apex::DestructibleAssetAuthoring::createExplicitHierarchicalMeshConvexHull ( ) [pure virtual]

Instantiates an ExplicitHierarchicalMesh::ConvexHull

See the ConvexHull API for its functionality. Can be used to author chunk hulls in the cookChunks function.

Use ConvexHull::release() to delete the object.

virtual bool nvidia::apex::DestructibleAssetAuthoring::createHierarchicallySplitMesh | ( | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureSliceDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | bool | exportCoreMesh,
 |  | int32_t | coreMeshImprintSubmeshIndex,
 |  | uint32_t | randomSeed,
 |  | IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the chunk in chunk[0], forming a hierarchy of fractured chunks in chunks[1...] using slice-mode fracturing.

Parameters:
meshProcessingParams | describes generic mesh processing directives
desc | describes the slicing surfaces (see FractureSliceDesc)
collisionDesc | convex hulls will be generated for each chunk using the method See CollisionDesc.
exportCoreMesh | if true, the core mesh will be included (at depth 1) in the hierarchically split mesh. Otherwise, it will only be used to create a hollow space.
coreMeshImprintSubmeshIndex | if this is < 0, use the core mesh materials (was applyCoreMeshMaterialToNeighborChunks). Otherwise, use the given submesh
randomSeed | seed for the random number generator, to ensure reproducibility.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::createScatterMeshSites | ( | uint8_t * | meshIndices,
 |  | PxMat44 * | relativeTransforms,
 |  | uint32_t * | chunkMeshStarts,
 |  | uint32_t | scatterMeshInstancesBufferSize,
 |  | uint32_t | targetChunkCount,
 |  | const uint16_t * | targetChunkIndices,
 |  | uint32_t * | randomSeed,
 |  | uint32_t | scatterMeshAssetCount,
 |  | nvidia::RenderMeshAsset ** | scatterMeshAssets,
 |  | const uint32_t * | minCount,
 |  | const uint32_t * | maxCount,
 |  | const float * | minScales,
 |  | const float * | maxScales,
 |  | const float * | maxAngles
 | ) |  | [pure virtual]

Creates scatter mesh sites randomly distributed on the mesh.

Parameters:
meshIndices | user-allocated array of size scatterMeshInstancesBufferSize which will be filled in by this function, giving the scatter mesh index used
relativeTransforms | user-allocated array of size scatterMeshInstancesBufferSize which will be filled in by this function, giving the chunk-relative transform for each chunk instance
chunkMeshStarts | user-allocated array which will be filled in with offsets into the meshIndices and relativeTransforms array. For a chunk indexed by i, the corresponding range [chunkMeshStart[i], chunkMeshStart[i+1]-1] in meshIndices and relativeTransforms is used. NOTE*: chunkMeshStart array must be of at least size N+1, where N is the number of chunks in the base explicit hierarchical mesh.
scatterMeshInstancesBufferSize | the size of meshIndices and relativeTransforms array.
targetChunkCount | how many chunks are in the array targetChunkIndices
targetChunkIndices | an array of chunk indices which are candidates for scatter meshes. The elements in the array chunkIndices will come from this array
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
scatterMeshAssetCount | the number of different scatter meshes (not instances). Should not exceed 255. If scatterMeshAssetCount > 255, only the first 255 will be used.
scatterMeshAssets | an array of size scatterMeshAssetCount, of the render mesh assets which will be used for the scatter meshes
minCount | an array of size scatterMeshAssetCount, giving the minimum number of instances to place for each mesh
maxCount | an array of size scatterMeshAssetCount, giving the maximum number of instances to place for each mesh
minScales | an array of size scatterMeshAssetCount, giving the minimum scale to apply to each scatter mesh
maxScales | an array of size scatterMeshAssetCount, giving the maximum scale to apply to each scatter mesh
maxAngles | an array of size scatterMeshAssetCount, giving a maximum deviation angle (in degrees) from the surface normal to apply to each scatter mesh
Returns:
return value: the number of instances placed in indices and relativeTransforms (will not exceed scatterMeshInstancesBufferSize)
virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::createVoronoiSitesInsideMesh | ( | PxVec3 * | siteBuffer,
 |  | uint32_t * | siteChunkIndices,
 |  | uint32_t | siteCount,
 |  | uint32_t * | randomSeed,
 |  | uint32_t * | microgridSize,
 |  | BSPOpenMode::Enum | meshMode,
 |  | IProgressListener & | progressListener,
 |  | uint32_t | chunkIndex = 0xFFFFFFFF
 | ) |  | [pure virtual]

Generates a set of uniformly distributed points in the interior of the root mesh.

Parameters:
siteBuffer | An array of PxVec3, at least the size of siteCount.
siteChunkIndices | If not NULL, it must be at least the size of siteCount. siteCount indices will be written to this buffer, associating each site with a chunk that contains it.
siteCount | The number of points to write into siteBuffer.
randomSeed | Pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
microgridSize | Pointer to a grid size used for BSP creation. If NULL, the default settings will be used.
meshMode | Open mesh handling. Modes: Automatic, Closed, Open (see BSPOpenMode)
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
chunkIndex | If this is a valid index, the voronoi sites will only be created within the volume of the indexed chunk. Otherwise, the sites will be created within each of the root-level chunks. Default value is an invalid index.
Returns:
Returns the number of sites actually created (written to siteBuffer and siteChunkIndices). This may be less than the number of sites requested if site placement fails.
virtual bool nvidia::apex::DestructibleAssetAuthoring::createVoronoiSplitMesh | ( | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureVoronoiDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | bool | exportCoreMesh,
 |  | int32_t | coreMeshImprintSubmeshIndex,
 |  | uint32_t | randomSeed,
 |  | IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the mesh in chunk[0], forming fractured pieces chunks[1...] using Voronoi decomposition fracturing.

Parameters:
meshProcessingParams | describes generic mesh processing directives
desc | describes the voronoi splitting parameters surfaces (see FractureVoronoiDesc)
collisionDesc | convex hulls will be generated for each chunk using the method See CollisionDesc.
exportCoreMesh | if true, the core mesh will be included (at depth 1) in the split mesh. Otherwise, it will only be used to create a hollow space.
coreMeshImprintSubmeshIndex | if this is < 0, use the core mesh materials (was applyCoreMeshMaterialToNeighborChunks). Otherwise, use the given submesh
randomSeed | seed for the random number generator, to ensure reproducibility.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual void nvidia::apex::DestructibleAssetAuthoring::deserializeFractureToolState | ( | PxFileBuf & | stream,
 |  | nvidia::ExplicitHierarchicalMesh::Embedding & | embedding
 | ) |  | [pure virtual]

Deserialization of the data associated with the fracture API. This includes the root mesh, core mesh, and cutout set.

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getActorTransformCount ( ) const [pure virtual]

Returns the size of the actor transform array. See getActorTransforms() for a description of this data.

virtual const PxMat44* nvidia::apex::DestructibleAssetAuthoring::getActorTransforms ( ) const [pure virtual]

Returns the head of the actor transform array. This list is a convenience for placing actors in a level from poses authored in a level editor. The transforms may contain scaling.

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getCachedOverlapCountAtDepth ( uint32_t depth ) [pure virtual]

The size of the array returned by getCachedOverlapsAtDepth(depth) (see below). Note: this function will not trigger overlap caching for the given depth. If no overlaps have been calculated for the depth given, this function returns NULL.

virtual const IntPair* nvidia::apex::DestructibleAssetAuthoring::getCachedOverlapsAtDepth ( uint32_t depth ) [pure virtual]

Array of integer pairs, indexing chunk pairs which touch at a given depth in the heirarcy. The size of the array is given by getCachedOverlapCountAtDepth(depth). Note: this function will not trigger overlap caching for the given depth. If no overlaps have been calculated for the depth given, this function returns NULL.

virtual int32_t nvidia::apex::DestructibleAssetAuthoring::getChunkChild | ( | uint32_t | chunkIndex,
 |  | uint32_t | childIndex
 | ) |  | const [pure virtual]

Returns the index for the given child of the given chunk. chunkIndex must be less than getChunkCount() and childIndex must be less than getChunkChildCount(chunkIndex). If either of these conditions is not met, the function returns ModuleDestructibleConst::INVALID_CHUNK_INDEX.

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getChunkChildCount ( uint32_t chunkIndex ) const [pure virtual]

Returns the number of children for the given chunk. chunkIndex must be less than getChunkCount(). If it is not, this function returns 0.

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getChunkCount ( ) const [pure virtual]

The total number of chunks in the cooked asset.

virtual PxVec3 nvidia::apex::DestructibleAssetAuthoring::getChunkPositionOffset ( uint32_t chunkIndex ) const [pure virtual]

If this chunk is instanced within the same asset, then this provides the instancing position offset. Otherwise, this function returns (0,0,0).

virtual PxVec2 nvidia::apex::DestructibleAssetAuthoring::getChunkUVOffset ( uint32_t chunkIndex ) const [pure virtual]

If this chunk is instanced within the same asset, then this provides the instancing UV offset. Otherwise, this function returns (0,0).

virtual ExplicitHierarchicalMesh& nvidia::apex::DestructibleAssetAuthoring::getCoreExplicitHierarchicalMesh ( ) [pure virtual]

DestructibleAssetAuthoring contains a second instantiation of ExplicitHierarchicalMesh used to describe the core mesh for slice fracturing (see FractureTools::FractureSliceDesc), done in createHierarchicallySplitMesh(). This function gives access to it.

virtual FractureTools::CutoutSet& nvidia::apex::DestructibleAssetAuthoring::getCutoutSet ( ) [pure virtual]

DestructibleAssetAuthoring contains an instantiation of CutoutSet used to describe the cutout fracturing shapes (see FractureTools::CutoutSet), done in createChippedMesh(). This function gives access to it.

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getDepthCount ( ) const [pure virtual]

The total number of fracture hierarchy depth levels in the cooked asset.

virtual DestructibleInitParameters nvidia::apex::DestructibleAssetAuthoring::getDestructibleInitParameters ( ) const [pure virtual]

The parameters used for default destructible initialization. See DestructibleInitParameters.

virtual DestructibleParameters nvidia::apex::DestructibleAssetAuthoring::getDestructibleParameters ( ) const [pure virtual]

The DestructibleParameters which describe the default fracturing behavior for instanced DestructibleActors. These may be overridden by calling setDestructibleParameters().

virtual ExplicitHierarchicalMesh& nvidia::apex::DestructibleAssetAuthoring::getExplicitHierarchicalMesh ( ) [pure virtual]

Fracturing API DestructibleAssetAuthoring contains an instantiation of ExplicitHierarchicalMesh. This function gives access to it. See ExplicitHierarchicalMesh for details, it is the object used by the fracturing tool set for mesh fracturing operations and is used to generate the embedded RenderMesh as well as collision and hierarchy data for the destructible asset.

virtual float nvidia::apex::DestructibleAssetAuthoring::getFractureImpulseScale ( ) const [pure virtual]

The scale factor used to apply an impulse force along the normal of chunk when fractured. This is used in order to "push" the pieces out as they fracture.

virtual float nvidia::apex::DestructibleAssetAuthoring::getImpactVelocityThreshold ( ) const [pure virtual]

Large impact force may be reported if rigid bodies are spawned inside one another. In this case the realative velocity of the two objects will be low. This variable allows the user to set a minimum velocity threshold for impacts to ensure that the objects are moving at a min velocity in order for the impact force to be considered.

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getInstancedChunkMeshCount ( ) const [pure virtual]

Get the number of instanced chunk meshes in this asset.

virtual float nvidia::apex::DestructibleAssetAuthoring::getNeighborPadding ( ) const [pure virtual]

Get padding used for chunk neighbor tests. Set setNeighborPadding().

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getPartIndex ( uint32_t chunkIndex ) const [pure virtual]

The render mesh asset part index associated with this chunk.

virtual const RenderMeshAsset* nvidia::apex::DestructibleAssetAuthoring::getRenderMeshAsset ( ) const [pure virtual]

Gets the RenderMeshAsset associated with this asset.

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getScatterMeshAssetCount ( ) const [pure virtual]

Retrieve the number of scatter mesh assets

virtual RenderMeshAsset* const nvidia::apex::DestructibleAssetAuthoring::getScatterMeshAssets ( ) const [pure virtual]

Retrieve the scatter mesh asset array

virtual void nvidia::apex::DestructibleAssetAuthoring::getStats ( DestructibleAssetStats & stats ) const [pure virtual]

Returns stats (sizes, counts) for the asset. See DestructibleAssetStats.

virtual bool nvidia::apex::DestructibleAssetAuthoring::hierarchicallySplitChunk | ( | uint32_t | chunkIndex,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureSliceDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t * | randomSeed,
 |  | IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the chunk in chunk[chunkIndex], forming a hierarchy of fractured chunks using slice-mode fracturing. The chunks will be rearranged so that they are in breadth-first order.

Parameters:
chunkIndex | index of chunk to be split
meshProcessingParams | describes generic mesh processing directives
desc | describes the slicing surfaces (see FractureSliceDesc)
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual bool nvidia::apex::DestructibleAssetAuthoring::importDestructibleAssetToRootMesh | ( | const nvidia::DestructibleAsset & | destructibleAsset,
 |  | uint32_t | maxRootDepth = UINT32_MAX
 | ) |  | [pure virtual]

Builds the root ExplicitHierarchicalMesh from an DestructibleAsset. Since an DestructibleAsset contains hierarchy information, the explicit mesh formed will have this hierarchy structure.

Parameters:
destructibleAsset | the asset to import
maxRootDepth | cap the root depth at this value. Re-fracturing of the mesh will occur at this depth. Default = UINT32_MAX
virtual bool nvidia::apex::DestructibleAssetAuthoring::importRenderMeshAssetToRootMesh | ( | const nvidia::RenderMeshAsset & | renderMeshAsset,
 |  | uint32_t | maxRootDepth = UINT32_MAX
 | ) |  | [pure virtual]

Builds the root ExplicitHierarchicalMesh from an RenderMeshAsset. Since an DestructibleAsset contains no hierarchy information, the input mesh must have only one part.

Parameters:
renderMeshAsset | the asset to import
maxRootDepth | cap the root depth at this value. Re-fracturing of the mesh will occur at this depth. Default = UINT32_MAX
virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::partitionMeshByIslands | ( | nvidia::ExplicitRenderTriangle * | mesh,
 |  | uint32_t | meshTriangleCount,
 |  | uint32_t * | meshPartition,
 |  | uint32_t | meshPartitionMaxCount,
 |  | float | padding = 0.0001f
 | ) |  | [pure virtual]

Partitions (and possibly re-orders) the mesh array if the triangles form disjoint islands.

Parameters:
mesh | pointer to array of ExplicitRenderTriangles which make up the mesh
meshTriangleCount | the size of the meshTriangles array
meshPartition | user-allocated array for mesh partition, will be filled with the end elements of contiguous subsets of meshTriangles.
meshPartitionMaxCount | size of user-allocated meshPartitionArray
padding | relative value multiplied by the mesh bounding box. padding gets added to the triangle bounds when calculating triangle neighbors.
Returns:
Returns the number of partitions. The value may be larger than meshPartitionMaxCount. In that case, the partitions beyond meshPartitionMaxCount are not recorded.
virtual void nvidia::apex::DestructibleAssetAuthoring::removeChunkOverlaps | ( | IntPair * | supportGraphEdges,
 |  | uint32_t | numSupportGraphEdges,
 |  | bool | keepCachedFlagIfEmpty
 | ) |  | [pure virtual]

Removes edges from support graph. The indices refer to the reordered chunk array, a mapping is provided in cookChunks.

Parameters:
supportGraphEdges | Integer pairs representing indices to chunks that are linked
numSupportGraphEdges | Number of provided integer pairs.
keepCachedFlagIfEmpty | If the flag is set, the depth is considered to be cached even if the overlaps list is empty.
virtual bool nvidia::apex::DestructibleAssetAuthoring::removePlatformMaxDepth ( PlatformTag platform ) [pure virtual]

Removes the maximum fracture depth limit for a given platform string.

Returns true if the platform's maximum fracture depth was previously set and now removed

virtual void nvidia::apex::DestructibleAssetAuthoring::serializeFractureToolState | ( | PxFileBuf & | stream,
 |  | nvidia::ExplicitHierarchicalMesh::Embedding & | embedding
 | ) |  | const [pure virtual]

Serialization of the data associated with the fracture API. This includes the root mesh, core mesh, and cutout set.

virtual void nvidia::apex::DestructibleAssetAuthoring::setBSPBuildParameters | ( | float | logAreaSigmaThreshold,
 |  | uint32_t | testSetSize,
 |  | float | splitWeight,
 |  | float | imbalanceWeight
 | ) |  | [pure virtual]

Set the parameters used in BSP building operations.

Parameters:
logAreaSigmaThreshold | At each step in the tree building process, the surface with maximum triangle area is compared to the other surface triangle areas. If the maximum area surface is far from the "typical" set of surface areas, then that surface is chosen as the next splitting plane. Otherwise, a random test set is chosen and a winner determined based upon the weightings below. The value logAreaSigmaThreshold determines how "atypical" the maximum area surface must be to be chosen in this manner. Default value = 2.0.
testSetSize | Larger values of testSetSize may find better BSP trees, but will take more time to create. testSetSize = 0 is treated as infinity (all surfaces will be tested for each branch). Default value = 10.
splitWeight | How much to weigh the relative number of triangle splits when searching for a BSP surface. Default value = 0.5.
imbalanceWeight | How much to weigh the relative triangle imbalance when searching for a BSP surface. Default value = 0.0.
virtual void nvidia::apex::DestructibleAssetAuthoring::setBSPTolerances | ( | float | linearTolerance,
 |  | float | angularTolerance,
 |  | float | baseTolerance,
 |  | float | clipTolerance,
 |  | float | cleaningTolerance
 | ) |  | [pure virtual]

Set the tolerances used in CSG calculations.

Parameters:
linearTolerance | relative (to mesh size) tolerance used with angularTolerance to determine coplanarity. Default = 1.0e-4.
angularTolerance | used with linearTolerance to determine coplanarity. Default = 1.0e-3
baseTolerance | relative (to mesh size) tolerance used for spatial partitioning
clipTolerance | relative (to mesh size) tolerance used when clipping triangles for CSG mesh building operations. Default = 1.0e-4.
cleaningTolerance | relative (to mesh size) tolerance used when cleaning the out put mesh generated from the toMesh() function. Default = 1.0e-7.
virtual void nvidia::apex::DestructibleAssetAuthoring::setChunkOverlapsCacheDepth ( int32_t depth = -1 ) [pure virtual]

Set current depth for chunk overlaps calculations.

virtual bool nvidia::apex::DestructibleAssetAuthoring::setCoreMesh | ( | const ExplicitRenderTriangle * | mesh,
 |  | uint32_t | meshTriangleCount,
 |  | const ExplicitSubmeshData * | submeshData,
 |  | uint32_t | submeshCount,
 |  | uint32_t * | meshPartition = NULL,
 |  | uint32_t | meshPartitionCount = 0
 | ) |  | [pure virtual]

Builds a new ExplicitHierarchicalMesh from an array of triangles, used as the core mesh for slice fracture operations (see FractureTools::FractureSliceDesc, passed into createHierarchicallySplitMesh).

Parameters:
mesh | pointer to array of ExplicitRenderTriangles which make up the mesh
meshTriangleCount | the size of the meshTriangles array
submeshData | pointer to array of ExplicitSubmeshData, describing the submeshes
submeshCount | the size of the submeshData array
meshPartition | meshPartition array
meshPartitionCount | meshPartition array size
virtual void nvidia::apex::DestructibleAssetAuthoring::setCrumbleEmitterName ( const char * ) [pure virtual]

Set the name of the emitter to use when generating crumble particles.

virtual void nvidia::apex::DestructibleAssetAuthoring::setDestructibleInitParameters ( const DestructibleInitParameters & ) [pure virtual]

Set the parameters used for default destructible initialization. See DestructibleInitParameters.

virtual void nvidia::apex::DestructibleAssetAuthoring::setDestructibleParameters ( const DestructibleParameters & ) [pure virtual]

Set the parameters used for runtime destruction behavior. See DestructibleParameters.

virtual void nvidia::apex::DestructibleAssetAuthoring::setDustEmitterName ( const char * ) [pure virtual]

Set the name of the emitter to use when generating fracture-line dust particles.

virtual void nvidia::apex::DestructibleAssetAuthoring::setFracturePatternName ( const char * ) [pure virtual]

Set the name of the fracture pattern to use when runtime fracture is enabled.

virtual void nvidia::apex::DestructibleAssetAuthoring::setNeighborPadding ( float neighborPadding ) [pure virtual]

Set padding used for chunk neighbor tests. This padding is relative to the largest diagonal of the asset's local bounding box. This value must be non-negative. Default value = 0.001f.

virtual bool nvidia::apex::DestructibleAssetAuthoring::setPlatformMaxDepth | ( | PlatformTag | platform,
 |  | uint32_t | maxDepth
 | ) |  | [pure virtual]

Set a maximum fracture depth for a given platform string.

Returns true if the supplied maxDepth is lesser than the number of chunk depth levels for this asset

virtual bool nvidia::apex::DestructibleAssetAuthoring::setRenderMeshAsset ( RenderMeshAsset * ) [pure virtual]

Set the RenderMeshAsset associated with this asset. This is the asset used for non-instanced rendering. NULL is a valid argument, and can be used to clear the internal mesh data.

Returns:
Returns true if successful.
virtual bool nvidia::apex::DestructibleAssetAuthoring::setRootMesh | ( | const ExplicitRenderTriangle * | meshTriangles,
 |  | uint32_t | meshTriangleCount,
 |  | const ExplicitSubmeshData * | submeshData,
 |  | uint32_t | submeshCount,
 |  | uint32_t * | meshPartition = NULL,
 |  | uint32_t | meshPartitionCount = 0,
 |  | int32_t * | parentIndices = NULL,
 |  | uint32_t | parentIndexCount = 0
 | ) |  | [pure virtual]

Builds a new ExplicitHierarchicalMesh from an array of triangles, used as the starting point for fracturing. It will contain only one chunk, at depth 0.

Parameters:
meshTriangles | pointer to array of ExplicitRenderTriangles which make up the mesh
meshTriangleCount | the size of the meshTriangles array
submeshData | pointer to array of ExplicitSubmeshData, describing the submeshes
submeshCount | the size of the submeshData array
meshPartition | if not NULL, an array of size meshPartitionCount, giving the end elements of contiguous subsets of meshTriangles. If meshPartition is NULL, one partition is assumed. When there is one partition, these triangles become the level 0 part. When there is more than one partition, the behavior is determined by firstPartitionIsDepthZero (see below).
meshPartitionCount | if meshPartition is not NULL, this is the size of the meshPartition array.
parentIndices | if not NULL, the parent indices for each chunk (corresponding to a partition in the mesh partition).
parentIndexCount | the size of the parentIndices array. This does not need to match meshPartitionCount. If a mesh partition has an index beyond the end of parentIndices, then the parentIndex is considered to be 0. Therefore, if parentIndexCount = 0, all parents are 0 and so all chunks created will be depth 1. This will cause a depth 0 chunk to be created that is the aggregate of the depth 1 chunks. If parentIndexCount > 0, then the depth-0 chunk must have a parentIndex of -1. To reproduce the effect of the old parameter 'firstPartitionIsDepthZero' = true, set parentIndices to the address of a int32_t containing the value -1, and set parentIndexCount = 1. To reproduce the effect of the old parameter 'firstPartitionIsDepthZero' = false, set parentIndexCount = 0. Note: if parent indices are given, the first one must be -1, and *only* that index may be negative. That is, there may be only one depth-0 mesh and it must be the first mesh.
virtual bool nvidia::apex::DestructibleAssetAuthoring::setScatterMeshAssets | ( | RenderMeshAsset ** | scatterMeshAssetArray,
 |  | uint32_t | scatterMeshAssetArraySize
 | ) |  | [pure virtual]

Set the RenderMeshAssets used for scatter mesh rendering associated with this asset. These assets will be rendered using instanced rendering. The array cannot contain NULL elements, if an array size greater than zero is specified.

Returns:
Returns true if successful.
virtual void nvidia::apex::DestructibleAssetAuthoring::trimCollisionGeometry | ( | const uint32_t * | partIndices,
 |  | uint32_t | partIndexCount,
 |  | float | maxTrimFraction = 0.2f
 | ) |  | [pure virtual]

Trim collision geometry to prevent explosive behavior. maxTrimFraction is the maximum (relative) distance to trim a hull in the direction of each trim plane.

Returns:
Returns true iff successful.
virtual void nvidia::apex::DestructibleAssetAuthoring::visualizeVoronoiCells | ( | nvidia::RenderDebugInterface & | debugRender,
 |  | const PxVec3 * | sites,
 |  | uint32_t | siteCount,
 |  | const uint32_t * | cellColors,
 |  | uint32_t | cellColorCount,
 |  | const PxBounds3 & | bounds,
 |  | uint32_t | cellIndex = 0xFFFFFFFF
 | ) |  | [pure virtual]

Utility to visualize Voronoi cells for a given set of sites.

Parameters:
debugRender | rendering object which will receive the drawing primitives associated with this cell visualization
sites | an array of Voronoi cell sites, of length siteCount
siteCount | the number of Voronoi cell sites (length of sites array)
cellColors | an optional array of colors (see RenderDebug for format) for the cells. If NULL, the white (0xFFFFFFFF) color will be used. If not NULL, this (of length cellColorCount) is used to color the cell graphics. The number cellColorCount need not match siteCount. If cellColorCount is less than siteCount, the cell colors will cycle. That is, site N gets cellColor[NcellColorCount].
cellColorCount | the number of cell colors (the length of cellColors array)
bounds | defines an axis-aligned bounding box which clips the visualization, since some cells extend to infinity
cellIndex | if this is a valid index (cellIndex < siteCount), then only the cell corresponding to sites[cellIndex] will be drawn. Otherwise, all cells will be drawn.
virtual bool nvidia::apex::DestructibleAssetAuthoring::voronoiSplitChunk | ( | uint32_t | chunkIndex,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureVoronoiDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t * | randomSeed,
 |  | IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the chunk in chunk[chunkIndex], forming fractured chunks using Voronoi decomposition fracturing. The chunks will be rearranged so that they are in breadth-first order.

Parameters:
chunkIndex | index of chunk to be split
meshProcessingParams | describes generic mesh processing directives
desc | describes the voronoi splitting parameters surfaces (see FractureVoronoiDesc)
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
The documentation for this class was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAssetAuthoring
nvidia::apex::DestructibleAssetAuthoring Member List
This is the complete list of members for nvidia::apex::DestructibleAssetAuthoring, including all inherited members.
addChunkOverlaps(IntPair *supportGraphEdges, uint32_t numSupportGraphEdges)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
appendActorTransforms(const PxMat44 *transforms, uint32_t transformCount)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
applyTransformation(const PxMat44 &transformation, float scale)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
applyTransformation(const PxMat44 &transformation)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
buildCutoutSet(const uint8_t *pixelBuffer, uint32_t bufferWidth, uint32_t bufferHeight, float snapThreshold, bool periodic)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
buildExplicitHierarchicalMesh(ExplicitHierarchicalMesh &hMesh, const ExplicitRenderTriangle *meshTriangles, uint32_t meshTriangleCount, const ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0, int32_t *parentIndices=NULL, uint32_t parentIndexCount=0)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
buildSliceMesh(const ExplicitRenderTriangle *&mesh, const FractureTools::NoiseParameters &noiseParameters, const PxPlane &slicePlane, uint32_t randomSeed)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
cacheChunkOverlapsUpToDepth(int32_t depth=-1)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
calculateCutoutUVMapping(PxMat33 &mapping, const nvidia::ExplicitRenderTriangle &triangle)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
calculateCutoutUVMapping(PxMat33 &mapping, const PxVec3 &targetDirection)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
clearActorTransforms()=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
clearChunkOverlaps(int32_t depth=-1, bool keepCachedFlag=false)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
cookChunks(const DestructibleAssetCookingDesc &cookingDesc, bool cacheOverlaps=true, uint32_t *chunkIndexMapUser2Apex=NULL, uint32_t *chunkIndexMapApex2User=NULL, uint32_t chunkIndexMapCount=0)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
createChippedMesh(const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureCutoutDesc &desc, const FractureTools::CutoutSet &cutoutSet, const FractureTools::FractureSliceDesc &sliceDesc, const FractureTools::FractureVoronoiDesc &voronoiDesc, const CollisionDesc &collisionDesc, uint32_t randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
createExplicitHierarchicalMeshConvexHull()=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
createHierarchicallySplitMesh(const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, uint32_t randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
createScatterMeshSites(uint8_t *meshIndices, PxMat44 *relativeTransforms, uint32_t *chunkMeshStarts, uint32_t scatterMeshInstancesBufferSize, uint32_t targetChunkCount, const uint16_t *targetChunkIndices, uint32_t *randomSeed, uint32_t scatterMeshAssetCount, nvidia::RenderMeshAsset **scatterMeshAssets, const uint32_t *minCount, const uint32_t *maxCount, const float *minScales, const float *maxScales, const float *maxAngles)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
createVoronoiSitesInsideMesh(PxVec3 *siteBuffer, uint32_t *siteChunkIndices, uint32_t siteCount, uint32_t *randomSeed, uint32_t *microgridSize, BSPOpenMode::Enum meshMode, IProgressListener &progressListener, uint32_t chunkIndex=0xFFFFFFFF)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
createVoronoiSplitMesh(const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, uint32_t randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
deserializeFractureToolState(PxFileBuf &stream, nvidia::ExplicitHierarchicalMesh::Embedding &embedding)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getActorTransformCount() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getActorTransforms() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getCachedOverlapCountAtDepth(uint32_t depth)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getCachedOverlapsAtDepth(uint32_t depth)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getChunkChild(uint32_t chunkIndex, uint32_t childIndex) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getChunkChildCount(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getChunkCount() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getChunkPositionOffset(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getChunkUVOffset(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getCoreExplicitHierarchicalMesh()=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getCutoutSet()=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getDepthCount() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getDestructibleInitParameters() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getDestructibleParameters() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getExplicitHierarchicalMesh()=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getFractureImpulseScale() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getImpactVelocityThreshold() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getInstancedChunkMeshCount() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getNeighborPadding() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getPartIndex(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getRenderMeshAsset() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getScatterMeshAssetCount() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getScatterMeshAssets() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getStats(DestructibleAssetStats &stats) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
hierarchicallySplitChunk(uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
importDestructibleAssetToRootMesh(const nvidia::DestructibleAsset &destructibleAsset, uint32_t maxRootDepth=UINT32_MAX)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
importRenderMeshAssetToRootMesh(const nvidia::RenderMeshAsset &renderMeshAsset, uint32_t maxRootDepth=UINT32_MAX)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
partitionMeshByIslands(nvidia::ExplicitRenderTriangle *mesh, uint32_t meshTriangleCount, uint32_t *meshPartition, uint32_t meshPartitionMaxCount, float padding=0.0001f)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
removeChunkOverlaps(IntPair *supportGraphEdges, uint32_t numSupportGraphEdges, bool keepCachedFlagIfEmpty)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
removePlatformMaxDepth(PlatformTag platform)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
serializeFractureToolState(PxFileBuf &stream, nvidia::ExplicitHierarchicalMesh::Embedding &embedding) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setBSPBuildParameters(float logAreaSigmaThreshold, uint32_t testSetSize, float splitWeight, float imbalanceWeight)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setBSPTolerances(float linearTolerance, float angularTolerance, float baseTolerance, float clipTolerance, float cleaningTolerance)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setChunkOverlapsCacheDepth(int32_t depth=-1)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setCoreMesh(const ExplicitRenderTriangle *mesh, uint32_t meshTriangleCount, const ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setCrumbleEmitterName(const char *)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setDestructibleInitParameters(const DestructibleInitParameters &)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setDestructibleParameters(const DestructibleParameters &)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setDustEmitterName(const char *)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setFracturePatternName(const char *)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setNeighborPadding(float neighborPadding)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setPlatformMaxDepth(PlatformTag platform, uint32_t maxDepth)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setRenderMeshAsset(RenderMeshAsset *)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setRootMesh(const ExplicitRenderTriangle *meshTriangles, uint32_t meshTriangleCount, const ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0, int32_t *parentIndices=NULL, uint32_t parentIndexCount=0)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setScatterMeshAssets(RenderMeshAsset **scatterMeshAssetArray, uint32_t scatterMeshAssetArraySize)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
trimCollisionGeometry(const uint32_t *partIndices, uint32_t partIndexCount, float maxTrimFraction=0.2f)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
visualizeVoronoiCells(nvidia::RenderDebugInterface &debugRender, const PxVec3 *sites, uint32_t siteCount, const uint32_t *cellColors, uint32_t cellColorCount, const PxBounds3 &bounds, uint32_t cellIndex=0xFFFFFFFF)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
voronoiSplitChunk(uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleAssetCookingDesc Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAssetCookingDesc
Public Member Functions | Public Attributes
nvidia::apex::DestructibleAssetCookingDesc Class Reference

#include <DestructibleAsset.h>

List of all members.

Public Member Functions

PX_INLINE | DestructibleAssetCookingDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE bool | isValid () const

Public Attributes

DestructibleChunkDesc * chunkDescs
uint32_t | chunkDescCount
DestructibleBehaviorGroupDesc defaultBehaviorGroupDesc
DestructibleBehaviorGroupDesc * behaviorGroupDescs
uint32_t | behaviorGroupDescCount
int8_t | RTFractureBehaviorGroup
DestructibleGeometryDesc * geometryDescs
uint32_t | geometryDescCount
nvidia::IntPair * | supportGraphEdges
uint32_t | supportGraphEdgeCount

Detailed Description

Destructible authoring structure.

Descriptor for the cookChunk() method of DestructibleAssetAuthoring

Constructor & Destructor Documentation

PX_INLINE nvidia::apex::DestructibleAssetCookingDesc::DestructibleAssetCookingDesc ( )

constructor sets to default.

Member Function Documentation

PX_INLINE bool nvidia::apex::DestructibleAssetCookingDesc::isValid ( ) const

Returns true iff an object can be created using this descriptor.

PX_INLINE void nvidia::apex::DestructibleAssetCookingDesc::setToDefault ( )

(re)sets the structure to the default.

Member Data Documentation

uint32_t nvidia::apex::DestructibleAssetCookingDesc::behaviorGroupDescCount

The size of the behaviorGroupDescs array. This must be positive.

DestructibleBehaviorGroupDesc* nvidia::apex::DestructibleAssetCookingDesc::behaviorGroupDescs

Beginning of array of descriptors, one for each behavior group.

uint32_t nvidia::apex::DestructibleAssetCookingDesc::chunkDescCount

The size of the chunkDescs array. This must be positive.

DestructibleChunkDesc* nvidia::apex::DestructibleAssetCookingDesc::chunkDescs

Beginning of array of descriptors, one for each chunk.

DestructibleBehaviorGroupDesc nvidia::apex::DestructibleAssetCookingDesc::defaultBehaviorGroupDesc

Default behavior group (corresponds to index of -1).

uint32_t nvidia::apex::DestructibleAssetCookingDesc::geometryDescCount

The size of the geometryDescs array. This must be positive.

DestructibleGeometryDesc* nvidia::apex::DestructibleAssetCookingDesc::geometryDescs

Beginning of array of descriptors, one for each mesh part.

int8_t nvidia::apex::DestructibleAssetCookingDesc::RTFractureBehaviorGroup

RT fracture behavior group

uint32_t nvidia::apex::DestructibleAssetCookingDesc::supportGraphEdgeCount

Number of index pairs in supportGraphEdges.

nvidia::IntPair* nvidia::apex::DestructibleAssetCookingDesc::supportGraphEdges

Index pairs that represent chunk connections in the support graph. The indices refer to the chunkDescs array. Only sibling chunks, i.e. chunks at equal depth may be connected.

The documentation for this class was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAssetCookingDesc
nvidia::apex::DestructibleAssetCookingDesc Member List
This is the complete list of members for nvidia::apex::DestructibleAssetCookingDesc, including all inherited members.
behaviorGroupDescCount | nvidia::apex::DestructibleAssetCookingDesc
behaviorGroupDescs | nvidia::apex::DestructibleAssetCookingDesc
chunkDescCount | nvidia::apex::DestructibleAssetCookingDesc
chunkDescs | nvidia::apex::DestructibleAssetCookingDesc
defaultBehaviorGroupDesc | nvidia::apex::DestructibleAssetCookingDesc
DestructibleAssetCookingDesc() | nvidia::apex::DestructibleAssetCookingDesc
geometryDescCount | nvidia::apex::DestructibleAssetCookingDesc
geometryDescs | nvidia::apex::DestructibleAssetCookingDesc
isValid() const | nvidia::apex::DestructibleAssetCookingDesc
RTFractureBehaviorGroup | nvidia::apex::DestructibleAssetCookingDesc
setToDefault() | nvidia::apex::DestructibleAssetCookingDesc
supportGraphEdgeCount | nvidia::apex::DestructibleAssetCookingDesc
supportGraphEdges | nvidia::apex::DestructibleAssetCookingDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleBehaviorGroupDesc Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleBehaviorGroupDesc
Public Member Functions | Public Attributes
nvidia::apex::DestructibleBehaviorGroupDesc Class Reference

#include <DestructibleAsset.h>

List of all members.

Public Member Functions

PX_INLINE | DestructibleBehaviorGroupDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE bool | isValid () const

Public Attributes

const char * | name
name
float | damageThreshold
damage threshold
float | damageToRadius
damage to radius
DamageSpreadFunction damageSpread
damage spread
DamageSpreadFunction damageColorSpread
damage color spread
PxVec4 | damageColorChange
damege color change
float | materialStrength
material strength
float | density
density
float | fadeOut
fade out
float | maxDepenetrationVelocity
maximal depenetration velocity
uint64_t | userData
user data

Detailed Description

Destructible authoring structure.

Descriptor to build one chunk in a fracture hierarchy.

Constructor & Destructor Documentation

PX_INLINE nvidia::apex::DestructibleBehaviorGroupDesc::DestructibleBehaviorGroupDesc ( )

constructor sets to default.

Member Function Documentation

PX_INLINE bool nvidia::apex::DestructibleBehaviorGroupDesc::isValid ( ) const

Returns true iff an object can be created using this descriptor.

PX_INLINE void nvidia::apex::DestructibleBehaviorGroupDesc::setToDefault ( )

(re)sets the structure to the default.

Member Data Documentation

PxVec4 nvidia::apex::DestructibleBehaviorGroupDesc::damageColorChange

damege color change

DamageSpreadFunction nvidia::apex::DestructibleBehaviorGroupDesc::damageColorSpread

damage color spread

DamageSpreadFunction nvidia::apex::DestructibleBehaviorGroupDesc::damageSpread

damage spread

float nvidia::apex::DestructibleBehaviorGroupDesc::damageThreshold

damage threshold

float nvidia::apex::DestructibleBehaviorGroupDesc::damageToRadius

damage to radius

float nvidia::apex::DestructibleBehaviorGroupDesc::density

density

float nvidia::apex::DestructibleBehaviorGroupDesc::fadeOut

fade out

float nvidia::apex::DestructibleBehaviorGroupDesc::materialStrength

material strength

float nvidia::apex::DestructibleBehaviorGroupDesc::maxDepenetrationVelocity

maximal depenetration velocity

const char* nvidia::apex::DestructibleBehaviorGroupDesc::name

name

Defines the chunk to be environmentally supported, if the appropriate DestructibleParametersFlag flags are set in DestructibleParameters.

uint64_t nvidia::apex::DestructibleBehaviorGroupDesc::userData

user data

The documentation for this class was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleBehaviorGroupDesc
nvidia::apex::DestructibleBehaviorGroupDesc Member List
This is the complete list of members for nvidia::apex::DestructibleBehaviorGroupDesc, including all inherited members.
damageColorChange | nvidia::apex::DestructibleBehaviorGroupDesc
damageColorSpread | nvidia::apex::DestructibleBehaviorGroupDesc
damageSpread | nvidia::apex::DestructibleBehaviorGroupDesc
damageThreshold | nvidia::apex::DestructibleBehaviorGroupDesc
damageToRadius | nvidia::apex::DestructibleBehaviorGroupDesc
density | nvidia::apex::DestructibleBehaviorGroupDesc
DestructibleBehaviorGroupDesc() | nvidia::apex::DestructibleBehaviorGroupDesc
fadeOut | nvidia::apex::DestructibleBehaviorGroupDesc
isValid() const | nvidia::apex::DestructibleBehaviorGroupDesc
materialStrength | nvidia::apex::DestructibleBehaviorGroupDesc
maxDepenetrationVelocity | nvidia::apex::DestructibleBehaviorGroupDesc
name | nvidia::apex::DestructibleBehaviorGroupDesc
setToDefault() | nvidia::apex::DestructibleBehaviorGroupDesc
userData | nvidia::apex::DestructibleBehaviorGroupDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleChunkDesc Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleChunkDesc
Public Member Functions | Public Attributes
nvidia::apex::DestructibleChunkDesc Class Reference

#include <DestructibleAsset.h>

List of all members.

Public Member Functions

PX_INLINE | DestructibleChunkDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE bool | isValid () const

Public Attributes

bool | isSupportChunk
bool | doNotFracture
bool | doNotDamage
bool | doNotCrumble
bool | runtimeFracture
bool | useInstancedRendering
PxVec3 | instancePositionOffset
PxVec2 | instanceUVOffset
uint16_t | meshIndex
int32_t | parentIndex
PxVec3 | surfaceNormal
int8_t | behaviorGroupIndex
uint32_t | scatterMeshCount
const uint8_t * | scatterMeshIndices
const PxMat44 * | scatterMeshTransforms

Detailed Description

Destructible authoring structure.

Descriptor to build one chunk in a fracture hierarchy.

Constructor & Destructor Documentation

PX_INLINE nvidia::apex::DestructibleChunkDesc::DestructibleChunkDesc ( )

constructor sets to default.

Member Function Documentation

PX_INLINE bool nvidia::apex::DestructibleChunkDesc::isValid ( ) const

Returns true iff an object can be created using this descriptor.

PX_INLINE void nvidia::apex::DestructibleChunkDesc::setToDefault ( )

(re)sets the structure to the default.

Member Data Documentation

int8_t nvidia::apex::DestructibleChunkDesc::behaviorGroupIndex

Referring to the behavior group used of this chunk, please check DestructibleAssetCookingDesc::behaviorGroupDescs for more detail.

bool nvidia::apex::DestructibleChunkDesc::doNotCrumble

Defines the chunk to be uncrumbleable. This means this chunk will not be broken down into fluid mesh particles no matter how much damage it takes. Note: this only applies to chunks with no children. For a chunk with children, then: 1) The chunk may be broken down into its children, and then its children may be crumbled, if the doNotCrumble flag is not set on them. 2) If the Destructible module's chunk depth offset LOD may be set such that this chunk effectively has no children. In this case, the doNotCrumble flag will apply to it.

bool nvidia::apex::DestructibleChunkDesc::doNotDamage

Defines the chunk to be undamageable. This means this chunk will not fracture, but its children might.

bool nvidia::apex::DestructibleChunkDesc::doNotFracture

Defines the chunk to be unfractureable. If this is true, then none of its children will be fractureable.

PxVec3 nvidia::apex::DestructibleChunkDesc::instancePositionOffset

Translation for this chunk mesh within the asset. Normally a chunk needs no translation, but if a chunk is instanced within the asset, then this translation is needed. Default = (0,0,0).

PxVec2 nvidia::apex::DestructibleChunkDesc::instanceUVOffset

UV translation for this chunk mesh within the asset. Normally a chunk needs no UV translation, but if a chunk is instanced within the asset, then this translation is usually needed. Default = (0,0).

bool nvidia::apex::DestructibleChunkDesc::isSupportChunk

Defines the chunk to be environmentally supported, if the appropriate DestructibleParametersFlag flags are set in DestructibleParameters.

uint16_t nvidia::apex::DestructibleChunkDesc::meshIndex

If useInstancedRendering = TRUE, this index is the instanced mesh index. If useInstancedRendering = FALSE, this index is the mesh part index for the skinned or statically rendered mesh. This must index a valid DestructibleGeometryDesc (see below). Default = 0xFFFF (invalid).

int32_t nvidia::apex::DestructibleChunkDesc::parentIndex

The parent index of this chunk. If the index is negative, this is a root chunk. Default = -1.

bool nvidia::apex::DestructibleChunkDesc::runtimeFracture

Defines the chunk to use run-time, dynamic fracturing. The chunk will use the fracture pattern provided by the asset to guide it's fracture. The resulting chunks will follow a similar process for subdivision.

uint32_t nvidia::apex::DestructibleChunkDesc::scatterMeshCount

The number of scatter mesh instances on this chunk. Default = 0.

const uint8_t* nvidia::apex::DestructibleChunkDesc::scatterMeshIndices

Array of indices corresponding the scatter mesh assets set using DestructibleAssetAuthoring::setScatterMeshAssets(). The array length must be at least scatterMeshCount. This pointer may be NULL if scatterMeshCount = 0. Default = NULL.

const PxMat44* nvidia::apex::DestructibleChunkDesc::scatterMeshTransforms

Array of chunk-relative transforms corresponding the scatter mesh assets set using DestructibleAssetAuthoring::setScatterMeshAssets(). The array length must be at least scatterMeshCount. This pointer may be NULL if scatterMeshCount = 0. Default = NULL.

PxVec3 nvidia::apex::DestructibleChunkDesc::surfaceNormal

A direction used to move the chunk out of the destructible, if an impact kick is applied.

bool nvidia::apex::DestructibleChunkDesc::useInstancedRendering

Whether or not to use instancing when rendering this chunk. If useInstancedRendering = TRUE, this chunk will share a draw call with all others that instance the mesh indexed by meshIndex. This may extend to other destructible actors created from this asset. If useInstancedRendering = FALSE, this chunk may share a draw call only with other chunks in this asset which have useInstancedRendering = FALSE. Default = FALSE.

The documentation for this class was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleChunkDesc
nvidia::apex::DestructibleChunkDesc Member List
This is the complete list of members for nvidia::apex::DestructibleChunkDesc, including all inherited members.
behaviorGroupIndex | nvidia::apex::DestructibleChunkDesc
DestructibleChunkDesc() | nvidia::apex::DestructibleChunkDesc
doNotCrumble | nvidia::apex::DestructibleChunkDesc
doNotDamage | nvidia::apex::DestructibleChunkDesc
doNotFracture | nvidia::apex::DestructibleChunkDesc
instancePositionOffset | nvidia::apex::DestructibleChunkDesc
instanceUVOffset | nvidia::apex::DestructibleChunkDesc
isSupportChunk | nvidia::apex::DestructibleChunkDesc
isValid() const | nvidia::apex::DestructibleChunkDesc
meshIndex | nvidia::apex::DestructibleChunkDesc
parentIndex | nvidia::apex::DestructibleChunkDesc
runtimeFracture | nvidia::apex::DestructibleChunkDesc
scatterMeshCount | nvidia::apex::DestructibleChunkDesc
scatterMeshIndices | nvidia::apex::DestructibleChunkDesc
scatterMeshTransforms | nvidia::apex::DestructibleChunkDesc
setToDefault() | nvidia::apex::DestructibleChunkDesc
surfaceNormal | nvidia::apex::DestructibleChunkDesc
useInstancedRendering | nvidia::apex::DestructibleChunkDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleGeometryDesc Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleGeometryDesc
Public Member Functions | Public Attributes
nvidia::apex::DestructibleGeometryDesc Class Reference

#include <DestructibleAsset.h>

List of all members.

Public Member Functions

PX_INLINE | DestructibleGeometryDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE bool | isValid () const

Public Attributes

const
nvidia::ExplicitHierarchicalMesh::ConvexHull ** 		convexHulls
uint32_t | convexHullCount
const CollisionVolumeDesc * | collisionVolumeDesc

Detailed Description

Destructible authoring structure.

Descriptor to build one chunk in a fracture hierarchy.

Constructor & Destructor Documentation

PX_INLINE nvidia::apex::DestructibleGeometryDesc::DestructibleGeometryDesc ( )

constructor sets to default.

Member Function Documentation

PX_INLINE bool nvidia::apex::DestructibleGeometryDesc::isValid ( ) const

Returns true iff an object can be created using this descriptor.

PX_INLINE void nvidia::apex::DestructibleGeometryDesc::setToDefault ( )

(re)sets the structure to the default.

Member Data Documentation

const CollisionVolumeDesc* nvidia::apex::DestructibleGeometryDesc::collisionVolumeDesc

If convexHullCount = 0, then collisionVolumeDesc must not be NULL. In this case convex hulls will automatically be created for this geometry. See CollisionVolumeDesc.

uint32_t nvidia::apex::DestructibleGeometryDesc::convexHullCount

The length of the convexHulls array. If this is positive, then convexHulls must point to a valid array of this size. If this is zero, then collisionVolumeDesc must not be NULL, and convex hulls will be automatically created for this geometry using collisionVolumeDesc.

const nvidia::ExplicitHierarchicalMesh::ConvexHull** nvidia::apex::DestructibleGeometryDesc::convexHulls

The convex hulls associated with this chunk. These may be obtained from ExplicitHierarchicalMesh::convexHulls() if authoring using an ExplicitHierarchicalMesh. The length of the array is given by convexHullCount.

The documentation for this class was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleGeometryDesc
nvidia::apex::DestructibleGeometryDesc Member List
This is the complete list of members for nvidia::apex::DestructibleGeometryDesc, including all inherited members.
collisionVolumeDesc | nvidia::apex::DestructibleGeometryDesc
convexHullCount | nvidia::apex::DestructibleGeometryDesc
convexHulls | nvidia::apex::DestructibleGeometryDesc
DestructibleGeometryDesc() | nvidia::apex::DestructibleGeometryDesc
isValid() const | nvidia::apex::DestructibleGeometryDesc
setToDefault() | nvidia::apex::DestructibleGeometryDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructiblePreview Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructiblePreview
Public Member Functions | Protected Member Functions
nvidia::apex::DestructiblePreview Class Reference

Destructible module's derivation AssetPreview. More...

#include <DestructiblePreview.h>

List of all members.

Public Member Functions

virtual const RenderMeshActor * | getRenderMeshActor () const =0
Returns render mesh actor.
virtual void | setExplodeView (uint32_t depth, float explode)=0
Sets the preview chunk depth and "explode" amount (pushes the chunks out by that relative distance).

Protected Member Functions

DestructiblePreview ()

Detailed Description

Destructible module's derivation AssetPreview.

Constructor & Destructor Documentation

nvidia::apex::DestructiblePreview::DestructiblePreview ( ) [inline, protected]

Member Function Documentation

virtual const RenderMeshActor* nvidia::apex::DestructiblePreview::getRenderMeshActor ( ) const [pure virtual]

Returns render mesh actor.

virtual void nvidia::apex::DestructiblePreview::setExplodeView | ( | uint32_t | depth,
 |  | float | explode
 | ) |  | [pure virtual]

Sets the preview chunk depth and "explode" amount (pushes the chunks out by that relative distance).

Parameters:
[in] | depth | Must be nonnegative. Internally the value will be clamped to the depth range in the asset.
[in] | explode | must be nonnegative.
The documentation for this class was generated from the following file:
  • DestructiblePreview.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructiblePreview
nvidia::apex::DestructiblePreview Member List
This is the complete list of members for nvidia::apex::DestructiblePreview, including all inherited members.
DestructiblePreview() | nvidia::apex::DestructiblePreview | [inline, protected]
getRenderMeshActor() const =0 | nvidia::apex::DestructiblePreview | [pure virtual]
setExplodeView(uint32_t depth, float explode)=0 | nvidia::apex::DestructiblePreview | [pure virtual]
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleRenderable Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRenderable
Public Member Functions | Protected Member Functions
nvidia::apex::DestructibleRenderable Class Reference

#include <DestructibleRenderable.h>

List of all members.

Public Member Functions

virtual RenderMeshActor * | getRenderMeshActor (DestructibleActorMeshType::Enum type=DestructibleActorMeshType::Skinned) const =0

Protected Member Functions

virtual | ~DestructibleRenderable ()

Detailed Description

Destructible renderable API. The destructible renderable contains rendering information for an DestructibleActor.

Constructor & Destructor Documentation

virtual nvidia::apex::DestructibleRenderable::~DestructibleRenderable ( ) [inline, protected, virtual]

Member Function Documentation

virtual RenderMeshActor* nvidia::apex::DestructibleRenderable::getRenderMeshActor ( DestructibleActorMeshType::Enum type = DestructibleActorMeshType::Skinned ) const [pure virtual]

Get the render mesh actor for the specified mesh type.

The documentation for this class was generated from the following file:
  • DestructibleRenderable.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRenderable
nvidia::apex::DestructibleRenderable Member List
This is the complete list of members for nvidia::apex::DestructibleRenderable, including all inherited members.
getRenderMeshActor(DestructibleActorMeshType::Enum type=DestructibleActorMeshType::Skinned) const =0 | nvidia::apex::DestructibleRenderable | [pure virtual]
~DestructibleRenderable() | nvidia::apex::DestructibleRenderable | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DisplacementMapVolume Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DisplacementMapVolume
Public Member Functions
nvidia::apex::DisplacementMapVolume Class Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

virtual void | getData (uint32_t &width, uint32_t &height, uint32_t &depth, uint32_t &size, unsigned char const **ppData) const =0
virtual | ~DisplacementMapVolume ()

Detailed Description

Interface to a "displacement map volume," used with tessellated fracturing. A displacement map volume captures how to displace a particular point in 3D space along the x, y and z axes. The data is stored as a 3D texture volume, with corresponding displacement coordinates acting as a look-up into this volume. X, Y and Z offsets correspond to R, G, and B color channels

Various approaches can be used to generate the 3D noise field, in this case Perlin noise is used, with appropriate settings specified by the FractureSliceDesc.

Constructor & Destructor Documentation

virtual nvidia::apex::DisplacementMapVolume::~DisplacementMapVolume ( ) [inline, virtual]

Member Function Documentation

virtual void nvidia::apex::DisplacementMapVolume::getData | ( | uint32_t & | width,
 |  | uint32_t & | height,
 |  | uint32_t & | depth,
 |  | uint32_t & | size,
 |  | unsigned char const ** | ppData
 | ) |  | const [pure virtual]

Fills the specified array and parameters with texture-compatible information.

The corresponding texture aligns with the displacement UVs generated as fracturing occurs when displacement maps are enabled, with RGB data corresponding to XYZ offsets, respectively.

The documentation for this class was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DisplacementMapVolume
nvidia::apex::DisplacementMapVolume Member List
This is the complete list of members for nvidia::apex::DisplacementMapVolume, including all inherited members.
getData(uint32_t &width, uint32_t &height, uint32_t &depth, uint32_t &size, unsigned char const **ppData) const =0 | nvidia::apex::DisplacementMapVolume | [pure virtual]
~DisplacementMapVolume() | nvidia::apex::DisplacementMapVolume | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::ExplicitHierarchicalMesh Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitHierarchicalMesh
Classes | Public Types | Public Member Functions | Protected Member Functions
nvidia::apex::ExplicitHierarchicalMesh Class Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Classes

class | ConvexHull
class | Embedding

Public Types

enum Enum {
VisualizeMeshBSPOutsideRegions = (1 << 0),
VisualizeMeshBSPInsideRegions = (1 << 1),
VisualizeMeshBSPSingleRegion = (1 << 8),
VisualizeSliceBSPOutsideRegions = (1 << 16),
VisualizeSliceBSPInsideRegions = (1 << 17),
VisualizeSliceBSPSingleRegion = (1 << 24),
VisualizeMeshBSPAllRegions = VisualizeMeshBSPOutsideRegions | VisualizeMeshBSPInsideRegions
}

Public Member Functions

virtual void | clear (bool keepRoot=false)=0
virtual int32_t | maxDepth () const =0
virtual uint32_t | partCount () const =0
virtual uint32_t | chunkCount () const =0
virtual int32_t * | parentIndex (uint32_t chunkIndex)=0
virtual uint64_t | chunkUniqueID (uint32_t chunkIndex)=0
virtual int32_t * | partIndex (uint32_t chunkIndex)=0
virtual PxVec3 * | instancedPositionOffset (uint32_t chunkIndex)=0
virtual PxVec2 * | instancedUVOffset (uint32_t chunkIndex)=0
virtual uint32_t | meshTriangleCount (uint32_t partIndex) const =0
virtual ExplicitRenderTriangle * | meshTriangles (uint32_t partIndex)=0
virtual PxBounds3 | meshBounds (uint32_t partIndex) const =0
virtual PxBounds3 | chunkBounds (uint32_t chunkIndex) const =0
virtual uint32_t * | chunkFlags (uint32_t chunkIndex) const =0
virtual void | buildCollisionGeometryForPart (uint32_t partIndex, const CollisionVolumeDesc &desc)=0
virtual void | buildCollisionGeometryForRootChunkParts (const CollisionDesc &desc, bool aggregateRootChunkParentCollision=true)=0
virtual void | reduceHulls (const CollisionDesc &desc, bool inflated)=0
virtual uint32_t | convexHullCount (uint32_t partIndex) const =0
virtual const ConvexHull ** | convexHulls (uint32_t partIndex) const =0
virtual PxVec3 * | surfaceNormal (uint32_t partIndex)=0
virtual const
DisplacementMapVolume & 		displacementMapVolume () const =0
virtual uint32_t | submeshCount () const =0
virtual ExplicitSubmeshData * | submeshData (uint32_t submeshIndex)=0
virtual uint32_t | addSubmesh (const ExplicitSubmeshData &submeshData)=0
virtual uint32_t | getMaterialFrameCount () const =0
virtual nvidia::MaterialFrame | getMaterialFrame (uint32_t index) const =0
virtual void | setMaterialFrame (uint32_t index, const nvidia::MaterialFrame &materialFrame)=0
virtual uint32_t | addMaterialFrame ()=0
virtual void | serialize (PxFileBuf &stream, Embedding &embedding) const =0
virtual void | deserialize (PxFileBuf &stream, Embedding &embedding)=0
virtual void | set (const ExplicitHierarchicalMesh &mesh)=0
virtual void | calculateMeshBSP (uint32_t randomSeed, IProgressListener *progressListener=NULL, const uint32_t *microgridSize=NULL, BSPOpenMode::Enum meshMode=BSPOpenMode::Automatic)=0
virtual void | replaceInteriorSubmeshes (uint32_t partIndex, uint32_t frameCount, uint32_t *frameIndices, uint32_t submeshIndex)=0
virtual void | visualize (RenderDebugInterface &debugRender, uint32_t flags, uint32_t index=0) const =0
virtual void | release ()=0

Protected Member Functions

ExplicitHierarchicalMesh ()
virtual | ~ExplicitHierarchicalMesh ()

Detailed Description

ExplicitHierarchicalMesh

An interface to a representation of a render mesh that is used for authoring.

The "hierarchical" nature of this mesh is represented by extra parent/child relations among the parts that will become the parts of an RenderMeshAsset.

Member Enumeration Documentation

enum nvidia::apex::ExplicitHierarchicalMesh::Enum

Used in the visualize method to determine what to draw.

Enumerator:
VisualizeMeshBSPOutsideRegions

Draws the convex hulls associated with the BSP regions marked "outside," if a BSP has been created for this object (see calculateMeshBSP()).

VisualizeMeshBSPInsideRegions

Draws the convex hulls associated with the BSP regions marked "inside," if a BSP has been created for this object (see calculateMeshBSP()).

VisualizeMeshBSPSingleRegion

Draws the convex hull associated with a single BSP regions, if a BSP has been created for this object (see calculateMeshBSP()). The region index must be passed into the visualize function if this flag is set.

VisualizeSliceBSPOutsideRegions

Currently unused

VisualizeSliceBSPInsideRegions

Currently unused

VisualizeSliceBSPSingleRegion

Currently unused

VisualizeMeshBSPAllRegions

Constructor & Destructor Documentation

nvidia::apex::ExplicitHierarchicalMesh::ExplicitHierarchicalMesh ( ) [inline, protected]

Constructor and destructor are not public Use createExplicitHierarchicalMesh() to instantiate an ExplicitHierarchicalMesh and ExplicitHierarchicalMesh::release() to destroy it.

virtual nvidia::apex::ExplicitHierarchicalMesh::~ExplicitHierarchicalMesh ( ) [inline, protected, virtual]

Member Function Documentation

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::addMaterialFrame ( ) [pure virtual]
See also:
ConvexHull::getMaterialFrameCount
virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::addSubmesh ( const ExplicitSubmeshData & submeshData ) [pure virtual]

Creates a submesh and adds it to the list of submeshes, and returns the index of the newly created submesh.

virtual void nvidia::apex::ExplicitHierarchicalMesh::buildCollisionGeometryForPart | ( | uint32_t | partIndex,
 |  | const CollisionVolumeDesc & | desc
 | ) |  | [pure virtual]

Build collision volumes for the part indexed by partIndex, using (See CollisionVolumeDesc.)

virtual void nvidia::apex::ExplicitHierarchicalMesh::buildCollisionGeometryForRootChunkParts | ( | const CollisionDesc & | desc,
 |  | bool | aggregateRootChunkParentCollision = true
 | ) |  | [pure virtual]

Build collision volumes for all parts referenced by chunks at the root depth.

If aggregateRootChunkParentCollision, then every chunk which is the parent of root chunks gets all of the collision hulls of its children. Otherwise, all root chunks have their collision volumes separately calculated.

virtual void nvidia::apex::ExplicitHierarchicalMesh::calculateMeshBSP | ( | uint32_t | randomSeed,
 |  | IProgressListener * | progressListener = NULL,
 |  | const uint32_t * | microgridSize = NULL,
 |  | BSPOpenMode::Enum | meshMode = BSPOpenMode::Automatic
 | ) |  | [pure virtual]

Creates an internal BSP representation of the mesh parts up to the root depth. This is used by authoring tools to perform CSG operations. If the user instantiates IProgressListener, they may pass it in to report progress of this operation. If microgridSize is not NULL, *microgridSize is used in the BSP calculation. Otherwise the default parameters are used. meshMode is used to determine if the mesh is open or closed. See NxMeshProcessingParameters::MeshMode

virtual PxBounds3 nvidia::apex::ExplicitHierarchicalMesh::chunkBounds ( uint32_t chunkIndex ) const [pure virtual]

The axis aligned bounding box of the triangles for the chunk index by chunkIndex.

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::chunkCount ( ) const [pure virtual]

The number of chunks in this mesh.

virtual uint32_t* nvidia::apex::ExplicitHierarchicalMesh::chunkFlags ( uint32_t chunkIndex ) const [pure virtual]

Flags describing attributes of the part indexed by partIndex. See DestructibleAsset::ChunkFlags

virtual uint64_t nvidia::apex::ExplicitHierarchicalMesh::chunkUniqueID ( uint32_t chunkIndex ) [pure virtual]

A runtime unique identifier for a chunk. During one execution of an application which contains the fracture tools, this chunk ID will be unique for the chunk.

virtual void nvidia::apex::ExplicitHierarchicalMesh::clear ( bool keepRoot = false ) [pure virtual]

"Resets" this object to its initial state, freeing all internal data. If keepRoot is true, then parts up to the root depth will not be cleared. (In this case, not all of the submesh data, etc. will be deleted.) The root depth is set when the ExplicitHierarchicalMesh is first created. Fracturing methods create pieces beyond the root depth.

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::convexHullCount ( uint32_t partIndex ) const [pure virtual]

The number of convex hulls for the given part.

virtual const ConvexHull** nvidia::apex::ExplicitHierarchicalMesh::convexHulls ( uint32_t partIndex ) const [pure virtual]

The convex hulls for the given part.

virtual void nvidia::apex::ExplicitHierarchicalMesh::deserialize | ( | PxFileBuf & | stream,
 |  | Embedding & | embedding
 | ) |  | [pure virtual]

Serialization. The user must instantiate Embedding in order to successfully serialize any embedded data.

virtual const DisplacementMapVolume& nvidia::apex::ExplicitHierarchicalMesh::displacementMapVolume ( ) const [pure virtual]

The displacement map volume for the mesh.

virtual nvidia::MaterialFrame nvidia::apex::ExplicitHierarchicalMesh::getMaterialFrame ( uint32_t index ) const [pure virtual]
See also:
ConvexHull::getMaterialFrameCount
virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::getMaterialFrameCount ( ) const [pure virtual]

If there are interior submeshes, then triangles belonging to those submesh will have materials applied to them with a using a coordinate frame. In the event that materials need to be re-applied (possibly at a different scale), it is convenient to store the material frames used. This function returns the array of material frames. The index extraDataIndex stored in each ExplicitRenderTriangle references this array.

virtual PxVec3* nvidia::apex::ExplicitHierarchicalMesh::instancedPositionOffset ( uint32_t chunkIndex ) [pure virtual]

If instanced, the part instance offset (translation).

virtual PxVec2* nvidia::apex::ExplicitHierarchicalMesh::instancedUVOffset ( uint32_t chunkIndex ) [pure virtual]

If instanced, the part instance offset (UV).

virtual int32_t nvidia::apex::ExplicitHierarchicalMesh::maxDepth ( ) const [pure virtual]

The maximum child depth in the hierarchy. Depth 0 is the base, depth 1 parts are children of depth 0, etc. If there are no parts, this function returns -1.

virtual PxBounds3 nvidia::apex::ExplicitHierarchicalMesh::meshBounds ( uint32_t partIndex ) const [pure virtual]

The axis aligned bounding box of the triangles for the part index by partIndex.

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::meshTriangleCount ( uint32_t partIndex ) const [pure virtual]

The number of triangles in the part indexed by partIndex. This includes all submeshes.

virtual ExplicitRenderTriangle* nvidia::apex::ExplicitHierarchicalMesh::meshTriangles ( uint32_t partIndex ) [pure virtual]

A pointer into the array of ExplicitRenderTriangles which form the mesh of the part indexed by partIndex.

virtual int32_t* nvidia::apex::ExplicitHierarchicalMesh::parentIndex ( uint32_t chunkIndex ) [pure virtual]

The parent index of the chunk indexed by chunkIndex. Depth 0 parts have no parents, and for those parts this function returns -1.

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::partCount ( ) const [pure virtual]

The number of parts in this mesh.

virtual int32_t* nvidia::apex::ExplicitHierarchicalMesh::partIndex ( uint32_t chunkIndex ) [pure virtual]

The geometric part index this chunk references

virtual void nvidia::apex::ExplicitHierarchicalMesh::reduceHulls | ( | const CollisionDesc & | desc,
 |  | bool | inflated
 | ) |  | [pure virtual]

Calls IConvexMesh::reduceHull on all part convex hulls. See IConvexMesh::reduceHull.

virtual void nvidia::apex::ExplicitHierarchicalMesh::release ( ) [pure virtual]

Releases all memory associated with this object and deletes itself.

virtual void nvidia::apex::ExplicitHierarchicalMesh::replaceInteriorSubmeshes | ( | uint32_t | partIndex,
 |  | uint32_t | frameCount,
 |  | uint32_t * | frameIndices,
 |  | uint32_t | submeshIndex
 | ) |  | [pure virtual]

Utility to replace the submesh on a set of interior triangles.

virtual void nvidia::apex::ExplicitHierarchicalMesh::serialize | ( | PxFileBuf & | stream,
 |  | Embedding & | embedding
 | ) |  | const [pure virtual]

Serialization. The user must instantiate Embedding in order to successfully serialize any embedded data.

virtual void nvidia::apex::ExplicitHierarchicalMesh::set ( const ExplicitHierarchicalMesh & mesh ) [pure virtual]

Copies the input mesh in to this object.

virtual void nvidia::apex::ExplicitHierarchicalMesh::setMaterialFrame | ( | uint32_t | index,
 |  | const nvidia::MaterialFrame & | materialFrame
 | ) |  | [pure virtual]
See also:
ConvexHull::getMaterialFrameCount
virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::submeshCount ( ) const [pure virtual]

The number of submeshes. The explicit mesh representation is just a list of ExplicitRenderTriangles for each part, and each ExplicitRenderTriangle has a submesh index. These indices will lie in a contiguous range from 0 to submeshCount()-1.

virtual ExplicitSubmeshData* nvidia::apex::ExplicitHierarchicalMesh::submeshData ( uint32_t submeshIndex ) [pure virtual]

The submeshData indexed by submeshIndex. See ExplicitSubmeshData.

virtual PxVec3* nvidia::apex::ExplicitHierarchicalMesh::surfaceNormal ( uint32_t partIndex ) [pure virtual]

The outward surface normal associated with the chunk mesh geometry.

virtual void nvidia::apex::ExplicitHierarchicalMesh::visualize | ( | RenderDebugInterface & | debugRender,
 |  | uint32_t | flags,
 |  | uint32_t | index = 0
 | ) |  | const [pure virtual]

Draws various components of this object to the debugRenderer, as defined by the flags (see the visualization Enum above). Some of the flags require an index be passed in as well.

The documentation for this class was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitHierarchicalMesh
nvidia::apex::ExplicitHierarchicalMesh Member List
This is the complete list of members for nvidia::apex::ExplicitHierarchicalMesh, including all inherited members.
addMaterialFrame()=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
addSubmesh(const ExplicitSubmeshData &submeshData)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
buildCollisionGeometryForPart(uint32_t partIndex, const CollisionVolumeDesc &desc)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
buildCollisionGeometryForRootChunkParts(const CollisionDesc &desc, bool aggregateRootChunkParentCollision=true)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
calculateMeshBSP(uint32_t randomSeed, IProgressListener *progressListener=NULL, const uint32_t *microgridSize=NULL, BSPOpenMode::Enum meshMode=BSPOpenMode::Automatic)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
chunkBounds(uint32_t chunkIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
chunkCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
chunkFlags(uint32_t chunkIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
chunkUniqueID(uint32_t chunkIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
clear(bool keepRoot=false)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
convexHullCount(uint32_t partIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
convexHulls(uint32_t partIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
deserialize(PxFileBuf &stream, Embedding &embedding)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
displacementMapVolume() const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
Enum enum name | nvidia::apex::ExplicitHierarchicalMesh |
ExplicitHierarchicalMesh() | nvidia::apex::ExplicitHierarchicalMesh | [inline, protected]
getMaterialFrame(uint32_t index) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
getMaterialFrameCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
instancedPositionOffset(uint32_t chunkIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
instancedUVOffset(uint32_t chunkIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
maxDepth() const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
meshBounds(uint32_t partIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
meshTriangleCount(uint32_t partIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
meshTriangles(uint32_t partIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
parentIndex(uint32_t chunkIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
partCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
partIndex(uint32_t chunkIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
reduceHulls(const CollisionDesc &desc, bool inflated)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
release()=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
replaceInteriorSubmeshes(uint32_t partIndex, uint32_t frameCount, uint32_t *frameIndices, uint32_t submeshIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
serialize(PxFileBuf &stream, Embedding &embedding) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
set(const ExplicitHierarchicalMesh &mesh)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
setMaterialFrame(uint32_t index, const nvidia::MaterialFrame &materialFrame)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
submeshCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
submeshData(uint32_t submeshIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
surfaceNormal(uint32_t partIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
visualize(RenderDebugInterface &debugRender, uint32_t flags, uint32_t index=0) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
VisualizeMeshBSPAllRegions enum value | nvidia::apex::ExplicitHierarchicalMesh |
VisualizeMeshBSPInsideRegions enum value | nvidia::apex::ExplicitHierarchicalMesh |
VisualizeMeshBSPOutsideRegions enum value | nvidia::apex::ExplicitHierarchicalMesh |
VisualizeMeshBSPSingleRegion enum value | nvidia::apex::ExplicitHierarchicalMesh |
VisualizeSliceBSPInsideRegions enum value | nvidia::apex::ExplicitHierarchicalMesh |
VisualizeSliceBSPOutsideRegions enum value | nvidia::apex::ExplicitHierarchicalMesh |
VisualizeSliceBSPSingleRegion enum value | nvidia::apex::ExplicitHierarchicalMesh |
~ExplicitHierarchicalMesh() | nvidia::apex::ExplicitHierarchicalMesh | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::ExplicitHierarchicalMesh::ConvexHull Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitHierarchicalMesh
  • ConvexHull
Public Member Functions | Protected Member Functions
nvidia::apex::ExplicitHierarchicalMesh::ConvexHull Class Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

virtual void | buildFromPoints (const void *points, uint32_t numPoints, uint32_t pointStrideBytes)=0
virtual const PxBounds3 & | getBounds () const =0
virtual float | getVolume () const =0
virtual uint32_t | getVertexCount () const =0
virtual PxVec3 | getVertex (uint32_t vertexIndex) const =0
virtual uint32_t | getEdgeCount () const =0
virtual PxVec3 | getEdgeEndpoint (uint32_t edgeIndex, uint32_t whichEndpoint) const =0
virtual uint32_t | getPlaneCount () const =0
virtual PxPlane | getPlane (uint32_t planeIndex) const =0
virtual bool | rayCast (float &in, float &out, const PxVec3 &orig, const PxVec3 &dir, const PxTransform &localToWorldRT, const PxVec3 &scale, PxVec3 *normal=NULL) const =0
virtual bool | reduceHull (uint32_t maxVertexCount, uint32_t maxEdgeCount, uint32_t maxFaceCount, bool inflated)=0
virtual void | release ()=0

Protected Member Functions

ConvexHull ()
virtual | ~ConvexHull ()

Detailed Description

Used to access the collision data for each mesh part

Constructor & Destructor Documentation

nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::ConvexHull ( ) [inline, protected]
virtual nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::~ConvexHull ( ) [inline, protected, virtual]

Member Function Documentation

virtual void nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::buildFromPoints | ( | const void * | points,
 |  | uint32_t | numPoints,
 |  | uint32_t | pointStrideBytes
 | ) |  | [pure virtual]

Builds the convex hull of the points given.

virtual const PxBounds3& nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getBounds ( ) const [pure virtual]

The hull's axis aligned bounding box.

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getEdgeCount ( ) const [pure virtual]

This is the number of edges in the convex hull.

virtual PxVec3 nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getEdgeEndpoint | ( | uint32_t | edgeIndex,
 |  | uint32_t | whichEndpoint
 | ) |  | const [pure virtual]

This is an edge endpoint indexed by edgeIndex, which must in the range [0, getEdgeCount()-1], and whichEndpoint, which must be 0 or 1.

virtual PxPlane nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getPlane ( uint32_t planeIndex ) const [pure virtual]

This is the plane indexed by planeIndex, which must in the range [0, getPlaneCount()-1].

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getPlaneCount ( ) const [pure virtual]

This is the number of planes which bound the convex hull.

virtual PxVec3 nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getVertex ( uint32_t vertexIndex ) const [pure virtual]

This is the vertex indexed by vertexIndex, which must in the range [0, getVertexCount()-1].

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getVertexCount ( ) const [pure virtual]

This is the number of vertices in the convex hull.

virtual float nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getVolume ( ) const [pure virtual]

The hull's volume.

virtual bool nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::rayCast | ( | float & | in,
 |  | float & | out,
 |  | const PxVec3 & | orig,
 |  | const PxVec3 & | dir,
 |  | const PxTransform & | localToWorldRT,
 |  | const PxVec3 & | scale,
 |  | PxVec3 * | normal = NULL
 | ) |  | const [pure virtual]

Perform a ray cast against the convex hull.

Parameters:
in | this MUST be set to the minimum 'time' that you wish to have reported for intersection. you may consider this an origin offset for the ray. On exit, if the hull is intersected, this value will contain the time of intersection, or its original value, which ever is larger.
out | this MUST be set to the maximum 'time' that you wish to have reported for intersection. you may consider this the endpoint of a line segment intersection. On exit, if the hull is intersected, this value will contain the time that the ray exits the hull, or its original value, which ever is smaller.
orig | describe the ray to intersect with the convex hull.
dir | describe the ray to intersect with the convex hull.
localToWorldRT | the rotation applied to the convex hull.
scale | the scale applied to the convex hull.
normal | if not NULL, *normal will contain the surface normal of the convex hull at the point of intersection (at the 'in' time). If the point on the ray at the 'in' time lies within the volume of the convex hull, then *normal will be set to (0,0,0).
Returns:
returns true if the line segment described by the user's supplied 'in' and 'out' parameters along the ray intersects the convex hull, false otherwise.
virtual bool nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::reduceHull | ( | uint32_t | maxVertexCount,
 |  | uint32_t | maxEdgeCount,
 |  | uint32_t | maxFaceCount,
 |  | bool | inflated
 | ) |  | [pure virtual]

Removes vertices from the hull until the bounds given in the function's parameters are met. If inflated = true, then the maximum counts given are compared with the cooked hull, which may have higher counts due to beveling.

Note:
a value of zero indicates no limit, effectively infinite.
Returns:
true if successful, i.e. the limits were met. False otherwise.
virtual void nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::release ( ) [pure virtual]

Releases all memory associated with this object and deletes itself.

The documentation for this class was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitHierarchicalMesh
  • ConvexHull
nvidia::apex::ExplicitHierarchicalMesh::ConvexHull Member List
This is the complete list of members for nvidia::apex::ExplicitHierarchicalMesh::ConvexHull, including all inherited members.
buildFromPoints(const void *points, uint32_t numPoints, uint32_t pointStrideBytes)=0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
ConvexHull() | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [inline, protected]
getBounds() const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getEdgeCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getEdgeEndpoint(uint32_t edgeIndex, uint32_t whichEndpoint) const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getPlane(uint32_t planeIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getPlaneCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getVertex(uint32_t vertexIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getVertexCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getVolume() const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
rayCast(float &in, float &out, const PxVec3 &orig, const PxVec3 &dir, const PxTransform &localToWorldRT, const PxVec3 &scale, PxVec3 *normal=NULL) const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
reduceHull(uint32_t maxVertexCount, uint32_t maxEdgeCount, uint32_t maxFaceCount, bool inflated)=0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
release()=0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
~ConvexHull() | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::ExplicitHierarchicalMesh::Embedding Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitHierarchicalMesh
  • Embedding
Public Types | Public Member Functions
nvidia::apex::ExplicitHierarchicalMesh::Embedding Class Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Types

enum | DataType { MaterialLibrary }

Public Member Functions

virtual void | serialize (PxFileBuf &stream, Embedding::DataType type) const =0
virtual void | deserialize (PxFileBuf &stream, Embedding::DataType type, uint32_t version)=0

Detailed Description

Used in the serialize and deserialize methods, to embed extra data. The user must implement this class to serialize and deserialize the enumerated data type given.

Member Enumeration Documentation

enum nvidia::apex::ExplicitHierarchicalMesh::Embedding::DataType

Enum of data types

Enumerator:
MaterialLibrary

Member Function Documentation

virtual void nvidia::apex::ExplicitHierarchicalMesh::Embedding::deserialize | ( | PxFileBuf & | stream,
 |  | Embedding::DataType | type,
 |  | uint32_t | version
 | ) |  | [pure virtual]

Deserialize the enumerated data type

virtual void nvidia::apex::ExplicitHierarchicalMesh::Embedding::serialize | ( | PxFileBuf & | stream,
 |  | Embedding::DataType | type
 | ) |  | const [pure virtual]

Serialize the enumerated data type

The documentation for this class was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitHierarchicalMesh
  • Embedding
nvidia::apex::ExplicitHierarchicalMesh::Embedding Member List
This is the complete list of members for nvidia::apex::ExplicitHierarchicalMesh::Embedding, including all inherited members.
DataType enum name | nvidia::apex::ExplicitHierarchicalMesh::Embedding |
deserialize(PxFileBuf &stream, Embedding::DataType type, uint32_t version)=0 | nvidia::apex::ExplicitHierarchicalMesh::Embedding | [pure virtual]
MaterialLibrary enum value | nvidia::apex::ExplicitHierarchicalMesh::Embedding |
serialize(PxFileBuf &stream, Embedding::DataType type) const =0 | nvidia::apex::ExplicitHierarchicalMesh::Embedding | [pure virtual]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::FractureToolsAPI Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureToolsAPI
Public Member Functions
nvidia::apex::FractureToolsAPI Class Reference

#include <FractureToolsAPI.h>

List of all members.

Public Member Functions

virtual FractureTools::CutoutSet * | createCutoutSet ()=0
virtual void | buildCutoutSet (FractureTools::CutoutSet &cutoutSet, const uint8_t *pixelBuffer, uint32_t bufferWidth, uint32_t bufferHeight, float snapThreshold, bool periodic)=0
virtual bool | calculateCutoutUVMapping (const nvidia::ExplicitRenderTriangle &triangle, PxMat33 &theMapping)=0
virtual bool | calculateCutoutUVMapping (nvidia::ExplicitHierarchicalMesh &hMesh, const PxVec3 &targetDirection, PxMat33 &theMapping)=0
virtual bool | createVoronoiSplitMesh (nvidia::ExplicitHierarchicalMesh &hMesh, nvidia::ExplicitHierarchicalMesh &iHMeshCore, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, uint32_t randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual uint32_t | createVoronoiSitesInsideMesh (nvidia::ExplicitHierarchicalMesh &hMesh, PxVec3 *siteBuffer, uint32_t *siteChunkIndices, uint32_t siteCount, uint32_t *randomSeed, uint32_t *microgridSize, BSPOpenMode::Enum meshMode, nvidia::IProgressListener &progressListener, uint32_t chunkIndex=0xFFFFFFFF)=0
virtual uint32_t | createScatterMeshSites (uint8_t *meshIndices, PxMat44 *relativeTransforms, uint32_t *chunkMeshStarts, uint32_t scatterMeshInstancesBufferSize, nvidia::ExplicitHierarchicalMesh &hMesh, uint32_t targetChunkCount, const uint16_t *targetChunkIndices, uint32_t *randomSeed, uint32_t scatterMeshAssetCount, nvidia::RenderMeshAsset **scatterMeshAssets, const uint32_t *minCount, const uint32_t *maxCount, const float *minScales, const float *maxScales, const float *maxAngles)=0
virtual void | visualizeVoronoiCells (nvidia::RenderDebugInterface &debugRender, const PxVec3 *sites, uint32_t siteCount, const uint32_t *cellColors, uint32_t cellColorCount, const PxBounds3 &bounds, uint32_t cellIndex=0xFFFFFFFF)=0
virtual bool | buildExplicitHierarchicalMesh (nvidia::ExplicitHierarchicalMesh &iHMesh, const nvidia::ExplicitRenderTriangle *meshTriangles, uint32_t meshTriangleCount, const nvidia::ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0, int32_t *parentIndices=NULL, uint32_t parentIndexCount=0)=0
virtual void | setBSPTolerances (float linearTolerance, float angularTolerance, float baseTolerance, float clipTolerance, float cleaningTolerance)=0
virtual void | setBSPBuildParameters (float logAreaSigmaThreshold, uint32_t testSetSize, float splitWeight, float imbalanceWeight)=0
virtual bool | buildExplicitHierarchicalMeshFromRenderMeshAsset (nvidia::ExplicitHierarchicalMesh &iHMesh, const nvidia::RenderMeshAsset &renderMeshAsset, uint32_t maxRootDepth=UINT32_MAX)=0
virtual bool | buildExplicitHierarchicalMeshFromDestructibleAsset (nvidia::ExplicitHierarchicalMesh &iHMesh, const nvidia::DestructibleAsset &destructibleAsset, uint32_t maxRootDepth=UINT32_MAX)=0
virtual bool | createHierarchicallySplitMesh (nvidia::ExplicitHierarchicalMesh &hMesh, nvidia::ExplicitHierarchicalMesh &iHMeshCore, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, uint32_t randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual bool | createChippedMesh (nvidia::ExplicitHierarchicalMesh &hMesh, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureCutoutDesc &desc, const FractureTools::CutoutSet &iCutoutSet, const FractureTools::FractureSliceDesc &sliceDesc, const FractureTools::FractureVoronoiDesc &voronoiDesc, const CollisionDesc &collisionDesc, uint32_t randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual bool | hierarchicallySplitChunk (nvidia::ExplicitHierarchicalMesh &hMesh, uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual bool | voronoiSplitChunk (nvidia::ExplicitHierarchicalMesh &hMesh, uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual bool | buildSliceMesh (nvidia::IntersectMesh &intersectMesh, nvidia::ExplicitHierarchicalMesh &referenceMesh, const PxPlane &slicePlane, const FractureTools::NoiseParameters &noiseParameters, uint32_t randomSeed)=0
virtual
nvidia::ExplicitHierarchicalMesh * 		createExplicitHierarchicalMesh ()=0
virtual
nvidia::ExplicitHierarchicalMesh::ConvexHull * 		createExplicitHierarchicalMeshConvexHull ()=0

Detailed Description

Fracture tools API

Member Function Documentation

virtual void nvidia::apex::FractureToolsAPI::buildCutoutSet | ( | FractureTools::CutoutSet & | cutoutSet,
 |  | const uint8_t * | pixelBuffer,
 |  | uint32_t | bufferWidth,
 |  | uint32_t | bufferHeight,
 |  | float | snapThreshold,
 |  | bool | periodic
 | ) |  | [pure virtual]

Builds a cutout set (which must have been initially created by createCutoutSet()). Uses a bitmap described by pixelBuffer, bufferWidth, and bufferHeight. Each pixel is represented by one byte in the buffer.

Parameters:
cutoutSet | the CutoutSet to build
pixelBuffer | pointer to be beginning of the pixel buffer
bufferWidth | the width of the buffer in pixels
bufferHeight | the height of the buffer in pixels
snapThreshold | the pixel distance at which neighboring cutout vertices and segments may be fudged into alignment.
periodic | whether or not to use periodic boundary conditions when creating cutouts from the map
virtual bool nvidia::apex::FractureToolsAPI::buildExplicitHierarchicalMesh | ( | nvidia::ExplicitHierarchicalMesh & | iHMesh,
 |  | const nvidia::ExplicitRenderTriangle * | meshTriangles,
 |  | uint32_t | meshTriangleCount,
 |  | const nvidia::ExplicitSubmeshData * | submeshData,
 |  | uint32_t | submeshCount,
 |  | uint32_t * | meshPartition = NULL,
 |  | uint32_t | meshPartitionCount = 0,
 |  | int32_t * | parentIndices = NULL,
 |  | uint32_t | parentIndexCount = 0
 | ) |  | [pure virtual]

Builds a new ExplicitHierarchicalMesh from an array of triangles.

Parameters:
iHMesh | the ExplicitHierarchicalMesh to build
meshTriangles | pointer to array of ExplicitRenderTriangles which make up the mesh
meshTriangleCount | the size of the meshTriangles array
submeshData | pointer to array of ExplicitSubmeshData, describing the submeshes
submeshCount | the size of the submeshData array
meshPartition | if not NULL, an array of size meshPartitionCount, giving the end elements of contiguous subsets of meshTriangles. If meshPartition is NULL, one partition is assumed. When there is one partition, these triangles become the level 0 part. When there is more than one partition, these triangles become level 1 parts, the behavior is determined by firstPartitionIsDepthZero (see below).
meshPartitionCount | if meshPartition is not NULL, this is the size of the meshPartition array.
parentIndices | if not NULL, the parent indices for each chunk (corresponding to a partition in the mesh partition).
parentIndexCount | the size of the parentIndices array. This does not need to match meshPartitionCount. If a mesh partition has an index beyond the end of parentIndices, then the parentIndex is considered to be 0. Therefore, if parentIndexCount = 0, all parents are 0 and so all chunks created will be depth 1. This will cause a depth 0 chunk to be created that is the aggregate of the depth 1 chunks. If parentIndexCount > 0, then the depth-0 chunk must have a parentIndex of -1. To reproduce the effect of the old parameter 'firstPartitionIsDepthZero' = true, set parentIndices to the address of a int32_t containing the value -1, and set parentIndexCount = 1. To reproduce the effect of the old parameter 'firstPartitionIsDepthZero' = false, set parentIndexCount = 0. Note: if parent indices are given, the first one must be -1, and *only* that index may be negative. That is, there may be only one depth-0 mesh and it must be the first mesh.
virtual bool nvidia::apex::FractureToolsAPI::buildExplicitHierarchicalMeshFromDestructibleAsset | ( | nvidia::ExplicitHierarchicalMesh & | iHMesh,
 |  | const nvidia::DestructibleAsset & | destructibleAsset,
 |  | uint32_t | maxRootDepth = UINT32_MAX
 | ) |  | [pure virtual]

Builds the root ExplicitHierarchicalMesh from an DestructibleAsset. Since an DestructibleAsset contains hierarchy information, the explicit mesh formed will have this hierarchy structure.

Parameters:
iHMesh | the ExplicitHierarchicalMesh to build
destructibleAsset | input Destructible asset
maxRootDepth | cap the root depth at this value. Re-fracturing of the mesh will occur at this depth. Default = UINT32_MAX
virtual bool nvidia::apex::FractureToolsAPI::buildExplicitHierarchicalMeshFromRenderMeshAsset | ( | nvidia::ExplicitHierarchicalMesh & | iHMesh,
 |  | const nvidia::RenderMeshAsset & | renderMeshAsset,
 |  | uint32_t | maxRootDepth = UINT32_MAX
 | ) |  | [pure virtual]

Builds the root ExplicitHierarchicalMesh from an RenderMeshAsset. Since an DestructibleAsset contains no hierarchy information, the input mesh must have only one part.

Parameters:
iHMesh | the ExplicitHierarchicalMesh to build
renderMeshAsset | input RenderMesh asset
maxRootDepth | cap the root depth at this value. Re-fracturing of the mesh will occur at this depth. Default = UINT32_MAX
virtual bool nvidia::apex::FractureToolsAPI::buildSliceMesh | ( | nvidia::IntersectMesh & | intersectMesh,
 |  | nvidia::ExplicitHierarchicalMesh & | referenceMesh,
 |  | const PxPlane & | slicePlane,
 |  | const FractureTools::NoiseParameters & | noiseParameters,
 |  | uint32_t | randomSeed
 | ) |  | [pure virtual]

Builds a mesh used for slice fracturing, given the noise parameters and random seed. This function is mostly intended for visualization - to give the user a "typical" slice surface used for fracturing.

virtual bool nvidia::apex::FractureToolsAPI::calculateCutoutUVMapping | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | const PxVec3 & | targetDirection,
 |  | PxMat33 & | theMapping
 | ) |  | [pure virtual]

Uses the passed-in target direction to find the best triangle in the root mesh with normal near the given targetDirection. If triangles exist with normals within one degree of the given target direction, then one with the greatest area of such triangles is used. Otherwise, the triangle with normal closest to the given target direction is used. The resulting triangle is used to calculate a UV mapping as in the function calculateCutoutUVMapping (above).

The assumption is that there exists a single mapping for all triangles on a specified face, for this feature to be useful.

Parameters:
hMesh | the explicit mesh with well rectangle-shaped faces
targetDirection | the target face's normal
theMapping | resulted mapping, composed by an affine transformation and a rotation
virtual bool nvidia::apex::FractureToolsAPI::calculateCutoutUVMapping | ( | const nvidia::ExplicitRenderTriangle & | triangle,
 |  | PxMat33 & | theMapping
 | ) |  | [pure virtual]

Calculate the mapping between a cutout fracture map and a given triangle. The result is a 3 by 3 matrix M composed by an affine transformation and a rotation, we can get the 3-D projection for a texture coordinate pair (u,v) with such a formula: (x,y,z) = M*PxVec3(u,v,1)

Parameters:
triangle | the target face's normal
theMapping | resulted mapping, composed by an affine transformation and a rotation
virtual bool nvidia::apex::FractureToolsAPI::createChippedMesh | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureCutoutDesc & | desc,
 |  | const FractureTools::CutoutSet & | iCutoutSet,
 |  | const FractureTools::FractureSliceDesc & | sliceDesc,
 |  | const FractureTools::FractureVoronoiDesc & | voronoiDesc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t | randomSeed,
 |  | nvidia::IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Chips the mesh in chunk[0], forming a hierarchy of fractured meshes in chunks[1...]

Parameters:
hMesh | the mesh to split
meshProcessingParams | describes generic mesh processing directives
desc | describes the slicing surfaces (see FractureCutoutDesc)
iCutoutSet | the cutout set to use for fracturing (see CutoutSet)
sliceDesc | used if desc.chunkFracturingMethod = SliceFractureCutoutChunks
voronoiDesc | used if desc.chunkFracturingMethod = VoronoiFractureCutoutChunks
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | seed for the random number generator, to ensure reproducibility.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual FractureTools::CutoutSet* nvidia::apex::FractureToolsAPI::createCutoutSet ( ) [pure virtual]

Instantiates a blank CutoutSet

virtual nvidia::ExplicitHierarchicalMesh* nvidia::apex::FractureToolsAPI::createExplicitHierarchicalMesh ( ) [pure virtual]

Instantiates an ExplicitHierarchicalMesh

virtual nvidia::ExplicitHierarchicalMesh::ConvexHull* nvidia::apex::FractureToolsAPI::createExplicitHierarchicalMeshConvexHull ( ) [pure virtual]

Instantiates an ExplicitHierarchicalMesh::ConvexHull

virtual bool nvidia::apex::FractureToolsAPI::createHierarchicallySplitMesh | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | nvidia::ExplicitHierarchicalMesh & | iHMeshCore,
 |  | bool | exportCoreMesh,
 |  | int32_t | coreMeshImprintSubmeshIndex,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureSliceDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t | randomSeed,
 |  | nvidia::IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the mesh in chunk[0], forming a hierarchy of fractured meshes in chunks[1...]

Parameters:
hMesh | the mesh to split
iHMeshCore | if this mesh is not empty, chunk 0 will be used as an indestructible "core" of the fractured mesh. That is, it will be subtracted from hMesh, and placed at level 1 of the hierarchy. The remainder of hMesh will be split as usual, creating chunks at level 1 (and possibly deeper).
exportCoreMesh | if true, a core mesh chunk will be created from iHMeshCore
coreMeshImprintSubmeshIndex | if this is < 0, use the core mesh materials (was applyCoreMeshMaterialToNeighborChunks). Otherwise, use the given submesh
meshProcessingParams | describes generic mesh processing directives
desc | describes the slicing surfaces (see FractureSliceDesc)
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | seed for the random number generator, to ensure reproducibility.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual uint32_t nvidia::apex::FractureToolsAPI::createScatterMeshSites | ( | uint8_t * | meshIndices,
 |  | PxMat44 * | relativeTransforms,
 |  | uint32_t * | chunkMeshStarts,
 |  | uint32_t | scatterMeshInstancesBufferSize,
 |  | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | uint32_t | targetChunkCount,
 |  | const uint16_t * | targetChunkIndices,
 |  | uint32_t * | randomSeed,
 |  | uint32_t | scatterMeshAssetCount,
 |  | nvidia::RenderMeshAsset ** | scatterMeshAssets,
 |  | const uint32_t * | minCount,
 |  | const uint32_t * | maxCount,
 |  | const float * | minScales,
 |  | const float * | maxScales,
 |  | const float * | maxAngles
 | ) |  | [pure virtual]

Creates scatter mesh sites randomly distributed on the mesh.

Parameters:
meshIndices | user-allocated array of size scatterMeshInstancesBufferSize which will be filled in by this function, giving the scatter mesh index used
relativeTransforms | user-allocated array of size scatterMeshInstancesBufferSize which will be filled in by this function, giving the chunk-relative transform for each chunk instance
chunkMeshStarts | user-allocated array which will be filled in with offsets into the meshIndices and relativeTransforms array. For a chunk indexed by i, the corresponding range [chunkMeshStart[i], chunkMeshStart[i+1]-1] in meshIndices and relativeTransforms is used. NOTE*: chunkMeshStart array must be of at least size N+1, where N is the number of chunks in the base explicit hierarchical mesh.
scatterMeshInstancesBufferSize | the size of meshIndices and relativeTransforms array.
scatterMeshInstancesBufferSize | the size of meshIndices and relativeTransforms array.
hMesh | the mesh in which to distribute sites
targetChunkCount | how many chunks are in the array targetChunkIndices
targetChunkIndices | an array of chunk indices which are candidates for scatter meshes. The elements in the array chunkIndices will come from this array
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
scatterMeshAssetCount | the number of different scatter meshes (not instances). Should not exceed 255. If scatterMeshAssetCount > 255, only the first 255 will be used.
scatterMeshAssets | an array of size scatterMeshAssetCount, of the render mesh assets which will be used for the scatter meshes
minCount | an array of size scatterMeshAssetCount, giving the minimum number of instances to place for each mesh
maxCount | an array of size scatterMeshAssetCount, giving the maximum number of instances to place for each mesh
minScales | an array of size scatterMeshAssetCount, giving the minimum scale to apply to each scatter mesh
maxScales | an array of size scatterMeshAssetCount, giving the maximum scale to apply to each scatter mesh
maxAngles | an array of size scatterMeshAssetCount, giving a maximum deviation angle (in degrees) from the surface normal to apply to each scatter mesh

return value the number of instances placed in indices and relativeTransforms (will not exceed scatterMeshInstancesBufferSize)

virtual uint32_t nvidia::apex::FractureToolsAPI::createVoronoiSitesInsideMesh | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | PxVec3 * | siteBuffer,
 |  | uint32_t * | siteChunkIndices,
 |  | uint32_t | siteCount,
 |  | uint32_t * | randomSeed,
 |  | uint32_t * | microgridSize,
 |  | BSPOpenMode::Enum | meshMode,
 |  | nvidia::IProgressListener & | progressListener,
 |  | uint32_t | chunkIndex = 0xFFFFFFFF
 | ) |  | [pure virtual]

Generates a set of uniformly distributed points in the interior of the root mesh.

Parameters:
hMesh | the mesh in which to distribute sites
siteBuffer | an array of PxVec3, at least the size of siteCount
siteChunkIndices | if not NULL, then must be at least the size of siteCount. siteCount indices will be written to this buffer, associating each site with a chunk that contains it.
siteCount | the number of points to write into siteBuffer
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
microgridSize | pointer to a grid size used for BSP creation. If NULL, the default settings will be used.
meshMode | Open mesh handling. Modes: Automatic, Closed, Open (see BSPOpenMode)
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
chunkIndex | If this is a valid index, the voronoi sites will only be created within the volume of the indexed chunk. Otherwise, the sites will be created within each of the root-level chunks. Default value is an invalid index.
Returns:
returns the number of sites actually created (written to siteBuffer and siteChunkIndices). This may be less than the number of sites requested if site placement fails.
virtual bool nvidia::apex::FractureToolsAPI::createVoronoiSplitMesh | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | nvidia::ExplicitHierarchicalMesh & | iHMeshCore,
 |  | bool | exportCoreMesh,
 |  | int32_t | coreMeshImprintSubmeshIndex,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureVoronoiDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t | randomSeed,
 |  | nvidia::IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the mesh in chunk[0], forming fractured pieces chunks[1...] using Voronoi decomposition fracturing.

Parameters:
hMesh | the mesh to split
iHMeshCore | if this mesh is not empty, chunk 0 will be used as an indestructible "core" of the fractured mesh. That is, it will be subtracted from hMesh, and placed at level 1 of the hierarchy. The remainder of hMesh will be split as usual, creating chunks at level 1 (and possibly deeper).
exportCoreMesh | if true, a core mesh chunk will be created from iHMeshCore
coreMeshImprintSubmeshIndex | if this is < 0, use the core mesh materials (was applyCoreMeshMaterialToNeighborChunks). Otherwise, use the given submesh
meshProcessingParams | describes generic mesh processing directives
desc | describes the voronoi splitting parameters surfaces (see FractureVoronoiDesc)
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | seed for the random number generator, to ensure reproducibility.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
true if successful.
virtual bool nvidia::apex::FractureToolsAPI::hierarchicallySplitChunk | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | uint32_t | chunkIndex,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureSliceDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t * | randomSeed,
 |  | nvidia::IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the chunk in chunk[chunkIndex], forming a hierarchy of fractured chunks using slice-mode fracturing. The chunks will be rearranged so that they are in breadth-first order.

Parameters:
hMesh | the ExplicitHierarchicalMesh to act upon
chunkIndex | index of chunk to be split
meshProcessingParams | used to create a BSP for this chunk
desc | describes the slicing surfaces (see FractureSliceDesc)
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual void nvidia::apex::FractureToolsAPI::setBSPBuildParameters | ( | float | logAreaSigmaThreshold,
 |  | uint32_t | testSetSize,
 |  | float | splitWeight,
 |  | float | imbalanceWeight
 | ) |  | [pure virtual]

Set the parameters used in BSP building operations.

Parameters:
logAreaSigmaThreshold | At each step in the tree building process, the surface with maximum triangle area is compared to the other surface triangle areas. If the maximum area surface is far from the "typical" set of surface areas, then that surface is chosen as the next splitting plane. Otherwise, a random test set is chosen and a winner determined based upon the weightings below. The value logAreaSigmaThreshold determines how "atypical" the maximum area surface must be to be chosen in this manner. Default value = 2.0.
testSetSize | Larger values of testSetSize may find better BSP trees, but will take more time to create. testSetSize = 0 is treated as infinity (all surfaces will be tested for each branch). Default value = 10.
splitWeight | How much to weigh the relative number of triangle splits when searching for a BSP surface. Default value = 0.5.
imbalanceWeight | How much to weigh the relative triangle imbalance when searching for a BSP surface. Default value = 0.0.
virtual void nvidia::apex::FractureToolsAPI::setBSPTolerances | ( | float | linearTolerance,
 |  | float | angularTolerance,
 |  | float | baseTolerance,
 |  | float | clipTolerance,
 |  | float | cleaningTolerance
 | ) |  | [pure virtual]

Set the tolerances used in CSG calculations with BSPs.

Parameters:
linearTolerance | relative (to mesh size) tolerance used with angularTolerance to determine coplanarity. Default = 1.0e-4.
angularTolerance | used with linearTolerance to determine coplanarity. Default = 1.0e-3
baseTolerance | relative (to mesh size) tolerance used for spatial partitioning
clipTolerance | relative (to mesh size) tolerance used when clipping triangles for CSG mesh building operations. Default = 1.0e-4.
cleaningTolerance | relative (to mesh size) tolerance used when cleaning the out put mesh generated from the toMesh() function. Default = 1.0e-7.
virtual void nvidia::apex::FractureToolsAPI::visualizeVoronoiCells | ( | nvidia::RenderDebugInterface & | debugRender,
 |  | const PxVec3 * | sites,
 |  | uint32_t | siteCount,
 |  | const uint32_t * | cellColors,
 |  | uint32_t | cellColorCount,
 |  | const PxBounds3 & | bounds,
 |  | uint32_t | cellIndex = 0xFFFFFFFF
 | ) |  | [pure virtual]

Utility to visualize Voronoi cells for a given set of sites.

debugRender rendering object which will receive the drawing primitives associated with this cell visualization sites an array of Voronoi cell sites, of length siteCount siteCount the number of Voronoi cell sites (length of sites array) cellColors an optional array of colors (see RenderDebug for format) for the cells. If NULL, the white (0xFFFFFFFF) color will be used. If not NULL, this (of length cellColorCount) is used to color the cell graphics. The number cellColorCount need not match siteCount. If cellColorCount is less than siteCount, the cell colors will cycle. That is, site N gets cellColor[NcellColorCount]. cellColorCount the number of cell colors (the length of cellColors array) bounds defines an axis-aligned bounding box which clips the visualization, since some cells extend to infinity cellIndex if this is a valid index (cellIndex < siteCount), then only the cell corresponding to sites[cellIndex] will be drawn. Otherwise, all cells will be drawn.

virtual bool nvidia::apex::FractureToolsAPI::voronoiSplitChunk | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | uint32_t | chunkIndex,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureVoronoiDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t * | randomSeed,
 |  | nvidia::IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the chunk in chunk[chunkIndex], forming fractured chunks using Voronoi decomposition fracturing. The chunks will be rearranged so that they are in breadth-first order.

Parameters:
hMesh | the ExplicitHierarchicalMesh to act upon
chunkIndex | index of chunk to be split
meshProcessingParams,: describes generic mesh processing directives
desc | describes the voronoi splitting parameters surfaces (see FractureVoronoiDesc)
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
The documentation for this class was generated from the following file:
  • FractureToolsAPI.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureToolsAPI
nvidia::apex::FractureToolsAPI Member List
This is the complete list of members for nvidia::apex::FractureToolsAPI, including all inherited members.
buildCutoutSet(FractureTools::CutoutSet &cutoutSet, const uint8_t *pixelBuffer, uint32_t bufferWidth, uint32_t bufferHeight, float snapThreshold, bool periodic)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
buildExplicitHierarchicalMesh(nvidia::ExplicitHierarchicalMesh &iHMesh, const nvidia::ExplicitRenderTriangle *meshTriangles, uint32_t meshTriangleCount, const nvidia::ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0, int32_t *parentIndices=NULL, uint32_t parentIndexCount=0)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
buildExplicitHierarchicalMeshFromDestructibleAsset(nvidia::ExplicitHierarchicalMesh &iHMesh, const nvidia::DestructibleAsset &destructibleAsset, uint32_t maxRootDepth=UINT32_MAX)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
buildExplicitHierarchicalMeshFromRenderMeshAsset(nvidia::ExplicitHierarchicalMesh &iHMesh, const nvidia::RenderMeshAsset &renderMeshAsset, uint32_t maxRootDepth=UINT32_MAX)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
buildSliceMesh(nvidia::IntersectMesh &intersectMesh, nvidia::ExplicitHierarchicalMesh &referenceMesh, const PxPlane &slicePlane, const FractureTools::NoiseParameters &noiseParameters, uint32_t randomSeed)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
calculateCutoutUVMapping(const nvidia::ExplicitRenderTriangle &triangle, PxMat33 &theMapping)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
calculateCutoutUVMapping(nvidia::ExplicitHierarchicalMesh &hMesh, const PxVec3 &targetDirection, PxMat33 &theMapping)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createChippedMesh(nvidia::ExplicitHierarchicalMesh &hMesh, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureCutoutDesc &desc, const FractureTools::CutoutSet &iCutoutSet, const FractureTools::FractureSliceDesc &sliceDesc, const FractureTools::FractureVoronoiDesc &voronoiDesc, const CollisionDesc &collisionDesc, uint32_t randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createCutoutSet()=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createExplicitHierarchicalMesh()=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createExplicitHierarchicalMeshConvexHull()=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createHierarchicallySplitMesh(nvidia::ExplicitHierarchicalMesh &hMesh, nvidia::ExplicitHierarchicalMesh &iHMeshCore, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, uint32_t randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createScatterMeshSites(uint8_t *meshIndices, PxMat44 *relativeTransforms, uint32_t *chunkMeshStarts, uint32_t scatterMeshInstancesBufferSize, nvidia::ExplicitHierarchicalMesh &hMesh, uint32_t targetChunkCount, const uint16_t *targetChunkIndices, uint32_t *randomSeed, uint32_t scatterMeshAssetCount, nvidia::RenderMeshAsset **scatterMeshAssets, const uint32_t *minCount, const uint32_t *maxCount, const float *minScales, const float *maxScales, const float *maxAngles)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createVoronoiSitesInsideMesh(nvidia::ExplicitHierarchicalMesh &hMesh, PxVec3 *siteBuffer, uint32_t *siteChunkIndices, uint32_t siteCount, uint32_t *randomSeed, uint32_t *microgridSize, BSPOpenMode::Enum meshMode, nvidia::IProgressListener &progressListener, uint32_t chunkIndex=0xFFFFFFFF)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createVoronoiSplitMesh(nvidia::ExplicitHierarchicalMesh &hMesh, nvidia::ExplicitHierarchicalMesh &iHMeshCore, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, uint32_t randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
hierarchicallySplitChunk(nvidia::ExplicitHierarchicalMesh &hMesh, uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
setBSPBuildParameters(float logAreaSigmaThreshold, uint32_t testSetSize, float splitWeight, float imbalanceWeight)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
setBSPTolerances(float linearTolerance, float angularTolerance, float baseTolerance, float clipTolerance, float cleaningTolerance)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
visualizeVoronoiCells(nvidia::RenderDebugInterface &debugRender, const PxVec3 *sites, uint32_t siteCount, const uint32_t *cellColors, uint32_t cellColorCount, const PxBounds3 &bounds, uint32_t cellIndex=0xFFFFFFFF)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
voronoiSplitChunk(nvidia::ExplicitHierarchicalMesh &hMesh, uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::ModuleDestructible Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleDestructible
Public Member Functions | Protected Member Functions
nvidia::apex::ModuleDestructible Class Reference

#include <ModuleDestructible.h>

List of all members.

Public Member Functions

virtual DestructibleActorJoint * | createDestructibleActorJoint (const DestructibleActorJointDesc &desc, Scene &scene)=0
virtual bool | isDestructibleActorJointActive (const DestructibleActorJoint *candidateJoint, Scene &apexScene) const =0
virtual void | setMaxDynamicChunkIslandCount (uint32_t maxCount)=0
virtual void | setMaxChunkCount (uint32_t maxCount)=0
virtual void | setSortByBenefit (bool sortByBenefit)=0
virtual void | setValidBoundsPadding (float pad)=0
virtual void | setMaxChunkDepthOffset (uint32_t maxChunkDepthOffset)=0
virtual void | setMaxChunkSeparationLOD (float separationLOD)=0
virtual void | setChunkReport (UserChunkReport *chunkReport)=0
virtual void | setImpactDamageReportCallback (UserImpactDamageReport *impactDamageReport)=0
virtual void | setChunkReportBitMask (uint32_t chunkReportBitMask)=0
virtual void | setDestructiblePhysXActorReport (UserDestructiblePhysXActorReport *destructiblePhysXActorReport)=0
virtual void | setChunkReportMaxFractureEventDepth (uint32_t chunkReportMaxFractureEventDepth)=0
virtual void | scheduleChunkStateEventCallback (DestructibleCallbackSchedule::Enum chunkStateEventCallbackSchedule)=0
virtual void | setChunkCrumbleReport (UserChunkParticleReport *chunkCrumbleReport)=0
virtual void | setChunkDustReport (UserChunkParticleReport *chunkDustReport)=0
virtual void | setWorldSupportPhysXScene (Scene &apexScene, PxScene *physxScene)=0
virtual bool | owns (const PxRigidActor *actor) const =0
virtual bool | isRuntimeFractureShape (const PxShape &shape) const =0
virtual DestructibleActor * | getDestructibleAndChunk (const PxShape *shape, int32_t *chunkIndex=NULL) const =0
virtual void | applyRadiusDamage (Scene &scene, float damage, float momentum, const PxVec3 &position, float radius, bool falloff)=0
virtual void | setMaxActorCreatesPerFrame (uint32_t maxActorsPerFrame)=0
virtual void | setMaxFracturesProcessedPerFrame (uint32_t maxFracturesProcessedPerFrame)=0
virtual bool | setSyncParams (UserDestructibleSyncHandler< DamageEventHeader > *userDamageEventHandler, UserDestructibleSyncHandler< FractureEventHeader > *userFractureEventHandler, UserDestructibleSyncHandler< ChunkTransformHeader > *userChunkMotionHandler)=0
virtual void | setUseLegacyChunkBoundsTesting (bool useLegacyChunkBoundsTesting)=0
virtual void | setUseLegacyDamageRadiusSpread (bool useLegacyDamageRadiusSpread)=0
virtual bool | setMassScaling (float massScale, float scaledMassExponent, Scene &apexScene)=0
virtual void | invalidateBounds (const PxBounds3 *bounds, uint32_t boundsCount, Scene &apexScene)=0
virtual void | setDamageApplicationRaycastFlags (nvidia::DestructibleActorRaycastFlags::Enum flags, Scene &apexScene)=0
virtual bool | setChunkCollisionHullCookingScale (const PxVec3 &scale)=0
virtual PxVec3 | getChunkCollisionHullCookingScale () const =0
virtual class FractureToolsAPI * | getFractureTools () const =0
Get reference to FractureTools object.

Protected Member Functions

virtual | ~ModuleDestructible ()

Detailed Description

Descriptor used to create the Destructible APEX module.

Constructor & Destructor Documentation

virtual nvidia::apex::ModuleDestructible::~ModuleDestructible ( ) [inline, protected, virtual]

Member Function Documentation

virtual void nvidia::apex::ModuleDestructible::applyRadiusDamage | ( | Scene & | scene,
 |  | float | damage,
 |  | float | momentum,
 |  | const PxVec3 & | position,
 |  | float | radius,
 |  | bool | falloff
 | ) |  | [pure virtual]

Applies damage to all DestructibleActors within the given radius in the apex scene. damage = the amount of damage at the damage point momentum = the magnitude of the impulse to transfer to each chunk position = the damage location radius = distance from damage location at which chunks will be affected falloff = whether or not to decrease damage with distance from the damage location. If true, damage will decrease linearly from the full damage (at zero distance) to zero damage (at radius). If false, full damage is applied to all chunks within the radius.

virtual DestructibleActorJoint* nvidia::apex::ModuleDestructible::createDestructibleActorJoint | ( | const DestructibleActorJointDesc & | desc,
 |  | Scene & | scene
 | ) |  | [pure virtual]

Object creation Create an DestructibleActorJoint from the descriptor. (See DestructibleActorJoint and DestructibleActorJointDesc.) This module will own the DestructibleActorJoint, so that any DestructibleAsset created by it will be released when this module is released. You may also call the DestructibleActorJoint's release() method, as long as the DestructibleActorJoint is still valid in the scene. (See isDestructibleActorJointActive())

virtual PxVec3 nvidia::apex::ModuleDestructible::getChunkCollisionHullCookingScale ( ) const [pure virtual]

Retrieves the cooking scale used for PhysX3 collision hulls, which can be set by setChunkCollisionHullCookingScale.

virtual DestructibleActor* nvidia::apex::ModuleDestructible::getDestructibleAndChunk | ( | const PxShape * | shape,
 |  | int32_t * | chunkIndex = NULL
 | ) |  | const [pure virtual]

PhysX SDK 3.X. Given an PxShape, returns the DestructibleActor and chunkIndex which belong to it, if the shape's PxActor is owned by the Destructible module (see the 'owns' function, above). Otherwise returns NULL. Useful when a scene query such as a raycast returns a shape.

virtual class FractureToolsAPI* nvidia::apex::ModuleDestructible::getFractureTools ( ) const [pure virtual]

Get reference to FractureTools object.

virtual void nvidia::apex::ModuleDestructible::invalidateBounds | ( | const PxBounds3 * | bounds,
 |  | uint32_t | boundsCount,
 |  | Scene & | apexScene
 | ) |  | [pure virtual]

If a static PhysX actor is about to be removed, or has just been added, to the scene, then world support may change. Use this function to notify the destruction module that it may need to reconsider world support in the given volumes. This may be called multiple times, and the bounds list will accumulate. This list will be processed upon the next APEX simulate call, and cleared.

virtual bool nvidia::apex::ModuleDestructible::isDestructibleActorJointActive | ( | const DestructibleActorJoint * | candidateJoint,
 |  | Scene & | apexScene
 | ) |  | const [pure virtual]

Query the module on the validity of a created DestructibleActorJoint. A DestructibleActorJoint will no longer be valid when it is destroyed in the scene, in which case the module calls the DestructibleActorJoint's release(). Therefore, this DestructibleActorJoint should no longer be referenced if it is not valid.

virtual bool nvidia::apex::ModuleDestructible::isRuntimeFractureShape ( const PxShape & shape ) const [pure virtual]

PhysX SDK 3.X. Returns true iff the PxShape was created by the runtime fracture system.

virtual bool nvidia::apex::ModuleDestructible::owns ( const PxRigidActor * actor ) const [pure virtual]

PhysX SDK 3.X. Returns true iff the PxRigidActor was created by the Destructible module. If true, the user must NOT destroy the actor.

virtual void nvidia::apex::ModuleDestructible::scheduleChunkStateEventCallback ( DestructibleCallbackSchedule::Enum chunkStateEventCallbackSchedule ) [pure virtual]

Set whether or not the UserChunkReport::onStateChangeNotify interface will be used to deliver visibility change data to the user.

Default = DestructibleCallbackSchedule::Disabled.

virtual bool nvidia::apex::ModuleDestructible::setChunkCollisionHullCookingScale ( const PxVec3 & scale ) [pure virtual]

In PhysX 3.x, scaling of collision shapes can be done in the shape, not the cooked hull data. As a consequence, each collision hull only needs to be cooked once. By default, this hull is not scaled from the original data. But if the user desires, the hull can be scaled before cooking. That scale will be removed from the DestructibleActor's scale before being applied to the shape using the hull. So ideally, this user-set cooking scale does nothing. Numerically, however, it may have an effect, so we leave it as an option.

The input scale must be positive in all components. If not, the cooking scale will not be set, and the function returns false. Otherwise, the scale is set and the function returns true.

virtual void nvidia::apex::ModuleDestructible::setChunkCrumbleReport ( UserChunkParticleReport * chunkCrumbleReport ) [pure virtual]

Sets the user chunk crumble particle buffer callback. See UserChunkParticleReport. Set to NULL (the default) to disable. APEX does not take ownership of the report object.

virtual void nvidia::apex::ModuleDestructible::setChunkDustReport ( UserChunkParticleReport * chunkDustReport ) [pure virtual]

Sets the user chunk dust particle buffer callback. See UserChunkParticleReport. Set to NULL (the default) to disable. APEX does not take ownership of the report object.

Note - this is a placeholder API. The dust feature is disabled in 1.2.0.

virtual void nvidia::apex::ModuleDestructible::setChunkReport ( UserChunkReport * chunkReport ) [pure virtual]

General Sets the user chunk fracture/destroy callback. See UserChunkReport. Set to NULL (the default) to disable. APEX does not take ownership of the report object.

virtual void nvidia::apex::ModuleDestructible::setChunkReportBitMask ( uint32_t chunkReportBitMask ) [pure virtual]

Set a bit mask of flags (see ApexChunkFlag) for the fracture/destroy callback (See setChunkReport.) Fracture events with flags that overlap this mask will contribute to the DamageEventReportData.

virtual void nvidia::apex::ModuleDestructible::setChunkReportMaxFractureEventDepth ( uint32_t chunkReportMaxFractureEventDepth ) [pure virtual]

Set the maximum depth at which individual chunk fracture events will be reported in an DamageEventReportData's fractureEventList through the UserChunkReport. Fracture events deeper than this will still contribute to the DamageEventReportData's worldBounds and totalNumberOfFractureEvents.

virtual void nvidia::apex::ModuleDestructible::setDamageApplicationRaycastFlags | ( | nvidia::DestructibleActorRaycastFlags::Enum | flags,
 |  | Scene & | apexScene
 | ) |  | [pure virtual]

When applyDamage, or damage from impact, is processed, a rayCast call is used internally to find a more accurate damage position. This allows the user to specify the rayCast behavior. If no flags are set, no raycasting is done. Raycasting will be peformed against static or dynamic chunks, or both, depending on the value of flags. The flags are defined by DestructibleActorRaycastFlags::Enum.

The default flag used is DestructibleActorRaycastFlags::StaticChunks, since static-only raycasts are faster than ones that include dynamic chunks.

Note: only the flags DestructibleActorRaycastFlags::NoChunks, StaticChunks, and DynamicChunks are considered.

virtual void nvidia::apex::ModuleDestructible::setDestructiblePhysXActorReport ( UserDestructiblePhysXActorReport * destructiblePhysXActorReport ) [pure virtual]

Sets the user callback to receive PhysX actor create/release notifications for destruction-associated PhysX actors. Set to NULL (the default) to disable.

virtual void nvidia::apex::ModuleDestructible::setImpactDamageReportCallback ( UserImpactDamageReport * impactDamageReport ) [pure virtual]

Sets the user impact damage report callback. See UserImpactDamageReport. Set to NULL (the default) to disable. APEX does not take ownership of the report object.

virtual bool nvidia::apex::ModuleDestructible::setMassScaling | ( | float | massScale,
 |  | float | scaledMassExponent,
 |  | Scene & | apexScene
 | ) |  | [pure virtual]

Sets mass scaling properties in a given apex scene.

massScale and scaledMassExponent are used for scaling dynamic chunk masses. The 'real' mass m of a chunk is calculated by the destructible actor's density multiplied by the total volume of the chunk's (scaled) collision shapes. The mass used in the simulation is massScale*pow(m/massScale,scaledMassExponent). Values less than 1 have the effect of reducing the ratio of different masses. The closer scaledMassExponent is to zero, the more the ratio will be 'flattened.' This helps PhysX converge when there is a very large number of interacting rigid bodies (such as a pile of destructible chunks).

massScale valid range: (0,infinity). Default = 1.0. scaledMassExponent valid range: [0,1]. Default = 0.5.

Returns true iff the parameters are valid and the apexScene is valid.

virtual void nvidia::apex::ModuleDestructible::setMaxActorCreatesPerFrame ( uint32_t maxActorsPerFrame ) [pure virtual]

Lets the user throttle the number of SDK actor creates per frame (per scene) due to destruction, as this can be quite costly. The default is 0xffffffff (unlimited).

virtual void nvidia::apex::ModuleDestructible::setMaxChunkCount ( uint32_t maxCount ) [pure virtual]

The maximum number of allowed visible chunks in the scene. If a fracturing event would cause more chunks to be created, then PxActors are released to make room for the created chunks. The priority for released PxActors is the same as described in setMaxDynamicChunkIslandCount.

virtual void nvidia::apex::ModuleDestructible::setMaxChunkDepthOffset ( uint32_t maxChunkDepthOffset ) [pure virtual]

Effectively eliminates the deeper level (smaller) chunks from DestructibleAssets (see DestructibleAsset). If maxChunkDepthOffset = 0, all chunks can be fractured. If maxChunkDepthOffset = 1, the depest level (smallest) chunks are eliminated, etc. This prevents too many chunks from being formed. In other words, the higher maxChunkDepthOffset, the lower the "level of detail."

virtual void nvidia::apex::ModuleDestructible::setMaxChunkSeparationLOD ( float separationLOD ) [pure virtual]

Every destructible asset defines a min and max lifetime, and maximum separation distance for its chunks. Chunk islands are destroyed after this time or separation from their origins. This parameter sets the lifetimes and max separations within their min-max ranges. The valid range is [0,1]. Default is 0.5.

virtual void nvidia::apex::ModuleDestructible::setMaxDynamicChunkIslandCount ( uint32_t maxCount ) [pure virtual]

LOD The maximum number of allowed PxActors which represent dynamic groups of chunks. If a fracturing event would cause more PxActors to be created, then some PxActors are released and the chunks they represent destroyed. The PxActors released to make room for others depends on the priority mode. If sorting by benefit (see setSortByBenefit), then chunks with the lowest LOD benefit are released first. Otherwise, oldest chunks are released first.

virtual void nvidia::apex::ModuleDestructible::setMaxFracturesProcessedPerFrame ( uint32_t maxFracturesProcessedPerFrame ) [pure virtual]

Lets the user throttle the number of fractures processed per frame (per scene) due to destruction, as this can be quite costly. The default is 0xffffffff (unlimited).

virtual void nvidia::apex::ModuleDestructible::setSortByBenefit ( bool sortByBenefit ) [pure virtual]

Instead of keeping the youngest PxActors, keep the greatest benefit PxActors if sortByBenefit is true. By default, this module does not sort by benefit. That is, oldest PxActors are released first.

virtual bool nvidia::apex::ModuleDestructible::setSyncParams | ( | UserDestructibleSyncHandler< DamageEventHeader > * | userDamageEventHandler,
 |  | UserDestructibleSyncHandler< FractureEventHeader > * | userFractureEventHandler,
 |  | UserDestructibleSyncHandler< ChunkTransformHeader > * | userChunkMotionHandler
 | ) |  | [pure virtual]

Set the callback pointers from which APEX will use to return sync-able data.

virtual void nvidia::apex::ModuleDestructible::setUseLegacyChunkBoundsTesting ( bool useLegacyChunkBoundsTesting ) [pure virtual]

The following functions control the use of legacy behavior. By default, destruction damage application (either point or radius damage) now use the exact collision bounds of the chunk to determine damage application. Before, bounding spheres were used on "leaf" chunks (deepest in the fracture hierarchy) and only the bounding sphere center (effectively radius 0) was used on all chunks higher in the hierarchy. This led to inconsistent behavior when damaging destructibles at various levels of detail.

If true is passed into this function, the legacy behavior is restored.

virtual void nvidia::apex::ModuleDestructible::setUseLegacyDamageRadiusSpread ( bool useLegacyDamageRadiusSpread ) [pure virtual]

By default, the BehaviorGroup fields damageSpread.minimumRadius, damageSpread.radiusMultiplier, and damageSpread.falloffExponent are used for point and radius damage. Impact damage still uses damageToRadius, but this radius does not scale with the size of the destructible.

The old, deprecated behavior was to base damage spread upon the damageToRadius field of the BehaviorGroup used by the chunk. Specifically, damage would spread throughout a damage radius calculated as radius = damageToRadius * (damage / damageThreshold) * (size of destructible).

If true is passed into this function, the legacy behavior is restored.

virtual void nvidia::apex::ModuleDestructible::setValidBoundsPadding ( float pad ) [pure virtual]

Deprecated

virtual void nvidia::apex::ModuleDestructible::setWorldSupportPhysXScene | ( | Scene & | apexScene,
 |  | PxScene * | physxScene
 | ) |  | [pure virtual]

PhysX SDK 3.X. Allows the user to specify an alternative PhysX scene to use for world support calculations. If NULL (the default), the PhysX scene associated with the Scene will be used.

The documentation for this class was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleDestructible
nvidia::apex::ModuleDestructible Member List
This is the complete list of members for nvidia::apex::ModuleDestructible, including all inherited members.
applyRadiusDamage(Scene &scene, float damage, float momentum, const PxVec3 &position, float radius, bool falloff)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
createDestructibleActorJoint(const DestructibleActorJointDesc &desc, Scene &scene)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
getChunkCollisionHullCookingScale() const =0 | nvidia::apex::ModuleDestructible | [pure virtual]
getDestructibleAndChunk(const PxShape *shape, int32_t *chunkIndex=NULL) const =0 | nvidia::apex::ModuleDestructible | [pure virtual]
getFractureTools() const =0 | nvidia::apex::ModuleDestructible | [pure virtual]
invalidateBounds(const PxBounds3 *bounds, uint32_t boundsCount, Scene &apexScene)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
isDestructibleActorJointActive(const DestructibleActorJoint *candidateJoint, Scene &apexScene) const =0 | nvidia::apex::ModuleDestructible | [pure virtual]
isRuntimeFractureShape(const PxShape &shape) const =0 | nvidia::apex::ModuleDestructible | [pure virtual]
owns(const PxRigidActor *actor) const =0 | nvidia::apex::ModuleDestructible | [pure virtual]
scheduleChunkStateEventCallback(DestructibleCallbackSchedule::Enum chunkStateEventCallbackSchedule)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setChunkCollisionHullCookingScale(const PxVec3 &scale)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setChunkCrumbleReport(UserChunkParticleReport *chunkCrumbleReport)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setChunkDustReport(UserChunkParticleReport *chunkDustReport)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setChunkReport(UserChunkReport *chunkReport)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setChunkReportBitMask(uint32_t chunkReportBitMask)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setChunkReportMaxFractureEventDepth(uint32_t chunkReportMaxFractureEventDepth)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setDamageApplicationRaycastFlags(nvidia::DestructibleActorRaycastFlags::Enum flags, Scene &apexScene)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setDestructiblePhysXActorReport(UserDestructiblePhysXActorReport *destructiblePhysXActorReport)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setImpactDamageReportCallback(UserImpactDamageReport *impactDamageReport)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMassScaling(float massScale, float scaledMassExponent, Scene &apexScene)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMaxActorCreatesPerFrame(uint32_t maxActorsPerFrame)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMaxChunkCount(uint32_t maxCount)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMaxChunkDepthOffset(uint32_t maxChunkDepthOffset)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMaxChunkSeparationLOD(float separationLOD)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMaxDynamicChunkIslandCount(uint32_t maxCount)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMaxFracturesProcessedPerFrame(uint32_t maxFracturesProcessedPerFrame)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setSortByBenefit(bool sortByBenefit)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setSyncParams(UserDestructibleSyncHandler< DamageEventHeader > *userDamageEventHandler, UserDestructibleSyncHandler< FractureEventHeader > *userFractureEventHandler, UserDestructibleSyncHandler< ChunkTransformHeader > *userChunkMotionHandler)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setUseLegacyChunkBoundsTesting(bool useLegacyChunkBoundsTesting)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setUseLegacyDamageRadiusSpread(bool useLegacyDamageRadiusSpread)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setValidBoundsPadding(float pad)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setWorldSupportPhysXScene(Scene &apexScene, PxScene *physxScene)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
~ModuleDestructible() | nvidia::apex::ModuleDestructible | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::UserChunkParticleReport Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserChunkParticleReport
Public Member Functions | Protected Member Functions
nvidia::apex::UserChunkParticleReport Class Reference

#include <ModuleDestructible.h>

List of all members.

Public Member Functions

virtual void | onParticleEmission (const ChunkParticleReportData &particleData)=0

Protected Member Functions

virtual | ~UserChunkParticleReport ()

Detailed Description

UserChunkParticleReport - API for a user-defined callback to get particle buffer data when a chunk crumbles or emits dust particles. Note - only crumble emitters are implemented in 1.2.0

Constructor & Destructor Documentation

virtual nvidia::apex::UserChunkParticleReport::~UserChunkParticleReport ( ) [inline, protected, virtual]

Member Function Documentation

virtual void nvidia::apex::UserChunkParticleReport::onParticleEmission ( const ChunkParticleReportData & particleData ) [pure virtual]

User implementation of UserChunkParticleReport must overload this function. This function will get called when an DestructibleActor generates crumble particle or dust particle effect data. Crumble particles are generated whenever a chunk is destroyed completely and the DestructibleActorFlag CRUMBLE_SMALLEST_CHUNKS is set. Dust line particles are generated along chunk boundaries whenever they are fractured free from other chunks.

Note - only crumble emitters are implemented in 1.2.0

The documentation for this class was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserChunkParticleReport
nvidia::apex::UserChunkParticleReport Member List
This is the complete list of members for nvidia::apex::UserChunkParticleReport, including all inherited members.
onParticleEmission(const ChunkParticleReportData &particleData)=0 | nvidia::apex::UserChunkParticleReport | [pure virtual]
~UserChunkParticleReport() | nvidia::apex::UserChunkParticleReport | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::UserChunkReport Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserChunkReport
Public Member Functions | Protected Member Functions
nvidia::apex::UserChunkReport Class Reference

#include <ModuleDestructible.h>

List of all members.

Public Member Functions

virtual void | onDamageNotify (const DamageEventReportData &damageEvent)=0
virtual void | onStateChangeNotify (const ChunkStateEventData &visibilityEvent)=0
virtual bool | releaseOnNoChunksVisible (const DestructibleActor *destructible)
virtual void | onDestructibleWake (DestructibleActor **destructibles, uint32_t count)=0
virtual void | onDestructibleSleep (DestructibleActor **destructibles, uint32_t count)=0

Protected Member Functions

virtual | ~UserChunkReport ()

Detailed Description

UserChunkReport - API for a user-defined callback to get information about fractured or damaged chunks

Constructor & Destructor Documentation

virtual nvidia::apex::UserChunkReport::~UserChunkReport ( ) [inline, protected, virtual]

Member Function Documentation

virtual void nvidia::apex::UserChunkReport::onDamageNotify ( const DamageEventReportData & damageEvent ) [pure virtual]

User implementation of UserChunkReport must overload this function. This function will get called when a chunk is fractured or destroyed. See the definition of DamageEventReportData for the information provided to the function.

virtual void nvidia::apex::UserChunkReport::onDestructibleSleep | ( | DestructibleActor ** | destructibles,
 |  | uint32_t | count
 | ) |  | [pure virtual]

List of destructible actors that have just gone to sleep (all associated PhysX actors have gone to sleep).

virtual void nvidia::apex::UserChunkReport::onDestructibleWake | ( | DestructibleActor ** | destructibles,
 |  | uint32_t | count
 | ) |  | [pure virtual]

List of destructible actors that have just become awake (any associated PhysX actor has become awake).

virtual void nvidia::apex::UserChunkReport::onStateChangeNotify ( const ChunkStateEventData & visibilityEvent ) [pure virtual]

User implementation of UserChunkReport must overload this function. This function gets called when chunk visibility changes occur, if the user has selected this option via ModuleDestructible::scheduleChunkStateEventCallback. See the definition of ChunkStateEventData for the information provided to the function.

Please note* the user must also set the NxParameterized actor parameter 'createChunkEvents' to true, on individual destructible actors, to receive state change events from that actor.

virtual bool nvidia::apex::UserChunkReport::releaseOnNoChunksVisible ( const DestructibleActor * destructible ) [inline, virtual]

Called when an DestructibleActor contains no visible chunks. If the user returns true, APEX will release the destructible actor. If the user returns false, they should not release the destructible actor from within the callback, and instead must wait until the completion of Scene::fetchResults().

Default implementation returns false, which is the legacy behavior.

If this class (UserChunkReport) is not implemented, APEX will not destroy the DestructibleActor.

The documentation for this class was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserChunkReport
nvidia::apex::UserChunkReport Member List
This is the complete list of members for nvidia::apex::UserChunkReport, including all inherited members.
onDamageNotify(const DamageEventReportData &damageEvent)=0 | nvidia::apex::UserChunkReport | [pure virtual]
onDestructibleSleep(DestructibleActor **destructibles, uint32_t count)=0 | nvidia::apex::UserChunkReport | [pure virtual]
onDestructibleWake(DestructibleActor **destructibles, uint32_t count)=0 | nvidia::apex::UserChunkReport | [pure virtual]
onStateChangeNotify(const ChunkStateEventData &visibilityEvent)=0 | nvidia::apex::UserChunkReport | [pure virtual]
releaseOnNoChunksVisible(const DestructibleActor *destructible) | nvidia::apex::UserChunkReport | [inline, virtual]
~UserChunkReport() | nvidia::apex::UserChunkReport | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::UserDestructiblePhysXActorReport Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserDestructiblePhysXActorReport
Public Member Functions | Protected Member Functions
nvidia::apex::UserDestructiblePhysXActorReport Class Reference

#include <ModuleDestructible.h>

List of all members.

Public Member Functions

virtual void | onPhysXActorCreate (const physx::PxActor &actor)=0
virtual void | onPhysXActorRelease (const physx::PxActor &actor)=0

Protected Member Functions

virtual | ~UserDestructiblePhysXActorReport ()

Detailed Description

UserDestructiblePhysXActorReport - API for user-defined callbacks giving notification of PhysX actor creation and release from the destruction module.

Constructor & Destructor Documentation

virtual nvidia::apex::UserDestructiblePhysXActorReport::~UserDestructiblePhysXActorReport ( ) [inline, protected, virtual]

Member Function Documentation

virtual void nvidia::apex::UserDestructiblePhysXActorReport::onPhysXActorCreate ( const physx::PxActor & actor ) [pure virtual]

Called immediately after a PxActor is created in the Destruction module.

virtual void nvidia::apex::UserDestructiblePhysXActorReport::onPhysXActorRelease ( const physx::PxActor & actor ) [pure virtual]

Called immediately before a PxActor is released in the Destruction module.

The documentation for this class was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserDestructiblePhysXActorReport
nvidia::apex::UserDestructiblePhysXActorReport Member List
This is the complete list of members for nvidia::apex::UserDestructiblePhysXActorReport, including all inherited members.
onPhysXActorCreate(const physx::PxActor &actor)=0 | nvidia::apex::UserDestructiblePhysXActorReport | [pure virtual]
onPhysXActorRelease(const physx::PxActor &actor)=0 | nvidia::apex::UserDestructiblePhysXActorReport | [pure virtual]
~UserDestructiblePhysXActorReport() | nvidia::apex::UserDestructiblePhysXActorReport | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > Class Template Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserDestructibleSyncHandler
Public Member Functions | Protected Member Functions
nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > Class Template Reference

#include <ModuleDestructible.h>

List of all members.

Public Member Functions

virtual void | onWriteBegin (DestructibleSyncHeader *&bufferStart, uint32_t bufferSize)=0
virtual void | onWriteDone (uint32_t headerCount)=0
virtual void | onPreProcessReadBegin (DestructibleSyncHeader *&bufferStart, uint32_t &bufferSize, bool &continuePointerSwizzling)=0
virtual void | onPreProcessReadDone (uint32_t headerCount)=0
virtual void | onReadBegin (const DestructibleSyncHeader *&bufferStart)=0
virtual void | onReadDone (const char *debugMessage)=0

Protected Member Functions

virtual | ~UserDestructibleSyncHandler ()

Detailed Description

template<typename DestructibleSyncHeader>
class nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >

Sync-able Callback Class.

Constructor & Destructor Documentation

template<typename DestructibleSyncHeader>
virtual nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >::~UserDestructibleSyncHandler ( ) [inline, protected, virtual]

Member Function Documentation

template<typename DestructibleSyncHeader>
virtual void nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >::onPreProcessReadBegin | ( | DestructibleSyncHeader *& | bufferStart,
 |  | uint32_t & | bufferSize,
 |  | bool & | continuePointerSwizzling
 | ) |  | [pure virtual]

Called when pre-process read begins.

template<typename DestructibleSyncHeader>
virtual void nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >::onPreProcessReadDone ( uint32_t headerCount ) [pure virtual]

Called when pre-process read done.

template<typename DestructibleSyncHeader>
virtual void nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >::onReadBegin ( const DestructibleSyncHeader *& bufferStart ) [pure virtual]

Called when read begins.

template<typename DestructibleSyncHeader>
virtual void nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >::onReadDone ( const char * debugMessage ) [pure virtual]

Called when read done.

template<typename DestructibleSyncHeader>
virtual void nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >::onWriteBegin | ( | DestructibleSyncHeader *& | bufferStart,
 |  | uint32_t | bufferSize
 | ) |  | [pure virtual]

Called when write begins.

template<typename DestructibleSyncHeader>
virtual void nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >::onWriteDone ( uint32_t headerCount ) [pure virtual]

Called when write done.

The documentation for this class was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserDestructibleSyncHandler
nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > Member List
This is the complete list of members for nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >, including all inherited members.
onPreProcessReadBegin(DestructibleSyncHeader *&bufferStart, uint32_t &bufferSize, bool &continuePointerSwizzling)=0 | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [pure virtual]
onPreProcessReadDone(uint32_t headerCount)=0 | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [pure virtual]
onReadBegin(const DestructibleSyncHeader *&bufferStart)=0 | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [pure virtual]
onReadDone(const char *debugMessage)=0 | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [pure virtual]
onWriteBegin(DestructibleSyncHeader *&bufferStart, uint32_t bufferSize)=0 | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [pure virtual]
onWriteDone(uint32_t headerCount)=0 | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [pure virtual]
~UserDestructibleSyncHandler() | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::UserImpactDamageReport Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserImpactDamageReport
Public Member Functions
nvidia::apex::UserImpactDamageReport Class Reference

#include <ModuleDestructible.h>

List of all members.

Public Member Functions

virtual void onImpactDamageNotify (const ImpactDamageEventData *buffer, uint32_t bufferSize)=0

Detailed Description

UserImpactDamageReport - API for a user-defined callback to get a buffer of impact damage events

Member Function Documentation

virtual void nvidia::apex::UserImpactDamageReport::onImpactDamageNotify | ( | const ImpactDamageEventData * | buffer,
 |  | uint32_t | bufferSize
 | ) |  | [pure virtual]

User implementation of UserImpactDamageReport must overload this function. If an instance of this object is passed to ModuleDestructible::setImpactDamageReportCallback, this function will get called once during ApexScene::fetchResults, passing back an array of ImpactDamageEventData reporting all impact damage events.

The documentation for this class was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserImpactDamageReport
nvidia::apex::UserImpactDamageReport Member List
This is the complete list of members for nvidia::apex::UserImpactDamageReport, including all inherited members.
onImpactDamageNotify(const ImpactDamageEventData *buffer, uint32_t bufferSize)=0 nvidia::apex::UserImpactDamageReport [pure virtual]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: DestructibleActor.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
DestructibleActor.h File Reference
#include "foundation/Px.h"
#include "Actor.h"
#include "Renderable.h"
#include "ModuleDestructible.h"
#include "PxForceMode.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::DestructibleEmitterType
struct | nvidia::apex::DestructibleParameterizedType
struct | nvidia::apex::DestructibleHitChunk
struct | nvidia::apex::DestructibleActorSyncFlags
struct | nvidia::apex::DestructiblePhysXActorQueryFlags
struct | nvidia::apex::DestructibleActorSyncState
struct | nvidia::apex::DestructibleChunkSyncState
struct | nvidia::apex::DestructibleActorChunkFlags
class | nvidia::apex::DestructibleActor

Namespaces

namespace | physx
namespace | nvidia
namespace | nvidia::apex

Defines

#define | DESTRUCTIBLE_ACTOR_TYPE_NAME "DestructibleActor"

Define Documentation

#define DESTRUCTIBLE_ACTOR_TYPE_NAME "DestructibleActor"
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: DestructibleActor.h Source File

  • File List
  • File Members
DestructibleActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef DESTRUCTIBLE_ACTOR_H
00031 #define DESTRUCTIBLE_ACTOR_H
00032
00033 #include "foundation/Px.h"
00034 #include "Actor.h"
00035 #include "Renderable.h"
00036 #include "ModuleDestructible.h"
00037 #include "PxForceMode.h"
00038
00039 namespace physx
00040 {
00041     class PxRigidDynamic;
00042 };
00043
00044 #define DESTRUCTIBLE_ACTOR_TYPE_NAME "DestructibleActor"
00045
00046 namespace nvidia
00047 {
00048 namespace apex
00049 {
00050
00051 PX_PUSH_PACK_DEFAULT
00052
00053 struct DestructibleParameters;
00054 class RenderVolume;
00055 class EmitterActor;
00056 class DestructibleRenderable;
00057 class DestructibleBehaviorGroupDesc;
00058
00059
00063 struct DestructibleEmitterType
00064 {
00068     enum Enum
00069     {
00070         Crumble,
00071         Dust,   // Note: this is a placeholder.  Its implementation has been removed in 1.2.0, and will be restored in later versions.
00072         Count
00073     };
00074 };
00075
00079 struct DestructibleParameterizedType
00080 {
00084     enum Enum
00085     {
00086         State,  // The full state of the actor (including params, chunk data, etc...)
00087         Params, // The parameters used to initialize the actor
00088     };
00089 };
00090
00094 struct DestructibleHitChunk
00095 {
00096     uint32_t chunkIndex;
00097     uint32_t hitChunkFlags;
00098 };
00099
00103 struct DestructibleActorSyncFlags
00104 {
00108     enum Enum
00109     {
00110         None                = 0,
00111         CopyDamageEvents    = (1 << 0),
00112         ReadDamageEvents    = (1 << 1),
00113         CopyFractureEvents  = (1 << 2),
00114         ReadFractureEvents  = (1 << 3),
00115         CopyChunkTransform  = (1 << 4),
00116         ReadChunkTransform  = (1 << 5),
00117         Last                = (1 << 6),
00118     };
00119 };
00120
00124 struct DestructiblePhysXActorQueryFlags
00125 {
00129     enum Enum
00130     {
00131         None = 0,
00132
00133         // Actor states
00134         Static = (1 << 0),
00135         Dynamic = (1 << 1),
00136         Dormant = (1 << 2),
00137
00138         AllStates = Static | Dynamic | Dormant,
00139
00140         // Other filters
00147         AllowRedundancy = (1 << 3),
00148
00152         AllowActorsNotInScenes = (1 << 4)
00153     };
00154 };
00155
00159 struct DestructibleActorSyncState
00160 {
00161     uint32_t    damageEventFilterDepth;
00162     uint32_t    fractureEventFilterDepth;
00163 };
00164
00168 struct DestructibleChunkSyncState
00169 {
00170     bool        disableTransformBuffering;
00171     bool        excludeSleepingChunks;
00172     uint32_t    chunkTransformCopyDepth;
00173 };
00174
00179 struct DestructibleActorChunkFlags
00180 {
00184     enum Enum
00185     {
00190         ChunkIsWorldSupported   =   (1<<0),
00191     };
00192 };
00193
00197 class DestructibleActor : public Actor, public Renderable
00198 #if PX_PHYSICS_VERSION_MAJOR == 3
00199     , public ActorSource
00200 #endif
00201 {
00202 public:
00206     virtual const RenderMeshActor*  getRenderMeshActor(DestructibleActorMeshType::Enum type = DestructibleActorMeshType::Skinned) const = 0;
00207
00211     virtual const DestructibleParameters& getDestructibleParameters() const = 0;
00212
00216     virtual void                    setDestructibleParameters(const DestructibleParameters& destructibleParameters) = 0;
00217
00221     virtual PxMat44                 getInitialGlobalPose() const = 0;
00222
00226     virtual void                    setInitialGlobalPose(const PxMat44& pose) = 0;
00227
00231     virtual PxVec3                  getScale() const = 0;
00232
00236     virtual bool                    isInitiallyDynamic() const = 0;
00237
00245     virtual void                    getChunkVisibilities(uint8_t* visibilityArray, uint32_t visibilityArraySize) const = 0;
00246
00250     virtual uint32_t                getNumVisibleChunks() const = 0;
00251
00255     virtual const uint16_t*         getVisibleChunks() const = 0;
00256
00267     virtual bool                    acquireChunkEventBuffer(const nvidia::DestructibleChunkEvent*& buffer, uint32_t& bufferSize) = 0;
00268
00275     virtual bool                    releaseChunkEventBuffer(bool clearBuffer = true) = 0;
00276
00289     virtual bool                    acquirePhysXActorBuffer(physx::PxRigidDynamic**& buffer, uint32_t& bufferSize, uint32_t flags = DestructiblePhysXActorQueryFlags::AllStates) = 0;
00290
00297     virtual bool                    releasePhysXActorBuffer() = 0;
00298
00307     virtual physx::PxRigidDynamic*  getChunkPhysXActor(uint32_t chunkIndex) = 0;
00308
00319     virtual uint32_t                getChunkPhysXShapes(physx::PxShape**& shapes, uint32_t chunkIndex) const = 0;
00320
00330     virtual PxTransform             getChunkPose(uint32_t chunkIndex) const = 0;
00331
00341     virtual PxTransform             getChunkTransform(uint32_t chunkIndex) const = 0;
00342
00348     virtual PxVec3                  getChunkLinearVelocity(uint32_t chunkIndex) const = 0;
00349
00355     virtual PxVec3                  getChunkAngularVelocity(uint32_t chunkIndex) const = 0;
00356
00363     virtual const PxMat44           getChunkTM(uint32_t chunkIndex) const = 0;
00364
00372     virtual int32_t                 getChunkBehaviorGroupIndex(uint32_t chunkIndex) const = 0;
00373
00380     virtual uint32_t                getChunkActorFlags(uint32_t chunkIndex) const = 0;
00381
00388     virtual void                    setGlobalPose(const PxMat44& pose) = 0;
00389
00396     virtual bool                    getGlobalPose(PxMat44& pose) = 0;
00397
00401     virtual void                    setLinearVelocity(const PxVec3& linearVelocity) = 0;
00402
00406     virtual void                    setAngularVelocity(const PxVec3& angularVelocity) = 0;
00407
00413     virtual void                    setDynamic(int32_t chunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX) = 0;
00414
00418     virtual bool                    isDynamic(uint32_t chunkIndex) const = 0;
00419
00425     virtual void                    enableHardSleeping() = 0;
00426
00431     virtual void                    disableHardSleeping(bool wake = false)= 0;
00432
00436     virtual bool                    isHardSleepingEnabled() const = 0;
00437
00446     virtual bool                    setChunkPhysXActorAwakeState(uint32_t chunkIndex, bool awake) = 0;
00447
00459     virtual bool                    addForce(uint32_t chunkIndex, const PxVec3& force, physx::PxForceMode::Enum mode, const PxVec3* position = NULL, bool wakeup = true) = 0;
00460
00464     virtual void                    setSkinnedOverrideMaterial(uint32_t submeshIndex, const char* overrideMaterialName) = 0;
00465
00469     virtual void                    setStaticOverrideMaterial(uint32_t submeshIndex, const char* overrideMaterialName) = 0;
00470
00474     virtual void                    setRuntimeFractureOverridePattern(const char* overridePatternName) = 0;
00475
00492     virtual void                    applyDamage(float damage, float momentum, const PxVec3& position, const PxVec3& direction, int32_t chunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX, void* damageUserData = NULL) = 0;
00493
00507     virtual void                    applyRadiusDamage(float damage, float momentum, const PxVec3& position, float radius, bool falloff, void* damageUserData = NULL) = 0;
00508
00513     virtual void                    takeImpact(const PxVec3& force, const PxVec3& position, uint16_t chunkIndex, PxActor const* damageImpactActor) = 0;
00514
00530     virtual int32_t                 rayCast(float& time, PxVec3& normal, const PxVec3& worldRayOrig, const PxVec3& worldRayDir, DestructibleActorRaycastFlags::Enum flags, int32_t parentChunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX) const = 0;
00531
00546     virtual int32_t                 obbSweep(float& time, PxVec3& normal, const PxVec3& worldBoxCenter, const PxVec3& worldBoxExtents, const PxMat33& worldBoxRot, const PxVec3& worldDisplacement, DestructibleActorRaycastFlags::Enum flags) const = 0;
00547
00551     virtual void                    setCrumbleEmitterState(bool enable) = 0;
00552
00557     virtual void                    setDustEmitterState(bool enable) = 0;
00558
00563     virtual void                    setPreferredRenderVolume(RenderVolume* volume, DestructibleEmitterType::Enum type) = 0;
00564
00565
00570     virtual EmitterActor*           getApexEmitter(DestructibleEmitterType::Enum type) = 0;
00571
00576     virtual bool                    recreateApexEmitter(DestructibleEmitterType::Enum type) = 0;
00577
00583     virtual const ::NvParameterized::Interface* getNvParameterized(DestructibleParameterizedType::Enum type = DestructibleParameterizedType::State) const = 0;
00584
00590     virtual void                    setNvParameterized(::NvParameterized::Interface*) = 0;
00591
00611     virtual bool                    setSyncParams(uint32_t userActorID, uint32_t actorSyncFlags = 0, const DestructibleActorSyncState * actorSyncState = NULL, const DestructibleChunkSyncState * chunkSyncState = NULL) = 0;
00612
00625     virtual bool                    setHitChunkTrackingParams(bool flushHistory, bool startTracking, uint32_t trackingDepth, bool trackAllChunks = true) = 0;
00626
00632     virtual bool                    getHitChunkHistory(const DestructibleHitChunk *& hitChunkContainer, uint32_t & hitChunkCount) const = 0;
00633
00644     virtual bool                    forceChunkHits(const DestructibleHitChunk * hitChunkContainer, uint32_t hitChunkCount, bool removeChunks = true, bool deferredEvent = false, PxVec3 damagePosition = PxVec3(0.0f), PxVec3 damageDirection = PxVec3(0.0f)) = 0;
00645
00651     virtual bool                    getDamageColoringHistory(const DamageEventCoreData *& damageEventCoreDataContainer, uint32_t & damageEventCoreDataCount) const = 0;
00652
00661     virtual bool                    forceDamageColoring(const DamageEventCoreData * damageEventCoreDataContainer, uint32_t damageEventCoreDataCount) = 0;
00662
00666     virtual PxBounds3               getLocalBounds() const = 0;
00667
00671     virtual PxBounds3               getOriginalBounds() const = 0;
00672
00676     virtual bool                    isChunkSolitary(int32_t chunkIndex) const = 0;
00677
00681     virtual PxBounds3               getChunkBounds(uint32_t chunkIndex) const = 0;
00682
00686     virtual PxBounds3               getChunkLocalBounds(uint32_t chunkIndex) const = 0;
00687
00691     virtual bool                    isChunkDestroyed(int32_t chunkIndex) const = 0;
00692
00696     virtual uint32_t                getSupportDepthChunkIndices(uint32_t* const OutChunkIndices, uint32_t MaxOutIndices) const = 0;
00697
00701     virtual uint32_t                getSupportDepth() const = 0;
00702
00706     virtual void                    setDeleteFracturedChunks(bool inDeleteChunkMode) = 0;
00707
00713     virtual DestructibleRenderable* acquireRenderableReference() = 0;
00714
00720     virtual uint32_t                getCustomBehaviorGroupCount() const = 0;
00721
00728     virtual bool                    getBehaviorGroup(nvidia::DestructibleBehaviorGroupDesc& behaviorGroupDesc, int32_t index = -1) const = 0;
00729
00730 protected:
00731     virtual                         ~DestructibleActor() {}
00732 };
00733
00734 PX_POP_PACK
00735
00736 }
00737 } // end namespace nvidia
00738
00739 #endif // DESTRUCTIBLE_ACTOR_H
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: DestructibleActorJoint.h File Reference

  • File List
  • File Members
Classes | Namespaces
DestructibleActorJoint.h File Reference
#include "ModuleDestructible.h"
#include "extensions/PxJoint.h"

Go to the source code of this file.

Classes

class | nvidia::apex::DestructibleActorJointDesc
class | nvidia::apex::DestructibleActorJoint

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: DestructibleActorJoint.h Source File

  • File List
  • File Members
DestructibleActorJoint.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef DESTRUCTIBLE_ACTOR_JOINT_H
00031 #define DESTRUCTIBLE_ACTOR_JOINT_H
00032
00033 #include "ModuleDestructible.h"
00034
00035 #include "extensions/PxJoint.h"
00036
00037
00038 namespace nvidia
00039 {
00040 namespace apex
00041 {
00042
00043 PX_PUSH_PACK_DEFAULT
00044
00048 class DestructibleActorJointDesc : public ApexDesc
00049 {
00050 public:
00051
00055     PX_INLINE               DestructibleActorJointDesc();
00056
00060     PX_INLINE void          setToDefault();
00061
00065     PX_INLINE bool          isValid() const;
00066
00070     physx::PxJointConcreteType::Enum type;
00074     PxRigidActor*           actor[2];
00078     PxVec3                  localAxis[2];
00082     PxVec3                  localAnchor[2];
00086     PxVec3                  localNormal[2];
00087
00092     DestructibleActor*      destructible[2];
00093
00101     int32_t                 attachmentChunkIndex[2];
00102
00103
00113     PxVec3          globalAnchor[2];
00114
00118     PxVec3          globalAxis[2];
00119
00123     PxVec3          globalNormal[2];
00124 };
00125
00126 // DestructibleActorJointDesc inline functions
00127
00128 PX_INLINE DestructibleActorJointDesc::DestructibleActorJointDesc() : ApexDesc()
00129 {
00130     setToDefault();
00131 }
00132
00133 PX_INLINE void DestructibleActorJointDesc::setToDefault()
00134 {
00135     ApexDesc::setToDefault();
00136     for (int i=0; i<2; i++)
00137     {
00138         actor[i] = 0;
00139         localAxis[i]    = PxVec3(0,0,1);
00140         localNormal[i]  = PxVec3(1,0,0);
00141         localAnchor[i]  = PxVec3(0);
00142     }
00143     for (int i = 0; i < 2; ++i)
00144     {
00145         destructible[i] = NULL;
00146         attachmentChunkIndex[i] = ModuleDestructibleConst::INVALID_CHUNK_INDEX;
00147         globalAnchor[i] = PxVec3(0.0f);
00148         globalAxis[i] = PxVec3(0.0f, 0.0f, 1.0f);
00149         globalNormal[i] = PxVec3(1.0f, 0.0f, 0.0f);
00150     }
00151 }
00152
00153 PX_INLINE bool DestructibleActorJointDesc::isValid() const
00154 {
00155     if (destructible[0] == NULL && destructible[1] == NULL)
00156     {
00157         return false;
00158     }
00159
00160     for (int i = 0; i < 2; ++i)
00161     {
00162         if (PxAbs(globalAxis[i].magnitudeSquared() - 1.0f) > 0.1f)
00163         {
00164             return false;
00165         }
00166         if (PxAbs(globalNormal[i].magnitudeSquared() - 1.0f) > 0.1f)
00167         {
00168             return false;
00169         }
00170         //check orthogonal pairs
00171         if (PxAbs(globalAxis[i].dot(globalNormal[i])) > 0.1f)
00172         {
00173             return false;
00174         }
00175     }
00176
00177     return ApexDesc::isValid();
00178 }
00179
00180
00185 class DestructibleActorJoint : public ApexInterface
00186 {
00187 public:
00197     virtual PxJoint*    joint() = 0;
00198
00199 protected:
00200     virtual             ~DestructibleActorJoint() {}
00201 };
00202
00203 PX_POP_PACK
00204
00205 }
00206 } // end namespace nvidia
00207
00208 #endif // DESTRUCTIBLE_ACTOR_JOINT_H
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: DestructibleAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
DestructibleAsset.h File Reference
#include "foundation/Px.h"
#include "FractureToolsAPI.h"
#include "ModuleDestructible.h"
#include "PxFiltering.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::DestructibleDepthParametersFlag
PX_PS4. More...
struct | nvidia::apex::DestructibleDepthParameters
struct | nvidia::apex::DestructibleRTFractureParameters
struct | nvidia::apex::DestructibleRTFractureParameters::FractureGlass
struct | nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
struct | nvidia::apex::DestructibleParametersFlag
struct | nvidia::apex::DestructibleParameters
struct | nvidia::apex::DestructibleInitParametersFlag
struct | nvidia::apex::DestructibleInitParameters
struct | nvidia::apex::DamageSpreadFunction
class | nvidia::apex::DestructibleBehaviorGroupDesc
class | nvidia::apex::DestructibleChunkDesc
class | nvidia::apex::DestructibleGeometryDesc
class | nvidia::apex::DestructibleAssetCookingDesc
struct | nvidia::apex::DestructibleAssetStats
class | nvidia::apex::DestructibleAssetAuthoring
class | nvidia::apex::DestructibleAsset

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | DESTRUCTIBLE_AUTHORING_TYPE_NAME "DestructibleAsset"

Define Documentation

#define DESTRUCTIBLE_AUTHORING_TYPE_NAME "DestructibleAsset"
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: DestructibleAsset.h Source File

  • File List
  • File Members
DestructibleAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef DESTRUCTIBLE_ASSET_H
00031 #define DESTRUCTIBLE_ASSET_H
00032
00033 #define DESTRUCTIBLE_AUTHORING_TYPE_NAME "DestructibleAsset"
00034
00035 #include "foundation/Px.h"
00036 #include "FractureToolsAPI.h"
00037 // TODO: Remove this include when we remove the APEX_RUNTIME_FRACTURE define
00038 #include "ModuleDestructible.h"
00039
00040 #if PX_PHYSICS_VERSION_MAJOR == 3
00041 #include "PxFiltering.h"
00042 #endif
00043
00044 namespace nvidia
00045 {
00046 namespace apex
00047 {
00048
00049 struct IntPair;
00050 class DestructibleActor;
00051 class DestructiblePreview;
00052
00053 PX_PUSH_PACK_DEFAULT
00054 #if !PX_PS4
00055     #pragma warning(push)
00056     #pragma warning(disable:4121)
00057 #endif  //!PX_PS4
00058
00062 struct DestructibleDepthParametersFlag
00063 {
00067     enum Enum
00068     {
00074         OVERRIDE_IMPACT_DAMAGE          = (1 << 0),
00075
00079         OVERRIDE_IMPACT_DAMAGE_VALUE    = (1 << 1),
00080
00084         IGNORE_POSE_UPDATES             = (1 << 2),
00085
00089         IGNORE_RAYCAST_CALLBACKS        = (1 << 3),
00090
00094         IGNORE_CONTACT_CALLBACKS        = (1 << 4),
00095
00099         USER_FLAG_0                     = (1 << 24),
00100         USER_FLAG_1                     = (1 << 25),
00101         USER_FLAG_2                     = (1 << 26),
00102         USER_FLAG_3                     = (1 << 27)
00103     };
00104 };
00105
00106
00110 struct DestructibleDepthParameters
00111 {
00115     PX_INLINE       DestructibleDepthParameters();
00116
00120     PX_INLINE void  setToDefault();
00121
00125     PX_INLINE void  setToMostExpensive();
00126
00130     PX_INLINE bool  overrideImpactDamage() const;
00131
00135     PX_INLINE bool  overrideImpactDamageValue() const;
00136
00140     PX_INLINE bool  ignoresPoseUpdates() const;
00141
00145     PX_INLINE bool  ignoresRaycastCallbacks() const;
00146
00150     PX_INLINE bool  ignoresContactCallbacks() const;
00151
00155     PX_INLINE bool  hasUserFlagSet(uint32_t flagIndex) const;
00156
00160     uint32_t        flags;
00161 };
00162
00163 // DestructibleDepthParameters inline functions
00164
00165 PX_INLINE DestructibleDepthParameters::DestructibleDepthParameters()
00166 {
00167     setToDefault();
00168 }
00169
00170 PX_INLINE void DestructibleDepthParameters::setToDefault()
00171 {
00172     flags = 0;
00173 }
00174
00175 PX_INLINE bool DestructibleDepthParameters::overrideImpactDamage() const
00176 {
00177     return (flags & DestructibleDepthParametersFlag::OVERRIDE_IMPACT_DAMAGE) != 0;
00178 }
00179
00180 PX_INLINE bool DestructibleDepthParameters::overrideImpactDamageValue() const
00181 {
00182     return (flags & DestructibleDepthParametersFlag::OVERRIDE_IMPACT_DAMAGE_VALUE) != 0;
00183 }
00184
00185 PX_INLINE bool DestructibleDepthParameters::ignoresPoseUpdates() const
00186 {
00187     return (flags & DestructibleDepthParametersFlag::IGNORE_POSE_UPDATES) != 0;
00188 }
00189
00190 PX_INLINE bool DestructibleDepthParameters::ignoresRaycastCallbacks() const
00191 {
00192     return (flags & DestructibleDepthParametersFlag::IGNORE_RAYCAST_CALLBACKS) != 0;
00193 }
00194
00195 PX_INLINE bool DestructibleDepthParameters::ignoresContactCallbacks() const
00196 {
00197     return (flags & DestructibleDepthParametersFlag::IGNORE_CONTACT_CALLBACKS) != 0;
00198 }
00199
00200 PX_INLINE bool DestructibleDepthParameters::hasUserFlagSet(uint32_t flagIndex) const
00201 {
00202     switch (flagIndex)
00203     {
00204     case 0:
00205         return (flags & DestructibleDepthParametersFlag::USER_FLAG_0) != 0;
00206     case 1:
00207         return (flags & DestructibleDepthParametersFlag::USER_FLAG_1) != 0;
00208     case 2:
00209         return (flags & DestructibleDepthParametersFlag::USER_FLAG_2) != 0;
00210     case 3:
00211         return (flags & DestructibleDepthParametersFlag::USER_FLAG_3) != 0;
00212     default:
00213         return false;
00214     }
00215 }
00216
00220 struct DestructibleRTFractureParameters
00221 {
00226     bool sheetFracture;
00227
00232     uint32_t depthLimit;
00233
00238     bool destroyIfAtDepthLimit;
00239
00243     float minConvexSize;
00244
00248     float impulseScale;
00249
00253     struct FractureGlass
00254     {
00258         uint32_t numSectors;
00259
00263         float sectorRand;
00264
00268         float firstSegmentSize;
00269
00273         float segmentScale;
00274
00278         float segmentRand;
00279     }glass;
00280
00284     struct FractureAttachment
00285     {
00289         bool posX;
00290
00294         bool negX;
00295
00299         bool posY;
00300
00304         bool negY;
00305
00309         bool posZ;
00310
00314         bool negZ;
00315     }attachment;
00316
00320     PX_INLINE void  setToDefault();
00321 };
00322
00323 PX_INLINE void DestructibleRTFractureParameters::setToDefault()
00324 {
00325     sheetFracture = true;
00326     depthLimit = 2;
00327     destroyIfAtDepthLimit = false;
00328     minConvexSize = 0.02f;
00329     impulseScale = 1.0f;
00330     glass.numSectors = 10;
00331     glass.sectorRand = 0.3f;
00332     glass.firstSegmentSize = 0.06f;
00333     glass.segmentScale = 1.4f;
00334     glass.segmentRand = 0.3f;
00335     attachment.posX = false;
00336     attachment.negX = false;
00337     attachment.posY = false;
00338     attachment.negY = false;
00339     attachment.posZ = false;
00340     attachment.negZ = false;
00341 }
00342
00346 struct DestructibleParametersFlag
00347 {
00351     enum Enum
00352     {
00358         ACCUMULATE_DAMAGE = (1 << 0),
00359
00365         DEBRIS_TIMEOUT =    (1 << 1),
00366
00373         DEBRIS_MAX_SEPARATION = (1 << 2),
00374
00382         CRUMBLE_SMALLEST_CHUNKS =   (1 << 3),
00383
00390         ACCURATE_RAYCASTS = (1 << 4),
00391
00397         USE_VALID_BOUNDS =  (1 << 5),
00398
00404         CRUMBLE_VIA_RUNTIME_FRACTURE =  (1 << 6),
00405     };
00406 };
00407
00408
00412 struct DestructibleParameters
00413 {
00417     PX_INLINE       DestructibleParameters();
00418
00422     PX_INLINE void  setToDefault();
00423
00429     float           damageCap;
00430
00437     float           forceToDamage;
00438
00445     float           impactVelocityThreshold;
00446
00450     uint32_t        minimumFractureDepth;
00451
00457     int32_t         impactDamageDefaultDepth;
00458
00465     int32_t         debrisDepth;
00466
00473     uint32_t        essentialDepth;
00474
00483     float           debrisLifetimeMin;
00484
00486     float           debrisLifetimeMax;
00487
00496     float           debrisMaxSeparationMin;
00497
00499     float           debrisMaxSeparationMax;
00500
00506     float           debrisDestructionProbability;
00507
00513     PxBounds3       validBounds;
00514
00519     float           maxChunkSpeed;
00520
00524     uint32_t        flags;
00525
00530     float           fractureImpulseScale;
00531
00536     uint16_t        damageDepthLimit;
00537
00541     uint8_t         dynamicChunksDominanceGroup;
00542
00547     bool            useDynamicChunksGroupsMask;
00548
00549 #if PX_PHYSICS_VERSION_MAJOR == 3
00550
00553     physx::PxFilterData dynamicChunksFilterData;
00554 #endif
00555
00559     float           supportStrength;
00560
00566     int8_t          legacyChunkBoundsTestSetting;
00567
00573     int8_t          legacyDamageRadiusSpreadSetting;
00574
00578     enum { kDepthParametersCountMax = 16 };
00579
00584     uint32_t        depthParametersCount;
00585
00592     DestructibleDepthParameters depthParameters[kDepthParametersCountMax];
00593
00597     DestructibleRTFractureParameters rtFractureParameters;
00598
00603     bool            alwaysDrawScatterMesh;
00604 };
00605
00606 // DestructibleParameters inline functions
00607
00608 PX_INLINE DestructibleParameters::DestructibleParameters()
00609 {
00610     setToDefault();
00611 }
00612
00613 PX_INLINE void DestructibleParameters::setToDefault()
00614 {
00615     damageCap = 0;
00616     forceToDamage = 0;
00617     impactVelocityThreshold = 0.0f;
00618     minimumFractureDepth = 0;
00619     impactDamageDefaultDepth = -1;
00620     debrisDepth = -1;
00621     essentialDepth = 0;
00622     debrisLifetimeMin = 1.0f;
00623     debrisLifetimeMax = 10.0f;
00624     debrisMaxSeparationMin = 1.0f;
00625     debrisMaxSeparationMax = 10.0f;
00626     debrisDestructionProbability = 0.0f;
00627     validBounds = PxBounds3(PxVec3(-10000.0f), PxVec3(10000.0f));
00628     maxChunkSpeed = 0.0f;
00629     fractureImpulseScale = 0.0f;
00630     damageDepthLimit = UINT16_MAX;
00631     useDynamicChunksGroupsMask = false;
00632 #if PX_PHYSICS_VERSION_MAJOR == 3
00633     dynamicChunksFilterData.word0 = dynamicChunksFilterData.word1 = dynamicChunksFilterData.word2 = dynamicChunksFilterData.word3 = 0;
00634 #endif
00635     supportStrength = -1.0;
00636     legacyChunkBoundsTestSetting = -1;
00637     legacyDamageRadiusSpreadSetting = -1;
00638     dynamicChunksDominanceGroup = 0xFF; // Out of range, so it won't be used.
00639     flags = DestructibleParametersFlag::ACCUMULATE_DAMAGE;
00640     depthParametersCount = 0;
00641     rtFractureParameters.setToDefault();
00642     alwaysDrawScatterMesh = false;
00643 }
00644
00648 struct DestructibleInitParametersFlag
00649 {
00653     enum Enum
00654     {
00661         ASSET_DEFINED_SUPPORT = (1 << 0),
00662
00669         WORLD_SUPPORT = (1 << 1),
00670
00675         FORM_EXTENDED_STRUCTURES =  (1 << 2)
00676     };
00677 };
00678
00682 struct DestructibleInitParameters
00683 {
00687     PX_INLINE       DestructibleInitParameters();
00688
00692     PX_INLINE void  setToDefault();
00693
00698     uint32_t        supportDepth;
00699
00703     uint32_t        flags;
00704 };
00705
00706
00707 // DestructibleInitParameters inline functions
00708
00709 PX_INLINE DestructibleInitParameters::DestructibleInitParameters()
00710 {
00711     setToDefault();
00712 }
00713
00714 PX_INLINE void DestructibleInitParameters::setToDefault()
00715 {
00716     supportDepth = 0;
00717     flags = 0;
00718 }
00719
00723 struct DamageSpreadFunction
00724 {
00725     PX_INLINE       DamageSpreadFunction()
00726     {
00727         setToDefault();
00728     }
00729
00733     PX_INLINE void  setToDefault()
00734     {
00735         minimumRadius = 0.0f;
00736         radiusMultiplier = 1.0f;
00737         falloffExponent = 1.0f;
00738     }
00739
00743     PX_INLINE bool  isValid() const
00744     {
00745         return
00746             minimumRadius >= 0.0f &&
00747             radiusMultiplier >= 0.0f &&
00748             falloffExponent >= 0.0f;
00749     }
00750
00751     float minimumRadius;
00752     float radiusMultiplier;
00753     float falloffExponent;
00754 };
00755
00761 class DestructibleBehaviorGroupDesc : public ApexDesc
00762 {
00763 public:
00767     PX_INLINE       DestructibleBehaviorGroupDesc();
00768
00772     PX_INLINE void  setToDefault();
00773
00777     PX_INLINE bool  isValid() const;
00778
00783     const char*     name;
00784     float           damageThreshold;
00785     float           damageToRadius;
00786     DamageSpreadFunction    damageSpread;
00787     DamageSpreadFunction    damageColorSpread;
00788     PxVec4          damageColorChange;
00789     float           materialStrength;
00790     float           density;
00791     float           fadeOut;
00792     float           maxDepenetrationVelocity;
00793     uint64_t        userData;
00794 };
00795
00796 // DestructibleChunkDesc inline functions
00797
00798 PX_INLINE DestructibleBehaviorGroupDesc::DestructibleBehaviorGroupDesc()
00799 {
00800     setToDefault();
00801 }
00802
00803 PX_INLINE void DestructibleBehaviorGroupDesc::setToDefault()
00804 {
00805     ApexDesc::setToDefault();
00806
00807     // TC_TODO: suitable default values?
00808     name = NULL;
00809     damageThreshold = 1.0f;
00810     damageToRadius = 0.1f;
00811     damageSpread.setToDefault();
00812     damageColorSpread.setToDefault();
00813     damageColorChange.setZero();
00814     materialStrength = 0.0f;
00815     density = 0;
00816     fadeOut = 1;
00817     maxDepenetrationVelocity = PX_MAX_F32;
00818     userData = (uint64_t)0;
00819 }
00820
00821 PX_INLINE bool DestructibleBehaviorGroupDesc::isValid() const
00822 {
00823     // TC_TODO: this good enough?
00824     if (damageThreshold < 0 ||
00825         damageToRadius < 0 ||
00826         !damageSpread.isValid() ||
00827         !damageColorSpread.isValid() ||
00828         materialStrength < 0 ||
00829         density < 0 ||
00830         fadeOut < 0 ||
00831         !(maxDepenetrationVelocity > 0.f))
00832     {
00833         return false;
00834     }
00835
00836     return ApexDesc::isValid();
00837 }
00843 class DestructibleChunkDesc : public ApexDesc
00844 {
00845 public:
00849     PX_INLINE               DestructibleChunkDesc();
00850
00854     PX_INLINE void          setToDefault();
00855
00859     PX_INLINE bool          isValid() const;
00860
00865     bool                    isSupportChunk;
00866
00870     bool                    doNotFracture;
00871
00875     bool                    doNotDamage;
00876
00886     bool                    doNotCrumble;
00887
00888 #if APEX_RUNTIME_FRACTURE
00889
00893     bool                    runtimeFracture;
00894 #endif
00895
00903     bool                    useInstancedRendering;
00904
00910     PxVec3                  instancePositionOffset;
00911
00917     PxVec2                  instanceUVOffset;
00918
00925     uint16_t                meshIndex;
00926
00931     int32_t                 parentIndex;
00932
00936     PxVec3                  surfaceNormal;
00937
00941     int8_t                  behaviorGroupIndex;
00942
00947     uint32_t                scatterMeshCount;
00948
00954     const uint8_t*          scatterMeshIndices;
00955
00962     const PxMat44*          scatterMeshTransforms;
00963 };
00964
00965 // DestructibleChunkDesc inline functions
00966
00967 PX_INLINE DestructibleChunkDesc::DestructibleChunkDesc()
00968 {
00969     setToDefault();
00970 }
00971
00972 PX_INLINE void DestructibleChunkDesc::setToDefault()
00973 {
00974     ApexDesc::setToDefault();
00975     isSupportChunk = false;
00976     doNotFracture = false;
00977     doNotDamage = false;
00978     doNotCrumble = false;
00979 #if APEX_RUNTIME_FRACTURE
00980     runtimeFracture = false;
00981 #endif
00982     useInstancedRendering = false;
00983     instancePositionOffset = PxVec3(0.0f);
00984     instanceUVOffset = PxVec2(0.0f);
00985     meshIndex = 0xFFFF;
00986     parentIndex = -1;
00987     surfaceNormal = PxVec3(0.0f);
00988     behaviorGroupIndex = -1;
00989     scatterMeshCount = 0;
00990     scatterMeshIndices = NULL;
00991     scatterMeshTransforms = NULL;
00992 }
00993
00994 PX_INLINE bool DestructibleChunkDesc::isValid() const
00995 {
00996     if (meshIndex == 0xFFFF)
00997     {
00998         return false;
00999     }
01000
01001     return ApexDesc::isValid();
01002 }
01003
01004
01010 class DestructibleGeometryDesc : public ApexDesc
01011 {
01012 public:
01016     PX_INLINE       DestructibleGeometryDesc();
01017
01021     PX_INLINE void  setToDefault();
01022
01026     PX_INLINE bool  isValid() const;
01027
01032     const nvidia::ExplicitHierarchicalMesh::ConvexHull**    convexHulls;
01033
01039     uint32_t                                                convexHullCount;
01040
01045     const CollisionVolumeDesc*                              collisionVolumeDesc;
01046 };
01047
01048 // DestructibleGeometryDesc inline functions
01049
01050 PX_INLINE DestructibleGeometryDesc::DestructibleGeometryDesc()
01051 {
01052     setToDefault();
01053 }
01054
01055 PX_INLINE void DestructibleGeometryDesc::setToDefault()
01056 {
01057     ApexDesc::setToDefault();
01058     convexHulls = NULL;
01059     convexHullCount = 0;
01060     collisionVolumeDesc = NULL;
01061 }
01062
01063 PX_INLINE bool DestructibleGeometryDesc::isValid() const
01064 {
01065     if (convexHullCount == 0 && collisionVolumeDesc == NULL)
01066     {
01067         return false;
01068     }
01069
01070     if (convexHullCount > 0 && convexHulls == NULL)
01071     {
01072         return false;
01073     }
01074
01075     return ApexDesc::isValid();
01076 }
01077
01078
01084 class DestructibleAssetCookingDesc : public ApexDesc
01085 {
01086 public:
01090     PX_INLINE       DestructibleAssetCookingDesc();
01091
01095     PX_INLINE void  setToDefault();
01096
01100     PX_INLINE bool  isValid() const;
01101
01105     DestructibleChunkDesc*          chunkDescs;
01106
01110     uint32_t                        chunkDescCount;
01111
01115     DestructibleBehaviorGroupDesc   defaultBehaviorGroupDesc;
01116
01120     DestructibleBehaviorGroupDesc*  behaviorGroupDescs;
01121
01125     uint32_t                        behaviorGroupDescCount;
01126
01130     int8_t                          RTFractureBehaviorGroup;
01131
01135     DestructibleGeometryDesc*       geometryDescs;
01136
01140     uint32_t                        geometryDescCount;
01141
01147     nvidia::IntPair*                supportGraphEdges;
01148
01152     uint32_t                        supportGraphEdgeCount;
01153 };
01154
01155 // DestructibleAssetCookingDesc inline functions
01156
01157 PX_INLINE DestructibleAssetCookingDesc::DestructibleAssetCookingDesc()
01158 {
01159     setToDefault();
01160 }
01161
01162 PX_INLINE void DestructibleAssetCookingDesc::setToDefault()
01163 {
01164     ApexDesc::setToDefault();
01165     chunkDescs = NULL;
01166     chunkDescCount = 0;
01167     geometryDescs = NULL;
01168     geometryDescCount = 0;
01169     behaviorGroupDescs = 0;
01170     behaviorGroupDescCount = 0;
01171     supportGraphEdges = 0;
01172     supportGraphEdgeCount = 0;
01173 }
01174
01175 PX_INLINE bool DestructibleAssetCookingDesc::isValid() const
01176 {
01177     if (chunkDescCount == 0 || chunkDescs == NULL)
01178     {
01179         return false;
01180     }
01181
01182     for (uint32_t i = 0; i < chunkDescCount; ++i )
01183     {
01184         if (!chunkDescs[i].isValid())
01185         {
01186             return false;
01187         }
01188     }
01189
01190     if (chunkDescCount >= 65535)
01191     {
01192         return false;
01193     }
01194
01195     if (geometryDescCount == 0 || geometryDescs == NULL)
01196     {
01197         return false;
01198     }
01199
01200     for (uint32_t i = 0; i < geometryDescCount; ++i )
01201     {
01202         if (!geometryDescs[i].isValid())
01203         {
01204             return false;
01205         }
01206     }
01207
01208     if (behaviorGroupDescCount > 127)
01209     {
01210         return false;
01211     }
01212
01213     for (uint32_t i = 0; i < behaviorGroupDescCount; ++i )
01214     {
01215         if (!behaviorGroupDescs[i].isValid())
01216         {
01217             return false;
01218         }
01219     }
01220
01221     return ApexDesc::isValid();
01222 }
01223
01224
01228 struct DestructibleAssetStats
01229 {
01230     uint32_t            totalBytes;
01231     uint32_t            chunkCount;
01232     uint32_t            chunkBytes;
01233     uint32_t            chunkHullDataBytes;
01234     uint32_t            collisionCookedHullDataBytes;
01235     uint32_t            collisionMeshCount;
01236     uint32_t            maxHullVertexCount;
01237     uint32_t            maxHullFaceCount;
01238     uint32_t            chunkWithMaxEdgeCount;
01239     uint32_t            runtimeCookedConvexCount;
01240     RenderMeshAssetStats    renderMeshAssetStats;
01241 };
01242
01246 class DestructibleAssetAuthoring : public AssetAuthoring
01247 {
01248 public:
01249
01259     virtual ExplicitHierarchicalMesh&   getExplicitHierarchicalMesh() = 0;
01260
01266     virtual ExplicitHierarchicalMesh&   getCoreExplicitHierarchicalMesh() = 0;
01267
01273     virtual FractureTools::CutoutSet&   getCutoutSet() = 0;
01274
01286     virtual uint32_t                    partitionMeshByIslands
01287     (
01288         nvidia::ExplicitRenderTriangle* mesh,
01289         uint32_t meshTriangleCount,
01290         uint32_t* meshPartition,
01291         uint32_t meshPartitionMaxCount,
01292         float padding = 0.0001f
01293     ) = 0;
01294
01316     virtual bool                        setRootMesh
01317     (
01318         const ExplicitRenderTriangle* meshTriangles,
01319         uint32_t meshTriangleCount,
01320         const ExplicitSubmeshData* submeshData,
01321         uint32_t submeshCount,
01322         uint32_t* meshPartition = NULL,
01323         uint32_t meshPartitionCount = 0,
01324         int32_t* parentIndices = NULL,
01325         uint32_t parentIndexCount = 0
01326     ) = 0;
01327
01335     virtual bool                        importRenderMeshAssetToRootMesh(const nvidia::RenderMeshAsset& renderMeshAsset, uint32_t maxRootDepth = UINT32_MAX) = 0;
01336
01345     virtual bool                        importDestructibleAssetToRootMesh(const nvidia::DestructibleAsset& destructibleAsset, uint32_t maxRootDepth = UINT32_MAX) = 0;
01346
01359     virtual bool                        setCoreMesh
01360     (
01361         const ExplicitRenderTriangle* mesh,
01362         uint32_t meshTriangleCount,
01363         const ExplicitSubmeshData* submeshData,
01364         uint32_t submeshCount,
01365         uint32_t* meshPartition = NULL,
01366         uint32_t meshPartitionCount = 0
01367     ) = 0;
01368
01393     virtual bool                        buildExplicitHierarchicalMesh
01394     (
01395         ExplicitHierarchicalMesh& hMesh,
01396         const ExplicitRenderTriangle* meshTriangles,
01397         uint32_t meshTriangleCount,
01398         const ExplicitSubmeshData* submeshData,
01399         uint32_t submeshCount,
01400         uint32_t* meshPartition = NULL,
01401         uint32_t meshPartitionCount = 0,
01402         int32_t* parentIndices = NULL,
01403         uint32_t parentIndexCount = 0
01404     ) = 0;
01405
01421     virtual bool                            createHierarchicallySplitMesh
01422     (
01423         const FractureTools::MeshProcessingParameters& meshProcessingParams,
01424         const FractureTools::FractureSliceDesc& desc,
01425         const CollisionDesc& collisionDesc,
01426         bool exportCoreMesh,
01427         int32_t coreMeshImprintSubmeshIndex,
01428         uint32_t randomSeed,
01429         IProgressListener& progressListener,
01430         volatile bool* cancel = NULL
01431     ) = 0;
01432
01449     virtual bool                            createChippedMesh
01450     (
01451         const FractureTools::MeshProcessingParameters& meshProcessingParams,
01452         const FractureTools::FractureCutoutDesc& desc,
01453         const FractureTools::CutoutSet& cutoutSet,
01454         const FractureTools::FractureSliceDesc& sliceDesc,
01455         const FractureTools::FractureVoronoiDesc& voronoiDesc,
01456         const CollisionDesc& collisionDesc,
01457         uint32_t randomSeed,
01458         IProgressListener& progressListener,
01459         volatile bool* cancel = NULL
01460     ) = 0;
01461
01471     virtual void                            buildCutoutSet
01472     (
01473         const uint8_t* pixelBuffer,
01474         uint32_t bufferWidth,
01475         uint32_t bufferHeight,
01476         float snapThreshold,
01477         bool periodic
01478     ) = 0;
01479
01488     virtual bool                            calculateCutoutUVMapping
01489     (
01490         PxMat33& mapping,
01491         const nvidia::ExplicitRenderTriangle& triangle
01492     ) = 0;
01493
01505     virtual bool                            calculateCutoutUVMapping
01506     (
01507         PxMat33& mapping,
01508         const PxVec3& targetDirection
01509     ) = 0;
01510
01526     virtual bool                            createVoronoiSplitMesh
01527     (
01528         const FractureTools::MeshProcessingParameters& meshProcessingParams,
01529         const FractureTools::FractureVoronoiDesc& desc,
01530         const CollisionDesc& collisionDesc,
01531         bool exportCoreMesh,
01532         int32_t coreMeshImprintSubmeshIndex,
01533         uint32_t randomSeed,
01534         IProgressListener& progressListener,
01535         volatile bool* cancel = NULL
01536     ) = 0;
01537
01557     virtual uint32_t                        createVoronoiSitesInsideMesh
01558     (
01559         PxVec3* siteBuffer,
01560         uint32_t* siteChunkIndices,
01561         uint32_t siteCount,
01562         uint32_t* randomSeed,
01563         uint32_t* microgridSize,
01564         BSPOpenMode::Enum meshMode,
01565         IProgressListener& progressListener,
01566         uint32_t chunkIndex = 0xFFFFFFFF
01567     ) = 0;
01568
01591     virtual uint32_t                    createScatterMeshSites
01592     (
01593         uint8_t*                        meshIndices,
01594         PxMat44*                        relativeTransforms,
01595         uint32_t*                       chunkMeshStarts,
01596         uint32_t                        scatterMeshInstancesBufferSize,
01597         uint32_t                        targetChunkCount,
01598         const uint16_t*                 targetChunkIndices,
01599         uint32_t*                       randomSeed,
01600         uint32_t                        scatterMeshAssetCount,
01601         nvidia::RenderMeshAsset**           scatterMeshAssets,
01602         const uint32_t*                 minCount,
01603         const uint32_t*                 maxCount,
01604         const float*                    minScales,
01605         const float*                    maxScales,
01606         const float*                    maxAngles
01607     ) = 0;
01608
01622     virtual void                            visualizeVoronoiCells
01623     (
01624         nvidia::RenderDebugInterface& debugRender,
01625         const PxVec3* sites,
01626         uint32_t siteCount,
01627         const uint32_t* cellColors,
01628         uint32_t cellColorCount,
01629         const PxBounds3& bounds,
01630         uint32_t cellIndex = 0xFFFFFFFF
01631     ) = 0;
01632
01647     virtual bool                            hierarchicallySplitChunk
01648     (
01649         uint32_t chunkIndex,
01650         const FractureTools::MeshProcessingParameters& meshProcessingParams,
01651         const FractureTools::FractureSliceDesc& desc,
01652         const CollisionDesc& collisionDesc,
01653         uint32_t* randomSeed,
01654         IProgressListener& progressListener,
01655         volatile bool* cancel = NULL
01656     ) = 0;
01657
01672     virtual bool                            voronoiSplitChunk
01673     (
01674         uint32_t chunkIndex,
01675         const FractureTools::MeshProcessingParameters& meshProcessingParams,
01676         const FractureTools::FractureVoronoiDesc& desc,
01677         const CollisionDesc& collisionDesc,
01678         uint32_t* randomSeed,
01679         IProgressListener& progressListener,
01680         volatile bool* cancel = NULL
01681     ) = 0;
01682
01692     virtual void                            setBSPTolerances
01693     (
01694         float linearTolerance,
01695         float angularTolerance,
01696         float baseTolerance,
01697         float clipTolerance,
01698         float cleaningTolerance
01699     ) = 0;
01700
01719     virtual void    setBSPBuildParameters
01720     (
01721         float logAreaSigmaThreshold,
01722         uint32_t testSetSize,
01723         float splitWeight,
01724         float imbalanceWeight
01725     ) = 0;
01726
01727
01736     virtual ExplicitHierarchicalMesh::ConvexHull*   createExplicitHierarchicalMeshConvexHull() = 0;
01737
01744     virtual uint32_t                        buildSliceMesh(const ExplicitRenderTriangle*& mesh, const FractureTools::NoiseParameters& noiseParameters, const PxPlane& slicePlane, uint32_t randomSeed) = 0;
01745
01750     virtual void                            serializeFractureToolState(PxFileBuf& stream, nvidia::ExplicitHierarchicalMesh::Embedding& embedding) const = 0;
01751
01756     virtual void                            deserializeFractureToolState(PxFileBuf& stream, nvidia::ExplicitHierarchicalMesh::Embedding& embedding) = 0;
01757
01761     virtual void                            setChunkOverlapsCacheDepth(int32_t depth = -1) = 0;
01762
01766     virtual const RenderMeshAsset*          getRenderMeshAsset() const = 0;
01767
01775     virtual bool                            setRenderMeshAsset(RenderMeshAsset*) = 0;
01776
01784     virtual bool                            setScatterMeshAssets(RenderMeshAsset** scatterMeshAssetArray, uint32_t scatterMeshAssetArraySize) = 0;
01785
01787     virtual uint32_t                        getScatterMeshAssetCount() const = 0;
01788
01790     virtual RenderMeshAsset* const *        getScatterMeshAssets() const = 0;
01791
01795     virtual uint32_t                        getInstancedChunkMeshCount() const = 0;
01796
01800     virtual void                            setDestructibleParameters(const DestructibleParameters&) = 0;
01801
01806     virtual DestructibleParameters          getDestructibleParameters() const = 0;
01807
01811     virtual void                            setDestructibleInitParameters(const DestructibleInitParameters&) = 0;
01812
01816     virtual DestructibleInitParameters      getDestructibleInitParameters() const = 0;
01817
01821     virtual void                            setCrumbleEmitterName(const char*) = 0;
01822
01826     virtual void                            setDustEmitterName(const char*) = 0;
01827
01831     virtual void                            setFracturePatternName(const char*) = 0;
01832
01839     virtual void                            setNeighborPadding(float neighborPadding) = 0;
01840
01844     virtual float                           getNeighborPadding() const = 0;
01845
01860     virtual void                            cookChunks( const DestructibleAssetCookingDesc& cookingDesc, bool cacheOverlaps = true,
01861                                                         uint32_t* chunkIndexMapUser2Apex = NULL, uint32_t* chunkIndexMapApex2User = NULL, uint32_t chunkIndexMapCount = 0) = 0;
01862
01867     virtual float                           getFractureImpulseScale() const = 0;
01868
01874     virtual float                           getImpactVelocityThreshold() const = 0;
01875
01879     virtual uint32_t                        getChunkCount() const = 0;
01880
01884     virtual uint32_t                        getDepthCount() const = 0;
01885
01890     virtual uint32_t                        getChunkChildCount(uint32_t chunkIndex) const = 0;
01891
01897     virtual int32_t                         getChunkChild(uint32_t chunkIndex, uint32_t childIndex) const = 0;
01898
01903     virtual PxVec3                          getChunkPositionOffset(uint32_t chunkIndex) const = 0;
01904
01909     virtual PxVec2                          getChunkUVOffset(uint32_t chunkIndex) const = 0;
01910
01914     virtual uint32_t                        getPartIndex(uint32_t chunkIndex) const = 0;
01915
01922     virtual void                            trimCollisionGeometry(const uint32_t* partIndices, uint32_t partIndexCount, float maxTrimFraction = 0.2f) = 0;
01923
01927     virtual void                            getStats(DestructibleAssetStats& stats) const = 0;
01928
01935     virtual void                            cacheChunkOverlapsUpToDepth(int32_t depth = -1) = 0;
01936
01943     virtual void                            clearChunkOverlaps(int32_t depth = -1, bool keepCachedFlag = false) = 0;
01944
01949     virtual void                            addChunkOverlaps(IntPair* supportGraphEdges, uint32_t numSupportGraphEdges) = 0;
01950
01959     virtual void                            removeChunkOverlaps(IntPair* supportGraphEdges, uint32_t numSupportGraphEdges, bool keepCachedFlagIfEmpty) = 0;
01960
01966     virtual uint32_t                        getCachedOverlapCountAtDepth(uint32_t depth) = 0;
01967
01974     virtual const IntPair*                  getCachedOverlapsAtDepth(uint32_t depth) = 0;
01975
01985     virtual void                            applyTransformation(const PxMat44& transformation, float scale) = 0;
01986
01995     virtual void                            applyTransformation(const PxMat44& transformation) = 0;
01996
02002     virtual bool                            setPlatformMaxDepth(PlatformTag platform, uint32_t maxDepth) = 0;
02003
02009     virtual bool                            removePlatformMaxDepth(PlatformTag platform) = 0;
02010
02014     virtual uint32_t                        getActorTransformCount() const = 0;
02015
02020     virtual const PxMat44*                  getActorTransforms() const = 0;
02021
02028     virtual void                            appendActorTransforms(const PxMat44* transforms, uint32_t transformCount) = 0;
02029
02033     virtual void                            clearActorTransforms() = 0;
02034 };
02035
02039 class DestructibleAsset : public Asset
02040 {
02041 public:
02045     enum ChunkFlags
02046     {
02047         ChunkEnvironmentallySupported =     (1 << 0),
02048         ChunkAndDescendentsDoNotFracture =  (1 << 1),
02049         ChunkDoesNotFracture =              (1 << 2),
02050         ChunkDoesNotCrumble =               (1 << 3),
02051 #if APEX_RUNTIME_FRACTURE
02052         ChunkRuntimeFracture =              (1 << 4),
02053 #endif
02054         ChunkIsInstanced =                  (1 << 16)
02055     };
02056
02065     virtual void                            releaseDestructibleActor(DestructibleActor& actor) = 0;
02066
02067
02076     virtual DestructibleActor*              createDestructibleActorFromDeserializedState(::NvParameterized::Interface* actorParams, Scene& apexScene) = 0;
02077
02082     virtual DestructibleParameters          getDestructibleParameters() const = 0;
02083
02087     virtual DestructibleInitParameters      getDestructibleInitParameters() const = 0;
02088
02093     virtual const char*                     getCrumbleEmitterName() const = 0;
02094
02099     virtual const char*                     getDustEmitterName() const = 0;
02100
02104     virtual uint32_t                        getChunkCount() const = 0;
02105
02109     virtual uint32_t                        getDepthCount() const = 0;
02110
02114     virtual const RenderMeshAsset*          getRenderMeshAsset() const = 0;
02115
02122     virtual bool                            setRenderMeshAsset(RenderMeshAsset*) = 0;
02123
02125     virtual uint32_t                        getScatterMeshAssetCount() const = 0;
02126
02128     virtual RenderMeshAsset* const *        getScatterMeshAssets() const = 0;
02129
02133     virtual uint32_t                        getInstancedChunkMeshCount() const = 0;
02134
02138     virtual void                            getStats(DestructibleAssetStats& stats) const = 0;
02139
02146     virtual void                            cacheChunkOverlapsUpToDepth(int32_t depth = -1) = 0;
02147
02155     virtual void                            clearChunkOverlaps(int32_t depth = -1, bool keepCachedFlag = false) = 0;
02156
02164     virtual void                            addChunkOverlaps(IntPair* supportGraphEdges, uint32_t numSupportGraphEdges) = 0;
02165
02174     virtual void                            removeChunkOverlaps(IntPair* supportGraphEdges, uint32_t numSupportGraphEdges, bool keepCachedFlagIfEmpty) = 0;
02175
02180     virtual uint32_t                        getCachedOverlapCountAtDepth(uint32_t depth) const = 0;
02181
02188     virtual const IntPair*                  getCachedOverlapsAtDepth(uint32_t depth) const = 0;
02189
02194     virtual PxVec3                          getChunkPositionOffset(uint32_t chunkIndex) const = 0;
02195
02200     virtual PxVec2                          getChunkUVOffset(uint32_t chunkIndex) const = 0;
02201
02205     virtual uint32_t                        getChunkFlags(uint32_t chunkIndex) const = 0;
02206
02210     virtual uint16_t                        getChunkDepth(uint32_t chunkIndex) const = 0;
02211
02216     virtual int32_t                         getChunkParentIndex(uint32_t chunkIndex) const = 0;
02217
02221     virtual PxBounds3                       getChunkActorLocalBounds(uint32_t chunkIndex) const = 0;
02222
02226     virtual uint32_t                        getPartIndex(uint32_t chunkIndex) const = 0;
02227
02231     virtual uint32_t                        getPartConvexHullCount(const uint32_t partIndex) const = 0;
02232
02236     virtual NvParameterized::Interface**    getPartConvexHullArray(const uint32_t partIndex) const = 0;
02237
02241     virtual uint32_t                        getActorTransformCount() const = 0;
02242
02247     virtual const PxMat44*                  getActorTransforms() const = 0;
02248
02258     virtual void                            applyTransformation(const PxMat44& transformation, float scale) = 0;
02259
02268     virtual void                            applyTransformation(const PxMat44& transformation) = 0;
02269
02274     virtual bool                            rebuildCollisionGeometry(uint32_t partIndex, const DestructibleGeometryDesc& geometryDesc) = 0;
02275
02276 protected:
02278     virtual                                 ~DestructibleAsset() {}
02279 };
02280
02281
02282 #if !PX_PS4
02283     #pragma warning(pop)
02284 #endif  //!PX_PS4
02285
02286 PX_POP_PACK
02287
02288 }
02289 } // end namespace nvidia
02290
02291 #endif // DESTRUCTIBLE_ASSET_H
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: DestructiblePreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
DestructiblePreview.h File Reference
#include "AssetPreview.h"
#include "RenderMeshActor.h"

Go to the source code of this file.

Classes

class | nvidia::apex::DestructiblePreview
Destructible module's derivation AssetPreview. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: DestructiblePreview.h Source File

  • File List
  • File Members
DestructiblePreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef DESTRUCTIBLE_PREVIEW_H
00031 #define DESTRUCTIBLE_PREVIEW_H
00032
00033 #include "AssetPreview.h"
00034 #include "RenderMeshActor.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043
00048 class DestructiblePreview : public AssetPreview
00049 {
00050 public:
00051
00055     virtual const RenderMeshActor* getRenderMeshActor() const = 0;
00056
00062     virtual void    setExplodeView(uint32_t depth, float explode) = 0;
00063
00064 protected:
00065     DestructiblePreview() {}
00066 };
00067
00068 PX_POP_PACK
00069
00070 }
00071 } // end namespace nvidia
00072
00073 #endif // DESTRUCTIBLE_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: DestructibleRenderable.h File Reference

  • File List
  • File Members
Classes | Namespaces
DestructibleRenderable.h File Reference
#include "foundation/Px.h"
#include "ApexInterface.h"
#include "Renderable.h"
#include "ModuleDestructible.h"

Go to the source code of this file.

Classes

class | nvidia::apex::DestructibleRenderable

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: DestructibleRenderable.h Source File

  • File List
  • File Members
DestructibleRenderable.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef DESTRUCTIBLE_RENDERABLE_H
00031 #define DESTRUCTIBLE_RENDERABLE_H
00032
00033 #include "foundation/Px.h"
00034 #include "ApexInterface.h"
00035 #include "Renderable.h"
00036 #include "ModuleDestructible.h"
00037
00038 namespace nvidia
00039 {
00040 namespace apex
00041 {
00042
00043 PX_PUSH_PACK_DEFAULT
00044
00045
00049 class DestructibleRenderable : public ApexInterface, public Renderable
00050 {
00051 public:
00055     virtual RenderMeshActor*    getRenderMeshActor(DestructibleActorMeshType::Enum type = DestructibleActorMeshType::Skinned) const = 0;
00056
00057 protected:
00058     virtual ~DestructibleRenderable() {}
00059 };
00060
00061 PX_POP_PACK
00062
00063 }
00064 } // end namespace nvidia
00065
00066 #endif // DESTRUCTIBLE_RENDERABLE_H
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: ExplicitHierarchicalMesh.h File Reference

  • File List
  • File Members
Classes | Namespaces
ExplicitHierarchicalMesh.h File Reference
#include "foundation/Px.h"
#include "IProgressListener.h"
#include "RenderMeshAsset.h"
#include "ConvexHullMethod.h"
#include "foundation/PxPlane.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::ExplicitVertexFormat
struct | nvidia::apex::ExplicitSubmeshData
struct | nvidia::apex::CollisionVolumeDesc
struct | nvidia::apex::CollisionDesc
struct | nvidia::apex::FractureMethod
struct | nvidia::apex::FractureMaterialDesc
struct | nvidia::apex::MaterialFrame
class | nvidia::apex::DisplacementMapVolume
struct | nvidia::apex::BSPOpenMode
class | nvidia::apex::ExplicitHierarchicalMesh
class | nvidia::apex::ExplicitHierarchicalMesh::Embedding
class | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: ExplicitHierarchicalMesh.h Source File

  • File List
  • File Members
ExplicitHierarchicalMesh.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EXPLICIT_HIERARCHICAL_MESH_H
00031 #define EXPLICIT_HIERARCHICAL_MESH_H
00032
00033 #include "foundation/Px.h"
00034 #include "IProgressListener.h"
00035 #include "RenderMeshAsset.h"
00036 #include "ConvexHullMethod.h"
00037 #include "foundation/PxPlane.h"
00038
00039 namespace nvidia
00040 {
00041 namespace apex
00042 {
00043
00044 PX_PUSH_PACK_DEFAULT
00045
00051 struct ExplicitVertexFormat
00052 {
00054     uint32_t            mWinding;
00055
00057     bool                mHasStaticPositions;
00058
00060     bool                mHasStaticNormals;
00061
00063     bool                mHasStaticTangents;
00064
00066     bool                mHasStaticBinormals;
00067
00069     bool                mHasStaticColors;
00070
00072     bool                mHasStaticSeparateBoneBuffer;
00073
00075     bool                mHasStaticDisplacements;
00076
00078     bool                mHasDynamicPositions;
00079
00081     bool                mHasDynamicNormals;
00082
00084     bool                mHasDynamicTangents;
00085
00087     bool                mHasDynamicBinormals;
00088
00090     bool                mHasDynamicColors;
00091
00093     bool                mHasDynamicSeparateBoneBuffer;
00094
00096     bool                mHasDynamicDisplacements;
00097
00099     uint32_t            mUVCount;
00100
00102     uint32_t            mBonesPerVertex;
00103
00105     ExplicitVertexFormat()
00106     {
00107         clear();
00108     }
00109
00131     void    clear()
00132     {
00133         mWinding = RenderCullMode::CLOCKWISE;
00134         mHasStaticPositions = false;
00135         mHasStaticNormals = false;
00136         mHasStaticTangents = false;
00137         mHasStaticBinormals = false;
00138         mHasStaticColors = false;
00139         mHasStaticSeparateBoneBuffer = false;
00140         mHasStaticDisplacements = false;
00141         mHasDynamicPositions = false;
00142         mHasDynamicNormals = false;
00143         mHasDynamicTangents = false;
00144         mHasDynamicBinormals = false;
00145         mHasDynamicColors = false;
00146         mHasDynamicSeparateBoneBuffer = false;
00147         mHasDynamicDisplacements = false;
00148         mUVCount = 0;
00149         mBonesPerVertex = 0;
00150     }
00151
00155     bool    operator == (const ExplicitVertexFormat& data) const
00156     {
00157         if (mWinding != data.mWinding)
00158         {
00159             return false;
00160         }
00161         if (mHasStaticPositions != data.mHasStaticPositions ||
00162                 mHasStaticNormals != data.mHasStaticNormals ||
00163                 mHasStaticTangents != data.mHasStaticTangents ||
00164                 mHasStaticBinormals != data.mHasStaticBinormals ||
00165                 mHasStaticColors != data.mHasStaticColors ||
00166                 mHasStaticSeparateBoneBuffer != data.mHasStaticSeparateBoneBuffer ||
00167                 mHasStaticDisplacements != data.mHasStaticDisplacements)
00168         {
00169             return false;
00170         }
00171         if (mHasDynamicPositions != data.mHasDynamicPositions ||
00172                 mHasDynamicNormals != data.mHasDynamicNormals ||
00173                 mHasDynamicTangents != data.mHasDynamicTangents ||
00174                 mHasDynamicBinormals != data.mHasDynamicBinormals ||
00175                 mHasDynamicColors != data.mHasDynamicColors ||
00176                 mHasDynamicSeparateBoneBuffer != data.mHasDynamicSeparateBoneBuffer ||
00177                 mHasDynamicDisplacements != data.mHasDynamicDisplacements)
00178         {
00179             return false;
00180         }
00181         if (mUVCount != data.mUVCount)
00182         {
00183             return false;
00184         }
00185         return true;
00186     }
00187
00191     bool    operator != (const ExplicitVertexFormat& data) const
00192     {
00193         return !(*this == data);
00194     }
00195
00199     void    copyToVertexFormat(VertexFormat* format) const
00200     {
00201         format->reset();
00202         uint32_t bi;
00203         if (mHasStaticPositions)
00204         {
00205             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::POSITION));
00206             format->setBufferFormat(bi, RenderDataFormat::FLOAT3);
00207             format->setBufferAccess(bi, mHasDynamicPositions ? RenderDataAccess::DYNAMIC :  RenderDataAccess::STATIC);
00208         }
00209         if (mHasStaticNormals)
00210         {
00211             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::NORMAL));
00212             format->setBufferFormat(bi, RenderDataFormat::FLOAT3);
00213             format->setBufferAccess(bi, mHasDynamicNormals ? RenderDataAccess::DYNAMIC :  RenderDataAccess::STATIC);
00214         }
00215         if (mHasStaticTangents)
00216         {
00217             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::TANGENT));
00218             format->setBufferFormat(bi, RenderDataFormat::FLOAT3);
00219             format->setBufferAccess(bi, mHasDynamicTangents ? RenderDataAccess::DYNAMIC :  RenderDataAccess::STATIC);
00220         }
00221         if (mHasStaticBinormals)
00222         {
00223             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BINORMAL));
00224             format->setBufferFormat(bi, RenderDataFormat::FLOAT3);
00225             format->setBufferAccess(bi, mHasDynamicBinormals ? RenderDataAccess::DYNAMIC :  RenderDataAccess::STATIC);
00226         }
00227         if (mHasStaticDisplacements)
00228         {
00229             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::DISPLACEMENT_TEXCOORD));
00230             format->setBufferFormat(bi, RenderDataFormat::FLOAT3);
00231             format->setBufferAccess(bi, mHasDynamicDisplacements ? RenderDataAccess::DYNAMIC : RenderDataAccess::STATIC);
00232             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::DISPLACEMENT_FLAGS));
00233             format->setBufferFormat(bi, RenderDataFormat::UINT1);
00234             format->setBufferAccess(bi, mHasDynamicDisplacements ? RenderDataAccess::DYNAMIC : RenderDataAccess::STATIC);
00235         }
00236         if (mUVCount > 0)
00237         {
00238             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::TEXCOORD0));
00239             format->setBufferFormat(bi, RenderDataFormat::FLOAT2);
00240         }
00241         if (mUVCount > 1)
00242         {
00243             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::TEXCOORD1));
00244             format->setBufferFormat(bi, RenderDataFormat::FLOAT2);
00245         }
00246         if (mUVCount > 2)
00247         {
00248             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::TEXCOORD2));
00249             format->setBufferFormat(bi, RenderDataFormat::FLOAT2);
00250         }
00251         if (mUVCount > 3)
00252         {
00253             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::TEXCOORD3));
00254             format->setBufferFormat(bi, RenderDataFormat::FLOAT2);
00255         }
00256         switch (mBonesPerVertex)
00257         {
00258         case 1:
00259             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_INDEX));
00260             format->setBufferFormat(bi, RenderDataFormat::USHORT1);
00261             break;
00262         case 2:
00263             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_INDEX));
00264             format->setBufferFormat(bi, RenderDataFormat::USHORT2);
00265             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_WEIGHT));
00266             format->setBufferFormat(bi, RenderDataFormat::FLOAT2);
00267             break;
00268         case 3:
00269             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_INDEX));
00270             format->setBufferFormat(bi, RenderDataFormat::USHORT3);
00271             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_WEIGHT));
00272             format->setBufferFormat(bi, RenderDataFormat::FLOAT3);
00273             break;
00274         case 4:
00275             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_INDEX));
00276             format->setBufferFormat(bi, RenderDataFormat::USHORT4);
00277             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_WEIGHT));
00278             format->setBufferFormat(bi, RenderDataFormat::FLOAT4);
00279             break;
00280         }
00281
00282         format->setHasSeparateBoneBuffer(mHasStaticSeparateBoneBuffer);
00283         format->setWinding((RenderCullMode::Enum)mWinding);
00284     }
00285 };
00286
00287
00295 struct ExplicitSubmeshData
00296 {
00300     enum
00301     {
00302         MaterialNameBufferSize = 1024
00303     };
00304
00308     char                    mMaterialName[MaterialNameBufferSize];
00309
00314     ExplicitVertexFormat    mVertexFormat;
00315
00319     bool    operator == (const ExplicitSubmeshData& data) const
00320     {
00321         return !::strcmp(mMaterialName, data.mMaterialName) && mVertexFormat == data.mVertexFormat;
00322     }
00323
00327     bool    operator != (const ExplicitSubmeshData& data) const
00328     {
00329         return !(*this == data);
00330     }
00331 };
00332
00333
00337 struct CollisionVolumeDesc
00338 {
00339     CollisionVolumeDesc()
00340     {
00341         setToDefault();
00342     }
00343
00347     void setToDefault()
00348     {
00349         mHullMethod = ConvexHullMethod::CONVEX_DECOMPOSITION;
00350         mConcavityPercent = 4.0f;
00351         mMergeThreshold = 4.0f;
00352         mRecursionDepth = 0;
00353         mMaxVertexCount = 0;
00354         mMaxEdgeCount = 0;
00355         mMaxFaceCount = 0;
00356     }
00357
00362     ConvexHullMethod::Enum  mHullMethod;
00363
00368     float                   mConcavityPercent;
00369
00374     float                   mMergeThreshold;
00375
00382     uint32_t                mRecursionDepth;
00383
00388     uint32_t                mMaxVertexCount;
00389
00394     uint32_t                mMaxEdgeCount;
00395
00400     uint32_t                mMaxFaceCount;
00401 };
00402
00403
00407 struct CollisionDesc
00408 {
00418     unsigned                mDepthCount;
00419
00423     CollisionVolumeDesc*    mVolumeDescs;
00424
00430     float                   mMaximumTrimming;
00431
00433     CollisionDesc()
00434     {
00435         setToDefault();
00436     }
00437
00441     void setToDefault()
00442     {
00443         mDepthCount = 0;
00444         mVolumeDescs = NULL;
00445         mMaximumTrimming = 0.2f;
00446     }
00447 };
00448
00449
00454 struct FractureMethod
00455 {
00459     enum Enum
00460     {
00461         Unknown,
00462         Slice,
00463         Cutout,
00464         Voronoi,
00465
00466         FractureMethodCount
00467     };
00468 };
00469
00470
00476 struct FractureMaterialDesc
00477 {
00481     PxVec2  uvScale;
00482
00486     PxVec2  uvOffset;
00487
00492     PxVec3  tangent;
00493
00497     float   uAngle;
00498
00503     uint32_t interiorSubmeshIndex;
00504
00506     FractureMaterialDesc()
00507     {
00508         setToDefault();
00509     }
00510
00519     void    setToDefault()
00520     {
00521         uvScale = PxVec2(1.0f);
00522         uvOffset = PxVec2(0.0f);
00523         tangent = PxVec3(0.0f);
00524         uAngle = 0.0f;
00525         interiorSubmeshIndex = 0;
00526     }
00527 };
00528
00529
00534 struct MaterialFrame
00535 {
00536     MaterialFrame() :
00537         mCoordinateSystem(PxVec4(1.0f)),
00538         mUVPlane(PxVec3(0.0f, 0.0f, 1.0f), 0.0f),
00539         mUVScale(1.0f),
00540         mUVOffset(0.0f),
00541         mFractureMethod(FractureMethod::Unknown),
00542         mFractureIndex(-1),
00543         mSliceDepth(0)
00544     {
00545     }
00546
00550     void    buildCoordinateSystemFromMaterialDesc(const nvidia::FractureMaterialDesc& materialDesc, const PxPlane& plane)
00551             {
00552                 PxVec3 zAxis = plane.n;
00553                 zAxis.normalize();
00554                 PxVec3 xAxis = materialDesc.tangent;
00555                 PxVec3 yAxis = zAxis.cross(xAxis);
00556                 const float l2 = yAxis.magnitudeSquared();
00557                 if (l2 > PX_EPS_F32*PX_EPS_F32)
00558                 {
00559                     yAxis *= PxRecipSqrt(l2);
00560                 }
00561                 else
00562                 {
00563                     uint32_t maxDir =  PxAbs(plane.n.x) > PxAbs(plane.n.y) ?
00564                         (PxAbs(plane.n.x) > PxAbs(plane.n.z) ? 0u : 2u) :
00565                         (PxAbs(plane.n.y) > PxAbs(plane.n.z) ? 1u : 2u);
00566                     xAxis = PxMat33(PxIdentity)[(maxDir + 1) % 3];
00567                     yAxis = zAxis.cross(xAxis);
00568                     yAxis.normalize();
00569                 }
00570                 xAxis = yAxis.cross(zAxis);
00571
00572                 const float c = PxCos(materialDesc.uAngle);
00573                 const float s = PxSin(materialDesc.uAngle);
00574
00575                 mCoordinateSystem.column0 = PxVec4(c*xAxis + s*yAxis, 0.0f);
00576                 mCoordinateSystem.column1 = PxVec4(c*yAxis - s*xAxis, 0.0f);
00577                 mCoordinateSystem.column2 = PxVec4(zAxis, 0.0f);
00578                 mCoordinateSystem.setPosition(plane.project(PxVec3(0.0f)));
00579
00580                 mUVPlane = plane;
00581                 mUVScale = materialDesc.uvScale;
00582                 mUVOffset = materialDesc.uvOffset;
00583             }
00584
00585     PxMat44 mCoordinateSystem;
00586     PxPlane mUVPlane;
00587     PxVec2  mUVScale;
00588     PxVec2  mUVOffset;
00589     uint32_t    mFractureMethod;
00590     int32_t mFractureIndex;
00591     uint32_t    mSliceDepth;
00592 };
00593
00594
00605 class DisplacementMapVolume
00606 {
00607 public:
00614     virtual void getData(uint32_t& width, uint32_t& height, uint32_t& depth, uint32_t& size, unsigned char const** ppData) const = 0;
00615
00616     virtual ~DisplacementMapVolume() { }
00617 };
00618
00619
00627 struct BSPOpenMode
00628 {
00632     enum Enum
00633     {
00634         Automatic,
00635         Closed,
00636         Open,
00637
00638         BSPOpenModeCount
00639     };
00640 };
00641
00642
00651 class ExplicitHierarchicalMesh
00652 {
00653 public:
00655     enum Enum
00656     {
00661         VisualizeMeshBSPOutsideRegions  = (1 << 0),
00662
00667         VisualizeMeshBSPInsideRegions   = (1 << 1),
00668
00674         VisualizeMeshBSPSingleRegion    = (1 << 8),
00675
00677         VisualizeSliceBSPOutsideRegions = (1 << 16),
00678
00680         VisualizeSliceBSPInsideRegions  = (1 << 17),
00681
00683         VisualizeSliceBSPSingleRegion   = (1 << 24),
00684
00685         VisualizeMeshBSPAllRegions      = VisualizeMeshBSPOutsideRegions | VisualizeMeshBSPInsideRegions
00686     };
00687
00693     class Embedding
00694     {
00695     public:
00699         enum DataType
00700         {
00701             MaterialLibrary
00702         };
00703
00707         virtual void    serialize(PxFileBuf& stream, Embedding::DataType type) const = 0;
00708
00712         virtual void    deserialize(PxFileBuf& stream, Embedding::DataType type, uint32_t version) = 0;
00713     };
00714
00718     class ConvexHull
00719     {
00720     protected:
00721         ConvexHull()
00722         {
00723         }
00724
00725         virtual ~ConvexHull()
00726         {
00727         }
00728
00729     public:
00733         virtual void                    buildFromPoints(const void* points, uint32_t numPoints, uint32_t pointStrideBytes) = 0;
00734
00738         virtual const PxBounds3&        getBounds() const = 0;
00739
00743         virtual float                   getVolume() const = 0;
00744
00748         virtual uint32_t                getVertexCount() const = 0;
00749
00754         virtual PxVec3                  getVertex(uint32_t vertexIndex) const = 0;
00755
00759         virtual uint32_t                getEdgeCount() const = 0;
00760
00766         virtual PxVec3                  getEdgeEndpoint(uint32_t edgeIndex, uint32_t whichEndpoint) const = 0;
00767
00771         virtual uint32_t                getPlaneCount() const = 0;
00772
00777         virtual PxPlane                 getPlane(uint32_t planeIndex) const = 0;
00778
00806         virtual bool                    rayCast(float& in, float& out, const PxVec3& orig, const PxVec3& dir,
00807                                                 const PxTransform& localToWorldRT, const PxVec3& scale, PxVec3* normal = NULL) const = 0;
00816         virtual bool                    reduceHull(uint32_t maxVertexCount, uint32_t maxEdgeCount, uint32_t maxFaceCount, bool inflated) = 0;
00817
00821         virtual void                    release() = 0;
00822     };
00823
00831     virtual void                        clear(bool keepRoot = false) = 0;
00832
00837     virtual int32_t                     maxDepth() const = 0;
00838
00842     virtual uint32_t                    partCount() const = 0;
00843
00847     virtual uint32_t                    chunkCount() const = 0;
00848
00853     virtual int32_t*                    parentIndex(uint32_t chunkIndex) = 0;
00854
00859     virtual uint64_t                    chunkUniqueID(uint32_t chunkIndex) = 0;
00860
00864     virtual int32_t*                    partIndex(uint32_t chunkIndex) = 0;
00865
00869     virtual PxVec3*                     instancedPositionOffset(uint32_t chunkIndex) = 0;
00870
00874     virtual PxVec2*                     instancedUVOffset(uint32_t chunkIndex) = 0;
00875
00880     virtual uint32_t                    meshTriangleCount(uint32_t partIndex) const = 0;
00881
00886     virtual ExplicitRenderTriangle*     meshTriangles(uint32_t partIndex) = 0;
00887
00891     virtual PxBounds3                   meshBounds(uint32_t partIndex) const = 0;
00892
00896     virtual PxBounds3                   chunkBounds(uint32_t chunkIndex) const = 0;
00897
00902     virtual uint32_t*                   chunkFlags(uint32_t chunkIndex) const = 0;
00903
00907     virtual void                        buildCollisionGeometryForPart(uint32_t partIndex, const CollisionVolumeDesc& desc) = 0;
00908
00916     virtual void                        buildCollisionGeometryForRootChunkParts(const CollisionDesc& desc, bool aggregateRootChunkParentCollision = true) = 0;
00917
00921     virtual void                        reduceHulls(const CollisionDesc& desc, bool inflated) = 0;
00922
00926     virtual uint32_t                    convexHullCount(uint32_t partIndex) const = 0;
00927
00931     virtual const ConvexHull**          convexHulls(uint32_t partIndex) const = 0;
00932
00936     virtual PxVec3*                     surfaceNormal(uint32_t partIndex) = 0;
00937
00941     virtual const DisplacementMapVolume&    displacementMapVolume() const = 0;
00942
00948     virtual uint32_t                    submeshCount() const = 0;
00949
00953     virtual ExplicitSubmeshData*        submeshData(uint32_t submeshIndex) = 0;
00954
00959     virtual uint32_t                    addSubmesh(const ExplicitSubmeshData& submeshData) = 0;
00960
00969     virtual uint32_t                    getMaterialFrameCount() const = 0;
00970     virtual nvidia::MaterialFrame       getMaterialFrame(uint32_t index) const = 0;
00971     virtual void                        setMaterialFrame(uint32_t index, const nvidia::MaterialFrame& materialFrame) = 0;
00972     virtual uint32_t                    addMaterialFrame() = 0;
00973
00978     virtual void                        serialize(PxFileBuf& stream, Embedding& embedding) const = 0;
00979
00984     virtual void                        deserialize(PxFileBuf& stream, Embedding& embedding) = 0;
00985
00989     virtual void                        set(const ExplicitHierarchicalMesh& mesh) = 0;
00990
00999     virtual void                        calculateMeshBSP(uint32_t randomSeed, IProgressListener* progressListener = NULL, const uint32_t* microgridSize = NULL, BSPOpenMode::Enum meshMode = BSPOpenMode::Automatic) = 0;
01000
01004     virtual void                        replaceInteriorSubmeshes(uint32_t partIndex, uint32_t frameCount, uint32_t* frameIndices, uint32_t submeshIndex) = 0;
01005
01011     virtual void                        visualize(RenderDebugInterface& debugRender, uint32_t flags, uint32_t index = 0) const = 0;
01012
01016     virtual void                        release() = 0;
01017
01018 protected:
01024     ExplicitHierarchicalMesh() {}
01025     virtual                             ~ExplicitHierarchicalMesh() {}
01026
01027 private:
01029     ExplicitHierarchicalMesh&           operator = (const ExplicitHierarchicalMesh&)
01030     {
01031         return *this;
01032     }
01033 };
01034
01035
01036 PX_POP_PACK
01037
01038 }
01039 } // end namespace nvidia
01040
01041
01042 #endif // EXPLICIT_HIERARCHICAL_MESH_H
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
DestructibleActor.h [code]
DestructibleActorJoint.h [code]
DestructibleAsset.h [code]
DestructiblePreview.h [code]
DestructibleRenderable.h [code]
ExplicitHierarchicalMesh.h [code]
FractureToolsAPI.h [code]
FractureToolsStructs.h [code]
ModuleDestructible.h [code]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: FractureToolsAPI.h File Reference

  • File List
  • File Members
Classes | Namespaces
FractureToolsAPI.h File Reference
#include "foundation/Px.h"
#include "ExplicitHierarchicalMesh.h"
#include "FractureToolsStructs.h"

Go to the source code of this file.

Classes

class | nvidia::apex::FractureToolsAPI

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: FractureToolsAPI.h Source File

  • File List
  • File Members
FractureToolsAPI.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef FRACTURE_TOOLS_API_H
00031 #define FRACTURE_TOOLS_API_H
00032
00033 #include "foundation/Px.h"
00034 #include "ExplicitHierarchicalMesh.h"
00035 #include "FractureToolsStructs.h"
00036
00037 PX_PUSH_PACK_DEFAULT
00038
00039 namespace nvidia
00040 {
00041 namespace apex
00042 {
00043
00044 struct IntersectMesh;
00045 class DestructibleAsset;
00046
00048 class FractureToolsAPI
00049 {
00050 public:
00051
00053     virtual FractureTools::CutoutSet* createCutoutSet() = 0;
00054
00067     virtual void buildCutoutSet(FractureTools::CutoutSet& cutoutSet, const uint8_t* pixelBuffer, uint32_t bufferWidth, uint32_t bufferHeight, float snapThreshold, bool periodic) = 0;
00068
00077     virtual bool calculateCutoutUVMapping(const nvidia::ExplicitRenderTriangle& triangle, PxMat33& theMapping) = 0;
00078
00091     virtual bool calculateCutoutUVMapping(nvidia::ExplicitHierarchicalMesh& hMesh, const PxVec3& targetDirection, PxMat33& theMapping) = 0;
00092
00113     virtual bool    createVoronoiSplitMesh
00114     (
00115         nvidia::ExplicitHierarchicalMesh& hMesh,
00116         nvidia::ExplicitHierarchicalMesh& iHMeshCore,
00117         bool exportCoreMesh,
00118         int32_t coreMeshImprintSubmeshIndex,
00119         const FractureTools::MeshProcessingParameters& meshProcessingParams,
00120         const FractureTools::FractureVoronoiDesc& desc,
00121         const CollisionDesc& collisionDesc,
00122         uint32_t randomSeed,
00123         nvidia::IProgressListener& progressListener,
00124         volatile bool* cancel = NULL
00125     ) = 0;
00126
00143     virtual uint32_t    createVoronoiSitesInsideMesh
00144     (
00145         nvidia::ExplicitHierarchicalMesh& hMesh,
00146         PxVec3* siteBuffer,
00147         uint32_t* siteChunkIndices,
00148         uint32_t siteCount,
00149         uint32_t* randomSeed,
00150         uint32_t* microgridSize,
00151         BSPOpenMode::Enum meshMode,
00152         nvidia::IProgressListener& progressListener,
00153         uint32_t chunkIndex = 0xFFFFFFFF
00154     ) = 0;
00155
00180     virtual uint32_t    createScatterMeshSites
00181     (
00182         uint8_t*                        meshIndices,
00183         PxMat44*                        relativeTransforms,
00184         uint32_t*                       chunkMeshStarts,
00185         uint32_t                        scatterMeshInstancesBufferSize,
00186         nvidia::ExplicitHierarchicalMesh&   hMesh,
00187         uint32_t                        targetChunkCount,
00188         const uint16_t*                 targetChunkIndices,
00189         uint32_t*                       randomSeed,
00190         uint32_t                        scatterMeshAssetCount,
00191         nvidia::RenderMeshAsset**           scatterMeshAssets,
00192         const uint32_t*                 minCount,
00193         const uint32_t*                 maxCount,
00194         const float*                    minScales,
00195         const float*                    maxScales,
00196         const float*                    maxAngles
00197     ) = 0;
00198
00212     virtual void    visualizeVoronoiCells
00213     (
00214         nvidia::RenderDebugInterface& debugRender,
00215         const PxVec3* sites,
00216         uint32_t siteCount,
00217         const uint32_t* cellColors,
00218         uint32_t cellColorCount,
00219         const PxBounds3& bounds,
00220         uint32_t cellIndex = 0xFFFFFFFF
00221     ) = 0;
00222
00246     virtual bool buildExplicitHierarchicalMesh
00247     (
00248         nvidia::ExplicitHierarchicalMesh& iHMesh,
00249         const nvidia::ExplicitRenderTriangle* meshTriangles,
00250         uint32_t meshTriangleCount,
00251         const nvidia::ExplicitSubmeshData* submeshData,
00252         uint32_t submeshCount,
00253         uint32_t* meshPartition = NULL,
00254         uint32_t meshPartitionCount = 0,
00255         int32_t* parentIndices = NULL,
00256         uint32_t parentIndexCount = 0
00257     ) = 0;
00258
00268     virtual void setBSPTolerances
00269     (
00270         float linearTolerance,
00271         float angularTolerance,
00272         float baseTolerance,
00273         float clipTolerance,
00274         float cleaningTolerance
00275     ) = 0;
00276
00295     virtual void setBSPBuildParameters
00296     (
00297         float logAreaSigmaThreshold,
00298         uint32_t testSetSize,
00299         float splitWeight,
00300         float imbalanceWeight
00301     ) = 0;
00302
00303
00312     virtual bool buildExplicitHierarchicalMeshFromRenderMeshAsset(nvidia::ExplicitHierarchicalMesh& iHMesh, const nvidia::RenderMeshAsset& renderMeshAsset, uint32_t maxRootDepth = UINT32_MAX) = 0;
00313
00323     virtual bool buildExplicitHierarchicalMeshFromDestructibleAsset(nvidia::ExplicitHierarchicalMesh& iHMesh, const nvidia::DestructibleAsset& destructibleAsset, uint32_t maxRootDepth = UINT32_MAX) = 0;
00324
00344     virtual bool createHierarchicallySplitMesh
00345     (
00346         nvidia::ExplicitHierarchicalMesh& hMesh,
00347         nvidia::ExplicitHierarchicalMesh& iHMeshCore,
00348         bool exportCoreMesh,
00349         int32_t coreMeshImprintSubmeshIndex,
00350         const FractureTools::MeshProcessingParameters& meshProcessingParams,
00351         const FractureTools::FractureSliceDesc& desc,
00352         const CollisionDesc& collisionDesc,
00353         uint32_t randomSeed,
00354         nvidia::IProgressListener& progressListener,
00355         volatile bool* cancel = NULL
00356     ) = 0;
00357
00375     virtual bool createChippedMesh
00376     (
00377         nvidia::ExplicitHierarchicalMesh& hMesh,
00378         const FractureTools::MeshProcessingParameters& meshProcessingParams,
00379         const FractureTools::FractureCutoutDesc& desc,
00380         const FractureTools::CutoutSet& iCutoutSet,
00381         const FractureTools::FractureSliceDesc& sliceDesc,
00382         const FractureTools::FractureVoronoiDesc& voronoiDesc,
00383         const CollisionDesc& collisionDesc,
00384         uint32_t randomSeed,
00385         nvidia::IProgressListener& progressListener,
00386         volatile bool* cancel = NULL
00387     ) = 0;
00388
00405     virtual bool hierarchicallySplitChunk
00406     (
00407         nvidia::ExplicitHierarchicalMesh& hMesh,
00408         uint32_t chunkIndex,
00409         const FractureTools::MeshProcessingParameters& meshProcessingParams,
00410         const FractureTools::FractureSliceDesc& desc,
00411         const CollisionDesc& collisionDesc,
00412         uint32_t* randomSeed,
00413         nvidia::IProgressListener& progressListener,
00414         volatile bool* cancel = NULL
00415     ) = 0;
00416
00433     virtual bool voronoiSplitChunk
00434     (
00435         nvidia::ExplicitHierarchicalMesh& hMesh,
00436         uint32_t chunkIndex,
00437         const FractureTools::MeshProcessingParameters& meshProcessingParams,
00438         const FractureTools::FractureVoronoiDesc& desc,
00439         const CollisionDesc& collisionDesc,
00440         uint32_t* randomSeed,
00441         nvidia::IProgressListener& progressListener,
00442         volatile bool* cancel = NULL
00443     ) = 0;
00444
00449     virtual bool buildSliceMesh
00450     (
00451         nvidia::IntersectMesh& intersectMesh,
00452         nvidia::ExplicitHierarchicalMesh& referenceMesh,
00453         const PxPlane& slicePlane,
00454         const FractureTools::NoiseParameters& noiseParameters,
00455         uint32_t randomSeed
00456     ) = 0;
00457
00459     virtual nvidia::ExplicitHierarchicalMesh*   createExplicitHierarchicalMesh() = 0;
00460
00462     virtual nvidia::ExplicitHierarchicalMesh::ConvexHull*   createExplicitHierarchicalMeshConvexHull() = 0;
00463
00464 };
00465
00466 }} // namespaces
00467
00468
00469 PX_POP_PACK
00470
00471 #endif // FRACTURE_TOOLS_API_H
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: FractureToolsStructs.h File Reference

  • File List
  • File Members
Classes | Namespaces
FractureToolsStructs.h File Reference
#include "foundation/Px.h"
#include "ExplicitHierarchicalMesh.h"

Go to the source code of this file.

Classes

struct | FractureTools::MeshProcessingParameters
class | FractureTools::CutoutSet
struct | FractureTools::NoiseParameters
struct | FractureTools::SliceParameters
struct | FractureTools::FractureSliceDesc
struct | FractureTools::CutoutParameters
struct | FractureTools::FractureCutoutDesc
struct | FractureTools::FractureVoronoiDesc

Namespaces

namespace | FractureTools
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: FractureToolsStructs.h Source File

  • File List
  • File Members
FractureToolsStructs.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef FRACTURE_TOOLS_STRUCTS_H
00030 #define FRACTURE_TOOLS_STRUCTS_H
00031
00032 #include "foundation/Px.h"
00033 #include "ExplicitHierarchicalMesh.h"
00034
00035 PX_PUSH_PACK_DEFAULT
00036
00037 namespace FractureTools
00038 {
00039
00043 struct MeshProcessingParameters
00044 {
00049     bool islandGeneration;
00050
00055     bool removeTJunctions;
00056
00063     unsigned microgridSize;
00064
00073     nvidia::BSPOpenMode::Enum meshMode;
00074
00079     int verbosity;
00080
00082     MeshProcessingParameters()
00083     {
00084         setToDefault();
00085     }
00086
00088     void    setToDefault()
00089     {
00090         islandGeneration = false;
00091         removeTJunctions = false;
00092         microgridSize = 65536;
00093         meshMode = nvidia::BSPOpenMode::Automatic;
00094         verbosity = 0;
00095     }
00096 };
00097
00098
00108 class CutoutSet
00109 {
00110 public:
00112     virtual uint32_t                getCutoutCount() const = 0;
00113
00118     virtual uint32_t                getCutoutVertexCount(uint32_t cutoutIndex) const = 0;
00119
00124     virtual uint32_t                getCutoutLoopCount(uint32_t cutoutIndex) const = 0;
00125
00130     virtual const physx::PxVec3&    getCutoutVertex(uint32_t cutoutIndex, uint32_t vertexIndex) const = 0;
00131
00136     virtual uint32_t                getCutoutLoopSize(uint32_t coutoutIndex, uint32_t loopIndex) const = 0;
00137
00143     virtual uint32_t                getCutoutLoopVertexIndex(uint32_t cutoutIndex, uint32_t loopIndex, uint32_t vertexNum) const = 0;
00144
00150     virtual uint32_t                getCutoutLoopVertexFlags(uint32_t cutoutIndex, uint32_t loopIndex, uint32_t vertexNum) const = 0;
00151
00155     virtual bool                    isPeriodic() const = 0;
00156
00160     virtual const physx::PxVec2&    getDimensions() const = 0;
00161
00163     //virtual void          serialize(physx::PxFileBuf& stream) const = 0;
00164     //virtual void          deserialize(physx::PxFileBuf& stream) = 0;
00165
00167     virtual void                    release() = 0;
00168
00169 protected:
00171     virtual                         ~CutoutSet() {}
00172 };
00173
00174
00179 struct NoiseParameters
00180 {
00184     float   amplitude;
00185
00190     float   frequency;
00191
00196     int     gridSize;
00197
00203     int     type;
00204
00206     NoiseParameters()
00207     {
00208         setToDefault();
00209     }
00210
00219     void    setToDefault()
00220     {
00221         amplitude = 0.0f;
00222         frequency = 0.25f;
00223         gridSize = 10;
00224         type = 0;
00225     }
00226 };
00227
00228
00234 struct SliceParameters
00235 {
00240     enum Order
00241     {
00242         XYZ,
00243         YZX,
00244         ZXY,
00245         ZYX,
00246         YXZ,
00247         XZY,
00248         Through
00249     };
00250
00252     unsigned order;
00253
00255     unsigned splitsPerPass[3];
00256
00263     float linearVariation[3];
00264
00270     float angularVariation[3];
00271
00273     NoiseParameters noise[3];
00274
00276     SliceParameters()
00277     {
00278         setToDefault();
00279     }
00280
00290     void    setToDefault()
00291     {
00292         order = XYZ;
00293         splitsPerPass[0] = splitsPerPass[1] = splitsPerPass[2] = 1;
00294         linearVariation[0] = linearVariation[1] = linearVariation[2] = 0.1f;
00295         angularVariation[0] = angularVariation[1] = angularVariation[2] = 20.0f * 3.1415927f / 180.0f;
00296         noise[0].setToDefault();
00297         noise[1].setToDefault();
00298         noise[2].setToDefault();
00299     }
00300 };
00301
00302
00308 struct FractureSliceDesc
00309 {
00311     unsigned                        maxDepth;
00312
00314     SliceParameters*                sliceParameters;
00315
00319     bool                            useTargetProportions;
00320
00328     float                           targetProportions[3];
00329
00336     float                           minimumChunkSize[3];
00337
00341     nvidia::FractureMaterialDesc    materialDesc[3];
00342
00346     bool                            instanceChunks;
00347
00351     bool                            useDisplacementMaps;
00352
00354     enum NoiseMode
00355     {
00356         NoiseWavePlane = 0,
00357         NoisePerlin2D,
00358         NoisePerlin3D,
00359
00360         NoiseModeCount
00361     };
00362
00366     unsigned            noiseMode;
00367
00369     FractureSliceDesc()
00370     {
00371         setToDefault();
00372     }
00373
00387     void    setToDefault()
00388     {
00389         maxDepth             = 0;
00390         sliceParameters      = NULL;
00391         useTargetProportions = false;
00392         for (int i = 0; i < 3; ++i)
00393         {
00394             targetProportions[i] = 1.0f;
00395             minimumChunkSize[i] = 0.0f;
00396             materialDesc[i].setToDefault();
00397         }
00398         instanceChunks       = false;
00399         useDisplacementMaps  = false;
00400         noiseMode            = NoiseWavePlane;
00401     }
00402 };
00403
00404
00410 struct CutoutParameters
00411 {
00416     float depth;
00417
00423     nvidia::FractureMaterialDesc materialDesc;
00424
00430     NoiseParameters backfaceNoise;
00431
00440     NoiseParameters edgeNoise;
00441
00443     CutoutParameters()
00444     {
00445         setToDefault();
00446     }
00447
00456     void    setToDefault()
00457     {
00458         depth = 1.0f;
00459         backfaceNoise.setToDefault();
00460         materialDesc.setToDefault();
00461         edgeNoise.setToDefault();
00462     }
00463 };
00464
00465
00471 struct FractureCutoutDesc
00472 {
00474     enum Directions
00475     {
00476         UserDefined = 0,    // If no flags are set, the cutout direction is taken from userDefinedDirection
00477
00478         NegativeX = 1 << 0,
00479         PositiveX = 1 << 1,
00480         NegativeY = 1 << 2,
00481         PositiveY = 1 << 3,
00482         NegativeZ = 1 << 4,
00483         PositiveZ = 1 << 5,
00484
00485         DirectionCount = 6
00486     };
00487
00489     unsigned directions;
00490
00495     unsigned directionOrder[DirectionCount];
00496
00498     CutoutParameters cutoutParameters[DirectionCount];
00499
00504     physx::PxVec3 userDefinedDirection;
00505
00507     physx::PxMat33 userUVMapping;
00508
00510     CutoutParameters userDefinedCutoutParameters;
00511
00513     enum InstancingMode
00514     {
00515         DoNotInstance,
00516         InstanceCongruentChunks,
00517         InstanceAllChunks,
00518
00519         InstanceModeCount
00520     };
00521
00525     unsigned instancingMode;
00526
00530     bool tileFractureMap;
00531
00535     physx::PxVec2 uvTileSize;
00536
00540     bool splitNonconvexRegions;
00541
00546     enum CutoutChunkFracturingMethod
00547     {
00548         DoNotFractureCutoutChunks,
00549         SliceFractureCutoutChunks,
00550         VoronoiFractureCutoutChunks,
00551
00552         CutoutChunkFracturingMethodCount
00553     };
00554
00563     unsigned chunkFracturingMethod;
00564
00572     bool trimFaceCollisionHulls;
00573
00575     float cutoutWidthScale[DirectionCount];
00576
00578     float cutoutHeightScale[DirectionCount];
00579
00581     float cutoutWidthOffset[DirectionCount];
00582
00584     float cutoutHeightOffset[DirectionCount];
00585
00587     bool cutoutWidthInvert[DirectionCount];
00588
00590     bool cutoutHeightInvert[DirectionCount];
00591
00593     float cutoutSizeX;
00594
00596     float cutoutSizeY;
00597
00604     float facetNormalMergeThresholdAngle;
00605
00607     FractureCutoutDesc()
00608     {
00609         setToDefault();
00610     }
00611
00638     void    setToDefault()
00639     {
00640         directions          = 0;
00641         userDefinedDirection= physx::PxVec3(0.0f);
00642         userUVMapping       = physx::PxMat33(physx::PxIdentity);
00643         userDefinedCutoutParameters.setToDefault();
00644         instancingMode      = DoNotInstance;
00645         tileFractureMap     = false;
00646         uvTileSize          = physx::PxVec2(0.0f);
00647         for (uint32_t i = 0; i < DirectionCount; ++i)
00648         {
00649             directionOrder[i]     = 1u << i;
00650             cutoutParameters[i].setToDefault();
00651             cutoutWidthScale[i]   = 1.0f;
00652             cutoutHeightScale[i]  = 1.0f;
00653             cutoutWidthOffset[i]  = 0.0f;
00654             cutoutHeightOffset[i] = 0.0f;
00655             cutoutWidthInvert[i]  = false;
00656             cutoutHeightInvert[i] = false;
00657         }
00658         cutoutSizeX                    = 1.0f;
00659         cutoutSizeY                    = 1.0f;
00660         facetNormalMergeThresholdAngle = 60.0f;
00661         splitNonconvexRegions          = false;
00662         chunkFracturingMethod          = DoNotFractureCutoutChunks;
00663         trimFaceCollisionHulls         = true;
00664     }
00665 };
00666
00667
00673 struct FractureVoronoiDesc
00674 {
00678     unsigned                siteCount;
00679
00683     const physx::PxVec3*    sites;
00684
00689     const uint32_t*         chunkIndices;
00690
00698     NoiseParameters         faceNoise;
00699
00703     bool                    instanceChunks;
00704
00708     bool                    useDisplacementMaps;
00709
00711     enum NoiseMode
00712     {
00713         NoiseWavePlane = 0,
00714         NoisePerlin2D,
00715         NoisePerlin3D,
00716
00717         NoiseModeCount
00718     };
00719
00723     unsigned                noiseMode;
00724
00731     float                   minimumChunkSize;
00732
00737     nvidia::FractureMaterialDesc    materialDesc;
00738
00739
00741     FractureVoronoiDesc()
00742     {
00743         setToDefault();
00744     }
00745
00759     void    setToDefault()
00760     {
00761         siteCount = 0;
00762         sites = NULL;
00763         chunkIndices = NULL;
00764         faceNoise.setToDefault();
00765         instanceChunks = false;
00766         useDisplacementMaps = false;
00767         noiseMode = NoiseWavePlane;
00768         minimumChunkSize = 0.0f;
00769         materialDesc.setToDefault();
00770     }
00771 };
00772
00773
00774 } // namespace FractureTools
00775
00776
00777 PX_POP_PACK
00778
00779 #endif // FRACTURE_TOOLS_H
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ACCUMULATE_DAMAGE : nvidia::apex::DestructibleParametersFlag
  • ACCURATE_RAYCASTS : nvidia::apex::DestructibleParametersFlag
  • acquireChunkEventBuffer() : nvidia::apex::DestructibleActor
  • acquirePhysXActorBuffer() : nvidia::apex::DestructibleActor
  • acquireRenderableReference() : nvidia::apex::DestructibleActor
  • actor : nvidia::apex::DestructibleActorJointDesc
  • addChunkOverlaps()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • addForce() : nvidia::apex::DestructibleActor
  • addMaterialFrame() : nvidia::apex::ExplicitHierarchicalMesh
  • addSubmesh() : nvidia::apex::ExplicitHierarchicalMesh
  • AllChunks : nvidia::apex::DestructibleActorRaycastFlags
  • AllowActorsNotInScenes : nvidia::apex::DestructiblePhysXActorQueryFlags
  • AllowRedundancy : nvidia::apex::DestructiblePhysXActorQueryFlags
  • AllStates : nvidia::apex::DestructiblePhysXActorQueryFlags
  • alwaysDrawScatterMesh : nvidia::apex::DestructibleParameters
  • amplitude : FractureTools::NoiseParameters
  • angularVariation : FractureTools::SliceParameters
  • appendActorTransforms() : nvidia::apex::DestructibleAssetAuthoring
  • appliedDamageUserData : nvidia::apex::DamageEventReportData
  • applyDamage() : nvidia::apex::DestructibleActor
  • applyRadiusDamage()
: nvidia::apex::DestructibleActor
, nvidia::apex::ModuleDestructible
  • applyTransformation()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • ASSET_DEFINED_SUPPORT : nvidia::apex::DestructibleInitParametersFlag
  • attachment : nvidia::apex::DestructibleRTFractureParameters
  • attachmentChunkIndex : nvidia::apex::DestructibleActorJointDesc
  • Automatic : nvidia::apex::BSPOpenMode
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- j -

  • joint() : nvidia::apex::DestructibleActorJoint
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- k -

  • kDepthParametersCountMax : nvidia::apex::DestructibleParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • Last : nvidia::apex::DestructibleActorSyncFlags
  • legacyChunkBoundsTestSetting : nvidia::apex::DestructibleParameters
  • legacyDamageRadiusSpreadSetting : nvidia::apex::DestructibleParameters
  • linearVariation : FractureTools::SliceParameters
  • localAnchor : nvidia::apex::DestructibleActorJointDesc
  • localAxis : nvidia::apex::DestructibleActorJointDesc
  • localNormal : nvidia::apex::DestructibleActorJointDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • materialDesc
: FractureTools::FractureSliceDesc
, FractureTools::CutoutParameters
, FractureTools::FractureVoronoiDesc
  • MaterialFrame() : nvidia::apex::MaterialFrame
  • MaterialLibrary : nvidia::apex::ExplicitHierarchicalMesh::Embedding
  • MaterialNameBufferSize : nvidia::apex::ExplicitSubmeshData
  • materialStrength : nvidia::apex::DestructibleBehaviorGroupDesc
  • maxChunkSpeed : nvidia::apex::DestructibleParameters
  • maxDepenetrationVelocity : nvidia::apex::DestructibleBehaviorGroupDesc
  • maxDepth
: FractureTools::FractureSliceDesc
, nvidia::apex::DamageEventReportData
, nvidia::apex::ExplicitHierarchicalMesh
  • maxHullFaceCount : nvidia::apex::DestructibleAssetStats
  • maxHullVertexCount : nvidia::apex::DestructibleAssetStats
  • mBonesPerVertex : nvidia::apex::ExplicitVertexFormat
  • mConcavityPercent : nvidia::apex::CollisionVolumeDesc
  • mCoordinateSystem : nvidia::apex::MaterialFrame
  • mDepthCount : nvidia::apex::CollisionDesc
  • meshBounds() : nvidia::apex::ExplicitHierarchicalMesh
  • meshIndex : nvidia::apex::DestructibleChunkDesc
  • meshMode : FractureTools::MeshProcessingParameters
  • MeshProcessingParameters() : FractureTools::MeshProcessingParameters
  • meshTriangleCount() : nvidia::apex::ExplicitHierarchicalMesh
  • meshTriangles() : nvidia::apex::ExplicitHierarchicalMesh
  • mFractureIndex : nvidia::apex::MaterialFrame
  • mFractureMethod : nvidia::apex::MaterialFrame
  • mHasDynamicBinormals : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicColors : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicDisplacements : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicNormals : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicPositions : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicSeparateBoneBuffer : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicTangents : nvidia::apex::ExplicitVertexFormat
  • mHasStaticBinormals : nvidia::apex::ExplicitVertexFormat
  • mHasStaticColors : nvidia::apex::ExplicitVertexFormat
  • mHasStaticDisplacements : nvidia::apex::ExplicitVertexFormat
  • mHasStaticNormals : nvidia::apex::ExplicitVertexFormat
  • mHasStaticPositions : nvidia::apex::ExplicitVertexFormat
  • mHasStaticSeparateBoneBuffer : nvidia::apex::ExplicitVertexFormat
  • mHasStaticTangents : nvidia::apex::ExplicitVertexFormat
  • mHullMethod : nvidia::apex::CollisionVolumeDesc
  • microgridSize : FractureTools::MeshProcessingParameters
  • minConvexSize : nvidia::apex::DestructibleRTFractureParameters
  • minDepth : nvidia::apex::DamageEventReportData
  • minimumChunkSize : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • minimumFractureDepth : nvidia::apex::DestructibleParameters
  • minimumRadius : nvidia::apex::DamageSpreadFunction
  • mMaterialName : nvidia::apex::ExplicitSubmeshData
  • mMaxEdgeCount : nvidia::apex::CollisionVolumeDesc
  • mMaxFaceCount : nvidia::apex::CollisionVolumeDesc
  • mMaximumTrimming : nvidia::apex::CollisionDesc
  • mMaxVertexCount : nvidia::apex::CollisionVolumeDesc
  • mMergeThreshold : nvidia::apex::CollisionVolumeDesc
  • momentum : nvidia::apex::DamageEventUnit
  • mRecursionDepth : nvidia::apex::CollisionVolumeDesc
  • mSliceDepth : nvidia::apex::MaterialFrame
  • mUVCount : nvidia::apex::ExplicitVertexFormat
  • mUVOffset : nvidia::apex::MaterialFrame
  • mUVPlane : nvidia::apex::MaterialFrame
  • mUVScale : nvidia::apex::MaterialFrame
  • mVertexFormat : nvidia::apex::ExplicitSubmeshData
  • mVolumeDescs : nvidia::apex::CollisionDesc
  • mWinding : nvidia::apex::ExplicitVertexFormat
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- n -

  • name : nvidia::apex::DestructibleBehaviorGroupDesc
  • NegativeX : FractureTools::FractureCutoutDesc
  • NegativeY : FractureTools::FractureCutoutDesc
  • NegativeZ : FractureTools::FractureCutoutDesc
  • negX : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • negY : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • negZ : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • next
: nvidia::apex::DamageEventHeader
, nvidia::apex::FractureEventHeader
, nvidia::apex::ChunkTransformHeader
  • NoChunks : nvidia::apex::DestructibleActorRaycastFlags
  • noise : FractureTools::SliceParameters
  • NoiseMode : FractureTools::FractureVoronoiDesc
  • noiseMode : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • NoiseMode : FractureTools::FractureSliceDesc
  • NoiseModeCount : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • NoiseParameters() : FractureTools::NoiseParameters
  • NoisePerlin2D : FractureTools::FractureVoronoiDesc , FractureTools::FractureSliceDesc
  • NoisePerlin3D : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • NoiseWavePlane : FractureTools::FractureVoronoiDesc , FractureTools::FractureSliceDesc
  • None : nvidia::apex::DestructiblePhysXActorQueryFlags , nvidia::apex::DestructibleActorSyncFlags
  • numSectors : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • obbSweep() : nvidia::apex::DestructibleActor
  • onDamageNotify() : nvidia::apex::UserChunkReport
  • onDestructibleSleep() : nvidia::apex::UserChunkReport
  • onDestructibleWake() : nvidia::apex::UserChunkReport
  • onImpactDamageNotify() : nvidia::apex::UserImpactDamageReport
  • onParticleEmission() : nvidia::apex::UserChunkParticleReport
  • onPhysXActorCreate() : nvidia::apex::UserDestructiblePhysXActorReport
  • onPhysXActorRelease() : nvidia::apex::UserDestructiblePhysXActorReport
  • onPreProcessReadBegin() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onPreProcessReadDone() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onReadBegin() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onReadDone() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onStateChangeNotify() : nvidia::apex::UserChunkReport
  • onWriteBegin() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onWriteDone() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • Open : nvidia::apex::BSPOpenMode
  • operator!=() : nvidia::apex::ExplicitVertexFormat , nvidia::apex::ExplicitSubmeshData
  • operator==() : nvidia::apex::ExplicitVertexFormat , nvidia::apex::ExplicitSubmeshData
  • Order : FractureTools::SliceParameters
  • order : FractureTools::SliceParameters
  • OVERRIDE_IMPACT_DAMAGE : nvidia::apex::DestructibleDepthParametersFlag
  • OVERRIDE_IMPACT_DAMAGE_VALUE : nvidia::apex::DestructibleDepthParametersFlag
  • overrideImpactDamage() : nvidia::apex::DestructibleDepthParameters
  • overrideImpactDamageValue() : nvidia::apex::DestructibleDepthParameters
  • owns() : nvidia::apex::ModuleDestructible
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZXY : FractureTools::SliceParameters
  • ZYX : FractureTools::SliceParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~ConvexHull() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • ~CutoutSet() : FractureTools::CutoutSet
  • ~DestructibleActor() : nvidia::apex::DestructibleActor
  • ~DestructibleActorJoint() : nvidia::apex::DestructibleActorJoint
  • ~DestructibleAsset() : nvidia::apex::DestructibleAsset
  • ~DestructibleRenderable() : nvidia::apex::DestructibleRenderable
  • ~DisplacementMapVolume() : nvidia::apex::DisplacementMapVolume
  • ~ExplicitHierarchicalMesh() : nvidia::apex::ExplicitHierarchicalMesh
  • ~ModuleDestructible() : nvidia::apex::ModuleDestructible
  • ~UserChunkParticleReport() : nvidia::apex::UserChunkParticleReport
  • ~UserChunkReport() : nvidia::apex::UserChunkReport
  • ~UserDestructiblePhysXActorReport() : nvidia::apex::UserDestructiblePhysXActorReport
  • ~UserDestructibleSyncHandler() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • backfaceNoise : FractureTools::CutoutParameters
  • BeforeTick : nvidia::apex::DestructibleCallbackSchedule
  • behaviorGroupDescCount : nvidia::apex::DestructibleAssetCookingDesc
  • behaviorGroupDescs : nvidia::apex::DestructibleAssetCookingDesc
  • behaviorGroupIndex : nvidia::apex::DestructibleChunkDesc
  • BSPOpenModeCount : nvidia::apex::BSPOpenMode
  • buildCollisionGeometryForPart() : nvidia::apex::ExplicitHierarchicalMesh
  • buildCollisionGeometryForRootChunkParts() : nvidia::apex::ExplicitHierarchicalMesh
  • buildCoordinateSystemFromMaterialDesc() : nvidia::apex::MaterialFrame
  • buildCutoutSet()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • buildExplicitHierarchicalMesh()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • buildExplicitHierarchicalMeshFromDestructibleAsset() : nvidia::apex::FractureToolsAPI
  • buildExplicitHierarchicalMeshFromRenderMeshAsset() : nvidia::apex::FractureToolsAPI
  • buildFromPoints() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • buildSliceMesh()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • cacheChunkOverlapsUpToDepth()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • calculateCutoutUVMapping()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • calculateMeshBSP() : nvidia::apex::ExplicitHierarchicalMesh
  • ChunkAndDescendentsDoNotFracture : nvidia::apex::DestructibleAsset
  • chunkBounds() : nvidia::apex::ExplicitHierarchicalMesh
  • chunkBytes : nvidia::apex::DestructibleAssetStats
  • chunkCount : nvidia::apex::DestructibleAssetStats , nvidia::apex::ExplicitHierarchicalMesh
  • chunkDescCount : nvidia::apex::DestructibleAssetCookingDesc
  • chunkDescs : nvidia::apex::DestructibleAssetCookingDesc
  • ChunkDoesNotCrumble : nvidia::apex::DestructibleAsset
  • ChunkDoesNotFracture : nvidia::apex::DestructibleAsset
  • ChunkEnvironmentallySupported : nvidia::apex::DestructibleAsset
  • chunkFlags() : nvidia::apex::ExplicitHierarchicalMesh
  • ChunkFlags : nvidia::apex::DestructibleAsset
  • chunkFracturingMethod : FractureTools::FractureCutoutDesc
  • chunkHullDataBytes : nvidia::apex::DestructibleAssetStats
  • chunkIndex
: nvidia::apex::DestructibleHitChunk
, nvidia::apex::DestructibleChunkEvent
, nvidia::apex::DamageEventUnit
, nvidia::apex::FractureEventUnit
, nvidia::apex::ChunkTransformUnit
  • chunkIndexInAsset : nvidia::apex::DamageEventCoreData
  • chunkIndices : FractureTools::FractureVoronoiDesc
  • ChunkIsInstanced : nvidia::apex::DestructibleAsset
  • ChunkIsWorldSupported : nvidia::apex::DestructibleActorChunkFlags
  • chunkOrientation : nvidia::apex::ChunkTransformUnit
  • chunkPosition : nvidia::apex::ChunkTransformUnit
  • ChunkRuntimeFracture : nvidia::apex::DestructibleAsset
  • chunkTransformBufferStart : nvidia::apex::ChunkTransformHeader
  • chunkTransformCopyDepth : nvidia::apex::DestructibleChunkSyncState
  • chunkTransformCount : nvidia::apex::ChunkTransformHeader
  • chunkUniqueID() : nvidia::apex::ExplicitHierarchicalMesh
  • ChunkVisible : nvidia::apex::DestructibleChunkEvent
  • chunkWithMaxEdgeCount : nvidia::apex::DestructibleAssetStats
  • clear()
: nvidia::apex::ExplicitVertexFormat
, nvidia::apex::ExplicitHierarchicalMesh
  • clearActorTransforms() : nvidia::apex::DestructibleAssetAuthoring
  • clearChunkOverlaps()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • Closed : nvidia::apex::BSPOpenMode
  • collisionCookedHullDataBytes : nvidia::apex::DestructibleAssetStats
  • CollisionDesc() : nvidia::apex::CollisionDesc
  • collisionMeshCount : nvidia::apex::DestructibleAssetStats
  • CollisionVolumeDesc() : nvidia::apex::CollisionVolumeDesc
  • collisionVolumeDesc : nvidia::apex::DestructibleGeometryDesc
  • ConvexHull() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • convexHullCount : nvidia::apex::DestructibleGeometryDesc , nvidia::apex::ExplicitHierarchicalMesh
  • convexHulls()
: nvidia::apex::ExplicitHierarchicalMesh
, nvidia::apex::DestructibleGeometryDesc
  • cookChunks() : nvidia::apex::DestructibleAssetAuthoring
  • CopyChunkTransform : nvidia::apex::DestructibleActorSyncFlags
  • CopyDamageEvents : nvidia::apex::DestructibleActorSyncFlags
  • CopyFractureEvents : nvidia::apex::DestructibleActorSyncFlags
  • copyToVertexFormat() : nvidia::apex::ExplicitVertexFormat
  • Count
: nvidia::apex::DestructibleCallbackSchedule
, nvidia::apex::DestructibleEmitterType
, nvidia::apex::DestructibleActorMeshType
  • createChippedMesh()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • createCutoutSet() : nvidia::apex::FractureToolsAPI
  • createDestructibleActorFromDeserializedState() : nvidia::apex::DestructibleAsset
  • createDestructibleActorJoint() : nvidia::apex::ModuleDestructible
  • createExplicitHierarchicalMesh() : nvidia::apex::FractureToolsAPI
  • createExplicitHierarchicalMeshConvexHull()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • createHierarchicallySplitMesh()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • createScatterMeshSites()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • createVoronoiSitesInsideMesh()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • createVoronoiSplitMesh()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • Crumble : nvidia::apex::DestructibleEmitterType
  • CRUMBLE_SMALLEST_CHUNKS : nvidia::apex::DestructibleParametersFlag
  • CRUMBLE_VIA_RUNTIME_FRACTURE : nvidia::apex::DestructibleParametersFlag
  • Cutout : nvidia::apex::FractureMethod
  • CutoutChunkFracturingMethod : FractureTools::FractureCutoutDesc
  • CutoutChunkFracturingMethodCount : FractureTools::FractureCutoutDesc
  • cutoutHeightInvert : FractureTools::FractureCutoutDesc
  • cutoutHeightOffset : FractureTools::FractureCutoutDesc
  • cutoutHeightScale : FractureTools::FractureCutoutDesc
  • cutoutParameters : FractureTools::FractureCutoutDesc
  • CutoutParameters() : FractureTools::CutoutParameters
  • cutoutSizeX : FractureTools::FractureCutoutDesc
  • cutoutSizeY : FractureTools::FractureCutoutDesc
  • cutoutWidthInvert : FractureTools::FractureCutoutDesc
  • cutoutWidthOffset : FractureTools::FractureCutoutDesc
  • cutoutWidthScale : FractureTools::FractureCutoutDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • damage
: nvidia::apex::ChunkData
, nvidia::apex::DamageEventCoreData
, nvidia::apex::DamageEventUnit
  • damageCap : nvidia::apex::DestructibleParameters
  • damageColorChange : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageColorSpread : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageDepthLimit : nvidia::apex::DestructibleParameters
  • damageEventBufferStart : nvidia::apex::DamageEventHeader
  • damageEventCount : nvidia::apex::DamageEventHeader
  • damageEventFilterDepth : nvidia::apex::DestructibleActorSyncState
  • damageEventFlags : nvidia::apex::DamageEventUnit
  • damageSpread : nvidia::apex::DestructibleBehaviorGroupDesc
  • DamageSpreadFunction() : nvidia::apex::DamageSpreadFunction
  • damageThreshold : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageToRadius : nvidia::apex::DestructibleBehaviorGroupDesc
  • DataType : nvidia::apex::ExplicitHierarchicalMesh::Embedding
  • DEBRIS_MAX_SEPARATION : nvidia::apex::DestructibleParametersFlag
  • DEBRIS_TIMEOUT : nvidia::apex::DestructibleParametersFlag
  • debrisDepth : nvidia::apex::DestructibleParameters
  • debrisDestructionProbability : nvidia::apex::DestructibleParameters
  • debrisLifetimeMax : nvidia::apex::DestructibleParameters
  • debrisLifetimeMin : nvidia::apex::DestructibleParameters
  • debrisMaxSeparationMax : nvidia::apex::DestructibleParameters
  • debrisMaxSeparationMin : nvidia::apex::DestructibleParameters
  • defaultBehaviorGroupDesc : nvidia::apex::DestructibleAssetCookingDesc
  • density : nvidia::apex::DestructibleBehaviorGroupDesc
  • depth : FractureTools::CutoutParameters , nvidia::apex::ChunkData
  • depthLimit : nvidia::apex::DestructibleRTFractureParameters
  • depthParameters : nvidia::apex::DestructibleParameters
  • depthParametersCount : nvidia::apex::DestructibleParameters
  • deserialize()
: nvidia::apex::ExplicitHierarchicalMesh::Embedding
, nvidia::apex::ExplicitHierarchicalMesh
  • deserializeFractureToolState() : nvidia::apex::DestructibleAssetAuthoring
  • DESTROYED_CRUMBLED : nvidia::apex::ApexChunkFlag
  • DESTROYED_ENTERED_USER_BOUNDS : nvidia::apex::ApexChunkFlag
  • DESTROYED_EXCEEDED_MAX_DISTANCE : nvidia::apex::ApexChunkFlag
  • DESTROYED_FIFO_FULL : nvidia::apex::ApexChunkFlag
  • DESTROYED_LEFT_USER_BOUNDS : nvidia::apex::ApexChunkFlag
  • DESTROYED_LEFT_VALID_BOUNDS : nvidia::apex::ApexChunkFlag
  • DESTROYED_TIMED_OUT : nvidia::apex::ApexChunkFlag
  • destroyIfAtDepthLimit : nvidia::apex::DestructibleRTFractureParameters
  • destructible
: nvidia::apex::DestructibleActorJointDesc
, nvidia::apex::DamageEventReportData
, nvidia::apex::ChunkStateEventData
, nvidia::apex::ImpactDamageEventData
  • DestructibleActorJointDesc() : nvidia::apex::DestructibleActorJointDesc
  • DestructibleAssetCookingDesc() : nvidia::apex::DestructibleAssetCookingDesc
  • DestructibleBehaviorGroupDesc() : nvidia::apex::DestructibleBehaviorGroupDesc
  • DestructibleChunkDesc() : nvidia::apex::DestructibleChunkDesc
  • DestructibleDepthParameters() : nvidia::apex::DestructibleDepthParameters
  • DestructibleGeometryDesc() : nvidia::apex::DestructibleGeometryDesc
  • DestructibleInitParameters() : nvidia::apex::DestructibleInitParameters
  • DestructibleParameters() : nvidia::apex::DestructibleParameters
  • DestructiblePreview() : nvidia::apex::DestructiblePreview
  • direction
: nvidia::apex::DamageEventUnit
, nvidia::apex::FractureEventUnit
, nvidia::apex::ImpactDamageEventData
  • DirectionCount : FractureTools::FractureCutoutDesc
  • directionOrder : FractureTools::FractureCutoutDesc
  • directions : FractureTools::FractureCutoutDesc
  • Directions : FractureTools::FractureCutoutDesc
  • Disabled : nvidia::apex::DestructibleCallbackSchedule
  • disableHardSleeping() : nvidia::apex::DestructibleActor
  • disableTransformBuffering : nvidia::apex::DestructibleChunkSyncState
  • displacementMapVolume() : nvidia::apex::ExplicitHierarchicalMesh
  • doNotCrumble : nvidia::apex::DestructibleChunkDesc
  • doNotDamage : nvidia::apex::DestructibleChunkDesc
  • doNotFracture : nvidia::apex::DestructibleChunkDesc
  • DoNotFractureCutoutChunks : FractureTools::FractureCutoutDesc
  • DoNotInstance : FractureTools::FractureCutoutDesc
  • Dormant : nvidia::apex::DestructiblePhysXActorQueryFlags
  • Dust : nvidia::apex::DestructibleEmitterType
  • Dynamic : nvidia::apex::DestructiblePhysXActorQueryFlags
  • DYNAMIC : nvidia::apex::ApexChunkFlag
  • DynamicChunks : nvidia::apex::DestructibleActorRaycastFlags
  • dynamicChunksDominanceGroup : nvidia::apex::DestructibleParameters
  • dynamicChunksFilterData : nvidia::apex::DestructibleParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • edgeNoise : FractureTools::CutoutParameters
  • enableHardSleeping() : nvidia::apex::DestructibleActor
  • Enum
: nvidia::apex::DestructibleParameterizedType
, nvidia::apex::DestructibleDepthParametersFlag
, nvidia::apex::DestructibleActorMeshType
, nvidia::apex::DestructibleActorRaycastFlags
, nvidia::apex::DestructibleParametersFlag
, nvidia::apex::DestructibleCallbackSchedule
, nvidia::apex::DestructibleActorSyncFlags
, nvidia::apex::DestructibleInitParametersFlag
, nvidia::apex::FractureMethod
, nvidia::apex::ModuleDestructibleConst
, nvidia::apex::ApexChunkFlag
, nvidia::apex::ExplicitHierarchicalMesh
, nvidia::apex::BSPOpenMode
, nvidia::apex::DestructibleEmitterType
, nvidia::apex::DestructiblePhysXActorQueryFlags
, nvidia::apex::DestructibleActorChunkFlags
  • essentialDepth : nvidia::apex::DestructibleParameters
  • event : nvidia::apex::DestructibleChunkEvent
  • EventMask : nvidia::apex::DestructibleChunkEvent
  • excludeSleepingChunks : nvidia::apex::DestructibleChunkSyncState
  • ExplicitHierarchicalMesh() : nvidia::apex::ExplicitHierarchicalMesh
  • ExplicitVertexFormat() : nvidia::apex::ExplicitVertexFormat
  • EXTERNALLY_SUPPORTED : nvidia::apex::ApexChunkFlag
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • faceNoise : FractureTools::FractureVoronoiDesc
  • facetNormalMergeThresholdAngle : FractureTools::FractureCutoutDesc
  • fadeOut : nvidia::apex::DestructibleBehaviorGroupDesc
  • falloffExponent : nvidia::apex::DamageSpreadFunction
  • FetchResults : nvidia::apex::DestructibleCallbackSchedule
  • firstSegmentSize : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • flags
: nvidia::apex::DestructibleParameters
, nvidia::apex::DestructibleInitParameters
, nvidia::apex::ChunkData
, nvidia::apex::DestructibleDepthParameters
  • ForceAccurateRaycastsOff : nvidia::apex::DestructibleActorRaycastFlags
  • ForceAccurateRaycastsOn : nvidia::apex::DestructibleActorRaycastFlags
  • forceChunkHits() : nvidia::apex::DestructibleActor
  • forceDamageColoring() : nvidia::apex::DestructibleActor
  • forceToDamage : nvidia::apex::DestructibleParameters
  • FORM_EXTENDED_STRUCTURES : nvidia::apex::DestructibleInitParametersFlag
  • FractureCutoutDesc() : FractureTools::FractureCutoutDesc
  • FRACTURED : nvidia::apex::ApexChunkFlag
  • fractureEventBufferStart : nvidia::apex::FractureEventHeader
  • fractureEventCount : nvidia::apex::FractureEventHeader
  • fractureEventFilterDepth : nvidia::apex::DestructibleActorSyncState
  • fractureEventFlags : nvidia::apex::FractureEventUnit
  • fractureEventList : nvidia::apex::DamageEventReportData
  • fractureEventListSize : nvidia::apex::DamageEventReportData
  • fractureImpulseScale : nvidia::apex::DestructibleParameters
  • FractureMaterialDesc() : nvidia::apex::FractureMaterialDesc
  • FractureMethodCount : nvidia::apex::FractureMethod
  • FractureSliceDesc() : FractureTools::FractureSliceDesc
  • FractureVoronoiDesc() : FractureTools::FractureVoronoiDesc
  • frequency : FractureTools::NoiseParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • geometryDescCount : nvidia::apex::DestructibleAssetCookingDesc
  • geometryDescs : nvidia::apex::DestructibleAssetCookingDesc
  • getActorTransformCount()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • getActorTransforms()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getApexEmitter() : nvidia::apex::DestructibleActor
  • getBehaviorGroup() : nvidia::apex::DestructibleActor
  • getBounds() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getCachedOverlapCountAtDepth()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getCachedOverlapsAtDepth()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkActorFlags() : nvidia::apex::DestructibleActor
  • getChunkActorLocalBounds() : nvidia::apex::DestructibleAsset
  • getChunkAngularVelocity() : nvidia::apex::DestructibleActor
  • getChunkBehaviorGroupIndex() : nvidia::apex::DestructibleActor
  • getChunkBounds() : nvidia::apex::DestructibleActor
  • getChunkChild() : nvidia::apex::DestructibleAssetAuthoring
  • getChunkChildCount() : nvidia::apex::DestructibleAssetAuthoring
  • getChunkCollisionHullCookingScale() : nvidia::apex::ModuleDestructible
  • getChunkCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkDepth() : nvidia::apex::DestructibleAsset
  • getChunkFlags() : nvidia::apex::DestructibleAsset
  • getChunkLinearVelocity() : nvidia::apex::DestructibleActor
  • getChunkLocalBounds() : nvidia::apex::DestructibleActor
  • getChunkParentIndex() : nvidia::apex::DestructibleAsset
  • getChunkPhysXActor() : nvidia::apex::DestructibleActor
  • getChunkPhysXShapes() : nvidia::apex::DestructibleActor
  • getChunkPose() : nvidia::apex::DestructibleActor
  • getChunkPositionOffset()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkTM() : nvidia::apex::DestructibleActor
  • getChunkTransform() : nvidia::apex::DestructibleActor
  • getChunkUVOffset()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkVisibilities() : nvidia::apex::DestructibleActor
  • getCoreExplicitHierarchicalMesh() : nvidia::apex::DestructibleAssetAuthoring
  • getCrumbleEmitterName() : nvidia::apex::DestructibleAsset
  • getCustomBehaviorGroupCount() : nvidia::apex::DestructibleActor
  • getCutoutCount() : FractureTools::CutoutSet
  • getCutoutLoopCount() : FractureTools::CutoutSet
  • getCutoutLoopSize() : FractureTools::CutoutSet
  • getCutoutLoopVertexFlags() : FractureTools::CutoutSet
  • getCutoutLoopVertexIndex() : FractureTools::CutoutSet
  • getCutoutSet() : nvidia::apex::DestructibleAssetAuthoring
  • getCutoutVertex() : FractureTools::CutoutSet
  • getCutoutVertexCount() : FractureTools::CutoutSet
  • getDamageColoringHistory() : nvidia::apex::DestructibleActor
  • getData() : nvidia::apex::DisplacementMapVolume
  • getDepthCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getDestructibleAndChunk() : nvidia::apex::ModuleDestructible
  • getDestructibleInitParameters()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getDestructibleParameters()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleActor
, nvidia::apex::DestructibleAssetAuthoring
  • getDimensions() : FractureTools::CutoutSet
  • getDustEmitterName() : nvidia::apex::DestructibleAsset
  • getEdgeCount() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getEdgeEndpoint() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getExplicitHierarchicalMesh() : nvidia::apex::DestructibleAssetAuthoring
  • getFractureImpulseScale() : nvidia::apex::DestructibleAssetAuthoring
  • getFractureTools() : nvidia::apex::ModuleDestructible
  • getGlobalPose() : nvidia::apex::DestructibleActor
  • getHitChunkHistory() : nvidia::apex::DestructibleActor
  • getImpactVelocityThreshold() : nvidia::apex::DestructibleAssetAuthoring
  • getInitialGlobalPose() : nvidia::apex::DestructibleActor
  • getInstancedChunkMeshCount()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • getLocalBounds() : nvidia::apex::DestructibleActor
  • getMaterialFrame() : nvidia::apex::ExplicitHierarchicalMesh
  • getMaterialFrameCount() : nvidia::apex::ExplicitHierarchicalMesh
  • getNeighborPadding() : nvidia::apex::DestructibleAssetAuthoring
  • getNumVisibleChunks() : nvidia::apex::DestructibleActor
  • getNvParameterized() : nvidia::apex::DestructibleActor
  • getOriginalBounds() : nvidia::apex::DestructibleActor
  • getPartConvexHullArray() : nvidia::apex::DestructibleAsset
  • getPartConvexHullCount() : nvidia::apex::DestructibleAsset
  • getPartIndex()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getPlane() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getPlaneCount() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getRenderMeshActor()
: nvidia::apex::DestructiblePreview
, nvidia::apex::DestructibleRenderable
, nvidia::apex::DestructibleActor
  • getRenderMeshAsset()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getScale() : nvidia::apex::DestructibleActor
  • getScatterMeshAssetCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getScatterMeshAssets()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getStats()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • getSupportDepth() : nvidia::apex::DestructibleActor
  • getSupportDepthChunkIndices() : nvidia::apex::DestructibleActor
  • getVertex() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getVertexCount() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getVisibleChunks() : nvidia::apex::DestructibleActor
  • getVolume() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • glass : nvidia::apex::DestructibleRTFractureParameters
  • globalAnchor : nvidia::apex::DestructibleActorJointDesc
  • globalAxis : nvidia::apex::DestructibleActorJointDesc
  • globalNormal : nvidia::apex::DestructibleActorJointDesc
  • gridSize : FractureTools::NoiseParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • hasUserFlagSet() : nvidia::apex::DestructibleDepthParameters
  • hierarchicallySplitChunk()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • hitChunkFlags : nvidia::apex::DestructibleHitChunk
  • hitDirection : nvidia::apex::DamageEventReportData
  • hitPosition : nvidia::apex::DamageEventReportData
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • IGNORE_CONTACT_CALLBACKS : nvidia::apex::DestructibleDepthParametersFlag
  • IGNORE_POSE_UPDATES : nvidia::apex::DestructibleDepthParametersFlag
  • IGNORE_RAYCAST_CALLBACKS : nvidia::apex::DestructibleDepthParametersFlag
  • ignoresContactCallbacks() : nvidia::apex::DestructibleDepthParameters
  • ignoresPoseUpdates() : nvidia::apex::DestructibleDepthParameters
  • ignoresRaycastCallbacks() : nvidia::apex::DestructibleDepthParameters
  • impactDamageActor : nvidia::apex::ImpactDamageEventData , nvidia::apex::DamageEventReportData
  • impactDamageDefaultDepth : nvidia::apex::DestructibleParameters
  • impactVelocityThreshold : nvidia::apex::DestructibleParameters
  • importDestructibleAssetToRootMesh() : nvidia::apex::DestructibleAssetAuthoring
  • importRenderMeshAssetToRootMesh() : nvidia::apex::DestructibleAssetAuthoring
  • impulse : nvidia::apex::FractureEventUnit
  • impulseScale : nvidia::apex::DestructibleRTFractureParameters
  • index : nvidia::apex::ChunkData
  • InstanceAllChunks : FractureTools::FractureCutoutDesc
  • instanceChunks : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • InstanceCongruentChunks : FractureTools::FractureCutoutDesc
  • instancedPositionOffset() : nvidia::apex::ExplicitHierarchicalMesh
  • instancedUVOffset() : nvidia::apex::ExplicitHierarchicalMesh
  • InstanceModeCount : FractureTools::FractureCutoutDesc
  • instancePositionOffset : nvidia::apex::DestructibleChunkDesc
  • instanceUVOffset : nvidia::apex::DestructibleChunkDesc
  • instancingMode : FractureTools::FractureCutoutDesc
  • InstancingMode : FractureTools::FractureCutoutDesc
  • interiorSubmeshIndex : nvidia::apex::FractureMaterialDesc
  • INVALID_CHUNK_INDEX : nvidia::apex::ModuleDestructibleConst
  • invalidateBounds() : nvidia::apex::ModuleDestructible
  • isChunkDestroyed() : nvidia::apex::DestructibleActor
  • isChunkSolitary() : nvidia::apex::DestructibleActor
  • isDestructibleActorJointActive() : nvidia::apex::ModuleDestructible
  • isDynamic() : nvidia::apex::DestructibleActor
  • isHardSleepingEnabled() : nvidia::apex::DestructibleActor
  • isInitiallyDynamic() : nvidia::apex::DestructibleActor
  • islandGeneration : FractureTools::MeshProcessingParameters
  • isPeriodic() : FractureTools::CutoutSet
  • isRuntimeFractureShape() : nvidia::apex::ModuleDestructible
  • isSupportChunk : nvidia::apex::DestructibleChunkDesc
  • isValid()
: nvidia::apex::DestructibleBehaviorGroupDesc
, nvidia::apex::DestructibleAssetCookingDesc
, nvidia::apex::DestructibleGeometryDesc
, nvidia::apex::DamageSpreadFunction
, nvidia::apex::DestructibleChunkDesc
, nvidia::apex::DestructibleActorJointDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • Params : nvidia::apex::DestructibleParameterizedType
  • parentIndex : nvidia::apex::DestructibleChunkDesc , nvidia::apex::ExplicitHierarchicalMesh
  • partCount() : nvidia::apex::ExplicitHierarchicalMesh
  • partIndex() : nvidia::apex::ExplicitHierarchicalMesh
  • partitionMeshByIslands() : nvidia::apex::DestructibleAssetAuthoring
  • position
: nvidia::apex::DamageEventUnit
, nvidia::apex::FractureEventUnit
, nvidia::apex::DamageEventCoreData
  • positionCount : nvidia::apex::ChunkParticleReportData
  • positions : nvidia::apex::ChunkParticleReportData
  • PositiveX : FractureTools::FractureCutoutDesc
  • PositiveY : FractureTools::FractureCutoutDesc
  • PositiveZ : FractureTools::FractureCutoutDesc
  • posX : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • posY : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • posZ : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • radius : nvidia::apex::DamageEventCoreData , nvidia::apex::DamageEventUnit
  • radiusMultiplier : nvidia::apex::DamageSpreadFunction
  • rayCast()
: nvidia::apex::DestructibleActor
, nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • ReadChunkTransform : nvidia::apex::DestructibleActorSyncFlags
  • ReadDamageEvents : nvidia::apex::DestructibleActorSyncFlags
  • ReadFractureEvents : nvidia::apex::DestructibleActorSyncFlags
  • rebuildCollisionGeometry() : nvidia::apex::DestructibleAsset
  • recreateApexEmitter() : nvidia::apex::DestructibleActor
  • reduceHull() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • reduceHulls() : nvidia::apex::ExplicitHierarchicalMesh
  • release()
: nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
, nvidia::apex::ExplicitHierarchicalMesh
, FractureTools::CutoutSet
  • releaseChunkEventBuffer() : nvidia::apex::DestructibleActor
  • releaseDestructibleActor() : nvidia::apex::DestructibleAsset
  • releaseOnNoChunksVisible() : nvidia::apex::UserChunkReport
  • releasePhysXActorBuffer() : nvidia::apex::DestructibleActor
  • removeChunkOverlaps()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • removePlatformMaxDepth() : nvidia::apex::DestructibleAssetAuthoring
  • removeTJunctions : FractureTools::MeshProcessingParameters
  • renderMeshAssetStats : nvidia::apex::DestructibleAssetStats
  • replaceInteriorSubmeshes() : nvidia::apex::ExplicitHierarchicalMesh
  • RTFractureBehaviorGroup : nvidia::apex::DestructibleAssetCookingDesc
  • rtFractureParameters : nvidia::apex::DestructibleParameters
  • runtimeCookedConvexCount : nvidia::apex::DestructibleAssetStats
  • runtimeFracture : nvidia::apex::DestructibleChunkDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • scatterMeshCount : nvidia::apex::DestructibleChunkDesc
  • scatterMeshIndices : nvidia::apex::DestructibleChunkDesc
  • scatterMeshTransforms : nvidia::apex::DestructibleChunkDesc
  • scheduleChunkStateEventCallback() : nvidia::apex::ModuleDestructible
  • sectorRand : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • SegmentIntersect : nvidia::apex::DestructibleActorRaycastFlags
  • segmentRand : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • segmentScale : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • serialize()
: nvidia::apex::ExplicitHierarchicalMesh::Embedding
, nvidia::apex::ExplicitHierarchicalMesh
  • serializeFractureToolState() : nvidia::apex::DestructibleAssetAuthoring
  • set() : nvidia::apex::ExplicitHierarchicalMesh
  • setAngularVelocity() : nvidia::apex::DestructibleActor
  • setBSPBuildParameters()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • setBSPTolerances()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • setChunkCollisionHullCookingScale() : nvidia::apex::ModuleDestructible
  • setChunkCrumbleReport() : nvidia::apex::ModuleDestructible
  • setChunkDustReport() : nvidia::apex::ModuleDestructible
  • setChunkOverlapsCacheDepth() : nvidia::apex::DestructibleAssetAuthoring
  • setChunkPhysXActorAwakeState() : nvidia::apex::DestructibleActor
  • setChunkReport() : nvidia::apex::ModuleDestructible
  • setChunkReportBitMask() : nvidia::apex::ModuleDestructible
  • setChunkReportMaxFractureEventDepth() : nvidia::apex::ModuleDestructible
  • setCoreMesh() : nvidia::apex::DestructibleAssetAuthoring
  • setCrumbleEmitterName() : nvidia::apex::DestructibleAssetAuthoring
  • setCrumbleEmitterState() : nvidia::apex::DestructibleActor
  • setDamageApplicationRaycastFlags() : nvidia::apex::ModuleDestructible
  • setDeleteFracturedChunks() : nvidia::apex::DestructibleActor
  • setDestructibleInitParameters() : nvidia::apex::DestructibleAssetAuthoring
  • setDestructibleParameters()
: nvidia::apex::DestructibleActor
, nvidia::apex::DestructibleAssetAuthoring
  • setDestructiblePhysXActorReport() : nvidia::apex::ModuleDestructible
  • setDustEmitterName() : nvidia::apex::DestructibleAssetAuthoring
  • setDustEmitterState() : nvidia::apex::DestructibleActor
  • setDynamic() : nvidia::apex::DestructibleActor
  • setExplodeView() : nvidia::apex::DestructiblePreview
  • setFracturePatternName() : nvidia::apex::DestructibleAssetAuthoring
  • setGlobalPose() : nvidia::apex::DestructibleActor
  • setHitChunkTrackingParams() : nvidia::apex::DestructibleActor
  • setImpactDamageReportCallback() : nvidia::apex::ModuleDestructible
  • setInitialGlobalPose() : nvidia::apex::DestructibleActor
  • setLinearVelocity() : nvidia::apex::DestructibleActor
  • setMassScaling() : nvidia::apex::ModuleDestructible
  • setMaterialFrame() : nvidia::apex::ExplicitHierarchicalMesh
  • setMaxActorCreatesPerFrame() : nvidia::apex::ModuleDestructible
  • setMaxChunkCount() : nvidia::apex::ModuleDestructible
  • setMaxChunkDepthOffset() : nvidia::apex::ModuleDestructible
  • setMaxChunkSeparationLOD() : nvidia::apex::ModuleDestructible
  • setMaxDynamicChunkIslandCount() : nvidia::apex::ModuleDestructible
  • setMaxFracturesProcessedPerFrame() : nvidia::apex::ModuleDestructible
  • setNeighborPadding() : nvidia::apex::DestructibleAssetAuthoring
  • setNvParameterized() : nvidia::apex::DestructibleActor
  • setPlatformMaxDepth() : nvidia::apex::DestructibleAssetAuthoring
  • setPreferredRenderVolume() : nvidia::apex::DestructibleActor
  • setRenderMeshAsset()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • setRootMesh() : nvidia::apex::DestructibleAssetAuthoring
  • setRuntimeFractureOverridePattern() : nvidia::apex::DestructibleActor
  • setScatterMeshAssets() : nvidia::apex::DestructibleAssetAuthoring
  • setSkinnedOverrideMaterial() : nvidia::apex::DestructibleActor
  • setSortByBenefit() : nvidia::apex::ModuleDestructible
  • setStaticOverrideMaterial() : nvidia::apex::DestructibleActor
  • setSyncParams()
: nvidia::apex::DestructibleActor
, nvidia::apex::ModuleDestructible
  • setToDefault()
: nvidia::apex::FractureMaterialDesc
, nvidia::apex::DestructibleActorJointDesc
, FractureTools::FractureCutoutDesc
, nvidia::apex::DestructibleDepthParameters
, nvidia::apex::DestructibleParameters
, FractureTools::FractureSliceDesc
, nvidia::apex::DamageSpreadFunction
, nvidia::apex::DestructibleBehaviorGroupDesc
, nvidia::apex::DestructibleChunkDesc
, FractureTools::SliceParameters
, nvidia::apex::DestructibleAssetCookingDesc
, nvidia::apex::CollisionVolumeDesc
, nvidia::apex::CollisionDesc
, nvidia::apex::DestructibleInitParameters
, FractureTools::MeshProcessingParameters
, FractureTools::NoiseParameters
, FractureTools::CutoutParameters
, nvidia::apex::DestructibleGeometryDesc
, nvidia::apex::DestructibleRTFractureParameters
, FractureTools::FractureVoronoiDesc
  • setToMostExpensive() : nvidia::apex::DestructibleDepthParameters
  • setUseLegacyChunkBoundsTesting() : nvidia::apex::ModuleDestructible
  • setUseLegacyDamageRadiusSpread() : nvidia::apex::ModuleDestructible
  • setValidBoundsPadding() : nvidia::apex::ModuleDestructible
  • setWorldSupportPhysXScene() : nvidia::apex::ModuleDestructible
  • sheetFracture : nvidia::apex::DestructibleRTFractureParameters
  • siteCount : FractureTools::FractureVoronoiDesc
  • sites : FractureTools::FractureVoronoiDesc
  • Skinned : nvidia::apex::DestructibleActorMeshType
  • Slice : nvidia::apex::FractureMethod
  • SliceFractureCutoutChunks : FractureTools::FractureCutoutDesc
  • SliceParameters() : FractureTools::SliceParameters
  • sliceParameters : FractureTools::FractureSliceDesc
  • splitNonconvexRegions : FractureTools::FractureCutoutDesc
  • splitsPerPass : FractureTools::SliceParameters
  • State : nvidia::apex::DestructibleParameterizedType
  • stateEventList : nvidia::apex::ChunkStateEventData
  • stateEventListSize : nvidia::apex::ChunkStateEventData
  • Static : nvidia::apex::DestructiblePhysXActorQueryFlags , nvidia::apex::DestructibleActorMeshType
  • StaticChunks : nvidia::apex::DestructibleActorRaycastFlags
  • submeshCount() : nvidia::apex::ExplicitHierarchicalMesh
  • submeshData() : nvidia::apex::ExplicitHierarchicalMesh
  • supportDepth : nvidia::apex::DestructibleInitParameters
  • supportGraphEdgeCount : nvidia::apex::DestructibleAssetCookingDesc
  • supportGraphEdges : nvidia::apex::DestructibleAssetCookingDesc
  • supportStrength : nvidia::apex::DestructibleParameters
  • surfaceNormal()
: nvidia::apex::ExplicitHierarchicalMesh
, nvidia::apex::DestructibleChunkDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • takeImpact() : nvidia::apex::DestructibleActor
  • tangent : nvidia::apex::FractureMaterialDesc
  • targetProportions : FractureTools::FractureSliceDesc
  • Through : FractureTools::SliceParameters
  • tileFractureMap : FractureTools::FractureCutoutDesc
  • totalBytes : nvidia::apex::DestructibleAssetStats
  • totalNumberOfFractureEvents : nvidia::apex::DamageEventReportData
  • trimCollisionGeometry() : nvidia::apex::DestructibleAssetAuthoring
  • trimFaceCollisionHulls : FractureTools::FractureCutoutDesc
  • type : nvidia::apex::DestructibleActorJointDesc , FractureTools::NoiseParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • uAngle : nvidia::apex::FractureMaterialDesc
  • Unknown : nvidia::apex::FractureMethod
  • USE_VALID_BOUNDS : nvidia::apex::DestructibleParametersFlag
  • useDisplacementMaps : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • useDynamicChunksGroupsMask : nvidia::apex::DestructibleParameters
  • useInstancedRendering : nvidia::apex::DestructibleChunkDesc
  • USER_FLAG_0 : nvidia::apex::DestructibleDepthParametersFlag
  • USER_FLAG_1 : nvidia::apex::DestructibleDepthParametersFlag
  • USER_FLAG_2 : nvidia::apex::DestructibleDepthParametersFlag
  • USER_FLAG_3 : nvidia::apex::DestructibleDepthParametersFlag
  • userActorID
: nvidia::apex::DamageEventHeader
, nvidia::apex::FractureEventHeader
, nvidia::apex::ChunkTransformHeader
  • userData : nvidia::apex::DestructibleBehaviorGroupDesc
  • UserDefined : FractureTools::FractureCutoutDesc
  • userDefinedCutoutParameters : FractureTools::FractureCutoutDesc
  • userDefinedDirection : FractureTools::FractureCutoutDesc
  • userUVMapping : FractureTools::FractureCutoutDesc
  • useTargetProportions : FractureTools::FractureSliceDesc
  • uvOffset : nvidia::apex::FractureMaterialDesc
  • uvScale : nvidia::apex::FractureMaterialDesc
  • uvTileSize : FractureTools::FractureCutoutDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- v -

  • validBounds : nvidia::apex::DestructibleParameters
  • velocities : nvidia::apex::ChunkParticleReportData
  • velocityCount : nvidia::apex::ChunkParticleReportData
  • verbosity : FractureTools::MeshProcessingParameters
  • VisibilityChanged : nvidia::apex::DestructibleChunkEvent
  • visualize() : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeMeshBSPAllRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeMeshBSPInsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeMeshBSPOutsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeMeshBSPSingleRegion : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeSliceBSPInsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeSliceBSPOutsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeSliceBSPSingleRegion : nvidia::apex::ExplicitHierarchicalMesh
  • visualizeVoronoiCells()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • Voronoi : nvidia::apex::FractureMethod
  • VoronoiFractureCutoutChunks : FractureTools::FractureCutoutDesc
  • voronoiSplitChunk()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • WORLD_SUPPORT : nvidia::apex::DestructibleInitParametersFlag
  • WORLD_SUPPORTED : nvidia::apex::ApexChunkFlag
  • worldBounds : nvidia::apex::ChunkData , nvidia::apex::DamageEventReportData
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- x -

  • XYZ : FractureTools::SliceParameters
  • XZY : FractureTools::SliceParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- y -

  • YXZ : FractureTools::SliceParameters
  • YZX : FractureTools::SliceParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Enumerations

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • ChunkFlags : nvidia::apex::DestructibleAsset
  • CutoutChunkFracturingMethod : FractureTools::FractureCutoutDesc
  • DataType : nvidia::apex::ExplicitHierarchicalMesh::Embedding
  • Directions : FractureTools::FractureCutoutDesc
  • Enum
: nvidia::apex::DestructibleEmitterType
, nvidia::apex::DestructibleParameterizedType
, nvidia::apex::DestructiblePhysXActorQueryFlags
, nvidia::apex::DestructibleActorRaycastFlags
, nvidia::apex::DestructibleActorMeshType
, nvidia::apex::ModuleDestructibleConst
, nvidia::apex::ApexChunkFlag
, nvidia::apex::ExplicitHierarchicalMesh
, nvidia::apex::BSPOpenMode
, nvidia::apex::FractureMethod
, nvidia::apex::DestructibleInitParametersFlag
, nvidia::apex::DestructibleParametersFlag
, nvidia::apex::DestructibleDepthParametersFlag
, nvidia::apex::DestructibleActorChunkFlags
, nvidia::apex::DestructibleCallbackSchedule
, nvidia::apex::DestructibleActorSyncFlags
  • EventMask : nvidia::apex::DestructibleChunkEvent
  • InstancingMode : FractureTools::FractureCutoutDesc
  • NoiseMode : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • Order : FractureTools::SliceParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Enumerator

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- a -

  • ACCUMULATE_DAMAGE : nvidia::apex::DestructibleParametersFlag
  • ACCURATE_RAYCASTS : nvidia::apex::DestructibleParametersFlag
  • AllChunks : nvidia::apex::DestructibleActorRaycastFlags
  • AllowActorsNotInScenes : nvidia::apex::DestructiblePhysXActorQueryFlags
  • AllowRedundancy : nvidia::apex::DestructiblePhysXActorQueryFlags
  • AllStates : nvidia::apex::DestructiblePhysXActorQueryFlags
  • ASSET_DEFINED_SUPPORT : nvidia::apex::DestructibleInitParametersFlag
  • Automatic : nvidia::apex::BSPOpenMode

- b -

  • BeforeTick : nvidia::apex::DestructibleCallbackSchedule
  • BSPOpenModeCount : nvidia::apex::BSPOpenMode

- c -

  • ChunkAndDescendentsDoNotFracture : nvidia::apex::DestructibleAsset
  • ChunkDoesNotCrumble : nvidia::apex::DestructibleAsset
  • ChunkDoesNotFracture : nvidia::apex::DestructibleAsset
  • ChunkEnvironmentallySupported : nvidia::apex::DestructibleAsset
  • ChunkIsInstanced : nvidia::apex::DestructibleAsset
  • ChunkIsWorldSupported : nvidia::apex::DestructibleActorChunkFlags
  • ChunkRuntimeFracture : nvidia::apex::DestructibleAsset
  • ChunkVisible : nvidia::apex::DestructibleChunkEvent
  • Closed : nvidia::apex::BSPOpenMode
  • CopyChunkTransform : nvidia::apex::DestructibleActorSyncFlags
  • CopyDamageEvents : nvidia::apex::DestructibleActorSyncFlags
  • CopyFractureEvents : nvidia::apex::DestructibleActorSyncFlags
  • Count
: nvidia::apex::DestructibleEmitterType
, nvidia::apex::DestructibleCallbackSchedule
, nvidia::apex::DestructibleActorMeshType
  • Crumble : nvidia::apex::DestructibleEmitterType
  • CRUMBLE_SMALLEST_CHUNKS : nvidia::apex::DestructibleParametersFlag
  • CRUMBLE_VIA_RUNTIME_FRACTURE : nvidia::apex::DestructibleParametersFlag
  • Cutout : nvidia::apex::FractureMethod
  • CutoutChunkFracturingMethodCount : FractureTools::FractureCutoutDesc

- d -

  • DEBRIS_MAX_SEPARATION : nvidia::apex::DestructibleParametersFlag
  • DEBRIS_TIMEOUT : nvidia::apex::DestructibleParametersFlag
  • DESTROYED_CRUMBLED : nvidia::apex::ApexChunkFlag
  • DESTROYED_ENTERED_USER_BOUNDS : nvidia::apex::ApexChunkFlag
  • DESTROYED_EXCEEDED_MAX_DISTANCE : nvidia::apex::ApexChunkFlag
  • DESTROYED_FIFO_FULL : nvidia::apex::ApexChunkFlag
  • DESTROYED_LEFT_USER_BOUNDS : nvidia::apex::ApexChunkFlag
  • DESTROYED_LEFT_VALID_BOUNDS : nvidia::apex::ApexChunkFlag
  • DESTROYED_TIMED_OUT : nvidia::apex::ApexChunkFlag
  • DirectionCount : FractureTools::FractureCutoutDesc
  • Disabled : nvidia::apex::DestructibleCallbackSchedule
  • DoNotFractureCutoutChunks : FractureTools::FractureCutoutDesc
  • DoNotInstance : FractureTools::FractureCutoutDesc
  • Dormant : nvidia::apex::DestructiblePhysXActorQueryFlags
  • Dust : nvidia::apex::DestructibleEmitterType
  • Dynamic : nvidia::apex::DestructiblePhysXActorQueryFlags
  • DYNAMIC : nvidia::apex::ApexChunkFlag
  • DynamicChunks : nvidia::apex::DestructibleActorRaycastFlags

- e -

  • EXTERNALLY_SUPPORTED : nvidia::apex::ApexChunkFlag

- f -

  • FetchResults : nvidia::apex::DestructibleCallbackSchedule
  • ForceAccurateRaycastsOff : nvidia::apex::DestructibleActorRaycastFlags
  • ForceAccurateRaycastsOn : nvidia::apex::DestructibleActorRaycastFlags
  • FORM_EXTENDED_STRUCTURES : nvidia::apex::DestructibleInitParametersFlag
  • FRACTURED : nvidia::apex::ApexChunkFlag
  • FractureMethodCount : nvidia::apex::FractureMethod

- i -

  • IGNORE_CONTACT_CALLBACKS : nvidia::apex::DestructibleDepthParametersFlag
  • IGNORE_POSE_UPDATES : nvidia::apex::DestructibleDepthParametersFlag
  • IGNORE_RAYCAST_CALLBACKS : nvidia::apex::DestructibleDepthParametersFlag
  • InstanceAllChunks : FractureTools::FractureCutoutDesc
  • InstanceCongruentChunks : FractureTools::FractureCutoutDesc
  • InstanceModeCount : FractureTools::FractureCutoutDesc
  • INVALID_CHUNK_INDEX : nvidia::apex::ModuleDestructibleConst

- k -

  • kDepthParametersCountMax : nvidia::apex::DestructibleParameters

- l -

  • Last : nvidia::apex::DestructibleActorSyncFlags

- m -

  • MaterialLibrary : nvidia::apex::ExplicitHierarchicalMesh::Embedding
  • MaterialNameBufferSize : nvidia::apex::ExplicitSubmeshData

- n -

  • NegativeX : FractureTools::FractureCutoutDesc
  • NegativeY : FractureTools::FractureCutoutDesc
  • NegativeZ : FractureTools::FractureCutoutDesc
  • NoChunks : nvidia::apex::DestructibleActorRaycastFlags
  • NoiseModeCount : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • NoisePerlin2D : FractureTools::FractureVoronoiDesc , FractureTools::FractureSliceDesc
  • NoisePerlin3D : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • NoiseWavePlane : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • None : nvidia::apex::DestructiblePhysXActorQueryFlags , nvidia::apex::DestructibleActorSyncFlags

- o -

  • Open : nvidia::apex::BSPOpenMode
  • OVERRIDE_IMPACT_DAMAGE : nvidia::apex::DestructibleDepthParametersFlag
  • OVERRIDE_IMPACT_DAMAGE_VALUE : nvidia::apex::DestructibleDepthParametersFlag

- p -

  • Params : nvidia::apex::DestructibleParameterizedType
  • PositiveX : FractureTools::FractureCutoutDesc
  • PositiveY : FractureTools::FractureCutoutDesc
  • PositiveZ : FractureTools::FractureCutoutDesc

- r -

  • ReadChunkTransform : nvidia::apex::DestructibleActorSyncFlags
  • ReadDamageEvents : nvidia::apex::DestructibleActorSyncFlags
  • ReadFractureEvents : nvidia::apex::DestructibleActorSyncFlags

- s -

  • SegmentIntersect : nvidia::apex::DestructibleActorRaycastFlags
  • Skinned : nvidia::apex::DestructibleActorMeshType
  • Slice : nvidia::apex::FractureMethod
  • SliceFractureCutoutChunks : FractureTools::FractureCutoutDesc
  • State : nvidia::apex::DestructibleParameterizedType
  • Static : nvidia::apex::DestructiblePhysXActorQueryFlags , nvidia::apex::DestructibleActorMeshType
  • StaticChunks : nvidia::apex::DestructibleActorRaycastFlags

- t -

  • Through : FractureTools::SliceParameters

- u -

  • Unknown : nvidia::apex::FractureMethod
  • USE_VALID_BOUNDS : nvidia::apex::DestructibleParametersFlag
  • USER_FLAG_0 : nvidia::apex::DestructibleDepthParametersFlag
  • USER_FLAG_1 : nvidia::apex::DestructibleDepthParametersFlag
  • USER_FLAG_2 : nvidia::apex::DestructibleDepthParametersFlag
  • USER_FLAG_3 : nvidia::apex::DestructibleDepthParametersFlag
  • UserDefined : FractureTools::FractureCutoutDesc

- v -

  • VisibilityChanged : nvidia::apex::DestructibleChunkEvent
  • VisualizeMeshBSPAllRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeMeshBSPInsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeMeshBSPOutsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeMeshBSPSingleRegion : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeSliceBSPInsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeSliceBSPOutsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeSliceBSPSingleRegion : nvidia::apex::ExplicitHierarchicalMesh
  • Voronoi : nvidia::apex::FractureMethod
  • VoronoiFractureCutoutChunks : FractureTools::FractureCutoutDesc

- w -

  • WORLD_SUPPORT : nvidia::apex::DestructibleInitParametersFlag
  • WORLD_SUPPORTED : nvidia::apex::ApexChunkFlag

- x -

  • XYZ : FractureTools::SliceParameters
  • XZY : FractureTools::SliceParameters

- y -

  • YXZ : FractureTools::SliceParameters
  • YZX : FractureTools::SliceParameters

- z -

  • ZXY : FractureTools::SliceParameters
  • ZYX : FractureTools::SliceParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- a -

  • acquireChunkEventBuffer() : nvidia::apex::DestructibleActor
  • acquirePhysXActorBuffer() : nvidia::apex::DestructibleActor
  • acquireRenderableReference() : nvidia::apex::DestructibleActor
  • addChunkOverlaps()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • addForce() : nvidia::apex::DestructibleActor
  • addMaterialFrame() : nvidia::apex::ExplicitHierarchicalMesh
  • addSubmesh() : nvidia::apex::ExplicitHierarchicalMesh
  • appendActorTransforms() : nvidia::apex::DestructibleAssetAuthoring
  • applyDamage() : nvidia::apex::DestructibleActor
  • applyRadiusDamage()
: nvidia::apex::DestructibleActor
, nvidia::apex::ModuleDestructible
  • applyTransformation()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- j -

  • joint() : nvidia::apex::DestructibleActorJoint
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- m -

  • MaterialFrame() : nvidia::apex::MaterialFrame
  • maxDepth() : nvidia::apex::ExplicitHierarchicalMesh
  • meshBounds() : nvidia::apex::ExplicitHierarchicalMesh
  • MeshProcessingParameters() : FractureTools::MeshProcessingParameters
  • meshTriangleCount() : nvidia::apex::ExplicitHierarchicalMesh
  • meshTriangles() : nvidia::apex::ExplicitHierarchicalMesh
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- n -

  • NoiseParameters() : FractureTools::NoiseParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- o -

  • obbSweep() : nvidia::apex::DestructibleActor
  • onDamageNotify() : nvidia::apex::UserChunkReport
  • onDestructibleSleep() : nvidia::apex::UserChunkReport
  • onDestructibleWake() : nvidia::apex::UserChunkReport
  • onImpactDamageNotify() : nvidia::apex::UserImpactDamageReport
  • onParticleEmission() : nvidia::apex::UserChunkParticleReport
  • onPhysXActorCreate() : nvidia::apex::UserDestructiblePhysXActorReport
  • onPhysXActorRelease() : nvidia::apex::UserDestructiblePhysXActorReport
  • onPreProcessReadBegin() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onPreProcessReadDone() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onReadBegin() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onReadDone() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onStateChangeNotify() : nvidia::apex::UserChunkReport
  • onWriteBegin() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onWriteDone() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • operator!=() : nvidia::apex::ExplicitVertexFormat , nvidia::apex::ExplicitSubmeshData
  • operator==() : nvidia::apex::ExplicitSubmeshData , nvidia::apex::ExplicitVertexFormat
  • overrideImpactDamage() : nvidia::apex::DestructibleDepthParameters
  • overrideImpactDamageValue() : nvidia::apex::DestructibleDepthParameters
  • owns() : nvidia::apex::ModuleDestructible
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- ~ -

  • ~ConvexHull() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • ~CutoutSet() : FractureTools::CutoutSet
  • ~DestructibleActor() : nvidia::apex::DestructibleActor
  • ~DestructibleActorJoint() : nvidia::apex::DestructibleActorJoint
  • ~DestructibleAsset() : nvidia::apex::DestructibleAsset
  • ~DestructibleRenderable() : nvidia::apex::DestructibleRenderable
  • ~DisplacementMapVolume() : nvidia::apex::DisplacementMapVolume
  • ~ExplicitHierarchicalMesh() : nvidia::apex::ExplicitHierarchicalMesh
  • ~ModuleDestructible() : nvidia::apex::ModuleDestructible
  • ~UserChunkParticleReport() : nvidia::apex::UserChunkParticleReport
  • ~UserChunkReport() : nvidia::apex::UserChunkReport
  • ~UserDestructiblePhysXActorReport() : nvidia::apex::UserDestructiblePhysXActorReport
  • ~UserDestructibleSyncHandler() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- b -

  • buildCollisionGeometryForPart() : nvidia::apex::ExplicitHierarchicalMesh
  • buildCollisionGeometryForRootChunkParts() : nvidia::apex::ExplicitHierarchicalMesh
  • buildCoordinateSystemFromMaterialDesc() : nvidia::apex::MaterialFrame
  • buildCutoutSet()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • buildExplicitHierarchicalMesh()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • buildExplicitHierarchicalMeshFromDestructibleAsset() : nvidia::apex::FractureToolsAPI
  • buildExplicitHierarchicalMeshFromRenderMeshAsset() : nvidia::apex::FractureToolsAPI
  • buildFromPoints() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • buildSliceMesh()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- c -

  • cacheChunkOverlapsUpToDepth()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • calculateCutoutUVMapping()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • calculateMeshBSP() : nvidia::apex::ExplicitHierarchicalMesh
  • chunkBounds() : nvidia::apex::ExplicitHierarchicalMesh
  • chunkCount() : nvidia::apex::ExplicitHierarchicalMesh
  • chunkFlags() : nvidia::apex::ExplicitHierarchicalMesh
  • chunkUniqueID() : nvidia::apex::ExplicitHierarchicalMesh
  • clear()
: nvidia::apex::ExplicitVertexFormat
, nvidia::apex::ExplicitHierarchicalMesh
  • clearActorTransforms() : nvidia::apex::DestructibleAssetAuthoring
  • clearChunkOverlaps()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • CollisionDesc() : nvidia::apex::CollisionDesc
  • CollisionVolumeDesc() : nvidia::apex::CollisionVolumeDesc
  • ConvexHull() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • convexHullCount() : nvidia::apex::ExplicitHierarchicalMesh
  • convexHulls() : nvidia::apex::ExplicitHierarchicalMesh
  • cookChunks() : nvidia::apex::DestructibleAssetAuthoring
  • copyToVertexFormat() : nvidia::apex::ExplicitVertexFormat
  • createChippedMesh()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • createCutoutSet() : nvidia::apex::FractureToolsAPI
  • createDestructibleActorFromDeserializedState() : nvidia::apex::DestructibleAsset
  • createDestructibleActorJoint() : nvidia::apex::ModuleDestructible
  • createExplicitHierarchicalMesh() : nvidia::apex::FractureToolsAPI
  • createExplicitHierarchicalMeshConvexHull()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • createHierarchicallySplitMesh()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • createScatterMeshSites()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • createVoronoiSitesInsideMesh()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • createVoronoiSplitMesh()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • CutoutParameters() : FractureTools::CutoutParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- d -

  • DamageSpreadFunction() : nvidia::apex::DamageSpreadFunction
  • deserialize()
: nvidia::apex::ExplicitHierarchicalMesh::Embedding
, nvidia::apex::ExplicitHierarchicalMesh
  • deserializeFractureToolState() : nvidia::apex::DestructibleAssetAuthoring
  • DestructibleActorJointDesc() : nvidia::apex::DestructibleActorJointDesc
  • DestructibleAssetCookingDesc() : nvidia::apex::DestructibleAssetCookingDesc
  • DestructibleBehaviorGroupDesc() : nvidia::apex::DestructibleBehaviorGroupDesc
  • DestructibleChunkDesc() : nvidia::apex::DestructibleChunkDesc
  • DestructibleDepthParameters() : nvidia::apex::DestructibleDepthParameters
  • DestructibleGeometryDesc() : nvidia::apex::DestructibleGeometryDesc
  • DestructibleInitParameters() : nvidia::apex::DestructibleInitParameters
  • DestructibleParameters() : nvidia::apex::DestructibleParameters
  • DestructiblePreview() : nvidia::apex::DestructiblePreview
  • disableHardSleeping() : nvidia::apex::DestructibleActor
  • displacementMapVolume() : nvidia::apex::ExplicitHierarchicalMesh
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- e -

  • enableHardSleeping() : nvidia::apex::DestructibleActor
  • ExplicitHierarchicalMesh() : nvidia::apex::ExplicitHierarchicalMesh
  • ExplicitVertexFormat() : nvidia::apex::ExplicitVertexFormat
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- f -

  • forceChunkHits() : nvidia::apex::DestructibleActor
  • forceDamageColoring() : nvidia::apex::DestructibleActor
  • FractureCutoutDesc() : FractureTools::FractureCutoutDesc
  • FractureMaterialDesc() : nvidia::apex::FractureMaterialDesc
  • FractureSliceDesc() : FractureTools::FractureSliceDesc
  • FractureVoronoiDesc() : FractureTools::FractureVoronoiDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- g -

  • getActorTransformCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getActorTransforms()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • getApexEmitter() : nvidia::apex::DestructibleActor
  • getBehaviorGroup() : nvidia::apex::DestructibleActor
  • getBounds() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getCachedOverlapCountAtDepth()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getCachedOverlapsAtDepth()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkActorFlags() : nvidia::apex::DestructibleActor
  • getChunkActorLocalBounds() : nvidia::apex::DestructibleAsset
  • getChunkAngularVelocity() : nvidia::apex::DestructibleActor
  • getChunkBehaviorGroupIndex() : nvidia::apex::DestructibleActor
  • getChunkBounds() : nvidia::apex::DestructibleActor
  • getChunkChild() : nvidia::apex::DestructibleAssetAuthoring
  • getChunkChildCount() : nvidia::apex::DestructibleAssetAuthoring
  • getChunkCollisionHullCookingScale() : nvidia::apex::ModuleDestructible
  • getChunkCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkDepth() : nvidia::apex::DestructibleAsset
  • getChunkFlags() : nvidia::apex::DestructibleAsset
  • getChunkLinearVelocity() : nvidia::apex::DestructibleActor
  • getChunkLocalBounds() : nvidia::apex::DestructibleActor
  • getChunkParentIndex() : nvidia::apex::DestructibleAsset
  • getChunkPhysXActor() : nvidia::apex::DestructibleActor
  • getChunkPhysXShapes() : nvidia::apex::DestructibleActor
  • getChunkPose() : nvidia::apex::DestructibleActor
  • getChunkPositionOffset()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkTM() : nvidia::apex::DestructibleActor
  • getChunkTransform() : nvidia::apex::DestructibleActor
  • getChunkUVOffset()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkVisibilities() : nvidia::apex::DestructibleActor
  • getCoreExplicitHierarchicalMesh() : nvidia::apex::DestructibleAssetAuthoring
  • getCrumbleEmitterName() : nvidia::apex::DestructibleAsset
  • getCustomBehaviorGroupCount() : nvidia::apex::DestructibleActor
  • getCutoutCount() : FractureTools::CutoutSet
  • getCutoutLoopCount() : FractureTools::CutoutSet
  • getCutoutLoopSize() : FractureTools::CutoutSet
  • getCutoutLoopVertexFlags() : FractureTools::CutoutSet
  • getCutoutLoopVertexIndex() : FractureTools::CutoutSet
  • getCutoutSet() : nvidia::apex::DestructibleAssetAuthoring
  • getCutoutVertex() : FractureTools::CutoutSet
  • getCutoutVertexCount() : FractureTools::CutoutSet
  • getDamageColoringHistory() : nvidia::apex::DestructibleActor
  • getData() : nvidia::apex::DisplacementMapVolume
  • getDepthCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getDestructibleAndChunk() : nvidia::apex::ModuleDestructible
  • getDestructibleInitParameters()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getDestructibleParameters()
: nvidia::apex::DestructibleActor
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getDimensions() : FractureTools::CutoutSet
  • getDustEmitterName() : nvidia::apex::DestructibleAsset
  • getEdgeCount() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getEdgeEndpoint() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getExplicitHierarchicalMesh() : nvidia::apex::DestructibleAssetAuthoring
  • getFractureImpulseScale() : nvidia::apex::DestructibleAssetAuthoring
  • getFractureTools() : nvidia::apex::ModuleDestructible
  • getGlobalPose() : nvidia::apex::DestructibleActor
  • getHitChunkHistory() : nvidia::apex::DestructibleActor
  • getImpactVelocityThreshold() : nvidia::apex::DestructibleAssetAuthoring
  • getInitialGlobalPose() : nvidia::apex::DestructibleActor
  • getInstancedChunkMeshCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getLocalBounds() : nvidia::apex::DestructibleActor
  • getMaterialFrame() : nvidia::apex::ExplicitHierarchicalMesh
  • getMaterialFrameCount() : nvidia::apex::ExplicitHierarchicalMesh
  • getNeighborPadding() : nvidia::apex::DestructibleAssetAuthoring
  • getNumVisibleChunks() : nvidia::apex::DestructibleActor
  • getNvParameterized() : nvidia::apex::DestructibleActor
  • getOriginalBounds() : nvidia::apex::DestructibleActor
  • getPartConvexHullArray() : nvidia::apex::DestructibleAsset
  • getPartConvexHullCount() : nvidia::apex::DestructibleAsset
  • getPartIndex()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • getPlane() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getPlaneCount() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getRenderMeshActor()
: nvidia::apex::DestructiblePreview
, nvidia::apex::DestructibleActor
, nvidia::apex::DestructibleRenderable
  • getRenderMeshAsset()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • getScale() : nvidia::apex::DestructibleActor
  • getScatterMeshAssetCount()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • getScatterMeshAssets()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getStats()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • getSupportDepth() : nvidia::apex::DestructibleActor
  • getSupportDepthChunkIndices() : nvidia::apex::DestructibleActor
  • getVertex() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getVertexCount() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getVisibleChunks() : nvidia::apex::DestructibleActor
  • getVolume() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- h -

  • hasUserFlagSet() : nvidia::apex::DestructibleDepthParameters
  • hierarchicallySplitChunk()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- i -

  • ignoresContactCallbacks() : nvidia::apex::DestructibleDepthParameters
  • ignoresPoseUpdates() : nvidia::apex::DestructibleDepthParameters
  • ignoresRaycastCallbacks() : nvidia::apex::DestructibleDepthParameters
  • importDestructibleAssetToRootMesh() : nvidia::apex::DestructibleAssetAuthoring
  • importRenderMeshAssetToRootMesh() : nvidia::apex::DestructibleAssetAuthoring
  • instancedPositionOffset() : nvidia::apex::ExplicitHierarchicalMesh
  • instancedUVOffset() : nvidia::apex::ExplicitHierarchicalMesh
  • invalidateBounds() : nvidia::apex::ModuleDestructible
  • isChunkDestroyed() : nvidia::apex::DestructibleActor
  • isChunkSolitary() : nvidia::apex::DestructibleActor
  • isDestructibleActorJointActive() : nvidia::apex::ModuleDestructible
  • isDynamic() : nvidia::apex::DestructibleActor
  • isHardSleepingEnabled() : nvidia::apex::DestructibleActor
  • isInitiallyDynamic() : nvidia::apex::DestructibleActor
  • isPeriodic() : FractureTools::CutoutSet
  • isRuntimeFractureShape() : nvidia::apex::ModuleDestructible
  • isValid()
: nvidia::apex::DamageSpreadFunction
, nvidia::apex::DestructibleGeometryDesc
, nvidia::apex::DestructibleActorJointDesc
, nvidia::apex::DestructibleBehaviorGroupDesc
, nvidia::apex::DestructibleChunkDesc
, nvidia::apex::DestructibleAssetCookingDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- p -

  • parentIndex() : nvidia::apex::ExplicitHierarchicalMesh
  • partCount() : nvidia::apex::ExplicitHierarchicalMesh
  • partIndex() : nvidia::apex::ExplicitHierarchicalMesh
  • partitionMeshByIslands() : nvidia::apex::DestructibleAssetAuthoring
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- r -

  • rayCast()
: nvidia::apex::DestructibleActor
, nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • rebuildCollisionGeometry() : nvidia::apex::DestructibleAsset
  • recreateApexEmitter() : nvidia::apex::DestructibleActor
  • reduceHull() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • reduceHulls() : nvidia::apex::ExplicitHierarchicalMesh
  • release()
: nvidia::apex::ExplicitHierarchicalMesh
, FractureTools::CutoutSet
, nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • releaseChunkEventBuffer() : nvidia::apex::DestructibleActor
  • releaseDestructibleActor() : nvidia::apex::DestructibleAsset
  • releaseOnNoChunksVisible() : nvidia::apex::UserChunkReport
  • releasePhysXActorBuffer() : nvidia::apex::DestructibleActor
  • removeChunkOverlaps()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • removePlatformMaxDepth() : nvidia::apex::DestructibleAssetAuthoring
  • replaceInteriorSubmeshes() : nvidia::apex::ExplicitHierarchicalMesh
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- s -

  • scheduleChunkStateEventCallback() : nvidia::apex::ModuleDestructible
  • serialize()
: nvidia::apex::ExplicitHierarchicalMesh::Embedding
, nvidia::apex::ExplicitHierarchicalMesh
  • serializeFractureToolState() : nvidia::apex::DestructibleAssetAuthoring
  • set() : nvidia::apex::ExplicitHierarchicalMesh
  • setAngularVelocity() : nvidia::apex::DestructibleActor
  • setBSPBuildParameters()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • setBSPTolerances()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • setChunkCollisionHullCookingScale() : nvidia::apex::ModuleDestructible
  • setChunkCrumbleReport() : nvidia::apex::ModuleDestructible
  • setChunkDustReport() : nvidia::apex::ModuleDestructible
  • setChunkOverlapsCacheDepth() : nvidia::apex::DestructibleAssetAuthoring
  • setChunkPhysXActorAwakeState() : nvidia::apex::DestructibleActor
  • setChunkReport() : nvidia::apex::ModuleDestructible
  • setChunkReportBitMask() : nvidia::apex::ModuleDestructible
  • setChunkReportMaxFractureEventDepth() : nvidia::apex::ModuleDestructible
  • setCoreMesh() : nvidia::apex::DestructibleAssetAuthoring
  • setCrumbleEmitterName() : nvidia::apex::DestructibleAssetAuthoring
  • setCrumbleEmitterState() : nvidia::apex::DestructibleActor
  • setDamageApplicationRaycastFlags() : nvidia::apex::ModuleDestructible
  • setDeleteFracturedChunks() : nvidia::apex::DestructibleActor
  • setDestructibleInitParameters() : nvidia::apex::DestructibleAssetAuthoring
  • setDestructibleParameters()
: nvidia::apex::DestructibleActor
, nvidia::apex::DestructibleAssetAuthoring
  • setDestructiblePhysXActorReport() : nvidia::apex::ModuleDestructible
  • setDustEmitterName() : nvidia::apex::DestructibleAssetAuthoring
  • setDustEmitterState() : nvidia::apex::DestructibleActor
  • setDynamic() : nvidia::apex::DestructibleActor
  • setExplodeView() : nvidia::apex::DestructiblePreview
  • setFracturePatternName() : nvidia::apex::DestructibleAssetAuthoring
  • setGlobalPose() : nvidia::apex::DestructibleActor
  • setHitChunkTrackingParams() : nvidia::apex::DestructibleActor
  • setImpactDamageReportCallback() : nvidia::apex::ModuleDestructible
  • setInitialGlobalPose() : nvidia::apex::DestructibleActor
  • setLinearVelocity() : nvidia::apex::DestructibleActor
  • setMassScaling() : nvidia::apex::ModuleDestructible
  • setMaterialFrame() : nvidia::apex::ExplicitHierarchicalMesh
  • setMaxActorCreatesPerFrame() : nvidia::apex::ModuleDestructible
  • setMaxChunkCount() : nvidia::apex::ModuleDestructible
  • setMaxChunkDepthOffset() : nvidia::apex::ModuleDestructible
  • setMaxChunkSeparationLOD() : nvidia::apex::ModuleDestructible
  • setMaxDynamicChunkIslandCount() : nvidia::apex::ModuleDestructible
  • setMaxFracturesProcessedPerFrame() : nvidia::apex::ModuleDestructible
  • setNeighborPadding() : nvidia::apex::DestructibleAssetAuthoring
  • setNvParameterized() : nvidia::apex::DestructibleActor
  • setPlatformMaxDepth() : nvidia::apex::DestructibleAssetAuthoring
  • setPreferredRenderVolume() : nvidia::apex::DestructibleActor
  • setRenderMeshAsset()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • setRootMesh() : nvidia::apex::DestructibleAssetAuthoring
  • setRuntimeFractureOverridePattern() : nvidia::apex::DestructibleActor
  • setScatterMeshAssets() : nvidia::apex::DestructibleAssetAuthoring
  • setSkinnedOverrideMaterial() : nvidia::apex::DestructibleActor
  • setSortByBenefit() : nvidia::apex::ModuleDestructible
  • setStaticOverrideMaterial() : nvidia::apex::DestructibleActor
  • setSyncParams()
: nvidia::apex::ModuleDestructible
, nvidia::apex::DestructibleActor
  • setToDefault()
: FractureTools::CutoutParameters
, nvidia::apex::DestructibleParameters
, nvidia::apex::DestructibleActorJointDesc
, nvidia::apex::DestructibleInitParameters
, nvidia::apex::DamageSpreadFunction
, FractureTools::FractureSliceDesc
, nvidia::apex::FractureMaterialDesc
, nvidia::apex::CollisionVolumeDesc
, FractureTools::MeshProcessingParameters
, FractureTools::FractureCutoutDesc
, FractureTools::NoiseParameters
, nvidia::apex::DestructibleChunkDesc
, nvidia::apex::CollisionDesc
, nvidia::apex::DestructibleAssetCookingDesc
, nvidia::apex::DestructibleRTFractureParameters
, nvidia::apex::DestructibleDepthParameters
, nvidia::apex::DestructibleGeometryDesc
, FractureTools::SliceParameters
, nvidia::apex::DestructibleBehaviorGroupDesc
, FractureTools::FractureVoronoiDesc
  • setToMostExpensive() : nvidia::apex::DestructibleDepthParameters
  • setUseLegacyChunkBoundsTesting() : nvidia::apex::ModuleDestructible
  • setUseLegacyDamageRadiusSpread() : nvidia::apex::ModuleDestructible
  • setValidBoundsPadding() : nvidia::apex::ModuleDestructible
  • setWorldSupportPhysXScene() : nvidia::apex::ModuleDestructible
  • SliceParameters() : FractureTools::SliceParameters
  • submeshCount() : nvidia::apex::ExplicitHierarchicalMesh
  • submeshData() : nvidia::apex::ExplicitHierarchicalMesh
  • surfaceNormal() : nvidia::apex::ExplicitHierarchicalMesh
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- t -

  • takeImpact() : nvidia::apex::DestructibleActor
  • trimCollisionGeometry() : nvidia::apex::DestructibleAssetAuthoring
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- v -

  • visualize() : nvidia::apex::ExplicitHierarchicalMesh
  • visualizeVoronoiCells()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • voronoiSplitChunk()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • actor : nvidia::apex::DestructibleActorJointDesc
  • alwaysDrawScatterMesh : nvidia::apex::DestructibleParameters
  • amplitude : FractureTools::NoiseParameters
  • angularVariation : FractureTools::SliceParameters
  • appliedDamageUserData : nvidia::apex::DamageEventReportData
  • attachment : nvidia::apex::DestructibleRTFractureParameters
  • attachmentChunkIndex : nvidia::apex::DestructibleActorJointDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • legacyChunkBoundsTestSetting : nvidia::apex::DestructibleParameters
  • legacyDamageRadiusSpreadSetting : nvidia::apex::DestructibleParameters
  • linearVariation : FractureTools::SliceParameters
  • localAnchor : nvidia::apex::DestructibleActorJointDesc
  • localAxis : nvidia::apex::DestructibleActorJointDesc
  • localNormal : nvidia::apex::DestructibleActorJointDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • materialDesc
: FractureTools::FractureSliceDesc
, FractureTools::CutoutParameters
, FractureTools::FractureVoronoiDesc
  • materialStrength : nvidia::apex::DestructibleBehaviorGroupDesc
  • maxChunkSpeed : nvidia::apex::DestructibleParameters
  • maxDepenetrationVelocity : nvidia::apex::DestructibleBehaviorGroupDesc
  • maxDepth : nvidia::apex::DamageEventReportData , FractureTools::FractureSliceDesc
  • maxHullFaceCount : nvidia::apex::DestructibleAssetStats
  • maxHullVertexCount : nvidia::apex::DestructibleAssetStats
  • mBonesPerVertex : nvidia::apex::ExplicitVertexFormat
  • mConcavityPercent : nvidia::apex::CollisionVolumeDesc
  • mCoordinateSystem : nvidia::apex::MaterialFrame
  • mDepthCount : nvidia::apex::CollisionDesc
  • meshIndex : nvidia::apex::DestructibleChunkDesc
  • meshMode : FractureTools::MeshProcessingParameters
  • mFractureIndex : nvidia::apex::MaterialFrame
  • mFractureMethod : nvidia::apex::MaterialFrame
  • mHasDynamicBinormals : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicColors : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicDisplacements : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicNormals : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicPositions : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicSeparateBoneBuffer : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicTangents : nvidia::apex::ExplicitVertexFormat
  • mHasStaticBinormals : nvidia::apex::ExplicitVertexFormat
  • mHasStaticColors : nvidia::apex::ExplicitVertexFormat
  • mHasStaticDisplacements : nvidia::apex::ExplicitVertexFormat
  • mHasStaticNormals : nvidia::apex::ExplicitVertexFormat
  • mHasStaticPositions : nvidia::apex::ExplicitVertexFormat
  • mHasStaticSeparateBoneBuffer : nvidia::apex::ExplicitVertexFormat
  • mHasStaticTangents : nvidia::apex::ExplicitVertexFormat
  • mHullMethod : nvidia::apex::CollisionVolumeDesc
  • microgridSize : FractureTools::MeshProcessingParameters
  • minConvexSize : nvidia::apex::DestructibleRTFractureParameters
  • minDepth : nvidia::apex::DamageEventReportData
  • minimumChunkSize : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • minimumFractureDepth : nvidia::apex::DestructibleParameters
  • minimumRadius : nvidia::apex::DamageSpreadFunction
  • mMaterialName : nvidia::apex::ExplicitSubmeshData
  • mMaxEdgeCount : nvidia::apex::CollisionVolumeDesc
  • mMaxFaceCount : nvidia::apex::CollisionVolumeDesc
  • mMaximumTrimming : nvidia::apex::CollisionDesc
  • mMaxVertexCount : nvidia::apex::CollisionVolumeDesc
  • mMergeThreshold : nvidia::apex::CollisionVolumeDesc
  • momentum : nvidia::apex::DamageEventUnit
  • mRecursionDepth : nvidia::apex::CollisionVolumeDesc
  • mSliceDepth : nvidia::apex::MaterialFrame
  • mUVCount : nvidia::apex::ExplicitVertexFormat
  • mUVOffset : nvidia::apex::MaterialFrame
  • mUVPlane : nvidia::apex::MaterialFrame
  • mUVScale : nvidia::apex::MaterialFrame
  • mVertexFormat : nvidia::apex::ExplicitSubmeshData
  • mVolumeDescs : nvidia::apex::CollisionDesc
  • mWinding : nvidia::apex::ExplicitVertexFormat
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • name : nvidia::apex::DestructibleBehaviorGroupDesc
  • negX : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • negY : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • negZ : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • next
: nvidia::apex::DamageEventHeader
, nvidia::apex::ChunkTransformHeader
, nvidia::apex::FractureEventHeader
  • noise : FractureTools::SliceParameters
  • noiseMode : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • numSectors : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • order : FractureTools::SliceParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • backfaceNoise : FractureTools::CutoutParameters
  • behaviorGroupDescCount : nvidia::apex::DestructibleAssetCookingDesc
  • behaviorGroupDescs : nvidia::apex::DestructibleAssetCookingDesc
  • behaviorGroupIndex : nvidia::apex::DestructibleChunkDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • chunkBytes : nvidia::apex::DestructibleAssetStats
  • chunkCount : nvidia::apex::DestructibleAssetStats
  • chunkDescCount : nvidia::apex::DestructibleAssetCookingDesc
  • chunkDescs : nvidia::apex::DestructibleAssetCookingDesc
  • chunkFracturingMethod : FractureTools::FractureCutoutDesc
  • chunkHullDataBytes : nvidia::apex::DestructibleAssetStats
  • chunkIndex
: nvidia::apex::DestructibleChunkEvent
, nvidia::apex::DamageEventUnit
, nvidia::apex::FractureEventUnit
, nvidia::apex::ChunkTransformUnit
, nvidia::apex::DestructibleHitChunk
  • chunkIndexInAsset : nvidia::apex::DamageEventCoreData
  • chunkIndices : FractureTools::FractureVoronoiDesc
  • chunkOrientation : nvidia::apex::ChunkTransformUnit
  • chunkPosition : nvidia::apex::ChunkTransformUnit
  • chunkTransformBufferStart : nvidia::apex::ChunkTransformHeader
  • chunkTransformCopyDepth : nvidia::apex::DestructibleChunkSyncState
  • chunkTransformCount : nvidia::apex::ChunkTransformHeader
  • chunkWithMaxEdgeCount : nvidia::apex::DestructibleAssetStats
  • collisionCookedHullDataBytes : nvidia::apex::DestructibleAssetStats
  • collisionMeshCount : nvidia::apex::DestructibleAssetStats
  • collisionVolumeDesc : nvidia::apex::DestructibleGeometryDesc
  • convexHullCount : nvidia::apex::DestructibleGeometryDesc
  • convexHulls : nvidia::apex::DestructibleGeometryDesc
  • cutoutHeightInvert : FractureTools::FractureCutoutDesc
  • cutoutHeightOffset : FractureTools::FractureCutoutDesc
  • cutoutHeightScale : FractureTools::FractureCutoutDesc
  • cutoutParameters : FractureTools::FractureCutoutDesc
  • cutoutSizeX : FractureTools::FractureCutoutDesc
  • cutoutSizeY : FractureTools::FractureCutoutDesc
  • cutoutWidthInvert : FractureTools::FractureCutoutDesc
  • cutoutWidthOffset : FractureTools::FractureCutoutDesc
  • cutoutWidthScale : FractureTools::FractureCutoutDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • damage
: nvidia::apex::ChunkData
, nvidia::apex::DamageEventCoreData
, nvidia::apex::DamageEventUnit
  • damageCap : nvidia::apex::DestructibleParameters
  • damageColorChange : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageColorSpread : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageDepthLimit : nvidia::apex::DestructibleParameters
  • damageEventBufferStart : nvidia::apex::DamageEventHeader
  • damageEventCount : nvidia::apex::DamageEventHeader
  • damageEventFilterDepth : nvidia::apex::DestructibleActorSyncState
  • damageEventFlags : nvidia::apex::DamageEventUnit
  • damageSpread : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageThreshold : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageToRadius : nvidia::apex::DestructibleBehaviorGroupDesc
  • debrisDepth : nvidia::apex::DestructibleParameters
  • debrisDestructionProbability : nvidia::apex::DestructibleParameters
  • debrisLifetimeMax : nvidia::apex::DestructibleParameters
  • debrisLifetimeMin : nvidia::apex::DestructibleParameters
  • debrisMaxSeparationMax : nvidia::apex::DestructibleParameters
  • debrisMaxSeparationMin : nvidia::apex::DestructibleParameters
  • defaultBehaviorGroupDesc : nvidia::apex::DestructibleAssetCookingDesc
  • density : nvidia::apex::DestructibleBehaviorGroupDesc
  • depth : FractureTools::CutoutParameters , nvidia::apex::ChunkData
  • depthLimit : nvidia::apex::DestructibleRTFractureParameters
  • depthParameters : nvidia::apex::DestructibleParameters
  • depthParametersCount : nvidia::apex::DestructibleParameters
  • destroyIfAtDepthLimit : nvidia::apex::DestructibleRTFractureParameters
  • destructible
: nvidia::apex::ImpactDamageEventData
, nvidia::apex::DestructibleActorJointDesc
, nvidia::apex::ChunkStateEventData
, nvidia::apex::DamageEventReportData
  • direction
: nvidia::apex::DamageEventUnit
, nvidia::apex::ImpactDamageEventData
, nvidia::apex::FractureEventUnit
  • directionOrder : FractureTools::FractureCutoutDesc
  • directions : FractureTools::FractureCutoutDesc
  • disableTransformBuffering : nvidia::apex::DestructibleChunkSyncState
  • doNotCrumble : nvidia::apex::DestructibleChunkDesc
  • doNotDamage : nvidia::apex::DestructibleChunkDesc
  • doNotFracture : nvidia::apex::DestructibleChunkDesc
  • dynamicChunksDominanceGroup : nvidia::apex::DestructibleParameters
  • dynamicChunksFilterData : nvidia::apex::DestructibleParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • edgeNoise : FractureTools::CutoutParameters
  • essentialDepth : nvidia::apex::DestructibleParameters
  • event : nvidia::apex::DestructibleChunkEvent
  • excludeSleepingChunks : nvidia::apex::DestructibleChunkSyncState
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • faceNoise : FractureTools::FractureVoronoiDesc
  • facetNormalMergeThresholdAngle : FractureTools::FractureCutoutDesc
  • fadeOut : nvidia::apex::DestructibleBehaviorGroupDesc
  • falloffExponent : nvidia::apex::DamageSpreadFunction
  • firstSegmentSize : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • flags
: nvidia::apex::DestructibleInitParameters
, nvidia::apex::ChunkData
, nvidia::apex::DestructibleDepthParameters
, nvidia::apex::DestructibleParameters
  • forceToDamage : nvidia::apex::DestructibleParameters
  • fractureEventBufferStart : nvidia::apex::FractureEventHeader
  • fractureEventCount : nvidia::apex::FractureEventHeader
  • fractureEventFilterDepth : nvidia::apex::DestructibleActorSyncState
  • fractureEventFlags : nvidia::apex::FractureEventUnit
  • fractureEventList : nvidia::apex::DamageEventReportData
  • fractureEventListSize : nvidia::apex::DamageEventReportData
  • fractureImpulseScale : nvidia::apex::DestructibleParameters
  • frequency : FractureTools::NoiseParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • geometryDescCount : nvidia::apex::DestructibleAssetCookingDesc
  • geometryDescs : nvidia::apex::DestructibleAssetCookingDesc
  • glass : nvidia::apex::DestructibleRTFractureParameters
  • globalAnchor : nvidia::apex::DestructibleActorJointDesc
  • globalAxis : nvidia::apex::DestructibleActorJointDesc
  • globalNormal : nvidia::apex::DestructibleActorJointDesc
  • gridSize : FractureTools::NoiseParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • hitChunkFlags : nvidia::apex::DestructibleHitChunk
  • hitDirection : nvidia::apex::DamageEventReportData
  • hitPosition : nvidia::apex::DamageEventReportData
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • impactDamageActor : nvidia::apex::DamageEventReportData , nvidia::apex::ImpactDamageEventData
  • impactDamageDefaultDepth : nvidia::apex::DestructibleParameters
  • impactVelocityThreshold : nvidia::apex::DestructibleParameters
  • impulse : nvidia::apex::FractureEventUnit
  • impulseScale : nvidia::apex::DestructibleRTFractureParameters
  • index : nvidia::apex::ChunkData
  • instanceChunks : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • instancePositionOffset : nvidia::apex::DestructibleChunkDesc
  • instanceUVOffset : nvidia::apex::DestructibleChunkDesc
  • instancingMode : FractureTools::FractureCutoutDesc
  • interiorSubmeshIndex : nvidia::apex::FractureMaterialDesc
  • islandGeneration : FractureTools::MeshProcessingParameters
  • isSupportChunk : nvidia::apex::DestructibleChunkDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • parentIndex : nvidia::apex::DestructibleChunkDesc
  • position
: nvidia::apex::DamageEventCoreData
, nvidia::apex::FractureEventUnit
, nvidia::apex::DamageEventUnit
  • positionCount : nvidia::apex::ChunkParticleReportData
  • positions : nvidia::apex::ChunkParticleReportData
  • posX : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • posY : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • posZ : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • radius : nvidia::apex::DamageEventCoreData , nvidia::apex::DamageEventUnit
  • radiusMultiplier : nvidia::apex::DamageSpreadFunction
  • removeTJunctions : FractureTools::MeshProcessingParameters
  • renderMeshAssetStats : nvidia::apex::DestructibleAssetStats
  • RTFractureBehaviorGroup : nvidia::apex::DestructibleAssetCookingDesc
  • rtFractureParameters : nvidia::apex::DestructibleParameters
  • runtimeCookedConvexCount : nvidia::apex::DestructibleAssetStats
  • runtimeFracture : nvidia::apex::DestructibleChunkDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • scatterMeshCount : nvidia::apex::DestructibleChunkDesc
  • scatterMeshIndices : nvidia::apex::DestructibleChunkDesc
  • scatterMeshTransforms : nvidia::apex::DestructibleChunkDesc
  • sectorRand : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • segmentRand : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • segmentScale : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • sheetFracture : nvidia::apex::DestructibleRTFractureParameters
  • siteCount : FractureTools::FractureVoronoiDesc
  • sites : FractureTools::FractureVoronoiDesc
  • sliceParameters : FractureTools::FractureSliceDesc
  • splitNonconvexRegions : FractureTools::FractureCutoutDesc
  • splitsPerPass : FractureTools::SliceParameters
  • stateEventList : nvidia::apex::ChunkStateEventData
  • stateEventListSize : nvidia::apex::ChunkStateEventData
  • supportDepth : nvidia::apex::DestructibleInitParameters
  • supportGraphEdgeCount : nvidia::apex::DestructibleAssetCookingDesc
  • supportGraphEdges : nvidia::apex::DestructibleAssetCookingDesc
  • supportStrength : nvidia::apex::DestructibleParameters
  • surfaceNormal : nvidia::apex::DestructibleChunkDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • tangent : nvidia::apex::FractureMaterialDesc
  • targetProportions : FractureTools::FractureSliceDesc
  • tileFractureMap : FractureTools::FractureCutoutDesc
  • totalBytes : nvidia::apex::DestructibleAssetStats
  • totalNumberOfFractureEvents : nvidia::apex::DamageEventReportData
  • trimFaceCollisionHulls : FractureTools::FractureCutoutDesc
  • type : FractureTools::NoiseParameters , nvidia::apex::DestructibleActorJointDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • uAngle : nvidia::apex::FractureMaterialDesc
  • useDisplacementMaps : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • useDynamicChunksGroupsMask : nvidia::apex::DestructibleParameters
  • useInstancedRendering : nvidia::apex::DestructibleChunkDesc
  • userActorID
: nvidia::apex::ChunkTransformHeader
, nvidia::apex::DamageEventHeader
, nvidia::apex::FractureEventHeader
  • userData : nvidia::apex::DestructibleBehaviorGroupDesc
  • userDefinedCutoutParameters : FractureTools::FractureCutoutDesc
  • userDefinedDirection : FractureTools::FractureCutoutDesc
  • userUVMapping : FractureTools::FractureCutoutDesc
  • useTargetProportions : FractureTools::FractureSliceDesc
  • uvOffset : nvidia::apex::FractureMaterialDesc
  • uvScale : nvidia::apex::FractureMaterialDesc
  • uvTileSize : FractureTools::FractureCutoutDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • validBounds : nvidia::apex::DestructibleParameters
  • velocities : nvidia::apex::ChunkParticleReportData
  • velocityCount : nvidia::apex::ChunkParticleReportData
  • verbosity : FractureTools::MeshProcessingParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • worldBounds : nvidia::apex::ChunkData , nvidia::apex::DamageEventReportData
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: File Members

  • File List
  • File Members
  • All
  • Defines
Here is a list of all file members with links to the files they belong to:
  • APEX_RUNTIME_FRACTURE : ModuleDestructible.h
  • DESTRUCTIBLE_ACTOR_TYPE_NAME : DestructibleActor.h
  • DESTRUCTIBLE_AUTHORING_TYPE_NAME : DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: File Members

  • File List
  • File Members
  • All
  • Defines
  • APEX_RUNTIME_FRACTURE : ModuleDestructible.h
  • DESTRUCTIBLE_ACTOR_TYPE_NAME : DestructibleActor.h
  • DESTRUCTIBLE_AUTHORING_TYPE_NAME : DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Class Hierarchy

  • Class List
  • Class Hierarchy
  • Class Members
Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
  • nvidia::apex::ApexChunkFlag
  • nvidia::apex::BSPOpenMode
  • nvidia::apex::ChunkData
  • nvidia::apex::ChunkParticleReportData
  • nvidia::apex::ChunkStateEventData
  • nvidia::apex::ChunkTransformHeader
  • nvidia::apex::ChunkTransformUnit
  • nvidia::apex::CollisionDesc
  • nvidia::apex::CollisionVolumeDesc
  • nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • FractureTools::CutoutParameters
  • FractureTools::CutoutSet
  • nvidia::apex::DamageEventCoreData
    • nvidia::apex::ImpactDamageEventData
  • nvidia::apex::DamageEventHeader
  • nvidia::apex::DamageEventReportData
  • nvidia::apex::DamageEventUnit
  • nvidia::apex::DamageSpreadFunction
  • nvidia::apex::DestructibleActor
  • nvidia::apex::DestructibleActorChunkFlags
  • nvidia::apex::DestructibleActorJoint
  • nvidia::apex::DestructibleActorJointDesc
  • nvidia::apex::DestructibleActorMeshType
  • nvidia::apex::DestructibleActorRaycastFlags
  • nvidia::apex::DestructibleActorSyncFlags
  • nvidia::apex::DestructibleActorSyncState
  • nvidia::apex::DestructibleAsset
  • nvidia::apex::DestructibleAssetAuthoring
  • nvidia::apex::DestructibleAssetCookingDesc
  • nvidia::apex::DestructibleAssetStats
  • nvidia::apex::DestructibleBehaviorGroupDesc
  • nvidia::apex::DestructibleCallbackSchedule
  • nvidia::apex::DestructibleChunkDesc
  • nvidia::apex::DestructibleChunkEvent
  • nvidia::apex::DestructibleChunkSyncState
  • nvidia::apex::DestructibleDepthParameters
  • nvidia::apex::DestructibleDepthParametersFlag
  • nvidia::apex::DestructibleEmitterType
  • nvidia::apex::DestructibleGeometryDesc
  • nvidia::apex::DestructibleHitChunk
  • nvidia::apex::DestructibleInitParameters
  • nvidia::apex::DestructibleInitParametersFlag
  • nvidia::apex::DestructibleParameterizedType
  • nvidia::apex::DestructibleParameters
  • nvidia::apex::DestructibleParametersFlag
  • nvidia::apex::DestructiblePhysXActorQueryFlags
  • nvidia::apex::DestructiblePreview
  • nvidia::apex::DestructibleRenderable
  • nvidia::apex::DestructibleRTFractureParameters
  • nvidia::apex::DisplacementMapVolume
  • nvidia::apex::ExplicitHierarchicalMesh::Embedding
  • nvidia::apex::ExplicitHierarchicalMesh
  • nvidia::apex::ExplicitSubmeshData
  • nvidia::apex::ExplicitVertexFormat
  • nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • FractureTools::FractureCutoutDesc
  • nvidia::apex::FractureEventHeader
  • nvidia::apex::FractureEventUnit
  • nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • nvidia::apex::FractureMaterialDesc
  • nvidia::apex::FractureMethod
  • FractureTools::FractureSliceDesc
  • nvidia::apex::FractureToolsAPI
  • FractureTools::FractureVoronoiDesc
  • nvidia::apex::MaterialFrame
  • FractureTools::MeshProcessingParameters
  • nvidia::apex::ModuleDestructible
  • nvidia::apex::ModuleDestructibleConst
  • FractureTools::NoiseParameters
  • FractureTools::SliceParameters
  • nvidia::apex::UserChunkParticleReport
  • nvidia::apex::UserChunkReport
  • nvidia::apex::UserDestructiblePhysXActorReport
  • nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • nvidia::apex::UserImpactDamageReport
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Main Page

APEX Destructible Module Documentation
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: ModuleDestructible.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines | Functions
ModuleDestructible.h File Reference
#include "foundation/Px.h"
#include "foundation/PxBounds3.h"
#include "Module.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::ApexChunkFlag
struct | nvidia::apex::ChunkData
struct | nvidia::apex::DamageEventReportData
struct | nvidia::apex::DestructibleChunkEvent
struct | nvidia::apex::ChunkStateEventData
class | nvidia::apex::UserChunkReport
struct | nvidia::apex::ChunkParticleReportData
class | nvidia::apex::UserChunkParticleReport
class | nvidia::apex::UserDestructiblePhysXActorReport
struct | nvidia::apex::ModuleDestructibleConst
struct | nvidia::apex::DestructibleActorMeshType
struct | nvidia::apex::DamageEventCoreData
struct | nvidia::apex::ImpactDamageEventData
class | nvidia::apex::UserImpactDamageReport
class | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
struct | nvidia::apex::DamageEventHeader
struct | nvidia::apex::DamageEventUnit
struct | nvidia::apex::FractureEventHeader
struct | nvidia::apex::FractureEventUnit
struct | nvidia::apex::ChunkTransformHeader
struct | nvidia::apex::ChunkTransformUnit
struct | nvidia::apex::DestructibleActorRaycastFlags
struct | nvidia::apex::DestructibleCallbackSchedule
class | nvidia::apex::ModuleDestructible

Namespaces

namespace | physx
namespace | nvidia
namespace | nvidia::apex

Defines

#define | APEX_RUNTIME_FRACTURE 1

Functions

void | nvidia::apex::instantiateModuleDestructible ()

Define Documentation

#define APEX_RUNTIME_FRACTURE 1
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: ModuleDestructible.h Source File

  • File List
  • File Members
ModuleDestructible.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_DESTRUCTIBLE_H
00031 #define MODULE_DESTRUCTIBLE_H
00032
00033 #include "foundation/Px.h"
00034 #include "foundation/PxBounds3.h"
00035 #include "Module.h"
00036
00037 #ifndef APEX_RUNTIME_FRACTURE
00038 #define APEX_RUNTIME_FRACTURE 1
00039 #else
00040 #undef APEX_RUNTIME_FRACTURE
00041 #define APEX_RUNTIME_FRACTURE 0
00042 #endif
00043
00044 #if PX_ANDROID
00045 #undef APEX_RUNTIME_FRACTURE
00046 #define APEX_RUNTIME_FRACTURE 0
00047 #endif
00048
00049 namespace physx
00050 {
00051 class PxRigidActor;
00052 class PxRigidDynamic;
00053 class PxScene;
00054 }
00055
00056 namespace nvidia
00057 {
00058 namespace apex
00059 {
00060
00061 PX_PUSH_PACK_DEFAULT
00062
00063 class DestructibleAsset;
00064 class DestructibleAssetAuthoring;
00065 class DestructibleActor;
00066 class DestructibleActorJoint;
00067 class DestructibleChunkDesc;
00068 class DestructibleActorDesc;
00069 class DestructibleActorJointDesc;
00070
00074 struct ApexChunkFlag
00075 {
00079     enum Enum
00080     {
00082         DYNAMIC                         =   1 << 0,
00083
00085         EXTERNALLY_SUPPORTED            =   1 << 1,
00086
00088         WORLD_SUPPORTED                 =   1 << 2,
00089
00091         FRACTURED                       =   1 << 3,
00092
00094         DESTROYED_FIFO_FULL             =   1 << 4,
00095
00097         DESTROYED_TIMED_OUT             =   1 << 5,
00098
00100         DESTROYED_EXCEEDED_MAX_DISTANCE =   1 << 6,
00101
00103         DESTROYED_CRUMBLED              =   1 << 7,
00104
00106         DESTROYED_LEFT_VALID_BOUNDS     =   1 << 8,
00107
00109         DESTROYED_LEFT_USER_BOUNDS      =   1 << 9,
00110
00112         DESTROYED_ENTERED_USER_BOUNDS   =   1 << 10
00113     };
00114 };
00115
00119 struct ChunkData
00120 {
00122     uint32_t            index;
00123
00125     uint32_t            depth;
00126
00130     PxBounds3           worldBounds;
00131
00135     float               damage;
00136
00141     uint32_t            flags;
00142 };
00143
00147 struct DamageEventReportData
00148 {
00152     DestructibleActor*  destructible;
00153
00157     PxVec3              hitDirection;
00158
00163     PxBounds3           worldBounds;
00164
00169     uint32_t            totalNumberOfFractureEvents;
00170
00175     uint16_t            minDepth;
00176
00181     uint16_t            maxDepth;
00182
00191     const ChunkData*    fractureEventList;
00192
00198     uint32_t            fractureEventListSize;
00199
00203     physx::PxActor const*   impactDamageActor;
00204
00205
00209     PxVec3              hitPosition;
00210
00214     void*               appliedDamageUserData;
00215 };
00216
00217
00223 struct DestructibleChunkEvent
00224 {
00228     enum EventMask
00229     {
00230         VisibilityChanged   =   (1 << 0),
00231         ChunkVisible    =       (1 << 1)
00232     };
00233
00234     uint16_t    chunkIndex;
00235     uint16_t    event;
00236 };
00237
00238
00242 struct ChunkStateEventData
00243 {
00247     DestructibleActor*          destructible;
00248
00252     const DestructibleChunkEvent* stateEventList;
00253
00257     uint32_t                    stateEventListSize;
00258 };
00259
00260
00264 class UserChunkReport
00265 {
00266 public:
00273     virtual void    onDamageNotify(const DamageEventReportData& damageEvent) = 0;
00274
00285     virtual void    onStateChangeNotify(const ChunkStateEventData& visibilityEvent) = 0;
00286
00297     virtual bool    releaseOnNoChunksVisible(const DestructibleActor* destructible) { PX_UNUSED(destructible);  return false; }
00298
00302     virtual void    onDestructibleWake(DestructibleActor** destructibles, uint32_t count) = 0;
00303
00307     virtual void    onDestructibleSleep(DestructibleActor** destructibles, uint32_t count) = 0;
00308
00309 protected:
00310     virtual         ~UserChunkReport() {}
00311 };
00312
00313
00317 struct ChunkParticleReportData
00318 {
00320     const PxVec3* positions;
00321
00323     uint32_t positionCount;
00324
00333     const PxVec3* velocities;
00334
00336     uint32_t velocityCount;
00337 };
00338
00343 class UserChunkParticleReport
00344 {
00345 public:
00355     virtual void    onParticleEmission(const ChunkParticleReportData& particleData) = 0;
00356
00357 protected:
00358     virtual         ~UserChunkParticleReport() {}
00359 };
00360
00361
00366 class UserDestructiblePhysXActorReport
00367 {
00368 public:
00370     virtual void    onPhysXActorCreate(const physx::PxActor& actor) = 0;
00371
00373     virtual void    onPhysXActorRelease(const physx::PxActor& actor) = 0;
00374 protected:
00375     virtual     ~UserDestructiblePhysXActorReport() {}
00376 };
00377
00378
00382 struct ModuleDestructibleConst
00383 {
00387     enum Enum
00388     {
00393         INVALID_CHUNK_INDEX = -1
00394     };
00395 };
00396
00400 struct DestructibleActorMeshType
00401 {
00405     enum Enum
00406     {
00407         Skinned,
00408         Static,
00409         Count
00410     };
00411 };
00412
00416 struct DamageEventCoreData
00417 {
00418     int32_t chunkIndexInAsset;
00419     PxVec3  position;
00420     float   damage;
00421     float   radius;
00422 };
00423
00427 struct ImpactDamageEventData : public DamageEventCoreData
00428 {
00429     nvidia::DestructibleActor*  destructible;
00430     PxVec3                      direction;
00431     physx::PxActor const*       impactDamageActor;
00432 };
00433
00437 class UserImpactDamageReport
00438 {
00439 public:
00446     virtual void    onImpactDamageNotify(const ImpactDamageEventData* buffer, uint32_t bufferSize) = 0;
00447 };
00448
00452 template<typename DestructibleSyncHeader>
00453 class UserDestructibleSyncHandler
00454 {
00455 public:
00459     virtual void    onWriteBegin(DestructibleSyncHeader *& bufferStart, uint32_t bufferSize) = 0;
00460
00464     virtual void    onWriteDone(uint32_t headerCount) = 0;
00465
00469     virtual void    onPreProcessReadBegin(DestructibleSyncHeader *& bufferStart, uint32_t & bufferSize, bool & continuePointerSwizzling) = 0;
00470
00474     virtual void    onPreProcessReadDone(uint32_t headerCount) = 0;
00475
00479     virtual void    onReadBegin(const DestructibleSyncHeader *& bufferStart) = 0;
00480
00484     virtual void    onReadDone(const char * debugMessage) = 0;
00485 protected:
00486     virtual ~UserDestructibleSyncHandler() {}
00487 };
00488
00489 /*** Sync-able Damage Data ***/
00490
00491 struct DamageEventUnit;
00495 struct DamageEventHeader
00496 {
00497     uint32_t                    userActorID;
00498     uint32_t                    damageEventCount;
00499     DamageEventUnit *           damageEventBufferStart;
00500     DamageEventHeader *         next;
00501 };
00502
00506 struct DamageEventUnit
00507 {
00508     uint32_t    chunkIndex;
00509     uint32_t    damageEventFlags;
00510     float       damage;
00511     float       momentum;
00512     float       radius;
00513     PxVec3      position;
00514     PxVec3      direction;
00515 };
00516
00517 /*** Sync-able Fracture Data ***/
00518
00519 struct FractureEventUnit;
00520
00524 struct FractureEventHeader
00525 {
00526     uint32_t                    userActorID;
00527     uint32_t                    fractureEventCount;
00528     FractureEventUnit *         fractureEventBufferStart;
00529     FractureEventHeader *       next;
00530 };
00531
00535 struct FractureEventUnit
00536 {
00537     uint32_t    chunkIndex;
00538     uint32_t    fractureEventFlags;
00539     PxVec3      position;
00540     PxVec3      direction;
00541     PxVec3      impulse;
00542 };
00543
00544 /*** Sync-able Transform Data ***/
00545
00546 struct ChunkTransformUnit;
00547
00551 struct ChunkTransformHeader
00552 {
00553     uint32_t                    userActorID;
00554     uint32_t                    chunkTransformCount;
00555     ChunkTransformUnit *        chunkTransformBufferStart;
00556     ChunkTransformHeader *      next;
00557 };
00558
00562 struct ChunkTransformUnit
00563 {
00564     uint32_t    chunkIndex;
00565     PxVec3      chunkPosition;
00566     PxQuat      chunkOrientation;
00567 };
00568
00569
00573 struct DestructibleActorRaycastFlags
00574 {
00578     enum Enum
00579     {
00580         NoChunks =      (0),
00581         StaticChunks =  (1 << 0),
00582         DynamicChunks = (1 << 1),
00583
00584         AllChunks =                 StaticChunks | DynamicChunks,
00585
00586         SegmentIntersect =  (1 << 2),
00587
00588         ForceAccurateRaycastsOn =   (1 << 3),
00589         ForceAccurateRaycastsOff =  (1 << 4),
00590     };
00591 };
00592
00593
00597 struct DestructibleCallbackSchedule
00598 {
00602     enum Enum
00603     {
00604         Disabled =      (0),
00605         BeforeTick,
00606         FetchResults,
00607
00608         Count
00609     };
00610 };
00611
00612
00616 class ModuleDestructible : public Module
00617 {
00618 public:
00628     virtual DestructibleActorJoint*         createDestructibleActorJoint(const DestructibleActorJointDesc& desc, Scene& scene) = 0;
00629
00635     virtual bool                            isDestructibleActorJointActive(const DestructibleActorJoint* candidateJoint, Scene& apexScene) const = 0;
00636
00646     virtual void                            setMaxDynamicChunkIslandCount(uint32_t maxCount) = 0;
00647
00654     virtual void                            setMaxChunkCount(uint32_t maxCount) = 0;
00655
00660     virtual void                            setSortByBenefit(bool sortByBenefit) = 0;
00661
00665     virtual void                            setValidBoundsPadding(float pad) = 0;
00666
00673     virtual void                            setMaxChunkDepthOffset(uint32_t maxChunkDepthOffset) = 0;
00674
00680     virtual void                            setMaxChunkSeparationLOD(float separationLOD) = 0;
00681
00682
00688     virtual void                            setChunkReport(UserChunkReport* chunkReport) = 0;
00689
00694     virtual void                            setImpactDamageReportCallback(UserImpactDamageReport* impactDamageReport) = 0;
00695
00700     virtual void                            setChunkReportBitMask(uint32_t chunkReportBitMask) = 0;
00701
00706     virtual void                            setDestructiblePhysXActorReport(UserDestructiblePhysXActorReport* destructiblePhysXActorReport) = 0;
00707
00713     virtual void                            setChunkReportMaxFractureEventDepth(uint32_t chunkReportMaxFractureEventDepth) = 0;
00714
00721     virtual void                            scheduleChunkStateEventCallback(DestructibleCallbackSchedule::Enum chunkStateEventCallbackSchedule) = 0;
00722
00727     virtual void                            setChunkCrumbleReport(UserChunkParticleReport* chunkCrumbleReport) = 0;
00728
00735     virtual void                            setChunkDustReport(UserChunkParticleReport* chunkDustReport) = 0;
00736
00742     virtual void                            setWorldSupportPhysXScene(Scene& apexScene, PxScene* physxScene) = 0;
00743
00748     virtual bool                            owns(const PxRigidActor* actor) const = 0;
00749
00750 #if APEX_RUNTIME_FRACTURE
00751
00755     virtual bool                            isRuntimeFractureShape(const PxShape& shape) const = 0;
00756 #endif
00757
00764     virtual DestructibleActor*              getDestructibleAndChunk(const PxShape* shape, int32_t* chunkIndex = NULL) const = 0;
00765
00776     virtual void                            applyRadiusDamage(Scene& scene, float damage, float momentum,
00777             const PxVec3& position, float radius, bool falloff) = 0;
00778
00783     virtual void                            setMaxActorCreatesPerFrame(uint32_t maxActorsPerFrame) = 0;
00784
00789     virtual void                            setMaxFracturesProcessedPerFrame(uint32_t maxFracturesProcessedPerFrame) = 0;
00790
00794     virtual bool                            setSyncParams(UserDestructibleSyncHandler<DamageEventHeader> * userDamageEventHandler, UserDestructibleSyncHandler<FractureEventHeader> * userFractureEventHandler, UserDestructibleSyncHandler<ChunkTransformHeader> * userChunkMotionHandler) = 0;
00795
00806     virtual void                            setUseLegacyChunkBoundsTesting(bool useLegacyChunkBoundsTesting) = 0;
00807
00819     virtual void                            setUseLegacyDamageRadiusSpread(bool useLegacyDamageRadiusSpread) = 0;
00820
00837     virtual bool                            setMassScaling(float massScale, float scaledMassExponent, Scene& apexScene) = 0;
00838
00845     virtual void                            invalidateBounds(const PxBounds3* bounds, uint32_t boundsCount, Scene& apexScene) = 0;
00846
00857     virtual void                            setDamageApplicationRaycastFlags(nvidia::DestructibleActorRaycastFlags::Enum flags, Scene& apexScene) = 0;
00858
00868     virtual bool                            setChunkCollisionHullCookingScale(const PxVec3& scale) = 0;
00869
00873     virtual PxVec3                          getChunkCollisionHullCookingScale() const = 0;
00874
00878     virtual class FractureToolsAPI*         getFractureTools() const = 0;
00879
00880 protected:
00881     virtual                                 ~ModuleDestructible() {}
00882 };
00883
00884
00885 #if !defined(_USRDLL)
00886
00890 void instantiateModuleDestructible();
00891 #endif
00892
00893 PX_POP_PACK
00894
00895 }
00896 } // end namespace nvidia
00897
00898 #endif // MODULE_DESTRUCTIBLE_H
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: FractureTools Namespace Reference

  • Namespace List
  • Namespace Members
Classes
FractureTools Namespace Reference

Classes

struct | MeshProcessingParameters
class | CutoutSet
struct | NoiseParameters
struct | SliceParameters
struct | FractureSliceDesc
struct | CutoutParameters
struct | FractureCutoutDesc
struct | FractureVoronoiDesc
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
Here is a list of all namespace members with links to the namespace documentation for each member:
  • instantiateModuleDestructible() : nvidia::apex
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • instantiateModuleDestructible() : nvidia::apex
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces
nvidia Namespace Reference

Namespaces

namespace apex
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex Namespace Reference

  • Namespace List
  • Namespace Members
  • nvidia
  • apex
Classes | Functions
nvidia::apex Namespace Reference

Classes

struct | DestructibleEmitterType
struct | DestructibleParameterizedType
struct | DestructibleHitChunk
struct | DestructibleActorSyncFlags
struct | DestructiblePhysXActorQueryFlags
struct | DestructibleActorSyncState
struct | DestructibleChunkSyncState
struct | DestructibleActorChunkFlags
class | DestructibleActor
class | DestructibleActorJointDesc
class | DestructibleActorJoint
struct | DestructibleDepthParametersFlag
PX_PS4. More...
struct | DestructibleDepthParameters
struct | DestructibleRTFractureParameters
struct | DestructibleParametersFlag
struct | DestructibleParameters
struct | DestructibleInitParametersFlag
struct | DestructibleInitParameters
struct | DamageSpreadFunction
class | DestructibleBehaviorGroupDesc
class | DestructibleChunkDesc
class | DestructibleGeometryDesc
class | DestructibleAssetCookingDesc
struct | DestructibleAssetStats
class | DestructibleAssetAuthoring
class | DestructibleAsset
class | DestructiblePreview
Destructible module's derivation AssetPreview. More...
class | DestructibleRenderable
struct | ExplicitVertexFormat
struct | ExplicitSubmeshData
struct | CollisionVolumeDesc
struct | CollisionDesc
struct | FractureMethod
struct | FractureMaterialDesc
struct | MaterialFrame
class | DisplacementMapVolume
struct | BSPOpenMode
class | ExplicitHierarchicalMesh
class | FractureToolsAPI
struct | ApexChunkFlag
struct | ChunkData
struct | DamageEventReportData
struct | DestructibleChunkEvent
struct | ChunkStateEventData
class | UserChunkReport
struct | ChunkParticleReportData
class | UserChunkParticleReport
class | UserDestructiblePhysXActorReport
struct | ModuleDestructibleConst
struct | DestructibleActorMeshType
struct | DamageEventCoreData
struct | ImpactDamageEventData
class | UserImpactDamageReport
class | UserDestructibleSyncHandler
struct | DamageEventHeader
struct | DamageEventUnit
struct | FractureEventHeader
struct | FractureEventUnit
struct | ChunkTransformHeader
struct | ChunkTransformUnit
struct | DestructibleActorRaycastFlags
struct | DestructibleCallbackSchedule
class | ModuleDestructible

Functions

void | instantiateModuleDestructible ()

Function Documentation

void nvidia::apex::instantiateModuleDestructible ( )

If this module is distributed as a static library, the user must call this function before calling ApexSDK::createModule("Destructible")

Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: physx Namespace Reference

  • Namespace List
  • Namespace Members
physx Namespace Reference
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
FractureTools
nvidia
nvidia::apex
physx
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: FractureTools::CutoutParameters Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • CutoutParameters
Public Member Functions | Public Attributes
FractureTools::CutoutParameters Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Member Functions

CutoutParameters ()
void | setToDefault ()

Public Attributes

float | depth
nvidia::FractureMaterialDesc | materialDesc
NoiseParameters backfaceNoise
NoiseParameters edgeNoise

Detailed Description

CutoutParameters

Parameters for a single cutout direction.

Constructor & Destructor Documentation

FractureTools::CutoutParameters::CutoutParameters ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::CutoutParameters::setToDefault ( ) [inline]

Set default values:

depth = 1.0f; backfaceNoise.setToDefault(); edgeNoise.setToDefault(); materialDesc.setToDefault();

Member Data Documentation

NoiseParameters FractureTools::CutoutParameters::backfaceNoise

Describes the characteristics of the backface cutting surface (along the various cutout directions). If the noise is 0, the cutting surface will be a plane. Otherwise, there will be some variation, or roughness, to the surface.

float FractureTools::CutoutParameters::depth

The depth to apply cutout fracturing. 0 has a special value; it means cut all the way through

NoiseParameters FractureTools::CutoutParameters::edgeNoise

Describes the characteristics of the perimeter cutting surfaces (for the various cutout directions). If the noise is 0, the cutting surface will smooth. Otherwise, there will be some variation, or roughness, to the surface.

Note: this noise is applied only to the graphics of the cutout chunks. The chunks' collision volumes AND the chunks' children (if fractured further) will NOT be affected by this noise.

nvidia::FractureMaterialDesc FractureTools::CutoutParameters::materialDesc

Material application descriptor used for the cutout direction. Note: The backface slice will use the U-direction and UV offset specified in each descriptor, however the cutout slices (surrounding each cutout chunk) will ignore these fields (only using the UV scale).

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • CutoutParameters
FractureTools::CutoutParameters Member List
This is the complete list of members for FractureTools::CutoutParameters, including all inherited members.
backfaceNoise | FractureTools::CutoutParameters |
CutoutParameters() | FractureTools::CutoutParameters | [inline]
depth | FractureTools::CutoutParameters |
edgeNoise | FractureTools::CutoutParameters |
materialDesc | FractureTools::CutoutParameters |
setToDefault() | FractureTools::CutoutParameters | [inline]
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: FractureTools::FractureCutoutDesc Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • FractureCutoutDesc
Public Types | Public Member Functions | Public Attributes
FractureTools::FractureCutoutDesc Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Types

enum Directions {
UserDefined = 0,
NegativeX = 1 << 0,
PositiveX = 1 << 1,
NegativeY = 1 << 2,
PositiveY = 1 << 3,
NegativeZ = 1 << 4,
PositiveZ = 1 << 5,
DirectionCount = 6
}
enum InstancingMode {
DoNotInstance,
InstanceCongruentChunks,
InstanceAllChunks,
InstanceModeCount
}
enum CutoutChunkFracturingMethod {
DoNotFractureCutoutChunks,
SliceFractureCutoutChunks,
VoronoiFractureCutoutChunks,
CutoutChunkFracturingMethodCount
}

Public Member Functions

FractureCutoutDesc ()
void | setToDefault ()

Public Attributes

unsigned | directions
unsigned | directionOrder [DirectionCount]
CutoutParameters | cutoutParameters [DirectionCount]
physx::PxVec3 | userDefinedDirection
physx::PxMat33 | userUVMapping
CutoutParameters userDefinedCutoutParameters
unsigned | instancingMode
bool | tileFractureMap
physx::PxVec2 | uvTileSize
bool | splitNonconvexRegions
unsigned | chunkFracturingMethod
bool | trimFaceCollisionHulls
float | cutoutWidthScale [DirectionCount]
float | cutoutHeightScale [DirectionCount]
float | cutoutWidthOffset [DirectionCount]
float | cutoutHeightOffset [DirectionCount]
bool | cutoutWidthInvert [DirectionCount]
bool | cutoutHeightInvert [DirectionCount]
float | cutoutSizeX
float | cutoutSizeY
float | facetNormalMergeThresholdAngle

Detailed Description

FractureCutoutDesc

Descriptor for cutout-mode (chippable) fracturing.

Member Enumeration Documentation

enum FractureTools::FractureCutoutDesc::CutoutChunkFracturingMethod

Fracturing to apply to cutout chunks (if any), to break them down further. Current options include none, slice fracturing, and voronoi fracturing.

Enumerator:
DoNotFractureCutoutChunks
SliceFractureCutoutChunks
VoronoiFractureCutoutChunks
CutoutChunkFracturingMethodCount
enum FractureTools::FractureCutoutDesc::Directions

Enum describing the directions to apply cutout fracturing.

Enumerator:
UserDefined
NegativeX
PositiveX
NegativeY
PositiveY
NegativeZ
PositiveZ
DirectionCount
enum FractureTools::FractureCutoutDesc::InstancingMode

Enum describing the instancing mode.

Enumerator:
DoNotInstance
InstanceCongruentChunks
InstanceAllChunks
InstanceModeCount

Constructor & Destructor Documentation

FractureTools::FractureCutoutDesc::FractureCutoutDesc ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::FractureCutoutDesc::setToDefault ( ) [inline]

Set default values:

directions = 0; directionOrder[0..5] = {NegativeX, .., PositiveZ}; cutoutParameters[0..5].setToDefault(); userDefinedDirection= physx::PxVec3(0.0f); userUVMapping = physx::PxMat33(physx::PxIdentity); userDefinedCutoutParameters.setToDefault(); instancingMode = DoNotInstance; tileFractureMap = false; uvTileSize = (0.0f,0.0f) cutoutParameters[0..5].setToDefault(); cutoutWidthScale[0..5] = 1.0f; cutoutHeightScale[0..5] = 1.0f; cutoutWidthOffset[0..5] = 0.0f; cutoutHeightOffset[0..5] = 0.0f; cutoutWidthInvert[0..5] = false; cutoutHeightInvert[0..5] = false; cutoutSizeX = 1.0f; cutoutSizeY = 1.0f; facetNormalMergeThresholdAngle = 60.0f; splitNonconvexRegions = false; chunkFracturingMethod = DoNotFractureCutoutChunks; trimFaceCollisionHulls = true;

Member Data Documentation

unsigned FractureTools::FractureCutoutDesc::chunkFracturingMethod

If true, slice-mode fracturing will be applied to each cutout piece. The cutout function must be provided with a FractureSliceDesc as well to describe the slice parameters. These parameters, however, must be interpreted from the point of view of the cutout direction. That is, X and Y slice parameters will be used to slice along the cutout faces. The Z slice parameters will be used to slice into the cutout faces.

bool FractureTools::FractureCutoutDesc::cutoutHeightInvert[DirectionCount]

If true, the cutout map will be flipped in the Y direction (along the various cutout directions).

float FractureTools::FractureCutoutDesc::cutoutHeightOffset[DirectionCount]

Offset to apply to the Y coordinates of the cutout set (along the various cutout directions).

float FractureTools::FractureCutoutDesc::cutoutHeightScale[DirectionCount]

Scale to apply to the Y coordinates of the cutout set (along the various cutout directions).

CutoutParameters FractureTools::FractureCutoutDesc::cutoutParameters[DirectionCount]

Cutout parameters used for the various pre-defined cutout directions.

float FractureTools::FractureCutoutDesc::cutoutSizeX

The interpreted size of the cutout map in the X direction

float FractureTools::FractureCutoutDesc::cutoutSizeY

The interpreted size of the cutout map in the Y direction

bool FractureTools::FractureCutoutDesc::cutoutWidthInvert[DirectionCount]

If true, the cutout map will be flipped in the X direction (along the various cutout directions).

float FractureTools::FractureCutoutDesc::cutoutWidthOffset[DirectionCount]

Offset to apply to the X coordinates of the cutout set (along the various cutout directions).

float FractureTools::FractureCutoutDesc::cutoutWidthScale[DirectionCount]

Scale to apply to the X coordinates of the cutout set (along the various cutout directions).

unsigned FractureTools::FractureCutoutDesc::directionOrder[DirectionCount]

The order in which to apply each cutout direction. The direction in directionOrder[0] is applied first, in directionOrder[1], second, and so on.

unsigned FractureTools::FractureCutoutDesc::directions

The directions to apply cutout fracturing. (See the Directions enum.)

float FractureTools::FractureCutoutDesc::facetNormalMergeThresholdAngle

Threshold angle to merge (smoothe) vertex normals around cutout, in degrees. If the exterior angle between two facets of a cutout region no more than this, the vertex normals and tangents will be averaged at the facet interface. A value of 0 effectively disables smoothing. Default value = 60 degrees.

unsigned FractureTools::FractureCutoutDesc::instancingMode

The instancing mode.

bool FractureTools::FractureCutoutDesc::splitNonconvexRegions

If true, non-convex cutouts will be split into convex ones.

bool FractureTools::FractureCutoutDesc::tileFractureMap

If tileFractureMap is true, the map will be tiled across the destructible.

bool FractureTools::FractureCutoutDesc::trimFaceCollisionHulls

If true, the backface and cutouts will be trimmed if (a) backface noise is non-zero or (b) the collision hull is something other than the mesh convex hull ("Wrap Graphics Mesh"). Trimming is done by intersecting the face slice plane (without added noise) with the backface and cutouts. Default is true.

CutoutParameters FractureTools::FractureCutoutDesc::userDefinedCutoutParameters

Cutout parameters used if user-defined (UV-based) cutout fracturing is selected by setting directions = 0

physx::PxVec3 FractureTools::FractureCutoutDesc::userDefinedDirection

The cutout direction if directions = 0. When this is used, it must be have non-zero length (it will be normalized internally), and userUVMapping must be set (this may be done with AssetAuthoring::calculateCutoutUVMapping).

physx::PxMat33 FractureTools::FractureCutoutDesc::userUVMapping

The UV mapping used if directons = 0 (along with userDefinedDirection).

physx::PxVec2 FractureTools::FractureCutoutDesc::uvTileSize

The U,V width of the fracture map when instancing chunks

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • FractureCutoutDesc
FractureTools::FractureCutoutDesc Member List
This is the complete list of members for FractureTools::FractureCutoutDesc, including all inherited members.
chunkFracturingMethod | FractureTools::FractureCutoutDesc |
CutoutChunkFracturingMethod enum name | FractureTools::FractureCutoutDesc |
CutoutChunkFracturingMethodCount enum value | FractureTools::FractureCutoutDesc |
cutoutHeightInvert | FractureTools::FractureCutoutDesc |
cutoutHeightOffset | FractureTools::FractureCutoutDesc |
cutoutHeightScale | FractureTools::FractureCutoutDesc |
cutoutParameters | FractureTools::FractureCutoutDesc |
cutoutSizeX | FractureTools::FractureCutoutDesc |
cutoutSizeY | FractureTools::FractureCutoutDesc |
cutoutWidthInvert | FractureTools::FractureCutoutDesc |
cutoutWidthOffset | FractureTools::FractureCutoutDesc |
cutoutWidthScale | FractureTools::FractureCutoutDesc |
DirectionCount enum value | FractureTools::FractureCutoutDesc |
directionOrder | FractureTools::FractureCutoutDesc |
directions | FractureTools::FractureCutoutDesc |
Directions enum name | FractureTools::FractureCutoutDesc |
DoNotFractureCutoutChunks enum value | FractureTools::FractureCutoutDesc |
DoNotInstance enum value | FractureTools::FractureCutoutDesc |
facetNormalMergeThresholdAngle | FractureTools::FractureCutoutDesc |
FractureCutoutDesc() | FractureTools::FractureCutoutDesc | [inline]
InstanceAllChunks enum value | FractureTools::FractureCutoutDesc |
InstanceCongruentChunks enum value | FractureTools::FractureCutoutDesc |
InstanceModeCount enum value | FractureTools::FractureCutoutDesc |
InstancingMode enum name | FractureTools::FractureCutoutDesc |
instancingMode | FractureTools::FractureCutoutDesc |
NegativeX enum value | FractureTools::FractureCutoutDesc |
NegativeY enum value | FractureTools::FractureCutoutDesc |
NegativeZ enum value | FractureTools::FractureCutoutDesc |
PositiveX enum value | FractureTools::FractureCutoutDesc |
PositiveY enum value | FractureTools::FractureCutoutDesc |
PositiveZ enum value | FractureTools::FractureCutoutDesc |
setToDefault() | FractureTools::FractureCutoutDesc | [inline]
SliceFractureCutoutChunks enum value | FractureTools::FractureCutoutDesc |
splitNonconvexRegions | FractureTools::FractureCutoutDesc |
tileFractureMap | FractureTools::FractureCutoutDesc |
trimFaceCollisionHulls | FractureTools::FractureCutoutDesc |
UserDefined enum value | FractureTools::FractureCutoutDesc |
userDefinedCutoutParameters | FractureTools::FractureCutoutDesc |
userDefinedDirection | FractureTools::FractureCutoutDesc |
userUVMapping | FractureTools::FractureCutoutDesc |
uvTileSize | FractureTools::FractureCutoutDesc |
VoronoiFractureCutoutChunks enum value | FractureTools::FractureCutoutDesc |
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: FractureTools::FractureSliceDesc Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • FractureSliceDesc
Public Types | Public Member Functions | Public Attributes
FractureTools::FractureSliceDesc Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Types

enum NoiseMode {
NoiseWavePlane = 0,
NoisePerlin2D,
NoisePerlin3D,
NoiseModeCount
}

Public Member Functions

FractureSliceDesc ()
void | setToDefault ()

Public Attributes

unsigned | maxDepth
SliceParameters * sliceParameters
bool | useTargetProportions
float | targetProportions [3]
float | minimumChunkSize [3]
nvidia::FractureMaterialDesc | materialDesc [3]
bool | instanceChunks
bool | useDisplacementMaps
unsigned | noiseMode

Detailed Description

FractureSliceDesc

Descriptor for slice-mode fracturing.

Member Enumeration Documentation

enum FractureTools::FractureSliceDesc::NoiseMode

Enum describing creation of displacement maps.

Enumerator:
NoiseWavePlane
NoisePerlin2D
NoisePerlin3D
NoiseModeCount

Constructor & Destructor Documentation

FractureTools::FractureSliceDesc::FractureSliceDesc ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::FractureSliceDesc::setToDefault ( ) [inline]

Sets the default values:

maxDepth = 0; sliceParameters = NULL; useTargetProportions = false; targetProportions[0..2] = 1.0f; minimumChunkSize[0..2] = 0.0f; materialDesc[0..2].setToDefault(); instanceChunks = false; useDisplacementMaps = false; noiseMode = NoiseWavePlane;

Member Data Documentation

bool FractureTools::FractureSliceDesc::instanceChunks

If instanceChunks is true, corresponding chunks in different destructible actors will be instanced.

nvidia::FractureMaterialDesc FractureTools::FractureSliceDesc::materialDesc[3]

Material application descriptor used for each slice axis.

unsigned FractureTools::FractureSliceDesc::maxDepth

How many times to recurse the slicing process

float FractureTools::FractureSliceDesc::minimumChunkSize[3]

Smallest size allowed for chunks, as measured by their bounding box widths along the x, y, and z axes. The sizes are interpreted as fractions of the unfractured mesh's bounding box width. Chunks created by fracturing which are smaller than this limit will be removed. Note - this will leave holes at the given depth. Default = (0,0,0), which disables this feature.

unsigned FractureTools::FractureSliceDesc::noiseMode

The noise mode. If displacement maps are enabled, NoisePerlin3D will be used.

SliceParameters* FractureTools::FractureSliceDesc::sliceParameters

Array of slice parameters; must be of length maxDepth

float FractureTools::FractureSliceDesc::targetProportions[3]

If useTargetProportions is true, the splitsPerPass values will not necessarily be used. Instead, the closest values will be chosen at each recursion of slicing, in order to make the pieces match the target proportions as closely as possible.

Note: the more noise there is in the slicing surfaces, the less accurate these proportions will be.

bool FractureTools::FractureSliceDesc::useDisplacementMaps

If true, slice geometry and noise will be stored in a separate displacement offset buffer.

bool FractureTools::FractureSliceDesc::useTargetProportions

If this is true, the targetProportions (see below) will be used.

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • FractureSliceDesc
FractureTools::FractureSliceDesc Member List
This is the complete list of members for FractureTools::FractureSliceDesc, including all inherited members.
FractureSliceDesc() | FractureTools::FractureSliceDesc | [inline]
instanceChunks | FractureTools::FractureSliceDesc |
materialDesc | FractureTools::FractureSliceDesc |
maxDepth | FractureTools::FractureSliceDesc |
minimumChunkSize | FractureTools::FractureSliceDesc |
NoiseMode enum name | FractureTools::FractureSliceDesc |
noiseMode | FractureTools::FractureSliceDesc |
NoiseModeCount enum value | FractureTools::FractureSliceDesc |
NoisePerlin2D enum value | FractureTools::FractureSliceDesc |
NoisePerlin3D enum value | FractureTools::FractureSliceDesc |
NoiseWavePlane enum value | FractureTools::FractureSliceDesc |
setToDefault() | FractureTools::FractureSliceDesc | [inline]
sliceParameters | FractureTools::FractureSliceDesc |
targetProportions | FractureTools::FractureSliceDesc |
useDisplacementMaps | FractureTools::FractureSliceDesc |
useTargetProportions | FractureTools::FractureSliceDesc |
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: FractureTools::FractureVoronoiDesc Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • FractureVoronoiDesc
Public Types | Public Member Functions | Public Attributes
FractureTools::FractureVoronoiDesc Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Types

enum NoiseMode {
NoiseWavePlane = 0,
NoisePerlin2D,
NoisePerlin3D,
NoiseModeCount
}

Public Member Functions

FractureVoronoiDesc ()
void | setToDefault ()

Public Attributes

unsigned | siteCount
const physx::PxVec3 * | sites
const uint32_t * | chunkIndices
NoiseParameters faceNoise
bool | instanceChunks
bool | useDisplacementMaps
unsigned | noiseMode
float | minimumChunkSize
nvidia::FractureMaterialDesc | materialDesc

Detailed Description

FractureVoronoiDesc

Descriptor for Voronoi decomposition fracturing.

Member Enumeration Documentation

enum FractureTools::FractureVoronoiDesc::NoiseMode

Enum describing creation of displacement maps.

Enumerator:
NoiseWavePlane
NoisePerlin2D
NoisePerlin3D
NoiseModeCount

Constructor & Destructor Documentation

FractureTools::FractureVoronoiDesc::FractureVoronoiDesc ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::FractureVoronoiDesc::setToDefault ( ) [inline]

Sets the default values:

siteCount = 0; sites = NULL; chunkIndices = NULL; faceNoise.setToDefault(); instanceChunks = false; useDisplacementMaps = false; noiseMode = NoiseWavePlane; minimumChunkSize = 0.0f; materialDesc.setToDefault();

Member Data Documentation

const uint32_t* FractureTools::FractureVoronoiDesc::chunkIndices

Array of chunk indices to associate with each site. If this pointer is NULL, then all sites will be used to split all chunks relevant to the splitting operation. Otherwise, the chunkIndices array must be of length siteCount.

NoiseParameters FractureTools::FractureVoronoiDesc::faceNoise

Describes the characteristics of the interior surfaces. If the noise is 0, the cutting surface will smooth. Otherwise, there will be some variation, or roughness, to the surface.

Note: this noise is applied only to the graphics of the chunks. The chunks' collision volumes AND the chunks' children (if fractured further) will NOT be affected by this noise.

bool FractureTools::FractureVoronoiDesc::instanceChunks

If instanceChunks is true, corresponding chunks in different destructible actors will be instanced.

nvidia::FractureMaterialDesc FractureTools::FractureVoronoiDesc::materialDesc

Material application descriptor used for each slice. Note: the U-direction and UV offset in the descriptor will be ignored - UV mapping is done in arbitrary orientation and translation on each chunk face.

float FractureTools::FractureVoronoiDesc::minimumChunkSize

Smallest size allowed for chunks, as measured by their bounding sphere diameters. The sizes are interpreted as fractions of the unfractured mesh's bounding sphere diameter. Chunks created by fracturing which are smaller than this limit will be removed. Note - this will leave holes at the given depth. Default = 0, which disables this feature.

unsigned FractureTools::FractureVoronoiDesc::noiseMode

The noise mode. If displacement maps are enabled, NoisePerlin3D will be used.

unsigned FractureTools::FractureVoronoiDesc::siteCount

Number of cell sites in the sites array. Must be positive.

const physx::PxVec3* FractureTools::FractureVoronoiDesc::sites

Array of cell sites. The length of this array is given by siteCount.

bool FractureTools::FractureVoronoiDesc::useDisplacementMaps

If true, slice geometry and noise will be stored in a separate displacement offset buffer.

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • FractureVoronoiDesc
FractureTools::FractureVoronoiDesc Member List
This is the complete list of members for FractureTools::FractureVoronoiDesc, including all inherited members.
chunkIndices | FractureTools::FractureVoronoiDesc |
faceNoise | FractureTools::FractureVoronoiDesc |
FractureVoronoiDesc() | FractureTools::FractureVoronoiDesc | [inline]
instanceChunks | FractureTools::FractureVoronoiDesc |
materialDesc | FractureTools::FractureVoronoiDesc |
minimumChunkSize | FractureTools::FractureVoronoiDesc |
noiseMode | FractureTools::FractureVoronoiDesc |
NoiseMode enum name | FractureTools::FractureVoronoiDesc |
NoiseModeCount enum value | FractureTools::FractureVoronoiDesc |
NoisePerlin2D enum value | FractureTools::FractureVoronoiDesc |
NoisePerlin3D enum value | FractureTools::FractureVoronoiDesc |
NoiseWavePlane enum value | FractureTools::FractureVoronoiDesc |
setToDefault() | FractureTools::FractureVoronoiDesc | [inline]
siteCount | FractureTools::FractureVoronoiDesc |
sites | FractureTools::FractureVoronoiDesc |
useDisplacementMaps | FractureTools::FractureVoronoiDesc |
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: FractureTools::MeshProcessingParameters Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • MeshProcessingParameters
Public Member Functions | Public Attributes
FractureTools::MeshProcessingParameters Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Member Functions

MeshProcessingParameters ()
void | setToDefault ()

Public Attributes

bool | islandGeneration
bool | removeTJunctions
unsigned | microgridSize
nvidia::BSPOpenMode::Enum | meshMode
int | verbosity

Detailed Description

These parameters are passed into the fracturing functions to guide mesh processing.

Constructor & Destructor Documentation

FractureTools::MeshProcessingParameters::MeshProcessingParameters ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::MeshProcessingParameters::setToDefault ( ) [inline]

Set default values

Member Data Documentation

bool FractureTools::MeshProcessingParameters::islandGeneration

If this is true, separate mesh islands will be turned into separate chunks. Default = false.

nvidia::BSPOpenMode::Enum FractureTools::MeshProcessingParameters::meshMode

Open mesh handling. Modes: Automatic, Closed, Open (see BSPOpenMode) Closed mode assumes the mesh is closed and attempts to insert interior faces. Open mode assumes the mesh is open and does not insert interior faces. Automatic mode attempts to determine if the mesh is open or closed, and act accordingly.

Default is Automatic mode.

unsigned FractureTools::MeshProcessingParameters::microgridSize

The mesh is initially scaled to fit in a unit cube, then (if gridSize is not zero), the vertices of the scaled mesh are snapped to a grid of size 1/gridSize. A power of two is recommended. Default = 65536.

bool FractureTools::MeshProcessingParameters::removeTJunctions

If this is true, all T-junctions will be removed from the mesh. Default = false.

int FractureTools::MeshProcessingParameters::verbosity

Debug output verbosity level. The higher the number, the more messages are output. Default = 0.

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • MeshProcessingParameters
FractureTools::MeshProcessingParameters Member List
This is the complete list of members for FractureTools::MeshProcessingParameters, including all inherited members.
islandGeneration | FractureTools::MeshProcessingParameters |
meshMode | FractureTools::MeshProcessingParameters |
MeshProcessingParameters() | FractureTools::MeshProcessingParameters | [inline]
microgridSize | FractureTools::MeshProcessingParameters |
removeTJunctions | FractureTools::MeshProcessingParameters |
setToDefault() | FractureTools::MeshProcessingParameters | [inline]
verbosity | FractureTools::MeshProcessingParameters |
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: FractureTools::NoiseParameters Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • NoiseParameters
Public Member Functions | Public Attributes
FractureTools::NoiseParameters Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Member Functions

NoiseParameters ()
void | setToDefault ()

Public Attributes

float | amplitude
float | frequency
int | gridSize
int | type

Detailed Description

NoiseParameters These parameters are used to build a splitting surface.

Constructor & Destructor Documentation

FractureTools::NoiseParameters::NoiseParameters ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::NoiseParameters::setToDefault ( ) [inline]

Set default values:

amplitude = 0.0f; frequency = 0.25f; gridSize = 10; type = 0;

Member Data Documentation

float FractureTools::NoiseParameters::amplitude

Size of the fluctuations, relative to mesh size

float FractureTools::NoiseParameters::frequency

Noise frequencey relative to 1/(grid spacing). On scales much smaller than this, the function is smooth. On scales much large, the function looks uncorrelated

int FractureTools::NoiseParameters::gridSize

Suggested number of grid elements across the mesh. The actual number may vary depending on the mesh's proportions.

int FractureTools::NoiseParameters::type

Noise function to use. This parameter is currently unused. Noise is generated by superposition of many fourier modes in random directions, with frequencies randomly chosen in a band around the input frequency,

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • NoiseParameters
FractureTools::NoiseParameters Member List
This is the complete list of members for FractureTools::NoiseParameters, including all inherited members.
amplitude | FractureTools::NoiseParameters |
frequency | FractureTools::NoiseParameters |
gridSize | FractureTools::NoiseParameters |
NoiseParameters() | FractureTools::NoiseParameters | [inline]
setToDefault() | FractureTools::NoiseParameters | [inline]
type | FractureTools::NoiseParameters |
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: FractureTools::SliceParameters Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • SliceParameters
Public Types | Public Member Functions | Public Attributes
FractureTools::SliceParameters Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Types

enum Order {
XYZ,
YZX,
ZXY,
ZYX,
YXZ,
XZY,
Through
}

Public Member Functions

SliceParameters ()
void | setToDefault ()

Public Attributes

unsigned | order
unsigned | splitsPerPass [3]
float | linearVariation [3]
float | angularVariation [3]
NoiseParameters | noise [3]

Detailed Description

SliceParameters

The slicing parameters for X, Y, and Z slicing of a mesh.

Member Enumeration Documentation

enum FractureTools::SliceParameters::Order

Which axis order to slice the mesh. This only matters if there is randomness in the slice surface.

Enumerator:
XYZ
YZX
ZXY
ZYX
YXZ
XZY
Through

Constructor & Destructor Documentation

FractureTools::SliceParameters::SliceParameters ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::SliceParameters::setToDefault ( ) [inline]

Sets all NoiseParameters to their defaults: order = XYZ; splitsPerPass[0] = splitsPerPass[1] = splitsPerPass[2] = 1; linearVariation[0] = linearVariation[1] = linearVariation[2] = 0.1f; angularVariation[0] = angularVariation[1] = angularVariation[2] = 20.0f*3.1415927f/180.0f; noise[0].setToDefault(); noise[1].setToDefault(); noise[2].setToDefault();

Member Data Documentation

float FractureTools::SliceParameters::angularVariation[3]

Variation in the slice surface angle along each axis. 0 variation means the slice surfaces are axis-aligned. Otherwise, the surface normal will be varied randomly, with angle to the axis somewhere within the given variation (in radians).

float FractureTools::SliceParameters::linearVariation[3]

Variation in slice position along each axis. This is a relative quantity. linearVariation[axis] = 0 means the slicing offsets are evenly spaced across the mesh along the axis. linearVariation[axis] = 1 means the slicing offsets are randomly chosen in a range of width 1/(splitsPerPass[axis]+1) times the width of the mesh along the axis.

NoiseParameters FractureTools::SliceParameters::noise[3]

The noise for each slicing direction

unsigned FractureTools::SliceParameters::order

The slicing order (see the Order enum)

unsigned FractureTools::SliceParameters::splitsPerPass[3]

How many times to slice along each axis

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • SliceParameters
FractureTools::SliceParameters Member List
This is the complete list of members for FractureTools::SliceParameters, including all inherited members.
angularVariation | FractureTools::SliceParameters |
linearVariation | FractureTools::SliceParameters |
noise | FractureTools::SliceParameters |
order | FractureTools::SliceParameters |
Order enum name | FractureTools::SliceParameters |
setToDefault() | FractureTools::SliceParameters | [inline]
SliceParameters() | FractureTools::SliceParameters | [inline]
splitsPerPass | FractureTools::SliceParameters |
Through enum value | FractureTools::SliceParameters |
XYZ enum value | FractureTools::SliceParameters |
XZY enum value | FractureTools::SliceParameters |
YXZ enum value | FractureTools::SliceParameters |
YZX enum value | FractureTools::SliceParameters |
ZXY enum value | FractureTools::SliceParameters |
ZYX enum value | FractureTools::SliceParameters |
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::ApexChunkFlag Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexChunkFlag
Public Types
nvidia::apex::ApexChunkFlag Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Types

enum Enum {
DYNAMIC = 1 << 0,
EXTERNALLY_SUPPORTED = 1 << 1,
WORLD_SUPPORTED = 1 << 2,
FRACTURED = 1 << 3,
DESTROYED_FIFO_FULL = 1 << 4,
DESTROYED_TIMED_OUT = 1 << 5,
DESTROYED_EXCEEDED_MAX_DISTANCE = 1 << 6,
DESTROYED_CRUMBLED = 1 << 7,
DESTROYED_LEFT_VALID_BOUNDS = 1 << 8,
DESTROYED_LEFT_USER_BOUNDS = 1 << 9,
DESTROYED_ENTERED_USER_BOUNDS = 1 << 10
}

Detailed Description

Flags returned by an UserChunkReport

Member Enumeration Documentation

enum nvidia::apex::ApexChunkFlag::Enum

Enum of apex chunk flag

Enumerator:
DYNAMIC

The chunk is dynamic

EXTERNALLY_SUPPORTED

The chunk has environmental support, so will remain kinematic until fractured

WORLD_SUPPORTED

Only true if EXTERNALLY_SUPPORTED is true. In addition, this means that it gained support via static geometry overlap.

FRACTURED

The chunk has been fractured

DESTROYED_FIFO_FULL

The chunk has been destroyed because the PxActor FIFO was full

DESTROYED_TIMED_OUT

The chunk has been destroyed because it has exceeded the maximum debris lifetime

DESTROYED_EXCEEDED_MAX_DISTANCE

The chunk has been destroyed because it has exceeded the maximum debris distance

DESTROYED_CRUMBLED

The destroyed chunk has generated crumble particles

DESTROYED_LEFT_VALID_BOUNDS

The destroyed chunk has moved beyond the destructible actor's valid bounds.

DESTROYED_LEFT_USER_BOUNDS

The destroyed chunk has moved beyond the user-defined bounding box.

DESTROYED_ENTERED_USER_BOUNDS

The destroyed chunk has moved into the user-defined bounding box.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexChunkFlag
nvidia::apex::ApexChunkFlag Member List
This is the complete list of members for nvidia::apex::ApexChunkFlag, including all inherited members.
DESTROYED_CRUMBLED enum value | nvidia::apex::ApexChunkFlag
DESTROYED_ENTERED_USER_BOUNDS enum value | nvidia::apex::ApexChunkFlag
DESTROYED_EXCEEDED_MAX_DISTANCE enum value | nvidia::apex::ApexChunkFlag
DESTROYED_FIFO_FULL enum value | nvidia::apex::ApexChunkFlag
DESTROYED_LEFT_USER_BOUNDS enum value | nvidia::apex::ApexChunkFlag
DESTROYED_LEFT_VALID_BOUNDS enum value | nvidia::apex::ApexChunkFlag
DESTROYED_TIMED_OUT enum value | nvidia::apex::ApexChunkFlag
DYNAMIC enum value | nvidia::apex::ApexChunkFlag
Enum enum name | nvidia::apex::ApexChunkFlag
EXTERNALLY_SUPPORTED enum value | nvidia::apex::ApexChunkFlag
FRACTURED enum value | nvidia::apex::ApexChunkFlag
WORLD_SUPPORTED enum value | nvidia::apex::ApexChunkFlag
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::BSPOpenMode Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BSPOpenMode
Public Types
nvidia::apex::BSPOpenMode Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Types

enum Enum {
Automatic,
Closed,
Open,
BSPOpenModeCount
}

Detailed Description

Handling of open meshes.

BSPMode::Automatic causes the mesh to be analyzed to determine if it's open or closed BSPOpenMode::Closed means the mesh should be closed and interior faces are created when the mesh is split BSPOpenMode::Open means the mesh should be open and no interior faces are created when it is split

Member Enumeration Documentation

enum nvidia::apex::BSPOpenMode::Enum

Enum of BSP open modes

Enumerator:
Automatic
Closed
Open
BSPOpenModeCount
The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BSPOpenMode
nvidia::apex::BSPOpenMode Member List
This is the complete list of members for nvidia::apex::BSPOpenMode, including all inherited members.
Automatic enum value | nvidia::apex::BSPOpenMode
BSPOpenModeCount enum value | nvidia::apex::BSPOpenMode
Closed enum value | nvidia::apex::BSPOpenMode
Enum enum name | nvidia::apex::BSPOpenMode
Open enum value | nvidia::apex::BSPOpenMode
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::ChunkData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkData
Public Attributes
nvidia::apex::ChunkData Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | index
uint32_t | depth
PxBounds3 | worldBounds
float | damage
uint32_t | flags

Detailed Description

Per-chunk data returned in DamageEventReportData

Member Data Documentation

float nvidia::apex::ChunkData::damage

How much damage the chunk has taken

uint32_t nvidia::apex::ChunkData::depth

The hierarchy depth of the chunk

uint32_t nvidia::apex::ChunkData::flags

Several flags holding chunk information

See also:
ApexChunkFlag
uint32_t nvidia::apex::ChunkData::index

The index of the chunk within the destructible asset

PxBounds3 nvidia::apex::ChunkData::worldBounds

The chunk's axis-aligned bounding box, in world space.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkData
nvidia::apex::ChunkData Member List
This is the complete list of members for nvidia::apex::ChunkData, including all inherited members.
damage | nvidia::apex::ChunkData
depth | nvidia::apex::ChunkData
flags | nvidia::apex::ChunkData
index | nvidia::apex::ChunkData
worldBounds | nvidia::apex::ChunkData
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::ChunkParticleReportData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkParticleReportData
Public Attributes
nvidia::apex::ChunkParticleReportData Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

const PxVec3 * | positions
uint32_t | positionCount
const PxVec3 * | velocities
uint32_t | velocityCount

Detailed Description

Particle buffer data returned with UserChunkParticleReport

Member Data Documentation

uint32_t nvidia::apex::ChunkParticleReportData::positionCount

The array length of the positions buffer.

const PxVec3* nvidia::apex::ChunkParticleReportData::positions

Position buffer. The length of this buffer is given by positionCount.

const PxVec3* nvidia::apex::ChunkParticleReportData::velocities

Velocity buffer. The length of this buffer is given by velocityCount. N.B.: The velocity buffer might not have the same length as the positions buffer. It will be one of three lengths: velocityCount = 0: There is no velocity data with these particles. velocityCount = 1: All of the particle velocities are the same, given by *velocities. velocityCount = positionCount: Each particle velocity is given.

uint32_t nvidia::apex::ChunkParticleReportData::velocityCount

The array length of the velocities buffer. (See the description above.)

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkParticleReportData
nvidia::apex::ChunkParticleReportData Member List
This is the complete list of members for nvidia::apex::ChunkParticleReportData, including all inherited members.
positionCount | nvidia::apex::ChunkParticleReportData
positions | nvidia::apex::ChunkParticleReportData
velocities | nvidia::apex::ChunkParticleReportData
velocityCount | nvidia::apex::ChunkParticleReportData
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::ChunkStateEventData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkStateEventData
Public Attributes
nvidia::apex::ChunkStateEventData Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

DestructibleActor * destructible
const DestructibleChunkEvent * | stateEventList
uint32_t | stateEventListSize

Detailed Description

Chunk state event data pushed to the user, if the user requests it via ModuleDestructible::scheduleChunkStateEventCallback.

Member Data Documentation

DestructibleActor* nvidia::apex::ChunkStateEventData::destructible

The DestructibleActor instance that these chunks belong to

const DestructibleChunkEvent* nvidia::apex::ChunkStateEventData::stateEventList

Array of chunk state event data collected since the last UserChunkReport::onStateChangeNotify call.

uint32_t nvidia::apex::ChunkStateEventData::stateEventListSize

Size of the stateEventList array

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkStateEventData
nvidia::apex::ChunkStateEventData Member List
This is the complete list of members for nvidia::apex::ChunkStateEventData, including all inherited members.
destructible | nvidia::apex::ChunkStateEventData
stateEventList | nvidia::apex::ChunkStateEventData
stateEventListSize | nvidia::apex::ChunkStateEventData
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::ChunkTransformHeader Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkTransformHeader
Public Attributes
nvidia::apex::ChunkTransformHeader Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | userActorID
User actor ID.
uint32_t | chunkTransformCount
Chunk transform count.
ChunkTransformUnit * chunkTransformBufferStart
Chunk transform buffer start.
ChunkTransformHeader * next
Pointer to next ChunkTransformHeader structure.

Detailed Description

Chunk transform header.

Member Data Documentation

ChunkTransformUnit* nvidia::apex::ChunkTransformHeader::chunkTransformBufferStart

Chunk transform buffer start.

uint32_t nvidia::apex::ChunkTransformHeader::chunkTransformCount

Chunk transform count.

ChunkTransformHeader* nvidia::apex::ChunkTransformHeader::next

Pointer to next ChunkTransformHeader structure.

uint32_t nvidia::apex::ChunkTransformHeader::userActorID

User actor ID.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkTransformHeader
nvidia::apex::ChunkTransformHeader Member List
This is the complete list of members for nvidia::apex::ChunkTransformHeader, including all inherited members.
chunkTransformBufferStart | nvidia::apex::ChunkTransformHeader
chunkTransformCount | nvidia::apex::ChunkTransformHeader
next | nvidia::apex::ChunkTransformHeader
userActorID | nvidia::apex::ChunkTransformHeader
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::ChunkTransformUnit Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkTransformUnit
Public Attributes
nvidia::apex::ChunkTransformUnit Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | chunkIndex
Chunk index.
PxVec3 | chunkPosition
Position.
PxQuat | chunkOrientation
Chunk orientation.

Detailed Description

Chunk transform unit.

Member Data Documentation

uint32_t nvidia::apex::ChunkTransformUnit::chunkIndex

Chunk index.

PxQuat nvidia::apex::ChunkTransformUnit::chunkOrientation

Chunk orientation.

PxVec3 nvidia::apex::ChunkTransformUnit::chunkPosition

Position.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkTransformUnit
nvidia::apex::ChunkTransformUnit Member List
This is the complete list of members for nvidia::apex::ChunkTransformUnit, including all inherited members.
chunkIndex | nvidia::apex::ChunkTransformUnit
chunkOrientation | nvidia::apex::ChunkTransformUnit
chunkPosition | nvidia::apex::ChunkTransformUnit
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::CollisionDesc Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CollisionDesc
Public Member Functions | Public Attributes
nvidia::apex::CollisionDesc Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

CollisionDesc ()
void | setToDefault ()

Public Attributes

unsigned | mDepthCount
CollisionVolumeDesc * mVolumeDescs
float | mMaximumTrimming

Detailed Description

Collision descriptor

Constructor & Destructor Documentation

nvidia::apex::CollisionDesc::CollisionDesc ( ) [inline]

Constructor sets default values.

Member Function Documentation

void nvidia::apex::CollisionDesc::setToDefault ( ) [inline]

Set CollisionDesc to default values

Member Data Documentation

unsigned nvidia::apex::CollisionDesc::mDepthCount

How many collision volume descriptors are in the mVolumeDescs array.

This count need not match the depth count of the destructible to be created. If it is greater than the depth count of the destructible, the extra volume descriptors will be ignored. If it is less than the depth count of the destructible, then mVolumeDescs[depthCount-1] will be used unless depthCount is zero. In that case, the defeult CollisionVolumeDesc() will be used.

This may be zero, in which case all volume descriptors will be the default values. If it is not zero, mVolumeDescs must be a valid pointer.

float nvidia::apex::CollisionDesc::mMaximumTrimming

The maximum amount to trim overlapping collision hulls (as a percentage of the hulls' widths)

Default = 0.2f

CollisionVolumeDesc* nvidia::apex::CollisionDesc::mVolumeDescs

Array of volume descriptors of length depthCount (may be NULL if depthCount is zero).

The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CollisionDesc
nvidia::apex::CollisionDesc Member List
This is the complete list of members for nvidia::apex::CollisionDesc, including all inherited members.
CollisionDesc() | nvidia::apex::CollisionDesc | [inline]
mDepthCount | nvidia::apex::CollisionDesc |
mMaximumTrimming | nvidia::apex::CollisionDesc |
mVolumeDescs | nvidia::apex::CollisionDesc |
setToDefault() | nvidia::apex::CollisionDesc | [inline]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::CollisionVolumeDesc Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CollisionVolumeDesc
Public Member Functions | Public Attributes
nvidia::apex::CollisionVolumeDesc Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

CollisionVolumeDesc ()
void | setToDefault ()

Public Attributes

ConvexHullMethod::Enum | mHullMethod
float | mConcavityPercent
float | mMergeThreshold
uint32_t | mRecursionDepth
uint32_t | mMaxVertexCount
uint32_t | mMaxEdgeCount
uint32_t | mMaxFaceCount

Detailed Description

Collision volume descriptor for a chunk

Constructor & Destructor Documentation

nvidia::apex::CollisionVolumeDesc::CollisionVolumeDesc ( ) [inline]

Member Function Documentation

void nvidia::apex::CollisionVolumeDesc::setToDefault ( ) [inline]

Set CollisionVolumeDesc to default values

Member Data Documentation

float nvidia::apex::CollisionVolumeDesc::mConcavityPercent

Allowed concavity if mHullMethod = ConvexHullMethod::CONVEX_DECOMPOSITION. Default = 4.0.

ConvexHullMethod::Enum nvidia::apex::CollisionVolumeDesc::mHullMethod

How to generate convex hulls for a chunk. See ConvexHullMethod::Enum. Default = CONVEX_DECOMPOSITION.

uint32_t nvidia::apex::CollisionVolumeDesc::mMaxEdgeCount

The maximum number of edges each hull may have. If 0, there is no limit. Default = 0.

uint32_t nvidia::apex::CollisionVolumeDesc::mMaxFaceCount

The maximum number of faces each hull may have. If 0, there is no limit. Default = 0.

uint32_t nvidia::apex::CollisionVolumeDesc::mMaxVertexCount

The maximum number of vertices each hull may have. If 0, there is no limit. Default = 0.

float nvidia::apex::CollisionVolumeDesc::mMergeThreshold

Merge threshold if mHullMethod = ConvexHullMethod::CONVEX_DECOMPOSITION. Default = 4.0.

uint32_t nvidia::apex::CollisionVolumeDesc::mRecursionDepth

Recursion depth if mHullMethod = ConvexHullMethod::CONVEX_DECOMPOSITION. Depth = 0 generates a single convex hull. Higher recursion depths may generate more convex hulls to fit the mesh. Default = 0.

The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CollisionVolumeDesc
nvidia::apex::CollisionVolumeDesc Member List
This is the complete list of members for nvidia::apex::CollisionVolumeDesc, including all inherited members.
CollisionVolumeDesc() | nvidia::apex::CollisionVolumeDesc | [inline]
mConcavityPercent | nvidia::apex::CollisionVolumeDesc |
mHullMethod | nvidia::apex::CollisionVolumeDesc |
mMaxEdgeCount | nvidia::apex::CollisionVolumeDesc |
mMaxFaceCount | nvidia::apex::CollisionVolumeDesc |
mMaxVertexCount | nvidia::apex::CollisionVolumeDesc |
mMergeThreshold | nvidia::apex::CollisionVolumeDesc |
mRecursionDepth | nvidia::apex::CollisionVolumeDesc |
setToDefault() | nvidia::apex::CollisionVolumeDesc | [inline]
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::DamageEventCoreData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventCoreData
Public Attributes
nvidia::apex::DamageEventCoreData Struct Reference

#include <ModuleDestructible.h>

Inheritance diagram for nvidia::apex::DamageEventCoreData:
nvidia::apex::ImpactDamageEventData

List of all members.

Public Attributes

int32_t | chunkIndexInAsset
Which chunk the damage is being applied to (non-range based damage)
PxVec3 | position
The position, in world space, where the damage event is originating from.
float | damage
The amount of damage.
float | radius
The radius of the damage, if this is a range based damage event.

Detailed Description

The core data of Damage Event. It is used for sync damage coloring.

Member Data Documentation

int32_t nvidia::apex::DamageEventCoreData::chunkIndexInAsset

Which chunk the damage is being applied to (non-range based damage)

float nvidia::apex::DamageEventCoreData::damage

The amount of damage.

PxVec3 nvidia::apex::DamageEventCoreData::position

The position, in world space, where the damage event is originating from.

float nvidia::apex::DamageEventCoreData::radius

The radius of the damage, if this is a range based damage event.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventCoreData
nvidia::apex::DamageEventCoreData Member List
This is the complete list of members for nvidia::apex::DamageEventCoreData, including all inherited members.
chunkIndexInAsset | nvidia::apex::DamageEventCoreData
damage | nvidia::apex::DamageEventCoreData
position | nvidia::apex::DamageEventCoreData
radius | nvidia::apex::DamageEventCoreData
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::DamageEventHeader Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventHeader
Public Attributes
nvidia::apex::DamageEventHeader Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | userActorID
User actor ID.
uint32_t | damageEventCount
Damage event count.
DamageEventUnit * damageEventBufferStart
damage event buffer size
DamageEventHeader * next
Pointer to next DamageEventHeader structure.

Detailed Description

Damage event header.

Member Data Documentation

DamageEventUnit* nvidia::apex::DamageEventHeader::damageEventBufferStart

damage event buffer size

uint32_t nvidia::apex::DamageEventHeader::damageEventCount

Damage event count.

DamageEventHeader* nvidia::apex::DamageEventHeader::next

Pointer to next DamageEventHeader structure.

uint32_t nvidia::apex::DamageEventHeader::userActorID

User actor ID.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventHeader
nvidia::apex::DamageEventHeader Member List
This is the complete list of members for nvidia::apex::DamageEventHeader, including all inherited members.
damageEventBufferStart | nvidia::apex::DamageEventHeader
damageEventCount | nvidia::apex::DamageEventHeader
next | nvidia::apex::DamageEventHeader
userActorID | nvidia::apex::DamageEventHeader
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::DamageEventReportData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventReportData
Public Attributes
nvidia::apex::DamageEventReportData Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

DestructibleActor * destructible
PxVec3 | hitDirection
PxBounds3 | worldBounds
uint32_t | totalNumberOfFractureEvents
uint16_t | minDepth
uint16_t | maxDepth
const ChunkData * | fractureEventList
uint32_t | fractureEventListSize
physx::PxActor const * | impactDamageActor
PxVec3 | hitPosition
void * | appliedDamageUserData

Detailed Description

Per-actor damage event data returned by an UserChunkReport

Member Data Documentation

void* nvidia::apex::DamageEventReportData::appliedDamageUserData

User data from applyDamage or applyRadiusDamage.

DestructibleActor* nvidia::apex::DamageEventReportData::destructible

The DestructibleActor instance that these chunks belong to

const ChunkData* nvidia::apex::DamageEventReportData::fractureEventList

Array of chunk fracture event data for all chunks above a size threshold, which have flags that overlap the module's chunkReportBitMask (see ModuleDestructible::setChunkReportBitMask). Currently the size cutoff is determined by the ModuleDestructible's chunkReportMaxFractureEventDepth (See ModuleDestructible::setChunkReportMaxFractureEventDepth). All chunks up to that depth, but no deeper, are reported in this list. The size of this array is given by fractureEventListSize. fractureEventList may be NULL if fractureEventListSize = 0.

uint32_t nvidia::apex::DamageEventReportData::fractureEventListSize

Size of the fractureEventList array. This may be less than totalNumberOfFractureEvents if some of the fracture events involve chunks which do not meet the size criterion described in the notes for the fractureEventList array.

PxVec3 nvidia::apex::DamageEventReportData::hitDirection

Damage event hitDirection in world space.

PxVec3 nvidia::apex::DamageEventReportData::hitPosition

Impact damage position in world-space.

physx::PxActor const* nvidia::apex::DamageEventReportData::impactDamageActor

Other PhysX actor that caused damage to DamageEventReportData.

uint16_t nvidia::apex::DamageEventReportData::maxDepth

Max depth of chunk fracture events caused by this damage event, which have flags that overlap the module's chunkReportBitMask (see ModuleDestructible::setChunkReportBitMask).

uint16_t nvidia::apex::DamageEventReportData::minDepth

Min depth of chunk fracture events caused by this damage event, which have flags that overlap the module's chunkReportBitMask (see ModuleDestructible::setChunkReportBitMask).

uint32_t nvidia::apex::DamageEventReportData::totalNumberOfFractureEvents

Total number of fracture events caused by this damage event, which have flags that overlap the module's chunkReportBitMask (see ModuleDestructible::setChunkReportBitMask).

PxBounds3 nvidia::apex::DamageEventReportData::worldBounds

The axis-aligned bounding box of all chunk fractures caused by this damage event, which have flags that overlap the module's chunkReportBitMask (see ModuleDestructible::setChunkReportBitMask).

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventReportData
nvidia::apex::DamageEventReportData Member List
This is the complete list of members for nvidia::apex::DamageEventReportData, including all inherited members.
appliedDamageUserData | nvidia::apex::DamageEventReportData
destructible | nvidia::apex::DamageEventReportData
fractureEventList | nvidia::apex::DamageEventReportData
fractureEventListSize | nvidia::apex::DamageEventReportData
hitDirection | nvidia::apex::DamageEventReportData
hitPosition | nvidia::apex::DamageEventReportData
impactDamageActor | nvidia::apex::DamageEventReportData
maxDepth | nvidia::apex::DamageEventReportData
minDepth | nvidia::apex::DamageEventReportData
totalNumberOfFractureEvents | nvidia::apex::DamageEventReportData
worldBounds | nvidia::apex::DamageEventReportData
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::DamageEventUnit Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventUnit
Public Attributes
nvidia::apex::DamageEventUnit Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | chunkIndex
Chunk index.
uint32_t | damageEventFlags
Damage event flags.
float | damage
Damage value.
float | momentum
Momentum.
float | radius
Radius.
PxVec3 | position
Position.
PxVec3 | direction
Direction.

Detailed Description

Damage event unit.

Member Data Documentation

uint32_t nvidia::apex::DamageEventUnit::chunkIndex

Chunk index.

float nvidia::apex::DamageEventUnit::damage

Damage value.

uint32_t nvidia::apex::DamageEventUnit::damageEventFlags

Damage event flags.

PxVec3 nvidia::apex::DamageEventUnit::direction

Direction.

float nvidia::apex::DamageEventUnit::momentum

Momentum.

PxVec3 nvidia::apex::DamageEventUnit::position

Position.

float nvidia::apex::DamageEventUnit::radius

Radius.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventUnit
nvidia::apex::DamageEventUnit Member List
This is the complete list of members for nvidia::apex::DamageEventUnit, including all inherited members.
chunkIndex | nvidia::apex::DamageEventUnit
damage | nvidia::apex::DamageEventUnit
damageEventFlags | nvidia::apex::DamageEventUnit
direction | nvidia::apex::DamageEventUnit
momentum | nvidia::apex::DamageEventUnit
position | nvidia::apex::DamageEventUnit
radius | nvidia::apex::DamageEventUnit
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::DamageSpreadFunction Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageSpreadFunction
Public Member Functions | Public Attributes
nvidia::apex::DamageSpreadFunction Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Member Functions

PX_INLINE | DamageSpreadFunction ()
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE bool | isValid () const

Public Attributes

float | minimumRadius
minimum radius
float | radiusMultiplier
radius multiplier
float | falloffExponent
falloff exponent

Detailed Description

DamageSpreadFunction

Constructor & Destructor Documentation

PX_INLINE nvidia::apex::DamageSpreadFunction::DamageSpreadFunction ( ) [inline]

Member Function Documentation

PX_INLINE bool nvidia::apex::DamageSpreadFunction::isValid ( ) const [inline]

Returns true iff an object can be created using this descriptor.

PX_INLINE void nvidia::apex::DamageSpreadFunction::setToDefault ( ) [inline]

(re)sets the structure to the default.

Member Data Documentation

float nvidia::apex::DamageSpreadFunction::falloffExponent

falloff exponent

float nvidia::apex::DamageSpreadFunction::minimumRadius

minimum radius

float nvidia::apex::DamageSpreadFunction::radiusMultiplier

radius multiplier

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageSpreadFunction
nvidia::apex::DamageSpreadFunction Member List
This is the complete list of members for nvidia::apex::DamageSpreadFunction, including all inherited members.
DamageSpreadFunction() | nvidia::apex::DamageSpreadFunction | [inline]
falloffExponent | nvidia::apex::DamageSpreadFunction |
isValid() const | nvidia::apex::DamageSpreadFunction | [inline]
minimumRadius | nvidia::apex::DamageSpreadFunction |
radiusMultiplier | nvidia::apex::DamageSpreadFunction |
setToDefault() | nvidia::apex::DamageSpreadFunction | [inline]
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleActorChunkFlags Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorChunkFlags
Public Types
nvidia::apex::DestructibleActorChunkFlags Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Types

enum Enum { ChunkIsWorldSupported = (1<<0) }

Detailed Description

Flags which describe an actor chunk (as opposed to an asset chunk) - takes into account the actor's condition, for example a chunk may be world supported because of the actor's placement

Member Enumeration Documentation

enum nvidia::apex::DestructibleActorChunkFlags::Enum

Enum of destructible actor chunk flags

Enumerator:
ChunkIsWorldSupported

"Use world support" is set in the destructible parameters, and this chunk is a support-depth chunk that overlaps the physx scene's static geometry

The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorChunkFlags
nvidia::apex::DestructibleActorChunkFlags Member List
This is the complete list of members for nvidia::apex::DestructibleActorChunkFlags, including all inherited members.
ChunkIsWorldSupported enum value | nvidia::apex::DestructibleActorChunkFlags
Enum enum name | nvidia::apex::DestructibleActorChunkFlags
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleActorMeshType Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorMeshType
Public Types
nvidia::apex::DestructibleActorMeshType Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Types

enum Enum {
Skinned,
Static,
Count
}

Detailed Description

Render mesh distinction, skinned vs. static

Member Enumeration Documentation

enum nvidia::apex::DestructibleActorMeshType::Enum

Enum for destructible actor mesh type.

Enumerator:
Skinned
Static
Count
The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorMeshType
nvidia::apex::DestructibleActorMeshType Member List
This is the complete list of members for nvidia::apex::DestructibleActorMeshType, including all inherited members.
Count enum value | nvidia::apex::DestructibleActorMeshType
Enum enum name | nvidia::apex::DestructibleActorMeshType
Skinned enum value | nvidia::apex::DestructibleActorMeshType
Static enum value | nvidia::apex::DestructibleActorMeshType
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::DestructibleActorRaycastFlags Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorRaycastFlags
Public Types
nvidia::apex::DestructibleActorRaycastFlags Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Types

enum Enum {
NoChunks = (0),
StaticChunks = (1 << 0),
DynamicChunks = (1 << 1),
AllChunks = StaticChunks | DynamicChunks,
SegmentIntersect = (1 << 2),
ForceAccurateRaycastsOn = (1 << 3),
ForceAccurateRaycastsOff = (1 << 4)
}

Detailed Description

Flags for DestructibleActor::raycast()

Member Enumeration Documentation

enum nvidia::apex::DestructibleActorRaycastFlags::Enum

Enum of destructible actor raycast flags.

Enumerator:
NoChunks
StaticChunks
DynamicChunks
AllChunks
SegmentIntersect

Do not consider intersect times > 1.

ForceAccurateRaycastsOn
ForceAccurateRaycastsOff
The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorRaycastFlags
nvidia::apex::DestructibleActorRaycastFlags Member List
This is the complete list of members for nvidia::apex::DestructibleActorRaycastFlags, including all inherited members.
AllChunks enum value | nvidia::apex::DestructibleActorRaycastFlags
DynamicChunks enum value | nvidia::apex::DestructibleActorRaycastFlags
Enum enum name | nvidia::apex::DestructibleActorRaycastFlags
ForceAccurateRaycastsOff enum value | nvidia::apex::DestructibleActorRaycastFlags
ForceAccurateRaycastsOn enum value | nvidia::apex::DestructibleActorRaycastFlags
NoChunks enum value | nvidia::apex::DestructibleActorRaycastFlags
SegmentIntersect enum value | nvidia::apex::DestructibleActorRaycastFlags
StaticChunks enum value | nvidia::apex::DestructibleActorRaycastFlags
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::DestructibleActorSyncFlags Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorSyncFlags
Public Types
nvidia::apex::DestructibleActorSyncFlags Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Types

enum Enum {
None = 0,
CopyDamageEvents = (1 << 0),
ReadDamageEvents = (1 << 1),
CopyFractureEvents = (1 << 2),
ReadFractureEvents = (1 << 3),
CopyChunkTransform = (1 << 4),
ReadChunkTransform = (1 << 5),
Last = (1 << 6)
}

Detailed Description

Flags for managing the sync state of the destructible actor

Member Enumeration Documentation

enum nvidia::apex::DestructibleActorSyncFlags::Enum

Enum of destructible actor sync flags

Enumerator:
None
CopyDamageEvents
ReadDamageEvents
CopyFractureEvents
ReadFractureEvents
CopyChunkTransform
ReadChunkTransform
Last
The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorSyncFlags
nvidia::apex::DestructibleActorSyncFlags Member List
This is the complete list of members for nvidia::apex::DestructibleActorSyncFlags, including all inherited members.
CopyChunkTransform enum value | nvidia::apex::DestructibleActorSyncFlags
CopyDamageEvents enum value | nvidia::apex::DestructibleActorSyncFlags
CopyFractureEvents enum value | nvidia::apex::DestructibleActorSyncFlags
Enum enum name | nvidia::apex::DestructibleActorSyncFlags
Last enum value | nvidia::apex::DestructibleActorSyncFlags
None enum value | nvidia::apex::DestructibleActorSyncFlags
ReadChunkTransform enum value | nvidia::apex::DestructibleActorSyncFlags
ReadDamageEvents enum value | nvidia::apex::DestructibleActorSyncFlags
ReadFractureEvents enum value | nvidia::apex::DestructibleActorSyncFlags
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleActorSyncState Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorSyncState
Public Attributes
nvidia::apex::DestructibleActorSyncState Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Attributes

uint32_t | damageEventFilterDepth
dictates the (inclusive) maximum depth at which damage events will be buffered.
uint32_t | fractureEventFilterDepth
dictates the (inclusive) maximum depth at which fracture events will be buffered.

Detailed Description

Tweak-able parameters on source-side for controlling the actor sync state.

Member Data Documentation

uint32_t nvidia::apex::DestructibleActorSyncState::damageEventFilterDepth

dictates the (inclusive) maximum depth at which damage events will be buffered.

uint32_t nvidia::apex::DestructibleActorSyncState::fractureEventFilterDepth

dictates the (inclusive) maximum depth at which fracture events will be buffered.

The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorSyncState
nvidia::apex::DestructibleActorSyncState Member List
This is the complete list of members for nvidia::apex::DestructibleActorSyncState, including all inherited members.
damageEventFilterDepth | nvidia::apex::DestructibleActorSyncState
fractureEventFilterDepth | nvidia::apex::DestructibleActorSyncState
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleAssetStats Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAssetStats
Public Attributes
nvidia::apex::DestructibleAssetStats Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Attributes

uint32_t | totalBytes
total bytes
uint32_t | chunkCount
chunk count
uint32_t | chunkBytes
chunk bytes
uint32_t | chunkHullDataBytes
chunk hull data bytes
uint32_t | collisionCookedHullDataBytes
collision cooked hull data bytes
uint32_t | collisionMeshCount
collision mesh count
uint32_t | maxHullVertexCount
max hull vertex count
uint32_t | maxHullFaceCount
max hull face count
uint32_t | chunkWithMaxEdgeCount
chunk with max edge count
uint32_t | runtimeCookedConvexCount
runtime cooked convex count
RenderMeshAssetStats | renderMeshAssetStats
render mesh asset stats

Detailed Description

Stats for an DestructibleAsset: memory usage, counts, etc.

Member Data Documentation

uint32_t nvidia::apex::DestructibleAssetStats::chunkBytes

chunk bytes

uint32_t nvidia::apex::DestructibleAssetStats::chunkCount

chunk count

uint32_t nvidia::apex::DestructibleAssetStats::chunkHullDataBytes

chunk hull data bytes

uint32_t nvidia::apex::DestructibleAssetStats::chunkWithMaxEdgeCount

chunk with max edge count

uint32_t nvidia::apex::DestructibleAssetStats::collisionCookedHullDataBytes

collision cooked hull data bytes

uint32_t nvidia::apex::DestructibleAssetStats::collisionMeshCount

collision mesh count

uint32_t nvidia::apex::DestructibleAssetStats::maxHullFaceCount

max hull face count

uint32_t nvidia::apex::DestructibleAssetStats::maxHullVertexCount

max hull vertex count

RenderMeshAssetStats nvidia::apex::DestructibleAssetStats::renderMeshAssetStats

render mesh asset stats

uint32_t nvidia::apex::DestructibleAssetStats::runtimeCookedConvexCount

runtime cooked convex count

uint32_t nvidia::apex::DestructibleAssetStats::totalBytes

total bytes

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAssetStats
nvidia::apex::DestructibleAssetStats Member List
This is the complete list of members for nvidia::apex::DestructibleAssetStats, including all inherited members.
chunkBytes | nvidia::apex::DestructibleAssetStats
chunkCount | nvidia::apex::DestructibleAssetStats
chunkHullDataBytes | nvidia::apex::DestructibleAssetStats
chunkWithMaxEdgeCount | nvidia::apex::DestructibleAssetStats
collisionCookedHullDataBytes | nvidia::apex::DestructibleAssetStats
collisionMeshCount | nvidia::apex::DestructibleAssetStats
maxHullFaceCount | nvidia::apex::DestructibleAssetStats
maxHullVertexCount | nvidia::apex::DestructibleAssetStats
renderMeshAssetStats | nvidia::apex::DestructibleAssetStats
runtimeCookedConvexCount | nvidia::apex::DestructibleAssetStats
totalBytes | nvidia::apex::DestructibleAssetStats
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleCallbackSchedule Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleCallbackSchedule
Public Types
nvidia::apex::DestructibleCallbackSchedule Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Types

enum Enum {
Disabled = (0),
BeforeTick,
FetchResults,
Count
}

Detailed Description

Enum to control when callbacks are fired.

Member Enumeration Documentation

enum nvidia::apex::DestructibleCallbackSchedule::Enum

Enum of destructible callback schedule

Enumerator:
Disabled
BeforeTick

Called by the simulation thread.

FetchResults

Called by an application thread.

Count
The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleCallbackSchedule
nvidia::apex::DestructibleCallbackSchedule Member List
This is the complete list of members for nvidia::apex::DestructibleCallbackSchedule, including all inherited members.
BeforeTick enum value | nvidia::apex::DestructibleCallbackSchedule
Count enum value | nvidia::apex::DestructibleCallbackSchedule
Disabled enum value | nvidia::apex::DestructibleCallbackSchedule
Enum enum name | nvidia::apex::DestructibleCallbackSchedule
FetchResults enum value | nvidia::apex::DestructibleCallbackSchedule
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::DestructibleChunkEvent Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleChunkEvent
Public Types | Public Attributes
nvidia::apex::DestructibleChunkEvent Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Types

enum EventMask {
VisibilityChanged = (1 << 0),
ChunkVisible = (1 << 1)
}

Public Attributes

uint16_t | chunkIndex
Chunk index.
uint16_t | event
Event.

Detailed Description

An event structure for an optional chunk event buffer. Contains a chunk index and an event field.

Note: currently the only chunk state event is for visibility changes, so the VisibilityChanged bit will always be set when this struct is used.

Member Enumeration Documentation

enum nvidia::apex::DestructibleChunkEvent::EventMask

Enum of event mask

Enumerator:
VisibilityChanged
ChunkVisible

Member Data Documentation

uint16_t nvidia::apex::DestructibleChunkEvent::chunkIndex

Chunk index.

uint16_t nvidia::apex::DestructibleChunkEvent::event

Event.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleChunkEvent
nvidia::apex::DestructibleChunkEvent Member List
This is the complete list of members for nvidia::apex::DestructibleChunkEvent, including all inherited members.
chunkIndex | nvidia::apex::DestructibleChunkEvent
ChunkVisible enum value | nvidia::apex::DestructibleChunkEvent
event | nvidia::apex::DestructibleChunkEvent
EventMask enum name | nvidia::apex::DestructibleChunkEvent
VisibilityChanged enum value | nvidia::apex::DestructibleChunkEvent
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::DestructibleChunkSyncState Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleChunkSyncState
Public Attributes
nvidia::apex::DestructibleChunkSyncState Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Attributes

bool | disableTransformBuffering
a handy switch for controlling whether chunk transforms will be buffered this instance.
bool | excludeSleepingChunks
dictates whether chunks that are sleeping will be buffered.
uint32_t | chunkTransformCopyDepth
dictates the (inclusive) maximum depth at which chunk transforms will be buffered.

Detailed Description

Tweak-able parameters on source-side for controlling the chunk sync state. DestructibleActorSyncFlags::CopyChunkTransform must first be set.

Member Data Documentation

uint32_t nvidia::apex::DestructibleChunkSyncState::chunkTransformCopyDepth

dictates the (inclusive) maximum depth at which chunk transforms will be buffered.

bool nvidia::apex::DestructibleChunkSyncState::disableTransformBuffering

a handy switch for controlling whether chunk transforms will be buffered this instance.

bool nvidia::apex::DestructibleChunkSyncState::excludeSleepingChunks

dictates whether chunks that are sleeping will be buffered.

The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleChunkSyncState
nvidia::apex::DestructibleChunkSyncState Member List
This is the complete list of members for nvidia::apex::DestructibleChunkSyncState, including all inherited members.
chunkTransformCopyDepth | nvidia::apex::DestructibleChunkSyncState
disableTransformBuffering | nvidia::apex::DestructibleChunkSyncState
excludeSleepingChunks | nvidia::apex::DestructibleChunkSyncState
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleDepthParameters Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleDepthParameters
Public Member Functions | Public Attributes
nvidia::apex::DestructibleDepthParameters Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Member Functions

PX_INLINE | DestructibleDepthParameters ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE void | setToMostExpensive ()
(re)sets the structure to parameters which are likely to be the most computationally expensive.
PX_INLINE bool | overrideImpactDamage () const
PX_INLINE bool | overrideImpactDamageValue () const
PX_INLINE bool | ignoresPoseUpdates () const
PX_INLINE bool | ignoresRaycastCallbacks () const
PX_INLINE bool | ignoresContactCallbacks () const
PX_INLINE bool | hasUserFlagSet (uint32_t flagIndex) const

Public Attributes

uint32_t | flags

Detailed Description

Parameters that may be set for all chunks at a particular depth in the fracture hierarchy

Constructor & Destructor Documentation

PX_INLINE nvidia::apex::DestructibleDepthParameters::DestructibleDepthParameters ( )

constructor sets to default.

Member Function Documentation

PX_INLINE bool nvidia::apex::DestructibleDepthParameters::hasUserFlagSet ( uint32_t flagIndex ) const

A convenience function to determine if the USER_FLAG_0, USER_FLAG_1, USER_FLAG_2, or USER_FLAG_3 flag is set.

PX_INLINE bool nvidia::apex::DestructibleDepthParameters::ignoresContactCallbacks ( ) const

A convenience function to determine if the IGNORE_CONTACT_CALLBACKS is set.

PX_INLINE bool nvidia::apex::DestructibleDepthParameters::ignoresPoseUpdates ( ) const

A convenience function to determine if the IGNORE_POSE_UPDATES is set.

PX_INLINE bool nvidia::apex::DestructibleDepthParameters::ignoresRaycastCallbacks ( ) const

A convenience function to determine if the IGNORE_RAYCAST_CALLBACKS is set.

PX_INLINE bool nvidia::apex::DestructibleDepthParameters::overrideImpactDamage ( ) const

A convenience function to determine if the OVERRIDE_IMPACT_DAMAGE is set.

PX_INLINE bool nvidia::apex::DestructibleDepthParameters::overrideImpactDamageValue ( ) const

A convenience function to read OVERRIDE_IMPACT_DAMAGE_VALUE is set.

PX_INLINE void nvidia::apex::DestructibleDepthParameters::setToDefault ( )

(re)sets the structure to the default.

PX_INLINE void nvidia::apex::DestructibleDepthParameters::setToMostExpensive ( )

(re)sets the structure to parameters which are likely to be the most computationally expensive.

Member Data Documentation

uint32_t nvidia::apex::DestructibleDepthParameters::flags

A collection of flags defined in DestructibleDepthParametersFlag.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleDepthParameters
nvidia::apex::DestructibleDepthParameters Member List
This is the complete list of members for nvidia::apex::DestructibleDepthParameters, including all inherited members.
DestructibleDepthParameters() | nvidia::apex::DestructibleDepthParameters
flags | nvidia::apex::DestructibleDepthParameters
hasUserFlagSet(uint32_t flagIndex) const | nvidia::apex::DestructibleDepthParameters
ignoresContactCallbacks() const | nvidia::apex::DestructibleDepthParameters
ignoresPoseUpdates() const | nvidia::apex::DestructibleDepthParameters
ignoresRaycastCallbacks() const | nvidia::apex::DestructibleDepthParameters
overrideImpactDamage() const | nvidia::apex::DestructibleDepthParameters
overrideImpactDamageValue() const | nvidia::apex::DestructibleDepthParameters
setToDefault() | nvidia::apex::DestructibleDepthParameters
setToMostExpensive() | nvidia::apex::DestructibleDepthParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleDepthParametersFlag Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleDepthParametersFlag
Public Types
nvidia::apex::DestructibleDepthParametersFlag Struct Reference

PX_PS4. More...

#include <DestructibleAsset.h>

List of all members.

Public Types

enum Enum {
OVERRIDE_IMPACT_DAMAGE = (1 << 0),
OVERRIDE_IMPACT_DAMAGE_VALUE = (1 << 1),
IGNORE_POSE_UPDATES = (1 << 2),
IGNORE_RAYCAST_CALLBACKS = (1 << 3),
IGNORE_CONTACT_CALLBACKS = (1 << 4),
USER_FLAG_0 = (1 << 24),
USER_FLAG_1 = (1 << 25),
USER_FLAG_2 = (1 << 26),
USER_FLAG_3 = (1 << 27)
}

Detailed Description

PX_PS4.

Flags that may be set for all chunks at a particular depth in the fracture hierarchy

Member Enumeration Documentation

enum nvidia::apex::DestructibleDepthParametersFlag::Enum

Enum of destructible depth parameters flag

Enumerator:
OVERRIDE_IMPACT_DAMAGE

If true, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE = TRUE, no matter the setting of impactDamageDefaultDepth.. Note, DestructibleParameters::forceToDamage must also be positive for this to take effect.

OVERRIDE_IMPACT_DAMAGE_VALUE

If OVERRIDE_IMPACT_DAMAGE = TRUE, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE = TRUE, no matter the setting of impactDamageDefaultDepth..

IGNORE_POSE_UPDATES

Chunks at this depth should have pose updates ignored.

IGNORE_RAYCAST_CALLBACKS

Chunks at this depth should be ignored in raycast callbacks.

IGNORE_CONTACT_CALLBACKS

Chunks at this depth should be ignored in contact callbacks.

USER_FLAG_0

User defined flags.

USER_FLAG_1
USER_FLAG_2
USER_FLAG_3
The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleDepthParametersFlag
nvidia::apex::DestructibleDepthParametersFlag Member List
This is the complete list of members for nvidia::apex::DestructibleDepthParametersFlag, including all inherited members.
Enum enum name | nvidia::apex::DestructibleDepthParametersFlag
IGNORE_CONTACT_CALLBACKS enum value | nvidia::apex::DestructibleDepthParametersFlag
IGNORE_POSE_UPDATES enum value | nvidia::apex::DestructibleDepthParametersFlag
IGNORE_RAYCAST_CALLBACKS enum value | nvidia::apex::DestructibleDepthParametersFlag
OVERRIDE_IMPACT_DAMAGE enum value | nvidia::apex::DestructibleDepthParametersFlag
OVERRIDE_IMPACT_DAMAGE_VALUE enum value | nvidia::apex::DestructibleDepthParametersFlag
USER_FLAG_0 enum value | nvidia::apex::DestructibleDepthParametersFlag
USER_FLAG_1 enum value | nvidia::apex::DestructibleDepthParametersFlag
USER_FLAG_2 enum value | nvidia::apex::DestructibleDepthParametersFlag
USER_FLAG_3 enum value | nvidia::apex::DestructibleDepthParametersFlag
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleEmitterType Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleEmitterType
Public Types
nvidia::apex::DestructibleEmitterType Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Types

enum Enum {
Crumble,
Dust,
Count
}

Detailed Description

Determines which type of emitter to associate with a render volume

Member Enumeration Documentation

enum nvidia::apex::DestructibleEmitterType::Enum

Enum of destructible emitter types

Enumerator:
Crumble
Dust
Count
The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleEmitterType
nvidia::apex::DestructibleEmitterType Member List
This is the complete list of members for nvidia::apex::DestructibleEmitterType, including all inherited members.
Count enum value | nvidia::apex::DestructibleEmitterType
Crumble enum value | nvidia::apex::DestructibleEmitterType
Dust enum value | nvidia::apex::DestructibleEmitterType
Enum enum name | nvidia::apex::DestructibleEmitterType
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleHitChunk Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleHitChunk
Public Attributes
nvidia::apex::DestructibleHitChunk Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Attributes

uint32_t | chunkIndex
chunk index
uint32_t | hitChunkFlags
hit chunk flag

Detailed Description

Hit chunk info. Hit chunks are those directly affected by fracture events. See getHitChunkHistory and forceChunkHits.

Member Data Documentation

uint32_t nvidia::apex::DestructibleHitChunk::chunkIndex

chunk index

uint32_t nvidia::apex::DestructibleHitChunk::hitChunkFlags

hit chunk flag

The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleHitChunk
nvidia::apex::DestructibleHitChunk Member List
This is the complete list of members for nvidia::apex::DestructibleHitChunk, including all inherited members.
chunkIndex | nvidia::apex::DestructibleHitChunk
hitChunkFlags | nvidia::apex::DestructibleHitChunk
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleInitParameters Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleInitParameters
Public Member Functions | Public Attributes
nvidia::apex::DestructibleInitParameters Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Member Functions

PX_INLINE | DestructibleInitParameters ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.

Public Attributes

uint32_t | supportDepth
uint32_t | flags

Detailed Description

Parameters that apply to a destructible actor at initialization

Constructor & Destructor Documentation

PX_INLINE nvidia::apex::DestructibleInitParameters::DestructibleInitParameters ( )

constructor sets to default.

Member Function Documentation

PX_INLINE void nvidia::apex::DestructibleInitParameters::setToDefault ( )

(re)sets the structure to the default.

Member Data Documentation

uint32_t nvidia::apex::DestructibleInitParameters::flags

A collection of flags defined in DestructibleInitParametersFlag.

uint32_t nvidia::apex::DestructibleInitParameters::supportDepth

The chunk hierarchy depth at which to create a support graph. Higher depth levels give more detailed support, but will give a higher computational load. Chunks below the support depth will never be supported.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleInitParameters
nvidia::apex::DestructibleInitParameters Member List
This is the complete list of members for nvidia::apex::DestructibleInitParameters, including all inherited members.
DestructibleInitParameters() | nvidia::apex::DestructibleInitParameters
flags | nvidia::apex::DestructibleInitParameters
setToDefault() | nvidia::apex::DestructibleInitParameters
supportDepth | nvidia::apex::DestructibleInitParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleInitParametersFlag Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleInitParametersFlag
Public Types
nvidia::apex::DestructibleInitParametersFlag Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Types

enum Enum {
ASSET_DEFINED_SUPPORT = (1 << 0),
WORLD_SUPPORT = (1 << 1),
FORM_EXTENDED_STRUCTURES = (1 << 2)
}

Detailed Description

Flags that apply to a destructible actor when it created

Member Enumeration Documentation

enum nvidia::apex::DestructibleInitParametersFlag::Enum

Enum of destructible init parameters flag

Enumerator:
ASSET_DEFINED_SUPPORT

If set, then chunks which are tagged as "support" chunks (via DestructibleChunkDesc::isSupportChunk) will have environmental support in static destructibles. Note: if both ASSET_DEFINED_SUPPORT and WORLD_SUPPORT are set, then chunks must be tagged as "support" chunks AND overlap the PxScene's static geometry in order to be environmentally supported.

WORLD_SUPPORT

If set, then chunks which overlap the PxScene's static geometry will have environmental support in static destructibles. Note: if both ASSET_DEFINED_SUPPORT and WORLD_SUPPORT are set, then chunks must be tagged as "support" chunks AND overlap the PxScene's static geometry in order to be environmentally supported.

FORM_EXTENDED_STRUCTURES

If this is set and the destructible is initially static, it will become part of an extended support structure if it is in contact with another static destructible that also has this flag set.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleInitParametersFlag
nvidia::apex::DestructibleInitParametersFlag Member List
This is the complete list of members for nvidia::apex::DestructibleInitParametersFlag, including all inherited members.
ASSET_DEFINED_SUPPORT enum value | nvidia::apex::DestructibleInitParametersFlag
Enum enum name | nvidia::apex::DestructibleInitParametersFlag
FORM_EXTENDED_STRUCTURES enum value | nvidia::apex::DestructibleInitParametersFlag
WORLD_SUPPORT enum value | nvidia::apex::DestructibleInitParametersFlag
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleParameterizedType Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleParameterizedType
Public Types
nvidia::apex::DestructibleParameterizedType Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Types

enum Enum {
State,
Params
}

Detailed Description

Provides access to specific NvParamterized types provided by the destructible actor

Member Enumeration Documentation

enum nvidia::apex::DestructibleParameterizedType::Enum

Enum of destructible parameterized types

Enumerator:
State
Params
The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleParameterizedType
nvidia::apex::DestructibleParameterizedType Member List
This is the complete list of members for nvidia::apex::DestructibleParameterizedType, including all inherited members.
Enum enum name | nvidia::apex::DestructibleParameterizedType
Params enum value | nvidia::apex::DestructibleParameterizedType
State enum value | nvidia::apex::DestructibleParameterizedType
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleParameters Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleParameters
Public Types | Public Member Functions | Public Attributes
nvidia::apex::DestructibleParameters Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Types

enum | { kDepthParametersCountMax = 16 }

Public Member Functions

PX_INLINE | DestructibleParameters ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.

Public Attributes

float | damageCap
float | forceToDamage
float | impactVelocityThreshold
uint32_t | minimumFractureDepth
int32_t | impactDamageDefaultDepth
int32_t | debrisDepth
uint32_t | essentialDepth
float | debrisLifetimeMin
float | debrisLifetimeMax
float | debrisMaxSeparationMin
float | debrisMaxSeparationMax
float | debrisDestructionProbability
PxBounds3 | validBounds
float | maxChunkSpeed
uint32_t | flags
float | fractureImpulseScale
uint16_t | damageDepthLimit
uint8_t | dynamicChunksDominanceGroup
bool | useDynamicChunksGroupsMask
physx::PxFilterData | dynamicChunksFilterData
float | supportStrength
int8_t | legacyChunkBoundsTestSetting
int8_t | legacyDamageRadiusSpreadSetting
uint32_t | depthParametersCount
DestructibleDepthParameters | depthParameters [kDepthParametersCountMax]
DestructibleRTFractureParameters rtFractureParameters
bool | alwaysDrawScatterMesh

Detailed Description

Parameters that apply to a destructible actor

Member Enumeration Documentation

anonymous enum

The maximum number of DestructibleDepthParameters (see depthParameters).

Enumerator:
kDepthParametersCountMax

Constructor & Destructor Documentation

PX_INLINE nvidia::apex::DestructibleParameters::DestructibleParameters ( )

constructor sets to default.

Member Function Documentation

PX_INLINE void nvidia::apex::DestructibleParameters::setToDefault ( )

(re)sets the structure to the default.

Member Data Documentation

bool nvidia::apex::DestructibleParameters::alwaysDrawScatterMesh

This flag forces drawing of scatter mesh on chunks with depth > 1. By default is false.

float nvidia::apex::DestructibleParameters::damageCap

Limits the amount of damage applied to a chunk. This is useful for preventing the entire destructible from getting pulverized by a very large application of damage. This can easily happen when impact damage is used, and the damage amount is proportional to the impact force (see forceToDamage).

uint16_t nvidia::apex::DestructibleParameters::damageDepthLimit

How deep in the hierarchy damage will be propagated, relative to the chunk hit. Default = UINT16_MAX.

int32_t nvidia::apex::DestructibleParameters::debrisDepth

The chunk hierarchy depth at which chunks are considered to be "debris." Chunks at this depth or below will be considered for various debris settings, such as debrisLifetime. Negative values indicate that no chunk depth is considered debris. Default value is -1.

float nvidia::apex::DestructibleParameters::debrisDestructionProbability

The probablity that a debris chunk, when fractured, will simply be destroyed instead of becoming dynamic or breaking down further into child chunks. Valid range = [0.0,1.0]. Default value = 0.0.'

float nvidia::apex::DestructibleParameters::debrisLifetimeMax
See also:
DestructibleAsset::debrisLifetimeMin
float nvidia::apex::DestructibleParameters::debrisLifetimeMin

"Debris chunks" (see debrisDepth, above) will be destroyed after a time (in seconds) separated from non-debris chunks. The actual lifetime is interpolated between these two values, based upon the module's LOD setting. To disable lifetime, clear the DestructibleDepthParametersFlag::DEBRIS_TIMEOUT flag in the flags field. If debrisLifetimeMax < debrisLifetimeMin, the mean of the two is used for both. Default debrisLifetimeMin = 1.0, debrisLifetimeMax = 10.0f.

float nvidia::apex::DestructibleParameters::debrisMaxSeparationMax
See also:
DestructibleAsset::debrisMaxSeparationMin
float nvidia::apex::DestructibleParameters::debrisMaxSeparationMin

"Debris chunks" (see debrisDepth, above) will be destroyed if they are separated from their origin by a distance greater than maxSeparation. The actual maxSeparation is interpolated between these two values, based upon the module's LOD setting. To disable maxSeparation, clear the DestructibleDepthParametersFlag::DEBRIS_MAX_SEPARATION flag in the flags field. If debrisMaxSeparationMax < debrisMaxSeparationMin, the mean of the two is used for both. Default debrisMaxSeparationMin = 1.0, debrisMaxSeparationMax = 10.0f.

DestructibleDepthParameters nvidia::apex::DestructibleParameters::depthParameters[kDepthParametersCountMax]

Parameters that apply to every chunk at a given depth level (see DestructibleDepthParameters). The element [0] of the array applies to the depth 0 (unfractured) chunk, element [1] applies to the level 1 chunks, etc. The number of valid depth parameters must be given in depthParametersCount.

uint32_t nvidia::apex::DestructibleParameters::depthParametersCount

The number of DestructibleDepthParameters (see depthParameters). Must be in the range [0, kDepthParametersCountMax].

uint8_t nvidia::apex::DestructibleParameters::dynamicChunksDominanceGroup

Optional dominance group for dynamic chunks created when fractured. (ignored if > 31)

physx::PxFilterData nvidia::apex::DestructibleParameters::dynamicChunksFilterData

Optional groups mask (2.x) or filter data (3.x) for dynamic chunks created when fractured. (Used if useDynamicChunksGroupsMask is true.)

uint32_t nvidia::apex::DestructibleParameters::essentialDepth

The chunk hierarchy depth up to which chunks will not be eliminated due to LOD considerations. These chunks are considered to be essential either for gameplay or visually. The minimum value is 0, meaning the level 0 chunk is always considered essential. Default value is 0.

uint32_t nvidia::apex::DestructibleParameters::flags

A collection of flags defined in DestructibleParametersFlag.

float nvidia::apex::DestructibleParameters::forceToDamage

If a chunk is at a depth which takes impact damage (see DestructibleDepthParameters), then when a chunk has a collision in the PxScene, it will take damage equal to forceToDamage mulitplied by the impact force. The default value is zero, which effectively disables impact damage.

float nvidia::apex::DestructibleParameters::fractureImpulseScale

Scale factor used to apply an impulse force along the normal of chunk when fractured. This is used in order to "push" the pieces out as they fracture.

int32_t nvidia::apex::DestructibleParameters::impactDamageDefaultDepth

The default depth to which chunks will take impact damage. This default may be overridden in the depth settings. Negative values imply no default impact damage. Default value = -1.

float nvidia::apex::DestructibleParameters::impactVelocityThreshold

Large impact force may be reported if rigid bodies are spawned inside one another. In this case the relative velocity of the two objects will be low. This variable allows the user to set a minimum velocity threshold for impacts to ensure that the objects are moving at a min velocity in order for the impact force to be considered. Default value is zero.

int8_t nvidia::apex::DestructibleParameters::legacyChunkBoundsTestSetting

Whether or not to use the old chunk bounds testing for damage, or use the module setting. A value of 0 forces the new method to be used. A positive value forces the old method to be used. Negative values cause the global (ModuleDestructible) setting to be used. Default = -1

int8_t nvidia::apex::DestructibleParameters::legacyDamageRadiusSpreadSetting

Whether or not to use the old damage spread method, or use the module setting. A value of 0 forces the new method to be used. A positive value forces the old method to be used. Negative values cause the global (ModuleDestructible) setting to be used. Default = -1

float nvidia::apex::DestructibleParameters::maxChunkSpeed

If greater than 0, the chunks' speeds will not be allowed to exceed maxChunkSpeed. Use 0 to disable this feature (this is the default).

uint32_t nvidia::apex::DestructibleParameters::minimumFractureDepth

The chunks will not be broken free below this depth.

DestructibleRTFractureParameters nvidia::apex::DestructibleParameters::rtFractureParameters

Parameters for RT Fracture.

float nvidia::apex::DestructibleParameters::supportStrength

The supportStrength is used for the stress solver. As this value is increased it takes more force to break apart the chunks under the effect of stress solver.

bool nvidia::apex::DestructibleParameters::useDynamicChunksGroupsMask

Whether or not to use dynamicChunksGroupsMask. If false, NULL will be passed into the DestructibleActor upon instantiation, through the DestructibleActorDesc.

PxBounds3 nvidia::apex::DestructibleParameters::validBounds

A bounding box around each DestructibleActor created, defining a range of validity for chunks that break free. These bounds are scaled and translated with the DestructibleActor's scale and position, but they are *not* rotated with the DestructibleActor.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleParameters
nvidia::apex::DestructibleParameters Member List
This is the complete list of members for nvidia::apex::DestructibleParameters, including all inherited members.
alwaysDrawScatterMesh | nvidia::apex::DestructibleParameters
damageCap | nvidia::apex::DestructibleParameters
damageDepthLimit | nvidia::apex::DestructibleParameters
debrisDepth | nvidia::apex::DestructibleParameters
debrisDestructionProbability | nvidia::apex::DestructibleParameters
debrisLifetimeMax | nvidia::apex::DestructibleParameters
debrisLifetimeMin | nvidia::apex::DestructibleParameters
debrisMaxSeparationMax | nvidia::apex::DestructibleParameters
debrisMaxSeparationMin | nvidia::apex::DestructibleParameters
depthParameters | nvidia::apex::DestructibleParameters
depthParametersCount | nvidia::apex::DestructibleParameters
DestructibleParameters() | nvidia::apex::DestructibleParameters
dynamicChunksDominanceGroup | nvidia::apex::DestructibleParameters
dynamicChunksFilterData | nvidia::apex::DestructibleParameters
essentialDepth | nvidia::apex::DestructibleParameters
flags | nvidia::apex::DestructibleParameters
forceToDamage | nvidia::apex::DestructibleParameters
fractureImpulseScale | nvidia::apex::DestructibleParameters
impactDamageDefaultDepth | nvidia::apex::DestructibleParameters
impactVelocityThreshold | nvidia::apex::DestructibleParameters
kDepthParametersCountMax enum value | nvidia::apex::DestructibleParameters
legacyChunkBoundsTestSetting | nvidia::apex::DestructibleParameters
legacyDamageRadiusSpreadSetting | nvidia::apex::DestructibleParameters
maxChunkSpeed | nvidia::apex::DestructibleParameters
minimumFractureDepth | nvidia::apex::DestructibleParameters
rtFractureParameters | nvidia::apex::DestructibleParameters
setToDefault() | nvidia::apex::DestructibleParameters
supportStrength | nvidia::apex::DestructibleParameters
useDynamicChunksGroupsMask | nvidia::apex::DestructibleParameters
validBounds | nvidia::apex::DestructibleParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleParametersFlag Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleParametersFlag
Public Types
nvidia::apex::DestructibleParametersFlag Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Types

enum Enum {
ACCUMULATE_DAMAGE = (1 << 0),
DEBRIS_TIMEOUT = (1 << 1),
DEBRIS_MAX_SEPARATION = (1 << 2),
CRUMBLE_SMALLEST_CHUNKS = (1 << 3),
ACCURATE_RAYCASTS = (1 << 4),
USE_VALID_BOUNDS = (1 << 5),
CRUMBLE_VIA_RUNTIME_FRACTURE = (1 << 6)
}

Detailed Description

Flags that apply to a destructible actor, settable at runtime

Member Enumeration Documentation

enum nvidia::apex::DestructibleParametersFlag::Enum

Enum of destructible parameters flag

Enumerator:
ACCUMULATE_DAMAGE

If set, chunks will "remember" damage applied to them, so that many applications of a damage amount below damageThreshold will eventually fracture the chunk. If not set, a single application of damage must exceed damageThreshold in order to fracture the chunk.

DEBRIS_TIMEOUT

Whether or not chunks at or deeper than the "debris" depth (see DestructibleParameters::debrisDepth) will time out. The lifetime is a value between DestructibleParameters::debrisLifetimeMin and DestructibleParameters::debrisLifetimeMax, based upon the destructible module's LOD setting.

DEBRIS_MAX_SEPARATION

Whether or not chunks at or deeper than the "debris" depth (see DestructibleParameters::debrisDepth) will be removed if they separate too far from their origins. The maxSeparation is a value between DestructibleParameters::debrisMaxSeparationMin and DestructibleParameters::debrisMaxSeparationMax, based upon the destructible module's LOD setting.

CRUMBLE_SMALLEST_CHUNKS

If set, the smallest chunks may be further broken down, either by fluid crumbles (if a crumble particle system is specified in the DestructibleActorDesc), or by simply removing the chunk if no crumble particle system is specified. Note: the "smallest chunks" are normally defined to be the deepest level of the fracture hierarchy. However, they may be taken from higher levels of the hierarchy if ModuleDestructible::setMaxChunkDepthOffset is called with a non-zero value.

ACCURATE_RAYCASTS

If set, the DestructibleActor::rayCast function will search within the nearest visible chunk hit for collisions with child chunks. This is used to get a better raycast position and normal, in case the parent collision volume does not tightly fit the graphics mesh. The returned chunk index will always be that of the visible parent that is intersected, however.

USE_VALID_BOUNDS

If set, the validBounds field of DestructibleParameters will be used. These bounds are translated (but not scaled or rotated) to the origin of the destructible actor. If a chunk or chunk island moves outside of those bounds, it is destroyed.

CRUMBLE_VIA_RUNTIME_FRACTURE

If set, chunk crumbling will be handled via the pattern-based runtime fracture pipeline. If no fracture pattern is specified in the DestructibleActorDesc, or no fracture pattern has been assigned to the destructible actor, chunks will simply be removed.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleParametersFlag
nvidia::apex::DestructibleParametersFlag Member List
This is the complete list of members for nvidia::apex::DestructibleParametersFlag, including all inherited members.
ACCUMULATE_DAMAGE enum value | nvidia::apex::DestructibleParametersFlag
ACCURATE_RAYCASTS enum value | nvidia::apex::DestructibleParametersFlag
CRUMBLE_SMALLEST_CHUNKS enum value | nvidia::apex::DestructibleParametersFlag
CRUMBLE_VIA_RUNTIME_FRACTURE enum value | nvidia::apex::DestructibleParametersFlag
DEBRIS_MAX_SEPARATION enum value | nvidia::apex::DestructibleParametersFlag
DEBRIS_TIMEOUT enum value | nvidia::apex::DestructibleParametersFlag
Enum enum name | nvidia::apex::DestructibleParametersFlag
USE_VALID_BOUNDS enum value | nvidia::apex::DestructibleParametersFlag
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructiblePhysXActorQueryFlags Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructiblePhysXActorQueryFlags
Public Types
nvidia::apex::DestructiblePhysXActorQueryFlags Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Types

enum Enum {
None = 0,
Static = (1 << 0),
Dynamic = (1 << 1),
Dormant = (1 << 2),
AllStates = Static | Dynamic | Dormant,
AllowRedundancy = (1 << 3),
AllowActorsNotInScenes = (1 << 4)
}

Detailed Description

Flags which control which actors are returned by DestructibleActor::acquirePhysXActorBuffer

Member Enumeration Documentation

enum nvidia::apex::DestructiblePhysXActorQueryFlags::Enum

Enum of destructible PhysX actor query flags

Enumerator:
None
Static
Dynamic

Destructible-static, which is a kinematic PhysX actor that hasn't been turned dynamic yet.

Dormant

Dynamic, not dormant (not kinematic)

AllStates

Dynamic, but dormant (had been made dynamic, but is now in a dormant, PhysX-kinematic state)

AllowRedundancy

Whether or not to ensure that PhysX actors are not listed more than once when this NxDestructibleActor is part of an extended structure. If this is true, then some NxDestructibleActors may not return all PhysX actors associated with all of their chunks (and in fact may return no PhysX actors), but after querying all NxDestructibleActors in a given structure, every PhysX actor will be accounted for.

AllowActorsNotInScenes

Whether or not to allow actors not yet put into the PxScene (e.g. there has not been a simulation step since the actor was created) are also returned.

The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructiblePhysXActorQueryFlags
nvidia::apex::DestructiblePhysXActorQueryFlags Member List
This is the complete list of members for nvidia::apex::DestructiblePhysXActorQueryFlags, including all inherited members.
AllowActorsNotInScenes enum value | nvidia::apex::DestructiblePhysXActorQueryFlags
AllowRedundancy enum value | nvidia::apex::DestructiblePhysXActorQueryFlags
AllStates enum value | nvidia::apex::DestructiblePhysXActorQueryFlags
Dormant enum value | nvidia::apex::DestructiblePhysXActorQueryFlags
Dynamic enum value | nvidia::apex::DestructiblePhysXActorQueryFlags
Enum enum name | nvidia::apex::DestructiblePhysXActorQueryFlags
None enum value | nvidia::apex::DestructiblePhysXActorQueryFlags
Static enum value | nvidia::apex::DestructiblePhysXActorQueryFlags
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleRTFractureParameters Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRTFractureParameters
Classes | Public Member Functions | Public Attributes
nvidia::apex::DestructibleRTFractureParameters Struct Reference

#include <DestructibleAsset.h>

List of all members.

Classes

struct | FractureAttachment
struct | FractureGlass

Public Member Functions

PX_INLINE void | setToDefault ()

Public Attributes

bool | sheetFracture
uint32_t | depthLimit
bool | destroyIfAtDepthLimit
float | minConvexSize
float | impulseScale
struct
nvidia::apex::DestructibleRTFractureParameters::FractureGlass 		glass
Instance of FractureGlass parameters.
struct
nvidia::apex::DestructibleRTFractureParameters::FractureAttachment 		attachment
Instance of FractureAttachment parameters.

Detailed Description

Parameters for RT Fracture

Member Function Documentation

PX_INLINE void nvidia::apex::DestructibleRTFractureParameters::setToDefault ( )

Set default fracture parameters

Member Data Documentation

struct nvidia::apex::DestructibleRTFractureParameters::FractureAttachment nvidia::apex::DestructibleRTFractureParameters::attachment

Instance of FractureAttachment parameters.

uint32_t nvidia::apex::DestructibleRTFractureParameters::depthLimit

Number of times deep a chunk can be fractured. Can help limit the number of chunks produced by runtime fracture.

bool nvidia::apex::DestructibleRTFractureParameters::destroyIfAtDepthLimit

If true, destroy chunks when they hit their depth limit. If false, then chunks at their depth limit will not fracture but will have a force applied.

struct nvidia::apex::DestructibleRTFractureParameters::FractureGlass nvidia::apex::DestructibleRTFractureParameters::glass

Instance of FractureGlass parameters.

float nvidia::apex::DestructibleRTFractureParameters::impulseScale

Scales impulse applied by a fracture.

float nvidia::apex::DestructibleRTFractureParameters::minConvexSize

Minimum Convex Size. Minimum size of convex produced by a fracture.

bool nvidia::apex::DestructibleRTFractureParameters::sheetFracture

If true, align fracture pattern to largest face. If false, the fracture pattern will be aligned to the hit normal with each fracture.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRTFractureParameters
nvidia::apex::DestructibleRTFractureParameters Member List
This is the complete list of members for nvidia::apex::DestructibleRTFractureParameters, including all inherited members.
attachment | nvidia::apex::DestructibleRTFractureParameters
depthLimit | nvidia::apex::DestructibleRTFractureParameters
destroyIfAtDepthLimit | nvidia::apex::DestructibleRTFractureParameters
glass | nvidia::apex::DestructibleRTFractureParameters
impulseScale | nvidia::apex::DestructibleRTFractureParameters
minConvexSize | nvidia::apex::DestructibleRTFractureParameters
setToDefault() | nvidia::apex::DestructibleRTFractureParameters
sheetFracture | nvidia::apex::DestructibleRTFractureParameters
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleRTFractureParameters::FractureAttachment Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRTFractureParameters
  • FractureAttachment
Public Attributes
nvidia::apex::DestructibleRTFractureParameters::FractureAttachment Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Attributes

bool | posX
bool | negX
bool | posY
bool | negY
bool | posZ
bool | negZ

Detailed Description

Fracture attachment

Member Data Documentation

bool nvidia::apex::DestructibleRTFractureParameters::FractureAttachment::negX

If true, make the negative x side of the sheet an attachment point.

bool nvidia::apex::DestructibleRTFractureParameters::FractureAttachment::negY

If true, make the negative y side of the sheet an attachment point.

bool nvidia::apex::DestructibleRTFractureParameters::FractureAttachment::negZ

If true, make the negative z side of the sheet an attachment point.

bool nvidia::apex::DestructibleRTFractureParameters::FractureAttachment::posX

If true, make the positive x side of the sheet an attachment point.

bool nvidia::apex::DestructibleRTFractureParameters::FractureAttachment::posY

If true, make the positive y side of the sheet an attachment point.

bool nvidia::apex::DestructibleRTFractureParameters::FractureAttachment::posZ

If true, make the positive z side of the sheet an attachment point.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRTFractureParameters
  • FractureAttachment
nvidia::apex::DestructibleRTFractureParameters::FractureAttachment Member List
This is the complete list of members for nvidia::apex::DestructibleRTFractureParameters::FractureAttachment, including all inherited members.
negX | nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
negY | nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
negZ | nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
posX | nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
posY | nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
posZ | nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::DestructibleRTFractureParameters::FractureGlass Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRTFractureParameters
  • FractureGlass
Public Attributes
nvidia::apex::DestructibleRTFractureParameters::FractureGlass Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Attributes

uint32_t | numSectors
float | sectorRand
float | firstSegmentSize
float | segmentScale
float | segmentRand

Detailed Description

Parameters for glass fracture

Member Data Documentation

float nvidia::apex::DestructibleRTFractureParameters::FractureGlass::firstSegmentSize

The minimum shard size. Shards below this size will not be created and thus not visible.

uint32_t nvidia::apex::DestructibleRTFractureParameters::FractureGlass::numSectors

Number of angular slices in the glass fracture pattern.

float nvidia::apex::DestructibleRTFractureParameters::FractureGlass::sectorRand

Creates variance in the angle of slices. A value of zero results in all angular slices having the same angle.

float nvidia::apex::DestructibleRTFractureParameters::FractureGlass::segmentRand

Creates variance in the radial size of shards. A value of zero results in a low noise circular pattern.

float nvidia::apex::DestructibleRTFractureParameters::FractureGlass::segmentScale

Scales the radial spacing in the glass fracture pattern. A larger value results in radially longer shards.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRTFractureParameters
  • FractureGlass
nvidia::apex::DestructibleRTFractureParameters::FractureGlass Member List
This is the complete list of members for nvidia::apex::DestructibleRTFractureParameters::FractureGlass, including all inherited members.
firstSegmentSize | nvidia::apex::DestructibleRTFractureParameters::FractureGlass
numSectors | nvidia::apex::DestructibleRTFractureParameters::FractureGlass
sectorRand | nvidia::apex::DestructibleRTFractureParameters::FractureGlass
segmentRand | nvidia::apex::DestructibleRTFractureParameters::FractureGlass
segmentScale | nvidia::apex::DestructibleRTFractureParameters::FractureGlass
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::ExplicitSubmeshData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitSubmeshData
Public Types | Public Member Functions | Public Attributes
nvidia::apex::ExplicitSubmeshData Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Types

enum | { MaterialNameBufferSize = 1024 }

Public Member Functions

bool | operator== (const ExplicitSubmeshData &data) const
bool | operator!= (const ExplicitSubmeshData &data) const

Public Attributes

char | mMaterialName [MaterialNameBufferSize]
ExplicitVertexFormat mVertexFormat

Detailed Description

ExplicitSubmeshData

This is used when authoring an RenderMeshAsset.

This is the per-submesh data: the material name, and vertex format.

Member Enumeration Documentation

anonymous enum

Enum for storing material name buffer size

Enumerator:
MaterialNameBufferSize

Member Function Documentation

bool nvidia::apex::ExplicitSubmeshData::operator!= ( const ExplicitSubmeshData & data ) const [inline]

Not equal operator for ExplicitSubmeshData

bool nvidia::apex::ExplicitSubmeshData::operator== ( const ExplicitSubmeshData & data ) const [inline]

Equal operator for ExplicitSubmeshData

Member Data Documentation

char nvidia::apex::ExplicitSubmeshData::mMaterialName[MaterialNameBufferSize]

Material name char buffer

ExplicitVertexFormat nvidia::apex::ExplicitSubmeshData::mVertexFormat

Explicit vertex format

See also:
ExplicitVertexFormat
The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitSubmeshData
nvidia::apex::ExplicitSubmeshData Member List
This is the complete list of members for nvidia::apex::ExplicitSubmeshData, including all inherited members.
MaterialNameBufferSize enum value | nvidia::apex::ExplicitSubmeshData |
mMaterialName | nvidia::apex::ExplicitSubmeshData |
mVertexFormat | nvidia::apex::ExplicitSubmeshData |
operator!=(const ExplicitSubmeshData &data) const | nvidia::apex::ExplicitSubmeshData | [inline]
operator==(const ExplicitSubmeshData &data) const | nvidia::apex::ExplicitSubmeshData | [inline]
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::ExplicitVertexFormat Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitVertexFormat
Public Member Functions | Public Attributes
nvidia::apex::ExplicitVertexFormat Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

ExplicitVertexFormat ()
void | clear ()
bool | operator== (const ExplicitVertexFormat &data) const
bool | operator!= (const ExplicitVertexFormat &data) const
void | copyToVertexFormat (VertexFormat *format) const

Public Attributes

uint32_t | mWinding
bool | mHasStaticPositions
bool | mHasStaticNormals
bool | mHasStaticTangents
bool | mHasStaticBinormals
bool | mHasStaticColors
bool | mHasStaticSeparateBoneBuffer
bool | mHasStaticDisplacements
bool | mHasDynamicPositions
bool | mHasDynamicNormals
bool | mHasDynamicTangents
bool | mHasDynamicBinormals
bool | mHasDynamicColors
bool | mHasDynamicSeparateBoneBuffer
bool | mHasDynamicDisplacements
uint32_t | mUVCount
uint32_t | mBonesPerVertex

Detailed Description

ExplicitVertexFormat

This is used when authoring an VertexBuffer, to define which data channels exist.

Constructor & Destructor Documentation

nvidia::apex::ExplicitVertexFormat::ExplicitVertexFormat ( ) [inline]

Constructor, calls clear() to set formats to default settings

Member Function Documentation

void nvidia::apex::ExplicitVertexFormat::clear ( ) [inline]

Set formats to default settings:

mWinding = RenderCullMode::CLOCKWISE; mHasStaticPositions = false; mHasStaticNormals = false; mHasStaticTangents = false; mHasStaticBinormals = false; mHasStaticColors = false; mHasStaticSeparateBoneBuffer = false; mHasStaticDisplacements = false; mHasDynamicPositions = false; mHasDynamicNormals = false; mHasDynamicTangents = false; mHasDynamicBinormals = false; mHasDynamicColors = false; mHasDynamicSeparateBoneBuffer = false; mHasDynamicDisplacements = false; mUVCount = 0; mBonesPerVertex = 0;

void nvidia::apex::ExplicitVertexFormat::copyToVertexFormat ( VertexFormat * format ) const [inline]

Creates a render-ready VertexFormat corresponding to this structure's member values.

bool nvidia::apex::ExplicitVertexFormat::operator!= ( const ExplicitVertexFormat & data ) const [inline]

Returns the logical complement of the == operator.

bool nvidia::apex::ExplicitVertexFormat::operator== ( const ExplicitVertexFormat & data ) const [inline]

Equality operator. All values are tested for equality except mBonesPerVertex.

Member Data Documentation

uint32_t nvidia::apex::ExplicitVertexFormat::mBonesPerVertex

How many bones may influence a vertex

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicBinormals

Whether or not the accompanying vertex data has defined dynamic vertex binormals.

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicColors

Whether or not the accompanying vertex data has defined dynamic vertex colors.

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicDisplacements

Whether or not the accompanying vertex data has defined dynamic displacement coordinates

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicNormals

Whether or not the accompanying vertex data has defined dynamic vertex normals.

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicPositions

Whether or not the accompanying vertex data has defined dynamic vertex positions.

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicSeparateBoneBuffer

Whether or not to create separate render resource for a dynamic bone index buffer.

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicTangents

Whether or not the accompanying vertex data has defined dynamic vertex tangents.

bool nvidia::apex::ExplicitVertexFormat::mHasStaticBinormals

Whether or not the accompanying vertex data has defined static vertex binormals.

bool nvidia::apex::ExplicitVertexFormat::mHasStaticColors

Whether or not the accompanying vertex data has defined static vertex colors.

bool nvidia::apex::ExplicitVertexFormat::mHasStaticDisplacements

Whether or not the accompanying vertex data has defined dynamic displacement coordinates

bool nvidia::apex::ExplicitVertexFormat::mHasStaticNormals

Whether or not the accompanying vertex data has defined static vertex normals.

bool nvidia::apex::ExplicitVertexFormat::mHasStaticPositions

Whether or not the accompanying vertex data has defined static vertex positions.

bool nvidia::apex::ExplicitVertexFormat::mHasStaticSeparateBoneBuffer

Whether or not to create separate render resource for a static bone index buffer.

bool nvidia::apex::ExplicitVertexFormat::mHasStaticTangents

Whether or not the accompanying vertex data has defined static vertex tangents.

uint32_t nvidia::apex::ExplicitVertexFormat::mUVCount

How many UV coordinate channels there are (per vertex)

uint32_t nvidia::apex::ExplicitVertexFormat::mWinding

This value defines which vertex winding orders will be rendered. See RenderCullMode.

The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitVertexFormat
nvidia::apex::ExplicitVertexFormat Member List
This is the complete list of members for nvidia::apex::ExplicitVertexFormat, including all inherited members.
clear() | nvidia::apex::ExplicitVertexFormat | [inline]
copyToVertexFormat(VertexFormat *format) const | nvidia::apex::ExplicitVertexFormat | [inline]
ExplicitVertexFormat() | nvidia::apex::ExplicitVertexFormat | [inline]
mBonesPerVertex | nvidia::apex::ExplicitVertexFormat |
mHasDynamicBinormals | nvidia::apex::ExplicitVertexFormat |
mHasDynamicColors | nvidia::apex::ExplicitVertexFormat |
mHasDynamicDisplacements | nvidia::apex::ExplicitVertexFormat |
mHasDynamicNormals | nvidia::apex::ExplicitVertexFormat |
mHasDynamicPositions | nvidia::apex::ExplicitVertexFormat |
mHasDynamicSeparateBoneBuffer | nvidia::apex::ExplicitVertexFormat |
mHasDynamicTangents | nvidia::apex::ExplicitVertexFormat |
mHasStaticBinormals | nvidia::apex::ExplicitVertexFormat |
mHasStaticColors | nvidia::apex::ExplicitVertexFormat |
mHasStaticDisplacements | nvidia::apex::ExplicitVertexFormat |
mHasStaticNormals | nvidia::apex::ExplicitVertexFormat |
mHasStaticPositions | nvidia::apex::ExplicitVertexFormat |
mHasStaticSeparateBoneBuffer | nvidia::apex::ExplicitVertexFormat |
mHasStaticTangents | nvidia::apex::ExplicitVertexFormat |
mUVCount | nvidia::apex::ExplicitVertexFormat |
mWinding | nvidia::apex::ExplicitVertexFormat |
operator!=(const ExplicitVertexFormat &data) const | nvidia::apex::ExplicitVertexFormat | [inline]
operator==(const ExplicitVertexFormat &data) const | nvidia::apex::ExplicitVertexFormat | [inline]
Generated on Sat Dec 1 2018 10:18:20


APEX Destructible Module: nvidia::apex::FractureEventHeader Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureEventHeader
Public Attributes
nvidia::apex::FractureEventHeader Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | userActorID
User actor ID.
uint32_t | fractureEventCount
Fracture event count.
FractureEventUnit * fractureEventBufferStart
Fracture event buffer start.
FractureEventHeader * next
Pointer to next FractureEventHeader structure.

Detailed Description

Fracture event header.

Member Data Documentation

FractureEventUnit* nvidia::apex::FractureEventHeader::fractureEventBufferStart

Fracture event buffer start.

uint32_t nvidia::apex::FractureEventHeader::fractureEventCount

Fracture event count.

FractureEventHeader* nvidia::apex::FractureEventHeader::next

Pointer to next FractureEventHeader structure.

uint32_t nvidia::apex::FractureEventHeader::userActorID

User actor ID.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureEventHeader
nvidia::apex::FractureEventHeader Member List
This is the complete list of members for nvidia::apex::FractureEventHeader, including all inherited members.
fractureEventBufferStart | nvidia::apex::FractureEventHeader
fractureEventCount | nvidia::apex::FractureEventHeader
next | nvidia::apex::FractureEventHeader
userActorID | nvidia::apex::FractureEventHeader
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::FractureEventUnit Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureEventUnit
Public Attributes
nvidia::apex::FractureEventUnit Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | chunkIndex
Chunk index.
uint32_t | fractureEventFlags
Fracture event flags.
PxVec3 | position
Position.
PxVec3 | direction
Direction.
PxVec3 | impulse
Impulse.

Detailed Description

Fracture event unit.

Member Data Documentation

uint32_t nvidia::apex::FractureEventUnit::chunkIndex

Chunk index.

PxVec3 nvidia::apex::FractureEventUnit::direction

Direction.

uint32_t nvidia::apex::FractureEventUnit::fractureEventFlags

Fracture event flags.

PxVec3 nvidia::apex::FractureEventUnit::impulse

Impulse.

PxVec3 nvidia::apex::FractureEventUnit::position

Position.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureEventUnit
nvidia::apex::FractureEventUnit Member List
This is the complete list of members for nvidia::apex::FractureEventUnit, including all inherited members.
chunkIndex | nvidia::apex::FractureEventUnit
direction | nvidia::apex::FractureEventUnit
fractureEventFlags | nvidia::apex::FractureEventUnit
impulse | nvidia::apex::FractureEventUnit
position | nvidia::apex::FractureEventUnit
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::FractureMaterialDesc Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureMaterialDesc
Public Member Functions | Public Attributes
nvidia::apex::FractureMaterialDesc Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

FractureMaterialDesc ()
void | setToDefault ()

Public Attributes

PxVec2 | uvScale
PxVec2 | uvOffset
PxVec3 | tangent
float | uAngle
uint32_t | interiorSubmeshIndex

Detailed Description

FractureMaterialDesc

Descriptor for materials applied to interior faces.

Constructor & Destructor Documentation

nvidia::apex::FractureMaterialDesc::FractureMaterialDesc ( ) [inline]

Constructor sets defaults

Member Function Documentation

void nvidia::apex::FractureMaterialDesc::setToDefault ( ) [inline]

Set default values: uvScale = PxVec2(1.0f); uvOffset = PxVec2(0.0f); tangent = PxVec3(0.0f); uAngle = 0.0f; interiorSubmeshIndex = 0;

Member Data Documentation

uint32_t nvidia::apex::FractureMaterialDesc::interiorSubmeshIndex

The submesh index to use for the newly-created triangles. If an invalid index is given, 0 will be used.

PxVec3 nvidia::apex::FractureMaterialDesc::tangent

World space vector specifying surface tangent direction. If this vector is (0.0f,0.0f,0.0f), then an arbitrary direction will be chosen. Default = (0.0f,0.0f,0.0f).

float nvidia::apex::FractureMaterialDesc::uAngle

Angle from tangent direction for the u coordinate axis. Default = 0.0f.

PxVec2 nvidia::apex::FractureMaterialDesc::uvOffset

A UV origin offset for interior materials. Default = (0.0f,0.0f).

PxVec2 nvidia::apex::FractureMaterialDesc::uvScale

The UV scale (geometric distance/unit texture distance) for interior materials. Default = (1.0f,1.0f).

The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureMaterialDesc
nvidia::apex::FractureMaterialDesc Member List
This is the complete list of members for nvidia::apex::FractureMaterialDesc, including all inherited members.
FractureMaterialDesc() | nvidia::apex::FractureMaterialDesc | [inline]
interiorSubmeshIndex | nvidia::apex::FractureMaterialDesc |
setToDefault() | nvidia::apex::FractureMaterialDesc | [inline]
tangent | nvidia::apex::FractureMaterialDesc |
uAngle | nvidia::apex::FractureMaterialDesc |
uvOffset | nvidia::apex::FractureMaterialDesc |
uvScale | nvidia::apex::FractureMaterialDesc |
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::FractureMethod Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureMethod
Public Types
nvidia::apex::FractureMethod Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Types

enum Enum {
Unknown,
Slice,
Cutout,
Voronoi,
FractureMethodCount
}

Detailed Description

Enumeration of current fracture methods. Used when an authored mesh needs to know how it was created, for example if we need to re-apply UV mapping information.

Member Enumeration Documentation

enum nvidia::apex::FractureMethod::Enum

Enum of fracture methods

Enumerator:
Unknown
Slice
Cutout
Voronoi
FractureMethodCount
The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureMethod
nvidia::apex::FractureMethod Member List
This is the complete list of members for nvidia::apex::FractureMethod, including all inherited members.
Cutout enum value | nvidia::apex::FractureMethod
Enum enum name | nvidia::apex::FractureMethod
FractureMethodCount enum value | nvidia::apex::FractureMethod
Slice enum value | nvidia::apex::FractureMethod
Unknown enum value | nvidia::apex::FractureMethod
Voronoi enum value | nvidia::apex::FractureMethod
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::ImpactDamageEventData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactDamageEventData
Public Attributes
nvidia::apex::ImpactDamageEventData Struct Reference

#include <ModuleDestructible.h>

Inheritance diagram for nvidia::apex::ImpactDamageEventData:
nvidia::apex::DamageEventCoreData

List of all members.

Public Attributes

nvidia::DestructibleActor * | destructible
The destructible hit by the impacting actor.
PxVec3 | direction
The position, in world space, from which the damage is applied.
physx::PxActor const * | impactDamageActor
Other PhysX actor that caused damage.

Detailed Description

Extended damage event data, used for impact damage reports

Member Data Documentation

nvidia::DestructibleActor* nvidia::apex::ImpactDamageEventData::destructible

The destructible hit by the impacting actor.

PxVec3 nvidia::apex::ImpactDamageEventData::direction

The position, in world space, from which the damage is applied.

physx::PxActor const* nvidia::apex::ImpactDamageEventData::impactDamageActor

Other PhysX actor that caused damage.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactDamageEventData
nvidia::apex::ImpactDamageEventData Member List
This is the complete list of members for nvidia::apex::ImpactDamageEventData, including all inherited members.
chunkIndexInAsset | nvidia::apex::DamageEventCoreData
damage | nvidia::apex::DamageEventCoreData
destructible | nvidia::apex::ImpactDamageEventData
direction | nvidia::apex::ImpactDamageEventData
impactDamageActor | nvidia::apex::ImpactDamageEventData
position | nvidia::apex::DamageEventCoreData
radius | nvidia::apex::DamageEventCoreData
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::MaterialFrame Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MaterialFrame
Public Member Functions | Public Attributes
nvidia::apex::MaterialFrame Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

MaterialFrame ()
void | buildCoordinateSystemFromMaterialDesc (const nvidia::FractureMaterialDesc &materialDesc, const PxPlane &plane)

Public Attributes

PxMat44 | mCoordinateSystem
Coordinate system.
PxPlane | mUVPlane
UV plane.
PxVec2 | mUVScale
UV scale.
PxVec2 | mUVOffset
UV offset.
uint32_t | mFractureMethod
Fracture method.
int32_t | mFractureIndex
Fracture index.
uint32_t | mSliceDepth
The depth being created when this split is done. mSliceDepth = 0 means "unknown".

Detailed Description

A reference frame for applying UV mapping to triangles. Also includes the fracturing method and an index which is used internally for such operations as re-applying UV mapping information.

Constructor & Destructor Documentation

nvidia::apex::MaterialFrame::MaterialFrame ( ) [inline]

Member Function Documentation

void nvidia::apex::MaterialFrame::buildCoordinateSystemFromMaterialDesc | ( | const nvidia::FractureMaterialDesc & | materialDesc,
 |  | const PxPlane & | plane
 | ) |  | [inline]

Builds coordinate system from material desc

Member Data Documentation

PxMat44 nvidia::apex::MaterialFrame::mCoordinateSystem

Coordinate system.

int32_t nvidia::apex::MaterialFrame::mFractureIndex

Fracture index.

uint32_t nvidia::apex::MaterialFrame::mFractureMethod

Fracture method.

uint32_t nvidia::apex::MaterialFrame::mSliceDepth

The depth being created when this split is done. mSliceDepth = 0 means "unknown".

PxVec2 nvidia::apex::MaterialFrame::mUVOffset

UV offset.

PxPlane nvidia::apex::MaterialFrame::mUVPlane

UV plane.

PxVec2 nvidia::apex::MaterialFrame::mUVScale

UV scale.

The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MaterialFrame
nvidia::apex::MaterialFrame Member List
This is the complete list of members for nvidia::apex::MaterialFrame, including all inherited members.
buildCoordinateSystemFromMaterialDesc(const nvidia::FractureMaterialDesc &materialDesc, const PxPlane &plane) | nvidia::apex::MaterialFrame | [inline]
MaterialFrame() | nvidia::apex::MaterialFrame | [inline]
mCoordinateSystem | nvidia::apex::MaterialFrame |
mFractureIndex | nvidia::apex::MaterialFrame |
mFractureMethod | nvidia::apex::MaterialFrame |
mSliceDepth | nvidia::apex::MaterialFrame |
mUVOffset | nvidia::apex::MaterialFrame |
mUVPlane | nvidia::apex::MaterialFrame |
mUVScale | nvidia::apex::MaterialFrame |
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: nvidia::apex::ModuleDestructibleConst Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleDestructibleConst
Public Types
nvidia::apex::ModuleDestructibleConst Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Types

enum Enum { INVALID_CHUNK_INDEX = -1 }

Detailed Description

Destructible module constants

Member Enumeration Documentation

enum nvidia::apex::ModuleDestructibleConst::Enum

Enum for invalid chunk index (-1)

Enumerator:
INVALID_CHUNK_INDEX

When a function returns a chunk index, or takes a chunk index as a parameter, this value indicates "no chunk."

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:21


APEX Destructible Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleDestructibleConst
nvidia::apex::ModuleDestructibleConst Member List
This is the complete list of members for nvidia::apex::ModuleDestructibleConst, including all inherited members.
Enum enum name | nvidia::apex::ModuleDestructibleConst
INVALID_CHUNK_INDEX enum value | nvidia::apex::ModuleDestructibleConst
Generated on Sat Dec 1 2018 10:18:21


APEX Emitter Module: Class List

  • Class List
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
nvidia::apex::EmitterGeomExplicit::EllipsoidParams | Ellipsoid parameters
nvidia::apex::EmitterActor | Apex emitter actor class. Emits particles within a given shape
nvidia::apex::EmitterAsset | APEX Emitter asset. Emits particles within some shape
nvidia::apex::EmitterAssetAuthoring | APEX Emitter Asset Authoring. Used to create APEX Emitter assets
nvidia::apex::EmitterGeom | Base class for all emitter shapes
nvidia::apex::EmitterGeomBox | Box shape for an emitter
nvidia::apex::EmitterGeomCylinder | Cylindrical shape for an emitter
nvidia::apex::EmitterGeomExplicit | Explicit geometry. Coordinates of each particle are given explicitly
nvidia::apex::EmitterGeomSphere | Spherical shape for an emitter
nvidia::apex::EmitterGeomSphereShell | Sphere shell shape for an emitter. It's a shape formed by the difference of two cocentered spheres
nvidia::apex::EmitterLodParamDesc | LOD parameters fro emitters
nvidia::apex::EmitterPreview |
nvidia::apex::EmitterType | Emitter type
nvidia::apex::EmitterActor::EmitterValidateCallback |
nvidia::apex::GroundEmitterActor | Ground Emitter actor. Uses raycasts against ground to spawn particles
nvidia::apex::GroundEmitterAsset | Ground emitter asset. Used to create Ground emitter actors with specific properties
nvidia::apex::GroundEmitterAssetAuthoring | Ground emitter authoring class. Used to create Ground emitter assets
nvidia::apex::GroundEmitterPreview | Ground emitter preview class. Use for preview rendering
nvidia::apex::ImpactEmitterActor | Impact emitter actor. Emits particles at impact places
nvidia::apex::ImpactEmitterAsset | Impact emitter asset class
nvidia::apex::ImpactEmitterAssetAuthoring | Impact emitter asset authoring. Used to create Impact Emitter assets
nvidia::apex::ImpactEmitterPreview | Impact emitter preview. Used for preview rendering of the emitter actors
nvidia::apex::MaterialLookupCallback | User calback interface used to map raycast hitpoints to material ID If an instance of this class is registered with a ground emitter actor, the actor will call requestMaterialLookups() in lieu of doing raycasts. The call will occur from within the scope of the ApexScene thread, so the callback must be thread safe
nvidia::apex::MaterialLookupCallback::MaterialRequest | Material request structure
nvidia::apex::ModuleEmitter | An APEX Module that provides generic Emitter classes
nvidia::apex::EmitterGeomExplicit::PointListData | Structure contains positions, velocities and user data for particles
nvidia::apex::EmitterGeomExplicit::PointParams | Point parameters
nvidia::apex::EmitterGeomExplicit::SphereParams | Sphere prameters
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Class Index

  • Class List
  • Class Hierarchy
  • Class Members
Class Index
E | G | I | M | P | S
E
EmitterGeomCylinder (nvidia::apex) EmitterActor::EmitterValidateCallback (nvidia::apex) ImpactEmitterActor (nvidia::apex) ModuleEmitter (nvidia::apex)
EmitterGeomExplicit::EllipsoidParams (nvidia::apex) EmitterGeomExplicit (nvidia::apex)
G
ImpactEmitterAsset (nvidia::apex)
P
EmitterActor (nvidia::apex) EmitterGeomSphere (nvidia::apex) GroundEmitterActor (nvidia::apex) ImpactEmitterAssetAuthoring (nvidia::apex) EmitterGeomExplicit::PointListData (nvidia::apex)
EmitterAsset (nvidia::apex) EmitterGeomSphereShell (nvidia::apex) GroundEmitterAsset (nvidia::apex) ImpactEmitterPreview (nvidia::apex) EmitterGeomExplicit::PointParams (nvidia::apex)
EmitterAssetAuthoring (nvidia::apex) EmitterLodParamDesc (nvidia::apex) GroundEmitterAssetAuthoring (nvidia::apex)
M
S
EmitterGeom (nvidia::apex) EmitterPreview (nvidia::apex) GroundEmitterPreview (nvidia::apex) MaterialLookupCallback (nvidia::apex) EmitterGeomExplicit::SphereParams (nvidia::apex)
EmitterGeomBox (nvidia::apex) EmitterType (nvidia::apex)
I
MaterialLookupCallback::MaterialRequest (nvidia::apex)
E | G | I | M | P | S
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterActor Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterActor
Classes | Public Member Functions | Protected Member Functions
nvidia::apex::EmitterActor Class Reference

Apex emitter actor class. Emits particles within a given shape. More...

#include <EmitterActor.h>

List of all members.

Classes

class | EmitterValidateCallback

Public Member Functions

virtual EmitterAsset * | getEmitterAsset () const =0
Returns the asset the instance has been created from.
virtual EmitterGeomExplicit * | isExplicitGeom ()=0
Returns the explicit geometry for THIS ACTOR only.
virtual PxMat44 | getGlobalPose () const =0
Gets the global pose.
virtual void | setCurrentPose (const PxTransform &pose)=0
Sets the curent pose of the emitter.
virtual void | setCurrentPosition (const PxVec3 &pos)=0
Sets the curent position of the emitter.
virtual void | setAttachActor (PxActor *)=0
PhysX SDK 3.X. Attaches the emitter to an actor.
virtual void | setAttachRelativePose (const PxTransform &pose)=0
sets the relative pose of the emitter in the space of the actor to which it is attached
virtual const PxActor * | getAttachActor () const =0
PhysX SDK 3.X. Retrieves the actor, to which the emitter is attached. NULL is returned for an unattached emitter.
virtual const PxMat44 | getAttachRelativePose () const =0
Retrieves the relative pose of the emitter in the space of the actor to which it is attached.
virtual float | getObjectRadius () const =0
Retrieves the particle radius.
virtual void | setOverlapTestCollisionGroups (uint32_t)=0
Sets collision groups used to reject particles that overlap the geometry.
virtual void | startEmit (bool persistent=true)=0
start emitting particles
virtual void | stopEmit ()=0
Stop emitting particles.
virtual bool | isEmitting () const =0
Returns true if the emitter is emitting particles.
virtual const EmitterLodParamDesc & | getLodParamDesc () const =0
Gets LOD settings.
virtual void | setLodParamDesc (const EmitterLodParamDesc &)=0
Sets LOD settings.
virtual void | setDensity (const float &)=0
Sets the range from which the density of particles within the volume is randomly chosen.
virtual void | setRate (const float &)=0
Sets the range from which the emission rate is randomly chosen.
virtual void | setVelocityLow (const PxVec3 &)=0
Sets the range from which the velocity of a particle is randomly chosen.
virtual void | setVelocityHigh (const PxVec3 &)=0
Sets the range from which the velocity of a particle is randomly chosen.
virtual void | setLifetimeLow (const float &)=0
Sets the range from which the lifetime of a particle is randomly chosen.
virtual void | setLifetimeHigh (const float &)=0
Sets the range from which the lifetime of a particle is randomly chosen.
virtual void | emitAssetParticles (bool enable)=0
Sets whether or not authored asset particles are emitted.
virtual bool | getEmitAssetParticles () const =0
Gets whether or not authored asset particles are emitted.
virtual void | setPreferredRenderVolume (RenderVolume *volume)=0
Emitted particles are injected to specified render volume on initial frame.
virtual void | getRate (float &) const =0
Gets the range from which the emission rate is randomly chosen.
virtual uint32_t | getSimParticlesCount () const =0
Returns the number of particles in simulation.
virtual uint32_t | getActiveParticleCount () const =0
Returns the number of particles still alive.
virtual void | setDensityGridPosition (const PxVec3 &pos)=0
Sets the origin of the density grid used by this emitter. Important, this density grid may be shared with lots of other emitters as well, it is based on the underlying IOS.
virtual void | setApexEmitterValidateCallback (EmitterValidateCallback *callback)=0
Sets the ApexEmitterPosition validation callback interface.
virtual PX_DEPRECATED void | setObjectScale (float scale)=0
Sets the uniform overall object scale.
virtual PX_DEPRECATED float | getObjectScale (void) const =0
Retrieves the uniform overall object scale.
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.

Protected Member Functions

virtual | ~EmitterActor ()

Detailed Description

Apex emitter actor class. Emits particles within a given shape.

Constructor & Destructor Documentation

virtual nvidia::apex::EmitterActor::~EmitterActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual void nvidia::apex::EmitterActor::emitAssetParticles ( bool enable ) [pure virtual]

Sets whether or not authored asset particles are emitted.

virtual uint32_t nvidia::apex::EmitterActor::getActiveParticleCount ( ) const [pure virtual]

Returns the number of particles still alive.

virtual const PxActor* nvidia::apex::EmitterActor::getAttachActor ( ) const [pure virtual]

PhysX SDK 3.X. Retrieves the actor, to which the emitter is attached. NULL is returned for an unattached emitter.

virtual const PxMat44 nvidia::apex::EmitterActor::getAttachRelativePose ( ) const [pure virtual]

Retrieves the relative pose of the emitter in the space of the actor to which it is attached.

virtual float nvidia::apex::EmitterActor::getCurrentScale ( void ) const [pure virtual]

Retrieves the uniform overall object scale.

virtual bool nvidia::apex::EmitterActor::getEmitAssetParticles ( ) const [pure virtual]

Gets whether or not authored asset particles are emitted.

virtual EmitterAsset* nvidia::apex::EmitterActor::getEmitterAsset ( ) const [pure virtual]

Returns the asset the instance has been created from.

virtual PxMat44 nvidia::apex::EmitterActor::getGlobalPose ( ) const [pure virtual]

Gets the global pose.

virtual const EmitterLodParamDesc& nvidia::apex::EmitterActor::getLodParamDesc ( ) const [pure virtual]

Gets LOD settings.

virtual float nvidia::apex::EmitterActor::getObjectRadius ( ) const [pure virtual]

Retrieves the particle radius.

virtual PX_DEPRECATED float nvidia::apex::EmitterActor::getObjectScale ( void ) const [pure virtual]

Retrieves the uniform overall object scale.

virtual void nvidia::apex::EmitterActor::getRate ( float & ) const [pure virtual]

Gets the range from which the emission rate is randomly chosen.

virtual uint32_t nvidia::apex::EmitterActor::getSimParticlesCount ( ) const [pure virtual]

Returns the number of particles in simulation.

virtual bool nvidia::apex::EmitterActor::isEmitting ( ) const [pure virtual]

Returns true if the emitter is emitting particles.

virtual EmitterGeomExplicit* nvidia::apex::EmitterActor::isExplicitGeom ( ) [pure virtual]

Returns the explicit geometry for THIS ACTOR only.

virtual void nvidia::apex::EmitterActor::setApexEmitterValidateCallback ( EmitterValidateCallback * callback ) [pure virtual]

Sets the ApexEmitterPosition validation callback interface.

virtual void nvidia::apex::EmitterActor::setAttachActor ( PxActor * ) [pure virtual]

PhysX SDK 3.X. Attaches the emitter to an actor.

PxActor pointer can be NULL to detach existing actor

virtual void nvidia::apex::EmitterActor::setAttachRelativePose ( const PxTransform & pose ) [pure virtual]

sets the relative pose of the emitter in the space of the actor to which it is attached

virtual void nvidia::apex::EmitterActor::setCurrentPose ( const PxTransform & pose ) [pure virtual]

Sets the curent pose of the emitter.

virtual void nvidia::apex::EmitterActor::setCurrentPosition ( const PxVec3 & pos ) [pure virtual]

Sets the curent position of the emitter.

virtual void nvidia::apex::EmitterActor::setCurrentScale ( float scale ) [pure virtual]

Sets the uniform overall object scale.

virtual void nvidia::apex::EmitterActor::setDensity ( const float & ) [pure virtual]

Sets the range from which the density of particles within the volume is randomly chosen.

Override authored scalable parameters, if necessary

virtual void nvidia::apex::EmitterActor::setDensityGridPosition ( const PxVec3 & pos ) [pure virtual]

Sets the origin of the density grid used by this emitter. Important, this density grid may be shared with lots of other emitters as well, it is based on the underlying IOS.

virtual void nvidia::apex::EmitterActor::setLifetimeHigh ( const float & ) [pure virtual]

Sets the range from which the lifetime of a particle is randomly chosen.

virtual void nvidia::apex::EmitterActor::setLifetimeLow ( const float & ) [pure virtual]

Sets the range from which the lifetime of a particle is randomly chosen.

virtual void nvidia::apex::EmitterActor::setLodParamDesc ( const EmitterLodParamDesc & ) [pure virtual]

Sets LOD settings.

virtual PX_DEPRECATED void nvidia::apex::EmitterActor::setObjectScale ( float scale ) [pure virtual]

Sets the uniform overall object scale.

virtual void nvidia::apex::EmitterActor::setOverlapTestCollisionGroups ( uint32_t ) [pure virtual]

Sets collision groups used to reject particles that overlap the geometry.

virtual void nvidia::apex::EmitterActor::setPreferredRenderVolume ( RenderVolume * volume ) [pure virtual]

Emitted particles are injected to specified render volume on initial frame.

This will work only if you have one renderVolume for each emitter. Set to NULL to clear the preferred volume.

virtual void nvidia::apex::EmitterActor::setRate ( const float & ) [pure virtual]

Sets the range from which the emission rate is randomly chosen.

virtual void nvidia::apex::EmitterActor::setVelocityHigh ( const PxVec3 & ) [pure virtual]

Sets the range from which the velocity of a particle is randomly chosen.

virtual void nvidia::apex::EmitterActor::setVelocityLow ( const PxVec3 & ) [pure virtual]

Sets the range from which the velocity of a particle is randomly chosen.

virtual void nvidia::apex::EmitterActor::startEmit ( bool persistent = true ) [pure virtual]

start emitting particles

If persistent is true, the emitter will emit every frame until stopEmit() is called.

virtual void nvidia::apex::EmitterActor::stopEmit ( ) [pure virtual]

Stop emitting particles.

The documentation for this class was generated from the following file:
  • EmitterActor.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterActor
nvidia::apex::EmitterActor Member List
This is the complete list of members for nvidia::apex::EmitterActor, including all inherited members.
emitAssetParticles(bool enable)=0 | nvidia::apex::EmitterActor | [pure virtual]
getActiveParticleCount() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getAttachActor() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getAttachRelativePose() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::EmitterActor | [pure virtual]
getEmitAssetParticles() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getEmitterAsset() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getGlobalPose() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getLodParamDesc() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getObjectRadius() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getObjectScale(void) const =0 | nvidia::apex::EmitterActor | [pure virtual]
getRate(float &) const =0 | nvidia::apex::EmitterActor | [pure virtual]
getSimParticlesCount() const =0 | nvidia::apex::EmitterActor | [pure virtual]
isEmitting() const =0 | nvidia::apex::EmitterActor | [pure virtual]
isExplicitGeom()=0 | nvidia::apex::EmitterActor | [pure virtual]
setApexEmitterValidateCallback(EmitterValidateCallback *callback)=0 | nvidia::apex::EmitterActor | [pure virtual]
setAttachActor(PxActor *)=0 | nvidia::apex::EmitterActor | [pure virtual]
setAttachRelativePose(const PxTransform &pose)=0 | nvidia::apex::EmitterActor | [pure virtual]
setCurrentPose(const PxTransform &pose)=0 | nvidia::apex::EmitterActor | [pure virtual]
setCurrentPosition(const PxVec3 &pos)=0 | nvidia::apex::EmitterActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::EmitterActor | [pure virtual]
setDensity(const float &)=0 | nvidia::apex::EmitterActor | [pure virtual]
setDensityGridPosition(const PxVec3 &pos)=0 | nvidia::apex::EmitterActor | [pure virtual]
setLifetimeHigh(const float &)=0 | nvidia::apex::EmitterActor | [pure virtual]
setLifetimeLow(const float &)=0 | nvidia::apex::EmitterActor | [pure virtual]
setLodParamDesc(const EmitterLodParamDesc &)=0 | nvidia::apex::EmitterActor | [pure virtual]
setObjectScale(float scale)=0 | nvidia::apex::EmitterActor | [pure virtual]
setOverlapTestCollisionGroups(uint32_t)=0 | nvidia::apex::EmitterActor | [pure virtual]
setPreferredRenderVolume(RenderVolume *volume)=0 | nvidia::apex::EmitterActor | [pure virtual]
setRate(const float &)=0 | nvidia::apex::EmitterActor | [pure virtual]
setVelocityHigh(const PxVec3 &)=0 | nvidia::apex::EmitterActor | [pure virtual]
setVelocityLow(const PxVec3 &)=0 | nvidia::apex::EmitterActor | [pure virtual]
startEmit(bool persistent=true)=0 | nvidia::apex::EmitterActor | [pure virtual]
stopEmit()=0 | nvidia::apex::EmitterActor | [pure virtual]
~EmitterActor() | nvidia::apex::EmitterActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterActor::EmitterValidateCallback Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterActor
  • EmitterValidateCallback
Public Member Functions
nvidia::apex::EmitterActor::EmitterValidateCallback Class Reference

#include <EmitterActor.h>

List of all members.

Public Member Functions

virtual bool validateEmitterPosition (const PxVec3 &emitterOrigin, PxVec3 &position)=0
This application callback is used to verify an emitted particle position.

Detailed Description

This is an optional user validation callback interface. If the application wants to confirm/verify all emitted particles they can provide this callback interface by using the setApexEmitterValidateCallback method.

Member Function Documentation

virtual bool nvidia::apex::EmitterActor::EmitterValidateCallback::validateEmitterPosition | ( | const PxVec3 & | emitterOrigin,
 |  | PxVec3 & | position
 | ) |  | [pure virtual]

This application callback is used to verify an emitted particle position.

If the user returns false, then the particle will not be emitted. If the user returns true if will be emitted but using the position value which is passed by reference. The application can choose to leave the emitter position alone, or modify it to a new location. All locations are in world space. For convenience to the application the world space emitter position is provided.

The documentation for this class was generated from the following file:
  • EmitterActor.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterActor
  • EmitterValidateCallback
nvidia::apex::EmitterActor::EmitterValidateCallback Member List
This is the complete list of members for nvidia::apex::EmitterActor::EmitterValidateCallback, including all inherited members.
validateEmitterPosition(const PxVec3 &emitterOrigin, PxVec3 &position)=0 nvidia::apex::EmitterActor::EmitterValidateCallback [pure virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterAsset Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterAsset
Public Member Functions | Protected Member Functions
nvidia::apex::EmitterAsset Class Reference

APEX Emitter asset. Emits particles within some shape. More...

#include <EmitterAsset.h>

List of all members.

Public Member Functions

virtual EmitterGeomExplicit * | isExplicitGeom ()=0
Returns the explicit geometry for the all actors based on this asset if the asset is explicit, NULL otherwise.
virtual const EmitterGeom * | getGeom () const =0
Returns the geometry used for the all actors based on this asset.
virtual const char * | getInstancedObjectEffectsAssetName (void) const =0
Gets IOFX asset name that is used to visualize partices of this emitter.
virtual const char * | getInstancedObjectSimulatorAssetName (void) const =0
Gets IOS asset name that is used to simulate partices of this emitter.
virtual const char * | getInstancedObjectSimulatorTypeName (void) const =0
Gets IOS asset class name that is used to simulate partices of this emitter.
virtual const float & | getDensity () const =0
Gets the range used to choose the density of particles.
virtual const float & | getRate () const =0
Gets the range used to choose the emission rate.
virtual const PxVec3 & | getVelocityLow () const =0
Gets the range used to choose the velocity of particles.
virtual const PxVec3 & | getVelocityHigh () const =0
Gets the range used to choose the velocity of particles.
virtual const float & | getLifetimeLow () const =0
Gets the range used to choose the lifetime of particles.
virtual const float & | getLifetimeHigh () const =0
Gets the range used to choose the lifetime of particles.
virtual uint32_t | getMaxSamples () const =0
For an explicit emitter, Max Samples is ignored. For shaped emitters, it is the maximum number of objects spawned in a step.
virtual float | getEmitDuration () const =0
Gets the emitter duration in seconds.
virtual const EmitterLodParamDesc & | getLodParamDesc () const =0
Gets LOD settings for this asset.

Protected Member Functions

virtual | ~EmitterAsset ()

Detailed Description

APEX Emitter asset. Emits particles within some shape.

Constructor & Destructor Documentation

virtual nvidia::apex::EmitterAsset::~EmitterAsset ( ) [inline, protected, virtual]

Member Function Documentation

virtual const float& nvidia::apex::EmitterAsset::getDensity ( ) const [pure virtual]

Gets the range used to choose the density of particles.

virtual float nvidia::apex::EmitterAsset::getEmitDuration ( ) const [pure virtual]

Gets the emitter duration in seconds.

Note:
If EmitterActor::startEmit() is called with persistent=true, then this duration is ignored.
virtual const EmitterGeom* nvidia::apex::EmitterAsset::getGeom ( ) const [pure virtual]

Returns the geometry used for the all actors based on this asset.

virtual const char* nvidia::apex::EmitterAsset::getInstancedObjectEffectsAssetName ( void ) const [pure virtual]

Gets IOFX asset name that is used to visualize partices of this emitter.

virtual const char* nvidia::apex::EmitterAsset::getInstancedObjectSimulatorAssetName ( void ) const [pure virtual]

Gets IOS asset name that is used to simulate partices of this emitter.

virtual const char* nvidia::apex::EmitterAsset::getInstancedObjectSimulatorTypeName ( void ) const [pure virtual]

Gets IOS asset class name that is used to simulate partices of this emitter.

virtual const float& nvidia::apex::EmitterAsset::getLifetimeHigh ( ) const [pure virtual]

Gets the range used to choose the lifetime of particles.

virtual const float& nvidia::apex::EmitterAsset::getLifetimeLow ( ) const [pure virtual]

Gets the range used to choose the lifetime of particles.

virtual const EmitterLodParamDesc& nvidia::apex::EmitterAsset::getLodParamDesc ( ) const [pure virtual]

Gets LOD settings for this asset.

virtual uint32_t nvidia::apex::EmitterAsset::getMaxSamples ( ) const [pure virtual]

For an explicit emitter, Max Samples is ignored. For shaped emitters, it is the maximum number of objects spawned in a step.

virtual const float& nvidia::apex::EmitterAsset::getRate ( ) const [pure virtual]

Gets the range used to choose the emission rate.

virtual const PxVec3& nvidia::apex::EmitterAsset::getVelocityHigh ( ) const [pure virtual]

Gets the range used to choose the velocity of particles.

virtual const PxVec3& nvidia::apex::EmitterAsset::getVelocityLow ( ) const [pure virtual]

Gets the range used to choose the velocity of particles.

virtual EmitterGeomExplicit* nvidia::apex::EmitterAsset::isExplicitGeom ( ) [pure virtual]

Returns the explicit geometry for the all actors based on this asset if the asset is explicit, NULL otherwise.

The documentation for this class was generated from the following file:
  • EmitterAsset.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterAsset
nvidia::apex::EmitterAsset Member List
This is the complete list of members for nvidia::apex::EmitterAsset, including all inherited members.
getDensity() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getEmitDuration() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getGeom() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getInstancedObjectEffectsAssetName(void) const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getInstancedObjectSimulatorAssetName(void) const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getInstancedObjectSimulatorTypeName(void) const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getLifetimeHigh() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getLifetimeLow() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getLodParamDesc() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getMaxSamples() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getRate() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getVelocityHigh() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getVelocityLow() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
isExplicitGeom()=0 | nvidia::apex::EmitterAsset | [pure virtual]
~EmitterAsset() | nvidia::apex::EmitterAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterAssetAuthoring Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterAssetAuthoring
Protected Member Functions
nvidia::apex::EmitterAssetAuthoring Class Reference

APEX Emitter Asset Authoring. Used to create APEX Emitter assets. More...

#include <EmitterAsset.h>

List of all members.

Protected Member Functions

virtual ~EmitterAssetAuthoring ()

Detailed Description

APEX Emitter Asset Authoring. Used to create APEX Emitter assets.

Constructor & Destructor Documentation

virtual nvidia::apex::EmitterAssetAuthoring::~EmitterAssetAuthoring ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • EmitterAsset.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterAssetAuthoring
nvidia::apex::EmitterAssetAuthoring Member List
This is the complete list of members for nvidia::apex::EmitterAssetAuthoring, including all inherited members.
~EmitterAssetAuthoring() nvidia::apex::EmitterAssetAuthoring [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterGeom Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeom
Public Member Functions
nvidia::apex::EmitterGeom Class Reference

Base class for all emitter shapes. More...

#include <EmitterGeoms.h>

Inheritance diagram for nvidia::apex::EmitterGeom:
nvidia::apex::EmitterGeomBox nvidia::apex::EmitterGeomCylinder nvidia::apex::EmitterGeomExplicit nvidia::apex::EmitterGeomSphere nvidia::apex::EmitterGeomSphereShell

List of all members.

Public Member Functions

virtual void | setEmitterType (EmitterType::Enum)=0
Sets the type of the emitter.
virtual EmitterType::Enum | getEmitterType () const =0
Gets the type of the emitter.
virtual const EmitterGeomBox * | isBoxGeom () const
If it is a box, cast to box class, return NULL otherwise.
virtual const EmitterGeomSphere * | isSphereGeom () const
If it is a sphere, cast to sphere class, return NULL otherwise.
virtual const
EmitterGeomSphereShell * 		isSphereShellGeom () const
If it is a sphere shell, cast to sphere shell class, return NULL otherwise.
virtual const EmitterGeomCylinder * | isCylinderGeom () const
If it is a cylinder shell, cast to cylinder class, return NULL otherwise.
virtual const EmitterGeomExplicit * | isExplicitGeom () const
If it is an explicit geom, cast to explicit geom class, return NULL otherwise.

Detailed Description

Base class for all emitter shapes.

Member Function Documentation

virtual EmitterType::Enum nvidia::apex::EmitterGeom::getEmitterType ( ) const [pure virtual]

Gets the type of the emitter.

virtual const EmitterGeomBox* nvidia::apex::EmitterGeom::isBoxGeom ( ) const [inline, virtual]

If it is a box, cast to box class, return NULL otherwise.

virtual const EmitterGeomCylinder* nvidia::apex::EmitterGeom::isCylinderGeom ( ) const [inline, virtual]

If it is a cylinder shell, cast to cylinder class, return NULL otherwise.

virtual const EmitterGeomExplicit* nvidia::apex::EmitterGeom::isExplicitGeom ( ) const [inline, virtual]

If it is an explicit geom, cast to explicit geom class, return NULL otherwise.

virtual const EmitterGeomSphere* nvidia::apex::EmitterGeom::isSphereGeom ( ) const [inline, virtual]

If it is a sphere, cast to sphere class, return NULL otherwise.

virtual const EmitterGeomSphereShell* nvidia::apex::EmitterGeom::isSphereShellGeom ( ) const [inline, virtual]

If it is a sphere shell, cast to sphere shell class, return NULL otherwise.

virtual void nvidia::apex::EmitterGeom::setEmitterType ( EmitterType::Enum ) [pure virtual]

Sets the type of the emitter.

The documentation for this class was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeom
nvidia::apex::EmitterGeom Member List
This is the complete list of members for nvidia::apex::EmitterGeom, including all inherited members.
getEmitterType() const =0 | nvidia::apex::EmitterGeom | [pure virtual]
isBoxGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isCylinderGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isExplicitGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereShellGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
setEmitterType(EmitterType::Enum)=0 | nvidia::apex::EmitterGeom | [pure virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterGeomBox Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomBox
Public Member Functions
nvidia::apex::EmitterGeomBox Class Reference

Box shape for an emitter. More...

#include <EmitterGeoms.h>

Inheritance diagram for nvidia::apex::EmitterGeomBox:
nvidia::apex::EmitterGeom

List of all members.

Public Member Functions

virtual void | setExtents (const PxVec3 &extents)=0
Set box extents.
virtual PxVec3 | getExtents () const =0
Get box extents.

Detailed Description

Box shape for an emitter.

Member Function Documentation

virtual PxVec3 nvidia::apex::EmitterGeomBox::getExtents ( ) const [pure virtual]

Get box extents.

virtual void nvidia::apex::EmitterGeomBox::setExtents ( const PxVec3 & extents ) [pure virtual]

Set box extents.

The documentation for this class was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomBox
nvidia::apex::EmitterGeomBox Member List
This is the complete list of members for nvidia::apex::EmitterGeomBox, including all inherited members.
getEmitterType() const =0 | nvidia::apex::EmitterGeom | [pure virtual]
getExtents() const =0 | nvidia::apex::EmitterGeomBox | [pure virtual]
isBoxGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isCylinderGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isExplicitGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereShellGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
setEmitterType(EmitterType::Enum)=0 | nvidia::apex::EmitterGeom | [pure virtual]
setExtents(const PxVec3 &extents)=0 | nvidia::apex::EmitterGeomBox | [pure virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterGeomCylinder Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomCylinder
Public Member Functions
nvidia::apex::EmitterGeomCylinder Class Reference

Cylindrical shape for an emitter. More...

#include <EmitterGeoms.h>

Inheritance diagram for nvidia::apex::EmitterGeomCylinder:
nvidia::apex::EmitterGeom

List of all members.

Public Member Functions

virtual void | setRadius (float radius)=0
Set cylinder radius.
virtual float | getRadius () const =0
Get cylinder radius.
virtual void | setHeight (float height)=0
Set cylinder height.
virtual float | getHeight () const =0
Get cylinder height.

Detailed Description

Cylindrical shape for an emitter.

Member Function Documentation

virtual float nvidia::apex::EmitterGeomCylinder::getHeight ( ) const [pure virtual]

Get cylinder height.

virtual float nvidia::apex::EmitterGeomCylinder::getRadius ( ) const [pure virtual]

Get cylinder radius.

virtual void nvidia::apex::EmitterGeomCylinder::setHeight ( float height ) [pure virtual]

Set cylinder height.

virtual void nvidia::apex::EmitterGeomCylinder::setRadius ( float radius ) [pure virtual]

Set cylinder radius.

The documentation for this class was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomCylinder
nvidia::apex::EmitterGeomCylinder Member List
This is the complete list of members for nvidia::apex::EmitterGeomCylinder, including all inherited members.
getEmitterType() const =0 | nvidia::apex::EmitterGeom | [pure virtual]
getHeight() const =0 | nvidia::apex::EmitterGeomCylinder | [pure virtual]
getRadius() const =0 | nvidia::apex::EmitterGeomCylinder | [pure virtual]
isBoxGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isCylinderGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isExplicitGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereShellGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
setEmitterType(EmitterType::Enum)=0 | nvidia::apex::EmitterGeom | [pure virtual]
setHeight(float height)=0 | nvidia::apex::EmitterGeomCylinder | [pure virtual]
setRadius(float radius)=0 | nvidia::apex::EmitterGeomCylinder | [pure virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterGeomExplicit Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
Classes | Public Member Functions
nvidia::apex::EmitterGeomExplicit Class Reference

Explicit geometry. Coordinates of each particle are given explicitly. More...

#include <EmitterGeoms.h>

Inheritance diagram for nvidia::apex::EmitterGeomExplicit:
nvidia::apex::EmitterGeom

List of all members.

Classes

struct | EllipsoidParams
Ellipsoid parameters. More...
struct | PointListData
Structure contains positions, velocities and user data for particles. More...
struct | PointParams
Point parameters. More...
struct | SphereParams
Sphere prameters. More...

Public Member Functions

virtual void | resetParticleList ()=0
Remove all shapes.
virtual void | addParticleList (uint32_t count, const PointParams *params, const PxVec3 *velocities=0)=0
Add particles to geometry to be emitted.
virtual void | addParticleList (uint32_t count, const PxVec3 *positions, const PxVec3 *velocities=0)=0
Add particles to geometry to be emitted.
virtual void | addParticleList (uint32_t count, const PointListData &data)=0
Add particles to geometry to be emitted.
virtual void | addSphereList (uint32_t count, const SphereParams *params, const PxVec3 *velocities=0)=0
Add spheres to geometry to be emitted.
virtual void | addEllipsoidList (uint32_t count, const EllipsoidParams *params, const PxVec3 *velocities=0)=0
Add ellipsoids to geometry to be emitted.
virtual void | getParticleList (const PointParams *&params, uint32_t &numPoints, const PxVec3 *&velocities, uint32_t &numVelocities) const =0
Access particles list.
virtual void | getSphereList (const SphereParams *&params, uint32_t &numSpheres, const PxVec3 *&velocities, uint32_t &numVelocities) const =0
Access spheres list.
virtual void | getEllipsoidList (const EllipsoidParams *&params, uint32_t &numEllipsoids, const PxVec3 *&velocities, uint32_t &numVelocities) const =0
Access ellipsoids list.
virtual uint32_t | getParticleCount () const =0
Get the number of points.
virtual PxVec3 | getParticlePos (uint32_t index) const =0
Get the position of point.
virtual uint32_t | getSphereCount () const =0
Get the number of spheres.
virtual PxVec3 | getSphereCenter (uint32_t index) const =0
Get the center of the sphere.
virtual float | getSphereRadius (uint32_t index) const =0
Get the radius of the sphere.
virtual uint32_t | getEllipsoidCount () const =0
Get the number of ellipsoids.
virtual PxVec3 | getEllipsoidCenter (uint32_t index) const =0
Get the center of the ellipsoid.
virtual float | getEllipsoidRadius (uint32_t index) const =0
Get the radius of the ellipsoid.
virtual PxVec3 | getEllipsoidNormal (uint32_t index) const =0
Get the normal of the ellipsoid.
virtual float | getEllipsoidPolarRadius (uint32_t index) const =0
Get the polar radius of the ellipsoid.
virtual float | getDistance () const =0
Get average distance between particles.

Detailed Description

Explicit geometry. Coordinates of each particle are given explicitly.

Member Function Documentation

virtual void nvidia::apex::EmitterGeomExplicit::addEllipsoidList | ( | uint32_t | count,
 |  | const EllipsoidParams * | params,
 |  | const PxVec3 * | velocities = 0
 | ) |  | [pure virtual]

Add ellipsoids to geometry to be emitted.

Parameters:
[in] | count | - number of ellipsoids being added by this call
[in] | params | - ellipsoids parameters
[in] | velocities | if NULL, the geometry's velocity list will be padded with zero velocities and the asset's velocityRange will be used for velocity
See also:
EmitterGeomExplicit::EellipsoidParams
virtual void nvidia::apex::EmitterGeomExplicit::addParticleList | ( | uint32_t | count,
 |  | const PointListData & | data
 | ) |  | [pure virtual]

Add particles to geometry to be emitted.

Parameters:
[in] | count | - number of particles being added by this call
[in] | data | - particles data
See also:
EmitterGeomExplicit::PointListData
virtual void nvidia::apex::EmitterGeomExplicit::addParticleList | ( | uint32_t | count,
 |  | const PointParams * | params,
 |  | const PxVec3 * | velocities = 0
 | ) |  | [pure virtual]

Add particles to geometry to be emitted.

Parameters:
[in] | count | - number of particles being added by this call
[in] | params | must be specified. When emitted, these relative positions are added to emitter actor position
[in] | velocities | if NULL, the geometry's velocity list will be padded with zero velocities and the asset's velocityRange will be used for velocity
virtual void nvidia::apex::EmitterGeomExplicit::addParticleList | ( | uint32_t | count,
 |  | const PxVec3 * | positions,
 |  | const PxVec3 * | velocities = 0
 | ) |  | [pure virtual]

Add particles to geometry to be emitted.

Parameters:
[in] | count | - number of particles being added by this call
[in] | positions | must be specified. When emitted, these relative positions are added to emitter actor position
[in] | velocities | if NULL, the geometry's velocity list will be padded with zero velocities and the asset's velocityRange will be used for velocity
virtual void nvidia::apex::EmitterGeomExplicit::addSphereList | ( | uint32_t | count,
 |  | const SphereParams * | params,
 |  | const PxVec3 * | velocities = 0
 | ) |  | [pure virtual]

Add spheres to geometry to be emitted.

Parameters:
[in] | count | - number of spheres being added by this call
[in] | params | - spheres parameters
[in] | velocities | if NULL, the geometry's velocity list will be padded with zero velocities and the asset's velocityRange will be used for velocity
See also:
EmitterGeomExplicit::SphereParams
virtual float nvidia::apex::EmitterGeomExplicit::getDistance ( ) const [pure virtual]

Get average distance between particles.

virtual PxVec3 nvidia::apex::EmitterGeomExplicit::getEllipsoidCenter ( uint32_t index ) const [pure virtual]

Get the center of the ellipsoid.

virtual uint32_t nvidia::apex::EmitterGeomExplicit::getEllipsoidCount ( ) const [pure virtual]

Get the number of ellipsoids.

virtual void nvidia::apex::EmitterGeomExplicit::getEllipsoidList | ( | const EllipsoidParams *& | params,
 |  | uint32_t & | numEllipsoids,
 |  | const PxVec3 *& | velocities,
 |  | uint32_t & | numVelocities
 | ) |  | const [pure virtual]

Access ellipsoids list.

Parameters:
[out] | params | - ellipsoids parameters
[out] | numEllipsoids | - number of ellipsoids in list
[out] | velocities | - ellipsoids velocities
[out] | numVelocities | - number of ellipsoids velocities in list
See also:
EmitterGeomExplicit::EllipsoidParams
virtual PxVec3 nvidia::apex::EmitterGeomExplicit::getEllipsoidNormal ( uint32_t index ) const [pure virtual]

Get the normal of the ellipsoid.

virtual float nvidia::apex::EmitterGeomExplicit::getEllipsoidPolarRadius ( uint32_t index ) const [pure virtual]

Get the polar radius of the ellipsoid.

virtual float nvidia::apex::EmitterGeomExplicit::getEllipsoidRadius ( uint32_t index ) const [pure virtual]

Get the radius of the ellipsoid.

virtual uint32_t nvidia::apex::EmitterGeomExplicit::getParticleCount ( ) const [pure virtual]

Get the number of points.

virtual void nvidia::apex::EmitterGeomExplicit::getParticleList | ( | const PointParams *& | params,
 |  | uint32_t & | numPoints,
 |  | const PxVec3 *& | velocities,
 |  | uint32_t & | numVelocities
 | ) |  | const [pure virtual]

Access particles list.

Parameters:
[out] | params | - particles coordinates
[out] | numPoints | - number of particles in list
[out] | velocities | - particles velocities
[out] | numVelocities | - number of particles velocities in list
See also:
EmitterGeomExplicit::PointParams
virtual PxVec3 nvidia::apex::EmitterGeomExplicit::getParticlePos ( uint32_t index ) const [pure virtual]

Get the position of point.

virtual PxVec3 nvidia::apex::EmitterGeomExplicit::getSphereCenter ( uint32_t index ) const [pure virtual]

Get the center of the sphere.

virtual uint32_t nvidia::apex::EmitterGeomExplicit::getSphereCount ( ) const [pure virtual]

Get the number of spheres.

virtual void nvidia::apex::EmitterGeomExplicit::getSphereList | ( | const SphereParams *& | params,
 |  | uint32_t & | numSpheres,
 |  | const PxVec3 *& | velocities,
 |  | uint32_t & | numVelocities
 | ) |  | const [pure virtual]

Access spheres list.

Parameters:
[out] | params | - spheres parameters
[out] | numSpheres | - number of spheres in list
[out] | velocities | - spheres velocities
[out] | numVelocities | - number of spheres velocities in list
See also:
EmitterGeomExplicit::SphereParams
virtual float nvidia::apex::EmitterGeomExplicit::getSphereRadius ( uint32_t index ) const [pure virtual]

Get the radius of the sphere.

virtual void nvidia::apex::EmitterGeomExplicit::resetParticleList ( ) [pure virtual]

Remove all shapes.

The documentation for this class was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
nvidia::apex::EmitterGeomExplicit Member List
This is the complete list of members for nvidia::apex::EmitterGeomExplicit, including all inherited members.
addEllipsoidList(uint32_t count, const EllipsoidParams *params, const PxVec3 *velocities=0)=0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
addParticleList(uint32_t count, const PointParams *params, const PxVec3 *velocities=0)=0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
addParticleList(uint32_t count, const PxVec3 *positions, const PxVec3 *velocities=0)=0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
addParticleList(uint32_t count, const PointListData &data)=0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
addSphereList(uint32_t count, const SphereParams *params, const PxVec3 *velocities=0)=0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getDistance() const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEllipsoidCenter(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEllipsoidCount() const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEllipsoidList(const EllipsoidParams *&params, uint32_t &numEllipsoids, const PxVec3 *&velocities, uint32_t &numVelocities) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEllipsoidNormal(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEllipsoidPolarRadius(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEllipsoidRadius(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEmitterType() const =0 | nvidia::apex::EmitterGeom | [pure virtual]
getParticleCount() const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getParticleList(const PointParams *&params, uint32_t &numPoints, const PxVec3 *&velocities, uint32_t &numVelocities) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getParticlePos(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getSphereCenter(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getSphereCount() const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getSphereList(const SphereParams *&params, uint32_t &numSpheres, const PxVec3 *&velocities, uint32_t &numVelocities) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getSphereRadius(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
isBoxGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isCylinderGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isExplicitGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereShellGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
resetParticleList()=0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
setEmitterType(EmitterType::Enum)=0 | nvidia::apex::EmitterGeom | [pure virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterGeomSphere Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomSphere
Public Member Functions
nvidia::apex::EmitterGeomSphere Class Reference

Spherical shape for an emitter. More...

#include <EmitterGeoms.h>

Inheritance diagram for nvidia::apex::EmitterGeomSphere:
nvidia::apex::EmitterGeom

List of all members.

Public Member Functions

virtual void | setRadius (float radius)=0
Set sphere radius.
virtual float | getRadius () const =0
Get sphere radius.

Detailed Description

Spherical shape for an emitter.

Member Function Documentation

virtual float nvidia::apex::EmitterGeomSphere::getRadius ( ) const [pure virtual]

Get sphere radius.

virtual void nvidia::apex::EmitterGeomSphere::setRadius ( float radius ) [pure virtual]

Set sphere radius.

The documentation for this class was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomSphere
nvidia::apex::EmitterGeomSphere Member List
This is the complete list of members for nvidia::apex::EmitterGeomSphere, including all inherited members.
getEmitterType() const =0 | nvidia::apex::EmitterGeom | [pure virtual]
getRadius() const =0 | nvidia::apex::EmitterGeomSphere | [pure virtual]
isBoxGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isCylinderGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isExplicitGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereShellGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
setEmitterType(EmitterType::Enum)=0 | nvidia::apex::EmitterGeom | [pure virtual]
setRadius(float radius)=0 | nvidia::apex::EmitterGeomSphere | [pure virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterGeomSphereShell Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomSphereShell
Public Member Functions
nvidia::apex::EmitterGeomSphereShell Class Reference

Sphere shell shape for an emitter. It's a shape formed by the difference of two cocentered spheres. More...

#include <EmitterGeoms.h>

Inheritance diagram for nvidia::apex::EmitterGeomSphereShell:
nvidia::apex::EmitterGeom

List of all members.

Public Member Functions

virtual void | setRadius (float radius)=0
Set sphere shell radius.
virtual float | getRadius () const =0
Get sphere shell radius.
virtual void | setShellThickness (float thickness)=0
Set sphere shell thickness.
virtual float | getShellThickness () const =0
Get sphere shell thickness.

Detailed Description

Sphere shell shape for an emitter. It's a shape formed by the difference of two cocentered spheres.

Member Function Documentation

virtual float nvidia::apex::EmitterGeomSphereShell::getRadius ( ) const [pure virtual]

Get sphere shell radius.

virtual float nvidia::apex::EmitterGeomSphereShell::getShellThickness ( ) const [pure virtual]

Get sphere shell thickness.

virtual void nvidia::apex::EmitterGeomSphereShell::setRadius ( float radius ) [pure virtual]

Set sphere shell radius.

virtual void nvidia::apex::EmitterGeomSphereShell::setShellThickness ( float thickness ) [pure virtual]

Set sphere shell thickness.

The documentation for this class was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomSphereShell
nvidia::apex::EmitterGeomSphereShell Member List
This is the complete list of members for nvidia::apex::EmitterGeomSphereShell, including all inherited members.
getEmitterType() const =0 | nvidia::apex::EmitterGeom | [pure virtual]
getRadius() const =0 | nvidia::apex::EmitterGeomSphereShell | [pure virtual]
getShellThickness() const =0 | nvidia::apex::EmitterGeomSphereShell | [pure virtual]
isBoxGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isCylinderGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isExplicitGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereShellGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
setEmitterType(EmitterType::Enum)=0 | nvidia::apex::EmitterGeom | [pure virtual]
setRadius(float radius)=0 | nvidia::apex::EmitterGeomSphereShell | [pure virtual]
setShellThickness(float thickness)=0 | nvidia::apex::EmitterGeomSphereShell | [pure virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterLodParamDesc Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterLodParamDesc
Public Types | Public Member Functions | Public Attributes
nvidia::apex::EmitterLodParamDesc Class Reference

LOD parameters fro emitters. More...

#include <EmitterLodParamDesc.h>

List of all members.

Public Types

enum ManifestVersions {
initial,
count,
current = count - 1
}
enum of manifest versions More...

Public Member Functions

PX_INLINE | EmitterLodParamDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
sets members to default values.
PX_INLINE bool | isValid () const
checks if this is a valid descriptor.

Public Attributes

float | maxDistance
Objects greater than this distance from the player will be culled more aggressively.
float | distanceWeight
Weight given to distance parameter in LOD function.
float | speedWeight
Weight given to velocity parameter in LOD function.
float | lifeWeight
Weight given to life remain parameter in LOD function.
float | separationWeight
Weight given to separation parameter in LOD function.
float | bias
Bias given to objects spawned by this emitter, relative to other emitters in the same IOS.

Detailed Description

LOD parameters fro emitters.

Member Enumeration Documentation

enum nvidia::apex::EmitterLodParamDesc::ManifestVersions

enum of manifest versions

Enumerator:
initial
count
current

Constructor & Destructor Documentation

PX_INLINE nvidia::apex::EmitterLodParamDesc::EmitterLodParamDesc ( ) [inline]

constructor sets to default.

Member Function Documentation

PX_INLINE bool nvidia::apex::EmitterLodParamDesc::isValid ( ) const [inline]

checks if this is a valid descriptor.

PX_INLINE void nvidia::apex::EmitterLodParamDesc::setToDefault ( ) [inline]

sets members to default values.

Member Data Documentation

float nvidia::apex::EmitterLodParamDesc::bias

Bias given to objects spawned by this emitter, relative to other emitters in the same IOS.

float nvidia::apex::EmitterLodParamDesc::distanceWeight

Weight given to distance parameter in LOD function.

float nvidia::apex::EmitterLodParamDesc::lifeWeight

Weight given to life remain parameter in LOD function.

float nvidia::apex::EmitterLodParamDesc::maxDistance

Objects greater than this distance from the player will be culled more aggressively.

float nvidia::apex::EmitterLodParamDesc::separationWeight

Weight given to separation parameter in LOD function.

float nvidia::apex::EmitterLodParamDesc::speedWeight

Weight given to velocity parameter in LOD function.

The documentation for this class was generated from the following file:
  • EmitterLodParamDesc.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterLodParamDesc
nvidia::apex::EmitterLodParamDesc Member List
This is the complete list of members for nvidia::apex::EmitterLodParamDesc, including all inherited members.
bias | nvidia::apex::EmitterLodParamDesc |
count enum value | nvidia::apex::EmitterLodParamDesc |
current enum value | nvidia::apex::EmitterLodParamDesc |
distanceWeight | nvidia::apex::EmitterLodParamDesc |
EmitterLodParamDesc() | nvidia::apex::EmitterLodParamDesc | [inline]
initial enum value | nvidia::apex::EmitterLodParamDesc |
isValid() const | nvidia::apex::EmitterLodParamDesc | [inline]
lifeWeight | nvidia::apex::EmitterLodParamDesc |
ManifestVersions enum name | nvidia::apex::EmitterLodParamDesc |
maxDistance | nvidia::apex::EmitterLodParamDesc |
separationWeight | nvidia::apex::EmitterLodParamDesc |
setToDefault() | nvidia::apex::EmitterLodParamDesc | [inline]
speedWeight | nvidia::apex::EmitterLodParamDesc |
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterPreview Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterPreview
Public Member Functions | Protected Member Functions
nvidia::apex::EmitterPreview Class Reference

#include <EmitterPreview.h>

List of all members.

Public Member Functions

virtual void | drawEmitterPreview ()=0
Draws the emitter.
virtual void | setScale (float scale)=0
Sets the scaling factor of the renderable.

Protected Member Functions

EmitterPreview ()

Detailed Description

Preview class for ApexEmitter. Used for preview rendeing.

Constructor & Destructor Documentation

nvidia::apex::EmitterPreview::EmitterPreview ( ) [inline, protected]

Member Function Documentation

virtual void nvidia::apex::EmitterPreview::drawEmitterPreview ( ) [pure virtual]

Draws the emitter.

virtual void nvidia::apex::EmitterPreview::setScale ( float scale ) [pure virtual]

Sets the scaling factor of the renderable.

The documentation for this class was generated from the following file:
  • EmitterPreview.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterPreview
nvidia::apex::EmitterPreview Member List
This is the complete list of members for nvidia::apex::EmitterPreview, including all inherited members.
drawEmitterPreview()=0 | nvidia::apex::EmitterPreview | [pure virtual]
EmitterPreview() | nvidia::apex::EmitterPreview | [inline, protected]
setScale(float scale)=0 | nvidia::apex::EmitterPreview | [pure virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::GroundEmitterActor Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterActor
Public Member Functions | Protected Member Functions
nvidia::apex::GroundEmitterActor Class Reference

Ground Emitter actor. Uses raycasts against ground to spawn particles. More...

#include <GroundEmitterActor.h>

List of all members.

Public Member Functions

virtual GroundEmitterAsset * | getEmitterAsset () const =0
Returns the asset the instance has been created from.
virtual const PxMat44 | getPose () const =0
Returns the pose of the emitter.
virtual void | setPose (const PxMat44 &pos)=0
Sets the pose of the emitter.
virtual void | setMaterialLookupCallback (MaterialLookupCallback *)=0
Set the material lookup callback method that replaces raycasts.
virtual MaterialLookupCallback * | getMaterialLookupCallback () const =0
Get the material lookup callback method that replaces raycasts.
virtual void | setAttachActor (PxActor *)=0
Attaches the emitter to an actor PxActor pointer can be NULL to detach existing actor.
virtual void | setAttachRelativePosition (const PxVec3 &pos)=0
sets the relative position of the emitter in the space of the actor to which it is attached
virtual const PxActor * | getAttachActor () const =0
PhysX SDK 3.X. Retrieves the actor, to which the emitter is attached. NULL is returned for an unattached emitter.
virtual const PxVec3 & | getAttachRelativePosition () const =0
Retrieves the relative position of the emitter in the space of the actor to which it is attached.
virtual void | setDensity (const float &)=0
Sets the range from which the density of particles within the volume is randomly chosen.
virtual void | setRadius (float)=0
Sets the radius. The ground emitter actor will create objects within a circle of size 'radius'.
virtual void | setMaxRaycastsPerFrame (uint32_t)=0
Sets The maximum raycasts number per frame.
virtual void | setRaycastHeight (float)=0
Sets the height from which the ground emitter will cast rays at terrain/objects opposite of the 'upDirection'.
virtual void | setSpawnHeight (float)=0
Sets the height above the ground to emit particles. If greater than 0, the ground emitter will refresh a disc above the player's position rather than refreshing a circle around the player's position.
virtual const float & | getDensity () const =0
Gets the range from which the density of particles within the volume is randomly chosen.
virtual float | getRadius () const =0
Gets the radius. The ground emitter actor will create objects within a circle of size 'radius'.
virtual uint32_t | getMaxRaycastsPerFrame () const =0
Gets The maximum raycasts number per frame.
virtual float | getRaycastHeight () const =0
Gets the height from which the ground emitter will cast rays at terrain/objects opposite of the 'upDirection'.
virtual float | getSpawnHeight () const =0
Gets the height above the ground to emit particles. If greater than 0, the ground emitter will refresh a disc above the player's position rather than refreshing a circle around the player's position.
virtual void | setRaycastCollisionGroups (uint32_t)=0
Sets collision groups used to cast rays.
virtual void | setRaycastCollisionGroupsMask (physx::PxFilterData *)=0
PHYSX SDK 3.X. Sets collision groups mask.
virtual uint32_t | getRaycastCollisionGroups () const =0
Gets collision groups used to cast rays.
virtual void | setPreferredRenderVolume (RenderVolume *volume)=0

Protected Member Functions

virtual | ~GroundEmitterActor ()

Detailed Description

Ground Emitter actor. Uses raycasts against ground to spawn particles.

Constructor & Destructor Documentation

virtual nvidia::apex::GroundEmitterActor::~GroundEmitterActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual const PxActor* nvidia::apex::GroundEmitterActor::getAttachActor ( ) const [pure virtual]

PhysX SDK 3.X. Retrieves the actor, to which the emitter is attached. NULL is returned for an unattached emitter.

virtual const PxVec3& nvidia::apex::GroundEmitterActor::getAttachRelativePosition ( ) const [pure virtual]

Retrieves the relative position of the emitter in the space of the actor to which it is attached.

virtual const float& nvidia::apex::GroundEmitterActor::getDensity ( ) const [pure virtual]

Gets the range from which the density of particles within the volume is randomly chosen.

virtual GroundEmitterAsset* nvidia::apex::GroundEmitterActor::getEmitterAsset ( ) const [pure virtual]

Returns the asset the instance has been created from.

virtual MaterialLookupCallback* nvidia::apex::GroundEmitterActor::getMaterialLookupCallback ( ) const [pure virtual]

Get the material lookup callback method that replaces raycasts.

virtual uint32_t nvidia::apex::GroundEmitterActor::getMaxRaycastsPerFrame ( ) const [pure virtual]

Gets The maximum raycasts number per frame.

virtual const PxMat44 nvidia::apex::GroundEmitterActor::getPose ( ) const [pure virtual]

Returns the pose of the emitter.

virtual float nvidia::apex::GroundEmitterActor::getRadius ( ) const [pure virtual]

Gets the radius. The ground emitter actor will create objects within a circle of size 'radius'.

virtual uint32_t nvidia::apex::GroundEmitterActor::getRaycastCollisionGroups ( ) const [pure virtual]

Gets collision groups used to cast rays.

virtual float nvidia::apex::GroundEmitterActor::getRaycastHeight ( ) const [pure virtual]

Gets the height from which the ground emitter will cast rays at terrain/objects opposite of the 'upDirection'.

virtual float nvidia::apex::GroundEmitterActor::getSpawnHeight ( ) const [pure virtual]

Gets the height above the ground to emit particles. If greater than 0, the ground emitter will refresh a disc above the player's position rather than refreshing a circle around the player's position.

virtual void nvidia::apex::GroundEmitterActor::setAttachActor ( PxActor * ) [pure virtual]

Attaches the emitter to an actor PxActor pointer can be NULL to detach existing actor.

virtual void nvidia::apex::GroundEmitterActor::setAttachRelativePosition ( const PxVec3 & pos ) [pure virtual]

sets the relative position of the emitter in the space of the actor to which it is attached

virtual void nvidia::apex::GroundEmitterActor::setDensity ( const float & ) [pure virtual]

Sets the range from which the density of particles within the volume is randomly chosen.

virtual void nvidia::apex::GroundEmitterActor::setMaterialLookupCallback ( MaterialLookupCallback * ) [pure virtual]

Set the material lookup callback method that replaces raycasts.

virtual void nvidia::apex::GroundEmitterActor::setMaxRaycastsPerFrame ( uint32_t ) [pure virtual]

Sets The maximum raycasts number per frame.

virtual void nvidia::apex::GroundEmitterActor::setPose ( const PxMat44 & pos ) [pure virtual]

Sets the pose of the emitter.

virtual void nvidia::apex::GroundEmitterActor::setPreferredRenderVolume ( RenderVolume * volume ) [pure virtual]

Emitted particles are injected to specified render volume on initial frame. Set to NULL to clear the preferred volume.

virtual void nvidia::apex::GroundEmitterActor::setRadius ( float ) [pure virtual]

Sets the radius. The ground emitter actor will create objects within a circle of size 'radius'.

virtual void nvidia::apex::GroundEmitterActor::setRaycastCollisionGroups ( uint32_t ) [pure virtual]

Sets collision groups used to cast rays.

virtual void nvidia::apex::GroundEmitterActor::setRaycastCollisionGroupsMask ( physx::PxFilterData * ) [pure virtual]

PHYSX SDK 3.X. Sets collision groups mask.

virtual void nvidia::apex::GroundEmitterActor::setRaycastHeight ( float ) [pure virtual]

Sets the height from which the ground emitter will cast rays at terrain/objects opposite of the 'upDirection'.

virtual void nvidia::apex::GroundEmitterActor::setSpawnHeight ( float ) [pure virtual]

Sets the height above the ground to emit particles. If greater than 0, the ground emitter will refresh a disc above the player's position rather than refreshing a circle around the player's position.

The documentation for this class was generated from the following file:
  • GroundEmitterActor.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterActor
nvidia::apex::GroundEmitterActor Member List
This is the complete list of members for nvidia::apex::GroundEmitterActor, including all inherited members.
getAttachActor() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getAttachRelativePosition() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getDensity() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getEmitterAsset() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getMaterialLookupCallback() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getMaxRaycastsPerFrame() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getPose() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getRadius() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getRaycastCollisionGroups() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getRaycastHeight() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getSpawnHeight() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setAttachActor(PxActor *)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setAttachRelativePosition(const PxVec3 &pos)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setDensity(const float &)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setMaterialLookupCallback(MaterialLookupCallback *)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setMaxRaycastsPerFrame(uint32_t)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setPose(const PxMat44 &pos)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setPreferredRenderVolume(RenderVolume *volume)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setRadius(float)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setRaycastCollisionGroups(uint32_t)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setRaycastCollisionGroupsMask(physx::PxFilterData *)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setRaycastHeight(float)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setSpawnHeight(float)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
~GroundEmitterActor() | nvidia::apex::GroundEmitterActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::GroundEmitterAsset Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterAsset
Public Member Functions | Protected Member Functions
nvidia::apex::GroundEmitterAsset Class Reference

Ground emitter asset. Used to create Ground emitter actors with specific properties. More...

#include <GroundEmitterAsset.h>

List of all members.

Public Member Functions

virtual const PxVec3 & | getVelocityLow () const =0
Gets the velocity range. The ground emitter actor will create objects with a random velocity within the velocity range.
virtual const PxVec3 & | getVelocityHigh () const =0
Gets the velocity range. The ground emitter actor will create objects with a random velocity within the velocity range.
virtual const float & | getLifetimeLow () const =0
Gets the lifetime range. The ground emitter actor will create objects with a random lifetime (in seconds) within the lifetime range.
virtual const float & | getLifetimeHigh () const =0
Gets the lifetime range. The ground emitter actor will create objects with a random lifetime (in seconds) within the lifetime range.
virtual float | getRadius () const =0
Gets the radius. The ground emitter actor will create objects within a circle of size 'radius'.
virtual uint32_t | getMaxRaycastsPerFrame () const =0
Gets The maximum raycasts number per frame.
virtual float | getRaycastHeight () const =0
Gets the height from which the ground emitter will cast rays at terrain/objects opposite of the 'upDirection'.
virtual float | getSpawnHeight () const =0
Gets the height above the ground to emit particles. If greater than 0, the ground emitter will refresh a disc above the player's position rather than refreshing a circle around the player's position.
virtual const char * | getRaycastCollisionGroupMaskName () const =0
Gets collision groups name used to cast rays.

Protected Member Functions

PX_INLINE | GroundEmitterAsset ()
virtual | ~GroundEmitterAsset ()

Detailed Description

Ground emitter asset. Used to create Ground emitter actors with specific properties.

Constructor & Destructor Documentation

PX_INLINE nvidia::apex::GroundEmitterAsset::GroundEmitterAsset ( ) [inline, protected]
virtual nvidia::apex::GroundEmitterAsset::~GroundEmitterAsset ( ) [inline, protected, virtual]

Member Function Documentation

virtual const float& nvidia::apex::GroundEmitterAsset::getLifetimeHigh ( ) const [pure virtual]

Gets the lifetime range. The ground emitter actor will create objects with a random lifetime (in seconds) within the lifetime range.

virtual const float& nvidia::apex::GroundEmitterAsset::getLifetimeLow ( ) const [pure virtual]

Gets the lifetime range. The ground emitter actor will create objects with a random lifetime (in seconds) within the lifetime range.

virtual uint32_t nvidia::apex::GroundEmitterAsset::getMaxRaycastsPerFrame ( ) const [pure virtual]

Gets The maximum raycasts number per frame.

virtual float nvidia::apex::GroundEmitterAsset::getRadius ( ) const [pure virtual]

Gets the radius. The ground emitter actor will create objects within a circle of size 'radius'.

virtual const char* nvidia::apex::GroundEmitterAsset::getRaycastCollisionGroupMaskName ( ) const [pure virtual]

Gets collision groups name used to cast rays.

virtual float nvidia::apex::GroundEmitterAsset::getRaycastHeight ( ) const [pure virtual]

Gets the height from which the ground emitter will cast rays at terrain/objects opposite of the 'upDirection'.

virtual float nvidia::apex::GroundEmitterAsset::getSpawnHeight ( ) const [pure virtual]

Gets the height above the ground to emit particles. If greater than 0, the ground emitter will refresh a disc above the player's position rather than refreshing a circle around the player's position.

virtual const PxVec3& nvidia::apex::GroundEmitterAsset::getVelocityHigh ( ) const [pure virtual]

Gets the velocity range. The ground emitter actor will create objects with a random velocity within the velocity range.

virtual const PxVec3& nvidia::apex::GroundEmitterAsset::getVelocityLow ( ) const [pure virtual]

Gets the velocity range. The ground emitter actor will create objects with a random velocity within the velocity range.

The documentation for this class was generated from the following file:
  • GroundEmitterAsset.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterAsset
nvidia::apex::GroundEmitterAsset Member List
This is the complete list of members for nvidia::apex::GroundEmitterAsset, including all inherited members.
getLifetimeHigh() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getLifetimeLow() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getMaxRaycastsPerFrame() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getRadius() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getRaycastCollisionGroupMaskName() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getRaycastHeight() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getSpawnHeight() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getVelocityHigh() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getVelocityLow() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
GroundEmitterAsset() | nvidia::apex::GroundEmitterAsset | [inline, protected]
~GroundEmitterAsset() | nvidia::apex::GroundEmitterAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::GroundEmitterAssetAuthoring Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterAssetAuthoring
Protected Member Functions
nvidia::apex::GroundEmitterAssetAuthoring Class Reference

Ground emitter authoring class. Used to create Ground emitter assets. More...

#include <GroundEmitterAsset.h>

List of all members.

Protected Member Functions

virtual ~GroundEmitterAssetAuthoring ()

Detailed Description

Ground emitter authoring class. Used to create Ground emitter assets.

Constructor & Destructor Documentation

virtual nvidia::apex::GroundEmitterAssetAuthoring::~GroundEmitterAssetAuthoring ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • GroundEmitterAsset.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterAssetAuthoring
nvidia::apex::GroundEmitterAssetAuthoring Member List
This is the complete list of members for nvidia::apex::GroundEmitterAssetAuthoring, including all inherited members.
~GroundEmitterAssetAuthoring() nvidia::apex::GroundEmitterAssetAuthoring [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::GroundEmitterPreview Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterPreview
Public Member Functions | Protected Member Functions
nvidia::apex::GroundEmitterPreview Class Reference

Ground emitter preview class. Use for preview rendering. More...

#include <GroundEmitterPreview.h>

List of all members.

Public Member Functions

virtual void | drawEmitterPreview ()=0
Does the drawing.
virtual void | setScale (float scale)=0
Sets the scale factor of the preview object.

Protected Member Functions

GroundEmitterPreview ()

Detailed Description

Ground emitter preview class. Use for preview rendering.

Constructor & Destructor Documentation

nvidia::apex::GroundEmitterPreview::GroundEmitterPreview ( ) [inline, protected]

Member Function Documentation

virtual void nvidia::apex::GroundEmitterPreview::drawEmitterPreview ( ) [pure virtual]

Does the drawing.

virtual void nvidia::apex::GroundEmitterPreview::setScale ( float scale ) [pure virtual]

Sets the scale factor of the preview object.

The documentation for this class was generated from the following file:
  • GroundEmitterPreview.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterPreview
nvidia::apex::GroundEmitterPreview Member List
This is the complete list of members for nvidia::apex::GroundEmitterPreview, including all inherited members.
drawEmitterPreview()=0 | nvidia::apex::GroundEmitterPreview | [pure virtual]
GroundEmitterPreview() | nvidia::apex::GroundEmitterPreview | [inline, protected]
setScale(float scale)=0 | nvidia::apex::GroundEmitterPreview | [pure virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::ImpactEmitterActor Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterActor
Public Member Functions | Protected Member Functions
nvidia::apex::ImpactEmitterActor Class Reference

Impact emitter actor. Emits particles at impact places. More...

#include <ImpactEmitterActor.h>

List of all members.

Public Member Functions

virtual ImpactEmitterAsset * | getEmitterAsset () const =0
Gets the pointer to the underlying asset.
virtual void | registerImpact (const PxVec3 &hitPos, const PxVec3 &hitDir, const PxVec3 &surfNorm, uint32_t setID)=0
Registers an impact in the queue.
virtual void | setPreferredRenderVolume (RenderVolume *volume)=0

Protected Member Functions

virtual | ~ImpactEmitterActor ()

Detailed Description

Impact emitter actor. Emits particles at impact places.

Constructor & Destructor Documentation

virtual nvidia::apex::ImpactEmitterActor::~ImpactEmitterActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual ImpactEmitterAsset* nvidia::apex::ImpactEmitterActor::getEmitterAsset ( ) const [pure virtual]

Gets the pointer to the underlying asset.

virtual void nvidia::apex::ImpactEmitterActor::registerImpact | ( | const PxVec3 & | hitPos,
 |  | const PxVec3 & | hitDir,
 |  | const PxVec3 & | surfNorm,
 |  | uint32_t | setID
 | ) |  | [pure virtual]

Registers an impact in the queue.

Parameters:
hitPos | impact position
hitDir | impact direction
surfNorm | normal of the surface that is hit by the impact
setID | - id for the event set which should be spawned. Specifies the behavior.
See also:
ImpactEmitterAsset::querySetID
virtual void nvidia::apex::ImpactEmitterActor::setPreferredRenderVolume ( RenderVolume * volume ) [pure virtual]

Emitted particles are injected to specified render volume on initial frame. Set to NULL to clear the preferred volume.

The documentation for this class was generated from the following file:
  • ImpactEmitterActor.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterActor
nvidia::apex::ImpactEmitterActor Member List
This is the complete list of members for nvidia::apex::ImpactEmitterActor, including all inherited members.
getEmitterAsset() const =0 | nvidia::apex::ImpactEmitterActor | [pure virtual]
registerImpact(const PxVec3 &hitPos, const PxVec3 &hitDir, const PxVec3 &surfNorm, uint32_t setID)=0 | nvidia::apex::ImpactEmitterActor | [pure virtual]
setPreferredRenderVolume(RenderVolume *volume)=0 | nvidia::apex::ImpactEmitterActor | [pure virtual]
~ImpactEmitterActor() | nvidia::apex::ImpactEmitterActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::ImpactEmitterAsset Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterAsset
Public Member Functions | Protected Member Functions
nvidia::apex::ImpactEmitterAsset Class Reference

Impact emitter asset class. More...

#include <ImpactEmitterAsset.h>

List of all members.

Public Member Functions

virtual uint32_t | querySetID (const char *setName)=0
Get the setID that corresponds to the set name.
virtual void | getSetNames (const char **inOutSetNames, uint32_t &nameCount) const =0
Get a list of the event set names. The name index in the outSetNames list is the setID.

Protected Member Functions

PX_INLINE | ImpactEmitterAsset ()
virtual | ~ImpactEmitterAsset ()

Detailed Description

Impact emitter asset class.

Constructor & Destructor Documentation

PX_INLINE nvidia::apex::ImpactEmitterAsset::ImpactEmitterAsset ( ) [inline, protected]
virtual nvidia::apex::ImpactEmitterAsset::~ImpactEmitterAsset ( ) [inline, protected, virtual]

Member Function Documentation

virtual void nvidia::apex::ImpactEmitterAsset::getSetNames | ( | const char ** | inOutSetNames,
 |  | uint32_t & | nameCount
 | ) |  | const [pure virtual]

Get a list of the event set names. The name index in the outSetNames list is the setID.

Parameters:
[in,out] | inOutSetNames | An array of const char * with at least nameCount
[in,out] | nameCount | The size of setNames as input and output, set to -1 if setIDs > nameCount
virtual uint32_t nvidia::apex::ImpactEmitterAsset::querySetID ( const char * setName ) [pure virtual]

Get the setID that corresponds to the set name.

See also:
ImpactEmitterActor::registerImpact()
The documentation for this class was generated from the following file:
  • ImpactEmitterAsset.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterAsset
nvidia::apex::ImpactEmitterAsset Member List
This is the complete list of members for nvidia::apex::ImpactEmitterAsset, including all inherited members.
getSetNames(const char **inOutSetNames, uint32_t &nameCount) const =0 | nvidia::apex::ImpactEmitterAsset | [pure virtual]
ImpactEmitterAsset() | nvidia::apex::ImpactEmitterAsset | [inline, protected]
querySetID(const char *setName)=0 | nvidia::apex::ImpactEmitterAsset | [pure virtual]
~ImpactEmitterAsset() | nvidia::apex::ImpactEmitterAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::ImpactEmitterAssetAuthoring Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterAssetAuthoring
Protected Member Functions
nvidia::apex::ImpactEmitterAssetAuthoring Class Reference

Impact emitter asset authoring. Used to create Impact Emitter assets. More...

#include <ImpactEmitterAsset.h>

List of all members.

Protected Member Functions

virtual ~ImpactEmitterAssetAuthoring ()

Detailed Description

Impact emitter asset authoring. Used to create Impact Emitter assets.

Constructor & Destructor Documentation

virtual nvidia::apex::ImpactEmitterAssetAuthoring::~ImpactEmitterAssetAuthoring ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • ImpactEmitterAsset.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterAssetAuthoring
nvidia::apex::ImpactEmitterAssetAuthoring Member List
This is the complete list of members for nvidia::apex::ImpactEmitterAssetAuthoring, including all inherited members.
~ImpactEmitterAssetAuthoring() nvidia::apex::ImpactEmitterAssetAuthoring [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::ImpactEmitterPreview Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterPreview
Protected Member Functions
nvidia::apex::ImpactEmitterPreview Class Reference

Impact emitter preview. Used for preview rendering of the emitter actors. More...

#include <ImpactEmitterPreview.h>

List of all members.

Protected Member Functions

ImpactEmitterPreview ()

Detailed Description

Impact emitter preview. Used for preview rendering of the emitter actors.

Constructor & Destructor Documentation

nvidia::apex::ImpactEmitterPreview::ImpactEmitterPreview ( ) [inline, protected]
The documentation for this class was generated from the following file:
  • ImpactEmitterPreview.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterPreview
nvidia::apex::ImpactEmitterPreview Member List
This is the complete list of members for nvidia::apex::ImpactEmitterPreview, including all inherited members.
ImpactEmitterPreview() nvidia::apex::ImpactEmitterPreview [inline, protected]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::MaterialLookupCallback Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MaterialLookupCallback
Classes | Public Member Functions
nvidia::apex::MaterialLookupCallback Class Reference

a user calback interface used to map raycast hitpoints to material ID If an instance of this class is registered with a ground emitter actor, the actor will call requestMaterialLookups() in lieu of doing raycasts. The call will occur from within the scope of the ApexScene thread, so the callback must be thread safe. More...

#include <GroundEmitterActor.h>

List of all members.

Classes

struct | MaterialRequest
Material request structure. More...

Public Member Functions

virtual void | requestMaterialLookups (uint32_t requestCount, MaterialRequest *reqList)=0
Submit the meterial lookup request. This method is called by the emitter and implemented by the user.
virtual | ~MaterialLookupCallback ()

Detailed Description

a user calback interface used to map raycast hitpoints to material ID If an instance of this class is registered with a ground emitter actor, the actor will call requestMaterialLookups() in lieu of doing raycasts. The call will occur from within the scope of the ApexScene thread, so the callback must be thread safe.

Constructor & Destructor Documentation

virtual nvidia::apex::MaterialLookupCallback::~MaterialLookupCallback ( ) [inline, virtual]

Member Function Documentation

virtual void nvidia::apex::MaterialLookupCallback::requestMaterialLookups | ( | uint32_t | requestCount,
 |  | MaterialRequest * | reqList
 | ) |  | [pure virtual]

Submit the meterial lookup request. This method is called by the emitter and implemented by the user.

Parameters:
requestCount | [IN] number of requests
reqList | [IN/OUT] the pointer to the requests. samplePosition is read and materialID is written to by the user.
The documentation for this class was generated from the following file:
  • GroundEmitterActor.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MaterialLookupCallback
nvidia::apex::MaterialLookupCallback Member List
This is the complete list of members for nvidia::apex::MaterialLookupCallback, including all inherited members.
requestMaterialLookups(uint32_t requestCount, MaterialRequest *reqList)=0 | nvidia::apex::MaterialLookupCallback | [pure virtual]
~MaterialLookupCallback() | nvidia::apex::MaterialLookupCallback | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::ModuleEmitter Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleEmitter
Public Member Functions | Protected Member Functions
nvidia::apex::ModuleEmitter Class Reference

An APEX Module that provides generic Emitter classes. More...

#include <ModuleEmitter.h>

List of all members.

Public Member Functions

virtual float | getRateScale () const =0
get rate scale. Rate parameter in all emitters will be multiplied by rate scale.
virtual float | getDensityScale () const =0
get density scale. Density parameter in all emitters except ground emitters will be multiplied by density scale.
virtual float | getGroundDensityScale () const =0
get ground density scale. Density parameter in all ground emitters will be multiplied by ground density scale.
virtual void | setRateScale (float rateScale)=0
set rate scale. Rate parameter in all module emitters will be multiplied by rate scale.
virtual void | setDensityScale (float densityScale)=0
set density scale. Density parameter in all emitters except ground emitters will be multiplied by density scale.
virtual void | setGroundDensityScale (float groundDensityScale)=0
set ground density scale. Density parameter in all ground emitters will be multiplied by ground density scale.

Protected Member Functions

virtual | ~ModuleEmitter ()

Detailed Description

An APEX Module that provides generic Emitter classes.

Constructor & Destructor Documentation

virtual nvidia::apex::ModuleEmitter::~ModuleEmitter ( ) [inline, protected, virtual]

Member Function Documentation

virtual float nvidia::apex::ModuleEmitter::getDensityScale ( ) const [pure virtual]

get density scale. Density parameter in all emitters except ground emitters will be multiplied by density scale.

virtual float nvidia::apex::ModuleEmitter::getGroundDensityScale ( ) const [pure virtual]

get ground density scale. Density parameter in all ground emitters will be multiplied by ground density scale.

virtual float nvidia::apex::ModuleEmitter::getRateScale ( ) const [pure virtual]

get rate scale. Rate parameter in all emitters will be multiplied by rate scale.

virtual void nvidia::apex::ModuleEmitter::setDensityScale ( float densityScale ) [pure virtual]

set density scale. Density parameter in all emitters except ground emitters will be multiplied by density scale.

virtual void nvidia::apex::ModuleEmitter::setGroundDensityScale ( float groundDensityScale ) [pure virtual]

set ground density scale. Density parameter in all ground emitters will be multiplied by ground density scale.

virtual void nvidia::apex::ModuleEmitter::setRateScale ( float rateScale ) [pure virtual]

set rate scale. Rate parameter in all module emitters will be multiplied by rate scale.

The documentation for this class was generated from the following file:
  • ModuleEmitter.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleEmitter
nvidia::apex::ModuleEmitter Member List
This is the complete list of members for nvidia::apex::ModuleEmitter, including all inherited members.
getDensityScale() const =0 | nvidia::apex::ModuleEmitter | [pure virtual]
getGroundDensityScale() const =0 | nvidia::apex::ModuleEmitter | [pure virtual]
getRateScale() const =0 | nvidia::apex::ModuleEmitter | [pure virtual]
setDensityScale(float densityScale)=0 | nvidia::apex::ModuleEmitter | [pure virtual]
setGroundDensityScale(float groundDensityScale)=0 | nvidia::apex::ModuleEmitter | [pure virtual]
setRateScale(float rateScale)=0 | nvidia::apex::ModuleEmitter | [pure virtual]
~ModuleEmitter() | nvidia::apex::ModuleEmitter | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: EmitterActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
EmitterActor.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::EmitterActor
Apex emitter actor class. Emits particles within a given shape. More...
class | nvidia::apex::EmitterActor::EmitterValidateCallback

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: EmitterActor.h Source File

  • File List
  • File Members
EmitterActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EMITTER_ACTOR_H
00031 #define EMITTER_ACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class EmitterAsset;
00043 class EmitterGeomExplicit;
00044 class EmitterLodParamDesc;
00045 class RenderVolume;
00046
00048 class EmitterActor : public Actor
00049 {
00050 protected:
00051     virtual ~EmitterActor() {}
00052
00053 public:
00054
00058     class EmitterValidateCallback
00059     {
00060     public:
00069         virtual bool validateEmitterPosition(const PxVec3 &emitterOrigin,PxVec3 &position) = 0;
00070     };
00071
00073     virtual EmitterAsset*           getEmitterAsset() const = 0;
00074
00076     virtual EmitterGeomExplicit*    isExplicitGeom() = 0;
00077
00079     virtual PxMat44                 getGlobalPose() const = 0;
00080
00082     virtual void                    setCurrentPose(const PxTransform& pose) = 0;
00083
00085     virtual void                    setCurrentPosition(const PxVec3& pos) = 0;
00086
00092     virtual void                    setAttachActor(PxActor*) = 0;
00093
00095     virtual void                    setAttachRelativePose(const PxTransform& pose) = 0;
00096
00098     virtual const PxActor*          getAttachActor() const = 0;
00099
00101     virtual const PxMat44           getAttachRelativePose() const = 0;
00102
00104     virtual float                   getObjectRadius() const = 0;
00105
00107     virtual void                    setOverlapTestCollisionGroups(uint32_t) = 0;
00108
00115     virtual void                    startEmit(bool persistent = true) = 0;
00116
00118     virtual void                    stopEmit() = 0;
00119
00121     virtual bool                    isEmitting() const = 0;
00122
00124     virtual const EmitterLodParamDesc& getLodParamDesc() const = 0;
00126     virtual void                    setLodParamDesc(const EmitterLodParamDesc&) = 0;
00127
00129
00130     virtual void                    setDensity(const float&) = 0;
00131
00133     virtual void                    setRate(const float&) = 0;
00134
00136     virtual void                    setVelocityLow(const PxVec3&) = 0;
00137
00139     virtual void                    setVelocityHigh(const PxVec3&) = 0;
00140
00142     virtual void                    setLifetimeLow(const float&) = 0;
00143
00145     virtual void                    setLifetimeHigh(const float&) = 0;
00146
00148     virtual void                    emitAssetParticles(bool enable) = 0;
00149
00151     virtual bool                    getEmitAssetParticles() const = 0;
00152
00159     virtual void                    setPreferredRenderVolume(RenderVolume* volume) = 0;
00160
00162     virtual void                    getRate(float&) const = 0;
00163
00165     virtual uint32_t                getSimParticlesCount() const = 0;
00166
00168     virtual uint32_t                getActiveParticleCount() const = 0;
00169
00171     virtual void                    setDensityGridPosition(const PxVec3 &pos) = 0;
00172
00174     virtual void                    setApexEmitterValidateCallback(EmitterValidateCallback *callback) = 0;
00175
00177     PX_DEPRECATED virtual void      setObjectScale(float scale) = 0;
00178
00180     PX_DEPRECATED virtual float     getObjectScale(void) const = 0;
00181
00183     virtual void                    setCurrentScale(float scale) = 0;
00184
00186     virtual float                   getCurrentScale(void) const = 0;
00187
00188
00189 };
00190
00191 PX_POP_PACK
00192
00193 }
00194 } // end namespace nvidia
00195
00196 #endif // EMITTER_ACTOR_H
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: EmitterAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
EmitterAsset.h File Reference
#include "Apex.h"
#include "EmitterGeoms.h"

Go to the source code of this file.

Classes

class | nvidia::apex::EmitterAsset
APEX Emitter asset. Emits particles within some shape. More...
class | nvidia::apex::EmitterAssetAuthoring
APEX Emitter Asset Authoring. Used to create APEX Emitter assets. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | EMITTER_AUTHORING_TYPE_NAME "ApexEmitterAsset"

Define Documentation

#define EMITTER_AUTHORING_TYPE_NAME "ApexEmitterAsset"
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: EmitterAsset.h Source File

  • File List
  • File Members
EmitterAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EMITTER_ASSET_H
00031 #define EMITTER_ASSET_H
00032
00033 #include "Apex.h"
00034 #include "EmitterGeoms.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define EMITTER_AUTHORING_TYPE_NAME "ApexEmitterAsset"
00044
00045 class EmitterActor;
00046 class EmitterPreview;
00047 class EmitterLodParamDesc;
00048
00050 class EmitterAsset : public Asset
00051 {
00052 protected:
00053     virtual ~EmitterAsset() {}
00054
00055 public:
00056
00058     virtual EmitterGeomExplicit*    isExplicitGeom() = 0;
00059
00061     virtual const EmitterGeom*      getGeom() const = 0;
00062
00064     virtual const char*             getInstancedObjectEffectsAssetName(void) const = 0;
00065
00067     virtual const char*             getInstancedObjectSimulatorAssetName(void) const = 0;
00068
00070     virtual const char*             getInstancedObjectSimulatorTypeName(void) const = 0;
00071
00072     virtual const float &           getDensity() const = 0;
00073     virtual const float &           getRate() const = 0;
00074     virtual const PxVec3 &          getVelocityLow() const = 0;
00075     virtual const PxVec3 &          getVelocityHigh() const = 0;
00076     virtual const float &           getLifetimeLow() const = 0;
00077     virtual const float &           getLifetimeHigh() const = 0;
00078
00080     virtual uint32_t                getMaxSamples() const = 0;
00081
00086     virtual float                   getEmitDuration() const = 0;
00087
00089     virtual const EmitterLodParamDesc& getLodParamDesc() const = 0;
00090
00091 };
00092
00094 class EmitterAssetAuthoring : public AssetAuthoring
00095 {
00096 protected:
00097     virtual ~EmitterAssetAuthoring() {}
00098 };
00099
00100
00101 PX_POP_PACK
00102
00103 }
00104 } // end namespace nvidia
00105
00106 #endif // EMITTER_ASSET_H
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: EmitterGeoms.h File Reference

  • File List
  • File Members
Classes | Namespaces
EmitterGeoms.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::EmitterType
Emitter type. More...
class | nvidia::apex::EmitterGeom
Base class for all emitter shapes. More...
class | nvidia::apex::EmitterGeomSphereShell
Sphere shell shape for an emitter. It's a shape formed by the difference of two cocentered spheres. More...
class | nvidia::apex::EmitterGeomSphere
Spherical shape for an emitter. More...
class | nvidia::apex::EmitterGeomCylinder
Cylindrical shape for an emitter. More...
class | nvidia::apex::EmitterGeomBox
Box shape for an emitter. More...
class | nvidia::apex::EmitterGeomExplicit
Explicit geometry. Coordinates of each particle are given explicitly. More...
struct | nvidia::apex::EmitterGeomExplicit::PointParams
Point parameters. More...
struct | nvidia::apex::EmitterGeomExplicit::SphereParams
Sphere prameters. More...
struct | nvidia::apex::EmitterGeomExplicit::EllipsoidParams
Ellipsoid parameters. More...
struct | nvidia::apex::EmitterGeomExplicit::PointListData
Structure contains positions, velocities and user data for particles. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: EmitterGeoms.h Source File

  • File List
  • File Members
EmitterGeoms.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EMITTER_GEOMS_H
00031 #define EMITTER_GEOMS_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00043 struct EmitterType
00044 {
00046     enum Enum
00047     {
00048         ET_RATE = 0,
00049         ET_DENSITY_ONCE,
00050         ET_DENSITY_BRUSH,
00051         ET_FILL,
00052         ET_UNDEFINED,
00053     };
00054 };
00055
00056 class EmitterGeomBox;
00057 class EmitterGeomSphere;
00058 class EmitterGeomSphereShell;
00059 class EmitterGeomCylinder;
00060 class EmitterGeomExplicit;
00061
00063 class EmitterGeom
00064 {
00065 public:
00067     virtual void                            setEmitterType(EmitterType::Enum) = 0;
00068
00070     virtual EmitterType::Enum               getEmitterType() const = 0;
00071
00073     virtual const EmitterGeomBox*           isBoxGeom() const
00074     {
00075         return NULL;
00076     }
00077
00079     virtual const EmitterGeomSphere*        isSphereGeom() const
00080     {
00081         return NULL;
00082     }
00083
00085     virtual const EmitterGeomSphereShell*   isSphereShellGeom() const
00086     {
00087         return NULL;
00088     }
00089
00091     virtual const EmitterGeomCylinder*      isCylinderGeom() const
00092     {
00093         return NULL;
00094     }
00095
00097     virtual const EmitterGeomExplicit*      isExplicitGeom() const
00098     {
00099         return NULL;
00100     }
00101 };
00102
00104 class EmitterGeomSphereShell : public EmitterGeom
00105 {
00106 public:
00107
00109     virtual void    setRadius(float radius) = 0;
00110
00112     virtual float   getRadius() const = 0;
00113
00115     virtual void    setShellThickness(float thickness) = 0;
00116
00118     virtual float   getShellThickness() const = 0;
00119 };
00120
00122 class EmitterGeomSphere : public EmitterGeom
00123 {
00124 public:
00125
00127     virtual void    setRadius(float radius) = 0;
00128
00130     virtual float   getRadius() const = 0;
00131 };
00132
00134 class EmitterGeomCylinder : public EmitterGeom
00135 {
00136 public:
00137
00139     virtual void    setRadius(float radius) = 0;
00140
00142     virtual float   getRadius() const = 0;
00143
00145     virtual void    setHeight(float height) = 0;
00146
00148     virtual float   getHeight() const = 0;
00149 };
00150
00152 class EmitterGeomBox : public EmitterGeom
00153 {
00154 public:
00155
00157     virtual void    setExtents(const PxVec3& extents) = 0;
00158
00160     virtual PxVec3  getExtents() const = 0;
00161 };
00162
00164 class EmitterGeomExplicit : public EmitterGeom
00165 {
00166 public:
00167
00169     struct PointParams
00170     {
00171         PxVec3 position;
00172         bool doDetectOverlaps;
00173     };
00174
00176     struct SphereParams
00177     {
00178         PxVec3 center;
00179         float radius;
00180         bool doDetectOverlaps;
00181     };
00182
00184     struct EllipsoidParams
00185     {
00186         PxVec3 center;
00187         float radius;
00188         PxVec3 normal;
00189         float polarRadius;
00190         bool doDetectOverlaps;
00191     };
00192
00194     virtual void    resetParticleList() = 0;
00195
00202     virtual void    addParticleList(uint32_t count,
00203                                     const PointParams* params,
00204                                     const PxVec3* velocities = 0) = 0;
00205
00212     virtual void    addParticleList(uint32_t count,
00213                                     const PxVec3* positions,
00214                                     const PxVec3* velocities = 0) = 0;
00215
00217     struct PointListData
00218     {
00219         const void* positionStart;
00220         uint32_t    positionStrideBytes;
00221         const void* velocityStart;
00222         uint32_t    velocityStrideBytes;
00223         const void* userDataStart;
00224         uint32_t    userDataStrideBytes;
00225     };
00226
00233     virtual void    addParticleList(uint32_t count, const PointListData& data) = 0;
00234
00242     virtual void    addSphereList(uint32_t count,
00243                                   const SphereParams* params,
00244                                   const PxVec3* velocities = 0) = 0;
00245
00253     virtual void    addEllipsoidList(uint32_t count,
00254                                      const EllipsoidParams*  params,
00255                                      const PxVec3* velocities = 0) = 0;
00256
00265     virtual void    getParticleList(const PointParams* &params,
00266                                     uint32_t& numPoints,
00267                                     const PxVec3* &velocities,
00268                                     uint32_t& numVelocities) const = 0;
00269
00278     virtual void    getSphereList(const SphereParams* &params,
00279                                   uint32_t& numSpheres,
00280                                   const PxVec3* &velocities,
00281                                   uint32_t& numVelocities) const = 0;
00282
00291     virtual void    getEllipsoidList(const EllipsoidParams* &params,
00292                                      uint32_t& numEllipsoids,
00293                                      const PxVec3* &velocities,
00294                                      uint32_t& numVelocities) const = 0;
00295
00297     virtual uint32_t    getParticleCount() const = 0;
00298
00300     virtual PxVec3      getParticlePos(uint32_t index) const = 0;
00301
00303     virtual uint32_t    getSphereCount() const = 0;
00304
00306     virtual PxVec3      getSphereCenter(uint32_t index) const = 0;
00307
00309     virtual float       getSphereRadius(uint32_t index) const = 0;
00310
00312     virtual uint32_t    getEllipsoidCount() const = 0;
00313
00315     virtual PxVec3      getEllipsoidCenter(uint32_t index) const = 0;
00316
00318     virtual float       getEllipsoidRadius(uint32_t index) const = 0;
00319
00321     virtual PxVec3      getEllipsoidNormal(uint32_t index) const = 0;
00322
00324     virtual float       getEllipsoidPolarRadius(uint32_t index) const = 0;
00325
00327     virtual float       getDistance() const = 0;
00328 };
00329
00330
00331 PX_POP_PACK
00332
00333 }
00334 } // end namespace nvidia
00335
00336 #endif // EMITTER_GEOMS_H
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: EmitterLodParamDesc.h File Reference

  • File List
  • File Members
Classes | Namespaces
EmitterLodParamDesc.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::EmitterLodParamDesc
LOD parameters fro emitters. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: EmitterLodParamDesc.h Source File

  • File List
  • File Members
EmitterLodParamDesc.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EMITTER_LOD_PARAM_DESC_H
00031 #define EMITTER_LOD_PARAM_DESC_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00044 class EmitterLodParamDesc : public ApexDesc
00045 {
00046 public:
00047     float  maxDistance;
00048     float  distanceWeight;
00049     float  speedWeight;
00050     float  lifeWeight;
00051     float  separationWeight;
00052     float  bias;
00053
00057     PX_INLINE EmitterLodParamDesc() : ApexDesc()
00058     {
00059         init();
00060     }
00061
00065     PX_INLINE void setToDefault()
00066     {
00067         ApexDesc::setToDefault();
00068         init();
00069     }
00070
00074     PX_INLINE bool isValid() const
00075     {
00076         if (distanceWeight < 0.0f || speedWeight < 0.0f || lifeWeight < 0.0f)
00077         {
00078             return false;
00079         }
00080         if (separationWeight < 0.0f || maxDistance < 0.0f || bias < 0.0f)
00081         {
00082             return false;
00083         }
00084         return ApexDesc::isValid();
00085     }
00086
00090     enum ManifestVersions
00091     {
00092         initial,
00093
00094         count,
00095         current = count - 1
00096     };
00097
00098 private:
00099
00100     PX_INLINE void init()
00101     {
00102         // These defaults give you pure distance based LOD weighting
00103         maxDistance = 0.0f;
00104         distanceWeight = 1.0f;
00105         speedWeight = 0.0f;
00106         lifeWeight = 0.0f;
00107         separationWeight = 0.0f;
00108         bias = 1.0f;
00109     }
00110 };
00111
00112
00113 PX_POP_PACK
00114
00115 }
00116 } // end namespace nvidia
00117
00118 #endif // EMITTER_LOD_PARAM_DESC_H
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: EmitterPreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
EmitterPreview.h File Reference
#include "Apex.h"
#include "AssetPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::EmitterPreview

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: EmitterPreview.h Source File

  • File List
  • File Members
EmitterPreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EMITTER_PREVIEW_H
00031 #define EMITTER_PREVIEW_H
00032
00033 #include "Apex.h"
00034 #include "AssetPreview.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00046 class EmitterPreview : public AssetPreview
00047 {
00048 public:
00050     virtual void    drawEmitterPreview() = 0;
00052     virtual void    setScale(float scale) = 0;
00053
00054 protected:
00055     EmitterPreview() {}
00056 };
00057
00058
00059 PX_POP_PACK
00060
00061 }
00062 } // end namespace nvidia
00063
00064 #endif // EMITTER_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
EmitterActor.h [code]
EmitterAsset.h [code]
EmitterGeoms.h [code]
EmitterLodParamDesc.h [code]
EmitterPreview.h [code]
GroundEmitterActor.h [code]
GroundEmitterAsset.h [code]
GroundEmitterPreview.h [code]
ImpactEmitterActor.h [code]
ImpactEmitterAsset.h [code]
ImpactEmitterPreview.h [code]
ModuleEmitter.h [code]
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • addEllipsoidList() : nvidia::apex::EmitterGeomExplicit
  • addParticleList() : nvidia::apex::EmitterGeomExplicit
  • addSphereList() : nvidia::apex::EmitterGeomExplicit

- b -

  • bias : nvidia::apex::EmitterLodParamDesc

- c -

  • center : nvidia::apex::EmitterGeomExplicit::SphereParams , nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • count : nvidia::apex::EmitterLodParamDesc
  • current : nvidia::apex::EmitterLodParamDesc

- d -

  • distanceWeight : nvidia::apex::EmitterLodParamDesc
  • doDetectOverlaps
: nvidia::apex::EmitterGeomExplicit::PointParams
, nvidia::apex::EmitterGeomExplicit::EllipsoidParams
, nvidia::apex::EmitterGeomExplicit::SphereParams
  • drawEmitterPreview()
: nvidia::apex::GroundEmitterPreview
, nvidia::apex::EmitterPreview

- e -

  • emitAssetParticles() : nvidia::apex::EmitterActor
  • EmitterLodParamDesc() : nvidia::apex::EmitterLodParamDesc
  • EmitterPreview() : nvidia::apex::EmitterPreview
  • Enum : nvidia::apex::EmitterType
  • ET_DENSITY_BRUSH : nvidia::apex::EmitterType
  • ET_DENSITY_ONCE : nvidia::apex::EmitterType
  • ET_FILL : nvidia::apex::EmitterType
  • ET_RATE : nvidia::apex::EmitterType
  • ET_UNDEFINED : nvidia::apex::EmitterType

- g -

  • getActiveParticleCount() : nvidia::apex::EmitterActor
  • getAttachActor()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
  • getAttachRelativePose() : nvidia::apex::EmitterActor
  • getAttachRelativePosition() : nvidia::apex::GroundEmitterActor
  • getCurrentScale() : nvidia::apex::EmitterActor
  • getDensity()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::EmitterAsset
  • getDensityScale() : nvidia::apex::ModuleEmitter
  • getDistance() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidCenter() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidCount() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidList() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidNormal() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidPolarRadius() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidRadius() : nvidia::apex::EmitterGeomExplicit
  • getEmitAssetParticles() : nvidia::apex::EmitterActor
  • getEmitDuration() : nvidia::apex::EmitterAsset
  • getEmitterAsset()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
, nvidia::apex::ImpactEmitterActor
  • getEmitterType() : nvidia::apex::EmitterGeom
  • getExtents() : nvidia::apex::EmitterGeomBox
  • getGeom() : nvidia::apex::EmitterAsset
  • getGlobalPose() : nvidia::apex::EmitterActor
  • getGroundDensityScale() : nvidia::apex::ModuleEmitter
  • getHeight() : nvidia::apex::EmitterGeomCylinder
  • getInstancedObjectEffectsAssetName() : nvidia::apex::EmitterAsset
  • getInstancedObjectSimulatorAssetName() : nvidia::apex::EmitterAsset
  • getInstancedObjectSimulatorTypeName() : nvidia::apex::EmitterAsset
  • getLifetimeHigh()
: nvidia::apex::GroundEmitterAsset
, nvidia::apex::EmitterAsset
  • getLifetimeLow()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterAsset
  • getLodParamDesc()
: nvidia::apex::EmitterActor
, nvidia::apex::EmitterAsset
  • getMaterialLookupCallback() : nvidia::apex::GroundEmitterActor
  • getMaxRaycastsPerFrame()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::GroundEmitterAsset
  • getMaxSamples() : nvidia::apex::EmitterAsset
  • getObjectRadius() : nvidia::apex::EmitterActor
  • getObjectScale() : nvidia::apex::EmitterActor
  • getParticleCount() : nvidia::apex::EmitterGeomExplicit
  • getParticleList() : nvidia::apex::EmitterGeomExplicit
  • getParticlePos() : nvidia::apex::EmitterGeomExplicit
  • getPose() : nvidia::apex::GroundEmitterActor
  • getRadius()
: nvidia::apex::EmitterGeomSphere
, nvidia::apex::EmitterGeomCylinder
, nvidia::apex::GroundEmitterActor
, nvidia::apex::GroundEmitterAsset
, nvidia::apex::EmitterGeomSphereShell
  • getRate()
: nvidia::apex::EmitterAsset
, nvidia::apex::EmitterActor
  • getRateScale() : nvidia::apex::ModuleEmitter
  • getRaycastCollisionGroupMaskName() : nvidia::apex::GroundEmitterAsset
  • getRaycastCollisionGroups() : nvidia::apex::GroundEmitterActor
  • getRaycastHeight()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::GroundEmitterAsset
  • getSetNames() : nvidia::apex::ImpactEmitterAsset
  • getShellThickness() : nvidia::apex::EmitterGeomSphereShell
  • getSimParticlesCount() : nvidia::apex::EmitterActor
  • getSpawnHeight()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::GroundEmitterAsset
  • getSphereCenter() : nvidia::apex::EmitterGeomExplicit
  • getSphereCount() : nvidia::apex::EmitterGeomExplicit
  • getSphereList() : nvidia::apex::EmitterGeomExplicit
  • getSphereRadius() : nvidia::apex::EmitterGeomExplicit
  • getVelocityHigh()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterAsset
  • getVelocityLow()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterAsset
  • GroundEmitterAsset() : nvidia::apex::GroundEmitterAsset
  • GroundEmitterPreview() : nvidia::apex::GroundEmitterPreview

- i -

  • ImpactEmitterAsset() : nvidia::apex::ImpactEmitterAsset
  • ImpactEmitterPreview() : nvidia::apex::ImpactEmitterPreview
  • initial : nvidia::apex::EmitterLodParamDesc
  • isBoxGeom() : nvidia::apex::EmitterGeom
  • isCylinderGeom() : nvidia::apex::EmitterGeom
  • isEmitting() : nvidia::apex::EmitterActor
  • isExplicitGeom()
: nvidia::apex::EmitterGeom
, nvidia::apex::EmitterAsset
, nvidia::apex::EmitterActor
  • isSphereGeom() : nvidia::apex::EmitterGeom
  • isSphereShellGeom() : nvidia::apex::EmitterGeom
  • isValid() : nvidia::apex::EmitterLodParamDesc

- l -

  • lifeWeight : nvidia::apex::EmitterLodParamDesc

- m -

  • ManifestVersions : nvidia::apex::EmitterLodParamDesc
  • maxDistance : nvidia::apex::EmitterLodParamDesc

- n -

  • normal : nvidia::apex::EmitterGeomExplicit::EllipsoidParams

- o -

  • outMaterialID : nvidia::apex::MaterialLookupCallback::MaterialRequest

- p -

  • polarRadius : nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • position : nvidia::apex::EmitterGeomExplicit::PointParams
  • positionStart : nvidia::apex::EmitterGeomExplicit::PointListData
  • positionStrideBytes : nvidia::apex::EmitterGeomExplicit::PointListData

- q -

  • querySetID() : nvidia::apex::ImpactEmitterAsset

- r -

  • radius : nvidia::apex::EmitterGeomExplicit::SphereParams , nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • registerImpact() : nvidia::apex::ImpactEmitterActor
  • requestMaterialLookups() : nvidia::apex::MaterialLookupCallback
  • resetParticleList() : nvidia::apex::EmitterGeomExplicit

- s -

  • samplePosition : nvidia::apex::MaterialLookupCallback::MaterialRequest
  • separationWeight : nvidia::apex::EmitterLodParamDesc
  • setApexEmitterValidateCallback() : nvidia::apex::EmitterActor
  • setAttachActor()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
  • setAttachRelativePose() : nvidia::apex::EmitterActor
  • setAttachRelativePosition() : nvidia::apex::GroundEmitterActor
  • setCurrentPose() : nvidia::apex::EmitterActor
  • setCurrentPosition() : nvidia::apex::EmitterActor
  • setCurrentScale() : nvidia::apex::EmitterActor
  • setDensity()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
  • setDensityGridPosition() : nvidia::apex::EmitterActor
  • setDensityScale() : nvidia::apex::ModuleEmitter
  • setEmitterType() : nvidia::apex::EmitterGeom
  • setExtents() : nvidia::apex::EmitterGeomBox
  • setGroundDensityScale() : nvidia::apex::ModuleEmitter
  • setHeight() : nvidia::apex::EmitterGeomCylinder
  • setLifetimeHigh() : nvidia::apex::EmitterActor
  • setLifetimeLow() : nvidia::apex::EmitterActor
  • setLodParamDesc() : nvidia::apex::EmitterActor
  • setMaterialLookupCallback() : nvidia::apex::GroundEmitterActor
  • setMaxRaycastsPerFrame() : nvidia::apex::GroundEmitterActor
  • setObjectScale() : nvidia::apex::EmitterActor
  • setOverlapTestCollisionGroups() : nvidia::apex::EmitterActor
  • setPose() : nvidia::apex::GroundEmitterActor
  • setPreferredRenderVolume()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
, nvidia::apex::ImpactEmitterActor
  • setRadius()
: nvidia::apex::EmitterGeomCylinder
, nvidia::apex::GroundEmitterActor
, nvidia::apex::EmitterGeomSphere
, nvidia::apex::EmitterGeomSphereShell
  • setRate() : nvidia::apex::EmitterActor
  • setRateScale() : nvidia::apex::ModuleEmitter
  • setRaycastCollisionGroups() : nvidia::apex::GroundEmitterActor
  • setRaycastCollisionGroupsMask() : nvidia::apex::GroundEmitterActor
  • setRaycastHeight() : nvidia::apex::GroundEmitterActor
  • setScale()
: nvidia::apex::EmitterPreview
, nvidia::apex::GroundEmitterPreview
  • setShellThickness() : nvidia::apex::EmitterGeomSphereShell
  • setSpawnHeight() : nvidia::apex::GroundEmitterActor
  • setToDefault() : nvidia::apex::EmitterLodParamDesc
  • setVelocityHigh() : nvidia::apex::EmitterActor
  • setVelocityLow() : nvidia::apex::EmitterActor
  • speedWeight : nvidia::apex::EmitterLodParamDesc
  • startEmit() : nvidia::apex::EmitterActor
  • stopEmit() : nvidia::apex::EmitterActor

- u -

  • userDataStart : nvidia::apex::EmitterGeomExplicit::PointListData
  • userDataStrideBytes : nvidia::apex::EmitterGeomExplicit::PointListData

- v -

  • validateEmitterPosition() : nvidia::apex::EmitterActor::EmitterValidateCallback
  • velocityStart : nvidia::apex::EmitterGeomExplicit::PointListData
  • velocityStrideBytes : nvidia::apex::EmitterGeomExplicit::PointListData

- ~ -

  • ~EmitterActor() : nvidia::apex::EmitterActor
  • ~EmitterAsset() : nvidia::apex::EmitterAsset
  • ~EmitterAssetAuthoring() : nvidia::apex::EmitterAssetAuthoring
  • ~GroundEmitterActor() : nvidia::apex::GroundEmitterActor
  • ~GroundEmitterAsset() : nvidia::apex::GroundEmitterAsset
  • ~GroundEmitterAssetAuthoring() : nvidia::apex::GroundEmitterAssetAuthoring
  • ~ImpactEmitterActor() : nvidia::apex::ImpactEmitterActor
  • ~ImpactEmitterAsset() : nvidia::apex::ImpactEmitterAsset
  • ~ImpactEmitterAssetAuthoring() : nvidia::apex::ImpactEmitterAssetAuthoring
  • ~MaterialLookupCallback() : nvidia::apex::MaterialLookupCallback
  • ~ModuleEmitter() : nvidia::apex::ModuleEmitter
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Class Members - Enumerations

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Enum : nvidia::apex::EmitterType
  • ManifestVersions : nvidia::apex::EmitterLodParamDesc
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Class Members - Enumerator

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • count : nvidia::apex::EmitterLodParamDesc
  • current : nvidia::apex::EmitterLodParamDesc
  • ET_DENSITY_BRUSH : nvidia::apex::EmitterType
  • ET_DENSITY_ONCE : nvidia::apex::EmitterType
  • ET_FILL : nvidia::apex::EmitterType
  • ET_RATE : nvidia::apex::EmitterType
  • ET_UNDEFINED : nvidia::apex::EmitterType
  • initial : nvidia::apex::EmitterLodParamDesc
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • d
  • e
  • g
  • i
  • q
  • r
  • s
  • v
  • ~

- a -

  • addEllipsoidList() : nvidia::apex::EmitterGeomExplicit
  • addParticleList() : nvidia::apex::EmitterGeomExplicit
  • addSphereList() : nvidia::apex::EmitterGeomExplicit

- d -

  • drawEmitterPreview()
: nvidia::apex::EmitterPreview
, nvidia::apex::GroundEmitterPreview

- e -

  • emitAssetParticles() : nvidia::apex::EmitterActor
  • EmitterLodParamDesc() : nvidia::apex::EmitterLodParamDesc
  • EmitterPreview() : nvidia::apex::EmitterPreview

- g -

  • getActiveParticleCount() : nvidia::apex::EmitterActor
  • getAttachActor()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
  • getAttachRelativePose() : nvidia::apex::EmitterActor
  • getAttachRelativePosition() : nvidia::apex::GroundEmitterActor
  • getCurrentScale() : nvidia::apex::EmitterActor
  • getDensity()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::EmitterAsset
  • getDensityScale() : nvidia::apex::ModuleEmitter
  • getDistance() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidCenter() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidCount() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidList() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidNormal() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidPolarRadius() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidRadius() : nvidia::apex::EmitterGeomExplicit
  • getEmitAssetParticles() : nvidia::apex::EmitterActor
  • getEmitDuration() : nvidia::apex::EmitterAsset
  • getEmitterAsset()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
, nvidia::apex::ImpactEmitterActor
  • getEmitterType() : nvidia::apex::EmitterGeom
  • getExtents() : nvidia::apex::EmitterGeomBox
  • getGeom() : nvidia::apex::EmitterAsset
  • getGlobalPose() : nvidia::apex::EmitterActor
  • getGroundDensityScale() : nvidia::apex::ModuleEmitter
  • getHeight() : nvidia::apex::EmitterGeomCylinder
  • getInstancedObjectEffectsAssetName() : nvidia::apex::EmitterAsset
  • getInstancedObjectSimulatorAssetName() : nvidia::apex::EmitterAsset
  • getInstancedObjectSimulatorTypeName() : nvidia::apex::EmitterAsset
  • getLifetimeHigh()
: nvidia::apex::GroundEmitterAsset
, nvidia::apex::EmitterAsset
  • getLifetimeLow()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterAsset
  • getLodParamDesc()
: nvidia::apex::EmitterActor
, nvidia::apex::EmitterAsset
  • getMaterialLookupCallback() : nvidia::apex::GroundEmitterActor
  • getMaxRaycastsPerFrame()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::GroundEmitterAsset
  • getMaxSamples() : nvidia::apex::EmitterAsset
  • getObjectRadius() : nvidia::apex::EmitterActor
  • getObjectScale() : nvidia::apex::EmitterActor
  • getParticleCount() : nvidia::apex::EmitterGeomExplicit
  • getParticleList() : nvidia::apex::EmitterGeomExplicit
  • getParticlePos() : nvidia::apex::EmitterGeomExplicit
  • getPose() : nvidia::apex::GroundEmitterActor
  • getRadius()
: nvidia::apex::EmitterGeomSphere
, nvidia::apex::EmitterGeomCylinder
, nvidia::apex::GroundEmitterActor
, nvidia::apex::GroundEmitterAsset
, nvidia::apex::EmitterGeomSphereShell
  • getRate()
: nvidia::apex::EmitterAsset
, nvidia::apex::EmitterActor
  • getRateScale() : nvidia::apex::ModuleEmitter
  • getRaycastCollisionGroupMaskName() : nvidia::apex::GroundEmitterAsset
  • getRaycastCollisionGroups() : nvidia::apex::GroundEmitterActor
  • getRaycastHeight()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::GroundEmitterAsset
  • getSetNames() : nvidia::apex::ImpactEmitterAsset
  • getShellThickness() : nvidia::apex::EmitterGeomSphereShell
  • getSimParticlesCount() : nvidia::apex::EmitterActor
  • getSpawnHeight()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::GroundEmitterAsset
  • getSphereCenter() : nvidia::apex::EmitterGeomExplicit
  • getSphereCount() : nvidia::apex::EmitterGeomExplicit
  • getSphereList() : nvidia::apex::EmitterGeomExplicit
  • getSphereRadius() : nvidia::apex::EmitterGeomExplicit
  • getVelocityHigh()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterAsset
  • getVelocityLow()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterAsset
  • GroundEmitterAsset() : nvidia::apex::GroundEmitterAsset
  • GroundEmitterPreview() : nvidia::apex::GroundEmitterPreview

- i -

  • ImpactEmitterAsset() : nvidia::apex::ImpactEmitterAsset
  • ImpactEmitterPreview() : nvidia::apex::ImpactEmitterPreview
  • isBoxGeom() : nvidia::apex::EmitterGeom
  • isCylinderGeom() : nvidia::apex::EmitterGeom
  • isEmitting() : nvidia::apex::EmitterActor
  • isExplicitGeom()
: nvidia::apex::EmitterAsset
, nvidia::apex::EmitterGeom
, nvidia::apex::EmitterActor
  • isSphereGeom() : nvidia::apex::EmitterGeom
  • isSphereShellGeom() : nvidia::apex::EmitterGeom
  • isValid() : nvidia::apex::EmitterLodParamDesc

- q -

  • querySetID() : nvidia::apex::ImpactEmitterAsset

- r -

  • registerImpact() : nvidia::apex::ImpactEmitterActor
  • requestMaterialLookups() : nvidia::apex::MaterialLookupCallback
  • resetParticleList() : nvidia::apex::EmitterGeomExplicit

- s -

  • setApexEmitterValidateCallback() : nvidia::apex::EmitterActor
  • setAttachActor()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
  • setAttachRelativePose() : nvidia::apex::EmitterActor
  • setAttachRelativePosition() : nvidia::apex::GroundEmitterActor
  • setCurrentPose() : nvidia::apex::EmitterActor
  • setCurrentPosition() : nvidia::apex::EmitterActor
  • setCurrentScale() : nvidia::apex::EmitterActor
  • setDensity()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
  • setDensityGridPosition() : nvidia::apex::EmitterActor
  • setDensityScale() : nvidia::apex::ModuleEmitter
  • setEmitterType() : nvidia::apex::EmitterGeom
  • setExtents() : nvidia::apex::EmitterGeomBox
  • setGroundDensityScale() : nvidia::apex::ModuleEmitter
  • setHeight() : nvidia::apex::EmitterGeomCylinder
  • setLifetimeHigh() : nvidia::apex::EmitterActor
  • setLifetimeLow() : nvidia::apex::EmitterActor
  • setLodParamDesc() : nvidia::apex::EmitterActor
  • setMaterialLookupCallback() : nvidia::apex::GroundEmitterActor
  • setMaxRaycastsPerFrame() : nvidia::apex::GroundEmitterActor
  • setObjectScale() : nvidia::apex::EmitterActor
  • setOverlapTestCollisionGroups() : nvidia::apex::EmitterActor
  • setPose() : nvidia::apex::GroundEmitterActor
  • setPreferredRenderVolume()
: nvidia::apex::ImpactEmitterActor
, nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
  • setRadius()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::EmitterGeomSphereShell
, nvidia::apex::EmitterGeomSphere
, nvidia::apex::EmitterGeomCylinder
  • setRate() : nvidia::apex::EmitterActor
  • setRateScale() : nvidia::apex::ModuleEmitter
  • setRaycastCollisionGroups() : nvidia::apex::GroundEmitterActor
  • setRaycastCollisionGroupsMask() : nvidia::apex::GroundEmitterActor
  • setRaycastHeight() : nvidia::apex::GroundEmitterActor
  • setScale()
: nvidia::apex::GroundEmitterPreview
, nvidia::apex::EmitterPreview
  • setShellThickness() : nvidia::apex::EmitterGeomSphereShell
  • setSpawnHeight() : nvidia::apex::GroundEmitterActor
  • setToDefault() : nvidia::apex::EmitterLodParamDesc
  • setVelocityHigh() : nvidia::apex::EmitterActor
  • setVelocityLow() : nvidia::apex::EmitterActor
  • startEmit() : nvidia::apex::EmitterActor
  • stopEmit() : nvidia::apex::EmitterActor

- v -

  • validateEmitterPosition() : nvidia::apex::EmitterActor::EmitterValidateCallback

- ~ -

  • ~EmitterActor() : nvidia::apex::EmitterActor
  • ~EmitterAsset() : nvidia::apex::EmitterAsset
  • ~EmitterAssetAuthoring() : nvidia::apex::EmitterAssetAuthoring
  • ~GroundEmitterActor() : nvidia::apex::GroundEmitterActor
  • ~GroundEmitterAsset() : nvidia::apex::GroundEmitterAsset
  • ~GroundEmitterAssetAuthoring() : nvidia::apex::GroundEmitterAssetAuthoring
  • ~ImpactEmitterActor() : nvidia::apex::ImpactEmitterActor
  • ~ImpactEmitterAsset() : nvidia::apex::ImpactEmitterAsset
  • ~ImpactEmitterAssetAuthoring() : nvidia::apex::ImpactEmitterAssetAuthoring
  • ~MaterialLookupCallback() : nvidia::apex::MaterialLookupCallback
  • ~ModuleEmitter() : nvidia::apex::ModuleEmitter
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • bias : nvidia::apex::EmitterLodParamDesc
  • center : nvidia::apex::EmitterGeomExplicit::SphereParams , nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • distanceWeight : nvidia::apex::EmitterLodParamDesc
  • doDetectOverlaps
: nvidia::apex::EmitterGeomExplicit::EllipsoidParams
, nvidia::apex::EmitterGeomExplicit::SphereParams
, nvidia::apex::EmitterGeomExplicit::PointParams
  • lifeWeight : nvidia::apex::EmitterLodParamDesc
  • maxDistance : nvidia::apex::EmitterLodParamDesc
  • normal : nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • outMaterialID : nvidia::apex::MaterialLookupCallback::MaterialRequest
  • polarRadius : nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • position : nvidia::apex::EmitterGeomExplicit::PointParams
  • positionStart : nvidia::apex::EmitterGeomExplicit::PointListData
  • positionStrideBytes : nvidia::apex::EmitterGeomExplicit::PointListData
  • radius : nvidia::apex::EmitterGeomExplicit::SphereParams , nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • samplePosition : nvidia::apex::MaterialLookupCallback::MaterialRequest
  • separationWeight : nvidia::apex::EmitterLodParamDesc
  • speedWeight : nvidia::apex::EmitterLodParamDesc
  • userDataStart : nvidia::apex::EmitterGeomExplicit::PointListData
  • userDataStrideBytes : nvidia::apex::EmitterGeomExplicit::PointListData
  • velocityStart : nvidia::apex::EmitterGeomExplicit::PointListData
  • velocityStrideBytes : nvidia::apex::EmitterGeomExplicit::PointListData
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: File Members

  • File List
  • File Members
  • All
  • Defines
Here is a list of all file members with links to the files they belong to:
  • EMITTER_AUTHORING_TYPE_NAME : EmitterAsset.h
  • GROUND_EMITTER_AUTHORING_TYPE_NAME : GroundEmitterAsset.h
  • IMPACT_EMITTER_AUTHORING_TYPE_NAME : ImpactEmitterAsset.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: File Members

  • File List
  • File Members
  • All
  • Defines
  • EMITTER_AUTHORING_TYPE_NAME : EmitterAsset.h
  • GROUND_EMITTER_AUTHORING_TYPE_NAME : GroundEmitterAsset.h
  • IMPACT_EMITTER_AUTHORING_TYPE_NAME : ImpactEmitterAsset.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: GroundEmitterActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
GroundEmitterActor.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::MaterialLookupCallback
a user calback interface used to map raycast hitpoints to material ID If an instance of this class is registered with a ground emitter actor, the actor will call requestMaterialLookups() in lieu of doing raycasts. The call will occur from within the scope of the ApexScene thread, so the callback must be thread safe. More...
struct | nvidia::apex::MaterialLookupCallback::MaterialRequest
Material request structure. More...
class | nvidia::apex::GroundEmitterActor
Ground Emitter actor. Uses raycasts against ground to spawn particles. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: GroundEmitterActor.h Source File

  • File List
  • File Members
GroundEmitterActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef GROUND_EMITTER_ACTOR_H
00031 #define GROUND_EMITTER_ACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class GroundEmitterAsset;
00044 class RenderVolume;
00045
00052 class MaterialLookupCallback
00053 {
00054 public:
00056     struct MaterialRequest
00057     {
00058         PxVec3      samplePosition;
00059         uint32_t    outMaterialID;
00060     };
00061
00067     virtual void requestMaterialLookups(uint32_t requestCount, MaterialRequest* reqList) = 0;
00068
00069     virtual ~MaterialLookupCallback() {}
00070 };
00071
00073 class GroundEmitterActor : public Actor
00074 {
00075 protected:
00076     virtual ~GroundEmitterActor() {}
00077
00078 public:
00082     virtual GroundEmitterAsset*     getEmitterAsset() const = 0;
00083
00087     virtual const PxMat44           getPose() const = 0;
00091     virtual void                    setPose(const PxMat44& pos) = 0;
00092
00094     virtual void                    setMaterialLookupCallback(MaterialLookupCallback*) = 0;
00095
00097     virtual MaterialLookupCallback* getMaterialLookupCallback() const = 0;
00098
00103     virtual void                    setAttachActor(PxActor*) = 0;
00104
00108     virtual void                    setAttachRelativePosition(const PxVec3& pos) = 0;
00109
00111     virtual const PxActor*          getAttachActor() const = 0;
00112
00114     virtual const PxVec3&           getAttachRelativePosition() const = 0;
00115
00116     /* Override some asset settings at run time */
00117
00119     virtual void                    setDensity(const float&) = 0;
00120
00122     virtual void                    setRadius(float) = 0;
00123
00125     virtual void                    setMaxRaycastsPerFrame(uint32_t) = 0;
00126
00128     virtual void                    setRaycastHeight(float) = 0;
00129
00136     virtual void                    setSpawnHeight(float) = 0;
00137
00139     virtual const float &           getDensity() const = 0;
00140
00142     virtual float                   getRadius() const = 0;
00143
00145     virtual uint32_t                getMaxRaycastsPerFrame() const = 0;
00146
00148     virtual float                   getRaycastHeight() const = 0;
00149
00155     virtual float                   getSpawnHeight() const = 0;
00156
00158     virtual void                    setRaycastCollisionGroups(uint32_t) = 0;
00159
00161     virtual void                    setRaycastCollisionGroupsMask(physx::PxFilterData*) = 0;
00162
00163
00165     virtual uint32_t                getRaycastCollisionGroups() const = 0;
00166
00169     virtual void                    setPreferredRenderVolume(RenderVolume* volume) = 0;
00170 };
00171
00172
00173 PX_POP_PACK
00174
00175 }
00176 } // end namespace nvidia
00177
00178 #endif // GROUND_EMITTER_ACTOR_H
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: GroundEmitterAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
GroundEmitterAsset.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::GroundEmitterAsset
Ground emitter asset. Used to create Ground emitter actors with specific properties. More...
class | nvidia::apex::GroundEmitterAssetAuthoring
Ground emitter authoring class. Used to create Ground emitter assets. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | GROUND_EMITTER_AUTHORING_TYPE_NAME "GroundEmitterAsset"

Define Documentation

#define GROUND_EMITTER_AUTHORING_TYPE_NAME "GroundEmitterAsset"
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: GroundEmitterAsset.h Source File

  • File List
  • File Members
GroundEmitterAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef GROUND_EMITTER_ASSET_H
00031 #define GROUND_EMITTER_ASSET_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define GROUND_EMITTER_AUTHORING_TYPE_NAME "GroundEmitterAsset"
00044
00046 class GroundEmitterAsset : public Asset
00047 {
00048 protected:
00049     PX_INLINE GroundEmitterAsset() {}
00050     virtual ~GroundEmitterAsset() {}
00051
00052 public:
00053
00055     virtual const PxVec3 &          getVelocityLow() const = 0;
00056
00058     virtual const PxVec3 &          getVelocityHigh() const = 0;
00059
00061     virtual const float &           getLifetimeLow() const = 0;
00062
00064     virtual const float &           getLifetimeHigh() const = 0;
00065
00067     virtual float                   getRadius() const = 0;
00068
00070     virtual uint32_t                getMaxRaycastsPerFrame() const = 0;
00071
00073     virtual float                   getRaycastHeight() const = 0;
00074
00080     virtual float                   getSpawnHeight() const = 0;
00081
00083     virtual const char*             getRaycastCollisionGroupMaskName() const = 0;
00084 };
00085
00087 class GroundEmitterAssetAuthoring : public AssetAuthoring
00088 {
00089 protected:
00090     virtual ~GroundEmitterAssetAuthoring() {}
00091 };
00092
00093
00094 PX_POP_PACK
00095
00096 }
00097 } // end namespace nvidia
00098
00099 #endif // GROUND_EMITTER_ASSET_H
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: GroundEmitterPreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
GroundEmitterPreview.h File Reference
#include "Apex.h"
#include "AssetPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::GroundEmitterPreview
Ground emitter preview class. Use for preview rendering. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: GroundEmitterPreview.h Source File

  • File List
  • File Members
GroundEmitterPreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef GROUND_EMITTER_PREVIEW_H
00031 #define GROUND_EMITTER_PREVIEW_H
00032
00033 #include "Apex.h"
00034 #include "AssetPreview.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041
00042 PX_PUSH_PACK_DEFAULT
00043
00045 class GroundEmitterPreview : public AssetPreview
00046 {
00047 public:
00049     virtual void    drawEmitterPreview() = 0;
00051     virtual void    setScale(float scale) = 0;
00052
00053 protected:
00054     GroundEmitterPreview() {}
00055 };
00056
00057
00058 PX_POP_PACK
00059
00060 }
00061 } // end namespace nvidia
00062
00063 #endif // GROUND_EMITTER_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Class Hierarchy

  • Class List
  • Class Hierarchy
  • Class Members
Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
  • nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • nvidia::apex::EmitterActor
  • nvidia::apex::EmitterAsset
  • nvidia::apex::EmitterAssetAuthoring
  • nvidia::apex::EmitterGeom
    • nvidia::apex::EmitterGeomBox
    • nvidia::apex::EmitterGeomCylinder
    • nvidia::apex::EmitterGeomExplicit
    • nvidia::apex::EmitterGeomSphere
    • nvidia::apex::EmitterGeomSphereShell
  • nvidia::apex::EmitterLodParamDesc
  • nvidia::apex::EmitterPreview
  • nvidia::apex::EmitterType
  • nvidia::apex::EmitterActor::EmitterValidateCallback
  • nvidia::apex::GroundEmitterActor
  • nvidia::apex::GroundEmitterAsset
  • nvidia::apex::GroundEmitterAssetAuthoring
  • nvidia::apex::GroundEmitterPreview
  • nvidia::apex::ImpactEmitterActor
  • nvidia::apex::ImpactEmitterAsset
  • nvidia::apex::ImpactEmitterAssetAuthoring
  • nvidia::apex::ImpactEmitterPreview
  • nvidia::apex::MaterialLookupCallback
  • nvidia::apex::MaterialLookupCallback::MaterialRequest
  • nvidia::apex::ModuleEmitter
  • nvidia::apex::EmitterGeomExplicit::PointListData
  • nvidia::apex::EmitterGeomExplicit::PointParams
  • nvidia::apex::EmitterGeomExplicit::SphereParams
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: ImpactEmitterActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
ImpactEmitterActor.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ImpactEmitterActor
Impact emitter actor. Emits particles at impact places. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: ImpactEmitterActor.h Source File

  • File List
  • File Members
ImpactEmitterActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IMPACT_EMITTER_ACTOR_H
00031 #define IMPACT_EMITTER_ACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class ImpactEmitterAsset;
00044 class RenderVolume;
00045
00047 class ImpactEmitterActor : public Actor
00048 {
00049 protected:
00050     virtual ~ImpactEmitterActor() {}
00051
00052 public:
00054     virtual ImpactEmitterAsset*     getEmitterAsset() const = 0;
00055
00065     virtual void registerImpact(const PxVec3& hitPos, const PxVec3& hitDir, const PxVec3& surfNorm, uint32_t setID) = 0;
00066
00069     virtual void setPreferredRenderVolume(RenderVolume* volume) = 0;
00070 };
00071
00072
00073 PX_POP_PACK
00074
00075 }
00076 } // end namespace nvidia
00077
00078 #endif // IMPACT_EMITTER_ACTOR_H
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: ImpactEmitterAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
ImpactEmitterAsset.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ImpactEmitterAsset
Impact emitter asset class. More...
class | nvidia::apex::ImpactEmitterAssetAuthoring
Impact emitter asset authoring. Used to create Impact Emitter assets. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | IMPACT_EMITTER_AUTHORING_TYPE_NAME "ImpactEmitterAsset"

Define Documentation

#define IMPACT_EMITTER_AUTHORING_TYPE_NAME "ImpactEmitterAsset"
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: ImpactEmitterAsset.h Source File

  • File List
  • File Members
ImpactEmitterAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IMPACT_EMITTER_ASSET_H
00031 #define IMPACT_EMITTER_ASSET_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define IMPACT_EMITTER_AUTHORING_TYPE_NAME "ImpactEmitterAsset"
00044
00045 class ImpactEmitterActor;
00046
00048 class ImpactEmitterAsset : public Asset
00049 {
00050 protected:
00051     PX_INLINE ImpactEmitterAsset() {}
00052     virtual ~ImpactEmitterAsset() {}
00053
00054 public:
00056     virtual uint32_t            querySetID(const char* setName) = 0;
00057
00063     virtual void                getSetNames(const char** inOutSetNames, uint32_t& nameCount) const = 0;
00064 };
00065
00067 class ImpactEmitterAssetAuthoring : public AssetAuthoring
00068 {
00069 protected:
00070     virtual ~ImpactEmitterAssetAuthoring() {}
00071
00072 public:
00073 };
00074
00075
00076 PX_POP_PACK
00077
00078 }
00079 } // end namespace nvidia
00080
00081 #endif // IMPACT_EMITTER_ASSET_H
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: ImpactEmitterPreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
ImpactEmitterPreview.h File Reference
#include "Apex.h"
#include "AssetPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ImpactEmitterPreview
Impact emitter preview. Used for preview rendering of the emitter actors. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: ImpactEmitterPreview.h Source File

  • File List
  • File Members
ImpactEmitterPreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IMPACT_EMITTER_PREVIEW_H
00031 #define IMPACT_EMITTER_PREVIEW_H
00032
00033 #include "Apex.h"
00034 #include "AssetPreview.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041
00042 PX_PUSH_PACK_DEFAULT
00043
00045 class ImpactEmitterPreview : public AssetPreview
00046 {
00047 public:
00048     /* No need to add any functionality here */
00049
00050 protected:
00051     ImpactEmitterPreview() {}
00052 };
00053
00054
00055 PX_POP_PACK
00056
00057 }
00058 } // end namespace nvidia
00059
00060 #endif // IMPACT_EMITTER_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Main Page

APEX Emitter Module Documentation
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: ModuleEmitter.h File Reference

  • File List
  • File Members
Classes | Namespaces
ModuleEmitter.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ModuleEmitter
An APEX Module that provides generic Emitter classes. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: ModuleEmitter.h Source File

  • File List
  • File Members
ModuleEmitter.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_EMITTER_H
00031 #define MODULE_EMITTER_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class EmitterAsset;
00044 class EmitterAssetAuthoring;
00045
00046 class GroundEmitterAsset;
00047 class GroundEmitterAssetAuthoring;
00048
00049 class ImpactEmitterAsset;
00050 class ImpactEmitterAssetAuthoring;
00051
00052
00056 class ModuleEmitter : public Module
00057 {
00058 protected:
00059     virtual ~ModuleEmitter() {}
00060
00061 public:
00062
00064     virtual float   getRateScale() const = 0;
00065
00067     virtual float   getDensityScale() const = 0;
00068
00070     virtual float   getGroundDensityScale() const = 0;
00071
00073     virtual void    setRateScale(float rateScale) = 0;
00074
00076     virtual void    setDensityScale(float densityScale) = 0;
00077
00079     virtual void    setGroundDensityScale(float groundDensityScale) = 0;
00080 };
00081
00082
00083
00084 PX_POP_PACK
00085
00086 }
00087 } // end namespace nvidia
00088
00089 #endif // MODULE_EMITTER_H
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia Namespace Reference

  • Namespace List
Namespaces
nvidia Namespace Reference

Namespaces

namespace apex
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex Namespace Reference

  • Namespace List
  • nvidia
  • apex
Classes
nvidia::apex Namespace Reference

Classes

class | EmitterActor
Apex emitter actor class. Emits particles within a given shape. More...
class | EmitterAsset
APEX Emitter asset. Emits particles within some shape. More...
class | EmitterAssetAuthoring
APEX Emitter Asset Authoring. Used to create APEX Emitter assets. More...
struct | EmitterType
Emitter type. More...
class | EmitterGeom
Base class for all emitter shapes. More...
class | EmitterGeomSphereShell
Sphere shell shape for an emitter. It's a shape formed by the difference of two cocentered spheres. More...
class | EmitterGeomSphere
Spherical shape for an emitter. More...
class | EmitterGeomCylinder
Cylindrical shape for an emitter. More...
class | EmitterGeomBox
Box shape for an emitter. More...
class | EmitterGeomExplicit
Explicit geometry. Coordinates of each particle are given explicitly. More...
class | EmitterLodParamDesc
LOD parameters fro emitters. More...
class | EmitterPreview
class | MaterialLookupCallback
a user calback interface used to map raycast hitpoints to material ID If an instance of this class is registered with a ground emitter actor, the actor will call requestMaterialLookups() in lieu of doing raycasts. The call will occur from within the scope of the ApexScene thread, so the callback must be thread safe. More...
class | GroundEmitterActor
Ground Emitter actor. Uses raycasts against ground to spawn particles. More...
class | GroundEmitterAsset
Ground emitter asset. Used to create Ground emitter actors with specific properties. More...
class | GroundEmitterAssetAuthoring
Ground emitter authoring class. Used to create Ground emitter assets. More...
class | GroundEmitterPreview
Ground emitter preview class. Use for preview rendering. More...
class | ImpactEmitterActor
Impact emitter actor. Emits particles at impact places. More...
class | ImpactEmitterAsset
Impact emitter asset class. More...
class | ImpactEmitterAssetAuthoring
Impact emitter asset authoring. Used to create Impact Emitter assets. More...
class | ImpactEmitterPreview
Impact emitter preview. Used for preview rendering of the emitter actors. More...
class | ModuleEmitter
An APEX Module that provides generic Emitter classes. More...
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Namespace List

  • Namespace List
Namespace List
Here is a list of all namespaces with brief descriptions:
nvidia
nvidia::apex
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterGeomExplicit::EllipsoidParams Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • EllipsoidParams
Public Attributes
nvidia::apex::EmitterGeomExplicit::EllipsoidParams Struct Reference

Ellipsoid parameters. More...

#include <EmitterGeoms.h>

List of all members.

Public Attributes

PxVec3 | center
Ellipsoid center.
float | radius
Ellipsoid radius.
PxVec3 | normal
Ellipsoid normal.
float | polarRadius
Ellipsoid polar radius.
bool | doDetectOverlaps
Should detect overlap.

Detailed Description

Ellipsoid parameters.

Member Data Documentation

PxVec3 nvidia::apex::EmitterGeomExplicit::EllipsoidParams::center

Ellipsoid center.

bool nvidia::apex::EmitterGeomExplicit::EllipsoidParams::doDetectOverlaps

Should detect overlap.

PxVec3 nvidia::apex::EmitterGeomExplicit::EllipsoidParams::normal

Ellipsoid normal.

float nvidia::apex::EmitterGeomExplicit::EllipsoidParams::polarRadius

Ellipsoid polar radius.

float nvidia::apex::EmitterGeomExplicit::EllipsoidParams::radius

Ellipsoid radius.

The documentation for this struct was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • EllipsoidParams
nvidia::apex::EmitterGeomExplicit::EllipsoidParams Member List
This is the complete list of members for nvidia::apex::EmitterGeomExplicit::EllipsoidParams, including all inherited members.
center | nvidia::apex::EmitterGeomExplicit::EllipsoidParams
doDetectOverlaps | nvidia::apex::EmitterGeomExplicit::EllipsoidParams
normal | nvidia::apex::EmitterGeomExplicit::EllipsoidParams
polarRadius | nvidia::apex::EmitterGeomExplicit::EllipsoidParams
radius | nvidia::apex::EmitterGeomExplicit::EllipsoidParams
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterGeomExplicit::PointListData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • PointListData
Public Attributes
nvidia::apex::EmitterGeomExplicit::PointListData Struct Reference

Structure contains positions, velocities and user data for particles. More...

#include <EmitterGeoms.h>

List of all members.

Public Attributes

const void * | positionStart
Pointer to first position.
uint32_t | positionStrideBytes
The stride between position vectors.
const void * | velocityStart
Pointer to first velocity.
uint32_t | velocityStrideBytes
The stride between velocity vectors.
const void * | userDataStart
Pointer to first instance of user data.
uint32_t | userDataStrideBytes
The stride between instances of user data.

Detailed Description

Structure contains positions, velocities and user data for particles.

Member Data Documentation

const void* nvidia::apex::EmitterGeomExplicit::PointListData::positionStart

Pointer to first position.

uint32_t nvidia::apex::EmitterGeomExplicit::PointListData::positionStrideBytes

The stride between position vectors.

const void* nvidia::apex::EmitterGeomExplicit::PointListData::userDataStart

Pointer to first instance of user data.

uint32_t nvidia::apex::EmitterGeomExplicit::PointListData::userDataStrideBytes

The stride between instances of user data.

const void* nvidia::apex::EmitterGeomExplicit::PointListData::velocityStart

Pointer to first velocity.

uint32_t nvidia::apex::EmitterGeomExplicit::PointListData::velocityStrideBytes

The stride between velocity vectors.

The documentation for this struct was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • PointListData
nvidia::apex::EmitterGeomExplicit::PointListData Member List
This is the complete list of members for nvidia::apex::EmitterGeomExplicit::PointListData, including all inherited members.
positionStart | nvidia::apex::EmitterGeomExplicit::PointListData
positionStrideBytes | nvidia::apex::EmitterGeomExplicit::PointListData
userDataStart | nvidia::apex::EmitterGeomExplicit::PointListData
userDataStrideBytes | nvidia::apex::EmitterGeomExplicit::PointListData
velocityStart | nvidia::apex::EmitterGeomExplicit::PointListData
velocityStrideBytes | nvidia::apex::EmitterGeomExplicit::PointListData
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterGeomExplicit::PointParams Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • PointParams
Public Attributes
nvidia::apex::EmitterGeomExplicit::PointParams Struct Reference

Point parameters. More...

#include <EmitterGeoms.h>

List of all members.

Public Attributes

PxVec3 | position
Point position.
bool | doDetectOverlaps
Should detect overlap.

Detailed Description

Point parameters.

Member Data Documentation

bool nvidia::apex::EmitterGeomExplicit::PointParams::doDetectOverlaps

Should detect overlap.

PxVec3 nvidia::apex::EmitterGeomExplicit::PointParams::position

Point position.

The documentation for this struct was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • PointParams
nvidia::apex::EmitterGeomExplicit::PointParams Member List
This is the complete list of members for nvidia::apex::EmitterGeomExplicit::PointParams, including all inherited members.
doDetectOverlaps | nvidia::apex::EmitterGeomExplicit::PointParams
position | nvidia::apex::EmitterGeomExplicit::PointParams
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterGeomExplicit::SphereParams Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • SphereParams
Public Attributes
nvidia::apex::EmitterGeomExplicit::SphereParams Struct Reference

Sphere prameters. More...

#include <EmitterGeoms.h>

List of all members.

Public Attributes

PxVec3 | center
Sphere center.
float | radius
Sphere radius.
bool | doDetectOverlaps
Should detect overlap.

Detailed Description

Sphere prameters.

Member Data Documentation

PxVec3 nvidia::apex::EmitterGeomExplicit::SphereParams::center

Sphere center.

bool nvidia::apex::EmitterGeomExplicit::SphereParams::doDetectOverlaps

Should detect overlap.

float nvidia::apex::EmitterGeomExplicit::SphereParams::radius

Sphere radius.

The documentation for this struct was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • SphereParams
nvidia::apex::EmitterGeomExplicit::SphereParams Member List
This is the complete list of members for nvidia::apex::EmitterGeomExplicit::SphereParams, including all inherited members.
center | nvidia::apex::EmitterGeomExplicit::SphereParams
doDetectOverlaps | nvidia::apex::EmitterGeomExplicit::SphereParams
radius | nvidia::apex::EmitterGeomExplicit::SphereParams
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::EmitterType Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterType
Public Types
nvidia::apex::EmitterType Struct Reference

Emitter type. More...

#include <EmitterGeoms.h>

List of all members.

Public Types

enum Enum {
ET_RATE = 0,
ET_DENSITY_ONCE,
ET_DENSITY_BRUSH,
ET_FILL,
ET_UNDEFINED
}
Enum of emitter types. More...

Detailed Description

Emitter type.

Member Enumeration Documentation

enum nvidia::apex::EmitterType::Enum

Enum of emitter types.

Enumerator:
ET_RATE

use emittion rate to calculate the number of particles

ET_DENSITY_ONCE

emit density particles at once

ET_DENSITY_BRUSH

brush behavior: particles are emitted proportionally to the newly occupied vlume

ET_FILL

fill the volume of the emitter with particles

ET_UNDEFINED
The documentation for this struct was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterType
nvidia::apex::EmitterType Member List
This is the complete list of members for nvidia::apex::EmitterType, including all inherited members.
Enum enum name | nvidia::apex::EmitterType
ET_DENSITY_BRUSH enum value | nvidia::apex::EmitterType
ET_DENSITY_ONCE enum value | nvidia::apex::EmitterType
ET_FILL enum value | nvidia::apex::EmitterType
ET_RATE enum value | nvidia::apex::EmitterType
ET_UNDEFINED enum value | nvidia::apex::EmitterType
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: nvidia::apex::MaterialLookupCallback::MaterialRequest Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MaterialLookupCallback
  • MaterialRequest
Public Attributes
nvidia::apex::MaterialLookupCallback::MaterialRequest Struct Reference

Material request structure. More...

#include <GroundEmitterActor.h>

List of all members.

Public Attributes

PxVec3 | samplePosition
test point position. This is filled by the emitter
uint32_t | outMaterialID
ID of the material at the hitpoint. This must be filled by the user.

Detailed Description

Material request structure.

Member Data Documentation

uint32_t nvidia::apex::MaterialLookupCallback::MaterialRequest::outMaterialID

ID of the material at the hitpoint. This must be filled by the user.

PxVec3 nvidia::apex::MaterialLookupCallback::MaterialRequest::samplePosition

test point position. This is filled by the emitter

The documentation for this struct was generated from the following file:
  • GroundEmitterActor.h
Generated on Sat Dec 1 2018 10:18:24


APEX Emitter Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MaterialLookupCallback
  • MaterialRequest
nvidia::apex::MaterialLookupCallback::MaterialRequest Member List
This is the complete list of members for nvidia::apex::MaterialLookupCallback::MaterialRequest, including all inherited members.
outMaterialID | nvidia::apex::MaterialLookupCallback::MaterialRequest
samplePosition | nvidia::apex::MaterialLookupCallback::MaterialRequest
Generated on Sat Dec 1 2018 10:18:24


APEX FieldSampler Module: Class List

  • Class List
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
nvidia::apex::FieldSamplerWeightedCollisionFilterCallback | This is an optional callback interface for collision filtering between field samplers and other objects If this interface is not provided, then collision filtering happens normally through the default scene simulationfiltershader callback However, if this is provided, then the user can no only return true/false to indicate whether or not the two objects should interact but can also assign a weighted multiplier value to control how strongly the two objects should interact
nvidia::apex::ModuleFieldSampler | FieldSampler module class
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: Class Index

  • Class List
  • Class Members
Class Index
F | M
F
FieldSamplerWeightedCollisionFilterCallback (nvidia::apex)
M
ModuleFieldSampler (nvidia::apex)
F | M
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: nvidia::apex::FieldSamplerWeightedCollisionFilterCallback Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • FieldSamplerWeightedCollisionFilterCallback
Public Member Functions
nvidia::apex::FieldSamplerWeightedCollisionFilterCallback Class Reference

This is an optional callback interface for collision filtering between field samplers and other objects If this interface is not provided, then collision filtering happens normally through the default scene simulationfiltershader callback However, if this is provided, then the user can no only return true/false to indicate whether or not the two objects should interact but can also assign a weighted multiplier value to control how strongly the two objects should interact. More...

#include <ModuleFieldSampler.h>

List of all members.

Public Member Functions

virtual bool fieldSamplerWeightedCollisionFilter (const physx::PxFilterData &objectA, const physx::PxFilterData &objectB, float &multiplierValue)=0
This is an optional callback interface for collision filtering between field samplers and other objects If this interface is not provided, then collision filtering happens normally through the default scene simulationfiltershader callback However, if this is provided, then the user can no only return true/false to indicate whether or not the two objects should interact but can also assign a weighted multiplier value to control how strongly the two objects should interact.

Detailed Description

This is an optional callback interface for collision filtering between field samplers and other objects If this interface is not provided, then collision filtering happens normally through the default scene simulationfiltershader callback However, if this is provided, then the user can no only return true/false to indicate whether or not the two objects should interact but can also assign a weighted multiplier value to control how strongly the two objects should interact.

Member Function Documentation

virtual bool nvidia::apex::FieldSamplerWeightedCollisionFilterCallback::fieldSamplerWeightedCollisionFilter | ( | const physx::PxFilterData & | objectA,
 |  | const physx::PxFilterData & | objectB,
 |  | float & | multiplierValue
 | ) |  | [pure virtual]

This is an optional callback interface for collision filtering between field samplers and other objects If this interface is not provided, then collision filtering happens normally through the default scene simulationfiltershader callback However, if this is provided, then the user can no only return true/false to indicate whether or not the two objects should interact but can also assign a weighted multiplier value to control how strongly the two objects should interact.

The documentation for this class was generated from the following file:
  • ModuleFieldSampler.h
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • FieldSamplerWeightedCollisionFilterCallback
nvidia::apex::FieldSamplerWeightedCollisionFilterCallback Member List
This is the complete list of members for nvidia::apex::FieldSamplerWeightedCollisionFilterCallback, including all inherited members.
fieldSamplerWeightedCollisionFilter(const physx::PxFilterData &objectA, const physx::PxFilterData &objectB, float &multiplierValue)=0 nvidia::apex::FieldSamplerWeightedCollisionFilterCallback [pure virtual]
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: nvidia::apex::ModuleFieldSampler Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • ModuleFieldSampler
Public Member Functions | Protected Member Functions
nvidia::apex::ModuleFieldSampler Class Reference

FieldSampler module class. More...

#include <ModuleFieldSampler.h>

List of all members.

Public Member Functions

virtual bool | setFieldSamplerWeightedCollisionFilterCallback (const Scene &apexScene, FieldSamplerWeightedCollisionFilterCallback *callback)=0
Sets the optional weighted collision filter callback for this scene. If not provided, it will use the default SimulationFilterShader on the current scene.
virtual void | enablePhysXMonitor (const Scene &apexScene, bool enable)=0
virtual void | setPhysXMonitorFilterData (const Scene &apexScene, physx::PxFilterData filterData)=0
Add filter data (collision group) to PhysXMonitor.
virtual uint32_t | createForceSampleBatch (const Scene &apexScene, uint32_t maxCount, const physx::PxFilterData filterData)=0
Initialize a query for a batch of sampling points.
virtual void | releaseForceSampleBatch (const Scene &apexScene, uint32_t batchId)=0
Release a query for a batch of sampling points.
virtual void | submitForceSampleBatch (const Scene &apexScene, uint32_t batchId, PxVec4 *forces, const uint32_t forcesStride, const PxVec3 *positions, const uint32_t positionsStride, const PxVec3 *velocities, const uint32_t velocitiesStride, const float *mass, const uint32_t massStride, const uint32_t *indices, const uint32_t numIndices)=0
Submits a batch of sampling points to be evaluated during the simulation step.

Protected Member Functions

virtual | ~ModuleFieldSampler ()

Detailed Description

FieldSampler module class.

Constructor & Destructor Documentation

virtual nvidia::apex::ModuleFieldSampler::~ModuleFieldSampler ( ) [inline, protected, virtual]

Member Function Documentation

virtual uint32_t nvidia::apex::ModuleFieldSampler::createForceSampleBatch | ( | const Scene & | apexScene,
 |  | uint32_t | maxCount,
 |  | const physx::PxFilterData | filterData
 | ) |  | [pure virtual]

Initialize a query for a batch of sampling points.

Parameters:
apexScene | [in] - Apex scene for which to create the force sample batch query.
maxCount | [in] - Maximum number of indices (active samples)
filterData | [in] - PhysX 3.0 collision mask for data
Returns:
the ID of created query
virtual void nvidia::apex::ModuleFieldSampler::enablePhysXMonitor | ( | const Scene & | apexScene,
 |  | bool | enable
 | ) |  | [pure virtual]

Set flag to toggle PhysXMonitor for ForceFields.

virtual void nvidia::apex::ModuleFieldSampler::releaseForceSampleBatch | ( | const Scene & | apexScene,
 |  | uint32_t | batchId
 | ) |  | [pure virtual]

Release a query for a batch of sampling points.

Parameters:
apexScene | [in] - Apex scene for which to create the force sample batch.
batchId | [in] - ID of query that should be released
virtual bool nvidia::apex::ModuleFieldSampler::setFieldSamplerWeightedCollisionFilterCallback | ( | const Scene & | apexScene,
 |  | FieldSamplerWeightedCollisionFilterCallback * | callback
 | ) |  | [pure virtual]

Sets the optional weighted collision filter callback for this scene. If not provided, it will use the default SimulationFilterShader on the current scene.

virtual void nvidia::apex::ModuleFieldSampler::setPhysXMonitorFilterData | ( | const Scene & | apexScene,
 |  | physx::PxFilterData | filterData
 | ) |  | [pure virtual]

Add filter data (collision group) to PhysXMonitor.

Parameters:
apexScene | [in] - Apex scene for which to submit the force sample batch.
filterData | [in] - PhysX 3.0 collision mask for PhysXMonitor
virtual void nvidia::apex::ModuleFieldSampler::submitForceSampleBatch | ( | const Scene & | apexScene,
 |  | uint32_t | batchId,
 |  | PxVec4 * | forces,
 |  | const uint32_t | forcesStride,
 |  | const PxVec3 * | positions,
 |  | const uint32_t | positionsStride,
 |  | const PxVec3 * | velocities,
 |  | const uint32_t | velocitiesStride,
 |  | const float * | mass,
 |  | const uint32_t | massStride,
 |  | const uint32_t * | indices,
 |  | const uint32_t | numIndices
 | ) |  | [pure virtual]

Submits a batch of sampling points to be evaluated during the simulation step.

Parameters:
apexScene | [in] - Apex scene for which to submit the force sample batch.
batchId | [in] - ID of query for force sample batch.
forces | [out] - Buffer to which computed forces are written to. The buffer needs to be persistent between calling this function and the next PxApexScene::fetchResults.
forcesStride | [in] - Stride between consecutive force vectors within the forces output.
positions | [in] - Buffer containing the positions of the input samples.
positionsStride | [in] - Stride between consecutive position vectors within the positions input.
velocities | [in] - Buffer containing the velocities of the input samples.
velocitiesStride | [in] - Stride between consecutive velocity vectors within the velocities input.
mass | [in] - Buffer containing the mass of the input samples.
massStride | [in] - Stride between consecutive mass values within the mass input.
indices | [in] - Buffer containing the indices of the active samples that are considered for the input and output buffers.
numIndices | [in] - Number of indices (active samples).
The documentation for this class was generated from the following file:
  • ModuleFieldSampler.h
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • ModuleFieldSampler
nvidia::apex::ModuleFieldSampler Member List
This is the complete list of members for nvidia::apex::ModuleFieldSampler, including all inherited members.
createForceSampleBatch(const Scene &apexScene, uint32_t maxCount, const physx::PxFilterData filterData)=0 | nvidia::apex::ModuleFieldSampler | [pure virtual]
enablePhysXMonitor(const Scene &apexScene, bool enable)=0 | nvidia::apex::ModuleFieldSampler | [pure virtual]
releaseForceSampleBatch(const Scene &apexScene, uint32_t batchId)=0 | nvidia::apex::ModuleFieldSampler | [pure virtual]
setFieldSamplerWeightedCollisionFilterCallback(const Scene &apexScene, FieldSamplerWeightedCollisionFilterCallback *callback)=0 | nvidia::apex::ModuleFieldSampler | [pure virtual]
setPhysXMonitorFilterData(const Scene &apexScene, physx::PxFilterData filterData)=0 | nvidia::apex::ModuleFieldSampler | [pure virtual]
submitForceSampleBatch(const Scene &apexScene, uint32_t batchId, PxVec4 *forces, const uint32_t forcesStride, const PxVec3 *positions, const uint32_t positionsStride, const PxVec3 *velocities, const uint32_t velocitiesStride, const float *mass, const uint32_t massStride, const uint32_t *indices, const uint32_t numIndices)=0 | nvidia::apex::ModuleFieldSampler | [pure virtual]
~ModuleFieldSampler() | nvidia::apex::ModuleFieldSampler | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: File List

  • File List
File List
Here is a list of all files with brief descriptions:
ModuleFieldSampler.h [code]
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: Class Members

  • Class List
  • Class Members
  • All
  • Functions
Here is a list of all class members with links to the classes they belong to:
  • createForceSampleBatch() : nvidia::apex::ModuleFieldSampler
  • enablePhysXMonitor() : nvidia::apex::ModuleFieldSampler
  • fieldSamplerWeightedCollisionFilter() : nvidia::apex::FieldSamplerWeightedCollisionFilterCallback
  • releaseForceSampleBatch() : nvidia::apex::ModuleFieldSampler
  • setFieldSamplerWeightedCollisionFilterCallback() : nvidia::apex::ModuleFieldSampler
  • setPhysXMonitorFilterData() : nvidia::apex::ModuleFieldSampler
  • submitForceSampleBatch() : nvidia::apex::ModuleFieldSampler
  • ~ModuleFieldSampler() : nvidia::apex::ModuleFieldSampler
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: Class Members - Functions

  • Class List
  • Class Members
  • All
  • Functions
  • createForceSampleBatch() : nvidia::apex::ModuleFieldSampler
  • enablePhysXMonitor() : nvidia::apex::ModuleFieldSampler
  • fieldSamplerWeightedCollisionFilter() : nvidia::apex::FieldSamplerWeightedCollisionFilterCallback
  • releaseForceSampleBatch() : nvidia::apex::ModuleFieldSampler
  • setFieldSamplerWeightedCollisionFilterCallback() : nvidia::apex::ModuleFieldSampler
  • setPhysXMonitorFilterData() : nvidia::apex::ModuleFieldSampler
  • submitForceSampleBatch() : nvidia::apex::ModuleFieldSampler
  • ~ModuleFieldSampler() : nvidia::apex::ModuleFieldSampler
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: Main Page

APEX FieldSampler Module Documentation
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: ModuleFieldSampler.h File Reference

  • File List
Classes | Namespaces
ModuleFieldSampler.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::FieldSamplerWeightedCollisionFilterCallback
This is an optional callback interface for collision filtering between field samplers and other objects If this interface is not provided, then collision filtering happens normally through the default scene simulationfiltershader callback However, if this is provided, then the user can no only return true/false to indicate whether or not the two objects should interact but can also assign a weighted multiplier value to control how strongly the two objects should interact. More...
class | nvidia::apex::ModuleFieldSampler
FieldSampler module class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: ModuleFieldSampler.h Source File

  • File List
ModuleFieldSampler.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_FIELD_SAMPLER_H
00031 #define MODULE_FIELD_SAMPLER_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00048 class FieldSamplerWeightedCollisionFilterCallback
00049 {
00050 public:
00057     virtual bool fieldSamplerWeightedCollisionFilter(const physx::PxFilterData &objectA,const physx::PxFilterData &objectB,float &multiplierValue) = 0;
00058 };
00059
00060
00064 class ModuleFieldSampler : public Module
00065 {
00066 protected:
00067     virtual                 ~ModuleFieldSampler() {}
00068
00069 public:
00070
00074     virtual bool            setFieldSamplerWeightedCollisionFilterCallback(const Scene& apexScene,FieldSamplerWeightedCollisionFilterCallback *callback) = 0;
00075
00076
00077 #if PX_PHYSICS_VERSION_MAJOR == 3
00078
00081     virtual void            enablePhysXMonitor(const Scene& apexScene, bool enable) = 0;
00088     virtual void            setPhysXMonitorFilterData(const Scene& apexScene, physx::PxFilterData filterData) = 0;
00089 #endif
00090
00099     virtual uint32_t        createForceSampleBatch(const Scene& apexScene, uint32_t maxCount, const physx::PxFilterData filterData) = 0;
00100
00107     virtual void            releaseForceSampleBatch(const Scene& apexScene, uint32_t batchId) = 0;
00108
00125     virtual void            submitForceSampleBatch( const Scene& apexScene, uint32_t batchId,
00126                                                     PxVec4* forces, const uint32_t forcesStride,
00127                                                     const PxVec3* positions, const uint32_t positionsStride,
00128                                                     const PxVec3* velocities, const uint32_t velocitiesStride,
00129                                                     const float* mass, const uint32_t massStride,
00130                                                     const uint32_t* indices, const uint32_t numIndices) = 0;
00131
00132 };
00133
00134
00135
00136 PX_POP_PACK
00137
00138 }
00139 } // end namespace nvidia::apex
00140
00141 #endif // MODULE_FIELD_SAMPLER_H
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: nvidia Namespace Reference

  • Namespace List
Namespaces
nvidia Namespace Reference

Namespaces

namespace apex
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: nvidia::apex Namespace Reference

  • Namespace List
  • nvidia
  • apex
Classes
nvidia::apex Namespace Reference

Classes

class | FieldSamplerWeightedCollisionFilterCallback
This is an optional callback interface for collision filtering between field samplers and other objects If this interface is not provided, then collision filtering happens normally through the default scene simulationfiltershader callback However, if this is provided, then the user can no only return true/false to indicate whether or not the two objects should interact but can also assign a weighted multiplier value to control how strongly the two objects should interact. More...
class | ModuleFieldSampler
FieldSampler module class. More...
Generated on Sat Dec 1 2018 10:18:25


APEX FieldSampler Module: Namespace List

  • Namespace List
Namespace List
Here is a list of all namespaces with brief descriptions:
nvidia
nvidia::apex
Generated on Sat Dec 1 2018 10:18:25


APEX ForceField Module: Class List

  • Class List
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
nvidia::apex::ForceFieldActor | ForceField Actor
nvidia::apex::ForceFieldAsset | ForceField Asset
nvidia::apex::ForceFieldAssetAuthoring | ForceField Asset Authoring
nvidia::apex::ForceFieldPreview | APEX asset preview force field asset
nvidia::apex::ModuleForceField | ForceField Module
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: Class Index

  • Class List
  • Class Members
Class Index
F | M
F
ForceFieldAsset (nvidia::apex) ForceFieldPreview (nvidia::apex)
M
ModuleForceField (nvidia::apex)
ForceFieldActor (nvidia::apex) ForceFieldAssetAuthoring (nvidia::apex)
F | M
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: nvidia::apex::ForceFieldActor Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • ForceFieldActor
Public Member Functions | Protected Member Functions
nvidia::apex::ForceFieldActor Class Reference

ForceField Actor. More...

#include <ForceFieldActor.h>

List of all members.

Public Member Functions

virtual bool | isEnable ()=0
virtual bool | disable ()=0
virtual bool | enable ()=0
virtual PxMat44 | getPose () const =0
virtual void | setPose (const PxMat44 &pose)=0
virtual PX_DEPRECATED float | getScale () const =0
virtual PX_DEPRECATED void | setScale (float scale)=0
virtual PX_DEPRECATED float | getCurrentScale () const =0
virtual PX_DEPRECATED void | setCurrentScale (float scale)=0
virtual const char * | getName () const =0
virtual void | setName (const char *name)=0
virtual void | setStrength (const float strength)=0
virtual void | setLifetime (const float lifetime)=0
virtual PX_DEPRECATED void | setFalloffType (const char *type)=0
virtual PX_DEPRECATED void | setFalloffMultiplier (const float multiplier)=0
virtual ForceFieldAsset * | getForceFieldAsset () const =0

Protected Member Functions

virtual | ~ForceFieldActor ()

Detailed Description

ForceField Actor.

Constructor & Destructor Documentation

virtual nvidia::apex::ForceFieldActor::~ForceFieldActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual bool nvidia::apex::ForceFieldActor::disable ( ) [pure virtual]

Disable force field actor. Default status is enable. Can switch it freely. A disabled explosion actor still exists there, but has no effect to the scene.

virtual bool nvidia::apex::ForceFieldActor::enable ( ) [pure virtual]

Enable force field actor. Default status is enable. Can switch it freely. A disabled explosion actor still exists there, but has no effect to the scene.

virtual PX_DEPRECATED float nvidia::apex::ForceFieldActor::getCurrentScale ( ) const [pure virtual]

Gets the force field actor's scale.

virtual ForceFieldAsset* nvidia::apex::ForceFieldActor::getForceFieldAsset ( ) const [pure virtual]

Returns the asset the actor has been created from.

virtual const char* nvidia::apex::ForceFieldActor::getName ( ) const [pure virtual]

Retrieves the name string for the force field actor.

virtual PxMat44 nvidia::apex::ForceFieldActor::getPose ( ) const [pure virtual]

Gets location and orientation of the force field.

virtual PX_DEPRECATED float nvidia::apex::ForceFieldActor::getScale ( ) const [pure virtual]

Gets the force field actor's scale.

virtual bool nvidia::apex::ForceFieldActor::isEnable ( ) [pure virtual]

Return true if the force field actor is enabled.

virtual PX_DEPRECATED void nvidia::apex::ForceFieldActor::setCurrentScale ( float scale ) [pure virtual]

Sets the force field actor's scale. (0.0f, +inf)

virtual PX_DEPRECATED void nvidia::apex::ForceFieldActor::setFalloffMultiplier ( const float multiplier ) [pure virtual]

Set falloff multiplier for the force field actor. Only works for radial force field types.

virtual PX_DEPRECATED void nvidia::apex::ForceFieldActor::setFalloffType ( const char * type ) [pure virtual]

Set falloff type (linear, steep, scurve, custom, none) for the force field actor. Only works for radial force field types.

virtual void nvidia::apex::ForceFieldActor::setLifetime ( const float lifetime ) [pure virtual]

Set lifetime for the force field actor.

virtual void nvidia::apex::ForceFieldActor::setName ( const char * name ) [pure virtual]

Set a name string for the force field actor that can be retrieved with getName().

virtual void nvidia::apex::ForceFieldActor::setPose ( const PxMat44 & pose ) [pure virtual]

Sets location and orientation of the force field.

virtual PX_DEPRECATED void nvidia::apex::ForceFieldActor::setScale ( float scale ) [pure virtual]

Sets the force field actor's scale. (0.0f, +inf)

virtual void nvidia::apex::ForceFieldActor::setStrength ( const float strength ) [pure virtual]

Set strength for the force field actor.

The documentation for this class was generated from the following file:
  • ForceFieldActor.h
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • ForceFieldActor
nvidia::apex::ForceFieldActor Member List
This is the complete list of members for nvidia::apex::ForceFieldActor, including all inherited members.
disable()=0 | nvidia::apex::ForceFieldActor | [pure virtual]
enable()=0 | nvidia::apex::ForceFieldActor | [pure virtual]
getCurrentScale() const =0 | nvidia::apex::ForceFieldActor | [pure virtual]
getForceFieldAsset() const =0 | nvidia::apex::ForceFieldActor | [pure virtual]
getName() const =0 | nvidia::apex::ForceFieldActor | [pure virtual]
getPose() const =0 | nvidia::apex::ForceFieldActor | [pure virtual]
getScale() const =0 | nvidia::apex::ForceFieldActor | [pure virtual]
isEnable()=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setFalloffMultiplier(const float multiplier)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setFalloffType(const char *type)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setLifetime(const float lifetime)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setName(const char *name)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setScale(float scale)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setStrength(const float strength)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
~ForceFieldActor() | nvidia::apex::ForceFieldActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: nvidia::apex::ForceFieldAsset Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • ForceFieldAsset
Public Member Functions | Protected Member Functions
nvidia::apex::ForceFieldAsset Class Reference

ForceField Asset. More...

#include <ForceFieldAsset.h>

List of all members.

Public Member Functions

virtual float | getDefaultScale () const =0
returns the default scale of the asset.
virtual void | releaseForceFieldActor (ForceFieldActor &)=0
release an actor created from this asset.

Protected Member Functions

virtual | ~ForceFieldAsset ()
force field asset default destructor.

Detailed Description

ForceField Asset.

Constructor & Destructor Documentation

virtual nvidia::apex::ForceFieldAsset::~ForceFieldAsset ( ) [inline, protected, virtual]

force field asset default destructor.

Member Function Documentation

virtual float nvidia::apex::ForceFieldAsset::getDefaultScale ( ) const [pure virtual]

returns the default scale of the asset.

virtual void nvidia::apex::ForceFieldAsset::releaseForceFieldActor ( ForceFieldActor & ) [pure virtual]

release an actor created from this asset.

The documentation for this class was generated from the following file:
  • ForceFieldAsset.h
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • ForceFieldAsset
nvidia::apex::ForceFieldAsset Member List
This is the complete list of members for nvidia::apex::ForceFieldAsset, including all inherited members.
getDefaultScale() const =0 | nvidia::apex::ForceFieldAsset | [pure virtual]
releaseForceFieldActor(ForceFieldActor &)=0 | nvidia::apex::ForceFieldAsset | [pure virtual]
~ForceFieldAsset() | nvidia::apex::ForceFieldAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: nvidia::apex::ForceFieldAssetAuthoring Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • ForceFieldAssetAuthoring
Protected Member Functions
nvidia::apex::ForceFieldAssetAuthoring Class Reference

ForceField Asset Authoring. More...

#include <ForceFieldAsset.h>

List of all members.

Protected Member Functions

virtual ~ForceFieldAssetAuthoring ()
force field asset authoring default destructor.

Detailed Description

ForceField Asset Authoring.

Constructor & Destructor Documentation

virtual nvidia::apex::ForceFieldAssetAuthoring::~ForceFieldAssetAuthoring ( ) [inline, protected, virtual]

force field asset authoring default destructor.

The documentation for this class was generated from the following file:
  • ForceFieldAsset.h
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • ForceFieldAssetAuthoring
nvidia::apex::ForceFieldAssetAuthoring Member List
This is the complete list of members for nvidia::apex::ForceFieldAssetAuthoring, including all inherited members.
~ForceFieldAssetAuthoring() nvidia::apex::ForceFieldAssetAuthoring [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: nvidia::apex::ForceFieldPreview Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • ForceFieldPreview
Public Member Functions | Protected Member Functions
nvidia::apex::ForceFieldPreview Class Reference

APEX asset preview force field asset. More...

#include <ForceFieldPreview.h>

List of all members.

Public Member Functions

virtual void | setIconScale (float scale)=0
virtual void | setDetailLevel (uint32_t detail)=0

Protected Member Functions

ForceFieldPreview ()

Detailed Description

APEX asset preview force field asset.

Constructor & Destructor Documentation

nvidia::apex::ForceFieldPreview::ForceFieldPreview ( ) [inline, protected]

Member Function Documentation

virtual void nvidia::apex::ForceFieldPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable. Any, all, or none of the following masks may be added together to select what should be drawn. The defines for the individual items are FORCEFIELD_DRAW_NOTHING, FORCEFIELD_DRAW_ICON, FORCEFIELD_DRAW_BOUNDARIES, FORCEFIELD_DRAW_WITH_CYLINDERS. All items may be drawn using the macro FORCEFIELD_DRAW_FULL_DETAIL and FORCEFIELD_DRAW_FULL_DETAIL_BOLD.

virtual void nvidia::apex::ForceFieldPreview::setIconScale ( float scale ) [pure virtual]

Set the scale of the icon. The unscaled icon has is 1.0x1.0 game units. By default the scale of the icon is 1.0. (unscaled)

The documentation for this class was generated from the following file:
  • ForceFieldPreview.h
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • ForceFieldPreview
nvidia::apex::ForceFieldPreview Member List
This is the complete list of members for nvidia::apex::ForceFieldPreview, including all inherited members.
ForceFieldPreview() | nvidia::apex::ForceFieldPreview | [inline, protected]
setDetailLevel(uint32_t detail)=0 | nvidia::apex::ForceFieldPreview | [pure virtual]
setIconScale(float scale)=0 | nvidia::apex::ForceFieldPreview | [pure virtual]
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: nvidia::apex::ModuleForceField Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • ModuleForceField
Public Member Functions | Protected Member Functions
nvidia::apex::ModuleForceField Class Reference

ForceField Module. More...

#include <ModuleForceField.h>

List of all members.

Public Member Functions

virtual uint32_t | getModuleValue () const =0
The module ID value of the force field.

Protected Member Functions

virtual | ~ModuleForceField ()
Force field module default destructor.

Detailed Description

ForceField Module.

Constructor & Destructor Documentation

virtual nvidia::apex::ModuleForceField::~ModuleForceField ( ) [inline, protected, virtual]

Force field module default destructor.

Member Function Documentation

virtual uint32_t nvidia::apex::ModuleForceField::getModuleValue ( ) const [pure virtual]

The module ID value of the force field.

The documentation for this class was generated from the following file:
  • ModuleForceField.h
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • ModuleForceField
nvidia::apex::ModuleForceField Member List
This is the complete list of members for nvidia::apex::ModuleForceField, including all inherited members.
getModuleValue() const =0 | nvidia::apex::ModuleForceField | [pure virtual]
~ModuleForceField() | nvidia::apex::ModuleForceField | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
ForceFieldActor.h [code]
ForceFieldAsset.h [code]
ForceFieldPreview.h [code]
ModuleForceField.h [code]
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: ForceFieldActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
ForceFieldActor.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ForceFieldActor
ForceField Actor. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: ForceFieldActor.h Source File

  • File List
  • File Members
ForceFieldActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef FORCE_FIELD_ACTOR_H
00031 #define FORCE_FIELD_ACTOR_H
00032
00033 #include "Apex.h"
00034
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041
00042 PX_PUSH_PACK_DEFAULT
00043
00044 class ForceFieldAsset;
00045 class ForceFieldAssetParams;
00046
00050 class ForceFieldActor : public Actor
00051 {
00052 protected:
00053     virtual ~ForceFieldActor() {}
00054
00055 public:
00059     virtual bool                    isEnable() = 0;
00060
00065     virtual bool                    disable() = 0;
00066
00071     virtual bool                    enable() = 0;
00072
00076     virtual PxMat44                 getPose() const = 0;
00077
00081     virtual void                    setPose(const PxMat44& pose) = 0;
00082
00086     PX_DEPRECATED virtual float     getScale() const = 0;
00087
00091     PX_DEPRECATED virtual void      setScale(float scale) = 0;
00092
00096     PX_DEPRECATED virtual float     getCurrentScale() const = 0;
00097
00101     PX_DEPRECATED virtual void      setCurrentScale(float scale) = 0;
00102
00103
00104
00108     virtual const char*             getName() const = 0;
00109
00113     virtual void                    setName(const char* name) = 0;
00114
00118     virtual void                    setStrength(const float strength) = 0;
00119
00123     virtual void                    setLifetime(const float lifetime) = 0;
00124
00129     PX_DEPRECATED virtual void      setFalloffType(const char* type) = 0;
00130
00135     PX_DEPRECATED virtual void      setFalloffMultiplier(const float multiplier) = 0;
00136
00140     virtual ForceFieldAsset*        getForceFieldAsset() const = 0;
00141
00142 };
00143
00144 PX_POP_PACK
00145
00146 } // namespace apex
00147 } // namespace nvidia
00148
00149 #endif // FORCE_FIELD_ACTOR_H
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: ForceFieldAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
ForceFieldAsset.h File Reference
#include "Apex.h"
#include "ForceFieldPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ForceFieldAsset
ForceField Asset. More...
class | nvidia::apex::ForceFieldAssetAuthoring
ForceField Asset Authoring. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | FORCEFIELD_AUTHORING_TYPE_NAME "ForceFieldAsset"

Define Documentation

#define FORCEFIELD_AUTHORING_TYPE_NAME "ForceFieldAsset"
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: ForceFieldAsset.h Source File

  • File List
  • File Members
ForceFieldAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef FORCE_FIELD_ASSET_H
00031 #define FORCE_FIELD_ASSET_H
00032
00033 #include "Apex.h"
00034 #include "ForceFieldPreview.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define FORCEFIELD_AUTHORING_TYPE_NAME "ForceFieldAsset"
00044
00045 class ForceFieldActor;
00046
00050 class ForceFieldAsset : public Asset
00051 {
00052 protected:
00056     virtual ~ForceFieldAsset() {}
00057
00058 public:
00062     virtual float       getDefaultScale() const = 0;
00063
00067     virtual void        releaseForceFieldActor(ForceFieldActor&) = 0;
00068 };
00069
00073 class ForceFieldAssetAuthoring : public AssetAuthoring
00074 {
00075 protected:
00079     virtual ~ForceFieldAssetAuthoring() {}
00080
00081 public:
00082 };
00083
00084
00085 PX_POP_PACK
00086
00087 } // namespace apex
00088 } // namespace nvidia
00089
00090 #endif // FORCE_FIELD_ASSET_H
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: ForceFieldPreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
ForceFieldPreview.h File Reference
#include "Apex.h"
#include "AssetPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ForceFieldPreview
APEX asset preview force field asset. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
namespace | nvidia::apex::APEX_FORCEFIELD
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: ForceFieldPreview.h Source File

  • File List
  • File Members
ForceFieldPreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef FORCE_FIELD_PREVIEW_H
00031 #define FORCE_FIELD_PREVIEW_H
00032
00033 #include "Apex.h"
00034 #include "AssetPreview.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class RenderDebugInterface;
00044
00045 namespace APEX_FORCEFIELD
00046 {
00051 static const uint32_t FORCEFIELD_DRAW_NOTHING = (0x00);
00056 static const uint32_t FORCEFIELD_DRAW_ICON = (0x01);
00061 static const uint32_t FORCEFIELD_DRAW_BOUNDARIES = (0x2);
00066 static const uint32_t FORCEFIELD_DRAW_WITH_CYLINDERS = (0x4);
00071 static const uint32_t FORCEFIELD_DRAW_FULL_DETAIL = (FORCEFIELD_DRAW_ICON + FORCEFIELD_DRAW_BOUNDARIES);
00076 static const uint32_t FORCEFIELD_DRAW_FULL_DETAIL_BOLD = (FORCEFIELD_DRAW_FULL_DETAIL + FORCEFIELD_DRAW_WITH_CYLINDERS);
00077 }
00078
00082 class ForceFieldPreview : public AssetPreview
00083 {
00084 public:
00090     virtual void    setIconScale(float scale) = 0;
00098     virtual void    setDetailLevel(uint32_t detail) = 0;
00099
00100 protected:
00101     ForceFieldPreview() {};
00102 };
00103
00104
00105 PX_POP_PACK
00106
00107 } // namespace apex
00108 } // namespace nvidia
00109
00110 #endif // FORCE_FIELD_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: Class Members

  • Class List
  • Class Members
  • All
  • Functions
Here is a list of all class members with links to the classes they belong to:
  • disable() : nvidia::apex::ForceFieldActor
  • enable() : nvidia::apex::ForceFieldActor
  • ForceFieldPreview() : nvidia::apex::ForceFieldPreview
  • getCurrentScale() : nvidia::apex::ForceFieldActor
  • getDefaultScale() : nvidia::apex::ForceFieldAsset
  • getForceFieldAsset() : nvidia::apex::ForceFieldActor
  • getModuleValue() : nvidia::apex::ModuleForceField
  • getName() : nvidia::apex::ForceFieldActor
  • getPose() : nvidia::apex::ForceFieldActor
  • getScale() : nvidia::apex::ForceFieldActor
  • isEnable() : nvidia::apex::ForceFieldActor
  • releaseForceFieldActor() : nvidia::apex::ForceFieldAsset
  • setCurrentScale() : nvidia::apex::ForceFieldActor
  • setDetailLevel() : nvidia::apex::ForceFieldPreview
  • setFalloffMultiplier() : nvidia::apex::ForceFieldActor
  • setFalloffType() : nvidia::apex::ForceFieldActor
  • setIconScale() : nvidia::apex::ForceFieldPreview
  • setLifetime() : nvidia::apex::ForceFieldActor
  • setName() : nvidia::apex::ForceFieldActor
  • setPose() : nvidia::apex::ForceFieldActor
  • setScale() : nvidia::apex::ForceFieldActor
  • setStrength() : nvidia::apex::ForceFieldActor
  • ~ForceFieldActor() : nvidia::apex::ForceFieldActor
  • ~ForceFieldAsset() : nvidia::apex::ForceFieldAsset
  • ~ForceFieldAssetAuthoring() : nvidia::apex::ForceFieldAssetAuthoring
  • ~ModuleForceField() : nvidia::apex::ModuleForceField
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: Class Members - Functions

  • Class List
  • Class Members
  • All
  • Functions
  • disable() : nvidia::apex::ForceFieldActor
  • enable() : nvidia::apex::ForceFieldActor
  • ForceFieldPreview() : nvidia::apex::ForceFieldPreview
  • getCurrentScale() : nvidia::apex::ForceFieldActor
  • getDefaultScale() : nvidia::apex::ForceFieldAsset
  • getForceFieldAsset() : nvidia::apex::ForceFieldActor
  • getModuleValue() : nvidia::apex::ModuleForceField
  • getName() : nvidia::apex::ForceFieldActor
  • getPose() : nvidia::apex::ForceFieldActor
  • getScale() : nvidia::apex::ForceFieldActor
  • isEnable() : nvidia::apex::ForceFieldActor
  • releaseForceFieldActor() : nvidia::apex::ForceFieldAsset
  • setCurrentScale() : nvidia::apex::ForceFieldActor
  • setDetailLevel() : nvidia::apex::ForceFieldPreview
  • setFalloffMultiplier() : nvidia::apex::ForceFieldActor
  • setFalloffType() : nvidia::apex::ForceFieldActor
  • setIconScale() : nvidia::apex::ForceFieldPreview
  • setLifetime() : nvidia::apex::ForceFieldActor
  • setName() : nvidia::apex::ForceFieldActor
  • setPose() : nvidia::apex::ForceFieldActor
  • setScale() : nvidia::apex::ForceFieldActor
  • setStrength() : nvidia::apex::ForceFieldActor
  • ~ForceFieldActor() : nvidia::apex::ForceFieldActor
  • ~ForceFieldAsset() : nvidia::apex::ForceFieldAsset
  • ~ForceFieldAssetAuthoring() : nvidia::apex::ForceFieldAssetAuthoring
  • ~ModuleForceField() : nvidia::apex::ModuleForceField
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: File Members

  • File List
  • File Members
  • All
  • Defines
Here is a list of all file members with links to the files they belong to:
  • FORCEFIELD_AUTHORING_TYPE_NAME : ForceFieldAsset.h
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: File Members

  • File List
  • File Members
  • All
  • Defines
  • FORCEFIELD_AUTHORING_TYPE_NAME : ForceFieldAsset.h
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: Main Page

APEX ForceField Module Documentation
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: ModuleForceField.h File Reference

  • File List
  • File Members
Classes | Namespaces
ModuleForceField.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ModuleForceField
ForceField Module. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: ModuleForceField.h Source File

  • File List
  • File Members
ModuleForceField.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_FORCE_FIELD_H
00031 #define MODULE_FORCE_FIELD_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class ForceFieldAsset;
00043 class ForceFieldAssetAuthoring;
00044
00048 class ModuleForceField : public Module
00049 {
00050 public:
00054     virtual uint32_t getModuleValue() const = 0;
00055
00056 protected:
00060     virtual ~ModuleForceField() {}
00061 };
00062
00063
00064
00065 PX_POP_PACK
00066
00067 } // namespace apex
00068 } // namespace nvidia
00069
00070 #endif // MODULE_FORCE_FIELD_H
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: nvidia Namespace Reference

  • Namespace List
Namespaces
nvidia Namespace Reference

Namespaces

namespace apex
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: nvidia::apex Namespace Reference

  • Namespace List
  • nvidia
  • apex
Namespaces | Classes
nvidia::apex Namespace Reference

Namespaces

namespace | APEX_FORCEFIELD

Classes

class | ForceFieldActor
ForceField Actor. More...
class | ForceFieldAsset
ForceField Asset. More...
class | ForceFieldAssetAuthoring
ForceField Asset Authoring. More...
class | ForceFieldPreview
APEX asset preview force field asset. More...
class | ModuleForceField
ForceField Module. More...
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: nvidia::apex::APEX_FORCEFIELD Namespace Reference

  • Namespace List
  • nvidia
  • apex
  • APEX_FORCEFIELD
nvidia::apex::APEX_FORCEFIELD Namespace Reference
Generated on Sat Dec 1 2018 10:18:26


APEX ForceField Module: Namespace List

  • Namespace List
Namespace List
Here is a list of all namespaces with brief descriptions:
nvidia
nvidia::apex
nvidia::apex::APEX_FORCEFIELD
Generated on Sat Dec 1 2018 10:18:26


APEX Framework: Actor.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Defines
Actor.h File Reference

classes ApexActor, ApexActorSource More...

#include "ApexInterface.h"
#include "PxActor.h"
#include "PxShape.h"
#include "PxFiltering.h"

Go to the source code of this file.

Classes

class | nvidia::apex::PhysX3DescTemplate
class | nvidia::apex::Actor
Base class for APEX module objects. More...
class | nvidia::apex::ActorSource
Base class for APEX classes that spawn PhysX SDK Actors. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Defines

#define | APEX_DEFAULT_WAKE_UP_COUNTER 0.4f
#define | APEX_ACTOR_TEMPLATE_PARAM(_type, _name, _valid, _default)

Detailed Description

classes ApexActor, ApexActorSource

Define Documentation

#define APEX_ACTOR_TEMPLATE_PARAM | ( | _type,
 |  | _name,
 |  | _valid,
 |  | _default
 | ) |
Value:
bool is##_name##Valid(_type x) const { PX_UNUSED(x); return _valid; } \
_type getDefault##_name() const { return _default; } \
virtual _type get##_name() const = 0; \
virtual bool set##_name(_type) = 0

Used to define generic get/set methods for 1-parameter values in PhysX3DescTemplate.

#define APEX_DEFAULT_WAKE_UP_COUNTER 0.4f

Corresponds to 20 frames for a time step of 0.02, PhysX 3.3 took PX_SLEEP_INTERVAL away

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Actor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Actor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef ACTOR_H
00031 #define ACTOR_H
00032
00038 #include "ApexInterface.h"
00039
00040 #if PX_PHYSICS_VERSION_MAJOR == 3
00041 #include "PxActor.h"
00042 #include "PxShape.h"
00043 #include "PxFiltering.h"
00044 namespace nvidia { namespace apex
00045 {
00046
00048 #define APEX_DEFAULT_WAKE_UP_COUNTER 0.4f
00049
00051 #define APEX_ACTOR_TEMPLATE_PARAM(_type, _name, _valid, _default) \
00052 bool is##_name##Valid(_type x) const { PX_UNUSED(x); return _valid; } \
00053 _type getDefault##_name() const { return _default; } \
00054 virtual _type get##_name() const = 0; \
00055 virtual bool set##_name(_type) = 0
00056
00062 class PhysX3DescTemplate
00063 {
00064 public:
00065     /*
00066         For each Name below, there are functions: getName(), setName(), isNameValid(), and getDefaultName().  For example:
00067
00068         PxDominanceGroup    getDominanceGroup() const;
00069         bool                setDominanceGroup(PxDominanceGroup);    // Returns true iff the passed-in value is valid.  (Note, will set the internal values even if they are not valid.)
00070         bool                isDominanceGroupValid() const;
00071         PxDominanceGroup    getDefaultDominanceGroup() const;
00072     */
00073
00074     /*                           Type                       Name                    Validity Condition      Default Value */
00075     // Actor
00077     APEX_ACTOR_TEMPLATE_PARAM(physx::PxDominanceGroup,  DominanceGroup,     (1),                    0);
00079     APEX_ACTOR_TEMPLATE_PARAM(uint8_t,              ActorFlags,             (1),                    physx::PxActorFlag::eSEND_SLEEP_NOTIFIES);
00081     APEX_ACTOR_TEMPLATE_PARAM(physx::PxClientID,    OwnerClient,            (1),                    0);
00083     APEX_ACTOR_TEMPLATE_PARAM(uint32_t,             ClientBehaviorBits,     (1),                    0);
00085     APEX_ACTOR_TEMPLATE_PARAM(uint16_t,             ContactReportFlags,     (1),                    0);
00087     APEX_ACTOR_TEMPLATE_PARAM(void*,                UserData,               (1),                    NULL);
00089     APEX_ACTOR_TEMPLATE_PARAM(const char*,          Name,                   (1),                    NULL);
00090
00091     // Body
00093     APEX_ACTOR_TEMPLATE_PARAM(float,                Density,                (x >= 0.0f),            1.0f);
00095     APEX_ACTOR_TEMPLATE_PARAM(uint8_t,              BodyFlags,              (1),                    0);
00097     APEX_ACTOR_TEMPLATE_PARAM(float,                WakeUpCounter,          (x >= 0.0f),            APEX_DEFAULT_WAKE_UP_COUNTER);
00099     APEX_ACTOR_TEMPLATE_PARAM(float,                LinearDamping,          (x >= 0.0f),            0.0f);
00101     APEX_ACTOR_TEMPLATE_PARAM(float,                AngularDamping,         (x >= 0.0f),            0.05f);
00103     APEX_ACTOR_TEMPLATE_PARAM(float,                MaxAngularVelocity,     (1),                    7.0f);
00105     APEX_ACTOR_TEMPLATE_PARAM(float,                SleepLinearVelocity,    (1),                    0.0f);
00107     APEX_ACTOR_TEMPLATE_PARAM(uint32_t,             SolverIterationCount,   (x >= 1 && x <= 255),   4);
00109     APEX_ACTOR_TEMPLATE_PARAM(uint32_t,             VelocityIterationCount, (x >= 1 && x <= 255),   1);
00111     APEX_ACTOR_TEMPLATE_PARAM(float,                ContactReportThreshold, (1),                    PX_MAX_F32);
00113     APEX_ACTOR_TEMPLATE_PARAM(float,                SleepThreshold,         (1),                    0.005f);
00114
00115     // Shape
00117     APEX_ACTOR_TEMPLATE_PARAM(uint8_t,              ShapeFlags,             (1),                    physx::PxShapeFlag::eSIMULATION_SHAPE | physx::PxShapeFlag::eSCENE_QUERY_SHAPE | physx::PxShapeFlag::eVISUALIZATION);
00119     APEX_ACTOR_TEMPLATE_PARAM(void*,                ShapeUserData,          (1),                    NULL);
00121     APEX_ACTOR_TEMPLATE_PARAM(const char*,          ShapeName,              (1),                    NULL);
00123     APEX_ACTOR_TEMPLATE_PARAM(physx::PxFilterData,  SimulationFilterData,   (1),                    physx::PxFilterData(0, 0, 0, 0));
00125     APEX_ACTOR_TEMPLATE_PARAM(physx::PxFilterData,  QueryFilterData,        (1),                    physx::PxFilterData(0, 0, 0, 0));
00127     APEX_ACTOR_TEMPLATE_PARAM(float,                ContactOffset,          (1),                    -1.0f);
00129     APEX_ACTOR_TEMPLATE_PARAM(float,                RestOffset,             (1),                    PX_MAX_F32);
00130     // Shape materials get explicitly defined API:
00132     virtual physx::PxMaterial** getMaterials(uint32_t& materialCount) const = 0;
00134     virtual bool                setMaterials(physx::PxMaterial** materialArray, uint32_t materialCount) = 0;    // Must have non-zero sized array of materials to be valid.
00135
00136
00138     virtual void release() = 0;
00139
00140 protected:
00141     virtual ~PhysX3DescTemplate() {}
00142 };  // PhysX3DescTemplate
00143
00144 #undef APEX_ACTOR_TEMPLATE_PARAM
00145
00146 }}
00147 #endif
00148
00149 namespace nvidia
00150 {
00151 namespace apex
00152 {
00153
00154 PX_PUSH_PACK_DEFAULT
00155
00156 class Asset;
00157
00161 class Actor : public ApexInterface
00162 {
00163 public:
00167     virtual Asset* getOwner() const = 0;
00168
00179     virtual void getLodRange(float& min, float& max, bool& intOnly) const = 0;
00180
00184     virtual float getActiveLod() const = 0;
00185
00194     virtual void forceLod(float lod) = 0;
00195
00199     virtual void cacheModuleData() const {}
00200
00204     virtual void setEnableDebugVisualization(bool state) = 0;
00205
00206
00207 protected:
00208     virtual ~Actor() {} // use release() method instead!
00209 };
00210
00211 #if PX_PHYSICS_VERSION_MAJOR == 3
00212
00215 class ActorSource
00216 {
00217 public:
00234     virtual void setPhysX3Template(const PhysX3DescTemplate*) = 0;
00235
00239     virtual bool getPhysX3Template(PhysX3DescTemplate& dest) const = 0;
00240
00244     virtual PhysX3DescTemplate* createPhysX3DescTemplate() const = 0;
00245 };
00246
00247 #endif
00248
00249 PX_POP_PACK
00250
00251 }
00252 } // end namespace nvidia::apex
00253
00254 #endif // ACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: Apex.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Namespaces
Apex.h File Reference

The top level include file for all of the APEX API. More...

#include "foundation/Px.h"
#include "ApexUsingNamespace.h"
#include "foundation/PxPreprocessor.h"
#include "foundation/PxSimpleTypes.h"
#include "foundation/PxAssert.h"
#include "foundation/PxBounds3.h"
#include "foundation/PxVec2.h"
#include "foundation/PxVec3.h"
#include "ApexDefs.h"
#include "ApexDesc.h"
#include "ApexInterface.h"
#include "ApexSDK.h"
#include "Actor.h"
#include "Context.h"
#include "ApexNameSpace.h"
#include "PhysXObjectDesc.h"
#include "RenderDataProvider.h"
#include "Renderable.h"
#include "AssetPreview.h"
#include "Asset.h"
#include "RenderContext.h"
#include "Scene.h"
#include "ApexSDKCachedData.h"
#include "IProgressListener.h"
#include "Module.h"
#include "IosAsset.h"
#include "RenderDataFormat.h"
#include "RenderBufferData.h"
#include "UserRenderResourceManager.h"
#include "UserRenderVertexBufferDesc.h"
#include "UserRenderInstanceBufferDesc.h"
#include "UserRenderSpriteBufferDesc.h"
#include "UserRenderIndexBufferDesc.h"
#include "UserRenderBoneBufferDesc.h"
#include "UserRenderResourceDesc.h"
#include "UserRenderSurfaceBufferDesc.h"
#include "UserRenderSurfaceBuffer.h"
#include "UserRenderResource.h"
#include "UserRenderVertexBuffer.h"
#include "UserRenderInstanceBuffer.h"
#include "UserRenderSpriteBuffer.h"
#include "UserRenderIndexBuffer.h"
#include "UserRenderBoneBuffer.h"
#include "UserRenderer.h"
#include "VertexFormat.h"
#include "RenderMesh.h"
#include "RenderMeshActorDesc.h"
#include "RenderMeshActor.h"
#include "RenderMeshAsset.h"
#include "ResourceCallback.h"
#include "ResourceProvider.h"

Go to the source code of this file.

Namespaces

namespace NvParameterized

NvParameterized namespace.

Detailed Description

The top level include file for all of the APEX API.

Include this whenever you want to use anything from the APEX API in a source file.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Apex.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Apex.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef APEX_H
00031 #define APEX_H
00032
00041 #include "foundation/Px.h"
00042
00043 #include "ApexUsingNamespace.h"
00044
00045
00046 namespace NvParameterized
00047 {
00048 class Traits;
00049 class Interface;
00050 class Serializer;
00051 };
00052
00053
00054 #include "foundation/PxPreprocessor.h"
00055 #include "foundation/PxSimpleTypes.h"
00056 #include "foundation/PxAssert.h"
00057 #include "foundation/PxBounds3.h"
00058 #include "foundation/PxVec2.h"
00059 #include "foundation/PxVec3.h"
00060
00061
00062 // APEX public API:
00063 // In general, APEX public headers will not be included 'alone', so they
00064 // should not include their prerequisites.
00065
00066 #include "ApexDefs.h"
00067 #include "ApexDesc.h"
00068 #include "ApexInterface.h"
00069 #include "ApexSDK.h"
00070
00071 #include "Actor.h"
00072 #include "Context.h"
00073 #include "ApexNameSpace.h"
00074 #include "PhysXObjectDesc.h"
00075 #include "RenderDataProvider.h"
00076 #include "Renderable.h"
00077 #include "AssetPreview.h"
00078 #include "Asset.h"
00079 #include "RenderContext.h"
00080 #include "Scene.h"
00081 #include "ApexSDKCachedData.h"
00082 #include "IProgressListener.h"
00083 #include "Module.h"
00084 #include "IosAsset.h"
00085
00086 #include "RenderDataFormat.h"
00087 #include "RenderBufferData.h"
00088 #include "UserRenderResourceManager.h"
00089 #include "UserRenderVertexBufferDesc.h"
00090 #include "UserRenderInstanceBufferDesc.h"
00091 #include "UserRenderSpriteBufferDesc.h"
00092 #include "UserRenderIndexBufferDesc.h"
00093 #include "UserRenderBoneBufferDesc.h"
00094 #include "UserRenderResourceDesc.h"
00095 #include "UserRenderSurfaceBufferDesc.h"
00096 #include "UserRenderSurfaceBuffer.h"
00097 #include "UserRenderResource.h"
00098 #include "UserRenderVertexBuffer.h"
00099 #include "UserRenderInstanceBuffer.h"
00100 #include "UserRenderSpriteBuffer.h"
00101 #include "UserRenderIndexBuffer.h"
00102 #include "UserRenderBoneBuffer.h"
00103 #include "UserRenderer.h"
00104
00105 #include "VertexFormat.h"
00106 #include "RenderMesh.h"
00107 #include "RenderMeshActorDesc.h"
00108 #include "RenderMeshActor.h"
00109 #include "RenderMeshAsset.h"
00110 #include "ResourceCallback.h"
00111 #include "ResourceProvider.h"
00112
00113 #endif // APEX_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ApexCudaContextManager.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Namespaces | Functions
ApexCudaContextManager.h File Reference

The file contains API for PxCudaConextManager public functions. More...

#include "foundation/Px.h"
#include "ApexSDK.h"

Go to the source code of this file.

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Functions

APEX_API int CALL_CONV | nvidia::apex::GetSuggestedCudaDeviceOrdinal (PxErrorCallback &errc)
Ask the NVIDIA control panel which GPU has been selected for use by PhysX. Returns -1 if no PhysX capable GPU is found or GPU PhysX has been disabled.
APEX_API PxCudaContextManager
*CALL_CONV 		nvidia::apex::CreateCudaContextManager (const PxCudaContextManagerDesc &desc, PxErrorCallback &errorCallback)
Allocate a CUDA Context manager, complete with heaps and task dispatcher. You only need one CUDA context manager per GPU device you intend to use for CUDA tasks. If mgr is NULL, no profiling of CUDA code will be possible.

Detailed Description

The file contains API for PxCudaConextManager public functions.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ApexCudaContextManager.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ApexCudaContextManager.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef APEX_CUDA_CONTEXT_MANAGER_H
00031 #define APEX_CUDA_CONTEXT_MANAGER_H
00032
00038 #include "foundation/Px.h"
00039 #include "ApexSDK.h"
00040
00041 namespace physx
00042 {
00043     class PxCudaContextManager;
00044     class PxCudaContextManagerDesc;
00045 }
00046
00047 namespace nvidia
00048 {
00049 namespace apex
00050 {
00051
00057 APEX_API int CALL_CONV GetSuggestedCudaDeviceOrdinal(PxErrorCallback& errc);
00058
00064 APEX_API PxCudaContextManager*  CALL_CONV CreateCudaContextManager(
00065     const PxCudaContextManagerDesc& desc, PxErrorCallback& errorCallback);
00066 }
00067 }
00068
00069 #endif // APEX_CUDA_CONTEXT_MANAGER_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ApexDefs.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Defines
ApexDefs.h File Reference

Version identifiers and other macro definitions. More...

#include "PhysXSDKVersion.h"
#include "foundation/PxPreprocessor.h"

Go to the source code of this file.

Defines

#define | APEX_SDK_VERSION 1
APEX Framework API version.
#define | APEX_SDK_RELEASE 0x01040100
APEX SDK Release version.
#define | DYNAMIC_CAST(type) static_cast<type>
Determines use of dynamic_cast<> by APEX modules.
#define | APEX_CUDA_SUPPORT (PX_SUPPORT_GPU_PHYSX) && !(PX_LINUX)
Enables CUDA code.
#define | APEX_USE_PARTICLES 0
Determines use of particle-related APEX modules.
#define | APEX_UE4 0
Enables code specific for UE4.
#define | APEX_LINUX_SHARED_LIBRARIES 0
Enables Linux shared library.
#define | APEX_DEFAULT_NO_INTEROP_IMPLEMENTATION 1
Provide API stubs with no CUDA interop support.

Detailed Description

Version identifiers and other macro definitions.

This file is intended to be usable without picking up the entire public APEX API, so it explicitly does not include Apex.h

Define Documentation

#define APEX_DEFAULT_NO_INTEROP_IMPLEMENTATION 1

Provide API stubs with no CUDA interop support.

Use this to add default implementations of interop-related interfaces for UserRenderer.

#define APEX_SDK_RELEASE 0x01040100

APEX SDK Release version.

Used for conditionally compiling user code based on the APEX SDK release version.

#define APEX_SDK_VERSION 1

APEX Framework API version.

Used for making sure you are linking to the same version of the SDK files that you have included. Should be incremented with every API change.

#define APEX_USE_PARTICLES 0

Determines use of particle-related APEX modules.

Enables particles related code.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ApexDefs.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ApexDefs.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef APEX_DEFS_H
00031 #define APEX_DEFS_H
00032
00041 #include "PhysXSDKVersion.h"
00042
00067 #include "foundation/PxPreprocessor.h"
00068
00069 #define APEX_SDK_VERSION 1
00070 #define APEX_SDK_RELEASE 0x01040100
00071
00072 #if USE_RTTI
00073 #define DYNAMIC_CAST(type) dynamic_cast<type>
00074 #else
00075 #define DYNAMIC_CAST(type) static_cast<type>
00076 #endif
00077
00079 #if defined(EXCLUDE_CUDA) && (EXCLUDE_CUDA > 0)
00080 #define APEX_CUDA_SUPPORT 0
00081 #else
00082 #define APEX_CUDA_SUPPORT (PX_SUPPORT_GPU_PHYSX) && !(PX_LINUX)
00083 #endif
00084
00086 #if !defined(EXCLUDE_PARTICLES) && PX_WINDOWS
00087 #define APEX_USE_PARTICLES 1
00088 #else
00089 #define APEX_USE_PARTICLES 0
00090 #endif
00091
00093 #ifndef APEX_UE4
00094 #define APEX_UE4 0
00095 #endif
00096
00098 #ifndef APEX_LINUX_SHARED_LIBRARIES
00099 #define APEX_LINUX_SHARED_LIBRARIES 0
00100 #endif
00101
00102 #define APEX_DEFAULT_NO_INTEROP_IMPLEMENTATION 1
00103
00104
00105 #endif // APEX_DEFS_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ApexDesc.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
ApexDesc.h File Reference

class ApexDesc More...

#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ApexDesc
Base class for all APEX Descriptor classes. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class ApexDesc

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ApexDesc.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ApexDesc.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef APEX_DESC_H
00031 #define APEX_DESC_H
00032
00038 #include "ApexUsingNamespace.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 PX_PUSH_PACK_DEFAULT
00046
00062 class ApexDesc
00063 {
00064 public:
00068     void* userData;
00069
00073     PX_INLINE ApexDesc()
00074     {
00075         setToDefault();
00076     }
00080     PX_INLINE void setToDefault()
00081     {
00082         userData = 0;
00083     }
00088     PX_INLINE bool isValid() const
00089     {
00090         return true;
00091     }
00092 };
00093
00094 PX_POP_PACK
00095
00096 }
00097 } // end namespace nvidia::apex
00098
00099 #endif // APEX_DESC_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ApexInterface.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
ApexInterface.h File Reference

class ApexInterface More...

#include "ApexUsingNamespace.h"
#include "RWLockable.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ApexInterface
Base class for all interface classes implemented by APEX SDK. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class ApexInterface

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ApexInterface.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ApexInterface.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef APEX_INTERFACE_H
00031 #define APEX_INTERFACE_H
00032
00038 #include "ApexUsingNamespace.h"
00039 #include "RWLockable.h"
00040
00041 namespace nvidia
00042 {
00043 namespace apex
00044 {
00045
00046 PX_PUSH_PACK_DEFAULT
00047
00053 class ApexInterface : public RWLockable
00054 {
00055 public:
00056     ApexInterface() : userData(NULL) {}
00057
00064     virtual void release() = 0;
00065
00072     void* userData;
00073 };
00074
00075 PX_POP_PACK
00076
00077 }
00078 } // end namespace nvidia::apex
00079
00080 #endif // APEX_INTERFACE_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ApexNameSpace.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Defines
ApexNameSpace.h File Reference

Defines APEX namespace strings. More...

#include "ApexUsingNamespace.h"

Go to the source code of this file.

Defines

#define | APEX_COLLISION_GROUP_NAME_SPACE "NSCollisionGroup"
A namespace for names of collision groups (CollisionGroup).
#define | APEX_COLLISION_GROUP_128_NAME_SPACE "NSCollisionGroup128"
A namespace for names of GroupsMasks.
#define | APEX_COLLISION_GROUP_64_NAME_SPACE "NSCollisionGroup64"
A namespace for names of GroupsMasks64.
#define | APEX_COLLISION_GROUP_MASK_NAME_SPACE "NSCollisionGroupMask"
A namespace for names of collision group masks.
#define | APEX_AUTHORABLE_ASSETS_TYPES_NAME_SPACE "AuthorableAssetTypes"
Internal namespace for authorable asset types.
#define | APEX_NV_PARAM_AUTH_ASSETS_TYPES_NAME_SPACE "NvParamAuthorableAssetTypes"
Internal namespace for parameterized authorable assets.
#define | APEX_MATERIALS_NAME_SPACE "ApexMaterials"
A namespace for graphical material names.
#define | APEX_VOLUME_RENDER_MATERIALS_NAME_SPACE "ApexVolumeRenderMaterials"
A namespace for volumetric rendering material names.
#define | APEX_PHYSICS_MATERIAL_NAME_SPACE "NSPhysicalMaterial"
A namespace for physical material names.
#define | APEX_CUSTOM_VB_NAME_SPACE "NSCustomVBNames"
A namespace for custom vertex buffer semantics names.

Detailed Description

Defines APEX namespace strings.

These are predefined framework namespaces in the named resource provider

Define Documentation

#define APEX_AUTHORABLE_ASSETS_TYPES_NAME_SPACE "AuthorableAssetTypes"

Internal namespace for authorable asset types.

For examples, there are entries in this namespace for "ApexRenderMesh", "NxClothingAsset", "DestructibleAsset", etc... The values stored in this namespace are the namespace IDs of the authorable asset types. So if your module needs to get a pointer to a FooAsset created by module Foo, you can ask the ApexSDK for that asset's namespace ID.

#define APEX_COLLISION_GROUP_128_NAME_SPACE "NSCollisionGroup128"

A namespace for names of GroupsMasks.

Each name in this namespace must map to a pointer to a persistent 128-bit GroupsMask type. The NRP will not automatically generate release requests for names in this namespace.

#define APEX_COLLISION_GROUP_64_NAME_SPACE "NSCollisionGroup64"

A namespace for names of GroupsMasks64.

Each name in this namespace must map to a pointer to a persistent 64-bit GroupsMask64 type. The NRP will not automatically generate release requests for names in this namespace.

#define APEX_COLLISION_GROUP_MASK_NAME_SPACE "NSCollisionGroupMask"

A namespace for names of collision group masks.

Each name in this namespace must map to a 32-bit integer (stored in a void*), wherein each bit represents a collision group (CollisionGroup). The NRP will not automatically generate release requests for names in this namespace.

#define APEX_COLLISION_GROUP_NAME_SPACE "NSCollisionGroup"

A namespace for names of collision groups (CollisionGroup).

Each name in this namespace must map to a 5-bit integer in the range [0..31] (stored in a void*). The NRP will not automatically generate release requests for names in this namespace.

#define APEX_CUSTOM_VB_NAME_SPACE "NSCustomVBNames"

A namespace for custom vertex buffer semantics names.

Each name in this namespace maps to a pointer to a game-engine defined data structure identifying a custom vertex buffer semantic. APEX does not interpret or dereference this pointer in any way. APEX provides an array of these pointers in UserRenderVertexBufferDesc::customBuffersIdents, which is passed the rendering engine when requesting allocation of vertex buffers.

#define APEX_MATERIALS_NAME_SPACE "ApexMaterials"

A namespace for graphical material names.

Each name in this namespace maps to a pointer to a game-engine defined graphical material data structure. APEX does not interpret or dereference this pointer in any way. APEX provides this pointer to the UserRenderResource::setMaterial(void *material) callback to the rendering engine. This mapping allows APEX assets to refer to game engine materials (e.g.: texture maps and shader programs) without imposing any limitations on what a game engine graphical material can contain. The NRP will not automatically generate release requests for names in this namespace.

#define APEX_PHYSICS_MATERIAL_NAME_SPACE "NSPhysicalMaterial"

A namespace for physical material names.

Each name in this namespace maps to MaterialID, which is a data type defined by the PhysX SDK. The NRP will not automatically generate release requests for names in this namespace.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ApexNameSpace.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ApexNameSpace.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef APEX_NAME_SPACE_H
00030 #define APEX_NAME_SPACE_H
00031
00032 #include "ApexUsingNamespace.h"
00033
00047 #define APEX_COLLISION_GROUP_NAME_SPACE             "NSCollisionGroup"
00048
00055 #define APEX_COLLISION_GROUP_128_NAME_SPACE         "NSCollisionGroup128"
00056
00063 #define APEX_COLLISION_GROUP_64_NAME_SPACE          "NSCollisionGroup64"
00064
00072 #define APEX_COLLISION_GROUP_MASK_NAME_SPACE        "NSCollisionGroupMask"
00073
00083 #define APEX_AUTHORABLE_ASSETS_TYPES_NAME_SPACE     "AuthorableAssetTypes"
00084
00088 #define APEX_NV_PARAM_AUTH_ASSETS_TYPES_NAME_SPACE  "NvParamAuthorableAssetTypes"
00089
00100 #define APEX_MATERIALS_NAME_SPACE                   "ApexMaterials"
00101
00106 #define APEX_VOLUME_RENDER_MATERIALS_NAME_SPACE     "ApexVolumeRenderMaterials"
00107
00108
00116 #define APEX_PHYSICS_MATERIAL_NAME_SPACE            "NSPhysicalMaterial"
00117
00126 #define APEX_CUSTOM_VB_NAME_SPACE                   "NSCustomVBNames"
00127
00128 #endif // APEX_NAME_SPACE_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ApexSDK.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Defines | Typedefs | Enumerations | Functions
ApexSDK.h File Reference

APEX SDK classes. More...

#include "ApexDefs.h"
#include "ApexUsingNamespace.h"
#include "ApexDesc.h"
#include "ApexInterface.h"
#include "nvparameterized/NvSerializer.h"
#include "nvparameterized/NvParameterized.h"
#include "nvparameterized/NvParameterizedTraits.h"
#include "Shape.h"

Go to the source code of this file.

Classes

class | nvidia::apex::GroupsMask64
64-bit mask used for collision filtering between IOSes and Field Samplers. More...
struct | nvidia::apex::GroupsFilterOp
Collision groups filtering operations. More...
class | nvidia::apex::ApexSDKDesc
Descriptor class for ApexSDK. More...
class | nvidia::apex::ApexSDK
The ApexSDK abstraction. Manages scenes and modules. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Defines

#define | APEX_API extern "C"
Export the function declaration from its DLL.
#define | CALL_CONV
Use C calling convention, required for exported functions.

Typedefs

typedef unsigned int | nvidia::apex::AuthObjTypeID
Integer values, each representing a unique authorable object class/type.

Enumerations

enum nvidia::apex::ApexCreateError {
nvidia::apex::APEX_CE_NO_ERROR = 0,
nvidia::apex::APEX_CE_NOT_FOUND = 1,
nvidia::apex::APEX_CE_WRONG_VERSION = 2,
nvidia::apex::APEX_CE_DESCRIPTOR_INVALID = 3,
nvidia::apex::APEX_CE_CREATE_NO_ALLOWED = 4
}
These errors are returned by the CreateApexSDK() and ApexSDK::createModule() functions. More...

Functions

APEX_API ApexSDK *CALL_CONV | nvidia::apex::CreateApexSDK (const ApexSDKDesc &desc, ApexCreateError *errorCode=NULL, uint32_t APEXsdkVersion=APEX_SDK_VERSION, PxAllocatorCallback *alloc=0)
Global function to create the SDK object. APEX_SDK_VERSION must be passed for the APEXsdkVersion.
APEX_API ApexSDK *CALL_CONV | nvidia::apex::GetApexSDK ()
Returns global SDK pointer.

Detailed Description

APEX SDK classes.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ApexSDK.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ApexSDK.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef APEX_SDK_H
00031 #define APEX_SDK_H
00032
00038 #include "ApexDefs.h"
00039 #include "ApexUsingNamespace.h"
00040 #include "ApexDesc.h"
00041 #include "ApexInterface.h"
00042
00043 #include "nvparameterized/NvSerializer.h"
00044 #include "nvparameterized/NvParameterized.h"
00045 #include "nvparameterized/NvParameterizedTraits.h"
00046 #include "Shape.h"
00047
00048
00049 namespace RENDER_DEBUG
00050 {
00051     class RenderDebugInterface;
00052 };
00053
00054 namespace physx
00055 {
00056     class PxFoundation;
00057     class PxCpuDispatcher;
00058
00059     namespace profile
00060     {
00061         class PxProfileZoneManager;
00062     }
00063     class PxPvd;
00064 }
00065
00067 namespace nvidia
00068 {
00070 namespace apex
00071 {
00072
00073 class UserRenderResourceManager;
00074 class Scene;
00075 class SceneDesc;
00076 class AssetPreviewScene;
00077 class RenderMeshAsset;
00078 class RenderMeshAssetAuthoring;
00079 class Module;
00080 class PhysXObjectDesc;
00081 class ResourceProvider;
00082 class ResourceCallback;
00083 class RenderDebugInterface;
00084 class Asset;
00085 class AssetAuthoring;
00086 class ApexSDKCachedData;
00087 class RenderMeshActor;
00088
00089 PX_PUSH_PACK_DEFAULT
00090
00094 class GroupsMask64
00095 {
00096 public:
00100     PX_INLINE GroupsMask64()
00101     {
00102         bits0 = bits1 = 0;
00103     }
00104
00108     PX_INLINE GroupsMask64(uint32_t b0, uint32_t b1) : bits0(b0), bits1(b1) {}
00109
00113     PX_INLINE void setToDefault()
00114     {
00115         *this = GroupsMask64();
00116     }
00117
00119     uint32_t        bits0;
00121     uint32_t        bits1;
00122 };
00123
00127 struct GroupsFilterOp
00128 {
00132     enum Enum
00133     {
00134         AND,
00135         OR,
00136         XOR,
00137         NAND,
00138         NOR,
00139         NXOR,
00140         SWAP_AND
00141     };
00142 };
00143
00147 typedef unsigned int AuthObjTypeID;
00148
00152 class ApexSDKDesc : public ApexDesc
00153 {
00154 public:
00158     PxFoundation* foundation;
00159
00167     uint32_t physXSDKVersion;
00168
00169 #if PX_PHYSICS_VERSION_MAJOR == 3
00170
00173     PxPhysics* physXSDK;
00174
00178     PxCooking* cooking;
00179 #endif
00180
00184     PxPvd*  pvd;
00185
00189     UserRenderResourceManager* renderResourceManager;
00190
00198     ResourceCallback* resourceCallback;
00199
00206     const char* dllLoadPath;
00207
00214     const char* wireframeMaterial;
00215
00222     const char* solidShadedMaterial;
00223
00233     bool renderMeshActorLoadMaterialsLazily;
00234
00244     const char* dllNamePostfix;
00245
00253     const char* appGuid;
00254
00255
00261     bool resourceProviderIsCaseSensitive;
00262
00267     uint32_t physXObjDescTableAllocationIncrement;
00268
00273     bool enableConcurrencyCheck;
00274
00278     PX_INLINE ApexSDKDesc() : ApexDesc()
00279     {
00280         init();
00281     }
00282
00286     PX_INLINE void setToDefault()
00287     {
00288         ApexDesc::setToDefault();
00289         init();
00290     }
00291
00296     PX_INLINE bool isValid() const
00297     {
00298         bool retVal = ApexDesc::isValid();
00299
00300         if (foundation == NULL)
00301         {
00302             return false;
00303         }
00304 #if PX_PHYSICS_VERSION_MAJOR == 3
00305         if (physXSDK == NULL)
00306         {
00307             return false;
00308         }
00309         if (cooking == NULL)
00310         {
00311             return false;
00312         }
00313         if (physXSDKVersion != PX_PHYSICS_VERSION)
00314         {
00315             return false;
00316         }
00317 #endif
00318         return retVal;
00319     }
00320
00321 private:
00322     PX_INLINE void init()
00323     {
00324         renderResourceManager = NULL;
00325         foundation = NULL;
00326 #if PX_PHYSICS_VERSION_MAJOR == 3
00327         physXSDKVersion = PX_PHYSICS_VERSION;
00328         physXSDK = NULL;
00329         cooking = NULL;
00330 #endif
00331         pvd = NULL;
00332         resourceCallback = NULL;
00333         dllLoadPath = NULL;
00334         solidShadedMaterial = "ApexSolidShaded";
00335         wireframeMaterial = "ApexWireframe";
00336         renderMeshActorLoadMaterialsLazily = true;
00337         dllNamePostfix = NULL;
00338         appGuid = NULL;
00339         resourceProviderIsCaseSensitive = false;
00340         physXObjDescTableAllocationIncrement = 128;
00341         enableConcurrencyCheck = false;
00342     }
00343 };
00344
00345
00349 enum ApexCreateError
00350 {
00354     APEX_CE_NO_ERROR = 0,
00355
00361     APEX_CE_NOT_FOUND = 1,
00362
00366     APEX_CE_WRONG_VERSION = 2,
00367
00371     APEX_CE_DESCRIPTOR_INVALID = 3,
00372
00376     APEX_CE_CREATE_NO_ALLOWED = 4,
00377
00378 };
00379
00380
00384 class ApexSDK : public ApexInterface
00385 {
00386 public:
00390     virtual Scene* createScene(const SceneDesc&) = 0;
00391
00395     virtual void releaseScene(Scene*) = 0;
00396
00400     virtual AssetPreviewScene* createAssetPreviewScene() = 0;
00401
00405     virtual void releaseAssetPreviewScene(AssetPreviewScene* nxScene) = 0;
00406
00410     virtual Module* createModule(const char* name, ApexCreateError* err = NULL) = 0;
00411
00412 #if PX_PHYSICS_VERSION_MAJOR == 0
00413
00419     virtual physx::PxCpuDispatcher* createCpuDispatcher(uint32_t numThreads = 0) = 0;
00423     virtual void releaseCpuDispatcher(physx::PxCpuDispatcher& cd) = 0;
00424 #endif
00425
00426 #if PX_PHYSICS_VERSION_MAJOR == 3
00427
00431     virtual const PhysXObjectDesc* getPhysXObjectInfo(const PxActor* actor) const = 0;
00432
00437     virtual const PhysXObjectDesc* getPhysXObjectInfo(const PxShape* shape) const = 0;
00438
00443     virtual const PhysXObjectDesc* getPhysXObjectInfo(const PxJoint* joint) const = 0;
00444
00449     virtual const PhysXObjectDesc* getPhysXObjectInfo(const PxCloth* cloth) const = 0;
00450
00454     virtual PxCooking* getCookingInterface() = 0;
00455 #endif
00456
00461     PX_DEPRECATED virtual PxErrorCallback* getOutputStream() = 0;
00462
00466     virtual PxErrorCallback* getErrorCallback() const = 0;
00467
00471     virtual PxAllocatorCallback* getAllocator() const = 0;
00472
00476     virtual ResourceProvider* getNamedResourceProvider() = 0;
00477
00483     virtual PxFileBuf* createStream(const char* filename, PxFileBuf::OpenMode mode) = 0;
00484
00488     virtual PxFileBuf* createMemoryReadStream(const void* mem, uint32_t len) = 0;
00489
00493     virtual PxFileBuf* createMemoryWriteStream(uint32_t alignment = 0) = 0;
00494
00498     virtual const void* getMemoryWriteBuffer(PxFileBuf& stream, uint32_t& len) = 0;
00499
00503     virtual void releaseMemoryReadStream(PxFileBuf& stream) = 0;
00504
00508     virtual void releaseMemoryWriteStream(PxFileBuf& stream) = 0;
00509
00510 #if PX_PHYSICS_VERSION_MAJOR == 3
00511
00514     virtual PxPhysics* getPhysXSDK() = 0;
00515 #endif
00516
00520     virtual uint32_t getNbModules() = 0;
00521
00525     virtual Module** getModules() = 0;
00526
00530     virtual void releaseModule(Module* module) = 0;
00531
00535     virtual RenderDebugInterface* createApexRenderDebug(RENDER_DEBUG::RenderDebugInterface* iface, bool useRemoteDebugVisualization = false) = 0;
00536
00540     virtual void releaseApexRenderDebug(RenderDebugInterface& debug) = 0;
00541
00545     virtual SphereShape* createApexSphereShape() = 0;
00546
00550     virtual CapsuleShape* createApexCapsuleShape() = 0;
00551
00555     virtual BoxShape* createApexBoxShape() = 0;
00556
00560     virtual HalfSpaceShape* createApexHalfSpaceShape() = 0;
00561
00565     virtual void releaseApexShape(Shape& shape) = 0;
00566
00570     virtual uint32_t forceLoadAssets() = 0;
00571
00578     virtual bool getAuthorableObjectNames(const char** authTypeNames, uint32_t& outCount, uint32_t inCount) = 0;
00579
00583     virtual ::NvParameterized::Traits* getParameterizedTraits() = 0;
00584
00588     virtual Asset* createAsset(AssetAuthoring&, const char* name) = 0;
00589
00594     virtual Asset* createAsset(::NvParameterized::Interface*, const char* name) = 0;
00595
00599     virtual void releaseAsset(Asset&) = 0;
00600
00604     virtual AssetAuthoring* createAssetAuthoring(const char* authorTypeName) = 0;
00605
00609     virtual AssetAuthoring* createAssetAuthoring(const char* authorTypeName, const char* name) = 0;
00610
00614     virtual AssetAuthoring* createAssetAuthoring(::NvParameterized::Interface*, const char* name) = 0;
00615
00619     virtual void releaseAssetAuthoring(AssetAuthoring&) = 0;
00620
00624     virtual ApexSDKCachedData& getCachedData() const = 0;
00625
00629     virtual ::NvParameterized::Serializer* createSerializer(::NvParameterized::Serializer::SerializeType type) = 0;
00630
00634     virtual ::NvParameterized::Serializer* createSerializer(::NvParameterized::Serializer::SerializeType type, ::NvParameterized::Traits* traits) = 0;
00635
00640     virtual ::NvParameterized::Serializer::SerializeType getSerializeType(const void* data, uint32_t dlen) = 0;
00641
00645     virtual ::NvParameterized::Serializer::SerializeType getSerializeType(PxFileBuf& stream) = 0;
00646
00650     virtual NvParameterized::Serializer::ErrorType getSerializePlatform(PxFileBuf& stream, NvParameterized::SerializePlatform& platform) = 0;
00651
00656     virtual NvParameterized::Serializer::ErrorType getSerializePlatform(const void* data, uint32_t dlen, NvParameterized::SerializePlatform& platform) = 0;
00657
00661     virtual void getCurrentPlatform(NvParameterized::SerializePlatform& platform) const = 0;
00662
00672     virtual bool getPlatformFromString(const char* name, NvParameterized::SerializePlatform& platform) const = 0;
00673
00677     virtual const char* getPlatformName(const NvParameterized::SerializePlatform& platform) const = 0;
00678
00683     virtual ::NvParameterized::Interface* getDebugColorParams() const = 0;
00684
00688     virtual const char* getWireframeMaterial() = 0;
00689
00693     virtual const char* getSolidShadedMaterial() = 0;
00694
00698     virtual void setEnableApexStats(bool enableApexStats) = 0;
00699
00703     virtual void setEnableConcurrencyCheck(bool enableConcurrencyChecks) = 0;
00704
00708     virtual bool isConcurrencyCheckEnabled() = 0;
00709
00710 protected:
00711     virtual ~ApexSDK() {}
00712
00713 };
00714
00725 PX_POP_PACK
00726
00727 #ifdef CALL_CONV
00728 #undef CALL_CONV
00729 #endif
00730
00731 #if PX_WINDOWS_FAMILY
00732
00733 #define APEX_API extern "C" __declspec(dllexport)
00734 #define CALL_CONV __cdecl
00735 #else
00736 #define APEX_API extern "C"
00737 #define CALL_CONV /* void */
00738 #endif
00739
00743 APEX_API ApexSDK*   CALL_CONV CreateApexSDK(    const ApexSDKDesc& desc,
00744                                                         ApexCreateError* errorCode = NULL,
00745                                                         uint32_t APEXsdkVersion = APEX_SDK_VERSION,
00746                                                         PxAllocatorCallback* alloc = 0);
00747
00751 APEX_API ApexSDK*   CALL_CONV GetApexSDK();
00752
00753 }
00754 } // end namespace nvidia::apex
00755
00756 #endif // APEX_SDK_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ApexSDKCachedData.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
ApexSDKCachedData.h File Reference

classes ModuleCachedData, ApexSDKCachedData More...

#include "ApexSDK.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ModuleCachedData
Cached data is stored per-module. More...
class | nvidia::apex::ApexSDKCachedData
A method for storing actor data in a scene. More...

Namespaces

namespace | NvParameterized

NvParameterized namespace.

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

classes ModuleCachedData, ApexSDKCachedData

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ApexSDKCachedData.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ApexSDKCachedData.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef APEX_SDKCACHED_DATA_H
00031 #define APEX_SDKCACHED_DATA_H
00032
00038 #include "ApexSDK.h"
00039
00040 namespace NvParameterized
00041 {
00042 class Interface;
00043 };
00044
00045 namespace nvidia
00046 {
00047 namespace apex
00048 {
00049
00050
00054 class ModuleCachedData
00055 {
00056 public:
00062     virtual ::NvParameterized::Interface*   getCachedDataForAssetAtScale(Asset& asset, const PxVec3& scale) = 0;
00063
00067     virtual PxFileBuf& serializeSingleAsset(Asset& asset, PxFileBuf& stream) = 0;
00068
00072     virtual PxFileBuf& deserializeSingleAsset(Asset& asset, PxFileBuf& stream) = 0;
00073 };
00074
00078 class ApexSDKCachedData
00079 {
00080 public:
00086     virtual ModuleCachedData*   getCacheForModule(AuthObjTypeID moduleID) = 0;
00087
00091     virtual PxFileBuf&          serialize(PxFileBuf&) const = 0;
00092
00096     virtual PxFileBuf&          deserialize(PxFileBuf&) = 0;
00097
00101     virtual void                clear(bool force = true) = 0;
00102
00103 protected:
00104     ApexSDKCachedData() {}
00105     virtual                     ~ApexSDKCachedData() {}
00106 };
00107
00108 }
00109 } // end namespace nvidia::apex
00110
00111
00112 #endif // APEX_SDKCACHED_DATA_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ApexSDKVersionString.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Namespaces | Defines | Enumerations | Functions
ApexSDKVersionString.h File Reference

APEX SDK versioning definitions. More...

#include "foundation/PxPreprocessor.h"
#include "ApexDefs.h"

Go to the source code of this file.

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Defines

#define | APEX_API extern "C"
Export the function declaration from its DLL.
#define | CALL_CONV
Use C calling convention, required for exported functions.

Enumerations

enum nvidia::apex::ApexSDKVersionString {
nvidia::apex::VERSION = 0,
nvidia::apex::CHANGELIST = 1,
nvidia::apex::TOOLS_CHANGELIST = 2,
nvidia::apex::BRANCH = 3,
nvidia::apex::BUILD_TIME = 4,
nvidia::apex::AUTHOR = 5,
nvidia::apex::REASON = 6
}
These values are used to select version string GetApexSDKVersionString function should return. More...

Functions

APEX_API const char *CALL_CONV | nvidia::apex::GetApexSDKVersionString (ApexSDKVersionString versionString)
Returns version strings.

Detailed Description

APEX SDK versioning definitions.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ApexSDKVersionString.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ApexSDKVersionString.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef APEX_SDKVERSION_STRING_H
00031 #define APEX_SDKVERSION_STRING_H
00032
00038 #include "foundation/PxPreprocessor.h"
00039 #include "ApexDefs.h"
00040
00042 namespace nvidia
00043 {
00045 namespace apex
00046 {
00047
00051 enum ApexSDKVersionString
00052 {
00056     VERSION = 0,
00060     CHANGELIST = 1,
00064     TOOLS_CHANGELIST = 2,
00068     BRANCH = 3,
00072     BUILD_TIME = 4,
00076     AUTHOR = 5,
00080     REASON = 6
00081 };
00082
00093 #ifdef CALL_CONV
00094 #undef CALL_CONV
00095 #endif
00096
00097 #if PX_WINDOWS_FAMILY
00098 #define APEX_API extern "C" __declspec(dllexport)
00099 #define CALL_CONV __cdecl
00100 #else
00101 #define APEX_API extern "C"
00102 #define CALL_CONV /* void */
00103 #endif
00104
00108 APEX_API const char*    CALL_CONV GetApexSDKVersionString(ApexSDKVersionString versionString);
00109
00110 }
00111 } // end namespace nvidia::apex
00112
00113 #endif // APEX_SDKVERSION_STRING_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ApexUsingNamespace.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ApexUsingNamespace.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef APEX_USING_NAMESPACE_H
00031 #define APEX_USING_NAMESPACE_H
00032
00033 #include "foundation/Px.h"
00034 #include "ApexDefs.h"
00035
00036 #define FORWARD_DECLARATION_AND_USING(T, X) \
00037     namespace physx \
00038     { \
00039         T X ; \
00040     }; \
00041
00042 FORWARD_DECLARATION_AND_USING(class,    PxActor);
00043 FORWARD_DECLARATION_AND_USING(class,    PxBase);
00044 FORWARD_DECLARATION_AND_USING(class,    PxBoxGeometry);
00045 FORWARD_DECLARATION_AND_USING(class,    PxCapsuleGeometry);
00046 FORWARD_DECLARATION_AND_USING(class,    PxCloth);
00047 FORWARD_DECLARATION_AND_USING(class,    PxCooking);
00048 FORWARD_DECLARATION_AND_USING(struct,   PxConvexFlag);
00049 FORWARD_DECLARATION_AND_USING(class,    PxConvexMesh);
00050 FORWARD_DECLARATION_AND_USING(class,    PxConvexMeshGeometry);
00051 FORWARD_DECLARATION_AND_USING(struct,   PxDebugPoint);
00052 FORWARD_DECLARATION_AND_USING(struct,   PxDebugLine);
00053 FORWARD_DECLARATION_AND_USING(struct,   PxDebugTriangle);
00054 FORWARD_DECLARATION_AND_USING(struct,   PxDebugText);
00055 FORWARD_DECLARATION_AND_USING(struct,   PxFilterData);
00056 FORWARD_DECLARATION_AND_USING(struct,   PxFilterFlag);
00057 FORWARD_DECLARATION_AND_USING(class,    PxGeometry);
00058 FORWARD_DECLARATION_AND_USING(struct,   PxGeometryType);
00059 FORWARD_DECLARATION_AND_USING(class,    PxJoint);
00060 FORWARD_DECLARATION_AND_USING(class,    PxMaterial);
00061 FORWARD_DECLARATION_AND_USING(struct,   PxPairFlag);
00062 FORWARD_DECLARATION_AND_USING(class,    PxParticleBase);
00063 FORWARD_DECLARATION_AND_USING(class,    PxParticleFluid);
00064 FORWARD_DECLARATION_AND_USING(class,    PxParticleSystem);
00065 FORWARD_DECLARATION_AND_USING(class,    PxPhysics);
00066 FORWARD_DECLARATION_AND_USING(struct,   PxQueryFilterData);
00067 FORWARD_DECLARATION_AND_USING(struct,   PxQueryFlag);
00068 FORWARD_DECLARATION_AND_USING(struct,   PxQueryHit);
00069 FORWARD_DECLARATION_AND_USING(struct,   PxQueryHitType);
00070 FORWARD_DECLARATION_AND_USING(class,    PxRenderBuffer);
00071 FORWARD_DECLARATION_AND_USING(class,    PxRigidActor);
00072 FORWARD_DECLARATION_AND_USING(class,    PxRigidBody);
00073 FORWARD_DECLARATION_AND_USING(struct,   PxRigidBodyFlag);
00074 FORWARD_DECLARATION_AND_USING(class,    PxRigidDynamic);
00075 FORWARD_DECLARATION_AND_USING(class,    PxSimulationEventCallback);
00076 FORWARD_DECLARATION_AND_USING(class,    PxContactModifyCallback);
00077 FORWARD_DECLARATION_AND_USING(class,    PxScene);
00078 FORWARD_DECLARATION_AND_USING(class,    PxShape);
00079 FORWARD_DECLARATION_AND_USING(struct,   PxShapeFlag);
00080 FORWARD_DECLARATION_AND_USING(class,    PxSphereGeometry);
00081 FORWARD_DECLARATION_AND_USING(class,    PxTriangleMesh);
00082 FORWARD_DECLARATION_AND_USING(class,    PxTriangleMeshGeometry);
00083
00084 namespace physx
00085 {
00086     namespace shdfnd {}
00087     using namespace shdfnd;
00088
00089     namespace general_PxIOStream2
00090     {
00091         class PxFileBuf;
00092     }
00093 }
00094
00095 namespace nvidia
00096 {
00097     namespace apex {}
00098     using namespace apex;
00099
00100     using namespace physx;
00101     using namespace physx::shdfnd;
00102     using namespace physx::general_PxIOStream2;
00103 };
00104
00105
00106
00107 #endif // APEX_USING_NAMESPACE_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: Asset.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Variables
Asset.h File Reference

class Asset More...

#include "ApexInterface.h"
#include "ApexSDK.h"
#include "AssetPreviewScene.h"

Go to the source code of this file.

Classes

class | nvidia::apex::Asset
Base class of all APEX assets. More...
class | nvidia::apex::AssetAuthoring
base class of all APEX asset authoring classes More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Variables

PX_PUSH_PACK_DEFAULT typedef
const char * 		nvidia::apex::PlatformTag
Usual typedef.

Detailed Description

class Asset

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Asset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Asset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef ASSET_H
00031 #define ASSET_H
00032
00038 #include "ApexInterface.h"
00039 #include "ApexSDK.h"
00040 #include "AssetPreviewScene.h"
00041
00042 namespace nvidia
00043 {
00044 namespace apex
00045 {
00046
00047 PX_PUSH_PACK_DEFAULT
00048
00050 typedef const char* PlatformTag;
00051
00052 class Actor;
00053 class AssetPreview;
00054
00058 class Asset : public ApexInterface
00059 {
00060 public:
00064     virtual const char* getName() const = 0;
00065
00072     virtual AuthObjTypeID getObjTypeID() const = 0;
00073
00077     virtual const char* getObjTypeName() const = 0;
00078
00083     virtual uint32_t forceLoadAssets() = 0;
00084
00090     virtual ::NvParameterized::Interface* getDefaultActorDesc() = 0;
00091
00095     virtual ::NvParameterized::Interface* getDefaultAssetPreviewDesc() = 0;
00096
00101     virtual const ::NvParameterized::Interface* getAssetNvParameterized() const = 0;
00102
00106     virtual Actor* createApexActor(const ::NvParameterized::Interface& actorParams, Scene& apexScene) = 0;
00107
00111     virtual AssetPreview* createApexAssetPreview(const ::NvParameterized::Interface& params, AssetPreviewScene* previewScene) = 0;
00112
00116     virtual NvParameterized::Interface* releaseAndReturnNvParameterizedInterface(void) = 0;
00117
00123     virtual bool isValidForActorCreation(const ::NvParameterized::Interface& actorParams, Scene& /*apexScene*/) const = 0;
00124
00130     virtual bool isDirty() const = 0;
00131
00132 protected:
00133     virtual ~Asset() {}; // illegal, do not call
00134 };
00135
00139 class AssetAuthoring : public ApexInterface
00140 {
00141 public:
00145     virtual const char* getName() const = 0;
00146
00150     virtual const char* getObjTypeName() const = 0;
00151
00155     virtual bool prepareForPlatform(nvidia::apex::PlatformTag) = 0;
00156
00160     virtual ::NvParameterized::Interface* getNvParameterized() const = 0;
00161
00165     virtual NvParameterized::Interface* releaseAndReturnNvParameterizedInterface(void) = 0;
00166
00174     virtual void setToolString(const char* toolName, const char* toolVersion, uint32_t toolChangelist) = 0;
00175 };
00176
00177 PX_POP_PACK
00178
00179 }
00180 } // end namespace nvidia::apex
00181
00182 #endif // ASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: AssetPreview.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
AssetPreview.h File Reference

class AssetPreview More...

#include "ApexInterface.h"
#include "Renderable.h"

Go to the source code of this file.

Classes

class | nvidia::apex::AssetPreview
Base class of all APEX asset previews. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class AssetPreview

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: AssetPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
AssetPreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef ASSET_PREVIEW_H
00031 #define ASSET_PREVIEW_H
00032
00038 #include "ApexInterface.h"
00039 #include "Renderable.h"
00040
00041 namespace nvidia
00042 {
00043 namespace apex
00044 {
00045
00046 PX_PUSH_PACK_DEFAULT
00047
00055 class AssetPreview : public ApexInterface, public Renderable
00056 {
00057 public:
00058
00062     virtual void setPose(const PxMat44& pose) = 0;
00063
00069     virtual const PxMat44 getPose() const = 0;
00070 protected:
00071     AssetPreview() {}
00072 };
00073
00074 PX_POP_PACK
00075
00076 }
00077 } // end namespace nvidia::apex
00078
00079 #endif // ASSET_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: AssetPreviewScene.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
AssetPreviewScene.h File Reference

classes Scene, SceneStats, SceneDesc More...

#include "ApexDesc.h"
#include "Renderable.h"
#include "Context.h"
#include "foundation/PxVec3.h"
#include <ApexDefs.h>
#include "PxFiltering.h"

Go to the source code of this file.

Classes

class | nvidia::apex::AssetPreviewScene
An APEX class for. More...

Namespaces

namespace | NvParameterized

NvParameterized namespace.

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

classes Scene, SceneStats, SceneDesc

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: AssetPreviewScene.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
AssetPreviewScene.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef ASSET_PREVIEW_SCENE_H
00031 #define ASSET_PREVIEW_SCENE_H
00032
00038 #include "ApexDesc.h"
00039 #include "Renderable.h"
00040 #include "Context.h"
00041 #include "foundation/PxVec3.h"
00042 #include <ApexDefs.h>
00043
00044 #if PX_PHYSICS_VERSION_MAJOR == 3
00045 #include "PxFiltering.h"
00046 #endif
00047 namespace physx
00048 {
00049     class PxActor;
00050     class PxScene;
00051     class PxRenderBuffer;
00052
00053     class PxCpuDispatcher;
00054     class PxGpuDispatcher;
00055     class PxTaskManager;
00056     class PxBaseTask;
00057 }
00058
00059 namespace NvParameterized
00060 {
00061 class Interface;
00062 }
00063
00064 namespace nvidia
00065 {
00066 namespace apex
00067 {
00068
00069 PX_PUSH_PACK_DEFAULT
00070
00071
00075 class AssetPreviewScene : public ApexInterface
00076 {
00077 public:
00081     virtual void                    setCameraMatrix(const PxMat44& viewTransform) = 0;
00082
00086     virtual PxMat44                 getCameraMatrix() const = 0;
00087
00091     virtual void                    setShowFullInfo(bool showFullInfo) = 0;
00092
00096     virtual bool                    getShowFullInfo() const = 0;
00097 };
00098
00099
00100 PX_POP_PACK
00101 }
00102 } // end namespace nvidia::apex
00103
00104 #endif // ASSET_PREVIEW_SCENE_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: AttractorFSActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
AttractorFSActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef ATTRACTOR_FSACTOR_H
00031 #define ATTRACTOR_FSACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class BasicFSAsset;
00043
00044
00048 class AttractorFSActor : public Actor, public Renderable
00049 {
00050 protected:
00051     virtual ~AttractorFSActor() {}
00052
00053 public:
00057     virtual BasicFSAsset*       getAttractorFSAsset() const = 0;
00058
00062     virtual PxVec3              getCurrentPosition() const = 0;
00063
00067     virtual void                setCurrentPosition(const PxVec3& pos) = 0;
00068
00072     virtual void                setFieldRadius(float) = 0;
00073
00077     virtual void                setConstFieldStrength(float) = 0;
00078
00082     virtual void                setVariableFieldStrength(float) = 0;
00083
00087     virtual void                setEnabled(bool isEnabled) = 0;
00088
00092     virtual void                setCurrentScale(float scale) = 0;
00093
00097     virtual float               getCurrentScale(void) const = 0;
00098
00099 };
00100
00101 PX_POP_PACK
00102
00103 }
00104 } // end namespace nvidia::apex
00105
00106 #endif // ATTRACTOR_FSACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: AttractorFSPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
AttractorFSPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef ATTRACTOR_FSPREVIEW_H
00030 #define ATTRACTOR_FSPREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class RenderDebugInterface;
00043
00052 namespace APEX_ATTRACT
00053 {
00058 static const uint32_t ATTRACT_DRAW_NOTHING = 0x00;
00063 static const uint32_t ATTRACT_DRAW_SHAPE = 0x01;
00070 static const uint32_t ATTRACT_DRAW_ASSET_INFO = 0x02;
00075 static const uint32_t ATTRACT_DRAW_FULL_DETAIL = (ATTRACT_DRAW_SHAPE + ATTRACT_DRAW_ASSET_INFO);
00076 }
00077
00082 class AttractorFSPreview : public AssetPreview
00083 {
00084 public:
00088     virtual void    setRadius(float radius) = 0;
00089
00100     virtual void    setDetailLevel(uint32_t detail) = 0;
00101 };
00102
00103
00104 PX_POP_PACK
00105
00106 }
00107 } // namespace nvidia
00108
00109 #endif // ATTRACTOR_FS_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: BasicFSAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
BasicFSAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef BASIC_FSASSET_H
00030 #define BASIC_FSASSET_H
00031
00032 #include "Apex.h"
00033
00034 namespace nvidia
00035 {
00036 namespace apex
00037 {
00038
00039 PX_PUSH_PACK_DEFAULT
00040
00041 #define JET_FS_AUTHORING_TYPE_NAME  "JetFSAsset"
00042 #define ATTRACTOR_FS_AUTHORING_TYPE_NAME    "AttractorFSAsset"
00043 #define VORTEX_FS_AUTHORING_TYPE_NAME   "VortexFSAsset"
00044 #define NOISE_FS_AUTHORING_TYPE_NAME "NoiseFSAsset"
00045 #define WIND_FS_AUTHORING_TYPE_NAME "WindFSAsset"
00046
00050 class BasicFSAsset : public Asset
00051 {
00052 protected:
00053     virtual ~BasicFSAsset() {}
00054
00055 public:
00056 };
00057
00061 class BasicFSAssetAuthoring : public AssetAuthoring
00062 {
00063 protected:
00064     virtual ~BasicFSAssetAuthoring() {}
00065
00066 public:
00067 };
00068
00069
00070 PX_POP_PACK
00071
00072 }
00073 } // end namespace nvidia::apex
00074
00075 #endif // BASIC_FSASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: BasicIosActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
BasicIosActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef BASIC_IOS_ACTOR_H
00031 #define BASIC_IOS_ACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00045 class BasicIosActor : public Actor
00046 {
00047 public:
00048
00050     virtual float                       getParticleRadius() const = 0;
00051
00053     virtual float                       getRestDensity() const = 0;
00054
00056     virtual uint32_t                    getParticleCount() const = 0;
00057
00058 protected:
00059
00060     virtual ~BasicIosActor()    {}
00061 };
00062
00063 PX_POP_PACK
00064
00065 }
00066 } // namespace nvidia
00067
00068 #endif // BASIC_IOS_ACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: BasicIosAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
BasicIosAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef BASIC_IOS_ASSET_H
00031 #define BASIC_IOS_ASSET_H
00032
00033 #include "Apex.h"
00034 #include <limits.h>
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define BASIC_IOS_AUTHORING_TYPE_NAME "BasicIosAsset"
00044
00048 class BasicIosAsset : public IosAsset
00049 {
00050 public:
00051
00053     virtual float                       getParticleRadius() const = 0;
00054
00056     virtual float                       getRestDensity() const = 0;
00057
00059     virtual float                       getMaxInjectedParticleCount() const = 0;
00060
00062     virtual uint32_t                    getMaxParticleCount() const = 0;
00063
00065     virtual float                       getParticleMass() const = 0;
00066
00067 protected:
00068     virtual ~BasicIosAsset()    {}
00069 };
00070
00074 class BasicIosAssetAuthoring : public AssetAuthoring
00075 {
00076 public:
00077
00079     virtual void setParticleRadius(float) = 0;
00080
00082     virtual void setRestDensity(float) = 0;
00083
00085     virtual void setMaxInjectedParticleCount(float count) = 0;
00086
00088     virtual void setMaxParticleCount(uint32_t count) = 0;
00089
00091     virtual void setParticleMass(float) = 0;
00092
00094     virtual void setCollisionGroupName(const char* collisionGroupName) = 0;
00095
00097     virtual void setCollisionGroupMaskName(const char* collisionGroupMaskName) = 0;
00098
00099 protected:
00100     virtual ~BasicIosAssetAuthoring()   {}
00101 };
00102
00103 PX_POP_PACK
00104
00105 }
00106 } // namespace nvidia
00107
00108 #endif // BASIC_IOS_ASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ClothingActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ClothingActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_ACTOR_H
00031 #define CLOTHING_ACTOR_H
00032
00033 #include "Actor.h"
00034 #include "Renderable.h"
00035 #include "ClothingAsset.h"
00036
00037 namespace NvParameterized
00038 {
00039 class Interface;
00040 }
00041
00042 namespace nvidia
00043 {
00044 namespace apex
00045 {
00046
00047 PX_PUSH_PACK_DEFAULT
00048
00049 class ClothingVelocityCallback;
00050 class ClothingPlane;
00051 class ClothingConvex;
00052 class ClothingSphere;
00053 class ClothingCapsule;
00054 class ClothingTriangleMesh;
00055 class ClothingRenderProxy;
00056
00057
00061 struct ClothingTeleportMode
00062 {
00064     enum Enum
00065     {
00069         Continuous,
00070
00076         Teleport,
00077
00083         TeleportAndReset,
00084     };
00085 };
00086
00087
00088
00092 class ClothingActor : public Actor, public Renderable
00093 {
00094 protected:
00095     virtual ~ClothingActor() {}
00096 public:
00097
00103     virtual ::NvParameterized::Interface* getActorDesc() = 0;
00104
00117     virtual void updateState(const PxMat44& globalPose, const PxMat44* newBoneMatrices, uint32_t boneMatricesByteStride, uint32_t numBoneMatrices, ClothingTeleportMode::Enum teleportMode) = 0;
00118
00125     virtual void updateMaxDistanceScale(float scale, bool multipliable) = 0;
00126
00130     virtual const PxMat44& getGlobalPose() const = 0;
00131
00142     virtual void setWind(float windAdaption, const PxVec3& windVelocity) = 0;
00143
00152     virtual void setMaxDistanceBlendTime(float blendTime) = 0;
00153
00159     virtual float getMaxDistanceBlendTime() const = 0;
00160
00168     virtual void setVisible(bool enable) = 0;
00169
00174     virtual bool isVisible() const = 0;
00175
00179     virtual void setFrozen(bool enable) = 0;
00180
00184     virtual bool isFrozen() const = 0;
00185
00189     virtual ClothSolverMode::Enum getClothSolverMode() const = 0;
00190
00201     virtual void setGraphicalLOD(uint32_t lod) = 0;
00202
00207     virtual uint32_t getGraphicalLod() = 0;
00208
00220     virtual bool rayCast(const PxVec3& worldOrigin, const PxVec3& worldDirection, float& time, PxVec3& normal, uint32_t& vertexIndex) = 0;
00221
00225     virtual void attachVertexToGlobalPosition(uint32_t vertexIndex, const PxVec3& globalPosition) = 0;
00226
00230     virtual void freeVertex(uint32_t vertexIndex) = 0;
00231
00235     virtual uint32_t getClothingMaterial() const = 0;
00236
00240     virtual void setClothingMaterial(uint32_t index) = 0;
00241
00245     virtual void setOverrideMaterial(uint32_t submeshIndex, const char* overrideMaterialName) = 0;
00246
00250     virtual void setVelocityCallback(ClothingVelocityCallback* callback) = 0;
00251
00261     virtual void getPhysicalMeshPositions(void* buffer, uint32_t byteStride) = 0;
00262
00272     virtual void getPhysicalMeshNormals(void* buffer, uint32_t byteStride) = 0;
00273
00277     virtual float getMaximumSimulationBudget() const = 0;
00278
00287     virtual uint32_t getNumSimulationVertices() const = 0;
00288
00289
00297     virtual const PxVec3* getSimulationPositions() = 0;
00298
00306     virtual const PxVec3* getSimulationNormals() = 0;
00307
00317     virtual bool getSimulationVelocities(PxVec3* velocities) = 0;
00318
00326     virtual uint32_t getNumGraphicalVerticesActive(uint32_t submeshIndex) const = 0;
00327
00333     virtual PxMat44 getRenderGlobalPose() const = 0;
00334
00341     virtual const PxMat44* getCurrentBoneSkinningMatrices() const = 0;
00342
00343
00349     virtual bool isHalfPrecisionAllowed() const = 0;
00350
00360     virtual void setHalfPrecision(bool isAllowed) = 0;
00361
00362
00366     virtual ClothingPlane* createCollisionPlane(const PxPlane& plane) = 0;
00367
00371     virtual ClothingConvex* createCollisionConvex(ClothingPlane** planes, uint32_t numPlanes) = 0;
00372
00376     virtual ClothingSphere* createCollisionSphere(const PxVec3& position, float radius) = 0;
00377
00381     virtual ClothingCapsule* createCollisionCapsule(ClothingSphere& sphere1, ClothingSphere& sphere2) = 0;
00382
00386     virtual ClothingTriangleMesh* createCollisionTriangleMesh() = 0;
00387
00404     virtual ClothingRenderProxy* acquireRenderProxy() = 0;
00405
00406 #if APEX_UE4
00407
00408     virtual void simulate(PxF32 dt) = 0;
00409 #endif
00410 };
00411
00412 PX_POP_PACK
00413
00414 }
00415 } // namespace nvidia
00416
00417 #endif // CLOTHING_ACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ClothingAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ClothingAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_ASSET_H
00031 #define CLOTHING_ASSET_H
00032
00033 #include "Asset.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class ClothingActor;
00043 class ClothingPreview;
00044
00045 #define CLOTHING_AUTHORING_TYPE_NAME "ClothingAsset"
00046
00047
00051 struct ClothSolverMode
00052 {
00054     enum Enum
00055     {
00059         v3,
00060     };
00061 };
00062
00063
00092 struct ClothingMeshSkinningMap
00093 {
00098     PxVec3 positionBary;
00099
00103     uint32_t vertexIndex0;
00104
00110     PxVec3 normalBary;
00111
00115     uint32_t vertexIndex1;
00116
00122     PxVec3 tangentBary;
00123
00127     uint32_t vertexIndex2;
00128 };
00129
00133 class ClothingAsset : public Asset
00134 {
00135 protected:
00136     // do not manually delete this object
00137     virtual ~ClothingAsset() {}
00138 public:
00142     virtual uint32_t getNumActors() const = 0;
00143
00147     virtual ClothingActor* getActor(uint32_t index) = 0;
00148
00152     virtual PxBounds3 getBoundingBox() const = 0;
00153
00157     virtual uint32_t getNumGraphicalLodLevels() const = 0;
00158
00162     virtual uint32_t getGraphicalLodValue(uint32_t lodLevel) const = 0;
00163
00167     virtual float getBiggestMaxDistance() const = 0;
00168
00172     virtual ClothSolverMode::Enum getClothSolverMode() const = 0;
00173
00182     virtual bool remapBoneIndex(const char* name, uint32_t newIndex) = 0;
00183
00187     virtual uint32_t getNumBones() const = 0;
00188
00192     virtual uint32_t getNumUsedBones() const = 0;
00193
00197     virtual const char* getBoneName(uint32_t internalIndex) const = 0;
00198
00202     virtual bool getBoneBasePose(uint32_t internalIndex, PxMat44& result) const = 0;
00203
00209     virtual void getBoneMapping(uint32_t* internal2externalMap) const = 0;
00210
00218     virtual const RenderMeshAsset*  getRenderMeshAsset(uint32_t lodLevel) const = 0;
00219
00231     virtual uint32_t prepareMorphTargetMapping(const PxVec3* originalPositions, uint32_t numPositions, float epsilon) = 0;
00232
00239     virtual uint32_t getMeshSkinningMapSize(uint32_t lod) = 0;
00240
00251     virtual void getMeshSkinningMap(uint32_t lod, ClothingMeshSkinningMap* map) = 0;
00252
00256     virtual bool releaseGraphicalData() = 0;
00257 };
00258
00259 PX_POP_PACK
00260
00261 } // namespace nvidia
00262 } // namespace nvidia
00263
00264 #endif // CLOTHING_ASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ClothingAssetAuthoring.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ClothingAssetAuthoring.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_ASSET_AUTHORING_H
00031 #define CLOTHING_ASSET_AUTHORING_H
00032
00033 #include "Asset.h"
00034 #include "IProgressListener.h"
00035 #include "ClothingPhysicalMesh.h"
00036
00037
00038 namespace nvidia
00039 {
00040 namespace apex
00041 {
00042
00043 PX_PUSH_PACK_DEFAULT
00044
00045
00046 class ClothingPhysicalMesh;
00047
00048
00052 class ClothingAssetAuthoring : public AssetAuthoring
00053 {
00054 public:
00055
00059     virtual void setDefaultConstrainCoefficients(const ClothingConstrainCoefficients& coeff) = 0;
00060
00064     virtual void setInvalidConstrainCoefficients(const ClothingConstrainCoefficients& coeff) = 0;
00065
00081     virtual void setMeshes(uint32_t lod, RenderMeshAssetAuthoring* graphicalMesh, ClothingPhysicalMesh* physicalMesh,
00082                            float normalResemblance = 25, bool ignoreUnusedVertices = true, IProgressListener* progress = NULL) = 0;
00083
00084
00088     virtual bool addPlatformToGraphicalLod(uint32_t lod, PlatformTag platform) = 0;
00089
00093     virtual bool removePlatform(uint32_t lod,  PlatformTag platform) = 0;
00094
00098     virtual uint32_t getNumPlatforms(uint32_t lod) const = 0;
00099
00103     virtual PlatformTag getPlatform(uint32_t lod, uint32_t i) const = 0;
00104
00108     virtual uint32_t getNumLods() const = 0;
00109
00115     virtual int32_t getLodValue(uint32_t lod) const = 0;
00116
00120     virtual void clearMeshes() = 0;
00121
00125     virtual ClothingPhysicalMesh* getClothingPhysicalMesh(uint32_t graphicalLod) const = 0;
00126
00135     virtual void setBoneInfo(uint32_t boneIndex, const char* boneName, const PxMat44& bindPose, int32_t parentIndex) = 0;
00136
00142     virtual void setRootBone(const char* boneName) = 0;
00143
00151     virtual uint32_t addBoneConvex(const char* boneName, const PxVec3* positions, uint32_t numPositions) = 0;
00152
00160     virtual uint32_t addBoneConvex(uint32_t boneIndex, const PxVec3* positions, uint32_t numPositions) = 0;
00161
00170     virtual void addBoneCapsule(const char* boneName, float capsuleRadius, float capsuleHeight, const PxMat44& localPose) = 0;
00171
00180     virtual void addBoneCapsule(uint32_t boneIndex, float capsuleRadius, float capsuleHeight, const PxMat44& localPose) = 0;
00181
00185     virtual void clearBoneActors(const char* boneName) = 0;
00186
00190     virtual void clearBoneActors(uint32_t boneIndex) = 0;
00191
00195     virtual void clearAllBoneActors() = 0;
00196
00209     virtual void setCollision(const char** boneNames, float* radii, PxVec3* localPositions, uint32_t numSpheres, uint16_t* pairs, uint32_t numIndices) = 0;
00210
00214     virtual void setCollision(uint32_t* boneIndices, float* radii, PxVec3* localPositions, uint32_t numSpheres, uint16_t* pairs, uint32_t numIndices) = 0;
00215
00219     virtual void clearCollision() = 0;
00220
00226     virtual void setSimulationHierarchicalLevels(uint32_t levels) = 0;
00227
00228
00232     virtual void setSimulationThickness(float thickness) = 0;
00233
00237     virtual void setSimulationVirtualParticleDensity(float density) = 0;
00238
00242     virtual void setSimulationSleepLinearVelocity(float sleep) = 0;
00243
00247     virtual void setSimulationGravityDirection(const PxVec3& gravity) = 0;
00248
00257     virtual void setSimulationDisableCCD(bool disable) = 0;
00258
00262     virtual void setSimulationTwowayInteraction(bool enable) = 0;
00263
00269     virtual void setSimulationUntangling(bool enable) = 0;
00270
00274     virtual void setSimulationRestLengthScale(float scale) = 0;
00275
00283     virtual void setExportScale(float scale) = 0;
00284
00299     virtual void applyTransformation(const PxMat44& transformation, float scale, bool applyToGraphics, bool applyToPhysics) = 0;
00300
00309     virtual void updateBindPoses(const PxMat44* newBindPoses, uint32_t newBindPosesCount, bool isInternalOrder, bool maintainCollisionWorldSpace) = 0;
00310
00315     virtual void setDeriveNormalsFromBones(bool enable) = 0;
00316
00320     virtual NvParameterized::Interface* getMaterialLibrary() = 0;
00321
00329     virtual bool setMaterialLibrary(NvParameterized::Interface* materialLibrary, uint32_t materialIndex, bool transferOwnership) = 0;
00330
00342     virtual ::NvParameterized::Interface*   getRenderMeshAssetAuthoring(uint32_t lodLevel) const = 0;
00343
00347     virtual bool getBoneBindPose(uint32_t boneIndex, PxMat44& bindPose) const = 0;
00348
00352     virtual bool setBoneBindPose(uint32_t boneIndex, const PxMat44& bindPose) = 0;
00353 };
00354
00355 PX_POP_PACK
00356
00357 } // namespace nvidia
00358 } // namespace nvidia
00359
00360 #endif // CLOTHING_ASSET_AUTHORING_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ClothingCollision.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
ClothingCollision.h File Reference

classes ClothingCollision, ClothingPlane, ClothingConvex, ClothingSphere, ClothingCapsule, ClothingTriangleMesh More...

#include "ApexInterface.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::ClothingCollisionType
Type of the ClothingCollision. More...
class | nvidia::apex::ClothingCollision
Base class of all clothing collision types. More...
class | nvidia::apex::ClothingPlane
Plane collision of a clothing actor. More...
class | nvidia::apex::ClothingConvex
Convex collision of a clothing actor. More...
class | nvidia::apex::ClothingSphere
Sphere collision of a clothing actor. More...
class | nvidia::apex::ClothingCapsule
Capsule collision of a clothing actor. More...
class | nvidia::apex::ClothingTriangleMesh
Triangle mesh collision of a clothing actor. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

classes ClothingCollision, ClothingPlane, ClothingConvex, ClothingSphere, ClothingCapsule, ClothingTriangleMesh

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ClothingCollision.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ClothingCollision.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_COLLISION_H
00031 #define CLOTHING_COLLISION_H
00032
00038 #include "ApexInterface.h"
00039
00040 namespace nvidia
00041 {
00042
00043 namespace apex
00044 {
00045 PX_PUSH_PACK_DEFAULT
00046
00047
00051 struct ClothingCollisionType
00052 {
00056     enum Enum
00057     {
00058         Plane,
00059         Convex,
00060         Sphere,
00061         Capsule,
00062         TriangleMesh
00063     };
00064 };
00065
00066
00067
00068 class ClothingPlane;
00069 class ClothingConvex;
00070 class ClothingSphere;
00071 class ClothingCapsule;
00072 class ClothingTriangleMesh;
00073
00077 class ClothingCollision : public ApexInterface
00078 {
00079 public:
00083     virtual ClothingCollisionType::Enum getType() const = 0;
00084
00088     virtual ClothingPlane* isPlane() = 0;
00089
00093     virtual ClothingConvex* isConvex() = 0;
00094
00098     virtual ClothingSphere* isSphere() = 0;
00099
00103     virtual ClothingCapsule* isCapsule() = 0;
00104
00108     virtual ClothingTriangleMesh* isTriangleMesh() = 0;
00109 };
00110
00111
00112
00116 class ClothingPlane : public ClothingCollision
00117 {
00118 public:
00122     virtual void setPlane(const PxPlane& plane) = 0;
00123
00127     virtual const PxPlane& getPlane() = 0;
00128
00132     virtual uint32_t getRefCount() const = 0;
00133 };
00134
00135
00136
00142 class ClothingConvex : public ClothingCollision
00143 {
00144 public:
00148     virtual uint32_t getNumPlanes() = 0;
00149
00153     virtual ClothingPlane** getPlanes() = 0;
00154
00160     virtual void releaseWithPlanes() = 0;
00161 };
00162
00163
00164
00168 class ClothingSphere : public ClothingCollision
00169 {
00170 public:
00174     virtual void setPosition(const PxVec3& position) = 0;
00175
00179     virtual const PxVec3& getPosition() const = 0;
00180
00188     virtual void setRadius(float radius) = 0;
00189
00193     virtual float getRadius() const = 0;
00194
00198     virtual uint32_t getRefCount() const = 0;
00199 };
00200
00201
00202
00208 class ClothingCapsule : public ClothingCollision
00209 {
00210 public:
00214     virtual ClothingSphere** getSpheres() = 0;
00215
00221     virtual void releaseWithSpheres() = 0;
00222 };
00223
00224
00225
00229 class ClothingTriangleMesh : public ClothingCollision
00230 {
00231 public:
00239     virtual uint32_t lockTriangles(const uint32_t** ids, const PxVec3** triangles) = 0;
00240
00248     virtual uint32_t lockTrianglesWrite(const uint32_t** ids, PxVec3** triangles) = 0;
00249
00253     virtual void unlockTriangles() = 0;
00254
00265     virtual void addTriangle(uint32_t id, const PxVec3& v0, const PxVec3& v1, const PxVec3& v2) = 0;
00266
00277     virtual void addTriangles(const uint32_t* ids, const PxVec3* triangleVertices, uint32_t numTriangles) = 0;
00278
00285     virtual void removeTriangle(uint32_t id) = 0;
00286
00294     virtual void removeTriangles(const uint32_t* ids, uint32_t numTriangles) = 0;
00295
00299     virtual void clearTriangles() = 0;
00300
00304     virtual void setPose(PxMat44 pose) = 0;
00305
00309     virtual const PxMat44& getPose() const = 0;
00310 };
00311
00312
00313
00314 PX_POP_PACK
00315 } // namespace nvidia
00316 } // namespace nvidia
00317
00318
00319 #endif // CLOTHING_COLLISION_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ClothingPhysicalMesh.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ClothingPhysicalMesh.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_PHYSICAL_MESH_H
00031 #define CLOTHING_PHYSICAL_MESH_H
00032
00033 #include "ApexInterface.h"
00034 #include "IProgressListener.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041
00045 struct ClothingConstrainCoefficients
00046 {
00047     float maxDistance;
00048     float collisionSphereRadius;
00049     float collisionSphereDistance;
00050 };
00051
00052
00053 PX_PUSH_PACK_DEFAULT
00054
00058 struct ClothingPhysicalMeshStats
00059 {
00061     uint32_t    totalBytes;
00063     uint32_t    numVertices;
00065     uint32_t    numIndices;
00066 };
00067
00068
00072 class ClothingPhysicalMesh : public ApexInterface
00073 {
00074 public:
00078     virtual uint32_t getNumVertices() const = 0;
00079
00083     virtual uint32_t getNumSimulatedVertices() const = 0;
00084
00088     virtual uint32_t getNumMaxDistance0Vertices() const = 0;
00089
00093     virtual uint32_t getNumIndices() const = 0;
00094
00098     virtual uint32_t getNumSimulatedIndices() const = 0;
00099
00107     virtual void getIndices(void* indexDestination, uint32_t byteStride, uint32_t numIndices) const = 0;
00108
00112     virtual bool isTetrahedralMesh() const = 0;
00113
00127     virtual void simplify(uint32_t subdivisions, int32_t maxSteps, float maxError, IProgressListener* progress) = 0;
00128
00135     virtual void setGeometry(bool tetraMesh, uint32_t numVertices, uint32_t vertexByteStride, const void* vertices, const uint32_t* driveChannels,
00136                             uint32_t numIndices, uint32_t indexByteStride, const void* indices) = 0;
00137
00138     // direct access to specific buffers
00145     virtual bool getIndices(uint32_t* indices, uint32_t byteStride) const = 0;
00146
00153     virtual bool getVertices(PxVec3* vertices, uint32_t byteStride) const = 0;
00154
00161     virtual bool getNormals(PxVec3* normals, uint32_t byteStride) const = 0;
00162
00166     virtual uint32_t getNumBonesPerVertex() const = 0;
00167
00177     virtual bool getBoneIndices(uint16_t* boneIndices, uint32_t byteStride) const = 0;
00178
00187     virtual bool getBoneWeights(float* boneWeights, uint32_t byteStride) const = 0;
00188
00194     virtual void allocateMasterFlagsBuffer() = 0;
00195
00201     virtual uint32_t* getMasterFlagsBuffer() = 0;
00202
00210     virtual void allocateConstrainCoefficientBuffer() = 0;
00211
00217     virtual ClothingConstrainCoefficients* getConstrainCoefficientBuffer() const = 0;
00218
00224     virtual bool getConstrainCoefficients(ClothingConstrainCoefficients* coeffs, uint32_t byteStride) const = 0;
00225
00229     virtual void getStats(ClothingPhysicalMeshStats& stats) const = 0;
00230
00231 };
00232
00233 PX_POP_PACK
00234
00235 }
00236 } // namespace nvidia
00237
00238 #endif // CLOTHING_PHYSICAL_MESH_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ClothingPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ClothingPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_PREVIEW_H
00031 #define CLOTHING_PREVIEW_H
00032
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042
00043
00047 class ClothingPreview : public AssetPreview
00048 {
00049
00050 public:
00051
00056     virtual void updateState(const PxMat44& globalPose, const PxMat44* newBoneMatrices, uint32_t boneMatricesByteStride, uint32_t numBoneMatrices) = 0;
00057
00058 };
00059
00060
00061 PX_POP_PACK
00062
00063 }
00064 } // namespace nvidia
00065
00066 #endif // CLOTHING_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ClothingRenderProxy.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ClothingRenderProxy.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_RENDER_PROXY_H
00031 #define CLOTHING_RENDER_PROXY_H
00032
00033 #include "Renderable.h"
00034 #include "ApexInterface.h"
00035
00036 namespace NvParameterized
00037 {
00038 class Interface;
00039 }
00040
00041 namespace nvidia
00042 {
00043 namespace apex
00044 {
00045
00046 PX_PUSH_PACK_DEFAULT
00047
00053 class ClothingRenderProxy : public ApexInterface, public Renderable
00054 {
00055 protected:
00056     virtual ~ClothingRenderProxy() {}
00057
00058 public:
00062     virtual bool hasSimulatedData() const = 0;
00063 };
00064
00065 PX_POP_PACK
00066
00067 }
00068 } // namespace nvidia
00069
00070 #endif // CLOTHING_RENDER_PROXY_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ClothingVelocityCallback.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ClothingVelocityCallback.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CLOTHING_VELOCITY_CALLBACK_H
00031 #define CLOTHING_VELOCITY_CALLBACK_H
00032
00033 #include "ApexUsingNamespace.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00043 class ClothingVelocityCallback
00044 {
00045 public:
00054     virtual bool velocityShader(PxVec3* velocities, const PxVec3* positions, uint32_t numParticles) = 0;
00055 };
00056
00057 } // namespace nvidia
00058 } // namespace nvidia
00059
00060 #endif // CLOTHING_VELOCITY_CALLBACK_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: Context.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
Context.h File Reference

class Context More...

#include "ApexInterface.h"

Go to the source code of this file.

Classes

class | nvidia::apex::Context
A container for Actors. More...
class | nvidia::apex::RenderableIterator
Iterate over all renderable Actors in an Context. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class Context

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Context.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Context.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CONTEXT_H
00031 #define CONTEXT_H
00032
00038 #include "ApexInterface.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 class Renderable;
00046 class RenderableIterator;
00047
00048 PX_PUSH_PACK_DEFAULT
00049
00053 class Context
00054 {
00055 public:
00059     virtual void removeAllActors() = 0;
00060
00064     virtual RenderableIterator* createRenderableIterator() = 0;
00065
00071     virtual void releaseRenderableIterator(RenderableIterator&) = 0;
00072
00073 protected:
00074     virtual ~Context() {}
00075 };
00076
00091 class RenderableIterator : public ApexInterface
00092 {
00093 public:
00097     virtual Renderable* getFirst() = 0;
00101     virtual Renderable* getNext() = 0;
00108     virtual void reset() = 0;
00109 };
00110
00111 PX_POP_PACK
00112
00113 }
00114 } // end namespace nvidia::apex
00115
00116 #endif // CONTEXT_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ConvexHullMethod.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
ConvexHullMethod.h File Reference

Misc utility classes. More...

#include "Module.h"
#include "foundation/PxMath.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::ConvexHullMethod
Method by which chunk mesh collision hulls are generated. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

Misc utility classes.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ConvexHullMethod.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ConvexHullMethod.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CONVEX_HULL_METHOD_H
00031 #define CONVEX_HULL_METHOD_H
00032
00038 #include "Module.h"
00039 #include "foundation/PxMath.h"
00040
00041 namespace nvidia
00042 {
00043 namespace apex
00044 {
00045
00046 PX_PUSH_PACK_DEFAULT
00047
00048
00052 struct ConvexHullMethod
00053 {
00057     enum Enum
00058     {
00059         USE_6_DOP,
00060         USE_10_DOP_X,
00061         USE_10_DOP_Y,
00062         USE_10_DOP_Z,
00063         USE_14_DOP_XY,
00064         USE_14_DOP_YZ,
00065         USE_14_DOP_ZX,
00066         USE_18_DOP,
00067         USE_26_DOP,
00068         WRAP_GRAPHICS_MESH,
00069         CONVEX_DECOMPOSITION,
00070
00071         COUNT
00072     };
00073 };
00074
00075
00076
00077 PX_POP_PACK
00078
00079 }
00080 } // end namespace nvidia::apex
00081
00082 #endif // CONVEX_HULL_METHOD_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: CudaTestManager.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
CudaTestManager.h File Reference

classes CudaTestManager More...

#include <ApexUsingNamespace.h>

Go to the source code of this file.

Classes

class | nvidia::apex::CudaTestManager
A class that set information on kernels should be tested and give directive for creation ApexCudaTestContext. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

classes CudaTestManager

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: CudaTestManager.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
CudaTestManager.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CUDA_TEST_MANAGER_H
00031 #define CUDA_TEST_MANAGER_H
00032
00038 #include <ApexUsingNamespace.h>
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 PX_PUSH_PACK_DEFAULT
00046
00053 class CudaTestManager
00054 {
00055 public:
00059     virtual void setWritePath(const char* path) = 0;
00060
00064     virtual void setWriteForFunction(const char* functionName, const char* moduleName) = 0;
00065
00069     virtual void setMaxSamples(uint32_t maxFrames) = 0;
00070
00074     virtual void setFrames(uint32_t numFrames, const uint32_t* frames) = 0;
00075
00079     virtual void setFramePeriod(uint32_t period) = 0;
00080
00084     virtual void setCallPerFrameMaxCount(uint32_t cpfMaxCount) = 0;
00085
00089     virtual void setWriteForNotSuccessfulKernel(bool flag) = 0;
00090
00094     virtual bool runKernel(const char* path) = 0;
00095 };
00096
00097 PX_POP_PACK
00098
00099 }
00100 }
00101
00102 #endif // CUDA_TEST_MANAGER_H
00103
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: Curve.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Curve.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CURVE_H
00031 #define CURVE_H
00032
00033 #include "Apex.h"
00034 #include "nvparameterized/NvParameterized.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00046 template <typename T>
00047 struct Vec2T
00048 {
00052     Vec2T(T _x = T(), T _y = T()) : x(_x), y(_y) { }
00053
00057     T x;
00058     T y;
00062
00066     T& operator[](uint32_t ndx)
00067     {
00068         PX_ASSERT(ndx < 2);
00069         return ((T*)&x)[ndx];
00070     }
00071 };
00072
00076 typedef Vec2T<float> Vec2R;
00077
00081 class Curve
00082 {
00083 public:
00084     virtual ~Curve() {}
00085
00090     virtual float evaluate(float x) const = 0;
00091
00095     virtual uint32_t addControlPoint(const Vec2R& controlPoint) = 0;
00096
00101     virtual void addControlPoints(::NvParameterized::Interface* param, ::NvParameterized::Handle& hPoints) = 0;
00102
00108     virtual bool calculateControlPoints(float x, Vec2R& outXPoints, Vec2R& outYPoints) const = 0;
00109
00113     virtual uint32_t calculateFollowingControlPoint(float xValue) const = 0;
00114
00116     virtual const Vec2R* getControlPoints(uint32_t& outCount) const = 0;
00117 };
00118
00119 PX_POP_PACK
00120
00121 }
00122 } // namespace apex
00123
00124 #endif // CURVE_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: CustomBufferIterator.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
CustomBufferIterator.h File Reference

class CustomBufferIterator More...

#include "RenderMesh.h"

Go to the source code of this file.

Classes

class | nvidia::apex::CustomBufferIterator
This class is used to access specific elements in an untyped chunk of memory. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class CustomBufferIterator

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: CustomBufferIterator.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
CustomBufferIterator.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef CUSTOM_BUFFER_ITERATOR_H
00031 #define CUSTOM_BUFFER_ITERATOR_H
00032
00038 #include "RenderMesh.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 PX_PUSH_PACK_DEFAULT
00046
00050 class CustomBufferIterator
00051 {
00052 public:
00058     virtual void*       getVertex(uint32_t triangleIndex, uint32_t vertexIndex) const = 0;
00059
00065     virtual int32_t     getAttributeIndex(const char* attributeName) const = 0;
00066
00075     virtual void*       getVertexAttribute(uint32_t triangleIndex, uint32_t vertexIndex, const char* attributeName, RenderDataFormat::Enum& outFormat) const = 0;
00076
00088     virtual void*       getVertexAttribute(uint32_t triangleIndex, uint32_t vertexIndex, uint32_t attributeIndex, RenderDataFormat::Enum& outFormat, const char*& outName) const = 0;
00089
00090 protected:
00091     CustomBufferIterator() {}
00092     virtual             ~CustomBufferIterator() {}
00093 };
00094
00095 PX_POP_PACK
00096
00097 }
00098 } // end namespace nvidia::apex
00099
00100 #endif // CUSTOM_BUFFER_ITERATOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: DestructibleActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
DestructibleActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef DESTRUCTIBLE_ACTOR_H
00031 #define DESTRUCTIBLE_ACTOR_H
00032
00033 #include "foundation/Px.h"
00034 #include "Actor.h"
00035 #include "Renderable.h"
00036 #include "ModuleDestructible.h"
00037 #include "PxForceMode.h"
00038
00039 namespace physx
00040 {
00041     class PxRigidDynamic;
00042 };
00043
00044 #define DESTRUCTIBLE_ACTOR_TYPE_NAME "DestructibleActor"
00045
00046 namespace nvidia
00047 {
00048 namespace apex
00049 {
00050
00051 PX_PUSH_PACK_DEFAULT
00052
00053 struct DestructibleParameters;
00054 class RenderVolume;
00055 class EmitterActor;
00056 class DestructibleRenderable;
00057 class DestructibleBehaviorGroupDesc;
00058
00059
00063 struct DestructibleEmitterType
00064 {
00068     enum Enum
00069     {
00070         Crumble,
00071         Dust,   // Note: this is a placeholder.  Its implementation has been removed in 1.2.0, and will be restored in later versions.
00072         Count
00073     };
00074 };
00075
00079 struct DestructibleParameterizedType
00080 {
00084     enum Enum
00085     {
00086         State,  // The full state of the actor (including params, chunk data, etc...)
00087         Params, // The parameters used to initialize the actor
00088     };
00089 };
00090
00094 struct DestructibleHitChunk
00095 {
00096     uint32_t chunkIndex;
00097     uint32_t hitChunkFlags;
00098 };
00099
00103 struct DestructibleActorSyncFlags
00104 {
00108     enum Enum
00109     {
00110         None                = 0,
00111         CopyDamageEvents    = (1 << 0),
00112         ReadDamageEvents    = (1 << 1),
00113         CopyFractureEvents  = (1 << 2),
00114         ReadFractureEvents  = (1 << 3),
00115         CopyChunkTransform  = (1 << 4),
00116         ReadChunkTransform  = (1 << 5),
00117         Last                = (1 << 6),
00118     };
00119 };
00120
00124 struct DestructiblePhysXActorQueryFlags
00125 {
00129     enum Enum
00130     {
00131         None = 0,
00132
00133         // Actor states
00134         Static = (1 << 0),
00135         Dynamic = (1 << 1),
00136         Dormant = (1 << 2),
00137
00138         AllStates = Static | Dynamic | Dormant,
00139
00140         // Other filters
00147         AllowRedundancy = (1 << 3),
00148
00152         AllowActorsNotInScenes = (1 << 4)
00153     };
00154 };
00155
00159 struct DestructibleActorSyncState
00160 {
00161     uint32_t    damageEventFilterDepth;
00162     uint32_t    fractureEventFilterDepth;
00163 };
00164
00168 struct DestructibleChunkSyncState
00169 {
00170     bool        disableTransformBuffering;
00171     bool        excludeSleepingChunks;
00172     uint32_t    chunkTransformCopyDepth;
00173 };
00174
00179 struct DestructibleActorChunkFlags
00180 {
00184     enum Enum
00185     {
00190         ChunkIsWorldSupported   =   (1<<0),
00191     };
00192 };
00193
00197 class DestructibleActor : public Actor, public Renderable
00198 #if PX_PHYSICS_VERSION_MAJOR == 3
00199     , public ActorSource
00200 #endif
00201 {
00202 public:
00206     virtual const RenderMeshActor*  getRenderMeshActor(DestructibleActorMeshType::Enum type = DestructibleActorMeshType::Skinned) const = 0;
00207
00211     virtual const DestructibleParameters& getDestructibleParameters() const = 0;
00212
00216     virtual void                    setDestructibleParameters(const DestructibleParameters& destructibleParameters) = 0;
00217
00221     virtual PxMat44                 getInitialGlobalPose() const = 0;
00222
00226     virtual void                    setInitialGlobalPose(const PxMat44& pose) = 0;
00227
00231     virtual PxVec3                  getScale() const = 0;
00232
00236     virtual bool                    isInitiallyDynamic() const = 0;
00237
00245     virtual void                    getChunkVisibilities(uint8_t* visibilityArray, uint32_t visibilityArraySize) const = 0;
00246
00250     virtual uint32_t                getNumVisibleChunks() const = 0;
00251
00255     virtual const uint16_t*         getVisibleChunks() const = 0;
00256
00267     virtual bool                    acquireChunkEventBuffer(const nvidia::DestructibleChunkEvent*& buffer, uint32_t& bufferSize) = 0;
00268
00275     virtual bool                    releaseChunkEventBuffer(bool clearBuffer = true) = 0;
00276
00289     virtual bool                    acquirePhysXActorBuffer(physx::PxRigidDynamic**& buffer, uint32_t& bufferSize, uint32_t flags = DestructiblePhysXActorQueryFlags::AllStates) = 0;
00290
00297     virtual bool                    releasePhysXActorBuffer() = 0;
00298
00307     virtual physx::PxRigidDynamic*  getChunkPhysXActor(uint32_t chunkIndex) = 0;
00308
00319     virtual uint32_t                getChunkPhysXShapes(physx::PxShape**& shapes, uint32_t chunkIndex) const = 0;
00320
00330     virtual PxTransform             getChunkPose(uint32_t chunkIndex) const = 0;
00331
00341     virtual PxTransform             getChunkTransform(uint32_t chunkIndex) const = 0;
00342
00348     virtual PxVec3                  getChunkLinearVelocity(uint32_t chunkIndex) const = 0;
00349
00355     virtual PxVec3                  getChunkAngularVelocity(uint32_t chunkIndex) const = 0;
00356
00363     virtual const PxMat44           getChunkTM(uint32_t chunkIndex) const = 0;
00364
00372     virtual int32_t                 getChunkBehaviorGroupIndex(uint32_t chunkIndex) const = 0;
00373
00380     virtual uint32_t                getChunkActorFlags(uint32_t chunkIndex) const = 0;
00381
00388     virtual void                    setGlobalPose(const PxMat44& pose) = 0;
00389
00396     virtual bool                    getGlobalPose(PxMat44& pose) = 0;
00397
00401     virtual void                    setLinearVelocity(const PxVec3& linearVelocity) = 0;
00402
00406     virtual void                    setAngularVelocity(const PxVec3& angularVelocity) = 0;
00407
00413     virtual void                    setDynamic(int32_t chunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX) = 0;
00414
00418     virtual bool                    isDynamic(uint32_t chunkIndex) const = 0;
00419
00425     virtual void                    enableHardSleeping() = 0;
00426
00431     virtual void                    disableHardSleeping(bool wake = false)= 0;
00432
00436     virtual bool                    isHardSleepingEnabled() const = 0;
00437
00446     virtual bool                    setChunkPhysXActorAwakeState(uint32_t chunkIndex, bool awake) = 0;
00447
00459     virtual bool                    addForce(uint32_t chunkIndex, const PxVec3& force, physx::PxForceMode::Enum mode, const PxVec3* position = NULL, bool wakeup = true) = 0;
00460
00464     virtual void                    setSkinnedOverrideMaterial(uint32_t submeshIndex, const char* overrideMaterialName) = 0;
00465
00469     virtual void                    setStaticOverrideMaterial(uint32_t submeshIndex, const char* overrideMaterialName) = 0;
00470
00474     virtual void                    setRuntimeFractureOverridePattern(const char* overridePatternName) = 0;
00475
00492     virtual void                    applyDamage(float damage, float momentum, const PxVec3& position, const PxVec3& direction, int32_t chunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX, void* damageUserData = NULL) = 0;
00493
00507     virtual void                    applyRadiusDamage(float damage, float momentum, const PxVec3& position, float radius, bool falloff, void* damageUserData = NULL) = 0;
00508
00513     virtual void                    takeImpact(const PxVec3& force, const PxVec3& position, uint16_t chunkIndex, PxActor const* damageImpactActor) = 0;
00514
00530     virtual int32_t                 rayCast(float& time, PxVec3& normal, const PxVec3& worldRayOrig, const PxVec3& worldRayDir, DestructibleActorRaycastFlags::Enum flags, int32_t parentChunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX) const = 0;
00531
00546     virtual int32_t                 obbSweep(float& time, PxVec3& normal, const PxVec3& worldBoxCenter, const PxVec3& worldBoxExtents, const PxMat33& worldBoxRot, const PxVec3& worldDisplacement, DestructibleActorRaycastFlags::Enum flags) const = 0;
00547
00551     virtual void                    setCrumbleEmitterState(bool enable) = 0;
00552
00557     virtual void                    setDustEmitterState(bool enable) = 0;
00558
00563     virtual void                    setPreferredRenderVolume(RenderVolume* volume, DestructibleEmitterType::Enum type) = 0;
00564
00565
00570     virtual EmitterActor*           getApexEmitter(DestructibleEmitterType::Enum type) = 0;
00571
00576     virtual bool                    recreateApexEmitter(DestructibleEmitterType::Enum type) = 0;
00577
00583     virtual const ::NvParameterized::Interface* getNvParameterized(DestructibleParameterizedType::Enum type = DestructibleParameterizedType::State) const = 0;
00584
00590     virtual void                    setNvParameterized(::NvParameterized::Interface*) = 0;
00591
00611     virtual bool                    setSyncParams(uint32_t userActorID, uint32_t actorSyncFlags = 0, const DestructibleActorSyncState * actorSyncState = NULL, const DestructibleChunkSyncState * chunkSyncState = NULL) = 0;
00612
00625     virtual bool                    setHitChunkTrackingParams(bool flushHistory, bool startTracking, uint32_t trackingDepth, bool trackAllChunks = true) = 0;
00626
00632     virtual bool                    getHitChunkHistory(const DestructibleHitChunk *& hitChunkContainer, uint32_t & hitChunkCount) const = 0;
00633
00644     virtual bool                    forceChunkHits(const DestructibleHitChunk * hitChunkContainer, uint32_t hitChunkCount, bool removeChunks = true, bool deferredEvent = false, PxVec3 damagePosition = PxVec3(0.0f), PxVec3 damageDirection = PxVec3(0.0f)) = 0;
00645
00651     virtual bool                    getDamageColoringHistory(const DamageEventCoreData *& damageEventCoreDataContainer, uint32_t & damageEventCoreDataCount) const = 0;
00652
00661     virtual bool                    forceDamageColoring(const DamageEventCoreData * damageEventCoreDataContainer, uint32_t damageEventCoreDataCount) = 0;
00662
00666     virtual PxBounds3               getLocalBounds() const = 0;
00667
00671     virtual PxBounds3               getOriginalBounds() const = 0;
00672
00676     virtual bool                    isChunkSolitary(int32_t chunkIndex) const = 0;
00677
00681     virtual PxBounds3               getChunkBounds(uint32_t chunkIndex) const = 0;
00682
00686     virtual PxBounds3               getChunkLocalBounds(uint32_t chunkIndex) const = 0;
00687
00691     virtual bool                    isChunkDestroyed(int32_t chunkIndex) const = 0;
00692
00696     virtual uint32_t                getSupportDepthChunkIndices(uint32_t* const OutChunkIndices, uint32_t MaxOutIndices) const = 0;
00697
00701     virtual uint32_t                getSupportDepth() const = 0;
00702
00706     virtual void                    setDeleteFracturedChunks(bool inDeleteChunkMode) = 0;
00707
00713     virtual DestructibleRenderable* acquireRenderableReference() = 0;
00714
00720     virtual uint32_t                getCustomBehaviorGroupCount() const = 0;
00721
00728     virtual bool                    getBehaviorGroup(nvidia::DestructibleBehaviorGroupDesc& behaviorGroupDesc, int32_t index = -1) const = 0;
00729
00730 protected:
00731     virtual                         ~DestructibleActor() {}
00732 };
00733
00734 PX_POP_PACK
00735
00736 }
00737 } // end namespace nvidia
00738
00739 #endif // DESTRUCTIBLE_ACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: DestructibleActorJoint.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
DestructibleActorJoint.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef DESTRUCTIBLE_ACTOR_JOINT_H
00031 #define DESTRUCTIBLE_ACTOR_JOINT_H
00032
00033 #include "ModuleDestructible.h"
00034
00035 #include "extensions/PxJoint.h"
00036
00037
00038 namespace nvidia
00039 {
00040 namespace apex
00041 {
00042
00043 PX_PUSH_PACK_DEFAULT
00044
00048 class DestructibleActorJointDesc : public ApexDesc
00049 {
00050 public:
00051
00055     PX_INLINE               DestructibleActorJointDesc();
00056
00060     PX_INLINE void          setToDefault();
00061
00065     PX_INLINE bool          isValid() const;
00066
00070     physx::PxJointConcreteType::Enum type;
00074     PxRigidActor*           actor[2];
00078     PxVec3                  localAxis[2];
00082     PxVec3                  localAnchor[2];
00086     PxVec3                  localNormal[2];
00087
00092     DestructibleActor*      destructible[2];
00093
00101     int32_t                 attachmentChunkIndex[2];
00102
00103
00113     PxVec3          globalAnchor[2];
00114
00118     PxVec3          globalAxis[2];
00119
00123     PxVec3          globalNormal[2];
00124 };
00125
00126 // DestructibleActorJointDesc inline functions
00127
00128 PX_INLINE DestructibleActorJointDesc::DestructibleActorJointDesc() : ApexDesc()
00129 {
00130     setToDefault();
00131 }
00132
00133 PX_INLINE void DestructibleActorJointDesc::setToDefault()
00134 {
00135     ApexDesc::setToDefault();
00136     for (int i=0; i<2; i++)
00137     {
00138         actor[i] = 0;
00139         localAxis[i]    = PxVec3(0,0,1);
00140         localNormal[i]  = PxVec3(1,0,0);
00141         localAnchor[i]  = PxVec3(0);
00142     }
00143     for (int i = 0; i < 2; ++i)
00144     {
00145         destructible[i] = NULL;
00146         attachmentChunkIndex[i] = ModuleDestructibleConst::INVALID_CHUNK_INDEX;
00147         globalAnchor[i] = PxVec3(0.0f);
00148         globalAxis[i] = PxVec3(0.0f, 0.0f, 1.0f);
00149         globalNormal[i] = PxVec3(1.0f, 0.0f, 0.0f);
00150     }
00151 }
00152
00153 PX_INLINE bool DestructibleActorJointDesc::isValid() const
00154 {
00155     if (destructible[0] == NULL && destructible[1] == NULL)
00156     {
00157         return false;
00158     }
00159
00160     for (int i = 0; i < 2; ++i)
00161     {
00162         if (PxAbs(globalAxis[i].magnitudeSquared() - 1.0f) > 0.1f)
00163         {
00164             return false;
00165         }
00166         if (PxAbs(globalNormal[i].magnitudeSquared() - 1.0f) > 0.1f)
00167         {
00168             return false;
00169         }
00170         //check orthogonal pairs
00171         if (PxAbs(globalAxis[i].dot(globalNormal[i])) > 0.1f)
00172         {
00173             return false;
00174         }
00175     }
00176
00177     return ApexDesc::isValid();
00178 }
00179
00180
00185 class DestructibleActorJoint : public ApexInterface
00186 {
00187 public:
00197     virtual PxJoint*    joint() = 0;
00198
00199 protected:
00200     virtual             ~DestructibleActorJoint() {}
00201 };
00202
00203 PX_POP_PACK
00204
00205 }
00206 } // end namespace nvidia
00207
00208 #endif // DESTRUCTIBLE_ACTOR_JOINT_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: DestructibleAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
DestructibleAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef DESTRUCTIBLE_ASSET_H
00031 #define DESTRUCTIBLE_ASSET_H
00032
00033 #define DESTRUCTIBLE_AUTHORING_TYPE_NAME "DestructibleAsset"
00034
00035 #include "foundation/Px.h"
00036 #include "FractureToolsAPI.h"
00037 // TODO: Remove this include when we remove the APEX_RUNTIME_FRACTURE define
00038 #include "ModuleDestructible.h"
00039
00040 #if PX_PHYSICS_VERSION_MAJOR == 3
00041 #include "PxFiltering.h"
00042 #endif
00043
00044 namespace nvidia
00045 {
00046 namespace apex
00047 {
00048
00049 struct IntPair;
00050 class DestructibleActor;
00051 class DestructiblePreview;
00052
00053 PX_PUSH_PACK_DEFAULT
00054 #if !PX_PS4
00055     #pragma warning(push)
00056     #pragma warning(disable:4121)
00057 #endif  //!PX_PS4
00058
00062 struct DestructibleDepthParametersFlag
00063 {
00067     enum Enum
00068     {
00074         OVERRIDE_IMPACT_DAMAGE          = (1 << 0),
00075
00079         OVERRIDE_IMPACT_DAMAGE_VALUE    = (1 << 1),
00080
00084         IGNORE_POSE_UPDATES             = (1 << 2),
00085
00089         IGNORE_RAYCAST_CALLBACKS        = (1 << 3),
00090
00094         IGNORE_CONTACT_CALLBACKS        = (1 << 4),
00095
00099         USER_FLAG_0                     = (1 << 24),
00100         USER_FLAG_1                     = (1 << 25),
00101         USER_FLAG_2                     = (1 << 26),
00102         USER_FLAG_3                     = (1 << 27)
00103     };
00104 };
00105
00106
00110 struct DestructibleDepthParameters
00111 {
00115     PX_INLINE       DestructibleDepthParameters();
00116
00120     PX_INLINE void  setToDefault();
00121
00125     PX_INLINE void  setToMostExpensive();
00126
00130     PX_INLINE bool  overrideImpactDamage() const;
00131
00135     PX_INLINE bool  overrideImpactDamageValue() const;
00136
00140     PX_INLINE bool  ignoresPoseUpdates() const;
00141
00145     PX_INLINE bool  ignoresRaycastCallbacks() const;
00146
00150     PX_INLINE bool  ignoresContactCallbacks() const;
00151
00155     PX_INLINE bool  hasUserFlagSet(uint32_t flagIndex) const;
00156
00160     uint32_t        flags;
00161 };
00162
00163 // DestructibleDepthParameters inline functions
00164
00165 PX_INLINE DestructibleDepthParameters::DestructibleDepthParameters()
00166 {
00167     setToDefault();
00168 }
00169
00170 PX_INLINE void DestructibleDepthParameters::setToDefault()
00171 {
00172     flags = 0;
00173 }
00174
00175 PX_INLINE bool DestructibleDepthParameters::overrideImpactDamage() const
00176 {
00177     return (flags & DestructibleDepthParametersFlag::OVERRIDE_IMPACT_DAMAGE) != 0;
00178 }
00179
00180 PX_INLINE bool DestructibleDepthParameters::overrideImpactDamageValue() const
00181 {
00182     return (flags & DestructibleDepthParametersFlag::OVERRIDE_IMPACT_DAMAGE_VALUE) != 0;
00183 }
00184
00185 PX_INLINE bool DestructibleDepthParameters::ignoresPoseUpdates() const
00186 {
00187     return (flags & DestructibleDepthParametersFlag::IGNORE_POSE_UPDATES) != 0;
00188 }
00189
00190 PX_INLINE bool DestructibleDepthParameters::ignoresRaycastCallbacks() const
00191 {
00192     return (flags & DestructibleDepthParametersFlag::IGNORE_RAYCAST_CALLBACKS) != 0;
00193 }
00194
00195 PX_INLINE bool DestructibleDepthParameters::ignoresContactCallbacks() const
00196 {
00197     return (flags & DestructibleDepthParametersFlag::IGNORE_CONTACT_CALLBACKS) != 0;
00198 }
00199
00200 PX_INLINE bool DestructibleDepthParameters::hasUserFlagSet(uint32_t flagIndex) const
00201 {
00202     switch (flagIndex)
00203     {
00204     case 0:
00205         return (flags & DestructibleDepthParametersFlag::USER_FLAG_0) != 0;
00206     case 1:
00207         return (flags & DestructibleDepthParametersFlag::USER_FLAG_1) != 0;
00208     case 2:
00209         return (flags & DestructibleDepthParametersFlag::USER_FLAG_2) != 0;
00210     case 3:
00211         return (flags & DestructibleDepthParametersFlag::USER_FLAG_3) != 0;
00212     default:
00213         return false;
00214     }
00215 }
00216
00220 struct DestructibleRTFractureParameters
00221 {
00226     bool sheetFracture;
00227
00232     uint32_t depthLimit;
00233
00238     bool destroyIfAtDepthLimit;
00239
00243     float minConvexSize;
00244
00248     float impulseScale;
00249
00253     struct FractureGlass
00254     {
00258         uint32_t numSectors;
00259
00263         float sectorRand;
00264
00268         float firstSegmentSize;
00269
00273         float segmentScale;
00274
00278         float segmentRand;
00279     }glass;
00280
00284     struct FractureAttachment
00285     {
00289         bool posX;
00290
00294         bool negX;
00295
00299         bool posY;
00300
00304         bool negY;
00305
00309         bool posZ;
00310
00314         bool negZ;
00315     }attachment;
00316
00320     PX_INLINE void  setToDefault();
00321 };
00322
00323 PX_INLINE void DestructibleRTFractureParameters::setToDefault()
00324 {
00325     sheetFracture = true;
00326     depthLimit = 2;
00327     destroyIfAtDepthLimit = false;
00328     minConvexSize = 0.02f;
00329     impulseScale = 1.0f;
00330     glass.numSectors = 10;
00331     glass.sectorRand = 0.3f;
00332     glass.firstSegmentSize = 0.06f;
00333     glass.segmentScale = 1.4f;
00334     glass.segmentRand = 0.3f;
00335     attachment.posX = false;
00336     attachment.negX = false;
00337     attachment.posY = false;
00338     attachment.negY = false;
00339     attachment.posZ = false;
00340     attachment.negZ = false;
00341 }
00342
00346 struct DestructibleParametersFlag
00347 {
00351     enum Enum
00352     {
00358         ACCUMULATE_DAMAGE = (1 << 0),
00359
00365         DEBRIS_TIMEOUT =    (1 << 1),
00366
00373         DEBRIS_MAX_SEPARATION = (1 << 2),
00374
00382         CRUMBLE_SMALLEST_CHUNKS =   (1 << 3),
00383
00390         ACCURATE_RAYCASTS = (1 << 4),
00391
00397         USE_VALID_BOUNDS =  (1 << 5),
00398
00404         CRUMBLE_VIA_RUNTIME_FRACTURE =  (1 << 6),
00405     };
00406 };
00407
00408
00412 struct DestructibleParameters
00413 {
00417     PX_INLINE       DestructibleParameters();
00418
00422     PX_INLINE void  setToDefault();
00423
00429     float           damageCap;
00430
00437     float           forceToDamage;
00438
00445     float           impactVelocityThreshold;
00446
00450     uint32_t        minimumFractureDepth;
00451
00457     int32_t         impactDamageDefaultDepth;
00458
00465     int32_t         debrisDepth;
00466
00473     uint32_t        essentialDepth;
00474
00483     float           debrisLifetimeMin;
00484
00486     float           debrisLifetimeMax;
00487
00496     float           debrisMaxSeparationMin;
00497
00499     float           debrisMaxSeparationMax;
00500
00506     float           debrisDestructionProbability;
00507
00513     PxBounds3       validBounds;
00514
00519     float           maxChunkSpeed;
00520
00524     uint32_t        flags;
00525
00530     float           fractureImpulseScale;
00531
00536     uint16_t        damageDepthLimit;
00537
00541     uint8_t         dynamicChunksDominanceGroup;
00542
00547     bool            useDynamicChunksGroupsMask;
00548
00549 #if PX_PHYSICS_VERSION_MAJOR == 3
00550
00553     physx::PxFilterData dynamicChunksFilterData;
00554 #endif
00555
00559     float           supportStrength;
00560
00566     int8_t          legacyChunkBoundsTestSetting;
00567
00573     int8_t          legacyDamageRadiusSpreadSetting;
00574
00578     enum { kDepthParametersCountMax = 16 };
00579
00584     uint32_t        depthParametersCount;
00585
00592     DestructibleDepthParameters depthParameters[kDepthParametersCountMax];
00593
00597     DestructibleRTFractureParameters rtFractureParameters;
00598
00603     bool            alwaysDrawScatterMesh;
00604 };
00605
00606 // DestructibleParameters inline functions
00607
00608 PX_INLINE DestructibleParameters::DestructibleParameters()
00609 {
00610     setToDefault();
00611 }
00612
00613 PX_INLINE void DestructibleParameters::setToDefault()
00614 {
00615     damageCap = 0;
00616     forceToDamage = 0;
00617     impactVelocityThreshold = 0.0f;
00618     minimumFractureDepth = 0;
00619     impactDamageDefaultDepth = -1;
00620     debrisDepth = -1;
00621     essentialDepth = 0;
00622     debrisLifetimeMin = 1.0f;
00623     debrisLifetimeMax = 10.0f;
00624     debrisMaxSeparationMin = 1.0f;
00625     debrisMaxSeparationMax = 10.0f;
00626     debrisDestructionProbability = 0.0f;
00627     validBounds = PxBounds3(PxVec3(-10000.0f), PxVec3(10000.0f));
00628     maxChunkSpeed = 0.0f;
00629     fractureImpulseScale = 0.0f;
00630     damageDepthLimit = UINT16_MAX;
00631     useDynamicChunksGroupsMask = false;
00632 #if PX_PHYSICS_VERSION_MAJOR == 3
00633     dynamicChunksFilterData.word0 = dynamicChunksFilterData.word1 = dynamicChunksFilterData.word2 = dynamicChunksFilterData.word3 = 0;
00634 #endif
00635     supportStrength = -1.0;
00636     legacyChunkBoundsTestSetting = -1;
00637     legacyDamageRadiusSpreadSetting = -1;
00638     dynamicChunksDominanceGroup = 0xFF; // Out of range, so it won't be used.
00639     flags = DestructibleParametersFlag::ACCUMULATE_DAMAGE;
00640     depthParametersCount = 0;
00641     rtFractureParameters.setToDefault();
00642     alwaysDrawScatterMesh = false;
00643 }
00644
00648 struct DestructibleInitParametersFlag
00649 {
00653     enum Enum
00654     {
00661         ASSET_DEFINED_SUPPORT = (1 << 0),
00662
00669         WORLD_SUPPORT = (1 << 1),
00670
00675         FORM_EXTENDED_STRUCTURES =  (1 << 2)
00676     };
00677 };
00678
00682 struct DestructibleInitParameters
00683 {
00687     PX_INLINE       DestructibleInitParameters();
00688
00692     PX_INLINE void  setToDefault();
00693
00698     uint32_t        supportDepth;
00699
00703     uint32_t        flags;
00704 };
00705
00706
00707 // DestructibleInitParameters inline functions
00708
00709 PX_INLINE DestructibleInitParameters::DestructibleInitParameters()
00710 {
00711     setToDefault();
00712 }
00713
00714 PX_INLINE void DestructibleInitParameters::setToDefault()
00715 {
00716     supportDepth = 0;
00717     flags = 0;
00718 }
00719
00723 struct DamageSpreadFunction
00724 {
00725     PX_INLINE       DamageSpreadFunction()
00726     {
00727         setToDefault();
00728     }
00729
00733     PX_INLINE void  setToDefault()
00734     {
00735         minimumRadius = 0.0f;
00736         radiusMultiplier = 1.0f;
00737         falloffExponent = 1.0f;
00738     }
00739
00743     PX_INLINE bool  isValid() const
00744     {
00745         return
00746             minimumRadius >= 0.0f &&
00747             radiusMultiplier >= 0.0f &&
00748             falloffExponent >= 0.0f;
00749     }
00750
00751     float minimumRadius;
00752     float radiusMultiplier;
00753     float falloffExponent;
00754 };
00755
00761 class DestructibleBehaviorGroupDesc : public ApexDesc
00762 {
00763 public:
00767     PX_INLINE       DestructibleBehaviorGroupDesc();
00768
00772     PX_INLINE void  setToDefault();
00773
00777     PX_INLINE bool  isValid() const;
00778
00783     const char*     name;
00784     float           damageThreshold;
00785     float           damageToRadius;
00786     DamageSpreadFunction    damageSpread;
00787     DamageSpreadFunction    damageColorSpread;
00788     PxVec4          damageColorChange;
00789     float           materialStrength;
00790     float           density;
00791     float           fadeOut;
00792     float           maxDepenetrationVelocity;
00793     uint64_t        userData;
00794 };
00795
00796 // DestructibleChunkDesc inline functions
00797
00798 PX_INLINE DestructibleBehaviorGroupDesc::DestructibleBehaviorGroupDesc()
00799 {
00800     setToDefault();
00801 }
00802
00803 PX_INLINE void DestructibleBehaviorGroupDesc::setToDefault()
00804 {
00805     ApexDesc::setToDefault();
00806
00807     // TC_TODO: suitable default values?
00808     name = NULL;
00809     damageThreshold = 1.0f;
00810     damageToRadius = 0.1f;
00811     damageSpread.setToDefault();
00812     damageColorSpread.setToDefault();
00813     damageColorChange.setZero();
00814     materialStrength = 0.0f;
00815     density = 0;
00816     fadeOut = 1;
00817     maxDepenetrationVelocity = PX_MAX_F32;
00818     userData = (uint64_t)0;
00819 }
00820
00821 PX_INLINE bool DestructibleBehaviorGroupDesc::isValid() const
00822 {
00823     // TC_TODO: this good enough?
00824     if (damageThreshold < 0 ||
00825         damageToRadius < 0 ||
00826         !damageSpread.isValid() ||
00827         !damageColorSpread.isValid() ||
00828         materialStrength < 0 ||
00829         density < 0 ||
00830         fadeOut < 0 ||
00831         !(maxDepenetrationVelocity > 0.f))
00832     {
00833         return false;
00834     }
00835
00836     return ApexDesc::isValid();
00837 }
00843 class DestructibleChunkDesc : public ApexDesc
00844 {
00845 public:
00849     PX_INLINE               DestructibleChunkDesc();
00850
00854     PX_INLINE void          setToDefault();
00855
00859     PX_INLINE bool          isValid() const;
00860
00865     bool                    isSupportChunk;
00866
00870     bool                    doNotFracture;
00871
00875     bool                    doNotDamage;
00876
00886     bool                    doNotCrumble;
00887
00888 #if APEX_RUNTIME_FRACTURE
00889
00893     bool                    runtimeFracture;
00894 #endif
00895
00903     bool                    useInstancedRendering;
00904
00910     PxVec3                  instancePositionOffset;
00911
00917     PxVec2                  instanceUVOffset;
00918
00925     uint16_t                meshIndex;
00926
00931     int32_t                 parentIndex;
00932
00936     PxVec3                  surfaceNormal;
00937
00941     int8_t                  behaviorGroupIndex;
00942
00947     uint32_t                scatterMeshCount;
00948
00954     const uint8_t*          scatterMeshIndices;
00955
00962     const PxMat44*          scatterMeshTransforms;
00963 };
00964
00965 // DestructibleChunkDesc inline functions
00966
00967 PX_INLINE DestructibleChunkDesc::DestructibleChunkDesc()
00968 {
00969     setToDefault();
00970 }
00971
00972 PX_INLINE void DestructibleChunkDesc::setToDefault()
00973 {
00974     ApexDesc::setToDefault();
00975     isSupportChunk = false;
00976     doNotFracture = false;
00977     doNotDamage = false;
00978     doNotCrumble = false;
00979 #if APEX_RUNTIME_FRACTURE
00980     runtimeFracture = false;
00981 #endif
00982     useInstancedRendering = false;
00983     instancePositionOffset = PxVec3(0.0f);
00984     instanceUVOffset = PxVec2(0.0f);
00985     meshIndex = 0xFFFF;
00986     parentIndex = -1;
00987     surfaceNormal = PxVec3(0.0f);
00988     behaviorGroupIndex = -1;
00989     scatterMeshCount = 0;
00990     scatterMeshIndices = NULL;
00991     scatterMeshTransforms = NULL;
00992 }
00993
00994 PX_INLINE bool DestructibleChunkDesc::isValid() const
00995 {
00996     if (meshIndex == 0xFFFF)
00997     {
00998         return false;
00999     }
01000
01001     return ApexDesc::isValid();
01002 }
01003
01004
01010 class DestructibleGeometryDesc : public ApexDesc
01011 {
01012 public:
01016     PX_INLINE       DestructibleGeometryDesc();
01017
01021     PX_INLINE void  setToDefault();
01022
01026     PX_INLINE bool  isValid() const;
01027
01032     const nvidia::ExplicitHierarchicalMesh::ConvexHull**    convexHulls;
01033
01039     uint32_t                                                convexHullCount;
01040
01045     const CollisionVolumeDesc*                              collisionVolumeDesc;
01046 };
01047
01048 // DestructibleGeometryDesc inline functions
01049
01050 PX_INLINE DestructibleGeometryDesc::DestructibleGeometryDesc()
01051 {
01052     setToDefault();
01053 }
01054
01055 PX_INLINE void DestructibleGeometryDesc::setToDefault()
01056 {
01057     ApexDesc::setToDefault();
01058     convexHulls = NULL;
01059     convexHullCount = 0;
01060     collisionVolumeDesc = NULL;
01061 }
01062
01063 PX_INLINE bool DestructibleGeometryDesc::isValid() const
01064 {
01065     if (convexHullCount == 0 && collisionVolumeDesc == NULL)
01066     {
01067         return false;
01068     }
01069
01070     if (convexHullCount > 0 && convexHulls == NULL)
01071     {
01072         return false;
01073     }
01074
01075     return ApexDesc::isValid();
01076 }
01077
01078
01084 class DestructibleAssetCookingDesc : public ApexDesc
01085 {
01086 public:
01090     PX_INLINE       DestructibleAssetCookingDesc();
01091
01095     PX_INLINE void  setToDefault();
01096
01100     PX_INLINE bool  isValid() const;
01101
01105     DestructibleChunkDesc*          chunkDescs;
01106
01110     uint32_t                        chunkDescCount;
01111
01115     DestructibleBehaviorGroupDesc   defaultBehaviorGroupDesc;
01116
01120     DestructibleBehaviorGroupDesc*  behaviorGroupDescs;
01121
01125     uint32_t                        behaviorGroupDescCount;
01126
01130     int8_t                          RTFractureBehaviorGroup;
01131
01135     DestructibleGeometryDesc*       geometryDescs;
01136
01140     uint32_t                        geometryDescCount;
01141
01147     nvidia::IntPair*                supportGraphEdges;
01148
01152     uint32_t                        supportGraphEdgeCount;
01153 };
01154
01155 // DestructibleAssetCookingDesc inline functions
01156
01157 PX_INLINE DestructibleAssetCookingDesc::DestructibleAssetCookingDesc()
01158 {
01159     setToDefault();
01160 }
01161
01162 PX_INLINE void DestructibleAssetCookingDesc::setToDefault()
01163 {
01164     ApexDesc::setToDefault();
01165     chunkDescs = NULL;
01166     chunkDescCount = 0;
01167     geometryDescs = NULL;
01168     geometryDescCount = 0;
01169     behaviorGroupDescs = 0;
01170     behaviorGroupDescCount = 0;
01171     supportGraphEdges = 0;
01172     supportGraphEdgeCount = 0;
01173 }
01174
01175 PX_INLINE bool DestructibleAssetCookingDesc::isValid() const
01176 {
01177     if (chunkDescCount == 0 || chunkDescs == NULL)
01178     {
01179         return false;
01180     }
01181
01182     for (uint32_t i = 0; i < chunkDescCount; ++i )
01183     {
01184         if (!chunkDescs[i].isValid())
01185         {
01186             return false;
01187         }
01188     }
01189
01190     if (chunkDescCount >= 65535)
01191     {
01192         return false;
01193     }
01194
01195     if (geometryDescCount == 0 || geometryDescs == NULL)
01196     {
01197         return false;
01198     }
01199
01200     for (uint32_t i = 0; i < geometryDescCount; ++i )
01201     {
01202         if (!geometryDescs[i].isValid())
01203         {
01204             return false;
01205         }
01206     }
01207
01208     if (behaviorGroupDescCount > 127)
01209     {
01210         return false;
01211     }
01212
01213     for (uint32_t i = 0; i < behaviorGroupDescCount; ++i )
01214     {
01215         if (!behaviorGroupDescs[i].isValid())
01216         {
01217             return false;
01218         }
01219     }
01220
01221     return ApexDesc::isValid();
01222 }
01223
01224
01228 struct DestructibleAssetStats
01229 {
01230     uint32_t            totalBytes;
01231     uint32_t            chunkCount;
01232     uint32_t            chunkBytes;
01233     uint32_t            chunkHullDataBytes;
01234     uint32_t            collisionCookedHullDataBytes;
01235     uint32_t            collisionMeshCount;
01236     uint32_t            maxHullVertexCount;
01237     uint32_t            maxHullFaceCount;
01238     uint32_t            chunkWithMaxEdgeCount;
01239     uint32_t            runtimeCookedConvexCount;
01240     RenderMeshAssetStats    renderMeshAssetStats;
01241 };
01242
01246 class DestructibleAssetAuthoring : public AssetAuthoring
01247 {
01248 public:
01249
01259     virtual ExplicitHierarchicalMesh&   getExplicitHierarchicalMesh() = 0;
01260
01266     virtual ExplicitHierarchicalMesh&   getCoreExplicitHierarchicalMesh() = 0;
01267
01273     virtual FractureTools::CutoutSet&   getCutoutSet() = 0;
01274
01286     virtual uint32_t                    partitionMeshByIslands
01287     (
01288         nvidia::ExplicitRenderTriangle* mesh,
01289         uint32_t meshTriangleCount,
01290         uint32_t* meshPartition,
01291         uint32_t meshPartitionMaxCount,
01292         float padding = 0.0001f
01293     ) = 0;
01294
01316     virtual bool                        setRootMesh
01317     (
01318         const ExplicitRenderTriangle* meshTriangles,
01319         uint32_t meshTriangleCount,
01320         const ExplicitSubmeshData* submeshData,
01321         uint32_t submeshCount,
01322         uint32_t* meshPartition = NULL,
01323         uint32_t meshPartitionCount = 0,
01324         int32_t* parentIndices = NULL,
01325         uint32_t parentIndexCount = 0
01326     ) = 0;
01327
01335     virtual bool                        importRenderMeshAssetToRootMesh(const nvidia::RenderMeshAsset& renderMeshAsset, uint32_t maxRootDepth = UINT32_MAX) = 0;
01336
01345     virtual bool                        importDestructibleAssetToRootMesh(const nvidia::DestructibleAsset& destructibleAsset, uint32_t maxRootDepth = UINT32_MAX) = 0;
01346
01359     virtual bool                        setCoreMesh
01360     (
01361         const ExplicitRenderTriangle* mesh,
01362         uint32_t meshTriangleCount,
01363         const ExplicitSubmeshData* submeshData,
01364         uint32_t submeshCount,
01365         uint32_t* meshPartition = NULL,
01366         uint32_t meshPartitionCount = 0
01367     ) = 0;
01368
01393     virtual bool                        buildExplicitHierarchicalMesh
01394     (
01395         ExplicitHierarchicalMesh& hMesh,
01396         const ExplicitRenderTriangle* meshTriangles,
01397         uint32_t meshTriangleCount,
01398         const ExplicitSubmeshData* submeshData,
01399         uint32_t submeshCount,
01400         uint32_t* meshPartition = NULL,
01401         uint32_t meshPartitionCount = 0,
01402         int32_t* parentIndices = NULL,
01403         uint32_t parentIndexCount = 0
01404     ) = 0;
01405
01421     virtual bool                            createHierarchicallySplitMesh
01422     (
01423         const FractureTools::MeshProcessingParameters& meshProcessingParams,
01424         const FractureTools::FractureSliceDesc& desc,
01425         const CollisionDesc& collisionDesc,
01426         bool exportCoreMesh,
01427         int32_t coreMeshImprintSubmeshIndex,
01428         uint32_t randomSeed,
01429         IProgressListener& progressListener,
01430         volatile bool* cancel = NULL
01431     ) = 0;
01432
01449     virtual bool                            createChippedMesh
01450     (
01451         const FractureTools::MeshProcessingParameters& meshProcessingParams,
01452         const FractureTools::FractureCutoutDesc& desc,
01453         const FractureTools::CutoutSet& cutoutSet,
01454         const FractureTools::FractureSliceDesc& sliceDesc,
01455         const FractureTools::FractureVoronoiDesc& voronoiDesc,
01456         const CollisionDesc& collisionDesc,
01457         uint32_t randomSeed,
01458         IProgressListener& progressListener,
01459         volatile bool* cancel = NULL
01460     ) = 0;
01461
01471     virtual void                            buildCutoutSet
01472     (
01473         const uint8_t* pixelBuffer,
01474         uint32_t bufferWidth,
01475         uint32_t bufferHeight,
01476         float snapThreshold,
01477         bool periodic
01478     ) = 0;
01479
01488     virtual bool                            calculateCutoutUVMapping
01489     (
01490         PxMat33& mapping,
01491         const nvidia::ExplicitRenderTriangle& triangle
01492     ) = 0;
01493
01505     virtual bool                            calculateCutoutUVMapping
01506     (
01507         PxMat33& mapping,
01508         const PxVec3& targetDirection
01509     ) = 0;
01510
01526     virtual bool                            createVoronoiSplitMesh
01527     (
01528         const FractureTools::MeshProcessingParameters& meshProcessingParams,
01529         const FractureTools::FractureVoronoiDesc& desc,
01530         const CollisionDesc& collisionDesc,
01531         bool exportCoreMesh,
01532         int32_t coreMeshImprintSubmeshIndex,
01533         uint32_t randomSeed,
01534         IProgressListener& progressListener,
01535         volatile bool* cancel = NULL
01536     ) = 0;
01537
01557     virtual uint32_t                        createVoronoiSitesInsideMesh
01558     (
01559         PxVec3* siteBuffer,
01560         uint32_t* siteChunkIndices,
01561         uint32_t siteCount,
01562         uint32_t* randomSeed,
01563         uint32_t* microgridSize,
01564         BSPOpenMode::Enum meshMode,
01565         IProgressListener& progressListener,
01566         uint32_t chunkIndex = 0xFFFFFFFF
01567     ) = 0;
01568
01591     virtual uint32_t                    createScatterMeshSites
01592     (
01593         uint8_t*                        meshIndices,
01594         PxMat44*                        relativeTransforms,
01595         uint32_t*                       chunkMeshStarts,
01596         uint32_t                        scatterMeshInstancesBufferSize,
01597         uint32_t                        targetChunkCount,
01598         const uint16_t*                 targetChunkIndices,
01599         uint32_t*                       randomSeed,
01600         uint32_t                        scatterMeshAssetCount,
01601         nvidia::RenderMeshAsset**           scatterMeshAssets,
01602         const uint32_t*                 minCount,
01603         const uint32_t*                 maxCount,
01604         const float*                    minScales,
01605         const float*                    maxScales,
01606         const float*                    maxAngles
01607     ) = 0;
01608
01622     virtual void                            visualizeVoronoiCells
01623     (
01624         nvidia::RenderDebugInterface& debugRender,
01625         const PxVec3* sites,
01626         uint32_t siteCount,
01627         const uint32_t* cellColors,
01628         uint32_t cellColorCount,
01629         const PxBounds3& bounds,
01630         uint32_t cellIndex = 0xFFFFFFFF
01631     ) = 0;
01632
01647     virtual bool                            hierarchicallySplitChunk
01648     (
01649         uint32_t chunkIndex,
01650         const FractureTools::MeshProcessingParameters& meshProcessingParams,
01651         const FractureTools::FractureSliceDesc& desc,
01652         const CollisionDesc& collisionDesc,
01653         uint32_t* randomSeed,
01654         IProgressListener& progressListener,
01655         volatile bool* cancel = NULL
01656     ) = 0;
01657
01672     virtual bool                            voronoiSplitChunk
01673     (
01674         uint32_t chunkIndex,
01675         const FractureTools::MeshProcessingParameters& meshProcessingParams,
01676         const FractureTools::FractureVoronoiDesc& desc,
01677         const CollisionDesc& collisionDesc,
01678         uint32_t* randomSeed,
01679         IProgressListener& progressListener,
01680         volatile bool* cancel = NULL
01681     ) = 0;
01682
01692     virtual void                            setBSPTolerances
01693     (
01694         float linearTolerance,
01695         float angularTolerance,
01696         float baseTolerance,
01697         float clipTolerance,
01698         float cleaningTolerance
01699     ) = 0;
01700
01719     virtual void    setBSPBuildParameters
01720     (
01721         float logAreaSigmaThreshold,
01722         uint32_t testSetSize,
01723         float splitWeight,
01724         float imbalanceWeight
01725     ) = 0;
01726
01727
01736     virtual ExplicitHierarchicalMesh::ConvexHull*   createExplicitHierarchicalMeshConvexHull() = 0;
01737
01744     virtual uint32_t                        buildSliceMesh(const ExplicitRenderTriangle*& mesh, const FractureTools::NoiseParameters& noiseParameters, const PxPlane& slicePlane, uint32_t randomSeed) = 0;
01745
01750     virtual void                            serializeFractureToolState(PxFileBuf& stream, nvidia::ExplicitHierarchicalMesh::Embedding& embedding) const = 0;
01751
01756     virtual void                            deserializeFractureToolState(PxFileBuf& stream, nvidia::ExplicitHierarchicalMesh::Embedding& embedding) = 0;
01757
01761     virtual void                            setChunkOverlapsCacheDepth(int32_t depth = -1) = 0;
01762
01766     virtual const RenderMeshAsset*          getRenderMeshAsset() const = 0;
01767
01775     virtual bool                            setRenderMeshAsset(RenderMeshAsset*) = 0;
01776
01784     virtual bool                            setScatterMeshAssets(RenderMeshAsset** scatterMeshAssetArray, uint32_t scatterMeshAssetArraySize) = 0;
01785
01787     virtual uint32_t                        getScatterMeshAssetCount() const = 0;
01788
01790     virtual RenderMeshAsset* const *        getScatterMeshAssets() const = 0;
01791
01795     virtual uint32_t                        getInstancedChunkMeshCount() const = 0;
01796
01800     virtual void                            setDestructibleParameters(const DestructibleParameters&) = 0;
01801
01806     virtual DestructibleParameters          getDestructibleParameters() const = 0;
01807
01811     virtual void                            setDestructibleInitParameters(const DestructibleInitParameters&) = 0;
01812
01816     virtual DestructibleInitParameters      getDestructibleInitParameters() const = 0;
01817
01821     virtual void                            setCrumbleEmitterName(const char*) = 0;
01822
01826     virtual void                            setDustEmitterName(const char*) = 0;
01827
01831     virtual void                            setFracturePatternName(const char*) = 0;
01832
01839     virtual void                            setNeighborPadding(float neighborPadding) = 0;
01840
01844     virtual float                           getNeighborPadding() const = 0;
01845
01860     virtual void                            cookChunks( const DestructibleAssetCookingDesc& cookingDesc, bool cacheOverlaps = true,
01861                                                         uint32_t* chunkIndexMapUser2Apex = NULL, uint32_t* chunkIndexMapApex2User = NULL, uint32_t chunkIndexMapCount = 0) = 0;
01862
01867     virtual float                           getFractureImpulseScale() const = 0;
01868
01874     virtual float                           getImpactVelocityThreshold() const = 0;
01875
01879     virtual uint32_t                        getChunkCount() const = 0;
01880
01884     virtual uint32_t                        getDepthCount() const = 0;
01885
01890     virtual uint32_t                        getChunkChildCount(uint32_t chunkIndex) const = 0;
01891
01897     virtual int32_t                         getChunkChild(uint32_t chunkIndex, uint32_t childIndex) const = 0;
01898
01903     virtual PxVec3                          getChunkPositionOffset(uint32_t chunkIndex) const = 0;
01904
01909     virtual PxVec2                          getChunkUVOffset(uint32_t chunkIndex) const = 0;
01910
01914     virtual uint32_t                        getPartIndex(uint32_t chunkIndex) const = 0;
01915
01922     virtual void                            trimCollisionGeometry(const uint32_t* partIndices, uint32_t partIndexCount, float maxTrimFraction = 0.2f) = 0;
01923
01927     virtual void                            getStats(DestructibleAssetStats& stats) const = 0;
01928
01935     virtual void                            cacheChunkOverlapsUpToDepth(int32_t depth = -1) = 0;
01936
01943     virtual void                            clearChunkOverlaps(int32_t depth = -1, bool keepCachedFlag = false) = 0;
01944
01949     virtual void                            addChunkOverlaps(IntPair* supportGraphEdges, uint32_t numSupportGraphEdges) = 0;
01950
01959     virtual void                            removeChunkOverlaps(IntPair* supportGraphEdges, uint32_t numSupportGraphEdges, bool keepCachedFlagIfEmpty) = 0;
01960
01966     virtual uint32_t                        getCachedOverlapCountAtDepth(uint32_t depth) = 0;
01967
01974     virtual const IntPair*                  getCachedOverlapsAtDepth(uint32_t depth) = 0;
01975
01985     virtual void                            applyTransformation(const PxMat44& transformation, float scale) = 0;
01986
01995     virtual void                            applyTransformation(const PxMat44& transformation) = 0;
01996
02002     virtual bool                            setPlatformMaxDepth(PlatformTag platform, uint32_t maxDepth) = 0;
02003
02009     virtual bool                            removePlatformMaxDepth(PlatformTag platform) = 0;
02010
02014     virtual uint32_t                        getActorTransformCount() const = 0;
02015
02020     virtual const PxMat44*                  getActorTransforms() const = 0;
02021
02028     virtual void                            appendActorTransforms(const PxMat44* transforms, uint32_t transformCount) = 0;
02029
02033     virtual void                            clearActorTransforms() = 0;
02034 };
02035
02039 class DestructibleAsset : public Asset
02040 {
02041 public:
02045     enum ChunkFlags
02046     {
02047         ChunkEnvironmentallySupported =     (1 << 0),
02048         ChunkAndDescendentsDoNotFracture =  (1 << 1),
02049         ChunkDoesNotFracture =              (1 << 2),
02050         ChunkDoesNotCrumble =               (1 << 3),
02051 #if APEX_RUNTIME_FRACTURE
02052         ChunkRuntimeFracture =              (1 << 4),
02053 #endif
02054         ChunkIsInstanced =                  (1 << 16)
02055     };
02056
02065     virtual void                            releaseDestructibleActor(DestructibleActor& actor) = 0;
02066
02067
02076     virtual DestructibleActor*              createDestructibleActorFromDeserializedState(::NvParameterized::Interface* actorParams, Scene& apexScene) = 0;
02077
02082     virtual DestructibleParameters          getDestructibleParameters() const = 0;
02083
02087     virtual DestructibleInitParameters      getDestructibleInitParameters() const = 0;
02088
02093     virtual const char*                     getCrumbleEmitterName() const = 0;
02094
02099     virtual const char*                     getDustEmitterName() const = 0;
02100
02104     virtual uint32_t                        getChunkCount() const = 0;
02105
02109     virtual uint32_t                        getDepthCount() const = 0;
02110
02114     virtual const RenderMeshAsset*          getRenderMeshAsset() const = 0;
02115
02122     virtual bool                            setRenderMeshAsset(RenderMeshAsset*) = 0;
02123
02125     virtual uint32_t                        getScatterMeshAssetCount() const = 0;
02126
02128     virtual RenderMeshAsset* const *        getScatterMeshAssets() const = 0;
02129
02133     virtual uint32_t                        getInstancedChunkMeshCount() const = 0;
02134
02138     virtual void                            getStats(DestructibleAssetStats& stats) const = 0;
02139
02146     virtual void                            cacheChunkOverlapsUpToDepth(int32_t depth = -1) = 0;
02147
02155     virtual void                            clearChunkOverlaps(int32_t depth = -1, bool keepCachedFlag = false) = 0;
02156
02164     virtual void                            addChunkOverlaps(IntPair* supportGraphEdges, uint32_t numSupportGraphEdges) = 0;
02165
02174     virtual void                            removeChunkOverlaps(IntPair* supportGraphEdges, uint32_t numSupportGraphEdges, bool keepCachedFlagIfEmpty) = 0;
02175
02180     virtual uint32_t                        getCachedOverlapCountAtDepth(uint32_t depth) const = 0;
02181
02188     virtual const IntPair*                  getCachedOverlapsAtDepth(uint32_t depth) const = 0;
02189
02194     virtual PxVec3                          getChunkPositionOffset(uint32_t chunkIndex) const = 0;
02195
02200     virtual PxVec2                          getChunkUVOffset(uint32_t chunkIndex) const = 0;
02201
02205     virtual uint32_t                        getChunkFlags(uint32_t chunkIndex) const = 0;
02206
02210     virtual uint16_t                        getChunkDepth(uint32_t chunkIndex) const = 0;
02211
02216     virtual int32_t                         getChunkParentIndex(uint32_t chunkIndex) const = 0;
02217
02221     virtual PxBounds3                       getChunkActorLocalBounds(uint32_t chunkIndex) const = 0;
02222
02226     virtual uint32_t                        getPartIndex(uint32_t chunkIndex) const = 0;
02227
02231     virtual uint32_t                        getPartConvexHullCount(const uint32_t partIndex) const = 0;
02232
02236     virtual NvParameterized::Interface**    getPartConvexHullArray(const uint32_t partIndex) const = 0;
02237
02241     virtual uint32_t                        getActorTransformCount() const = 0;
02242
02247     virtual const PxMat44*                  getActorTransforms() const = 0;
02248
02258     virtual void                            applyTransformation(const PxMat44& transformation, float scale) = 0;
02259
02268     virtual void                            applyTransformation(const PxMat44& transformation) = 0;
02269
02274     virtual bool                            rebuildCollisionGeometry(uint32_t partIndex, const DestructibleGeometryDesc& geometryDesc) = 0;
02275
02276 protected:
02278     virtual                                 ~DestructibleAsset() {}
02279 };
02280
02281
02282 #if !PX_PS4
02283     #pragma warning(pop)
02284 #endif  //!PX_PS4
02285
02286 PX_POP_PACK
02287
02288 }
02289 } // end namespace nvidia
02290
02291 #endif // DESTRUCTIBLE_ASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: DestructiblePreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
DestructiblePreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef DESTRUCTIBLE_PREVIEW_H
00031 #define DESTRUCTIBLE_PREVIEW_H
00032
00033 #include "AssetPreview.h"
00034 #include "RenderMeshActor.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043
00048 class DestructiblePreview : public AssetPreview
00049 {
00050 public:
00051
00055     virtual const RenderMeshActor* getRenderMeshActor() const = 0;
00056
00062     virtual void    setExplodeView(uint32_t depth, float explode) = 0;
00063
00064 protected:
00065     DestructiblePreview() {}
00066 };
00067
00068 PX_POP_PACK
00069
00070 }
00071 } // end namespace nvidia
00072
00073 #endif // DESTRUCTIBLE_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: DestructibleRenderable.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
DestructibleRenderable.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef DESTRUCTIBLE_RENDERABLE_H
00031 #define DESTRUCTIBLE_RENDERABLE_H
00032
00033 #include "foundation/Px.h"
00034 #include "ApexInterface.h"
00035 #include "Renderable.h"
00036 #include "ModuleDestructible.h"
00037
00038 namespace nvidia
00039 {
00040 namespace apex
00041 {
00042
00043 PX_PUSH_PACK_DEFAULT
00044
00045
00049 class DestructibleRenderable : public ApexInterface, public Renderable
00050 {
00051 public:
00055     virtual RenderMeshActor*    getRenderMeshActor(DestructibleActorMeshType::Enum type = DestructibleActorMeshType::Skinned) const = 0;
00056
00057 protected:
00058     virtual ~DestructibleRenderable() {}
00059 };
00060
00061 PX_POP_PACK
00062
00063 }
00064 } // end namespace nvidia
00065
00066 #endif // DESTRUCTIBLE_RENDERABLE_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: EffectPackageActor.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Enumerations
EffectPackageActor.h File Reference

An EffectPackageActor represents an instantiation of a collection of related particle actors The EffectPackage system allows for multiple related particle actors to be instantiated as a single unit with a single root pose transform. This can be one or more emitters as well as associated field samplers, heat sources, etc. This single instantiation can be subject to level of detail culling and otherwise manipulated as a single unit. More...

#include "Actor.h"
#include "EmitterActor.h"

Go to the source code of this file.

Classes

class | nvidia::apex::EffectPackageActor
Defines the EffectPackageActor API which is instantiated from an EffectPackageAsset. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Enumerations

enum nvidia::apex::EffectType {
ET_EMITTER,
ET_HEAT_SOURCE,
ET_SUBSTANCE_SOURCE,
ET_TURBULENCE_FS,
ET_JET_FS,
ET_ATTRACTOR_FS,
ET_FORCE_FIELD,
ET_NOISE_FS,
ET_VORTEX_FS,
ET_WIND_FS,
ET_RIGID_BODY,
ET_VELOCITY_SOURCE,
ET_FLAME_EMITTER,
ET_LAST
}

Detailed Description

An EffectPackageActor represents an instantiation of a collection of related particle actors The EffectPackage system allows for multiple related particle actors to be instantiated as a single unit with a single root pose transform. This can be one or more emitters as well as associated field samplers, heat sources, etc. This single instantiation can be subject to level of detail culling and otherwise manipulated as a single unit.

EffectPackages are authored using the 'ParticleEffectTool' which allows the developer to rapidly prototype a combined 'particle effect'. This is a PhysX 3.x only feature.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: EffectPackageActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
EffectPackageActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EFFECT_PACKAGE_ACTOR_H
00031 #define EFFECT_PACKAGE_ACTOR_H
00032
00033 #include "Actor.h"
00034 #include "EmitterActor.h"
00035
00048 struct ID3D11ShaderResourceView;
00049 struct ID3D11DeviceContext;
00050
00051 namespace physx
00052 {
00053     class PxRigidDynamic;
00054 }
00055
00056 namespace nvidia
00057 {
00058
00059 namespace general_renderdebug4
00060 {
00062 class RenderDebugInterface;
00063 };
00064
00065 namespace apex
00066 {
00067
00071 enum EffectType
00072 {
00073     ET_EMITTER,
00074     ET_HEAT_SOURCE,
00075     ET_SUBSTANCE_SOURCE,
00076     ET_TURBULENCE_FS,
00077     ET_JET_FS,
00078     ET_ATTRACTOR_FS,
00079     ET_FORCE_FIELD,
00080     ET_NOISE_FS,
00081     ET_VORTEX_FS,
00082     ET_WIND_FS,
00083     ET_RIGID_BODY,
00084     ET_VELOCITY_SOURCE,
00085     ET_FLAME_EMITTER,
00086     ET_LAST
00087 };
00088
00089 class Actor;
00090 class RenderVolume;
00091
00095 class EffectPackageActor : public Actor
00096 {
00097 public:
00098
00109     virtual void fadeOut(float fadetime) = 0;
00110
00120     virtual void fadeIn(float fadetime) = 0;
00121
00125     virtual uint32_t getEffectCount() const = 0;
00126
00132     virtual EffectType getEffectType(uint32_t effectIndex) const = 0;
00133
00139     virtual const char* getEffectName(uint32_t effectIndex) const = 0;
00140
00146     virtual bool isEffectEnabled(uint32_t effectIndex) const = 0;
00147
00154     virtual bool setEffectEnabled(uint32_t effectIndex, bool state) = 0;
00155
00161     virtual void setCurrentScale(float scale) = 0;
00162
00166     virtual float getCurrentScale(void) const = 0;
00167
00175     virtual bool getEffectPose(uint32_t effectIndex, PxTransform& pose, bool worldSpace) = 0;
00176
00184     virtual bool setEffectPose(uint32_t effectIndex, const PxTransform& pose, bool worldSpace) = 0;
00185
00198     virtual Actor* getEffectActor(uint32_t effectIndex) const  = 0;
00199
00209     virtual PxRigidDynamic* getEffectRigidDynamic(uint32_t effectIndex) const  = 0;
00210
00218     virtual void setEmitterState(bool state) = 0;
00219
00225     virtual uint32_t getActiveParticleCount() const = 0;
00226
00235     virtual bool isStillEmitting() const = 0;
00236
00240     virtual bool isAlive(void) const = 0;
00241
00251     virtual void setEnabled(bool state) = 0;
00252
00256     virtual bool getEnabled() const = 0;
00257
00265     virtual void setPose(const PxTransform& pose) = 0;
00266
00270     virtual const PxTransform& getPose() const = 0;
00271
00275     virtual void refresh() = 0;
00276
00280     virtual void release() = 0;
00281
00285     virtual const char* getName() const = 0;
00286
00290     virtual float getDuration() const = 0;
00291
00295     virtual float getCurrentLife() const = 0;
00296
00300     virtual void                 setPreferredRenderVolume(RenderVolume* volume) = 0;
00301
00305     virtual const char * hasVolumeRenderMaterial(uint32_t &index) const = 0;
00306
00310     virtual void setApexEmitterValidateCallback(EmitterActor::EmitterValidateCallback *callback) = 0;
00311 };
00312
00313
00314 }; // end of apex namespace
00315 }; // end of physx namespace
00316
00317 #endif
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: EffectPackageAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
EffectPackageAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EFFECT_PACKAGE_ASSET_H
00031 #define EFFECT_PACKAGE_ASSET_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 #define PARTICLES_EFFECT_PACKAGE_AUTHORING_TYPE_NAME "EffectPackageAsset"
00043
00047 class EffectPackageAsset : public Asset
00048 {
00049 protected:
00050
00051     virtual ~EffectPackageAsset() {}
00052
00053 public:
00057     virtual float getDuration() const = 0;
00058
00062     virtual bool useUniqueRenderVolume() const = 0;
00063
00064
00065 }; //
00066
00071 class EffectPackageAssetAuthoring : public AssetAuthoring
00072 {
00073 protected:
00074     virtual ~EffectPackageAssetAuthoring() {}
00075 };
00076
00077 PX_POP_PACK
00078
00079 } // end of apex namespace
00080 } // end of nvidia namespace
00081
00082 #endif
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: EmitterActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
EmitterActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EMITTER_ACTOR_H
00031 #define EMITTER_ACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class EmitterAsset;
00043 class EmitterGeomExplicit;
00044 class EmitterLodParamDesc;
00045 class RenderVolume;
00046
00048 class EmitterActor : public Actor
00049 {
00050 protected:
00051     virtual ~EmitterActor() {}
00052
00053 public:
00054
00058     class EmitterValidateCallback
00059     {
00060     public:
00069         virtual bool validateEmitterPosition(const PxVec3 &emitterOrigin,PxVec3 &position) = 0;
00070     };
00071
00073     virtual EmitterAsset*           getEmitterAsset() const = 0;
00074
00076     virtual EmitterGeomExplicit*    isExplicitGeom() = 0;
00077
00079     virtual PxMat44                 getGlobalPose() const = 0;
00080
00082     virtual void                    setCurrentPose(const PxTransform& pose) = 0;
00083
00085     virtual void                    setCurrentPosition(const PxVec3& pos) = 0;
00086
00092     virtual void                    setAttachActor(PxActor*) = 0;
00093
00095     virtual void                    setAttachRelativePose(const PxTransform& pose) = 0;
00096
00098     virtual const PxActor*          getAttachActor() const = 0;
00099
00101     virtual const PxMat44           getAttachRelativePose() const = 0;
00102
00104     virtual float                   getObjectRadius() const = 0;
00105
00107     virtual void                    setOverlapTestCollisionGroups(uint32_t) = 0;
00108
00115     virtual void                    startEmit(bool persistent = true) = 0;
00116
00118     virtual void                    stopEmit() = 0;
00119
00121     virtual bool                    isEmitting() const = 0;
00122
00124     virtual const EmitterLodParamDesc& getLodParamDesc() const = 0;
00126     virtual void                    setLodParamDesc(const EmitterLodParamDesc&) = 0;
00127
00129
00130     virtual void                    setDensity(const float&) = 0;
00131
00133     virtual void                    setRate(const float&) = 0;
00134
00136     virtual void                    setVelocityLow(const PxVec3&) = 0;
00137
00139     virtual void                    setVelocityHigh(const PxVec3&) = 0;
00140
00142     virtual void                    setLifetimeLow(const float&) = 0;
00143
00145     virtual void                    setLifetimeHigh(const float&) = 0;
00146
00148     virtual void                    emitAssetParticles(bool enable) = 0;
00149
00151     virtual bool                    getEmitAssetParticles() const = 0;
00152
00159     virtual void                    setPreferredRenderVolume(RenderVolume* volume) = 0;
00160
00162     virtual void                    getRate(float&) const = 0;
00163
00165     virtual uint32_t                getSimParticlesCount() const = 0;
00166
00168     virtual uint32_t                getActiveParticleCount() const = 0;
00169
00171     virtual void                    setDensityGridPosition(const PxVec3 &pos) = 0;
00172
00174     virtual void                    setApexEmitterValidateCallback(EmitterValidateCallback *callback) = 0;
00175
00177     PX_DEPRECATED virtual void      setObjectScale(float scale) = 0;
00178
00180     PX_DEPRECATED virtual float     getObjectScale(void) const = 0;
00181
00183     virtual void                    setCurrentScale(float scale) = 0;
00184
00186     virtual float                   getCurrentScale(void) const = 0;
00187
00188
00189 };
00190
00191 PX_POP_PACK
00192
00193 }
00194 } // end namespace nvidia
00195
00196 #endif // EMITTER_ACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: EmitterAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
EmitterAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EMITTER_ASSET_H
00031 #define EMITTER_ASSET_H
00032
00033 #include "Apex.h"
00034 #include "EmitterGeoms.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define EMITTER_AUTHORING_TYPE_NAME "ApexEmitterAsset"
00044
00045 class EmitterActor;
00046 class EmitterPreview;
00047 class EmitterLodParamDesc;
00048
00050 class EmitterAsset : public Asset
00051 {
00052 protected:
00053     virtual ~EmitterAsset() {}
00054
00055 public:
00056
00058     virtual EmitterGeomExplicit*    isExplicitGeom() = 0;
00059
00061     virtual const EmitterGeom*      getGeom() const = 0;
00062
00064     virtual const char*             getInstancedObjectEffectsAssetName(void) const = 0;
00065
00067     virtual const char*             getInstancedObjectSimulatorAssetName(void) const = 0;
00068
00070     virtual const char*             getInstancedObjectSimulatorTypeName(void) const = 0;
00071
00072     virtual const float &           getDensity() const = 0;
00073     virtual const float &           getRate() const = 0;
00074     virtual const PxVec3 &          getVelocityLow() const = 0;
00075     virtual const PxVec3 &          getVelocityHigh() const = 0;
00076     virtual const float &           getLifetimeLow() const = 0;
00077     virtual const float &           getLifetimeHigh() const = 0;
00078
00080     virtual uint32_t                getMaxSamples() const = 0;
00081
00086     virtual float                   getEmitDuration() const = 0;
00087
00089     virtual const EmitterLodParamDesc& getLodParamDesc() const = 0;
00090
00091 };
00092
00094 class EmitterAssetAuthoring : public AssetAuthoring
00095 {
00096 protected:
00097     virtual ~EmitterAssetAuthoring() {}
00098 };
00099
00100
00101 PX_POP_PACK
00102
00103 }
00104 } // end namespace nvidia
00105
00106 #endif // EMITTER_ASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: EmitterGeoms.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
EmitterGeoms.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EMITTER_GEOMS_H
00031 #define EMITTER_GEOMS_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00043 struct EmitterType
00044 {
00046     enum Enum
00047     {
00048         ET_RATE = 0,
00049         ET_DENSITY_ONCE,
00050         ET_DENSITY_BRUSH,
00051         ET_FILL,
00052         ET_UNDEFINED,
00053     };
00054 };
00055
00056 class EmitterGeomBox;
00057 class EmitterGeomSphere;
00058 class EmitterGeomSphereShell;
00059 class EmitterGeomCylinder;
00060 class EmitterGeomExplicit;
00061
00063 class EmitterGeom
00064 {
00065 public:
00067     virtual void                            setEmitterType(EmitterType::Enum) = 0;
00068
00070     virtual EmitterType::Enum               getEmitterType() const = 0;
00071
00073     virtual const EmitterGeomBox*           isBoxGeom() const
00074     {
00075         return NULL;
00076     }
00077
00079     virtual const EmitterGeomSphere*        isSphereGeom() const
00080     {
00081         return NULL;
00082     }
00083
00085     virtual const EmitterGeomSphereShell*   isSphereShellGeom() const
00086     {
00087         return NULL;
00088     }
00089
00091     virtual const EmitterGeomCylinder*      isCylinderGeom() const
00092     {
00093         return NULL;
00094     }
00095
00097     virtual const EmitterGeomExplicit*      isExplicitGeom() const
00098     {
00099         return NULL;
00100     }
00101 };
00102
00104 class EmitterGeomSphereShell : public EmitterGeom
00105 {
00106 public:
00107
00109     virtual void    setRadius(float radius) = 0;
00110
00112     virtual float   getRadius() const = 0;
00113
00115     virtual void    setShellThickness(float thickness) = 0;
00116
00118     virtual float   getShellThickness() const = 0;
00119 };
00120
00122 class EmitterGeomSphere : public EmitterGeom
00123 {
00124 public:
00125
00127     virtual void    setRadius(float radius) = 0;
00128
00130     virtual float   getRadius() const = 0;
00131 };
00132
00134 class EmitterGeomCylinder : public EmitterGeom
00135 {
00136 public:
00137
00139     virtual void    setRadius(float radius) = 0;
00140
00142     virtual float   getRadius() const = 0;
00143
00145     virtual void    setHeight(float height) = 0;
00146
00148     virtual float   getHeight() const = 0;
00149 };
00150
00152 class EmitterGeomBox : public EmitterGeom
00153 {
00154 public:
00155
00157     virtual void    setExtents(const PxVec3& extents) = 0;
00158
00160     virtual PxVec3  getExtents() const = 0;
00161 };
00162
00164 class EmitterGeomExplicit : public EmitterGeom
00165 {
00166 public:
00167
00169     struct PointParams
00170     {
00171         PxVec3 position;
00172         bool doDetectOverlaps;
00173     };
00174
00176     struct SphereParams
00177     {
00178         PxVec3 center;
00179         float radius;
00180         bool doDetectOverlaps;
00181     };
00182
00184     struct EllipsoidParams
00185     {
00186         PxVec3 center;
00187         float radius;
00188         PxVec3 normal;
00189         float polarRadius;
00190         bool doDetectOverlaps;
00191     };
00192
00194     virtual void    resetParticleList() = 0;
00195
00202     virtual void    addParticleList(uint32_t count,
00203                                     const PointParams* params,
00204                                     const PxVec3* velocities = 0) = 0;
00205
00212     virtual void    addParticleList(uint32_t count,
00213                                     const PxVec3* positions,
00214                                     const PxVec3* velocities = 0) = 0;
00215
00217     struct PointListData
00218     {
00219         const void* positionStart;
00220         uint32_t    positionStrideBytes;
00221         const void* velocityStart;
00222         uint32_t    velocityStrideBytes;
00223         const void* userDataStart;
00224         uint32_t    userDataStrideBytes;
00225     };
00226
00233     virtual void    addParticleList(uint32_t count, const PointListData& data) = 0;
00234
00242     virtual void    addSphereList(uint32_t count,
00243                                   const SphereParams* params,
00244                                   const PxVec3* velocities = 0) = 0;
00245
00253     virtual void    addEllipsoidList(uint32_t count,
00254                                      const EllipsoidParams*  params,
00255                                      const PxVec3* velocities = 0) = 0;
00256
00265     virtual void    getParticleList(const PointParams* &params,
00266                                     uint32_t& numPoints,
00267                                     const PxVec3* &velocities,
00268                                     uint32_t& numVelocities) const = 0;
00269
00278     virtual void    getSphereList(const SphereParams* &params,
00279                                   uint32_t& numSpheres,
00280                                   const PxVec3* &velocities,
00281                                   uint32_t& numVelocities) const = 0;
00282
00291     virtual void    getEllipsoidList(const EllipsoidParams* &params,
00292                                      uint32_t& numEllipsoids,
00293                                      const PxVec3* &velocities,
00294                                      uint32_t& numVelocities) const = 0;
00295
00297     virtual uint32_t    getParticleCount() const = 0;
00298
00300     virtual PxVec3      getParticlePos(uint32_t index) const = 0;
00301
00303     virtual uint32_t    getSphereCount() const = 0;
00304
00306     virtual PxVec3      getSphereCenter(uint32_t index) const = 0;
00307
00309     virtual float       getSphereRadius(uint32_t index) const = 0;
00310
00312     virtual uint32_t    getEllipsoidCount() const = 0;
00313
00315     virtual PxVec3      getEllipsoidCenter(uint32_t index) const = 0;
00316
00318     virtual float       getEllipsoidRadius(uint32_t index) const = 0;
00319
00321     virtual PxVec3      getEllipsoidNormal(uint32_t index) const = 0;
00322
00324     virtual float       getEllipsoidPolarRadius(uint32_t index) const = 0;
00325
00327     virtual float       getDistance() const = 0;
00328 };
00329
00330
00331 PX_POP_PACK
00332
00333 }
00334 } // end namespace nvidia
00335
00336 #endif // EMITTER_GEOMS_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: EmitterLodParamDesc.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
EmitterLodParamDesc.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EMITTER_LOD_PARAM_DESC_H
00031 #define EMITTER_LOD_PARAM_DESC_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00044 class EmitterLodParamDesc : public ApexDesc
00045 {
00046 public:
00047     float  maxDistance;
00048     float  distanceWeight;
00049     float  speedWeight;
00050     float  lifeWeight;
00051     float  separationWeight;
00052     float  bias;
00053
00057     PX_INLINE EmitterLodParamDesc() : ApexDesc()
00058     {
00059         init();
00060     }
00061
00065     PX_INLINE void setToDefault()
00066     {
00067         ApexDesc::setToDefault();
00068         init();
00069     }
00070
00074     PX_INLINE bool isValid() const
00075     {
00076         if (distanceWeight < 0.0f || speedWeight < 0.0f || lifeWeight < 0.0f)
00077         {
00078             return false;
00079         }
00080         if (separationWeight < 0.0f || maxDistance < 0.0f || bias < 0.0f)
00081         {
00082             return false;
00083         }
00084         return ApexDesc::isValid();
00085     }
00086
00090     enum ManifestVersions
00091     {
00092         initial,
00093
00094         count,
00095         current = count - 1
00096     };
00097
00098 private:
00099
00100     PX_INLINE void init()
00101     {
00102         // These defaults give you pure distance based LOD weighting
00103         maxDistance = 0.0f;
00104         distanceWeight = 1.0f;
00105         speedWeight = 0.0f;
00106         lifeWeight = 0.0f;
00107         separationWeight = 0.0f;
00108         bias = 1.0f;
00109     }
00110 };
00111
00112
00113 PX_POP_PACK
00114
00115 }
00116 } // end namespace nvidia
00117
00118 #endif // EMITTER_LOD_PARAM_DESC_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: EmitterPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
EmitterPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EMITTER_PREVIEW_H
00031 #define EMITTER_PREVIEW_H
00032
00033 #include "Apex.h"
00034 #include "AssetPreview.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00046 class EmitterPreview : public AssetPreview
00047 {
00048 public:
00050     virtual void    drawEmitterPreview() = 0;
00052     virtual void    setScale(float scale) = 0;
00053
00054 protected:
00055     EmitterPreview() {}
00056 };
00057
00058
00059 PX_POP_PACK
00060
00061 }
00062 } // end namespace nvidia
00063
00064 #endif // EMITTER_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ExplicitHierarchicalMesh.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ExplicitHierarchicalMesh.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef EXPLICIT_HIERARCHICAL_MESH_H
00031 #define EXPLICIT_HIERARCHICAL_MESH_H
00032
00033 #include "foundation/Px.h"
00034 #include "IProgressListener.h"
00035 #include "RenderMeshAsset.h"
00036 #include "ConvexHullMethod.h"
00037 #include "foundation/PxPlane.h"
00038
00039 namespace nvidia
00040 {
00041 namespace apex
00042 {
00043
00044 PX_PUSH_PACK_DEFAULT
00045
00051 struct ExplicitVertexFormat
00052 {
00054     uint32_t            mWinding;
00055
00057     bool                mHasStaticPositions;
00058
00060     bool                mHasStaticNormals;
00061
00063     bool                mHasStaticTangents;
00064
00066     bool                mHasStaticBinormals;
00067
00069     bool                mHasStaticColors;
00070
00072     bool                mHasStaticSeparateBoneBuffer;
00073
00075     bool                mHasStaticDisplacements;
00076
00078     bool                mHasDynamicPositions;
00079
00081     bool                mHasDynamicNormals;
00082
00084     bool                mHasDynamicTangents;
00085
00087     bool                mHasDynamicBinormals;
00088
00090     bool                mHasDynamicColors;
00091
00093     bool                mHasDynamicSeparateBoneBuffer;
00094
00096     bool                mHasDynamicDisplacements;
00097
00099     uint32_t            mUVCount;
00100
00102     uint32_t            mBonesPerVertex;
00103
00105     ExplicitVertexFormat()
00106     {
00107         clear();
00108     }
00109
00131     void    clear()
00132     {
00133         mWinding = RenderCullMode::CLOCKWISE;
00134         mHasStaticPositions = false;
00135         mHasStaticNormals = false;
00136         mHasStaticTangents = false;
00137         mHasStaticBinormals = false;
00138         mHasStaticColors = false;
00139         mHasStaticSeparateBoneBuffer = false;
00140         mHasStaticDisplacements = false;
00141         mHasDynamicPositions = false;
00142         mHasDynamicNormals = false;
00143         mHasDynamicTangents = false;
00144         mHasDynamicBinormals = false;
00145         mHasDynamicColors = false;
00146         mHasDynamicSeparateBoneBuffer = false;
00147         mHasDynamicDisplacements = false;
00148         mUVCount = 0;
00149         mBonesPerVertex = 0;
00150     }
00151
00155     bool    operator == (const ExplicitVertexFormat& data) const
00156     {
00157         if (mWinding != data.mWinding)
00158         {
00159             return false;
00160         }
00161         if (mHasStaticPositions != data.mHasStaticPositions ||
00162                 mHasStaticNormals != data.mHasStaticNormals ||
00163                 mHasStaticTangents != data.mHasStaticTangents ||
00164                 mHasStaticBinormals != data.mHasStaticBinormals ||
00165                 mHasStaticColors != data.mHasStaticColors ||
00166                 mHasStaticSeparateBoneBuffer != data.mHasStaticSeparateBoneBuffer ||
00167                 mHasStaticDisplacements != data.mHasStaticDisplacements)
00168         {
00169             return false;
00170         }
00171         if (mHasDynamicPositions != data.mHasDynamicPositions ||
00172                 mHasDynamicNormals != data.mHasDynamicNormals ||
00173                 mHasDynamicTangents != data.mHasDynamicTangents ||
00174                 mHasDynamicBinormals != data.mHasDynamicBinormals ||
00175                 mHasDynamicColors != data.mHasDynamicColors ||
00176                 mHasDynamicSeparateBoneBuffer != data.mHasDynamicSeparateBoneBuffer ||
00177                 mHasDynamicDisplacements != data.mHasDynamicDisplacements)
00178         {
00179             return false;
00180         }
00181         if (mUVCount != data.mUVCount)
00182         {
00183             return false;
00184         }
00185         return true;
00186     }
00187
00191     bool    operator != (const ExplicitVertexFormat& data) const
00192     {
00193         return !(*this == data);
00194     }
00195
00199     void    copyToVertexFormat(VertexFormat* format) const
00200     {
00201         format->reset();
00202         uint32_t bi;
00203         if (mHasStaticPositions)
00204         {
00205             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::POSITION));
00206             format->setBufferFormat(bi, RenderDataFormat::FLOAT3);
00207             format->setBufferAccess(bi, mHasDynamicPositions ? RenderDataAccess::DYNAMIC :  RenderDataAccess::STATIC);
00208         }
00209         if (mHasStaticNormals)
00210         {
00211             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::NORMAL));
00212             format->setBufferFormat(bi, RenderDataFormat::FLOAT3);
00213             format->setBufferAccess(bi, mHasDynamicNormals ? RenderDataAccess::DYNAMIC :  RenderDataAccess::STATIC);
00214         }
00215         if (mHasStaticTangents)
00216         {
00217             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::TANGENT));
00218             format->setBufferFormat(bi, RenderDataFormat::FLOAT3);
00219             format->setBufferAccess(bi, mHasDynamicTangents ? RenderDataAccess::DYNAMIC :  RenderDataAccess::STATIC);
00220         }
00221         if (mHasStaticBinormals)
00222         {
00223             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BINORMAL));
00224             format->setBufferFormat(bi, RenderDataFormat::FLOAT3);
00225             format->setBufferAccess(bi, mHasDynamicBinormals ? RenderDataAccess::DYNAMIC :  RenderDataAccess::STATIC);
00226         }
00227         if (mHasStaticDisplacements)
00228         {
00229             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::DISPLACEMENT_TEXCOORD));
00230             format->setBufferFormat(bi, RenderDataFormat::FLOAT3);
00231             format->setBufferAccess(bi, mHasDynamicDisplacements ? RenderDataAccess::DYNAMIC : RenderDataAccess::STATIC);
00232             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::DISPLACEMENT_FLAGS));
00233             format->setBufferFormat(bi, RenderDataFormat::UINT1);
00234             format->setBufferAccess(bi, mHasDynamicDisplacements ? RenderDataAccess::DYNAMIC : RenderDataAccess::STATIC);
00235         }
00236         if (mUVCount > 0)
00237         {
00238             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::TEXCOORD0));
00239             format->setBufferFormat(bi, RenderDataFormat::FLOAT2);
00240         }
00241         if (mUVCount > 1)
00242         {
00243             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::TEXCOORD1));
00244             format->setBufferFormat(bi, RenderDataFormat::FLOAT2);
00245         }
00246         if (mUVCount > 2)
00247         {
00248             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::TEXCOORD2));
00249             format->setBufferFormat(bi, RenderDataFormat::FLOAT2);
00250         }
00251         if (mUVCount > 3)
00252         {
00253             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::TEXCOORD3));
00254             format->setBufferFormat(bi, RenderDataFormat::FLOAT2);
00255         }
00256         switch (mBonesPerVertex)
00257         {
00258         case 1:
00259             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_INDEX));
00260             format->setBufferFormat(bi, RenderDataFormat::USHORT1);
00261             break;
00262         case 2:
00263             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_INDEX));
00264             format->setBufferFormat(bi, RenderDataFormat::USHORT2);
00265             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_WEIGHT));
00266             format->setBufferFormat(bi, RenderDataFormat::FLOAT2);
00267             break;
00268         case 3:
00269             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_INDEX));
00270             format->setBufferFormat(bi, RenderDataFormat::USHORT3);
00271             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_WEIGHT));
00272             format->setBufferFormat(bi, RenderDataFormat::FLOAT3);
00273             break;
00274         case 4:
00275             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_INDEX));
00276             format->setBufferFormat(bi, RenderDataFormat::USHORT4);
00277             bi = (uint32_t)format->addBuffer(format->getSemanticName(RenderVertexSemantic::BONE_WEIGHT));
00278             format->setBufferFormat(bi, RenderDataFormat::FLOAT4);
00279             break;
00280         }
00281
00282         format->setHasSeparateBoneBuffer(mHasStaticSeparateBoneBuffer);
00283         format->setWinding((RenderCullMode::Enum)mWinding);
00284     }
00285 };
00286
00287
00295 struct ExplicitSubmeshData
00296 {
00300     enum
00301     {
00302         MaterialNameBufferSize = 1024
00303     };
00304
00308     char                    mMaterialName[MaterialNameBufferSize];
00309
00314     ExplicitVertexFormat    mVertexFormat;
00315
00319     bool    operator == (const ExplicitSubmeshData& data) const
00320     {
00321         return !::strcmp(mMaterialName, data.mMaterialName) && mVertexFormat == data.mVertexFormat;
00322     }
00323
00327     bool    operator != (const ExplicitSubmeshData& data) const
00328     {
00329         return !(*this == data);
00330     }
00331 };
00332
00333
00337 struct CollisionVolumeDesc
00338 {
00339     CollisionVolumeDesc()
00340     {
00341         setToDefault();
00342     }
00343
00347     void setToDefault()
00348     {
00349         mHullMethod = ConvexHullMethod::CONVEX_DECOMPOSITION;
00350         mConcavityPercent = 4.0f;
00351         mMergeThreshold = 4.0f;
00352         mRecursionDepth = 0;
00353         mMaxVertexCount = 0;
00354         mMaxEdgeCount = 0;
00355         mMaxFaceCount = 0;
00356     }
00357
00362     ConvexHullMethod::Enum  mHullMethod;
00363
00368     float                   mConcavityPercent;
00369
00374     float                   mMergeThreshold;
00375
00382     uint32_t                mRecursionDepth;
00383
00388     uint32_t                mMaxVertexCount;
00389
00394     uint32_t                mMaxEdgeCount;
00395
00400     uint32_t                mMaxFaceCount;
00401 };
00402
00403
00407 struct CollisionDesc
00408 {
00418     unsigned                mDepthCount;
00419
00423     CollisionVolumeDesc*    mVolumeDescs;
00424
00430     float                   mMaximumTrimming;
00431
00433     CollisionDesc()
00434     {
00435         setToDefault();
00436     }
00437
00441     void setToDefault()
00442     {
00443         mDepthCount = 0;
00444         mVolumeDescs = NULL;
00445         mMaximumTrimming = 0.2f;
00446     }
00447 };
00448
00449
00454 struct FractureMethod
00455 {
00459     enum Enum
00460     {
00461         Unknown,
00462         Slice,
00463         Cutout,
00464         Voronoi,
00465
00466         FractureMethodCount
00467     };
00468 };
00469
00470
00476 struct FractureMaterialDesc
00477 {
00481     PxVec2  uvScale;
00482
00486     PxVec2  uvOffset;
00487
00492     PxVec3  tangent;
00493
00497     float   uAngle;
00498
00503     uint32_t interiorSubmeshIndex;
00504
00506     FractureMaterialDesc()
00507     {
00508         setToDefault();
00509     }
00510
00519     void    setToDefault()
00520     {
00521         uvScale = PxVec2(1.0f);
00522         uvOffset = PxVec2(0.0f);
00523         tangent = PxVec3(0.0f);
00524         uAngle = 0.0f;
00525         interiorSubmeshIndex = 0;
00526     }
00527 };
00528
00529
00534 struct MaterialFrame
00535 {
00536     MaterialFrame() :
00537         mCoordinateSystem(PxVec4(1.0f)),
00538         mUVPlane(PxVec3(0.0f, 0.0f, 1.0f), 0.0f),
00539         mUVScale(1.0f),
00540         mUVOffset(0.0f),
00541         mFractureMethod(FractureMethod::Unknown),
00542         mFractureIndex(-1),
00543         mSliceDepth(0)
00544     {
00545     }
00546
00550     void    buildCoordinateSystemFromMaterialDesc(const nvidia::FractureMaterialDesc& materialDesc, const PxPlane& plane)
00551             {
00552                 PxVec3 zAxis = plane.n;
00553                 zAxis.normalize();
00554                 PxVec3 xAxis = materialDesc.tangent;
00555                 PxVec3 yAxis = zAxis.cross(xAxis);
00556                 const float l2 = yAxis.magnitudeSquared();
00557                 if (l2 > PX_EPS_F32*PX_EPS_F32)
00558                 {
00559                     yAxis *= PxRecipSqrt(l2);
00560                 }
00561                 else
00562                 {
00563                     uint32_t maxDir =  PxAbs(plane.n.x) > PxAbs(plane.n.y) ?
00564                         (PxAbs(plane.n.x) > PxAbs(plane.n.z) ? 0u : 2u) :
00565                         (PxAbs(plane.n.y) > PxAbs(plane.n.z) ? 1u : 2u);
00566                     xAxis = PxMat33(PxIdentity)[(maxDir + 1) % 3];
00567                     yAxis = zAxis.cross(xAxis);
00568                     yAxis.normalize();
00569                 }
00570                 xAxis = yAxis.cross(zAxis);
00571
00572                 const float c = PxCos(materialDesc.uAngle);
00573                 const float s = PxSin(materialDesc.uAngle);
00574
00575                 mCoordinateSystem.column0 = PxVec4(c*xAxis + s*yAxis, 0.0f);
00576                 mCoordinateSystem.column1 = PxVec4(c*yAxis - s*xAxis, 0.0f);
00577                 mCoordinateSystem.column2 = PxVec4(zAxis, 0.0f);
00578                 mCoordinateSystem.setPosition(plane.project(PxVec3(0.0f)));
00579
00580                 mUVPlane = plane;
00581                 mUVScale = materialDesc.uvScale;
00582                 mUVOffset = materialDesc.uvOffset;
00583             }
00584
00585     PxMat44 mCoordinateSystem;
00586     PxPlane mUVPlane;
00587     PxVec2  mUVScale;
00588     PxVec2  mUVOffset;
00589     uint32_t    mFractureMethod;
00590     int32_t mFractureIndex;
00591     uint32_t    mSliceDepth;
00592 };
00593
00594
00605 class DisplacementMapVolume
00606 {
00607 public:
00614     virtual void getData(uint32_t& width, uint32_t& height, uint32_t& depth, uint32_t& size, unsigned char const** ppData) const = 0;
00615
00616     virtual ~DisplacementMapVolume() { }
00617 };
00618
00619
00627 struct BSPOpenMode
00628 {
00632     enum Enum
00633     {
00634         Automatic,
00635         Closed,
00636         Open,
00637
00638         BSPOpenModeCount
00639     };
00640 };
00641
00642
00651 class ExplicitHierarchicalMesh
00652 {
00653 public:
00655     enum Enum
00656     {
00661         VisualizeMeshBSPOutsideRegions  = (1 << 0),
00662
00667         VisualizeMeshBSPInsideRegions   = (1 << 1),
00668
00674         VisualizeMeshBSPSingleRegion    = (1 << 8),
00675
00677         VisualizeSliceBSPOutsideRegions = (1 << 16),
00678
00680         VisualizeSliceBSPInsideRegions  = (1 << 17),
00681
00683         VisualizeSliceBSPSingleRegion   = (1 << 24),
00684
00685         VisualizeMeshBSPAllRegions      = VisualizeMeshBSPOutsideRegions | VisualizeMeshBSPInsideRegions
00686     };
00687
00693     class Embedding
00694     {
00695     public:
00699         enum DataType
00700         {
00701             MaterialLibrary
00702         };
00703
00707         virtual void    serialize(PxFileBuf& stream, Embedding::DataType type) const = 0;
00708
00712         virtual void    deserialize(PxFileBuf& stream, Embedding::DataType type, uint32_t version) = 0;
00713     };
00714
00718     class ConvexHull
00719     {
00720     protected:
00721         ConvexHull()
00722         {
00723         }
00724
00725         virtual ~ConvexHull()
00726         {
00727         }
00728
00729     public:
00733         virtual void                    buildFromPoints(const void* points, uint32_t numPoints, uint32_t pointStrideBytes) = 0;
00734
00738         virtual const PxBounds3&        getBounds() const = 0;
00739
00743         virtual float                   getVolume() const = 0;
00744
00748         virtual uint32_t                getVertexCount() const = 0;
00749
00754         virtual PxVec3                  getVertex(uint32_t vertexIndex) const = 0;
00755
00759         virtual uint32_t                getEdgeCount() const = 0;
00760
00766         virtual PxVec3                  getEdgeEndpoint(uint32_t edgeIndex, uint32_t whichEndpoint) const = 0;
00767
00771         virtual uint32_t                getPlaneCount() const = 0;
00772
00777         virtual PxPlane                 getPlane(uint32_t planeIndex) const = 0;
00778
00806         virtual bool                    rayCast(float& in, float& out, const PxVec3& orig, const PxVec3& dir,
00807                                                 const PxTransform& localToWorldRT, const PxVec3& scale, PxVec3* normal = NULL) const = 0;
00816         virtual bool                    reduceHull(uint32_t maxVertexCount, uint32_t maxEdgeCount, uint32_t maxFaceCount, bool inflated) = 0;
00817
00821         virtual void                    release() = 0;
00822     };
00823
00831     virtual void                        clear(bool keepRoot = false) = 0;
00832
00837     virtual int32_t                     maxDepth() const = 0;
00838
00842     virtual uint32_t                    partCount() const = 0;
00843
00847     virtual uint32_t                    chunkCount() const = 0;
00848
00853     virtual int32_t*                    parentIndex(uint32_t chunkIndex) = 0;
00854
00859     virtual uint64_t                    chunkUniqueID(uint32_t chunkIndex) = 0;
00860
00864     virtual int32_t*                    partIndex(uint32_t chunkIndex) = 0;
00865
00869     virtual PxVec3*                     instancedPositionOffset(uint32_t chunkIndex) = 0;
00870
00874     virtual PxVec2*                     instancedUVOffset(uint32_t chunkIndex) = 0;
00875
00880     virtual uint32_t                    meshTriangleCount(uint32_t partIndex) const = 0;
00881
00886     virtual ExplicitRenderTriangle*     meshTriangles(uint32_t partIndex) = 0;
00887
00891     virtual PxBounds3                   meshBounds(uint32_t partIndex) const = 0;
00892
00896     virtual PxBounds3                   chunkBounds(uint32_t chunkIndex) const = 0;
00897
00902     virtual uint32_t*                   chunkFlags(uint32_t chunkIndex) const = 0;
00903
00907     virtual void                        buildCollisionGeometryForPart(uint32_t partIndex, const CollisionVolumeDesc& desc) = 0;
00908
00916     virtual void                        buildCollisionGeometryForRootChunkParts(const CollisionDesc& desc, bool aggregateRootChunkParentCollision = true) = 0;
00917
00921     virtual void                        reduceHulls(const CollisionDesc& desc, bool inflated) = 0;
00922
00926     virtual uint32_t                    convexHullCount(uint32_t partIndex) const = 0;
00927
00931     virtual const ConvexHull**          convexHulls(uint32_t partIndex) const = 0;
00932
00936     virtual PxVec3*                     surfaceNormal(uint32_t partIndex) = 0;
00937
00941     virtual const DisplacementMapVolume&    displacementMapVolume() const = 0;
00942
00948     virtual uint32_t                    submeshCount() const = 0;
00949
00953     virtual ExplicitSubmeshData*        submeshData(uint32_t submeshIndex) = 0;
00954
00959     virtual uint32_t                    addSubmesh(const ExplicitSubmeshData& submeshData) = 0;
00960
00969     virtual uint32_t                    getMaterialFrameCount() const = 0;
00970     virtual nvidia::MaterialFrame       getMaterialFrame(uint32_t index) const = 0;
00971     virtual void                        setMaterialFrame(uint32_t index, const nvidia::MaterialFrame& materialFrame) = 0;
00972     virtual uint32_t                    addMaterialFrame() = 0;
00973
00978     virtual void                        serialize(PxFileBuf& stream, Embedding& embedding) const = 0;
00979
00984     virtual void                        deserialize(PxFileBuf& stream, Embedding& embedding) = 0;
00985
00989     virtual void                        set(const ExplicitHierarchicalMesh& mesh) = 0;
00990
00999     virtual void                        calculateMeshBSP(uint32_t randomSeed, IProgressListener* progressListener = NULL, const uint32_t* microgridSize = NULL, BSPOpenMode::Enum meshMode = BSPOpenMode::Automatic) = 0;
01000
01004     virtual void                        replaceInteriorSubmeshes(uint32_t partIndex, uint32_t frameCount, uint32_t* frameIndices, uint32_t submeshIndex) = 0;
01005
01011     virtual void                        visualize(RenderDebugInterface& debugRender, uint32_t flags, uint32_t index = 0) const = 0;
01012
01016     virtual void                        release() = 0;
01017
01018 protected:
01024     ExplicitHierarchicalMesh() {}
01025     virtual                             ~ExplicitHierarchicalMesh() {}
01026
01027 private:
01029     ExplicitHierarchicalMesh&           operator = (const ExplicitHierarchicalMesh&)
01030     {
01031         return *this;
01032     }
01033 };
01034
01035
01036 PX_POP_PACK
01037
01038 }
01039 } // end namespace nvidia
01040
01041
01042 #endif // EXPLICIT_HIERARCHICAL_MESH_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: FlameEmitterActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
FlameEmitterActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef FLAME_EMITTER_ACTOR_H
00030 #define FLAME_EMITTER_ACTOR_H
00031
00032 #include "Apex.h"
00033 #include "Shape.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 class FlameEmitterAsset;
00041
00042
00046 class FlameEmitterActor : public Actor
00047 {
00048 protected:
00049     virtual ~FlameEmitterActor() {}
00050
00051 public:
00053     virtual FlameEmitterAsset*          getFlameEmitterAsset() const = 0;
00054
00055
00057     virtual void                        setEnabled(bool enable) = 0;
00058
00060     virtual bool                        isEnabled() const = 0;
00061
00063     virtual bool                        intersectAgainstAABB(const PxBounds3&) const = 0;
00064
00066     virtual PxMat44                     getPose() const = 0;
00067
00069     virtual void                        setPose(PxMat44 pose) = 0;
00070
00072     virtual void                        setCurrentScale(float scale) = 0;
00073
00075     virtual float                       getCurrentScale(void) const = 0;
00076
00077     virtual void                        release() = 0;
00078 };
00079
00080
00081 }
00082 } // end namespace nvidia
00083
00084 #endif
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: FlameEmitterAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
FlameEmitterAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef FLAME_EMITTER_ASSET_H
00030 #define FLAME_EMITTER_ASSET_H
00031
00032 #include "Apex.h"
00033 #include "CustomBufferIterator.h"
00034
00035 #define FLAME_EMITTER_AUTHORING_TYPE_NAME "FlameEmitterAsset"
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00045 class FlameEmitterAsset : public Asset
00046 {
00047 protected:
00048     virtual ~FlameEmitterAsset() {}
00049 };
00050
00051
00055 class FlameEmitterAssetAuthoring : public AssetAuthoring
00056 {
00057 protected:
00058     virtual ~FlameEmitterAssetAuthoring() {}
00059 };
00060
00061
00062 }
00063 } // end namespace nvidia
00064
00065 #endif // FLAME_EMITTER_ASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: FlameEmitterPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
FlameEmitterPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef FLAME_EMITTER_PREVIEW_H
00030 #define FLAME_EMITTER_PREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00045 class FlameEmitterPreview : public AssetPreview
00046 {
00047 public:
00048     public:
00050     virtual void    drawFlameEmitterPreview() = 0;
00052     virtual void    setScale(float scale) = 0;
00053
00054 protected:
00055     FlameEmitterPreview() {}
00056 };
00057
00058
00059 PX_POP_PACK
00060
00061 }
00062 } // namespace nvidia
00063
00064 #endif // FLAME_EMITTER_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ForceFieldActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ForceFieldActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef FORCE_FIELD_ACTOR_H
00031 #define FORCE_FIELD_ACTOR_H
00032
00033 #include "Apex.h"
00034
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041
00042 PX_PUSH_PACK_DEFAULT
00043
00044 class ForceFieldAsset;
00045 class ForceFieldAssetParams;
00046
00050 class ForceFieldActor : public Actor
00051 {
00052 protected:
00053     virtual ~ForceFieldActor() {}
00054
00055 public:
00059     virtual bool                    isEnable() = 0;
00060
00065     virtual bool                    disable() = 0;
00066
00071     virtual bool                    enable() = 0;
00072
00076     virtual PxMat44                 getPose() const = 0;
00077
00081     virtual void                    setPose(const PxMat44& pose) = 0;
00082
00086     PX_DEPRECATED virtual float     getScale() const = 0;
00087
00091     PX_DEPRECATED virtual void      setScale(float scale) = 0;
00092
00096     PX_DEPRECATED virtual float     getCurrentScale() const = 0;
00097
00101     PX_DEPRECATED virtual void      setCurrentScale(float scale) = 0;
00102
00103
00104
00108     virtual const char*             getName() const = 0;
00109
00113     virtual void                    setName(const char* name) = 0;
00114
00118     virtual void                    setStrength(const float strength) = 0;
00119
00123     virtual void                    setLifetime(const float lifetime) = 0;
00124
00129     PX_DEPRECATED virtual void      setFalloffType(const char* type) = 0;
00130
00135     PX_DEPRECATED virtual void      setFalloffMultiplier(const float multiplier) = 0;
00136
00140     virtual ForceFieldAsset*        getForceFieldAsset() const = 0;
00141
00142 };
00143
00144 PX_POP_PACK
00145
00146 } // namespace apex
00147 } // namespace nvidia
00148
00149 #endif // FORCE_FIELD_ACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ForceFieldAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ForceFieldAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef FORCE_FIELD_ASSET_H
00031 #define FORCE_FIELD_ASSET_H
00032
00033 #include "Apex.h"
00034 #include "ForceFieldPreview.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define FORCEFIELD_AUTHORING_TYPE_NAME "ForceFieldAsset"
00044
00045 class ForceFieldActor;
00046
00050 class ForceFieldAsset : public Asset
00051 {
00052 protected:
00056     virtual ~ForceFieldAsset() {}
00057
00058 public:
00062     virtual float       getDefaultScale() const = 0;
00063
00067     virtual void        releaseForceFieldActor(ForceFieldActor&) = 0;
00068 };
00069
00073 class ForceFieldAssetAuthoring : public AssetAuthoring
00074 {
00075 protected:
00079     virtual ~ForceFieldAssetAuthoring() {}
00080
00081 public:
00082 };
00083
00084
00085 PX_POP_PACK
00086
00087 } // namespace apex
00088 } // namespace nvidia
00089
00090 #endif // FORCE_FIELD_ASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ForceFieldPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ForceFieldPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef FORCE_FIELD_PREVIEW_H
00031 #define FORCE_FIELD_PREVIEW_H
00032
00033 #include "Apex.h"
00034 #include "AssetPreview.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class RenderDebugInterface;
00044
00045 namespace APEX_FORCEFIELD
00046 {
00051 static const uint32_t FORCEFIELD_DRAW_NOTHING = (0x00);
00056 static const uint32_t FORCEFIELD_DRAW_ICON = (0x01);
00061 static const uint32_t FORCEFIELD_DRAW_BOUNDARIES = (0x2);
00066 static const uint32_t FORCEFIELD_DRAW_WITH_CYLINDERS = (0x4);
00071 static const uint32_t FORCEFIELD_DRAW_FULL_DETAIL = (FORCEFIELD_DRAW_ICON + FORCEFIELD_DRAW_BOUNDARIES);
00076 static const uint32_t FORCEFIELD_DRAW_FULL_DETAIL_BOLD = (FORCEFIELD_DRAW_FULL_DETAIL + FORCEFIELD_DRAW_WITH_CYLINDERS);
00077 }
00078
00082 class ForceFieldPreview : public AssetPreview
00083 {
00084 public:
00090     virtual void    setIconScale(float scale) = 0;
00098     virtual void    setDetailLevel(uint32_t detail) = 0;
00099
00100 protected:
00101     ForceFieldPreview() {};
00102 };
00103
00104
00105 PX_POP_PACK
00106
00107 } // namespace apex
00108 } // namespace nvidia
00109
00110 #endif // FORCE_FIELD_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: FractureToolsAPI.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
FractureToolsAPI.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef FRACTURE_TOOLS_API_H
00031 #define FRACTURE_TOOLS_API_H
00032
00033 #include "foundation/Px.h"
00034 #include "ExplicitHierarchicalMesh.h"
00035 #include "FractureToolsStructs.h"
00036
00037 PX_PUSH_PACK_DEFAULT
00038
00039 namespace nvidia
00040 {
00041 namespace apex
00042 {
00043
00044 struct IntersectMesh;
00045 class DestructibleAsset;
00046
00048 class FractureToolsAPI
00049 {
00050 public:
00051
00053     virtual FractureTools::CutoutSet* createCutoutSet() = 0;
00054
00067     virtual void buildCutoutSet(FractureTools::CutoutSet& cutoutSet, const uint8_t* pixelBuffer, uint32_t bufferWidth, uint32_t bufferHeight, float snapThreshold, bool periodic) = 0;
00068
00077     virtual bool calculateCutoutUVMapping(const nvidia::ExplicitRenderTriangle& triangle, PxMat33& theMapping) = 0;
00078
00091     virtual bool calculateCutoutUVMapping(nvidia::ExplicitHierarchicalMesh& hMesh, const PxVec3& targetDirection, PxMat33& theMapping) = 0;
00092
00113     virtual bool    createVoronoiSplitMesh
00114     (
00115         nvidia::ExplicitHierarchicalMesh& hMesh,
00116         nvidia::ExplicitHierarchicalMesh& iHMeshCore,
00117         bool exportCoreMesh,
00118         int32_t coreMeshImprintSubmeshIndex,
00119         const FractureTools::MeshProcessingParameters& meshProcessingParams,
00120         const FractureTools::FractureVoronoiDesc& desc,
00121         const CollisionDesc& collisionDesc,
00122         uint32_t randomSeed,
00123         nvidia::IProgressListener& progressListener,
00124         volatile bool* cancel = NULL
00125     ) = 0;
00126
00143     virtual uint32_t    createVoronoiSitesInsideMesh
00144     (
00145         nvidia::ExplicitHierarchicalMesh& hMesh,
00146         PxVec3* siteBuffer,
00147         uint32_t* siteChunkIndices,
00148         uint32_t siteCount,
00149         uint32_t* randomSeed,
00150         uint32_t* microgridSize,
00151         BSPOpenMode::Enum meshMode,
00152         nvidia::IProgressListener& progressListener,
00153         uint32_t chunkIndex = 0xFFFFFFFF
00154     ) = 0;
00155
00180     virtual uint32_t    createScatterMeshSites
00181     (
00182         uint8_t*                        meshIndices,
00183         PxMat44*                        relativeTransforms,
00184         uint32_t*                       chunkMeshStarts,
00185         uint32_t                        scatterMeshInstancesBufferSize,
00186         nvidia::ExplicitHierarchicalMesh&   hMesh,
00187         uint32_t                        targetChunkCount,
00188         const uint16_t*                 targetChunkIndices,
00189         uint32_t*                       randomSeed,
00190         uint32_t                        scatterMeshAssetCount,
00191         nvidia::RenderMeshAsset**           scatterMeshAssets,
00192         const uint32_t*                 minCount,
00193         const uint32_t*                 maxCount,
00194         const float*                    minScales,
00195         const float*                    maxScales,
00196         const float*                    maxAngles
00197     ) = 0;
00198
00212     virtual void    visualizeVoronoiCells
00213     (
00214         nvidia::RenderDebugInterface& debugRender,
00215         const PxVec3* sites,
00216         uint32_t siteCount,
00217         const uint32_t* cellColors,
00218         uint32_t cellColorCount,
00219         const PxBounds3& bounds,
00220         uint32_t cellIndex = 0xFFFFFFFF
00221     ) = 0;
00222
00246     virtual bool buildExplicitHierarchicalMesh
00247     (
00248         nvidia::ExplicitHierarchicalMesh& iHMesh,
00249         const nvidia::ExplicitRenderTriangle* meshTriangles,
00250         uint32_t meshTriangleCount,
00251         const nvidia::ExplicitSubmeshData* submeshData,
00252         uint32_t submeshCount,
00253         uint32_t* meshPartition = NULL,
00254         uint32_t meshPartitionCount = 0,
00255         int32_t* parentIndices = NULL,
00256         uint32_t parentIndexCount = 0
00257     ) = 0;
00258
00268     virtual void setBSPTolerances
00269     (
00270         float linearTolerance,
00271         float angularTolerance,
00272         float baseTolerance,
00273         float clipTolerance,
00274         float cleaningTolerance
00275     ) = 0;
00276
00295     virtual void setBSPBuildParameters
00296     (
00297         float logAreaSigmaThreshold,
00298         uint32_t testSetSize,
00299         float splitWeight,
00300         float imbalanceWeight
00301     ) = 0;
00302
00303
00312     virtual bool buildExplicitHierarchicalMeshFromRenderMeshAsset(nvidia::ExplicitHierarchicalMesh& iHMesh, const nvidia::RenderMeshAsset& renderMeshAsset, uint32_t maxRootDepth = UINT32_MAX) = 0;
00313
00323     virtual bool buildExplicitHierarchicalMeshFromDestructibleAsset(nvidia::ExplicitHierarchicalMesh& iHMesh, const nvidia::DestructibleAsset& destructibleAsset, uint32_t maxRootDepth = UINT32_MAX) = 0;
00324
00344     virtual bool createHierarchicallySplitMesh
00345     (
00346         nvidia::ExplicitHierarchicalMesh& hMesh,
00347         nvidia::ExplicitHierarchicalMesh& iHMeshCore,
00348         bool exportCoreMesh,
00349         int32_t coreMeshImprintSubmeshIndex,
00350         const FractureTools::MeshProcessingParameters& meshProcessingParams,
00351         const FractureTools::FractureSliceDesc& desc,
00352         const CollisionDesc& collisionDesc,
00353         uint32_t randomSeed,
00354         nvidia::IProgressListener& progressListener,
00355         volatile bool* cancel = NULL
00356     ) = 0;
00357
00375     virtual bool createChippedMesh
00376     (
00377         nvidia::ExplicitHierarchicalMesh& hMesh,
00378         const FractureTools::MeshProcessingParameters& meshProcessingParams,
00379         const FractureTools::FractureCutoutDesc& desc,
00380         const FractureTools::CutoutSet& iCutoutSet,
00381         const FractureTools::FractureSliceDesc& sliceDesc,
00382         const FractureTools::FractureVoronoiDesc& voronoiDesc,
00383         const CollisionDesc& collisionDesc,
00384         uint32_t randomSeed,
00385         nvidia::IProgressListener& progressListener,
00386         volatile bool* cancel = NULL
00387     ) = 0;
00388
00405     virtual bool hierarchicallySplitChunk
00406     (
00407         nvidia::ExplicitHierarchicalMesh& hMesh,
00408         uint32_t chunkIndex,
00409         const FractureTools::MeshProcessingParameters& meshProcessingParams,
00410         const FractureTools::FractureSliceDesc& desc,
00411         const CollisionDesc& collisionDesc,
00412         uint32_t* randomSeed,
00413         nvidia::IProgressListener& progressListener,
00414         volatile bool* cancel = NULL
00415     ) = 0;
00416
00433     virtual bool voronoiSplitChunk
00434     (
00435         nvidia::ExplicitHierarchicalMesh& hMesh,
00436         uint32_t chunkIndex,
00437         const FractureTools::MeshProcessingParameters& meshProcessingParams,
00438         const FractureTools::FractureVoronoiDesc& desc,
00439         const CollisionDesc& collisionDesc,
00440         uint32_t* randomSeed,
00441         nvidia::IProgressListener& progressListener,
00442         volatile bool* cancel = NULL
00443     ) = 0;
00444
00449     virtual bool buildSliceMesh
00450     (
00451         nvidia::IntersectMesh& intersectMesh,
00452         nvidia::ExplicitHierarchicalMesh& referenceMesh,
00453         const PxPlane& slicePlane,
00454         const FractureTools::NoiseParameters& noiseParameters,
00455         uint32_t randomSeed
00456     ) = 0;
00457
00459     virtual nvidia::ExplicitHierarchicalMesh*   createExplicitHierarchicalMesh() = 0;
00460
00462     virtual nvidia::ExplicitHierarchicalMesh::ConvexHull*   createExplicitHierarchicalMeshConvexHull() = 0;
00463
00464 };
00465
00466 }} // namespaces
00467
00468
00469 PX_POP_PACK
00470
00471 #endif // FRACTURE_TOOLS_API_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: FractureToolsStructs.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
FractureToolsStructs.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef FRACTURE_TOOLS_STRUCTS_H
00030 #define FRACTURE_TOOLS_STRUCTS_H
00031
00032 #include "foundation/Px.h"
00033 #include "ExplicitHierarchicalMesh.h"
00034
00035 PX_PUSH_PACK_DEFAULT
00036
00037 namespace FractureTools
00038 {
00039
00043 struct MeshProcessingParameters
00044 {
00049     bool islandGeneration;
00050
00055     bool removeTJunctions;
00056
00063     unsigned microgridSize;
00064
00073     nvidia::BSPOpenMode::Enum meshMode;
00074
00079     int verbosity;
00080
00082     MeshProcessingParameters()
00083     {
00084         setToDefault();
00085     }
00086
00088     void    setToDefault()
00089     {
00090         islandGeneration = false;
00091         removeTJunctions = false;
00092         microgridSize = 65536;
00093         meshMode = nvidia::BSPOpenMode::Automatic;
00094         verbosity = 0;
00095     }
00096 };
00097
00098
00108 class CutoutSet
00109 {
00110 public:
00112     virtual uint32_t                getCutoutCount() const = 0;
00113
00118     virtual uint32_t                getCutoutVertexCount(uint32_t cutoutIndex) const = 0;
00119
00124     virtual uint32_t                getCutoutLoopCount(uint32_t cutoutIndex) const = 0;
00125
00130     virtual const physx::PxVec3&    getCutoutVertex(uint32_t cutoutIndex, uint32_t vertexIndex) const = 0;
00131
00136     virtual uint32_t                getCutoutLoopSize(uint32_t coutoutIndex, uint32_t loopIndex) const = 0;
00137
00143     virtual uint32_t                getCutoutLoopVertexIndex(uint32_t cutoutIndex, uint32_t loopIndex, uint32_t vertexNum) const = 0;
00144
00150     virtual uint32_t                getCutoutLoopVertexFlags(uint32_t cutoutIndex, uint32_t loopIndex, uint32_t vertexNum) const = 0;
00151
00155     virtual bool                    isPeriodic() const = 0;
00156
00160     virtual const physx::PxVec2&    getDimensions() const = 0;
00161
00163     //virtual void          serialize(physx::PxFileBuf& stream) const = 0;
00164     //virtual void          deserialize(physx::PxFileBuf& stream) = 0;
00165
00167     virtual void                    release() = 0;
00168
00169 protected:
00171     virtual                         ~CutoutSet() {}
00172 };
00173
00174
00179 struct NoiseParameters
00180 {
00184     float   amplitude;
00185
00190     float   frequency;
00191
00196     int     gridSize;
00197
00203     int     type;
00204
00206     NoiseParameters()
00207     {
00208         setToDefault();
00209     }
00210
00219     void    setToDefault()
00220     {
00221         amplitude = 0.0f;
00222         frequency = 0.25f;
00223         gridSize = 10;
00224         type = 0;
00225     }
00226 };
00227
00228
00234 struct SliceParameters
00235 {
00240     enum Order
00241     {
00242         XYZ,
00243         YZX,
00244         ZXY,
00245         ZYX,
00246         YXZ,
00247         XZY,
00248         Through
00249     };
00250
00252     unsigned order;
00253
00255     unsigned splitsPerPass[3];
00256
00263     float linearVariation[3];
00264
00270     float angularVariation[3];
00271
00273     NoiseParameters noise[3];
00274
00276     SliceParameters()
00277     {
00278         setToDefault();
00279     }
00280
00290     void    setToDefault()
00291     {
00292         order = XYZ;
00293         splitsPerPass[0] = splitsPerPass[1] = splitsPerPass[2] = 1;
00294         linearVariation[0] = linearVariation[1] = linearVariation[2] = 0.1f;
00295         angularVariation[0] = angularVariation[1] = angularVariation[2] = 20.0f * 3.1415927f / 180.0f;
00296         noise[0].setToDefault();
00297         noise[1].setToDefault();
00298         noise[2].setToDefault();
00299     }
00300 };
00301
00302
00308 struct FractureSliceDesc
00309 {
00311     unsigned                        maxDepth;
00312
00314     SliceParameters*                sliceParameters;
00315
00319     bool                            useTargetProportions;
00320
00328     float                           targetProportions[3];
00329
00336     float                           minimumChunkSize[3];
00337
00341     nvidia::FractureMaterialDesc    materialDesc[3];
00342
00346     bool                            instanceChunks;
00347
00351     bool                            useDisplacementMaps;
00352
00354     enum NoiseMode
00355     {
00356         NoiseWavePlane = 0,
00357         NoisePerlin2D,
00358         NoisePerlin3D,
00359
00360         NoiseModeCount
00361     };
00362
00366     unsigned            noiseMode;
00367
00369     FractureSliceDesc()
00370     {
00371         setToDefault();
00372     }
00373
00387     void    setToDefault()
00388     {
00389         maxDepth             = 0;
00390         sliceParameters      = NULL;
00391         useTargetProportions = false;
00392         for (int i = 0; i < 3; ++i)
00393         {
00394             targetProportions[i] = 1.0f;
00395             minimumChunkSize[i] = 0.0f;
00396             materialDesc[i].setToDefault();
00397         }
00398         instanceChunks       = false;
00399         useDisplacementMaps  = false;
00400         noiseMode            = NoiseWavePlane;
00401     }
00402 };
00403
00404
00410 struct CutoutParameters
00411 {
00416     float depth;
00417
00423     nvidia::FractureMaterialDesc materialDesc;
00424
00430     NoiseParameters backfaceNoise;
00431
00440     NoiseParameters edgeNoise;
00441
00443     CutoutParameters()
00444     {
00445         setToDefault();
00446     }
00447
00456     void    setToDefault()
00457     {
00458         depth = 1.0f;
00459         backfaceNoise.setToDefault();
00460         materialDesc.setToDefault();
00461         edgeNoise.setToDefault();
00462     }
00463 };
00464
00465
00471 struct FractureCutoutDesc
00472 {
00474     enum Directions
00475     {
00476         UserDefined = 0,    // If no flags are set, the cutout direction is taken from userDefinedDirection
00477
00478         NegativeX = 1 << 0,
00479         PositiveX = 1 << 1,
00480         NegativeY = 1 << 2,
00481         PositiveY = 1 << 3,
00482         NegativeZ = 1 << 4,
00483         PositiveZ = 1 << 5,
00484
00485         DirectionCount = 6
00486     };
00487
00489     unsigned directions;
00490
00495     unsigned directionOrder[DirectionCount];
00496
00498     CutoutParameters cutoutParameters[DirectionCount];
00499
00504     physx::PxVec3 userDefinedDirection;
00505
00507     physx::PxMat33 userUVMapping;
00508
00510     CutoutParameters userDefinedCutoutParameters;
00511
00513     enum InstancingMode
00514     {
00515         DoNotInstance,
00516         InstanceCongruentChunks,
00517         InstanceAllChunks,
00518
00519         InstanceModeCount
00520     };
00521
00525     unsigned instancingMode;
00526
00530     bool tileFractureMap;
00531
00535     physx::PxVec2 uvTileSize;
00536
00540     bool splitNonconvexRegions;
00541
00546     enum CutoutChunkFracturingMethod
00547     {
00548         DoNotFractureCutoutChunks,
00549         SliceFractureCutoutChunks,
00550         VoronoiFractureCutoutChunks,
00551
00552         CutoutChunkFracturingMethodCount
00553     };
00554
00563     unsigned chunkFracturingMethod;
00564
00572     bool trimFaceCollisionHulls;
00573
00575     float cutoutWidthScale[DirectionCount];
00576
00578     float cutoutHeightScale[DirectionCount];
00579
00581     float cutoutWidthOffset[DirectionCount];
00582
00584     float cutoutHeightOffset[DirectionCount];
00585
00587     bool cutoutWidthInvert[DirectionCount];
00588
00590     bool cutoutHeightInvert[DirectionCount];
00591
00593     float cutoutSizeX;
00594
00596     float cutoutSizeY;
00597
00604     float facetNormalMergeThresholdAngle;
00605
00607     FractureCutoutDesc()
00608     {
00609         setToDefault();
00610     }
00611
00638     void    setToDefault()
00639     {
00640         directions          = 0;
00641         userDefinedDirection= physx::PxVec3(0.0f);
00642         userUVMapping       = physx::PxMat33(physx::PxIdentity);
00643         userDefinedCutoutParameters.setToDefault();
00644         instancingMode      = DoNotInstance;
00645         tileFractureMap     = false;
00646         uvTileSize          = physx::PxVec2(0.0f);
00647         for (uint32_t i = 0; i < DirectionCount; ++i)
00648         {
00649             directionOrder[i]     = 1u << i;
00650             cutoutParameters[i].setToDefault();
00651             cutoutWidthScale[i]   = 1.0f;
00652             cutoutHeightScale[i]  = 1.0f;
00653             cutoutWidthOffset[i]  = 0.0f;
00654             cutoutHeightOffset[i] = 0.0f;
00655             cutoutWidthInvert[i]  = false;
00656             cutoutHeightInvert[i] = false;
00657         }
00658         cutoutSizeX                    = 1.0f;
00659         cutoutSizeY                    = 1.0f;
00660         facetNormalMergeThresholdAngle = 60.0f;
00661         splitNonconvexRegions          = false;
00662         chunkFracturingMethod          = DoNotFractureCutoutChunks;
00663         trimFaceCollisionHulls         = true;
00664     }
00665 };
00666
00667
00673 struct FractureVoronoiDesc
00674 {
00678     unsigned                siteCount;
00679
00683     const physx::PxVec3*    sites;
00684
00689     const uint32_t*         chunkIndices;
00690
00698     NoiseParameters         faceNoise;
00699
00703     bool                    instanceChunks;
00704
00708     bool                    useDisplacementMaps;
00709
00711     enum NoiseMode
00712     {
00713         NoiseWavePlane = 0,
00714         NoisePerlin2D,
00715         NoisePerlin3D,
00716
00717         NoiseModeCount
00718     };
00719
00723     unsigned                noiseMode;
00724
00731     float                   minimumChunkSize;
00732
00737     nvidia::FractureMaterialDesc    materialDesc;
00738
00739
00741     FractureVoronoiDesc()
00742     {
00743         setToDefault();
00744     }
00745
00759     void    setToDefault()
00760     {
00761         siteCount = 0;
00762         sites = NULL;
00763         chunkIndices = NULL;
00764         faceNoise.setToDefault();
00765         instanceChunks = false;
00766         useDisplacementMaps = false;
00767         noiseMode = NoiseWavePlane;
00768         minimumChunkSize = 0.0f;
00769         materialDesc.setToDefault();
00770     }
00771 };
00772
00773
00774 } // namespace FractureTools
00775
00776
00777 PX_POP_PACK
00778
00779 #endif // FRACTURE_TOOLS_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: GroundEmitterActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
GroundEmitterActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef GROUND_EMITTER_ACTOR_H
00031 #define GROUND_EMITTER_ACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class GroundEmitterAsset;
00044 class RenderVolume;
00045
00052 class MaterialLookupCallback
00053 {
00054 public:
00056     struct MaterialRequest
00057     {
00058         PxVec3      samplePosition;
00059         uint32_t    outMaterialID;
00060     };
00061
00067     virtual void requestMaterialLookups(uint32_t requestCount, MaterialRequest* reqList) = 0;
00068
00069     virtual ~MaterialLookupCallback() {}
00070 };
00071
00073 class GroundEmitterActor : public Actor
00074 {
00075 protected:
00076     virtual ~GroundEmitterActor() {}
00077
00078 public:
00082     virtual GroundEmitterAsset*     getEmitterAsset() const = 0;
00083
00087     virtual const PxMat44           getPose() const = 0;
00091     virtual void                    setPose(const PxMat44& pos) = 0;
00092
00094     virtual void                    setMaterialLookupCallback(MaterialLookupCallback*) = 0;
00095
00097     virtual MaterialLookupCallback* getMaterialLookupCallback() const = 0;
00098
00103     virtual void                    setAttachActor(PxActor*) = 0;
00104
00108     virtual void                    setAttachRelativePosition(const PxVec3& pos) = 0;
00109
00111     virtual const PxActor*          getAttachActor() const = 0;
00112
00114     virtual const PxVec3&           getAttachRelativePosition() const = 0;
00115
00116     /* Override some asset settings at run time */
00117
00119     virtual void                    setDensity(const float&) = 0;
00120
00122     virtual void                    setRadius(float) = 0;
00123
00125     virtual void                    setMaxRaycastsPerFrame(uint32_t) = 0;
00126
00128     virtual void                    setRaycastHeight(float) = 0;
00129
00136     virtual void                    setSpawnHeight(float) = 0;
00137
00139     virtual const float &           getDensity() const = 0;
00140
00142     virtual float                   getRadius() const = 0;
00143
00145     virtual uint32_t                getMaxRaycastsPerFrame() const = 0;
00146
00148     virtual float                   getRaycastHeight() const = 0;
00149
00155     virtual float                   getSpawnHeight() const = 0;
00156
00158     virtual void                    setRaycastCollisionGroups(uint32_t) = 0;
00159
00161     virtual void                    setRaycastCollisionGroupsMask(physx::PxFilterData*) = 0;
00162
00163
00165     virtual uint32_t                getRaycastCollisionGroups() const = 0;
00166
00169     virtual void                    setPreferredRenderVolume(RenderVolume* volume) = 0;
00170 };
00171
00172
00173 PX_POP_PACK
00174
00175 }
00176 } // end namespace nvidia
00177
00178 #endif // GROUND_EMITTER_ACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: GroundEmitterAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
GroundEmitterAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef GROUND_EMITTER_ASSET_H
00031 #define GROUND_EMITTER_ASSET_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define GROUND_EMITTER_AUTHORING_TYPE_NAME "GroundEmitterAsset"
00044
00046 class GroundEmitterAsset : public Asset
00047 {
00048 protected:
00049     PX_INLINE GroundEmitterAsset() {}
00050     virtual ~GroundEmitterAsset() {}
00051
00052 public:
00053
00055     virtual const PxVec3 &          getVelocityLow() const = 0;
00056
00058     virtual const PxVec3 &          getVelocityHigh() const = 0;
00059
00061     virtual const float &           getLifetimeLow() const = 0;
00062
00064     virtual const float &           getLifetimeHigh() const = 0;
00065
00067     virtual float                   getRadius() const = 0;
00068
00070     virtual uint32_t                getMaxRaycastsPerFrame() const = 0;
00071
00073     virtual float                   getRaycastHeight() const = 0;
00074
00080     virtual float                   getSpawnHeight() const = 0;
00081
00083     virtual const char*             getRaycastCollisionGroupMaskName() const = 0;
00084 };
00085
00087 class GroundEmitterAssetAuthoring : public AssetAuthoring
00088 {
00089 protected:
00090     virtual ~GroundEmitterAssetAuthoring() {}
00091 };
00092
00093
00094 PX_POP_PACK
00095
00096 }
00097 } // end namespace nvidia
00098
00099 #endif // GROUND_EMITTER_ASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: GroundEmitterPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
GroundEmitterPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef GROUND_EMITTER_PREVIEW_H
00031 #define GROUND_EMITTER_PREVIEW_H
00032
00033 #include "Apex.h"
00034 #include "AssetPreview.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041
00042 PX_PUSH_PACK_DEFAULT
00043
00045 class GroundEmitterPreview : public AssetPreview
00046 {
00047 public:
00049     virtual void    drawEmitterPreview() = 0;
00051     virtual void    setScale(float scale) = 0;
00052
00053 protected:
00054     GroundEmitterPreview() {}
00055 };
00056
00057
00058 PX_POP_PACK
00059
00060 }
00061 } // end namespace nvidia
00062
00063 #endif // GROUND_EMITTER_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: HeatSourceActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
HeatSourceActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef HEAT_SOURCE_ACTOR_H
00030 #define HEAT_SOURCE_ACTOR_H
00031
00032 #include "Apex.h"
00033 #include "Shape.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 class HeatSourceAsset;
00041
00042
00046 class HeatSourceActor : public Actor
00047 {
00048 protected:
00049     virtual ~HeatSourceActor() {}
00050
00051 public:
00053     virtual HeatSourceAsset*            getHeatSourceAsset() const = 0;
00054
00056     virtual void                        setEnabled(bool enable) = 0;
00057
00059     virtual bool                        isEnabled() const = 0;
00060
00062     virtual bool                        intersectAgainstAABB(PxBounds3) = 0;
00063
00065     virtual  Shape*                     getShape() const = 0;
00066
00068     virtual BoxShape*                   getBoxShape() = 0;
00069
00071     virtual SphereShape*                getSphereShape() = 0;
00072
00074     virtual float                       getAverageTemperature() const = 0;
00075
00077     virtual float                       getStdTemperature() const = 0;
00078
00080     virtual PxMat44                     getPose() const = 0;
00081
00083     virtual void                        setTemperature(float averageTemperature, float stdTemperature) = 0;
00084
00086     virtual void                        setPose(PxMat44 pose) = 0;
00087
00089     virtual void                        setCurrentScale(float scale) = 0;
00090
00092     virtual float                       getCurrentScale(void) const = 0;
00093
00094     virtual void                        release() = 0;
00095 };
00096
00097
00098 }
00099 } // end namespace nvidia
00100
00101 #endif
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: HeatSourceAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
HeatSourceAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef HEAT_SOURCE_ASSET_H
00030 #define HEAT_SOURCE_ASSET_H
00031
00032 #include "Apex.h"
00033 #include "CustomBufferIterator.h"
00034
00035 #define HEAT_SOURCE_AUTHORING_TYPE_NAME "HeatSourceAsset"
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00042 class TurbulenceFSActorParams;
00043 class TurbulenceFSActor;
00044 class TurbulenceFSPreview;
00045
00049 class HeatSourceAsset : public Asset
00050 {
00051 protected:
00052     virtual ~HeatSourceAsset() {}
00053 };
00054
00055
00059 class HeatSourceAssetAuthoring : public AssetAuthoring
00060 {
00061 protected:
00062     virtual ~HeatSourceAssetAuthoring() {}
00063 };
00064
00065
00066 }
00067 } // end namespace nvidia
00068
00069 #endif // HEAT_SOURCE_ASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: HeatSourcePreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
HeatSourcePreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef HEAT_SOURCE_PREVIEW_H
00030 #define HEAT_SOURCE_PREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00045 class HeatSourcePreview : public AssetPreview
00046 {
00047 public:
00048     public:
00050     virtual void    drawHeatSourcePreview() = 0;
00052     virtual void    setScale(float scale) = 0;
00053
00054 protected:
00055     HeatSourcePreview() {}
00056 };
00057
00058
00059 PX_POP_PACK
00060
00061 }
00062 } // namespace nvidia
00063
00064 #endif // HEAT_SOURCE_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: IProgressListener.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
IProgressListener.h File Reference

class IProgressListener More...

#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

class | nvidia::apex::IProgressListener
User-provided class for following the progress of a task. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class IProgressListener

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: IProgressListener.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
IProgressListener.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IPROGRESS_LISTENER_H
00031 #define IPROGRESS_LISTENER_H
00032
00038 #include "ApexUsingNamespace.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 PX_PUSH_PACK_DEFAULT
00046
00048 class IProgressListener
00049 {
00050 public:
00052     virtual void    setProgress(int progress, const char* taskName = NULL) = 0;
00053 };
00054
00055 PX_POP_PACK
00056
00057 }
00058 } // end namespace nvidia::apex
00059
00060 #endif // IPROGRESS_LISTENER_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ImpactEmitterActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ImpactEmitterActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IMPACT_EMITTER_ACTOR_H
00031 #define IMPACT_EMITTER_ACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class ImpactEmitterAsset;
00044 class RenderVolume;
00045
00047 class ImpactEmitterActor : public Actor
00048 {
00049 protected:
00050     virtual ~ImpactEmitterActor() {}
00051
00052 public:
00054     virtual ImpactEmitterAsset*     getEmitterAsset() const = 0;
00055
00065     virtual void registerImpact(const PxVec3& hitPos, const PxVec3& hitDir, const PxVec3& surfNorm, uint32_t setID) = 0;
00066
00069     virtual void setPreferredRenderVolume(RenderVolume* volume) = 0;
00070 };
00071
00072
00073 PX_POP_PACK
00074
00075 }
00076 } // end namespace nvidia
00077
00078 #endif // IMPACT_EMITTER_ACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ImpactEmitterAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ImpactEmitterAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IMPACT_EMITTER_ASSET_H
00031 #define IMPACT_EMITTER_ASSET_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define IMPACT_EMITTER_AUTHORING_TYPE_NAME "ImpactEmitterAsset"
00044
00045 class ImpactEmitterActor;
00046
00048 class ImpactEmitterAsset : public Asset
00049 {
00050 protected:
00051     PX_INLINE ImpactEmitterAsset() {}
00052     virtual ~ImpactEmitterAsset() {}
00053
00054 public:
00056     virtual uint32_t            querySetID(const char* setName) = 0;
00057
00063     virtual void                getSetNames(const char** inOutSetNames, uint32_t& nameCount) const = 0;
00064 };
00065
00067 class ImpactEmitterAssetAuthoring : public AssetAuthoring
00068 {
00069 protected:
00070     virtual ~ImpactEmitterAssetAuthoring() {}
00071
00072 public:
00073 };
00074
00075
00076 PX_POP_PACK
00077
00078 }
00079 } // end namespace nvidia
00080
00081 #endif // IMPACT_EMITTER_ASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ImpactEmitterPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ImpactEmitterPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IMPACT_EMITTER_PREVIEW_H
00031 #define IMPACT_EMITTER_PREVIEW_H
00032
00033 #include "Apex.h"
00034 #include "AssetPreview.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041
00042 PX_PUSH_PACK_DEFAULT
00043
00045 class ImpactEmitterPreview : public AssetPreview
00046 {
00047 public:
00048     /* No need to add any functionality here */
00049
00050 protected:
00051     ImpactEmitterPreview() {}
00052 };
00053
00054
00055 PX_POP_PACK
00056
00057 }
00058 } // end namespace nvidia
00059
00060 #endif // IMPACT_EMITTER_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: IofxActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
IofxActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IOFX_ACTOR_H
00031 #define IOFX_ACTOR_H
00032
00033 #include "Apex.h"
00034 #include "IofxAsset.h"
00035 #include "IofxRenderable.h"
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00042 PX_PUSH_PACK_DEFAULT
00043
00047 class IofxActor : public Actor
00048 {
00049 public:
00051     virtual float               getObjectRadius() const = 0;
00052
00054     virtual uint32_t            getObjectCount() const = 0;
00055
00057     virtual uint32_t            getVisibleCount() const = 0;
00058
00060     virtual const char*         getIosAssetName() const = 0;
00061
00063     virtual physx::PxBounds3    getBounds() const = 0;
00064
00071     virtual IofxRenderable*     acquireRenderableReference() = 0;
00072 };
00073
00074 PX_POP_PACK
00075
00076 }
00077 } // namespace nvidia
00078
00079 #endif // IOFX_ACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: IofxAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
IofxAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IOFX_ASSET_H
00031 #define IOFX_ASSET_H
00032
00033 #include "Apex.h"
00034 #include "ModifierDefs.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define IOFX_AUTHORING_TYPE_NAME "IOFX"
00044
00045 class Modifier;
00046 class ApexActor;
00047
00052 class IofxAsset : public Asset, public Context
00053 {
00054 public:
00056     virtual const char*                     getSpriteMaterialName() const = 0;
00057
00059     virtual uint32_t                        getMeshAssetCount() const = 0;
00060
00063     virtual const char*                     getMeshAssetName(uint32_t index = 0) const = 0;
00064
00067     virtual uint32_t                        getMeshAssetWeight(uint32_t index = 0) const = 0;
00068
00070     virtual const Modifier*                 getSpawnModifiers(uint32_t& outCount) const = 0;
00071
00073     virtual const Modifier*                 getContinuousModifiers(uint32_t& outCount) const = 0;
00074
00078     virtual float                           getScaleUpperBound(float maxVelocity) const = 0;
00079
00082     virtual void                            addDependentActor(ApexActor* actor) = 0;
00083 };
00084
00088 class IofxAssetAuthoring : public AssetAuthoring
00089 {
00090 };
00091
00092 PX_POP_PACK
00093
00094 }
00095 } // namespace nvidia
00096
00097 #endif // IOFX_ASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: IofxRenderCallback.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
IofxRenderCallback.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IOFX_RENDER_CALLBACK_H
00031 #define IOFX_RENDER_CALLBACK_H
00032
00033 #include "foundation/Px.h"
00034 #include "UserRenderCallback.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class IofxRenderable;
00044 class IofxSpriteRenderable;
00045 class IofxMeshRenderable;
00046
00050 struct IofxRenderSemantic
00051 {
00055     enum Enum
00056     {
00057         POSITION = 0,
00058         COLOR,
00059         VELOCITY,
00060         SCALE,
00061         LIFE_REMAIN,
00062         DENSITY,
00063         SUBTEXTURE,
00064         ORIENTATION,
00065         ROTATION,
00066         USER_DATA,
00067
00068         NUM_SEMANTICS
00069     };
00070 };
00071
00072
00076 struct IofxSpriteRenderLayoutElement
00077 {
00081     enum Enum
00082     {
00083         POSITION_FLOAT3,
00084         COLOR_RGBA8,
00085         COLOR_BGRA8,
00086         COLOR_FLOAT4,
00087         VELOCITY_FLOAT3,
00088         SCALE_FLOAT2,
00089         LIFE_REMAIN_FLOAT1,
00090         DENSITY_FLOAT1,
00091         SUBTEXTURE_FLOAT1,
00092         ORIENTATION_FLOAT1,
00093         USER_DATA_UINT1,
00094
00095         MAX_COUNT
00096     };
00097
00101     static PX_INLINE RenderDataFormat::Enum getFormat(Enum element)
00102     {
00103         switch (element)
00104         {
00105         case POSITION_FLOAT3:
00106             return RenderDataFormat::FLOAT3;
00107         case COLOR_RGBA8:
00108             return RenderDataFormat::R8G8B8A8;
00109         case COLOR_BGRA8:
00110             return RenderDataFormat::B8G8R8A8;
00111         case COLOR_FLOAT4:
00112             return RenderDataFormat::FLOAT4;
00113         case VELOCITY_FLOAT3:
00114             return RenderDataFormat::FLOAT3;
00115         case SCALE_FLOAT2:
00116             return RenderDataFormat::FLOAT2;
00117         case LIFE_REMAIN_FLOAT1:
00118             return RenderDataFormat::FLOAT1;
00119         case DENSITY_FLOAT1:
00120             return RenderDataFormat::FLOAT1;
00121         case SUBTEXTURE_FLOAT1:
00122             return RenderDataFormat::FLOAT1;
00123         case ORIENTATION_FLOAT1:
00124             return RenderDataFormat::FLOAT1;
00125         case USER_DATA_UINT1:
00126             return RenderDataFormat::UINT1;
00127         default:
00128             PX_ALWAYS_ASSERT();
00129             return RenderDataFormat::NUM_FORMATS;
00130         }
00131     }
00132 };
00133
00137 struct IofxSpriteRenderLayoutSurfaceElement
00138 {
00142     enum Enum
00143     {
00144         POSITION_FLOAT4,
00145         SCALE_ORIENT_SUBTEX_FLOAT4,
00146         COLOR_RGBA8, //<! COLOR in RGBA8 format
00147         COLOR_BGRA8, //<! COLOR in BGRA8 format
00148         COLOR_FLOAT4, //<! COLOR in FLOAT4 format
00149
00150         MAX_COUNT
00151     };
00152
00156     static PX_INLINE RenderDataFormat::Enum getFormat(Enum element)
00157     {
00158         switch (element)
00159         {
00160         case POSITION_FLOAT4:
00161             return RenderDataFormat::FLOAT4;
00162         case SCALE_ORIENT_SUBTEX_FLOAT4:
00163             return RenderDataFormat::FLOAT4;
00164         case COLOR_RGBA8:
00165             return RenderDataFormat::R8G8B8A8;
00166         case COLOR_BGRA8:
00167             return RenderDataFormat::B8G8R8A8;
00168         case COLOR_FLOAT4:
00169             return RenderDataFormat::R32G32B32A32_FLOAT;
00170         default:
00171             PX_ALWAYS_ASSERT();
00172             return RenderDataFormat::NUM_FORMATS;
00173         }
00174     }
00175 };
00176
00180 struct IofxSpriteRenderLayout
00181 {
00182     IofxSpriteRenderLayout(void)
00183     {
00184         setDefaults();
00185     }
00186
00190     void setDefaults()
00191     {
00192         bufferDesc.setDefaults();
00193         for (uint32_t i = 0; i < IofxSpriteRenderLayoutElement::MAX_COUNT; i++)
00194         {
00195             offsets[i] = uint32_t(-1);
00196         }
00197         stride = 0;
00198         surfaceCount = 0;
00199         for (uint32_t i = 0; i < MAX_SURFACE_COUNT; i++)
00200         {
00201             surfaceElements[i] = IofxSpriteRenderLayoutSurfaceElement::MAX_COUNT;
00202         }
00203     }
00204
00208     bool isValid(void) const
00209     {
00210         uint32_t numFailed = 0;
00211
00212         numFailed += (surfaceCount == 0) && !bufferDesc.isValid();
00213         numFailed += (surfaceCount == 0) && (stride == 0);
00214         numFailed += (surfaceCount == 0) && (offsets[IofxSpriteRenderLayoutElement::POSITION_FLOAT3] == uint32_t(-1));
00215
00216         numFailed += ((stride & 0x03) != 0);
00217         for (uint32_t i = 0; i < IofxSpriteRenderLayoutElement::MAX_COUNT; i++)
00218         {
00219             if (offsets[i] != static_cast<uint32_t>(-1))
00220             {
00221                 numFailed += (offsets[i] >= stride);
00222                 numFailed += ((offsets[i] & 0x03) != 0);
00223             }
00224         }
00225         for (uint32_t i= 0; i < surfaceCount; ++i)
00226         {
00227             numFailed += (surfaceElements[i] >= IofxSpriteRenderLayoutSurfaceElement::MAX_COUNT);
00228             numFailed += !surfaceDescs[i].isValid();
00229             numFailed += (surfaceDescs[i].width == 0) || (surfaceDescs[i].height == 0);
00230             numFailed += (IofxSpriteRenderLayoutSurfaceElement::getFormat(surfaceElements[i]) != surfaceDescs[i].format);
00231         }
00232
00233         return (numFailed == 0);
00234     }
00235
00239     bool isTheSameAs(const IofxSpriteRenderLayout& other) const
00240     {
00241         if (surfaceCount != other.surfaceCount) return false;
00242         if (surfaceCount == 0)
00243         {
00244             if (!bufferDesc.isTheSameAs(other.bufferDesc)) return false;
00245             if (stride != other.stride) return false;
00246             for (uint32_t i = 0; i < IofxSpriteRenderLayoutElement::MAX_COUNT; i++)
00247             {
00248                 if (offsets[i] != other.offsets[i]) return false;
00249             }
00250         }
00251         else
00252         {
00253             for (uint32_t i = 0; i < surfaceCount; ++i)
00254             {
00255                 if (surfaceElements[i] != other.surfaceElements[i]) return false;
00256                 if (!surfaceDescs[i].isTheSameAs(other.surfaceDescs[i])) return false;
00257             }
00258         }
00259         return true;
00260     }
00261
00262 public:
00263     UserRenderBufferDesc        bufferDesc;
00264
00268     uint32_t                    offsets[IofxSpriteRenderLayoutElement::MAX_COUNT];
00269     uint32_t                    stride;
00270
00271     uint32_t                    surfaceCount;
00272
00276     static const uint32_t MAX_SURFACE_COUNT = 4;
00277
00281     IofxSpriteRenderLayoutSurfaceElement::Enum  surfaceElements[MAX_SURFACE_COUNT];
00285     UserRenderSurfaceDesc                           surfaceDescs[MAX_SURFACE_COUNT];
00286 };
00287
00288
00292 struct IofxMeshRenderLayoutElement
00293 {
00297     enum Enum
00298     {
00299         POSITION_FLOAT3,
00300         ROTATION_SCALE_FLOAT3x3,
00301         POSE_FLOAT3x4,
00302         VELOCITY_LIFE_FLOAT4,
00303         DENSITY_FLOAT1,
00304         COLOR_RGBA8,
00305         COLOR_BGRA8,
00306         COLOR_FLOAT4,
00307         USER_DATA_UINT1,
00308
00309         MAX_COUNT
00310     };
00311
00315     static PX_INLINE RenderDataFormat::Enum getFormat(Enum element)
00316     {
00317         switch (element)
00318         {
00319         case POSITION_FLOAT3:
00320             return RenderDataFormat::FLOAT3;
00321         case ROTATION_SCALE_FLOAT3x3:
00322             return RenderDataFormat::FLOAT3x3;
00323         case POSE_FLOAT3x4:
00324             return RenderDataFormat::FLOAT3x4;
00325         case VELOCITY_LIFE_FLOAT4:
00326             return RenderDataFormat::FLOAT4;
00327         case DENSITY_FLOAT1:
00328             return RenderDataFormat::FLOAT1;
00329         case COLOR_RGBA8:
00330             return RenderDataFormat::R8G8B8A8;
00331         case COLOR_BGRA8:
00332             return RenderDataFormat::B8G8R8A8;
00333         case COLOR_FLOAT4:
00334             return RenderDataFormat::FLOAT4;
00335         case USER_DATA_UINT1:
00336             return RenderDataFormat::UINT1;
00337         default:
00338             PX_ALWAYS_ASSERT();
00339             return RenderDataFormat::NUM_FORMATS;
00340         }
00341     }
00342 };
00343
00347 struct IofxMeshRenderLayout
00348 {
00349     IofxMeshRenderLayout(void)
00350     {
00351         setDefaults();
00352     }
00353
00357     void setDefaults()
00358     {
00359         bufferDesc.setDefaults();
00360         for (uint32_t i = 0; i < IofxMeshRenderLayoutElement::MAX_COUNT; i++)
00361         {
00362             offsets[i] = uint32_t(-1);
00363         }
00364         stride = 0;
00365     }
00366
00370     bool isValid(void) const
00371     {
00372         uint32_t numFailed = 0;
00373
00374         numFailed += !bufferDesc.isValid();
00375         numFailed += (stride == 0);
00376         numFailed += (offsets[IofxMeshRenderLayoutElement::POSITION_FLOAT3] == uint32_t(-1))
00377             && (offsets[IofxMeshRenderLayoutElement::POSE_FLOAT3x4] == uint32_t(-1));
00378
00379         numFailed += ((stride & 0x03) != 0);
00380         for (uint32_t i = 0; i < IofxMeshRenderLayoutElement::MAX_COUNT; i++)
00381         {
00382             if (offsets[i] != static_cast<uint32_t>(-1))
00383             {
00384                 numFailed += (offsets[i] >= stride);
00385                 numFailed += ((offsets[i] & 0x03) != 0);
00386             }
00387         }
00388
00389         return (numFailed == 0);
00390     }
00391
00395     bool isTheSameAs(const IofxMeshRenderLayout& other) const
00396     {
00397         if (!bufferDesc.isTheSameAs(other.bufferDesc)) return false;
00398         if (stride != other.stride) return false;
00399         for (uint32_t i = 0; i < IofxMeshRenderLayoutElement::MAX_COUNT; i++)
00400         {
00401             if (offsets[i] != other.offsets[i]) return false;
00402         }
00403         return true;
00404     }
00405
00406 public:
00407     UserRenderBufferDesc        bufferDesc;
00408
00412     uint32_t                    offsets[IofxMeshRenderLayoutElement::MAX_COUNT];
00413     uint32_t                    stride;
00414 };
00415
00416
00420 class IofxRenderCallback : public UserRenderCallback
00421 {
00422 public:
00426     virtual void onCreatedIofxRenderable(IofxRenderable& ) {}
00427
00431     virtual void onUpdatedIofxRenderable(IofxRenderable& ) {}
00432
00436     virtual void onReleasingIofxRenderable(IofxRenderable& ) {}
00437
00445     virtual bool getIofxSpriteRenderLayout(IofxSpriteRenderLayout& spriteRenderLayout, uint32_t spriteCount, uint32_t spriteSemanticsBitmap, RenderInteropFlags::Enum interopFlags)
00446     {
00447         PX_UNUSED(spriteRenderLayout);
00448         PX_UNUSED(spriteCount);
00449         PX_UNUSED(spriteSemanticsBitmap);
00450         PX_UNUSED(interopFlags);
00451         return false;
00452     }
00453
00461     virtual bool getIofxMeshRenderLayout(IofxMeshRenderLayout& meshRenderLayout, uint32_t meshCount, uint32_t meshSemanticsBitmap, RenderInteropFlags::Enum interopFlags)
00462     {
00463         PX_UNUSED(meshRenderLayout);
00464         PX_UNUSED(meshCount);
00465         PX_UNUSED(meshSemanticsBitmap);
00466         PX_UNUSED(interopFlags);
00467         return false;
00468     }
00469
00470 };
00471
00472 PX_POP_PACK
00473
00474 }
00475 } // end namespace nvidia
00476
00477 #endif // IOFX_RENDER_CALLBACK_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: IofxRenderable.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
IofxRenderable.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IOFX_RENDERABLE_H
00031 #define IOFX_RENDERABLE_H
00032
00033 #include "foundation/Px.h"
00034 #include "ApexInterface.h"
00035 #include "Renderable.h"
00036 #include "IofxRenderCallback.h"
00037
00038 namespace nvidia
00039 {
00040 namespace apex
00041 {
00042
00043 PX_PUSH_PACK_DEFAULT
00044
00048 struct IofxSharedRenderData
00049 {
00050     uint32_t    maxObjectCount;
00051     uint32_t    activeObjectCount;
00052 };
00053
00057 struct IofxSpriteSharedRenderData : IofxSharedRenderData
00058 {
00059     IofxSpriteRenderLayout  spriteRenderLayout;
00060     UserRenderBuffer*           spriteRenderBuffer;
00061     UserRenderSurface*      spriteRenderSurfaces[IofxSpriteRenderLayout::MAX_SURFACE_COUNT];
00062 };
00063
00067 struct IofxMeshSharedRenderData : IofxSharedRenderData
00068 {
00069     IofxMeshRenderLayout        meshRenderLayout;
00070     UserRenderBuffer*           meshRenderBuffer;
00071 };
00072
00076 struct IofxCommonRenderData
00077 {
00078     uint32_t        startIndex;
00079     uint32_t        objectCount;
00080
00081     const char*     renderResourceNameSpace;
00082     const char*     renderResourceName;
00083     void*           renderResource;
00084 };
00085
00089 struct IofxSpriteRenderData : IofxCommonRenderData
00090 {
00091     uint32_t        visibleCount;
00092
00093     const IofxSpriteSharedRenderData* sharedRenderData;
00094 };
00095
00099 struct IofxMeshRenderData : IofxCommonRenderData
00100 {
00101     const IofxMeshSharedRenderData* sharedRenderData;
00102 };
00103
00104 class IofxSpriteRenderable;
00105 class IofxMeshRenderable;
00106
00111 class IofxRenderable : public ApexInterface
00112 {
00113 public:
00117     enum Type
00118     {
00119         SPRITE,
00120         MESH
00121     };
00122
00126     virtual Type                        getType() const = 0;
00127
00131     virtual const IofxSpriteRenderData* getSpriteRenderData() const = 0;
00132
00136     virtual const IofxMeshRenderData*   getMeshRenderData() const = 0;
00137
00141     virtual const physx::PxBounds3&     getBounds() const = 0;
00142
00143 protected:
00144     virtual ~IofxRenderable() {}
00145
00146 };
00147
00148 PX_POP_PACK
00149
00150 }
00151 } // end namespace nvidia
00152
00153 #endif // IOFX_RENDERABLE_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: IosAsset.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
IosAsset.h File Reference

class IosAsset More...

#include "Asset.h"

Go to the source code of this file.

Classes

class | nvidia::apex::IosAsset
The base class of all Instanced Object Simulation classes. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class IosAsset

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: IosAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
IosAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IOS_ASSET_H
00031 #define IOS_ASSET_H
00032
00038 #include "Asset.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 class Scene;
00046 class Actor;
00047
00048 class IofxAsset;
00049
00050 PX_PUSH_PACK_DEFAULT
00051
00055 class IosAsset : public Asset
00056 {
00057 public:
00059     virtual Actor*              createIosActor(Scene& scene, IofxAsset* iofxAsset) = 0;
00061     virtual void                releaseIosActor(Actor& actor) = 0;
00063     virtual bool                getSupportsDensity() const = 0;
00064 };
00065
00066 PX_POP_PACK
00067
00068 }
00069 } // end namespace nvidia::apex
00070
00071 #endif // IOS_ASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: JetFSActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
JetFSActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef JET_FSACTOR_H
00031 #define JET_FSACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class BasicFSAsset;
00043
00044
00048 class JetFSActor : public Actor, public Renderable
00049 {
00050 protected:
00051     virtual ~JetFSActor() {}
00052
00053 public:
00054
00058     virtual BasicFSAsset*       getJetFSAsset() const = 0;
00059
00063     virtual PxMat44             getCurrentPose() const = 0;
00064
00068     virtual void                setCurrentPose(const PxTransform& pose) = 0;
00069
00073     virtual PxVec3              getCurrentPosition() const = 0;
00074
00078     virtual void                setCurrentPosition(const PxVec3& pos) = 0;
00079
00083     virtual float               getCurrentScale() const = 0;
00084
00088     virtual void                setCurrentScale(const float& scale) = 0;
00089
00093     virtual void                setFieldStrength(float) = 0;
00094
00098     virtual void                setFieldDirection(const PxVec3&) = 0;
00099
00103     virtual void                setEnabled(bool isEnabled) = 0;
00104
00105 };
00106
00107 PX_POP_PACK
00108
00109 }
00110 } // end namespace nvidia::apex
00111
00112 #endif // JET_FSACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: JetFSPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
JetFSPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef JET_FSPREVIEW_H
00030 #define JET_FSPREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class RenderDebugInterface;
00043
00052 namespace APEX_JET
00053 {
00058 static const uint32_t JET_DRAW_NOTHING = 0x00;
00063 static const uint32_t JET_DRAW_SHAPE = 0x01;
00069 static const uint32_t JET_DRAW_ASSET_INFO = 0x02;
00074 static const uint32_t JET_DRAW_FULL_DETAIL = (JET_DRAW_SHAPE + JET_DRAW_ASSET_INFO);
00075 }
00076
00081 class JetFSPreview : public AssetPreview
00082 {
00083 public:
00094     virtual void    setDetailLevel(uint32_t detail) = 0;
00095 };
00096
00097
00098 PX_POP_PACK
00099
00100 }
00101 } // namespace nvidia
00102
00103 #endif // JET_FSPREVIEW_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: Lock.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Defines
Lock.h File Reference

classes PxSceneReadLock, PxSceneWriteLock More...

#include "ApexInterface.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ReadLock
RAII wrapper for the Scene read lock. More...
class | nvidia::apex::WriteLock
RAII wrapper for the Scene write lock. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Defines

#define | WRITE_LOCK(LOCKABLE) nvidia::apex::WriteLock __WriteLock(LOCKABLE, __FILE__, __LINE__);
Lock an object for writing by the current thread for the duration of the enclosing scope.
#define | READ_LOCK(LOCKABLE) nvidia::apex::ReadLock __ReadLock(LOCKABLE, __FILE__, __LINE__);
Lock an object for reading by the current thread for the duration of the enclosing scope.

Detailed Description

classes PxSceneReadLock, PxSceneWriteLock

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Lock.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Lock.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 // Copyright (c) 2004-2008 AGEIA Technologies, Inc. All rights reserved.
00030 // Copyright (c) 2001-2004 NovodeX AG. All rights reserved.
00031
00032
00033 #ifndef LOCK_H
00034 #define LOCK_H
00035
00041 #include "ApexInterface.h"
00042
00043 namespace nvidia
00044 {
00045 namespace apex
00046 {
00047
00058 class ReadLock
00059 {
00060     ReadLock(const ReadLock&);
00061     ReadLock& operator=(const ReadLock&);
00062
00063 public:
00064
00071     ReadLock(const ApexInterface& lockable, const char* file=NULL, uint32_t line=0)
00072         : mLockable(lockable)
00073     {
00074         mLockable.acquireReadLock(file, line);
00075     }
00076
00077     ~ReadLock()
00078     {
00079         mLockable.releaseReadLock();
00080     }
00081
00082 private:
00083
00084     const ApexInterface& mLockable;
00085 };
00086
00097 class WriteLock
00098 {
00099     WriteLock(const WriteLock&);
00100     WriteLock& operator=(const WriteLock&);
00101
00102 public:
00103
00110     WriteLock(const ApexInterface& lockable, const char* file=NULL, uint32_t line=0)
00111         : mLockable(lockable)
00112     {
00113         mLockable.acquireWriteLock(file, line);
00114     }
00115
00116     ~WriteLock()
00117     {
00118         mLockable.releaseWriteLock();
00119     }
00120
00121 private:
00122     const ApexInterface& mLockable;
00123 };
00124
00125
00126 } // namespace apex
00127 } // namespace nvidia
00128
00132 #define WRITE_LOCK(LOCKABLE) nvidia::apex::WriteLock __WriteLock(LOCKABLE, __FILE__, __LINE__);
00133
00136 #define READ_LOCK(LOCKABLE) nvidia::apex::ReadLock __ReadLock(LOCKABLE, __FILE__, __LINE__);
00137
00139 #endif
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: MirrorScene.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
MirrorScene.h File Reference

classes MirrorScene, MirrorScene::MirrorFilter More...

#include "ApexDefs.h"
#include "ApexUsingNamespace.h"
#include "foundation/PxPreprocessor.h"

Go to the source code of this file.

Classes

class | nvidia::apex::MirrorScene
MirrorScene is used to create a selected mirrored copy of a primary scene. Works only with PhysX 3.x. More...
class | nvidia::apex::MirrorScene::MirrorFilter
MirrorFilter is a callback interface implemented by the application to confirm which actors and shapes are, or are not, replicated into the mirrored scene. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

classes MirrorScene, MirrorScene::MirrorFilter

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: MirrorScene.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
MirrorScene.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MIRROR_SCENE_H
00031
00032 #define MIRROR_SCENE_H
00033
00039 #include "ApexDefs.h"
00040 #include "ApexUsingNamespace.h"
00041 #include "foundation/PxPreprocessor.h"
00042
00043
00044 namespace nvidia
00045 {
00046     namespace apex
00047     {
00048
00052         class MirrorScene
00053         {
00054         public:
00058             class MirrorFilter
00059             {
00060             public:
00066                 virtual bool shouldMirror(const PxActor &actor) = 0;
00067
00073                 virtual bool shouldMirror(const PxShape &shape) = 0;
00074
00080                 virtual void reviseMirrorShape(physx::PxShape &shape) = 0;
00081
00087                 virtual void reviseMirrorActor(physx::PxActor &actor) = 0;
00088             };
00089
00096             virtual void synchronizePrimaryScene(const PxVec3 &cameraPos) = 0;
00097
00104             virtual void synchronizeMirrorScene(void) = 0;
00105
00110             virtual void release(void) = 0;
00111
00112         };
00113
00114     }; // end of apex namespace
00115 }; // end of physx namespace
00116
00117 #endif
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: Modifier.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Modifier.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODIFIER_H
00031 #define MODIFIER_H
00032
00033 #include "Apex.h"
00034 #include "Curve.h"
00035 #include "IofxAsset.h"
00036 #include "IofxRenderCallback.h"
00037
00038 #include "ModifierDefs.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 PX_PUSH_PACK_DEFAULT
00046
00048 inline uint32_t ModifierUsageFromStage(ModifierStage stage)
00049 {
00050     return 1u << stage;
00051 }
00052
00053 // Disable the unused arguments warning for this header.
00054 #pragma warning( disable: 4100 )
00055
00062 class Modifier
00063 {
00064 public:
00065
00067     virtual ModifierTypeEnum getModifierType() const = 0;
00068
00070     virtual uint32_t getModifierUsage() const = 0;
00071
00073     virtual uint32_t getModifierSpriteSemantics()
00074     {
00075         return 0;
00076     }
00077
00079     virtual uint32_t getModifierMeshSemantics()
00080     {
00081         return 0;
00082     }
00083
00084     virtual ~Modifier() { }
00085
00086 };
00087
00094 template <typename T>
00095 class ModifierT : public Modifier
00096 {
00097 public:
00098
00100     virtual ModifierTypeEnum getModifierType() const
00101     {
00102         return T::ModifierType;
00103     }
00104
00106     virtual uint32_t getModifierUsage() const
00107     {
00108         return T::ModifierUsage;
00109     }
00110 };
00111
00112
00116 class RotationModifier : public ModifierT<RotationModifier>
00117 {
00118 public:
00119
00121     static const ModifierTypeEnum ModifierType = ModifierType_Rotation;
00122
00124     static const uint32_t ModifierUsage = ModifierUsage_Spawn | ModifierUsage_Continuous
00125             | ModifierUsage_Mesh;
00126
00127
00129     virtual ApexMeshParticleRollType::Enum getRollType() const = 0;
00130
00132     virtual void setRollType(ApexMeshParticleRollType::Enum rollType) = 0;
00133
00135     virtual float getMaxSettleRate() const = 0;
00136
00138     virtual void setMaxSettleRate(float settleRate) = 0;
00139
00141     virtual float getMaxRotationRate() const = 0;
00142
00144     virtual void setMaxRotationRate(float rotationRate) = 0;
00145
00146 };
00147
00152 class SimpleScaleModifier : public ModifierT<SimpleScaleModifier>
00153 {
00154 public:
00155
00157     static const ModifierTypeEnum ModifierType = ModifierType_SimpleScale;
00158
00160     static const uint32_t ModifierUsage = ModifierUsage_Spawn | ModifierUsage_Continuous
00161             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00162
00163
00165     virtual PxVec3 getScaleFactor() const = 0;
00166
00168     virtual void setScaleFactor(const PxVec3& s) = 0;
00169 };
00170
00174 class ScaleByMassModifier : public ModifierT<ScaleByMassModifier>
00175 {
00176 public:
00177
00179     static const ModifierTypeEnum ModifierType = ModifierType_ScaleByMass;
00180
00182     static const uint32_t ModifierUsage = ModifierUsage_Spawn | ModifierUsage_Continuous
00183             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00184 };
00185
00190 class RandomScaleModifier : public ModifierT<RandomScaleModifier>
00191 {
00192 public:
00193
00195     static const ModifierTypeEnum ModifierType = ModifierType_RandomScale;
00196
00198     static const uint32_t ModifierUsage = ModifierUsage_Spawn
00199             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00200
00201
00203     virtual Range<float> getScaleFactor() const = 0;
00204
00206     virtual void setScaleFactor(const Range<float>& s) = 0;
00207 };
00208
00213 class ColorVsLifeModifier : public ModifierT<ColorVsLifeModifier>
00214 {
00215 public:
00216
00218     static const ModifierTypeEnum ModifierType = ModifierType_ColorVsLife;
00219
00221     static const uint32_t ModifierUsage = ModifierUsage_Spawn | ModifierUsage_Continuous
00222             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00223
00224
00226     virtual ColorChannel getColorChannel() const = 0;
00227
00229     virtual void setColorChannel(ColorChannel colorChannel) = 0;
00230
00232     virtual const Curve* getFunction() const = 0;
00233
00235     virtual void setFunction(const Curve* f) = 0;
00236 };
00237
00242 class ColorVsDensityModifier : public ModifierT<ColorVsDensityModifier>
00243 {
00244 public:
00245
00247     static const ModifierTypeEnum ModifierType = ModifierType_ColorVsDensity;
00248
00250     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00251             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00252
00253
00255     virtual ColorChannel getColorChannel() const = 0;
00256
00258     virtual void setColorChannel(ColorChannel colorChannel) = 0;
00259
00261     virtual const Curve* getFunction() const = 0;
00262
00264     virtual void setFunction(const Curve* f) = 0;
00265 };
00266
00272 class SubtextureVsLifeModifier : public ModifierT<SubtextureVsLifeModifier>
00273 {
00274 public:
00275
00277     static const ModifierTypeEnum ModifierType = ModifierType_SubtextureVsLife;
00278
00280     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00281             | ModifierUsage_Sprite;
00282
00283
00285     virtual const Curve* getFunction() const = 0;
00286
00288     virtual void setFunction(const Curve* f) = 0;
00289 };
00290
00294 class OrientAlongVelocityModifier : public ModifierT<OrientAlongVelocityModifier>
00295 {
00296 public:
00297
00299     static const ModifierTypeEnum ModifierType = ModifierType_OrientAlongVelocity;
00300
00302     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00303             | ModifierUsage_Mesh;
00304
00305
00307     virtual PxVec3 getModelForward() const = 0;
00308
00310     virtual void setModelForward(const PxVec3& s) = 0;
00311 };
00312
00313
00319 class ScaleAlongVelocityModifier : public ModifierT<ScaleAlongVelocityModifier>
00320 {
00321 public:
00322
00324     static const ModifierTypeEnum ModifierType = ModifierType_ScaleAlongVelocity;
00325
00327     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00328             | ModifierUsage_Mesh;
00329
00330
00332     virtual float getScaleFactor() const = 0;
00333
00335     virtual void setScaleFactor(const float& s) = 0;
00336 };
00337
00341 class RandomSubtextureModifier : public ModifierT<RandomSubtextureModifier>
00342 {
00343 public:
00344
00346     static const ModifierTypeEnum ModifierType = ModifierType_RandomSubtexture;
00347
00349     static const uint32_t ModifierUsage = ModifierUsage_Spawn
00350             | ModifierUsage_Sprite;
00351
00352
00354     virtual Range<float> getSubtextureRange() const = 0;
00355
00357     virtual void setSubtextureRange(const Range<float>& s) = 0;
00358 };
00359
00365 class RandomRotationModifier : public ModifierT<RandomRotationModifier>
00366 {
00367 public:
00368
00370     static const ModifierTypeEnum ModifierType = ModifierType_RandomRotation;
00371
00373     static const uint32_t ModifierUsage = ModifierUsage_Spawn
00374             | ModifierUsage_Sprite;
00375
00376
00378     virtual Range<float> getRotationRange() const = 0;
00379
00381     virtual void setRotationRange(const Range<float>& s) = 0;
00382 };
00383
00387 class ScaleVsLifeModifier : public ModifierT<ScaleVsLifeModifier>
00388 {
00389 public:
00390
00392     static const ModifierTypeEnum ModifierType = ModifierType_ScaleVsLife;
00393
00395     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00396             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00397
00398
00400     virtual ScaleAxis getScaleAxis() const = 0;
00401
00403     virtual void setScaleAxis(ScaleAxis a) = 0;
00404
00406     virtual const Curve* getFunction() const = 0;
00407
00409     virtual void setFunction(const Curve* f) = 0;
00410 };
00411
00415 class ScaleVsDensityModifier : public ModifierT<ScaleVsDensityModifier>
00416 {
00417 public:
00418
00420     static const ModifierTypeEnum ModifierType = ModifierType_ScaleVsDensity;
00421
00423     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00424             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00425
00426
00428     virtual ScaleAxis getScaleAxis() const = 0;
00429
00431     virtual void setScaleAxis(ScaleAxis a) = 0;
00432
00434     virtual const Curve* getFunction() const = 0;
00435
00437     virtual void setFunction(const Curve* f) = 0;
00438 };
00439
00443 class ScaleVsCameraDistanceModifier : public ModifierT<ScaleVsCameraDistanceModifier>
00444 {
00445 public:
00446
00448     static const ModifierTypeEnum ModifierType = ModifierType_ScaleVsCameraDistance;
00449
00451     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00452             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00453
00454
00456     virtual ScaleAxis getScaleAxis() const = 0;
00457
00459     virtual void setScaleAxis(ScaleAxis a) = 0;
00460
00462     virtual const Curve* getFunction() const = 0;
00463
00465     virtual void setFunction(const Curve* f) = 0;
00466 };
00467
00471 class ViewDirectionSortingModifier : public ModifierT<ViewDirectionSortingModifier>
00472 {
00473 public:
00474
00476     static const ModifierTypeEnum ModifierType = ModifierType_ViewDirectionSorting;
00477
00479     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00480             | ModifierUsage_Sprite;
00481
00482 };
00483
00487 class RotationRateModifier : public ModifierT<RotationRateModifier>
00488 {
00489 public:
00490
00492     static const ModifierTypeEnum ModifierType = ModifierType_RotationRate;
00493
00495     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00496             | ModifierUsage_Sprite;
00497
00498
00500     virtual float getRotationRate() const = 0;
00501
00503     virtual void setRotationRate(const float& rate) = 0;
00504 };
00505
00509 class RotationRateVsLifeModifier : public ModifierT<RotationRateVsLifeModifier>
00510 {
00511 public:
00512
00514     static const ModifierTypeEnum ModifierType = ModifierType_RotationRateVsLife;
00515
00517     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00518             | ModifierUsage_Sprite;
00519
00520
00522     virtual const Curve* getFunction() const = 0;
00523
00525     virtual void setFunction(const Curve* f) = 0;
00526 };
00527
00531 class OrientScaleAlongScreenVelocityModifier : public ModifierT<OrientScaleAlongScreenVelocityModifier>
00532 {
00533 public:
00534
00536     static const ModifierTypeEnum ModifierType = ModifierType_OrientScaleAlongScreenVelocity;
00537
00539     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00540             | ModifierUsage_Sprite;
00541
00542
00544     virtual float getScalePerVelocity() const = 0;
00545
00547     virtual void setScalePerVelocity(const float& s) = 0;
00548
00550     virtual float getScaleChangeLimit() const = 0;
00551
00553     virtual void setScaleChangeLimit(const float& s) = 0;
00554
00556     virtual float getScaleChangeDelay() const = 0;
00557
00559     virtual void setScaleChangeDelay(const float& s) = 0;
00560 };
00561
00566 class ColorVsVelocityModifier : public ModifierT<ColorVsVelocityModifier>
00567 {
00568 public:
00569
00571     static const ModifierTypeEnum ModifierType = ModifierType_ColorVsVelocity;
00572
00574     static const uint32_t ModifierUsage = ModifierUsage_Spawn | ModifierUsage_Continuous
00575             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00576
00577
00579     virtual ColorChannel getColorChannel() const = 0;
00580
00582     virtual void setColorChannel(ColorChannel colorChannel) = 0;
00583
00585     virtual const Curve* getFunction() const = 0;
00586
00588     virtual void setFunction(const Curve* f) = 0;
00589
00591     virtual float getVelocity0() const = 0;
00592
00594     virtual void setVelocity0(float value) = 0;
00595
00597     virtual float getVelocity1() const = 0;
00598
00600     virtual void setVelocity1(float value) = 0;
00601 };
00602
00603 #pragma warning( default: 4100 )
00604
00605 PX_POP_PACK
00606
00607 }
00608 } // namespace nvidia
00609
00610 #endif // MODIFIER_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModifierDefs.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModifierDefs.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODIFIER_DEFS_H
00031 #define MODIFIER_DEFS_H
00032
00033 #include "ApexUsingNamespace.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00045 struct ApexMeshParticleRollType
00046 {
00050     enum Enum
00051     {
00052         SPHERICAL = 0,
00053         CUBIC,
00054         FLAT_X,
00055         FLAT_Y,
00056         FLAT_Z,
00057         LONG_X,
00058         LONG_Y,
00059         LONG_Z,
00060         SPRITE,
00061
00062         COUNT
00063     };
00064 };
00065
00072 enum ModifierTypeEnum
00073 {
00074     ModifierType_Invalid                        = 0,
00075     ModifierType_Rotation                       = 1,
00076     ModifierType_SimpleScale                    = 2,
00077     ModifierType_RandomScale                    = 3,
00078     ModifierType_ColorVsLife                    = 4,
00079     ModifierType_ColorVsDensity                 = 5,
00080     ModifierType_SubtextureVsLife               = 6,
00081     ModifierType_OrientAlongVelocity            = 7,
00082     ModifierType_ScaleAlongVelocity             = 8,
00083     ModifierType_RandomSubtexture               = 9,
00084     ModifierType_RandomRotation                 = 10,
00085     ModifierType_ScaleVsLife                    = 11,
00086     ModifierType_ScaleVsDensity                 = 12,
00087     ModifierType_ScaleVsCameraDistance          = 13,
00088     ModifierType_ViewDirectionSorting           = 14,
00089     ModifierType_RotationRate                   = 15,
00090     ModifierType_RotationRateVsLife             = 16,
00091     ModifierType_OrientScaleAlongScreenVelocity = 17,
00092     ModifierType_ScaleByMass                    = 18,
00093     ModifierType_ColorVsVelocity                = 19,
00094
00095     ModifierType_Count
00096 };
00097
00101 enum ModifierStage
00102 {
00103     ModifierStage_Spawn = 0,
00104     ModifierStage_Continuous = 1,
00105
00106     ModifierStage_Count
00107 };
00108
00112 enum ColorChannel
00113 {
00114     ColorChannel_Red    = 0,
00115     ColorChannel_Green  = 1,
00116     ColorChannel_Blue   = 2,
00117     ColorChannel_Alpha  = 3
00118 };
00119
00123 enum ScaleAxis
00124 {
00125     ScaleAxis_X         = 0,
00126     ScaleAxis_Y         = 1,
00127     ScaleAxis_Z         = 2
00128 };
00129
00133 enum ModifierUsage
00134 {
00135     ModifierUsage_Spawn         = 0x01,
00136     ModifierUsage_Continuous    = 0x02,
00137
00138     ModifierUsage_Sprite        = 0x04,
00139     ModifierUsage_Mesh          = 0x08,
00140 };
00141
00142 PX_POP_PACK
00143
00144 }
00145 } // namespace nvidia
00146
00147 #endif // MODIFIER_DEFS_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: Module.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
Module.h File Reference

APEX Module API. More...

#include "ApexInterface.h"
#include "ApexSDK.h"
#include "foundation/PxSimpleTypes.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::RenderLockMode
Render lock modes. These are used per-module to determine how render locking is done. More...
struct | nvidia::apex::Range< T >
A structure that holds two templated values, a min and a max. More...
class | nvidia::apex::Module
base class of all APEX modules More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

APEX Module API.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Module.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Module.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_H
00031 #define MODULE_H
00032
00038 #include "ApexInterface.h"
00039 #include "ApexSDK.h"
00040 #include "foundation/PxSimpleTypes.h"
00041
00042 namespace nvidia
00043 {
00044 namespace apex
00045 {
00046
00047 PX_PUSH_PACK_DEFAULT
00048
00049 class RenderableIterator;
00050
00054 struct RenderLockMode
00055 {
00059     enum Enum
00060     {
00064         NO_RENDER_LOCK                  = 0,
00065
00069         PER_ACTOR_RENDER_LOCK           = 1,
00070
00074         PER_MODULE_SCENE_RENDER_LOCK    = 2,
00075     };
00076 };
00077
00081 template <typename T>
00082 struct Range
00083 {
00084     Range() {};
00088     Range(T inMin, T inMax) : minimum(inMin), maximum(inMax) {};
00089
00093     bool operator== (const Range& r) const
00094     {
00095         return minimum == r.minimum && maximum == r.maximum;
00096     }
00097
00101     T minimum;
00105     T maximum;
00106 };
00107
00108
00109
00115 class Module : public ApexInterface
00116 {
00117 public:
00122     virtual void init(::NvParameterized::Interface& desc) = 0;
00123
00127     virtual const char* getName() const = 0;
00128
00132     virtual AuthObjTypeID getModuleID() const = 0;
00133
00138     virtual ::NvParameterized::Interface* getDefaultModuleDesc()
00139     {
00140         return NULL;
00141     }
00142
00150     virtual RenderableIterator* createRenderableIterator(const Scene&) = 0;
00151
00157     virtual bool setRenderLockMode(RenderLockMode::Enum, Scene&) { return false; }
00158
00162     virtual RenderLockMode::Enum getRenderLockMode(const Scene&) const { return RenderLockMode::NO_RENDER_LOCK; }
00163
00169     virtual bool lockModuleSceneRenderLock(Scene&) { return false; }
00170
00176     virtual bool unlockModuleSceneRenderLock(Scene&) { return false; }
00177 };
00178
00179 PX_POP_PACK
00180
00181 }
00182 } // end namespace nvidia::apex
00183
00184 #endif // MODULE_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleBasicFS.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleBasicFS.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef MODULE_BASIC_FS_H
00030 #define MODULE_BASIC_FS_H
00031
00032 #include "Apex.h"
00033
00034 namespace nvidia
00035 {
00036 namespace apex
00037 {
00038
00039 PX_PUSH_PACK_DEFAULT
00040
00041 class BasicFSAsset;
00042 class BasicFSAssetAuthoring;
00043
00044
00048 class ModuleBasicFS : public Module
00049 {
00050 public:
00051
00052 protected:
00053     virtual ~ModuleBasicFS() {}
00054 };
00055
00056
00057 PX_POP_PACK
00058
00059 }
00060 } // end namespace nvidia::apex
00061
00062 #endif // MODULE_BASIC_FS_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleBasicIos.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleBasicIos.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_BASIC_IOS_H
00031 #define MODULE_BASIC_IOS_H
00032
00033 #include "Apex.h"
00034 #include "TestBase.h"
00035 #include <limits.h>
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00042 PX_PUSH_PACK_DEFAULT
00043
00044 class Scene;
00045 class BasicIosAsset;
00046 class BasicIosActor;
00047 class BasicIosAssetAuthoring;
00048
00052 class ModuleBasicIos : public Module
00053 {
00054 protected:
00055     virtual                                     ~ModuleBasicIos() {}
00056
00057 public:
00059     virtual const char*                         getBasicIosTypeName() = 0;
00060
00062     virtual const TestBase*                     getTestBase(Scene* apexScene) const = 0;
00063
00064 };
00065
00066
00067 PX_POP_PACK
00068
00069 }
00070 } // namespace nvidia
00071
00072 #endif // MODULE_BASIC_IOS_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleClothing.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleClothing.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_CLOTHING_H
00031 #define MODULE_CLOTHING_H
00032
00033 #include "Module.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class ClothingAsset;
00043 class ClothingAssetAuthoring;
00044 class ClothingPhysicalMesh;
00045
00046 class IProgressListener;
00047 class RenderMeshAssetAuthoring;
00048
00064 class ModuleClothing : public Module
00065 {
00066 public:
00070     virtual ClothingPhysicalMesh* createEmptyPhysicalMesh() = 0;
00071
00081     virtual ClothingPhysicalMesh* createSingleLayeredMesh(RenderMeshAssetAuthoring* asset, uint32_t subdivision, bool mergeVertices, bool closeHoles, IProgressListener* progress) = 0;
00082
00083 protected:
00084     virtual ~ModuleClothing() {}
00085 };
00086
00087 #if !defined(_USRDLL)
00088
00092 void instantiateModuleClothing();
00093 #endif
00094
00095
00096 PX_POP_PACK
00097
00098 }
00099 } // namespace nvidia
00100
00101 #endif // MODULE_CLOTHING_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleDestructible.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleDestructible.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_DESTRUCTIBLE_H
00031 #define MODULE_DESTRUCTIBLE_H
00032
00033 #include "foundation/Px.h"
00034 #include "foundation/PxBounds3.h"
00035 #include "Module.h"
00036
00037 #ifndef APEX_RUNTIME_FRACTURE
00038 #define APEX_RUNTIME_FRACTURE 1
00039 #else
00040 #undef APEX_RUNTIME_FRACTURE
00041 #define APEX_RUNTIME_FRACTURE 0
00042 #endif
00043
00044 #if PX_ANDROID
00045 #undef APEX_RUNTIME_FRACTURE
00046 #define APEX_RUNTIME_FRACTURE 0
00047 #endif
00048
00049 namespace physx
00050 {
00051 class PxRigidActor;
00052 class PxRigidDynamic;
00053 class PxScene;
00054 }
00055
00056 namespace nvidia
00057 {
00058 namespace apex
00059 {
00060
00061 PX_PUSH_PACK_DEFAULT
00062
00063 class DestructibleAsset;
00064 class DestructibleAssetAuthoring;
00065 class DestructibleActor;
00066 class DestructibleActorJoint;
00067 class DestructibleChunkDesc;
00068 class DestructibleActorDesc;
00069 class DestructibleActorJointDesc;
00070
00074 struct ApexChunkFlag
00075 {
00079     enum Enum
00080     {
00082         DYNAMIC                         =   1 << 0,
00083
00085         EXTERNALLY_SUPPORTED            =   1 << 1,
00086
00088         WORLD_SUPPORTED                 =   1 << 2,
00089
00091         FRACTURED                       =   1 << 3,
00092
00094         DESTROYED_FIFO_FULL             =   1 << 4,
00095
00097         DESTROYED_TIMED_OUT             =   1 << 5,
00098
00100         DESTROYED_EXCEEDED_MAX_DISTANCE =   1 << 6,
00101
00103         DESTROYED_CRUMBLED              =   1 << 7,
00104
00106         DESTROYED_LEFT_VALID_BOUNDS     =   1 << 8,
00107
00109         DESTROYED_LEFT_USER_BOUNDS      =   1 << 9,
00110
00112         DESTROYED_ENTERED_USER_BOUNDS   =   1 << 10
00113     };
00114 };
00115
00119 struct ChunkData
00120 {
00122     uint32_t            index;
00123
00125     uint32_t            depth;
00126
00130     PxBounds3           worldBounds;
00131
00135     float               damage;
00136
00141     uint32_t            flags;
00142 };
00143
00147 struct DamageEventReportData
00148 {
00152     DestructibleActor*  destructible;
00153
00157     PxVec3              hitDirection;
00158
00163     PxBounds3           worldBounds;
00164
00169     uint32_t            totalNumberOfFractureEvents;
00170
00175     uint16_t            minDepth;
00176
00181     uint16_t            maxDepth;
00182
00191     const ChunkData*    fractureEventList;
00192
00198     uint32_t            fractureEventListSize;
00199
00203     physx::PxActor const*   impactDamageActor;
00204
00205
00209     PxVec3              hitPosition;
00210
00214     void*               appliedDamageUserData;
00215 };
00216
00217
00223 struct DestructibleChunkEvent
00224 {
00228     enum EventMask
00229     {
00230         VisibilityChanged   =   (1 << 0),
00231         ChunkVisible    =       (1 << 1)
00232     };
00233
00234     uint16_t    chunkIndex;
00235     uint16_t    event;
00236 };
00237
00238
00242 struct ChunkStateEventData
00243 {
00247     DestructibleActor*          destructible;
00248
00252     const DestructibleChunkEvent* stateEventList;
00253
00257     uint32_t                    stateEventListSize;
00258 };
00259
00260
00264 class UserChunkReport
00265 {
00266 public:
00273     virtual void    onDamageNotify(const DamageEventReportData& damageEvent) = 0;
00274
00285     virtual void    onStateChangeNotify(const ChunkStateEventData& visibilityEvent) = 0;
00286
00297     virtual bool    releaseOnNoChunksVisible(const DestructibleActor* destructible) { PX_UNUSED(destructible);  return false; }
00298
00302     virtual void    onDestructibleWake(DestructibleActor** destructibles, uint32_t count) = 0;
00303
00307     virtual void    onDestructibleSleep(DestructibleActor** destructibles, uint32_t count) = 0;
00308
00309 protected:
00310     virtual         ~UserChunkReport() {}
00311 };
00312
00313
00317 struct ChunkParticleReportData
00318 {
00320     const PxVec3* positions;
00321
00323     uint32_t positionCount;
00324
00333     const PxVec3* velocities;
00334
00336     uint32_t velocityCount;
00337 };
00338
00343 class UserChunkParticleReport
00344 {
00345 public:
00355     virtual void    onParticleEmission(const ChunkParticleReportData& particleData) = 0;
00356
00357 protected:
00358     virtual         ~UserChunkParticleReport() {}
00359 };
00360
00361
00366 class UserDestructiblePhysXActorReport
00367 {
00368 public:
00370     virtual void    onPhysXActorCreate(const physx::PxActor& actor) = 0;
00371
00373     virtual void    onPhysXActorRelease(const physx::PxActor& actor) = 0;
00374 protected:
00375     virtual     ~UserDestructiblePhysXActorReport() {}
00376 };
00377
00378
00382 struct ModuleDestructibleConst
00383 {
00387     enum Enum
00388     {
00393         INVALID_CHUNK_INDEX = -1
00394     };
00395 };
00396
00400 struct DestructibleActorMeshType
00401 {
00405     enum Enum
00406     {
00407         Skinned,
00408         Static,
00409         Count
00410     };
00411 };
00412
00416 struct DamageEventCoreData
00417 {
00418     int32_t chunkIndexInAsset;
00419     PxVec3  position;
00420     float   damage;
00421     float   radius;
00422 };
00423
00427 struct ImpactDamageEventData : public DamageEventCoreData
00428 {
00429     nvidia::DestructibleActor*  destructible;
00430     PxVec3                      direction;
00431     physx::PxActor const*       impactDamageActor;
00432 };
00433
00437 class UserImpactDamageReport
00438 {
00439 public:
00446     virtual void    onImpactDamageNotify(const ImpactDamageEventData* buffer, uint32_t bufferSize) = 0;
00447 };
00448
00452 template<typename DestructibleSyncHeader>
00453 class UserDestructibleSyncHandler
00454 {
00455 public:
00459     virtual void    onWriteBegin(DestructibleSyncHeader *& bufferStart, uint32_t bufferSize) = 0;
00460
00464     virtual void    onWriteDone(uint32_t headerCount) = 0;
00465
00469     virtual void    onPreProcessReadBegin(DestructibleSyncHeader *& bufferStart, uint32_t & bufferSize, bool & continuePointerSwizzling) = 0;
00470
00474     virtual void    onPreProcessReadDone(uint32_t headerCount) = 0;
00475
00479     virtual void    onReadBegin(const DestructibleSyncHeader *& bufferStart) = 0;
00480
00484     virtual void    onReadDone(const char * debugMessage) = 0;
00485 protected:
00486     virtual ~UserDestructibleSyncHandler() {}
00487 };
00488
00489 /*** Sync-able Damage Data ***/
00490
00491 struct DamageEventUnit;
00495 struct DamageEventHeader
00496 {
00497     uint32_t                    userActorID;
00498     uint32_t                    damageEventCount;
00499     DamageEventUnit *           damageEventBufferStart;
00500     DamageEventHeader *         next;
00501 };
00502
00506 struct DamageEventUnit
00507 {
00508     uint32_t    chunkIndex;
00509     uint32_t    damageEventFlags;
00510     float       damage;
00511     float       momentum;
00512     float       radius;
00513     PxVec3      position;
00514     PxVec3      direction;
00515 };
00516
00517 /*** Sync-able Fracture Data ***/
00518
00519 struct FractureEventUnit;
00520
00524 struct FractureEventHeader
00525 {
00526     uint32_t                    userActorID;
00527     uint32_t                    fractureEventCount;
00528     FractureEventUnit *         fractureEventBufferStart;
00529     FractureEventHeader *       next;
00530 };
00531
00535 struct FractureEventUnit
00536 {
00537     uint32_t    chunkIndex;
00538     uint32_t    fractureEventFlags;
00539     PxVec3      position;
00540     PxVec3      direction;
00541     PxVec3      impulse;
00542 };
00543
00544 /*** Sync-able Transform Data ***/
00545
00546 struct ChunkTransformUnit;
00547
00551 struct ChunkTransformHeader
00552 {
00553     uint32_t                    userActorID;
00554     uint32_t                    chunkTransformCount;
00555     ChunkTransformUnit *        chunkTransformBufferStart;
00556     ChunkTransformHeader *      next;
00557 };
00558
00562 struct ChunkTransformUnit
00563 {
00564     uint32_t    chunkIndex;
00565     PxVec3      chunkPosition;
00566     PxQuat      chunkOrientation;
00567 };
00568
00569
00573 struct DestructibleActorRaycastFlags
00574 {
00578     enum Enum
00579     {
00580         NoChunks =      (0),
00581         StaticChunks =  (1 << 0),
00582         DynamicChunks = (1 << 1),
00583
00584         AllChunks =                 StaticChunks | DynamicChunks,
00585
00586         SegmentIntersect =  (1 << 2),
00587
00588         ForceAccurateRaycastsOn =   (1 << 3),
00589         ForceAccurateRaycastsOff =  (1 << 4),
00590     };
00591 };
00592
00593
00597 struct DestructibleCallbackSchedule
00598 {
00602     enum Enum
00603     {
00604         Disabled =      (0),
00605         BeforeTick,
00606         FetchResults,
00607
00608         Count
00609     };
00610 };
00611
00612
00616 class ModuleDestructible : public Module
00617 {
00618 public:
00628     virtual DestructibleActorJoint*         createDestructibleActorJoint(const DestructibleActorJointDesc& desc, Scene& scene) = 0;
00629
00635     virtual bool                            isDestructibleActorJointActive(const DestructibleActorJoint* candidateJoint, Scene& apexScene) const = 0;
00636
00646     virtual void                            setMaxDynamicChunkIslandCount(uint32_t maxCount) = 0;
00647
00654     virtual void                            setMaxChunkCount(uint32_t maxCount) = 0;
00655
00660     virtual void                            setSortByBenefit(bool sortByBenefit) = 0;
00661
00665     virtual void                            setValidBoundsPadding(float pad) = 0;
00666
00673     virtual void                            setMaxChunkDepthOffset(uint32_t maxChunkDepthOffset) = 0;
00674
00680     virtual void                            setMaxChunkSeparationLOD(float separationLOD) = 0;
00681
00682
00688     virtual void                            setChunkReport(UserChunkReport* chunkReport) = 0;
00689
00694     virtual void                            setImpactDamageReportCallback(UserImpactDamageReport* impactDamageReport) = 0;
00695
00700     virtual void                            setChunkReportBitMask(uint32_t chunkReportBitMask) = 0;
00701
00706     virtual void                            setDestructiblePhysXActorReport(UserDestructiblePhysXActorReport* destructiblePhysXActorReport) = 0;
00707
00713     virtual void                            setChunkReportMaxFractureEventDepth(uint32_t chunkReportMaxFractureEventDepth) = 0;
00714
00721     virtual void                            scheduleChunkStateEventCallback(DestructibleCallbackSchedule::Enum chunkStateEventCallbackSchedule) = 0;
00722
00727     virtual void                            setChunkCrumbleReport(UserChunkParticleReport* chunkCrumbleReport) = 0;
00728
00735     virtual void                            setChunkDustReport(UserChunkParticleReport* chunkDustReport) = 0;
00736
00742     virtual void                            setWorldSupportPhysXScene(Scene& apexScene, PxScene* physxScene) = 0;
00743
00748     virtual bool                            owns(const PxRigidActor* actor) const = 0;
00749
00750 #if APEX_RUNTIME_FRACTURE
00751
00755     virtual bool                            isRuntimeFractureShape(const PxShape& shape) const = 0;
00756 #endif
00757
00764     virtual DestructibleActor*              getDestructibleAndChunk(const PxShape* shape, int32_t* chunkIndex = NULL) const = 0;
00765
00776     virtual void                            applyRadiusDamage(Scene& scene, float damage, float momentum,
00777             const PxVec3& position, float radius, bool falloff) = 0;
00778
00783     virtual void                            setMaxActorCreatesPerFrame(uint32_t maxActorsPerFrame) = 0;
00784
00789     virtual void                            setMaxFracturesProcessedPerFrame(uint32_t maxFracturesProcessedPerFrame) = 0;
00790
00794     virtual bool                            setSyncParams(UserDestructibleSyncHandler<DamageEventHeader> * userDamageEventHandler, UserDestructibleSyncHandler<FractureEventHeader> * userFractureEventHandler, UserDestructibleSyncHandler<ChunkTransformHeader> * userChunkMotionHandler) = 0;
00795
00806     virtual void                            setUseLegacyChunkBoundsTesting(bool useLegacyChunkBoundsTesting) = 0;
00807
00819     virtual void                            setUseLegacyDamageRadiusSpread(bool useLegacyDamageRadiusSpread) = 0;
00820
00837     virtual bool                            setMassScaling(float massScale, float scaledMassExponent, Scene& apexScene) = 0;
00838
00845     virtual void                            invalidateBounds(const PxBounds3* bounds, uint32_t boundsCount, Scene& apexScene) = 0;
00846
00857     virtual void                            setDamageApplicationRaycastFlags(nvidia::DestructibleActorRaycastFlags::Enum flags, Scene& apexScene) = 0;
00858
00868     virtual bool                            setChunkCollisionHullCookingScale(const PxVec3& scale) = 0;
00869
00873     virtual PxVec3                          getChunkCollisionHullCookingScale() const = 0;
00874
00878     virtual class FractureToolsAPI*         getFractureTools() const = 0;
00879
00880 protected:
00881     virtual                                 ~ModuleDestructible() {}
00882 };
00883
00884
00885 #if !defined(_USRDLL)
00886
00890 void instantiateModuleDestructible();
00891 #endif
00892
00893 PX_POP_PACK
00894
00895 }
00896 } // end namespace nvidia
00897
00898 #endif // MODULE_DESTRUCTIBLE_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleEmitter.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleEmitter.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_EMITTER_H
00031 #define MODULE_EMITTER_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class EmitterAsset;
00044 class EmitterAssetAuthoring;
00045
00046 class GroundEmitterAsset;
00047 class GroundEmitterAssetAuthoring;
00048
00049 class ImpactEmitterAsset;
00050 class ImpactEmitterAssetAuthoring;
00051
00052
00056 class ModuleEmitter : public Module
00057 {
00058 protected:
00059     virtual ~ModuleEmitter() {}
00060
00061 public:
00062
00064     virtual float   getRateScale() const = 0;
00065
00067     virtual float   getDensityScale() const = 0;
00068
00070     virtual float   getGroundDensityScale() const = 0;
00071
00073     virtual void    setRateScale(float rateScale) = 0;
00074
00076     virtual void    setDensityScale(float densityScale) = 0;
00077
00079     virtual void    setGroundDensityScale(float groundDensityScale) = 0;
00080 };
00081
00082
00083
00084 PX_POP_PACK
00085
00086 }
00087 } // end namespace nvidia
00088
00089 #endif // MODULE_EMITTER_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleFieldSampler.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleFieldSampler.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_FIELD_SAMPLER_H
00031 #define MODULE_FIELD_SAMPLER_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00048 class FieldSamplerWeightedCollisionFilterCallback
00049 {
00050 public:
00057     virtual bool fieldSamplerWeightedCollisionFilter(const physx::PxFilterData &objectA,const physx::PxFilterData &objectB,float &multiplierValue) = 0;
00058 };
00059
00060
00064 class ModuleFieldSampler : public Module
00065 {
00066 protected:
00067     virtual                 ~ModuleFieldSampler() {}
00068
00069 public:
00070
00074     virtual bool            setFieldSamplerWeightedCollisionFilterCallback(const Scene& apexScene,FieldSamplerWeightedCollisionFilterCallback *callback) = 0;
00075
00076
00077 #if PX_PHYSICS_VERSION_MAJOR == 3
00078
00081     virtual void            enablePhysXMonitor(const Scene& apexScene, bool enable) = 0;
00088     virtual void            setPhysXMonitorFilterData(const Scene& apexScene, physx::PxFilterData filterData) = 0;
00089 #endif
00090
00099     virtual uint32_t        createForceSampleBatch(const Scene& apexScene, uint32_t maxCount, const physx::PxFilterData filterData) = 0;
00100
00107     virtual void            releaseForceSampleBatch(const Scene& apexScene, uint32_t batchId) = 0;
00108
00125     virtual void            submitForceSampleBatch( const Scene& apexScene, uint32_t batchId,
00126                                                     PxVec4* forces, const uint32_t forcesStride,
00127                                                     const PxVec3* positions, const uint32_t positionsStride,
00128                                                     const PxVec3* velocities, const uint32_t velocitiesStride,
00129                                                     const float* mass, const uint32_t massStride,
00130                                                     const uint32_t* indices, const uint32_t numIndices) = 0;
00131
00132 };
00133
00134
00135
00136 PX_POP_PACK
00137
00138 }
00139 } // end namespace nvidia::apex
00140
00141 #endif // MODULE_FIELD_SAMPLER_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleForceField.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleForceField.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_FORCE_FIELD_H
00031 #define MODULE_FORCE_FIELD_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class ForceFieldAsset;
00043 class ForceFieldAssetAuthoring;
00044
00048 class ModuleForceField : public Module
00049 {
00050 public:
00054     virtual uint32_t getModuleValue() const = 0;
00055
00056 protected:
00060     virtual ~ModuleForceField() {}
00061 };
00062
00063
00064
00065 PX_POP_PACK
00066
00067 } // namespace apex
00068 } // namespace nvidia
00069
00070 #endif // MODULE_FORCE_FIELD_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleIofx.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleIofx.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_IOFX_H
00031 #define MODULE_IOFX_H
00032
00033 #include "Apex.h"
00034 #include "TestBase.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class IofxAsset;
00044 class IofxAssetAuthoring;
00045 class RenderVolume;
00046 class IofxRenderCallback;
00047 class IofxRenderable;
00048
00049
00053 class IofxRenderableIterator : public ApexInterface
00054 {
00055 public:
00056
00058     virtual IofxRenderable* getFirst() = 0;
00059
00061     virtual IofxRenderable* getNext() = 0;
00062 };
00063
00064
00072 class ModuleIofx : public Module
00073 {
00074 protected:
00075     virtual                         ~ModuleIofx() {}
00076
00077 public:
00079     virtual void                    disableCudaInterop() = 0;
00080
00082     virtual void                    disableCudaModifiers() = 0;
00083
00089     virtual void                    disableDeferredRenderableAllocation() = 0;
00090
00097     virtual RenderVolume*           createRenderVolume(const Scene& apexScene, const PxBounds3& b, uint32_t priority, bool allIofx) = 0;
00098
00105     virtual void                    releaseRenderVolume(RenderVolume& volume) = 0;
00106
00108     virtual const TestBase*         getTestBase(Scene* apexScene) const = 0;
00109
00114     virtual bool                    setIofxRenderCallback(const Scene& apexScene, IofxRenderCallback* ) = 0;
00115
00120     virtual IofxRenderCallback*     getIofxRenderCallback(const Scene& apexScene) const = 0;
00121
00125     virtual IofxRenderableIterator* createIofxRenderableIterator(const Scene&) = 0;
00126
00130     virtual void                    prepareRenderables(const Scene&) = 0;
00131 };
00132
00133
00134 PX_POP_PACK
00135
00136 }
00137 } // namespace nvidia
00138
00139 #endif // MODULE_IOFX_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleIofxLegacy.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleIofxLegacy.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_IOFX_LEGACY_H
00031 #define MODULE_IOFX_LEGACY_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 class IofxRenderCallback;
00041
00042 PX_PUSH_PACK_DEFAULT
00043
00049 class ModuleIofxLegacy : public Module
00050 {
00051 protected:
00052     virtual ~ModuleIofxLegacy() {}
00053
00054 public:
00055
00059     virtual IofxRenderCallback* getIofxLegacyRenderCallback(const Scene& apexScene) = 0;
00060 };
00061
00062 PX_POP_PACK
00063
00064 }
00065 } // end namespace nvidia::apex
00066
00067 #endif // MODULE_IOFX_LEGACY_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleLegacy.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleLegacy.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_LEGACY_H
00031 #define MODULE_LEGACY_H
00032
00033 #include <ApexUsingNamespace.h>
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 #if !defined(_USRDLL)
00041
00045 void instantiateModuleLegacy();
00046 #endif
00047
00048 }
00049 } // end namespace physx::apex
00050
00051 #endif // MODULE_LEGACY_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleLoader.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleLoader.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_LOADER_H
00031 #define MODULE_LOADER_H
00032
00033 #include "Apex.h"
00034 #include "PsHashMap.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00051 class ModuleLoader : public Module
00052 {
00053 public:
00055     virtual Module* loadModule(const char* name) = 0;
00056
00065     virtual void loadModules(const char** names, uint32_t size, Module** modules = 0) = 0;
00066
00068     virtual void loadAllModules() = 0;
00069
00071     virtual void loadAllLegacyModules() = 0;
00072
00074     virtual uint32_t getLoadedModuleCount() const = 0;
00075
00077     virtual Module* getLoadedModule(uint32_t idx) const = 0;
00078
00080     virtual Module* getLoadedModule(const char* name) const = 0;
00081
00083     virtual void releaseModule(uint32_t idx) = 0;
00084
00086     virtual void releaseModule(const char* name) = 0;
00087
00089     virtual void releaseModules(Module** modules, uint32_t size) = 0;
00090
00097     virtual void releaseModule(Module* module) = 0;
00098
00105     virtual void releaseModules(const char** names, uint32_t size) = 0;
00106
00108     virtual void releaseLoadedModules() = 0;
00109
00111     typedef shdfnd::HashMap<const char*, nvidia::apex::ApexCreateError> ModuleNameErrorMap;
00112
00114     virtual const ModuleNameErrorMap& getLoadedModulesErrors() const = 0;
00115 };
00116
00117 #if !defined(_USRDLL)
00118
00122 void instantiateModuleLoader();
00123 #endif
00124
00125 }
00126 } // end namespace nvidia::apex
00127
00128 #endif // MODULE_LOADER_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleParticleIos.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleParticleIos.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_PARTICLE_IOS_H
00031 #define MODULE_PARTICLE_IOS_H
00032
00033 #include "Apex.h"
00034 #include <limits.h>
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class ParticleIosAsset;
00044 class ParticleIosAssetAuthoring;
00045 class CudaTestManager;
00046 class Scene;
00047
00051 class ModuleParticleIos : public Module
00052 {
00053 protected:
00054     virtual                                         ~ModuleParticleIos() {}
00055
00056 public:
00058     virtual const char*                             getParticleIosTypeName() = 0;
00059 };
00060
00061
00062 PX_POP_PACK
00063
00064 }
00065 } // namespace nvidia
00066
00067 #endif // MODULE_PARTICLE_IOS_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleParticles.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleParticles.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_PARTICLES_H
00031 #define MODULE_PARTICLES_H
00032
00033 #include "Apex.h"
00034
00035
00036 namespace nvidia
00037 {
00038
00039
00040 namespace apex
00041 {
00042
00043 PX_PUSH_PACK_DEFAULT
00044
00045 class Module;
00046 class Scene;
00047 class EffectPackageActor;
00082 class ModuleParticles : public Module
00083 {
00084 public:
00085
00089     virtual nvidia::apex::Module* getModule(const char* moduleName) = 0;
00090
00101     virtual bool setEffectPackageGraphicsMaterialsDatabase(const NvParameterized::Interface* dataBase) = 0;
00102
00113     virtual bool setEffectPackageIOSDatabase(const NvParameterized::Interface* dataBase) = 0;
00114
00125     virtual bool setEffectPackageIOFXDatabase(const NvParameterized::Interface* dataBase) = 0;
00126
00137     virtual bool setEffectPackageEmitterDatabase(const NvParameterized::Interface* dataBase) = 0;
00138
00149     virtual bool setEffectPackageDatabase(const NvParameterized::Interface* dataBase) = 0;
00150
00161     virtual bool setEffectPackageFieldSamplerDatabase(const NvParameterized::Interface* dataBase) = 0;
00162
00166     virtual const NvParameterized::Interface* getEffectPackageGraphicsMaterialsDatabase() const = 0;
00167
00171     virtual const NvParameterized::Interface* getEffectPackageIOSDatabase() const = 0;
00172
00176     virtual const NvParameterized::Interface* getEffectPackageIOFXDatabase() const = 0;
00177
00181     virtual const NvParameterized::Interface* getEffectPackageEmitterDatabase() const = 0;
00182
00186     virtual const NvParameterized::Interface* getEffectPackageDatabase() const = 0;
00187
00191     virtual const NvParameterized::Interface* getEffectPackageFieldSamplerDatabase() const = 0;
00192
00204     virtual const NvParameterized::Interface* locateGraphicsMaterialData(const char* name) const = 0;
00205
00216     virtual NvParameterized::Interface* locateResource(const char* resourceName,
00217             const char* nameSpace) = 0;
00218
00219
00229     virtual const char** getResourceNames(const char* nameSpace, uint32_t& nameCount, const char** &variants) = 0;
00230
00240     virtual void setEnableScreenCulling(bool state, bool znegative) = 0;
00241
00245     virtual void resetEmitterPool() = 0;
00246
00256     virtual void setUseEmitterPool(bool state) = 0;
00257
00261     virtual bool getUseEmitterPool() const = 0;
00262
00266     virtual void initializeDefaultDatabases() = 0;
00267
00268 protected:
00269     virtual ~ModuleParticles() {}
00270 };
00271
00272 #if !defined(_USRDLL)
00273
00277 void instantiateModuleParticles();
00278 #endif
00279
00280
00281 PX_POP_PACK
00282
00283 }
00284 } // end namespace nvidia
00285
00286 #endif // MODULE_PARTICLES_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ModuleTurbulenceFS.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ModuleTurbulenceFS.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_TURBULENCE_FS_H
00031 #define MODULE_TURBULENCE_FS_H
00032
00033 #include "Apex.h"
00034 #include "Shape.h"
00035 #include "VelocitySourceActor.h"
00036 #include "HeatSourceActor.h"
00037 #include "SubstanceSourceActor.h"
00038 #include "FlameEmitterActor.h"
00039 #include "TestBase.h"
00040 #include "PxFiltering.h"
00041
00042 namespace nvidia
00043 {
00044 namespace apex
00045 {
00046
00047 class TurbulenceFSAsset;
00048 class TurbulenceFSAssetAuthoring;
00049
00050 class TurbulenceRenderCallback;
00051
00055 class ModuleTurbulenceFS : public Module
00056 {
00057 public:
00058
00060     virtual bool                        setCustomTimestep(const Scene& apexScene, float timestep, int numIterations) = 0;
00061
00063     virtual bool                        setMultiSolveEnabled(const Scene& apexScene, bool enabled) = 0;
00064
00066     virtual void                        enableOutputVelocityField() = 0;
00067
00069     virtual void                        enableOutputDensityField() = 0;
00070
00072     virtual void                        enableOutputFlameField() = 0;
00073
00075     virtual void                        setCustomFilterShader(physx::PxSimulationFilterShader shader, const void* shaderData, uint32_t shaderDataSize) = 0;
00076
00078     virtual const TestBase*             getTestBase(Scene* apexScene) const = 0;
00079
00081     virtual int32_t                     getGridSizePow() const = 0;
00082
00084     virtual void                        setGridSizePow(int32_t power) = 0;
00085
00087     virtual void                        prepareRenderables(const Scene&) = 0;
00088
00093     virtual bool                        setTurbulenceRenderCallback(const Scene& apexScene, TurbulenceRenderCallback* ) = 0;
00094
00099     virtual TurbulenceRenderCallback*   getTurbulenceRenderCallback(const Scene& apexScene) const = 0;
00100
00101 protected:
00102     virtual ~ModuleTurbulenceFS() {}
00103 };
00104
00105 #if !defined(_USRDLL)
00106
00110 void instantiateModuleTurbulenceFS();
00111 #endif
00112
00113 }
00114 } // end namespace nvidia
00115
00116 #endif // MODULE_TURBULENCE_FS_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: NoiseFSActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
NoiseFSActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef NOISE_FSACTOR_H
00031 #define NOISE_FSACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class BasicFSAsset;
00043
00044
00048 class NoiseFSActor : public Actor, public Renderable
00049 {
00050 protected:
00051     virtual ~NoiseFSActor() {}
00052
00053 public:
00054
00058     virtual BasicFSAsset*       getNoiseFSAsset() const = 0;
00059
00063     virtual PxMat44             getCurrentPose() const = 0;
00064
00068     virtual void                setCurrentPose(const PxTransform& pose) = 0;
00069
00073     virtual PxVec3              getCurrentPosition() const = 0;
00074
00078     virtual void                setCurrentPosition(const PxVec3& pos) = 0;
00079
00083     virtual float               getCurrentScale() const = 0;
00084
00088     virtual void                setCurrentScale(const float& scale) = 0;
00089
00093     virtual void                setNoiseStrength(float) = 0;
00094
00098     virtual void                setEnabled(bool isEnabled) = 0;
00099
00100 };
00101
00102 PX_POP_PACK
00103
00104 }
00105 } // end namespace nvidia::apex
00106
00107 #endif // NOISE_FSACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: NoiseFSPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
NoiseFSPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef NOISE_FSPREVIEW_H
00030 #define NOISE_FSPREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class RenderDebugInterface;
00043
00052 namespace APEX_NOISE
00053 {
00058 static const uint32_t NOISE_DRAW_NOTHING = 0x00;
00063 static const uint32_t NOISE_DRAW_SHAPE = 0x01;
00069 static const uint32_t NOISE_DRAW_ASSET_INFO = 0x02;
00074 static const uint32_t NOISE_DRAW_FULL_DETAIL = (NOISE_DRAW_SHAPE + NOISE_DRAW_ASSET_INFO);
00075 }
00076
00081 class NoiseFSPreview : public AssetPreview
00082 {
00083 public:
00094     virtual void    setDetailLevel(uint32_t detail) = 0;
00095 };
00096
00097
00098 PX_POP_PACK
00099
00100 }
00101 } // namespace nvidia
00102
00103 #endif // NOISE_FSPREVIEW_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: NvParamUtils.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
NvParamUtils.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2008-2018 NVIDIA Corporation. All rights reserved.
00027
00028 #ifndef NV_PARAM_UTILS_H
00029 #define NV_PARAM_UTILS_H
00030
00031 #include "NvParameterized.h"
00032
00033 // utility methods to operate on NvParameterized data.
00034
00035 namespace NvParameterized
00036 {
00037
00053 PX_INLINE const Interface * findParam(const Interface &i,const char *longName, Handle &outHandle);
00054
00055
00071 PX_INLINE Interface * findParam(Interface &i,const char *longName, Handle &outHandle);
00072
00076 struct ParamResult
00077 {
00078 public:
00082     ParamResult(const char *name,
00083                 const char *longName,
00084                 const char *className,
00085                 const char *instanceName,
00086                 const Handle &handle,
00087                 int32_t arraySize,
00088                 DataType type)
00089         : mArraySize(arraySize),
00090         mInstanceName(instanceName),
00091         mClassName(className),
00092         mName(name),
00093         mLongName(longName),
00094         mHandle(handle),
00095         mDataType(type)
00096     {}
00097
00101     int32_t mArraySize;
00102
00106     const char *mInstanceName;
00107
00111     const char *mClassName;
00112
00116     const char *mName;
00117
00121     const char *mLongName;
00122
00126     Handle mHandle;
00127
00131     DataType mDataType;
00132 };
00133
00148 PX_INLINE const ParamResult * getParamList(const Interface &i,
00149                                  const char *className, // name of class to match
00150                                  const char *paramName, // name of parameter to match
00151                                  uint32_t &count,
00152                                  bool recursive,
00153                                  bool classesOnly,
00154                                  NvParameterized::Traits *traits);
00155
00157 PX_INLINE void              releaseParamList(uint32_t resultCount,const ParamResult *results,NvParameterized::Traits *traits);
00158
00160 PX_INLINE bool getParamArraySize(const Interface &pm, const char *name, int32_t &arraySize);
00161
00163 PX_INLINE bool resizeParamArray(Interface &pm, const char *name, int32_t newSize);
00164
00168 class NamedReferenceInterface
00169 {
00170 public:
00174     virtual ~NamedReferenceInterface() {}
00182     virtual const char * namedReferenceCallback(const char *className,const char *namedReference,Handle &handle) = 0;
00183 };
00184
00186 PX_INLINE uint32_t getNamedReferences(const Interface &i,
00187                                           NamedReferenceInterface &namedReference,
00188                                           bool recursive);
00189
00193 class ReferenceInterface
00194 {
00195 public:
00199     virtual ~ReferenceInterface() {}
00205     virtual void referenceCallback(Handle &handle) = 0;
00206 };
00207
00209 PX_INLINE void getReferences(const Interface &iface,
00210                                           ReferenceInterface &cb,
00211                                           bool named,
00212                                           bool included,
00213                                           bool recursive);
00214
00216 PX_INLINE bool getParamBool(const Interface &pm, const char *name, bool &val);
00218 PX_INLINE bool setParamBool(Interface &pm, const char *name, bool val) ;
00219
00221 PX_INLINE bool getParamString(const Interface &pm, const char *name, const char *&val);
00223 PX_INLINE bool setParamString(Interface &pm, const char *name, const char *val) ;
00224
00226 PX_INLINE bool getParamEnum(const Interface &pm, const char *name, const char *&val);
00228 PX_INLINE bool setParamEnum(Interface &pm, const char *name, const char *val) ;
00229
00231 PX_INLINE bool getParamRef(const Interface &pm, const char *name, NvParameterized::Interface *&val);
00233 PX_INLINE bool setParamRef(Interface &pm, const char *name, NvParameterized::Interface *val, bool doDestroyOld = false) ;
00234
00236 PX_INLINE bool initParamRef(Interface &pm, const char *name, const char *className, bool doDestroyOld = false);
00238 PX_INLINE bool initParamRef(Interface &pm, const char *name, const char *className, const char *objName, bool doDestroyOld = false);
00239
00241 PX_INLINE bool getParamI8(const Interface &pm, const char *name, int8_t &val);
00243 PX_INLINE bool setParamI8(Interface &pm, const char *name, int8_t val) ;
00244
00246 PX_INLINE bool getParamI16(const Interface &pm, const char *name, int16_t &val);
00248 PX_INLINE bool setParamI16(Interface &pm, const char *name, int16_t val) ;
00249
00251 PX_INLINE bool getParamI32(const Interface &pm, const char *name, int32_t &val);
00253 PX_INLINE bool setParamI32(Interface &pm, const char *name, int32_t val) ;
00254
00256 PX_INLINE bool getParamI64(const Interface &pm, const char *name, int64_t &val);
00258 PX_INLINE bool setParamI64(Interface &pm, const char *name, int64_t val) ;
00259
00261 PX_INLINE bool getParamU8(const Interface &pm, const char *name, uint8_t &val);
00263 PX_INLINE bool setParamU8(Interface &pm, const char *name, uint8_t val) ;
00264
00266 PX_INLINE bool getParamU16(const Interface &pm, const char *name, uint16_t &val);
00268 PX_INLINE bool setParamU16(Interface &pm, const char *name, uint16_t val) ;
00269
00271 PX_INLINE bool getParamU32(const Interface &pm, const char *name, uint32_t &val);
00273 PX_INLINE bool setParamU32(Interface &pm, const char *name, uint32_t val) ;
00274
00276 PX_INLINE bool getParamU64(const Interface &pm, const char *name, uint64_t &val);
00278 PX_INLINE bool setParamU64(Interface &pm, const char *name, uint64_t val) ;
00279
00281 PX_INLINE bool getParamF32(const Interface &pm, const char *name, float &val);
00283 PX_INLINE bool setParamF32(Interface &pm, const char *name, float val) ;
00284
00286 PX_INLINE bool getParamF64(const Interface &pm, const char *name, double &val);
00288 PX_INLINE bool setParamF64(Interface &pm, const char *name, double val) ;
00289
00291 PX_INLINE bool getParamVec2(const Interface &pm, const char *name, physx::PxVec2 &val);
00293 PX_INLINE bool setParamVec2(Interface &pm, const char *name, const physx::PxVec2 &val) ;
00294
00296 PX_INLINE bool getParamVec3(const Interface &pm, const char *name, physx::PxVec3 &val);
00298 PX_INLINE bool setParamVec3(Interface &pm, const char *name, const physx::PxVec3 &val) ;
00299
00301 PX_INLINE bool getParamVec4(const Interface &pm, const char *name, physx::PxVec4 &val);
00303 PX_INLINE bool setParamVec4(Interface &pm, const char *name, const physx::PxVec4 &val) ;
00304
00306 PX_INLINE bool getParamQuat(const Interface &pm, const char *name, physx::PxQuat &val);
00308 PX_INLINE bool setParamQuat(Interface &pm, const char *name, const physx::PxQuat &val) ;
00309
00311 PX_INLINE bool getParamMat33(const Interface &pm, const char *name, physx::PxMat33 &val);
00313 PX_INLINE bool setParamMat33(Interface &pm, const char *name, const physx::PxMat33 &val) ;
00314
00316 PX_INLINE bool getParamMat44(const Interface &pm, const char *name, physx::PxMat44 &val);
00318 PX_INLINE bool setParamMat44(Interface &pm, const char *name, const physx::PxMat44 &val) ;
00319
00321 PX_INLINE bool getParamBounds3(const Interface &pm, const char *name, physx::PxBounds3 &val);
00323 PX_INLINE bool setParamBounds3(Interface &pm, const char *name, const physx::PxBounds3 &val) ;
00324
00326 PX_INLINE bool getParamTransform(const Interface &pm, const char *name, physx::PxTransform &val);
00328 PX_INLINE bool setParamTransform(Interface &pm, const char *name, const physx::PxTransform &val) ;
00329
00330 } // namespace NvParameterized
00331
00332
00333 #include "NvParamUtils.inl"
00334
00335 #endif // NV_PARAM_UTILS_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: NvParameterized.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Enumerations
NvParameterized.h File Reference

NvParameterized classes. More...

#include "foundation/PxVec2.h"
#include "foundation/PxVec3.h"
#include "foundation/PxVec4.h"
#include "foundation/PxQuat.h"
#include "foundation/PxBounds3.h"
#include "foundation/PxMat44.h"
#include <stdio.h>
#include <stdarg.h>
#include <new>
#include "NvParameterized.inl"

Go to the source code of this file.

Classes

class | NvParameterized::Hint
Provides hints about the parameter definition. More...
class | NvParameterized::Definition
Provides information about a parameter. More...
class | NvParameterized::Handle
Provides access to individual parameters within the NvParameterized object. More...
class | NvParameterized::SerializationCallback
A callback class for notification just prior to serialization. More...
class | NvParameterized::Interface
Represents the interface to the NvParameterized object. More...

Namespaces

namespace | NvParameterized

NvParameterized namespace.

Enumerations

enum NvParameterized::ErrorType {
ERROR_NONE = 0,
ERROR_TYPE_NOT_SUPPORTED,
ERROR_INDEX_OUT_OF_RANGE,
ERROR_INVALID_PARAMETER_NAME,
ERROR_INVALID_PARAMETER_HANDLE,
ERROR_CAST_FAILED,
ERROR_INVALID_ENUM_VAL,
ERROR_SYNTAX_ERROR_IN_NAME,
ERROR_IS_LEAF_NODE,
ERROR_RESULT_BUFFER_OVERFLOW,
ERROR_NAME_DOES_NOT_MATCH_DEFINITION,
ERROR_NOT_AN_ARRAY,
ERROR_ARRAY_SIZE_IS_FIXED,
ERROR_ARRAY_RESIZING_IS_NOT_SUPPORTED,
ERROR_ARRAY_IS_TOO_SMALL,
ERROR_INVALID_ARRAY_DIMENSION,
ERROR_INVALID_ARRAY_SIZE,
ERROR_PARAMETER_HANDLE_DOES_NOT_MATCH_CLASS,
ERROR_MEMORY_ALLOCATION_FAILURE,
ERROR_INVALID_REFERENCE_INCLUDE_HINT,
ERROR_INVALID_REFERENCE_VALUE,
ERROR_PARAMETER_HANDLE_NOT_INITIALIZED,
ERROR_PARAMETER_DEFINITIONS_DO_NOT_MATCH,
ERROR_HANDLE_MISSING_INTERFACE_POINTER,
ERROR_HANDLE_INVALID_INTERFACE_POINTER,
ERROR_INVALID_CALL_ON_NAMED_REFERENCE,
ERROR_NOT_IMPLEMENTED,
ERROR_OBJECT_CONSTRUCTION_FAILED,
ERROR_MODIFY_CONST_HANDLE
}
Various errors that may be returned from NvParameterized calls.
enum NvParameterized::DataType {
TYPE_UNDEFINED = 0,
NvParameterized::TYPE_ARRAY = 1,
TYPE_STRUCT = 2,
TYPE_BOOL = 3,
NvParameterized::TYPE_STRING = 4,
NvParameterized::TYPE_ENUM = 5,
NvParameterized::TYPE_REF = 6,
TYPE_I8 = 7,
TYPE_I16 = 8,
TYPE_I32 = 9,
TYPE_I64 = 10,
TYPE_U8 = 11,
TYPE_U16 = 12,
TYPE_U32 = 13,
TYPE_U64 = 14,
TYPE_F32 = 15,
TYPE_F64 = 16,
TYPE_VEC2 = 17,
TYPE_VEC3 = 18,
TYPE_VEC4 = 19,
TYPE_QUAT = 20,
TYPE_MAT33 = 21,
TYPE_BOUNDS3 = 23,
TYPE_MAT44 = 24,
TYPE_POINTER = 25,
TYPE_TRANSFORM = 26,
TYPE_MAT34 = 27,
TYPE_LAST
}
These types are supported in NvParameterized schemas. More...

Detailed Description

NvParameterized classes.

APEX uses a framework called NvParameterized for storing asset and actor data. NvParameterized classes provide reflection on every parameter they include making it effective for serialization and auto-generation of user interfaces for tools.

NvParameterized stores data in C++ classes which are auto-generated from their descriptions written in a special domain specific language (DSL). Description files contain information on internal layout and various high-level metadata of corresponding classes and their members. All generated classes implement special interface for run time reflection and modification of data.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: NvParameterized.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
NvParameterized.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2008-2018 NVIDIA Corporation. All rights reserved.
00027
00028 #ifndef NV_PARAMETERIZED_H
00029 #define NV_PARAMETERIZED_H
00030
00048 #include "foundation/PxVec2.h"
00049 #include "foundation/PxVec3.h"
00050 #include "foundation/PxVec4.h"
00051 #include "foundation/PxQuat.h"
00052 #include "foundation/PxBounds3.h"
00053 #include "foundation/PxMat44.h"
00054 #include <stdio.h>
00055 #include <stdarg.h>
00056 #include <new> // for placement new
00057
00058 PX_PUSH_PACK_DEFAULT
00059
00061 namespace NvParameterized
00062 {
00063
00064 class Interface;
00065 class Traits;
00066
00070 enum ErrorType
00071 {
00072    ERROR_NONE = 0,
00073    ERROR_TYPE_NOT_SUPPORTED,
00074    ERROR_INDEX_OUT_OF_RANGE,
00075    ERROR_INVALID_PARAMETER_NAME,
00076    ERROR_INVALID_PARAMETER_HANDLE,
00077    ERROR_CAST_FAILED,
00078    ERROR_INVALID_ENUM_VAL,
00079    ERROR_SYNTAX_ERROR_IN_NAME,
00080    ERROR_IS_LEAF_NODE,
00081    ERROR_RESULT_BUFFER_OVERFLOW,
00082    ERROR_NAME_DOES_NOT_MATCH_DEFINITION,
00083    ERROR_NOT_AN_ARRAY,
00084    ERROR_ARRAY_SIZE_IS_FIXED,
00085    ERROR_ARRAY_RESIZING_IS_NOT_SUPPORTED,
00086    ERROR_ARRAY_IS_TOO_SMALL,
00087    ERROR_INVALID_ARRAY_DIMENSION,
00088    ERROR_INVALID_ARRAY_SIZE,
00089    ERROR_PARAMETER_HANDLE_DOES_NOT_MATCH_CLASS,
00090    ERROR_MEMORY_ALLOCATION_FAILURE,
00091    ERROR_INVALID_REFERENCE_INCLUDE_HINT,
00092    ERROR_INVALID_REFERENCE_VALUE,
00093    ERROR_PARAMETER_HANDLE_NOT_INITIALIZED,
00094    ERROR_PARAMETER_DEFINITIONS_DO_NOT_MATCH,
00095    ERROR_HANDLE_MISSING_INTERFACE_POINTER,
00096    ERROR_HANDLE_INVALID_INTERFACE_POINTER,
00097    ERROR_INVALID_CALL_ON_NAMED_REFERENCE,
00098    ERROR_NOT_IMPLEMENTED,
00099    ERROR_OBJECT_CONSTRUCTION_FAILED,
00100    ERROR_MODIFY_CONST_HANDLE
00101 };
00102
00107 enum DataType
00108 {
00109     TYPE_UNDEFINED = 0,
00110
00115     TYPE_ARRAY = 1,
00116
00117     TYPE_STRUCT = 2,
00118
00119     TYPE_BOOL = 3,
00124     TYPE_STRING = 4,
00125
00130     TYPE_ENUM = 5,
00131
00143     TYPE_REF = 6,
00144
00145     TYPE_I8 = 7,
00146     TYPE_I16 = 8,
00147     TYPE_I32 = 9,
00148     TYPE_I64 = 10,
00149
00150     TYPE_U8 = 11,
00151     TYPE_U16 = 12,
00152     TYPE_U32 = 13,
00153     TYPE_U64 = 14,
00154
00155     TYPE_F32 = 15,
00156     TYPE_F64 = 16,
00157
00158     TYPE_VEC2 = 17,
00159     TYPE_VEC3 = 18,
00160     TYPE_VEC4 = 19,
00161     TYPE_QUAT = 20,
00162     TYPE_MAT33 = 21,
00163     TYPE_BOUNDS3 = 23,
00164     TYPE_MAT44 = 24,
00165
00166     TYPE_POINTER = 25,
00167
00168     TYPE_TRANSFORM = 26,
00169
00170     TYPE_MAT34 = 27,
00171
00172     TYPE_LAST
00173 };
00174
00180 class Hint
00181 {
00182     public:
00183
00187     virtual ~Hint() {}
00191     virtual const char *    name(void) const = 0;
00192
00196     virtual DataType         type(void) const = 0;
00197
00202     virtual    uint64_t             asUInt(void) const = 0;
00203
00208     virtual double             asFloat(void) const = 0;
00209
00214     virtual const char *    asString(void) const = 0;
00215
00219     virtual bool setAsUInt(uint64_t v) = 0;
00220
00221     private:
00222 };
00223
00227 class Definition
00228 {
00229 public:
00230
00234     virtual ~Definition() {}
00235
00239     virtual void destroy() = 0;
00240
00244     virtual int32_t                             numHints(void) const = 0;
00245
00250     virtual const Hint *                    hint(int32_t index) const = 0;
00251
00256     virtual const Hint *                    hint(const char *name) const = 0;
00257
00262     virtual void                            setHints(const Hint **hints, int32_t n) = 0;
00263
00268     virtual void                            addHint(Hint *hint) = 0;
00269
00274     virtual const Definition *    parent(void) const = 0;
00275
00279     virtual const Definition *    root(void) const = 0;
00280
00284     virtual const char *                    name(void) const = 0;
00285
00291     virtual const char *                    longName(void) const = 0;
00292
00297     virtual const char *                    structName(void) const = 0;
00298
00302     virtual DataType                        type(void) const = 0;
00303
00307     virtual const char*                     typeString() const = 0;
00308
00314     virtual    int32_t                             numRefVariants(void) const = 0;
00315
00320     virtual    int32_t                             refVariantValIndex( const char * ref_val ) const = 0;
00321
00325     virtual    const char *                     refVariantVal(int32_t index) const = 0;
00326
00330     virtual int32_t                             numEnumVals(void) const = 0;
00331
00336     virtual    int32_t                             enumValIndex( const char * enum_val ) const = 0;
00337
00342     virtual const char *                    enumVal(int32_t index) const = 0;
00343
00348     virtual void                             setEnumVals(const char **enum_vals, int32_t n) = 0;
00349
00354     virtual void                             addEnumVal(const char *enum_val) = 0;
00355
00359     virtual uint32_t alignment(void) const = 0;
00360
00364     virtual uint32_t padding(void) const = 0;
00365
00369     virtual int32_t arrayDimension(void) const = 0;
00370
00375     virtual int32_t arraySize(int32_t dimension = 0) const = 0;
00376
00380     virtual bool arraySizeIsFixed(void) const = 0;
00381
00386     virtual bool setArraySize(int32_t size) = 0; // -1 if the size is not fixed
00387
00391     virtual bool isLeaf(void) const = 0;
00392
00396     virtual bool isIncludedRef(void) const = 0;
00397
00401     virtual int32_t numChildren(void) const = 0;
00402
00406     virtual const Definition *child(int32_t index) const = 0;
00407
00412     virtual const Definition *child(const char *name, int32_t &index) const = 0;
00413
00418     virtual void setChildren(Definition **children, int32_t n) = 0;
00419
00424     virtual void addChild(Definition *child) = 0;
00425
00429     virtual void setDynamicHandleIndicesMap(const uint8_t *indices, uint32_t numIndices) = 0;
00430
00434     virtual const uint8_t * getDynamicHandleIndicesMap(uint32_t &outNumIndices) const = 0;
00435
00441     virtual bool isSimpleType(bool simpleStructs = true, bool simpleStrings = true) const = 0;
00442 };
00443
00447 class Handle
00448 {
00449 public:
00450
00451     enum { MAX_DEPTH = 16 };
00452
00456     PX_INLINE Handle(::NvParameterized::Interface *iface);
00457
00461     PX_INLINE Handle(::NvParameterized::Interface &iface);
00462
00467     PX_INLINE Handle(const ::NvParameterized::Interface &iface);
00468
00472     PX_INLINE Handle(const Handle &param_handle);
00473
00477     PX_INLINE Handle(::NvParameterized::Interface &instance, const char *longName);
00478
00483     PX_INLINE Handle(const ::NvParameterized::Interface &instance, const char *longName);
00484
00488     PX_INLINE const Definition *parameterDefinition(void) const { return(mParameterDefinition); }
00489
00493     PX_INLINE int32_t numIndexes(void) const { return(mNumIndexes); }
00494
00498     PX_INLINE int32_t index(int32_t i) const { return(mIndexList[i]); }
00499
00503     PX_INLINE int32_t popIndex(int32_t levels = 1);
00504
00508     PX_INLINE ErrorType set(const ::NvParameterized::Interface *instance, const Definition *root, const char *child_long_name);
00509
00513     PX_INLINE ErrorType set(const ::NvParameterized::Interface *instance, const char *child_long_name);
00514
00522     PX_INLINE ErrorType getParameter(const char *longName);
00523
00530     PX_INLINE ErrorType set(int32_t child_index);
00531
00537     PX_INLINE ErrorType getChildHandle(const ::NvParameterized::Interface *instance, const char *child_long_name, Handle &outHandle);
00538
00543     PX_INLINE ErrorType getChildHandle(int32_t index, Handle &outHandle);
00544
00549     PX_INLINE bool getLongName(char *str, uint32_t max_str_len) const;
00550
00554     PX_INLINE void reset();
00555
00559     PX_INLINE bool isConst(void) const { return(mIsConst); }
00560
00564     PX_INLINE bool isValid(void) const { return(mIsValid); }
00565
00569     PX_INLINE operator bool() const { return(isValid()); }
00570
00574     PX_INLINE const void *userData(void) const { return(mUserData); }
00575
00579     PX_INLINE void *userData(void) { return(mUserData); }
00580
00584     PX_INLINE void setUserData(void *user_data) { mUserData = user_data; }
00585
00590     PX_INLINE ::NvParameterized::Interface * getInterface(void) const { return mIsConst ? 0 : mInterface; }
00591
00595     PX_INLINE const ::NvParameterized::Interface * getConstInterface(void) const { return mInterface; }
00596
00600     PX_INLINE void setInterface(::NvParameterized::Interface *iface) { mIsConst = false; mInterface = iface; }
00601
00605     PX_INLINE void setInterface(const ::NvParameterized::Interface *iface) { mIsConst = true; mInterface = (::NvParameterized::Interface *)iface; }
00606
00617     PX_INLINE ErrorType initParamRef(const char *chosenRefStr = 0, bool doDestroyOld = false);
00618
00626     PX_INLINE ErrorType valueToStr(char *buf, uint32_t bufSize, const char *&ret);
00627
00633     PX_INLINE ErrorType strToValue(const char *str, const char **endptr);
00634
00638     ErrorType resizeArray(int32_t new_size);
00639
00643     PX_INLINE ErrorType getArraySize(int32_t &size, int32_t dimension = 0) const;
00644
00648     PX_INLINE ErrorType swapArrayElements(uint32_t firstElement, uint32_t secondElement);
00649
00650     // These functions wrap the raw(Get|Set)XXXXX() methods.  They deal with
00651     // error handling and casting.
00652
00656     PX_INLINE ErrorType getParamBool(bool &val) const ;
00657
00661     PX_INLINE ErrorType setParamBool(bool val) ;
00662
00666     PX_INLINE ErrorType getParamBoolArray(bool *array, int32_t n, int32_t offset = 0) const ;
00667
00671     PX_INLINE ErrorType setParamBoolArray(const bool *array, int32_t n, int32_t offset = 0) ;
00672
00676     PX_INLINE ErrorType getParamString(const char *&val) const ;
00677
00681     PX_INLINE ErrorType setParamString(const char *val) ;
00682
00686     PX_INLINE ErrorType getParamStringArray(char **array, int32_t n, int32_t offset = 0) const ;
00687
00691     PX_INLINE ErrorType setParamStringArray(const char **array, int32_t n, int32_t offset = 0) ;
00692
00696     PX_INLINE ErrorType getParamEnum(const char *&val) const ;
00697
00701     PX_INLINE ErrorType setParamEnum(const char *val) ;
00702
00706     PX_INLINE ErrorType getParamEnumArray(char **array, int32_t n, int32_t offset = 0) const ;
00707
00711     PX_INLINE ErrorType setParamEnumArray(const char **array, int32_t n, int32_t offset = 0) ;
00712
00716     PX_INLINE ErrorType getParamRef(::NvParameterized::Interface *&val) const ;
00717
00721     PX_INLINE ErrorType getParamRefArray(::NvParameterized::Interface **array, int32_t n, int32_t offset = 0) const ;
00722
00726     PX_INLINE ErrorType setParamRef(::NvParameterized::Interface * val, bool doDestroyOld = false) ;
00727
00731     PX_INLINE ErrorType setParamRefArray(::NvParameterized::Interface **array, int32_t n, int32_t offset = 0, bool doDestroyOld = false) ;
00732
00736     PX_INLINE ErrorType getParamI8(int8_t &val) const ;
00737
00741     PX_INLINE ErrorType setParamI8(int8_t val) ;
00742
00746     PX_INLINE ErrorType getParamI8Array(int8_t *array, int32_t n, int32_t offset = 0) const ;
00747
00751     PX_INLINE ErrorType setParamI8Array(const int8_t *val, int32_t n, int32_t offset = 0) ;
00752
00756     PX_INLINE ErrorType getParamI16(int16_t &val) const ;
00757
00761     PX_INLINE ErrorType setParamI16(int16_t val) ;
00762
00766     PX_INLINE ErrorType getParamI16Array(int16_t *array, int32_t n, int32_t offset = 0) const ;
00767
00771     PX_INLINE ErrorType setParamI16Array(const int16_t *val, int32_t n, int32_t offset = 0) ;
00772
00776     PX_INLINE ErrorType getParamI32(int32_t &val) const ;
00777
00781     PX_INLINE ErrorType setParamI32(int32_t val) ;
00782
00786     PX_INLINE ErrorType getParamI32Array(int32_t *array, int32_t n, int32_t offset = 0) const ;
00787
00791     PX_INLINE ErrorType setParamI32Array(const int32_t *val, int32_t n, int32_t offset = 0) ;
00792
00796     PX_INLINE ErrorType getParamI64(int64_t &val) const ;
00797
00801     PX_INLINE ErrorType setParamI64(int64_t val) ;
00802
00806     PX_INLINE ErrorType getParamI64Array(int64_t *array, int32_t n, int32_t offset = 0) const ;
00807
00811     PX_INLINE ErrorType setParamI64Array(const int64_t *val, int32_t n, int32_t offset = 0) ;
00812
00816     PX_INLINE ErrorType getParamU8(uint8_t &val) const ;
00817
00821     PX_INLINE ErrorType setParamU8(uint8_t val) ;
00822
00826     PX_INLINE ErrorType getParamU8Array(uint8_t *array, int32_t n, int32_t offset = 0) const ;
00827
00831     PX_INLINE ErrorType setParamU8Array(const uint8_t *val, int32_t n, int32_t offset = 0) ;
00832
00836     PX_INLINE ErrorType getParamU16(uint16_t &val) const ;
00837
00841     PX_INLINE ErrorType setParamU16(uint16_t val) ;
00842
00846     PX_INLINE ErrorType getParamU16Array(uint16_t *array, int32_t n, int32_t offset = 0) const ;
00847
00851     PX_INLINE ErrorType setParamU16Array(const uint16_t *array, int32_t n, int32_t offset = 0) ;
00852
00856     PX_INLINE ErrorType getParamU32(uint32_t &val) const ;
00857
00861     PX_INLINE ErrorType setParamU32(uint32_t val) ;
00862
00866     PX_INLINE ErrorType getParamU32Array(uint32_t *array, int32_t n, int32_t offset = 0) const ;
00867
00871     PX_INLINE ErrorType setParamU32Array(const uint32_t *array, int32_t n, int32_t offset = 0) ;
00872
00876     PX_INLINE ErrorType getParamU64(uint64_t &val) const ;
00877
00881     PX_INLINE ErrorType setParamU64(uint64_t val) ;
00882
00886     PX_INLINE ErrorType getParamU64Array(uint64_t *array, int32_t n, int32_t offset = 0) const ;
00887
00891     PX_INLINE ErrorType setParamU64Array(const uint64_t *array, int32_t n, int32_t offset = 0) ;
00892
00896     PX_INLINE ErrorType getParamF32(float &val) const ;
00897
00901     PX_INLINE ErrorType setParamF32(float val) ;
00902
00906     PX_INLINE ErrorType getParamF32Array(float *array, int32_t n, int32_t offset = 0) const ;
00907
00911     PX_INLINE ErrorType setParamF32Array(const float *array, int32_t n, int32_t offset = 0) ;
00912
00916     PX_INLINE ErrorType getParamF64(double &val) const ;
00917
00921     PX_INLINE ErrorType setParamF64(double val) ;
00922
00926     PX_INLINE ErrorType getParamF64Array(double *array, int32_t n, int32_t offset = 0) const ;
00927
00931     PX_INLINE ErrorType setParamF64Array(const double *array, int32_t n, int32_t offset = 0) ;
00932
00936     PX_INLINE ErrorType setParamVec2(const physx::PxVec2 &val) ;
00937
00941     PX_INLINE ErrorType getParamVec2(physx::PxVec2 &val) const ;
00942
00946     PX_INLINE ErrorType getParamVec2Array(physx::PxVec2 *array, int32_t n, int32_t offset = 0) const ;
00947
00951     PX_INLINE ErrorType setParamVec2Array(const physx::PxVec2 *array, int32_t n, int32_t offset = 0) ;
00952
00956     PX_INLINE ErrorType setParamVec3(const physx::PxVec3 &val) ;
00957
00961     PX_INLINE ErrorType getParamVec3(physx::PxVec3 &val) const ;
00962
00966     PX_INLINE ErrorType getParamVec3Array(physx::PxVec3 *array, int32_t n, int32_t offset = 0) const ;
00967
00971     PX_INLINE ErrorType setParamVec3Array(const physx::PxVec3 *array, int32_t n, int32_t offset = 0) ;
00972
00976     PX_INLINE ErrorType setParamVec4(const physx::PxVec4 &val) ;
00977
00981     PX_INLINE ErrorType getParamVec4(physx::PxVec4 &val) const ;
00982
00986     PX_INLINE ErrorType getParamVec4Array(physx::PxVec4 *array, int32_t n, int32_t offset = 0) const ;
00987
00991     PX_INLINE ErrorType setParamVec4Array(const physx::PxVec4 *array, int32_t n, int32_t offset = 0) ;
00992
00996     PX_INLINE ErrorType setParamQuat(const physx::PxQuat &val) ;
00997
01001     PX_INLINE ErrorType getParamQuat(physx::PxQuat &val) const ;
01002
01006     PX_INLINE ErrorType getParamQuatArray(physx::PxQuat *array, int32_t n, int32_t offset = 0) const ;
01007
01011     PX_INLINE ErrorType setParamQuatArray(const physx::PxQuat *array, int32_t n, int32_t offset = 0) ;
01012
01016     PX_INLINE ErrorType setParamMat33(const physx::PxMat33 &val) ;
01017
01021     PX_INLINE ErrorType getParamMat33(physx::PxMat33 &val) const ;
01022
01026     PX_INLINE ErrorType getParamMat33Array(physx::PxMat33 *array, int32_t n, int32_t offset = 0) const ;
01027
01031     PX_INLINE ErrorType setParamMat33Array(const physx::PxMat33 *array, int32_t n, int32_t offset = 0) ;
01032
01036     PX_INLINE ErrorType setParamMat44(const physx::PxMat44 &val) ;
01037
01041     PX_INLINE ErrorType getParamMat44(physx::PxMat44 &val) const ;
01042
01046     PX_INLINE ErrorType getParamMat44Array(physx::PxMat44 *array, int32_t n, int32_t offset = 0) const ;
01047
01051     PX_INLINE ErrorType setParamMat44Array(const physx::PxMat44 *array, int32_t n, int32_t offset = 0) ;
01052
01056     PX_INLINE ErrorType setParamMat34Legacy(const float (&val)[12]) ;
01057
01061     PX_INLINE ErrorType getParamMat34Legacy(float (&val)[12]) const ;
01062
01066     PX_INLINE ErrorType getParamMat34LegacyArray(float* array, int32_t n, int32_t offset = 0) const ;
01067
01071     PX_INLINE ErrorType setParamMat34LegacyArray(const float *array, int32_t n, int32_t offset = 0) ;
01072
01076     PX_INLINE ErrorType setParamBounds3(const physx::PxBounds3 &val) ;
01077
01081     PX_INLINE ErrorType getParamBounds3(physx::PxBounds3 &val) const ;
01082
01086     PX_INLINE ErrorType getParamBounds3Array(physx::PxBounds3 *array, int32_t n, int32_t offset = 0) const ;
01087
01091     PX_INLINE ErrorType setParamBounds3Array(const physx::PxBounds3 *array, int32_t n, int32_t offset = 0) ;
01092
01096     PX_INLINE ErrorType setParamTransform(const physx::PxTransform &val) ;
01097
01101     PX_INLINE ErrorType getParamTransform(physx::PxTransform &val) const ;
01102
01106     PX_INLINE ErrorType getParamTransformArray(physx::PxTransform *array, int32_t n, int32_t offset = 0) const ;
01107
01111     PX_INLINE ErrorType setParamTransformArray(const physx::PxTransform *array, int32_t n, int32_t offset = 0) ;
01112
01113
01115     template <typename T> PX_INLINE ErrorType setParam(const T &val);
01116
01118     template <typename T> PX_INLINE ErrorType getParam(T &val) const;
01119
01121     template <typename T> PX_INLINE ErrorType getParamArray(T *array, int32_t n, int32_t offset = 0) const;
01122
01124     template <typename T> PX_INLINE ErrorType setParamArray(const T *array, int32_t n, int32_t offset = 0);
01125
01126 private:
01127
01128     PX_INLINE void pushIndex(int32_t index);
01129
01130     bool mIsValid, mIsConst;
01131     int32_t mNumIndexes;
01132     int32_t mIndexList[MAX_DEPTH];
01133     const Definition *mParameterDefinition;
01134     void *mUserData;
01135     ::NvParameterized::Interface    *mInterface;
01136 };
01137
01139 class SerializationCallback
01140 {
01141 public:
01142     virtual ~SerializationCallback() {}
01144     virtual void preSerialize(void* userData = NULL) = 0;
01145 };
01146
01147
01151 class Interface
01152 {
01153     friend class Handle;
01154 public:
01155
01159     virtual ~Interface() {}
01160
01164     virtual void destroy() = 0;
01165
01169     virtual void initDefaults(void) = 0;
01170
01174     virtual void initRandom(void) = 0;
01175
01179     virtual const char * className(void) const = 0;
01180
01187     virtual void setClassName(const char *name) = 0;
01188
01193     virtual const char * name(void) const = 0;
01194
01199     virtual void setName(const char *name) = 0;
01200
01204     virtual uint32_t version(void) const = 0;
01205
01209     virtual uint16_t getMajorVersion(void) const = 0;
01210
01214     virtual uint16_t getMinorVersion(void) const = 0;
01215
01221     virtual const uint32_t * checksum(uint32_t &bits) const = 0;
01222
01226     virtual int32_t numParameters(void) = 0;
01227
01231     virtual const Definition *parameterDefinition(int32_t index) = 0;
01232
01236     virtual const Definition *rootParameterDefinition(void) = 0;
01237
01241     virtual const Definition *rootParameterDefinition(void) const = 0;
01242
01250     virtual ErrorType getParameterHandle(const char *longName, Handle  &handle) const = 0;
01251
01259     virtual ErrorType getParameterHandle(const char *longName, Handle  &handle) = 0;
01260
01262     virtual void setSerializationCallback(SerializationCallback *cb, void *userData = NULL) = 0;
01263
01265     virtual ErrorType callPreSerializeCallback() const = 0;
01266
01267
01276     virtual bool equals(const ::NvParameterized::Interface &obj, Handle* handlesOfInequality = NULL, uint32_t numHandlesOfInequality = 0, bool doCompareNotSerialized = true) const = 0;
01277
01284     virtual bool areParamsOK(Handle *invalidHandles = NULL, uint32_t numInvalidHandles = 0) = 0;
01285
01290     virtual ErrorType copy(const ::NvParameterized::Interface &src) = 0;
01291
01296     virtual ErrorType clone(Interface *&nullDestObject) const = 0;
01297
01302     virtual bool checkAlignments() const = 0;
01303
01304 protected:
01310     virtual ErrorType initParamRef(const Handle &handle, const char *chosenRefStr = 0, bool doDestroyOld = false) = 0;
01311
01312     // These functions wrap the raw(Get|Set)XXXXX() methods.  They deal with
01313     // error handling and casting.
01314
01318     virtual ErrorType getParamBool(const Handle &handle, bool &val) const = 0;
01319
01323     virtual ErrorType setParamBool(const Handle &handle, bool val) = 0;
01324
01328     virtual ErrorType getParamBoolArray(const Handle &handle, bool *array, int32_t n, int32_t offset = 0) const = 0;
01329
01333     virtual ErrorType setParamBoolArray(const Handle &handle, const bool *array, int32_t n, int32_t offset = 0) = 0;
01334
01338     virtual ErrorType getParamString(const Handle &handle, const char *&val) const = 0;
01339
01343     virtual ErrorType setParamString(const Handle &handle, const char *val) = 0;
01344
01348     virtual ErrorType getParamStringArray(const Handle &handle, char **array, int32_t n, int32_t offset = 0) const = 0;
01349
01353     virtual ErrorType setParamStringArray(const Handle &handle, const char **array, int32_t n, int32_t offset = 0) = 0;
01354
01358     virtual ErrorType getParamEnum(const Handle &handle, const char *&val) const = 0;
01359
01363     virtual ErrorType setParamEnum(const Handle &handle, const char *val) = 0;
01364
01368     virtual ErrorType getParamEnumArray(const Handle &handle, char **array, int32_t n, int32_t offset = 0) const = 0;
01369
01373     virtual ErrorType setParamEnumArray(const Handle &handle, const char **array, int32_t n, int32_t offset = 0) = 0;
01374
01378     virtual ErrorType getParamRef(const Handle &handle, ::NvParameterized::Interface *&val) const = 0;
01379
01383     virtual ErrorType getParamRefArray(const Handle &handle, ::NvParameterized::Interface **array, int32_t n, int32_t offset = 0) const = 0;
01384
01388     virtual ErrorType setParamRef(const Handle &handle, ::NvParameterized::Interface * val, bool doDestroyOld = false) = 0;
01389
01393     virtual ErrorType setParamRefArray(const Handle &handle, /*const*/ ::NvParameterized::Interface **array, int32_t n, int32_t offset = 0, bool doDestroyOld = false) = 0;
01394
01398     virtual ErrorType getParamI8(const Handle &handle, int8_t &val) const = 0;
01399
01403     virtual ErrorType setParamI8(const Handle &handle, int8_t val) = 0;
01404
01408     virtual ErrorType getParamI8Array(const Handle &handle, int8_t *array, int32_t n, int32_t offset = 0) const = 0;
01409
01413     virtual ErrorType setParamI8Array(const Handle &handle, const int8_t *val, int32_t n, int32_t offset = 0) = 0;
01414
01418     virtual ErrorType getParamI16(const Handle &handle, int16_t &val) const = 0;
01419
01423     virtual ErrorType setParamI16(const Handle &handle, int16_t val) = 0;
01424
01428     virtual ErrorType getParamI16Array(const Handle &handle, int16_t *array, int32_t n, int32_t offset = 0) const = 0;
01429
01433     virtual ErrorType setParamI16Array(const Handle &handle, const int16_t *val, int32_t n, int32_t offset = 0) = 0;
01434
01438     virtual ErrorType getParamI32(const Handle &handle, int32_t &val) const = 0;
01439
01443     virtual ErrorType setParamI32(const Handle &handle, int32_t val) = 0;
01444
01448     virtual ErrorType getParamI32Array(const Handle &handle, int32_t *array, int32_t n, int32_t offset = 0) const = 0;
01449
01453     virtual ErrorType setParamI32Array(const Handle &handle, const int32_t *val, int32_t n, int32_t offset = 0) = 0;
01454
01458     virtual ErrorType getParamI64(const Handle &handle, int64_t &val) const = 0;
01459
01463     virtual ErrorType setParamI64(const Handle &handle, int64_t val) = 0;
01464
01468     virtual ErrorType getParamI64Array(const Handle &handle, int64_t *array, int32_t n, int32_t offset = 0) const = 0;
01469
01473     virtual ErrorType setParamI64Array(const Handle &handle, const int64_t *val, int32_t n, int32_t offset = 0) = 0;
01474
01478     virtual ErrorType getParamU8(const Handle &handle, uint8_t &val) const = 0;
01479
01483     virtual ErrorType setParamU8(const Handle &handle, uint8_t val) = 0;
01484
01488     virtual ErrorType getParamU8Array(const Handle &handle, uint8_t *array, int32_t n, int32_t offset = 0) const = 0;
01489
01493     virtual ErrorType setParamU8Array(const Handle &handle, const uint8_t *val, int32_t n, int32_t offset = 0) = 0;
01494
01498     virtual ErrorType getParamU16(const Handle &handle, uint16_t &val) const = 0;
01499
01503     virtual ErrorType setParamU16(const Handle &handle, uint16_t val) = 0;
01504
01508     virtual ErrorType getParamU16Array(const Handle &handle, uint16_t *array, int32_t n, int32_t offset = 0) const = 0;
01509
01513     virtual ErrorType setParamU16Array(const Handle &handle, const uint16_t *array, int32_t n, int32_t offset = 0) = 0;
01514
01518     virtual ErrorType getParamU32(const Handle &handle, uint32_t &val) const = 0;
01519
01523     virtual ErrorType setParamU32(const Handle &handle, uint32_t val) = 0;
01524
01528     virtual ErrorType getParamU32Array(const Handle &handle, uint32_t *array, int32_t n, int32_t offset = 0) const = 0;
01529
01533     virtual ErrorType setParamU32Array(const Handle &handle, const uint32_t *array, int32_t n, int32_t offset = 0) = 0;
01534
01538     virtual ErrorType getParamU64(const Handle &handle, uint64_t &val) const = 0;
01539
01543     virtual ErrorType setParamU64(const Handle &handle, uint64_t val) = 0;
01544
01548     virtual ErrorType getParamU64Array(const Handle &handle, uint64_t *array, int32_t n, int32_t offset = 0) const = 0;
01549
01553     virtual ErrorType setParamU64Array(const Handle &handle, const uint64_t *array, int32_t n, int32_t offset = 0) = 0;
01554
01558     virtual ErrorType getParamF32(const Handle &handle, float &val) const = 0;
01559
01563     virtual ErrorType setParamF32(const Handle &handle, float val) = 0;
01564
01568     virtual ErrorType getParamF32Array(const Handle &handle, float *array, int32_t n, int32_t offset = 0) const = 0;
01569
01573     virtual ErrorType setParamF32Array(const Handle &handle, const float *array, int32_t n, int32_t offset = 0) = 0;
01574
01578     virtual ErrorType getParamF64(const Handle &handle, double &val) const = 0;
01579
01583     virtual ErrorType setParamF64(const Handle &handle, double val) = 0;
01584
01588     virtual ErrorType getParamF64Array(const Handle &handle, double *array, int32_t n, int32_t offset = 0) const = 0;
01589
01593     virtual ErrorType setParamF64Array(const Handle &handle, const double *array, int32_t n, int32_t offset = 0) = 0;
01594
01598     virtual ErrorType setParamVec2(const Handle &handle, const physx::PxVec2 &val) = 0;
01599
01603     virtual ErrorType getParamVec2(const Handle &handle, physx::PxVec2 &val) const = 0;
01604
01608     virtual ErrorType getParamVec2Array(const Handle &handle, physx::PxVec2 *array, int32_t n, int32_t offset = 0) const = 0;
01609
01613     virtual ErrorType setParamVec2Array(const Handle &handle, const physx::PxVec2 *array, int32_t n, int32_t offset = 0) = 0;
01614
01618     virtual ErrorType setParamVec3(const Handle &handle, const physx::PxVec3 &val) = 0;
01619
01623     virtual ErrorType getParamVec3(const Handle &handle, physx::PxVec3 &val) const = 0;
01624
01628     virtual ErrorType getParamVec3Array(const Handle &handle, physx::PxVec3 *array, int32_t n, int32_t offset = 0) const = 0;
01629
01633     virtual ErrorType setParamVec3Array(const Handle &handle, const physx::PxVec3 *array, int32_t n, int32_t offset = 0) = 0;
01634
01638     virtual ErrorType setParamVec4(const Handle &handle, const physx::PxVec4 &val) = 0;
01639
01643     virtual ErrorType getParamVec4(const Handle &handle, physx::PxVec4 &val) const = 0;
01644
01648     virtual ErrorType getParamVec4Array(const Handle &handle, physx::PxVec4 *array, int32_t n, int32_t offset = 0) const = 0;
01649
01653     virtual ErrorType setParamVec4Array(const Handle &handle, const physx::PxVec4 *array, int32_t n, int32_t offset = 0) = 0;
01654
01658     virtual ErrorType setParamQuat(const Handle &handle, const physx::PxQuat &val) = 0;
01659
01663     virtual ErrorType getParamQuat(const Handle &handle, physx::PxQuat &val) const = 0;
01664
01668     virtual ErrorType getParamQuatArray(const Handle &handle, physx::PxQuat *array, int32_t n, int32_t offset = 0) const = 0;
01669
01673     virtual ErrorType setParamQuatArray(const Handle &handle, const physx::PxQuat *array, int32_t n, int32_t offset = 0) = 0;
01674
01678     virtual ErrorType setParamMat33(const Handle &handle, const physx::PxMat33 &val) = 0;
01679
01683     virtual ErrorType getParamMat33(const Handle &handle, physx::PxMat33 &val) const = 0;
01684
01688     virtual ErrorType getParamMat33Array(const Handle &handle, physx::PxMat33 *array, int32_t n, int32_t offset = 0) const = 0;
01689
01693     virtual ErrorType setParamMat33Array(const Handle &handle, const physx::PxMat33 *array, int32_t n, int32_t offset = 0) = 0;
01694
01698     virtual ErrorType setParamMat44(const Handle &handle, const physx::PxMat44 &val) = 0;
01699
01703     virtual ErrorType getParamMat44(const Handle &handle, physx::PxMat44 &val) const = 0;
01704
01708     virtual ErrorType getParamMat44Array(const Handle &handle, physx::PxMat44 *array, int32_t n, int32_t offset = 0) const = 0;
01709
01713     virtual ErrorType setParamMat44Array(const Handle &handle, const physx::PxMat44 *array, int32_t n, int32_t offset = 0) = 0;
01714
01718     virtual ErrorType setParamMat34Legacy(const Handle &handle, const float (&val)[12]) = 0;
01719
01723     virtual ErrorType getParamMat34Legacy(const Handle &handle, float (&val)[12]) const = 0;
01724
01728     virtual ErrorType getParamMat34LegacyArray(const Handle &handle, float *array, int32_t n, int32_t offset = 0) const = 0;
01729
01733     virtual ErrorType setParamMat34LegacyArray(const Handle &handle, const float *array, int32_t n, int32_t offset = 0) = 0;
01734
01738     virtual ErrorType setParamBounds3(const Handle &handle, const physx::PxBounds3 &val) = 0;
01739
01743     virtual ErrorType getParamBounds3(const Handle &handle, physx::PxBounds3 &val) const = 0;
01744
01748     virtual ErrorType getParamBounds3Array(const Handle &handle, physx::PxBounds3 *array, int32_t n, int32_t offset = 0) const = 0;
01749
01753     virtual ErrorType setParamTransform(const Handle &handle, const physx::PxTransform &val) = 0;
01754
01758     virtual ErrorType getParamTransform(const Handle &handle, physx::PxTransform &val) const = 0;
01759
01763     virtual ErrorType getParamTransformArray(const Handle &handle, physx::PxTransform *array, int32_t n, int32_t offset = 0) const = 0;
01764
01768     virtual ErrorType setParamTransformArray(const Handle &handle, const physx::PxTransform *array, int32_t n, int32_t offset = 0) = 0;
01769
01773     virtual ErrorType setParamBounds3Array(const Handle &handle, const physx::PxBounds3 *array, int32_t n, int32_t offset = 0) = 0;
01774
01779     virtual ErrorType valueToStr(const Handle &handle, char *buf, uint32_t bufSize, const char *&ret) = 0;
01780
01785     virtual ErrorType strToValue(Handle &handle,const char *str, const char **endptr) = 0; // assigns this string to the value
01786
01791     virtual ErrorType resizeArray(const Handle &array_handle, int32_t new_size) = 0;
01792
01797     virtual ErrorType getArraySize(const Handle &array_handle, int32_t &size, int32_t dimension = 0) const = 0;
01798
01803     virtual ErrorType swapArrayElements(const Handle &array_handle, uint32_t firstElement, uint32_t secondElement) = 0;
01804 };
01805
01806 } // end of namespace
01807
01808 #include "NvParameterized.inl" // inline the NvParamterHandle methods.
01809
01810 PX_POP_PACK
01811
01812 #endif // NV_PARAMETERIZED_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: NvParameterized_types.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
NvParameterized_types.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2008-2018 NVIDIA Corporation. All rights reserved.
00027
00034 // NV_PARAMETERIZED_TYPE(type_name, enum_name, c_type)
00035
00036 #if PX_VC && !PX_PS4
00037     #pragma warning(push)
00038     #pragma warning(disable:4555)
00039 #endif  //!PX_PS4
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #ifndef NV_PARAMETERIZED_TYPES_ONLY_SIMPLE_TYPES
00044 #ifndef NV_PARAMETERIZED_TYPES_ONLY_SCALAR_TYPES
00045 NV_PARAMETERIZED_TYPE(Array, ARRAY, void *)
00046 NV_PARAMETERIZED_TYPE(Struct, STRUCT, void *)
00047 NV_PARAMETERIZED_TYPE(Ref, REF, NvParameterized::Interface *)
00048 #endif
00049 #endif
00050
00051 #ifndef NV_PARAMETERIZED_TYPES_NO_STRING_TYPES
00052 #ifndef NV_PARAMETERIZED_TYPES_ONLY_SCALAR_TYPES
00053 NV_PARAMETERIZED_TYPE(String, STRING, const char *)
00054 NV_PARAMETERIZED_TYPE(Enum, ENUM, const char *)
00055 #endif
00056 #endif
00057
00058 NV_PARAMETERIZED_TYPE(Bool, BOOL, bool)
00059
00060 NV_PARAMETERIZED_TYPE(I8,  I8,  int8_t)
00061 NV_PARAMETERIZED_TYPE(I16, I16, int16_t)
00062 NV_PARAMETERIZED_TYPE(I32, I32, int32_t)
00063 NV_PARAMETERIZED_TYPE(I64, I64, int64_t)
00064
00065 NV_PARAMETERIZED_TYPE(U8,  U8,  uint8_t)
00066 NV_PARAMETERIZED_TYPE(U16, U16, uint16_t)
00067 NV_PARAMETERIZED_TYPE(U32, U32, uint32_t)
00068 NV_PARAMETERIZED_TYPE(U64, U64, uint64_t)
00069
00070 NV_PARAMETERIZED_TYPE(F32, F32, float)
00071 NV_PARAMETERIZED_TYPE(F64, F64, double)
00072
00073 #ifndef NV_PARAMETERIZED_TYPES_ONLY_SCALAR_TYPES
00074 NV_PARAMETERIZED_TYPE(Vec2,      VEC2,      physx::PxVec2)
00075 NV_PARAMETERIZED_TYPE(Vec3,      VEC3,      physx::PxVec3)
00076 NV_PARAMETERIZED_TYPE(Vec4,      VEC4,      physx::PxVec4)
00077 NV_PARAMETERIZED_TYPE(Quat,      QUAT,      physx::PxQuat)
00078 NV_PARAMETERIZED_TYPE(Bounds3,   BOUNDS3,   physx::PxBounds3)
00079 NV_PARAMETERIZED_TYPE(Mat33,     MAT33,     physx::PxMat33)
00080 NV_PARAMETERIZED_TYPE(Mat44,     MAT44,     physx::PxMat44)
00081 NV_PARAMETERIZED_TYPE(Transform, TRANSFORM, physx::PxTransform)
00082 #endif
00083
00084
00085 #ifdef NV_PARAMETERIZED_TYPES_ONLY_SIMPLE_TYPES
00086 #   undef NV_PARAMETERIZED_TYPES_ONLY_SIMPLE_TYPES
00087 #endif
00088
00089 #ifdef NV_PARAMETERIZED_TYPES_NO_STRING_TYPES
00090 #   undef NV_PARAMETERIZED_TYPES_NO_STRING_TYPES
00091 #endif
00092
00093 #ifdef NV_PARAMETERIZED_TYPES_ONLY_SCALAR_TYPES
00094 #   undef NV_PARAMETERIZED_TYPES_ONLY_SCALAR_TYPES
00095 #endif
00096
00097 #ifdef NV_PARAMETERIZED_TYPES_NO_LEGACY_TYPES
00098 #   undef NV_PARAMETERIZED_TYPES_NO_LEGACY_TYPES
00099 #endif
00100
00101 #if PX_VC && !PX_PS4
00102     #pragma warning(pop)
00103 #endif  //!PX_PS4
00104
00105 PX_POP_PACK
00106
00107 #undef NV_PARAMETERIZED_TYPE
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: NvParameterizedMacroses.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
NvParameterizedMacroses.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2008-2018 NVIDIA Corporation. All rights reserved.
00027
00028 #ifndef NV_PARAMETERIZED_MACROSES_H
00029 #define NV_PARAMETERIZED_MACROSES_H
00030
00033 #define NV_PARAMETRIZED_AGGREGATE_DATATYPE_LABELS \
00034 case NvParameterized::TYPE_ARRAY:\
00035 case NvParameterized::TYPE_STRUCT:\
00036
00037 #define NV_PARAMETRIZED_LINAL_DATATYPE_LABELS \
00038 case NvParameterized::TYPE_VEC2:\
00039 case NvParameterized::TYPE_VEC3:\
00040 case NvParameterized::TYPE_VEC4:\
00041 case NvParameterized::TYPE_QUAT:\
00042 case NvParameterized::TYPE_MAT33:\
00043 case NvParameterized::TYPE_BOUNDS3:\
00044 case NvParameterized::TYPE_MAT44:\
00045 case NvParameterized::TYPE_TRANSFORM:\
00046 case NvParameterized::TYPE_MAT34:
00047
00048 #define NV_PARAMETRIZED_ARITHMETIC_DATATYPE_LABELS \
00049 case NvParameterized::TYPE_I8:\
00050 case NvParameterized::TYPE_I16:\
00051 case NvParameterized::TYPE_I32:\
00052 case NvParameterized::TYPE_I64:\
00053 case NvParameterized::TYPE_U8:\
00054 case NvParameterized::TYPE_U16:\
00055 case NvParameterized::TYPE_U32:\
00056 case NvParameterized::TYPE_U64:\
00057 case NvParameterized::TYPE_F32:\
00058 case NvParameterized::TYPE_F64:\
00059 case NvParameterized::TYPE_BOOL:
00060
00061 #define NV_PARAMETRIZED_STRING_DATATYPE_LABELS \
00062 case NvParameterized::TYPE_STRING:
00063
00064 #define NV_PARAMETRIZED_REF_DATATYPE_LABELS \
00065 case NvParameterized::TYPE_REF:
00066
00067 #define NV_PARAMETRIZED_ENUM_DATATYPE_LABELS \
00068 case NvParameterized::TYPE_ENUM:
00069
00070 #define NV_PARAMETRIZED_SERVICE_DATATYPE_LABELS \
00071 case NvParameterized::TYPE_POINTER:
00072
00073 #define NV_PARAMETRIZED_UNDEFINED_AND_LAST_DATATYPE_LABELS \
00074 case NvParameterized::TYPE_UNDEFINED:\
00075 case NvParameterized::TYPE_LAST:
00076
00078 /***********************************************************************/
00079 #define NV_PARAMETRIZED_NO_AGGREGATE_DATATYPE_LABELS \
00080 /* NV_PARAMETRIZED_AGGREGATE_DATATYPE_LABELS*/ \
00081 NV_PARAMETRIZED_LINAL_DATATYPE_LABELS \
00082 NV_PARAMETRIZED_ARITHMETIC_DATATYPE_LABELS \
00083 NV_PARAMETRIZED_STRING_DATATYPE_LABELS \
00084 NV_PARAMETRIZED_REF_DATATYPE_LABELS \
00085 NV_PARAMETRIZED_ENUM_DATATYPE_LABELS \
00086 NV_PARAMETRIZED_SERVICE_DATATYPE_LABELS \
00087 NV_PARAMETRIZED_UNDEFINED_AND_LAST_DATATYPE_LABELS
00088
00089 #define NV_PARAMETRIZED_NO_AGGREGATE_AND_ARITHMETIC_DATATYPE_LABELS \
00090 /* NV_PARAMETRIZED_AGGREGATE_DATATYPE_LABELS*/ \
00091 NV_PARAMETRIZED_LINAL_DATATYPE_LABELS \
00092 /*NV_PARAMETRIZED_ARITHMETIC_DATATYPE_LABELS*/ \
00093 NV_PARAMETRIZED_STRING_DATATYPE_LABELS \
00094 NV_PARAMETRIZED_REF_DATATYPE_LABELS \
00095 NV_PARAMETRIZED_ENUM_DATATYPE_LABELS \
00096 NV_PARAMETRIZED_SERVICE_DATATYPE_LABELS \
00097 NV_PARAMETRIZED_UNDEFINED_AND_LAST_DATATYPE_LABELS
00098
00099 #define NV_PARAMETRIZED_NO_AGGREGATE_AND_REF_DATATYPE_LABELS \
00100 /* NV_PARAMETRIZED_AGGREGATE_DATATYPE_LABELS*/ \
00101 NV_PARAMETRIZED_LINAL_DATATYPE_LABELS \
00102 NV_PARAMETRIZED_ARITHMETIC_DATATYPE_LABELS \
00103 NV_PARAMETRIZED_STRING_DATATYPE_LABELS \
00104 /*NV_PARAMETRIZED_REF_DATATYPE_LABELS*/ \
00105 NV_PARAMETRIZED_ENUM_DATATYPE_LABELS \
00106 NV_PARAMETRIZED_SERVICE_DATATYPE_LABELS \
00107 NV_PARAMETRIZED_UNDEFINED_AND_LAST_DATATYPE_LABELS
00108
00109 #define NV_PARAMETRIZED_NO_ARITHMETIC_AND_LINAL_DATATYPE_LABELS \
00110 NV_PARAMETRIZED_AGGREGATE_DATATYPE_LABELS \
00111 /*NV_PARAMETRIZED_LINAL_DATATYPE_LABELS*/ \
00112 /*NV_PARAMETRIZED_ARITHMETIC_DATATYPE_LABELS*/ \
00113 NV_PARAMETRIZED_STRING_DATATYPE_LABELS \
00114 NV_PARAMETRIZED_REF_DATATYPE_LABELS \
00115 NV_PARAMETRIZED_ENUM_DATATYPE_LABELS \
00116 NV_PARAMETRIZED_SERVICE_DATATYPE_LABELS \
00117 NV_PARAMETRIZED_UNDEFINED_AND_LAST_DATATYPE_LABELS
00118
00119 #define NV_PARAMETRIZED_SERVICE_AND_LAST_DATATYPE_LABELS \
00120 NV_PARAMETRIZED_SERVICE_DATATYPE_LABELS \
00121 case NvParameterized::TYPE_LAST:
00122
00123 #define NV_PARAMETRIZED_LEGACY_DATATYPE_LABELS \
00124 case NvParameterized::TYPE_MAT34:
00125
00126 #define NV_PARAMETRIZED_NO_MATH_DATATYPE_LABELS \
00127 NV_PARAMETRIZED_AGGREGATE_DATATYPE_LABELS \
00128 NV_PARAMETRIZED_STRING_DATATYPE_LABELS \
00129 NV_PARAMETRIZED_REF_DATATYPE_LABELS \
00130 NV_PARAMETRIZED_ENUM_DATATYPE_LABELS \
00131 NV_PARAMETRIZED_SERVICE_DATATYPE_LABELS \
00132 NV_PARAMETRIZED_UNDEFINED_AND_LAST_DATATYPE_LABELS
00133
00134 /***********************************************************************/
00135
00136 #endif // NV_PARAMETERIZED_MACROSES_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: NvParameterizedTraits.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
NvParameterizedTraits.h File Reference

NvParameterized traits class. More...

#include <string.h>
#include "foundation/PxAssert.h"

Go to the source code of this file.

Classes

class | NvParameterized::Factory
Interface class for NvParameterized factories. More...
class | NvParameterized::Conversion
Interface class for legacy object conversions. More...
class | NvParameterized::Traits
Interface class for user traits. More...
class | NvParameterized::Traits::Allocator
Adapter for allocator classes in PxAlloctor.h. More...

Namespaces

namespace | NvParameterized

NvParameterized namespace.

Detailed Description

NvParameterized traits class.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: NvParameterizedTraits.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
NvParameterizedTraits.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2008-2018 NVIDIA Corporation. All rights reserved.
00027
00028 #ifndef NV_PARAMETERIZED_TRAITS_H
00029 #define NV_PARAMETERIZED_TRAITS_H
00030
00036 #include <string.h>
00037 #include "foundation/PxAssert.h"
00038
00039 namespace NvParameterized
00040 {
00041
00042 PX_PUSH_PACK_DEFAULT
00043
00044 class Traits;
00045 class Interface;
00046
00050 class Factory
00051 {
00052 public:
00053
00057     virtual ::NvParameterized::Interface *create( Traits *paramTraits ) = 0;
00058
00062     virtual ::NvParameterized::Interface *finish( Traits *paramTraits, void *obj, void *buf, int32_t *refCount ) = 0;
00063
00067     virtual const char * getClassName() = 0;
00068
00072     virtual uint32_t getVersion() = 0;
00073
00077     virtual uint32_t getAlignment() = 0;
00078
00082     virtual const uint32_t * getChecksum( uint32_t &bits ) = 0;
00083
00087     virtual ~Factory() {}
00088
00092     virtual void freeParameterDefinitionTable(NvParameterized::Traits* traits) = 0;
00093 };
00094
00098 class Conversion
00099 {
00100 public:
00101     virtual ~Conversion() {}
00102
00110     virtual bool operator()(::NvParameterized::Interface &legacyObj, ::NvParameterized::Interface &obj) = 0;
00111
00115     virtual void release() = 0;
00116 };
00117
00124 class Traits
00125 {
00126 public:
00127     virtual ~Traits() {}
00128
00132     virtual void registerFactory( ::NvParameterized::Factory & factory ) = 0;
00133
00138     virtual ::NvParameterized::Factory *removeFactory( const char * className ) = 0;
00139
00144     virtual ::NvParameterized::Factory *removeFactory( const char * className, uint32_t version ) = 0;
00145
00149     virtual bool doesFactoryExist(const char* className) = 0;
00150
00154     virtual bool doesFactoryExist(const char* className, uint32_t version) = 0;
00155
00163     virtual ::NvParameterized::Interface * createNvParameterized( const char * name ) = 0;
00164
00173     virtual ::NvParameterized::Interface * createNvParameterized( const char * name, uint32_t ver ) = 0;
00174
00180     virtual ::NvParameterized::Interface * finishNvParameterized( const char * name, void *obj, void *buf, int32_t *refCount ) = 0;
00181
00187     virtual ::NvParameterized::Interface * finishNvParameterized( const char * name, uint32_t ver, void *obj, void *buf, int32_t *refCount ) = 0;
00188
00192     virtual uint32_t getCurrentVersion(const char *className) const = 0;
00193
00197     virtual uint32_t getAlignment(const char *className, uint32_t classVersion) const = 0;
00198
00202     virtual void registerConversion(const char * /*className*/, uint32_t /*from*/, uint32_t /*to*/, Conversion & /*conv*/) {}
00203
00207     virtual ::NvParameterized::Conversion *removeConversion(const char * /*className*/, uint32_t /*from*/, uint32_t /*to*/) { return 0; }
00208
00216     virtual bool updateLegacyNvParameterized(::NvParameterized::Interface &legacyObj, ::NvParameterized::Interface &obj)
00217     {
00218         PX_UNUSED(&legacyObj);
00219         PX_UNUSED(&obj);
00220
00221         return false;
00222     }
00223
00235     virtual bool getNvParameterizedNames( const char ** names, uint32_t &outCount, uint32_t inCount) const = 0;
00236
00249     virtual bool getNvParameterizedVersions(const char* className, uint32_t* versions, uint32_t &outCount, uint32_t inCount) const = 0;
00250
00254     virtual int32_t incRefCount(int32_t *refCount) = 0;
00255
00259     virtual int32_t decRefCount(int32_t *refCount) = 0;
00260
00264     virtual void onInplaceObjectDestroyed(void * /*buf*/, ::NvParameterized::Interface * /*obj*/) {}
00265
00269     virtual void onAllInplaceObjectsDestroyed(void *buf) { free(buf); }
00270
00274     virtual void *alloc(uint32_t nbytes) = 0;
00275
00279     virtual void *alloc(uint32_t nbytes, uint32_t align) = 0;
00280
00284     virtual void free(void *buf) = 0;
00285
00289     virtual char *strdup(const char *str)
00290     {
00291         if( !str )
00292             return NULL;
00293
00294         uint32_t strLen = (uint32_t)strlen(str) + 1;
00295         char *retStr = (char *)this->alloc(strLen, 1);
00296
00297         PX_ASSERT( retStr );
00298
00299         if( NULL != retStr )
00300 #if PX_WINDOWS_FAMILY || PX_XBOXONE
00301             strcpy_s( retStr, strLen, str );
00302 #else
00303             strncpy(retStr, str, strLen);
00304 #endif
00305         return retStr;
00306     }
00307
00311     virtual void strfree(char *str)
00312     {
00313         if( NULL != str )
00314             this->free( str );
00315     }
00316
00320     virtual void traitsWarn(const char * /*msg*/) const {}
00321
00325     virtual void release(void) = 0;
00326
00330     class Allocator
00331     {
00332 		::NvParameterized::Traits *mTraits;
00333
00334     public:
00335
00339         Allocator(Traits *traits): mTraits(traits) {}
00340
00344         void *allocate(size_t size)
00345         {
00346             return allocate(size, __FILE__, __LINE__);
00347         }
00348
00352         void *allocate(size_t size, const char * /*filename*/, int /*line*/)
00353         {
00354             PX_ASSERT( static_cast<uint32_t>(size) == size );
00355             return mTraits->alloc(static_cast<uint32_t>(size));
00356         }
00357
00361         void deallocate(void *ptr)
00362         {
00363             return mTraits->free(ptr);
00364         }
00365     };
00366 };
00367
00368
00369 PX_POP_PACK
00370
00371 } // namespace NvParameterized
00372
00373 #endif // NV_PARAMETERIZED_TRAITS_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: NvSerializer.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
NvSerializer.h File Reference

NvParameterized serializer class. More...

#include <filebuf/PxFileBuf.h>
#include "NvSerializer.inl"

Go to the source code of this file.

Classes

struct | NvParameterized::SerializePlatform
Platform descriptor. More...
class | NvParameterized::Serializer
Interface class for serializer-deserializer of NvParameterized objects. More...
class | NvParameterized::Serializer::DeserializedResults< T, bufSize >
TODO. More...
struct | NvParameterized::Serializer::MetadataEntry
This class keeps metadata of a single NvParameterized class. More...

Namespaces

namespace | NvParameterized

NvParameterized namespace.

Detailed Description

NvParameterized serializer class.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: NvSerializer.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
NvSerializer.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2008-2018 NVIDIA Corporation. All rights reserved.
00027
00028 #ifndef NV_SERIALIZER_H
00029 #define NV_SERIALIZER_H
00030
00037 #include <filebuf/PxFileBuf.h>
00038
00039
00040 namespace NvParameterized
00041 {
00042
00043 PX_PUSH_PACK_DEFAULT
00044
00050 struct SerializePlatform
00051 {
00056     typedef enum
00057     {
00058         ARCH_GEN = 0,
00059         ARCH_X86 = 1,
00060         ARCH_X86_64 = 2,
00061         ARCH_PPC = 3,
00062         ARCH_CELL = 4,
00063         ARCH_ARM = 5,
00064         ARCH_ARM_64 = 6,
00065         ARCH_LAST
00066     } ArchType;
00067
00071     ArchType archType;
00072
00077     typedef enum
00078     {
00079         COMP_GEN = 0,
00080         COMP_GCC = 1,
00081         COMP_VC = 2,
00082         COMP_MW = 3,
00083         COMP_LAST
00084     } CompilerType;
00085
00089     CompilerType compilerType;
00090
00094     uint32_t compilerVer;
00095
00100     typedef enum
00101     {
00102         OS_WINDOWS = 0,
00103         OS_LINUX = 1,
00104         OS_LV2 = 2, // PS3
00105         OS_MACOSX = 3,
00106         OS_XBOX = 4,
00107         OS_GEN = 5,
00108         OS_ANDROID = 6,
00109         OS_XBOXONE = 7,
00110         OS_PS4 = 8,
00111         OS_HOS = 9,
00112         OS_LAST
00113     } OsType;
00114
00118     OsType osType;
00119
00123     uint32_t osVer;
00124
00128     static const uint32_t ANY_VERSION = (uint32_t)-1;
00129
00130     PX_INLINE SerializePlatform();
00131
00135     PX_INLINE SerializePlatform(ArchType archType, CompilerType compType, uint32_t compVer, OsType osType, uint32_t osVer);
00136
00140     PX_INLINE bool operator ==(const SerializePlatform &p) const;
00141
00145     PX_INLINE bool operator !=(const SerializePlatform &p) const;
00146 };
00147
00148 class Interface;
00149 class Definition;
00150 class Traits;
00151 struct SerializePlatform;
00152
00159 class Serializer
00160 {
00161 public:
00162
00166     enum ErrorType
00167     {
00168         ERROR_NONE = 0,
00169
00170         ERROR_UNKNOWN,
00171         ERROR_NOT_IMPLEMENTED,
00172
00173         // File format related errors
00174         ERROR_INVALID_PLATFORM,
00175         ERROR_INVALID_PLATFORM_NAME,
00176         ERROR_INVALID_FILE_VERSION,
00177         ERROR_INVALID_FILE_FORMAT,
00178         ERROR_INVALID_MAGIC,
00179         ERROR_INVALID_CHAR,
00180
00181         // External errors
00182         ERROR_STREAM_ERROR,
00183         ERROR_MEMORY_ALLOCATION_FAILURE,
00184         ERROR_UNALIGNED_MEMORY,
00185         ERROR_PRESERIALIZE_FAILED,
00186         ERROR_INTERNAL_BUFFER_OVERFLOW,
00187         ERROR_OBJECT_CREATION_FAILED,
00188         ERROR_CONVERSION_FAILED,
00189
00190         // Xml-specific errors
00191         ERROR_VAL2STRING_FAILED,
00192         ERROR_STRING2VAL_FAILED,
00193         ERROR_INVALID_TYPE_ATTRIBUTE,
00194         ERROR_UNKNOWN_XML_TAG,
00195         ERROR_MISSING_DOCTYPE,
00196         ERROR_MISSING_ROOT_ELEMENT,
00197         ERROR_INVALID_NESTING,
00198         ERROR_INVALID_ATTR,
00199
00200         // Other stuff
00201         ERROR_INVALID_ARRAY,
00202         ERROR_ARRAY_INDEX_OUT_OF_RANGE,
00203         ERROR_INVALID_VALUE,
00204         ERROR_INVALID_INTERNAL_PTR,
00205         ERROR_INVALID_PARAM_HANDLE,
00206         ERROR_INVALID_RELOC_TYPE,
00207         ERROR_INVALID_DATA_TYPE,
00208         ERROR_INVALID_REFERENCE
00209     };
00210
00214     enum SerializeType
00215     {
00217         NST_XML = 0,
00218
00220         NST_BINARY,
00221
00222         NST_LAST
00223     };
00224
00229     static SerializeType peekSerializeType(physx::general_PxIOStream2::PxFileBuf &stream);
00230
00236     static ErrorType peekPlatform(physx::general_PxIOStream2::PxFileBuf &stream, SerializePlatform &platform);
00237
00238     virtual ~Serializer() {}
00239
00250     virtual ErrorType setTargetPlatform(const SerializePlatform &platform) = 0;
00251
00260     virtual void setAutoUpdate(bool doUpdate) = 0;
00261
00271     virtual ErrorType serialize(
00272         physx::general_PxIOStream2::PxFileBuf &stream,
00273         const ::NvParameterized::Interface **objs,
00274         uint32_t nobjs,
00275         bool doSerializeMetadata = false) = 0;
00276
00284     virtual ErrorType peekNumObjects(physx::general_PxIOStream2::PxFileBuf &stream, uint32_t &numObjects) = 0;
00285
00294     virtual ErrorType peekClassNames(physx::general_PxIOStream2::PxFileBuf &stream, char **classNames, uint32_t &numClassNames) = 0;
00295
00302     virtual ErrorType peekNumObjectsInplace(const void *data, uint32_t dataLen, uint32_t &numObjects) = 0;
00303
00305     template < typename T, int bufSize = 8 > class DeserializedResults
00306     {
00307         T buf[bufSize]; //For small number of objects
00308
00309         T *objs;
00310
00311         uint32_t nobjs;
00312
00313         Traits *traits;
00314
00315         void clear();
00316
00317     public:
00318
00319         PX_INLINE DeserializedResults();
00320
00321         PX_INLINE ~DeserializedResults();
00322
00326         PX_INLINE DeserializedResults(const DeserializedResults &data);
00327
00331         PX_INLINE DeserializedResults &operator =(const DeserializedResults &rhs);
00332
00336         PX_INLINE void init(Traits *traits_, uint32_t nobjs_);
00337
00341         PX_INLINE void init(Traits *traits_, T *objs_, uint32_t nobjs_);
00342
00346         PX_INLINE uint32_t size() const;
00347
00351         PX_INLINE T &operator[](uint32_t i);
00352
00356         PX_INLINE const T &operator[](uint32_t i) const;
00357
00362         PX_INLINE void getObjects(T *outObjs);
00363
00367         PX_INLINE void releaseAll();
00368     };
00369
00375     typedef DeserializedResults< ::NvParameterized::Interface *> DeserializedData;
00376
00378     struct MetadataEntry
00379     {
00381         const char *className;
00382
00384         uint32_t version;
00385
00387         Definition *def;
00388     };
00389
00395     typedef DeserializedResults<MetadataEntry> DeserializedMetadata;
00396
00403     virtual ErrorType deserializeMetadata(physx::general_PxIOStream2::PxFileBuf &stream, DeserializedMetadata &desData);
00404
00410     virtual ErrorType deserialize(physx::general_PxIOStream2::PxFileBuf &stream, DeserializedData &desData);
00411
00418     virtual ErrorType deserialize(physx::general_PxIOStream2::PxFileBuf &stream, DeserializedData &desData, bool &isUpdated) = 0;
00419
00429     virtual ErrorType deserializeInplace(void *data, uint32_t dataLen, DeserializedData &desData);
00430
00441     virtual ErrorType deserializeInplace(void *data, uint32_t dataLen, DeserializedData &desData, bool &isUpdated) = 0;
00442
00449     virtual ErrorType peekInplaceAlignment(physx::general_PxIOStream2::PxFileBuf& stream, uint32_t& align) = 0;
00450
00454     virtual void release() = 0;
00455 };
00456
00457 PX_POP_PACK
00458
00459 } // namespace NvParameterized
00460
00461 #include "NvSerializer.inl"
00462
00463 #endif // NV_SERIALIZER_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ParticleIosActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ParticleIosActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef PARTICLE_IOS_ACTOR_H
00031 #define PARTICLE_IOS_ACTOR_H
00032
00033 #include "Apex.h"
00034
00035 #if PX_PHYSICS_VERSION_MAJOR == 3
00036 #include "ScopedPhysXLock.h"
00037 #endif
00038
00039 namespace nvidia
00040 {
00041 namespace apex
00042 {
00043
00044 PX_PUSH_PACK_DEFAULT
00045
00049 class ParticleIosActor : public Actor
00050 {
00051 public:
00052     // This actor is not publically visible
00053
00054 protected:
00055     virtual ~ParticleIosActor() {}
00056 };
00057
00058 PX_POP_PACK
00059
00060 }
00061 } // namespace nvidia
00062
00063 #endif // PARTICLE_IOS_ACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ParticleIosAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ParticleIosAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef PARTICLE_IOS_ASSET_H
00031 #define PARTICLE_IOS_ASSET_H
00032
00033 #include "Apex.h"
00034 #include <limits.h>
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define PARTICLE_IOS_AUTHORING_TYPE_NAME "ParticleIosAsset"
00044
00048 class ParticleIosAsset : public IosAsset
00049 {
00050 public:
00052     virtual float                       getParticleRadius() const = 0;
00053
00055     virtual float                       getMaxInjectedParticleCount() const = 0;
00056
00058     virtual uint32_t                    getMaxParticleCount() const = 0;
00059
00061     virtual float                       getParticleMass() const = 0;
00062
00063 protected:
00064     virtual ~ParticleIosAsset() {}
00065 };
00066
00070 class ParticleIosAssetAuthoring : public AssetAuthoring
00071 {
00072 public:
00074     virtual void setParticleRadius(float) = 0;
00075
00077     virtual void setMaxInjectedParticleCount(float count) = 0;
00078
00080     virtual void setMaxParticleCount(uint32_t count) = 0;
00081
00083     virtual void setParticleMass(float) = 0;
00084
00086     virtual void setCollisionGroupName(const char* collisionGroupName) = 0;
00087
00089     virtual void setCollisionGroupMaskName(const char* collisionGroupMaskName) = 0;
00090
00091 protected:
00092     virtual ~ParticleIosAssetAuthoring()    {}
00093 };
00094
00095 PX_POP_PACK
00096
00097 }
00098 } // namespace nvidia
00099
00100 #endif // PARTICLE_IOS_ASSET_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ParticlesPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ParticlesPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef PARTICLES_PREVIEW_H
00031 #define PARTICLES_PREVIEW_H
00032
00033 #include "Apex.h"
00034 #include "AssetPreview.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class RenderDebugInterface;
00044
00045 namespace APEX_PARTICLES
00046 {
00051 static const uint32_t PARTICLES_DRAW_NOTHING = (0x00);
00056 static const uint32_t PARTICLES_DRAW_ICON = (0x01);
00061 static const uint32_t PARTICLES_DRAW_BOUNDARIES = (0x2);
00066 static const uint32_t PARTICLES_DRAW_WITH_CYLINDERS = (0x4);
00071 static const uint32_t PARTICLES_DRAW_FULL_DETAIL = (PARTICLES_DRAW_ICON + PARTICLES_DRAW_BOUNDARIES);
00076 static const uint32_t PARTICLES_DRAW_FULL_DETAIL_BOLD = (PARTICLES_DRAW_FULL_DETAIL + PARTICLES_DRAW_WITH_CYLINDERS);
00077 }
00078
00082 class ParticlesPreview : public AssetPreview
00083 {
00084 public:
00090     virtual void    setIconScale(float scale) = 0;
00098     virtual void    setDetailLevel(uint32_t detail) = 0;
00099
00100 protected:
00101     ParticlesPreview() {};
00102 };
00103
00104
00105 PX_POP_PACK
00106
00107 }
00108 } // end namespace nvidia
00109
00110 #endif // PARTICLES_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: PhysXSDKVersion.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Defines
PhysXSDKVersion.h File Reference

Version identifiers for PhysX less configuration. More...

Go to the source code of this file.

Defines

#define | PX_PHYSICS_VERSION 0
helper PhysX version
#define | PX_PHYSICS_VERSION_MAJOR 0
helper PhysX version, major part

Detailed Description

Version identifiers for PhysX less configuration.

This file is intended to be included by ApexDefs.h

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: PhysXSDKVersion.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
PhysXSDKVersion.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2008-2018 NVIDIA Corporation. All rights reserved.
00027
00028 #ifndef PHYSX_SDK_VERSION_H
00029 #define PHYSX_SDK_VERSION_H
00030
00038
00039 #define PX_PHYSICS_VERSION 0
00040
00042 #define PX_PHYSICS_VERSION_MAJOR 0
00043
00044 #endif // PHYSX_SDK_VERSION_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: PhysXSDKVersion.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Defines
PhysXSDKVersion.h File Reference

Version identifiers for PhysX major release 3. More...

Go to the source code of this file.

Defines

#define | SDK_VERSION_NUMBER 300
helper Version number, this number should not be trusted for differentiating between different PhysX 3 versions
#define | PX_PHYSICS_VERSION_MAJOR 3
Major version of PhysX.
#define | PX_PHYSICS_VERSION_MINOR 4
Minor version of PhysX.
#define | PX_PHYSICS_VERSION_BUGFIX 2
Bugfix version of PhysX.
#define | PX_PHYSICS_VERSION ((PX_PHYSICS_VERSION_MAJOR<<24) + (PX_PHYSICS_VERSION_MINOR<<16) + (PX_PHYSICS_VERSION_BUGFIX<<8) + 0)

Detailed Description

Version identifiers for PhysX major release 3.

This file is intended to be included by ApexDefs.h

Define Documentation

#define PX_PHYSICS_VERSION ((PX_PHYSICS_VERSION_MAJOR<<24) + (PX_PHYSICS_VERSION_MINOR<<16) + (PX_PHYSICS_VERSION_BUGFIX<<8) + 0)

The constant PX_PHYSICS_VERSION is used when creating certain PhysX module objects. This is to ensure that the application is using the same header version as the library was built with.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: PhysXSDKVersion.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
PhysXSDKVersion.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef PHYSX_SDK_VERSION_H
00031 #define PHYSX_SDK_VERSION_H
00032
00040
00041 #define SDK_VERSION_NUMBER 300
00042
00044 #define PX_PHYSICS_VERSION_MAJOR 3
00045
00046 #define PX_PHYSICS_VERSION_MINOR 4
00047
00048 #define PX_PHYSICS_VERSION_BUGFIX 2
00049
00054 #define PX_PHYSICS_VERSION ((PX_PHYSICS_VERSION_MAJOR<<24) + (PX_PHYSICS_VERSION_MINOR<<16) + (PX_PHYSICS_VERSION_BUGFIX<<8) + 0)
00055
00056 #endif // PHYSX_SDK_VERSION_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: PhysXObjectDesc.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
PhysXObjectDesc.h File Reference

class PhysXObjectDesc More...

#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

class | nvidia::apex::PhysXObjectDesc
PhysX object descriptor. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class PhysXObjectDesc

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: PhysXObjectDesc.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
PhysXObjectDesc.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef PHYS_XOBJECT_DESC_H
00031 #define PHYS_XOBJECT_DESC_H
00032
00038 #include "ApexUsingNamespace.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 class Actor;
00046
00047 PX_PUSH_PACK_DEFAULT
00048
00055 class PhysXObjectDesc
00056 {
00057 protected:
00064     uint32_t                mFlags;
00065
00066     enum
00067     {
00068         TRANSFORM   = (1U << 31),
00069         RAYCASTS    = (1U << 30),
00070         CONTACTS    = (1U << 29)
00071     };
00072
00073
00074 public:
00076     virtual uint32_t                getApexActorCount() const = 0;
00078     virtual const Actor*    getApexActor(uint32_t i) const = 0;
00079
00081     bool ignoreTransform() const
00082     {
00083         return (mFlags & (uint32_t)TRANSFORM) ? true : false;
00084     }
00086     bool ignoreRaycasts() const
00087     {
00088         return (mFlags & (uint32_t)RAYCASTS) ? true : false;
00089     }
00091     bool ignoreContacts() const
00092     {
00093         return (mFlags & (uint32_t)CONTACTS) ? true : false;
00094     }
00096     bool getUserDefinedFlag(uint32_t index) const
00097     {
00098         return (mFlags & (uint32_t)(1 << index)) ? true : false;
00099     }
00100
00107     void*               userData;
00108 };
00109
00110 // To get owning Actor's authorable object type name:
00111 //      getActor()->getOwner()->getAuthObjName();
00112 // To get owning Actor's authorable object type ID:
00113 //      getActor()->getOwner()->getAuthObjType();
00114
00115 PX_POP_PACK
00116
00117 }
00118 } // end namespace nvidia::apex
00119
00120 #endif // PHYS_XOBJECT_DESC_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: PxStreamFromFileBuf.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
PxStreamFromFileBuf.h File Reference

Conversion utilities between PhysX 2.8 and 3.0 data types. More...

#include "ApexDefs.h"
#include "foundation/PxIO.h"
#include "filebuf/PxFileBuf.h"

Go to the source code of this file.

Classes

class | nvidia::apex::PxStreamFromFileBuf
A wrapper class that provides an NvStream API for a PxFileBuf. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

Conversion utilities between PhysX 2.8 and 3.0 data types.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: PxStreamFromFileBuf.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
PxStreamFromFileBuf.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef PX_STREAM_FROM_FILE_BUF_H
00031 #define PX_STREAM_FROM_FILE_BUF_H
00032
00038 #include "ApexDefs.h"
00039 #include "foundation/PxIO.h"
00040 #include "filebuf/PxFileBuf.h"
00041
00042 namespace nvidia
00043 {
00044 namespace apex
00045 {
00046
00047 PX_PUSH_PACK_DEFAULT
00048
00052 class PxStreamFromFileBuf :
00053     public physx::PxInputStream, public physx::PxOutputStream
00054 {
00055 private:
00056     physx::PxFileBuf& mFileBuf;
00057     PxStreamFromFileBuf& operator=(const PxStreamFromFileBuf&)
00058     {
00059         return *this;
00060     }
00061
00062 public:
00064     PxStreamFromFileBuf(physx::PxFileBuf& fb) : mFileBuf(fb) {}
00065
00067     uint32_t    read(void* dest, uint32_t count)
00068     {
00069         return mFileBuf.read(dest, count);
00070     }
00071
00073     uint32_t write(const void* src, uint32_t count)
00074     {
00075         return mFileBuf.write(src, count);
00076     }
00077 };
00078
00079 PX_POP_PACK
00080
00081 }
00082 } // end namespace nvidia::apex
00083
00084 #endif // PX_STREAM_FROM_FILE_BUF_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: RWLockable.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
RWLockable.h File Reference

The include containing the interface for any rw-lockable object in the APEX SDK. More...

#include "foundation/PxSimpleTypes.h"
#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

class | nvidia::apex::RWLockable
Base class for any rw-lockable object implemented by APEX SDK. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

The include containing the interface for any rw-lockable object in the APEX SDK.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: RWLockable.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
RWLockable.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RWLOCKABLE_H
00031 #define RWLOCKABLE_H
00032
00038 #include "foundation/PxSimpleTypes.h"
00039
00040 #include "ApexUsingNamespace.h"
00041
00042 namespace nvidia
00043 {
00044 namespace apex
00045 {
00046
00050 class RWLockable
00051 {
00052 public:
00061     virtual void acquireReadLock(const char *fileName, const uint32_t lineno) const = 0;
00062
00071     virtual void acquireWriteLock(const char *fileName, const uint32_t lineno) const = 0;
00072
00076     virtual void releaseReadLock(void) const = 0;
00077
00081     virtual void releaseWriteLock(void) const = 0;
00082 };
00083
00084 }
00085 }
00086 #endif // RWLOCKABLE_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: RenderBufferData.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
RenderBufferData.h File Reference

classes RenderSemanticData, RenderBufferData, ModuleSpecificRenderBufferData More...

#include "ApexUsingNamespace.h"
#include "RenderDataFormat.h"
#include "ApexSDK.h"

Go to the source code of this file.

Classes

class | nvidia::apex::RenderSemanticData
Describes the data location and layout of a single semantic. More...
class | nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >
Describes all of the semantics of a render buffer. More...
class | nvidia::apex::ModuleSpecificRenderBufferData
Describes data semantics provided by a particular module. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

classes RenderSemanticData, RenderBufferData, ModuleSpecificRenderBufferData

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: RenderBufferData.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
RenderBufferData.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RENDER_BUFFER_DATA_H
00031 #define RENDER_BUFFER_DATA_H
00032
00038 #include "ApexUsingNamespace.h"
00039 #include "RenderDataFormat.h"
00040 #include "ApexSDK.h"
00041
00042 namespace nvidia
00043 {
00044 namespace apex
00045 {
00046
00047 PX_PUSH_PACK_DEFAULT
00048
00052 class RenderSemanticData
00053 {
00054 public:
00055     const void*             data;
00056     uint32_t                stride;
00057     void*                   ident;
00058     RenderDataFormat::Enum  format;
00059
00065     RenderDataFormat::Enum  srcFormat;
00071     bool                    serialize;
00072 public:
00073     PX_INLINE RenderSemanticData(void)
00074     {
00075         data   = 0;
00076         stride = 0;
00077         ident  = 0;
00078         format = RenderDataFormat::UNSPECIFIED;
00079         srcFormat = RenderDataFormat::UNSPECIFIED;
00080         serialize = false;
00081     }
00082 };
00083
00087 template < class SemanticClass, class SemanticEnum>
00088 class RenderBufferData
00089 {
00090 public:
00091     PX_INLINE RenderBufferData(void)
00092     {
00093         m_numCustomSemantics = 0;
00094         m_customSemanticData = 0;
00095     }
00096
00100     PX_INLINE const RenderSemanticData& getSemanticData(SemanticEnum semantic) const
00101     {
00102         PX_ASSERT(semantic < SemanticClass::NUM_SEMANTICS);
00103         return m_semanticData[semantic];
00104     }
00105
00109     PX_INLINE uint32_t getNumCustomSemantics() const
00110     {
00111         return m_numCustomSemantics;
00112     }
00113
00117     PX_INLINE const RenderSemanticData& getCustomSemanticData(uint32_t index) const
00118     {
00119         PX_ASSERT(index < m_numCustomSemantics);
00120         return m_customSemanticData[index];
00121     }
00122
00129     PX_INLINE void setCustomSemanticData(RenderSemanticData* data, uint32_t num)
00130     {
00131         m_numCustomSemantics = num;
00132         m_customSemanticData = data;
00133     }
00134
00138     PX_INLINE void setSemanticData(SemanticEnum semantic, const void* data, uint32_t stride, RenderDataFormat::Enum format, RenderDataFormat::Enum srcFormat = RenderDataFormat::UNSPECIFIED)
00139     {
00140         PX_ASSERT(semantic < SemanticClass::NUM_SEMANTICS);
00141         RenderSemanticData& sd = m_semanticData[semantic];
00142         sd.data   = data;
00143         sd.stride = stride;
00144         sd.format = format;
00145         sd.srcFormat = srcFormat == RenderDataFormat::UNSPECIFIED ? format : srcFormat;
00146     }
00147
00148 private:
00149     RenderSemanticData  m_semanticData[SemanticClass::NUM_SEMANTICS];
00150     uint32_t              m_numCustomSemantics;
00151     RenderSemanticData* m_customSemanticData;
00152 };
00153
00157 class ModuleSpecificRenderBufferData
00158 {
00159 public:
00160     AuthObjTypeID           moduleId;
00161     RenderSemanticData*     moduleSpecificSemanticData;
00162     uint32_t                numModuleSpecificSemantics;
00163
00164 public:
00165     PX_INLINE ModuleSpecificRenderBufferData(void)
00166     {
00167         moduleId                   = 0;
00168         moduleSpecificSemanticData = 0;
00169         numModuleSpecificSemantics = 0;
00170     }
00171 };
00172
00173 PX_POP_PACK
00174
00175 }
00176 } // end namespace nvidia::apex
00177
00178 #endif // RENDER_BUFFER_DATA_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: RenderContext.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
RenderContext.h File Reference

class RenderContext More...

#include "ApexUsingNamespace.h"
#include "foundation/PxMat44.h"

Go to the source code of this file.

Classes

class | nvidia::apex::RenderContext
Describes the context of a renderable object. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class RenderContext

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: RenderContext.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
RenderContext.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RENDER_CONTEXT_H
00031 #define RENDER_CONTEXT_H
00032
00038 #include "ApexUsingNamespace.h"
00039 #include "foundation/PxMat44.h"
00040
00041 namespace nvidia
00042 {
00043 namespace apex
00044 {
00045
00046 class UserRenderResource;
00047 class UserOpaqueMesh;
00048
00049 PX_PUSH_PACK_DEFAULT
00050
00054 class RenderContext
00055 {
00056 public:
00057     RenderContext(void)
00058     {
00059         renderResource = 0;
00060         isScreenSpace = false;
00061         renderMeshName = NULL;
00062     }
00063
00064 public:
00065     UserRenderResource* renderResource;
00066     bool                isScreenSpace;
00067     PxMat44             local2world;
00068     PxMat44             world2local;
00069     const char*         renderMeshName;
00070 };
00071
00072 PX_POP_PACK
00073
00074 }
00075 } // end namespace nvidia::apex
00076
00077 #endif // RENDER_CONTEXT_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: RenderDataFormat.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
RenderDataFormat.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RENDER_DATA_FORMAT_H
00031 #define RENDER_DATA_FORMAT_H
00032
00033 #include "ApexUsingNamespace.h"
00034 #include "foundation/PxAssert.h"
00035 #include "foundation/PxMat44.h"
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00042 PX_PUSH_PACK_DEFAULT
00043
00049 struct RenderDataFormat
00050 {
00052     enum Enum
00053     {
00054         UNSPECIFIED =           0,
00055
00057         UBYTE1 =                1,
00058         UBYTE2 =                2,
00059         UBYTE3 =                3,
00060         UBYTE4 =                4,
00061
00062         USHORT1 =               5,
00063         USHORT2 =               6,
00064         USHORT3 =               7,
00065         USHORT4 =               8,
00066
00067         SHORT1 =                9,
00068         SHORT2 =                10,
00069         SHORT3 =                11,
00070         SHORT4 =                12,
00071
00072         UINT1 =                 13,
00073         UINT2 =                 14,
00074         UINT3 =                 15,
00075         UINT4 =                 16,
00076
00078         R8G8B8A8 =              17,
00079         B8G8R8A8 =              18,
00080         R32G32B32A32_FLOAT =    19,
00081         B32G32R32A32_FLOAT =    20,
00082
00084         BYTE_UNORM1 =           21,
00085         BYTE_UNORM2 =           22,
00086         BYTE_UNORM3 =           23,
00087         BYTE_UNORM4 =           24,
00088
00089         SHORT_UNORM1 =          25,
00090         SHORT_UNORM2 =          26,
00091         SHORT_UNORM3 =          27,
00092         SHORT_UNORM4 =          28,
00093
00094         BYTE_SNORM1 =           29,
00095         BYTE_SNORM2 =           30,
00096         BYTE_SNORM3 =           31,
00097         BYTE_SNORM4 =           32,
00098
00099         SHORT_SNORM1 =          33,
00100         SHORT_SNORM2 =          34,
00101         SHORT_SNORM3 =          35,
00102         SHORT_SNORM4 =          36,
00103
00105         HALF1 =                 37,
00106         HALF2 =                 38,
00107         HALF3 =                 39,
00108         HALF4 =                 40,
00109
00110         FLOAT1 =                41,
00111         FLOAT2 =                42,
00112         FLOAT3 =                43,
00113         FLOAT4 =                44,
00114
00115         FLOAT4x4 =              45,
00116         FLOAT3x4 =              46,
00117         FLOAT3x3 =              47,
00118
00119         FLOAT4_QUAT =           48,
00120         BYTE_SNORM4_QUATXYZW =  49,
00121         SHORT_SNORM4_QUATXYZW = 50,
00122
00123         NUM_FORMATS
00124     };
00125
00127     static PX_INLINE uint32_t getFormatDataSize(Enum format)
00128     {
00129         switch (format)
00130         {
00131         default:
00132             PX_ALWAYS_ASSERT();
00133         case UNSPECIFIED:
00134             return 0;
00135
00136         case UBYTE1:
00137         case BYTE_UNORM1:
00138         case BYTE_SNORM1:
00139             return sizeof(uint8_t);
00140         case UBYTE2:
00141         case BYTE_UNORM2:
00142         case BYTE_SNORM2:
00143             return sizeof(uint8_t) * 2;
00144         case UBYTE3:
00145         case BYTE_UNORM3:
00146         case BYTE_SNORM3:
00147             return sizeof(uint8_t) * 3;
00148         case UBYTE4:
00149         case BYTE_UNORM4:
00150         case BYTE_SNORM4:
00151         case BYTE_SNORM4_QUATXYZW:
00152             return sizeof(uint8_t) * 4;
00153
00154         case USHORT1:
00155         case SHORT1:
00156         case HALF1:
00157         case SHORT_UNORM1:
00158         case SHORT_SNORM1:
00159             return sizeof(uint16_t);
00160         case USHORT2:
00161         case SHORT2:
00162         case HALF2:
00163         case SHORT_UNORM2:
00164         case SHORT_SNORM2:
00165             return sizeof(uint16_t) * 2;
00166         case USHORT3:
00167         case SHORT3:
00168         case HALF3:
00169         case SHORT_UNORM3:
00170         case SHORT_SNORM3:
00171             return sizeof(uint16_t) * 3;
00172         case USHORT4:
00173         case SHORT4:
00174         case HALF4:
00175         case SHORT_UNORM4:
00176         case SHORT_SNORM4:
00177         case SHORT_SNORM4_QUATXYZW:
00178             return sizeof(uint16_t) * 4;
00179
00180         case UINT1:
00181             return sizeof(uint32_t);
00182         case UINT2:
00183             return sizeof(uint32_t) * 2;
00184         case UINT3:
00185             return sizeof(uint32_t) * 3;
00186         case UINT4:
00187             return sizeof(uint32_t) * 4;
00188
00189         case R8G8B8A8:
00190         case B8G8R8A8:
00191             return sizeof(uint8_t) * 4;
00192
00193         case R32G32B32A32_FLOAT:
00194         case B32G32R32A32_FLOAT:
00195             return sizeof(float) * 4;
00196
00197         case FLOAT1:
00198             return sizeof(float);
00199         case FLOAT2:
00200             return sizeof(float) * 2;
00201         case FLOAT3:
00202             return sizeof(float) * 3;
00203         case FLOAT4:
00204             return sizeof(float) * 4;
00205
00206         case FLOAT4x4:
00207             return sizeof(PxMat44);
00208
00209         case FLOAT3x4:
00210             return sizeof(float) * 12;
00211
00212         case FLOAT3x3:
00213             return sizeof(PxMat33);
00214
00215         case FLOAT4_QUAT:
00216             return sizeof(PxQuat);
00217         }
00218     }
00219 };
00220
00221 PX_POP_PACK
00222
00223 }
00224 } // end namespace nvidia::apex
00225
00226 #endif  // RENDER_DATA_FORMAT_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: RenderDataProvider.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
RenderDataProvider.h File Reference

class RenderDataProvider More...

#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

class | nvidia::apex::RenderDataProvider
An actor instance that provides renderable data. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class RenderDataProvider

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: RenderDataProvider.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
RenderDataProvider.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RENDER_DATA_PROVIDER_H
00031 #define RENDER_DATA_PROVIDER_H
00032
00038 #include "ApexUsingNamespace.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 PX_PUSH_PACK_DEFAULT
00046
00050 class RenderDataProvider
00051 {
00052 public:
00063     virtual void lockRenderResources() = 0;
00064
00070     virtual void unlockRenderResources() = 0;
00071
00086     virtual void updateRenderResources(bool rewriteBuffers = false, void* userRenderData = 0) = 0;
00087 };
00088
00089 PX_POP_PACK
00090
00091 }
00092 } // end namespace nvidia::apex
00093
00094 #endif // RENDER_DATA_PROVIDER_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: RenderDebugInterface.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Defines
RenderDebugInterface.h File Reference

debug rendering classes and structures More...

#include "ApexDefs.h"
#include "RenderDebugTyped.h"
#include "ApexInterface.h"
#include "Renderable.h"
#include "common/PxRenderBuffer.h"

Go to the source code of this file.

Classes

class | nvidia::apex::PhysXRenderBuffer
This is a helper class implementation of PxRenderBuffer that holds the counts and pointers for renderable data. Does not own the memory, simply used to transfer the state. The append method is not supported. More...
class | nvidia::apex::RenderDebugInterface
wrapper for DebugRenderable More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Defines

#define | RENDER_DEBUG_IFACE(ptr) ((ptr)->getRenderDebugInterface())
Macros for getting render debug interface for argument.

Detailed Description

debug rendering classes and structures

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: RenderDebugInterface.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
RenderDebugInterface.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RENDER_DEBUG_INTERFACE_H
00031 #define RENDER_DEBUG_INTERFACE_H
00032
00038 #include "ApexDefs.h"
00039 #include "RenderDebugTyped.h" // include the header file containing the base class
00040 #include "ApexInterface.h"
00041 #include "Renderable.h"
00042
00043 #if PX_PHYSICS_VERSION_MAJOR == 3
00044 #include "common/PxRenderBuffer.h"
00045 #endif
00046
00048 #define RENDER_DEBUG_IFACE(ptr) ((ptr)->getRenderDebugInterface())
00049
00050 namespace nvidia
00051 {
00052
00053 namespace apex
00054 {
00055 class UserRenderer;
00056 class UserRenderResourceManager;
00057
00058 PX_PUSH_PACK_DEFAULT
00059
00060 #if PX_PHYSICS_VERSION_MAJOR == 3
00061
00067 class PhysXRenderBuffer : public PxRenderBuffer
00068 {
00069 public:
00070     PhysXRenderBuffer()
00071     {
00072         clear();
00073     }
00074
00078     virtual uint32_t getNbPoints() const
00079     {
00080         return mNbPoints;
00081     }
00082
00086     virtual const PxDebugPoint* getPoints() const
00087     {
00088         return mPoints;
00089     }
00090
00094     virtual uint32_t getNbLines() const
00095     {
00096         return mNbLines;
00097     }
00098
00102     virtual const PxDebugLine* getLines() const
00103     {
00104         return mLines;
00105     }
00106
00110     virtual uint32_t getNbTriangles() const
00111     {
00112         return mNbTriangles;
00113     }
00114
00118     virtual const PxDebugTriangle* getTriangles() const
00119     {
00120         return mTriangles;
00121     }
00122
00126     virtual uint32_t getNbTexts() const
00127     {
00128         return mNbTexts;
00129     }
00130
00134     virtual const PxDebugText* getTexts() const
00135     {
00136         return mTexts;
00137     }
00138
00142     virtual void append(const PxRenderBuffer& other)
00143     {
00144         PX_UNUSED(other);
00145         PX_ALWAYS_ASSERT(); // this method not implemented!
00146     }
00147
00151     virtual void clear()
00152     {
00153         mNbPoints = 0;
00154         mPoints = NULL;
00155         mNbLines = 0;
00156         mLines = NULL;
00157         mNbTriangles = 0;
00158         mTriangles = NULL;
00159         mNbTexts = 0;
00160         mTexts = NULL;
00161     }
00162
00166     uint32_t        mNbPoints;
00170     PxDebugPoint    *mPoints;
00174     uint32_t        mNbLines;
00178     PxDebugLine     *mLines;
00182     uint32_t        mNbTriangles;
00186     PxDebugTriangle *mTriangles;
00190     uint32_t        mNbTexts;
00194     PxDebugText     *mTexts;
00195 };
00196 #endif
00197
00201 class RenderDebugInterface : public ApexInterface, public Renderable
00202 {
00203 public:
00212     virtual void    setUseDebugRenderable(bool state) = 0;
00213
00214
00215 #if PX_PHYSICS_VERSION_MAJOR == 3
00216
00224     virtual void    getRenderBuffer(PhysXRenderBuffer& renderable) = 0;
00225
00234     virtual void    getRenderBufferScreenSpace(PhysXRenderBuffer& renderable) = 0;
00235
00242     virtual void    addDebugRenderable(const physx::PxRenderBuffer& renderBuffer) = 0;
00243
00244 #endif //PX_PHYSICS_VERSION_MAJOR == 3
00245
00246     virtual void release() = 0;
00247
00251     virtual RENDER_DEBUG::RenderDebugTyped* getRenderDebugInterface() = 0;
00252
00253 protected:
00254
00255     virtual ~RenderDebugInterface(void) { };
00256
00257 };
00258
00259 PX_POP_PACK
00260
00261 }
00262 } // end namespace nvidia::apex
00263
00264 #endif // RENDER_DEBUG_INTERFACE_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: RenderMesh.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
RenderMesh.h File Reference

classes RenderSubmesh, VertexBuffer, and MaterialNamingConvention enums More...

#include "ApexUsingNamespace.h"
#include "VertexFormat.h"

Go to the source code of this file.

Classes

class | nvidia::apex::VertexBuffer
a vertex buffer that supports multiple formats More...
class | nvidia::apex::RenderSubmesh
a mesh that has only one material (or render state, in general) More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

classes RenderSubmesh, VertexBuffer, and MaterialNamingConvention enums

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: RenderMesh.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
RenderMesh.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RENDER_MESH_H
00031 #define RENDER_MESH_H
00032
00038 #include "ApexUsingNamespace.h"
00039 #include "VertexFormat.h"
00040
00041 namespace nvidia
00042 {
00043 namespace apex
00044 {
00045
00046 PX_PUSH_PACK_DEFAULT
00047
00048 class RenderMeshActor;
00049 class Context;
00050 struct VertexUV;
00051
00052
00056 class VertexBuffer
00057 {
00058 public:
00062     virtual uint32_t                getVertexCount() const = 0;
00063
00067     virtual const VertexFormat&     getFormat() const = 0;
00068
00072     virtual VertexFormat&           getFormatWritable() = 0;
00073
00078     virtual const void*             getBuffer(uint32_t bufferIndex) const = 0;
00079
00083     virtual const void*             getBufferAndFormat(RenderDataFormat::Enum& format, uint32_t bufferIndex) const = 0;
00084
00088     virtual void*                   getBufferAndFormatWritable(RenderDataFormat::Enum& format, uint32_t bufferIndex) = 0;
00089
00097     virtual bool                    getBufferData(void* dstBuffer, nvidia::RenderDataFormat::Enum dstBufferFormat, uint32_t dstBufferStride, uint32_t bufferIndex,
00098                                                   uint32_t startVertexIndex, uint32_t elementCount) const = 0;
00099
00100 protected:
00101     /* Do not allow class to be created directly */
00102     VertexBuffer() {}
00103 };
00104
00105
00109 class RenderSubmesh
00110 {
00111 public:
00112     virtual                         ~RenderSubmesh() {}
00113
00117     virtual uint32_t                getVertexCount(uint32_t partIndex) const = 0;
00118
00122     virtual const VertexBuffer&     getVertexBuffer() const = 0;
00123
00127     virtual VertexBuffer&           getVertexBufferWritable() = 0;
00128
00133     virtual uint32_t                getFirstVertexIndex(uint32_t partIndex) const = 0;
00134
00138     virtual uint32_t                getIndexCount(uint32_t partIndex) const = 0;
00139
00143     virtual const uint32_t*         getIndexBuffer(uint32_t partIndex) const = 0;
00144
00150     virtual const uint32_t*         getSmoothingGroups(uint32_t partIndex) const = 0;
00151
00152 protected:
00153     RenderSubmesh() {}
00154 };
00155
00156 PX_POP_PACK
00157
00158 }
00159 } // end namespace nvidia::apex
00160
00161 #endif // RENDER_MESH_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: RenderMeshActor.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
RenderMeshActor.h File Reference

class RenderMeshActor More...

#include "Actor.h"
#include "Renderable.h"
#include "UserRenderResourceManager.h"
#include "foundation/PxVec3.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::RenderMeshActorRaycastFlags
Flags used for raycasting an RenderMeshActor. More...
struct | nvidia::apex::RenderMeshActorRaycastHitData
Return data from raycasting an RenderMeshActor. More...
class | nvidia::apex::RenderMeshActor
Renderable mesh (dynamic data associated with RenderMeshAsset) More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class RenderMeshActor

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: RenderMeshActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
RenderMeshActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RENDER_MESH_ACTOR_H
00031 #define RENDER_MESH_ACTOR_H
00032
00038 #include "Actor.h"
00039 #include "Renderable.h"
00040 #include "UserRenderResourceManager.h"  // For RenderCullMode
00041 #include "foundation/PxVec3.h"
00042
00043 namespace nvidia
00044 {
00045 namespace apex
00046 {
00047
00048 PX_PUSH_PACK_DEFAULT
00049
00050 class UserRenderInstanceBuffer;
00051
00055 struct RenderMeshActorRaycastFlags
00056 {
00060     enum Enum
00061     {
00062         VISIBLE_PARTS = (1 << 0),
00063         INVISIBLE_PARTS =   (1 << 1),
00064
00065         ALL_PARTS =         VISIBLE_PARTS | INVISIBLE_PARTS
00066     };
00067 };
00068
00072 struct RenderMeshActorRaycastHitData
00073 {
00077     float       time;
00078
00082     uint32_t    partIndex;
00083
00087     uint32_t    submeshIndex;
00088
00092     uint32_t    vertexIndices[3];
00093
00097     PxVec3      normal;
00098
00102     PxVec3      tangent;
00103
00107     PxVec3      binormal;
00108 };
00109
00110
00114 class RenderMeshActor : public Actor, public Renderable
00115 {
00116 public:
00117
00118     enum
00119     {
00120         InvalidInstanceID = 0xFFFFFFFF
00121     };
00122
00131     virtual bool                    getVisibilities(uint8_t* visibilityArray, uint32_t visibilityArraySize) const = 0;
00132
00136     virtual bool                    setVisibility(bool visible, uint16_t partIndex = 0) = 0;
00137
00141     virtual bool                    isVisible(uint16_t partIndex = 0) const = 0;
00142
00146     virtual uint32_t                visiblePartCount() const = 0;
00147
00154     virtual const uint32_t*         getVisibleParts() const = 0;
00155
00159     virtual uint32_t                getBoneCount() const = 0;
00160
00164     virtual void                    setTM(const PxMat44& tm, uint32_t boneIndex = 0) = 0;
00165
00173     virtual void                    setTM(const PxMat44& tm, const PxVec3& scale, uint32_t boneIndex = 0) = 0;
00174
00178     virtual void                    updateBounds() = 0;
00179
00183     virtual const PxMat44           getTM(uint32_t boneIndex = 0) const = 0;
00184
00189     virtual void                    setReleaseResourcesIfNothingToRender(bool value) = 0;
00190
00194     virtual void                    setBufferVisibility(bool bufferVisibility) = 0;
00195
00199     virtual void                    setOverrideMaterial(uint32_t submeshIndex, const char* overrideMaterialName) = 0;
00200
00208     virtual void                    syncVisibility(bool useLock = true) = 0;
00209
00213     virtual UserRenderInstanceBuffer* getInstanceBuffer() const = 0;
00217     virtual void                    setInstanceBuffer(UserRenderInstanceBuffer* instBuf) = 0;
00221     virtual void                    setMaxInstanceCount(uint32_t count) = 0;
00228     virtual void                    setInstanceBufferRange(uint32_t from, uint32_t count) = 0;
00229
00247     virtual bool                    rayCast(RenderMeshActorRaycastHitData& hitData,
00248                                             const PxVec3& worldOrig, const PxVec3& worldDisp,
00249                                             RenderMeshActorRaycastFlags::Enum flags = RenderMeshActorRaycastFlags::VISIBLE_PARTS,
00250                                             RenderCullMode::Enum winding = RenderCullMode::CLOCKWISE,
00251                                             int32_t partIndex = -1) const = 0;
00252
00253 protected:
00254
00255     virtual                         ~RenderMeshActor() {}
00256 };
00257
00258 PX_POP_PACK
00259
00260 }
00261 } // end namespace nvidia::apex
00262
00263 #endif // RENDER_MESH_ACTOR_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: RenderMeshActorDesc.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
RenderMeshActorDesc.h File Reference

class RenderMeshActorDesc More...

#include "ApexDesc.h"
#include "UserRenderResourceManager.h"

Go to the source code of this file.

Classes

class | nvidia::apex::RenderMeshActorDesc
Descriptor for creating a rendering mesh (collection of parts and submesh extra data) More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class RenderMeshActorDesc

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: RenderMeshActorDesc.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
RenderMeshActorDesc.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RENDER_MESH_ACTOR_DESC_H
00031 #define RENDER_MESH_ACTOR_DESC_H
00032
00038 #include "ApexDesc.h"
00039 #include "UserRenderResourceManager.h"
00040
00041 namespace nvidia
00042 {
00043 namespace apex
00044 {
00045
00046 PX_PUSH_PACK_DEFAULT
00047
00051 class RenderMeshActorDesc : public ApexDesc
00052 {
00053 public:
00054
00058     PX_INLINE RenderMeshActorDesc()
00059     {
00060         setToDefault();
00061     }
00062
00066     PX_INLINE void setToDefault()
00067     {
00068         visible = true;
00069         bufferVisibility = false;
00070         keepVisibleBonesPacked = false;
00071         renderWithoutSkinning = false;
00072         forceFallbackSkinning = false;
00073         maxInstanceCount = 0;
00074         indexBufferHint = RenderBufferHint::STATIC;
00075         overrideMaterials = NULL;
00076         overrideMaterialCount = 0;
00077         keepPreviousFrameBoneBuffer = false;
00078         forceBoneIndexChannel = false;
00079     }
00080
00085     PX_INLINE bool isValid() const
00086     {
00087         if (overrideMaterialCount != 0 && overrideMaterials == NULL)
00088         {
00089             return false;
00090         }
00091         return ApexDesc::isValid();
00092     }
00093
00097     bool                        visible;
00098
00103     bool                        bufferVisibility;
00104
00114     bool                        keepVisibleBonesPacked;
00115
00122     bool                        renderWithoutSkinning;
00123
00130     bool                        forceFallbackSkinning;
00131
00136     uint32_t                    maxInstanceCount;
00137
00142     RenderBufferHint::Enum      indexBufferHint;
00143
00148     const char**                overrideMaterials;
00149
00157     uint32_t                    overrideMaterialCount;
00158
00163     bool                        keepPreviousFrameBoneBuffer;
00164
00168     bool                        forceBoneIndexChannel;
00169 };
00170
00171 PX_POP_PACK
00172
00173 }
00174 } // end namespace nvidia::apex
00175
00176 #endif // RENDER_MESH_ACTOR_DESC_H
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: RenderMeshAsset.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Defines
RenderMeshAsset.h File Reference

APEX RenderMesh Asset. More...

#include "ApexUsingNamespace.h"
#include "VertexFormat.h"
#include "Asset.h"
#include "RenderBufferData.h"
#include "RenderMesh.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::RenderMeshAssetStats
Stats for an RenderMeshAsset: memory usage, counts, etc. More...
struct | nvidia::apex::RenderMeshAssetInstanceMode
Instance buffer data mode. DEPRECATED, to be removed by APEX 1.0. More...
struct | nvidia::apex::VertexColor
The full RGBA color of a vertex. More...
struct | nvidia::apex::VertexUV
a simple u, v coordinate struct More...
struct | nvidia::apex::Vertex
An inefficient vertex description used for authoring. More...
struct | nvidia::apex::ExplicitRenderTriangle
A less inefficient triangle description used for authoring. More...
struct | nvidia::apex::RenderMeshPartData
Descriptor for creating a rendering mesh part. More...
class | nvidia::apex::RenderMeshAssetAuthoring
Authoring interface for an RenderMeshAsset. More...
class | nvidia::apex::RenderMeshAssetAuthoring::VertexBuffer
Vertex buffer class used for mesh creation. More...
struct | nvidia::apex::RenderMeshAssetAuthoring::Primitive
How the geometry is stored. Currently only supporting triangles. More...
struct | nvidia::apex::RenderMeshAssetAuthoring::IndexType
class | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
class | nvidia::apex::RenderMeshAssetAuthoring::MeshDesc
class | nvidia::apex::RenderMeshAsset
Rendering mesh (data) class. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Defines

#define | RENDER_MESH_AUTHORING_TYPE_NAME "ApexRenderMesh"
Name of RenderMesh authoring type namespace.

Detailed Description

APEX RenderMesh Asset.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: RenderMeshAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
RenderMeshAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RENDER_MESH_ASSET_H
00031 #define RENDER_MESH_ASSET_H
00032
00038 #include "ApexUsingNamespace.h"
00039 #include "VertexFormat.h"
00040 #include "Asset.h"
00041 #include "RenderBufferData.h"
00042 #include "RenderMesh.h"
00043
00044 namespace nvidia
00045 {
00046 namespace apex
00047 {
00048
00049 PX_PUSH_PACK_DEFAULT
00050
00051 class RenderMeshActor;
00052 class RenderMeshActorDesc;
00053 class CustomBufferIterator;
00054
00056 #define RENDER_MESH_AUTHORING_TYPE_NAME "ApexRenderMesh"
00057
00061 struct RenderMeshAssetStats
00062 {
00063     uint32_t    totalBytes;
00064     uint32_t    submeshCount;
00065     uint32_t    partCount;
00066     uint32_t    vertexCount;
00067     uint32_t    indexCount;
00068     uint32_t    vertexBufferBytes;
00069     uint32_t    indexBufferBytes;
00070 };
00071
00075 struct RenderMeshAssetInstanceMode
00076 {
00080     enum Enum
00081     {
00082         POSE_SCALE = 0,
00083         POS_VEL_LIFE,
00084
00085         NUM_MODES
00086     };
00087 };
00088
00089
00093 struct VertexColor
00094 {
00095 public:
00096
00097     PX_INLINE                   VertexColor()   {}
00098
00102     PX_INLINE                   VertexColor(const ColorRGBA c)
00103     {
00104         const float recip255 = 1 / (float)255;
00105         set((float)c.r * recip255, (float)c.g * recip255, (float)c.b * recip255, (float)c.a * recip255);
00106     }
00107
00111     PX_INLINE   VertexColor&    operator = (const VertexColor& c)
00112     {
00113         r = c.r;
00114         g = c.g;
00115         b = c.b;
00116         a = c.a;
00117         return *this;
00118     }
00119
00121     PX_INLINE   void            set(float _r, float _g, float _b, float _a)
00122     {
00123         r = _r;
00124         g = _g;
00125         b = _b;
00126         a = _a;
00127     }
00128
00130     PX_INLINE   ColorRGBA       toColorRGBA() const
00131     {
00132         return ColorRGBA((uint8_t)(255 * r + (float)0.5),
00133                            (uint8_t)(255 * g + (float)0.5),
00134                            (uint8_t)(255 * b + (float)0.5),
00135                            (uint8_t)(255 * a + (float)0.5));
00136     }
00137
00138     float r;
00139     float g;
00140     float b;
00141     float a;
00142 };
00143
00144
00148 struct VertexUV
00149 {
00150     VertexUV() {}
00151
00155     VertexUV(float _u, float _v)
00156     {
00157         set(_u, _v);
00158     }
00159
00163     VertexUV(const float uv[])
00164     {
00165         set(uv);
00166     }
00167
00171     void            set(float _u, float _v)
00172     {
00173         u = _u;
00174         v = _v;
00175     }
00176
00180     void            set(const float uv[])
00181     {
00182         u = uv[0];
00183         v = uv[1];
00184     }
00185
00189     float&          operator [](int i)
00190     {
00191         PX_ASSERT(i >= 0 && i <= 1);
00192         return (&u)[i];
00193     }
00194
00198     const float&    operator [](int i) const
00199     {
00200         PX_ASSERT(i >= 0 && i <= 1);
00201         return (&u)[i];
00202     }
00203
00205     float   u;
00207     float   v;
00208 };
00209
00210
00214 struct Vertex
00215 {
00216     PxVec3      position;
00217     PxVec3      normal;
00218     PxVec3      tangent;
00219     PxVec3      binormal;
00220     VertexUV    uv[VertexFormat::MAX_UV_COUNT];
00221     VertexColor color;
00222     uint16_t    boneIndices[VertexFormat::MAX_BONE_PER_VERTEX_COUNT];
00223     float       boneWeights[VertexFormat::MAX_BONE_PER_VERTEX_COUNT];
00224     uint16_t    displacementFlags;
00225
00229     Vertex()
00230     {
00231         memset(this, 0, sizeof(Vertex));
00232     }
00233 };
00234
00235
00239 struct ExplicitRenderTriangle
00240 {
00241     Vertex      vertices[3];
00242     int32_t     submeshIndex;
00243     uint32_t    smoothingMask;
00244     uint32_t    extraDataIndex;
00245
00249     PxVec3  calculateNormal() const
00250     {
00251         return (vertices[1].position - vertices[0].position).cross(vertices[2].position - vertices[0].position);
00252     }
00253 };
00254
00255
00256
00260 struct RenderMeshPartData
00261 {
00262     RenderMeshPartData() : triangleCount(0), userData(NULL) {}
00263
00267     RenderMeshPartData(uint32_t _triCount, void* _data) : triangleCount(_triCount), userData(_data) {}
00268
00269     uint32_t        triangleCount;
00270     void*           userData;
00271 };
00272
00273
00277 class RenderMeshAssetAuthoring : public AssetAuthoring
00278 {
00279 public:
00281     class VertexBuffer : public RenderBufferData<RenderVertexSemantic, RenderVertexSemantic::Enum> {};
00282
00284     struct Primitive
00285     {
00289         enum Enum
00290         {
00291             TRIANGLE_LIST,
00292             //      TRIANGLE_STRIP, // Not supported for now
00293             //      TRIANGLE_FAN,   // Not supported for now
00294
00295             COUNT
00296         };
00297     };
00298
00300     struct IndexType
00301     {
00305         enum Enum
00306         {
00307             UINT,
00308             USHORT,
00309
00310             COUNT
00311         };
00312     };
00313
00316     class SubmeshDesc
00317     {
00318     public:
00320         const char*             m_materialName;
00321
00323         const VertexBuffer*     m_vertexBuffers;
00324
00326         uint32_t                m_numVertexBuffers;
00327
00329         uint32_t                m_numVertices;
00330
00332         Primitive::Enum         m_primitive;
00333
00335         IndexType::Enum         m_indexType;
00336
00338         const void*             m_vertexIndices;
00339
00341         uint32_t                m_numIndices;
00342
00347         uint32_t*               m_smoothingGroups;
00348
00350         uint32_t                m_firstVertex;
00351
00353         const void*             m_partIndices;
00354
00356         uint32_t                m_numParts;
00357
00359         RenderCullMode::Enum    m_cullMode;
00360
00362         SubmeshDesc()
00363         {
00364             memset(this, 0, sizeof(SubmeshDesc));
00365         }
00366
00368         bool    isValid() const
00369         {
00370             return  m_materialName != NULL &&
00371                     m_vertexBuffers != NULL &&  // BRG - todo: check the vertex buffers for validity
00372                     m_numVertexBuffers > 0 &&
00373                     m_numVertices > 0 &&
00374                     m_primitive >= (Primitive::Enum)0 && m_primitive < Primitive::COUNT &&
00375                     m_indexType >= (IndexType::Enum)0 && m_indexType < IndexType::COUNT &&
00376                     m_numIndices > 0 &&
00377                     (m_partIndices == NULL || m_numParts > 0) &&
00378                     (m_cullMode == RenderCullMode::CLOCKWISE || m_cullMode == RenderCullMode::COUNTER_CLOCKWISE || m_cullMode == RenderCullMode::NONE);
00379         }
00380     };
00381
00383     class MeshDesc
00384     {
00385     public:
00387         const SubmeshDesc*      m_submeshes;
00388
00390         uint32_t                m_numSubmeshes;
00391
00393         TextureUVOrigin::Enum   m_uvOrigin;
00394
00395
00396
00398         MeshDesc() : m_submeshes(NULL), m_numSubmeshes(0), m_uvOrigin(TextureUVOrigin::ORIGIN_TOP_LEFT) {}
00399
00401         bool    isValid() const
00402         {
00403             return  m_submeshes != NULL &&
00404                     m_numSubmeshes > 0;
00405         }
00406     };
00407
00408
00414     virtual void                    createRenderMesh(const MeshDesc& meshDesc, bool createMappingInformation) = 0;
00415
00416
00425     virtual uint32_t                createReductionMap(uint32_t* map, const Vertex* vertices, const uint32_t* smoothingGroups, uint32_t vertexCount,
00426                                                        const PxVec3& positionTolerance, float normalTolerance, float UVTolerance) = 0;
00427
00428
00432     virtual void                    deleteStaticBuffersAfterUse(bool set)   = 0;
00433
00438     /* Public access to RenderMeshAsset get methods */
00439
00441     virtual uint32_t                getSubmeshCount() const = 0;
00443     virtual uint32_t                getPartCount() const = 0;
00445     virtual const char*             getMaterialName(uint32_t submeshIndex) const = 0;
00447     virtual void                    setMaterialName(uint32_t submeshIndex, const char* name) = 0;
00449     virtual void                    setWindingOrder(uint32_t submeshIndex, RenderCullMode::Enum winding) = 0;
00451     virtual RenderCullMode::Enum    getWindingOrder(uint32_t submeshIndex) const = 0;
00453     virtual const RenderSubmesh&    getSubmesh(uint32_t submeshIndex) const = 0;
00455     virtual RenderSubmesh&          getSubmeshWritable(uint32_t submeshIndex) = 0;
00457     virtual const PxBounds3&        getBounds(uint32_t partIndex = 0) const = 0;
00459     virtual void                    getStats(RenderMeshAssetStats& stats) const = 0;
00460 };
00461
00462
00468 class RenderMeshAsset : public Asset
00469 {
00470 public:
00471
00477     virtual RenderMeshActor*        createActor(const RenderMeshActorDesc& desc) = 0;
00478
00482     virtual void                    releaseActor(RenderMeshActor&) = 0;
00483
00489     virtual uint32_t                getSubmeshCount() const = 0;
00490
00496     virtual uint32_t                getPartCount() const = 0;
00497
00501     virtual const char*             getMaterialName(uint32_t submeshIndex) const = 0;
00502
00509     virtual const RenderSubmesh&    getSubmesh(uint32_t submeshIndex) const = 0;
00510
00516     virtual const PxBounds3&        getBounds(uint32_t partIndex = 0) const = 0;
00517
00523     virtual void                    getStats(RenderMeshAssetStats& stats) const = 0;
00524
00528     virtual UserOpaqueMesh*         getOpaqueMesh(void) const = 0;
00529
00530 protected:
00531     virtual                         ~RenderMeshAsset() {}
00532 };
00533
00534 PX_POP_PACK
00535
00536 }
00537 } // end namespace nvidia::apex
00538
00539 #endif // RENDER_MESH_ASSET_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: RenderVolume.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
RenderVolume.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RENDER_VOLUME_H
00031 #define RENDER_VOLUME_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class IofxAsset;
00043 class IofxActor;
00044
00055 class RenderVolume : public ApexInterface
00056 {
00057 public:
00059     virtual physx::PxBounds3    getBounds() const = 0;
00060
00062     virtual bool                getAffectsAllIofx() const = 0;
00063
00065     virtual bool                addIofxAsset(IofxAsset& iofx) = 0;
00066
00068     virtual void                setPosition(const PxVec3& pos) = 0;
00069
00071     virtual void                setOwnershipBounds(const PxBounds3& b) = 0;
00072
00074     virtual PxBounds3           getOwnershipBounds() const = 0;
00075
00091     virtual IofxActor* const*   lockIofxActorList(uint32_t& count) = 0;
00092
00097     virtual void                unlockIofxActorList() = 0;
00098
00107     virtual IofxAsset* const*   getIofxAssetList(uint32_t& count) const = 0;
00108
00109     virtual PxVec3              getPosition() const = 0;
00110     virtual uint32_t            getPriority() const = 0;
00111
00117     virtual bool                affectsIofxAsset(const IofxAsset& iofx) const = 0;
00118
00119 protected:
00120     virtual ~RenderVolume() {}
00121 };
00122
00123 PX_POP_PACK
00124
00125 }
00126 } // namespace nvidia
00127
00128 #endif // RENDER_VOLUME_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Renderable.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
Renderable.h File Reference

class Renderable More...

#include "RenderDataProvider.h"

Go to the source code of this file.

Classes

class | nvidia::apex::Renderable
Base class of any actor that can be rendered. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class Renderable

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Renderable.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Renderable.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RENDERABLE_H
00031 #define RENDERABLE_H
00032
00038 #include "RenderDataProvider.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 class UserRenderer;
00046
00047 PX_PUSH_PACK_DEFAULT
00048
00052 class Renderable : public RenderDataProvider
00053 {
00054 public:
00060     virtual void dispatchRenderResources(UserRenderer& renderer) = 0;
00061
00066     virtual PxBounds3 getBounds() const = 0;
00067 };
00068
00069 PX_POP_PACK
00070
00071 }
00072 } // end namespace nvidia::apex
00073
00074 #endif
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: ResourceCallback.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
ResourceCallback.h File Reference

class ResourceCallback More...

#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ResourceCallback
User defined callback for resource management. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class ResourceCallback

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ResourceCallback.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ResourceCallback.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RESOURCE_CALLBACK_H
00031 #define RESOURCE_CALLBACK_H
00032
00038 #include "ApexUsingNamespace.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 PX_PUSH_PACK_DEFAULT
00046
00054 class ResourceCallback
00055 {
00056 public:
00057     virtual ~ResourceCallback() {}
00058
00070     virtual void* requestResource(const char* nameSpace, const char* name) = 0;
00071
00078     virtual void  releaseResource(const char* nameSpace, const char* name, void* resource) = 0;
00079 };
00080
00081 PX_POP_PACK
00082
00083 }
00084 } // namespace nvidia::apex
00085
00086 #endif // RESOURCE_CALLBACK_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ResourceProvider.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
ResourceProvider.h File Reference

class ResourceProvider More...

#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ResourceProvider
A user provided class for mapping names to pointers or integers. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class ResourceProvider

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ResourceProvider.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ResourceProvider.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RESOURCE_PROVIDER_H
00031 #define RESOURCE_PROVIDER_H
00032
00038 #include "ApexUsingNamespace.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 class ResourceCallback;
00046
00047 PX_PUSH_PACK_DEFAULT
00048
00056 class ResourceProvider
00057 {
00058 public:
00066     virtual void        registerCallback(ResourceCallback* impl) = 0;
00067
00071     virtual void        setResource(const char* nameSpace, const char* name, void* resource, bool incRefCount = false) = 0;
00072
00073
00077     virtual void        setResourceU32(const char* nameSpace, const char* name, uint32_t id, bool incRefCount = false) = 0;
00078
00089     virtual void*       getResource(const char* nameSpace, const char* name) = 0;
00090
00095     virtual uint32_t    releaseAllResourcesInNamespace(const char* nameSpace) = 0;
00096
00101     virtual uint32_t    releaseResource(const char* nameSpace, const char* name) = 0;
00102
00106     virtual bool        findRefCount(const char* nameSpace, const char* name, uint32_t& refCount) = 0;
00107
00114     virtual void*       findResource(const char* nameSpace, const char* name) = 0;
00115
00119     virtual uint32_t    findResourceU32(const char* nameSpace, const char* name) = 0;
00120
00124     virtual void**      findAllResources(const char* nameSpace, uint32_t& count) = 0;
00125
00129     virtual const char** findAllResourceNames(const char* nameSpace, uint32_t& count) = 0;
00130
00134     virtual const char** findNameSpaces(uint32_t& count) = 0;
00135
00139     virtual void dumpResourceTable() = 0;
00140
00150     virtual bool isCaseSensitive() = 0;
00151 };
00152
00153 PX_POP_PACK
00154
00155 }
00156 } // end namespace nvidia::apex
00157
00158 #endif // RESOURCE_PROVIDER_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Scene.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Typedefs
Scene.h File Reference

classes Scene, SceneStats, SceneDesc More...

#include "ApexDesc.h"
#include "Renderable.h"
#include "RenderDebugInterface.h"
#include "Context.h"
#include "foundation/PxVec3.h"
#include <ApexDefs.h>
#include "PxFiltering.h"
#include "MirrorScene.h"

Go to the source code of this file.

Classes

class | nvidia::apex::PhysX3Interface
Interface used to call setter function for PhysX 3.0. More...
class | nvidia::apex::SceneDesc
Data used to initialize a new Scene. More...
struct | nvidia::apex::StatDataType
APEX stat struct that contains the type enums. More...
struct | nvidia::apex::oaValueStruct
data value definitions for stats (derived from openautomate) More...
struct | nvidia::apex::StatsInfo
data value definitions for stats More...
struct | nvidia::apex::SceneStats
Per scene statistics. More...
struct | nvidia::apex::ViewMatrixType
Types of view matrices handled by APEX. More...
struct | nvidia::apex::ProjMatrixType
Types of projection matrices handled by APEX. More...
struct | nvidia::apex::UserBoundingBoxFlags
Enum of the bounding box types. More...
class | nvidia::apex::Scene
An APEX wrapper for an PxScene. More...

Namespaces

namespace | NvParameterized

NvParameterized namespace.

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Typedefs

typedef struct
nvidia::apex::oaValueStruct 		nvidia::apex::StatValue
data value definitions for stats (derived from openautomate)

Detailed Description

classes Scene, SceneStats, SceneDesc

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Scene.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Scene.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef SCENE_H
00031 #define SCENE_H
00032
00038 #include "ApexDesc.h"
00039 #include "Renderable.h"
00040 #include "RenderDebugInterface.h"
00041 #include "Context.h"
00042 #include "foundation/PxVec3.h"
00043 #include <ApexDefs.h>
00044
00045 #if PX_PHYSICS_VERSION_MAJOR == 3
00046 #include "PxFiltering.h"
00047 #endif
00048 #include "MirrorScene.h"
00049
00050 namespace NvParameterized
00051 {
00052 class Interface;
00053 }
00054
00055 namespace physx
00056 {
00057     class PxBaseTask;
00058     class PxTaskManager;
00059     class PxCpuDispatcher;
00060     class PxGpuDispatcher;
00061 }
00062
00063 namespace nvidia
00064 {
00065 namespace apex
00066 {
00067 // Forward declaration for the PhysX3Interface::setContactReportFlags() callback
00068 class DestructibleActor;
00069
00070 PX_PUSH_PACK_DEFAULT
00071
00072 #if PX_PHYSICS_VERSION_MAJOR == 3
00073
00076 class PhysX3Interface
00077 {
00078 public:
00084     virtual void setContactReportFlags(PxShape* shape, physx::PxPairFlags flags, DestructibleActor* actor, uint16_t actorChunkIndex) = 0;
00085
00090     virtual physx::PxPairFlags getContactReportFlags(const physx::PxShape* shape) const = 0;
00091 };
00092 #endif
00093
00097 class SceneDesc : public ApexDesc
00098 {
00099 public:
00100
00101     PX_INLINE SceneDesc() : ApexDesc()
00102     {
00103         init();
00104     }
00105
00106     PX_INLINE void setToDefault()
00107     {
00108         ApexDesc::setToDefault();
00109         init();
00110     }
00111
00112
00119     PxScene* scene;
00120
00123     RenderDebugInterface* debugInterface;
00124
00125 #if PX_PHYSICS_VERSION_MAJOR == 0
00126
00133     PxCpuDispatcher* cpuDispatcher;
00134
00141     PxGpuDispatcher* gpuDispatcher;
00142
00143 #elif PX_PHYSICS_VERSION_MAJOR == 3
00144
00147     PhysX3Interface* physX3Interface;
00148
00149 #endif
00150
00157     bool    useDebugRenderable;
00158
00162     bool    debugVisualizeRemotely;
00163
00167     bool    debugVisualizeLocally;
00168
00172     bool    useCuda;
00173
00174 private:
00175     PX_INLINE void init()
00176     {
00177 #if PX_PHYSICS_VERSION_MAJOR == 0
00178         cpuDispatcher = 0;
00179         gpuDispatcher = 0;
00180 #elif PX_PHYSICS_VERSION_MAJOR == 3
00181         physX3Interface = 0;
00182 #endif
00183         scene = 0;
00184         debugInterface = 0;
00185         useDebugRenderable = false;
00186         debugVisualizeRemotely = false;
00187         debugVisualizeLocally = true;
00188 #if APEX_CUDA_SUPPORT
00189         useCuda = true;
00190 #else
00191         useCuda = false;
00192 #endif
00193     }
00194 };
00195
00196
00200 struct StatDataType
00201 {
00205     enum Enum
00206     {
00207         INVALID = 0,
00208         STRING  = 1,
00209         INT     = 2,
00210         FLOAT   = 3,
00211         ENUM    = 4,
00212         BOOL    = 5,
00213     };
00214 };
00215
00219 typedef struct oaValueStruct
00220 {
00221     union
00222     {
00223         char*           String;
00224         int32_t         Int;
00225         float           Float;
00226         char*           Enum;
00227         bool            Bool;
00228     };
00229 } StatValue;
00230
00234 typedef struct
00235 {
00237     const char*         StatName;
00238
00240     StatDataType::Enum  StatType;
00241
00243     StatValue           StatCurrentValue;
00244 } StatsInfo;
00245
00249 struct SceneStats
00250 {
00253     uint32_t            numApexStats;
00256     StatsInfo*          ApexStatsInfoPtr;
00257 };
00258
00267 struct ViewMatrixType
00268 {
00272     enum Enum
00273     {
00274         USER_CUSTOMIZED = 0,
00275         LOOK_AT_RH,
00276         LOOK_AT_LH,
00277     };
00278 };
00279
00286 struct ProjMatrixType
00287 {
00291     enum Enum
00292     {
00293         USER_CUSTOMIZED = 0,
00294     };
00295 };
00296
00300 struct UserBoundingBoxFlags
00301 {
00305     enum Enum
00306     {
00307         NONE    = 1 << 0,
00308         ENTER   = 1 << 1,
00309         LEAVE   = 1 << 2
00310     };
00311 };
00312
00316 class Scene : public Renderable, public Context, public ApexInterface
00317 {
00318 public:
00319
00320 #if PX_PHYSICS_VERSION_MAJOR == 3
00321
00329     virtual void setPhysXScene(PxScene* s) = 0;
00330
00334     virtual PxScene* getPhysXScene() const = 0;
00335
00336 #endif
00337
00341     virtual const SceneStats* getStats(void) const = 0;
00342
00369     virtual void simulate(float elapsedTime,
00370                           bool finalStep = true,
00371                           PxBaseTask *completionTask = NULL,
00372                           void* scratchMemBlock = 0,
00373                           uint32_t scratchMemBlockSize = 0) = 0;
00374
00384     virtual bool fetchResults(bool block, uint32_t* errorState) = 0;
00385
00389     virtual const PxRenderBuffer* getRenderBuffer() const = 0;
00390
00394     virtual const PxRenderBuffer* getRenderBufferScreenSpace() const = 0;
00395
00402     virtual bool checkResults(bool block) const = 0;
00403
00417     virtual uint32_t allocViewMatrix(ViewMatrixType::Enum) = 0;
00418
00431     virtual uint32_t allocProjMatrix(ProjMatrixType::Enum) = 0;
00432
00436     virtual uint32_t getNumViewMatrices() const = 0;
00437
00441     virtual uint32_t getNumProjMatrices() const = 0;
00442
00450     virtual void setViewMatrix(const PxMat44& viewTransform, const uint32_t viewID = 0) = 0;
00451
00457     virtual PxMat44 getViewMatrix(const uint32_t viewID = 0) const = 0;
00458
00465     virtual void setProjMatrix(const PxMat44& projTransform, const uint32_t projID = 0) = 0;
00466
00472     virtual PxMat44 getProjMatrix(const uint32_t projID = 0) const = 0;
00473
00477     virtual void setUseViewProjMatrix(const uint32_t viewID = 0, const uint32_t projID = 0) = 0;
00478
00484     virtual void setViewParams(const PxVec3& eyePosition, const PxVec3& eyeDirection, const PxVec3& worldUpDirection = PxVec3(0, 1, 0), const uint32_t viewID = 0) = 0;
00485
00491     virtual void setProjParams(float nearPlaneDistance, float farPlaneDistance, float fieldOfViewDegree, uint32_t viewportWidth, uint32_t viewportHeight, const uint32_t projID = 0) = 0;
00492
00499     virtual PxVec3 getEyePosition(const uint32_t viewID = 0) const = 0;
00500
00507     virtual PxVec3 getEyeDirection(const uint32_t viewID = 0) const = 0;
00508
00512     virtual PxTaskManager* getTaskManager() const = 0;
00513
00517     virtual void setUseDebugRenderable(bool state) = 0;
00518
00522     virtual ::NvParameterized::Interface* getDebugRenderParams() const = 0;
00523
00527     virtual ::NvParameterized::Interface* getModuleDebugRenderParams(const char* name) const = 0;
00528
00532     virtual PxVec3 getGravity() const = 0;
00533
00537     virtual void setGravity(const PxVec3& gravity) = 0;
00538
00539
00540 #if PX_PHYSICS_VERSION_MAJOR == 3
00541
00549     virtual void lockRead(const char *fileName,uint32_t lineo) = 0;
00550
00559     virtual void lockWrite(const char *fileName,uint32_t lineno) = 0;
00560
00564     virtual void unlockRead() = 0;
00565
00569     virtual void unlockWrite() = 0;
00570
00583     virtual void addActorPair(PxActor *actor0,PxActor *actor1) = 0;
00584
00591     virtual void removeActorPair(PxActor *actor0,PxActor *actor1) = 0;
00592
00604     virtual bool findActorPair(PxActor *actor0,PxActor *actor1) const = 0;
00605
00606
00617     virtual MirrorScene *createMirrorScene(nvidia::apex::Scene &mirrorScene,
00618         MirrorScene::MirrorFilter &mirrorFilter,
00619         float mirrorStaticDistance,
00620         float mirrorDynamicDistance,
00621         float mirrorRefreshDistance) = 0;
00622 #endif
00623
00624
00633     virtual void addBoundingBox(const PxBounds3& bounds, UserBoundingBoxFlags::Enum flags) = 0;
00634
00641     virtual const PxBounds3 getBoundingBox(const uint32_t index) const = 0;
00642
00649     virtual UserBoundingBoxFlags::Enum getBoundingBoxFlags(const uint32_t index) const = 0;
00650
00654     virtual uint32_t getBoundingBoxCount() const = 0;
00655
00661     virtual void  removeBoundingBox(const uint32_t index) = 0;
00662
00666     virtual void  removeAllBoundingBoxes() = 0;
00667
00671     virtual void* getCudaTestManager() const = 0;
00672
00676     virtual void* getCudaProfileManager() const = 0;
00677
00683     virtual void setCudaKernelCheckEnabled(bool enabled) = 0;
00684
00688     virtual bool getCudaKernelCheckEnabled() const = 0;
00689
00690 #if APEX_UE4
00691
00694     virtual void updateGravity() = 0;
00695 #endif
00696 };
00697
00698
00699 PX_POP_PACK
00700
00701 }
00702 } // end namespace nvidia::apex
00703
00704 #endif // SCENE_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: ScopedPhysXLock.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
ScopedPhysXLock.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef SCOPED_PHYS_XLOCK_H
00030
00031 #define SCOPED_PHYS_XLOCK_H
00032
00033 #include "foundation/PxPreprocessor.h"
00034 #include "ApexDefs.h"
00035
00036
00037 #include "PxScene.h"
00038 #include "Scene.h"
00039
00040 namespace nvidia
00041 {
00042     namespace apex
00043     {
00044
00052         class ScopedPhysXLockRead
00053         {
00054         public:
00055
00062             ScopedPhysXLockRead(nvidia::Scene* scene, const char *fileName, int lineno) : mApexScene(scene), mPhysXScene(0)
00063             {
00064                 if (mApexScene)
00065                 {
00066                     mApexScene->lockRead(fileName, (uint32_t)lineno);
00067                 }
00068             }
00069
00076             ScopedPhysXLockRead(physx::PxScene* scene, const char *fileName, int lineno) : mPhysXScene(scene), mApexScene(0)
00077             {
00078                 if (mPhysXScene)
00079                 {
00080                     mPhysXScene->lockRead(fileName, (uint32_t)lineno);
00081                 }
00082             }
00083
00084             ~ScopedPhysXLockRead()
00085             {
00086                 if (mApexScene)
00087                 {
00088                     mApexScene->unlockRead();
00089                 }
00090                 if (mPhysXScene)
00091                 {
00092                     mPhysXScene->unlockRead();
00093                 }
00094             }
00095         private:
00096             nvidia::Scene* mApexScene;
00097             physx::PxScene* mPhysXScene;
00098         };
00099
00106         class ScopedPhysXLockWrite
00107         {
00108         public:
00115             ScopedPhysXLockWrite(nvidia::Scene *scene, const char *fileName, int lineno) : mApexScene(scene), mPhysXScene(0)
00116             {
00117                 if (mApexScene)
00118                 {
00119                     mApexScene->lockWrite(fileName, (uint32_t)lineno);
00120                 }
00121             }
00122
00129             ScopedPhysXLockWrite(physx::PxScene *scene, const char *fileName, int lineno) : mPhysXScene(scene), mApexScene(0)
00130             {
00131                 if (mPhysXScene)
00132                 {
00133                     mPhysXScene->lockWrite(fileName, (uint32_t)lineno);
00134                 }
00135             }
00136
00137             ~ScopedPhysXLockWrite()
00138             {
00139                 if (mApexScene)
00140                 {
00141                     mApexScene->unlockWrite();
00142                 }
00143                 if (mPhysXScene)
00144                 {
00145                     mPhysXScene->unlockWrite();
00146                 }
00147             }
00148         private:
00149             nvidia::Scene* mApexScene;
00150             physx::PxScene* mPhysXScene;
00151         };
00152     }
00153 }
00154
00155
00156 #if defined(_DEBUG) || PX_CHECKED
00157
00160 #define SCOPED_PHYSX_LOCK_WRITE(x) nvidia::apex::ScopedPhysXLockWrite _wlock(x,__FILE__,__LINE__);
00161 #else
00162
00165 #define SCOPED_PHYSX_LOCK_WRITE(x) nvidia::apex::ScopedPhysXLockWrite _wlock(x,"",0);
00166 #endif
00167
00168 #if defined(_DEBUG) || PX_CHECKED
00169
00172 #define SCOPED_PHYSX_LOCK_READ(x) nvidia::apex::ScopedPhysXLockRead _rlock(x,__FILE__,__LINE__);
00173 #else
00174
00177 #define SCOPED_PHYSX_LOCK_READ(x) nvidia::apex::ScopedPhysXLockRead _rlock(x,"",0);
00178 #endif
00179
00180
00181
00182 #endif
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Shape.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
Shape.h File Reference

class Shape More...

#include "foundation/PxPreprocessor.h"
#include "ApexUsingNamespace.h"
#include "ApexDefs.h"

Go to the source code of this file.

Classes

class | nvidia::apex::Shape
Describes the format of an Shape. More...
class | nvidia::apex::SphereShape
helper Sphere shape More...
class | nvidia::apex::CapsuleShape
helper the capsule is oriented along the y axis by default and its total height is height+2*radius More...
class | nvidia::apex::BoxShape
helper Box shape More...
class | nvidia::apex::HalfSpaceShape
helper HalfSpace shape More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class Shape

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Shape.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Shape.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef SHAPE_H
00031 #define SHAPE_H
00032
00038 #include "foundation/PxPreprocessor.h"
00039 #include "ApexUsingNamespace.h"
00040
00041 #include "ApexDefs.h"
00042
00043 /*#if PX_PHYSICS_VERSION_MAJOR < 3
00044 #include "Nxp.h"
00045 #endif*/
00046
00047 namespace nvidia
00048 {
00049 namespace apex
00050 {
00051
00052 PX_PUSH_PACK_DEFAULT
00053
00054
00055 class SphereShape;
00056 class CapsuleShape;
00057 class BoxShape;
00058 class HalfSpaceShape;
00059 class RenderDebugInterface;
00060
00064 class Shape
00065 {
00066 public:
00067
00069     virtual bool intersectAgainstAABB(PxBounds3) = 0;
00070
00072     virtual PxBounds3 getAABB() const = 0;
00073
00075     virtual const BoxShape* isBoxGeom() const
00076     {
00077         return NULL;
00078     }
00079
00081     virtual const SphereShape* isSphereGeom() const
00082     {
00083         return NULL;
00084     }
00085
00087     virtual const CapsuleShape* isCapsuleGeom() const
00088     {
00089         return NULL;
00090     }
00091
00093     virtual const HalfSpaceShape* isHalfSpaceGeom() const
00094     {
00095         return NULL;
00096     }
00097
00099     virtual void releaseApexShape() = 0;
00100
00102     virtual void visualize(RenderDebugInterface* renderer) const = 0;
00103
00105     virtual PxMat44 getPose() const = 0;
00106
00108     virtual void setPose(PxMat44 pose) = 0;
00109
00111     virtual PxMat44 getPreviousPose() const = 0;
00112 };
00113
00115 class SphereShape : public Shape
00116 {
00117 public:
00119     virtual float getRadius() const = 0;
00120
00122     virtual void setRadius(float radius) = 0;
00123
00124 };
00125
00127 class CapsuleShape : public Shape
00128 {
00129 public:
00131     virtual void getDimensions(float& height, float& radius) const = 0;
00132
00134     virtual void setDimensions(float height, float radius) = 0;
00135
00136 };
00137
00139 class BoxShape : public Shape
00140 {
00141 public:
00144     virtual void setSize(PxVec3 size) = 0;
00145
00147     virtual PxVec3 getSize() const = 0;
00148
00149 };
00150
00152 class HalfSpaceShape : public Shape
00153 {
00154 public:
00156     virtual void setOriginAndNormal(PxVec3 origin, PxVec3 normal) = 0;
00157
00159     virtual PxVec3 getNormal() const = 0;
00160
00162     virtual PxVec3 getOrigin() const = 0;
00163
00165     virtual PxVec3 getPreviousOrigin() const = 0;
00166 };
00167
00168
00169 PX_POP_PACK
00170
00171 }
00172 } // end namespace nvidia::apex
00173
00174 #endif // SHAPE_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: SubstanceSourceActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
SubstanceSourceActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef SUBSTANCE_SOURCE_ACTOR_H
00030 #define SUBSTANCE_SOURCE_ACTOR_H
00031
00032 #include "Apex.h"
00033 #include "Shape.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 class SubstanceSourceAsset;
00041
00042
00046 class SubstanceSourceActor : public Actor
00047 {
00048 protected:
00049     virtual ~SubstanceSourceActor() {}
00050
00051 public:
00053     virtual SubstanceSourceAsset*       getSubstanceSourceAsset() const = 0;
00054
00060     virtual void                        setEnabled(bool enable) = 0;
00061
00063     virtual bool                        isEnabled() const = 0;
00064
00066     virtual bool                        intersectAgainstAABB(PxBounds3) = 0;
00067
00069     virtual  Shape*                     getShape() const = 0;
00070
00072     virtual BoxShape*                   getBoxShape() = 0;
00073
00075     virtual SphereShape*                getSphereShape() = 0;
00076
00078     virtual float                       getAverageDensity() const = 0;
00079
00081     virtual float                       getStdDensity() const = 0;
00082
00084     virtual void                        setDensity(float averageDensity, float stdDensity) = 0;
00085
00087     virtual void                        setCurrentScale(float scale) = 0;
00088
00090     virtual float                       getCurrentScale(void) const = 0;
00091
00092     virtual void                        release() = 0;
00093 };
00094
00095
00096 }
00097 } // end namespace nvidia
00098
00099 #endif
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: SubstanceSourceAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
SubstanceSourceAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef SUBSTANCE_SOURCE_ASSET_H
00030 #define SUBSTANCE_SOURCE_ASSET_H
00031
00032 #include "Apex.h"
00033 #include "CustomBufferIterator.h"
00034
00035 #define SUBSTANCE_SOURCE_AUTHORING_TYPE_NAME "SubstanceSourceAsset"
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00042 class TurbulenceFSActorParams;
00043 class TurbulenceFSActor;
00044 class TurbulenceFSPreview;
00045
00049 class SubstanceSourceAsset : public Asset
00050 {
00051 protected:
00052     virtual ~SubstanceSourceAsset() {}
00053 };
00054
00055
00059 class SubstanceSourceAssetAuthoring : public AssetAuthoring
00060 {
00061 protected:
00062     virtual ~SubstanceSourceAssetAuthoring() {}
00063 };
00064
00065
00066 }
00067 } // end namespace nvidia
00068
00069 #endif // SUBSTANCE_SOURCE_ASSET_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: TestBase.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
TestBase.h File Reference

An TestBase is an interface for managing unit tests. More...

#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

class | nvidia::apex::TestFunctionInterface
class | nvidia::apex::TestBase

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

An TestBase is an interface for managing unit tests.

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: TestBase.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
TestBase.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef TEST_BASE_H
00031 #define TEST_BASE_H
00032
00033 #include "ApexUsingNamespace.h"
00034
00040 namespace nvidia
00041 {
00042
00043 namespace apex
00044 {
00045
00046 class Actor;
00047
00051 class TestFunctionInterface
00052 {
00053 public:
00054
00058     TestFunctionInterface(const char* name) : mName(name) {}
00059
00063     virtual bool run(void*, void*) = 0;
00064
00068     virtual bool check(void*, void*) = 0;
00069
00073     virtual bool runGpu(void*, void*, void*) = 0;
00074
00078     const char* mName;
00079 };
00080
00084 class TestBase
00085 {
00086 public:
00087
00093     virtual const char* getUnitTestsName(uint32_t unitTestsIndex) const = 0;
00094
00100     virtual uint32_t getUnitTestsIndex(const char* unitTestsName) const = 0;
00101
00108     virtual bool runUnitTests(uint32_t unitTestsID, void* dataPtr) const = 0;
00109
00113     virtual bool checkUnitTests(uint32_t unitTestsID, void* dataPtr) const = 0;
00114
00118     virtual uint32_t getUnitTestsCount() const = 0;
00119
00129     virtual void setRuntimeCheckLevel(uint32_t level) = 0;
00130 };
00131
00132
00133 }; // end of apex namespace
00134 }; // end of nvidia namespace
00135
00136 #endif
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: TurbulenceFSActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
TurbulenceFSActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef TURBULENCE_FSACTOR_H
00030 #define TURBULENCE_FSACTOR_H
00031
00032 #include "Apex.h"
00033 #include "Shape.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 class TurbulenceFSAsset;
00041 class TurbulenceRenderable;
00042
00046 class TurbulenceFSActor : public Actor, public Renderable
00047 {
00048 protected:
00049     virtual ~TurbulenceFSActor() {}
00050
00051 public:
00052
00054     virtual TurbulenceFSAsset* getTurbulenceFSAsset() const = 0;
00055
00057     virtual void setEnabled(bool enable) = 0;
00058
00066     virtual void setPose(PxMat44 pose) = 0;
00067
00075     virtual PxMat44 getPose() const = 0;
00076
00078     virtual PxVec3 getGridBoundingBoxMin() = 0;
00080     virtual PxVec3 getGridBoundingBoxMax() = 0;
00081
00083     virtual PxVec3 getGridSize() = 0;
00084
00086     virtual void getGridDimensions(uint32_t &gridX,uint32_t &gridY,uint32_t &gridZ) = 0;
00087
00089     virtual void setGridDimensions(const uint32_t &gridX, const uint32_t &gridY, const uint32_t &gridZ) = 0;
00090
00098     virtual void setUpdatesPerFrame(float upd) = 0;
00100     virtual float getUpdatesPerFrame() const = 0;
00101
00107     virtual void getVelocityField(void** x, void** y, void** z, uint32_t& sizeX, uint32_t& sizeY, uint32_t& sizeZ) = 0;
00108
00110     virtual void setSampleVelocityFieldEnabled(bool enabled) = 0;
00111
00113     virtual void setAngularVelocityMultiplierAndClamp(float angularVelocityMultiplier, float angularVelocityClamp) = 0;
00114
00116     virtual void setLinearVelocityMultiplierAndClamp(float linearVelocityMultiplier, float linearVelocityClamp) = 0;
00117
00119     virtual void setVelocityFieldFade(float fade) = 0;
00120
00122     virtual void setFluidViscosity(float viscosity) = 0;
00123
00125     virtual void setVelocityFieldCleaningTime(float time) = 0;
00126
00128     virtual void setVelocityFieldCleaningDelay(float time) = 0;
00129
00134     virtual void setVelocityFieldCleaningIntensity(float a) = 0;
00135
00140     virtual void setUseHeat(bool enable) = 0;
00141
00143     virtual void setHeatBasedParameters(float forceMultiplier, float ambientTemperature, PxVec3 heatForceDirection, float thermalConductivity) = 0;
00144
00149     virtual void setUseDensity(bool enable) = 0;
00150
00152     virtual bool getUseDensity(void) const = 0;
00153
00155     virtual void setDensityBasedParameters(float diffusionCoef, float densityFieldFade) = 0;
00156
00158     virtual void getDensityGridDimensions(uint32_t &gridX,uint32_t &gridY,uint32_t &gridZ) = 0;
00159
00164     virtual void setExternalVelocity(PxVec3 vel) = 0;
00165
00167     virtual void setFieldVelocityMultiplier(float value) = 0;
00168
00170     virtual void setFieldVelocityWeight(float value) = 0;
00171
00173     virtual void setNoiseParameters(float noiseStrength, PxVec3 noiseSpacePeriod, float noiseTimePeriod, uint32_t noiseOctaves) = 0;
00174
00176     virtual void setDensityTextureRange(float minValue, float maxValue) = 0;
00177
00179     virtual const char *getVolumeRenderMaterialName(void) const = 0;
00180
00182     virtual void setCurrentScale(float scale) = 0;
00183
00185     virtual float getCurrentScale(void) const = 0;
00186
00188     virtual bool getUseFlame(void) const = 0;
00189
00191     virtual void getFlameGridDimensions(uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ) const = 0;
00192
00199     virtual TurbulenceRenderable* acquireRenderableReference() = 0;
00200
00201 };
00202
00203 }
00204 } // end namespace nvidia
00205
00206 #endif // TURBULENCE_FSACTOR_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: TurbulenceFSAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
TurbulenceFSAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef TURBULENCE_FSASSET_H
00030 #define TURBULENCE_FSASSET_H
00031
00032 #include "Apex.h"
00033 #include "CustomBufferIterator.h"
00034
00035 #define TURBULENCE_FS_AUTHORING_TYPE_NAME "TurbulenceFSAsset"
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00042 class TurbulenceFSActorParams;
00043 class TurbulenceFSActor;
00044 class TurbulenceFSPreview;
00045
00049 class TurbulenceFSAsset : public Asset
00050 {
00051 protected:
00052     virtual ~TurbulenceFSAsset() {}
00053
00054 };
00055
00059 class TurbulenceFSAssetAuthoring : public AssetAuthoring
00060 {
00061 protected:
00062     virtual ~TurbulenceFSAssetAuthoring() {}
00063
00064 };
00065
00066 }
00067 } // end namespace nvidia
00068
00069 #endif // TURBULENCE_FSASSET_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: TurbulenceFSPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
TurbulenceFSPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef TURBULENCE_FSPREVIEW_H
00030 #define TURBULENCE_FSPREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class RenderDebugInterface;
00043
00054 namespace APEX_TURBO
00055 {
00060 static const uint32_t TURBO_DRAW_NOTHING = 0x00;
00065 static const uint32_t TURBO_DRAW_ICON = 0x01;
00070 static const uint32_t TURBO_DRAW_BOX = 0x02;
00076 static const uint32_t TURBO_DRAW_GRIDS = 0x04;
00082 static const uint32_t TURBO_DRAW_ASSET_INFO = 0x20;
00087 static const uint32_t TURBO_DRAW_FULL_DETAIL = (TURBO_DRAW_ICON + TURBO_DRAW_BOX + TURBO_DRAW_GRIDS + TURBO_DRAW_ASSET_INFO);
00088 }
00089
00094 class TurbulenceFSPreview : public AssetPreview
00095 {
00096 public:
00100     virtual void    setHalfLengthDimensions(PxVec3 halfLengthDimensions) = 0;
00104     virtual void    setNumGrids(PxVec3 numGrids) = 0;
00111     virtual void    setIconScale(float scale) = 0;
00126     virtual void    setDetailLevel(uint32_t detail) = 0;
00127 };
00128
00129
00130 PX_POP_PACK
00131
00132 }
00133 } // namespace nvidia
00134
00135 #endif // TURBULENCE_FSPREVIEW_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: TurbulenceRenderCallback.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
TurbulenceRenderCallback.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef TURBULENCE_RENDER_CALLBACK_H
00031 #define TURBULENCE_RENDER_CALLBACK_H
00032
00033 #include "foundation/Px.h"
00034 #include "UserRenderCallback.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class TurbulenceRenderable;
00044
00048 struct TurbulenceVelocityFormat
00049 {
00053     enum Enum
00054     {
00055         DEFAULT = 0,
00056         HALF4 = RenderDataFormat::HALF4,
00057         FLOAT4 = RenderDataFormat::FLOAT4,
00058     };
00059 };
00060
00064 struct TurbulenceDensityFormat
00065 {
00069     enum Enum
00070     {
00071         DEFAULT = 0,
00072         UBYTE1 = RenderDataFormat::UBYTE1,
00073         HALF1 = RenderDataFormat::HALF1,
00074         FLOAT1 = RenderDataFormat::FLOAT1,
00075     };
00076 };
00077
00081 struct TurbulenceFlameFormat
00082 {
00086     enum Enum
00087     {
00088         DEFAULT = 0,
00089         HALF4 = RenderDataFormat::HALF4,
00090         FLOAT4 = RenderDataFormat::FLOAT4,
00091     };
00092 };
00093
00097 struct TurbulenceRenderLayout
00098 {
00099     TurbulenceRenderLayout()
00100     {
00101         setDefaults();
00102     }
00103
00105     void setDefaults()
00106     {
00107         velocityFormat = TurbulenceVelocityFormat::DEFAULT;
00108         densityFormat = TurbulenceDensityFormat::DEFAULT;
00109         flameFormat = TurbulenceFlameFormat::DEFAULT;
00110     }
00111
00113     TurbulenceVelocityFormat::Enum  velocityFormat;
00114
00116     TurbulenceDensityFormat::Enum   densityFormat;
00117
00119     TurbulenceFlameFormat::Enum     flameFormat;
00120 };
00121
00125 class TurbulenceRenderCallback : public UserRenderCallback
00126 {
00127 public:
00129     virtual void onCreatedTurbulenceRenderable(TurbulenceRenderable& ) {}
00130
00132     virtual void onUpdatedTurbulenceRenderable(TurbulenceRenderable& ) {}
00133
00135     virtual void onReleasingTurbulenceRenderable(TurbulenceRenderable& ) {}
00136
00138     virtual bool getTurbulenceRenderLayout(TurbulenceRenderLayout& renderLayout, uint32_t sizeX, uint32_t sizeY, uint32_t sizeZ, uint32_t densitySizeMultiplier, uint32_t flameSizeMultiplier)
00139     {
00140         PX_UNUSED(renderLayout);
00141         PX_UNUSED(sizeX);
00142         PX_UNUSED(sizeY);
00143         PX_UNUSED(sizeZ);
00144         PX_UNUSED(densitySizeMultiplier);
00145         PX_UNUSED(flameSizeMultiplier);
00146         return false;
00147     }
00148 };
00149
00150 PX_POP_PACK
00151
00152 }
00153 } // end namespace nvidia
00154
00155 #endif // TURBULENCE_RENDER_CALLBACK_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: TurbulenceRenderable.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
TurbulenceRenderable.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef TURBULENCE_RENDERABLE_H
00031 #define TURBULENCE_RENDERABLE_H
00032
00033 #include "foundation/Px.h"
00034 #include "ApexInterface.h"
00035 #include "Renderable.h"
00036 #include "TurbulenceRenderCallback.h"
00037
00038 namespace nvidia
00039 {
00040 namespace apex
00041 {
00042
00043 PX_PUSH_PACK_DEFAULT
00044
00048 struct TurbulenceFieldType
00049 {
00053     enum Enum
00054     {
00055         VELOCITY = 0,
00056         DENSITY,
00057         FLAME,
00058
00059         MAX_COUNT
00060     };
00061 };
00062
00066 struct TurbulenceRenderData
00067 {
00069     UserRenderSurfaceDesc   fieldSurfaceDescs[TurbulenceFieldType::MAX_COUNT];
00070
00072     UserRenderSurface*      fieldSurfaces[TurbulenceFieldType::MAX_COUNT];
00073 };
00074
00080 class TurbulenceRenderable : public ApexInterface
00081 {
00082 public:
00084     virtual const TurbulenceRenderData* getRenderData() const = 0;
00085
00087     virtual const physx::PxBounds3&     getBounds() const = 0;
00088
00089 protected:
00090     virtual ~TurbulenceRenderable() {}
00091
00092 };
00093
00094 PX_POP_PACK
00095
00096 }
00097 } // end namespace nvidia
00098
00099 #endif // TURBULENCE_RENDERABLE_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserOpaqueMesh.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Defines
UserOpaqueMesh.h File Reference

class UserOpaqueMesh More...

#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

class | nvidia::apex::UserOpaqueMeshDesc
Opaque mesh description. More...
class | nvidia::apex::UserOpaqueMesh
An abstract interface to an opaque mesh. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Defines

#define | APEX_OPAQUE_MESH_NAME_SPACE "ApexOpaqueMesh"
Name of OpaqueMesh authoring type namespace.

Detailed Description

class UserOpaqueMesh

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserOpaqueMesh.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserOpaqueMesh.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_OPAQUE_MESH_H
00031 #define USER_OPAQUE_MESH_H
00032
00038 #include "ApexUsingNamespace.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 PX_PUSH_PACK_DEFAULT
00046
00048 #define APEX_OPAQUE_MESH_NAME_SPACE "ApexOpaqueMesh"
00049
00053 class UserOpaqueMeshDesc
00054 {
00055 public:
00057     const char* mMeshName;
00058 };
00059
00067 class UserOpaqueMesh
00068 {
00069 public:
00070     virtual ~UserOpaqueMesh() {}
00071 };
00072
00073 PX_POP_PACK
00074
00075 }
00076 } // end namespace nvidia::apex
00077
00078 #endif
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderBoneBuffer.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
UserRenderBoneBuffer.h File Reference

class UserRenderBoneBuffer More...

#include "RenderBufferData.h"
#include "UserRenderBoneBufferDesc.h"

Go to the source code of this file.

Classes

class | nvidia::apex::RenderBoneBufferData
type of the bone buffer data More...
class | nvidia::apex::UserRenderBoneBuffer
Used for storing skeletal bone information used during skinning. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class UserRenderBoneBuffer

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderBoneBuffer.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderBoneBuffer.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_BONE_BUFFER_H
00031 #define USER_RENDER_BONE_BUFFER_H
00032
00038 #include "RenderBufferData.h"
00039 #include "UserRenderBoneBufferDesc.h"
00040
00041 namespace nvidia
00042 {
00043 namespace apex
00044 {
00045
00046 PX_PUSH_PACK_DEFAULT
00047
00051 class RenderBoneBufferData : public RenderBufferData<RenderBoneSemantic, RenderBoneSemantic::Enum> {};
00052
00060 class UserRenderBoneBuffer
00061 {
00062 public:
00063     virtual     ~UserRenderBoneBuffer() {}
00064
00076     virtual void writeBuffer(const nvidia::RenderBoneBufferData& data, uint32_t firstBone, uint32_t numBones)   = 0;
00077 };
00078
00079 PX_POP_PACK
00080
00081 }
00082 } // end namespace nvidia::apex
00083
00084 #endif
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderBoneBufferDesc.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
UserRenderBoneBufferDesc.h File Reference

class UserRenderBoneBufferDesc, structs RenderDataFormat and RenderBoneSemantic More...

#include "RenderDataFormat.h"
#include "UserRenderResourceManager.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::RenderBoneSemantic
The semantics available for bone buffers. More...
class | nvidia::apex::UserRenderBoneBufferDesc
Descriptor to generate a bone buffer. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class UserRenderBoneBufferDesc, structs RenderDataFormat and RenderBoneSemantic

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderBoneBufferDesc.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderBoneBufferDesc.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_BONE_BUFFER_DESC_H
00031 #define USER_RENDER_BONE_BUFFER_DESC_H
00032
00038 #include "RenderDataFormat.h"
00039 #include "UserRenderResourceManager.h"
00040
00041 namespace nvidia
00042 {
00043 namespace apex
00044 {
00045
00046 PX_PUSH_PACK_DEFAULT
00047
00051 struct RenderBoneSemantic
00052 {
00056     enum Enum
00057     {
00058         POSE = 0,
00059         PREVIOUS_POSE,
00060         NUM_SEMANTICS
00061     };
00062 };
00063
00064
00065
00072 class UserRenderBoneBufferDesc
00073 {
00074 public:
00075     UserRenderBoneBufferDesc(void)
00076     {
00077         maxBones = 0;
00078         hint     = RenderBufferHint::STATIC;
00079         for (uint32_t i = 0; i < RenderBoneSemantic::NUM_SEMANTICS; i++)
00080         {
00081             buffersRequest[i] = RenderDataFormat::UNSPECIFIED;
00082         }
00083     }
00084
00088     bool isValid(void) const
00089     {
00090         uint32_t numFailed = 0;
00091         return (numFailed == 0);
00092     }
00093
00094 public:
00098     uint32_t                maxBones;
00099
00103     RenderBufferHint::Enum  hint;
00104
00110     RenderDataFormat::Enum  buffersRequest[RenderBoneSemantic::NUM_SEMANTICS];
00111 };
00112
00113 PX_POP_PACK
00114
00115 }
00116 } // end namespace nvidia::apex
00117
00118 #endif
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderCallback.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderCallback.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_CALLBACK_H
00031 #define USER_RENDER_CALLBACK_H
00032
00033 #include "RenderDataFormat.h"
00034
00038 typedef struct CUgraphicsResource_st* CUgraphicsResource;
00039
00040
00041 namespace nvidia
00042 {
00043 namespace apex
00044 {
00045
00046 PX_PUSH_PACK_DEFAULT
00047
00051 struct RenderInteropFlags
00052 {
00056     enum Enum
00057     {
00058         NO_INTEROP = 0,
00059         CUDA_INTEROP,
00060     };
00061 };
00062
00066 struct RenderMapType
00067 {
00071     enum Enum
00072     {
00073         MAP_READ                 = 1,
00074         MAP_WRITE                = 2,
00075         MAP_READ_WRITE           = 3,
00076         MAP_WRITE_DISCARD        = 4,
00077         MAP_WRITE_NO_OVERWRITE   = 5
00078     };
00079 };
00080
00084 class UserRenderData
00085 {
00086 public:
00087
00091     virtual void addRef() = 0;
00092
00096     virtual void release() = 0;
00097 };
00098
00102 class UserRenderDataHolder
00103 {
00104 public:
00105     UserRenderDataHolder()
00106         : userData(NULL)
00107     {
00108     }
00109
00110     ~UserRenderDataHolder()
00111     {
00112         if (userData)
00113         {
00114             userData->release();
00115         }
00116     }
00117
00121     UserRenderDataHolder(const UserRenderDataHolder& other)
00122         : userData(other.userData)
00123     {
00124         if (userData)
00125         {
00126             userData->addRef();
00127         }
00128     }
00129
00133     UserRenderDataHolder& operator=(const UserRenderDataHolder& other)
00134     {
00135         setUserData(other.userData);
00136         return *this;
00137     }
00138
00143     void setUserData(UserRenderData* newUserData)
00144     {
00145         if (userData != newUserData)
00146         {
00147             if (userData)
00148             {
00149                 userData->release();
00150             }
00151             userData = newUserData;
00152             if (userData)
00153             {
00154                 userData->addRef();
00155             }
00156         }
00157     }
00158
00163     UserRenderData* getUserData() const
00164     {
00165         return userData;
00166     }
00167
00168 private:
00169
00174     UserRenderData* userData;
00175 };
00176
00180 class UserRenderStorage
00181 {
00182 public:
00183
00187     virtual void release() = 0;
00188
00192     enum Type
00193     {
00194         BUFFER = 0,
00195         SURFACE,
00196     };
00197
00201     virtual Type getType() const = 0;
00202 };
00203
00207 struct UserRenderBufferDesc : public UserRenderDataHolder
00208 {
00209     UserRenderBufferDesc(void)
00210     {
00211         setDefaults();
00212     }
00213
00217     void setDefaults()
00218     {
00219         size = 0;
00220         setUserData(NULL);
00221         userFlags = 0;
00222         interopFlags = RenderInteropFlags::NO_INTEROP;
00223     }
00224
00228     bool isValid(void) const
00229     {
00230         return (size > 0);
00231     }
00232
00236     bool isTheSameAs(const UserRenderBufferDesc& other) const
00237     {
00238         if (size != other.size) return false;
00239         if (userFlags != other.userFlags) return false;
00240         if (getUserData() != other.getUserData()) return false;
00241         if (interopFlags != other.interopFlags) return false;
00242         return true;
00243     }
00244
00245     size_t                      size;
00246     uint32_t                    userFlags;
00247     RenderInteropFlags::Enum    interopFlags;
00248 };
00249
00253 class UserRenderBuffer : public UserRenderStorage
00254 {
00255 public:
00256
00260     virtual Type getType() const
00261     {
00262         return BUFFER;
00263     }
00264
00269     virtual void* map(RenderMapType::Enum mapType, size_t offset = 0, size_t size = SIZE_MAX) = 0;
00270
00274     virtual void unmap() = 0;
00275
00280     virtual bool getCUDAgraphicsResource(CUgraphicsResource &ret) = 0;
00281 };
00282
00286 struct UserRenderSurfaceDesc : public UserRenderDataHolder
00287 {
00288     UserRenderSurfaceDesc(void)
00289     {
00290         setDefaults();
00291     }
00292
00296     void setDefaults()
00297     {
00298         width = 0;
00299         height = 0;
00300         depth = 0;
00301         format = RenderDataFormat::UNSPECIFIED;
00302         setUserData(NULL);
00303         userFlags = 0;
00304         interopFlags = RenderInteropFlags::NO_INTEROP;
00305     }
00306
00310     bool isValid(void) const
00311     {
00312         uint32_t numFailed = 0;
00313         numFailed += (width == 0);
00314         numFailed += (format == RenderDataFormat::UNSPECIFIED);
00315         return (numFailed == 0);
00316     }
00317
00321     bool isTheSameAs(const UserRenderSurfaceDesc& other) const
00322     {
00323         if (width != other.width) return false;
00324         if (height != other.height) return false;
00325         if (depth != other.depth) return false;
00326         if (format != other.format) return false;
00327         if (userFlags != other.userFlags) return false;
00328         if (getUserData() != other.getUserData()) return false;
00329         if (interopFlags != other.interopFlags) return false;
00330         return true;
00331     }
00332
00333     size_t                      width;
00334     size_t                      height;
00335     size_t                      depth;
00336     RenderDataFormat::Enum      format;
00337     uint32_t                    userFlags;
00338     RenderInteropFlags::Enum    interopFlags;
00339 };
00340
00344 class UserRenderSurface : public UserRenderStorage
00345 {
00346 public:
00347
00351     virtual Type getType() const
00352     {
00353         return SURFACE;
00354     }
00355
00359     struct MappedInfo
00360     {
00361         void*       pData;
00362         uint32_t    rowPitch;
00363         uint32_t    depthPitch;
00364     };
00365
00370     virtual bool map(RenderMapType::Enum mapType, MappedInfo& info) = 0;
00371
00375     virtual void unmap() = 0;
00376
00381     virtual bool getCUDAgraphicsResource(CUgraphicsResource &ret) = 0;
00382 };
00383
00387 class UserRenderCallback
00388 {
00389 public:
00390
00394     virtual UserRenderBuffer* createRenderBuffer(const UserRenderBufferDesc& )
00395     {
00396         return NULL;
00397     }
00401     virtual UserRenderSurface* createRenderSurface(const UserRenderSurfaceDesc& )
00402     {
00403         return NULL;
00404     }
00405 };
00406
00407 PX_POP_PACK
00408
00409 }
00410 } // end namespace nvidia::apex
00411
00412 #endif
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderIndexBuffer.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Typedefs
UserRenderIndexBuffer.h File Reference

class UserRenderIndexBuffer More...

#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

class | nvidia::apex::UserRenderIndexBuffer
Used for storing index data for rendering. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Typedefs

typedef struct
CUgraphicsResource_st * 		CUgraphicsResource
Cuda graphics resource.

Detailed Description

class UserRenderIndexBuffer

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderIndexBuffer.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderIndexBuffer.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_INDEX_BUFFER_H
00031 #define USER_RENDER_INDEX_BUFFER_H
00032
00038 #include "ApexUsingNamespace.h"
00039
00043 typedef struct CUgraphicsResource_st* CUgraphicsResource;
00044
00045 namespace nvidia
00046 {
00047 namespace apex
00048 {
00049
00050 PX_PUSH_PACK_DEFAULT
00051
00055 class UserRenderIndexBuffer
00056 {
00057 public:
00058     virtual     ~UserRenderIndexBuffer() {}
00059
00062     virtual bool getInteropResourceHandle(CUgraphicsResource& handle)
00063 #if APEX_DEFAULT_NO_INTEROP_IMPLEMENTATION
00064     {
00065         PX_UNUSED(&handle);
00066         return false;
00067     }
00068 #else
00069     = 0;
00070 #endif
00071
00073     //  the source data type is assumed to be the same as what was defined in the descriptor.
00074     virtual void writeBuffer(const void* srcData, uint32_t srcStride, uint32_t firstDestElement, uint32_t numElements) = 0;
00075 };
00076
00077 PX_POP_PACK
00078
00079 }
00080 } // namespace nvidia::apex
00081
00082 #endif // USER_RENDER_INDEX_BUFFER_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderIndexBufferDesc.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
UserRenderIndexBufferDesc.h File Reference

class UserRenderIndexBufferDesc, structs RenderDataFormat and UserRenderIndexBufferDesc More...

#include "RenderDataFormat.h"
#include "UserRenderResourceManager.h"

Go to the source code of this file.

Classes

class | nvidia::apex::UserRenderIndexBufferDesc
PX_PS4. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class UserRenderIndexBufferDesc, structs RenderDataFormat and UserRenderIndexBufferDesc

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderIndexBufferDesc.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderIndexBufferDesc.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_INDEX_BUFFER_DESC_H
00031 #define USER_RENDER_INDEX_BUFFER_DESC_H
00032
00038 #include "RenderDataFormat.h"
00039 #include "UserRenderResourceManager.h"
00040
00041 namespace physx
00042 {
00043     class PxCudaContextManager;
00044 };
00045
00046 namespace nvidia
00047 {
00048 namespace apex
00049 {
00050
00051 PX_PUSH_PACK_DEFAULT
00052
00053 #if !PX_PS4
00054     #pragma warning(push)
00055     #pragma warning(disable:4121)
00056 #endif  //!PX_PS4
00057
00061 class UserRenderIndexBufferDesc
00062 {
00063 public:
00064     UserRenderIndexBufferDesc(void)
00065     {
00066         registerInCUDA = false;
00067         interopContext = 0;
00068         maxIndices = 0;
00069         hint       = RenderBufferHint::STATIC;
00070         format     = RenderDataFormat::UNSPECIFIED;
00071         primitives = RenderPrimitiveType::TRIANGLES;
00072     }
00073
00077     bool isValid(void) const
00078     {
00079         uint32_t numFailed = 0;
00080         numFailed += (registerInCUDA && !interopContext) ? 1 : 0;
00081         return (numFailed == 0);
00082     }
00083
00084 public:
00085
00089     uint32_t                    maxIndices;
00090
00094     RenderBufferHint::Enum      hint;
00095
00099     RenderDataFormat::Enum      format;
00100
00104     RenderPrimitiveType::Enum   primitives;
00105
00109     bool                        registerInCUDA;
00110
00117     PxCudaContextManager*       interopContext;
00118 };
00119
00120 #if !PX_PS4
00121     #pragma warning(pop)
00122 #endif  //!PX_PS4
00123
00124 PX_POP_PACK
00125
00126 }
00127 } // end namespace nvidia::apex
00128
00129 #endif // USER_RENDER_INDEX_BUFFER_DESC_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderInstanceBuffer.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Typedefs
UserRenderInstanceBuffer.h File Reference

class UserRenderInstanceBuffer More...

#include "RenderBufferData.h"
#include "UserRenderInstanceBufferDesc.h"

Go to the source code of this file.

Classes

class | nvidia::apex::RenderInstanceBufferData
The instance buffer type (deprecated) More...
class | nvidia::apex::UserRenderInstanceBuffer
Used for storing per-instance data for rendering. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Typedefs

typedef struct
CUgraphicsResource_st * 		CUgraphicsResource
Cuda graphics resource.

Detailed Description

class UserRenderInstanceBuffer

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderInstanceBuffer.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderInstanceBuffer.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_INSTANCE_BUFFER_H
00031 #define USER_RENDER_INSTANCE_BUFFER_H
00032
00038 #include "RenderBufferData.h"
00039 #include "UserRenderInstanceBufferDesc.h"
00040
00044 typedef struct CUgraphicsResource_st* CUgraphicsResource;
00045
00046 namespace nvidia
00047 {
00048 namespace apex
00049 {
00050
00051 PX_PUSH_PACK_DEFAULT
00055 class PX_DEPRECATED RenderInstanceBufferData : public RenderBufferData<RenderInstanceSemantic, RenderInstanceSemantic::Enum> {};
00056
00060 class UserRenderInstanceBuffer
00061 {
00062 public:
00063     virtual     ~UserRenderInstanceBuffer() {}
00064
00067     virtual bool getInteropResourceHandle(CUgraphicsResource& handle)
00068 #if APEX_DEFAULT_NO_INTEROP_IMPLEMENTATION
00069     {
00070         PX_UNUSED(&handle);
00071         return false;
00072     }
00073 #else
00074     = 0;
00075 #endif
00076
00087     virtual void writeBuffer(const void* data, uint32_t firstInstance, uint32_t numInstances)
00088     {
00089         PX_UNUSED(data);
00090         PX_UNUSED(firstInstance);
00091         PX_UNUSED(numInstances);
00092     }
00093 };
00094
00095 PX_POP_PACK
00096
00097 }
00098 } // end namespace nvidia::apex
00099
00100 #endif // USER_RENDER_INSTANCE_BUFFER_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderInstanceBufferDesc.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
UserRenderInstanceBufferDesc.h File Reference

class UserRenderInstanceBufferDesc, structs RenderDataFormat and RenderInstanceSemantic More...

#include "UserRenderResourceManager.h"
#include "RenderDataFormat.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::RenderInstanceSemantic
PX_PS4. More...
struct | nvidia::apex::RenderInstanceLayoutElement
potential semantics of a sprite buffer More...
class | nvidia::apex::UserRenderInstanceBufferDesc
Describes the data and layout of an instance buffer. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class UserRenderInstanceBufferDesc, structs RenderDataFormat and RenderInstanceSemantic

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderInstanceBufferDesc.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderInstanceBufferDesc.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_INSTANCE_BUFFER_DESC_H
00031 #define USER_RENDER_INSTANCE_BUFFER_DESC_H
00032
00038 #include "UserRenderResourceManager.h"
00039 #include "RenderDataFormat.h"
00040
00041 namespace physx
00042 {
00043     class PxCudaContextManager;
00044 };
00045
00046 namespace nvidia
00047 {
00048 namespace apex
00049 {
00050
00051 PX_PUSH_PACK_DEFAULT
00052
00053 #if !PX_PS4
00054     #pragma warning(push)
00055     #pragma warning(disable:4121)
00056 #endif  //!PX_PS4
00057
00061 struct RenderInstanceSemantic
00062 {
00066     enum Enum
00067     {
00068         POSITION = 0,
00069         ROTATION_SCALE,
00070         VELOCITY_LIFE,
00071         DENSITY,
00072         COLOR,
00073         UV_OFFSET,
00074         LOCAL_OFFSET,
00075
00076         USER_DATA,
00077
00078         POSE,
00079
00080         NUM_SEMANTICS
00081     };
00082 };
00083
00087 struct RenderInstanceLayoutElement
00088 {
00092     enum Enum
00093     {
00094         POSITION_FLOAT3,
00095         ROTATION_SCALE_FLOAT3x3,
00096         VELOCITY_LIFE_FLOAT4,
00097         DENSITY_FLOAT1,
00098         COLOR_RGBA8,
00099         COLOR_BGRA8,
00100         COLOR_FLOAT4,
00101         UV_OFFSET_FLOAT2,
00102         LOCAL_OFFSET_FLOAT3,
00103         USER_DATA_UINT1,
00104         POSE_FLOAT3x4,
00105
00106         NUM_SEMANTICS
00107     };
00108
00112     static PX_INLINE RenderDataFormat::Enum getSemanticFormat(Enum semantic)
00113     {
00114         switch (semantic)
00115         {
00116         case POSITION_FLOAT3:
00117             return RenderDataFormat::FLOAT3;
00118         case ROTATION_SCALE_FLOAT3x3:
00119             return RenderDataFormat::FLOAT3x3;
00120         case VELOCITY_LIFE_FLOAT4:
00121             return RenderDataFormat::FLOAT4;
00122         case DENSITY_FLOAT1:
00123             return RenderDataFormat::FLOAT1;
00124         case COLOR_RGBA8:
00125             return RenderDataFormat::R8G8B8A8;
00126         case COLOR_BGRA8:
00127             return RenderDataFormat::B8G8R8A8;
00128         case COLOR_FLOAT4:
00129             return RenderDataFormat::FLOAT4;
00130         case UV_OFFSET_FLOAT2:
00131             return RenderDataFormat::FLOAT2;
00132         case LOCAL_OFFSET_FLOAT3:
00133             return RenderDataFormat::FLOAT3;
00134         case USER_DATA_UINT1:
00135             return RenderDataFormat::UINT1;
00136         case POSE_FLOAT3x4:
00137             return RenderDataFormat::FLOAT3x4;
00138         default:
00139             PX_ALWAYS_ASSERT();
00140             return RenderDataFormat::NUM_FORMATS;
00141         }
00142     }
00146     static PX_INLINE RenderInstanceSemantic::Enum getSemantic(Enum semantic)
00147     {
00148         switch (semantic)
00149         {
00150         case POSITION_FLOAT3:
00151             return RenderInstanceSemantic::POSITION;
00152         case ROTATION_SCALE_FLOAT3x3:
00153             return RenderInstanceSemantic::ROTATION_SCALE;
00154         case VELOCITY_LIFE_FLOAT4:
00155             return RenderInstanceSemantic::VELOCITY_LIFE;
00156         case DENSITY_FLOAT1:
00157             return RenderInstanceSemantic::DENSITY;
00158         case COLOR_RGBA8:
00159         case COLOR_BGRA8:
00160         case COLOR_FLOAT4:
00161             return RenderInstanceSemantic::COLOR;
00162         case UV_OFFSET_FLOAT2:
00163             return RenderInstanceSemantic::UV_OFFSET;
00164         case LOCAL_OFFSET_FLOAT3:
00165             return RenderInstanceSemantic::LOCAL_OFFSET;
00166         case USER_DATA_UINT1:
00167             return RenderInstanceSemantic::USER_DATA;
00168         case POSE_FLOAT3x4:
00169             return RenderInstanceSemantic::POSE;
00170         default:
00171             PX_ALWAYS_ASSERT();
00172             return RenderInstanceSemantic::NUM_SEMANTICS;
00173         }
00174     }
00175 };
00176
00180 class UserRenderInstanceBufferDesc
00181 {
00182 public:
00183     UserRenderInstanceBufferDesc(void)
00184     {
00185         setDefaults();
00186     }
00187
00191     void setDefaults()
00192     {
00193         registerInCUDA = false;
00194         interopContext = 0;
00195         maxInstances = 0;
00196         hint         = RenderBufferHint::STATIC;
00197         for (uint32_t i = 0; i < RenderInstanceLayoutElement::NUM_SEMANTICS; i++)
00198         {
00199             semanticOffsets[i] = uint32_t(-1);
00200         }
00201         stride = 0;
00202     }
00203
00207     bool isValid(void) const
00208     {
00209         uint32_t numFailed = 0;
00210
00211         numFailed += (maxInstances == 0);
00212         numFailed += (stride == 0);
00213         numFailed += (semanticOffsets[RenderInstanceLayoutElement::POSITION_FLOAT3] == uint32_t(-1))
00214             && (semanticOffsets[RenderInstanceLayoutElement::POSE_FLOAT3x4] == uint32_t(-1));
00215         numFailed += registerInCUDA && (interopContext == 0);
00216
00217         numFailed += ((stride & 0x03) != 0);
00218         for (uint32_t i = 0; i < RenderInstanceLayoutElement::NUM_SEMANTICS; i++)
00219         {
00220             if (semanticOffsets[i] != static_cast<uint32_t>(-1))
00221             {
00222                 numFailed += (semanticOffsets[i] >= stride);
00223                 numFailed += ((semanticOffsets[i] & 0x03) != 0);
00224             }
00225         }
00226
00227         return (numFailed == 0);
00228     }
00229
00233     bool isTheSameAs(const UserRenderInstanceBufferDesc& other) const
00234     {
00235         if (registerInCUDA != other.registerInCUDA) return false;
00236         if (maxInstances != other.maxInstances) return false;
00237         if (hint != other.hint) return false;
00238
00239         if (stride != other.stride) return false;
00240         for (uint32_t i = 0; i < RenderInstanceLayoutElement::NUM_SEMANTICS; i++)
00241         {
00242             if (semanticOffsets[i] != other.semanticOffsets[i]) return false;
00243         }
00244         return true;
00245     }
00246
00247 public:
00248     uint32_t                    maxInstances;
00249     RenderBufferHint::Enum      hint;
00250
00254     uint32_t                    semanticOffsets[RenderInstanceLayoutElement::NUM_SEMANTICS];
00255
00256     uint32_t                    stride;
00257
00258     bool                        registerInCUDA;
00259
00264     PxCudaContextManager*       interopContext;
00265 };
00266
00267 #if !PX_PS4
00268     #pragma warning(pop)
00269 #endif  //!PX_PS4
00270
00271 PX_POP_PACK
00272
00273 }
00274 } // end namespace nvidia::apex
00275
00276 #endif // USER_RENDER_INSTANCE_BUFFER_DESC_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderResource.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
UserRenderResource.h File Reference

class UserRenderResource More...

#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

class | nvidia::apex::UserRenderResource
An abstract interface to a renderable resource. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class UserRenderResource

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderResource.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderResource.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_RESOURCE_H
00031 #define USER_RENDER_RESOURCE_H
00032
00038 #include "ApexUsingNamespace.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 class UserRenderVertexBuffer;
00046 class UserRenderIndexBuffer;
00047 class UserRenderBoneBuffer;
00048 class UserRenderInstanceBuffer;
00049 class UserRenderSpriteBuffer;
00050
00051
00052 PX_PUSH_PACK_DEFAULT
00053
00057 class UserRenderResource
00058 {
00059 public:
00060     virtual ~UserRenderResource() {}
00061
00063     virtual void setVertexBufferRange(uint32_t firstVertex, uint32_t numVerts) = 0;
00065     virtual void setIndexBufferRange(uint32_t firstIndex, uint32_t numIndices) = 0;
00067     virtual void setBoneBufferRange(uint32_t firstBone, uint32_t numBones) = 0;
00069     virtual void setInstanceBufferRange(uint32_t firstInstance, uint32_t numInstances) = 0;
00071     virtual void setSpriteBufferRange(uint32_t firstSprite, uint32_t numSprites) = 0;
00073     virtual void setSpriteVisibleCount(uint32_t visibleCount) { PX_UNUSED(visibleCount); }
00075     virtual void setMaterial(void* material) = 0;
00076
00078     virtual uint32_t getNbVertexBuffers() const = 0;
00080     virtual UserRenderVertexBuffer* getVertexBuffer(uint32_t index) const = 0;
00082     virtual UserRenderIndexBuffer* getIndexBuffer() const = 0;
00084     virtual UserRenderBoneBuffer* getBoneBuffer() const = 0;
00086     virtual UserRenderInstanceBuffer* getInstanceBuffer() const = 0;
00088     virtual UserRenderSpriteBuffer* getSpriteBuffer() const = 0;
00089 };
00090
00091 PX_POP_PACK
00092
00093 }
00094 } // end namespace nvidia::apex
00095
00096 #endif
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderResourceDesc.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
UserRenderResourceDesc.h File Reference

class UserRenderResourceDesc More...

#include "UserRenderResourceManager.h"
#include "foundation/PxAssert.h"

Go to the source code of this file.

Classes

class | nvidia::apex::UserRenderResourceDesc
Describes all the data that makes up a renderable resource. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class UserRenderResourceDesc

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderResourceDesc.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderResourceDesc.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_RESOURCE_DESC_H
00031 #define USER_RENDER_RESOURCE_DESC_H
00032
00038 #include "UserRenderResourceManager.h"
00039 #include "foundation/PxAssert.h"
00040
00041 namespace nvidia
00042 {
00043 namespace apex
00044 {
00045
00046 PX_PUSH_PACK_DEFAULT
00047
00048 class Renderable;
00049 class UserOpaqueMesh;
00050 class UserRenderVertexBuffer;
00051 class UserRenderIndexBuffer;
00052 class UserRenderBoneBuffer;
00053 class UserRenderInstanceBuffer;
00054 class UserRenderSpriteBuffer;
00055
00059 class UserRenderResourceDesc
00060 {
00061 public:
00062     UserRenderResourceDesc(void)
00063     {
00064         firstVertex      = 0;
00065         numVerts         = 0;
00066
00067         indexBuffer      = 0;
00068         firstIndex       = 0;
00069         numIndices       = 0;
00070
00071         boneBuffer       = 0;
00072         firstBone        = 0;
00073         numBones         = 0;
00074
00075         instanceBuffer   = 0;
00076         firstInstance    = 0;
00077         numInstances     = 0;
00078
00079         spriteBuffer     = 0;
00080         firstSprite      = 0;
00081         numSprites       = 0;
00082         visibleSpriteCount = 0;
00083
00084         material         = 0;
00085         submeshIndex     = 0;
00086
00087         userRenderData   = 0;
00088
00089         numVertexBuffers = 0;
00090         vertexBuffers     = NULL;
00091
00092         cullMode         = RenderCullMode::CLOCKWISE;
00093         primitives       = RenderPrimitiveType::UNKNOWN;
00094
00095         opaqueMesh      = NULL;
00096     }
00097
00101     bool isValid(void) const
00102     {
00103         uint32_t numFailed = 0;
00104         if (numVertexBuffers >= 255)
00105         {
00106             numFailed++;
00107         }
00108         if (numIndices   && !indexBuffer)
00109         {
00110             numFailed++;
00111         }
00112         if (numBones     && !boneBuffer)
00113         {
00114             numFailed++;
00115         }
00116         if (numInstances && !instanceBuffer)
00117         {
00118             numFailed++;
00119         }
00120         if (numSprites   && !spriteBuffer)
00121         {
00122             numFailed++;
00123         }
00124         PX_ASSERT(numFailed == 0);
00125         return numFailed == 0;
00126     }
00127
00128 public:
00129     UserOpaqueMesh*             opaqueMesh;
00130     UserRenderVertexBuffer**    vertexBuffers;
00131
00132     uint32_t                    numVertexBuffers;
00133
00134     uint32_t                    firstVertex;
00135     uint32_t                    numVerts;
00136
00137     UserRenderIndexBuffer*      indexBuffer;
00138     uint32_t                    firstIndex;
00139     uint32_t                    numIndices;
00140
00141     UserRenderBoneBuffer*       boneBuffer;
00142     uint32_t                    firstBone;
00143     uint32_t                    numBones;
00144
00145     UserRenderInstanceBuffer*   instanceBuffer;
00146     uint32_t                    firstInstance;
00147     uint32_t                    numInstances;
00148
00149     UserRenderSpriteBuffer*     spriteBuffer;
00150     uint32_t                    firstSprite;
00151     uint32_t                    numSprites;
00152     uint32_t                    visibleSpriteCount;
00153
00154     UserRenderSurfaceBuffer**   surfaceBuffers;
00155     uint32_t                    numSurfaceBuffers;
00156     uint32_t                    widthSurfaceBuffers;
00157     uint32_t                    heightSurfaceBuffers;
00158
00159     void*                       material;
00160     uint32_t                    submeshIndex;
00161
00163     void*                       userRenderData;
00164
00165     RenderCullMode::Enum        cullMode;
00166     RenderPrimitiveType::Enum   primitives;
00167 };
00168
00169 PX_POP_PACK
00170
00171 }
00172 } // end namespace nvidia::apex
00173
00174 #endif
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderResourceManager.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
UserRenderResourceManager.h File Reference

class UserRenderResourceManager, structs RenderPrimitiveType, RenderBufferHint, and RenderCullMode More...

#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::RenderPrimitiveType
Describe the implied vertex ordering. More...
struct | nvidia::apex::RenderCullMode
Possible triangle culling modes. More...
struct | nvidia::apex::RenderBufferHint
Hint of the buffer data lifespan. More...
class | nvidia::apex::UserRenderResourceManager
User defined renderable resource manager. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class UserRenderResourceManager, structs RenderPrimitiveType, RenderBufferHint, and RenderCullMode

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderResourceManager.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderResourceManager.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_RESOURCE_MANAGER_H
00031 #define USER_RENDER_RESOURCE_MANAGER_H
00032
00038 #include "ApexUsingNamespace.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 PX_PUSH_PACK_DEFAULT
00046
00047 class UserRenderVertexBuffer;
00048 class UserRenderVertexBufferDesc;
00049 class UserRenderIndexBuffer;
00050 class UserRenderIndexBufferDesc;
00051 class UserRenderSurfaceBuffer;
00052 class UserRenderSurfaceBufferDesc;
00053 class UserRenderBoneBuffer;
00054 class UserRenderBoneBufferDesc;
00055 class UserRenderInstanceBuffer;
00056 class UserRenderInstanceBufferDesc;
00057 class UserRenderSpriteBuffer;
00058 class UserRenderSpriteBufferDesc;
00059 class UserRenderResource;
00060 class UserRenderResourceDesc;
00061 class UserOpaqueMesh;
00062 class UserOpaqueMeshDesc;
00063
00064 class UserRenderSpriteTextureDesc;
00065
00069 struct RenderPrimitiveType
00070 {
00074     enum Enum
00075     {
00076         UNKNOWN = 0,
00077
00078         TRIANGLES,
00079         TRIANGLE_STRIP,
00080
00081         LINES,
00082         LINE_STRIP,
00083
00084         POINTS,
00085         POINT_SPRITES,
00086     };
00087 };
00088
00092 struct RenderCullMode
00093 {
00097     enum Enum
00098     {
00099         CLOCKWISE = 0,
00100         COUNTER_CLOCKWISE,
00101         NONE
00102     };
00103 };
00104
00108 struct RenderBufferHint
00109 {
00113     enum Enum
00114     {
00115         STATIC = 0,
00116         DYNAMIC,
00117         STREAMING,
00118     };
00119 };
00120
00128 class UserRenderResourceManager
00129 {
00130 public:
00131     virtual                             ~UserRenderResourceManager() {}
00132
00139     virtual UserRenderVertexBuffer*     createVertexBuffer(const UserRenderVertexBufferDesc& desc)     = 0;
00141     virtual void                        releaseVertexBuffer(UserRenderVertexBuffer& buffer)            = 0;
00142
00144     virtual UserRenderIndexBuffer*      createIndexBuffer(const UserRenderIndexBufferDesc& desc)       = 0;
00146     virtual void                        releaseIndexBuffer(UserRenderIndexBuffer& buffer)              = 0;
00147
00149     virtual UserRenderBoneBuffer*       createBoneBuffer(const UserRenderBoneBufferDesc& desc)         = 0;
00151     virtual void                        releaseBoneBuffer(UserRenderBoneBuffer& buffer)                = 0;
00152
00154     virtual UserRenderInstanceBuffer*   createInstanceBuffer(const UserRenderInstanceBufferDesc& desc) = 0;
00156     virtual void                        releaseInstanceBuffer(UserRenderInstanceBuffer& buffer)        = 0;
00157
00159     virtual UserRenderSpriteBuffer*     createSpriteBuffer(const UserRenderSpriteBufferDesc& desc)     = 0;
00161     virtual void                        releaseSpriteBuffer(UserRenderSpriteBuffer& buffer)            = 0;
00162
00164     virtual UserRenderSurfaceBuffer*    createSurfaceBuffer(const UserRenderSurfaceBufferDesc& desc)   = 0;
00166     virtual void                        releaseSurfaceBuffer(UserRenderSurfaceBuffer& buffer)          = 0;
00167
00169     virtual UserRenderResource*         createResource(const UserRenderResourceDesc& desc)             = 0;
00170
00175     virtual void                        releaseResource(UserRenderResource& resource)                  = 0;
00176
00181     virtual uint32_t                    getMaxBonesForMaterial(void* material)                         = 0;
00182
00183
00189     virtual bool                        getSpriteLayoutData(uint32_t spriteCount, uint32_t spriteSemanticsBitmap, UserRenderSpriteBufferDesc* textureDescArray) = 0;
00190
00196     virtual bool                        getInstanceLayoutData(uint32_t spriteCount, uint32_t spriteSemanticsBitmap, UserRenderInstanceBufferDesc* instanceDescArray) = 0;
00197
00198 };
00199
00200 PX_POP_PACK
00201
00202 }
00203 } // end namespace nvidia::apex
00204
00205 #endif
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderSpriteBuffer.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Typedefs
UserRenderSpriteBuffer.h File Reference

class UserRenderSpriteBuffer More...

#include "RenderBufferData.h"
#include "UserRenderSpriteBufferDesc.h"

Go to the source code of this file.

Classes

class | nvidia::apex::RenderSpriteBufferData
Sprite buffer data (deprecated) More...
class | nvidia::apex::UserRenderSpriteBuffer
Used for storing per-sprite instance data for rendering. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Typedefs

typedef struct
CUgraphicsResource_st * 		CUgraphicsResource
Cuda graphics resource.

Detailed Description

class UserRenderSpriteBuffer

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderSpriteBuffer.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderSpriteBuffer.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_SPRITE_BUFFER_H
00031 #define USER_RENDER_SPRITE_BUFFER_H
00032
00038 #include "RenderBufferData.h"
00039 #include "UserRenderSpriteBufferDesc.h"
00040
00044 typedef struct CUgraphicsResource_st* CUgraphicsResource;
00045
00046 namespace nvidia
00047 {
00048 namespace apex
00049 {
00050
00051 PX_PUSH_PACK_DEFAULT
00052
00056 class PX_DEPRECATED RenderSpriteBufferData : public RenderBufferData<RenderSpriteSemantic, RenderSpriteSemantic::Enum>, public ModuleSpecificRenderBufferData
00057 {
00058 };
00059
00063 class UserRenderSpriteBuffer
00064 {
00065 public:
00066     virtual     ~UserRenderSpriteBuffer() {}
00067
00079     virtual void writeBuffer(const void* data, uint32_t firstSprite, uint32_t numSprites)
00080     {
00081         PX_UNUSED(data);
00082         PX_UNUSED(firstSprite);
00083         PX_UNUSED(numSprites);
00084     }
00085
00088     virtual bool getInteropResourceHandle(CUgraphicsResource& handle)
00089 #if APEX_DEFAULT_NO_INTEROP_IMPLEMENTATION
00090     {
00091         PX_UNUSED(&handle);
00092         return false;
00093     }
00094 #else
00095     = 0;
00096 #endif
00097
00101     virtual bool getInteropTextureHandleList(CUgraphicsResource* handleList)
00102     {
00103         PX_UNUSED(handleList);
00104         return false;
00105     }
00106
00110     virtual void writeTexture(uint32_t textureId, uint32_t numSprites, const void* srcData, size_t srcSize)
00111     {
00112         PX_UNUSED(textureId);
00113         PX_UNUSED(numSprites);
00114         PX_UNUSED(srcData);
00115         PX_UNUSED(srcSize);
00116
00117         PX_ALWAYS_ASSERT();
00118     }
00119 };
00120
00121 PX_POP_PACK
00122
00123 }
00124 } // end namespace nvidia::apex
00125
00126 #endif // USER_RENDER_SPRITE_BUFFER_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderSpriteBufferDesc.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
UserRenderSpriteBufferDesc.h File Reference

class UserRenderSpriteBufferDesc, structs RenderDataFormat and RenderSpriteSemantic More...

#include "ApexUsingNamespace.h"
#include "RenderDataFormat.h"
#include "UserRenderResourceManager.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::RenderSpriteSemantic
PX_PS4. More...
struct | nvidia::apex::RenderSpriteLayoutElement
potential semantics of a sprite buffer More...
struct | nvidia::apex::RenderSpriteTextureLayout
Struct for sprite texture layout info. More...
class | nvidia::apex::UserRenderSpriteTextureDesc
Class for storing sprite texture render data. More...
class | nvidia::apex::UserRenderSpriteBufferDesc
describes the semantics and layout of a sprite buffer More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class UserRenderSpriteBufferDesc, structs RenderDataFormat and RenderSpriteSemantic

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderSpriteBufferDesc.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderSpriteBufferDesc.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_SPRITE_BUFFER_DESC_H
00031 #define USER_RENDER_SPRITE_BUFFER_DESC_H
00032
00038 #include "ApexUsingNamespace.h"
00039 #include "RenderDataFormat.h"
00040 #include "UserRenderResourceManager.h"
00041
00042 namespace physx
00043 {
00044     class PxCudaContextManager;
00045 };
00046
00047 namespace nvidia
00048 {
00049 namespace apex
00050 {
00051
00052 PX_PUSH_PACK_DEFAULT
00053
00054 #if !PX_PS4
00055     #pragma warning(push)
00056     #pragma warning(disable:4121)
00057 #endif  //!PX_PS4
00058
00062 struct RenderSpriteSemantic
00063 {
00067     enum Enum
00068     {
00069         POSITION = 0,
00070         COLOR,
00071         VELOCITY,
00072         SCALE,
00073         LIFE_REMAIN,
00074         DENSITY,
00075         SUBTEXTURE,
00076         ORIENTATION,
00077
00078         USER_DATA,
00079
00080         NUM_SEMANTICS
00081     };
00082 };
00083
00087 struct RenderSpriteLayoutElement
00088 {
00092     enum Enum
00093     {
00094         POSITION_FLOAT3,
00095         COLOR_RGBA8,
00096         COLOR_BGRA8,
00097         COLOR_FLOAT4,
00098         VELOCITY_FLOAT3,
00099         SCALE_FLOAT2,
00100         LIFE_REMAIN_FLOAT1,
00101         DENSITY_FLOAT1,
00102         SUBTEXTURE_FLOAT1,
00103         ORIENTATION_FLOAT1,
00104         USER_DATA_UINT1,
00105
00106         NUM_SEMANTICS
00107     };
00108
00112     static PX_INLINE RenderDataFormat::Enum getSemanticFormat(Enum semantic)
00113     {
00114         switch (semantic)
00115         {
00116         case POSITION_FLOAT3:
00117             return RenderDataFormat::FLOAT3;
00118         case COLOR_RGBA8:
00119             return RenderDataFormat::R8G8B8A8;
00120         case COLOR_BGRA8:
00121             return RenderDataFormat::B8G8R8A8;
00122         case COLOR_FLOAT4:
00123             return RenderDataFormat::FLOAT4;
00124         case VELOCITY_FLOAT3:
00125             return RenderDataFormat::FLOAT3;
00126         case SCALE_FLOAT2:
00127             return RenderDataFormat::FLOAT2;
00128         case LIFE_REMAIN_FLOAT1:
00129             return RenderDataFormat::FLOAT1;
00130         case DENSITY_FLOAT1:
00131             return RenderDataFormat::FLOAT1;
00132         case SUBTEXTURE_FLOAT1:
00133             return RenderDataFormat::FLOAT1;
00134         case ORIENTATION_FLOAT1:
00135             return RenderDataFormat::FLOAT1;
00136         case USER_DATA_UINT1:
00137             return RenderDataFormat::UINT1;
00138         default:
00139             PX_ALWAYS_ASSERT();
00140             return RenderDataFormat::NUM_FORMATS;
00141         }
00142     }
00146     static PX_INLINE RenderSpriteSemantic::Enum getSemantic(Enum semantic)
00147     {
00148         switch (semantic)
00149         {
00150         case POSITION_FLOAT3:
00151             return RenderSpriteSemantic::POSITION;
00152         case COLOR_RGBA8:
00153         case COLOR_BGRA8:
00154         case COLOR_FLOAT4:
00155             return RenderSpriteSemantic::COLOR;
00156         case VELOCITY_FLOAT3:
00157             return RenderSpriteSemantic::VELOCITY;
00158         case SCALE_FLOAT2:
00159             return RenderSpriteSemantic::SCALE;
00160         case LIFE_REMAIN_FLOAT1:
00161             return RenderSpriteSemantic::LIFE_REMAIN;
00162         case DENSITY_FLOAT1:
00163             return RenderSpriteSemantic::DENSITY;
00164         case SUBTEXTURE_FLOAT1:
00165             return RenderSpriteSemantic::SUBTEXTURE;
00166         case ORIENTATION_FLOAT1:
00167             return RenderSpriteSemantic::ORIENTATION;
00168         case USER_DATA_UINT1:
00169             return RenderSpriteSemantic::USER_DATA;
00170         default:
00171             PX_ALWAYS_ASSERT();
00172             return RenderSpriteSemantic::NUM_SEMANTICS;
00173         }
00174     }
00175 };
00176
00180 struct RenderSpriteTextureLayout
00181 {
00185     enum Enum
00186     {
00187         NONE = 0,
00188         POSITION_FLOAT4, //float4(POSITION.x, POSITION.y, POSITION.z, 1)
00189         SCALE_ORIENT_SUBTEX_FLOAT4, //float4(SCALE.x, SCALE.y, ORIENTATION, SUBTEXTURE)
00190         COLOR_RGBA8,
00191         COLOR_BGRA8,
00192         COLOR_FLOAT4,
00193         NUM_LAYOUTS
00194     };
00195
00199     static PX_INLINE RenderDataFormat::Enum getLayoutFormat(Enum layout)
00200     {
00201         switch (layout)
00202         {
00203         case NONE:
00204             return RenderDataFormat::UNSPECIFIED;
00205         case POSITION_FLOAT4:
00206             return RenderDataFormat::FLOAT4;
00207         case SCALE_ORIENT_SUBTEX_FLOAT4:
00208             return RenderDataFormat::FLOAT4;
00209         case COLOR_RGBA8:
00210             return RenderDataFormat::R8G8B8A8;
00211         case COLOR_BGRA8:
00212             return RenderDataFormat::B8G8R8A8;
00213         case COLOR_FLOAT4:
00214             return RenderDataFormat::R32G32B32A32_FLOAT;
00215         default:
00216             PX_ALWAYS_ASSERT();
00217             return RenderDataFormat::NUM_FORMATS;
00218         }
00219     }
00220
00221 };
00222
00226 class UserRenderSpriteTextureDesc
00227 {
00228 public:
00229     RenderSpriteTextureLayout::Enum layout;
00230     uint32_t width;
00231     uint32_t height;
00232     uint32_t pitchBytes;
00233     uint32_t arrayIndex;
00234     uint32_t mipLevel;
00235
00236 public:
00237     PX_INLINE UserRenderSpriteTextureDesc(void)
00238     {
00239         layout = RenderSpriteTextureLayout::NONE;
00240         width = 0;
00241         height = 0;
00242         pitchBytes = 0;
00243
00244         arrayIndex = 0;
00245         mipLevel = 0;
00246     }
00247
00251     bool isTheSameAs(const UserRenderSpriteTextureDesc& other) const
00252     {
00253         if (layout != other.layout) return false;
00254         if (width != other.width) return false;
00255         if (height != other.height) return false;
00256         if (pitchBytes != other.pitchBytes) return false;
00257         if (arrayIndex != other.arrayIndex) return false;
00258         if (mipLevel != other.mipLevel) return false;
00259         return true;
00260     }
00261 };
00262
00266 class UserRenderSpriteBufferDesc
00267 {
00268 public:
00272     static const uint32_t MAX_SPRITE_TEXTURES = 4;
00273
00274     UserRenderSpriteBufferDesc(void)
00275     {
00276         setDefaults();
00277     }
00278
00282     void setDefaults()
00283     {
00284         maxSprites = 0;
00285         hint         = RenderBufferHint::STATIC;
00286         registerInCUDA = false;
00287         interopContext = 0;
00288
00289         for (uint32_t i = 0; i < RenderSpriteLayoutElement::NUM_SEMANTICS; i++)
00290         {
00291             semanticOffsets[i] = static_cast<uint32_t>(-1);
00292         }
00293         stride = 0;
00294
00295         textureCount = 0;
00296     }
00297
00301     bool isValid(void) const
00302     {
00303         uint32_t numFailed = 0;
00304
00305         numFailed += (maxSprites == 0);
00306         numFailed += (textureCount == 0) && (stride == 0);
00307         numFailed += (textureCount == 0) && (semanticOffsets[RenderSpriteLayoutElement::POSITION_FLOAT3] == uint32_t(-1));
00308         numFailed += registerInCUDA && (interopContext == 0);
00309
00310         numFailed += ((stride & 0x03) != 0);
00311         for (uint32_t i = 0; i < RenderSpriteLayoutElement::NUM_SEMANTICS; i++)
00312         {
00313             if (semanticOffsets[i] != static_cast<uint32_t>(-1))
00314             {
00315                 numFailed += (semanticOffsets[i] >= stride);
00316                 numFailed += ((semanticOffsets[i] & 0x03) != 0);
00317             }
00318         }
00319
00320         return (numFailed == 0);
00321     }
00322
00326     bool isTheSameAs(const UserRenderSpriteBufferDesc& other) const
00327     {
00328         if (registerInCUDA != other.registerInCUDA) return false;
00329         if (maxSprites != other.maxSprites) return false;
00330         if (hint != other.hint) return false;
00331         if (textureCount != other.textureCount) return false;
00332         if (textureCount == 0)
00333         {
00334             if (stride != other.stride) return false;
00335             for (uint32_t i = 0; i < RenderSpriteLayoutElement::NUM_SEMANTICS; i++)
00336             {
00337                 if (semanticOffsets[i] != other.semanticOffsets[i]) return false;
00338             }
00339         }
00340         else
00341         {
00342             for (uint32_t i = 0; i < textureCount; i++)
00343             {
00344                 if (textureDescs[i].isTheSameAs(other.textureDescs[i]) == false) return false;
00345             }
00346         }
00347         return true;
00348     }
00349
00350 public:
00351     uint32_t                    maxSprites;
00352     RenderBufferHint::Enum      hint;
00353
00357     uint32_t                    semanticOffsets[RenderSpriteLayoutElement::NUM_SEMANTICS];
00358
00359     uint32_t                    stride;
00360
00361     bool                        registerInCUDA;
00362
00367     PxCudaContextManager*       interopContext;
00368
00369     uint32_t                    textureCount;
00370     UserRenderSpriteTextureDesc textureDescs[MAX_SPRITE_TEXTURES];
00371 };
00372
00373 #if !PX_PS4
00374     #pragma warning(pop)
00375 #endif  //!PX_PS4
00376
00377 PX_POP_PACK
00378
00379 }
00380 } // end namespace nvidia::apex
00381
00382 #endif // USER_RENDER_SPRITE_BUFFER_DESC_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderSurfaceBuffer.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Typedefs
UserRenderSurfaceBuffer.h File Reference

classes UserRenderSurfaceBuffer and RenderSurfaceBufferData More...

#include "UserRenderSurfaceBufferDesc.h"

Go to the source code of this file.

Classes

class | nvidia::apex::RenderSurfaceBufferData
surface buffer data More...
class | nvidia::apex::UserRenderSurfaceBuffer
Used for storing per-vertex data for rendering. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Typedefs

typedef struct
CUgraphicsResource_st * 		CUgraphicsResource
Cuda graphics resource.

Detailed Description

classes UserRenderSurfaceBuffer and RenderSurfaceBufferData

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderSurfaceBuffer.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderSurfaceBuffer.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_SURFACE_BUFFER_H
00031 #define USER_RENDER_SURFACE_BUFFER_H
00032
00038 #include "UserRenderSurfaceBufferDesc.h"
00039
00043 typedef struct CUgraphicsResource_st* CUgraphicsResource;
00044
00045 namespace nvidia
00046 {
00047 namespace apex
00048 {
00049
00050 PX_PUSH_PACK_DEFAULT
00051
00055 class RenderSurfaceBufferData {};
00056
00060 class UserRenderSurfaceBuffer
00061 {
00062 public:
00063     virtual     ~UserRenderSurfaceBuffer() {}
00064
00080     virtual void writeBuffer(const void* srcData, uint32_t srcPitch, uint32_t srcHeight, uint32_t dstX, uint32_t dstY, uint32_t dstZ, uint32_t width, uint32_t height, uint32_t depth) = 0;
00081
00082
00085     virtual bool getInteropResourceHandle(CUgraphicsResource& handle)
00086 #if APEX_DEFAULT_NO_INTEROP_IMPLEMENTATION
00087     {
00088         PX_UNUSED(&handle);
00089         return false;
00090     }
00091 #else
00092     = 0;
00093 #endif
00094
00095 };
00096
00097 PX_POP_PACK
00098
00099 }
00100 } // end namespace nvidia::apex
00101
00102 #endif // USER_RENDER_SURFACE_BUFFER_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderSurfaceBufferDesc.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
UserRenderSurfaceBufferDesc.h File Reference

class UserRenderSurfaceBufferDesc, structs RenderDataFormat and RenderSurfaceSemantic More...

#include "ApexUsingNamespace.h"
#include "UserRenderResourceManager.h"
#include "RenderDataFormat.h"
#include "ApexSDK.h"

Go to the source code of this file.

Classes

class | nvidia::apex::UserRenderSurfaceBufferDesc
Describes the semantics and layout of a Surface buffer. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class UserRenderSurfaceBufferDesc, structs RenderDataFormat and RenderSurfaceSemantic

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderSurfaceBufferDesc.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderSurfaceBufferDesc.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_SURFACE_BUFFER_DESC_H
00031 #define USER_RENDER_SURFACE_BUFFER_DESC_H
00032
00038 #include "ApexUsingNamespace.h"
00039 #include "UserRenderResourceManager.h"
00040 #include "RenderDataFormat.h"
00041 #include "ApexSDK.h"
00042
00043 namespace physx
00044 {
00045     class PxCudaContextManager;
00046 }
00047
00048 namespace nvidia
00049 {
00050 namespace apex
00051 {
00052
00053 PX_PUSH_PACK_DEFAULT
00054
00058 class UserRenderSurfaceBufferDesc
00059 {
00060 public:
00061     UserRenderSurfaceBufferDesc(void)
00062     {
00063         setDefaults();
00064     }
00065
00069     void setDefaults()
00070     {
00071 //      hint   = RenderBufferHint::STATIC;
00072         format = RenderDataFormat::UNSPECIFIED;
00073
00074         width = 0;
00075         height = 0;
00076         depth = 1;
00077
00078         //moduleIdentifier = 0;
00079
00080         registerInCUDA = false;
00081         interopContext = 0;
00082 //      stride = 0;
00083     }
00084
00088     bool isValid(void) const
00089     {
00090         uint32_t numFailed = 0;
00091         numFailed += (format == RenderDataFormat::UNSPECIFIED);
00092         numFailed += (width == 0) && (height == 0) && (depth == 0);
00093         numFailed += registerInCUDA && (interopContext == 0);
00094 //      numFailed += registerInCUDA && (stride == 0);
00095
00096         return (numFailed == 0);
00097     }
00098
00099 public:
00103     uint32_t                width;
00104
00108     uint32_t                height;
00109
00113     uint32_t                depth;
00114
00118     RenderDataFormat::Enum  format;
00119
00120     bool                    registerInCUDA;
00121
00126     PxCudaContextManager*   interopContext;
00127 };
00128
00129 PX_POP_PACK
00130
00131 }
00132 } // end namespace nvidia::apex
00133
00134 #endif // USER_RENDER_SURFACE_BUFFER_DESC_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderVertexBuffer.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces | Typedefs
UserRenderVertexBuffer.h File Reference

classes UserRenderVertexBuffer and RenderVertexBufferData More...

#include "RenderBufferData.h"
#include "UserRenderVertexBufferDesc.h"
#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

class | nvidia::apex::RenderVertexBufferData
vertex buffer data More...
class | nvidia::apex::UserRenderVertexBuffer
Used for storing per-vertex data for rendering. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Typedefs

typedef struct
CUgraphicsResource_st * 		CUgraphicsResource
Cuda graphics resource.

Detailed Description

classes UserRenderVertexBuffer and RenderVertexBufferData

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderVertexBuffer.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderVertexBuffer.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_VERTEX_BUFFER_H
00031 #define USER_RENDER_VERTEX_BUFFER_H
00032
00038 #include "RenderBufferData.h"
00039 #include "UserRenderVertexBufferDesc.h"
00040
00041 #include "ApexUsingNamespace.h"
00042
00046 typedef struct CUgraphicsResource_st* CUgraphicsResource;
00047
00048 namespace nvidia
00049 {
00050 namespace apex
00051 {
00052
00053 PX_PUSH_PACK_DEFAULT
00054
00058 class RenderVertexBufferData : public RenderBufferData<RenderVertexSemantic, RenderVertexSemantic::Enum>, public ModuleSpecificRenderBufferData
00059 {
00060 };
00061
00065 class UserRenderVertexBuffer
00066 {
00067 public:
00068     virtual     ~UserRenderVertexBuffer() {}
00069
00072     virtual bool getInteropResourceHandle(CUgraphicsResource& handle)
00073 #if APEX_DEFAULT_NO_INTEROP_IMPLEMENTATION
00074     {
00075         PX_UNUSED(&handle);
00076         return false;
00077     }
00078 #else
00079     = 0;
00080 #endif
00081
00093     virtual void writeBuffer(const nvidia::RenderVertexBufferData& data, uint32_t firstVertex, uint32_t numVertices) = 0;
00094 };
00095
00096 PX_POP_PACK
00097
00098 }
00099 } // end namespace nvidia::apex
00100
00101 #endif // USER_RENDER_VERTEX_BUFFER_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderVertexBufferDesc.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
UserRenderVertexBufferDesc.h File Reference

class UserRenderVertexBufferDesc, structs RenderDataFormat and RenderVertexSemantic More...

#include "ApexUsingNamespace.h"
#include "UserRenderResourceManager.h"
#include "RenderDataFormat.h"
#include "ApexSDK.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::RenderVertexSemantic
Potential semantics of a vertex buffer. More...
struct | nvidia::apex::TextureUVOrigin
Texture UV direction convention. More...
class | nvidia::apex::UserRenderVertexBufferDesc
Describes the semantics and layout of a vertex buffer. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class UserRenderVertexBufferDesc, structs RenderDataFormat and RenderVertexSemantic

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderVertexBufferDesc.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderVertexBufferDesc.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDER_VERTEX_BUFFER_DESC_H
00031 #define USER_RENDER_VERTEX_BUFFER_DESC_H
00032
00038 #include "ApexUsingNamespace.h"
00039 #include "UserRenderResourceManager.h"
00040 #include "RenderDataFormat.h"
00041 #include "ApexSDK.h"
00042
00043 namespace physx
00044 {
00045     class PxCudaContextManager;
00046 };
00047
00048 namespace nvidia
00049 {
00050 namespace apex
00051 {
00052
00053 PX_PUSH_PACK_DEFAULT
00054
00058 struct RenderVertexSemantic
00059 {
00063     enum Enum
00064     {
00065         CUSTOM = -1,
00066
00067         POSITION = 0,
00068         NORMAL,
00069         TANGENT,
00070         BINORMAL,
00071         COLOR,
00072         TEXCOORD0,
00073         TEXCOORD1,
00074         TEXCOORD2,
00075         TEXCOORD3,
00076         BONE_INDEX,
00077         BONE_WEIGHT,
00078
00079         DISPLACEMENT_TEXCOORD,
00080         DISPLACEMENT_FLAGS,
00081
00082         NUM_SEMANTICS
00083     };
00084 };
00085
00089 struct TextureUVOrigin
00090 {
00094     enum Enum
00095     {
00096         ORIGIN_TOP_LEFT = 0,
00097         ORIGIN_TOP_RIGHT = 1,
00098         ORIGIN_BOTTOM_LEFT = 2,
00099         ORIGIN_BOTTOM_RIGHT = 3,
00100
00101         ORIGIN_UNKNOWN = 0xFFFFFFFF
00102     };
00103 };
00104
00105
00109 class UserRenderVertexBufferDesc
00110 {
00111 public:
00112     UserRenderVertexBufferDesc(void)
00113     {
00114         interopContext = 0;
00115         registerInCUDA = false;
00116         maxVerts = 0;
00117         hint     = RenderBufferHint::STATIC;
00118         for (uint32_t i = 0; i < RenderVertexSemantic::NUM_SEMANTICS; i++)
00119         {
00120             buffersRequest[i] = RenderDataFormat::UNSPECIFIED;
00121         }
00122         moduleIdentifier = 0;
00123         numCustomBuffers = 0;
00124         customBuffersIdents = NULL;
00125         customBuffersRequest = NULL;
00126         uvOrigin         = TextureUVOrigin::ORIGIN_TOP_LEFT;
00127         canBeShared      = true;
00128     }
00129
00133     bool isValid(void) const
00134     {
00135         uint32_t numFailed = 0;
00136         if (maxVerts == 0)
00137         {
00138             numFailed++;
00139         }
00140         if (!customBuffersRequest)
00141         {
00142             uint32_t vertexSize = 0;
00143             for (uint32_t i = 0; i < RenderVertexSemantic::NUM_SEMANTICS; i++)
00144             {
00145                 vertexSize += RenderDataFormat::getFormatDataSize(buffersRequest[i]);
00146             }
00147             if (vertexSize == 0)
00148             {
00149                 numFailed++;
00150             }
00151         }
00152         return (numFailed == 0);
00153     }
00154
00155 public:
00159     uint32_t                    maxVerts;
00160
00164     RenderBufferHint::Enum      hint;
00165
00171     RenderDataFormat::Enum      buffersRequest[RenderVertexSemantic::NUM_SEMANTICS];
00172
00180     uint32_t                    numCustomBuffers;
00181
00185     void**                      customBuffersIdents;
00186
00190     RenderDataFormat::Enum*     customBuffersRequest;
00191
00195     AuthObjTypeID               moduleIdentifier;
00196
00200     TextureUVOrigin::Enum       uvOrigin;
00201
00205     bool                        canBeShared;
00206
00210     bool                        registerInCUDA;
00211
00218     PxCudaContextManager*       interopContext;
00219 };
00220
00221 PX_POP_PACK
00222
00223 }
00224 } // end namespace nvidia::apex
00225
00226 #endif // USER_RENDER_VERTEX_BUFFER_DESC_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderer.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
UserRenderer.h File Reference

class UserRenderer More...

#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

class | nvidia::apex::UserRenderer
User provided renderer interface. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class UserRenderer

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: UserRenderer.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
UserRenderer.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef USER_RENDERER_H
00031 #define USER_RENDERER_H
00032
00038 #include "ApexUsingNamespace.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 PX_PUSH_PACK_DEFAULT
00046
00047 class RenderContext;
00048
00052 class UserRenderer
00053 {
00054 public:
00055     virtual ~UserRenderer() {}
00063     virtual void renderResource(const RenderContext& context) = 0;
00064 };
00065
00066 PX_POP_PACK
00067
00068 }
00069 } // end namespace nvidia::apex
00070
00071 #endif
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: VelocitySourceActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
VelocitySourceActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef VELOCITY_SOURCE_ACTOR_H
00030 #define VELOCITY_SOURCE_ACTOR_H
00031
00032 #include "Apex.h"
00033 #include "Shape.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 class VelocitySourceAsset;
00041
00042
00046 class VelocitySourceActor : public Actor
00047 {
00048 protected:
00049     virtual ~VelocitySourceActor() {}
00050
00051 public:
00053     virtual VelocitySourceAsset*        getVelocitySourceAsset() const = 0;
00054
00056     virtual void                        setEnabled(bool enable) = 0;
00057
00059     virtual bool                        isEnabled() const = 0;
00060
00062     virtual bool                        intersectAgainstAABB(PxBounds3) = 0;
00063
00065     virtual  Shape*                     getShape() const = 0;
00066
00068     virtual BoxShape*                   getBoxShape() = 0;
00069
00071     virtual SphereShape*                getSphereShape() = 0;
00072
00074     virtual float                       getAverageVelocity() const = 0;
00075
00077     virtual float                       getStdVelocity() const = 0;
00078
00080     virtual PxMat44                     getPose() const = 0;
00081
00083     virtual void                        setVelocity(float averageVelocity, float stdVelocity) = 0;
00084
00086     virtual void                        setPose(PxMat44 pose) = 0;
00087
00089     virtual void                        setCurrentScale(float scale) = 0;
00090
00092     virtual float                       getCurrentScale(void) const = 0;
00093
00094     virtual void                        release() = 0;
00095 };
00096
00097
00098 }
00099 } // end namespace nvidia
00100
00101 #endif
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: VelocitySourceAsset.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
VelocitySourceAsset.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef VELOCITY_SOURCE_ASSET_H
00030 #define VELOCITY_SOURCE_ASSET_H
00031
00032 #include "Apex.h"
00033 #include "CustomBufferIterator.h"
00034
00035 #define VELOCITY_SOURCE_AUTHORING_TYPE_NAME "VelocitySourceAsset"
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00042 class TurbulenceFSActorParams;
00043 class TurbulenceFSActor;
00044 class TurbulenceFSPreview;
00045
00049 class VelocitySourceAsset : public Asset
00050 {
00051 protected:
00052     virtual ~VelocitySourceAsset() {}
00053 };
00054
00055
00059 class VelocitySourceAssetAuthoring : public AssetAuthoring
00060 {
00061 protected:
00062     virtual ~VelocitySourceAssetAuthoring() {}
00063 };
00064
00065
00066 }
00067 } // end namespace nvidia
00068
00069 #endif // VELOCITY_SOURCE_ASSET_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: VelocitySourcePreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
VelocitySourcePreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef VELOCITY_SOURCE_PREVIEW_H
00030 #define VELOCITY_SOURCE_PREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00045 class VelocitySourcePreview : public AssetPreview
00046 {
00047 public:
00048     public:
00050     virtual void    drawVelocitySourcePreview() = 0;
00052     virtual void    setScale(float scale) = 0;
00053
00054 protected:
00055     VelocitySourcePreview() {}
00056 };
00057
00058
00059 PX_POP_PACK
00060
00061 }
00062 } // namespace nvidia
00063
00064 #endif // VELOCITY_SOURCE_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: VertexFormat.h File Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
Classes | Namespaces
VertexFormat.h File Reference

class VertexFormat and struct VertexFormatFlag More...

#include "ApexUsingNamespace.h"
#include "UserRenderResourceManager.h"
#include "UserRenderVertexBufferDesc.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::ColorRGBA
Color stored in 32 bits. More...
struct | nvidia::apex::RenderDataAccess
Type of render data. More...
class | nvidia::apex::VertexFormat
Describes the format of an VertexBuffer. More...

Namespaces

namespace | nvidia

nvidia namespace

namespace | nvidia::apex

apex namespace

Detailed Description

class VertexFormat and struct VertexFormatFlag

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: VertexFormat.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
VertexFormat.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef VERTEX_FORMAT_H
00031 #define VERTEX_FORMAT_H
00032
00038 #include "ApexUsingNamespace.h"
00039 #include "UserRenderResourceManager.h"
00040 #include "UserRenderVertexBufferDesc.h"
00041
00042 namespace nvidia
00043 {
00044 namespace apex
00045 {
00046
00047 PX_PUSH_PACK_DEFAULT
00048
00052 struct ColorRGBA
00053 {
00055     ColorRGBA() : r(0xFF), g(0xFF), b(0xFF), a(0xFF) {}
00057     ColorRGBA(uint8_t _r, uint8_t _g, uint8_t _b, uint8_t _a) : r(_r), g(_g), b(_b), a(_a) {}
00058
00060     uint8_t r;
00062     uint8_t g;
00064     uint8_t b;
00066     uint8_t a;
00067 };
00068
00072 struct RenderDataAccess
00073 {
00077     enum Enum
00078     {
00079         STATIC = 0,
00080         DYNAMIC,
00081         STREAMING,
00082
00083         ACCESS_TYPE_COUNT
00084     };
00085 };
00086
00090 class VertexFormat
00091 {
00092 public:
00093
00094     enum
00095     {
00096         MAX_UV_COUNT = 4,
00097         MAX_BONE_PER_VERTEX_COUNT = 4,
00098     };
00099
00101     typedef uint32_t BufferID;
00102
00103
00105     virtual void                            reset() = 0;
00106
00107
00109     virtual void                            setWinding(RenderCullMode::Enum winding) = 0;
00110
00112     virtual void                            setHasSeparateBoneBuffer(bool hasSeparateBoneBuffer) = 0;
00113
00115     virtual RenderCullMode::Enum            getWinding() const = 0;
00116
00118     virtual bool                            hasSeparateBoneBuffer() const = 0;
00119
00120
00122     virtual const char*                     getSemanticName(RenderVertexSemantic::Enum semantic) const = 0;
00123
00125     virtual BufferID                        getSemanticID(RenderVertexSemantic::Enum semantic) const = 0;
00126
00129     virtual BufferID                        getID(const char* name) const = 0;
00130
00131
00136     virtual int32_t                         addBuffer(const char* name) = 0;
00137
00142     virtual bool                            bufferReplaceWithLast(uint32_t index) = 0;
00143
00144
00148     virtual bool                            setBufferFormat(uint32_t index, RenderDataFormat::Enum format) = 0;
00149
00153     virtual bool                            setBufferAccess(uint32_t index, RenderDataAccess::Enum access) = 0;
00154
00158     virtual bool                            setBufferSerialize(uint32_t index, bool serialize) = 0;
00159
00160
00164     virtual const char*                     getBufferName(uint32_t index) const = 0;
00165
00169     virtual RenderVertexSemantic::Enum      getBufferSemantic(uint32_t index) const = 0;
00170
00174     virtual BufferID                        getBufferID(uint32_t index) const = 0;
00175
00179     virtual RenderDataFormat::Enum          getBufferFormat(uint32_t index) const = 0;
00180
00184     virtual RenderDataAccess::Enum          getBufferAccess(uint32_t index) const = 0;
00185
00189     virtual bool                            getBufferSerialize(uint32_t index) const = 0;
00190
00191
00193     virtual uint32_t                        getBufferCount() const = 0;
00194
00196     virtual uint32_t                        getCustomBufferCount() const = 0;
00197
00201     virtual int32_t                         getBufferIndexFromID(BufferID id) const = 0;
00202
00203
00204 protected:
00205     VertexFormat()  {}
00206     virtual                                 ~VertexFormat() {}
00207 };
00208
00209 PX_POP_PACK
00210
00211 }
00212 } // end namespace nvidia::apex
00213
00214 #endif // VERTEX_FORMAT_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: VortexFSActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
VortexFSActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef VORTEX_FSACTOR_H
00031 #define VORTEX_FSACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class BasicFSAsset;
00043
00044
00048 class VortexFSActor : public Actor, public Renderable
00049 {
00050 protected:
00051     virtual ~VortexFSActor() {}
00052
00053 public:
00054
00058     virtual BasicFSAsset*       getVortexFSAsset() const = 0;
00059
00063     virtual PxMat44             getCurrentPose() const = 0;
00064
00068     virtual void                setCurrentPose(const PxTransform& pose) = 0;
00069
00073     virtual PxVec3              getCurrentPosition() const = 0;
00074
00078     virtual void                setCurrentPosition(const PxVec3& pos) = 0;
00079
00083     virtual void                setAxis(const PxVec3&) = 0;
00084
00088     virtual void                setHeight(float) = 0;
00089
00093     virtual void                setBottomRadius(float) = 0;
00094
00098     virtual void                setTopRadius(float) = 0;
00099
00103     virtual void                setBottomSphericalForce(bool) = 0;
00104
00108     virtual void                setTopSphericalForce(bool) = 0;
00109
00113     virtual void                setRotationalStrength(float) = 0;
00114
00118     virtual void                setRadialStrength(float) = 0;
00119
00123     virtual void                setLiftStrength(float) = 0;
00124
00128     virtual void                setEnabled(bool isEnabled) = 0;
00129
00130
00134     virtual void                setCurrentScale(float scale) = 0;
00135
00139     virtual float               getCurrentScale(void) const = 0;
00140
00141 };
00142
00143 PX_POP_PACK
00144
00145 }
00146 } // end namespace nvidia::apex
00147
00148 #endif // VORTEX_FSACTOR_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: VortexFSPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
VortexFSPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef VORTEX_FSPREVIEW_H
00030 #define VORTEX_FSPREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class RenderDebugInterface;
00043
00052 namespace APEX_VORTEX
00053 {
00058 static const uint32_t VORTEX_DRAW_NOTHING = 0x00;
00063 static const uint32_t VORTEX_DRAW_SHAPE = 0x01;
00070 static const uint32_t VORTEX_DRAW_ASSET_INFO = 0x02;
00075 static const uint32_t VORTEX_DRAW_FULL_DETAIL = (VORTEX_DRAW_SHAPE + VORTEX_DRAW_ASSET_INFO);
00076 }
00077
00082 class VortexFSPreview : public AssetPreview
00083 {
00084 public:
00088     virtual void    setRadius(float radius) = 0;
00099     virtual void    setDetailLevel(uint32_t detail) = 0;
00100 };
00101
00102
00103 PX_POP_PACK
00104
00105 }
00106 } // namespace nvidia
00107
00108 #endif // VORTEX_FS_PREVIEW_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: WindFSActor.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
WindFSActor.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef WIND_FSACTOR_H
00031 #define WIND_FSACTOR_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class BasicFSAsset;
00043
00044
00048 class WindFSActor : public Actor, public Renderable
00049 {
00050 protected:
00051     virtual ~WindFSActor() {}
00052
00053 public:
00054
00058     virtual BasicFSAsset*       getWindFSAsset() const = 0;
00059
00063     virtual PxMat44             getCurrentPose() const = 0;
00064
00068     virtual void                setCurrentPose(const PxTransform& pose) = 0;
00069
00073     virtual PxVec3              getCurrentPosition() const = 0;
00074
00078     virtual void                setCurrentPosition(const PxVec3& pos) = 0;
00079
00083     virtual void                setFieldStrength(float) = 0;
00084
00088     virtual void                setFieldDirection(const PxVec3&) = 0;
00089
00093     virtual void                setEnabled(bool isEnabled) = 0;
00094
00098     virtual void                setCurrentScale(float scale) = 0;
00099
00103     virtual float               getCurrentScale(void) const = 0;
00104 };
00105
00106 PX_POP_PACK
00107
00108 }
00109 } // end namespace nvidia::apex
00110
00111 #endif // WIND_FSACTOR_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: WindFSPreview.h Source File

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
WindFSPreview.h
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef WIND_FSPREVIEW_H
00030 #define WIND_FSPREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class RenderDebugInterface;
00043
00051 namespace APEX_WIND
00052 {
00057 static const uint32_t WIND_DRAW_NOTHING = 0x00;
00063 static const uint32_t WIND_DRAW_ASSET_INFO = 0x02;
00068 static const uint32_t WIND_DRAW_FULL_DETAIL = (WIND_DRAW_ASSET_INFO);
00069 }
00070
00075 class WindFSPreview : public AssetPreview
00076 {
00077 public:
00087     virtual void    setDetailLevel(uint32_t detail) = 0;
00088 };
00089
00090
00091 PX_POP_PACK
00092
00093 }
00094 } // namespace nvidia
00095
00096 #endif // WIND_FSPREVIEW_H
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
nvidia::apex::Actor | Base class for APEX module objects
nvidia::apex::ActorSource | Base class for APEX classes that spawn PhysX SDK Actors
NvParameterized::Traits::Allocator | Adapter for allocator classes in PxAlloctor.h
nvidia::apex::ApexChunkFlag |
nvidia::apex::ApexDesc | Base class for all APEX Descriptor classes
nvidia::apex::ApexInterface | Base class for all interface classes implemented by APEX SDK
nvidia::apex::ApexMeshParticleRollType | Roll type of a particle
nvidia::apex::ApexSDK | The ApexSDK abstraction. Manages scenes and modules
nvidia::apex::ApexSDKCachedData | A method for storing actor data in a scene
nvidia::apex::ApexSDKDesc | Descriptor class for ApexSDK
nvidia::apex::Asset | Base class of all APEX assets
nvidia::apex::AssetAuthoring | Base class of all APEX asset authoring classes
nvidia::apex::AssetPreview | Base class of all APEX asset previews
nvidia::apex::AssetPreviewScene | An APEX class for
nvidia::apex::AttractorFSActor | AttractorFS Actor class
nvidia::apex::AttractorFSPreview | This class provides the asset preview for APEX AttractorFS Assets. The class provides multiple levels of prevew detail that can be selected individually
nvidia::apex::BasicFSAsset | BasicFS Asset class
nvidia::apex::BasicFSAssetAuthoring | BasicFS Asset Authoring class
nvidia::apex::BasicIosActor | BasicIOS Actor. A simple actor that simulates a particle system
nvidia::apex::BasicIosAsset | APEX Particle System Asset
nvidia::apex::BasicIosAssetAuthoring | APEX Particle System Asset Authoring class
nvidia::apex::BoxShape | Helper Box shape
nvidia::apex::BSPOpenMode |
nvidia::apex::CapsuleShape | Helper the capsule is oriented along the y axis by default and its total height is height+2*radius
nvidia::apex::ChunkData |
nvidia::apex::ChunkParticleReportData |
nvidia::apex::ChunkStateEventData |
nvidia::apex::ChunkTransformHeader |
nvidia::apex::ChunkTransformUnit |
nvidia::apex::ClothingActor | Instance of ClothingAsset. Can be positioned, animated, updated and rendered
nvidia::apex::ClothingAsset | A clothing asset. It contains all the static and shared data for a given piece of clothing
nvidia::apex::ClothingAssetAuthoring | The clothing authoring asset. This is used to generate streams that can then be deserialized into a regular asset
nvidia::apex::ClothingCapsule | Capsule collision of a clothing actor
nvidia::apex::ClothingCollision | Base class of all clothing collision types
nvidia::apex::ClothingCollisionType | Type of the ClothingCollision
nvidia::apex::ClothingConstrainCoefficients | Constrain coefficients of the physical mesh vertices
nvidia::apex::ClothingConvex | Convex collision of a clothing actor
nvidia::apex::ClothingMeshSkinningMap | Maps from a triangle of the simulated mesh to a vertex of the rendered mesh. The barycentric coordinates describe the position of a point in space relative to a simulated triangle. The actual z-coordinate is computed by bary.z = 1 - bary.x - bary.y. The z part of the vector contains the height of the skinned vertex along the normal of the simulated triangle
nvidia::apex::ClothingPhysicalMesh | Holder for a physical mesh, this can be generated through various ways (see single- and multi-layered clothing) or hand crafted
nvidia::apex::ClothingPhysicalMeshStats | Contains the data for handing out statistics about a ClothingPhysicalMesh
nvidia::apex::ClothingPlane | Plane collision of a clothing actor
nvidia::apex::ClothingPreview | A lightweight preview of a ClothingActor that will not perform any simulation
nvidia::apex::ClothingRenderProxy | Instance of ClothingRenderProxy. This is the renderable of a clothing actor. The data in this object is consistent until it is returned to APEX with the release() call
nvidia::apex::ClothingSphere | Sphere collision of a clothing actor
nvidia::apex::ClothingTeleportMode | Selects the mode the clothing actor will be in the simulation frame
nvidia::apex::ClothingTriangleMesh | Triangle mesh collision of a clothing actor
nvidia::apex::ClothingVelocityCallback | Container class for the velocity shader callback
nvidia::apex::ClothSolverMode | Describes the solver that is used to simulate the clothing actor
nvidia::apex::CollisionDesc |
nvidia::apex::CollisionVolumeDesc |
nvidia::apex::ColorRGBA | Color stored in 32 bits
nvidia::apex::ColorVsDensityModifier | ColorVsDensityModifier modifies the color constants associated with a particle depending on the density of the particle
nvidia::apex::ColorVsLifeModifier | ColorVsLifeModifier modifies the color constants associated with a particle depending on the life remaining of the particle
nvidia::apex::ColorVsVelocityModifier | ColorVsVelocityModifier modifies the color constants associated with a particle depending on the velocity of the particle
nvidia::apex::Context | A container for Actors
NvParameterized::Conversion | Interface class for legacy object conversions
nvidia::apex::ExplicitHierarchicalMesh::ConvexHull |
nvidia::apex::ConvexHullMethod | Method by which chunk mesh collision hulls are generated
nvidia::apex::CudaTestManager | A class that set information on kernels should be tested and give directive for creation ApexCudaTestContext
nvidia::apex::Curve |
nvidia::apex::CustomBufferIterator | This class is used to access specific elements in an untyped chunk of memory
FractureTools::CutoutParameters |
FractureTools::CutoutSet |
nvidia::apex::DamageEventCoreData |
nvidia::apex::DamageEventHeader |
nvidia::apex::DamageEventReportData |
nvidia::apex::DamageEventUnit |
nvidia::apex::DamageSpreadFunction |
NvParameterized::Definition | Provides information about a parameter
NvParameterized::Serializer::DeserializedResults< T, bufSize > | TODO
nvidia::apex::DestructibleActor |
nvidia::apex::DestructibleActorChunkFlags |
nvidia::apex::DestructibleActorJoint |
nvidia::apex::DestructibleActorJointDesc |
nvidia::apex::DestructibleActorMeshType |
nvidia::apex::DestructibleActorRaycastFlags |
nvidia::apex::DestructibleActorSyncFlags |
nvidia::apex::DestructibleActorSyncState |
nvidia::apex::DestructibleAsset |
nvidia::apex::DestructibleAssetAuthoring |
nvidia::apex::DestructibleAssetCookingDesc |
nvidia::apex::DestructibleAssetStats |
nvidia::apex::DestructibleBehaviorGroupDesc |
nvidia::apex::DestructibleCallbackSchedule |
nvidia::apex::DestructibleChunkDesc |
nvidia::apex::DestructibleChunkEvent |
nvidia::apex::DestructibleChunkSyncState |
nvidia::apex::DestructibleDepthParameters |
nvidia::apex::DestructibleDepthParametersFlag | PX_PS4
nvidia::apex::DestructibleEmitterType |
nvidia::apex::DestructibleGeometryDesc |
nvidia::apex::DestructibleHitChunk |
nvidia::apex::DestructibleInitParameters |
nvidia::apex::DestructibleInitParametersFlag |
nvidia::apex::DestructibleParameterizedType |
nvidia::apex::DestructibleParameters |
nvidia::apex::DestructibleParametersFlag |
nvidia::apex::DestructiblePhysXActorQueryFlags |
nvidia::apex::DestructiblePreview | Destructible module's derivation AssetPreview
nvidia::apex::DestructibleRenderable |
nvidia::apex::DestructibleRTFractureParameters |
nvidia::apex::DisplacementMapVolume |
nvidia::apex::EffectPackageActor | Defines the EffectPackageActor API which is instantiated from an EffectPackageAsset
nvidia::apex::EffectPackageAsset | Describes an EffectPackageAsset; a collection of particle related effects (emitters, field samplers, etc.)
nvidia::apex::EffectPackageAssetAuthoring | Describes an EffectPackageAssetAuthoring class; not currently used. The ParticleEffectTool is used to author EffectPackageAssets
nvidia::apex::EmitterGeomExplicit::EllipsoidParams | Ellipsoid parameters
nvidia::apex::ExplicitHierarchicalMesh::Embedding |
nvidia::apex::EmitterActor | Apex emitter actor class. Emits particles within a given shape
nvidia::apex::EmitterAsset | APEX Emitter asset. Emits particles within some shape
nvidia::apex::EmitterAssetAuthoring | APEX Emitter Asset Authoring. Used to create APEX Emitter assets
nvidia::apex::EmitterGeom | Base class for all emitter shapes
nvidia::apex::EmitterGeomBox | Box shape for an emitter
nvidia::apex::EmitterGeomCylinder | Cylindrical shape for an emitter
nvidia::apex::EmitterGeomExplicit | Explicit geometry. Coordinates of each particle are given explicitly
nvidia::apex::EmitterGeomSphere | Spherical shape for an emitter
nvidia::apex::EmitterGeomSphereShell | Sphere shell shape for an emitter. It's a shape formed by the difference of two cocentered spheres
nvidia::apex::EmitterLodParamDesc | LOD parameters fro emitters
nvidia::apex::EmitterPreview |
nvidia::apex::EmitterType | Emitter type
nvidia::apex::EmitterActor::EmitterValidateCallback |
nvidia::apex::ExplicitHierarchicalMesh |
nvidia::apex::ExplicitRenderTriangle | A less inefficient triangle description used for authoring
nvidia::apex::ExplicitSubmeshData |
nvidia::apex::ExplicitVertexFormat |
NvParameterized::Factory | Interface class for NvParameterized factories
nvidia::apex::FieldSamplerWeightedCollisionFilterCallback | This is an optional callback interface for collision filtering between field samplers and other objects If this interface is not provided, then collision filtering happens normally through the default scene simulationfiltershader callback However, if this is provided, then the user can no only return true/false to indicate whether or not the two objects should interact but can also assign a weighted multiplier value to control how strongly the two objects should interact
nvidia::apex::FlameEmitterActor | Flame Emitter Actor class
nvidia::apex::FlameEmitterAsset | Flame Emitter Asset class
nvidia::apex::FlameEmitterAssetAuthoring | Flame Emitter Asset Authoring class
nvidia::apex::FlameEmitterPreview | This class provides the asset preview for APEX Flame Emitter Assets
nvidia::apex::ForceFieldActor | ForceField Actor
nvidia::apex::ForceFieldAsset | ForceField Asset
nvidia::apex::ForceFieldAssetAuthoring | ForceField Asset Authoring
nvidia::apex::ForceFieldPreview | APEX asset preview force field asset
nvidia::apex::DestructibleRTFractureParameters::FractureAttachment |
FractureTools::FractureCutoutDesc |
nvidia::apex::FractureEventHeader |
nvidia::apex::FractureEventUnit |
nvidia::apex::DestructibleRTFractureParameters::FractureGlass |
nvidia::apex::FractureMaterialDesc |
nvidia::apex::FractureMethod |
FractureTools::FractureSliceDesc |
nvidia::apex::FractureToolsAPI |
FractureTools::FractureVoronoiDesc |
nvidia::apex::GroundEmitterActor | Ground Emitter actor. Uses raycasts against ground to spawn particles
nvidia::apex::GroundEmitterAsset | Ground emitter asset. Used to create Ground emitter actors with specific properties
nvidia::apex::GroundEmitterAssetAuthoring | Ground emitter authoring class. Used to create Ground emitter assets
nvidia::apex::GroundEmitterPreview | Ground emitter preview class. Use for preview rendering
nvidia::apex::GroupsFilterOp | Collision groups filtering operations
nvidia::apex::GroupsMask64 | 64-bit mask used for collision filtering between IOSes and Field Samplers
nvidia::apex::HalfSpaceShape | Helper HalfSpace shape
NvParameterized::Handle | Provides access to individual parameters within the NvParameterized object
nvidia::apex::HeatSourceActor | Turbulence HeatSource Actor class
nvidia::apex::HeatSourceAsset | Turbulence FieldSampler Asset class
nvidia::apex::HeatSourceAssetAuthoring | Turbulence FieldSampler Asset Authoring class
nvidia::apex::HeatSourcePreview | This class provides the asset preview for APEX HeatSource Assets
NvParameterized::Hint | Provides hints about the parameter definition
nvidia::apex::ImpactDamageEventData |
nvidia::apex::ImpactEmitterActor | Impact emitter actor. Emits particles at impact places
nvidia::apex::ImpactEmitterAsset | Impact emitter asset class
nvidia::apex::ImpactEmitterAssetAuthoring | Impact emitter asset authoring. Used to create Impact Emitter assets
nvidia::apex::ImpactEmitterPreview | Impact emitter preview. Used for preview rendering of the emitter actors
nvidia::apex::RenderMeshAssetAuthoring::IndexType |
NvParameterized::Interface | Represents the interface to the NvParameterized object
nvidia::apex::IofxActor | IOFX actor public interface
nvidia::apex::IofxAsset | IOFX Asset public interface. Used to define the way the visual parameters are created from physical parameters of a particle
nvidia::apex::IofxAssetAuthoring | IOFX Asset Authoring public interface
nvidia::apex::IofxCommonRenderData | IofxCommonRenderData stores common render data for one IOFX Renderable
nvidia::apex::IofxMeshRenderData | IofxMeshRenderData stores mesh render data for one IOFX Renderable
nvidia::apex::IofxMeshRenderLayout | Describes the layout for mesh rendering
nvidia::apex::IofxMeshRenderLayoutElement | Enumerates the potential IOFX mesh render layout elements
nvidia::apex::IofxMeshSharedRenderData | IofxMeshSharedRenderData stores mesh render data shared by several IOFX Renderables
nvidia::apex::IofxRenderable | The IOFX renderable represents a unit of rendering. It contains complete information to render a batch of particles with the same material/mesh in the same render volume
nvidia::apex::IofxRenderableIterator | Iterate over all renderables in IOFX module. IMPORTANT: release() should be called for each returned not-NULL renderable!
nvidia::apex::IofxRenderCallback | User defined callback for IOFX rendering
nvidia::apex::IofxRenderSemantic | Enumerates the potential IOFX render semantics
nvidia::apex::IofxSharedRenderData | IofxSharedRenderData stores common render data shared by several IOFX Renderables
nvidia::apex::IofxSpriteRenderData | IofxSpriteRenderData stores sprite render data for one IOFX Renderable
nvidia::apex::IofxSpriteRenderLayout | Describes the layout for sprite rendering
nvidia::apex::IofxSpriteRenderLayoutElement | Enumerates the potential IOFX mesh render layout elements
nvidia::apex::IofxSpriteRenderLayoutSurfaceElement | Enumerates the potential IOFX sprite render layout surface elements
nvidia::apex::IofxSpriteSharedRenderData | IofxSpriteSharedRenderData stores sprite render data shared by several IOFX Renderables
nvidia::apex::IosAsset | The base class of all Instanced Object Simulation classes
nvidia::apex::IProgressListener | User-provided class for following the progress of a task
nvidia::apex::JetFSActor | JetFS Actor class
nvidia::apex::JetFSPreview | This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually
nvidia::apex::UserRenderSurface::MappedInfo | Mapped information
nvidia::apex::MaterialFrame |
nvidia::apex::MaterialLookupCallback | User calback interface used to map raycast hitpoints to material ID If an instance of this class is registered with a ground emitter actor, the actor will call requestMaterialLookups() in lieu of doing raycasts. The call will occur from within the scope of the ApexScene thread, so the callback must be thread safe
nvidia::apex::MaterialLookupCallback::MaterialRequest | Material request structure
nvidia::apex::RenderMeshAssetAuthoring::MeshDesc |
FractureTools::MeshProcessingParameters |
NvParameterized::Serializer::MetadataEntry | This class keeps metadata of a single NvParameterized class
nvidia::apex::MirrorScene::MirrorFilter | MirrorFilter is a callback interface implemented by the application to confirm which actors and shapes are, or are not, replicated into the mirrored scene
nvidia::apex::MirrorScene | MirrorScene is used to create a selected mirrored copy of a primary scene. Works only with PhysX 3.x
nvidia::apex::Modifier | Modifier contains all of the data necessary to apply a single modifier type to a particle system
nvidia::apex::ModifierT< T > | ModifierT is a helper class to handle the mapping of Type->Enum and Enum->Type
nvidia::apex::Module | Base class of all APEX modules
nvidia::apex::ModuleBasicFS | BasicFS module class
nvidia::apex::ModuleBasicIos | BasicIOS Module
nvidia::apex::ModuleCachedData | Cached data is stored per-module
nvidia::apex::ModuleClothing | APEX Clothing Module
nvidia::apex::ModuleDestructible |
nvidia::apex::ModuleDestructibleConst |
nvidia::apex::ModuleEmitter | An APEX Module that provides generic Emitter classes
nvidia::apex::ModuleFieldSampler | FieldSampler module class
nvidia::apex::ModuleForceField | ForceField Module
nvidia::apex::ModuleIofx | IOFX Module
nvidia::apex::ModuleIofxLegacy | ModuleIofx interface used in APEXSDK before v. 1.4
nvidia::apex::ModuleLoader | The ModuleLoader is a utility class for loading APEX modules
nvidia::apex::ModuleParticleIos | ParticleIOS Module - Manages PhysX 3.0 PxParticleSystem and PxParticleFluid simulations
nvidia::apex::ModuleParticles | Defines the API for the Particles Module
nvidia::apex::ModuleSpecificRenderBufferData | Describes data semantics provided by a particular module
nvidia::apex::ModuleTurbulenceFS | Class for TurbulenceFS module
NvParameterized::NamedReferenceInterface | Callback container for getNamedReferences
nvidia::apex::NoiseFSActor | JetFS Actor class
nvidia::apex::NoiseFSPreview | This class provides the asset preview for APEX NoiseFS Assets. The class provides multiple levels of prevew detail that can be selected individually
FractureTools::NoiseParameters |
nvidia::apex::oaValueStruct | Data value definitions for stats (derived from openautomate)
nvidia::apex::OrientAlongVelocityModifier | OrientAlongVelocity is a modifier to orient a mesh so that a particular axis coincides with the velocity vector
nvidia::apex::OrientScaleAlongScreenVelocityModifier | OrientScaleAlongScreenVelocityModifier is a modifier to orient & scale sprites along the current screen velocity vector
NvParameterized::ParameterFind | Finds parameter in NvParameterized
NvParameterized::ParameterList | Parameter list
NvParameterized::ParamResult | Container for results of getParamList
nvidia::apex::ParticleIosActor | ParticleIOS Actor. A simple actor that simulates a particle system
nvidia::apex::ParticleIosAsset | APEX Particle System Asset
nvidia::apex::ParticleIosAssetAuthoring | APEX Particle System Asset Authoring class
nvidia::apex::ParticlesPreview | APEX asset preview wind asset
nvidia::apex::PhysX3DescTemplate |
nvidia::apex::PhysX3Interface | Interface used to call setter function for PhysX 3.0
nvidia::apex::PhysXObjectDesc | PhysX object descriptor
nvidia::apex::PhysXRenderBuffer | This is a helper class implementation of PxRenderBuffer that holds the counts and pointers for renderable data. Does not own the memory, simply used to transfer the state. The append method is not supported
nvidia::apex::EmitterGeomExplicit::PointListData | Structure contains positions, velocities and user data for particles
nvidia::apex::EmitterGeomExplicit::PointParams | Point parameters
nvidia::apex::RenderMeshAssetAuthoring::Primitive | How the geometry is stored. Currently only supporting triangles
nvidia::apex::ProjMatrixType | Types of projection matrices handled by APEX
nvidia::apex::PxStreamFromFileBuf | A wrapper class that provides an NvStream API for a PxFileBuf
nvidia::apex::RandomRotationModifier | RandomRotationModifier will choose a random orientation for a sprite particle within the range as specified below
nvidia::apex::RandomScaleModifier | RandomScaleModifier applies a random scale uniformly to all three dimensions. Currently, the scale is a uniform in the range specified
nvidia::apex::RandomSubtextureModifier | RandomSubtextureModifier generates a random subtexture ID and places it in the subTextureId field
nvidia::apex::Range< T > | A structure that holds two templated values, a min and a max
nvidia::apex::ReadLock | RAII wrapper for the Scene read lock
NvParameterized::ReferenceInterface | Callback container for getReferences
nvidia::apex::Renderable | Base class of any actor that can be rendered
nvidia::apex::RenderableIterator | Iterate over all renderable Actors in an Context
nvidia::apex::RenderBoneBufferData | Type of the bone buffer data
nvidia::apex::RenderBoneSemantic | The semantics available for bone buffers
nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum > | Describes all of the semantics of a render buffer
nvidia::apex::RenderBufferHint | Hint of the buffer data lifespan
nvidia::apex::RenderContext | Describes the context of a renderable object
nvidia::apex::RenderCullMode | Possible triangle culling modes
nvidia::apex::RenderDataAccess | Type of render data
nvidia::apex::RenderDataFormat | Enumeration of possible formats of various buffer semantics
nvidia::apex::RenderDataProvider | An actor instance that provides renderable data
nvidia::apex::RenderDebugInterface | Wrapper for DebugRenderable
nvidia::apex::RenderInstanceBufferData | The instance buffer type (deprecated)
nvidia::apex::RenderInstanceLayoutElement | Potential semantics of a sprite buffer
nvidia::apex::RenderInstanceSemantic | PX_PS4
nvidia::apex::RenderInteropFlags | Render interop flags
nvidia::apex::RenderLockMode | Render lock modes. These are used per-module to determine how render locking is done
nvidia::apex::RenderMapType | Render map type
nvidia::apex::RenderMeshActor | Renderable mesh (dynamic data associated with RenderMeshAsset)
nvidia::apex::RenderMeshActorDesc | Descriptor for creating a rendering mesh (collection of parts and submesh extra data)
nvidia::apex::RenderMeshActorRaycastFlags | Flags used for raycasting an RenderMeshActor
nvidia::apex::RenderMeshActorRaycastHitData | Return data from raycasting an RenderMeshActor
nvidia::apex::RenderMeshAsset | Rendering mesh (data) class
nvidia::apex::RenderMeshAssetAuthoring | Authoring interface for an RenderMeshAsset
nvidia::apex::RenderMeshAssetInstanceMode | Instance buffer data mode. DEPRECATED, to be removed by APEX 1.0
nvidia::apex::RenderMeshAssetStats | Stats for an RenderMeshAsset: memory usage, counts, etc
nvidia::apex::RenderMeshPartData | Descriptor for creating a rendering mesh part
nvidia::apex::RenderPrimitiveType | Describe the implied vertex ordering
nvidia::apex::RenderSemanticData | Describes the data location and layout of a single semantic
nvidia::apex::RenderSpriteBufferData | Sprite buffer data (deprecated)
nvidia::apex::RenderSpriteLayoutElement | Potential semantics of a sprite buffer
nvidia::apex::RenderSpriteSemantic | PX_PS4
nvidia::apex::RenderSpriteTextureLayout | Struct for sprite texture layout info
nvidia::apex::RenderSubmesh | Mesh that has only one material (or render state, in general)
nvidia::apex::RenderSurfaceBufferData | Surface buffer data
nvidia::apex::RenderVertexBufferData | Vertex buffer data
nvidia::apex::RenderVertexSemantic | Potential semantics of a vertex buffer
nvidia::apex::RenderVolume | An object which "owns" a volume of world space
nvidia::apex::ResourceCallback | User defined callback for resource management
nvidia::apex::ResourceProvider | A user provided class for mapping names to pointers or integers
nvidia::apex::RotationModifier | RotationModifier applies rotation to the particles using one of several rotation models
nvidia::apex::RotationRateModifier | RotationRateModifier is a modifier to apply a continuous rotation for sprites
nvidia::apex::RotationRateVsLifeModifier | RotationRateVsLifeModifier is a modifier to adjust the rotation rate versus the life remaining of a particular particle
nvidia::apex::RWLockable | Base class for any rw-lockable object implemented by APEX SDK
nvidia::apex::ScaleAlongVelocityModifier | ScaleAlongVelocityModifier is a modifier to apply a scale factor along the current velocity vector
nvidia::apex::ScaleByMassModifier | ScaleByMassModifier scales by mass of the particle
nvidia::apex::ScaleVsCameraDistanceModifier | ScaleVsCameraDistance applies a scale factor against a specific axis based on distance from the camera to the particle
nvidia::apex::ScaleVsDensityModifier | ScaleVsDensityModifier applies a scale factor function against a single axis versus the density of the particle
nvidia::apex::ScaleVsLifeModifier | ScaleVsLifeModifier applies a scale factor function against a single axis versus the life remaining
nvidia::apex::Scene | An APEX wrapper for an PxScene
nvidia::apex::SceneDesc | Data used to initialize a new Scene
nvidia::apex::SceneStats | Per scene statistics
nvidia::apex::ScopedPhysXLockRead | This helper class creates a scoped read access to the PhysX SDK API
nvidia::apex::ScopedPhysXLockWrite | This helper class creates a scoped write access to the PhysX SDK API
NvParameterized::SerializationCallback | A callback class for notification just prior to serialization
NvParameterized::SerializePlatform | Platform descriptor
NvParameterized::Serializer | Interface class for serializer-deserializer of NvParameterized objects
nvidia::apex::Shape | Describes the format of an Shape
nvidia::apex::SimpleScaleModifier | SimpleScaleModifier just applies a simple scale factor to each of the X, Y and Z aspects of the model. Each scalefactor can be applied independently
FractureTools::SliceParameters |
nvidia::apex::EmitterGeomExplicit::SphereParams | Sphere prameters
nvidia::apex::SphereShape | Helper Sphere shape
nvidia::apex::StatDataType | APEX stat struct that contains the type enums
nvidia::apex::StatsInfo | Data value definitions for stats
nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
nvidia::apex::SubstanceSourceActor | Turbulence ScalarSource Actor class
nvidia::apex::SubstanceSourceAsset | Turbulence FieldSampler Asset class
nvidia::apex::SubstanceSourceAssetAuthoring | Turbulence FieldSampler Asset Authoring class
nvidia::apex::SubtextureVsLifeModifier | SubtextureVsLifeModifier is a modifier to adjust the subtexture id versus the life remaining of a particular particle
nvidia::apex::TestBase |
nvidia::apex::TestFunctionInterface |
nvidia::apex::TextureUVOrigin | Texture UV direction convention
NvParameterized::Traits | Interface class for user traits
nvidia::apex::TurbulenceDensityFormat | Density format for Turbulence rendering
nvidia::apex::TurbulenceFieldType | Render surface field type
nvidia::apex::TurbulenceFlameFormat | Flame format for Turbulence rendering
nvidia::apex::TurbulenceFSActor | Turbulence FieldSampler Actor class
nvidia::apex::TurbulenceFSAsset | Turbulence FieldSampler Asset class
nvidia::apex::TurbulenceFSAssetAuthoring | Turbulence FieldSampler Asset Authoring class
nvidia::apex::TurbulenceFSPreview | This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually
nvidia::apex::TurbulenceRenderable | The Turbulence renderable represents a unit of rendering
nvidia::apex::TurbulenceRenderCallback | User defined callback for Turbulence rendering
nvidia::apex::TurbulenceRenderData | TurbulenceRenderData stores render data for one Turbulence Renderable
nvidia::apex::TurbulenceRenderLayout | Render layout for Turbulence rendering
nvidia::apex::TurbulenceVelocityFormat | Velocity format for Turbulence rendering
nvidia::apex::UserBoundingBoxFlags | Enum of the bounding box types
nvidia::apex::UserChunkParticleReport |
nvidia::apex::UserChunkReport |
nvidia::apex::UserDestructiblePhysXActorReport |
nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > |
nvidia::apex::UserImpactDamageReport |
nvidia::apex::UserOpaqueMesh | An abstract interface to an opaque mesh
nvidia::apex::UserOpaqueMeshDesc | Opaque mesh description
nvidia::apex::UserRenderBoneBuffer | Used for storing skeletal bone information used during skinning
nvidia::apex::UserRenderBoneBufferDesc | Descriptor to generate a bone buffer
nvidia::apex::UserRenderBuffer | User render buffer
nvidia::apex::UserRenderBufferDesc | User render buffer desc
nvidia::apex::UserRenderCallback | User render callback
nvidia::apex::UserRenderData | User render data
nvidia::apex::UserRenderDataHolder | User render data holder
nvidia::apex::UserRenderer | User provided renderer interface
nvidia::apex::UserRenderIndexBuffer | Used for storing index data for rendering
nvidia::apex::UserRenderIndexBufferDesc | PX_PS4
nvidia::apex::UserRenderInstanceBuffer | Used for storing per-instance data for rendering
nvidia::apex::UserRenderInstanceBufferDesc | Describes the data and layout of an instance buffer
nvidia::apex::UserRenderResource | An abstract interface to a renderable resource
nvidia::apex::UserRenderResourceDesc | Describes all the data that makes up a renderable resource
nvidia::apex::UserRenderResourceManager | User defined renderable resource manager
nvidia::apex::UserRenderSpriteBuffer | Used for storing per-sprite instance data for rendering
nvidia::apex::UserRenderSpriteBufferDesc | Describes the semantics and layout of a sprite buffer
nvidia::apex::UserRenderSpriteTextureDesc | Class for storing sprite texture render data
nvidia::apex::UserRenderStorage | User render storage
nvidia::apex::UserRenderSurface | User render surface
nvidia::apex::UserRenderSurfaceBuffer | Used for storing per-vertex data for rendering
nvidia::apex::UserRenderSurfaceBufferDesc | Describes the semantics and layout of a Surface buffer
nvidia::apex::UserRenderSurfaceDesc | User render surface desc
nvidia::apex::UserRenderVertexBuffer | Used for storing per-vertex data for rendering
nvidia::apex::UserRenderVertexBufferDesc | Describes the semantics and layout of a vertex buffer
nvidia::apex::Vec2T< T > | A trivial templatized math vector type for pairs
nvidia::apex::VelocitySourceActor | Turbulence VelocitySource Actor class
nvidia::apex::VelocitySourceAsset | Turbulence FieldSampler Asset class
nvidia::apex::VelocitySourceAssetAuthoring | Turbulence FieldSampler Asset Authoring class
nvidia::apex::VelocitySourcePreview | This class provides the asset preview for APEX VelocitySource Assets
nvidia::apex::Vertex | An inefficient vertex description used for authoring
nvidia::apex::VertexBuffer | Vertex buffer that supports multiple formats
nvidia::apex::RenderMeshAssetAuthoring::VertexBuffer | Vertex buffer class used for mesh creation
nvidia::apex::VertexColor | The full RGBA color of a vertex
nvidia::apex::VertexFormat | Describes the format of an VertexBuffer
nvidia::apex::VertexUV | Simple u, v coordinate struct
nvidia::apex::ViewDirectionSortingModifier | ViewDirectionSortingModifier sorts sprite particles along view direction back to front
nvidia::apex::ViewMatrixType | Types of view matrices handled by APEX
nvidia::apex::VortexFSActor | VortexFS Actor class
nvidia::apex::VortexFSPreview | This class provides the asset preview for APEX VortexFS Assets. The class provides multiple levels of prevew detail that can be selected individually
nvidia::apex::WindFSActor | WindFS Actor class
nvidia::apex::WindFSPreview | This class provides the asset preview for APEX WindFS Assets. The class provides multiple levels of prevew detail that can be selected individually
NvParameterized::WrappedNamedReference | WrappedNamedReference
nvidia::apex::WriteLock | RAII wrapper for the Scene write lock
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: FractureTools::CutoutSet Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • CutoutSet
Public Member Functions | Protected Member Functions
FractureTools::CutoutSet Class Reference

#include <FractureToolsStructs.h>

List of all members.

Public Member Functions

virtual uint32_t | getCutoutCount () const =0
virtual uint32_t | getCutoutVertexCount (uint32_t cutoutIndex) const =0
virtual uint32_t | getCutoutLoopCount (uint32_t cutoutIndex) const =0
virtual const physx::PxVec3 & | getCutoutVertex (uint32_t cutoutIndex, uint32_t vertexIndex) const =0
virtual uint32_t | getCutoutLoopSize (uint32_t coutoutIndex, uint32_t loopIndex) const =0
virtual uint32_t | getCutoutLoopVertexIndex (uint32_t cutoutIndex, uint32_t loopIndex, uint32_t vertexNum) const =0
virtual uint32_t | getCutoutLoopVertexFlags (uint32_t cutoutIndex, uint32_t loopIndex, uint32_t vertexNum) const =0
virtual bool | isPeriodic () const =0
virtual const physx::PxVec2 & | getDimensions () const =0
virtual void | release ()=0

Protected Member Functions

virtual | ~CutoutSet ()

Detailed Description

Interface to a "cutout set," used with chippable fracturing. A cutout set is created from a bitmap. The result is turned into cutouts which are applied to the mesh. For example, a bitmap which looks like a brick pattern will generate a cutout for each "brick," forming the cutout set.

Each cutout is a 2D entity, meant to be projected onto various faces of a mesh. They are represented by a set of 2D vertices, which form closed loops. More than one loop may represent a single cutout, if the loops are forced to be convex. Otherwise, a cutout is represented by a single loop.

Constructor & Destructor Documentation

virtual FractureTools::CutoutSet::~CutoutSet ( ) [inline, protected, virtual]

Protected destructor. Use the release() method.

Member Function Documentation

virtual uint32_t FractureTools::CutoutSet::getCutoutCount ( ) const [pure virtual]

Returns the number of cutouts in the set.

virtual uint32_t FractureTools::CutoutSet::getCutoutLoopCount ( uint32_t cutoutIndex ) const [pure virtual]

Applies to the cutout indexed by cutoutIndex: Returns the number of loops in this cutout.

virtual uint32_t FractureTools::CutoutSet::getCutoutLoopSize | ( | uint32_t | coutoutIndex,
 |  | uint32_t | loopIndex
 | ) |  | const [pure virtual]

Applies to the cutout indexed by cutoutIndex: Returns the number of vertices in the loop indexed by loopIndex.

virtual uint32_t FractureTools::CutoutSet::getCutoutLoopVertexFlags | ( | uint32_t | cutoutIndex,
 |  | uint32_t | loopIndex,
 |  | uint32_t | vertexNum
 | ) |  | const [pure virtual]

Applies to the cutout indexed by cutoutIndex: Returns the flags of the vertex indexed by vertexNum, in the loop indexed by loopIndex.

virtual uint32_t FractureTools::CutoutSet::getCutoutLoopVertexIndex | ( | uint32_t | cutoutIndex,
 |  | uint32_t | loopIndex,
 |  | uint32_t | vertexNum
 | ) |  | const [pure virtual]

Applies to the cutout indexed by cutoutIndex: Returns the vertex index of the vertex indexed by vertexNum, in the loop indexed by loopIndex.

virtual const physx::PxVec3& FractureTools::CutoutSet::getCutoutVertex | ( | uint32_t | cutoutIndex,
 |  | uint32_t | vertexIndex
 | ) |  | const [pure virtual]

Applies to the cutout indexed by cutoutIndex: Returns the vertex indexed by vertexIndex. (Only the X and Y coordinates are used.)

virtual uint32_t FractureTools::CutoutSet::getCutoutVertexCount ( uint32_t cutoutIndex ) const [pure virtual]

Applies to the cutout indexed by cutoutIndex: Returns the number of vertices in the cutout.

virtual const physx::PxVec2& FractureTools::CutoutSet::getDimensions ( ) const [pure virtual]

The dimensions of the fracture map used to create the cutout set.

virtual bool FractureTools::CutoutSet::isPeriodic ( ) const [pure virtual]

Whether or not this cutout set is to be tiled.

virtual void FractureTools::CutoutSet::release ( ) [pure virtual]

Serialization Releases all memory and deletes itself.

The documentation for this class was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • CutoutSet
FractureTools::CutoutSet Member List
This is the complete list of members for FractureTools::CutoutSet, including all inherited members.
getCutoutCount() const =0 | FractureTools::CutoutSet | [pure virtual]
getCutoutLoopCount(uint32_t cutoutIndex) const =0 | FractureTools::CutoutSet | [pure virtual]
getCutoutLoopSize(uint32_t coutoutIndex, uint32_t loopIndex) const =0 | FractureTools::CutoutSet | [pure virtual]
getCutoutLoopVertexFlags(uint32_t cutoutIndex, uint32_t loopIndex, uint32_t vertexNum) const =0 | FractureTools::CutoutSet | [pure virtual]
getCutoutLoopVertexIndex(uint32_t cutoutIndex, uint32_t loopIndex, uint32_t vertexNum) const =0 | FractureTools::CutoutSet | [pure virtual]
getCutoutVertex(uint32_t cutoutIndex, uint32_t vertexIndex) const =0 | FractureTools::CutoutSet | [pure virtual]
getCutoutVertexCount(uint32_t cutoutIndex) const =0 | FractureTools::CutoutSet | [pure virtual]
getDimensions() const =0 | FractureTools::CutoutSet | [pure virtual]
isPeriodic() const =0 | FractureTools::CutoutSet | [pure virtual]
release()=0 | FractureTools::CutoutSet | [pure virtual]
~CutoutSet() | FractureTools::CutoutSet | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: NvParameterized::Conversion Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Conversion
Public Member Functions
NvParameterized::Conversion Class Reference

Interface class for legacy object conversions. More...

#include <NvParameterizedTraits.h>

List of all members.

Public Member Functions

virtual bool | operator() (::NvParameterized::Interface &legacyObj,::NvParameterized::Interface &obj)=0
Initialize object using data from legacy object.
virtual void | release ()=0
Release converter and any memory allocations associated with it.

Detailed Description

Interface class for legacy object conversions.

Member Function Documentation

virtual bool NvParameterized::Conversion::operator() | ( | ::NvParameterized::Interface & | legacyObj,
 |  | ::NvParameterized::Interface & | obj
 | ) |  | [pure virtual]

Initialize object using data from legacy object.

Parameters:
[in] | legacyObj | legacy object to be converter
[in] | obj | destination object
Returns:
true if conversion succeeded, false otherwise
Warning:
You may assume that all nested references were already converted.
The documentation for this class was generated from the following file:
  • NvParameterizedTraits.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Conversion
NvParameterized::Conversion Member List
This is the complete list of members for NvParameterized::Conversion, including all inherited members.
operator()(::NvParameterized::Interface &legacyObj,::NvParameterized::Interface &obj)=0 | NvParameterized::Conversion | [pure virtual]
release()=0 | NvParameterized::Conversion | [pure virtual]
~Conversion() (defined in NvParameterized::Conversion) | NvParameterized::Conversion | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::Definition Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Definition
Public Member Functions
NvParameterized::Definition Class Reference

Provides information about a parameter. More...

#include <NvParameterized.h>

List of all members.

Public Member Functions

virtual | ~Definition ()
Destructor.
virtual void | destroy ()=0
Destroys the Definition object and all nested dynamic objects contained within.
virtual int32_t | numHints (void) const =0
Returns the number of hints in the parameter Definition.
virtual const Hint * | hint (int32_t index) const =0
Returns the Hint located at the index.
virtual const Hint * | hint (const char *name) const =0
Returns the Hint that matches the input name.
virtual void | setHints (const Hint **hints, int32_t n)=0
Store parameter hints.
virtual void | addHint (Hint *hint)=0
Add parameter hint.
virtual const Definition * | parent (void) const =0
Returns this Definition's parent Definition.
virtual const Definition * | root (void) const =0
Returns this Definition's top most ancestor.
virtual const char * | name (void) const =0
Returns the name of the parameter.
virtual const char * | longName (void) const =0
Returns the long name of the parameter If the parameter is a member of a struct or an array the long name will contain these parent names.
virtual const char * | structName (void) const =0
Returns the name of parameter's struct type.
virtual DataType | type (void) const =0
Returns the parameter type.
virtual const char * | typeString () const =0
Return the parameter type in string form.
virtual int32_t | numRefVariants (void) const =0
Returns the number of variants this parameter could be A reference is sometimes a union of different types, each different type is referred to as a "variant". Variants can be used in either included or named references.
virtual int32_t | refVariantValIndex (const char *ref_val) const =0
Given the ref variant name, get its val index.
virtual const char * | refVariantVal (int32_t index) const =0
Get the string value of the reference variant.
virtual int32_t | numEnumVals (void) const =0
Returns the number of enums for the parameter.
virtual int32_t | enumValIndex (const char *enum_val) const =0
Given the enum string, get the enum val index.
virtual const char * | enumVal (int32_t index) const =0
Returns the Enum string located at the index.
virtual void | setEnumVals (const char **enum_vals, int32_t n)=0
Store possible enum values for TYPE_ENUM parameter.
virtual void | addEnumVal (const char *enum_val)=0
Add new enum value to a list of possible enum values for TYPE_ENUM parameter.
virtual uint32_t | alignment (void) const =0
Returns custom alignment if parameter uses it; otherwise returns 0.
virtual uint32_t | padding (void) const =0
Returns custom padding if parameter uses it; otherwise returns 0.
virtual int32_t | arrayDimension (void) const =0
Returns the number of dimensions of a static array.
virtual int32_t | arraySize (int32_t dimension=0) const =0
Returns the array size of a static array.
virtual bool | arraySizeIsFixed (void) const =0
Used to determine if an array is static or dynamic.
virtual bool | setArraySize (int32_t size)=0
Set size of static array.
virtual bool | isLeaf (void) const =0
Used to determine if parameter is aggregate (TYPE_STRUCT or TYPE_ARRAY) or not.
virtual bool | isIncludedRef (void) const =0
Used to determine if reference is included or not.
virtual int32_t | numChildren (void) const =0
Returns the number of children (for a struct or static array)
virtual const Definition * | child (int32_t index) const =0
Access definition of i-th child parameter.
virtual const Definition * | child (const char *name, int32_t &index) const =0
Access definition of child parameter with given name.
virtual void | setChildren (Definition **children, int32_t n)=0
Store definitions of child parameters.
virtual void | addChild (Definition *child)=0
Add definition of one morechild parameter.
virtual void | setDynamicHandleIndicesMap (const uint8_t *indices, uint32_t numIndices)=0
Set indices of child handles which must be released when downsizing array.
virtual const uint8_t * | getDynamicHandleIndicesMap (uint32_t &outNumIndices) const =0
Get indices of child handles which must be released when downsizing array.
virtual bool | isSimpleType (bool simpleStructs=true, bool simpleStrings=true) const =0
Used to determine whether type is not an aggregate (array, ref or struct)

Detailed Description

Provides information about a parameter.

Member Function Documentation

virtual void NvParameterized::Definition::addChild ( Definition * child ) [pure virtual]

Add definition of one morechild parameter.

Warning:
Only for internal use
virtual void NvParameterized::Definition::addEnumVal ( const char * enum_val ) [pure virtual]

Add new enum value to a list of possible enum values for TYPE_ENUM parameter.

Warning:
Only for internal use
virtual void NvParameterized::Definition::addHint ( Hint * hint ) [pure virtual]

Add parameter hint.

Warning:
Only for internal use
virtual int32_t NvParameterized::Definition::arraySize ( int32_t dimension = 0 ) const [pure virtual]

Returns the array size of a static array.

Returns:
0 for dynamic arrays
virtual const Definition* NvParameterized::Definition::child | ( | const char * | name,
 |  | int32_t & | index
 | ) |  | const [pure virtual]

Access definition of child parameter with given name.

Warning:
Only used with TYPE_STRUCT
virtual const char* NvParameterized::Definition::enumVal ( int32_t index ) const [pure virtual]

Returns the Enum string located at the index.

Returns:
NULL if index >= Hint::numEnumVals()
virtual int32_t NvParameterized::Definition::enumValIndex ( const char * enum_val ) const [pure virtual]

Given the enum string, get the enum val index.

Returns:
-1 if input enum_val is not found
virtual const Hint* NvParameterized::Definition::hint ( const char * name ) const [pure virtual]

Returns the Hint that matches the input name.

Returns:
NULL if name does not match any of the Definition's hints
virtual const Hint* NvParameterized::Definition::hint ( int32_t index ) const [pure virtual]

Returns the Hint located at the index.

Returns:
NULL if index >= Hint::numHints()
virtual bool NvParameterized::Definition::isSimpleType | ( | bool | simpleStructs = true,
 |  | bool | simpleStrings = true
 | ) |  | const [pure virtual]

Used to determine whether type is not an aggregate (array, ref or struct)

Parameters:
[in] | simpleStructs | structure of simple types is also considered simple
[in] | simpleStrings | strings are considered simple
virtual const Definition* NvParameterized::Definition::parent ( void ) const [pure virtual]

Returns this Definition's parent Definition.

Returns:
NULL if at the top level
virtual int32_t NvParameterized::Definition::refVariantValIndex ( const char * ref_val ) const [pure virtual]

Given the ref variant name, get its val index.

Returns:
-1 if input ref_val is not found
virtual bool NvParameterized::Definition::setArraySize ( int32_t size ) [pure virtual]

Set size of static array.

Warning:
Only for internal use
virtual void NvParameterized::Definition::setChildren | ( | Definition ** | children,
 |  | int32_t | n
 | ) |  | [pure virtual]

Store definitions of child parameters.

Warning:
Only for internal use
virtual void NvParameterized::Definition::setEnumVals | ( | const char ** | enum_vals,
 |  | int32_t | n
 | ) |  | [pure virtual]

Store possible enum values for TYPE_ENUM parameter.

Warning:
Only for internal use
virtual void NvParameterized::Definition::setHints | ( | const Hint ** | hints,
 |  | int32_t | n
 | ) |  | [pure virtual]

Store parameter hints.

Warning:
Only for internal use
virtual const char* NvParameterized::Definition::structName ( void ) const [pure virtual]

Returns the name of parameter's struct type.

Returns:
NULL if not struct
The documentation for this class was generated from the following file:
  • NvParameterized.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Definition
NvParameterized::Definition Member List
This is the complete list of members for NvParameterized::Definition, including all inherited members.
addChild(Definition *child)=0 | NvParameterized::Definition | [pure virtual]
addEnumVal(const char *enum_val)=0 | NvParameterized::Definition | [pure virtual]
addHint(Hint *hint)=0 | NvParameterized::Definition | [pure virtual]
alignment(void) const =0 | NvParameterized::Definition | [pure virtual]
arrayDimension(void) const =0 | NvParameterized::Definition | [pure virtual]
arraySize(int32_t dimension=0) const =0 | NvParameterized::Definition | [pure virtual]
arraySizeIsFixed(void) const =0 | NvParameterized::Definition | [pure virtual]
child(int32_t index) const =0 | NvParameterized::Definition | [pure virtual]
child(const char *name, int32_t &index) const =0 | NvParameterized::Definition | [pure virtual]
destroy()=0 | NvParameterized::Definition | [pure virtual]
enumVal(int32_t index) const =0 | NvParameterized::Definition | [pure virtual]
enumValIndex(const char *enum_val) const =0 | NvParameterized::Definition | [pure virtual]
getDynamicHandleIndicesMap(uint32_t &outNumIndices) const =0 | NvParameterized::Definition | [pure virtual]
hint(int32_t index) const =0 | NvParameterized::Definition | [pure virtual]
hint(const char *name) const =0 | NvParameterized::Definition | [pure virtual]
isIncludedRef(void) const =0 | NvParameterized::Definition | [pure virtual]
isLeaf(void) const =0 | NvParameterized::Definition | [pure virtual]
isSimpleType(bool simpleStructs=true, bool simpleStrings=true) const =0 | NvParameterized::Definition | [pure virtual]
longName(void) const =0 | NvParameterized::Definition | [pure virtual]
name(void) const =0 | NvParameterized::Definition | [pure virtual]
numChildren(void) const =0 | NvParameterized::Definition | [pure virtual]
numEnumVals(void) const =0 | NvParameterized::Definition | [pure virtual]
numHints(void) const =0 | NvParameterized::Definition | [pure virtual]
numRefVariants(void) const =0 | NvParameterized::Definition | [pure virtual]
padding(void) const =0 | NvParameterized::Definition | [pure virtual]
parent(void) const =0 | NvParameterized::Definition | [pure virtual]
refVariantVal(int32_t index) const =0 | NvParameterized::Definition | [pure virtual]
refVariantValIndex(const char *ref_val) const =0 | NvParameterized::Definition | [pure virtual]
root(void) const =0 | NvParameterized::Definition | [pure virtual]
setArraySize(int32_t size)=0 | NvParameterized::Definition | [pure virtual]
setChildren(Definition **children, int32_t n)=0 | NvParameterized::Definition | [pure virtual]
setDynamicHandleIndicesMap(const uint8_t *indices, uint32_t numIndices)=0 | NvParameterized::Definition | [pure virtual]
setEnumVals(const char **enum_vals, int32_t n)=0 | NvParameterized::Definition | [pure virtual]
setHints(const Hint **hints, int32_t n)=0 | NvParameterized::Definition | [pure virtual]
structName(void) const =0 | NvParameterized::Definition | [pure virtual]
type(void) const =0 | NvParameterized::Definition | [pure virtual]
typeString() const =0 | NvParameterized::Definition | [pure virtual]
~Definition() | NvParameterized::Definition | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::Factory Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Factory
Public Member Functions
NvParameterized::Factory Class Reference

Interface class for NvParameterized factories. More...

#include <NvParameterizedTraits.h>

List of all members.

Public Member Functions

virtual
::NvParameterized::Interface * 		create (Traits *paramTraits)=0
Creates NvParameterized object of class.
virtual
::NvParameterized::Interface * 		finish (Traits *paramTraits, void *obj, void *buf, int32_t *refCount)=0
Finishes initialization of inplace-deserialized objects (vptr and stuff)
virtual const char * | getClassName ()=0
Returns name of class whose objects are created by factory.
virtual uint32_t | getVersion ()=0
Returns version of class whose objects are created by factory.
virtual uint32_t | getAlignment ()=0
Returns memory alignment required for objects of class.
virtual const uint32_t * | getChecksum (uint32_t &bits)=0
Returns checksum of class whose objects are created by factory.
virtual | ~Factory ()
Destructor.
virtual void | freeParameterDefinitionTable (NvParameterized::Traits *traits)=0
Clean reflection definition table. Call it if you don't have any instances of classes.

Detailed Description

Interface class for NvParameterized factories.

The documentation for this class was generated from the following file:
  • NvParameterizedTraits.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Factory
NvParameterized::Factory Member List
This is the complete list of members for NvParameterized::Factory, including all inherited members.
create(Traits *paramTraits)=0 | NvParameterized::Factory | [pure virtual]
finish(Traits *paramTraits, void *obj, void *buf, int32_t *refCount)=0 | NvParameterized::Factory | [pure virtual]
freeParameterDefinitionTable(NvParameterized::Traits *traits)=0 | NvParameterized::Factory | [pure virtual]
getAlignment()=0 | NvParameterized::Factory | [pure virtual]
getChecksum(uint32_t &bits)=0 | NvParameterized::Factory | [pure virtual]
getClassName()=0 | NvParameterized::Factory | [pure virtual]
getVersion()=0 | NvParameterized::Factory | [pure virtual]
~Factory() | NvParameterized::Factory | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::Handle Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Handle
Public Types | Public Member Functions
NvParameterized::Handle Class Reference

Provides access to individual parameters within the NvParameterized object. More...

#include <NvParameterized.h>

List of all members.

Public Types

enum | { MAX_DEPTH = 16 }

Public Member Functions

PX_INLINE | Handle (::NvParameterized::Interface *iface)
The constructor takes a pointer (if the user requires an instance before the NvParameterized::Interface exists)
PX_INLINE | Handle (::NvParameterized::Interface &iface)
The constructor takes a reference.
PX_INLINE | Handle (const ::NvParameterized::Interface &iface)
The constructor takes a const interface.
PX_INLINE | Handle (const Handle &param_handle)
Copy constructor.
PX_INLINE | Handle (::NvParameterized::Interface &instance, const char *longName)
This constructor allows the user to create a handle that initially points at a particular parameter in the instance.
PX_INLINE | Handle (const ::NvParameterized::Interface &instance, const char *longName)
This constructor allows the user to create a handle that initially points at a particular parameter in the instance.
PX_INLINE const Definition * | parameterDefinition (void) const
Get the parameter Definition for the handle's parameter.
PX_INLINE int32_t | numIndexes (void) const
Get the depth of the handle within the NvParameterized object.
PX_INLINE int32_t | index (int32_t i) const
Get the index at the specified depth within the NvParameterized object.
PX_INLINE int32_t | popIndex (int32_t levels=1)
Reduce the handle's depth within the NvParameterized object.
PX_INLINE ErrorType | set (const ::NvParameterized::Interface *instance, const Definition *root, const char *child_long_name)
Set the Handle so it references a parameter in the specified instance with the name child_long_name.
PX_INLINE ErrorType | set (const ::NvParameterized::Interface *instance, const char *child_long_name)
Set the Handle so it references a parameter in the specified instance with the name child_long_name.
PX_INLINE ErrorType | getParameter (const char *longName)
Get the parameter specified by longName and set the Handle to point it Given a long name like "mystruct.somearray[10].foo", it will return a handle to that specific parameter. The handle can then be used to set/get values, as long as it's a handle to a leaf node.
PX_INLINE ErrorType | set (int32_t child_index)
Set the depth of the handle within the handle's parameter.
PX_INLINE ErrorType | getChildHandle (const ::NvParameterized::Interface *instance, const char *child_long_name, Handle &outHandle)
Get a child handle of this handle Sets handle to point to a child of this handle, with child_long_name being relative to the current long name.
PX_INLINE ErrorType | getChildHandle (int32_t index, Handle &outHandle)
Get a child handle of this handle Sets handle to point to a direct child of this handle. Works with structs and arrays.
PX_INLINE bool | getLongName (char *str, uint32_t max_str_len) const
Returns the long name of the parameter, with indexes into str.
PX_INLINE void | reset ()
Reset all of the state data for the handle.
PX_INLINE bool | isConst (void) const
Does handle correspond to an existing Interface?
PX_INLINE bool | isValid (void) const
Does handle correspond to a valid parameter?
PX_INLINE | operator bool () const
Same as isValid.
PX_INLINE const void * | userData (void) const
Return user data stored in handle.
PX_INLINE void * | userData (void)
Return user data stored in handle.
PX_INLINE void | setUserData (void *user_data)
Store user data in handle.
PX_INLINE::NvParameterized::Interface * | getInterface (void) const
Get associated NvParameterized object.
PX_INLINEconst::NvParameterized::Interface * | getConstInterface (void) const
Get associated NvParameterized object.
PX_INLINE void | setInterface (::NvParameterized::Interface *iface)
Set associated NvParameterized object.
PX_INLINE void | setInterface (const ::NvParameterized::Interface *iface)
Set associated NvParameterized object.
PX_INLINE ErrorType | initParamRef (const char *chosenRefStr=0, bool doDestroyOld=false)
Initialize a Reference parameter.
PX_INLINE ErrorType | valueToStr (char *buf, uint32_t bufSize, const char *&ret)
Store this Handle's parameter to a string.
PX_INLINE ErrorType | strToValue (const char *str, const char **endptr)
Store the string to this Handle's parameter.
ErrorType | resizeArray (int32_t new_size)
Resize the array that the Handle points to.
PX_INLINE ErrorType | getArraySize (int32_t &size, int32_t dimension=0) const
Get the array size for the given array dimension.
PX_INLINE ErrorType | swapArrayElements (uint32_t firstElement, uint32_t secondElement)
Swap two elements of an array.
PX_INLINE ErrorType | getParamBool (bool &val) const
Get param.
PX_INLINE ErrorType | setParamBool (bool val)
Set param.
PX_INLINE ErrorType | getParamBoolArray (bool *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamBoolArray (const bool *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | getParamString (const char *&val) const
Get param.
PX_INLINE ErrorType | setParamString (const char *val)
Set param.
PX_INLINE ErrorType | getParamStringArray (char **array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamStringArray (const char **array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | getParamEnum (const char *&val) const
Get param.
PX_INLINE ErrorType | setParamEnum (const char *val)
Set param.
PX_INLINE ErrorType | getParamEnumArray (char **array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamEnumArray (const char **array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | getParamRef (::NvParameterized::Interface *&val) const
PX_INLINE ErrorType | getParamRefArray (::NvParameterized::Interface **array, int32_t n, int32_t offset=0) const
PX_INLINE ErrorType | setParamRef (::NvParameterized::Interface *val, bool doDestroyOld=false)
PX_INLINE ErrorType | setParamRefArray (::NvParameterized::Interface **array, int32_t n, int32_t offset=0, bool doDestroyOld=false)
PX_INLINE ErrorType | getParamI8 (int8_t &val) const
Get param.
PX_INLINE ErrorType | setParamI8 (int8_t val)
Set param.
PX_INLINE ErrorType | getParamI8Array (int8_t *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamI8Array (const int8_t *val, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | getParamI16 (int16_t &val) const
Get param.
PX_INLINE ErrorType | setParamI16 (int16_t val)
Set param.
PX_INLINE ErrorType | getParamI16Array (int16_t *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamI16Array (const int16_t *val, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | getParamI32 (int32_t &val) const
Get param.
PX_INLINE ErrorType | setParamI32 (int32_t val)
Set param.
PX_INLINE ErrorType | getParamI32Array (int32_t *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamI32Array (const int32_t *val, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | getParamI64 (int64_t &val) const
Get param.
PX_INLINE ErrorType | setParamI64 (int64_t val)
Set param.
PX_INLINE ErrorType | getParamI64Array (int64_t *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamI64Array (const int64_t *val, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | getParamU8 (uint8_t &val) const
Get param.
PX_INLINE ErrorType | setParamU8 (uint8_t val)
Set param.
PX_INLINE ErrorType | getParamU8Array (uint8_t *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamU8Array (const uint8_t *val, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | getParamU16 (uint16_t &val) const
Get param.
PX_INLINE ErrorType | setParamU16 (uint16_t val)
Set param.
PX_INLINE ErrorType | getParamU16Array (uint16_t *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamU16Array (const uint16_t *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | getParamU32 (uint32_t &val) const
Get param.
PX_INLINE ErrorType | setParamU32 (uint32_t val)
Set param.
PX_INLINE ErrorType | getParamU32Array (uint32_t *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamU32Array (const uint32_t *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | getParamU64 (uint64_t &val) const
Get param.
PX_INLINE ErrorType | setParamU64 (uint64_t val)
Set param.
PX_INLINE ErrorType | getParamU64Array (uint64_t *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamU64Array (const uint64_t *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | getParamF32 (float &val) const
Get param.
PX_INLINE ErrorType | setParamF32 (float val)
Set param.
PX_INLINE ErrorType | getParamF32Array (float *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamF32Array (const float *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | getParamF64 (double &val) const
Get param.
PX_INLINE ErrorType | setParamF64 (double val)
Set param.
PX_INLINE ErrorType | getParamF64Array (double *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamF64Array (const double *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | setParamVec2 (const physx::PxVec2 &val)
Set param.
PX_INLINE ErrorType | getParamVec2 (physx::PxVec2 &val) const
Get param.
PX_INLINE ErrorType | getParamVec2Array (physx::PxVec2 *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamVec2Array (const physx::PxVec2 *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | setParamVec3 (const physx::PxVec3 &val)
Get param.
PX_INLINE ErrorType | getParamVec3 (physx::PxVec3 &val) const
Set param.
PX_INLINE ErrorType | getParamVec3Array (physx::PxVec3 *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamVec3Array (const physx::PxVec3 *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | setParamVec4 (const physx::PxVec4 &val)
Get param.
PX_INLINE ErrorType | getParamVec4 (physx::PxVec4 &val) const
Set param.
PX_INLINE ErrorType | getParamVec4Array (physx::PxVec4 *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamVec4Array (const physx::PxVec4 *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | setParamQuat (const physx::PxQuat &val)
Get param.
PX_INLINE ErrorType | getParamQuat (physx::PxQuat &val) const
Set param.
PX_INLINE ErrorType | getParamQuatArray (physx::PxQuat *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamQuatArray (const physx::PxQuat *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | setParamMat33 (const physx::PxMat33 &val)
Get param.
PX_INLINE ErrorType | getParamMat33 (physx::PxMat33 &val) const
Set param.
PX_INLINE ErrorType | getParamMat33Array (physx::PxMat33 *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamMat33Array (const physx::PxMat33 *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | setParamMat44 (const physx::PxMat44 &val)
Set param.
PX_INLINE ErrorType | getParamMat44 (physx::PxMat44 &val) const
Get param.
PX_INLINE ErrorType | getParamMat44Array (physx::PxMat44 *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamMat44Array (const physx::PxMat44 *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | setParamMat34Legacy (const float(&val)[12])
Set param.
PX_INLINE ErrorType | getParamMat34Legacy (float(&val)[12]) const
Get param.
PX_INLINE ErrorType | getParamMat34LegacyArray (float *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamMat34LegacyArray (const float *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | setParamBounds3 (const physx::PxBounds3 &val)
Set param.
PX_INLINE ErrorType | getParamBounds3 (physx::PxBounds3 &val) const
Get param.
PX_INLINE ErrorType | getParamBounds3Array (physx::PxBounds3 *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamBounds3Array (const physx::PxBounds3 *array, int32_t n, int32_t offset=0)
Set param.
PX_INLINE ErrorType | setParamTransform (const physx::PxTransform &val)
Set param.
PX_INLINE ErrorType | getParamTransform (physx::PxTransform &val) const
Get param.
PX_INLINE ErrorType | getParamTransformArray (physx::PxTransform *array, int32_t n, int32_t offset=0) const
Get param.
PX_INLINE ErrorType | setParamTransformArray (const physx::PxTransform *array, int32_t n, int32_t offset=0)
Set param.
template<typename T >
PX_INLINE ErrorType | setParam (const T &val)
Template version of setParamXxx.
template<typename T >
PX_INLINE ErrorType | getParam (T &val) const
Template version of getParamXxx.
template<typename T >
PX_INLINE ErrorType | getParamArray (T *array, int32_t n, int32_t offset=0) const
Template version of getParamXxxArray.
template<typename T >
PX_INLINE ErrorType | setParamArray (const T *array, int32_t n, int32_t offset=0)
Template version of setParamXxxArray.

Detailed Description

Provides access to individual parameters within the NvParameterized object.

Constructor & Destructor Documentation

PX_INLINE NvParameterized::Handle::Handle ( const ::NvParameterized::Interface & iface )

The constructor takes a const interface.

Note:
Handles which are constructed from const objects are not allowed to modify them.
PX_INLINE NvParameterized::Handle::Handle | ( | const ::NvParameterized::Interface & | instance,
 |  | const char * | longName
 | ) |  |

This constructor allows the user to create a handle that initially points at a particular parameter in the instance.

Note:
Handles which are constructed from const objects are not allowed to modify them.

Member Function Documentation

PX_INLINE ::NvParameterized::Interface* NvParameterized::Handle::getInterface ( void ) const [inline]

Get associated NvParameterized object.

Note:
Will return NULL in case of const handle (use getConstInterface instead)
PX_INLINE bool NvParameterized::Handle::getLongName | ( | char * | str,
 |  | uint32_t | max_str_len
 | ) |  | const

Returns the long name of the parameter, with indexes into str.

Returns:
false if the long name didn't fit in str.
PX_INLINE ErrorType NvParameterized::Handle::getParameter ( const char * longName )

Get the parameter specified by longName and set the Handle to point it Given a long name like "mystruct.somearray[10].foo", it will return a handle to that specific parameter. The handle can then be used to set/get values, as long as it's a handle to a leaf node.

Note:
this method will not work if an included reference's child is included in the longName
PX_INLINE ErrorType NvParameterized::Handle::getParamRef ( ::NvParameterized::Interface *& val ) const
See also:
Interface::getParamRef()
PX_INLINE ErrorType NvParameterized::Handle::getParamRefArray | ( | ::NvParameterized::Interface ** | array,
 |  | int32_t | n,
 |  | int32_t | offset = 0
 | ) |  | const
See also:
Interface::getParamRefArray()
PX_INLINE ErrorType NvParameterized::Handle::initParamRef | ( | const char * | chosenRefStr = 0,
 |  | bool | doDestroyOld = false
 | ) |  |

Initialize a Reference parameter.

Parameters:
[in] | chosenRefStr | This string must be one of the strings returned from Definition::refVariantVal()
[in] | doDestroyOld | Sets whether the previous object should be destroyed or not
See also:
Interface::initParamRef(), Definition::numRefVariants(), Definition::refVariantVal()
PX_INLINE ErrorType NvParameterized::Handle::set ( int32_t child_index )

Set the depth of the handle within the handle's parameter.

The set method is useful for accessing indices within an array of parameters or members within a struct.

PX_INLINE ErrorType NvParameterized::Handle::setParamRef | ( | ::NvParameterized::Interface * | val,
 |  | bool | doDestroyOld = false
 | ) |  |
See also:
Interface::setParamRef()
PX_INLINE ErrorType NvParameterized::Handle::setParamRefArray | ( | ::NvParameterized::Interface ** | array,
 |  | int32_t | n,
 |  | int32_t | offset = 0,
 |  | bool | doDestroyOld = false
 | ) |  |
See also:
Interface::setParamRefArray()
PX_INLINE ErrorType NvParameterized::Handle::strToValue | ( | const char * | str,
 |  | const char ** | endptr
 | ) |  |

Store the string to this Handle's parameter.

Returns:
ERROR_TYPE_NOT_SUPPORTED if the Handle's parameter type is an array, struct, or reference
ERROR_NONE if the Handle's parameter type is a simple type (u32, i32, vec3, etc)
PX_PUSH_PACK_DEFAULT PX_POP_PACK PX_INLINE ErrorType NvParameterized::Handle::valueToStr | ( | char * | buf,
 |  | uint32_t | bufSize,
 |  | const char *& | ret
 | ) |  |

Store this Handle's parameter to a string.

NvParameterized type X-macro template.

Parameters:
[in] | buf | this buffer is used to store any strings that need to be constructed
[in] | bufSize | size of buf
[out] | ret | this contains a pointer to the value as a string, it may or may not be equal to buf, depending if the value had to be constructed dynamically or if it already exists as a static string
Note:
See http://en.wikipedia.org/wiki/C_preprocessor#X-Macros for more detailsPX_PS4 PX_PS4
The documentation for this class was generated from the following files:
  • NvParameterized.h
  • NvParameterized.inl
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Handle
NvParameterized::Handle Member List
This is the complete list of members for NvParameterized::Handle, including all inherited members.
getArraySize(int32_t &size, int32_t dimension=0) const | NvParameterized::Handle |
getChildHandle(const ::NvParameterized::Interface *instance, const char *child_long_name, Handle &outHandle) | NvParameterized::Handle |
getChildHandle(int32_t index, Handle &outHandle) | NvParameterized::Handle |
getConstInterface(void) const | NvParameterized::Handle | [inline]
getInterface(void) const | NvParameterized::Handle | [inline]
getLongName(char *str, uint32_t max_str_len) const | NvParameterized::Handle |
getParam(T &val) const | NvParameterized::Handle |
getParamArray(T *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamBool(bool &val) const | NvParameterized::Handle |
getParamBoolArray(bool *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamBounds3(physx::PxBounds3 &val) const | NvParameterized::Handle |
getParamBounds3Array(physx::PxBounds3 *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamEnum(const char *&val) const | NvParameterized::Handle |
getParamEnumArray(char **array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParameter(const char *longName) | NvParameterized::Handle |
getParamF32(float &val) const | NvParameterized::Handle |
getParamF32Array(float *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamF64(double &val) const | NvParameterized::Handle |
getParamF64Array(double *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamI16(int16_t &val) const | NvParameterized::Handle |
getParamI16Array(int16_t *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamI32(int32_t &val) const | NvParameterized::Handle |
getParamI32Array(int32_t *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamI64(int64_t &val) const | NvParameterized::Handle |
getParamI64Array(int64_t *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamI8(int8_t &val) const | NvParameterized::Handle |
getParamI8Array(int8_t *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamMat33(physx::PxMat33 &val) const | NvParameterized::Handle |
getParamMat33Array(physx::PxMat33 *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamMat34Legacy(float(&val)[12]) const | NvParameterized::Handle |
getParamMat34LegacyArray(float *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamMat44(physx::PxMat44 &val) const | NvParameterized::Handle |
getParamMat44Array(physx::PxMat44 *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamQuat(physx::PxQuat &val) const | NvParameterized::Handle |
getParamQuatArray(physx::PxQuat *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamRef(::NvParameterized::Interface *&val) const | NvParameterized::Handle |
getParamRefArray(::NvParameterized::Interface **array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamString(const char *&val) const | NvParameterized::Handle |
getParamStringArray(char **array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamTransform(physx::PxTransform &val) const | NvParameterized::Handle |
getParamTransformArray(physx::PxTransform *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamU16(uint16_t &val) const | NvParameterized::Handle |
getParamU16Array(uint16_t *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamU32(uint32_t &val) const | NvParameterized::Handle |
getParamU32Array(uint32_t *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamU64(uint64_t &val) const | NvParameterized::Handle |
getParamU64Array(uint64_t *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamU8(uint8_t &val) const | NvParameterized::Handle |
getParamU8Array(uint8_t *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamVec2(physx::PxVec2 &val) const | NvParameterized::Handle |
getParamVec2Array(physx::PxVec2 *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamVec3(physx::PxVec3 &val) const | NvParameterized::Handle |
getParamVec3Array(physx::PxVec3 *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
getParamVec4(physx::PxVec4 &val) const | NvParameterized::Handle |
getParamVec4Array(physx::PxVec4 *array, int32_t n, int32_t offset=0) const | NvParameterized::Handle |
Handle(::NvParameterized::Interface *iface) | NvParameterized::Handle |
Handle(::NvParameterized::Interface &iface) | NvParameterized::Handle |
Handle(const ::NvParameterized::Interface &iface) | NvParameterized::Handle |
Handle(const Handle &param_handle) | NvParameterized::Handle |
Handle(::NvParameterized::Interface &instance, const char *longName) | NvParameterized::Handle |
Handle(const ::NvParameterized::Interface &instance, const char *longName) | NvParameterized::Handle |
index(int32_t i) const | NvParameterized::Handle | [inline]
initParamRef(const char *chosenRefStr=0, bool doDestroyOld=false) | NvParameterized::Handle |
isConst(void) const | NvParameterized::Handle | [inline]
isValid(void) const | NvParameterized::Handle | [inline]
MAX_DEPTH enum value (defined in NvParameterized::Handle) | NvParameterized::Handle |
numIndexes(void) const | NvParameterized::Handle | [inline]
operator bool() const | NvParameterized::Handle | [inline]
parameterDefinition(void) const | NvParameterized::Handle | [inline]
popIndex(int32_t levels=1) | NvParameterized::Handle |
reset() | NvParameterized::Handle |
resizeArray(int32_t new_size) | NvParameterized::Handle |
set(const ::NvParameterized::Interface *instance, const Definition *root, const char *child_long_name) | NvParameterized::Handle |
set(const ::NvParameterized::Interface *instance, const char *child_long_name) | NvParameterized::Handle |
set(int32_t child_index) | NvParameterized::Handle |
setInterface(::NvParameterized::Interface *iface) | NvParameterized::Handle | [inline]
setInterface(const ::NvParameterized::Interface *iface) | NvParameterized::Handle | [inline]
setParam(const T &val) | NvParameterized::Handle |
setParamArray(const T *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamBool(bool val) | NvParameterized::Handle |
setParamBoolArray(const bool *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamBounds3(const physx::PxBounds3 &val) | NvParameterized::Handle |
setParamBounds3Array(const physx::PxBounds3 *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamEnum(const char *val) | NvParameterized::Handle |
setParamEnumArray(const char **array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamF32(float val) | NvParameterized::Handle |
setParamF32Array(const float *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamF64(double val) | NvParameterized::Handle |
setParamF64Array(const double *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamI16(int16_t val) | NvParameterized::Handle |
setParamI16Array(const int16_t *val, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamI32(int32_t val) | NvParameterized::Handle |
setParamI32Array(const int32_t *val, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamI64(int64_t val) | NvParameterized::Handle |
setParamI64Array(const int64_t *val, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamI8(int8_t val) | NvParameterized::Handle |
setParamI8Array(const int8_t *val, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamMat33(const physx::PxMat33 &val) | NvParameterized::Handle |
setParamMat33Array(const physx::PxMat33 *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamMat34Legacy(const float(&val)[12]) | NvParameterized::Handle |
setParamMat34LegacyArray(const float *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamMat44(const physx::PxMat44 &val) | NvParameterized::Handle |
setParamMat44Array(const physx::PxMat44 *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamQuat(const physx::PxQuat &val) | NvParameterized::Handle |
setParamQuatArray(const physx::PxQuat *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamRef(::NvParameterized::Interface *val, bool doDestroyOld=false) | NvParameterized::Handle |
setParamRefArray(::NvParameterized::Interface **array, int32_t n, int32_t offset=0, bool doDestroyOld=false) | NvParameterized::Handle |
setParamString(const char *val) | NvParameterized::Handle |
setParamStringArray(const char **array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamTransform(const physx::PxTransform &val) | NvParameterized::Handle |
setParamTransformArray(const physx::PxTransform *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamU16(uint16_t val) | NvParameterized::Handle |
setParamU16Array(const uint16_t *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamU32(uint32_t val) | NvParameterized::Handle |
setParamU32Array(const uint32_t *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamU64(uint64_t val) | NvParameterized::Handle |
setParamU64Array(const uint64_t *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamU8(uint8_t val) | NvParameterized::Handle |
setParamU8Array(const uint8_t *val, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamVec2(const physx::PxVec2 &val) | NvParameterized::Handle |
setParamVec2Array(const physx::PxVec2 *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamVec3(const physx::PxVec3 &val) | NvParameterized::Handle |
setParamVec3Array(const physx::PxVec3 *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setParamVec4(const physx::PxVec4 &val) | NvParameterized::Handle |
setParamVec4Array(const physx::PxVec4 *array, int32_t n, int32_t offset=0) | NvParameterized::Handle |
setUserData(void *user_data) | NvParameterized::Handle | [inline]
strToValue(const char *str, const char **endptr) | NvParameterized::Handle |
swapArrayElements(uint32_t firstElement, uint32_t secondElement) | NvParameterized::Handle |
userData(void) const | NvParameterized::Handle | [inline]
userData(void) | NvParameterized::Handle | [inline]
valueToStr(char *buf, uint32_t bufSize, const char *&ret) | NvParameterized::Handle |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::Hint Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Hint
Public Member Functions
NvParameterized::Hint Class Reference

Provides hints about the parameter definition. More...

#include <NvParameterized.h>

List of all members.

Public Member Functions

virtual | ~Hint ()
Destructor.
virtual const char * | name (void) const =0
Returns the name of the hint.
virtual DataType | type (void) const =0
Returns the type of the hint.
virtual uint64_t | asUInt (void) const =0
Returns the unsigned 64-bit value of the hint.
virtual double | asFloat (void) const =0
Returns the 64-bit floating point value of the hint.
virtual const char * | asString (void) const =0
Returns the const character pointer for hint.
virtual bool | setAsUInt (uint64_t v)=0
Set the value if the hint is a 64bit unsigned type.

Detailed Description

Provides hints about the parameter definition.

See also:
Definition

Member Function Documentation

virtual double NvParameterized::Hint::asFloat ( void ) const [pure virtual]

Returns the 64-bit floating point value of the hint.

Note:
Undefined results if the type != TYPE_FU64
virtual const char* NvParameterized::Hint::asString ( void ) const [pure virtual]

Returns the const character pointer for hint.

Note:
Undefined results if the type != TYPE_STRING
virtual uint64_t NvParameterized::Hint::asUInt ( void ) const [pure virtual]

Returns the unsigned 64-bit value of the hint.

Note:
Undefined results if the type != TYPE_U64
The documentation for this class was generated from the following file:
  • NvParameterized.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Hint
NvParameterized::Hint Member List
This is the complete list of members for NvParameterized::Hint, including all inherited members.
asFloat(void) const =0 | NvParameterized::Hint | [pure virtual]
asString(void) const =0 | NvParameterized::Hint | [pure virtual]
asUInt(void) const =0 | NvParameterized::Hint | [pure virtual]
name(void) const =0 | NvParameterized::Hint | [pure virtual]
setAsUInt(uint64_t v)=0 | NvParameterized::Hint | [pure virtual]
type(void) const =0 | NvParameterized::Hint | [pure virtual]
~Hint() | NvParameterized::Hint | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::Interface Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Interface
Public Member Functions | Protected Member Functions | Friends
NvParameterized::Interface Class Reference

Represents the interface to the NvParameterized object. More...

#include <NvParameterized.h>

List of all members.

Public Member Functions

virtual | ~Interface ()
Destructor.
virtual void | destroy ()=0
Destroys the NvParameterized object and all nested dynamic objects contained within.
virtual void | initDefaults (void)=0
Initializes all parameters to their default value.
virtual void | initRandom (void)=0
Initializes all parameters with random values.
virtual const char * | className (void) const =0
Get the class name.
virtual void | setClassName (const char *name)=0
Sets the class name.
virtual const char * | name (void) const =0
Get the name of the NvParameterized object This method is used for named references. The name will typically specify an asset to be loaded.
virtual void | setName (const char *name)=0
Set the name of the NvParameterized object This method is used for named references. The name will typically specify an asset to be loaded.
virtual uint32_t | version (void) const =0
Get the class version.
virtual uint16_t | getMajorVersion (void) const =0
Get the major part of class version.
virtual uint16_t | getMinorVersion (void) const =0
Get the minor part of class version.
virtual const uint32_t * | checksum (uint32_t &bits) const =0
Get the class checksum.
virtual int32_t | numParameters (void)=0
Get the number of parameters contained in the NvParameterized object.
virtual const Definition * | parameterDefinition (int32_t index)=0
Get the definition of i-th parameter.
virtual const Definition * | rootParameterDefinition (void)=0
Get definition of root structure.
virtual const Definition * | rootParameterDefinition (void) const =0
Get definition of root structure.
virtual ErrorType | getParameterHandle (const char *longName, Handle &handle) const =0
Set the Handle to point to the parameter specified by longName Given a long name like "mystruct.somearray[10].foo", it will return a handle to that specific parameter. The handle can then be used to set/get values, as long as it's a handle to a leaf node.
virtual ErrorType | getParameterHandle (const char *longName, Handle &handle)=0
Set the Handle to point to the parameter specified by longName Given a long name like "mystruct.somearray[10].foo", it will return a handle to that specific parameter. The handle can then be used to set/get values, as long as it's a handle to a leaf node.
virtual void | setSerializationCallback (SerializationCallback *cb, void *userData=NULL)=0
An application may set a callback function that is called immediately before serialization.
virtual ErrorType | callPreSerializeCallback () const =0
Called prior by Serializer to serialization.
virtual bool | equals (const ::NvParameterized::Interface &obj, Handle *handlesOfInequality=NULL, uint32_t numHandlesOfInequality=0, bool doCompareNotSerialized=true) const =0
Compares two NvParameterized objects.
virtual bool | areParamsOK (Handle *invalidHandles=NULL, uint32_t numInvalidHandles=0)=0
Checks if object satisfies schema constraints.
virtual ErrorType | copy (const ::NvParameterized::Interface &src)=0
Copies an NvParameterized object.
virtual ErrorType | clone (Interface *&nullDestObject) const =0
Clones an NvParameterized object.
virtual bool | checkAlignments () const =0
Check that alignments of internal elements match the schema.

Protected Member Functions

virtual ErrorType | initParamRef (const Handle &handle, const char *chosenRefStr=0, bool doDestroyOld=false)=0
Initialize a Reference parameter.
virtual ErrorType | getParamBool (const Handle &handle, bool &val) const =0
Get param.
virtual ErrorType | setParamBool (const Handle &handle, bool val)=0
Set param.
virtual ErrorType | getParamBoolArray (const Handle &handle, bool *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamBoolArray (const Handle &handle, const bool *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | getParamString (const Handle &handle, const char *&val) const =0
Get param.
virtual ErrorType | setParamString (const Handle &handle, const char *val)=0
Set param.
virtual ErrorType | getParamStringArray (const Handle &handle, char **array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamStringArray (const Handle &handle, const char **array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | getParamEnum (const Handle &handle, const char *&val) const =0
Get param.
virtual ErrorType | setParamEnum (const Handle &handle, const char *val)=0
Set param.
virtual ErrorType | getParamEnumArray (const Handle &handle, char **array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamEnumArray (const Handle &handle, const char **array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | getParamRef (const Handle &handle,::NvParameterized::Interface *&val) const =0
Get param.
virtual ErrorType | getParamRefArray (const Handle &handle,::NvParameterized::Interface **array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamRef (const Handle &handle,::NvParameterized::Interface *val, bool doDestroyOld=false)=0
virtual ErrorType | setParamRefArray (const Handle &handle,::NvParameterized::Interface **array, int32_t n, int32_t offset=0, bool doDestroyOld=false)=0
virtual ErrorType | getParamI8 (const Handle &handle, int8_t &val) const =0
Get param.
virtual ErrorType | setParamI8 (const Handle &handle, int8_t val)=0
Set param.
virtual ErrorType | getParamI8Array (const Handle &handle, int8_t *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamI8Array (const Handle &handle, const int8_t *val, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | getParamI16 (const Handle &handle, int16_t &val) const =0
Get param.
virtual ErrorType | setParamI16 (const Handle &handle, int16_t val)=0
Set param.
virtual ErrorType | getParamI16Array (const Handle &handle, int16_t *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamI16Array (const Handle &handle, const int16_t *val, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | getParamI32 (const Handle &handle, int32_t &val) const =0
Get param.
virtual ErrorType | setParamI32 (const Handle &handle, int32_t val)=0
Set param.
virtual ErrorType | getParamI32Array (const Handle &handle, int32_t *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamI32Array (const Handle &handle, const int32_t *val, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | getParamI64 (const Handle &handle, int64_t &val) const =0
Get param.
virtual ErrorType | setParamI64 (const Handle &handle, int64_t val)=0
Set param.
virtual ErrorType | getParamI64Array (const Handle &handle, int64_t *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamI64Array (const Handle &handle, const int64_t *val, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | getParamU8 (const Handle &handle, uint8_t &val) const =0
Get param.
virtual ErrorType | setParamU8 (const Handle &handle, uint8_t val)=0
Set param.
virtual ErrorType | getParamU8Array (const Handle &handle, uint8_t *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamU8Array (const Handle &handle, const uint8_t *val, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | getParamU16 (const Handle &handle, uint16_t &val) const =0
Get param.
virtual ErrorType | setParamU16 (const Handle &handle, uint16_t val)=0
Set param.
virtual ErrorType | getParamU16Array (const Handle &handle, uint16_t *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamU16Array (const Handle &handle, const uint16_t *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | getParamU32 (const Handle &handle, uint32_t &val) const =0
Get param.
virtual ErrorType | setParamU32 (const Handle &handle, uint32_t val)=0
Set param.
virtual ErrorType | getParamU32Array (const Handle &handle, uint32_t *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamU32Array (const Handle &handle, const uint32_t *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | getParamU64 (const Handle &handle, uint64_t &val) const =0
Get param.
virtual ErrorType | setParamU64 (const Handle &handle, uint64_t val)=0
Set param.
virtual ErrorType | getParamU64Array (const Handle &handle, uint64_t *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamU64Array (const Handle &handle, const uint64_t *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | getParamF32 (const Handle &handle, float &val) const =0
Get param.
virtual ErrorType | setParamF32 (const Handle &handle, float val)=0
Set param.
virtual ErrorType | getParamF32Array (const Handle &handle, float *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamF32Array (const Handle &handle, const float *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | getParamF64 (const Handle &handle, double &val) const =0
Get param.
virtual ErrorType | setParamF64 (const Handle &handle, double val)=0
Set param.
virtual ErrorType | getParamF64Array (const Handle &handle, double *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamF64Array (const Handle &handle, const double *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | setParamVec2 (const Handle &handle, const physx::PxVec2 &val)=0
Set param.
virtual ErrorType | getParamVec2 (const Handle &handle, physx::PxVec2 &val) const =0
Get param.
virtual ErrorType | getParamVec2Array (const Handle &handle, physx::PxVec2 *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamVec2Array (const Handle &handle, const physx::PxVec2 *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | setParamVec3 (const Handle &handle, const physx::PxVec3 &val)=0
Set param.
virtual ErrorType | getParamVec3 (const Handle &handle, physx::PxVec3 &val) const =0
Get param.
virtual ErrorType | getParamVec3Array (const Handle &handle, physx::PxVec3 *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamVec3Array (const Handle &handle, const physx::PxVec3 *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | setParamVec4 (const Handle &handle, const physx::PxVec4 &val)=0
Set param.
virtual ErrorType | getParamVec4 (const Handle &handle, physx::PxVec4 &val) const =0
Get param.
virtual ErrorType | getParamVec4Array (const Handle &handle, physx::PxVec4 *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamVec4Array (const Handle &handle, const physx::PxVec4 *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | setParamQuat (const Handle &handle, const physx::PxQuat &val)=0
Set param.
virtual ErrorType | getParamQuat (const Handle &handle, physx::PxQuat &val) const =0
Get param.
virtual ErrorType | getParamQuatArray (const Handle &handle, physx::PxQuat *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamQuatArray (const Handle &handle, const physx::PxQuat *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | setParamMat33 (const Handle &handle, const physx::PxMat33 &val)=0
Set param.
virtual ErrorType | getParamMat33 (const Handle &handle, physx::PxMat33 &val) const =0
Get param.
virtual ErrorType | getParamMat33Array (const Handle &handle, physx::PxMat33 *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamMat33Array (const Handle &handle, const physx::PxMat33 *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | setParamMat44 (const Handle &handle, const physx::PxMat44 &val)=0
Set param.
virtual ErrorType | getParamMat44 (const Handle &handle, physx::PxMat44 &val) const =0
Get param.
virtual ErrorType | getParamMat44Array (const Handle &handle, physx::PxMat44 *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamMat44Array (const Handle &handle, const physx::PxMat44 *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | setParamMat34Legacy (const Handle &handle, const float(&val)[12])=0
Set param.
virtual ErrorType | getParamMat34Legacy (const Handle &handle, float(&val)[12]) const =0
Get param.
virtual ErrorType | getParamMat34LegacyArray (const Handle &handle, float *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamMat34LegacyArray (const Handle &handle, const float *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | setParamBounds3 (const Handle &handle, const physx::PxBounds3 &val)=0
Set param.
virtual ErrorType | getParamBounds3 (const Handle &handle, physx::PxBounds3 &val) const =0
Get param.
virtual ErrorType | getParamBounds3Array (const Handle &handle, physx::PxBounds3 *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamTransform (const Handle &handle, const physx::PxTransform &val)=0
Set param.
virtual ErrorType | getParamTransform (const Handle &handle, physx::PxTransform &val) const =0
Get param.
virtual ErrorType | getParamTransformArray (const Handle &handle, physx::PxTransform *array, int32_t n, int32_t offset=0) const =0
Get param.
virtual ErrorType | setParamTransformArray (const Handle &handle, const physx::PxTransform *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | setParamBounds3Array (const Handle &handle, const physx::PxBounds3 *array, int32_t n, int32_t offset=0)=0
Set param.
virtual ErrorType | valueToStr (const Handle &handle, char *buf, uint32_t bufSize, const char *&ret)=0
Store value of parameter into a string.
virtual ErrorType | strToValue (Handle &handle, const char *str, const char **endptr)=0
Read value of parameter from string.
virtual ErrorType | resizeArray (const Handle &array_handle, int32_t new_size)=0
Resize array parameter.
virtual ErrorType | getArraySize (const Handle &array_handle, int32_t &size, int32_t dimension=0) const =0
Get size of array parameter.
virtual ErrorType | swapArrayElements (const Handle &array_handle, uint32_t firstElement, uint32_t secondElement)=0
Swap two elements of an array.

Friends

class | Handle

Detailed Description

Represents the interface to the NvParameterized object.

Member Function Documentation

virtual bool NvParameterized::Interface::areParamsOK | ( | Handle * | invalidHandles = NULL,
 |  | uint32_t | numInvalidHandles = 0
 | ) |  | [pure virtual]

Checks if object satisfies schema constraints.

Parameters:
[out] | invalidHandles | If the return value is False, these handles will contain the path to invalid data
[in] | numInvalidHandles | The number of handles that can be written to.
Returns:
true if all values satisfy constraints
virtual bool NvParameterized::Interface::checkAlignments ( ) const [pure virtual]

Check that alignments of internal elements match the schema.

Warning:
Only for internal use
virtual const uint32_t* NvParameterized::Interface::checksum ( uint32_t & bits ) const [pure virtual]

Get the class checksum.

Parameters:
bits contains the number of bits contained in the checksum
Returns:
A pointer to a constant array of uint32_t values representing the checksum
virtual ErrorType NvParameterized::Interface::clone ( Interface *& nullDestObject ) const [pure virtual]

Clones an NvParameterized object.

Parameters:
[out] nullDestObject cloned object; note this is a *reference* to a pointer; the destination cloned object will be created and stored in this pointer; should be NULL on entry!
virtual ErrorType NvParameterized::Interface::copy ( const ::NvParameterized::Interface & src ) [pure virtual]

Copies an NvParameterized object.

Parameters:
[in] src the src NvParameterized object will be copied to this object. It must be of the same type (class name).
virtual bool NvParameterized::Interface::equals | ( | const ::NvParameterized::Interface & | obj,
 |  | Handle * | handlesOfInequality = NULL,
 |  | uint32_t | numHandlesOfInequality = 0,
 |  | bool | doCompareNotSerialized = true
 | ) |  | const [pure virtual]

Compares two NvParameterized objects.

Parameters:
[in] | obj | The other NvParameterized::Interface object (this == obj)
[out] | handlesOfInequality | If the return value is False, these handles will contain the path to where definition or data is not identical
[in] | numHandlesOfInequality | The number of handles that can be written to.
[in] | doCompareNotSerialized | If false differences of parameters with DONOTSERIALIZE-hint are ignored.
Returns:
true if parameter definition tree is equal as well as parameter values
virtual ErrorType NvParameterized::Interface::getArraySize | ( | const Handle & | array_handle,
 |  | int32_t & | size,
 |  | int32_t | dimension = 0
 | ) |  | const [protected, pure virtual]

Get size of array parameter.

See also:
Handle::getArraySize
virtual ErrorType NvParameterized::Interface::getParameterHandle | ( | const char * | longName,
 |  | Handle & | handle
 | ) |  | const [pure virtual]

Set the Handle to point to the parameter specified by longName Given a long name like "mystruct.somearray[10].foo", it will return a handle to that specific parameter. The handle can then be used to set/get values, as long as it's a handle to a leaf node.

Note:
this method will not work if an included reference's child is included in the longName
virtual ErrorType NvParameterized::Interface::getParameterHandle | ( | const char * | longName,
 |  | Handle & | handle
 | ) |  | [pure virtual]

Set the Handle to point to the parameter specified by longName Given a long name like "mystruct.somearray[10].foo", it will return a handle to that specific parameter. The handle can then be used to set/get values, as long as it's a handle to a leaf node.

Note:
this method will not work if an included reference's child is included in the longName
virtual ErrorType NvParameterized::Interface::initParamRef | ( | const Handle & | handle,
 |  | const char * | chosenRefStr = 0,
 |  | bool | doDestroyOld = false
 | ) |  | [protected, pure virtual]

Initialize a Reference parameter.

Note:
By default previous value of parameter isn't destroyed (bool doDestroyOld = false)
virtual ErrorType NvParameterized::Interface::resizeArray | ( | const Handle & | array_handle,
 |  | int32_t | new_size
 | ) |  | [protected, pure virtual]

Resize array parameter.

See also:
Handle::resizeArray
virtual void NvParameterized::Interface::setClassName ( const char * name ) [pure virtual]

Sets the class name.

This method is used for named references. The input name should be one of the possible variants.

See also:
Definition::numRefVariants(), Definition::refVariantVal()
virtual ErrorType NvParameterized::Interface::setParamRef | ( | const Handle & | handle,
 |  | ::NvParameterized::Interface * | val,
 |  | bool | doDestroyOld = false
 | ) |  | [protected, pure virtual]
Note:
By default previous value of parameter is not destroyed (bool doDestroyOld = false)
virtual ErrorType NvParameterized::Interface::setParamRefArray | ( | const Handle & | handle,
 |  | ::NvParameterized::Interface ** | array,
 |  | int32_t | n,
 |  | int32_t | offset = 0,
 |  | bool | doDestroyOld = false
 | ) |  | [protected, pure virtual]
Note:
By default previous values of parameter are not destroyed (bool doDestroyOld = false)
virtual ErrorType NvParameterized::Interface::strToValue | ( | Handle & | handle,
 |  | const char * | str,
 |  | const char ** | endptr
 | ) |  | [protected, pure virtual]

Read value of parameter from string.

See also:
Handle::strToValue
virtual ErrorType NvParameterized::Interface::swapArrayElements | ( | const Handle & | array_handle,
 |  | uint32_t | firstElement,
 |  | uint32_t | secondElement
 | ) |  | [protected, pure virtual]

Swap two elements of an array.

See also:
Handle::swapArrayElements
virtual ErrorType NvParameterized::Interface::valueToStr | ( | const Handle & | handle,
 |  | char * | buf,
 |  | uint32_t | bufSize,
 |  | const char *& | ret
 | ) |  | [protected, pure virtual]

Store value of parameter into a string.

See also:
Handle::valueToStr
The documentation for this class was generated from the following file:
  • NvParameterized.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Interface
NvParameterized::Interface Member List
This is the complete list of members for NvParameterized::Interface, including all inherited members.
areParamsOK(Handle *invalidHandles=NULL, uint32_t numInvalidHandles=0)=0 | NvParameterized::Interface | [pure virtual]
callPreSerializeCallback() const =0 | NvParameterized::Interface | [pure virtual]
checkAlignments() const =0 | NvParameterized::Interface | [pure virtual]
checksum(uint32_t &bits) const =0 | NvParameterized::Interface | [pure virtual]
className(void) const =0 | NvParameterized::Interface | [pure virtual]
clone(Interface *&nullDestObject) const =0 | NvParameterized::Interface | [pure virtual]
copy(const ::NvParameterized::Interface &src)=0 | NvParameterized::Interface | [pure virtual]
destroy()=0 | NvParameterized::Interface | [pure virtual]
equals(const ::NvParameterized::Interface &obj, Handle *handlesOfInequality=NULL, uint32_t numHandlesOfInequality=0, bool doCompareNotSerialized=true) const =0 | NvParameterized::Interface | [pure virtual]
getArraySize(const Handle &array_handle, int32_t &size, int32_t dimension=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getMajorVersion(void) const =0 | NvParameterized::Interface | [pure virtual]
getMinorVersion(void) const =0 | NvParameterized::Interface | [pure virtual]
getParamBool(const Handle &handle, bool &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamBoolArray(const Handle &handle, bool *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamBounds3(const Handle &handle, physx::PxBounds3 &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamBounds3Array(const Handle &handle, physx::PxBounds3 *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamEnum(const Handle &handle, const char *&val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamEnumArray(const Handle &handle, char **array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParameterHandle(const char *longName, Handle &handle) const =0 | NvParameterized::Interface | [pure virtual]
getParameterHandle(const char *longName, Handle &handle)=0 | NvParameterized::Interface | [pure virtual]
getParamF32(const Handle &handle, float &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamF32Array(const Handle &handle, float *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamF64(const Handle &handle, double &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamF64Array(const Handle &handle, double *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamI16(const Handle &handle, int16_t &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamI16Array(const Handle &handle, int16_t *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamI32(const Handle &handle, int32_t &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamI32Array(const Handle &handle, int32_t *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamI64(const Handle &handle, int64_t &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamI64Array(const Handle &handle, int64_t *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamI8(const Handle &handle, int8_t &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamI8Array(const Handle &handle, int8_t *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamMat33(const Handle &handle, physx::PxMat33 &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamMat33Array(const Handle &handle, physx::PxMat33 *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamMat34Legacy(const Handle &handle, float(&val)[12]) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamMat34LegacyArray(const Handle &handle, float *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamMat44(const Handle &handle, physx::PxMat44 &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamMat44Array(const Handle &handle, physx::PxMat44 *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamQuat(const Handle &handle, physx::PxQuat &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamQuatArray(const Handle &handle, physx::PxQuat *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamRef(const Handle &handle,::NvParameterized::Interface *&val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamRefArray(const Handle &handle,::NvParameterized::Interface **array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamString(const Handle &handle, const char *&val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamStringArray(const Handle &handle, char **array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamTransform(const Handle &handle, physx::PxTransform &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamTransformArray(const Handle &handle, physx::PxTransform *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamU16(const Handle &handle, uint16_t &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamU16Array(const Handle &handle, uint16_t *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamU32(const Handle &handle, uint32_t &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamU32Array(const Handle &handle, uint32_t *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamU64(const Handle &handle, uint64_t &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamU64Array(const Handle &handle, uint64_t *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamU8(const Handle &handle, uint8_t &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamU8Array(const Handle &handle, uint8_t *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamVec2(const Handle &handle, physx::PxVec2 &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamVec2Array(const Handle &handle, physx::PxVec2 *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamVec3(const Handle &handle, physx::PxVec3 &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamVec3Array(const Handle &handle, physx::PxVec3 *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamVec4(const Handle &handle, physx::PxVec4 &val) const =0 | NvParameterized::Interface | [protected, pure virtual]
getParamVec4Array(const Handle &handle, physx::PxVec4 *array, int32_t n, int32_t offset=0) const =0 | NvParameterized::Interface | [protected, pure virtual]
Handle (defined in NvParameterized::Interface) | NvParameterized::Interface | [friend]
initDefaults(void)=0 | NvParameterized::Interface | [pure virtual]
initParamRef(const Handle &handle, const char *chosenRefStr=0, bool doDestroyOld=false)=0 | NvParameterized::Interface | [protected, pure virtual]
initRandom(void)=0 | NvParameterized::Interface | [pure virtual]
name(void) const =0 | NvParameterized::Interface | [pure virtual]
numParameters(void)=0 | NvParameterized::Interface | [pure virtual]
parameterDefinition(int32_t index)=0 | NvParameterized::Interface | [pure virtual]
resizeArray(const Handle &array_handle, int32_t new_size)=0 | NvParameterized::Interface | [protected, pure virtual]
rootParameterDefinition(void)=0 | NvParameterized::Interface | [pure virtual]
rootParameterDefinition(void) const =0 | NvParameterized::Interface | [pure virtual]
setClassName(const char *name)=0 | NvParameterized::Interface | [pure virtual]
setName(const char *name)=0 | NvParameterized::Interface | [pure virtual]
setParamBool(const Handle &handle, bool val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamBoolArray(const Handle &handle, const bool *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamBounds3(const Handle &handle, const physx::PxBounds3 &val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamBounds3Array(const Handle &handle, const physx::PxBounds3 *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamEnum(const Handle &handle, const char *val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamEnumArray(const Handle &handle, const char **array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamF32(const Handle &handle, float val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamF32Array(const Handle &handle, const float *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamF64(const Handle &handle, double val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamF64Array(const Handle &handle, const double *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamI16(const Handle &handle, int16_t val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamI16Array(const Handle &handle, const int16_t *val, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamI32(const Handle &handle, int32_t val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamI32Array(const Handle &handle, const int32_t *val, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamI64(const Handle &handle, int64_t val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamI64Array(const Handle &handle, const int64_t *val, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamI8(const Handle &handle, int8_t val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamI8Array(const Handle &handle, const int8_t *val, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamMat33(const Handle &handle, const physx::PxMat33 &val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamMat33Array(const Handle &handle, const physx::PxMat33 *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamMat34Legacy(const Handle &handle, const float(&val)[12])=0 | NvParameterized::Interface | [protected, pure virtual]
setParamMat34LegacyArray(const Handle &handle, const float *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamMat44(const Handle &handle, const physx::PxMat44 &val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamMat44Array(const Handle &handle, const physx::PxMat44 *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamQuat(const Handle &handle, const physx::PxQuat &val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamQuatArray(const Handle &handle, const physx::PxQuat *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamRef(const Handle &handle,::NvParameterized::Interface *val, bool doDestroyOld=false)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamRefArray(const Handle &handle,::NvParameterized::Interface **array, int32_t n, int32_t offset=0, bool doDestroyOld=false)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamString(const Handle &handle, const char *val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamStringArray(const Handle &handle, const char **array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamTransform(const Handle &handle, const physx::PxTransform &val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamTransformArray(const Handle &handle, const physx::PxTransform *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamU16(const Handle &handle, uint16_t val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamU16Array(const Handle &handle, const uint16_t *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamU32(const Handle &handle, uint32_t val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamU32Array(const Handle &handle, const uint32_t *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamU64(const Handle &handle, uint64_t val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamU64Array(const Handle &handle, const uint64_t *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamU8(const Handle &handle, uint8_t val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamU8Array(const Handle &handle, const uint8_t *val, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamVec2(const Handle &handle, const physx::PxVec2 &val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamVec2Array(const Handle &handle, const physx::PxVec2 *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamVec3(const Handle &handle, const physx::PxVec3 &val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamVec3Array(const Handle &handle, const physx::PxVec3 *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamVec4(const Handle &handle, const physx::PxVec4 &val)=0 | NvParameterized::Interface | [protected, pure virtual]
setParamVec4Array(const Handle &handle, const physx::PxVec4 *array, int32_t n, int32_t offset=0)=0 | NvParameterized::Interface | [protected, pure virtual]
setSerializationCallback(SerializationCallback *cb, void *userData=NULL)=0 | NvParameterized::Interface | [pure virtual]
strToValue(Handle &handle, const char *str, const char **endptr)=0 | NvParameterized::Interface | [protected, pure virtual]
swapArrayElements(const Handle &array_handle, uint32_t firstElement, uint32_t secondElement)=0 | NvParameterized::Interface | [protected, pure virtual]
valueToStr(const Handle &handle, char *buf, uint32_t bufSize, const char *&ret)=0 | NvParameterized::Interface | [protected, pure virtual]
version(void) const =0 | NvParameterized::Interface | [pure virtual]
~Interface() | NvParameterized::Interface | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::NamedReferenceInterface Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • NamedReferenceInterface
Public Member Functions
NvParameterized::NamedReferenceInterface Class Reference

Callback container for getNamedReferences. More...

#include <NvParamUtils.h>

List of all members.

Public Member Functions

virtual | ~NamedReferenceInterface ()
Destructor.
virtual const char * | namedReferenceCallback (const char *className, const char *namedReference, Handle &handle)=0
Callback.

Detailed Description

Callback container for getNamedReferences.

Member Function Documentation

virtual const char* NvParameterized::NamedReferenceInterface::namedReferenceCallback | ( | const char * | className,
 |  | const char * | namedReference,
 |  | Handle & | handle
 | ) |  | [pure virtual]

Callback.

Calls back to the user with any named reference (not included references) in the NvParameterized::Interface If the user returns a NULL pointer, than the original named reference is left alone. If the user returns a non-NULL pointer, than the named reference is replaced with the 'const char *' returned.

The documentation for this class was generated from the following file:
  • NvParamUtils.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • NamedReferenceInterface
NvParameterized::NamedReferenceInterface Member List
This is the complete list of members for NvParameterized::NamedReferenceInterface, including all inherited members.
namedReferenceCallback(const char *className, const char *namedReference, Handle &handle)=0 | NvParameterized::NamedReferenceInterface | [pure virtual]
~NamedReferenceInterface() | NvParameterized::NamedReferenceInterface | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::ReferenceInterface Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • ReferenceInterface
Public Member Functions
NvParameterized::ReferenceInterface Class Reference

Callback container for getReferences. More...

#include <NvParamUtils.h>

Inheritance diagram for NvParameterized::ReferenceInterface:
NvParameterized::WrappedNamedReference

List of all members.

Public Member Functions

virtual | ~ReferenceInterface ()
Destructor.
virtual void | referenceCallback (Handle &handle)=0
Callback.

Detailed Description

Callback container for getReferences.

Member Function Documentation

virtual void NvParameterized::ReferenceInterface::referenceCallback ( Handle & handle ) [pure virtual]

Callback.

Calls back to the user with any reference (named or included or both) in the NvParameterized::Interface.

Implemented in NvParameterized::WrappedNamedReference.

The documentation for this class was generated from the following file:
  • NvParamUtils.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • ReferenceInterface
NvParameterized::ReferenceInterface Member List
This is the complete list of members for NvParameterized::ReferenceInterface, including all inherited members.
referenceCallback(Handle &handle)=0 | NvParameterized::ReferenceInterface | [pure virtual]
~ReferenceInterface() | NvParameterized::ReferenceInterface | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::SerializationCallback Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • SerializationCallback
Public Member Functions
NvParameterized::SerializationCallback Class Reference

A callback class for notification just prior to serialization. More...

#include <NvParameterized.h>

List of all members.

Public Member Functions

virtual void preSerialize (void *userData=NULL)=0
Callback method.

Detailed Description

A callback class for notification just prior to serialization.

The documentation for this class was generated from the following file:
  • NvParameterized.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • SerializationCallback
NvParameterized::SerializationCallback Member List
This is the complete list of members for NvParameterized::SerializationCallback, including all inherited members.
preSerialize(void *userData=NULL)=0 | NvParameterized::SerializationCallback | [pure virtual]
~SerializationCallback() (defined in NvParameterized::SerializationCallback) | NvParameterized::SerializationCallback | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::Serializer Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Serializer
Classes | Public Types | Public Member Functions | Static Public Member Functions
NvParameterized::Serializer Class Reference

Interface class for serializer-deserializer of NvParameterized objects. More...

#include <NvSerializer.h>

List of all members.

Classes

class | DeserializedResults
TODO. More...
struct | MetadataEntry
This class keeps metadata of a single NvParameterized class. More...

Public Types

enum ErrorType {
ERROR_NONE = 0,
ERROR_UNKNOWN,
ERROR_NOT_IMPLEMENTED,
ERROR_INVALID_PLATFORM,
ERROR_INVALID_PLATFORM_NAME,
ERROR_INVALID_FILE_VERSION,
ERROR_INVALID_FILE_FORMAT,
ERROR_INVALID_MAGIC,
ERROR_INVALID_CHAR,
ERROR_STREAM_ERROR,
ERROR_MEMORY_ALLOCATION_FAILURE,
ERROR_UNALIGNED_MEMORY,
ERROR_PRESERIALIZE_FAILED,
ERROR_INTERNAL_BUFFER_OVERFLOW,
ERROR_OBJECT_CREATION_FAILED,
ERROR_CONVERSION_FAILED,
ERROR_VAL2STRING_FAILED,
ERROR_STRING2VAL_FAILED,
ERROR_INVALID_TYPE_ATTRIBUTE,
ERROR_UNKNOWN_XML_TAG,
ERROR_MISSING_DOCTYPE,
ERROR_MISSING_ROOT_ELEMENT,
ERROR_INVALID_NESTING,
ERROR_INVALID_ATTR,
ERROR_INVALID_ARRAY,
ERROR_ARRAY_INDEX_OUT_OF_RANGE,
ERROR_INVALID_VALUE,
ERROR_INVALID_INTERNAL_PTR,
ERROR_INVALID_PARAM_HANDLE,
ERROR_INVALID_RELOC_TYPE,
ERROR_INVALID_DATA_TYPE,
ERROR_INVALID_REFERENCE
}
Status enums that the Serializer methods may return.
enum SerializeType {
NST_XML = 0,
NST_BINARY,
NST_LAST
}
The supported serialization formats. More...
typedef DeserializedResults
< ::NvParameterized::Interface * > 		DeserializedData
Container for results of deserialization.
typedef DeserializedResults
< MetadataEntry > 		DeserializedMetadata
Container for results of metadata deserialization.

Public Member Functions

virtual ErrorType | setTargetPlatform (const SerializePlatform &platform)=0
Set platform to use in platform-dependent serialization.
virtual void | setAutoUpdate (bool doUpdate)=0
Sets whether serializer will automatically update objects after deserialization.
virtual ErrorType | serialize (physx::general_PxIOStream2::PxFileBuf &stream, const ::NvParameterized::Interface **objs, uint32_t nobjs, bool doSerializeMetadata=false)=0
Serialize array of NvParameterized-objects to a stream.
virtual ErrorType | peekNumObjects (physx::general_PxIOStream2::PxFileBuf &stream, uint32_t &numObjects)=0
Peek number of NvParameterized-objects in stream with serialized data.
virtual ErrorType | peekClassNames (physx::general_PxIOStream2::PxFileBuf &stream, char **classNames, uint32_t &numClassNames)=0
Peek number of NvParameterized-objects in stream with serialized data.
virtual ErrorType | peekNumObjectsInplace (const void *data, uint32_t dataLen, uint32_t &numObjects)=0
Peek number of NvParameterized-objects in memory buffer with serialized data.
virtual ErrorType | deserializeMetadata (physx::general_PxIOStream2::PxFileBuf &stream, DeserializedMetadata &desData)
Deserialize metadata from a stream into one or more definitions.
virtual ErrorType | deserialize (physx::general_PxIOStream2::PxFileBuf &stream, DeserializedData &desData)
Deserialize a stream into one or more NvParameterized objects.
virtual ErrorType | deserialize (physx::general_PxIOStream2::PxFileBuf &stream, DeserializedData &desData, bool &isUpdated)=0
Deserialize a stream into one or more NvParameterized objects.
virtual ErrorType | deserializeInplace (void *data, uint32_t dataLen, DeserializedData &desData)
Deserialize memory buffer into one or more NvParameterized objects.
virtual ErrorType | deserializeInplace (void *data, uint32_t dataLen, DeserializedData &desData, bool &isUpdated)=0
Deserialize memory buffer into one or more NvParameterized objects.
virtual ErrorType | peekInplaceAlignment (physx::general_PxIOStream2::PxFileBuf &stream, uint32_t &align)=0
Get minimum alignment required for inplace deserialization of data in stream.
virtual void | release ()=0
Release deserializer and any memory allocations associated with it.

Static Public Member Functions

static SerializeType | peekSerializeType (physx::general_PxIOStream2::PxFileBuf &stream)
Get type of stream (binary or xml)
static ErrorType | peekPlatform (physx::general_PxIOStream2::PxFileBuf &stream, SerializePlatform &platform)
Get stream native platform.

Detailed Description

Interface class for serializer-deserializer of NvParameterized objects.

Serializer serializes and deserializes one or more NvParameterized objects to file using various output formats (see SerializeType).

Member Typedef Documentation

typedef DeserializedResults< ::NvParameterized::Interface *> NvParameterized::Serializer::DeserializedData

Container for results of deserialization.

DeserializedData holds array of NvParameterized objects obtained during deserialization.

typedef DeserializedResults<MetadataEntry> NvParameterized::Serializer::DeserializedMetadata

Container for results of metadata deserialization.

DeserializedMetadata holds array of MetadataEntry obtained during metadata deserialization.

Member Enumeration Documentation

enum NvParameterized::Serializer::SerializeType

The supported serialization formats.

Enumerator:
NST_XML

serialize in XML format.

NST_BINARY

serialize in a binary format

Member Function Documentation

virtual ErrorType NvParameterized::Serializer::deserialize | ( | physx::general_PxIOStream2::PxFileBuf & | stream,
 |  | DeserializedData & | desData
 | ) |  | [virtual]

Deserialize a stream into one or more NvParameterized objects.

Parameters:
[in] | stream | the stream from which objects will be deserialized
[out] | desData | storage for deserialized data
virtual ErrorType NvParameterized::Serializer::deserialize | ( | physx::general_PxIOStream2::PxFileBuf & | stream,
 |  | DeserializedData & | desData,
 |  | bool & | isUpdated
 | ) |  | [pure virtual]

Deserialize a stream into one or more NvParameterized objects.

Parameters:
[in] | stream | the stream from which objects will be deserialized
[out] | desData | storage for deserialized data
[out] | isUpdated | true if any legacy object was updated, false otherwise
virtual ErrorType NvParameterized::Serializer::deserializeInplace | ( | void * | data,
 |  | uint32_t | dataLen,
 |  | DeserializedData & | desData
 | ) |  | [virtual]

Deserialize memory buffer into one or more NvParameterized objects.

Parameters:
[in] | data | pointer to serialized data. It should be allocated via Traits.
[in] | dataLen | length of serialized data
[out] | desData | storage for deserialized data
Warning:
Currently only binary serializer supports inplace deserialization
Memory must be aligned to 8 byte boundary
virtual ErrorType NvParameterized::Serializer::deserializeInplace | ( | void * | data,
 |  | uint32_t | dataLen,
 |  | DeserializedData & | desData,
 |  | bool & | isUpdated
 | ) |  | [pure virtual]

Deserialize memory buffer into one or more NvParameterized objects.

Parameters:
[in] | data | pointer to serialized data
[in] | dataLen | length of serialized data
[out] | desData | storage for deserialized data
[out] | isUpdated | true if any legacy object was updated, false otherwise
Warning:
Currently only binary serializer supports inplace deserialization
Memory must be aligned to the boundary required by the data (see getInplaceAlignment)
virtual ErrorType NvParameterized::Serializer::deserializeMetadata | ( | physx::general_PxIOStream2::PxFileBuf & | stream,
 |  | DeserializedMetadata & | desData
 | ) |  | [virtual]

Deserialize metadata from a stream into one or more definitions.

Parameters:
[in] | stream | the stream from which metadata will be deserialized
[out] | desData | storage for deserialized metadata
Warning:
This is a draft implementation!
virtual ErrorType NvParameterized::Serializer::peekClassNames | ( | physx::general_PxIOStream2::PxFileBuf & | stream,
 |  | char ** | classNames,
 |  | uint32_t & | numClassNames
 | ) |  | [pure virtual]

Peek number of NvParameterized-objects in stream with serialized data.

Parameters:
[in] | stream | the stream from which objects will be deserialized
[in] | classNames | pointer to buffer for resulting names
[in,out] | numClassNames | limit on number of returned classNames; number of returned names
Warning:
User is responsible for releasing every element of classNames via Traits::strfree()
virtual ErrorType NvParameterized::Serializer::peekInplaceAlignment | ( | physx::general_PxIOStream2::PxFileBuf & | stream,
 |  | uint32_t & | align
 | ) |  | [pure virtual]

Get minimum alignment required for inplace deserialization of data in stream.

Parameters:
[in] | stream | stream which will be inplace deserialized
[out] | align | alignment required for inplace deserialization of stream
Note:
For most of the objects this will return default alignment of 8 bytes
virtual ErrorType NvParameterized::Serializer::peekNumObjects | ( | physx::general_PxIOStream2::PxFileBuf & | stream,
 |  | uint32_t & | numObjects
 | ) |  | [pure virtual]

Peek number of NvParameterized-objects in stream with serialized data.

Parameters:
[in] | stream | the stream from which the object will be deserialized
[out] | numObjects | number of objects
Warning:
Not all streams support peeking
virtual ErrorType NvParameterized::Serializer::peekNumObjectsInplace | ( | const void * | data,
 |  | uint32_t | dataLen,
 |  | uint32_t & | numObjects
 | ) |  | [pure virtual]

Peek number of NvParameterized-objects in memory buffer with serialized data.

Parameters:
[in] | data | pointer to memory buffer
[in] | dataLen | length of memory buffer
[out] | numObjects | number of objects
static ErrorType NvParameterized::Serializer::peekPlatform | ( | physx::general_PxIOStream2::PxFileBuf & | stream,
 |  | SerializePlatform & | platform
 | ) |  | [static]

Get stream native platform.

Parameters:
[in] | stream | stream to be analyzed
[out] | platform | stream native platform
static SerializeType NvParameterized::Serializer::peekSerializeType ( physx::general_PxIOStream2::PxFileBuf & stream ) [static]

Get type of stream (binary or xml)

Parameters:
[in] stream stream to be analyzed
virtual ErrorType NvParameterized::Serializer::serialize | ( | physx::general_PxIOStream2::PxFileBuf & | stream,
 |  | const ::NvParameterized::Interface ** | objs,
 |  | uint32_t | nobjs,
 |  | bool | doSerializeMetadata = false
 | ) |  | [pure virtual]

Serialize array of NvParameterized-objects to a stream.

Parameters:
[in] | stream | the stream to which the object will be serialized
[in] | objs | NvParameterized-objects which will be serialized
[in] | nobjs | number of objects
[in] | doSerializeMetadata | set this to store object metadata in file
Warning:
Serialized file may depend on selected target platform
virtual void NvParameterized::Serializer::setAutoUpdate ( bool doUpdate ) [pure virtual]

Sets whether serializer will automatically update objects after deserialization.

Parameters:
[in] doUpdate should automatic update be done?
Warning:
Normally you will not need this
This is true by default
virtual ErrorType NvParameterized::Serializer::setTargetPlatform ( const SerializePlatform & platform ) [pure virtual]

Set platform to use in platform-dependent serialization.

Parameters:
[in] platform target platform
Warning:
Currently this is used only in binary serializer

Application running on target platforms may potentially make use of extremely fast inplace deserialization (using method deserializeInplace) on files which were serialized for this platform.

The documentation for this class was generated from the following file:
  • NvSerializer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Serializer
NvParameterized::Serializer Member List
This is the complete list of members for NvParameterized::Serializer, including all inherited members.
deserialize(physx::general_PxIOStream2::PxFileBuf &stream, DeserializedData &desData) | NvParameterized::Serializer | [virtual]
deserialize(physx::general_PxIOStream2::PxFileBuf &stream, DeserializedData &desData, bool &isUpdated)=0 | NvParameterized::Serializer | [pure virtual]
DeserializedData typedef | NvParameterized::Serializer |
DeserializedMetadata typedef | NvParameterized::Serializer |
deserializeInplace(void *data, uint32_t dataLen, DeserializedData &desData) | NvParameterized::Serializer | [virtual]
deserializeInplace(void *data, uint32_t dataLen, DeserializedData &desData, bool &isUpdated)=0 | NvParameterized::Serializer | [pure virtual]
deserializeMetadata(physx::general_PxIOStream2::PxFileBuf &stream, DeserializedMetadata &desData) | NvParameterized::Serializer | [virtual]
ERROR_ARRAY_INDEX_OUT_OF_RANGE enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_CONVERSION_FAILED enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INTERNAL_BUFFER_OVERFLOW enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_ARRAY enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_ATTR enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_CHAR enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_DATA_TYPE enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_FILE_FORMAT enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_FILE_VERSION enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_INTERNAL_PTR enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_MAGIC enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_NESTING enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_PARAM_HANDLE enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_PLATFORM enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_PLATFORM_NAME enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_REFERENCE enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_RELOC_TYPE enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_TYPE_ATTRIBUTE enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_INVALID_VALUE enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_MEMORY_ALLOCATION_FAILURE enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_MISSING_DOCTYPE enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_MISSING_ROOT_ELEMENT enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_NONE enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_NOT_IMPLEMENTED enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_OBJECT_CREATION_FAILED enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_PRESERIALIZE_FAILED enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_STREAM_ERROR enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_STRING2VAL_FAILED enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_UNALIGNED_MEMORY enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_UNKNOWN enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_UNKNOWN_XML_TAG enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ERROR_VAL2STRING_FAILED enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
ErrorType enum name | NvParameterized::Serializer |
NST_BINARY enum value | NvParameterized::Serializer |
NST_LAST enum value (defined in NvParameterized::Serializer) | NvParameterized::Serializer |
NST_XML enum value | NvParameterized::Serializer |
peekClassNames(physx::general_PxIOStream2::PxFileBuf &stream, char **classNames, uint32_t &numClassNames)=0 | NvParameterized::Serializer | [pure virtual]
peekInplaceAlignment(physx::general_PxIOStream2::PxFileBuf &stream, uint32_t &align)=0 | NvParameterized::Serializer | [pure virtual]
peekNumObjects(physx::general_PxIOStream2::PxFileBuf &stream, uint32_t &numObjects)=0 | NvParameterized::Serializer | [pure virtual]
peekNumObjectsInplace(const void *data, uint32_t dataLen, uint32_t &numObjects)=0 | NvParameterized::Serializer | [pure virtual]
peekPlatform(physx::general_PxIOStream2::PxFileBuf &stream, SerializePlatform &platform) | NvParameterized::Serializer | [static]
peekSerializeType(physx::general_PxIOStream2::PxFileBuf &stream) | NvParameterized::Serializer | [static]
release()=0 | NvParameterized::Serializer | [pure virtual]
serialize(physx::general_PxIOStream2::PxFileBuf &stream, const ::NvParameterized::Interface **objs, uint32_t nobjs, bool doSerializeMetadata=false)=0 | NvParameterized::Serializer | [pure virtual]
SerializeType enum name | NvParameterized::Serializer |
setAutoUpdate(bool doUpdate)=0 | NvParameterized::Serializer | [pure virtual]
setTargetPlatform(const SerializePlatform &platform)=0 | NvParameterized::Serializer | [pure virtual]
~Serializer() (defined in NvParameterized::Serializer) | NvParameterized::Serializer | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::Serializer::DeserializedResults< T, bufSize > Class Template Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Serializer
  • DeserializedResults
Public Member Functions
NvParameterized::Serializer::DeserializedResults< T, bufSize > Class Template Reference

TODO. More...

#include <NvSerializer.h>

List of all members.

Public Member Functions

PX_INLINE | DeserializedResults (const DeserializedResults &data)
Copy constructor.
PX_INLINE DeserializedResults & | operator= (const DeserializedResults &rhs)
Assignment operator.
PX_INLINE void | init (Traits *traits_, uint32_t nobjs_)
Allocate memory for values.
PX_INLINE void | init (Traits *traits_, T *objs_, uint32_t nobjs_)
Allocate memory and set values.
PX_INLINE uint32_t | size () const
Number of objects in a container.
PX_INLINE T & | operator[] (uint32_t i)
Access individual object in container.
PX_INLINE const T & | operator[] (uint32_t i) const
Const-access individual object in container.
PX_INLINE void | getObjects (T *outObjs)
Read all NvParameterized objects in container to buffer outObjs.
PX_INLINE void | releaseAll ()
Release all objects.

Detailed Description

template<typename T, int bufSize = 8>
class NvParameterized::Serializer::DeserializedResults< T, bufSize >

TODO.

Member Function Documentation

template<typename T , int bufSize>
PX_INLINE void NvParameterized::Serializer::DeserializedResults< T, bufSize >::getObjects ( T * outObjs )

Read all NvParameterized objects in container to buffer outObjs.

Warning:
outObjs must be large enough to hold all contained objects
The documentation for this class was generated from the following files:
  • NvSerializer.h
  • NvSerializer.inl
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Serializer
  • DeserializedResults
NvParameterized::Serializer::DeserializedResults< T, bufSize > Member List
This is the complete list of members for NvParameterized::Serializer::DeserializedResults< T, bufSize >, including all inherited members.
DeserializedResults() (defined in NvParameterized::Serializer::DeserializedResults< T, bufSize >) | NvParameterized::Serializer::DeserializedResults< T, bufSize >
DeserializedResults(const DeserializedResults &data) | NvParameterized::Serializer::DeserializedResults< T, bufSize >
getObjects(T *outObjs) | NvParameterized::Serializer::DeserializedResults< T, bufSize >
init(Traits *traits_, uint32_t nobjs_) | NvParameterized::Serializer::DeserializedResults< T, bufSize >
init(Traits *traits_, T *objs_, uint32_t nobjs_) | NvParameterized::Serializer::DeserializedResults< T, bufSize >
operator=(const DeserializedResults &rhs) | NvParameterized::Serializer::DeserializedResults< T, bufSize >
operator[](uint32_t i) | NvParameterized::Serializer::DeserializedResults< T, bufSize >
operator[](uint32_t i) const | NvParameterized::Serializer::DeserializedResults< T, bufSize >
releaseAll() | NvParameterized::Serializer::DeserializedResults< T, bufSize >
size() const | NvParameterized::Serializer::DeserializedResults< T, bufSize >
~DeserializedResults() (defined in NvParameterized::Serializer::DeserializedResults< T, bufSize >) | NvParameterized::Serializer::DeserializedResults< T, bufSize >
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::Traits Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Traits
Classes | Public Member Functions
NvParameterized::Traits Class Reference

Interface class for user traits. More...

#include <NvParameterizedTraits.h>

List of all members.

Classes

class | Allocator
Adapter for allocator classes in PxAlloctor.h. More...

Public Member Functions

virtual void | registerFactory (::NvParameterized::Factory &factory)=0
Register NvParameterized class factory.
virtual
::NvParameterized::Factory * 		removeFactory (const char *className)=0
Remove NvParameterized class factory for current version of class.
virtual
::NvParameterized::Factory * 		removeFactory (const char *className, uint32_t version)=0
Remove NvParameterized class factory for given version of class.
virtual bool | doesFactoryExist (const char *className)=0
Checks whether any class factory is registered.
virtual bool | doesFactoryExist (const char *className, uint32_t version)=0
Checks whether class factory for given version is registered.
virtual
::NvParameterized::Interface * 		createNvParameterized (const char *name)=0
Create object of NvParameterized class using its staticClassName()
virtual
::NvParameterized::Interface * 		createNvParameterized (const char *name, uint32_t ver)=0
Create object of NvParameterized class using its staticClassName()
virtual
::NvParameterized::Interface * 		finishNvParameterized (const char *name, void *obj, void *buf, int32_t *refCount)=0
Finish construction of inplace object of NvParameterized class.
virtual
::NvParameterized::Interface * 		finishNvParameterized (const char *name, uint32_t ver, void *obj, void *buf, int32_t *refCount)=0
Finish construction of inplace object of NvParameterized class.
virtual uint32_t | getCurrentVersion (const char *className) const =0
Get version of class which is currently used.
virtual uint32_t | getAlignment (const char *className, uint32_t classVersion) const =0
Get memory alignment required for objects of class.
virtual void | registerConversion (const char *, uint32_t, uint32_t, Conversion &)
Register converter for legacy version of class.
virtual
::NvParameterized::Conversion * 		removeConversion (const char *, uint32_t, uint32_t)
Remove converter for legacy version of class.
virtual bool | updateLegacyNvParameterized (::NvParameterized::Interface &legacyObj,::NvParameterized::Interface &obj)
Update legacy object (most probably using appropriate registered converter)
virtual bool | getNvParameterizedNames (const char **names, uint32_t &outCount, uint32_t inCount) const =0
Get a list of the NvParameterized class type names.
virtual bool | getNvParameterizedVersions (const char *className, uint32_t *versions, uint32_t &outCount, uint32_t inCount) const =0
Get a list of versions of particular NvParameterized class.
virtual int32_t | incRefCount (int32_t *refCount)=0
Increment reference counter.
virtual int32_t | decRefCount (int32_t *refCount)=0
Decrement reference counter.
virtual void | onInplaceObjectDestroyed (void *,::NvParameterized::Interface *)
Called when inplace object is destroyed.
virtual void | onAllInplaceObjectsDestroyed (void *buf)
Called when all inplace objects are destroyed.
virtual void * | alloc (uint32_t nbytes)=0
Allocate memory with default alignment of 8.
virtual void * | alloc (uint32_t nbytes, uint32_t align)=0
Allocate aligned memory.
virtual void | free (void *buf)=0
Deallocate memory.
virtual char * | strdup (const char *str)
Copy string.
virtual void | strfree (char *str)
Release copied string.
virtual void | traitsWarn (const char *) const
Warns user.
virtual void | release (void)=0
Release Traits.

Detailed Description

Interface class for user traits.

This class is a collection of loosely-related functions provided by application or framework and used by NvParameterized library to do memory allocation, object creation, user notification, etc.

Member Function Documentation

virtual ::NvParameterized::Interface* NvParameterized::Traits::createNvParameterized ( const char * name ) [pure virtual]

Create object of NvParameterized class using its staticClassName()

Parameters:
[in] name static class name of the instance to create

Most probably this just calls Factory::create on appropriate factory.

virtual ::NvParameterized::Interface* NvParameterized::Traits::createNvParameterized | ( | const char * | name,
 |  | uint32_t | ver
 | ) |  | [pure virtual]

Create object of NvParameterized class using its staticClassName()

Parameters:
[in] | name | static class name of the instance to create
[in] | ver | version of the class

Most probably this just calls Factory::create on appropriate factory.

virtual ::NvParameterized::Interface* NvParameterized::Traits::finishNvParameterized | ( | const char * | name,
 |  | void * | obj,
 |  | void * | buf,
 |  | int32_t * | refCount
 | ) |  | [pure virtual]

Finish construction of inplace object of NvParameterized class.

Most probably this just calls Factory::finish using appropriate factory.

virtual ::NvParameterized::Interface* NvParameterized::Traits::finishNvParameterized | ( | const char * | name,
 |  | uint32_t | ver,
 |  | void * | obj,
 |  | void * | buf,
 |  | int32_t * | refCount
 | ) |  | [pure virtual]

Finish construction of inplace object of NvParameterized class.

Most probably this just calls Factory::finish using appropriate factory.

virtual bool NvParameterized::Traits::getNvParameterizedNames | ( | const char ** | names,
 |  | uint32_t & | outCount,
 |  | uint32_t | inCount
 | ) |  | const [pure virtual]

Get a list of the NvParameterized class type names.

Parameters:
[in] | names | buffer for names
[out] | outCount | minimal required length of buffer
[in] | inCount | length of buffer
Returns:
False if 'inCount' is not large enough to contain all of the names, true otherwise
Warning:
The memory for the strings returned is owned by the traits class and should only be read, not written or freed.
virtual bool NvParameterized::Traits::getNvParameterizedVersions | ( | const char * | className,
 |  | uint32_t * | versions,
 |  | uint32_t & | outCount,
 |  | uint32_t | inCount
 | ) |  | const [pure virtual]

Get a list of versions of particular NvParameterized class.

Parameters:
[in] | className | Name of the class
[in] | versions | buffer for versions
[out] | outCount | minimal required length of buffer
[in] | inCount | length of buffer
Returns:
False if 'inCount' is not large enough to contain all of version names, true otherwise
Warning:
The memory for the strings returned is owned by the traits class and should only be read, not written or freed.
virtual ::NvParameterized::Factory* NvParameterized::Traits::removeFactory ( const char * className ) [pure virtual]

Remove NvParameterized class factory for current version of class.

Returns:
Removed factory or NULL if it is not found
virtual ::NvParameterized::Factory* NvParameterized::Traits::removeFactory | ( | const char * | className,
 |  | uint32_t | version
 | ) |  | [pure virtual]

Remove NvParameterized class factory for given version of class.

Returns:
Removed factory or NULL if it is not found
virtual bool NvParameterized::Traits::updateLegacyNvParameterized | ( | ::NvParameterized::Interface & | legacyObj,
 |  | ::NvParameterized::Interface & | obj
 | ) |  | [inline, virtual]

Update legacy object (most probably using appropriate registered converter)

Parameters:
[in] | legacyObj | legacy object to be converted
[in] | obj | destination object
Returns:
True if conversion was successful, false otherwise
Warning:
Note that update is intrusive - legacyObj may be modified as a result of update
The documentation for this class was generated from the following file:
  • NvParameterizedTraits.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Traits
NvParameterized::Traits Member List
This is the complete list of members for NvParameterized::Traits, including all inherited members.
alloc(uint32_t nbytes)=0 | NvParameterized::Traits | [pure virtual]
alloc(uint32_t nbytes, uint32_t align)=0 | NvParameterized::Traits | [pure virtual]
createNvParameterized(const char *name)=0 | NvParameterized::Traits | [pure virtual]
createNvParameterized(const char *name, uint32_t ver)=0 | NvParameterized::Traits | [pure virtual]
decRefCount(int32_t *refCount)=0 | NvParameterized::Traits | [pure virtual]
doesFactoryExist(const char *className)=0 | NvParameterized::Traits | [pure virtual]
doesFactoryExist(const char *className, uint32_t version)=0 | NvParameterized::Traits | [pure virtual]
finishNvParameterized(const char *name, void *obj, void *buf, int32_t *refCount)=0 | NvParameterized::Traits | [pure virtual]
finishNvParameterized(const char *name, uint32_t ver, void *obj, void *buf, int32_t *refCount)=0 | NvParameterized::Traits | [pure virtual]
free(void *buf)=0 | NvParameterized::Traits | [pure virtual]
getAlignment(const char *className, uint32_t classVersion) const =0 | NvParameterized::Traits | [pure virtual]
getCurrentVersion(const char *className) const =0 | NvParameterized::Traits | [pure virtual]
getNvParameterizedNames(const char **names, uint32_t &outCount, uint32_t inCount) const =0 | NvParameterized::Traits | [pure virtual]
getNvParameterizedVersions(const char *className, uint32_t *versions, uint32_t &outCount, uint32_t inCount) const =0 | NvParameterized::Traits | [pure virtual]
incRefCount(int32_t *refCount)=0 | NvParameterized::Traits | [pure virtual]
onAllInplaceObjectsDestroyed(void *buf) | NvParameterized::Traits | [inline, virtual]
onInplaceObjectDestroyed(void *,::NvParameterized::Interface *) | NvParameterized::Traits | [inline, virtual]
registerConversion(const char *, uint32_t, uint32_t, Conversion &) | NvParameterized::Traits | [inline, virtual]
registerFactory(::NvParameterized::Factory &factory)=0 | NvParameterized::Traits | [pure virtual]
release(void)=0 | NvParameterized::Traits | [pure virtual]
removeConversion(const char *, uint32_t, uint32_t) | NvParameterized::Traits | [inline]
removeFactory(const char *className)=0 | NvParameterized::Traits | [pure virtual]
removeFactory(const char *className, uint32_t version)=0 | NvParameterized::Traits | [pure virtual]
strdup(const char *str) | NvParameterized::Traits | [inline, virtual]
strfree(char *str) | NvParameterized::Traits | [inline, virtual]
traitsWarn(const char *) const | NvParameterized::Traits | [inline, virtual]
updateLegacyNvParameterized(::NvParameterized::Interface &legacyObj,::NvParameterized::Interface &obj) | NvParameterized::Traits | [inline, virtual]
~Traits() (defined in NvParameterized::Traits) | NvParameterized::Traits | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::Traits::Allocator Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Traits
  • Allocator
Public Member Functions
NvParameterized::Traits::Allocator Class Reference

Adapter for allocator classes in PxAlloctor.h. More...

#include <NvParameterizedTraits.h>

List of all members.

Public Member Functions

Allocator (Traits *traits)
Constructor.
void * | allocate (size_t size)
Allocate memory.
void * | allocate (size_t size, const char *, int)
Allocate memory.
void | deallocate (void *ptr)
Release memory.

Detailed Description

Adapter for allocator classes in PxAlloctor.h.

The documentation for this class was generated from the following file:
  • NvParameterizedTraits.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Traits
  • Allocator
NvParameterized::Traits::Allocator Member List
This is the complete list of members for NvParameterized::Traits::Allocator, including all inherited members.
allocate(size_t size) | NvParameterized::Traits::Allocator | [inline]
allocate(size_t size, const char *, int) | NvParameterized::Traits::Allocator | [inline]
Allocator(Traits *traits) | NvParameterized::Traits::Allocator | [inline]
deallocate(void *ptr) | NvParameterized::Traits::Allocator | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::WrappedNamedReference Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • WrappedNamedReference
Public Member Functions | Public Attributes
NvParameterized::WrappedNamedReference Class Reference

WrappedNamedReference. More...

Inheritance diagram for NvParameterized::WrappedNamedReference:
NvParameterized::ReferenceInterface

List of all members.

Public Member Functions

WrappedNamedReference (NamedReferenceInterface &wrappedReference_)
Constructor.
void | referenceCallback (Handle &handle)
referenceCallback

Public Attributes

uint32_t | refCount
refCount

Detailed Description

WrappedNamedReference.

The documentation for this class was generated from the following file:
  • NvParamUtils.inl
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • WrappedNamedReference
NvParameterized::WrappedNamedReference Member List
This is the complete list of members for NvParameterized::WrappedNamedReference, including all inherited members.
refCount | NvParameterized::WrappedNamedReference |
referenceCallback(Handle &handle) | NvParameterized::WrappedNamedReference | [inline, virtual]
WrappedNamedReference(NamedReferenceInterface &wrappedReference_) | NvParameterized::WrappedNamedReference | [inline]
~ReferenceInterface() | NvParameterized::ReferenceInterface | [inline, virtual]
~WrappedNamedReference() (defined in NvParameterized::WrappedNamedReference) | NvParameterized::WrappedNamedReference | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Class Index

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
Class Index
A | B | C | D | E | F | G | H | I | J | M | N | O | P | R | S | T | U | V | W
A
DestructibleActorSyncFlags (nvidia::apex) HeatSourceActor (nvidia::apex) ParticleIosAssetAuthoring (nvidia::apex) SphereShape (nvidia::apex)
Actor (nvidia::apex) DestructibleActorSyncState (nvidia::apex) HeatSourceAsset (nvidia::apex) ParticlesPreview (nvidia::apex) StatDataType (nvidia::apex)
ActorSource (nvidia::apex) DestructibleAsset (nvidia::apex) HeatSourceAssetAuthoring (nvidia::apex) PhysX3DescTemplate (nvidia::apex) StatsInfo (nvidia::apex)
Traits::Allocator (NvParameterized) DestructibleAssetAuthoring (nvidia::apex) HeatSourcePreview (nvidia::apex) PhysX3Interface (nvidia::apex) RenderMeshAssetAuthoring::SubmeshDesc (nvidia::apex)
ApexChunkFlag (nvidia::apex) DestructibleAssetCookingDesc (nvidia::apex) Hint (NvParameterized) PhysXObjectDesc (nvidia::apex) SubstanceSourceActor (nvidia::apex)
ApexDesc (nvidia::apex) DestructibleAssetStats (nvidia::apex)
I
PhysXRenderBuffer (nvidia::apex) SubstanceSourceAsset (nvidia::apex)
ApexInterface (nvidia::apex) DestructibleBehaviorGroupDesc (nvidia::apex) ImpactDamageEventData (nvidia::apex) EmitterGeomExplicit::PointListData (nvidia::apex) SubstanceSourceAssetAuthoring (nvidia::apex)
ApexMeshParticleRollType (nvidia::apex) DestructibleCallbackSchedule (nvidia::apex) ImpactEmitterActor (nvidia::apex) EmitterGeomExplicit::PointParams (nvidia::apex) SubtextureVsLifeModifier (nvidia::apex)
ApexSDK (nvidia::apex) DestructibleChunkDesc (nvidia::apex) ImpactEmitterAsset (nvidia::apex) RenderMeshAssetAuthoring::Primitive (nvidia::apex)
T
ApexSDKCachedData (nvidia::apex) DestructibleChunkEvent (nvidia::apex) ImpactEmitterAssetAuthoring (nvidia::apex) ProjMatrixType (nvidia::apex) TestBase (nvidia::apex)
ApexSDKDesc (nvidia::apex) DestructibleChunkSyncState (nvidia::apex) ImpactEmitterPreview (nvidia::apex) PxStreamFromFileBuf (nvidia::apex) TestFunctionInterface (nvidia::apex)
Asset (nvidia::apex) DestructibleDepthParameters (nvidia::apex) RenderMeshAssetAuthoring::IndexType (nvidia::apex)
R
TextureUVOrigin (nvidia::apex)
AssetAuthoring (nvidia::apex) DestructibleDepthParametersFlag (nvidia::apex) Interface (NvParameterized) RandomRotationModifier (nvidia::apex) Traits (NvParameterized)
AssetPreview (nvidia::apex) DestructibleEmitterType (nvidia::apex) IofxActor (nvidia::apex) RandomScaleModifier (nvidia::apex) TurbulenceDensityFormat (nvidia::apex)
AssetPreviewScene (nvidia::apex) DestructibleGeometryDesc (nvidia::apex) IofxAsset (nvidia::apex) RandomSubtextureModifier (nvidia::apex) TurbulenceFieldType (nvidia::apex)
AttractorFSActor (nvidia::apex) DestructibleHitChunk (nvidia::apex) IofxAssetAuthoring (nvidia::apex) Range (nvidia::apex) TurbulenceFlameFormat (nvidia::apex)
AttractorFSPreview (nvidia::apex) DestructibleInitParameters (nvidia::apex) IofxCommonRenderData (nvidia::apex) ReadLock (nvidia::apex) TurbulenceFSActor (nvidia::apex)
B
DestructibleInitParametersFlag (nvidia::apex) IofxMeshRenderData (nvidia::apex) ReferenceInterface (NvParameterized) TurbulenceFSAsset (nvidia::apex)
BasicFSAsset (nvidia::apex) DestructibleParameterizedType (nvidia::apex) IofxMeshRenderLayout (nvidia::apex) Renderable (nvidia::apex) TurbulenceFSAssetAuthoring (nvidia::apex)
BasicFSAssetAuthoring (nvidia::apex) DestructibleParameters (nvidia::apex) IofxMeshRenderLayoutElement (nvidia::apex) RenderableIterator (nvidia::apex) TurbulenceFSPreview (nvidia::apex)
BasicIosActor (nvidia::apex) DestructibleParametersFlag (nvidia::apex) IofxMeshSharedRenderData (nvidia::apex) RenderBoneBufferData (nvidia::apex) TurbulenceRenderable (nvidia::apex)
BasicIosAsset (nvidia::apex) DestructiblePhysXActorQueryFlags (nvidia::apex) IofxRenderable (nvidia::apex) RenderBoneSemantic (nvidia::apex) TurbulenceRenderCallback (nvidia::apex)
BasicIosAssetAuthoring (nvidia::apex) DestructiblePreview (nvidia::apex) IofxRenderableIterator (nvidia::apex) RenderBufferData (nvidia::apex) TurbulenceRenderData (nvidia::apex)
BoxShape (nvidia::apex) DestructibleRenderable (nvidia::apex) IofxRenderCallback (nvidia::apex) RenderBufferHint (nvidia::apex) TurbulenceRenderLayout (nvidia::apex)
BSPOpenMode (nvidia::apex) DestructibleRTFractureParameters (nvidia::apex) IofxRenderSemantic (nvidia::apex) RenderContext (nvidia::apex) TurbulenceVelocityFormat (nvidia::apex)
C
DisplacementMapVolume (nvidia::apex) IofxSharedRenderData (nvidia::apex) RenderCullMode (nvidia::apex)
U
CapsuleShape (nvidia::apex)
E
IofxSpriteRenderData (nvidia::apex) RenderDataAccess (nvidia::apex) UserBoundingBoxFlags (nvidia::apex)
ChunkData (nvidia::apex) EffectPackageActor (nvidia::apex) IofxSpriteRenderLayout (nvidia::apex) RenderDataFormat (nvidia::apex) UserChunkParticleReport (nvidia::apex)
ChunkParticleReportData (nvidia::apex) EffectPackageAsset (nvidia::apex) IofxSpriteRenderLayoutElement (nvidia::apex) RenderDataProvider (nvidia::apex) UserChunkReport (nvidia::apex)
ChunkStateEventData (nvidia::apex) EffectPackageAssetAuthoring (nvidia::apex) IofxSpriteRenderLayoutSurfaceElement (nvidia::apex) RenderDebugInterface (nvidia::apex) UserDestructiblePhysXActorReport (nvidia::apex)
ChunkTransformHeader (nvidia::apex) EmitterGeomExplicit::EllipsoidParams (nvidia::apex) IofxSpriteSharedRenderData (nvidia::apex) RenderInstanceBufferData (nvidia::apex) UserDestructibleSyncHandler (nvidia::apex)
ChunkTransformUnit (nvidia::apex) ExplicitHierarchicalMesh::Embedding (nvidia::apex) IosAsset (nvidia::apex) RenderInstanceLayoutElement (nvidia::apex) UserImpactDamageReport (nvidia::apex)
ClothingActor (nvidia::apex) EmitterActor (nvidia::apex) IProgressListener (nvidia::apex) RenderInstanceSemantic (nvidia::apex) UserOpaqueMesh (nvidia::apex)
ClothingAsset (nvidia::apex) EmitterAsset (nvidia::apex)
J
RenderInteropFlags (nvidia::apex) UserOpaqueMeshDesc (nvidia::apex)
ClothingAssetAuthoring (nvidia::apex) EmitterAssetAuthoring (nvidia::apex) JetFSActor (nvidia::apex) RenderLockMode (nvidia::apex) UserRenderBoneBuffer (nvidia::apex)
ClothingCapsule (nvidia::apex) EmitterGeom (nvidia::apex) JetFSPreview (nvidia::apex) RenderMapType (nvidia::apex) UserRenderBoneBufferDesc (nvidia::apex)
ClothingCollision (nvidia::apex) EmitterGeomBox (nvidia::apex)
M
RenderMeshActor (nvidia::apex) UserRenderBuffer (nvidia::apex)
ClothingCollisionType (nvidia::apex) EmitterGeomCylinder (nvidia::apex) UserRenderSurface::MappedInfo (nvidia::apex) RenderMeshActorDesc (nvidia::apex) UserRenderBufferDesc (nvidia::apex)
ClothingConstrainCoefficients (nvidia::apex) EmitterGeomExplicit (nvidia::apex) MaterialFrame (nvidia::apex) RenderMeshActorRaycastFlags (nvidia::apex) UserRenderCallback (nvidia::apex)
ClothingConvex (nvidia::apex) EmitterGeomSphere (nvidia::apex) MaterialLookupCallback (nvidia::apex) RenderMeshActorRaycastHitData (nvidia::apex) UserRenderData (nvidia::apex)
ClothingMeshSkinningMap (nvidia::apex) EmitterGeomSphereShell (nvidia::apex) MaterialLookupCallback::MaterialRequest (nvidia::apex) RenderMeshAsset (nvidia::apex) UserRenderDataHolder (nvidia::apex)
ClothingPhysicalMesh (nvidia::apex) EmitterLodParamDesc (nvidia::apex) RenderMeshAssetAuthoring::MeshDesc (nvidia::apex) RenderMeshAssetAuthoring (nvidia::apex) UserRenderer (nvidia::apex)
ClothingPhysicalMeshStats (nvidia::apex) | EmitterPreview (nvidia::apex) | MeshProcessingParameters (FractureTools) | RenderMeshAssetInstanceMode (nvidia::apex) | UserRenderIndexBuffer (nvidia::apex)
ClothingPlane (nvidia::apex) EmitterType (nvidia::apex) Serializer::MetadataEntry (NvParameterized) RenderMeshAssetStats (nvidia::apex) UserRenderIndexBufferDesc (nvidia::apex)
ClothingPreview (nvidia::apex) EmitterActor::EmitterValidateCallback (nvidia::apex) MirrorScene::MirrorFilter (nvidia::apex) RenderMeshPartData (nvidia::apex) UserRenderInstanceBuffer (nvidia::apex)
ClothingRenderProxy (nvidia::apex) ExplicitHierarchicalMesh (nvidia::apex) MirrorScene (nvidia::apex) RenderPrimitiveType (nvidia::apex) UserRenderInstanceBufferDesc (nvidia::apex)
ClothingSphere (nvidia::apex) ExplicitRenderTriangle (nvidia::apex) Modifier (nvidia::apex) RenderSemanticData (nvidia::apex) UserRenderResource (nvidia::apex)
ClothingTeleportMode (nvidia::apex) ExplicitSubmeshData (nvidia::apex) ModifierT (nvidia::apex) RenderSpriteBufferData (nvidia::apex) UserRenderResourceDesc (nvidia::apex)
ClothingTriangleMesh (nvidia::apex) ExplicitVertexFormat (nvidia::apex) Module (nvidia::apex) RenderSpriteLayoutElement (nvidia::apex) UserRenderResourceManager (nvidia::apex)
ClothingVelocityCallback (nvidia::apex)
F
ModuleBasicFS (nvidia::apex) RenderSpriteSemantic (nvidia::apex) UserRenderSpriteBuffer (nvidia::apex)
ClothSolverMode (nvidia::apex) Factory (NvParameterized) ModuleBasicIos (nvidia::apex) RenderSpriteTextureLayout (nvidia::apex) UserRenderSpriteBufferDesc (nvidia::apex)
CollisionDesc (nvidia::apex) FieldSamplerWeightedCollisionFilterCallback (nvidia::apex) ModuleCachedData (nvidia::apex) RenderSubmesh (nvidia::apex) UserRenderSpriteTextureDesc (nvidia::apex)
CollisionVolumeDesc (nvidia::apex) FlameEmitterActor (nvidia::apex) ModuleClothing (nvidia::apex) RenderSurfaceBufferData (nvidia::apex) UserRenderStorage (nvidia::apex)
ColorRGBA (nvidia::apex) FlameEmitterAsset (nvidia::apex) ModuleDestructible (nvidia::apex) RenderVertexBufferData (nvidia::apex) UserRenderSurface (nvidia::apex)
ColorVsDensityModifier (nvidia::apex) FlameEmitterAssetAuthoring (nvidia::apex) ModuleDestructibleConst (nvidia::apex) RenderVertexSemantic (nvidia::apex) UserRenderSurfaceBuffer (nvidia::apex)
ColorVsLifeModifier (nvidia::apex) FlameEmitterPreview (nvidia::apex) ModuleEmitter (nvidia::apex) RenderVolume (nvidia::apex) UserRenderSurfaceBufferDesc (nvidia::apex)
ColorVsVelocityModifier (nvidia::apex) ForceFieldActor (nvidia::apex) ModuleFieldSampler (nvidia::apex) ResourceCallback (nvidia::apex) UserRenderSurfaceDesc (nvidia::apex)
Context (nvidia::apex) ForceFieldAsset (nvidia::apex) ModuleForceField (nvidia::apex) ResourceProvider (nvidia::apex) UserRenderVertexBuffer (nvidia::apex)
Conversion (NvParameterized) ForceFieldAssetAuthoring (nvidia::apex) ModuleIofx (nvidia::apex) RotationModifier (nvidia::apex) UserRenderVertexBufferDesc (nvidia::apex)
ExplicitHierarchicalMesh::ConvexHull (nvidia::apex) ForceFieldPreview (nvidia::apex) ModuleIofxLegacy (nvidia::apex) RotationRateModifier (nvidia::apex)
V
ConvexHullMethod (nvidia::apex) DestructibleRTFractureParameters::FractureAttachment (nvidia::apex) ModuleLoader (nvidia::apex) RotationRateVsLifeModifier (nvidia::apex) Vec2T (nvidia::apex)
CudaTestManager (nvidia::apex) | FractureCutoutDesc (FractureTools) | ModuleParticleIos (nvidia::apex) | RWLockable (nvidia::apex) | VelocitySourceActor (nvidia::apex)
Curve (nvidia::apex) FractureEventHeader (nvidia::apex) ModuleParticles (nvidia::apex)
S
VelocitySourceAsset (nvidia::apex)
CustomBufferIterator (nvidia::apex) FractureEventUnit (nvidia::apex) ModuleSpecificRenderBufferData (nvidia::apex) ScaleAlongVelocityModifier (nvidia::apex) VelocitySourceAssetAuthoring (nvidia::apex)
CutoutParameters (FractureTools) | DestructibleRTFractureParameters::FractureGlass (nvidia::apex) | ModuleTurbulenceFS (nvidia::apex) | ScaleByMassModifier (nvidia::apex) | VelocitySourcePreview (nvidia::apex)
CutoutSet (FractureTools) FractureMaterialDesc (nvidia::apex)
N
ScaleVsCameraDistanceModifier (nvidia::apex) Vertex (nvidia::apex)
D
FractureMethod (nvidia::apex) NamedReferenceInterface (NvParameterized) ScaleVsDensityModifier (nvidia::apex) RenderMeshAssetAuthoring::VertexBuffer (nvidia::apex)
DamageEventCoreData (nvidia::apex) | FractureSliceDesc (FractureTools) | NoiseFSActor (nvidia::apex) | ScaleVsLifeModifier (nvidia::apex) | VertexBuffer (nvidia::apex)
DamageEventHeader (nvidia::apex) FractureToolsAPI (nvidia::apex) NoiseFSPreview (nvidia::apex) Scene (nvidia::apex) VertexColor (nvidia::apex)
DamageEventReportData (nvidia::apex) | FractureVoronoiDesc (FractureTools) | NoiseParameters (FractureTools) | SceneDesc (nvidia::apex) | VertexFormat (nvidia::apex)
DamageEventUnit (nvidia::apex)
G
O
SceneStats (nvidia::apex) VertexUV (nvidia::apex)
DamageSpreadFunction (nvidia::apex) GroundEmitterActor (nvidia::apex) oaValueStruct (nvidia::apex) ScopedPhysXLockRead (nvidia::apex) ViewDirectionSortingModifier (nvidia::apex)
Definition (NvParameterized) GroundEmitterAsset (nvidia::apex) OrientAlongVelocityModifier (nvidia::apex) ScopedPhysXLockWrite (nvidia::apex) ViewMatrixType (nvidia::apex)
Serializer::DeserializedResults (NvParameterized) GroundEmitterAssetAuthoring (nvidia::apex) OrientScaleAlongScreenVelocityModifier (nvidia::apex) SerializationCallback (NvParameterized) VortexFSActor (nvidia::apex)
DestructibleActor (nvidia::apex) GroundEmitterPreview (nvidia::apex)
P
SerializePlatform (NvParameterized) VortexFSPreview (nvidia::apex)
DestructibleActorChunkFlags (nvidia::apex) GroupsFilterOp (nvidia::apex) ParameterFind (NvParameterized) Serializer (NvParameterized)
W
DestructibleActorJoint (nvidia::apex) GroupsMask64 (nvidia::apex) ParameterList (NvParameterized) Shape (nvidia::apex) WindFSActor (nvidia::apex)
DestructibleActorJointDesc (nvidia::apex)
H
ParamResult (NvParameterized) SimpleScaleModifier (nvidia::apex) WindFSPreview (nvidia::apex)
DestructibleActorMeshType (nvidia::apex) | HalfSpaceShape (nvidia::apex) | ParticleIosActor (nvidia::apex) | SliceParameters (FractureTools) | WrappedNamedReference (NvParameterized)
DestructibleActorRaycastFlags (nvidia::apex) Handle (NvParameterized) ParticleIosAsset (nvidia::apex) EmitterGeomExplicit::SphereParams (nvidia::apex) WriteLock (nvidia::apex)
A | B | C | D | E | F | G | H | I | J | M | N | O | P | R | S | T | U | V | W
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: nvidia::apex::Actor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Actor
Public Member Functions
nvidia::apex::Actor Class Reference

Base class for APEX module objects. More...

#include <Actor.h>

Inheritance diagram for nvidia::apex::Actor:
nvidia::apex::ApexInterface nvidia::apex::RWLockable nvidia::apex::AttractorFSActor nvidia::apex::BasicIosActor nvidia::apex::ClothingActor nvidia::apex::DestructibleActor nvidia::apex::EffectPackageActor nvidia::apex::EmitterActor nvidia::apex::FlameEmitterActor nvidia::apex::ForceFieldActor nvidia::apex::GroundEmitterActor nvidia::apex::HeatSourceActor nvidia::apex::ImpactEmitterActor nvidia::apex::IofxActor nvidia::apex::JetFSActor nvidia::apex::NoiseFSActor nvidia::apex::ParticleIosActor nvidia::apex::RenderMeshActor nvidia::apex::SubstanceSourceActor nvidia::apex::TurbulenceFSActor nvidia::apex::VelocitySourceActor nvidia::apex::VortexFSActor nvidia::apex::WindFSActor

List of all members.

Public Member Functions

virtual Asset * | getOwner () const =0
Returns the owning asset.
virtual void | getLodRange (float &min, float &max, bool &intOnly) const =0
Returns the range of possible values for physical Lod overwrite.
virtual float | getActiveLod () const =0
Get current physical lod.
virtual void | forceLod (float lod)=0
Force an APEX Actor to use a certian physical Lod.
virtual void | cacheModuleData () const
Ensure that all module-cached data is cached.
virtual void | setEnableDebugVisualization (bool state)=0
Selectively enables/disables debug visualization of a specific APEX actor. Default value it true.

Detailed Description

Base class for APEX module objects.

Member Function Documentation

virtual void nvidia::apex::Actor::forceLod ( float lod ) [pure virtual]

Force an APEX Actor to use a certian physical Lod.

Parameters:
[in] lod Overwrite the Lod system to use this Lod.
Note:
Setting the lod value to a negative number will turn off the overwrite and proceed with regular Lod computations
See also:
Actor::getLodRange()
virtual void nvidia::apex::Actor::getLodRange | ( | float & | min,
 |  | float & | max,
 |  | bool & | intOnly
 | ) |  | const [pure virtual]

Returns the range of possible values for physical Lod overwrite.

Parameters:
[out] | min | The minimum lod value
[out] | max | The maximum lod value
[out] | intOnly | Only integers are allowed if this is true, gets rounded to nearest
Note:
The max value can change with different graphical Lods
See also:
Actor::forceLod()
The documentation for this class was generated from the following file:
  • Actor.h
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Actor
nvidia::apex::Actor Member List
This is the complete list of members for nvidia::apex::Actor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: nvidia::apex::ActorSource Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ActorSource
Public Member Functions
nvidia::apex::ActorSource Class Reference

Base class for APEX classes that spawn PhysX SDK Actors. More...

#include <Actor.h>

Inheritance diagram for nvidia::apex::ActorSource:
nvidia::apex::DestructibleActor

List of all members.

Public Member Functions

virtual void | setPhysX3Template (const PhysX3DescTemplate *)=0
Sets the current body template.
virtual bool | getPhysX3Template (PhysX3DescTemplate &dest) const =0
Retrieve the current body template.
virtual PhysX3DescTemplate * | createPhysX3DescTemplate () const =0
Create an PhysX3DescTemplate object to pass into the get/set methods.

Detailed Description

Base class for APEX classes that spawn PhysX SDK Actors.

Member Function Documentation

virtual void nvidia::apex::ActorSource::setPhysX3Template ( const PhysX3DescTemplate * ) [pure virtual]

Sets the current body template.

User can specify a descriptor template for bodies that this object may create. APEX may customize these suggested settings. Already created / existing bodies will not be changed if the body template is changed! The body template will only be used for new bodies created after this is called!

members that are ignored: massLocalPose massSpaceInertia mass linearVelocity angularVelocity

These fields should be left at their default values as set by the desc constructor.

The documentation for this class was generated from the following file:
  • Actor.h
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ActorSource
nvidia::apex::ActorSource Member List
This is the complete list of members for nvidia::apex::ActorSource, including all inherited members.
createPhysX3DescTemplate() const =0 | nvidia::apex::ActorSource | [pure virtual]
getPhysX3Template(PhysX3DescTemplate &dest) const =0 | nvidia::apex::ActorSource | [pure virtual]
setPhysX3Template(const PhysX3DescTemplate *)=0 | nvidia::apex::ActorSource | [pure virtual]
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: nvidia::apex::ApexDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexDesc
Public Member Functions | Public Attributes
nvidia::apex::ApexDesc Class Reference

Base class for all APEX Descriptor classes. More...

#include <ApexDesc.h>

Inheritance diagram for nvidia::apex::ApexDesc:
nvidia::apex::ApexSDKDesc nvidia::apex::DestructibleActorJointDesc nvidia::apex::DestructibleAssetCookingDesc nvidia::apex::DestructibleBehaviorGroupDesc nvidia::apex::DestructibleChunkDesc nvidia::apex::DestructibleGeometryDesc nvidia::apex::EmitterLodParamDesc nvidia::apex::RenderMeshActorDesc nvidia::apex::SceneDesc

List of all members.

Public Member Functions

PX_INLINE | ApexDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE bool | isValid () const
Returns true if the descriptor is valid.

Public Attributes

void * | userData
for standard init of user data member

Detailed Description

Base class for all APEX Descriptor classes.

A descriptor class of type NxXDesc is typically passed to a createX() function. Descriptors have several advantages over simply passing a number of explicit parameters to create():

  • all parameters can have default values so the user only needs to know about the ones he needs to change
  • new parameters can be added without changing the user code, along with defaults
  • the user and the SDK can validate the parameter's correctness using isValid()
  • if creation fails, the user can look at the code of isValid() to see what exactly is not being accepted by the SDK
  • some object types can save out their state into descriptors again for serialization

Care should be taken that derived descriptor classes do not initialize their base class members multiple times, once in the constructor, and once in setToDefault()!

Member Function Documentation

PX_INLINE bool nvidia::apex::ApexDesc::isValid ( ) const [inline]

Returns true if the descriptor is valid.

Returns:
true if the current settings are valid.

Reimplemented in nvidia::apex::ApexSDKDesc, nvidia::apex::DestructibleActorJointDesc, nvidia::apex::DestructibleBehaviorGroupDesc, nvidia::apex::DestructibleChunkDesc, nvidia::apex::DestructibleGeometryDesc, nvidia::apex::DestructibleAssetCookingDesc, nvidia::apex::EmitterLodParamDesc, and nvidia::apex::RenderMeshActorDesc.

The documentation for this class was generated from the following file:
  • ApexDesc.h
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexDesc
nvidia::apex::ApexDesc Member List
This is the complete list of members for nvidia::apex::ApexDesc, including all inherited members.
ApexDesc() | nvidia::apex::ApexDesc | [inline]
isValid() const | nvidia::apex::ApexDesc | [inline]
setToDefault() | nvidia::apex::ApexDesc | [inline]
userData | nvidia::apex::ApexDesc |
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: nvidia::apex::ApexInterface Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexInterface
Public Member Functions | Public Attributes
nvidia::apex::ApexInterface Class Reference

Base class for all interface classes implemented by APEX SDK. More...

#include <ApexInterface.h>

Inheritance diagram for nvidia::apex::ApexInterface:
nvidia::apex::RWLockable nvidia::apex::Actor nvidia::apex::ApexSDK nvidia::apex::Asset nvidia::apex::AssetAuthoring nvidia::apex::AssetPreview nvidia::apex::AssetPreviewScene nvidia::apex::ClothingCollision nvidia::apex::ClothingPhysicalMesh nvidia::apex::ClothingRenderProxy nvidia::apex::DestructibleActorJoint nvidia::apex::DestructibleRenderable nvidia::apex::IofxRenderable nvidia::apex::IofxRenderableIterator nvidia::apex::Module nvidia::apex::RenderableIterator nvidia::apex::RenderDebugInterface nvidia::apex::RenderVolume nvidia::apex::Scene nvidia::apex::TurbulenceRenderable

List of all members.

Public Member Functions

virtual void | release ()=0
Release an object instance.

Public Attributes

void * | userData
User data variable.

Detailed Description

Base class for all interface classes implemented by APEX SDK.

User callback interfaces should not derive from this class.

Member Function Documentation

virtual void nvidia::apex::ApexInterface::release ( ) [pure virtual]

Release an object instance.

Calling this will unhook the class and delete it from memory. You should not keep any reference to this class instance after calling release

Implemented in nvidia::apex::EffectPackageActor, nvidia::apex::RenderDebugInterface, nvidia::apex::FlameEmitterActor, nvidia::apex::HeatSourceActor, nvidia::apex::SubstanceSourceActor, and nvidia::apex::VelocitySourceActor.

Member Data Documentation

void* nvidia::apex::ApexInterface::userData

User data variable.

Practical in scenarios where this object has a clear and unique owner, not so useful in other scenarios.

The documentation for this class was generated from the following file:
  • ApexInterface.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexInterface
nvidia::apex::ApexInterface Member List
This is the complete list of members for nvidia::apex::ApexInterface, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::ApexSDK Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexSDK
Public Member Functions
nvidia::apex::ApexSDK Class Reference

The ApexSDK abstraction. Manages scenes and modules. More...

#include <ApexSDK.h>

Inheritance diagram for nvidia::apex::ApexSDK:
nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual Scene * | createScene (const SceneDesc &)=0
Create an APEX Scene.
virtual void | releaseScene (Scene *)=0
Release an APEX Scene.
virtual AssetPreviewScene * | createAssetPreviewScene ()=0
Create an APEX Asset Preview Scene.
virtual void | releaseAssetPreviewScene (AssetPreviewScene *nxScene)=0
Release an APEX Asset Preview Scene.
virtual Module * | createModule (const char *name, ApexCreateError *err=NULL)=0
Create/Load a module.
virtual const PhysXObjectDesc * | getPhysXObjectInfo (const PxActor *actor) const =0
Return an object describing how APEX is using the PhysX Actor.
virtual const PhysXObjectDesc * | getPhysXObjectInfo (const PxShape *shape) const =0
Return an object describing how APEX is using the PhysX Shape.
virtual const PhysXObjectDesc * | getPhysXObjectInfo (const PxJoint *joint) const =0
Return an object describing how APEX is using the PhysX Joint.
virtual const PhysXObjectDesc * | getPhysXObjectInfo (const PxCloth *cloth) const =0
Return an object describing how APEX is using the PhysX Cloth.
virtual PxCooking * | getCookingInterface ()=0
Returns the cooking interface.
virtual PX_DEPRECATED
PxErrorCallback * 		getOutputStream ()=0
Return the user error callback.
virtual PxErrorCallback * | getErrorCallback () const =0
Return the user error callback.
virtual PxAllocatorCallback * | getAllocator () const =0
Return the user allocator callback.
virtual ResourceProvider * | getNamedResourceProvider ()=0
Return the named resource provider.
virtual PxFileBuf * | createStream (const char *filename, PxFileBuf::OpenMode mode)=0
Return an APEX PxFileBuf instance. For use by APEX tools and samples, not by APEX internally. Internally, APEX will use an PxFileBuf directly provided by the user.
virtual PxFileBuf * | createMemoryReadStream (const void *mem, uint32_t len)=0
Return a PxFileBuf which reads from a buffer in memory.
virtual PxFileBuf * | createMemoryWriteStream (uint32_t alignment=0)=0
Return a PxFileBuf which writes to memory.
virtual const void * | getMemoryWriteBuffer (PxFileBuf &stream, uint32_t &len)=0
Return the address and length of the contents of a memory write buffer stream.
virtual void | releaseMemoryReadStream (PxFileBuf &stream)=0
Release a previously created PxFileBuf used as a read stream.
virtual void | releaseMemoryWriteStream (PxFileBuf &stream)=0
Release a previously created PxFileBuf used as a write stream.
virtual PxPhysics * | getPhysXSDK ()=0
Return the PhysX SDK.
virtual uint32_t | getNbModules ()=0
Return the number of modules.
virtual Module ** | getModules ()=0
Return an array of module pointers.
virtual void | releaseModule (Module *module)=0
Release a previously loaded module.
virtual RenderDebugInterface * | createApexRenderDebug (RENDER_DEBUG::RenderDebugInterface *iface, bool useRemoteDebugVisualization=false)=0
Creates an ApexDebugRender interface.
virtual void | releaseApexRenderDebug (RenderDebugInterface &debug)=0
Releases an ApexDebugRender interface.
virtual SphereShape * | createApexSphereShape ()=0
Creates an ApexSphereShape interface.
virtual CapsuleShape * | createApexCapsuleShape ()=0
Creates an ApexCapsuleShape interface.
virtual BoxShape * | createApexBoxShape ()=0
Creates an ApexBoxShape interface.
virtual HalfSpaceShape * | createApexHalfSpaceShape ()=0
Creates an ApexHalfSpaceShape interface.
virtual void | releaseApexShape (Shape &shape)=0
Release an Shape interface.
virtual uint32_t | forceLoadAssets ()=0
Return the number of assets force loaded by all of the existing APEX modules.
virtual bool | getAuthorableObjectNames (const char **authTypeNames, uint32_t &outCount, uint32_t inCount)=0
Get a list of the APEX authorable types.
virtual ::NvParameterized::Traits * | getParameterizedTraits ()=0
Get the a pointer to APEX's instance of the NvParameterized::Traits class.
virtual Asset * | createAsset (AssetAuthoring &, const char *name)=0
Creates an APEX asset from an AssetAuthoring object.
virtual Asset * | createAsset (::NvParameterized::Interface *, const char *name)=0
Creates an APEX asset from a parameterized object.
virtual void | releaseAsset (Asset &)=0
Release an APEX asset.
virtual AssetAuthoring * | createAssetAuthoring (const char *authorTypeName)=0
Creates an APEX asset authoring object.
virtual AssetAuthoring * | createAssetAuthoring (const char *authorTypeName, const char *name)=0
Create an APEX asset authoring object with a name.
virtual AssetAuthoring * | createAssetAuthoring (::NvParameterized::Interface *, const char *name)=0
Create an APEX asset authoring object from a parameterized object.
virtual void | releaseAssetAuthoring (AssetAuthoring &)=0
Releases an APEX asset authoring object.
virtual ApexSDKCachedData & | getCachedData () const =0
Returns the scene data cache for actors in the scene.
virtual
::NvParameterized::Serializer * 		createSerializer (::NvParameterized::Serializer::SerializeType type)=0
Create a Serialization object.
virtual
::NvParameterized::Serializer * 		createSerializer (::NvParameterized::Serializer::SerializeType type,::NvParameterized::Traits *traits)=0
Create a Serialization object from custom traits.
virtual
::NvParameterized::Serializer::SerializeType 		getSerializeType (const void *data, uint32_t dlen)=0
Figure out whether a given chunk of data was xml or binary serialized. To properly detect XML formats, 32 bytes of data are scanned, so dlen should be at least 32 bytes.
virtual
::NvParameterized::Serializer::SerializeType 		getSerializeType (PxFileBuf &stream)=0
Figure out whether a given chunk of data was xml or binary serialized.
virtual
NvParameterized::Serializer::ErrorType 		getSerializePlatform (PxFileBuf &stream, NvParameterized::SerializePlatform &platform)=0
Find native platform for a given chunk of data.
virtual
NvParameterized::Serializer::ErrorType 		getSerializePlatform (const void *data, uint32_t dlen, NvParameterized::SerializePlatform &platform)=0
Find native platform for a given chunk of data.
virtual void | getCurrentPlatform (NvParameterized::SerializePlatform &platform) const =0
Get current (native) platform.
virtual bool | getPlatformFromString (const char *name, NvParameterized::SerializePlatform &platform) const =0
Get platform from human-readable name.
virtual const char * | getPlatformName (const NvParameterized::SerializePlatform &platform) const =0
Get canonical name for platform.
virtual
::NvParameterized::Interface * 		getDebugColorParams () const =0
Gets NvParameterized debug rendering color parameters. Modiying NvParameterized debug colors automatically updates color table in debug renderer.
virtual const char * | getWireframeMaterial ()=0
Gets a string for the material to use when rendering wireframe data.
virtual const char * | getSolidShadedMaterial ()=0
Gets a string for the material to use when rendering solid shaded (per vertex color) lit triangles.
virtual void | setEnableApexStats (bool enableApexStats)=0
Enable or disable the APEX module-specific stat collection (some modules can be time consuming)
virtual void | setEnableConcurrencyCheck (bool enableConcurrencyChecks)=0
Enable or disable the APEX concurrent access check.
virtual bool | isConcurrencyCheckEnabled ()=0
Returns current setting for APEX concurrent access check.

Detailed Description

The ApexSDK abstraction. Manages scenes and modules.

Member Function Documentation

virtual Asset* nvidia::apex::ApexSDK::createAsset | ( | ::NvParameterized::Interface * | ,
 |  | const char * | name
 | ) |  | [pure virtual]

Creates an APEX asset from a parameterized object.

Note:
The NvParameterized::Interface object's ownership passes to the asset, if a copy is needed, use the NvParameterized::Interface::copy() method
virtual bool nvidia::apex::ApexSDK::getAuthorableObjectNames | ( | const char ** | authTypeNames,
 |  | uint32_t & | outCount,
 |  | uint32_t | inCount
 | ) |  | [pure virtual]

Get a list of the APEX authorable types.

The memory for the strings returned is owned by the APEX SDK and should only be read, not written or freed. Returns false if 'inCount' is not large enough to contain all of the names.

virtual PX_DEPRECATED PxErrorCallback* nvidia::apex::ApexSDK::getOutputStream ( ) [pure virtual]

Return the user error callback.

Deprecated:
Use getErrorCallback() instead.
virtual const PhysXObjectDesc* nvidia::apex::ApexSDK::getPhysXObjectInfo ( const PxJoint * joint ) const [pure virtual]

Return an object describing how APEX is using the PhysX Joint.

Returns:
NULL if PhysX Joint is not owned by APEX.
virtual const PhysXObjectDesc* nvidia::apex::ApexSDK::getPhysXObjectInfo ( const PxCloth * cloth ) const [pure virtual]

Return an object describing how APEX is using the PhysX Cloth.

Returns:
NULL if PhysX Cloth is not owned by APEX.
virtual const PhysXObjectDesc* nvidia::apex::ApexSDK::getPhysXObjectInfo ( const PxActor * actor ) const [pure virtual]

Return an object describing how APEX is using the PhysX Actor.

Returns:
NULL if PhysX Actor is not owned by APEX.
virtual const PhysXObjectDesc* nvidia::apex::ApexSDK::getPhysXObjectInfo ( const PxShape * shape ) const [pure virtual]

Return an object describing how APEX is using the PhysX Shape.

Returns:
NULL if PhysX Shape is not owned by APEX.
virtual bool nvidia::apex::ApexSDK::getPlatformFromString | ( | const char * | name,
 |  | NvParameterized::SerializePlatform & | platform
 | ) |  | const [pure virtual]

Get platform from human-readable name.

Parameters:
[in] | name | platform name
[out] | platform | Platform corresponding to name
Returns:
Success

Name format: compiler + compiler version (if needed) + architecture. Supported names: VcWin32, VcWin64, VcXboxOne, GccPs4, AndroidARM, GccLinux32, GccLinux64, GccOsX32, Pib.

virtual NvParameterized::Serializer::ErrorType nvidia::apex::ApexSDK::getSerializePlatform | ( | const void * | data,
 |  | uint32_t | dlen,
 |  | NvParameterized::SerializePlatform & | platform
 | ) |  | [pure virtual]

Find native platform for a given chunk of data.

Note:
To properly detect platform 64 bytes of data are scanned, so dlen should be at least 64 bytes
The documentation for this class was generated from the following file:
  • ApexSDK.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexSDK
nvidia::apex::ApexSDK Member List
This is the complete list of members for nvidia::apex::ApexSDK, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexBoxShape()=0 | nvidia::apex::ApexSDK | [pure virtual]
createApexCapsuleShape()=0 | nvidia::apex::ApexSDK | [pure virtual]
createApexHalfSpaceShape()=0 | nvidia::apex::ApexSDK | [pure virtual]
createApexRenderDebug(RENDER_DEBUG::RenderDebugInterface *iface, bool useRemoteDebugVisualization=false)=0 | nvidia::apex::ApexSDK | [pure virtual]
createApexSphereShape()=0 | nvidia::apex::ApexSDK | [pure virtual]
createAsset(AssetAuthoring &, const char *name)=0 | nvidia::apex::ApexSDK | [pure virtual]
createAsset(::NvParameterized::Interface *, const char *name)=0 | nvidia::apex::ApexSDK | [pure virtual]
createAssetAuthoring(const char *authorTypeName)=0 | nvidia::apex::ApexSDK | [pure virtual]
createAssetAuthoring(const char *authorTypeName, const char *name)=0 | nvidia::apex::ApexSDK | [pure virtual]
createAssetAuthoring(::NvParameterized::Interface *, const char *name)=0 | nvidia::apex::ApexSDK | [pure virtual]
createAssetPreviewScene()=0 | nvidia::apex::ApexSDK | [pure virtual]
createMemoryReadStream(const void *mem, uint32_t len)=0 | nvidia::apex::ApexSDK | [pure virtual]
createMemoryWriteStream(uint32_t alignment=0)=0 | nvidia::apex::ApexSDK | [pure virtual]
createModule(const char *name, ApexCreateError *err=NULL)=0 | nvidia::apex::ApexSDK | [pure virtual]
createScene(const SceneDesc &)=0 | nvidia::apex::ApexSDK | [pure virtual]
createSerializer(::NvParameterized::Serializer::SerializeType type)=0 | nvidia::apex::ApexSDK | [pure virtual]
createSerializer(::NvParameterized::Serializer::SerializeType type,::NvParameterized::Traits *traits)=0 | nvidia::apex::ApexSDK | [pure virtual]
createStream(const char *filename, PxFileBuf::OpenMode mode)=0 | nvidia::apex::ApexSDK | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::ApexSDK | [pure virtual]
getAllocator() const =0 | nvidia::apex::ApexSDK | [pure virtual]
getAuthorableObjectNames(const char **authTypeNames, uint32_t &outCount, uint32_t inCount)=0 | nvidia::apex::ApexSDK | [pure virtual]
getCachedData() const =0 | nvidia::apex::ApexSDK | [pure virtual]
getCookingInterface()=0 | nvidia::apex::ApexSDK | [pure virtual]
getCurrentPlatform(NvParameterized::SerializePlatform &platform) const =0 | nvidia::apex::ApexSDK | [pure virtual]
getDebugColorParams() const =0 | nvidia::apex::ApexSDK | [pure virtual]
getErrorCallback() const =0 | nvidia::apex::ApexSDK | [pure virtual]
getMemoryWriteBuffer(PxFileBuf &stream, uint32_t &len)=0 | nvidia::apex::ApexSDK | [pure virtual]
getModules()=0 | nvidia::apex::ApexSDK | [pure virtual]
getNamedResourceProvider()=0 | nvidia::apex::ApexSDK | [pure virtual]
getNbModules()=0 | nvidia::apex::ApexSDK | [pure virtual]
getOutputStream()=0 | nvidia::apex::ApexSDK | [pure virtual]
getParameterizedTraits()=0 | nvidia::apex::ApexSDK | [pure virtual]
getPhysXObjectInfo(const PxActor *actor) const =0 | nvidia::apex::ApexSDK | [pure virtual]
getPhysXObjectInfo(const PxShape *shape) const =0 | nvidia::apex::ApexSDK | [pure virtual]
getPhysXObjectInfo(const PxJoint *joint) const =0 | nvidia::apex::ApexSDK | [pure virtual]
getPhysXObjectInfo(const PxCloth *cloth) const =0 | nvidia::apex::ApexSDK | [pure virtual]
getPhysXSDK()=0 | nvidia::apex::ApexSDK | [pure virtual]
getPlatformFromString(const char *name, NvParameterized::SerializePlatform &platform) const =0 | nvidia::apex::ApexSDK | [pure virtual]
getPlatformName(const NvParameterized::SerializePlatform &platform) const =0 | nvidia::apex::ApexSDK | [pure virtual]
getSerializePlatform(PxFileBuf &stream, NvParameterized::SerializePlatform &platform)=0 | nvidia::apex::ApexSDK | [pure virtual]
getSerializePlatform(const void *data, uint32_t dlen, NvParameterized::SerializePlatform &platform)=0 | nvidia::apex::ApexSDK | [pure virtual]
getSerializeType(const void *data, uint32_t dlen)=0 | nvidia::apex::ApexSDK | [pure virtual]
getSerializeType(PxFileBuf &stream)=0 | nvidia::apex::ApexSDK | [pure virtual]
getSolidShadedMaterial()=0 | nvidia::apex::ApexSDK | [pure virtual]
getWireframeMaterial()=0 | nvidia::apex::ApexSDK | [pure virtual]
isConcurrencyCheckEnabled()=0 | nvidia::apex::ApexSDK | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseApexRenderDebug(RenderDebugInterface &debug)=0 | nvidia::apex::ApexSDK | [pure virtual]
releaseApexShape(Shape &shape)=0 | nvidia::apex::ApexSDK | [pure virtual]
releaseAsset(Asset &)=0 | nvidia::apex::ApexSDK | [pure virtual]
releaseAssetAuthoring(AssetAuthoring &)=0 | nvidia::apex::ApexSDK | [pure virtual]
releaseAssetPreviewScene(AssetPreviewScene *nxScene)=0 | nvidia::apex::ApexSDK | [pure virtual]
releaseMemoryReadStream(PxFileBuf &stream)=0 | nvidia::apex::ApexSDK | [pure virtual]
releaseMemoryWriteStream(PxFileBuf &stream)=0 | nvidia::apex::ApexSDK | [pure virtual]
releaseModule(Module *module)=0 | nvidia::apex::ApexSDK | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseScene(Scene *)=0 | nvidia::apex::ApexSDK | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setEnableApexStats(bool enableApexStats)=0 | nvidia::apex::ApexSDK | [pure virtual]
setEnableConcurrencyCheck(bool enableConcurrencyChecks)=0 | nvidia::apex::ApexSDK | [pure virtual]
userData | nvidia::apex::ApexInterface |
~ApexSDK() (defined in nvidia::apex::ApexSDK) | nvidia::apex::ApexSDK | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::ApexSDKCachedData Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexSDKCachedData
Public Member Functions
nvidia::apex::ApexSDKCachedData Class Reference

A method for storing actor data in a scene. More...

#include <ApexSDKCachedData.h>

List of all members.

Public Member Functions

virtual ModuleCachedData * | getCacheForModule (AuthObjTypeID moduleID)=0
Retreives the scene cached data for the actor, if it exists.
virtual PxFileBuf & | serialize (PxFileBuf &) const =0
Save cache configuration to a stream.
virtual PxFileBuf & | deserialize (PxFileBuf &)=0
Load cache configuration from a stream.
virtual void | clear (bool force=true)=0
Clear data.

Detailed Description

A method for storing actor data in a scene.

Member Function Documentation

virtual ModuleCachedData* nvidia::apex::ApexSDKCachedData::getCacheForModule ( AuthObjTypeID moduleID ) [pure virtual]

Retreives the scene cached data for the actor, if it exists.

Otherwise returns NULL.

The documentation for this class was generated from the following file:
  • ApexSDKCachedData.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexSDKCachedData
nvidia::apex::ApexSDKCachedData Member List
This is the complete list of members for nvidia::apex::ApexSDKCachedData, including all inherited members.
ApexSDKCachedData() (defined in nvidia::apex::ApexSDKCachedData) | nvidia::apex::ApexSDKCachedData | [inline, protected]
clear(bool force=true)=0 | nvidia::apex::ApexSDKCachedData | [pure virtual]
deserialize(PxFileBuf &)=0 | nvidia::apex::ApexSDKCachedData | [pure virtual]
getCacheForModule(AuthObjTypeID moduleID)=0 | nvidia::apex::ApexSDKCachedData | [pure virtual]
serialize(PxFileBuf &) const =0 | nvidia::apex::ApexSDKCachedData | [pure virtual]
~ApexSDKCachedData() (defined in nvidia::apex::ApexSDKCachedData) | nvidia::apex::ApexSDKCachedData | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::ApexSDKDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexSDKDesc
Public Member Functions | Public Attributes
nvidia::apex::ApexSDKDesc Class Reference

Descriptor class for ApexSDK. More...

#include <ApexSDK.h>

Inheritance diagram for nvidia::apex::ApexSDKDesc:
nvidia::apex::ApexDesc

List of all members.

Public Member Functions

PX_INLINE | ApexSDKDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE bool | isValid () const
Returns true if the descriptor is valid.

Public Attributes

PxFoundation * | foundation
The PxFoundation you are building with.
uint32_t | physXSDKVersion
The PhysX SDK version you are building with.
PxPhysics * | physXSDK
Pointer to the physX sdk (PhysX SDK version specific structure)
PxCooking * | cooking
Pointer to the cooking interface (PhysX SDK version specific structure)
PxPvd * | pvd
Pointer to PVD (optional)
UserRenderResourceManager * renderResourceManager
User defined interface for creating renderable resources.
ResourceCallback * resourceCallback
Pointer to a user-callback for unresolved named resources.
const char * | dllLoadPath
Path to APEX module DLLs (Windows Only)
const char * | wireframeMaterial
Wireframe material name.
const char * | solidShadedMaterial
Solid material name.
bool | renderMeshActorLoadMaterialsLazily
Delays material loading.
const char * | dllNamePostfix
APEX module DLL name postfix (Windows Only)
const char * | appGuid
Application-specific GUID (Windows Only)
bool | resourceProviderIsCaseSensitive
Sets the resource provider's case sensitive mode.
uint32_t | physXObjDescTableAllocationIncrement
Sets the number of physX object descriptor table entries that are allocated when it gets full.
bool | enableConcurrencyCheck
Enables warnings upon detection of concurrent access to the APEX SDK.

Detailed Description

Descriptor class for ApexSDK.

Member Function Documentation

PX_INLINE bool nvidia::apex::ApexSDKDesc::isValid ( ) const [inline]

Returns true if the descriptor is valid.

Returns:
true if the current settings are valid

Reimplemented from nvidia::apex::ApexDesc.

Member Data Documentation

const char* nvidia::apex::ApexSDKDesc::appGuid

Application-specific GUID (Windows Only)

Provide an optional appGuid if you have made local modifications to your APEX DLLs. Application GUIDs are available from NVIDIA. For non-Windows platforms the appGuid is ignored.

const char* nvidia::apex::ApexSDKDesc::dllLoadPath

Path to APEX module DLLs (Windows Only)

If specified, this string will be prepended to the APEX module names prior to calling LoadLibrary() to load them. You can use this mechanism to ship the APEX module DLLS into their own subdirectory. For example: "APEX/"

const char* nvidia::apex::ApexSDKDesc::dllNamePostfix

APEX module DLL name postfix (Windows Only)

If specified, this string will be appended to the APEX module DLL names prior to calling LoadLibrary() to load them. You can use this mechanism to load the APEX module DLLS for two different PhysX SDKs in the same process (DCC tools).

For example, the APEX_Destructible_x86.dll is renamed to APEX_Destructible_x86_PhysX-2.8.4.dll. dllNamePostfix would be "_PhysX-2.8.4"

uint32_t nvidia::apex::ApexSDKDesc::physXSDKVersion

The PhysX SDK version you are building with.

A particular APEX build will be against a particular PhysX version except the case physXSDKVersion = 0. If physXSDKVersion = 0 APEX will be built without PhysX. Versioning the PhysX API will require versioning of APEX.

bool nvidia::apex::ApexSDKDesc::renderMeshActorLoadMaterialsLazily

Delays material loading.

Any RenderMeshActor will issue callbacks to the ResourceCallback to create one or more materials. This happens either at actor creation or lazily during updateRenderResource upon necessity. Additionally it will call UserRenderResourceManager::getMaxBonesPerMaterial for the freshly created material right after a successful material creation. If this is set to true, the updateRenderResource calls should not run asynchronously.

ResourceCallback* nvidia::apex::ApexSDKDesc::resourceCallback

Pointer to a user-callback for unresolved named resources.

This function will be called by APEX when an unresolved named resource is requested. The function will be called at most once for each named resource. The function must directly return the pointer to the resource or NULL.

bool nvidia::apex::ApexSDKDesc::resourceProviderIsCaseSensitive

Sets the resource provider's case sensitive mode.

Note:
This is a reference to the ResourceProvider string lookups
const char* nvidia::apex::ApexSDKDesc::solidShadedMaterial

Solid material name.

If specified, this string designates the material to use when rendering solid shaded (per vertex color) lit triangles. If not specified, the default value is "ApexSolidShaded"

const char* nvidia::apex::ApexSDKDesc::wireframeMaterial

Wireframe material name.

If specified, this string designates the material to use when rendering wireframe data. It not specified, the default value is "ApexWireframe"

The documentation for this class was generated from the following file:
  • ApexSDK.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexSDKDesc
nvidia::apex::ApexSDKDesc Member List
This is the complete list of members for nvidia::apex::ApexSDKDesc, including all inherited members.
ApexDesc() | nvidia::apex::ApexDesc | [inline]
ApexSDKDesc() | nvidia::apex::ApexSDKDesc | [inline]
appGuid | nvidia::apex::ApexSDKDesc |
cooking | nvidia::apex::ApexSDKDesc |
dllLoadPath | nvidia::apex::ApexSDKDesc |
dllNamePostfix | nvidia::apex::ApexSDKDesc |
enableConcurrencyCheck | nvidia::apex::ApexSDKDesc |
foundation | nvidia::apex::ApexSDKDesc |
isValid() const | nvidia::apex::ApexSDKDesc | [inline]
physXObjDescTableAllocationIncrement | nvidia::apex::ApexSDKDesc |
physXSDK | nvidia::apex::ApexSDKDesc |
physXSDKVersion | nvidia::apex::ApexSDKDesc |
pvd | nvidia::apex::ApexSDKDesc |
renderMeshActorLoadMaterialsLazily | nvidia::apex::ApexSDKDesc |
renderResourceManager | nvidia::apex::ApexSDKDesc |
resourceCallback | nvidia::apex::ApexSDKDesc |
resourceProviderIsCaseSensitive | nvidia::apex::ApexSDKDesc |
setToDefault() | nvidia::apex::ApexSDKDesc | [inline]
solidShadedMaterial | nvidia::apex::ApexSDKDesc |
userData | nvidia::apex::ApexDesc |
wireframeMaterial | nvidia::apex::ApexSDKDesc |
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::Asset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Asset
Public Member Functions
nvidia::apex::Asset Class Reference

Base class of all APEX assets. More...

#include <Asset.h>

Inheritance diagram for nvidia::apex::Asset:
nvidia::apex::ApexInterface nvidia::apex::RWLockable nvidia::apex::BasicFSAsset nvidia::apex::ClothingAsset nvidia::apex::DestructibleAsset nvidia::apex::EffectPackageAsset nvidia::apex::EmitterAsset nvidia::apex::FlameEmitterAsset nvidia::apex::ForceFieldAsset nvidia::apex::GroundEmitterAsset nvidia::apex::HeatSourceAsset nvidia::apex::ImpactEmitterAsset nvidia::apex::IofxAsset nvidia::apex::IosAsset nvidia::apex::RenderMeshAsset nvidia::apex::SubstanceSourceAsset nvidia::apex::TurbulenceFSAsset nvidia::apex::VelocitySourceAsset

List of all members.

Public Member Functions

virtual const char * | getName () const =0
Returns the name of this deserialized asset.
virtual AuthObjTypeID | getObjTypeID () const =0
Returns the ID of the asset's authorable object type.
virtual const char * | getObjTypeName () const =0
Returns the name of this asset's authorable object type.
virtual uint32_t | forceLoadAssets ()=0
Returns the number of assets force loaded by all of this asset's named asset references.
virtual
::NvParameterized::Interface * 		getDefaultActorDesc ()=0
Returns the default actor descriptor NvParamaterized interface Memory ownership stays with this asset. The user may modify the interface values, but they will not persist past another acll to 'getDefaultActorDesc' Typically used to create an actor after making small local editing changes.
virtual
::NvParameterized::Interface * 		getDefaultAssetPreviewDesc ()=0
Returns the default AssetPreview descriptor NvParamaterized interface.
virtual const
::NvParameterized::Interface * 		getAssetNvParameterized () const =0
Returns the asset's NvParamaterized interface This cannot be directly modified! It is read only to the user.
virtual Actor * | createApexActor (const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0
Creates an Actor representing the Asset in a Scene.
virtual AssetPreview * | createApexAssetPreview (const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0
Creates an Asset Preview for the asset.
virtual
NvParameterized::Interface * 		releaseAndReturnNvParameterizedInterface (void)=0
Releases the ApexAsset but returns the NvParameterized::Interface and *ownership* to the caller.
virtual bool | isValidForActorCreation (const ::NvParameterized::Interface &actorParams, Scene &) const =0
Returns true if the asset is in a state that is valid for creating an actor.
virtual bool | isDirty () const =0
Returns true if the parameterized object of the asset has been modified.

Detailed Description

Base class of all APEX assets.

Member Function Documentation

virtual AuthObjTypeID nvidia::apex::Asset::getObjTypeID ( ) const [pure virtual]

Returns the ID of the asset's authorable object type.

Every asset will correspond to an APEX authorable object type. The module must register those types with the SDK at startup.

virtual bool nvidia::apex::Asset::isDirty ( ) const [pure virtual]

Returns true if the parameterized object of the asset has been modified.

This flag will be reset once the parameterized object has been serialized again.

virtual bool nvidia::apex::Asset::isValidForActorCreation | ( | const ::NvParameterized::Interface & | actorParams,
 |  | Scene & |
 | ) |  | const [pure virtual]

Returns true if the asset is in a state that is valid for creating an actor.

Parameters:
actorParams parameters of actor to create
Returns:
true if call to createApexActor will return true on inputs, false otherwise
The documentation for this class was generated from the following file:
  • Asset.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Asset
nvidia::apex::Asset Member List
This is the complete list of members for nvidia::apex::Asset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::AssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • AssetAuthoring
Public Member Functions
nvidia::apex::AssetAuthoring Class Reference

base class of all APEX asset authoring classes More...

#include <Asset.h>

Inheritance diagram for nvidia::apex::AssetAuthoring:
nvidia::apex::ApexInterface nvidia::apex::RWLockable nvidia::apex::BasicFSAssetAuthoring nvidia::apex::BasicIosAssetAuthoring nvidia::apex::ClothingAssetAuthoring nvidia::apex::DestructibleAssetAuthoring nvidia::apex::EffectPackageAssetAuthoring nvidia::apex::EmitterAssetAuthoring nvidia::apex::FlameEmitterAssetAuthoring nvidia::apex::ForceFieldAssetAuthoring nvidia::apex::GroundEmitterAssetAuthoring nvidia::apex::HeatSourceAssetAuthoring nvidia::apex::ImpactEmitterAssetAuthoring nvidia::apex::IofxAssetAuthoring nvidia::apex::ParticleIosAssetAuthoring nvidia::apex::RenderMeshAssetAuthoring nvidia::apex::SubstanceSourceAssetAuthoring nvidia::apex::TurbulenceFSAssetAuthoring nvidia::apex::VelocitySourceAssetAuthoring

List of all members.

Public Member Functions

virtual const char * | getName () const =0
Returns the name of asset author.
virtual const char * | getObjTypeName () const =0
Returns the name of this APEX authorable object type.
virtual bool | prepareForPlatform (nvidia::apex::PlatformTag)=0
Prepares a fully authored Asset Authoring object for a specified platform.
virtual
::NvParameterized::Interface * 		getNvParameterized () const =0
Returns the asset's NvParameterized interface, may return NULL.
virtual
NvParameterized::Interface * 		releaseAndReturnNvParameterizedInterface (void)=0
Releases the ApexAsset but returns the NvParameterized::Interface and *ownership* to the caller.
virtual void | setToolString (const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0
Generates a string that is stored in the asset with all the relevant information about the build.

Detailed Description

base class of all APEX asset authoring classes

Member Function Documentation

virtual void nvidia::apex::AssetAuthoring::setToolString | ( | const char * | toolName,
 |  | const char * | toolVersion,
 |  | uint32_t | toolChangelist
 | ) |  | [pure virtual]

Generates a string that is stored in the asset with all the relevant information about the build.

Parameters:
toolName | The name of the tool with proper casing, i.e. "Clothing Tool".
toolVersion | The version of the tool as a string, can be NULL.
toolChangelist | The CL# of the tool, will use internal tools directory CL if 0
The documentation for this class was generated from the following file:
  • Asset.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • AssetAuthoring
nvidia::apex::AssetAuthoring Member List
This is the complete list of members for nvidia::apex::AssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::AssetPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • AssetPreview
Public Member Functions
nvidia::apex::AssetPreview Class Reference

Base class of all APEX asset previews. More...

#include <AssetPreview.h>

Inheritance diagram for nvidia::apex::AssetPreview:
nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider nvidia::apex::AttractorFSPreview nvidia::apex::ClothingPreview nvidia::apex::DestructiblePreview nvidia::apex::EmitterPreview nvidia::apex::FlameEmitterPreview nvidia::apex::ForceFieldPreview nvidia::apex::GroundEmitterPreview nvidia::apex::HeatSourcePreview nvidia::apex::ImpactEmitterPreview nvidia::apex::JetFSPreview nvidia::apex::NoiseFSPreview nvidia::apex::ParticlesPreview nvidia::apex::TurbulenceFSPreview nvidia::apex::VelocitySourcePreview nvidia::apex::VortexFSPreview nvidia::apex::WindFSPreview

List of all members.

Public Member Functions

virtual void | setPose (const PxMat44 &pose)=0
Set the preview instance's world pose. This may include scaling.
virtual const PxMat44 | getPose () const =0
Get the preview instance's world pose.

Detailed Description

Base class of all APEX asset previews.

The preview is a lightweight Renderable instance which can be rendered without having to create an ApexScene. It is intended to be used by level editors to place assets within a level.

Member Function Documentation

virtual const PxMat44 nvidia::apex::AssetPreview::getPose ( ) const [pure virtual]

Get the preview instance's world pose.

Note:
can't return by reference as long as the internal representation is not identical.
The documentation for this class was generated from the following file:
  • AssetPreview.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • AssetPreview
nvidia::apex::AssetPreview Member List
This is the complete list of members for nvidia::apex::AssetPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::AssetPreviewScene Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • AssetPreviewScene
Public Member Functions
nvidia::apex::AssetPreviewScene Class Reference

An APEX class for. More...

#include <AssetPreviewScene.h>

Inheritance diagram for nvidia::apex::AssetPreviewScene:
nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual void | setCameraMatrix (const PxMat44 &viewTransform)=0
Sets the view matrix. Should be called whenever the view matrix needs to be updated.
virtual PxMat44 | getCameraMatrix () const =0
Returns the view matrix set by the user for the given viewID.
virtual void | setShowFullInfo (bool showFullInfo)=0
Sets whether the asset preview should simply show asset names or many other parameter values.
virtual bool | getShowFullInfo () const =0
Get the bool which determines whether the asset preview shows just asset names or parameter values.

Detailed Description

An APEX class for.

The documentation for this class was generated from the following file:
  • AssetPreviewScene.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • AssetPreviewScene
nvidia::apex::AssetPreviewScene Member List
This is the complete list of members for nvidia::apex::AssetPreviewScene, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getCameraMatrix() const =0 | nvidia::apex::AssetPreviewScene | [pure virtual]
getShowFullInfo() const =0 | nvidia::apex::AssetPreviewScene | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setCameraMatrix(const PxMat44 &viewTransform)=0 | nvidia::apex::AssetPreviewScene | [pure virtual]
setShowFullInfo(bool showFullInfo)=0 | nvidia::apex::AssetPreviewScene | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::AttractorFSActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • AttractorFSActor
Public Member Functions
nvidia::apex::AttractorFSActor Class Reference

AttractorFS Actor class. More...

#include <AttractorFSActor.h>

Inheritance diagram for nvidia::apex::AttractorFSActor:
nvidia::apex::Actor nvidia::apex::Renderable nvidia::apex::ApexInterface nvidia::apex::RenderDataProvider nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual BasicFSAsset * | getAttractorFSAsset () const =0
Returns the asset the instance has been created from.
virtual PxVec3 | getCurrentPosition () const =0
Gets the current position of the actor.
virtual void | setCurrentPosition (const PxVec3 &pos)=0
Sets the current position of the actor.
virtual void | setFieldRadius (float)=0
Sets the attracting radius of the field.
virtual void | setConstFieldStrength (float)=0
Sets strength of the constant part of attracting field.
virtual void | setVariableFieldStrength (float)=0
Sets strength coefficient for variable part of attracting field.
virtual void | setEnabled (bool isEnabled)=0
Enable/Disable the field simulation.
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.

Detailed Description

AttractorFS Actor class.

The documentation for this class was generated from the following file:
  • AttractorFSActor.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • AttractorFSActor
nvidia::apex::AttractorFSActor Member List
This is the complete list of members for nvidia::apex::AttractorFSActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getAttractorFSAsset() const =0 | nvidia::apex::AttractorFSActor | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getCurrentPosition() const =0 | nvidia::apex::AttractorFSActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::AttractorFSActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setConstFieldStrength(float)=0 | nvidia::apex::AttractorFSActor | [pure virtual]
setCurrentPosition(const PxVec3 &pos)=0 | nvidia::apex::AttractorFSActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::AttractorFSActor | [pure virtual]
setEnabled(bool isEnabled)=0 | nvidia::apex::AttractorFSActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setFieldRadius(float)=0 | nvidia::apex::AttractorFSActor | [pure virtual]
setVariableFieldStrength(float)=0 | nvidia::apex::AttractorFSActor | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~AttractorFSActor() (defined in nvidia::apex::AttractorFSActor) | nvidia::apex::AttractorFSActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::AttractorFSPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • AttractorFSPreview
Public Member Functions
nvidia::apex::AttractorFSPreview Class Reference

This class provides the asset preview for APEX AttractorFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

#include <AttractorFSPreview.h>

Inheritance diagram for nvidia::apex::AttractorFSPreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void | setRadius (float radius)=0
Set the radius of the attractor.
virtual void | setDetailLevel (uint32_t detail)=0

Detailed Description

This class provides the asset preview for APEX AttractorFS Assets. The class provides multiple levels of prevew detail that can be selected individually.

Member Function Documentation

virtual void nvidia::apex::AttractorFSPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable.
Any, all, or none of the following masks may be added together to select what should be drawn.
The defines for the individual items are:
ATTRACT_DRAW_NOTHING - draw nothing
ATTRACT_DRAW_SHAPE - draw the shape
ATTRACT_DRAW_ASSET_INFO - draw the turbulencefs asset info in the screen space
ATTRACT_DRAW_FULL_DETAIL - draw all components of the turbulencefs preview
All items may be drawn using the macro DRAW_FULL_DETAIL.

The documentation for this class was generated from the following file:
  • AttractorFSPreview.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • AttractorFSPreview
nvidia::apex::AttractorFSPreview Member List
This is the complete list of members for nvidia::apex::AttractorFSPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setDetailLevel(uint32_t detail)=0 | nvidia::apex::AttractorFSPreview | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
setRadius(float radius)=0 | nvidia::apex::AttractorFSPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::BasicFSAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BasicFSAsset
nvidia::apex::BasicFSAsset Class Reference

BasicFS Asset class. More...

#include <BasicFSAsset.h>

Inheritance diagram for nvidia::apex::BasicFSAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

BasicFS Asset class.

The documentation for this class was generated from the following file:
  • BasicFSAsset.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BasicFSAsset
nvidia::apex::BasicFSAsset Member List
This is the complete list of members for nvidia::apex::BasicFSAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~BasicFSAsset() (defined in nvidia::apex::BasicFSAsset) | nvidia::apex::BasicFSAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::BasicFSAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BasicFSAssetAuthoring
nvidia::apex::BasicFSAssetAuthoring Class Reference

BasicFS Asset Authoring class. More...

#include <BasicFSAsset.h>

Inheritance diagram for nvidia::apex::BasicFSAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

BasicFS Asset Authoring class.

The documentation for this class was generated from the following file:
  • BasicFSAsset.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BasicFSAssetAuthoring
nvidia::apex::BasicFSAssetAuthoring Member List
This is the complete list of members for nvidia::apex::BasicFSAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
~BasicFSAssetAuthoring() (defined in nvidia::apex::BasicFSAssetAuthoring) | nvidia::apex::BasicFSAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::BasicIosActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BasicIosActor
Public Member Functions
nvidia::apex::BasicIosActor Class Reference

BasicIOS Actor. A simple actor that simulates a particle system. More...

#include <BasicIosActor.h>

Inheritance diagram for nvidia::apex::BasicIosActor:
nvidia::apex::Actor nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual float | getParticleRadius () const =0
Get the particle radius.
virtual float | getRestDensity () const =0
Get the particle rest density.
virtual uint32_t | getParticleCount () const =0
Get the current number of particles.

Detailed Description

BasicIOS Actor. A simple actor that simulates a particle system.

The documentation for this class was generated from the following file:
  • BasicIosActor.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BasicIosActor
nvidia::apex::BasicIosActor Member List
This is the complete list of members for nvidia::apex::BasicIosActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getParticleCount() const =0 | nvidia::apex::BasicIosActor | [pure virtual]
getParticleRadius() const =0 | nvidia::apex::BasicIosActor | [pure virtual]
getRestDensity() const =0 | nvidia::apex::BasicIosActor | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~BasicIosActor() (defined in nvidia::apex::BasicIosActor) | nvidia::apex::BasicIosActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::BasicIosAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BasicIosAsset
Public Member Functions
nvidia::apex::BasicIosAsset Class Reference

APEX Particle System Asset. More...

#include <BasicIosAsset.h>

Inheritance diagram for nvidia::apex::BasicIosAsset:
nvidia::apex::IosAsset nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual float | getParticleRadius () const =0
Get the radius of a particle.
virtual float | getRestDensity () const =0
Get the rest density of a particle.
virtual float | getMaxInjectedParticleCount () const =0
Get the maximum number of particles that are allowed to be newly created on each frame.
virtual uint32_t | getMaxParticleCount () const =0
Get the maximum number of particles that this IOS can simulate.
virtual float | getParticleMass () const =0
Get the mass of a particle.

Detailed Description

APEX Particle System Asset.

The documentation for this class was generated from the following file:
  • BasicIosAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BasicIosAsset
nvidia::apex::BasicIosAsset Member List
This is the complete list of members for nvidia::apex::BasicIosAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
createIosActor(Scene &scene, IofxAsset *iofxAsset)=0 | nvidia::apex::IosAsset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getMaxInjectedParticleCount() const =0 | nvidia::apex::BasicIosAsset | [pure virtual]
getMaxParticleCount() const =0 | nvidia::apex::BasicIosAsset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
getParticleMass() const =0 | nvidia::apex::BasicIosAsset | [pure virtual]
getParticleRadius() const =0 | nvidia::apex::BasicIosAsset | [pure virtual]
getRestDensity() const =0 | nvidia::apex::BasicIosAsset | [pure virtual]
getSupportsDensity() const =0 | nvidia::apex::IosAsset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseIosActor(Actor &actor)=0 | nvidia::apex::IosAsset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~BasicIosAsset() (defined in nvidia::apex::BasicIosAsset) | nvidia::apex::BasicIosAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::BasicIosAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BasicIosAssetAuthoring
Public Member Functions
nvidia::apex::BasicIosAssetAuthoring Class Reference

APEX Particle System Asset Authoring class. More...

#include <BasicIosAsset.h>

Inheritance diagram for nvidia::apex::BasicIosAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual void | setParticleRadius (float)=0
Set the radius of a particle.
virtual void | setRestDensity (float)=0
Set the rest density of a particle.
virtual void | setMaxInjectedParticleCount (float count)=0
Set the maximum number of particles that are allowed to be newly created on each frame.
virtual void | setMaxParticleCount (uint32_t count)=0
Set the maximum number of particles that this IOS can simulate.
virtual void | setParticleMass (float)=0
Set the mass of a particle.
virtual void | setCollisionGroupName (const char *collisionGroupName)=0
Set the (NRP) name for the collision group.
virtual void | setCollisionGroupMaskName (const char *collisionGroupMaskName)=0
Set the (NRP) name for the collision group mask.

Detailed Description

APEX Particle System Asset Authoring class.

The documentation for this class was generated from the following file:
  • BasicIosAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BasicIosAssetAuthoring
nvidia::apex::BasicIosAssetAuthoring Member List
This is the complete list of members for nvidia::apex::BasicIosAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setCollisionGroupMaskName(const char *collisionGroupMaskName)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
setCollisionGroupName(const char *collisionGroupName)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
setMaxInjectedParticleCount(float count)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
setMaxParticleCount(uint32_t count)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
setParticleMass(float)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
setParticleRadius(float)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
setRestDensity(float)=0 | nvidia::apex::BasicIosAssetAuthoring | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
~BasicIosAssetAuthoring() (defined in nvidia::apex::BasicIosAssetAuthoring) | nvidia::apex::BasicIosAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::BoxShape Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BoxShape
Public Member Functions
nvidia::apex::BoxShape Class Reference

helper Box shape More...

#include <Shape.h>

Inheritance diagram for nvidia::apex::BoxShape:
nvidia::apex::Shape

List of all members.

Public Member Functions

virtual void | setSize (PxVec3 size)=0
virtual PxVec3 | getSize () const =0
get size of the box

Detailed Description

helper Box shape

Member Function Documentation

virtual void nvidia::apex::BoxShape::setSize ( PxVec3 size ) [pure virtual]

set the length of the sides of the box. The default value is 1.0f for each of the sides. the size of the sides can also be changed by using the setPose method

The documentation for this class was generated from the following file:
  • Shape.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BoxShape
nvidia::apex::BoxShape Member List
This is the complete list of members for nvidia::apex::BoxShape, including all inherited members.
getAABB() const =0 | nvidia::apex::Shape | [pure virtual]
getPose() const =0 | nvidia::apex::Shape | [pure virtual]
getPreviousPose() const =0 | nvidia::apex::Shape | [pure virtual]
getSize() const =0 | nvidia::apex::BoxShape | [pure virtual]
intersectAgainstAABB(PxBounds3)=0 | nvidia::apex::Shape | [pure virtual]
isBoxGeom() const | nvidia::apex::Shape | [inline, virtual]
isCapsuleGeom() const | nvidia::apex::Shape | [inline, virtual]
isHalfSpaceGeom() const | nvidia::apex::Shape | [inline, virtual]
isSphereGeom() const | nvidia::apex::Shape | [inline, virtual]
releaseApexShape()=0 | nvidia::apex::Shape | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::Shape | [pure virtual]
setSize(PxVec3 size)=0 | nvidia::apex::BoxShape | [pure virtual]
visualize(RenderDebugInterface *renderer) const =0 | nvidia::apex::Shape | [pure virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::CapsuleShape Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CapsuleShape
Public Member Functions
nvidia::apex::CapsuleShape Class Reference

helper the capsule is oriented along the y axis by default and its total height is height+2*radius More...

#include <Shape.h>

Inheritance diagram for nvidia::apex::CapsuleShape:
nvidia::apex::Shape

List of all members.

Public Member Functions

virtual void | getDimensions (float &height, float &radius) const =0
get height and radius of the capsule
virtual void | setDimensions (float height, float radius)=0
set height and radius of the capsule

Detailed Description

helper the capsule is oriented along the y axis by default and its total height is height+2*radius

The documentation for this class was generated from the following file:
  • Shape.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CapsuleShape
nvidia::apex::CapsuleShape Member List
This is the complete list of members for nvidia::apex::CapsuleShape, including all inherited members.
getAABB() const =0 | nvidia::apex::Shape | [pure virtual]
getDimensions(float &height, float &radius) const =0 | nvidia::apex::CapsuleShape | [pure virtual]
getPose() const =0 | nvidia::apex::Shape | [pure virtual]
getPreviousPose() const =0 | nvidia::apex::Shape | [pure virtual]
intersectAgainstAABB(PxBounds3)=0 | nvidia::apex::Shape | [pure virtual]
isBoxGeom() const | nvidia::apex::Shape | [inline, virtual]
isCapsuleGeom() const | nvidia::apex::Shape | [inline, virtual]
isHalfSpaceGeom() const | nvidia::apex::Shape | [inline, virtual]
isSphereGeom() const | nvidia::apex::Shape | [inline, virtual]
releaseApexShape()=0 | nvidia::apex::Shape | [pure virtual]
setDimensions(float height, float radius)=0 | nvidia::apex::CapsuleShape | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::Shape | [pure virtual]
visualize(RenderDebugInterface *renderer) const =0 | nvidia::apex::Shape | [pure virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::ClothingActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingActor
Public Member Functions
nvidia::apex::ClothingActor Class Reference

Instance of ClothingAsset. Can be positioned, animated, updated and rendered. More...

#include <ClothingActor.h>

Inheritance diagram for nvidia::apex::ClothingActor:
nvidia::apex::Actor nvidia::apex::Renderable nvidia::apex::ApexInterface nvidia::apex::RenderDataProvider nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual
::NvParameterized::Interface * 		getActorDesc ()=0
Returns a reference to the actor descriptor as it is held by the ClothingActor.
virtual void | updateState (const PxMat44 &globalPose, const PxMat44 *newBoneMatrices, uint32_t boneMatricesByteStride, uint32_t numBoneMatrices, ClothingTeleportMode::Enum teleportMode)=0
Updates all internal bone matrices. This should be called with updated information before apex scenes start simulating.
virtual void | updateMaxDistanceScale (float scale, bool multipliable)=0
Change the max distance of all active vertices with a scalar parameter.
virtual const PxMat44 & | getGlobalPose () const =0
returns the globalPose that was set with ClothingActor::updateState()
virtual void | setWind (float windAdaption, const PxVec3 &windVelocity)=0
Sets the wind strength and direction, can be called any time.
virtual void | setMaxDistanceBlendTime (float blendTime)=0
DEPRECATED Time in seconds how long it takes to go from 0 maxDistance to full maxDistance
virtual float | getMaxDistanceBlendTime () const =0
DEPRECATED Time in seconds how long it takes to go from 0 maxDistance to full maxDistance
virtual void | setVisible (bool enable)=0
Tells the actor if it will be rendered or not. If an actor is simulated, but not rendered, some computations (skinning, normal and tangent calculation) doesn't need to be done.
virtual bool | isVisible () const =0
Returns the current visibility setting. The most recently set value is returned (i.e. the buffered value, not the actual value).
virtual void | setFrozen (bool enable)=0
Stops simulating the actor.
virtual bool | isFrozen () const =0
Returns if the simulation is currently stopped for this actor.
virtual ClothSolverMode::Enum | getClothSolverMode () const =0
Returns whether the actor is simulated using the 2.8.x or the 3.x cloth solver.
virtual void | setGraphicalLOD (uint32_t lod)=0
sets the graphical Lod This chooses the graphical mesh of all the meshes stored in the asset to be rendered. It has to be set before the simulate call to take effect for the next time the actor is rendered. Otherwise, the given value will be buffered and used as soon as possible.
virtual uint32_t | getGraphicalLod ()=0
returns the graphical Lod This returns the buffered most recently set graphical lod, even if it's not active yet.
virtual bool | rayCast (const PxVec3 &worldOrigin, const PxVec3 &worldDirection, float &time, PxVec3 &normal, uint32_t &vertexIndex)=0
Raycasts against the ClothingActor.
virtual void | attachVertexToGlobalPosition (uint32_t vertexIndex, const PxVec3 &globalPosition)=0
Attach a vertex to a global position.
virtual void | freeVertex (uint32_t vertexIndex)=0
Free a previously attached vertex.
virtual uint32_t | getClothingMaterial () const =0
Returns the actively selected material.
virtual void | setClothingMaterial (uint32_t index)=0
Sets which clothing material is used from the assets library.
virtual void | setOverrideMaterial (uint32_t submeshIndex, const char *overrideMaterialName)=0
Sets the override material for the submesh with the given index.
virtual void | setVelocityCallback (ClothingVelocityCallback *callback)=0
sets the velocity callback for an individual actor, turned off when NULL
virtual void | getPhysicalMeshPositions (void *buffer, uint32_t byteStride)=0
Returns the current position of all physics vertices.
virtual void | getPhysicalMeshNormals (void *buffer, uint32_t byteStride)=0
Returns the current normals of all physics vertices.
virtual float | getMaximumSimulationBudget () const =0
Returns how much an Actor will cost at maximum.
virtual uint32_t | getNumSimulationVertices () const =0
Returns the number of currently simulation vertices.
virtual const PxVec3 * | getSimulationPositions ()=0
Returns a pointer to the internal positions array of the simulated physics mesh Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)
virtual const PxVec3 * | getSimulationNormals ()=0
Returns a pointer to the internal normals array of the simulated physics mesh Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)
virtual bool | getSimulationVelocities (PxVec3 *velocities)=0
Writes the current velocities of the simulated vertices into the provided array. A buffer of getNumSimulationVertices() PxVec3's needs to be provided. The function cannot be called during simulation. Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)
virtual uint32_t | getNumGraphicalVerticesActive (uint32_t submeshIndex) const =0
Returns the number of the graphical vertices that need to be skinned to the simulation mesh [0, numGraphicalVerticesActive)
virtual PxMat44 | getRenderGlobalPose () const =0
Returns the transform that needs to be applied to the rendered mesh.
virtual const PxMat44 * | getCurrentBoneSkinningMatrices () const =0
Returns the current skinning matrices. The skinning matrices already contain the global pose of the actor.
virtual bool | isHalfPrecisionAllowed () const =0
return whether GPU solver can use half precision for storing positions.
virtual void | setHalfPrecision (bool isAllowed)=0
allow GPU solver to use half precision for storing positions.
virtual ClothingPlane * | createCollisionPlane (const PxPlane &plane)=0
Create a collision plane for the actor.
virtual ClothingConvex * | createCollisionConvex (ClothingPlane **planes, uint32_t numPlanes)=0
Create a collision convex for the actor, defined by planes.
virtual ClothingSphere * | createCollisionSphere (const PxVec3 &position, float radius)=0
Create a collision sphere for the actor.
virtual ClothingCapsule * | createCollisionCapsule (ClothingSphere &sphere1, ClothingSphere &sphere2)=0
Create a tapered collision capsule for the actor, defined by two spheres.
virtual ClothingTriangleMesh * | createCollisionTriangleMesh ()=0
Create a collision triangle mesh for the actor.
virtual ClothingRenderProxy * | acquireRenderProxy ()=0
Returns the Render Proxy for this clothing actor.

Detailed Description

Instance of ClothingAsset. Can be positioned, animated, updated and rendered.

Member Function Documentation

virtual ClothingRenderProxy* nvidia::apex::ClothingActor::acquireRenderProxy ( ) [pure virtual]

Returns the Render Proxy for this clothing actor.

Call this function after fetchResults to get the ClothingRenderProxy object that can be used to render the simulation reset. The render proxy can be acquired at any time, it contains the result from the last fetchResults call. It is recommended to acquire the render proxy after fetchResults and to release it before the next simulate call to prevent the memory overhead of buffering the render data. The data in the render proxy remains consistent until it is released (release returns the object into a pool from which it can be reused). The ClothingRenderProxy object is valid even after the release of the clothing actor. However it becomes invalid when the corresponding asset is released. Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)

Returns:
ClothingRenderProxy object with static render data. Can be acquired only once per frame, otherwise NULL is returned.
virtual ::NvParameterized::Interface* nvidia::apex::ClothingActor::getActorDesc ( ) [pure virtual]

Returns a reference to the actor descriptor as it is held by the ClothingActor.

This descriptor can be modified at any time, changes will only be read during the first part of the simulation.

virtual const PxMat44* nvidia::apex::ClothingActor::getCurrentBoneSkinningMatrices ( ) const [pure virtual]

Returns the current skinning matrices. The skinning matrices already contain the global pose of the actor.

Note:
Only valid after simulate.
virtual float nvidia::apex::ClothingActor::getMaxDistanceBlendTime ( ) const [pure virtual]

DEPRECATED Time in seconds how long it takes to go from 0 maxDistance to full maxDistance

Deprecated:
Use ClothingActor::getActorDesc() and read the maxDistanceBlendTime part of it
virtual uint32_t nvidia::apex::ClothingActor::getNumGraphicalVerticesActive ( uint32_t submeshIndex ) const [pure virtual]

Returns the number of the graphical vertices that need to be skinned to the simulation mesh [0, numGraphicalVerticesActive)

The rest must be regularly skinned to bones [numGraphicalVerticesActive, numVertices)

Note:
Only valid after simulate.
virtual uint32_t nvidia::apex::ClothingActor::getNumSimulationVertices ( ) const [pure virtual]

Returns the number of currently simulation vertices.

Note:
This is not to be used for getPhysicalMeshPositions. getNumSimulatedVertices returns the number of actually simulated verts, while getPhysicalMeshPositions returns the complete physical mesh, regardless of the current physical lod
virtual void nvidia::apex::ClothingActor::getPhysicalMeshNormals | ( | void * | buffer,
 |  | uint32_t | byteStride
 | ) |  | [pure virtual]

Returns the current normals of all physics vertices.

This method provides the normals of the currently simulated part of the physics mesh and skins the non-simulated part with the current bone positions.

Note:
This should usually not be needed other than for rendering the physics mesh yourself
Must be called in between Scene::fetchResults and Scene::simulate.
virtual void nvidia::apex::ClothingActor::getPhysicalMeshPositions | ( | void * | buffer,
 |  | uint32_t | byteStride
 | ) |  | [pure virtual]

Returns the current position of all physics vertices.

This method provides the positions of the currently simulated part of the physics mesh and skins the non-simulated part with the current bone positions.

Note:
This should usually not be needed other than for rendering the physics mesh yourself
Must be called in between Scene::fetchResults and Scene::simulate.
virtual PxMat44 nvidia::apex::ClothingActor::getRenderGlobalPose ( ) const [pure virtual]

Returns the transform that needs to be applied to the rendered mesh.

Note:
Only valid after simulate.
virtual const PxVec3* nvidia::apex::ClothingActor::getSimulationNormals ( ) [pure virtual]

Returns a pointer to the internal normals array of the simulated physics mesh Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)

Returns:
Pointer the simulation mesh normals
virtual const PxVec3* nvidia::apex::ClothingActor::getSimulationPositions ( ) [pure virtual]

Returns a pointer to the internal positions array of the simulated physics mesh Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)

Returns:
Pointer the simulation mesh positions
virtual bool nvidia::apex::ClothingActor::getSimulationVelocities ( PxVec3 * velocities ) [pure virtual]

Writes the current velocities of the simulated vertices into the provided array. A buffer of getNumSimulationVertices() PxVec3's needs to be provided. The function cannot be called during simulation. Blocks until the simulation and post simulation processing is done (with asyncFetchResult set to true)

Returns:
true if a simulation is available and the velocities have been written
virtual bool nvidia::apex::ClothingActor::isHalfPrecisionAllowed ( ) const [pure virtual]

return whether GPU solver can use half precision for storing positions.

Note:
If allowed half precision will be activated only when actors cannot be fitted to shared memory with float precision.
virtual bool nvidia::apex::ClothingActor::rayCast | ( | const PxVec3 & | worldOrigin,
 |  | const PxVec3 & | worldDirection,
 |  | float & | time,
 |  | PxVec3 & | normal,
 |  | uint32_t & | vertexIndex
 | ) |  | [pure virtual]

Raycasts against the ClothingActor.

Parameters:
[in] | worldOrigin | The world ray's origin
[in] | worldDirection | The world ray's direction, needs not to be normalized
[out] | time | Impact time
[out] | normal | Impact normal in world space
[out] | vertexIndex | Vertex index that was hit
Returns:
true if this actor is hit
virtual void nvidia::apex::ClothingActor::setGraphicalLOD ( uint32_t lod ) [pure virtual]

sets the graphical Lod This chooses the graphical mesh of all the meshes stored in the asset to be rendered. It has to be set before the simulate call to take effect for the next time the actor is rendered. Otherwise, the given value will be buffered and used as soon as possible.

Parameters:
[in] lod lod used to render the mesh
Note:
It is safe to call this even during simulation
virtual void nvidia::apex::ClothingActor::setHalfPrecision ( bool isAllowed ) [pure virtual]

allow GPU solver to use half precision for storing positions.

Note:
This option will be activated only when actors cannot be fitted to shared memory with float precision. Be aware half precision might be insufficient for some cloth simulation. Especially simulation with extensive self collisions sensitive to precision.
Parameters:
[in] isAllowed true - allow GPU solver to use half precision, false - don't allow
virtual void nvidia::apex::ClothingActor::setMaxDistanceBlendTime ( float blendTime ) [pure virtual]

DEPRECATED Time in seconds how long it takes to go from 0 maxDistance to full maxDistance

Deprecated:
Use ClothingActor::getActorDesc() and modify the maxDistanceBlendTime part of it Default: 1.0
Note:
This also influences how quickly different physical LoDs can be switched
It is safe to call this even during simulation.
virtual void nvidia::apex::ClothingActor::setVisible ( bool enable ) [pure virtual]

Tells the actor if it will be rendered or not. If an actor is simulated, but not rendered, some computations (skinning, normal and tangent calculation) doesn't need to be done.

disabling is set immediately, disabling is buffered for the next frame.

virtual void nvidia::apex::ClothingActor::setWind | ( | float | windAdaption,
 |  | const PxVec3 & | windVelocity
 | ) |  | [pure virtual]

Sets the wind strength and direction, can be called any time.

Deprecated:
Use ClothingActor::getActorDesc() and modify the wind part of it
Parameters:
[in] | windAdaption | The rate of adaption. The higher this value, the faster the cloth reaches the wind velocity. Set to 0 to turn off wind
[in] | windVelocity | The target velocity each vertex tries to achieve.
Note:
It is safe to call this even during simulation, but it will only have an effect after the next call to Scene::simulate()
virtual void nvidia::apex::ClothingActor::updateMaxDistanceScale | ( | float | scale,
 |  | bool | multipliable
 | ) |  | [pure virtual]

Change the max distance of all active vertices with a scalar parameter.

Parameters:
[in] | scale | Must be in [0,1] range
[in] | multipliable | Setting to define how the scale is applied. True will multiply the scale on top of the max distance, False will subtract the maximum max distance.
virtual void nvidia::apex::ClothingActor::updateState | ( | const PxMat44 & | globalPose,
 |  | const PxMat44 * | newBoneMatrices,
 |  | uint32_t | boneMatricesByteStride,
 |  | uint32_t | numBoneMatrices,
 |  | ClothingTeleportMode::Enum | teleportMode
 | ) |  | [pure virtual]

Updates all internal bone matrices. This should be called with updated information before apex scenes start simulating.

Parameters:
[in] | globalPose | The new location of the actor
[in] | newBoneMatrices | Pointer to the array of transformations that contain the composite bone transformations for the current frame
[in] | boneMatricesByteStride | stride of the bone matrices, must be bigger than sizeof(PxMat44)
[in] | numBoneMatrices | number of bone matrices available. This should correspond with the number of bones present in the asset
[in] | teleportMode | Setting this to anything but TM_Continuous will force apply a teleport and optionally a reset.
Note:
This must be called before Scene::simulate is called
The documentation for this class was generated from the following file:
  • ClothingActor.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingActor
nvidia::apex::ClothingActor Member List
This is the complete list of members for nvidia::apex::ClothingActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireRenderProxy()=0 | nvidia::apex::ClothingActor | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
attachVertexToGlobalPosition(uint32_t vertexIndex, const PxVec3 &globalPosition)=0 | nvidia::apex::ClothingActor | [pure virtual]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
createCollisionCapsule(ClothingSphere &sphere1, ClothingSphere &sphere2)=0 | nvidia::apex::ClothingActor | [pure virtual]
createCollisionConvex(ClothingPlane **planes, uint32_t numPlanes)=0 | nvidia::apex::ClothingActor | [pure virtual]
createCollisionPlane(const PxPlane &plane)=0 | nvidia::apex::ClothingActor | [pure virtual]
createCollisionSphere(const PxVec3 &position, float radius)=0 | nvidia::apex::ClothingActor | [pure virtual]
createCollisionTriangleMesh()=0 | nvidia::apex::ClothingActor | [pure virtual]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
freeVertex(uint32_t vertexIndex)=0 | nvidia::apex::ClothingActor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getActorDesc()=0 | nvidia::apex::ClothingActor | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getClothingMaterial() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getClothSolverMode() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getCurrentBoneSkinningMatrices() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getGlobalPose() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getGraphicalLod()=0 | nvidia::apex::ClothingActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getMaxDistanceBlendTime() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getMaximumSimulationBudget() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getNumGraphicalVerticesActive(uint32_t submeshIndex) const =0 | nvidia::apex::ClothingActor | [pure virtual]
getNumSimulationVertices() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getPhysicalMeshNormals(void *buffer, uint32_t byteStride)=0 | nvidia::apex::ClothingActor | [pure virtual]
getPhysicalMeshPositions(void *buffer, uint32_t byteStride)=0 | nvidia::apex::ClothingActor | [pure virtual]
getRenderGlobalPose() const =0 | nvidia::apex::ClothingActor | [pure virtual]
getSimulationNormals()=0 | nvidia::apex::ClothingActor | [pure virtual]
getSimulationPositions()=0 | nvidia::apex::ClothingActor | [pure virtual]
getSimulationVelocities(PxVec3 *velocities)=0 | nvidia::apex::ClothingActor | [pure virtual]
isFrozen() const =0 | nvidia::apex::ClothingActor | [pure virtual]
isHalfPrecisionAllowed() const =0 | nvidia::apex::ClothingActor | [pure virtual]
isVisible() const =0 | nvidia::apex::ClothingActor | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
rayCast(const PxVec3 &worldOrigin, const PxVec3 &worldDirection, float &time, PxVec3 &normal, uint32_t &vertexIndex)=0 | nvidia::apex::ClothingActor | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setClothingMaterial(uint32_t index)=0 | nvidia::apex::ClothingActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setFrozen(bool enable)=0 | nvidia::apex::ClothingActor | [pure virtual]
setGraphicalLOD(uint32_t lod)=0 | nvidia::apex::ClothingActor | [pure virtual]
setHalfPrecision(bool isAllowed)=0 | nvidia::apex::ClothingActor | [pure virtual]
setMaxDistanceBlendTime(float blendTime)=0 | nvidia::apex::ClothingActor | [pure virtual]
setOverrideMaterial(uint32_t submeshIndex, const char *overrideMaterialName)=0 | nvidia::apex::ClothingActor | [pure virtual]
setVelocityCallback(ClothingVelocityCallback *callback)=0 | nvidia::apex::ClothingActor | [pure virtual]
setVisible(bool enable)=0 | nvidia::apex::ClothingActor | [pure virtual]
setWind(float windAdaption, const PxVec3 &windVelocity)=0 | nvidia::apex::ClothingActor | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateMaxDistanceScale(float scale, bool multipliable)=0 | nvidia::apex::ClothingActor | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateState(const PxMat44 &globalPose, const PxMat44 *newBoneMatrices, uint32_t boneMatricesByteStride, uint32_t numBoneMatrices, ClothingTeleportMode::Enum teleportMode)=0 | nvidia::apex::ClothingActor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~ClothingActor() (defined in nvidia::apex::ClothingActor) | nvidia::apex::ClothingActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingAsset
Public Member Functions
nvidia::apex::ClothingAsset Class Reference

A clothing asset. It contains all the static and shared data for a given piece of clothing. More...

#include <ClothingAsset.h>

Inheritance diagram for nvidia::apex::ClothingAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual uint32_t | getNumActors () const =0
Returns the number of ClothingActors this asset has created.
virtual ClothingActor * | getActor (uint32_t index)=0
Returns the index'th ClothingActor.
virtual PxBounds3 | getBoundingBox () const =0
Returns the bounding box for the asset.
virtual uint32_t | getNumGraphicalLodLevels () const =0
returns the number of LOD levels present in this asset
virtual uint32_t | getGraphicalLodValue (uint32_t lodLevel) const =0
returns the actual LOD value of any particular level, normally this is just the identity map
virtual float | getBiggestMaxDistance () const =0
returns the biggest max distance of any vertex in any physical mesh
virtual ClothSolverMode::Enum | getClothSolverMode () const =0
returns for which solver the asset has been cooked for.
virtual bool | remapBoneIndex (const char *name, uint32_t newIndex)=0
remaps bone with given name to a new index for updateState calls
virtual uint32_t | getNumBones () const =0
Returns the number of bones.
virtual uint32_t | getNumUsedBones () const =0
Returns the number of bones that are actually used. They are the first ones internally.
virtual const char * | getBoneName (uint32_t internalIndex) const =0
Returns the name of the bone at the given internal index.
virtual bool | getBoneBasePose (uint32_t internalIndex, PxMat44 &result) const =0
Returns the bind pose transform for this bone.
virtual void | getBoneMapping (uint32_t *internal2externalMap) const =0
returns the mapping from internal to external indices for a given asset.
virtual const RenderMeshAsset * | getRenderMeshAsset (uint32_t lodLevel) const =0
Gets the RenderMeshAsset associated with this asset.
virtual uint32_t | prepareMorphTargetMapping (const PxVec3 *originalPositions, uint32_t numPositions, float epsilon)=0
Prepares the asset for use with morph target.
virtual uint32_t | getMeshSkinningMapSize (uint32_t lod)=0
Returns the size of the mesh skinning map.
virtual void | getMeshSkinningMap (uint32_t lod, ClothingMeshSkinningMap *map)=0
Provides the mesh to mesh skinning map.
virtual bool | releaseGraphicalData ()=0
Releases all data needed to compute render data in apex clothing.

Detailed Description

A clothing asset. It contains all the static and shared data for a given piece of clothing.

Member Function Documentation

virtual void nvidia::apex::ClothingAsset::getBoneMapping ( uint32_t * internal2externalMap ) const [pure virtual]

returns the mapping from internal to external indices for a given asset.

Use this map to transform all the boneIndices returned from the ClothingPhysicalMesh into the order you specified initially

virtual void nvidia::apex::ClothingAsset::getMeshSkinningMap | ( | uint32_t | lod,
 |  | ClothingMeshSkinningMap * | map
 | ) |  | [pure virtual]

Provides the mesh to mesh skinning map.

This map stores for each graphics mesh vertex the corresponding triangle indices of the physics mesh and barycentric coordinates to skin the vertex position, normal and tangent.

Note:
This call has the side effect of merging the immediate map into the mesh skinning map. This might affect skinning performance done by APEX.
Parameters:
[in] | lod | lod for which the map is requested
[out] | map | Skinning map
virtual uint32_t nvidia::apex::ClothingAsset::getMeshSkinningMapSize ( uint32_t lod ) [pure virtual]

Returns the size of the mesh skinning map.

Note:
This call has the side effect of merging the immediate map into the mesh skinning map. This might affect skinning performance done by APEX.
Returns:
Number of entries in the map
virtual const RenderMeshAsset* nvidia::apex::ClothingAsset::getRenderMeshAsset ( uint32_t lodLevel ) const [pure virtual]

Gets the RenderMeshAsset associated with this asset.

Parameters:
[in] lodLevel The LoD level of the render mesh asset
Returns:
NULL if lodLevel is not valid
See also:
ClothingAsset::getNumGraphicalLodLevels()
virtual uint32_t nvidia::apex::ClothingAsset::prepareMorphTargetMapping | ( | const PxVec3 * | originalPositions,
 |  | uint32_t | numPositions,
 |  | float | epsilon
 | ) |  | [pure virtual]

Prepares the asset for use with morph target.

When setting morph target displacements, the asset needs to create a mapping of external to internal vertex order. These positions will be matched with the internal mesh positions with a smallest distance criterion.

Parameters:
[in] | originalPositions | Array of positions before the morphing is applied.
[in] | numPositions | Length of the Array
[in] | epsilon | Difference two vertices can have before being reported
Returns:
Number of vertices for which the distance to the next originalPosition was larger than epsilon
virtual bool nvidia::apex::ClothingAsset::remapBoneIndex | ( | const char * | name,
 |  | uint32_t | newIndex
 | ) |  | [pure virtual]

remaps bone with given name to a new index for updateState calls

This is needed when the order of bones differs from authoring tool to runtime

Note:
must be called after asset is deserialized. Changing this any later, especially after the first ClothingActor::updateState call will lead to ill-defined behavior.
The documentation for this class was generated from the following file:
  • ClothingAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingAsset
nvidia::apex::ClothingAsset Member List
This is the complete list of members for nvidia::apex::ClothingAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getActor(uint32_t index)=0 | nvidia::apex::ClothingAsset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getBiggestMaxDistance() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getBoneBasePose(uint32_t internalIndex, PxMat44 &result) const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getBoneMapping(uint32_t *internal2externalMap) const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getBoneName(uint32_t internalIndex) const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getBoundingBox() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getClothSolverMode() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getGraphicalLodValue(uint32_t lodLevel) const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getMeshSkinningMap(uint32_t lod, ClothingMeshSkinningMap *map)=0 | nvidia::apex::ClothingAsset | [pure virtual]
getMeshSkinningMapSize(uint32_t lod)=0 | nvidia::apex::ClothingAsset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getNumActors() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getNumBones() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getNumGraphicalLodLevels() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getNumUsedBones() const =0 | nvidia::apex::ClothingAsset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
getRenderMeshAsset(uint32_t lodLevel) const =0 | nvidia::apex::ClothingAsset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
prepareMorphTargetMapping(const PxVec3 *originalPositions, uint32_t numPositions, float epsilon)=0 | nvidia::apex::ClothingAsset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseGraphicalData()=0 | nvidia::apex::ClothingAsset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
remapBoneIndex(const char *name, uint32_t newIndex)=0 | nvidia::apex::ClothingAsset | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~ClothingAsset() (defined in nvidia::apex::ClothingAsset) | nvidia::apex::ClothingAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingAssetAuthoring
Public Member Functions
nvidia::apex::ClothingAssetAuthoring Class Reference

The clothing authoring asset. This is used to generate streams that can then be deserialized into a regular asset. More...

#include <ClothingAssetAuthoring.h>

Inheritance diagram for nvidia::apex::ClothingAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual void | setDefaultConstrainCoefficients (const ClothingConstrainCoefficients &coeff)=0
set the default value for all coefficients if none is available
virtual void | setInvalidConstrainCoefficients (const ClothingConstrainCoefficients &coeff)=0
set the value which is considered invalid when painting
virtual void | setMeshes (uint32_t lod, RenderMeshAssetAuthoring *graphicalMesh, ClothingPhysicalMesh *physicalMesh, float normalResemblance=25, bool ignoreUnusedVertices=true, IProgressListener *progress=NULL)=0
Sets the graphical and physical mesh for the given graphical lod level.
virtual bool | addPlatformToGraphicalLod (uint32_t lod, PlatformTag platform)=0
Assigns a platform tag to a graphical lod.
virtual bool | removePlatform (uint32_t lod, PlatformTag platform)=0
Removes a platform tag from a graphical lod.
virtual uint32_t | getNumPlatforms (uint32_t lod) const =0
Get number of platform tags for a given lod.
virtual PlatformTag | getPlatform (uint32_t lod, uint32_t i) const =0
Get i-th platform tag of given lod;.
virtual uint32_t | getNumLods () const =0
Returns the number of LoDs that have been set in the ClothingAssetAuthoring::setMeshes call.
virtual int32_t | getLodValue (uint32_t lod) const =0
Returns the n-th LoD value from the ClothingAssetAuthoring::setMeshes call.
virtual void | clearMeshes ()=0
Clears all lods and meshes.
virtual ClothingPhysicalMesh * | getClothingPhysicalMesh (uint32_t graphicalLod) const =0
Returns a reference to the internal copy of the physical mesh for the given graphical lod. Returned object MUST be destroyed by the user immediately after use.
virtual void | setBoneInfo (uint32_t boneIndex, const char *boneName, const PxMat44 &bindPose, int32_t parentIndex)=0
assigns name and bindpose to a bone. This needs to be called for every bone at least once
virtual void | setRootBone (const char *boneName)=0
Specifies the root bone.
virtual uint32_t | addBoneConvex (const char *boneName, const PxVec3 *positions, uint32_t numPositions)=0
add a convex collision representation to a bone, vertices must be in bone-bind-pose space!
virtual uint32_t | addBoneConvex (uint32_t boneIndex, const PxVec3 *positions, uint32_t numPositions)=0
add a convex collision representation to a bone, vertices must be in bone-bind-pose space!
virtual void | addBoneCapsule (const char *boneName, float capsuleRadius, float capsuleHeight, const PxMat44 &localPose)=0
add a capsule to the bone's collision. all relative to bone-bind-pose space!
virtual void | addBoneCapsule (uint32_t boneIndex, float capsuleRadius, float capsuleHeight, const PxMat44 &localPose)=0
add a capsule to the bone's collision. all relative to bone-bind-pose space!
virtual void | clearBoneActors (const char *boneName)=0
clear all collision information for a given bone name
virtual void | clearBoneActors (uint32_t boneIndex)=0
clear all collision information for a given bone index
virtual void | clearAllBoneActors ()=0
clear all collision information for any bone
virtual void | setCollision (const char **boneNames, float *radii, PxVec3 *localPositions, uint32_t numSpheres, uint16_t *pairs, uint32_t numIndices)=0
Set up the collision volumes for PhysX3. The boneNames, radii and localPositions array need to be of size numSpheres, each triplet describes a sphere that is attached to a bone. The pairs array describes connections between pairs of spheres. It defines capsules with 2 radii.
virtual void | setCollision (uint32_t *boneIndices, float *radii, PxVec3 *localPositions, uint32_t numSpheres, uint16_t *pairs, uint32_t numIndices)=0
Set up the collision volumes for PhysX3.
virtual void | clearCollision ()=0
Clear the collision volumes for PhysX3.
virtual void | setSimulationHierarchicalLevels (uint32_t levels)=0
Number of hierarchical levels. 0 to turn off.
virtual void | setSimulationThickness (float thickness)=0
The radius of the cloth/softbody particles.
virtual void | setSimulationVirtualParticleDensity (float density)=0
The amount of virtual particles created. 0 means none, 1 means 2 or 3 per triangle.
virtual void | setSimulationSleepLinearVelocity (float sleep)=0
The sleep velocity. If all vertices of a cloth/softbody are below this velocity for some time, it falls asleep.
virtual void | setSimulationGravityDirection (const PxVec3 &gravity)=0
The direction of gravity. Can be used for cooking.
virtual void | setSimulationDisableCCD (bool disable)=0
Turn off Continuous collision detection for clothing.
virtual void | setSimulationTwowayInteraction (bool enable)=0
Turns on twoway interaction with rigid body. Only of limited use for clothing.
virtual void | setSimulationUntangling (bool enable)=0
EXPERIMENTAL: Turns on local untangling.
virtual void | setSimulationRestLengthScale (float scale)=0
The scale of the cloth rest length.
virtual void | setExportScale (float scale)=0
Provide a scaling to the serialize functionality.
virtual void | applyTransformation (const PxMat44 &transformation, float scale, bool applyToGraphics, bool applyToPhysics)=0
Apply an arbitrary transformation to either the physical, the graphical mesh or both.
virtual void | updateBindPoses (const PxMat44 *newBindPoses, uint32_t newBindPosesCount, bool isInternalOrder, bool maintainCollisionWorldSpace)=0
Move every bone bind pose to a new position.
virtual void | setDeriveNormalsFromBones (bool enable)=0
If enabled, the normals of the physical mesh are derived from the directions of the physical vertex to the bind poses of the assigned bones.
virtual
NvParameterized::Interface * 		getMaterialLibrary ()=0
Returns the material interface.
virtual bool | setMaterialLibrary (NvParameterized::Interface *materialLibrary, uint32_t materialIndex, bool transferOwnership)=0
Adds a new material library to the asset.
virtual
::NvParameterized::Interface * 		getRenderMeshAssetAuthoring (uint32_t lodLevel) const =0
Gets the parameterized render mesh associated with this asset.
virtual bool | getBoneBindPose (uint32_t boneIndex, PxMat44 &bindPose) const =0
Retrieves the bind pose transform of this bone.
virtual bool | setBoneBindPose (uint32_t boneIndex, const PxMat44 &bindPose)=0
Directly sets the bind pose transform of this bone.

Detailed Description

The clothing authoring asset. This is used to generate streams that can then be deserialized into a regular asset.

Member Function Documentation

virtual void nvidia::apex::ClothingAssetAuthoring::addBoneCapsule | ( | const char * | boneName,
 |  | float | capsuleRadius,
 |  | float | capsuleHeight,
 |  | const PxMat44 & | localPose
 | ) |  | [pure virtual]

add a capsule to the bone's collision. all relative to bone-bind-pose space!

Parameters:
[in] | boneName | name of the bone this collision info is for.
[in] | capsuleRadius | The radius of the capsule. if set to 0, bone collision will default back to convex
[in] | capsuleHeight | The height of the capsule
[in] | localPose | The frame of the capsule relative to the frame of the bone (not world space)
virtual void nvidia::apex::ClothingAssetAuthoring::addBoneCapsule | ( | uint32_t | boneIndex,
 |  | float | capsuleRadius,
 |  | float | capsuleHeight,
 |  | const PxMat44 & | localPose
 | ) |  | [pure virtual]

add a capsule to the bone's collision. all relative to bone-bind-pose space!

Parameters:
[in] | boneIndex | index of the bone this collision info is for.
[in] | capsuleRadius | if set to 0, bone collision will default back to convex
[in] | capsuleHeight | The height of the capsule
[in] | localPose | The frame of the capsule relative to the frame of the bone (not world space)
virtual uint32_t nvidia::apex::ClothingAssetAuthoring::addBoneConvex | ( | const char * | boneName,
 |  | const PxVec3 * | positions,
 |  | uint32_t | numPositions
 | ) |  | [pure virtual]

add a convex collision representation to a bone, vertices must be in bone-bind-pose space!

Parameters:
[in] | boneName | name of the bone this collision info is for.
[in] | positions | array of vertices with the positions.
[in] | numPositions | number of elements in positions array. if set to 0, bone collision will be capsule.
virtual uint32_t nvidia::apex::ClothingAssetAuthoring::addBoneConvex | ( | uint32_t | boneIndex,
 |  | const PxVec3 * | positions,
 |  | uint32_t | numPositions
 | ) |  | [pure virtual]

add a convex collision representation to a bone, vertices must be in bone-bind-pose space!

Parameters:
[in] | boneIndex | index of the bone this collision info is for.
[in] | positions | array of vertices with the positions.
[in] | numPositions | number of elements in positions array. if set to 0, bone collision will be capsule.
virtual void nvidia::apex::ClothingAssetAuthoring::applyTransformation | ( | const PxMat44 & | transformation,
 |  | float | scale,
 |  | bool | applyToGraphics,
 |  | bool | applyToPhysics
 | ) |  | [pure virtual]

Apply an arbitrary transformation to either the physical, the graphical mesh or both.

This is a permanent transformation and it changes the object state. Should only be called immediately before serialization and without further modifying the object later on.

Parameters:
transformation | This matrix is allowed to contain a translation and a rotation.
scale | Apply a uniform scaling as well
applyToGraphics | Apply the transformation and scale to the graphical part of the asset
applyToPhysics | Apply the transformation and scale to the physical part of the asset
Note:
if the 3x3 part of the transformation parameter contains mirroring of axis (= negative determinant) some additional processing is done. This includes flipping of simulation triangles and adaption of the mesh-mesh skinning.
virtual int32_t nvidia::apex::ClothingAssetAuthoring::getLodValue ( uint32_t lod ) const [pure virtual]

Returns the n-th LoD value from the ClothingAssetAuthoring::setMeshes call.

Note:
These values do not have to be a continuous list
virtual ::NvParameterized::Interface* nvidia::apex::ClothingAssetAuthoring::getRenderMeshAssetAuthoring ( uint32_t lodLevel ) const [pure virtual]

Gets the parameterized render mesh associated with this asset.

Parameters:
[in] lodLevel The LoD level of the render mesh asset
Returns:
NULL if lodLevel is not valid
See also:
ClothingAssetAuthoring::getNumLods()
Note:
Under no circumstances you should modify the positions of the render mesh asset's vertices. This will certainly break clothing
virtual void nvidia::apex::ClothingAssetAuthoring::setBoneInfo | ( | uint32_t | boneIndex,
 |  | const char * | boneName,
 |  | const PxMat44 & | bindPose,
 |  | int32_t | parentIndex
 | ) |  | [pure virtual]

assigns name and bindpose to a bone. This needs to be called for every bone at least once

Parameters:
[in] | boneIndex | The bone index the information is provided for.
[in] | boneName | The bone name. An internal copy of this string will be made.
[in] | bindPose | The bind or rest pose of this bone.
[in] | parentIndex | The bone index of the parent bone, -1 for root bones.
virtual void nvidia::apex::ClothingAssetAuthoring::setCollision | ( | const char ** | boneNames,
 |  | float * | radii,
 |  | PxVec3 * | localPositions,
 |  | uint32_t | numSpheres,
 |  | uint16_t * | pairs,
 |  | uint32_t | numIndices
 | ) |  | [pure virtual]

Set up the collision volumes for PhysX3. The boneNames, radii and localPositions array need to be of size numSpheres, each triplet describes a sphere that is attached to a bone. The pairs array describes connections between pairs of spheres. It defines capsules with 2 radii.

Parameters:
[in] | boneNames | names of the bones to which a spheres are added
[in] | radii | radii of the spheres
[in] | localPositions | sphere positions relative to the bone
[in] | numSpheres | number of spheres that are being defined
[in] | pairs | pairs of indices that reference 2 spheres to define a capsule with 2 radii
[in] | numIndices | size of the pairs array
virtual void nvidia::apex::ClothingAssetAuthoring::setExportScale ( float scale ) [pure virtual]

Provide a scaling to the serialize functionality.

This is useful when the game runs in a different scale than the tool this asset was created in

Deprecated:
Only works with deprecated serialization, use applyTransformation instead!
virtual bool nvidia::apex::ClothingAssetAuthoring::setMaterialLibrary | ( | NvParameterized::Interface * | materialLibrary,
 |  | uint32_t | materialIndex,
 |  | bool | transferOwnership
 | ) |  | [pure virtual]

Adds a new material library to the asset.

Parameters:
[in] | materialLibrary | User-generated material library object.
[in] | materialIndex | Default value for the Actor to know which material to use in the library
[in] | transferOwnership | Hands ownership to the authoring asset.
virtual void nvidia::apex::ClothingAssetAuthoring::setMeshes | ( | uint32_t | lod,
 |  | RenderMeshAssetAuthoring * | graphicalMesh,
 |  | ClothingPhysicalMesh * | physicalMesh,
 |  | float | normalResemblance = 25,
 |  | bool | ignoreUnusedVertices = true,
 |  | IProgressListener * | progress = NULL
 | ) |  | [pure virtual]

Sets the graphical and physical mesh for the given graphical lod level.

Parameters:
[in] | lod | Identifier for that lod level.
[in] | graphicalMesh | The graphical mesh to be rendered in that lod level.
[in] physicalMesh The physical mesh to be simulated on that lod level. The reference to the same physical mesh can be given for different graphical lods. It is copied internally.
Note: If the same physical mesh is used several time, the paint values are copied from the graphical mesh the first time the physical mesh is passed in here.
[in] | normalResemblance | This angle (in degrees) specifies how similar the normal from the physical and graphical mesh need to be in order for them to be accepted as immediate mode skinning pairs. Use 90 or bigger for any resemblance. Must be in range (0, 90], but it's highly recommended to use more than 5 degrees.
[in] | ignoreUnusedVertices | All Vertices that have the 'usedForPhysics' property set to false will be ignored when transferring the painted values from the graphical to the physical mesh
[in] | progress | Progress bar callback class.
virtual void nvidia::apex::ClothingAssetAuthoring::setRootBone ( const char * boneName ) [pure virtual]

Specifies the root bone.

Parameters:
[in] boneName The bone name.
virtual void nvidia::apex::ClothingAssetAuthoring::setSimulationDisableCCD ( bool disable ) [pure virtual]

Turn off Continuous collision detection for clothing.

Fast moving objects can cause massive forces to the cloth, especially when some kinematic actors move large distances within one frame. Without CCD those collisions are not detected and thus don't influence the cloth.

Note:
Whenever the isContinuous parameter in ClothingActor::updateState is set to false, cloth CCD will be temporarily disabled as well
virtual void nvidia::apex::ClothingAssetAuthoring::setSimulationHierarchicalLevels ( uint32_t levels ) [pure virtual]

Number of hierarchical levels. 0 to turn off.

If either the hierarchical solver iterations or the hierarchical levels are set to 0, this feature is turned off

virtual void nvidia::apex::ClothingAssetAuthoring::setSimulationUntangling ( bool enable ) [pure virtual]

EXPERIMENTAL: Turns on local untangling.

See also:
CLF_UNTANGLING
virtual void nvidia::apex::ClothingAssetAuthoring::updateBindPoses | ( | const PxMat44 * | newBindPoses,
 |  | uint32_t | newBindPosesCount,
 |  | bool | isInternalOrder,
 |  | bool | maintainCollisionWorldSpace
 | ) |  | [pure virtual]

Move every bone bind pose to a new position.

Parameters:
newBindPoses | array of matrices for the new bind poses. This must be in object space (not relative to the parent bone!)
newBindPosesCount | number of matrices in the specified array
isInternalOrder | using internal numbering or external numbering?
maintainCollisionWorldSpace | The collision volumes do not move to the new bone bind pose
The documentation for this class was generated from the following file:
  • ClothingAssetAuthoring.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingAssetAuthoring
nvidia::apex::ClothingAssetAuthoring Member List
This is the complete list of members for nvidia::apex::ClothingAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
addBoneCapsule(const char *boneName, float capsuleRadius, float capsuleHeight, const PxMat44 &localPose)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
addBoneCapsule(uint32_t boneIndex, float capsuleRadius, float capsuleHeight, const PxMat44 &localPose)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
addBoneConvex(const char *boneName, const PxVec3 *positions, uint32_t numPositions)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
addBoneConvex(uint32_t boneIndex, const PxVec3 *positions, uint32_t numPositions)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
addPlatformToGraphicalLod(uint32_t lod, PlatformTag platform)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
applyTransformation(const PxMat44 &transformation, float scale, bool applyToGraphics, bool applyToPhysics)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
clearAllBoneActors()=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
clearBoneActors(const char *boneName)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
clearBoneActors(uint32_t boneIndex)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
clearCollision()=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
clearMeshes()=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getBoneBindPose(uint32_t boneIndex, PxMat44 &bindPose) const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getClothingPhysicalMesh(uint32_t graphicalLod) const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getLodValue(uint32_t lod) const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getMaterialLibrary()=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNumLods() const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getNumPlatforms(uint32_t lod) const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getPlatform(uint32_t lod, uint32_t i) const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
getRenderMeshAssetAuthoring(uint32_t lodLevel) const =0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
removePlatform(uint32_t lod, PlatformTag platform)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setBoneBindPose(uint32_t boneIndex, const PxMat44 &bindPose)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setBoneInfo(uint32_t boneIndex, const char *boneName, const PxMat44 &bindPose, int32_t parentIndex)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setCollision(const char **boneNames, float *radii, PxVec3 *localPositions, uint32_t numSpheres, uint16_t *pairs, uint32_t numIndices)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setCollision(uint32_t *boneIndices, float *radii, PxVec3 *localPositions, uint32_t numSpheres, uint16_t *pairs, uint32_t numIndices)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setDefaultConstrainCoefficients(const ClothingConstrainCoefficients &coeff)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setDeriveNormalsFromBones(bool enable)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setExportScale(float scale)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setInvalidConstrainCoefficients(const ClothingConstrainCoefficients &coeff)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setMaterialLibrary(NvParameterized::Interface *materialLibrary, uint32_t materialIndex, bool transferOwnership)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setMeshes(uint32_t lod, RenderMeshAssetAuthoring *graphicalMesh, ClothingPhysicalMesh *physicalMesh, float normalResemblance=25, bool ignoreUnusedVertices=true, IProgressListener *progress=NULL)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setRootBone(const char *boneName)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationDisableCCD(bool disable)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationGravityDirection(const PxVec3 &gravity)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationHierarchicalLevels(uint32_t levels)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationRestLengthScale(float scale)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationSleepLinearVelocity(float sleep)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationThickness(float thickness)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationTwowayInteraction(bool enable)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationUntangling(bool enable)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setSimulationVirtualParticleDensity(float density)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
updateBindPoses(const PxMat44 *newBindPoses, uint32_t newBindPosesCount, bool isInternalOrder, bool maintainCollisionWorldSpace)=0 | nvidia::apex::ClothingAssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingCapsule Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingCapsule
Public Member Functions
nvidia::apex::ClothingCapsule Class Reference

Capsule collision of a clothing actor. More...

#include <ClothingCollision.h>

Inheritance diagram for nvidia::apex::ClothingCapsule:
nvidia::apex::ClothingCollision nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual ClothingSphere ** | getSpheres ()=0
Returns the pointers to the two spheres that represent this capsule.
virtual void | releaseWithSpheres ()=0
Releases this sphere and its two spheres.

Detailed Description

Capsule collision of a clothing actor.

A capsule is represented by two ClothingSpheres.

Member Function Documentation

virtual void nvidia::apex::ClothingCapsule::releaseWithSpheres ( ) [pure virtual]

Releases this sphere and its two spheres.

Note:
Only use releaseWithSpheres if the 2 spheres are used exclusively by this capsule. Spheres referenced by other convexes will not be released.
The documentation for this class was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingCapsule
nvidia::apex::ClothingCapsule Member List
This is the complete list of members for nvidia::apex::ClothingCapsule, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getSpheres()=0 | nvidia::apex::ClothingCapsule | [pure virtual]
getType() const =0 | nvidia::apex::ClothingCollision | [pure virtual]
isCapsule()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isConvex()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isPlane()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isSphere()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isTriangleMesh()=0 | nvidia::apex::ClothingCollision | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWithSpheres()=0 | nvidia::apex::ClothingCapsule | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingCollision Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingCollision
Public Member Functions
nvidia::apex::ClothingCollision Class Reference

Base class of all clothing collision types. More...

#include <ClothingCollision.h>

Inheritance diagram for nvidia::apex::ClothingCollision:
nvidia::apex::ApexInterface nvidia::apex::RWLockable nvidia::apex::ClothingCapsule nvidia::apex::ClothingConvex nvidia::apex::ClothingPlane nvidia::apex::ClothingSphere nvidia::apex::ClothingTriangleMesh

List of all members.

Public Member Functions

virtual ClothingCollisionType::Enum | getType () const =0
Returns the Type of this collision object.
virtual ClothingPlane * | isPlane ()=0
Returns the pointer to this object if it is a plane, NULL otherwise.
virtual ClothingConvex * | isConvex ()=0
Returns the pointer to this object if it is a convex, NULL otherwise.
virtual ClothingSphere * | isSphere ()=0
Returns the pointer to this object if it is a sphere, NULL otherwise.
virtual ClothingCapsule * | isCapsule ()=0
Returns the pointer to this object if it is a capsule, NULL otherwise.
virtual ClothingTriangleMesh * | isTriangleMesh ()=0
Returns the pointer to this object if it is a triangle mesh, NULL otherwise.

Detailed Description

Base class of all clothing collision types.

The documentation for this class was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingCollision
nvidia::apex::ClothingCollision Member List
This is the complete list of members for nvidia::apex::ClothingCollision, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getType() const =0 | nvidia::apex::ClothingCollision | [pure virtual]
isCapsule()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isConvex()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isPlane()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isSphere()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isTriangleMesh()=0 | nvidia::apex::ClothingCollision | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingConvex Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingConvex
Public Member Functions
nvidia::apex::ClothingConvex Class Reference

Convex collision of a clothing actor. More...

#include <ClothingCollision.h>

Inheritance diagram for nvidia::apex::ClothingConvex:
nvidia::apex::ClothingCollision nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual uint32_t | getNumPlanes ()=0
Returns the number of planes that define this convex.
virtual ClothingPlane ** | getPlanes ()=0
Returns pointer to the planes that define this convex.
virtual void | releaseWithPlanes ()=0
Releases this convex and all its planes.

Detailed Description

Convex collision of a clothing actor.

A convex is represented by a list of ClothingPlanes.

Member Function Documentation

virtual void nvidia::apex::ClothingConvex::releaseWithPlanes ( ) [pure virtual]

Releases this convex and all its planes.

Note:
Only use this if the planes are used exclusively by this convex. Planes referenced by other convexes will not be released.
The documentation for this class was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingConvex
nvidia::apex::ClothingConvex Member List
This is the complete list of members for nvidia::apex::ClothingConvex, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getNumPlanes()=0 | nvidia::apex::ClothingConvex | [pure virtual]
getPlanes()=0 | nvidia::apex::ClothingConvex | [pure virtual]
getType() const =0 | nvidia::apex::ClothingCollision | [pure virtual]
isCapsule()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isConvex()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isPlane()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isSphere()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isTriangleMesh()=0 | nvidia::apex::ClothingCollision | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWithPlanes()=0 | nvidia::apex::ClothingConvex | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingPhysicalMesh Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPhysicalMesh
Public Member Functions
nvidia::apex::ClothingPhysicalMesh Class Reference

Holder for a physical mesh, this can be generated through various ways (see single- and multi-layered clothing) or hand crafted. More...

#include <ClothingPhysicalMesh.h>

Inheritance diagram for nvidia::apex::ClothingPhysicalMesh:
nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual uint32_t | getNumVertices () const =0
returns the number of vertices
virtual uint32_t | getNumSimulatedVertices () const =0
returns the number of simulated vertices
virtual uint32_t | getNumMaxDistance0Vertices () const =0
returns the number of vertices with zero max distance
virtual uint32_t | getNumIndices () const =0
returns the number of indices
virtual uint32_t | getNumSimulatedIndices () const =0
returns the number of simulated indices
virtual void | getIndices (void *indexDestination, uint32_t byteStride, uint32_t numIndices) const =0
writes the indices to a destination buffer
virtual bool | isTetrahedralMesh () const =0
returns whether the mesh is built out of tetrahedra or triangles
virtual void | simplify (uint32_t subdivisions, int32_t maxSteps, float maxError, IProgressListener *progress)=0
This will simplify the current mesh.
virtual void | setGeometry (bool tetraMesh, uint32_t numVertices, uint32_t vertexByteStride, const void *vertices, const uint32_t *driveChannels, uint32_t numIndices, uint32_t indexByteStride, const void *indices)=0
Create a physical mesh from scratch.
virtual bool | getIndices (uint32_t *indices, uint32_t byteStride) const =0
writes the indices into a user specified buffer.
virtual bool | getVertices (PxVec3 *vertices, uint32_t byteStride) const =0
Writes the vertex positions into a user specified buffer.
virtual bool | getNormals (PxVec3 *normals, uint32_t byteStride) const =0
Writes the normals into a user specified buffer.
virtual uint32_t | getNumBonesPerVertex () const =0
Returns the number of bones per vertex.
virtual bool | getBoneIndices (uint16_t *boneIndices, uint32_t byteStride) const =0
Writes the bone indices into a user specified buffer.
virtual bool | getBoneWeights (float *boneWeights, uint32_t byteStride) const =0
Writes the bone weights into a user specified buffer.
virtual void | allocateMasterFlagsBuffer ()=0
Allocates and initializes the drive channels (master flags) of the physics mesh.
virtual uint32_t * | getMasterFlagsBuffer ()=0
Returns the masterFlag buffer pointer in order to edit the values.
virtual void | allocateConstrainCoefficientBuffer ()=0
Allocates and initializes the constrain coefficients of the physics mesh.
virtual
ClothingConstrainCoefficients * 		getConstrainCoefficientBuffer () const =0
Returns the constrain coefficient buffer pointer in order to edit the values.
virtual bool | getConstrainCoefficients (ClothingConstrainCoefficients *coeffs, uint32_t byteStride) const =0
Writes the cloth constrain coefficients into a user specified buffer.
virtual void | getStats (ClothingPhysicalMeshStats &stats) const =0
Returns stats (sizes, counts) for the asset. See ClothingPhysicalMeshStats.

Detailed Description

Holder for a physical mesh, this can be generated through various ways (see single- and multi-layered clothing) or hand crafted.

Member Function Documentation

virtual void nvidia::apex::ClothingPhysicalMesh::allocateConstrainCoefficientBuffer ( ) [pure virtual]

Allocates and initializes the constrain coefficients of the physics mesh.

This allows to set the constrain coefficients like maxDistance directly on the physics mesh. If this is not called by the authoring tool, the constrain coefficients are read from the graphical mesh.

virtual void nvidia::apex::ClothingPhysicalMesh::allocateMasterFlagsBuffer ( ) [pure virtual]

Allocates and initializes the drive channels (master flags) of the physics mesh.

This allows to set the drive channels directly on the physics mesh.

virtual bool nvidia::apex::ClothingPhysicalMesh::getBoneIndices | ( | uint16_t * | boneIndices,
 |  | uint32_t | byteStride
 | ) |  | const [pure virtual]

Writes the bone indices into a user specified buffer.

Returns false if the buffer doesn't exist. The buffer must be bigger than sizeof(uint16_t) * getNumVertices() * getNumBonesPerVertex(). (numBonesPerVertex is the same as in the graphical mesh for LOD 0)

The bytestride is applied only after writing numBonesPerVertex and thus must be >= sizoef(uint16_t) * numBonesPerVertex

virtual bool nvidia::apex::ClothingPhysicalMesh::getBoneWeights | ( | float * | boneWeights,
 |  | uint32_t | byteStride
 | ) |  | const [pure virtual]

Writes the bone weights into a user specified buffer.

Returns false if the buffer doesn't exist. The buffer must be bigger than sizeof(float) * getNumVertices() * getNumBonesPerVertex(). (numBonesPerVertex is the same as in the graphical mesh for LOD 0) The bytestride is applied only after writing numBonesPerVertex and thus must be >= sizoef(float) * numBonesPerVertex

virtual ClothingConstrainCoefficients* nvidia::apex::ClothingPhysicalMesh::getConstrainCoefficientBuffer ( ) const [pure virtual]

Returns the constrain coefficient buffer pointer in order to edit the values.

This allows to set the constrain coefficients like maxDistance directly on the physics mesh.

virtual bool nvidia::apex::ClothingPhysicalMesh::getConstrainCoefficients | ( | ClothingConstrainCoefficients * | coeffs,
 |  | uint32_t | byteStride
 | ) |  | const [pure virtual]

Writes the cloth constrain coefficients into a user specified buffer.

Returns false if the buffer doesn't exist. The buffer must be bigger than sizeof(ClothingConstrainCoefficients) * getNumVertices().

virtual bool nvidia::apex::ClothingPhysicalMesh::getIndices | ( | uint32_t * | indices,
 |  | uint32_t | byteStride
 | ) |  | const [pure virtual]

writes the indices into a user specified buffer.

Returns false if the buffer doesn't exist. The buffer must be bigger than sizeof(uint32_t) * getNumIndices()

virtual void nvidia::apex::ClothingPhysicalMesh::getIndices | ( | void * | indexDestination,
 |  | uint32_t | byteStride,
 |  | uint32_t | numIndices
 | ) |  | const [pure virtual]

writes the indices to a destination buffer

Parameters:
[out] | indexDestination | destination buffer where to write the indices
[in] | byteStride | stride of the destination buffer
[in] | numIndices | number of indices the buffer can hold. This can be smaller than getNumIndices()
virtual uint32_t* nvidia::apex::ClothingPhysicalMesh::getMasterFlagsBuffer ( ) [pure virtual]

Returns the masterFlag buffer pointer in order to edit the values.

This allows to set values directly on the physics mesh.

virtual bool nvidia::apex::ClothingPhysicalMesh::getNormals | ( | PxVec3 * | normals,
 |  | uint32_t | byteStride
 | ) |  | const [pure virtual]

Writes the normals into a user specified buffer.

Returns false if the buffer doesn't exist. The buffer must be bigger than sizeof(PxVec3) * getNumVertices()

virtual bool nvidia::apex::ClothingPhysicalMesh::getVertices | ( | PxVec3 * | vertices,
 |  | uint32_t | byteStride
 | ) |  | const [pure virtual]

Writes the vertex positions into a user specified buffer.

Returns false if the buffer doesn't exist. The buffer must be bigger than sizeof(PxVec3) * getNumVertices()

virtual void nvidia::apex::ClothingPhysicalMesh::setGeometry | ( | bool | tetraMesh,
 |  | uint32_t | numVertices,
 |  | uint32_t | vertexByteStride,
 |  | const void * | vertices,
 |  | const uint32_t * | driveChannels,
 |  | uint32_t | numIndices,
 |  | uint32_t | indexByteStride,
 |  | const void * | indices
 | ) |  | [pure virtual]

Create a physical mesh from scratch.

Overwrites all vertices/indices, and invalidates all misc vertex buffers. vertices must be PxVec3 and indices uint32_t. If driveChannels is NULL, all vertices are assigned to all drive channels (initialized to 0xffffffff)

virtual void nvidia::apex::ClothingPhysicalMesh::simplify | ( | uint32_t | subdivisions,
 |  | int32_t | maxSteps,
 |  | float | maxError,
 |  | IProgressListener * | progress
 | ) |  | [pure virtual]

This will simplify the current mesh.

Parameters:
[in] subdivisions used to derive the maximal length a new edge can get.
Divide the bounding box diagonal by this value to get the maximal edge length for newly created edges
Use 0 to not restrict the maximal edge length
[in] maxSteps The maximum number of edges to be considered for simplification.
Use 0 to turn off
[in] maxError The maximal quadric error an edge can cause to be considered simplifyable.
Use any value < 0 to turn off
[in] progress Callback class that will be fired every now and then to update a progress bar in the gui.
Returns:
The number of edges collapsed
The documentation for this class was generated from the following file:
  • ClothingPhysicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPhysicalMesh
nvidia::apex::ClothingPhysicalMesh Member List
This is the complete list of members for nvidia::apex::ClothingPhysicalMesh, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
allocateConstrainCoefficientBuffer()=0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
allocateMasterFlagsBuffer()=0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getBoneIndices(uint16_t *boneIndices, uint32_t byteStride) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getBoneWeights(float *boneWeights, uint32_t byteStride) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getConstrainCoefficientBuffer() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getConstrainCoefficients(ClothingConstrainCoefficients *coeffs, uint32_t byteStride) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getIndices(void *indexDestination, uint32_t byteStride, uint32_t numIndices) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getIndices(uint32_t *indices, uint32_t byteStride) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getMasterFlagsBuffer()=0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNormals(PxVec3 *normals, uint32_t byteStride) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNumBonesPerVertex() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNumIndices() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNumMaxDistance0Vertices() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNumSimulatedIndices() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNumSimulatedVertices() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getNumVertices() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getStats(ClothingPhysicalMeshStats &stats) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
getVertices(PxVec3 *vertices, uint32_t byteStride) const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
isTetrahedralMesh() const =0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setGeometry(bool tetraMesh, uint32_t numVertices, uint32_t vertexByteStride, const void *vertices, const uint32_t *driveChannels, uint32_t numIndices, uint32_t indexByteStride, const void *indices)=0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
simplify(uint32_t subdivisions, int32_t maxSteps, float maxError, IProgressListener *progress)=0 | nvidia::apex::ClothingPhysicalMesh | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingPlane Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPlane
Public Member Functions
nvidia::apex::ClothingPlane Class Reference

Plane collision of a clothing actor. More...

#include <ClothingCollision.h>

Inheritance diagram for nvidia::apex::ClothingPlane:
nvidia::apex::ClothingCollision nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual void | setPlane (const PxPlane &plane)=0
Sets the plane equation of the plane.
virtual const PxPlane & | getPlane ()=0
Returns the plane equation of the plane.
virtual uint32_t | getRefCount () const =0
Returns the number of convexes that reference this plane.

Detailed Description

Plane collision of a clothing actor.

The documentation for this class was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPlane
nvidia::apex::ClothingPlane Member List
This is the complete list of members for nvidia::apex::ClothingPlane, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getPlane()=0 | nvidia::apex::ClothingPlane | [pure virtual]
getRefCount() const =0 | nvidia::apex::ClothingPlane | [pure virtual]
getType() const =0 | nvidia::apex::ClothingCollision | [pure virtual]
isCapsule()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isConvex()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isPlane()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isSphere()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isTriangleMesh()=0 | nvidia::apex::ClothingCollision | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setPlane(const PxPlane &plane)=0 | nvidia::apex::ClothingPlane | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPreview
Public Member Functions
nvidia::apex::ClothingPreview Class Reference

A lightweight preview of a ClothingActor that will not perform any simulation. More...

#include <ClothingPreview.h>

Inheritance diagram for nvidia::apex::ClothingPreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void updateState (const PxMat44 &globalPose, const PxMat44 *newBoneMatrices, uint32_t boneMatricesByteStride, uint32_t numBoneMatrices)=0
Updates all internal bone matrices.

Detailed Description

A lightweight preview of a ClothingActor that will not perform any simulation.

Member Function Documentation

virtual void nvidia::apex::ClothingPreview::updateState | ( | const PxMat44 & | globalPose,
 |  | const PxMat44 * | newBoneMatrices,
 |  | uint32_t | boneMatricesByteStride,
 |  | uint32_t | numBoneMatrices
 | ) |  | [pure virtual]

Updates all internal bone matrices.

See also:
ClothingActor::updateState
The documentation for this class was generated from the following file:
  • ClothingPreview.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPreview
nvidia::apex::ClothingPreview Member List
This is the complete list of members for nvidia::apex::ClothingPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateState(const PxMat44 &globalPose, const PxMat44 *newBoneMatrices, uint32_t boneMatricesByteStride, uint32_t numBoneMatrices)=0 | nvidia::apex::ClothingPreview | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingRenderProxy Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingRenderProxy
Public Member Functions
nvidia::apex::ClothingRenderProxy Class Reference

Instance of ClothingRenderProxy. This is the renderable of a clothing actor. The data in this object is consistent until it is returned to APEX with the release() call. More...

#include <ClothingRenderProxy.h>

Inheritance diagram for nvidia::apex::ClothingRenderProxy:
nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual bool hasSimulatedData () const =0
True if the render proxy contains simulated data, false if it is purely animated.

Detailed Description

Instance of ClothingRenderProxy. This is the renderable of a clothing actor. The data in this object is consistent until it is returned to APEX with the release() call.

The documentation for this class was generated from the following file:
  • ClothingRenderProxy.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingRenderProxy
nvidia::apex::ClothingRenderProxy Member List
This is the complete list of members for nvidia::apex::ClothingRenderProxy, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
hasSimulatedData() const =0 | nvidia::apex::ClothingRenderProxy | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
~ClothingRenderProxy() (defined in nvidia::apex::ClothingRenderProxy) | nvidia::apex::ClothingRenderProxy | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingSphere Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingSphere
Public Member Functions
nvidia::apex::ClothingSphere Class Reference

Sphere collision of a clothing actor. More...

#include <ClothingCollision.h>

Inheritance diagram for nvidia::apex::ClothingSphere:
nvidia::apex::ClothingCollision nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual void | setPosition (const PxVec3 &position)=0
Sets the position of this sphere.
virtual const PxVec3 & | getPosition () const =0
Returns the position of this sphere.
virtual void | setRadius (float radius)=0
Sets the radius of this sphere.
virtual float | getRadius () const =0
Returns the Radius of this sphere.
virtual uint32_t | getRefCount () const =0
Returns the number of capsules that reference this plane.

Detailed Description

Sphere collision of a clothing actor.

Member Function Documentation

virtual void nvidia::apex::ClothingSphere::setRadius ( float radius ) [pure virtual]

Sets the radius of this sphere.

Sets the Radius of this sphere.

The documentation for this class was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingSphere
nvidia::apex::ClothingSphere Member List
This is the complete list of members for nvidia::apex::ClothingSphere, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getPosition() const =0 | nvidia::apex::ClothingSphere | [pure virtual]
getRadius() const =0 | nvidia::apex::ClothingSphere | [pure virtual]
getRefCount() const =0 | nvidia::apex::ClothingSphere | [pure virtual]
getType() const =0 | nvidia::apex::ClothingCollision | [pure virtual]
isCapsule()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isConvex()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isPlane()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isSphere()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isTriangleMesh()=0 | nvidia::apex::ClothingCollision | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setPosition(const PxVec3 &position)=0 | nvidia::apex::ClothingSphere | [pure virtual]
setRadius(float radius)=0 | nvidia::apex::ClothingSphere | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingTriangleMesh Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingTriangleMesh
Public Member Functions
nvidia::apex::ClothingTriangleMesh Class Reference

Triangle mesh collision of a clothing actor. More...

#include <ClothingCollision.h>

Inheritance diagram for nvidia::apex::ClothingTriangleMesh:
nvidia::apex::ClothingCollision nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual uint32_t | lockTriangles (const uint32_t **ids, const PxVec3 **triangles)=0
Read access to the current triangles of the mesh. unlockTriangles needs to be called when done reading.
virtual uint32_t | lockTrianglesWrite (const uint32_t **ids, PxVec3 **triangles)=0
Write access to the current triangles of the mesh. Changing Ids is not allowed. unlockTriangles needs to be called when done editing.
virtual void | unlockTriangles ()=0
Unlock the mesh data after editing or reading.
virtual void | addTriangle (uint32_t id, const PxVec3 &v0, const PxVec3 &v1, const PxVec3 &v2)=0
Adds a triangle to the mesh. Clockwise winding. If a triangle with a given id already exists, it will update that triangle with the new values. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.
virtual void | addTriangles (const uint32_t *ids, const PxVec3 *triangleVertices, uint32_t numTriangles)=0
Adds a list of triangles to the mesh. Clockwise winding. If a triangle with a given id already exists, it will update that triangle with the new values. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.
virtual void | removeTriangle (uint32_t id)=0
Removes triangle with given id. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.
virtual void | removeTriangles (const uint32_t *ids, uint32_t numTriangles)=0
Removes triangles. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.
virtual void | clearTriangles ()=0
Clear all triangles to start with an empty mesh.
virtual void | setPose (PxMat44 pose)=0
Sets the global pose of the mesh.
virtual const PxMat44 & | getPose () const =0
Returns the global pose of the mesh.

Detailed Description

Triangle mesh collision of a clothing actor.

Member Function Documentation

virtual void nvidia::apex::ClothingTriangleMesh::addTriangle | ( | uint32_t | id,
 |  | const PxVec3 & | v0,
 |  | const PxVec3 & | v1,
 |  | const PxVec3 & | v2
 | ) |  | [pure virtual]

Adds a triangle to the mesh. Clockwise winding. If a triangle with a given id already exists, it will update that triangle with the new values. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.

Parameters:
[in] | id | User provided triangle id that allows identifing and removing the triangle.
[in] | v0 | First vertex of triangle
[in] | v1 | Second vertex of triangle
[in] | v2 | Third vertex of triangle
virtual void nvidia::apex::ClothingTriangleMesh::addTriangles | ( | const uint32_t * | ids,
 |  | const PxVec3 * | triangleVertices,
 |  | uint32_t | numTriangles
 | ) |  | [pure virtual]

Adds a list of triangles to the mesh. Clockwise winding. If a triangle with a given id already exists, it will update that triangle with the new values. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.

Parameters:
[in] | ids | User provided triangle indices that allows identifing and removing the triangle. Needs to contain numTriangles indices.
[in] | triangleVertices | Triangle vertices to add. Needs to contain 3*numTriangles vertex positions
[in] | numTriangles | Number of triangles to add
virtual uint32_t nvidia::apex::ClothingTriangleMesh::lockTriangles | ( | const uint32_t ** | ids,
 |  | const PxVec3 ** | triangles
 | ) |  | [pure virtual]

Read access to the current triangles of the mesh. unlockTriangles needs to be called when done reading.

Parameters:
[out] | ids | Pointer to the triangle ids. Not written if NULL is provided.
[out] | triangles | Pointer to the triangles. Contains (3*number of triangles) vertex positions. Not written if NULL is provided.
Returns:
Current number of triangles
virtual uint32_t nvidia::apex::ClothingTriangleMesh::lockTrianglesWrite | ( | const uint32_t ** | ids,
 |  | PxVec3 ** | triangles
 | ) |  | [pure virtual]

Write access to the current triangles of the mesh. Changing Ids is not allowed. unlockTriangles needs to be called when done editing.

Parameters:
[out] | ids | pointer to the triangle ids. not written if NULL is provided.
[out] | triangles | pointer to the triangles. Contains (3*number of triangles) vertex positions. Not written if NULL is provided.
Returns:
Current number of triangles
virtual void nvidia::apex::ClothingTriangleMesh::removeTriangle ( uint32_t id ) [pure virtual]

Removes triangle with given id. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.

Parameters:
[in] id id of the triangle to be removed
virtual void nvidia::apex::ClothingTriangleMesh::removeTriangles | ( | const uint32_t * | ids,
 |  | uint32_t | numTriangles
 | ) |  | [pure virtual]

Removes triangles. Ids for triangle removal and adding are accumulated and processed during simulate. That means a triangle will not be added if the same id is removed in the same frame, independent of the order of the remove and add calls.

Parameters:
[in] | ids | ids of the triangles to be removed. Needs to contain numTriangle indices.
[in] | numTriangles | Number of triangles to remove
The documentation for this class was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingTriangleMesh
nvidia::apex::ClothingTriangleMesh Member List
This is the complete list of members for nvidia::apex::ClothingTriangleMesh, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
addTriangle(uint32_t id, const PxVec3 &v0, const PxVec3 &v1, const PxVec3 &v2)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
addTriangles(const uint32_t *ids, const PxVec3 *triangleVertices, uint32_t numTriangles)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
clearTriangles()=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
getPose() const =0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
getType() const =0 | nvidia::apex::ClothingCollision | [pure virtual]
isCapsule()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isConvex()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isPlane()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isSphere()=0 | nvidia::apex::ClothingCollision | [pure virtual]
isTriangleMesh()=0 | nvidia::apex::ClothingCollision | [pure virtual]
lockTriangles(const uint32_t **ids, const PxVec3 **triangles)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
lockTrianglesWrite(const uint32_t **ids, PxVec3 **triangles)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
removeTriangle(uint32_t id)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
removeTriangles(const uint32_t *ids, uint32_t numTriangles)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
unlockTriangles()=0 | nvidia::apex::ClothingTriangleMesh | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingVelocityCallback Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingVelocityCallback
Public Member Functions
nvidia::apex::ClothingVelocityCallback Class Reference

container class for the velocity shader callback. More...

#include <ClothingVelocityCallback.h>

List of all members.

Public Member Functions

virtual bool velocityShader (PxVec3 *velocities, const PxVec3 *positions, uint32_t numParticles)=0
This callback will be fired in Apex threads. It must not address any user data, just operate on the data.

Detailed Description

container class for the velocity shader callback.

Member Function Documentation

virtual bool nvidia::apex::ClothingVelocityCallback::velocityShader | ( | PxVec3 * | velocities,
 |  | const PxVec3 * | positions,
 |  | uint32_t | numParticles
 | ) |  | [pure virtual]

This callback will be fired in Apex threads. It must not address any user data, just operate on the data.

Parameters:
[in,out] | velocities | The velocities of the cloth. These can be modified if necessary, but then the method needs to return true!
[in] | positions | The positions of the cloth. Must not be modified, only read.
[in] | numParticles | Size of the velocities and positions array.
Returns:
return true if the velocities have been altered, false if they just have been read
The documentation for this class was generated from the following file:
  • ClothingVelocityCallback.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingVelocityCallback
nvidia::apex::ClothingVelocityCallback Member List
This is the complete list of members for nvidia::apex::ClothingVelocityCallback, including all inherited members.
velocityShader(PxVec3 *velocities, const PxVec3 *positions, uint32_t numParticles)=0 nvidia::apex::ClothingVelocityCallback [pure virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ColorVsDensityModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorVsDensityModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ColorVsDensityModifier Class Reference

ColorVsDensityModifier modifies the color constants associated with a particle depending on the density of the particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ColorVsDensityModifier:
nvidia::apex::ModifierT< ColorVsDensityModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ColorChannel | getColorChannel () const =0
get the affected color channel
virtual void | setColorChannel (ColorChannel colorChannel)=0
set the affected color channel
virtual const Curve * | getFunction () const =0
get the curve that sets the dependency between the density and the color
virtual void | setFunction (const Curve *f)=0
set the curve that sets the dependency between the density and the color

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ColorVsDensity
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ColorVsDensityModifier modifies the color constants associated with a particle depending on the density of the particle.

Member Data Documentation

const uint32_t nvidia::apex::ColorVsDensityModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorVsDensityModifier
nvidia::apex::ColorVsDensityModifier Member List
This is the complete list of members for nvidia::apex::ColorVsDensityModifier, including all inherited members.
getColorChannel() const =0 | nvidia::apex::ColorVsDensityModifier | [pure virtual]
getFunction() const =0 | nvidia::apex::ColorVsDensityModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ColorVsDensityModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ColorVsDensityModifier > | [inline, virtual]
ModifierType | nvidia::apex::ColorVsDensityModifier | [static]
ModifierUsage | nvidia::apex::ColorVsDensityModifier | [static]
setColorChannel(ColorChannel colorChannel)=0 | nvidia::apex::ColorVsDensityModifier | [pure virtual]
setFunction(const Curve *f)=0 | nvidia::apex::ColorVsDensityModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ColorVsLifeModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorVsLifeModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ColorVsLifeModifier Class Reference

ColorVsLifeModifier modifies the color constants associated with a particle depending on the life remaining of the particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ColorVsLifeModifier:
nvidia::apex::ModifierT< ColorVsLifeModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ColorChannel | getColorChannel () const =0
get the affected color channel
virtual void | setColorChannel (ColorChannel colorChannel)=0
set the affected color channel
virtual const Curve * | getFunction () const =0
get the curve that sets the dependency between the lifetime and the color
virtual void | setFunction (const Curve *f)=0
set the curve that sets the dependency between the lifetime and the color

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ColorVsLife
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ColorVsLifeModifier modifies the color constants associated with a particle depending on the life remaining of the particle.

Member Data Documentation

const uint32_t nvidia::apex::ColorVsLifeModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn | ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorVsLifeModifier
nvidia::apex::ColorVsLifeModifier Member List
This is the complete list of members for nvidia::apex::ColorVsLifeModifier, including all inherited members.
getColorChannel() const =0 | nvidia::apex::ColorVsLifeModifier | [pure virtual]
getFunction() const =0 | nvidia::apex::ColorVsLifeModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ColorVsLifeModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ColorVsLifeModifier > | [inline, virtual]
ModifierType | nvidia::apex::ColorVsLifeModifier | [static]
ModifierUsage | nvidia::apex::ColorVsLifeModifier | [static]
setColorChannel(ColorChannel colorChannel)=0 | nvidia::apex::ColorVsLifeModifier | [pure virtual]
setFunction(const Curve *f)=0 | nvidia::apex::ColorVsLifeModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ColorVsVelocityModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorVsVelocityModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ColorVsVelocityModifier Class Reference

ColorVsVelocityModifier modifies the color constants associated with a particle depending on the velocity of the particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ColorVsVelocityModifier:
nvidia::apex::ModifierT< ColorVsVelocityModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ColorChannel | getColorChannel () const =0
get the affected color channel
virtual void | setColorChannel (ColorChannel colorChannel)=0
set the affected color channel
virtual const Curve * | getFunction () const =0
get the curve that sets the dependency between the lifetime and the color
virtual void | setFunction (const Curve *f)=0
set the curve that sets the dependency between the lifetime and the color
virtual float | getVelocity0 () const =0
get velocity0
virtual void | setVelocity0 (float value)=0
set velocity0
virtual float | getVelocity1 () const =0
get velocity1
virtual void | setVelocity1 (float value)=0
set velocity1

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ColorVsVelocity
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ColorVsVelocityModifier modifies the color constants associated with a particle depending on the velocity of the particle.

Member Data Documentation

const uint32_t nvidia::apex::ColorVsVelocityModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn | ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorVsVelocityModifier
nvidia::apex::ColorVsVelocityModifier Member List
This is the complete list of members for nvidia::apex::ColorVsVelocityModifier, including all inherited members.
getColorChannel() const =0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
getFunction() const =0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ColorVsVelocityModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ColorVsVelocityModifier > | [inline, virtual]
getVelocity0() const =0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
getVelocity1() const =0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
ModifierType | nvidia::apex::ColorVsVelocityModifier | [static]
ModifierUsage | nvidia::apex::ColorVsVelocityModifier | [static]
setColorChannel(ColorChannel colorChannel)=0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
setFunction(const Curve *f)=0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
setVelocity0(float value)=0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
setVelocity1(float value)=0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::Context Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Context
Public Member Functions
nvidia::apex::Context Class Reference

A container for Actors. More...

#include <Context.h>

Inheritance diagram for nvidia::apex::Context:
nvidia::apex::IofxAsset nvidia::apex::Scene

List of all members.

Public Member Functions

virtual void | removeAllActors ()=0
Removes all actors from the context and releases them.
virtual RenderableIterator * | createRenderableIterator ()=0
Create an iterator for all renderables in this context.
virtual void | releaseRenderableIterator (RenderableIterator &)=0
Release a renderable iterator.

Detailed Description

A container for Actors.

Member Function Documentation

virtual void nvidia::apex::Context::releaseRenderableIterator ( RenderableIterator & ) [pure virtual]

Release a renderable iterator.

Equivalent to calling the iterator's release method.

The documentation for this class was generated from the following file:
  • Context.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Context
nvidia::apex::Context Member List
This is the complete list of members for nvidia::apex::Context, including all inherited members.
createRenderableIterator()=0 | nvidia::apex::Context | [pure virtual]
releaseRenderableIterator(RenderableIterator &)=0 | nvidia::apex::Context | [pure virtual]
removeAllActors()=0 | nvidia::apex::Context | [pure virtual]
~Context() (defined in nvidia::apex::Context) | nvidia::apex::Context | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::CudaTestManager Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CudaTestManager
Public Member Functions
nvidia::apex::CudaTestManager Class Reference

A class that set information on kernels should be tested and give directive for creation ApexCudaTestContext. More...

#include <CudaTestManager.h>

List of all members.

Public Member Functions

virtual void | setWritePath (const char *path)=0
Set the write path.
virtual void | setWriteForFunction (const char *functionName, const char *moduleName)=0
Set write for function.
virtual void | setMaxSamples (uint32_t maxFrames)=0
Set the maximum number of frames.
virtual void | setFrames (uint32_t numFrames, const uint32_t *frames)=0
Set the frames.
virtual void | setFramePeriod (uint32_t period)=0
Set the frame period.
virtual void | setCallPerFrameMaxCount (uint32_t cpfMaxCount)=0
Set maximal count of kernel calls per frame.
virtual void | setWriteForNotSuccessfulKernel (bool flag)=0
Set flag for writing kernel context for kernel that return not successful error code.
virtual bool | runKernel (const char *path)=0
Run a kernel.

Detailed Description

A class that set information on kernels should be tested and give directive for creation ApexCudaTestContext.

The documentation for this class was generated from the following file:
  • CudaTestManager.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CudaTestManager
nvidia::apex::CudaTestManager Member List
This is the complete list of members for nvidia::apex::CudaTestManager, including all inherited members.
runKernel(const char *path)=0 | nvidia::apex::CudaTestManager | [pure virtual]
setCallPerFrameMaxCount(uint32_t cpfMaxCount)=0 | nvidia::apex::CudaTestManager | [pure virtual]
setFramePeriod(uint32_t period)=0 | nvidia::apex::CudaTestManager | [pure virtual]
setFrames(uint32_t numFrames, const uint32_t *frames)=0 | nvidia::apex::CudaTestManager | [pure virtual]
setMaxSamples(uint32_t maxFrames)=0 | nvidia::apex::CudaTestManager | [pure virtual]
setWriteForFunction(const char *functionName, const char *moduleName)=0 | nvidia::apex::CudaTestManager | [pure virtual]
setWriteForNotSuccessfulKernel(bool flag)=0 | nvidia::apex::CudaTestManager | [pure virtual]
setWritePath(const char *path)=0 | nvidia::apex::CudaTestManager | [pure virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::Curve Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Curve
Public Member Functions
nvidia::apex::Curve Class Reference

#include <Curve.h>

List of all members.

Public Member Functions

virtual float | evaluate (float x) const =0
virtual uint32_t | addControlPoint (const Vec2R &controlPoint)=0
virtual void | addControlPoints (::NvParameterized::Interface *param,::NvParameterized::Handle &hPoints)=0
virtual bool | calculateControlPoints (float x, Vec2R &outXPoints, Vec2R &outYPoints) const =0
virtual uint32_t | calculateFollowingControlPoint (float xValue) const =0
virtual const Vec2R * | getControlPoints (uint32_t &outCount) const =0
get the array of control points

Detailed Description

The Curve is a class for storing control points on a curve and evaluating the results later.

Member Function Documentation

virtual uint32_t nvidia::apex::Curve::addControlPoint ( const Vec2R & controlPoint ) [pure virtual]

Add a control point to the list of control points, returning the index of the new point.

virtual void nvidia::apex::Curve::addControlPoints | ( | ::NvParameterized::Interface * | param,
 |  | ::NvParameterized::Handle & | hPoints
 | ) |  | [pure virtual]

Add a control points to the list of control points. Assuming the hPoints points to a list of vec2s

virtual bool nvidia::apex::Curve::calculateControlPoints | ( | float | x,
 |  | Vec2R & | outXPoints,
 |  | Vec2R & | outYPoints
 | ) |  | const [pure virtual]

Locates the control points that contain x, placing the resulting control points in the two out parameters. Returns true if the points were found, false otherwise. If the points were not found, the output variables are untouched

virtual uint32_t nvidia::apex::Curve::calculateFollowingControlPoint ( float xValue ) const [pure virtual]

Locates the first control point with x larger than xValue or the nimber of control points if such point doesn't exist

virtual float nvidia::apex::Curve::evaluate ( float x ) const [pure virtual]

Retrieve the output Y for the specified input x, based on the properties of the stored curve described by mControlPoints.

The documentation for this class was generated from the following file:
  • Curve.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Curve
nvidia::apex::Curve Member List
This is the complete list of members for nvidia::apex::Curve, including all inherited members.
addControlPoint(const Vec2R &controlPoint)=0 | nvidia::apex::Curve | [pure virtual]
addControlPoints(::NvParameterized::Interface *param,::NvParameterized::Handle &hPoints)=0 | nvidia::apex::Curve | [pure virtual]
calculateControlPoints(float x, Vec2R &outXPoints, Vec2R &outYPoints) const =0 | nvidia::apex::Curve | [pure virtual]
calculateFollowingControlPoint(float xValue) const =0 | nvidia::apex::Curve | [pure virtual]
evaluate(float x) const =0 | nvidia::apex::Curve | [pure virtual]
getControlPoints(uint32_t &outCount) const =0 | nvidia::apex::Curve | [pure virtual]
~Curve() (defined in nvidia::apex::Curve) | nvidia::apex::Curve | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::CustomBufferIterator Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CustomBufferIterator
Public Member Functions
nvidia::apex::CustomBufferIterator Class Reference

This class is used to access specific elements in an untyped chunk of memory. More...

#include <CustomBufferIterator.h>

List of all members.

Public Member Functions

virtual void * | getVertex (uint32_t triangleIndex, uint32_t vertexIndex) const =0
Returns the memory start of a specific vertex.
virtual int32_t | getAttributeIndex (const char *attributeName) const =0
Returns the index of a certain custom buffer.
virtual void * | getVertexAttribute (uint32_t triangleIndex, uint32_t vertexIndex, const char *attributeName, RenderDataFormat::Enum &outFormat) const =0
Returns a pointer to a certain attribute of the specified vertex/triangle.
virtual void * | getVertexAttribute (uint32_t triangleIndex, uint32_t vertexIndex, uint32_t attributeIndex, RenderDataFormat::Enum &outFormat, const char *&outName) const =0
Returns a pointer to a certain attribute of the specified vertex/triangle.

Detailed Description

This class is used to access specific elements in an untyped chunk of memory.

Member Function Documentation

virtual int32_t nvidia::apex::CustomBufferIterator::getAttributeIndex ( const char * attributeName ) const [pure virtual]

Returns the index of a certain custom buffer.

Note:
This is constant throughout the existence of this class.
virtual void* nvidia::apex::CustomBufferIterator::getVertex | ( | uint32_t | triangleIndex,
 |  | uint32_t | vertexIndex
 | ) |  | const [pure virtual]

Returns the memory start of a specific vertex.

All custom buffers are stored interleaved, so this is also the memory start of the first attribute of this vertex.

virtual void* nvidia::apex::CustomBufferIterator::getVertexAttribute | ( | uint32_t | triangleIndex,
 |  | uint32_t | vertexIndex,
 |  | const char * | attributeName,
 |  | RenderDataFormat::Enum & | outFormat
 | ) |  | const [pure virtual]

Returns a pointer to a certain attribute of the specified vertex/triangle.

Parameters:
[in] | triangleIndex | Which triangle
[in] | vertexIndex | Which of the vertices of this triangle (must be either 0, 1 or 2)
[in] | attributeName | The name of the attribute you wish the data for
[out] | outFormat | The format of the attribute, reinterpret_cast the void pointer accordingly.
virtual void* nvidia::apex::CustomBufferIterator::getVertexAttribute | ( | uint32_t | triangleIndex,
 |  | uint32_t | vertexIndex,
 |  | uint32_t | attributeIndex,
 |  | RenderDataFormat::Enum & | outFormat,
 |  | const char *& | outName
 | ) |  | const [pure virtual]

Returns a pointer to a certain attribute of the specified vertex/triangle.

Note:
This is the faster method than the one above since it won't do any string comparisons
Parameters:
[in] | triangleIndex | Which triangle
[in] | vertexIndex | Which of the vertices of this triangle (must be either 0, 1 or 2)
[in] | attributeIndex | The indexof the attribute you wish the data for (use CustomBufferIterator::getAttributeIndex to find the index to a certain attribute name
[out] | outFormat | The format of the attribute, reinterpret_cast the void pointer accordingly.
[out] | outName | The name associated with the attribute
The documentation for this class was generated from the following file:
  • CustomBufferIterator.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CustomBufferIterator
nvidia::apex::CustomBufferIterator Member List
This is the complete list of members for nvidia::apex::CustomBufferIterator, including all inherited members.
CustomBufferIterator() (defined in nvidia::apex::CustomBufferIterator) | nvidia::apex::CustomBufferIterator | [inline, protected]
getAttributeIndex(const char *attributeName) const =0 | nvidia::apex::CustomBufferIterator | [pure virtual]
getVertex(uint32_t triangleIndex, uint32_t vertexIndex) const =0 | nvidia::apex::CustomBufferIterator | [pure virtual]
getVertexAttribute(uint32_t triangleIndex, uint32_t vertexIndex, const char *attributeName, RenderDataFormat::Enum &outFormat) const =0 | nvidia::apex::CustomBufferIterator | [pure virtual]
getVertexAttribute(uint32_t triangleIndex, uint32_t vertexIndex, uint32_t attributeIndex, RenderDataFormat::Enum &outFormat, const char *&outName) const =0 | nvidia::apex::CustomBufferIterator | [pure virtual]
~CustomBufferIterator() (defined in nvidia::apex::CustomBufferIterator) | nvidia::apex::CustomBufferIterator | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActor
Public Member Functions
nvidia::apex::DestructibleActor Class Reference

#include <DestructibleActor.h>

Inheritance diagram for nvidia::apex::DestructibleActor:
nvidia::apex::Actor nvidia::apex::Renderable nvidia::apex::ActorSource nvidia::apex::ApexInterface nvidia::apex::RenderDataProvider nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual const RenderMeshActor * | getRenderMeshActor (DestructibleActorMeshType::Enum type=DestructibleActorMeshType::Skinned) const =0
virtual const
DestructibleParameters & 		getDestructibleParameters () const =0
virtual void | setDestructibleParameters (const DestructibleParameters &destructibleParameters)=0
virtual PxMat44 | getInitialGlobalPose () const =0
virtual void | setInitialGlobalPose (const PxMat44 &pose)=0
virtual PxVec3 | getScale () const =0
virtual bool | isInitiallyDynamic () const =0
virtual void | getChunkVisibilities (uint8_t *visibilityArray, uint32_t visibilityArraySize) const =0
virtual uint32_t | getNumVisibleChunks () const =0
virtual const uint16_t * | getVisibleChunks () const =0
virtual bool | acquireChunkEventBuffer (const nvidia::DestructibleChunkEvent *&buffer, uint32_t &bufferSize)=0
virtual bool | releaseChunkEventBuffer (bool clearBuffer=true)=0
virtual bool | acquirePhysXActorBuffer (physx::PxRigidDynamic **&buffer, uint32_t &bufferSize, uint32_t flags=DestructiblePhysXActorQueryFlags::AllStates)=0
virtual bool | releasePhysXActorBuffer ()=0
virtual physx::PxRigidDynamic * | getChunkPhysXActor (uint32_t chunkIndex)=0
virtual uint32_t | getChunkPhysXShapes (physx::PxShape **&shapes, uint32_t chunkIndex) const =0
virtual PxTransform | getChunkPose (uint32_t chunkIndex) const =0
virtual PxTransform | getChunkTransform (uint32_t chunkIndex) const =0
virtual PxVec3 | getChunkLinearVelocity (uint32_t chunkIndex) const =0
virtual PxVec3 | getChunkAngularVelocity (uint32_t chunkIndex) const =0
virtual const PxMat44 | getChunkTM (uint32_t chunkIndex) const =0
virtual int32_t | getChunkBehaviorGroupIndex (uint32_t chunkIndex) const =0
virtual uint32_t | getChunkActorFlags (uint32_t chunkIndex) const =0
virtual void | setGlobalPose (const PxMat44 &pose)=0
virtual bool | getGlobalPose (PxMat44 &pose)=0
virtual void | setLinearVelocity (const PxVec3 &linearVelocity)=0
virtual void | setAngularVelocity (const PxVec3 &angularVelocity)=0
virtual void | setDynamic (int32_t chunkIndex=ModuleDestructibleConst::INVALID_CHUNK_INDEX)=0
virtual bool | isDynamic (uint32_t chunkIndex) const =0
virtual void | enableHardSleeping ()=0
virtual void | disableHardSleeping (bool wake=false)=0
virtual bool | isHardSleepingEnabled () const =0
virtual bool | setChunkPhysXActorAwakeState (uint32_t chunkIndex, bool awake)=0
virtual bool | addForce (uint32_t chunkIndex, const PxVec3 &force, physx::PxForceMode::Enum mode, const PxVec3 *position=NULL, bool wakeup=true)=0
virtual void | setSkinnedOverrideMaterial (uint32_t submeshIndex, const char *overrideMaterialName)=0
virtual void | setStaticOverrideMaterial (uint32_t submeshIndex, const char *overrideMaterialName)=0
virtual void | setRuntimeFractureOverridePattern (const char *overridePatternName)=0
virtual void | applyDamage (float damage, float momentum, const PxVec3 &position, const PxVec3 &direction, int32_t chunkIndex=ModuleDestructibleConst::INVALID_CHUNK_INDEX, void *damageUserData=NULL)=0
virtual void | applyRadiusDamage (float damage, float momentum, const PxVec3 &position, float radius, bool falloff, void *damageUserData=NULL)=0
virtual void | takeImpact (const PxVec3 &force, const PxVec3 &position, uint16_t chunkIndex, PxActor const *damageImpactActor)=0
virtual int32_t | rayCast (float &time, PxVec3 &normal, const PxVec3 &worldRayOrig, const PxVec3 &worldRayDir, DestructibleActorRaycastFlags::Enum flags, int32_t parentChunkIndex=ModuleDestructibleConst::INVALID_CHUNK_INDEX) const =0
virtual int32_t | obbSweep (float &time, PxVec3 &normal, const PxVec3 &worldBoxCenter, const PxVec3 &worldBoxExtents, const PxMat33 &worldBoxRot, const PxVec3 &worldDisplacement, DestructibleActorRaycastFlags::Enum flags) const =0
virtual void | setCrumbleEmitterState (bool enable)=0
virtual void | setDustEmitterState (bool enable)=0
virtual void | setPreferredRenderVolume (RenderVolume *volume, DestructibleEmitterType::Enum type)=0
virtual EmitterActor * | getApexEmitter (DestructibleEmitterType::Enum type)=0
virtual bool | recreateApexEmitter (DestructibleEmitterType::Enum type)=0
virtual const
::NvParameterized::Interface * 		getNvParameterized (DestructibleParameterizedType::Enum type=DestructibleParameterizedType::State) const =0
Returns the actor's NvParamaterized interface This cannot be directly modified! It is read only to the user. This handle can be used to directly serialize the complete actor state.
virtual void | setNvParameterized (::NvParameterized::Interface *)=0
Sets the actor's state via the NvParameterized object This can be used to update the state from deserialized data. The actor assumes control of the interface.
virtual bool | setSyncParams (uint32_t userActorID, uint32_t actorSyncFlags=0, const DestructibleActorSyncState *actorSyncState=NULL, const DestructibleChunkSyncState *chunkSyncState=NULL)=0
virtual bool | setHitChunkTrackingParams (bool flushHistory, bool startTracking, uint32_t trackingDepth, bool trackAllChunks=true)=0
virtual bool | getHitChunkHistory (const DestructibleHitChunk *&hitChunkContainer, uint32_t &hitChunkCount) const =0
virtual bool | forceChunkHits (const DestructibleHitChunk *hitChunkContainer, uint32_t hitChunkCount, bool removeChunks=true, bool deferredEvent=false, PxVec3 damagePosition=PxVec3(0.0f), PxVec3 damageDirection=PxVec3(0.0f))=0
virtual bool | getDamageColoringHistory (const DamageEventCoreData *&damageEventCoreDataContainer, uint32_t &damageEventCoreDataCount) const =0
virtual bool | forceDamageColoring (const DamageEventCoreData *damageEventCoreDataContainer, uint32_t damageEventCoreDataCount)=0
virtual PxBounds3 | getLocalBounds () const =0
virtual PxBounds3 | getOriginalBounds () const =0
virtual bool | isChunkSolitary (int32_t chunkIndex) const =0
virtual PxBounds3 | getChunkBounds (uint32_t chunkIndex) const =0
virtual PxBounds3 | getChunkLocalBounds (uint32_t chunkIndex) const =0
virtual bool | isChunkDestroyed (int32_t chunkIndex) const =0
virtual uint32_t | getSupportDepthChunkIndices (uint32_t *const OutChunkIndices, uint32_t MaxOutIndices) const =0
virtual uint32_t | getSupportDepth () const =0
virtual void | setDeleteFracturedChunks (bool inDeleteChunkMode)=0
virtual DestructibleRenderable * | acquireRenderableReference ()=0
virtual uint32_t | getCustomBehaviorGroupCount () const =0
virtual bool | getBehaviorGroup (nvidia::DestructibleBehaviorGroupDesc &behaviorGroupDesc, int32_t index=-1) const =0

Detailed Description

Destructible actor API. The destructible actor is instanced from an DestructibleAsset.

Member Function Documentation

virtual bool nvidia::apex::DestructibleActor::acquireChunkEventBuffer | ( | const nvidia::DestructibleChunkEvent *& | buffer,
 |  | uint32_t & | bufferSize
 | ) |  | [pure virtual]

Locks the chunk event buffer, and (if successful) returns the head of the chunk event buffer in the buffer field and the length of the buffer (the number of events) in the bufferSize field. To unlock the buffer, use releaseChunkEventBuffer(). See DestructibleChunkEvent. This buffer is filled with chunk events if the DestructibleActor parameter createChunkEvents is set to true. This buffer is not automatically cleared by APEX. The user must clear it using releaseChunkEventBuffer(true).

N.B. This function only works when the user has *not* requested chunk event callbacks via ModuleDestructible::scheduleChunkStateEventCallback.

Returns:
Returns true if successful, false otherwise.
virtual bool nvidia::apex::DestructibleActor::acquirePhysXActorBuffer | ( | physx::PxRigidDynamic **& | buffer,
 |  | uint32_t & | bufferSize,
 |  | uint32_t | flags = DestructiblePhysXActorQueryFlags::AllStates
 | ) |  | [pure virtual]

Locks a PhysX actor buffer, and (if successful) returns the head of the buffer in the buffer field and the length of the buffer (the number of PhysX actors) in the bufferSize field. To unlock the buffer, use releasePhysXActorBuffer(). The user must release this buffer before another call to releasePhysXActorBuffer.

Parameters:
buffer | returned buffer, if successful
bufferSize | returned buffer size, if successful
flags | flags which control which actors are returned. See DestructiblePhysXActorQueryFlags.
Returns:
Returns true if successful, false otherwise.
virtual DestructibleRenderable* nvidia::apex::DestructibleActor::acquireRenderableReference ( ) [pure virtual]

Acquire a pointer to the destructible's renderable proxy and increment its reference count. The DestructibleRenderable will only be deleted when its reference count is zero. Calls to DestructibleRenderable::release decrement the reference count, as does a call to DestructibleActor::release(). .

virtual bool nvidia::apex::DestructibleActor::addForce | ( | uint32_t | chunkIndex,
 |  | const PxVec3 & | force,
 |  | physx::PxForceMode::Enum | mode,
 |  | const PxVec3 * | position = NULL,
 |  | bool | wakeup = true
 | ) |  | [pure virtual]

Apply force to chunk's actor

Parameters:
chunkIndex | the chunk index within the actor
force | force, impulse, velocity change, or acceleration (depending on value of mode)
mode | PhysX force mode (PxForceMode::Enum)
position | if not null, applies force at position. Otherwise applies force at center of mass
wakeup | if true, the actor is awakened

Returns true iff successful.

virtual void nvidia::apex::DestructibleActor::applyDamage | ( | float | damage,
 |  | float | momentum,
 |  | const PxVec3 & | position,
 |  | const PxVec3 & | direction,
 |  | int32_t | chunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX,
 |  | void * | damageUserData = NULL
 | ) |  | [pure virtual]

Damage Apply damage at a point. Damage will be propagated into the destructible based upon its DestructibleParameters.

Parameters:
damage | the amount of damage at the damage point
momentum | the magnitude of the impulse to transfer to the actor
position | the damage location
direction | direction of impact. This is valid even if momentum = 0, for use in deformation calculations.
chunkIndex | which chunk to damage (returned by rayCast and ModuleDestructible::getDestructibleAndChunk). If chunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX, then the nearest visible chunk hit is found.
damageUserData | pointer which will be returned in damage and fracture event callbacks
virtual void nvidia::apex::DestructibleActor::applyRadiusDamage | ( | float | damage,
 |  | float | momentum,
 |  | const PxVec3 & | position,
 |  | float | radius,
 |  | bool | falloff,
 |  | void * | damageUserData = NULL
 | ) |  | [pure virtual]

Apply damage to all chunks within a radius. Damage will also propagate into the destructible based upon its DestructibleParameters.

Parameters:
damage | the amount of damage at the damage point
momentum | the magnitude of the impulse to transfer to each chunk
position | the damage location
radius | distance from damage location at which chunks will be affected
falloff | whether or not to decrease damage with distance from the damage location. If true, damage will decrease linearly from the full damage (at zero distance) to zero damage (at radius). If false, full damage is applied to all chunks within the radius.
damageUserData | pointer which will be returned in damage and fracture event callbacks
virtual void nvidia::apex::DestructibleActor::disableHardSleeping ( bool wake = false ) [pure virtual]

See the comments for enableHardSleeping() for a description of this feature. The disableHardSleeping function takes a "wake" parameter, which (if true) will not only turn kinematic-sleeping actors dynamic, but wake them as well.

virtual void nvidia::apex::DestructibleActor::enableHardSleeping ( ) [pure virtual]

If "hard sleeping" is enabled, physx actors for chunk islands that go to sleep will be turned kinematic. If a chunk island has chunks from more than one DestructibleActor, then hard sleeping will be used if ANY of the destructibles have hard sleeping enabled.

virtual bool nvidia::apex::DestructibleActor::forceChunkHits | ( | const DestructibleHitChunk * | hitChunkContainer,
 |  | uint32_t | hitChunkCount,
 |  | bool | removeChunks = true,
 |  | bool | deferredEvent = false,
 |  | PxVec3 | damagePosition = PxVec3(0.0f),
 |  | PxVec3 | damageDirection = PxVec3(0.0f)
 | ) |  | [pure virtual]

Force the actor to register chunk hits.

Parameters:
hitChunkContainer | should take in an argument that was generated from another destructible actor. See getHitChunkHistory()
hitChunkCount | hit chunk count
removeChunks | removeChunks == true indicates that the chunks given by hitChunkContainer will be forcibly removed.
deferredEvent | whether to enable deferred event mode. If true, fracture events won't get processed until the next tick.
damagePosition | passed through to ApexDamageEventReportData::hitPosition and hitDirection in the damage notify output by APEX.
damageDirection | passed through to ApexDamageEventReportData::hitPosition and hitDirection in the damage notify output by APEX.
virtual bool nvidia::apex::DestructibleActor::forceDamageColoring | ( | const DamageEventCoreData * | damageEventCoreDataContainer,
 |  | uint32_t | damageEventCoreDataCount
 | ) |  | [pure virtual]

Force the actor to register damage coloring.

Parameters:
damageEventCoreDataContainer | should take in an argument that was generated from another destructible actor. See getDamageColoringHistory()
damageEventCoreDataCount | the count of damageEventCoreDataContainer.
Returns:
Returns true if the function executes correctly with the given arguments.
virtual EmitterActor* nvidia::apex::DestructibleActor::getApexEmitter ( DestructibleEmitterType::Enum type ) [pure virtual]

Returns the EmitterActor of either a dust or crumble emitter Note - only crumble emitters are implemented in 1.2.0

virtual bool nvidia::apex::DestructibleActor::getBehaviorGroup | ( | nvidia::DestructibleBehaviorGroupDesc & | behaviorGroupDesc,
 |  | int32_t | index = -1
 | ) |  | const [pure virtual]

Access to behavior groups created for this actor. Each chunk has a behavior group index associated with it.

This returns the indexed behavior group. The index must be either -1 (for the default group) or in the range [0, getCustomBehaviorGroupCount()-1]. If any other index is given, this function returns false. Otherwise it returns true and the behavior descriptor is filled in.

virtual uint32_t nvidia::apex::DestructibleActor::getChunkActorFlags ( uint32_t chunkIndex ) const [pure virtual]

Returns the DestructibleActorChunkFlags for a chunk. These are flags that describe aspects of the chunk that can only be determined at runtime.

Parameters:
chunkIndex the chunk index within the actor
virtual PxVec3 nvidia::apex::DestructibleActor::getChunkAngularVelocity ( uint32_t chunkIndex ) const [pure virtual]

Returns a chunk's angular velocity in world space.

Parameters:
chunkIndex the chunk index within the actor
virtual int32_t nvidia::apex::DestructibleActor::getChunkBehaviorGroupIndex ( uint32_t chunkIndex ) const [pure virtual]

Returns the behavior group index associated with the chunk. Use getBehaviorGroup() to access the behavior group data. The index will either be -1, in which case it is the default behavior group, or in the range [0, getCustomBehaviorGroupCount()-1]. Any of those values is valid for getBehaviorGroup().

Parameters:
chunkIndex the chunk index within the actor
virtual PxBounds3 nvidia::apex::DestructibleActor::getChunkBounds ( uint32_t chunkIndex ) const [pure virtual]

Accessor to query the axis aligned bounding box of a given chunk in world-space.

virtual PxVec3 nvidia::apex::DestructibleActor::getChunkLinearVelocity ( uint32_t chunkIndex ) const [pure virtual]

Returns a chunk's linear velocity in world space.

Parameters:
chunkIndex the chunk index within the actor
virtual PxBounds3 nvidia::apex::DestructibleActor::getChunkLocalBounds ( uint32_t chunkIndex ) const [pure virtual]

Accessor to query the axis aligned bounding box of a given chunk in chunk local-space.

virtual physx::PxRigidDynamic* nvidia::apex::DestructibleActor::getChunkPhysXActor ( uint32_t chunkIndex ) [pure virtual]

Returns the PhysX actor associated with the given chunk. Note, more than one chunk may be associated with a given PhysX actor, and chunks from different DestructibleActors may even be associated with the same PhysX actor. Caution is recommended when using this function. During APEX scene simulate/fetchResults, this actor may be deleted, replaced, or tampered with. When the chunk in question is not visible, but an ancestor of a visible chunk, the visible ancestor's shapes are returned.

Parameters:
chunkIndex the chunk index within the actor
virtual uint32_t nvidia::apex::DestructibleActor::getChunkPhysXShapes | ( | physx::PxShape **& | shapes,
 |  | uint32_t | chunkIndex
 | ) |  | const [pure virtual]

Returns the PhysX shapes associated with the given chunk. Caution is recommended when using this function. During APEX scene simulate/fetchResults, this actor may be deleted, replaced, or tampered with. It is safe to use the results of this function during the chunk event callback (see ModuleDestructible::setChunkReport).

Parameters:
shapes | returned pointer to array of shapes. May be NULL.
chunkIndex | the chunk index within the actor
Returns:
size of array pointed to by shapes pointer. 0 if shapes == NULL.
virtual PxTransform nvidia::apex::DestructibleActor::getChunkPose ( uint32_t chunkIndex ) const [pure virtual]

Returns current pose of a chunk's reference frame, without scaling. This pose can be used to transform the chunk's hull data from the asset into global space.

Parameters:
chunkIndex the chunk index within the actor
Note:
This pose's translation might not be inside the chunk. Use getChunkBounds to get a better representation of where the chunk is located.
virtual const PxMat44 nvidia::apex::DestructibleActor::getChunkTM ( uint32_t chunkIndex ) const [pure virtual]

Returns the transform of the chunk's graphical representation. This may have a scale component.

Parameters:
chunkIndex the chunk index within the actor
virtual PxTransform nvidia::apex::DestructibleActor::getChunkTransform ( uint32_t chunkIndex ) const [pure virtual]

Returns current pose of a chunk's reference frame, without scaling. This pose can be used to transform the chunk's hull data from the asset into global space.

Parameters:
chunkIndex the chunk index within the actor
Note:
This pose's translation might not be inside the chunk. Use getChunkBounds to get a better representation of where the chunk is located.
virtual void nvidia::apex::DestructibleActor::getChunkVisibilities | ( | uint8_t * | visibilityArray,
 |  | uint32_t | visibilityArraySize
 | ) |  | const [pure virtual]

Returns an array of visibility data for each chunk. Each byte in the array is 0 if the corresponding chunkIndex is invisible, 1 if visibile.

Parameters:
visibilityArray | a pointer to the byte buffer to hold the visibility values.
visibilityArraySize | the size of the visibilityArray
virtual uint32_t nvidia::apex::DestructibleActor::getCustomBehaviorGroupCount ( ) const [pure virtual]

Access to behavior groups created for this actor. Each chunk has a behavior group index associated with it.

Returns:
This returns the number of custom (non-default) behavior groups.
virtual bool nvidia::apex::DestructibleActor::getDamageColoringHistory | ( | const DamageEventCoreData *& | damageEventCoreDataContainer,
 |  | uint32_t & | damageEventCoreDataCount
 | ) |  | const [pure virtual]

Get the damage coloring history of the actor. To start caching damage coloring, see setHitChunkTrackingParams()

Returns:
Returns true if the function executes correctly with the given arguments.
virtual const DestructibleParameters& nvidia::apex::DestructibleActor::getDestructibleParameters ( ) const [pure virtual]

Gets the destructible's DestructibleParameter block of parameters. These are initially set from the asset.

virtual bool nvidia::apex::DestructibleActor::getGlobalPose ( PxMat44 & pose ) [pure virtual]

Get the destructible actor's global pose. This will be the pose of the physx PxActor or PxActor for the static chunks in the structure containing this actor, if there are static chunks. If there are no static chunks in the structure, pose will not be modified and false will be returned. Otherwise pose will be filled in with a scale-free transform, and true is returned.

virtual bool nvidia::apex::DestructibleActor::getHitChunkHistory | ( | const DestructibleHitChunk *& | hitChunkContainer,
 |  | uint32_t & | hitChunkCount
 | ) |  | const [pure virtual]

Get the chunk hit history of the actor. To start caching chunk hits, see setHitChunkTrackingParams()

Returns:
Returns true if the function executes correctly with the given arguments.
virtual PxMat44 nvidia::apex::DestructibleActor::getInitialGlobalPose ( ) const [pure virtual]

Gets the global pose used when the actor is added to the scene, in the DestructibleActorDesc

virtual PxBounds3 nvidia::apex::DestructibleActor::getLocalBounds ( ) const [pure virtual]

Accessor to get the initial locally-aligned bounding box of a destructible actor.

virtual uint32_t nvidia::apex::DestructibleActor::getNumVisibleChunks ( ) const [pure virtual]

Returns the number of visible chunks. This is the number of 1's written to the visibilityArray by getChunkVisibilities.

virtual PxBounds3 nvidia::apex::DestructibleActor::getOriginalBounds ( ) const [pure virtual]

Accessor to get the initial world axis-aligned bounding box of a destructible actor.

virtual const RenderMeshActor* nvidia::apex::DestructibleActor::getRenderMeshActor ( DestructibleActorMeshType::Enum type = DestructibleActorMeshType::Skinned ) const [pure virtual]

Get the render mesh actor for the specified mesh type.

virtual PxVec3 nvidia::apex::DestructibleActor::getScale ( ) const [pure virtual]

Gets the destructible actor's 3D (possibly nonuniform) scale

virtual uint32_t nvidia::apex::DestructibleActor::getSupportDepth ( ) const [pure virtual]

Query the actor's support depth.

virtual uint32_t nvidia::apex::DestructibleActor::getSupportDepthChunkIndices | ( | uint32_t *const | OutChunkIndices,
 |  | uint32_t | MaxOutIndices
 | ) |  | const [pure virtual]

Accessor to get the array of chunk indices at the support depth.

virtual const uint16_t* nvidia::apex::DestructibleActor::getVisibleChunks ( ) const [pure virtual]

Returns a pointer to an array of visible chunk indices.

virtual bool nvidia::apex::DestructibleActor::isChunkDestroyed ( int32_t chunkIndex ) const [pure virtual]

Accessor to query if a chunk has been destroyed.

virtual bool nvidia::apex::DestructibleActor::isChunkSolitary ( int32_t chunkIndex ) const [pure virtual]

Accessor to query if a chunk is part of a detached island.

virtual bool nvidia::apex::DestructibleActor::isDynamic ( uint32_t chunkIndex ) const [pure virtual]

Returns true if the chunkIndex is valid, and the indexed chunk is dynamic. Returns false otherwise.

virtual bool nvidia::apex::DestructibleActor::isHardSleepingEnabled ( ) const [pure virtual]

Returns true iff hard sleeping is selected for this DestructibleActor.

virtual bool nvidia::apex::DestructibleActor::isInitiallyDynamic ( ) const [pure virtual]

Returns true iff the destructible actor starts off life dynamic.

virtual int32_t nvidia::apex::DestructibleActor::obbSweep | ( | float & | time,
 |  | PxVec3 & | normal,
 |  | const PxVec3 & | worldBoxCenter,
 |  | const PxVec3 & | worldBoxExtents,
 |  | const PxMat33 & | worldBoxRot,
 |  | const PxVec3 & | worldDisplacement,
 |  | DestructibleActorRaycastFlags::Enum | flags
 | ) |  | const [pure virtual]

Physx SDK 3.X. Returns the index of the first visible chunk hit in the actor by swept oriented bounding box, if any. Otherwise returns ModuleDestructibleConst::INVALID_CHUNK_INDEX. If a chunk is hit, the time and normal fields are modified.

Parameters:
[out] | time | (return value) of the time to the hit chunk, if any.
[out] | normal | (return value) the surface normal of the hit chunk's collision volume, if any.
worldBoxCenter | the center of the obb to sweep against the actor, oriented in world space
worldBoxExtents | the extents of the obb to sweep against the actor, oriented in world space
worldBoxRot | the rotation of the obb to sweep against the actor, oriented in world space
worldDisplacement | the displacement of the center of the worldBox through the sweep, in world space
flags | raycast control flags (see DestructibleActorRaycastFlags)
virtual int32_t nvidia::apex::DestructibleActor::rayCast | ( | float & | time,
 |  | PxVec3 & | normal,
 |  | const PxVec3 & | worldRayOrig,
 |  | const PxVec3 & | worldRayDir,
 |  | DestructibleActorRaycastFlags::Enum | flags,
 |  | int32_t | parentChunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX
 | ) |  | const [pure virtual]

PhysX SDK 3.X. Returns the index of the first visible chunk hit in the actor by worldRay, if any. Otherwise returns ModuleDestructibleConst::INVALID_CHUNK_INDEX. If a chunk is hit, the time and normal fields are modified.

Parameters:
[out] | time | (return value) of the time to the hit chunk, if any.
[out] | normal | (return value) the surface normal of the hit chunk's collision volume, if any.
worldRayOrig | origin of the ray to fire at the actor (the direction need not be normalized)
worldRayDir | direction of the ray to fire at the actor (the direction need not be normalized)
flags | raycast control flags (see DestructibleActorRaycastFlags)
parentChunkIndex | (if not equal to ModuleDestructibleConst::INVALID_CHUNK_INDEX) the chunk subhierarchy in which to confine the raycast. If parentChunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX, then the whole actor is searched.
virtual bool nvidia::apex::DestructibleActor::recreateApexEmitter ( DestructibleEmitterType::Enum type ) [pure virtual]

Recreates the Apex Emitter, if necessary. Use this method to re-initialize the crumble or dust emitter after a change has been made to a dependent asset Note - only crumble emitters are implemented in 1.2.0

virtual bool nvidia::apex::DestructibleActor::releaseChunkEventBuffer ( bool clearBuffer = true ) [pure virtual]

Releases the chunk event buffer, which may have been locked by acquireChunkEventBuffer(). If clearBuffer is true, the buffer will be erased before it is unlocked.

Returns:
Returns true if successful, false otherwise.
virtual bool nvidia::apex::DestructibleActor::releasePhysXActorBuffer ( ) [pure virtual]

Releases the PhysX actor buffer, which may have been locked by acquirePhysXActorBuffer(). The buffer will be erased before it is unlocked.

Returns:
Returns true if successful, false otherwise.
virtual void nvidia::apex::DestructibleActor::setAngularVelocity ( const PxVec3 & angularVelocity ) [pure virtual]

Sets the angular velocity of every dynamic chunk to the given value.

virtual bool nvidia::apex::DestructibleActor::setChunkPhysXActorAwakeState | ( | uint32_t | chunkIndex,
 |  | bool | awake
 | ) |  | [pure virtual]

Puts the PxActor associated with the given chunk to sleep, or wakes it up, depending upon the value of the 'awake' bool.

Parameters:
chunkIndex | the chunk index within the actor
awake | if true, wakes the actor, otherwise puts the actor to sleep

Returns true iff successful.

virtual void nvidia::apex::DestructibleActor::setCrumbleEmitterState ( bool enable ) [pure virtual]

Enable/disable the crumble emitter

virtual void nvidia::apex::DestructibleActor::setDeleteFracturedChunks ( bool inDeleteChunkMode ) [pure virtual]

Set the actor to delete its fractured chunks instead of simulating them.

virtual void nvidia::apex::DestructibleActor::setDestructibleParameters ( const DestructibleParameters & destructibleParameters ) [pure virtual]

Sets the destructible's DestructibleParameter block of parameters. These may be set at runtime.

virtual void nvidia::apex::DestructibleActor::setDustEmitterState ( bool enable ) [pure virtual]

Enable/disable the dust emitter Note - this is a placeholder API. The dust feature is disabled in 1.2.0.

virtual void nvidia::apex::DestructibleActor::setDynamic ( int32_t chunkIndex = ModuleDestructibleConst::INVALID_CHUNK_INDEX ) [pure virtual]

If the indexed chunk is visible, it is made dynamic (if it is not already). If ModuleDestructibleConst::INVALID_CHUNK_INDEX is passed in, all visible chunks in the destructible actor are made dynamic, if they are not already.

virtual void nvidia::apex::DestructibleActor::setGlobalPose ( const PxMat44 & pose ) [pure virtual]

Set the destructible actor's global pose. This will only be applied to the physx PxActor or PxActor for the static chunks, and therefore will apply to all static chunks in the structure which contains the this destructible actor. This pose should not contain scale, as the scale is already contained in the actor's scale parameter.

virtual bool nvidia::apex::DestructibleActor::setHitChunkTrackingParams | ( | bool | flushHistory,
 |  | bool | startTracking,
 |  | uint32_t | trackingDepth,
 |  | bool | trackAllChunks = true
 | ) |  | [pure virtual]

Set the tracking properties of the actor for chunks that are hit. Chunks that are hit are chunks directly affected by fracture events.

Parameters:
flushHistory | flushHistory == true indicates that both the cached chunk hit history and the cached damage event core data will be cleared. To get the chunk hit history of this actor, see getHitChunkHistory() To get the damage coloring history of this actor, see getDamageColoringHistory()
startTracking | startTracking == true indicates that chunk hits and damage coloring will begin caching internally. The actor does not cache chunk hits by default.
trackingDepth | the depth at which hit chunks will be cached. This value should not exceed the maximum depth level.
trackAllChunks | trackAllChunks == true indicates that all the chunks will be cached, trackAllChunks == false indicates that only static chunks will be cached.

Returns true if the function executes correctly with the given arguments.

virtual void nvidia::apex::DestructibleActor::setInitialGlobalPose ( const PxMat44 & pose ) [pure virtual]

Resets the initial global pose used for support calculations when the first simulation step is run.

virtual void nvidia::apex::DestructibleActor::setLinearVelocity ( const PxVec3 & linearVelocity ) [pure virtual]

Sets the linear velocity of every dynamic chunk to the given value.

virtual void nvidia::apex::DestructibleActor::setPreferredRenderVolume | ( | RenderVolume * | volume,
 |  | DestructibleEmitterType::Enum | type
 | ) |  | [pure virtual]

Sets a preferred render volume for a dust or crumble emitter Note - only crumble emitters are implemented in 1.2.0

virtual void nvidia::apex::DestructibleActor::setRuntimeFractureOverridePattern ( const char * overridePatternName ) [pure virtual]

Sets the override fracture pattern.

virtual void nvidia::apex::DestructibleActor::setSkinnedOverrideMaterial | ( | uint32_t | submeshIndex,
 |  | const char * | overrideMaterialName
 | ) |  | [pure virtual]

Sets the override material.

virtual void nvidia::apex::DestructibleActor::setStaticOverrideMaterial | ( | uint32_t | submeshIndex,
 |  | const char * | overrideMaterialName
 | ) |  | [pure virtual]

Sets the override material.

virtual bool nvidia::apex::DestructibleActor::setSyncParams | ( | uint32_t | userActorID,
 |  | uint32_t | actorSyncFlags = 0,
 |  | const DestructibleActorSyncState * | actorSyncState = NULL,
 |  | const DestructibleChunkSyncState * | chunkSyncState = NULL
 | ) |  | [pure virtual]

Set the syncing properties of the destructible actor.

Parameters:
userActorID | user-defined value used to identify the syncing actor. This value will be used to identify destructible actors between the server and client. userActorID = 0 is used for unregistering the actor as a syncing actor, and is the default value. The other arguments will then be forcibly set to the default (non-participating) values. userActorID != 0 registers the actor as a participating syncing actor. userActorID can be overwritten. In this case, the destructible actor which used to hold this userActorID will behave exactly like a call to set userActorID to 0.
actorSyncFlags | describes the kind of actor information that participates in syncing. See struct DestructibleActorSyncFlags
actorSyncState | describes information that allows finer control over the actor that participates in syncing. See struct DestructibleActorSyncState
chunkSyncState | describes information that allows finer control over the chunk that participates in syncing. See struct DestructibleChunkSyncState
Returns:
Returns true if arguments are accepted. Any one invalid argument will cause a return false. In such a case, no changes are made.
virtual void nvidia::apex::DestructibleActor::takeImpact | ( | const PxVec3 & | force,
 |  | const PxVec3 & | position,
 |  | uint16_t | chunkIndex,
 |  | PxActor const * | damageImpactActor
 | ) |  | [pure virtual]

Register a rigid body impact for impact-based damage. Much like applyDamage, but multplies the input 'force' by the destructible's forceToDamage parameter, and also allows the user to report the impacting PhysX actor

The documentation for this class was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActor
nvidia::apex::DestructibleActor Member List
This is the complete list of members for nvidia::apex::DestructibleActor, including all inherited members.
acquireChunkEventBuffer(const nvidia::DestructibleChunkEvent *&buffer, uint32_t &bufferSize)=0 | nvidia::apex::DestructibleActor | [pure virtual]
acquirePhysXActorBuffer(physx::PxRigidDynamic **&buffer, uint32_t &bufferSize, uint32_t flags=DestructiblePhysXActorQueryFlags::AllStates)=0 | nvidia::apex::DestructibleActor | [pure virtual]
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireRenderableReference()=0 | nvidia::apex::DestructibleActor | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
addForce(uint32_t chunkIndex, const PxVec3 &force, physx::PxForceMode::Enum mode, const PxVec3 *position=NULL, bool wakeup=true)=0 | nvidia::apex::DestructibleActor | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
applyDamage(float damage, float momentum, const PxVec3 &position, const PxVec3 &direction, int32_t chunkIndex=ModuleDestructibleConst::INVALID_CHUNK_INDEX, void *damageUserData=NULL)=0 | nvidia::apex::DestructibleActor | [pure virtual]
applyRadiusDamage(float damage, float momentum, const PxVec3 &position, float radius, bool falloff, void *damageUserData=NULL)=0 | nvidia::apex::DestructibleActor | [pure virtual]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
createPhysX3DescTemplate() const =0 | nvidia::apex::ActorSource | [pure virtual]
disableHardSleeping(bool wake=false)=0 | nvidia::apex::DestructibleActor | [pure virtual]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
enableHardSleeping()=0 | nvidia::apex::DestructibleActor | [pure virtual]
forceChunkHits(const DestructibleHitChunk *hitChunkContainer, uint32_t hitChunkCount, bool removeChunks=true, bool deferredEvent=false, PxVec3 damagePosition=PxVec3(0.0f), PxVec3 damageDirection=PxVec3(0.0f))=0 | nvidia::apex::DestructibleActor | [pure virtual]
forceDamageColoring(const DamageEventCoreData *damageEventCoreDataContainer, uint32_t damageEventCoreDataCount)=0 | nvidia::apex::DestructibleActor | [pure virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getApexEmitter(DestructibleEmitterType::Enum type)=0 | nvidia::apex::DestructibleActor | [pure virtual]
getBehaviorGroup(nvidia::DestructibleBehaviorGroupDesc &behaviorGroupDesc, int32_t index=-1) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getChunkActorFlags(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkAngularVelocity(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkBehaviorGroupIndex(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkBounds(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkLinearVelocity(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkLocalBounds(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkPhysXActor(uint32_t chunkIndex)=0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkPhysXShapes(physx::PxShape **&shapes, uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkPose(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkTM(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkTransform(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getChunkVisibilities(uint8_t *visibilityArray, uint32_t visibilityArraySize) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getCustomBehaviorGroupCount() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getDamageColoringHistory(const DamageEventCoreData *&damageEventCoreDataContainer, uint32_t &damageEventCoreDataCount) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getDestructibleParameters() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getGlobalPose(PxMat44 &pose)=0 | nvidia::apex::DestructibleActor | [pure virtual]
getHitChunkHistory(const DestructibleHitChunk *&hitChunkContainer, uint32_t &hitChunkCount) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getInitialGlobalPose() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getLocalBounds() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getNumVisibleChunks() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getNvParameterized(DestructibleParameterizedType::Enum type=DestructibleParameterizedType::State) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getOriginalBounds() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getPhysX3Template(PhysX3DescTemplate &dest) const =0 | nvidia::apex::ActorSource | [pure virtual]
getRenderMeshActor(DestructibleActorMeshType::Enum type=DestructibleActorMeshType::Skinned) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getScale() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getSupportDepth() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getSupportDepthChunkIndices(uint32_t *const OutChunkIndices, uint32_t MaxOutIndices) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
getVisibleChunks() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
isChunkDestroyed(int32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
isChunkSolitary(int32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
isDynamic(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
isHardSleepingEnabled() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
isInitiallyDynamic() const =0 | nvidia::apex::DestructibleActor | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
obbSweep(float &time, PxVec3 &normal, const PxVec3 &worldBoxCenter, const PxVec3 &worldBoxExtents, const PxMat33 &worldBoxRot, const PxVec3 &worldDisplacement, DestructibleActorRaycastFlags::Enum flags) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
rayCast(float &time, PxVec3 &normal, const PxVec3 &worldRayOrig, const PxVec3 &worldRayDir, DestructibleActorRaycastFlags::Enum flags, int32_t parentChunkIndex=ModuleDestructibleConst::INVALID_CHUNK_INDEX) const =0 | nvidia::apex::DestructibleActor | [pure virtual]
recreateApexEmitter(DestructibleEmitterType::Enum type)=0 | nvidia::apex::DestructibleActor | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseChunkEventBuffer(bool clearBuffer=true)=0 | nvidia::apex::DestructibleActor | [pure virtual]
releasePhysXActorBuffer()=0 | nvidia::apex::DestructibleActor | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setAngularVelocity(const PxVec3 &angularVelocity)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setChunkPhysXActorAwakeState(uint32_t chunkIndex, bool awake)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setCrumbleEmitterState(bool enable)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setDeleteFracturedChunks(bool inDeleteChunkMode)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setDestructibleParameters(const DestructibleParameters &destructibleParameters)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setDustEmitterState(bool enable)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setDynamic(int32_t chunkIndex=ModuleDestructibleConst::INVALID_CHUNK_INDEX)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setGlobalPose(const PxMat44 &pose)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setHitChunkTrackingParams(bool flushHistory, bool startTracking, uint32_t trackingDepth, bool trackAllChunks=true)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setInitialGlobalPose(const PxMat44 &pose)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setLinearVelocity(const PxVec3 &linearVelocity)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setNvParameterized(::NvParameterized::Interface *)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setPhysX3Template(const PhysX3DescTemplate *)=0 | nvidia::apex::ActorSource | [pure virtual]
setPreferredRenderVolume(RenderVolume *volume, DestructibleEmitterType::Enum type)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setRuntimeFractureOverridePattern(const char *overridePatternName)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setSkinnedOverrideMaterial(uint32_t submeshIndex, const char *overrideMaterialName)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setStaticOverrideMaterial(uint32_t submeshIndex, const char *overrideMaterialName)=0 | nvidia::apex::DestructibleActor | [pure virtual]
setSyncParams(uint32_t userActorID, uint32_t actorSyncFlags=0, const DestructibleActorSyncState *actorSyncState=NULL, const DestructibleChunkSyncState *chunkSyncState=NULL)=0 | nvidia::apex::DestructibleActor | [pure virtual]
takeImpact(const PxVec3 &force, const PxVec3 &position, uint16_t chunkIndex, PxActor const *damageImpactActor)=0 | nvidia::apex::DestructibleActor | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~DestructibleActor() (defined in nvidia::apex::DestructibleActor) | nvidia::apex::DestructibleActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleActorJoint Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorJoint
Public Member Functions
nvidia::apex::DestructibleActorJoint Class Reference

#include <DestructibleActorJoint.h>

Inheritance diagram for nvidia::apex::DestructibleActorJoint:
nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual PxJoint * joint ()=0

Detailed Description

Destructible actor joint - a wrapper for an PxJoint. This needs to be used because APEX may need to replace an PxJoint when fracturing occurs. Always use the joint() method to get the currently valid joint.

Member Function Documentation

virtual PxJoint* nvidia::apex::DestructibleActorJoint::joint ( ) [pure virtual]

PhysX SDK 3.X Access to the {xJoint represented by the DestructibleActorJoint. This is a temporary interface, and there are some shortcomings and restrictions: 1) The user will have to upcast the result of joint() to the correct joint type in order to access the interface for derived joints. 2) The user must never delete the joint using the PhysX SDK. To release this joint, simply use the release() method of this object (defined in the ApexInterface base class).

The documentation for this class was generated from the following file:
  • DestructibleActorJoint.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorJoint
nvidia::apex::DestructibleActorJoint Member List
This is the complete list of members for nvidia::apex::DestructibleActorJoint, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
joint()=0 | nvidia::apex::DestructibleActorJoint | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~DestructibleActorJoint() (defined in nvidia::apex::DestructibleActorJoint) | nvidia::apex::DestructibleActorJoint | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleActorJointDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorJointDesc
Public Member Functions | Public Attributes
nvidia::apex::DestructibleActorJointDesc Class Reference

#include <DestructibleActorJoint.h>

Inheritance diagram for nvidia::apex::DestructibleActorJointDesc:
nvidia::apex::ApexDesc

List of all members.

Public Member Functions

PX_INLINE | DestructibleActorJointDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
Resets descriptor to default settings.
PX_INLINE bool | isValid () const

Public Attributes

physx::PxJointConcreteType::Enum | type
PxRigidActor * | actor [2]
PxVec3 | localAxis [2]
PxVec3 | localAnchor [2]
PxVec3 | localNormal [2]
DestructibleActor * | destructible [2]
int32_t | attachmentChunkIndex [2]
PxVec3 | globalAnchor [2]
global attachment positions
PxVec3 | globalAxis [2]
global axes
PxVec3 | globalNormal [2]
global normals

Detailed Description

Descriptor used to create the Destructible actor joint.

Member Function Documentation

PX_INLINE bool nvidia::apex::DestructibleActorJointDesc::isValid ( ) const

Returns true iff an object can be created using this descriptor.

Reimplemented from nvidia::apex::ApexDesc.

Member Data Documentation

PxRigidActor* nvidia::apex::DestructibleActorJointDesc::actor[2]

PhysX SDK 3.X only.

int32_t nvidia::apex::DestructibleActorJointDesc::attachmentChunkIndex[2]

If destructible[i] is not NULL and attachmentChunkIndex[i] is a valid chunk index within that destructible, then that chunk will be used for attachment. If destructible[i] is not NULL and attachmentChunkIndex[i] is NOT a valid chunk index (such as the default ModuleDestructibleConst::INVALID_CHUNK_INDEX), then the nearest chunk to globalAnchor[i] is used instead. Once a chunk is determined, the chunk's associated PxActor will be the PxJoint's attachment actor.

DestructibleActor* nvidia::apex::DestructibleActorJointDesc::destructible[2]

If destructible[i] is not NULL, it will effectively replace the actor[i] in jointDesc. At least one must be non-NULL.

PxVec3 nvidia::apex::DestructibleActorJointDesc::globalAnchor[2]

global attachment positions

Global attachment data. Since destructibles come apart, there is no single referece frame associated with them. Therefore it makes more sense to use a global reference frame when describing the attachment positions and axes.

PxVec3 nvidia::apex::DestructibleActorJointDesc::localAnchor[2]

PhysX SDK 3.X only.

PxVec3 nvidia::apex::DestructibleActorJointDesc::localAxis[2]

PhysX SDK 3.X only.

PxVec3 nvidia::apex::DestructibleActorJointDesc::localNormal[2]

PhysX SDK 3.X only.

physx::PxJointConcreteType::Enum nvidia::apex::DestructibleActorJointDesc::type

PhysX SDK 3.X only.

The documentation for this class was generated from the following file:
  • DestructibleActorJoint.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorJointDesc
nvidia::apex::DestructibleActorJointDesc Member List
This is the complete list of members for nvidia::apex::DestructibleActorJointDesc, including all inherited members.
actor | nvidia::apex::DestructibleActorJointDesc |
ApexDesc() | nvidia::apex::ApexDesc | [inline]
attachmentChunkIndex | nvidia::apex::DestructibleActorJointDesc |
destructible | nvidia::apex::DestructibleActorJointDesc |
DestructibleActorJointDesc() | nvidia::apex::DestructibleActorJointDesc |
globalAnchor | nvidia::apex::DestructibleActorJointDesc |
globalAxis | nvidia::apex::DestructibleActorJointDesc |
globalNormal | nvidia::apex::DestructibleActorJointDesc |
isValid() const | nvidia::apex::DestructibleActorJointDesc |
localAnchor | nvidia::apex::DestructibleActorJointDesc |
localAxis | nvidia::apex::DestructibleActorJointDesc |
localNormal | nvidia::apex::DestructibleActorJointDesc |
setToDefault() | nvidia::apex::DestructibleActorJointDesc |
type | nvidia::apex::DestructibleActorJointDesc |
userData | nvidia::apex::ApexDesc |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAsset
Public Types | Public Member Functions | Protected Member Functions
nvidia::apex::DestructibleAsset Class Reference

#include <DestructibleAsset.h>

Inheritance diagram for nvidia::apex::DestructibleAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Types

enum ChunkFlags {
ChunkEnvironmentallySupported = (1 << 0),
ChunkAndDescendentsDoNotFracture = (1 << 1),
ChunkDoesNotFracture = (1 << 2),
ChunkDoesNotCrumble = (1 << 3),
ChunkRuntimeFracture = (1 << 4),
ChunkIsInstanced = (1 << 16)
}

Public Member Functions

virtual void | releaseDestructibleActor (DestructibleActor &actor)=0
virtual DestructibleActor * | createDestructibleActorFromDeserializedState (::NvParameterized::Interface *actorParams, Scene &apexScene)=0
virtual DestructibleParameters | getDestructibleParameters () const =0
virtual DestructibleInitParameters | getDestructibleInitParameters () const =0
virtual const char * | getCrumbleEmitterName () const =0
virtual const char * | getDustEmitterName () const =0
virtual uint32_t | getChunkCount () const =0
virtual uint32_t | getDepthCount () const =0
virtual const RenderMeshAsset * | getRenderMeshAsset () const =0
virtual bool | setRenderMeshAsset (RenderMeshAsset *)=0
virtual uint32_t | getScatterMeshAssetCount () const =0
virtual RenderMeshAsset *const | getScatterMeshAssets () const =0
virtual uint32_t | getInstancedChunkMeshCount () const =0
virtual void | getStats (DestructibleAssetStats &stats) const =0
virtual void | cacheChunkOverlapsUpToDepth (int32_t depth=-1)=0
virtual void | clearChunkOverlaps (int32_t depth=-1, bool keepCachedFlag=false)=0
virtual void | addChunkOverlaps (IntPair *supportGraphEdges, uint32_t numSupportGraphEdges)=0
virtual void | removeChunkOverlaps (IntPair *supportGraphEdges, uint32_t numSupportGraphEdges, bool keepCachedFlagIfEmpty)=0
virtual uint32_t | getCachedOverlapCountAtDepth (uint32_t depth) const =0
virtual const IntPair * | getCachedOverlapsAtDepth (uint32_t depth) const =0
virtual PxVec3 | getChunkPositionOffset (uint32_t chunkIndex) const =0
virtual PxVec2 | getChunkUVOffset (uint32_t chunkIndex) const =0
virtual uint32_t | getChunkFlags (uint32_t chunkIndex) const =0
virtual uint16_t | getChunkDepth (uint32_t chunkIndex) const =0
virtual int32_t | getChunkParentIndex (uint32_t chunkIndex) const =0
virtual PxBounds3 | getChunkActorLocalBounds (uint32_t chunkIndex) const =0
virtual uint32_t | getPartIndex (uint32_t chunkIndex) const =0
virtual uint32_t | getPartConvexHullCount (const uint32_t partIndex) const =0
virtual
NvParameterized::Interface ** 		getPartConvexHullArray (const uint32_t partIndex) const =0
virtual uint32_t | getActorTransformCount () const =0
Returns the size of the actor transform array. See getActorTransforms() for a description of this data.
virtual const PxMat44 * | getActorTransforms () const =0
Returns the head of the actor transform array. This list is a convenience for placing actors in a level from poses authored in a level editor. The transforms may contain scaling.
virtual void | applyTransformation (const PxMat44 &transformation, float scale)=0
Apply a transformation to destructible asset.
virtual void | applyTransformation (const PxMat44 &transformation)=0
Apply an arbitrary affine transformation to destructible asset.
virtual bool | rebuildCollisionGeometry (uint32_t partIndex, const DestructibleGeometryDesc &geometryDesc)=0

Protected Member Functions

virtual | ~DestructibleAsset ()

Detailed Description

Destructible asset API. Destructible actors are instanced from destructible assets.

Member Enumeration Documentation

enum nvidia::apex::DestructibleAsset::ChunkFlags

Enum of chunk flags

Constructor & Destructor Documentation

virtual nvidia::apex::DestructibleAsset::~DestructibleAsset ( ) [inline, protected, virtual]

Hidden destructor. Use release().

Member Function Documentation

virtual void nvidia::apex::DestructibleAsset::addChunkOverlaps | ( | IntPair * | supportGraphEdges,
 |  | uint32_t | numSupportGraphEdges
 | ) |  | [pure virtual]

Adds edges to the support graph. Edges must connect chunks of equal depth. The indices refer to the reordered chunk array, a mapping is provided in cookChunks.

Parameters:
supportGraphEdges | Integer pairs representing indices to chunks that are linked
numSupportGraphEdges | Number of provided integer pairs.
virtual void nvidia::apex::DestructibleAsset::applyTransformation | ( | const PxMat44 & | transformation,
 |  | float | scale
 | ) |  | [pure virtual]

Apply a transformation to destructible asset.

This is a permanent transformation and it changes the object state. Should only be called immediately before serialization and without further modifying the object later on.

Parameters:
transformation | This matrix is allowed to contain a translation and a rotation
scale | Apply a uniform scaling as well
virtual void nvidia::apex::DestructibleAsset::applyTransformation ( const PxMat44 & transformation ) [pure virtual]

Apply an arbitrary affine transformation to destructible asset.

This is a permanent transformation and it changes the object state. Should only be called immediately before serialization and without further modifying the object later on.

Parameters:
transformation This matrix is allowed to contain translation, rotation, scale and skew
virtual void nvidia::apex::DestructibleAsset::cacheChunkOverlapsUpToDepth ( int32_t depth = -1 ) [pure virtual]

Ensures that the asset has chunk overlap information cached up to the given depth. If depth < 0 (as it is by default), the depth will be taken to be the supportDepth given in the asset's destructibleParameters. It is ok to pass in a depth greater than any chunk depth in the asset.

virtual void nvidia::apex::DestructibleAsset::clearChunkOverlaps | ( | int32_t | depth = -1,
 |  | bool | keepCachedFlag = false
 | ) |  | [pure virtual]

Clears the chunk overlap cache. If depth < 0 (as it is by default), it clears the cache for each depth.

Parameters:
depth | Depth to be cleared. -1 for all depths.
keepCachedFlag | If the flag is set, the depth is considered to be cached even if the overlaps list is empty.
virtual DestructibleActor* nvidia::apex::DestructibleAsset::createDestructibleActorFromDeserializedState | ( | ::NvParameterized::Interface * | actorParams,
 |  | Scene & | apexScene
 | ) |  | [pure virtual]

General Create a destructible actor representing the destructible asset in a scene. Unlike a call to createApexActor, here the created actor takes explicit ownership of the provided actorParams. This can represent either the destructible descriptor or previously serialized destructible state. Note: The client should not attempt to use the provided actorParams after calling this method.

virtual uint32_t nvidia::apex::DestructibleAsset::getCachedOverlapCountAtDepth ( uint32_t depth ) const [pure virtual]

The size of the array returned by getCachedOverlapsAtDepth(depth) (see below). Note: this function will not trigger overlap caching for the given depth.

virtual const IntPair* nvidia::apex::DestructibleAsset::getCachedOverlapsAtDepth ( uint32_t depth ) const [pure virtual]

Array of integer pairs, indexing chunk pairs which touch at a given depth in the hierarchy. The size of the array is given by getCachedOverlapCountAtDepth(depth). Note: this function will not trigger overlap caching for the given depth. If no overlaps have been calculated for the depth given, this function returns NULL.

virtual PxBounds3 nvidia::apex::DestructibleAsset::getChunkActorLocalBounds ( uint32_t chunkIndex ) const [pure virtual]

Returns the chunk bounds in the asset (local) space.

virtual uint32_t nvidia::apex::DestructibleAsset::getChunkCount ( ) const [pure virtual]

The total number of chunks in the asset.

virtual uint16_t nvidia::apex::DestructibleAsset::getChunkDepth ( uint32_t chunkIndex ) const [pure virtual]

Accessor to query the depth of a given chunk.

virtual uint32_t nvidia::apex::DestructibleAsset::getChunkFlags ( uint32_t chunkIndex ) const [pure virtual]

Retrieve flags (see ChunkFlags) for the given chunk.

virtual int32_t nvidia::apex::DestructibleAsset::getChunkParentIndex ( uint32_t chunkIndex ) const [pure virtual]

Returns the index of the given chunk's parent. If the chunk has no parent (is the root of the fracture hierarchy), then -1 is returned.

virtual PxVec3 nvidia::apex::DestructibleAsset::getChunkPositionOffset ( uint32_t chunkIndex ) const [pure virtual]

If this chunk is instanced within the same asset, then this provides the instancing position offset. Otherwise, this function returns (0,0,0).

virtual PxVec2 nvidia::apex::DestructibleAsset::getChunkUVOffset ( uint32_t chunkIndex ) const [pure virtual]

If this chunk is instanced within the same asset, then this provides the instancing UV offset. Otherwise, this function returns (0,0).

virtual const char* nvidia::apex::DestructibleAsset::getCrumbleEmitterName ( ) const [pure virtual]

The name of the emitter to use when generating crumble particles. Returns NULL if no emitter is configured.

virtual uint32_t nvidia::apex::DestructibleAsset::getDepthCount ( ) const [pure virtual]

The total number of fracture hierarchy depth levels in the asset.

virtual DestructibleInitParameters nvidia::apex::DestructibleAsset::getDestructibleInitParameters ( ) const [pure virtual]

The parameters used for default destructible initialization. See DestructibleInitParameters.

virtual DestructibleParameters nvidia::apex::DestructibleAsset::getDestructibleParameters ( ) const [pure virtual]

The DestructibleParameters which describe the default fracturing behavior for instanced DestructibleActors.

virtual const char* nvidia::apex::DestructibleAsset::getDustEmitterName ( ) const [pure virtual]

The name of the emitter to use when generating fracture-line dust particles. Returns NULL if no emitter is configured.

virtual uint32_t nvidia::apex::DestructibleAsset::getInstancedChunkMeshCount ( ) const [pure virtual]

Get the number of instanced chunk meshes in this asset.

virtual NvParameterized::Interface** nvidia::apex::DestructibleAsset::getPartConvexHullArray ( const uint32_t partIndex ) const [pure virtual]

Returns the head of an array to convex hull NvParamterized::Interface* pointers for a given part.

virtual uint32_t nvidia::apex::DestructibleAsset::getPartConvexHullCount ( const uint32_t partIndex ) const [pure virtual]

The number of convex hulls associated with a given part.

virtual uint32_t nvidia::apex::DestructibleAsset::getPartIndex ( uint32_t chunkIndex ) const [pure virtual]

The render mesh asset part index associated with this chunk.

virtual const RenderMeshAsset* nvidia::apex::DestructibleAsset::getRenderMeshAsset ( ) const [pure virtual]

Gets the RenderMeshAsset associated with this asset.

virtual uint32_t nvidia::apex::DestructibleAsset::getScatterMeshAssetCount ( ) const [pure virtual]

Retrieve the number of scatter mesh assets

virtual RenderMeshAsset* const nvidia::apex::DestructibleAsset::getScatterMeshAssets ( ) const [pure virtual]

Retrieve the scatter mesh asset array

virtual void nvidia::apex::DestructibleAsset::getStats ( DestructibleAssetStats & stats ) const [pure virtual]

Returns stats (sizes, counts) for the asset. See DestructibleAssetStats.

virtual bool nvidia::apex::DestructibleAsset::rebuildCollisionGeometry | ( | uint32_t | partIndex,
 |  | const DestructibleGeometryDesc & | geometryDesc
 | ) |  | [pure virtual]

Rebuild the collision volumes for the given chunk, using the geometryDesc (see DestructibleGeometryDesc). Returns true iff successful.

virtual void nvidia::apex::DestructibleAsset::releaseDestructibleActor ( DestructibleActor & actor ) [pure virtual]

Instancing Instances the DestructibleAsset, creating an DestructibleActor, using the DestructibleActorDesc. See DestructibleActor and DestructibleActorDesc. This asset will own the DestructibleActor, so that any DestructibleActor created by it will be released when this asset is released. You may also call the DestructibleActor's release() method at any time.

virtual void nvidia::apex::DestructibleAsset::removeChunkOverlaps | ( | IntPair * | supportGraphEdges,
 |  | uint32_t | numSupportGraphEdges,
 |  | bool | keepCachedFlagIfEmpty
 | ) |  | [pure virtual]

Removes edges from support graph. The indices refer to the reordered chunk array, a mapping is provided in cookChunks.

Parameters:
supportGraphEdges | Integer pairs representing indices to chunks that are linked
numSupportGraphEdges | Number of provided integer pairs.
keepCachedFlagIfEmpty | If the flag is set, the depth is considered to be cached even if the overlaps list is empty.
virtual bool nvidia::apex::DestructibleAsset::setRenderMeshAsset ( RenderMeshAsset * ) [pure virtual]

Set the RenderMeshAsset associated with this asset. This is the asset used for non-instanced rendering. NULL is a valid argument, and can be used to clear the internal mesh data. Returns true if successful.

The documentation for this class was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAsset
nvidia::apex::DestructibleAsset Member List
This is the complete list of members for nvidia::apex::DestructibleAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
addChunkOverlaps(IntPair *supportGraphEdges, uint32_t numSupportGraphEdges)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
applyTransformation(const PxMat44 &transformation, float scale)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
applyTransformation(const PxMat44 &transformation)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
cacheChunkOverlapsUpToDepth(int32_t depth=-1)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
ChunkAndDescendentsDoNotFracture enum value (defined in nvidia::apex::DestructibleAsset) | nvidia::apex::DestructibleAsset |
ChunkDoesNotCrumble enum value (defined in nvidia::apex::DestructibleAsset) | nvidia::apex::DestructibleAsset |
ChunkDoesNotFracture enum value (defined in nvidia::apex::DestructibleAsset) | nvidia::apex::DestructibleAsset |
ChunkEnvironmentallySupported enum value (defined in nvidia::apex::DestructibleAsset) | nvidia::apex::DestructibleAsset |
ChunkFlags enum name | nvidia::apex::DestructibleAsset |
ChunkIsInstanced enum value (defined in nvidia::apex::DestructibleAsset) | nvidia::apex::DestructibleAsset |
ChunkRuntimeFracture enum value (defined in nvidia::apex::DestructibleAsset) | nvidia::apex::DestructibleAsset |
clearChunkOverlaps(int32_t depth=-1, bool keepCachedFlag=false)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
createDestructibleActorFromDeserializedState(::NvParameterized::Interface *actorParams, Scene &apexScene)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getActorTransformCount() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getActorTransforms() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getCachedOverlapCountAtDepth(uint32_t depth) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getCachedOverlapsAtDepth(uint32_t depth) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkActorLocalBounds(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkCount() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkDepth(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkFlags(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkParentIndex(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkPositionOffset(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getChunkUVOffset(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getCrumbleEmitterName() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDepthCount() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getDestructibleInitParameters() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getDestructibleParameters() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getDustEmitterName() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getInstancedChunkMeshCount() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
getPartConvexHullArray(const uint32_t partIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getPartConvexHullCount(const uint32_t partIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getPartIndex(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getRenderMeshAsset() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getScatterMeshAssetCount() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getScatterMeshAssets() const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
getStats(DestructibleAssetStats &stats) const =0 | nvidia::apex::DestructibleAsset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
rebuildCollisionGeometry(uint32_t partIndex, const DestructibleGeometryDesc &geometryDesc)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseDestructibleActor(DestructibleActor &actor)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
removeChunkOverlaps(IntPair *supportGraphEdges, uint32_t numSupportGraphEdges, bool keepCachedFlagIfEmpty)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
setRenderMeshAsset(RenderMeshAsset *)=0 | nvidia::apex::DestructibleAsset | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~DestructibleAsset() | nvidia::apex::DestructibleAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAssetAuthoring
Public Member Functions
nvidia::apex::DestructibleAssetAuthoring Class Reference

#include <DestructibleAsset.h>

Inheritance diagram for nvidia::apex::DestructibleAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual ExplicitHierarchicalMesh & | getExplicitHierarchicalMesh ()=0
virtual ExplicitHierarchicalMesh & | getCoreExplicitHierarchicalMesh ()=0
virtual FractureTools::CutoutSet & | getCutoutSet ()=0
virtual uint32_t | partitionMeshByIslands (nvidia::ExplicitRenderTriangle *mesh, uint32_t meshTriangleCount, uint32_t *meshPartition, uint32_t meshPartitionMaxCount, float padding=0.0001f)=0
virtual bool | setRootMesh (const ExplicitRenderTriangle *meshTriangles, uint32_t meshTriangleCount, const ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0, int32_t *parentIndices=NULL, uint32_t parentIndexCount=0)=0
virtual bool | importRenderMeshAssetToRootMesh (const nvidia::RenderMeshAsset &renderMeshAsset, uint32_t maxRootDepth=UINT32_MAX)=0
virtual bool | importDestructibleAssetToRootMesh (const nvidia::DestructibleAsset &destructibleAsset, uint32_t maxRootDepth=UINT32_MAX)=0
virtual bool | setCoreMesh (const ExplicitRenderTriangle *mesh, uint32_t meshTriangleCount, const ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0)=0
virtual bool | buildExplicitHierarchicalMesh (ExplicitHierarchicalMesh &hMesh, const ExplicitRenderTriangle *meshTriangles, uint32_t meshTriangleCount, const ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0, int32_t *parentIndices=NULL, uint32_t parentIndexCount=0)=0
virtual bool | createHierarchicallySplitMesh (const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, uint32_t randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual bool | createChippedMesh (const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureCutoutDesc &desc, const FractureTools::CutoutSet &cutoutSet, const FractureTools::FractureSliceDesc &sliceDesc, const FractureTools::FractureVoronoiDesc &voronoiDesc, const CollisionDesc &collisionDesc, uint32_t randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual void | buildCutoutSet (const uint8_t *pixelBuffer, uint32_t bufferWidth, uint32_t bufferHeight, float snapThreshold, bool periodic)=0
virtual bool | calculateCutoutUVMapping (PxMat33 &mapping, const nvidia::ExplicitRenderTriangle &triangle)=0
virtual bool | calculateCutoutUVMapping (PxMat33 &mapping, const PxVec3 &targetDirection)=0
virtual bool | createVoronoiSplitMesh (const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, uint32_t randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual uint32_t | createVoronoiSitesInsideMesh (PxVec3 *siteBuffer, uint32_t *siteChunkIndices, uint32_t siteCount, uint32_t *randomSeed, uint32_t *microgridSize, BSPOpenMode::Enum meshMode, IProgressListener &progressListener, uint32_t chunkIndex=0xFFFFFFFF)=0
virtual uint32_t | createScatterMeshSites (uint8_t *meshIndices, PxMat44 *relativeTransforms, uint32_t *chunkMeshStarts, uint32_t scatterMeshInstancesBufferSize, uint32_t targetChunkCount, const uint16_t *targetChunkIndices, uint32_t *randomSeed, uint32_t scatterMeshAssetCount, nvidia::RenderMeshAsset **scatterMeshAssets, const uint32_t *minCount, const uint32_t *maxCount, const float *minScales, const float *maxScales, const float *maxAngles)=0
virtual void | visualizeVoronoiCells (nvidia::RenderDebugInterface &debugRender, const PxVec3 *sites, uint32_t siteCount, const uint32_t *cellColors, uint32_t cellColorCount, const PxBounds3 &bounds, uint32_t cellIndex=0xFFFFFFFF)=0
virtual bool | hierarchicallySplitChunk (uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual bool | voronoiSplitChunk (uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual void | setBSPTolerances (float linearTolerance, float angularTolerance, float baseTolerance, float clipTolerance, float cleaningTolerance)=0
virtual void | setBSPBuildParameters (float logAreaSigmaThreshold, uint32_t testSetSize, float splitWeight, float imbalanceWeight)=0
virtual
ExplicitHierarchicalMesh::ConvexHull * 		createExplicitHierarchicalMeshConvexHull ()=0
virtual uint32_t | buildSliceMesh (const ExplicitRenderTriangle *&mesh, const FractureTools::NoiseParameters &noiseParameters, const PxPlane &slicePlane, uint32_t randomSeed)=0
virtual void | serializeFractureToolState (PxFileBuf &stream, nvidia::ExplicitHierarchicalMesh::Embedding &embedding) const =0
virtual void | deserializeFractureToolState (PxFileBuf &stream, nvidia::ExplicitHierarchicalMesh::Embedding &embedding)=0
virtual void | setChunkOverlapsCacheDepth (int32_t depth=-1)=0
virtual const RenderMeshAsset * | getRenderMeshAsset () const =0
virtual bool | setRenderMeshAsset (RenderMeshAsset *)=0
virtual bool | setScatterMeshAssets (RenderMeshAsset **scatterMeshAssetArray, uint32_t scatterMeshAssetArraySize)=0
virtual uint32_t | getScatterMeshAssetCount () const =0
virtual RenderMeshAsset *const | getScatterMeshAssets () const =0
virtual uint32_t | getInstancedChunkMeshCount () const =0
virtual void | setDestructibleParameters (const DestructibleParameters &)=0
virtual DestructibleParameters | getDestructibleParameters () const =0
virtual void | setDestructibleInitParameters (const DestructibleInitParameters &)=0
virtual DestructibleInitParameters | getDestructibleInitParameters () const =0
virtual void | setCrumbleEmitterName (const char *)=0
virtual void | setDustEmitterName (const char *)=0
virtual void | setFracturePatternName (const char *)=0
virtual void | setNeighborPadding (float neighborPadding)=0
virtual float | getNeighborPadding () const =0
virtual void | cookChunks (const DestructibleAssetCookingDesc &cookingDesc, bool cacheOverlaps=true, uint32_t *chunkIndexMapUser2Apex=NULL, uint32_t *chunkIndexMapApex2User=NULL, uint32_t chunkIndexMapCount=0)=0
virtual float | getFractureImpulseScale () const =0
virtual float | getImpactVelocityThreshold () const =0
virtual uint32_t | getChunkCount () const =0
virtual uint32_t | getDepthCount () const =0
virtual uint32_t | getChunkChildCount (uint32_t chunkIndex) const =0
virtual int32_t | getChunkChild (uint32_t chunkIndex, uint32_t childIndex) const =0
virtual PxVec3 | getChunkPositionOffset (uint32_t chunkIndex) const =0
virtual PxVec2 | getChunkUVOffset (uint32_t chunkIndex) const =0
virtual uint32_t | getPartIndex (uint32_t chunkIndex) const =0
virtual void | trimCollisionGeometry (const uint32_t *partIndices, uint32_t partIndexCount, float maxTrimFraction=0.2f)=0
virtual void | getStats (DestructibleAssetStats &stats) const =0
virtual void | cacheChunkOverlapsUpToDepth (int32_t depth=-1)=0
virtual void | clearChunkOverlaps (int32_t depth=-1, bool keepCachedFlag=false)=0
virtual void | addChunkOverlaps (IntPair *supportGraphEdges, uint32_t numSupportGraphEdges)=0
virtual void | removeChunkOverlaps (IntPair *supportGraphEdges, uint32_t numSupportGraphEdges, bool keepCachedFlagIfEmpty)=0
virtual uint32_t | getCachedOverlapCountAtDepth (uint32_t depth)=0
virtual const IntPair * | getCachedOverlapsAtDepth (uint32_t depth)=0
virtual void | applyTransformation (const PxMat44 &transformation, float scale)=0
Apply a transformation to destructible asset.
virtual void | applyTransformation (const PxMat44 &transformation)=0
Apply an arbitrary affine transformation to destructible asset.
virtual bool | setPlatformMaxDepth (PlatformTag platform, uint32_t maxDepth)=0
Set a maximum fracture depth for a given platform string.
virtual bool | removePlatformMaxDepth (PlatformTag platform)=0
Removes the maximum fracture depth limit for a given platform string.
virtual uint32_t | getActorTransformCount () const =0
Returns the size of the actor transform array. See getActorTransforms() for a description of this data.
virtual const PxMat44 * | getActorTransforms () const =0
Returns the head of the actor transform array. This list is a convenience for placing actors in a level from poses authored in a level editor. The transforms may contain scaling.
virtual void | appendActorTransforms (const PxMat44 *transforms, uint32_t transformCount)=0
Append transforms to the actor transform list. See getActorTransforms() for a description of this data.
virtual void | clearActorTransforms ()=0
Clear the actor transform array. See getActorTransforms() for a description of this data.

Detailed Description

Authoring API for a destructible asset.

Member Function Documentation

virtual void nvidia::apex::DestructibleAssetAuthoring::addChunkOverlaps | ( | IntPair * | supportGraphEdges,
 |  | uint32_t | numSupportGraphEdges
 | ) |  | [pure virtual]

Adds edges to the support graph. Edges must connect chunks of equal depth. The indices refer to the reordered chunk array, a mapping is provided in cookChunks.

virtual void nvidia::apex::DestructibleAssetAuthoring::appendActorTransforms | ( | const PxMat44 * | transforms,
 |  | uint32_t | transformCount
 | ) |  | [pure virtual]

Append transforms to the actor transform list. See getActorTransforms() for a description of this data.

Parameters:
transforms | Head of an array of transforms
transformCount | Size of transforms
virtual void nvidia::apex::DestructibleAssetAuthoring::applyTransformation | ( | const PxMat44 & | transformation,
 |  | float | scale
 | ) |  | [pure virtual]

Apply a transformation to destructible asset.

This is a permanent transformation and it changes the object state. Should only be called immediately before serialization and without further modifying the object later on.

Parameters:
transformation | This matrix is allowed to contain a translation and a rotation
scale | Apply a uniform scaling as well
virtual void nvidia::apex::DestructibleAssetAuthoring::applyTransformation ( const PxMat44 & transformation ) [pure virtual]

Apply an arbitrary affine transformation to destructible asset.

This is a permanent transformation and it changes the object state. Should only be called immediately before serialization and without further modifying the object later on.

Parameters:
transformation This matrix is allowed to contain translation, rotation, scale and skew
virtual void nvidia::apex::DestructibleAssetAuthoring::buildCutoutSet | ( | const uint8_t * | pixelBuffer,
 |  | uint32_t | bufferWidth,
 |  | uint32_t | bufferHeight,
 |  | float | snapThreshold,
 |  | bool | periodic
 | ) |  | [pure virtual]

Builds an internal cutout set.

Parameters:
pixelBuffer | pointer to be beginning of the pixel buffer
bufferWidth | the width of the buffer in pixels
bufferHeight | the height of the buffer in pixels
snapThreshold | the pixel distance at which neighboring cutout vertices and segments may be fudged into alignment.
periodic | whether or not to use periodic boundary conditions when creating cutouts from the map
virtual bool nvidia::apex::DestructibleAssetAuthoring::buildExplicitHierarchicalMesh | ( | ExplicitHierarchicalMesh & | hMesh,
 |  | const ExplicitRenderTriangle * | meshTriangles,
 |  | uint32_t | meshTriangleCount,
 |  | const ExplicitSubmeshData * | submeshData,
 |  | uint32_t | submeshCount,
 |  | uint32_t * | meshPartition = NULL,
 |  | uint32_t | meshPartitionCount = 0,
 |  | int32_t * | parentIndices = NULL,
 |  | uint32_t | parentIndexCount = 0
 | ) |  | [pure virtual]

Builds a new ExplicitHierarchicalMesh from an array of triangles, externally provided by the user. Note: setRootMesh and setCoreMesh may be implemented as follows: setRootMesh(x) <-> buildExplicitHierarchicalMesh( getExplicitHierarchicalMesh(), x) setCoreMesh(x) <-> buildExplicitHierarchicalMesh( getCoreExplicitHierarchicalMesh(), x)

Parameters:
hMesh | new ExplicitHierarchicalMesh
meshTriangles | pointer to array of ExplicitRenderTriangles which make up the mesh
meshTriangleCount | the size of the meshTriangles array
submeshData | pointer to array of ExplicitSubmeshData, describing the submeshes
submeshCount | the size of the submeshData array
meshPartition | if not NULL, an array of size meshPartitionCount, giving the end elements of contiguous subsets of meshTriangles. If meshPartition is NULL, one partition is assumed. When there is one partition, these triangles become the level 0 part. When there is more than one partition, these triangles become level 1 parts, while the union of the parts will be the level 0 part.
meshPartitionCount | if meshPartition is not NULL, this is the size of the meshPartition array.
parentIndices | if not NULL, the parent indices for each chunk (corresponding to a partition in the mesh partition).
parentIndexCount | the size of the parentIndices array. This does not need to match meshPartitionCount. If a mesh partition has an index beyond the end of parentIndices, then the parentIndex is considered to be 0. Therefore, if parentIndexCount = 0, all parents are 0 and so all chunks created will be depth 1. This will cause a depth 0 chunk to be created that is the aggregate of the depth 1 chunks. If parentIndexCount > 0, then the depth-0 chunk must have a parentIndex of -1. To reproduce the effect of the old parameter 'firstPartitionIsDepthZero' = true, set parentIndices to the address of a int32_t containing the value -1, and set parentIndexCount = 1. To reproduce the effect of the old parameter 'firstPartitionIsDepthZero' = false, set parentIndexCount = 0. Note: if parent indices are given, the first one must be -1, and *only* that index may be negative. That is, there may be only one depth-0 mesh and it must be the first mesh.
virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::buildSliceMesh | ( | const ExplicitRenderTriangle *& | mesh,
 |  | const FractureTools::NoiseParameters & | noiseParameters,
 |  | const PxPlane & | slicePlane,
 |  | uint32_t | randomSeed
 | ) |  | [pure virtual]

Builds a mesh used for slice fracturing, given the noise parameters and random seed. This function is mostly intended for visualization - to give the user a "typical" slice surface used for fracturing.

Returns:
Returns the head of an array of ExplicitRenderTriangles, of length given by the return value.
virtual void nvidia::apex::DestructibleAssetAuthoring::cacheChunkOverlapsUpToDepth ( int32_t depth = -1 ) [pure virtual]

Ensures that the asset has chunk overlap information cached up to the given depth. If depth < 0 (as it is by default), the depth will be taken to be the supportDepth given in the asset's destructibleParameters. It is ok to pass in a depth greater than any chunk depth in the asset.

virtual bool nvidia::apex::DestructibleAssetAuthoring::calculateCutoutUVMapping | ( | PxMat33 & | mapping,
 |  | const nvidia::ExplicitRenderTriangle & | triangle
 | ) |  | [pure virtual]

Calculate the mapping between a cutout fracture map and a given triangle. The result is a 3 by 3 matrix M composed by an affine transformation and a rotation, we can get the 3-D projection for a texture coordinate pair (u,v) with such a formula: (x,y,z) = M*PxVec3(u,v,1)

Parameters:
mapping | resulted mapping, composed by an affine transformation and a rotation
triangle | triangle
virtual bool nvidia::apex::DestructibleAssetAuthoring::calculateCutoutUVMapping | ( | PxMat33 & | mapping,
 |  | const PxVec3 & | targetDirection
 | ) |  | [pure virtual]

Uses the passed-in target direction to find the best triangle in the root mesh with normal near the given targetDirection. If triangles exist with normals within one degree of the given target direction, then one with the greatest area of such triangles is used. Otherwise, the triangle with normal closest to the given target direction is used. The resulting triangle is used to calculate a UV mapping as in the function calculateCutoutUVMapping (above).

The assumption is that there exists a single mapping for all triangles on a specified face, for this feature to be useful.

Parameters:
mapping resulted mapping, composed by an affine transformation and a rotation
targetDirection,: the target face's normal
virtual void nvidia::apex::DestructibleAssetAuthoring::clearChunkOverlaps | ( | int32_t | depth = -1,
 |  | bool | keepCachedFlag = false
 | ) |  | [pure virtual]

Clears the chunk overlap cache.

Parameters:
depth | Depth to be cleared. -1 for all depths.
keepCachedFlag | If the flag is set, the depth is considered to be cached even if the overlaps list is empty.
virtual void nvidia::apex::DestructibleAssetAuthoring::cookChunks | ( | const DestructibleAssetCookingDesc & | cookingDesc,
 |  | bool | cacheOverlaps = true,
 |  | uint32_t * | chunkIndexMapUser2Apex = NULL,
 |  | uint32_t * | chunkIndexMapApex2User = NULL,
 |  | uint32_t | chunkIndexMapCount = 0
 | ) |  | [pure virtual]

Once the internal ExplicitHierarchicalMesh is built using the fracture tools functions and all emitter names and parameters set, this functions builds the destructible asset. Every chunk (corresponding to a part in the ExplicitHierarchicalMesh) must have destruction-specific data set through the descriptor passed into this function. See DestructibleAssetCookingDesc.

Parameters:
cookingDesc | cooking setup
cacheOverlaps | whether the chunk overlaps up to chunkOverlapCacheDepth should be cached in this call
chunkIndexMapUser2Apex | optional user provided uint32_t array that will contains the mapping from user chunk indices (referring to chunks in cookingDesc) to Apex internal chunk indices (referring to chunk is internal chunk array)
chunkIndexMapApex2User | same as chunkIndexMapUser2Apex, but opposite direction
chunkIndexMapCount | size of the user provided mapping arrays
virtual bool nvidia::apex::DestructibleAssetAuthoring::createChippedMesh | ( | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureCutoutDesc & | desc,
 |  | const FractureTools::CutoutSet & | cutoutSet,
 |  | const FractureTools::FractureSliceDesc & | sliceDesc,
 |  | const FractureTools::FractureVoronoiDesc & | voronoiDesc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t | randomSeed,
 |  | IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the mesh in chunk[0], forming a hierarchy of fractured meshes in chunks[1...] using cutout-mode (chippable) fracturing.

Parameters:
meshProcessingParams | describes generic mesh processing directives
desc | describes the slicing surfaces (see FractureCutoutDesc)
cutoutSet | the cutout set to use for fracturing (see CutoutSet)
sliceDesc | used if desc.chunkFracturingMethod = SliceFractureCutoutChunks
voronoiDesc | used if desc.chunkFracturingMethod = VoronoiFractureCutoutChunks
collisionDesc | convex hulls will be generated for each chunk using the method See CollisionDesc.
randomSeed | seed for the random number generator, to ensure reproducibility.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual ExplicitHierarchicalMesh::ConvexHull* nvidia::apex::DestructibleAssetAuthoring::createExplicitHierarchicalMeshConvexHull ( ) [pure virtual]

Instantiates an ExplicitHierarchicalMesh::ConvexHull

See the ConvexHull API for its functionality. Can be used to author chunk hulls in the cookChunks function.

Use ConvexHull::release() to delete the object.

virtual bool nvidia::apex::DestructibleAssetAuthoring::createHierarchicallySplitMesh | ( | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureSliceDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | bool | exportCoreMesh,
 |  | int32_t | coreMeshImprintSubmeshIndex,
 |  | uint32_t | randomSeed,
 |  | IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the chunk in chunk[0], forming a hierarchy of fractured chunks in chunks[1...] using slice-mode fracturing.

Parameters:
meshProcessingParams | describes generic mesh processing directives
desc | describes the slicing surfaces (see FractureSliceDesc)
collisionDesc | convex hulls will be generated for each chunk using the method See CollisionDesc.
exportCoreMesh | if true, the core mesh will be included (at depth 1) in the hierarchically split mesh. Otherwise, it will only be used to create a hollow space.
coreMeshImprintSubmeshIndex | if this is < 0, use the core mesh materials (was applyCoreMeshMaterialToNeighborChunks). Otherwise, use the given submesh
randomSeed | seed for the random number generator, to ensure reproducibility.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::createScatterMeshSites | ( | uint8_t * | meshIndices,
 |  | PxMat44 * | relativeTransforms,
 |  | uint32_t * | chunkMeshStarts,
 |  | uint32_t | scatterMeshInstancesBufferSize,
 |  | uint32_t | targetChunkCount,
 |  | const uint16_t * | targetChunkIndices,
 |  | uint32_t * | randomSeed,
 |  | uint32_t | scatterMeshAssetCount,
 |  | nvidia::RenderMeshAsset ** | scatterMeshAssets,
 |  | const uint32_t * | minCount,
 |  | const uint32_t * | maxCount,
 |  | const float * | minScales,
 |  | const float * | maxScales,
 |  | const float * | maxAngles
 | ) |  | [pure virtual]

Creates scatter mesh sites randomly distributed on the mesh.

Parameters:
meshIndices | user-allocated array of size scatterMeshInstancesBufferSize which will be filled in by this function, giving the scatter mesh index used
relativeTransforms | user-allocated array of size scatterMeshInstancesBufferSize which will be filled in by this function, giving the chunk-relative transform for each chunk instance
chunkMeshStarts | user-allocated array which will be filled in with offsets into the meshIndices and relativeTransforms array. For a chunk indexed by i, the corresponding range [chunkMeshStart[i], chunkMeshStart[i+1]-1] in meshIndices and relativeTransforms is used. NOTE*: chunkMeshStart array must be of at least size N+1, where N is the number of chunks in the base explicit hierarchical mesh.
scatterMeshInstancesBufferSize | the size of meshIndices and relativeTransforms array.
targetChunkCount | how many chunks are in the array targetChunkIndices
targetChunkIndices | an array of chunk indices which are candidates for scatter meshes. The elements in the array chunkIndices will come from this array
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
scatterMeshAssetCount | the number of different scatter meshes (not instances). Should not exceed 255. If scatterMeshAssetCount > 255, only the first 255 will be used.
scatterMeshAssets | an array of size scatterMeshAssetCount, of the render mesh assets which will be used for the scatter meshes
minCount | an array of size scatterMeshAssetCount, giving the minimum number of instances to place for each mesh
maxCount | an array of size scatterMeshAssetCount, giving the maximum number of instances to place for each mesh
minScales | an array of size scatterMeshAssetCount, giving the minimum scale to apply to each scatter mesh
maxScales | an array of size scatterMeshAssetCount, giving the maximum scale to apply to each scatter mesh
maxAngles | an array of size scatterMeshAssetCount, giving a maximum deviation angle (in degrees) from the surface normal to apply to each scatter mesh
Returns:
return value: the number of instances placed in indices and relativeTransforms (will not exceed scatterMeshInstancesBufferSize)
virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::createVoronoiSitesInsideMesh | ( | PxVec3 * | siteBuffer,
 |  | uint32_t * | siteChunkIndices,
 |  | uint32_t | siteCount,
 |  | uint32_t * | randomSeed,
 |  | uint32_t * | microgridSize,
 |  | BSPOpenMode::Enum | meshMode,
 |  | IProgressListener & | progressListener,
 |  | uint32_t | chunkIndex = 0xFFFFFFFF
 | ) |  | [pure virtual]

Generates a set of uniformly distributed points in the interior of the root mesh.

Parameters:
siteBuffer | An array of PxVec3, at least the size of siteCount.
siteChunkIndices | If not NULL, it must be at least the size of siteCount. siteCount indices will be written to this buffer, associating each site with a chunk that contains it.
siteCount | The number of points to write into siteBuffer.
randomSeed | Pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
microgridSize | Pointer to a grid size used for BSP creation. If NULL, the default settings will be used.
meshMode | Open mesh handling. Modes: Automatic, Closed, Open (see BSPOpenMode)
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
chunkIndex | If this is a valid index, the voronoi sites will only be created within the volume of the indexed chunk. Otherwise, the sites will be created within each of the root-level chunks. Default value is an invalid index.
Returns:
Returns the number of sites actually created (written to siteBuffer and siteChunkIndices). This may be less than the number of sites requested if site placement fails.
virtual bool nvidia::apex::DestructibleAssetAuthoring::createVoronoiSplitMesh | ( | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureVoronoiDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | bool | exportCoreMesh,
 |  | int32_t | coreMeshImprintSubmeshIndex,
 |  | uint32_t | randomSeed,
 |  | IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the mesh in chunk[0], forming fractured pieces chunks[1...] using Voronoi decomposition fracturing.

Parameters:
meshProcessingParams | describes generic mesh processing directives
desc | describes the voronoi splitting parameters surfaces (see FractureVoronoiDesc)
collisionDesc | convex hulls will be generated for each chunk using the method See CollisionDesc.
exportCoreMesh | if true, the core mesh will be included (at depth 1) in the split mesh. Otherwise, it will only be used to create a hollow space.
coreMeshImprintSubmeshIndex | if this is < 0, use the core mesh materials (was applyCoreMeshMaterialToNeighborChunks). Otherwise, use the given submesh
randomSeed | seed for the random number generator, to ensure reproducibility.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual void nvidia::apex::DestructibleAssetAuthoring::deserializeFractureToolState | ( | PxFileBuf & | stream,
 |  | nvidia::ExplicitHierarchicalMesh::Embedding & | embedding
 | ) |  | [pure virtual]

Deserialization of the data associated with the fracture API. This includes the root mesh, core mesh, and cutout set.

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getCachedOverlapCountAtDepth ( uint32_t depth ) [pure virtual]

The size of the array returned by getCachedOverlapsAtDepth(depth) (see below). Note: this function will not trigger overlap caching for the given depth. If no overlaps have been calculated for the depth given, this function returns NULL.

virtual const IntPair* nvidia::apex::DestructibleAssetAuthoring::getCachedOverlapsAtDepth ( uint32_t depth ) [pure virtual]

Array of integer pairs, indexing chunk pairs which touch at a given depth in the heirarcy. The size of the array is given by getCachedOverlapCountAtDepth(depth). Note: this function will not trigger overlap caching for the given depth. If no overlaps have been calculated for the depth given, this function returns NULL.

virtual int32_t nvidia::apex::DestructibleAssetAuthoring::getChunkChild | ( | uint32_t | chunkIndex,
 |  | uint32_t | childIndex
 | ) |  | const [pure virtual]

Returns the index for the given child of the given chunk. chunkIndex must be less than getChunkCount() and childIndex must be less than getChunkChildCount(chunkIndex). If either of these conditions is not met, the function returns ModuleDestructibleConst::INVALID_CHUNK_INDEX.

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getChunkChildCount ( uint32_t chunkIndex ) const [pure virtual]

Returns the number of children for the given chunk. chunkIndex must be less than getChunkCount(). If it is not, this function returns 0.

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getChunkCount ( ) const [pure virtual]

The total number of chunks in the cooked asset.

virtual PxVec3 nvidia::apex::DestructibleAssetAuthoring::getChunkPositionOffset ( uint32_t chunkIndex ) const [pure virtual]

If this chunk is instanced within the same asset, then this provides the instancing position offset. Otherwise, this function returns (0,0,0).

virtual PxVec2 nvidia::apex::DestructibleAssetAuthoring::getChunkUVOffset ( uint32_t chunkIndex ) const [pure virtual]

If this chunk is instanced within the same asset, then this provides the instancing UV offset. Otherwise, this function returns (0,0).

virtual ExplicitHierarchicalMesh& nvidia::apex::DestructibleAssetAuthoring::getCoreExplicitHierarchicalMesh ( ) [pure virtual]

DestructibleAssetAuthoring contains a second instantiation of ExplicitHierarchicalMesh used to describe the core mesh for slice fracturing (see FractureTools::FractureSliceDesc), done in createHierarchicallySplitMesh(). This function gives access to it.

virtual FractureTools::CutoutSet& nvidia::apex::DestructibleAssetAuthoring::getCutoutSet ( ) [pure virtual]

DestructibleAssetAuthoring contains an instantiation of CutoutSet used to describe the cutout fracturing shapes (see FractureTools::CutoutSet), done in createChippedMesh(). This function gives access to it.

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getDepthCount ( ) const [pure virtual]

The total number of fracture hierarchy depth levels in the cooked asset.

virtual DestructibleInitParameters nvidia::apex::DestructibleAssetAuthoring::getDestructibleInitParameters ( ) const [pure virtual]

The parameters used for default destructible initialization. See DestructibleInitParameters.

virtual DestructibleParameters nvidia::apex::DestructibleAssetAuthoring::getDestructibleParameters ( ) const [pure virtual]

The DestructibleParameters which describe the default fracturing behavior for instanced DestructibleActors. These may be overridden by calling setDestructibleParameters().

virtual ExplicitHierarchicalMesh& nvidia::apex::DestructibleAssetAuthoring::getExplicitHierarchicalMesh ( ) [pure virtual]

Fracturing API DestructibleAssetAuthoring contains an instantiation of ExplicitHierarchicalMesh. This function gives access to it. See ExplicitHierarchicalMesh for details, it is the object used by the fracturing tool set for mesh fracturing operations and is used to generate the embedded RenderMesh as well as collision and hierarchy data for the destructible asset.

virtual float nvidia::apex::DestructibleAssetAuthoring::getFractureImpulseScale ( ) const [pure virtual]

The scale factor used to apply an impulse force along the normal of chunk when fractured. This is used in order to "push" the pieces out as they fracture.

virtual float nvidia::apex::DestructibleAssetAuthoring::getImpactVelocityThreshold ( ) const [pure virtual]

Large impact force may be reported if rigid bodies are spawned inside one another. In this case the realative velocity of the two objects will be low. This variable allows the user to set a minimum velocity threshold for impacts to ensure that the objects are moving at a min velocity in order for the impact force to be considered.

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getInstancedChunkMeshCount ( ) const [pure virtual]

Get the number of instanced chunk meshes in this asset.

virtual float nvidia::apex::DestructibleAssetAuthoring::getNeighborPadding ( ) const [pure virtual]

Get padding used for chunk neighbor tests. Set setNeighborPadding().

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getPartIndex ( uint32_t chunkIndex ) const [pure virtual]

The render mesh asset part index associated with this chunk.

virtual const RenderMeshAsset* nvidia::apex::DestructibleAssetAuthoring::getRenderMeshAsset ( ) const [pure virtual]

Gets the RenderMeshAsset associated with this asset.

virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::getScatterMeshAssetCount ( ) const [pure virtual]

Retrieve the number of scatter mesh assets

virtual RenderMeshAsset* const nvidia::apex::DestructibleAssetAuthoring::getScatterMeshAssets ( ) const [pure virtual]

Retrieve the scatter mesh asset array

virtual void nvidia::apex::DestructibleAssetAuthoring::getStats ( DestructibleAssetStats & stats ) const [pure virtual]

Returns stats (sizes, counts) for the asset. See DestructibleAssetStats.

virtual bool nvidia::apex::DestructibleAssetAuthoring::hierarchicallySplitChunk | ( | uint32_t | chunkIndex,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureSliceDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t * | randomSeed,
 |  | IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the chunk in chunk[chunkIndex], forming a hierarchy of fractured chunks using slice-mode fracturing. The chunks will be rearranged so that they are in breadth-first order.

Parameters:
chunkIndex | index of chunk to be split
meshProcessingParams | describes generic mesh processing directives
desc | describes the slicing surfaces (see FractureSliceDesc)
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual bool nvidia::apex::DestructibleAssetAuthoring::importDestructibleAssetToRootMesh | ( | const nvidia::DestructibleAsset & | destructibleAsset,
 |  | uint32_t | maxRootDepth = UINT32_MAX
 | ) |  | [pure virtual]

Builds the root ExplicitHierarchicalMesh from an DestructibleAsset. Since an DestructibleAsset contains hierarchy information, the explicit mesh formed will have this hierarchy structure.

Parameters:
destructibleAsset | the asset to import
maxRootDepth | cap the root depth at this value. Re-fracturing of the mesh will occur at this depth. Default = UINT32_MAX
virtual bool nvidia::apex::DestructibleAssetAuthoring::importRenderMeshAssetToRootMesh | ( | const nvidia::RenderMeshAsset & | renderMeshAsset,
 |  | uint32_t | maxRootDepth = UINT32_MAX
 | ) |  | [pure virtual]

Builds the root ExplicitHierarchicalMesh from an RenderMeshAsset. Since an DestructibleAsset contains no hierarchy information, the input mesh must have only one part.

Parameters:
renderMeshAsset | the asset to import
maxRootDepth | cap the root depth at this value. Re-fracturing of the mesh will occur at this depth. Default = UINT32_MAX
virtual uint32_t nvidia::apex::DestructibleAssetAuthoring::partitionMeshByIslands | ( | nvidia::ExplicitRenderTriangle * | mesh,
 |  | uint32_t | meshTriangleCount,
 |  | uint32_t * | meshPartition,
 |  | uint32_t | meshPartitionMaxCount,
 |  | float | padding = 0.0001f
 | ) |  | [pure virtual]

Partitions (and possibly re-orders) the mesh array if the triangles form disjoint islands.

Parameters:
mesh | pointer to array of ExplicitRenderTriangles which make up the mesh
meshTriangleCount | the size of the meshTriangles array
meshPartition | user-allocated array for mesh partition, will be filled with the end elements of contiguous subsets of meshTriangles.
meshPartitionMaxCount | size of user-allocated meshPartitionArray
padding | relative value multiplied by the mesh bounding box. padding gets added to the triangle bounds when calculating triangle neighbors.
Returns:
Returns the number of partitions. The value may be larger than meshPartitionMaxCount. In that case, the partitions beyond meshPartitionMaxCount are not recorded.
virtual void nvidia::apex::DestructibleAssetAuthoring::removeChunkOverlaps | ( | IntPair * | supportGraphEdges,
 |  | uint32_t | numSupportGraphEdges,
 |  | bool | keepCachedFlagIfEmpty
 | ) |  | [pure virtual]

Removes edges from support graph. The indices refer to the reordered chunk array, a mapping is provided in cookChunks.

Parameters:
supportGraphEdges | Integer pairs representing indices to chunks that are linked
numSupportGraphEdges | Number of provided integer pairs.
keepCachedFlagIfEmpty | If the flag is set, the depth is considered to be cached even if the overlaps list is empty.
virtual bool nvidia::apex::DestructibleAssetAuthoring::removePlatformMaxDepth ( PlatformTag platform ) [pure virtual]

Removes the maximum fracture depth limit for a given platform string.

Returns true if the platform's maximum fracture depth was previously set and now removed

virtual void nvidia::apex::DestructibleAssetAuthoring::serializeFractureToolState | ( | PxFileBuf & | stream,
 |  | nvidia::ExplicitHierarchicalMesh::Embedding & | embedding
 | ) |  | const [pure virtual]

Serialization of the data associated with the fracture API. This includes the root mesh, core mesh, and cutout set.

virtual void nvidia::apex::DestructibleAssetAuthoring::setBSPBuildParameters | ( | float | logAreaSigmaThreshold,
 |  | uint32_t | testSetSize,
 |  | float | splitWeight,
 |  | float | imbalanceWeight
 | ) |  | [pure virtual]

Set the parameters used in BSP building operations.

Parameters:
logAreaSigmaThreshold | At each step in the tree building process, the surface with maximum triangle area is compared to the other surface triangle areas. If the maximum area surface is far from the "typical" set of surface areas, then that surface is chosen as the next splitting plane. Otherwise, a random test set is chosen and a winner determined based upon the weightings below. The value logAreaSigmaThreshold determines how "atypical" the maximum area surface must be to be chosen in this manner. Default value = 2.0.
testSetSize | Larger values of testSetSize may find better BSP trees, but will take more time to create. testSetSize = 0 is treated as infinity (all surfaces will be tested for each branch). Default value = 10.
splitWeight | How much to weigh the relative number of triangle splits when searching for a BSP surface. Default value = 0.5.
imbalanceWeight | How much to weigh the relative triangle imbalance when searching for a BSP surface. Default value = 0.0.
virtual void nvidia::apex::DestructibleAssetAuthoring::setBSPTolerances | ( | float | linearTolerance,
 |  | float | angularTolerance,
 |  | float | baseTolerance,
 |  | float | clipTolerance,
 |  | float | cleaningTolerance
 | ) |  | [pure virtual]

Set the tolerances used in CSG calculations.

Parameters:
linearTolerance | relative (to mesh size) tolerance used with angularTolerance to determine coplanarity. Default = 1.0e-4.
angularTolerance | used with linearTolerance to determine coplanarity. Default = 1.0e-3
baseTolerance | relative (to mesh size) tolerance used for spatial partitioning
clipTolerance | relative (to mesh size) tolerance used when clipping triangles for CSG mesh building operations. Default = 1.0e-4.
cleaningTolerance | relative (to mesh size) tolerance used when cleaning the out put mesh generated from the toMesh() function. Default = 1.0e-7.
virtual void nvidia::apex::DestructibleAssetAuthoring::setChunkOverlapsCacheDepth ( int32_t depth = -1 ) [pure virtual]

Set current depth for chunk overlaps calculations.

virtual bool nvidia::apex::DestructibleAssetAuthoring::setCoreMesh | ( | const ExplicitRenderTriangle * | mesh,
 |  | uint32_t | meshTriangleCount,
 |  | const ExplicitSubmeshData * | submeshData,
 |  | uint32_t | submeshCount,
 |  | uint32_t * | meshPartition = NULL,
 |  | uint32_t | meshPartitionCount = 0
 | ) |  | [pure virtual]

Builds a new ExplicitHierarchicalMesh from an array of triangles, used as the core mesh for slice fracture operations (see FractureTools::FractureSliceDesc, passed into createHierarchicallySplitMesh).

Parameters:
mesh | pointer to array of ExplicitRenderTriangles which make up the mesh
meshTriangleCount | the size of the meshTriangles array
submeshData | pointer to array of ExplicitSubmeshData, describing the submeshes
submeshCount | the size of the submeshData array
meshPartition | meshPartition array
meshPartitionCount | meshPartition array size
virtual void nvidia::apex::DestructibleAssetAuthoring::setCrumbleEmitterName ( const char * ) [pure virtual]

Set the name of the emitter to use when generating crumble particles.

virtual void nvidia::apex::DestructibleAssetAuthoring::setDestructibleInitParameters ( const DestructibleInitParameters & ) [pure virtual]

Set the parameters used for default destructible initialization. See DestructibleInitParameters.

virtual void nvidia::apex::DestructibleAssetAuthoring::setDestructibleParameters ( const DestructibleParameters & ) [pure virtual]

Set the parameters used for runtime destruction behavior. See DestructibleParameters.

virtual void nvidia::apex::DestructibleAssetAuthoring::setDustEmitterName ( const char * ) [pure virtual]

Set the name of the emitter to use when generating fracture-line dust particles.

virtual void nvidia::apex::DestructibleAssetAuthoring::setFracturePatternName ( const char * ) [pure virtual]

Set the name of the fracture pattern to use when runtime fracture is enabled.

virtual void nvidia::apex::DestructibleAssetAuthoring::setNeighborPadding ( float neighborPadding ) [pure virtual]

Set padding used for chunk neighbor tests. This padding is relative to the largest diagonal of the asset's local bounding box. This value must be non-negative. Default value = 0.001f.

virtual bool nvidia::apex::DestructibleAssetAuthoring::setPlatformMaxDepth | ( | PlatformTag | platform,
 |  | uint32_t | maxDepth
 | ) |  | [pure virtual]

Set a maximum fracture depth for a given platform string.

Returns true if the supplied maxDepth is lesser than the number of chunk depth levels for this asset

virtual bool nvidia::apex::DestructibleAssetAuthoring::setRenderMeshAsset ( RenderMeshAsset * ) [pure virtual]

Set the RenderMeshAsset associated with this asset. This is the asset used for non-instanced rendering. NULL is a valid argument, and can be used to clear the internal mesh data.

Returns:
Returns true if successful.
virtual bool nvidia::apex::DestructibleAssetAuthoring::setRootMesh | ( | const ExplicitRenderTriangle * | meshTriangles,
 |  | uint32_t | meshTriangleCount,
 |  | const ExplicitSubmeshData * | submeshData,
 |  | uint32_t | submeshCount,
 |  | uint32_t * | meshPartition = NULL,
 |  | uint32_t | meshPartitionCount = 0,
 |  | int32_t * | parentIndices = NULL,
 |  | uint32_t | parentIndexCount = 0
 | ) |  | [pure virtual]

Builds a new ExplicitHierarchicalMesh from an array of triangles, used as the starting point for fracturing. It will contain only one chunk, at depth 0.

Parameters:
meshTriangles | pointer to array of ExplicitRenderTriangles which make up the mesh
meshTriangleCount | the size of the meshTriangles array
submeshData | pointer to array of ExplicitSubmeshData, describing the submeshes
submeshCount | the size of the submeshData array
meshPartition | if not NULL, an array of size meshPartitionCount, giving the end elements of contiguous subsets of meshTriangles. If meshPartition is NULL, one partition is assumed. When there is one partition, these triangles become the level 0 part. When there is more than one partition, the behavior is determined by firstPartitionIsDepthZero (see below).
meshPartitionCount | if meshPartition is not NULL, this is the size of the meshPartition array.
parentIndices | if not NULL, the parent indices for each chunk (corresponding to a partition in the mesh partition).
parentIndexCount | the size of the parentIndices array. This does not need to match meshPartitionCount. If a mesh partition has an index beyond the end of parentIndices, then the parentIndex is considered to be 0. Therefore, if parentIndexCount = 0, all parents are 0 and so all chunks created will be depth 1. This will cause a depth 0 chunk to be created that is the aggregate of the depth 1 chunks. If parentIndexCount > 0, then the depth-0 chunk must have a parentIndex of -1. To reproduce the effect of the old parameter 'firstPartitionIsDepthZero' = true, set parentIndices to the address of a int32_t containing the value -1, and set parentIndexCount = 1. To reproduce the effect of the old parameter 'firstPartitionIsDepthZero' = false, set parentIndexCount = 0. Note: if parent indices are given, the first one must be -1, and *only* that index may be negative. That is, there may be only one depth-0 mesh and it must be the first mesh.
virtual bool nvidia::apex::DestructibleAssetAuthoring::setScatterMeshAssets | ( | RenderMeshAsset ** | scatterMeshAssetArray,
 |  | uint32_t | scatterMeshAssetArraySize
 | ) |  | [pure virtual]

Set the RenderMeshAssets used for scatter mesh rendering associated with this asset. These assets will be rendered using instanced rendering. The array cannot contain NULL elements, if an array size greater than zero is specified.

Returns:
Returns true if successful.
virtual void nvidia::apex::DestructibleAssetAuthoring::trimCollisionGeometry | ( | const uint32_t * | partIndices,
 |  | uint32_t | partIndexCount,
 |  | float | maxTrimFraction = 0.2f
 | ) |  | [pure virtual]

Trim collision geometry to prevent explosive behavior. maxTrimFraction is the maximum (relative) distance to trim a hull in the direction of each trim plane.

Returns:
Returns true iff successful.
virtual void nvidia::apex::DestructibleAssetAuthoring::visualizeVoronoiCells | ( | nvidia::RenderDebugInterface & | debugRender,
 |  | const PxVec3 * | sites,
 |  | uint32_t | siteCount,
 |  | const uint32_t * | cellColors,
 |  | uint32_t | cellColorCount,
 |  | const PxBounds3 & | bounds,
 |  | uint32_t | cellIndex = 0xFFFFFFFF
 | ) |  | [pure virtual]

Utility to visualize Voronoi cells for a given set of sites.

Parameters:
debugRender | rendering object which will receive the drawing primitives associated with this cell visualization
sites | an array of Voronoi cell sites, of length siteCount
siteCount | the number of Voronoi cell sites (length of sites array)
cellColors | an optional array of colors (see RenderDebug for format) for the cells. If NULL, the white (0xFFFFFFFF) color will be used. If not NULL, this (of length cellColorCount) is used to color the cell graphics. The number cellColorCount need not match siteCount. If cellColorCount is less than siteCount, the cell colors will cycle. That is, site N gets cellColor[NcellColorCount].
cellColorCount | the number of cell colors (the length of cellColors array)
bounds | defines an axis-aligned bounding box which clips the visualization, since some cells extend to infinity
cellIndex | if this is a valid index (cellIndex < siteCount), then only the cell corresponding to sites[cellIndex] will be drawn. Otherwise, all cells will be drawn.
virtual bool nvidia::apex::DestructibleAssetAuthoring::voronoiSplitChunk | ( | uint32_t | chunkIndex,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureVoronoiDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t * | randomSeed,
 |  | IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the chunk in chunk[chunkIndex], forming fractured chunks using Voronoi decomposition fracturing. The chunks will be rearranged so that they are in breadth-first order.

Parameters:
chunkIndex | index of chunk to be split
meshProcessingParams | describes generic mesh processing directives
desc | describes the voronoi splitting parameters surfaces (see FractureVoronoiDesc)
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
The documentation for this class was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAssetAuthoring
nvidia::apex::DestructibleAssetAuthoring Member List
This is the complete list of members for nvidia::apex::DestructibleAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
addChunkOverlaps(IntPair *supportGraphEdges, uint32_t numSupportGraphEdges)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
appendActorTransforms(const PxMat44 *transforms, uint32_t transformCount)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
applyTransformation(const PxMat44 &transformation, float scale)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
applyTransformation(const PxMat44 &transformation)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
buildCutoutSet(const uint8_t *pixelBuffer, uint32_t bufferWidth, uint32_t bufferHeight, float snapThreshold, bool periodic)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
buildExplicitHierarchicalMesh(ExplicitHierarchicalMesh &hMesh, const ExplicitRenderTriangle *meshTriangles, uint32_t meshTriangleCount, const ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0, int32_t *parentIndices=NULL, uint32_t parentIndexCount=0)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
buildSliceMesh(const ExplicitRenderTriangle *&mesh, const FractureTools::NoiseParameters &noiseParameters, const PxPlane &slicePlane, uint32_t randomSeed)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
cacheChunkOverlapsUpToDepth(int32_t depth=-1)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
calculateCutoutUVMapping(PxMat33 &mapping, const nvidia::ExplicitRenderTriangle &triangle)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
calculateCutoutUVMapping(PxMat33 &mapping, const PxVec3 &targetDirection)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
clearActorTransforms()=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
clearChunkOverlaps(int32_t depth=-1, bool keepCachedFlag=false)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
cookChunks(const DestructibleAssetCookingDesc &cookingDesc, bool cacheOverlaps=true, uint32_t *chunkIndexMapUser2Apex=NULL, uint32_t *chunkIndexMapApex2User=NULL, uint32_t chunkIndexMapCount=0)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
createChippedMesh(const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureCutoutDesc &desc, const FractureTools::CutoutSet &cutoutSet, const FractureTools::FractureSliceDesc &sliceDesc, const FractureTools::FractureVoronoiDesc &voronoiDesc, const CollisionDesc &collisionDesc, uint32_t randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
createExplicitHierarchicalMeshConvexHull()=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
createHierarchicallySplitMesh(const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, uint32_t randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
createScatterMeshSites(uint8_t *meshIndices, PxMat44 *relativeTransforms, uint32_t *chunkMeshStarts, uint32_t scatterMeshInstancesBufferSize, uint32_t targetChunkCount, const uint16_t *targetChunkIndices, uint32_t *randomSeed, uint32_t scatterMeshAssetCount, nvidia::RenderMeshAsset **scatterMeshAssets, const uint32_t *minCount, const uint32_t *maxCount, const float *minScales, const float *maxScales, const float *maxAngles)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
createVoronoiSitesInsideMesh(PxVec3 *siteBuffer, uint32_t *siteChunkIndices, uint32_t siteCount, uint32_t *randomSeed, uint32_t *microgridSize, BSPOpenMode::Enum meshMode, IProgressListener &progressListener, uint32_t chunkIndex=0xFFFFFFFF)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
createVoronoiSplitMesh(const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, uint32_t randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
deserializeFractureToolState(PxFileBuf &stream, nvidia::ExplicitHierarchicalMesh::Embedding &embedding)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getActorTransformCount() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getActorTransforms() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getCachedOverlapCountAtDepth(uint32_t depth)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getCachedOverlapsAtDepth(uint32_t depth)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getChunkChild(uint32_t chunkIndex, uint32_t childIndex) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getChunkChildCount(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getChunkCount() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getChunkPositionOffset(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getChunkUVOffset(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getCoreExplicitHierarchicalMesh()=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getCutoutSet()=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getDepthCount() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getDestructibleInitParameters() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getDestructibleParameters() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getExplicitHierarchicalMesh()=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getFractureImpulseScale() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getImpactVelocityThreshold() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getInstancedChunkMeshCount() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNeighborPadding() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getPartIndex(uint32_t chunkIndex) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getRenderMeshAsset() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getScatterMeshAssetCount() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getScatterMeshAssets() const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
getStats(DestructibleAssetStats &stats) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
hierarchicallySplitChunk(uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
importDestructibleAssetToRootMesh(const nvidia::DestructibleAsset &destructibleAsset, uint32_t maxRootDepth=UINT32_MAX)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
importRenderMeshAssetToRootMesh(const nvidia::RenderMeshAsset &renderMeshAsset, uint32_t maxRootDepth=UINT32_MAX)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
partitionMeshByIslands(nvidia::ExplicitRenderTriangle *mesh, uint32_t meshTriangleCount, uint32_t *meshPartition, uint32_t meshPartitionMaxCount, float padding=0.0001f)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
removeChunkOverlaps(IntPair *supportGraphEdges, uint32_t numSupportGraphEdges, bool keepCachedFlagIfEmpty)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
removePlatformMaxDepth(PlatformTag platform)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
serializeFractureToolState(PxFileBuf &stream, nvidia::ExplicitHierarchicalMesh::Embedding &embedding) const =0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setBSPBuildParameters(float logAreaSigmaThreshold, uint32_t testSetSize, float splitWeight, float imbalanceWeight)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setBSPTolerances(float linearTolerance, float angularTolerance, float baseTolerance, float clipTolerance, float cleaningTolerance)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setChunkOverlapsCacheDepth(int32_t depth=-1)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setCoreMesh(const ExplicitRenderTriangle *mesh, uint32_t meshTriangleCount, const ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setCrumbleEmitterName(const char *)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setDestructibleInitParameters(const DestructibleInitParameters &)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setDestructibleParameters(const DestructibleParameters &)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setDustEmitterName(const char *)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setFracturePatternName(const char *)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setNeighborPadding(float neighborPadding)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setPlatformMaxDepth(PlatformTag platform, uint32_t maxDepth)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setRenderMeshAsset(RenderMeshAsset *)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setRootMesh(const ExplicitRenderTriangle *meshTriangles, uint32_t meshTriangleCount, const ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0, int32_t *parentIndices=NULL, uint32_t parentIndexCount=0)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setScatterMeshAssets(RenderMeshAsset **scatterMeshAssetArray, uint32_t scatterMeshAssetArraySize)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
trimCollisionGeometry(const uint32_t *partIndices, uint32_t partIndexCount, float maxTrimFraction=0.2f)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
visualizeVoronoiCells(nvidia::RenderDebugInterface &debugRender, const PxVec3 *sites, uint32_t siteCount, const uint32_t *cellColors, uint32_t cellColorCount, const PxBounds3 &bounds, uint32_t cellIndex=0xFFFFFFFF)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
voronoiSplitChunk(uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::DestructibleAssetAuthoring | [pure virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleAssetCookingDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAssetCookingDesc
Public Member Functions | Public Attributes
nvidia::apex::DestructibleAssetCookingDesc Class Reference

#include <DestructibleAsset.h>

Inheritance diagram for nvidia::apex::DestructibleAssetCookingDesc:
nvidia::apex::ApexDesc

List of all members.

Public Member Functions

PX_INLINE | DestructibleAssetCookingDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE bool | isValid () const

Public Attributes

DestructibleChunkDesc * chunkDescs
uint32_t | chunkDescCount
DestructibleBehaviorGroupDesc defaultBehaviorGroupDesc
DestructibleBehaviorGroupDesc * behaviorGroupDescs
uint32_t | behaviorGroupDescCount
int8_t | RTFractureBehaviorGroup
DestructibleGeometryDesc * geometryDescs
uint32_t | geometryDescCount
nvidia::IntPair * | supportGraphEdges
uint32_t | supportGraphEdgeCount

Detailed Description

Destructible authoring structure.

Descriptor for the cookChunk() method of DestructibleAssetAuthoring

Member Function Documentation

PX_INLINE bool nvidia::apex::DestructibleAssetCookingDesc::isValid ( ) const

Returns true iff an object can be created using this descriptor.

Reimplemented from nvidia::apex::ApexDesc.

Member Data Documentation

uint32_t nvidia::apex::DestructibleAssetCookingDesc::behaviorGroupDescCount

The size of the behaviorGroupDescs array. This must be positive.

DestructibleBehaviorGroupDesc* nvidia::apex::DestructibleAssetCookingDesc::behaviorGroupDescs

Beginning of array of descriptors, one for each behavior group.

uint32_t nvidia::apex::DestructibleAssetCookingDesc::chunkDescCount

The size of the chunkDescs array. This must be positive.

DestructibleChunkDesc* nvidia::apex::DestructibleAssetCookingDesc::chunkDescs

Beginning of array of descriptors, one for each chunk.

DestructibleBehaviorGroupDesc nvidia::apex::DestructibleAssetCookingDesc::defaultBehaviorGroupDesc

Default behavior group (corresponds to index of -1).

uint32_t nvidia::apex::DestructibleAssetCookingDesc::geometryDescCount

The size of the geometryDescs array. This must be positive.

DestructibleGeometryDesc* nvidia::apex::DestructibleAssetCookingDesc::geometryDescs

Beginning of array of descriptors, one for each mesh part.

int8_t nvidia::apex::DestructibleAssetCookingDesc::RTFractureBehaviorGroup

RT fracture behavior group

uint32_t nvidia::apex::DestructibleAssetCookingDesc::supportGraphEdgeCount

Number of index pairs in supportGraphEdges.

nvidia::IntPair* nvidia::apex::DestructibleAssetCookingDesc::supportGraphEdges

Index pairs that represent chunk connections in the support graph. The indices refer to the chunkDescs array. Only sibling chunks, i.e. chunks at equal depth may be connected.

The documentation for this class was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAssetCookingDesc
nvidia::apex::DestructibleAssetCookingDesc Member List
This is the complete list of members for nvidia::apex::DestructibleAssetCookingDesc, including all inherited members.
ApexDesc() | nvidia::apex::ApexDesc | [inline]
behaviorGroupDescCount | nvidia::apex::DestructibleAssetCookingDesc |
behaviorGroupDescs | nvidia::apex::DestructibleAssetCookingDesc |
chunkDescCount | nvidia::apex::DestructibleAssetCookingDesc |
chunkDescs | nvidia::apex::DestructibleAssetCookingDesc |
defaultBehaviorGroupDesc | nvidia::apex::DestructibleAssetCookingDesc |
DestructibleAssetCookingDesc() | nvidia::apex::DestructibleAssetCookingDesc |
geometryDescCount | nvidia::apex::DestructibleAssetCookingDesc |
geometryDescs | nvidia::apex::DestructibleAssetCookingDesc |
isValid() const | nvidia::apex::DestructibleAssetCookingDesc |
RTFractureBehaviorGroup | nvidia::apex::DestructibleAssetCookingDesc |
setToDefault() | nvidia::apex::DestructibleAssetCookingDesc |
supportGraphEdgeCount | nvidia::apex::DestructibleAssetCookingDesc |
supportGraphEdges | nvidia::apex::DestructibleAssetCookingDesc |
userData | nvidia::apex::ApexDesc |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleBehaviorGroupDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleBehaviorGroupDesc
Public Member Functions | Public Attributes
nvidia::apex::DestructibleBehaviorGroupDesc Class Reference

#include <DestructibleAsset.h>

Inheritance diagram for nvidia::apex::DestructibleBehaviorGroupDesc:
nvidia::apex::ApexDesc

List of all members.

Public Member Functions

PX_INLINE | DestructibleBehaviorGroupDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE bool | isValid () const

Public Attributes

const char * | name
name
float | damageThreshold
damage threshold
float | damageToRadius
damage to radius
DamageSpreadFunction damageSpread
damage spread
DamageSpreadFunction damageColorSpread
damage color spread
PxVec4 | damageColorChange
damege color change
float | materialStrength
material strength
float | density
density
float | fadeOut
fade out
float | maxDepenetrationVelocity
maximal depenetration velocity
uint64_t | userData
user data

Detailed Description

Destructible authoring structure.

Descriptor to build one chunk in a fracture hierarchy.

Member Function Documentation

PX_INLINE bool nvidia::apex::DestructibleBehaviorGroupDesc::isValid ( ) const

Returns true iff an object can be created using this descriptor.

Reimplemented from nvidia::apex::ApexDesc.

Member Data Documentation

const char* nvidia::apex::DestructibleBehaviorGroupDesc::name

name

Defines the chunk to be environmentally supported, if the appropriate DestructibleParametersFlag flags are set in DestructibleParameters.

The documentation for this class was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleBehaviorGroupDesc
nvidia::apex::DestructibleBehaviorGroupDesc Member List
This is the complete list of members for nvidia::apex::DestructibleBehaviorGroupDesc, including all inherited members.
ApexDesc() | nvidia::apex::ApexDesc | [inline]
damageColorChange | nvidia::apex::DestructibleBehaviorGroupDesc |
damageColorSpread | nvidia::apex::DestructibleBehaviorGroupDesc |
damageSpread | nvidia::apex::DestructibleBehaviorGroupDesc |
damageThreshold | nvidia::apex::DestructibleBehaviorGroupDesc |
damageToRadius | nvidia::apex::DestructibleBehaviorGroupDesc |
density | nvidia::apex::DestructibleBehaviorGroupDesc |
DestructibleBehaviorGroupDesc() | nvidia::apex::DestructibleBehaviorGroupDesc |
fadeOut | nvidia::apex::DestructibleBehaviorGroupDesc |
isValid() const | nvidia::apex::DestructibleBehaviorGroupDesc |
materialStrength | nvidia::apex::DestructibleBehaviorGroupDesc |
maxDepenetrationVelocity | nvidia::apex::DestructibleBehaviorGroupDesc |
name | nvidia::apex::DestructibleBehaviorGroupDesc |
setToDefault() | nvidia::apex::DestructibleBehaviorGroupDesc |
userData | nvidia::apex::DestructibleBehaviorGroupDesc |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleChunkDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleChunkDesc
Public Member Functions | Public Attributes
nvidia::apex::DestructibleChunkDesc Class Reference

#include <DestructibleAsset.h>

Inheritance diagram for nvidia::apex::DestructibleChunkDesc:
nvidia::apex::ApexDesc

List of all members.

Public Member Functions

PX_INLINE | DestructibleChunkDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE bool | isValid () const

Public Attributes

bool | isSupportChunk
bool | doNotFracture
bool | doNotDamage
bool | doNotCrumble
bool | runtimeFracture
bool | useInstancedRendering
PxVec3 | instancePositionOffset
PxVec2 | instanceUVOffset
uint16_t | meshIndex
int32_t | parentIndex
PxVec3 | surfaceNormal
int8_t | behaviorGroupIndex
uint32_t | scatterMeshCount
const uint8_t * | scatterMeshIndices
const PxMat44 * | scatterMeshTransforms

Detailed Description

Destructible authoring structure.

Descriptor to build one chunk in a fracture hierarchy.

Member Function Documentation

PX_INLINE bool nvidia::apex::DestructibleChunkDesc::isValid ( ) const

Returns true iff an object can be created using this descriptor.

Reimplemented from nvidia::apex::ApexDesc.

Member Data Documentation

int8_t nvidia::apex::DestructibleChunkDesc::behaviorGroupIndex

Referring to the behavior group used of this chunk, please check DestructibleAssetCookingDesc::behaviorGroupDescs for more detail.

bool nvidia::apex::DestructibleChunkDesc::doNotCrumble

Defines the chunk to be uncrumbleable. This means this chunk will not be broken down into fluid mesh particles no matter how much damage it takes. Note: this only applies to chunks with no children. For a chunk with children, then: 1) The chunk may be broken down into its children, and then its children may be crumbled, if the doNotCrumble flag is not set on them. 2) If the Destructible module's chunk depth offset LOD may be set such that this chunk effectively has no children. In this case, the doNotCrumble flag will apply to it.

bool nvidia::apex::DestructibleChunkDesc::doNotDamage

Defines the chunk to be undamageable. This means this chunk will not fracture, but its children might.

bool nvidia::apex::DestructibleChunkDesc::doNotFracture

Defines the chunk to be unfractureable. If this is true, then none of its children will be fractureable.

PxVec3 nvidia::apex::DestructibleChunkDesc::instancePositionOffset

Translation for this chunk mesh within the asset. Normally a chunk needs no translation, but if a chunk is instanced within the asset, then this translation is needed. Default = (0,0,0).

PxVec2 nvidia::apex::DestructibleChunkDesc::instanceUVOffset

UV translation for this chunk mesh within the asset. Normally a chunk needs no UV translation, but if a chunk is instanced within the asset, then this translation is usually needed. Default = (0,0).

bool nvidia::apex::DestructibleChunkDesc::isSupportChunk

Defines the chunk to be environmentally supported, if the appropriate DestructibleParametersFlag flags are set in DestructibleParameters.

uint16_t nvidia::apex::DestructibleChunkDesc::meshIndex

If useInstancedRendering = TRUE, this index is the instanced mesh index. If useInstancedRendering = FALSE, this index is the mesh part index for the skinned or statically rendered mesh. This must index a valid DestructibleGeometryDesc (see below). Default = 0xFFFF (invalid).

int32_t nvidia::apex::DestructibleChunkDesc::parentIndex

The parent index of this chunk. If the index is negative, this is a root chunk. Default = -1.

bool nvidia::apex::DestructibleChunkDesc::runtimeFracture

Defines the chunk to use run-time, dynamic fracturing. The chunk will use the fracture pattern provided by the asset to guide it's fracture. The resulting chunks will follow a similar process for subdivision.

uint32_t nvidia::apex::DestructibleChunkDesc::scatterMeshCount

The number of scatter mesh instances on this chunk. Default = 0.

const uint8_t* nvidia::apex::DestructibleChunkDesc::scatterMeshIndices

Array of indices corresponding the scatter mesh assets set using DestructibleAssetAuthoring::setScatterMeshAssets(). The array length must be at least scatterMeshCount. This pointer may be NULL if scatterMeshCount = 0. Default = NULL.

const PxMat44* nvidia::apex::DestructibleChunkDesc::scatterMeshTransforms

Array of chunk-relative transforms corresponding the scatter mesh assets set using DestructibleAssetAuthoring::setScatterMeshAssets(). The array length must be at least scatterMeshCount. This pointer may be NULL if scatterMeshCount = 0. Default = NULL.

PxVec3 nvidia::apex::DestructibleChunkDesc::surfaceNormal

A direction used to move the chunk out of the destructible, if an impact kick is applied.

bool nvidia::apex::DestructibleChunkDesc::useInstancedRendering

Whether or not to use instancing when rendering this chunk. If useInstancedRendering = TRUE, this chunk will share a draw call with all others that instance the mesh indexed by meshIndex. This may extend to other destructible actors created from this asset. If useInstancedRendering = FALSE, this chunk may share a draw call only with other chunks in this asset which have useInstancedRendering = FALSE. Default = FALSE.

The documentation for this class was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleChunkDesc
nvidia::apex::DestructibleChunkDesc Member List
This is the complete list of members for nvidia::apex::DestructibleChunkDesc, including all inherited members.
ApexDesc() | nvidia::apex::ApexDesc | [inline]
behaviorGroupIndex | nvidia::apex::DestructibleChunkDesc |
DestructibleChunkDesc() | nvidia::apex::DestructibleChunkDesc |
doNotCrumble | nvidia::apex::DestructibleChunkDesc |
doNotDamage | nvidia::apex::DestructibleChunkDesc |
doNotFracture | nvidia::apex::DestructibleChunkDesc |
instancePositionOffset | nvidia::apex::DestructibleChunkDesc |
instanceUVOffset | nvidia::apex::DestructibleChunkDesc |
isSupportChunk | nvidia::apex::DestructibleChunkDesc |
isValid() const | nvidia::apex::DestructibleChunkDesc |
meshIndex | nvidia::apex::DestructibleChunkDesc |
parentIndex | nvidia::apex::DestructibleChunkDesc |
runtimeFracture | nvidia::apex::DestructibleChunkDesc |
scatterMeshCount | nvidia::apex::DestructibleChunkDesc |
scatterMeshIndices | nvidia::apex::DestructibleChunkDesc |
scatterMeshTransforms | nvidia::apex::DestructibleChunkDesc |
setToDefault() | nvidia::apex::DestructibleChunkDesc |
surfaceNormal | nvidia::apex::DestructibleChunkDesc |
useInstancedRendering | nvidia::apex::DestructibleChunkDesc |
userData | nvidia::apex::ApexDesc |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleGeometryDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleGeometryDesc
Public Member Functions | Public Attributes
nvidia::apex::DestructibleGeometryDesc Class Reference

#include <DestructibleAsset.h>

Inheritance diagram for nvidia::apex::DestructibleGeometryDesc:
nvidia::apex::ApexDesc

List of all members.

Public Member Functions

PX_INLINE | DestructibleGeometryDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE bool | isValid () const

Public Attributes

const
nvidia::ExplicitHierarchicalMesh::ConvexHull ** 		convexHulls
uint32_t | convexHullCount
const CollisionVolumeDesc * | collisionVolumeDesc

Detailed Description

Destructible authoring structure.

Descriptor to build one chunk in a fracture hierarchy.

Member Function Documentation

PX_INLINE bool nvidia::apex::DestructibleGeometryDesc::isValid ( ) const

Returns true iff an object can be created using this descriptor.

Reimplemented from nvidia::apex::ApexDesc.

Member Data Documentation

const CollisionVolumeDesc* nvidia::apex::DestructibleGeometryDesc::collisionVolumeDesc

If convexHullCount = 0, then collisionVolumeDesc must not be NULL. In this case convex hulls will automatically be created for this geometry. See CollisionVolumeDesc.

uint32_t nvidia::apex::DestructibleGeometryDesc::convexHullCount

The length of the convexHulls array. If this is positive, then convexHulls must point to a valid array of this size. If this is zero, then collisionVolumeDesc must not be NULL, and convex hulls will be automatically created for this geometry using collisionVolumeDesc.

const nvidia::ExplicitHierarchicalMesh::ConvexHull** nvidia::apex::DestructibleGeometryDesc::convexHulls

The convex hulls associated with this chunk. These may be obtained from ExplicitHierarchicalMesh::convexHulls() if authoring using an ExplicitHierarchicalMesh. The length of the array is given by convexHullCount.

The documentation for this class was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleGeometryDesc
nvidia::apex::DestructibleGeometryDesc Member List
This is the complete list of members for nvidia::apex::DestructibleGeometryDesc, including all inherited members.
ApexDesc() | nvidia::apex::ApexDesc | [inline]
collisionVolumeDesc | nvidia::apex::DestructibleGeometryDesc |
convexHullCount | nvidia::apex::DestructibleGeometryDesc |
convexHulls | nvidia::apex::DestructibleGeometryDesc |
DestructibleGeometryDesc() | nvidia::apex::DestructibleGeometryDesc |
isValid() const | nvidia::apex::DestructibleGeometryDesc |
setToDefault() | nvidia::apex::DestructibleGeometryDesc |
userData | nvidia::apex::ApexDesc |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructiblePreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructiblePreview
Public Member Functions
nvidia::apex::DestructiblePreview Class Reference

Destructible module's derivation AssetPreview. More...

#include <DestructiblePreview.h>

Inheritance diagram for nvidia::apex::DestructiblePreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual const RenderMeshActor * | getRenderMeshActor () const =0
Returns render mesh actor.
virtual void | setExplodeView (uint32_t depth, float explode)=0
Sets the preview chunk depth and "explode" amount (pushes the chunks out by that relative distance).

Detailed Description

Destructible module's derivation AssetPreview.

Member Function Documentation

virtual void nvidia::apex::DestructiblePreview::setExplodeView | ( | uint32_t | depth,
 |  | float | explode
 | ) |  | [pure virtual]

Sets the preview chunk depth and "explode" amount (pushes the chunks out by that relative distance).

Parameters:
[in] | depth | Must be nonnegative. Internally the value will be clamped to the depth range in the asset.
[in] | explode | must be nonnegative.
The documentation for this class was generated from the following file:
  • DestructiblePreview.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructiblePreview
nvidia::apex::DestructiblePreview Member List
This is the complete list of members for nvidia::apex::DestructiblePreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
DestructiblePreview() (defined in nvidia::apex::DestructiblePreview) | nvidia::apex::DestructiblePreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
getRenderMeshActor() const =0 | nvidia::apex::DestructiblePreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setExplodeView(uint32_t depth, float explode)=0 | nvidia::apex::DestructiblePreview | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleRenderable Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRenderable
Public Member Functions
nvidia::apex::DestructibleRenderable Class Reference

#include <DestructibleRenderable.h>

Inheritance diagram for nvidia::apex::DestructibleRenderable:
nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual RenderMeshActor * getRenderMeshActor (DestructibleActorMeshType::Enum type=DestructibleActorMeshType::Skinned) const =0

Detailed Description

Destructible renderable API. The destructible renderable contains rendering information for an DestructibleActor.

Member Function Documentation

virtual RenderMeshActor* nvidia::apex::DestructibleRenderable::getRenderMeshActor ( DestructibleActorMeshType::Enum type = DestructibleActorMeshType::Skinned ) const [pure virtual]

Get the render mesh actor for the specified mesh type.

The documentation for this class was generated from the following file:
  • DestructibleRenderable.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRenderable
nvidia::apex::DestructibleRenderable Member List
This is the complete list of members for nvidia::apex::DestructibleRenderable, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getRenderMeshActor(DestructibleActorMeshType::Enum type=DestructibleActorMeshType::Skinned) const =0 | nvidia::apex::DestructibleRenderable | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
~DestructibleRenderable() (defined in nvidia::apex::DestructibleRenderable) | nvidia::apex::DestructibleRenderable | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DisplacementMapVolume Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DisplacementMapVolume
Public Member Functions
nvidia::apex::DisplacementMapVolume Class Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

virtual void getData (uint32_t &width, uint32_t &height, uint32_t &depth, uint32_t &size, unsigned char const **ppData) const =0

Detailed Description

Interface to a "displacement map volume," used with tessellated fracturing. A displacement map volume captures how to displace a particular point in 3D space along the x, y and z axes. The data is stored as a 3D texture volume, with corresponding displacement coordinates acting as a look-up into this volume. X, Y and Z offsets correspond to R, G, and B color channels

Various approaches can be used to generate the 3D noise field, in this case Perlin noise is used, with appropriate settings specified by the FractureSliceDesc.

Member Function Documentation

virtual void nvidia::apex::DisplacementMapVolume::getData | ( | uint32_t & | width,
 |  | uint32_t & | height,
 |  | uint32_t & | depth,
 |  | uint32_t & | size,
 |  | unsigned char const ** | ppData
 | ) |  | const [pure virtual]

Fills the specified array and parameters with texture-compatible information.

The corresponding texture aligns with the displacement UVs generated as fracturing occurs when displacement maps are enabled, with RGB data corresponding to XYZ offsets, respectively.

The documentation for this class was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DisplacementMapVolume
nvidia::apex::DisplacementMapVolume Member List
This is the complete list of members for nvidia::apex::DisplacementMapVolume, including all inherited members.
getData(uint32_t &width, uint32_t &height, uint32_t &depth, uint32_t &size, unsigned char const **ppData) const =0 | nvidia::apex::DisplacementMapVolume | [pure virtual]
~DisplacementMapVolume() (defined in nvidia::apex::DisplacementMapVolume) | nvidia::apex::DisplacementMapVolume | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::EffectPackageActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EffectPackageActor
Public Member Functions
nvidia::apex::EffectPackageActor Class Reference

Defines the EffectPackageActor API which is instantiated from an EffectPackageAsset. More...

#include <EffectPackageActor.h>

Inheritance diagram for nvidia::apex::EffectPackageActor:
nvidia::apex::Actor nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual void | fadeOut (float fadetime)=0
Fade out the EffectPackageActor over a period of time. This method will cause the actors within the EffectPackage to be 'faded out' over a period of time. The EffectPackageAsset will define how this fadeOut operation is to be applied. Some actors may simply be turned off over this duration while others are modulated in some way. For example, by default, emitter actors will have their emitter rate reduced over this duration so they do not appear to immediately cut off.
virtual void | fadeIn (float fadetime)=0
Fade in the EffectPackageActor over a period of time. This method will cause the associated effects to be faded in over a period of time. It will begin the linear interpolation fade process relative to the current fade time. Meaning if you had previously specified a fadeOut duration of 1 second but then execute a fadeIn just a 1/2 second later, will will begin fading in from a 50% level; not zero.
virtual uint32_t | getEffectCount () const =0
Returns the number of effects within this effect package.
virtual EffectType | getEffectType (uint32_t effectIndex) const =0
Returns the type of effect at this index location.
virtual const char * | getEffectName (uint32_t effectIndex) const =0
Returns the name of the effect at this index.
virtual bool | isEffectEnabled (uint32_t effectIndex) const =0
Returns true if this sub-effect is currently enabled.
virtual bool | setEffectEnabled (uint32_t effectIndex, bool state)=0
Sets the enabled state of this sub-effect.
virtual void | setCurrentScale (float scale)=0
Sets the over all effect scale, this is a uniform scaling factor.
virtual float | getCurrentScale (void) const =0
Gets the current overall uniform effect scale.
virtual bool | getEffectPose (uint32_t effectIndex, PxTransform &pose, bool worldSpace)=0
Returns the pose of this sub-effect; returns as a bool the active state of this effect.
virtual bool | setEffectPose (uint32_t effectIndex, const PxTransform &pose, bool worldSpace)=0
Sets the pose of this sub-effect; returns as a bool the active state of this effect.
virtual Actor * | getEffectActor (uint32_t effectIndex) const =0
Returns the base Actor pointer for this effect. Use this method if you need direct access to the base Actor pointer relative to this effect. You must use 'getEffectType' to know what type of actor this is referring to before you cast it to either an emitter, or heat source, or turbulence actor, etc. It is important to note that the application cannot cache this pointer as it may be deleted in subsequent frames due to level of detail calculations or timing values such as fade out operations.
virtual PxRigidDynamic * | getEffectRigidDynamic (uint32_t effectIndex) const =0
Returns the base PxRigidDynamic actor pointer for this effect. Use this method if you need direct access to the base PxRigidDynamic actor pointer relative to this effect.
virtual void | setEmitterState (bool state)=0
Forces the state of all emitters associated with this effect package to be on or off. This method allows the application to manually force all emitters to be active or inactive based on an explicit call.
virtual uint32_t | getActiveParticleCount () const =0
A helper method to return the active number of particles being simulated by all related effects in this EffectPackageActor.
virtual bool | isStillEmitting () const =0
This helper method reports if any emitters within this EffectPackageActor are still actively emitting particles.
virtual bool | isAlive (void) const =0
virtual void | setEnabled (bool state)=0
Allows the application to manually enable this EffectPackageActor.
virtual bool | getEnabled () const =0
Returns the current enabled state for this actor.
virtual void | setPose (const PxTransform &pose)=0
Sets the root pose for this EffectPackageActor It's important to note that child-relative poses for each sub-component in an EffectPackageActor are authored in the ParticleEffectTool.
virtual const PxTransform & | getPose () const =0
Returns the current root pose for this EffectPackageActor.
virtual void | refresh ()=0
This method is used by the ParticleEffectTool to refresh a currently running effect with real-time property changes.
virtual void | release ()=0
Releases this EffectPackageActor and all associated children effects.
virtual const char * | getName () const =0
A convenient helper method to return the name of the asset used to to create this actor.
virtual float | getDuration () const =0
returns the duration of the effect; accounting for maximum duration of each sub-effect. A duration of 'zero' means it is an infinite lifetime effect.
virtual float | getCurrentLife () const =0
Returns the current lifetime of the particle.
virtual void | setPreferredRenderVolume (RenderVolume *volume)=0
Sets the preferred render volume for emitters in this effect package.
virtual const char * | hasVolumeRenderMaterial (uint32_t &index) const =0
Returns true if this effect package contains a turbulence effect that specifies a volume-render material; if so then the application may want to set up volume rendering.
virtual void | setApexEmitterValidateCallback (EmitterActor::EmitterValidateCallback *callback)=0
Sets the emitter validation callback for any newly created emitter actors.

Detailed Description

Defines the EffectPackageActor API which is instantiated from an EffectPackageAsset.

Member Function Documentation

virtual void nvidia::apex::EffectPackageActor::fadeIn ( float fadetime ) [pure virtual]

Fade in the EffectPackageActor over a period of time. This method will cause the associated effects to be faded in over a period of time. It will begin the linear interpolation fade process relative to the current fade time. Meaning if you had previously specified a fadeOut duration of 1 second but then execute a fadeIn just a 1/2 second later, will will begin fading in from a 50% level; not zero.

Parameters:
[in] fadetime : The duration to fade this effect in, in seconds
virtual void nvidia::apex::EffectPackageActor::fadeOut ( float fadetime ) [pure virtual]

Fade out the EffectPackageActor over a period of time. This method will cause the actors within the EffectPackage to be 'faded out' over a period of time. The EffectPackageAsset will define how this fadeOut operation is to be applied. Some actors may simply be turned off over this duration while others are modulated in some way. For example, by default, emitter actors will have their emitter rate reduced over this duration so they do not appear to immediately cut off.

Parameters:
[in] fadetime : The duration to fade out the associated effects in seconds
virtual uint32_t nvidia::apex::EffectPackageActor::getActiveParticleCount ( ) const [pure virtual]

A helper method to return the active number of particles being simulated by all related effects in this EffectPackageActor.

Returns:
Returns the number of particles active relative to this EffectPackageActor
virtual Actor* nvidia::apex::EffectPackageActor::getEffectActor ( uint32_t effectIndex ) const [pure virtual]

Returns the base Actor pointer for this effect. Use this method if you need direct access to the base Actor pointer relative to this effect. You must use 'getEffectType' to know what type of actor this is referring to before you cast it to either an emitter, or heat source, or turbulence actor, etc. It is important to note that the application cannot cache this pointer as it may be deleted in subsequent frames due to level of detail calculations or timing values such as fade out operations.

Parameters:
[in] effectIndex : The effect number to refer to; must be less than the result of getEffectCount
Returns:
Returns the Actor pointer for this effect. This may be NULL if that effect is not currently active.
virtual const char* nvidia::apex::EffectPackageActor::getEffectName ( uint32_t effectIndex ) const [pure virtual]

Returns the name of the effect at this index.

Parameters:
[in] effectIndex : The effect number to refer to; must be less than the result of getEffectCount
virtual bool nvidia::apex::EffectPackageActor::getEffectPose | ( | uint32_t | effectIndex,
 |  | PxTransform & | pose,
 |  | bool | worldSpace
 | ) |  | [pure virtual]

Returns the pose of this sub-effect; returns as a bool the active state of this effect.

Parameters:
[in] | effectIndex | : The effect number to refer to; must be less than the result of getEffectCount
[pose] | : Contains the pose requested
[worldSpace] | : Whether to return the pose in world-space or in parent-relative space.
virtual PxRigidDynamic* nvidia::apex::EffectPackageActor::getEffectRigidDynamic ( uint32_t effectIndex ) const [pure virtual]

Returns the base PxRigidDynamic actor pointer for this effect. Use this method if you need direct access to the base PxRigidDynamic actor pointer relative to this effect.

Parameters:
[in] effectIndex : The effect number to refer to; must be less than the result of getEffectCount, must be a rigid dynamic effect
Returns:
Returns the PxRigidDynamic pointer for this effect. This may be NULL if that effect is not currently active.
virtual EffectType nvidia::apex::EffectPackageActor::getEffectType ( uint32_t effectIndex ) const [pure virtual]

Returns the type of effect at this index location.

Parameters:
[in] effectIndex : The effect number to refer to; must be less than the result of getEffectCount
virtual bool nvidia::apex::EffectPackageActor::isAlive ( void ) const [pure virtual]

Returns true if any portion of the effect is still considered 'alive' based on LOD and duration settings.

virtual bool nvidia::apex::EffectPackageActor::isEffectEnabled ( uint32_t effectIndex ) const [pure virtual]

Returns true if this sub-effect is currently enabled.

Parameters:
[in] effectIndex : The effect number to refer to; must be less than the result of getEffectCount
virtual bool nvidia::apex::EffectPackageActor::isStillEmitting ( ) const [pure virtual]

This helper method reports if any emitters within this EffectPackageActor are still actively emitting particles.

This method allows the application to determine whether or not any emitters are actively running relative to this actor. Typically this would be used to defer deleting an effect while it is still active.

Returns:
Returns true if any emitters in the actor are still active.
virtual void nvidia::apex::EffectPackageActor::setCurrentScale ( float scale ) [pure virtual]

Sets the over all effect scale, this is a uniform scaling factor.

Parameters:
[in] scale : The uniform scale to apply to all effects in this effect package
virtual bool nvidia::apex::EffectPackageActor::setEffectEnabled | ( | uint32_t | effectIndex,
 |  | bool | state
 | ) |  | [pure virtual]

Sets the enabled state of this sub-effect.

Parameters:
[in] | effectIndex | : The effect number to refer to; must be less than the result of getEffectCount
[in] | state | : Whether the effect should be enabled or not.
virtual bool nvidia::apex::EffectPackageActor::setEffectPose | ( | uint32_t | effectIndex,
 |  | const PxTransform & | pose,
 |  | bool | worldSpace
 | ) |  | [pure virtual]

Sets the pose of this sub-effect; returns as a bool the active state of this effect.

Parameters:
[in] | effectIndex | : The effect number to refer to; must be less than the result of getEffectCount
[pose] | : Contains the pose to be set
[worldSpace] | : Whether to return the pose in world-space or in parent-relative space.
virtual void nvidia::apex::EffectPackageActor::setEmitterState ( bool state ) [pure virtual]

Forces the state of all emitters associated with this effect package to be on or off. This method allows the application to manually force all emitters to be active or inactive based on an explicit call.

Parameters:
[state] : Determines whether to set all emitters on or off
virtual void nvidia::apex::EffectPackageActor::setEnabled ( bool state ) [pure virtual]

Allows the application to manually enable this EffectPackageActor.

This method is used by the application to manually force the EffectPackageActor to be enabled. This is generally used based on some kind of game logic where the EffectPackageActor has been pre-allocated and placed into the world but is initially inactive until some event occurs.

Parameters:
[state] Set the current enabled state to true or false
virtual void nvidia::apex::EffectPackageActor::setPose ( const PxTransform & pose ) [pure virtual]

Sets the root pose for this EffectPackageActor It's important to note that child-relative poses for each sub-component in an EffectPackageActor are authored in the ParticleEffectTool.

Parameters:
[pose] : Sets the current root pose for this EffectPackageActor
The documentation for this class was generated from the following file:
  • EffectPackageActor.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EffectPackageActor
nvidia::apex::EffectPackageActor Member List
This is the complete list of members for nvidia::apex::EffectPackageActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
fadeIn(float fadetime)=0 | nvidia::apex::EffectPackageActor | [pure virtual]
fadeOut(float fadetime)=0 | nvidia::apex::EffectPackageActor | [pure virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getActiveParticleCount() const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
getCurrentLife() const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
getDuration() const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
getEffectActor(uint32_t effectIndex) const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
getEffectCount() const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
getEffectName(uint32_t effectIndex) const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
getEffectPose(uint32_t effectIndex, PxTransform &pose, bool worldSpace)=0 | nvidia::apex::EffectPackageActor | [pure virtual]
getEffectRigidDynamic(uint32_t effectIndex) const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
getEffectType(uint32_t effectIndex) const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
getEnabled() const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getName() const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getPose() const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
hasVolumeRenderMaterial(uint32_t &index) const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
isAlive(void) const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
isEffectEnabled(uint32_t effectIndex) const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
isStillEmitting() const =0 | nvidia::apex::EffectPackageActor | [pure virtual]
refresh()=0 | nvidia::apex::EffectPackageActor | [pure virtual]
release()=0 | nvidia::apex::EffectPackageActor | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setApexEmitterValidateCallback(EmitterActor::EmitterValidateCallback *callback)=0 | nvidia::apex::EffectPackageActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::EffectPackageActor | [pure virtual]
setEffectEnabled(uint32_t effectIndex, bool state)=0 | nvidia::apex::EffectPackageActor | [pure virtual]
setEffectPose(uint32_t effectIndex, const PxTransform &pose, bool worldSpace)=0 | nvidia::apex::EffectPackageActor | [pure virtual]
setEmitterState(bool state)=0 | nvidia::apex::EffectPackageActor | [pure virtual]
setEnabled(bool state)=0 | nvidia::apex::EffectPackageActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setPose(const PxTransform &pose)=0 | nvidia::apex::EffectPackageActor | [pure virtual]
setPreferredRenderVolume(RenderVolume *volume)=0 | nvidia::apex::EffectPackageActor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::EffectPackageAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EffectPackageAsset
Public Member Functions
nvidia::apex::EffectPackageAsset Class Reference

Describes an EffectPackageAsset; a collection of particle related effects (emitters, field samplers, etc.) More...

#include <EffectPackageAsset.h>

Inheritance diagram for nvidia::apex::EffectPackageAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual float | getDuration () const =0
returns the duration of the effect; accounting for maximum duration of each sub-effect. A duration of 'zero' means it is an infinite lifetime effect.
virtual bool | useUniqueRenderVolume () const =0
This method returns true if the authored asset has the 'hint' set to indicate the actors should be created with a unique render volume.

Detailed Description

Describes an EffectPackageAsset; a collection of particle related effects (emitters, field samplers, etc.)

The documentation for this class was generated from the following file:
  • EffectPackageAsset.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EffectPackageAsset
nvidia::apex::EffectPackageAsset Member List
This is the complete list of members for nvidia::apex::EffectPackageAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDuration() const =0 | nvidia::apex::EffectPackageAsset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
useUniqueRenderVolume() const =0 | nvidia::apex::EffectPackageAsset | [pure virtual]
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~EffectPackageAsset() (defined in nvidia::apex::EffectPackageAsset) | nvidia::apex::EffectPackageAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::EffectPackageAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EffectPackageAssetAuthoring
nvidia::apex::EffectPackageAssetAuthoring Class Reference

Describes an EffectPackageAssetAuthoring class; not currently used. The ParticleEffectTool is used to author EffectPackageAssets. More...

#include <EffectPackageAsset.h>

Inheritance diagram for nvidia::apex::EffectPackageAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

Describes an EffectPackageAssetAuthoring class; not currently used. The ParticleEffectTool is used to author EffectPackageAssets.

The documentation for this class was generated from the following file:
  • EffectPackageAsset.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EffectPackageAssetAuthoring
nvidia::apex::EffectPackageAssetAuthoring Member List
This is the complete list of members for nvidia::apex::EffectPackageAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
~EffectPackageAssetAuthoring() (defined in nvidia::apex::EffectPackageAssetAuthoring) | nvidia::apex::EffectPackageAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::EmitterActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterActor
Classes | Public Member Functions
nvidia::apex::EmitterActor Class Reference

Apex emitter actor class. Emits particles within a given shape. More...

#include <EmitterActor.h>

Inheritance diagram for nvidia::apex::EmitterActor:
nvidia::apex::Actor nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Classes

class | EmitterValidateCallback

Public Member Functions

virtual EmitterAsset * | getEmitterAsset () const =0
Returns the asset the instance has been created from.
virtual EmitterGeomExplicit * | isExplicitGeom ()=0
Returns the explicit geometry for THIS ACTOR only.
virtual PxMat44 | getGlobalPose () const =0
Gets the global pose.
virtual void | setCurrentPose (const PxTransform &pose)=0
Sets the curent pose of the emitter.
virtual void | setCurrentPosition (const PxVec3 &pos)=0
Sets the curent position of the emitter.
virtual void | setAttachActor (PxActor *)=0
PhysX SDK 3.X. Attaches the emitter to an actor.
virtual void | setAttachRelativePose (const PxTransform &pose)=0
sets the relative pose of the emitter in the space of the actor to which it is attached
virtual const PxActor * | getAttachActor () const =0
PhysX SDK 3.X. Retrieves the actor, to which the emitter is attached. NULL is returned for an unattached emitter.
virtual const PxMat44 | getAttachRelativePose () const =0
Retrieves the relative pose of the emitter in the space of the actor to which it is attached.
virtual float | getObjectRadius () const =0
Retrieves the particle radius.
virtual void | setOverlapTestCollisionGroups (uint32_t)=0
Sets collision groups used to reject particles that overlap the geometry.
virtual void | startEmit (bool persistent=true)=0
start emitting particles
virtual void | stopEmit ()=0
Stop emitting particles.
virtual bool | isEmitting () const =0
Returns true if the emitter is emitting particles.
virtual const EmitterLodParamDesc & | getLodParamDesc () const =0
Gets LOD settings.
virtual void | setLodParamDesc (const EmitterLodParamDesc &)=0
Sets LOD settings.
virtual void | setDensity (const float &)=0
Sets the range from which the density of particles within the volume is randomly chosen.
virtual void | setRate (const float &)=0
Sets the range from which the emission rate is randomly chosen.
virtual void | setVelocityLow (const PxVec3 &)=0
Sets the range from which the velocity of a particle is randomly chosen.
virtual void | setVelocityHigh (const PxVec3 &)=0
Sets the range from which the velocity of a particle is randomly chosen.
virtual void | setLifetimeLow (const float &)=0
Sets the range from which the lifetime of a particle is randomly chosen.
virtual void | setLifetimeHigh (const float &)=0
Sets the range from which the lifetime of a particle is randomly chosen.
virtual void | emitAssetParticles (bool enable)=0
Sets whether or not authored asset particles are emitted.
virtual bool | getEmitAssetParticles () const =0
Gets whether or not authored asset particles are emitted.
virtual void | setPreferredRenderVolume (RenderVolume *volume)=0
Emitted particles are injected to specified render volume on initial frame.
virtual void | getRate (float &) const =0
Gets the range from which the emission rate is randomly chosen.
virtual uint32_t | getSimParticlesCount () const =0
Returns the number of particles in simulation.
virtual uint32_t | getActiveParticleCount () const =0
Returns the number of particles still alive.
virtual void | setDensityGridPosition (const PxVec3 &pos)=0
Sets the origin of the density grid used by this emitter. Important, this density grid may be shared with lots of other emitters as well, it is based on the underlying IOS.
virtual void | setApexEmitterValidateCallback (EmitterValidateCallback *callback)=0
Sets the ApexEmitterPosition validation callback interface.
virtual PX_DEPRECATED void | setObjectScale (float scale)=0
Sets the uniform overall object scale.
virtual PX_DEPRECATED float | getObjectScale (void) const =0
Retrieves the uniform overall object scale.
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.

Detailed Description

Apex emitter actor class. Emits particles within a given shape.

Member Function Documentation

virtual void nvidia::apex::EmitterActor::setAttachActor ( PxActor * ) [pure virtual]

PhysX SDK 3.X. Attaches the emitter to an actor.

PxActor pointer can be NULL to detach existing actor

virtual void nvidia::apex::EmitterActor::setDensity ( const float & ) [pure virtual]

Sets the range from which the density of particles within the volume is randomly chosen.

Override authored scalable parameters, if necessary

virtual void nvidia::apex::EmitterActor::setPreferredRenderVolume ( RenderVolume * volume ) [pure virtual]

Emitted particles are injected to specified render volume on initial frame.

This will work only if you have one renderVolume for each emitter. Set to NULL to clear the preferred volume.

virtual void nvidia::apex::EmitterActor::startEmit ( bool persistent = true ) [pure virtual]

start emitting particles

If persistent is true, the emitter will emit every frame until stopEmit() is called.

The documentation for this class was generated from the following file:
  • EmitterActor.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterActor
nvidia::apex::EmitterActor Member List
This is the complete list of members for nvidia::apex::EmitterActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
emitAssetParticles(bool enable)=0 | nvidia::apex::EmitterActor | [pure virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getActiveParticleCount() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getAttachActor() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getAttachRelativePose() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::EmitterActor | [pure virtual]
getEmitAssetParticles() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getEmitterAsset() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getGlobalPose() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getLodParamDesc() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getObjectRadius() const =0 | nvidia::apex::EmitterActor | [pure virtual]
getObjectScale(void) const =0 | nvidia::apex::EmitterActor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getRate(float &) const =0 | nvidia::apex::EmitterActor | [pure virtual]
getSimParticlesCount() const =0 | nvidia::apex::EmitterActor | [pure virtual]
isEmitting() const =0 | nvidia::apex::EmitterActor | [pure virtual]
isExplicitGeom()=0 | nvidia::apex::EmitterActor | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setApexEmitterValidateCallback(EmitterValidateCallback *callback)=0 | nvidia::apex::EmitterActor | [pure virtual]
setAttachActor(PxActor *)=0 | nvidia::apex::EmitterActor | [pure virtual]
setAttachRelativePose(const PxTransform &pose)=0 | nvidia::apex::EmitterActor | [pure virtual]
setCurrentPose(const PxTransform &pose)=0 | nvidia::apex::EmitterActor | [pure virtual]
setCurrentPosition(const PxVec3 &pos)=0 | nvidia::apex::EmitterActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::EmitterActor | [pure virtual]
setDensity(const float &)=0 | nvidia::apex::EmitterActor | [pure virtual]
setDensityGridPosition(const PxVec3 &pos)=0 | nvidia::apex::EmitterActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setLifetimeHigh(const float &)=0 | nvidia::apex::EmitterActor | [pure virtual]
setLifetimeLow(const float &)=0 | nvidia::apex::EmitterActor | [pure virtual]
setLodParamDesc(const EmitterLodParamDesc &)=0 | nvidia::apex::EmitterActor | [pure virtual]
setObjectScale(float scale)=0 | nvidia::apex::EmitterActor | [pure virtual]
setOverlapTestCollisionGroups(uint32_t)=0 | nvidia::apex::EmitterActor | [pure virtual]
setPreferredRenderVolume(RenderVolume *volume)=0 | nvidia::apex::EmitterActor | [pure virtual]
setRate(const float &)=0 | nvidia::apex::EmitterActor | [pure virtual]
setVelocityHigh(const PxVec3 &)=0 | nvidia::apex::EmitterActor | [pure virtual]
setVelocityLow(const PxVec3 &)=0 | nvidia::apex::EmitterActor | [pure virtual]
startEmit(bool persistent=true)=0 | nvidia::apex::EmitterActor | [pure virtual]
stopEmit()=0 | nvidia::apex::EmitterActor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~EmitterActor() (defined in nvidia::apex::EmitterActor) | nvidia::apex::EmitterActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterActor::EmitterValidateCallback Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterActor
  • EmitterValidateCallback
Public Member Functions
nvidia::apex::EmitterActor::EmitterValidateCallback Class Reference

#include <EmitterActor.h>

List of all members.

Public Member Functions

virtual bool validateEmitterPosition (const PxVec3 &emitterOrigin, PxVec3 &position)=0
This application callback is used to verify an emitted particle position.

Detailed Description

This is an optional user validation callback interface. If the application wants to confirm/verify all emitted particles they can provide this callback interface by using the setApexEmitterValidateCallback method.

Member Function Documentation

virtual bool nvidia::apex::EmitterActor::EmitterValidateCallback::validateEmitterPosition | ( | const PxVec3 & | emitterOrigin,
 |  | PxVec3 & | position
 | ) |  | [pure virtual]

This application callback is used to verify an emitted particle position.

If the user returns false, then the particle will not be emitted. If the user returns true if will be emitted but using the position value which is passed by reference. The application can choose to leave the emitter position alone, or modify it to a new location. All locations are in world space. For convenience to the application the world space emitter position is provided.

The documentation for this class was generated from the following file:
  • EmitterActor.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterActor
  • EmitterValidateCallback
nvidia::apex::EmitterActor::EmitterValidateCallback Member List
This is the complete list of members for nvidia::apex::EmitterActor::EmitterValidateCallback, including all inherited members.
validateEmitterPosition(const PxVec3 &emitterOrigin, PxVec3 &position)=0 nvidia::apex::EmitterActor::EmitterValidateCallback [pure virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterAsset
Public Member Functions
nvidia::apex::EmitterAsset Class Reference

APEX Emitter asset. Emits particles within some shape. More...

#include <EmitterAsset.h>

Inheritance diagram for nvidia::apex::EmitterAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual EmitterGeomExplicit * | isExplicitGeom ()=0
Returns the explicit geometry for the all actors based on this asset if the asset is explicit, NULL otherwise.
virtual const EmitterGeom * | getGeom () const =0
Returns the geometry used for the all actors based on this asset.
virtual const char * | getInstancedObjectEffectsAssetName (void) const =0
Gets IOFX asset name that is used to visualize partices of this emitter.
virtual const char * | getInstancedObjectSimulatorAssetName (void) const =0
Gets IOS asset name that is used to simulate partices of this emitter.
virtual const char * | getInstancedObjectSimulatorTypeName (void) const =0
Gets IOS asset class name that is used to simulate partices of this emitter.
virtual const float & | getDensity () const =0
Gets the range used to choose the density of particles.
virtual const float & | getRate () const =0
Gets the range used to choose the emission rate.
virtual const PxVec3 & | getVelocityLow () const =0
Gets the range used to choose the velocity of particles.
virtual const PxVec3 & | getVelocityHigh () const =0
Gets the range used to choose the velocity of particles.
virtual const float & | getLifetimeLow () const =0
Gets the range used to choose the lifetime of particles.
virtual const float & | getLifetimeHigh () const =0
Gets the range used to choose the lifetime of particles.
virtual uint32_t | getMaxSamples () const =0
For an explicit emitter, Max Samples is ignored. For shaped emitters, it is the maximum number of objects spawned in a step.
virtual float | getEmitDuration () const =0
Gets the emitter duration in seconds.
virtual const EmitterLodParamDesc & | getLodParamDesc () const =0
Gets LOD settings for this asset.

Detailed Description

APEX Emitter asset. Emits particles within some shape.

Member Function Documentation

virtual float nvidia::apex::EmitterAsset::getEmitDuration ( ) const [pure virtual]

Gets the emitter duration in seconds.

Note:
If EmitterActor::startEmit() is called with persistent=true, then this duration is ignored.
The documentation for this class was generated from the following file:
  • EmitterAsset.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterAsset
nvidia::apex::EmitterAsset Member List
This is the complete list of members for nvidia::apex::EmitterAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDensity() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getEmitDuration() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getGeom() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getInstancedObjectEffectsAssetName(void) const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getInstancedObjectSimulatorAssetName(void) const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getInstancedObjectSimulatorTypeName(void) const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getLifetimeHigh() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getLifetimeLow() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getLodParamDesc() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getMaxSamples() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
getRate() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getVelocityHigh() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
getVelocityLow() const =0 | nvidia::apex::EmitterAsset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isExplicitGeom()=0 | nvidia::apex::EmitterAsset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~EmitterAsset() (defined in nvidia::apex::EmitterAsset) | nvidia::apex::EmitterAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterAssetAuthoring
nvidia::apex::EmitterAssetAuthoring Class Reference

APEX Emitter Asset Authoring. Used to create APEX Emitter assets. More...

#include <EmitterAsset.h>

Inheritance diagram for nvidia::apex::EmitterAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

APEX Emitter Asset Authoring. Used to create APEX Emitter assets.

The documentation for this class was generated from the following file:
  • EmitterAsset.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterAssetAuthoring
nvidia::apex::EmitterAssetAuthoring Member List
This is the complete list of members for nvidia::apex::EmitterAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
~EmitterAssetAuthoring() (defined in nvidia::apex::EmitterAssetAuthoring) | nvidia::apex::EmitterAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterGeom Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeom
Public Member Functions
nvidia::apex::EmitterGeom Class Reference

Base class for all emitter shapes. More...

#include <EmitterGeoms.h>

Inheritance diagram for nvidia::apex::EmitterGeom:
nvidia::apex::EmitterGeomBox nvidia::apex::EmitterGeomCylinder nvidia::apex::EmitterGeomExplicit nvidia::apex::EmitterGeomSphere nvidia::apex::EmitterGeomSphereShell

List of all members.

Public Member Functions

virtual void | setEmitterType (EmitterType::Enum)=0
Sets the type of the emitter.
virtual EmitterType::Enum | getEmitterType () const =0
Gets the type of the emitter.
virtual const EmitterGeomBox * | isBoxGeom () const
If it is a box, cast to box class, return NULL otherwise.
virtual const EmitterGeomSphere * | isSphereGeom () const
If it is a sphere, cast to sphere class, return NULL otherwise.
virtual const
EmitterGeomSphereShell * 		isSphereShellGeom () const
If it is a sphere shell, cast to sphere shell class, return NULL otherwise.
virtual const EmitterGeomCylinder * | isCylinderGeom () const
If it is a cylinder shell, cast to cylinder class, return NULL otherwise.
virtual const EmitterGeomExplicit * | isExplicitGeom () const
If it is an explicit geom, cast to explicit geom class, return NULL otherwise.

Detailed Description

Base class for all emitter shapes.

The documentation for this class was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeom
nvidia::apex::EmitterGeom Member List
This is the complete list of members for nvidia::apex::EmitterGeom, including all inherited members.
getEmitterType() const =0 | nvidia::apex::EmitterGeom | [pure virtual]
isBoxGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isCylinderGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isExplicitGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereShellGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
setEmitterType(EmitterType::Enum)=0 | nvidia::apex::EmitterGeom | [pure virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterGeomBox Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomBox
Public Member Functions
nvidia::apex::EmitterGeomBox Class Reference

Box shape for an emitter. More...

#include <EmitterGeoms.h>

Inheritance diagram for nvidia::apex::EmitterGeomBox:
nvidia::apex::EmitterGeom

List of all members.

Public Member Functions

virtual void | setExtents (const PxVec3 &extents)=0
Set box extents.
virtual PxVec3 | getExtents () const =0
Get box extents.

Detailed Description

Box shape for an emitter.

The documentation for this class was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomBox
nvidia::apex::EmitterGeomBox Member List
This is the complete list of members for nvidia::apex::EmitterGeomBox, including all inherited members.
getEmitterType() const =0 | nvidia::apex::EmitterGeom | [pure virtual]
getExtents() const =0 | nvidia::apex::EmitterGeomBox | [pure virtual]
isBoxGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isCylinderGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isExplicitGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereShellGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
setEmitterType(EmitterType::Enum)=0 | nvidia::apex::EmitterGeom | [pure virtual]
setExtents(const PxVec3 &extents)=0 | nvidia::apex::EmitterGeomBox | [pure virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterGeomCylinder Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomCylinder
Public Member Functions
nvidia::apex::EmitterGeomCylinder Class Reference

Cylindrical shape for an emitter. More...

#include <EmitterGeoms.h>

Inheritance diagram for nvidia::apex::EmitterGeomCylinder:
nvidia::apex::EmitterGeom

List of all members.

Public Member Functions

virtual void | setRadius (float radius)=0
Set cylinder radius.
virtual float | getRadius () const =0
Get cylinder radius.
virtual void | setHeight (float height)=0
Set cylinder height.
virtual float | getHeight () const =0
Get cylinder height.

Detailed Description

Cylindrical shape for an emitter.

The documentation for this class was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomCylinder
nvidia::apex::EmitterGeomCylinder Member List
This is the complete list of members for nvidia::apex::EmitterGeomCylinder, including all inherited members.
getEmitterType() const =0 | nvidia::apex::EmitterGeom | [pure virtual]
getHeight() const =0 | nvidia::apex::EmitterGeomCylinder | [pure virtual]
getRadius() const =0 | nvidia::apex::EmitterGeomCylinder | [pure virtual]
isBoxGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isCylinderGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isExplicitGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereShellGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
setEmitterType(EmitterType::Enum)=0 | nvidia::apex::EmitterGeom | [pure virtual]
setHeight(float height)=0 | nvidia::apex::EmitterGeomCylinder | [pure virtual]
setRadius(float radius)=0 | nvidia::apex::EmitterGeomCylinder | [pure virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterGeomExplicit Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
Classes | Public Member Functions
nvidia::apex::EmitterGeomExplicit Class Reference

Explicit geometry. Coordinates of each particle are given explicitly. More...

#include <EmitterGeoms.h>

Inheritance diagram for nvidia::apex::EmitterGeomExplicit:
nvidia::apex::EmitterGeom

List of all members.

Classes

struct | EllipsoidParams
Ellipsoid parameters. More...
struct | PointListData
Structure contains positions, velocities and user data for particles. More...
struct | PointParams
Point parameters. More...
struct | SphereParams
Sphere prameters. More...

Public Member Functions

virtual void | resetParticleList ()=0
Remove all shapes.
virtual void | addParticleList (uint32_t count, const PointParams *params, const PxVec3 *velocities=0)=0
Add particles to geometry to be emitted.
virtual void | addParticleList (uint32_t count, const PxVec3 *positions, const PxVec3 *velocities=0)=0
Add particles to geometry to be emitted.
virtual void | addParticleList (uint32_t count, const PointListData &data)=0
Add particles to geometry to be emitted.
virtual void | addSphereList (uint32_t count, const SphereParams *params, const PxVec3 *velocities=0)=0
Add spheres to geometry to be emitted.
virtual void | addEllipsoidList (uint32_t count, const EllipsoidParams *params, const PxVec3 *velocities=0)=0
Add ellipsoids to geometry to be emitted.
virtual void | getParticleList (const PointParams *&params, uint32_t &numPoints, const PxVec3 *&velocities, uint32_t &numVelocities) const =0
Access particles list.
virtual void | getSphereList (const SphereParams *&params, uint32_t &numSpheres, const PxVec3 *&velocities, uint32_t &numVelocities) const =0
Access spheres list.
virtual void | getEllipsoidList (const EllipsoidParams *&params, uint32_t &numEllipsoids, const PxVec3 *&velocities, uint32_t &numVelocities) const =0
Access ellipsoids list.
virtual uint32_t | getParticleCount () const =0
Get the number of points.
virtual PxVec3 | getParticlePos (uint32_t index) const =0
Get the position of point.
virtual uint32_t | getSphereCount () const =0
Get the number of spheres.
virtual PxVec3 | getSphereCenter (uint32_t index) const =0
Get the center of the sphere.
virtual float | getSphereRadius (uint32_t index) const =0
Get the radius of the sphere.
virtual uint32_t | getEllipsoidCount () const =0
Get the number of ellipsoids.
virtual PxVec3 | getEllipsoidCenter (uint32_t index) const =0
Get the center of the ellipsoid.
virtual float | getEllipsoidRadius (uint32_t index) const =0
Get the radius of the ellipsoid.
virtual PxVec3 | getEllipsoidNormal (uint32_t index) const =0
Get the normal of the ellipsoid.
virtual float | getEllipsoidPolarRadius (uint32_t index) const =0
Get the polar radius of the ellipsoid.
virtual float | getDistance () const =0
Get average distance between particles.

Detailed Description

Explicit geometry. Coordinates of each particle are given explicitly.

Member Function Documentation

virtual void nvidia::apex::EmitterGeomExplicit::addEllipsoidList | ( | uint32_t | count,
 |  | const EllipsoidParams * | params,
 |  | const PxVec3 * | velocities = 0
 | ) |  | [pure virtual]

Add ellipsoids to geometry to be emitted.

Parameters:
[in] | count | - number of ellipsoids being added by this call
[in] | params | - ellipsoids parameters
[in] | velocities | if NULL, the geometry's velocity list will be padded with zero velocities and the asset's velocityRange will be used for velocity
See also:
EmitterGeomExplicit::EellipsoidParams
virtual void nvidia::apex::EmitterGeomExplicit::addParticleList | ( | uint32_t | count,
 |  | const PointListData & | data
 | ) |  | [pure virtual]

Add particles to geometry to be emitted.

Parameters:
[in] | count | - number of particles being added by this call
[in] | data | - particles data
See also:
EmitterGeomExplicit::PointListData
virtual void nvidia::apex::EmitterGeomExplicit::addParticleList | ( | uint32_t | count,
 |  | const PointParams * | params,
 |  | const PxVec3 * | velocities = 0
 | ) |  | [pure virtual]

Add particles to geometry to be emitted.

Parameters:
[in] | count | - number of particles being added by this call
[in] | params | must be specified. When emitted, these relative positions are added to emitter actor position
[in] | velocities | if NULL, the geometry's velocity list will be padded with zero velocities and the asset's velocityRange will be used for velocity
virtual void nvidia::apex::EmitterGeomExplicit::addParticleList | ( | uint32_t | count,
 |  | const PxVec3 * | positions,
 |  | const PxVec3 * | velocities = 0
 | ) |  | [pure virtual]

Add particles to geometry to be emitted.

Parameters:
[in] | count | - number of particles being added by this call
[in] | positions | must be specified. When emitted, these relative positions are added to emitter actor position
[in] | velocities | if NULL, the geometry's velocity list will be padded with zero velocities and the asset's velocityRange will be used for velocity
virtual void nvidia::apex::EmitterGeomExplicit::addSphereList | ( | uint32_t | count,
 |  | const SphereParams * | params,
 |  | const PxVec3 * | velocities = 0
 | ) |  | [pure virtual]

Add spheres to geometry to be emitted.

Parameters:
[in] | count | - number of spheres being added by this call
[in] | params | - spheres parameters
[in] | velocities | if NULL, the geometry's velocity list will be padded with zero velocities and the asset's velocityRange will be used for velocity
See also:
EmitterGeomExplicit::SphereParams
virtual void nvidia::apex::EmitterGeomExplicit::getEllipsoidList | ( | const EllipsoidParams *& | params,
 |  | uint32_t & | numEllipsoids,
 |  | const PxVec3 *& | velocities,
 |  | uint32_t & | numVelocities
 | ) |  | const [pure virtual]

Access ellipsoids list.

Parameters:
[out] | params | - ellipsoids parameters
[out] | numEllipsoids | - number of ellipsoids in list
[out] | velocities | - ellipsoids velocities
[out] | numVelocities | - number of ellipsoids velocities in list
See also:
EmitterGeomExplicit::EllipsoidParams
virtual void nvidia::apex::EmitterGeomExplicit::getParticleList | ( | const PointParams *& | params,
 |  | uint32_t & | numPoints,
 |  | const PxVec3 *& | velocities,
 |  | uint32_t & | numVelocities
 | ) |  | const [pure virtual]

Access particles list.

Parameters:
[out] | params | - particles coordinates
[out] | numPoints | - number of particles in list
[out] | velocities | - particles velocities
[out] | numVelocities | - number of particles velocities in list
See also:
EmitterGeomExplicit::PointParams
virtual void nvidia::apex::EmitterGeomExplicit::getSphereList | ( | const SphereParams *& | params,
 |  | uint32_t & | numSpheres,
 |  | const PxVec3 *& | velocities,
 |  | uint32_t & | numVelocities
 | ) |  | const [pure virtual]

Access spheres list.

Parameters:
[out] | params | - spheres parameters
[out] | numSpheres | - number of spheres in list
[out] | velocities | - spheres velocities
[out] | numVelocities | - number of spheres velocities in list
See also:
EmitterGeomExplicit::SphereParams
The documentation for this class was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
nvidia::apex::EmitterGeomExplicit Member List
This is the complete list of members for nvidia::apex::EmitterGeomExplicit, including all inherited members.
addEllipsoidList(uint32_t count, const EllipsoidParams *params, const PxVec3 *velocities=0)=0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
addParticleList(uint32_t count, const PointParams *params, const PxVec3 *velocities=0)=0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
addParticleList(uint32_t count, const PxVec3 *positions, const PxVec3 *velocities=0)=0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
addParticleList(uint32_t count, const PointListData &data)=0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
addSphereList(uint32_t count, const SphereParams *params, const PxVec3 *velocities=0)=0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getDistance() const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEllipsoidCenter(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEllipsoidCount() const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEllipsoidList(const EllipsoidParams *&params, uint32_t &numEllipsoids, const PxVec3 *&velocities, uint32_t &numVelocities) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEllipsoidNormal(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEllipsoidPolarRadius(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEllipsoidRadius(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getEmitterType() const =0 | nvidia::apex::EmitterGeom | [pure virtual]
getParticleCount() const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getParticleList(const PointParams *&params, uint32_t &numPoints, const PxVec3 *&velocities, uint32_t &numVelocities) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getParticlePos(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getSphereCenter(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getSphereCount() const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getSphereList(const SphereParams *&params, uint32_t &numSpheres, const PxVec3 *&velocities, uint32_t &numVelocities) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
getSphereRadius(uint32_t index) const =0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
isBoxGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isCylinderGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isExplicitGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereShellGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
resetParticleList()=0 | nvidia::apex::EmitterGeomExplicit | [pure virtual]
setEmitterType(EmitterType::Enum)=0 | nvidia::apex::EmitterGeom | [pure virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterGeomSphere Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomSphere
Public Member Functions
nvidia::apex::EmitterGeomSphere Class Reference

Spherical shape for an emitter. More...

#include <EmitterGeoms.h>

Inheritance diagram for nvidia::apex::EmitterGeomSphere:
nvidia::apex::EmitterGeom

List of all members.

Public Member Functions

virtual void | setRadius (float radius)=0
Set sphere radius.
virtual float | getRadius () const =0
Get sphere radius.

Detailed Description

Spherical shape for an emitter.

The documentation for this class was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomSphere
nvidia::apex::EmitterGeomSphere Member List
This is the complete list of members for nvidia::apex::EmitterGeomSphere, including all inherited members.
getEmitterType() const =0 | nvidia::apex::EmitterGeom | [pure virtual]
getRadius() const =0 | nvidia::apex::EmitterGeomSphere | [pure virtual]
isBoxGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isCylinderGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isExplicitGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereShellGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
setEmitterType(EmitterType::Enum)=0 | nvidia::apex::EmitterGeom | [pure virtual]
setRadius(float radius)=0 | nvidia::apex::EmitterGeomSphere | [pure virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterGeomSphereShell Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomSphereShell
Public Member Functions
nvidia::apex::EmitterGeomSphereShell Class Reference

Sphere shell shape for an emitter. It's a shape formed by the difference of two cocentered spheres. More...

#include <EmitterGeoms.h>

Inheritance diagram for nvidia::apex::EmitterGeomSphereShell:
nvidia::apex::EmitterGeom

List of all members.

Public Member Functions

virtual void | setRadius (float radius)=0
Set sphere shell radius.
virtual float | getRadius () const =0
Get sphere shell radius.
virtual void | setShellThickness (float thickness)=0
Set sphere shell thickness.
virtual float | getShellThickness () const =0
Get sphere shell thickness.

Detailed Description

Sphere shell shape for an emitter. It's a shape formed by the difference of two cocentered spheres.

The documentation for this class was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomSphereShell
nvidia::apex::EmitterGeomSphereShell Member List
This is the complete list of members for nvidia::apex::EmitterGeomSphereShell, including all inherited members.
getEmitterType() const =0 | nvidia::apex::EmitterGeom | [pure virtual]
getRadius() const =0 | nvidia::apex::EmitterGeomSphereShell | [pure virtual]
getShellThickness() const =0 | nvidia::apex::EmitterGeomSphereShell | [pure virtual]
isBoxGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isCylinderGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isExplicitGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
isSphereShellGeom() const | nvidia::apex::EmitterGeom | [inline, virtual]
setEmitterType(EmitterType::Enum)=0 | nvidia::apex::EmitterGeom | [pure virtual]
setRadius(float radius)=0 | nvidia::apex::EmitterGeomSphereShell | [pure virtual]
setShellThickness(float thickness)=0 | nvidia::apex::EmitterGeomSphereShell | [pure virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterLodParamDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterLodParamDesc
Public Types | Public Member Functions | Public Attributes
nvidia::apex::EmitterLodParamDesc Class Reference

LOD parameters fro emitters. More...

#include <EmitterLodParamDesc.h>

Inheritance diagram for nvidia::apex::EmitterLodParamDesc:
nvidia::apex::ApexDesc

List of all members.

Public Types

enum ManifestVersions {
initial,
count,
current = count - 1
}
enum of manifest versions

Public Member Functions

PX_INLINE | EmitterLodParamDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
sets members to default values.
PX_INLINE bool | isValid () const
checks if this is a valid descriptor.

Public Attributes

float | maxDistance
Objects greater than this distance from the player will be culled more aggressively.
float | distanceWeight
Weight given to distance parameter in LOD function.
float | speedWeight
Weight given to velocity parameter in LOD function.
float | lifeWeight
Weight given to life remain parameter in LOD function.
float | separationWeight
Weight given to separation parameter in LOD function.
float | bias
Bias given to objects spawned by this emitter, relative to other emitters in the same IOS.

Detailed Description

LOD parameters fro emitters.

The documentation for this class was generated from the following file:
  • EmitterLodParamDesc.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterLodParamDesc
nvidia::apex::EmitterLodParamDesc Member List
This is the complete list of members for nvidia::apex::EmitterLodParamDesc, including all inherited members.
ApexDesc() | nvidia::apex::ApexDesc | [inline]
bias | nvidia::apex::EmitterLodParamDesc |
count enum value (defined in nvidia::apex::EmitterLodParamDesc) | nvidia::apex::EmitterLodParamDesc |
current enum value (defined in nvidia::apex::EmitterLodParamDesc) | nvidia::apex::EmitterLodParamDesc |
distanceWeight | nvidia::apex::EmitterLodParamDesc |
EmitterLodParamDesc() | nvidia::apex::EmitterLodParamDesc | [inline]
initial enum value (defined in nvidia::apex::EmitterLodParamDesc) | nvidia::apex::EmitterLodParamDesc |
isValid() const | nvidia::apex::EmitterLodParamDesc | [inline]
lifeWeight | nvidia::apex::EmitterLodParamDesc |
ManifestVersions enum name | nvidia::apex::EmitterLodParamDesc |
maxDistance | nvidia::apex::EmitterLodParamDesc |
separationWeight | nvidia::apex::EmitterLodParamDesc |
setToDefault() | nvidia::apex::EmitterLodParamDesc | [inline]
speedWeight | nvidia::apex::EmitterLodParamDesc |
userData | nvidia::apex::ApexDesc |
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterPreview
Public Member Functions
nvidia::apex::EmitterPreview Class Reference

#include <EmitterPreview.h>

Inheritance diagram for nvidia::apex::EmitterPreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void | drawEmitterPreview ()=0
Draws the emitter.
virtual void | setScale (float scale)=0
Sets the scaling factor of the renderable.

Detailed Description

Preview class for ApexEmitter. Used for preview rendeing.

The documentation for this class was generated from the following file:
  • EmitterPreview.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterPreview
nvidia::apex::EmitterPreview Member List
This is the complete list of members for nvidia::apex::EmitterPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
drawEmitterPreview()=0 | nvidia::apex::EmitterPreview | [pure virtual]
EmitterPreview() (defined in nvidia::apex::EmitterPreview) | nvidia::apex::EmitterPreview | [inline, protected]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
setScale(float scale)=0 | nvidia::apex::EmitterPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::ExplicitHierarchicalMesh Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitHierarchicalMesh
Classes | Public Types | Public Member Functions | Protected Member Functions
nvidia::apex::ExplicitHierarchicalMesh Class Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Classes

class | ConvexHull
class | Embedding

Public Types

enum Enum {
VisualizeMeshBSPOutsideRegions = (1 << 0),
VisualizeMeshBSPInsideRegions = (1 << 1),
VisualizeMeshBSPSingleRegion = (1 << 8),
VisualizeSliceBSPOutsideRegions = (1 << 16),
VisualizeSliceBSPInsideRegions = (1 << 17),
VisualizeSliceBSPSingleRegion = (1 << 24),
VisualizeMeshBSPAllRegions = VisualizeMeshBSPOutsideRegions | VisualizeMeshBSPInsideRegions
}

Public Member Functions

virtual void | clear (bool keepRoot=false)=0
virtual int32_t | maxDepth () const =0
virtual uint32_t | partCount () const =0
virtual uint32_t | chunkCount () const =0
virtual int32_t * | parentIndex (uint32_t chunkIndex)=0
virtual uint64_t | chunkUniqueID (uint32_t chunkIndex)=0
virtual int32_t * | partIndex (uint32_t chunkIndex)=0
virtual PxVec3 * | instancedPositionOffset (uint32_t chunkIndex)=0
virtual PxVec2 * | instancedUVOffset (uint32_t chunkIndex)=0
virtual uint32_t | meshTriangleCount (uint32_t partIndex) const =0
virtual ExplicitRenderTriangle * | meshTriangles (uint32_t partIndex)=0
virtual PxBounds3 | meshBounds (uint32_t partIndex) const =0
virtual PxBounds3 | chunkBounds (uint32_t chunkIndex) const =0
virtual uint32_t * | chunkFlags (uint32_t chunkIndex) const =0
virtual void | buildCollisionGeometryForPart (uint32_t partIndex, const CollisionVolumeDesc &desc)=0
virtual void | buildCollisionGeometryForRootChunkParts (const CollisionDesc &desc, bool aggregateRootChunkParentCollision=true)=0
virtual void | reduceHulls (const CollisionDesc &desc, bool inflated)=0
virtual uint32_t | convexHullCount (uint32_t partIndex) const =0
virtual const ConvexHull ** | convexHulls (uint32_t partIndex) const =0
virtual PxVec3 * | surfaceNormal (uint32_t partIndex)=0
virtual const
DisplacementMapVolume & 		displacementMapVolume () const =0
virtual uint32_t | submeshCount () const =0
virtual ExplicitSubmeshData * | submeshData (uint32_t submeshIndex)=0
virtual uint32_t | addSubmesh (const ExplicitSubmeshData &submeshData)=0
virtual uint32_t | getMaterialFrameCount () const =0
virtual nvidia::MaterialFrame | getMaterialFrame (uint32_t index) const =0
virtual void | setMaterialFrame (uint32_t index, const nvidia::MaterialFrame &materialFrame)=0
virtual uint32_t | addMaterialFrame ()=0
virtual void | serialize (PxFileBuf &stream, Embedding &embedding) const =0
virtual void | deserialize (PxFileBuf &stream, Embedding &embedding)=0
virtual void | set (const ExplicitHierarchicalMesh &mesh)=0
virtual void | calculateMeshBSP (uint32_t randomSeed, IProgressListener *progressListener=NULL, const uint32_t *microgridSize=NULL, BSPOpenMode::Enum meshMode=BSPOpenMode::Automatic)=0
virtual void | replaceInteriorSubmeshes (uint32_t partIndex, uint32_t frameCount, uint32_t *frameIndices, uint32_t submeshIndex)=0
virtual void | visualize (RenderDebugInterface &debugRender, uint32_t flags, uint32_t index=0) const =0
virtual void | release ()=0

Protected Member Functions

ExplicitHierarchicalMesh ()

Detailed Description

ExplicitHierarchicalMesh

An interface to a representation of a render mesh that is used for authoring.

The "hierarchical" nature of this mesh is represented by extra parent/child relations among the parts that will become the parts of an RenderMeshAsset.

Member Enumeration Documentation

enum nvidia::apex::ExplicitHierarchicalMesh::Enum

Used in the visualize method to determine what to draw.

Enumerator:
VisualizeMeshBSPOutsideRegions

Draws the convex hulls associated with the BSP regions marked "outside," if a BSP has been created for this object (see calculateMeshBSP()).

VisualizeMeshBSPInsideRegions

Draws the convex hulls associated with the BSP regions marked "inside," if a BSP has been created for this object (see calculateMeshBSP()).

VisualizeMeshBSPSingleRegion

Draws the convex hull associated with a single BSP regions, if a BSP has been created for this object (see calculateMeshBSP()). The region index must be passed into the visualize function if this flag is set.

VisualizeSliceBSPOutsideRegions

Currently unused

VisualizeSliceBSPInsideRegions

Currently unused

VisualizeSliceBSPSingleRegion

Currently unused

Constructor & Destructor Documentation

nvidia::apex::ExplicitHierarchicalMesh::ExplicitHierarchicalMesh ( ) [inline, protected]

Constructor and destructor are not public Use createExplicitHierarchicalMesh() to instantiate an ExplicitHierarchicalMesh and ExplicitHierarchicalMesh::release() to destroy it.

Member Function Documentation

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::addMaterialFrame ( ) [pure virtual]
See also:
ConvexHull::getMaterialFrameCount
virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::addSubmesh ( const ExplicitSubmeshData & submeshData ) [pure virtual]

Creates a submesh and adds it to the list of submeshes, and returns the index of the newly created submesh.

virtual void nvidia::apex::ExplicitHierarchicalMesh::buildCollisionGeometryForPart | ( | uint32_t | partIndex,
 |  | const CollisionVolumeDesc & | desc
 | ) |  | [pure virtual]

Build collision volumes for the part indexed by partIndex, using (See CollisionVolumeDesc.)

virtual void nvidia::apex::ExplicitHierarchicalMesh::buildCollisionGeometryForRootChunkParts | ( | const CollisionDesc & | desc,
 |  | bool | aggregateRootChunkParentCollision = true
 | ) |  | [pure virtual]

Build collision volumes for all parts referenced by chunks at the root depth.

If aggregateRootChunkParentCollision, then every chunk which is the parent of root chunks gets all of the collision hulls of its children. Otherwise, all root chunks have their collision volumes separately calculated.

virtual void nvidia::apex::ExplicitHierarchicalMesh::calculateMeshBSP | ( | uint32_t | randomSeed,
 |  | IProgressListener * | progressListener = NULL,
 |  | const uint32_t * | microgridSize = NULL,
 |  | BSPOpenMode::Enum | meshMode = BSPOpenMode::Automatic
 | ) |  | [pure virtual]

Creates an internal BSP representation of the mesh parts up to the root depth. This is used by authoring tools to perform CSG operations. If the user instantiates IProgressListener, they may pass it in to report progress of this operation. If microgridSize is not NULL, *microgridSize is used in the BSP calculation. Otherwise the default parameters are used. meshMode is used to determine if the mesh is open or closed. See NxMeshProcessingParameters::MeshMode

virtual PxBounds3 nvidia::apex::ExplicitHierarchicalMesh::chunkBounds ( uint32_t chunkIndex ) const [pure virtual]

The axis aligned bounding box of the triangles for the chunk index by chunkIndex.

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::chunkCount ( ) const [pure virtual]

The number of chunks in this mesh.

virtual uint32_t* nvidia::apex::ExplicitHierarchicalMesh::chunkFlags ( uint32_t chunkIndex ) const [pure virtual]

Flags describing attributes of the part indexed by partIndex. See DestructibleAsset::ChunkFlags

virtual uint64_t nvidia::apex::ExplicitHierarchicalMesh::chunkUniqueID ( uint32_t chunkIndex ) [pure virtual]

A runtime unique identifier for a chunk. During one execution of an application which contains the fracture tools, this chunk ID will be unique for the chunk.

virtual void nvidia::apex::ExplicitHierarchicalMesh::clear ( bool keepRoot = false ) [pure virtual]

"Resets" this object to its initial state, freeing all internal data. If keepRoot is true, then parts up to the root depth will not be cleared. (In this case, not all of the submesh data, etc. will be deleted.) The root depth is set when the ExplicitHierarchicalMesh is first created. Fracturing methods create pieces beyond the root depth.

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::convexHullCount ( uint32_t partIndex ) const [pure virtual]

The number of convex hulls for the given part.

virtual const ConvexHull** nvidia::apex::ExplicitHierarchicalMesh::convexHulls ( uint32_t partIndex ) const [pure virtual]

The convex hulls for the given part.

virtual void nvidia::apex::ExplicitHierarchicalMesh::deserialize | ( | PxFileBuf & | stream,
 |  | Embedding & | embedding
 | ) |  | [pure virtual]

Serialization. The user must instantiate Embedding in order to successfully serialize any embedded data.

virtual const DisplacementMapVolume& nvidia::apex::ExplicitHierarchicalMesh::displacementMapVolume ( ) const [pure virtual]

The displacement map volume for the mesh.

virtual nvidia::MaterialFrame nvidia::apex::ExplicitHierarchicalMesh::getMaterialFrame ( uint32_t index ) const [pure virtual]
See also:
ConvexHull::getMaterialFrameCount
virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::getMaterialFrameCount ( ) const [pure virtual]

If there are interior submeshes, then triangles belonging to those submesh will have materials applied to them with a using a coordinate frame. In the event that materials need to be re-applied (possibly at a different scale), it is convenient to store the material frames used. This function returns the array of material frames. The index extraDataIndex stored in each ExplicitRenderTriangle references this array.

virtual PxVec3* nvidia::apex::ExplicitHierarchicalMesh::instancedPositionOffset ( uint32_t chunkIndex ) [pure virtual]

If instanced, the part instance offset (translation).

virtual PxVec2* nvidia::apex::ExplicitHierarchicalMesh::instancedUVOffset ( uint32_t chunkIndex ) [pure virtual]

If instanced, the part instance offset (UV).

virtual int32_t nvidia::apex::ExplicitHierarchicalMesh::maxDepth ( ) const [pure virtual]

The maximum child depth in the hierarchy. Depth 0 is the base, depth 1 parts are children of depth 0, etc. If there are no parts, this function returns -1.

virtual PxBounds3 nvidia::apex::ExplicitHierarchicalMesh::meshBounds ( uint32_t partIndex ) const [pure virtual]

The axis aligned bounding box of the triangles for the part index by partIndex.

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::meshTriangleCount ( uint32_t partIndex ) const [pure virtual]

The number of triangles in the part indexed by partIndex. This includes all submeshes.

virtual ExplicitRenderTriangle* nvidia::apex::ExplicitHierarchicalMesh::meshTriangles ( uint32_t partIndex ) [pure virtual]

A pointer into the array of ExplicitRenderTriangles which form the mesh of the part indexed by partIndex.

virtual int32_t* nvidia::apex::ExplicitHierarchicalMesh::parentIndex ( uint32_t chunkIndex ) [pure virtual]

The parent index of the chunk indexed by chunkIndex. Depth 0 parts have no parents, and for those parts this function returns -1.

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::partCount ( ) const [pure virtual]

The number of parts in this mesh.

virtual int32_t* nvidia::apex::ExplicitHierarchicalMesh::partIndex ( uint32_t chunkIndex ) [pure virtual]

The geometric part index this chunk references

virtual void nvidia::apex::ExplicitHierarchicalMesh::reduceHulls | ( | const CollisionDesc & | desc,
 |  | bool | inflated
 | ) |  | [pure virtual]

Calls IConvexMesh::reduceHull on all part convex hulls. See IConvexMesh::reduceHull.

virtual void nvidia::apex::ExplicitHierarchicalMesh::release ( ) [pure virtual]

Releases all memory associated with this object and deletes itself.

virtual void nvidia::apex::ExplicitHierarchicalMesh::replaceInteriorSubmeshes | ( | uint32_t | partIndex,
 |  | uint32_t | frameCount,
 |  | uint32_t * | frameIndices,
 |  | uint32_t | submeshIndex
 | ) |  | [pure virtual]

Utility to replace the submesh on a set of interior triangles.

virtual void nvidia::apex::ExplicitHierarchicalMesh::serialize | ( | PxFileBuf & | stream,
 |  | Embedding & | embedding
 | ) |  | const [pure virtual]

Serialization. The user must instantiate Embedding in order to successfully serialize any embedded data.

virtual void nvidia::apex::ExplicitHierarchicalMesh::set ( const ExplicitHierarchicalMesh & mesh ) [pure virtual]

Copies the input mesh in to this object.

virtual void nvidia::apex::ExplicitHierarchicalMesh::setMaterialFrame | ( | uint32_t | index,
 |  | const nvidia::MaterialFrame & | materialFrame
 | ) |  | [pure virtual]
See also:
ConvexHull::getMaterialFrameCount
virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::submeshCount ( ) const [pure virtual]

The number of submeshes. The explicit mesh representation is just a list of ExplicitRenderTriangles for each part, and each ExplicitRenderTriangle has a submesh index. These indices will lie in a contiguous range from 0 to submeshCount()-1.

virtual ExplicitSubmeshData* nvidia::apex::ExplicitHierarchicalMesh::submeshData ( uint32_t submeshIndex ) [pure virtual]

The submeshData indexed by submeshIndex. See ExplicitSubmeshData.

virtual PxVec3* nvidia::apex::ExplicitHierarchicalMesh::surfaceNormal ( uint32_t partIndex ) [pure virtual]

The outward surface normal associated with the chunk mesh geometry.

virtual void nvidia::apex::ExplicitHierarchicalMesh::visualize | ( | RenderDebugInterface & | debugRender,
 |  | uint32_t | flags,
 |  | uint32_t | index = 0
 | ) |  | const [pure virtual]

Draws various components of this object to the debugRenderer, as defined by the flags (see the visualization Enum above). Some of the flags require an index be passed in as well.

The documentation for this class was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitHierarchicalMesh
nvidia::apex::ExplicitHierarchicalMesh Member List
This is the complete list of members for nvidia::apex::ExplicitHierarchicalMesh, including all inherited members.
addMaterialFrame()=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
addSubmesh(const ExplicitSubmeshData &submeshData)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
buildCollisionGeometryForPart(uint32_t partIndex, const CollisionVolumeDesc &desc)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
buildCollisionGeometryForRootChunkParts(const CollisionDesc &desc, bool aggregateRootChunkParentCollision=true)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
calculateMeshBSP(uint32_t randomSeed, IProgressListener *progressListener=NULL, const uint32_t *microgridSize=NULL, BSPOpenMode::Enum meshMode=BSPOpenMode::Automatic)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
chunkBounds(uint32_t chunkIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
chunkCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
chunkFlags(uint32_t chunkIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
chunkUniqueID(uint32_t chunkIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
clear(bool keepRoot=false)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
convexHullCount(uint32_t partIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
convexHulls(uint32_t partIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
deserialize(PxFileBuf &stream, Embedding &embedding)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
displacementMapVolume() const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
Enum enum name | nvidia::apex::ExplicitHierarchicalMesh |
ExplicitHierarchicalMesh() | nvidia::apex::ExplicitHierarchicalMesh | [inline, protected]
getMaterialFrame(uint32_t index) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
getMaterialFrameCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
instancedPositionOffset(uint32_t chunkIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
instancedUVOffset(uint32_t chunkIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
maxDepth() const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
meshBounds(uint32_t partIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
meshTriangleCount(uint32_t partIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
meshTriangles(uint32_t partIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
parentIndex(uint32_t chunkIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
partCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
partIndex(uint32_t chunkIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
reduceHulls(const CollisionDesc &desc, bool inflated)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
release()=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
replaceInteriorSubmeshes(uint32_t partIndex, uint32_t frameCount, uint32_t *frameIndices, uint32_t submeshIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
serialize(PxFileBuf &stream, Embedding &embedding) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
set(const ExplicitHierarchicalMesh &mesh)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
setMaterialFrame(uint32_t index, const nvidia::MaterialFrame &materialFrame)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
submeshCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
submeshData(uint32_t submeshIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
surfaceNormal(uint32_t partIndex)=0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
visualize(RenderDebugInterface &debugRender, uint32_t flags, uint32_t index=0) const =0 | nvidia::apex::ExplicitHierarchicalMesh | [pure virtual]
VisualizeMeshBSPAllRegions enum value (defined in nvidia::apex::ExplicitHierarchicalMesh) | nvidia::apex::ExplicitHierarchicalMesh |
VisualizeMeshBSPInsideRegions enum value | nvidia::apex::ExplicitHierarchicalMesh |
VisualizeMeshBSPOutsideRegions enum value | nvidia::apex::ExplicitHierarchicalMesh |
VisualizeMeshBSPSingleRegion enum value | nvidia::apex::ExplicitHierarchicalMesh |
VisualizeSliceBSPInsideRegions enum value | nvidia::apex::ExplicitHierarchicalMesh |
VisualizeSliceBSPOutsideRegions enum value | nvidia::apex::ExplicitHierarchicalMesh |
VisualizeSliceBSPSingleRegion enum value | nvidia::apex::ExplicitHierarchicalMesh |
~ExplicitHierarchicalMesh() (defined in nvidia::apex::ExplicitHierarchicalMesh) | nvidia::apex::ExplicitHierarchicalMesh | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ExplicitHierarchicalMesh::ConvexHull Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitHierarchicalMesh
  • ConvexHull
Public Member Functions
nvidia::apex::ExplicitHierarchicalMesh::ConvexHull Class Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

virtual void | buildFromPoints (const void *points, uint32_t numPoints, uint32_t pointStrideBytes)=0
virtual const PxBounds3 & | getBounds () const =0
virtual float | getVolume () const =0
virtual uint32_t | getVertexCount () const =0
virtual PxVec3 | getVertex (uint32_t vertexIndex) const =0
virtual uint32_t | getEdgeCount () const =0
virtual PxVec3 | getEdgeEndpoint (uint32_t edgeIndex, uint32_t whichEndpoint) const =0
virtual uint32_t | getPlaneCount () const =0
virtual PxPlane | getPlane (uint32_t planeIndex) const =0
virtual bool | rayCast (float &in, float &out, const PxVec3 &orig, const PxVec3 &dir, const PxTransform &localToWorldRT, const PxVec3 &scale, PxVec3 *normal=NULL) const =0
virtual bool | reduceHull (uint32_t maxVertexCount, uint32_t maxEdgeCount, uint32_t maxFaceCount, bool inflated)=0
virtual void | release ()=0

Detailed Description

Used to access the collision data for each mesh part

Member Function Documentation

virtual void nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::buildFromPoints | ( | const void * | points,
 |  | uint32_t | numPoints,
 |  | uint32_t | pointStrideBytes
 | ) |  | [pure virtual]

Builds the convex hull of the points given.

virtual const PxBounds3& nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getBounds ( ) const [pure virtual]

The hull's axis aligned bounding box.

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getEdgeCount ( ) const [pure virtual]

This is the number of edges in the convex hull.

virtual PxVec3 nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getEdgeEndpoint | ( | uint32_t | edgeIndex,
 |  | uint32_t | whichEndpoint
 | ) |  | const [pure virtual]

This is an edge endpoint indexed by edgeIndex, which must in the range [0, getEdgeCount()-1], and whichEndpoint, which must be 0 or 1.

virtual PxPlane nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getPlane ( uint32_t planeIndex ) const [pure virtual]

This is the plane indexed by planeIndex, which must in the range [0, getPlaneCount()-1].

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getPlaneCount ( ) const [pure virtual]

This is the number of planes which bound the convex hull.

virtual PxVec3 nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getVertex ( uint32_t vertexIndex ) const [pure virtual]

This is the vertex indexed by vertexIndex, which must in the range [0, getVertexCount()-1].

virtual uint32_t nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getVertexCount ( ) const [pure virtual]

This is the number of vertices in the convex hull.

virtual float nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::getVolume ( ) const [pure virtual]

The hull's volume.

virtual bool nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::rayCast | ( | float & | in,
 |  | float & | out,
 |  | const PxVec3 & | orig,
 |  | const PxVec3 & | dir,
 |  | const PxTransform & | localToWorldRT,
 |  | const PxVec3 & | scale,
 |  | PxVec3 * | normal = NULL
 | ) |  | const [pure virtual]

Perform a ray cast against the convex hull.

Parameters:
in | this MUST be set to the minimum 'time' that you wish to have reported for intersection. you may consider this an origin offset for the ray. On exit, if the hull is intersected, this value will contain the time of intersection, or its original value, which ever is larger.
out | this MUST be set to the maximum 'time' that you wish to have reported for intersection. you may consider this the endpoint of a line segment intersection. On exit, if the hull is intersected, this value will contain the time that the ray exits the hull, or its original value, which ever is smaller.
orig | describe the ray to intersect with the convex hull.
dir | describe the ray to intersect with the convex hull.
localToWorldRT | the rotation applied to the convex hull.
scale | the scale applied to the convex hull.
normal | if not NULL, *normal will contain the surface normal of the convex hull at the point of intersection (at the 'in' time). If the point on the ray at the 'in' time lies within the volume of the convex hull, then *normal will be set to (0,0,0).
Returns:
returns true if the line segment described by the user's supplied 'in' and 'out' parameters along the ray intersects the convex hull, false otherwise.
virtual bool nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::reduceHull | ( | uint32_t | maxVertexCount,
 |  | uint32_t | maxEdgeCount,
 |  | uint32_t | maxFaceCount,
 |  | bool | inflated
 | ) |  | [pure virtual]

Removes vertices from the hull until the bounds given in the function's parameters are met. If inflated = true, then the maximum counts given are compared with the cooked hull, which may have higher counts due to beveling.

Note:
a value of zero indicates no limit, effectively infinite.
Returns:
true if successful, i.e. the limits were met. False otherwise.
virtual void nvidia::apex::ExplicitHierarchicalMesh::ConvexHull::release ( ) [pure virtual]

Releases all memory associated with this object and deletes itself.

The documentation for this class was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitHierarchicalMesh
  • ConvexHull
nvidia::apex::ExplicitHierarchicalMesh::ConvexHull Member List
This is the complete list of members for nvidia::apex::ExplicitHierarchicalMesh::ConvexHull, including all inherited members.
buildFromPoints(const void *points, uint32_t numPoints, uint32_t pointStrideBytes)=0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
ConvexHull() (defined in nvidia::apex::ExplicitHierarchicalMesh::ConvexHull) | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [inline, protected]
getBounds() const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getEdgeCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getEdgeEndpoint(uint32_t edgeIndex, uint32_t whichEndpoint) const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getPlane(uint32_t planeIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getPlaneCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getVertex(uint32_t vertexIndex) const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getVertexCount() const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
getVolume() const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
rayCast(float &in, float &out, const PxVec3 &orig, const PxVec3 &dir, const PxTransform &localToWorldRT, const PxVec3 &scale, PxVec3 *normal=NULL) const =0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
reduceHull(uint32_t maxVertexCount, uint32_t maxEdgeCount, uint32_t maxFaceCount, bool inflated)=0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
release()=0 | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [pure virtual]
~ConvexHull() (defined in nvidia::apex::ExplicitHierarchicalMesh::ConvexHull) | nvidia::apex::ExplicitHierarchicalMesh::ConvexHull | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ExplicitHierarchicalMesh::Embedding Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitHierarchicalMesh
  • Embedding
Public Types | Public Member Functions
nvidia::apex::ExplicitHierarchicalMesh::Embedding Class Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Types

enum | DataType { MaterialLibrary }

Public Member Functions

virtual void | serialize (PxFileBuf &stream, Embedding::DataType type) const =0
virtual void | deserialize (PxFileBuf &stream, Embedding::DataType type, uint32_t version)=0

Detailed Description

Used in the serialize and deserialize methods, to embed extra data. The user must implement this class to serialize and deserialize the enumerated data type given.

Member Enumeration Documentation

enum nvidia::apex::ExplicitHierarchicalMesh::Embedding::DataType

Enum of data types

Member Function Documentation

virtual void nvidia::apex::ExplicitHierarchicalMesh::Embedding::deserialize | ( | PxFileBuf & | stream,
 |  | Embedding::DataType | type,
 |  | uint32_t | version
 | ) |  | [pure virtual]

Deserialize the enumerated data type

virtual void nvidia::apex::ExplicitHierarchicalMesh::Embedding::serialize | ( | PxFileBuf & | stream,
 |  | Embedding::DataType | type
 | ) |  | const [pure virtual]

Serialize the enumerated data type

The documentation for this class was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitHierarchicalMesh
  • Embedding
nvidia::apex::ExplicitHierarchicalMesh::Embedding Member List
This is the complete list of members for nvidia::apex::ExplicitHierarchicalMesh::Embedding, including all inherited members.
DataType enum name | nvidia::apex::ExplicitHierarchicalMesh::Embedding |
deserialize(PxFileBuf &stream, Embedding::DataType type, uint32_t version)=0 | nvidia::apex::ExplicitHierarchicalMesh::Embedding | [pure virtual]
MaterialLibrary enum value (defined in nvidia::apex::ExplicitHierarchicalMesh::Embedding) | nvidia::apex::ExplicitHierarchicalMesh::Embedding |
serialize(PxFileBuf &stream, Embedding::DataType type) const =0 | nvidia::apex::ExplicitHierarchicalMesh::Embedding | [pure virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::FieldSamplerWeightedCollisionFilterCallback Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FieldSamplerWeightedCollisionFilterCallback
Public Member Functions
nvidia::apex::FieldSamplerWeightedCollisionFilterCallback Class Reference

This is an optional callback interface for collision filtering between field samplers and other objects If this interface is not provided, then collision filtering happens normally through the default scene simulationfiltershader callback However, if this is provided, then the user can no only return true/false to indicate whether or not the two objects should interact but can also assign a weighted multiplier value to control how strongly the two objects should interact. More...

#include <ModuleFieldSampler.h>

List of all members.

Public Member Functions

virtual bool fieldSamplerWeightedCollisionFilter (const physx::PxFilterData &objectA, const physx::PxFilterData &objectB, float &multiplierValue)=0
This is an optional callback interface for collision filtering between field samplers and other objects If this interface is not provided, then collision filtering happens normally through the default scene simulationfiltershader callback However, if this is provided, then the user can no only return true/false to indicate whether or not the two objects should interact but can also assign a weighted multiplier value to control how strongly the two objects should interact.

Detailed Description

This is an optional callback interface for collision filtering between field samplers and other objects If this interface is not provided, then collision filtering happens normally through the default scene simulationfiltershader callback However, if this is provided, then the user can no only return true/false to indicate whether or not the two objects should interact but can also assign a weighted multiplier value to control how strongly the two objects should interact.

The documentation for this class was generated from the following file:
  • ModuleFieldSampler.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FieldSamplerWeightedCollisionFilterCallback
nvidia::apex::FieldSamplerWeightedCollisionFilterCallback Member List
This is the complete list of members for nvidia::apex::FieldSamplerWeightedCollisionFilterCallback, including all inherited members.
fieldSamplerWeightedCollisionFilter(const physx::PxFilterData &objectA, const physx::PxFilterData &objectB, float &multiplierValue)=0 nvidia::apex::FieldSamplerWeightedCollisionFilterCallback [pure virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::FlameEmitterActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FlameEmitterActor
Public Member Functions
nvidia::apex::FlameEmitterActor Class Reference

Flame Emitter Actor class. More...

#include <FlameEmitterActor.h>

Inheritance diagram for nvidia::apex::FlameEmitterActor:
nvidia::apex::Actor nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual FlameEmitterAsset * | getFlameEmitterAsset () const =0
Returns the asset the instance has been created from.
virtual void | setEnabled (bool enable)=0
enable/disable flame emitter
virtual bool | isEnabled () const =0
Returns true if flame emitter enabled.
virtual bool | intersectAgainstAABB (const PxBounds3 &) const =0
intersect the collision shape against a given AABB
virtual PxMat44 | getPose () const =0
get the global pose
virtual void | setPose (PxMat44 pose)=0
set the global pose
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.
virtual void | release ()=0
Release an object instance.

Detailed Description

Flame Emitter Actor class.

Member Function Documentation

virtual void nvidia::apex::FlameEmitterActor::release ( ) [pure virtual]

Release an object instance.

Calling this will unhook the class and delete it from memory. You should not keep any reference to this class instance after calling release

Implements nvidia::apex::ApexInterface.

The documentation for this class was generated from the following file:
  • FlameEmitterActor.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FlameEmitterActor
nvidia::apex::FlameEmitterActor Member List
This is the complete list of members for nvidia::apex::FlameEmitterActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::FlameEmitterActor | [pure virtual]
getFlameEmitterAsset() const =0 | nvidia::apex::FlameEmitterActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getPose() const =0 | nvidia::apex::FlameEmitterActor | [pure virtual]
intersectAgainstAABB(const PxBounds3 &) const =0 | nvidia::apex::FlameEmitterActor | [pure virtual]
isEnabled() const =0 | nvidia::apex::FlameEmitterActor | [pure virtual]
release()=0 | nvidia::apex::FlameEmitterActor | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::FlameEmitterActor | [pure virtual]
setEnabled(bool enable)=0 | nvidia::apex::FlameEmitterActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::FlameEmitterActor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~FlameEmitterActor() (defined in nvidia::apex::FlameEmitterActor) | nvidia::apex::FlameEmitterActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::FlameEmitterAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FlameEmitterAsset
nvidia::apex::FlameEmitterAsset Class Reference

Flame Emitter Asset class. More...

#include <FlameEmitterAsset.h>

Inheritance diagram for nvidia::apex::FlameEmitterAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

Flame Emitter Asset class.

The documentation for this class was generated from the following file:
  • FlameEmitterAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FlameEmitterAsset
nvidia::apex::FlameEmitterAsset Member List
This is the complete list of members for nvidia::apex::FlameEmitterAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~FlameEmitterAsset() (defined in nvidia::apex::FlameEmitterAsset) | nvidia::apex::FlameEmitterAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::FlameEmitterAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FlameEmitterAssetAuthoring
nvidia::apex::FlameEmitterAssetAuthoring Class Reference

Flame Emitter Asset Authoring class. More...

#include <FlameEmitterAsset.h>

Inheritance diagram for nvidia::apex::FlameEmitterAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

Flame Emitter Asset Authoring class.

The documentation for this class was generated from the following file:
  • FlameEmitterAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FlameEmitterAssetAuthoring
nvidia::apex::FlameEmitterAssetAuthoring Member List
This is the complete list of members for nvidia::apex::FlameEmitterAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
~FlameEmitterAssetAuthoring() (defined in nvidia::apex::FlameEmitterAssetAuthoring) | nvidia::apex::FlameEmitterAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::FlameEmitterPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FlameEmitterPreview
Public Member Functions
nvidia::apex::FlameEmitterPreview Class Reference

This class provides the asset preview for APEX Flame Emitter Assets. More...

#include <FlameEmitterPreview.h>

Inheritance diagram for nvidia::apex::FlameEmitterPreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void | drawFlameEmitterPreview ()=0
Draws the emitter.
virtual void | setScale (float scale)=0
Sets the scaling factor of the renderable.

Detailed Description

This class provides the asset preview for APEX Flame Emitter Assets.

The documentation for this class was generated from the following file:
  • FlameEmitterPreview.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FlameEmitterPreview
nvidia::apex::FlameEmitterPreview Member List
This is the complete list of members for nvidia::apex::FlameEmitterPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
drawFlameEmitterPreview()=0 | nvidia::apex::FlameEmitterPreview | [pure virtual]
FlameEmitterPreview() (defined in nvidia::apex::FlameEmitterPreview) | nvidia::apex::FlameEmitterPreview | [inline, protected]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
setScale(float scale)=0 | nvidia::apex::FlameEmitterPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::ForceFieldActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ForceFieldActor
Public Member Functions
nvidia::apex::ForceFieldActor Class Reference

ForceField Actor. More...

#include <ForceFieldActor.h>

Inheritance diagram for nvidia::apex::ForceFieldActor:
nvidia::apex::Actor nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual bool | isEnable ()=0
virtual bool | disable ()=0
virtual bool | enable ()=0
virtual PxMat44 | getPose () const =0
virtual void | setPose (const PxMat44 &pose)=0
virtual PX_DEPRECATED float | getScale () const =0
virtual PX_DEPRECATED void | setScale (float scale)=0
virtual PX_DEPRECATED float | getCurrentScale () const =0
virtual PX_DEPRECATED void | setCurrentScale (float scale)=0
virtual const char * | getName () const =0
virtual void | setName (const char *name)=0
virtual void | setStrength (const float strength)=0
virtual void | setLifetime (const float lifetime)=0
virtual PX_DEPRECATED void | setFalloffType (const char *type)=0
virtual PX_DEPRECATED void | setFalloffMultiplier (const float multiplier)=0
virtual ForceFieldAsset * | getForceFieldAsset () const =0

Detailed Description

ForceField Actor.

Member Function Documentation

virtual bool nvidia::apex::ForceFieldActor::disable ( ) [pure virtual]

Disable force field actor. Default status is enable. Can switch it freely. A disabled explosion actor still exists there, but has no effect to the scene.

virtual bool nvidia::apex::ForceFieldActor::enable ( ) [pure virtual]

Enable force field actor. Default status is enable. Can switch it freely. A disabled explosion actor still exists there, but has no effect to the scene.

virtual PX_DEPRECATED float nvidia::apex::ForceFieldActor::getCurrentScale ( ) const [pure virtual]

Gets the force field actor's scale.

virtual ForceFieldAsset* nvidia::apex::ForceFieldActor::getForceFieldAsset ( ) const [pure virtual]

Returns the asset the actor has been created from.

virtual const char* nvidia::apex::ForceFieldActor::getName ( ) const [pure virtual]

Retrieves the name string for the force field actor.

virtual PxMat44 nvidia::apex::ForceFieldActor::getPose ( ) const [pure virtual]

Gets location and orientation of the force field.

virtual PX_DEPRECATED float nvidia::apex::ForceFieldActor::getScale ( ) const [pure virtual]

Gets the force field actor's scale.

virtual bool nvidia::apex::ForceFieldActor::isEnable ( ) [pure virtual]

Return true if the force field actor is enabled.

virtual PX_DEPRECATED void nvidia::apex::ForceFieldActor::setCurrentScale ( float scale ) [pure virtual]

Sets the force field actor's scale. (0.0f, +inf)

virtual PX_DEPRECATED void nvidia::apex::ForceFieldActor::setFalloffMultiplier ( const float multiplier ) [pure virtual]

Set falloff multiplier for the force field actor. Only works for radial force field types.

virtual PX_DEPRECATED void nvidia::apex::ForceFieldActor::setFalloffType ( const char * type ) [pure virtual]

Set falloff type (linear, steep, scurve, custom, none) for the force field actor. Only works for radial force field types.

virtual void nvidia::apex::ForceFieldActor::setLifetime ( const float lifetime ) [pure virtual]

Set lifetime for the force field actor.

virtual void nvidia::apex::ForceFieldActor::setName ( const char * name ) [pure virtual]

Set a name string for the force field actor that can be retrieved with getName().

virtual void nvidia::apex::ForceFieldActor::setPose ( const PxMat44 & pose ) [pure virtual]

Sets location and orientation of the force field.

virtual PX_DEPRECATED void nvidia::apex::ForceFieldActor::setScale ( float scale ) [pure virtual]

Sets the force field actor's scale. (0.0f, +inf)

virtual void nvidia::apex::ForceFieldActor::setStrength ( const float strength ) [pure virtual]

Set strength for the force field actor.

The documentation for this class was generated from the following file:
  • ForceFieldActor.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ForceFieldActor
nvidia::apex::ForceFieldActor Member List
This is the complete list of members for nvidia::apex::ForceFieldActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
disable()=0 | nvidia::apex::ForceFieldActor | [pure virtual]
enable()=0 | nvidia::apex::ForceFieldActor | [pure virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getCurrentScale() const =0 | nvidia::apex::ForceFieldActor | [pure virtual]
getForceFieldAsset() const =0 | nvidia::apex::ForceFieldActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getName() const =0 | nvidia::apex::ForceFieldActor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getPose() const =0 | nvidia::apex::ForceFieldActor | [pure virtual]
getScale() const =0 | nvidia::apex::ForceFieldActor | [pure virtual]
isEnable()=0 | nvidia::apex::ForceFieldActor | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setFalloffMultiplier(const float multiplier)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setFalloffType(const char *type)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setLifetime(const float lifetime)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setName(const char *name)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setScale(float scale)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
setStrength(const float strength)=0 | nvidia::apex::ForceFieldActor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~ForceFieldActor() (defined in nvidia::apex::ForceFieldActor) | nvidia::apex::ForceFieldActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::ForceFieldAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ForceFieldAsset
Public Member Functions | Protected Member Functions
nvidia::apex::ForceFieldAsset Class Reference

ForceField Asset. More...

#include <ForceFieldAsset.h>

Inheritance diagram for nvidia::apex::ForceFieldAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual float | getDefaultScale () const =0
returns the default scale of the asset.
virtual void | releaseForceFieldActor (ForceFieldActor &)=0
release an actor created from this asset.

Protected Member Functions

virtual | ~ForceFieldAsset ()
force field asset default destructor.

Detailed Description

ForceField Asset.

The documentation for this class was generated from the following file:
  • ForceFieldAsset.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ForceFieldAsset
nvidia::apex::ForceFieldAsset Member List
This is the complete list of members for nvidia::apex::ForceFieldAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultScale() const =0 | nvidia::apex::ForceFieldAsset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseForceFieldActor(ForceFieldActor &)=0 | nvidia::apex::ForceFieldAsset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~ForceFieldAsset() | nvidia::apex::ForceFieldAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::ForceFieldAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ForceFieldAssetAuthoring
Protected Member Functions
nvidia::apex::ForceFieldAssetAuthoring Class Reference

ForceField Asset Authoring. More...

#include <ForceFieldAsset.h>

Inheritance diagram for nvidia::apex::ForceFieldAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Protected Member Functions

virtual ~ForceFieldAssetAuthoring ()
force field asset authoring default destructor.

Detailed Description

ForceField Asset Authoring.

The documentation for this class was generated from the following file:
  • ForceFieldAsset.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ForceFieldAssetAuthoring
nvidia::apex::ForceFieldAssetAuthoring Member List
This is the complete list of members for nvidia::apex::ForceFieldAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
~ForceFieldAssetAuthoring() | nvidia::apex::ForceFieldAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::ForceFieldPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ForceFieldPreview
Public Member Functions
nvidia::apex::ForceFieldPreview Class Reference

APEX asset preview force field asset. More...

#include <ForceFieldPreview.h>

Inheritance diagram for nvidia::apex::ForceFieldPreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void | setIconScale (float scale)=0
virtual void | setDetailLevel (uint32_t detail)=0

Detailed Description

APEX asset preview force field asset.

Member Function Documentation

virtual void nvidia::apex::ForceFieldPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable. Any, all, or none of the following masks may be added together to select what should be drawn. The defines for the individual items are FORCEFIELD_DRAW_NOTHING, FORCEFIELD_DRAW_ICON, FORCEFIELD_DRAW_BOUNDARIES, FORCEFIELD_DRAW_WITH_CYLINDERS. All items may be drawn using the macro FORCEFIELD_DRAW_FULL_DETAIL and FORCEFIELD_DRAW_FULL_DETAIL_BOLD.

virtual void nvidia::apex::ForceFieldPreview::setIconScale ( float scale ) [pure virtual]

Set the scale of the icon. The unscaled icon has is 1.0x1.0 game units. By default the scale of the icon is 1.0. (unscaled)

The documentation for this class was generated from the following file:
  • ForceFieldPreview.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ForceFieldPreview
nvidia::apex::ForceFieldPreview Member List
This is the complete list of members for nvidia::apex::ForceFieldPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
ForceFieldPreview() (defined in nvidia::apex::ForceFieldPreview) | nvidia::apex::ForceFieldPreview | [inline, protected]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setDetailLevel(uint32_t detail)=0 | nvidia::apex::ForceFieldPreview | [pure virtual]
setIconScale(float scale)=0 | nvidia::apex::ForceFieldPreview | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::FractureToolsAPI Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureToolsAPI
Public Member Functions
nvidia::apex::FractureToolsAPI Class Reference

#include <FractureToolsAPI.h>

List of all members.

Public Member Functions

virtual FractureTools::CutoutSet * | createCutoutSet ()=0
virtual void | buildCutoutSet (FractureTools::CutoutSet &cutoutSet, const uint8_t *pixelBuffer, uint32_t bufferWidth, uint32_t bufferHeight, float snapThreshold, bool periodic)=0
virtual bool | calculateCutoutUVMapping (const nvidia::ExplicitRenderTriangle &triangle, PxMat33 &theMapping)=0
virtual bool | calculateCutoutUVMapping (nvidia::ExplicitHierarchicalMesh &hMesh, const PxVec3 &targetDirection, PxMat33 &theMapping)=0
virtual bool | createVoronoiSplitMesh (nvidia::ExplicitHierarchicalMesh &hMesh, nvidia::ExplicitHierarchicalMesh &iHMeshCore, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, uint32_t randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual uint32_t | createVoronoiSitesInsideMesh (nvidia::ExplicitHierarchicalMesh &hMesh, PxVec3 *siteBuffer, uint32_t *siteChunkIndices, uint32_t siteCount, uint32_t *randomSeed, uint32_t *microgridSize, BSPOpenMode::Enum meshMode, nvidia::IProgressListener &progressListener, uint32_t chunkIndex=0xFFFFFFFF)=0
virtual uint32_t | createScatterMeshSites (uint8_t *meshIndices, PxMat44 *relativeTransforms, uint32_t *chunkMeshStarts, uint32_t scatterMeshInstancesBufferSize, nvidia::ExplicitHierarchicalMesh &hMesh, uint32_t targetChunkCount, const uint16_t *targetChunkIndices, uint32_t *randomSeed, uint32_t scatterMeshAssetCount, nvidia::RenderMeshAsset **scatterMeshAssets, const uint32_t *minCount, const uint32_t *maxCount, const float *minScales, const float *maxScales, const float *maxAngles)=0
virtual void | visualizeVoronoiCells (nvidia::RenderDebugInterface &debugRender, const PxVec3 *sites, uint32_t siteCount, const uint32_t *cellColors, uint32_t cellColorCount, const PxBounds3 &bounds, uint32_t cellIndex=0xFFFFFFFF)=0
virtual bool | buildExplicitHierarchicalMesh (nvidia::ExplicitHierarchicalMesh &iHMesh, const nvidia::ExplicitRenderTriangle *meshTriangles, uint32_t meshTriangleCount, const nvidia::ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0, int32_t *parentIndices=NULL, uint32_t parentIndexCount=0)=0
virtual void | setBSPTolerances (float linearTolerance, float angularTolerance, float baseTolerance, float clipTolerance, float cleaningTolerance)=0
virtual void | setBSPBuildParameters (float logAreaSigmaThreshold, uint32_t testSetSize, float splitWeight, float imbalanceWeight)=0
virtual bool | buildExplicitHierarchicalMeshFromRenderMeshAsset (nvidia::ExplicitHierarchicalMesh &iHMesh, const nvidia::RenderMeshAsset &renderMeshAsset, uint32_t maxRootDepth=UINT32_MAX)=0
virtual bool | buildExplicitHierarchicalMeshFromDestructibleAsset (nvidia::ExplicitHierarchicalMesh &iHMesh, const nvidia::DestructibleAsset &destructibleAsset, uint32_t maxRootDepth=UINT32_MAX)=0
virtual bool | createHierarchicallySplitMesh (nvidia::ExplicitHierarchicalMesh &hMesh, nvidia::ExplicitHierarchicalMesh &iHMeshCore, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, uint32_t randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual bool | createChippedMesh (nvidia::ExplicitHierarchicalMesh &hMesh, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureCutoutDesc &desc, const FractureTools::CutoutSet &iCutoutSet, const FractureTools::FractureSliceDesc &sliceDesc, const FractureTools::FractureVoronoiDesc &voronoiDesc, const CollisionDesc &collisionDesc, uint32_t randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual bool | hierarchicallySplitChunk (nvidia::ExplicitHierarchicalMesh &hMesh, uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual bool | voronoiSplitChunk (nvidia::ExplicitHierarchicalMesh &hMesh, uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0
virtual bool | buildSliceMesh (nvidia::IntersectMesh &intersectMesh, nvidia::ExplicitHierarchicalMesh &referenceMesh, const PxPlane &slicePlane, const FractureTools::NoiseParameters &noiseParameters, uint32_t randomSeed)=0
virtual
nvidia::ExplicitHierarchicalMesh * 		createExplicitHierarchicalMesh ()=0
virtual
nvidia::ExplicitHierarchicalMesh::ConvexHull * 		createExplicitHierarchicalMeshConvexHull ()=0

Detailed Description

Fracture tools API

Member Function Documentation

virtual void nvidia::apex::FractureToolsAPI::buildCutoutSet | ( | FractureTools::CutoutSet & | cutoutSet,
 |  | const uint8_t * | pixelBuffer,
 |  | uint32_t | bufferWidth,
 |  | uint32_t | bufferHeight,
 |  | float | snapThreshold,
 |  | bool | periodic
 | ) |  | [pure virtual]

Builds a cutout set (which must have been initially created by createCutoutSet()). Uses a bitmap described by pixelBuffer, bufferWidth, and bufferHeight. Each pixel is represented by one byte in the buffer.

Parameters:
cutoutSet | the CutoutSet to build
pixelBuffer | pointer to be beginning of the pixel buffer
bufferWidth | the width of the buffer in pixels
bufferHeight | the height of the buffer in pixels
snapThreshold | the pixel distance at which neighboring cutout vertices and segments may be fudged into alignment.
periodic | whether or not to use periodic boundary conditions when creating cutouts from the map
virtual bool nvidia::apex::FractureToolsAPI::buildExplicitHierarchicalMesh | ( | nvidia::ExplicitHierarchicalMesh & | iHMesh,
 |  | const nvidia::ExplicitRenderTriangle * | meshTriangles,
 |  | uint32_t | meshTriangleCount,
 |  | const nvidia::ExplicitSubmeshData * | submeshData,
 |  | uint32_t | submeshCount,
 |  | uint32_t * | meshPartition = NULL,
 |  | uint32_t | meshPartitionCount = 0,
 |  | int32_t * | parentIndices = NULL,
 |  | uint32_t | parentIndexCount = 0
 | ) |  | [pure virtual]

Builds a new ExplicitHierarchicalMesh from an array of triangles.

Parameters:
iHMesh | the ExplicitHierarchicalMesh to build
meshTriangles | pointer to array of ExplicitRenderTriangles which make up the mesh
meshTriangleCount | the size of the meshTriangles array
submeshData | pointer to array of ExplicitSubmeshData, describing the submeshes
submeshCount | the size of the submeshData array
meshPartition | if not NULL, an array of size meshPartitionCount, giving the end elements of contiguous subsets of meshTriangles. If meshPartition is NULL, one partition is assumed. When there is one partition, these triangles become the level 0 part. When there is more than one partition, these triangles become level 1 parts, the behavior is determined by firstPartitionIsDepthZero (see below).
meshPartitionCount | if meshPartition is not NULL, this is the size of the meshPartition array.
parentIndices | if not NULL, the parent indices for each chunk (corresponding to a partition in the mesh partition).
parentIndexCount | the size of the parentIndices array. This does not need to match meshPartitionCount. If a mesh partition has an index beyond the end of parentIndices, then the parentIndex is considered to be 0. Therefore, if parentIndexCount = 0, all parents are 0 and so all chunks created will be depth 1. This will cause a depth 0 chunk to be created that is the aggregate of the depth 1 chunks. If parentIndexCount > 0, then the depth-0 chunk must have a parentIndex of -1. To reproduce the effect of the old parameter 'firstPartitionIsDepthZero' = true, set parentIndices to the address of a int32_t containing the value -1, and set parentIndexCount = 1. To reproduce the effect of the old parameter 'firstPartitionIsDepthZero' = false, set parentIndexCount = 0. Note: if parent indices are given, the first one must be -1, and *only* that index may be negative. That is, there may be only one depth-0 mesh and it must be the first mesh.
virtual bool nvidia::apex::FractureToolsAPI::buildExplicitHierarchicalMeshFromDestructibleAsset | ( | nvidia::ExplicitHierarchicalMesh & | iHMesh,
 |  | const nvidia::DestructibleAsset & | destructibleAsset,
 |  | uint32_t | maxRootDepth = UINT32_MAX
 | ) |  | [pure virtual]

Builds the root ExplicitHierarchicalMesh from an DestructibleAsset. Since an DestructibleAsset contains hierarchy information, the explicit mesh formed will have this hierarchy structure.

Parameters:
iHMesh | the ExplicitHierarchicalMesh to build
destructibleAsset | input Destructible asset
maxRootDepth | cap the root depth at this value. Re-fracturing of the mesh will occur at this depth. Default = UINT32_MAX
virtual bool nvidia::apex::FractureToolsAPI::buildExplicitHierarchicalMeshFromRenderMeshAsset | ( | nvidia::ExplicitHierarchicalMesh & | iHMesh,
 |  | const nvidia::RenderMeshAsset & | renderMeshAsset,
 |  | uint32_t | maxRootDepth = UINT32_MAX
 | ) |  | [pure virtual]

Builds the root ExplicitHierarchicalMesh from an RenderMeshAsset. Since an DestructibleAsset contains no hierarchy information, the input mesh must have only one part.

Parameters:
iHMesh | the ExplicitHierarchicalMesh to build
renderMeshAsset | input RenderMesh asset
maxRootDepth | cap the root depth at this value. Re-fracturing of the mesh will occur at this depth. Default = UINT32_MAX
virtual bool nvidia::apex::FractureToolsAPI::buildSliceMesh | ( | nvidia::IntersectMesh & | intersectMesh,
 |  | nvidia::ExplicitHierarchicalMesh & | referenceMesh,
 |  | const PxPlane & | slicePlane,
 |  | const FractureTools::NoiseParameters & | noiseParameters,
 |  | uint32_t | randomSeed
 | ) |  | [pure virtual]

Builds a mesh used for slice fracturing, given the noise parameters and random seed. This function is mostly intended for visualization - to give the user a "typical" slice surface used for fracturing.

virtual bool nvidia::apex::FractureToolsAPI::calculateCutoutUVMapping | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | const PxVec3 & | targetDirection,
 |  | PxMat33 & | theMapping
 | ) |  | [pure virtual]

Uses the passed-in target direction to find the best triangle in the root mesh with normal near the given targetDirection. If triangles exist with normals within one degree of the given target direction, then one with the greatest area of such triangles is used. Otherwise, the triangle with normal closest to the given target direction is used. The resulting triangle is used to calculate a UV mapping as in the function calculateCutoutUVMapping (above).

The assumption is that there exists a single mapping for all triangles on a specified face, for this feature to be useful.

Parameters:
hMesh | the explicit mesh with well rectangle-shaped faces
targetDirection | the target face's normal
theMapping | resulted mapping, composed by an affine transformation and a rotation
virtual bool nvidia::apex::FractureToolsAPI::calculateCutoutUVMapping | ( | const nvidia::ExplicitRenderTriangle & | triangle,
 |  | PxMat33 & | theMapping
 | ) |  | [pure virtual]

Calculate the mapping between a cutout fracture map and a given triangle. The result is a 3 by 3 matrix M composed by an affine transformation and a rotation, we can get the 3-D projection for a texture coordinate pair (u,v) with such a formula: (x,y,z) = M*PxVec3(u,v,1)

Parameters:
triangle | the target face's normal
theMapping | resulted mapping, composed by an affine transformation and a rotation
virtual bool nvidia::apex::FractureToolsAPI::createChippedMesh | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureCutoutDesc & | desc,
 |  | const FractureTools::CutoutSet & | iCutoutSet,
 |  | const FractureTools::FractureSliceDesc & | sliceDesc,
 |  | const FractureTools::FractureVoronoiDesc & | voronoiDesc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t | randomSeed,
 |  | nvidia::IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Chips the mesh in chunk[0], forming a hierarchy of fractured meshes in chunks[1...]

Parameters:
hMesh | the mesh to split
meshProcessingParams | describes generic mesh processing directives
desc | describes the slicing surfaces (see FractureCutoutDesc)
iCutoutSet | the cutout set to use for fracturing (see CutoutSet)
sliceDesc | used if desc.chunkFracturingMethod = SliceFractureCutoutChunks
voronoiDesc | used if desc.chunkFracturingMethod = VoronoiFractureCutoutChunks
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | seed for the random number generator, to ensure reproducibility.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual FractureTools::CutoutSet* nvidia::apex::FractureToolsAPI::createCutoutSet ( ) [pure virtual]

Instantiates a blank CutoutSet

virtual nvidia::ExplicitHierarchicalMesh* nvidia::apex::FractureToolsAPI::createExplicitHierarchicalMesh ( ) [pure virtual]

Instantiates an ExplicitHierarchicalMesh

virtual nvidia::ExplicitHierarchicalMesh::ConvexHull* nvidia::apex::FractureToolsAPI::createExplicitHierarchicalMeshConvexHull ( ) [pure virtual]

Instantiates an ExplicitHierarchicalMesh::ConvexHull

virtual bool nvidia::apex::FractureToolsAPI::createHierarchicallySplitMesh | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | nvidia::ExplicitHierarchicalMesh & | iHMeshCore,
 |  | bool | exportCoreMesh,
 |  | int32_t | coreMeshImprintSubmeshIndex,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureSliceDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t | randomSeed,
 |  | nvidia::IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the mesh in chunk[0], forming a hierarchy of fractured meshes in chunks[1...]

Parameters:
hMesh | the mesh to split
iHMeshCore | if this mesh is not empty, chunk 0 will be used as an indestructible "core" of the fractured mesh. That is, it will be subtracted from hMesh, and placed at level 1 of the hierarchy. The remainder of hMesh will be split as usual, creating chunks at level 1 (and possibly deeper).
exportCoreMesh | if true, a core mesh chunk will be created from iHMeshCore
coreMeshImprintSubmeshIndex | if this is < 0, use the core mesh materials (was applyCoreMeshMaterialToNeighborChunks). Otherwise, use the given submesh
meshProcessingParams | describes generic mesh processing directives
desc | describes the slicing surfaces (see FractureSliceDesc)
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | seed for the random number generator, to ensure reproducibility.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual uint32_t nvidia::apex::FractureToolsAPI::createScatterMeshSites | ( | uint8_t * | meshIndices,
 |  | PxMat44 * | relativeTransforms,
 |  | uint32_t * | chunkMeshStarts,
 |  | uint32_t | scatterMeshInstancesBufferSize,
 |  | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | uint32_t | targetChunkCount,
 |  | const uint16_t * | targetChunkIndices,
 |  | uint32_t * | randomSeed,
 |  | uint32_t | scatterMeshAssetCount,
 |  | nvidia::RenderMeshAsset ** | scatterMeshAssets,
 |  | const uint32_t * | minCount,
 |  | const uint32_t * | maxCount,
 |  | const float * | minScales,
 |  | const float * | maxScales,
 |  | const float * | maxAngles
 | ) |  | [pure virtual]

Creates scatter mesh sites randomly distributed on the mesh.

Parameters:
meshIndices | user-allocated array of size scatterMeshInstancesBufferSize which will be filled in by this function, giving the scatter mesh index used
relativeTransforms | user-allocated array of size scatterMeshInstancesBufferSize which will be filled in by this function, giving the chunk-relative transform for each chunk instance
chunkMeshStarts | user-allocated array which will be filled in with offsets into the meshIndices and relativeTransforms array. For a chunk indexed by i, the corresponding range [chunkMeshStart[i], chunkMeshStart[i+1]-1] in meshIndices and relativeTransforms is used. NOTE*: chunkMeshStart array must be of at least size N+1, where N is the number of chunks in the base explicit hierarchical mesh.
scatterMeshInstancesBufferSize | the size of meshIndices and relativeTransforms array.
scatterMeshInstancesBufferSize | the size of meshIndices and relativeTransforms array.
hMesh | the mesh in which to distribute sites
targetChunkCount | how many chunks are in the array targetChunkIndices
targetChunkIndices | an array of chunk indices which are candidates for scatter meshes. The elements in the array chunkIndices will come from this array
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
scatterMeshAssetCount | the number of different scatter meshes (not instances). Should not exceed 255. If scatterMeshAssetCount > 255, only the first 255 will be used.
scatterMeshAssets | an array of size scatterMeshAssetCount, of the render mesh assets which will be used for the scatter meshes
minCount | an array of size scatterMeshAssetCount, giving the minimum number of instances to place for each mesh
maxCount | an array of size scatterMeshAssetCount, giving the maximum number of instances to place for each mesh
minScales | an array of size scatterMeshAssetCount, giving the minimum scale to apply to each scatter mesh
maxScales | an array of size scatterMeshAssetCount, giving the maximum scale to apply to each scatter mesh
maxAngles | an array of size scatterMeshAssetCount, giving a maximum deviation angle (in degrees) from the surface normal to apply to each scatter mesh

return value the number of instances placed in indices and relativeTransforms (will not exceed scatterMeshInstancesBufferSize)

virtual uint32_t nvidia::apex::FractureToolsAPI::createVoronoiSitesInsideMesh | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | PxVec3 * | siteBuffer,
 |  | uint32_t * | siteChunkIndices,
 |  | uint32_t | siteCount,
 |  | uint32_t * | randomSeed,
 |  | uint32_t * | microgridSize,
 |  | BSPOpenMode::Enum | meshMode,
 |  | nvidia::IProgressListener & | progressListener,
 |  | uint32_t | chunkIndex = 0xFFFFFFFF
 | ) |  | [pure virtual]

Generates a set of uniformly distributed points in the interior of the root mesh.

Parameters:
hMesh | the mesh in which to distribute sites
siteBuffer | an array of PxVec3, at least the size of siteCount
siteChunkIndices | if not NULL, then must be at least the size of siteCount. siteCount indices will be written to this buffer, associating each site with a chunk that contains it.
siteCount | the number of points to write into siteBuffer
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
microgridSize | pointer to a grid size used for BSP creation. If NULL, the default settings will be used.
meshMode | Open mesh handling. Modes: Automatic, Closed, Open (see BSPOpenMode)
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
chunkIndex | If this is a valid index, the voronoi sites will only be created within the volume of the indexed chunk. Otherwise, the sites will be created within each of the root-level chunks. Default value is an invalid index.
Returns:
returns the number of sites actually created (written to siteBuffer and siteChunkIndices). This may be less than the number of sites requested if site placement fails.
virtual bool nvidia::apex::FractureToolsAPI::createVoronoiSplitMesh | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | nvidia::ExplicitHierarchicalMesh & | iHMeshCore,
 |  | bool | exportCoreMesh,
 |  | int32_t | coreMeshImprintSubmeshIndex,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureVoronoiDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t | randomSeed,
 |  | nvidia::IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the mesh in chunk[0], forming fractured pieces chunks[1...] using Voronoi decomposition fracturing.

Parameters:
hMesh | the mesh to split
iHMeshCore | if this mesh is not empty, chunk 0 will be used as an indestructible "core" of the fractured mesh. That is, it will be subtracted from hMesh, and placed at level 1 of the hierarchy. The remainder of hMesh will be split as usual, creating chunks at level 1 (and possibly deeper).
exportCoreMesh | if true, a core mesh chunk will be created from iHMeshCore
coreMeshImprintSubmeshIndex | if this is < 0, use the core mesh materials (was applyCoreMeshMaterialToNeighborChunks). Otherwise, use the given submesh
meshProcessingParams | describes generic mesh processing directives
desc | describes the voronoi splitting parameters surfaces (see FractureVoronoiDesc)
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | seed for the random number generator, to ensure reproducibility.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
true if successful.
virtual bool nvidia::apex::FractureToolsAPI::hierarchicallySplitChunk | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | uint32_t | chunkIndex,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureSliceDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t * | randomSeed,
 |  | nvidia::IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the chunk in chunk[chunkIndex], forming a hierarchy of fractured chunks using slice-mode fracturing. The chunks will be rearranged so that they are in breadth-first order.

Parameters:
hMesh | the ExplicitHierarchicalMesh to act upon
chunkIndex | index of chunk to be split
meshProcessingParams | used to create a BSP for this chunk
desc | describes the slicing surfaces (see FractureSliceDesc)
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
virtual void nvidia::apex::FractureToolsAPI::setBSPBuildParameters | ( | float | logAreaSigmaThreshold,
 |  | uint32_t | testSetSize,
 |  | float | splitWeight,
 |  | float | imbalanceWeight
 | ) |  | [pure virtual]

Set the parameters used in BSP building operations.

Parameters:
logAreaSigmaThreshold | At each step in the tree building process, the surface with maximum triangle area is compared to the other surface triangle areas. If the maximum area surface is far from the "typical" set of surface areas, then that surface is chosen as the next splitting plane. Otherwise, a random test set is chosen and a winner determined based upon the weightings below. The value logAreaSigmaThreshold determines how "atypical" the maximum area surface must be to be chosen in this manner. Default value = 2.0.
testSetSize | Larger values of testSetSize may find better BSP trees, but will take more time to create. testSetSize = 0 is treated as infinity (all surfaces will be tested for each branch). Default value = 10.
splitWeight | How much to weigh the relative number of triangle splits when searching for a BSP surface. Default value = 0.5.
imbalanceWeight | How much to weigh the relative triangle imbalance when searching for a BSP surface. Default value = 0.0.
virtual void nvidia::apex::FractureToolsAPI::setBSPTolerances | ( | float | linearTolerance,
 |  | float | angularTolerance,
 |  | float | baseTolerance,
 |  | float | clipTolerance,
 |  | float | cleaningTolerance
 | ) |  | [pure virtual]

Set the tolerances used in CSG calculations with BSPs.

Parameters:
linearTolerance | relative (to mesh size) tolerance used with angularTolerance to determine coplanarity. Default = 1.0e-4.
angularTolerance | used with linearTolerance to determine coplanarity. Default = 1.0e-3
baseTolerance | relative (to mesh size) tolerance used for spatial partitioning
clipTolerance | relative (to mesh size) tolerance used when clipping triangles for CSG mesh building operations. Default = 1.0e-4.
cleaningTolerance | relative (to mesh size) tolerance used when cleaning the out put mesh generated from the toMesh() function. Default = 1.0e-7.
virtual void nvidia::apex::FractureToolsAPI::visualizeVoronoiCells | ( | nvidia::RenderDebugInterface & | debugRender,
 |  | const PxVec3 * | sites,
 |  | uint32_t | siteCount,
 |  | const uint32_t * | cellColors,
 |  | uint32_t | cellColorCount,
 |  | const PxBounds3 & | bounds,
 |  | uint32_t | cellIndex = 0xFFFFFFFF
 | ) |  | [pure virtual]

Utility to visualize Voronoi cells for a given set of sites.

debugRender rendering object which will receive the drawing primitives associated with this cell visualization sites an array of Voronoi cell sites, of length siteCount siteCount the number of Voronoi cell sites (length of sites array) cellColors an optional array of colors (see RenderDebug for format) for the cells. If NULL, the white (0xFFFFFFFF) color will be used. If not NULL, this (of length cellColorCount) is used to color the cell graphics. The number cellColorCount need not match siteCount. If cellColorCount is less than siteCount, the cell colors will cycle. That is, site N gets cellColor[NcellColorCount]. cellColorCount the number of cell colors (the length of cellColors array) bounds defines an axis-aligned bounding box which clips the visualization, since some cells extend to infinity cellIndex if this is a valid index (cellIndex < siteCount), then only the cell corresponding to sites[cellIndex] will be drawn. Otherwise, all cells will be drawn.

virtual bool nvidia::apex::FractureToolsAPI::voronoiSplitChunk | ( | nvidia::ExplicitHierarchicalMesh & | hMesh,
 |  | uint32_t | chunkIndex,
 |  | const FractureTools::MeshProcessingParameters & | meshProcessingParams,
 |  | const FractureTools::FractureVoronoiDesc & | desc,
 |  | const CollisionDesc & | collisionDesc,
 |  | uint32_t * | randomSeed,
 |  | nvidia::IProgressListener & | progressListener,
 |  | volatile bool * | cancel = NULL
 | ) |  | [pure virtual]

Splits the chunk in chunk[chunkIndex], forming fractured chunks using Voronoi decomposition fracturing. The chunks will be rearranged so that they are in breadth-first order.

Parameters:
hMesh | the ExplicitHierarchicalMesh to act upon
chunkIndex | index of chunk to be split
meshProcessingParams,: describes generic mesh processing directives
desc | describes the voronoi splitting parameters surfaces (see FractureVoronoiDesc)
collisionDesc | convex hulls will be generated for each chunk using the method. See CollisionDesc.
randomSeed | pointer to a seed for the random number generator, to ensure reproducibility. If NULL, the random number generator will not be re-seeded.
progressListener | The user must instantiate an IProgressListener, so that this function may report progress of this operation
cancel | if not NULL and *cancel is set to true, the root mesh will be restored to its original state, and the function will return at its earliest opportunity. Meant to be set from another thread.
Returns:
returns true if successful.
The documentation for this class was generated from the following file:
  • FractureToolsAPI.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureToolsAPI
nvidia::apex::FractureToolsAPI Member List
This is the complete list of members for nvidia::apex::FractureToolsAPI, including all inherited members.
buildCutoutSet(FractureTools::CutoutSet &cutoutSet, const uint8_t *pixelBuffer, uint32_t bufferWidth, uint32_t bufferHeight, float snapThreshold, bool periodic)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
buildExplicitHierarchicalMesh(nvidia::ExplicitHierarchicalMesh &iHMesh, const nvidia::ExplicitRenderTriangle *meshTriangles, uint32_t meshTriangleCount, const nvidia::ExplicitSubmeshData *submeshData, uint32_t submeshCount, uint32_t *meshPartition=NULL, uint32_t meshPartitionCount=0, int32_t *parentIndices=NULL, uint32_t parentIndexCount=0)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
buildExplicitHierarchicalMeshFromDestructibleAsset(nvidia::ExplicitHierarchicalMesh &iHMesh, const nvidia::DestructibleAsset &destructibleAsset, uint32_t maxRootDepth=UINT32_MAX)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
buildExplicitHierarchicalMeshFromRenderMeshAsset(nvidia::ExplicitHierarchicalMesh &iHMesh, const nvidia::RenderMeshAsset &renderMeshAsset, uint32_t maxRootDepth=UINT32_MAX)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
buildSliceMesh(nvidia::IntersectMesh &intersectMesh, nvidia::ExplicitHierarchicalMesh &referenceMesh, const PxPlane &slicePlane, const FractureTools::NoiseParameters &noiseParameters, uint32_t randomSeed)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
calculateCutoutUVMapping(const nvidia::ExplicitRenderTriangle &triangle, PxMat33 &theMapping)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
calculateCutoutUVMapping(nvidia::ExplicitHierarchicalMesh &hMesh, const PxVec3 &targetDirection, PxMat33 &theMapping)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createChippedMesh(nvidia::ExplicitHierarchicalMesh &hMesh, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureCutoutDesc &desc, const FractureTools::CutoutSet &iCutoutSet, const FractureTools::FractureSliceDesc &sliceDesc, const FractureTools::FractureVoronoiDesc &voronoiDesc, const CollisionDesc &collisionDesc, uint32_t randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createCutoutSet()=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createExplicitHierarchicalMesh()=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createExplicitHierarchicalMeshConvexHull()=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createHierarchicallySplitMesh(nvidia::ExplicitHierarchicalMesh &hMesh, nvidia::ExplicitHierarchicalMesh &iHMeshCore, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, uint32_t randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createScatterMeshSites(uint8_t *meshIndices, PxMat44 *relativeTransforms, uint32_t *chunkMeshStarts, uint32_t scatterMeshInstancesBufferSize, nvidia::ExplicitHierarchicalMesh &hMesh, uint32_t targetChunkCount, const uint16_t *targetChunkIndices, uint32_t *randomSeed, uint32_t scatterMeshAssetCount, nvidia::RenderMeshAsset **scatterMeshAssets, const uint32_t *minCount, const uint32_t *maxCount, const float *minScales, const float *maxScales, const float *maxAngles)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createVoronoiSitesInsideMesh(nvidia::ExplicitHierarchicalMesh &hMesh, PxVec3 *siteBuffer, uint32_t *siteChunkIndices, uint32_t siteCount, uint32_t *randomSeed, uint32_t *microgridSize, BSPOpenMode::Enum meshMode, nvidia::IProgressListener &progressListener, uint32_t chunkIndex=0xFFFFFFFF)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
createVoronoiSplitMesh(nvidia::ExplicitHierarchicalMesh &hMesh, nvidia::ExplicitHierarchicalMesh &iHMeshCore, bool exportCoreMesh, int32_t coreMeshImprintSubmeshIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, uint32_t randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
hierarchicallySplitChunk(nvidia::ExplicitHierarchicalMesh &hMesh, uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureSliceDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
setBSPBuildParameters(float logAreaSigmaThreshold, uint32_t testSetSize, float splitWeight, float imbalanceWeight)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
setBSPTolerances(float linearTolerance, float angularTolerance, float baseTolerance, float clipTolerance, float cleaningTolerance)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
visualizeVoronoiCells(nvidia::RenderDebugInterface &debugRender, const PxVec3 *sites, uint32_t siteCount, const uint32_t *cellColors, uint32_t cellColorCount, const PxBounds3 &bounds, uint32_t cellIndex=0xFFFFFFFF)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
voronoiSplitChunk(nvidia::ExplicitHierarchicalMesh &hMesh, uint32_t chunkIndex, const FractureTools::MeshProcessingParameters &meshProcessingParams, const FractureTools::FractureVoronoiDesc &desc, const CollisionDesc &collisionDesc, uint32_t *randomSeed, nvidia::IProgressListener &progressListener, volatile bool *cancel=NULL)=0 | nvidia::apex::FractureToolsAPI | [pure virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::GroundEmitterActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterActor
Public Member Functions
nvidia::apex::GroundEmitterActor Class Reference

Ground Emitter actor. Uses raycasts against ground to spawn particles. More...

#include <GroundEmitterActor.h>

Inheritance diagram for nvidia::apex::GroundEmitterActor:
nvidia::apex::Actor nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual GroundEmitterAsset * | getEmitterAsset () const =0
Returns the asset the instance has been created from.
virtual const PxMat44 | getPose () const =0
Returns the pose of the emitter.
virtual void | setPose (const PxMat44 &pos)=0
Sets the pose of the emitter.
virtual void | setMaterialLookupCallback (MaterialLookupCallback *)=0
Set the material lookup callback method that replaces raycasts.
virtual MaterialLookupCallback * | getMaterialLookupCallback () const =0
Get the material lookup callback method that replaces raycasts.
virtual void | setAttachActor (PxActor *)=0
Attaches the emitter to an actor PxActor pointer can be NULL to detach existing actor.
virtual void | setAttachRelativePosition (const PxVec3 &pos)=0
sets the relative position of the emitter in the space of the actor to which it is attached
virtual const PxActor * | getAttachActor () const =0
PhysX SDK 3.X. Retrieves the actor, to which the emitter is attached. NULL is returned for an unattached emitter.
virtual const PxVec3 & | getAttachRelativePosition () const =0
Retrieves the relative position of the emitter in the space of the actor to which it is attached.
virtual void | setDensity (const float &)=0
Sets the range from which the density of particles within the volume is randomly chosen.
virtual void | setRadius (float)=0
Sets the radius. The ground emitter actor will create objects within a circle of size 'radius'.
virtual void | setMaxRaycastsPerFrame (uint32_t)=0
Sets The maximum raycasts number per frame.
virtual void | setRaycastHeight (float)=0
Sets the height from which the ground emitter will cast rays at terrain/objects opposite of the 'upDirection'.
virtual void | setSpawnHeight (float)=0
Sets the height above the ground to emit particles. If greater than 0, the ground emitter will refresh a disc above the player's position rather than refreshing a circle around the player's position.
virtual const float & | getDensity () const =0
Gets the range from which the density of particles within the volume is randomly chosen.
virtual float | getRadius () const =0
Gets the radius. The ground emitter actor will create objects within a circle of size 'radius'.
virtual uint32_t | getMaxRaycastsPerFrame () const =0
Gets The maximum raycasts number per frame.
virtual float | getRaycastHeight () const =0
Gets the height from which the ground emitter will cast rays at terrain/objects opposite of the 'upDirection'.
virtual float | getSpawnHeight () const =0
Gets the height above the ground to emit particles. If greater than 0, the ground emitter will refresh a disc above the player's position rather than refreshing a circle around the player's position.
virtual void | setRaycastCollisionGroups (uint32_t)=0
Sets collision groups used to cast rays.
virtual void | setRaycastCollisionGroupsMask (physx::PxFilterData *)=0
PHYSX SDK 3.X. Sets collision groups mask.
virtual uint32_t | getRaycastCollisionGroups () const =0
Gets collision groups used to cast rays.
virtual void | setPreferredRenderVolume (RenderVolume *volume)=0

Detailed Description

Ground Emitter actor. Uses raycasts against ground to spawn particles.

Member Function Documentation

virtual void nvidia::apex::GroundEmitterActor::setPreferredRenderVolume ( RenderVolume * volume ) [pure virtual]

Emitted particles are injected to specified render volume on initial frame. Set to NULL to clear the preferred volume.

The documentation for this class was generated from the following file:
  • GroundEmitterActor.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterActor
nvidia::apex::GroundEmitterActor Member List
This is the complete list of members for nvidia::apex::GroundEmitterActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getAttachActor() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getAttachRelativePosition() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getDensity() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getEmitterAsset() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getMaterialLookupCallback() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getMaxRaycastsPerFrame() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getPose() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getRadius() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getRaycastCollisionGroups() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getRaycastHeight() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
getSpawnHeight() const =0 | nvidia::apex::GroundEmitterActor | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setAttachActor(PxActor *)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setAttachRelativePosition(const PxVec3 &pos)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setDensity(const float &)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setMaterialLookupCallback(MaterialLookupCallback *)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setMaxRaycastsPerFrame(uint32_t)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setPose(const PxMat44 &pos)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setPreferredRenderVolume(RenderVolume *volume)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setRadius(float)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setRaycastCollisionGroups(uint32_t)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setRaycastCollisionGroupsMask(physx::PxFilterData *)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setRaycastHeight(float)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
setSpawnHeight(float)=0 | nvidia::apex::GroundEmitterActor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~GroundEmitterActor() (defined in nvidia::apex::GroundEmitterActor) | nvidia::apex::GroundEmitterActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::GroundEmitterAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterAsset
Public Member Functions
nvidia::apex::GroundEmitterAsset Class Reference

Ground emitter asset. Used to create Ground emitter actors with specific properties. More...

#include <GroundEmitterAsset.h>

Inheritance diagram for nvidia::apex::GroundEmitterAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual const PxVec3 & | getVelocityLow () const =0
Gets the velocity range. The ground emitter actor will create objects with a random velocity within the velocity range.
virtual const PxVec3 & | getVelocityHigh () const =0
Gets the velocity range. The ground emitter actor will create objects with a random velocity within the velocity range.
virtual const float & | getLifetimeLow () const =0
Gets the lifetime range. The ground emitter actor will create objects with a random lifetime (in seconds) within the lifetime range.
virtual const float & | getLifetimeHigh () const =0
Gets the lifetime range. The ground emitter actor will create objects with a random lifetime (in seconds) within the lifetime range.
virtual float | getRadius () const =0
Gets the radius. The ground emitter actor will create objects within a circle of size 'radius'.
virtual uint32_t | getMaxRaycastsPerFrame () const =0
Gets The maximum raycasts number per frame.
virtual float | getRaycastHeight () const =0
Gets the height from which the ground emitter will cast rays at terrain/objects opposite of the 'upDirection'.
virtual float | getSpawnHeight () const =0
Gets the height above the ground to emit particles. If greater than 0, the ground emitter will refresh a disc above the player's position rather than refreshing a circle around the player's position.
virtual const char * | getRaycastCollisionGroupMaskName () const =0
Gets collision groups name used to cast rays.

Detailed Description

Ground emitter asset. Used to create Ground emitter actors with specific properties.

The documentation for this class was generated from the following file:
  • GroundEmitterAsset.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterAsset
nvidia::apex::GroundEmitterAsset Member List
This is the complete list of members for nvidia::apex::GroundEmitterAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getLifetimeHigh() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getLifetimeLow() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getMaxRaycastsPerFrame() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
getRadius() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getRaycastCollisionGroupMaskName() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getRaycastHeight() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getSpawnHeight() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getVelocityHigh() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
getVelocityLow() const =0 | nvidia::apex::GroundEmitterAsset | [pure virtual]
GroundEmitterAsset() (defined in nvidia::apex::GroundEmitterAsset) | nvidia::apex::GroundEmitterAsset | [inline, protected]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~GroundEmitterAsset() (defined in nvidia::apex::GroundEmitterAsset) | nvidia::apex::GroundEmitterAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::GroundEmitterAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterAssetAuthoring
nvidia::apex::GroundEmitterAssetAuthoring Class Reference

Ground emitter authoring class. Used to create Ground emitter assets. More...

#include <GroundEmitterAsset.h>

Inheritance diagram for nvidia::apex::GroundEmitterAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

Ground emitter authoring class. Used to create Ground emitter assets.

The documentation for this class was generated from the following file:
  • GroundEmitterAsset.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterAssetAuthoring
nvidia::apex::GroundEmitterAssetAuthoring Member List
This is the complete list of members for nvidia::apex::GroundEmitterAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
~GroundEmitterAssetAuthoring() (defined in nvidia::apex::GroundEmitterAssetAuthoring) | nvidia::apex::GroundEmitterAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::GroundEmitterPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterPreview
Public Member Functions
nvidia::apex::GroundEmitterPreview Class Reference

Ground emitter preview class. Use for preview rendering. More...

#include <GroundEmitterPreview.h>

Inheritance diagram for nvidia::apex::GroundEmitterPreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void | drawEmitterPreview ()=0
Does the drawing.
virtual void | setScale (float scale)=0
Sets the scale factor of the preview object.

Detailed Description

Ground emitter preview class. Use for preview rendering.

The documentation for this class was generated from the following file:
  • GroundEmitterPreview.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroundEmitterPreview
nvidia::apex::GroundEmitterPreview Member List
This is the complete list of members for nvidia::apex::GroundEmitterPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
drawEmitterPreview()=0 | nvidia::apex::GroundEmitterPreview | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
GroundEmitterPreview() (defined in nvidia::apex::GroundEmitterPreview) | nvidia::apex::GroundEmitterPreview | [inline, protected]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
setScale(float scale)=0 | nvidia::apex::GroundEmitterPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::GroupsMask64 Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroupsMask64
Public Member Functions | Public Attributes
nvidia::apex::GroupsMask64 Class Reference

64-bit mask used for collision filtering between IOSes and Field Samplers. More...

#include <ApexSDK.h>

List of all members.

Public Member Functions

PX_INLINE | GroupsMask64 ()
Default constructor.
PX_INLINE | GroupsMask64 (uint32_t b0, uint32_t b1)
Constructor to set filter data initially.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.

Public Attributes

uint32_t | bits0
Mask bits.
uint32_t | bits1
Mask bits.

Detailed Description

64-bit mask used for collision filtering between IOSes and Field Samplers.

The documentation for this class was generated from the following file:
  • ApexSDK.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroupsMask64
nvidia::apex::GroupsMask64 Member List
This is the complete list of members for nvidia::apex::GroupsMask64, including all inherited members.
bits0 | nvidia::apex::GroupsMask64 |
bits1 | nvidia::apex::GroupsMask64 |
GroupsMask64() | nvidia::apex::GroupsMask64 | [inline]
GroupsMask64(uint32_t b0, uint32_t b1) | nvidia::apex::GroupsMask64 | [inline]
setToDefault() | nvidia::apex::GroupsMask64 | [inline]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::HalfSpaceShape Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • HalfSpaceShape
Public Member Functions
nvidia::apex::HalfSpaceShape Class Reference

helper HalfSpace shape More...

#include <Shape.h>

Inheritance diagram for nvidia::apex::HalfSpaceShape:
nvidia::apex::Shape

List of all members.

Public Member Functions

virtual void | setOriginAndNormal (PxVec3 origin, PxVec3 normal)=0
set origin and normal of the halfspace
virtual PxVec3 | getNormal () const =0
get normal of the halfspace
virtual PxVec3 | getOrigin () const =0
get origin of the halfspace
virtual PxVec3 | getPreviousOrigin () const =0
get previous origin of the halfspace

Detailed Description

helper HalfSpace shape

The documentation for this class was generated from the following file:
  • Shape.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • HalfSpaceShape
nvidia::apex::HalfSpaceShape Member List
This is the complete list of members for nvidia::apex::HalfSpaceShape, including all inherited members.
getAABB() const =0 | nvidia::apex::Shape | [pure virtual]
getNormal() const =0 | nvidia::apex::HalfSpaceShape | [pure virtual]
getOrigin() const =0 | nvidia::apex::HalfSpaceShape | [pure virtual]
getPose() const =0 | nvidia::apex::Shape | [pure virtual]
getPreviousOrigin() const =0 | nvidia::apex::HalfSpaceShape | [pure virtual]
getPreviousPose() const =0 | nvidia::apex::Shape | [pure virtual]
intersectAgainstAABB(PxBounds3)=0 | nvidia::apex::Shape | [pure virtual]
isBoxGeom() const | nvidia::apex::Shape | [inline, virtual]
isCapsuleGeom() const | nvidia::apex::Shape | [inline, virtual]
isHalfSpaceGeom() const | nvidia::apex::Shape | [inline, virtual]
isSphereGeom() const | nvidia::apex::Shape | [inline, virtual]
releaseApexShape()=0 | nvidia::apex::Shape | [pure virtual]
setOriginAndNormal(PxVec3 origin, PxVec3 normal)=0 | nvidia::apex::HalfSpaceShape | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::Shape | [pure virtual]
visualize(RenderDebugInterface *renderer) const =0 | nvidia::apex::Shape | [pure virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::HeatSourceActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • HeatSourceActor
Public Member Functions
nvidia::apex::HeatSourceActor Class Reference

Turbulence HeatSource Actor class. More...

#include <HeatSourceActor.h>

Inheritance diagram for nvidia::apex::HeatSourceActor:
nvidia::apex::Actor nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual HeatSourceAsset * | getHeatSourceAsset () const =0
Returns the asset the instance has been created from.
virtual void | setEnabled (bool enable)=0
enable/disable the heating
virtual bool | isEnabled () const =0
Returns true if heating enabled.
virtual bool | intersectAgainstAABB (PxBounds3)=0
intersect the collision shape against a given AABB
virtual Shape * | getShape () const =0
Returns pointer to Shape of heat source.
virtual BoxShape * | getBoxShape ()=0
If it is a box, cast to box class, return NULL otherwise.
virtual SphereShape * | getSphereShape ()=0
If it is a sphere, cast to sphere class, return NULL otherwise.
virtual float | getAverageTemperature () const =0
Return average value of temperature.
virtual float | getStdTemperature () const =0
Return STD value of temperature.
virtual PxMat44 | getPose () const =0
get the pose of a heat source shape
virtual void | setTemperature (float averageTemperature, float stdTemperature)=0
Set average and STD values for temperature.
virtual void | setPose (PxMat44 pose)=0
set the pose of a heat source shape
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.
virtual void | release ()=0
Release an object instance.

Detailed Description

Turbulence HeatSource Actor class.

Member Function Documentation

virtual void nvidia::apex::HeatSourceActor::release ( ) [pure virtual]

Release an object instance.

Calling this will unhook the class and delete it from memory. You should not keep any reference to this class instance after calling release

Implements nvidia::apex::ApexInterface.

The documentation for this class was generated from the following file:
  • HeatSourceActor.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • HeatSourceActor
nvidia::apex::HeatSourceActor Member List
This is the complete list of members for nvidia::apex::HeatSourceActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getAverageTemperature() const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
getBoxShape()=0 | nvidia::apex::HeatSourceActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
getHeatSourceAsset() const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getPose() const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
getShape() const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
getSphereShape()=0 | nvidia::apex::HeatSourceActor | [pure virtual]
getStdTemperature() const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
intersectAgainstAABB(PxBounds3)=0 | nvidia::apex::HeatSourceActor | [pure virtual]
isEnabled() const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
release()=0 | nvidia::apex::HeatSourceActor | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::HeatSourceActor | [pure virtual]
setEnabled(bool enable)=0 | nvidia::apex::HeatSourceActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::HeatSourceActor | [pure virtual]
setTemperature(float averageTemperature, float stdTemperature)=0 | nvidia::apex::HeatSourceActor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~HeatSourceActor() (defined in nvidia::apex::HeatSourceActor) | nvidia::apex::HeatSourceActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::HeatSourceAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • HeatSourceAsset
nvidia::apex::HeatSourceAsset Class Reference

Turbulence FieldSampler Asset class. More...

#include <HeatSourceAsset.h>

Inheritance diagram for nvidia::apex::HeatSourceAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

Turbulence FieldSampler Asset class.

The documentation for this class was generated from the following file:
  • HeatSourceAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • HeatSourceAsset
nvidia::apex::HeatSourceAsset Member List
This is the complete list of members for nvidia::apex::HeatSourceAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~HeatSourceAsset() (defined in nvidia::apex::HeatSourceAsset) | nvidia::apex::HeatSourceAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::HeatSourceAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • HeatSourceAssetAuthoring
nvidia::apex::HeatSourceAssetAuthoring Class Reference

Turbulence FieldSampler Asset Authoring class. More...

#include <HeatSourceAsset.h>

Inheritance diagram for nvidia::apex::HeatSourceAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

Turbulence FieldSampler Asset Authoring class.

The documentation for this class was generated from the following file:
  • HeatSourceAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • HeatSourceAssetAuthoring
nvidia::apex::HeatSourceAssetAuthoring Member List
This is the complete list of members for nvidia::apex::HeatSourceAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
~HeatSourceAssetAuthoring() (defined in nvidia::apex::HeatSourceAssetAuthoring) | nvidia::apex::HeatSourceAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::HeatSourcePreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • HeatSourcePreview
Public Member Functions
nvidia::apex::HeatSourcePreview Class Reference

This class provides the asset preview for APEX HeatSource Assets. More...

#include <HeatSourcePreview.h>

Inheritance diagram for nvidia::apex::HeatSourcePreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void | drawHeatSourcePreview ()=0
Draws the emitter.
virtual void | setScale (float scale)=0
Sets the scaling factor of the renderable.

Detailed Description

This class provides the asset preview for APEX HeatSource Assets.

The documentation for this class was generated from the following file:
  • HeatSourcePreview.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • HeatSourcePreview
nvidia::apex::HeatSourcePreview Member List
This is the complete list of members for nvidia::apex::HeatSourcePreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
drawHeatSourcePreview()=0 | nvidia::apex::HeatSourcePreview | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
HeatSourcePreview() (defined in nvidia::apex::HeatSourcePreview) | nvidia::apex::HeatSourcePreview | [inline, protected]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
setScale(float scale)=0 | nvidia::apex::HeatSourcePreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::IProgressListener Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IProgressListener
Public Member Functions
nvidia::apex::IProgressListener Class Reference

User-provided class for following the progress of a task. More...

#include <IProgressListener.h>

List of all members.

Public Member Functions

virtual void setProgress (int progress, const char *taskName=NULL)=0
APEX calls this method to update the progress of a task.

Detailed Description

User-provided class for following the progress of a task.

The documentation for this class was generated from the following file:
  • IProgressListener.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IProgressListener
nvidia::apex::IProgressListener Member List
This is the complete list of members for nvidia::apex::IProgressListener, including all inherited members.
setProgress(int progress, const char *taskName=NULL)=0 nvidia::apex::IProgressListener [pure virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ImpactEmitterActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterActor
Public Member Functions
nvidia::apex::ImpactEmitterActor Class Reference

Impact emitter actor. Emits particles at impact places. More...

#include <ImpactEmitterActor.h>

Inheritance diagram for nvidia::apex::ImpactEmitterActor:
nvidia::apex::Actor nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual ImpactEmitterAsset * | getEmitterAsset () const =0
Gets the pointer to the underlying asset.
virtual void | registerImpact (const PxVec3 &hitPos, const PxVec3 &hitDir, const PxVec3 &surfNorm, uint32_t setID)=0
Registers an impact in the queue.
virtual void | setPreferredRenderVolume (RenderVolume *volume)=0

Detailed Description

Impact emitter actor. Emits particles at impact places.

Member Function Documentation

virtual void nvidia::apex::ImpactEmitterActor::registerImpact | ( | const PxVec3 & | hitPos,
 |  | const PxVec3 & | hitDir,
 |  | const PxVec3 & | surfNorm,
 |  | uint32_t | setID
 | ) |  | [pure virtual]

Registers an impact in the queue.

Parameters:
hitPos | impact position
hitDir | impact direction
surfNorm | normal of the surface that is hit by the impact
setID | - id for the event set which should be spawned. Specifies the behavior.
See also:
ImpactEmitterAsset::querySetID
virtual void nvidia::apex::ImpactEmitterActor::setPreferredRenderVolume ( RenderVolume * volume ) [pure virtual]

Emitted particles are injected to specified render volume on initial frame. Set to NULL to clear the preferred volume.

The documentation for this class was generated from the following file:
  • ImpactEmitterActor.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterActor
nvidia::apex::ImpactEmitterActor Member List
This is the complete list of members for nvidia::apex::ImpactEmitterActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getEmitterAsset() const =0 | nvidia::apex::ImpactEmitterActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
registerImpact(const PxVec3 &hitPos, const PxVec3 &hitDir, const PxVec3 &surfNorm, uint32_t setID)=0 | nvidia::apex::ImpactEmitterActor | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setPreferredRenderVolume(RenderVolume *volume)=0 | nvidia::apex::ImpactEmitterActor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~ImpactEmitterActor() (defined in nvidia::apex::ImpactEmitterActor) | nvidia::apex::ImpactEmitterActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::ImpactEmitterAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterAsset
Public Member Functions
nvidia::apex::ImpactEmitterAsset Class Reference

Impact emitter asset class. More...

#include <ImpactEmitterAsset.h>

Inheritance diagram for nvidia::apex::ImpactEmitterAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual uint32_t | querySetID (const char *setName)=0
Get the setID that corresponds to the set name.
virtual void | getSetNames (const char **inOutSetNames, uint32_t &nameCount) const =0
Get a list of the event set names. The name index in the outSetNames list is the setID.

Detailed Description

Impact emitter asset class.

Member Function Documentation

virtual void nvidia::apex::ImpactEmitterAsset::getSetNames | ( | const char ** | inOutSetNames,
 |  | uint32_t & | nameCount
 | ) |  | const [pure virtual]

Get a list of the event set names. The name index in the outSetNames list is the setID.

Parameters:
[in,out] | inOutSetNames | An array of const char * with at least nameCount
[in,out] | nameCount | The size of setNames as input and output, set to -1 if setIDs > nameCount
virtual uint32_t nvidia::apex::ImpactEmitterAsset::querySetID ( const char * setName ) [pure virtual]

Get the setID that corresponds to the set name.

See also:
ImpactEmitterActor::registerImpact()
The documentation for this class was generated from the following file:
  • ImpactEmitterAsset.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterAsset
nvidia::apex::ImpactEmitterAsset Member List
This is the complete list of members for nvidia::apex::ImpactEmitterAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
getSetNames(const char **inOutSetNames, uint32_t &nameCount) const =0 | nvidia::apex::ImpactEmitterAsset | [pure virtual]
ImpactEmitterAsset() (defined in nvidia::apex::ImpactEmitterAsset) | nvidia::apex::ImpactEmitterAsset | [inline, protected]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
querySetID(const char *setName)=0 | nvidia::apex::ImpactEmitterAsset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~ImpactEmitterAsset() (defined in nvidia::apex::ImpactEmitterAsset) | nvidia::apex::ImpactEmitterAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::ImpactEmitterAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterAssetAuthoring
nvidia::apex::ImpactEmitterAssetAuthoring Class Reference

Impact emitter asset authoring. Used to create Impact Emitter assets. More...

#include <ImpactEmitterAsset.h>

Inheritance diagram for nvidia::apex::ImpactEmitterAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

Impact emitter asset authoring. Used to create Impact Emitter assets.

The documentation for this class was generated from the following file:
  • ImpactEmitterAsset.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterAssetAuthoring
nvidia::apex::ImpactEmitterAssetAuthoring Member List
This is the complete list of members for nvidia::apex::ImpactEmitterAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
~ImpactEmitterAssetAuthoring() (defined in nvidia::apex::ImpactEmitterAssetAuthoring) | nvidia::apex::ImpactEmitterAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::ImpactEmitterPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterPreview
nvidia::apex::ImpactEmitterPreview Class Reference

Impact emitter preview. Used for preview rendering of the emitter actors. More...

#include <ImpactEmitterPreview.h>

Inheritance diagram for nvidia::apex::ImpactEmitterPreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Detailed Description

Impact emitter preview. Used for preview rendering of the emitter actors.

The documentation for this class was generated from the following file:
  • ImpactEmitterPreview.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactEmitterPreview
nvidia::apex::ImpactEmitterPreview Member List
This is the complete list of members for nvidia::apex::ImpactEmitterPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
ImpactEmitterPreview() (defined in nvidia::apex::ImpactEmitterPreview) | nvidia::apex::ImpactEmitterPreview | [inline, protected]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxActor
Public Member Functions
nvidia::apex::IofxActor Class Reference

IOFX actor public interface. More...

#include <IofxActor.h>

Inheritance diagram for nvidia::apex::IofxActor:
nvidia::apex::Actor nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual float | getObjectRadius () const =0
get the radius of the partice
virtual uint32_t | getObjectCount () const =0
get the number of particles
virtual uint32_t | getVisibleCount () const =0
get the number of visible particles (if sprite depth sorting is enabled, returns only number of particles in front of camera)
virtual const char * | getIosAssetName () const =0
get the name of the IOS asset used to feed partices to the IOFX
virtual physx::PxBounds3 | getBounds () const =0
returns AABB covering all objects in this actor, it's updated each frame during Scene::fetchResults().
virtual IofxRenderable * | acquireRenderableReference ()=0
Acquire a pointer to the iofx's renderable proxy and increment its reference count.

Detailed Description

IOFX actor public interface.

Member Function Documentation

virtual IofxRenderable* nvidia::apex::IofxActor::acquireRenderableReference ( ) [pure virtual]

Acquire a pointer to the iofx's renderable proxy and increment its reference count.

The IofxRenderable will only be deleted when its reference count is zero. Calls to IofxRenderable::release decrement the reference count, as does a call to IofxActor::release().

The documentation for this class was generated from the following file:
  • IofxActor.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxActor
nvidia::apex::IofxActor Member List
This is the complete list of members for nvidia::apex::IofxActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireRenderableReference()=0 | nvidia::apex::IofxActor | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getBounds() const =0 | nvidia::apex::IofxActor | [pure virtual]
getIosAssetName() const =0 | nvidia::apex::IofxActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getObjectCount() const =0 | nvidia::apex::IofxActor | [pure virtual]
getObjectRadius() const =0 | nvidia::apex::IofxActor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getVisibleCount() const =0 | nvidia::apex::IofxActor | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxAsset
Public Member Functions
nvidia::apex::IofxAsset Class Reference

IOFX Asset public interface. Used to define the way the visual parameters are created from physical parameters of a particle. More...

#include <IofxAsset.h>

Inheritance diagram for nvidia::apex::IofxAsset:
nvidia::apex::Asset nvidia::apex::Context nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual const char * | getSpriteMaterialName () const =0
get the name of the material used for sprite-based particles visualization
virtual uint32_t | getMeshAssetCount () const =0
get the number of different mesh assets used for mesh-based particles visualization
virtual const char * | getMeshAssetName (uint32_t index=0) const =0
virtual uint32_t | getMeshAssetWeight (uint32_t index=0) const =0
virtual const Modifier * | getSpawnModifiers (uint32_t &outCount) const =0
get the list of spawn modifiers
virtual const Modifier * | getContinuousModifiers (uint32_t &outCount) const =0
get the list of continuous modifiers
virtual float | getScaleUpperBound (float maxVelocity) const =0
virtual void | addDependentActor (ApexActor *actor)=0

Detailed Description

IOFX Asset public interface. Used to define the way the visual parameters are created from physical parameters of a particle.

Member Function Documentation

virtual void nvidia::apex::IofxAsset::addDependentActor ( ApexActor * actor ) [pure virtual]

the IOFX asset needs to inform other actors when it is released

Note:
only for internal use
virtual const char* nvidia::apex::IofxAsset::getMeshAssetName ( uint32_t index = 0 ) const [pure virtual]

get the name of one of the mesh assets used for mesh-based particles visualization

Parameters:
index mesh asset internal index
virtual uint32_t nvidia::apex::IofxAsset::getMeshAssetWeight ( uint32_t index = 0 ) const [pure virtual]

get the weight of one of the mesh assets used for mesh-based particles visualization. Can be any value; not normalized.

Parameters:
index mesh asset internal index
virtual float nvidia::apex::IofxAsset::getScaleUpperBound ( float maxVelocity ) const [pure virtual]

get the biggest possible scale given the current spawn- and continuous modifiers note that some modifiers depend on velocity, so the scale can get arbitrarily large.

Parameters:
maxVelocity this value defines what the highest expected velocity is to compute the upper bound
The documentation for this class was generated from the following file:
  • IofxAsset.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxAsset
nvidia::apex::IofxAsset Member List
This is the complete list of members for nvidia::apex::IofxAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
addDependentActor(ApexActor *actor)=0 | nvidia::apex::IofxAsset | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
createRenderableIterator()=0 | nvidia::apex::Context | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getContinuousModifiers(uint32_t &outCount) const =0 | nvidia::apex::IofxAsset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getMeshAssetCount() const =0 | nvidia::apex::IofxAsset | [pure virtual]
getMeshAssetName(uint32_t index=0) const =0 | nvidia::apex::IofxAsset | [pure virtual]
getMeshAssetWeight(uint32_t index=0) const =0 | nvidia::apex::IofxAsset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
getScaleUpperBound(float maxVelocity) const =0 | nvidia::apex::IofxAsset | [pure virtual]
getSpawnModifiers(uint32_t &outCount) const =0 | nvidia::apex::IofxAsset | [pure virtual]
getSpriteMaterialName() const =0 | nvidia::apex::IofxAsset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseRenderableIterator(RenderableIterator &)=0 | nvidia::apex::Context | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
removeAllActors()=0 | nvidia::apex::Context | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~Context() (defined in nvidia::apex::Context) | nvidia::apex::Context | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxAssetAuthoring
nvidia::apex::IofxAssetAuthoring Class Reference

IOFX Asset Authoring public interface. More...

#include <IofxAsset.h>

Inheritance diagram for nvidia::apex::IofxAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

IOFX Asset Authoring public interface.

The documentation for this class was generated from the following file:
  • IofxAsset.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxAssetAuthoring
nvidia::apex::IofxAssetAuthoring Member List
This is the complete list of members for nvidia::apex::IofxAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxRenderCallback Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderCallback
Public Member Functions
nvidia::apex::IofxRenderCallback Class Reference

User defined callback for IOFX rendering. More...

#include <IofxRenderCallback.h>

Inheritance diagram for nvidia::apex::IofxRenderCallback:
nvidia::apex::UserRenderCallback

List of all members.

Public Member Functions

virtual void | onCreatedIofxRenderable (IofxRenderable &)
Called just after a new IOFX renderable was created.
virtual void | onUpdatedIofxRenderable (IofxRenderable &)
Called just after an IOFX renderable was updated.
virtual void | onReleasingIofxRenderable (IofxRenderable &)
Called just before an IOFX renderable is going to be released.
virtual bool | getIofxSpriteRenderLayout (IofxSpriteRenderLayout &spriteRenderLayout, uint32_t spriteCount, uint32_t spriteSemanticsBitmap, RenderInteropFlags::Enum interopFlags)
Called by the IOFX module to query layout for sprite rendering. Should return true in case IofxSpriteRenderLayout is properly filled, and then IOFX will pass this layout to createRender[Buffer|Surface] method(s) to create needed render resources. In case this method is not implemented and returns false the IOFX module will create a layout to hold all input semantics. Also in case this method is not implemented or/and createRender[Buffer|Surface] method is not implemented, then the IOFX module will create its own render buffer/surfaces which user can map to access rendering content.
virtual bool | getIofxMeshRenderLayout (IofxMeshRenderLayout &meshRenderLayout, uint32_t meshCount, uint32_t meshSemanticsBitmap, RenderInteropFlags::Enum interopFlags)
Called by the IOFX module to query layout for mesh rendering. Should return true in case IofxMeshRenderLayout is properly filled, and then IOFX will pass this layout to createRenderBuffer method to create needed render resources. In case this method is not implemented and returns false the IOFX module will create a layout to hold all input semantics. Also in case this method is not implemented or/and createRenderBuffer method is not implemented, then the IOFX module will create its own render buffer which user can map to access rendering content.

Detailed Description

User defined callback for IOFX rendering.

The documentation for this class was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderCallback
nvidia::apex::IofxRenderCallback Member List
This is the complete list of members for nvidia::apex::IofxRenderCallback, including all inherited members.
createRenderBuffer(const UserRenderBufferDesc &) | nvidia::apex::UserRenderCallback | [inline, virtual]
createRenderSurface(const UserRenderSurfaceDesc &) | nvidia::apex::UserRenderCallback | [inline, virtual]
getIofxMeshRenderLayout(IofxMeshRenderLayout &meshRenderLayout, uint32_t meshCount, uint32_t meshSemanticsBitmap, RenderInteropFlags::Enum interopFlags) | nvidia::apex::IofxRenderCallback | [inline, virtual]
getIofxSpriteRenderLayout(IofxSpriteRenderLayout &spriteRenderLayout, uint32_t spriteCount, uint32_t spriteSemanticsBitmap, RenderInteropFlags::Enum interopFlags) | nvidia::apex::IofxRenderCallback | [inline, virtual]
onCreatedIofxRenderable(IofxRenderable &) | nvidia::apex::IofxRenderCallback | [inline, virtual]
onReleasingIofxRenderable(IofxRenderable &) | nvidia::apex::IofxRenderCallback | [inline, virtual]
onUpdatedIofxRenderable(IofxRenderable &) | nvidia::apex::IofxRenderCallback | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxRenderable Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderable
Public Types | Public Member Functions
nvidia::apex::IofxRenderable Class Reference

The IOFX renderable represents a unit of rendering. It contains complete information to render a batch of particles with the same material/mesh in the same render volume. More...

#include <IofxRenderable.h>

Inheritance diagram for nvidia::apex::IofxRenderable:
nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Types

enum Type {
SPRITE,
MESH
}
Type of IOFX renderable. More...

Public Member Functions

virtual Type | getType () const =0
Return Type of this renderable.
virtual const
IofxSpriteRenderData * 		getSpriteRenderData () const =0
Return Sprite render data for Sprite renderable and NULL for other types.
virtual const IofxMeshRenderData * | getMeshRenderData () const =0
Return Mesh render data for Mesh renderable and NULL for other types.
virtual const physx::PxBounds3 & | getBounds () const =0
Return AABB of this renderable.

Detailed Description

The IOFX renderable represents a unit of rendering. It contains complete information to render a batch of particles with the same material/mesh in the same render volume.

Member Enumeration Documentation

enum nvidia::apex::IofxRenderable::Type

Type of IOFX renderable.

Enumerator:
SPRITE

Sprite particles type.

MESH

Mesh particles type.

The documentation for this class was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderable
nvidia::apex::IofxRenderable Member List
This is the complete list of members for nvidia::apex::IofxRenderable, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getBounds() const =0 | nvidia::apex::IofxRenderable | [pure virtual]
getMeshRenderData() const =0 | nvidia::apex::IofxRenderable | [pure virtual]
getSpriteRenderData() const =0 | nvidia::apex::IofxRenderable | [pure virtual]
getType() const =0 | nvidia::apex::IofxRenderable | [pure virtual]
MESH enum value | nvidia::apex::IofxRenderable |
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
SPRITE enum value | nvidia::apex::IofxRenderable |
Type enum name | nvidia::apex::IofxRenderable |
userData | nvidia::apex::ApexInterface |
~IofxRenderable() (defined in nvidia::apex::IofxRenderable) | nvidia::apex::IofxRenderable | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxRenderableIterator Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderableIterator
Public Member Functions
nvidia::apex::IofxRenderableIterator Class Reference

Iterate over all renderables in IOFX module. IMPORTANT: release() should be called for each returned not-NULL renderable! More...

#include <ModuleIofx.h>

Inheritance diagram for nvidia::apex::IofxRenderableIterator:
nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual IofxRenderable * | getFirst ()=0
Return the first renderable in IOFX module.
virtual IofxRenderable * | getNext ()=0
Return the next renderable IOFX module.

Detailed Description

Iterate over all renderables in IOFX module. IMPORTANT: release() should be called for each returned not-NULL renderable!

The documentation for this class was generated from the following file:
  • ModuleIofx.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderableIterator
nvidia::apex::IofxRenderableIterator Member List
This is the complete list of members for nvidia::apex::IofxRenderableIterator, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getFirst()=0 | nvidia::apex::IofxRenderableIterator | [pure virtual]
getNext()=0 | nvidia::apex::IofxRenderableIterator | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::IosAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IosAsset
Public Member Functions
nvidia::apex::IosAsset Class Reference

The base class of all Instanced Object Simulation classes. More...

#include <IosAsset.h>

Inheritance diagram for nvidia::apex::IosAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable nvidia::apex::BasicIosAsset nvidia::apex::ParticleIosAsset

List of all members.

Public Member Functions

virtual Actor * | createIosActor (Scene &scene, IofxAsset *iofxAsset)=0
create a generic IOS Actor in a specific Scene
virtual void | releaseIosActor (Actor &actor)=0
release a generic IOS Actor
virtual bool | getSupportsDensity () const =0
get supports density

Detailed Description

The base class of all Instanced Object Simulation classes.

The documentation for this class was generated from the following file:
  • IosAsset.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IosAsset
nvidia::apex::IosAsset Member List
This is the complete list of members for nvidia::apex::IosAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
createIosActor(Scene &scene, IofxAsset *iofxAsset)=0 | nvidia::apex::IosAsset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
getSupportsDensity() const =0 | nvidia::apex::IosAsset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseIosActor(Actor &actor)=0 | nvidia::apex::IosAsset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::JetFSActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • JetFSActor
Public Member Functions
nvidia::apex::JetFSActor Class Reference

JetFS Actor class. More...

#include <JetFSActor.h>

Inheritance diagram for nvidia::apex::JetFSActor:
nvidia::apex::Actor nvidia::apex::Renderable nvidia::apex::ApexInterface nvidia::apex::RenderDataProvider nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual BasicFSAsset * | getJetFSAsset () const =0
Returns the asset the instance has been created from.
virtual PxMat44 | getCurrentPose () const =0
Gets the current pose of the actor.
virtual void | setCurrentPose (const PxTransform &pose)=0
Sets the current pose of the actor.
virtual PxVec3 | getCurrentPosition () const =0
Gets the current position of the actor.
virtual void | setCurrentPosition (const PxVec3 &pos)=0
Sets the current position of the actor.
virtual float | getCurrentScale () const =0
Gets the current scale of the actor.
virtual void | setCurrentScale (const float &scale)=0
Sets the current scale of the actor.
virtual void | setFieldStrength (float)=0
Sets the field strength.
virtual void | setFieldDirection (const PxVec3 &)=0
Sets the field direction.
virtual void | setEnabled (bool isEnabled)=0
Enable/Disable the field simulation.

Detailed Description

JetFS Actor class.

The documentation for this class was generated from the following file:
  • JetFSActor.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • JetFSActor
nvidia::apex::JetFSActor Member List
This is the complete list of members for nvidia::apex::JetFSActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getCurrentPose() const =0 | nvidia::apex::JetFSActor | [pure virtual]
getCurrentPosition() const =0 | nvidia::apex::JetFSActor | [pure virtual]
getCurrentScale() const =0 | nvidia::apex::JetFSActor | [pure virtual]
getJetFSAsset() const =0 | nvidia::apex::JetFSActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setCurrentPose(const PxTransform &pose)=0 | nvidia::apex::JetFSActor | [pure virtual]
setCurrentPosition(const PxVec3 &pos)=0 | nvidia::apex::JetFSActor | [pure virtual]
setCurrentScale(const float &scale)=0 | nvidia::apex::JetFSActor | [pure virtual]
setEnabled(bool isEnabled)=0 | nvidia::apex::JetFSActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setFieldDirection(const PxVec3 &)=0 | nvidia::apex::JetFSActor | [pure virtual]
setFieldStrength(float)=0 | nvidia::apex::JetFSActor | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~JetFSActor() (defined in nvidia::apex::JetFSActor) | nvidia::apex::JetFSActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::JetFSPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • JetFSPreview
Public Member Functions
nvidia::apex::JetFSPreview Class Reference

This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

#include <JetFSPreview.h>

Inheritance diagram for nvidia::apex::JetFSPreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void setDetailLevel (uint32_t detail)=0

Detailed Description

This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually.

Member Function Documentation

virtual void nvidia::apex::JetFSPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable.
Any, all, or none of the following masks may be added together to select what should be drawn.
The defines for the individual items are:
JET_DRAW_NOTHING - draw nothing
JET_DRAW_SHAPE - draw the shape
JET_DRAW_ASSET_INFO - draw the turbulencefs asset info in the screen space
JET_DRAW_FULL_DETAIL - draw all components of the turbulencefs preview
All items may be drawn using the macro DRAW_FULL_DETAIL.

The documentation for this class was generated from the following file:
  • JetFSPreview.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • JetFSPreview
nvidia::apex::JetFSPreview Member List
This is the complete list of members for nvidia::apex::JetFSPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setDetailLevel(uint32_t detail)=0 | nvidia::apex::JetFSPreview | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::MaterialLookupCallback Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MaterialLookupCallback
Classes | Public Member Functions
nvidia::apex::MaterialLookupCallback Class Reference

a user calback interface used to map raycast hitpoints to material ID If an instance of this class is registered with a ground emitter actor, the actor will call requestMaterialLookups() in lieu of doing raycasts. The call will occur from within the scope of the ApexScene thread, so the callback must be thread safe. More...

#include <GroundEmitterActor.h>

List of all members.

Classes

struct | MaterialRequest
Material request structure. More...

Public Member Functions

virtual void | requestMaterialLookups (uint32_t requestCount, MaterialRequest *reqList)=0
Submit the meterial lookup request. This method is called by the emitter and implemented by the user.

Detailed Description

a user calback interface used to map raycast hitpoints to material ID If an instance of this class is registered with a ground emitter actor, the actor will call requestMaterialLookups() in lieu of doing raycasts. The call will occur from within the scope of the ApexScene thread, so the callback must be thread safe.

Member Function Documentation

virtual void nvidia::apex::MaterialLookupCallback::requestMaterialLookups | ( | uint32_t | requestCount,
 |  | MaterialRequest * | reqList
 | ) |  | [pure virtual]

Submit the meterial lookup request. This method is called by the emitter and implemented by the user.

Parameters:
requestCount | [IN] number of requests
reqList | [IN/OUT] the pointer to the requests. samplePosition is read and materialID is written to by the user.
The documentation for this class was generated from the following file:
  • GroundEmitterActor.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MaterialLookupCallback
nvidia::apex::MaterialLookupCallback Member List
This is the complete list of members for nvidia::apex::MaterialLookupCallback, including all inherited members.
requestMaterialLookups(uint32_t requestCount, MaterialRequest *reqList)=0 | nvidia::apex::MaterialLookupCallback | [pure virtual]
~MaterialLookupCallback() (defined in nvidia::apex::MaterialLookupCallback) | nvidia::apex::MaterialLookupCallback | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::MirrorScene Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MirrorScene
Classes | Public Member Functions
nvidia::apex::MirrorScene Class Reference

MirrorScene is used to create a selected mirrored copy of a primary scene. Works only with PhysX 3.x. More...

#include <MirrorScene.h>

List of all members.

Classes

class | MirrorFilter
MirrorFilter is a callback interface implemented by the application to confirm which actors and shapes are, or are not, replicated into the mirrored scene. More...

Public Member Functions

virtual void | synchronizePrimaryScene (const PxVec3 &cameraPos)=0
SynchronizePrimaryScene updates the positions of the objects around the camera relative to the static and dynamic distances specified These objects are then put in a thread safe queue to be processed when the mirror scene synchronize is called.
virtual void | synchronizeMirrorScene (void)=0
Processes the updates to get this mirrored scene to reflect the subset of the primary scene that is being mirrored. Completely thread safe, assumes that the primary scene and mirrored scene are most likely being run be completely separate threads.
virtual void | release (void)=0
Releases the MirrorScene class and all associated mirrored objects; it is important to not that this does *not* release the actual APEX scnee; simply the MirrorScene helper class.

Detailed Description

MirrorScene is used to create a selected mirrored copy of a primary scene. Works only with PhysX 3.x.

Member Function Documentation

virtual void nvidia::apex::MirrorScene::synchronizePrimaryScene ( const PxVec3 & cameraPos ) [pure virtual]

SynchronizePrimaryScene updates the positions of the objects around the camera relative to the static and dynamic distances specified These objects are then put in a thread safe queue to be processed when the mirror scene synchronize is called.

Parameters:
[in] cameraPos The current position of the camera relative to where objects are being mirrored
The documentation for this class was generated from the following file:
  • MirrorScene.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MirrorScene
nvidia::apex::MirrorScene Member List
This is the complete list of members for nvidia::apex::MirrorScene, including all inherited members.
release(void)=0 | nvidia::apex::MirrorScene | [pure virtual]
synchronizeMirrorScene(void)=0 | nvidia::apex::MirrorScene | [pure virtual]
synchronizePrimaryScene(const PxVec3 &cameraPos)=0 | nvidia::apex::MirrorScene | [pure virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::MirrorScene::MirrorFilter Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MirrorScene
  • MirrorFilter
Public Member Functions
nvidia::apex::MirrorScene::MirrorFilter Class Reference

MirrorFilter is a callback interface implemented by the application to confirm which actors and shapes are, or are not, replicated into the mirrored scene. More...

#include <MirrorScene.h>

List of all members.

Public Member Functions

virtual bool | shouldMirror (const PxActor &actor)=0
The application returns true if this actor should be mirrored into the secondary mirrored scene.
virtual bool | shouldMirror (const PxShape &shape)=0
The application returns true if this shape should be mirrored into the secondary mirrored scene.
virtual void | reviseMirrorShape (physx::PxShape &shape)=0
Affords the application with an opportunity to modify the contents/state of the shape before is placed into the mirrored scene.
virtual void | reviseMirrorActor (physx::PxActor &actor)=0
Affords the application with an opportunity to modify the contents/state of the actor before is placed into the mirrored scene.

Detailed Description

MirrorFilter is a callback interface implemented by the application to confirm which actors and shapes are, or are not, replicated into the mirrored scene.

Member Function Documentation

virtual void nvidia::apex::MirrorScene::MirrorFilter::reviseMirrorActor ( physx::PxActor & actor ) [pure virtual]

Affords the application with an opportunity to modify the contents/state of the actor before is placed into the mirrored scene.

Parameters:
[in] actor A reference to the actor that is about to be placed into the mirrored scene
virtual void nvidia::apex::MirrorScene::MirrorFilter::reviseMirrorShape ( physx::PxShape & shape ) [pure virtual]

Affords the application with an opportunity to modify the contents/state of the shape before is placed into the mirrored scene.

Parameters:
[in] shape A reference to the shape that is about to be placed into the mirrored scene.
virtual bool nvidia::apex::MirrorScene::MirrorFilter::shouldMirror ( const PxActor & actor ) [pure virtual]

The application returns true if this actor should be mirrored into the secondary mirrored scene.

Parameters:
[in] actor A const reference to the actor in the primary scene to be considered mirrored into the secondary scene.
virtual bool nvidia::apex::MirrorScene::MirrorFilter::shouldMirror ( const PxShape & shape ) [pure virtual]

The application returns true if this shape should be mirrored into the secondary mirrored scene.

Parameters:
[in] shape A const reference to the shape in the primary scene to be considered mirrored into the secondary scene.
The documentation for this class was generated from the following file:
  • MirrorScene.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MirrorScene
  • MirrorFilter
nvidia::apex::MirrorScene::MirrorFilter Member List
This is the complete list of members for nvidia::apex::MirrorScene::MirrorFilter, including all inherited members.
reviseMirrorActor(physx::PxActor &actor)=0 | nvidia::apex::MirrorScene::MirrorFilter | [pure virtual]
reviseMirrorShape(physx::PxShape &shape)=0 | nvidia::apex::MirrorScene::MirrorFilter | [pure virtual]
shouldMirror(const PxActor &actor)=0 | nvidia::apex::MirrorScene::MirrorFilter | [pure virtual]
shouldMirror(const PxShape &shape)=0 | nvidia::apex::MirrorScene::MirrorFilter | [pure virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::Modifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Modifier
Public Member Functions
nvidia::apex::Modifier Class Reference

Modifier contains all of the data necessary to apply a single modifier type to a particle system. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::Modifier:
nvidia::apex::ModifierT< ColorVsDensityModifier > nvidia::apex::ModifierT< ColorVsLifeModifier > nvidia::apex::ModifierT< ColorVsVelocityModifier > nvidia::apex::ModifierT< OrientAlongVelocityModifier > nvidia::apex::ModifierT< OrientScaleAlongScreenVelocityModifier > nvidia::apex::ModifierT< RandomRotationModifier > nvidia::apex::ModifierT< RandomScaleModifier > nvidia::apex::ModifierT< RandomSubtextureModifier > nvidia::apex::ModifierT< RotationModifier > nvidia::apex::ModifierT< RotationRateModifier > nvidia::apex::ModifierT< RotationRateVsLifeModifier > nvidia::apex::ModifierT< ScaleAlongVelocityModifier > nvidia::apex::ModifierT< ScaleByMassModifier > nvidia::apex::ModifierT< ScaleVsCameraDistanceModifier > nvidia::apex::ModifierT< ScaleVsDensityModifier > nvidia::apex::ModifierT< ScaleVsLifeModifier > nvidia::apex::ModifierT< SimpleScaleModifier > nvidia::apex::ModifierT< SubtextureVsLifeModifier > nvidia::apex::ModifierT< ViewDirectionSortingModifier > nvidia::apex::ModifierT< T >

List of all members.

Public Member Functions

virtual ModifierTypeEnum | getModifierType () const =0
getModifierType returns the enumerated type associated with this class.
virtual uint32_t | getModifierUsage () const =0
getModifierUsage returns the usage scenarios allowed for a particular modifier.
virtual uint32_t | getModifierSpriteSemantics ()
returns a bitmap that includes every sprite semantic that the modifier updates
virtual uint32_t | getModifierMeshSemantics ()
returns a bitmap that includes every mesh(instance) semantic that the modifier updates

Detailed Description

Modifier contains all of the data necessary to apply a single modifier type to a particle system.

Generally this combines some physical transformation with parameters specified at authoring time to modify the look of the final effect.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Modifier
nvidia::apex::Modifier Member List
This is the complete list of members for nvidia::apex::Modifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const =0 | nvidia::apex::Modifier | [pure virtual]
getModifierUsage() const =0 | nvidia::apex::Modifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ModifierT< T > Class Template Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModifierT
Public Member Functions
nvidia::apex::ModifierT< T > Class Template Reference

ModifierT is a helper class to handle the mapping of Type->Enum and Enum->Type. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ModifierT< T >:
nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ModifierTypeEnum | getModifierType () const
Returns ModifierType for typename T.
virtual uint32_t | getModifierUsage () const
Returns ModifierUsage for typename T.

Detailed Description

template<typename T>
class nvidia::apex::ModifierT< T >

ModifierT is a helper class to handle the mapping of Type->Enum and Enum->Type.

This imposes some structure on the subclasses--they all now expect to have a const static field called ModifierType.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModifierT
nvidia::apex::ModifierT< T > Member List
This is the complete list of members for nvidia::apex::ModifierT< T >, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< T > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< T > | [inline, virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::Module Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Module
Public Member Functions
nvidia::apex::Module Class Reference

base class of all APEX modules More...

#include <Module.h>

Inheritance diagram for nvidia::apex::Module:
nvidia::apex::ApexInterface nvidia::apex::RWLockable nvidia::apex::ModuleBasicFS nvidia::apex::ModuleBasicIos nvidia::apex::ModuleClothing nvidia::apex::ModuleDestructible nvidia::apex::ModuleEmitter nvidia::apex::ModuleFieldSampler nvidia::apex::ModuleForceField nvidia::apex::ModuleIofx nvidia::apex::ModuleIofxLegacy nvidia::apex::ModuleLoader nvidia::apex::ModuleParticleIos nvidia::apex::ModuleParticles nvidia::apex::ModuleTurbulenceFS

List of all members.

Public Member Functions

virtual void | init (::NvParameterized::Interface &desc)=0
Initialize the module.
virtual const char * | getName () const =0
Returns the name of the module.
virtual AuthObjTypeID | getModuleID () const =0
Returns the unique ID of the module.
virtual
::NvParameterized::Interface * 		getDefaultModuleDesc ()
Returns the NvParameterized interface that contains module initialization parameters.
virtual RenderableIterator * | createRenderableIterator (const Scene &)=0
Allocate a renderable iterator.
virtual bool | setRenderLockMode (RenderLockMode::Enum, Scene &)
Choose the locking mode for the module scene. See RenderLockMode.
virtual RenderLockMode::Enum | getRenderLockMode (const Scene &) const
Returns the current render lock mode for the module scene.
virtual bool | lockModuleSceneRenderLock (Scene &)
Sets a render lock for the module scene. Used when the SDK render lock mode is RenderLockMode::PER_MODULE_SCENE_RENDER_LOCK. See ApexSDK::setRenderLockMode().
virtual bool | unlockModuleSceneRenderLock (Scene &)
Releases the render lock for the module scene. See lockModuleSceneRenderLock().

Detailed Description

base class of all APEX modules

It describes the LODParameters and weights defined by the module.

Member Function Documentation

virtual RenderableIterator* nvidia::apex::Module::createRenderableIterator ( const Scene & ) [pure virtual]

Allocate a renderable iterator.

Returns an Renderable iterator instance for the specified Scene. The iterator will return pointers to renderables in this scene that were generated by this module. This is the preferred method for rendering IOFX actors.

virtual ::NvParameterized::Interface* nvidia::apex::Module::getDefaultModuleDesc ( ) [inline]

Returns the NvParameterized interface that contains module initialization parameters.

Note:
The module itself owns this object, so there's no need for the application to destroy it
virtual void nvidia::apex::Module::init ( ::NvParameterized::Interface & desc ) [pure virtual]

Initialize the module.

Parameters:
[in] desc use Module::getDefaultModuleDesc() to get the descriptor necessary for initializing the module
virtual bool nvidia::apex::Module::lockModuleSceneRenderLock ( Scene & ) [inline, virtual]

Sets a render lock for the module scene. Used when the SDK render lock mode is RenderLockMode::PER_MODULE_SCENE_RENDER_LOCK. See ApexSDK::setRenderLockMode().

Returns true iff successful.

virtual bool nvidia::apex::Module::setRenderLockMode | ( | RenderLockMode::Enum | ,
 |  | Scene & |
 | ) |  | [inline, virtual]

Choose the locking mode for the module scene. See RenderLockMode.

Returns true if successful.

virtual bool nvidia::apex::Module::unlockModuleSceneRenderLock ( Scene & ) [inline, virtual]

Releases the render lock for the module scene. See lockModuleSceneRenderLock().

Returns true iff successful.

The documentation for this class was generated from the following file:
  • Module.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Module
nvidia::apex::Module Member List
This is the complete list of members for nvidia::apex::Module, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ModuleBasicFS Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleBasicFS
nvidia::apex::ModuleBasicFS Class Reference

BasicFS module class. More...

#include <ModuleBasicFS.h>

Inheritance diagram for nvidia::apex::ModuleBasicFS:
nvidia::apex::Module nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

BasicFS module class.

The documentation for this class was generated from the following file:
  • ModuleBasicFS.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleBasicFS
nvidia::apex::ModuleBasicFS Member List
This is the complete list of members for nvidia::apex::ModuleBasicFS, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
~ModuleBasicFS() (defined in nvidia::apex::ModuleBasicFS) | nvidia::apex::ModuleBasicFS | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::ModuleBasicIos Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleBasicIos
Public Member Functions
nvidia::apex::ModuleBasicIos Class Reference

BasicIOS Module. More...

#include <ModuleBasicIos.h>

Inheritance diagram for nvidia::apex::ModuleBasicIos:
nvidia::apex::Module nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual const char * | getBasicIosTypeName ()=0
Get BasicIOS authoring type name.
virtual const TestBase * | getTestBase (Scene *apexScene) const =0
Get TestBase implementation of BasicIos scene.

Detailed Description

BasicIOS Module.

The documentation for this class was generated from the following file:
  • ModuleBasicIos.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleBasicIos
nvidia::apex::ModuleBasicIos Member List
This is the complete list of members for nvidia::apex::ModuleBasicIos, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
getBasicIosTypeName()=0 | nvidia::apex::ModuleBasicIos | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
getTestBase(Scene *apexScene) const =0 | nvidia::apex::ModuleBasicIos | [pure virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
~ModuleBasicIos() (defined in nvidia::apex::ModuleBasicIos) | nvidia::apex::ModuleBasicIos | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ModuleCachedData Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleCachedData
Public Member Functions
nvidia::apex::ModuleCachedData Class Reference

Cached data is stored per-module. More...

#include <ApexSDKCachedData.h>

List of all members.

Public Member Functions

virtual
::NvParameterized::Interface * 		getCachedDataForAssetAtScale (Asset &asset, const PxVec3 &scale)=0
Retreives the cached data for the asset, if it exists.
virtual PxFileBuf & | serializeSingleAsset (Asset &asset, PxFileBuf &stream)=0
Serializes the cooked data for a single asset into a stream.
virtual PxFileBuf & | deserializeSingleAsset (Asset &asset, PxFileBuf &stream)=0
Deserializes the cooked data for a single asset from a stream.

Detailed Description

Cached data is stored per-module.

Member Function Documentation

virtual ::NvParameterized::Interface* nvidia::apex::ModuleCachedData::getCachedDataForAssetAtScale | ( | Asset & | asset,
 |  | const PxVec3 & | scale
 | ) |  | [pure virtual]

Retreives the cached data for the asset, if it exists.

Otherwise returns NULL.

The documentation for this class was generated from the following file:
  • ApexSDKCachedData.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleCachedData
nvidia::apex::ModuleCachedData Member List
This is the complete list of members for nvidia::apex::ModuleCachedData, including all inherited members.
deserializeSingleAsset(Asset &asset, PxFileBuf &stream)=0 | nvidia::apex::ModuleCachedData | [pure virtual]
getCachedDataForAssetAtScale(Asset &asset, const PxVec3 &scale)=0 | nvidia::apex::ModuleCachedData | [pure virtual]
serializeSingleAsset(Asset &asset, PxFileBuf &stream)=0 | nvidia::apex::ModuleCachedData | [pure virtual]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::ModuleClothing Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleClothing
Public Member Functions
nvidia::apex::ModuleClothing Class Reference

APEX Clothing Module. More...

#include <ModuleClothing.h>

Inheritance diagram for nvidia::apex::ModuleClothing:
nvidia::apex::Module nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual ClothingPhysicalMesh * | createEmptyPhysicalMesh ()=0
creates an empty physical mesh. A custom mesh can be assigned to it.
virtual ClothingPhysicalMesh * | createSingleLayeredMesh (RenderMeshAssetAuthoring *asset, uint32_t subdivision, bool mergeVertices, bool closeHoles, IProgressListener *progress)=0
creates a physical mesh based on a render mesh asset. This will be a 1 to 1 copy of the render mesh

Detailed Description

APEX Clothing Module.

Used to generate simulated clothing on (mostly humanoid) characters.

Member Function Documentation

virtual ClothingPhysicalMesh* nvidia::apex::ModuleClothing::createSingleLayeredMesh | ( | RenderMeshAssetAuthoring * | asset,
 |  | uint32_t | subdivision,
 |  | bool | mergeVertices,
 |  | bool | closeHoles,
 |  | IProgressListener * | progress
 | ) |  | [pure virtual]

creates a physical mesh based on a render mesh asset. This will be a 1 to 1 copy of the render mesh

Parameters:
[in] | asset | The render mesh that is used as source for the physical mesh
[in] | subdivision | Modify the physical mesh such that all edges that are longer than (bounding box diagonal / subdivision) are split up. Must be <= 200
[in] | mergeVertices | All vertices with the same position will be welded together.
[in] | closeHoles | Close any hole found in the mesh.
[in] | progress | An optional callback for progress display.
The documentation for this class was generated from the following file:
  • ModuleClothing.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleClothing
nvidia::apex::ModuleClothing Member List
This is the complete list of members for nvidia::apex::ModuleClothing, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createEmptyPhysicalMesh()=0 | nvidia::apex::ModuleClothing | [pure virtual]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
createSingleLayeredMesh(RenderMeshAssetAuthoring *asset, uint32_t subdivision, bool mergeVertices, bool closeHoles, IProgressListener *progress)=0 | nvidia::apex::ModuleClothing | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
~ModuleClothing() (defined in nvidia::apex::ModuleClothing) | nvidia::apex::ModuleClothing | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ModuleDestructible Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleDestructible
Public Member Functions
nvidia::apex::ModuleDestructible Class Reference

#include <ModuleDestructible.h>

Inheritance diagram for nvidia::apex::ModuleDestructible:
nvidia::apex::Module nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual DestructibleActorJoint * | createDestructibleActorJoint (const DestructibleActorJointDesc &desc, Scene &scene)=0
virtual bool | isDestructibleActorJointActive (const DestructibleActorJoint *candidateJoint, Scene &apexScene) const =0
virtual void | setMaxDynamicChunkIslandCount (uint32_t maxCount)=0
virtual void | setMaxChunkCount (uint32_t maxCount)=0
virtual void | setSortByBenefit (bool sortByBenefit)=0
virtual void | setValidBoundsPadding (float pad)=0
virtual void | setMaxChunkDepthOffset (uint32_t maxChunkDepthOffset)=0
virtual void | setMaxChunkSeparationLOD (float separationLOD)=0
virtual void | setChunkReport (UserChunkReport *chunkReport)=0
virtual void | setImpactDamageReportCallback (UserImpactDamageReport *impactDamageReport)=0
virtual void | setChunkReportBitMask (uint32_t chunkReportBitMask)=0
virtual void | setDestructiblePhysXActorReport (UserDestructiblePhysXActorReport *destructiblePhysXActorReport)=0
virtual void | setChunkReportMaxFractureEventDepth (uint32_t chunkReportMaxFractureEventDepth)=0
virtual void | scheduleChunkStateEventCallback (DestructibleCallbackSchedule::Enum chunkStateEventCallbackSchedule)=0
virtual void | setChunkCrumbleReport (UserChunkParticleReport *chunkCrumbleReport)=0
virtual void | setChunkDustReport (UserChunkParticleReport *chunkDustReport)=0
virtual void | setWorldSupportPhysXScene (Scene &apexScene, PxScene *physxScene)=0
virtual bool | owns (const PxRigidActor *actor) const =0
virtual bool | isRuntimeFractureShape (const PxShape &shape) const =0
virtual DestructibleActor * | getDestructibleAndChunk (const PxShape *shape, int32_t *chunkIndex=NULL) const =0
virtual void | applyRadiusDamage (Scene &scene, float damage, float momentum, const PxVec3 &position, float radius, bool falloff)=0
virtual void | setMaxActorCreatesPerFrame (uint32_t maxActorsPerFrame)=0
virtual void | setMaxFracturesProcessedPerFrame (uint32_t maxFracturesProcessedPerFrame)=0
virtual bool | setSyncParams (UserDestructibleSyncHandler< DamageEventHeader > *userDamageEventHandler, UserDestructibleSyncHandler< FractureEventHeader > *userFractureEventHandler, UserDestructibleSyncHandler< ChunkTransformHeader > *userChunkMotionHandler)=0
virtual void | setUseLegacyChunkBoundsTesting (bool useLegacyChunkBoundsTesting)=0
virtual void | setUseLegacyDamageRadiusSpread (bool useLegacyDamageRadiusSpread)=0
virtual bool | setMassScaling (float massScale, float scaledMassExponent, Scene &apexScene)=0
virtual void | invalidateBounds (const PxBounds3 *bounds, uint32_t boundsCount, Scene &apexScene)=0
virtual void | setDamageApplicationRaycastFlags (nvidia::DestructibleActorRaycastFlags::Enum flags, Scene &apexScene)=0
virtual bool | setChunkCollisionHullCookingScale (const PxVec3 &scale)=0
virtual PxVec3 | getChunkCollisionHullCookingScale () const =0
virtual class FractureToolsAPI * | getFractureTools () const =0
Get reference to FractureTools object.

Detailed Description

Descriptor used to create the Destructible APEX module.

Member Function Documentation

virtual void nvidia::apex::ModuleDestructible::applyRadiusDamage | ( | Scene & | scene,
 |  | float | damage,
 |  | float | momentum,
 |  | const PxVec3 & | position,
 |  | float | radius,
 |  | bool | falloff
 | ) |  | [pure virtual]

Applies damage to all DestructibleActors within the given radius in the apex scene. damage = the amount of damage at the damage point momentum = the magnitude of the impulse to transfer to each chunk position = the damage location radius = distance from damage location at which chunks will be affected falloff = whether or not to decrease damage with distance from the damage location. If true, damage will decrease linearly from the full damage (at zero distance) to zero damage (at radius). If false, full damage is applied to all chunks within the radius.

virtual DestructibleActorJoint* nvidia::apex::ModuleDestructible::createDestructibleActorJoint | ( | const DestructibleActorJointDesc & | desc,
 |  | Scene & | scene
 | ) |  | [pure virtual]

Object creation Create an DestructibleActorJoint from the descriptor. (See DestructibleActorJoint and DestructibleActorJointDesc.) This module will own the DestructibleActorJoint, so that any DestructibleAsset created by it will be released when this module is released. You may also call the DestructibleActorJoint's release() method, as long as the DestructibleActorJoint is still valid in the scene. (See isDestructibleActorJointActive())

virtual PxVec3 nvidia::apex::ModuleDestructible::getChunkCollisionHullCookingScale ( ) const [pure virtual]

Retrieves the cooking scale used for PhysX3 collision hulls, which can be set by setChunkCollisionHullCookingScale.

virtual DestructibleActor* nvidia::apex::ModuleDestructible::getDestructibleAndChunk | ( | const PxShape * | shape,
 |  | int32_t * | chunkIndex = NULL
 | ) |  | const [pure virtual]

PhysX SDK 3.X. Given an PxShape, returns the DestructibleActor and chunkIndex which belong to it, if the shape's PxActor is owned by the Destructible module (see the 'owns' function, above). Otherwise returns NULL. Useful when a scene query such as a raycast returns a shape.

virtual void nvidia::apex::ModuleDestructible::invalidateBounds | ( | const PxBounds3 * | bounds,
 |  | uint32_t | boundsCount,
 |  | Scene & | apexScene
 | ) |  | [pure virtual]

If a static PhysX actor is about to be removed, or has just been added, to the scene, then world support may change. Use this function to notify the destruction module that it may need to reconsider world support in the given volumes. This may be called multiple times, and the bounds list will accumulate. This list will be processed upon the next APEX simulate call, and cleared.

virtual bool nvidia::apex::ModuleDestructible::isDestructibleActorJointActive | ( | const DestructibleActorJoint * | candidateJoint,
 |  | Scene & | apexScene
 | ) |  | const [pure virtual]

Query the module on the validity of a created DestructibleActorJoint. A DestructibleActorJoint will no longer be valid when it is destroyed in the scene, in which case the module calls the DestructibleActorJoint's release(). Therefore, this DestructibleActorJoint should no longer be referenced if it is not valid.

virtual bool nvidia::apex::ModuleDestructible::isRuntimeFractureShape ( const PxShape & shape ) const [pure virtual]

PhysX SDK 3.X. Returns true iff the PxShape was created by the runtime fracture system.

virtual bool nvidia::apex::ModuleDestructible::owns ( const PxRigidActor * actor ) const [pure virtual]

PhysX SDK 3.X. Returns true iff the PxRigidActor was created by the Destructible module. If true, the user must NOT destroy the actor.

virtual void nvidia::apex::ModuleDestructible::scheduleChunkStateEventCallback ( DestructibleCallbackSchedule::Enum chunkStateEventCallbackSchedule ) [pure virtual]

Set whether or not the UserChunkReport::onStateChangeNotify interface will be used to deliver visibility change data to the user.

Default = DestructibleCallbackSchedule::Disabled.

virtual bool nvidia::apex::ModuleDestructible::setChunkCollisionHullCookingScale ( const PxVec3 & scale ) [pure virtual]

In PhysX 3.x, scaling of collision shapes can be done in the shape, not the cooked hull data. As a consequence, each collision hull only needs to be cooked once. By default, this hull is not scaled from the original data. But if the user desires, the hull can be scaled before cooking. That scale will be removed from the DestructibleActor's scale before being applied to the shape using the hull. So ideally, this user-set cooking scale does nothing. Numerically, however, it may have an effect, so we leave it as an option.

The input scale must be positive in all components. If not, the cooking scale will not be set, and the function returns false. Otherwise, the scale is set and the function returns true.

virtual void nvidia::apex::ModuleDestructible::setChunkCrumbleReport ( UserChunkParticleReport * chunkCrumbleReport ) [pure virtual]

Sets the user chunk crumble particle buffer callback. See UserChunkParticleReport. Set to NULL (the default) to disable. APEX does not take ownership of the report object.

virtual void nvidia::apex::ModuleDestructible::setChunkDustReport ( UserChunkParticleReport * chunkDustReport ) [pure virtual]

Sets the user chunk dust particle buffer callback. See UserChunkParticleReport. Set to NULL (the default) to disable. APEX does not take ownership of the report object.

Note - this is a placeholder API. The dust feature is disabled in 1.2.0.

virtual void nvidia::apex::ModuleDestructible::setChunkReport ( UserChunkReport * chunkReport ) [pure virtual]

General Sets the user chunk fracture/destroy callback. See UserChunkReport. Set to NULL (the default) to disable. APEX does not take ownership of the report object.

virtual void nvidia::apex::ModuleDestructible::setChunkReportBitMask ( uint32_t chunkReportBitMask ) [pure virtual]

Set a bit mask of flags (see ApexChunkFlag) for the fracture/destroy callback (See setChunkReport.) Fracture events with flags that overlap this mask will contribute to the DamageEventReportData.

virtual void nvidia::apex::ModuleDestructible::setChunkReportMaxFractureEventDepth ( uint32_t chunkReportMaxFractureEventDepth ) [pure virtual]

Set the maximum depth at which individual chunk fracture events will be reported in an DamageEventReportData's fractureEventList through the UserChunkReport. Fracture events deeper than this will still contribute to the DamageEventReportData's worldBounds and totalNumberOfFractureEvents.

virtual void nvidia::apex::ModuleDestructible::setDamageApplicationRaycastFlags | ( | nvidia::DestructibleActorRaycastFlags::Enum | flags,
 |  | Scene & | apexScene
 | ) |  | [pure virtual]

When applyDamage, or damage from impact, is processed, a rayCast call is used internally to find a more accurate damage position. This allows the user to specify the rayCast behavior. If no flags are set, no raycasting is done. Raycasting will be peformed against static or dynamic chunks, or both, depending on the value of flags. The flags are defined by DestructibleActorRaycastFlags::Enum.

The default flag used is DestructibleActorRaycastFlags::StaticChunks, since static-only raycasts are faster than ones that include dynamic chunks.

Note: only the flags DestructibleActorRaycastFlags::NoChunks, StaticChunks, and DynamicChunks are considered.

virtual void nvidia::apex::ModuleDestructible::setDestructiblePhysXActorReport ( UserDestructiblePhysXActorReport * destructiblePhysXActorReport ) [pure virtual]

Sets the user callback to receive PhysX actor create/release notifications for destruction-associated PhysX actors. Set to NULL (the default) to disable.

virtual void nvidia::apex::ModuleDestructible::setImpactDamageReportCallback ( UserImpactDamageReport * impactDamageReport ) [pure virtual]

Sets the user impact damage report callback. See UserImpactDamageReport. Set to NULL (the default) to disable. APEX does not take ownership of the report object.

virtual bool nvidia::apex::ModuleDestructible::setMassScaling | ( | float | massScale,
 |  | float | scaledMassExponent,
 |  | Scene & | apexScene
 | ) |  | [pure virtual]

Sets mass scaling properties in a given apex scene.

massScale and scaledMassExponent are used for scaling dynamic chunk masses. The 'real' mass m of a chunk is calculated by the destructible actor's density multiplied by the total volume of the chunk's (scaled) collision shapes. The mass used in the simulation is massScale*pow(m/massScale,scaledMassExponent). Values less than 1 have the effect of reducing the ratio of different masses. The closer scaledMassExponent is to zero, the more the ratio will be 'flattened.' This helps PhysX converge when there is a very large number of interacting rigid bodies (such as a pile of destructible chunks).

massScale valid range: (0,infinity). Default = 1.0. scaledMassExponent valid range: [0,1]. Default = 0.5.

Returns true iff the parameters are valid and the apexScene is valid.

virtual void nvidia::apex::ModuleDestructible::setMaxActorCreatesPerFrame ( uint32_t maxActorsPerFrame ) [pure virtual]

Lets the user throttle the number of SDK actor creates per frame (per scene) due to destruction, as this can be quite costly. The default is 0xffffffff (unlimited).

virtual void nvidia::apex::ModuleDestructible::setMaxChunkCount ( uint32_t maxCount ) [pure virtual]

The maximum number of allowed visible chunks in the scene. If a fracturing event would cause more chunks to be created, then PxActors are released to make room for the created chunks. The priority for released PxActors is the same as described in setMaxDynamicChunkIslandCount.

virtual void nvidia::apex::ModuleDestructible::setMaxChunkDepthOffset ( uint32_t maxChunkDepthOffset ) [pure virtual]

Effectively eliminates the deeper level (smaller) chunks from DestructibleAssets (see DestructibleAsset). If maxChunkDepthOffset = 0, all chunks can be fractured. If maxChunkDepthOffset = 1, the depest level (smallest) chunks are eliminated, etc. This prevents too many chunks from being formed. In other words, the higher maxChunkDepthOffset, the lower the "level of detail."

virtual void nvidia::apex::ModuleDestructible::setMaxChunkSeparationLOD ( float separationLOD ) [pure virtual]

Every destructible asset defines a min and max lifetime, and maximum separation distance for its chunks. Chunk islands are destroyed after this time or separation from their origins. This parameter sets the lifetimes and max separations within their min-max ranges. The valid range is [0,1]. Default is 0.5.

virtual void nvidia::apex::ModuleDestructible::setMaxDynamicChunkIslandCount ( uint32_t maxCount ) [pure virtual]

LOD The maximum number of allowed PxActors which represent dynamic groups of chunks. If a fracturing event would cause more PxActors to be created, then some PxActors are released and the chunks they represent destroyed. The PxActors released to make room for others depends on the priority mode. If sorting by benefit (see setSortByBenefit), then chunks with the lowest LOD benefit are released first. Otherwise, oldest chunks are released first.

virtual void nvidia::apex::ModuleDestructible::setMaxFracturesProcessedPerFrame ( uint32_t maxFracturesProcessedPerFrame ) [pure virtual]

Lets the user throttle the number of fractures processed per frame (per scene) due to destruction, as this can be quite costly. The default is 0xffffffff (unlimited).

virtual void nvidia::apex::ModuleDestructible::setSortByBenefit ( bool sortByBenefit ) [pure virtual]

Instead of keeping the youngest PxActors, keep the greatest benefit PxActors if sortByBenefit is true. By default, this module does not sort by benefit. That is, oldest PxActors are released first.

virtual bool nvidia::apex::ModuleDestructible::setSyncParams | ( | UserDestructibleSyncHandler< DamageEventHeader > * | userDamageEventHandler,
 |  | UserDestructibleSyncHandler< FractureEventHeader > * | userFractureEventHandler,
 |  | UserDestructibleSyncHandler< ChunkTransformHeader > * | userChunkMotionHandler
 | ) |  | [pure virtual]

Set the callback pointers from which APEX will use to return sync-able data.

virtual void nvidia::apex::ModuleDestructible::setUseLegacyChunkBoundsTesting ( bool useLegacyChunkBoundsTesting ) [pure virtual]

The following functions control the use of legacy behavior. By default, destruction damage application (either point or radius damage) now use the exact collision bounds of the chunk to determine damage application. Before, bounding spheres were used on "leaf" chunks (deepest in the fracture hierarchy) and only the bounding sphere center (effectively radius 0) was used on all chunks higher in the hierarchy. This led to inconsistent behavior when damaging destructibles at various levels of detail.

If true is passed into this function, the legacy behavior is restored.

virtual void nvidia::apex::ModuleDestructible::setUseLegacyDamageRadiusSpread ( bool useLegacyDamageRadiusSpread ) [pure virtual]

By default, the BehaviorGroup fields damageSpread.minimumRadius, damageSpread.radiusMultiplier, and damageSpread.falloffExponent are used for point and radius damage. Impact damage still uses damageToRadius, but this radius does not scale with the size of the destructible.

The old, deprecated behavior was to base damage spread upon the damageToRadius field of the BehaviorGroup used by the chunk. Specifically, damage would spread throughout a damage radius calculated as radius = damageToRadius * (damage / damageThreshold) * (size of destructible).

If true is passed into this function, the legacy behavior is restored.

virtual void nvidia::apex::ModuleDestructible::setValidBoundsPadding ( float pad ) [pure virtual]

Deprecated

virtual void nvidia::apex::ModuleDestructible::setWorldSupportPhysXScene | ( | Scene & | apexScene,
 |  | PxScene * | physxScene
 | ) |  | [pure virtual]

PhysX SDK 3.X. Allows the user to specify an alternative PhysX scene to use for world support calculations. If NULL (the default), the PhysX scene associated with the Scene will be used.

The documentation for this class was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleDestructible
nvidia::apex::ModuleDestructible Member List
This is the complete list of members for nvidia::apex::ModuleDestructible, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
applyRadiusDamage(Scene &scene, float damage, float momentum, const PxVec3 &position, float radius, bool falloff)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
createDestructibleActorJoint(const DestructibleActorJointDesc &desc, Scene &scene)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
getChunkCollisionHullCookingScale() const =0 | nvidia::apex::ModuleDestructible | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getDestructibleAndChunk(const PxShape *shape, int32_t *chunkIndex=NULL) const =0 | nvidia::apex::ModuleDestructible | [pure virtual]
getFractureTools() const =0 | nvidia::apex::ModuleDestructible | [pure virtual]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
invalidateBounds(const PxBounds3 *bounds, uint32_t boundsCount, Scene &apexScene)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
isDestructibleActorJointActive(const DestructibleActorJoint *candidateJoint, Scene &apexScene) const =0 | nvidia::apex::ModuleDestructible | [pure virtual]
isRuntimeFractureShape(const PxShape &shape) const =0 | nvidia::apex::ModuleDestructible | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
owns(const PxRigidActor *actor) const =0 | nvidia::apex::ModuleDestructible | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
scheduleChunkStateEventCallback(DestructibleCallbackSchedule::Enum chunkStateEventCallbackSchedule)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setChunkCollisionHullCookingScale(const PxVec3 &scale)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setChunkCrumbleReport(UserChunkParticleReport *chunkCrumbleReport)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setChunkDustReport(UserChunkParticleReport *chunkDustReport)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setChunkReport(UserChunkReport *chunkReport)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setChunkReportBitMask(uint32_t chunkReportBitMask)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setChunkReportMaxFractureEventDepth(uint32_t chunkReportMaxFractureEventDepth)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setDamageApplicationRaycastFlags(nvidia::DestructibleActorRaycastFlags::Enum flags, Scene &apexScene)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setDestructiblePhysXActorReport(UserDestructiblePhysXActorReport *destructiblePhysXActorReport)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setImpactDamageReportCallback(UserImpactDamageReport *impactDamageReport)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMassScaling(float massScale, float scaledMassExponent, Scene &apexScene)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMaxActorCreatesPerFrame(uint32_t maxActorsPerFrame)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMaxChunkCount(uint32_t maxCount)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMaxChunkDepthOffset(uint32_t maxChunkDepthOffset)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMaxChunkSeparationLOD(float separationLOD)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMaxDynamicChunkIslandCount(uint32_t maxCount)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setMaxFracturesProcessedPerFrame(uint32_t maxFracturesProcessedPerFrame)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
setSortByBenefit(bool sortByBenefit)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setSyncParams(UserDestructibleSyncHandler< DamageEventHeader > *userDamageEventHandler, UserDestructibleSyncHandler< FractureEventHeader > *userFractureEventHandler, UserDestructibleSyncHandler< ChunkTransformHeader > *userChunkMotionHandler)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setUseLegacyChunkBoundsTesting(bool useLegacyChunkBoundsTesting)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setUseLegacyDamageRadiusSpread(bool useLegacyDamageRadiusSpread)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setValidBoundsPadding(float pad)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
setWorldSupportPhysXScene(Scene &apexScene, PxScene *physxScene)=0 | nvidia::apex::ModuleDestructible | [pure virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
~ModuleDestructible() (defined in nvidia::apex::ModuleDestructible) | nvidia::apex::ModuleDestructible | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::ModuleEmitter Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleEmitter
Public Member Functions
nvidia::apex::ModuleEmitter Class Reference

An APEX Module that provides generic Emitter classes. More...

#include <ModuleEmitter.h>

Inheritance diagram for nvidia::apex::ModuleEmitter:
nvidia::apex::Module nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual float | getRateScale () const =0
get rate scale. Rate parameter in all emitters will be multiplied by rate scale.
virtual float | getDensityScale () const =0
get density scale. Density parameter in all emitters except ground emitters will be multiplied by density scale.
virtual float | getGroundDensityScale () const =0
get ground density scale. Density parameter in all ground emitters will be multiplied by ground density scale.
virtual void | setRateScale (float rateScale)=0
set rate scale. Rate parameter in all module emitters will be multiplied by rate scale.
virtual void | setDensityScale (float densityScale)=0
set density scale. Density parameter in all emitters except ground emitters will be multiplied by density scale.
virtual void | setGroundDensityScale (float groundDensityScale)=0
set ground density scale. Density parameter in all ground emitters will be multiplied by ground density scale.

Detailed Description

An APEX Module that provides generic Emitter classes.

The documentation for this class was generated from the following file:
  • ModuleEmitter.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleEmitter
nvidia::apex::ModuleEmitter Member List
This is the complete list of members for nvidia::apex::ModuleEmitter, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getDensityScale() const =0 | nvidia::apex::ModuleEmitter | [pure virtual]
getGroundDensityScale() const =0 | nvidia::apex::ModuleEmitter | [pure virtual]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getRateScale() const =0 | nvidia::apex::ModuleEmitter | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setDensityScale(float densityScale)=0 | nvidia::apex::ModuleEmitter | [pure virtual]
setGroundDensityScale(float groundDensityScale)=0 | nvidia::apex::ModuleEmitter | [pure virtual]
setRateScale(float rateScale)=0 | nvidia::apex::ModuleEmitter | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
~ModuleEmitter() (defined in nvidia::apex::ModuleEmitter) | nvidia::apex::ModuleEmitter | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::ModuleFieldSampler Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleFieldSampler
Public Member Functions
nvidia::apex::ModuleFieldSampler Class Reference

FieldSampler module class. More...

#include <ModuleFieldSampler.h>

Inheritance diagram for nvidia::apex::ModuleFieldSampler:
nvidia::apex::Module nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual bool | setFieldSamplerWeightedCollisionFilterCallback (const Scene &apexScene, FieldSamplerWeightedCollisionFilterCallback *callback)=0
Sets the optional weighted collision filter callback for this scene. If not provided, it will use the default SimulationFilterShader on the current scene.
virtual void | enablePhysXMonitor (const Scene &apexScene, bool enable)=0
virtual void | setPhysXMonitorFilterData (const Scene &apexScene, physx::PxFilterData filterData)=0
Add filter data (collision group) to PhysXMonitor.
virtual uint32_t | createForceSampleBatch (const Scene &apexScene, uint32_t maxCount, const physx::PxFilterData filterData)=0
Initialize a query for a batch of sampling points.
virtual void | releaseForceSampleBatch (const Scene &apexScene, uint32_t batchId)=0
Release a query for a batch of sampling points.
virtual void | submitForceSampleBatch (const Scene &apexScene, uint32_t batchId, PxVec4 *forces, const uint32_t forcesStride, const PxVec3 *positions, const uint32_t positionsStride, const PxVec3 *velocities, const uint32_t velocitiesStride, const float *mass, const uint32_t massStride, const uint32_t *indices, const uint32_t numIndices)=0
Submits a batch of sampling points to be evaluated during the simulation step.

Detailed Description

FieldSampler module class.

Member Function Documentation

virtual uint32_t nvidia::apex::ModuleFieldSampler::createForceSampleBatch | ( | const Scene & | apexScene,
 |  | uint32_t | maxCount,
 |  | const physx::PxFilterData | filterData
 | ) |  | [pure virtual]

Initialize a query for a batch of sampling points.

Parameters:
apexScene | [in] - Apex scene for which to create the force sample batch query.
maxCount | [in] - Maximum number of indices (active samples)
filterData | [in] - PhysX 3.0 collision mask for data
Returns:
the ID of created query
virtual void nvidia::apex::ModuleFieldSampler::enablePhysXMonitor | ( | const Scene & | apexScene,
 |  | bool | enable
 | ) |  | [pure virtual]

Set flag to toggle PhysXMonitor for ForceFields.

virtual void nvidia::apex::ModuleFieldSampler::releaseForceSampleBatch | ( | const Scene & | apexScene,
 |  | uint32_t | batchId
 | ) |  | [pure virtual]

Release a query for a batch of sampling points.

Parameters:
apexScene | [in] - Apex scene for which to create the force sample batch.
batchId | [in] - ID of query that should be released
virtual void nvidia::apex::ModuleFieldSampler::setPhysXMonitorFilterData | ( | const Scene & | apexScene,
 |  | physx::PxFilterData | filterData
 | ) |  | [pure virtual]

Add filter data (collision group) to PhysXMonitor.

Parameters:
apexScene | [in] - Apex scene for which to submit the force sample batch.
filterData | [in] - PhysX 3.0 collision mask for PhysXMonitor
virtual void nvidia::apex::ModuleFieldSampler::submitForceSampleBatch | ( | const Scene & | apexScene,
 |  | uint32_t | batchId,
 |  | PxVec4 * | forces,
 |  | const uint32_t | forcesStride,
 |  | const PxVec3 * | positions,
 |  | const uint32_t | positionsStride,
 |  | const PxVec3 * | velocities,
 |  | const uint32_t | velocitiesStride,
 |  | const float * | mass,
 |  | const uint32_t | massStride,
 |  | const uint32_t * | indices,
 |  | const uint32_t | numIndices
 | ) |  | [pure virtual]

Submits a batch of sampling points to be evaluated during the simulation step.

Parameters:
apexScene | [in] - Apex scene for which to submit the force sample batch.
batchId | [in] - ID of query for force sample batch.
forces | [out] - Buffer to which computed forces are written to. The buffer needs to be persistent between calling this function and the next PxApexScene::fetchResults.
forcesStride | [in] - Stride between consecutive force vectors within the forces output.
positions | [in] - Buffer containing the positions of the input samples.
positionsStride | [in] - Stride between consecutive position vectors within the positions input.
velocities | [in] - Buffer containing the velocities of the input samples.
velocitiesStride | [in] - Stride between consecutive velocity vectors within the velocities input.
mass | [in] - Buffer containing the mass of the input samples.
massStride | [in] - Stride between consecutive mass values within the mass input.
indices | [in] - Buffer containing the indices of the active samples that are considered for the input and output buffers.
numIndices | [in] - Number of indices (active samples).
The documentation for this class was generated from the following file:
  • ModuleFieldSampler.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleFieldSampler
nvidia::apex::ModuleFieldSampler Member List
This is the complete list of members for nvidia::apex::ModuleFieldSampler, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createForceSampleBatch(const Scene &apexScene, uint32_t maxCount, const physx::PxFilterData filterData)=0 | nvidia::apex::ModuleFieldSampler | [pure virtual]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
enablePhysXMonitor(const Scene &apexScene, bool enable)=0 | nvidia::apex::ModuleFieldSampler | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseForceSampleBatch(const Scene &apexScene, uint32_t batchId)=0 | nvidia::apex::ModuleFieldSampler | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setFieldSamplerWeightedCollisionFilterCallback(const Scene &apexScene, FieldSamplerWeightedCollisionFilterCallback *callback)=0 | nvidia::apex::ModuleFieldSampler | [pure virtual]
setPhysXMonitorFilterData(const Scene &apexScene, physx::PxFilterData filterData)=0 | nvidia::apex::ModuleFieldSampler | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
submitForceSampleBatch(const Scene &apexScene, uint32_t batchId, PxVec4 *forces, const uint32_t forcesStride, const PxVec3 *positions, const uint32_t positionsStride, const PxVec3 *velocities, const uint32_t velocitiesStride, const float *mass, const uint32_t massStride, const uint32_t *indices, const uint32_t numIndices)=0 | nvidia::apex::ModuleFieldSampler | [pure virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
~ModuleFieldSampler() (defined in nvidia::apex::ModuleFieldSampler) | nvidia::apex::ModuleFieldSampler | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::ModuleForceField Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleForceField
Public Member Functions | Protected Member Functions
nvidia::apex::ModuleForceField Class Reference

ForceField Module. More...

#include <ModuleForceField.h>

Inheritance diagram for nvidia::apex::ModuleForceField:
nvidia::apex::Module nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual uint32_t | getModuleValue () const =0
The module ID value of the force field.

Protected Member Functions

virtual | ~ModuleForceField ()
Force field module default destructor.

Detailed Description

ForceField Module.

The documentation for this class was generated from the following file:
  • ModuleForceField.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleForceField
nvidia::apex::ModuleForceField Member List
This is the complete list of members for nvidia::apex::ModuleForceField, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getModuleValue() const =0 | nvidia::apex::ModuleForceField | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
~ModuleForceField() | nvidia::apex::ModuleForceField | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::ModuleIofx Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleIofx
Public Member Functions
nvidia::apex::ModuleIofx Class Reference

IOFX Module. More...

#include <ModuleIofx.h>

Inheritance diagram for nvidia::apex::ModuleIofx:
nvidia::apex::Module nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual void | disableCudaInterop ()=0
Disable use of OGL/D3D Interop. Must be called before emitters are created to have any effect.
virtual void | disableCudaModifiers ()=0
Disable use of CUDA IOFX modifiers. Must be called before emitters are created to have any effect.
virtual void | disableDeferredRenderableAllocation ()=0
Disables deferred allocation of IOFX actors.
virtual RenderVolume * | createRenderVolume (const Scene &apexScene, const PxBounds3 &b, uint32_t priority, bool allIofx)=0
Create a new render volume.
virtual void | releaseRenderVolume (RenderVolume &volume)=0
Release a render volume.
virtual const TestBase * | getTestBase (Scene *apexScene) const =0
Get TestBase implementation of Iofx scene.
virtual bool | setIofxRenderCallback (const Scene &apexScene, IofxRenderCallback *)=0
Set IofxRenderCallback.
virtual IofxRenderCallback * | getIofxRenderCallback (const Scene &apexScene) const =0
Get IofxRenderCallback.
virtual IofxRenderableIterator * | createIofxRenderableIterator (const Scene &)=0
Create an iterator for all renderables in IOFX module.
virtual void | prepareRenderables (const Scene &)=0
Prepare renderables for rendering, should be called each frame before using renderables to update them with the most recent data.

Detailed Description

IOFX Module.

This module is used to convert physical parameters of particles into visual parameters that can be used to render particles. ApexRenderVolume provide the ability to partition world space into separate renderables.

Member Function Documentation

virtual RenderVolume* nvidia::apex::ModuleIofx::createRenderVolume | ( | const Scene & | apexScene,
 |  | const PxBounds3 & | b,
 |  | uint32_t | priority,
 |  | bool | allIofx
 | ) |  | [pure virtual]

Create a new render volume.

Render volumes may be created at any time, unlike most other APEX asset and actor types. Their insertion into the scene is deferred if the simulation is active.

virtual void nvidia::apex::ModuleIofx::disableDeferredRenderableAllocation ( ) [pure virtual]

Disables deferred allocation of IOFX actors.

By default, IOFX actors and their render resources will not be created until it has objects to render.

virtual IofxRenderCallback* nvidia::apex::ModuleIofx::getIofxRenderCallback ( const Scene & apexScene ) const [pure virtual]

Get IofxRenderCallback.

See also:
IofxRenderCallback
virtual void nvidia::apex::ModuleIofx::releaseRenderVolume ( RenderVolume & volume ) [pure virtual]

Release a render volume.

Render volumes may be released at any time, unlike most other APEX asset and actor types. If the simulation is active, their resources are released at the end of the simulation step.

virtual bool nvidia::apex::ModuleIofx::setIofxRenderCallback | ( | const Scene & | apexScene,
 |  | IofxRenderCallback * |
 | ) |  | [pure virtual]

Set IofxRenderCallback.

See also:
IofxRenderCallback
The documentation for this class was generated from the following file:
  • ModuleIofx.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleIofx
nvidia::apex::ModuleIofx Member List
This is the complete list of members for nvidia::apex::ModuleIofx, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createIofxRenderableIterator(const Scene &)=0 | nvidia::apex::ModuleIofx | [pure virtual]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
createRenderVolume(const Scene &apexScene, const PxBounds3 &b, uint32_t priority, bool allIofx)=0 | nvidia::apex::ModuleIofx | [pure virtual]
disableCudaInterop()=0 | nvidia::apex::ModuleIofx | [pure virtual]
disableCudaModifiers()=0 | nvidia::apex::ModuleIofx | [pure virtual]
disableDeferredRenderableAllocation()=0 | nvidia::apex::ModuleIofx | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getIofxRenderCallback(const Scene &apexScene) const =0 | nvidia::apex::ModuleIofx | [pure virtual]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
getTestBase(Scene *apexScene) const =0 | nvidia::apex::ModuleIofx | [pure virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
prepareRenderables(const Scene &)=0 | nvidia::apex::ModuleIofx | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseRenderVolume(RenderVolume &volume)=0 | nvidia::apex::ModuleIofx | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setIofxRenderCallback(const Scene &apexScene, IofxRenderCallback *)=0 | nvidia::apex::ModuleIofx | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
~ModuleIofx() (defined in nvidia::apex::ModuleIofx) | nvidia::apex::ModuleIofx | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ModuleIofxLegacy Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleIofxLegacy
Public Member Functions
nvidia::apex::ModuleIofxLegacy Class Reference

ModuleIofx interface used in APEXSDK before v. 1.4. More...

#include <ModuleIofxLegacy.h>

Inheritance diagram for nvidia::apex::ModuleIofxLegacy:
nvidia::apex::Module nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual IofxRenderCallback * getIofxLegacyRenderCallback (const Scene &apexScene)=0
Returns IOFX render callback.

Detailed Description

ModuleIofx interface used in APEXSDK before v. 1.4.

This interface depricated in APEX 1.4

The documentation for this class was generated from the following file:
  • ModuleIofxLegacy.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleIofxLegacy
nvidia::apex::ModuleIofxLegacy Member List
This is the complete list of members for nvidia::apex::ModuleIofxLegacy, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getIofxLegacyRenderCallback(const Scene &apexScene)=0 | nvidia::apex::ModuleIofxLegacy | [pure virtual]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
~ModuleIofxLegacy() (defined in nvidia::apex::ModuleIofxLegacy) | nvidia::apex::ModuleIofxLegacy | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ModuleLoader Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleLoader
Public Types | Public Member Functions
nvidia::apex::ModuleLoader Class Reference

The ModuleLoader is a utility class for loading APEX modules. More...

#include <ModuleLoader.h>

Inheritance diagram for nvidia::apex::ModuleLoader:
nvidia::apex::Module nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Types

typedef shdfnd::HashMap< const
char
*, nvidia::apex::ApexCreateError > 		ModuleNameErrorMap
ModuleNameErrorMap.

Public Member Functions

virtual Module * | loadModule (const char *name)=0
Load and initialize a specific APEX module.
virtual void | loadModules (const char **names, uint32_t size, Module **modules=0)=0
Load and initialize a list of specific APEX modules.
virtual void | loadAllModules ()=0
Load and initialize all APEX modules.
virtual void | loadAllLegacyModules ()=0
Load and initialize all legacy APEX modules (useful for deserializing legacy assets)
virtual uint32_t | getLoadedModuleCount () const =0
Returns the number of loaded APEX modules.
virtual Module * | getLoadedModule (uint32_t idx) const =0
Returns the APEX module specified by the index if it was loaded by this ModuleLoader.
virtual Module * | getLoadedModule (const char *name) const =0
Returns the APEX module specified by the name if it was loaded by this ModuleLoader.
virtual void | releaseModule (uint32_t idx)=0
Releases the APEX module specified by the index if it was loaded by this ModuleLoader.
virtual void | releaseModule (const char *name)=0
Releases the APEX module specified by the name if it was loaded by this ModuleLoader.
virtual void | releaseModules (Module **modules, uint32_t size)=0
Releases the APEX module specified by the index if it was loaded by this ModuleLoader.
virtual void | releaseModule (Module *module)=0
Releases the specified APEX module.
virtual void | releaseModules (const char **names, uint32_t size)=0
Releases the APEX modules specified in the names list.
virtual void | releaseLoadedModules ()=0
Releases all APEX modules loaded by this ModuleLoader.
virtual const ModuleNameErrorMap & | getLoadedModulesErrors () const =0
Returns ModuleNameErrorMap.

Detailed Description

The ModuleLoader is a utility class for loading APEX modules.

Note:
The most useful methods for rapid integration are "loadAllModules()", "loadAllLegacyModules()", and "releaseLoadedModules()".
If you need to release APEX modules loaded with ModuleLoader you should use one of the release-methods provided below. Note that you may never need it because SDK automatically releases all modules when program ends.

Member Function Documentation

virtual void nvidia::apex::ModuleLoader::loadModules | ( | const char ** | names,
 |  | uint32_t | size,
 |  | Module ** | modules = 0
 | ) |  | [pure virtual]

Load and initialize a list of specific APEX modules.

Parameters:
[in] | names | The names of modules to load
[in] | size | Number of modules to load
[in] | modules | The modules array must be the same size as the names array to support storage of every loaded Module pointer. Use NULL if you do not need the list of created modules.
virtual void nvidia::apex::ModuleLoader::releaseModule ( Module * module ) [pure virtual]

Releases the specified APEX module.

Note:
If the ModuleLoader is used to load modules, this method must be used to release individual modules. Do not use the Module::release() method.
virtual void nvidia::apex::ModuleLoader::releaseModules | ( | const char ** | names,
 |  | uint32_t | size
 | ) |  | [pure virtual]

Releases the APEX modules specified in the names list.

Note:
If the ModuleLoader is used to load modules, this method must be used to release individual modules. Do not use the Module::release() method.
The documentation for this class was generated from the following file:
  • ModuleLoader.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleLoader
nvidia::apex::ModuleLoader Member List
This is the complete list of members for nvidia::apex::ModuleLoader, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getLoadedModule(uint32_t idx) const =0 | nvidia::apex::ModuleLoader | [pure virtual]
getLoadedModule(const char *name) const =0 | nvidia::apex::ModuleLoader | [pure virtual]
getLoadedModuleCount() const =0 | nvidia::apex::ModuleLoader | [pure virtual]
getLoadedModulesErrors() const =0 | nvidia::apex::ModuleLoader | [pure virtual]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
loadAllLegacyModules()=0 | nvidia::apex::ModuleLoader | [pure virtual]
loadAllModules()=0 | nvidia::apex::ModuleLoader | [pure virtual]
loadModule(const char *name)=0 | nvidia::apex::ModuleLoader | [pure virtual]
loadModules(const char **names, uint32_t size, Module **modules=0)=0 | nvidia::apex::ModuleLoader | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
ModuleNameErrorMap typedef | nvidia::apex::ModuleLoader |
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseLoadedModules()=0 | nvidia::apex::ModuleLoader | [pure virtual]
releaseModule(uint32_t idx)=0 | nvidia::apex::ModuleLoader | [pure virtual]
releaseModule(const char *name)=0 | nvidia::apex::ModuleLoader | [pure virtual]
releaseModule(Module *module)=0 | nvidia::apex::ModuleLoader | [pure virtual]
releaseModules(Module **modules, uint32_t size)=0 | nvidia::apex::ModuleLoader | [pure virtual]
releaseModules(const char **names, uint32_t size)=0 | nvidia::apex::ModuleLoader | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ModuleParticleIos Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleParticleIos
Public Member Functions
nvidia::apex::ModuleParticleIos Class Reference

ParticleIOS Module - Manages PhysX 3.0 PxParticleSystem and PxParticleFluid simulations. More...

#include <ModuleParticleIos.h>

Inheritance diagram for nvidia::apex::ModuleParticleIos:
nvidia::apex::Module nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual const char * getParticleIosTypeName ()=0
Get ParticleIOS authoring type name.

Detailed Description

ParticleIOS Module - Manages PhysX 3.0 PxParticleSystem and PxParticleFluid simulations.

The documentation for this class was generated from the following file:
  • ModuleParticleIos.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleParticleIos
nvidia::apex::ModuleParticleIos Member List
This is the complete list of members for nvidia::apex::ModuleParticleIos, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getParticleIosTypeName()=0 | nvidia::apex::ModuleParticleIos | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
~ModuleParticleIos() (defined in nvidia::apex::ModuleParticleIos) | nvidia::apex::ModuleParticleIos | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ModuleParticles Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleParticles
Public Member Functions
nvidia::apex::ModuleParticles Class Reference

Defines the API for the Particles Module. More...

#include <ModuleParticles.h>

Inheritance diagram for nvidia::apex::ModuleParticles:
nvidia::apex::Module nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual nvidia::apex::Module * | getModule (const char *moduleName)=0
Return one of the particle related modules, by name, created by the particles module.
virtual bool | setEffectPackageGraphicsMaterialsDatabase (const NvParameterized::Interface *dataBase)=0
Registers and adds either a single GraphicsMaterial definition or an entire array of them to the particles module.
virtual bool | setEffectPackageIOSDatabase (const NvParameterized::Interface *dataBase)=0
Registers and adds either a single IOS definition or an entire array of them to the particles module.
virtual bool | setEffectPackageIOFXDatabase (const NvParameterized::Interface *dataBase)=0
Registers and adds either a single IOFX definition or an entire array of them to the particles module.
virtual bool | setEffectPackageEmitterDatabase (const NvParameterized::Interface *dataBase)=0
Registers and adds either a single Emitter definition or an entire array of them to the particles module.
virtual bool | setEffectPackageDatabase (const NvParameterized::Interface *dataBase)=0
Registers and adds either a single EffectPackage definition or an entire array of them to the particles module.
virtual bool | setEffectPackageFieldSamplerDatabase (const NvParameterized::Interface *dataBase)=0
Registers and adds either a single FieldSampler definition or an entire array of them to the particles module.
virtual const
NvParameterized::Interface * 		getEffectPackageGraphicsMaterialsDatabase () const =0
Returns the NvParameterized::Interface representing the array of GraphicsMaterial assets registered by the Paricles modules.
virtual const
NvParameterized::Interface * 		getEffectPackageIOSDatabase () const =0
Returns the NvParameterized::Interface representing the array of IOS assets registered by the Paricles modules.
virtual const
NvParameterized::Interface * 		getEffectPackageIOFXDatabase () const =0
Returns the NvParameterized::Interface representing the array of IOFX assets registered by the Paricles modules.
virtual const
NvParameterized::Interface * 		getEffectPackageEmitterDatabase () const =0
Returns the NvParameterized::Interface representing the array of Emitter assets registered by the Paricles modules.
virtual const
NvParameterized::Interface * 		getEffectPackageDatabase () const =0
Returns the NvParameterized::Interface representing the array of EffectPackage assets registered by the Paricles modules.
virtual const
NvParameterized::Interface * 		getEffectPackageFieldSamplerDatabase () const =0
Returns the NvParameterized::Interface representing the array of FieldSampler assets registered by the Paricles modules.
virtual const
NvParameterized::Interface * 		locateGraphicsMaterialData (const char *name) const =0
This helper method will return the NvParameterized::Interface for a previously defined 'GraphicsMaterial' This 'GraphicsMaterial' contains settings which were defined in the ParticleEffectTool. The ParticleEffectTool will let the user define things like a source texture, a blend mode, user properties, and celled animation settings, relative to a particular named material. The application can use all of these settings or none of them as they prefer. These settings are used by the ParticleEffectTool to provide a prototype visualization of a sprite based particle effect.
virtual
NvParameterized::Interface * 		locateResource (const char *resourceName, const char *nameSpace)=0
This helper method will return the NvParameterized::Interface data for a predefined asset in one of the registered 'databases' When an application gets a callback asking for an asset which was authored using the ParticleEffectTool it can use this method to extract the current parameter data necessary to create that asset.
virtual const char ** | getResourceNames (const char *nameSpace, uint32_t &nameCount, const char **&variants)=0
This is a helper method to return the names of all assets registered relative to a particular namespace.
virtual void | setEnableScreenCulling (bool state, bool znegative)=0
This method globally enabled or disables the screen-space culling LOD feature for EffectPackageActors EffectPackageActors can be culled based on whether or not they are on screen. For this to work the application must provide a valid projection matrix, in addition to a current view matrix, into the SDK. The projection matrix in some engines define Z positive as being in front of the screen and others Z negative.
virtual void | resetEmitterPool ()=0
Resets the emitter pool; causing all cached emitters to be released.
virtual void | setUseEmitterPool (bool state)=0
Sets the state to determine whether or not the particles module is going to use the emitter pool. The emitter pool is an optimization which prevents the effect system from constantly creating and the immediately releasing a great deal of APEX related assets and resources. Take for example the case of a short lived particle effect. Without an emitter pool, triggering this effect would cause a number of assets and rendering resources to be allocated sufficient to render and simulate this effect. But, in just a very short time, the effect lifespan is over and all of those assets and rendering resources are deleted. Then the same effect gets fired again causing the assets and render resources to be immediately re-allocated yet once again. With the emitter pool enabled, the original emitter is not actually released when it times out. Therefore the render resources and associated assets stay resident in memory. When the same effect gets triggered again, it simply reuses the previously allocated emitter from the emitter pool.
virtual bool | getUseEmitterPool () const =0
Returns the current state of the emitter pool status.
virtual void | initializeDefaultDatabases ()=0
Used by the ParticleEffectTool to initialize the default database values for the editor.

Detailed Description

Defines the API for the Particles Module.

The particles module combines the features of a number of particle related APEX modules into one location; with the exception of APEX turbulence. It also provides support for the EffectPackage actor and asset as well as integration with the ParticleEffectAuthoring tool.

Loading the APEX Particles module will now automatically cause the following related modules to be instantiated.

APEX_Emitter APEX_BasicIOS APEX_IOFX APEX_FieldSampler APEX_BasicIOS APEX_ParticleIOS APEX_ForceField

These modules are no longer loaded as separate DLLs and instantiated individually like they were prior to APEX 1.3. Instead simply loading the APEX_Particles DLL or calling 'instantiateModuleParticles' will cause the other particle related modules to be loaded.

The rationale for making this change was to simplify the startup/shutdown sequence for applications using APEX particle related effects. It also dramatically simplifies the distribution process for developers as they now only have to deal with a single DLL rather than as many as 8 which were required before.

The turbulence module was not folded into the unified APEX_Particles module at this time since the source code for it is not yet made available to licensees.

It is important to note that since the APEX_Particles module does not load the Turbulence module, the application *must* load the Turbulence module first so that it will already be registered.

Member Function Documentation

virtual const char** nvidia::apex::ModuleParticles::getResourceNames | ( | const char * | nameSpace,
 |  | uint32_t & | nameCount,
 |  | const char **& | variants
 | ) |  | [pure virtual]

This is a helper method to return the names of all assets registered relative to a particular namespace.

Parameters:
[in] | nameSpace | : The namespace of the asset type we are searching for.
[in] | nameCount | : A reference to a counter which will contain the number of assets found matching this namespace
[in] | variants | : A reference to an array of const char pointers which will contain what reference variant each returned asset matches.
Returns:
Returns an array of const char pointers representing the asset names matching this resource type.
virtual const NvParameterized::Interface* nvidia::apex::ModuleParticles::locateGraphicsMaterialData ( const char * name ) const [pure virtual]

This helper method will return the NvParameterized::Interface for a previously defined 'GraphicsMaterial' This 'GraphicsMaterial' contains settings which were defined in the ParticleEffectTool. The ParticleEffectTool will let the user define things like a source texture, a blend mode, user properties, and celled animation settings, relative to a particular named material. The application can use all of these settings or none of them as they prefer. These settings are used by the ParticleEffectTool to provide a prototype visualization of a sprite based particle effect.

Parameters:
[in] name : The name of the predefined graphics material
Returns:
A pointer to the NvParameterized::Interface representing this material or NULL if not found.
virtual NvParameterized::Interface* nvidia::apex::ModuleParticles::locateResource | ( | const char * | resourceName,
 |  | const char * | nameSpace
 | ) |  | [pure virtual]

This helper method will return the NvParameterized::Interface data for a predefined asset in one of the registered 'databases' When an application gets a callback asking for an asset which was authored using the ParticleEffectTool it can use this method to extract the current parameter data necessary to create that asset.

Parameters:
[in] | resourceName | : The name of the previously defined/registered asset
[in] | nameSpace | : The namespace of the asset.
Returns:
Returns the NvParamterized::Interface pointer for that asset or NULL if not found.
virtual bool nvidia::apex::ModuleParticles::setEffectPackageDatabase ( const NvParameterized::Interface * dataBase ) [pure virtual]

Registers and adds either a single EffectPackage definition or an entire array of them to the particles module.

The EffectPackage system works with a set of predefined assets which have been authored using the ParticleEffectTool. This method adds or revises either a single asset or an array of assets. When an EffectPackageActor is instantiated it may refer to assets which have been previously authored and registered using this method.

Returns:
Returns true if during the registration of this asset the contents were modified.
virtual bool nvidia::apex::ModuleParticles::setEffectPackageEmitterDatabase ( const NvParameterized::Interface * dataBase ) [pure virtual]

Registers and adds either a single Emitter definition or an entire array of them to the particles module.

The EffectPackage system works with a set of predefined assets which have been authored using the ParticleEffectTool. This method adds or revises either a single asset or an array of assets. When an EffectPackageActor is instantiated it may refer to assets which have been previously authored and registered using this method.

Returns:
Returns true if during the registration of this asset the contents were modified.
virtual bool nvidia::apex::ModuleParticles::setEffectPackageFieldSamplerDatabase ( const NvParameterized::Interface * dataBase ) [pure virtual]

Registers and adds either a single FieldSampler definition or an entire array of them to the particles module.

The EffectPackage system works with a set of predefined assets which have been authored using the ParticleEffectTool. This method adds or revises either a single asset or an array of assets. When an EffectPackageActor is instantiated it may refer to assets which have been previously authored and registered using this method.

Returns:
Returns true if during the registration of this asset the contents were modified.
virtual bool nvidia::apex::ModuleParticles::setEffectPackageGraphicsMaterialsDatabase ( const NvParameterized::Interface * dataBase ) [pure virtual]

Registers and adds either a single GraphicsMaterial definition or an entire array of them to the particles module.

The EffectPackage system works with a set of predefined assets which have been authored using the ParticleEffectTool. This method adds or revises either a single asset or an array of assets. When an EffectPackageActor is instantiated it may refer to assets which have been previously authored and registered using this method.

Returns:
Returns true if during the registration of this asset the contents were modified.
virtual bool nvidia::apex::ModuleParticles::setEffectPackageIOFXDatabase ( const NvParameterized::Interface * dataBase ) [pure virtual]

Registers and adds either a single IOFX definition or an entire array of them to the particles module.

The EffectPackage system works with a set of predefined assets which have been authored using the ParticleEffectTool. This method adds or revises either a single asset or an array of assets. When an EffectPackageActor is instantiated it may refer to assets which have been previously authored and registered using this method.

Returns:
Returns true if during the registration of this asset the contents were modified.
virtual bool nvidia::apex::ModuleParticles::setEffectPackageIOSDatabase ( const NvParameterized::Interface * dataBase ) [pure virtual]

Registers and adds either a single IOS definition or an entire array of them to the particles module.

The EffectPackage system works with a set of predefined assets which have been authored using the ParticleEffectTool. This method adds or revises either a single asset or an array of assets. When an EffectPackageActor is instantiated it may refer to assets which have been previously authored and registered using this method.

Returns:
Returns true if during the registration of this asset the contents were modified.
virtual void nvidia::apex::ModuleParticles::setEnableScreenCulling | ( | bool | state,
 |  | bool | znegative
 | ) |  | [pure virtual]

This method globally enabled or disables the screen-space culling LOD feature for EffectPackageActors EffectPackageActors can be culled based on whether or not they are on screen. For this to work the application must provide a valid projection matrix, in addition to a current view matrix, into the SDK. The projection matrix in some engines define Z positive as being in front of the screen and others Z negative.

Parameters:
[in] | state | : Whether to enable or disable the screen culling feature
[in] | znegative | : Whether or not Z is positive or negative when a point projected into screen-space is in front or behind the camera.
The documentation for this class was generated from the following file:
  • ModuleParticles.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleParticles
nvidia::apex::ModuleParticles Member List
This is the complete list of members for nvidia::apex::ModuleParticles, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getEffectPackageDatabase() const =0 | nvidia::apex::ModuleParticles | [pure virtual]
getEffectPackageEmitterDatabase() const =0 | nvidia::apex::ModuleParticles | [pure virtual]
getEffectPackageFieldSamplerDatabase() const =0 | nvidia::apex::ModuleParticles | [pure virtual]
getEffectPackageGraphicsMaterialsDatabase() const =0 | nvidia::apex::ModuleParticles | [pure virtual]
getEffectPackageIOFXDatabase() const =0 | nvidia::apex::ModuleParticles | [pure virtual]
getEffectPackageIOSDatabase() const =0 | nvidia::apex::ModuleParticles | [pure virtual]
getModule(const char *moduleName)=0 | nvidia::apex::ModuleParticles | [pure virtual]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
getResourceNames(const char *nameSpace, uint32_t &nameCount, const char **&variants)=0 | nvidia::apex::ModuleParticles | [pure virtual]
getUseEmitterPool() const =0 | nvidia::apex::ModuleParticles | [pure virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
initializeDefaultDatabases()=0 | nvidia::apex::ModuleParticles | [pure virtual]
locateGraphicsMaterialData(const char *name) const =0 | nvidia::apex::ModuleParticles | [pure virtual]
locateResource(const char *resourceName, const char *nameSpace)=0 | nvidia::apex::ModuleParticles | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
resetEmitterPool()=0 | nvidia::apex::ModuleParticles | [pure virtual]
setEffectPackageDatabase(const NvParameterized::Interface *dataBase)=0 | nvidia::apex::ModuleParticles | [pure virtual]
setEffectPackageEmitterDatabase(const NvParameterized::Interface *dataBase)=0 | nvidia::apex::ModuleParticles | [pure virtual]
setEffectPackageFieldSamplerDatabase(const NvParameterized::Interface *dataBase)=0 | nvidia::apex::ModuleParticles | [pure virtual]
setEffectPackageGraphicsMaterialsDatabase(const NvParameterized::Interface *dataBase)=0 | nvidia::apex::ModuleParticles | [pure virtual]
setEffectPackageIOFXDatabase(const NvParameterized::Interface *dataBase)=0 | nvidia::apex::ModuleParticles | [pure virtual]
setEffectPackageIOSDatabase(const NvParameterized::Interface *dataBase)=0 | nvidia::apex::ModuleParticles | [pure virtual]
setEnableScreenCulling(bool state, bool znegative)=0 | nvidia::apex::ModuleParticles | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
setUseEmitterPool(bool state)=0 | nvidia::apex::ModuleParticles | [pure virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
~ModuleParticles() (defined in nvidia::apex::ModuleParticles) | nvidia::apex::ModuleParticles | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ModuleSpecificRenderBufferData Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleSpecificRenderBufferData
Public Attributes
nvidia::apex::ModuleSpecificRenderBufferData Class Reference

Describes data semantics provided by a particular module. More...

#include <RenderBufferData.h>

Inheritance diagram for nvidia::apex::ModuleSpecificRenderBufferData:
nvidia::apex::RenderSpriteBufferData nvidia::apex::RenderVertexBufferData

List of all members.

Public Attributes

AuthObjTypeID moduleId
Unique module identifier, from Module::getModuleID()
RenderSemanticData * moduleSpecificSemanticData
Pointer to an array of custom semantics.
uint32_t numModuleSpecificSemantics
Count of custom semantics provided by this module.

Detailed Description

Describes data semantics provided by a particular module.

The documentation for this class was generated from the following file:
  • RenderBufferData.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleSpecificRenderBufferData
nvidia::apex::ModuleSpecificRenderBufferData Member List
This is the complete list of members for nvidia::apex::ModuleSpecificRenderBufferData, including all inherited members.
moduleId | nvidia::apex::ModuleSpecificRenderBufferData |
ModuleSpecificRenderBufferData(void) (defined in nvidia::apex::ModuleSpecificRenderBufferData) | nvidia::apex::ModuleSpecificRenderBufferData | [inline]
moduleSpecificSemanticData | nvidia::apex::ModuleSpecificRenderBufferData |
numModuleSpecificSemantics | nvidia::apex::ModuleSpecificRenderBufferData |
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::ModuleTurbulenceFS Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleTurbulenceFS
Public Member Functions
nvidia::apex::ModuleTurbulenceFS Class Reference

Class for TurbulenceFS module. More...

#include <ModuleTurbulenceFS.h>

Inheritance diagram for nvidia::apex::ModuleTurbulenceFS:
nvidia::apex::Module nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual bool | setCustomTimestep (const Scene &apexScene, float timestep, int numIterations)=0
Set custom timestep parameters for the specified scene (only for one simulation call)
virtual bool | setMultiSolveEnabled (const Scene &apexScene, bool enabled)=0
Enable/disable multi-solve feature for the specified scene (disable by default)
virtual void | enableOutputVelocityField ()=0
Enable output velocity field to UserRenderSurfaceBuffer.
virtual void | enableOutputDensityField ()=0
Enable output density field to UserRenderSurfaceBuffer.
virtual void | enableOutputFlameField ()=0
Enable output flame field to UserRenderSurfaceBuffer.
virtual void | setCustomFilterShader (physx::PxSimulationFilterShader shader, const void *shaderData, uint32_t shaderDataSize)=0
Set custum filter shader to filter collision shapes interacting with Turbulence grids.
virtual const TestBase * | getTestBase (Scene *apexScene) const =0
Returns pointer to TestBase. Internal feature, return NULL for distribution builds.
virtual int32_t | getGridSizePow () const =0
get grid size power. Grid size of all actors will be multiplied by 2^(grid size power). But final grid size restricted by defined values
virtual void | setGridSizePow (int32_t power)=0
set grid size power. Grid size of all actors will be multiplied by 2^(grid size power). But final grid size restricted by defined values
virtual void | prepareRenderables (const Scene &)=0
Prepare renderables for rendering, should be called each frame before using renderables to update them with the most recent data.
virtual bool | setTurbulenceRenderCallback (const Scene &apexScene, TurbulenceRenderCallback *)=0
Set TurbulenceRenderCallback.
virtual TurbulenceRenderCallback * | getTurbulenceRenderCallback (const Scene &apexScene) const =0
Get TurbulenceRenderCallback.

Detailed Description

Class for TurbulenceFS module.

Member Function Documentation

virtual TurbulenceRenderCallback* nvidia::apex::ModuleTurbulenceFS::getTurbulenceRenderCallback ( const Scene & apexScene ) const [pure virtual]

Get TurbulenceRenderCallback.

See also:
TurbulenceRenderCallback
virtual bool nvidia::apex::ModuleTurbulenceFS::setTurbulenceRenderCallback | ( | const Scene & | apexScene,
 |  | TurbulenceRenderCallback * |
 | ) |  | [pure virtual]

Set TurbulenceRenderCallback.

See also:
TurbulenceRenderCallback
The documentation for this class was generated from the following file:
  • ModuleTurbulenceFS.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleTurbulenceFS
nvidia::apex::ModuleTurbulenceFS Member List
This is the complete list of members for nvidia::apex::ModuleTurbulenceFS, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createRenderableIterator(const Scene &)=0 | nvidia::apex::Module | [pure virtual]
enableOutputDensityField()=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
enableOutputFlameField()=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
enableOutputVelocityField()=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
getDefaultModuleDesc() | nvidia::apex::Module | [inline]
getGridSizePow() const =0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
getModuleID() const =0 | nvidia::apex::Module | [pure virtual]
getName() const =0 | nvidia::apex::Module | [pure virtual]
getRenderLockMode(const Scene &) const | nvidia::apex::Module | [inline, virtual]
getTestBase(Scene *apexScene) const =0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
getTurbulenceRenderCallback(const Scene &apexScene) const =0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
init(::NvParameterized::Interface &desc)=0 | nvidia::apex::Module | [pure virtual]
lockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
prepareRenderables(const Scene &)=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setCustomFilterShader(physx::PxSimulationFilterShader shader, const void *shaderData, uint32_t shaderDataSize)=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
setCustomTimestep(const Scene &apexScene, float timestep, int numIterations)=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
setGridSizePow(int32_t power)=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
setMultiSolveEnabled(const Scene &apexScene, bool enabled)=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
setRenderLockMode(RenderLockMode::Enum, Scene &) | nvidia::apex::Module | [inline, virtual]
setTurbulenceRenderCallback(const Scene &apexScene, TurbulenceRenderCallback *)=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
unlockModuleSceneRenderLock(Scene &) | nvidia::apex::Module | [inline, virtual]
userData | nvidia::apex::ApexInterface |
~ModuleTurbulenceFS() (defined in nvidia::apex::ModuleTurbulenceFS) | nvidia::apex::ModuleTurbulenceFS | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::NoiseFSActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • NoiseFSActor
Public Member Functions
nvidia::apex::NoiseFSActor Class Reference

JetFS Actor class. More...

#include <NoiseFSActor.h>

Inheritance diagram for nvidia::apex::NoiseFSActor:
nvidia::apex::Actor nvidia::apex::Renderable nvidia::apex::ApexInterface nvidia::apex::RenderDataProvider nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual BasicFSAsset * | getNoiseFSAsset () const =0
Returns the asset the instance has been created from.
virtual PxMat44 | getCurrentPose () const =0
Gets the current pose of the actor.
virtual void | setCurrentPose (const PxTransform &pose)=0
Sets the current pose of the actor.
virtual PxVec3 | getCurrentPosition () const =0
Gets the current position of the actor.
virtual void | setCurrentPosition (const PxVec3 &pos)=0
Sets the current position of the actor.
virtual float | getCurrentScale () const =0
Gets the current scale of the actor.
virtual void | setCurrentScale (const float &scale)=0
Sets the current scale of the actor.
virtual void | setNoiseStrength (float)=0
Sets the noise strength.
virtual void | setEnabled (bool isEnabled)=0
Enable/Disable the field simulation.

Detailed Description

JetFS Actor class.

The documentation for this class was generated from the following file:
  • NoiseFSActor.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • NoiseFSActor
nvidia::apex::NoiseFSActor Member List
This is the complete list of members for nvidia::apex::NoiseFSActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getCurrentPose() const =0 | nvidia::apex::NoiseFSActor | [pure virtual]
getCurrentPosition() const =0 | nvidia::apex::NoiseFSActor | [pure virtual]
getCurrentScale() const =0 | nvidia::apex::NoiseFSActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getNoiseFSAsset() const =0 | nvidia::apex::NoiseFSActor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setCurrentPose(const PxTransform &pose)=0 | nvidia::apex::NoiseFSActor | [pure virtual]
setCurrentPosition(const PxVec3 &pos)=0 | nvidia::apex::NoiseFSActor | [pure virtual]
setCurrentScale(const float &scale)=0 | nvidia::apex::NoiseFSActor | [pure virtual]
setEnabled(bool isEnabled)=0 | nvidia::apex::NoiseFSActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setNoiseStrength(float)=0 | nvidia::apex::NoiseFSActor | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~NoiseFSActor() (defined in nvidia::apex::NoiseFSActor) | nvidia::apex::NoiseFSActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::NoiseFSPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • NoiseFSPreview
Public Member Functions
nvidia::apex::NoiseFSPreview Class Reference

This class provides the asset preview for APEX NoiseFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

#include <NoiseFSPreview.h>

Inheritance diagram for nvidia::apex::NoiseFSPreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void setDetailLevel (uint32_t detail)=0

Detailed Description

This class provides the asset preview for APEX NoiseFS Assets. The class provides multiple levels of prevew detail that can be selected individually.

Member Function Documentation

virtual void nvidia::apex::NoiseFSPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable.
Any, all, or none of the following masks may be added together to select what should be drawn.
The defines for the individual items are:
NOISE_DRAW_NOTHING - draw nothing
NOISE_DRAW_SHAPE - draw the shape
NOISE_DRAW_ASSET_INFO - draw the asset info in the screen space
NOISE_DRAW_FULL_DETAIL - draw all components of the asset preview
All items may be drawn using the macro DRAW_FULL_DETAIL.

The documentation for this class was generated from the following file:
  • NoiseFSPreview.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • NoiseFSPreview
nvidia::apex::NoiseFSPreview Member List
This is the complete list of members for nvidia::apex::NoiseFSPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setDetailLevel(uint32_t detail)=0 | nvidia::apex::NoiseFSPreview | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::OrientAlongVelocityModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • OrientAlongVelocityModifier
Public Member Functions | Static Public Attributes
nvidia::apex::OrientAlongVelocityModifier Class Reference

OrientAlongVelocity is a modifier to orient a mesh so that a particular axis coincides with the velocity vector. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::OrientAlongVelocityModifier:
nvidia::apex::ModifierT< OrientAlongVelocityModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual PxVec3 | getModelForward () const =0
get the object-space vector that will coincide with the velocity vector
virtual void | setModelForward (const PxVec3 &s)=0
set the object-space vector that will coincide with the velocity vector

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_OrientAlongVelocity
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

OrientAlongVelocity is a modifier to orient a mesh so that a particular axis coincides with the velocity vector.

Member Data Documentation

const uint32_t nvidia::apex::OrientAlongVelocityModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • OrientAlongVelocityModifier
nvidia::apex::OrientAlongVelocityModifier Member List
This is the complete list of members for nvidia::apex::OrientAlongVelocityModifier, including all inherited members.
getModelForward() const =0 | nvidia::apex::OrientAlongVelocityModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< OrientAlongVelocityModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< OrientAlongVelocityModifier > | [inline, virtual]
ModifierType | nvidia::apex::OrientAlongVelocityModifier | [static]
ModifierUsage | nvidia::apex::OrientAlongVelocityModifier | [static]
setModelForward(const PxVec3 &s)=0 | nvidia::apex::OrientAlongVelocityModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::OrientScaleAlongScreenVelocityModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • OrientScaleAlongScreenVelocityModifier
Public Member Functions | Static Public Attributes
nvidia::apex::OrientScaleAlongScreenVelocityModifier Class Reference

OrientScaleAlongScreenVelocityModifier is a modifier to orient & scale sprites along the current screen velocity vector. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::OrientScaleAlongScreenVelocityModifier:
nvidia::apex::ModifierT< OrientScaleAlongScreenVelocityModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual float | getScalePerVelocity () const =0
get the scale per velocity
virtual void | setScalePerVelocity (const float &s)=0
set the scale per velocity
virtual float | getScaleChangeLimit () const =0
get the scale change limit
virtual void | setScaleChangeLimit (const float &s)=0
set the scale change limit
virtual float | getScaleChangeDelay () const =0
get the scale change delay
virtual void | setScaleChangeDelay (const float &s)=0
set the scale change delay

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_OrientScaleAlongScreenVelocity
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

OrientScaleAlongScreenVelocityModifier is a modifier to orient & scale sprites along the current screen velocity vector.

Member Data Documentation

const uint32_t nvidia::apex::OrientScaleAlongScreenVelocityModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • OrientScaleAlongScreenVelocityModifier
nvidia::apex::OrientScaleAlongScreenVelocityModifier Member List
This is the complete list of members for nvidia::apex::OrientScaleAlongScreenVelocityModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< OrientScaleAlongScreenVelocityModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< OrientScaleAlongScreenVelocityModifier > | [inline, virtual]
getScaleChangeDelay() const =0 | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [pure virtual]
getScaleChangeLimit() const =0 | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [pure virtual]
getScalePerVelocity() const =0 | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [pure virtual]
ModifierType | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [static]
ModifierUsage | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [static]
setScaleChangeDelay(const float &s)=0 | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [pure virtual]
setScaleChangeLimit(const float &s)=0 | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [pure virtual]
setScalePerVelocity(const float &s)=0 | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ParticleIosActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ParticleIosActor
nvidia::apex::ParticleIosActor Class Reference

ParticleIOS Actor. A simple actor that simulates a particle system. More...

#include <ParticleIosActor.h>

Inheritance diagram for nvidia::apex::ParticleIosActor:
nvidia::apex::Actor nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

ParticleIOS Actor. A simple actor that simulates a particle system.

The documentation for this class was generated from the following file:
  • ParticleIosActor.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ParticleIosActor
nvidia::apex::ParticleIosActor Member List
This is the complete list of members for nvidia::apex::ParticleIosActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~ParticleIosActor() (defined in nvidia::apex::ParticleIosActor) | nvidia::apex::ParticleIosActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ParticleIosAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ParticleIosAsset
Public Member Functions
nvidia::apex::ParticleIosAsset Class Reference

APEX Particle System Asset. More...

#include <ParticleIosAsset.h>

Inheritance diagram for nvidia::apex::ParticleIosAsset:
nvidia::apex::IosAsset nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual float | getParticleRadius () const =0
Get the radius of a particle.
virtual float | getMaxInjectedParticleCount () const =0
Get the maximum number of particles that are allowed to be newly created on each frame.
virtual uint32_t | getMaxParticleCount () const =0
Get the maximum number of particles that this IOS can simulate.
virtual float | getParticleMass () const =0
Get the mass of a particle.

Detailed Description

APEX Particle System Asset.

The documentation for this class was generated from the following file:
  • ParticleIosAsset.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ParticleIosAsset
nvidia::apex::ParticleIosAsset Member List
This is the complete list of members for nvidia::apex::ParticleIosAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
createIosActor(Scene &scene, IofxAsset *iofxAsset)=0 | nvidia::apex::IosAsset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getMaxInjectedParticleCount() const =0 | nvidia::apex::ParticleIosAsset | [pure virtual]
getMaxParticleCount() const =0 | nvidia::apex::ParticleIosAsset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
getParticleMass() const =0 | nvidia::apex::ParticleIosAsset | [pure virtual]
getParticleRadius() const =0 | nvidia::apex::ParticleIosAsset | [pure virtual]
getSupportsDensity() const =0 | nvidia::apex::IosAsset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseIosActor(Actor &actor)=0 | nvidia::apex::IosAsset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~ParticleIosAsset() (defined in nvidia::apex::ParticleIosAsset) | nvidia::apex::ParticleIosAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ParticleIosAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ParticleIosAssetAuthoring
Public Member Functions
nvidia::apex::ParticleIosAssetAuthoring Class Reference

APEX Particle System Asset Authoring class. More...

#include <ParticleIosAsset.h>

Inheritance diagram for nvidia::apex::ParticleIosAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual void | setParticleRadius (float)=0
Set the radius of a particle.
virtual void | setMaxInjectedParticleCount (float count)=0
Set the maximum number of particles that are allowed to be newly created on each frame.
virtual void | setMaxParticleCount (uint32_t count)=0
Set the maximum number of particles that this IOS can simulate.
virtual void | setParticleMass (float)=0
Set the mass of a particle.
virtual void | setCollisionGroupName (const char *collisionGroupName)=0
Set the (NRP) name for the collision group.
virtual void | setCollisionGroupMaskName (const char *collisionGroupMaskName)=0
Set the (NRP) name for the collision group mask.

Detailed Description

APEX Particle System Asset Authoring class.

The documentation for this class was generated from the following file:
  • ParticleIosAsset.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ParticleIosAssetAuthoring
nvidia::apex::ParticleIosAssetAuthoring Member List
This is the complete list of members for nvidia::apex::ParticleIosAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setCollisionGroupMaskName(const char *collisionGroupMaskName)=0 | nvidia::apex::ParticleIosAssetAuthoring | [pure virtual]
setCollisionGroupName(const char *collisionGroupName)=0 | nvidia::apex::ParticleIosAssetAuthoring | [pure virtual]
setMaxInjectedParticleCount(float count)=0 | nvidia::apex::ParticleIosAssetAuthoring | [pure virtual]
setMaxParticleCount(uint32_t count)=0 | nvidia::apex::ParticleIosAssetAuthoring | [pure virtual]
setParticleMass(float)=0 | nvidia::apex::ParticleIosAssetAuthoring | [pure virtual]
setParticleRadius(float)=0 | nvidia::apex::ParticleIosAssetAuthoring | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
~ParticleIosAssetAuthoring() (defined in nvidia::apex::ParticleIosAssetAuthoring) | nvidia::apex::ParticleIosAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ParticlesPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ParticlesPreview
Public Member Functions
nvidia::apex::ParticlesPreview Class Reference

APEX asset preview wind asset. More...

#include <ParticlesPreview.h>

Inheritance diagram for nvidia::apex::ParticlesPreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void | setIconScale (float scale)=0
virtual void | setDetailLevel (uint32_t detail)=0

Detailed Description

APEX asset preview wind asset.

Member Function Documentation

virtual void nvidia::apex::ParticlesPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable. Any, all, or none of the following masks may be added together to select what should be drawn. The defines for the individual items are PARTICLES_DRAW_NOTHING, PARTICLES_DRAW_ICON, PARTICLES_DRAW_BOUNDARIES, PARTICLES_DRAW_WITH_CYLINDERS. All items may be drawn using the macro PARTICLES_DRAW_FULL_DETAIL and PARTICLES_DRAW_FULL_DETAIL_BOLD.

virtual void nvidia::apex::ParticlesPreview::setIconScale ( float scale ) [pure virtual]

Set the scale of the icon. The unscaled icon has is 1.0x1.0 game units. By default the scale of the icon is 1.0. (unscaled)

The documentation for this class was generated from the following file:
  • ParticlesPreview.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ParticlesPreview
nvidia::apex::ParticlesPreview Member List
This is the complete list of members for nvidia::apex::ParticlesPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
ParticlesPreview() (defined in nvidia::apex::ParticlesPreview) | nvidia::apex::ParticlesPreview | [inline, protected]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setDetailLevel(uint32_t detail)=0 | nvidia::apex::ParticlesPreview | [pure virtual]
setIconScale(float scale)=0 | nvidia::apex::ParticlesPreview | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::PhysX3DescTemplate Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • PhysX3DescTemplate
Public Member Functions
nvidia::apex::PhysX3DescTemplate Class Reference

#include <Actor.h>

List of all members.

Public Member Functions

APEX_ACTOR_TEMPLATE_PARAM (physx::PxDominanceGroup, DominanceGroup,(1), 0)
APEX_ACTOR_TEMPLATE_PARAM (uint8_t, ActorFlags,(1), physx::PxActorFlag::eSEND_SLEEP_NOTIFIES)
APEX_ACTOR_TEMPLATE_PARAM (physx::PxClientID, OwnerClient,(1), 0)
APEX_ACTOR_TEMPLATE_PARAM (uint32_t, ClientBehaviorBits,(1), 0)
APEX_ACTOR_TEMPLATE_PARAM (uint16_t, ContactReportFlags,(1), 0)
APEX_ACTOR_TEMPLATE_PARAM (void *, UserData,(1), NULL)
APEX_ACTOR_TEMPLATE_PARAM (const char *, Name,(1), NULL)
APEX_ACTOR_TEMPLATE_PARAM (float, Density,(x >=0.0f), 1.0f)
APEX_ACTOR_TEMPLATE_PARAM (uint8_t, BodyFlags,(1), 0)
APEX_ACTOR_TEMPLATE_PARAM (float, WakeUpCounter,(x >=0.0f), APEX_DEFAULT_WAKE_UP_COUNTER)
APEX_ACTOR_TEMPLATE_PARAM (float, LinearDamping,(x >=0.0f), 0.0f)
APEX_ACTOR_TEMPLATE_PARAM (float, AngularDamping,(x >=0.0f), 0.05f)
APEX_ACTOR_TEMPLATE_PARAM (float, MaxAngularVelocity,(1), 7.0f)
APEX_ACTOR_TEMPLATE_PARAM (float, SleepLinearVelocity,(1), 0.0f)
APEX_ACTOR_TEMPLATE_PARAM (uint32_t, SolverIterationCount,(x >=1 &&x<=255), 4)
APEX_ACTOR_TEMPLATE_PARAM (uint32_t, VelocityIterationCount,(x >=1 &&x<=255), 1)
APEX_ACTOR_TEMPLATE_PARAM (float, ContactReportThreshold,(1), PX_MAX_F32)
APEX_ACTOR_TEMPLATE_PARAM (float, SleepThreshold,(1), 0.005f)
APEX_ACTOR_TEMPLATE_PARAM (uint8_t, ShapeFlags,(1), physx::PxShapeFlag::eSIMULATION_SHAPE|physx::PxShapeFlag::eSCENE_QUERY_SHAPE|physx::PxShapeFlag::eVISUALIZATION)
APEX_ACTOR_TEMPLATE_PARAM (void *, ShapeUserData,(1), NULL)
APEX_ACTOR_TEMPLATE_PARAM (const char *, ShapeName,(1), NULL)
APEX_ACTOR_TEMPLATE_PARAM (physx::PxFilterData, SimulationFilterData,(1), physx::PxFilterData(0, 0, 0, 0))
APEX_ACTOR_TEMPLATE_PARAM (physx::PxFilterData, QueryFilterData,(1), physx::PxFilterData(0, 0, 0, 0))
APEX_ACTOR_TEMPLATE_PARAM (float, ContactOffset,(1),-1.0f)
APEX_ACTOR_TEMPLATE_PARAM (float, RestOffset,(1), PX_MAX_F32)
virtual physx::PxMaterial ** | getMaterials (uint32_t &materialCount) const =0
virtual bool | setMaterials (physx::PxMaterial **materialArray, uint32_t materialCount)=0
virtual void | release ()=0

Detailed Description

Template for PhysX3.x actor, body and shape. Used by the Destruction module when creating PhysX objects.

See ApexActorSource::setPhysX3Template and ActorSource::getPhysX3Template.

Member Function Documentation

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | physx::PxDominanceGroup | ,
 |  | DominanceGroup | ,
 |  | (1) | ,
 |  | 0 |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=DominanceGroup (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | uint8_t | ,
 |  | ActorFlags | ,
 |  | (1) | ,
 |  | physx::PxActorFlag::eSEND_SLEEP_NOTIFIES |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=ActorFlags (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | uint32_t | ,
 |  | ClientBehaviorBits | ,
 |  | (1) | ,
 |  | 0 |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=ClientBehaviorBits (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | float | ,
 |  | Density | ,
 |  | (x >=0.0f) | ,
 |  | 1. | 0f
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=Density (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | float | ,
 |  | RestOffset | ,
 |  | (1) | ,
 |  | PX_MAX_F32 |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=RestOffset (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | float | ,
 |  | ContactOffset | ,
 |  | (1) | ,
 |  | -1. | 0f
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=ContactOffset (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | physx::PxFilterData | ,
 |  | QueryFilterData | ,
 |  | (1) | ,
 |  | physx:: | PxFilterData0, 0, 0, 0
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=QueryFilterData (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | physx::PxFilterData | ,
 |  | SimulationFilterData | ,
 |  | (1) | ,
 |  | physx:: | PxFilterData0, 0, 0, 0
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=SimulationFilterData (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | const char * | ,
 |  | ShapeName | ,
 |  | (1) | ,
 |  | NULL |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=ShapeName (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | void * | ,
 |  | ShapeUserData | ,
 |  | (1) | ,
 |  | NULL |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=ShapeUserData (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | uint8_t | ,
 |  | ShapeFlags | ,
 |  | (1) | ,
 |  | physx::PxShapeFlag::eSIMULATION_SHAPE|physx::PxShapeFlag::eSCENE_QUERY_SHAPE|physx::PxShapeFlag::eVISUALIZATION |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=ShapeFlags (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | float | ,
 |  | SleepThreshold | ,
 |  | (1) | ,
 |  | 0. | 005f
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=SleepThreshold (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | uint32_t | ,
 |  | VelocityIterationCount | ,
 |  | (x >=1 &&x<=255) | ,
 |  | 1 |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=VelocityIterationCount (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | float | ,
 |  | ContactReportThreshold | ,
 |  | (1) | ,
 |  | PX_MAX_F32 |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=ContactReportThreshold (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | uint32_t | ,
 |  | SolverIterationCount | ,
 |  | (x >=1 &&x<=255) | ,
 |  | 4 |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=SolverIterationCount (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | float | ,
 |  | SleepLinearVelocity | ,
 |  | (1) | ,
 |  | 0. | 0f
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=SleepLinearVelocity (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | float | ,
 |  | MaxAngularVelocity | ,
 |  | (1) | ,
 |  | 7. | 0f
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=MaxAngularVelocity (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | float | ,
 |  | AngularDamping | ,
 |  | (x >=0.0f) | ,
 |  | 0. | 05f
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=AngularDamping (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | float | ,
 |  | LinearDamping | ,
 |  | (x >=0.0f) | ,
 |  | 0. | 0f
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=LinearDamping (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | float | ,
 |  | WakeUpCounter | ,
 |  | (x >=0.0f) | ,
 |  | APEX_DEFAULT_WAKE_UP_COUNTER |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=WakeUpCounter (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | uint8_t | ,
 |  | BodyFlags | ,
 |  | (1) | ,
 |  | 0 |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=BodyFlags (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | uint16_t | ,
 |  | ContactReportFlags | ,
 |  | (1) | ,
 |  | 0 |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=ContactReportFlags (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | const char * | ,
 |  | Name | ,
 |  | (1) | ,
 |  | NULL |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=Name (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | void * | ,
 |  | UserData | ,
 |  | (1) | ,
 |  | NULL |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=UserData (see APEX_ACTOR_TEMPLATE_PARAM)

nvidia::apex::PhysX3DescTemplate::APEX_ACTOR_TEMPLATE_PARAM | ( | physx::PxClientID | ,
 |  | OwnerClient | ,
 |  | (1) | ,
 |  | 0 |
 | ) |  |

getX(), setX(), getDefaultX(), and isXValid() for X=OwnerClient (see APEX_ACTOR_TEMPLATE_PARAM)

virtual physx::PxMaterial** nvidia::apex::PhysX3DescTemplate::getMaterials ( uint32_t & materialCount ) const [pure virtual]

getMaterials function is non-generic, as it returns two parameters (the materials array and the array size in materialCount)

virtual void nvidia::apex::PhysX3DescTemplate::release ( ) [pure virtual]

Use this method to release this object

virtual bool nvidia::apex::PhysX3DescTemplate::setMaterials | ( | physx::PxMaterial ** | materialArray,
 |  | uint32_t | materialCount
 | ) |  | [pure virtual]

setMaterials function is non-generic, as it sets two parameters (the materials array in materialArray and the array size in materialCount)

The documentation for this class was generated from the following file:
  • Actor.h
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • PhysX3DescTemplate
nvidia::apex::PhysX3DescTemplate Member List
This is the complete list of members for nvidia::apex::PhysX3DescTemplate, including all inherited members.
APEX_ACTOR_TEMPLATE_PARAM(physx::PxDominanceGroup, DominanceGroup,(1), 0) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(uint8_t, ActorFlags,(1), physx::PxActorFlag::eSEND_SLEEP_NOTIFIES) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(physx::PxClientID, OwnerClient,(1), 0) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(uint32_t, ClientBehaviorBits,(1), 0) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(uint16_t, ContactReportFlags,(1), 0) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(void *, UserData,(1), NULL) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(const char *, Name,(1), NULL) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(float, Density,(x >=0.0f), 1.0f) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(uint8_t, BodyFlags,(1), 0) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(float, WakeUpCounter,(x >=0.0f), APEX_DEFAULT_WAKE_UP_COUNTER) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(float, LinearDamping,(x >=0.0f), 0.0f) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(float, AngularDamping,(x >=0.0f), 0.05f) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(float, MaxAngularVelocity,(1), 7.0f) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(float, SleepLinearVelocity,(1), 0.0f) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(uint32_t, SolverIterationCount,(x >=1 &&x<=255), 4) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(uint32_t, VelocityIterationCount,(x >=1 &&x<=255), 1) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(float, ContactReportThreshold,(1), PX_MAX_F32) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(float, SleepThreshold,(1), 0.005f) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(uint8_t, ShapeFlags,(1), physx::PxShapeFlag::eSIMULATION_SHAPE|physx::PxShapeFlag::eSCENE_QUERY_SHAPE|physx::PxShapeFlag::eVISUALIZATION) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(void *, ShapeUserData,(1), NULL) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(const char *, ShapeName,(1), NULL) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(physx::PxFilterData, SimulationFilterData,(1), physx::PxFilterData(0, 0, 0, 0)) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(physx::PxFilterData, QueryFilterData,(1), physx::PxFilterData(0, 0, 0, 0)) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(float, ContactOffset,(1),-1.0f) | nvidia::apex::PhysX3DescTemplate |
APEX_ACTOR_TEMPLATE_PARAM(float, RestOffset,(1), PX_MAX_F32) | nvidia::apex::PhysX3DescTemplate |
getMaterials(uint32_t &materialCount) const =0 | nvidia::apex::PhysX3DescTemplate | [pure virtual]
release()=0 | nvidia::apex::PhysX3DescTemplate | [pure virtual]
setMaterials(physx::PxMaterial **materialArray, uint32_t materialCount)=0 | nvidia::apex::PhysX3DescTemplate | [pure virtual]
~PhysX3DescTemplate() (defined in nvidia::apex::PhysX3DescTemplate) | nvidia::apex::PhysX3DescTemplate | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: nvidia::apex::PhysX3Interface Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • PhysX3Interface
Public Member Functions
nvidia::apex::PhysX3Interface Class Reference

Interface used to call setter function for PhysX 3.0. More...

#include <Scene.h>

List of all members.

Public Member Functions

virtual void | setContactReportFlags (PxShape *shape, physx::PxPairFlags flags, DestructibleActor *actor, uint16_t actorChunkIndex)=0
Set the current contact report pair flags any time the Destructible module creates a PhysX 3.x shape.
virtual physx::PxPairFlags | getContactReportFlags (const physx::PxShape *shape) const =0
Get the current contact report pair flags.

Detailed Description

Interface used to call setter function for PhysX 3.0.

Member Function Documentation

virtual void nvidia::apex::PhysX3Interface::setContactReportFlags | ( | PxShape * | shape,
 |  | physx::PxPairFlags | flags,
 |  | DestructibleActor * | actor,
 |  | uint16_t | actorChunkIndex
 | ) |  | [pure virtual]

Set the current contact report pair flags any time the Destructible module creates a PhysX 3.x shape.

User can set the report pair flags to specified actor

The documentation for this class was generated from the following file:
  • Scene.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • PhysX3Interface
nvidia::apex::PhysX3Interface Member List
This is the complete list of members for nvidia::apex::PhysX3Interface, including all inherited members.
getContactReportFlags(const physx::PxShape *shape) const =0 | nvidia::apex::PhysX3Interface | [pure virtual]
setContactReportFlags(PxShape *shape, physx::PxPairFlags flags, DestructibleActor *actor, uint16_t actorChunkIndex)=0 | nvidia::apex::PhysX3Interface | [pure virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::PhysXObjectDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • PhysXObjectDesc
Public Member Functions | Public Attributes | Protected Types | Protected Attributes
nvidia::apex::PhysXObjectDesc Class Reference

PhysX object descriptor. More...

#include <PhysXObjectDesc.h>

List of all members.

Public Member Functions

virtual uint32_t | getApexActorCount () const =0
Returns the number of Actors associated with the PhysX object.
virtual const Actor * | getApexActor (uint32_t i) const =0
Returns the indexed Actor pointer.
bool | ignoreTransform () const
Returns whether this object's xform should be ignored.
bool | ignoreRaycasts () const
Returns whether this object should be ignored by raycasts.
bool | ignoreContacts () const
Returns whether this object should be ignored by contact report callbacks.
bool | getUserDefinedFlag (uint32_t index) const
Returns a user defined status bit.

Public Attributes

void * | userData
User data, for use by APEX.

Protected Types

enum {
TRANSFORM = (1U << 31),
RAYCASTS = (1U << 30),
CONTACTS = (1U << 29)
}

Protected Attributes

uint32_t | mFlags
Object interaction flags.

Detailed Description

PhysX object descriptor.

Class which describes how a PhysX object is being used by APEX. Data access is non virtual for performance reasons.

Member Enumeration Documentation

anonymous enum [protected]
Enumerator:
TRANSFORM

If set, ignore this object's xform in active actor callbacks.

RAYCASTS

If set, ignore this object in raycasts.

CONTACTS

If set, ignore this object in contact callbacks.

Member Data Documentation

uint32_t nvidia::apex::PhysXObjectDesc::mFlags [protected]

Object interaction flags.

These flags determine how this PhysX object should interact with user callbacks. For instance whether contact callbacks with the object should be ignored.

void* nvidia::apex::PhysXObjectDesc::userData

User data, for use by APEX.

For internal use by APEX. Please do not modify this field. You may use the PhysX object userData or Actor userData field.

The documentation for this class was generated from the following file:
  • PhysXObjectDesc.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • PhysXObjectDesc
nvidia::apex::PhysXObjectDesc Member List
This is the complete list of members for nvidia::apex::PhysXObjectDesc, including all inherited members.
CONTACTS enum value | nvidia::apex::PhysXObjectDesc | [protected]
getApexActor(uint32_t i) const =0 | nvidia::apex::PhysXObjectDesc | [pure virtual]
getApexActorCount() const =0 | nvidia::apex::PhysXObjectDesc | [pure virtual]
getUserDefinedFlag(uint32_t index) const | nvidia::apex::PhysXObjectDesc | [inline]
ignoreContacts() const | nvidia::apex::PhysXObjectDesc | [inline]
ignoreRaycasts() const | nvidia::apex::PhysXObjectDesc | [inline]
ignoreTransform() const | nvidia::apex::PhysXObjectDesc | [inline]
mFlags | nvidia::apex::PhysXObjectDesc | [protected]
RAYCASTS enum value | nvidia::apex::PhysXObjectDesc | [protected]
TRANSFORM enum value | nvidia::apex::PhysXObjectDesc | [protected]
userData | nvidia::apex::PhysXObjectDesc |
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::PhysXRenderBuffer Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • PhysXRenderBuffer
Public Member Functions | Public Attributes
nvidia::apex::PhysXRenderBuffer Class Reference

This is a helper class implementation of PxRenderBuffer that holds the counts and pointers for renderable data. Does not own the memory, simply used to transfer the state. The append method is not supported. More...

#include <RenderDebugInterface.h>

List of all members.

Public Member Functions

virtual uint32_t | getNbPoints () const
Get number of points in the render buffer.
virtual const PxDebugPoint * | getPoints () const
Get points data.
virtual uint32_t | getNbLines () const
Get number of lines in the render buffer.
virtual const PxDebugLine * | getLines () const
Get lines data.
virtual uint32_t | getNbTriangles () const
Get number of triangles in the render buffer.
virtual const PxDebugTriangle * | getTriangles () const
Get triangles data.
virtual uint32_t | getNbTexts () const
Get number of texts in the render buffer.
virtual const PxDebugText * | getTexts () const
Get texts data.
virtual void | append (const PxRenderBuffer &other)
Append PhysX render buffer.
virtual void | clear ()
Clear this buffer.

Public Attributes

uint32_t | mNbPoints
Number of points.
PxDebugPoint * | mPoints
Points data.
uint32_t | mNbLines
Number of lines.
PxDebugLine * | mLines
Lines data.
uint32_t | mNbTriangles
Number of triangles.
PxDebugTriangle * | mTriangles
Triangles data.
uint32_t | mNbTexts
Number of texts.
PxDebugText * | mTexts
Text data.

Detailed Description

This is a helper class implementation of PxRenderBuffer that holds the counts and pointers for renderable data. Does not own the memory, simply used to transfer the state. The append method is not supported.

The documentation for this class was generated from the following file:
  • RenderDebugInterface.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • PhysXRenderBuffer
nvidia::apex::PhysXRenderBuffer Member List
This is the complete list of members for nvidia::apex::PhysXRenderBuffer, including all inherited members.
append(const PxRenderBuffer &other) | nvidia::apex::PhysXRenderBuffer | [inline, virtual]
clear() | nvidia::apex::PhysXRenderBuffer | [inline, virtual]
getLines() const | nvidia::apex::PhysXRenderBuffer | [inline, virtual]
getNbLines() const | nvidia::apex::PhysXRenderBuffer | [inline, virtual]
getNbPoints() const | nvidia::apex::PhysXRenderBuffer | [inline, virtual]
getNbTexts() const | nvidia::apex::PhysXRenderBuffer | [inline, virtual]
getNbTriangles() const | nvidia::apex::PhysXRenderBuffer | [inline, virtual]
getPoints() const | nvidia::apex::PhysXRenderBuffer | [inline, virtual]
getTexts() const | nvidia::apex::PhysXRenderBuffer | [inline, virtual]
getTriangles() const | nvidia::apex::PhysXRenderBuffer | [inline, virtual]
mLines | nvidia::apex::PhysXRenderBuffer |
mNbLines | nvidia::apex::PhysXRenderBuffer |
mNbPoints | nvidia::apex::PhysXRenderBuffer |
mNbTexts | nvidia::apex::PhysXRenderBuffer |
mNbTriangles | nvidia::apex::PhysXRenderBuffer |
mPoints | nvidia::apex::PhysXRenderBuffer |
mTexts | nvidia::apex::PhysXRenderBuffer |
mTriangles | nvidia::apex::PhysXRenderBuffer |
PhysXRenderBuffer() (defined in nvidia::apex::PhysXRenderBuffer) | nvidia::apex::PhysXRenderBuffer | [inline]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::PxStreamFromFileBuf Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • PxStreamFromFileBuf
Public Member Functions
nvidia::apex::PxStreamFromFileBuf Class Reference

A wrapper class that provides an NvStream API for a PxFileBuf. More...

#include <PxStreamFromFileBuf.h>

List of all members.

Public Member Functions

PxStreamFromFileBuf (physx::PxFileBuf &fb)
Constructor that takes a PxFileBuf.
uint32_t | read (void *dest, uint32_t count)
Read data from the stream.
uint32_t | write (const void *src, uint32_t count)
Read data to the stream.

Detailed Description

A wrapper class that provides an NvStream API for a PxFileBuf.

The documentation for this class was generated from the following file:
  • PxStreamFromFileBuf.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • PxStreamFromFileBuf
nvidia::apex::PxStreamFromFileBuf Member List
This is the complete list of members for nvidia::apex::PxStreamFromFileBuf, including all inherited members.
PxStreamFromFileBuf(physx::PxFileBuf &fb) | nvidia::apex::PxStreamFromFileBuf | [inline]
read(void *dest, uint32_t count) | nvidia::apex::PxStreamFromFileBuf | [inline]
write(const void *src, uint32_t count) | nvidia::apex::PxStreamFromFileBuf | [inline]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::RWLockable Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RWLockable
Public Member Functions
nvidia::apex::RWLockable Class Reference

Base class for any rw-lockable object implemented by APEX SDK. More...

#include <RWLockable.h>

Inheritance diagram for nvidia::apex::RWLockable:
nvidia::apex::ApexInterface nvidia::apex::Actor nvidia::apex::ApexSDK nvidia::apex::Asset nvidia::apex::AssetAuthoring nvidia::apex::AssetPreview nvidia::apex::AssetPreviewScene nvidia::apex::ClothingCollision nvidia::apex::ClothingPhysicalMesh nvidia::apex::ClothingRenderProxy nvidia::apex::DestructibleActorJoint nvidia::apex::DestructibleRenderable nvidia::apex::IofxRenderable nvidia::apex::IofxRenderableIterator nvidia::apex::Module nvidia::apex::RenderableIterator nvidia::apex::RenderDebugInterface nvidia::apex::RenderVolume nvidia::apex::Scene nvidia::apex::TurbulenceRenderable

List of all members.

Public Member Functions

virtual void | acquireReadLock (const char *fileName, const uint32_t lineno) const =0
Acquire RW lock for read access.
virtual void | acquireWriteLock (const char *fileName, const uint32_t lineno) const =0
Acquire RW lock for write access.
virtual void | releaseReadLock (void) const =0
Release the RW read lock.
virtual void | releaseWriteLock (void) const =0
Release the RW write lock.

Detailed Description

Base class for any rw-lockable object implemented by APEX SDK.

Member Function Documentation

virtual void nvidia::apex::RWLockable::acquireReadLock | ( | const char * | fileName,
 |  | const uint32_t | lineno
 | ) |  | const [pure virtual]

Acquire RW lock for read access.

The APEX 1.3.3 SDK (and higher) provides a multiple-reader single writer mutex lock to coordinate access to the APEX SDK API from multiple concurrent threads. This method will in turn invoke the lockRead call on the APEX Scene. The source code fileName and line number are provided for debugging purposes.

virtual void nvidia::apex::RWLockable::acquireWriteLock | ( | const char * | fileName,
 |  | const uint32_t | lineno
 | ) |  | const [pure virtual]

Acquire RW lock for write access.

The APEX 1.3.3 SDK (and higher) provides a multiple-reader single writer mutex lock to coordinate access to the APEX SDK API from multiple concurrent threads. This method will in turn invoke the lockRead call on the APEX Scene. The source code fileName and line number are provided for debugging purposes.

The documentation for this class was generated from the following file:
  • RWLockable.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RWLockable
nvidia::apex::RWLockable Member List
This is the complete list of members for nvidia::apex::RWLockable, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RandomRotationModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RandomRotationModifier
Public Member Functions | Static Public Attributes
nvidia::apex::RandomRotationModifier Class Reference

RandomRotationModifier will choose a random orientation for a sprite particle within the range as specified below. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::RandomRotationModifier:
nvidia::apex::ModifierT< RandomRotationModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual Range< float > | getRotationRange () const =0
get the range of orientations, in radians.
virtual void | setRotationRange (const Range< float > &s)=0
set the range of orientations, in radians.

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_RandomRotation
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

RandomRotationModifier will choose a random orientation for a sprite particle within the range as specified below.

The values in the range are interpreted as radians. Please keep in mind that all the sprites are coplanar to the screen.

Member Data Documentation

const uint32_t nvidia::apex::RandomRotationModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RandomRotationModifier
nvidia::apex::RandomRotationModifier Member List
This is the complete list of members for nvidia::apex::RandomRotationModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< RandomRotationModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< RandomRotationModifier > | [inline, virtual]
getRotationRange() const =0 | nvidia::apex::RandomRotationModifier | [pure virtual]
ModifierType | nvidia::apex::RandomRotationModifier | [static]
ModifierUsage | nvidia::apex::RandomRotationModifier | [static]
setRotationRange(const Range< float > &s)=0 | nvidia::apex::RandomRotationModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::RandomScaleModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RandomScaleModifier
Public Member Functions | Static Public Attributes
nvidia::apex::RandomScaleModifier Class Reference

RandomScaleModifier applies a random scale uniformly to all three dimensions. Currently, the scale is a uniform in the range specified. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::RandomScaleModifier:
nvidia::apex::ModifierT< RandomScaleModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual Range< float > | getScaleFactor () const =0
get the range of scale factors along the three axes
virtual void | setScaleFactor (const Range< float > &s)=0
set the range of scale factors along the three axes

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_RandomScale
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

RandomScaleModifier applies a random scale uniformly to all three dimensions. Currently, the scale is a uniform in the range specified.

Member Data Documentation

const uint32_t nvidia::apex::RandomScaleModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RandomScaleModifier
nvidia::apex::RandomScaleModifier Member List
This is the complete list of members for nvidia::apex::RandomScaleModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< RandomScaleModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< RandomScaleModifier > | [inline, virtual]
getScaleFactor() const =0 | nvidia::apex::RandomScaleModifier | [pure virtual]
ModifierType | nvidia::apex::RandomScaleModifier | [static]
ModifierUsage | nvidia::apex::RandomScaleModifier | [static]
setScaleFactor(const Range< float > &s)=0 | nvidia::apex::RandomScaleModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::RandomSubtextureModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RandomSubtextureModifier
Public Member Functions | Static Public Attributes
nvidia::apex::RandomSubtextureModifier Class Reference

RandomSubtextureModifier generates a random subtexture ID and places it in the subTextureId field. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::RandomSubtextureModifier:
nvidia::apex::ModifierT< RandomSubtextureModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual Range< float > | getSubtextureRange () const =0
get the range for subtexture values
virtual void | setSubtextureRange (const Range< float > &s)=0
set the range for subtexture values

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_RandomSubtexture
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

RandomSubtextureModifier generates a random subtexture ID and places it in the subTextureId field.

Member Data Documentation

const uint32_t nvidia::apex::RandomSubtextureModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RandomSubtextureModifier
nvidia::apex::RandomSubtextureModifier Member List
This is the complete list of members for nvidia::apex::RandomSubtextureModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< RandomSubtextureModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< RandomSubtextureModifier > | [inline, virtual]
getSubtextureRange() const =0 | nvidia::apex::RandomSubtextureModifier | [pure virtual]
ModifierType | nvidia::apex::RandomSubtextureModifier | [static]
ModifierUsage | nvidia::apex::RandomSubtextureModifier | [static]
setSubtextureRange(const Range< float > &s)=0 | nvidia::apex::RandomSubtextureModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ReadLock Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ReadLock
Public Member Functions
nvidia::apex::ReadLock Class Reference

RAII wrapper for the Scene read lock. More...

#include <Lock.h>

List of all members.

Public Member Functions

ReadLock (const ApexInterface &lockable, const char *file=NULL, uint32_t line=0)
Constructor.

Detailed Description

RAII wrapper for the Scene read lock.

Use this class as follows to lock the scene for reading by the current thread for the duration of the enclosing scope:

ReadLock lock(sceneRef);

See also:
Scene::apexacquireReadLock(), Scene::apexUnacquireReadLock(), SceneDesc::useRWLock

Constructor & Destructor Documentation

nvidia::apex::ReadLock::ReadLock | ( | const ApexInterface & | lockable,
 |  | const char * | file = NULL,
 |  | uint32_t | line = 0
 | ) |  | [inline]

Constructor.

Parameters:
lockable | The object to lock for reading
file | Optional string for debugging purposes
line | Optional line number for debugging purposes
The documentation for this class was generated from the following file:
  • Lock.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ReadLock
nvidia::apex::ReadLock Member List
This is the complete list of members for nvidia::apex::ReadLock, including all inherited members.
ReadLock(const ApexInterface &lockable, const char *file=NULL, uint32_t line=0) | nvidia::apex::ReadLock | [inline]
~ReadLock() (defined in nvidia::apex::ReadLock) | nvidia::apex::ReadLock | [inline]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::RenderBoneBufferData Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderBoneBufferData
nvidia::apex::RenderBoneBufferData Class Reference

type of the bone buffer data More...

#include <UserRenderBoneBuffer.h>

Inheritance diagram for nvidia::apex::RenderBoneBufferData:
nvidia::apex::RenderBufferData< RenderBoneSemantic, RenderBoneSemantic::Enum >

List of all members.

Detailed Description

type of the bone buffer data

The documentation for this class was generated from the following file:
  • UserRenderBoneBuffer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderBoneBufferData
nvidia::apex::RenderBoneBufferData Member List
This is the complete list of members for nvidia::apex::RenderBoneBufferData, including all inherited members.
getCustomSemanticData(uint32_t index) const | nvidia::apex::RenderBufferData< RenderBoneSemantic, RenderBoneSemantic::Enum > | [inline]
getNumCustomSemantics() const | nvidia::apex::RenderBufferData< RenderBoneSemantic, RenderBoneSemantic::Enum > | [inline]
getSemanticData(RenderBoneSemantic::Enumsemantic) const | nvidia::apex::RenderBufferData< RenderBoneSemantic, RenderBoneSemantic::Enum > | [inline]
RenderBufferData(void) (defined in nvidia::apex::RenderBufferData< RenderBoneSemantic, RenderBoneSemantic::Enum >) | nvidia::apex::RenderBufferData< RenderBoneSemantic, RenderBoneSemantic::Enum > | [inline]
setCustomSemanticData(RenderSemanticData *data, uint32_t num) | nvidia::apex::RenderBufferData< RenderBoneSemantic, RenderBoneSemantic::Enum > | [inline]
setSemanticData(RenderBoneSemantic::Enumsemantic, const void *data, uint32_t stride, RenderDataFormat::Enum format, RenderDataFormat::Enum srcFormat=RenderDataFormat::UNSPECIFIED) | nvidia::apex::RenderBufferData< RenderBoneSemantic, RenderBoneSemantic::Enum > | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum > Class Template Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderBufferData
Public Member Functions
nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum > Class Template Reference

Describes all of the semantics of a render buffer. More...

#include <RenderBufferData.h>

List of all members.

Public Member Functions

PX_INLINE const
RenderSemanticData & 		getSemanticData (SemanticEnum semantic) const
Returns the properties of a base semantic.
PX_INLINE uint32_t | getNumCustomSemantics () const
Returns the number of custom semantics.
PX_INLINE const
RenderSemanticData & 		getCustomSemanticData (uint32_t index) const
Returns the properties of a custom semantic.
PX_INLINE void | setCustomSemanticData (RenderSemanticData *data, uint32_t num)
Set a specific set of custom semantics on this data buffer.
PX_INLINE void | setSemanticData (SemanticEnum semantic, const void *data, uint32_t stride, RenderDataFormat::Enum format, RenderDataFormat::Enum srcFormat=RenderDataFormat::UNSPECIFIED)
Set the properties (pointer and stride) of a base semantic.

Detailed Description

template<class SemanticClass, class SemanticEnum>
class nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >

Describes all of the semantics of a render buffer.

Member Function Documentation

template<class SemanticClass, class SemanticEnum>
PX_INLINE void nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >::setCustomSemanticData | ( | RenderSemanticData * | data,
 |  | uint32_t | num
 | ) |  | [inline]

Set a specific set of custom semantics on this data buffer.

If there are named custom semantics in a RenderMeshAsset, its RenderMeshActor will call this function to set those semantics on this buffer.

The documentation for this class was generated from the following file:
  • RenderBufferData.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderBufferData
nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum > Member List
This is the complete list of members for nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >, including all inherited members.
getCustomSemanticData(uint32_t index) const | nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum > | [inline]
getNumCustomSemantics() const | nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum > | [inline]
getSemanticData(SemanticEnum semantic) const | nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum > | [inline]
RenderBufferData(void) (defined in nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >) | nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum > | [inline]
setCustomSemanticData(RenderSemanticData *data, uint32_t num) | nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum > | [inline]
setSemanticData(SemanticEnum semantic, const void *data, uint32_t stride, RenderDataFormat::Enum format, RenderDataFormat::Enum srcFormat=RenderDataFormat::UNSPECIFIED) | nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum > | [inline]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderContext Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderContext
Public Attributes
nvidia::apex::RenderContext Class Reference

Describes the context of a renderable object. More...

#include <RenderContext.h>

List of all members.

Public Attributes

UserRenderResource * renderResource
The renderable resource to be rendered.
bool | isScreenSpace
The data is in screenspace and should use a screenspace projection that transforms X -1 to +1 and Y -1 to +1 with zbuffer disabled.
PxMat44 | local2world
Reverse world pose transform for this renderable.
PxMat44 | world2local
World pose transform for this renderable.
const char * | renderMeshName
The name of the render mesh this context is associated with.

Detailed Description

Describes the context of a renderable object.

The documentation for this class was generated from the following file:
  • RenderContext.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderContext
nvidia::apex::RenderContext Member List
This is the complete list of members for nvidia::apex::RenderContext, including all inherited members.
isScreenSpace | nvidia::apex::RenderContext |
local2world | nvidia::apex::RenderContext |
RenderContext(void) (defined in nvidia::apex::RenderContext) | nvidia::apex::RenderContext | [inline]
renderMeshName | nvidia::apex::RenderContext |
renderResource | nvidia::apex::RenderContext |
world2local | nvidia::apex::RenderContext |
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderDataProvider Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderDataProvider
Public Member Functions
nvidia::apex::RenderDataProvider Class Reference

An actor instance that provides renderable data. More...

#include <RenderDataProvider.h>

Inheritance diagram for nvidia::apex::RenderDataProvider:
nvidia::apex::Renderable nvidia::apex::AssetPreview nvidia::apex::AttractorFSActor nvidia::apex::ClothingActor nvidia::apex::ClothingRenderProxy nvidia::apex::DestructibleActor nvidia::apex::DestructibleRenderable nvidia::apex::JetFSActor nvidia::apex::NoiseFSActor nvidia::apex::RenderDebugInterface nvidia::apex::RenderMeshActor nvidia::apex::Scene nvidia::apex::TurbulenceFSActor nvidia::apex::VortexFSActor nvidia::apex::WindFSActor

List of all members.

Public Member Functions

virtual void | lockRenderResources ()=0
Lock the renderable resources of this Renderable actor.
virtual void | unlockRenderResources ()=0
Unlocks the renderable data of this Renderable actor.
virtual void | updateRenderResources (bool rewriteBuffers=false, void *userRenderData=0)=0
Update the renderable data of this Renderable actor.

Detailed Description

An actor instance that provides renderable data.

Member Function Documentation

virtual void nvidia::apex::RenderDataProvider::lockRenderResources ( ) [pure virtual]

Lock the renderable resources of this Renderable actor.

Locks the renderable data of this Renderable actor. If the user uses an RenderableIterator to retrieve the list of Renderables, then locking is handled for them automatically by APEX. If the user is storing Renderable pointers and using them ad-hoc, then they must use this API to lock the actor while updateRenderResources() and/or dispatchRenderResources() is called. If an iterator is not being used, the user is also responsible for insuring the Renderable has not been deleted by another game thread.

virtual void nvidia::apex::RenderDataProvider::unlockRenderResources ( ) [pure virtual]

Unlocks the renderable data of this Renderable actor.

See locking semantics for RenderDataProvider::lockRenderResources().

virtual void nvidia::apex::RenderDataProvider::updateRenderResources | ( | bool | rewriteBuffers = false,
 |  | void * | userRenderData = 0
 | ) |  | [pure virtual]

Update the renderable data of this Renderable actor.

When called, this method will use the UserRenderResourceManager interface to inform the user about its render resource needs. It will also call the writeBuffer() methods of various graphics buffers. It must be called by the user each frame before any calls to dispatchRenderResources(). If the actor is not being rendered, this function may also be skipped.

Parameters:
[in] | rewriteBuffers | If true then static buffers will be rewritten (in the case of a graphics device context being lost if managed buffers aren't being used)
[in] | userRenderData | A pointer used by the application for context information which will be sent in the UserRenderResourceManager::createResource() method as a member of the UserRenderResourceDesc class.
The documentation for this class was generated from the following file:
  • RenderDataProvider.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderDataProvider
nvidia::apex::RenderDataProvider Member List
This is the complete list of members for nvidia::apex::RenderDataProvider, including all inherited members.
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderDebugInterface Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderDebugInterface
Public Member Functions
nvidia::apex::RenderDebugInterface Class Reference

wrapper for DebugRenderable More...

#include <RenderDebugInterface.h>

Inheritance diagram for nvidia::apex::RenderDebugInterface:
nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void | setUseDebugRenderable (bool state)=0
Method to support rendering to a legacy PhysX SDK DebugRenderable object instead of to the APEX Render Resources API (i.e.: Renderable).
virtual void | getRenderBuffer (PhysXRenderBuffer &renderable)=0
Method to support rendering to a legacy PhysX SDK PxRenderBuffer object instead of to the APEX Render Resources API (i.e.: Renderable).
virtual void | getRenderBufferScreenSpace (PhysXRenderBuffer &renderable)=0
Method to support rendering to a legacy PhysX SDK PxRenderBuffer object instead of to the APEX Render Resources API (i.e.: Renderable). Lines and triangle in screen space.
virtual void | addDebugRenderable (const physx::PxRenderBuffer &renderBuffer)=0
Method to support rendering from an existing PhysX SDK PxRenderBuffer object.
virtual void | release ()=0
Release an object instance.
virtual
RENDER_DEBUG::RenderDebugTyped * 		getRenderDebugInterface ()=0
Returns render debug interface RENDER_DEBUG::RenderDebugTyped.

Detailed Description

wrapper for DebugRenderable

Member Function Documentation

virtual void nvidia::apex::RenderDebugInterface::addDebugRenderable ( const physx::PxRenderBuffer & renderBuffer ) [pure virtual]

Method to support rendering from an existing PhysX SDK PxRenderBuffer object.

The contents of the PxRenderBuffer is added to the current contents of the RenderDebug object, and is output through the APEX Render Resources API.

virtual void nvidia::apex::RenderDebugInterface::getRenderBuffer ( PhysXRenderBuffer & renderable ) [pure virtual]

Method to support rendering to a legacy PhysX SDK PxRenderBuffer object instead of to the APEX Render Resources API (i.e.: Renderable).

When enabled with a call to setUseDebugRenderable(true), this method will return a legacy PxRenderBuffer object that contains all of the output of the RenderDebug class.

virtual void nvidia::apex::RenderDebugInterface::getRenderBufferScreenSpace ( PhysXRenderBuffer & renderable ) [pure virtual]

Method to support rendering to a legacy PhysX SDK PxRenderBuffer object instead of to the APEX Render Resources API (i.e.: Renderable). Lines and triangle in screen space.

When enabled with a call to setUseDebugRenderable(true), this method will return a legacy PxRenderBuffer object that contains all of the output of the RenderDebug class.

virtual void nvidia::apex::RenderDebugInterface::release ( ) [pure virtual]

Release an object instance.

Calling this will unhook the class and delete it from memory. You should not keep any reference to this class instance after calling release

Implements nvidia::apex::ApexInterface.

virtual void nvidia::apex::RenderDebugInterface::setUseDebugRenderable ( bool state ) [pure virtual]

Method to support rendering to a legacy PhysX SDK DebugRenderable object instead of to the APEX Render Resources API (i.e.: Renderable).

This method is used to enable or disable the use of a legacy DebugRenderable. When enabled, use the getDebugRenderable() method to get a legacy DebugRenerable object that will contain all the debug output.

The documentation for this class was generated from the following file:
  • RenderDebugInterface.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderDebugInterface
nvidia::apex::RenderDebugInterface Member List
This is the complete list of members for nvidia::apex::RenderDebugInterface, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
addDebugRenderable(const physx::PxRenderBuffer &renderBuffer)=0 | nvidia::apex::RenderDebugInterface | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getRenderBuffer(PhysXRenderBuffer &renderable)=0 | nvidia::apex::RenderDebugInterface | [pure virtual]
getRenderBufferScreenSpace(PhysXRenderBuffer &renderable)=0 | nvidia::apex::RenderDebugInterface | [pure virtual]
getRenderDebugInterface()=0 | nvidia::apex::RenderDebugInterface | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::RenderDebugInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setUseDebugRenderable(bool state)=0 | nvidia::apex::RenderDebugInterface | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
~RenderDebugInterface(void) (defined in nvidia::apex::RenderDebugInterface) | nvidia::apex::RenderDebugInterface | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderInstanceBufferData Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderInstanceBufferData
nvidia::apex::RenderInstanceBufferData Class Reference

The instance buffer type (deprecated) More...

#include <UserRenderInstanceBuffer.h>

Inheritance diagram for nvidia::apex::RenderInstanceBufferData:
nvidia::apex::RenderBufferData< RenderInstanceSemantic, RenderInstanceSemantic::Enum >

List of all members.

Detailed Description

The instance buffer type (deprecated)

The documentation for this class was generated from the following file:
  • UserRenderInstanceBuffer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderInstanceBufferData
nvidia::apex::RenderInstanceBufferData Member List
This is the complete list of members for nvidia::apex::RenderInstanceBufferData, including all inherited members.
getCustomSemanticData(uint32_t index) const | nvidia::apex::RenderBufferData< RenderInstanceSemantic, RenderInstanceSemantic::Enum > | [inline]
getNumCustomSemantics() const | nvidia::apex::RenderBufferData< RenderInstanceSemantic, RenderInstanceSemantic::Enum > | [inline]
getSemanticData(RenderInstanceSemantic::Enumsemantic) const | nvidia::apex::RenderBufferData< RenderInstanceSemantic, RenderInstanceSemantic::Enum > | [inline]
RenderBufferData(void) (defined in nvidia::apex::RenderBufferData< RenderInstanceSemantic, RenderInstanceSemantic::Enum >) | nvidia::apex::RenderBufferData< RenderInstanceSemantic, RenderInstanceSemantic::Enum > | [inline]
setCustomSemanticData(RenderSemanticData *data, uint32_t num) | nvidia::apex::RenderBufferData< RenderInstanceSemantic, RenderInstanceSemantic::Enum > | [inline]
setSemanticData(RenderInstanceSemantic::Enumsemantic, const void *data, uint32_t stride, RenderDataFormat::Enum format, RenderDataFormat::Enum srcFormat=RenderDataFormat::UNSPECIFIED) | nvidia::apex::RenderBufferData< RenderInstanceSemantic, RenderInstanceSemantic::Enum > | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderMeshActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshActor
Public Types | Public Member Functions
nvidia::apex::RenderMeshActor Class Reference

Renderable mesh (dynamic data associated with RenderMeshAsset) More...

#include <RenderMeshActor.h>

Inheritance diagram for nvidia::apex::RenderMeshActor:
nvidia::apex::Actor nvidia::apex::Renderable nvidia::apex::ApexInterface nvidia::apex::RenderDataProvider nvidia::apex::RWLockable

List of all members.

Public Types

enum | { InvalidInstanceID = 0xFFFFFFFF }

Public Member Functions

virtual bool | getVisibilities (uint8_t *visibilityArray, uint32_t visibilityArraySize) const =0
Returns the visibilities of all mesh parts in the given array.
virtual bool | setVisibility (bool visible, uint16_t partIndex=0)=0
Set the visibility of the indexed part. Returns true iff the visibility for the part is changed by this operation.
virtual bool | isVisible (uint16_t partIndex=0) const =0
Returns the visibility of the indexed part.
virtual uint32_t | visiblePartCount () const =0
Returns the number of visible parts.
virtual const uint32_t * | getVisibleParts () const =0
Returns an array of visible part indices.
virtual uint32_t | getBoneCount () const =0
Returns the number of bones used by this render mesh.
virtual void | setTM (const PxMat44 &tm, uint32_t boneIndex=0)=0
Sets the local-to-world transform for the indexed bone. The transform need not be orthonormal.
virtual void | setTM (const PxMat44 &tm, const PxVec3 &scale, uint32_t boneIndex=0)=0
Same as setTM(), but assumes tm is pure rotation.
virtual void | updateBounds ()=0
Update the axis-aligned bounding box which encloses all visible parts in their world-transformed poses.
virtual const PxMat44 | getTM (uint32_t boneIndex=0) const =0
Returns the local-to-world transform for the indexed bone.
virtual void | setReleaseResourcesIfNothingToRender (bool value)=0
If the number of visible parts becomes 0, or if instancing and the number of instances becomes 0, then release resources if this bool is true.
virtual void | setBufferVisibility (bool bufferVisibility)=0
If this set to true, render visibility will not be updated until the user calls syncVisibility().
virtual void | setOverrideMaterial (uint32_t submeshIndex, const char *overrideMaterialName)=0
Sets the override material for the submesh with the given index.
virtual void | syncVisibility (bool useLock=true)=0
Sync render visibility with that set by the user. Only needed if bufferVisibility(true) is called, or bufferVisibility = true in the actor's descriptor.
virtual UserRenderInstanceBuffer * | getInstanceBuffer () const =0
get the user-provided instance buffer.
virtual void | setInstanceBuffer (UserRenderInstanceBuffer *instBuf)=0
applies the user-provided instance buffer to all submeshes.
virtual void | setMaxInstanceCount (uint32_t count)=0
allows the user to change the max instance count in the case that the instance buffer was changed
virtual void | setInstanceBufferRange (uint32_t from, uint32_t count)=0
sets the range for the instance buffer
virtual bool | rayCast (RenderMeshActorRaycastHitData &hitData, const PxVec3 &worldOrig, const PxVec3 &worldDisp, RenderMeshActorRaycastFlags::Enum flags=RenderMeshActorRaycastFlags::VISIBLE_PARTS, RenderCullMode::Enum winding=RenderCullMode::CLOCKWISE, int32_t partIndex=-1) const =0

Detailed Description

Renderable mesh (dynamic data associated with RenderMeshAsset)

Member Function Documentation

virtual bool nvidia::apex::RenderMeshActor::getVisibilities | ( | uint8_t * | visibilityArray,
 |  | uint32_t | visibilityArraySize
 | ) |  | const [pure virtual]

Returns the visibilities of all mesh parts in the given array.

The user must supply the array size. If the size is less than the part count, then the list will be truncated to fit the given array.

Returns true if any of the visibility values in visibilityArray are changed.

virtual const uint32_t* nvidia::apex::RenderMeshActor::getVisibleParts ( ) const [pure virtual]

Returns an array of visible part indices.

The size of this array is given by visiblePartCount(). Note: the indices are in an arbitrary order.

virtual bool nvidia::apex::RenderMeshActor::rayCast | ( | RenderMeshActorRaycastHitData & | hitData,
 |  | const PxVec3 & | worldOrig,
 |  | const PxVec3 & | worldDisp,
 |  | RenderMeshActorRaycastFlags::Enum | flags = RenderMeshActorRaycastFlags::VISIBLE_PARTS,
 |  | RenderCullMode::Enum | winding = RenderCullMode::CLOCKWISE,
 |  | int32_t | partIndex = -1
 | ) |  | const [pure virtual]

Returns true if and only if a part is hit matching various criteria given in the function parameters. If a part is hit, the hitData field contains information about the ray intersection. (hitData may be modified even if the function returns false.) hitData (output) = information about the mesh at the hitpoint. See RenderMeshActorRaycastHitData. worldOrig = the origin of the ray in world space worldDisp = the displacement of the ray in world space (need not be normalized) flags = raycast control flags (see RenderMeshActorRaycastFlags) winding = winding filter for hit triangle. If RenderCullMode::CLOCKWISE or RenderCullMode::COUNTER_CLOCKWISE, then triangles will be assumed to have that winding, and will only contribute to the raycast if front-facing. If RenderCullMode::NONE, then all triangles will contribute. partIndex = If -1, then all mesh parts will be raycast, and the result returned for the earliest hit. Otherwise only the part indexed by partIndex will be raycast.

N.B. Currently only works for static (unskinned) and one transform per-part, single-weighted vertex skinning.

virtual void nvidia::apex::RenderMeshActor::setInstanceBufferRange | ( | uint32_t | from,
 |  | uint32_t | count
 | ) |  | [pure virtual]

sets the range for the instance buffer

Parameters:
from | the position in the buffer (measured in number of elements) to start reading from
count | number of instances to be rendered. Must not exceed maxInstances for this actor
virtual void nvidia::apex::RenderMeshActor::setTM | ( | const PxMat44 & | tm,
 |  | const PxVec3 & | scale,
 |  | uint32_t | boneIndex = 0
 | ) |  | [pure virtual]

Same as setTM(), but assumes tm is pure rotation.

This can allow some optimization. The user must supply scaling separately. The scale vector is interpreted as the diagonal of a diagonal matrix, applied before the rotation component of tm.

virtual void nvidia::apex::RenderMeshActor::syncVisibility ( bool useLock = true ) [pure virtual]

Sync render visibility with that set by the user. Only needed if bufferVisibility(true) is called, or bufferVisibility = true in the actor's descriptor.

If useLock == true, the RenderMeshActor's lock is used during the sync.

The documentation for this class was generated from the following file:
  • RenderMeshActor.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshActor
nvidia::apex::RenderMeshActor Member List
This is the complete list of members for nvidia::apex::RenderMeshActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getBoneCount() const =0 | nvidia::apex::RenderMeshActor | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getInstanceBuffer() const =0 | nvidia::apex::RenderMeshActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getTM(uint32_t boneIndex=0) const =0 | nvidia::apex::RenderMeshActor | [pure virtual]
getVisibilities(uint8_t *visibilityArray, uint32_t visibilityArraySize) const =0 | nvidia::apex::RenderMeshActor | [pure virtual]
getVisibleParts() const =0 | nvidia::apex::RenderMeshActor | [pure virtual]
InvalidInstanceID enum value (defined in nvidia::apex::RenderMeshActor) | nvidia::apex::RenderMeshActor |
isVisible(uint16_t partIndex=0) const =0 | nvidia::apex::RenderMeshActor | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
rayCast(RenderMeshActorRaycastHitData &hitData, const PxVec3 &worldOrig, const PxVec3 &worldDisp, RenderMeshActorRaycastFlags::Enum flags=RenderMeshActorRaycastFlags::VISIBLE_PARTS, RenderCullMode::Enum winding=RenderCullMode::CLOCKWISE, int32_t partIndex=-1) const =0 | nvidia::apex::RenderMeshActor | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setBufferVisibility(bool bufferVisibility)=0 | nvidia::apex::RenderMeshActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setInstanceBuffer(UserRenderInstanceBuffer *instBuf)=0 | nvidia::apex::RenderMeshActor | [pure virtual]
setInstanceBufferRange(uint32_t from, uint32_t count)=0 | nvidia::apex::RenderMeshActor | [pure virtual]
setMaxInstanceCount(uint32_t count)=0 | nvidia::apex::RenderMeshActor | [pure virtual]
setOverrideMaterial(uint32_t submeshIndex, const char *overrideMaterialName)=0 | nvidia::apex::RenderMeshActor | [pure virtual]
setReleaseResourcesIfNothingToRender(bool value)=0 | nvidia::apex::RenderMeshActor | [pure virtual]
setTM(const PxMat44 &tm, uint32_t boneIndex=0)=0 | nvidia::apex::RenderMeshActor | [pure virtual]
setTM(const PxMat44 &tm, const PxVec3 &scale, uint32_t boneIndex=0)=0 | nvidia::apex::RenderMeshActor | [pure virtual]
setVisibility(bool visible, uint16_t partIndex=0)=0 | nvidia::apex::RenderMeshActor | [pure virtual]
syncVisibility(bool useLock=true)=0 | nvidia::apex::RenderMeshActor | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateBounds()=0 | nvidia::apex::RenderMeshActor | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
visiblePartCount() const =0 | nvidia::apex::RenderMeshActor | [pure virtual]
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~RenderMeshActor() (defined in nvidia::apex::RenderMeshActor) | nvidia::apex::RenderMeshActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderMeshActorDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshActorDesc
Public Member Functions | Public Attributes
nvidia::apex::RenderMeshActorDesc Class Reference

Descriptor for creating a rendering mesh (collection of parts and submesh extra data) More...

#include <RenderMeshActorDesc.h>

Inheritance diagram for nvidia::apex::RenderMeshActorDesc:
nvidia::apex::ApexDesc

List of all members.

Public Member Functions

PX_INLINE | RenderMeshActorDesc ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE bool | isValid () const
Returns true if the descriptor is valid.

Public Attributes

bool | visible
Initial visibility of all parts.
bool | bufferVisibility
If this set to true, render visibility will not be updated until the user calls syncVisibility().
bool | keepVisibleBonesPacked
Pack visible bones.
bool | renderWithoutSkinning
Render without skinning.
bool | forceFallbackSkinning
Enforce the use of fallback skinning.
uint32_t | maxInstanceCount
If maxInstanceCount = 0, mesh will be renedered without instancing. Otherwise, instance buffers (below) will be used.
RenderBufferHint::Enum indexBufferHint
Hint passed along to the user describing whether the index buffer of this render mesh can be modified.
const char ** | overrideMaterials
Per-actor material names, to override those in the asset. The number of override material names is given by overrideMaterialCount.
uint32_t | overrideMaterialCount
Number of override material names in the overrideMaterials array. If this number is less than the number of materials in the asset, only the first overrideMaterialCount names will be overridden. If this number is greater than the number of materials in the asset, the extra override material names will be ignored.
bool | keepPreviousFrameBoneBuffer
If true, the previous frame's bone buffer is kept and delivered during updateRenderResources as a second bone buffer.
bool | forceBoneIndexChannel
If true, a static runtime bone index channel will be created.

Detailed Description

Descriptor for creating a rendering mesh (collection of parts and submesh extra data)

Member Function Documentation

PX_INLINE bool nvidia::apex::RenderMeshActorDesc::isValid ( void ) const [inline]

Returns true if the descriptor is valid.

Returns:
true if the current settings are valid.

Reimplemented from nvidia::apex::ApexDesc.

Member Data Documentation

bool nvidia::apex::RenderMeshActorDesc::forceFallbackSkinning

Enforce the use of fallback skinning.

This will not create render resources with bone buffers since all the skinning will be done on the CPU already. Does not work if keepVisibleBones is set. These two features are mutually exclusive.

bool nvidia::apex::RenderMeshActorDesc::keepVisibleBonesPacked

Pack visible bones.

If set, bone transform order will be maitained in an order that keeps visible bones contiguous. This is more efficient for cases where there are large number of nonvisible parts (it reduces the number of bone transforms that need to be updated in writeBuffer). This only works when vertices are single-weighted, and the number of bones equals the number of parts.

bool nvidia::apex::RenderMeshActorDesc::renderWithoutSkinning

Render without skinning.

If set, all vertices will be transformed by one transform, set using RenderMeshActor::setTM with boneIndex = 0 (the default).

The documentation for this class was generated from the following file:
  • RenderMeshActorDesc.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshActorDesc
nvidia::apex::RenderMeshActorDesc Member List
This is the complete list of members for nvidia::apex::RenderMeshActorDesc, including all inherited members.
ApexDesc() | nvidia::apex::ApexDesc | [inline]
bufferVisibility | nvidia::apex::RenderMeshActorDesc |
forceBoneIndexChannel | nvidia::apex::RenderMeshActorDesc |
forceFallbackSkinning | nvidia::apex::RenderMeshActorDesc |
indexBufferHint | nvidia::apex::RenderMeshActorDesc |
isValid() const | nvidia::apex::RenderMeshActorDesc | [inline]
keepPreviousFrameBoneBuffer | nvidia::apex::RenderMeshActorDesc |
keepVisibleBonesPacked | nvidia::apex::RenderMeshActorDesc |
maxInstanceCount | nvidia::apex::RenderMeshActorDesc |
overrideMaterialCount | nvidia::apex::RenderMeshActorDesc |
overrideMaterials | nvidia::apex::RenderMeshActorDesc |
RenderMeshActorDesc() | nvidia::apex::RenderMeshActorDesc | [inline]
renderWithoutSkinning | nvidia::apex::RenderMeshActorDesc |
setToDefault() | nvidia::apex::RenderMeshActorDesc | [inline]
userData | nvidia::apex::ApexDesc |
visible | nvidia::apex::RenderMeshActorDesc |
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderMeshAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAsset
Public Member Functions
nvidia::apex::RenderMeshAsset Class Reference

Rendering mesh (data) class. More...

#include <RenderMeshAsset.h>

Inheritance diagram for nvidia::apex::RenderMeshAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual RenderMeshActor * | createActor (const RenderMeshActorDesc &desc)=0
Instance this asset, return the created RenderMeshActor.
virtual void | releaseActor (RenderMeshActor &)=0
Releases an RenderMeshActor instanced by this asset.
virtual uint32_t | getSubmeshCount () const =0
Number of submeshes.
virtual uint32_t | getPartCount () const =0
Number of parts.
virtual const char * | getMaterialName (uint32_t submeshIndex) const =0
Returns an array of length submeshCount()
virtual const RenderSubmesh & | getSubmesh (uint32_t submeshIndex) const =0
Returns an submesh.
virtual const PxBounds3 & | getBounds (uint32_t partIndex=0) const =0
Returns the axis-aligned bounding box of the vertices for the given part.
virtual void | getStats (RenderMeshAssetStats &stats) const =0
Returns stats (sizes, counts) for the asset.
virtual UserOpaqueMesh * | getOpaqueMesh (void) const =0
Returns opaque mesh resource (NULL when opaque mesh isn't specified)

Detailed Description

Rendering mesh (data) class.

To render a mesh asset, you must create an instance

Member Function Documentation

virtual RenderMeshActor* nvidia::apex::RenderMeshAsset::createActor ( const RenderMeshActorDesc & desc ) [pure virtual]

Instance this asset, return the created RenderMeshActor.

See RenderMeshActor

virtual const PxBounds3& nvidia::apex::RenderMeshAsset::getBounds ( uint32_t partIndex = 0 ) const [pure virtual]

Returns the axis-aligned bounding box of the vertices for the given part.

Valid range of partIndex is {0..partCount()-1}

virtual uint32_t nvidia::apex::RenderMeshAsset::getPartCount ( ) const [pure virtual]

Number of parts.

These act as separate meshes, but they share submesh data (like materials).

virtual void nvidia::apex::RenderMeshAsset::getStats ( RenderMeshAssetStats & stats ) const [pure virtual]

Returns stats (sizes, counts) for the asset.

See RenderMeshAssetStats.

virtual const RenderSubmesh& nvidia::apex::RenderMeshAsset::getSubmesh ( uint32_t submeshIndex ) const [pure virtual]

Returns an submesh.

A submesh contains all the triangles in all parts with the same material (indexed by submeshIndex)

virtual uint32_t nvidia::apex::RenderMeshAsset::getSubmeshCount ( ) const [pure virtual]

Number of submeshes.

Each part effectively has the same number of submeshes, even if some are empty.

The documentation for this class was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAsset
nvidia::apex::RenderMeshAsset Member List
This is the complete list of members for nvidia::apex::RenderMeshAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createActor(const RenderMeshActorDesc &desc)=0 | nvidia::apex::RenderMeshAsset | [pure virtual]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getBounds(uint32_t partIndex=0) const =0 | nvidia::apex::RenderMeshAsset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getMaterialName(uint32_t submeshIndex) const =0 | nvidia::apex::RenderMeshAsset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
getOpaqueMesh(void) const =0 | nvidia::apex::RenderMeshAsset | [pure virtual]
getPartCount() const =0 | nvidia::apex::RenderMeshAsset | [pure virtual]
getStats(RenderMeshAssetStats &stats) const =0 | nvidia::apex::RenderMeshAsset | [pure virtual]
getSubmesh(uint32_t submeshIndex) const =0 | nvidia::apex::RenderMeshAsset | [pure virtual]
getSubmeshCount() const =0 | nvidia::apex::RenderMeshAsset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseActor(RenderMeshActor &)=0 | nvidia::apex::RenderMeshAsset | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~RenderMeshAsset() (defined in nvidia::apex::RenderMeshAsset) | nvidia::apex::RenderMeshAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderMeshAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetAuthoring
Classes | Public Member Functions
nvidia::apex::RenderMeshAssetAuthoring Class Reference

Authoring interface for an RenderMeshAsset. More...

#include <RenderMeshAsset.h>

Inheritance diagram for nvidia::apex::RenderMeshAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Classes

struct | IndexType
class | MeshDesc
struct | Primitive
How the geometry is stored. Currently only supporting triangles. More...
class | SubmeshDesc
class | VertexBuffer
Vertex buffer class used for mesh creation. More...

Public Member Functions

virtual void | createRenderMesh (const MeshDesc &meshDesc, bool createMappingInformation)=0
Mesh-building function.
virtual uint32_t | createReductionMap (uint32_t *map, const Vertex *vertices, const uint32_t *smoothingGroups, uint32_t vertexCount, const PxVec3 &positionTolerance, float normalTolerance, float UVTolerance)=0
virtual void | deleteStaticBuffersAfterUse (bool set)=0
virtual uint32_t | getSubmeshCount () const =0
Return the number of submeshes.
virtual uint32_t | getPartCount () const =0
Return the number of mesh parts.
virtual const char * | getMaterialName (uint32_t submeshIndex) const =0
Return the name of a submesh.
virtual void | setMaterialName (uint32_t submeshIndex, const char *name)=0
Set the name of a submesh.
virtual void | setWindingOrder (uint32_t submeshIndex, RenderCullMode::Enum winding)=0
Set the winding order of a submesh.
virtual RenderCullMode::Enum | getWindingOrder (uint32_t submeshIndex) const =0
Return the winding order of a submesh.
virtual const RenderSubmesh & | getSubmesh (uint32_t submeshIndex) const =0
Return a submesh.
virtual RenderSubmesh & | getSubmeshWritable (uint32_t submeshIndex)=0
Return a mutable submesh.
virtual const PxBounds3 & | getBounds (uint32_t partIndex=0) const =0
Return the bounds of a mesh part.
virtual void | getStats (RenderMeshAssetStats &stats) const =0
Get the asset statistics.

Detailed Description

Authoring interface for an RenderMeshAsset.

Member Function Documentation

virtual uint32_t nvidia::apex::RenderMeshAssetAuthoring::createReductionMap | ( | uint32_t * | map,
 |  | const Vertex * | vertices,
 |  | const uint32_t * | smoothingGroups,
 |  | uint32_t | vertexCount,
 |  | const PxVec3 & | positionTolerance,
 |  | float | normalTolerance,
 |  | float | UVTolerance
 | ) |  | [pure virtual]

Utility to reduce a vertex buffer of explicit vertices (Vertex). The parameters 'map' and 'vertices' must point to arrays of size vertexCount. The parameter 'smoothingGroups' must point to an array of size vertexCount, or be NULL. If not NULL, only vertices with equal smoothing groups will be merged. Upon return, the map array will be filled in with remapped vertex positions for a new vertex buffer. The return value is the number of vertices in the reduced buffer. Note: this function does NOT actually create the new vertex buffer.

virtual void nvidia::apex::RenderMeshAssetAuthoring::createRenderMesh | ( | const MeshDesc & | meshDesc,
 |  | bool | createMappingInformation
 | ) |  | [pure virtual]

Mesh-building function.

Parameters:
[in] | meshDesc | contains the setup for all vertex buffers
[in] | createMappingInformation | A vertex buffer with remapping indices will be generated. The name of the buffer is VERTEX_ORIGINAL_INDEX
virtual void nvidia::apex::RenderMeshAssetAuthoring::deleteStaticBuffersAfterUse ( bool set ) [pure virtual]

If set, static data buffers will be deleted after they are used in createRenderResources.

virtual uint32_t nvidia::apex::RenderMeshAssetAuthoring::getSubmeshCount ( ) const [pure virtual]

Return the number of submeshes.

Old mesh-building interface follows (DEPRECATED, to be removed by beta release):

The documentation for this class was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetAuthoring
nvidia::apex::RenderMeshAssetAuthoring Member List
This is the complete list of members for nvidia::apex::RenderMeshAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createReductionMap(uint32_t *map, const Vertex *vertices, const uint32_t *smoothingGroups, uint32_t vertexCount, const PxVec3 &positionTolerance, float normalTolerance, float UVTolerance)=0 | nvidia::apex::RenderMeshAssetAuthoring | [pure virtual]
createRenderMesh(const MeshDesc &meshDesc, bool createMappingInformation)=0 | nvidia::apex::RenderMeshAssetAuthoring | [pure virtual]
deleteStaticBuffersAfterUse(bool set)=0 | nvidia::apex::RenderMeshAssetAuthoring | [pure virtual]
getBounds(uint32_t partIndex=0) const =0 | nvidia::apex::RenderMeshAssetAuthoring | [pure virtual]
getMaterialName(uint32_t submeshIndex) const =0 | nvidia::apex::RenderMeshAssetAuthoring | [pure virtual]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getPartCount() const =0 | nvidia::apex::RenderMeshAssetAuthoring | [pure virtual]
getStats(RenderMeshAssetStats &stats) const =0 | nvidia::apex::RenderMeshAssetAuthoring | [pure virtual]
getSubmesh(uint32_t submeshIndex) const =0 | nvidia::apex::RenderMeshAssetAuthoring | [pure virtual]
getSubmeshCount() const =0 | nvidia::apex::RenderMeshAssetAuthoring | [pure virtual]
getSubmeshWritable(uint32_t submeshIndex)=0 | nvidia::apex::RenderMeshAssetAuthoring | [pure virtual]
getWindingOrder(uint32_t submeshIndex) const =0 | nvidia::apex::RenderMeshAssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setMaterialName(uint32_t submeshIndex, const char *name)=0 | nvidia::apex::RenderMeshAssetAuthoring | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
setWindingOrder(uint32_t submeshIndex, RenderCullMode::Enum winding)=0 | nvidia::apex::RenderMeshAssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderMeshAssetAuthoring::MeshDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetAuthoring
  • MeshDesc
Public Member Functions | Public Attributes
nvidia::apex::RenderMeshAssetAuthoring::MeshDesc Class Reference

#include <RenderMeshAsset.h>

List of all members.

Public Member Functions

MeshDesc ()
bool | isValid () const

Public Attributes

const SubmeshDesc * | m_submeshes
uint32_t | m_numSubmeshes
TextureUVOrigin::Enum m_uvOrigin

Detailed Description

Description of a mesh, used for authoring an Render mesh. It contains a number of vertex buffers and submeshes.

Constructor & Destructor Documentation

nvidia::apex::RenderMeshAssetAuthoring::MeshDesc::MeshDesc ( ) [inline]

Constructor sets default values.

Member Function Documentation

bool nvidia::apex::RenderMeshAssetAuthoring::MeshDesc::isValid ( void ) const [inline]

Validity check, returns true if this descriptor contains valid fields.

Member Data Documentation

uint32_t nvidia::apex::RenderMeshAssetAuthoring::MeshDesc::m_numSubmeshes

The number of elements in m_submeshes.

const SubmeshDesc* nvidia::apex::RenderMeshAssetAuthoring::MeshDesc::m_submeshes

Array of descriptors for the submeshes in this mesh.

TextureUVOrigin::Enum nvidia::apex::RenderMeshAssetAuthoring::MeshDesc::m_uvOrigin

Texture UV direction.

The documentation for this class was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetAuthoring
  • MeshDesc
nvidia::apex::RenderMeshAssetAuthoring::MeshDesc Member List
This is the complete list of members for nvidia::apex::RenderMeshAssetAuthoring::MeshDesc, including all inherited members.
isValid() const | nvidia::apex::RenderMeshAssetAuthoring::MeshDesc | [inline]
m_numSubmeshes | nvidia::apex::RenderMeshAssetAuthoring::MeshDesc |
m_submeshes | nvidia::apex::RenderMeshAssetAuthoring::MeshDesc |
m_uvOrigin | nvidia::apex::RenderMeshAssetAuthoring::MeshDesc |
MeshDesc() | nvidia::apex::RenderMeshAssetAuthoring::MeshDesc | [inline]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetAuthoring
  • SubmeshDesc
Public Member Functions | Public Attributes
nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc Class Reference

#include <RenderMeshAsset.h>

List of all members.

Public Member Functions

SubmeshDesc ()
bool | isValid () const

Public Attributes

const char * | m_materialName
const VertexBuffer * | m_vertexBuffers
uint32_t | m_numVertexBuffers
uint32_t | m_numVertices
Primitive::Enum m_primitive
IndexType::Enum m_indexType
const void * | m_vertexIndices
uint32_t | m_numIndices
uint32_t * | m_smoothingGroups
uint32_t | m_firstVertex
const void * | m_partIndices
uint32_t | m_numParts
RenderCullMode::Enum m_cullMode

Detailed Description

Description of one submesh, corresponding to one material. The vertex buffer format contains bone indices, so these do not need to be described here. The submesh's partitioning into parts is described here.

Constructor & Destructor Documentation

nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::SubmeshDesc ( ) [inline]

Constructor sets default values.

Member Function Documentation

bool nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::isValid ( void ) const [inline]

Validity check, returns true if this descriptor contains valid fields.

Member Data Documentation

RenderCullMode::Enum nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::m_cullMode

Winding order of the submesh

uint32_t nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::m_firstVertex

Vertex index offset.

IndexType::Enum nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::m_indexType

Type of the indices used in m_VertexIndices. See the IndexType enum.

const char* nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::m_materialName

Name of material associated with this geometry.

uint32_t nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::m_numIndices

Size (in indices) of m_VertexIndices.

uint32_t nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::m_numParts

If m_PartIndices is not NULL, the number of parts.

uint32_t nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::m_numVertexBuffers

Number of vertex buffers in m_VertexBuffers array.

uint32_t nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::m_numVertices

Number of vertices. Each vertex buffer in m_VertexBuffers must have this many vertices.

const void* nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::m_partIndices

If not NULL, an array (of m_IndexType-sized indices) into m_VertexIndices, at the start of each part.

Primitive::Enum nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::m_primitive

How the geometry is represented. See the Primitive enum.

uint32_t* nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::m_smoothingGroups

Smoothing groups associated with each triangle. The size of this array (if not NULL) must be appropriate for the m_primitive type. Since only triangle lists are currently supported, the size of this array (if not NULL) must currently be m_numIndices/3.

const VertexBuffer* nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::m_vertexBuffers

Vertex buffers for this submesh. One may pass in the same buffers for each submesh.

const void* nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc::m_vertexIndices

Buffer of vertex indices, stored as described by primitive and indexSize. If NULL, m_vertexIndices = {0,1,2,...} is implied.

The documentation for this class was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetAuthoring
  • SubmeshDesc
nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc Member List
This is the complete list of members for nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc, including all inherited members.
isValid() const | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc | [inline]
m_cullMode | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
m_firstVertex | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
m_indexType | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
m_materialName | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
m_numIndices | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
m_numParts | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
m_numVertexBuffers | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
m_numVertices | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
m_partIndices | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
m_primitive | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
m_smoothingGroups | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
m_vertexBuffers | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
m_vertexIndices | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc |
SubmeshDesc() | nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc | [inline]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderMeshAssetAuthoring::VertexBuffer Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetAuthoring
  • VertexBuffer
nvidia::apex::RenderMeshAssetAuthoring::VertexBuffer Class Reference

Vertex buffer class used for mesh creation. More...

#include <RenderMeshAsset.h>

Inheritance diagram for nvidia::apex::RenderMeshAssetAuthoring::VertexBuffer:
nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum >

List of all members.

Detailed Description

Vertex buffer class used for mesh creation.

The documentation for this class was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetAuthoring
  • VertexBuffer
nvidia::apex::RenderMeshAssetAuthoring::VertexBuffer Member List
This is the complete list of members for nvidia::apex::RenderMeshAssetAuthoring::VertexBuffer, including all inherited members.
getCustomSemanticData(uint32_t index) const | nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum > | [inline]
getNumCustomSemantics() const | nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum > | [inline]
getSemanticData(RenderVertexSemantic::Enumsemantic) const | nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum > | [inline]
RenderBufferData(void) (defined in nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum >) | nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum > | [inline]
setCustomSemanticData(RenderSemanticData *data, uint32_t num) | nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum > | [inline]
setSemanticData(RenderVertexSemantic::Enumsemantic, const void *data, uint32_t stride, RenderDataFormat::Enum format, RenderDataFormat::Enum srcFormat=RenderDataFormat::UNSPECIFIED) | nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum > | [inline]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderSemanticData Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderSemanticData
Public Attributes
nvidia::apex::RenderSemanticData Class Reference

Describes the data location and layout of a single semantic. More...

#include <RenderBufferData.h>

List of all members.

Public Attributes

const void * | data
Pointer to first semantic data element.
uint32_t | stride
Semantic stride, in bytes.
void * | ident
Used for custom semantics only: value retrieved from NRP.
RenderDataFormat::Enum format
Format used for this semantic.
RenderDataFormat::Enum srcFormat
When this class is used for mesh authoring, this is the format of the source (user's) buffer. If different from 'format', and not RenderDataFormat::UNSPECIFIED, the data will be converted to from srcFormat to format (if a converter exists). If srcFormat = RenderDataFormat::UNSPECIFIED (default value), it is assumed that srcFormat = format.
bool | serialize
Copy this buffer from the authoring asset to the asset.

Detailed Description

Describes the data location and layout of a single semantic.

Member Data Documentation

bool nvidia::apex::RenderSemanticData::serialize

Copy this buffer from the authoring asset to the asset.

This will only be used at render mesh asset creation time.

The documentation for this class was generated from the following file:
  • RenderBufferData.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderSemanticData
nvidia::apex::RenderSemanticData Member List
This is the complete list of members for nvidia::apex::RenderSemanticData, including all inherited members.
data | nvidia::apex::RenderSemanticData |
format | nvidia::apex::RenderSemanticData |
ident | nvidia::apex::RenderSemanticData |
RenderSemanticData(void) (defined in nvidia::apex::RenderSemanticData) | nvidia::apex::RenderSemanticData | [inline]
serialize | nvidia::apex::RenderSemanticData |
srcFormat | nvidia::apex::RenderSemanticData |
stride | nvidia::apex::RenderSemanticData |
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderSpriteBufferData Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderSpriteBufferData
nvidia::apex::RenderSpriteBufferData Class Reference

Sprite buffer data (deprecated) More...

#include <UserRenderSpriteBuffer.h>

Inheritance diagram for nvidia::apex::RenderSpriteBufferData:
nvidia::apex::RenderBufferData< RenderSpriteSemantic, RenderSpriteSemantic::Enum > nvidia::apex::ModuleSpecificRenderBufferData

List of all members.

Detailed Description

Sprite buffer data (deprecated)

The documentation for this class was generated from the following file:
  • UserRenderSpriteBuffer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderSpriteBufferData
nvidia::apex::RenderSpriteBufferData Member List
This is the complete list of members for nvidia::apex::RenderSpriteBufferData, including all inherited members.
getCustomSemanticData(uint32_t index) const | nvidia::apex::RenderBufferData< RenderSpriteSemantic, RenderSpriteSemantic::Enum > | [inline]
getNumCustomSemantics() const | nvidia::apex::RenderBufferData< RenderSpriteSemantic, RenderSpriteSemantic::Enum > | [inline]
getSemanticData(RenderSpriteSemantic::Enumsemantic) const | nvidia::apex::RenderBufferData< RenderSpriteSemantic, RenderSpriteSemantic::Enum > | [inline]
moduleId | nvidia::apex::ModuleSpecificRenderBufferData |
ModuleSpecificRenderBufferData(void) (defined in nvidia::apex::ModuleSpecificRenderBufferData) | nvidia::apex::ModuleSpecificRenderBufferData | [inline]
moduleSpecificSemanticData | nvidia::apex::ModuleSpecificRenderBufferData |
numModuleSpecificSemantics | nvidia::apex::ModuleSpecificRenderBufferData |
RenderBufferData(void) (defined in nvidia::apex::RenderBufferData< RenderSpriteSemantic, RenderSpriteSemantic::Enum >) | nvidia::apex::RenderBufferData< RenderSpriteSemantic, RenderSpriteSemantic::Enum > | [inline]
setCustomSemanticData(RenderSemanticData *data, uint32_t num) | nvidia::apex::RenderBufferData< RenderSpriteSemantic, RenderSpriteSemantic::Enum > | [inline]
setSemanticData(RenderSpriteSemantic::Enumsemantic, const void *data, uint32_t stride, RenderDataFormat::Enum format, RenderDataFormat::Enum srcFormat=RenderDataFormat::UNSPECIFIED) | nvidia::apex::RenderBufferData< RenderSpriteSemantic, RenderSpriteSemantic::Enum > | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderSubmesh Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderSubmesh
Public Member Functions
nvidia::apex::RenderSubmesh Class Reference

a mesh that has only one material (or render state, in general) More...

#include <RenderMesh.h>

List of all members.

Public Member Functions

virtual uint32_t | getVertexCount (uint32_t partIndex) const =0
virtual const VertexBuffer & | getVertexBuffer () const =0
virtual VertexBuffer & | getVertexBufferWritable ()=0
virtual uint32_t | getFirstVertexIndex (uint32_t partIndex) const =0
virtual uint32_t | getIndexCount (uint32_t partIndex) const =0
virtual const uint32_t * | getIndexBuffer (uint32_t partIndex) const =0
virtual const uint32_t * | getSmoothingGroups (uint32_t partIndex) const =0

Detailed Description

a mesh that has only one material (or render state, in general)

Member Function Documentation

virtual uint32_t nvidia::apex::RenderSubmesh::getFirstVertexIndex ( uint32_t partIndex ) const [pure virtual]

Vertices for a given part are contiguous within the vertex buffer. This function returns the first vertex index for the indexed part.

virtual const uint32_t* nvidia::apex::RenderSubmesh::getIndexBuffer ( uint32_t partIndex ) const [pure virtual]

Returns the index buffer associated with the indexed part.

virtual uint32_t nvidia::apex::RenderSubmesh::getIndexCount ( uint32_t partIndex ) const [pure virtual]

Returns the number of indices in the part's index buffer.

virtual const uint32_t* nvidia::apex::RenderSubmesh::getSmoothingGroups ( uint32_t partIndex ) const [pure virtual]

Returns an array of smoothing groups for the given part, if one exists. Otherwise, returns NULL. If not NULL, the size of the array is the number of triangles in the part. Since only triangle lists are currently supported, the size of this array is getIndexCount(partIndex)/3.

virtual const VertexBuffer& nvidia::apex::RenderSubmesh::getVertexBuffer ( ) const [pure virtual]

Returns the submesh's vertex buffer (contains all parts' vertices)

virtual VertexBuffer& nvidia::apex::RenderSubmesh::getVertexBufferWritable ( ) [pure virtual]

Returns the submesh's index buffer (contains all parts' vertices). Can be changed.

virtual uint32_t nvidia::apex::RenderSubmesh::getVertexCount ( uint32_t partIndex ) const [pure virtual]

Returns the number of vertices associated with the indexed part.

The documentation for this class was generated from the following file:
  • RenderMesh.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderSubmesh
nvidia::apex::RenderSubmesh Member List
This is the complete list of members for nvidia::apex::RenderSubmesh, including all inherited members.
getFirstVertexIndex(uint32_t partIndex) const =0 | nvidia::apex::RenderSubmesh | [pure virtual]
getIndexBuffer(uint32_t partIndex) const =0 | nvidia::apex::RenderSubmesh | [pure virtual]
getIndexCount(uint32_t partIndex) const =0 | nvidia::apex::RenderSubmesh | [pure virtual]
getSmoothingGroups(uint32_t partIndex) const =0 | nvidia::apex::RenderSubmesh | [pure virtual]
getVertexBuffer() const =0 | nvidia::apex::RenderSubmesh | [pure virtual]
getVertexBufferWritable()=0 | nvidia::apex::RenderSubmesh | [pure virtual]
getVertexCount(uint32_t partIndex) const =0 | nvidia::apex::RenderSubmesh | [pure virtual]
RenderSubmesh() (defined in nvidia::apex::RenderSubmesh) | nvidia::apex::RenderSubmesh | [inline, protected]
~RenderSubmesh() (defined in nvidia::apex::RenderSubmesh) | nvidia::apex::RenderSubmesh | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderSurfaceBufferData Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderSurfaceBufferData
nvidia::apex::RenderSurfaceBufferData Class Reference

surface buffer data More...

#include <UserRenderSurfaceBuffer.h>

Detailed Description

surface buffer data

The documentation for this class was generated from the following file:
  • UserRenderSurfaceBuffer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderVertexBufferData Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderVertexBufferData
nvidia::apex::RenderVertexBufferData Class Reference

vertex buffer data More...

#include <UserRenderVertexBuffer.h>

Inheritance diagram for nvidia::apex::RenderVertexBufferData:
nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum > nvidia::apex::ModuleSpecificRenderBufferData

List of all members.

Detailed Description

vertex buffer data

The documentation for this class was generated from the following file:
  • UserRenderVertexBuffer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderVertexBufferData
nvidia::apex::RenderVertexBufferData Member List
This is the complete list of members for nvidia::apex::RenderVertexBufferData, including all inherited members.
getCustomSemanticData(uint32_t index) const | nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum > | [inline]
getNumCustomSemantics() const | nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum > | [inline]
getSemanticData(RenderVertexSemantic::Enumsemantic) const | nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum > | [inline]
moduleId | nvidia::apex::ModuleSpecificRenderBufferData |
ModuleSpecificRenderBufferData(void) (defined in nvidia::apex::ModuleSpecificRenderBufferData) | nvidia::apex::ModuleSpecificRenderBufferData | [inline]
moduleSpecificSemanticData | nvidia::apex::ModuleSpecificRenderBufferData |
numModuleSpecificSemantics | nvidia::apex::ModuleSpecificRenderBufferData |
RenderBufferData(void) (defined in nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum >) | nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum > | [inline]
setCustomSemanticData(RenderSemanticData *data, uint32_t num) | nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum > | [inline]
setSemanticData(RenderVertexSemantic::Enumsemantic, const void *data, uint32_t stride, RenderDataFormat::Enum format, RenderDataFormat::Enum srcFormat=RenderDataFormat::UNSPECIFIED) | nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum > | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderVolume Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderVolume
Public Member Functions
nvidia::apex::RenderVolume Class Reference

An object which "owns" a volume of world space. More...

#include <RenderVolume.h>

Inheritance diagram for nvidia::apex::RenderVolume:
nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual physx::PxBounds3 | getBounds () const =0
Returns AABB covering all objects in this render volume, it's updated each frame during Scene::fetchResults().
virtual bool | getAffectsAllIofx () const =0
Returns true if the volume affects all IOFX assets.
virtual bool | addIofxAsset (IofxAsset &iofx)=0
Adds IOFX asset to volume's list of affected IOFX assets, returns false on failure.
virtual void | setPosition (const PxVec3 &pos)=0
Moves the render volume while maintaining its dimensions.
virtual void | setOwnershipBounds (const PxBounds3 &b)=0
Directly assigns a new AABB ownership volume.
virtual PxBounds3 | getOwnershipBounds () const =0
Retrieves the configured AABB bounds of the volume. Call getBounds() for the "live" bounds.
virtual IofxActor *const | lockIofxActorList (uint32_t &count)=0
Retrieve list of IOFX actors owned by this volume (one per IOFX Asset per IOS actor)
virtual void | unlockIofxActorList ()=0
Unlock IOFX actors which where locked by calling lockIofxActorList.
virtual IofxAsset *const | getIofxAssetList (uint32_t &count) const =0
Retrieve list of volume's affected IOFX assets.
virtual PxVec3 | getPosition () const =0
Returns center of ownership bounds.
virtual uint32_t | getPriority () const =0
Returns priority of volume.
virtual bool | affectsIofxAsset (const IofxAsset &iofx) const =0
Returns true if this volume affects the specified IOFX asset.

Detailed Description

An object which "owns" a volume of world space.

Any particles which enter the owned volume will be migrated to an IOFX actor owned by this object (if the particle's IOFX asset is affected by this volume).

When volumes overlap, their relative priorities break the tie. If multiple volumes have the same priority, the tie breaker goes to the volume that owns the particle.

Member Function Documentation

virtual bool nvidia::apex::RenderVolume::affectsIofxAsset ( const IofxAsset & iofx ) const [pure virtual]

Returns true if this volume affects the specified IOFX asset.

Callers must acquire render lock of the volume before calling this function, for thread safety.

virtual IofxAsset* const nvidia::apex::RenderVolume::getIofxAssetList ( uint32_t & count ) const [pure virtual]

Retrieve list of volume's affected IOFX assets.

Returns count of 0 if empty or volume affects all IOFX assets. Returned pointer is undefined when count is 0.

The returned buffer not thread-safe, and is only valid until the next APEX API call that steps the simulation or modifies the number of IOFX assets in a scene.

virtual IofxActor* const nvidia::apex::RenderVolume::lockIofxActorList ( uint32_t & count ) [pure virtual]

Retrieve list of IOFX actors owned by this volume (one per IOFX Asset per IOS actor)

Returns count of 0 if empty. Returned pointer is undefined when count is 0.

The bounds of each of these IOFX is guaranteed to be within the bounds of the volume itself. Calling the updateRenderResources and dispatchRenderResources() methods of the volume will implicitly call the same methods of each of these IOFX actors, so there is no need to iterate over them for rendering purposes, unless you require special logic per IOFX.

It is not necessary to release these actors, they will be released automatically when their volume, their IOFX Asset, or their host IOS actor are released.

This call is not thread-safe. The returned buffer is only valid until the next APEX API call that steps the simulation or modifies the number of IOFX actors in a scene.

virtual void nvidia::apex::RenderVolume::unlockIofxActorList ( ) [pure virtual]

Unlock IOFX actors which where locked by calling lockIofxActorList.

See also:
RenderVolume::lockIofxActorList
The documentation for this class was generated from the following file:
  • RenderVolume.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderVolume
nvidia::apex::RenderVolume Member List
This is the complete list of members for nvidia::apex::RenderVolume, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
addIofxAsset(IofxAsset &iofx)=0 | nvidia::apex::RenderVolume | [pure virtual]
affectsIofxAsset(const IofxAsset &iofx) const =0 | nvidia::apex::RenderVolume | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getAffectsAllIofx() const =0 | nvidia::apex::RenderVolume | [pure virtual]
getBounds() const =0 | nvidia::apex::RenderVolume | [pure virtual]
getIofxAssetList(uint32_t &count) const =0 | nvidia::apex::RenderVolume | [pure virtual]
getOwnershipBounds() const =0 | nvidia::apex::RenderVolume | [pure virtual]
getPosition() const =0 | nvidia::apex::RenderVolume | [pure virtual]
getPriority() const =0 | nvidia::apex::RenderVolume | [pure virtual]
lockIofxActorList(uint32_t &count)=0 | nvidia::apex::RenderVolume | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setOwnershipBounds(const PxBounds3 &b)=0 | nvidia::apex::RenderVolume | [pure virtual]
setPosition(const PxVec3 &pos)=0 | nvidia::apex::RenderVolume | [pure virtual]
unlockIofxActorList()=0 | nvidia::apex::RenderVolume | [pure virtual]
userData | nvidia::apex::ApexInterface |
~RenderVolume() (defined in nvidia::apex::RenderVolume) | nvidia::apex::RenderVolume | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::Renderable Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Renderable
Public Member Functions
nvidia::apex::Renderable Class Reference

Base class of any actor that can be rendered. More...

#include <Renderable.h>

Inheritance diagram for nvidia::apex::Renderable:
nvidia::apex::RenderDataProvider nvidia::apex::AssetPreview nvidia::apex::AttractorFSActor nvidia::apex::ClothingActor nvidia::apex::ClothingRenderProxy nvidia::apex::DestructibleActor nvidia::apex::DestructibleRenderable nvidia::apex::JetFSActor nvidia::apex::NoiseFSActor nvidia::apex::RenderDebugInterface nvidia::apex::RenderMeshActor nvidia::apex::Scene nvidia::apex::TurbulenceFSActor nvidia::apex::VortexFSActor nvidia::apex::WindFSActor

List of all members.

Public Member Functions

virtual void | dispatchRenderResources (UserRenderer &renderer)=0
virtual PxBounds3 | getBounds () const =0

Detailed Description

Base class of any actor that can be rendered.

Member Function Documentation

virtual void nvidia::apex::Renderable::dispatchRenderResources ( UserRenderer & renderer ) [pure virtual]

When called, this method will use the UserRenderer interface to render itself (if visible, etc) by calling renderer.renderResource( RenderContext& ) as many times as necessary. See locking semantics for RenderDataProvider::lockRenderResources().

virtual PxBounds3 nvidia::apex::Renderable::getBounds ( ) const [pure virtual]

Returns AABB covering rendered data. The actor's world bounds is updated each frame during Scene::fetchResults(). This function does not require the Renderable actor to be locked.

The documentation for this class was generated from the following file:
  • Renderable.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Renderable
nvidia::apex::Renderable Member List
This is the complete list of members for nvidia::apex::Renderable, including all inherited members.
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderableIterator Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderableIterator
Public Member Functions
nvidia::apex::RenderableIterator Class Reference

Iterate over all renderable Actors in an Context. More...

#include <Context.h>

Inheritance diagram for nvidia::apex::RenderableIterator:
nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual Renderable * | getFirst ()=0
Return the first renderable in an Context.
virtual Renderable * | getNext ()=0
Return the next unlocked renderable in an Context.
virtual void | reset ()=0
Refresh the renderable actor list for this context.

Detailed Description

Iterate over all renderable Actors in an Context.

An RenderableIterator is a lock-safe iterator over all renderable Actors in an Context. Actors which are locked are skipped in the initial pass and deferred till the end. The returned Renderable is locked by the iterator and remains locked until you call getNext().

The RenderableIterator is also deletion safe. If an actor is deleted from the Context in another thread, the iterator will skip that actor.

An RenderableIterator should not be held for longer than a single simulation step. It should be allocated on demand and released after use.

Member Function Documentation

virtual void nvidia::apex::RenderableIterator::reset ( ) [pure virtual]

Refresh the renderable actor list for this context.

This function is only necessary if you believe actors have been added or deleted since the iterator was created.

The documentation for this class was generated from the following file:
  • Context.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderableIterator
nvidia::apex::RenderableIterator Member List
This is the complete list of members for nvidia::apex::RenderableIterator, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getFirst()=0 | nvidia::apex::RenderableIterator | [pure virtual]
getNext()=0 | nvidia::apex::RenderableIterator | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
reset()=0 | nvidia::apex::RenderableIterator | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ResourceCallback Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ResourceCallback
Public Member Functions
nvidia::apex::ResourceCallback Class Reference

User defined callback for resource management. More...

#include <ResourceCallback.h>

List of all members.

Public Member Functions

virtual void * | requestResource (const char *nameSpace, const char *name)=0
Request a resource from the user.
virtual void | releaseResource (const char *nameSpace, const char *name, void *resource)=0
Request the user to release a resource.

Detailed Description

User defined callback for resource management.

The user may implement a subclass of this abstract class and provide an instance to the ApexSDK descriptor. These callbacks can only be triggered directly by ApexSDK API calls, so they do not need to be re-entrant or thread safe.

Member Function Documentation

virtual void nvidia::apex::ResourceCallback::releaseResource | ( | const char * | nameSpace,
 |  | const char * | name,
 |  | void * | resource
 | ) |  | [pure virtual]

Request the user to release a resource.

Will be called by the ApexSDK when all internal references to a named resource have been released. If this named resource is required again in the future, a new call to requestResource() will be made.

virtual void* nvidia::apex::ResourceCallback::requestResource | ( | const char * | nameSpace,
 |  | const char * | name
 | ) |  | [pure virtual]

Request a resource from the user.

Will be called by the ApexSDK if a named resource is required but has not yet been provided. The resource pointer is returned directly, ResourceProvider::setResource() should not be called. This function will be called at most once per named resource, unless an intermediate call to releaseResource() has been made.

Note:
If this call results in the application calling ApexSDK::createAsset, the name given to the asset must match the input name parameter in this method.
The documentation for this class was generated from the following file:
  • ResourceCallback.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ResourceCallback
nvidia::apex::ResourceCallback Member List
This is the complete list of members for nvidia::apex::ResourceCallback, including all inherited members.
releaseResource(const char *nameSpace, const char *name, void *resource)=0 | nvidia::apex::ResourceCallback | [pure virtual]
requestResource(const char *nameSpace, const char *name)=0 | nvidia::apex::ResourceCallback | [pure virtual]
~ResourceCallback() (defined in nvidia::apex::ResourceCallback) | nvidia::apex::ResourceCallback | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::ResourceProvider Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ResourceProvider
Public Member Functions
nvidia::apex::ResourceProvider Class Reference

A user provided class for mapping names to pointers or integers. More...

#include <ResourceProvider.h>

List of all members.

Public Member Functions

virtual void | registerCallback (ResourceCallback *impl)=0
Register a callback.
virtual void | setResource (const char *nameSpace, const char *name, void *resource, bool incRefCount=false)=0
Provide the pointer for the specified named resource.
virtual void | setResourceU32 (const char *nameSpace, const char *name, uint32_t id, bool incRefCount=false)=0
Provide the unsigned integer for the specified named resource.
virtual void * | getResource (const char *nameSpace, const char *name)=0
Retrieve the pointer to the specified named resource.
virtual uint32_t | releaseAllResourcesInNamespace (const char *nameSpace)=0
Releases all resources in this namespace.
virtual uint32_t | releaseResource (const char *nameSpace, const char *name)=0
Releases a single resource.
virtual bool | findRefCount (const char *nameSpace, const char *name, uint32_t &refCount)=0
Reports if a current resource exists and, if so, the reference count.
virtual void * | findResource (const char *nameSpace, const char *name)=0
Locates an existing resource.
virtual uint32_t | findResourceU32 (const char *nameSpace, const char *name)=0
Locates an existing integer resource.
virtual void ** | findAllResources (const char *nameSpace, uint32_t &count)=0
Returns a list of all resources in a particular namespace.
virtual const char ** | findAllResourceNames (const char *nameSpace, uint32_t &count)=0
Returns a list of the names of all resources within a particular namespace.
virtual const char ** | findNameSpaces (uint32_t &count)=0
Returns a list of all registered namespaces.
virtual void | dumpResourceTable ()=0
Write contents of resource table to error stream.
virtual bool | isCaseSensitive ()=0
Returns if the resource provider is operating in a case sensitive mode.

Detailed Description

A user provided class for mapping names to pointers or integers.

Named resource provider - a name-to-pointer utility. User must provide the pointed-to data.

  • also supports name-to-integer

Member Function Documentation

virtual void* nvidia::apex::ResourceProvider::findResource | ( | const char * | nameSpace,
 |  | const char * | name
 | ) |  | [pure virtual]

Locates an existing resource.

This function will *not* call back to the application if the resource does not exist. Only reports currently set resources.

virtual void* nvidia::apex::ResourceProvider::getResource | ( | const char * | nameSpace,
 |  | const char * | name
 | ) |  | [pure virtual]

Retrieve the pointer to the specified named resource.

The game application (level loader) may use this to find assets by name, as a convenience. If the named resource has not yet been loaded it will trigger a call to ResourceCallback::requestResource(), assuming an ResourceCallback instance was registered with the APEX SDK. If the named resource has already been loaded, getResource will not increment the reference count.

virtual bool nvidia::apex::ResourceProvider::isCaseSensitive ( ) [pure virtual]

Returns if the resource provider is operating in a case sensitive mode.

Note:
By default the resource provider is NOT case sensitive
It's not possible to change the case sensitivity of the NRP once the APEX SDK is created, so the the switch is available in the ApexSDKDesc::resourceProviderIsCaseSensitive member variable.
virtual void nvidia::apex::ResourceProvider::registerCallback ( ResourceCallback * impl ) [pure virtual]

Register a callback.

Register a callback function for unresolved named resources. This function will be called by APEX when an unresolved named resource is requested. The function will be called at most once for each named resource. The function must directly return the pointer to the resource or NULL.

virtual uint32_t nvidia::apex::ResourceProvider::releaseAllResourcesInNamespace ( const char * nameSpace ) [pure virtual]

Releases all resources in this namespace.

Returns:
the total number of resources released.
virtual uint32_t nvidia::apex::ResourceProvider::releaseResource | ( | const char * | nameSpace,
 |  | const char * | name
 | ) |  | [pure virtual]

Releases a single resource.

Returns:
the outstanding referernce count after the release is performed.
The documentation for this class was generated from the following file:
  • ResourceProvider.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ResourceProvider
nvidia::apex::ResourceProvider Member List
This is the complete list of members for nvidia::apex::ResourceProvider, including all inherited members.
dumpResourceTable()=0 | nvidia::apex::ResourceProvider | [pure virtual]
findAllResourceNames(const char *nameSpace, uint32_t &count)=0 | nvidia::apex::ResourceProvider | [pure virtual]
findAllResources(const char *nameSpace, uint32_t &count)=0 | nvidia::apex::ResourceProvider | [pure virtual]
findNameSpaces(uint32_t &count)=0 | nvidia::apex::ResourceProvider | [pure virtual]
findRefCount(const char *nameSpace, const char *name, uint32_t &refCount)=0 | nvidia::apex::ResourceProvider | [pure virtual]
findResource(const char *nameSpace, const char *name)=0 | nvidia::apex::ResourceProvider | [pure virtual]
findResourceU32(const char *nameSpace, const char *name)=0 | nvidia::apex::ResourceProvider | [pure virtual]
getResource(const char *nameSpace, const char *name)=0 | nvidia::apex::ResourceProvider | [pure virtual]
isCaseSensitive()=0 | nvidia::apex::ResourceProvider | [pure virtual]
registerCallback(ResourceCallback *impl)=0 | nvidia::apex::ResourceProvider | [pure virtual]
releaseAllResourcesInNamespace(const char *nameSpace)=0 | nvidia::apex::ResourceProvider | [pure virtual]
releaseResource(const char *nameSpace, const char *name)=0 | nvidia::apex::ResourceProvider | [pure virtual]
setResource(const char *nameSpace, const char *name, void *resource, bool incRefCount=false)=0 | nvidia::apex::ResourceProvider | [pure virtual]
setResourceU32(const char *nameSpace, const char *name, uint32_t id, bool incRefCount=false)=0 | nvidia::apex::ResourceProvider | [pure virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RotationModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RotationModifier
Public Member Functions | Static Public Attributes
nvidia::apex::RotationModifier Class Reference

RotationModifier applies rotation to the particles using one of several rotation models. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::RotationModifier:
nvidia::apex::ModifierT< RotationModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual
ApexMeshParticleRollType::Enum 		getRollType () const =0
get the roll model
virtual void | setRollType (ApexMeshParticleRollType::Enum rollType)=0
set the roll model
virtual float | getMaxSettleRate () const =0
get the maximum allowed settle rate per second
virtual void | setMaxSettleRate (float settleRate)=0
set the maximum allowed settle rate per second
virtual float | getMaxRotationRate () const =0
get the maximum allowed rotation rate per second
virtual void | setMaxRotationRate (float rotationRate)=0
set the maximum allowed rotation rate per second

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_Rotation
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

RotationModifier applies rotation to the particles using one of several rotation models.

Member Data Documentation

const uint32_t nvidia::apex::RotationModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn | ModifierUsage_Continuous
            | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RotationModifier
nvidia::apex::RotationModifier Member List
This is the complete list of members for nvidia::apex::RotationModifier, including all inherited members.
getMaxRotationRate() const =0 | nvidia::apex::RotationModifier | [pure virtual]
getMaxSettleRate() const =0 | nvidia::apex::RotationModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< RotationModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< RotationModifier > | [inline, virtual]
getRollType() const =0 | nvidia::apex::RotationModifier | [pure virtual]
ModifierType | nvidia::apex::RotationModifier | [static]
ModifierUsage | nvidia::apex::RotationModifier | [static]
setMaxRotationRate(float rotationRate)=0 | nvidia::apex::RotationModifier | [pure virtual]
setMaxSettleRate(float settleRate)=0 | nvidia::apex::RotationModifier | [pure virtual]
setRollType(ApexMeshParticleRollType::Enum rollType)=0 | nvidia::apex::RotationModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::RotationRateModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RotationRateModifier
Public Member Functions | Static Public Attributes
nvidia::apex::RotationRateModifier Class Reference

RotationRateModifier is a modifier to apply a continuous rotation for sprites. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::RotationRateModifier:
nvidia::apex::ModifierT< RotationRateModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual float | getRotationRate () const =0
set the rotation rate
virtual void | setRotationRate (const float &rate)=0
get the rotation rate

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_RotationRate
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

RotationRateModifier is a modifier to apply a continuous rotation for sprites.

Member Data Documentation

const uint32_t nvidia::apex::RotationRateModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RotationRateModifier
nvidia::apex::RotationRateModifier Member List
This is the complete list of members for nvidia::apex::RotationRateModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< RotationRateModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< RotationRateModifier > | [inline, virtual]
getRotationRate() const =0 | nvidia::apex::RotationRateModifier | [pure virtual]
ModifierType | nvidia::apex::RotationRateModifier | [static]
ModifierUsage | nvidia::apex::RotationRateModifier | [static]
setRotationRate(const float &rate)=0 | nvidia::apex::RotationRateModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::RotationRateVsLifeModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RotationRateVsLifeModifier
Public Member Functions | Static Public Attributes
nvidia::apex::RotationRateVsLifeModifier Class Reference

RotationRateVsLifeModifier is a modifier to adjust the rotation rate versus the life remaining of a particular particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::RotationRateVsLifeModifier:
nvidia::apex::ModifierT< RotationRateVsLifeModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual const Curve * | getFunction () const =0
get the curve that sets the dependency between the life remaining and the rotation rate
virtual void | setFunction (const Curve *f)=0
set the curve that sets the dependency between the life remaining and the rotation rate

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_RotationRateVsLife
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

RotationRateVsLifeModifier is a modifier to adjust the rotation rate versus the life remaining of a particular particle.

Member Data Documentation

const uint32_t nvidia::apex::RotationRateVsLifeModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RotationRateVsLifeModifier
nvidia::apex::RotationRateVsLifeModifier Member List
This is the complete list of members for nvidia::apex::RotationRateVsLifeModifier, including all inherited members.
getFunction() const =0 | nvidia::apex::RotationRateVsLifeModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< RotationRateVsLifeModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< RotationRateVsLifeModifier > | [inline, virtual]
ModifierType | nvidia::apex::RotationRateVsLifeModifier | [static]
ModifierUsage | nvidia::apex::RotationRateVsLifeModifier | [static]
setFunction(const Curve *f)=0 | nvidia::apex::RotationRateVsLifeModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ScaleAlongVelocityModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleAlongVelocityModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ScaleAlongVelocityModifier Class Reference

ScaleAlongVelocityModifier is a modifier to apply a scale factor along the current velocity vector. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ScaleAlongVelocityModifier:
nvidia::apex::ModifierT< ScaleAlongVelocityModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual float | getScaleFactor () const =0
get the scale factor
virtual void | setScaleFactor (const float &s)=0
set the scale factor

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ScaleAlongVelocity
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ScaleAlongVelocityModifier is a modifier to apply a scale factor along the current velocity vector.

Note that without applying an OrientAlongVelocity modifier first, the results for this will be 'odd.'

Member Data Documentation

const uint32_t nvidia::apex::ScaleAlongVelocityModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleAlongVelocityModifier
nvidia::apex::ScaleAlongVelocityModifier Member List
This is the complete list of members for nvidia::apex::ScaleAlongVelocityModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ScaleAlongVelocityModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ScaleAlongVelocityModifier > | [inline, virtual]
getScaleFactor() const =0 | nvidia::apex::ScaleAlongVelocityModifier | [pure virtual]
ModifierType | nvidia::apex::ScaleAlongVelocityModifier | [static]
ModifierUsage | nvidia::apex::ScaleAlongVelocityModifier | [static]
setScaleFactor(const float &s)=0 | nvidia::apex::ScaleAlongVelocityModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ScaleByMassModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleByMassModifier
Static Public Attributes
nvidia::apex::ScaleByMassModifier Class Reference

ScaleByMassModifier scales by mass of the particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ScaleByMassModifier:
nvidia::apex::ModifierT< ScaleByMassModifier > nvidia::apex::Modifier

List of all members.

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ScaleByMass
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ScaleByMassModifier scales by mass of the particle.

Member Data Documentation

const uint32_t nvidia::apex::ScaleByMassModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn | ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleByMassModifier
nvidia::apex::ScaleByMassModifier Member List
This is the complete list of members for nvidia::apex::ScaleByMassModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ScaleByMassModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ScaleByMassModifier > | [inline, virtual]
ModifierType | nvidia::apex::ScaleByMassModifier | [static]
ModifierUsage | nvidia::apex::ScaleByMassModifier | [static]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ScaleVsCameraDistanceModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleVsCameraDistanceModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ScaleVsCameraDistanceModifier Class Reference

ScaleVsCameraDistance applies a scale factor against a specific axis based on distance from the camera to the particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ScaleVsCameraDistanceModifier:
nvidia::apex::ModifierT< ScaleVsCameraDistanceModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ScaleAxis | getScaleAxis () const =0
get the axis along which the scale factor will be applied
virtual void | setScaleAxis (ScaleAxis a)=0
set the axis along which the scale factor will be applied
virtual const Curve * | getFunction () const =0
get the the curve that defines the dependency between the camera distance and the scale factor
virtual void | setFunction (const Curve *f)=0
set the the curve that defines the dependency between the camera distance and the scale factor

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ScaleVsCameraDistance
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ScaleVsCameraDistance applies a scale factor against a specific axis based on distance from the camera to the particle.

Member Data Documentation

const uint32_t nvidia::apex::ScaleVsCameraDistanceModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleVsCameraDistanceModifier
nvidia::apex::ScaleVsCameraDistanceModifier Member List
This is the complete list of members for nvidia::apex::ScaleVsCameraDistanceModifier, including all inherited members.
getFunction() const =0 | nvidia::apex::ScaleVsCameraDistanceModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ScaleVsCameraDistanceModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ScaleVsCameraDistanceModifier > | [inline, virtual]
getScaleAxis() const =0 | nvidia::apex::ScaleVsCameraDistanceModifier | [pure virtual]
ModifierType | nvidia::apex::ScaleVsCameraDistanceModifier | [static]
ModifierUsage | nvidia::apex::ScaleVsCameraDistanceModifier | [static]
setFunction(const Curve *f)=0 | nvidia::apex::ScaleVsCameraDistanceModifier | [pure virtual]
setScaleAxis(ScaleAxis a)=0 | nvidia::apex::ScaleVsCameraDistanceModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ScaleVsDensityModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleVsDensityModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ScaleVsDensityModifier Class Reference

ScaleVsDensityModifier applies a scale factor function against a single axis versus the density of the particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ScaleVsDensityModifier:
nvidia::apex::ModifierT< ScaleVsDensityModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ScaleAxis | getScaleAxis () const =0
get the axis along which the scale factor will be applied
virtual void | setScaleAxis (ScaleAxis a)=0
set the axis along which the scale factor will be applied
virtual const Curve * | getFunction () const =0
get the the curve that defines the dependency between the density and the scale factor
virtual void | setFunction (const Curve *f)=0
set the the curve that defines the dependency between the density and the scale factor

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ScaleVsDensity
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ScaleVsDensityModifier applies a scale factor function against a single axis versus the density of the particle.

Member Data Documentation

const uint32_t nvidia::apex::ScaleVsDensityModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleVsDensityModifier
nvidia::apex::ScaleVsDensityModifier Member List
This is the complete list of members for nvidia::apex::ScaleVsDensityModifier, including all inherited members.
getFunction() const =0 | nvidia::apex::ScaleVsDensityModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ScaleVsDensityModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ScaleVsDensityModifier > | [inline, virtual]
getScaleAxis() const =0 | nvidia::apex::ScaleVsDensityModifier | [pure virtual]
ModifierType | nvidia::apex::ScaleVsDensityModifier | [static]
ModifierUsage | nvidia::apex::ScaleVsDensityModifier | [static]
setFunction(const Curve *f)=0 | nvidia::apex::ScaleVsDensityModifier | [pure virtual]
setScaleAxis(ScaleAxis a)=0 | nvidia::apex::ScaleVsDensityModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::ScaleVsLifeModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleVsLifeModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ScaleVsLifeModifier Class Reference

ScaleVsLifeModifier applies a scale factor function against a single axis versus the life remaining. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ScaleVsLifeModifier:
nvidia::apex::ModifierT< ScaleVsLifeModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ScaleAxis | getScaleAxis () const =0
get the axis along which the scale factor will be applied
virtual void | setScaleAxis (ScaleAxis a)=0
set the axis along which the scale factor will be applied
virtual const Curve * | getFunction () const =0
get the the curve that defines the dependency between the life remaining and the scale factor
virtual void | setFunction (const Curve *f)=0
set the the curve that defines the dependency between the life remaining and the scale factor

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ScaleVsLife
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ScaleVsLifeModifier applies a scale factor function against a single axis versus the life remaining.

Member Data Documentation

const uint32_t nvidia::apex::ScaleVsLifeModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleVsLifeModifier
nvidia::apex::ScaleVsLifeModifier Member List
This is the complete list of members for nvidia::apex::ScaleVsLifeModifier, including all inherited members.
getFunction() const =0 | nvidia::apex::ScaleVsLifeModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ScaleVsLifeModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ScaleVsLifeModifier > | [inline, virtual]
getScaleAxis() const =0 | nvidia::apex::ScaleVsLifeModifier | [pure virtual]
ModifierType | nvidia::apex::ScaleVsLifeModifier | [static]
ModifierUsage | nvidia::apex::ScaleVsLifeModifier | [static]
setFunction(const Curve *f)=0 | nvidia::apex::ScaleVsLifeModifier | [pure virtual]
setScaleAxis(ScaleAxis a)=0 | nvidia::apex::ScaleVsLifeModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::Scene Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Scene
Public Member Functions
nvidia::apex::Scene Class Reference

An APEX wrapper for an PxScene. More...

#include <Scene.h>

Inheritance diagram for nvidia::apex::Scene:
nvidia::apex::Renderable nvidia::apex::Context nvidia::apex::ApexInterface nvidia::apex::RenderDataProvider nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual void | setPhysXScene (PxScene *s)=0
Associate an PxScene with this Scene.
virtual PxScene * | getPhysXScene () const =0
Retrieve the PxScene associated with this Scene.
virtual const SceneStats * | getStats (void) const =0
Retrieve scene statistics.
virtual void | simulate (float elapsedTime, bool finalStep=true, PxBaseTask *completionTask=NULL, void *scratchMemBlock=0, uint32_t scratchMemBlockSize=0)=0
Start simulation of the APEX (and PhysX) scene.
virtual bool | fetchResults (bool block, uint32_t *errorState)=0
Checks, and optionally blocks, for simulation completion. Updates scene state.
virtual const PxRenderBuffer * | getRenderBuffer () const =0
Returns an DebugRenderable object that contains the data for debug rendering of this scene.
virtual const PxRenderBuffer * | getRenderBufferScreenSpace () const =0
Returns an DebugRenderable object that contains the data for debug rendering of this scene, in screenspace.
virtual bool | checkResults (bool block) const =0
Checks, and optionally blocks, for simulation completion.
virtual uint32_t | allocViewMatrix (ViewMatrixType::Enum)=0
Allocate a view matrix. Returns a viewID that identifies this view matrix for future calls to setViewMatrix(). The matrix is de-allocated automatically when the scene is released.
virtual uint32_t | allocProjMatrix (ProjMatrixType::Enum)=0
Allocate a projection matrix. Returns a projID that identifies this projection matrix for future calls to setProjMatrix(). The matrix is de-allocated automatically when the scene is released.
virtual uint32_t | getNumViewMatrices () const =0
Returns the number of view matrices allocated.
virtual uint32_t | getNumProjMatrices () const =0
Returns the number of projection matrices allocated.
virtual void | setViewMatrix (const PxMat44 &viewTransform, const uint32_t viewID=0)=0
Sets the view matrix for the given viewID. Should be called whenever the view matrix needs to be updated.
virtual PxMat44 | getViewMatrix (const uint32_t viewID=0) const =0
Returns the view matrix set by the user for the given viewID.
virtual void | setProjMatrix (const PxMat44 &projTransform, const uint32_t projID=0)=0
Sets the projection matrix for the given projID. Should be called whenever the projection matrix needs to be updated.
virtual PxMat44 | getProjMatrix (const uint32_t projID=0) const =0
Returns the projection matrix set by the user for the given projID.
virtual void | setUseViewProjMatrix (const uint32_t viewID=0, const uint32_t projID=0)=0
Sets the use of the view matrix and projection matrix as identified by their IDs. Should be called whenever either matrices needs to be updated.
virtual void | setViewParams (const PxVec3 &eyePosition, const PxVec3 &eyeDirection, const PxVec3 &worldUpDirection=PxVec3(0, 1, 0), const uint32_t viewID=0)=0
Sets the necessary information for the view matrix as identified by its viewID. Should be called whenever any of the listed parameters needs to be updated.
virtual void | setProjParams (float nearPlaneDistance, float farPlaneDistance, float fieldOfViewDegree, uint32_t viewportWidth, uint32_t viewportHeight, const uint32_t projID=0)=0
Sets the necessary information for the projection matrix as identified by its projID. Should be called whenever any of the listed parameters needs to be updated.
virtual PxVec3 | getEyePosition (const uint32_t viewID=0) const =0
Returns the world space eye position.
virtual PxVec3 | getEyeDirection (const uint32_t viewID=0) const =0
Returns the world space eye direction.
virtual PxTaskManager * | getTaskManager () const =0
Returns the APEX scene's task manager.
virtual void | setUseDebugRenderable (bool state)=0
Toggle the use of a debug renderable.
virtual
::NvParameterized::Interface * 		getDebugRenderParams () const =0
Gets debug rendering parameters from NvParameterized.
virtual
::NvParameterized::Interface * 		getModuleDebugRenderParams (const char *name) const =0
Gets module debug rendering parameters from NvParameterized.
virtual PxVec3 | getGravity () const =0
Gets gravity value from PhysX or Apex scene for non PhysX configuration.
virtual void | setGravity (const PxVec3 &gravity)=0
Sets gravity for PhysX or Apex scene for non PhysX configuration.
virtual void | lockRead (const char *fileName, uint32_t lineo)=0
Acquire the PhysX scene lock for read access.
virtual void | lockWrite (const char *fileName, uint32_t lineno)=0
Acquire the PhysX scene lock for write access.
virtual void | unlockRead ()=0
Release the PhysX scene read lock.
virtual void | unlockWrite ()=0
Release the PhysX scene write lock.
virtual void | addActorPair (PxActor *actor0, PxActor *actor1)=0
Allows the application to specify a pair of PhysX actors for the purposes of collision filtering.
virtual void | removeActorPair (PxActor *actor0, PxActor *actor1)=0
Removes a previously specified pair of actors from the actor-pair filter table.
virtual bool | findActorPair (PxActor *actor0, PxActor *actor1) const =0
This method is used to determine if two actor pairs match.
virtual MirrorScene * | createMirrorScene (nvidia::apex::Scene &mirrorScene, MirrorScene::MirrorFilter &mirrorFilter, float mirrorStaticDistance, float mirrorDynamicDistance, float mirrorRefreshDistance)=0
Returns an MirrorScene helper class which keeps a primary APEX scene mirrored into a secondary scene.
virtual void | addBoundingBox (const PxBounds3 &bounds, UserBoundingBoxFlags::Enum flags)=0
Adds user-defined bounding box into the scene. Each module can use these bounding boxes in a module-specific way. See documentation on each module. Some modules might use it as a valid volume of simulation, deleting actors or parts of actors upon leaving a BB.
virtual const PxBounds3 | getBoundingBox (const uint32_t index) const =0
Returns user-defined bounding box added previously. In case there is no bounding box for the given index, zero sized PxBounds3 is returned.
virtual UserBoundingBoxFlags::Enum | getBoundingBoxFlags (const uint32_t index) const =0
Returns user-defined bounding box flags. In case there is no bounding box (and its flags) for the given index, UserBoundingBoxFlags::NONE is returned.
virtual uint32_t | getBoundingBoxCount () const =0
Returns user-defined bounding box count.
virtual void | removeBoundingBox (const uint32_t index)=0
Removes user-defined bounding box at index. In case index is invalid (there is no bounding box for this index) nothing is happenning.
virtual void | removeAllBoundingBoxes ()=0
Removed all of the user-specified bounding boxes.
virtual void * | getCudaTestManager () const =0
Returns CUDA test manager. For distribution builds return NULL.
virtual void * | getCudaProfileManager () const =0
Returns CUDA profile manager. For distribution builds return NULL.
virtual void | setCudaKernelCheckEnabled (bool enabled)=0
Enables/disables CUDA error check after each kernel launch.
virtual bool | getCudaKernelCheckEnabled () const =0
Returns whether CUDA error check enabled.

Detailed Description

An APEX wrapper for an PxScene.

Member Function Documentation

virtual void nvidia::apex::Scene::addActorPair | ( | PxActor * | actor0,
 |  | PxActor * | actor1
 | ) |  | [pure virtual]

Allows the application to specify a pair of PhysX actors for the purposes of collision filtering.

The set of methods addActorPair/removeActorPair and findActorPair can be used to implement collision filtering. This is a feature typically required to implement ragdoll systems to prevent nearby bodies from generating contacts which create jitter in the simulation; causing artifacts and preventing a ragdoll from coming to rest.

These methods are not required but are helper methods available if needed by the application.

Parameters:
actor0 | The first actor in the actor pair to consider
actor1 | The second actor in the actor pair to consider for filtering
virtual void nvidia::apex::Scene::addBoundingBox | ( | const PxBounds3 & | bounds,
 |  | UserBoundingBoxFlags::Enum | flags
 | ) |  | [pure virtual]

Adds user-defined bounding box into the scene. Each module can use these bounding boxes in a module-specific way. See documentation on each module. Some modules might use it as a valid volume of simulation, deleting actors or parts of actors upon leaving a BB.

Parameters:
bounds | [in] - The bounding box in world coordinates.
flags | [in] - The flag for supplied bounding box.
virtual uint32_t nvidia::apex::Scene::allocProjMatrix ( ProjMatrixType::Enum ) [pure virtual]

Allocate a projection matrix. Returns a projID that identifies this projection matrix for future calls to setProjMatrix(). The matrix is de-allocated automatically when the scene is released.

Each call of this function allocates space for one projection matrix. Since many features in APEX require a projection matrix it is _required_ that the application call this method. Max calls restricted to 1 for now. If ProjMatrixType is USER_CUSTOMIZED, setProjParams() as well using this projID

See also:
ProjMatrixType
setProjParams()
virtual uint32_t nvidia::apex::Scene::allocViewMatrix ( ViewMatrixType::Enum ) [pure virtual]

Allocate a view matrix. Returns a viewID that identifies this view matrix for future calls to setViewMatrix(). The matrix is de-allocated automatically when the scene is released.

Each call of this function allocates space for one view matrix. Since many features in APEX require a projection matrix it is _required_ that the application call this method. Max calls restricted to 1 for now. If ViewMatrixType is USER_CUSTOMIZED, setViewParams() as well using this viewID. If connected to PVD, PVD camera is set up.

See also:
ViewMatrixType
setViewParams()
virtual bool nvidia::apex::Scene::checkResults ( bool block ) const [pure virtual]

Checks, and optionally blocks, for simulation completion.

Performs same function as fetchResults(), but does not update scene state. fetchResults() must still be called before the next simulation step can begin.

virtual MirrorScene* nvidia::apex::Scene::createMirrorScene | ( | nvidia::apex::Scene & | mirrorScene,
 |  | MirrorScene::MirrorFilter & | mirrorFilter,
 |  | float | mirrorStaticDistance,
 |  | float | mirrorDynamicDistance,
 |  | float | mirrorRefreshDistance
 | ) |  | [pure virtual]

Returns an MirrorScene helper class which keeps a primary APEX scene mirrored into a secondary scene.

Parameters:
mirrorScene | [in] - The APEX scene that this scene will be mirrored into.
mirrorFilter | [in] - The application provided callback interface to filter which actors/shapes get mirrored.
mirrorStaticDistance | [in] - The distance to mirror static objects from the primary scene into the mirrored scene.
mirrorDynamicDistance | [in] - The distance to mirror dynamic objects from the primary scene into the mirrored scene.
mirrorRefreshDistance | [in] - The distance the camera should have moved before revising the trigger shapes controlling which actors get mirrored.
virtual bool nvidia::apex::Scene::fetchResults | ( | bool | block,
 |  | uint32_t * | errorState
 | ) |  | [pure virtual]

Checks, and optionally blocks, for simulation completion. Updates scene state.

Checks if Scene has completed simulating (optionally blocking for completion). Updates new state of Actors and the PxScene. Returns true if simulation is complete.

Parameters:
block | [in] - block until simulation is complete
errorState | [out] - error value is written to this address, if not NULL
virtual bool nvidia::apex::Scene::findActorPair | ( | PxActor * | actor0,
 |  | PxActor * | actor1
 | ) |  | const [pure virtual]

This method is used to determine if two actor pairs match.

If actor0 and actor1 were previously added to the actor-pair filter table, then this method will return true. Order is not important, actor0+actor1 will return the same result as actor1+actor0

Parameters:
actor0 | The first actor to consider
actor1 | The second actor to consider
Returns:
Returns true if the two actors match false if they have not been previously defined.
virtual const PxBounds3 nvidia::apex::Scene::getBoundingBox ( const uint32_t index ) const [pure virtual]

Returns user-defined bounding box added previously. In case there is no bounding box for the given index, zero sized PxBounds3 is returned.

Parameters:
index [in] - Index of the bounding box. User could acquire total number of bounding boxes using getBoundingBoxCount.
virtual UserBoundingBoxFlags::Enum nvidia::apex::Scene::getBoundingBoxFlags ( const uint32_t index ) const [pure virtual]

Returns user-defined bounding box flags. In case there is no bounding box (and its flags) for the given index, UserBoundingBoxFlags::NONE is returned.

Parameters:
index [in] - Index of the bounding box. User could acquire total number of bounding boxes using getBoundingBoxCount.
virtual PxVec3 nvidia::apex::Scene::getEyeDirection ( const uint32_t viewID = 0 ) const [pure virtual]

Returns the world space eye direction.

See also:
ViewMatrixType
setViewMatrix()
virtual PxVec3 nvidia::apex::Scene::getEyePosition ( const uint32_t viewID = 0 ) const [pure virtual]

Returns the world space eye position.

See also:
ViewMatrixType
setViewMatrix()
virtual PxMat44 nvidia::apex::Scene::getProjMatrix ( const uint32_t projID = 0 ) const [pure virtual]

Returns the projection matrix set by the user for the given projID.

See also:
setProjMatrix()
virtual PxMat44 nvidia::apex::Scene::getViewMatrix ( const uint32_t viewID = 0 ) const [pure virtual]

Returns the view matrix set by the user for the given viewID.

See also:
setViewMatrix()
virtual void nvidia::apex::Scene::lockRead | ( | const char * | fileName,
 |  | uint32_t | lineo
 | ) |  | [pure virtual]

Acquire the PhysX scene lock for read access.

The PhysX 3.2.2 SDK (and higher) provides a multiple-reader single writer mutex lock to coordinate access to the PhysX SDK API from multiple concurrent threads. This method will in turn invoke the lockRead call on the PhysX Scene. The source code fileName and line number a provided for debugging purposes.

virtual void nvidia::apex::Scene::lockWrite | ( | const char * | fileName,
 |  | uint32_t | lineno
 | ) |  | [pure virtual]

Acquire the PhysX scene lock for write access.

The PhysX 3.2.2 SDK (and higher) provides a multiple-reader single writer mutex lock to coordinate access to the PhysX SDK API from multiple concurrent threads. This method will in turn invoke the lockWrite call on the PhysX Scene. The source code fileName and line number a provided for debugging purposes.

virtual void nvidia::apex::Scene::removeActorPair | ( | PxActor * | actor0,
 |  | PxActor * | actor1
 | ) |  | [pure virtual]

Removes a previously specified pair of actors from the actor-pair filter table.

Parameters:
actor0 | The first actor in the actor pair to remove
actor1 | The second actor in the actor pair to remove
virtual void nvidia::apex::Scene::removeBoundingBox ( const uint32_t index ) [pure virtual]

Removes user-defined bounding box at index. In case index is invalid (there is no bounding box for this index) nothing is happenning.

Parameters:
index [in] - Index of the bounding box. User could acquire total number of bounding boxes using getBoundingBoxCount.
virtual void nvidia::apex::Scene::setCudaKernelCheckEnabled ( bool enabled ) [pure virtual]

Enables/disables CUDA error check after each kernel launch.

Use ONLY for DEBUG purposes, when enabled could dramatically slowdown performance!

virtual void nvidia::apex::Scene::setPhysXScene ( PxScene * s ) [pure virtual]

Associate an PxScene with this Scene.

All Actors in the Scene will be added to the PxScene. The PxScene pointer can be NULL, which will cause all APEX actors to be removed from the previously specified PxScene. This must be done before the PxScene can be released.

virtual void nvidia::apex::Scene::setProjMatrix | ( | const PxMat44 & | projTransform,
 |  | const uint32_t | projID = 0
 | ) |  | [pure virtual]

Sets the projection matrix for the given projID. Should be called whenever the projection matrix needs to be updated.

Make a call to setProjParams().

See also:
setProjParams()
virtual void nvidia::apex::Scene::setProjParams | ( | float | nearPlaneDistance,
 |  | float | farPlaneDistance,
 |  | float | fieldOfViewDegree,
 |  | uint32_t | viewportWidth,
 |  | uint32_t | viewportHeight,
 |  | const uint32_t | projID = 0
 | ) |  | [pure virtual]

Sets the necessary information for the projection matrix as identified by its projID. Should be called whenever any of the listed parameters needs to be updated.

See also:
ProjMatrixType
virtual void nvidia::apex::Scene::setViewMatrix | ( | const PxMat44 & | viewTransform,
 |  | const uint32_t | viewID = 0
 | ) |  | [pure virtual]

Sets the view matrix for the given viewID. Should be called whenever the view matrix needs to be updated.

If the given viewID's matrix type is identifiable as indicated in ViewMatrixType, eye position and eye direction are set as well, using values from this matrix. Otherwise, make a call to setViewParams(). If connected to PVD, PVD camera is updated.

virtual void nvidia::apex::Scene::setViewParams | ( | const PxVec3 & | eyePosition,
 |  | const PxVec3 & | eyeDirection,
 |  | const PxVec3 & | worldUpDirection = PxVec3(0, 1, 0),
 |  | const uint32_t | viewID = 0
 | ) |  | [pure virtual]

Sets the necessary information for the view matrix as identified by its viewID. Should be called whenever any of the listed parameters needs to be updated.

See also:
ViewMatrixType
virtual void nvidia::apex::Scene::simulate | ( | float | elapsedTime,
 |  | bool | finalStep = true,
 |  | PxBaseTask * | completionTask = NULL,
 |  | void * | scratchMemBlock = 0,
 |  | uint32_t | scratchMemBlockSize = 0
 | ) |  | [pure virtual]

Start simulation of the APEX (and PhysX) scene.

Start simulation of the Actors and the PxScene associated with this Scene. No Actors should be added, deleted, or modified until fetchResults() is called.

Calls to simulate() should pair with calls to fetchResults(): Each fetchResults() invocation corresponds to exactly one simulate() invocation; calling simulate() twice without an intervening fetchResults() or fetchResults() twice without an intervening simulate() causes an error condition.

Parameters:
[in] | elapsedTime | Amount of time to advance simulation by. Range: (0,inf)
[in] | finalStep | should be left as true, unless your application is manually sub stepping APEX (and PhysX) and you do not intend to try to render the output of intermediate steps.
[in] | completionTask | if non-NULL, this task will have its refcount incremented in simulate(), then decremented when the scene is ready to have fetchResults called. So the task will not run until the application also calls removeReference() after calling simulate.
[in] | scratchMemBlock | a memory region for physx to use for temporary data during simulation. This block may be reused by the application after fetchResults returns. Must be aligned on a 16-byte boundary
[in] | scratchMemBlockSize | the size of the scratch memory block. Must be a multiple of 16K.
The documentation for this class was generated from the following file:
  • Scene.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Scene
nvidia::apex::Scene Member List
This is the complete list of members for nvidia::apex::Scene, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
addActorPair(PxActor *actor0, PxActor *actor1)=0 | nvidia::apex::Scene | [pure virtual]
addBoundingBox(const PxBounds3 &bounds, UserBoundingBoxFlags::Enum flags)=0 | nvidia::apex::Scene | [pure virtual]
allocProjMatrix(ProjMatrixType::Enum)=0 | nvidia::apex::Scene | [pure virtual]
allocViewMatrix(ViewMatrixType::Enum)=0 | nvidia::apex::Scene | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
checkResults(bool block) const =0 | nvidia::apex::Scene | [pure virtual]
createMirrorScene(nvidia::apex::Scene &mirrorScene, MirrorScene::MirrorFilter &mirrorFilter, float mirrorStaticDistance, float mirrorDynamicDistance, float mirrorRefreshDistance)=0 | nvidia::apex::Scene | [pure virtual]
createRenderableIterator()=0 | nvidia::apex::Context | [pure virtual]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
fetchResults(bool block, uint32_t *errorState)=0 | nvidia::apex::Scene | [pure virtual]
findActorPair(PxActor *actor0, PxActor *actor1) const =0 | nvidia::apex::Scene | [pure virtual]
getBoundingBox(const uint32_t index) const =0 | nvidia::apex::Scene | [pure virtual]
getBoundingBoxCount() const =0 | nvidia::apex::Scene | [pure virtual]
getBoundingBoxFlags(const uint32_t index) const =0 | nvidia::apex::Scene | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getCudaKernelCheckEnabled() const =0 | nvidia::apex::Scene | [pure virtual]
getCudaProfileManager() const =0 | nvidia::apex::Scene | [pure virtual]
getCudaTestManager() const =0 | nvidia::apex::Scene | [pure virtual]
getDebugRenderParams() const =0 | nvidia::apex::Scene | [pure virtual]
getEyeDirection(const uint32_t viewID=0) const =0 | nvidia::apex::Scene | [pure virtual]
getEyePosition(const uint32_t viewID=0) const =0 | nvidia::apex::Scene | [pure virtual]
getGravity() const =0 | nvidia::apex::Scene | [pure virtual]
getModuleDebugRenderParams(const char *name) const =0 | nvidia::apex::Scene | [pure virtual]
getNumProjMatrices() const =0 | nvidia::apex::Scene | [pure virtual]
getNumViewMatrices() const =0 | nvidia::apex::Scene | [pure virtual]
getPhysXScene() const =0 | nvidia::apex::Scene | [pure virtual]
getProjMatrix(const uint32_t projID=0) const =0 | nvidia::apex::Scene | [pure virtual]
getRenderBuffer() const =0 | nvidia::apex::Scene | [pure virtual]
getRenderBufferScreenSpace() const =0 | nvidia::apex::Scene | [pure virtual]
getStats(void) const =0 | nvidia::apex::Scene | [pure virtual]
getTaskManager() const =0 | nvidia::apex::Scene | [pure virtual]
getViewMatrix(const uint32_t viewID=0) const =0 | nvidia::apex::Scene | [pure virtual]
lockRead(const char *fileName, uint32_t lineo)=0 | nvidia::apex::Scene | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
lockWrite(const char *fileName, uint32_t lineno)=0 | nvidia::apex::Scene | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseRenderableIterator(RenderableIterator &)=0 | nvidia::apex::Context | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
removeActorPair(PxActor *actor0, PxActor *actor1)=0 | nvidia::apex::Scene | [pure virtual]
removeAllActors()=0 | nvidia::apex::Context | [pure virtual]
removeAllBoundingBoxes()=0 | nvidia::apex::Scene | [pure virtual]
removeBoundingBox(const uint32_t index)=0 | nvidia::apex::Scene | [pure virtual]
setCudaKernelCheckEnabled(bool enabled)=0 | nvidia::apex::Scene | [pure virtual]
setGravity(const PxVec3 &gravity)=0 | nvidia::apex::Scene | [pure virtual]
setPhysXScene(PxScene *s)=0 | nvidia::apex::Scene | [pure virtual]
setProjMatrix(const PxMat44 &projTransform, const uint32_t projID=0)=0 | nvidia::apex::Scene | [pure virtual]
setProjParams(float nearPlaneDistance, float farPlaneDistance, float fieldOfViewDegree, uint32_t viewportWidth, uint32_t viewportHeight, const uint32_t projID=0)=0 | nvidia::apex::Scene | [pure virtual]
setUseDebugRenderable(bool state)=0 | nvidia::apex::Scene | [pure virtual]
setUseViewProjMatrix(const uint32_t viewID=0, const uint32_t projID=0)=0 | nvidia::apex::Scene | [pure virtual]
setViewMatrix(const PxMat44 &viewTransform, const uint32_t viewID=0)=0 | nvidia::apex::Scene | [pure virtual]
setViewParams(const PxVec3 &eyePosition, const PxVec3 &eyeDirection, const PxVec3 &worldUpDirection=PxVec3(0, 1, 0), const uint32_t viewID=0)=0 | nvidia::apex::Scene | [pure virtual]
simulate(float elapsedTime, bool finalStep=true, PxBaseTask *completionTask=NULL, void *scratchMemBlock=0, uint32_t scratchMemBlockSize=0)=0 | nvidia::apex::Scene | [pure virtual]
unlockRead()=0 | nvidia::apex::Scene | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
unlockWrite()=0 | nvidia::apex::Scene | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Context() (defined in nvidia::apex::Context) | nvidia::apex::Context | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::SceneDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SceneDesc
Public Member Functions | Public Attributes
nvidia::apex::SceneDesc Class Reference

Data used to initialize a new Scene. More...

#include <Scene.h>

Inheritance diagram for nvidia::apex::SceneDesc:
nvidia::apex::ApexDesc

List of all members.

Public Member Functions

PX_INLINE void | setToDefault ()
(re)sets the structure to the default.

Public Attributes

PxScene * | scene
Give this ApexScene an existing PxScene.
RenderDebugInterface * debugInterface
Give this ApexScene an existing RenderDebugInterface.
PhysX3Interface * physX3Interface
Give this ApexScene a user defined interface to the PhysX 3.*.
bool | useDebugRenderable
Toggle the use of a legacy DebugRenderable for PhysX 2.8.x or PxRenderBuffer for 3.x.
bool | debugVisualizeRemotely
Transmits debug rendering to PVD2 as well.
bool | debugVisualizeLocally
If 'debugVisualizeLocally' is true, then debug visualization which is being transmitted remotely will also be shown locally as well.
bool | useCuda
Switch for particles (BasicIOS, ParticleIOS, FieldSampler) which defines whether to use CUDA or not.

Detailed Description

Data used to initialize a new Scene.

Member Data Documentation

PxScene* nvidia::apex::SceneDesc::scene

Give this ApexScene an existing PxScene.

The ApexScene will use the same CpuDispatcher and GpuDispatcher that were provided to the PxScene when it was created. There is no need to provide these pointers in the ApexScene descriptor.

bool nvidia::apex::SceneDesc::useDebugRenderable

Toggle the use of a legacy DebugRenderable for PhysX 2.8.x or PxRenderBuffer for 3.x.

If true, then debug rendering will happen through the legacy DebugRenderable interface. If false (the default value) it will render through the UserRenderResources interface.

The documentation for this class was generated from the following file:
  • Scene.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SceneDesc
nvidia::apex::SceneDesc Member List
This is the complete list of members for nvidia::apex::SceneDesc, including all inherited members.
ApexDesc() | nvidia::apex::ApexDesc | [inline]
debugInterface | nvidia::apex::SceneDesc |
debugVisualizeLocally | nvidia::apex::SceneDesc |
debugVisualizeRemotely | nvidia::apex::SceneDesc |
isValid() const | nvidia::apex::ApexDesc | [inline]
physX3Interface | nvidia::apex::SceneDesc |
scene | nvidia::apex::SceneDesc |
SceneDesc() (defined in nvidia::apex::SceneDesc) | nvidia::apex::SceneDesc | [inline]
setToDefault() | nvidia::apex::SceneDesc | [inline]
useCuda | nvidia::apex::SceneDesc |
useDebugRenderable | nvidia::apex::SceneDesc |
userData | nvidia::apex::ApexDesc |
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::ScopedPhysXLockRead Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScopedPhysXLockRead
Public Member Functions
nvidia::apex::ScopedPhysXLockRead Class Reference

This helper class creates a scoped read access to the PhysX SDK API. More...

#include <ScopedPhysXLock.h>

List of all members.

Public Member Functions

ScopedPhysXLockRead (nvidia::Scene *scene, const char *fileName, int lineno)
Constructor for ScopedPhysXLockRead.
ScopedPhysXLockRead (physx::PxScene *scene, const char *fileName, int lineno)
Constructor for ScopedPhysXLockRead.

Detailed Description

This helper class creates a scoped read access to the PhysX SDK API.

This helper class is used to create a scoped read lock/unlock pair around a section of code which is trying to do read access against the PhysX SDK.

Constructor & Destructor Documentation

nvidia::apex::ScopedPhysXLockRead::ScopedPhysXLockRead | ( | nvidia::Scene * | scene,
 |  | const char * | fileName,
 |  | int | lineno
 | ) |  | [inline]

Constructor for ScopedPhysXLockRead.

Parameters:
[in] | scene | the APEX scene
[in] | fileName | used to determine what file called the lock for debugging purposes
[in] | lineno | used to determine what line number called the lock for debugging purposes
nvidia::apex::ScopedPhysXLockRead::ScopedPhysXLockRead | ( | physx::PxScene * | scene,
 |  | const char * | fileName,
 |  | int | lineno
 | ) |  | [inline]

Constructor for ScopedPhysXLockRead.

Parameters:
[in] | scene | the PhysX scene
[in] | fileName | used to determine what file called the lock for debugging purposes
[in] | lineno | used to determine what line number called the lock for debugging purposes
The documentation for this class was generated from the following file:
  • ScopedPhysXLock.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScopedPhysXLockRead
nvidia::apex::ScopedPhysXLockRead Member List
This is the complete list of members for nvidia::apex::ScopedPhysXLockRead, including all inherited members.
ScopedPhysXLockRead(nvidia::Scene *scene, const char *fileName, int lineno) | nvidia::apex::ScopedPhysXLockRead | [inline]
ScopedPhysXLockRead(physx::PxScene *scene, const char *fileName, int lineno) | nvidia::apex::ScopedPhysXLockRead | [inline]
~ScopedPhysXLockRead() (defined in nvidia::apex::ScopedPhysXLockRead) | nvidia::apex::ScopedPhysXLockRead | [inline]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::ScopedPhysXLockWrite Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScopedPhysXLockWrite
Public Member Functions
nvidia::apex::ScopedPhysXLockWrite Class Reference

This helper class creates a scoped write access to the PhysX SDK API. More...

#include <ScopedPhysXLock.h>

List of all members.

Public Member Functions

ScopedPhysXLockWrite (nvidia::Scene *scene, const char *fileName, int lineno)
Constructor for ScopedPhysXLockWrite.
ScopedPhysXLockWrite (physx::PxScene *scene, const char *fileName, int lineno)
Constructor for ScopedPhysXLockWrite.

Detailed Description

This helper class creates a scoped write access to the PhysX SDK API.

This helper class is used to create a scoped write lock/unlock pair around a section of code which is trying to do read access against the PhysX SDK.

Constructor & Destructor Documentation

nvidia::apex::ScopedPhysXLockWrite::ScopedPhysXLockWrite | ( | nvidia::Scene * | scene,
 |  | const char * | fileName,
 |  | int | lineno
 | ) |  | [inline]

Constructor for ScopedPhysXLockWrite.

Parameters:
[in] | scene | the APEX scene
[in] | fileName | used to determine what file called the lock for debugging purposes
[in] | lineno | used to determine what line number called the lock for debugging purposes
nvidia::apex::ScopedPhysXLockWrite::ScopedPhysXLockWrite | ( | physx::PxScene * | scene,
 |  | const char * | fileName,
 |  | int | lineno
 | ) |  | [inline]

Constructor for ScopedPhysXLockWrite.

Parameters:
[in] | scene | the PhysX scene
[in] | fileName | used to determine what file called the lock for debugging purposes
[in] | lineno | used to determine what line number called the lock for debugging purposes
The documentation for this class was generated from the following file:
  • ScopedPhysXLock.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScopedPhysXLockWrite
nvidia::apex::ScopedPhysXLockWrite Member List
This is the complete list of members for nvidia::apex::ScopedPhysXLockWrite, including all inherited members.
ScopedPhysXLockWrite(nvidia::Scene *scene, const char *fileName, int lineno) | nvidia::apex::ScopedPhysXLockWrite | [inline]
ScopedPhysXLockWrite(physx::PxScene *scene, const char *fileName, int lineno) | nvidia::apex::ScopedPhysXLockWrite | [inline]
~ScopedPhysXLockWrite() (defined in nvidia::apex::ScopedPhysXLockWrite) | nvidia::apex::ScopedPhysXLockWrite | [inline]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::Shape Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Shape
Public Member Functions
nvidia::apex::Shape Class Reference

Describes the format of an Shape. More...

#include <Shape.h>

Inheritance diagram for nvidia::apex::Shape:
nvidia::apex::BoxShape nvidia::apex::CapsuleShape nvidia::apex::HalfSpaceShape nvidia::apex::SphereShape

List of all members.

Public Member Functions

virtual bool | intersectAgainstAABB (PxBounds3)=0
intersect the collision shape against a given AABB
virtual PxBounds3 | getAABB () const =0
AABB of collision shape.
virtual const BoxShape * | isBoxGeom () const
If it is a box, cast to box class, return NULL otherwise.
virtual const SphereShape * | isSphereGeom () const
If it is a sphere, cast to sphere class, return NULL otherwise.
virtual const CapsuleShape * | isCapsuleGeom () const
If it is a capsule, cast to the capsule class, return NULL otherwise.
virtual const HalfSpaceShape * | isHalfSpaceGeom () const
If it is a half space, cast to half space class, return NULL otherwise.
virtual void | releaseApexShape ()=0
Release shape.
virtual void | visualize (RenderDebugInterface *renderer) const =0
Visualize shape.
virtual PxMat44 | getPose () const =0
get the pose of the shape
virtual void | setPose (PxMat44 pose)=0
set the pose of the shape - this pose will modify the scale, orientation and position of the shape
virtual PxMat44 | getPreviousPose () const =0
get the previous pose of the shape

Detailed Description

Describes the format of an Shape.

The documentation for this class was generated from the following file:
  • Shape.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Shape
nvidia::apex::Shape Member List
This is the complete list of members for nvidia::apex::Shape, including all inherited members.
getAABB() const =0 | nvidia::apex::Shape | [pure virtual]
getPose() const =0 | nvidia::apex::Shape | [pure virtual]
getPreviousPose() const =0 | nvidia::apex::Shape | [pure virtual]
intersectAgainstAABB(PxBounds3)=0 | nvidia::apex::Shape | [pure virtual]
isBoxGeom() const | nvidia::apex::Shape | [inline, virtual]
isCapsuleGeom() const | nvidia::apex::Shape | [inline, virtual]
isHalfSpaceGeom() const | nvidia::apex::Shape | [inline, virtual]
isSphereGeom() const | nvidia::apex::Shape | [inline, virtual]
releaseApexShape()=0 | nvidia::apex::Shape | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::Shape | [pure virtual]
visualize(RenderDebugInterface *renderer) const =0 | nvidia::apex::Shape | [pure virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::SimpleScaleModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SimpleScaleModifier
Public Member Functions | Static Public Attributes
nvidia::apex::SimpleScaleModifier Class Reference

SimpleScaleModifier just applies a simple scale factor to each of the X, Y and Z aspects of the model. Each scalefactor can be applied independently. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::SimpleScaleModifier:
nvidia::apex::ModifierT< SimpleScaleModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual PxVec3 | getScaleFactor () const =0
get the vector of scale factors along the three axes
virtual void | setScaleFactor (const PxVec3 &s)=0
set the vector of scale factors along the three axes

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_SimpleScale
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

SimpleScaleModifier just applies a simple scale factor to each of the X, Y and Z aspects of the model. Each scalefactor can be applied independently.

Member Data Documentation

const uint32_t nvidia::apex::SimpleScaleModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn | ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SimpleScaleModifier
nvidia::apex::SimpleScaleModifier Member List
This is the complete list of members for nvidia::apex::SimpleScaleModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< SimpleScaleModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< SimpleScaleModifier > | [inline, virtual]
getScaleFactor() const =0 | nvidia::apex::SimpleScaleModifier | [pure virtual]
ModifierType | nvidia::apex::SimpleScaleModifier | [static]
ModifierUsage | nvidia::apex::SimpleScaleModifier | [static]
setScaleFactor(const PxVec3 &s)=0 | nvidia::apex::SimpleScaleModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::SphereShape Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SphereShape
Public Member Functions
nvidia::apex::SphereShape Class Reference

helper Sphere shape More...

#include <Shape.h>

Inheritance diagram for nvidia::apex::SphereShape:
nvidia::apex::Shape

List of all members.

Public Member Functions

virtual float | getRadius () const =0
get radius of the sphere
virtual void | setRadius (float radius)=0
set radius of the sphere

Detailed Description

helper Sphere shape

The documentation for this class was generated from the following file:
  • Shape.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SphereShape
nvidia::apex::SphereShape Member List
This is the complete list of members for nvidia::apex::SphereShape, including all inherited members.
getAABB() const =0 | nvidia::apex::Shape | [pure virtual]
getPose() const =0 | nvidia::apex::Shape | [pure virtual]
getPreviousPose() const =0 | nvidia::apex::Shape | [pure virtual]
getRadius() const =0 | nvidia::apex::SphereShape | [pure virtual]
intersectAgainstAABB(PxBounds3)=0 | nvidia::apex::Shape | [pure virtual]
isBoxGeom() const | nvidia::apex::Shape | [inline, virtual]
isCapsuleGeom() const | nvidia::apex::Shape | [inline, virtual]
isHalfSpaceGeom() const | nvidia::apex::Shape | [inline, virtual]
isSphereGeom() const | nvidia::apex::Shape | [inline, virtual]
releaseApexShape()=0 | nvidia::apex::Shape | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::Shape | [pure virtual]
setRadius(float radius)=0 | nvidia::apex::SphereShape | [pure virtual]
visualize(RenderDebugInterface *renderer) const =0 | nvidia::apex::Shape | [pure virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::SubstanceSourceActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SubstanceSourceActor
Public Member Functions
nvidia::apex::SubstanceSourceActor Class Reference

Turbulence ScalarSource Actor class. More...

#include <SubstanceSourceActor.h>

Inheritance diagram for nvidia::apex::SubstanceSourceActor:
nvidia::apex::Actor nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual SubstanceSourceAsset * | getSubstanceSourceAsset () const =0
Returns the asset the instance has been created from.
virtual void | setEnabled (bool enable)=0
enable whether or not to use density in the simulation (enabling density reduces performance).
virtual bool | isEnabled () const =0
Returns true if substance source enabled.
virtual bool | intersectAgainstAABB (PxBounds3)=0
intersect the collision shape against a given AABB
virtual Shape * | getShape () const =0
Returns pointer to Shape of substance source.
virtual BoxShape * | getBoxShape ()=0
If it is a box, cast to box class, return NULL otherwise.
virtual SphereShape * | getSphereShape ()=0
If it is a sphere, cast to sphere class, return NULL otherwise.
virtual float | getAverageDensity () const =0
Return average value of density.
virtual float | getStdDensity () const =0
Return STD value of density.
virtual void | setDensity (float averageDensity, float stdDensity)=0
Set average and STD values for density.
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.
virtual void | release ()=0
Release an object instance.

Detailed Description

Turbulence ScalarSource Actor class.

Member Function Documentation

virtual void nvidia::apex::SubstanceSourceActor::release ( ) [pure virtual]

Release an object instance.

Calling this will unhook the class and delete it from memory. You should not keep any reference to this class instance after calling release

Implements nvidia::apex::ApexInterface.

virtual void nvidia::apex::SubstanceSourceActor::setEnabled ( bool enable ) [pure virtual]

enable whether or not to use density in the simulation (enabling density reduces performance).

If you are enabling density then you also need to add substance sources (without substance sources you will see no effect of density on the simulation, except a drop in performance)

The documentation for this class was generated from the following file:
  • SubstanceSourceActor.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SubstanceSourceActor
nvidia::apex::SubstanceSourceActor Member List
This is the complete list of members for nvidia::apex::SubstanceSourceActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getAverageDensity() const =0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
getBoxShape()=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getShape() const =0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
getSphereShape()=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
getStdDensity() const =0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
getSubstanceSourceAsset() const =0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
intersectAgainstAABB(PxBounds3)=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
isEnabled() const =0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
release()=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
setDensity(float averageDensity, float stdDensity)=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
setEnabled(bool enable)=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~SubstanceSourceActor() (defined in nvidia::apex::SubstanceSourceActor) | nvidia::apex::SubstanceSourceActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::SubstanceSourceAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SubstanceSourceAsset
nvidia::apex::SubstanceSourceAsset Class Reference

Turbulence FieldSampler Asset class. More...

#include <SubstanceSourceAsset.h>

Inheritance diagram for nvidia::apex::SubstanceSourceAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

Turbulence FieldSampler Asset class.

The documentation for this class was generated from the following file:
  • SubstanceSourceAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SubstanceSourceAsset
nvidia::apex::SubstanceSourceAsset Member List
This is the complete list of members for nvidia::apex::SubstanceSourceAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~SubstanceSourceAsset() (defined in nvidia::apex::SubstanceSourceAsset) | nvidia::apex::SubstanceSourceAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::SubstanceSourceAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SubstanceSourceAssetAuthoring
nvidia::apex::SubstanceSourceAssetAuthoring Class Reference

Turbulence FieldSampler Asset Authoring class. More...

#include <SubstanceSourceAsset.h>

Inheritance diagram for nvidia::apex::SubstanceSourceAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

Turbulence FieldSampler Asset Authoring class.

The documentation for this class was generated from the following file:
  • SubstanceSourceAsset.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SubstanceSourceAssetAuthoring
nvidia::apex::SubstanceSourceAssetAuthoring Member List
This is the complete list of members for nvidia::apex::SubstanceSourceAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
~SubstanceSourceAssetAuthoring() (defined in nvidia::apex::SubstanceSourceAssetAuthoring) | nvidia::apex::SubstanceSourceAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::SubtextureVsLifeModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SubtextureVsLifeModifier
Public Member Functions | Static Public Attributes
nvidia::apex::SubtextureVsLifeModifier Class Reference

SubtextureVsLifeModifier is a modifier to adjust the subtexture id versus the life remaining of a particular particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::SubtextureVsLifeModifier:
nvidia::apex::ModifierT< SubtextureVsLifeModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual const Curve * | getFunction () const =0
get the curve that sets the dependency between the life remaining and the subtexture id
virtual void | setFunction (const Curve *f)=0
set the curve that sets the dependency between the life remaining and the subtexture id

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_SubtextureVsLife
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

SubtextureVsLifeModifier is a modifier to adjust the subtexture id versus the life remaining of a particular particle.

Interpretation of the subtexture id over time is up to the application.

Member Data Documentation

const uint32_t nvidia::apex::SubtextureVsLifeModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SubtextureVsLifeModifier
nvidia::apex::SubtextureVsLifeModifier Member List
This is the complete list of members for nvidia::apex::SubtextureVsLifeModifier, including all inherited members.
getFunction() const =0 | nvidia::apex::SubtextureVsLifeModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< SubtextureVsLifeModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< SubtextureVsLifeModifier > | [inline, virtual]
ModifierType | nvidia::apex::SubtextureVsLifeModifier | [static]
ModifierUsage | nvidia::apex::SubtextureVsLifeModifier | [static]
setFunction(const Curve *f)=0 | nvidia::apex::SubtextureVsLifeModifier | [pure virtual]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::TestBase Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TestBase
Public Member Functions
nvidia::apex::TestBase Class Reference

#include <TestBase.h>

List of all members.

Public Member Functions

virtual const char * | getUnitTestsName (uint32_t unitTestsIndex) const =0
Returns the name of the test at this index.
virtual uint32_t | getUnitTestsIndex (const char *unitTestsName) const =0
Returns the index of the test for this name.
virtual bool | runUnitTests (uint32_t unitTestsID, void *dataPtr) const =0
run unit test
virtual bool | checkUnitTests (uint32_t unitTestsID, void *dataPtr) const =0
check unit test
virtual uint32_t | getUnitTestsCount () const =0
returns the number of unit tests
virtual void | setRuntimeCheckLevel (uint32_t level)=0
set level of runtime check

Detailed Description

Defines the UnitTestsActor API which is instantiated from an UnitTestsAsset

Member Function Documentation

virtual uint32_t nvidia::apex::TestBase::getUnitTestsIndex ( const char * unitTestsName ) const [pure virtual]

Returns the index of the test for this name.

Parameters:
[in] unitTestsName : The test name to refer to; if there is no such name method returns -1
virtual const char* nvidia::apex::TestBase::getUnitTestsName ( uint32_t unitTestsIndex ) const [pure virtual]

Returns the name of the test at this index.

Parameters:
[in] unitTestsIndex : The test number to refer to; must be less than the result of getUnitTestCount
virtual bool nvidia::apex::TestBase::runUnitTests | ( | uint32_t | unitTestsID,
 |  | void * | dataPtr
 | ) |  | const [pure virtual]

run unit test

Parameters:
[in] | unitTestsID | : The unit test number to refer to; must be less than the result of getUnitTestsCount
[in] | dataPtr | : The pointer to data which is needed for unit test.
virtual void nvidia::apex::TestBase::setRuntimeCheckLevel ( uint32_t level ) [pure virtual]

set level of runtime check

Parameters:
[in] level - level of runtime check

level = 0 - no runtime checks level = 1 - easy-weight checks. Perfomance should not drop more than 10-20% level = 2 - medium-weight checks. Perfomance drop less than 300-500% level = 3 - hard-weight checks. Perfomance drop isn't limited

The documentation for this class was generated from the following file:
  • TestBase.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TestBase
nvidia::apex::TestBase Member List
This is the complete list of members for nvidia::apex::TestBase, including all inherited members.
checkUnitTests(uint32_t unitTestsID, void *dataPtr) const =0 | nvidia::apex::TestBase | [pure virtual]
getUnitTestsCount() const =0 | nvidia::apex::TestBase | [pure virtual]
getUnitTestsIndex(const char *unitTestsName) const =0 | nvidia::apex::TestBase | [pure virtual]
getUnitTestsName(uint32_t unitTestsIndex) const =0 | nvidia::apex::TestBase | [pure virtual]
runUnitTests(uint32_t unitTestsID, void *dataPtr) const =0 | nvidia::apex::TestBase | [pure virtual]
setRuntimeCheckLevel(uint32_t level)=0 | nvidia::apex::TestBase | [pure virtual]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::TestFunctionInterface Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TestFunctionInterface
Public Member Functions | Public Attributes
nvidia::apex::TestFunctionInterface Class Reference

#include <TestBase.h>

List of all members.

Public Member Functions

TestFunctionInterface (const char *name)
virtual bool | run (void *, void *)=0
virtual bool | check (void *, void *)=0
virtual bool | runGpu (void *, void *, void *)=0

Public Attributes

const char * | mName

Detailed Description

Interface for user's unit tests

Constructor & Destructor Documentation

nvidia::apex::TestFunctionInterface::TestFunctionInterface ( const char * name ) [inline]

Constructor for TestFunctionInterface

Member Function Documentation

virtual bool nvidia::apex::TestFunctionInterface::check | ( | void * | ,
 |  | void * |
 | ) |  | [pure virtual]

Check state, true if user's test object in correct state

virtual bool nvidia::apex::TestFunctionInterface::run | ( | void * | ,
 |  | void * |
 | ) |  | [pure virtual]

Run CPU tests, returns true if all tests passed

virtual bool nvidia::apex::TestFunctionInterface::runGpu | ( | void * | ,
 |  | void * | ,
 |  | void * |
 | ) |  | [pure virtual]

Run GPU tests, returns true if all tests passed

Member Data Documentation

const char* nvidia::apex::TestFunctionInterface::mName

User's test name

The documentation for this class was generated from the following file:
  • TestBase.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TestFunctionInterface
nvidia::apex::TestFunctionInterface Member List
This is the complete list of members for nvidia::apex::TestFunctionInterface, including all inherited members.
check(void *, void *)=0 | nvidia::apex::TestFunctionInterface | [pure virtual]
mName | nvidia::apex::TestFunctionInterface |
run(void *, void *)=0 | nvidia::apex::TestFunctionInterface | [pure virtual]
runGpu(void *, void *, void *)=0 | nvidia::apex::TestFunctionInterface | [pure virtual]
TestFunctionInterface(const char *name) | nvidia::apex::TestFunctionInterface | [inline]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::TurbulenceFSActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSActor
Public Member Functions
nvidia::apex::TurbulenceFSActor Class Reference

Turbulence FieldSampler Actor class. More...

#include <TurbulenceFSActor.h>

Inheritance diagram for nvidia::apex::TurbulenceFSActor:
nvidia::apex::Actor nvidia::apex::Renderable nvidia::apex::ApexInterface nvidia::apex::RenderDataProvider nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual TurbulenceFSAsset * | getTurbulenceFSAsset () const =0
Returns the asset the instance has been created from.
virtual void | setEnabled (bool enable)=0
enable/disable the fluid simulation
virtual void | setPose (PxMat44 pose)=0
set the pose of the grid - this includes only the position and rotation.
virtual PxMat44 | getPose () const =0
get the pose of the grid - this includes only the position and rotation.
virtual PxVec3 | getGridBoundingBoxMin ()=0
get the grid bounding box min point
virtual PxVec3 | getGridBoundingBoxMax ()=0
get the grid bounding box max point
virtual PxVec3 | getGridSize ()=0
get the grid size vector
virtual void | getGridDimensions (uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ)=0
get the grid dimensions
virtual void | setGridDimensions (const uint32_t &gridX, const uint32_t &gridY, const uint32_t &gridZ)=0
set the grid dimensions
virtual void | setUpdatesPerFrame (float upd)=0
force the current updates per frame to a particular value.
virtual float | getUpdatesPerFrame () const =0
get the current value of the updates per frame
virtual void | getVelocityField (void **x, void **y, void **z, uint32_t &sizeX, uint32_t &sizeY, uint32_t &sizeZ)=0
methods to get the velocity field sampled at grid centers.
virtual void | setSampleVelocityFieldEnabled (bool enabled)=0
enable/disable sample velocity field
virtual void | setAngularVelocityMultiplierAndClamp (float angularVelocityMultiplier, float angularVelocityClamp)=0
set a multiplier and a clamp on the total angular velocity induced in the system by the internal collision obstacle or by external collision objects
virtual void | setLinearVelocityMultiplierAndClamp (float linearVelocityMultiplier, float linearVelocityClamp)=0
set a multiplier and a clamp on the total linear velocity induced in the system by a collision obstacle
virtual void | setVelocityFieldFade (float fade)=0
set velocity field fade. All cells in the field multiplies by (1 - fade) on each frame
virtual void | setFluidViscosity (float viscosity)=0
set fluid viscosity (diffusion) for velocity
virtual void | setVelocityFieldCleaningTime (float time)=0
set time of velocity field cleaning process [sec]
virtual void | setVelocityFieldCleaningDelay (float time)=0
set time without activity before velocity field cleaning process starts [sec].
virtual void | setVelocityFieldCleaningIntensity (float a)=0
virtual void | setUseHeat (bool enable)=0
enable whether or not to use heat in the simulation (enabling heat reduces performance).

virtual void | setHeatBasedParameters (float forceMultiplier, float ambientTemperature, PxVec3 heatForceDirection, float thermalConductivity)=0
set heat specific parameters for the simulation
virtual void | setUseDensity (bool enable)=0
enable whether or not to use density in the simulation (enabling density reduces performance).

virtual bool | getUseDensity (void) const =0
Returns true if turbulence actor is in density mode.
virtual void | setDensityBasedParameters (float diffusionCoef, float densityFieldFade)=0
set density specific parameters for the simulation
virtual void | getDensityGridDimensions (uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ)=0
get the density grid dimensions
virtual void | setExternalVelocity (PxVec3 vel)=0
allows external actors like wind or explosion to add a single directional velocity to the grid.

virtual void | setFieldVelocityMultiplier (float value)=0
set a multiplier for the field velocity
virtual void | setFieldVelocityWeight (float value)=0
set a weight for the field velocity
virtual void | setNoiseParameters (float noiseStrength, PxVec3 noiseSpacePeriod, float noiseTimePeriod, uint32_t noiseOctaves)=0
set noise parameters
virtual void | setDensityTextureRange (float minValue, float maxValue)=0
set density texture range
virtual const char * | getVolumeRenderMaterialName (void) const =0
Returns the optional volume render material name specified for this turbulence actor.
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.
virtual bool | getUseFlame (void) const =0
Returns true if turbulence actor is in flame mode.
virtual void | getFlameGridDimensions (uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ) const =0
Returns flame grid dimensions.
virtual TurbulenceRenderable * | acquireRenderableReference ()=0
Acquire a pointer to the Turbulence renderable proxy and increment its reference count.

Detailed Description

Turbulence FieldSampler Actor class.

Member Function Documentation

virtual TurbulenceRenderable* nvidia::apex::TurbulenceFSActor::acquireRenderableReference ( ) [pure virtual]

Acquire a pointer to the Turbulence renderable proxy and increment its reference count.

The TurbulenceRenderable will only be deleted when its reference count is zero. Calls to TurbulenceRenderable::release decrement the reference count, as does a call to TurbulenceFSActor::release().

virtual PxMat44 nvidia::apex::TurbulenceFSActor::getPose ( ) const [pure virtual]

get the pose of the grid - this includes only the position and rotation.

the position is that of the center of the grid, as is determined as (pose.column3.x, pose.column3.y, pose.column3.z)
the rotation is the rotation of the object that the grid is centered on
(the grid does not rotate, but we use this pose for rotating the collision obstacle, the jets and imparting angular momentum)

virtual void nvidia::apex::TurbulenceFSActor::getVelocityField | ( | void ** | x,
 |  | void ** | y,
 |  | void ** | z,
 |  | uint32_t & | sizeX,
 |  | uint32_t & | sizeY,
 |  | uint32_t & | sizeZ
 | ) |  | [pure virtual]

methods to get the velocity field sampled at grid centers.

call setSampleVelocityFieldEnabled(true) to enable the sampling and call getVelocityField to get back the sampled results

virtual void nvidia::apex::TurbulenceFSActor::setExternalVelocity ( PxVec3 vel ) [pure virtual]

allows external actors like wind or explosion to add a single directional velocity to the grid.

Note:
if multiple calls to this function are made only the last call is honored (i.e. the velocities are not accumulated)
virtual void nvidia::apex::TurbulenceFSActor::setPose ( PxMat44 pose ) [pure virtual]

set the pose of the grid - this includes only the position and rotation.

the position is that of the center of the grid, as is determined as (pose.column3.x, pose.column3.y, pose.column3.z)
the rotation is the rotation of the object that the grid is centered on
(the grid does not rotate, but we use this pose for rotating the collision obstacle, the jets and imparting angular momentum)

virtual void nvidia::apex::TurbulenceFSActor::setUpdatesPerFrame ( float upd ) [pure virtual]

force the current updates per frame to a particular value.

Range is 0-1:
1.0f is maximum simulation quality
0.0f is minimum simulation quality

virtual void nvidia::apex::TurbulenceFSActor::setUseDensity ( bool enable ) [pure virtual]

enable whether or not to use density in the simulation (enabling density reduces performance).

Note:
If you are enabling density then you also need to add substance sources (without substance sources you will see no effect of density on the simulation, except a drop in performance)
virtual void nvidia::apex::TurbulenceFSActor::setUseHeat ( bool enable ) [pure virtual]

enable whether or not to use heat in the simulation (enabling heat reduces performance).

Note:
If you are enabling heat then you also need to add temperature sources (without temperature sources you will see no effect of heat on the simulation, except a drop in performance)
virtual void nvidia::apex::TurbulenceFSActor::setVelocityFieldCleaningIntensity ( float a ) [pure virtual]

set parameter which correspond to 'a' in erf(a*(cleaning_timer/velocityFieldCleaningTime)). for full cleaning it should be greater then 2. If you want just decrease velocity magitude use smaller value

The documentation for this class was generated from the following file:
  • TurbulenceFSActor.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSActor
nvidia::apex::TurbulenceFSActor Member List
This is the complete list of members for nvidia::apex::TurbulenceFSActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireRenderableReference()=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getDensityGridDimensions(uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getFlameGridDimensions(uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ) const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getGridBoundingBoxMax()=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getGridBoundingBoxMin()=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getGridDimensions(uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getGridSize()=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getPose() const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getTurbulenceFSAsset() const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getUpdatesPerFrame() const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getUseDensity(void) const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getUseFlame(void) const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getVelocityField(void **x, void **y, void **z, uint32_t &sizeX, uint32_t &sizeY, uint32_t &sizeZ)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getVolumeRenderMaterialName(void) const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setAngularVelocityMultiplierAndClamp(float angularVelocityMultiplier, float angularVelocityClamp)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setDensityBasedParameters(float diffusionCoef, float densityFieldFade)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setDensityTextureRange(float minValue, float maxValue)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setEnabled(bool enable)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setExternalVelocity(PxVec3 vel)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setFieldVelocityMultiplier(float value)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setFieldVelocityWeight(float value)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setFluidViscosity(float viscosity)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setGridDimensions(const uint32_t &gridX, const uint32_t &gridY, const uint32_t &gridZ)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setHeatBasedParameters(float forceMultiplier, float ambientTemperature, PxVec3 heatForceDirection, float thermalConductivity)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setLinearVelocityMultiplierAndClamp(float linearVelocityMultiplier, float linearVelocityClamp)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setNoiseParameters(float noiseStrength, PxVec3 noiseSpacePeriod, float noiseTimePeriod, uint32_t noiseOctaves)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setSampleVelocityFieldEnabled(bool enabled)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setUpdatesPerFrame(float upd)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setUseDensity(bool enable)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setUseHeat(bool enable)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setVelocityFieldCleaningDelay(float time)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setVelocityFieldCleaningIntensity(float a)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setVelocityFieldCleaningTime(float time)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setVelocityFieldFade(float fade)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~TurbulenceFSActor() (defined in nvidia::apex::TurbulenceFSActor) | nvidia::apex::TurbulenceFSActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::TurbulenceFSAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSAsset
nvidia::apex::TurbulenceFSAsset Class Reference

Turbulence FieldSampler Asset class. More...

#include <TurbulenceFSAsset.h>

Inheritance diagram for nvidia::apex::TurbulenceFSAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

Turbulence FieldSampler Asset class.

The documentation for this class was generated from the following file:
  • TurbulenceFSAsset.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSAsset
nvidia::apex::TurbulenceFSAsset Member List
This is the complete list of members for nvidia::apex::TurbulenceFSAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~TurbulenceFSAsset() (defined in nvidia::apex::TurbulenceFSAsset) | nvidia::apex::TurbulenceFSAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::TurbulenceFSAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSAssetAuthoring
nvidia::apex::TurbulenceFSAssetAuthoring Class Reference

Turbulence FieldSampler Asset Authoring class. More...

#include <TurbulenceFSAsset.h>

Inheritance diagram for nvidia::apex::TurbulenceFSAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

Turbulence FieldSampler Asset Authoring class.

The documentation for this class was generated from the following file:
  • TurbulenceFSAsset.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSAssetAuthoring
nvidia::apex::TurbulenceFSAssetAuthoring Member List
This is the complete list of members for nvidia::apex::TurbulenceFSAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
~TurbulenceFSAssetAuthoring() (defined in nvidia::apex::TurbulenceFSAssetAuthoring) | nvidia::apex::TurbulenceFSAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::TurbulenceFSPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSPreview
Public Member Functions
nvidia::apex::TurbulenceFSPreview Class Reference

This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

#include <TurbulenceFSPreview.h>

Inheritance diagram for nvidia::apex::TurbulenceFSPreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void | setHalfLengthDimensions (PxVec3 halfLengthDimensions)=0
Set the half length dimensions of the actor thus resizing the box.
virtual void | setNumGrids (PxVec3 numGrids)=0
Set number of grid cells in the box.
virtual void | setIconScale (float scale)=0
Set the scale of the icon.
virtual void | setDetailLevel (uint32_t detail)=0
Set the detail level of the preview rendering by selecting which features to enable.

Detailed Description

This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually.

Member Function Documentation

virtual void nvidia::apex::TurbulenceFSPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable.

Any, all, or none of the following masks may be added together to select what should be drawn.
The defines for the individual items are:
TURBO_DRAW_NOTHING - draw nothing
TURBO_DRAW_ICON - draw the APEX TurbulenceFS Icon
TURBO_DRAW_BOX - draw the box
TURBO_DRAW_COLLISION_IMPLICIT - draw the collision implicit
TURBO_DRAW_GRIDS - draw the top and bottom grids of the box
TURBO_DRAW_ASSET_INFO - draw the turbulencefs asset info in the screen space
TURBO_DRAW_FULL_DETAIL - draw all components of the turbulencefs preview
All items may be drawn using the macro DRAW_FULL_DETAIL.

virtual void nvidia::apex::TurbulenceFSPreview::setIconScale ( float scale ) [pure virtual]

Set the scale of the icon.

The unscaled icon has is 1.0x1.0 game units.
By default the scale of the icon is 1.0. (unscaled)

The documentation for this class was generated from the following file:
  • TurbulenceFSPreview.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSPreview
nvidia::apex::TurbulenceFSPreview Member List
This is the complete list of members for nvidia::apex::TurbulenceFSPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setDetailLevel(uint32_t detail)=0 | nvidia::apex::TurbulenceFSPreview | [pure virtual]
setHalfLengthDimensions(PxVec3 halfLengthDimensions)=0 | nvidia::apex::TurbulenceFSPreview | [pure virtual]
setIconScale(float scale)=0 | nvidia::apex::TurbulenceFSPreview | [pure virtual]
setNumGrids(PxVec3 numGrids)=0 | nvidia::apex::TurbulenceFSPreview | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::TurbulenceRenderCallback Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderCallback
Public Member Functions
nvidia::apex::TurbulenceRenderCallback Class Reference

User defined callback for Turbulence rendering. More...

#include <TurbulenceRenderCallback.h>

Inheritance diagram for nvidia::apex::TurbulenceRenderCallback:
nvidia::apex::UserRenderCallback

List of all members.

Public Member Functions

virtual void | onCreatedTurbulenceRenderable (TurbulenceRenderable &)
Called just after a new Turbulence renderable was created.
virtual void | onUpdatedTurbulenceRenderable (TurbulenceRenderable &)
Called just after an Turbulence renderable was updated.
virtual void | onReleasingTurbulenceRenderable (TurbulenceRenderable &)
Called just before an Turbulence renderable is going to be released.
virtual bool | getTurbulenceRenderLayout (TurbulenceRenderLayout &renderLayout, uint32_t sizeX, uint32_t sizeY, uint32_t sizeZ, uint32_t densitySizeMultiplier, uint32_t flameSizeMultiplier)
Returns render layout.

Detailed Description

User defined callback for Turbulence rendering.

The documentation for this class was generated from the following file:
  • TurbulenceRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderCallback
nvidia::apex::TurbulenceRenderCallback Member List
This is the complete list of members for nvidia::apex::TurbulenceRenderCallback, including all inherited members.
createRenderBuffer(const UserRenderBufferDesc &) | nvidia::apex::UserRenderCallback | [inline, virtual]
createRenderSurface(const UserRenderSurfaceDesc &) | nvidia::apex::UserRenderCallback | [inline, virtual]
getTurbulenceRenderLayout(TurbulenceRenderLayout &renderLayout, uint32_t sizeX, uint32_t sizeY, uint32_t sizeZ, uint32_t densitySizeMultiplier, uint32_t flameSizeMultiplier) | nvidia::apex::TurbulenceRenderCallback | [inline, virtual]
onCreatedTurbulenceRenderable(TurbulenceRenderable &) | nvidia::apex::TurbulenceRenderCallback | [inline, virtual]
onReleasingTurbulenceRenderable(TurbulenceRenderable &) | nvidia::apex::TurbulenceRenderCallback | [inline, virtual]
onUpdatedTurbulenceRenderable(TurbulenceRenderable &) | nvidia::apex::TurbulenceRenderCallback | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::TurbulenceRenderable Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderable
Public Member Functions
nvidia::apex::TurbulenceRenderable Class Reference

The Turbulence renderable represents a unit of rendering. More...

#include <TurbulenceRenderable.h>

Inheritance diagram for nvidia::apex::TurbulenceRenderable:
nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual const
TurbulenceRenderData * 		getRenderData () const =0
Return render data.
virtual const physx::PxBounds3 & getBounds () const =0
Return AABB of this renderable.

Detailed Description

The Turbulence renderable represents a unit of rendering.

It contains complete information to render one Turbulence Actor.

The documentation for this class was generated from the following file:
  • TurbulenceRenderable.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderable
nvidia::apex::TurbulenceRenderable Member List
This is the complete list of members for nvidia::apex::TurbulenceRenderable, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getBounds() const =0 | nvidia::apex::TurbulenceRenderable | [pure virtual]
getRenderData() const =0 | nvidia::apex::TurbulenceRenderable | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~TurbulenceRenderable() (defined in nvidia::apex::TurbulenceRenderable) | nvidia::apex::TurbulenceRenderable | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserChunkParticleReport Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserChunkParticleReport
Public Member Functions
nvidia::apex::UserChunkParticleReport Class Reference

#include <ModuleDestructible.h>

List of all members.

Public Member Functions

virtual void onParticleEmission (const ChunkParticleReportData &particleData)=0

Detailed Description

UserChunkParticleReport - API for a user-defined callback to get particle buffer data when a chunk crumbles or emits dust particles. Note - only crumble emitters are implemented in 1.2.0

Member Function Documentation

virtual void nvidia::apex::UserChunkParticleReport::onParticleEmission ( const ChunkParticleReportData & particleData ) [pure virtual]

User implementation of UserChunkParticleReport must overload this function. This function will get called when an DestructibleActor generates crumble particle or dust particle effect data. Crumble particles are generated whenever a chunk is destroyed completely and the DestructibleActorFlag CRUMBLE_SMALLEST_CHUNKS is set. Dust line particles are generated along chunk boundaries whenever they are fractured free from other chunks.

Note - only crumble emitters are implemented in 1.2.0

The documentation for this class was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserChunkParticleReport
nvidia::apex::UserChunkParticleReport Member List
This is the complete list of members for nvidia::apex::UserChunkParticleReport, including all inherited members.
onParticleEmission(const ChunkParticleReportData &particleData)=0 | nvidia::apex::UserChunkParticleReport | [pure virtual]
~UserChunkParticleReport() (defined in nvidia::apex::UserChunkParticleReport) | nvidia::apex::UserChunkParticleReport | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::UserChunkReport Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserChunkReport
Public Member Functions
nvidia::apex::UserChunkReport Class Reference

#include <ModuleDestructible.h>

List of all members.

Public Member Functions

virtual void | onDamageNotify (const DamageEventReportData &damageEvent)=0
virtual void | onStateChangeNotify (const ChunkStateEventData &visibilityEvent)=0
virtual bool | releaseOnNoChunksVisible (const DestructibleActor *destructible)
virtual void | onDestructibleWake (DestructibleActor **destructibles, uint32_t count)=0
virtual void | onDestructibleSleep (DestructibleActor **destructibles, uint32_t count)=0

Detailed Description

UserChunkReport - API for a user-defined callback to get information about fractured or damaged chunks

Member Function Documentation

virtual void nvidia::apex::UserChunkReport::onDamageNotify ( const DamageEventReportData & damageEvent ) [pure virtual]

User implementation of UserChunkReport must overload this function. This function will get called when a chunk is fractured or destroyed. See the definition of DamageEventReportData for the information provided to the function.

virtual void nvidia::apex::UserChunkReport::onDestructibleSleep | ( | DestructibleActor ** | destructibles,
 |  | uint32_t | count
 | ) |  | [pure virtual]

List of destructible actors that have just gone to sleep (all associated PhysX actors have gone to sleep).

virtual void nvidia::apex::UserChunkReport::onDestructibleWake | ( | DestructibleActor ** | destructibles,
 |  | uint32_t | count
 | ) |  | [pure virtual]

List of destructible actors that have just become awake (any associated PhysX actor has become awake).

virtual void nvidia::apex::UserChunkReport::onStateChangeNotify ( const ChunkStateEventData & visibilityEvent ) [pure virtual]

User implementation of UserChunkReport must overload this function. This function gets called when chunk visibility changes occur, if the user has selected this option via ModuleDestructible::scheduleChunkStateEventCallback. See the definition of ChunkStateEventData for the information provided to the function.

Please note* the user must also set the NxParameterized actor parameter 'createChunkEvents' to true, on individual destructible actors, to receive state change events from that actor.

virtual bool nvidia::apex::UserChunkReport::releaseOnNoChunksVisible ( const DestructibleActor * destructible ) [inline, virtual]

Called when an DestructibleActor contains no visible chunks. If the user returns true, APEX will release the destructible actor. If the user returns false, they should not release the destructible actor from within the callback, and instead must wait until the completion of Scene::fetchResults().

Default implementation returns false, which is the legacy behavior.

If this class (UserChunkReport) is not implemented, APEX will not destroy the DestructibleActor.

The documentation for this class was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserChunkReport
nvidia::apex::UserChunkReport Member List
This is the complete list of members for nvidia::apex::UserChunkReport, including all inherited members.
onDamageNotify(const DamageEventReportData &damageEvent)=0 | nvidia::apex::UserChunkReport | [pure virtual]
onDestructibleSleep(DestructibleActor **destructibles, uint32_t count)=0 | nvidia::apex::UserChunkReport | [pure virtual]
onDestructibleWake(DestructibleActor **destructibles, uint32_t count)=0 | nvidia::apex::UserChunkReport | [pure virtual]
onStateChangeNotify(const ChunkStateEventData &visibilityEvent)=0 | nvidia::apex::UserChunkReport | [pure virtual]
releaseOnNoChunksVisible(const DestructibleActor *destructible) | nvidia::apex::UserChunkReport | [inline, virtual]
~UserChunkReport() (defined in nvidia::apex::UserChunkReport) | nvidia::apex::UserChunkReport | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::UserDestructiblePhysXActorReport Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserDestructiblePhysXActorReport
Public Member Functions
nvidia::apex::UserDestructiblePhysXActorReport Class Reference

#include <ModuleDestructible.h>

List of all members.

Public Member Functions

virtual void | onPhysXActorCreate (const physx::PxActor &actor)=0
virtual void | onPhysXActorRelease (const physx::PxActor &actor)=0

Detailed Description

UserDestructiblePhysXActorReport - API for user-defined callbacks giving notification of PhysX actor creation and release from the destruction module.

Member Function Documentation

virtual void nvidia::apex::UserDestructiblePhysXActorReport::onPhysXActorCreate ( const physx::PxActor & actor ) [pure virtual]

Called immediately after a PxActor is created in the Destruction module.

virtual void nvidia::apex::UserDestructiblePhysXActorReport::onPhysXActorRelease ( const physx::PxActor & actor ) [pure virtual]

Called immediately before a PxActor is released in the Destruction module.

The documentation for this class was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserDestructiblePhysXActorReport
nvidia::apex::UserDestructiblePhysXActorReport Member List
This is the complete list of members for nvidia::apex::UserDestructiblePhysXActorReport, including all inherited members.
onPhysXActorCreate(const physx::PxActor &actor)=0 | nvidia::apex::UserDestructiblePhysXActorReport | [pure virtual]
onPhysXActorRelease(const physx::PxActor &actor)=0 | nvidia::apex::UserDestructiblePhysXActorReport | [pure virtual]
~UserDestructiblePhysXActorReport() (defined in nvidia::apex::UserDestructiblePhysXActorReport) | nvidia::apex::UserDestructiblePhysXActorReport | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > Class Template Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserDestructibleSyncHandler
Public Member Functions
nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > Class Template Reference

#include <ModuleDestructible.h>

List of all members.

Public Member Functions

virtual void | onWriteBegin (DestructibleSyncHeader *&bufferStart, uint32_t bufferSize)=0
virtual void | onWriteDone (uint32_t headerCount)=0
virtual void | onPreProcessReadBegin (DestructibleSyncHeader *&bufferStart, uint32_t &bufferSize, bool &continuePointerSwizzling)=0
virtual void | onPreProcessReadDone (uint32_t headerCount)=0
virtual void | onReadBegin (const DestructibleSyncHeader *&bufferStart)=0
virtual void | onReadDone (const char *debugMessage)=0

Detailed Description

template<typename DestructibleSyncHeader>
class nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >

Sync-able Callback Class.

Member Function Documentation

template<typename DestructibleSyncHeader>
virtual void nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >::onPreProcessReadBegin | ( | DestructibleSyncHeader *& | bufferStart,
 |  | uint32_t & | bufferSize,
 |  | bool & | continuePointerSwizzling
 | ) |  | [pure virtual]

Called when pre-process read begins.

template<typename DestructibleSyncHeader>
virtual void nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >::onPreProcessReadDone ( uint32_t headerCount ) [pure virtual]

Called when pre-process read done.

template<typename DestructibleSyncHeader>
virtual void nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >::onReadBegin ( const DestructibleSyncHeader *& bufferStart ) [pure virtual]

Called when read begins.

template<typename DestructibleSyncHeader>
virtual void nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >::onReadDone ( const char * debugMessage ) [pure virtual]

Called when read done.

template<typename DestructibleSyncHeader>
virtual void nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >::onWriteBegin | ( | DestructibleSyncHeader *& | bufferStart,
 |  | uint32_t | bufferSize
 | ) |  | [pure virtual]

Called when write begins.

template<typename DestructibleSyncHeader>
virtual void nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >::onWriteDone ( uint32_t headerCount ) [pure virtual]

Called when write done.

The documentation for this class was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserDestructibleSyncHandler
nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > Member List
This is the complete list of members for nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >, including all inherited members.
onPreProcessReadBegin(DestructibleSyncHeader *&bufferStart, uint32_t &bufferSize, bool &continuePointerSwizzling)=0 | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [pure virtual]
onPreProcessReadDone(uint32_t headerCount)=0 | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [pure virtual]
onReadBegin(const DestructibleSyncHeader *&bufferStart)=0 | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [pure virtual]
onReadDone(const char *debugMessage)=0 | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [pure virtual]
onWriteBegin(DestructibleSyncHeader *&bufferStart, uint32_t bufferSize)=0 | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [pure virtual]
onWriteDone(uint32_t headerCount)=0 | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [pure virtual]
~UserDestructibleSyncHandler() (defined in nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >) | nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader > | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::UserImpactDamageReport Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserImpactDamageReport
Public Member Functions
nvidia::apex::UserImpactDamageReport Class Reference

#include <ModuleDestructible.h>

List of all members.

Public Member Functions

virtual void onImpactDamageNotify (const ImpactDamageEventData *buffer, uint32_t bufferSize)=0

Detailed Description

UserImpactDamageReport - API for a user-defined callback to get a buffer of impact damage events

Member Function Documentation

virtual void nvidia::apex::UserImpactDamageReport::onImpactDamageNotify | ( | const ImpactDamageEventData * | buffer,
 |  | uint32_t | bufferSize
 | ) |  | [pure virtual]

User implementation of UserImpactDamageReport must overload this function. If an instance of this object is passed to ModuleDestructible::setImpactDamageReportCallback, this function will get called once during ApexScene::fetchResults, passing back an array of ImpactDamageEventData reporting all impact damage events.

The documentation for this class was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserImpactDamageReport
nvidia::apex::UserImpactDamageReport Member List
This is the complete list of members for nvidia::apex::UserImpactDamageReport, including all inherited members.
onImpactDamageNotify(const ImpactDamageEventData *buffer, uint32_t bufferSize)=0 nvidia::apex::UserImpactDamageReport [pure virtual]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::UserOpaqueMesh Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserOpaqueMesh
nvidia::apex::UserOpaqueMesh Class Reference

An abstract interface to an opaque mesh. More...

#include <UserOpaqueMesh.h>

List of all members.

Detailed Description

An abstract interface to an opaque mesh.

An 'opaque' mesh is a binding between the 'name' of a mesh and some internal mesh representation used by the application. This allows the application to refer to meshes by name without involving duplciation of index buffer and vertex buffer data declarations.

The documentation for this class was generated from the following file:
  • UserOpaqueMesh.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserOpaqueMesh
nvidia::apex::UserOpaqueMesh Member List
This is the complete list of members for nvidia::apex::UserOpaqueMesh, including all inherited members.
~UserOpaqueMesh() (defined in nvidia::apex::UserOpaqueMesh) nvidia::apex::UserOpaqueMesh [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserOpaqueMeshDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserOpaqueMeshDesc
Public Attributes
nvidia::apex::UserOpaqueMeshDesc Class Reference

Opaque mesh description. More...

#include <UserOpaqueMesh.h>

List of all members.

Public Attributes

const char * mMeshName
the name of the opaque mesh

Detailed Description

Opaque mesh description.

The documentation for this class was generated from the following file:
  • UserOpaqueMesh.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserOpaqueMeshDesc
nvidia::apex::UserOpaqueMeshDesc Member List
This is the complete list of members for nvidia::apex::UserOpaqueMeshDesc, including all inherited members.
mMeshName nvidia::apex::UserOpaqueMeshDesc
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderBoneBuffer Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderBoneBuffer
Public Member Functions
nvidia::apex::UserRenderBoneBuffer Class Reference

Used for storing skeletal bone information used during skinning. More...

#include <UserRenderBoneBuffer.h>

List of all members.

Public Member Functions

virtual void writeBuffer (const nvidia::RenderBoneBufferData &data, uint32_t firstBone, uint32_t numBones)=0
Called when APEX wants to update the contents of the bone buffer.

Detailed Description

Used for storing skeletal bone information used during skinning.

Separated out into its own interface as we don't know how the user is going to implement this it could be in another vertex buffer, a texture or just an array and skinned on CPU depending on engine and hardware support.

Member Function Documentation

virtual void nvidia::apex::UserRenderBoneBuffer::writeBuffer | ( | const nvidia::RenderBoneBufferData & | data,
 |  | uint32_t | firstBone,
 |  | uint32_t | numBones
 | ) |  | [pure virtual]

Called when APEX wants to update the contents of the bone buffer.

The source data type is assumed to be the same as what was defined in the descriptor. APEX should call this function and supply data for ALL semantics that were originally requested during creation every time its called.

Parameters:
[in] | data | Contains the source data for the bone buffer.
[in] | firstBone | first bone to start writing to.
[in] | numBones | number of bones to write.
The documentation for this class was generated from the following file:
  • UserRenderBoneBuffer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderBoneBuffer
nvidia::apex::UserRenderBoneBuffer Member List
This is the complete list of members for nvidia::apex::UserRenderBoneBuffer, including all inherited members.
writeBuffer(const nvidia::RenderBoneBufferData &data, uint32_t firstBone, uint32_t numBones)=0 | nvidia::apex::UserRenderBoneBuffer | [pure virtual]
~UserRenderBoneBuffer() (defined in nvidia::apex::UserRenderBoneBuffer) | nvidia::apex::UserRenderBoneBuffer | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderBoneBufferDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderBoneBufferDesc
Public Member Functions | Public Attributes
nvidia::apex::UserRenderBoneBufferDesc Class Reference

Descriptor to generate a bone buffer. More...

#include <UserRenderBoneBufferDesc.h>

List of all members.

Public Member Functions

bool | isValid (void) const
Check if parameter's values are correct.

Public Attributes

uint32_t | maxBones
The maximum amount of bones this buffer will ever hold.
RenderBufferHint::Enum hint
Hint on how often this buffer is updated.
RenderDataFormat::Enum | buffersRequest [RenderBoneSemantic::NUM_SEMANTICS]
Array of semantics with the corresponding format.

Detailed Description

Descriptor to generate a bone buffer.

This descriptor is filled out by APEX and helps as a guide how the bone buffer should be generated.

Member Data Documentation

RenderDataFormat::Enum nvidia::apex::UserRenderBoneBufferDesc::buffersRequest[RenderBoneSemantic::NUM_SEMANTICS]

Array of semantics with the corresponding format.

RenderDataFormat::UNSPECIFIED is used for semantics that are disabled

The documentation for this class was generated from the following file:
  • UserRenderBoneBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderBoneBufferDesc
nvidia::apex::UserRenderBoneBufferDesc Member List
This is the complete list of members for nvidia::apex::UserRenderBoneBufferDesc, including all inherited members.
buffersRequest | nvidia::apex::UserRenderBoneBufferDesc |
hint | nvidia::apex::UserRenderBoneBufferDesc |
isValid(void) const | nvidia::apex::UserRenderBoneBufferDesc | [inline]
maxBones | nvidia::apex::UserRenderBoneBufferDesc |
UserRenderBoneBufferDesc(void) (defined in nvidia::apex::UserRenderBoneBufferDesc) | nvidia::apex::UserRenderBoneBufferDesc | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderBuffer Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderBuffer
Public Member Functions
nvidia::apex::UserRenderBuffer Class Reference

User render buffer. More...

#include <UserRenderCallback.h>

Inheritance diagram for nvidia::apex::UserRenderBuffer:
nvidia::apex::UserRenderStorage

List of all members.

Public Member Functions

virtual Type | getType () const
Returns BUFFER type.
virtual void * | map (RenderMapType::Enum mapType, size_t offset=0, size_t size=SIZE_MAX)=0
Returns CPU memory pointer to buffer content.
virtual void | unmap ()=0
Flush CPU buffer to GPU.
virtual bool | getCUDAgraphicsResource (CUgraphicsResource &ret)=0
Returns graphics resource for CUDA Interop.

Detailed Description

User render buffer.

Member Function Documentation

virtual bool nvidia::apex::UserRenderBuffer::getCUDAgraphicsResource ( CUgraphicsResource & ret ) [pure virtual]

Returns graphics resource for CUDA Interop.

Note:
GPU access
virtual void* nvidia::apex::UserRenderBuffer::map | ( | RenderMapType::Enum | mapType,
 |  | size_t | offset = 0,
 |  | size_t | size = SIZE_MAX
 | ) |  | [pure virtual]

Returns CPU memory pointer to buffer content.

Note:
CPU access
The documentation for this class was generated from the following file:
  • UserRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderBuffer
nvidia::apex::UserRenderBuffer Member List
This is the complete list of members for nvidia::apex::UserRenderBuffer, including all inherited members.
BUFFER enum value (defined in nvidia::apex::UserRenderStorage) | nvidia::apex::UserRenderStorage |
getCUDAgraphicsResource(CUgraphicsResource &ret)=0 | nvidia::apex::UserRenderBuffer | [pure virtual]
getType() const | nvidia::apex::UserRenderBuffer | [inline, virtual]
map(RenderMapType::Enum mapType, size_t offset=0, size_t size=SIZE_MAX)=0 | nvidia::apex::UserRenderBuffer | [pure virtual]
release()=0 | nvidia::apex::UserRenderStorage | [pure virtual]
SURFACE enum value (defined in nvidia::apex::UserRenderStorage) | nvidia::apex::UserRenderStorage |
Type enum name | nvidia::apex::UserRenderStorage |
unmap()=0 | nvidia::apex::UserRenderBuffer | [pure virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderCallback Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderCallback
Public Member Functions
nvidia::apex::UserRenderCallback Class Reference

User render callback. More...

#include <UserRenderCallback.h>

Inheritance diagram for nvidia::apex::UserRenderCallback:
nvidia::apex::IofxRenderCallback nvidia::apex::TurbulenceRenderCallback

List of all members.

Public Member Functions

virtual UserRenderBuffer * | createRenderBuffer (const UserRenderBufferDesc &)
Creates render buffer with specified UserRenderBufferDesc.
virtual UserRenderSurface * | createRenderSurface (const UserRenderSurfaceDesc &)
Creates render surface with specified UserRenderSurfaceDesc.

Detailed Description

User render callback.

The documentation for this class was generated from the following file:
  • UserRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderCallback
nvidia::apex::UserRenderCallback Member List
This is the complete list of members for nvidia::apex::UserRenderCallback, including all inherited members.
createRenderBuffer(const UserRenderBufferDesc &) | nvidia::apex::UserRenderCallback | [inline, virtual]
createRenderSurface(const UserRenderSurfaceDesc &) | nvidia::apex::UserRenderCallback | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderData Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderData
Public Member Functions
nvidia::apex::UserRenderData Class Reference

User render data. More...

#include <UserRenderCallback.h>

List of all members.

Public Member Functions

virtual void | addRef ()=0
Add reference.
virtual void | release ()=0
release data

Detailed Description

User render data.

The documentation for this class was generated from the following file:
  • UserRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderData
nvidia::apex::UserRenderData Member List
This is the complete list of members for nvidia::apex::UserRenderData, including all inherited members.
addRef()=0 | nvidia::apex::UserRenderData | [pure virtual]
release()=0 | nvidia::apex::UserRenderData | [pure virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderDataHolder Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderDataHolder
Public Member Functions
nvidia::apex::UserRenderDataHolder Class Reference

User render data holder. More...

#include <UserRenderCallback.h>

Inheritance diagram for nvidia::apex::UserRenderDataHolder:
nvidia::apex::UserRenderBufferDesc nvidia::apex::UserRenderSurfaceDesc

List of all members.

Public Member Functions

UserRenderDataHolder (const UserRenderDataHolder &other)
Copy constructor for UserRenderDataHolder.
UserRenderDataHolder & | operator= (const UserRenderDataHolder &other)
Assignment operator for UserRenderDataHolder.
void | setUserData (UserRenderData *newUserData)
Set user render data.
UserRenderData * | getUserData () const
Get user render data.

Detailed Description

User render data holder.

Member Function Documentation

UserRenderData* nvidia::apex::UserRenderDataHolder::getUserData ( ) const [inline]

Get user render data.

See also:
UserRenderData
void nvidia::apex::UserRenderDataHolder::setUserData ( UserRenderData * newUserData ) [inline]

Set user render data.

See also:
UserRenderData
The documentation for this class was generated from the following file:
  • UserRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderDataHolder
nvidia::apex::UserRenderDataHolder Member List
This is the complete list of members for nvidia::apex::UserRenderDataHolder, including all inherited members.
getUserData() const | nvidia::apex::UserRenderDataHolder | [inline]
operator=(const UserRenderDataHolder &other) | nvidia::apex::UserRenderDataHolder | [inline]
setUserData(UserRenderData *newUserData) | nvidia::apex::UserRenderDataHolder | [inline]
UserRenderDataHolder() (defined in nvidia::apex::UserRenderDataHolder) | nvidia::apex::UserRenderDataHolder | [inline]
UserRenderDataHolder(const UserRenderDataHolder &other) | nvidia::apex::UserRenderDataHolder | [inline]
~UserRenderDataHolder() (defined in nvidia::apex::UserRenderDataHolder) | nvidia::apex::UserRenderDataHolder | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderIndexBuffer Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderIndexBuffer
Public Member Functions
nvidia::apex::UserRenderIndexBuffer Class Reference

Used for storing index data for rendering. More...

#include <UserRenderIndexBuffer.h>

List of all members.

Public Member Functions

virtual bool | getInteropResourceHandle (CUgraphicsResource &handle)
virtual void | writeBuffer (const void *srcData, uint32_t srcStride, uint32_t firstDestElement, uint32_t numElements)=0
write some data into the buffer.

Detailed Description

Used for storing index data for rendering.

Member Function Documentation

virtual bool nvidia::apex::UserRenderIndexBuffer::getInteropResourceHandle ( CUgraphicsResource & handle ) [inline, virtual]

Get the low-level handle of the buffer resource (D3D resource pointer or GL buffer object ID)

Returns:
true id succeeded, false otherwise
The documentation for this class was generated from the following file:
  • UserRenderIndexBuffer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderIndexBuffer
nvidia::apex::UserRenderIndexBuffer Member List
This is the complete list of members for nvidia::apex::UserRenderIndexBuffer, including all inherited members.
getInteropResourceHandle(CUgraphicsResource &handle) | nvidia::apex::UserRenderIndexBuffer | [inline, virtual]
writeBuffer(const void *srcData, uint32_t srcStride, uint32_t firstDestElement, uint32_t numElements)=0 | nvidia::apex::UserRenderIndexBuffer | [pure virtual]
~UserRenderIndexBuffer() (defined in nvidia::apex::UserRenderIndexBuffer) | nvidia::apex::UserRenderIndexBuffer | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderIndexBufferDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderIndexBufferDesc
Public Member Functions | Public Attributes
nvidia::apex::UserRenderIndexBufferDesc Class Reference

PX_PS4. More...

#include <UserRenderIndexBufferDesc.h>

List of all members.

Public Member Functions

bool | isValid (void) const
Check if parameter's values are correct.

Public Attributes

uint32_t | maxIndices
The maximum amount of indices this buffer will ever hold.
RenderBufferHint::Enum hint
Hint on how often this buffer is updated.
RenderDataFormat::Enum format
The format of this buffer (only one implied semantic)
RenderPrimitiveType::Enum primitives
Rendering primitive type (triangle, line strip, etc)
bool | registerInCUDA
Declare if the resource must be registered in CUDA upon creation.
PxCudaContextManager * | interopContext
The CUDA context.

Detailed Description

PX_PS4.

describes the semantics and layout of an index buffer

Member Data Documentation

PxCudaContextManager* nvidia::apex::UserRenderIndexBufferDesc::interopContext

The CUDA context.

This context must be used to register and unregister the resource every time the device is lost and recreated.

The documentation for this class was generated from the following file:
  • UserRenderIndexBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderIndexBufferDesc
nvidia::apex::UserRenderIndexBufferDesc Member List
This is the complete list of members for nvidia::apex::UserRenderIndexBufferDesc, including all inherited members.
format | nvidia::apex::UserRenderIndexBufferDesc |
hint | nvidia::apex::UserRenderIndexBufferDesc |
interopContext | nvidia::apex::UserRenderIndexBufferDesc |
isValid(void) const | nvidia::apex::UserRenderIndexBufferDesc | [inline]
maxIndices | nvidia::apex::UserRenderIndexBufferDesc |
primitives | nvidia::apex::UserRenderIndexBufferDesc |
registerInCUDA | nvidia::apex::UserRenderIndexBufferDesc |
UserRenderIndexBufferDesc(void) (defined in nvidia::apex::UserRenderIndexBufferDesc) | nvidia::apex::UserRenderIndexBufferDesc | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderInstanceBuffer Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderInstanceBuffer
Public Member Functions
nvidia::apex::UserRenderInstanceBuffer Class Reference

Used for storing per-instance data for rendering. More...

#include <UserRenderInstanceBuffer.h>

List of all members.

Public Member Functions

virtual bool | getInteropResourceHandle (CUgraphicsResource &handle)
virtual void | writeBuffer (const void *data, uint32_t firstInstance, uint32_t numInstances)
Called when APEX wants to update the contents of the instance buffer.

Detailed Description

Used for storing per-instance data for rendering.

Member Function Documentation

virtual bool nvidia::apex::UserRenderInstanceBuffer::getInteropResourceHandle ( CUgraphicsResource & handle ) [inline, virtual]

Get the low-level handle of the buffer resource

Returns:
true if succeeded, false otherwise
virtual void nvidia::apex::UserRenderInstanceBuffer::writeBuffer | ( | const void * | data,
 |  | uint32_t | firstInstance,
 |  | uint32_t | numInstances
 | ) |  | [inline, virtual]

Called when APEX wants to update the contents of the instance buffer.

The source data type is assumed to be the same as what was defined in the descriptor. APEX should call this function and supply data for ALL semantics that were originally requested during creation every time its called.

Parameters:
[in] | data | Contains the source data for the instance buffer.
[in] | firstInstance | first instance to start writing to.
[in] | numInstances | number of instance to write.
The documentation for this class was generated from the following file:
  • UserRenderInstanceBuffer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderInstanceBuffer
nvidia::apex::UserRenderInstanceBuffer Member List
This is the complete list of members for nvidia::apex::UserRenderInstanceBuffer, including all inherited members.
getInteropResourceHandle(CUgraphicsResource &handle) | nvidia::apex::UserRenderInstanceBuffer | [inline, virtual]
writeBuffer(const void *data, uint32_t firstInstance, uint32_t numInstances) | nvidia::apex::UserRenderInstanceBuffer | [inline, virtual]
~UserRenderInstanceBuffer() (defined in nvidia::apex::UserRenderInstanceBuffer) | nvidia::apex::UserRenderInstanceBuffer | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderInstanceBufferDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderInstanceBufferDesc
Public Member Functions | Public Attributes
nvidia::apex::UserRenderInstanceBufferDesc Class Reference

Describes the data and layout of an instance buffer. More...

#include <UserRenderInstanceBufferDesc.h>

List of all members.

Public Member Functions

void | setDefaults ()
Default values.
bool | isValid (void) const
Check if parameter's values are correct.
bool | isTheSameAs (const UserRenderInstanceBufferDesc &other) const
Check if this object is the same as other.

Public Attributes

uint32_t | maxInstances
The maximum amount of instances this buffer will ever hold.
RenderBufferHint::Enum hint
Hint on how often this buffer is updated.
uint32_t | semanticOffsets [RenderInstanceLayoutElement::NUM_SEMANTICS]
Array of the corresponding offsets (in bytes) for each semantic.
uint32_t | stride
The stride between instances of this buffer. Required when CUDA interop is used!
bool | registerInCUDA
Declare if the resource must be registered in CUDA upon creation.
PxCudaContextManager * | interopContext

Detailed Description

Describes the data and layout of an instance buffer.

Member Data Documentation

PxCudaContextManager* nvidia::apex::UserRenderInstanceBufferDesc::interopContext

This context must be used to register and unregister the resource every time the device is lost and recreated.

The documentation for this class was generated from the following file:
  • UserRenderInstanceBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderInstanceBufferDesc
nvidia::apex::UserRenderInstanceBufferDesc Member List
This is the complete list of members for nvidia::apex::UserRenderInstanceBufferDesc, including all inherited members.
hint | nvidia::apex::UserRenderInstanceBufferDesc |
interopContext | nvidia::apex::UserRenderInstanceBufferDesc |
isTheSameAs(const UserRenderInstanceBufferDesc &other) const | nvidia::apex::UserRenderInstanceBufferDesc | [inline]
isValid(void) const | nvidia::apex::UserRenderInstanceBufferDesc | [inline]
maxInstances | nvidia::apex::UserRenderInstanceBufferDesc |
registerInCUDA | nvidia::apex::UserRenderInstanceBufferDesc |
semanticOffsets | nvidia::apex::UserRenderInstanceBufferDesc |
setDefaults() | nvidia::apex::UserRenderInstanceBufferDesc | [inline]
stride | nvidia::apex::UserRenderInstanceBufferDesc |
UserRenderInstanceBufferDesc(void) (defined in nvidia::apex::UserRenderInstanceBufferDesc) | nvidia::apex::UserRenderInstanceBufferDesc | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderResource Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderResource
Public Member Functions
nvidia::apex::UserRenderResource Class Reference

An abstract interface to a renderable resource. More...

#include <UserRenderResource.h>

List of all members.

Public Member Functions

virtual void | setVertexBufferRange (uint32_t firstVertex, uint32_t numVerts)=0
Set vertex buffer range.
virtual void | setIndexBufferRange (uint32_t firstIndex, uint32_t numIndices)=0
Set index buffer range.
virtual void | setBoneBufferRange (uint32_t firstBone, uint32_t numBones)=0
Set bone buffer range.
virtual void | setInstanceBufferRange (uint32_t firstInstance, uint32_t numInstances)=0
Set instance buffer range.
virtual void | setSpriteBufferRange (uint32_t firstSprite, uint32_t numSprites)=0
Set sprite buffer range.
virtual void | setSpriteVisibleCount (uint32_t visibleCount)
Set sprite visible count.
virtual void | setMaterial (void *material)=0
Set material.
virtual uint32_t | getNbVertexBuffers () const =0
Get number of vertex buffers.
virtual UserRenderVertexBuffer * | getVertexBuffer (uint32_t index) const =0
Get vertex buffer.
virtual UserRenderIndexBuffer * | getIndexBuffer () const =0
Get index buffer.
virtual UserRenderBoneBuffer * | getBoneBuffer () const =0
Get bone buffer.
virtual UserRenderInstanceBuffer * | getInstanceBuffer () const =0
Get instance buffer.
virtual UserRenderSpriteBuffer * | getSpriteBuffer () const =0
Get sprite buffer.

Detailed Description

An abstract interface to a renderable resource.

The documentation for this class was generated from the following file:
  • UserRenderResource.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderResource
nvidia::apex::UserRenderResource Member List
This is the complete list of members for nvidia::apex::UserRenderResource, including all inherited members.
getBoneBuffer() const =0 | nvidia::apex::UserRenderResource | [pure virtual]
getIndexBuffer() const =0 | nvidia::apex::UserRenderResource | [pure virtual]
getInstanceBuffer() const =0 | nvidia::apex::UserRenderResource | [pure virtual]
getNbVertexBuffers() const =0 | nvidia::apex::UserRenderResource | [pure virtual]
getSpriteBuffer() const =0 | nvidia::apex::UserRenderResource | [pure virtual]
getVertexBuffer(uint32_t index) const =0 | nvidia::apex::UserRenderResource | [pure virtual]
setBoneBufferRange(uint32_t firstBone, uint32_t numBones)=0 | nvidia::apex::UserRenderResource | [pure virtual]
setIndexBufferRange(uint32_t firstIndex, uint32_t numIndices)=0 | nvidia::apex::UserRenderResource | [pure virtual]
setInstanceBufferRange(uint32_t firstInstance, uint32_t numInstances)=0 | nvidia::apex::UserRenderResource | [pure virtual]
setMaterial(void *material)=0 | nvidia::apex::UserRenderResource | [pure virtual]
setSpriteBufferRange(uint32_t firstSprite, uint32_t numSprites)=0 | nvidia::apex::UserRenderResource | [pure virtual]
setSpriteVisibleCount(uint32_t visibleCount) | nvidia::apex::UserRenderResource | [inline, virtual]
setVertexBufferRange(uint32_t firstVertex, uint32_t numVerts)=0 | nvidia::apex::UserRenderResource | [pure virtual]
~UserRenderResource() (defined in nvidia::apex::UserRenderResource) | nvidia::apex::UserRenderResource | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderResourceDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderResourceDesc
Public Member Functions | Public Attributes
nvidia::apex::UserRenderResourceDesc Class Reference

Describes all the data that makes up a renderable resource. More...

#include <UserRenderResourceDesc.h>

List of all members.

Public Member Functions

bool | isValid (void) const
Checks if the resource is valid.

Public Attributes

UserOpaqueMesh * opaqueMesh
A user specified opaque mesh interface.
UserRenderVertexBuffer ** vertexBuffers
there should be no overlap in semantics between any two VBs.
uint32_t | numVertexBuffers
number of vertex buffers used when rendering this resource.
uint32_t | firstVertex
First vertex to render.
uint32_t | numVerts
Number of vertices to render.
UserRenderIndexBuffer * indexBuffer
optional index buffer used when rendering this resource.
uint32_t | firstIndex
First index to render.
uint32_t | numIndices
Number of indices to render.
UserRenderBoneBuffer * boneBuffer
optional bone buffer used for skinned meshes.
uint32_t | firstBone
First bone to render.
uint32_t | numBones
Number of bones to render.
UserRenderInstanceBuffer * instanceBuffer
optional instance buffer if rendering multiple instances of the same resource.
uint32_t | firstInstance
First instance to render.
uint32_t | numInstances
Number of instances to render.
UserRenderSpriteBuffer * spriteBuffer
optional sprite buffer if rendering sprites
uint32_t | firstSprite
First sprite to render.
uint32_t | numSprites
Number of sprites to render.
uint32_t | visibleSpriteCount
If the sprite buffer is using the view direction modifier; this will represent the number of sprites visible in front of the camera (Not necessarily in the frustum but in front of the camera)
UserRenderSurfaceBuffer ** surfaceBuffers
optional surface buffer for transferring variable to texture
uint32_t | numSurfaceBuffers
Number of surface buffers to render.
uint32_t | widthSurfaceBuffers
The surface buffer width.
uint32_t | heightSurfaceBuffers
The surface buffer height.
void * | material
user defined material used when rendering this resource.
uint32_t | submeshIndex
the index of the submesh that render resource belongs to
void * | userRenderData
user defined pointer originally passed in to Renderable::updateRenderResources(..)
RenderCullMode::Enum cullMode
Triangle culling mode.
RenderPrimitiveType::Enum primitives
Rendering primitive type (triangle, line strip, etc)

Detailed Description

Describes all the data that makes up a renderable resource.

Member Data Documentation

UserRenderVertexBuffer** nvidia::apex::UserRenderResourceDesc::vertexBuffers

there should be no overlap in semantics between any two VBs.

vertex buffers used when rendering this resource.

The documentation for this class was generated from the following file:
  • UserRenderResourceDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderResourceDesc
nvidia::apex::UserRenderResourceDesc Member List
This is the complete list of members for nvidia::apex::UserRenderResourceDesc, including all inherited members.
boneBuffer | nvidia::apex::UserRenderResourceDesc |
cullMode | nvidia::apex::UserRenderResourceDesc |
firstBone | nvidia::apex::UserRenderResourceDesc |
firstIndex | nvidia::apex::UserRenderResourceDesc |
firstInstance | nvidia::apex::UserRenderResourceDesc |
firstSprite | nvidia::apex::UserRenderResourceDesc |
firstVertex | nvidia::apex::UserRenderResourceDesc |
heightSurfaceBuffers | nvidia::apex::UserRenderResourceDesc |
indexBuffer | nvidia::apex::UserRenderResourceDesc |
instanceBuffer | nvidia::apex::UserRenderResourceDesc |
isValid(void) const | nvidia::apex::UserRenderResourceDesc | [inline]
material | nvidia::apex::UserRenderResourceDesc |
numBones | nvidia::apex::UserRenderResourceDesc |
numIndices | nvidia::apex::UserRenderResourceDesc |
numInstances | nvidia::apex::UserRenderResourceDesc |
numSprites | nvidia::apex::UserRenderResourceDesc |
numSurfaceBuffers | nvidia::apex::UserRenderResourceDesc |
numVertexBuffers | nvidia::apex::UserRenderResourceDesc |
numVerts | nvidia::apex::UserRenderResourceDesc |
opaqueMesh | nvidia::apex::UserRenderResourceDesc |
primitives | nvidia::apex::UserRenderResourceDesc |
spriteBuffer | nvidia::apex::UserRenderResourceDesc |
submeshIndex | nvidia::apex::UserRenderResourceDesc |
surfaceBuffers | nvidia::apex::UserRenderResourceDesc |
userRenderData | nvidia::apex::UserRenderResourceDesc |
UserRenderResourceDesc(void) (defined in nvidia::apex::UserRenderResourceDesc) | nvidia::apex::UserRenderResourceDesc | [inline]
vertexBuffers | nvidia::apex::UserRenderResourceDesc |
visibleSpriteCount | nvidia::apex::UserRenderResourceDesc |
widthSurfaceBuffers | nvidia::apex::UserRenderResourceDesc |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderResourceManager Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderResourceManager
Public Member Functions
nvidia::apex::UserRenderResourceManager Class Reference

User defined renderable resource manager. More...

#include <UserRenderResourceManager.h>

List of all members.

Public Member Functions

virtual UserRenderVertexBuffer * | createVertexBuffer (const UserRenderVertexBufferDesc &desc)=0
virtual void | releaseVertexBuffer (UserRenderVertexBuffer &buffer)=0
Release vertex buffer.
virtual UserRenderIndexBuffer * | createIndexBuffer (const UserRenderIndexBufferDesc &desc)=0
Create index buffer.
virtual void | releaseIndexBuffer (UserRenderIndexBuffer &buffer)=0
Release index buffer.
virtual UserRenderBoneBuffer * | createBoneBuffer (const UserRenderBoneBufferDesc &desc)=0
Create bone buffer.
virtual void | releaseBoneBuffer (UserRenderBoneBuffer &buffer)=0
Release bone buffer.
virtual UserRenderInstanceBuffer * | createInstanceBuffer (const UserRenderInstanceBufferDesc &desc)=0
Create instance buffer.
virtual void | releaseInstanceBuffer (UserRenderInstanceBuffer &buffer)=0
Release instance buffer.
virtual UserRenderSpriteBuffer * | createSpriteBuffer (const UserRenderSpriteBufferDesc &desc)=0
Create sprite buffer.
virtual void | releaseSpriteBuffer (UserRenderSpriteBuffer &buffer)=0
Release sprite buffer.
virtual UserRenderSurfaceBuffer * | createSurfaceBuffer (const UserRenderSurfaceBufferDesc &desc)=0
Create surface buffer.
virtual void | releaseSurfaceBuffer (UserRenderSurfaceBuffer &buffer)=0
Release surface buffer.
virtual UserRenderResource * | createResource (const UserRenderResourceDesc &desc)=0
Create resource.
virtual void | releaseResource (UserRenderResource &resource)=0
virtual uint32_t | getMaxBonesForMaterial (void *material)=0
virtual bool | getSpriteLayoutData (uint32_t spriteCount, uint32_t spriteSemanticsBitmap, UserRenderSpriteBufferDesc *textureDescArray)=0
Get the sprite layout data Returns true in case textureDescArray is set. In case user is not interested in setting specific layout for sprite PS, this function should return false.
virtual bool | getInstanceLayoutData (uint32_t spriteCount, uint32_t spriteSemanticsBitmap, UserRenderInstanceBufferDesc *instanceDescArray)=0
Get the instance layout data Returns true in case textureDescArray is set. In case user is not interested in setting specific layout for sprite PS, this function should return false.

Detailed Description

User defined renderable resource manager.

A render resource manager is an object that creates and manages renderable resources... This is given to the APEX SDK at creation time via the descriptor and must be persistent through the lifetime of the SDK.

Member Function Documentation

virtual UserRenderVertexBuffer* nvidia::apex::UserRenderResourceManager::createVertexBuffer ( const UserRenderVertexBufferDesc & desc ) [pure virtual]

The create methods in this class will only be called from the context of an Renderable::updateRenderResources() call, but the release methods can be triggered by any APEX API call that deletes an Actor. It is up to the end-user to make the release methods thread safe.

virtual uint32_t nvidia::apex::UserRenderResourceManager::getMaxBonesForMaterial ( void * material ) [pure virtual]

Get the maximum number of bones supported by a given material. Return 0 for infinite. For optimal rendering, do not limit the bone count (return 0 from this function).

virtual void nvidia::apex::UserRenderResourceManager::releaseResource ( UserRenderResource & resource ) [pure virtual]

releaseResource() should not release any of the included buffer pointers. Those free methods will be called separately by the APEX SDK before (or sometimes after) releasing the UserRenderResource.

The documentation for this class was generated from the following file:
  • UserRenderResourceManager.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderResourceManager
nvidia::apex::UserRenderResourceManager Member List
This is the complete list of members for nvidia::apex::UserRenderResourceManager, including all inherited members.
createBoneBuffer(const UserRenderBoneBufferDesc &desc)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
createIndexBuffer(const UserRenderIndexBufferDesc &desc)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
createInstanceBuffer(const UserRenderInstanceBufferDesc &desc)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
createResource(const UserRenderResourceDesc &desc)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
createSpriteBuffer(const UserRenderSpriteBufferDesc &desc)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
createSurfaceBuffer(const UserRenderSurfaceBufferDesc &desc)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
createVertexBuffer(const UserRenderVertexBufferDesc &desc)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
getInstanceLayoutData(uint32_t spriteCount, uint32_t spriteSemanticsBitmap, UserRenderInstanceBufferDesc *instanceDescArray)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
getMaxBonesForMaterial(void *material)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
getSpriteLayoutData(uint32_t spriteCount, uint32_t spriteSemanticsBitmap, UserRenderSpriteBufferDesc *textureDescArray)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
releaseBoneBuffer(UserRenderBoneBuffer &buffer)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
releaseIndexBuffer(UserRenderIndexBuffer &buffer)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
releaseInstanceBuffer(UserRenderInstanceBuffer &buffer)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
releaseResource(UserRenderResource &resource)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
releaseSpriteBuffer(UserRenderSpriteBuffer &buffer)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
releaseSurfaceBuffer(UserRenderSurfaceBuffer &buffer)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
releaseVertexBuffer(UserRenderVertexBuffer &buffer)=0 | nvidia::apex::UserRenderResourceManager | [pure virtual]
~UserRenderResourceManager() (defined in nvidia::apex::UserRenderResourceManager) | nvidia::apex::UserRenderResourceManager | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderSpriteBuffer Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSpriteBuffer
Public Member Functions
nvidia::apex::UserRenderSpriteBuffer Class Reference

Used for storing per-sprite instance data for rendering. More...

#include <UserRenderSpriteBuffer.h>

List of all members.

Public Member Functions

virtual void | writeBuffer (const void *data, uint32_t firstSprite, uint32_t numSprites)
Called when APEX wants to update the contents of the sprite buffer.
virtual bool | getInteropResourceHandle (CUgraphicsResource &handle)
virtual bool | getInteropTextureHandleList (CUgraphicsResource *handleList)
Get interop texture handle list.
virtual void | writeTexture (uint32_t textureId, uint32_t numSprites, const void *srcData, size_t srcSize)
Write data to the texture.

Detailed Description

Used for storing per-sprite instance data for rendering.

Member Function Documentation

virtual bool nvidia::apex::UserRenderSpriteBuffer::getInteropResourceHandle ( CUgraphicsResource & handle ) [inline, virtual]

Get the low-level handle of the buffer resource

Returns:
true if succeeded, false otherwise
virtual void nvidia::apex::UserRenderSpriteBuffer::writeBuffer | ( | const void * | data,
 |  | uint32_t | firstSprite,
 |  | uint32_t | numSprites
 | ) |  | [inline, virtual]

Called when APEX wants to update the contents of the sprite buffer.

The source data type is assumed to be the same as what was defined in the descriptor. APEX should call this function and supply data for ALL semantics that were originally requested during creation every time its called.

Parameters:
[in] | data | Contains the source data for the sprite buffer.
[in] | firstSprite | first sprite to start writing to.
[in] | numSprites | number of vertices to write.
The documentation for this class was generated from the following file:
  • UserRenderSpriteBuffer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSpriteBuffer
nvidia::apex::UserRenderSpriteBuffer Member List
This is the complete list of members for nvidia::apex::UserRenderSpriteBuffer, including all inherited members.
getInteropResourceHandle(CUgraphicsResource &handle) | nvidia::apex::UserRenderSpriteBuffer | [inline, virtual]
getInteropTextureHandleList(CUgraphicsResource *handleList) | nvidia::apex::UserRenderSpriteBuffer | [inline, virtual]
writeBuffer(const void *data, uint32_t firstSprite, uint32_t numSprites) | nvidia::apex::UserRenderSpriteBuffer | [inline, virtual]
writeTexture(uint32_t textureId, uint32_t numSprites, const void *srcData, size_t srcSize) | nvidia::apex::UserRenderSpriteBuffer | [inline, virtual]
~UserRenderSpriteBuffer() (defined in nvidia::apex::UserRenderSpriteBuffer) | nvidia::apex::UserRenderSpriteBuffer | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderSpriteBufferDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSpriteBufferDesc
Public Member Functions | Public Attributes | Static Public Attributes
nvidia::apex::UserRenderSpriteBufferDesc Class Reference

describes the semantics and layout of a sprite buffer More...

#include <UserRenderSpriteBufferDesc.h>

List of all members.

Public Member Functions

void | setDefaults ()
Default values.
bool | isValid (void) const
Checks if data is correct.
bool | isTheSameAs (const UserRenderSpriteBufferDesc &other) const
Check if this object is the same as other.

Public Attributes

uint32_t | maxSprites
The maximum number of sprites that APEX will store in this buffer.
RenderBufferHint::Enum hint
A hint about the update frequency of this buffer.
uint32_t | semanticOffsets [RenderSpriteLayoutElement::NUM_SEMANTICS]
Array of the corresponding offsets (in bytes) for each semantic.
uint32_t | stride
The stride between sprites of this buffer. Required when CUDA interop is used!
bool | registerInCUDA
Declare if the resource must be registered in CUDA upon creation.
PxCudaContextManager * | interopContext
uint32_t | textureCount
the number of textures
UserRenderSpriteTextureDesc textureDescs [MAX_SPRITE_TEXTURES]
an array of texture descriptors

Static Public Attributes

static const uint32_t | MAX_SPRITE_TEXTURES = 4
Max number of sprite textures.

Detailed Description

describes the semantics and layout of a sprite buffer

Member Data Documentation

PxCudaContextManager* nvidia::apex::UserRenderSpriteBufferDesc::interopContext

This context must be used to register and unregister the resource every time the device is lost and recreated.

The documentation for this class was generated from the following file:
  • UserRenderSpriteBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSpriteBufferDesc
nvidia::apex::UserRenderSpriteBufferDesc Member List
This is the complete list of members for nvidia::apex::UserRenderSpriteBufferDesc, including all inherited members.
hint | nvidia::apex::UserRenderSpriteBufferDesc |
interopContext | nvidia::apex::UserRenderSpriteBufferDesc |
isTheSameAs(const UserRenderSpriteBufferDesc &other) const | nvidia::apex::UserRenderSpriteBufferDesc | [inline]
isValid(void) const | nvidia::apex::UserRenderSpriteBufferDesc | [inline]
MAX_SPRITE_TEXTURES | nvidia::apex::UserRenderSpriteBufferDesc | [static]
maxSprites | nvidia::apex::UserRenderSpriteBufferDesc |
registerInCUDA | nvidia::apex::UserRenderSpriteBufferDesc |
semanticOffsets | nvidia::apex::UserRenderSpriteBufferDesc |
setDefaults() | nvidia::apex::UserRenderSpriteBufferDesc | [inline]
stride | nvidia::apex::UserRenderSpriteBufferDesc |
textureCount | nvidia::apex::UserRenderSpriteBufferDesc |
textureDescs | nvidia::apex::UserRenderSpriteBufferDesc |
UserRenderSpriteBufferDesc(void) (defined in nvidia::apex::UserRenderSpriteBufferDesc) | nvidia::apex::UserRenderSpriteBufferDesc | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderSpriteTextureDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSpriteTextureDesc
Public Member Functions | Public Attributes
nvidia::apex::UserRenderSpriteTextureDesc Class Reference

Class for storing sprite texture render data. More...

#include <UserRenderSpriteBufferDesc.h>

List of all members.

Public Member Functions

bool | isTheSameAs (const UserRenderSpriteTextureDesc &other) const
Check if this object is the same as other.

Public Attributes

RenderSpriteTextureLayout::Enum layout
texture layout
uint32_t | width
texture width
uint32_t | height
texture height
uint32_t | pitchBytes
texture pitch bytes
uint32_t | arrayIndex
array index for array textures or cubemap face index
uint32_t | mipLevel
mipmap level

Detailed Description

Class for storing sprite texture render data.

The documentation for this class was generated from the following file:
  • UserRenderSpriteBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSpriteTextureDesc
nvidia::apex::UserRenderSpriteTextureDesc Member List
This is the complete list of members for nvidia::apex::UserRenderSpriteTextureDesc, including all inherited members.
arrayIndex | nvidia::apex::UserRenderSpriteTextureDesc |
height | nvidia::apex::UserRenderSpriteTextureDesc |
isTheSameAs(const UserRenderSpriteTextureDesc &other) const | nvidia::apex::UserRenderSpriteTextureDesc | [inline]
layout | nvidia::apex::UserRenderSpriteTextureDesc |
mipLevel | nvidia::apex::UserRenderSpriteTextureDesc |
pitchBytes | nvidia::apex::UserRenderSpriteTextureDesc |
UserRenderSpriteTextureDesc(void) (defined in nvidia::apex::UserRenderSpriteTextureDesc) | nvidia::apex::UserRenderSpriteTextureDesc | [inline]
width | nvidia::apex::UserRenderSpriteTextureDesc |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderStorage Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderStorage
Public Types | Public Member Functions
nvidia::apex::UserRenderStorage Class Reference

User render storage. More...

#include <UserRenderCallback.h>

Inheritance diagram for nvidia::apex::UserRenderStorage:
nvidia::apex::UserRenderBuffer nvidia::apex::UserRenderSurface

List of all members.

Public Types

enum Type {
BUFFER = 0,
SURFACE
}
Enum of user render storage type.

Public Member Functions

virtual void | release ()=0
Release user render storage.
virtual Type | getType () const =0
Returns type of user render storage.

Detailed Description

User render storage.

The documentation for this class was generated from the following file:
  • UserRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderStorage
nvidia::apex::UserRenderStorage Member List
This is the complete list of members for nvidia::apex::UserRenderStorage, including all inherited members.
BUFFER enum value (defined in nvidia::apex::UserRenderStorage) | nvidia::apex::UserRenderStorage |
getType() const =0 | nvidia::apex::UserRenderStorage | [pure virtual]
release()=0 | nvidia::apex::UserRenderStorage | [pure virtual]
SURFACE enum value (defined in nvidia::apex::UserRenderStorage) | nvidia::apex::UserRenderStorage |
Type enum name | nvidia::apex::UserRenderStorage |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderSurface Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSurface
Classes | Public Member Functions
nvidia::apex::UserRenderSurface Class Reference

User render surface. More...

#include <UserRenderCallback.h>

Inheritance diagram for nvidia::apex::UserRenderSurface:
nvidia::apex::UserRenderStorage

List of all members.

Classes

struct | MappedInfo
Mapped information. More...

Public Member Functions

virtual Type | getType () const
Returns SURFACE type.
virtual bool | map (RenderMapType::Enum mapType, MappedInfo &info)=0
Returns CPU memory pointer to buffer content.
virtual void | unmap ()=0
Flush CPU buffer to GPU.
virtual bool | getCUDAgraphicsResource (CUgraphicsResource &ret)=0
Returns graphics resource for CUDA Interop.

Detailed Description

User render surface.

Member Function Documentation

virtual bool nvidia::apex::UserRenderSurface::getCUDAgraphicsResource ( CUgraphicsResource & ret ) [pure virtual]

Returns graphics resource for CUDA Interop.

Note:
GPU access
virtual bool nvidia::apex::UserRenderSurface::map | ( | RenderMapType::Enum | mapType,
 |  | MappedInfo & | info
 | ) |  | [pure virtual]

Returns CPU memory pointer to buffer content.

Note:
CPU access
The documentation for this class was generated from the following file:
  • UserRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSurface
nvidia::apex::UserRenderSurface Member List
This is the complete list of members for nvidia::apex::UserRenderSurface, including all inherited members.
BUFFER enum value (defined in nvidia::apex::UserRenderStorage) | nvidia::apex::UserRenderStorage |
getCUDAgraphicsResource(CUgraphicsResource &ret)=0 | nvidia::apex::UserRenderSurface | [pure virtual]
getType() const | nvidia::apex::UserRenderSurface | [inline, virtual]
map(RenderMapType::Enum mapType, MappedInfo &info)=0 | nvidia::apex::UserRenderSurface | [pure virtual]
release()=0 | nvidia::apex::UserRenderStorage | [pure virtual]
SURFACE enum value (defined in nvidia::apex::UserRenderStorage) | nvidia::apex::UserRenderStorage |
Type enum name | nvidia::apex::UserRenderStorage |
unmap()=0 | nvidia::apex::UserRenderSurface | [pure virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderSurfaceBuffer Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSurfaceBuffer
Public Member Functions
nvidia::apex::UserRenderSurfaceBuffer Class Reference

Used for storing per-vertex data for rendering. More...

#include <UserRenderSurfaceBuffer.h>

List of all members.

Public Member Functions

virtual void | writeBuffer (const void *srcData, uint32_t srcPitch, uint32_t srcHeight, uint32_t dstX, uint32_t dstY, uint32_t dstZ, uint32_t width, uint32_t height, uint32_t depth)=0
Called when APEX wants to update the contents of the surface buffer.
virtual bool | getInteropResourceHandle (CUgraphicsResource &handle)

Detailed Description

Used for storing per-vertex data for rendering.

Member Function Documentation

virtual bool nvidia::apex::UserRenderSurfaceBuffer::getInteropResourceHandle ( CUgraphicsResource & handle ) [inline, virtual]

Get the low-level handle of the buffer resource

Returns:
true if succeeded, false otherwise
virtual void nvidia::apex::UserRenderSurfaceBuffer::writeBuffer | ( | const void * | srcData,
 |  | uint32_t | srcPitch,
 |  | uint32_t | srcHeight,
 |  | uint32_t | dstX,
 |  | uint32_t | dstY,
 |  | uint32_t | dstZ,
 |  | uint32_t | width,
 |  | uint32_t | height,
 |  | uint32_t | depth
 | ) |  | [pure virtual]

Called when APEX wants to update the contents of the surface buffer.

The source data type is assumed to be the same as what was defined in the descriptor.

Parameters:
[in] | srcData | contains the source data for the surface buffer.
[in] | srcPitch | source data pitch (in bytes).
[in] | srcHeight | source data height.
[in] | dstX | first element to start writing in X-dimension.
[in] | dstY | first element to start writing in Y-dimension.
[in] | dstZ | first element to start writing in Z-dimension.
[in] | width | number of elements in X-dimension.
[in] | height | number of elements in Y-dimension.
[in] | depth | number of elements in Z-dimension.
The documentation for this class was generated from the following file:
  • UserRenderSurfaceBuffer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSurfaceBuffer
nvidia::apex::UserRenderSurfaceBuffer Member List
This is the complete list of members for nvidia::apex::UserRenderSurfaceBuffer, including all inherited members.
getInteropResourceHandle(CUgraphicsResource &handle) | nvidia::apex::UserRenderSurfaceBuffer | [inline, virtual]
writeBuffer(const void *srcData, uint32_t srcPitch, uint32_t srcHeight, uint32_t dstX, uint32_t dstY, uint32_t dstZ, uint32_t width, uint32_t height, uint32_t depth)=0 | nvidia::apex::UserRenderSurfaceBuffer | [pure virtual]
~UserRenderSurfaceBuffer() (defined in nvidia::apex::UserRenderSurfaceBuffer) | nvidia::apex::UserRenderSurfaceBuffer | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderSurfaceBufferDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSurfaceBufferDesc
Public Member Functions | Public Attributes
nvidia::apex::UserRenderSurfaceBufferDesc Class Reference

Describes the semantics and layout of a Surface buffer. More...

#include <UserRenderSurfaceBufferDesc.h>

List of all members.

Public Member Functions

void | setDefaults ()
Default values.
bool | isValid (void) const
Checks if the surface buffer descriptor is valid.

Public Attributes

uint32_t | width
The size of U-dimension.
uint32_t | height
The size of V-dimension.
uint32_t | depth
The size of W-dimension.
RenderDataFormat::Enum format
Data format of suface buffer.
bool | registerInCUDA
Declare if the resource must be registered in CUDA upon creation.
PxCudaContextManager * | interopContext

Detailed Description

Describes the semantics and layout of a Surface buffer.

Member Data Documentation

PxCudaContextManager* nvidia::apex::UserRenderSurfaceBufferDesc::interopContext

This context must be used to register and unregister the resource every time the device is lost and recreated.

The documentation for this class was generated from the following file:
  • UserRenderSurfaceBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSurfaceBufferDesc
nvidia::apex::UserRenderSurfaceBufferDesc Member List
This is the complete list of members for nvidia::apex::UserRenderSurfaceBufferDesc, including all inherited members.
depth | nvidia::apex::UserRenderSurfaceBufferDesc |
format | nvidia::apex::UserRenderSurfaceBufferDesc |
height | nvidia::apex::UserRenderSurfaceBufferDesc |
interopContext | nvidia::apex::UserRenderSurfaceBufferDesc |
isValid(void) const | nvidia::apex::UserRenderSurfaceBufferDesc | [inline]
registerInCUDA | nvidia::apex::UserRenderSurfaceBufferDesc |
setDefaults() | nvidia::apex::UserRenderSurfaceBufferDesc | [inline]
UserRenderSurfaceBufferDesc(void) (defined in nvidia::apex::UserRenderSurfaceBufferDesc) | nvidia::apex::UserRenderSurfaceBufferDesc | [inline]
width | nvidia::apex::UserRenderSurfaceBufferDesc |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderVertexBuffer Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderVertexBuffer
Public Member Functions
nvidia::apex::UserRenderVertexBuffer Class Reference

Used for storing per-vertex data for rendering. More...

#include <UserRenderVertexBuffer.h>

List of all members.

Public Member Functions

virtual bool | getInteropResourceHandle (CUgraphicsResource &handle)
virtual void | writeBuffer (const nvidia::RenderVertexBufferData &data, uint32_t firstVertex, uint32_t numVertices)=0
Called when APEX wants to update the contents of the vertex buffer.

Detailed Description

Used for storing per-vertex data for rendering.

Member Function Documentation

virtual bool nvidia::apex::UserRenderVertexBuffer::getInteropResourceHandle ( CUgraphicsResource & handle ) [inline, virtual]

Get the low-level handle of the buffer resource (D3D resource pointer or GL buffer object ID)

Returns:
true id succeeded, false otherwise
virtual void nvidia::apex::UserRenderVertexBuffer::writeBuffer | ( | const nvidia::RenderVertexBufferData & | data,
 |  | uint32_t | firstVertex,
 |  | uint32_t | numVertices
 | ) |  | [pure virtual]

Called when APEX wants to update the contents of the vertex buffer.

The source data type is assumed to be the same as what was defined in the descriptor. APEX should call this function and supply data for ALL semantics that were originally requested during creation every time its called.

Parameters:
[in] | data | Contains the source data for the vertex buffer.
[in] | firstVertex | first vertex to start writing to.
[in] | numVertices | number of vertices to write.
The documentation for this class was generated from the following file:
  • UserRenderVertexBuffer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderVertexBuffer
nvidia::apex::UserRenderVertexBuffer Member List
This is the complete list of members for nvidia::apex::UserRenderVertexBuffer, including all inherited members.
getInteropResourceHandle(CUgraphicsResource &handle) | nvidia::apex::UserRenderVertexBuffer | [inline, virtual]
writeBuffer(const nvidia::RenderVertexBufferData &data, uint32_t firstVertex, uint32_t numVertices)=0 | nvidia::apex::UserRenderVertexBuffer | [pure virtual]
~UserRenderVertexBuffer() (defined in nvidia::apex::UserRenderVertexBuffer) | nvidia::apex::UserRenderVertexBuffer | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderVertexBufferDesc Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderVertexBufferDesc
Public Member Functions | Public Attributes
nvidia::apex::UserRenderVertexBufferDesc Class Reference

Describes the semantics and layout of a vertex buffer. More...

#include <UserRenderVertexBufferDesc.h>

List of all members.

Public Member Functions

bool | isValid (void) const
Checks if dsta is correct.

Public Attributes

uint32_t | maxVerts
The maximum number of vertices that APEX will store in this buffer.
RenderBufferHint::Enum hint
A hint about the update frequency of this buffer.
RenderDataFormat::Enum | buffersRequest [RenderVertexSemantic::NUM_SEMANTICS]
Array of semantics with the corresponding format.
uint32_t | numCustomBuffers
List of custom semantics that will be provided for this VB.
void ** | customBuffersIdents
Array of custom buffer identifiers.
RenderDataFormat::Enum * customBuffersRequest
Array of custom VB format types.
AuthObjTypeID moduleIdentifier
Identifier of module generating this request.
TextureUVOrigin::Enum uvOrigin
Texture UV direction convention.
bool | canBeShared
Buffer can be shared by multiple render resources.
bool | registerInCUDA
Declare if the resource must be registered in CUDA upon creation.
PxCudaContextManager * | interopContext
The CUDA context.

Detailed Description

Describes the semantics and layout of a vertex buffer.

Member Data Documentation

RenderDataFormat::Enum nvidia::apex::UserRenderVertexBufferDesc::buffersRequest[RenderVertexSemantic::NUM_SEMANTICS]

Array of semantics with the corresponding format.

RenderDataFormat::UNSPECIFIED is used for semantics that are disabled

PxCudaContextManager* nvidia::apex::UserRenderVertexBufferDesc::interopContext

The CUDA context.

This context must be used to register and unregister the resource every time the device is lost and recreated.

uint32_t nvidia::apex::UserRenderVertexBufferDesc::numCustomBuffers

List of custom semantics that will be provided for this VB.

The number of custom VB semantics.

The documentation for this class was generated from the following file:
  • UserRenderVertexBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderVertexBufferDesc
nvidia::apex::UserRenderVertexBufferDesc Member List
This is the complete list of members for nvidia::apex::UserRenderVertexBufferDesc, including all inherited members.
buffersRequest | nvidia::apex::UserRenderVertexBufferDesc |
canBeShared | nvidia::apex::UserRenderVertexBufferDesc |
customBuffersIdents | nvidia::apex::UserRenderVertexBufferDesc |
customBuffersRequest | nvidia::apex::UserRenderVertexBufferDesc |
hint | nvidia::apex::UserRenderVertexBufferDesc |
interopContext | nvidia::apex::UserRenderVertexBufferDesc |
isValid(void) const | nvidia::apex::UserRenderVertexBufferDesc | [inline]
maxVerts | nvidia::apex::UserRenderVertexBufferDesc |
moduleIdentifier | nvidia::apex::UserRenderVertexBufferDesc |
numCustomBuffers | nvidia::apex::UserRenderVertexBufferDesc |
registerInCUDA | nvidia::apex::UserRenderVertexBufferDesc |
UserRenderVertexBufferDesc(void) (defined in nvidia::apex::UserRenderVertexBufferDesc) | nvidia::apex::UserRenderVertexBufferDesc | [inline]
uvOrigin | nvidia::apex::UserRenderVertexBufferDesc |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderer Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderer
Public Member Functions
nvidia::apex::UserRenderer Class Reference

User provided renderer interface. More...

#include <UserRenderer.h>

List of all members.

Public Member Functions

virtual void renderResource (const RenderContext &context)=0
Render a resource.

Detailed Description

User provided renderer interface.

Member Function Documentation

virtual void nvidia::apex::UserRenderer::renderResource ( const RenderContext & context ) [pure virtual]

Render a resource.

Renderable::dispatchRenderResouces() will call this function as many times as possible to render all of the actor's sub-meshes.

The documentation for this class was generated from the following file:
  • UserRenderer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderer
nvidia::apex::UserRenderer Member List
This is the complete list of members for nvidia::apex::UserRenderer, including all inherited members.
renderResource(const RenderContext &context)=0 | nvidia::apex::UserRenderer | [pure virtual]
~UserRenderer() (defined in nvidia::apex::UserRenderer) | nvidia::apex::UserRenderer | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::VelocitySourceActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VelocitySourceActor
Public Member Functions
nvidia::apex::VelocitySourceActor Class Reference

Turbulence VelocitySource Actor class. More...

#include <VelocitySourceActor.h>

Inheritance diagram for nvidia::apex::VelocitySourceActor:
nvidia::apex::Actor nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual VelocitySourceAsset * | getVelocitySourceAsset () const =0
Returns the asset the instance has been created from.
virtual void | setEnabled (bool enable)=0
enable/disable the velocity source
virtual bool | isEnabled () const =0
Returns true if velocity source enabled.
virtual bool | intersectAgainstAABB (PxBounds3)=0
intersect the collision shape against a given AABB
virtual Shape * | getShape () const =0
Returns pointer to Shape of velocity source.
virtual BoxShape * | getBoxShape ()=0
If it is a box, cast to box class, return NULL otherwise.
virtual SphereShape * | getSphereShape ()=0
If it is a sphere, cast to sphere class, return NULL otherwise.
virtual float | getAverageVelocity () const =0
Return average value of velocity.
virtual float | getStdVelocity () const =0
Return STD value of velocity.
virtual PxMat44 | getPose () const =0
get the pose of a velocity source shape
virtual void | setVelocity (float averageVelocity, float stdVelocity)=0
Set average and STD values for velocity.
virtual void | setPose (PxMat44 pose)=0
set the pose of a velocity source shape
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.
virtual void | release ()=0
Release an object instance.

Detailed Description

Turbulence VelocitySource Actor class.

Member Function Documentation

virtual void nvidia::apex::VelocitySourceActor::release ( ) [pure virtual]

Release an object instance.

Calling this will unhook the class and delete it from memory. You should not keep any reference to this class instance after calling release

Implements nvidia::apex::ApexInterface.

The documentation for this class was generated from the following file:
  • VelocitySourceActor.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VelocitySourceActor
nvidia::apex::VelocitySourceActor Member List
This is the complete list of members for nvidia::apex::VelocitySourceActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getAverageVelocity() const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getBoxShape()=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getPose() const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getShape() const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getSphereShape()=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getStdVelocity() const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getVelocitySourceAsset() const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
intersectAgainstAABB(PxBounds3)=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
isEnabled() const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
release()=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
setEnabled(bool enable)=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
setVelocity(float averageVelocity, float stdVelocity)=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~VelocitySourceActor() (defined in nvidia::apex::VelocitySourceActor) | nvidia::apex::VelocitySourceActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::VelocitySourceAsset Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VelocitySourceAsset
nvidia::apex::VelocitySourceAsset Class Reference

Turbulence FieldSampler Asset class. More...

#include <VelocitySourceAsset.h>

Inheritance diagram for nvidia::apex::VelocitySourceAsset:
nvidia::apex::Asset nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

Turbulence FieldSampler Asset class.

The documentation for this class was generated from the following file:
  • VelocitySourceAsset.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VelocitySourceAsset
nvidia::apex::VelocitySourceAsset Member List
This is the complete list of members for nvidia::apex::VelocitySourceAsset, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
createApexActor(const ::NvParameterized::Interface &actorParams, Scene &apexScene)=0 | nvidia::apex::Asset | [pure virtual]
createApexAssetPreview(const ::NvParameterized::Interface &params, AssetPreviewScene *previewScene)=0 | nvidia::apex::Asset | [pure virtual]
forceLoadAssets()=0 | nvidia::apex::Asset | [pure virtual]
getAssetNvParameterized() const =0 | nvidia::apex::Asset | [pure virtual]
getDefaultActorDesc()=0 | nvidia::apex::Asset | [pure virtual]
getDefaultAssetPreviewDesc()=0 | nvidia::apex::Asset | [pure virtual]
getName() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeID() const =0 | nvidia::apex::Asset | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::Asset | [pure virtual]
isDirty() const =0 | nvidia::apex::Asset | [pure virtual]
isValidForActorCreation(const ::NvParameterized::Interface &actorParams, Scene &) const =0 | nvidia::apex::Asset | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::Asset | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Asset() (defined in nvidia::apex::Asset) | nvidia::apex::Asset | [inline, protected, virtual]
~VelocitySourceAsset() (defined in nvidia::apex::VelocitySourceAsset) | nvidia::apex::VelocitySourceAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::VelocitySourceAssetAuthoring Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VelocitySourceAssetAuthoring
nvidia::apex::VelocitySourceAssetAuthoring Class Reference

Turbulence FieldSampler Asset Authoring class. More...

#include <VelocitySourceAsset.h>

Inheritance diagram for nvidia::apex::VelocitySourceAssetAuthoring:
nvidia::apex::AssetAuthoring nvidia::apex::ApexInterface nvidia::apex::RWLockable

List of all members.

Detailed Description

Turbulence FieldSampler Asset Authoring class.

The documentation for this class was generated from the following file:
  • VelocitySourceAsset.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VelocitySourceAssetAuthoring
nvidia::apex::VelocitySourceAssetAuthoring Member List
This is the complete list of members for nvidia::apex::VelocitySourceAssetAuthoring, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
getName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getNvParameterized() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
getObjTypeName() const =0 | nvidia::apex::AssetAuthoring | [pure virtual]
prepareForPlatform(nvidia::apex::PlatformTag)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseAndReturnNvParameterizedInterface(void)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setToolString(const char *toolName, const char *toolVersion, uint32_t toolChangelist)=0 | nvidia::apex::AssetAuthoring | [pure virtual]
userData | nvidia::apex::ApexInterface |
~VelocitySourceAssetAuthoring() (defined in nvidia::apex::VelocitySourceAssetAuthoring) | nvidia::apex::VelocitySourceAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::VelocitySourcePreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VelocitySourcePreview
Public Member Functions
nvidia::apex::VelocitySourcePreview Class Reference

This class provides the asset preview for APEX VelocitySource Assets. More...

#include <VelocitySourcePreview.h>

Inheritance diagram for nvidia::apex::VelocitySourcePreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void | drawVelocitySourcePreview ()=0
Draws the emitter.
virtual void | setScale (float scale)=0
Sets the scaling factor of the renderable.

Detailed Description

This class provides the asset preview for APEX VelocitySource Assets.

The documentation for this class was generated from the following file:
  • VelocitySourcePreview.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VelocitySourcePreview
nvidia::apex::VelocitySourcePreview Member List
This is the complete list of members for nvidia::apex::VelocitySourcePreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
drawVelocitySourcePreview()=0 | nvidia::apex::VelocitySourcePreview | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
setScale(float scale)=0 | nvidia::apex::VelocitySourcePreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
VelocitySourcePreview() (defined in nvidia::apex::VelocitySourcePreview) | nvidia::apex::VelocitySourcePreview | [inline, protected]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::VertexBuffer Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VertexBuffer
Public Member Functions
nvidia::apex::VertexBuffer Class Reference

a vertex buffer that supports multiple formats More...

#include <RenderMesh.h>

List of all members.

Public Member Functions

virtual uint32_t | getVertexCount () const =0
Returns the number of vertices in the buffer.
virtual const VertexFormat & | getFormat () const =0
Returns the data format. See VertexFormat.
virtual VertexFormat & | getFormatWritable ()=0
Returns the data format. See VertexFormat. Can be changed.
virtual const void * | getBuffer (uint32_t bufferIndex) const =0
Accessor for the data buffer indexed by bufferIndex. To get the buffer format, use getFormat().getBufferFormat( index ). If the data channel doesn't exist then this function returns NULL.
virtual const void * | getBufferAndFormat (RenderDataFormat::Enum &format, uint32_t bufferIndex) const =0
Like getBuffer(), but also returns the buffer's format.
virtual void * | getBufferAndFormatWritable (RenderDataFormat::Enum &format, uint32_t bufferIndex)=0
Like getBuffer(), but also returns the buffer's format. Can be changed.
virtual bool | getBufferData (void *dstBuffer, nvidia::RenderDataFormat::Enum dstBufferFormat, uint32_t dstBufferStride, uint32_t bufferIndex, uint32_t startVertexIndex, uint32_t elementCount) const =0
Accessor for data in a desired format from the buffer indexed by bufferIndex. If the channel does not exist, or if it is in a format for which there is not presently a converter to the the desired format dstBufferFormat, this function returns false. The dstBufferStride field must be at least the size of the dstBufferFormat data, or zero (in which case the stride is assumed to be the size of the dstBufferFormat data). If neither of these conditions hold, this function returns false. Otherwise, dstBuffer is filled in with elementCount elements of the converted data, starting from startVertexIndex, withe the given stride.

Detailed Description

a vertex buffer that supports multiple formats

The documentation for this class was generated from the following file:
  • RenderMesh.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VertexBuffer
nvidia::apex::VertexBuffer Member List
This is the complete list of members for nvidia::apex::VertexBuffer, including all inherited members.
getBuffer(uint32_t bufferIndex) const =0 | nvidia::apex::VertexBuffer | [pure virtual]
getBufferAndFormat(RenderDataFormat::Enum &format, uint32_t bufferIndex) const =0 | nvidia::apex::VertexBuffer | [pure virtual]
getBufferAndFormatWritable(RenderDataFormat::Enum &format, uint32_t bufferIndex)=0 | nvidia::apex::VertexBuffer | [pure virtual]
getBufferData(void *dstBuffer, nvidia::RenderDataFormat::Enum dstBufferFormat, uint32_t dstBufferStride, uint32_t bufferIndex, uint32_t startVertexIndex, uint32_t elementCount) const =0 | nvidia::apex::VertexBuffer | [pure virtual]
getFormat() const =0 | nvidia::apex::VertexBuffer | [pure virtual]
getFormatWritable()=0 | nvidia::apex::VertexBuffer | [pure virtual]
getVertexCount() const =0 | nvidia::apex::VertexBuffer | [pure virtual]
VertexBuffer() (defined in nvidia::apex::VertexBuffer) | nvidia::apex::VertexBuffer | [inline, protected]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::VertexFormat Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VertexFormat
Public Types | Public Member Functions
nvidia::apex::VertexFormat Class Reference

Describes the format of an VertexBuffer. More...

#include <VertexFormat.h>

List of all members.

Public Types

enum {
MAX_UV_COUNT = 4,
MAX_BONE_PER_VERTEX_COUNT = 4
}
typedef uint32_t | BufferID
Buffer ID.

Public Member Functions

virtual void | reset ()=0
Resets the format to the initial state.
virtual void | setWinding (RenderCullMode::Enum winding)=0
Sets the winding (cull mode) for this format.
virtual void | setHasSeparateBoneBuffer (bool hasSeparateBoneBuffer)=0
Sets whether or not a separate bone buffer is used.
virtual RenderCullMode::Enum | getWinding () const =0
Accessor to read winding (cull mode)
virtual bool | hasSeparateBoneBuffer () const =0
Accessor to read if a seperate vertex buffer for bone indices and weights is generated.
virtual const char * | getSemanticName (RenderVertexSemantic::Enum semantic) const =0
Returns a buffer name for a semantic. Returns NULL if the semantic is invalid.
virtual BufferID | getSemanticID (RenderVertexSemantic::Enum semantic) const =0
Returns a buffer ID for a semantic. For custom buffers, use the getID() function.
virtual BufferID | getID (const char *name) const =0
Returns a buffer ID for a named buffer. For standard semantics, the getSemanticID( semantic ) function is faster, but is equivalent to getID( getSemanticName( semantic ) ). Returns 0 if name == NULL.
virtual int32_t | addBuffer (const char *name)=0
Adds a vertex buffer channel to this format.
virtual bool | bufferReplaceWithLast (uint32_t index)=0
Removes a buffer.
virtual bool | setBufferFormat (uint32_t index, RenderDataFormat::Enum format)=0
Set the format for a semantic.
virtual bool | setBufferAccess (uint32_t index, RenderDataAccess::Enum access)=0
Set the access type for a buffer (static, dynamic, etc.)
virtual bool | setBufferSerialize (uint32_t index, bool serialize)=0
Set whether or not the buffer should be serialized.
virtual const char * | getBufferName (uint32_t index) const =0
Accessor to read the name of a given buffer.
virtual RenderVertexSemantic::Enum | getBufferSemantic (uint32_t index) const =0
Accessor to read the semantic of a given buffer.
virtual BufferID | getBufferID (uint32_t index) const =0
Accessor to read the ID of a given buffer.
virtual RenderDataFormat::Enum | getBufferFormat (uint32_t index) const =0
Get the format for a buffer.
virtual RenderDataAccess::Enum | getBufferAccess (uint32_t index) const =0
Get the access type for a buffer (static, dynamic, etc.)
virtual bool | getBufferSerialize (uint32_t index) const =0
Get whether or not the buffer should be serialized.
virtual uint32_t | getBufferCount () const =0
Accessor to read the number of buffers.
virtual uint32_t | getCustomBufferCount () const =0
Returns the number of buffers that are user-specified.
virtual int32_t | getBufferIndexFromID (BufferID id) const =0
Accessor to get the buffer index If the buffer is not found, -1 is returned.

Detailed Description

Describes the format of an VertexBuffer.

Member Function Documentation

virtual int32_t nvidia::apex::VertexFormat::addBuffer ( const char * name ) [pure virtual]

Adds a vertex buffer channel to this format.

Parameters:
[in] name the name of a new buffer (use getSemanticName for standard semantics)
Returns:
The buffer index. If the buffer for the semantic already exists, the index of the existing buffer is returned. Returns -1 if there is an error (e.g. name == NULL).
virtual bool nvidia::apex::VertexFormat::bufferReplaceWithLast ( uint32_t index ) [pure virtual]

Removes a buffer.

Parameters:
[in] index the buffer to remove
Returns:
True if successful, false otherwise (if the buffer index was invalid)
virtual RenderDataAccess::Enum nvidia::apex::VertexFormat::getBufferAccess ( uint32_t index ) const [pure virtual]

Get the access type for a buffer (static, dynamic, etc.)

Returns:
The buffer access if successful, RenderDataAccess::ACCESS_TYPE_COUNT otherwise.
virtual RenderDataFormat::Enum nvidia::apex::VertexFormat::getBufferFormat ( uint32_t index ) const [pure virtual]

Get the format for a buffer.

Returns:
The buffer format if successful, RenderDataFormat::UNSPECIFIED otherwise.
virtual BufferID nvidia::apex::VertexFormat::getBufferID ( uint32_t index ) const [pure virtual]

Accessor to read the ID of a given buffer.

Returns:
The buffer semantic if successful, 0 otherwise.
virtual const char* nvidia::apex::VertexFormat::getBufferName ( uint32_t index ) const [pure virtual]

Accessor to read the name of a given buffer.

Returns:
The buffer name if successful, NULL otherwise.
virtual RenderVertexSemantic::Enum nvidia::apex::VertexFormat::getBufferSemantic ( uint32_t index ) const [pure virtual]

Accessor to read the semantic of a given buffer.

Returns:
The buffer semantic if successful, RenderVertexSemantic::NUM_SEMANTICS otherwise.
virtual bool nvidia::apex::VertexFormat::getBufferSerialize ( uint32_t index ) const [pure virtual]

Get whether or not the buffer should be serialized.

Returns:
Whether or not the buffer should be serialized if successful, false otherwise.
virtual bool nvidia::apex::VertexFormat::setBufferAccess | ( | uint32_t | index,
 |  | RenderDataAccess::Enum | access
 | ) |  | [pure virtual]

Set the access type for a buffer (static, dynamic, etc.)

Returns:
True if successful, false otherwise (if the buffer index was invalid)
virtual bool nvidia::apex::VertexFormat::setBufferFormat | ( | uint32_t | index,
 |  | RenderDataFormat::Enum | format
 | ) |  | [pure virtual]

Set the format for a semantic.

Returns:
True if successful, false otherwise (if the buffer index was invalid)
virtual bool nvidia::apex::VertexFormat::setBufferSerialize | ( | uint32_t | index,
 |  | bool | serialize
 | ) |  | [pure virtual]

Set whether or not the buffer should be serialized.

Returns:
True if successful, false otherwise (if the buffer index was invalid)
The documentation for this class was generated from the following file:
  • VertexFormat.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VertexFormat
nvidia::apex::VertexFormat Member List
This is the complete list of members for nvidia::apex::VertexFormat, including all inherited members.
addBuffer(const char *name)=0 | nvidia::apex::VertexFormat | [pure virtual]
BufferID typedef | nvidia::apex::VertexFormat |
bufferReplaceWithLast(uint32_t index)=0 | nvidia::apex::VertexFormat | [pure virtual]
getBufferAccess(uint32_t index) const =0 | nvidia::apex::VertexFormat | [pure virtual]
getBufferCount() const =0 | nvidia::apex::VertexFormat | [pure virtual]
getBufferFormat(uint32_t index) const =0 | nvidia::apex::VertexFormat | [pure virtual]
getBufferID(uint32_t index) const =0 | nvidia::apex::VertexFormat | [pure virtual]
getBufferIndexFromID(BufferID id) const =0 | nvidia::apex::VertexFormat | [pure virtual]
getBufferName(uint32_t index) const =0 | nvidia::apex::VertexFormat | [pure virtual]
getBufferSemantic(uint32_t index) const =0 | nvidia::apex::VertexFormat | [pure virtual]
getBufferSerialize(uint32_t index) const =0 | nvidia::apex::VertexFormat | [pure virtual]
getCustomBufferCount() const =0 | nvidia::apex::VertexFormat | [pure virtual]
getID(const char *name) const =0 | nvidia::apex::VertexFormat | [pure virtual]
getSemanticID(RenderVertexSemantic::Enum semantic) const =0 | nvidia::apex::VertexFormat | [pure virtual]
getSemanticName(RenderVertexSemantic::Enum semantic) const =0 | nvidia::apex::VertexFormat | [pure virtual]
getWinding() const =0 | nvidia::apex::VertexFormat | [pure virtual]
hasSeparateBoneBuffer() const =0 | nvidia::apex::VertexFormat | [pure virtual]
MAX_BONE_PER_VERTEX_COUNT enum value (defined in nvidia::apex::VertexFormat) | nvidia::apex::VertexFormat |
MAX_UV_COUNT enum value (defined in nvidia::apex::VertexFormat) | nvidia::apex::VertexFormat |
reset()=0 | nvidia::apex::VertexFormat | [pure virtual]
setBufferAccess(uint32_t index, RenderDataAccess::Enum access)=0 | nvidia::apex::VertexFormat | [pure virtual]
setBufferFormat(uint32_t index, RenderDataFormat::Enum format)=0 | nvidia::apex::VertexFormat | [pure virtual]
setBufferSerialize(uint32_t index, bool serialize)=0 | nvidia::apex::VertexFormat | [pure virtual]
setHasSeparateBoneBuffer(bool hasSeparateBoneBuffer)=0 | nvidia::apex::VertexFormat | [pure virtual]
setWinding(RenderCullMode::Enum winding)=0 | nvidia::apex::VertexFormat | [pure virtual]
VertexFormat() (defined in nvidia::apex::VertexFormat) | nvidia::apex::VertexFormat | [inline, protected]
~VertexFormat() (defined in nvidia::apex::VertexFormat) | nvidia::apex::VertexFormat | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::ViewDirectionSortingModifier Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ViewDirectionSortingModifier
Static Public Attributes
nvidia::apex::ViewDirectionSortingModifier Class Reference

ViewDirectionSortingModifier sorts sprite particles along view direction back to front. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ViewDirectionSortingModifier:
nvidia::apex::ModifierT< ViewDirectionSortingModifier > nvidia::apex::Modifier

List of all members.

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ViewDirectionSorting
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ViewDirectionSortingModifier sorts sprite particles along view direction back to front.

Member Data Documentation

const uint32_t nvidia::apex::ViewDirectionSortingModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ViewDirectionSortingModifier
nvidia::apex::ViewDirectionSortingModifier Member List
This is the complete list of members for nvidia::apex::ViewDirectionSortingModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ViewDirectionSortingModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ViewDirectionSortingModifier > | [inline, virtual]
ModifierType | nvidia::apex::ViewDirectionSortingModifier | [static]
ModifierUsage | nvidia::apex::ViewDirectionSortingModifier | [static]
~Modifier() (defined in nvidia::apex::Modifier) | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::VortexFSActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VortexFSActor
Public Member Functions
nvidia::apex::VortexFSActor Class Reference

VortexFS Actor class. More...

#include <VortexFSActor.h>

Inheritance diagram for nvidia::apex::VortexFSActor:
nvidia::apex::Actor nvidia::apex::Renderable nvidia::apex::ApexInterface nvidia::apex::RenderDataProvider nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual BasicFSAsset * | getVortexFSAsset () const =0
Returns the asset the instance has been created from.
virtual PxMat44 | getCurrentPose () const =0
Gets the current pose of the actor.
virtual void | setCurrentPose (const PxTransform &pose)=0
Sets the current pose of the actor.
virtual PxVec3 | getCurrentPosition () const =0
Gets the current position of the actor.
virtual void | setCurrentPosition (const PxVec3 &pos)=0
Sets the current position of the actor.
virtual void | setAxis (const PxVec3 &)=0
Sets the axis of the capsule in local coordinate system.
virtual void | setHeight (float)=0
Sets the height of the capsule.
virtual void | setBottomRadius (float)=0
Sets the bottom radius of the capsule.
virtual void | setTopRadius (float)=0
Sets the top radius of the capsule.
virtual void | setBottomSphericalForce (bool)=0
Sets the bottom spherical force of the capsule.
virtual void | setTopSphericalForce (bool)=0
Sets the top spherical force of the capsule.
virtual void | setRotationalStrength (float)=0
Sets strength of the rotational part of vortex field.
virtual void | setRadialStrength (float)=0
Sets strength of the radial part of vortex field.
virtual void | setLiftStrength (float)=0
Sets strength of the lifting part of vortex field.
virtual void | setEnabled (bool isEnabled)=0
Enable/Disable the field simulation.
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.

Detailed Description

VortexFS Actor class.

The documentation for this class was generated from the following file:
  • VortexFSActor.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VortexFSActor
nvidia::apex::VortexFSActor Member List
This is the complete list of members for nvidia::apex::VortexFSActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getCurrentPose() const =0 | nvidia::apex::VortexFSActor | [pure virtual]
getCurrentPosition() const =0 | nvidia::apex::VortexFSActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::VortexFSActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getVortexFSAsset() const =0 | nvidia::apex::VortexFSActor | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setAxis(const PxVec3 &)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setBottomRadius(float)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setBottomSphericalForce(bool)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setCurrentPose(const PxTransform &pose)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setCurrentPosition(const PxVec3 &pos)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setEnabled(bool isEnabled)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setHeight(float)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setLiftStrength(float)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setRadialStrength(float)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setRotationalStrength(float)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setTopRadius(float)=0 | nvidia::apex::VortexFSActor | [pure virtual]
setTopSphericalForce(bool)=0 | nvidia::apex::VortexFSActor | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~VortexFSActor() (defined in nvidia::apex::VortexFSActor) | nvidia::apex::VortexFSActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::VortexFSPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VortexFSPreview
Public Member Functions
nvidia::apex::VortexFSPreview Class Reference

This class provides the asset preview for APEX VortexFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

#include <VortexFSPreview.h>

Inheritance diagram for nvidia::apex::VortexFSPreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void | setRadius (float radius)=0
Set the radius of the vortex.
virtual void | setDetailLevel (uint32_t detail)=0

Detailed Description

This class provides the asset preview for APEX VortexFS Assets. The class provides multiple levels of prevew detail that can be selected individually.

Member Function Documentation

virtual void nvidia::apex::VortexFSPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable.
Any, all, or none of the following masks may be added together to select what should be drawn.
The defines for the individual items are:
VORTEX_DRAW_NOTHING - draw nothing
VORTEX_DRAW_SHAPE - draw the shape
VORTEX_DRAW_ASSET_INFO - draw the turbulencefs asset info in the screen space
VORTEX_DRAW_FULL_DETAIL - draw all components of the turbulencefs preview
All items may be drawn using the macro DRAW_FULL_DETAIL.

The documentation for this class was generated from the following file:
  • VortexFSPreview.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VortexFSPreview
nvidia::apex::VortexFSPreview Member List
This is the complete list of members for nvidia::apex::VortexFSPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setDetailLevel(uint32_t detail)=0 | nvidia::apex::VortexFSPreview | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
setRadius(float radius)=0 | nvidia::apex::VortexFSPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::WindFSActor Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • WindFSActor
Public Member Functions
nvidia::apex::WindFSActor Class Reference

WindFS Actor class. More...

#include <WindFSActor.h>

Inheritance diagram for nvidia::apex::WindFSActor:
nvidia::apex::Actor nvidia::apex::Renderable nvidia::apex::ApexInterface nvidia::apex::RenderDataProvider nvidia::apex::RWLockable

List of all members.

Public Member Functions

virtual BasicFSAsset * | getWindFSAsset () const =0
Returns the asset the instance has been created from.
virtual PxMat44 | getCurrentPose () const =0
Gets the current pose of the actor.
virtual void | setCurrentPose (const PxTransform &pose)=0
Sets the current pose of the actor.
virtual PxVec3 | getCurrentPosition () const =0
Gets the current position of the actor.
virtual void | setCurrentPosition (const PxVec3 &pos)=0
Sets the current position of the actor.
virtual void | setFieldStrength (float)=0
Sets the field strength.
virtual void | setFieldDirection (const PxVec3 &)=0
Sets the field direction.
virtual void | setEnabled (bool isEnabled)=0
Enable/Disable the field simulation.
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.

Detailed Description

WindFS Actor class.

The documentation for this class was generated from the following file:
  • WindFSActor.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • WindFSActor
nvidia::apex::WindFSActor Member List
This is the complete list of members for nvidia::apex::WindFSActor, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
cacheModuleData() const | nvidia::apex::Actor | [inline, virtual]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
forceLod(float lod)=0 | nvidia::apex::Actor | [pure virtual]
getActiveLod() const =0 | nvidia::apex::Actor | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getCurrentPose() const =0 | nvidia::apex::WindFSActor | [pure virtual]
getCurrentPosition() const =0 | nvidia::apex::WindFSActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::WindFSActor | [pure virtual]
getLodRange(float &min, float &max, bool &intOnly) const =0 | nvidia::apex::Actor | [pure virtual]
getOwner() const =0 | nvidia::apex::Actor | [pure virtual]
getWindFSAsset() const =0 | nvidia::apex::WindFSActor | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setCurrentPose(const PxTransform &pose)=0 | nvidia::apex::WindFSActor | [pure virtual]
setCurrentPosition(const PxVec3 &pos)=0 | nvidia::apex::WindFSActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::WindFSActor | [pure virtual]
setEnabled(bool isEnabled)=0 | nvidia::apex::WindFSActor | [pure virtual]
setEnableDebugVisualization(bool state)=0 | nvidia::apex::Actor | [pure virtual]
setFieldDirection(const PxVec3 &)=0 | nvidia::apex::WindFSActor | [pure virtual]
setFieldStrength(float)=0 | nvidia::apex::WindFSActor | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
~Actor() (defined in nvidia::apex::Actor) | nvidia::apex::Actor | [inline, protected, virtual]
~WindFSActor() (defined in nvidia::apex::WindFSActor) | nvidia::apex::WindFSActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::WindFSPreview Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • WindFSPreview
Public Member Functions
nvidia::apex::WindFSPreview Class Reference

This class provides the asset preview for APEX WindFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

#include <WindFSPreview.h>

Inheritance diagram for nvidia::apex::WindFSPreview:
nvidia::apex::AssetPreview nvidia::apex::ApexInterface nvidia::apex::Renderable nvidia::apex::RWLockable nvidia::apex::RenderDataProvider

List of all members.

Public Member Functions

virtual void setDetailLevel (uint32_t detail)=0

Detailed Description

This class provides the asset preview for APEX WindFS Assets. The class provides multiple levels of prevew detail that can be selected individually.

Member Function Documentation

virtual void nvidia::apex::WindFSPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable.
Any, all, or none of the following masks may be added together to select what should be drawn.
The defines for the individual items are:
WIND_DRAW_NOTHING - draw nothing
WIND_DRAW_ASSET_INFO - draw the asset info in the screen space
WIND_DRAW_FULL_DETAIL - draw all components of the asset preview
All items may be drawn using the macro DRAW_FULL_DETAIL.

The documentation for this class was generated from the following file:
  • WindFSPreview.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • WindFSPreview
nvidia::apex::WindFSPreview Member List
This is the complete list of members for nvidia::apex::WindFSPreview, including all inherited members.
acquireReadLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
acquireWriteLock(const char *fileName, const uint32_t lineno) const =0 | nvidia::apex::RWLockable | [pure virtual]
ApexInterface() (defined in nvidia::apex::ApexInterface) | nvidia::apex::ApexInterface | [inline]
AssetPreview() (defined in nvidia::apex::AssetPreview) | nvidia::apex::AssetPreview | [inline, protected]
dispatchRenderResources(UserRenderer &renderer)=0 | nvidia::apex::Renderable | [pure virtual]
getBounds() const =0 | nvidia::apex::Renderable | [pure virtual]
getPose() const =0 | nvidia::apex::AssetPreview | [pure virtual]
lockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
release()=0 | nvidia::apex::ApexInterface | [pure virtual]
releaseReadLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
releaseWriteLock(void) const =0 | nvidia::apex::RWLockable | [pure virtual]
setDetailLevel(uint32_t detail)=0 | nvidia::apex::WindFSPreview | [pure virtual]
setPose(const PxMat44 &pose)=0 | nvidia::apex::AssetPreview | [pure virtual]
unlockRenderResources()=0 | nvidia::apex::RenderDataProvider | [pure virtual]
updateRenderResources(bool rewriteBuffers=false, void *userRenderData=0)=0 | nvidia::apex::RenderDataProvider | [pure virtual]
userData | nvidia::apex::ApexInterface |
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::WriteLock Class Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • WriteLock
Public Member Functions
nvidia::apex::WriteLock Class Reference

RAII wrapper for the Scene write lock. More...

#include <Lock.h>

List of all members.

Public Member Functions

WriteLock (const ApexInterface &lockable, const char *file=NULL, uint32_t line=0)
Constructor.

Detailed Description

RAII wrapper for the Scene write lock.

Use this class as follows to lock the scene for writing by the current thread for the duration of the enclosing scope:

WriteLock lock(sceneRef);

See also:
Scene::apexacquireWriteLock(), Scene::apexUnacquireWriteLock(), SceneDesc::useRWLock

Constructor & Destructor Documentation

nvidia::apex::WriteLock::WriteLock | ( | const ApexInterface & | lockable,
 |  | const char * | file = NULL,
 |  | uint32_t | line = 0
 | ) |  | [inline]

Constructor.

Parameters:
lockable | The object to lock for writing
file | Optional string for debugging purposes
line | Optional line number for debugging purposes
The documentation for this class was generated from the following file:
  • Lock.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • WriteLock
nvidia::apex::WriteLock Member List
This is the complete list of members for nvidia::apex::WriteLock, including all inherited members.
WriteLock(const ApexInterface &lockable, const char *file=NULL, uint32_t line=0) | nvidia::apex::WriteLock | [inline]
~WriteLock() (defined in nvidia::apex::WriteLock) | nvidia::apex::WriteLock | [inline]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Deprecated List

  • Related Pages
  • Namespaces
  • Classes
  • Files
Deprecated List

Member nvidia::apex::ApexSDK::getOutputStream ()=0
Use getErrorCallback() instead.

Member nvidia::apex::ClothingActor::getMaxDistanceBlendTime () const =0
Use ClothingActor::getActorDesc() and read the maxDistanceBlendTime part of it

Member nvidia::apex::ClothingActor::setMaxDistanceBlendTime (float blendTime)=0
Use ClothingActor::getActorDesc() and modify the maxDistanceBlendTime part of it Default: 1.0

Member nvidia::apex::ClothingActor::setWind (float windAdaption, const PxVec3 &windVelocity)=0
Use ClothingActor::getActorDesc() and modify the wind part of it

Member nvidia::apex::ClothingAssetAuthoring::setExportScale (float scale)=0
Only works with deprecated serialization, use applyTransformation instead!
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: File List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
File List
Here is a list of all documented files with brief descriptions:
Actor.h [code] | Classes ApexActor, ApexActorSource
Apex.h [code] | The top level include file for all of the APEX API
ApexCudaContextManager.h [code] | The file contains API for PxCudaConextManager public functions
ApexDefs.h [code] | Version identifiers and other macro definitions
ApexDesc.h [code] | Class ApexDesc
ApexInterface.h [code] | Class ApexInterface
ApexNameSpace.h [code] | Defines APEX namespace strings
ApexSDK.h [code] | APEX SDK classes
ApexSDKCachedData.h [code] | Classes ModuleCachedData, ApexSDKCachedData
ApexSDKVersionString.h [code] | APEX SDK versioning definitions
ApexUsingNamespace.h [code] |
Asset.h [code] | Class Asset
AssetPreview.h [code] | Class AssetPreview
AssetPreviewScene.h [code] | Classes Scene, SceneStats, SceneDesc
AttractorFSActor.h [code] |
AttractorFSPreview.h [code] |
BasicFSAsset.h [code] |
BasicIosActor.h [code] |
BasicIosAsset.h [code] |
ClothingActor.h [code] |
ClothingAsset.h [code] |
ClothingAssetAuthoring.h [code] |
ClothingCollision.h [code] | Classes ClothingCollision, ClothingPlane, ClothingConvex, ClothingSphere, ClothingCapsule, ClothingTriangleMesh
ClothingPhysicalMesh.h [code] |
ClothingPreview.h [code] |
ClothingRenderProxy.h [code] |
ClothingVelocityCallback.h [code] |
Context.h [code] | Class Context
ConvexHullMethod.h [code] | Misc utility classes
CudaTestManager.h [code] | Classes CudaTestManager
Curve.h [code] |
CustomBufferIterator.h [code] | Class CustomBufferIterator
DestructibleActor.h [code] |
DestructibleActorJoint.h [code] |
DestructibleAsset.h [code] |
DestructiblePreview.h [code] |
DestructibleRenderable.h [code] |
EffectPackageActor.h [code] | An EffectPackageActor represents an instantiation of a collection of related particle actors The EffectPackage system allows for multiple related particle actors to be instantiated as a single unit with a single root pose transform. This can be one or more emitters as well as associated field samplers, heat sources, etc. This single instantiation can be subject to level of detail culling and otherwise manipulated as a single unit
EffectPackageAsset.h [code] |
EmitterActor.h [code] |
EmitterAsset.h [code] |
EmitterGeoms.h [code] |
EmitterLodParamDesc.h [code] |
EmitterPreview.h [code] |
ExplicitHierarchicalMesh.h [code] |
FlameEmitterActor.h [code] |
FlameEmitterAsset.h [code] |
FlameEmitterPreview.h [code] |
ForceFieldActor.h [code] |
ForceFieldAsset.h [code] |
ForceFieldPreview.h [code] |
FractureToolsAPI.h [code] |
FractureToolsStructs.h [code] |
GroundEmitterActor.h [code] |
GroundEmitterAsset.h [code] |
GroundEmitterPreview.h [code] |
HeatSourceActor.h [code] |
HeatSourceAsset.h [code] |
HeatSourcePreview.h [code] |
ImpactEmitterActor.h [code] |
ImpactEmitterAsset.h [code] |
ImpactEmitterPreview.h [code] |
IofxActor.h [code] |
IofxAsset.h [code] |
IofxRenderable.h [code] |
IofxRenderCallback.h [code] |
IosAsset.h [code] | Class IosAsset
IProgressListener.h [code] | Class IProgressListener
JetFSActor.h [code] |
JetFSPreview.h [code] |
Lock.h [code] | Classes PxSceneReadLock, PxSceneWriteLock
MirrorScene.h [code] | Classes MirrorScene, MirrorScene::MirrorFilter
Modifier.h [code] |
ModifierDefs.h [code] |
Module.h [code] | APEX Module API
ModuleBasicFS.h [code] |
ModuleBasicIos.h [code] |
ModuleClothing.h [code] |
ModuleDestructible.h [code] |
ModuleEmitter.h [code] |
ModuleFieldSampler.h [code] |
ModuleForceField.h [code] |
ModuleIofx.h [code] |
ModuleIofxLegacy.h [code] |
ModuleLegacy.h [code] |
ModuleLoader.h [code] |
ModuleParticleIos.h [code] |
ModuleParticles.h [code] |
ModuleTurbulenceFS.h [code] |
NoiseFSActor.h [code] |
NoiseFSPreview.h [code] |
NvParameterized.h [code] | NvParameterized classes
NvParameterized_types.h [code] |
NvParameterizedMacroses.h [code] |
NvParameterizedTraits.h [code] | NvParameterized traits class
NvParamUtils.h [code] |
NvSerializer.h [code] | NvParameterized serializer class
ParticleIosActor.h [code] |
ParticleIosAsset.h [code] |
ParticlesPreview.h [code] |
PhysXObjectDesc.h [code] | Class PhysXObjectDesc
PhysX0/PhysXSDKVersion.h [code] | Version identifiers for PhysX less configuration
PhysX3/PhysXSDKVersion.h [code] | Version identifiers for PhysX major release 3
PxStreamFromFileBuf.h [code] | Conversion utilities between PhysX 2.8 and 3.0 data types
Renderable.h [code] | Class Renderable
RenderBufferData.h [code] | Classes RenderSemanticData, RenderBufferData, ModuleSpecificRenderBufferData
RenderContext.h [code] | Class RenderContext
RenderDataFormat.h [code] |
RenderDataProvider.h [code] | Class RenderDataProvider
RenderDebugInterface.h [code] | Debug rendering classes and structures
RenderMesh.h [code] | Classes RenderSubmesh, VertexBuffer, and MaterialNamingConvention enums
RenderMeshActor.h [code] | Class RenderMeshActor
RenderMeshActorDesc.h [code] | Class RenderMeshActorDesc
RenderMeshAsset.h [code] | APEX RenderMesh Asset
RenderVolume.h [code] |
ResourceCallback.h [code] | Class ResourceCallback
ResourceProvider.h [code] | Class ResourceProvider
RWLockable.h [code] | The include containing the interface for any rw-lockable object in the APEX SDK
Scene.h [code] | Classes Scene, SceneStats, SceneDesc
ScopedPhysXLock.h [code] |
Shape.h [code] | Class Shape
SubstanceSourceActor.h [code] |
SubstanceSourceAsset.h [code] |
TestBase.h [code] | An TestBase is an interface for managing unit tests
TurbulenceFSActor.h [code] |
TurbulenceFSAsset.h [code] |
TurbulenceFSPreview.h [code] |
TurbulenceRenderable.h [code] |
TurbulenceRenderCallback.h [code] |
UserOpaqueMesh.h [code] | Class UserOpaqueMesh
UserRenderBoneBuffer.h [code] | Class UserRenderBoneBuffer
UserRenderBoneBufferDesc.h [code] | Class UserRenderBoneBufferDesc, structs RenderDataFormat and RenderBoneSemantic
UserRenderCallback.h [code] |
UserRenderer.h [code] | Class UserRenderer
UserRenderIndexBuffer.h [code] | Class UserRenderIndexBuffer
UserRenderIndexBufferDesc.h [code] | Class UserRenderIndexBufferDesc, structs RenderDataFormat and UserRenderIndexBufferDesc
UserRenderInstanceBuffer.h [code] | Class UserRenderInstanceBuffer
UserRenderInstanceBufferDesc.h [code] | Class UserRenderInstanceBufferDesc, structs RenderDataFormat and RenderInstanceSemantic
UserRenderResource.h [code] | Class UserRenderResource
UserRenderResourceDesc.h [code] | Class UserRenderResourceDesc
UserRenderResourceManager.h [code] | Class UserRenderResourceManager, structs RenderPrimitiveType, RenderBufferHint, and RenderCullMode
UserRenderSpriteBuffer.h [code] | Class UserRenderSpriteBuffer
UserRenderSpriteBufferDesc.h [code] | Class UserRenderSpriteBufferDesc, structs RenderDataFormat and RenderSpriteSemantic
UserRenderSurfaceBuffer.h [code] | Classes UserRenderSurfaceBuffer and RenderSurfaceBufferData
UserRenderSurfaceBufferDesc.h [code] | Class UserRenderSurfaceBufferDesc, structs RenderDataFormat and RenderSurfaceSemantic
UserRenderVertexBuffer.h [code] | Classes UserRenderVertexBuffer and RenderVertexBufferData
UserRenderVertexBufferDesc.h [code] | Class UserRenderVertexBufferDesc, structs RenderDataFormat and RenderVertexSemantic
VelocitySourceActor.h [code] |
VelocitySourceAsset.h [code] |
VelocitySourcePreview.h [code] |
VertexFormat.h [code] | Class VertexFormat and struct VertexFormatFlag
VortexFSActor.h [code] |
VortexFSPreview.h [code] |
WindFSActor.h [code] |
WindFSPreview.h [code] |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • a : nvidia::apex::VertexColor , nvidia::apex::ColorRGBA
  • ACCUMULATE_DAMAGE : nvidia::apex::DestructibleParametersFlag
  • ACCURATE_RAYCASTS : nvidia::apex::DestructibleParametersFlag
  • acquireChunkEventBuffer() : nvidia::apex::DestructibleActor
  • acquirePhysXActorBuffer() : nvidia::apex::DestructibleActor
  • acquireReadLock() : nvidia::apex::RWLockable
  • acquireRenderableReference()
: nvidia::apex::DestructibleActor
, nvidia::apex::IofxActor
, nvidia::apex::TurbulenceFSActor
  • acquireRenderProxy() : nvidia::apex::ClothingActor
  • acquireWriteLock() : nvidia::apex::RWLockable
  • activeObjectCount : nvidia::apex::IofxSharedRenderData
  • actor : nvidia::apex::DestructibleActorJointDesc
  • addActorPair() : nvidia::apex::Scene
  • addBoneCapsule() : nvidia::apex::ClothingAssetAuthoring
  • addBoneConvex() : nvidia::apex::ClothingAssetAuthoring
  • addBoundingBox() : nvidia::apex::Scene
  • addBuffer() : nvidia::apex::VertexFormat
  • addChild() : NvParameterized::Definition
  • addChunkOverlaps()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • addControlPoint() : nvidia::apex::Curve
  • addControlPoints() : nvidia::apex::Curve
  • addDebugRenderable() : nvidia::apex::RenderDebugInterface
  • addDependentActor() : nvidia::apex::IofxAsset
  • addEllipsoidList() : nvidia::apex::EmitterGeomExplicit
  • addEnumVal() : NvParameterized::Definition
  • addForce() : nvidia::apex::DestructibleActor
  • addHint() : NvParameterized::Definition
  • addIofxAsset() : nvidia::apex::RenderVolume
  • addMaterialFrame() : nvidia::apex::ExplicitHierarchicalMesh
  • addParticleList() : nvidia::apex::EmitterGeomExplicit
  • addPlatformToGraphicalLod() : nvidia::apex::ClothingAssetAuthoring
  • addRef() : nvidia::apex::UserRenderData
  • addSphereList() : nvidia::apex::EmitterGeomExplicit
  • addSubmesh() : nvidia::apex::ExplicitHierarchicalMesh
  • addTriangle() : nvidia::apex::ClothingTriangleMesh
  • addTriangles() : nvidia::apex::ClothingTriangleMesh
  • affectsIofxAsset() : nvidia::apex::RenderVolume
  • alignment() : NvParameterized::Definition
  • alloc() : NvParameterized::Traits
  • allocate() : NvParameterized::Traits::Allocator
  • allocateConstrainCoefficientBuffer() : nvidia::apex::ClothingPhysicalMesh
  • allocateMasterFlagsBuffer() : nvidia::apex::ClothingPhysicalMesh
  • Allocator() : NvParameterized::Traits::Allocator
  • allocProjMatrix() : nvidia::apex::Scene
  • allocViewMatrix() : nvidia::apex::Scene
  • AllowActorsNotInScenes : nvidia::apex::DestructiblePhysXActorQueryFlags
  • AllowRedundancy : nvidia::apex::DestructiblePhysXActorQueryFlags
  • AllStates : nvidia::apex::DestructiblePhysXActorQueryFlags
  • alwaysDrawScatterMesh : nvidia::apex::DestructibleParameters
  • amplitude : FractureTools::NoiseParameters
  • angularVariation : FractureTools::SliceParameters
  • ANY_VERSION : NvParameterized::SerializePlatform
  • APEX_ACTOR_TEMPLATE_PARAM() : nvidia::apex::PhysX3DescTemplate
  • ApexDesc() : nvidia::apex::ApexDesc
  • ApexSDKDesc() : nvidia::apex::ApexSDKDesc
  • ApexStatsInfoPtr : nvidia::apex::SceneStats
  • append() : nvidia::apex::PhysXRenderBuffer
  • appendActorTransforms() : nvidia::apex::DestructibleAssetAuthoring
  • appGuid : nvidia::apex::ApexSDKDesc
  • appliedDamageUserData : nvidia::apex::DamageEventReportData
  • applyDamage() : nvidia::apex::DestructibleActor
  • applyRadiusDamage()
: nvidia::apex::DestructibleActor
, nvidia::apex::ModuleDestructible
  • applyTransformation()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::ClothingAssetAuthoring
, nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • archType : NvParameterized::SerializePlatform
  • ArchType : NvParameterized::SerializePlatform
  • areParamsOK() : NvParameterized::Interface
  • arrayDimension() : NvParameterized::Definition
  • arrayIndex : nvidia::apex::UserRenderSpriteTextureDesc
  • arraySize() : NvParameterized::Definition
  • arraySizeIsFixed() : NvParameterized::Definition
  • asFloat() : NvParameterized::Hint
  • ASSET_DEFINED_SUPPORT : nvidia::apex::DestructibleInitParametersFlag
  • asString() : NvParameterized::Hint
  • asUInt() : NvParameterized::Hint
  • attachment : nvidia::apex::DestructibleRTFractureParameters
  • attachmentChunkIndex : nvidia::apex::DestructibleActorJointDesc
  • attachVertexToGlobalPosition() : nvidia::apex::ClothingActor
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- j -

  • joint() : nvidia::apex::DestructibleActorJoint
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • keepPreviousFrameBoneBuffer : nvidia::apex::RenderMeshActorDesc
  • keepVisibleBonesPacked : nvidia::apex::RenderMeshActorDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • layout : nvidia::apex::UserRenderSpriteTextureDesc
  • legacyChunkBoundsTestSetting : nvidia::apex::DestructibleParameters
  • legacyDamageRadiusSpreadSetting : nvidia::apex::DestructibleParameters
  • LIFE_REMAIN : nvidia::apex::IofxRenderSemantic , nvidia::apex::RenderSpriteSemantic
  • lifeWeight : nvidia::apex::EmitterLodParamDesc
  • linearVariation : FractureTools::SliceParameters
  • loadAllLegacyModules() : nvidia::apex::ModuleLoader
  • loadAllModules() : nvidia::apex::ModuleLoader
  • loadModule() : nvidia::apex::ModuleLoader
  • loadModules() : nvidia::apex::ModuleLoader
  • local2world : nvidia::apex::RenderContext
  • LOCAL_OFFSET : nvidia::apex::RenderInstanceSemantic
  • localAnchor : nvidia::apex::DestructibleActorJointDesc
  • localAxis : nvidia::apex::DestructibleActorJointDesc
  • localNormal : nvidia::apex::DestructibleActorJointDesc
  • locateGraphicsMaterialData() : nvidia::apex::ModuleParticles
  • locateResource() : nvidia::apex::ModuleParticles
  • lockIofxActorList() : nvidia::apex::RenderVolume
  • lockModuleSceneRenderLock() : nvidia::apex::Module
  • lockRead() : nvidia::apex::Scene
  • lockRenderResources() : nvidia::apex::RenderDataProvider
  • lockTriangles() : nvidia::apex::ClothingTriangleMesh
  • lockTrianglesWrite() : nvidia::apex::ClothingTriangleMesh
  • lockWrite() : nvidia::apex::Scene
  • LONG_X : nvidia::apex::ApexMeshParticleRollType
  • LONG_Y : nvidia::apex::ApexMeshParticleRollType
  • LONG_Z : nvidia::apex::ApexMeshParticleRollType
  • longName() : NvParameterized::Definition
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • m_cullMode : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_firstVertex : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_indexType : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_materialName : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_numIndices : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_numParts : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_numSubmeshes : nvidia::apex::RenderMeshAssetAuthoring::MeshDesc
  • m_numVertexBuffers : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_numVertices : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_partIndices : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_primitive : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_smoothingGroups : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_submeshes : nvidia::apex::RenderMeshAssetAuthoring::MeshDesc
  • m_uvOrigin : nvidia::apex::RenderMeshAssetAuthoring::MeshDesc
  • m_vertexBuffers : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_vertexIndices : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • ManifestVersions : nvidia::apex::EmitterLodParamDesc
  • map()
: nvidia::apex::UserRenderBuffer
, nvidia::apex::UserRenderSurface
  • mArrayIndex : NvParameterized::ParameterFind , NvParameterized::ParameterList
  • mArraySize : NvParameterized::ParamResult
  • material : nvidia::apex::UserRenderResourceDesc
  • materialDesc
: FractureTools::FractureSliceDesc
, FractureTools::CutoutParameters
, FractureTools::FractureVoronoiDesc
  • materialStrength : nvidia::apex::DestructibleBehaviorGroupDesc
  • MAX_SPRITE_TEXTURES : nvidia::apex::UserRenderSpriteBufferDesc
  • MAX_SURFACE_COUNT : nvidia::apex::IofxSpriteRenderLayout
  • maxBones : nvidia::apex::UserRenderBoneBufferDesc
  • maxChunkSpeed : nvidia::apex::DestructibleParameters
  • maxDepenetrationVelocity : nvidia::apex::DestructibleBehaviorGroupDesc
  • maxDepth
: FractureTools::FractureSliceDesc
, nvidia::apex::DamageEventReportData
, nvidia::apex::ExplicitHierarchicalMesh
  • maxDistance : nvidia::apex::ClothingConstrainCoefficients , nvidia::apex::EmitterLodParamDesc
  • maxHullFaceCount : nvidia::apex::DestructibleAssetStats
  • maxHullVertexCount : nvidia::apex::DestructibleAssetStats
  • maximum : nvidia::apex::Range< T >
  • maxIndices : nvidia::apex::UserRenderIndexBufferDesc
  • maxInstanceCount : nvidia::apex::RenderMeshActorDesc
  • maxInstances : nvidia::apex::UserRenderInstanceBufferDesc
  • maxObjectCount : nvidia::apex::IofxSharedRenderData
  • maxSprites : nvidia::apex::UserRenderSpriteBufferDesc
  • maxVerts : nvidia::apex::UserRenderVertexBufferDesc
  • mBonesPerVertex : nvidia::apex::ExplicitVertexFormat
  • mClassesOnly : NvParameterized::ParameterList
  • mClassName : NvParameterized::ParamResult , NvParameterized::ParameterList
  • mConcavityPercent : nvidia::apex::CollisionVolumeDesc
  • mCoordinateSystem : nvidia::apex::MaterialFrame
  • mDataType : NvParameterized::ParamResult
  • mDepthCount : nvidia::apex::CollisionDesc
  • mError : NvParameterized::ParameterFind
  • MESH : nvidia::apex::IofxRenderable
  • meshBounds() : nvidia::apex::ExplicitHierarchicalMesh
  • MeshDesc() : nvidia::apex::RenderMeshAssetAuthoring::MeshDesc
  • meshIndex : nvidia::apex::DestructibleChunkDesc
  • meshMode : FractureTools::MeshProcessingParameters
  • MeshProcessingParameters() : FractureTools::MeshProcessingParameters
  • meshRenderBuffer : nvidia::apex::IofxMeshSharedRenderData
  • meshRenderLayout : nvidia::apex::IofxMeshSharedRenderData
  • meshTriangleCount() : nvidia::apex::ExplicitHierarchicalMesh
  • meshTriangles() : nvidia::apex::ExplicitHierarchicalMesh
  • mFlags : nvidia::apex::PhysXObjectDesc
  • mFractureIndex : nvidia::apex::MaterialFrame
  • mFractureMethod : nvidia::apex::MaterialFrame
  • mHandle : NvParameterized::ParamResult
  • mHasDynamicBinormals : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicColors : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicDisplacements : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicNormals : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicPositions : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicSeparateBoneBuffer : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicTangents : nvidia::apex::ExplicitVertexFormat
  • mHasStaticBinormals : nvidia::apex::ExplicitVertexFormat
  • mHasStaticColors : nvidia::apex::ExplicitVertexFormat
  • mHasStaticDisplacements : nvidia::apex::ExplicitVertexFormat
  • mHasStaticNormals : nvidia::apex::ExplicitVertexFormat
  • mHasStaticPositions : nvidia::apex::ExplicitVertexFormat
  • mHasStaticSeparateBoneBuffer : nvidia::apex::ExplicitVertexFormat
  • mHasStaticTangents : nvidia::apex::ExplicitVertexFormat
  • mHullMethod : nvidia::apex::CollisionVolumeDesc
  • microgridSize : FractureTools::MeshProcessingParameters
  • minConvexSize : nvidia::apex::DestructibleRTFractureParameters
  • minDepth : nvidia::apex::DamageEventReportData
  • minimum : nvidia::apex::Range< T >
  • minimumChunkSize : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • minimumFractureDepth : nvidia::apex::DestructibleParameters
  • minimumRadius : nvidia::apex::DamageSpreadFunction
  • mInstanceName : NvParameterized::ParamResult
  • mInterface : NvParameterized::ParameterList , NvParameterized::ParameterFind
  • mipLevel : nvidia::apex::UserRenderSpriteTextureDesc
  • mLines : nvidia::apex::PhysXRenderBuffer
  • mLongName : NvParameterized::ParamResult
  • mMaterialName : nvidia::apex::ExplicitSubmeshData
  • mMaxEdgeCount : nvidia::apex::CollisionVolumeDesc
  • mMaxFaceCount : nvidia::apex::CollisionVolumeDesc
  • mMaximumTrimming : nvidia::apex::CollisionDesc
  • mMaxResults : NvParameterized::ParameterList
  • mMaxVertexCount : nvidia::apex::CollisionVolumeDesc
  • mMergeThreshold : nvidia::apex::CollisionVolumeDesc
  • mMeshName : nvidia::apex::UserOpaqueMeshDesc
  • mName : NvParameterized::ParamResult , nvidia::apex::TestFunctionInterface
  • mNameCount : NvParameterized::ParameterFind
  • mNameIndex : NvParameterized::ParameterList , NvParameterized::ParameterFind
  • mNbLines : nvidia::apex::PhysXRenderBuffer
  • mNbPoints : nvidia::apex::PhysXRenderBuffer
  • mNbTexts : nvidia::apex::PhysXRenderBuffer
  • mNbTriangles : nvidia::apex::PhysXRenderBuffer
  • ModifierType
: nvidia::apex::OrientScaleAlongScreenVelocityModifier
, nvidia::apex::ScaleByMassModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::OrientAlongVelocityModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::SubtextureVsLifeModifier
, nvidia::apex::ViewDirectionSortingModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::SimpleScaleModifier
, nvidia::apex::RotationRateModifier
, nvidia::apex::ColorVsVelocityModifier
, nvidia::apex::RandomScaleModifier
, nvidia::apex::RandomSubtextureModifier
, nvidia::apex::RandomRotationModifier
, nvidia::apex::RotationModifier
, nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::ScaleAlongVelocityModifier
  • ModifierUsage
: nvidia::apex::ColorVsVelocityModifier
, nvidia::apex::SimpleScaleModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::RandomRotationModifier
, nvidia::apex::ScaleAlongVelocityModifier
, nvidia::apex::RandomSubtextureModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::OrientScaleAlongScreenVelocityModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::SubtextureVsLifeModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::OrientAlongVelocityModifier
, nvidia::apex::ScaleByMassModifier
, nvidia::apex::ColorVsLifeModifier
, nvidia::apex::RandomScaleModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::RotationModifier
, nvidia::apex::ViewDirectionSortingModifier
, nvidia::apex::RotationRateModifier
  • moduleId : nvidia::apex::ModuleSpecificRenderBufferData
  • moduleIdentifier : nvidia::apex::UserRenderVertexBufferDesc
  • ModuleNameErrorMap : nvidia::apex::ModuleLoader
  • moduleSpecificSemanticData : nvidia::apex::ModuleSpecificRenderBufferData
  • momentum : nvidia::apex::DamageEventUnit
  • mParamName : NvParameterized::ParameterList
  • mPoints : nvidia::apex::PhysXRenderBuffer
  • mRecursionDepth : nvidia::apex::CollisionVolumeDesc
  • mRecursive : NvParameterized::ParameterList
  • mResult : NvParameterized::ParameterList , NvParameterized::ParameterFind
  • mResultCount : NvParameterized::ParameterList
  • mResults : NvParameterized::ParameterList
  • mSearchName : NvParameterized::ParameterFind , NvParameterized::ParameterList
  • mSearchNames : NvParameterized::ParameterFind
  • mSliceDepth : nvidia::apex::MaterialFrame
  • mTexts : nvidia::apex::PhysXRenderBuffer
  • mTraits : NvParameterized::ParameterList
  • mTriangles : nvidia::apex::PhysXRenderBuffer
  • mUVCount : nvidia::apex::ExplicitVertexFormat
  • mUVOffset : nvidia::apex::MaterialFrame
  • mUVPlane : nvidia::apex::MaterialFrame
  • mUVScale : nvidia::apex::MaterialFrame
  • mVertexFormat : nvidia::apex::ExplicitSubmeshData
  • mVolumeDescs : nvidia::apex::CollisionDesc
  • mWinding : nvidia::apex::ExplicitVertexFormat
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • name
: nvidia::apex::DestructibleBehaviorGroupDesc
, NvParameterized::Hint
, NvParameterized::Interface
, NvParameterized::Definition
  • namedReferenceCallback() : NvParameterized::NamedReferenceInterface
  • nameMatch()
: NvParameterized::ParameterFind
, NvParameterized::ParameterList
  • negX : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • negY : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • negZ : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • next
: nvidia::apex::DamageEventHeader
, nvidia::apex::FractureEventHeader
, nvidia::apex::ChunkTransformHeader
  • NO_RENDER_LOCK : nvidia::apex::RenderLockMode
  • noise : FractureTools::SliceParameters
  • noiseMode : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • NoiseMode : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • NoiseParameters() : FractureTools::NoiseParameters
  • NORMAL : nvidia::apex::RenderVertexSemantic
  • normal
: nvidia::apex::EmitterGeomExplicit::EllipsoidParams
, nvidia::apex::RenderMeshActorRaycastHitData
, nvidia::apex::Vertex
  • normalBary : nvidia::apex::ClothingMeshSkinningMap
  • NST_BINARY : NvParameterized::Serializer
  • NST_XML : NvParameterized::Serializer
  • NUM_SEMANTICS
: nvidia::apex::RenderVertexSemantic
, nvidia::apex::RenderSpriteSemantic
, nvidia::apex::IofxRenderSemantic
, nvidia::apex::RenderBoneSemantic
, nvidia::apex::RenderInstanceSemantic
  • numApexStats : nvidia::apex::SceneStats
  • numBones : nvidia::apex::UserRenderResourceDesc
  • numChildren() : NvParameterized::Definition
  • numCustomBuffers : nvidia::apex::UserRenderVertexBufferDesc
  • numEnumVals() : NvParameterized::Definition
  • numHints() : NvParameterized::Definition
  • numIndexes() : NvParameterized::Handle
  • numIndices : nvidia::apex::ClothingPhysicalMeshStats , nvidia::apex::UserRenderResourceDesc
  • numInstances : nvidia::apex::UserRenderResourceDesc
  • numModuleSpecificSemantics : nvidia::apex::ModuleSpecificRenderBufferData
  • numParameters() : NvParameterized::Interface
  • numRefVariants() : NvParameterized::Definition
  • numSectors : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • numSprites : nvidia::apex::UserRenderResourceDesc
  • numSurfaceBuffers : nvidia::apex::UserRenderResourceDesc
  • numVertexBuffers : nvidia::apex::UserRenderResourceDesc
  • numVertices : nvidia::apex::ClothingPhysicalMeshStats
  • numVerts : nvidia::apex::UserRenderResourceDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • obbSweep() : nvidia::apex::DestructibleActor
  • objectCount : nvidia::apex::IofxCommonRenderData
  • offsets : nvidia::apex::IofxMeshRenderLayout , nvidia::apex::IofxSpriteRenderLayout
  • onAllInplaceObjectsDestroyed() : NvParameterized::Traits
  • onCreatedIofxRenderable() : nvidia::apex::IofxRenderCallback
  • onCreatedTurbulenceRenderable() : nvidia::apex::TurbulenceRenderCallback
  • onDamageNotify() : nvidia::apex::UserChunkReport
  • onDestructibleSleep() : nvidia::apex::UserChunkReport
  • onDestructibleWake() : nvidia::apex::UserChunkReport
  • onImpactDamageNotify() : nvidia::apex::UserImpactDamageReport
  • onInplaceObjectDestroyed() : NvParameterized::Traits
  • onParticleEmission() : nvidia::apex::UserChunkParticleReport
  • onPhysXActorCreate() : nvidia::apex::UserDestructiblePhysXActorReport
  • onPhysXActorRelease() : nvidia::apex::UserDestructiblePhysXActorReport
  • onPreProcessReadBegin() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onPreProcessReadDone() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onReadBegin() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onReadDone() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onReleasingIofxRenderable() : nvidia::apex::IofxRenderCallback
  • onReleasingTurbulenceRenderable() : nvidia::apex::TurbulenceRenderCallback
  • onStateChangeNotify() : nvidia::apex::UserChunkReport
  • onUpdatedIofxRenderable() : nvidia::apex::IofxRenderCallback
  • onUpdatedTurbulenceRenderable() : nvidia::apex::TurbulenceRenderCallback
  • onWriteBegin() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onWriteDone() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • opaqueMesh : nvidia::apex::UserRenderResourceDesc
  • operator bool() : NvParameterized::Handle
  • operator!=()
: nvidia::apex::ExplicitVertexFormat
, nvidia::apex::ExplicitSubmeshData
, NvParameterized::SerializePlatform
  • operator()() : NvParameterized::Conversion
  • operator=()
: NvParameterized::Serializer::DeserializedResults< T, bufSize >
, nvidia::apex::VertexColor
, nvidia::apex::UserRenderDataHolder
  • operator==()
: nvidia::apex::ExplicitVertexFormat
, nvidia::apex::ExplicitSubmeshData
, nvidia::apex::Range< T >
, NvParameterized::SerializePlatform
  • operator[]()
: nvidia::apex::Vec2T< T >
, NvParameterized::Serializer::DeserializedResults< T, bufSize >
, nvidia::apex::VertexUV
  • order : FractureTools::SliceParameters
  • Order : FractureTools::SliceParameters
  • ORIENTATION : nvidia::apex::IofxRenderSemantic , nvidia::apex::RenderSpriteSemantic
  • ORIGIN_BOTTOM_LEFT : nvidia::apex::TextureUVOrigin
  • ORIGIN_BOTTOM_RIGHT : nvidia::apex::TextureUVOrigin
  • ORIGIN_TOP_LEFT : nvidia::apex::TextureUVOrigin
  • ORIGIN_TOP_RIGHT : nvidia::apex::TextureUVOrigin
  • ORIGIN_UNKNOWN : nvidia::apex::TextureUVOrigin
  • osType : NvParameterized::SerializePlatform
  • OsType : NvParameterized::SerializePlatform
  • osVer : NvParameterized::SerializePlatform
  • outMaterialID : nvidia::apex::MaterialLookupCallback::MaterialRequest
  • OVERRIDE_IMPACT_DAMAGE : nvidia::apex::DestructibleDepthParametersFlag
  • OVERRIDE_IMPACT_DAMAGE_VALUE : nvidia::apex::DestructibleDepthParametersFlag
  • overrideImpactDamage() : nvidia::apex::DestructibleDepthParameters
  • overrideImpactDamageValue() : nvidia::apex::DestructibleDepthParameters
  • overrideMaterialCount : nvidia::apex::RenderMeshActorDesc
  • overrideMaterials : nvidia::apex::RenderMeshActorDesc
  • owns() : nvidia::apex::ModuleDestructible
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~CutoutSet() : FractureTools::CutoutSet
  • ~Definition() : NvParameterized::Definition
  • ~DestructibleAsset() : nvidia::apex::DestructibleAsset
  • ~Factory() : NvParameterized::Factory
  • ~ForceFieldAsset() : nvidia::apex::ForceFieldAsset
  • ~ForceFieldAssetAuthoring() : nvidia::apex::ForceFieldAssetAuthoring
  • ~Hint() : NvParameterized::Hint
  • ~Interface() : NvParameterized::Interface
  • ~ModuleForceField() : nvidia::apex::ModuleForceField
  • ~NamedReferenceInterface() : NvParameterized::NamedReferenceInterface
  • ~ReferenceInterface() : NvParameterized::ReferenceInterface
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • b : nvidia::apex::VertexColor , nvidia::apex::ColorRGBA
  • B32G32R32A32_FLOAT : nvidia::apex::RenderDataFormat
  • B8G8R8A8 : nvidia::apex::RenderDataFormat
  • backfaceNoise : FractureTools::CutoutParameters
  • BeforeTick : nvidia::apex::DestructibleCallbackSchedule
  • behaviorGroupDescCount : nvidia::apex::DestructibleAssetCookingDesc
  • behaviorGroupDescs : nvidia::apex::DestructibleAssetCookingDesc
  • behaviorGroupIndex : nvidia::apex::DestructibleChunkDesc
  • bias : nvidia::apex::EmitterLodParamDesc
  • binormal : nvidia::apex::RenderMeshActorRaycastHitData , nvidia::apex::Vertex
  • BINORMAL : nvidia::apex::RenderVertexSemantic
  • bits0 : nvidia::apex::GroupsMask64
  • bits1 : nvidia::apex::GroupsMask64
  • BONE_INDEX : nvidia::apex::RenderVertexSemantic
  • BONE_WEIGHT : nvidia::apex::RenderVertexSemantic
  • boneBuffer : nvidia::apex::UserRenderResourceDesc
  • boneIndices : nvidia::apex::Vertex
  • boneWeights : nvidia::apex::Vertex
  • bufferDesc : nvidia::apex::IofxSpriteRenderLayout , nvidia::apex::IofxMeshRenderLayout
  • BufferID : nvidia::apex::VertexFormat
  • bufferReplaceWithLast() : nvidia::apex::VertexFormat
  • buffersRequest : nvidia::apex::UserRenderBoneBufferDesc , nvidia::apex::UserRenderVertexBufferDesc
  • bufferVisibility : nvidia::apex::RenderMeshActorDesc
  • buildCollisionGeometryForPart() : nvidia::apex::ExplicitHierarchicalMesh
  • buildCollisionGeometryForRootChunkParts() : nvidia::apex::ExplicitHierarchicalMesh
  • buildCoordinateSystemFromMaterialDesc() : nvidia::apex::MaterialFrame
  • buildCutoutSet()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • buildExplicitHierarchicalMesh()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • buildExplicitHierarchicalMeshFromDestructibleAsset() : nvidia::apex::FractureToolsAPI
  • buildExplicitHierarchicalMeshFromRenderMeshAsset() : nvidia::apex::FractureToolsAPI
  • buildFromPoints() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • buildSliceMesh()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • BYTE_SNORM1 : nvidia::apex::RenderDataFormat
  • BYTE_SNORM2 : nvidia::apex::RenderDataFormat
  • BYTE_SNORM3 : nvidia::apex::RenderDataFormat
  • BYTE_SNORM4 : nvidia::apex::RenderDataFormat
  • BYTE_SNORM4_QUATXYZW : nvidia::apex::RenderDataFormat
  • BYTE_UNORM1 : nvidia::apex::RenderDataFormat
  • BYTE_UNORM2 : nvidia::apex::RenderDataFormat
  • BYTE_UNORM3 : nvidia::apex::RenderDataFormat
  • BYTE_UNORM4 : nvidia::apex::RenderDataFormat
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • cacheChunkOverlapsUpToDepth()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • cacheModuleData() : nvidia::apex::Actor
  • calculateControlPoints() : nvidia::apex::Curve
  • calculateCutoutUVMapping()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • calculateFollowingControlPoint() : nvidia::apex::Curve
  • calculateMeshBSP() : nvidia::apex::ExplicitHierarchicalMesh
  • calculateNormal() : nvidia::apex::ExplicitRenderTriangle
  • callPreSerializeCallback() : NvParameterized::Interface
  • canBeShared : nvidia::apex::UserRenderVertexBufferDesc
  • center : nvidia::apex::EmitterGeomExplicit::SphereParams , nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • check() : nvidia::apex::TestFunctionInterface
  • checkAlignments() : NvParameterized::Interface
  • checkResults() : nvidia::apex::Scene
  • checksum() : NvParameterized::Interface
  • checkUnitTests() : nvidia::apex::TestBase
  • child() : NvParameterized::Definition
  • chunkBounds() : nvidia::apex::ExplicitHierarchicalMesh
  • chunkBytes : nvidia::apex::DestructibleAssetStats
  • chunkCount : nvidia::apex::DestructibleAssetStats , nvidia::apex::ExplicitHierarchicalMesh
  • chunkDescCount : nvidia::apex::DestructibleAssetCookingDesc
  • chunkDescs : nvidia::apex::DestructibleAssetCookingDesc
  • chunkFlags() : nvidia::apex::ExplicitHierarchicalMesh
  • ChunkFlags : nvidia::apex::DestructibleAsset
  • chunkFracturingMethod : FractureTools::FractureCutoutDesc
  • chunkHullDataBytes : nvidia::apex::DestructibleAssetStats
  • chunkIndex
: nvidia::apex::DestructibleHitChunk
, nvidia::apex::DestructibleChunkEvent
, nvidia::apex::DamageEventUnit
, nvidia::apex::FractureEventUnit
, nvidia::apex::ChunkTransformUnit
  • chunkIndexInAsset : nvidia::apex::DamageEventCoreData
  • chunkIndices : FractureTools::FractureVoronoiDesc
  • ChunkIsWorldSupported : nvidia::apex::DestructibleActorChunkFlags
  • chunkOrientation : nvidia::apex::ChunkTransformUnit
  • chunkPosition : nvidia::apex::ChunkTransformUnit
  • chunkTransformBufferStart : nvidia::apex::ChunkTransformHeader
  • chunkTransformCopyDepth : nvidia::apex::DestructibleChunkSyncState
  • chunkTransformCount : nvidia::apex::ChunkTransformHeader
  • chunkUniqueID() : nvidia::apex::ExplicitHierarchicalMesh
  • chunkWithMaxEdgeCount : nvidia::apex::DestructibleAssetStats
  • className : NvParameterized::Serializer::MetadataEntry , NvParameterized::Interface
  • clear()
: nvidia::apex::ApexSDKCachedData
, nvidia::apex::ExplicitVertexFormat
, nvidia::apex::ExplicitHierarchicalMesh
, nvidia::apex::PhysXRenderBuffer
  • clearActorTransforms() : nvidia::apex::DestructibleAssetAuthoring
  • clearAllBoneActors() : nvidia::apex::ClothingAssetAuthoring
  • clearBoneActors() : nvidia::apex::ClothingAssetAuthoring
  • clearChunkOverlaps()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • clearCollision() : nvidia::apex::ClothingAssetAuthoring
  • clearMeshes() : nvidia::apex::ClothingAssetAuthoring
  • clearTriangles() : nvidia::apex::ClothingTriangleMesh
  • clone() : NvParameterized::Interface
  • collisionCookedHullDataBytes : nvidia::apex::DestructibleAssetStats
  • CollisionDesc() : nvidia::apex::CollisionDesc
  • collisionMeshCount : nvidia::apex::DestructibleAssetStats
  • collisionSphereDistance : nvidia::apex::ClothingConstrainCoefficients
  • collisionSphereRadius : nvidia::apex::ClothingConstrainCoefficients
  • collisionVolumeDesc : nvidia::apex::DestructibleGeometryDesc
  • color : nvidia::apex::Vertex
  • COLOR
: nvidia::apex::IofxRenderSemantic
, nvidia::apex::RenderInstanceSemantic
, nvidia::apex::RenderSpriteSemantic
, nvidia::apex::RenderVertexSemantic
  • ColorRGBA() : nvidia::apex::ColorRGBA
  • compilerType : NvParameterized::SerializePlatform
  • CompilerType : NvParameterized::SerializePlatform
  • compilerVer : NvParameterized::SerializePlatform
  • CONTACTS : nvidia::apex::PhysXObjectDesc
  • Continuous : nvidia::apex::ClothingTeleportMode
  • convexHullCount : nvidia::apex::DestructibleGeometryDesc , nvidia::apex::ExplicitHierarchicalMesh
  • convexHulls : nvidia::apex::DestructibleGeometryDesc , nvidia::apex::ExplicitHierarchicalMesh
  • cookChunks() : nvidia::apex::DestructibleAssetAuthoring
  • cooking : nvidia::apex::ApexSDKDesc
  • copy() : NvParameterized::Interface
  • copyToVertexFormat() : nvidia::apex::ExplicitVertexFormat
  • create() : NvParameterized::Factory
  • createActor() : nvidia::apex::RenderMeshAsset
  • createApexActor() : nvidia::apex::Asset
  • createApexAssetPreview() : nvidia::apex::Asset
  • createApexBoxShape() : nvidia::apex::ApexSDK
  • createApexCapsuleShape() : nvidia::apex::ApexSDK
  • createApexHalfSpaceShape() : nvidia::apex::ApexSDK
  • createApexRenderDebug() : nvidia::apex::ApexSDK
  • createApexSphereShape() : nvidia::apex::ApexSDK
  • createAsset() : nvidia::apex::ApexSDK
  • createAssetAuthoring() : nvidia::apex::ApexSDK
  • createAssetPreviewScene() : nvidia::apex::ApexSDK
  • createBoneBuffer() : nvidia::apex::UserRenderResourceManager
  • createChippedMesh()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • createCollisionCapsule() : nvidia::apex::ClothingActor
  • createCollisionConvex() : nvidia::apex::ClothingActor
  • createCollisionPlane() : nvidia::apex::ClothingActor
  • createCollisionSphere() : nvidia::apex::ClothingActor
  • createCollisionTriangleMesh() : nvidia::apex::ClothingActor
  • createCutoutSet() : nvidia::apex::FractureToolsAPI
  • createDestructibleActorFromDeserializedState() : nvidia::apex::DestructibleAsset
  • createDestructibleActorJoint() : nvidia::apex::ModuleDestructible
  • createEmptyPhysicalMesh() : nvidia::apex::ModuleClothing
  • createExplicitHierarchicalMesh() : nvidia::apex::FractureToolsAPI
  • createExplicitHierarchicalMeshConvexHull()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • createForceSampleBatch() : nvidia::apex::ModuleFieldSampler
  • createHierarchicallySplitMesh()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • createIndexBuffer() : nvidia::apex::UserRenderResourceManager
  • createInstanceBuffer() : nvidia::apex::UserRenderResourceManager
  • createIofxRenderableIterator() : nvidia::apex::ModuleIofx
  • createIosActor() : nvidia::apex::IosAsset
  • createMemoryReadStream() : nvidia::apex::ApexSDK
  • createMemoryWriteStream() : nvidia::apex::ApexSDK
  • createMirrorScene() : nvidia::apex::Scene
  • createModule() : nvidia::apex::ApexSDK
  • createNvParameterized() : NvParameterized::Traits
  • createPhysX3DescTemplate() : nvidia::apex::ActorSource
  • createReductionMap() : nvidia::apex::RenderMeshAssetAuthoring
  • createRenderableIterator()
: nvidia::apex::Module
, nvidia::apex::Context
  • createRenderBuffer() : nvidia::apex::UserRenderCallback
  • createRenderMesh() : nvidia::apex::RenderMeshAssetAuthoring
  • createRenderSurface() : nvidia::apex::UserRenderCallback
  • createRenderVolume() : nvidia::apex::ModuleIofx
  • createResource() : nvidia::apex::UserRenderResourceManager
  • createScatterMeshSites()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • createScene() : nvidia::apex::ApexSDK
  • createSerializer() : nvidia::apex::ApexSDK
  • createSingleLayeredMesh() : nvidia::apex::ModuleClothing
  • createSpriteBuffer() : nvidia::apex::UserRenderResourceManager
  • createStream() : nvidia::apex::ApexSDK
  • createSurfaceBuffer() : nvidia::apex::UserRenderResourceManager
  • createVertexBuffer() : nvidia::apex::UserRenderResourceManager
  • createVoronoiSitesInsideMesh()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • createVoronoiSplitMesh()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • CRUMBLE_SMALLEST_CHUNKS : nvidia::apex::DestructibleParametersFlag
  • CRUMBLE_VIA_RUNTIME_FRACTURE : nvidia::apex::DestructibleParametersFlag
  • CUBIC : nvidia::apex::ApexMeshParticleRollType
  • cullMode : nvidia::apex::UserRenderResourceDesc
  • CUSTOM : nvidia::apex::RenderVertexSemantic
  • customBuffersIdents : nvidia::apex::UserRenderVertexBufferDesc
  • customBuffersRequest : nvidia::apex::UserRenderVertexBufferDesc
  • CutoutChunkFracturingMethod : FractureTools::FractureCutoutDesc
  • cutoutHeightInvert : FractureTools::FractureCutoutDesc
  • cutoutHeightOffset : FractureTools::FractureCutoutDesc
  • cutoutHeightScale : FractureTools::FractureCutoutDesc
  • cutoutParameters : FractureTools::FractureCutoutDesc
  • CutoutParameters() : FractureTools::CutoutParameters
  • cutoutSizeX : FractureTools::FractureCutoutDesc
  • cutoutSizeY : FractureTools::FractureCutoutDesc
  • cutoutWidthInvert : FractureTools::FractureCutoutDesc
  • cutoutWidthOffset : FractureTools::FractureCutoutDesc
  • cutoutWidthScale : FractureTools::FractureCutoutDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • damage
: nvidia::apex::ChunkData
, nvidia::apex::DamageEventCoreData
, nvidia::apex::DamageEventUnit
  • damageCap : nvidia::apex::DestructibleParameters
  • damageColorChange : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageColorSpread : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageDepthLimit : nvidia::apex::DestructibleParameters
  • damageEventBufferStart : nvidia::apex::DamageEventHeader
  • damageEventCount : nvidia::apex::DamageEventHeader
  • damageEventFilterDepth : nvidia::apex::DestructibleActorSyncState
  • damageEventFlags : nvidia::apex::DamageEventUnit
  • damageSpread : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageThreshold : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageToRadius : nvidia::apex::DestructibleBehaviorGroupDesc
  • data : nvidia::apex::RenderSemanticData
  • DataType : nvidia::apex::ExplicitHierarchicalMesh::Embedding
  • deallocate() : NvParameterized::Traits::Allocator
  • DEBRIS_MAX_SEPARATION : nvidia::apex::DestructibleParametersFlag
  • DEBRIS_TIMEOUT : nvidia::apex::DestructibleParametersFlag
  • debrisDepth : nvidia::apex::DestructibleParameters
  • debrisDestructionProbability : nvidia::apex::DestructibleParameters
  • debrisLifetimeMax : nvidia::apex::DestructibleParameters
  • debrisLifetimeMin : nvidia::apex::DestructibleParameters
  • debrisMaxSeparationMax : nvidia::apex::DestructibleParameters
  • debrisMaxSeparationMin : nvidia::apex::DestructibleParameters
  • debugInterface : nvidia::apex::SceneDesc
  • debugVisualizeLocally : nvidia::apex::SceneDesc
  • debugVisualizeRemotely : nvidia::apex::SceneDesc
  • decRefCount() : NvParameterized::Traits
  • def : NvParameterized::Serializer::MetadataEntry
  • defaultBehaviorGroupDesc : nvidia::apex::DestructibleAssetCookingDesc
  • deleteStaticBuffersAfterUse() : nvidia::apex::RenderMeshAssetAuthoring
  • density : nvidia::apex::DestructibleBehaviorGroupDesc
  • DENSITY
: nvidia::apex::IofxRenderSemantic
, nvidia::apex::RenderInstanceSemantic
, nvidia::apex::RenderSpriteSemantic
  • densityFormat : nvidia::apex::TurbulenceRenderLayout
  • depth
: FractureTools::CutoutParameters
, nvidia::apex::ChunkData
, nvidia::apex::UserRenderSurfaceDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
  • depthLimit : nvidia::apex::DestructibleRTFractureParameters
  • depthParameters : nvidia::apex::DestructibleParameters
  • depthParametersCount : nvidia::apex::DestructibleParameters
  • depthPitch : nvidia::apex::UserRenderSurface::MappedInfo
  • deserialize()
: nvidia::apex::ApexSDKCachedData
, nvidia::apex::ExplicitHierarchicalMesh::Embedding
, nvidia::apex::ExplicitHierarchicalMesh
, NvParameterized::Serializer
  • DeserializedData : NvParameterized::Serializer
  • DeserializedMetadata : NvParameterized::Serializer
  • DeserializedResults() : NvParameterized::Serializer::DeserializedResults< T, bufSize >
  • deserializeFractureToolState() : nvidia::apex::DestructibleAssetAuthoring
  • deserializeInplace() : NvParameterized::Serializer
  • deserializeMetadata() : NvParameterized::Serializer
  • deserializeSingleAsset() : nvidia::apex::ModuleCachedData
  • destroy()
: NvParameterized::Definition
, NvParameterized::Interface
  • DESTROYED_CRUMBLED : nvidia::apex::ApexChunkFlag
  • DESTROYED_ENTERED_USER_BOUNDS : nvidia::apex::ApexChunkFlag
  • DESTROYED_EXCEEDED_MAX_DISTANCE : nvidia::apex::ApexChunkFlag
  • DESTROYED_FIFO_FULL : nvidia::apex::ApexChunkFlag
  • DESTROYED_LEFT_USER_BOUNDS : nvidia::apex::ApexChunkFlag
  • DESTROYED_LEFT_VALID_BOUNDS : nvidia::apex::ApexChunkFlag
  • DESTROYED_TIMED_OUT : nvidia::apex::ApexChunkFlag
  • destroyIfAtDepthLimit : nvidia::apex::DestructibleRTFractureParameters
  • destructible
: nvidia::apex::DestructibleActorJointDesc
, nvidia::apex::DamageEventReportData
, nvidia::apex::ImpactDamageEventData
, nvidia::apex::ChunkStateEventData
  • DestructibleActorJointDesc() : nvidia::apex::DestructibleActorJointDesc
  • DestructibleAssetCookingDesc() : nvidia::apex::DestructibleAssetCookingDesc
  • DestructibleBehaviorGroupDesc() : nvidia::apex::DestructibleBehaviorGroupDesc
  • DestructibleChunkDesc() : nvidia::apex::DestructibleChunkDesc
  • DestructibleDepthParameters() : nvidia::apex::DestructibleDepthParameters
  • DestructibleGeometryDesc() : nvidia::apex::DestructibleGeometryDesc
  • DestructibleInitParameters() : nvidia::apex::DestructibleInitParameters
  • DestructibleParameters() : nvidia::apex::DestructibleParameters
  • direction
: nvidia::apex::ImpactDamageEventData
, nvidia::apex::DamageEventUnit
, nvidia::apex::FractureEventUnit
  • directionOrder : FractureTools::FractureCutoutDesc
  • Directions : FractureTools::FractureCutoutDesc
  • directions : FractureTools::FractureCutoutDesc
  • disable() : nvidia::apex::ForceFieldActor
  • disableCudaInterop() : nvidia::apex::ModuleIofx
  • disableCudaModifiers() : nvidia::apex::ModuleIofx
  • disableDeferredRenderableAllocation() : nvidia::apex::ModuleIofx
  • disableHardSleeping() : nvidia::apex::DestructibleActor
  • disableTransformBuffering : nvidia::apex::DestructibleChunkSyncState
  • dispatchRenderResources() : nvidia::apex::Renderable
  • DISPLACEMENT_FLAGS : nvidia::apex::RenderVertexSemantic
  • DISPLACEMENT_TEXCOORD : nvidia::apex::RenderVertexSemantic
  • displacementFlags : nvidia::apex::Vertex
  • displacementMapVolume() : nvidia::apex::ExplicitHierarchicalMesh
  • distanceWeight : nvidia::apex::EmitterLodParamDesc
  • dllLoadPath : nvidia::apex::ApexSDKDesc
  • dllNamePostfix : nvidia::apex::ApexSDKDesc
  • doDetectOverlaps
: nvidia::apex::EmitterGeomExplicit::PointParams
, nvidia::apex::EmitterGeomExplicit::EllipsoidParams
, nvidia::apex::EmitterGeomExplicit::SphereParams
  • doesFactoryExist() : NvParameterized::Traits
  • done() : NvParameterized::ParameterFind
  • doNotCrumble : nvidia::apex::DestructibleChunkDesc
  • doNotDamage : nvidia::apex::DestructibleChunkDesc
  • doNotFracture : nvidia::apex::DestructibleChunkDesc
  • Dormant : nvidia::apex::DestructiblePhysXActorQueryFlags
  • drawEmitterPreview()
: nvidia::apex::EmitterPreview
, nvidia::apex::GroundEmitterPreview
  • drawFlameEmitterPreview() : nvidia::apex::FlameEmitterPreview
  • drawHeatSourcePreview() : nvidia::apex::HeatSourcePreview
  • drawVelocitySourcePreview() : nvidia::apex::VelocitySourcePreview
  • dumpResourceTable() : nvidia::apex::ResourceProvider
  • DYNAMIC : nvidia::apex::ApexChunkFlag
  • Dynamic : nvidia::apex::DestructiblePhysXActorQueryFlags
  • dynamicChunksDominanceGroup : nvidia::apex::DestructibleParameters
  • dynamicChunksFilterData : nvidia::apex::DestructibleParameters
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • edgeNoise : FractureTools::CutoutParameters
  • emitAssetParticles() : nvidia::apex::EmitterActor
  • EmitterLodParamDesc() : nvidia::apex::EmitterLodParamDesc
  • enable() : nvidia::apex::ForceFieldActor
  • enableConcurrencyCheck : nvidia::apex::ApexSDKDesc
  • enableHardSleeping() : nvidia::apex::DestructibleActor
  • enableOutputDensityField() : nvidia::apex::ModuleTurbulenceFS
  • enableOutputFlameField() : nvidia::apex::ModuleTurbulenceFS
  • enableOutputVelocityField() : nvidia::apex::ModuleTurbulenceFS
  • enablePhysXMonitor() : nvidia::apex::ModuleFieldSampler
  • Enum
: nvidia::apex::DestructibleEmitterType
, nvidia::apex::EmitterType
, nvidia::apex::TextureUVOrigin
, nvidia::apex::RenderDataAccess
, nvidia::apex::IofxRenderSemantic
, nvidia::apex::DestructibleParameterizedType
, nvidia::apex::IofxSpriteRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::DestructibleActorSyncFlags
, nvidia::apex::IofxMeshRenderLayoutElement
, nvidia::apex::RenderVertexSemantic
, nvidia::apex::RenderSpriteTextureLayout
, nvidia::apex::RenderSpriteLayoutElement
, nvidia::apex::RenderSpriteSemantic
, nvidia::apex::RenderBufferHint
, nvidia::apex::RenderCullMode
, nvidia::apex::RenderPrimitiveType
, nvidia::apex::ApexMeshParticleRollType
, nvidia::apex::RenderInstanceSemantic
, nvidia::apex::RenderMapType
, nvidia::apex::RenderInteropFlags
, nvidia::apex::RenderBoneSemantic
, nvidia::apex::TurbulenceFlameFormat
, nvidia::apex::TurbulenceDensityFormat
, nvidia::apex::DestructiblePhysXActorQueryFlags
, nvidia::apex::RenderLockMode
, nvidia::apex::UserBoundingBoxFlags
, nvidia::apex::ProjMatrixType
, nvidia::apex::ViewMatrixType
, nvidia::apex::StatDataType
, nvidia::apex::RenderMeshAssetAuthoring::IndexType
, nvidia::apex::RenderMeshAssetAuthoring::Primitive
, nvidia::apex::RenderDataFormat
, nvidia::apex::DestructibleActorChunkFlags
, nvidia::apex::RenderMeshActorRaycastFlags
, nvidia::apex::RenderMeshAssetInstanceMode
, nvidia::apex::DestructibleDepthParametersFlag
, nvidia::apex::GroupsFilterOp
, nvidia::apex::DestructibleParametersFlag
, nvidia::apex::DestructibleInitParametersFlag
, nvidia::apex::ClothingTeleportMode
, nvidia::apex::FractureMethod
, nvidia::apex::DestructibleCallbackSchedule
, nvidia::apex::DestructibleActorRaycastFlags
, nvidia::apex::DestructibleActorMeshType
, nvidia::apex::RenderInstanceLayoutElement
, nvidia::apex::ApexChunkFlag
, nvidia::apex::ExplicitHierarchicalMesh
, nvidia::apex::TurbulenceFieldType
, nvidia::apex::TurbulenceVelocityFormat
, nvidia::apex::BSPOpenMode
, nvidia::apex::ClothSolverMode
, nvidia::apex::ClothingCollisionType
, nvidia::apex::ModuleDestructibleConst
, nvidia::apex::ConvexHullMethod
  • enumVal() : NvParameterized::Definition
  • enumValIndex() : NvParameterized::Definition
  • equals() : NvParameterized::Interface
  • ErrorType : NvParameterized::Serializer
  • essentialDepth : nvidia::apex::DestructibleParameters
  • ET_DENSITY_BRUSH : nvidia::apex::EmitterType
  • ET_DENSITY_ONCE : nvidia::apex::EmitterType
  • ET_FILL : nvidia::apex::EmitterType
  • ET_RATE : nvidia::apex::EmitterType
  • evaluate() : nvidia::apex::Curve
  • event : nvidia::apex::DestructibleChunkEvent
  • EventMask : nvidia::apex::DestructibleChunkEvent
  • excludeSleepingChunks : nvidia::apex::DestructibleChunkSyncState
  • ExplicitHierarchicalMesh() : nvidia::apex::ExplicitHierarchicalMesh
  • ExplicitVertexFormat() : nvidia::apex::ExplicitVertexFormat
  • EXTERNALLY_SUPPORTED : nvidia::apex::ApexChunkFlag
  • extraDataIndex : nvidia::apex::ExplicitRenderTriangle
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • faceNoise : FractureTools::FractureVoronoiDesc
  • facetNormalMergeThresholdAngle : FractureTools::FractureCutoutDesc
  • fadeIn() : nvidia::apex::EffectPackageActor
  • fadeOut : nvidia::apex::DestructibleBehaviorGroupDesc , nvidia::apex::EffectPackageActor
  • falloffExponent : nvidia::apex::DamageSpreadFunction
  • FetchResults : nvidia::apex::DestructibleCallbackSchedule
  • fetchResults() : nvidia::apex::Scene
  • fieldSamplerWeightedCollisionFilter() : nvidia::apex::FieldSamplerWeightedCollisionFilterCallback
  • fieldSurfaceDescs : nvidia::apex::TurbulenceRenderData
  • fieldSurfaces : nvidia::apex::TurbulenceRenderData
  • findActorPair() : nvidia::apex::Scene
  • findAllResourceNames() : nvidia::apex::ResourceProvider
  • findAllResources() : nvidia::apex::ResourceProvider
  • findNameSpaces() : nvidia::apex::ResourceProvider
  • findRefCount() : nvidia::apex::ResourceProvider
  • findResource() : nvidia::apex::ResourceProvider
  • findResourceU32() : nvidia::apex::ResourceProvider
  • finish() : NvParameterized::Factory
  • finishNvParameterized() : NvParameterized::Traits
  • firstBone : nvidia::apex::UserRenderResourceDesc
  • firstIndex : nvidia::apex::UserRenderResourceDesc
  • firstInstance : nvidia::apex::UserRenderResourceDesc
  • firstSegmentSize : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • firstSprite : nvidia::apex::UserRenderResourceDesc
  • firstVertex : nvidia::apex::UserRenderResourceDesc
  • flags
: nvidia::apex::DestructibleDepthParameters
, nvidia::apex::DestructibleParameters
, nvidia::apex::DestructibleInitParameters
, nvidia::apex::ChunkData
  • flameFormat : nvidia::apex::TurbulenceRenderLayout
  • FLAT_X : nvidia::apex::ApexMeshParticleRollType
  • FLAT_Y : nvidia::apex::ApexMeshParticleRollType
  • FLAT_Z : nvidia::apex::ApexMeshParticleRollType
  • FLOAT1 : nvidia::apex::RenderDataFormat
  • FLOAT2 : nvidia::apex::RenderDataFormat
  • FLOAT3 : nvidia::apex::RenderDataFormat
  • FLOAT3x3 : nvidia::apex::RenderDataFormat
  • FLOAT3x4 : nvidia::apex::RenderDataFormat
  • FLOAT4 : nvidia::apex::RenderDataFormat
  • FLOAT4_QUAT : nvidia::apex::RenderDataFormat
  • FLOAT4x4 : nvidia::apex::RenderDataFormat
  • forceBoneIndexChannel : nvidia::apex::RenderMeshActorDesc
  • forceChunkHits() : nvidia::apex::DestructibleActor
  • forceDamageColoring() : nvidia::apex::DestructibleActor
  • forceFallbackSkinning : nvidia::apex::RenderMeshActorDesc
  • forceLoadAssets()
: nvidia::apex::ApexSDK
, nvidia::apex::Asset
  • forceLod() : nvidia::apex::Actor
  • forceToDamage : nvidia::apex::DestructibleParameters
  • FORM_EXTENDED_STRUCTURES : nvidia::apex::DestructibleInitParametersFlag
  • format
: nvidia::apex::RenderSemanticData
, nvidia::apex::UserRenderIndexBufferDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
, nvidia::apex::UserRenderSurfaceDesc
  • foundation : nvidia::apex::ApexSDKDesc
  • FractureCutoutDesc() : FractureTools::FractureCutoutDesc
  • FRACTURED : nvidia::apex::ApexChunkFlag
  • fractureEventBufferStart : nvidia::apex::FractureEventHeader
  • fractureEventCount : nvidia::apex::FractureEventHeader
  • fractureEventFilterDepth : nvidia::apex::DestructibleActorSyncState
  • fractureEventFlags : nvidia::apex::FractureEventUnit
  • fractureEventList : nvidia::apex::DamageEventReportData
  • fractureEventListSize : nvidia::apex::DamageEventReportData
  • fractureImpulseScale : nvidia::apex::DestructibleParameters
  • FractureMaterialDesc() : nvidia::apex::FractureMaterialDesc
  • FractureSliceDesc() : FractureTools::FractureSliceDesc
  • FractureVoronoiDesc() : FractureTools::FractureVoronoiDesc
  • free() : NvParameterized::Traits
  • freeParameterDefinitionTable() : NvParameterized::Factory
  • freeVertex() : nvidia::apex::ClothingActor
  • frequency : FractureTools::NoiseParameters
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • g : nvidia::apex::VertexColor , nvidia::apex::ColorRGBA
  • geometryDescCount : nvidia::apex::DestructibleAssetCookingDesc
  • geometryDescs : nvidia::apex::DestructibleAssetCookingDesc
  • getAABB() : nvidia::apex::Shape
  • getActiveLod() : nvidia::apex::Actor
  • getActiveParticleCount()
: nvidia::apex::EffectPackageActor
, nvidia::apex::EmitterActor
  • getActor() : nvidia::apex::ClothingAsset
  • getActorDesc() : nvidia::apex::ClothingActor
  • getActorTransformCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getActorTransforms()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getAffectsAllIofx() : nvidia::apex::RenderVolume
  • getAlignment()
: NvParameterized::Factory
, NvParameterized::Traits
  • getAllocator() : nvidia::apex::ApexSDK
  • getApexActor() : nvidia::apex::PhysXObjectDesc
  • getApexActorCount() : nvidia::apex::PhysXObjectDesc
  • getApexEmitter() : nvidia::apex::DestructibleActor
  • getArrayIndex() : NvParameterized::ParameterFind
  • getArraySize()
: NvParameterized::Handle
, NvParameterized::Interface
  • getAssetNvParameterized() : nvidia::apex::Asset
  • getAttachActor()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
  • getAttachRelativePose() : nvidia::apex::EmitterActor
  • getAttachRelativePosition() : nvidia::apex::GroundEmitterActor
  • getAttractorFSAsset() : nvidia::apex::AttractorFSActor
  • getAttributeIndex() : nvidia::apex::CustomBufferIterator
  • getAuthorableObjectNames() : nvidia::apex::ApexSDK
  • getAverageDensity() : nvidia::apex::SubstanceSourceActor
  • getAverageTemperature() : nvidia::apex::HeatSourceActor
  • getAverageVelocity() : nvidia::apex::VelocitySourceActor
  • getBasicIosTypeName() : nvidia::apex::ModuleBasicIos
  • getBehaviorGroup() : nvidia::apex::DestructibleActor
  • getBiggestMaxDistance() : nvidia::apex::ClothingAsset
  • getBoneBasePose() : nvidia::apex::ClothingAsset
  • getBoneBindPose() : nvidia::apex::ClothingAssetAuthoring
  • getBoneBuffer() : nvidia::apex::UserRenderResource
  • getBoneCount() : nvidia::apex::RenderMeshActor
  • getBoneIndices() : nvidia::apex::ClothingPhysicalMesh
  • getBoneMapping() : nvidia::apex::ClothingAsset
  • getBoneName() : nvidia::apex::ClothingAsset
  • getBoneWeights() : nvidia::apex::ClothingPhysicalMesh
  • getBoundingBox()
: nvidia::apex::ClothingAsset
, nvidia::apex::Scene
  • getBoundingBoxCount() : nvidia::apex::Scene
  • getBoundingBoxFlags() : nvidia::apex::Scene
  • getBounds()
: nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
, nvidia::apex::IofxActor
, nvidia::apex::IofxRenderable
, nvidia::apex::RenderVolume
, nvidia::apex::Renderable
, nvidia::apex::RenderMeshAssetAuthoring
, nvidia::apex::RenderMeshAsset
, nvidia::apex::TurbulenceRenderable
  • getBoxShape()
: nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::VelocitySourceActor
  • getBuffer() : nvidia::apex::VertexBuffer
  • getBufferAccess() : nvidia::apex::VertexFormat
  • getBufferAndFormat() : nvidia::apex::VertexBuffer
  • getBufferAndFormatWritable() : nvidia::apex::VertexBuffer
  • getBufferCount() : nvidia::apex::VertexFormat
  • getBufferData() : nvidia::apex::VertexBuffer
  • getBufferFormat() : nvidia::apex::VertexFormat
  • getBufferID() : nvidia::apex::VertexFormat
  • getBufferIndexFromID() : nvidia::apex::VertexFormat
  • getBufferName() : nvidia::apex::VertexFormat
  • getBufferSemantic() : nvidia::apex::VertexFormat
  • getBufferSerialize() : nvidia::apex::VertexFormat
  • getCachedData() : nvidia::apex::ApexSDK
  • getCachedDataForAssetAtScale() : nvidia::apex::ModuleCachedData
  • getCachedOverlapCountAtDepth()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getCachedOverlapsAtDepth()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getCacheForModule() : nvidia::apex::ApexSDKCachedData
  • getCameraMatrix() : nvidia::apex::AssetPreviewScene
  • getChecksum() : NvParameterized::Factory
  • getChildHandle() : NvParameterized::Handle
  • getChunkActorFlags() : nvidia::apex::DestructibleActor
  • getChunkActorLocalBounds() : nvidia::apex::DestructibleAsset
  • getChunkAngularVelocity() : nvidia::apex::DestructibleActor
  • getChunkBehaviorGroupIndex() : nvidia::apex::DestructibleActor
  • getChunkBounds() : nvidia::apex::DestructibleActor
  • getChunkChild() : nvidia::apex::DestructibleAssetAuthoring
  • getChunkChildCount() : nvidia::apex::DestructibleAssetAuthoring
  • getChunkCollisionHullCookingScale() : nvidia::apex::ModuleDestructible
  • getChunkCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkDepth() : nvidia::apex::DestructibleAsset
  • getChunkFlags() : nvidia::apex::DestructibleAsset
  • getChunkLinearVelocity() : nvidia::apex::DestructibleActor
  • getChunkLocalBounds() : nvidia::apex::DestructibleActor
  • getChunkParentIndex() : nvidia::apex::DestructibleAsset
  • getChunkPhysXActor() : nvidia::apex::DestructibleActor
  • getChunkPhysXShapes() : nvidia::apex::DestructibleActor
  • getChunkPose() : nvidia::apex::DestructibleActor
  • getChunkPositionOffset()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkTM() : nvidia::apex::DestructibleActor
  • getChunkTransform() : nvidia::apex::DestructibleActor
  • getChunkUVOffset()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkVisibilities() : nvidia::apex::DestructibleActor
  • getClassName() : NvParameterized::Factory
  • getClothingMaterial() : nvidia::apex::ClothingActor
  • getClothingPhysicalMesh() : nvidia::apex::ClothingAssetAuthoring
  • getClothSolverMode()
: nvidia::apex::ClothingActor
, nvidia::apex::ClothingAsset
  • getColorChannel()
: nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::ColorVsVelocityModifier
  • getConstInterface() : NvParameterized::Handle
  • getConstrainCoefficientBuffer() : nvidia::apex::ClothingPhysicalMesh
  • getConstrainCoefficients() : nvidia::apex::ClothingPhysicalMesh
  • getContactReportFlags() : nvidia::apex::PhysX3Interface
  • getContinuousModifiers() : nvidia::apex::IofxAsset
  • getControlPoints() : nvidia::apex::Curve
  • getCookingInterface() : nvidia::apex::ApexSDK
  • getCoreExplicitHierarchicalMesh() : nvidia::apex::DestructibleAssetAuthoring
  • getCrumbleEmitterName() : nvidia::apex::DestructibleAsset
  • getCUDAgraphicsResource()
: nvidia::apex::UserRenderSurface
, nvidia::apex::UserRenderBuffer
  • getCudaKernelCheckEnabled() : nvidia::apex::Scene
  • getCudaProfileManager() : nvidia::apex::Scene
  • getCudaTestManager() : nvidia::apex::Scene
  • getCurrentBoneSkinningMatrices() : nvidia::apex::ClothingActor
  • getCurrentLife() : nvidia::apex::EffectPackageActor
  • getCurrentPlatform() : nvidia::apex::ApexSDK
  • getCurrentPose()
: nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
  • getCurrentPosition()
: nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
  • getCurrentScale()
: nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::EmitterActor
, nvidia::apex::ForceFieldActor
, nvidia::apex::EffectPackageActor
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::VelocitySourceActor
  • getCurrentVersion() : NvParameterized::Traits
  • getCustomBehaviorGroupCount() : nvidia::apex::DestructibleActor
  • getCustomBufferCount() : nvidia::apex::VertexFormat
  • getCustomSemanticData() : nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >
  • getCutoutCount() : FractureTools::CutoutSet
  • getCutoutLoopCount() : FractureTools::CutoutSet
  • getCutoutLoopSize() : FractureTools::CutoutSet
  • getCutoutLoopVertexFlags() : FractureTools::CutoutSet
  • getCutoutLoopVertexIndex() : FractureTools::CutoutSet
  • getCutoutSet() : nvidia::apex::DestructibleAssetAuthoring
  • getCutoutVertex() : FractureTools::CutoutSet
  • getCutoutVertexCount() : FractureTools::CutoutSet
  • getDamageColoringHistory() : nvidia::apex::DestructibleActor
  • getData() : nvidia::apex::DisplacementMapVolume
  • getDebugColorParams() : nvidia::apex::ApexSDK
  • getDebugRenderParams() : nvidia::apex::Scene
  • getDefaultActorDesc() : nvidia::apex::Asset
  • getDefaultAssetPreviewDesc() : nvidia::apex::Asset
  • getDefaultModuleDesc() : nvidia::apex::Module
  • getDefaultScale() : nvidia::apex::ForceFieldAsset
  • getDensity()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterActor
  • getDensityGridDimensions() : nvidia::apex::TurbulenceFSActor
  • getDensityScale() : nvidia::apex::ModuleEmitter
  • getDepthCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getDestructibleAndChunk() : nvidia::apex::ModuleDestructible
  • getDestructibleInitParameters()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getDestructibleParameters()
: nvidia::apex::DestructibleActor
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getDimensions()
: FractureTools::CutoutSet
, nvidia::apex::CapsuleShape
  • getDistance() : nvidia::apex::EmitterGeomExplicit
  • getDuration()
: nvidia::apex::EffectPackageActor
, nvidia::apex::EffectPackageAsset
  • getDustEmitterName() : nvidia::apex::DestructibleAsset
  • getDynamicHandleIndicesMap() : NvParameterized::Definition
  • getEdgeCount() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getEdgeEndpoint() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getEffectActor() : nvidia::apex::EffectPackageActor
  • getEffectCount() : nvidia::apex::EffectPackageActor
  • getEffectName() : nvidia::apex::EffectPackageActor
  • getEffectPackageDatabase() : nvidia::apex::ModuleParticles
  • getEffectPackageEmitterDatabase() : nvidia::apex::ModuleParticles
  • getEffectPackageFieldSamplerDatabase() : nvidia::apex::ModuleParticles
  • getEffectPackageGraphicsMaterialsDatabase() : nvidia::apex::ModuleParticles
  • getEffectPackageIOFXDatabase() : nvidia::apex::ModuleParticles
  • getEffectPackageIOSDatabase() : nvidia::apex::ModuleParticles
  • getEffectPose() : nvidia::apex::EffectPackageActor
  • getEffectRigidDynamic() : nvidia::apex::EffectPackageActor
  • getEffectType() : nvidia::apex::EffectPackageActor
  • getEllipsoidCenter() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidCount() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidList() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidNormal() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidPolarRadius() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidRadius() : nvidia::apex::EmitterGeomExplicit
  • getEmitAssetParticles() : nvidia::apex::EmitterActor
  • getEmitDuration() : nvidia::apex::EmitterAsset
  • getEmitterAsset()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
, nvidia::apex::ImpactEmitterActor
  • getEmitterType() : nvidia::apex::EmitterGeom
  • getEnabled() : nvidia::apex::EffectPackageActor
  • getErrorCallback() : nvidia::apex::ApexSDK
  • getExplicitHierarchicalMesh() : nvidia::apex::DestructibleAssetAuthoring
  • getExtents() : nvidia::apex::EmitterGeomBox
  • getEyeDirection() : nvidia::apex::Scene
  • getEyePosition() : nvidia::apex::Scene
  • getFirst()
: nvidia::apex::RenderableIterator
, nvidia::apex::IofxRenderableIterator
  • getFirstVertexIndex() : nvidia::apex::RenderSubmesh
  • getFlameEmitterAsset() : nvidia::apex::FlameEmitterActor
  • getFlameGridDimensions() : nvidia::apex::TurbulenceFSActor
  • getForceFieldAsset() : nvidia::apex::ForceFieldActor
  • getFormat()
: nvidia::apex::IofxSpriteRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::IofxMeshRenderLayoutElement
, nvidia::apex::VertexBuffer
  • getFormatDataSize() : nvidia::apex::RenderDataFormat
  • getFormatWritable() : nvidia::apex::VertexBuffer
  • getFractureImpulseScale() : nvidia::apex::DestructibleAssetAuthoring
  • getFractureTools() : nvidia::apex::ModuleDestructible
  • getFunction()
: nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::SubtextureVsLifeModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::ColorVsVelocityModifier
  • getGeom() : nvidia::apex::EmitterAsset
  • getGlobalPose()
: nvidia::apex::ClothingActor
, nvidia::apex::DestructibleActor
, nvidia::apex::EmitterActor
  • getGraphicalLod() : nvidia::apex::ClothingActor
  • getGraphicalLodValue() : nvidia::apex::ClothingAsset
  • getGravity() : nvidia::apex::Scene
  • getGridBoundingBoxMax() : nvidia::apex::TurbulenceFSActor
  • getGridBoundingBoxMin() : nvidia::apex::TurbulenceFSActor
  • getGridDimensions() : nvidia::apex::TurbulenceFSActor
  • getGridSize() : nvidia::apex::TurbulenceFSActor
  • getGridSizePow() : nvidia::apex::ModuleTurbulenceFS
  • getGroundDensityScale() : nvidia::apex::ModuleEmitter
  • getHeatSourceAsset() : nvidia::apex::HeatSourceActor
  • getHeight() : nvidia::apex::EmitterGeomCylinder
  • getHitChunkHistory() : nvidia::apex::DestructibleActor
  • getID() : nvidia::apex::VertexFormat
  • getImpactVelocityThreshold() : nvidia::apex::DestructibleAssetAuthoring
  • getIndexBuffer()
: nvidia::apex::RenderSubmesh
, nvidia::apex::UserRenderResource
  • getIndexCount() : nvidia::apex::RenderSubmesh
  • getIndices() : nvidia::apex::ClothingPhysicalMesh
  • getInitialGlobalPose() : nvidia::apex::DestructibleActor
  • getInstanceBuffer()
: nvidia::apex::RenderMeshActor
, nvidia::apex::UserRenderResource
  • getInstancedChunkMeshCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getInstancedObjectEffectsAssetName() : nvidia::apex::EmitterAsset
  • getInstancedObjectSimulatorAssetName() : nvidia::apex::EmitterAsset
  • getInstancedObjectSimulatorTypeName() : nvidia::apex::EmitterAsset
  • getInstanceLayoutData() : nvidia::apex::UserRenderResourceManager
  • getInterface() : NvParameterized::Handle
  • getInteropResourceHandle()
: nvidia::apex::UserRenderIndexBuffer
, nvidia::apex::UserRenderInstanceBuffer
, nvidia::apex::UserRenderSpriteBuffer
, nvidia::apex::UserRenderSurfaceBuffer
, nvidia::apex::UserRenderVertexBuffer
  • getInteropTextureHandleList() : nvidia::apex::UserRenderSpriteBuffer
  • getIofxAssetList() : nvidia::apex::RenderVolume
  • getIofxLegacyRenderCallback() : nvidia::apex::ModuleIofxLegacy
  • getIofxMeshRenderLayout() : nvidia::apex::IofxRenderCallback
  • getIofxRenderCallback() : nvidia::apex::ModuleIofx
  • getIofxSpriteRenderLayout() : nvidia::apex::IofxRenderCallback
  • getIosAssetName() : nvidia::apex::IofxActor
  • getJetFSAsset() : nvidia::apex::JetFSActor
  • getLayoutFormat() : nvidia::apex::RenderSpriteTextureLayout
  • getLifetimeHigh()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterAsset
  • getLifetimeLow()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterAsset
  • getLines() : nvidia::apex::PhysXRenderBuffer
  • getLoadedModule() : nvidia::apex::ModuleLoader
  • getLoadedModuleCount() : nvidia::apex::ModuleLoader
  • getLoadedModulesErrors() : nvidia::apex::ModuleLoader
  • getLocalBounds() : nvidia::apex::DestructibleActor
  • getLodParamDesc()
: nvidia::apex::EmitterActor
, nvidia::apex::EmitterAsset
  • getLodRange() : nvidia::apex::Actor
  • getLodValue() : nvidia::apex::ClothingAssetAuthoring
  • getLongName() : NvParameterized::Handle
  • getMajorVersion() : NvParameterized::Interface
  • getMasterFlagsBuffer() : nvidia::apex::ClothingPhysicalMesh
  • getMaterialFrame() : nvidia::apex::ExplicitHierarchicalMesh
  • getMaterialFrameCount() : nvidia::apex::ExplicitHierarchicalMesh
  • getMaterialLibrary() : nvidia::apex::ClothingAssetAuthoring
  • getMaterialLookupCallback() : nvidia::apex::GroundEmitterActor
  • getMaterialName()
: nvidia::apex::RenderMeshAssetAuthoring
, nvidia::apex::RenderMeshAsset
  • getMaterials() : nvidia::apex::PhysX3DescTemplate
  • getMaxBonesForMaterial() : nvidia::apex::UserRenderResourceManager
  • getMaxDistanceBlendTime() : nvidia::apex::ClothingActor
  • getMaximumSimulationBudget() : nvidia::apex::ClothingActor
  • getMaxInjectedParticleCount()
: nvidia::apex::BasicIosAsset
, nvidia::apex::ParticleIosAsset
  • getMaxParticleCount()
: nvidia::apex::BasicIosAsset
, nvidia::apex::ParticleIosAsset
  • getMaxRaycastsPerFrame()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::GroundEmitterAsset
  • getMaxRotationRate() : nvidia::apex::RotationModifier
  • getMaxSamples() : nvidia::apex::EmitterAsset
  • getMaxSettleRate() : nvidia::apex::RotationModifier
  • getMemoryWriteBuffer() : nvidia::apex::ApexSDK
  • getMeshAssetCount() : nvidia::apex::IofxAsset
  • getMeshAssetName() : nvidia::apex::IofxAsset
  • getMeshAssetWeight() : nvidia::apex::IofxAsset
  • getMeshRenderData() : nvidia::apex::IofxRenderable
  • getMeshSkinningMap() : nvidia::apex::ClothingAsset
  • getMeshSkinningMapSize() : nvidia::apex::ClothingAsset
  • getMinorVersion() : NvParameterized::Interface
  • getModelForward() : nvidia::apex::OrientAlongVelocityModifier
  • getModifierMeshSemantics() : nvidia::apex::Modifier
  • getModifierSpriteSemantics() : nvidia::apex::Modifier
  • getModifierType()
: nvidia::apex::Modifier
, nvidia::apex::ModifierT< T >
  • getModifierUsage()
: nvidia::apex::Modifier
, nvidia::apex::ModifierT< T >
  • getModule() : nvidia::apex::ModuleParticles
  • getModuleDebugRenderParams() : nvidia::apex::Scene
  • getModuleID() : nvidia::apex::Module
  • getModules() : nvidia::apex::ApexSDK
  • getModuleValue() : nvidia::apex::ModuleForceField
  • getName()
: nvidia::apex::Asset
, nvidia::apex::AssetAuthoring
, nvidia::apex::ForceFieldActor
, nvidia::apex::Module
, nvidia::apex::EffectPackageActor
  • getNamedResourceProvider() : nvidia::apex::ApexSDK
  • getNbLines() : nvidia::apex::PhysXRenderBuffer
  • getNbModules() : nvidia::apex::ApexSDK
  • getNbPoints() : nvidia::apex::PhysXRenderBuffer
  • getNbTexts() : nvidia::apex::PhysXRenderBuffer
  • getNbTriangles() : nvidia::apex::PhysXRenderBuffer
  • getNbVertexBuffers() : nvidia::apex::UserRenderResource
  • getNeighborPadding() : nvidia::apex::DestructibleAssetAuthoring
  • getNext()
: nvidia::apex::RenderableIterator
, nvidia::apex::IofxRenderableIterator
  • getNoiseFSAsset() : nvidia::apex::NoiseFSActor
  • getNormal() : nvidia::apex::HalfSpaceShape
  • getNormals() : nvidia::apex::ClothingPhysicalMesh
  • getNumActors() : nvidia::apex::ClothingAsset
  • getNumBones() : nvidia::apex::ClothingAsset
  • getNumBonesPerVertex() : nvidia::apex::ClothingPhysicalMesh
  • getNumCustomSemantics() : nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >
  • getNumGraphicalLodLevels() : nvidia::apex::ClothingAsset
  • getNumGraphicalVerticesActive() : nvidia::apex::ClothingActor
  • getNumIndices() : nvidia::apex::ClothingPhysicalMesh
  • getNumLods() : nvidia::apex::ClothingAssetAuthoring
  • getNumMaxDistance0Vertices() : nvidia::apex::ClothingPhysicalMesh
  • getNumPlanes() : nvidia::apex::ClothingConvex
  • getNumPlatforms() : nvidia::apex::ClothingAssetAuthoring
  • getNumProjMatrices() : nvidia::apex::Scene
  • getNumSimulatedIndices() : nvidia::apex::ClothingPhysicalMesh
  • getNumSimulatedVertices() : nvidia::apex::ClothingPhysicalMesh
  • getNumSimulationVertices() : nvidia::apex::ClothingActor
  • getNumUsedBones() : nvidia::apex::ClothingAsset
  • getNumVertices() : nvidia::apex::ClothingPhysicalMesh
  • getNumViewMatrices() : nvidia::apex::Scene
  • getNumVisibleChunks() : nvidia::apex::DestructibleActor
  • getNvParameterized()
: nvidia::apex::DestructibleActor
, nvidia::apex::AssetAuthoring
  • getNvParameterizedNames() : NvParameterized::Traits
  • getNvParameterizedVersions() : NvParameterized::Traits
  • getObjectCount() : nvidia::apex::IofxActor
  • getObjectRadius()
: nvidia::apex::EmitterActor
, nvidia::apex::IofxActor
  • getObjects() : NvParameterized::Serializer::DeserializedResults< T, bufSize >
  • getObjectScale() : nvidia::apex::EmitterActor
  • getObjTypeID() : nvidia::apex::Asset
  • getObjTypeName()
: nvidia::apex::Asset
, nvidia::apex::AssetAuthoring
  • getOpaqueMesh() : nvidia::apex::RenderMeshAsset
  • getOrigin() : nvidia::apex::HalfSpaceShape
  • getOriginalBounds() : nvidia::apex::DestructibleActor
  • getOutputStream() : nvidia::apex::ApexSDK
  • getOwner() : nvidia::apex::Actor
  • getOwnershipBounds() : nvidia::apex::RenderVolume
  • getParam() : NvParameterized::Handle
  • getParamArray() : NvParameterized::Handle
  • getParamBool()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamBoolArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamBounds3()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamBounds3Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamEnum()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamEnumArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParameter() : NvParameterized::Handle
  • getParameterHandle() : NvParameterized::Interface
  • getParameterizedTraits() : nvidia::apex::ApexSDK
  • getParamF32()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamF32Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamF64()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamF64Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamI16()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamI16Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamI32()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamI32Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamI64()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamI64Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamI8()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamI8Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamMat33()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamMat33Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamMat34Legacy()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamMat34LegacyArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamMat44()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamMat44Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamQuat()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamQuatArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamRef()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamRefArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamString()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamStringArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamTransform()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamTransformArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU16()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamU16Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU32()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU32Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU64()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU64Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU8()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU8Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamVec2()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamVec2Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamVec3()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamVec3Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamVec4()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamVec4Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • getPartConvexHullArray() : nvidia::apex::DestructibleAsset
  • getPartConvexHullCount() : nvidia::apex::DestructibleAsset
  • getPartCount()
: nvidia::apex::RenderMeshAsset
, nvidia::apex::RenderMeshAssetAuthoring
  • getParticleCount()
: nvidia::apex::EmitterGeomExplicit
, nvidia::apex::BasicIosActor
  • getParticleIosTypeName() : nvidia::apex::ModuleParticleIos
  • getParticleList() : nvidia::apex::EmitterGeomExplicit
  • getParticleMass()
: nvidia::apex::BasicIosAsset
, nvidia::apex::ParticleIosAsset
  • getParticlePos() : nvidia::apex::EmitterGeomExplicit
  • getParticleRadius()
: nvidia::apex::BasicIosAsset
, nvidia::apex::ParticleIosAsset
, nvidia::apex::BasicIosActor
  • getPartIndex()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getPhysicalMeshNormals() : nvidia::apex::ClothingActor
  • getPhysicalMeshPositions() : nvidia::apex::ClothingActor
  • getPhysX3Template() : nvidia::apex::ActorSource
  • getPhysXObjectInfo() : nvidia::apex::ApexSDK
  • getPhysXScene() : nvidia::apex::Scene
  • getPhysXSDK() : nvidia::apex::ApexSDK
  • getPlane()
: nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
, nvidia::apex::ClothingPlane
  • getPlaneCount() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getPlanes() : nvidia::apex::ClothingConvex
  • getPlatform() : nvidia::apex::ClothingAssetAuthoring
  • getPlatformFromString() : nvidia::apex::ApexSDK
  • getPlatformName() : nvidia::apex::ApexSDK
  • getPoints() : nvidia::apex::PhysXRenderBuffer
  • getPose()
: nvidia::apex::ClothingTriangleMesh
, nvidia::apex::Shape
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::EffectPackageActor
, nvidia::apex::AssetPreview
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::GroundEmitterActor
, nvidia::apex::ForceFieldActor
  • getPosition()
: nvidia::apex::RenderVolume
, nvidia::apex::ClothingSphere
  • getPreviousOrigin() : nvidia::apex::HalfSpaceShape
  • getPreviousPose() : nvidia::apex::Shape
  • getPriority() : nvidia::apex::RenderVolume
  • getProjMatrix() : nvidia::apex::Scene
  • getRadius()
: nvidia::apex::EmitterGeomSphereShell
, nvidia::apex::GroundEmitterAsset
, nvidia::apex::SphereShape
, nvidia::apex::EmitterGeomCylinder
, nvidia::apex::GroundEmitterActor
, nvidia::apex::EmitterGeomSphere
, nvidia::apex::ClothingSphere
  • getRate()
: nvidia::apex::EmitterActor
, nvidia::apex::EmitterAsset
  • getRateScale() : nvidia::apex::ModuleEmitter
  • getRaycastCollisionGroupMaskName() : nvidia::apex::GroundEmitterAsset
  • getRaycastCollisionGroups() : nvidia::apex::GroundEmitterActor
  • getRaycastHeight()
: nvidia::apex::GroundEmitterAsset
, nvidia::apex::GroundEmitterActor
  • getRefCount()
: nvidia::apex::ClothingSphere
, nvidia::apex::ClothingPlane
  • getRenderBuffer()
: nvidia::apex::Scene
, nvidia::apex::RenderDebugInterface
  • getRenderBufferScreenSpace()
: nvidia::apex::Scene
, nvidia::apex::RenderDebugInterface
  • getRenderData() : nvidia::apex::TurbulenceRenderable
  • getRenderDebugInterface() : nvidia::apex::RenderDebugInterface
  • getRenderGlobalPose() : nvidia::apex::ClothingActor
  • getRenderLockMode() : nvidia::apex::Module
  • getRenderMeshActor()
: nvidia::apex::DestructiblePreview
, nvidia::apex::DestructibleRenderable
, nvidia::apex::DestructibleActor
  • getRenderMeshAsset()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::ClothingAsset
  • getRenderMeshAssetAuthoring() : nvidia::apex::ClothingAssetAuthoring
  • getResource() : nvidia::apex::ResourceProvider
  • getResourceNames() : nvidia::apex::ModuleParticles
  • getRestDensity()
: nvidia::apex::BasicIosActor
, nvidia::apex::BasicIosAsset
  • getResultCount() : NvParameterized::ParameterList
  • getResults() : NvParameterized::ParameterList
  • getRollType() : nvidia::apex::RotationModifier
  • getRotationRange() : nvidia::apex::RandomRotationModifier
  • getRotationRate() : nvidia::apex::RotationRateModifier
  • getScale()
: nvidia::apex::DestructibleActor
, nvidia::apex::ForceFieldActor
  • getScaleAxis()
: nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
  • getScaleChangeDelay() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • getScaleChangeLimit() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • getScaleFactor()
: nvidia::apex::SimpleScaleModifier
, nvidia::apex::ScaleAlongVelocityModifier
, nvidia::apex::RandomScaleModifier
  • getScalePerVelocity() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • getScaleUpperBound() : nvidia::apex::IofxAsset
  • getScatterMeshAssetCount()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • getScatterMeshAssets()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • getSemantic()
: nvidia::apex::RenderSpriteLayoutElement
, nvidia::apex::RenderInstanceLayoutElement
  • getSemanticData() : nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >
  • getSemanticFormat()
: nvidia::apex::RenderInstanceLayoutElement
, nvidia::apex::RenderSpriteLayoutElement
  • getSemanticID() : nvidia::apex::VertexFormat
  • getSemanticName() : nvidia::apex::VertexFormat
  • getSerializePlatform() : nvidia::apex::ApexSDK
  • getSerializeType() : nvidia::apex::ApexSDK
  • getSetNames() : nvidia::apex::ImpactEmitterAsset
  • getShape()
: nvidia::apex::SubstanceSourceActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::VelocitySourceActor
  • getShellThickness() : nvidia::apex::EmitterGeomSphereShell
  • getShowFullInfo() : nvidia::apex::AssetPreviewScene
  • getSimParticlesCount() : nvidia::apex::EmitterActor
  • getSimulationNormals() : nvidia::apex::ClothingActor
  • getSimulationPositions() : nvidia::apex::ClothingActor
  • getSimulationVelocities() : nvidia::apex::ClothingActor
  • getSize() : nvidia::apex::BoxShape
  • getSmoothingGroups() : nvidia::apex::RenderSubmesh
  • getSolidShadedMaterial() : nvidia::apex::ApexSDK
  • getSpawnHeight()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::GroundEmitterAsset
  • getSpawnModifiers() : nvidia::apex::IofxAsset
  • getSphereCenter() : nvidia::apex::EmitterGeomExplicit
  • getSphereCount() : nvidia::apex::EmitterGeomExplicit
  • getSphereList() : nvidia::apex::EmitterGeomExplicit
  • getSphereRadius() : nvidia::apex::EmitterGeomExplicit
  • getSpheres() : nvidia::apex::ClothingCapsule
  • getSphereShape()
: nvidia::apex::SubstanceSourceActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::HeatSourceActor
  • getSpriteBuffer() : nvidia::apex::UserRenderResource
  • getSpriteLayoutData() : nvidia::apex::UserRenderResourceManager
  • getSpriteMaterialName() : nvidia::apex::IofxAsset
  • getSpriteRenderData() : nvidia::apex::IofxRenderable
  • getStats()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::RenderMeshAssetAuthoring
, nvidia::apex::ClothingPhysicalMesh
, nvidia::apex::RenderMeshAsset
, nvidia::apex::Scene
  • getStdDensity() : nvidia::apex::SubstanceSourceActor
  • getStdTemperature() : nvidia::apex::HeatSourceActor
  • getStdVelocity() : nvidia::apex::VelocitySourceActor
  • getSubmesh()
: nvidia::apex::RenderMeshAsset
, nvidia::apex::RenderMeshAssetAuthoring
  • getSubmeshCount()
: nvidia::apex::RenderMeshAsset
, nvidia::apex::RenderMeshAssetAuthoring
  • getSubmeshWritable() : nvidia::apex::RenderMeshAssetAuthoring
  • getSubstanceSourceAsset() : nvidia::apex::SubstanceSourceActor
  • getSubtextureRange() : nvidia::apex::RandomSubtextureModifier
  • getSupportDepth() : nvidia::apex::DestructibleActor
  • getSupportDepthChunkIndices() : nvidia::apex::DestructibleActor
  • getSupportsDensity() : nvidia::apex::IosAsset
  • getTaskManager() : nvidia::apex::Scene
  • getTestBase()
: nvidia::apex::ModuleTurbulenceFS
, nvidia::apex::ModuleBasicIos
, nvidia::apex::ModuleIofx
  • getTexts() : nvidia::apex::PhysXRenderBuffer
  • getTM() : nvidia::apex::RenderMeshActor
  • getTriangles() : nvidia::apex::PhysXRenderBuffer
  • getTurbulenceFSAsset() : nvidia::apex::TurbulenceFSActor
  • getTurbulenceRenderCallback() : nvidia::apex::ModuleTurbulenceFS
  • getTurbulenceRenderLayout() : nvidia::apex::TurbulenceRenderCallback
  • getType()
: nvidia::apex::UserRenderBuffer
, nvidia::apex::ClothingCollision
, nvidia::apex::UserRenderSurface
, nvidia::apex::IofxRenderable
, nvidia::apex::UserRenderStorage
  • getUnitTestsCount() : nvidia::apex::TestBase
  • getUnitTestsIndex() : nvidia::apex::TestBase
  • getUnitTestsName() : nvidia::apex::TestBase
  • getUpdatesPerFrame() : nvidia::apex::TurbulenceFSActor
  • getUseDensity() : nvidia::apex::TurbulenceFSActor
  • getUseEmitterPool() : nvidia::apex::ModuleParticles
  • getUseFlame() : nvidia::apex::TurbulenceFSActor
  • getUserData() : nvidia::apex::UserRenderDataHolder
  • getUserDefinedFlag() : nvidia::apex::PhysXObjectDesc
  • getVelocity0() : nvidia::apex::ColorVsVelocityModifier
  • getVelocity1() : nvidia::apex::ColorVsVelocityModifier
  • getVelocityField() : nvidia::apex::TurbulenceFSActor
  • getVelocityHigh()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterAsset
  • getVelocityLow()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterAsset
  • getVelocitySourceAsset() : nvidia::apex::VelocitySourceActor
  • getVersion() : NvParameterized::Factory
  • getVertex()
: nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
, nvidia::apex::CustomBufferIterator
  • getVertexAttribute() : nvidia::apex::CustomBufferIterator
  • getVertexBuffer()
: nvidia::apex::UserRenderResource
, nvidia::apex::RenderSubmesh
  • getVertexBufferWritable() : nvidia::apex::RenderSubmesh
  • getVertexCount()
: nvidia::apex::RenderSubmesh
, nvidia::apex::VertexBuffer
, nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getVertices() : nvidia::apex::ClothingPhysicalMesh
  • getViewMatrix() : nvidia::apex::Scene
  • getVisibilities() : nvidia::apex::RenderMeshActor
  • getVisibleChunks() : nvidia::apex::DestructibleActor
  • getVisibleCount() : nvidia::apex::IofxActor
  • getVisibleParts() : nvidia::apex::RenderMeshActor
  • getVolume() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getVolumeRenderMaterialName() : nvidia::apex::TurbulenceFSActor
  • getVortexFSAsset() : nvidia::apex::VortexFSActor
  • getWindFSAsset() : nvidia::apex::WindFSActor
  • getWinding() : nvidia::apex::VertexFormat
  • getWindingOrder() : nvidia::apex::RenderMeshAssetAuthoring
  • getWireframeMaterial() : nvidia::apex::ApexSDK
  • glass : nvidia::apex::DestructibleRTFractureParameters
  • globalAnchor : nvidia::apex::DestructibleActorJointDesc
  • globalAxis : nvidia::apex::DestructibleActorJointDesc
  • globalNormal : nvidia::apex::DestructibleActorJointDesc
  • gridSize : FractureTools::NoiseParameters
  • GroupsMask64() : nvidia::apex::GroupsMask64
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HALF1 : nvidia::apex::RenderDataFormat
  • HALF2 : nvidia::apex::RenderDataFormat
  • HALF3 : nvidia::apex::RenderDataFormat
  • HALF4 : nvidia::apex::RenderDataFormat
  • Handle() : NvParameterized::Handle
  • hasSeparateBoneBuffer() : nvidia::apex::VertexFormat
  • hasSimulatedData() : nvidia::apex::ClothingRenderProxy
  • hasUserFlagSet() : nvidia::apex::DestructibleDepthParameters
  • hasVolumeRenderMaterial() : nvidia::apex::EffectPackageActor
  • height
: nvidia::apex::UserRenderSpriteTextureDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
, nvidia::apex::UserRenderSurfaceDesc
  • heightSurfaceBuffers : nvidia::apex::UserRenderResourceDesc
  • hierarchicallySplitChunk()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • hint
: nvidia::apex::UserRenderVertexBufferDesc
, nvidia::apex::UserRenderIndexBufferDesc
, nvidia::apex::UserRenderBoneBufferDesc
, NvParameterized::Definition
, nvidia::apex::UserRenderInstanceBufferDesc
, NvParameterized::Definition
, nvidia::apex::UserRenderSpriteBufferDesc
  • hitChunkFlags : nvidia::apex::DestructibleHitChunk
  • hitDirection : nvidia::apex::DamageEventReportData
  • hitPosition : nvidia::apex::DamageEventReportData
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • ident : nvidia::apex::RenderSemanticData
  • IGNORE_CONTACT_CALLBACKS : nvidia::apex::DestructibleDepthParametersFlag
  • IGNORE_POSE_UPDATES : nvidia::apex::DestructibleDepthParametersFlag
  • IGNORE_RAYCAST_CALLBACKS : nvidia::apex::DestructibleDepthParametersFlag
  • ignoreContacts() : nvidia::apex::PhysXObjectDesc
  • ignoreRaycasts() : nvidia::apex::PhysXObjectDesc
  • ignoresContactCallbacks() : nvidia::apex::DestructibleDepthParameters
  • ignoresPoseUpdates() : nvidia::apex::DestructibleDepthParameters
  • ignoresRaycastCallbacks() : nvidia::apex::DestructibleDepthParameters
  • ignoreTransform() : nvidia::apex::PhysXObjectDesc
  • impactDamageActor : nvidia::apex::DamageEventReportData , nvidia::apex::ImpactDamageEventData
  • impactDamageDefaultDepth : nvidia::apex::DestructibleParameters
  • impactVelocityThreshold : nvidia::apex::DestructibleParameters
  • importDestructibleAssetToRootMesh() : nvidia::apex::DestructibleAssetAuthoring
  • importRenderMeshAssetToRootMesh() : nvidia::apex::DestructibleAssetAuthoring
  • impulse : nvidia::apex::FractureEventUnit
  • impulseScale : nvidia::apex::DestructibleRTFractureParameters
  • incRefCount() : NvParameterized::Traits
  • index : nvidia::apex::ChunkData , NvParameterized::Handle
  • indexBuffer : nvidia::apex::UserRenderResourceDesc
  • indexBufferBytes : nvidia::apex::RenderMeshAssetStats
  • indexBufferHint : nvidia::apex::RenderMeshActorDesc
  • indexCount : nvidia::apex::RenderMeshAssetStats
  • init()
: nvidia::apex::Module
, NvParameterized::Serializer::DeserializedResults< T, bufSize >
  • initDefaults() : NvParameterized::Interface
  • initializeDefaultDatabases() : nvidia::apex::ModuleParticles
  • initParamRef()
: NvParameterized::Interface
, NvParameterized::Handle
  • initRandom() : NvParameterized::Interface
  • instanceBuffer : nvidia::apex::UserRenderResourceDesc
  • instanceChunks : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • instancedPositionOffset() : nvidia::apex::ExplicitHierarchicalMesh
  • instancedUVOffset() : nvidia::apex::ExplicitHierarchicalMesh
  • instancePositionOffset : nvidia::apex::DestructibleChunkDesc
  • instanceUVOffset : nvidia::apex::DestructibleChunkDesc
  • InstancingMode : FractureTools::FractureCutoutDesc
  • instancingMode : FractureTools::FractureCutoutDesc
  • interiorSubmeshIndex : nvidia::apex::FractureMaterialDesc
  • interopContext
: nvidia::apex::UserRenderIndexBufferDesc
, nvidia::apex::UserRenderInstanceBufferDesc
, nvidia::apex::UserRenderSpriteBufferDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
, nvidia::apex::UserRenderVertexBufferDesc
  • interopFlags : nvidia::apex::UserRenderBufferDesc , nvidia::apex::UserRenderSurfaceDesc
  • intersectAgainstAABB()
: nvidia::apex::Shape
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::VelocitySourceActor
  • INVALID_CHUNK_INDEX : nvidia::apex::ModuleDestructibleConst
  • invalidateBounds() : nvidia::apex::ModuleDestructible
  • isAlive() : nvidia::apex::EffectPackageActor
  • isBoxGeom()
: nvidia::apex::EmitterGeom
, nvidia::apex::Shape
  • isCapsule() : nvidia::apex::ClothingCollision
  • isCapsuleGeom() : nvidia::apex::Shape
  • isCaseSensitive() : nvidia::apex::ResourceProvider
  • isChunkDestroyed() : nvidia::apex::DestructibleActor
  • isChunkSolitary() : nvidia::apex::DestructibleActor
  • isComplete() : NvParameterized::ParameterFind
  • isConcurrencyCheckEnabled() : nvidia::apex::ApexSDK
  • isConst() : NvParameterized::Handle
  • isConvex() : nvidia::apex::ClothingCollision
  • isCylinderGeom() : nvidia::apex::EmitterGeom
  • isDestructibleActorJointActive() : nvidia::apex::ModuleDestructible
  • isDigit() : NvParameterized::ParameterFind
  • isDirty() : nvidia::apex::Asset
  • isDynamic() : nvidia::apex::DestructibleActor
  • isEffectEnabled() : nvidia::apex::EffectPackageActor
  • isEmitting() : nvidia::apex::EmitterActor
  • isEnable() : nvidia::apex::ForceFieldActor
  • isEnabled()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::HeatSourceActor
  • isExplicitGeom()
: nvidia::apex::EmitterActor
, nvidia::apex::EmitterAsset
, nvidia::apex::EmitterGeom
  • isFrozen() : nvidia::apex::ClothingActor
  • isHalfPrecisionAllowed() : nvidia::apex::ClothingActor
  • isHalfSpaceGeom() : nvidia::apex::Shape
  • isHardSleepingEnabled() : nvidia::apex::DestructibleActor
  • isIncludedRef() : NvParameterized::Definition
  • isInitiallyDynamic() : nvidia::apex::DestructibleActor
  • islandGeneration : FractureTools::MeshProcessingParameters
  • isLeaf() : NvParameterized::Definition
  • isPeriodic() : FractureTools::CutoutSet
  • isPlane() : nvidia::apex::ClothingCollision
  • isRecursive() : NvParameterized::ParameterList
  • isRuntimeFractureShape() : nvidia::apex::ModuleDestructible
  • isScreenSpace : nvidia::apex::RenderContext
  • isSimpleType() : NvParameterized::Definition
  • isSphere() : nvidia::apex::ClothingCollision
  • isSphereGeom()
: nvidia::apex::Shape
, nvidia::apex::EmitterGeom
  • isSphereShellGeom() : nvidia::apex::EmitterGeom
  • isStillEmitting() : nvidia::apex::EffectPackageActor
  • isSupportChunk : nvidia::apex::DestructibleChunkDesc
  • isTetrahedralMesh() : nvidia::apex::ClothingPhysicalMesh
  • isTheSameAs()
: nvidia::apex::UserRenderSurfaceDesc
, nvidia::apex::IofxMeshRenderLayout
, nvidia::apex::UserRenderSpriteTextureDesc
, nvidia::apex::IofxSpriteRenderLayout
, nvidia::apex::UserRenderBufferDesc
, nvidia::apex::UserRenderSpriteBufferDesc
, nvidia::apex::UserRenderInstanceBufferDesc
  • isTriangleMesh() : nvidia::apex::ClothingCollision
  • isValid()
: nvidia::apex::DestructibleBehaviorGroupDesc
, nvidia::apex::UserRenderResourceDesc
, nvidia::apex::UserRenderBoneBufferDesc
, NvParameterized::Handle
, nvidia::apex::RenderMeshActorDesc
, nvidia::apex::EmitterLodParamDesc
, nvidia::apex::UserRenderInstanceBufferDesc
, nvidia::apex::ApexDesc
, nvidia::apex::RenderMeshAssetAuthoring::MeshDesc
, nvidia::apex::UserRenderSpriteBufferDesc
, nvidia::apex::UserRenderSurfaceDesc
, nvidia::apex::DamageSpreadFunction
, nvidia::apex::UserRenderVertexBufferDesc
, nvidia::apex::IofxSpriteRenderLayout
, nvidia::apex::UserRenderIndexBufferDesc
, nvidia::apex::DestructibleChunkDesc
, nvidia::apex::UserRenderBufferDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
, nvidia::apex::DestructibleActorJointDesc
, nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
, nvidia::apex::DestructibleAssetCookingDesc
, nvidia::apex::DestructibleGeometryDesc
, nvidia::apex::ApexSDKDesc
, nvidia::apex::IofxMeshRenderLayout
  • isValidForActorCreation() : nvidia::apex::Asset
  • isVisible()
: nvidia::apex::ClothingActor
, nvidia::apex::RenderMeshActor
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • padding() : NvParameterized::Definition
  • parameterDefinition()
: NvParameterized::Handle
, NvParameterized::Interface
  • ParameterFind() : NvParameterized::ParameterFind
  • ParameterList() : NvParameterized::ParameterList
  • ParamResult() : NvParameterized::ParamResult
  • parent() : NvParameterized::Definition
  • parentIndex : nvidia::apex::DestructibleChunkDesc , nvidia::apex::ExplicitHierarchicalMesh
  • partCount : nvidia::apex::RenderMeshAssetStats , nvidia::apex::ExplicitHierarchicalMesh
  • partIndex : nvidia::apex::RenderMeshActorRaycastHitData , nvidia::apex::ExplicitHierarchicalMesh
  • partitionMeshByIslands() : nvidia::apex::DestructibleAssetAuthoring
  • pData : nvidia::apex::UserRenderSurface::MappedInfo
  • peekClassNames() : NvParameterized::Serializer
  • peekInplaceAlignment() : NvParameterized::Serializer
  • peekNumObjects() : NvParameterized::Serializer
  • peekNumObjectsInplace() : NvParameterized::Serializer
  • peekPlatform() : NvParameterized::Serializer
  • peekSerializeType() : NvParameterized::Serializer
  • PER_ACTOR_RENDER_LOCK : nvidia::apex::RenderLockMode
  • PER_MODULE_SCENE_RENDER_LOCK : nvidia::apex::RenderLockMode
  • physX3Interface : nvidia::apex::SceneDesc
  • physXObjDescTableAllocationIncrement : nvidia::apex::ApexSDKDesc
  • physXSDK : nvidia::apex::ApexSDKDesc
  • physXSDKVersion : nvidia::apex::ApexSDKDesc
  • pitchBytes : nvidia::apex::UserRenderSpriteTextureDesc
  • polarRadius : nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • popIndex() : NvParameterized::Handle
  • popNameMatch()
: NvParameterized::ParameterList
, NvParameterized::ParameterFind
  • POSE : nvidia::apex::RenderBoneSemantic , nvidia::apex::RenderInstanceSemantic
  • position : nvidia::apex::DamageEventCoreData
  • POSITION : nvidia::apex::RenderVertexSemantic
  • position
: nvidia::apex::DamageEventUnit
, nvidia::apex::FractureEventUnit
, nvidia::apex::EmitterGeomExplicit::PointParams
  • POSITION
: nvidia::apex::IofxRenderSemantic
, nvidia::apex::RenderInstanceSemantic
, nvidia::apex::RenderSpriteSemantic
  • position : nvidia::apex::Vertex
  • POSITION_FLOAT4 : nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
  • positionBary : nvidia::apex::ClothingMeshSkinningMap
  • positionCount : nvidia::apex::ChunkParticleReportData
  • positions : nvidia::apex::ChunkParticleReportData
  • positionStart : nvidia::apex::EmitterGeomExplicit::PointListData
  • positionStrideBytes : nvidia::apex::EmitterGeomExplicit::PointListData
  • posX : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • posY : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • posZ : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • prepareForPlatform() : nvidia::apex::AssetAuthoring
  • prepareMorphTargetMapping() : nvidia::apex::ClothingAsset
  • prepareRenderables()
: nvidia::apex::ModuleIofx
, nvidia::apex::ModuleTurbulenceFS
  • preSerialize() : NvParameterized::SerializationCallback
  • PREVIOUS_POSE : nvidia::apex::RenderBoneSemantic
  • primitives : nvidia::apex::UserRenderResourceDesc , nvidia::apex::UserRenderIndexBufferDesc
  • pushName() : NvParameterized::ParameterList
  • pushNameMatch() : NvParameterized::ParameterFind
  • pvd : nvidia::apex::ApexSDKDesc
  • PxStreamFromFileBuf() : nvidia::apex::PxStreamFromFileBuf
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • querySetID() : nvidia::apex::ImpactEmitterAsset
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • r : nvidia::apex::VertexColor , nvidia::apex::ColorRGBA
  • R32G32B32A32_FLOAT : nvidia::apex::RenderDataFormat
  • R8G8B8A8 : nvidia::apex::RenderDataFormat
  • radius
: nvidia::apex::EmitterGeomExplicit::EllipsoidParams
, nvidia::apex::DamageEventCoreData
, nvidia::apex::DamageEventUnit
, nvidia::apex::EmitterGeomExplicit::SphereParams
  • radiusMultiplier : nvidia::apex::DamageSpreadFunction
  • Range() : nvidia::apex::Range< T >
  • rayCast()
: nvidia::apex::ClothingActor
, nvidia::apex::DestructibleActor
, nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
, nvidia::apex::RenderMeshActor
  • RAYCASTS : nvidia::apex::PhysXObjectDesc
  • read() : nvidia::apex::PxStreamFromFileBuf
  • ReadLock() : nvidia::apex::ReadLock
  • rebuildCollisionGeometry() : nvidia::apex::DestructibleAsset
  • recreateApexEmitter() : nvidia::apex::DestructibleActor
  • reduceHull() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • reduceHulls() : nvidia::apex::ExplicitHierarchicalMesh
  • refCount : NvParameterized::WrappedNamedReference
  • referenceCallback()
: NvParameterized::ReferenceInterface
, NvParameterized::WrappedNamedReference
  • refresh() : nvidia::apex::EffectPackageActor
  • refVariantVal() : NvParameterized::Definition
  • refVariantValIndex() : NvParameterized::Definition
  • registerCallback() : nvidia::apex::ResourceProvider
  • registerConversion() : NvParameterized::Traits
  • registerFactory() : NvParameterized::Traits
  • registerImpact() : nvidia::apex::ImpactEmitterActor
  • registerInCUDA
: nvidia::apex::UserRenderIndexBufferDesc
, nvidia::apex::UserRenderInstanceBufferDesc
, nvidia::apex::UserRenderSpriteBufferDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
, nvidia::apex::UserRenderVertexBufferDesc
  • release()
: nvidia::apex::PhysX3DescTemplate
, nvidia::apex::ApexInterface
, nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
, nvidia::apex::ExplicitHierarchicalMesh
, FractureTools::CutoutSet
, nvidia::apex::MirrorScene
, NvParameterized::Conversion
, NvParameterized::Traits
, NvParameterized::Serializer
, nvidia::apex::EffectPackageActor
, nvidia::apex::RenderDebugInterface
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::UserRenderData
, nvidia::apex::UserRenderStorage
  • releaseActor() : nvidia::apex::RenderMeshAsset
  • releaseAll() : NvParameterized::Serializer::DeserializedResults< T, bufSize >
  • releaseAllResourcesInNamespace() : nvidia::apex::ResourceProvider
  • releaseAndReturnNvParameterizedInterface()
: nvidia::apex::Asset
, nvidia::apex::AssetAuthoring
  • releaseApexRenderDebug() : nvidia::apex::ApexSDK
  • releaseApexShape()
: nvidia::apex::ApexSDK
, nvidia::apex::Shape
  • releaseAsset() : nvidia::apex::ApexSDK
  • releaseAssetAuthoring() : nvidia::apex::ApexSDK
  • releaseAssetPreviewScene() : nvidia::apex::ApexSDK
  • releaseBoneBuffer() : nvidia::apex::UserRenderResourceManager
  • releaseChunkEventBuffer() : nvidia::apex::DestructibleActor
  • releaseDestructibleActor() : nvidia::apex::DestructibleAsset
  • releaseForceFieldActor() : nvidia::apex::ForceFieldAsset
  • releaseForceSampleBatch() : nvidia::apex::ModuleFieldSampler
  • releaseGraphicalData() : nvidia::apex::ClothingAsset
  • releaseIndexBuffer() : nvidia::apex::UserRenderResourceManager
  • releaseInstanceBuffer() : nvidia::apex::UserRenderResourceManager
  • releaseIosActor() : nvidia::apex::IosAsset
  • releaseLoadedModules() : nvidia::apex::ModuleLoader
  • releaseMemoryReadStream() : nvidia::apex::ApexSDK
  • releaseMemoryWriteStream() : nvidia::apex::ApexSDK
  • releaseModule()
: nvidia::apex::ApexSDK
, nvidia::apex::ModuleLoader
  • releaseModules() : nvidia::apex::ModuleLoader
  • releaseOnNoChunksVisible() : nvidia::apex::UserChunkReport
  • releasePhysXActorBuffer() : nvidia::apex::DestructibleActor
  • releaseReadLock() : nvidia::apex::RWLockable
  • releaseRenderableIterator() : nvidia::apex::Context
  • releaseRenderVolume() : nvidia::apex::ModuleIofx
  • releaseResource()
: nvidia::apex::ResourceCallback
, nvidia::apex::ResourceProvider
, nvidia::apex::UserRenderResourceManager
  • releaseScene() : nvidia::apex::ApexSDK
  • releaseSpriteBuffer() : nvidia::apex::UserRenderResourceManager
  • releaseSurfaceBuffer() : nvidia::apex::UserRenderResourceManager
  • releaseVertexBuffer() : nvidia::apex::UserRenderResourceManager
  • releaseWithPlanes() : nvidia::apex::ClothingConvex
  • releaseWithSpheres() : nvidia::apex::ClothingCapsule
  • releaseWriteLock() : nvidia::apex::RWLockable
  • remapBoneIndex() : nvidia::apex::ClothingAsset
  • removeActorPair() : nvidia::apex::Scene
  • removeAllActors() : nvidia::apex::Context
  • removeAllBoundingBoxes() : nvidia::apex::Scene
  • removeBoundingBox() : nvidia::apex::Scene
  • removeChunkOverlaps()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • removeConversion() : NvParameterized::Traits
  • removeFactory() : NvParameterized::Traits
  • removePlatform() : nvidia::apex::ClothingAssetAuthoring
  • removePlatformMaxDepth() : nvidia::apex::DestructibleAssetAuthoring
  • removeTJunctions : FractureTools::MeshProcessingParameters
  • removeTriangle() : nvidia::apex::ClothingTriangleMesh
  • removeTriangles() : nvidia::apex::ClothingTriangleMesh
  • RenderMeshActorDesc() : nvidia::apex::RenderMeshActorDesc
  • renderMeshActorLoadMaterialsLazily : nvidia::apex::ApexSDKDesc
  • renderMeshAssetStats : nvidia::apex::DestructibleAssetStats
  • renderMeshName : nvidia::apex::RenderContext
  • RenderMeshPartData() : nvidia::apex::RenderMeshPartData
  • renderResource
: nvidia::apex::IofxCommonRenderData
, nvidia::apex::RenderContext
, nvidia::apex::UserRenderer
  • renderResourceManager : nvidia::apex::ApexSDKDesc
  • renderResourceName : nvidia::apex::IofxCommonRenderData
  • renderResourceNameSpace : nvidia::apex::IofxCommonRenderData
  • renderWithoutSkinning : nvidia::apex::RenderMeshActorDesc
  • replaceInteriorSubmeshes() : nvidia::apex::ExplicitHierarchicalMesh
  • requestMaterialLookups() : nvidia::apex::MaterialLookupCallback
  • requestResource() : nvidia::apex::ResourceCallback
  • reset()
: nvidia::apex::RenderableIterator
, nvidia::apex::VertexFormat
, NvParameterized::Handle
  • resetEmitterPool() : nvidia::apex::ModuleParticles
  • resetParticleList() : nvidia::apex::EmitterGeomExplicit
  • resizeArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • resourceCallback : nvidia::apex::ApexSDKDesc
  • resourceProviderIsCaseSensitive : nvidia::apex::ApexSDKDesc
  • reviseMirrorActor() : nvidia::apex::MirrorScene::MirrorFilter
  • reviseMirrorShape() : nvidia::apex::MirrorScene::MirrorFilter
  • root() : NvParameterized::Definition
  • rootParameterDefinition() : NvParameterized::Interface
  • ROTATION : nvidia::apex::IofxRenderSemantic
  • ROTATION_SCALE : nvidia::apex::RenderInstanceSemantic
  • rowPitch : nvidia::apex::UserRenderSurface::MappedInfo
  • RTFractureBehaviorGroup : nvidia::apex::DestructibleAssetCookingDesc
  • rtFractureParameters : nvidia::apex::DestructibleParameters
  • run() : nvidia::apex::TestFunctionInterface
  • runGpu() : nvidia::apex::TestFunctionInterface
  • runKernel() : nvidia::apex::CudaTestManager
  • runtimeCookedConvexCount : nvidia::apex::DestructibleAssetStats
  • runtimeFracture : nvidia::apex::DestructibleChunkDesc
  • runUnitTests() : nvidia::apex::TestBase
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • samplePosition : nvidia::apex::MaterialLookupCallback::MaterialRequest
  • SCALE : nvidia::apex::IofxRenderSemantic , nvidia::apex::RenderSpriteSemantic
  • SCALE_ORIENT_SUBTEX_FLOAT4 : nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
  • scatterMeshCount : nvidia::apex::DestructibleChunkDesc
  • scatterMeshIndices : nvidia::apex::DestructibleChunkDesc
  • scatterMeshTransforms : nvidia::apex::DestructibleChunkDesc
  • scene : nvidia::apex::SceneDesc
  • scheduleChunkStateEventCallback() : nvidia::apex::ModuleDestructible
  • ScopedPhysXLockRead() : nvidia::apex::ScopedPhysXLockRead
  • ScopedPhysXLockWrite() : nvidia::apex::ScopedPhysXLockWrite
  • sectorRand : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • SegmentIntersect : nvidia::apex::DestructibleActorRaycastFlags
  • segmentRand : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • segmentScale : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • semanticOffsets : nvidia::apex::UserRenderInstanceBufferDesc , nvidia::apex::UserRenderSpriteBufferDesc
  • separationWeight : nvidia::apex::EmitterLodParamDesc
  • serialize
: nvidia::apex::RenderSemanticData
, nvidia::apex::ApexSDKCachedData
, nvidia::apex::ExplicitHierarchicalMesh::Embedding
, nvidia::apex::ExplicitHierarchicalMesh
, NvParameterized::Serializer
  • serializeFractureToolState() : nvidia::apex::DestructibleAssetAuthoring
  • SerializePlatform() : NvParameterized::SerializePlatform
  • serializeSingleAsset() : nvidia::apex::ModuleCachedData
  • SerializeType : NvParameterized::Serializer
  • set()
: NvParameterized::Handle
, nvidia::apex::VertexColor
, nvidia::apex::VertexUV
, nvidia::apex::ExplicitHierarchicalMesh
, NvParameterized::Handle
  • setAngularVelocity() : nvidia::apex::DestructibleActor
  • setAngularVelocityMultiplierAndClamp() : nvidia::apex::TurbulenceFSActor
  • setApexEmitterValidateCallback()
: nvidia::apex::EmitterActor
, nvidia::apex::EffectPackageActor
  • setArraySize() : NvParameterized::Definition
  • setAsUInt() : NvParameterized::Hint
  • setAttachActor()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
  • setAttachRelativePose() : nvidia::apex::EmitterActor
  • setAttachRelativePosition() : nvidia::apex::GroundEmitterActor
  • setAutoUpdate() : NvParameterized::Serializer
  • setAxis() : nvidia::apex::VortexFSActor
  • setBoneBindPose() : nvidia::apex::ClothingAssetAuthoring
  • setBoneBufferRange() : nvidia::apex::UserRenderResource
  • setBoneInfo() : nvidia::apex::ClothingAssetAuthoring
  • setBottomRadius() : nvidia::apex::VortexFSActor
  • setBottomSphericalForce() : nvidia::apex::VortexFSActor
  • setBSPBuildParameters()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • setBSPTolerances()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • setBufferAccess() : nvidia::apex::VertexFormat
  • setBufferFormat() : nvidia::apex::VertexFormat
  • setBufferSerialize() : nvidia::apex::VertexFormat
  • setBufferVisibility() : nvidia::apex::RenderMeshActor
  • setCallPerFrameMaxCount() : nvidia::apex::CudaTestManager
  • setCameraMatrix() : nvidia::apex::AssetPreviewScene
  • setChildren() : NvParameterized::Definition
  • setChunkCollisionHullCookingScale() : nvidia::apex::ModuleDestructible
  • setChunkCrumbleReport() : nvidia::apex::ModuleDestructible
  • setChunkDustReport() : nvidia::apex::ModuleDestructible
  • setChunkOverlapsCacheDepth() : nvidia::apex::DestructibleAssetAuthoring
  • setChunkPhysXActorAwakeState() : nvidia::apex::DestructibleActor
  • setChunkReport() : nvidia::apex::ModuleDestructible
  • setChunkReportBitMask() : nvidia::apex::ModuleDestructible
  • setChunkReportMaxFractureEventDepth() : nvidia::apex::ModuleDestructible
  • setClassName() : NvParameterized::Interface
  • setClothingMaterial() : nvidia::apex::ClothingActor
  • setCollision() : nvidia::apex::ClothingAssetAuthoring
  • setCollisionGroupMaskName()
: nvidia::apex::BasicIosAssetAuthoring
, nvidia::apex::ParticleIosAssetAuthoring
  • setCollisionGroupName()
: nvidia::apex::BasicIosAssetAuthoring
, nvidia::apex::ParticleIosAssetAuthoring
  • setColorChannel()
: nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::ColorVsVelocityModifier
  • setConstFieldStrength() : nvidia::apex::AttractorFSActor
  • setContactReportFlags() : nvidia::apex::PhysX3Interface
  • setCoreMesh() : nvidia::apex::DestructibleAssetAuthoring
  • setCrumbleEmitterName() : nvidia::apex::DestructibleAssetAuthoring
  • setCrumbleEmitterState() : nvidia::apex::DestructibleActor
  • setCudaKernelCheckEnabled() : nvidia::apex::Scene
  • setCurrentPose()
: nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::EmitterActor
  • setCurrentPosition()
: nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::EmitterActor
  • setCurrentScale()
: nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::EmitterActor
, nvidia::apex::ForceFieldActor
, nvidia::apex::EffectPackageActor
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::VelocitySourceActor
  • setCustomFilterShader() : nvidia::apex::ModuleTurbulenceFS
  • setCustomSemanticData() : nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >
  • setCustomTimestep() : nvidia::apex::ModuleTurbulenceFS
  • setDamageApplicationRaycastFlags() : nvidia::apex::ModuleDestructible
  • setDefaultConstrainCoefficients() : nvidia::apex::ClothingAssetAuthoring
  • setDefaults()
: nvidia::apex::IofxSpriteRenderLayout
, nvidia::apex::IofxMeshRenderLayout
, nvidia::apex::TurbulenceRenderLayout
, nvidia::apex::UserRenderBufferDesc
, nvidia::apex::UserRenderSurfaceDesc
, nvidia::apex::UserRenderInstanceBufferDesc
, nvidia::apex::UserRenderSpriteBufferDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
  • setDeleteFracturedChunks() : nvidia::apex::DestructibleActor
  • setDensity()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
, nvidia::apex::SubstanceSourceActor
  • setDensityBasedParameters() : nvidia::apex::TurbulenceFSActor
  • setDensityGridPosition() : nvidia::apex::EmitterActor
  • setDensityScale() : nvidia::apex::ModuleEmitter
  • setDensityTextureRange() : nvidia::apex::TurbulenceFSActor
  • setDeriveNormalsFromBones() : nvidia::apex::ClothingAssetAuthoring
  • setDestructibleInitParameters() : nvidia::apex::DestructibleAssetAuthoring
  • setDestructibleParameters()
: nvidia::apex::DestructibleActor
, nvidia::apex::DestructibleAssetAuthoring
  • setDestructiblePhysXActorReport() : nvidia::apex::ModuleDestructible
  • setDetailLevel()
: nvidia::apex::AttractorFSPreview
, nvidia::apex::JetFSPreview
, nvidia::apex::NoiseFSPreview
, nvidia::apex::VortexFSPreview
, nvidia::apex::WindFSPreview
, nvidia::apex::ForceFieldPreview
, nvidia::apex::ParticlesPreview
, nvidia::apex::TurbulenceFSPreview
  • setDimensions() : nvidia::apex::CapsuleShape
  • setDustEmitterName() : nvidia::apex::DestructibleAssetAuthoring
  • setDustEmitterState() : nvidia::apex::DestructibleActor
  • setDynamic() : nvidia::apex::DestructibleActor
  • setDynamicHandleIndicesMap() : NvParameterized::Definition
  • setEffectEnabled() : nvidia::apex::EffectPackageActor
  • setEffectPackageDatabase() : nvidia::apex::ModuleParticles
  • setEffectPackageEmitterDatabase() : nvidia::apex::ModuleParticles
  • setEffectPackageFieldSamplerDatabase() : nvidia::apex::ModuleParticles
  • setEffectPackageGraphicsMaterialsDatabase() : nvidia::apex::ModuleParticles
  • setEffectPackageIOFXDatabase() : nvidia::apex::ModuleParticles
  • setEffectPackageIOSDatabase() : nvidia::apex::ModuleParticles
  • setEffectPose() : nvidia::apex::EffectPackageActor
  • setEmitterState() : nvidia::apex::EffectPackageActor
  • setEmitterType() : nvidia::apex::EmitterGeom
  • setEnableApexStats() : nvidia::apex::ApexSDK
  • setEnableConcurrencyCheck() : nvidia::apex::ApexSDK
  • setEnabled()
: nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::EffectPackageActor
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::VelocitySourceActor
  • setEnableDebugVisualization() : nvidia::apex::Actor
  • setEnableScreenCulling() : nvidia::apex::ModuleParticles
  • setEnumVals() : NvParameterized::Definition
  • setExplodeView() : nvidia::apex::DestructiblePreview
  • setExportScale() : nvidia::apex::ClothingAssetAuthoring
  • setExtents() : nvidia::apex::EmitterGeomBox
  • setExternalVelocity() : nvidia::apex::TurbulenceFSActor
  • setFalloffMultiplier() : nvidia::apex::ForceFieldActor
  • setFalloffType() : nvidia::apex::ForceFieldActor
  • setFieldDirection()
: nvidia::apex::JetFSActor
, nvidia::apex::WindFSActor
  • setFieldRadius() : nvidia::apex::AttractorFSActor
  • setFieldSamplerWeightedCollisionFilterCallback() : nvidia::apex::ModuleFieldSampler
  • setFieldStrength()
: nvidia::apex::JetFSActor
, nvidia::apex::WindFSActor
  • setFieldVelocityMultiplier() : nvidia::apex::TurbulenceFSActor
  • setFieldVelocityWeight() : nvidia::apex::TurbulenceFSActor
  • setFluidViscosity() : nvidia::apex::TurbulenceFSActor
  • setFracturePatternName() : nvidia::apex::DestructibleAssetAuthoring
  • setFramePeriod() : nvidia::apex::CudaTestManager
  • setFrames() : nvidia::apex::CudaTestManager
  • setFrozen() : nvidia::apex::ClothingActor
  • setFunction()
: nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::SubtextureVsLifeModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::ColorVsVelocityModifier
  • setGeometry() : nvidia::apex::ClothingPhysicalMesh
  • setGlobalPose() : nvidia::apex::DestructibleActor
  • setGraphicalLOD() : nvidia::apex::ClothingActor
  • setGravity() : nvidia::apex::Scene
  • setGridDimensions() : nvidia::apex::TurbulenceFSActor
  • setGridSizePow() : nvidia::apex::ModuleTurbulenceFS
  • setGroundDensityScale() : nvidia::apex::ModuleEmitter
  • setHalfLengthDimensions() : nvidia::apex::TurbulenceFSPreview
  • setHalfPrecision() : nvidia::apex::ClothingActor
  • setHasSeparateBoneBuffer() : nvidia::apex::VertexFormat
  • setHeatBasedParameters() : nvidia::apex::TurbulenceFSActor
  • setHeight()
: nvidia::apex::VortexFSActor
, nvidia::apex::EmitterGeomCylinder
  • setHints() : NvParameterized::Definition
  • setHitChunkTrackingParams() : nvidia::apex::DestructibleActor
  • setIconScale()
: nvidia::apex::ForceFieldPreview
, nvidia::apex::ParticlesPreview
, nvidia::apex::TurbulenceFSPreview
  • setImpactDamageReportCallback() : nvidia::apex::ModuleDestructible
  • setIndexBufferRange() : nvidia::apex::UserRenderResource
  • setInitialGlobalPose() : nvidia::apex::DestructibleActor
  • setInstanceBuffer() : nvidia::apex::RenderMeshActor
  • setInstanceBufferRange()
: nvidia::apex::RenderMeshActor
, nvidia::apex::UserRenderResource
  • setInterface() : NvParameterized::Handle
  • setInvalidConstrainCoefficients() : nvidia::apex::ClothingAssetAuthoring
  • setIofxRenderCallback() : nvidia::apex::ModuleIofx
  • setLifetime() : nvidia::apex::ForceFieldActor
  • setLifetimeHigh() : nvidia::apex::EmitterActor
  • setLifetimeLow() : nvidia::apex::EmitterActor
  • setLiftStrength() : nvidia::apex::VortexFSActor
  • setLinearVelocity() : nvidia::apex::DestructibleActor
  • setLinearVelocityMultiplierAndClamp() : nvidia::apex::TurbulenceFSActor
  • setLodParamDesc() : nvidia::apex::EmitterActor
  • setMassScaling() : nvidia::apex::ModuleDestructible
  • setMaterial() : nvidia::apex::UserRenderResource
  • setMaterialFrame() : nvidia::apex::ExplicitHierarchicalMesh
  • setMaterialLibrary() : nvidia::apex::ClothingAssetAuthoring
  • setMaterialLookupCallback() : nvidia::apex::GroundEmitterActor
  • setMaterialName() : nvidia::apex::RenderMeshAssetAuthoring
  • setMaterials() : nvidia::apex::PhysX3DescTemplate
  • setMaxActorCreatesPerFrame() : nvidia::apex::ModuleDestructible
  • setMaxChunkCount() : nvidia::apex::ModuleDestructible
  • setMaxChunkDepthOffset() : nvidia::apex::ModuleDestructible
  • setMaxChunkSeparationLOD() : nvidia::apex::ModuleDestructible
  • setMaxDistanceBlendTime() : nvidia::apex::ClothingActor
  • setMaxDynamicChunkIslandCount() : nvidia::apex::ModuleDestructible
  • setMaxFracturesProcessedPerFrame() : nvidia::apex::ModuleDestructible
  • setMaxInjectedParticleCount()
: nvidia::apex::ParticleIosAssetAuthoring
, nvidia::apex::BasicIosAssetAuthoring
  • setMaxInstanceCount() : nvidia::apex::RenderMeshActor
  • setMaxParticleCount()
: nvidia::apex::BasicIosAssetAuthoring
, nvidia::apex::ParticleIosAssetAuthoring
  • setMaxRaycastsPerFrame() : nvidia::apex::GroundEmitterActor
  • setMaxRotationRate() : nvidia::apex::RotationModifier
  • setMaxSamples() : nvidia::apex::CudaTestManager
  • setMaxSettleRate() : nvidia::apex::RotationModifier
  • setMeshes() : nvidia::apex::ClothingAssetAuthoring
  • setModelForward() : nvidia::apex::OrientAlongVelocityModifier
  • setMultiSolveEnabled() : nvidia::apex::ModuleTurbulenceFS
  • setName()
: nvidia::apex::ForceFieldActor
, NvParameterized::Interface
  • setNeighborPadding() : nvidia::apex::DestructibleAssetAuthoring
  • setNoiseParameters() : nvidia::apex::TurbulenceFSActor
  • setNoiseStrength() : nvidia::apex::NoiseFSActor
  • setNumGrids() : nvidia::apex::TurbulenceFSPreview
  • setNvParameterized() : nvidia::apex::DestructibleActor
  • setObjectScale() : nvidia::apex::EmitterActor
  • setOriginAndNormal() : nvidia::apex::HalfSpaceShape
  • setOverlapTestCollisionGroups() : nvidia::apex::EmitterActor
  • setOverrideMaterial()
: nvidia::apex::ClothingActor
, nvidia::apex::RenderMeshActor
  • setOwnershipBounds() : nvidia::apex::RenderVolume
  • setParam() : NvParameterized::Handle
  • setParamArray() : NvParameterized::Handle
  • setParamBool()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamBoolArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamBounds3()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamBounds3Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamEnum()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamEnumArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamF32()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamF32Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamF64()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamF64Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI16()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI16Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI32()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI32Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI64()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI64Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI8()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI8Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamMat33()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamMat33Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamMat34Legacy()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamMat34LegacyArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamMat44()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamMat44Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamQuat()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamQuatArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamRef()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamRefArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamString()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamStringArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamTransform()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamTransformArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamU16()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamU16Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamU32()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamU32Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamU64()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamU64Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamU8()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamU8Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamVec2()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamVec2Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamVec3()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamVec3Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamVec4()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamVec4Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParticleMass()
: nvidia::apex::BasicIosAssetAuthoring
, nvidia::apex::ParticleIosAssetAuthoring
  • setParticleRadius()
: nvidia::apex::BasicIosAssetAuthoring
, nvidia::apex::ParticleIosAssetAuthoring
  • setPhysX3Template() : nvidia::apex::ActorSource
  • setPhysXMonitorFilterData() : nvidia::apex::ModuleFieldSampler
  • setPhysXScene() : nvidia::apex::Scene
  • setPlane() : nvidia::apex::ClothingPlane
  • setPlatformMaxDepth() : nvidia::apex::DestructibleAssetAuthoring
  • setPose()
: nvidia::apex::ClothingTriangleMesh
, nvidia::apex::GroundEmitterActor
, nvidia::apex::ForceFieldActor
, nvidia::apex::EffectPackageActor
, nvidia::apex::Shape
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::AssetPreview
  • setPosition()
: nvidia::apex::ClothingSphere
, nvidia::apex::RenderVolume
  • setPreferredRenderVolume()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
, nvidia::apex::ImpactEmitterActor
, nvidia::apex::EffectPackageActor
, nvidia::apex::DestructibleActor
  • setProgress() : nvidia::apex::IProgressListener
  • setProjMatrix() : nvidia::apex::Scene
  • setProjParams() : nvidia::apex::Scene
  • setRadialStrength() : nvidia::apex::VortexFSActor
  • setRadius()
: nvidia::apex::AttractorFSPreview
, nvidia::apex::VortexFSPreview
, nvidia::apex::ClothingSphere
, nvidia::apex::EmitterGeomSphere
, nvidia::apex::EmitterGeomCylinder
, nvidia::apex::GroundEmitterActor
, nvidia::apex::EmitterGeomSphereShell
, nvidia::apex::SphereShape
  • setRate() : nvidia::apex::EmitterActor
  • setRateScale() : nvidia::apex::ModuleEmitter
  • setRaycastCollisionGroups() : nvidia::apex::GroundEmitterActor
  • setRaycastCollisionGroupsMask() : nvidia::apex::GroundEmitterActor
  • setRaycastHeight() : nvidia::apex::GroundEmitterActor
  • setReleaseResourcesIfNothingToRender() : nvidia::apex::RenderMeshActor
  • setRenderLockMode() : nvidia::apex::Module
  • setRenderMeshAsset()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • setResource() : nvidia::apex::ResourceProvider
  • setResourceU32() : nvidia::apex::ResourceProvider
  • setRestDensity() : nvidia::apex::BasicIosAssetAuthoring
  • setRollType() : nvidia::apex::RotationModifier
  • setRootBone() : nvidia::apex::ClothingAssetAuthoring
  • setRootMesh() : nvidia::apex::DestructibleAssetAuthoring
  • setRotationalStrength() : nvidia::apex::VortexFSActor
  • setRotationRange() : nvidia::apex::RandomRotationModifier
  • setRotationRate() : nvidia::apex::RotationRateModifier
  • setRuntimeCheckLevel() : nvidia::apex::TestBase
  • setRuntimeFractureOverridePattern() : nvidia::apex::DestructibleActor
  • setSampleVelocityFieldEnabled() : nvidia::apex::TurbulenceFSActor
  • setScale()
: nvidia::apex::HeatSourcePreview
, nvidia::apex::VelocitySourcePreview
, nvidia::apex::ForceFieldActor
, nvidia::apex::GroundEmitterPreview
, nvidia::apex::EmitterPreview
, nvidia::apex::FlameEmitterPreview
  • setScaleAxis()
: nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
  • setScaleChangeDelay() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • setScaleChangeLimit() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • setScaleFactor()
: nvidia::apex::SimpleScaleModifier
, nvidia::apex::RandomScaleModifier
, nvidia::apex::ScaleAlongVelocityModifier
  • setScalePerVelocity() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • setScatterMeshAssets() : nvidia::apex::DestructibleAssetAuthoring
  • setSearchName() : NvParameterized::ParameterFind
  • setSemanticData() : nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >
  • setSerializationCallback() : NvParameterized::Interface
  • setShellThickness() : nvidia::apex::EmitterGeomSphereShell
  • setShowFullInfo() : nvidia::apex::AssetPreviewScene
  • setSimulationDisableCCD() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationGravityDirection() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationHierarchicalLevels() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationRestLengthScale() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationSleepLinearVelocity() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationThickness() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationTwowayInteraction() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationUntangling() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationVirtualParticleDensity() : nvidia::apex::ClothingAssetAuthoring
  • setSize() : nvidia::apex::BoxShape
  • setSkinnedOverrideMaterial() : nvidia::apex::DestructibleActor
  • setSortByBenefit() : nvidia::apex::ModuleDestructible
  • setSpawnHeight() : nvidia::apex::GroundEmitterActor
  • setSpriteBufferRange() : nvidia::apex::UserRenderResource
  • setSpriteVisibleCount() : nvidia::apex::UserRenderResource
  • setStaticOverrideMaterial() : nvidia::apex::DestructibleActor
  • setStrength() : nvidia::apex::ForceFieldActor
  • setSubtextureRange() : nvidia::apex::RandomSubtextureModifier
  • setSyncParams()
: nvidia::apex::ModuleDestructible
, nvidia::apex::DestructibleActor
  • setTargetPlatform() : NvParameterized::Serializer
  • setTemperature() : nvidia::apex::HeatSourceActor
  • setTM() : nvidia::apex::RenderMeshActor
  • setToDefault()
: nvidia::apex::DamageSpreadFunction
, FractureTools::NoiseParameters
, FractureTools::FractureCutoutDesc
, FractureTools::FractureSliceDesc
, nvidia::apex::EmitterLodParamDesc
, nvidia::apex::DestructibleBehaviorGroupDesc
, nvidia::apex::FractureMaterialDesc
, FractureTools::MeshProcessingParameters
, nvidia::apex::CollisionVolumeDesc
, nvidia::apex::DestructibleGeometryDesc
, nvidia::apex::GroupsMask64
, nvidia::apex::DestructibleInitParameters
, nvidia::apex::DestructibleRTFractureParameters
, nvidia::apex::ApexDesc
, FractureTools::CutoutParameters
, nvidia::apex::RenderMeshActorDesc
, FractureTools::SliceParameters
, nvidia::apex::DestructibleDepthParameters
, nvidia::apex::ApexSDKDesc
, nvidia::apex::DestructibleActorJointDesc
, nvidia::apex::DestructibleParameters
, nvidia::apex::DestructibleChunkDesc
, nvidia::apex::DestructibleAssetCookingDesc
, nvidia::apex::CollisionDesc
, nvidia::apex::SceneDesc
, FractureTools::FractureVoronoiDesc
  • setToMostExpensive() : nvidia::apex::DestructibleDepthParameters
  • setToolString() : nvidia::apex::AssetAuthoring
  • setTopRadius() : nvidia::apex::VortexFSActor
  • setTopSphericalForce() : nvidia::apex::VortexFSActor
  • setTurbulenceRenderCallback() : nvidia::apex::ModuleTurbulenceFS
  • setUpdatesPerFrame() : nvidia::apex::TurbulenceFSActor
  • setUseDebugRenderable()
: nvidia::apex::Scene
, nvidia::apex::RenderDebugInterface
  • setUseDensity() : nvidia::apex::TurbulenceFSActor
  • setUseEmitterPool() : nvidia::apex::ModuleParticles
  • setUseHeat() : nvidia::apex::TurbulenceFSActor
  • setUseLegacyChunkBoundsTesting() : nvidia::apex::ModuleDestructible
  • setUseLegacyDamageRadiusSpread() : nvidia::apex::ModuleDestructible
  • setUserData()
: NvParameterized::Handle
, nvidia::apex::UserRenderDataHolder
  • setUseViewProjMatrix() : nvidia::apex::Scene
  • setValidBoundsPadding() : nvidia::apex::ModuleDestructible
  • setVariableFieldStrength() : nvidia::apex::AttractorFSActor
  • setVelocity() : nvidia::apex::VelocitySourceActor
  • setVelocity0() : nvidia::apex::ColorVsVelocityModifier
  • setVelocity1() : nvidia::apex::ColorVsVelocityModifier
  • setVelocityCallback() : nvidia::apex::ClothingActor
  • setVelocityFieldCleaningDelay() : nvidia::apex::TurbulenceFSActor
  • setVelocityFieldCleaningIntensity() : nvidia::apex::TurbulenceFSActor
  • setVelocityFieldCleaningTime() : nvidia::apex::TurbulenceFSActor
  • setVelocityFieldFade() : nvidia::apex::TurbulenceFSActor
  • setVelocityHigh() : nvidia::apex::EmitterActor
  • setVelocityLow() : nvidia::apex::EmitterActor
  • setVertexBufferRange() : nvidia::apex::UserRenderResource
  • setViewMatrix() : nvidia::apex::Scene
  • setViewParams() : nvidia::apex::Scene
  • setVisibility() : nvidia::apex::RenderMeshActor
  • setVisible() : nvidia::apex::ClothingActor
  • setWind() : nvidia::apex::ClothingActor
  • setWinding() : nvidia::apex::VertexFormat
  • setWindingOrder() : nvidia::apex::RenderMeshAssetAuthoring
  • setWorldSupportPhysXScene() : nvidia::apex::ModuleDestructible
  • setWriteForFunction() : nvidia::apex::CudaTestManager
  • setWriteForNotSuccessfulKernel() : nvidia::apex::CudaTestManager
  • setWritePath() : nvidia::apex::CudaTestManager
  • sharedRenderData : nvidia::apex::IofxMeshRenderData , nvidia::apex::IofxSpriteRenderData
  • sheetFracture : nvidia::apex::DestructibleRTFractureParameters
  • SHORT1 : nvidia::apex::RenderDataFormat
  • SHORT2 : nvidia::apex::RenderDataFormat
  • SHORT3 : nvidia::apex::RenderDataFormat
  • SHORT4 : nvidia::apex::RenderDataFormat
  • SHORT_SNORM1 : nvidia::apex::RenderDataFormat
  • SHORT_SNORM2 : nvidia::apex::RenderDataFormat
  • SHORT_SNORM3 : nvidia::apex::RenderDataFormat
  • SHORT_SNORM4 : nvidia::apex::RenderDataFormat
  • SHORT_SNORM4_QUATXYZW : nvidia::apex::RenderDataFormat
  • SHORT_UNORM1 : nvidia::apex::RenderDataFormat
  • SHORT_UNORM2 : nvidia::apex::RenderDataFormat
  • SHORT_UNORM3 : nvidia::apex::RenderDataFormat
  • SHORT_UNORM4 : nvidia::apex::RenderDataFormat
  • shouldMirror() : nvidia::apex::MirrorScene::MirrorFilter
  • simplify() : nvidia::apex::ClothingPhysicalMesh
  • simulate() : nvidia::apex::Scene
  • siteCount : FractureTools::FractureVoronoiDesc
  • sites : FractureTools::FractureVoronoiDesc
  • size : nvidia::apex::UserRenderBufferDesc , NvParameterized::Serializer::DeserializedResults< T, bufSize >
  • SliceParameters() : FractureTools::SliceParameters
  • sliceParameters : FractureTools::FractureSliceDesc
  • smoothingMask : nvidia::apex::ExplicitRenderTriangle
  • solidShadedMaterial : nvidia::apex::ApexSDKDesc
  • speedWeight : nvidia::apex::EmitterLodParamDesc
  • SPHERICAL : nvidia::apex::ApexMeshParticleRollType
  • splitNonconvexRegions : FractureTools::FractureCutoutDesc
  • splitsPerPass : FractureTools::SliceParameters
  • SPRITE : nvidia::apex::IofxRenderable , nvidia::apex::ApexMeshParticleRollType
  • spriteBuffer : nvidia::apex::UserRenderResourceDesc
  • spriteRenderBuffer : nvidia::apex::IofxSpriteSharedRenderData
  • spriteRenderLayout : nvidia::apex::IofxSpriteSharedRenderData
  • spriteRenderSurfaces : nvidia::apex::IofxSpriteSharedRenderData
  • srcFormat : nvidia::apex::RenderSemanticData
  • startEmit() : nvidia::apex::EmitterActor
  • startIndex : nvidia::apex::IofxCommonRenderData
  • StatCurrentValue : nvidia::apex::StatsInfo
  • stateEventList : nvidia::apex::ChunkStateEventData
  • stateEventListSize : nvidia::apex::ChunkStateEventData
  • StatName : nvidia::apex::StatsInfo
  • StatType : nvidia::apex::StatsInfo
  • stopEmit() : nvidia::apex::EmitterActor
  • strdup() : NvParameterized::Traits
  • strfree() : NvParameterized::Traits
  • stride
: nvidia::apex::IofxMeshRenderLayout
, nvidia::apex::IofxSpriteRenderLayout
, nvidia::apex::UserRenderInstanceBufferDesc
, nvidia::apex::RenderSemanticData
, nvidia::apex::UserRenderSpriteBufferDesc
  • strToValue()
: NvParameterized::Interface
, NvParameterized::Handle
  • structName() : NvParameterized::Definition
  • submeshCount : nvidia::apex::RenderMeshAssetStats , nvidia::apex::ExplicitHierarchicalMesh
  • submeshData() : nvidia::apex::ExplicitHierarchicalMesh
  • SubmeshDesc() : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • submeshIndex
: nvidia::apex::UserRenderResourceDesc
, nvidia::apex::ExplicitRenderTriangle
, nvidia::apex::RenderMeshActorRaycastHitData
  • submitForceSampleBatch() : nvidia::apex::ModuleFieldSampler
  • SUBTEXTURE : nvidia::apex::RenderSpriteSemantic , nvidia::apex::IofxRenderSemantic
  • supportDepth : nvidia::apex::DestructibleInitParameters
  • supportGraphEdgeCount : nvidia::apex::DestructibleAssetCookingDesc
  • supportGraphEdges : nvidia::apex::DestructibleAssetCookingDesc
  • supportStrength : nvidia::apex::DestructibleParameters
  • surfaceBuffers : nvidia::apex::UserRenderResourceDesc
  • surfaceCount : nvidia::apex::IofxSpriteRenderLayout
  • surfaceDescs : nvidia::apex::IofxSpriteRenderLayout
  • surfaceElements : nvidia::apex::IofxSpriteRenderLayout
  • surfaceNormal()
: nvidia::apex::ExplicitHierarchicalMesh
, nvidia::apex::DestructibleChunkDesc
  • swapArrayElements()
: NvParameterized::Interface
, NvParameterized::Handle
  • synchronizeMirrorScene() : nvidia::apex::MirrorScene
  • synchronizePrimaryScene() : nvidia::apex::MirrorScene
  • syncVisibility() : nvidia::apex::RenderMeshActor
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • takeImpact() : nvidia::apex::DestructibleActor
  • tangent : nvidia::apex::FractureMaterialDesc , nvidia::apex::Vertex
  • TANGENT : nvidia::apex::RenderVertexSemantic
  • tangent : nvidia::apex::RenderMeshActorRaycastHitData
  • tangentBary : nvidia::apex::ClothingMeshSkinningMap
  • targetProportions : FractureTools::FractureSliceDesc
  • Teleport : nvidia::apex::ClothingTeleportMode
  • TeleportAndReset : nvidia::apex::ClothingTeleportMode
  • TestFunctionInterface() : nvidia::apex::TestFunctionInterface
  • TEXCOORD0 : nvidia::apex::RenderVertexSemantic
  • TEXCOORD1 : nvidia::apex::RenderVertexSemantic
  • TEXCOORD2 : nvidia::apex::RenderVertexSemantic
  • TEXCOORD3 : nvidia::apex::RenderVertexSemantic
  • textureCount : nvidia::apex::UserRenderSpriteBufferDesc
  • textureDescs : nvidia::apex::UserRenderSpriteBufferDesc
  • tileFractureMap : FractureTools::FractureCutoutDesc
  • time : nvidia::apex::RenderMeshActorRaycastHitData
  • toColorRGBA() : nvidia::apex::VertexColor
  • totalBytes
: nvidia::apex::ClothingPhysicalMeshStats
, nvidia::apex::DestructibleAssetStats
, nvidia::apex::RenderMeshAssetStats
  • totalNumberOfFractureEvents : nvidia::apex::DamageEventReportData
  • traitsWarn() : NvParameterized::Traits
  • TRANSFORM : nvidia::apex::PhysXObjectDesc
  • triangleCount : nvidia::apex::RenderMeshPartData
  • trimCollisionGeometry() : nvidia::apex::DestructibleAssetAuthoring
  • trimFaceCollisionHulls : FractureTools::FractureCutoutDesc
  • Type : nvidia::apex::IofxRenderable
  • type
: nvidia::apex::DestructibleActorJointDesc
, NvParameterized::Hint
, NvParameterized::Definition
, FractureTools::NoiseParameters
  • Type : nvidia::apex::UserRenderStorage
  • typeString() : NvParameterized::Definition
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • u : nvidia::apex::VertexUV
  • uAngle : nvidia::apex::FractureMaterialDesc
  • UBYTE1 : nvidia::apex::RenderDataFormat
  • UBYTE2 : nvidia::apex::RenderDataFormat
  • UBYTE3 : nvidia::apex::RenderDataFormat
  • UBYTE4 : nvidia::apex::RenderDataFormat
  • UINT1 : nvidia::apex::RenderDataFormat
  • UINT2 : nvidia::apex::RenderDataFormat
  • UINT3 : nvidia::apex::RenderDataFormat
  • UINT4 : nvidia::apex::RenderDataFormat
  • unlockIofxActorList() : nvidia::apex::RenderVolume
  • unlockModuleSceneRenderLock() : nvidia::apex::Module
  • unlockRead() : nvidia::apex::Scene
  • unlockRenderResources() : nvidia::apex::RenderDataProvider
  • unlockTriangles() : nvidia::apex::ClothingTriangleMesh
  • unlockWrite() : nvidia::apex::Scene
  • unmap()
: nvidia::apex::UserRenderBuffer
, nvidia::apex::UserRenderSurface
  • UNSPECIFIED : nvidia::apex::RenderDataFormat
  • updateBindPoses() : nvidia::apex::ClothingAssetAuthoring
  • updateBounds() : nvidia::apex::RenderMeshActor
  • updateLegacyNvParameterized() : NvParameterized::Traits
  • updateMaxDistanceScale() : nvidia::apex::ClothingActor
  • updateRenderResources() : nvidia::apex::RenderDataProvider
  • updateState()
: nvidia::apex::ClothingActor
, nvidia::apex::ClothingPreview
  • USE_VALID_BOUNDS : nvidia::apex::DestructibleParametersFlag
  • useCuda : nvidia::apex::SceneDesc
  • useDebugRenderable : nvidia::apex::SceneDesc
  • useDisplacementMaps : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • useDynamicChunksGroupsMask : nvidia::apex::DestructibleParameters
  • useInstancedRendering : nvidia::apex::DestructibleChunkDesc
  • USER_DATA
: nvidia::apex::IofxRenderSemantic
, nvidia::apex::RenderInstanceSemantic
, nvidia::apex::RenderSpriteSemantic
  • USER_FLAG_0 : nvidia::apex::DestructibleDepthParametersFlag
  • userActorID
: nvidia::apex::DamageEventHeader
, nvidia::apex::ChunkTransformHeader
, nvidia::apex::FractureEventHeader
  • userData()
: NvParameterized::Handle
, nvidia::apex::ApexDesc
, nvidia::apex::ApexInterface
, nvidia::apex::PhysXObjectDesc
, nvidia::apex::RenderMeshPartData
, NvParameterized::Handle
, nvidia::apex::DestructibleBehaviorGroupDesc
  • userDataStart : nvidia::apex::EmitterGeomExplicit::PointListData
  • userDataStrideBytes : nvidia::apex::EmitterGeomExplicit::PointListData
  • userDefinedCutoutParameters : FractureTools::FractureCutoutDesc
  • userDefinedDirection : FractureTools::FractureCutoutDesc
  • userFlags : nvidia::apex::UserRenderSurfaceDesc , nvidia::apex::UserRenderBufferDesc
  • userRenderData : nvidia::apex::UserRenderResourceDesc
  • UserRenderDataHolder() : nvidia::apex::UserRenderDataHolder
  • userUVMapping : FractureTools::FractureCutoutDesc
  • useTargetProportions : FractureTools::FractureSliceDesc
  • useUniqueRenderVolume() : nvidia::apex::EffectPackageAsset
  • USHORT1 : nvidia::apex::RenderDataFormat
  • USHORT2 : nvidia::apex::RenderDataFormat
  • USHORT3 : nvidia::apex::RenderDataFormat
  • USHORT4 : nvidia::apex::RenderDataFormat
  • uv : nvidia::apex::Vertex
  • UV_OFFSET : nvidia::apex::RenderInstanceSemantic
  • uvOffset : nvidia::apex::FractureMaterialDesc
  • uvOrigin : nvidia::apex::UserRenderVertexBufferDesc
  • uvScale : nvidia::apex::FractureMaterialDesc
  • uvTileSize : FractureTools::FractureCutoutDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • v : nvidia::apex::VertexUV
  • v3 : nvidia::apex::ClothSolverMode
  • validateEmitterPosition() : nvidia::apex::EmitterActor::EmitterValidateCallback
  • validBounds : nvidia::apex::DestructibleParameters
  • valueToStr()
: NvParameterized::Handle
, NvParameterized::Interface
  • Vec2T() : nvidia::apex::Vec2T< T >
  • velocities : nvidia::apex::ChunkParticleReportData
  • VELOCITY : nvidia::apex::IofxRenderSemantic , nvidia::apex::RenderSpriteSemantic
  • VELOCITY_LIFE : nvidia::apex::RenderInstanceSemantic
  • velocityCount : nvidia::apex::ChunkParticleReportData
  • velocityFormat : nvidia::apex::TurbulenceRenderLayout
  • velocityShader() : nvidia::apex::ClothingVelocityCallback
  • velocityStart : nvidia::apex::EmitterGeomExplicit::PointListData
  • velocityStrideBytes : nvidia::apex::EmitterGeomExplicit::PointListData
  • verbosity : FractureTools::MeshProcessingParameters
  • version : NvParameterized::Serializer::MetadataEntry , NvParameterized::Interface
  • Vertex() : nvidia::apex::Vertex
  • vertexBufferBytes : nvidia::apex::RenderMeshAssetStats
  • vertexBuffers : nvidia::apex::UserRenderResourceDesc
  • VertexColor() : nvidia::apex::VertexColor
  • vertexCount : nvidia::apex::RenderMeshAssetStats
  • vertexIndex0 : nvidia::apex::ClothingMeshSkinningMap
  • vertexIndex1 : nvidia::apex::ClothingMeshSkinningMap
  • vertexIndex2 : nvidia::apex::ClothingMeshSkinningMap
  • vertexIndices : nvidia::apex::RenderMeshActorRaycastHitData
  • VertexUV() : nvidia::apex::VertexUV
  • vertices : nvidia::apex::ExplicitRenderTriangle
  • visible : nvidia::apex::RenderMeshActorDesc
  • visibleCount : nvidia::apex::IofxSpriteRenderData
  • visiblePartCount() : nvidia::apex::RenderMeshActor
  • visibleSpriteCount : nvidia::apex::UserRenderResourceDesc
  • visualize()
: nvidia::apex::ExplicitHierarchicalMesh
, nvidia::apex::Shape
  • VisualizeMeshBSPInsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeMeshBSPOutsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeMeshBSPSingleRegion : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeSliceBSPInsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeSliceBSPOutsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeSliceBSPSingleRegion : nvidia::apex::ExplicitHierarchicalMesh
  • visualizeVoronoiCells()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • voronoiSplitChunk()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • width
: nvidia::apex::UserRenderSurfaceDesc
, nvidia::apex::UserRenderSpriteTextureDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
  • widthSurfaceBuffers : nvidia::apex::UserRenderResourceDesc
  • wireframeMaterial : nvidia::apex::ApexSDKDesc
  • world2local : nvidia::apex::RenderContext
  • WORLD_SUPPORT : nvidia::apex::DestructibleInitParametersFlag
  • WORLD_SUPPORTED : nvidia::apex::ApexChunkFlag
  • worldBounds : nvidia::apex::ChunkData , nvidia::apex::DamageEventReportData
  • WrappedNamedReference() : NvParameterized::WrappedNamedReference
  • write() : nvidia::apex::PxStreamFromFileBuf
  • writeBuffer()
: nvidia::apex::UserRenderSurfaceBuffer
, nvidia::apex::UserRenderBoneBuffer
, nvidia::apex::UserRenderIndexBuffer
, nvidia::apex::UserRenderSpriteBuffer
, nvidia::apex::UserRenderVertexBuffer
, nvidia::apex::UserRenderInstanceBuffer
  • WriteLock() : nvidia::apex::WriteLock
  • writeTexture() : nvidia::apex::UserRenderSpriteBuffer
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • x : nvidia::apex::Vec2T< T >
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • y : nvidia::apex::Vec2T< T >
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Enumerations

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • i
  • m
  • n
  • o
  • s
  • t

- a -

  • ArchType : NvParameterized::SerializePlatform

- c -

  • ChunkFlags : nvidia::apex::DestructibleAsset
  • CompilerType : NvParameterized::SerializePlatform
  • CutoutChunkFracturingMethod : FractureTools::FractureCutoutDesc

- d -

  • DataType : nvidia::apex::ExplicitHierarchicalMesh::Embedding
  • Directions : FractureTools::FractureCutoutDesc

- e -

  • Enum
: nvidia::apex::GroupsFilterOp
, nvidia::apex::ClothingTeleportMode
, nvidia::apex::ClothingCollisionType
, nvidia::apex::RenderDataAccess
, nvidia::apex::TextureUVOrigin
, nvidia::apex::RenderVertexSemantic
, nvidia::apex::RenderSpriteTextureLayout
, nvidia::apex::RenderSpriteLayoutElement
, nvidia::apex::RenderSpriteSemantic
, nvidia::apex::RenderBufferHint
, nvidia::apex::RenderCullMode
, nvidia::apex::RenderPrimitiveType
, nvidia::apex::RenderInstanceLayoutElement
, nvidia::apex::RenderInstanceSemantic
, nvidia::apex::RenderMapType
, nvidia::apex::RenderInteropFlags
, nvidia::apex::RenderBoneSemantic
, nvidia::apex::TurbulenceFlameFormat
, nvidia::apex::TurbulenceDensityFormat
, nvidia::apex::TurbulenceVelocityFormat
, nvidia::apex::TurbulenceFieldType
, nvidia::apex::UserBoundingBoxFlags
, nvidia::apex::ProjMatrixType
, nvidia::apex::ViewMatrixType
, nvidia::apex::StatDataType
, nvidia::apex::DestructibleActorSyncFlags
, nvidia::apex::ExplicitHierarchicalMesh
, nvidia::apex::RenderMeshAssetInstanceMode
, nvidia::apex::RenderMeshActorRaycastFlags
, nvidia::apex::RenderDataFormat
, nvidia::apex::RenderLockMode
, nvidia::apex::ApexMeshParticleRollType
, nvidia::apex::IofxMeshRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::IofxSpriteRenderLayoutElement
, nvidia::apex::IofxRenderSemantic
, nvidia::apex::EmitterType
, nvidia::apex::DestructibleCallbackSchedule
, nvidia::apex::DestructibleActorRaycastFlags
, nvidia::apex::DestructibleActorMeshType
, nvidia::apex::ModuleDestructibleConst
, nvidia::apex::RenderMeshAssetAuthoring::Primitive
, nvidia::apex::RenderMeshAssetAuthoring::IndexType
, nvidia::apex::BSPOpenMode
, nvidia::apex::FractureMethod
, nvidia::apex::DestructibleInitParametersFlag
, nvidia::apex::DestructibleParametersFlag
, nvidia::apex::DestructibleDepthParametersFlag
, nvidia::apex::DestructibleActorChunkFlags
, nvidia::apex::ApexChunkFlag
, nvidia::apex::DestructiblePhysXActorQueryFlags
, nvidia::apex::DestructibleParameterizedType
, nvidia::apex::DestructibleEmitterType
, nvidia::apex::ConvexHullMethod
, nvidia::apex::ClothSolverMode
  • ErrorType : NvParameterized::Serializer
  • EventMask : nvidia::apex::DestructibleChunkEvent

- i -

  • InstancingMode : FractureTools::FractureCutoutDesc

- m -

  • ManifestVersions : nvidia::apex::EmitterLodParamDesc

- n -

  • NoiseMode : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc

- o -

  • Order : FractureTools::SliceParameters
  • OsType : NvParameterized::SerializePlatform

- s -

  • SerializeType : NvParameterized::Serializer

- t -

  • Type : nvidia::apex::IofxRenderable , nvidia::apex::UserRenderStorage
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Enumerator

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • ACCUMULATE_DAMAGE : nvidia::apex::DestructibleParametersFlag
  • ACCURATE_RAYCASTS : nvidia::apex::DestructibleParametersFlag
  • AllowActorsNotInScenes : nvidia::apex::DestructiblePhysXActorQueryFlags
  • AllowRedundancy : nvidia::apex::DestructiblePhysXActorQueryFlags
  • AllStates : nvidia::apex::DestructiblePhysXActorQueryFlags
  • ASSET_DEFINED_SUPPORT : nvidia::apex::DestructibleInitParametersFlag

- b -

  • B32G32R32A32_FLOAT : nvidia::apex::RenderDataFormat
  • B8G8R8A8 : nvidia::apex::RenderDataFormat
  • BeforeTick : nvidia::apex::DestructibleCallbackSchedule
  • BINORMAL : nvidia::apex::RenderVertexSemantic
  • BONE_INDEX : nvidia::apex::RenderVertexSemantic
  • BONE_WEIGHT : nvidia::apex::RenderVertexSemantic
  • BYTE_SNORM1 : nvidia::apex::RenderDataFormat
  • BYTE_SNORM2 : nvidia::apex::RenderDataFormat
  • BYTE_SNORM3 : nvidia::apex::RenderDataFormat
  • BYTE_SNORM4 : nvidia::apex::RenderDataFormat
  • BYTE_SNORM4_QUATXYZW : nvidia::apex::RenderDataFormat
  • BYTE_UNORM1 : nvidia::apex::RenderDataFormat
  • BYTE_UNORM2 : nvidia::apex::RenderDataFormat
  • BYTE_UNORM3 : nvidia::apex::RenderDataFormat
  • BYTE_UNORM4 : nvidia::apex::RenderDataFormat

- c -

  • ChunkIsWorldSupported : nvidia::apex::DestructibleActorChunkFlags
  • COLOR
: nvidia::apex::IofxRenderSemantic
, nvidia::apex::RenderSpriteSemantic
, nvidia::apex::RenderVertexSemantic
, nvidia::apex::RenderInstanceSemantic
  • CONTACTS : nvidia::apex::PhysXObjectDesc
  • Continuous : nvidia::apex::ClothingTeleportMode
  • CRUMBLE_SMALLEST_CHUNKS : nvidia::apex::DestructibleParametersFlag
  • CRUMBLE_VIA_RUNTIME_FRACTURE : nvidia::apex::DestructibleParametersFlag
  • CUBIC : nvidia::apex::ApexMeshParticleRollType
  • CUSTOM : nvidia::apex::RenderVertexSemantic

- d -

  • DEBRIS_MAX_SEPARATION : nvidia::apex::DestructibleParametersFlag
  • DEBRIS_TIMEOUT : nvidia::apex::DestructibleParametersFlag
  • DENSITY
: nvidia::apex::RenderInstanceSemantic
, nvidia::apex::RenderSpriteSemantic
, nvidia::apex::IofxRenderSemantic
  • DESTROYED_CRUMBLED : nvidia::apex::ApexChunkFlag
  • DESTROYED_ENTERED_USER_BOUNDS : nvidia::apex::ApexChunkFlag
  • DESTROYED_EXCEEDED_MAX_DISTANCE : nvidia::apex::ApexChunkFlag
  • DESTROYED_FIFO_FULL : nvidia::apex::ApexChunkFlag
  • DESTROYED_LEFT_USER_BOUNDS : nvidia::apex::ApexChunkFlag
  • DESTROYED_LEFT_VALID_BOUNDS : nvidia::apex::ApexChunkFlag
  • DESTROYED_TIMED_OUT : nvidia::apex::ApexChunkFlag
  • DISPLACEMENT_FLAGS : nvidia::apex::RenderVertexSemantic
  • DISPLACEMENT_TEXCOORD : nvidia::apex::RenderVertexSemantic
  • Dormant : nvidia::apex::DestructiblePhysXActorQueryFlags
  • DYNAMIC : nvidia::apex::ApexChunkFlag
  • Dynamic : nvidia::apex::DestructiblePhysXActorQueryFlags

- e -

  • ET_DENSITY_BRUSH : nvidia::apex::EmitterType
  • ET_DENSITY_ONCE : nvidia::apex::EmitterType
  • ET_FILL : nvidia::apex::EmitterType
  • ET_RATE : nvidia::apex::EmitterType
  • EXTERNALLY_SUPPORTED : nvidia::apex::ApexChunkFlag

- f -

  • FetchResults : nvidia::apex::DestructibleCallbackSchedule
  • FLAT_X : nvidia::apex::ApexMeshParticleRollType
  • FLAT_Y : nvidia::apex::ApexMeshParticleRollType
  • FLAT_Z : nvidia::apex::ApexMeshParticleRollType
  • FLOAT1 : nvidia::apex::RenderDataFormat
  • FLOAT2 : nvidia::apex::RenderDataFormat
  • FLOAT3 : nvidia::apex::RenderDataFormat
  • FLOAT3x3 : nvidia::apex::RenderDataFormat
  • FLOAT3x4 : nvidia::apex::RenderDataFormat
  • FLOAT4 : nvidia::apex::RenderDataFormat
  • FLOAT4_QUAT : nvidia::apex::RenderDataFormat
  • FLOAT4x4 : nvidia::apex::RenderDataFormat
  • FORM_EXTENDED_STRUCTURES : nvidia::apex::DestructibleInitParametersFlag
  • FRACTURED : nvidia::apex::ApexChunkFlag

- h -

  • HALF1 : nvidia::apex::RenderDataFormat
  • HALF2 : nvidia::apex::RenderDataFormat
  • HALF3 : nvidia::apex::RenderDataFormat
  • HALF4 : nvidia::apex::RenderDataFormat

- i -

  • IGNORE_CONTACT_CALLBACKS : nvidia::apex::DestructibleDepthParametersFlag
  • IGNORE_POSE_UPDATES : nvidia::apex::DestructibleDepthParametersFlag
  • IGNORE_RAYCAST_CALLBACKS : nvidia::apex::DestructibleDepthParametersFlag
  • INVALID_CHUNK_INDEX : nvidia::apex::ModuleDestructibleConst

- l -

  • LIFE_REMAIN : nvidia::apex::IofxRenderSemantic , nvidia::apex::RenderSpriteSemantic
  • LOCAL_OFFSET : nvidia::apex::RenderInstanceSemantic
  • LONG_X : nvidia::apex::ApexMeshParticleRollType
  • LONG_Y : nvidia::apex::ApexMeshParticleRollType
  • LONG_Z : nvidia::apex::ApexMeshParticleRollType

- m -

  • MESH : nvidia::apex::IofxRenderable

- n -

  • NO_RENDER_LOCK : nvidia::apex::RenderLockMode
  • NORMAL : nvidia::apex::RenderVertexSemantic
  • NST_BINARY : NvParameterized::Serializer
  • NST_XML : NvParameterized::Serializer
  • NUM_SEMANTICS
: nvidia::apex::RenderBoneSemantic
, nvidia::apex::IofxRenderSemantic
, nvidia::apex::RenderVertexSemantic
, nvidia::apex::RenderSpriteSemantic
, nvidia::apex::RenderInstanceSemantic

- o -

  • ORIENTATION : nvidia::apex::IofxRenderSemantic , nvidia::apex::RenderSpriteSemantic
  • ORIGIN_BOTTOM_LEFT : nvidia::apex::TextureUVOrigin
  • ORIGIN_BOTTOM_RIGHT : nvidia::apex::TextureUVOrigin
  • ORIGIN_TOP_LEFT : nvidia::apex::TextureUVOrigin
  • ORIGIN_TOP_RIGHT : nvidia::apex::TextureUVOrigin
  • ORIGIN_UNKNOWN : nvidia::apex::TextureUVOrigin
  • OVERRIDE_IMPACT_DAMAGE : nvidia::apex::DestructibleDepthParametersFlag
  • OVERRIDE_IMPACT_DAMAGE_VALUE : nvidia::apex::DestructibleDepthParametersFlag

- p -

  • PER_ACTOR_RENDER_LOCK : nvidia::apex::RenderLockMode
  • PER_MODULE_SCENE_RENDER_LOCK : nvidia::apex::RenderLockMode
  • POSE : nvidia::apex::RenderInstanceSemantic , nvidia::apex::RenderBoneSemantic
  • POSITION
: nvidia::apex::RenderSpriteSemantic
, nvidia::apex::RenderVertexSemantic
, nvidia::apex::IofxRenderSemantic
, nvidia::apex::RenderInstanceSemantic
  • POSITION_FLOAT4 : nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
  • PREVIOUS_POSE : nvidia::apex::RenderBoneSemantic

- r -

  • R32G32B32A32_FLOAT : nvidia::apex::RenderDataFormat
  • R8G8B8A8 : nvidia::apex::RenderDataFormat
  • RAYCASTS : nvidia::apex::PhysXObjectDesc
  • ROTATION : nvidia::apex::IofxRenderSemantic
  • ROTATION_SCALE : nvidia::apex::RenderInstanceSemantic

- s -

  • SCALE : nvidia::apex::IofxRenderSemantic , nvidia::apex::RenderSpriteSemantic
  • SCALE_ORIENT_SUBTEX_FLOAT4 : nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
  • SegmentIntersect : nvidia::apex::DestructibleActorRaycastFlags
  • SHORT1 : nvidia::apex::RenderDataFormat
  • SHORT2 : nvidia::apex::RenderDataFormat
  • SHORT3 : nvidia::apex::RenderDataFormat
  • SHORT4 : nvidia::apex::RenderDataFormat
  • SHORT_SNORM1 : nvidia::apex::RenderDataFormat
  • SHORT_SNORM2 : nvidia::apex::RenderDataFormat
  • SHORT_SNORM3 : nvidia::apex::RenderDataFormat
  • SHORT_SNORM4 : nvidia::apex::RenderDataFormat
  • SHORT_SNORM4_QUATXYZW : nvidia::apex::RenderDataFormat
  • SHORT_UNORM1 : nvidia::apex::RenderDataFormat
  • SHORT_UNORM2 : nvidia::apex::RenderDataFormat
  • SHORT_UNORM3 : nvidia::apex::RenderDataFormat
  • SHORT_UNORM4 : nvidia::apex::RenderDataFormat
  • SPHERICAL : nvidia::apex::ApexMeshParticleRollType
  • SPRITE : nvidia::apex::IofxRenderable , nvidia::apex::ApexMeshParticleRollType
  • SUBTEXTURE : nvidia::apex::IofxRenderSemantic , nvidia::apex::RenderSpriteSemantic

- t -

  • TANGENT : nvidia::apex::RenderVertexSemantic
  • Teleport : nvidia::apex::ClothingTeleportMode
  • TeleportAndReset : nvidia::apex::ClothingTeleportMode
  • TEXCOORD0 : nvidia::apex::RenderVertexSemantic
  • TEXCOORD1 : nvidia::apex::RenderVertexSemantic
  • TEXCOORD2 : nvidia::apex::RenderVertexSemantic
  • TEXCOORD3 : nvidia::apex::RenderVertexSemantic
  • TRANSFORM : nvidia::apex::PhysXObjectDesc

- u -

  • UBYTE1 : nvidia::apex::RenderDataFormat
  • UBYTE2 : nvidia::apex::RenderDataFormat
  • UBYTE3 : nvidia::apex::RenderDataFormat
  • UBYTE4 : nvidia::apex::RenderDataFormat
  • UINT1 : nvidia::apex::RenderDataFormat
  • UINT2 : nvidia::apex::RenderDataFormat
  • UINT3 : nvidia::apex::RenderDataFormat
  • UINT4 : nvidia::apex::RenderDataFormat
  • UNSPECIFIED : nvidia::apex::RenderDataFormat
  • USE_VALID_BOUNDS : nvidia::apex::DestructibleParametersFlag
  • USER_DATA
: nvidia::apex::IofxRenderSemantic
, nvidia::apex::RenderInstanceSemantic
, nvidia::apex::RenderSpriteSemantic
  • USER_FLAG_0 : nvidia::apex::DestructibleDepthParametersFlag
  • USHORT1 : nvidia::apex::RenderDataFormat
  • USHORT2 : nvidia::apex::RenderDataFormat
  • USHORT3 : nvidia::apex::RenderDataFormat
  • USHORT4 : nvidia::apex::RenderDataFormat
  • UV_OFFSET : nvidia::apex::RenderInstanceSemantic

- v -

  • v3 : nvidia::apex::ClothSolverMode
  • VELOCITY : nvidia::apex::IofxRenderSemantic , nvidia::apex::RenderSpriteSemantic
  • VELOCITY_LIFE : nvidia::apex::RenderInstanceSemantic
  • VisualizeMeshBSPInsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeMeshBSPOutsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeMeshBSPSingleRegion : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeSliceBSPInsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeSliceBSPOutsideRegions : nvidia::apex::ExplicitHierarchicalMesh
  • VisualizeSliceBSPSingleRegion : nvidia::apex::ExplicitHierarchicalMesh

- w -

  • WORLD_SUPPORT : nvidia::apex::DestructibleInitParametersFlag
  • WORLD_SUPPORTED : nvidia::apex::ApexChunkFlag
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- a -

  • acquireChunkEventBuffer() : nvidia::apex::DestructibleActor
  • acquirePhysXActorBuffer() : nvidia::apex::DestructibleActor
  • acquireReadLock() : nvidia::apex::RWLockable
  • acquireRenderableReference()
: nvidia::apex::DestructibleActor
, nvidia::apex::IofxActor
, nvidia::apex::TurbulenceFSActor
  • acquireRenderProxy() : nvidia::apex::ClothingActor
  • acquireWriteLock() : nvidia::apex::RWLockable
  • addActorPair() : nvidia::apex::Scene
  • addBoneCapsule() : nvidia::apex::ClothingAssetAuthoring
  • addBoneConvex() : nvidia::apex::ClothingAssetAuthoring
  • addBoundingBox() : nvidia::apex::Scene
  • addBuffer() : nvidia::apex::VertexFormat
  • addChild() : NvParameterized::Definition
  • addChunkOverlaps()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • addControlPoint() : nvidia::apex::Curve
  • addControlPoints() : nvidia::apex::Curve
  • addDebugRenderable() : nvidia::apex::RenderDebugInterface
  • addDependentActor() : nvidia::apex::IofxAsset
  • addEllipsoidList() : nvidia::apex::EmitterGeomExplicit
  • addEnumVal() : NvParameterized::Definition
  • addForce() : nvidia::apex::DestructibleActor
  • addHint() : NvParameterized::Definition
  • addIofxAsset() : nvidia::apex::RenderVolume
  • addMaterialFrame() : nvidia::apex::ExplicitHierarchicalMesh
  • addParticleList() : nvidia::apex::EmitterGeomExplicit
  • addPlatformToGraphicalLod() : nvidia::apex::ClothingAssetAuthoring
  • addRef() : nvidia::apex::UserRenderData
  • addSphereList() : nvidia::apex::EmitterGeomExplicit
  • addSubmesh() : nvidia::apex::ExplicitHierarchicalMesh
  • addTriangle() : nvidia::apex::ClothingTriangleMesh
  • addTriangles() : nvidia::apex::ClothingTriangleMesh
  • affectsIofxAsset() : nvidia::apex::RenderVolume
  • alignment() : NvParameterized::Definition
  • alloc() : NvParameterized::Traits
  • allocate() : NvParameterized::Traits::Allocator
  • allocateConstrainCoefficientBuffer() : nvidia::apex::ClothingPhysicalMesh
  • allocateMasterFlagsBuffer() : nvidia::apex::ClothingPhysicalMesh
  • Allocator() : NvParameterized::Traits::Allocator
  • allocProjMatrix() : nvidia::apex::Scene
  • allocViewMatrix() : nvidia::apex::Scene
  • APEX_ACTOR_TEMPLATE_PARAM() : nvidia::apex::PhysX3DescTemplate
  • ApexDesc() : nvidia::apex::ApexDesc
  • ApexSDKDesc() : nvidia::apex::ApexSDKDesc
  • append() : nvidia::apex::PhysXRenderBuffer
  • appendActorTransforms() : nvidia::apex::DestructibleAssetAuthoring
  • applyDamage() : nvidia::apex::DestructibleActor
  • applyRadiusDamage()
: nvidia::apex::DestructibleActor
, nvidia::apex::ModuleDestructible
  • applyTransformation()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::ClothingAssetAuthoring
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • areParamsOK() : NvParameterized::Interface
  • arrayDimension() : NvParameterized::Definition
  • arraySize() : NvParameterized::Definition
  • arraySizeIsFixed() : NvParameterized::Definition
  • asFloat() : NvParameterized::Hint
  • asString() : NvParameterized::Hint
  • asUInt() : NvParameterized::Hint
  • attachVertexToGlobalPosition() : nvidia::apex::ClothingActor
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- j -

  • joint() : nvidia::apex::DestructibleActorJoint
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- l -

  • loadAllLegacyModules() : nvidia::apex::ModuleLoader
  • loadAllModules() : nvidia::apex::ModuleLoader
  • loadModule() : nvidia::apex::ModuleLoader
  • loadModules() : nvidia::apex::ModuleLoader
  • locateGraphicsMaterialData() : nvidia::apex::ModuleParticles
  • locateResource() : nvidia::apex::ModuleParticles
  • lockIofxActorList() : nvidia::apex::RenderVolume
  • lockModuleSceneRenderLock() : nvidia::apex::Module
  • lockRead() : nvidia::apex::Scene
  • lockRenderResources() : nvidia::apex::RenderDataProvider
  • lockTriangles() : nvidia::apex::ClothingTriangleMesh
  • lockTrianglesWrite() : nvidia::apex::ClothingTriangleMesh
  • lockWrite() : nvidia::apex::Scene
  • longName() : NvParameterized::Definition
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- m -

  • map()
: nvidia::apex::UserRenderBuffer
, nvidia::apex::UserRenderSurface
  • maxDepth() : nvidia::apex::ExplicitHierarchicalMesh
  • meshBounds() : nvidia::apex::ExplicitHierarchicalMesh
  • MeshDesc() : nvidia::apex::RenderMeshAssetAuthoring::MeshDesc
  • MeshProcessingParameters() : FractureTools::MeshProcessingParameters
  • meshTriangleCount() : nvidia::apex::ExplicitHierarchicalMesh
  • meshTriangles() : nvidia::apex::ExplicitHierarchicalMesh
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- n -

  • name()
: NvParameterized::Hint
, NvParameterized::Definition
, NvParameterized::Interface
  • namedReferenceCallback() : NvParameterized::NamedReferenceInterface
  • nameMatch()
: NvParameterized::ParameterFind
, NvParameterized::ParameterList
  • NoiseParameters() : FractureTools::NoiseParameters
  • numChildren() : NvParameterized::Definition
  • numEnumVals() : NvParameterized::Definition
  • numHints() : NvParameterized::Definition
  • numIndexes() : NvParameterized::Handle
  • numParameters() : NvParameterized::Interface
  • numRefVariants() : NvParameterized::Definition
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- o -

  • obbSweep() : nvidia::apex::DestructibleActor
  • onAllInplaceObjectsDestroyed() : NvParameterized::Traits
  • onCreatedIofxRenderable() : nvidia::apex::IofxRenderCallback
  • onCreatedTurbulenceRenderable() : nvidia::apex::TurbulenceRenderCallback
  • onDamageNotify() : nvidia::apex::UserChunkReport
  • onDestructibleSleep() : nvidia::apex::UserChunkReport
  • onDestructibleWake() : nvidia::apex::UserChunkReport
  • onImpactDamageNotify() : nvidia::apex::UserImpactDamageReport
  • onInplaceObjectDestroyed() : NvParameterized::Traits
  • onParticleEmission() : nvidia::apex::UserChunkParticleReport
  • onPhysXActorCreate() : nvidia::apex::UserDestructiblePhysXActorReport
  • onPhysXActorRelease() : nvidia::apex::UserDestructiblePhysXActorReport
  • onPreProcessReadBegin() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onPreProcessReadDone() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onReadBegin() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onReadDone() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onReleasingIofxRenderable() : nvidia::apex::IofxRenderCallback
  • onReleasingTurbulenceRenderable() : nvidia::apex::TurbulenceRenderCallback
  • onStateChangeNotify() : nvidia::apex::UserChunkReport
  • onUpdatedIofxRenderable() : nvidia::apex::IofxRenderCallback
  • onUpdatedTurbulenceRenderable() : nvidia::apex::TurbulenceRenderCallback
  • onWriteBegin() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • onWriteDone() : nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • operator bool() : NvParameterized::Handle
  • operator!=()
: NvParameterized::SerializePlatform
, nvidia::apex::ExplicitVertexFormat
, nvidia::apex::ExplicitSubmeshData
  • operator()() : NvParameterized::Conversion
  • operator=()
: NvParameterized::Serializer::DeserializedResults< T, bufSize >
, nvidia::apex::UserRenderDataHolder
, nvidia::apex::VertexColor
  • operator==()
: nvidia::apex::ExplicitVertexFormat
, nvidia::apex::ExplicitSubmeshData
, NvParameterized::SerializePlatform
, nvidia::apex::Range< T >
  • operator[]()
: NvParameterized::Serializer::DeserializedResults< T, bufSize >
, nvidia::apex::Vec2T< T >
, NvParameterized::Serializer::DeserializedResults< T, bufSize >
, nvidia::apex::VertexUV
  • overrideImpactDamage() : nvidia::apex::DestructibleDepthParameters
  • overrideImpactDamageValue() : nvidia::apex::DestructibleDepthParameters
  • owns() : nvidia::apex::ModuleDestructible
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- ~ -

  • ~CutoutSet() : FractureTools::CutoutSet
  • ~Definition() : NvParameterized::Definition
  • ~DestructibleAsset() : nvidia::apex::DestructibleAsset
  • ~Factory() : NvParameterized::Factory
  • ~ForceFieldAsset() : nvidia::apex::ForceFieldAsset
  • ~ForceFieldAssetAuthoring() : nvidia::apex::ForceFieldAssetAuthoring
  • ~Hint() : NvParameterized::Hint
  • ~Interface() : NvParameterized::Interface
  • ~ModuleForceField() : nvidia::apex::ModuleForceField
  • ~NamedReferenceInterface() : NvParameterized::NamedReferenceInterface
  • ~ReferenceInterface() : NvParameterized::ReferenceInterface
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- b -

  • bufferReplaceWithLast() : nvidia::apex::VertexFormat
  • buildCollisionGeometryForPart() : nvidia::apex::ExplicitHierarchicalMesh
  • buildCollisionGeometryForRootChunkParts() : nvidia::apex::ExplicitHierarchicalMesh
  • buildCoordinateSystemFromMaterialDesc() : nvidia::apex::MaterialFrame
  • buildCutoutSet()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • buildExplicitHierarchicalMesh()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • buildExplicitHierarchicalMeshFromDestructibleAsset() : nvidia::apex::FractureToolsAPI
  • buildExplicitHierarchicalMeshFromRenderMeshAsset() : nvidia::apex::FractureToolsAPI
  • buildFromPoints() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • buildSliceMesh()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- c -

  • cacheChunkOverlapsUpToDepth()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • cacheModuleData() : nvidia::apex::Actor
  • calculateControlPoints() : nvidia::apex::Curve
  • calculateCutoutUVMapping()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • calculateFollowingControlPoint() : nvidia::apex::Curve
  • calculateMeshBSP() : nvidia::apex::ExplicitHierarchicalMesh
  • calculateNormal() : nvidia::apex::ExplicitRenderTriangle
  • callPreSerializeCallback() : NvParameterized::Interface
  • check() : nvidia::apex::TestFunctionInterface
  • checkAlignments() : NvParameterized::Interface
  • checkResults() : nvidia::apex::Scene
  • checksum() : NvParameterized::Interface
  • checkUnitTests() : nvidia::apex::TestBase
  • child() : NvParameterized::Definition
  • chunkBounds() : nvidia::apex::ExplicitHierarchicalMesh
  • chunkCount() : nvidia::apex::ExplicitHierarchicalMesh
  • chunkFlags() : nvidia::apex::ExplicitHierarchicalMesh
  • chunkUniqueID() : nvidia::apex::ExplicitHierarchicalMesh
  • className() : NvParameterized::Interface
  • clear()
: nvidia::apex::ApexSDKCachedData
, nvidia::apex::ExplicitVertexFormat
, nvidia::apex::ExplicitHierarchicalMesh
, nvidia::apex::PhysXRenderBuffer
  • clearActorTransforms() : nvidia::apex::DestructibleAssetAuthoring
  • clearAllBoneActors() : nvidia::apex::ClothingAssetAuthoring
  • clearBoneActors() : nvidia::apex::ClothingAssetAuthoring
  • clearChunkOverlaps()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • clearCollision() : nvidia::apex::ClothingAssetAuthoring
  • clearMeshes() : nvidia::apex::ClothingAssetAuthoring
  • clearTriangles() : nvidia::apex::ClothingTriangleMesh
  • clone() : NvParameterized::Interface
  • CollisionDesc() : nvidia::apex::CollisionDesc
  • ColorRGBA() : nvidia::apex::ColorRGBA
  • convexHullCount() : nvidia::apex::ExplicitHierarchicalMesh
  • convexHulls() : nvidia::apex::ExplicitHierarchicalMesh
  • cookChunks() : nvidia::apex::DestructibleAssetAuthoring
  • copy() : NvParameterized::Interface
  • copyToVertexFormat() : nvidia::apex::ExplicitVertexFormat
  • create() : NvParameterized::Factory
  • createActor() : nvidia::apex::RenderMeshAsset
  • createApexActor() : nvidia::apex::Asset
  • createApexAssetPreview() : nvidia::apex::Asset
  • createApexBoxShape() : nvidia::apex::ApexSDK
  • createApexCapsuleShape() : nvidia::apex::ApexSDK
  • createApexHalfSpaceShape() : nvidia::apex::ApexSDK
  • createApexRenderDebug() : nvidia::apex::ApexSDK
  • createApexSphereShape() : nvidia::apex::ApexSDK
  • createAsset() : nvidia::apex::ApexSDK
  • createAssetAuthoring() : nvidia::apex::ApexSDK
  • createAssetPreviewScene() : nvidia::apex::ApexSDK
  • createBoneBuffer() : nvidia::apex::UserRenderResourceManager
  • createChippedMesh()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • createCollisionCapsule() : nvidia::apex::ClothingActor
  • createCollisionConvex() : nvidia::apex::ClothingActor
  • createCollisionPlane() : nvidia::apex::ClothingActor
  • createCollisionSphere() : nvidia::apex::ClothingActor
  • createCollisionTriangleMesh() : nvidia::apex::ClothingActor
  • createCutoutSet() : nvidia::apex::FractureToolsAPI
  • createDestructibleActorFromDeserializedState() : nvidia::apex::DestructibleAsset
  • createDestructibleActorJoint() : nvidia::apex::ModuleDestructible
  • createEmptyPhysicalMesh() : nvidia::apex::ModuleClothing
  • createExplicitHierarchicalMesh() : nvidia::apex::FractureToolsAPI
  • createExplicitHierarchicalMeshConvexHull()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • createForceSampleBatch() : nvidia::apex::ModuleFieldSampler
  • createHierarchicallySplitMesh()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • createIndexBuffer() : nvidia::apex::UserRenderResourceManager
  • createInstanceBuffer() : nvidia::apex::UserRenderResourceManager
  • createIofxRenderableIterator() : nvidia::apex::ModuleIofx
  • createIosActor() : nvidia::apex::IosAsset
  • createMemoryReadStream() : nvidia::apex::ApexSDK
  • createMemoryWriteStream() : nvidia::apex::ApexSDK
  • createMirrorScene() : nvidia::apex::Scene
  • createModule() : nvidia::apex::ApexSDK
  • createNvParameterized() : NvParameterized::Traits
  • createPhysX3DescTemplate() : nvidia::apex::ActorSource
  • createReductionMap() : nvidia::apex::RenderMeshAssetAuthoring
  • createRenderableIterator()
: nvidia::apex::Module
, nvidia::apex::Context
  • createRenderBuffer() : nvidia::apex::UserRenderCallback
  • createRenderMesh() : nvidia::apex::RenderMeshAssetAuthoring
  • createRenderSurface() : nvidia::apex::UserRenderCallback
  • createRenderVolume() : nvidia::apex::ModuleIofx
  • createResource() : nvidia::apex::UserRenderResourceManager
  • createScatterMeshSites()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • createScene() : nvidia::apex::ApexSDK
  • createSerializer() : nvidia::apex::ApexSDK
  • createSingleLayeredMesh() : nvidia::apex::ModuleClothing
  • createSpriteBuffer() : nvidia::apex::UserRenderResourceManager
  • createStream() : nvidia::apex::ApexSDK
  • createSurfaceBuffer() : nvidia::apex::UserRenderResourceManager
  • createVertexBuffer() : nvidia::apex::UserRenderResourceManager
  • createVoronoiSitesInsideMesh()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • createVoronoiSplitMesh()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • CutoutParameters() : FractureTools::CutoutParameters
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- d -

  • deallocate() : NvParameterized::Traits::Allocator
  • decRefCount() : NvParameterized::Traits
  • deleteStaticBuffersAfterUse() : nvidia::apex::RenderMeshAssetAuthoring
  • deserialize()
: nvidia::apex::ApexSDKCachedData
, NvParameterized::Serializer
, nvidia::apex::ExplicitHierarchicalMesh::Embedding
, nvidia::apex::ExplicitHierarchicalMesh
, NvParameterized::Serializer
  • DeserializedResults() : NvParameterized::Serializer::DeserializedResults< T, bufSize >
  • deserializeFractureToolState() : nvidia::apex::DestructibleAssetAuthoring
  • deserializeInplace() : NvParameterized::Serializer
  • deserializeMetadata() : NvParameterized::Serializer
  • deserializeSingleAsset() : nvidia::apex::ModuleCachedData
  • destroy()
: NvParameterized::Interface
, NvParameterized::Definition
  • DestructibleActorJointDesc() : nvidia::apex::DestructibleActorJointDesc
  • DestructibleAssetCookingDesc() : nvidia::apex::DestructibleAssetCookingDesc
  • DestructibleBehaviorGroupDesc() : nvidia::apex::DestructibleBehaviorGroupDesc
  • DestructibleChunkDesc() : nvidia::apex::DestructibleChunkDesc
  • DestructibleDepthParameters() : nvidia::apex::DestructibleDepthParameters
  • DestructibleGeometryDesc() : nvidia::apex::DestructibleGeometryDesc
  • DestructibleInitParameters() : nvidia::apex::DestructibleInitParameters
  • DestructibleParameters() : nvidia::apex::DestructibleParameters
  • disable() : nvidia::apex::ForceFieldActor
  • disableCudaInterop() : nvidia::apex::ModuleIofx
  • disableCudaModifiers() : nvidia::apex::ModuleIofx
  • disableDeferredRenderableAllocation() : nvidia::apex::ModuleIofx
  • disableHardSleeping() : nvidia::apex::DestructibleActor
  • dispatchRenderResources() : nvidia::apex::Renderable
  • displacementMapVolume() : nvidia::apex::ExplicitHierarchicalMesh
  • doesFactoryExist() : NvParameterized::Traits
  • done() : NvParameterized::ParameterFind
  • drawEmitterPreview()
: nvidia::apex::GroundEmitterPreview
, nvidia::apex::EmitterPreview
  • drawFlameEmitterPreview() : nvidia::apex::FlameEmitterPreview
  • drawHeatSourcePreview() : nvidia::apex::HeatSourcePreview
  • drawVelocitySourcePreview() : nvidia::apex::VelocitySourcePreview
  • dumpResourceTable() : nvidia::apex::ResourceProvider
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- e -

  • emitAssetParticles() : nvidia::apex::EmitterActor
  • EmitterLodParamDesc() : nvidia::apex::EmitterLodParamDesc
  • enable() : nvidia::apex::ForceFieldActor
  • enableHardSleeping() : nvidia::apex::DestructibleActor
  • enableOutputDensityField() : nvidia::apex::ModuleTurbulenceFS
  • enableOutputFlameField() : nvidia::apex::ModuleTurbulenceFS
  • enableOutputVelocityField() : nvidia::apex::ModuleTurbulenceFS
  • enablePhysXMonitor() : nvidia::apex::ModuleFieldSampler
  • enumVal() : NvParameterized::Definition
  • enumValIndex() : NvParameterized::Definition
  • equals() : NvParameterized::Interface
  • evaluate() : nvidia::apex::Curve
  • ExplicitHierarchicalMesh() : nvidia::apex::ExplicitHierarchicalMesh
  • ExplicitVertexFormat() : nvidia::apex::ExplicitVertexFormat
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- f -

  • fadeIn() : nvidia::apex::EffectPackageActor
  • fadeOut() : nvidia::apex::EffectPackageActor
  • fetchResults() : nvidia::apex::Scene
  • fieldSamplerWeightedCollisionFilter() : nvidia::apex::FieldSamplerWeightedCollisionFilterCallback
  • findActorPair() : nvidia::apex::Scene
  • findAllResourceNames() : nvidia::apex::ResourceProvider
  • findAllResources() : nvidia::apex::ResourceProvider
  • findNameSpaces() : nvidia::apex::ResourceProvider
  • findRefCount() : nvidia::apex::ResourceProvider
  • findResource() : nvidia::apex::ResourceProvider
  • findResourceU32() : nvidia::apex::ResourceProvider
  • finish() : NvParameterized::Factory
  • finishNvParameterized() : NvParameterized::Traits
  • forceChunkHits() : nvidia::apex::DestructibleActor
  • forceDamageColoring() : nvidia::apex::DestructibleActor
  • forceLoadAssets()
: nvidia::apex::ApexSDK
, nvidia::apex::Asset
  • forceLod() : nvidia::apex::Actor
  • FractureCutoutDesc() : FractureTools::FractureCutoutDesc
  • FractureMaterialDesc() : nvidia::apex::FractureMaterialDesc
  • FractureSliceDesc() : FractureTools::FractureSliceDesc
  • FractureVoronoiDesc() : FractureTools::FractureVoronoiDesc
  • free() : NvParameterized::Traits
  • freeParameterDefinitionTable() : NvParameterized::Factory
  • freeVertex() : nvidia::apex::ClothingActor
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- g -

  • getAABB() : nvidia::apex::Shape
  • getActiveLod() : nvidia::apex::Actor
  • getActiveParticleCount()
: nvidia::apex::EffectPackageActor
, nvidia::apex::EmitterActor
  • getActor() : nvidia::apex::ClothingAsset
  • getActorDesc() : nvidia::apex::ClothingActor
  • getActorTransformCount()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • getActorTransforms()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getAffectsAllIofx() : nvidia::apex::RenderVolume
  • getAlignment()
: NvParameterized::Factory
, NvParameterized::Traits
  • getAllocator() : nvidia::apex::ApexSDK
  • getApexActor() : nvidia::apex::PhysXObjectDesc
  • getApexActorCount() : nvidia::apex::PhysXObjectDesc
  • getApexEmitter() : nvidia::apex::DestructibleActor
  • getArrayIndex() : NvParameterized::ParameterFind
  • getArraySize()
: NvParameterized::Handle
, NvParameterized::Interface
  • getAssetNvParameterized() : nvidia::apex::Asset
  • getAttachActor()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
  • getAttachRelativePose() : nvidia::apex::EmitterActor
  • getAttachRelativePosition() : nvidia::apex::GroundEmitterActor
  • getAttractorFSAsset() : nvidia::apex::AttractorFSActor
  • getAttributeIndex() : nvidia::apex::CustomBufferIterator
  • getAuthorableObjectNames() : nvidia::apex::ApexSDK
  • getAverageDensity() : nvidia::apex::SubstanceSourceActor
  • getAverageTemperature() : nvidia::apex::HeatSourceActor
  • getAverageVelocity() : nvidia::apex::VelocitySourceActor
  • getBasicIosTypeName() : nvidia::apex::ModuleBasicIos
  • getBehaviorGroup() : nvidia::apex::DestructibleActor
  • getBiggestMaxDistance() : nvidia::apex::ClothingAsset
  • getBoneBasePose() : nvidia::apex::ClothingAsset
  • getBoneBindPose() : nvidia::apex::ClothingAssetAuthoring
  • getBoneBuffer() : nvidia::apex::UserRenderResource
  • getBoneCount() : nvidia::apex::RenderMeshActor
  • getBoneIndices() : nvidia::apex::ClothingPhysicalMesh
  • getBoneMapping() : nvidia::apex::ClothingAsset
  • getBoneName() : nvidia::apex::ClothingAsset
  • getBoneWeights() : nvidia::apex::ClothingPhysicalMesh
  • getBoundingBox()
: nvidia::apex::ClothingAsset
, nvidia::apex::Scene
  • getBoundingBoxCount() : nvidia::apex::Scene
  • getBoundingBoxFlags() : nvidia::apex::Scene
  • getBounds()
: nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
, nvidia::apex::IofxActor
, nvidia::apex::IofxRenderable
, nvidia::apex::RenderVolume
, nvidia::apex::Renderable
, nvidia::apex::RenderMeshAssetAuthoring
, nvidia::apex::RenderMeshAsset
, nvidia::apex::TurbulenceRenderable
  • getBoxShape()
: nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::VelocitySourceActor
  • getBuffer() : nvidia::apex::VertexBuffer
  • getBufferAccess() : nvidia::apex::VertexFormat
  • getBufferAndFormat() : nvidia::apex::VertexBuffer
  • getBufferAndFormatWritable() : nvidia::apex::VertexBuffer
  • getBufferCount() : nvidia::apex::VertexFormat
  • getBufferData() : nvidia::apex::VertexBuffer
  • getBufferFormat() : nvidia::apex::VertexFormat
  • getBufferID() : nvidia::apex::VertexFormat
  • getBufferIndexFromID() : nvidia::apex::VertexFormat
  • getBufferName() : nvidia::apex::VertexFormat
  • getBufferSemantic() : nvidia::apex::VertexFormat
  • getBufferSerialize() : nvidia::apex::VertexFormat
  • getCachedData() : nvidia::apex::ApexSDK
  • getCachedDataForAssetAtScale() : nvidia::apex::ModuleCachedData
  • getCachedOverlapCountAtDepth()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getCachedOverlapsAtDepth()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getCacheForModule() : nvidia::apex::ApexSDKCachedData
  • getCameraMatrix() : nvidia::apex::AssetPreviewScene
  • getChecksum() : NvParameterized::Factory
  • getChildHandle() : NvParameterized::Handle
  • getChunkActorFlags() : nvidia::apex::DestructibleActor
  • getChunkActorLocalBounds() : nvidia::apex::DestructibleAsset
  • getChunkAngularVelocity() : nvidia::apex::DestructibleActor
  • getChunkBehaviorGroupIndex() : nvidia::apex::DestructibleActor
  • getChunkBounds() : nvidia::apex::DestructibleActor
  • getChunkChild() : nvidia::apex::DestructibleAssetAuthoring
  • getChunkChildCount() : nvidia::apex::DestructibleAssetAuthoring
  • getChunkCollisionHullCookingScale() : nvidia::apex::ModuleDestructible
  • getChunkCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkDepth() : nvidia::apex::DestructibleAsset
  • getChunkFlags() : nvidia::apex::DestructibleAsset
  • getChunkLinearVelocity() : nvidia::apex::DestructibleActor
  • getChunkLocalBounds() : nvidia::apex::DestructibleActor
  • getChunkParentIndex() : nvidia::apex::DestructibleAsset
  • getChunkPhysXActor() : nvidia::apex::DestructibleActor
  • getChunkPhysXShapes() : nvidia::apex::DestructibleActor
  • getChunkPose() : nvidia::apex::DestructibleActor
  • getChunkPositionOffset()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkTM() : nvidia::apex::DestructibleActor
  • getChunkTransform() : nvidia::apex::DestructibleActor
  • getChunkUVOffset()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getChunkVisibilities() : nvidia::apex::DestructibleActor
  • getClassName() : NvParameterized::Factory
  • getClothingMaterial() : nvidia::apex::ClothingActor
  • getClothingPhysicalMesh() : nvidia::apex::ClothingAssetAuthoring
  • getClothSolverMode()
: nvidia::apex::ClothingActor
, nvidia::apex::ClothingAsset
  • getColorChannel()
: nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::ColorVsVelocityModifier
  • getConstInterface() : NvParameterized::Handle
  • getConstrainCoefficientBuffer() : nvidia::apex::ClothingPhysicalMesh
  • getConstrainCoefficients() : nvidia::apex::ClothingPhysicalMesh
  • getContactReportFlags() : nvidia::apex::PhysX3Interface
  • getContinuousModifiers() : nvidia::apex::IofxAsset
  • getControlPoints() : nvidia::apex::Curve
  • getCookingInterface() : nvidia::apex::ApexSDK
  • getCoreExplicitHierarchicalMesh() : nvidia::apex::DestructibleAssetAuthoring
  • getCrumbleEmitterName() : nvidia::apex::DestructibleAsset
  • getCUDAgraphicsResource()
: nvidia::apex::UserRenderBuffer
, nvidia::apex::UserRenderSurface
  • getCudaKernelCheckEnabled() : nvidia::apex::Scene
  • getCudaProfileManager() : nvidia::apex::Scene
  • getCudaTestManager() : nvidia::apex::Scene
  • getCurrentBoneSkinningMatrices() : nvidia::apex::ClothingActor
  • getCurrentLife() : nvidia::apex::EffectPackageActor
  • getCurrentPlatform() : nvidia::apex::ApexSDK
  • getCurrentPose()
: nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
  • getCurrentPosition()
: nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
  • getCurrentScale()
: nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::EmitterActor
, nvidia::apex::ForceFieldActor
, nvidia::apex::EffectPackageActor
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::VelocitySourceActor
  • getCurrentVersion() : NvParameterized::Traits
  • getCustomBehaviorGroupCount() : nvidia::apex::DestructibleActor
  • getCustomBufferCount() : nvidia::apex::VertexFormat
  • getCustomSemanticData() : nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >
  • getCutoutCount() : FractureTools::CutoutSet
  • getCutoutLoopCount() : FractureTools::CutoutSet
  • getCutoutLoopSize() : FractureTools::CutoutSet
  • getCutoutLoopVertexFlags() : FractureTools::CutoutSet
  • getCutoutLoopVertexIndex() : FractureTools::CutoutSet
  • getCutoutSet() : nvidia::apex::DestructibleAssetAuthoring
  • getCutoutVertex() : FractureTools::CutoutSet
  • getCutoutVertexCount() : FractureTools::CutoutSet
  • getDamageColoringHistory() : nvidia::apex::DestructibleActor
  • getData() : nvidia::apex::DisplacementMapVolume
  • getDebugColorParams() : nvidia::apex::ApexSDK
  • getDebugRenderParams() : nvidia::apex::Scene
  • getDefaultActorDesc() : nvidia::apex::Asset
  • getDefaultAssetPreviewDesc() : nvidia::apex::Asset
  • getDefaultModuleDesc() : nvidia::apex::Module
  • getDefaultScale() : nvidia::apex::ForceFieldAsset
  • getDensity()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterActor
  • getDensityGridDimensions() : nvidia::apex::TurbulenceFSActor
  • getDensityScale() : nvidia::apex::ModuleEmitter
  • getDepthCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getDestructibleAndChunk() : nvidia::apex::ModuleDestructible
  • getDestructibleInitParameters()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getDestructibleParameters()
: nvidia::apex::DestructibleActor
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getDimensions()
: FractureTools::CutoutSet
, nvidia::apex::CapsuleShape
  • getDistance() : nvidia::apex::EmitterGeomExplicit
  • getDuration()
: nvidia::apex::EffectPackageActor
, nvidia::apex::EffectPackageAsset
  • getDustEmitterName() : nvidia::apex::DestructibleAsset
  • getDynamicHandleIndicesMap() : NvParameterized::Definition
  • getEdgeCount() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getEdgeEndpoint() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getEffectActor() : nvidia::apex::EffectPackageActor
  • getEffectCount() : nvidia::apex::EffectPackageActor
  • getEffectName() : nvidia::apex::EffectPackageActor
  • getEffectPackageDatabase() : nvidia::apex::ModuleParticles
  • getEffectPackageEmitterDatabase() : nvidia::apex::ModuleParticles
  • getEffectPackageFieldSamplerDatabase() : nvidia::apex::ModuleParticles
  • getEffectPackageGraphicsMaterialsDatabase() : nvidia::apex::ModuleParticles
  • getEffectPackageIOFXDatabase() : nvidia::apex::ModuleParticles
  • getEffectPackageIOSDatabase() : nvidia::apex::ModuleParticles
  • getEffectPose() : nvidia::apex::EffectPackageActor
  • getEffectRigidDynamic() : nvidia::apex::EffectPackageActor
  • getEffectType() : nvidia::apex::EffectPackageActor
  • getEllipsoidCenter() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidCount() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidList() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidNormal() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidPolarRadius() : nvidia::apex::EmitterGeomExplicit
  • getEllipsoidRadius() : nvidia::apex::EmitterGeomExplicit
  • getEmitAssetParticles() : nvidia::apex::EmitterActor
  • getEmitDuration() : nvidia::apex::EmitterAsset
  • getEmitterAsset()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
, nvidia::apex::ImpactEmitterActor
  • getEmitterType() : nvidia::apex::EmitterGeom
  • getEnabled() : nvidia::apex::EffectPackageActor
  • getErrorCallback() : nvidia::apex::ApexSDK
  • getExplicitHierarchicalMesh() : nvidia::apex::DestructibleAssetAuthoring
  • getExtents() : nvidia::apex::EmitterGeomBox
  • getEyeDirection() : nvidia::apex::Scene
  • getEyePosition() : nvidia::apex::Scene
  • getFirst()
: nvidia::apex::RenderableIterator
, nvidia::apex::IofxRenderableIterator
  • getFirstVertexIndex() : nvidia::apex::RenderSubmesh
  • getFlameEmitterAsset() : nvidia::apex::FlameEmitterActor
  • getFlameGridDimensions() : nvidia::apex::TurbulenceFSActor
  • getForceFieldAsset() : nvidia::apex::ForceFieldActor
  • getFormat()
: nvidia::apex::IofxSpriteRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::IofxMeshRenderLayoutElement
, nvidia::apex::VertexBuffer
  • getFormatDataSize() : nvidia::apex::RenderDataFormat
  • getFormatWritable() : nvidia::apex::VertexBuffer
  • getFractureImpulseScale() : nvidia::apex::DestructibleAssetAuthoring
  • getFractureTools() : nvidia::apex::ModuleDestructible
  • getFunction()
: nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::SubtextureVsLifeModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::ColorVsVelocityModifier
  • getGeom() : nvidia::apex::EmitterAsset
  • getGlobalPose()
: nvidia::apex::ClothingActor
, nvidia::apex::DestructibleActor
, nvidia::apex::EmitterActor
  • getGraphicalLod() : nvidia::apex::ClothingActor
  • getGraphicalLodValue() : nvidia::apex::ClothingAsset
  • getGravity() : nvidia::apex::Scene
  • getGridBoundingBoxMax() : nvidia::apex::TurbulenceFSActor
  • getGridBoundingBoxMin() : nvidia::apex::TurbulenceFSActor
  • getGridDimensions() : nvidia::apex::TurbulenceFSActor
  • getGridSize() : nvidia::apex::TurbulenceFSActor
  • getGridSizePow() : nvidia::apex::ModuleTurbulenceFS
  • getGroundDensityScale() : nvidia::apex::ModuleEmitter
  • getHeatSourceAsset() : nvidia::apex::HeatSourceActor
  • getHeight() : nvidia::apex::EmitterGeomCylinder
  • getHitChunkHistory() : nvidia::apex::DestructibleActor
  • getID() : nvidia::apex::VertexFormat
  • getImpactVelocityThreshold() : nvidia::apex::DestructibleAssetAuthoring
  • getIndexBuffer()
: nvidia::apex::RenderSubmesh
, nvidia::apex::UserRenderResource
  • getIndexCount() : nvidia::apex::RenderSubmesh
  • getIndices() : nvidia::apex::ClothingPhysicalMesh
  • getInitialGlobalPose() : nvidia::apex::DestructibleActor
  • getInstanceBuffer()
: nvidia::apex::RenderMeshActor
, nvidia::apex::UserRenderResource
  • getInstancedChunkMeshCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getInstancedObjectEffectsAssetName() : nvidia::apex::EmitterAsset
  • getInstancedObjectSimulatorAssetName() : nvidia::apex::EmitterAsset
  • getInstancedObjectSimulatorTypeName() : nvidia::apex::EmitterAsset
  • getInstanceLayoutData() : nvidia::apex::UserRenderResourceManager
  • getInterface() : NvParameterized::Handle
  • getInteropResourceHandle()
: nvidia::apex::UserRenderIndexBuffer
, nvidia::apex::UserRenderInstanceBuffer
, nvidia::apex::UserRenderSpriteBuffer
, nvidia::apex::UserRenderSurfaceBuffer
, nvidia::apex::UserRenderVertexBuffer
  • getInteropTextureHandleList() : nvidia::apex::UserRenderSpriteBuffer
  • getIofxAssetList() : nvidia::apex::RenderVolume
  • getIofxLegacyRenderCallback() : nvidia::apex::ModuleIofxLegacy
  • getIofxMeshRenderLayout() : nvidia::apex::IofxRenderCallback
  • getIofxRenderCallback() : nvidia::apex::ModuleIofx
  • getIofxSpriteRenderLayout() : nvidia::apex::IofxRenderCallback
  • getIosAssetName() : nvidia::apex::IofxActor
  • getJetFSAsset() : nvidia::apex::JetFSActor
  • getLayoutFormat() : nvidia::apex::RenderSpriteTextureLayout
  • getLifetimeHigh()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterAsset
  • getLifetimeLow()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterAsset
  • getLines() : nvidia::apex::PhysXRenderBuffer
  • getLoadedModule() : nvidia::apex::ModuleLoader
  • getLoadedModuleCount() : nvidia::apex::ModuleLoader
  • getLoadedModulesErrors() : nvidia::apex::ModuleLoader
  • getLocalBounds() : nvidia::apex::DestructibleActor
  • getLodParamDesc()
: nvidia::apex::EmitterActor
, nvidia::apex::EmitterAsset
  • getLodRange() : nvidia::apex::Actor
  • getLodValue() : nvidia::apex::ClothingAssetAuthoring
  • getLongName() : NvParameterized::Handle
  • getMajorVersion() : NvParameterized::Interface
  • getMasterFlagsBuffer() : nvidia::apex::ClothingPhysicalMesh
  • getMaterialFrame() : nvidia::apex::ExplicitHierarchicalMesh
  • getMaterialFrameCount() : nvidia::apex::ExplicitHierarchicalMesh
  • getMaterialLibrary() : nvidia::apex::ClothingAssetAuthoring
  • getMaterialLookupCallback() : nvidia::apex::GroundEmitterActor
  • getMaterialName()
: nvidia::apex::RenderMeshAssetAuthoring
, nvidia::apex::RenderMeshAsset
  • getMaterials() : nvidia::apex::PhysX3DescTemplate
  • getMaxBonesForMaterial() : nvidia::apex::UserRenderResourceManager
  • getMaxDistanceBlendTime() : nvidia::apex::ClothingActor
  • getMaximumSimulationBudget() : nvidia::apex::ClothingActor
  • getMaxInjectedParticleCount()
: nvidia::apex::BasicIosAsset
, nvidia::apex::ParticleIosAsset
  • getMaxParticleCount()
: nvidia::apex::BasicIosAsset
, nvidia::apex::ParticleIosAsset
  • getMaxRaycastsPerFrame()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::GroundEmitterAsset
  • getMaxRotationRate() : nvidia::apex::RotationModifier
  • getMaxSamples() : nvidia::apex::EmitterAsset
  • getMaxSettleRate() : nvidia::apex::RotationModifier
  • getMemoryWriteBuffer() : nvidia::apex::ApexSDK
  • getMeshAssetCount() : nvidia::apex::IofxAsset
  • getMeshAssetName() : nvidia::apex::IofxAsset
  • getMeshAssetWeight() : nvidia::apex::IofxAsset
  • getMeshRenderData() : nvidia::apex::IofxRenderable
  • getMeshSkinningMap() : nvidia::apex::ClothingAsset
  • getMeshSkinningMapSize() : nvidia::apex::ClothingAsset
  • getMinorVersion() : NvParameterized::Interface
  • getModelForward() : nvidia::apex::OrientAlongVelocityModifier
  • getModifierMeshSemantics() : nvidia::apex::Modifier
  • getModifierSpriteSemantics() : nvidia::apex::Modifier
  • getModifierType()
: nvidia::apex::Modifier
, nvidia::apex::ModifierT< T >
  • getModifierUsage()
: nvidia::apex::Modifier
, nvidia::apex::ModifierT< T >
  • getModule() : nvidia::apex::ModuleParticles
  • getModuleDebugRenderParams() : nvidia::apex::Scene
  • getModuleID() : nvidia::apex::Module
  • getModules() : nvidia::apex::ApexSDK
  • getModuleValue() : nvidia::apex::ModuleForceField
  • getName()
: nvidia::apex::Asset
, nvidia::apex::AssetAuthoring
, nvidia::apex::ForceFieldActor
, nvidia::apex::Module
, nvidia::apex::EffectPackageActor
  • getNamedResourceProvider() : nvidia::apex::ApexSDK
  • getNbLines() : nvidia::apex::PhysXRenderBuffer
  • getNbModules() : nvidia::apex::ApexSDK
  • getNbPoints() : nvidia::apex::PhysXRenderBuffer
  • getNbTexts() : nvidia::apex::PhysXRenderBuffer
  • getNbTriangles() : nvidia::apex::PhysXRenderBuffer
  • getNbVertexBuffers() : nvidia::apex::UserRenderResource
  • getNeighborPadding() : nvidia::apex::DestructibleAssetAuthoring
  • getNext()
: nvidia::apex::RenderableIterator
, nvidia::apex::IofxRenderableIterator
  • getNoiseFSAsset() : nvidia::apex::NoiseFSActor
  • getNormal() : nvidia::apex::HalfSpaceShape
  • getNormals() : nvidia::apex::ClothingPhysicalMesh
  • getNumActors() : nvidia::apex::ClothingAsset
  • getNumBones() : nvidia::apex::ClothingAsset
  • getNumBonesPerVertex() : nvidia::apex::ClothingPhysicalMesh
  • getNumCustomSemantics() : nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >
  • getNumGraphicalLodLevels() : nvidia::apex::ClothingAsset
  • getNumGraphicalVerticesActive() : nvidia::apex::ClothingActor
  • getNumIndices() : nvidia::apex::ClothingPhysicalMesh
  • getNumLods() : nvidia::apex::ClothingAssetAuthoring
  • getNumMaxDistance0Vertices() : nvidia::apex::ClothingPhysicalMesh
  • getNumPlanes() : nvidia::apex::ClothingConvex
  • getNumPlatforms() : nvidia::apex::ClothingAssetAuthoring
  • getNumProjMatrices() : nvidia::apex::Scene
  • getNumSimulatedIndices() : nvidia::apex::ClothingPhysicalMesh
  • getNumSimulatedVertices() : nvidia::apex::ClothingPhysicalMesh
  • getNumSimulationVertices() : nvidia::apex::ClothingActor
  • getNumUsedBones() : nvidia::apex::ClothingAsset
  • getNumVertices() : nvidia::apex::ClothingPhysicalMesh
  • getNumViewMatrices() : nvidia::apex::Scene
  • getNumVisibleChunks() : nvidia::apex::DestructibleActor
  • getNvParameterized()
: nvidia::apex::AssetAuthoring
, nvidia::apex::DestructibleActor
  • getNvParameterizedNames() : NvParameterized::Traits
  • getNvParameterizedVersions() : NvParameterized::Traits
  • getObjectCount() : nvidia::apex::IofxActor
  • getObjectRadius()
: nvidia::apex::EmitterActor
, nvidia::apex::IofxActor
  • getObjects() : NvParameterized::Serializer::DeserializedResults< T, bufSize >
  • getObjectScale() : nvidia::apex::EmitterActor
  • getObjTypeID() : nvidia::apex::Asset
  • getObjTypeName()
: nvidia::apex::Asset
, nvidia::apex::AssetAuthoring
  • getOpaqueMesh() : nvidia::apex::RenderMeshAsset
  • getOrigin() : nvidia::apex::HalfSpaceShape
  • getOriginalBounds() : nvidia::apex::DestructibleActor
  • getOutputStream() : nvidia::apex::ApexSDK
  • getOwner() : nvidia::apex::Actor
  • getOwnershipBounds() : nvidia::apex::RenderVolume
  • getParam() : NvParameterized::Handle
  • getParamArray() : NvParameterized::Handle
  • getParamBool()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamBoolArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamBounds3()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamBounds3Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamEnum()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamEnumArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParameter() : NvParameterized::Handle
  • getParameterHandle() : NvParameterized::Interface
  • getParameterizedTraits() : nvidia::apex::ApexSDK
  • getParamF32()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamF32Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamF64()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamF64Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamI16()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamI16Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamI32()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamI32Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamI64()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamI64Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamI8()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamI8Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamMat33()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamMat33Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamMat34Legacy()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamMat34LegacyArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamMat44()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamMat44Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamQuat()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamQuatArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamRef()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamRefArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamString()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamStringArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamTransform()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamTransformArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU16()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU16Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU32()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU32Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU64()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU64Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamU8()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamU8Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamVec2()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamVec2Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamVec3()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamVec3Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • getParamVec4()
: NvParameterized::Interface
, NvParameterized::Handle
  • getParamVec4Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • getPartConvexHullArray() : nvidia::apex::DestructibleAsset
  • getPartConvexHullCount() : nvidia::apex::DestructibleAsset
  • getPartCount()
: nvidia::apex::RenderMeshAsset
, nvidia::apex::RenderMeshAssetAuthoring
  • getParticleCount()
: nvidia::apex::EmitterGeomExplicit
, nvidia::apex::BasicIosActor
  • getParticleIosTypeName() : nvidia::apex::ModuleParticleIos
  • getParticleList() : nvidia::apex::EmitterGeomExplicit
  • getParticleMass()
: nvidia::apex::ParticleIosAsset
, nvidia::apex::BasicIosAsset
  • getParticlePos() : nvidia::apex::EmitterGeomExplicit
  • getParticleRadius()
: nvidia::apex::BasicIosActor
, nvidia::apex::BasicIosAsset
, nvidia::apex::ParticleIosAsset
  • getPartIndex()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getPhysicalMeshNormals() : nvidia::apex::ClothingActor
  • getPhysicalMeshPositions() : nvidia::apex::ClothingActor
  • getPhysX3Template() : nvidia::apex::ActorSource
  • getPhysXObjectInfo() : nvidia::apex::ApexSDK
  • getPhysXScene() : nvidia::apex::Scene
  • getPhysXSDK() : nvidia::apex::ApexSDK
  • getPlane()
: nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
, nvidia::apex::ClothingPlane
  • getPlaneCount() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getPlanes() : nvidia::apex::ClothingConvex
  • getPlatform() : nvidia::apex::ClothingAssetAuthoring
  • getPlatformFromString() : nvidia::apex::ApexSDK
  • getPlatformName() : nvidia::apex::ApexSDK
  • getPoints() : nvidia::apex::PhysXRenderBuffer
  • getPose()
: nvidia::apex::ClothingTriangleMesh
, nvidia::apex::ForceFieldActor
, nvidia::apex::Shape
, nvidia::apex::VelocitySourceActor
, nvidia::apex::EffectPackageActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::AssetPreview
, nvidia::apex::HeatSourceActor
, nvidia::apex::FlameEmitterActor
, nvidia::apex::GroundEmitterActor
  • getPosition()
: nvidia::apex::ClothingSphere
, nvidia::apex::RenderVolume
  • getPreviousOrigin() : nvidia::apex::HalfSpaceShape
  • getPreviousPose() : nvidia::apex::Shape
  • getPriority() : nvidia::apex::RenderVolume
  • getProjMatrix() : nvidia::apex::Scene
  • getRadius()
: nvidia::apex::EmitterGeomSphereShell
, nvidia::apex::EmitterGeomCylinder
, nvidia::apex::GroundEmitterAsset
, nvidia::apex::ClothingSphere
, nvidia::apex::SphereShape
, nvidia::apex::EmitterGeomSphere
, nvidia::apex::GroundEmitterActor
  • getRate()
: nvidia::apex::EmitterActor
, nvidia::apex::EmitterAsset
  • getRateScale() : nvidia::apex::ModuleEmitter
  • getRaycastCollisionGroupMaskName() : nvidia::apex::GroundEmitterAsset
  • getRaycastCollisionGroups() : nvidia::apex::GroundEmitterActor
  • getRaycastHeight()
: nvidia::apex::GroundEmitterAsset
, nvidia::apex::GroundEmitterActor
  • getRefCount()
: nvidia::apex::ClothingSphere
, nvidia::apex::ClothingPlane
  • getRenderBuffer()
: nvidia::apex::Scene
, nvidia::apex::RenderDebugInterface
  • getRenderBufferScreenSpace()
: nvidia::apex::Scene
, nvidia::apex::RenderDebugInterface
  • getRenderData() : nvidia::apex::TurbulenceRenderable
  • getRenderDebugInterface() : nvidia::apex::RenderDebugInterface
  • getRenderGlobalPose() : nvidia::apex::ClothingActor
  • getRenderLockMode() : nvidia::apex::Module
  • getRenderMeshActor()
: nvidia::apex::DestructiblePreview
, nvidia::apex::DestructibleRenderable
, nvidia::apex::DestructibleActor
  • getRenderMeshAsset()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::ClothingAsset
  • getRenderMeshAssetAuthoring() : nvidia::apex::ClothingAssetAuthoring
  • getResource() : nvidia::apex::ResourceProvider
  • getResourceNames() : nvidia::apex::ModuleParticles
  • getRestDensity()
: nvidia::apex::BasicIosActor
, nvidia::apex::BasicIosAsset
  • getResultCount() : NvParameterized::ParameterList
  • getResults() : NvParameterized::ParameterList
  • getRollType() : nvidia::apex::RotationModifier
  • getRotationRange() : nvidia::apex::RandomRotationModifier
  • getRotationRate() : nvidia::apex::RotationRateModifier
  • getScale()
: nvidia::apex::ForceFieldActor
, nvidia::apex::DestructibleActor
  • getScaleAxis()
: nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleVsLifeModifier
  • getScaleChangeDelay() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • getScaleChangeLimit() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • getScaleFactor()
: nvidia::apex::ScaleAlongVelocityModifier
, nvidia::apex::SimpleScaleModifier
, nvidia::apex::RandomScaleModifier
  • getScalePerVelocity() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • getScaleUpperBound() : nvidia::apex::IofxAsset
  • getScatterMeshAssetCount()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getScatterMeshAssets()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::DestructibleAsset
  • getSemantic()
: nvidia::apex::RenderSpriteLayoutElement
, nvidia::apex::RenderInstanceLayoutElement
  • getSemanticData() : nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >
  • getSemanticFormat()
: nvidia::apex::RenderInstanceLayoutElement
, nvidia::apex::RenderSpriteLayoutElement
  • getSemanticID() : nvidia::apex::VertexFormat
  • getSemanticName() : nvidia::apex::VertexFormat
  • getSerializePlatform() : nvidia::apex::ApexSDK
  • getSerializeType() : nvidia::apex::ApexSDK
  • getSetNames() : nvidia::apex::ImpactEmitterAsset
  • getShape()
: nvidia::apex::VelocitySourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::HeatSourceActor
  • getShellThickness() : nvidia::apex::EmitterGeomSphereShell
  • getShowFullInfo() : nvidia::apex::AssetPreviewScene
  • getSimParticlesCount() : nvidia::apex::EmitterActor
  • getSimulationNormals() : nvidia::apex::ClothingActor
  • getSimulationPositions() : nvidia::apex::ClothingActor
  • getSimulationVelocities() : nvidia::apex::ClothingActor
  • getSize() : nvidia::apex::BoxShape
  • getSmoothingGroups() : nvidia::apex::RenderSubmesh
  • getSolidShadedMaterial() : nvidia::apex::ApexSDK
  • getSpawnHeight()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::GroundEmitterAsset
  • getSpawnModifiers() : nvidia::apex::IofxAsset
  • getSphereCenter() : nvidia::apex::EmitterGeomExplicit
  • getSphereCount() : nvidia::apex::EmitterGeomExplicit
  • getSphereList() : nvidia::apex::EmitterGeomExplicit
  • getSphereRadius() : nvidia::apex::EmitterGeomExplicit
  • getSpheres() : nvidia::apex::ClothingCapsule
  • getSphereShape()
: nvidia::apex::HeatSourceActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::SubstanceSourceActor
  • getSpriteBuffer() : nvidia::apex::UserRenderResource
  • getSpriteLayoutData() : nvidia::apex::UserRenderResourceManager
  • getSpriteMaterialName() : nvidia::apex::IofxAsset
  • getSpriteRenderData() : nvidia::apex::IofxRenderable
  • getStats()
: nvidia::apex::ClothingPhysicalMesh
, nvidia::apex::RenderMeshAsset
, nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::RenderMeshAssetAuthoring
, nvidia::apex::DestructibleAsset
, nvidia::apex::Scene
  • getStdDensity() : nvidia::apex::SubstanceSourceActor
  • getStdTemperature() : nvidia::apex::HeatSourceActor
  • getStdVelocity() : nvidia::apex::VelocitySourceActor
  • getSubmesh()
: nvidia::apex::RenderMeshAsset
, nvidia::apex::RenderMeshAssetAuthoring
  • getSubmeshCount()
: nvidia::apex::RenderMeshAssetAuthoring
, nvidia::apex::RenderMeshAsset
  • getSubmeshWritable() : nvidia::apex::RenderMeshAssetAuthoring
  • getSubstanceSourceAsset() : nvidia::apex::SubstanceSourceActor
  • getSubtextureRange() : nvidia::apex::RandomSubtextureModifier
  • getSupportDepth() : nvidia::apex::DestructibleActor
  • getSupportDepthChunkIndices() : nvidia::apex::DestructibleActor
  • getSupportsDensity() : nvidia::apex::IosAsset
  • getTaskManager() : nvidia::apex::Scene
  • getTestBase()
: nvidia::apex::ModuleIofx
, nvidia::apex::ModuleBasicIos
, nvidia::apex::ModuleTurbulenceFS
  • getTexts() : nvidia::apex::PhysXRenderBuffer
  • getTM() : nvidia::apex::RenderMeshActor
  • getTriangles() : nvidia::apex::PhysXRenderBuffer
  • getTurbulenceFSAsset() : nvidia::apex::TurbulenceFSActor
  • getTurbulenceRenderCallback() : nvidia::apex::ModuleTurbulenceFS
  • getTurbulenceRenderLayout() : nvidia::apex::TurbulenceRenderCallback
  • getType()
: nvidia::apex::UserRenderBuffer
, nvidia::apex::UserRenderStorage
, nvidia::apex::UserRenderSurface
, nvidia::apex::IofxRenderable
, nvidia::apex::ClothingCollision
  • getUnitTestsCount() : nvidia::apex::TestBase
  • getUnitTestsIndex() : nvidia::apex::TestBase
  • getUnitTestsName() : nvidia::apex::TestBase
  • getUpdatesPerFrame() : nvidia::apex::TurbulenceFSActor
  • getUseDensity() : nvidia::apex::TurbulenceFSActor
  • getUseEmitterPool() : nvidia::apex::ModuleParticles
  • getUseFlame() : nvidia::apex::TurbulenceFSActor
  • getUserData() : nvidia::apex::UserRenderDataHolder
  • getUserDefinedFlag() : nvidia::apex::PhysXObjectDesc
  • getVelocity0() : nvidia::apex::ColorVsVelocityModifier
  • getVelocity1() : nvidia::apex::ColorVsVelocityModifier
  • getVelocityField() : nvidia::apex::TurbulenceFSActor
  • getVelocityHigh()
: nvidia::apex::EmitterAsset
, nvidia::apex::GroundEmitterAsset
  • getVelocityLow()
: nvidia::apex::GroundEmitterAsset
, nvidia::apex::EmitterAsset
  • getVelocitySourceAsset() : nvidia::apex::VelocitySourceActor
  • getVersion() : NvParameterized::Factory
  • getVertex()
: nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
, nvidia::apex::CustomBufferIterator
  • getVertexAttribute() : nvidia::apex::CustomBufferIterator
  • getVertexBuffer()
: nvidia::apex::RenderSubmesh
, nvidia::apex::UserRenderResource
  • getVertexBufferWritable() : nvidia::apex::RenderSubmesh
  • getVertexCount()
: nvidia::apex::RenderSubmesh
, nvidia::apex::VertexBuffer
, nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getVertices() : nvidia::apex::ClothingPhysicalMesh
  • getViewMatrix() : nvidia::apex::Scene
  • getVisibilities() : nvidia::apex::RenderMeshActor
  • getVisibleChunks() : nvidia::apex::DestructibleActor
  • getVisibleCount() : nvidia::apex::IofxActor
  • getVisibleParts() : nvidia::apex::RenderMeshActor
  • getVolume() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • getVolumeRenderMaterialName() : nvidia::apex::TurbulenceFSActor
  • getVortexFSAsset() : nvidia::apex::VortexFSActor
  • getWindFSAsset() : nvidia::apex::WindFSActor
  • getWinding() : nvidia::apex::VertexFormat
  • getWindingOrder() : nvidia::apex::RenderMeshAssetAuthoring
  • getWireframeMaterial() : nvidia::apex::ApexSDK
  • GroupsMask64() : nvidia::apex::GroupsMask64
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- h -

  • Handle() : NvParameterized::Handle
  • hasSeparateBoneBuffer() : nvidia::apex::VertexFormat
  • hasSimulatedData() : nvidia::apex::ClothingRenderProxy
  • hasUserFlagSet() : nvidia::apex::DestructibleDepthParameters
  • hasVolumeRenderMaterial() : nvidia::apex::EffectPackageActor
  • hierarchicallySplitChunk()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • hint() : NvParameterized::Definition
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- i -

  • ignoreContacts() : nvidia::apex::PhysXObjectDesc
  • ignoreRaycasts() : nvidia::apex::PhysXObjectDesc
  • ignoresContactCallbacks() : nvidia::apex::DestructibleDepthParameters
  • ignoresPoseUpdates() : nvidia::apex::DestructibleDepthParameters
  • ignoresRaycastCallbacks() : nvidia::apex::DestructibleDepthParameters
  • ignoreTransform() : nvidia::apex::PhysXObjectDesc
  • importDestructibleAssetToRootMesh() : nvidia::apex::DestructibleAssetAuthoring
  • importRenderMeshAssetToRootMesh() : nvidia::apex::DestructibleAssetAuthoring
  • incRefCount() : NvParameterized::Traits
  • index() : NvParameterized::Handle
  • init()
: nvidia::apex::Module
, NvParameterized::Serializer::DeserializedResults< T, bufSize >
  • initDefaults() : NvParameterized::Interface
  • initializeDefaultDatabases() : nvidia::apex::ModuleParticles
  • initParamRef()
: NvParameterized::Handle
, NvParameterized::Interface
  • initRandom() : NvParameterized::Interface
  • instancedPositionOffset() : nvidia::apex::ExplicitHierarchicalMesh
  • instancedUVOffset() : nvidia::apex::ExplicitHierarchicalMesh
  • intersectAgainstAABB()
: nvidia::apex::Shape
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::VelocitySourceActor
  • invalidateBounds() : nvidia::apex::ModuleDestructible
  • isAlive() : nvidia::apex::EffectPackageActor
  • isBoxGeom()
: nvidia::apex::EmitterGeom
, nvidia::apex::Shape
  • isCapsule() : nvidia::apex::ClothingCollision
  • isCapsuleGeom() : nvidia::apex::Shape
  • isCaseSensitive() : nvidia::apex::ResourceProvider
  • isChunkDestroyed() : nvidia::apex::DestructibleActor
  • isChunkSolitary() : nvidia::apex::DestructibleActor
  • isComplete() : NvParameterized::ParameterFind
  • isConcurrencyCheckEnabled() : nvidia::apex::ApexSDK
  • isConst() : NvParameterized::Handle
  • isConvex() : nvidia::apex::ClothingCollision
  • isCylinderGeom() : nvidia::apex::EmitterGeom
  • isDestructibleActorJointActive() : nvidia::apex::ModuleDestructible
  • isDigit() : NvParameterized::ParameterFind
  • isDirty() : nvidia::apex::Asset
  • isDynamic() : nvidia::apex::DestructibleActor
  • isEffectEnabled() : nvidia::apex::EffectPackageActor
  • isEmitting() : nvidia::apex::EmitterActor
  • isEnable() : nvidia::apex::ForceFieldActor
  • isEnabled()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::VelocitySourceActor
  • isExplicitGeom()
: nvidia::apex::EmitterActor
, nvidia::apex::EmitterAsset
, nvidia::apex::EmitterGeom
  • isFrozen() : nvidia::apex::ClothingActor
  • isHalfPrecisionAllowed() : nvidia::apex::ClothingActor
  • isHalfSpaceGeom() : nvidia::apex::Shape
  • isHardSleepingEnabled() : nvidia::apex::DestructibleActor
  • isIncludedRef() : NvParameterized::Definition
  • isInitiallyDynamic() : nvidia::apex::DestructibleActor
  • isLeaf() : NvParameterized::Definition
  • isPeriodic() : FractureTools::CutoutSet
  • isPlane() : nvidia::apex::ClothingCollision
  • isRecursive() : NvParameterized::ParameterList
  • isRuntimeFractureShape() : nvidia::apex::ModuleDestructible
  • isSimpleType() : NvParameterized::Definition
  • isSphere() : nvidia::apex::ClothingCollision
  • isSphereGeom()
: nvidia::apex::EmitterGeom
, nvidia::apex::Shape
  • isSphereShellGeom() : nvidia::apex::EmitterGeom
  • isStillEmitting() : nvidia::apex::EffectPackageActor
  • isTetrahedralMesh() : nvidia::apex::ClothingPhysicalMesh
  • isTheSameAs()
: nvidia::apex::UserRenderBufferDesc
, nvidia::apex::UserRenderSurfaceDesc
, nvidia::apex::IofxSpriteRenderLayout
, nvidia::apex::IofxMeshRenderLayout
, nvidia::apex::UserRenderInstanceBufferDesc
, nvidia::apex::UserRenderSpriteTextureDesc
, nvidia::apex::UserRenderSpriteBufferDesc
  • isTriangleMesh() : nvidia::apex::ClothingCollision
  • isValid()
: nvidia::apex::UserRenderSpriteBufferDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
, nvidia::apex::RenderMeshAssetAuthoring::MeshDesc
, nvidia::apex::DamageSpreadFunction
, nvidia::apex::DestructibleAssetCookingDesc
, nvidia::apex::EmitterLodParamDesc
, nvidia::apex::UserRenderInstanceBufferDesc
, nvidia::apex::UserRenderResourceDesc
, nvidia::apex::UserRenderVertexBufferDesc
, nvidia::apex::UserRenderIndexBufferDesc
, NvParameterized::Handle
, nvidia::apex::ApexDesc
, nvidia::apex::IofxSpriteRenderLayout
, nvidia::apex::UserRenderBoneBufferDesc
, nvidia::apex::IofxMeshRenderLayout
, nvidia::apex::ApexSDKDesc
, nvidia::apex::DestructibleBehaviorGroupDesc
, nvidia::apex::UserRenderSurfaceDesc
, nvidia::apex::DestructibleGeometryDesc
, nvidia::apex::RenderMeshActorDesc
, nvidia::apex::DestructibleChunkDesc
, nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
, nvidia::apex::UserRenderBufferDesc
, nvidia::apex::DestructibleActorJointDesc
  • isValidForActorCreation() : nvidia::apex::Asset
  • isVisible()
: nvidia::apex::RenderMeshActor
, nvidia::apex::ClothingActor
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- p -

  • padding() : NvParameterized::Definition
  • parameterDefinition()
: NvParameterized::Handle
, NvParameterized::Interface
  • ParameterFind() : NvParameterized::ParameterFind
  • ParameterList() : NvParameterized::ParameterList
  • ParamResult() : NvParameterized::ParamResult
  • parent() : NvParameterized::Definition
  • parentIndex() : nvidia::apex::ExplicitHierarchicalMesh
  • partCount() : nvidia::apex::ExplicitHierarchicalMesh
  • partIndex() : nvidia::apex::ExplicitHierarchicalMesh
  • partitionMeshByIslands() : nvidia::apex::DestructibleAssetAuthoring
  • peekClassNames() : NvParameterized::Serializer
  • peekInplaceAlignment() : NvParameterized::Serializer
  • peekNumObjects() : NvParameterized::Serializer
  • peekNumObjectsInplace() : NvParameterized::Serializer
  • peekPlatform() : NvParameterized::Serializer
  • peekSerializeType() : NvParameterized::Serializer
  • popIndex() : NvParameterized::Handle
  • popNameMatch()
: NvParameterized::ParameterFind
, NvParameterized::ParameterList
  • prepareForPlatform() : nvidia::apex::AssetAuthoring
  • prepareMorphTargetMapping() : nvidia::apex::ClothingAsset
  • prepareRenderables()
: nvidia::apex::ModuleIofx
, nvidia::apex::ModuleTurbulenceFS
  • preSerialize() : NvParameterized::SerializationCallback
  • pushName() : NvParameterized::ParameterList
  • pushNameMatch() : NvParameterized::ParameterFind
  • PxStreamFromFileBuf() : nvidia::apex::PxStreamFromFileBuf
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- q -

  • querySetID() : nvidia::apex::ImpactEmitterAsset
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- r -

  • Range() : nvidia::apex::Range< T >
  • rayCast()
: nvidia::apex::ClothingActor
, nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
, nvidia::apex::RenderMeshActor
, nvidia::apex::DestructibleActor
  • read() : nvidia::apex::PxStreamFromFileBuf
  • ReadLock() : nvidia::apex::ReadLock
  • rebuildCollisionGeometry() : nvidia::apex::DestructibleAsset
  • recreateApexEmitter() : nvidia::apex::DestructibleActor
  • reduceHull() : nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • reduceHulls() : nvidia::apex::ExplicitHierarchicalMesh
  • referenceCallback()
: NvParameterized::ReferenceInterface
, NvParameterized::WrappedNamedReference
  • refresh() : nvidia::apex::EffectPackageActor
  • refVariantVal() : NvParameterized::Definition
  • refVariantValIndex() : NvParameterized::Definition
  • registerCallback() : nvidia::apex::ResourceProvider
  • registerConversion() : NvParameterized::Traits
  • registerFactory() : NvParameterized::Traits
  • registerImpact() : nvidia::apex::ImpactEmitterActor
  • release()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::UserRenderData
, nvidia::apex::UserRenderStorage
, nvidia::apex::PhysX3DescTemplate
, nvidia::apex::ApexInterface
, nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
, nvidia::apex::ExplicitHierarchicalMesh
, FractureTools::CutoutSet
, nvidia::apex::MirrorScene
, NvParameterized::Conversion
, NvParameterized::Traits
, NvParameterized::Serializer
, nvidia::apex::EffectPackageActor
, nvidia::apex::RenderDebugInterface
  • releaseActor() : nvidia::apex::RenderMeshAsset
  • releaseAll() : NvParameterized::Serializer::DeserializedResults< T, bufSize >
  • releaseAllResourcesInNamespace() : nvidia::apex::ResourceProvider
  • releaseAndReturnNvParameterizedInterface()
: nvidia::apex::Asset
, nvidia::apex::AssetAuthoring
  • releaseApexRenderDebug() : nvidia::apex::ApexSDK
  • releaseApexShape()
: nvidia::apex::ApexSDK
, nvidia::apex::Shape
  • releaseAsset() : nvidia::apex::ApexSDK
  • releaseAssetAuthoring() : nvidia::apex::ApexSDK
  • releaseAssetPreviewScene() : nvidia::apex::ApexSDK
  • releaseBoneBuffer() : nvidia::apex::UserRenderResourceManager
  • releaseChunkEventBuffer() : nvidia::apex::DestructibleActor
  • releaseDestructibleActor() : nvidia::apex::DestructibleAsset
  • releaseForceFieldActor() : nvidia::apex::ForceFieldAsset
  • releaseForceSampleBatch() : nvidia::apex::ModuleFieldSampler
  • releaseGraphicalData() : nvidia::apex::ClothingAsset
  • releaseIndexBuffer() : nvidia::apex::UserRenderResourceManager
  • releaseInstanceBuffer() : nvidia::apex::UserRenderResourceManager
  • releaseIosActor() : nvidia::apex::IosAsset
  • releaseLoadedModules() : nvidia::apex::ModuleLoader
  • releaseMemoryReadStream() : nvidia::apex::ApexSDK
  • releaseMemoryWriteStream() : nvidia::apex::ApexSDK
  • releaseModule()
: nvidia::apex::ModuleLoader
, nvidia::apex::ApexSDK
, nvidia::apex::ModuleLoader
  • releaseModules() : nvidia::apex::ModuleLoader
  • releaseOnNoChunksVisible() : nvidia::apex::UserChunkReport
  • releasePhysXActorBuffer() : nvidia::apex::DestructibleActor
  • releaseReadLock() : nvidia::apex::RWLockable
  • releaseRenderableIterator() : nvidia::apex::Context
  • releaseRenderVolume() : nvidia::apex::ModuleIofx
  • releaseResource()
: nvidia::apex::ResourceCallback
, nvidia::apex::ResourceProvider
, nvidia::apex::UserRenderResourceManager
  • releaseScene() : nvidia::apex::ApexSDK
  • releaseSpriteBuffer() : nvidia::apex::UserRenderResourceManager
  • releaseSurfaceBuffer() : nvidia::apex::UserRenderResourceManager
  • releaseVertexBuffer() : nvidia::apex::UserRenderResourceManager
  • releaseWithPlanes() : nvidia::apex::ClothingConvex
  • releaseWithSpheres() : nvidia::apex::ClothingCapsule
  • releaseWriteLock() : nvidia::apex::RWLockable
  • remapBoneIndex() : nvidia::apex::ClothingAsset
  • removeActorPair() : nvidia::apex::Scene
  • removeAllActors() : nvidia::apex::Context
  • removeAllBoundingBoxes() : nvidia::apex::Scene
  • removeBoundingBox() : nvidia::apex::Scene
  • removeChunkOverlaps()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • removeConversion() : NvParameterized::Traits
  • removeFactory() : NvParameterized::Traits
  • removePlatform() : nvidia::apex::ClothingAssetAuthoring
  • removePlatformMaxDepth() : nvidia::apex::DestructibleAssetAuthoring
  • removeTriangle() : nvidia::apex::ClothingTriangleMesh
  • removeTriangles() : nvidia::apex::ClothingTriangleMesh
  • RenderMeshActorDesc() : nvidia::apex::RenderMeshActorDesc
  • RenderMeshPartData() : nvidia::apex::RenderMeshPartData
  • renderResource() : nvidia::apex::UserRenderer
  • replaceInteriorSubmeshes() : nvidia::apex::ExplicitHierarchicalMesh
  • requestMaterialLookups() : nvidia::apex::MaterialLookupCallback
  • requestResource() : nvidia::apex::ResourceCallback
  • reset()
: NvParameterized::Handle
, nvidia::apex::RenderableIterator
, nvidia::apex::VertexFormat
  • resetEmitterPool() : nvidia::apex::ModuleParticles
  • resetParticleList() : nvidia::apex::EmitterGeomExplicit
  • resizeArray()
: NvParameterized::Interface
, NvParameterized::Handle
  • reviseMirrorActor() : nvidia::apex::MirrorScene::MirrorFilter
  • reviseMirrorShape() : nvidia::apex::MirrorScene::MirrorFilter
  • root() : NvParameterized::Definition
  • rootParameterDefinition() : NvParameterized::Interface
  • run() : nvidia::apex::TestFunctionInterface
  • runGpu() : nvidia::apex::TestFunctionInterface
  • runKernel() : nvidia::apex::CudaTestManager
  • runUnitTests() : nvidia::apex::TestBase
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- s -

  • scheduleChunkStateEventCallback() : nvidia::apex::ModuleDestructible
  • ScopedPhysXLockRead() : nvidia::apex::ScopedPhysXLockRead
  • ScopedPhysXLockWrite() : nvidia::apex::ScopedPhysXLockWrite
  • serialize()
: nvidia::apex::ExplicitHierarchicalMesh
, NvParameterized::Serializer
, nvidia::apex::ApexSDKCachedData
, nvidia::apex::ExplicitHierarchicalMesh::Embedding
  • serializeFractureToolState() : nvidia::apex::DestructibleAssetAuthoring
  • SerializePlatform() : NvParameterized::SerializePlatform
  • serializeSingleAsset() : nvidia::apex::ModuleCachedData
  • set()
: NvParameterized::Handle
, nvidia::apex::VertexColor
, nvidia::apex::VertexUV
, nvidia::apex::ExplicitHierarchicalMesh
, NvParameterized::Handle
  • setAngularVelocity() : nvidia::apex::DestructibleActor
  • setAngularVelocityMultiplierAndClamp() : nvidia::apex::TurbulenceFSActor
  • setApexEmitterValidateCallback()
: nvidia::apex::EmitterActor
, nvidia::apex::EffectPackageActor
  • setArraySize() : NvParameterized::Definition
  • setAsUInt() : NvParameterized::Hint
  • setAttachActor()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
  • setAttachRelativePose() : nvidia::apex::EmitterActor
  • setAttachRelativePosition() : nvidia::apex::GroundEmitterActor
  • setAutoUpdate() : NvParameterized::Serializer
  • setAxis() : nvidia::apex::VortexFSActor
  • setBoneBindPose() : nvidia::apex::ClothingAssetAuthoring
  • setBoneBufferRange() : nvidia::apex::UserRenderResource
  • setBoneInfo() : nvidia::apex::ClothingAssetAuthoring
  • setBottomRadius() : nvidia::apex::VortexFSActor
  • setBottomSphericalForce() : nvidia::apex::VortexFSActor
  • setBSPBuildParameters()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • setBSPTolerances()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
  • setBufferAccess() : nvidia::apex::VertexFormat
  • setBufferFormat() : nvidia::apex::VertexFormat
  • setBufferSerialize() : nvidia::apex::VertexFormat
  • setBufferVisibility() : nvidia::apex::RenderMeshActor
  • setCallPerFrameMaxCount() : nvidia::apex::CudaTestManager
  • setCameraMatrix() : nvidia::apex::AssetPreviewScene
  • setChildren() : NvParameterized::Definition
  • setChunkCollisionHullCookingScale() : nvidia::apex::ModuleDestructible
  • setChunkCrumbleReport() : nvidia::apex::ModuleDestructible
  • setChunkDustReport() : nvidia::apex::ModuleDestructible
  • setChunkOverlapsCacheDepth() : nvidia::apex::DestructibleAssetAuthoring
  • setChunkPhysXActorAwakeState() : nvidia::apex::DestructibleActor
  • setChunkReport() : nvidia::apex::ModuleDestructible
  • setChunkReportBitMask() : nvidia::apex::ModuleDestructible
  • setChunkReportMaxFractureEventDepth() : nvidia::apex::ModuleDestructible
  • setClassName() : NvParameterized::Interface
  • setClothingMaterial() : nvidia::apex::ClothingActor
  • setCollision() : nvidia::apex::ClothingAssetAuthoring
  • setCollisionGroupMaskName()
: nvidia::apex::BasicIosAssetAuthoring
, nvidia::apex::ParticleIosAssetAuthoring
  • setCollisionGroupName()
: nvidia::apex::BasicIosAssetAuthoring
, nvidia::apex::ParticleIosAssetAuthoring
  • setColorChannel()
: nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::ColorVsVelocityModifier
  • setConstFieldStrength() : nvidia::apex::AttractorFSActor
  • setContactReportFlags() : nvidia::apex::PhysX3Interface
  • setCoreMesh() : nvidia::apex::DestructibleAssetAuthoring
  • setCrumbleEmitterName() : nvidia::apex::DestructibleAssetAuthoring
  • setCrumbleEmitterState() : nvidia::apex::DestructibleActor
  • setCudaKernelCheckEnabled() : nvidia::apex::Scene
  • setCurrentPose()
: nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::EmitterActor
  • setCurrentPosition()
: nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::EmitterActor
  • setCurrentScale()
: nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::EmitterActor
, nvidia::apex::ForceFieldActor
, nvidia::apex::EffectPackageActor
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::VelocitySourceActor
  • setCustomFilterShader() : nvidia::apex::ModuleTurbulenceFS
  • setCustomSemanticData() : nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >
  • setCustomTimestep() : nvidia::apex::ModuleTurbulenceFS
  • setDamageApplicationRaycastFlags() : nvidia::apex::ModuleDestructible
  • setDefaultConstrainCoefficients() : nvidia::apex::ClothingAssetAuthoring
  • setDefaults()
: nvidia::apex::IofxSpriteRenderLayout
, nvidia::apex::IofxMeshRenderLayout
, nvidia::apex::TurbulenceRenderLayout
, nvidia::apex::UserRenderBufferDesc
, nvidia::apex::UserRenderSurfaceDesc
, nvidia::apex::UserRenderInstanceBufferDesc
, nvidia::apex::UserRenderSpriteBufferDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
  • setDeleteFracturedChunks() : nvidia::apex::DestructibleActor
  • setDensity()
: nvidia::apex::EmitterActor
, nvidia::apex::GroundEmitterActor
, nvidia::apex::SubstanceSourceActor
  • setDensityBasedParameters() : nvidia::apex::TurbulenceFSActor
  • setDensityGridPosition() : nvidia::apex::EmitterActor
  • setDensityScale() : nvidia::apex::ModuleEmitter
  • setDensityTextureRange() : nvidia::apex::TurbulenceFSActor
  • setDeriveNormalsFromBones() : nvidia::apex::ClothingAssetAuthoring
  • setDestructibleInitParameters() : nvidia::apex::DestructibleAssetAuthoring
  • setDestructibleParameters()
: nvidia::apex::DestructibleActor
, nvidia::apex::DestructibleAssetAuthoring
  • setDestructiblePhysXActorReport() : nvidia::apex::ModuleDestructible
  • setDetailLevel()
: nvidia::apex::ForceFieldPreview
, nvidia::apex::ParticlesPreview
, nvidia::apex::TurbulenceFSPreview
, nvidia::apex::AttractorFSPreview
, nvidia::apex::JetFSPreview
, nvidia::apex::NoiseFSPreview
, nvidia::apex::VortexFSPreview
, nvidia::apex::WindFSPreview
  • setDimensions() : nvidia::apex::CapsuleShape
  • setDustEmitterName() : nvidia::apex::DestructibleAssetAuthoring
  • setDustEmitterState() : nvidia::apex::DestructibleActor
  • setDynamic() : nvidia::apex::DestructibleActor
  • setDynamicHandleIndicesMap() : NvParameterized::Definition
  • setEffectEnabled() : nvidia::apex::EffectPackageActor
  • setEffectPackageDatabase() : nvidia::apex::ModuleParticles
  • setEffectPackageEmitterDatabase() : nvidia::apex::ModuleParticles
  • setEffectPackageFieldSamplerDatabase() : nvidia::apex::ModuleParticles
  • setEffectPackageGraphicsMaterialsDatabase() : nvidia::apex::ModuleParticles
  • setEffectPackageIOFXDatabase() : nvidia::apex::ModuleParticles
  • setEffectPackageIOSDatabase() : nvidia::apex::ModuleParticles
  • setEffectPose() : nvidia::apex::EffectPackageActor
  • setEmitterState() : nvidia::apex::EffectPackageActor
  • setEmitterType() : nvidia::apex::EmitterGeom
  • setEnableApexStats() : nvidia::apex::ApexSDK
  • setEnableConcurrencyCheck() : nvidia::apex::ApexSDK
  • setEnabled()
: nvidia::apex::AttractorFSActor
, nvidia::apex::JetFSActor
, nvidia::apex::NoiseFSActor
, nvidia::apex::VortexFSActor
, nvidia::apex::WindFSActor
, nvidia::apex::EffectPackageActor
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::VelocitySourceActor
  • setEnableDebugVisualization() : nvidia::apex::Actor
  • setEnableScreenCulling() : nvidia::apex::ModuleParticles
  • setEnumVals() : NvParameterized::Definition
  • setExplodeView() : nvidia::apex::DestructiblePreview
  • setExportScale() : nvidia::apex::ClothingAssetAuthoring
  • setExtents() : nvidia::apex::EmitterGeomBox
  • setExternalVelocity() : nvidia::apex::TurbulenceFSActor
  • setFalloffMultiplier() : nvidia::apex::ForceFieldActor
  • setFalloffType() : nvidia::apex::ForceFieldActor
  • setFieldDirection()
: nvidia::apex::JetFSActor
, nvidia::apex::WindFSActor
  • setFieldRadius() : nvidia::apex::AttractorFSActor
  • setFieldSamplerWeightedCollisionFilterCallback() : nvidia::apex::ModuleFieldSampler
  • setFieldStrength()
: nvidia::apex::JetFSActor
, nvidia::apex::WindFSActor
  • setFieldVelocityMultiplier() : nvidia::apex::TurbulenceFSActor
  • setFieldVelocityWeight() : nvidia::apex::TurbulenceFSActor
  • setFluidViscosity() : nvidia::apex::TurbulenceFSActor
  • setFracturePatternName() : nvidia::apex::DestructibleAssetAuthoring
  • setFramePeriod() : nvidia::apex::CudaTestManager
  • setFrames() : nvidia::apex::CudaTestManager
  • setFrozen() : nvidia::apex::ClothingActor
  • setFunction()
: nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::SubtextureVsLifeModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::ColorVsVelocityModifier
  • setGeometry() : nvidia::apex::ClothingPhysicalMesh
  • setGlobalPose() : nvidia::apex::DestructibleActor
  • setGraphicalLOD() : nvidia::apex::ClothingActor
  • setGravity() : nvidia::apex::Scene
  • setGridDimensions() : nvidia::apex::TurbulenceFSActor
  • setGridSizePow() : nvidia::apex::ModuleTurbulenceFS
  • setGroundDensityScale() : nvidia::apex::ModuleEmitter
  • setHalfLengthDimensions() : nvidia::apex::TurbulenceFSPreview
  • setHalfPrecision() : nvidia::apex::ClothingActor
  • setHasSeparateBoneBuffer() : nvidia::apex::VertexFormat
  • setHeatBasedParameters() : nvidia::apex::TurbulenceFSActor
  • setHeight()
: nvidia::apex::VortexFSActor
, nvidia::apex::EmitterGeomCylinder
  • setHints() : NvParameterized::Definition
  • setHitChunkTrackingParams() : nvidia::apex::DestructibleActor
  • setIconScale()
: nvidia::apex::ForceFieldPreview
, nvidia::apex::ParticlesPreview
, nvidia::apex::TurbulenceFSPreview
  • setImpactDamageReportCallback() : nvidia::apex::ModuleDestructible
  • setIndexBufferRange() : nvidia::apex::UserRenderResource
  • setInitialGlobalPose() : nvidia::apex::DestructibleActor
  • setInstanceBuffer() : nvidia::apex::RenderMeshActor
  • setInstanceBufferRange()
: nvidia::apex::RenderMeshActor
, nvidia::apex::UserRenderResource
  • setInterface() : NvParameterized::Handle
  • setInvalidConstrainCoefficients() : nvidia::apex::ClothingAssetAuthoring
  • setIofxRenderCallback() : nvidia::apex::ModuleIofx
  • setLifetime() : nvidia::apex::ForceFieldActor
  • setLifetimeHigh() : nvidia::apex::EmitterActor
  • setLifetimeLow() : nvidia::apex::EmitterActor
  • setLiftStrength() : nvidia::apex::VortexFSActor
  • setLinearVelocity() : nvidia::apex::DestructibleActor
  • setLinearVelocityMultiplierAndClamp() : nvidia::apex::TurbulenceFSActor
  • setLodParamDesc() : nvidia::apex::EmitterActor
  • setMassScaling() : nvidia::apex::ModuleDestructible
  • setMaterial() : nvidia::apex::UserRenderResource
  • setMaterialFrame() : nvidia::apex::ExplicitHierarchicalMesh
  • setMaterialLibrary() : nvidia::apex::ClothingAssetAuthoring
  • setMaterialLookupCallback() : nvidia::apex::GroundEmitterActor
  • setMaterialName() : nvidia::apex::RenderMeshAssetAuthoring
  • setMaterials() : nvidia::apex::PhysX3DescTemplate
  • setMaxActorCreatesPerFrame() : nvidia::apex::ModuleDestructible
  • setMaxChunkCount() : nvidia::apex::ModuleDestructible
  • setMaxChunkDepthOffset() : nvidia::apex::ModuleDestructible
  • setMaxChunkSeparationLOD() : nvidia::apex::ModuleDestructible
  • setMaxDistanceBlendTime() : nvidia::apex::ClothingActor
  • setMaxDynamicChunkIslandCount() : nvidia::apex::ModuleDestructible
  • setMaxFracturesProcessedPerFrame() : nvidia::apex::ModuleDestructible
  • setMaxInjectedParticleCount()
: nvidia::apex::BasicIosAssetAuthoring
, nvidia::apex::ParticleIosAssetAuthoring
  • setMaxInstanceCount() : nvidia::apex::RenderMeshActor
  • setMaxParticleCount()
: nvidia::apex::BasicIosAssetAuthoring
, nvidia::apex::ParticleIosAssetAuthoring
  • setMaxRaycastsPerFrame() : nvidia::apex::GroundEmitterActor
  • setMaxRotationRate() : nvidia::apex::RotationModifier
  • setMaxSamples() : nvidia::apex::CudaTestManager
  • setMaxSettleRate() : nvidia::apex::RotationModifier
  • setMeshes() : nvidia::apex::ClothingAssetAuthoring
  • setModelForward() : nvidia::apex::OrientAlongVelocityModifier
  • setMultiSolveEnabled() : nvidia::apex::ModuleTurbulenceFS
  • setName()
: nvidia::apex::ForceFieldActor
, NvParameterized::Interface
  • setNeighborPadding() : nvidia::apex::DestructibleAssetAuthoring
  • setNoiseParameters() : nvidia::apex::TurbulenceFSActor
  • setNoiseStrength() : nvidia::apex::NoiseFSActor
  • setNumGrids() : nvidia::apex::TurbulenceFSPreview
  • setNvParameterized() : nvidia::apex::DestructibleActor
  • setObjectScale() : nvidia::apex::EmitterActor
  • setOriginAndNormal() : nvidia::apex::HalfSpaceShape
  • setOverlapTestCollisionGroups() : nvidia::apex::EmitterActor
  • setOverrideMaterial()
: nvidia::apex::ClothingActor
, nvidia::apex::RenderMeshActor
  • setOwnershipBounds() : nvidia::apex::RenderVolume
  • setParam() : NvParameterized::Handle
  • setParamArray() : NvParameterized::Handle
  • setParamBool()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamBoolArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamBounds3()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamBounds3Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamEnum()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamEnumArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamF32()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamF32Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamF64()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamF64Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI16()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI16Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI32()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI32Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI64()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI64Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI8()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamI8Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamMat33()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamMat33Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamMat34Legacy()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamMat34LegacyArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamMat44()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamMat44Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamQuat()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamQuatArray()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamRef()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamRefArray()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamString()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamStringArray()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamTransform()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamTransformArray()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamU16()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamU16Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamU32()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamU32Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamU64()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamU64Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamU8()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamU8Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamVec2()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamVec2Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamVec3()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamVec3Array()
: NvParameterized::Interface
, NvParameterized::Handle
  • setParamVec4()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParamVec4Array()
: NvParameterized::Handle
, NvParameterized::Interface
  • setParticleMass()
: nvidia::apex::BasicIosAssetAuthoring
, nvidia::apex::ParticleIosAssetAuthoring
  • setParticleRadius()
: nvidia::apex::ParticleIosAssetAuthoring
, nvidia::apex::BasicIosAssetAuthoring
  • setPhysX3Template() : nvidia::apex::ActorSource
  • setPhysXMonitorFilterData() : nvidia::apex::ModuleFieldSampler
  • setPhysXScene() : nvidia::apex::Scene
  • setPlane() : nvidia::apex::ClothingPlane
  • setPlatformMaxDepth() : nvidia::apex::DestructibleAssetAuthoring
  • setPose()
: nvidia::apex::Shape
, nvidia::apex::VelocitySourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::GroundEmitterActor
, nvidia::apex::ForceFieldActor
, nvidia::apex::EffectPackageActor
, nvidia::apex::FlameEmitterActor
, nvidia::apex::ClothingTriangleMesh
, nvidia::apex::HeatSourceActor
, nvidia::apex::AssetPreview
  • setPosition()
: nvidia::apex::ClothingSphere
, nvidia::apex::RenderVolume
  • setPreferredRenderVolume()
: nvidia::apex::DestructibleActor
, nvidia::apex::GroundEmitterActor
, nvidia::apex::ImpactEmitterActor
, nvidia::apex::EffectPackageActor
, nvidia::apex::EmitterActor
  • setProgress() : nvidia::apex::IProgressListener
  • setProjMatrix() : nvidia::apex::Scene
  • setProjParams() : nvidia::apex::Scene
  • setRadialStrength() : nvidia::apex::VortexFSActor
  • setRadius()
: nvidia::apex::GroundEmitterActor
, nvidia::apex::AttractorFSPreview
, nvidia::apex::EmitterGeomSphere
, nvidia::apex::EmitterGeomSphereShell
, nvidia::apex::ClothingSphere
, nvidia::apex::VortexFSPreview
, nvidia::apex::EmitterGeomCylinder
, nvidia::apex::SphereShape
  • setRate() : nvidia::apex::EmitterActor
  • setRateScale() : nvidia::apex::ModuleEmitter
  • setRaycastCollisionGroups() : nvidia::apex::GroundEmitterActor
  • setRaycastCollisionGroupsMask() : nvidia::apex::GroundEmitterActor
  • setRaycastHeight() : nvidia::apex::GroundEmitterActor
  • setReleaseResourcesIfNothingToRender() : nvidia::apex::RenderMeshActor
  • setRenderLockMode() : nvidia::apex::Module
  • setRenderMeshAsset()
: nvidia::apex::DestructibleAsset
, nvidia::apex::DestructibleAssetAuthoring
  • setResource() : nvidia::apex::ResourceProvider
  • setResourceU32() : nvidia::apex::ResourceProvider
  • setRestDensity() : nvidia::apex::BasicIosAssetAuthoring
  • setRollType() : nvidia::apex::RotationModifier
  • setRootBone() : nvidia::apex::ClothingAssetAuthoring
  • setRootMesh() : nvidia::apex::DestructibleAssetAuthoring
  • setRotationalStrength() : nvidia::apex::VortexFSActor
  • setRotationRange() : nvidia::apex::RandomRotationModifier
  • setRotationRate() : nvidia::apex::RotationRateModifier
  • setRuntimeCheckLevel() : nvidia::apex::TestBase
  • setRuntimeFractureOverridePattern() : nvidia::apex::DestructibleActor
  • setSampleVelocityFieldEnabled() : nvidia::apex::TurbulenceFSActor
  • setScale()
: nvidia::apex::FlameEmitterPreview
, nvidia::apex::VelocitySourcePreview
, nvidia::apex::EmitterPreview
, nvidia::apex::GroundEmitterPreview
, nvidia::apex::ForceFieldActor
, nvidia::apex::HeatSourcePreview
  • setScaleAxis()
: nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::ScaleVsDensityModifier
  • setScaleChangeDelay() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • setScaleChangeLimit() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • setScaleFactor()
: nvidia::apex::SimpleScaleModifier
, nvidia::apex::RandomScaleModifier
, nvidia::apex::ScaleAlongVelocityModifier
  • setScalePerVelocity() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • setScatterMeshAssets() : nvidia::apex::DestructibleAssetAuthoring
  • setSearchName() : NvParameterized::ParameterFind
  • setSemanticData() : nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >
  • setSerializationCallback() : NvParameterized::Interface
  • setShellThickness() : nvidia::apex::EmitterGeomSphereShell
  • setShowFullInfo() : nvidia::apex::AssetPreviewScene
  • setSimulationDisableCCD() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationGravityDirection() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationHierarchicalLevels() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationRestLengthScale() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationSleepLinearVelocity() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationThickness() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationTwowayInteraction() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationUntangling() : nvidia::apex::ClothingAssetAuthoring
  • setSimulationVirtualParticleDensity() : nvidia::apex::ClothingAssetAuthoring
  • setSize() : nvidia::apex::BoxShape
  • setSkinnedOverrideMaterial() : nvidia::apex::DestructibleActor
  • setSortByBenefit() : nvidia::apex::ModuleDestructible
  • setSpawnHeight() : nvidia::apex::GroundEmitterActor
  • setSpriteBufferRange() : nvidia::apex::UserRenderResource
  • setSpriteVisibleCount() : nvidia::apex::UserRenderResource
  • setStaticOverrideMaterial() : nvidia::apex::DestructibleActor
  • setStrength() : nvidia::apex::ForceFieldActor
  • setSubtextureRange() : nvidia::apex::RandomSubtextureModifier
  • setSyncParams()
: nvidia::apex::DestructibleActor
, nvidia::apex::ModuleDestructible
  • setTargetPlatform() : NvParameterized::Serializer
  • setTemperature() : nvidia::apex::HeatSourceActor
  • setTM() : nvidia::apex::RenderMeshActor
  • setToDefault()
: nvidia::apex::DestructibleAssetCookingDesc
, nvidia::apex::CollisionVolumeDesc
, nvidia::apex::SceneDesc
, nvidia::apex::ApexDesc
, FractureTools::FractureVoronoiDesc
, nvidia::apex::RenderMeshActorDesc
, FractureTools::CutoutParameters
, FractureTools::SliceParameters
, nvidia::apex::CollisionDesc
, nvidia::apex::DestructibleGeometryDesc
, FractureTools::FractureCutoutDesc
, nvidia::apex::DestructibleChunkDesc
, nvidia::apex::DestructibleActorJointDesc
, nvidia::apex::FractureMaterialDesc
, nvidia::apex::DestructibleParameters
, nvidia::apex::DamageSpreadFunction
, nvidia::apex::ApexSDKDesc
, nvidia::apex::DestructibleBehaviorGroupDesc
, nvidia::apex::GroupsMask64
, nvidia::apex::DestructibleDepthParameters
, nvidia::apex::DestructibleInitParameters
, nvidia::apex::EmitterLodParamDesc
, FractureTools::MeshProcessingParameters
, FractureTools::FractureSliceDesc
, FractureTools::NoiseParameters
, nvidia::apex::DestructibleRTFractureParameters
  • setToMostExpensive() : nvidia::apex::DestructibleDepthParameters
  • setToolString() : nvidia::apex::AssetAuthoring
  • setTopRadius() : nvidia::apex::VortexFSActor
  • setTopSphericalForce() : nvidia::apex::VortexFSActor
  • setTurbulenceRenderCallback() : nvidia::apex::ModuleTurbulenceFS
  • setUpdatesPerFrame() : nvidia::apex::TurbulenceFSActor
  • setUseDebugRenderable()
: nvidia::apex::RenderDebugInterface
, nvidia::apex::Scene
  • setUseDensity() : nvidia::apex::TurbulenceFSActor
  • setUseEmitterPool() : nvidia::apex::ModuleParticles
  • setUseHeat() : nvidia::apex::TurbulenceFSActor
  • setUseLegacyChunkBoundsTesting() : nvidia::apex::ModuleDestructible
  • setUseLegacyDamageRadiusSpread() : nvidia::apex::ModuleDestructible
  • setUserData()
: nvidia::apex::UserRenderDataHolder
, NvParameterized::Handle
  • setUseViewProjMatrix() : nvidia::apex::Scene
  • setValidBoundsPadding() : nvidia::apex::ModuleDestructible
  • setVariableFieldStrength() : nvidia::apex::AttractorFSActor
  • setVelocity() : nvidia::apex::VelocitySourceActor
  • setVelocity0() : nvidia::apex::ColorVsVelocityModifier
  • setVelocity1() : nvidia::apex::ColorVsVelocityModifier
  • setVelocityCallback() : nvidia::apex::ClothingActor
  • setVelocityFieldCleaningDelay() : nvidia::apex::TurbulenceFSActor
  • setVelocityFieldCleaningIntensity() : nvidia::apex::TurbulenceFSActor
  • setVelocityFieldCleaningTime() : nvidia::apex::TurbulenceFSActor
  • setVelocityFieldFade() : nvidia::apex::TurbulenceFSActor
  • setVelocityHigh() : nvidia::apex::EmitterActor
  • setVelocityLow() : nvidia::apex::EmitterActor
  • setVertexBufferRange() : nvidia::apex::UserRenderResource
  • setViewMatrix() : nvidia::apex::Scene
  • setViewParams() : nvidia::apex::Scene
  • setVisibility() : nvidia::apex::RenderMeshActor
  • setVisible() : nvidia::apex::ClothingActor
  • setWind() : nvidia::apex::ClothingActor
  • setWinding() : nvidia::apex::VertexFormat
  • setWindingOrder() : nvidia::apex::RenderMeshAssetAuthoring
  • setWorldSupportPhysXScene() : nvidia::apex::ModuleDestructible
  • setWriteForFunction() : nvidia::apex::CudaTestManager
  • setWriteForNotSuccessfulKernel() : nvidia::apex::CudaTestManager
  • setWritePath() : nvidia::apex::CudaTestManager
  • shouldMirror() : nvidia::apex::MirrorScene::MirrorFilter
  • simplify() : nvidia::apex::ClothingPhysicalMesh
  • simulate() : nvidia::apex::Scene
  • size() : NvParameterized::Serializer::DeserializedResults< T, bufSize >
  • SliceParameters() : FractureTools::SliceParameters
  • startEmit() : nvidia::apex::EmitterActor
  • stopEmit() : nvidia::apex::EmitterActor
  • strdup() : NvParameterized::Traits
  • strfree() : NvParameterized::Traits
  • strToValue()
: NvParameterized::Handle
, NvParameterized::Interface
  • structName() : NvParameterized::Definition
  • submeshCount() : nvidia::apex::ExplicitHierarchicalMesh
  • submeshData() : nvidia::apex::ExplicitHierarchicalMesh
  • SubmeshDesc() : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • submitForceSampleBatch() : nvidia::apex::ModuleFieldSampler
  • surfaceNormal() : nvidia::apex::ExplicitHierarchicalMesh
  • swapArrayElements()
: NvParameterized::Handle
, NvParameterized::Interface
  • synchronizeMirrorScene() : nvidia::apex::MirrorScene
  • synchronizePrimaryScene() : nvidia::apex::MirrorScene
  • syncVisibility() : nvidia::apex::RenderMeshActor
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- t -

  • takeImpact() : nvidia::apex::DestructibleActor
  • TestFunctionInterface() : nvidia::apex::TestFunctionInterface
  • toColorRGBA() : nvidia::apex::VertexColor
  • traitsWarn() : NvParameterized::Traits
  • trimCollisionGeometry() : nvidia::apex::DestructibleAssetAuthoring
  • type()
: NvParameterized::Hint
, NvParameterized::Definition
  • typeString() : NvParameterized::Definition
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- u -

  • unlockIofxActorList() : nvidia::apex::RenderVolume
  • unlockModuleSceneRenderLock() : nvidia::apex::Module
  • unlockRead() : nvidia::apex::Scene
  • unlockRenderResources() : nvidia::apex::RenderDataProvider
  • unlockTriangles() : nvidia::apex::ClothingTriangleMesh
  • unlockWrite() : nvidia::apex::Scene
  • unmap()
: nvidia::apex::UserRenderSurface
, nvidia::apex::UserRenderBuffer
  • updateBindPoses() : nvidia::apex::ClothingAssetAuthoring
  • updateBounds() : nvidia::apex::RenderMeshActor
  • updateLegacyNvParameterized() : NvParameterized::Traits
  • updateMaxDistanceScale() : nvidia::apex::ClothingActor
  • updateRenderResources() : nvidia::apex::RenderDataProvider
  • updateState()
: nvidia::apex::ClothingActor
, nvidia::apex::ClothingPreview
  • userData() : NvParameterized::Handle
  • UserRenderDataHolder() : nvidia::apex::UserRenderDataHolder
  • useUniqueRenderVolume() : nvidia::apex::EffectPackageAsset
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- v -

  • validateEmitterPosition() : nvidia::apex::EmitterActor::EmitterValidateCallback
  • valueToStr()
: NvParameterized::Handle
, NvParameterized::Interface
  • Vec2T() : nvidia::apex::Vec2T< T >
  • velocityShader() : nvidia::apex::ClothingVelocityCallback
  • version() : NvParameterized::Interface
  • Vertex() : nvidia::apex::Vertex
  • VertexColor() : nvidia::apex::VertexColor
  • VertexUV() : nvidia::apex::VertexUV
  • visiblePartCount() : nvidia::apex::RenderMeshActor
  • visualize()
: nvidia::apex::Shape
, nvidia::apex::ExplicitHierarchicalMesh
  • visualizeVoronoiCells()
: nvidia::apex::FractureToolsAPI
, nvidia::apex::DestructibleAssetAuthoring
  • voronoiSplitChunk()
: nvidia::apex::DestructibleAssetAuthoring
, nvidia::apex::FractureToolsAPI
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Functions

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- w -

  • WrappedNamedReference() : NvParameterized::WrappedNamedReference
  • write() : nvidia::apex::PxStreamFromFileBuf
  • writeBuffer()
: nvidia::apex::UserRenderIndexBuffer
, nvidia::apex::UserRenderVertexBuffer
, nvidia::apex::UserRenderSurfaceBuffer
, nvidia::apex::UserRenderSpriteBuffer
, nvidia::apex::UserRenderInstanceBuffer
, nvidia::apex::UserRenderBoneBuffer
  • WriteLock() : nvidia::apex::WriteLock
  • writeTexture() : nvidia::apex::UserRenderSpriteBuffer
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Typedefs

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • BufferID : nvidia::apex::VertexFormat
  • DeserializedData : NvParameterized::Serializer
  • DeserializedMetadata : NvParameterized::Serializer
  • ModuleNameErrorMap : nvidia::apex::ModuleLoader
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • a : nvidia::apex::VertexColor , nvidia::apex::ColorRGBA
  • activeObjectCount : nvidia::apex::IofxSharedRenderData
  • actor : nvidia::apex::DestructibleActorJointDesc
  • alwaysDrawScatterMesh : nvidia::apex::DestructibleParameters
  • amplitude : FractureTools::NoiseParameters
  • angularVariation : FractureTools::SliceParameters
  • ANY_VERSION : NvParameterized::SerializePlatform
  • ApexStatsInfoPtr : nvidia::apex::SceneStats
  • appGuid : nvidia::apex::ApexSDKDesc
  • appliedDamageUserData : nvidia::apex::DamageEventReportData
  • archType : NvParameterized::SerializePlatform
  • arrayIndex : nvidia::apex::UserRenderSpriteTextureDesc
  • attachment : nvidia::apex::DestructibleRTFractureParameters
  • attachmentChunkIndex : nvidia::apex::DestructibleActorJointDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- k -

  • keepPreviousFrameBoneBuffer : nvidia::apex::RenderMeshActorDesc
  • keepVisibleBonesPacked : nvidia::apex::RenderMeshActorDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • layout : nvidia::apex::UserRenderSpriteTextureDesc
  • legacyChunkBoundsTestSetting : nvidia::apex::DestructibleParameters
  • legacyDamageRadiusSpreadSetting : nvidia::apex::DestructibleParameters
  • lifeWeight : nvidia::apex::EmitterLodParamDesc
  • linearVariation : FractureTools::SliceParameters
  • local2world : nvidia::apex::RenderContext
  • localAnchor : nvidia::apex::DestructibleActorJointDesc
  • localAxis : nvidia::apex::DestructibleActorJointDesc
  • localNormal : nvidia::apex::DestructibleActorJointDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • m_cullMode : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_firstVertex : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_indexType : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_materialName : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_numIndices : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_numParts : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_numSubmeshes : nvidia::apex::RenderMeshAssetAuthoring::MeshDesc
  • m_numVertexBuffers : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_numVertices : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_partIndices : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_primitive : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_smoothingGroups : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_submeshes : nvidia::apex::RenderMeshAssetAuthoring::MeshDesc
  • m_uvOrigin : nvidia::apex::RenderMeshAssetAuthoring::MeshDesc
  • m_vertexBuffers : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • m_vertexIndices : nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • mArrayIndex : NvParameterized::ParameterFind , NvParameterized::ParameterList
  • mArraySize : NvParameterized::ParamResult
  • material : nvidia::apex::UserRenderResourceDesc
  • materialDesc
: FractureTools::FractureSliceDesc
, FractureTools::CutoutParameters
, FractureTools::FractureVoronoiDesc
  • materialStrength : nvidia::apex::DestructibleBehaviorGroupDesc
  • MAX_SPRITE_TEXTURES : nvidia::apex::UserRenderSpriteBufferDesc
  • MAX_SURFACE_COUNT : nvidia::apex::IofxSpriteRenderLayout
  • maxBones : nvidia::apex::UserRenderBoneBufferDesc
  • maxChunkSpeed : nvidia::apex::DestructibleParameters
  • maxDepenetrationVelocity : nvidia::apex::DestructibleBehaviorGroupDesc
  • maxDepth : FractureTools::FractureSliceDesc , nvidia::apex::DamageEventReportData
  • maxDistance : nvidia::apex::ClothingConstrainCoefficients , nvidia::apex::EmitterLodParamDesc
  • maxHullFaceCount : nvidia::apex::DestructibleAssetStats
  • maxHullVertexCount : nvidia::apex::DestructibleAssetStats
  • maximum : nvidia::apex::Range< T >
  • maxIndices : nvidia::apex::UserRenderIndexBufferDesc
  • maxInstanceCount : nvidia::apex::RenderMeshActorDesc
  • maxInstances : nvidia::apex::UserRenderInstanceBufferDesc
  • maxObjectCount : nvidia::apex::IofxSharedRenderData
  • maxSprites : nvidia::apex::UserRenderSpriteBufferDesc
  • maxVerts : nvidia::apex::UserRenderVertexBufferDesc
  • mBonesPerVertex : nvidia::apex::ExplicitVertexFormat
  • mClassesOnly : NvParameterized::ParameterList
  • mClassName : NvParameterized::ParamResult , NvParameterized::ParameterList
  • mConcavityPercent : nvidia::apex::CollisionVolumeDesc
  • mCoordinateSystem : nvidia::apex::MaterialFrame
  • mDataType : NvParameterized::ParamResult
  • mDepthCount : nvidia::apex::CollisionDesc
  • mError : NvParameterized::ParameterFind
  • meshIndex : nvidia::apex::DestructibleChunkDesc
  • meshMode : FractureTools::MeshProcessingParameters
  • meshRenderBuffer : nvidia::apex::IofxMeshSharedRenderData
  • meshRenderLayout : nvidia::apex::IofxMeshSharedRenderData
  • mFlags : nvidia::apex::PhysXObjectDesc
  • mFractureIndex : nvidia::apex::MaterialFrame
  • mFractureMethod : nvidia::apex::MaterialFrame
  • mHandle : NvParameterized::ParamResult
  • mHasDynamicBinormals : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicColors : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicDisplacements : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicNormals : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicPositions : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicSeparateBoneBuffer : nvidia::apex::ExplicitVertexFormat
  • mHasDynamicTangents : nvidia::apex::ExplicitVertexFormat
  • mHasStaticBinormals : nvidia::apex::ExplicitVertexFormat
  • mHasStaticColors : nvidia::apex::ExplicitVertexFormat
  • mHasStaticDisplacements : nvidia::apex::ExplicitVertexFormat
  • mHasStaticNormals : nvidia::apex::ExplicitVertexFormat
  • mHasStaticPositions : nvidia::apex::ExplicitVertexFormat
  • mHasStaticSeparateBoneBuffer : nvidia::apex::ExplicitVertexFormat
  • mHasStaticTangents : nvidia::apex::ExplicitVertexFormat
  • mHullMethod : nvidia::apex::CollisionVolumeDesc
  • microgridSize : FractureTools::MeshProcessingParameters
  • minConvexSize : nvidia::apex::DestructibleRTFractureParameters
  • minDepth : nvidia::apex::DamageEventReportData
  • minimum : nvidia::apex::Range< T >
  • minimumChunkSize : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • minimumFractureDepth : nvidia::apex::DestructibleParameters
  • minimumRadius : nvidia::apex::DamageSpreadFunction
  • mInstanceName : NvParameterized::ParamResult
  • mInterface : NvParameterized::ParameterFind , NvParameterized::ParameterList
  • mipLevel : nvidia::apex::UserRenderSpriteTextureDesc
  • mLines : nvidia::apex::PhysXRenderBuffer
  • mLongName : NvParameterized::ParamResult
  • mMaterialName : nvidia::apex::ExplicitSubmeshData
  • mMaxEdgeCount : nvidia::apex::CollisionVolumeDesc
  • mMaxFaceCount : nvidia::apex::CollisionVolumeDesc
  • mMaximumTrimming : nvidia::apex::CollisionDesc
  • mMaxResults : NvParameterized::ParameterList
  • mMaxVertexCount : nvidia::apex::CollisionVolumeDesc
  • mMergeThreshold : nvidia::apex::CollisionVolumeDesc
  • mMeshName : nvidia::apex::UserOpaqueMeshDesc
  • mName : NvParameterized::ParamResult , nvidia::apex::TestFunctionInterface
  • mNameCount : NvParameterized::ParameterFind
  • mNameIndex : NvParameterized::ParameterFind , NvParameterized::ParameterList
  • mNbLines : nvidia::apex::PhysXRenderBuffer
  • mNbPoints : nvidia::apex::PhysXRenderBuffer
  • mNbTexts : nvidia::apex::PhysXRenderBuffer
  • mNbTriangles : nvidia::apex::PhysXRenderBuffer
  • ModifierType
: nvidia::apex::SimpleScaleModifier
, nvidia::apex::RotationRateModifier
, nvidia::apex::OrientScaleAlongScreenVelocityModifier
, nvidia::apex::ColorVsVelocityModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::RotationModifier
, nvidia::apex::RandomRotationModifier
, nvidia::apex::ScaleAlongVelocityModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::ScaleByMassModifier
, nvidia::apex::ColorVsLifeModifier
, nvidia::apex::RandomScaleModifier
, nvidia::apex::SubtextureVsLifeModifier
, nvidia::apex::OrientAlongVelocityModifier
, nvidia::apex::RandomSubtextureModifier
, nvidia::apex::ViewDirectionSortingModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
  • ModifierUsage
: nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::RandomScaleModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::ColorVsVelocityModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ViewDirectionSortingModifier
, nvidia::apex::RotationRateModifier
, nvidia::apex::ScaleByMassModifier
, nvidia::apex::RandomSubtextureModifier
, nvidia::apex::RandomRotationModifier
, nvidia::apex::RotationModifier
, nvidia::apex::SubtextureVsLifeModifier
, nvidia::apex::ColorVsLifeModifier
, nvidia::apex::SimpleScaleModifier
, nvidia::apex::ScaleAlongVelocityModifier
, nvidia::apex::OrientScaleAlongScreenVelocityModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::OrientAlongVelocityModifier
  • moduleId : nvidia::apex::ModuleSpecificRenderBufferData
  • moduleIdentifier : nvidia::apex::UserRenderVertexBufferDesc
  • moduleSpecificSemanticData : nvidia::apex::ModuleSpecificRenderBufferData
  • momentum : nvidia::apex::DamageEventUnit
  • mParamName : NvParameterized::ParameterList
  • mPoints : nvidia::apex::PhysXRenderBuffer
  • mRecursionDepth : nvidia::apex::CollisionVolumeDesc
  • mRecursive : NvParameterized::ParameterList
  • mResult : NvParameterized::ParameterList , NvParameterized::ParameterFind
  • mResultCount : NvParameterized::ParameterList
  • mResults : NvParameterized::ParameterList
  • mSearchName : NvParameterized::ParameterFind , NvParameterized::ParameterList
  • mSearchNames : NvParameterized::ParameterFind
  • mSliceDepth : nvidia::apex::MaterialFrame
  • mTexts : nvidia::apex::PhysXRenderBuffer
  • mTraits : NvParameterized::ParameterList
  • mTriangles : nvidia::apex::PhysXRenderBuffer
  • mUVCount : nvidia::apex::ExplicitVertexFormat
  • mUVOffset : nvidia::apex::MaterialFrame
  • mUVPlane : nvidia::apex::MaterialFrame
  • mUVScale : nvidia::apex::MaterialFrame
  • mVertexFormat : nvidia::apex::ExplicitSubmeshData
  • mVolumeDescs : nvidia::apex::CollisionDesc
  • mWinding : nvidia::apex::ExplicitVertexFormat
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • name : nvidia::apex::DestructibleBehaviorGroupDesc
  • negX : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • negY : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • negZ : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • next
: nvidia::apex::DamageEventHeader
, nvidia::apex::FractureEventHeader
, nvidia::apex::ChunkTransformHeader
  • noise : FractureTools::SliceParameters
  • noiseMode : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • normal
: nvidia::apex::EmitterGeomExplicit::EllipsoidParams
, nvidia::apex::RenderMeshActorRaycastHitData
, nvidia::apex::Vertex
  • normalBary : nvidia::apex::ClothingMeshSkinningMap
  • numApexStats : nvidia::apex::SceneStats
  • numBones : nvidia::apex::UserRenderResourceDesc
  • numCustomBuffers : nvidia::apex::UserRenderVertexBufferDesc
  • numIndices : nvidia::apex::ClothingPhysicalMeshStats , nvidia::apex::UserRenderResourceDesc
  • numInstances : nvidia::apex::UserRenderResourceDesc
  • numModuleSpecificSemantics : nvidia::apex::ModuleSpecificRenderBufferData
  • numSectors : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • numSprites : nvidia::apex::UserRenderResourceDesc
  • numSurfaceBuffers : nvidia::apex::UserRenderResourceDesc
  • numVertexBuffers : nvidia::apex::UserRenderResourceDesc
  • numVertices : nvidia::apex::ClothingPhysicalMeshStats
  • numVerts : nvidia::apex::UserRenderResourceDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • objectCount : nvidia::apex::IofxCommonRenderData
  • offsets : nvidia::apex::IofxSpriteRenderLayout , nvidia::apex::IofxMeshRenderLayout
  • opaqueMesh : nvidia::apex::UserRenderResourceDesc
  • order : FractureTools::SliceParameters
  • osType : NvParameterized::SerializePlatform
  • osVer : NvParameterized::SerializePlatform
  • outMaterialID : nvidia::apex::MaterialLookupCallback::MaterialRequest
  • overrideMaterialCount : nvidia::apex::RenderMeshActorDesc
  • overrideMaterials : nvidia::apex::RenderMeshActorDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • b : nvidia::apex::VertexColor , nvidia::apex::ColorRGBA
  • backfaceNoise : FractureTools::CutoutParameters
  • behaviorGroupDescCount : nvidia::apex::DestructibleAssetCookingDesc
  • behaviorGroupDescs : nvidia::apex::DestructibleAssetCookingDesc
  • behaviorGroupIndex : nvidia::apex::DestructibleChunkDesc
  • bias : nvidia::apex::EmitterLodParamDesc
  • binormal : nvidia::apex::RenderMeshActorRaycastHitData , nvidia::apex::Vertex
  • bits0 : nvidia::apex::GroupsMask64
  • bits1 : nvidia::apex::GroupsMask64
  • boneBuffer : nvidia::apex::UserRenderResourceDesc
  • boneIndices : nvidia::apex::Vertex
  • boneWeights : nvidia::apex::Vertex
  • bufferDesc : nvidia::apex::IofxSpriteRenderLayout , nvidia::apex::IofxMeshRenderLayout
  • buffersRequest : nvidia::apex::UserRenderVertexBufferDesc , nvidia::apex::UserRenderBoneBufferDesc
  • bufferVisibility : nvidia::apex::RenderMeshActorDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • canBeShared : nvidia::apex::UserRenderVertexBufferDesc
  • center : nvidia::apex::EmitterGeomExplicit::SphereParams , nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • chunkBytes : nvidia::apex::DestructibleAssetStats
  • chunkCount : nvidia::apex::DestructibleAssetStats
  • chunkDescCount : nvidia::apex::DestructibleAssetCookingDesc
  • chunkDescs : nvidia::apex::DestructibleAssetCookingDesc
  • chunkFracturingMethod : FractureTools::FractureCutoutDesc
  • chunkHullDataBytes : nvidia::apex::DestructibleAssetStats
  • chunkIndex
: nvidia::apex::DestructibleHitChunk
, nvidia::apex::DestructibleChunkEvent
, nvidia::apex::DamageEventUnit
, nvidia::apex::FractureEventUnit
, nvidia::apex::ChunkTransformUnit
  • chunkIndexInAsset : nvidia::apex::DamageEventCoreData
  • chunkIndices : FractureTools::FractureVoronoiDesc
  • chunkOrientation : nvidia::apex::ChunkTransformUnit
  • chunkPosition : nvidia::apex::ChunkTransformUnit
  • chunkTransformBufferStart : nvidia::apex::ChunkTransformHeader
  • chunkTransformCopyDepth : nvidia::apex::DestructibleChunkSyncState
  • chunkTransformCount : nvidia::apex::ChunkTransformHeader
  • chunkWithMaxEdgeCount : nvidia::apex::DestructibleAssetStats
  • className : NvParameterized::Serializer::MetadataEntry
  • collisionCookedHullDataBytes : nvidia::apex::DestructibleAssetStats
  • collisionMeshCount : nvidia::apex::DestructibleAssetStats
  • collisionSphereDistance : nvidia::apex::ClothingConstrainCoefficients
  • collisionSphereRadius : nvidia::apex::ClothingConstrainCoefficients
  • collisionVolumeDesc : nvidia::apex::DestructibleGeometryDesc
  • color : nvidia::apex::Vertex
  • compilerType : NvParameterized::SerializePlatform
  • compilerVer : NvParameterized::SerializePlatform
  • convexHullCount : nvidia::apex::DestructibleGeometryDesc
  • convexHulls : nvidia::apex::DestructibleGeometryDesc
  • cooking : nvidia::apex::ApexSDKDesc
  • cullMode : nvidia::apex::UserRenderResourceDesc
  • customBuffersIdents : nvidia::apex::UserRenderVertexBufferDesc
  • customBuffersRequest : nvidia::apex::UserRenderVertexBufferDesc
  • cutoutHeightInvert : FractureTools::FractureCutoutDesc
  • cutoutHeightOffset : FractureTools::FractureCutoutDesc
  • cutoutHeightScale : FractureTools::FractureCutoutDesc
  • cutoutParameters : FractureTools::FractureCutoutDesc
  • cutoutSizeX : FractureTools::FractureCutoutDesc
  • cutoutSizeY : FractureTools::FractureCutoutDesc
  • cutoutWidthInvert : FractureTools::FractureCutoutDesc
  • cutoutWidthOffset : FractureTools::FractureCutoutDesc
  • cutoutWidthScale : FractureTools::FractureCutoutDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • damage
: nvidia::apex::ChunkData
, nvidia::apex::DamageEventCoreData
, nvidia::apex::DamageEventUnit
  • damageCap : nvidia::apex::DestructibleParameters
  • damageColorChange : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageColorSpread : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageDepthLimit : nvidia::apex::DestructibleParameters
  • damageEventBufferStart : nvidia::apex::DamageEventHeader
  • damageEventCount : nvidia::apex::DamageEventHeader
  • damageEventFilterDepth : nvidia::apex::DestructibleActorSyncState
  • damageEventFlags : nvidia::apex::DamageEventUnit
  • damageSpread : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageThreshold : nvidia::apex::DestructibleBehaviorGroupDesc
  • damageToRadius : nvidia::apex::DestructibleBehaviorGroupDesc
  • data : nvidia::apex::RenderSemanticData
  • debrisDepth : nvidia::apex::DestructibleParameters
  • debrisDestructionProbability : nvidia::apex::DestructibleParameters
  • debrisLifetimeMax : nvidia::apex::DestructibleParameters
  • debrisLifetimeMin : nvidia::apex::DestructibleParameters
  • debrisMaxSeparationMax : nvidia::apex::DestructibleParameters
  • debrisMaxSeparationMin : nvidia::apex::DestructibleParameters
  • debugInterface : nvidia::apex::SceneDesc
  • debugVisualizeLocally : nvidia::apex::SceneDesc
  • debugVisualizeRemotely : nvidia::apex::SceneDesc
  • def : NvParameterized::Serializer::MetadataEntry
  • defaultBehaviorGroupDesc : nvidia::apex::DestructibleAssetCookingDesc
  • density : nvidia::apex::DestructibleBehaviorGroupDesc
  • densityFormat : nvidia::apex::TurbulenceRenderLayout
  • depth
: nvidia::apex::UserRenderSurfaceBufferDesc
, FractureTools::CutoutParameters
, nvidia::apex::ChunkData
, nvidia::apex::UserRenderSurfaceDesc
  • depthLimit : nvidia::apex::DestructibleRTFractureParameters
  • depthParameters : nvidia::apex::DestructibleParameters
  • depthParametersCount : nvidia::apex::DestructibleParameters
  • depthPitch : nvidia::apex::UserRenderSurface::MappedInfo
  • destroyIfAtDepthLimit : nvidia::apex::DestructibleRTFractureParameters
  • destructible
: nvidia::apex::DestructibleActorJointDesc
, nvidia::apex::DamageEventReportData
, nvidia::apex::ChunkStateEventData
, nvidia::apex::ImpactDamageEventData
  • direction
: nvidia::apex::DamageEventUnit
, nvidia::apex::ImpactDamageEventData
, nvidia::apex::FractureEventUnit
  • directionOrder : FractureTools::FractureCutoutDesc
  • directions : FractureTools::FractureCutoutDesc
  • disableTransformBuffering : nvidia::apex::DestructibleChunkSyncState
  • displacementFlags : nvidia::apex::Vertex
  • distanceWeight : nvidia::apex::EmitterLodParamDesc
  • dllLoadPath : nvidia::apex::ApexSDKDesc
  • dllNamePostfix : nvidia::apex::ApexSDKDesc
  • doDetectOverlaps
: nvidia::apex::EmitterGeomExplicit::PointParams
, nvidia::apex::EmitterGeomExplicit::SphereParams
, nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • doNotCrumble : nvidia::apex::DestructibleChunkDesc
  • doNotDamage : nvidia::apex::DestructibleChunkDesc
  • doNotFracture : nvidia::apex::DestructibleChunkDesc
  • dynamicChunksDominanceGroup : nvidia::apex::DestructibleParameters
  • dynamicChunksFilterData : nvidia::apex::DestructibleParameters
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • edgeNoise : FractureTools::CutoutParameters
  • enableConcurrencyCheck : nvidia::apex::ApexSDKDesc
  • essentialDepth : nvidia::apex::DestructibleParameters
  • event : nvidia::apex::DestructibleChunkEvent
  • excludeSleepingChunks : nvidia::apex::DestructibleChunkSyncState
  • extraDataIndex : nvidia::apex::ExplicitRenderTriangle
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • faceNoise : FractureTools::FractureVoronoiDesc
  • facetNormalMergeThresholdAngle : FractureTools::FractureCutoutDesc
  • fadeOut : nvidia::apex::DestructibleBehaviorGroupDesc
  • falloffExponent : nvidia::apex::DamageSpreadFunction
  • fieldSurfaceDescs : nvidia::apex::TurbulenceRenderData
  • fieldSurfaces : nvidia::apex::TurbulenceRenderData
  • firstBone : nvidia::apex::UserRenderResourceDesc
  • firstIndex : nvidia::apex::UserRenderResourceDesc
  • firstInstance : nvidia::apex::UserRenderResourceDesc
  • firstSegmentSize : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • firstSprite : nvidia::apex::UserRenderResourceDesc
  • firstVertex : nvidia::apex::UserRenderResourceDesc
  • flags
: nvidia::apex::ChunkData
, nvidia::apex::DestructibleDepthParameters
, nvidia::apex::DestructibleParameters
, nvidia::apex::DestructibleInitParameters
  • flameFormat : nvidia::apex::TurbulenceRenderLayout
  • forceBoneIndexChannel : nvidia::apex::RenderMeshActorDesc
  • forceFallbackSkinning : nvidia::apex::RenderMeshActorDesc
  • forceToDamage : nvidia::apex::DestructibleParameters
  • format
: nvidia::apex::RenderSemanticData
, nvidia::apex::UserRenderSurfaceDesc
, nvidia::apex::UserRenderIndexBufferDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
  • foundation : nvidia::apex::ApexSDKDesc
  • fractureEventBufferStart : nvidia::apex::FractureEventHeader
  • fractureEventCount : nvidia::apex::FractureEventHeader
  • fractureEventFilterDepth : nvidia::apex::DestructibleActorSyncState
  • fractureEventFlags : nvidia::apex::FractureEventUnit
  • fractureEventList : nvidia::apex::DamageEventReportData
  • fractureEventListSize : nvidia::apex::DamageEventReportData
  • fractureImpulseScale : nvidia::apex::DestructibleParameters
  • frequency : FractureTools::NoiseParameters
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • g : nvidia::apex::VertexColor , nvidia::apex::ColorRGBA
  • geometryDescCount : nvidia::apex::DestructibleAssetCookingDesc
  • geometryDescs : nvidia::apex::DestructibleAssetCookingDesc
  • glass : nvidia::apex::DestructibleRTFractureParameters
  • globalAnchor : nvidia::apex::DestructibleActorJointDesc
  • globalAxis : nvidia::apex::DestructibleActorJointDesc
  • globalNormal : nvidia::apex::DestructibleActorJointDesc
  • gridSize : FractureTools::NoiseParameters
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • height
: nvidia::apex::UserRenderSurfaceDesc
, nvidia::apex::UserRenderSpriteTextureDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
  • heightSurfaceBuffers : nvidia::apex::UserRenderResourceDesc
  • hint
: nvidia::apex::UserRenderSpriteBufferDesc
, nvidia::apex::UserRenderVertexBufferDesc
, nvidia::apex::UserRenderInstanceBufferDesc
, nvidia::apex::UserRenderBoneBufferDesc
, nvidia::apex::UserRenderIndexBufferDesc
  • hitChunkFlags : nvidia::apex::DestructibleHitChunk
  • hitDirection : nvidia::apex::DamageEventReportData
  • hitPosition : nvidia::apex::DamageEventReportData
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • ident : nvidia::apex::RenderSemanticData
  • impactDamageActor : nvidia::apex::DamageEventReportData , nvidia::apex::ImpactDamageEventData
  • impactDamageDefaultDepth : nvidia::apex::DestructibleParameters
  • impactVelocityThreshold : nvidia::apex::DestructibleParameters
  • impulse : nvidia::apex::FractureEventUnit
  • impulseScale : nvidia::apex::DestructibleRTFractureParameters
  • index : nvidia::apex::ChunkData
  • indexBuffer : nvidia::apex::UserRenderResourceDesc
  • indexBufferBytes : nvidia::apex::RenderMeshAssetStats
  • indexBufferHint : nvidia::apex::RenderMeshActorDesc
  • indexCount : nvidia::apex::RenderMeshAssetStats
  • instanceBuffer : nvidia::apex::UserRenderResourceDesc
  • instanceChunks : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • instancePositionOffset : nvidia::apex::DestructibleChunkDesc
  • instanceUVOffset : nvidia::apex::DestructibleChunkDesc
  • instancingMode : FractureTools::FractureCutoutDesc
  • interiorSubmeshIndex : nvidia::apex::FractureMaterialDesc
  • interopContext
: nvidia::apex::UserRenderSpriteBufferDesc
, nvidia::apex::UserRenderIndexBufferDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
, nvidia::apex::UserRenderInstanceBufferDesc
, nvidia::apex::UserRenderVertexBufferDesc
  • interopFlags : nvidia::apex::UserRenderSurfaceDesc , nvidia::apex::UserRenderBufferDesc
  • islandGeneration : FractureTools::MeshProcessingParameters
  • isScreenSpace : nvidia::apex::RenderContext
  • isSupportChunk : nvidia::apex::DestructibleChunkDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • parentIndex : nvidia::apex::DestructibleChunkDesc
  • partCount : nvidia::apex::RenderMeshAssetStats
  • partIndex : nvidia::apex::RenderMeshActorRaycastHitData
  • pData : nvidia::apex::UserRenderSurface::MappedInfo
  • physX3Interface : nvidia::apex::SceneDesc
  • physXObjDescTableAllocationIncrement : nvidia::apex::ApexSDKDesc
  • physXSDK : nvidia::apex::ApexSDKDesc
  • physXSDKVersion : nvidia::apex::ApexSDKDesc
  • pitchBytes : nvidia::apex::UserRenderSpriteTextureDesc
  • polarRadius : nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • position
: nvidia::apex::DamageEventCoreData
, nvidia::apex::DamageEventUnit
, nvidia::apex::Vertex
, nvidia::apex::FractureEventUnit
, nvidia::apex::EmitterGeomExplicit::PointParams
  • positionBary : nvidia::apex::ClothingMeshSkinningMap
  • positionCount : nvidia::apex::ChunkParticleReportData
  • positions : nvidia::apex::ChunkParticleReportData
  • positionStart : nvidia::apex::EmitterGeomExplicit::PointListData
  • positionStrideBytes : nvidia::apex::EmitterGeomExplicit::PointListData
  • posX : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • posY : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • posZ : nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • primitives : nvidia::apex::UserRenderIndexBufferDesc , nvidia::apex::UserRenderResourceDesc
  • pvd : nvidia::apex::ApexSDKDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • r : nvidia::apex::VertexColor , nvidia::apex::ColorRGBA
  • radius
: nvidia::apex::DamageEventUnit
, nvidia::apex::EmitterGeomExplicit::SphereParams
, nvidia::apex::DamageEventCoreData
, nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • radiusMultiplier : nvidia::apex::DamageSpreadFunction
  • refCount : NvParameterized::WrappedNamedReference
  • registerInCUDA
: nvidia::apex::UserRenderIndexBufferDesc
, nvidia::apex::UserRenderInstanceBufferDesc
, nvidia::apex::UserRenderSpriteBufferDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
, nvidia::apex::UserRenderVertexBufferDesc
  • removeTJunctions : FractureTools::MeshProcessingParameters
  • renderMeshActorLoadMaterialsLazily : nvidia::apex::ApexSDKDesc
  • renderMeshAssetStats : nvidia::apex::DestructibleAssetStats
  • renderMeshName : nvidia::apex::RenderContext
  • renderResource : nvidia::apex::IofxCommonRenderData , nvidia::apex::RenderContext
  • renderResourceManager : nvidia::apex::ApexSDKDesc
  • renderResourceName : nvidia::apex::IofxCommonRenderData
  • renderResourceNameSpace : nvidia::apex::IofxCommonRenderData
  • renderWithoutSkinning : nvidia::apex::RenderMeshActorDesc
  • resourceCallback : nvidia::apex::ApexSDKDesc
  • resourceProviderIsCaseSensitive : nvidia::apex::ApexSDKDesc
  • rowPitch : nvidia::apex::UserRenderSurface::MappedInfo
  • RTFractureBehaviorGroup : nvidia::apex::DestructibleAssetCookingDesc
  • rtFractureParameters : nvidia::apex::DestructibleParameters
  • runtimeCookedConvexCount : nvidia::apex::DestructibleAssetStats
  • runtimeFracture : nvidia::apex::DestructibleChunkDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • samplePosition : nvidia::apex::MaterialLookupCallback::MaterialRequest
  • scatterMeshCount : nvidia::apex::DestructibleChunkDesc
  • scatterMeshIndices : nvidia::apex::DestructibleChunkDesc
  • scatterMeshTransforms : nvidia::apex::DestructibleChunkDesc
  • scene : nvidia::apex::SceneDesc
  • sectorRand : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • segmentRand : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • segmentScale : nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • semanticOffsets : nvidia::apex::UserRenderInstanceBufferDesc , nvidia::apex::UserRenderSpriteBufferDesc
  • separationWeight : nvidia::apex::EmitterLodParamDesc
  • serialize : nvidia::apex::RenderSemanticData
  • sharedRenderData : nvidia::apex::IofxSpriteRenderData , nvidia::apex::IofxMeshRenderData
  • sheetFracture : nvidia::apex::DestructibleRTFractureParameters
  • siteCount : FractureTools::FractureVoronoiDesc
  • sites : FractureTools::FractureVoronoiDesc
  • size : nvidia::apex::UserRenderBufferDesc
  • sliceParameters : FractureTools::FractureSliceDesc
  • smoothingMask : nvidia::apex::ExplicitRenderTriangle
  • solidShadedMaterial : nvidia::apex::ApexSDKDesc
  • speedWeight : nvidia::apex::EmitterLodParamDesc
  • splitNonconvexRegions : FractureTools::FractureCutoutDesc
  • splitsPerPass : FractureTools::SliceParameters
  • spriteBuffer : nvidia::apex::UserRenderResourceDesc
  • spriteRenderBuffer : nvidia::apex::IofxSpriteSharedRenderData
  • spriteRenderLayout : nvidia::apex::IofxSpriteSharedRenderData
  • spriteRenderSurfaces : nvidia::apex::IofxSpriteSharedRenderData
  • srcFormat : nvidia::apex::RenderSemanticData
  • startIndex : nvidia::apex::IofxCommonRenderData
  • StatCurrentValue : nvidia::apex::StatsInfo
  • stateEventList : nvidia::apex::ChunkStateEventData
  • stateEventListSize : nvidia::apex::ChunkStateEventData
  • StatName : nvidia::apex::StatsInfo
  • StatType : nvidia::apex::StatsInfo
  • stride
: nvidia::apex::UserRenderInstanceBufferDesc
, nvidia::apex::IofxMeshRenderLayout
, nvidia::apex::RenderSemanticData
, nvidia::apex::IofxSpriteRenderLayout
, nvidia::apex::UserRenderSpriteBufferDesc
  • submeshCount : nvidia::apex::RenderMeshAssetStats
  • submeshIndex
: nvidia::apex::RenderMeshActorRaycastHitData
, nvidia::apex::UserRenderResourceDesc
, nvidia::apex::ExplicitRenderTriangle
  • supportDepth : nvidia::apex::DestructibleInitParameters
  • supportGraphEdgeCount : nvidia::apex::DestructibleAssetCookingDesc
  • supportGraphEdges : nvidia::apex::DestructibleAssetCookingDesc
  • supportStrength : nvidia::apex::DestructibleParameters
  • surfaceBuffers : nvidia::apex::UserRenderResourceDesc
  • surfaceCount : nvidia::apex::IofxSpriteRenderLayout
  • surfaceDescs : nvidia::apex::IofxSpriteRenderLayout
  • surfaceElements : nvidia::apex::IofxSpriteRenderLayout
  • surfaceNormal : nvidia::apex::DestructibleChunkDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • tangent
: nvidia::apex::FractureMaterialDesc
, nvidia::apex::RenderMeshActorRaycastHitData
, nvidia::apex::Vertex
  • tangentBary : nvidia::apex::ClothingMeshSkinningMap
  • targetProportions : FractureTools::FractureSliceDesc
  • textureCount : nvidia::apex::UserRenderSpriteBufferDesc
  • textureDescs : nvidia::apex::UserRenderSpriteBufferDesc
  • tileFractureMap : FractureTools::FractureCutoutDesc
  • time : nvidia::apex::RenderMeshActorRaycastHitData
  • totalBytes
: nvidia::apex::DestructibleAssetStats
, nvidia::apex::ClothingPhysicalMeshStats
, nvidia::apex::RenderMeshAssetStats
  • totalNumberOfFractureEvents : nvidia::apex::DamageEventReportData
  • triangleCount : nvidia::apex::RenderMeshPartData
  • trimFaceCollisionHulls : FractureTools::FractureCutoutDesc
  • type : nvidia::apex::DestructibleActorJointDesc , FractureTools::NoiseParameters
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • u : nvidia::apex::VertexUV
  • uAngle : nvidia::apex::FractureMaterialDesc
  • useCuda : nvidia::apex::SceneDesc
  • useDebugRenderable : nvidia::apex::SceneDesc
  • useDisplacementMaps : FractureTools::FractureSliceDesc , FractureTools::FractureVoronoiDesc
  • useDynamicChunksGroupsMask : nvidia::apex::DestructibleParameters
  • useInstancedRendering : nvidia::apex::DestructibleChunkDesc
  • userActorID
: nvidia::apex::DamageEventHeader
, nvidia::apex::FractureEventHeader
, nvidia::apex::ChunkTransformHeader
  • userData
: nvidia::apex::RenderMeshPartData
, nvidia::apex::ApexDesc
, nvidia::apex::ApexInterface
, nvidia::apex::DestructibleBehaviorGroupDesc
, nvidia::apex::PhysXObjectDesc
  • userDataStart : nvidia::apex::EmitterGeomExplicit::PointListData
  • userDataStrideBytes : nvidia::apex::EmitterGeomExplicit::PointListData
  • userDefinedCutoutParameters : FractureTools::FractureCutoutDesc
  • userDefinedDirection : FractureTools::FractureCutoutDesc
  • userFlags : nvidia::apex::UserRenderBufferDesc , nvidia::apex::UserRenderSurfaceDesc
  • userRenderData : nvidia::apex::UserRenderResourceDesc
  • userUVMapping : FractureTools::FractureCutoutDesc
  • useTargetProportions : FractureTools::FractureSliceDesc
  • uv : nvidia::apex::Vertex
  • uvOffset : nvidia::apex::FractureMaterialDesc
  • uvOrigin : nvidia::apex::UserRenderVertexBufferDesc
  • uvScale : nvidia::apex::FractureMaterialDesc
  • uvTileSize : FractureTools::FractureCutoutDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • v : nvidia::apex::VertexUV
  • validBounds : nvidia::apex::DestructibleParameters
  • velocities : nvidia::apex::ChunkParticleReportData
  • velocityCount : nvidia::apex::ChunkParticleReportData
  • velocityFormat : nvidia::apex::TurbulenceRenderLayout
  • velocityStart : nvidia::apex::EmitterGeomExplicit::PointListData
  • velocityStrideBytes : nvidia::apex::EmitterGeomExplicit::PointListData
  • verbosity : FractureTools::MeshProcessingParameters
  • version : NvParameterized::Serializer::MetadataEntry
  • vertexBufferBytes : nvidia::apex::RenderMeshAssetStats
  • vertexBuffers : nvidia::apex::UserRenderResourceDesc
  • vertexCount : nvidia::apex::RenderMeshAssetStats
  • vertexIndex0 : nvidia::apex::ClothingMeshSkinningMap
  • vertexIndex1 : nvidia::apex::ClothingMeshSkinningMap
  • vertexIndex2 : nvidia::apex::ClothingMeshSkinningMap
  • vertexIndices : nvidia::apex::RenderMeshActorRaycastHitData
  • vertices : nvidia::apex::ExplicitRenderTriangle
  • visible : nvidia::apex::RenderMeshActorDesc
  • visibleCount : nvidia::apex::IofxSpriteRenderData
  • visibleSpriteCount : nvidia::apex::UserRenderResourceDesc
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • width
: nvidia::apex::UserRenderSurfaceDesc
, nvidia::apex::UserRenderSpriteTextureDesc
, nvidia::apex::UserRenderSurfaceBufferDesc
  • widthSurfaceBuffers : nvidia::apex::UserRenderResourceDesc
  • wireframeMaterial : nvidia::apex::ApexSDKDesc
  • world2local : nvidia::apex::RenderContext
  • worldBounds : nvidia::apex::DamageEventReportData , nvidia::apex::ChunkData
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • x : nvidia::apex::Vec2T< T >
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Class Members - Variables

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • y : nvidia::apex::Vec2T< T >
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: File Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • All
  • Typedefs
  • Defines
  • a
  • c
  • d
  • p
  • r
  • s
  • w
Here is a list of all documented file members with links to the documentation:

- a -

  • APEX_ACTOR_TEMPLATE_PARAM : Actor.h
  • APEX_API : ApexSDK.h , ApexSDKVersionString.h
  • APEX_AUTHORABLE_ASSETS_TYPES_NAME_SPACE : ApexNameSpace.h
  • APEX_COLLISION_GROUP_128_NAME_SPACE : ApexNameSpace.h
  • APEX_COLLISION_GROUP_64_NAME_SPACE : ApexNameSpace.h
  • APEX_COLLISION_GROUP_MASK_NAME_SPACE : ApexNameSpace.h
  • APEX_COLLISION_GROUP_NAME_SPACE : ApexNameSpace.h
  • APEX_CUDA_SUPPORT : ApexDefs.h
  • APEX_CUSTOM_VB_NAME_SPACE : ApexNameSpace.h
  • APEX_DEFAULT_NO_INTEROP_IMPLEMENTATION : ApexDefs.h
  • APEX_DEFAULT_WAKE_UP_COUNTER : Actor.h
  • APEX_LINUX_SHARED_LIBRARIES : ApexDefs.h
  • APEX_MATERIALS_NAME_SPACE : ApexNameSpace.h
  • APEX_NV_PARAM_AUTH_ASSETS_TYPES_NAME_SPACE : ApexNameSpace.h
  • APEX_OPAQUE_MESH_NAME_SPACE : UserOpaqueMesh.h
  • APEX_PHYSICS_MATERIAL_NAME_SPACE : ApexNameSpace.h
  • APEX_SDK_RELEASE : ApexDefs.h
  • APEX_SDK_VERSION : ApexDefs.h
  • APEX_UE4 : ApexDefs.h
  • APEX_USE_PARTICLES : ApexDefs.h
  • APEX_VOLUME_RENDER_MATERIALS_NAME_SPACE : ApexNameSpace.h

- c -

  • CALL_CONV : ApexSDK.h , ApexSDKVersionString.h
  • CUgraphicsResource : UserRenderSurfaceBuffer.h , UserRenderSpriteBuffer.h , UserRenderInstanceBuffer.h , UserRenderIndexBuffer.h , UserRenderVertexBuffer.h

- d -

  • DYNAMIC_CAST : ApexDefs.h

- p -

  • PX_PHYSICS_VERSION : PhysX0/PhysXSDKVersion.h , PhysX3/PhysXSDKVersion.h
  • PX_PHYSICS_VERSION_BUGFIX : PhysX3/PhysXSDKVersion.h
  • PX_PHYSICS_VERSION_MAJOR : PhysX0/PhysXSDKVersion.h , PhysX3/PhysXSDKVersion.h
  • PX_PHYSICS_VERSION_MINOR : PhysX3/PhysXSDKVersion.h

- r -

  • READ_LOCK : Lock.h
  • RENDER_DEBUG_IFACE : RenderDebugInterface.h
  • RENDER_MESH_AUTHORING_TYPE_NAME : RenderMeshAsset.h

- s -

  • SDK_VERSION_NUMBER : PhysX3/PhysXSDKVersion.h

- w -

  • WRITE_LOCK : Lock.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: File Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • All
  • Typedefs
  • Defines
  • a
  • c
  • d
  • p
  • r
  • s
  • w

- a -

  • APEX_ACTOR_TEMPLATE_PARAM : Actor.h
  • APEX_API : ApexSDK.h , ApexSDKVersionString.h
  • APEX_AUTHORABLE_ASSETS_TYPES_NAME_SPACE : ApexNameSpace.h
  • APEX_COLLISION_GROUP_128_NAME_SPACE : ApexNameSpace.h
  • APEX_COLLISION_GROUP_64_NAME_SPACE : ApexNameSpace.h
  • APEX_COLLISION_GROUP_MASK_NAME_SPACE : ApexNameSpace.h
  • APEX_COLLISION_GROUP_NAME_SPACE : ApexNameSpace.h
  • APEX_CUDA_SUPPORT : ApexDefs.h
  • APEX_CUSTOM_VB_NAME_SPACE : ApexNameSpace.h
  • APEX_DEFAULT_NO_INTEROP_IMPLEMENTATION : ApexDefs.h
  • APEX_DEFAULT_WAKE_UP_COUNTER : Actor.h
  • APEX_LINUX_SHARED_LIBRARIES : ApexDefs.h
  • APEX_MATERIALS_NAME_SPACE : ApexNameSpace.h
  • APEX_NV_PARAM_AUTH_ASSETS_TYPES_NAME_SPACE : ApexNameSpace.h
  • APEX_OPAQUE_MESH_NAME_SPACE : UserOpaqueMesh.h
  • APEX_PHYSICS_MATERIAL_NAME_SPACE : ApexNameSpace.h
  • APEX_SDK_RELEASE : ApexDefs.h
  • APEX_SDK_VERSION : ApexDefs.h
  • APEX_UE4 : ApexDefs.h
  • APEX_USE_PARTICLES : ApexDefs.h
  • APEX_VOLUME_RENDER_MATERIALS_NAME_SPACE : ApexNameSpace.h

- c -

  • CALL_CONV : ApexSDK.h , ApexSDKVersionString.h

- d -

  • DYNAMIC_CAST : ApexDefs.h

- p -

  • PX_PHYSICS_VERSION : PhysX0/PhysXSDKVersion.h , PhysX3/PhysXSDKVersion.h
  • PX_PHYSICS_VERSION_BUGFIX : PhysX3/PhysXSDKVersion.h
  • PX_PHYSICS_VERSION_MAJOR : PhysX0/PhysXSDKVersion.h , PhysX3/PhysXSDKVersion.h
  • PX_PHYSICS_VERSION_MINOR : PhysX3/PhysXSDKVersion.h

- r -

  • READ_LOCK : Lock.h
  • RENDER_DEBUG_IFACE : RenderDebugInterface.h
  • RENDER_MESH_AUTHORING_TYPE_NAME : RenderMeshAsset.h

- s -

  • SDK_VERSION_NUMBER : PhysX3/PhysXSDKVersion.h

- w -

  • WRITE_LOCK : Lock.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: File Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • All
  • Typedefs
  • Defines
  • CUgraphicsResource : UserRenderIndexBuffer.h , UserRenderVertexBuffer.h , UserRenderSurfaceBuffer.h , UserRenderSpriteBuffer.h , UserRenderInstanceBuffer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Class Hierarchy

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
  • nvidia::apex::ActorSource
    • nvidia::apex::DestructibleActor
  • NvParameterized::Traits::Allocator
  • nvidia::apex::ApexChunkFlag
  • nvidia::apex::ApexDesc
    • nvidia::apex::ApexSDKDesc
    • nvidia::apex::DestructibleActorJointDesc
    • nvidia::apex::DestructibleAssetCookingDesc
    • nvidia::apex::DestructibleBehaviorGroupDesc
    • nvidia::apex::DestructibleChunkDesc
    • nvidia::apex::DestructibleGeometryDesc
    • nvidia::apex::EmitterLodParamDesc
    • nvidia::apex::RenderMeshActorDesc
    • nvidia::apex::SceneDesc
  • nvidia::apex::ApexMeshParticleRollType
  • nvidia::apex::ApexSDKCachedData
  • nvidia::apex::BSPOpenMode
  • nvidia::apex::ChunkData
  • nvidia::apex::ChunkParticleReportData
  • nvidia::apex::ChunkStateEventData
  • nvidia::apex::ChunkTransformHeader
  • nvidia::apex::ChunkTransformUnit
  • nvidia::apex::ClothingCollisionType
  • nvidia::apex::ClothingConstrainCoefficients
  • nvidia::apex::ClothingMeshSkinningMap
  • nvidia::apex::ClothingPhysicalMeshStats
  • nvidia::apex::ClothingTeleportMode
  • nvidia::apex::ClothingVelocityCallback
  • nvidia::apex::ClothSolverMode
  • nvidia::apex::CollisionDesc
  • nvidia::apex::CollisionVolumeDesc
  • nvidia::apex::ColorRGBA
  • nvidia::apex::Context
    • nvidia::apex::IofxAsset
    • nvidia::apex::Scene
  • NvParameterized::Conversion
  • nvidia::apex::ExplicitHierarchicalMesh::ConvexHull
  • nvidia::apex::ConvexHullMethod
  • nvidia::apex::CudaTestManager
  • nvidia::apex::Curve
  • nvidia::apex::CustomBufferIterator
  • FractureTools::CutoutParameters
  • FractureTools::CutoutSet
  • nvidia::apex::DamageEventCoreData
    • nvidia::apex::ImpactDamageEventData
  • nvidia::apex::DamageEventHeader
  • nvidia::apex::DamageEventReportData
  • nvidia::apex::DamageEventUnit
  • nvidia::apex::DamageSpreadFunction
  • NvParameterized::Definition
  • NvParameterized::Serializer::DeserializedResults< T, bufSize >
  • nvidia::apex::DestructibleActorChunkFlags
  • nvidia::apex::DestructibleActorMeshType
  • nvidia::apex::DestructibleActorRaycastFlags
  • nvidia::apex::DestructibleActorSyncFlags
  • nvidia::apex::DestructibleActorSyncState
  • nvidia::apex::DestructibleAssetStats
  • nvidia::apex::DestructibleCallbackSchedule
  • nvidia::apex::DestructibleChunkEvent
  • nvidia::apex::DestructibleChunkSyncState
  • nvidia::apex::DestructibleDepthParameters
  • nvidia::apex::DestructibleDepthParametersFlag
  • nvidia::apex::DestructibleEmitterType
  • nvidia::apex::DestructibleHitChunk
  • nvidia::apex::DestructibleInitParameters
  • nvidia::apex::DestructibleInitParametersFlag
  • nvidia::apex::DestructibleParameterizedType
  • nvidia::apex::DestructibleParameters
  • nvidia::apex::DestructibleParametersFlag
  • nvidia::apex::DestructiblePhysXActorQueryFlags
  • nvidia::apex::DestructibleRTFractureParameters
  • nvidia::apex::DisplacementMapVolume
  • nvidia::apex::EmitterGeomExplicit::EllipsoidParams
  • nvidia::apex::ExplicitHierarchicalMesh::Embedding
  • nvidia::apex::EmitterGeom
    • nvidia::apex::EmitterGeomBox
    • nvidia::apex::EmitterGeomCylinder
    • nvidia::apex::EmitterGeomExplicit
    • nvidia::apex::EmitterGeomSphere
    • nvidia::apex::EmitterGeomSphereShell
  • nvidia::apex::EmitterType
  • nvidia::apex::EmitterActor::EmitterValidateCallback
  • nvidia::apex::ExplicitHierarchicalMesh
  • nvidia::apex::ExplicitRenderTriangle
  • nvidia::apex::ExplicitSubmeshData
  • nvidia::apex::ExplicitVertexFormat
  • NvParameterized::Factory
  • nvidia::apex::FieldSamplerWeightedCollisionFilterCallback
  • nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
  • FractureTools::FractureCutoutDesc
  • nvidia::apex::FractureEventHeader
  • nvidia::apex::FractureEventUnit
  • nvidia::apex::DestructibleRTFractureParameters::FractureGlass
  • nvidia::apex::FractureMaterialDesc
  • nvidia::apex::FractureMethod
  • FractureTools::FractureSliceDesc
  • nvidia::apex::FractureToolsAPI
  • FractureTools::FractureVoronoiDesc
  • nvidia::apex::GroupsFilterOp
  • nvidia::apex::GroupsMask64
  • NvParameterized::Handle
  • NvParameterized::Hint
  • nvidia::apex::RenderMeshAssetAuthoring::IndexType
  • NvParameterized::Interface
  • nvidia::apex::IofxCommonRenderData
    • nvidia::apex::IofxMeshRenderData
    • nvidia::apex::IofxSpriteRenderData
  • nvidia::apex::IofxMeshRenderLayout
  • nvidia::apex::IofxMeshRenderLayoutElement
  • nvidia::apex::IofxRenderSemantic
  • nvidia::apex::IofxSharedRenderData
    • nvidia::apex::IofxMeshSharedRenderData
    • nvidia::apex::IofxSpriteSharedRenderData
  • nvidia::apex::IofxSpriteRenderLayout
  • nvidia::apex::IofxSpriteRenderLayoutElement
  • nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
  • nvidia::apex::IProgressListener
  • nvidia::apex::UserRenderSurface::MappedInfo
  • nvidia::apex::MaterialFrame
  • nvidia::apex::MaterialLookupCallback
  • nvidia::apex::MaterialLookupCallback::MaterialRequest
  • nvidia::apex::RenderMeshAssetAuthoring::MeshDesc
  • FractureTools::MeshProcessingParameters
  • NvParameterized::Serializer::MetadataEntry
  • nvidia::apex::MirrorScene::MirrorFilter
  • nvidia::apex::MirrorScene
  • nvidia::apex::Modifier
    • nvidia::apex::ModifierT< ColorVsDensityModifier >
      • nvidia::apex::ColorVsDensityModifier
    • nvidia::apex::ModifierT< ColorVsLifeModifier >
      • nvidia::apex::ColorVsLifeModifier
    • nvidia::apex::ModifierT< ColorVsVelocityModifier >
      • nvidia::apex::ColorVsVelocityModifier
    • nvidia::apex::ModifierT< OrientAlongVelocityModifier >
      • nvidia::apex::OrientAlongVelocityModifier
    • nvidia::apex::ModifierT< OrientScaleAlongScreenVelocityModifier >
      • nvidia::apex::OrientScaleAlongScreenVelocityModifier
    • nvidia::apex::ModifierT< RandomRotationModifier >
      • nvidia::apex::RandomRotationModifier
    • nvidia::apex::ModifierT< RandomScaleModifier >
      • nvidia::apex::RandomScaleModifier
    • nvidia::apex::ModifierT< RandomSubtextureModifier >
      • nvidia::apex::RandomSubtextureModifier
    • nvidia::apex::ModifierT< RotationModifier >
      • nvidia::apex::RotationModifier
    • nvidia::apex::ModifierT< RotationRateModifier >
      • nvidia::apex::RotationRateModifier
    • nvidia::apex::ModifierT< RotationRateVsLifeModifier >
      • nvidia::apex::RotationRateVsLifeModifier
    • nvidia::apex::ModifierT< ScaleAlongVelocityModifier >
      • nvidia::apex::ScaleAlongVelocityModifier
    • nvidia::apex::ModifierT< ScaleByMassModifier >
      • nvidia::apex::ScaleByMassModifier
    • nvidia::apex::ModifierT< ScaleVsCameraDistanceModifier >
      • nvidia::apex::ScaleVsCameraDistanceModifier
    • nvidia::apex::ModifierT< ScaleVsDensityModifier >
      • nvidia::apex::ScaleVsDensityModifier
    • nvidia::apex::ModifierT< ScaleVsLifeModifier >
      • nvidia::apex::ScaleVsLifeModifier
    • nvidia::apex::ModifierT< SimpleScaleModifier >
      • nvidia::apex::SimpleScaleModifier
    • nvidia::apex::ModifierT< SubtextureVsLifeModifier >
      • nvidia::apex::SubtextureVsLifeModifier
    • nvidia::apex::ModifierT< ViewDirectionSortingModifier >
      • nvidia::apex::ViewDirectionSortingModifier
    • nvidia::apex::ModifierT< T >
  • nvidia::apex::ModuleCachedData
  • nvidia::apex::ModuleDestructibleConst
  • nvidia::apex::ModuleSpecificRenderBufferData
    • nvidia::apex::RenderSpriteBufferData
    • nvidia::apex::RenderVertexBufferData
  • NvParameterized::NamedReferenceInterface
  • FractureTools::NoiseParameters
  • nvidia::apex::oaValueStruct
  • NvParameterized::ParameterFind
  • NvParameterized::ParameterList
  • NvParameterized::ParamResult
  • nvidia::apex::PhysX3DescTemplate
  • nvidia::apex::PhysX3Interface
  • nvidia::apex::PhysXObjectDesc
  • nvidia::apex::PhysXRenderBuffer
  • nvidia::apex::EmitterGeomExplicit::PointListData
  • nvidia::apex::EmitterGeomExplicit::PointParams
  • nvidia::apex::RenderMeshAssetAuthoring::Primitive
  • nvidia::apex::ProjMatrixType
  • nvidia::apex::PxStreamFromFileBuf
  • nvidia::apex::Range< T >
  • nvidia::apex::ReadLock
  • NvParameterized::ReferenceInterface
    • NvParameterized::WrappedNamedReference
  • nvidia::apex::RenderBoneSemantic
  • nvidia::apex::RenderBufferData< SemanticClass, SemanticEnum >
  • nvidia::apex::RenderBufferData< RenderBoneSemantic, RenderBoneSemantic::Enum >
    • nvidia::apex::RenderBoneBufferData
  • nvidia::apex::RenderBufferData< RenderInstanceSemantic, RenderInstanceSemantic::Enum >
    • nvidia::apex::RenderInstanceBufferData
  • nvidia::apex::RenderBufferData< RenderSpriteSemantic, RenderSpriteSemantic::Enum >
    • nvidia::apex::RenderSpriteBufferData
  • nvidia::apex::RenderBufferData< RenderVertexSemantic, RenderVertexSemantic::Enum >
    • nvidia::apex::RenderMeshAssetAuthoring::VertexBuffer
    • nvidia::apex::RenderVertexBufferData
  • nvidia::apex::RenderBufferHint
  • nvidia::apex::RenderContext
  • nvidia::apex::RenderCullMode
  • nvidia::apex::RenderDataAccess
  • nvidia::apex::RenderDataFormat
  • nvidia::apex::RenderDataProvider
    • nvidia::apex::Renderable
      • nvidia::apex::AssetPreview
        • nvidia::apex::AttractorFSPreview
        • nvidia::apex::ClothingPreview
        • nvidia::apex::DestructiblePreview
        • nvidia::apex::EmitterPreview
        • nvidia::apex::FlameEmitterPreview
        • nvidia::apex::ForceFieldPreview
        • nvidia::apex::GroundEmitterPreview
        • nvidia::apex::HeatSourcePreview
        • nvidia::apex::ImpactEmitterPreview
        • nvidia::apex::JetFSPreview
        • nvidia::apex::NoiseFSPreview
        • nvidia::apex::ParticlesPreview
        • nvidia::apex::TurbulenceFSPreview
        • nvidia::apex::VelocitySourcePreview
        • nvidia::apex::VortexFSPreview
        • nvidia::apex::WindFSPreview
      • nvidia::apex::AttractorFSActor
      • nvidia::apex::ClothingActor
      • nvidia::apex::ClothingRenderProxy
      • nvidia::apex::DestructibleActor
      • nvidia::apex::DestructibleRenderable
      • nvidia::apex::JetFSActor
      • nvidia::apex::NoiseFSActor
      • nvidia::apex::RenderDebugInterface
      • nvidia::apex::RenderMeshActor
      • nvidia::apex::Scene
      • nvidia::apex::TurbulenceFSActor
      • nvidia::apex::VortexFSActor
      • nvidia::apex::WindFSActor
  • nvidia::apex::RenderInstanceLayoutElement
  • nvidia::apex::RenderInstanceSemantic
  • nvidia::apex::RenderInteropFlags
  • nvidia::apex::RenderLockMode
  • nvidia::apex::RenderMapType
  • nvidia::apex::RenderMeshActorRaycastFlags
  • nvidia::apex::RenderMeshActorRaycastHitData
  • nvidia::apex::RenderMeshAssetInstanceMode
  • nvidia::apex::RenderMeshAssetStats
  • nvidia::apex::RenderMeshPartData
  • nvidia::apex::RenderPrimitiveType
  • nvidia::apex::RenderSemanticData
  • nvidia::apex::RenderSpriteLayoutElement
  • nvidia::apex::RenderSpriteSemantic
  • nvidia::apex::RenderSpriteTextureLayout
  • nvidia::apex::RenderSubmesh
  • nvidia::apex::RenderSurfaceBufferData
  • nvidia::apex::RenderVertexSemantic
  • nvidia::apex::ResourceCallback
  • nvidia::apex::ResourceProvider
  • nvidia::apex::RWLockable
    • nvidia::apex::ApexInterface
      • nvidia::apex::Actor
        • nvidia::apex::AttractorFSActor
        • nvidia::apex::BasicIosActor
        • nvidia::apex::ClothingActor
        • nvidia::apex::DestructibleActor
        • nvidia::apex::EffectPackageActor
        • nvidia::apex::EmitterActor
        • nvidia::apex::FlameEmitterActor
        • nvidia::apex::ForceFieldActor
        • nvidia::apex::GroundEmitterActor
        • nvidia::apex::HeatSourceActor
        • nvidia::apex::ImpactEmitterActor
        • nvidia::apex::IofxActor
        • nvidia::apex::JetFSActor
        • nvidia::apex::NoiseFSActor
        • nvidia::apex::ParticleIosActor
        • nvidia::apex::RenderMeshActor
        • nvidia::apex::SubstanceSourceActor
        • nvidia::apex::TurbulenceFSActor
        • nvidia::apex::VelocitySourceActor
        • nvidia::apex::VortexFSActor
        • nvidia::apex::WindFSActor
      • nvidia::apex::ApexSDK
      • nvidia::apex::Asset
        • nvidia::apex::BasicFSAsset
        • nvidia::apex::ClothingAsset
        • nvidia::apex::DestructibleAsset
        • nvidia::apex::EffectPackageAsset
        • nvidia::apex::EmitterAsset
        • nvidia::apex::FlameEmitterAsset
        • nvidia::apex::ForceFieldAsset
        • nvidia::apex::GroundEmitterAsset
        • nvidia::apex::HeatSourceAsset
        • nvidia::apex::ImpactEmitterAsset
        • nvidia::apex::IofxAsset
        • nvidia::apex::IosAsset
          • nvidia::apex::BasicIosAsset
          • nvidia::apex::ParticleIosAsset
        • nvidia::apex::RenderMeshAsset
        • nvidia::apex::SubstanceSourceAsset
        • nvidia::apex::TurbulenceFSAsset
        • nvidia::apex::VelocitySourceAsset
      • nvidia::apex::AssetAuthoring
        • nvidia::apex::BasicFSAssetAuthoring
        • nvidia::apex::BasicIosAssetAuthoring
        • nvidia::apex::ClothingAssetAuthoring
        • nvidia::apex::DestructibleAssetAuthoring
        • nvidia::apex::EffectPackageAssetAuthoring
        • nvidia::apex::EmitterAssetAuthoring
        • nvidia::apex::FlameEmitterAssetAuthoring
        • nvidia::apex::ForceFieldAssetAuthoring
        • nvidia::apex::GroundEmitterAssetAuthoring
        • nvidia::apex::HeatSourceAssetAuthoring
        • nvidia::apex::ImpactEmitterAssetAuthoring
        • nvidia::apex::IofxAssetAuthoring
        • nvidia::apex::ParticleIosAssetAuthoring
        • nvidia::apex::RenderMeshAssetAuthoring
        • nvidia::apex::SubstanceSourceAssetAuthoring
        • nvidia::apex::TurbulenceFSAssetAuthoring
        • nvidia::apex::VelocitySourceAssetAuthoring
      • nvidia::apex::AssetPreview
      • nvidia::apex::AssetPreviewScene
      • nvidia::apex::ClothingCollision
        • nvidia::apex::ClothingCapsule
        • nvidia::apex::ClothingConvex
        • nvidia::apex::ClothingPlane
        • nvidia::apex::ClothingSphere
        • nvidia::apex::ClothingTriangleMesh
      • nvidia::apex::ClothingPhysicalMesh
      • nvidia::apex::ClothingRenderProxy
      • nvidia::apex::DestructibleActorJoint
      • nvidia::apex::DestructibleRenderable
      • nvidia::apex::IofxRenderable
      • nvidia::apex::IofxRenderableIterator
      • nvidia::apex::Module
        • nvidia::apex::ModuleBasicFS
        • nvidia::apex::ModuleBasicIos
        • nvidia::apex::ModuleClothing
        • nvidia::apex::ModuleDestructible
        • nvidia::apex::ModuleEmitter
        • nvidia::apex::ModuleFieldSampler
        • nvidia::apex::ModuleForceField
        • nvidia::apex::ModuleIofx
        • nvidia::apex::ModuleIofxLegacy
        • nvidia::apex::ModuleLoader
        • nvidia::apex::ModuleParticleIos
        • nvidia::apex::ModuleParticles
        • nvidia::apex::ModuleTurbulenceFS
      • nvidia::apex::RenderableIterator
      • nvidia::apex::RenderDebugInterface
      • nvidia::apex::RenderVolume
      • nvidia::apex::Scene
      • nvidia::apex::TurbulenceRenderable
  • nvidia::apex::SceneStats
  • nvidia::apex::ScopedPhysXLockRead
  • nvidia::apex::ScopedPhysXLockWrite
  • NvParameterized::SerializationCallback
  • NvParameterized::SerializePlatform
  • NvParameterized::Serializer
  • nvidia::apex::Shape
    • nvidia::apex::BoxShape
    • nvidia::apex::CapsuleShape
    • nvidia::apex::HalfSpaceShape
    • nvidia::apex::SphereShape
  • FractureTools::SliceParameters
  • nvidia::apex::EmitterGeomExplicit::SphereParams
  • nvidia::apex::StatDataType
  • nvidia::apex::StatsInfo
  • nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc
  • nvidia::apex::TestBase
  • nvidia::apex::TestFunctionInterface
  • nvidia::apex::TextureUVOrigin
  • NvParameterized::Traits
  • nvidia::apex::TurbulenceDensityFormat
  • nvidia::apex::TurbulenceFieldType
  • nvidia::apex::TurbulenceFlameFormat
  • nvidia::apex::TurbulenceRenderData
  • nvidia::apex::TurbulenceRenderLayout
  • nvidia::apex::TurbulenceVelocityFormat
  • nvidia::apex::UserBoundingBoxFlags
  • nvidia::apex::UserChunkParticleReport
  • nvidia::apex::UserChunkReport
  • nvidia::apex::UserDestructiblePhysXActorReport
  • nvidia::apex::UserDestructibleSyncHandler< DestructibleSyncHeader >
  • nvidia::apex::UserImpactDamageReport
  • nvidia::apex::UserOpaqueMesh
  • nvidia::apex::UserOpaqueMeshDesc
  • nvidia::apex::UserRenderBoneBuffer
  • nvidia::apex::UserRenderBoneBufferDesc
  • nvidia::apex::UserRenderCallback
    • nvidia::apex::IofxRenderCallback
    • nvidia::apex::TurbulenceRenderCallback
  • nvidia::apex::UserRenderData
  • nvidia::apex::UserRenderDataHolder
    • nvidia::apex::UserRenderBufferDesc
    • nvidia::apex::UserRenderSurfaceDesc
  • nvidia::apex::UserRenderer
  • nvidia::apex::UserRenderIndexBuffer
  • nvidia::apex::UserRenderIndexBufferDesc
  • nvidia::apex::UserRenderInstanceBuffer
  • nvidia::apex::UserRenderInstanceBufferDesc
  • nvidia::apex::UserRenderResource
  • nvidia::apex::UserRenderResourceDesc
  • nvidia::apex::UserRenderResourceManager
  • nvidia::apex::UserRenderSpriteBuffer
  • nvidia::apex::UserRenderSpriteBufferDesc
  • nvidia::apex::UserRenderSpriteTextureDesc
  • nvidia::apex::UserRenderStorage
    • nvidia::apex::UserRenderBuffer
    • nvidia::apex::UserRenderSurface
  • nvidia::apex::UserRenderSurfaceBuffer
  • nvidia::apex::UserRenderSurfaceBufferDesc
  • nvidia::apex::UserRenderVertexBuffer
  • nvidia::apex::UserRenderVertexBufferDesc
  • nvidia::apex::Vec2T< T >
  • nvidia::apex::Vertex
  • nvidia::apex::VertexBuffer
  • nvidia::apex::VertexColor
  • nvidia::apex::VertexFormat
  • nvidia::apex::VertexUV
  • nvidia::apex::ViewMatrixType
  • nvidia::apex::WriteLock
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: APEX Clothing API Documentation

  • Related Pages
  • Namespaces
  • Classes
  • Files
APEX Clothing API Documentation

Overview

This document contains a full API documentation for all public classes.

Generated on Sat Dec 1 2018 10:18:28


APEX Framework: NvParameterized Namespace Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
NvParameterized Namespace Reference

NvParameterized namespace. More...

Classes

class | Hint
Provides hints about the parameter definition. More...
class | Definition
Provides information about a parameter. More...
class | Handle
Provides access to individual parameters within the NvParameterized object. More...
class | SerializationCallback
A callback class for notification just prior to serialization. More...
class | Interface
Represents the interface to the NvParameterized object. More...
class | Factory
Interface class for NvParameterized factories. More...
class | Conversion
Interface class for legacy object conversions. More...
class | Traits
Interface class for user traits. More...
struct | ParamResult
Container for results of getParamList. More...
class | NamedReferenceInterface
Callback container for getNamedReferences. More...
class | ReferenceInterface
Callback container for getReferences. More...
struct | ParameterFind
Finds parameter in NvParameterized. More...
struct | ParameterList
Parameter list. More...
class | WrappedNamedReference
WrappedNamedReference. More...
struct | SerializePlatform
Platform descriptor. More...
class | Serializer
Interface class for serializer-deserializer of NvParameterized objects. More...

Enumerations

enum ErrorType {
ERROR_NONE = 0,
ERROR_TYPE_NOT_SUPPORTED,
ERROR_INDEX_OUT_OF_RANGE,
ERROR_INVALID_PARAMETER_NAME,
ERROR_INVALID_PARAMETER_HANDLE,
ERROR_CAST_FAILED,
ERROR_INVALID_ENUM_VAL,
ERROR_SYNTAX_ERROR_IN_NAME,
ERROR_IS_LEAF_NODE,
ERROR_RESULT_BUFFER_OVERFLOW,
ERROR_NAME_DOES_NOT_MATCH_DEFINITION,
ERROR_NOT_AN_ARRAY,
ERROR_ARRAY_SIZE_IS_FIXED,
ERROR_ARRAY_RESIZING_IS_NOT_SUPPORTED,
ERROR_ARRAY_IS_TOO_SMALL,
ERROR_INVALID_ARRAY_DIMENSION,
ERROR_INVALID_ARRAY_SIZE,
ERROR_PARAMETER_HANDLE_DOES_NOT_MATCH_CLASS,
ERROR_MEMORY_ALLOCATION_FAILURE,
ERROR_INVALID_REFERENCE_INCLUDE_HINT,
ERROR_INVALID_REFERENCE_VALUE,
ERROR_PARAMETER_HANDLE_NOT_INITIALIZED,
ERROR_PARAMETER_DEFINITIONS_DO_NOT_MATCH,
ERROR_HANDLE_MISSING_INTERFACE_POINTER,
ERROR_HANDLE_INVALID_INTERFACE_POINTER,
ERROR_INVALID_CALL_ON_NAMED_REFERENCE,
ERROR_NOT_IMPLEMENTED,
ERROR_OBJECT_CONSTRUCTION_FAILED,
ERROR_MODIFY_CONST_HANDLE
}
Various errors that may be returned from NvParameterized calls.
enum DataType {
TYPE_UNDEFINED = 0,
TYPE_ARRAY = 1,
TYPE_STRUCT = 2,
TYPE_BOOL = 3,
TYPE_STRING = 4,
TYPE_ENUM = 5,
TYPE_REF = 6,
TYPE_I8 = 7,
TYPE_I16 = 8,
TYPE_I32 = 9,
TYPE_I64 = 10,
TYPE_U8 = 11,
TYPE_U16 = 12,
TYPE_U32 = 13,
TYPE_U64 = 14,
TYPE_F32 = 15,
TYPE_F64 = 16,
TYPE_VEC2 = 17,
TYPE_VEC3 = 18,
TYPE_VEC4 = 19,
TYPE_QUAT = 20,
TYPE_MAT33 = 21,
TYPE_BOUNDS3 = 23,
TYPE_MAT44 = 24,
TYPE_POINTER = 25,
TYPE_TRANSFORM = 26,
TYPE_MAT34 = 27,
TYPE_LAST
}
These types are supported in NvParameterized schemas. More...
enum TokenizerResultType {
TOKENIZER_RESULT_NONE,
TOKENIZER_RESULT_BUFFER_OVERFLOW,
TOKENIZER_RESULT_SYNTAX_ERROR,
TOKENIZER_RESULT_STRUCT_MEMBER,
TOKENIZER_RESULT_ARRAY_INDEX
}
Enum of tokenizer result types.

Functions

PX_INLINE TokenizerResultType | getStructMemberToken (const char *long_name, char *token, uint32_t max_token_len, uint32_t &offset)
Get struct member token.
PX_INLINE TokenizerResultType | getArrayMemberToken (const char *long_name, char *token, uint32_t max_token_len, uint32_t &offset)
Get array member token.
PX_INLINE TokenizerResultType | getNextToken (const char *long_name, char *token, uint32_t max_token_len, uint32_t &offset)
Get next token.
PX_INLINE int | local_strcat_s (char *dest, size_t size, const char *src)
The local_strcat_s function appends strSource to strDestination and terminates the resulting string with a null character.
int32_t | local_sprintf_s (char *_DstBuf, size_t _DstSize, const char *_Format,...)
The local_sprintf_s function wraps the va_list functionality required for PxVxprintf.
PX_INLINE const Interface * | findParam (const Interface &i, const char *longName, Handle &outHandle)
Recursively finds a parameter with the given name.
PX_INLINE Interface * | findParam (Interface &i, const char *longName, Handle &outHandle)
Recursively finds a parameter with the given name.
PX_INLINE const ParamResult * | getParamList (const Interface &i, const char *className, const char *paramName, uint32_t &count, bool recursive, bool classesOnly, NvParameterized::Traits *traits)
A helper method to retrieve the list of all parameters relative to an interface.
PX_INLINE void | releaseParamList (uint32_t resultCount, const ParamResult *results, NvParameterized::Traits *traits)
helper function to free the parameter list returned from getParamList
PX_INLINE bool | getParamArraySize (const Interface &pm, const char *name, int32_t &arraySize)
helper function to get an NvParameterized array size
PX_INLINE bool | resizeParamArray (Interface &pm, const char *name, int32_t newSize)
helper function to resize an NvParameterized array
PX_INLINE uint32_t | getNamedReferences (const Interface &i, NamedReferenceInterface &namedReference, bool recursive)
Calls back for every non-included named reference.
PX_INLINE void | getReferences (const Interface &iface, ReferenceInterface &cb, bool named, bool included, bool recursive)
Calls back for every reference (named or included or both).
PX_INLINE bool | getParamBool (const Interface &pm, const char *name, bool &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamBool (Interface &pm, const char *name, bool val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamString (const Interface &pm, const char *name, const char *&val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamString (Interface &pm, const char *name, const char *val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamEnum (const Interface &pm, const char *name, const char *&val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamEnum (Interface &pm, const char *name, const char *val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamRef (const Interface &pm, const char *name, NvParameterized::Interface *&val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamRef (Interface &pm, const char *name, NvParameterized::Interface *val, bool doDestroyOld=false)
helper function to set an NvParameterized value
PX_INLINE bool | initParamRef (Interface &pm, const char *name, const char *className, bool doDestroyOld=false)
helper function to init an NvParameterized value
PX_INLINE bool | initParamRef (Interface &pm, const char *name, const char *className, const char *objName, bool doDestroyOld=false)
helper function to init an NvParameterized value
PX_INLINE bool | getParamI8 (const Interface &pm, const char *name, int8_t &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamI8 (Interface &pm, const char *name, int8_t val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamI16 (const Interface &pm, const char *name, int16_t &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamI16 (Interface &pm, const char *name, int16_t val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamI32 (const Interface &pm, const char *name, int32_t &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamI32 (Interface &pm, const char *name, int32_t val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamI64 (const Interface &pm, const char *name, int64_t &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamI64 (Interface &pm, const char *name, int64_t val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamU8 (const Interface &pm, const char *name, uint8_t &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamU8 (Interface &pm, const char *name, uint8_t val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamU16 (const Interface &pm, const char *name, uint16_t &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamU16 (Interface &pm, const char *name, uint16_t val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamU32 (const Interface &pm, const char *name, uint32_t &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamU32 (Interface &pm, const char *name, uint32_t val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamU64 (const Interface &pm, const char *name, uint64_t &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamU64 (Interface &pm, const char *name, uint64_t val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamF32 (const Interface &pm, const char *name, float &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamF32 (Interface &pm, const char *name, float val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamF64 (const Interface &pm, const char *name, double &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamF64 (Interface &pm, const char *name, double val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamVec2 (const Interface &pm, const char *name, physx::PxVec2 &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamVec2 (Interface &pm, const char *name, const physx::PxVec2 &val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamVec3 (const Interface &pm, const char *name, physx::PxVec3 &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamVec3 (Interface &pm, const char *name, const physx::PxVec3 &val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamVec4 (const Interface &pm, const char *name, physx::PxVec4 &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamVec4 (Interface &pm, const char *name, const physx::PxVec4 &val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamQuat (const Interface &pm, const char *name, physx::PxQuat &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamQuat (Interface &pm, const char *name, const physx::PxQuat &val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamMat33 (const Interface &pm, const char *name, physx::PxMat33 &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamMat33 (Interface &pm, const char *name, const physx::PxMat33 &val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamMat44 (const Interface &pm, const char *name, physx::PxMat44 &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamMat44 (Interface &pm, const char *name, const physx::PxMat44 &val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamBounds3 (const Interface &pm, const char *name, physx::PxBounds3 &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamBounds3 (Interface &pm, const char *name, const physx::PxBounds3 &val)
helper function to set an NvParameterized value
PX_INLINE bool | getParamTransform (const Interface &pm, const char *name, physx::PxTransform &val)
helper function to get an NvParameterized value
PX_INLINE bool | setParamTransform (Interface &pm, const char *name, const physx::PxTransform &val)
helper function to set an NvParameterized value
int32_t | local_strcmp (const char *s1, const char *s2)
local_strcmp
int32_t | local_stricmp (const char *s1, const char *s2)
local_stricmp
PX_INLINE void | findParameter (const NvParameterized::Interface &obj, Handle &handle, ParameterFind &pf, bool fromArray=false)
findParameter
PX_INLINE void | listParameters (const NvParameterized::Interface &obj, Handle &handle, ParameterList &pf, int32_t parentArraySize)
listParameters
PX_INLINE void | getReferences (const Interface &iface, Handle &handle, ReferenceInterface &cb, bool named, bool included, bool recursive)
Calls back for every reference.
PX_INLINE bool | DoCompilerVersMatch (SerializePlatform::CompilerType t, uint32_t v1, uint32_t v2)
Serializer::SerializePlatform and Serializer::DeserializedData inline implementation.
PX_INLINE bool | DoOsVersMatch (SerializePlatform::OsType t, uint32_t v1, uint32_t v2)
Check binary compatibility of OS versions.

Detailed Description

NvParameterized namespace.

NvParameterized inline implementation.

Enumeration Type Documentation

enum NvParameterized::DataType

These types are supported in NvParameterized schemas.

Warning:
Do not change values of enums!
Enumerator:
TYPE_ARRAY

Array type, size may be static or dynamic.

See also:
Definition::arraySizeIsFixed(), Handle::resizeArray(), Handle::getArraySize()
TYPE_STRING

String type, represented by a const char pointer.

See also:
Handle::getParamString(), Handle::setParamString()
TYPE_ENUM

Enum type, represented by a const char pointer.

See also:
Definition::numEnumVals(), Definition::enumVal(), Handle::getParamEnum(), Handle::setParamEnum()
TYPE_REF

Reference type, may be a named or included reference.

References are intended to be used in instances where a class needs either a named reference (an emitter asset references an IOFX and IOS asset), or an included reference (a destructible asset that serializes an APEX render mesh). References may also used to create a unions within a class. Each reference will contain one or more variants to allow for unions.

See also:
Handle::initParamRef(), Definition::numRefVariants(), Definition::refVariantVal(), Handle::initParamRef(), Handle::getParamRef(), Handle::setParamRef()

Function Documentation

PX_INLINE bool NvParameterized::DoCompilerVersMatch | ( | SerializePlatform::CompilerType | t,
 |  | uint32_t | v1,
 |  | uint32_t | v2
 | ) |  |

Serializer::SerializePlatform and Serializer::DeserializedData inline implementation.

Check binary compatibility of compiler versions

PX_INLINE const Interface * NvParameterized::findParam | ( | const Interface & | i,
 |  | const char * | longName,
 |  | Handle & | outHandle
 | ) |  |

Recursively finds a parameter with the given name.

This method will recursively search through not only this parameterized but all referenced parameterized objects as well. It sets the handle and returns the NvParameterized::Interface in which the name was found.

Parameters:
i | the parameterized object that will be searched
longName | contains the name of the parameter to be found the longName will work with arrays, structs, and included references
outHandle | will contain the output handle that provides read-only access to the specified parameter
Returns:
the NvParameterized::Interface pointer in which the parameter is contained (this could be different than the top level NvParameterized::Interface if the parameter is contained in an included reference)
PX_INLINE Interface * NvParameterized::findParam | ( | Interface & | i,
 |  | const char * | longName,
 |  | Handle & | outHandle
 | ) |  |

Recursively finds a parameter with the given name.

This method will recursively search through not only this parameterized but all referenced parameterized objects as well. It sets the handle and returns the NvParameterized::Interface in which the name was found.

Parameters:
i | the parameterized object that will be searched
longName | contains the name of the parameter to be found the longName will work with arrays, structs, and included references
outHandle | will contain the output handle that provides read-write access to the specified parameter
Returns:
the NvParameterized::Interface pointer in which the parameter is contained (this could be different than the top level NvParameterized::Interface if the parameter is contained in an included reference)
PX_INLINE const ParamResult * NvParameterized::getParamList | ( | const Interface & | i,
 |  | const char * | className,
 |  | const char * | paramName,
 |  | uint32_t & | count,
 |  | bool | recursive,
 |  | bool | classesOnly,
 |  | NvParameterized::Traits * | traits
 | ) |  |

A helper method to retrieve the list of all parameters relative to an interface.

Gets every parameter in an NvParameterized Interface class.

Parameters:
[in] | i | the input interface
[in] | className | is an optional class name to match to. If this is null, it will return all parameters.
[in] | paramName | is an optional parameter name to match to. If this is null, it will return all parameters.
[out] | count | the number of parameters found
[in] | recursive | if true the search will recurse into every included reference, not just the top parameterized class
[in] | classesOnly | if true the search will only match against class names
[in] | traits | typically the APEX traits class, used to allocate the ParamResult, see ApexSDK::getParameterizedTraits()
Note:
The return pointer is allocated by the NvParameterized Traits class and should be freed by calling releaseParamList()
The return pointer is allocated by the NvParameterized Traits class and should be freed by calling releaseParamList
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Namespace Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all documented namespace members with links to the namespaces they belong to:

- a -

  • APEX_CE_CREATE_NO_ALLOWED : nvidia::apex
  • APEX_CE_DESCRIPTOR_INVALID : nvidia::apex
  • APEX_CE_NO_ERROR : nvidia::apex
  • APEX_CE_NOT_FOUND : nvidia::apex
  • APEX_CE_WRONG_VERSION : nvidia::apex
  • ApexCreateError : nvidia::apex
  • ApexSDKVersionString : nvidia::apex
  • AuthObjTypeID : nvidia::apex
  • AUTHOR : nvidia::apex

- b -

  • BRANCH : nvidia::apex
  • BUILD_TIME : nvidia::apex

- c -

  • CHANGELIST : nvidia::apex
  • ColorChannel : nvidia::apex
  • CreateApexSDK() : nvidia::apex
  • CreateCudaContextManager() : nvidia::apex

- d -

  • DataType : NvParameterized
  • DoCompilerVersMatch() : NvParameterized
  • DoOsVersMatch() : NvParameterized

- e -

  • EffectType : nvidia::apex
  • ErrorType : NvParameterized

- f -

  • findParam() : NvParameterized
  • findParameter() : NvParameterized

- g -

  • GetApexSDK() : nvidia::apex
  • GetApexSDKVersionString() : nvidia::apex
  • getArrayMemberToken() : NvParameterized
  • getNamedReferences() : NvParameterized
  • getNextToken() : NvParameterized
  • getParamArraySize() : NvParameterized
  • getParamBool() : NvParameterized
  • getParamBounds3() : NvParameterized
  • getParamEnum() : NvParameterized
  • getParamF32() : NvParameterized
  • getParamF64() : NvParameterized
  • getParamI16() : NvParameterized
  • getParamI32() : NvParameterized
  • getParamI64() : NvParameterized
  • getParamI8() : NvParameterized
  • getParamList() : NvParameterized
  • getParamMat33() : NvParameterized
  • getParamMat44() : NvParameterized
  • getParamQuat() : NvParameterized
  • getParamRef() : NvParameterized
  • getParamString() : NvParameterized
  • getParamTransform() : NvParameterized
  • getParamU16() : NvParameterized
  • getParamU32() : NvParameterized
  • getParamU64() : NvParameterized
  • getParamU8() : NvParameterized
  • getParamVec2() : NvParameterized
  • getParamVec3() : NvParameterized
  • getParamVec4() : NvParameterized
  • getReferences() : NvParameterized
  • getStructMemberToken() : NvParameterized
  • GetSuggestedCudaDeviceOrdinal() : nvidia::apex

- i -

  • initParamRef() : NvParameterized
  • instantiateModuleClothing() : nvidia::apex
  • instantiateModuleDestructible() : nvidia::apex
  • instantiateModuleLegacy() : nvidia::apex
  • instantiateModuleLoader() : nvidia::apex
  • instantiateModuleParticles() : nvidia::apex
  • instantiateModuleTurbulenceFS() : nvidia::apex

- l -

  • listParameters() : NvParameterized
  • local_sprintf_s() : NvParameterized
  • local_strcat_s() : NvParameterized
  • local_strcmp() : NvParameterized
  • local_stricmp() : NvParameterized

- m -

  • ModifierStage : nvidia::apex
  • ModifierStage_Continuous : nvidia::apex
  • ModifierStage_Spawn : nvidia::apex
  • ModifierTypeEnum : nvidia::apex
  • ModifierUsage : nvidia::apex
  • ModifierUsageFromStage() : nvidia::apex

- p -

  • PlatformTag : nvidia::apex

- r -

  • REASON : nvidia::apex
  • releaseParamList() : NvParameterized
  • resizeParamArray() : NvParameterized

- s -

  • ScaleAxis : nvidia::apex
  • setParamBool() : NvParameterized
  • setParamBounds3() : NvParameterized
  • setParamEnum() : NvParameterized
  • setParamF32() : NvParameterized
  • setParamF64() : NvParameterized
  • setParamI16() : NvParameterized
  • setParamI32() : NvParameterized
  • setParamI64() : NvParameterized
  • setParamI8() : NvParameterized
  • setParamMat33() : NvParameterized
  • setParamMat44() : NvParameterized
  • setParamQuat() : NvParameterized
  • setParamRef() : NvParameterized
  • setParamString() : NvParameterized
  • setParamTransform() : NvParameterized
  • setParamU16() : NvParameterized
  • setParamU32() : NvParameterized
  • setParamU64() : NvParameterized
  • setParamU8() : NvParameterized
  • setParamVec2() : NvParameterized
  • setParamVec3() : NvParameterized
  • setParamVec4() : NvParameterized
  • StatValue : nvidia::apex

- t -

  • TokenizerResultType : NvParameterized
  • TOOLS_CHANGELIST : nvidia::apex
  • TYPE_ARRAY : NvParameterized
  • TYPE_ENUM : NvParameterized
  • TYPE_REF : NvParameterized
  • TYPE_STRING : NvParameterized

- v -

  • Vec2R : nvidia::apex
  • VERSION : nvidia::apex
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Namespace Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • ApexCreateError : nvidia::apex
  • ApexSDKVersionString : nvidia::apex
  • ColorChannel : nvidia::apex
  • DataType : NvParameterized
  • EffectType : nvidia::apex
  • ErrorType : NvParameterized
  • ModifierStage : nvidia::apex
  • ModifierTypeEnum : nvidia::apex
  • ModifierUsage : nvidia::apex
  • ScaleAxis : nvidia::apex
  • TokenizerResultType : NvParameterized
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Namespace Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • APEX_CE_CREATE_NO_ALLOWED : nvidia::apex
  • APEX_CE_DESCRIPTOR_INVALID : nvidia::apex
  • APEX_CE_NO_ERROR : nvidia::apex
  • APEX_CE_NOT_FOUND : nvidia::apex
  • APEX_CE_WRONG_VERSION : nvidia::apex
  • AUTHOR : nvidia::apex
  • BRANCH : nvidia::apex
  • BUILD_TIME : nvidia::apex
  • CHANGELIST : nvidia::apex
  • ModifierStage_Continuous : nvidia::apex
  • ModifierStage_Spawn : nvidia::apex
  • REASON : nvidia::apex
  • TOOLS_CHANGELIST : nvidia::apex
  • TYPE_ARRAY : NvParameterized
  • TYPE_ENUM : NvParameterized
  • TYPE_REF : NvParameterized
  • TYPE_STRING : NvParameterized
  • VERSION : nvidia::apex
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Namespace Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • c
  • d
  • f
  • g
  • i
  • l
  • m
  • r
  • s

- c -

  • CreateApexSDK() : nvidia::apex
  • CreateCudaContextManager() : nvidia::apex

- d -

  • DoCompilerVersMatch() : NvParameterized
  • DoOsVersMatch() : NvParameterized

- f -

  • findParam() : NvParameterized
  • findParameter() : NvParameterized

- g -

  • GetApexSDK() : nvidia::apex
  • GetApexSDKVersionString() : nvidia::apex
  • getArrayMemberToken() : NvParameterized
  • getNamedReferences() : NvParameterized
  • getNextToken() : NvParameterized
  • getParamArraySize() : NvParameterized
  • getParamBool() : NvParameterized
  • getParamBounds3() : NvParameterized
  • getParamEnum() : NvParameterized
  • getParamF32() : NvParameterized
  • getParamF64() : NvParameterized
  • getParamI16() : NvParameterized
  • getParamI32() : NvParameterized
  • getParamI64() : NvParameterized
  • getParamI8() : NvParameterized
  • getParamList() : NvParameterized
  • getParamMat33() : NvParameterized
  • getParamMat44() : NvParameterized
  • getParamQuat() : NvParameterized
  • getParamRef() : NvParameterized
  • getParamString() : NvParameterized
  • getParamTransform() : NvParameterized
  • getParamU16() : NvParameterized
  • getParamU32() : NvParameterized
  • getParamU64() : NvParameterized
  • getParamU8() : NvParameterized
  • getParamVec2() : NvParameterized
  • getParamVec3() : NvParameterized
  • getParamVec4() : NvParameterized
  • getReferences() : NvParameterized
  • getStructMemberToken() : NvParameterized
  • GetSuggestedCudaDeviceOrdinal() : nvidia::apex

- i -

  • initParamRef() : NvParameterized
  • instantiateModuleClothing() : nvidia::apex
  • instantiateModuleDestructible() : nvidia::apex
  • instantiateModuleLegacy() : nvidia::apex
  • instantiateModuleLoader() : nvidia::apex
  • instantiateModuleParticles() : nvidia::apex
  • instantiateModuleTurbulenceFS() : nvidia::apex

- l -

  • listParameters() : NvParameterized
  • local_sprintf_s() : NvParameterized
  • local_strcat_s() : NvParameterized
  • local_strcmp() : NvParameterized
  • local_stricmp() : NvParameterized

- m -

  • ModifierUsageFromStage() : nvidia::apex

- r -

  • releaseParamList() : NvParameterized
  • resizeParamArray() : NvParameterized

- s -

  • setParamBool() : NvParameterized
  • setParamBounds3() : NvParameterized
  • setParamEnum() : NvParameterized
  • setParamF32() : NvParameterized
  • setParamF64() : NvParameterized
  • setParamI16() : NvParameterized
  • setParamI32() : NvParameterized
  • setParamI64() : NvParameterized
  • setParamI8() : NvParameterized
  • setParamMat33() : NvParameterized
  • setParamMat44() : NvParameterized
  • setParamQuat() : NvParameterized
  • setParamRef() : NvParameterized
  • setParamString() : NvParameterized
  • setParamTransform() : NvParameterized
  • setParamU16() : NvParameterized
  • setParamU32() : NvParameterized
  • setParamU64() : NvParameterized
  • setParamU8() : NvParameterized
  • setParamVec2() : NvParameterized
  • setParamVec3() : NvParameterized
  • setParamVec4() : NvParameterized
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Namespace Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • AuthObjTypeID : nvidia::apex
  • StatValue : nvidia::apex
  • Vec2R : nvidia::apex
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Namespace Members

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • PlatformTag : nvidia::apex
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia Namespace Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
Namespaces
nvidia Namespace Reference

nvidia namespace More...

Namespaces

namespace apex

apex namespace

Detailed Description

nvidia namespace

physx namespace

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: nvidia::apex Namespace Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • nvidia
  • apex
Namespaces | Classes | Typedefs | Enumerations | Functions | Variables
nvidia::apex Namespace Reference

apex namespace More...

Namespaces

namespace | APEX_ATTRACT

The APEX_ATTRACT namespace contains the defines for setting the preview detail levels.

namespace | APEX_JET

The APEX_JET namespace contains the defines for setting the preview detail levels.

namespace | APEX_NOISE

The APEX_NOISE namespace contains the defines for setting the preview detail levels.

namespace | APEX_TURBO

The APEX_TURBO namespace contains the defines for setting the preview detail levels.

namespace | APEX_VORTEX

The APEX_VORTEX namespace contains the defines for setting the preview detail levels.

namespace | APEX_WIND

The APEX_WIND namespace contains the defines for setting the preview detail levels.

Classes

class | PhysX3DescTemplate
class | Actor
Base class for APEX module objects. More...
class | ActorSource
Base class for APEX classes that spawn PhysX SDK Actors. More...
class | ApexDesc
Base class for all APEX Descriptor classes. More...
class | ApexInterface
Base class for all interface classes implemented by APEX SDK. More...
class | GroupsMask64
64-bit mask used for collision filtering between IOSes and Field Samplers. More...
struct | GroupsFilterOp
Collision groups filtering operations. More...
class | ApexSDKDesc
Descriptor class for ApexSDK. More...
class | ApexSDK
The ApexSDK abstraction. Manages scenes and modules. More...
class | ModuleCachedData
Cached data is stored per-module. More...
class | ApexSDKCachedData
A method for storing actor data in a scene. More...
class | Asset
Base class of all APEX assets. More...
class | AssetAuthoring
base class of all APEX asset authoring classes More...
class | AssetPreview
Base class of all APEX asset previews. More...
class | AssetPreviewScene
An APEX class for. More...
class | AttractorFSActor
AttractorFS Actor class. More...
class | AttractorFSPreview
This class provides the asset preview for APEX AttractorFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...
class | BasicFSAsset
BasicFS Asset class. More...
class | BasicFSAssetAuthoring
BasicFS Asset Authoring class. More...
class | JetFSActor
JetFS Actor class. More...
class | JetFSPreview
This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...
class | ModuleBasicFS
BasicFS module class. More...
class | NoiseFSActor
JetFS Actor class. More...
class | NoiseFSPreview
This class provides the asset preview for APEX NoiseFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...
class | VortexFSActor
VortexFS Actor class. More...
class | VortexFSPreview
This class provides the asset preview for APEX VortexFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...
class | WindFSActor
WindFS Actor class. More...
class | WindFSPreview
This class provides the asset preview for APEX WindFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...
class | BasicIosActor
BasicIOS Actor. A simple actor that simulates a particle system. More...
class | BasicIosAsset
APEX Particle System Asset. More...
class | BasicIosAssetAuthoring
APEX Particle System Asset Authoring class. More...
class | ModuleBasicIos
BasicIOS Module. More...
struct | ClothingTeleportMode
selects the mode the clothing actor will be in the simulation frame More...
class | ClothingActor
Instance of ClothingAsset. Can be positioned, animated, updated and rendered. More...
struct | ClothSolverMode
Describes the solver that is used to simulate the clothing actor. More...
struct | ClothingMeshSkinningMap
Maps from a triangle of the simulated mesh to a vertex of the rendered mesh. The barycentric coordinates describe the position of a point in space relative to a simulated triangle. The actual z-coordinate is computed by bary.z = 1 - bary.x - bary.y. The z part of the vector contains the height of the skinned vertex along the normal of the simulated triangle. More...
class | ClothingAsset
A clothing asset. It contains all the static and shared data for a given piece of clothing. More...
class | ClothingAssetAuthoring
The clothing authoring asset. This is used to generate streams that can then be deserialized into a regular asset. More...
struct | ClothingCollisionType
Type of the ClothingCollision. More...
class | ClothingCollision
Base class of all clothing collision types. More...
class | ClothingPlane
Plane collision of a clothing actor. More...
class | ClothingConvex
Convex collision of a clothing actor. More...
class | ClothingSphere
Sphere collision of a clothing actor. More...
class | ClothingCapsule
Capsule collision of a clothing actor. More...
class | ClothingTriangleMesh
Triangle mesh collision of a clothing actor. More...
struct | ClothingConstrainCoefficients
Constrain coefficients of the physical mesh vertices. More...
struct | ClothingPhysicalMeshStats
Contains the data for handing out statistics about a ClothingPhysicalMesh. More...
class | ClothingPhysicalMesh
Holder for a physical mesh, this can be generated through various ways (see single- and multi-layered clothing) or hand crafted. More...
class | ClothingPreview
A lightweight preview of a ClothingActor that will not perform any simulation. More...
class | ClothingRenderProxy
Instance of ClothingRenderProxy. This is the renderable of a clothing actor. The data in this object is consistent until it is returned to APEX with the release() call. More...
class | ClothingVelocityCallback
container class for the velocity shader callback. More...
class | ModuleClothing
APEX Clothing Module. More...
class | Context
A container for Actors. More...
class | RenderableIterator
Iterate over all renderable Actors in an Context. More...
struct | ConvexHullMethod
Method by which chunk mesh collision hulls are generated. More...
class | CudaTestManager
A class that set information on kernels should be tested and give directive for creation ApexCudaTestContext. More...
struct | Vec2T
A trivial templatized math vector type for pairs. More...
class | Curve
class | CustomBufferIterator
This class is used to access specific elements in an untyped chunk of memory. More...
struct | DestructibleEmitterType
struct | DestructibleParameterizedType
struct | DestructibleHitChunk
struct | DestructibleActorSyncFlags
struct | DestructiblePhysXActorQueryFlags
struct | DestructibleActorSyncState
struct | DestructibleChunkSyncState
struct | DestructibleActorChunkFlags
class | DestructibleActor
class | DestructibleActorJointDesc
class | DestructibleActorJoint
struct | DestructibleDepthParametersFlag
PX_PS4. More...
struct | DestructibleDepthParameters
struct | DestructibleRTFractureParameters
struct | DestructibleParametersFlag
struct | DestructibleParameters
struct | DestructibleInitParametersFlag
struct | DestructibleInitParameters
struct | DamageSpreadFunction
class | DestructibleBehaviorGroupDesc
class | DestructibleChunkDesc
class | DestructibleGeometryDesc
class | DestructibleAssetCookingDesc
struct | DestructibleAssetStats
class | DestructibleAssetAuthoring
class | DestructibleAsset
class | DestructiblePreview
Destructible module's derivation AssetPreview. More...
class | DestructibleRenderable
struct | ExplicitVertexFormat
struct | ExplicitSubmeshData
struct | CollisionVolumeDesc
struct | CollisionDesc
struct | FractureMethod
struct | FractureMaterialDesc
struct | MaterialFrame
class | DisplacementMapVolume
struct | BSPOpenMode
class | ExplicitHierarchicalMesh
class | FractureToolsAPI
struct | ApexChunkFlag
struct | ChunkData
struct | DamageEventReportData
struct | DestructibleChunkEvent
struct | ChunkStateEventData
class | UserChunkReport
struct | ChunkParticleReportData
class | UserChunkParticleReport
class | UserDestructiblePhysXActorReport
struct | ModuleDestructibleConst
struct | DestructibleActorMeshType
struct | DamageEventCoreData
struct | ImpactDamageEventData
class | UserImpactDamageReport
class | UserDestructibleSyncHandler
struct | DamageEventHeader
struct | DamageEventUnit
struct | FractureEventHeader
struct | FractureEventUnit
struct | ChunkTransformHeader
struct | ChunkTransformUnit
struct | DestructibleActorRaycastFlags
struct | DestructibleCallbackSchedule
class | ModuleDestructible
class | EmitterActor
Apex emitter actor class. Emits particles within a given shape. More...
class | EmitterAsset
APEX Emitter asset. Emits particles within some shape. More...
class | EmitterAssetAuthoring
APEX Emitter Asset Authoring. Used to create APEX Emitter assets. More...
struct | EmitterType
Emitter type. More...
class | EmitterGeom
Base class for all emitter shapes. More...
class | EmitterGeomSphereShell
Sphere shell shape for an emitter. It's a shape formed by the difference of two cocentered spheres. More...
class | EmitterGeomSphere
Spherical shape for an emitter. More...
class | EmitterGeomCylinder
Cylindrical shape for an emitter. More...
class | EmitterGeomBox
Box shape for an emitter. More...
class | EmitterGeomExplicit
Explicit geometry. Coordinates of each particle are given explicitly. More...
class | EmitterLodParamDesc
LOD parameters fro emitters. More...
class | EmitterPreview
class | MaterialLookupCallback
a user calback interface used to map raycast hitpoints to material ID If an instance of this class is registered with a ground emitter actor, the actor will call requestMaterialLookups() in lieu of doing raycasts. The call will occur from within the scope of the ApexScene thread, so the callback must be thread safe. More...
class | GroundEmitterActor
Ground Emitter actor. Uses raycasts against ground to spawn particles. More...
class | GroundEmitterAsset
Ground emitter asset. Used to create Ground emitter actors with specific properties. More...
class | GroundEmitterAssetAuthoring
Ground emitter authoring class. Used to create Ground emitter assets. More...
class | GroundEmitterPreview
Ground emitter preview class. Use for preview rendering. More...
class | ImpactEmitterActor
Impact emitter actor. Emits particles at impact places. More...
class | ImpactEmitterAsset
Impact emitter asset class. More...
class | ImpactEmitterAssetAuthoring
Impact emitter asset authoring. Used to create Impact Emitter assets. More...
class | ImpactEmitterPreview
Impact emitter preview. Used for preview rendering of the emitter actors. More...
class | ModuleEmitter
An APEX Module that provides generic Emitter classes. More...
class | FieldSamplerWeightedCollisionFilterCallback
This is an optional callback interface for collision filtering between field samplers and other objects If this interface is not provided, then collision filtering happens normally through the default scene simulationfiltershader callback However, if this is provided, then the user can no only return true/false to indicate whether or not the two objects should interact but can also assign a weighted multiplier value to control how strongly the two objects should interact. More...
class | ModuleFieldSampler
FieldSampler module class. More...
class | ForceFieldActor
ForceField Actor. More...
class | ForceFieldAsset
ForceField Asset. More...
class | ForceFieldAssetAuthoring
ForceField Asset Authoring. More...
class | ForceFieldPreview
APEX asset preview force field asset. More...
class | ModuleForceField
ForceField Module. More...
class | IofxActor
IOFX actor public interface. More...
class | IofxAsset
IOFX Asset public interface. Used to define the way the visual parameters are created from physical parameters of a particle. More...
class | IofxAssetAuthoring
IOFX Asset Authoring public interface. More...
struct | IofxSharedRenderData
IofxSharedRenderData stores common render data shared by several IOFX Renderables. More...
struct | IofxSpriteSharedRenderData
IofxSpriteSharedRenderData stores sprite render data shared by several IOFX Renderables. More...
struct | IofxMeshSharedRenderData
IofxMeshSharedRenderData stores mesh render data shared by several IOFX Renderables. More...
struct | IofxCommonRenderData
IofxCommonRenderData stores common render data for one IOFX Renderable. More...
struct | IofxSpriteRenderData
IofxSpriteRenderData stores sprite render data for one IOFX Renderable. More...
struct | IofxMeshRenderData
IofxMeshRenderData stores mesh render data for one IOFX Renderable. More...
class | IofxRenderable
The IOFX renderable represents a unit of rendering. It contains complete information to render a batch of particles with the same material/mesh in the same render volume. More...
struct | IofxRenderSemantic
Enumerates the potential IOFX render semantics. More...
struct | IofxSpriteRenderLayoutElement
Enumerates the potential IOFX mesh render layout elements. More...
struct | IofxSpriteRenderLayoutSurfaceElement
Enumerates the potential IOFX sprite render layout surface elements. More...
struct | IofxSpriteRenderLayout
Describes the layout for sprite rendering. More...
struct | IofxMeshRenderLayoutElement
Enumerates the potential IOFX mesh render layout elements. More...
struct | IofxMeshRenderLayout
Describes the layout for mesh rendering. More...
class | IofxRenderCallback
User defined callback for IOFX rendering. More...
class | Modifier
Modifier contains all of the data necessary to apply a single modifier type to a particle system. More...
class | ModifierT
ModifierT is a helper class to handle the mapping of Type->Enum and Enum->Type. More...
class | RotationModifier
RotationModifier applies rotation to the particles using one of several rotation models. More...
class | SimpleScaleModifier
SimpleScaleModifier just applies a simple scale factor to each of the X, Y and Z aspects of the model. Each scalefactor can be applied independently. More...
class | ScaleByMassModifier
ScaleByMassModifier scales by mass of the particle. More...
class | RandomScaleModifier
RandomScaleModifier applies a random scale uniformly to all three dimensions. Currently, the scale is a uniform in the range specified. More...
class | ColorVsLifeModifier
ColorVsLifeModifier modifies the color constants associated with a particle depending on the life remaining of the particle. More...
class | ColorVsDensityModifier
ColorVsDensityModifier modifies the color constants associated with a particle depending on the density of the particle. More...
class | SubtextureVsLifeModifier
SubtextureVsLifeModifier is a modifier to adjust the subtexture id versus the life remaining of a particular particle. More...
class | OrientAlongVelocityModifier
OrientAlongVelocity is a modifier to orient a mesh so that a particular axis coincides with the velocity vector. More...
class | ScaleAlongVelocityModifier
ScaleAlongVelocityModifier is a modifier to apply a scale factor along the current velocity vector. More...
class | RandomSubtextureModifier
RandomSubtextureModifier generates a random subtexture ID and places it in the subTextureId field. More...
class | RandomRotationModifier
RandomRotationModifier will choose a random orientation for a sprite particle within the range as specified below. More...
class | ScaleVsLifeModifier
ScaleVsLifeModifier applies a scale factor function against a single axis versus the life remaining. More...
class | ScaleVsDensityModifier
ScaleVsDensityModifier applies a scale factor function against a single axis versus the density of the particle. More...
class | ScaleVsCameraDistanceModifier
ScaleVsCameraDistance applies a scale factor against a specific axis based on distance from the camera to the particle. More...
class | ViewDirectionSortingModifier
ViewDirectionSortingModifier sorts sprite particles along view direction back to front. More...
class | RotationRateModifier
RotationRateModifier is a modifier to apply a continuous rotation for sprites. More...
class | RotationRateVsLifeModifier
RotationRateVsLifeModifier is a modifier to adjust the rotation rate versus the life remaining of a particular particle. More...
class | OrientScaleAlongScreenVelocityModifier
OrientScaleAlongScreenVelocityModifier is a modifier to orient & scale sprites along the current screen velocity vector. More...
class | ColorVsVelocityModifier
ColorVsVelocityModifier modifies the color constants associated with a particle depending on the velocity of the particle. More...
struct | ApexMeshParticleRollType
Roll type of a particle. More...
class | IofxRenderableIterator
Iterate over all renderables in IOFX module. IMPORTANT: release() should be called for each returned not-NULL renderable! More...
class | ModuleIofx
IOFX Module. More...
class | RenderVolume
An object which "owns" a volume of world space. More...
class | IosAsset
The base class of all Instanced Object Simulation classes. More...
class | IProgressListener
User-provided class for following the progress of a task. More...
class | ModuleIofxLegacy
ModuleIofx interface used in APEXSDK before v. 1.4. More...
class | ModuleLoader
The ModuleLoader is a utility class for loading APEX modules. More...
class | ReadLock
RAII wrapper for the Scene read lock. More...
class | WriteLock
RAII wrapper for the Scene write lock. More...
class | MirrorScene
MirrorScene is used to create a selected mirrored copy of a primary scene. Works only with PhysX 3.x. More...
struct | RenderLockMode
Render lock modes. These are used per-module to determine how render locking is done. More...
struct | Range
A structure that holds two templated values, a min and a max. More...
class | Module
base class of all APEX modules More...
class | EffectPackageActor
Defines the EffectPackageActor API which is instantiated from an EffectPackageAsset. More...
class | EffectPackageAsset
Describes an EffectPackageAsset; a collection of particle related effects (emitters, field samplers, etc.) More...
class | EffectPackageAssetAuthoring
Describes an EffectPackageAssetAuthoring class; not currently used. The ParticleEffectTool is used to author EffectPackageAssets. More...
class | ModuleParticles
Defines the API for the Particles Module. More...
class | ParticlesPreview
APEX asset preview wind asset. More...
class | PhysXObjectDesc
PhysX object descriptor. More...
class | ModuleParticleIos
ParticleIOS Module - Manages PhysX 3.0 PxParticleSystem and PxParticleFluid simulations. More...
class | ParticleIosActor
ParticleIOS Actor. A simple actor that simulates a particle system. More...
class | ParticleIosAsset
APEX Particle System Asset. More...
class | ParticleIosAssetAuthoring
APEX Particle System Asset Authoring class. More...
class | PxStreamFromFileBuf
A wrapper class that provides an NvStream API for a PxFileBuf. More...
class | Renderable
Base class of any actor that can be rendered. More...
class | RenderSemanticData
Describes the data location and layout of a single semantic. More...
class | RenderBufferData
Describes all of the semantics of a render buffer. More...
class | ModuleSpecificRenderBufferData
Describes data semantics provided by a particular module. More...
class | RenderContext
Describes the context of a renderable object. More...
struct | RenderDataFormat
Enumeration of possible formats of various buffer semantics. More...
class | RenderDataProvider
An actor instance that provides renderable data. More...
class | PhysXRenderBuffer
This is a helper class implementation of PxRenderBuffer that holds the counts and pointers for renderable data. Does not own the memory, simply used to transfer the state. The append method is not supported. More...
class | RenderDebugInterface
wrapper for DebugRenderable More...
class | VertexBuffer
a vertex buffer that supports multiple formats More...
class | RenderSubmesh
a mesh that has only one material (or render state, in general) More...
struct | RenderMeshActorRaycastFlags
Flags used for raycasting an RenderMeshActor. More...
struct | RenderMeshActorRaycastHitData
Return data from raycasting an RenderMeshActor. More...
class | RenderMeshActor
Renderable mesh (dynamic data associated with RenderMeshAsset) More...
class | RenderMeshActorDesc
Descriptor for creating a rendering mesh (collection of parts and submesh extra data) More...
struct | RenderMeshAssetStats
Stats for an RenderMeshAsset: memory usage, counts, etc. More...
struct | RenderMeshAssetInstanceMode
Instance buffer data mode. DEPRECATED, to be removed by APEX 1.0. More...
struct | VertexColor
The full RGBA color of a vertex. More...
struct | VertexUV
a simple u, v coordinate struct More...
struct | Vertex
An inefficient vertex description used for authoring. More...
struct | ExplicitRenderTriangle
A less inefficient triangle description used for authoring. More...
struct | RenderMeshPartData
Descriptor for creating a rendering mesh part. More...
class | RenderMeshAssetAuthoring
Authoring interface for an RenderMeshAsset. More...
class | RenderMeshAsset
Rendering mesh (data) class. More...
class | ResourceCallback
User defined callback for resource management. More...
class | ResourceProvider
A user provided class for mapping names to pointers or integers. More...
class | RWLockable
Base class for any rw-lockable object implemented by APEX SDK. More...
class | PhysX3Interface
Interface used to call setter function for PhysX 3.0. More...
class | SceneDesc
Data used to initialize a new Scene. More...
struct | StatDataType
APEX stat struct that contains the type enums. More...
struct | oaValueStruct
data value definitions for stats (derived from openautomate) More...
struct | StatsInfo
data value definitions for stats More...
struct | SceneStats
Per scene statistics. More...
struct | ViewMatrixType
Types of view matrices handled by APEX. More...
struct | ProjMatrixType
Types of projection matrices handled by APEX. More...
struct | UserBoundingBoxFlags
Enum of the bounding box types. More...
class | Scene
An APEX wrapper for an PxScene. More...
class | ScopedPhysXLockRead
This helper class creates a scoped read access to the PhysX SDK API. More...
class | ScopedPhysXLockWrite
This helper class creates a scoped write access to the PhysX SDK API. More...
class | Shape
Describes the format of an Shape. More...
class | SphereShape
helper Sphere shape More...
class | CapsuleShape
helper the capsule is oriented along the y axis by default and its total height is height+2*radius More...
class | BoxShape
helper Box shape More...
class | HalfSpaceShape
helper HalfSpace shape More...
class | TestFunctionInterface
class | TestBase
class | FlameEmitterActor
Flame Emitter Actor class. More...
class | FlameEmitterAsset
Flame Emitter Asset class. More...
class | FlameEmitterAssetAuthoring
Flame Emitter Asset Authoring class. More...
class | FlameEmitterPreview
This class provides the asset preview for APEX Flame Emitter Assets. More...
class | HeatSourceActor
Turbulence HeatSource Actor class. More...
class | HeatSourceAsset
Turbulence FieldSampler Asset class. More...
class | HeatSourceAssetAuthoring
Turbulence FieldSampler Asset Authoring class. More...
class | HeatSourcePreview
This class provides the asset preview for APEX HeatSource Assets. More...
class | ModuleTurbulenceFS
Class for TurbulenceFS module. More...
class | SubstanceSourceActor
Turbulence ScalarSource Actor class. More...
class | SubstanceSourceAsset
Turbulence FieldSampler Asset class. More...
class | SubstanceSourceAssetAuthoring
Turbulence FieldSampler Asset Authoring class. More...
class | TurbulenceFSActor
Turbulence FieldSampler Actor class. More...
class | TurbulenceFSAsset
Turbulence FieldSampler Asset class. More...
class | TurbulenceFSAssetAuthoring
Turbulence FieldSampler Asset Authoring class. More...
class | TurbulenceFSPreview
This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...
struct | TurbulenceFieldType
Render surface field type. More...
struct | TurbulenceRenderData
TurbulenceRenderData stores render data for one Turbulence Renderable. More...
class | TurbulenceRenderable
The Turbulence renderable represents a unit of rendering. More...
struct | TurbulenceVelocityFormat
Velocity format for Turbulence rendering. More...
struct | TurbulenceDensityFormat
Density format for Turbulence rendering. More...
struct | TurbulenceFlameFormat
Flame format for Turbulence rendering. More...
struct | TurbulenceRenderLayout
Render layout for Turbulence rendering. More...
class | TurbulenceRenderCallback
User defined callback for Turbulence rendering. More...
class | VelocitySourceActor
Turbulence VelocitySource Actor class. More...
class | VelocitySourceAsset
Turbulence FieldSampler Asset class. More...
class | VelocitySourceAssetAuthoring
Turbulence FieldSampler Asset Authoring class. More...
class | VelocitySourcePreview
This class provides the asset preview for APEX VelocitySource Assets. More...
class | UserOpaqueMeshDesc
Opaque mesh description. More...
class | UserOpaqueMesh
An abstract interface to an opaque mesh. More...
class | RenderBoneBufferData
type of the bone buffer data More...
class | UserRenderBoneBuffer
Used for storing skeletal bone information used during skinning. More...
struct | RenderBoneSemantic
The semantics available for bone buffers. More...
class | UserRenderBoneBufferDesc
Descriptor to generate a bone buffer. More...
struct | RenderInteropFlags
Render interop flags. More...
struct | RenderMapType
Render map type. More...
class | UserRenderData
User render data. More...
class | UserRenderDataHolder
User render data holder. More...
class | UserRenderStorage
User render storage. More...
struct | UserRenderBufferDesc
User render buffer desc. More...
class | UserRenderBuffer
User render buffer. More...
struct | UserRenderSurfaceDesc
User render surface desc. More...
class | UserRenderSurface
User render surface. More...
class | UserRenderCallback
User render callback. More...
class | UserRenderer
User provided renderer interface. More...
class | UserRenderIndexBuffer
Used for storing index data for rendering. More...
class | UserRenderIndexBufferDesc
PX_PS4. More...
class | RenderInstanceBufferData
The instance buffer type (deprecated) More...
class | UserRenderInstanceBuffer
Used for storing per-instance data for rendering. More...
struct | RenderInstanceSemantic
PX_PS4. More...
struct | RenderInstanceLayoutElement
potential semantics of a sprite buffer More...
class | UserRenderInstanceBufferDesc
Describes the data and layout of an instance buffer. More...
class | UserRenderResource
An abstract interface to a renderable resource. More...
class | UserRenderResourceDesc
Describes all the data that makes up a renderable resource. More...
struct | RenderPrimitiveType
Describe the implied vertex ordering. More...
struct | RenderCullMode
Possible triangle culling modes. More...
struct | RenderBufferHint
Hint of the buffer data lifespan. More...
class | UserRenderResourceManager
User defined renderable resource manager. More...
class | RenderSpriteBufferData
Sprite buffer data (deprecated) More...
class | UserRenderSpriteBuffer
Used for storing per-sprite instance data for rendering. More...
struct | RenderSpriteSemantic
PX_PS4. More...
struct | RenderSpriteLayoutElement
potential semantics of a sprite buffer More...
struct | RenderSpriteTextureLayout
Struct for sprite texture layout info. More...
class | UserRenderSpriteTextureDesc
Class for storing sprite texture render data. More...
class | UserRenderSpriteBufferDesc
describes the semantics and layout of a sprite buffer More...
class | RenderSurfaceBufferData
surface buffer data More...
class | UserRenderSurfaceBuffer
Used for storing per-vertex data for rendering. More...
class | UserRenderSurfaceBufferDesc
Describes the semantics and layout of a Surface buffer. More...
class | RenderVertexBufferData
vertex buffer data More...
class | UserRenderVertexBuffer
Used for storing per-vertex data for rendering. More...
struct | RenderVertexSemantic
Potential semantics of a vertex buffer. More...
struct | TextureUVOrigin
Texture UV direction convention. More...
class | UserRenderVertexBufferDesc
Describes the semantics and layout of a vertex buffer. More...
struct | ColorRGBA
Color stored in 32 bits. More...
struct | RenderDataAccess
Type of render data. More...
class | VertexFormat
Describes the format of an VertexBuffer. More...

Typedefs

typedef unsigned int | AuthObjTypeID
Integer values, each representing a unique authorable object class/type.
typedef Vec2T< float > | Vec2R
Vec2R is a helpful typedef for a pair of 32bit floats.
typedef struct
nvidia::apex::oaValueStruct 		StatValue
data value definitions for stats (derived from openautomate)

Enumerations

enum ApexCreateError {
APEX_CE_NO_ERROR = 0,
APEX_CE_NOT_FOUND = 1,
APEX_CE_WRONG_VERSION = 2,
APEX_CE_DESCRIPTOR_INVALID = 3,
APEX_CE_CREATE_NO_ALLOWED = 4
}
These errors are returned by the CreateApexSDK() and ApexSDK::createModule() functions. More...
enum ApexSDKVersionString {
VERSION = 0,
CHANGELIST = 1,
TOOLS_CHANGELIST = 2,
BRANCH = 3,
BUILD_TIME = 4,
AUTHOR = 5,
REASON = 6
}
These values are used to select version string GetApexSDKVersionString function should return. More...
enum ModifierTypeEnum {
ModifierType_Invalid = 0,
ModifierType_Rotation = 1,
ModifierType_SimpleScale = 2,
ModifierType_RandomScale = 3,
ModifierType_ColorVsLife = 4,
ModifierType_ColorVsDensity = 5,
ModifierType_SubtextureVsLife = 6,
ModifierType_OrientAlongVelocity = 7,
ModifierType_ScaleAlongVelocity = 8,
ModifierType_RandomSubtexture = 9,
ModifierType_RandomRotation = 10,
ModifierType_ScaleVsLife = 11,
ModifierType_ScaleVsDensity = 12,
ModifierType_ScaleVsCameraDistance = 13,
ModifierType_ViewDirectionSorting = 14,
ModifierType_RotationRate = 15,
ModifierType_RotationRateVsLife = 16,
ModifierType_OrientScaleAlongScreenVelocity = 17,
ModifierType_ScaleByMass = 18,
ModifierType_ColorVsVelocity = 19,
ModifierType_Count
}
Modifiers list. More...
enum ModifierStage {
ModifierStage_Spawn = 0,
ModifierStage_Continuous = 1,
ModifierStage_Count
}
Stage at which the modifier is applied. More...
enum ColorChannel {
ColorChannel_Red = 0,
ColorChannel_Green = 1,
ColorChannel_Blue = 2,
ColorChannel_Alpha = 3
}
Color channel.
enum ScaleAxis {
ScaleAxis_X = 0,
ScaleAxis_Y = 1,
ScaleAxis_Z = 2
}
Scale axis.
enum ModifierUsage {
ModifierUsage_Spawn = 0x01,
ModifierUsage_Continuous = 0x02,
ModifierUsage_Sprite = 0x04,
ModifierUsage_Mesh = 0x08
}
Modifier usage.
enum EffectType {
ET_EMITTER,
ET_HEAT_SOURCE,
ET_SUBSTANCE_SOURCE,
ET_TURBULENCE_FS,
ET_JET_FS,
ET_ATTRACTOR_FS,
ET_FORCE_FIELD,
ET_NOISE_FS,
ET_VORTEX_FS,
ET_WIND_FS,
ET_RIGID_BODY,
ET_VELOCITY_SOURCE,
ET_FLAME_EMITTER,
ET_LAST
}

Functions

APEX_API int CALL_CONV | GetSuggestedCudaDeviceOrdinal (PxErrorCallback &errc)
Ask the NVIDIA control panel which GPU has been selected for use by PhysX. Returns -1 if no PhysX capable GPU is found or GPU PhysX has been disabled.
APEX_API PxCudaContextManager
*CALL_CONV 		CreateCudaContextManager (const PxCudaContextManagerDesc &desc, PxErrorCallback &errorCallback)
Allocate a CUDA Context manager, complete with heaps and task dispatcher. You only need one CUDA context manager per GPU device you intend to use for CUDA tasks. If mgr is NULL, no profiling of CUDA code will be possible.
APEX_API ApexSDK *CALL_CONV | CreateApexSDK (const ApexSDKDesc &desc, ApexCreateError *errorCode=NULL, uint32_t APEXsdkVersion=APEX_SDK_VERSION, PxAllocatorCallback *alloc=0)
Global function to create the SDK object. APEX_SDK_VERSION must be passed for the APEXsdkVersion.
APEX_API ApexSDK *CALL_CONV | GetApexSDK ()
Returns global SDK pointer.
APEX_API const char *CALL_CONV | GetApexSDKVersionString (ApexSDKVersionString versionString)
Returns version strings.
void | instantiateModuleClothing ()
void | instantiateModuleDestructible ()
PX_PUSH_PACK_DEFAULT uint32_t | ModifierUsageFromStage (ModifierStage stage)
Converts ModifierStage to bitmap.
void | instantiateModuleLegacy ()
void | instantiateModuleLoader ()
void | instantiateModuleParticles ()
void | instantiateModuleTurbulenceFS ()
If this module is distributed as a static library, the user must call this function before calling ApexSDK::createModule("Turbulence")

Variables

PX_PUSH_PACK_DEFAULT typedef
const char * 		PlatformTag
Usual typedef.

Detailed Description

apex namespace

Enumeration Type Documentation

enum nvidia::apex::ApexCreateError

These errors are returned by the CreateApexSDK() and ApexSDK::createModule() functions.

Enumerator:
APEX_CE_NO_ERROR

No errors occurred when creating the Physics SDK.

APEX_CE_NOT_FOUND

Unable to find the libraries. For statically linked APEX, a module specific instantiate function must be called prior to the createModule call.

APEX_CE_WRONG_VERSION

The application supplied a version number that does not match with the libraries.

APEX_CE_DESCRIPTOR_INVALID

The supplied descriptor is invalid.

APEX_CE_CREATE_NO_ALLOWED

This module cannot be created by the application, it is created via a parent module use as APEX_Particles or APEX_Legacy.

enum nvidia::apex::ApexSDKVersionString

These values are used to select version string GetApexSDKVersionString function should return.

Enumerator:
VERSION

APEX version.

CHANGELIST

APEX build changelist.

TOOLS_CHANGELIST

APEX tools build changelist.

BRANCH

APEX branch used to create build.

BUILD_TIME

Time at which the build was created.

AUTHOR

Author of the build.

REASON

Reason to prepare the build.

enum nvidia::apex::EffectType

This enum is used to identity what 'type' of effect

enum nvidia::apex::ModifierStage

Stage at which the modifier is applied.

Enumerator:
ModifierStage_Spawn

at the spawn

ModifierStage_Continuous

on every frame

enum nvidia::apex::ModifierTypeEnum

Modifiers list.

Note:
These are serialized to disk, so if you reorder them or change existing modifier types, you will need to version the stream and map the old values to the new values. If new values are just appended, no other special care needs to be handled.

Function Documentation

void nvidia::apex::instantiateModuleClothing ( )

If this module is distributed as a static library, the user must call this function before calling ApexSDK::createModule("Clothing")

void nvidia::apex::instantiateModuleDestructible ( )

If this module is distributed as a static library, the user must call this function before calling ApexSDK::createModule("Destructible")

void nvidia::apex::instantiateModuleLegacy ( )

If this module is distributed as a static library, the user must call this function before calling ApexSDK::createModule("Legacy")

void nvidia::apex::instantiateModuleLoader ( )

If this module is distributed as a static library, the user must call this function before calling ApexSDK::createModule("Loader")

void nvidia::apex::instantiateModuleParticles ( )

If this module is distributed as a static library, the user must call this function before calling ApexSDK::createModule("Particles")

Generated on Sat Dec 1 2018 10:18:29


APEX Framework: nvidia::apex::APEX_ATTRACT Namespace Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • nvidia
  • apex
  • APEX_ATTRACT
nvidia::apex::APEX_ATTRACT Namespace Reference

The APEX_ATTRACT namespace contains the defines for setting the preview detail levels. More...

Detailed Description

The APEX_ATTRACT namespace contains the defines for setting the preview detail levels.

ATTRACT_DRAW_NOTHING - draw nothing
ATTRACT_DRAW_SHAPE - draw the attractor shape
ATTRACT_DRAW_ASSET_INFO - draw the asset info in the screen space
ATTRACT_DRAW_FULL_DETAIL - draw all components of the preview

Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::APEX_JET Namespace Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • nvidia
  • apex
  • APEX_JET
nvidia::apex::APEX_JET Namespace Reference

The APEX_JET namespace contains the defines for setting the preview detail levels. More...

Detailed Description

The APEX_JET namespace contains the defines for setting the preview detail levels.

JET_DRAW_NOTHING - draw nothing
JET_DRAW_SHAPE - draw the shape
JET_DRAW_ASSET_INFO - draw the asset info in the screen space
JET_DRAW_FULL_DETAIL - draw all components of the preview

Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::APEX_NOISE Namespace Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • nvidia
  • apex
  • APEX_NOISE
nvidia::apex::APEX_NOISE Namespace Reference

The APEX_NOISE namespace contains the defines for setting the preview detail levels. More...

Detailed Description

The APEX_NOISE namespace contains the defines for setting the preview detail levels.

NOISE_DRAW_NOTHING - draw nothing
NOISE_DRAW_SHAPE - draw the shape
NOISE_DRAW_ASSET_INFO - draw the asset info in the screen space
NOISE_DRAW_FULL_DETAIL - draw all components of the preview

Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::APEX_TURBO Namespace Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • nvidia
  • apex
  • APEX_TURBO
nvidia::apex::APEX_TURBO Namespace Reference

The APEX_TURBO namespace contains the defines for setting the preview detail levels. More...

Detailed Description

The APEX_TURBO namespace contains the defines for setting the preview detail levels.

TURBO_DRAW_NOTHING - draw nothing
TURBO_DRAW_ICON - draw the APEX TurbulenceFS Icon
TURBO_DRAW_BOX - draw the box
TURBO_DRAW_GRIDS - draw the top and bottom grids of the box
TURBO_DRAW_ASSET_INFO - draw the asset info in the screen space
TURBO_DRAW_FULL_DETAIL - draw all components of the preview

Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::APEX_VORTEX Namespace Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • nvidia
  • apex
  • APEX_VORTEX
nvidia::apex::APEX_VORTEX Namespace Reference

The APEX_VORTEX namespace contains the defines for setting the preview detail levels. More...

Detailed Description

The APEX_VORTEX namespace contains the defines for setting the preview detail levels.

VORTEX_DRAW_NOTHING - draw nothing
VORTEX_DRAW_SHAPE - draw the Vortex shape
VORTEX_DRAW_ASSET_INFO - draw the asset info in the screen space
VORTEX_DRAW_FULL_DETAIL - draw all components of the preview

Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::APEX_WIND Namespace Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • nvidia
  • apex
  • APEX_WIND
nvidia::apex::APEX_WIND Namespace Reference

The APEX_WIND namespace contains the defines for setting the preview detail levels. More...

Detailed Description

The APEX_WIND namespace contains the defines for setting the preview detail levels.

WIND_DRAW_NOTHING - draw nothing
WIND_DRAW_ASSET_INFO - draw the asset info in the screen space
WIND_DRAW_FULL_DETAIL - draw all components of the preview

Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Namespace List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all documented namespaces with brief descriptions:
nvidia | Nvidia namespace
nvidia::apex | Apex namespace
nvidia::apex::APEX_ATTRACT | The APEX_ATTRACT namespace contains the defines for setting the preview detail levels
nvidia::apex::APEX_JET | The APEX_JET namespace contains the defines for setting the preview detail levels
nvidia::apex::APEX_NOISE | The APEX_NOISE namespace contains the defines for setting the preview detail levels
nvidia::apex::APEX_TURBO | The APEX_TURBO namespace contains the defines for setting the preview detail levels
nvidia::apex::APEX_VORTEX | The APEX_VORTEX namespace contains the defines for setting the preview detail levels
nvidia::apex::APEX_WIND | The APEX_WIND namespace contains the defines for setting the preview detail levels
NvParameterized | NvParameterized namespace
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Related Pages

  • Related Pages
  • Namespaces
  • Classes
  • Files
Related Pages
Here is a list of all related documentation pages:
  • Deprecated List
Generated on Sat Dec 1 2018 10:18:28


APEX Framework: FractureTools::CutoutParameters Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • CutoutParameters
Public Member Functions | Public Attributes
FractureTools::CutoutParameters Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Member Functions

CutoutParameters ()
void | setToDefault ()

Public Attributes

float | depth
nvidia::FractureMaterialDesc materialDesc
NoiseParameters backfaceNoise
NoiseParameters edgeNoise

Detailed Description

CutoutParameters

Parameters for a single cutout direction.

Constructor & Destructor Documentation

FractureTools::CutoutParameters::CutoutParameters ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::CutoutParameters::setToDefault ( ) [inline]

Set default values:

depth = 1.0f; backfaceNoise.setToDefault(); edgeNoise.setToDefault(); materialDesc.setToDefault();

Member Data Documentation

NoiseParameters FractureTools::CutoutParameters::backfaceNoise

Describes the characteristics of the backface cutting surface (along the various cutout directions). If the noise is 0, the cutting surface will be a plane. Otherwise, there will be some variation, or roughness, to the surface.

float FractureTools::CutoutParameters::depth

The depth to apply cutout fracturing. 0 has a special value; it means cut all the way through

NoiseParameters FractureTools::CutoutParameters::edgeNoise

Describes the characteristics of the perimeter cutting surfaces (for the various cutout directions). If the noise is 0, the cutting surface will smooth. Otherwise, there will be some variation, or roughness, to the surface.

Note: this noise is applied only to the graphics of the cutout chunks. The chunks' collision volumes AND the chunks' children (if fractured further) will NOT be affected by this noise.

nvidia::FractureMaterialDesc FractureTools::CutoutParameters::materialDesc

Material application descriptor used for the cutout direction. Note: The backface slice will use the U-direction and UV offset specified in each descriptor, however the cutout slices (surrounding each cutout chunk) will ignore these fields (only using the UV scale).

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • CutoutParameters
FractureTools::CutoutParameters Member List
This is the complete list of members for FractureTools::CutoutParameters, including all inherited members.
backfaceNoise | FractureTools::CutoutParameters |
CutoutParameters() | FractureTools::CutoutParameters | [inline]
depth | FractureTools::CutoutParameters |
edgeNoise | FractureTools::CutoutParameters |
materialDesc | FractureTools::CutoutParameters |
setToDefault() | FractureTools::CutoutParameters | [inline]
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: FractureTools::FractureCutoutDesc Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • FractureCutoutDesc
Public Types | Public Member Functions | Public Attributes
FractureTools::FractureCutoutDesc Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Types

enum Directions {
UserDefined = 0,
NegativeX = 1 << 0,
PositiveX = 1 << 1,
NegativeY = 1 << 2,
PositiveY = 1 << 3,
NegativeZ = 1 << 4,
PositiveZ = 1 << 5,
DirectionCount = 6
}
enum InstancingMode {
DoNotInstance,
InstanceCongruentChunks,
InstanceAllChunks,
InstanceModeCount
}
enum CutoutChunkFracturingMethod {
DoNotFractureCutoutChunks,
SliceFractureCutoutChunks,
VoronoiFractureCutoutChunks,
CutoutChunkFracturingMethodCount
}

Public Member Functions

FractureCutoutDesc ()
void | setToDefault ()

Public Attributes

unsigned | directions
unsigned | directionOrder [DirectionCount]
CutoutParameters | cutoutParameters [DirectionCount]
physx::PxVec3 | userDefinedDirection
physx::PxMat33 | userUVMapping
CutoutParameters userDefinedCutoutParameters
unsigned | instancingMode
bool | tileFractureMap
physx::PxVec2 | uvTileSize
bool | splitNonconvexRegions
unsigned | chunkFracturingMethod
bool | trimFaceCollisionHulls
float | cutoutWidthScale [DirectionCount]
float | cutoutHeightScale [DirectionCount]
float | cutoutWidthOffset [DirectionCount]
float | cutoutHeightOffset [DirectionCount]
bool | cutoutWidthInvert [DirectionCount]
bool | cutoutHeightInvert [DirectionCount]
float | cutoutSizeX
float | cutoutSizeY
float | facetNormalMergeThresholdAngle

Detailed Description

FractureCutoutDesc

Descriptor for cutout-mode (chippable) fracturing.

Member Enumeration Documentation

enum FractureTools::FractureCutoutDesc::CutoutChunkFracturingMethod

Fracturing to apply to cutout chunks (if any), to break them down further. Current options include none, slice fracturing, and voronoi fracturing.

enum FractureTools::FractureCutoutDesc::Directions

Enum describing the directions to apply cutout fracturing.

enum FractureTools::FractureCutoutDesc::InstancingMode

Enum describing the instancing mode.

Constructor & Destructor Documentation

FractureTools::FractureCutoutDesc::FractureCutoutDesc ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::FractureCutoutDesc::setToDefault ( ) [inline]

Set default values:

directions = 0; directionOrder[0..5] = {NegativeX, .., PositiveZ}; cutoutParameters[0..5].setToDefault(); userDefinedDirection= physx::PxVec3(0.0f); userUVMapping = physx::PxMat33(physx::PxIdentity); userDefinedCutoutParameters.setToDefault(); instancingMode = DoNotInstance; tileFractureMap = false; uvTileSize = (0.0f,0.0f) cutoutParameters[0..5].setToDefault(); cutoutWidthScale[0..5] = 1.0f; cutoutHeightScale[0..5] = 1.0f; cutoutWidthOffset[0..5] = 0.0f; cutoutHeightOffset[0..5] = 0.0f; cutoutWidthInvert[0..5] = false; cutoutHeightInvert[0..5] = false; cutoutSizeX = 1.0f; cutoutSizeY = 1.0f; facetNormalMergeThresholdAngle = 60.0f; splitNonconvexRegions = false; chunkFracturingMethod = DoNotFractureCutoutChunks; trimFaceCollisionHulls = true;

Member Data Documentation

unsigned FractureTools::FractureCutoutDesc::chunkFracturingMethod

If true, slice-mode fracturing will be applied to each cutout piece. The cutout function must be provided with a FractureSliceDesc as well to describe the slice parameters. These parameters, however, must be interpreted from the point of view of the cutout direction. That is, X and Y slice parameters will be used to slice along the cutout faces. The Z slice parameters will be used to slice into the cutout faces.

bool FractureTools::FractureCutoutDesc::cutoutHeightInvert[DirectionCount]

If true, the cutout map will be flipped in the Y direction (along the various cutout directions).

float FractureTools::FractureCutoutDesc::cutoutHeightOffset[DirectionCount]

Offset to apply to the Y coordinates of the cutout set (along the various cutout directions).

float FractureTools::FractureCutoutDesc::cutoutHeightScale[DirectionCount]

Scale to apply to the Y coordinates of the cutout set (along the various cutout directions).

CutoutParameters FractureTools::FractureCutoutDesc::cutoutParameters[DirectionCount]

Cutout parameters used for the various pre-defined cutout directions.

float FractureTools::FractureCutoutDesc::cutoutSizeX

The interpreted size of the cutout map in the X direction

float FractureTools::FractureCutoutDesc::cutoutSizeY

The interpreted size of the cutout map in the Y direction

bool FractureTools::FractureCutoutDesc::cutoutWidthInvert[DirectionCount]

If true, the cutout map will be flipped in the X direction (along the various cutout directions).

float FractureTools::FractureCutoutDesc::cutoutWidthOffset[DirectionCount]

Offset to apply to the X coordinates of the cutout set (along the various cutout directions).

float FractureTools::FractureCutoutDesc::cutoutWidthScale[DirectionCount]

Scale to apply to the X coordinates of the cutout set (along the various cutout directions).

unsigned FractureTools::FractureCutoutDesc::directionOrder[DirectionCount]

The order in which to apply each cutout direction. The direction in directionOrder[0] is applied first, in directionOrder[1], second, and so on.

unsigned FractureTools::FractureCutoutDesc::directions

The directions to apply cutout fracturing. (See the Directions enum.)

float FractureTools::FractureCutoutDesc::facetNormalMergeThresholdAngle

Threshold angle to merge (smoothe) vertex normals around cutout, in degrees. If the exterior angle between two facets of a cutout region no more than this, the vertex normals and tangents will be averaged at the facet interface. A value of 0 effectively disables smoothing. Default value = 60 degrees.

unsigned FractureTools::FractureCutoutDesc::instancingMode

The instancing mode.

bool FractureTools::FractureCutoutDesc::splitNonconvexRegions

If true, non-convex cutouts will be split into convex ones.

bool FractureTools::FractureCutoutDesc::tileFractureMap

If tileFractureMap is true, the map will be tiled across the destructible.

bool FractureTools::FractureCutoutDesc::trimFaceCollisionHulls

If true, the backface and cutouts will be trimmed if (a) backface noise is non-zero or (b) the collision hull is something other than the mesh convex hull ("Wrap Graphics Mesh"). Trimming is done by intersecting the face slice plane (without added noise) with the backface and cutouts. Default is true.

CutoutParameters FractureTools::FractureCutoutDesc::userDefinedCutoutParameters

Cutout parameters used if user-defined (UV-based) cutout fracturing is selected by setting directions = 0

physx::PxVec3 FractureTools::FractureCutoutDesc::userDefinedDirection

The cutout direction if directions = 0. When this is used, it must be have non-zero length (it will be normalized internally), and userUVMapping must be set (this may be done with AssetAuthoring::calculateCutoutUVMapping).

physx::PxMat33 FractureTools::FractureCutoutDesc::userUVMapping

The UV mapping used if directons = 0 (along with userDefinedDirection).

physx::PxVec2 FractureTools::FractureCutoutDesc::uvTileSize

The U,V width of the fracture map when instancing chunks

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • FractureCutoutDesc
FractureTools::FractureCutoutDesc Member List
This is the complete list of members for FractureTools::FractureCutoutDesc, including all inherited members.
chunkFracturingMethod | FractureTools::FractureCutoutDesc |
CutoutChunkFracturingMethod enum name | FractureTools::FractureCutoutDesc |
CutoutChunkFracturingMethodCount enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
cutoutHeightInvert | FractureTools::FractureCutoutDesc |
cutoutHeightOffset | FractureTools::FractureCutoutDesc |
cutoutHeightScale | FractureTools::FractureCutoutDesc |
cutoutParameters | FractureTools::FractureCutoutDesc |
cutoutSizeX | FractureTools::FractureCutoutDesc |
cutoutSizeY | FractureTools::FractureCutoutDesc |
cutoutWidthInvert | FractureTools::FractureCutoutDesc |
cutoutWidthOffset | FractureTools::FractureCutoutDesc |
cutoutWidthScale | FractureTools::FractureCutoutDesc |
DirectionCount enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
directionOrder | FractureTools::FractureCutoutDesc |
directions | FractureTools::FractureCutoutDesc |
Directions enum name | FractureTools::FractureCutoutDesc |
DoNotFractureCutoutChunks enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
DoNotInstance enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
facetNormalMergeThresholdAngle | FractureTools::FractureCutoutDesc |
FractureCutoutDesc() | FractureTools::FractureCutoutDesc | [inline]
InstanceAllChunks enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
InstanceCongruentChunks enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
InstanceModeCount enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
InstancingMode enum name | FractureTools::FractureCutoutDesc |
instancingMode | FractureTools::FractureCutoutDesc |
NegativeX enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
NegativeY enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
NegativeZ enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
PositiveX enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
PositiveY enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
PositiveZ enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
setToDefault() | FractureTools::FractureCutoutDesc | [inline]
SliceFractureCutoutChunks enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
splitNonconvexRegions | FractureTools::FractureCutoutDesc |
tileFractureMap | FractureTools::FractureCutoutDesc |
trimFaceCollisionHulls | FractureTools::FractureCutoutDesc |
UserDefined enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
userDefinedCutoutParameters | FractureTools::FractureCutoutDesc |
userDefinedDirection | FractureTools::FractureCutoutDesc |
userUVMapping | FractureTools::FractureCutoutDesc |
uvTileSize | FractureTools::FractureCutoutDesc |
VoronoiFractureCutoutChunks enum value (defined in FractureTools::FractureCutoutDesc) | FractureTools::FractureCutoutDesc |
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: FractureTools::FractureSliceDesc Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • FractureSliceDesc
Public Types | Public Member Functions | Public Attributes
FractureTools::FractureSliceDesc Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Types

enum NoiseMode {
NoiseWavePlane = 0,
NoisePerlin2D,
NoisePerlin3D,
NoiseModeCount
}

Public Member Functions

FractureSliceDesc ()
void | setToDefault ()

Public Attributes

unsigned | maxDepth
SliceParameters * sliceParameters
bool | useTargetProportions
float | targetProportions [3]
float | minimumChunkSize [3]
nvidia::FractureMaterialDesc | materialDesc [3]
bool | instanceChunks
bool | useDisplacementMaps
unsigned | noiseMode

Detailed Description

FractureSliceDesc

Descriptor for slice-mode fracturing.

Member Enumeration Documentation

enum FractureTools::FractureSliceDesc::NoiseMode

Enum describing creation of displacement maps.

Constructor & Destructor Documentation

FractureTools::FractureSliceDesc::FractureSliceDesc ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::FractureSliceDesc::setToDefault ( ) [inline]

Sets the default values:

maxDepth = 0; sliceParameters = NULL; useTargetProportions = false; targetProportions[0..2] = 1.0f; minimumChunkSize[0..2] = 0.0f; materialDesc[0..2].setToDefault(); instanceChunks = false; useDisplacementMaps = false; noiseMode = NoiseWavePlane;

Member Data Documentation

bool FractureTools::FractureSliceDesc::instanceChunks

If instanceChunks is true, corresponding chunks in different destructible actors will be instanced.

nvidia::FractureMaterialDesc FractureTools::FractureSliceDesc::materialDesc[3]

Material application descriptor used for each slice axis.

unsigned FractureTools::FractureSliceDesc::maxDepth

How many times to recurse the slicing process

float FractureTools::FractureSliceDesc::minimumChunkSize[3]

Smallest size allowed for chunks, as measured by their bounding box widths along the x, y, and z axes. The sizes are interpreted as fractions of the unfractured mesh's bounding box width. Chunks created by fracturing which are smaller than this limit will be removed. Note - this will leave holes at the given depth. Default = (0,0,0), which disables this feature.

unsigned FractureTools::FractureSliceDesc::noiseMode

The noise mode. If displacement maps are enabled, NoisePerlin3D will be used.

SliceParameters* FractureTools::FractureSliceDesc::sliceParameters

Array of slice parameters; must be of length maxDepth

float FractureTools::FractureSliceDesc::targetProportions[3]

If useTargetProportions is true, the splitsPerPass values will not necessarily be used. Instead, the closest values will be chosen at each recursion of slicing, in order to make the pieces match the target proportions as closely as possible.

Note: the more noise there is in the slicing surfaces, the less accurate these proportions will be.

bool FractureTools::FractureSliceDesc::useDisplacementMaps

If true, slice geometry and noise will be stored in a separate displacement offset buffer.

bool FractureTools::FractureSliceDesc::useTargetProportions

If this is true, the targetProportions (see below) will be used.

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • FractureSliceDesc
FractureTools::FractureSliceDesc Member List
This is the complete list of members for FractureTools::FractureSliceDesc, including all inherited members.
FractureSliceDesc() | FractureTools::FractureSliceDesc | [inline]
instanceChunks | FractureTools::FractureSliceDesc |
materialDesc | FractureTools::FractureSliceDesc |
maxDepth | FractureTools::FractureSliceDesc |
minimumChunkSize | FractureTools::FractureSliceDesc |
NoiseMode enum name | FractureTools::FractureSliceDesc |
noiseMode | FractureTools::FractureSliceDesc |
NoiseModeCount enum value (defined in FractureTools::FractureSliceDesc) | FractureTools::FractureSliceDesc |
NoisePerlin2D enum value (defined in FractureTools::FractureSliceDesc) | FractureTools::FractureSliceDesc |
NoisePerlin3D enum value (defined in FractureTools::FractureSliceDesc) | FractureTools::FractureSliceDesc |
NoiseWavePlane enum value (defined in FractureTools::FractureSliceDesc) | FractureTools::FractureSliceDesc |
setToDefault() | FractureTools::FractureSliceDesc | [inline]
sliceParameters | FractureTools::FractureSliceDesc |
targetProportions | FractureTools::FractureSliceDesc |
useDisplacementMaps | FractureTools::FractureSliceDesc |
useTargetProportions | FractureTools::FractureSliceDesc |
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: FractureTools::FractureVoronoiDesc Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • FractureVoronoiDesc
Public Types | Public Member Functions | Public Attributes
FractureTools::FractureVoronoiDesc Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Types

enum NoiseMode {
NoiseWavePlane = 0,
NoisePerlin2D,
NoisePerlin3D,
NoiseModeCount
}

Public Member Functions

FractureVoronoiDesc ()
void | setToDefault ()

Public Attributes

unsigned | siteCount
const physx::PxVec3 * | sites
const uint32_t * | chunkIndices
NoiseParameters faceNoise
bool | instanceChunks
bool | useDisplacementMaps
unsigned | noiseMode
float | minimumChunkSize
nvidia::FractureMaterialDesc materialDesc

Detailed Description

FractureVoronoiDesc

Descriptor for Voronoi decomposition fracturing.

Member Enumeration Documentation

enum FractureTools::FractureVoronoiDesc::NoiseMode

Enum describing creation of displacement maps.

Constructor & Destructor Documentation

FractureTools::FractureVoronoiDesc::FractureVoronoiDesc ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::FractureVoronoiDesc::setToDefault ( ) [inline]

Sets the default values:

siteCount = 0; sites = NULL; chunkIndices = NULL; faceNoise.setToDefault(); instanceChunks = false; useDisplacementMaps = false; noiseMode = NoiseWavePlane; minimumChunkSize = 0.0f; materialDesc.setToDefault();

Member Data Documentation

const uint32_t* FractureTools::FractureVoronoiDesc::chunkIndices

Array of chunk indices to associate with each site. If this pointer is NULL, then all sites will be used to split all chunks relevant to the splitting operation. Otherwise, the chunkIndices array must be of length siteCount.

NoiseParameters FractureTools::FractureVoronoiDesc::faceNoise

Describes the characteristics of the interior surfaces. If the noise is 0, the cutting surface will smooth. Otherwise, there will be some variation, or roughness, to the surface.

Note: this noise is applied only to the graphics of the chunks. The chunks' collision volumes AND the chunks' children (if fractured further) will NOT be affected by this noise.

bool FractureTools::FractureVoronoiDesc::instanceChunks

If instanceChunks is true, corresponding chunks in different destructible actors will be instanced.

nvidia::FractureMaterialDesc FractureTools::FractureVoronoiDesc::materialDesc

Material application descriptor used for each slice. Note: the U-direction and UV offset in the descriptor will be ignored - UV mapping is done in arbitrary orientation and translation on each chunk face.

float FractureTools::FractureVoronoiDesc::minimumChunkSize

Smallest size allowed for chunks, as measured by their bounding sphere diameters. The sizes are interpreted as fractions of the unfractured mesh's bounding sphere diameter. Chunks created by fracturing which are smaller than this limit will be removed. Note - this will leave holes at the given depth. Default = 0, which disables this feature.

unsigned FractureTools::FractureVoronoiDesc::noiseMode

The noise mode. If displacement maps are enabled, NoisePerlin3D will be used.

unsigned FractureTools::FractureVoronoiDesc::siteCount

Number of cell sites in the sites array. Must be positive.

const physx::PxVec3* FractureTools::FractureVoronoiDesc::sites

Array of cell sites. The length of this array is given by siteCount.

bool FractureTools::FractureVoronoiDesc::useDisplacementMaps

If true, slice geometry and noise will be stored in a separate displacement offset buffer.

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • FractureVoronoiDesc
FractureTools::FractureVoronoiDesc Member List
This is the complete list of members for FractureTools::FractureVoronoiDesc, including all inherited members.
chunkIndices | FractureTools::FractureVoronoiDesc |
faceNoise | FractureTools::FractureVoronoiDesc |
FractureVoronoiDesc() | FractureTools::FractureVoronoiDesc | [inline]
instanceChunks | FractureTools::FractureVoronoiDesc |
materialDesc | FractureTools::FractureVoronoiDesc |
minimumChunkSize | FractureTools::FractureVoronoiDesc |
noiseMode | FractureTools::FractureVoronoiDesc |
NoiseMode enum name | FractureTools::FractureVoronoiDesc |
NoiseModeCount enum value (defined in FractureTools::FractureVoronoiDesc) | FractureTools::FractureVoronoiDesc |
NoisePerlin2D enum value (defined in FractureTools::FractureVoronoiDesc) | FractureTools::FractureVoronoiDesc |
NoisePerlin3D enum value (defined in FractureTools::FractureVoronoiDesc) | FractureTools::FractureVoronoiDesc |
NoiseWavePlane enum value (defined in FractureTools::FractureVoronoiDesc) | FractureTools::FractureVoronoiDesc |
setToDefault() | FractureTools::FractureVoronoiDesc | [inline]
siteCount | FractureTools::FractureVoronoiDesc |
sites | FractureTools::FractureVoronoiDesc |
useDisplacementMaps | FractureTools::FractureVoronoiDesc |
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: FractureTools::MeshProcessingParameters Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • MeshProcessingParameters
Public Member Functions | Public Attributes
FractureTools::MeshProcessingParameters Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Member Functions

MeshProcessingParameters ()
void | setToDefault ()

Public Attributes

bool | islandGeneration
bool | removeTJunctions
unsigned | microgridSize
nvidia::BSPOpenMode::Enum meshMode
int | verbosity

Detailed Description

These parameters are passed into the fracturing functions to guide mesh processing.

Constructor & Destructor Documentation

FractureTools::MeshProcessingParameters::MeshProcessingParameters ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::MeshProcessingParameters::setToDefault ( ) [inline]

Set default values

Member Data Documentation

bool FractureTools::MeshProcessingParameters::islandGeneration

If this is true, separate mesh islands will be turned into separate chunks. Default = false.

nvidia::BSPOpenMode::Enum FractureTools::MeshProcessingParameters::meshMode

Open mesh handling. Modes: Automatic, Closed, Open (see BSPOpenMode) Closed mode assumes the mesh is closed and attempts to insert interior faces. Open mode assumes the mesh is open and does not insert interior faces. Automatic mode attempts to determine if the mesh is open or closed, and act accordingly.

Default is Automatic mode.

unsigned FractureTools::MeshProcessingParameters::microgridSize

The mesh is initially scaled to fit in a unit cube, then (if gridSize is not zero), the vertices of the scaled mesh are snapped to a grid of size 1/gridSize. A power of two is recommended. Default = 65536.

bool FractureTools::MeshProcessingParameters::removeTJunctions

If this is true, all T-junctions will be removed from the mesh. Default = false.

int FractureTools::MeshProcessingParameters::verbosity

Debug output verbosity level. The higher the number, the more messages are output. Default = 0.

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • MeshProcessingParameters
FractureTools::MeshProcessingParameters Member List
This is the complete list of members for FractureTools::MeshProcessingParameters, including all inherited members.
islandGeneration | FractureTools::MeshProcessingParameters |
meshMode | FractureTools::MeshProcessingParameters |
MeshProcessingParameters() | FractureTools::MeshProcessingParameters | [inline]
microgridSize | FractureTools::MeshProcessingParameters |
removeTJunctions | FractureTools::MeshProcessingParameters |
setToDefault() | FractureTools::MeshProcessingParameters | [inline]
verbosity | FractureTools::MeshProcessingParameters |
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: FractureTools::NoiseParameters Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • NoiseParameters
Public Member Functions | Public Attributes
FractureTools::NoiseParameters Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Member Functions

NoiseParameters ()
void | setToDefault ()

Public Attributes

float | amplitude
float | frequency
int | gridSize
int | type

Detailed Description

NoiseParameters These parameters are used to build a splitting surface.

Constructor & Destructor Documentation

FractureTools::NoiseParameters::NoiseParameters ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::NoiseParameters::setToDefault ( ) [inline]

Set default values:

amplitude = 0.0f; frequency = 0.25f; gridSize = 10; type = 0;

Member Data Documentation

float FractureTools::NoiseParameters::amplitude

Size of the fluctuations, relative to mesh size

float FractureTools::NoiseParameters::frequency

Noise frequencey relative to 1/(grid spacing). On scales much smaller than this, the function is smooth. On scales much large, the function looks uncorrelated

int FractureTools::NoiseParameters::gridSize

Suggested number of grid elements across the mesh. The actual number may vary depending on the mesh's proportions.

int FractureTools::NoiseParameters::type

Noise function to use. This parameter is currently unused. Noise is generated by superposition of many fourier modes in random directions, with frequencies randomly chosen in a band around the input frequency,

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • NoiseParameters
FractureTools::NoiseParameters Member List
This is the complete list of members for FractureTools::NoiseParameters, including all inherited members.
amplitude | FractureTools::NoiseParameters |
frequency | FractureTools::NoiseParameters |
gridSize | FractureTools::NoiseParameters |
NoiseParameters() | FractureTools::NoiseParameters | [inline]
setToDefault() | FractureTools::NoiseParameters | [inline]
type | FractureTools::NoiseParameters |
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: FractureTools::SliceParameters Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • SliceParameters
Public Types | Public Member Functions | Public Attributes
FractureTools::SliceParameters Struct Reference

#include <FractureToolsStructs.h>

List of all members.

Public Types

enum Order {
XYZ,
YZX,
ZXY,
ZYX,
YXZ,
XZY,
Through
}

Public Member Functions

SliceParameters ()
void | setToDefault ()

Public Attributes

unsigned | order
unsigned | splitsPerPass [3]
float | linearVariation [3]
float | angularVariation [3]
NoiseParameters | noise [3]

Detailed Description

SliceParameters

The slicing parameters for X, Y, and Z slicing of a mesh.

Member Enumeration Documentation

enum FractureTools::SliceParameters::Order

Which axis order to slice the mesh. This only matters if there is randomness in the slice surface.

Constructor & Destructor Documentation

FractureTools::SliceParameters::SliceParameters ( ) [inline]

Constructor sets defaults

Member Function Documentation

void FractureTools::SliceParameters::setToDefault ( ) [inline]

Sets all NoiseParameters to their defaults: order = XYZ; splitsPerPass[0] = splitsPerPass[1] = splitsPerPass[2] = 1; linearVariation[0] = linearVariation[1] = linearVariation[2] = 0.1f; angularVariation[0] = angularVariation[1] = angularVariation[2] = 20.0f*3.1415927f/180.0f; noise[0].setToDefault(); noise[1].setToDefault(); noise[2].setToDefault();

Member Data Documentation

float FractureTools::SliceParameters::angularVariation[3]

Variation in the slice surface angle along each axis. 0 variation means the slice surfaces are axis-aligned. Otherwise, the surface normal will be varied randomly, with angle to the axis somewhere within the given variation (in radians).

float FractureTools::SliceParameters::linearVariation[3]

Variation in slice position along each axis. This is a relative quantity. linearVariation[axis] = 0 means the slicing offsets are evenly spaced across the mesh along the axis. linearVariation[axis] = 1 means the slicing offsets are randomly chosen in a range of width 1/(splitsPerPass[axis]+1) times the width of the mesh along the axis.

NoiseParameters FractureTools::SliceParameters::noise[3]

The noise for each slicing direction

unsigned FractureTools::SliceParameters::order

The slicing order (see the Order enum)

unsigned FractureTools::SliceParameters::splitsPerPass[3]

How many times to slice along each axis

The documentation for this struct was generated from the following file:
  • FractureToolsStructs.h
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • FractureTools
  • SliceParameters
FractureTools::SliceParameters Member List
This is the complete list of members for FractureTools::SliceParameters, including all inherited members.
angularVariation | FractureTools::SliceParameters |
linearVariation | FractureTools::SliceParameters |
noise | FractureTools::SliceParameters |
order | FractureTools::SliceParameters |
Order enum name | FractureTools::SliceParameters |
setToDefault() | FractureTools::SliceParameters | [inline]
SliceParameters() | FractureTools::SliceParameters | [inline]
splitsPerPass | FractureTools::SliceParameters |
Through enum value (defined in FractureTools::SliceParameters) | FractureTools::SliceParameters |
XYZ enum value (defined in FractureTools::SliceParameters) | FractureTools::SliceParameters |
XZY enum value (defined in FractureTools::SliceParameters) | FractureTools::SliceParameters |
YXZ enum value (defined in FractureTools::SliceParameters) | FractureTools::SliceParameters |
YZX enum value (defined in FractureTools::SliceParameters) | FractureTools::SliceParameters |
ZXY enum value (defined in FractureTools::SliceParameters) | FractureTools::SliceParameters |
ZYX enum value (defined in FractureTools::SliceParameters) | FractureTools::SliceParameters |
Generated on Sat Dec 1 2018 10:18:29


APEX Framework: NvParameterized::ParamResult Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • ParamResult
Public Member Functions | Public Attributes
NvParameterized::ParamResult Struct Reference

Container for results of getParamList. More...

#include <NvParamUtils.h>

List of all members.

Public Member Functions

ParamResult (const char *name, const char *longName, const char *className, const char *instanceName, const Handle &handle, int32_t arraySize, DataType type)
Constructor.

Public Attributes

int32_t | mArraySize
size of array (if parameter is array)
const char * | mInstanceName
Name of parameter's parent object.
const char * | mClassName
Name of NvParameterized-class of parameter's parent object.
const char * | mName
The name of the parameter.
const char * | mLongName
The fully qualified 'long' name of the parameter.
Handle mHandle
Use this handle to access the parameter in question.
DataType mDataType
The type of parameter.

Detailed Description

Container for results of getParamList.

The documentation for this struct was generated from the following file:
  • NvParamUtils.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • ParamResult
NvParameterized::ParamResult Member List
This is the complete list of members for NvParameterized::ParamResult, including all inherited members.
mArraySize | NvParameterized::ParamResult |
mClassName | NvParameterized::ParamResult |
mDataType | NvParameterized::ParamResult |
mHandle | NvParameterized::ParamResult |
mInstanceName | NvParameterized::ParamResult |
mLongName | NvParameterized::ParamResult |
mName | NvParameterized::ParamResult |
ParamResult(const char *name, const char *longName, const char *className, const char *instanceName, const Handle &handle, int32_t arraySize, DataType type) | NvParameterized::ParamResult | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::ParameterFind Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • ParameterFind
Public Member Functions | Public Attributes
NvParameterized::ParameterFind Struct Reference

Finds parameter in NvParameterized. More...

List of all members.

Public Member Functions

ParameterFind (const NvParameterized::Interface &iface)
Contructor.
bool | isDigit (char c) const
isDigit
bool | setSearchName (const char *str)
setSearchName
bool | done (void) const
done
int32_t | getArrayIndex (void)
getArrayIndex
bool | nameMatch (const char *longName) const
nameMatch
bool | isComplete (void) const
isCompleete
bool | pushNameMatch (void)
pushNameMatch
void | popNameMatch (void)
popNameMatch

Public Attributes

uint32_t | mNameIndex
mNameIndex
uint32_t | mNameCount
mNameCount
Handle mResult
mResult
const NvParameterized::Interface * | mInterface
mInterface
bool | mError
mError;
char | mSearchName [MAX_SEARCH_NAME]
mSearchName
char * | mSearchNames [MAX_SEARCH_NAMES]
mSearchNames
int32_t | mArrayIndex [MAX_SEARCH_NAMES]
mArrayIndex

Detailed Description

Finds parameter in NvParameterized.

The documentation for this struct was generated from the following file:
  • NvParamUtils.inl
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • ParameterFind
NvParameterized::ParameterFind Member List
This is the complete list of members for NvParameterized::ParameterFind, including all inherited members.
done(void) const | NvParameterized::ParameterFind | [inline]
getArrayIndex(void) | NvParameterized::ParameterFind | [inline]
isComplete(void) const | NvParameterized::ParameterFind | [inline]
isDigit(char c) const | NvParameterized::ParameterFind | [inline]
mArrayIndex | NvParameterized::ParameterFind |
mError | NvParameterized::ParameterFind |
mInterface | NvParameterized::ParameterFind |
mNameCount | NvParameterized::ParameterFind |
mNameIndex | NvParameterized::ParameterFind |
mResult | NvParameterized::ParameterFind |
mSearchName | NvParameterized::ParameterFind |
mSearchNames | NvParameterized::ParameterFind |
nameMatch(const char *longName) const | NvParameterized::ParameterFind | [inline]
ParameterFind(const NvParameterized::Interface &iface) | NvParameterized::ParameterFind | [inline]
popNameMatch(void) | NvParameterized::ParameterFind | [inline]
pushNameMatch(void) | NvParameterized::ParameterFind | [inline]
setSearchName(const char *str) | NvParameterized::ParameterFind | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::ParameterList Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • ParameterList
Public Member Functions | Public Attributes
NvParameterized::ParameterList Struct Reference

Parameter list. More...

List of all members.

Public Member Functions

ParameterList (const NvParameterized::Interface &iface, const char *className, const char *paramName, bool recursive, bool classesOnly, NvParameterized::Traits *traits)
Constructor.
bool | nameMatch (const Interface *iface, const char *name, int32_t arrayIndex, DataType type, Handle &handle)
nameMatch
bool | pushName (const char *name, int32_t arrayIndex)
pushName
void | popNameMatch (void)
popNameMatch
bool | isRecursive (void) const
isRecursive
uint32_t | getResultCount (void) const
getResultCount
ParamResult * | getResults (void) const
getResults

Public Attributes

uint32_t | mNameIndex
mNameIndex
Handle mResult
mResult
const NvParameterized::Interface * | mInterface
mInterface
const char * | mClassName
mClassName
const char * | mParamName
mParamName
bool | mRecursive
mRecursive
bool | mClassesOnly
mClassesOnly
NvParameterized::Traits * mTraits
mTraits
uint32_t | mResultCount
mResultCount
uint32_t | mMaxResults
mMaxResults
ParamResult * mResults
mResults
const char * | mSearchName [MAX_SEARCH_NAME]
mSearchName
int32_t | mArrayIndex [MAX_SEARCH_NAME]
mArrayIndex

Detailed Description

Parameter list.

The documentation for this struct was generated from the following file:
  • NvParamUtils.inl
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • ParameterList
NvParameterized::ParameterList Member List
This is the complete list of members for NvParameterized::ParameterList, including all inherited members.
getResultCount(void) const | NvParameterized::ParameterList | [inline]
getResults(void) const | NvParameterized::ParameterList | [inline]
isRecursive(void) const | NvParameterized::ParameterList | [inline]
mArrayIndex | NvParameterized::ParameterList |
mClassesOnly | NvParameterized::ParameterList |
mClassName | NvParameterized::ParameterList |
mInterface | NvParameterized::ParameterList |
mMaxResults | NvParameterized::ParameterList |
mNameIndex | NvParameterized::ParameterList |
mParamName | NvParameterized::ParameterList |
mRecursive | NvParameterized::ParameterList |
mResult | NvParameterized::ParameterList |
mResultCount | NvParameterized::ParameterList |
mResults | NvParameterized::ParameterList |
mSearchName | NvParameterized::ParameterList |
mTraits | NvParameterized::ParameterList |
nameMatch(const Interface *iface, const char *name, int32_t arrayIndex, DataType type, Handle &handle) | NvParameterized::ParameterList | [inline]
ParameterList(const NvParameterized::Interface &iface, const char *className, const char *paramName, bool recursive, bool classesOnly, NvParameterized::Traits *traits) | NvParameterized::ParameterList | [inline]
popNameMatch(void) | NvParameterized::ParameterList | [inline]
pushName(const char *name, int32_t arrayIndex) | NvParameterized::ParameterList | [inline]
~ParameterList(void) (defined in NvParameterized::ParameterList) | NvParameterized::ParameterList | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::SerializePlatform Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • SerializePlatform
Public Types | Public Member Functions | Public Attributes | Static Public Attributes
NvParameterized::SerializePlatform Struct Reference

Platform descriptor. More...

#include <NvSerializer.h>

List of all members.

Public Types

enum ArchType {
ARCH_GEN = 0,
ARCH_X86 = 1,
ARCH_X86_64 = 2,
ARCH_PPC = 3,
ARCH_CELL = 4,
ARCH_ARM = 5,
ARCH_ARM_64 = 6,
ARCH_LAST
}
Processor architectures enumeration. More...
enum CompilerType {
COMP_GEN = 0,
COMP_GCC = 1,
COMP_VC = 2,
COMP_MW = 3,
COMP_LAST
}
Compilers enumeration. More...
enum OsType {
OS_WINDOWS = 0,
OS_LINUX = 1,
OS_LV2 = 2,
OS_MACOSX = 3,
OS_XBOX = 4,
OS_GEN = 5,
OS_ANDROID = 6,
OS_XBOXONE = 7,
OS_PS4 = 8,
OS_HOS = 9,
OS_LAST
}
OSes enumeration. More...

Public Member Functions

PX_INLINE | SerializePlatform (ArchType archType, CompilerType compType, uint32_t compVer, OsType osType, uint32_t osVer)
Constructor of SerializePlatform.
PX_INLINE bool | operator== (const SerializePlatform &p) const
Checks if platforms are binary-compatible.
PX_INLINE bool | operator!= (const SerializePlatform &p) const
Checks if platforms are binary-incompatible.

Public Attributes

ArchType archType
Platform processor architecture.
CompilerType compilerType
Platform compiler.
uint32_t | compilerVer
Platform compiler version.
OsType osType
Platform OS.
uint32_t | osVer
Platform OS version.

Static Public Attributes

static const uint32_t | ANY_VERSION = (uint32_t)-1
This value identfies that version is unknown.

Detailed Description

Platform descriptor.

This class describes target serialization platform which consists of processor architecture, compiler and OS.

Member Enumeration Documentation

enum NvParameterized::SerializePlatform::ArchType

Processor architectures enumeration.

Warning:
Do not change values of enums!
enum NvParameterized::SerializePlatform::CompilerType

Compilers enumeration.

Warning:
Do not change values of enums!
enum NvParameterized::SerializePlatform::OsType

OSes enumeration.

Warning:
Do not change values of enums!
The documentation for this struct was generated from the following files:
  • NvSerializer.h
  • NvSerializer.inl
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • SerializePlatform
NvParameterized::SerializePlatform Member List
This is the complete list of members for NvParameterized::SerializePlatform, including all inherited members.
ANY_VERSION | NvParameterized::SerializePlatform | [static]
ARCH_ARM enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
ARCH_ARM_64 enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
ARCH_CELL enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
ARCH_GEN enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
ARCH_LAST enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
ARCH_PPC enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
ARCH_X86 enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
ARCH_X86_64 enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
archType | NvParameterized::SerializePlatform |
ArchType enum name | NvParameterized::SerializePlatform |
COMP_GCC enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
COMP_GEN enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
COMP_LAST enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
COMP_MW enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
COMP_VC enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
CompilerType enum name | NvParameterized::SerializePlatform |
compilerType | NvParameterized::SerializePlatform |
compilerVer | NvParameterized::SerializePlatform |
operator!=(const SerializePlatform &p) const | NvParameterized::SerializePlatform |
operator==(const SerializePlatform &p) const | NvParameterized::SerializePlatform |
OS_ANDROID enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
OS_GEN enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
OS_HOS enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
OS_LAST enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
OS_LINUX enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
OS_LV2 enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
OS_MACOSX enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
OS_PS4 enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
OS_WINDOWS enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
OS_XBOX enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
OS_XBOXONE enum value (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
osType | NvParameterized::SerializePlatform |
OsType enum name | NvParameterized::SerializePlatform |
osVer | NvParameterized::SerializePlatform |
SerializePlatform() (defined in NvParameterized::SerializePlatform) | NvParameterized::SerializePlatform |
SerializePlatform(ArchType archType, CompilerType compType, uint32_t compVer, OsType osType, uint32_t osVer) | NvParameterized::SerializePlatform |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: NvParameterized::Serializer::MetadataEntry Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Serializer
  • MetadataEntry
Public Attributes
NvParameterized::Serializer::MetadataEntry Struct Reference

This class keeps metadata of a single NvParameterized class. More...

#include <NvSerializer.h>

List of all members.

Public Attributes

const char * | className
Class name.
uint32_t | version
Class version.
Definition * def
Class metadata.

Detailed Description

This class keeps metadata of a single NvParameterized class.

The documentation for this struct was generated from the following file:
  • NvSerializer.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • NvParameterized
  • Serializer
  • MetadataEntry
NvParameterized::Serializer::MetadataEntry Member List
This is the complete list of members for NvParameterized::Serializer::MetadataEntry, including all inherited members.
className | NvParameterized::Serializer::MetadataEntry
def | NvParameterized::Serializer::MetadataEntry
version | NvParameterized::Serializer::MetadataEntry
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::ApexChunkFlag Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexChunkFlag
Public Types
nvidia::apex::ApexChunkFlag Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Types

enum Enum {
DYNAMIC = 1 << 0,
EXTERNALLY_SUPPORTED = 1 << 1,
WORLD_SUPPORTED = 1 << 2,
FRACTURED = 1 << 3,
DESTROYED_FIFO_FULL = 1 << 4,
DESTROYED_TIMED_OUT = 1 << 5,
DESTROYED_EXCEEDED_MAX_DISTANCE = 1 << 6,
DESTROYED_CRUMBLED = 1 << 7,
DESTROYED_LEFT_VALID_BOUNDS = 1 << 8,
DESTROYED_LEFT_USER_BOUNDS = 1 << 9,
DESTROYED_ENTERED_USER_BOUNDS = 1 << 10
}

Detailed Description

Flags returned by an UserChunkReport

Member Enumeration Documentation

enum nvidia::apex::ApexChunkFlag::Enum

Enum of apex chunk flag

Enumerator:
DYNAMIC

The chunk is dynamic

EXTERNALLY_SUPPORTED

The chunk has environmental support, so will remain kinematic until fractured

WORLD_SUPPORTED

Only true if EXTERNALLY_SUPPORTED is true. In addition, this means that it gained support via static geometry overlap.

FRACTURED

The chunk has been fractured

DESTROYED_FIFO_FULL

The chunk has been destroyed because the PxActor FIFO was full

DESTROYED_TIMED_OUT

The chunk has been destroyed because it has exceeded the maximum debris lifetime

DESTROYED_EXCEEDED_MAX_DISTANCE

The chunk has been destroyed because it has exceeded the maximum debris distance

DESTROYED_CRUMBLED

The destroyed chunk has generated crumble particles

DESTROYED_LEFT_VALID_BOUNDS

The destroyed chunk has moved beyond the destructible actor's valid bounds.

DESTROYED_LEFT_USER_BOUNDS

The destroyed chunk has moved beyond the user-defined bounding box.

DESTROYED_ENTERED_USER_BOUNDS

The destroyed chunk has moved into the user-defined bounding box.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexChunkFlag
nvidia::apex::ApexChunkFlag Member List
This is the complete list of members for nvidia::apex::ApexChunkFlag, including all inherited members.
DESTROYED_CRUMBLED enum value | nvidia::apex::ApexChunkFlag
DESTROYED_ENTERED_USER_BOUNDS enum value | nvidia::apex::ApexChunkFlag
DESTROYED_EXCEEDED_MAX_DISTANCE enum value | nvidia::apex::ApexChunkFlag
DESTROYED_FIFO_FULL enum value | nvidia::apex::ApexChunkFlag
DESTROYED_LEFT_USER_BOUNDS enum value | nvidia::apex::ApexChunkFlag
DESTROYED_LEFT_VALID_BOUNDS enum value | nvidia::apex::ApexChunkFlag
DESTROYED_TIMED_OUT enum value | nvidia::apex::ApexChunkFlag
DYNAMIC enum value | nvidia::apex::ApexChunkFlag
Enum enum name | nvidia::apex::ApexChunkFlag
EXTERNALLY_SUPPORTED enum value | nvidia::apex::ApexChunkFlag
FRACTURED enum value | nvidia::apex::ApexChunkFlag
WORLD_SUPPORTED enum value | nvidia::apex::ApexChunkFlag
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ApexMeshParticleRollType Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexMeshParticleRollType
Public Types
nvidia::apex::ApexMeshParticleRollType Struct Reference

Roll type of a particle. More...

#include <ModifierDefs.h>

List of all members.

Public Types

enum Enum {
SPHERICAL = 0,
CUBIC,
FLAT_X,
FLAT_Y,
FLAT_Z,
LONG_X,
LONG_Y,
LONG_Z,
SPRITE,
COUNT
}
Enum of roll type of a particle. More...

Detailed Description

Roll type of a particle.

Member Enumeration Documentation

enum nvidia::apex::ApexMeshParticleRollType::Enum

Enum of roll type of a particle.

Enumerator:
SPHERICAL

roll as a sphere

CUBIC

as a cubical object

FLAT_X

as a flat object (shortest axis is x)

FLAT_Y

as a flat object (shortest axis is y)

FLAT_Z

as a flat object (shortest axis is z)

LONG_X

as a long object (longest axis is x)

LONG_Y

as a long object (longest axis is y)

LONG_Z

as a long object (longest axis is z)

SPRITE

as a sprite

The documentation for this struct was generated from the following file:
  • ModifierDefs.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexMeshParticleRollType
nvidia::apex::ApexMeshParticleRollType Member List
This is the complete list of members for nvidia::apex::ApexMeshParticleRollType, including all inherited members.
COUNT enum value (defined in nvidia::apex::ApexMeshParticleRollType) | nvidia::apex::ApexMeshParticleRollType
CUBIC enum value | nvidia::apex::ApexMeshParticleRollType
Enum enum name | nvidia::apex::ApexMeshParticleRollType
FLAT_X enum value | nvidia::apex::ApexMeshParticleRollType
FLAT_Y enum value | nvidia::apex::ApexMeshParticleRollType
FLAT_Z enum value | nvidia::apex::ApexMeshParticleRollType
LONG_X enum value | nvidia::apex::ApexMeshParticleRollType
LONG_Y enum value | nvidia::apex::ApexMeshParticleRollType
LONG_Z enum value | nvidia::apex::ApexMeshParticleRollType
SPHERICAL enum value | nvidia::apex::ApexMeshParticleRollType
SPRITE enum value | nvidia::apex::ApexMeshParticleRollType
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::BSPOpenMode Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BSPOpenMode
Public Types
nvidia::apex::BSPOpenMode Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Types

enum Enum {
Automatic,
Closed,
Open,
BSPOpenModeCount
}

Detailed Description

Handling of open meshes.

BSPMode::Automatic causes the mesh to be analyzed to determine if it's open or closed BSPOpenMode::Closed means the mesh should be closed and interior faces are created when the mesh is split BSPOpenMode::Open means the mesh should be open and no interior faces are created when it is split

Member Enumeration Documentation

enum nvidia::apex::BSPOpenMode::Enum

Enum of BSP open modes

The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • BSPOpenMode
nvidia::apex::BSPOpenMode Member List
This is the complete list of members for nvidia::apex::BSPOpenMode, including all inherited members.
Automatic enum value (defined in nvidia::apex::BSPOpenMode) | nvidia::apex::BSPOpenMode
BSPOpenModeCount enum value (defined in nvidia::apex::BSPOpenMode) | nvidia::apex::BSPOpenMode
Closed enum value (defined in nvidia::apex::BSPOpenMode) | nvidia::apex::BSPOpenMode
Enum enum name | nvidia::apex::BSPOpenMode
Open enum value (defined in nvidia::apex::BSPOpenMode) | nvidia::apex::BSPOpenMode
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ChunkData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkData
Public Attributes
nvidia::apex::ChunkData Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | index
uint32_t | depth
PxBounds3 | worldBounds
float | damage
uint32_t | flags

Detailed Description

Per-chunk data returned in DamageEventReportData

Member Data Documentation

float nvidia::apex::ChunkData::damage

How much damage the chunk has taken

uint32_t nvidia::apex::ChunkData::depth

The hierarchy depth of the chunk

uint32_t nvidia::apex::ChunkData::flags

Several flags holding chunk information

See also:
ApexChunkFlag
uint32_t nvidia::apex::ChunkData::index

The index of the chunk within the destructible asset

PxBounds3 nvidia::apex::ChunkData::worldBounds

The chunk's axis-aligned bounding box, in world space.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkData
nvidia::apex::ChunkData Member List
This is the complete list of members for nvidia::apex::ChunkData, including all inherited members.
damage | nvidia::apex::ChunkData
depth | nvidia::apex::ChunkData
flags | nvidia::apex::ChunkData
index | nvidia::apex::ChunkData
worldBounds | nvidia::apex::ChunkData
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ChunkParticleReportData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkParticleReportData
Public Attributes
nvidia::apex::ChunkParticleReportData Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

const PxVec3 * | positions
uint32_t | positionCount
const PxVec3 * | velocities
uint32_t | velocityCount

Detailed Description

Particle buffer data returned with UserChunkParticleReport

Member Data Documentation

uint32_t nvidia::apex::ChunkParticleReportData::positionCount

The array length of the positions buffer.

const PxVec3* nvidia::apex::ChunkParticleReportData::positions

Position buffer. The length of this buffer is given by positionCount.

const PxVec3* nvidia::apex::ChunkParticleReportData::velocities

Velocity buffer. The length of this buffer is given by velocityCount. N.B.: The velocity buffer might not have the same length as the positions buffer. It will be one of three lengths: velocityCount = 0: There is no velocity data with these particles. velocityCount = 1: All of the particle velocities are the same, given by *velocities. velocityCount = positionCount: Each particle velocity is given.

uint32_t nvidia::apex::ChunkParticleReportData::velocityCount

The array length of the velocities buffer. (See the description above.)

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkParticleReportData
nvidia::apex::ChunkParticleReportData Member List
This is the complete list of members for nvidia::apex::ChunkParticleReportData, including all inherited members.
positionCount | nvidia::apex::ChunkParticleReportData
positions | nvidia::apex::ChunkParticleReportData
velocities | nvidia::apex::ChunkParticleReportData
velocityCount | nvidia::apex::ChunkParticleReportData
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ChunkStateEventData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkStateEventData
Public Attributes
nvidia::apex::ChunkStateEventData Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

DestructibleActor * destructible
const DestructibleChunkEvent * | stateEventList
uint32_t | stateEventListSize

Detailed Description

Chunk state event data pushed to the user, if the user requests it via ModuleDestructible::scheduleChunkStateEventCallback.

Member Data Documentation

DestructibleActor* nvidia::apex::ChunkStateEventData::destructible

The DestructibleActor instance that these chunks belong to

const DestructibleChunkEvent* nvidia::apex::ChunkStateEventData::stateEventList

Array of chunk state event data collected since the last UserChunkReport::onStateChangeNotify call.

uint32_t nvidia::apex::ChunkStateEventData::stateEventListSize

Size of the stateEventList array

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkStateEventData
nvidia::apex::ChunkStateEventData Member List
This is the complete list of members for nvidia::apex::ChunkStateEventData, including all inherited members.
destructible | nvidia::apex::ChunkStateEventData
stateEventList | nvidia::apex::ChunkStateEventData
stateEventListSize | nvidia::apex::ChunkStateEventData
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ChunkTransformHeader Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkTransformHeader
Public Attributes
nvidia::apex::ChunkTransformHeader Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | userActorID
User actor ID.
uint32_t | chunkTransformCount
Chunk transform count.
ChunkTransformUnit * chunkTransformBufferStart
Chunk transform buffer start.
ChunkTransformHeader * next
Pointer to next ChunkTransformHeader structure.

Detailed Description

Chunk transform header.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkTransformHeader
nvidia::apex::ChunkTransformHeader Member List
This is the complete list of members for nvidia::apex::ChunkTransformHeader, including all inherited members.
chunkTransformBufferStart | nvidia::apex::ChunkTransformHeader
chunkTransformCount | nvidia::apex::ChunkTransformHeader
next | nvidia::apex::ChunkTransformHeader
userActorID | nvidia::apex::ChunkTransformHeader
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ChunkTransformUnit Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkTransformUnit
Public Attributes
nvidia::apex::ChunkTransformUnit Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | chunkIndex
Chunk index.
PxVec3 | chunkPosition
Position.
PxQuat | chunkOrientation
Chunk orientation.

Detailed Description

Chunk transform unit.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ChunkTransformUnit
nvidia::apex::ChunkTransformUnit Member List
This is the complete list of members for nvidia::apex::ChunkTransformUnit, including all inherited members.
chunkIndex | nvidia::apex::ChunkTransformUnit
chunkOrientation | nvidia::apex::ChunkTransformUnit
chunkPosition | nvidia::apex::ChunkTransformUnit
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothSolverMode Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothSolverMode
Public Types
nvidia::apex::ClothSolverMode Struct Reference

Describes the solver that is used to simulate the clothing actor. More...

#include <ClothingAsset.h>

List of all members.

Public Types

enum Enum { v3 }
the enum type More...

Detailed Description

Describes the solver that is used to simulate the clothing actor.

Member Enumeration Documentation

enum nvidia::apex::ClothSolverMode::Enum

the enum type

Enumerator:
v3

The actor is simulated using the 3.x cloth solver.

The documentation for this struct was generated from the following file:
  • ClothingAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothSolverMode
nvidia::apex::ClothSolverMode Member List
This is the complete list of members for nvidia::apex::ClothSolverMode, including all inherited members.
Enum enum name | nvidia::apex::ClothSolverMode
v3 enum value | nvidia::apex::ClothSolverMode
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingCollisionType Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingCollisionType
Public Types
nvidia::apex::ClothingCollisionType Struct Reference

Type of the ClothingCollision. More...

#include <ClothingCollision.h>

List of all members.

Public Types

enum Enum {
Plane,
Convex,
Sphere,
Capsule,
TriangleMesh
}
Enum.

Detailed Description

Type of the ClothingCollision.

The documentation for this struct was generated from the following file:
  • ClothingCollision.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingCollisionType
nvidia::apex::ClothingCollisionType Member List
This is the complete list of members for nvidia::apex::ClothingCollisionType, including all inherited members.
Capsule enum value (defined in nvidia::apex::ClothingCollisionType) | nvidia::apex::ClothingCollisionType
Convex enum value (defined in nvidia::apex::ClothingCollisionType) | nvidia::apex::ClothingCollisionType
Enum enum name | nvidia::apex::ClothingCollisionType
Plane enum value (defined in nvidia::apex::ClothingCollisionType) | nvidia::apex::ClothingCollisionType
Sphere enum value (defined in nvidia::apex::ClothingCollisionType) | nvidia::apex::ClothingCollisionType
TriangleMesh enum value (defined in nvidia::apex::ClothingCollisionType) | nvidia::apex::ClothingCollisionType
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingConstrainCoefficients Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingConstrainCoefficients
Public Attributes
nvidia::apex::ClothingConstrainCoefficients Struct Reference

Constrain coefficients of the physical mesh vertices. More...

#include <ClothingPhysicalMesh.h>

List of all members.

Public Attributes

float | maxDistance
Maximum distance a vertex is allowed to move.
float | collisionSphereRadius
Backstop sphere radius.
float | collisionSphereDistance
Backstop sphere distance.

Detailed Description

Constrain coefficients of the physical mesh vertices.

The documentation for this struct was generated from the following file:
  • ClothingPhysicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingConstrainCoefficients
nvidia::apex::ClothingConstrainCoefficients Member List
This is the complete list of members for nvidia::apex::ClothingConstrainCoefficients, including all inherited members.
collisionSphereDistance | nvidia::apex::ClothingConstrainCoefficients
collisionSphereRadius | nvidia::apex::ClothingConstrainCoefficients
maxDistance | nvidia::apex::ClothingConstrainCoefficients
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingMeshSkinningMap Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingMeshSkinningMap
Public Attributes
nvidia::apex::ClothingMeshSkinningMap Struct Reference

Maps from a triangle of the simulated mesh to a vertex of the rendered mesh. The barycentric coordinates describe the position of a point in space relative to a simulated triangle. The actual z-coordinate is computed by bary.z = 1 - bary.x - bary.y. The z part of the vector contains the height of the skinned vertex along the normal of the simulated triangle. More...

#include <ClothingAsset.h>

List of all members.

Public Attributes

PxVec3 | positionBary
Barycentric coordinates of the graphical vertex relative to the simulated triangle.
uint32_t | vertexIndex0
First vertex of the simulated triangle.
PxVec3 | normalBary
Barycentric coordinates of a point that represents the normal. The actual normal can be extracted by subtracting the skinned position from this point.
uint32_t | vertexIndex1
Second vertex of the simulated triangle.
PxVec3 | tangentBary
Barycentric coordinates of a point that represents the tangent. The actual tangent can be extracted by subtracting the skinned position from this point.
uint32_t | vertexIndex2
Third vertex of the simulated triangle.

Detailed Description

Maps from a triangle of the simulated mesh to a vertex of the rendered mesh. The barycentric coordinates describe the position of a point in space relative to a simulated triangle. The actual z-coordinate is computed by bary.z = 1 - bary.x - bary.y. The z part of the vector contains the height of the skinned vertex along the normal of the simulated triangle.

So, the following computes the new skinned position:

uint32_t i0 = map[mapId].vertexIndex0; uint32_t i1 = map[mapId].vertexIndex1; uint32_t i2 = map[mapId].vertexIndex2;

PxVec3 bary = map[mapId].positionBary; float heightOffset = bary.z * actorScale; bary.z = (1 - bary.x - bary.y);

PxVec3 posOnTriangle = physPositions[i0] * bary.x + physPositions[i1] * bary.y + physPositions[i2] * bary.z;

offsetFromTriangle = (physNormals[i0] * bary.x + physNormals[i1] * bary.y + physNormals[i2] * bary.z) heightOffset;

skinnedPos = posOnTriangle + offsetFromTriangle;

Member Data Documentation

PxVec3 nvidia::apex::ClothingMeshSkinningMap::normalBary

Barycentric coordinates of a point that represents the normal. The actual normal can be extracted by subtracting the skinned position from this point.

Note:
PX_MAX_F32 values represent invalid coordinates.
PxVec3 nvidia::apex::ClothingMeshSkinningMap::positionBary

Barycentric coordinates of the graphical vertex relative to the simulated triangle.

Note:
PX_MAX_F32 values represent invalid coordinates.
PxVec3 nvidia::apex::ClothingMeshSkinningMap::tangentBary

Barycentric coordinates of a point that represents the tangent. The actual tangent can be extracted by subtracting the skinned position from this point.

Note:
PX_MAX_F32 values represent invalid coordinates.
The documentation for this struct was generated from the following file:
  • ClothingAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingMeshSkinningMap
nvidia::apex::ClothingMeshSkinningMap Member List
This is the complete list of members for nvidia::apex::ClothingMeshSkinningMap, including all inherited members.
normalBary | nvidia::apex::ClothingMeshSkinningMap
positionBary | nvidia::apex::ClothingMeshSkinningMap
tangentBary | nvidia::apex::ClothingMeshSkinningMap
vertexIndex0 | nvidia::apex::ClothingMeshSkinningMap
vertexIndex1 | nvidia::apex::ClothingMeshSkinningMap
vertexIndex2 | nvidia::apex::ClothingMeshSkinningMap
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingPhysicalMeshStats Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPhysicalMeshStats
Public Attributes
nvidia::apex::ClothingPhysicalMeshStats Struct Reference

Contains the data for handing out statistics about a ClothingPhysicalMesh. More...

#include <ClothingPhysicalMesh.h>

List of all members.

Public Attributes

uint32_t | totalBytes
the number of bytes allocated for the physical mesh
uint32_t | numVertices
the number of vertices
uint32_t | numIndices
the number of indices

Detailed Description

Contains the data for handing out statistics about a ClothingPhysicalMesh.

The documentation for this struct was generated from the following file:
  • ClothingPhysicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingPhysicalMeshStats
nvidia::apex::ClothingPhysicalMeshStats Member List
This is the complete list of members for nvidia::apex::ClothingPhysicalMeshStats, including all inherited members.
numIndices | nvidia::apex::ClothingPhysicalMeshStats
numVertices | nvidia::apex::ClothingPhysicalMeshStats
totalBytes | nvidia::apex::ClothingPhysicalMeshStats
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ClothingTeleportMode Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingTeleportMode
Public Types
nvidia::apex::ClothingTeleportMode Struct Reference

selects the mode the clothing actor will be in the simulation frame More...

#include <ClothingActor.h>

List of all members.

Public Types

enum Enum {
Continuous,
Teleport,
TeleportAndReset
}
the enum type More...

Detailed Description

selects the mode the clothing actor will be in the simulation frame

Member Enumeration Documentation

enum nvidia::apex::ClothingTeleportMode::Enum

the enum type

Enumerator:
Continuous

Simulation continues smoothly. This is the most commonly used mode.

Teleport

Transforms the current simulation state from the old global pose to the new global pose.

This will transform positions and velocities and thus keep the simulation state, just translate it to a new pose.

TeleportAndReset

Forces the cloth to the animated position in the next frame.

This can be used to reset it from a bad state or by a teleport where the old state is not important anymore.

The documentation for this struct was generated from the following file:
  • ClothingActor.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ClothingTeleportMode
nvidia::apex::ClothingTeleportMode Member List
This is the complete list of members for nvidia::apex::ClothingTeleportMode, including all inherited members.
Continuous enum value | nvidia::apex::ClothingTeleportMode
Enum enum name | nvidia::apex::ClothingTeleportMode
Teleport enum value | nvidia::apex::ClothingTeleportMode
TeleportAndReset enum value | nvidia::apex::ClothingTeleportMode
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::CollisionDesc Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CollisionDesc
Public Member Functions | Public Attributes
nvidia::apex::CollisionDesc Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

CollisionDesc ()
void | setToDefault ()

Public Attributes

unsigned | mDepthCount
CollisionVolumeDesc * mVolumeDescs
float | mMaximumTrimming

Detailed Description

Collision descriptor

Constructor & Destructor Documentation

nvidia::apex::CollisionDesc::CollisionDesc ( ) [inline]

Constructor sets default values.

Member Function Documentation

void nvidia::apex::CollisionDesc::setToDefault ( ) [inline]

Set CollisionDesc to default values

Member Data Documentation

unsigned nvidia::apex::CollisionDesc::mDepthCount

How many collision volume descriptors are in the mVolumeDescs array.

This count need not match the depth count of the destructible to be created. If it is greater than the depth count of the destructible, the extra volume descriptors will be ignored. If it is less than the depth count of the destructible, then mVolumeDescs[depthCount-1] will be used unless depthCount is zero. In that case, the defeult CollisionVolumeDesc() will be used.

This may be zero, in which case all volume descriptors will be the default values. If it is not zero, mVolumeDescs must be a valid pointer.

float nvidia::apex::CollisionDesc::mMaximumTrimming

The maximum amount to trim overlapping collision hulls (as a percentage of the hulls' widths)

Default = 0.2f

CollisionVolumeDesc* nvidia::apex::CollisionDesc::mVolumeDescs

Array of volume descriptors of length depthCount (may be NULL if depthCount is zero).

The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CollisionDesc
nvidia::apex::CollisionDesc Member List
This is the complete list of members for nvidia::apex::CollisionDesc, including all inherited members.
CollisionDesc() | nvidia::apex::CollisionDesc | [inline]
mDepthCount | nvidia::apex::CollisionDesc |
mMaximumTrimming | nvidia::apex::CollisionDesc |
mVolumeDescs | nvidia::apex::CollisionDesc |
setToDefault() | nvidia::apex::CollisionDesc | [inline]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::CollisionVolumeDesc Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CollisionVolumeDesc
Public Member Functions | Public Attributes
nvidia::apex::CollisionVolumeDesc Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

void | setToDefault ()

Public Attributes

ConvexHullMethod::Enum mHullMethod
float | mConcavityPercent
float | mMergeThreshold
uint32_t | mRecursionDepth
uint32_t | mMaxVertexCount
uint32_t | mMaxEdgeCount
uint32_t | mMaxFaceCount

Detailed Description

Collision volume descriptor for a chunk

Member Function Documentation

void nvidia::apex::CollisionVolumeDesc::setToDefault ( ) [inline]

Set CollisionVolumeDesc to default values

Member Data Documentation

float nvidia::apex::CollisionVolumeDesc::mConcavityPercent

Allowed concavity if mHullMethod = ConvexHullMethod::CONVEX_DECOMPOSITION. Default = 4.0.

ConvexHullMethod::Enum nvidia::apex::CollisionVolumeDesc::mHullMethod

How to generate convex hulls for a chunk. See ConvexHullMethod::Enum. Default = CONVEX_DECOMPOSITION.

uint32_t nvidia::apex::CollisionVolumeDesc::mMaxEdgeCount

The maximum number of edges each hull may have. If 0, there is no limit. Default = 0.

uint32_t nvidia::apex::CollisionVolumeDesc::mMaxFaceCount

The maximum number of faces each hull may have. If 0, there is no limit. Default = 0.

uint32_t nvidia::apex::CollisionVolumeDesc::mMaxVertexCount

The maximum number of vertices each hull may have. If 0, there is no limit. Default = 0.

float nvidia::apex::CollisionVolumeDesc::mMergeThreshold

Merge threshold if mHullMethod = ConvexHullMethod::CONVEX_DECOMPOSITION. Default = 4.0.

uint32_t nvidia::apex::CollisionVolumeDesc::mRecursionDepth

Recursion depth if mHullMethod = ConvexHullMethod::CONVEX_DECOMPOSITION. Depth = 0 generates a single convex hull. Higher recursion depths may generate more convex hulls to fit the mesh. Default = 0.

The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • CollisionVolumeDesc
nvidia::apex::CollisionVolumeDesc Member List
This is the complete list of members for nvidia::apex::CollisionVolumeDesc, including all inherited members.
CollisionVolumeDesc() (defined in nvidia::apex::CollisionVolumeDesc) | nvidia::apex::CollisionVolumeDesc | [inline]
mConcavityPercent | nvidia::apex::CollisionVolumeDesc |
mHullMethod | nvidia::apex::CollisionVolumeDesc |
mMaxEdgeCount | nvidia::apex::CollisionVolumeDesc |
mMaxFaceCount | nvidia::apex::CollisionVolumeDesc |
mMaxVertexCount | nvidia::apex::CollisionVolumeDesc |
mMergeThreshold | nvidia::apex::CollisionVolumeDesc |
mRecursionDepth | nvidia::apex::CollisionVolumeDesc |
setToDefault() | nvidia::apex::CollisionVolumeDesc | [inline]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ColorRGBA Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorRGBA
Public Member Functions | Public Attributes
nvidia::apex::ColorRGBA Struct Reference

Color stored in 32 bits. More...

#include <VertexFormat.h>

List of all members.

Public Member Functions

ColorRGBA ()
Constructor.
ColorRGBA (uint8_t _r, uint8_t _g, uint8_t _b, uint8_t _a)
Constructor.

Public Attributes

uint8_t | r
color
uint8_t | g
color
uint8_t | b
color
uint8_t | a
color

Detailed Description

Color stored in 32 bits.

The documentation for this struct was generated from the following file:
  • VertexFormat.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorRGBA
nvidia::apex::ColorRGBA Member List
This is the complete list of members for nvidia::apex::ColorRGBA, including all inherited members.
a | nvidia::apex::ColorRGBA |
b | nvidia::apex::ColorRGBA |
ColorRGBA() | nvidia::apex::ColorRGBA | [inline]
ColorRGBA(uint8_t _r, uint8_t _g, uint8_t _b, uint8_t _a) | nvidia::apex::ColorRGBA | [inline]
g | nvidia::apex::ColorRGBA |
r | nvidia::apex::ColorRGBA |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::ConvexHullMethod Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ConvexHullMethod
Public Types
nvidia::apex::ConvexHullMethod Struct Reference

Method by which chunk mesh collision hulls are generated. More...

#include <ConvexHullMethod.h>

List of all members.

Public Types

enum Enum {
USE_6_DOP,
USE_10_DOP_X,
USE_10_DOP_Y,
USE_10_DOP_Z,
USE_14_DOP_XY,
USE_14_DOP_YZ,
USE_14_DOP_ZX,
USE_18_DOP,
USE_26_DOP,
WRAP_GRAPHICS_MESH,
CONVEX_DECOMPOSITION,
COUNT
}
Enum of methods by which chunk mesh collision hulls are generated.

Detailed Description

Method by which chunk mesh collision hulls are generated.

The documentation for this struct was generated from the following file:
  • ConvexHullMethod.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ConvexHullMethod
nvidia::apex::ConvexHullMethod Member List
This is the complete list of members for nvidia::apex::ConvexHullMethod, including all inherited members.
CONVEX_DECOMPOSITION enum value (defined in nvidia::apex::ConvexHullMethod) | nvidia::apex::ConvexHullMethod
COUNT enum value (defined in nvidia::apex::ConvexHullMethod) | nvidia::apex::ConvexHullMethod
Enum enum name | nvidia::apex::ConvexHullMethod
USE_10_DOP_X enum value (defined in nvidia::apex::ConvexHullMethod) | nvidia::apex::ConvexHullMethod
USE_10_DOP_Y enum value (defined in nvidia::apex::ConvexHullMethod) | nvidia::apex::ConvexHullMethod
USE_10_DOP_Z enum value (defined in nvidia::apex::ConvexHullMethod) | nvidia::apex::ConvexHullMethod
USE_14_DOP_XY enum value (defined in nvidia::apex::ConvexHullMethod) | nvidia::apex::ConvexHullMethod
USE_14_DOP_YZ enum value (defined in nvidia::apex::ConvexHullMethod) | nvidia::apex::ConvexHullMethod
USE_14_DOP_ZX enum value (defined in nvidia::apex::ConvexHullMethod) | nvidia::apex::ConvexHullMethod
USE_18_DOP enum value (defined in nvidia::apex::ConvexHullMethod) | nvidia::apex::ConvexHullMethod
USE_26_DOP enum value (defined in nvidia::apex::ConvexHullMethod) | nvidia::apex::ConvexHullMethod
USE_6_DOP enum value (defined in nvidia::apex::ConvexHullMethod) | nvidia::apex::ConvexHullMethod
WRAP_GRAPHICS_MESH enum value (defined in nvidia::apex::ConvexHullMethod) | nvidia::apex::ConvexHullMethod
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DamageEventCoreData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventCoreData
Public Attributes
nvidia::apex::DamageEventCoreData Struct Reference

#include <ModuleDestructible.h>

Inheritance diagram for nvidia::apex::DamageEventCoreData:
nvidia::apex::ImpactDamageEventData

List of all members.

Public Attributes

int32_t | chunkIndexInAsset
Which chunk the damage is being applied to (non-range based damage)
PxVec3 | position
The position, in world space, where the damage event is originating from.
float | damage
The amount of damage.
float | radius
The radius of the damage, if this is a range based damage event.

Detailed Description

The core data of Damage Event. It is used for sync damage coloring.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventCoreData
nvidia::apex::DamageEventCoreData Member List
This is the complete list of members for nvidia::apex::DamageEventCoreData, including all inherited members.
chunkIndexInAsset | nvidia::apex::DamageEventCoreData
damage | nvidia::apex::DamageEventCoreData
position | nvidia::apex::DamageEventCoreData
radius | nvidia::apex::DamageEventCoreData
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DamageEventHeader Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventHeader
Public Attributes
nvidia::apex::DamageEventHeader Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | userActorID
User actor ID.
uint32_t | damageEventCount
Damage event count.
DamageEventUnit * damageEventBufferStart
damage event buffer size
DamageEventHeader * next
Pointer to next DamageEventHeader structure.

Detailed Description

Damage event header.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventHeader
nvidia::apex::DamageEventHeader Member List
This is the complete list of members for nvidia::apex::DamageEventHeader, including all inherited members.
damageEventBufferStart | nvidia::apex::DamageEventHeader
damageEventCount | nvidia::apex::DamageEventHeader
next | nvidia::apex::DamageEventHeader
userActorID | nvidia::apex::DamageEventHeader
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DamageEventReportData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventReportData
Public Attributes
nvidia::apex::DamageEventReportData Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

DestructibleActor * destructible
PxVec3 | hitDirection
PxBounds3 | worldBounds
uint32_t | totalNumberOfFractureEvents
uint16_t | minDepth
uint16_t | maxDepth
const ChunkData * | fractureEventList
uint32_t | fractureEventListSize
physx::PxActor const * | impactDamageActor
PxVec3 | hitPosition
void * | appliedDamageUserData

Detailed Description

Per-actor damage event data returned by an UserChunkReport

Member Data Documentation

void* nvidia::apex::DamageEventReportData::appliedDamageUserData

User data from applyDamage or applyRadiusDamage.

DestructibleActor* nvidia::apex::DamageEventReportData::destructible

The DestructibleActor instance that these chunks belong to

const ChunkData* nvidia::apex::DamageEventReportData::fractureEventList

Array of chunk fracture event data for all chunks above a size threshold, which have flags that overlap the module's chunkReportBitMask (see ModuleDestructible::setChunkReportBitMask). Currently the size cutoff is determined by the ModuleDestructible's chunkReportMaxFractureEventDepth (See ModuleDestructible::setChunkReportMaxFractureEventDepth). All chunks up to that depth, but no deeper, are reported in this list. The size of this array is given by fractureEventListSize. fractureEventList may be NULL if fractureEventListSize = 0.

uint32_t nvidia::apex::DamageEventReportData::fractureEventListSize

Size of the fractureEventList array. This may be less than totalNumberOfFractureEvents if some of the fracture events involve chunks which do not meet the size criterion described in the notes for the fractureEventList array.

PxVec3 nvidia::apex::DamageEventReportData::hitDirection

Damage event hitDirection in world space.

PxVec3 nvidia::apex::DamageEventReportData::hitPosition

Impact damage position in world-space.

physx::PxActor const* nvidia::apex::DamageEventReportData::impactDamageActor

Other PhysX actor that caused damage to DamageEventReportData.

uint16_t nvidia::apex::DamageEventReportData::maxDepth

Max depth of chunk fracture events caused by this damage event, which have flags that overlap the module's chunkReportBitMask (see ModuleDestructible::setChunkReportBitMask).

uint16_t nvidia::apex::DamageEventReportData::minDepth

Min depth of chunk fracture events caused by this damage event, which have flags that overlap the module's chunkReportBitMask (see ModuleDestructible::setChunkReportBitMask).

uint32_t nvidia::apex::DamageEventReportData::totalNumberOfFractureEvents

Total number of fracture events caused by this damage event, which have flags that overlap the module's chunkReportBitMask (see ModuleDestructible::setChunkReportBitMask).

PxBounds3 nvidia::apex::DamageEventReportData::worldBounds

The axis-aligned bounding box of all chunk fractures caused by this damage event, which have flags that overlap the module's chunkReportBitMask (see ModuleDestructible::setChunkReportBitMask).

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventReportData
nvidia::apex::DamageEventReportData Member List
This is the complete list of members for nvidia::apex::DamageEventReportData, including all inherited members.
appliedDamageUserData | nvidia::apex::DamageEventReportData
destructible | nvidia::apex::DamageEventReportData
fractureEventList | nvidia::apex::DamageEventReportData
fractureEventListSize | nvidia::apex::DamageEventReportData
hitDirection | nvidia::apex::DamageEventReportData
hitPosition | nvidia::apex::DamageEventReportData
impactDamageActor | nvidia::apex::DamageEventReportData
maxDepth | nvidia::apex::DamageEventReportData
minDepth | nvidia::apex::DamageEventReportData
totalNumberOfFractureEvents | nvidia::apex::DamageEventReportData
worldBounds | nvidia::apex::DamageEventReportData
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DamageEventUnit Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventUnit
Public Attributes
nvidia::apex::DamageEventUnit Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | chunkIndex
Chunk index.
uint32_t | damageEventFlags
Damage event flags.
float | damage
Damage value.
float | momentum
Momentum.
float | radius
Radius.
PxVec3 | position
Position.
PxVec3 | direction
Direction.

Detailed Description

Damage event unit.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageEventUnit
nvidia::apex::DamageEventUnit Member List
This is the complete list of members for nvidia::apex::DamageEventUnit, including all inherited members.
chunkIndex | nvidia::apex::DamageEventUnit
damage | nvidia::apex::DamageEventUnit
damageEventFlags | nvidia::apex::DamageEventUnit
direction | nvidia::apex::DamageEventUnit
momentum | nvidia::apex::DamageEventUnit
position | nvidia::apex::DamageEventUnit
radius | nvidia::apex::DamageEventUnit
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DamageSpreadFunction Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageSpreadFunction
Public Member Functions | Public Attributes
nvidia::apex::DamageSpreadFunction Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Member Functions

PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE bool | isValid () const

Public Attributes

float | minimumRadius
minimum radius
float | radiusMultiplier
radius multiplier
float | falloffExponent
falloff exponent

Detailed Description

DamageSpreadFunction

Member Function Documentation

PX_INLINE bool nvidia::apex::DamageSpreadFunction::isValid ( ) const [inline]

Returns true iff an object can be created using this descriptor.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DamageSpreadFunction
nvidia::apex::DamageSpreadFunction Member List
This is the complete list of members for nvidia::apex::DamageSpreadFunction, including all inherited members.
DamageSpreadFunction() (defined in nvidia::apex::DamageSpreadFunction) | nvidia::apex::DamageSpreadFunction | [inline]
falloffExponent | nvidia::apex::DamageSpreadFunction |
isValid() const | nvidia::apex::DamageSpreadFunction | [inline]
minimumRadius | nvidia::apex::DamageSpreadFunction |
radiusMultiplier | nvidia::apex::DamageSpreadFunction |
setToDefault() | nvidia::apex::DamageSpreadFunction | [inline]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleActorChunkFlags Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorChunkFlags
Public Types
nvidia::apex::DestructibleActorChunkFlags Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Types

enum Enum { ChunkIsWorldSupported = (1<<0) }

Detailed Description

Flags which describe an actor chunk (as opposed to an asset chunk) - takes into account the actor's condition, for example a chunk may be world supported because of the actor's placement

Member Enumeration Documentation

enum nvidia::apex::DestructibleActorChunkFlags::Enum

Enum of destructible actor chunk flags

Enumerator:
ChunkIsWorldSupported

"Use world support" is set in the destructible parameters, and this chunk is a support-depth chunk that overlaps the physx scene's static geometry

The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorChunkFlags
nvidia::apex::DestructibleActorChunkFlags Member List
This is the complete list of members for nvidia::apex::DestructibleActorChunkFlags, including all inherited members.
ChunkIsWorldSupported enum value | nvidia::apex::DestructibleActorChunkFlags
Enum enum name | nvidia::apex::DestructibleActorChunkFlags
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleActorMeshType Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorMeshType
Public Types
nvidia::apex::DestructibleActorMeshType Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Types

enum Enum {
Skinned,
Static,
Count
}

Detailed Description

Render mesh distinction, skinned vs. static

Member Enumeration Documentation

enum nvidia::apex::DestructibleActorMeshType::Enum

Enum for destructible actor mesh type.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorMeshType
nvidia::apex::DestructibleActorMeshType Member List
This is the complete list of members for nvidia::apex::DestructibleActorMeshType, including all inherited members.
Count enum value (defined in nvidia::apex::DestructibleActorMeshType) | nvidia::apex::DestructibleActorMeshType
Enum enum name | nvidia::apex::DestructibleActorMeshType
Skinned enum value (defined in nvidia::apex::DestructibleActorMeshType) | nvidia::apex::DestructibleActorMeshType
Static enum value (defined in nvidia::apex::DestructibleActorMeshType) | nvidia::apex::DestructibleActorMeshType
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleActorRaycastFlags Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorRaycastFlags
Public Types
nvidia::apex::DestructibleActorRaycastFlags Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Types

enum Enum {
NoChunks = (0),
StaticChunks = (1 << 0),
DynamicChunks = (1 << 1),
AllChunks = StaticChunks | DynamicChunks,
SegmentIntersect = (1 << 2),
ForceAccurateRaycastsOn = (1 << 3),
ForceAccurateRaycastsOff = (1 << 4)
}

Detailed Description

Flags for DestructibleActor::raycast()

Member Enumeration Documentation

enum nvidia::apex::DestructibleActorRaycastFlags::Enum

Enum of destructible actor raycast flags.

Enumerator:
SegmentIntersect

Do not consider intersect times > 1.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorRaycastFlags
nvidia::apex::DestructibleActorRaycastFlags Member List
This is the complete list of members for nvidia::apex::DestructibleActorRaycastFlags, including all inherited members.
AllChunks enum value (defined in nvidia::apex::DestructibleActorRaycastFlags) | nvidia::apex::DestructibleActorRaycastFlags
DynamicChunks enum value (defined in nvidia::apex::DestructibleActorRaycastFlags) | nvidia::apex::DestructibleActorRaycastFlags
Enum enum name | nvidia::apex::DestructibleActorRaycastFlags
ForceAccurateRaycastsOff enum value (defined in nvidia::apex::DestructibleActorRaycastFlags) | nvidia::apex::DestructibleActorRaycastFlags
ForceAccurateRaycastsOn enum value (defined in nvidia::apex::DestructibleActorRaycastFlags) | nvidia::apex::DestructibleActorRaycastFlags
NoChunks enum value (defined in nvidia::apex::DestructibleActorRaycastFlags) | nvidia::apex::DestructibleActorRaycastFlags
SegmentIntersect enum value | nvidia::apex::DestructibleActorRaycastFlags
StaticChunks enum value (defined in nvidia::apex::DestructibleActorRaycastFlags) | nvidia::apex::DestructibleActorRaycastFlags
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleActorSyncFlags Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorSyncFlags
Public Types
nvidia::apex::DestructibleActorSyncFlags Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Types

enum Enum {
None = 0,
CopyDamageEvents = (1 << 0),
ReadDamageEvents = (1 << 1),
CopyFractureEvents = (1 << 2),
ReadFractureEvents = (1 << 3),
CopyChunkTransform = (1 << 4),
ReadChunkTransform = (1 << 5),
Last = (1 << 6)
}

Detailed Description

Flags for managing the sync state of the destructible actor

Member Enumeration Documentation

enum nvidia::apex::DestructibleActorSyncFlags::Enum

Enum of destructible actor sync flags

The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorSyncFlags
nvidia::apex::DestructibleActorSyncFlags Member List
This is the complete list of members for nvidia::apex::DestructibleActorSyncFlags, including all inherited members.
CopyChunkTransform enum value (defined in nvidia::apex::DestructibleActorSyncFlags) | nvidia::apex::DestructibleActorSyncFlags
CopyDamageEvents enum value (defined in nvidia::apex::DestructibleActorSyncFlags) | nvidia::apex::DestructibleActorSyncFlags
CopyFractureEvents enum value (defined in nvidia::apex::DestructibleActorSyncFlags) | nvidia::apex::DestructibleActorSyncFlags
Enum enum name | nvidia::apex::DestructibleActorSyncFlags
Last enum value (defined in nvidia::apex::DestructibleActorSyncFlags) | nvidia::apex::DestructibleActorSyncFlags
None enum value (defined in nvidia::apex::DestructibleActorSyncFlags) | nvidia::apex::DestructibleActorSyncFlags
ReadChunkTransform enum value (defined in nvidia::apex::DestructibleActorSyncFlags) | nvidia::apex::DestructibleActorSyncFlags
ReadDamageEvents enum value (defined in nvidia::apex::DestructibleActorSyncFlags) | nvidia::apex::DestructibleActorSyncFlags
ReadFractureEvents enum value (defined in nvidia::apex::DestructibleActorSyncFlags) | nvidia::apex::DestructibleActorSyncFlags
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleActorSyncState Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorSyncState
Public Attributes
nvidia::apex::DestructibleActorSyncState Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Attributes

uint32_t | damageEventFilterDepth
dictates the (inclusive) maximum depth at which damage events will be buffered.
uint32_t | fractureEventFilterDepth
dictates the (inclusive) maximum depth at which fracture events will be buffered.

Detailed Description

Tweak-able parameters on source-side for controlling the actor sync state.

The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleActorSyncState
nvidia::apex::DestructibleActorSyncState Member List
This is the complete list of members for nvidia::apex::DestructibleActorSyncState, including all inherited members.
damageEventFilterDepth | nvidia::apex::DestructibleActorSyncState
fractureEventFilterDepth | nvidia::apex::DestructibleActorSyncState
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleAssetStats Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAssetStats
Public Attributes
nvidia::apex::DestructibleAssetStats Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Attributes

uint32_t | totalBytes
total bytes
uint32_t | chunkCount
chunk count
uint32_t | chunkBytes
chunk bytes
uint32_t | chunkHullDataBytes
chunk hull data bytes
uint32_t | collisionCookedHullDataBytes
collision cooked hull data bytes
uint32_t | collisionMeshCount
collision mesh count
uint32_t | maxHullVertexCount
max hull vertex count
uint32_t | maxHullFaceCount
max hull face count
uint32_t | chunkWithMaxEdgeCount
chunk with max edge count
uint32_t | runtimeCookedConvexCount
runtime cooked convex count
RenderMeshAssetStats renderMeshAssetStats
render mesh asset stats

Detailed Description

Stats for an DestructibleAsset: memory usage, counts, etc.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleAssetStats
nvidia::apex::DestructibleAssetStats Member List
This is the complete list of members for nvidia::apex::DestructibleAssetStats, including all inherited members.
chunkBytes | nvidia::apex::DestructibleAssetStats
chunkCount | nvidia::apex::DestructibleAssetStats
chunkHullDataBytes | nvidia::apex::DestructibleAssetStats
chunkWithMaxEdgeCount | nvidia::apex::DestructibleAssetStats
collisionCookedHullDataBytes | nvidia::apex::DestructibleAssetStats
collisionMeshCount | nvidia::apex::DestructibleAssetStats
maxHullFaceCount | nvidia::apex::DestructibleAssetStats
maxHullVertexCount | nvidia::apex::DestructibleAssetStats
renderMeshAssetStats | nvidia::apex::DestructibleAssetStats
runtimeCookedConvexCount | nvidia::apex::DestructibleAssetStats
totalBytes | nvidia::apex::DestructibleAssetStats
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleCallbackSchedule Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleCallbackSchedule
Public Types
nvidia::apex::DestructibleCallbackSchedule Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Types

enum Enum {
Disabled = (0),
BeforeTick,
FetchResults,
Count
}

Detailed Description

Enum to control when callbacks are fired.

Member Enumeration Documentation

enum nvidia::apex::DestructibleCallbackSchedule::Enum

Enum of destructible callback schedule

Enumerator:
BeforeTick

Called by the simulation thread.

FetchResults

Called by an application thread.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleCallbackSchedule
nvidia::apex::DestructibleCallbackSchedule Member List
This is the complete list of members for nvidia::apex::DestructibleCallbackSchedule, including all inherited members.
BeforeTick enum value | nvidia::apex::DestructibleCallbackSchedule
Count enum value (defined in nvidia::apex::DestructibleCallbackSchedule) | nvidia::apex::DestructibleCallbackSchedule
Disabled enum value (defined in nvidia::apex::DestructibleCallbackSchedule) | nvidia::apex::DestructibleCallbackSchedule
Enum enum name | nvidia::apex::DestructibleCallbackSchedule
FetchResults enum value | nvidia::apex::DestructibleCallbackSchedule
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::DestructibleChunkEvent Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleChunkEvent
Public Types | Public Attributes
nvidia::apex::DestructibleChunkEvent Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Types

enum EventMask {
VisibilityChanged = (1 << 0),
ChunkVisible = (1 << 1)
}

Public Attributes

uint16_t | chunkIndex
Chunk index.
uint16_t | event
Event.

Detailed Description

An event structure for an optional chunk event buffer. Contains a chunk index and an event field.

Note: currently the only chunk state event is for visibility changes, so the VisibilityChanged bit will always be set when this struct is used.

Member Enumeration Documentation

enum nvidia::apex::DestructibleChunkEvent::EventMask

Enum of event mask

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleChunkEvent
nvidia::apex::DestructibleChunkEvent Member List
This is the complete list of members for nvidia::apex::DestructibleChunkEvent, including all inherited members.
chunkIndex | nvidia::apex::DestructibleChunkEvent
ChunkVisible enum value (defined in nvidia::apex::DestructibleChunkEvent) | nvidia::apex::DestructibleChunkEvent
event | nvidia::apex::DestructibleChunkEvent
EventMask enum name | nvidia::apex::DestructibleChunkEvent
VisibilityChanged enum value (defined in nvidia::apex::DestructibleChunkEvent) | nvidia::apex::DestructibleChunkEvent
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleChunkSyncState Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleChunkSyncState
Public Attributes
nvidia::apex::DestructibleChunkSyncState Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Attributes

bool | disableTransformBuffering
a handy switch for controlling whether chunk transforms will be buffered this instance.
bool | excludeSleepingChunks
dictates whether chunks that are sleeping will be buffered.
uint32_t | chunkTransformCopyDepth
dictates the (inclusive) maximum depth at which chunk transforms will be buffered.

Detailed Description

Tweak-able parameters on source-side for controlling the chunk sync state. DestructibleActorSyncFlags::CopyChunkTransform must first be set.

The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleChunkSyncState
nvidia::apex::DestructibleChunkSyncState Member List
This is the complete list of members for nvidia::apex::DestructibleChunkSyncState, including all inherited members.
chunkTransformCopyDepth | nvidia::apex::DestructibleChunkSyncState
disableTransformBuffering | nvidia::apex::DestructibleChunkSyncState
excludeSleepingChunks | nvidia::apex::DestructibleChunkSyncState
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleDepthParameters Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleDepthParameters
Public Member Functions | Public Attributes
nvidia::apex::DestructibleDepthParameters Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Member Functions

PX_INLINE | DestructibleDepthParameters ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.
PX_INLINE void | setToMostExpensive ()
(re)sets the structure to parameters which are likely to be the most computationally expensive.
PX_INLINE bool | overrideImpactDamage () const
PX_INLINE bool | overrideImpactDamageValue () const
PX_INLINE bool | ignoresPoseUpdates () const
PX_INLINE bool | ignoresRaycastCallbacks () const
PX_INLINE bool | ignoresContactCallbacks () const
PX_INLINE bool | hasUserFlagSet (uint32_t flagIndex) const

Public Attributes

uint32_t | flags

Detailed Description

Parameters that may be set for all chunks at a particular depth in the fracture hierarchy

Member Function Documentation

PX_INLINE bool nvidia::apex::DestructibleDepthParameters::hasUserFlagSet ( uint32_t flagIndex ) const

A convenience function to determine if the USER_FLAG_0, USER_FLAG_1, USER_FLAG_2, or USER_FLAG_3 flag is set.

PX_INLINE bool nvidia::apex::DestructibleDepthParameters::ignoresContactCallbacks ( ) const

A convenience function to determine if the IGNORE_CONTACT_CALLBACKS is set.

PX_INLINE bool nvidia::apex::DestructibleDepthParameters::ignoresPoseUpdates ( ) const

A convenience function to determine if the IGNORE_POSE_UPDATES is set.

PX_INLINE bool nvidia::apex::DestructibleDepthParameters::ignoresRaycastCallbacks ( ) const

A convenience function to determine if the IGNORE_RAYCAST_CALLBACKS is set.

PX_INLINE bool nvidia::apex::DestructibleDepthParameters::overrideImpactDamage ( ) const

A convenience function to determine if the OVERRIDE_IMPACT_DAMAGE is set.

PX_INLINE bool nvidia::apex::DestructibleDepthParameters::overrideImpactDamageValue ( ) const

A convenience function to read OVERRIDE_IMPACT_DAMAGE_VALUE is set.

Member Data Documentation

uint32_t nvidia::apex::DestructibleDepthParameters::flags

A collection of flags defined in DestructibleDepthParametersFlag.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleDepthParameters
nvidia::apex::DestructibleDepthParameters Member List
This is the complete list of members for nvidia::apex::DestructibleDepthParameters, including all inherited members.
DestructibleDepthParameters() | nvidia::apex::DestructibleDepthParameters
flags | nvidia::apex::DestructibleDepthParameters
hasUserFlagSet(uint32_t flagIndex) const | nvidia::apex::DestructibleDepthParameters
ignoresContactCallbacks() const | nvidia::apex::DestructibleDepthParameters
ignoresPoseUpdates() const | nvidia::apex::DestructibleDepthParameters
ignoresRaycastCallbacks() const | nvidia::apex::DestructibleDepthParameters
overrideImpactDamage() const | nvidia::apex::DestructibleDepthParameters
overrideImpactDamageValue() const | nvidia::apex::DestructibleDepthParameters
setToDefault() | nvidia::apex::DestructibleDepthParameters
setToMostExpensive() | nvidia::apex::DestructibleDepthParameters
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleDepthParametersFlag Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleDepthParametersFlag
Public Types
nvidia::apex::DestructibleDepthParametersFlag Struct Reference

PX_PS4. More...

#include <DestructibleAsset.h>

List of all members.

Public Types

enum Enum {
OVERRIDE_IMPACT_DAMAGE = (1 << 0),
OVERRIDE_IMPACT_DAMAGE_VALUE = (1 << 1),
IGNORE_POSE_UPDATES = (1 << 2),
IGNORE_RAYCAST_CALLBACKS = (1 << 3),
IGNORE_CONTACT_CALLBACKS = (1 << 4),
USER_FLAG_0 = (1 << 24),
USER_FLAG_1 = (1 << 25),
USER_FLAG_2 = (1 << 26),
USER_FLAG_3 = (1 << 27)
}

Detailed Description

PX_PS4.

Flags that may be set for all chunks at a particular depth in the fracture hierarchy

Member Enumeration Documentation

enum nvidia::apex::DestructibleDepthParametersFlag::Enum

Enum of destructible depth parameters flag

Enumerator:
OVERRIDE_IMPACT_DAMAGE

If true, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE = TRUE, no matter the setting of impactDamageDefaultDepth.. Note, DestructibleParameters::forceToDamage must also be positive for this to take effect.

OVERRIDE_IMPACT_DAMAGE_VALUE

If OVERRIDE_IMPACT_DAMAGE = TRUE, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE = TRUE, no matter the setting of impactDamageDefaultDepth..

IGNORE_POSE_UPDATES

Chunks at this depth should have pose updates ignored.

IGNORE_RAYCAST_CALLBACKS

Chunks at this depth should be ignored in raycast callbacks.

IGNORE_CONTACT_CALLBACKS

Chunks at this depth should be ignored in contact callbacks.

USER_FLAG_0

User defined flags.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleDepthParametersFlag
nvidia::apex::DestructibleDepthParametersFlag Member List
This is the complete list of members for nvidia::apex::DestructibleDepthParametersFlag, including all inherited members.
Enum enum name | nvidia::apex::DestructibleDepthParametersFlag
IGNORE_CONTACT_CALLBACKS enum value | nvidia::apex::DestructibleDepthParametersFlag
IGNORE_POSE_UPDATES enum value | nvidia::apex::DestructibleDepthParametersFlag
IGNORE_RAYCAST_CALLBACKS enum value | nvidia::apex::DestructibleDepthParametersFlag
OVERRIDE_IMPACT_DAMAGE enum value | nvidia::apex::DestructibleDepthParametersFlag
OVERRIDE_IMPACT_DAMAGE_VALUE enum value | nvidia::apex::DestructibleDepthParametersFlag
USER_FLAG_0 enum value | nvidia::apex::DestructibleDepthParametersFlag
USER_FLAG_1 enum value (defined in nvidia::apex::DestructibleDepthParametersFlag) | nvidia::apex::DestructibleDepthParametersFlag
USER_FLAG_2 enum value (defined in nvidia::apex::DestructibleDepthParametersFlag) | nvidia::apex::DestructibleDepthParametersFlag
USER_FLAG_3 enum value (defined in nvidia::apex::DestructibleDepthParametersFlag) | nvidia::apex::DestructibleDepthParametersFlag
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleEmitterType Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleEmitterType
Public Types
nvidia::apex::DestructibleEmitterType Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Types

enum Enum {
Crumble,
Dust,
Count
}

Detailed Description

Determines which type of emitter to associate with a render volume

Member Enumeration Documentation

enum nvidia::apex::DestructibleEmitterType::Enum

Enum of destructible emitter types

The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleEmitterType
nvidia::apex::DestructibleEmitterType Member List
This is the complete list of members for nvidia::apex::DestructibleEmitterType, including all inherited members.
Count enum value (defined in nvidia::apex::DestructibleEmitterType) | nvidia::apex::DestructibleEmitterType
Crumble enum value (defined in nvidia::apex::DestructibleEmitterType) | nvidia::apex::DestructibleEmitterType
Dust enum value (defined in nvidia::apex::DestructibleEmitterType) | nvidia::apex::DestructibleEmitterType
Enum enum name | nvidia::apex::DestructibleEmitterType
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleHitChunk Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleHitChunk
Public Attributes
nvidia::apex::DestructibleHitChunk Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Attributes

uint32_t | chunkIndex
chunk index
uint32_t | hitChunkFlags
hit chunk flag

Detailed Description

Hit chunk info. Hit chunks are those directly affected by fracture events. See getHitChunkHistory and forceChunkHits.

The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleHitChunk
nvidia::apex::DestructibleHitChunk Member List
This is the complete list of members for nvidia::apex::DestructibleHitChunk, including all inherited members.
chunkIndex | nvidia::apex::DestructibleHitChunk
hitChunkFlags | nvidia::apex::DestructibleHitChunk
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleInitParameters Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleInitParameters
Public Member Functions | Public Attributes
nvidia::apex::DestructibleInitParameters Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Member Functions

PX_INLINE | DestructibleInitParameters ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.

Public Attributes

uint32_t | supportDepth
uint32_t | flags

Detailed Description

Parameters that apply to a destructible actor at initialization

Member Data Documentation

uint32_t nvidia::apex::DestructibleInitParameters::flags

A collection of flags defined in DestructibleInitParametersFlag.

uint32_t nvidia::apex::DestructibleInitParameters::supportDepth

The chunk hierarchy depth at which to create a support graph. Higher depth levels give more detailed support, but will give a higher computational load. Chunks below the support depth will never be supported.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleInitParameters
nvidia::apex::DestructibleInitParameters Member List
This is the complete list of members for nvidia::apex::DestructibleInitParameters, including all inherited members.
DestructibleInitParameters() | nvidia::apex::DestructibleInitParameters
flags | nvidia::apex::DestructibleInitParameters
setToDefault() | nvidia::apex::DestructibleInitParameters
supportDepth | nvidia::apex::DestructibleInitParameters
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleInitParametersFlag Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleInitParametersFlag
Public Types
nvidia::apex::DestructibleInitParametersFlag Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Types

enum Enum {
ASSET_DEFINED_SUPPORT = (1 << 0),
WORLD_SUPPORT = (1 << 1),
FORM_EXTENDED_STRUCTURES = (1 << 2)
}

Detailed Description

Flags that apply to a destructible actor when it created

Member Enumeration Documentation

enum nvidia::apex::DestructibleInitParametersFlag::Enum

Enum of destructible init parameters flag

Enumerator:
ASSET_DEFINED_SUPPORT

If set, then chunks which are tagged as "support" chunks (via DestructibleChunkDesc::isSupportChunk) will have environmental support in static destructibles. Note: if both ASSET_DEFINED_SUPPORT and WORLD_SUPPORT are set, then chunks must be tagged as "support" chunks AND overlap the PxScene's static geometry in order to be environmentally supported.

WORLD_SUPPORT

If set, then chunks which overlap the PxScene's static geometry will have environmental support in static destructibles. Note: if both ASSET_DEFINED_SUPPORT and WORLD_SUPPORT are set, then chunks must be tagged as "support" chunks AND overlap the PxScene's static geometry in order to be environmentally supported.

FORM_EXTENDED_STRUCTURES

If this is set and the destructible is initially static, it will become part of an extended support structure if it is in contact with another static destructible that also has this flag set.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleInitParametersFlag
nvidia::apex::DestructibleInitParametersFlag Member List
This is the complete list of members for nvidia::apex::DestructibleInitParametersFlag, including all inherited members.
ASSET_DEFINED_SUPPORT enum value | nvidia::apex::DestructibleInitParametersFlag
Enum enum name | nvidia::apex::DestructibleInitParametersFlag
FORM_EXTENDED_STRUCTURES enum value | nvidia::apex::DestructibleInitParametersFlag
WORLD_SUPPORT enum value | nvidia::apex::DestructibleInitParametersFlag
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleParameterizedType Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleParameterizedType
Public Types
nvidia::apex::DestructibleParameterizedType Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Types

enum Enum {
State,
Params
}

Detailed Description

Provides access to specific NvParamterized types provided by the destructible actor

Member Enumeration Documentation

enum nvidia::apex::DestructibleParameterizedType::Enum

Enum of destructible parameterized types

The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleParameterizedType
nvidia::apex::DestructibleParameterizedType Member List
This is the complete list of members for nvidia::apex::DestructibleParameterizedType, including all inherited members.
Enum enum name | nvidia::apex::DestructibleParameterizedType
Params enum value (defined in nvidia::apex::DestructibleParameterizedType) | nvidia::apex::DestructibleParameterizedType
State enum value (defined in nvidia::apex::DestructibleParameterizedType) | nvidia::apex::DestructibleParameterizedType
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleParameters Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleParameters
Public Types | Public Member Functions | Public Attributes
nvidia::apex::DestructibleParameters Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Types

enum | { kDepthParametersCountMax = 16 }

Public Member Functions

PX_INLINE | DestructibleParameters ()
constructor sets to default.
PX_INLINE void | setToDefault ()
(re)sets the structure to the default.

Public Attributes

float | damageCap
float | forceToDamage
float | impactVelocityThreshold
uint32_t | minimumFractureDepth
int32_t | impactDamageDefaultDepth
int32_t | debrisDepth
uint32_t | essentialDepth
float | debrisLifetimeMin
float | debrisLifetimeMax
float | debrisMaxSeparationMin
float | debrisMaxSeparationMax
float | debrisDestructionProbability
PxBounds3 | validBounds
float | maxChunkSpeed
uint32_t | flags
float | fractureImpulseScale
uint16_t | damageDepthLimit
uint8_t | dynamicChunksDominanceGroup
bool | useDynamicChunksGroupsMask
physx::PxFilterData | dynamicChunksFilterData
float | supportStrength
int8_t | legacyChunkBoundsTestSetting
int8_t | legacyDamageRadiusSpreadSetting
uint32_t | depthParametersCount
DestructibleDepthParameters | depthParameters [kDepthParametersCountMax]
DestructibleRTFractureParameters rtFractureParameters
bool | alwaysDrawScatterMesh

Detailed Description

Parameters that apply to a destructible actor

Member Enumeration Documentation

anonymous enum

The maximum number of DestructibleDepthParameters (see depthParameters).

Member Data Documentation

bool nvidia::apex::DestructibleParameters::alwaysDrawScatterMesh

This flag forces drawing of scatter mesh on chunks with depth > 1. By default is false.

float nvidia::apex::DestructibleParameters::damageCap

Limits the amount of damage applied to a chunk. This is useful for preventing the entire destructible from getting pulverized by a very large application of damage. This can easily happen when impact damage is used, and the damage amount is proportional to the impact force (see forceToDamage).

uint16_t nvidia::apex::DestructibleParameters::damageDepthLimit

How deep in the hierarchy damage will be propagated, relative to the chunk hit. Default = UINT16_MAX.

int32_t nvidia::apex::DestructibleParameters::debrisDepth

The chunk hierarchy depth at which chunks are considered to be "debris." Chunks at this depth or below will be considered for various debris settings, such as debrisLifetime. Negative values indicate that no chunk depth is considered debris. Default value is -1.

float nvidia::apex::DestructibleParameters::debrisDestructionProbability

The probablity that a debris chunk, when fractured, will simply be destroyed instead of becoming dynamic or breaking down further into child chunks. Valid range = [0.0,1.0]. Default value = 0.0.'

float nvidia::apex::DestructibleParameters::debrisLifetimeMax
See also:
DestructibleAsset::debrisLifetimeMin
float nvidia::apex::DestructibleParameters::debrisLifetimeMin

"Debris chunks" (see debrisDepth, above) will be destroyed after a time (in seconds) separated from non-debris chunks. The actual lifetime is interpolated between these two values, based upon the module's LOD setting. To disable lifetime, clear the DestructibleDepthParametersFlag::DEBRIS_TIMEOUT flag in the flags field. If debrisLifetimeMax < debrisLifetimeMin, the mean of the two is used for both. Default debrisLifetimeMin = 1.0, debrisLifetimeMax = 10.0f.

float nvidia::apex::DestructibleParameters::debrisMaxSeparationMax
See also:
DestructibleAsset::debrisMaxSeparationMin
float nvidia::apex::DestructibleParameters::debrisMaxSeparationMin

"Debris chunks" (see debrisDepth, above) will be destroyed if they are separated from their origin by a distance greater than maxSeparation. The actual maxSeparation is interpolated between these two values, based upon the module's LOD setting. To disable maxSeparation, clear the DestructibleDepthParametersFlag::DEBRIS_MAX_SEPARATION flag in the flags field. If debrisMaxSeparationMax < debrisMaxSeparationMin, the mean of the two is used for both. Default debrisMaxSeparationMin = 1.0, debrisMaxSeparationMax = 10.0f.

DestructibleDepthParameters nvidia::apex::DestructibleParameters::depthParameters[kDepthParametersCountMax]

Parameters that apply to every chunk at a given depth level (see DestructibleDepthParameters). The element [0] of the array applies to the depth 0 (unfractured) chunk, element [1] applies to the level 1 chunks, etc. The number of valid depth parameters must be given in depthParametersCount.

uint32_t nvidia::apex::DestructibleParameters::depthParametersCount

The number of DestructibleDepthParameters (see depthParameters). Must be in the range [0, kDepthParametersCountMax].

uint8_t nvidia::apex::DestructibleParameters::dynamicChunksDominanceGroup

Optional dominance group for dynamic chunks created when fractured. (ignored if > 31)

physx::PxFilterData nvidia::apex::DestructibleParameters::dynamicChunksFilterData

Optional groups mask (2.x) or filter data (3.x) for dynamic chunks created when fractured. (Used if useDynamicChunksGroupsMask is true.)

uint32_t nvidia::apex::DestructibleParameters::essentialDepth

The chunk hierarchy depth up to which chunks will not be eliminated due to LOD considerations. These chunks are considered to be essential either for gameplay or visually. The minimum value is 0, meaning the level 0 chunk is always considered essential. Default value is 0.

uint32_t nvidia::apex::DestructibleParameters::flags

A collection of flags defined in DestructibleParametersFlag.

float nvidia::apex::DestructibleParameters::forceToDamage

If a chunk is at a depth which takes impact damage (see DestructibleDepthParameters), then when a chunk has a collision in the PxScene, it will take damage equal to forceToDamage mulitplied by the impact force. The default value is zero, which effectively disables impact damage.

float nvidia::apex::DestructibleParameters::fractureImpulseScale

Scale factor used to apply an impulse force along the normal of chunk when fractured. This is used in order to "push" the pieces out as they fracture.

int32_t nvidia::apex::DestructibleParameters::impactDamageDefaultDepth

The default depth to which chunks will take impact damage. This default may be overridden in the depth settings. Negative values imply no default impact damage. Default value = -1.

float nvidia::apex::DestructibleParameters::impactVelocityThreshold

Large impact force may be reported if rigid bodies are spawned inside one another. In this case the relative velocity of the two objects will be low. This variable allows the user to set a minimum velocity threshold for impacts to ensure that the objects are moving at a min velocity in order for the impact force to be considered. Default value is zero.

int8_t nvidia::apex::DestructibleParameters::legacyChunkBoundsTestSetting

Whether or not to use the old chunk bounds testing for damage, or use the module setting. A value of 0 forces the new method to be used. A positive value forces the old method to be used. Negative values cause the global (ModuleDestructible) setting to be used. Default = -1

int8_t nvidia::apex::DestructibleParameters::legacyDamageRadiusSpreadSetting

Whether or not to use the old damage spread method, or use the module setting. A value of 0 forces the new method to be used. A positive value forces the old method to be used. Negative values cause the global (ModuleDestructible) setting to be used. Default = -1

float nvidia::apex::DestructibleParameters::maxChunkSpeed

If greater than 0, the chunks' speeds will not be allowed to exceed maxChunkSpeed. Use 0 to disable this feature (this is the default).

uint32_t nvidia::apex::DestructibleParameters::minimumFractureDepth

The chunks will not be broken free below this depth.

DestructibleRTFractureParameters nvidia::apex::DestructibleParameters::rtFractureParameters

Parameters for RT Fracture.

float nvidia::apex::DestructibleParameters::supportStrength

The supportStrength is used for the stress solver. As this value is increased it takes more force to break apart the chunks under the effect of stress solver.

bool nvidia::apex::DestructibleParameters::useDynamicChunksGroupsMask

Whether or not to use dynamicChunksGroupsMask. If false, NULL will be passed into the DestructibleActor upon instantiation, through the DestructibleActorDesc.

PxBounds3 nvidia::apex::DestructibleParameters::validBounds

A bounding box around each DestructibleActor created, defining a range of validity for chunks that break free. These bounds are scaled and translated with the DestructibleActor's scale and position, but they are *not* rotated with the DestructibleActor.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleParameters
nvidia::apex::DestructibleParameters Member List
This is the complete list of members for nvidia::apex::DestructibleParameters, including all inherited members.
alwaysDrawScatterMesh | nvidia::apex::DestructibleParameters
damageCap | nvidia::apex::DestructibleParameters
damageDepthLimit | nvidia::apex::DestructibleParameters
debrisDepth | nvidia::apex::DestructibleParameters
debrisDestructionProbability | nvidia::apex::DestructibleParameters
debrisLifetimeMax | nvidia::apex::DestructibleParameters
debrisLifetimeMin | nvidia::apex::DestructibleParameters
debrisMaxSeparationMax | nvidia::apex::DestructibleParameters
debrisMaxSeparationMin | nvidia::apex::DestructibleParameters
depthParameters | nvidia::apex::DestructibleParameters
depthParametersCount | nvidia::apex::DestructibleParameters
DestructibleParameters() | nvidia::apex::DestructibleParameters
dynamicChunksDominanceGroup | nvidia::apex::DestructibleParameters
dynamicChunksFilterData | nvidia::apex::DestructibleParameters
essentialDepth | nvidia::apex::DestructibleParameters
flags | nvidia::apex::DestructibleParameters
forceToDamage | nvidia::apex::DestructibleParameters
fractureImpulseScale | nvidia::apex::DestructibleParameters
impactDamageDefaultDepth | nvidia::apex::DestructibleParameters
impactVelocityThreshold | nvidia::apex::DestructibleParameters
kDepthParametersCountMax enum value (defined in nvidia::apex::DestructibleParameters) | nvidia::apex::DestructibleParameters
legacyChunkBoundsTestSetting | nvidia::apex::DestructibleParameters
legacyDamageRadiusSpreadSetting | nvidia::apex::DestructibleParameters
maxChunkSpeed | nvidia::apex::DestructibleParameters
minimumFractureDepth | nvidia::apex::DestructibleParameters
rtFractureParameters | nvidia::apex::DestructibleParameters
setToDefault() | nvidia::apex::DestructibleParameters
supportStrength | nvidia::apex::DestructibleParameters
useDynamicChunksGroupsMask | nvidia::apex::DestructibleParameters
validBounds | nvidia::apex::DestructibleParameters
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleParametersFlag Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleParametersFlag
Public Types
nvidia::apex::DestructibleParametersFlag Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Types

enum Enum {
ACCUMULATE_DAMAGE = (1 << 0),
DEBRIS_TIMEOUT = (1 << 1),
DEBRIS_MAX_SEPARATION = (1 << 2),
CRUMBLE_SMALLEST_CHUNKS = (1 << 3),
ACCURATE_RAYCASTS = (1 << 4),
USE_VALID_BOUNDS = (1 << 5),
CRUMBLE_VIA_RUNTIME_FRACTURE = (1 << 6)
}

Detailed Description

Flags that apply to a destructible actor, settable at runtime

Member Enumeration Documentation

enum nvidia::apex::DestructibleParametersFlag::Enum

Enum of destructible parameters flag

Enumerator:
ACCUMULATE_DAMAGE

If set, chunks will "remember" damage applied to them, so that many applications of a damage amount below damageThreshold will eventually fracture the chunk. If not set, a single application of damage must exceed damageThreshold in order to fracture the chunk.

DEBRIS_TIMEOUT

Whether or not chunks at or deeper than the "debris" depth (see DestructibleParameters::debrisDepth) will time out. The lifetime is a value between DestructibleParameters::debrisLifetimeMin and DestructibleParameters::debrisLifetimeMax, based upon the destructible module's LOD setting.

DEBRIS_MAX_SEPARATION

Whether or not chunks at or deeper than the "debris" depth (see DestructibleParameters::debrisDepth) will be removed if they separate too far from their origins. The maxSeparation is a value between DestructibleParameters::debrisMaxSeparationMin and DestructibleParameters::debrisMaxSeparationMax, based upon the destructible module's LOD setting.

CRUMBLE_SMALLEST_CHUNKS

If set, the smallest chunks may be further broken down, either by fluid crumbles (if a crumble particle system is specified in the DestructibleActorDesc), or by simply removing the chunk if no crumble particle system is specified. Note: the "smallest chunks" are normally defined to be the deepest level of the fracture hierarchy. However, they may be taken from higher levels of the hierarchy if ModuleDestructible::setMaxChunkDepthOffset is called with a non-zero value.

ACCURATE_RAYCASTS

If set, the DestructibleActor::rayCast function will search within the nearest visible chunk hit for collisions with child chunks. This is used to get a better raycast position and normal, in case the parent collision volume does not tightly fit the graphics mesh. The returned chunk index will always be that of the visible parent that is intersected, however.

USE_VALID_BOUNDS

If set, the validBounds field of DestructibleParameters will be used. These bounds are translated (but not scaled or rotated) to the origin of the destructible actor. If a chunk or chunk island moves outside of those bounds, it is destroyed.

CRUMBLE_VIA_RUNTIME_FRACTURE

If set, chunk crumbling will be handled via the pattern-based runtime fracture pipeline. If no fracture pattern is specified in the DestructibleActorDesc, or no fracture pattern has been assigned to the destructible actor, chunks will simply be removed.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleParametersFlag
nvidia::apex::DestructibleParametersFlag Member List
This is the complete list of members for nvidia::apex::DestructibleParametersFlag, including all inherited members.
ACCUMULATE_DAMAGE enum value | nvidia::apex::DestructibleParametersFlag
ACCURATE_RAYCASTS enum value | nvidia::apex::DestructibleParametersFlag
CRUMBLE_SMALLEST_CHUNKS enum value | nvidia::apex::DestructibleParametersFlag
CRUMBLE_VIA_RUNTIME_FRACTURE enum value | nvidia::apex::DestructibleParametersFlag
DEBRIS_MAX_SEPARATION enum value | nvidia::apex::DestructibleParametersFlag
DEBRIS_TIMEOUT enum value | nvidia::apex::DestructibleParametersFlag
Enum enum name | nvidia::apex::DestructibleParametersFlag
USE_VALID_BOUNDS enum value | nvidia::apex::DestructibleParametersFlag
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructiblePhysXActorQueryFlags Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructiblePhysXActorQueryFlags
Public Types
nvidia::apex::DestructiblePhysXActorQueryFlags Struct Reference

#include <DestructibleActor.h>

List of all members.

Public Types

enum Enum {
None = 0,
Static = (1 << 0),
Dynamic = (1 << 1),
Dormant = (1 << 2),
AllStates = Static | Dynamic | Dormant,
AllowRedundancy = (1 << 3),
AllowActorsNotInScenes = (1 << 4)
}

Detailed Description

Flags which control which actors are returned by DestructibleActor::acquirePhysXActorBuffer

Member Enumeration Documentation

enum nvidia::apex::DestructiblePhysXActorQueryFlags::Enum

Enum of destructible PhysX actor query flags

Enumerator:
Dynamic

Destructible-static, which is a kinematic PhysX actor that hasn't been turned dynamic yet.

Dormant

Dynamic, not dormant (not kinematic)

AllStates

Dynamic, but dormant (had been made dynamic, but is now in a dormant, PhysX-kinematic state)

AllowRedundancy

Whether or not to ensure that PhysX actors are not listed more than once when this NxDestructibleActor is part of an extended structure. If this is true, then some NxDestructibleActors may not return all PhysX actors associated with all of their chunks (and in fact may return no PhysX actors), but after querying all NxDestructibleActors in a given structure, every PhysX actor will be accounted for.

AllowActorsNotInScenes

Whether or not to allow actors not yet put into the PxScene (e.g. there has not been a simulation step since the actor was created) are also returned.

The documentation for this struct was generated from the following file:
  • DestructibleActor.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructiblePhysXActorQueryFlags
nvidia::apex::DestructiblePhysXActorQueryFlags Member List
This is the complete list of members for nvidia::apex::DestructiblePhysXActorQueryFlags, including all inherited members.
AllowActorsNotInScenes enum value | nvidia::apex::DestructiblePhysXActorQueryFlags
AllowRedundancy enum value | nvidia::apex::DestructiblePhysXActorQueryFlags
AllStates enum value | nvidia::apex::DestructiblePhysXActorQueryFlags
Dormant enum value | nvidia::apex::DestructiblePhysXActorQueryFlags
Dynamic enum value | nvidia::apex::DestructiblePhysXActorQueryFlags
Enum enum name | nvidia::apex::DestructiblePhysXActorQueryFlags
None enum value (defined in nvidia::apex::DestructiblePhysXActorQueryFlags) | nvidia::apex::DestructiblePhysXActorQueryFlags
Static enum value (defined in nvidia::apex::DestructiblePhysXActorQueryFlags) | nvidia::apex::DestructiblePhysXActorQueryFlags
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleRTFractureParameters Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRTFractureParameters
Classes | Public Member Functions | Public Attributes
nvidia::apex::DestructibleRTFractureParameters Struct Reference

#include <DestructibleAsset.h>

List of all members.

Classes

struct | FractureAttachment
struct | FractureGlass

Public Member Functions

PX_INLINE void | setToDefault ()

Public Attributes

bool | sheetFracture
uint32_t | depthLimit
bool | destroyIfAtDepthLimit
float | minConvexSize
float | impulseScale
struct
nvidia::apex::DestructibleRTFractureParameters::FractureGlass 		glass
Instance of FractureGlass parameters.
struct
nvidia::apex::DestructibleRTFractureParameters::FractureAttachment 		attachment
Instance of FractureAttachment parameters.

Detailed Description

Parameters for RT Fracture

Member Function Documentation

PX_INLINE void nvidia::apex::DestructibleRTFractureParameters::setToDefault ( )

Set default fracture parameters

Member Data Documentation

uint32_t nvidia::apex::DestructibleRTFractureParameters::depthLimit

Number of times deep a chunk can be fractured. Can help limit the number of chunks produced by runtime fracture.

bool nvidia::apex::DestructibleRTFractureParameters::destroyIfAtDepthLimit

If true, destroy chunks when they hit their depth limit. If false, then chunks at their depth limit will not fracture but will have a force applied.

float nvidia::apex::DestructibleRTFractureParameters::impulseScale

Scales impulse applied by a fracture.

float nvidia::apex::DestructibleRTFractureParameters::minConvexSize

Minimum Convex Size. Minimum size of convex produced by a fracture.

bool nvidia::apex::DestructibleRTFractureParameters::sheetFracture

If true, align fracture pattern to largest face. If false, the fracture pattern will be aligned to the hit normal with each fracture.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRTFractureParameters
nvidia::apex::DestructibleRTFractureParameters Member List
This is the complete list of members for nvidia::apex::DestructibleRTFractureParameters, including all inherited members.
attachment | nvidia::apex::DestructibleRTFractureParameters
depthLimit | nvidia::apex::DestructibleRTFractureParameters
destroyIfAtDepthLimit | nvidia::apex::DestructibleRTFractureParameters
glass | nvidia::apex::DestructibleRTFractureParameters
impulseScale | nvidia::apex::DestructibleRTFractureParameters
minConvexSize | nvidia::apex::DestructibleRTFractureParameters
setToDefault() | nvidia::apex::DestructibleRTFractureParameters
sheetFracture | nvidia::apex::DestructibleRTFractureParameters
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleRTFractureParameters::FractureAttachment Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRTFractureParameters
  • FractureAttachment
Public Attributes
nvidia::apex::DestructibleRTFractureParameters::FractureAttachment Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Attributes

bool | posX
bool | negX
bool | posY
bool | negY
bool | posZ
bool | negZ

Detailed Description

Fracture attachment

Member Data Documentation

bool nvidia::apex::DestructibleRTFractureParameters::FractureAttachment::negX

If true, make the negative x side of the sheet an attachment point.

bool nvidia::apex::DestructibleRTFractureParameters::FractureAttachment::negY

If true, make the negative y side of the sheet an attachment point.

bool nvidia::apex::DestructibleRTFractureParameters::FractureAttachment::negZ

If true, make the negative z side of the sheet an attachment point.

bool nvidia::apex::DestructibleRTFractureParameters::FractureAttachment::posX

If true, make the positive x side of the sheet an attachment point.

bool nvidia::apex::DestructibleRTFractureParameters::FractureAttachment::posY

If true, make the positive y side of the sheet an attachment point.

bool nvidia::apex::DestructibleRTFractureParameters::FractureAttachment::posZ

If true, make the positive z side of the sheet an attachment point.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRTFractureParameters
  • FractureAttachment
nvidia::apex::DestructibleRTFractureParameters::FractureAttachment Member List
This is the complete list of members for nvidia::apex::DestructibleRTFractureParameters::FractureAttachment, including all inherited members.
negX | nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
negY | nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
negZ | nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
posX | nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
posY | nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
posZ | nvidia::apex::DestructibleRTFractureParameters::FractureAttachment
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::DestructibleRTFractureParameters::FractureGlass Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRTFractureParameters
  • FractureGlass
Public Attributes
nvidia::apex::DestructibleRTFractureParameters::FractureGlass Struct Reference

#include <DestructibleAsset.h>

List of all members.

Public Attributes

uint32_t | numSectors
float | sectorRand
float | firstSegmentSize
float | segmentScale
float | segmentRand

Detailed Description

Parameters for glass fracture

Member Data Documentation

float nvidia::apex::DestructibleRTFractureParameters::FractureGlass::firstSegmentSize

The minimum shard size. Shards below this size will not be created and thus not visible.

uint32_t nvidia::apex::DestructibleRTFractureParameters::FractureGlass::numSectors

Number of angular slices in the glass fracture pattern.

float nvidia::apex::DestructibleRTFractureParameters::FractureGlass::sectorRand

Creates variance in the angle of slices. A value of zero results in all angular slices having the same angle.

float nvidia::apex::DestructibleRTFractureParameters::FractureGlass::segmentRand

Creates variance in the radial size of shards. A value of zero results in a low noise circular pattern.

float nvidia::apex::DestructibleRTFractureParameters::FractureGlass::segmentScale

Scales the radial spacing in the glass fracture pattern. A larger value results in radially longer shards.

The documentation for this struct was generated from the following file:
  • DestructibleAsset.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • DestructibleRTFractureParameters
  • FractureGlass
nvidia::apex::DestructibleRTFractureParameters::FractureGlass Member List
This is the complete list of members for nvidia::apex::DestructibleRTFractureParameters::FractureGlass, including all inherited members.
firstSegmentSize | nvidia::apex::DestructibleRTFractureParameters::FractureGlass
numSectors | nvidia::apex::DestructibleRTFractureParameters::FractureGlass
sectorRand | nvidia::apex::DestructibleRTFractureParameters::FractureGlass
segmentRand | nvidia::apex::DestructibleRTFractureParameters::FractureGlass
segmentScale | nvidia::apex::DestructibleRTFractureParameters::FractureGlass
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::EmitterGeomExplicit::EllipsoidParams Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • EllipsoidParams
Public Attributes
nvidia::apex::EmitterGeomExplicit::EllipsoidParams Struct Reference

Ellipsoid parameters. More...

#include <EmitterGeoms.h>

List of all members.

Public Attributes

PxVec3 | center
Ellipsoid center.
float | radius
Ellipsoid radius.
PxVec3 | normal
Ellipsoid normal.
float | polarRadius
Ellipsoid polar radius.
bool | doDetectOverlaps
Should detect overlap.

Detailed Description

Ellipsoid parameters.

The documentation for this struct was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • EllipsoidParams
nvidia::apex::EmitterGeomExplicit::EllipsoidParams Member List
This is the complete list of members for nvidia::apex::EmitterGeomExplicit::EllipsoidParams, including all inherited members.
center | nvidia::apex::EmitterGeomExplicit::EllipsoidParams
doDetectOverlaps | nvidia::apex::EmitterGeomExplicit::EllipsoidParams
normal | nvidia::apex::EmitterGeomExplicit::EllipsoidParams
polarRadius | nvidia::apex::EmitterGeomExplicit::EllipsoidParams
radius | nvidia::apex::EmitterGeomExplicit::EllipsoidParams
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterGeomExplicit::PointListData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • PointListData
Public Attributes
nvidia::apex::EmitterGeomExplicit::PointListData Struct Reference

Structure contains positions, velocities and user data for particles. More...

#include <EmitterGeoms.h>

List of all members.

Public Attributes

const void * | positionStart
Pointer to first position.
uint32_t | positionStrideBytes
The stride between position vectors.
const void * | velocityStart
Pointer to first velocity.
uint32_t | velocityStrideBytes
The stride between velocity vectors.
const void * | userDataStart
Pointer to first instance of user data.
uint32_t | userDataStrideBytes
The stride between instances of user data.

Detailed Description

Structure contains positions, velocities and user data for particles.

The documentation for this struct was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • PointListData
nvidia::apex::EmitterGeomExplicit::PointListData Member List
This is the complete list of members for nvidia::apex::EmitterGeomExplicit::PointListData, including all inherited members.
positionStart | nvidia::apex::EmitterGeomExplicit::PointListData
positionStrideBytes | nvidia::apex::EmitterGeomExplicit::PointListData
userDataStart | nvidia::apex::EmitterGeomExplicit::PointListData
userDataStrideBytes | nvidia::apex::EmitterGeomExplicit::PointListData
velocityStart | nvidia::apex::EmitterGeomExplicit::PointListData
velocityStrideBytes | nvidia::apex::EmitterGeomExplicit::PointListData
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterGeomExplicit::PointParams Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • PointParams
Public Attributes
nvidia::apex::EmitterGeomExplicit::PointParams Struct Reference

Point parameters. More...

#include <EmitterGeoms.h>

List of all members.

Public Attributes

PxVec3 | position
Point position.
bool | doDetectOverlaps
Should detect overlap.

Detailed Description

Point parameters.

The documentation for this struct was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • PointParams
nvidia::apex::EmitterGeomExplicit::PointParams Member List
This is the complete list of members for nvidia::apex::EmitterGeomExplicit::PointParams, including all inherited members.
doDetectOverlaps | nvidia::apex::EmitterGeomExplicit::PointParams
position | nvidia::apex::EmitterGeomExplicit::PointParams
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterGeomExplicit::SphereParams Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • SphereParams
Public Attributes
nvidia::apex::EmitterGeomExplicit::SphereParams Struct Reference

Sphere prameters. More...

#include <EmitterGeoms.h>

List of all members.

Public Attributes

PxVec3 | center
Sphere center.
float | radius
Sphere radius.
bool | doDetectOverlaps
Should detect overlap.

Detailed Description

Sphere prameters.

The documentation for this struct was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterGeomExplicit
  • SphereParams
nvidia::apex::EmitterGeomExplicit::SphereParams Member List
This is the complete list of members for nvidia::apex::EmitterGeomExplicit::SphereParams, including all inherited members.
center | nvidia::apex::EmitterGeomExplicit::SphereParams
doDetectOverlaps | nvidia::apex::EmitterGeomExplicit::SphereParams
radius | nvidia::apex::EmitterGeomExplicit::SphereParams
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::EmitterType Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterType
Public Types
nvidia::apex::EmitterType Struct Reference

Emitter type. More...

#include <EmitterGeoms.h>

List of all members.

Public Types

enum Enum {
ET_RATE = 0,
ET_DENSITY_ONCE,
ET_DENSITY_BRUSH,
ET_FILL,
ET_UNDEFINED
}
Enum of emitter types. More...

Detailed Description

Emitter type.

Member Enumeration Documentation

enum nvidia::apex::EmitterType::Enum

Enum of emitter types.

Enumerator:
ET_RATE

use emittion rate to calculate the number of particles

ET_DENSITY_ONCE

emit density particles at once

ET_DENSITY_BRUSH

brush behavior: particles are emitted proportionally to the newly occupied vlume

ET_FILL

fill the volume of the emitter with particles

The documentation for this struct was generated from the following file:
  • EmitterGeoms.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • EmitterType
nvidia::apex::EmitterType Member List
This is the complete list of members for nvidia::apex::EmitterType, including all inherited members.
Enum enum name | nvidia::apex::EmitterType
ET_DENSITY_BRUSH enum value | nvidia::apex::EmitterType
ET_DENSITY_ONCE enum value | nvidia::apex::EmitterType
ET_FILL enum value | nvidia::apex::EmitterType
ET_RATE enum value | nvidia::apex::EmitterType
ET_UNDEFINED enum value (defined in nvidia::apex::EmitterType) | nvidia::apex::EmitterType
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::ExplicitRenderTriangle Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitRenderTriangle
Public Member Functions | Public Attributes
nvidia::apex::ExplicitRenderTriangle Struct Reference

A less inefficient triangle description used for authoring. More...

#include <RenderMeshAsset.h>

List of all members.

Public Member Functions

PxVec3 | calculateNormal () const
Returns an unnormalized normal, in general.

Public Attributes

Vertex | vertices [3]
The three verts that define the triangle.
int32_t | submeshIndex
The submesh to which this triangle belongs.
uint32_t | smoothingMask
Smoothing mask.
uint32_t | extraDataIndex
Index of extra data.

Detailed Description

A less inefficient triangle description used for authoring.

The documentation for this struct was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitRenderTriangle
nvidia::apex::ExplicitRenderTriangle Member List
This is the complete list of members for nvidia::apex::ExplicitRenderTriangle, including all inherited members.
calculateNormal() const | nvidia::apex::ExplicitRenderTriangle | [inline]
extraDataIndex | nvidia::apex::ExplicitRenderTriangle |
smoothingMask | nvidia::apex::ExplicitRenderTriangle |
submeshIndex | nvidia::apex::ExplicitRenderTriangle |
vertices | nvidia::apex::ExplicitRenderTriangle |
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::ExplicitSubmeshData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitSubmeshData
Public Types | Public Member Functions | Public Attributes
nvidia::apex::ExplicitSubmeshData Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Types

enum | { MaterialNameBufferSize = 1024 }

Public Member Functions

bool | operator== (const ExplicitSubmeshData &data) const
bool | operator!= (const ExplicitSubmeshData &data) const

Public Attributes

char | mMaterialName [MaterialNameBufferSize]
ExplicitVertexFormat mVertexFormat

Detailed Description

ExplicitSubmeshData

This is used when authoring an RenderMeshAsset.

This is the per-submesh data: the material name, and vertex format.

Member Enumeration Documentation

anonymous enum

Enum for storing material name buffer size

Member Function Documentation

bool nvidia::apex::ExplicitSubmeshData::operator!= ( const ExplicitSubmeshData & data ) const [inline]

Not equal operator for ExplicitSubmeshData

bool nvidia::apex::ExplicitSubmeshData::operator== ( const ExplicitSubmeshData & data ) const [inline]

Equal operator for ExplicitSubmeshData

Member Data Documentation

char nvidia::apex::ExplicitSubmeshData::mMaterialName[MaterialNameBufferSize]

Material name char buffer

ExplicitVertexFormat nvidia::apex::ExplicitSubmeshData::mVertexFormat

Explicit vertex format

See also:
ExplicitVertexFormat
The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitSubmeshData
nvidia::apex::ExplicitSubmeshData Member List
This is the complete list of members for nvidia::apex::ExplicitSubmeshData, including all inherited members.
MaterialNameBufferSize enum value (defined in nvidia::apex::ExplicitSubmeshData) | nvidia::apex::ExplicitSubmeshData |
mMaterialName | nvidia::apex::ExplicitSubmeshData |
mVertexFormat | nvidia::apex::ExplicitSubmeshData |
operator!=(const ExplicitSubmeshData &data) const | nvidia::apex::ExplicitSubmeshData | [inline]
operator==(const ExplicitSubmeshData &data) const | nvidia::apex::ExplicitSubmeshData | [inline]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ExplicitVertexFormat Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitVertexFormat
Public Member Functions | Public Attributes
nvidia::apex::ExplicitVertexFormat Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

ExplicitVertexFormat ()
void | clear ()
bool | operator== (const ExplicitVertexFormat &data) const
bool | operator!= (const ExplicitVertexFormat &data) const
void | copyToVertexFormat (VertexFormat *format) const

Public Attributes

uint32_t | mWinding
bool | mHasStaticPositions
bool | mHasStaticNormals
bool | mHasStaticTangents
bool | mHasStaticBinormals
bool | mHasStaticColors
bool | mHasStaticSeparateBoneBuffer
bool | mHasStaticDisplacements
bool | mHasDynamicPositions
bool | mHasDynamicNormals
bool | mHasDynamicTangents
bool | mHasDynamicBinormals
bool | mHasDynamicColors
bool | mHasDynamicSeparateBoneBuffer
bool | mHasDynamicDisplacements
uint32_t | mUVCount
uint32_t | mBonesPerVertex

Detailed Description

ExplicitVertexFormat

This is used when authoring an VertexBuffer, to define which data channels exist.

Constructor & Destructor Documentation

nvidia::apex::ExplicitVertexFormat::ExplicitVertexFormat ( ) [inline]

Constructor, calls clear() to set formats to default settings

Member Function Documentation

void nvidia::apex::ExplicitVertexFormat::clear ( ) [inline]

Set formats to default settings:

mWinding = RenderCullMode::CLOCKWISE; mHasStaticPositions = false; mHasStaticNormals = false; mHasStaticTangents = false; mHasStaticBinormals = false; mHasStaticColors = false; mHasStaticSeparateBoneBuffer = false; mHasStaticDisplacements = false; mHasDynamicPositions = false; mHasDynamicNormals = false; mHasDynamicTangents = false; mHasDynamicBinormals = false; mHasDynamicColors = false; mHasDynamicSeparateBoneBuffer = false; mHasDynamicDisplacements = false; mUVCount = 0; mBonesPerVertex = 0;

void nvidia::apex::ExplicitVertexFormat::copyToVertexFormat ( VertexFormat * format ) const [inline]

Creates a render-ready VertexFormat corresponding to this structure's member values.

bool nvidia::apex::ExplicitVertexFormat::operator!= ( const ExplicitVertexFormat & data ) const [inline]

Returns the logical complement of the == operator.

bool nvidia::apex::ExplicitVertexFormat::operator== ( const ExplicitVertexFormat & data ) const [inline]

Equality operator. All values are tested for equality except mBonesPerVertex.

Member Data Documentation

uint32_t nvidia::apex::ExplicitVertexFormat::mBonesPerVertex

How many bones may influence a vertex

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicBinormals

Whether or not the accompanying vertex data has defined dynamic vertex binormals.

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicColors

Whether or not the accompanying vertex data has defined dynamic vertex colors.

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicDisplacements

Whether or not the accompanying vertex data has defined dynamic displacement coordinates

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicNormals

Whether or not the accompanying vertex data has defined dynamic vertex normals.

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicPositions

Whether or not the accompanying vertex data has defined dynamic vertex positions.

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicSeparateBoneBuffer

Whether or not to create separate render resource for a dynamic bone index buffer.

bool nvidia::apex::ExplicitVertexFormat::mHasDynamicTangents

Whether or not the accompanying vertex data has defined dynamic vertex tangents.

bool nvidia::apex::ExplicitVertexFormat::mHasStaticBinormals

Whether or not the accompanying vertex data has defined static vertex binormals.

bool nvidia::apex::ExplicitVertexFormat::mHasStaticColors

Whether or not the accompanying vertex data has defined static vertex colors.

bool nvidia::apex::ExplicitVertexFormat::mHasStaticDisplacements

Whether or not the accompanying vertex data has defined dynamic displacement coordinates

bool nvidia::apex::ExplicitVertexFormat::mHasStaticNormals

Whether or not the accompanying vertex data has defined static vertex normals.

bool nvidia::apex::ExplicitVertexFormat::mHasStaticPositions

Whether or not the accompanying vertex data has defined static vertex positions.

bool nvidia::apex::ExplicitVertexFormat::mHasStaticSeparateBoneBuffer

Whether or not to create separate render resource for a static bone index buffer.

bool nvidia::apex::ExplicitVertexFormat::mHasStaticTangents

Whether or not the accompanying vertex data has defined static vertex tangents.

uint32_t nvidia::apex::ExplicitVertexFormat::mUVCount

How many UV coordinate channels there are (per vertex)

uint32_t nvidia::apex::ExplicitVertexFormat::mWinding

This value defines which vertex winding orders will be rendered. See RenderCullMode.

The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ExplicitVertexFormat
nvidia::apex::ExplicitVertexFormat Member List
This is the complete list of members for nvidia::apex::ExplicitVertexFormat, including all inherited members.
clear() | nvidia::apex::ExplicitVertexFormat | [inline]
copyToVertexFormat(VertexFormat *format) const | nvidia::apex::ExplicitVertexFormat | [inline]
ExplicitVertexFormat() | nvidia::apex::ExplicitVertexFormat | [inline]
mBonesPerVertex | nvidia::apex::ExplicitVertexFormat |
mHasDynamicBinormals | nvidia::apex::ExplicitVertexFormat |
mHasDynamicColors | nvidia::apex::ExplicitVertexFormat |
mHasDynamicDisplacements | nvidia::apex::ExplicitVertexFormat |
mHasDynamicNormals | nvidia::apex::ExplicitVertexFormat |
mHasDynamicPositions | nvidia::apex::ExplicitVertexFormat |
mHasDynamicSeparateBoneBuffer | nvidia::apex::ExplicitVertexFormat |
mHasDynamicTangents | nvidia::apex::ExplicitVertexFormat |
mHasStaticBinormals | nvidia::apex::ExplicitVertexFormat |
mHasStaticColors | nvidia::apex::ExplicitVertexFormat |
mHasStaticDisplacements | nvidia::apex::ExplicitVertexFormat |
mHasStaticNormals | nvidia::apex::ExplicitVertexFormat |
mHasStaticPositions | nvidia::apex::ExplicitVertexFormat |
mHasStaticSeparateBoneBuffer | nvidia::apex::ExplicitVertexFormat |
mHasStaticTangents | nvidia::apex::ExplicitVertexFormat |
mUVCount | nvidia::apex::ExplicitVertexFormat |
mWinding | nvidia::apex::ExplicitVertexFormat |
operator!=(const ExplicitVertexFormat &data) const | nvidia::apex::ExplicitVertexFormat | [inline]
operator==(const ExplicitVertexFormat &data) const | nvidia::apex::ExplicitVertexFormat | [inline]
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::FractureEventHeader Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureEventHeader
Public Attributes
nvidia::apex::FractureEventHeader Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | userActorID
User actor ID.
uint32_t | fractureEventCount
Fracture event count.
FractureEventUnit * fractureEventBufferStart
Fracture event buffer start.
FractureEventHeader * next
Pointer to next FractureEventHeader structure.

Detailed Description

Fracture event header.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureEventHeader
nvidia::apex::FractureEventHeader Member List
This is the complete list of members for nvidia::apex::FractureEventHeader, including all inherited members.
fractureEventBufferStart | nvidia::apex::FractureEventHeader
fractureEventCount | nvidia::apex::FractureEventHeader
next | nvidia::apex::FractureEventHeader
userActorID | nvidia::apex::FractureEventHeader
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::FractureEventUnit Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureEventUnit
Public Attributes
nvidia::apex::FractureEventUnit Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Attributes

uint32_t | chunkIndex
Chunk index.
uint32_t | fractureEventFlags
Fracture event flags.
PxVec3 | position
Position.
PxVec3 | direction
Direction.
PxVec3 | impulse
Impulse.

Detailed Description

Fracture event unit.

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureEventUnit
nvidia::apex::FractureEventUnit Member List
This is the complete list of members for nvidia::apex::FractureEventUnit, including all inherited members.
chunkIndex | nvidia::apex::FractureEventUnit
direction | nvidia::apex::FractureEventUnit
fractureEventFlags | nvidia::apex::FractureEventUnit
impulse | nvidia::apex::FractureEventUnit
position | nvidia::apex::FractureEventUnit
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::FractureMaterialDesc Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureMaterialDesc
Public Member Functions | Public Attributes
nvidia::apex::FractureMaterialDesc Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

FractureMaterialDesc ()
void | setToDefault ()

Public Attributes

PxVec2 | uvScale
PxVec2 | uvOffset
PxVec3 | tangent
float | uAngle
uint32_t | interiorSubmeshIndex

Detailed Description

FractureMaterialDesc

Descriptor for materials applied to interior faces.

Constructor & Destructor Documentation

nvidia::apex::FractureMaterialDesc::FractureMaterialDesc ( ) [inline]

Constructor sets defaults

Member Function Documentation

void nvidia::apex::FractureMaterialDesc::setToDefault ( ) [inline]

Set default values: uvScale = PxVec2(1.0f); uvOffset = PxVec2(0.0f); tangent = PxVec3(0.0f); uAngle = 0.0f; interiorSubmeshIndex = 0;

Member Data Documentation

uint32_t nvidia::apex::FractureMaterialDesc::interiorSubmeshIndex

The submesh index to use for the newly-created triangles. If an invalid index is given, 0 will be used.

PxVec3 nvidia::apex::FractureMaterialDesc::tangent

World space vector specifying surface tangent direction. If this vector is (0.0f,0.0f,0.0f), then an arbitrary direction will be chosen. Default = (0.0f,0.0f,0.0f).

float nvidia::apex::FractureMaterialDesc::uAngle

Angle from tangent direction for the u coordinate axis. Default = 0.0f.

PxVec2 nvidia::apex::FractureMaterialDesc::uvOffset

A UV origin offset for interior materials. Default = (0.0f,0.0f).

PxVec2 nvidia::apex::FractureMaterialDesc::uvScale

The UV scale (geometric distance/unit texture distance) for interior materials. Default = (1.0f,1.0f).

The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureMaterialDesc
nvidia::apex::FractureMaterialDesc Member List
This is the complete list of members for nvidia::apex::FractureMaterialDesc, including all inherited members.
FractureMaterialDesc() | nvidia::apex::FractureMaterialDesc | [inline]
interiorSubmeshIndex | nvidia::apex::FractureMaterialDesc |
setToDefault() | nvidia::apex::FractureMaterialDesc | [inline]
tangent | nvidia::apex::FractureMaterialDesc |
uAngle | nvidia::apex::FractureMaterialDesc |
uvOffset | nvidia::apex::FractureMaterialDesc |
uvScale | nvidia::apex::FractureMaterialDesc |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::FractureMethod Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureMethod
Public Types
nvidia::apex::FractureMethod Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Types

enum Enum {
Unknown,
Slice,
Cutout,
Voronoi,
FractureMethodCount
}

Detailed Description

Enumeration of current fracture methods. Used when an authored mesh needs to know how it was created, for example if we need to re-apply UV mapping information.

Member Enumeration Documentation

enum nvidia::apex::FractureMethod::Enum

Enum of fracture methods

The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • FractureMethod
nvidia::apex::FractureMethod Member List
This is the complete list of members for nvidia::apex::FractureMethod, including all inherited members.
Cutout enum value (defined in nvidia::apex::FractureMethod) | nvidia::apex::FractureMethod
Enum enum name | nvidia::apex::FractureMethod
FractureMethodCount enum value (defined in nvidia::apex::FractureMethod) | nvidia::apex::FractureMethod
Slice enum value (defined in nvidia::apex::FractureMethod) | nvidia::apex::FractureMethod
Unknown enum value (defined in nvidia::apex::FractureMethod) | nvidia::apex::FractureMethod
Voronoi enum value (defined in nvidia::apex::FractureMethod) | nvidia::apex::FractureMethod
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::GroupsFilterOp Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroupsFilterOp
Public Types
nvidia::apex::GroupsFilterOp Struct Reference

Collision groups filtering operations. More...

#include <ApexSDK.h>

List of all members.

Public Types

enum Enum {
AND,
OR,
XOR,
NAND,
NOR,
NXOR,
SWAP_AND
}
Enum of names for group filtering operations.

Detailed Description

Collision groups filtering operations.

The documentation for this struct was generated from the following file:
  • ApexSDK.h
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • GroupsFilterOp
nvidia::apex::GroupsFilterOp Member List
This is the complete list of members for nvidia::apex::GroupsFilterOp, including all inherited members.
AND enum value (defined in nvidia::apex::GroupsFilterOp) | nvidia::apex::GroupsFilterOp
Enum enum name | nvidia::apex::GroupsFilterOp
NAND enum value (defined in nvidia::apex::GroupsFilterOp) | nvidia::apex::GroupsFilterOp
NOR enum value (defined in nvidia::apex::GroupsFilterOp) | nvidia::apex::GroupsFilterOp
NXOR enum value (defined in nvidia::apex::GroupsFilterOp) | nvidia::apex::GroupsFilterOp
OR enum value (defined in nvidia::apex::GroupsFilterOp) | nvidia::apex::GroupsFilterOp
SWAP_AND enum value (defined in nvidia::apex::GroupsFilterOp) | nvidia::apex::GroupsFilterOp
XOR enum value (defined in nvidia::apex::GroupsFilterOp) | nvidia::apex::GroupsFilterOp
Generated on Sat Dec 1 2018 10:18:30


APEX Framework: nvidia::apex::ImpactDamageEventData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactDamageEventData
Public Attributes
nvidia::apex::ImpactDamageEventData Struct Reference

#include <ModuleDestructible.h>

Inheritance diagram for nvidia::apex::ImpactDamageEventData:
nvidia::apex::DamageEventCoreData

List of all members.

Public Attributes

nvidia::DestructibleActor * destructible
The destructible hit by the impacting actor.
PxVec3 | direction
The position, in world space, from which the damage is applied.
physx::PxActor const * | impactDamageActor
Other PhysX actor that caused damage.

Detailed Description

Extended damage event data, used for impact damage reports

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ImpactDamageEventData
nvidia::apex::ImpactDamageEventData Member List
This is the complete list of members for nvidia::apex::ImpactDamageEventData, including all inherited members.
chunkIndexInAsset | nvidia::apex::DamageEventCoreData
damage | nvidia::apex::DamageEventCoreData
destructible | nvidia::apex::ImpactDamageEventData
direction | nvidia::apex::ImpactDamageEventData
impactDamageActor | nvidia::apex::ImpactDamageEventData
position | nvidia::apex::DamageEventCoreData
radius | nvidia::apex::DamageEventCoreData
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::IofxCommonRenderData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxCommonRenderData
Public Attributes
nvidia::apex::IofxCommonRenderData Struct Reference

IofxCommonRenderData stores common render data for one IOFX Renderable. More...

#include <IofxRenderable.h>

Inheritance diagram for nvidia::apex::IofxCommonRenderData:
nvidia::apex::IofxMeshRenderData nvidia::apex::IofxSpriteRenderData

List of all members.

Public Attributes

uint32_t | startIndex
index of the first particle in render buffer
uint32_t | objectCount
number of particles in render buffer
const char * | renderResourceNameSpace
render resource name space
const char * | renderResourceName
render resource name
void * | renderResource
render resource

Detailed Description

IofxCommonRenderData stores common render data for one IOFX Renderable.

The documentation for this struct was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxCommonRenderData
nvidia::apex::IofxCommonRenderData Member List
This is the complete list of members for nvidia::apex::IofxCommonRenderData, including all inherited members.
objectCount | nvidia::apex::IofxCommonRenderData
renderResource | nvidia::apex::IofxCommonRenderData
renderResourceName | nvidia::apex::IofxCommonRenderData
renderResourceNameSpace | nvidia::apex::IofxCommonRenderData
startIndex | nvidia::apex::IofxCommonRenderData
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxMeshRenderData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshRenderData
Public Attributes
nvidia::apex::IofxMeshRenderData Struct Reference

IofxMeshRenderData stores mesh render data for one IOFX Renderable. More...

#include <IofxRenderable.h>

Inheritance diagram for nvidia::apex::IofxMeshRenderData:
nvidia::apex::IofxCommonRenderData

List of all members.

Public Attributes

const IofxMeshSharedRenderData * sharedRenderData
reference to Mesh shared render data

Detailed Description

IofxMeshRenderData stores mesh render data for one IOFX Renderable.

The documentation for this struct was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshRenderData
nvidia::apex::IofxMeshRenderData Member List
This is the complete list of members for nvidia::apex::IofxMeshRenderData, including all inherited members.
objectCount | nvidia::apex::IofxCommonRenderData
renderResource | nvidia::apex::IofxCommonRenderData
renderResourceName | nvidia::apex::IofxCommonRenderData
renderResourceNameSpace | nvidia::apex::IofxCommonRenderData
sharedRenderData | nvidia::apex::IofxMeshRenderData
startIndex | nvidia::apex::IofxCommonRenderData
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxMeshRenderLayout Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshRenderLayout
Public Member Functions | Public Attributes
nvidia::apex::IofxMeshRenderLayout Struct Reference

Describes the layout for mesh rendering. More...

#include <IofxRenderCallback.h>

List of all members.

Public Member Functions

void | setDefaults ()
Reset to default values.
bool | isValid (void) const
Check if parameter's values are correct.
bool | isTheSameAs (const IofxMeshRenderLayout &other) const
Check if this object is the same as other.

Public Attributes

UserRenderBufferDesc bufferDesc
Render buffer desc.
uint32_t | offsets [IofxMeshRenderLayoutElement::MAX_COUNT]
Array of the corresponding offsets (in bytes) for each layout element.
uint32_t | stride
The stride between objects in render buffer.

Detailed Description

Describes the layout for mesh rendering.

The documentation for this struct was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshRenderLayout
nvidia::apex::IofxMeshRenderLayout Member List
This is the complete list of members for nvidia::apex::IofxMeshRenderLayout, including all inherited members.
bufferDesc | nvidia::apex::IofxMeshRenderLayout |
IofxMeshRenderLayout(void) (defined in nvidia::apex::IofxMeshRenderLayout) | nvidia::apex::IofxMeshRenderLayout | [inline]
isTheSameAs(const IofxMeshRenderLayout &other) const | nvidia::apex::IofxMeshRenderLayout | [inline]
isValid(void) const | nvidia::apex::IofxMeshRenderLayout | [inline]
offsets | nvidia::apex::IofxMeshRenderLayout |
setDefaults() | nvidia::apex::IofxMeshRenderLayout | [inline]
stride | nvidia::apex::IofxMeshRenderLayout |
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxMeshRenderLayoutElement Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshRenderLayoutElement
Public Types | Static Public Member Functions
nvidia::apex::IofxMeshRenderLayoutElement Struct Reference

Enumerates the potential IOFX mesh render layout elements. More...

#include <IofxRenderCallback.h>

List of all members.

Public Types

enum Enum {
POSITION_FLOAT3,
ROTATION_SCALE_FLOAT3x3,
POSE_FLOAT3x4,
VELOCITY_LIFE_FLOAT4,
DENSITY_FLOAT1,
COLOR_RGBA8,
COLOR_BGRA8,
COLOR_FLOAT4,
USER_DATA_UINT1,
MAX_COUNT
}
Enum of IOFX mesh render layout elements.

Static Public Member Functions

static PX_INLINE
RenderDataFormat::Enum 		getFormat (Enum element)
Get layout element format.

Detailed Description

Enumerates the potential IOFX mesh render layout elements.

The documentation for this struct was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshRenderLayoutElement
nvidia::apex::IofxMeshRenderLayoutElement Member List
This is the complete list of members for nvidia::apex::IofxMeshRenderLayoutElement, including all inherited members.
COLOR_BGRA8 enum value (defined in nvidia::apex::IofxMeshRenderLayoutElement) | nvidia::apex::IofxMeshRenderLayoutElement |
COLOR_FLOAT4 enum value (defined in nvidia::apex::IofxMeshRenderLayoutElement) | nvidia::apex::IofxMeshRenderLayoutElement |
COLOR_RGBA8 enum value (defined in nvidia::apex::IofxMeshRenderLayoutElement) | nvidia::apex::IofxMeshRenderLayoutElement |
DENSITY_FLOAT1 enum value (defined in nvidia::apex::IofxMeshRenderLayoutElement) | nvidia::apex::IofxMeshRenderLayoutElement |
Enum enum name | nvidia::apex::IofxMeshRenderLayoutElement |
getFormat(Enum element) | nvidia::apex::IofxMeshRenderLayoutElement | [inline, static]
MAX_COUNT enum value (defined in nvidia::apex::IofxMeshRenderLayoutElement) | nvidia::apex::IofxMeshRenderLayoutElement |
POSE_FLOAT3x4 enum value (defined in nvidia::apex::IofxMeshRenderLayoutElement) | nvidia::apex::IofxMeshRenderLayoutElement |
POSITION_FLOAT3 enum value (defined in nvidia::apex::IofxMeshRenderLayoutElement) | nvidia::apex::IofxMeshRenderLayoutElement |
ROTATION_SCALE_FLOAT3x3 enum value (defined in nvidia::apex::IofxMeshRenderLayoutElement) | nvidia::apex::IofxMeshRenderLayoutElement |
USER_DATA_UINT1 enum value (defined in nvidia::apex::IofxMeshRenderLayoutElement) | nvidia::apex::IofxMeshRenderLayoutElement |
VELOCITY_LIFE_FLOAT4 enum value (defined in nvidia::apex::IofxMeshRenderLayoutElement) | nvidia::apex::IofxMeshRenderLayoutElement |
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxMeshSharedRenderData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshSharedRenderData
Public Attributes
nvidia::apex::IofxMeshSharedRenderData Struct Reference

IofxMeshSharedRenderData stores mesh render data shared by several IOFX Renderables. More...

#include <IofxRenderable.h>

Inheritance diagram for nvidia::apex::IofxMeshSharedRenderData:
nvidia::apex::IofxSharedRenderData

List of all members.

Public Attributes

IofxMeshRenderLayout meshRenderLayout
mesh render layout
UserRenderBuffer * meshRenderBuffer
mesh render buffer

Detailed Description

IofxMeshSharedRenderData stores mesh render data shared by several IOFX Renderables.

The documentation for this struct was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshSharedRenderData
nvidia::apex::IofxMeshSharedRenderData Member List
This is the complete list of members for nvidia::apex::IofxMeshSharedRenderData, including all inherited members.
activeObjectCount | nvidia::apex::IofxSharedRenderData
maxObjectCount | nvidia::apex::IofxSharedRenderData
meshRenderBuffer | nvidia::apex::IofxMeshSharedRenderData
meshRenderLayout | nvidia::apex::IofxMeshSharedRenderData
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxRenderSemantic Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderSemantic
Public Types
nvidia::apex::IofxRenderSemantic Struct Reference

Enumerates the potential IOFX render semantics. More...

#include <IofxRenderCallback.h>

List of all members.

Public Types

enum Enum {
POSITION = 0,
COLOR,
VELOCITY,
SCALE,
LIFE_REMAIN,
DENSITY,
SUBTEXTURE,
ORIENTATION,
ROTATION,
USER_DATA,
NUM_SEMANTICS
}
Enum of IOFX render semantics. More...

Detailed Description

Enumerates the potential IOFX render semantics.

Member Enumeration Documentation

enum nvidia::apex::IofxRenderSemantic::Enum

Enum of IOFX render semantics.

Enumerator:
POSITION

Position of particle.

COLOR

Color of particle.

VELOCITY

Linear velocity of particle.

SCALE

Scale of particle.

LIFE_REMAIN

1.0 (new) .. 0.0 (dead)

DENSITY

Particle density.

SUBTEXTURE

Sub-texture index of particle.

ORIENTATION

2D particle orientation (angle in radians, CCW in screen plane)

ROTATION

3D particle rotation

USER_DATA

User data - 32 bits (passed from Emitter)

NUM_SEMANTICS

Count of semantics, not a valid semantic.

The documentation for this struct was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderSemantic
nvidia::apex::IofxRenderSemantic Member List
This is the complete list of members for nvidia::apex::IofxRenderSemantic, including all inherited members.
COLOR enum value | nvidia::apex::IofxRenderSemantic
DENSITY enum value | nvidia::apex::IofxRenderSemantic
Enum enum name | nvidia::apex::IofxRenderSemantic
LIFE_REMAIN enum value | nvidia::apex::IofxRenderSemantic
NUM_SEMANTICS enum value | nvidia::apex::IofxRenderSemantic
ORIENTATION enum value | nvidia::apex::IofxRenderSemantic
POSITION enum value | nvidia::apex::IofxRenderSemantic
ROTATION enum value | nvidia::apex::IofxRenderSemantic
SCALE enum value | nvidia::apex::IofxRenderSemantic
SUBTEXTURE enum value | nvidia::apex::IofxRenderSemantic
USER_DATA enum value | nvidia::apex::IofxRenderSemantic
VELOCITY enum value | nvidia::apex::IofxRenderSemantic
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxSharedRenderData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSharedRenderData
Public Attributes
nvidia::apex::IofxSharedRenderData Struct Reference

IofxSharedRenderData stores common render data shared by several IOFX Renderables. More...

#include <IofxRenderable.h>

Inheritance diagram for nvidia::apex::IofxSharedRenderData:
nvidia::apex::IofxMeshSharedRenderData nvidia::apex::IofxSpriteSharedRenderData

List of all members.

Public Attributes

uint32_t | maxObjectCount
maximum number of particles
uint32_t | activeObjectCount
currently active number of particles

Detailed Description

IofxSharedRenderData stores common render data shared by several IOFX Renderables.

The documentation for this struct was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSharedRenderData
nvidia::apex::IofxSharedRenderData Member List
This is the complete list of members for nvidia::apex::IofxSharedRenderData, including all inherited members.
activeObjectCount | nvidia::apex::IofxSharedRenderData
maxObjectCount | nvidia::apex::IofxSharedRenderData
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxSpriteRenderData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderData
Public Attributes
nvidia::apex::IofxSpriteRenderData Struct Reference

IofxSpriteRenderData stores sprite render data for one IOFX Renderable. More...

#include <IofxRenderable.h>

Inheritance diagram for nvidia::apex::IofxSpriteRenderData:
nvidia::apex::IofxCommonRenderData

List of all members.

Public Attributes

uint32_t | visibleCount
number of visible particles (if sprite depth sorting is enabled, includes only particles in front of the view frustrum)
const IofxSpriteSharedRenderData * | sharedRenderData
reference to Sprite shared render data

Detailed Description

IofxSpriteRenderData stores sprite render data for one IOFX Renderable.

The documentation for this struct was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderData
nvidia::apex::IofxSpriteRenderData Member List
This is the complete list of members for nvidia::apex::IofxSpriteRenderData, including all inherited members.
objectCount | nvidia::apex::IofxCommonRenderData
renderResource | nvidia::apex::IofxCommonRenderData
renderResourceName | nvidia::apex::IofxCommonRenderData
renderResourceNameSpace | nvidia::apex::IofxCommonRenderData
sharedRenderData | nvidia::apex::IofxSpriteRenderData
startIndex | nvidia::apex::IofxCommonRenderData
visibleCount | nvidia::apex::IofxSpriteRenderData
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxSpriteRenderLayout Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderLayout
Public Member Functions | Public Attributes | Static Public Attributes
nvidia::apex::IofxSpriteRenderLayout Struct Reference

Describes the layout for sprite rendering. More...

#include <IofxRenderCallback.h>

List of all members.

Public Member Functions

void | setDefaults ()
Reset to default values.
bool | isValid (void) const
Check if parameter's values are correct.
bool | isTheSameAs (const IofxSpriteRenderLayout &other) const
Check if this object is the same as other.

Public Attributes

UserRenderBufferDesc bufferDesc
Render buffer desc.
uint32_t | offsets [IofxSpriteRenderLayoutElement::MAX_COUNT]
Array of the corresponding offsets (in bytes) for each layout element.
uint32_t | stride
The stride between objects in render buffer.
uint32_t | surfaceCount
Number of render surfaces (if zero render buffer is used)
IofxSpriteRenderLayoutSurfaceElement::Enum surfaceElements [MAX_SURFACE_COUNT]
Layout element for each render surface (should be valid for all indices < surfaceCount)
UserRenderSurfaceDesc surfaceDescs [MAX_SURFACE_COUNT]
Description for each render surface (should be valid for all indices < surfaceCount)

Static Public Attributes

static const uint32_t | MAX_SURFACE_COUNT = 4
Max number of supported render surfaces.

Detailed Description

Describes the layout for sprite rendering.

The documentation for this struct was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderLayout
nvidia::apex::IofxSpriteRenderLayout Member List
This is the complete list of members for nvidia::apex::IofxSpriteRenderLayout, including all inherited members.
bufferDesc | nvidia::apex::IofxSpriteRenderLayout |
IofxSpriteRenderLayout(void) (defined in nvidia::apex::IofxSpriteRenderLayout) | nvidia::apex::IofxSpriteRenderLayout | [inline]
isTheSameAs(const IofxSpriteRenderLayout &other) const | nvidia::apex::IofxSpriteRenderLayout | [inline]
isValid(void) const | nvidia::apex::IofxSpriteRenderLayout | [inline]
MAX_SURFACE_COUNT | nvidia::apex::IofxSpriteRenderLayout | [static]
offsets | nvidia::apex::IofxSpriteRenderLayout |
setDefaults() | nvidia::apex::IofxSpriteRenderLayout | [inline]
stride | nvidia::apex::IofxSpriteRenderLayout |
surfaceCount | nvidia::apex::IofxSpriteRenderLayout |
surfaceDescs | nvidia::apex::IofxSpriteRenderLayout |
surfaceElements | nvidia::apex::IofxSpriteRenderLayout |
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxSpriteRenderLayoutElement Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderLayoutElement
Public Types | Static Public Member Functions
nvidia::apex::IofxSpriteRenderLayoutElement Struct Reference

Enumerates the potential IOFX mesh render layout elements. More...

#include <IofxRenderCallback.h>

List of all members.

Public Types

enum Enum {
POSITION_FLOAT3,
COLOR_RGBA8,
COLOR_BGRA8,
COLOR_FLOAT4,
VELOCITY_FLOAT3,
SCALE_FLOAT2,
LIFE_REMAIN_FLOAT1,
DENSITY_FLOAT1,
SUBTEXTURE_FLOAT1,
ORIENTATION_FLOAT1,
USER_DATA_UINT1,
MAX_COUNT
}
Enum of IOFX sprite render layout elements.

Static Public Member Functions

static PX_INLINE
RenderDataFormat::Enum 		getFormat (Enum element)
Get layout element format.

Detailed Description

Enumerates the potential IOFX mesh render layout elements.

The documentation for this struct was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderLayoutElement
nvidia::apex::IofxSpriteRenderLayoutElement Member List
This is the complete list of members for nvidia::apex::IofxSpriteRenderLayoutElement, including all inherited members.
COLOR_BGRA8 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutElement) | nvidia::apex::IofxSpriteRenderLayoutElement |
COLOR_FLOAT4 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutElement) | nvidia::apex::IofxSpriteRenderLayoutElement |
COLOR_RGBA8 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutElement) | nvidia::apex::IofxSpriteRenderLayoutElement |
DENSITY_FLOAT1 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutElement) | nvidia::apex::IofxSpriteRenderLayoutElement |
Enum enum name | nvidia::apex::IofxSpriteRenderLayoutElement |
getFormat(Enum element) | nvidia::apex::IofxSpriteRenderLayoutElement | [inline, static]
LIFE_REMAIN_FLOAT1 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutElement) | nvidia::apex::IofxSpriteRenderLayoutElement |
MAX_COUNT enum value (defined in nvidia::apex::IofxSpriteRenderLayoutElement) | nvidia::apex::IofxSpriteRenderLayoutElement |
ORIENTATION_FLOAT1 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutElement) | nvidia::apex::IofxSpriteRenderLayoutElement |
POSITION_FLOAT3 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutElement) | nvidia::apex::IofxSpriteRenderLayoutElement |
SCALE_FLOAT2 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutElement) | nvidia::apex::IofxSpriteRenderLayoutElement |
SUBTEXTURE_FLOAT1 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutElement) | nvidia::apex::IofxSpriteRenderLayoutElement |
USER_DATA_UINT1 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutElement) | nvidia::apex::IofxSpriteRenderLayoutElement |
VELOCITY_FLOAT3 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutElement) | nvidia::apex::IofxSpriteRenderLayoutElement |
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxSpriteRenderLayoutSurfaceElement Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderLayoutSurfaceElement
Public Types | Static Public Member Functions
nvidia::apex::IofxSpriteRenderLayoutSurfaceElement Struct Reference

Enumerates the potential IOFX sprite render layout surface elements. More...

#include <IofxRenderCallback.h>

List of all members.

Public Types

enum Enum {
POSITION_FLOAT4,
SCALE_ORIENT_SUBTEX_FLOAT4,
COLOR_RGBA8,
COLOR_BGRA8,
COLOR_FLOAT4,
MAX_COUNT
}
Enum of IOFX sprite render layout surface elements. More...

Static Public Member Functions

static PX_INLINE
RenderDataFormat::Enum 		getFormat (Enum element)
Get layout element format.

Detailed Description

Enumerates the potential IOFX sprite render layout surface elements.

Member Enumeration Documentation

enum nvidia::apex::IofxSpriteRenderLayoutSurfaceElement::Enum

Enum of IOFX sprite render layout surface elements.

Enumerator:
POSITION_FLOAT4

float4(POSITION.x, POSITION.y, POSITION.z, 1)

SCALE_ORIENT_SUBTEX_FLOAT4

float4(SCALE.x, SCALE.y, ORIENTATION, SUBTEXTURE)

The documentation for this struct was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderLayoutSurfaceElement
nvidia::apex::IofxSpriteRenderLayoutSurfaceElement Member List
This is the complete list of members for nvidia::apex::IofxSpriteRenderLayoutSurfaceElement, including all inherited members.
COLOR_BGRA8 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutSurfaceElement) | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
COLOR_FLOAT4 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutSurfaceElement) | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
COLOR_RGBA8 enum value (defined in nvidia::apex::IofxSpriteRenderLayoutSurfaceElement) | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
Enum enum name | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
getFormat(Enum element) | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement | [inline, static]
MAX_COUNT enum value (defined in nvidia::apex::IofxSpriteRenderLayoutSurfaceElement) | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
POSITION_FLOAT4 enum value | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
SCALE_ORIENT_SUBTEX_FLOAT4 enum value | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::IofxSpriteSharedRenderData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteSharedRenderData
Public Attributes
nvidia::apex::IofxSpriteSharedRenderData Struct Reference

IofxSpriteSharedRenderData stores sprite render data shared by several IOFX Renderables. More...

#include <IofxRenderable.h>

Inheritance diagram for nvidia::apex::IofxSpriteSharedRenderData:
nvidia::apex::IofxSharedRenderData

List of all members.

Public Attributes

IofxSpriteRenderLayout spriteRenderLayout
sprite render layout
UserRenderBuffer * spriteRenderBuffer
sprite render buffer
UserRenderSurface * spriteRenderSurfaces [IofxSpriteRenderLayout::MAX_SURFACE_COUNT]
sprite render surfaces

Detailed Description

IofxSpriteSharedRenderData stores sprite render data shared by several IOFX Renderables.

The documentation for this struct was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteSharedRenderData
nvidia::apex::IofxSpriteSharedRenderData Member List
This is the complete list of members for nvidia::apex::IofxSpriteSharedRenderData, including all inherited members.
activeObjectCount | nvidia::apex::IofxSharedRenderData
maxObjectCount | nvidia::apex::IofxSharedRenderData
spriteRenderBuffer | nvidia::apex::IofxSpriteSharedRenderData
spriteRenderLayout | nvidia::apex::IofxSpriteSharedRenderData
spriteRenderSurfaces | nvidia::apex::IofxSpriteSharedRenderData
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::MaterialFrame Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MaterialFrame
Public Member Functions | Public Attributes
nvidia::apex::MaterialFrame Struct Reference

#include <ExplicitHierarchicalMesh.h>

List of all members.

Public Member Functions

void | buildCoordinateSystemFromMaterialDesc (const nvidia::FractureMaterialDesc &materialDesc, const PxPlane &plane)

Public Attributes

PxMat44 | mCoordinateSystem
Coordinate system.
PxPlane | mUVPlane
UV plane.
PxVec2 | mUVScale
UV scale.
PxVec2 | mUVOffset
UV offset.
uint32_t | mFractureMethod
Fracture method.
int32_t | mFractureIndex
Fracture index.
uint32_t | mSliceDepth
The depth being created when this split is done. mSliceDepth = 0 means "unknown".

Detailed Description

A reference frame for applying UV mapping to triangles. Also includes the fracturing method and an index which is used internally for such operations as re-applying UV mapping information.

Member Function Documentation

void nvidia::apex::MaterialFrame::buildCoordinateSystemFromMaterialDesc | ( | const nvidia::FractureMaterialDesc & | materialDesc,
 |  | const PxPlane & | plane
 | ) |  | [inline]

Builds coordinate system from material desc

The documentation for this struct was generated from the following file:
  • ExplicitHierarchicalMesh.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MaterialFrame
nvidia::apex::MaterialFrame Member List
This is the complete list of members for nvidia::apex::MaterialFrame, including all inherited members.
buildCoordinateSystemFromMaterialDesc(const nvidia::FractureMaterialDesc &materialDesc, const PxPlane &plane) | nvidia::apex::MaterialFrame | [inline]
MaterialFrame() (defined in nvidia::apex::MaterialFrame) | nvidia::apex::MaterialFrame | [inline]
mCoordinateSystem | nvidia::apex::MaterialFrame |
mFractureIndex | nvidia::apex::MaterialFrame |
mFractureMethod | nvidia::apex::MaterialFrame |
mSliceDepth | nvidia::apex::MaterialFrame |
mUVOffset | nvidia::apex::MaterialFrame |
mUVPlane | nvidia::apex::MaterialFrame |
mUVScale | nvidia::apex::MaterialFrame |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::MaterialLookupCallback::MaterialRequest Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MaterialLookupCallback
  • MaterialRequest
Public Attributes
nvidia::apex::MaterialLookupCallback::MaterialRequest Struct Reference

Material request structure. More...

#include <GroundEmitterActor.h>

List of all members.

Public Attributes

PxVec3 | samplePosition
test point position. This is filled by the emitter
uint32_t | outMaterialID
ID of the material at the hitpoint. This must be filled by the user.

Detailed Description

Material request structure.

The documentation for this struct was generated from the following file:
  • GroundEmitterActor.h
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • MaterialLookupCallback
  • MaterialRequest
nvidia::apex::MaterialLookupCallback::MaterialRequest Member List
This is the complete list of members for nvidia::apex::MaterialLookupCallback::MaterialRequest, including all inherited members.
outMaterialID | nvidia::apex::MaterialLookupCallback::MaterialRequest
samplePosition | nvidia::apex::MaterialLookupCallback::MaterialRequest
Generated on Sat Dec 1 2018 10:18:32


APEX Framework: nvidia::apex::ModuleDestructibleConst Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleDestructibleConst
Public Types
nvidia::apex::ModuleDestructibleConst Struct Reference

#include <ModuleDestructible.h>

List of all members.

Public Types

enum Enum { INVALID_CHUNK_INDEX = -1 }

Detailed Description

Destructible module constants

Member Enumeration Documentation

enum nvidia::apex::ModuleDestructibleConst::Enum

Enum for invalid chunk index (-1)

Enumerator:
INVALID_CHUNK_INDEX

When a function returns a chunk index, or takes a chunk index as a parameter, this value indicates "no chunk."

The documentation for this struct was generated from the following file:
  • ModuleDestructible.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleDestructibleConst
nvidia::apex::ModuleDestructibleConst Member List
This is the complete list of members for nvidia::apex::ModuleDestructibleConst, including all inherited members.
Enum enum name | nvidia::apex::ModuleDestructibleConst
INVALID_CHUNK_INDEX enum value | nvidia::apex::ModuleDestructibleConst
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::ProjMatrixType Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ProjMatrixType
Public Types
nvidia::apex::ProjMatrixType Struct Reference

Types of projection matrices handled by APEX. More...

#include <Scene.h>

List of all members.

Public Types

enum Enum { USER_CUSTOMIZED = 0 }
Enum of the projection matrices types.

Detailed Description

Types of projection matrices handled by APEX.

USER_CUSTOMIZED : APEX simply uses the projection matrix given. Need to setProjParams()

The documentation for this struct was generated from the following file:
  • Scene.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ProjMatrixType
nvidia::apex::ProjMatrixType Member List
This is the complete list of members for nvidia::apex::ProjMatrixType, including all inherited members.
Enum enum name | nvidia::apex::ProjMatrixType
USER_CUSTOMIZED enum value (defined in nvidia::apex::ProjMatrixType) | nvidia::apex::ProjMatrixType
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::Range< T > Struct Template Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Range
Public Member Functions | Public Attributes
nvidia::apex::Range< T > Struct Template Reference

A structure that holds two templated values, a min and a max. More...

#include <Module.h>

List of all members.

Public Member Functions

Range (T inMin, T inMax)
Constructor, sets min amd max values.
bool | operator== (const Range &r) const
operator ==

Public Attributes

T | minimum
Minimal value.
T | maximum
Maximal value.

Detailed Description

template<typename T>
struct nvidia::apex::Range< T >

A structure that holds two templated values, a min and a max.

The documentation for this struct was generated from the following file:
  • Module.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Range
nvidia::apex::Range< T > Member List
This is the complete list of members for nvidia::apex::Range< T >, including all inherited members.
maximum | nvidia::apex::Range< T > |
minimum | nvidia::apex::Range< T > |
operator==(const Range &r) const | nvidia::apex::Range< T > | [inline]
Range() (defined in nvidia::apex::Range< T >) | nvidia::apex::Range< T > | [inline]
Range(T inMin, T inMax) | nvidia::apex::Range< T > | [inline]
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::RenderBoneSemantic Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderBoneSemantic
Public Types
nvidia::apex::RenderBoneSemantic Struct Reference

The semantics available for bone buffers. More...

#include <UserRenderBoneBufferDesc.h>

List of all members.

Public Types

enum Enum {
POSE = 0,
PREVIOUS_POSE,
NUM_SEMANTICS
}
Enum of the semantics available for bone buffers. More...

Detailed Description

The semantics available for bone buffers.

Member Enumeration Documentation

enum nvidia::apex::RenderBoneSemantic::Enum

Enum of the semantics available for bone buffers.

Enumerator:
POSE

A matrix that transforms from object space into animated object space or even world space.

PREVIOUS_POSE

The corresponding poses from the last frame.

NUM_SEMANTICS

Count of semantics, not a valid semantic.

The documentation for this struct was generated from the following file:
  • UserRenderBoneBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderBoneSemantic
nvidia::apex::RenderBoneSemantic Member List
This is the complete list of members for nvidia::apex::RenderBoneSemantic, including all inherited members.
Enum enum name | nvidia::apex::RenderBoneSemantic
NUM_SEMANTICS enum value | nvidia::apex::RenderBoneSemantic
POSE enum value | nvidia::apex::RenderBoneSemantic
PREVIOUS_POSE enum value | nvidia::apex::RenderBoneSemantic
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderBufferHint Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderBufferHint
Public Types
nvidia::apex::RenderBufferHint Struct Reference

Hint of the buffer data lifespan. More...

#include <UserRenderResourceManager.h>

List of all members.

Public Types

enum Enum {
STATIC = 0,
DYNAMIC,
STREAMING
}
Enum of hints of the buffer data lifespan.

Detailed Description

Hint of the buffer data lifespan.

The documentation for this struct was generated from the following file:
  • UserRenderResourceManager.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderBufferHint
nvidia::apex::RenderBufferHint Member List
This is the complete list of members for nvidia::apex::RenderBufferHint, including all inherited members.
DYNAMIC enum value (defined in nvidia::apex::RenderBufferHint) | nvidia::apex::RenderBufferHint
Enum enum name | nvidia::apex::RenderBufferHint
STATIC enum value (defined in nvidia::apex::RenderBufferHint) | nvidia::apex::RenderBufferHint
STREAMING enum value (defined in nvidia::apex::RenderBufferHint) | nvidia::apex::RenderBufferHint
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderCullMode Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderCullMode
Public Types
nvidia::apex::RenderCullMode Struct Reference

Possible triangle culling modes. More...

#include <UserRenderResourceManager.h>

List of all members.

Public Types

enum Enum {
CLOCKWISE = 0,
COUNTER_CLOCKWISE,
NONE
}
Enum of possible triangle culling mode types.

Detailed Description

Possible triangle culling modes.

The documentation for this struct was generated from the following file:
  • UserRenderResourceManager.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderCullMode
nvidia::apex::RenderCullMode Member List
This is the complete list of members for nvidia::apex::RenderCullMode, including all inherited members.
CLOCKWISE enum value (defined in nvidia::apex::RenderCullMode) | nvidia::apex::RenderCullMode
COUNTER_CLOCKWISE enum value (defined in nvidia::apex::RenderCullMode) | nvidia::apex::RenderCullMode
Enum enum name | nvidia::apex::RenderCullMode
NONE enum value (defined in nvidia::apex::RenderCullMode) | nvidia::apex::RenderCullMode
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderDataAccess Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderDataAccess
Public Types
nvidia::apex::RenderDataAccess Struct Reference

Type of render data. More...

#include <VertexFormat.h>

List of all members.

Public Types

enum Enum {
STATIC = 0,
DYNAMIC,
STREAMING,
ACCESS_TYPE_COUNT
}
Enum of type of render data.

Detailed Description

Type of render data.

The documentation for this struct was generated from the following file:
  • VertexFormat.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderDataAccess
nvidia::apex::RenderDataAccess Member List
This is the complete list of members for nvidia::apex::RenderDataAccess, including all inherited members.
ACCESS_TYPE_COUNT enum value (defined in nvidia::apex::RenderDataAccess) | nvidia::apex::RenderDataAccess
DYNAMIC enum value (defined in nvidia::apex::RenderDataAccess) | nvidia::apex::RenderDataAccess
Enum enum name | nvidia::apex::RenderDataAccess
STATIC enum value (defined in nvidia::apex::RenderDataAccess) | nvidia::apex::RenderDataAccess
STREAMING enum value (defined in nvidia::apex::RenderDataAccess) | nvidia::apex::RenderDataAccess
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderDataFormat Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderDataFormat
Public Types | Static Public Member Functions
nvidia::apex::RenderDataFormat Struct Reference

Enumeration of possible formats of various buffer semantics. More...

#include <RenderDataFormat.h>

List of all members.

Public Types

enum Enum {
UNSPECIFIED = 0,
UBYTE1 = 1,
UBYTE2 = 2,
UBYTE3 = 3,
UBYTE4 = 4,
USHORT1 = 5,
USHORT2 = 6,
USHORT3 = 7,
USHORT4 = 8,
SHORT1 = 9,
SHORT2 = 10,
SHORT3 = 11,
SHORT4 = 12,
UINT1 = 13,
UINT2 = 14,
UINT3 = 15,
UINT4 = 16,
R8G8B8A8 = 17,
B8G8R8A8 = 18,
R32G32B32A32_FLOAT = 19,
B32G32R32A32_FLOAT = 20,
BYTE_UNORM1 = 21,
BYTE_UNORM2 = 22,
BYTE_UNORM3 = 23,
BYTE_UNORM4 = 24,
SHORT_UNORM1 = 25,
SHORT_UNORM2 = 26,
SHORT_UNORM3 = 27,
SHORT_UNORM4 = 28,
BYTE_SNORM1 = 29,
BYTE_SNORM2 = 30,
BYTE_SNORM3 = 31,
BYTE_SNORM4 = 32,
SHORT_SNORM1 = 33,
SHORT_SNORM2 = 34,
SHORT_SNORM3 = 35,
SHORT_SNORM4 = 36,
HALF1 = 37,
HALF2 = 38,
HALF3 = 39,
HALF4 = 40,
FLOAT1 = 41,
FLOAT2 = 42,
FLOAT3 = 43,
FLOAT4 = 44,
FLOAT4x4 = 45,
FLOAT3x4 = 46,
FLOAT3x3 = 47,
FLOAT4_QUAT = 48,
BYTE_SNORM4_QUATXYZW = 49,
SHORT_SNORM4_QUATXYZW = 50,
NUM_FORMATS
}
the enum type More...

Static Public Member Functions

static PX_INLINE uint32_t getFormatDataSize (Enum format)
Get byte size of format type.

Detailed Description

Enumeration of possible formats of various buffer semantics.

N.B.: DO NOT CHANGE THE VALUES OF OLD FORMATS.

Member Enumeration Documentation

enum nvidia::apex::RenderDataFormat::Enum

the enum type

Enumerator:
UNSPECIFIED

No format (semantic not used)

Integer formats

UBYTE1

One unsigned 8-bit integer (uint8_t[1])

UBYTE2

Two unsigned 8-bit integers (uint8_t[2])

UBYTE3

Three unsigned 8-bit integers (uint8_t[3])

UBYTE4

Four unsigned 8-bit integers (uint8_t[4])

USHORT1

One unsigned 16-bit integer (uint16_t[1])

USHORT2

Two unsigned 16-bit integers (uint16_t[2])

USHORT3

Three unsigned 16-bit integers (uint16_t[3])

USHORT4

Four unsigned 16-bit integers (uint16_t[4])

SHORT1

One signed 16-bit integer (int16_t[1])

SHORT2

Two signed 16-bit integers (int16_t[2])

SHORT3

Three signed 16-bit integers (int16_t[3])

SHORT4

Four signed 16-bit integers (int16_t[4])

UINT1

One unsigned integer (uint32_t[1])

UINT2

Two unsigned integers (uint32_t[2])

UINT3

Three unsigned integers (uint32_t[3])

UINT4

Four unsigned integers (uint32_t[4])

Color formats

R8G8B8A8

Four unsigned bytes (uint8_t[4]) representing red, green, blue, alpha.

B8G8R8A8

Four unsigned bytes (uint8_t[4]) representing blue, green, red, alpha.

R32G32B32A32_FLOAT

Four floats (float[4]) representing red, green, blue, alpha.

B32G32R32A32_FLOAT

Four floats (float[4]) representing blue, green, red, alpha.

Normalized formats

BYTE_UNORM1

One unsigned normalized value in the range [0,1], packed into 8 bits (uint8_t[1])

BYTE_UNORM2

Two unsigned normalized value in the range [0,1], each packed into 8 bits (uint8_t[2])

BYTE_UNORM3

Three unsigned normalized value in the range [0,1], each packed into bits (uint8_t[3])

BYTE_UNORM4

Four unsigned normalized value in the range [0,1], each packed into 8 bits (uint8_t[4])

SHORT_UNORM1

One unsigned normalized value in the range [0,1], packed into 16 bits (uint16_t[1])

SHORT_UNORM2

Two unsigned normalized value in the range [0,1], each packed into 16 bits (uint16_t[2])

SHORT_UNORM3

Three unsigned normalized value in the range [0,1], each packed into 16 bits (uint16_t[3])

SHORT_UNORM4

Four unsigned normalized value in the range [0,1], each packed into 16 bits (uint16_t[4])

BYTE_SNORM1

One signed normalized value in the range [-1,1], packed into 8 bits (uint8_t[1])

BYTE_SNORM2

Two signed normalized value in the range [-1,1], each packed into 8 bits (uint8_t[2])

BYTE_SNORM3

Three signed normalized value in the range [-1,1], each packed into bits (uint8_t[3])

BYTE_SNORM4

Four signed normalized value in the range [-1,1], each packed into 8 bits (uint8_t[4])

SHORT_SNORM1

One signed normalized value in the range [-1,1], packed into 16 bits (uint16_t[1])

SHORT_SNORM2

Two signed normalized value in the range [-1,1], each packed into 16 bits (uint16_t[2])

SHORT_SNORM3

Three signed normalized value in the range [-1,1], each packed into 16 bits (uint16_t[3])

SHORT_SNORM4

Four signed normalized value in the range [-1,1], each packed into 16 bits (uint16_t[4])

Float formats

HALF1

One 16-bit floating point value.

HALF2

Two 16-bit floating point values.

HALF3

Three 16-bit floating point values.

HALF4

Four 16-bit floating point values.

FLOAT1

One 32-bit floating point value.

FLOAT2

Two 32-bit floating point values.

FLOAT3

Three 32-bit floating point values.

FLOAT4

Four 32-bit floating point values.

FLOAT4x4

A 4x4 matrix (see PxMat44)

FLOAT3x4

A 3x4 matrix (see float[12])

FLOAT3x3

A 3x3 matrix (see PxMat33)

FLOAT4_QUAT

A quaternion (see PxQuat)

BYTE_SNORM4_QUATXYZW

A normalized quaternion with signed byte elements, X,Y,Z,W format (uint8_t[4])

SHORT_SNORM4_QUATXYZW

A normalized quaternion with signed short elements, X,Y,Z,W format (uint16_t[4])

The documentation for this struct was generated from the following file:
  • RenderDataFormat.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderDataFormat
nvidia::apex::RenderDataFormat Member List
This is the complete list of members for nvidia::apex::RenderDataFormat, including all inherited members.
B32G32R32A32_FLOAT enum value | nvidia::apex::RenderDataFormat |
B8G8R8A8 enum value | nvidia::apex::RenderDataFormat |
BYTE_SNORM1 enum value | nvidia::apex::RenderDataFormat |
BYTE_SNORM2 enum value | nvidia::apex::RenderDataFormat |
BYTE_SNORM3 enum value | nvidia::apex::RenderDataFormat |
BYTE_SNORM4 enum value | nvidia::apex::RenderDataFormat |
BYTE_SNORM4_QUATXYZW enum value | nvidia::apex::RenderDataFormat |
BYTE_UNORM1 enum value | nvidia::apex::RenderDataFormat |
BYTE_UNORM2 enum value | nvidia::apex::RenderDataFormat |
BYTE_UNORM3 enum value | nvidia::apex::RenderDataFormat |
BYTE_UNORM4 enum value | nvidia::apex::RenderDataFormat |
Enum enum name | nvidia::apex::RenderDataFormat |
FLOAT1 enum value | nvidia::apex::RenderDataFormat |
FLOAT2 enum value | nvidia::apex::RenderDataFormat |
FLOAT3 enum value | nvidia::apex::RenderDataFormat |
FLOAT3x3 enum value | nvidia::apex::RenderDataFormat |
FLOAT3x4 enum value | nvidia::apex::RenderDataFormat |
FLOAT4 enum value | nvidia::apex::RenderDataFormat |
FLOAT4_QUAT enum value | nvidia::apex::RenderDataFormat |
FLOAT4x4 enum value | nvidia::apex::RenderDataFormat |
getFormatDataSize(Enum format) | nvidia::apex::RenderDataFormat | [inline, static]
HALF1 enum value | nvidia::apex::RenderDataFormat |
HALF2 enum value | nvidia::apex::RenderDataFormat |
HALF3 enum value | nvidia::apex::RenderDataFormat |
HALF4 enum value | nvidia::apex::RenderDataFormat |
NUM_FORMATS enum value (defined in nvidia::apex::RenderDataFormat) | nvidia::apex::RenderDataFormat |
R32G32B32A32_FLOAT enum value | nvidia::apex::RenderDataFormat |
R8G8B8A8 enum value | nvidia::apex::RenderDataFormat |
SHORT1 enum value | nvidia::apex::RenderDataFormat |
SHORT2 enum value | nvidia::apex::RenderDataFormat |
SHORT3 enum value | nvidia::apex::RenderDataFormat |
SHORT4 enum value | nvidia::apex::RenderDataFormat |
SHORT_SNORM1 enum value | nvidia::apex::RenderDataFormat |
SHORT_SNORM2 enum value | nvidia::apex::RenderDataFormat |
SHORT_SNORM3 enum value | nvidia::apex::RenderDataFormat |
SHORT_SNORM4 enum value | nvidia::apex::RenderDataFormat |
SHORT_SNORM4_QUATXYZW enum value | nvidia::apex::RenderDataFormat |
SHORT_UNORM1 enum value | nvidia::apex::RenderDataFormat |
SHORT_UNORM2 enum value | nvidia::apex::RenderDataFormat |
SHORT_UNORM3 enum value | nvidia::apex::RenderDataFormat |
SHORT_UNORM4 enum value | nvidia::apex::RenderDataFormat |
UBYTE1 enum value | nvidia::apex::RenderDataFormat |
UBYTE2 enum value | nvidia::apex::RenderDataFormat |
UBYTE3 enum value | nvidia::apex::RenderDataFormat |
UBYTE4 enum value | nvidia::apex::RenderDataFormat |
UINT1 enum value | nvidia::apex::RenderDataFormat |
UINT2 enum value | nvidia::apex::RenderDataFormat |
UINT3 enum value | nvidia::apex::RenderDataFormat |
UINT4 enum value | nvidia::apex::RenderDataFormat |
UNSPECIFIED enum value | nvidia::apex::RenderDataFormat |
USHORT1 enum value | nvidia::apex::RenderDataFormat |
USHORT2 enum value | nvidia::apex::RenderDataFormat |
USHORT3 enum value | nvidia::apex::RenderDataFormat |
USHORT4 enum value | nvidia::apex::RenderDataFormat |
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderInstanceLayoutElement Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderInstanceLayoutElement
Public Types | Static Public Member Functions
nvidia::apex::RenderInstanceLayoutElement Struct Reference

potential semantics of a sprite buffer More...

#include <UserRenderInstanceBufferDesc.h>

List of all members.

Public Types

enum Enum {
POSITION_FLOAT3,
ROTATION_SCALE_FLOAT3x3,
VELOCITY_LIFE_FLOAT4,
DENSITY_FLOAT1,
COLOR_RGBA8,
COLOR_BGRA8,
COLOR_FLOAT4,
UV_OFFSET_FLOAT2,
LOCAL_OFFSET_FLOAT3,
USER_DATA_UINT1,
POSE_FLOAT3x4,
NUM_SEMANTICS
}
Enum of sprite buffer semantics types.

Static Public Member Functions

static PX_INLINE
RenderDataFormat::Enum 		getSemanticFormat (Enum semantic)
Get semantic format.
static PX_INLINE
RenderInstanceSemantic::Enum 		getSemantic (Enum semantic)
Get semantic from layout element format.

Detailed Description

potential semantics of a sprite buffer

The documentation for this struct was generated from the following file:
  • UserRenderInstanceBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderInstanceLayoutElement
nvidia::apex::RenderInstanceLayoutElement Member List
This is the complete list of members for nvidia::apex::RenderInstanceLayoutElement, including all inherited members.
COLOR_BGRA8 enum value (defined in nvidia::apex::RenderInstanceLayoutElement) | nvidia::apex::RenderInstanceLayoutElement |
COLOR_FLOAT4 enum value (defined in nvidia::apex::RenderInstanceLayoutElement) | nvidia::apex::RenderInstanceLayoutElement |
COLOR_RGBA8 enum value (defined in nvidia::apex::RenderInstanceLayoutElement) | nvidia::apex::RenderInstanceLayoutElement |
DENSITY_FLOAT1 enum value (defined in nvidia::apex::RenderInstanceLayoutElement) | nvidia::apex::RenderInstanceLayoutElement |
Enum enum name | nvidia::apex::RenderInstanceLayoutElement |
getSemantic(Enum semantic) | nvidia::apex::RenderInstanceLayoutElement | [inline, static]
getSemanticFormat(Enum semantic) | nvidia::apex::RenderInstanceLayoutElement | [inline, static]
LOCAL_OFFSET_FLOAT3 enum value (defined in nvidia::apex::RenderInstanceLayoutElement) | nvidia::apex::RenderInstanceLayoutElement |
NUM_SEMANTICS enum value (defined in nvidia::apex::RenderInstanceLayoutElement) | nvidia::apex::RenderInstanceLayoutElement |
POSE_FLOAT3x4 enum value (defined in nvidia::apex::RenderInstanceLayoutElement) | nvidia::apex::RenderInstanceLayoutElement |
POSITION_FLOAT3 enum value (defined in nvidia::apex::RenderInstanceLayoutElement) | nvidia::apex::RenderInstanceLayoutElement |
ROTATION_SCALE_FLOAT3x3 enum value (defined in nvidia::apex::RenderInstanceLayoutElement) | nvidia::apex::RenderInstanceLayoutElement |
USER_DATA_UINT1 enum value (defined in nvidia::apex::RenderInstanceLayoutElement) | nvidia::apex::RenderInstanceLayoutElement |
UV_OFFSET_FLOAT2 enum value (defined in nvidia::apex::RenderInstanceLayoutElement) | nvidia::apex::RenderInstanceLayoutElement |
VELOCITY_LIFE_FLOAT4 enum value (defined in nvidia::apex::RenderInstanceLayoutElement) | nvidia::apex::RenderInstanceLayoutElement |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderInstanceSemantic Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderInstanceSemantic
Public Types
nvidia::apex::RenderInstanceSemantic Struct Reference

PX_PS4. More...

#include <UserRenderInstanceBufferDesc.h>

List of all members.

Public Types

enum Enum {
POSITION = 0,
ROTATION_SCALE,
VELOCITY_LIFE,
DENSITY,
COLOR,
UV_OFFSET,
LOCAL_OFFSET,
USER_DATA,
POSE,
NUM_SEMANTICS
}
Enume of the potential instance buffer semantics. More...

Detailed Description

PX_PS4.

Enumerates the potential instance buffer semantics

Member Enumeration Documentation

enum nvidia::apex::RenderInstanceSemantic::Enum

Enume of the potential instance buffer semantics.

Enumerator:
POSITION

position of instance

ROTATION_SCALE

rotation matrix and scale baked together

VELOCITY_LIFE

velocity and life remain (1.0=new .. 0.0=dead) baked together

DENSITY

particle density at instance location

COLOR

color of instance

UV_OFFSET

an offset to apply to all U,V coordinates

LOCAL_OFFSET

the static initial position offset of the instance

USER_DATA

User data - 32 bits.

POSE

pose matrix

NUM_SEMANTICS

Count of semantics, not a valid semantic.

The documentation for this struct was generated from the following file:
  • UserRenderInstanceBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderInstanceSemantic
nvidia::apex::RenderInstanceSemantic Member List
This is the complete list of members for nvidia::apex::RenderInstanceSemantic, including all inherited members.
COLOR enum value | nvidia::apex::RenderInstanceSemantic
DENSITY enum value | nvidia::apex::RenderInstanceSemantic
Enum enum name | nvidia::apex::RenderInstanceSemantic
LOCAL_OFFSET enum value | nvidia::apex::RenderInstanceSemantic
NUM_SEMANTICS enum value | nvidia::apex::RenderInstanceSemantic
POSE enum value | nvidia::apex::RenderInstanceSemantic
POSITION enum value | nvidia::apex::RenderInstanceSemantic
ROTATION_SCALE enum value | nvidia::apex::RenderInstanceSemantic
USER_DATA enum value | nvidia::apex::RenderInstanceSemantic
UV_OFFSET enum value | nvidia::apex::RenderInstanceSemantic
VELOCITY_LIFE enum value | nvidia::apex::RenderInstanceSemantic
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderInteropFlags Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderInteropFlags
Public Types
nvidia::apex::RenderInteropFlags Struct Reference

Render interop flags. More...

#include <UserRenderCallback.h>

List of all members.

Public Types

enum Enum {
NO_INTEROP = 0,
CUDA_INTEROP
}
Enum of render interop flags.

Detailed Description

Render interop flags.

The documentation for this struct was generated from the following file:
  • UserRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderInteropFlags
nvidia::apex::RenderInteropFlags Member List
This is the complete list of members for nvidia::apex::RenderInteropFlags, including all inherited members.
CUDA_INTEROP enum value (defined in nvidia::apex::RenderInteropFlags) | nvidia::apex::RenderInteropFlags
Enum enum name | nvidia::apex::RenderInteropFlags
NO_INTEROP enum value (defined in nvidia::apex::RenderInteropFlags) | nvidia::apex::RenderInteropFlags
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderLockMode Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderLockMode
Public Types
nvidia::apex::RenderLockMode Struct Reference

Render lock modes. These are used per-module to determine how render locking is done. More...

#include <Module.h>

List of all members.

Public Types

enum Enum {
NO_RENDER_LOCK = 0,
PER_ACTOR_RENDER_LOCK = 1,
PER_MODULE_SCENE_RENDER_LOCK = 2
}
Enum of render lock modes. More...

Detailed Description

Render lock modes. These are used per-module to determine how render locking is done.

Member Enumeration Documentation

enum nvidia::apex::RenderLockMode::Enum

Enum of render lock modes.

Enumerator:
NO_RENDER_LOCK

Disables render locking in the module scene.

PER_ACTOR_RENDER_LOCK

Locks all apex actors in the module scene individually.

PER_MODULE_SCENE_RENDER_LOCK

Locks an entire module scene with one lock.

The documentation for this struct was generated from the following file:
  • Module.h
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderLockMode
nvidia::apex::RenderLockMode Member List
This is the complete list of members for nvidia::apex::RenderLockMode, including all inherited members.
Enum enum name | nvidia::apex::RenderLockMode
NO_RENDER_LOCK enum value | nvidia::apex::RenderLockMode
PER_ACTOR_RENDER_LOCK enum value | nvidia::apex::RenderLockMode
PER_MODULE_SCENE_RENDER_LOCK enum value | nvidia::apex::RenderLockMode
Generated on Sat Dec 1 2018 10:18:33


APEX Framework: nvidia::apex::RenderMapType Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMapType
Public Types
nvidia::apex::RenderMapType Struct Reference

Render map type. More...

#include <UserRenderCallback.h>

List of all members.

Public Types

enum Enum {
MAP_READ = 1,
MAP_WRITE = 2,
MAP_READ_WRITE = 3,
MAP_WRITE_DISCARD = 4,
MAP_WRITE_NO_OVERWRITE = 5
}
Enum of render map type.

Detailed Description

Render map type.

The documentation for this struct was generated from the following file:
  • UserRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMapType
nvidia::apex::RenderMapType Member List
This is the complete list of members for nvidia::apex::RenderMapType, including all inherited members.
Enum enum name | nvidia::apex::RenderMapType
MAP_READ enum value (defined in nvidia::apex::RenderMapType) | nvidia::apex::RenderMapType
MAP_READ_WRITE enum value (defined in nvidia::apex::RenderMapType) | nvidia::apex::RenderMapType
MAP_WRITE enum value (defined in nvidia::apex::RenderMapType) | nvidia::apex::RenderMapType
MAP_WRITE_DISCARD enum value (defined in nvidia::apex::RenderMapType) | nvidia::apex::RenderMapType
MAP_WRITE_NO_OVERWRITE enum value (defined in nvidia::apex::RenderMapType) | nvidia::apex::RenderMapType
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderMeshActorRaycastFlags Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshActorRaycastFlags
Public Types
nvidia::apex::RenderMeshActorRaycastFlags Struct Reference

Flags used for raycasting an RenderMeshActor. More...

#include <RenderMeshActor.h>

List of all members.

Public Types

enum Enum {
VISIBLE_PARTS = (1 << 0),
INVISIBLE_PARTS = (1 << 1),
ALL_PARTS = VISIBLE_PARTS | INVISIBLE_PARTS
}
Enum of flags used for raycasting an RenderMeshActor.

Detailed Description

Flags used for raycasting an RenderMeshActor.

The documentation for this struct was generated from the following file:
  • RenderMeshActor.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshActorRaycastFlags
nvidia::apex::RenderMeshActorRaycastFlags Member List
This is the complete list of members for nvidia::apex::RenderMeshActorRaycastFlags, including all inherited members.
ALL_PARTS enum value (defined in nvidia::apex::RenderMeshActorRaycastFlags) | nvidia::apex::RenderMeshActorRaycastFlags
Enum enum name | nvidia::apex::RenderMeshActorRaycastFlags
INVISIBLE_PARTS enum value (defined in nvidia::apex::RenderMeshActorRaycastFlags) | nvidia::apex::RenderMeshActorRaycastFlags
VISIBLE_PARTS enum value (defined in nvidia::apex::RenderMeshActorRaycastFlags) | nvidia::apex::RenderMeshActorRaycastFlags
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderMeshActorRaycastHitData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshActorRaycastHitData
Public Attributes
nvidia::apex::RenderMeshActorRaycastHitData Struct Reference

Return data from raycasting an RenderMeshActor. More...

#include <RenderMeshActor.h>

List of all members.

Public Attributes

float | time
uint32_t | partIndex
uint32_t | submeshIndex
uint32_t | vertexIndices [3]
PxVec3 | normal
PxVec3 | tangent
PxVec3 | binormal

Detailed Description

Return data from raycasting an RenderMeshActor.

Member Data Documentation

PxVec3 nvidia::apex::RenderMeshActorRaycastHitData::binormal

The lighting binormal at the hit point, if the vertex format supports this. Otherwise set to (0,0,0).

PxVec3 nvidia::apex::RenderMeshActorRaycastHitData::normal

The lighting normal at the hit point, if the vertex format supports this. Otherwise set to (0,0,0).

uint32_t nvidia::apex::RenderMeshActorRaycastHitData::partIndex

The part index containing the hit triangle.

uint32_t nvidia::apex::RenderMeshActorRaycastHitData::submeshIndex

The submesh index of the triangle hit.

PxVec3 nvidia::apex::RenderMeshActorRaycastHitData::tangent

The lighting tangent at the hit point, if the vertex format supports this. Otherwise set to (0,0,0).

float nvidia::apex::RenderMeshActorRaycastHitData::time

The time to the hit point. That is, the hit point is given by worldOrig + time*worldDisp.

uint32_t nvidia::apex::RenderMeshActorRaycastHitData::vertexIndices[3]

The vertex indices of the triangle hit.

The documentation for this struct was generated from the following file:
  • RenderMeshActor.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshActorRaycastHitData
nvidia::apex::RenderMeshActorRaycastHitData Member List
This is the complete list of members for nvidia::apex::RenderMeshActorRaycastHitData, including all inherited members.
binormal | nvidia::apex::RenderMeshActorRaycastHitData
normal | nvidia::apex::RenderMeshActorRaycastHitData
partIndex | nvidia::apex::RenderMeshActorRaycastHitData
submeshIndex | nvidia::apex::RenderMeshActorRaycastHitData
tangent | nvidia::apex::RenderMeshActorRaycastHitData
time | nvidia::apex::RenderMeshActorRaycastHitData
vertexIndices | nvidia::apex::RenderMeshActorRaycastHitData
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderMeshAssetAuthoring::IndexType Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetAuthoring
  • IndexType
Public Types
nvidia::apex::RenderMeshAssetAuthoring::IndexType Struct Reference

#include <RenderMeshAsset.h>

List of all members.

Public Types

enum Enum {
UINT,
USHORT,
COUNT
}
Enum of integers types using for indices.

Detailed Description

What kind of integer is used for indices.

The documentation for this struct was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetAuthoring
  • IndexType
nvidia::apex::RenderMeshAssetAuthoring::IndexType Member List
This is the complete list of members for nvidia::apex::RenderMeshAssetAuthoring::IndexType, including all inherited members.
COUNT enum value (defined in nvidia::apex::RenderMeshAssetAuthoring::IndexType) | nvidia::apex::RenderMeshAssetAuthoring::IndexType
Enum enum name | nvidia::apex::RenderMeshAssetAuthoring::IndexType
UINT enum value (defined in nvidia::apex::RenderMeshAssetAuthoring::IndexType) | nvidia::apex::RenderMeshAssetAuthoring::IndexType
USHORT enum value (defined in nvidia::apex::RenderMeshAssetAuthoring::IndexType) | nvidia::apex::RenderMeshAssetAuthoring::IndexType
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderMeshAssetAuthoring::Primitive Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetAuthoring
  • Primitive
Public Types
nvidia::apex::RenderMeshAssetAuthoring::Primitive Struct Reference

How the geometry is stored. Currently only supporting triangles. More...

#include <RenderMeshAsset.h>

List of all members.

Public Types

enum Enum {
TRIANGLE_LIST,
COUNT
}
Enum of geometry stored types.

Detailed Description

How the geometry is stored. Currently only supporting triangles.

The documentation for this struct was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetAuthoring
  • Primitive
nvidia::apex::RenderMeshAssetAuthoring::Primitive Member List
This is the complete list of members for nvidia::apex::RenderMeshAssetAuthoring::Primitive, including all inherited members.
COUNT enum value (defined in nvidia::apex::RenderMeshAssetAuthoring::Primitive) | nvidia::apex::RenderMeshAssetAuthoring::Primitive
Enum enum name | nvidia::apex::RenderMeshAssetAuthoring::Primitive
TRIANGLE_LIST enum value (defined in nvidia::apex::RenderMeshAssetAuthoring::Primitive) | nvidia::apex::RenderMeshAssetAuthoring::Primitive
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderMeshAssetInstanceMode Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetInstanceMode
Public Types
nvidia::apex::RenderMeshAssetInstanceMode Struct Reference

Instance buffer data mode. DEPRECATED, to be removed by APEX 1.0. More...

#include <RenderMeshAsset.h>

List of all members.

Public Types

enum Enum {
POSE_SCALE = 0,
POS_VEL_LIFE,
NUM_MODES
}
Enum of instance buffer data.

Detailed Description

Instance buffer data mode. DEPRECATED, to be removed by APEX 1.0.

The documentation for this struct was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetInstanceMode
nvidia::apex::RenderMeshAssetInstanceMode Member List
This is the complete list of members for nvidia::apex::RenderMeshAssetInstanceMode, including all inherited members.
Enum enum name | nvidia::apex::RenderMeshAssetInstanceMode
NUM_MODES enum value (defined in nvidia::apex::RenderMeshAssetInstanceMode) | nvidia::apex::RenderMeshAssetInstanceMode
POS_VEL_LIFE enum value (defined in nvidia::apex::RenderMeshAssetInstanceMode) | nvidia::apex::RenderMeshAssetInstanceMode
POSE_SCALE enum value (defined in nvidia::apex::RenderMeshAssetInstanceMode) | nvidia::apex::RenderMeshAssetInstanceMode
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderMeshAssetStats Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetStats
Public Attributes
nvidia::apex::RenderMeshAssetStats Struct Reference

Stats for an RenderMeshAsset: memory usage, counts, etc. More...

#include <RenderMeshAsset.h>

List of all members.

Public Attributes

uint32_t | totalBytes
Total byte size of mesh.
uint32_t | submeshCount
Number of submeshes.
uint32_t | partCount
Number of mesh parts.
uint32_t | vertexCount
Number of vertices.
uint32_t | indexCount
Size (count) of index buffer.
uint32_t | vertexBufferBytes
Byte size of vertex buffer.
uint32_t | indexBufferBytes
Byte size of index buffer.

Detailed Description

Stats for an RenderMeshAsset: memory usage, counts, etc.

The documentation for this struct was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshAssetStats
nvidia::apex::RenderMeshAssetStats Member List
This is the complete list of members for nvidia::apex::RenderMeshAssetStats, including all inherited members.
indexBufferBytes | nvidia::apex::RenderMeshAssetStats
indexCount | nvidia::apex::RenderMeshAssetStats
partCount | nvidia::apex::RenderMeshAssetStats
submeshCount | nvidia::apex::RenderMeshAssetStats
totalBytes | nvidia::apex::RenderMeshAssetStats
vertexBufferBytes | nvidia::apex::RenderMeshAssetStats
vertexCount | nvidia::apex::RenderMeshAssetStats
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderMeshPartData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshPartData
Public Member Functions | Public Attributes
nvidia::apex::RenderMeshPartData Struct Reference

Descriptor for creating a rendering mesh part. More...

#include <RenderMeshAsset.h>

List of all members.

Public Member Functions

RenderMeshPartData (uint32_t _triCount, void *_data)
Constructor.

Public Attributes

uint32_t | triangleCount
Number of triangles in this mesh part.
void * | userData
User definable pointer to part data, passed back to createTriangles.

Detailed Description

Descriptor for creating a rendering mesh part.

The documentation for this struct was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderMeshPartData
nvidia::apex::RenderMeshPartData Member List
This is the complete list of members for nvidia::apex::RenderMeshPartData, including all inherited members.
RenderMeshPartData() (defined in nvidia::apex::RenderMeshPartData) | nvidia::apex::RenderMeshPartData | [inline]
RenderMeshPartData(uint32_t _triCount, void *_data) | nvidia::apex::RenderMeshPartData | [inline]
triangleCount | nvidia::apex::RenderMeshPartData |
userData | nvidia::apex::RenderMeshPartData |
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::RenderPrimitiveType Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderPrimitiveType
Public Types
nvidia::apex::RenderPrimitiveType Struct Reference

Describe the implied vertex ordering. More...

#include <UserRenderResourceManager.h>

List of all members.

Public Types

enum Enum {
UNKNOWN = 0,
TRIANGLES,
TRIANGLE_STRIP,
LINES,
LINE_STRIP,
POINTS,
POINT_SPRITES
}
Enum of the implied vertex ordering types.

Detailed Description

Describe the implied vertex ordering.

The documentation for this struct was generated from the following file:
  • UserRenderResourceManager.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderPrimitiveType
nvidia::apex::RenderPrimitiveType Member List
This is the complete list of members for nvidia::apex::RenderPrimitiveType, including all inherited members.
Enum enum name | nvidia::apex::RenderPrimitiveType
LINE_STRIP enum value (defined in nvidia::apex::RenderPrimitiveType) | nvidia::apex::RenderPrimitiveType
LINES enum value (defined in nvidia::apex::RenderPrimitiveType) | nvidia::apex::RenderPrimitiveType
POINT_SPRITES enum value (defined in nvidia::apex::RenderPrimitiveType) | nvidia::apex::RenderPrimitiveType
POINTS enum value (defined in nvidia::apex::RenderPrimitiveType) | nvidia::apex::RenderPrimitiveType
TRIANGLE_STRIP enum value (defined in nvidia::apex::RenderPrimitiveType) | nvidia::apex::RenderPrimitiveType
TRIANGLES enum value (defined in nvidia::apex::RenderPrimitiveType) | nvidia::apex::RenderPrimitiveType
UNKNOWN enum value (defined in nvidia::apex::RenderPrimitiveType) | nvidia::apex::RenderPrimitiveType
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderSpriteLayoutElement Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderSpriteLayoutElement
Public Types | Static Public Member Functions
nvidia::apex::RenderSpriteLayoutElement Struct Reference

potential semantics of a sprite buffer More...

#include <UserRenderSpriteBufferDesc.h>

List of all members.

Public Types

enum Enum {
POSITION_FLOAT3,
COLOR_RGBA8,
COLOR_BGRA8,
COLOR_FLOAT4,
VELOCITY_FLOAT3,
SCALE_FLOAT2,
LIFE_REMAIN_FLOAT1,
DENSITY_FLOAT1,
SUBTEXTURE_FLOAT1,
ORIENTATION_FLOAT1,
USER_DATA_UINT1,
NUM_SEMANTICS
}
Enum of sprite buffer semantics types.

Static Public Member Functions

static PX_INLINE
RenderDataFormat::Enum 		getSemanticFormat (Enum semantic)
Get semantic format.
static PX_INLINE
RenderSpriteSemantic::Enum 		getSemantic (Enum semantic)
Get semantic from layout element format.

Detailed Description

potential semantics of a sprite buffer

The documentation for this struct was generated from the following file:
  • UserRenderSpriteBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderSpriteLayoutElement
nvidia::apex::RenderSpriteLayoutElement Member List
This is the complete list of members for nvidia::apex::RenderSpriteLayoutElement, including all inherited members.
COLOR_BGRA8 enum value (defined in nvidia::apex::RenderSpriteLayoutElement) | nvidia::apex::RenderSpriteLayoutElement |
COLOR_FLOAT4 enum value (defined in nvidia::apex::RenderSpriteLayoutElement) | nvidia::apex::RenderSpriteLayoutElement |
COLOR_RGBA8 enum value (defined in nvidia::apex::RenderSpriteLayoutElement) | nvidia::apex::RenderSpriteLayoutElement |
DENSITY_FLOAT1 enum value (defined in nvidia::apex::RenderSpriteLayoutElement) | nvidia::apex::RenderSpriteLayoutElement |
Enum enum name | nvidia::apex::RenderSpriteLayoutElement |
getSemantic(Enum semantic) | nvidia::apex::RenderSpriteLayoutElement | [inline, static]
getSemanticFormat(Enum semantic) | nvidia::apex::RenderSpriteLayoutElement | [inline, static]
LIFE_REMAIN_FLOAT1 enum value (defined in nvidia::apex::RenderSpriteLayoutElement) | nvidia::apex::RenderSpriteLayoutElement |
NUM_SEMANTICS enum value (defined in nvidia::apex::RenderSpriteLayoutElement) | nvidia::apex::RenderSpriteLayoutElement |
ORIENTATION_FLOAT1 enum value (defined in nvidia::apex::RenderSpriteLayoutElement) | nvidia::apex::RenderSpriteLayoutElement |
POSITION_FLOAT3 enum value (defined in nvidia::apex::RenderSpriteLayoutElement) | nvidia::apex::RenderSpriteLayoutElement |
SCALE_FLOAT2 enum value (defined in nvidia::apex::RenderSpriteLayoutElement) | nvidia::apex::RenderSpriteLayoutElement |
SUBTEXTURE_FLOAT1 enum value (defined in nvidia::apex::RenderSpriteLayoutElement) | nvidia::apex::RenderSpriteLayoutElement |
USER_DATA_UINT1 enum value (defined in nvidia::apex::RenderSpriteLayoutElement) | nvidia::apex::RenderSpriteLayoutElement |
VELOCITY_FLOAT3 enum value (defined in nvidia::apex::RenderSpriteLayoutElement) | nvidia::apex::RenderSpriteLayoutElement |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderSpriteSemantic Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderSpriteSemantic
Public Types
nvidia::apex::RenderSpriteSemantic Struct Reference

PX_PS4. More...

#include <UserRenderSpriteBufferDesc.h>

List of all members.

Public Types

enum Enum {
POSITION = 0,
COLOR,
VELOCITY,
SCALE,
LIFE_REMAIN,
DENSITY,
SUBTEXTURE,
ORIENTATION,
USER_DATA,
NUM_SEMANTICS
}
Enum of sprite buffer semantics types. More...

Detailed Description

PX_PS4.

potential semantics of a sprite buffer

Member Enumeration Documentation

enum nvidia::apex::RenderSpriteSemantic::Enum

Enum of sprite buffer semantics types.

Enumerator:
POSITION

Position of sprite.

COLOR

Color of sprite.

VELOCITY

Linear velocity of sprite.

SCALE

Scale of sprite.

LIFE_REMAIN

1.0 (new) .. 0.0 (dead)

DENSITY

Particle density at sprite location.

SUBTEXTURE

Sub-texture index of sprite.

ORIENTATION

2D sprite orientation (angle in radians, CCW in screen plane)

USER_DATA

User data - 32 bits (passed from Emitter)

NUM_SEMANTICS

Count of semantics, not a valid semantic.

The documentation for this struct was generated from the following file:
  • UserRenderSpriteBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderSpriteSemantic
nvidia::apex::RenderSpriteSemantic Member List
This is the complete list of members for nvidia::apex::RenderSpriteSemantic, including all inherited members.
COLOR enum value | nvidia::apex::RenderSpriteSemantic
DENSITY enum value | nvidia::apex::RenderSpriteSemantic
Enum enum name | nvidia::apex::RenderSpriteSemantic
LIFE_REMAIN enum value | nvidia::apex::RenderSpriteSemantic
NUM_SEMANTICS enum value | nvidia::apex::RenderSpriteSemantic
ORIENTATION enum value | nvidia::apex::RenderSpriteSemantic
POSITION enum value | nvidia::apex::RenderSpriteSemantic
SCALE enum value | nvidia::apex::RenderSpriteSemantic
SUBTEXTURE enum value | nvidia::apex::RenderSpriteSemantic
USER_DATA enum value | nvidia::apex::RenderSpriteSemantic
VELOCITY enum value | nvidia::apex::RenderSpriteSemantic
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderSpriteTextureLayout Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderSpriteTextureLayout
Public Types | Static Public Member Functions
nvidia::apex::RenderSpriteTextureLayout Struct Reference

Struct for sprite texture layout info. More...

#include <UserRenderSpriteBufferDesc.h>

List of all members.

Public Types

enum Enum {
NONE = 0,
POSITION_FLOAT4,
SCALE_ORIENT_SUBTEX_FLOAT4,
COLOR_RGBA8,
COLOR_BGRA8,
COLOR_FLOAT4,
NUM_LAYOUTS
}
Enum of sprite texture layout info.

Static Public Member Functions

static PX_INLINE
RenderDataFormat::Enum 		getLayoutFormat (Enum layout)
Get layout format.

Detailed Description

Struct for sprite texture layout info.

The documentation for this struct was generated from the following file:
  • UserRenderSpriteBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderSpriteTextureLayout
nvidia::apex::RenderSpriteTextureLayout Member List
This is the complete list of members for nvidia::apex::RenderSpriteTextureLayout, including all inherited members.
COLOR_BGRA8 enum value (defined in nvidia::apex::RenderSpriteTextureLayout) | nvidia::apex::RenderSpriteTextureLayout |
COLOR_FLOAT4 enum value (defined in nvidia::apex::RenderSpriteTextureLayout) | nvidia::apex::RenderSpriteTextureLayout |
COLOR_RGBA8 enum value (defined in nvidia::apex::RenderSpriteTextureLayout) | nvidia::apex::RenderSpriteTextureLayout |
Enum enum name | nvidia::apex::RenderSpriteTextureLayout |
getLayoutFormat(Enum layout) | nvidia::apex::RenderSpriteTextureLayout | [inline, static]
NONE enum value (defined in nvidia::apex::RenderSpriteTextureLayout) | nvidia::apex::RenderSpriteTextureLayout |
NUM_LAYOUTS enum value (defined in nvidia::apex::RenderSpriteTextureLayout) | nvidia::apex::RenderSpriteTextureLayout |
POSITION_FLOAT4 enum value (defined in nvidia::apex::RenderSpriteTextureLayout) | nvidia::apex::RenderSpriteTextureLayout |
SCALE_ORIENT_SUBTEX_FLOAT4 enum value (defined in nvidia::apex::RenderSpriteTextureLayout) | nvidia::apex::RenderSpriteTextureLayout |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::RenderVertexSemantic Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderVertexSemantic
Public Types
nvidia::apex::RenderVertexSemantic Struct Reference

Potential semantics of a vertex buffer. More...

#include <UserRenderVertexBufferDesc.h>

List of all members.

Public Types

enum Enum {
CUSTOM = -1,
POSITION = 0,
NORMAL,
TANGENT,
BINORMAL,
COLOR,
TEXCOORD0,
TEXCOORD1,
TEXCOORD2,
TEXCOORD3,
BONE_INDEX,
BONE_WEIGHT,
DISPLACEMENT_TEXCOORD,
DISPLACEMENT_FLAGS,
NUM_SEMANTICS
}
Enum of vertex buffer semantics types. More...

Detailed Description

Potential semantics of a vertex buffer.

Member Enumeration Documentation

enum nvidia::apex::RenderVertexSemantic::Enum

Enum of vertex buffer semantics types.

Enumerator:
CUSTOM

User-defined.

POSITION

Position of vertex.

NORMAL

Normal at vertex.

TANGENT

Tangent at vertex.

BINORMAL

Binormal at vertex.

COLOR

Color at vertex.

TEXCOORD0

Texture coord 0 of vertex.

TEXCOORD1

Texture coord 1 of vertex.

TEXCOORD2

Texture coord 2 of vertex.

TEXCOORD3

Texture coord 3 of vertex.

BONE_INDEX

Bone index of vertex.

BONE_WEIGHT

Bone weight of vertex.

DISPLACEMENT_TEXCOORD

X Displacement map texture coord of vertex.

DISPLACEMENT_FLAGS

Displacement map flags of vertex.

NUM_SEMANTICS

Count of standard semantics, not a valid semantic.

The documentation for this struct was generated from the following file:
  • UserRenderVertexBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderVertexSemantic
nvidia::apex::RenderVertexSemantic Member List
This is the complete list of members for nvidia::apex::RenderVertexSemantic, including all inherited members.
BINORMAL enum value | nvidia::apex::RenderVertexSemantic
BONE_INDEX enum value | nvidia::apex::RenderVertexSemantic
BONE_WEIGHT enum value | nvidia::apex::RenderVertexSemantic
COLOR enum value | nvidia::apex::RenderVertexSemantic
CUSTOM enum value | nvidia::apex::RenderVertexSemantic
DISPLACEMENT_FLAGS enum value | nvidia::apex::RenderVertexSemantic
DISPLACEMENT_TEXCOORD enum value | nvidia::apex::RenderVertexSemantic
Enum enum name | nvidia::apex::RenderVertexSemantic
NORMAL enum value | nvidia::apex::RenderVertexSemantic
NUM_SEMANTICS enum value | nvidia::apex::RenderVertexSemantic
POSITION enum value | nvidia::apex::RenderVertexSemantic
TANGENT enum value | nvidia::apex::RenderVertexSemantic
TEXCOORD0 enum value | nvidia::apex::RenderVertexSemantic
TEXCOORD1 enum value | nvidia::apex::RenderVertexSemantic
TEXCOORD2 enum value | nvidia::apex::RenderVertexSemantic
TEXCOORD3 enum value | nvidia::apex::RenderVertexSemantic
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::SceneStats Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SceneStats
Public Attributes
nvidia::apex::SceneStats Struct Reference

Per scene statistics. More...

#include <Scene.h>

List of all members.

Public Attributes

uint32_t numApexStats
The number of ApexStats structures stored.
StatsInfo * ApexStatsInfoPtr
Array of StatsInfo structures.

Detailed Description

Per scene statistics.

The documentation for this struct was generated from the following file:
  • Scene.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SceneStats
nvidia::apex::SceneStats Member List
This is the complete list of members for nvidia::apex::SceneStats, including all inherited members.
ApexStatsInfoPtr | nvidia::apex::SceneStats
numApexStats | nvidia::apex::SceneStats
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::StatDataType Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • StatDataType
Public Types
nvidia::apex::StatDataType Struct Reference

APEX stat struct that contains the type enums. More...

#include <Scene.h>

List of all members.

Public Types

enum Enum {
INVALID = 0,
STRING = 1,
INT = 2,
FLOAT = 3,
ENUM = 4,
BOOL = 5
}
Enum of the APEX stat types.

Detailed Description

APEX stat struct that contains the type enums.

The documentation for this struct was generated from the following file:
  • Scene.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • StatDataType
nvidia::apex::StatDataType Member List
This is the complete list of members for nvidia::apex::StatDataType, including all inherited members.
BOOL enum value (defined in nvidia::apex::StatDataType) | nvidia::apex::StatDataType
ENUM enum value (defined in nvidia::apex::StatDataType) | nvidia::apex::StatDataType
Enum enum name | nvidia::apex::StatDataType
FLOAT enum value (defined in nvidia::apex::StatDataType) | nvidia::apex::StatDataType
INT enum value (defined in nvidia::apex::StatDataType) | nvidia::apex::StatDataType
INVALID enum value (defined in nvidia::apex::StatDataType) | nvidia::apex::StatDataType
STRING enum value (defined in nvidia::apex::StatDataType) | nvidia::apex::StatDataType
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::StatsInfo Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • StatsInfo
Public Attributes
nvidia::apex::StatsInfo Struct Reference

data value definitions for stats More...

#include <Scene.h>

List of all members.

Public Attributes

const char * StatName
name
StatDataType::Enum StatType
type
StatValue StatCurrentValue
current value

Detailed Description

data value definitions for stats

The documentation for this struct was generated from the following file:
  • Scene.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • StatsInfo
nvidia::apex::StatsInfo Member List
This is the complete list of members for nvidia::apex::StatsInfo, including all inherited members.
StatCurrentValue | nvidia::apex::StatsInfo
StatName | nvidia::apex::StatsInfo
StatType | nvidia::apex::StatsInfo
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::TextureUVOrigin Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TextureUVOrigin
Public Types
nvidia::apex::TextureUVOrigin Struct Reference

Texture UV direction convention. More...

#include <UserRenderVertexBufferDesc.h>

List of all members.

Public Types

enum Enum {
ORIGIN_TOP_LEFT = 0,
ORIGIN_TOP_RIGHT = 1,
ORIGIN_BOTTOM_LEFT = 2,
ORIGIN_BOTTOM_RIGHT = 3,
ORIGIN_UNKNOWN = 0xFFFFFFFF
}
Enum of texture UV directions types. More...

Detailed Description

Texture UV direction convention.

Member Enumeration Documentation

enum nvidia::apex::TextureUVOrigin::Enum

Enum of texture UV directions types.

Enumerator:
ORIGIN_TOP_LEFT

Origin is at top left.

ORIGIN_TOP_RIGHT

Origin is at top right.

ORIGIN_BOTTOM_LEFT

Origin is at bottom left.

ORIGIN_BOTTOM_RIGHT

Origin is at bottom right.

ORIGIN_UNKNOWN

Unknown origin.

The documentation for this struct was generated from the following file:
  • UserRenderVertexBufferDesc.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TextureUVOrigin
nvidia::apex::TextureUVOrigin Member List
This is the complete list of members for nvidia::apex::TextureUVOrigin, including all inherited members.
Enum enum name | nvidia::apex::TextureUVOrigin
ORIGIN_BOTTOM_LEFT enum value | nvidia::apex::TextureUVOrigin
ORIGIN_BOTTOM_RIGHT enum value | nvidia::apex::TextureUVOrigin
ORIGIN_TOP_LEFT enum value | nvidia::apex::TextureUVOrigin
ORIGIN_TOP_RIGHT enum value | nvidia::apex::TextureUVOrigin
ORIGIN_UNKNOWN enum value | nvidia::apex::TextureUVOrigin
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::TurbulenceDensityFormat Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceDensityFormat
Public Types
nvidia::apex::TurbulenceDensityFormat Struct Reference

Density format for Turbulence rendering. More...

#include <TurbulenceRenderCallback.h>

List of all members.

Public Types

enum Enum {
DEFAULT = 0,
UBYTE1 = RenderDataFormat::UBYTE1,
HALF1 = RenderDataFormat::HALF1,
FLOAT1 = RenderDataFormat::FLOAT1
}
Enum of density format for Turbulence rendering.

Detailed Description

Density format for Turbulence rendering.

The documentation for this struct was generated from the following file:
  • TurbulenceRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceDensityFormat
nvidia::apex::TurbulenceDensityFormat Member List
This is the complete list of members for nvidia::apex::TurbulenceDensityFormat, including all inherited members.
DEFAULT enum value (defined in nvidia::apex::TurbulenceDensityFormat) | nvidia::apex::TurbulenceDensityFormat
Enum enum name | nvidia::apex::TurbulenceDensityFormat
FLOAT1 enum value (defined in nvidia::apex::TurbulenceDensityFormat) | nvidia::apex::TurbulenceDensityFormat
HALF1 enum value (defined in nvidia::apex::TurbulenceDensityFormat) | nvidia::apex::TurbulenceDensityFormat
UBYTE1 enum value (defined in nvidia::apex::TurbulenceDensityFormat) | nvidia::apex::TurbulenceDensityFormat
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::TurbulenceFieldType Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceFieldType
Public Types
nvidia::apex::TurbulenceFieldType Struct Reference

Render surface field type. More...

#include <TurbulenceRenderable.h>

List of all members.

Public Types

enum Enum {
VELOCITY = 0,
DENSITY,
FLAME,
MAX_COUNT
}
Enum of render surface field types.

Detailed Description

Render surface field type.

The documentation for this struct was generated from the following file:
  • TurbulenceRenderable.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceFieldType
nvidia::apex::TurbulenceFieldType Member List
This is the complete list of members for nvidia::apex::TurbulenceFieldType, including all inherited members.
DENSITY enum value (defined in nvidia::apex::TurbulenceFieldType) | nvidia::apex::TurbulenceFieldType
Enum enum name | nvidia::apex::TurbulenceFieldType
FLAME enum value (defined in nvidia::apex::TurbulenceFieldType) | nvidia::apex::TurbulenceFieldType
MAX_COUNT enum value (defined in nvidia::apex::TurbulenceFieldType) | nvidia::apex::TurbulenceFieldType
VELOCITY enum value (defined in nvidia::apex::TurbulenceFieldType) | nvidia::apex::TurbulenceFieldType
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::TurbulenceFlameFormat Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceFlameFormat
Public Types
nvidia::apex::TurbulenceFlameFormat Struct Reference

Flame format for Turbulence rendering. More...

#include <TurbulenceRenderCallback.h>

List of all members.

Public Types

enum Enum {
DEFAULT = 0,
HALF4 = RenderDataFormat::HALF4,
FLOAT4 = RenderDataFormat::FLOAT4
}
Enum of flame format for Turbulence rendering.

Detailed Description

Flame format for Turbulence rendering.

The documentation for this struct was generated from the following file:
  • TurbulenceRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceFlameFormat
nvidia::apex::TurbulenceFlameFormat Member List
This is the complete list of members for nvidia::apex::TurbulenceFlameFormat, including all inherited members.
DEFAULT enum value (defined in nvidia::apex::TurbulenceFlameFormat) | nvidia::apex::TurbulenceFlameFormat
Enum enum name | nvidia::apex::TurbulenceFlameFormat
FLOAT4 enum value (defined in nvidia::apex::TurbulenceFlameFormat) | nvidia::apex::TurbulenceFlameFormat
HALF4 enum value (defined in nvidia::apex::TurbulenceFlameFormat) | nvidia::apex::TurbulenceFlameFormat
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::TurbulenceRenderData Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderData
Public Attributes
nvidia::apex::TurbulenceRenderData Struct Reference

TurbulenceRenderData stores render data for one Turbulence Renderable. More...

#include <TurbulenceRenderable.h>

List of all members.

Public Attributes

UserRenderSurfaceDesc | fieldSurfaceDescs [TurbulenceFieldType::MAX_COUNT]
UserRenderSurfaceDesc array for all field types.
UserRenderSurface * | fieldSurfaces [TurbulenceFieldType::MAX_COUNT]
UserRenderSurface array for all field types.

Detailed Description

TurbulenceRenderData stores render data for one Turbulence Renderable.

The documentation for this struct was generated from the following file:
  • TurbulenceRenderable.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderData
nvidia::apex::TurbulenceRenderData Member List
This is the complete list of members for nvidia::apex::TurbulenceRenderData, including all inherited members.
fieldSurfaceDescs | nvidia::apex::TurbulenceRenderData
fieldSurfaces | nvidia::apex::TurbulenceRenderData
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::TurbulenceRenderLayout Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderLayout
Public Member Functions | Public Attributes
nvidia::apex::TurbulenceRenderLayout Struct Reference

Render layout for Turbulence rendering. More...

#include <TurbulenceRenderCallback.h>

List of all members.

Public Member Functions

void setDefaults ()
set default formats

Public Attributes

TurbulenceVelocityFormat::Enum velocityFormat
Velocity format.
TurbulenceDensityFormat::Enum densityFormat
Density format.
TurbulenceFlameFormat::Enum flameFormat
Flame format.

Detailed Description

Render layout for Turbulence rendering.

The documentation for this struct was generated from the following file:
  • TurbulenceRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderLayout
nvidia::apex::TurbulenceRenderLayout Member List
This is the complete list of members for nvidia::apex::TurbulenceRenderLayout, including all inherited members.
densityFormat | nvidia::apex::TurbulenceRenderLayout |
flameFormat | nvidia::apex::TurbulenceRenderLayout |
setDefaults() | nvidia::apex::TurbulenceRenderLayout | [inline]
TurbulenceRenderLayout() (defined in nvidia::apex::TurbulenceRenderLayout) | nvidia::apex::TurbulenceRenderLayout | [inline]
velocityFormat | nvidia::apex::TurbulenceRenderLayout |
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::TurbulenceVelocityFormat Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceVelocityFormat
Public Types
nvidia::apex::TurbulenceVelocityFormat Struct Reference

Velocity format for Turbulence rendering. More...

#include <TurbulenceRenderCallback.h>

List of all members.

Public Types

enum Enum {
DEFAULT = 0,
HALF4 = RenderDataFormat::HALF4,
FLOAT4 = RenderDataFormat::FLOAT4
}
Enum of velocity format for Turbulence rendering.

Detailed Description

Velocity format for Turbulence rendering.

The documentation for this struct was generated from the following file:
  • TurbulenceRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • TurbulenceVelocityFormat
nvidia::apex::TurbulenceVelocityFormat Member List
This is the complete list of members for nvidia::apex::TurbulenceVelocityFormat, including all inherited members.
DEFAULT enum value (defined in nvidia::apex::TurbulenceVelocityFormat) | nvidia::apex::TurbulenceVelocityFormat
Enum enum name | nvidia::apex::TurbulenceVelocityFormat
FLOAT4 enum value (defined in nvidia::apex::TurbulenceVelocityFormat) | nvidia::apex::TurbulenceVelocityFormat
HALF4 enum value (defined in nvidia::apex::TurbulenceVelocityFormat) | nvidia::apex::TurbulenceVelocityFormat
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserBoundingBoxFlags Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserBoundingBoxFlags
Public Types
nvidia::apex::UserBoundingBoxFlags Struct Reference

Enum of the bounding box types. More...

#include <Scene.h>

List of all members.

Public Types

enum Enum {
NONE = 1 << 0,
ENTER = 1 << 1,
LEAVE = 1 << 2
}
Enum of the bounding box types.

Detailed Description

Enum of the bounding box types.

The documentation for this struct was generated from the following file:
  • Scene.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserBoundingBoxFlags
nvidia::apex::UserBoundingBoxFlags Member List
This is the complete list of members for nvidia::apex::UserBoundingBoxFlags, including all inherited members.
ENTER enum value (defined in nvidia::apex::UserBoundingBoxFlags) | nvidia::apex::UserBoundingBoxFlags
Enum enum name | nvidia::apex::UserBoundingBoxFlags
LEAVE enum value (defined in nvidia::apex::UserBoundingBoxFlags) | nvidia::apex::UserBoundingBoxFlags
NONE enum value (defined in nvidia::apex::UserBoundingBoxFlags) | nvidia::apex::UserBoundingBoxFlags
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::UserRenderBufferDesc Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderBufferDesc
Public Member Functions | Public Attributes
nvidia::apex::UserRenderBufferDesc Struct Reference

User render buffer desc. More...

#include <UserRenderCallback.h>

Inheritance diagram for nvidia::apex::UserRenderBufferDesc:
nvidia::apex::UserRenderDataHolder

List of all members.

Public Member Functions

void | setDefaults ()
Default values.
bool | isValid (void) const
Check if parameter's values are correct.
bool | isTheSameAs (const UserRenderBufferDesc &other) const
Check if this object is the same as other.

Public Attributes

size_t | size
Buffer size.
uint32_t | userFlags
User flags.
RenderInteropFlags::Enum interopFlags
Interop flags.

Detailed Description

User render buffer desc.

The documentation for this struct was generated from the following file:
  • UserRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderBufferDesc
nvidia::apex::UserRenderBufferDesc Member List
This is the complete list of members for nvidia::apex::UserRenderBufferDesc, including all inherited members.
getUserData() const | nvidia::apex::UserRenderDataHolder | [inline]
interopFlags | nvidia::apex::UserRenderBufferDesc |
isTheSameAs(const UserRenderBufferDesc &other) const | nvidia::apex::UserRenderBufferDesc | [inline]
isValid(void) const | nvidia::apex::UserRenderBufferDesc | [inline]
operator=(const UserRenderDataHolder &other) | nvidia::apex::UserRenderDataHolder | [inline]
setDefaults() | nvidia::apex::UserRenderBufferDesc | [inline]
setUserData(UserRenderData *newUserData) | nvidia::apex::UserRenderDataHolder | [inline]
size | nvidia::apex::UserRenderBufferDesc |
userFlags | nvidia::apex::UserRenderBufferDesc |
UserRenderBufferDesc(void) (defined in nvidia::apex::UserRenderBufferDesc) | nvidia::apex::UserRenderBufferDesc | [inline]
UserRenderDataHolder() (defined in nvidia::apex::UserRenderDataHolder) | nvidia::apex::UserRenderDataHolder | [inline]
UserRenderDataHolder(const UserRenderDataHolder &other) | nvidia::apex::UserRenderDataHolder | [inline]
~UserRenderDataHolder() (defined in nvidia::apex::UserRenderDataHolder) | nvidia::apex::UserRenderDataHolder | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderSurface::MappedInfo Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSurface
  • MappedInfo
Public Attributes
nvidia::apex::UserRenderSurface::MappedInfo Struct Reference

Mapped information. More...

#include <UserRenderCallback.h>

List of all members.

Public Attributes

void * | pData
Data pointer.
uint32_t | rowPitch
Row pitch.
uint32_t | depthPitch
Depth pitch.

Detailed Description

Mapped information.

The documentation for this struct was generated from the following file:
  • UserRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSurface
  • MappedInfo
nvidia::apex::UserRenderSurface::MappedInfo Member List
This is the complete list of members for nvidia::apex::UserRenderSurface::MappedInfo, including all inherited members.
depthPitch | nvidia::apex::UserRenderSurface::MappedInfo
pData | nvidia::apex::UserRenderSurface::MappedInfo
rowPitch | nvidia::apex::UserRenderSurface::MappedInfo
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::UserRenderSurfaceDesc Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSurfaceDesc
Public Member Functions | Public Attributes
nvidia::apex::UserRenderSurfaceDesc Struct Reference

User render surface desc. More...

#include <UserRenderCallback.h>

Inheritance diagram for nvidia::apex::UserRenderSurfaceDesc:
nvidia::apex::UserRenderDataHolder

List of all members.

Public Member Functions

void | setDefaults ()
Default values.
bool | isValid (void) const
Check if parameter's values are correct.
bool | isTheSameAs (const UserRenderSurfaceDesc &other) const
Check if this object is the same as other.

Public Attributes

size_t | width
Surface width.
size_t | height
Surface height.
size_t | depth
Surface depth.
RenderDataFormat::Enum format
Render data format.
uint32_t | userFlags
User flags.
RenderInteropFlags::Enum interopFlags
Interop flags.

Detailed Description

User render surface desc.

The documentation for this struct was generated from the following file:
  • UserRenderCallback.h
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • UserRenderSurfaceDesc
nvidia::apex::UserRenderSurfaceDesc Member List
This is the complete list of members for nvidia::apex::UserRenderSurfaceDesc, including all inherited members.
depth | nvidia::apex::UserRenderSurfaceDesc |
format | nvidia::apex::UserRenderSurfaceDesc |
getUserData() const | nvidia::apex::UserRenderDataHolder | [inline]
height | nvidia::apex::UserRenderSurfaceDesc |
interopFlags | nvidia::apex::UserRenderSurfaceDesc |
isTheSameAs(const UserRenderSurfaceDesc &other) const | nvidia::apex::UserRenderSurfaceDesc | [inline]
isValid(void) const | nvidia::apex::UserRenderSurfaceDesc | [inline]
operator=(const UserRenderDataHolder &other) | nvidia::apex::UserRenderDataHolder | [inline]
setDefaults() | nvidia::apex::UserRenderSurfaceDesc | [inline]
setUserData(UserRenderData *newUserData) | nvidia::apex::UserRenderDataHolder | [inline]
userFlags | nvidia::apex::UserRenderSurfaceDesc |
UserRenderDataHolder() (defined in nvidia::apex::UserRenderDataHolder) | nvidia::apex::UserRenderDataHolder | [inline]
UserRenderDataHolder(const UserRenderDataHolder &other) | nvidia::apex::UserRenderDataHolder | [inline]
UserRenderSurfaceDesc(void) (defined in nvidia::apex::UserRenderSurfaceDesc) | nvidia::apex::UserRenderSurfaceDesc | [inline]
width | nvidia::apex::UserRenderSurfaceDesc |
~UserRenderDataHolder() (defined in nvidia::apex::UserRenderDataHolder) | nvidia::apex::UserRenderDataHolder | [inline]
Generated on Sat Dec 1 2018 10:18:35


APEX Framework: nvidia::apex::Vec2T< T > Struct Template Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Vec2T
Public Member Functions | Public Attributes
nvidia::apex::Vec2T< T > Struct Template Reference

A trivial templatized math vector type for pairs. More...

#include <Curve.h>

List of all members.

Public Member Functions

Vec2T (T _x=T(), T _y=T())
Constructor that takes 0, 1, or 2 parameters to initialize the pair.
T & | operator[] (uint32_t ndx)
Overloading the subscript operator to access the members of the pair.

Public Attributes

T | x
The first element in the pair.
T | y
The second element in the pair.

Detailed Description

template<typename T>
struct nvidia::apex::Vec2T< T >

A trivial templatized math vector type for pairs.

The documentation for this struct was generated from the following file:
  • Curve.h
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Vec2T
nvidia::apex::Vec2T< T > Member List
This is the complete list of members for nvidia::apex::Vec2T< T >, including all inherited members.
operator[](uint32_t ndx) | nvidia::apex::Vec2T< T > | [inline]
Vec2T(T _x=T(), T _y=T()) | nvidia::apex::Vec2T< T > | [inline]
x | nvidia::apex::Vec2T< T > |
y | nvidia::apex::Vec2T< T > |
Generated on Sat Dec 1 2018 10:18:31


APEX Framework: nvidia::apex::Vertex Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Vertex
Public Member Functions | Public Attributes
nvidia::apex::Vertex Struct Reference

An inefficient vertex description used for authoring. More...

#include <RenderMeshAsset.h>

List of all members.

Public Member Functions

Vertex ()
Constructor which clears the entire structure.

Public Attributes

PxVec3 | position
Vertex position.
PxVec3 | normal
Surface normal at this position.
PxVec3 | tangent
Surface tangent at this position.
PxVec3 | binormal
Surface binormal at this position.
VertexUV | uv [VertexFormat::MAX_UV_COUNT]
Texture UV coordinates.
VertexColor color
Color ar this position.
uint16_t | boneIndices [VertexFormat::MAX_BONE_PER_VERTEX_COUNT]
Bones which are attached to this vertex.
float | boneWeights [VertexFormat::MAX_BONE_PER_VERTEX_COUNT]
Per bone wieght, 0.0 if no bone.
uint16_t | displacementFlags
Flags for vertex displacement.

Detailed Description

An inefficient vertex description used for authoring.

The documentation for this struct was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Vertex
nvidia::apex::Vertex Member List
This is the complete list of members for nvidia::apex::Vertex, including all inherited members.
binormal | nvidia::apex::Vertex |
boneIndices | nvidia::apex::Vertex |
boneWeights | nvidia::apex::Vertex |
color | nvidia::apex::Vertex |
displacementFlags | nvidia::apex::Vertex |
normal | nvidia::apex::Vertex |
position | nvidia::apex::Vertex |
tangent | nvidia::apex::Vertex |
uv | nvidia::apex::Vertex |
Vertex() | nvidia::apex::Vertex | [inline]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::VertexColor Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VertexColor
Public Member Functions | Public Attributes
nvidia::apex::VertexColor Struct Reference

The full RGBA color of a vertex. More...

#include <RenderMeshAsset.h>

List of all members.

Public Member Functions

PX_INLINE | VertexColor (const ColorRGBA c)
Constructor.
PX_INLINE VertexColor & | operator= (const VertexColor &c)
Copy assignment operator.
PX_INLINE void | set (float _r, float _g, float _b, float _a)
set the color as RGBA floats
PX_INLINE ColorRGBA | toColorRGBA () const
return the color as a 32bit integer

Public Attributes

float | r
RED.
float | g
GREEN.
float | b
BLUE.
float | a
ALPHA.

Detailed Description

The full RGBA color of a vertex.

The documentation for this struct was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VertexColor
nvidia::apex::VertexColor Member List
This is the complete list of members for nvidia::apex::VertexColor, including all inherited members.
a | nvidia::apex::VertexColor |
b | nvidia::apex::VertexColor |
g | nvidia::apex::VertexColor |
operator=(const VertexColor &c) | nvidia::apex::VertexColor | [inline]
r | nvidia::apex::VertexColor |
set(float _r, float _g, float _b, float _a) | nvidia::apex::VertexColor | [inline]
toColorRGBA() const | nvidia::apex::VertexColor | [inline]
VertexColor() (defined in nvidia::apex::VertexColor) | nvidia::apex::VertexColor | [inline]
VertexColor(const ColorRGBA c) | nvidia::apex::VertexColor | [inline]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::VertexUV Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VertexUV
Public Member Functions | Public Attributes
nvidia::apex::VertexUV Struct Reference

a simple u, v coordinate struct More...

#include <RenderMeshAsset.h>

List of all members.

Public Member Functions

VertexUV (float _u, float _v)
Constructor.
VertexUV (const float uv[])
Constructor.
void | set (float _u, float _v)
Set coordinates.
void | set (const float uv[])
Set coordinates.
float & | operator[] (int i)
operator []
const float & | operator[] (int i) const
const operator []

Public Attributes

float | u
coordinate
float | v
coordinate

Detailed Description

a simple u, v coordinate struct

The documentation for this struct was generated from the following file:
  • RenderMeshAsset.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • VertexUV
nvidia::apex::VertexUV Member List
This is the complete list of members for nvidia::apex::VertexUV, including all inherited members.
operator[](int i) | nvidia::apex::VertexUV | [inline]
operator[](int i) const | nvidia::apex::VertexUV | [inline]
set(float _u, float _v) | nvidia::apex::VertexUV | [inline]
set(const float uv[]) | nvidia::apex::VertexUV | [inline]
u | nvidia::apex::VertexUV |
v | nvidia::apex::VertexUV |
VertexUV() (defined in nvidia::apex::VertexUV) | nvidia::apex::VertexUV | [inline]
VertexUV(float _u, float _v) | nvidia::apex::VertexUV | [inline]
VertexUV(const float uv[]) | nvidia::apex::VertexUV | [inline]
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::ViewMatrixType Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ViewMatrixType
Public Types
nvidia::apex::ViewMatrixType Struct Reference

Types of view matrices handled by APEX. More...

#include <Scene.h>

List of all members.

Public Types

enum Enum {
USER_CUSTOMIZED = 0,
LOOK_AT_RH,
LOOK_AT_LH
}
Enum of the view matrices types.

Detailed Description

Types of view matrices handled by APEX.

USER_CUSTOMIZED : APEX simply uses the view matrix given. Need to setViewParams() LOOK_AT_RH: APEX gets the eye direction and eye position based on this kind of matrix. LOOK_AT_LH: APEX gets the eye direction and eye position based on this kind of matrix.

The documentation for this struct was generated from the following file:
  • Scene.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ViewMatrixType
nvidia::apex::ViewMatrixType Member List
This is the complete list of members for nvidia::apex::ViewMatrixType, including all inherited members.
Enum enum name | nvidia::apex::ViewMatrixType
LOOK_AT_LH enum value (defined in nvidia::apex::ViewMatrixType) | nvidia::apex::ViewMatrixType
LOOK_AT_RH enum value (defined in nvidia::apex::ViewMatrixType) | nvidia::apex::ViewMatrixType
USER_CUSTOMIZED enum value (defined in nvidia::apex::ViewMatrixType) | nvidia::apex::ViewMatrixType
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: nvidia::apex::oaValueStruct Struct Reference

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • oaValueStruct
Public Attributes
nvidia::apex::oaValueStruct Struct Reference

data value definitions for stats (derived from openautomate) More...

#include <Scene.h>

List of all members.

Public Attributes

union {
char * String
int32_t Int
float Float
char * Enum
bool Bool
};

Detailed Description

data value definitions for stats (derived from openautomate)

The documentation for this struct was generated from the following file:
  • Scene.h
Generated on Sat Dec 1 2018 10:18:34


APEX Framework: Member List

  • Related Pages
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • oaValueStruct
nvidia::apex::oaValueStruct Member List
This is the complete list of members for nvidia::apex::oaValueStruct, including all inherited members.
Bool (defined in nvidia::apex::oaValueStruct) | nvidia::apex::oaValueStruct
Enum (defined in nvidia::apex::oaValueStruct) | nvidia::apex::oaValueStruct
Float (defined in nvidia::apex::oaValueStruct) | nvidia::apex::oaValueStruct
Int (defined in nvidia::apex::oaValueStruct) | nvidia::apex::oaValueStruct
String (defined in nvidia::apex::oaValueStruct) | nvidia::apex::oaValueStruct
Generated on Sat Dec 1 2018 10:18:34


APEX IOFX Module: Class List

  • Class List
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
nvidia::apex::ApexMeshParticleRollType | Roll type of a particle
nvidia::apex::ColorVsDensityModifier | ColorVsDensityModifier modifies the color constants associated with a particle depending on the density of the particle
nvidia::apex::ColorVsLifeModifier | ColorVsLifeModifier modifies the color constants associated with a particle depending on the life remaining of the particle
nvidia::apex::ColorVsVelocityModifier | ColorVsVelocityModifier modifies the color constants associated with a particle depending on the velocity of the particle
nvidia::apex::IofxActor | IOFX actor public interface
nvidia::apex::IofxAsset | IOFX Asset public interface. Used to define the way the visual parameters are created from physical parameters of a particle
nvidia::apex::IofxAssetAuthoring | IOFX Asset Authoring public interface
nvidia::apex::IofxCommonRenderData | IofxCommonRenderData stores common render data for one IOFX Renderable
nvidia::apex::IofxMeshRenderData | IofxMeshRenderData stores mesh render data for one IOFX Renderable
nvidia::apex::IofxMeshRenderLayout | Describes the layout for mesh rendering
nvidia::apex::IofxMeshRenderLayoutElement | Enumerates the potential IOFX mesh render layout elements
nvidia::apex::IofxMeshSharedRenderData | IofxMeshSharedRenderData stores mesh render data shared by several IOFX Renderables
nvidia::apex::IofxRenderable | The IOFX renderable represents a unit of rendering. It contains complete information to render a batch of particles with the same material/mesh in the same render volume
nvidia::apex::IofxRenderableIterator | Iterate over all renderables in IOFX module. IMPORTANT: release() should be called for each returned not-NULL renderable!
nvidia::apex::IofxRenderCallback | User defined callback for IOFX rendering
nvidia::apex::IofxRenderSemantic | Enumerates the potential IOFX render semantics
nvidia::apex::IofxSharedRenderData | IofxSharedRenderData stores common render data shared by several IOFX Renderables
nvidia::apex::IofxSpriteRenderData | IofxSpriteRenderData stores sprite render data for one IOFX Renderable
nvidia::apex::IofxSpriteRenderLayout | Describes the layout for sprite rendering
nvidia::apex::IofxSpriteRenderLayoutElement | Enumerates the potential IOFX mesh render layout elements
nvidia::apex::IofxSpriteRenderLayoutSurfaceElement | Enumerates the potential IOFX sprite render layout surface elements
nvidia::apex::IofxSpriteSharedRenderData | IofxSpriteSharedRenderData stores sprite render data shared by several IOFX Renderables
nvidia::apex::Modifier | Modifier contains all of the data necessary to apply a single modifier type to a particle system
nvidia::apex::ModifierT< T > | ModifierT is a helper class to handle the mapping of Type->Enum and Enum->Type
nvidia::apex::ModuleIofx | IOFX Module
nvidia::apex::OrientAlongVelocityModifier | OrientAlongVelocity is a modifier to orient a mesh so that a particular axis coincides with the velocity vector
nvidia::apex::OrientScaleAlongScreenVelocityModifier | OrientScaleAlongScreenVelocityModifier is a modifier to orient & scale sprites along the current screen velocity vector
nvidia::apex::RandomRotationModifier | RandomRotationModifier will choose a random orientation for a sprite particle within the range as specified below
nvidia::apex::RandomScaleModifier | RandomScaleModifier applies a random scale uniformly to all three dimensions. Currently, the scale is a uniform in the range specified
nvidia::apex::RandomSubtextureModifier | RandomSubtextureModifier generates a random subtexture ID and places it in the subTextureId field
nvidia::apex::RenderVolume | An object which "owns" a volume of world space
nvidia::apex::RotationModifier | RotationModifier applies rotation to the particles using one of several rotation models
nvidia::apex::RotationRateModifier | RotationRateModifier is a modifier to apply a continuous rotation for sprites
nvidia::apex::RotationRateVsLifeModifier | RotationRateVsLifeModifier is a modifier to adjust the rotation rate versus the life remaining of a particular particle
nvidia::apex::ScaleAlongVelocityModifier | ScaleAlongVelocityModifier is a modifier to apply a scale factor along the current velocity vector
nvidia::apex::ScaleByMassModifier | ScaleByMassModifier scales by mass of the particle
nvidia::apex::ScaleVsCameraDistanceModifier | ScaleVsCameraDistance applies a scale factor against a specific axis based on distance from the camera to the particle
nvidia::apex::ScaleVsDensityModifier | ScaleVsDensityModifier applies a scale factor function against a single axis versus the density of the particle
nvidia::apex::ScaleVsLifeModifier | ScaleVsLifeModifier applies a scale factor function against a single axis versus the life remaining
nvidia::apex::SimpleScaleModifier | SimpleScaleModifier just applies a simple scale factor to each of the X, Y and Z aspects of the model. Each scalefactor can be applied independently
nvidia::apex::SubtextureVsLifeModifier | SubtextureVsLifeModifier is a modifier to adjust the subtexture id versus the life remaining of a particular particle
nvidia::apex::ViewDirectionSortingModifier | ViewDirectionSortingModifier sorts sprite particles along view direction back to front
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Index

  • Class List
  • Class Hierarchy
  • Class Members
Class Index
A | C | I | M | O | R | S | V
A
IofxCommonRenderData (nvidia::apex) IofxSpriteRenderData (nvidia::apex) OrientAlongVelocityModifier (nvidia::apex)
S
ApexMeshParticleRollType (nvidia::apex) IofxMeshRenderData (nvidia::apex) IofxSpriteRenderLayout (nvidia::apex) OrientScaleAlongScreenVelocityModifier (nvidia::apex) ScaleAlongVelocityModifier (nvidia::apex)
C
IofxMeshRenderLayout (nvidia::apex) IofxSpriteRenderLayoutElement (nvidia::apex)
R
ScaleByMassModifier (nvidia::apex)
ColorVsDensityModifier (nvidia::apex) IofxMeshRenderLayoutElement (nvidia::apex) IofxSpriteRenderLayoutSurfaceElement (nvidia::apex) RandomRotationModifier (nvidia::apex) ScaleVsCameraDistanceModifier (nvidia::apex)
ColorVsLifeModifier (nvidia::apex) IofxMeshSharedRenderData (nvidia::apex) IofxSpriteSharedRenderData (nvidia::apex) RandomScaleModifier (nvidia::apex) ScaleVsDensityModifier (nvidia::apex)
ColorVsVelocityModifier (nvidia::apex) IofxRenderable (nvidia::apex)
M
RandomSubtextureModifier (nvidia::apex) ScaleVsLifeModifier (nvidia::apex)
I
IofxRenderableIterator (nvidia::apex) Modifier (nvidia::apex) RenderVolume (nvidia::apex) SimpleScaleModifier (nvidia::apex)
IofxActor (nvidia::apex) IofxRenderCallback (nvidia::apex) ModifierT (nvidia::apex) RotationModifier (nvidia::apex) SubtextureVsLifeModifier (nvidia::apex)
IofxAsset (nvidia::apex) IofxRenderSemantic (nvidia::apex) ModuleIofx (nvidia::apex) RotationRateModifier (nvidia::apex)
V
IofxAssetAuthoring (nvidia::apex) IofxSharedRenderData (nvidia::apex)
O
RotationRateVsLifeModifier (nvidia::apex) ViewDirectionSortingModifier (nvidia::apex)
A | C | I | M | O | R | S | V
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::ColorVsDensityModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorVsDensityModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ColorVsDensityModifier Class Reference

ColorVsDensityModifier modifies the color constants associated with a particle depending on the density of the particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ColorVsDensityModifier:
nvidia::apex::ModifierT< ColorVsDensityModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ColorChannel | getColorChannel () const =0
get the affected color channel
virtual void | setColorChannel (ColorChannel colorChannel)=0
set the affected color channel
virtual const Curve * | getFunction () const =0
get the curve that sets the dependency between the density and the color
virtual void | setFunction (const Curve *f)=0
set the curve that sets the dependency between the density and the color

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ColorVsDensity
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ColorVsDensityModifier modifies the color constants associated with a particle depending on the density of the particle.

Member Function Documentation

virtual ColorChannel nvidia::apex::ColorVsDensityModifier::getColorChannel ( ) const [pure virtual]

get the affected color channel

virtual const Curve* nvidia::apex::ColorVsDensityModifier::getFunction ( ) const [pure virtual]

get the curve that sets the dependency between the density and the color

virtual void nvidia::apex::ColorVsDensityModifier::setColorChannel ( ColorChannel colorChannel ) [pure virtual]

set the affected color channel

virtual void nvidia::apex::ColorVsDensityModifier::setFunction ( const Curve * f ) [pure virtual]

set the curve that sets the dependency between the density and the color

Member Data Documentation

const ModifierTypeEnum nvidia::apex::ColorVsDensityModifier::ModifierType = ModifierType_ColorVsDensity [static]

ModifierType.

const uint32_t nvidia::apex::ColorVsDensityModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorVsDensityModifier
nvidia::apex::ColorVsDensityModifier Member List
This is the complete list of members for nvidia::apex::ColorVsDensityModifier, including all inherited members.
getColorChannel() const =0 | nvidia::apex::ColorVsDensityModifier | [pure virtual]
getFunction() const =0 | nvidia::apex::ColorVsDensityModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ColorVsDensityModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ColorVsDensityModifier > | [inline, virtual]
ModifierType | nvidia::apex::ColorVsDensityModifier | [static]
ModifierUsage | nvidia::apex::ColorVsDensityModifier | [static]
setColorChannel(ColorChannel colorChannel)=0 | nvidia::apex::ColorVsDensityModifier | [pure virtual]
setFunction(const Curve *f)=0 | nvidia::apex::ColorVsDensityModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::ColorVsLifeModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorVsLifeModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ColorVsLifeModifier Class Reference

ColorVsLifeModifier modifies the color constants associated with a particle depending on the life remaining of the particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ColorVsLifeModifier:
nvidia::apex::ModifierT< ColorVsLifeModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ColorChannel | getColorChannel () const =0
get the affected color channel
virtual void | setColorChannel (ColorChannel colorChannel)=0
set the affected color channel
virtual const Curve * | getFunction () const =0
get the curve that sets the dependency between the lifetime and the color
virtual void | setFunction (const Curve *f)=0
set the curve that sets the dependency between the lifetime and the color

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ColorVsLife
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ColorVsLifeModifier modifies the color constants associated with a particle depending on the life remaining of the particle.

Member Function Documentation

virtual ColorChannel nvidia::apex::ColorVsLifeModifier::getColorChannel ( ) const [pure virtual]

get the affected color channel

virtual const Curve* nvidia::apex::ColorVsLifeModifier::getFunction ( ) const [pure virtual]

get the curve that sets the dependency between the lifetime and the color

virtual void nvidia::apex::ColorVsLifeModifier::setColorChannel ( ColorChannel colorChannel ) [pure virtual]

set the affected color channel

virtual void nvidia::apex::ColorVsLifeModifier::setFunction ( const Curve * f ) [pure virtual]

set the curve that sets the dependency between the lifetime and the color

Member Data Documentation

const ModifierTypeEnum nvidia::apex::ColorVsLifeModifier::ModifierType = ModifierType_ColorVsLife [static]

ModifierType.

const uint32_t nvidia::apex::ColorVsLifeModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn | ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorVsLifeModifier
nvidia::apex::ColorVsLifeModifier Member List
This is the complete list of members for nvidia::apex::ColorVsLifeModifier, including all inherited members.
getColorChannel() const =0 | nvidia::apex::ColorVsLifeModifier | [pure virtual]
getFunction() const =0 | nvidia::apex::ColorVsLifeModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ColorVsLifeModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ColorVsLifeModifier > | [inline, virtual]
ModifierType | nvidia::apex::ColorVsLifeModifier | [static]
ModifierUsage | nvidia::apex::ColorVsLifeModifier | [static]
setColorChannel(ColorChannel colorChannel)=0 | nvidia::apex::ColorVsLifeModifier | [pure virtual]
setFunction(const Curve *f)=0 | nvidia::apex::ColorVsLifeModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::ColorVsVelocityModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorVsVelocityModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ColorVsVelocityModifier Class Reference

ColorVsVelocityModifier modifies the color constants associated with a particle depending on the velocity of the particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ColorVsVelocityModifier:
nvidia::apex::ModifierT< ColorVsVelocityModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ColorChannel | getColorChannel () const =0
get the affected color channel
virtual void | setColorChannel (ColorChannel colorChannel)=0
set the affected color channel
virtual const Curve * | getFunction () const =0
get the curve that sets the dependency between the lifetime and the color
virtual void | setFunction (const Curve *f)=0
set the curve that sets the dependency between the lifetime and the color
virtual float | getVelocity0 () const =0
get velocity0
virtual void | setVelocity0 (float value)=0
set velocity0
virtual float | getVelocity1 () const =0
get velocity1
virtual void | setVelocity1 (float value)=0
set velocity1

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ColorVsVelocity
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ColorVsVelocityModifier modifies the color constants associated with a particle depending on the velocity of the particle.

Member Function Documentation

virtual ColorChannel nvidia::apex::ColorVsVelocityModifier::getColorChannel ( ) const [pure virtual]

get the affected color channel

virtual const Curve* nvidia::apex::ColorVsVelocityModifier::getFunction ( ) const [pure virtual]

get the curve that sets the dependency between the lifetime and the color

virtual float nvidia::apex::ColorVsVelocityModifier::getVelocity0 ( ) const [pure virtual]

get velocity0

virtual float nvidia::apex::ColorVsVelocityModifier::getVelocity1 ( ) const [pure virtual]

get velocity1

virtual void nvidia::apex::ColorVsVelocityModifier::setColorChannel ( ColorChannel colorChannel ) [pure virtual]

set the affected color channel

virtual void nvidia::apex::ColorVsVelocityModifier::setFunction ( const Curve * f ) [pure virtual]

set the curve that sets the dependency between the lifetime and the color

virtual void nvidia::apex::ColorVsVelocityModifier::setVelocity0 ( float value ) [pure virtual]

set velocity0

virtual void nvidia::apex::ColorVsVelocityModifier::setVelocity1 ( float value ) [pure virtual]

set velocity1

Member Data Documentation

const ModifierTypeEnum nvidia::apex::ColorVsVelocityModifier::ModifierType = ModifierType_ColorVsVelocity [static]

ModifierType.

const uint32_t nvidia::apex::ColorVsVelocityModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn | ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ColorVsVelocityModifier
nvidia::apex::ColorVsVelocityModifier Member List
This is the complete list of members for nvidia::apex::ColorVsVelocityModifier, including all inherited members.
getColorChannel() const =0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
getFunction() const =0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ColorVsVelocityModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ColorVsVelocityModifier > | [inline, virtual]
getVelocity0() const =0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
getVelocity1() const =0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
ModifierType | nvidia::apex::ColorVsVelocityModifier | [static]
ModifierUsage | nvidia::apex::ColorVsVelocityModifier | [static]
setColorChannel(ColorChannel colorChannel)=0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
setFunction(const Curve *f)=0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
setVelocity0(float value)=0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
setVelocity1(float value)=0 | nvidia::apex::ColorVsVelocityModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::IofxActor Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxActor
Public Member Functions
nvidia::apex::IofxActor Class Reference

IOFX actor public interface. More...

#include <IofxActor.h>

List of all members.

Public Member Functions

virtual float | getObjectRadius () const =0
get the radius of the partice
virtual uint32_t | getObjectCount () const =0
get the number of particles
virtual uint32_t | getVisibleCount () const =0
get the number of visible particles (if sprite depth sorting is enabled, returns only number of particles in front of camera)
virtual const char * | getIosAssetName () const =0
get the name of the IOS asset used to feed partices to the IOFX
virtual physx::PxBounds3 | getBounds () const =0
returns AABB covering all objects in this actor, it's updated each frame during Scene::fetchResults().
virtual IofxRenderable * | acquireRenderableReference ()=0
Acquire a pointer to the iofx's renderable proxy and increment its reference count.

Detailed Description

IOFX actor public interface.

Member Function Documentation

virtual IofxRenderable* nvidia::apex::IofxActor::acquireRenderableReference ( ) [pure virtual]

Acquire a pointer to the iofx's renderable proxy and increment its reference count.

The IofxRenderable will only be deleted when its reference count is zero. Calls to IofxRenderable::release decrement the reference count, as does a call to IofxActor::release().

virtual physx::PxBounds3 nvidia::apex::IofxActor::getBounds ( ) const [pure virtual]

returns AABB covering all objects in this actor, it's updated each frame during Scene::fetchResults().

virtual const char* nvidia::apex::IofxActor::getIosAssetName ( ) const [pure virtual]

get the name of the IOS asset used to feed partices to the IOFX

virtual uint32_t nvidia::apex::IofxActor::getObjectCount ( ) const [pure virtual]

get the number of particles

virtual float nvidia::apex::IofxActor::getObjectRadius ( ) const [pure virtual]

get the radius of the partice

virtual uint32_t nvidia::apex::IofxActor::getVisibleCount ( ) const [pure virtual]

get the number of visible particles (if sprite depth sorting is enabled, returns only number of particles in front of camera)

The documentation for this class was generated from the following file:
  • IofxActor.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxActor
nvidia::apex::IofxActor Member List
This is the complete list of members for nvidia::apex::IofxActor, including all inherited members.
acquireRenderableReference()=0 | nvidia::apex::IofxActor | [pure virtual]
getBounds() const =0 | nvidia::apex::IofxActor | [pure virtual]
getIosAssetName() const =0 | nvidia::apex::IofxActor | [pure virtual]
getObjectCount() const =0 | nvidia::apex::IofxActor | [pure virtual]
getObjectRadius() const =0 | nvidia::apex::IofxActor | [pure virtual]
getVisibleCount() const =0 | nvidia::apex::IofxActor | [pure virtual]
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxAsset Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxAsset
Public Member Functions
nvidia::apex::IofxAsset Class Reference

IOFX Asset public interface. Used to define the way the visual parameters are created from physical parameters of a particle. More...

#include <IofxAsset.h>

List of all members.

Public Member Functions

virtual const char * | getSpriteMaterialName () const =0
get the name of the material used for sprite-based particles visualization
virtual uint32_t | getMeshAssetCount () const =0
get the number of different mesh assets used for mesh-based particles visualization
virtual const char * | getMeshAssetName (uint32_t index=0) const =0
virtual uint32_t | getMeshAssetWeight (uint32_t index=0) const =0
virtual const Modifier * | getSpawnModifiers (uint32_t &outCount) const =0
get the list of spawn modifiers
virtual const Modifier * | getContinuousModifiers (uint32_t &outCount) const =0
get the list of continuous modifiers
virtual float | getScaleUpperBound (float maxVelocity) const =0
virtual void | addDependentActor (ApexActor *actor)=0

Detailed Description

IOFX Asset public interface. Used to define the way the visual parameters are created from physical parameters of a particle.

Member Function Documentation

virtual void nvidia::apex::IofxAsset::addDependentActor ( ApexActor * actor ) [pure virtual]

the IOFX asset needs to inform other actors when it is released

Note:
only for internal use
virtual const Modifier* nvidia::apex::IofxAsset::getContinuousModifiers ( uint32_t & outCount ) const [pure virtual]

get the list of continuous modifiers

virtual uint32_t nvidia::apex::IofxAsset::getMeshAssetCount ( ) const [pure virtual]

get the number of different mesh assets used for mesh-based particles visualization

virtual const char* nvidia::apex::IofxAsset::getMeshAssetName ( uint32_t index = 0 ) const [pure virtual]

get the name of one of the mesh assets used for mesh-based particles visualization

Parameters:
index mesh asset internal index
virtual uint32_t nvidia::apex::IofxAsset::getMeshAssetWeight ( uint32_t index = 0 ) const [pure virtual]

get the weight of one of the mesh assets used for mesh-based particles visualization. Can be any value; not normalized.

Parameters:
index mesh asset internal index
virtual float nvidia::apex::IofxAsset::getScaleUpperBound ( float maxVelocity ) const [pure virtual]

get the biggest possible scale given the current spawn- and continuous modifiers note that some modifiers depend on velocity, so the scale can get arbitrarily large.

Parameters:
maxVelocity this value defines what the highest expected velocity is to compute the upper bound
virtual const Modifier* nvidia::apex::IofxAsset::getSpawnModifiers ( uint32_t & outCount ) const [pure virtual]

get the list of spawn modifiers

virtual const char* nvidia::apex::IofxAsset::getSpriteMaterialName ( ) const [pure virtual]

get the name of the material used for sprite-based particles visualization

The documentation for this class was generated from the following file:
  • IofxAsset.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxAsset
nvidia::apex::IofxAsset Member List
This is the complete list of members for nvidia::apex::IofxAsset, including all inherited members.
addDependentActor(ApexActor *actor)=0 | nvidia::apex::IofxAsset | [pure virtual]
getContinuousModifiers(uint32_t &outCount) const =0 | nvidia::apex::IofxAsset | [pure virtual]
getMeshAssetCount() const =0 | nvidia::apex::IofxAsset | [pure virtual]
getMeshAssetName(uint32_t index=0) const =0 | nvidia::apex::IofxAsset | [pure virtual]
getMeshAssetWeight(uint32_t index=0) const =0 | nvidia::apex::IofxAsset | [pure virtual]
getScaleUpperBound(float maxVelocity) const =0 | nvidia::apex::IofxAsset | [pure virtual]
getSpawnModifiers(uint32_t &outCount) const =0 | nvidia::apex::IofxAsset | [pure virtual]
getSpriteMaterialName() const =0 | nvidia::apex::IofxAsset | [pure virtual]
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxAssetAuthoring Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxAssetAuthoring
nvidia::apex::IofxAssetAuthoring Class Reference

IOFX Asset Authoring public interface. More...

#include <IofxAsset.h>

Detailed Description

IOFX Asset Authoring public interface.

The documentation for this class was generated from the following file:
  • IofxAsset.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxRenderable Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderable
Public Types | Public Member Functions | Protected Member Functions
nvidia::apex::IofxRenderable Class Reference

The IOFX renderable represents a unit of rendering. It contains complete information to render a batch of particles with the same material/mesh in the same render volume. More...

#include <IofxRenderable.h>

List of all members.

Public Types

enum Type {
SPRITE,
MESH
}
Type of IOFX renderable. More...

Public Member Functions

virtual Type | getType () const =0
Return Type of this renderable.
virtual const
IofxSpriteRenderData * 		getSpriteRenderData () const =0
Return Sprite render data for Sprite renderable and NULL for other types.
virtual const IofxMeshRenderData * | getMeshRenderData () const =0
Return Mesh render data for Mesh renderable and NULL for other types.
virtual const physx::PxBounds3 & | getBounds () const =0
Return AABB of this renderable.

Protected Member Functions

virtual | ~IofxRenderable ()

Detailed Description

The IOFX renderable represents a unit of rendering. It contains complete information to render a batch of particles with the same material/mesh in the same render volume.

Member Enumeration Documentation

enum nvidia::apex::IofxRenderable::Type

Type of IOFX renderable.

Enumerator:
SPRITE

Sprite particles type.

MESH

Mesh particles type.

Constructor & Destructor Documentation

virtual nvidia::apex::IofxRenderable::~IofxRenderable ( ) [inline, protected, virtual]

Member Function Documentation

virtual const physx::PxBounds3& nvidia::apex::IofxRenderable::getBounds ( ) const [pure virtual]

Return AABB of this renderable.

virtual const IofxMeshRenderData* nvidia::apex::IofxRenderable::getMeshRenderData ( ) const [pure virtual]

Return Mesh render data for Mesh renderable and NULL for other types.

virtual const IofxSpriteRenderData* nvidia::apex::IofxRenderable::getSpriteRenderData ( ) const [pure virtual]

Return Sprite render data for Sprite renderable and NULL for other types.

virtual Type nvidia::apex::IofxRenderable::getType ( ) const [pure virtual]

Return Type of this renderable.

The documentation for this class was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderable
nvidia::apex::IofxRenderable Member List
This is the complete list of members for nvidia::apex::IofxRenderable, including all inherited members.
getBounds() const =0 | nvidia::apex::IofxRenderable | [pure virtual]
getMeshRenderData() const =0 | nvidia::apex::IofxRenderable | [pure virtual]
getSpriteRenderData() const =0 | nvidia::apex::IofxRenderable | [pure virtual]
getType() const =0 | nvidia::apex::IofxRenderable | [pure virtual]
MESH enum value | nvidia::apex::IofxRenderable |
SPRITE enum value | nvidia::apex::IofxRenderable |
Type enum name | nvidia::apex::IofxRenderable |
~IofxRenderable() | nvidia::apex::IofxRenderable | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxRenderableIterator Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderableIterator
Public Member Functions
nvidia::apex::IofxRenderableIterator Class Reference

Iterate over all renderables in IOFX module. IMPORTANT: release() should be called for each returned not-NULL renderable! More...

#include <ModuleIofx.h>

List of all members.

Public Member Functions

virtual IofxRenderable * | getFirst ()=0
Return the first renderable in IOFX module.
virtual IofxRenderable * | getNext ()=0
Return the next renderable IOFX module.

Detailed Description

Iterate over all renderables in IOFX module. IMPORTANT: release() should be called for each returned not-NULL renderable!

Member Function Documentation

virtual IofxRenderable* nvidia::apex::IofxRenderableIterator::getFirst ( ) [pure virtual]

Return the first renderable in IOFX module.

virtual IofxRenderable* nvidia::apex::IofxRenderableIterator::getNext ( ) [pure virtual]

Return the next renderable IOFX module.

The documentation for this class was generated from the following file:
  • ModuleIofx.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderableIterator
nvidia::apex::IofxRenderableIterator Member List
This is the complete list of members for nvidia::apex::IofxRenderableIterator, including all inherited members.
getFirst()=0 | nvidia::apex::IofxRenderableIterator | [pure virtual]
getNext()=0 | nvidia::apex::IofxRenderableIterator | [pure virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::IofxRenderCallback Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderCallback
Public Member Functions
nvidia::apex::IofxRenderCallback Class Reference

User defined callback for IOFX rendering. More...

#include <IofxRenderCallback.h>

List of all members.

Public Member Functions

virtual void | onCreatedIofxRenderable (IofxRenderable &)
Called just after a new IOFX renderable was created.
virtual void | onUpdatedIofxRenderable (IofxRenderable &)
Called just after an IOFX renderable was updated.
virtual void | onReleasingIofxRenderable (IofxRenderable &)
Called just before an IOFX renderable is going to be released.
virtual bool | getIofxSpriteRenderLayout (IofxSpriteRenderLayout &spriteRenderLayout, uint32_t spriteCount, uint32_t spriteSemanticsBitmap, RenderInteropFlags::Enum interopFlags)
Called by the IOFX module to query layout for sprite rendering. Should return true in case IofxSpriteRenderLayout is properly filled, and then IOFX will pass this layout to createRender[Buffer|Surface] method(s) to create needed render resources. In case this method is not implemented and returns false the IOFX module will create a layout to hold all input semantics. Also in case this method is not implemented or/and createRender[Buffer|Surface] method is not implemented, then the IOFX module will create its own render buffer/surfaces which user can map to access rendering content.
virtual bool | getIofxMeshRenderLayout (IofxMeshRenderLayout &meshRenderLayout, uint32_t meshCount, uint32_t meshSemanticsBitmap, RenderInteropFlags::Enum interopFlags)
Called by the IOFX module to query layout for mesh rendering. Should return true in case IofxMeshRenderLayout is properly filled, and then IOFX will pass this layout to createRenderBuffer method to create needed render resources. In case this method is not implemented and returns false the IOFX module will create a layout to hold all input semantics. Also in case this method is not implemented or/and createRenderBuffer method is not implemented, then the IOFX module will create its own render buffer which user can map to access rendering content.

Detailed Description

User defined callback for IOFX rendering.

Member Function Documentation

virtual bool nvidia::apex::IofxRenderCallback::getIofxMeshRenderLayout | ( | IofxMeshRenderLayout & | meshRenderLayout,
 |  | uint32_t | meshCount,
 |  | uint32_t | meshSemanticsBitmap,
 |  | RenderInteropFlags::Enum | interopFlags
 | ) |  | [inline, virtual]

Called by the IOFX module to query layout for mesh rendering. Should return true in case IofxMeshRenderLayout is properly filled, and then IOFX will pass this layout to createRenderBuffer method to create needed render resources. In case this method is not implemented and returns false the IOFX module will create a layout to hold all input semantics. Also in case this method is not implemented or/and createRenderBuffer method is not implemented, then the IOFX module will create its own render buffer which user can map to access rendering content.

virtual bool nvidia::apex::IofxRenderCallback::getIofxSpriteRenderLayout | ( | IofxSpriteRenderLayout & | spriteRenderLayout,
 |  | uint32_t | spriteCount,
 |  | uint32_t | spriteSemanticsBitmap,
 |  | RenderInteropFlags::Enum | interopFlags
 | ) |  | [inline, virtual]

Called by the IOFX module to query layout for sprite rendering. Should return true in case IofxSpriteRenderLayout is properly filled, and then IOFX will pass this layout to createRender[Buffer|Surface] method(s) to create needed render resources. In case this method is not implemented and returns false the IOFX module will create a layout to hold all input semantics. Also in case this method is not implemented or/and createRender[Buffer|Surface] method is not implemented, then the IOFX module will create its own render buffer/surfaces which user can map to access rendering content.

virtual void nvidia::apex::IofxRenderCallback::onCreatedIofxRenderable ( IofxRenderable & ) [inline, virtual]

Called just after a new IOFX renderable was created.

virtual void nvidia::apex::IofxRenderCallback::onReleasingIofxRenderable ( IofxRenderable & ) [inline, virtual]

Called just before an IOFX renderable is going to be released.

virtual void nvidia::apex::IofxRenderCallback::onUpdatedIofxRenderable ( IofxRenderable & ) [inline, virtual]

Called just after an IOFX renderable was updated.

The documentation for this class was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderCallback
nvidia::apex::IofxRenderCallback Member List
This is the complete list of members for nvidia::apex::IofxRenderCallback, including all inherited members.
getIofxMeshRenderLayout(IofxMeshRenderLayout &meshRenderLayout, uint32_t meshCount, uint32_t meshSemanticsBitmap, RenderInteropFlags::Enum interopFlags) | nvidia::apex::IofxRenderCallback | [inline, virtual]
getIofxSpriteRenderLayout(IofxSpriteRenderLayout &spriteRenderLayout, uint32_t spriteCount, uint32_t spriteSemanticsBitmap, RenderInteropFlags::Enum interopFlags) | nvidia::apex::IofxRenderCallback | [inline, virtual]
onCreatedIofxRenderable(IofxRenderable &) | nvidia::apex::IofxRenderCallback | [inline, virtual]
onReleasingIofxRenderable(IofxRenderable &) | nvidia::apex::IofxRenderCallback | [inline, virtual]
onUpdatedIofxRenderable(IofxRenderable &) | nvidia::apex::IofxRenderCallback | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::Modifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Modifier
Public Member Functions
nvidia::apex::Modifier Class Reference

Modifier contains all of the data necessary to apply a single modifier type to a particle system. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::Modifier:
nvidia::apex::ModifierT< ColorVsDensityModifier > nvidia::apex::ModifierT< ColorVsLifeModifier > nvidia::apex::ModifierT< ColorVsVelocityModifier > nvidia::apex::ModifierT< OrientAlongVelocityModifier > nvidia::apex::ModifierT< OrientScaleAlongScreenVelocityModifier > nvidia::apex::ModifierT< RandomRotationModifier > nvidia::apex::ModifierT< RandomScaleModifier > nvidia::apex::ModifierT< RandomSubtextureModifier > nvidia::apex::ModifierT< RotationModifier > nvidia::apex::ModifierT< RotationRateModifier > nvidia::apex::ModifierT< RotationRateVsLifeModifier > nvidia::apex::ModifierT< ScaleAlongVelocityModifier > nvidia::apex::ModifierT< ScaleByMassModifier > nvidia::apex::ModifierT< ScaleVsCameraDistanceModifier > nvidia::apex::ModifierT< ScaleVsDensityModifier > nvidia::apex::ModifierT< ScaleVsLifeModifier > nvidia::apex::ModifierT< SimpleScaleModifier > nvidia::apex::ModifierT< SubtextureVsLifeModifier > nvidia::apex::ModifierT< ViewDirectionSortingModifier > nvidia::apex::ModifierT< T >

List of all members.

Public Member Functions

virtual ModifierTypeEnum | getModifierType () const =0
getModifierType returns the enumerated type associated with this class.
virtual uint32_t | getModifierUsage () const =0
getModifierUsage returns the usage scenarios allowed for a particular modifier.
virtual uint32_t | getModifierSpriteSemantics ()
returns a bitmap that includes every sprite semantic that the modifier updates
virtual uint32_t | getModifierMeshSemantics ()
returns a bitmap that includes every mesh(instance) semantic that the modifier updates
virtual | ~Modifier ()

Detailed Description

Modifier contains all of the data necessary to apply a single modifier type to a particle system.

Generally this combines some physical transformation with parameters specified at authoring time to modify the look of the final effect.

Constructor & Destructor Documentation

virtual nvidia::apex::Modifier::~Modifier ( ) [inline, virtual]

Member Function Documentation

virtual uint32_t nvidia::apex::Modifier::getModifierMeshSemantics ( ) [inline, virtual]

returns a bitmap that includes every mesh(instance) semantic that the modifier updates

virtual uint32_t nvidia::apex::Modifier::getModifierSpriteSemantics ( ) [inline, virtual]

returns a bitmap that includes every sprite semantic that the modifier updates

virtual ModifierTypeEnum nvidia::apex::Modifier::getModifierType ( ) const [pure virtual]

getModifierType returns the enumerated type associated with this class.

Implemented in nvidia::apex::ModifierT< T >, nvidia::apex::ModifierT< ScaleVsLifeModifier >, nvidia::apex::ModifierT< RotationModifier >, nvidia::apex::ModifierT< ViewDirectionSortingModifier >, nvidia::apex::ModifierT< OrientAlongVelocityModifier >, nvidia::apex::ModifierT< ColorVsLifeModifier >, nvidia::apex::ModifierT< ScaleVsDensityModifier >, nvidia::apex::ModifierT< ScaleByMassModifier >, nvidia::apex::ModifierT< ScaleAlongVelocityModifier >, nvidia::apex::ModifierT< RotationRateModifier >, nvidia::apex::ModifierT< ColorVsDensityModifier >, nvidia::apex::ModifierT< SimpleScaleModifier >, nvidia::apex::ModifierT< RotationRateVsLifeModifier >, nvidia::apex::ModifierT< SubtextureVsLifeModifier >, nvidia::apex::ModifierT< RandomSubtextureModifier >, nvidia::apex::ModifierT< OrientScaleAlongScreenVelocityModifier >, nvidia::apex::ModifierT< ScaleVsCameraDistanceModifier >, nvidia::apex::ModifierT< ColorVsVelocityModifier >, nvidia::apex::ModifierT< RandomScaleModifier >, and nvidia::apex::ModifierT< RandomRotationModifier >.

virtual uint32_t nvidia::apex::Modifier::getModifierUsage ( ) const [pure virtual]

getModifierUsage returns the usage scenarios allowed for a particular modifier.

Implemented in nvidia::apex::ModifierT< T >, nvidia::apex::ModifierT< ScaleVsLifeModifier >, nvidia::apex::ModifierT< RotationModifier >, nvidia::apex::ModifierT< ViewDirectionSortingModifier >, nvidia::apex::ModifierT< OrientAlongVelocityModifier >, nvidia::apex::ModifierT< ColorVsLifeModifier >, nvidia::apex::ModifierT< ScaleVsDensityModifier >, nvidia::apex::ModifierT< ScaleByMassModifier >, nvidia::apex::ModifierT< ScaleAlongVelocityModifier >, nvidia::apex::ModifierT< RotationRateModifier >, nvidia::apex::ModifierT< ColorVsDensityModifier >, nvidia::apex::ModifierT< SimpleScaleModifier >, nvidia::apex::ModifierT< RotationRateVsLifeModifier >, nvidia::apex::ModifierT< SubtextureVsLifeModifier >, nvidia::apex::ModifierT< RandomSubtextureModifier >, nvidia::apex::ModifierT< OrientScaleAlongScreenVelocityModifier >, nvidia::apex::ModifierT< ScaleVsCameraDistanceModifier >, nvidia::apex::ModifierT< ColorVsVelocityModifier >, nvidia::apex::ModifierT< RandomScaleModifier >, and nvidia::apex::ModifierT< RandomRotationModifier >.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • Modifier
nvidia::apex::Modifier Member List
This is the complete list of members for nvidia::apex::Modifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const =0 | nvidia::apex::Modifier | [pure virtual]
getModifierUsage() const =0 | nvidia::apex::Modifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::ModifierT< T > Class Template Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModifierT
Public Member Functions
nvidia::apex::ModifierT< T > Class Template Reference

ModifierT is a helper class to handle the mapping of Type->Enum and Enum->Type. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ModifierT< T >:
nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ModifierTypeEnum | getModifierType () const
Returns ModifierType for typename T.
virtual uint32_t | getModifierUsage () const
Returns ModifierUsage for typename T.

Detailed Description

template<typename T>
class nvidia::apex::ModifierT< T >

ModifierT is a helper class to handle the mapping of Type->Enum and Enum->Type.

This imposes some structure on the subclasses--they all now expect to have a const static field called ModifierType.

Member Function Documentation

template<typename T>
virtual ModifierTypeEnum nvidia::apex::ModifierT< T >::getModifierType ( ) const [inline, virtual]

Returns ModifierType for typename T.

Implements nvidia::apex::Modifier.

template<typename T>
virtual uint32_t nvidia::apex::ModifierT< T >::getModifierUsage ( ) const [inline, virtual]

Returns ModifierUsage for typename T.

Implements nvidia::apex::Modifier.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModifierT
nvidia::apex::ModifierT< T > Member List
This is the complete list of members for nvidia::apex::ModifierT< T >, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< T > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< T > | [inline, virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::ModuleIofx Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleIofx
Public Member Functions | Protected Member Functions
nvidia::apex::ModuleIofx Class Reference

IOFX Module. More...

#include <ModuleIofx.h>

List of all members.

Public Member Functions

virtual void | disableCudaInterop ()=0
Disable use of OGL/D3D Interop. Must be called before emitters are created to have any effect.
virtual void | disableCudaModifiers ()=0
Disable use of CUDA IOFX modifiers. Must be called before emitters are created to have any effect.
virtual void | disableDeferredRenderableAllocation ()=0
Disables deferred allocation of IOFX actors.
virtual RenderVolume * | createRenderVolume (const Scene &apexScene, const PxBounds3 &b, uint32_t priority, bool allIofx)=0
Create a new render volume.
virtual void | releaseRenderVolume (RenderVolume &volume)=0
Release a render volume.
virtual const TestBase * | getTestBase (Scene *apexScene) const =0
Get TestBase implementation of Iofx scene.
virtual bool | setIofxRenderCallback (const Scene &apexScene, IofxRenderCallback *)=0
Set IofxRenderCallback.
virtual IofxRenderCallback * | getIofxRenderCallback (const Scene &apexScene) const =0
Get IofxRenderCallback.
virtual IofxRenderableIterator * | createIofxRenderableIterator (const Scene &)=0
Create an iterator for all renderables in IOFX module.
virtual void | prepareRenderables (const Scene &)=0
Prepare renderables for rendering, should be called each frame before using renderables to update them with the most recent data.

Protected Member Functions

virtual | ~ModuleIofx ()

Detailed Description

IOFX Module.

This module is used to convert physical parameters of particles into visual parameters that can be used to render particles. ApexRenderVolume provide the ability to partition world space into separate renderables.

Constructor & Destructor Documentation

virtual nvidia::apex::ModuleIofx::~ModuleIofx ( ) [inline, protected, virtual]

Member Function Documentation

virtual IofxRenderableIterator* nvidia::apex::ModuleIofx::createIofxRenderableIterator ( const Scene & ) [pure virtual]

Create an iterator for all renderables in IOFX module.

virtual RenderVolume* nvidia::apex::ModuleIofx::createRenderVolume | ( | const Scene & | apexScene,
 |  | const PxBounds3 & | b,
 |  | uint32_t | priority,
 |  | bool | allIofx
 | ) |  | [pure virtual]

Create a new render volume.

Render volumes may be created at any time, unlike most other APEX asset and actor types. Their insertion into the scene is deferred if the simulation is active.

virtual void nvidia::apex::ModuleIofx::disableCudaInterop ( ) [pure virtual]

Disable use of OGL/D3D Interop. Must be called before emitters are created to have any effect.

virtual void nvidia::apex::ModuleIofx::disableCudaModifiers ( ) [pure virtual]

Disable use of CUDA IOFX modifiers. Must be called before emitters are created to have any effect.

virtual void nvidia::apex::ModuleIofx::disableDeferredRenderableAllocation ( ) [pure virtual]

Disables deferred allocation of IOFX actors.

By default, IOFX actors and their render resources will not be created until it has objects to render.

virtual IofxRenderCallback* nvidia::apex::ModuleIofx::getIofxRenderCallback ( const Scene & apexScene ) const [pure virtual]

Get IofxRenderCallback.

See also:
IofxRenderCallback
virtual const TestBase* nvidia::apex::ModuleIofx::getTestBase ( Scene * apexScene ) const [pure virtual]

Get TestBase implementation of Iofx scene.

virtual void nvidia::apex::ModuleIofx::prepareRenderables ( const Scene & ) [pure virtual]

Prepare renderables for rendering, should be called each frame before using renderables to update them with the most recent data.

virtual void nvidia::apex::ModuleIofx::releaseRenderVolume ( RenderVolume & volume ) [pure virtual]

Release a render volume.

Render volumes may be released at any time, unlike most other APEX asset and actor types. If the simulation is active, their resources are released at the end of the simulation step.

virtual bool nvidia::apex::ModuleIofx::setIofxRenderCallback | ( | const Scene & | apexScene,
 |  | IofxRenderCallback * |
 | ) |  | [pure virtual]

Set IofxRenderCallback.

See also:
IofxRenderCallback
The documentation for this class was generated from the following file:
  • ModuleIofx.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ModuleIofx
nvidia::apex::ModuleIofx Member List
This is the complete list of members for nvidia::apex::ModuleIofx, including all inherited members.
createIofxRenderableIterator(const Scene &)=0 | nvidia::apex::ModuleIofx | [pure virtual]
createRenderVolume(const Scene &apexScene, const PxBounds3 &b, uint32_t priority, bool allIofx)=0 | nvidia::apex::ModuleIofx | [pure virtual]
disableCudaInterop()=0 | nvidia::apex::ModuleIofx | [pure virtual]
disableCudaModifiers()=0 | nvidia::apex::ModuleIofx | [pure virtual]
disableDeferredRenderableAllocation()=0 | nvidia::apex::ModuleIofx | [pure virtual]
getIofxRenderCallback(const Scene &apexScene) const =0 | nvidia::apex::ModuleIofx | [pure virtual]
getTestBase(Scene *apexScene) const =0 | nvidia::apex::ModuleIofx | [pure virtual]
prepareRenderables(const Scene &)=0 | nvidia::apex::ModuleIofx | [pure virtual]
releaseRenderVolume(RenderVolume &volume)=0 | nvidia::apex::ModuleIofx | [pure virtual]
setIofxRenderCallback(const Scene &apexScene, IofxRenderCallback *)=0 | nvidia::apex::ModuleIofx | [pure virtual]
~ModuleIofx() | nvidia::apex::ModuleIofx | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::OrientAlongVelocityModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • OrientAlongVelocityModifier
Public Member Functions | Static Public Attributes
nvidia::apex::OrientAlongVelocityModifier Class Reference

OrientAlongVelocity is a modifier to orient a mesh so that a particular axis coincides with the velocity vector. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::OrientAlongVelocityModifier:
nvidia::apex::ModifierT< OrientAlongVelocityModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual PxVec3 | getModelForward () const =0
get the object-space vector that will coincide with the velocity vector
virtual void | setModelForward (const PxVec3 &s)=0
set the object-space vector that will coincide with the velocity vector

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_OrientAlongVelocity
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

OrientAlongVelocity is a modifier to orient a mesh so that a particular axis coincides with the velocity vector.

Member Function Documentation

virtual PxVec3 nvidia::apex::OrientAlongVelocityModifier::getModelForward ( ) const [pure virtual]

get the object-space vector that will coincide with the velocity vector

virtual void nvidia::apex::OrientAlongVelocityModifier::setModelForward ( const PxVec3 & s ) [pure virtual]

set the object-space vector that will coincide with the velocity vector

Member Data Documentation

const ModifierTypeEnum nvidia::apex::OrientAlongVelocityModifier::ModifierType = ModifierType_OrientAlongVelocity [static]

ModifierType.

const uint32_t nvidia::apex::OrientAlongVelocityModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • OrientAlongVelocityModifier
nvidia::apex::OrientAlongVelocityModifier Member List
This is the complete list of members for nvidia::apex::OrientAlongVelocityModifier, including all inherited members.
getModelForward() const =0 | nvidia::apex::OrientAlongVelocityModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< OrientAlongVelocityModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< OrientAlongVelocityModifier > | [inline, virtual]
ModifierType | nvidia::apex::OrientAlongVelocityModifier | [static]
ModifierUsage | nvidia::apex::OrientAlongVelocityModifier | [static]
setModelForward(const PxVec3 &s)=0 | nvidia::apex::OrientAlongVelocityModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::OrientScaleAlongScreenVelocityModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • OrientScaleAlongScreenVelocityModifier
Public Member Functions | Static Public Attributes
nvidia::apex::OrientScaleAlongScreenVelocityModifier Class Reference

OrientScaleAlongScreenVelocityModifier is a modifier to orient & scale sprites along the current screen velocity vector. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::OrientScaleAlongScreenVelocityModifier:
nvidia::apex::ModifierT< OrientScaleAlongScreenVelocityModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual float | getScalePerVelocity () const =0
get the scale per velocity
virtual void | setScalePerVelocity (const float &s)=0
set the scale per velocity
virtual float | getScaleChangeLimit () const =0
get the scale change limit
virtual void | setScaleChangeLimit (const float &s)=0
set the scale change limit
virtual float | getScaleChangeDelay () const =0
get the scale change delay
virtual void | setScaleChangeDelay (const float &s)=0
set the scale change delay

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_OrientScaleAlongScreenVelocity
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

OrientScaleAlongScreenVelocityModifier is a modifier to orient & scale sprites along the current screen velocity vector.

Member Function Documentation

virtual float nvidia::apex::OrientScaleAlongScreenVelocityModifier::getScaleChangeDelay ( ) const [pure virtual]

get the scale change delay

virtual float nvidia::apex::OrientScaleAlongScreenVelocityModifier::getScaleChangeLimit ( ) const [pure virtual]

get the scale change limit

virtual float nvidia::apex::OrientScaleAlongScreenVelocityModifier::getScalePerVelocity ( ) const [pure virtual]

get the scale per velocity

virtual void nvidia::apex::OrientScaleAlongScreenVelocityModifier::setScaleChangeDelay ( const float & s ) [pure virtual]

set the scale change delay

virtual void nvidia::apex::OrientScaleAlongScreenVelocityModifier::setScaleChangeLimit ( const float & s ) [pure virtual]

set the scale change limit

virtual void nvidia::apex::OrientScaleAlongScreenVelocityModifier::setScalePerVelocity ( const float & s ) [pure virtual]

set the scale per velocity

Member Data Documentation

const ModifierTypeEnum nvidia::apex::OrientScaleAlongScreenVelocityModifier::ModifierType = ModifierType_OrientScaleAlongScreenVelocity [static]

ModifierType.

const uint32_t nvidia::apex::OrientScaleAlongScreenVelocityModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • OrientScaleAlongScreenVelocityModifier
nvidia::apex::OrientScaleAlongScreenVelocityModifier Member List
This is the complete list of members for nvidia::apex::OrientScaleAlongScreenVelocityModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< OrientScaleAlongScreenVelocityModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< OrientScaleAlongScreenVelocityModifier > | [inline, virtual]
getScaleChangeDelay() const =0 | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [pure virtual]
getScaleChangeLimit() const =0 | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [pure virtual]
getScalePerVelocity() const =0 | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [pure virtual]
ModifierType | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [static]
ModifierUsage | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [static]
setScaleChangeDelay(const float &s)=0 | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [pure virtual]
setScaleChangeLimit(const float &s)=0 | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [pure virtual]
setScalePerVelocity(const float &s)=0 | nvidia::apex::OrientScaleAlongScreenVelocityModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::RandomRotationModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RandomRotationModifier
Public Member Functions | Static Public Attributes
nvidia::apex::RandomRotationModifier Class Reference

RandomRotationModifier will choose a random orientation for a sprite particle within the range as specified below. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::RandomRotationModifier:
nvidia::apex::ModifierT< RandomRotationModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual Range< float > | getRotationRange () const =0
get the range of orientations, in radians.
virtual void | setRotationRange (const Range< float > &s)=0
set the range of orientations, in radians.

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_RandomRotation
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

RandomRotationModifier will choose a random orientation for a sprite particle within the range as specified below.

The values in the range are interpreted as radians. Please keep in mind that all the sprites are coplanar to the screen.

Member Function Documentation

virtual Range<float> nvidia::apex::RandomRotationModifier::getRotationRange ( ) const [pure virtual]

get the range of orientations, in radians.

virtual void nvidia::apex::RandomRotationModifier::setRotationRange ( const Range< float > & s ) [pure virtual]

set the range of orientations, in radians.

Member Data Documentation

const ModifierTypeEnum nvidia::apex::RandomRotationModifier::ModifierType = ModifierType_RandomRotation [static]

ModifierType.

const uint32_t nvidia::apex::RandomRotationModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RandomRotationModifier
nvidia::apex::RandomRotationModifier Member List
This is the complete list of members for nvidia::apex::RandomRotationModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< RandomRotationModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< RandomRotationModifier > | [inline, virtual]
getRotationRange() const =0 | nvidia::apex::RandomRotationModifier | [pure virtual]
ModifierType | nvidia::apex::RandomRotationModifier | [static]
ModifierUsage | nvidia::apex::RandomRotationModifier | [static]
setRotationRange(const Range< float > &s)=0 | nvidia::apex::RandomRotationModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::RandomScaleModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RandomScaleModifier
Public Member Functions | Static Public Attributes
nvidia::apex::RandomScaleModifier Class Reference

RandomScaleModifier applies a random scale uniformly to all three dimensions. Currently, the scale is a uniform in the range specified. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::RandomScaleModifier:
nvidia::apex::ModifierT< RandomScaleModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual Range< float > | getScaleFactor () const =0
get the range of scale factors along the three axes
virtual void | setScaleFactor (const Range< float > &s)=0
set the range of scale factors along the three axes

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_RandomScale
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

RandomScaleModifier applies a random scale uniformly to all three dimensions. Currently, the scale is a uniform in the range specified.

Member Function Documentation

virtual Range<float> nvidia::apex::RandomScaleModifier::getScaleFactor ( ) const [pure virtual]

get the range of scale factors along the three axes

virtual void nvidia::apex::RandomScaleModifier::setScaleFactor ( const Range< float > & s ) [pure virtual]

set the range of scale factors along the three axes

Member Data Documentation

const ModifierTypeEnum nvidia::apex::RandomScaleModifier::ModifierType = ModifierType_RandomScale [static]

ModifierType.

const uint32_t nvidia::apex::RandomScaleModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RandomScaleModifier
nvidia::apex::RandomScaleModifier Member List
This is the complete list of members for nvidia::apex::RandomScaleModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< RandomScaleModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< RandomScaleModifier > | [inline, virtual]
getScaleFactor() const =0 | nvidia::apex::RandomScaleModifier | [pure virtual]
ModifierType | nvidia::apex::RandomScaleModifier | [static]
ModifierUsage | nvidia::apex::RandomScaleModifier | [static]
setScaleFactor(const Range< float > &s)=0 | nvidia::apex::RandomScaleModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::RandomSubtextureModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RandomSubtextureModifier
Public Member Functions | Static Public Attributes
nvidia::apex::RandomSubtextureModifier Class Reference

RandomSubtextureModifier generates a random subtexture ID and places it in the subTextureId field. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::RandomSubtextureModifier:
nvidia::apex::ModifierT< RandomSubtextureModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual Range< float > | getSubtextureRange () const =0
get the range for subtexture values
virtual void | setSubtextureRange (const Range< float > &s)=0
set the range for subtexture values

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_RandomSubtexture
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

RandomSubtextureModifier generates a random subtexture ID and places it in the subTextureId field.

Member Function Documentation

virtual Range<float> nvidia::apex::RandomSubtextureModifier::getSubtextureRange ( ) const [pure virtual]

get the range for subtexture values

virtual void nvidia::apex::RandomSubtextureModifier::setSubtextureRange ( const Range< float > & s ) [pure virtual]

set the range for subtexture values

Member Data Documentation

const ModifierTypeEnum nvidia::apex::RandomSubtextureModifier::ModifierType = ModifierType_RandomSubtexture [static]

ModifierType.

const uint32_t nvidia::apex::RandomSubtextureModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RandomSubtextureModifier
nvidia::apex::RandomSubtextureModifier Member List
This is the complete list of members for nvidia::apex::RandomSubtextureModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< RandomSubtextureModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< RandomSubtextureModifier > | [inline, virtual]
getSubtextureRange() const =0 | nvidia::apex::RandomSubtextureModifier | [pure virtual]
ModifierType | nvidia::apex::RandomSubtextureModifier | [static]
ModifierUsage | nvidia::apex::RandomSubtextureModifier | [static]
setSubtextureRange(const Range< float > &s)=0 | nvidia::apex::RandomSubtextureModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::RenderVolume Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderVolume
Public Member Functions | Protected Member Functions
nvidia::apex::RenderVolume Class Reference

An object which "owns" a volume of world space. More...

#include <RenderVolume.h>

List of all members.

Public Member Functions

virtual physx::PxBounds3 | getBounds () const =0
Returns AABB covering all objects in this render volume, it's updated each frame during Scene::fetchResults().
virtual bool | getAffectsAllIofx () const =0
Returns true if the volume affects all IOFX assets.
virtual bool | addIofxAsset (IofxAsset &iofx)=0
Adds IOFX asset to volume's list of affected IOFX assets, returns false on failure.
virtual void | setPosition (const PxVec3 &pos)=0
Moves the render volume while maintaining its dimensions.
virtual void | setOwnershipBounds (const PxBounds3 &b)=0
Directly assigns a new AABB ownership volume.
virtual PxBounds3 | getOwnershipBounds () const =0
Retrieves the configured AABB bounds of the volume. Call getBounds() for the "live" bounds.
virtual IofxActor *const | lockIofxActorList (uint32_t &count)=0
Retrieve list of IOFX actors owned by this volume (one per IOFX Asset per IOS actor)
virtual void | unlockIofxActorList ()=0
Unlock IOFX actors which where locked by calling lockIofxActorList.
virtual IofxAsset *const | getIofxAssetList (uint32_t &count) const =0
Retrieve list of volume's affected IOFX assets.
virtual PxVec3 | getPosition () const =0
Returns center of ownership bounds.
virtual uint32_t | getPriority () const =0
Returns priority of volume.
virtual bool | affectsIofxAsset (const IofxAsset &iofx) const =0
Returns true if this volume affects the specified IOFX asset.

Protected Member Functions

virtual | ~RenderVolume ()

Detailed Description

An object which "owns" a volume of world space.

Any particles which enter the owned volume will be migrated to an IOFX actor owned by this object (if the particle's IOFX asset is affected by this volume).

When volumes overlap, their relative priorities break the tie. If multiple volumes have the same priority, the tie breaker goes to the volume that owns the particle.

Constructor & Destructor Documentation

virtual nvidia::apex::RenderVolume::~RenderVolume ( ) [inline, protected, virtual]

Member Function Documentation

virtual bool nvidia::apex::RenderVolume::addIofxAsset ( IofxAsset & iofx ) [pure virtual]

Adds IOFX asset to volume's list of affected IOFX assets, returns false on failure.

virtual bool nvidia::apex::RenderVolume::affectsIofxAsset ( const IofxAsset & iofx ) const [pure virtual]

Returns true if this volume affects the specified IOFX asset.

Callers must acquire render lock of the volume before calling this function, for thread safety.

virtual bool nvidia::apex::RenderVolume::getAffectsAllIofx ( ) const [pure virtual]

Returns true if the volume affects all IOFX assets.

virtual physx::PxBounds3 nvidia::apex::RenderVolume::getBounds ( ) const [pure virtual]

Returns AABB covering all objects in this render volume, it's updated each frame during Scene::fetchResults().

virtual IofxAsset* const nvidia::apex::RenderVolume::getIofxAssetList ( uint32_t & count ) const [pure virtual]

Retrieve list of volume's affected IOFX assets.

Returns count of 0 if empty or volume affects all IOFX assets. Returned pointer is undefined when count is 0.

The returned buffer not thread-safe, and is only valid until the next APEX API call that steps the simulation or modifies the number of IOFX assets in a scene.

virtual PxBounds3 nvidia::apex::RenderVolume::getOwnershipBounds ( ) const [pure virtual]

Retrieves the configured AABB bounds of the volume. Call getBounds() for the "live" bounds.

virtual PxVec3 nvidia::apex::RenderVolume::getPosition ( ) const [pure virtual]

Returns center of ownership bounds.

virtual uint32_t nvidia::apex::RenderVolume::getPriority ( ) const [pure virtual]

Returns priority of volume.

virtual IofxActor* const nvidia::apex::RenderVolume::lockIofxActorList ( uint32_t & count ) [pure virtual]

Retrieve list of IOFX actors owned by this volume (one per IOFX Asset per IOS actor)

Returns count of 0 if empty. Returned pointer is undefined when count is 0.

The bounds of each of these IOFX is guaranteed to be within the bounds of the volume itself. Calling the updateRenderResources and dispatchRenderResources() methods of the volume will implicitly call the same methods of each of these IOFX actors, so there is no need to iterate over them for rendering purposes, unless you require special logic per IOFX.

It is not necessary to release these actors, they will be released automatically when their volume, their IOFX Asset, or their host IOS actor are released.

This call is not thread-safe. The returned buffer is only valid until the next APEX API call that steps the simulation or modifies the number of IOFX actors in a scene.

virtual void nvidia::apex::RenderVolume::setOwnershipBounds ( const PxBounds3 & b ) [pure virtual]

Directly assigns a new AABB ownership volume.

virtual void nvidia::apex::RenderVolume::setPosition ( const PxVec3 & pos ) [pure virtual]

Moves the render volume while maintaining its dimensions.

virtual void nvidia::apex::RenderVolume::unlockIofxActorList ( ) [pure virtual]

Unlock IOFX actors which where locked by calling lockIofxActorList.

See also:
RenderVolume::lockIofxActorList
The documentation for this class was generated from the following file:
  • RenderVolume.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RenderVolume
nvidia::apex::RenderVolume Member List
This is the complete list of members for nvidia::apex::RenderVolume, including all inherited members.
addIofxAsset(IofxAsset &iofx)=0 | nvidia::apex::RenderVolume | [pure virtual]
affectsIofxAsset(const IofxAsset &iofx) const =0 | nvidia::apex::RenderVolume | [pure virtual]
getAffectsAllIofx() const =0 | nvidia::apex::RenderVolume | [pure virtual]
getBounds() const =0 | nvidia::apex::RenderVolume | [pure virtual]
getIofxAssetList(uint32_t &count) const =0 | nvidia::apex::RenderVolume | [pure virtual]
getOwnershipBounds() const =0 | nvidia::apex::RenderVolume | [pure virtual]
getPosition() const =0 | nvidia::apex::RenderVolume | [pure virtual]
getPriority() const =0 | nvidia::apex::RenderVolume | [pure virtual]
lockIofxActorList(uint32_t &count)=0 | nvidia::apex::RenderVolume | [pure virtual]
setOwnershipBounds(const PxBounds3 &b)=0 | nvidia::apex::RenderVolume | [pure virtual]
setPosition(const PxVec3 &pos)=0 | nvidia::apex::RenderVolume | [pure virtual]
unlockIofxActorList()=0 | nvidia::apex::RenderVolume | [pure virtual]
~RenderVolume() | nvidia::apex::RenderVolume | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::RotationModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RotationModifier
Public Member Functions | Static Public Attributes
nvidia::apex::RotationModifier Class Reference

RotationModifier applies rotation to the particles using one of several rotation models. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::RotationModifier:
nvidia::apex::ModifierT< RotationModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual
ApexMeshParticleRollType::Enum 		getRollType () const =0
get the roll model
virtual void | setRollType (ApexMeshParticleRollType::Enum rollType)=0
set the roll model
virtual float | getMaxSettleRate () const =0
get the maximum allowed settle rate per second
virtual void | setMaxSettleRate (float settleRate)=0
set the maximum allowed settle rate per second
virtual float | getMaxRotationRate () const =0
get the maximum allowed rotation rate per second
virtual void | setMaxRotationRate (float rotationRate)=0
set the maximum allowed rotation rate per second

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_Rotation
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

RotationModifier applies rotation to the particles using one of several rotation models.

Member Function Documentation

virtual float nvidia::apex::RotationModifier::getMaxRotationRate ( ) const [pure virtual]

get the maximum allowed rotation rate per second

virtual float nvidia::apex::RotationModifier::getMaxSettleRate ( ) const [pure virtual]

get the maximum allowed settle rate per second

virtual ApexMeshParticleRollType::Enum nvidia::apex::RotationModifier::getRollType ( ) const [pure virtual]

get the roll model

virtual void nvidia::apex::RotationModifier::setMaxRotationRate ( float rotationRate ) [pure virtual]

set the maximum allowed rotation rate per second

virtual void nvidia::apex::RotationModifier::setMaxSettleRate ( float settleRate ) [pure virtual]

set the maximum allowed settle rate per second

virtual void nvidia::apex::RotationModifier::setRollType ( ApexMeshParticleRollType::Enum rollType ) [pure virtual]

set the roll model

Member Data Documentation

const ModifierTypeEnum nvidia::apex::RotationModifier::ModifierType = ModifierType_Rotation [static]

ModifierType.

const uint32_t nvidia::apex::RotationModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn | ModifierUsage_Continuous
            | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RotationModifier
nvidia::apex::RotationModifier Member List
This is the complete list of members for nvidia::apex::RotationModifier, including all inherited members.
getMaxRotationRate() const =0 | nvidia::apex::RotationModifier | [pure virtual]
getMaxSettleRate() const =0 | nvidia::apex::RotationModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< RotationModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< RotationModifier > | [inline, virtual]
getRollType() const =0 | nvidia::apex::RotationModifier | [pure virtual]
ModifierType | nvidia::apex::RotationModifier | [static]
ModifierUsage | nvidia::apex::RotationModifier | [static]
setMaxRotationRate(float rotationRate)=0 | nvidia::apex::RotationModifier | [pure virtual]
setMaxSettleRate(float settleRate)=0 | nvidia::apex::RotationModifier | [pure virtual]
setRollType(ApexMeshParticleRollType::Enum rollType)=0 | nvidia::apex::RotationModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::RotationRateModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RotationRateModifier
Public Member Functions | Static Public Attributes
nvidia::apex::RotationRateModifier Class Reference

RotationRateModifier is a modifier to apply a continuous rotation for sprites. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::RotationRateModifier:
nvidia::apex::ModifierT< RotationRateModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual float | getRotationRate () const =0
set the rotation rate
virtual void | setRotationRate (const float &rate)=0
get the rotation rate

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_RotationRate
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

RotationRateModifier is a modifier to apply a continuous rotation for sprites.

Member Function Documentation

virtual float nvidia::apex::RotationRateModifier::getRotationRate ( ) const [pure virtual]

set the rotation rate

virtual void nvidia::apex::RotationRateModifier::setRotationRate ( const float & rate ) [pure virtual]

get the rotation rate

Member Data Documentation

const ModifierTypeEnum nvidia::apex::RotationRateModifier::ModifierType = ModifierType_RotationRate [static]

ModifierType.

const uint32_t nvidia::apex::RotationRateModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RotationRateModifier
nvidia::apex::RotationRateModifier Member List
This is the complete list of members for nvidia::apex::RotationRateModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< RotationRateModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< RotationRateModifier > | [inline, virtual]
getRotationRate() const =0 | nvidia::apex::RotationRateModifier | [pure virtual]
ModifierType | nvidia::apex::RotationRateModifier | [static]
ModifierUsage | nvidia::apex::RotationRateModifier | [static]
setRotationRate(const float &rate)=0 | nvidia::apex::RotationRateModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::RotationRateVsLifeModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RotationRateVsLifeModifier
Public Member Functions | Static Public Attributes
nvidia::apex::RotationRateVsLifeModifier Class Reference

RotationRateVsLifeModifier is a modifier to adjust the rotation rate versus the life remaining of a particular particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::RotationRateVsLifeModifier:
nvidia::apex::ModifierT< RotationRateVsLifeModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual const Curve * | getFunction () const =0
get the curve that sets the dependency between the life remaining and the rotation rate
virtual void | setFunction (const Curve *f)=0
set the curve that sets the dependency between the life remaining and the rotation rate

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_RotationRateVsLife
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

RotationRateVsLifeModifier is a modifier to adjust the rotation rate versus the life remaining of a particular particle.

Member Function Documentation

virtual const Curve* nvidia::apex::RotationRateVsLifeModifier::getFunction ( ) const [pure virtual]

get the curve that sets the dependency between the life remaining and the rotation rate

virtual void nvidia::apex::RotationRateVsLifeModifier::setFunction ( const Curve * f ) [pure virtual]

set the curve that sets the dependency between the life remaining and the rotation rate

Member Data Documentation

const ModifierTypeEnum nvidia::apex::RotationRateVsLifeModifier::ModifierType = ModifierType_RotationRateVsLife [static]

ModifierType.

const uint32_t nvidia::apex::RotationRateVsLifeModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • RotationRateVsLifeModifier
nvidia::apex::RotationRateVsLifeModifier Member List
This is the complete list of members for nvidia::apex::RotationRateVsLifeModifier, including all inherited members.
getFunction() const =0 | nvidia::apex::RotationRateVsLifeModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< RotationRateVsLifeModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< RotationRateVsLifeModifier > | [inline, virtual]
ModifierType | nvidia::apex::RotationRateVsLifeModifier | [static]
ModifierUsage | nvidia::apex::RotationRateVsLifeModifier | [static]
setFunction(const Curve *f)=0 | nvidia::apex::RotationRateVsLifeModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::ScaleAlongVelocityModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleAlongVelocityModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ScaleAlongVelocityModifier Class Reference

ScaleAlongVelocityModifier is a modifier to apply a scale factor along the current velocity vector. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ScaleAlongVelocityModifier:
nvidia::apex::ModifierT< ScaleAlongVelocityModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual float | getScaleFactor () const =0
get the scale factor
virtual void | setScaleFactor (const float &s)=0
set the scale factor

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ScaleAlongVelocity
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ScaleAlongVelocityModifier is a modifier to apply a scale factor along the current velocity vector.

Note that without applying an OrientAlongVelocity modifier first, the results for this will be 'odd.'

Member Function Documentation

virtual float nvidia::apex::ScaleAlongVelocityModifier::getScaleFactor ( ) const [pure virtual]

get the scale factor

virtual void nvidia::apex::ScaleAlongVelocityModifier::setScaleFactor ( const float & s ) [pure virtual]

set the scale factor

Member Data Documentation

const ModifierTypeEnum nvidia::apex::ScaleAlongVelocityModifier::ModifierType = ModifierType_ScaleAlongVelocity [static]

ModifierType.

const uint32_t nvidia::apex::ScaleAlongVelocityModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleAlongVelocityModifier
nvidia::apex::ScaleAlongVelocityModifier Member List
This is the complete list of members for nvidia::apex::ScaleAlongVelocityModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ScaleAlongVelocityModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ScaleAlongVelocityModifier > | [inline, virtual]
getScaleFactor() const =0 | nvidia::apex::ScaleAlongVelocityModifier | [pure virtual]
ModifierType | nvidia::apex::ScaleAlongVelocityModifier | [static]
ModifierUsage | nvidia::apex::ScaleAlongVelocityModifier | [static]
setScaleFactor(const float &s)=0 | nvidia::apex::ScaleAlongVelocityModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::ScaleByMassModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleByMassModifier
Static Public Attributes
nvidia::apex::ScaleByMassModifier Class Reference

ScaleByMassModifier scales by mass of the particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ScaleByMassModifier:
nvidia::apex::ModifierT< ScaleByMassModifier > nvidia::apex::Modifier

List of all members.

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ScaleByMass
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ScaleByMassModifier scales by mass of the particle.

Member Data Documentation

const ModifierTypeEnum nvidia::apex::ScaleByMassModifier::ModifierType = ModifierType_ScaleByMass [static]

ModifierType.

const uint32_t nvidia::apex::ScaleByMassModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn | ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleByMassModifier
nvidia::apex::ScaleByMassModifier Member List
This is the complete list of members for nvidia::apex::ScaleByMassModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ScaleByMassModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ScaleByMassModifier > | [inline, virtual]
ModifierType | nvidia::apex::ScaleByMassModifier | [static]
ModifierUsage | nvidia::apex::ScaleByMassModifier | [static]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::ScaleVsCameraDistanceModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleVsCameraDistanceModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ScaleVsCameraDistanceModifier Class Reference

ScaleVsCameraDistance applies a scale factor against a specific axis based on distance from the camera to the particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ScaleVsCameraDistanceModifier:
nvidia::apex::ModifierT< ScaleVsCameraDistanceModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ScaleAxis | getScaleAxis () const =0
get the axis along which the scale factor will be applied
virtual void | setScaleAxis (ScaleAxis a)=0
set the axis along which the scale factor will be applied
virtual const Curve * | getFunction () const =0
get the the curve that defines the dependency between the camera distance and the scale factor
virtual void | setFunction (const Curve *f)=0
set the the curve that defines the dependency between the camera distance and the scale factor

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ScaleVsCameraDistance
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ScaleVsCameraDistance applies a scale factor against a specific axis based on distance from the camera to the particle.

Member Function Documentation

virtual const Curve* nvidia::apex::ScaleVsCameraDistanceModifier::getFunction ( ) const [pure virtual]

get the the curve that defines the dependency between the camera distance and the scale factor

virtual ScaleAxis nvidia::apex::ScaleVsCameraDistanceModifier::getScaleAxis ( ) const [pure virtual]

get the axis along which the scale factor will be applied

virtual void nvidia::apex::ScaleVsCameraDistanceModifier::setFunction ( const Curve * f ) [pure virtual]

set the the curve that defines the dependency between the camera distance and the scale factor

virtual void nvidia::apex::ScaleVsCameraDistanceModifier::setScaleAxis ( ScaleAxis a ) [pure virtual]

set the axis along which the scale factor will be applied

Member Data Documentation

const ModifierTypeEnum nvidia::apex::ScaleVsCameraDistanceModifier::ModifierType = ModifierType_ScaleVsCameraDistance [static]

ModifierType.

const uint32_t nvidia::apex::ScaleVsCameraDistanceModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleVsCameraDistanceModifier
nvidia::apex::ScaleVsCameraDistanceModifier Member List
This is the complete list of members for nvidia::apex::ScaleVsCameraDistanceModifier, including all inherited members.
getFunction() const =0 | nvidia::apex::ScaleVsCameraDistanceModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ScaleVsCameraDistanceModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ScaleVsCameraDistanceModifier > | [inline, virtual]
getScaleAxis() const =0 | nvidia::apex::ScaleVsCameraDistanceModifier | [pure virtual]
ModifierType | nvidia::apex::ScaleVsCameraDistanceModifier | [static]
ModifierUsage | nvidia::apex::ScaleVsCameraDistanceModifier | [static]
setFunction(const Curve *f)=0 | nvidia::apex::ScaleVsCameraDistanceModifier | [pure virtual]
setScaleAxis(ScaleAxis a)=0 | nvidia::apex::ScaleVsCameraDistanceModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::ScaleVsDensityModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleVsDensityModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ScaleVsDensityModifier Class Reference

ScaleVsDensityModifier applies a scale factor function against a single axis versus the density of the particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ScaleVsDensityModifier:
nvidia::apex::ModifierT< ScaleVsDensityModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ScaleAxis | getScaleAxis () const =0
get the axis along which the scale factor will be applied
virtual void | setScaleAxis (ScaleAxis a)=0
set the axis along which the scale factor will be applied
virtual const Curve * | getFunction () const =0
get the the curve that defines the dependency between the density and the scale factor
virtual void | setFunction (const Curve *f)=0
set the the curve that defines the dependency between the density and the scale factor

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ScaleVsDensity
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ScaleVsDensityModifier applies a scale factor function against a single axis versus the density of the particle.

Member Function Documentation

virtual const Curve* nvidia::apex::ScaleVsDensityModifier::getFunction ( ) const [pure virtual]

get the the curve that defines the dependency between the density and the scale factor

virtual ScaleAxis nvidia::apex::ScaleVsDensityModifier::getScaleAxis ( ) const [pure virtual]

get the axis along which the scale factor will be applied

virtual void nvidia::apex::ScaleVsDensityModifier::setFunction ( const Curve * f ) [pure virtual]

set the the curve that defines the dependency between the density and the scale factor

virtual void nvidia::apex::ScaleVsDensityModifier::setScaleAxis ( ScaleAxis a ) [pure virtual]

set the axis along which the scale factor will be applied

Member Data Documentation

const ModifierTypeEnum nvidia::apex::ScaleVsDensityModifier::ModifierType = ModifierType_ScaleVsDensity [static]

ModifierType.

const uint32_t nvidia::apex::ScaleVsDensityModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleVsDensityModifier
nvidia::apex::ScaleVsDensityModifier Member List
This is the complete list of members for nvidia::apex::ScaleVsDensityModifier, including all inherited members.
getFunction() const =0 | nvidia::apex::ScaleVsDensityModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ScaleVsDensityModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ScaleVsDensityModifier > | [inline, virtual]
getScaleAxis() const =0 | nvidia::apex::ScaleVsDensityModifier | [pure virtual]
ModifierType | nvidia::apex::ScaleVsDensityModifier | [static]
ModifierUsage | nvidia::apex::ScaleVsDensityModifier | [static]
setFunction(const Curve *f)=0 | nvidia::apex::ScaleVsDensityModifier | [pure virtual]
setScaleAxis(ScaleAxis a)=0 | nvidia::apex::ScaleVsDensityModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::ScaleVsLifeModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleVsLifeModifier
Public Member Functions | Static Public Attributes
nvidia::apex::ScaleVsLifeModifier Class Reference

ScaleVsLifeModifier applies a scale factor function against a single axis versus the life remaining. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ScaleVsLifeModifier:
nvidia::apex::ModifierT< ScaleVsLifeModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual ScaleAxis | getScaleAxis () const =0
get the axis along which the scale factor will be applied
virtual void | setScaleAxis (ScaleAxis a)=0
set the axis along which the scale factor will be applied
virtual const Curve * | getFunction () const =0
get the the curve that defines the dependency between the life remaining and the scale factor
virtual void | setFunction (const Curve *f)=0
set the the curve that defines the dependency between the life remaining and the scale factor

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ScaleVsLife
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ScaleVsLifeModifier applies a scale factor function against a single axis versus the life remaining.

Member Function Documentation

virtual const Curve* nvidia::apex::ScaleVsLifeModifier::getFunction ( ) const [pure virtual]

get the the curve that defines the dependency between the life remaining and the scale factor

virtual ScaleAxis nvidia::apex::ScaleVsLifeModifier::getScaleAxis ( ) const [pure virtual]

get the axis along which the scale factor will be applied

virtual void nvidia::apex::ScaleVsLifeModifier::setFunction ( const Curve * f ) [pure virtual]

set the the curve that defines the dependency between the life remaining and the scale factor

virtual void nvidia::apex::ScaleVsLifeModifier::setScaleAxis ( ScaleAxis a ) [pure virtual]

set the axis along which the scale factor will be applied

Member Data Documentation

const ModifierTypeEnum nvidia::apex::ScaleVsLifeModifier::ModifierType = ModifierType_ScaleVsLife [static]

ModifierType.

const uint32_t nvidia::apex::ScaleVsLifeModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ScaleVsLifeModifier
nvidia::apex::ScaleVsLifeModifier Member List
This is the complete list of members for nvidia::apex::ScaleVsLifeModifier, including all inherited members.
getFunction() const =0 | nvidia::apex::ScaleVsLifeModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ScaleVsLifeModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ScaleVsLifeModifier > | [inline, virtual]
getScaleAxis() const =0 | nvidia::apex::ScaleVsLifeModifier | [pure virtual]
ModifierType | nvidia::apex::ScaleVsLifeModifier | [static]
ModifierUsage | nvidia::apex::ScaleVsLifeModifier | [static]
setFunction(const Curve *f)=0 | nvidia::apex::ScaleVsLifeModifier | [pure virtual]
setScaleAxis(ScaleAxis a)=0 | nvidia::apex::ScaleVsLifeModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::SimpleScaleModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SimpleScaleModifier
Public Member Functions | Static Public Attributes
nvidia::apex::SimpleScaleModifier Class Reference

SimpleScaleModifier just applies a simple scale factor to each of the X, Y and Z aspects of the model. Each scalefactor can be applied independently. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::SimpleScaleModifier:
nvidia::apex::ModifierT< SimpleScaleModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual PxVec3 | getScaleFactor () const =0
get the vector of scale factors along the three axes
virtual void | setScaleFactor (const PxVec3 &s)=0
set the vector of scale factors along the three axes

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_SimpleScale
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

SimpleScaleModifier just applies a simple scale factor to each of the X, Y and Z aspects of the model. Each scalefactor can be applied independently.

Member Function Documentation

virtual PxVec3 nvidia::apex::SimpleScaleModifier::getScaleFactor ( ) const [pure virtual]

get the vector of scale factors along the three axes

virtual void nvidia::apex::SimpleScaleModifier::setScaleFactor ( const PxVec3 & s ) [pure virtual]

set the vector of scale factors along the three axes

Member Data Documentation

const ModifierTypeEnum nvidia::apex::SimpleScaleModifier::ModifierType = ModifierType_SimpleScale [static]

ModifierType.

const uint32_t nvidia::apex::SimpleScaleModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Spawn | ModifierUsage_Continuous
            | ModifierUsage_Sprite | ModifierUsage_Mesh

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SimpleScaleModifier
nvidia::apex::SimpleScaleModifier Member List
This is the complete list of members for nvidia::apex::SimpleScaleModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< SimpleScaleModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< SimpleScaleModifier > | [inline, virtual]
getScaleFactor() const =0 | nvidia::apex::SimpleScaleModifier | [pure virtual]
ModifierType | nvidia::apex::SimpleScaleModifier | [static]
ModifierUsage | nvidia::apex::SimpleScaleModifier | [static]
setScaleFactor(const PxVec3 &s)=0 | nvidia::apex::SimpleScaleModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::SubtextureVsLifeModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SubtextureVsLifeModifier
Public Member Functions | Static Public Attributes
nvidia::apex::SubtextureVsLifeModifier Class Reference

SubtextureVsLifeModifier is a modifier to adjust the subtexture id versus the life remaining of a particular particle. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::SubtextureVsLifeModifier:
nvidia::apex::ModifierT< SubtextureVsLifeModifier > nvidia::apex::Modifier

List of all members.

Public Member Functions

virtual const Curve * | getFunction () const =0
get the curve that sets the dependency between the life remaining and the subtexture id
virtual void | setFunction (const Curve *f)=0
set the curve that sets the dependency between the life remaining and the subtexture id

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_SubtextureVsLife
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

SubtextureVsLifeModifier is a modifier to adjust the subtexture id versus the life remaining of a particular particle.

Interpretation of the subtexture id over time is up to the application.

Member Function Documentation

virtual const Curve* nvidia::apex::SubtextureVsLifeModifier::getFunction ( ) const [pure virtual]

get the curve that sets the dependency between the life remaining and the subtexture id

virtual void nvidia::apex::SubtextureVsLifeModifier::setFunction ( const Curve * f ) [pure virtual]

set the curve that sets the dependency between the life remaining and the subtexture id

Member Data Documentation

const ModifierTypeEnum nvidia::apex::SubtextureVsLifeModifier::ModifierType = ModifierType_SubtextureVsLife [static]

ModifierType.

const uint32_t nvidia::apex::SubtextureVsLifeModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • SubtextureVsLifeModifier
nvidia::apex::SubtextureVsLifeModifier Member List
This is the complete list of members for nvidia::apex::SubtextureVsLifeModifier, including all inherited members.
getFunction() const =0 | nvidia::apex::SubtextureVsLifeModifier | [pure virtual]
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< SubtextureVsLifeModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< SubtextureVsLifeModifier > | [inline, virtual]
ModifierType | nvidia::apex::SubtextureVsLifeModifier | [static]
ModifierUsage | nvidia::apex::SubtextureVsLifeModifier | [static]
setFunction(const Curve *f)=0 | nvidia::apex::SubtextureVsLifeModifier | [pure virtual]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::ViewDirectionSortingModifier Class Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ViewDirectionSortingModifier
Static Public Attributes
nvidia::apex::ViewDirectionSortingModifier Class Reference

ViewDirectionSortingModifier sorts sprite particles along view direction back to front. More...

#include <Modifier.h>

Inheritance diagram for nvidia::apex::ViewDirectionSortingModifier:
nvidia::apex::ModifierT< ViewDirectionSortingModifier > nvidia::apex::Modifier

List of all members.

Static Public Attributes

static const ModifierTypeEnum | ModifierType = ModifierType_ViewDirectionSorting
ModifierType.
static const uint32_t | ModifierUsage
ModifierUsage.

Detailed Description

ViewDirectionSortingModifier sorts sprite particles along view direction back to front.

Member Data Documentation

const ModifierTypeEnum nvidia::apex::ViewDirectionSortingModifier::ModifierType = ModifierType_ViewDirectionSorting [static]

ModifierType.

const uint32_t nvidia::apex::ViewDirectionSortingModifier::ModifierUsage [static]
Initial value:
 ModifierUsage_Continuous
            | ModifierUsage_Sprite

ModifierUsage.

The documentation for this class was generated from the following file:
  • Modifier.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ViewDirectionSortingModifier
nvidia::apex::ViewDirectionSortingModifier Member List
This is the complete list of members for nvidia::apex::ViewDirectionSortingModifier, including all inherited members.
getModifierMeshSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierSpriteSemantics() | nvidia::apex::Modifier | [inline, virtual]
getModifierType() const | nvidia::apex::ModifierT< ViewDirectionSortingModifier > | [inline, virtual]
getModifierUsage() const | nvidia::apex::ModifierT< ViewDirectionSortingModifier > | [inline, virtual]
ModifierType | nvidia::apex::ViewDirectionSortingModifier | [static]
ModifierUsage | nvidia::apex::ViewDirectionSortingModifier | [static]
~Modifier() | nvidia::apex::Modifier | [inline, virtual]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
IofxActor.h [code]
IofxAsset.h [code]
IofxRenderable.h [code]
IofxRenderCallback.h [code]
Modifier.h [code]
ModifierDefs.h [code]
ModuleIofx.h [code]
RenderVolume.h [code]
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • acquireRenderableReference() : nvidia::apex::IofxActor
  • activeObjectCount : nvidia::apex::IofxSharedRenderData
  • addDependentActor() : nvidia::apex::IofxAsset
  • addIofxAsset() : nvidia::apex::RenderVolume
  • affectsIofxAsset() : nvidia::apex::RenderVolume
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • LIFE_REMAIN : nvidia::apex::IofxRenderSemantic
  • LIFE_REMAIN_FLOAT1 : nvidia::apex::IofxSpriteRenderLayoutElement
  • lockIofxActorList() : nvidia::apex::RenderVolume
  • LONG_X : nvidia::apex::ApexMeshParticleRollType
  • LONG_Y : nvidia::apex::ApexMeshParticleRollType
  • LONG_Z : nvidia::apex::ApexMeshParticleRollType
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • MAX_COUNT
: nvidia::apex::IofxSpriteRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::IofxMeshRenderLayoutElement
  • MAX_SURFACE_COUNT : nvidia::apex::IofxSpriteRenderLayout
  • maxObjectCount : nvidia::apex::IofxSharedRenderData
  • MESH : nvidia::apex::IofxRenderable
  • meshRenderBuffer : nvidia::apex::IofxMeshSharedRenderData
  • meshRenderLayout : nvidia::apex::IofxMeshSharedRenderData
  • ModifierType
: nvidia::apex::OrientAlongVelocityModifier
, nvidia::apex::ScaleAlongVelocityModifier
, nvidia::apex::RotationModifier
, nvidia::apex::RandomSubtextureModifier
, nvidia::apex::RandomRotationModifier
, nvidia::apex::SimpleScaleModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleByMassModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::ViewDirectionSortingModifier
, nvidia::apex::RandomScaleModifier
, nvidia::apex::ColorVsVelocityModifier
, nvidia::apex::OrientScaleAlongScreenVelocityModifier
, nvidia::apex::RotationRateModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::SubtextureVsLifeModifier
  • ModifierUsage
: nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::RandomRotationModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::RotationRateModifier
, nvidia::apex::ColorVsVelocityModifier
, nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ViewDirectionSortingModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::RotationModifier
, nvidia::apex::RandomScaleModifier
, nvidia::apex::SubtextureVsLifeModifier
, nvidia::apex::RandomSubtextureModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::OrientScaleAlongScreenVelocityModifier
, nvidia::apex::ScaleByMassModifier
, nvidia::apex::ScaleAlongVelocityModifier
, nvidia::apex::OrientAlongVelocityModifier
, nvidia::apex::SimpleScaleModifier
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- n -

  • NUM_SEMANTICS : nvidia::apex::IofxRenderSemantic
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • objectCount : nvidia::apex::IofxCommonRenderData
  • offsets : nvidia::apex::IofxSpriteRenderLayout , nvidia::apex::IofxMeshRenderLayout
  • onCreatedIofxRenderable() : nvidia::apex::IofxRenderCallback
  • onReleasingIofxRenderable() : nvidia::apex::IofxRenderCallback
  • onUpdatedIofxRenderable() : nvidia::apex::IofxRenderCallback
  • ORIENTATION : nvidia::apex::IofxRenderSemantic
  • ORIENTATION_FLOAT1 : nvidia::apex::IofxSpriteRenderLayoutElement
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~IofxRenderable() : nvidia::apex::IofxRenderable
  • ~Modifier() : nvidia::apex::Modifier
  • ~ModuleIofx() : nvidia::apex::ModuleIofx
  • ~RenderVolume() : nvidia::apex::RenderVolume
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • bufferDesc : nvidia::apex::IofxSpriteRenderLayout , nvidia::apex::IofxMeshRenderLayout
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • COLOR : nvidia::apex::IofxRenderSemantic
  • COLOR_BGRA8
: nvidia::apex::IofxSpriteRenderLayoutElement
, nvidia::apex::IofxMeshRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
  • COLOR_FLOAT4
: nvidia::apex::IofxSpriteRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::IofxMeshRenderLayoutElement
  • COLOR_RGBA8
: nvidia::apex::IofxSpriteRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::IofxMeshRenderLayoutElement
  • COUNT : nvidia::apex::ApexMeshParticleRollType
  • createIofxRenderableIterator() : nvidia::apex::ModuleIofx
  • createRenderVolume() : nvidia::apex::ModuleIofx
  • CUBIC : nvidia::apex::ApexMeshParticleRollType
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • DENSITY : nvidia::apex::IofxRenderSemantic
  • DENSITY_FLOAT1 : nvidia::apex::IofxSpriteRenderLayoutElement , nvidia::apex::IofxMeshRenderLayoutElement
  • disableCudaInterop() : nvidia::apex::ModuleIofx
  • disableCudaModifiers() : nvidia::apex::ModuleIofx
  • disableDeferredRenderableAllocation() : nvidia::apex::ModuleIofx
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • Enum
: nvidia::apex::IofxRenderSemantic
, nvidia::apex::ApexMeshParticleRollType
, nvidia::apex::IofxMeshRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::IofxSpriteRenderLayoutElement
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • FLAT_X : nvidia::apex::ApexMeshParticleRollType
  • FLAT_Y : nvidia::apex::ApexMeshParticleRollType
  • FLAT_Z : nvidia::apex::ApexMeshParticleRollType
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • getAffectsAllIofx() : nvidia::apex::RenderVolume
  • getBounds()
: nvidia::apex::IofxActor
, nvidia::apex::RenderVolume
, nvidia::apex::IofxRenderable
  • getColorChannel()
: nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::ColorVsVelocityModifier
  • getContinuousModifiers() : nvidia::apex::IofxAsset
  • getFirst() : nvidia::apex::IofxRenderableIterator
  • getFormat()
: nvidia::apex::IofxSpriteRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::IofxMeshRenderLayoutElement
  • getFunction()
: nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::ColorVsVelocityModifier
, nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::SubtextureVsLifeModifier
  • getIofxAssetList() : nvidia::apex::RenderVolume
  • getIofxMeshRenderLayout() : nvidia::apex::IofxRenderCallback
  • getIofxRenderCallback() : nvidia::apex::ModuleIofx
  • getIofxSpriteRenderLayout() : nvidia::apex::IofxRenderCallback
  • getIosAssetName() : nvidia::apex::IofxActor
  • getMaxRotationRate() : nvidia::apex::RotationModifier
  • getMaxSettleRate() : nvidia::apex::RotationModifier
  • getMeshAssetCount() : nvidia::apex::IofxAsset
  • getMeshAssetName() : nvidia::apex::IofxAsset
  • getMeshAssetWeight() : nvidia::apex::IofxAsset
  • getMeshRenderData() : nvidia::apex::IofxRenderable
  • getModelForward() : nvidia::apex::OrientAlongVelocityModifier
  • getModifierMeshSemantics() : nvidia::apex::Modifier
  • getModifierSpriteSemantics() : nvidia::apex::Modifier
  • getModifierType()
: nvidia::apex::Modifier
, nvidia::apex::ModifierT< T >
  • getModifierUsage()
: nvidia::apex::Modifier
, nvidia::apex::ModifierT< T >
  • getNext() : nvidia::apex::IofxRenderableIterator
  • getObjectCount() : nvidia::apex::IofxActor
  • getObjectRadius() : nvidia::apex::IofxActor
  • getOwnershipBounds() : nvidia::apex::RenderVolume
  • getPosition() : nvidia::apex::RenderVolume
  • getPriority() : nvidia::apex::RenderVolume
  • getRollType() : nvidia::apex::RotationModifier
  • getRotationRange() : nvidia::apex::RandomRotationModifier
  • getRotationRate() : nvidia::apex::RotationRateModifier
  • getScaleAxis()
: nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::ScaleVsDensityModifier
  • getScaleChangeDelay() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • getScaleChangeLimit() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • getScaleFactor()
: nvidia::apex::SimpleScaleModifier
, nvidia::apex::RandomScaleModifier
, nvidia::apex::ScaleAlongVelocityModifier
  • getScalePerVelocity() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • getScaleUpperBound() : nvidia::apex::IofxAsset
  • getSpawnModifiers() : nvidia::apex::IofxAsset
  • getSpriteMaterialName() : nvidia::apex::IofxAsset
  • getSpriteRenderData() : nvidia::apex::IofxRenderable
  • getSubtextureRange() : nvidia::apex::RandomSubtextureModifier
  • getTestBase() : nvidia::apex::ModuleIofx
  • getType() : nvidia::apex::IofxRenderable
  • getVelocity0() : nvidia::apex::ColorVsVelocityModifier
  • getVelocity1() : nvidia::apex::ColorVsVelocityModifier
  • getVisibleCount() : nvidia::apex::IofxActor
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • IofxMeshRenderLayout() : nvidia::apex::IofxMeshRenderLayout
  • IofxSpriteRenderLayout() : nvidia::apex::IofxSpriteRenderLayout
  • isTheSameAs()
: nvidia::apex::IofxMeshRenderLayout
, nvidia::apex::IofxSpriteRenderLayout
  • isValid()
: nvidia::apex::IofxMeshRenderLayout
, nvidia::apex::IofxSpriteRenderLayout
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • POSE_FLOAT3x4 : nvidia::apex::IofxMeshRenderLayoutElement
  • POSITION : nvidia::apex::IofxRenderSemantic
  • POSITION_FLOAT3 : nvidia::apex::IofxMeshRenderLayoutElement , nvidia::apex::IofxSpriteRenderLayoutElement
  • POSITION_FLOAT4 : nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
  • prepareRenderables() : nvidia::apex::ModuleIofx
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • releaseRenderVolume() : nvidia::apex::ModuleIofx
  • renderResource : nvidia::apex::IofxCommonRenderData
  • renderResourceName : nvidia::apex::IofxCommonRenderData
  • renderResourceNameSpace : nvidia::apex::IofxCommonRenderData
  • ROTATION : nvidia::apex::IofxRenderSemantic
  • ROTATION_SCALE_FLOAT3x3 : nvidia::apex::IofxMeshRenderLayoutElement
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • SCALE : nvidia::apex::IofxRenderSemantic
  • SCALE_FLOAT2 : nvidia::apex::IofxSpriteRenderLayoutElement
  • SCALE_ORIENT_SUBTEX_FLOAT4 : nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
  • setColorChannel()
: nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::ColorVsVelocityModifier
  • setDefaults()
: nvidia::apex::IofxMeshRenderLayout
, nvidia::apex::IofxSpriteRenderLayout
  • setFunction()
: nvidia::apex::ColorVsVelocityModifier
, nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::SubtextureVsLifeModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::RotationRateVsLifeModifier
  • setIofxRenderCallback() : nvidia::apex::ModuleIofx
  • setMaxRotationRate() : nvidia::apex::RotationModifier
  • setMaxSettleRate() : nvidia::apex::RotationModifier
  • setModelForward() : nvidia::apex::OrientAlongVelocityModifier
  • setOwnershipBounds() : nvidia::apex::RenderVolume
  • setPosition() : nvidia::apex::RenderVolume
  • setRollType() : nvidia::apex::RotationModifier
  • setRotationRange() : nvidia::apex::RandomRotationModifier
  • setRotationRate() : nvidia::apex::RotationRateModifier
  • setScaleAxis()
: nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
  • setScaleChangeDelay() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • setScaleChangeLimit() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • setScaleFactor()
: nvidia::apex::RandomScaleModifier
, nvidia::apex::ScaleAlongVelocityModifier
, nvidia::apex::SimpleScaleModifier
  • setScalePerVelocity() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • setSubtextureRange() : nvidia::apex::RandomSubtextureModifier
  • setVelocity0() : nvidia::apex::ColorVsVelocityModifier
  • setVelocity1() : nvidia::apex::ColorVsVelocityModifier
  • sharedRenderData : nvidia::apex::IofxSpriteRenderData , nvidia::apex::IofxMeshRenderData
  • SPHERICAL : nvidia::apex::ApexMeshParticleRollType
  • SPRITE : nvidia::apex::ApexMeshParticleRollType , nvidia::apex::IofxRenderable
  • spriteRenderBuffer : nvidia::apex::IofxSpriteSharedRenderData
  • spriteRenderLayout : nvidia::apex::IofxSpriteSharedRenderData
  • spriteRenderSurfaces : nvidia::apex::IofxSpriteSharedRenderData
  • startIndex : nvidia::apex::IofxCommonRenderData
  • stride : nvidia::apex::IofxMeshRenderLayout , nvidia::apex::IofxSpriteRenderLayout
  • SUBTEXTURE : nvidia::apex::IofxRenderSemantic
  • SUBTEXTURE_FLOAT1 : nvidia::apex::IofxSpriteRenderLayoutElement
  • surfaceCount : nvidia::apex::IofxSpriteRenderLayout
  • surfaceDescs : nvidia::apex::IofxSpriteRenderLayout
  • surfaceElements : nvidia::apex::IofxSpriteRenderLayout
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • Type : nvidia::apex::IofxRenderable
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • unlockIofxActorList() : nvidia::apex::RenderVolume
  • USER_DATA : nvidia::apex::IofxRenderSemantic
  • USER_DATA_UINT1 : nvidia::apex::IofxSpriteRenderLayoutElement , nvidia::apex::IofxMeshRenderLayoutElement
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- v -

  • VELOCITY : nvidia::apex::IofxRenderSemantic
  • VELOCITY_FLOAT3 : nvidia::apex::IofxSpriteRenderLayoutElement
  • VELOCITY_LIFE_FLOAT4 : nvidia::apex::IofxMeshRenderLayoutElement
  • visibleCount : nvidia::apex::IofxSpriteRenderData
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members - Enumerations

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Enum
: nvidia::apex::IofxRenderSemantic
, nvidia::apex::ApexMeshParticleRollType
, nvidia::apex::IofxMeshRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::IofxSpriteRenderLayoutElement
  • Type : nvidia::apex::IofxRenderable
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members - Enumerator

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • c
  • d
  • f
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • v

- c -

  • COLOR : nvidia::apex::IofxRenderSemantic
  • COLOR_BGRA8
: nvidia::apex::IofxSpriteRenderLayoutElement
, nvidia::apex::IofxMeshRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
  • COLOR_FLOAT4
: nvidia::apex::IofxSpriteRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::IofxMeshRenderLayoutElement
  • COLOR_RGBA8
: nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::IofxMeshRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutElement
  • COUNT : nvidia::apex::ApexMeshParticleRollType
  • CUBIC : nvidia::apex::ApexMeshParticleRollType

- d -

  • DENSITY : nvidia::apex::IofxRenderSemantic
  • DENSITY_FLOAT1 : nvidia::apex::IofxMeshRenderLayoutElement , nvidia::apex::IofxSpriteRenderLayoutElement

- f -

  • FLAT_X : nvidia::apex::ApexMeshParticleRollType
  • FLAT_Y : nvidia::apex::ApexMeshParticleRollType
  • FLAT_Z : nvidia::apex::ApexMeshParticleRollType

- l -

  • LIFE_REMAIN : nvidia::apex::IofxRenderSemantic
  • LIFE_REMAIN_FLOAT1 : nvidia::apex::IofxSpriteRenderLayoutElement
  • LONG_X : nvidia::apex::ApexMeshParticleRollType
  • LONG_Y : nvidia::apex::ApexMeshParticleRollType
  • LONG_Z : nvidia::apex::ApexMeshParticleRollType

- m -

  • MAX_COUNT
: nvidia::apex::IofxSpriteRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::IofxMeshRenderLayoutElement
  • MESH : nvidia::apex::IofxRenderable

- n -

  • NUM_SEMANTICS : nvidia::apex::IofxRenderSemantic

- o -

  • ORIENTATION : nvidia::apex::IofxRenderSemantic
  • ORIENTATION_FLOAT1 : nvidia::apex::IofxSpriteRenderLayoutElement

- p -

  • POSE_FLOAT3x4 : nvidia::apex::IofxMeshRenderLayoutElement
  • POSITION : nvidia::apex::IofxRenderSemantic
  • POSITION_FLOAT3 : nvidia::apex::IofxMeshRenderLayoutElement , nvidia::apex::IofxSpriteRenderLayoutElement
  • POSITION_FLOAT4 : nvidia::apex::IofxSpriteRenderLayoutSurfaceElement

- r -

  • ROTATION : nvidia::apex::IofxRenderSemantic
  • ROTATION_SCALE_FLOAT3x3 : nvidia::apex::IofxMeshRenderLayoutElement

- s -

  • SCALE : nvidia::apex::IofxRenderSemantic
  • SCALE_FLOAT2 : nvidia::apex::IofxSpriteRenderLayoutElement
  • SCALE_ORIENT_SUBTEX_FLOAT4 : nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
  • SPHERICAL : nvidia::apex::ApexMeshParticleRollType
  • SPRITE : nvidia::apex::IofxRenderable , nvidia::apex::ApexMeshParticleRollType
  • SUBTEXTURE : nvidia::apex::IofxRenderSemantic
  • SUBTEXTURE_FLOAT1 : nvidia::apex::IofxSpriteRenderLayoutElement

- u -

  • USER_DATA : nvidia::apex::IofxRenderSemantic
  • USER_DATA_UINT1 : nvidia::apex::IofxMeshRenderLayoutElement , nvidia::apex::IofxSpriteRenderLayoutElement

- v -

  • VELOCITY : nvidia::apex::IofxRenderSemantic
  • VELOCITY_FLOAT3 : nvidia::apex::IofxSpriteRenderLayoutElement
  • VELOCITY_LIFE_FLOAT4 : nvidia::apex::IofxMeshRenderLayoutElement
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members - Functions

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • g
  • i
  • l
  • o
  • p
  • r
  • s
  • u
  • ~

- a -

  • acquireRenderableReference() : nvidia::apex::IofxActor
  • addDependentActor() : nvidia::apex::IofxAsset
  • addIofxAsset() : nvidia::apex::RenderVolume
  • affectsIofxAsset() : nvidia::apex::RenderVolume

- c -

  • createIofxRenderableIterator() : nvidia::apex::ModuleIofx
  • createRenderVolume() : nvidia::apex::ModuleIofx

- d -

  • disableCudaInterop() : nvidia::apex::ModuleIofx
  • disableCudaModifiers() : nvidia::apex::ModuleIofx
  • disableDeferredRenderableAllocation() : nvidia::apex::ModuleIofx

- g -

  • getAffectsAllIofx() : nvidia::apex::RenderVolume
  • getBounds()
: nvidia::apex::IofxActor
, nvidia::apex::RenderVolume
, nvidia::apex::IofxRenderable
  • getColorChannel()
: nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::ColorVsVelocityModifier
  • getContinuousModifiers() : nvidia::apex::IofxAsset
  • getFirst() : nvidia::apex::IofxRenderableIterator
  • getFormat()
: nvidia::apex::IofxSpriteRenderLayoutElement
, nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
, nvidia::apex::IofxMeshRenderLayoutElement
  • getFunction()
: nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::ColorVsVelocityModifier
, nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::SubtextureVsLifeModifier
  • getIofxAssetList() : nvidia::apex::RenderVolume
  • getIofxMeshRenderLayout() : nvidia::apex::IofxRenderCallback
  • getIofxRenderCallback() : nvidia::apex::ModuleIofx
  • getIofxSpriteRenderLayout() : nvidia::apex::IofxRenderCallback
  • getIosAssetName() : nvidia::apex::IofxActor
  • getMaxRotationRate() : nvidia::apex::RotationModifier
  • getMaxSettleRate() : nvidia::apex::RotationModifier
  • getMeshAssetCount() : nvidia::apex::IofxAsset
  • getMeshAssetName() : nvidia::apex::IofxAsset
  • getMeshAssetWeight() : nvidia::apex::IofxAsset
  • getMeshRenderData() : nvidia::apex::IofxRenderable
  • getModelForward() : nvidia::apex::OrientAlongVelocityModifier
  • getModifierMeshSemantics() : nvidia::apex::Modifier
  • getModifierSpriteSemantics() : nvidia::apex::Modifier
  • getModifierType()
: nvidia::apex::Modifier
, nvidia::apex::ModifierT< T >
  • getModifierUsage()
: nvidia::apex::Modifier
, nvidia::apex::ModifierT< T >
  • getNext() : nvidia::apex::IofxRenderableIterator
  • getObjectCount() : nvidia::apex::IofxActor
  • getObjectRadius() : nvidia::apex::IofxActor
  • getOwnershipBounds() : nvidia::apex::RenderVolume
  • getPosition() : nvidia::apex::RenderVolume
  • getPriority() : nvidia::apex::RenderVolume
  • getRollType() : nvidia::apex::RotationModifier
  • getRotationRange() : nvidia::apex::RandomRotationModifier
  • getRotationRate() : nvidia::apex::RotationRateModifier
  • getScaleAxis()
: nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::ScaleVsDensityModifier
  • getScaleChangeDelay() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • getScaleChangeLimit() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • getScaleFactor()
: nvidia::apex::SimpleScaleModifier
, nvidia::apex::RandomScaleModifier
, nvidia::apex::ScaleAlongVelocityModifier
  • getScalePerVelocity() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • getScaleUpperBound() : nvidia::apex::IofxAsset
  • getSpawnModifiers() : nvidia::apex::IofxAsset
  • getSpriteMaterialName() : nvidia::apex::IofxAsset
  • getSpriteRenderData() : nvidia::apex::IofxRenderable
  • getSubtextureRange() : nvidia::apex::RandomSubtextureModifier
  • getTestBase() : nvidia::apex::ModuleIofx
  • getType() : nvidia::apex::IofxRenderable
  • getVelocity0() : nvidia::apex::ColorVsVelocityModifier
  • getVelocity1() : nvidia::apex::ColorVsVelocityModifier
  • getVisibleCount() : nvidia::apex::IofxActor

- i -

  • IofxMeshRenderLayout() : nvidia::apex::IofxMeshRenderLayout
  • IofxSpriteRenderLayout() : nvidia::apex::IofxSpriteRenderLayout
  • isTheSameAs()
: nvidia::apex::IofxMeshRenderLayout
, nvidia::apex::IofxSpriteRenderLayout
  • isValid()
: nvidia::apex::IofxMeshRenderLayout
, nvidia::apex::IofxSpriteRenderLayout

- l -

  • lockIofxActorList() : nvidia::apex::RenderVolume

- o -

  • onCreatedIofxRenderable() : nvidia::apex::IofxRenderCallback
  • onReleasingIofxRenderable() : nvidia::apex::IofxRenderCallback
  • onUpdatedIofxRenderable() : nvidia::apex::IofxRenderCallback

- p -

  • prepareRenderables() : nvidia::apex::ModuleIofx

- r -

  • releaseRenderVolume() : nvidia::apex::ModuleIofx

- s -

  • setColorChannel()
: nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::ColorVsVelocityModifier
  • setDefaults()
: nvidia::apex::IofxSpriteRenderLayout
, nvidia::apex::IofxMeshRenderLayout
  • setFunction()
: nvidia::apex::SubtextureVsLifeModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::ColorVsLifeModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::ColorVsVelocityModifier
, nvidia::apex::ColorVsDensityModifier
  • setIofxRenderCallback() : nvidia::apex::ModuleIofx
  • setMaxRotationRate() : nvidia::apex::RotationModifier
  • setMaxSettleRate() : nvidia::apex::RotationModifier
  • setModelForward() : nvidia::apex::OrientAlongVelocityModifier
  • setOwnershipBounds() : nvidia::apex::RenderVolume
  • setPosition() : nvidia::apex::RenderVolume
  • setRollType() : nvidia::apex::RotationModifier
  • setRotationRange() : nvidia::apex::RandomRotationModifier
  • setRotationRate() : nvidia::apex::RotationRateModifier
  • setScaleAxis()
: nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ScaleVsLifeModifier
  • setScaleChangeDelay() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • setScaleChangeLimit() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • setScaleFactor()
: nvidia::apex::ScaleAlongVelocityModifier
, nvidia::apex::RandomScaleModifier
, nvidia::apex::SimpleScaleModifier
  • setScalePerVelocity() : nvidia::apex::OrientScaleAlongScreenVelocityModifier
  • setSubtextureRange() : nvidia::apex::RandomSubtextureModifier
  • setVelocity0() : nvidia::apex::ColorVsVelocityModifier
  • setVelocity1() : nvidia::apex::ColorVsVelocityModifier

- u -

  • unlockIofxActorList() : nvidia::apex::RenderVolume

- ~ -

  • ~IofxRenderable() : nvidia::apex::IofxRenderable
  • ~Modifier() : nvidia::apex::Modifier
  • ~ModuleIofx() : nvidia::apex::ModuleIofx
  • ~RenderVolume() : nvidia::apex::RenderVolume
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Class Members - Variables

  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • m
  • o
  • r
  • s
  • v

- a -

  • activeObjectCount : nvidia::apex::IofxSharedRenderData

- b -

  • bufferDesc : nvidia::apex::IofxSpriteRenderLayout , nvidia::apex::IofxMeshRenderLayout

- m -

  • MAX_SURFACE_COUNT : nvidia::apex::IofxSpriteRenderLayout
  • maxObjectCount : nvidia::apex::IofxSharedRenderData
  • meshRenderBuffer : nvidia::apex::IofxMeshSharedRenderData
  • meshRenderLayout : nvidia::apex::IofxMeshSharedRenderData
  • ModifierType
: nvidia::apex::RandomScaleModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::ViewDirectionSortingModifier
, nvidia::apex::RotationModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::RotationRateModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::SubtextureVsLifeModifier
, nvidia::apex::OrientScaleAlongScreenVelocityModifier
, nvidia::apex::ColorVsVelocityModifier
, nvidia::apex::SimpleScaleModifier
, nvidia::apex::OrientAlongVelocityModifier
, nvidia::apex::ScaleAlongVelocityModifier
, nvidia::apex::ScaleByMassModifier
, nvidia::apex::RandomSubtextureModifier
, nvidia::apex::RandomRotationModifier
  • ModifierUsage
: nvidia::apex::RandomRotationModifier
, nvidia::apex::ScaleVsCameraDistanceModifier
, nvidia::apex::ViewDirectionSortingModifier
, nvidia::apex::RotationRateVsLifeModifier
, nvidia::apex::ColorVsVelocityModifier
, nvidia::apex::SubtextureVsLifeModifier
, nvidia::apex::RotationModifier
, nvidia::apex::ScaleByMassModifier
, nvidia::apex::OrientScaleAlongScreenVelocityModifier
, nvidia::apex::ColorVsDensityModifier
, nvidia::apex::ScaleAlongVelocityModifier
, nvidia::apex::ScaleVsDensityModifier
, nvidia::apex::RotationRateModifier
, nvidia::apex::OrientAlongVelocityModifier
, nvidia::apex::SimpleScaleModifier
, nvidia::apex::ColorVsLifeModifier
, nvidia::apex::ScaleVsLifeModifier
, nvidia::apex::RandomSubtextureModifier
, nvidia::apex::RandomScaleModifier

- o -

  • objectCount : nvidia::apex::IofxCommonRenderData
  • offsets : nvidia::apex::IofxMeshRenderLayout , nvidia::apex::IofxSpriteRenderLayout

- r -

  • renderResource : nvidia::apex::IofxCommonRenderData
  • renderResourceName : nvidia::apex::IofxCommonRenderData
  • renderResourceNameSpace : nvidia::apex::IofxCommonRenderData

- s -

  • sharedRenderData : nvidia::apex::IofxSpriteRenderData , nvidia::apex::IofxMeshRenderData
  • spriteRenderBuffer : nvidia::apex::IofxSpriteSharedRenderData
  • spriteRenderLayout : nvidia::apex::IofxSpriteSharedRenderData
  • spriteRenderSurfaces : nvidia::apex::IofxSpriteSharedRenderData
  • startIndex : nvidia::apex::IofxCommonRenderData
  • stride : nvidia::apex::IofxMeshRenderLayout , nvidia::apex::IofxSpriteRenderLayout
  • surfaceCount : nvidia::apex::IofxSpriteRenderLayout
  • surfaceDescs : nvidia::apex::IofxSpriteRenderLayout
  • surfaceElements : nvidia::apex::IofxSpriteRenderLayout

- v -

  • visibleCount : nvidia::apex::IofxSpriteRenderData
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: File Members

  • File List
  • File Members
  • All
  • Defines
Here is a list of all file members with links to the files they belong to:
  • IOFX_AUTHORING_TYPE_NAME : IofxAsset.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: File Members

  • File List
  • File Members
  • All
  • Defines
  • IOFX_AUTHORING_TYPE_NAME : IofxAsset.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Class Hierarchy

  • Class List
  • Class Hierarchy
  • Class Members
Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
  • nvidia::apex::ApexMeshParticleRollType
  • nvidia::apex::IofxActor
  • nvidia::apex::IofxAsset
  • nvidia::apex::IofxAssetAuthoring
  • nvidia::apex::IofxCommonRenderData
    • nvidia::apex::IofxMeshRenderData
    • nvidia::apex::IofxSpriteRenderData
  • nvidia::apex::IofxMeshRenderLayout
  • nvidia::apex::IofxMeshRenderLayoutElement
  • nvidia::apex::IofxRenderable
  • nvidia::apex::IofxRenderableIterator
  • nvidia::apex::IofxRenderCallback
  • nvidia::apex::IofxRenderSemantic
  • nvidia::apex::IofxSharedRenderData
    • nvidia::apex::IofxMeshSharedRenderData
    • nvidia::apex::IofxSpriteSharedRenderData
  • nvidia::apex::IofxSpriteRenderLayout
  • nvidia::apex::IofxSpriteRenderLayoutElement
  • nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
  • nvidia::apex::Modifier
    • nvidia::apex::ModifierT< ColorVsDensityModifier >
      • nvidia::apex::ColorVsDensityModifier
    • nvidia::apex::ModifierT< ColorVsLifeModifier >
      • nvidia::apex::ColorVsLifeModifier
    • nvidia::apex::ModifierT< ColorVsVelocityModifier >
      • nvidia::apex::ColorVsVelocityModifier
    • nvidia::apex::ModifierT< OrientAlongVelocityModifier >
      • nvidia::apex::OrientAlongVelocityModifier
    • nvidia::apex::ModifierT< OrientScaleAlongScreenVelocityModifier >
      • nvidia::apex::OrientScaleAlongScreenVelocityModifier
    • nvidia::apex::ModifierT< RandomRotationModifier >
      • nvidia::apex::RandomRotationModifier
    • nvidia::apex::ModifierT< RandomScaleModifier >
      • nvidia::apex::RandomScaleModifier
    • nvidia::apex::ModifierT< RandomSubtextureModifier >
      • nvidia::apex::RandomSubtextureModifier
    • nvidia::apex::ModifierT< RotationModifier >
      • nvidia::apex::RotationModifier
    • nvidia::apex::ModifierT< RotationRateModifier >
      • nvidia::apex::RotationRateModifier
    • nvidia::apex::ModifierT< RotationRateVsLifeModifier >
      • nvidia::apex::RotationRateVsLifeModifier
    • nvidia::apex::ModifierT< ScaleAlongVelocityModifier >
      • nvidia::apex::ScaleAlongVelocityModifier
    • nvidia::apex::ModifierT< ScaleByMassModifier >
      • nvidia::apex::ScaleByMassModifier
    • nvidia::apex::ModifierT< ScaleVsCameraDistanceModifier >
      • nvidia::apex::ScaleVsCameraDistanceModifier
    • nvidia::apex::ModifierT< ScaleVsDensityModifier >
      • nvidia::apex::ScaleVsDensityModifier
    • nvidia::apex::ModifierT< ScaleVsLifeModifier >
      • nvidia::apex::ScaleVsLifeModifier
    • nvidia::apex::ModifierT< SimpleScaleModifier >
      • nvidia::apex::SimpleScaleModifier
    • nvidia::apex::ModifierT< SubtextureVsLifeModifier >
      • nvidia::apex::SubtextureVsLifeModifier
    • nvidia::apex::ModifierT< ViewDirectionSortingModifier >
      • nvidia::apex::ViewDirectionSortingModifier
    • nvidia::apex::ModifierT< T >
  • nvidia::apex::ModuleIofx
  • nvidia::apex::RenderVolume
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Main Page

APEX IOFX Module Documentation
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: IofxActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
IofxActor.h File Reference
#include "Apex.h"
#include "IofxAsset.h"
#include "IofxRenderable.h"

Go to the source code of this file.

Classes

class | nvidia::apex::IofxActor
IOFX actor public interface. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: IofxActor.h Source File

  • File List
  • File Members
IofxActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IOFX_ACTOR_H
00031 #define IOFX_ACTOR_H
00032
00033 #include "Apex.h"
00034 #include "IofxAsset.h"
00035 #include "IofxRenderable.h"
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00042 PX_PUSH_PACK_DEFAULT
00043
00047 class IofxActor : public Actor
00048 {
00049 public:
00051     virtual float               getObjectRadius() const = 0;
00052
00054     virtual uint32_t            getObjectCount() const = 0;
00055
00057     virtual uint32_t            getVisibleCount() const = 0;
00058
00060     virtual const char*         getIosAssetName() const = 0;
00061
00063     virtual physx::PxBounds3    getBounds() const = 0;
00064
00071     virtual IofxRenderable*     acquireRenderableReference() = 0;
00072 };
00073
00074 PX_POP_PACK
00075
00076 }
00077 } // namespace nvidia
00078
00079 #endif // IOFX_ACTOR_H
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: IofxAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
IofxAsset.h File Reference
#include "Apex.h"
#include "ModifierDefs.h"

Go to the source code of this file.

Classes

class | nvidia::apex::IofxAsset
IOFX Asset public interface. Used to define the way the visual parameters are created from physical parameters of a particle. More...
class | nvidia::apex::IofxAssetAuthoring
IOFX Asset Authoring public interface. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | IOFX_AUTHORING_TYPE_NAME "IOFX"

Define Documentation

#define IOFX_AUTHORING_TYPE_NAME "IOFX"
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: IofxAsset.h Source File

  • File List
  • File Members
IofxAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IOFX_ASSET_H
00031 #define IOFX_ASSET_H
00032
00033 #include "Apex.h"
00034 #include "ModifierDefs.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define IOFX_AUTHORING_TYPE_NAME "IOFX"
00044
00045 class Modifier;
00046 class ApexActor;
00047
00052 class IofxAsset : public Asset, public Context
00053 {
00054 public:
00056     virtual const char*                     getSpriteMaterialName() const = 0;
00057
00059     virtual uint32_t                        getMeshAssetCount() const = 0;
00060
00063     virtual const char*                     getMeshAssetName(uint32_t index = 0) const = 0;
00064
00067     virtual uint32_t                        getMeshAssetWeight(uint32_t index = 0) const = 0;
00068
00070     virtual const Modifier*                 getSpawnModifiers(uint32_t& outCount) const = 0;
00071
00073     virtual const Modifier*                 getContinuousModifiers(uint32_t& outCount) const = 0;
00074
00078     virtual float                           getScaleUpperBound(float maxVelocity) const = 0;
00079
00082     virtual void                            addDependentActor(ApexActor* actor) = 0;
00083 };
00084
00088 class IofxAssetAuthoring : public AssetAuthoring
00089 {
00090 };
00091
00092 PX_POP_PACK
00093
00094 }
00095 } // namespace nvidia
00096
00097 #endif // IOFX_ASSET_H
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: IofxRenderable.h File Reference

  • File List
  • File Members
Classes | Namespaces
IofxRenderable.h File Reference
#include "foundation/Px.h"
#include "ApexInterface.h"
#include "Renderable.h"
#include "IofxRenderCallback.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::IofxSharedRenderData
IofxSharedRenderData stores common render data shared by several IOFX Renderables. More...
struct | nvidia::apex::IofxSpriteSharedRenderData
IofxSpriteSharedRenderData stores sprite render data shared by several IOFX Renderables. More...
struct | nvidia::apex::IofxMeshSharedRenderData
IofxMeshSharedRenderData stores mesh render data shared by several IOFX Renderables. More...
struct | nvidia::apex::IofxCommonRenderData
IofxCommonRenderData stores common render data for one IOFX Renderable. More...
struct | nvidia::apex::IofxSpriteRenderData
IofxSpriteRenderData stores sprite render data for one IOFX Renderable. More...
struct | nvidia::apex::IofxMeshRenderData
IofxMeshRenderData stores mesh render data for one IOFX Renderable. More...
class | nvidia::apex::IofxRenderable
The IOFX renderable represents a unit of rendering. It contains complete information to render a batch of particles with the same material/mesh in the same render volume. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: IofxRenderable.h Source File

  • File List
  • File Members
IofxRenderable.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IOFX_RENDERABLE_H
00031 #define IOFX_RENDERABLE_H
00032
00033 #include "foundation/Px.h"
00034 #include "ApexInterface.h"
00035 #include "Renderable.h"
00036 #include "IofxRenderCallback.h"
00037
00038 namespace nvidia
00039 {
00040 namespace apex
00041 {
00042
00043 PX_PUSH_PACK_DEFAULT
00044
00048 struct IofxSharedRenderData
00049 {
00050     uint32_t    maxObjectCount;
00051     uint32_t    activeObjectCount;
00052 };
00053
00057 struct IofxSpriteSharedRenderData : IofxSharedRenderData
00058 {
00059     IofxSpriteRenderLayout  spriteRenderLayout;
00060     UserRenderBuffer*           spriteRenderBuffer;
00061     UserRenderSurface*      spriteRenderSurfaces[IofxSpriteRenderLayout::MAX_SURFACE_COUNT];
00062 };
00063
00067 struct IofxMeshSharedRenderData : IofxSharedRenderData
00068 {
00069     IofxMeshRenderLayout        meshRenderLayout;
00070     UserRenderBuffer*           meshRenderBuffer;
00071 };
00072
00076 struct IofxCommonRenderData
00077 {
00078     uint32_t        startIndex;
00079     uint32_t        objectCount;
00080
00081     const char*     renderResourceNameSpace;
00082     const char*     renderResourceName;
00083     void*           renderResource;
00084 };
00085
00089 struct IofxSpriteRenderData : IofxCommonRenderData
00090 {
00091     uint32_t        visibleCount;
00092
00093     const IofxSpriteSharedRenderData* sharedRenderData;
00094 };
00095
00099 struct IofxMeshRenderData : IofxCommonRenderData
00100 {
00101     const IofxMeshSharedRenderData* sharedRenderData;
00102 };
00103
00104 class IofxSpriteRenderable;
00105 class IofxMeshRenderable;
00106
00111 class IofxRenderable : public ApexInterface
00112 {
00113 public:
00117     enum Type
00118     {
00119         SPRITE,
00120         MESH
00121     };
00122
00126     virtual Type                        getType() const = 0;
00127
00131     virtual const IofxSpriteRenderData* getSpriteRenderData() const = 0;
00132
00136     virtual const IofxMeshRenderData*   getMeshRenderData() const = 0;
00137
00141     virtual const physx::PxBounds3&     getBounds() const = 0;
00142
00143 protected:
00144     virtual ~IofxRenderable() {}
00145
00146 };
00147
00148 PX_POP_PACK
00149
00150 }
00151 } // end namespace nvidia
00152
00153 #endif // IOFX_RENDERABLE_H
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: IofxRenderCallback.h File Reference

  • File List
  • File Members
Classes | Namespaces
IofxRenderCallback.h File Reference
#include "foundation/Px.h"
#include "UserRenderCallback.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::IofxRenderSemantic
Enumerates the potential IOFX render semantics. More...
struct | nvidia::apex::IofxSpriteRenderLayoutElement
Enumerates the potential IOFX mesh render layout elements. More...
struct | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement
Enumerates the potential IOFX sprite render layout surface elements. More...
struct | nvidia::apex::IofxSpriteRenderLayout
Describes the layout for sprite rendering. More...
struct | nvidia::apex::IofxMeshRenderLayoutElement
Enumerates the potential IOFX mesh render layout elements. More...
struct | nvidia::apex::IofxMeshRenderLayout
Describes the layout for mesh rendering. More...
class | nvidia::apex::IofxRenderCallback
User defined callback for IOFX rendering. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: IofxRenderCallback.h Source File

  • File List
  • File Members
IofxRenderCallback.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef IOFX_RENDER_CALLBACK_H
00031 #define IOFX_RENDER_CALLBACK_H
00032
00033 #include "foundation/Px.h"
00034 #include "UserRenderCallback.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class IofxRenderable;
00044 class IofxSpriteRenderable;
00045 class IofxMeshRenderable;
00046
00050 struct IofxRenderSemantic
00051 {
00055     enum Enum
00056     {
00057         POSITION = 0,
00058         COLOR,
00059         VELOCITY,
00060         SCALE,
00061         LIFE_REMAIN,
00062         DENSITY,
00063         SUBTEXTURE,
00064         ORIENTATION,
00065         ROTATION,
00066         USER_DATA,
00067
00068         NUM_SEMANTICS
00069     };
00070 };
00071
00072
00076 struct IofxSpriteRenderLayoutElement
00077 {
00081     enum Enum
00082     {
00083         POSITION_FLOAT3,
00084         COLOR_RGBA8,
00085         COLOR_BGRA8,
00086         COLOR_FLOAT4,
00087         VELOCITY_FLOAT3,
00088         SCALE_FLOAT2,
00089         LIFE_REMAIN_FLOAT1,
00090         DENSITY_FLOAT1,
00091         SUBTEXTURE_FLOAT1,
00092         ORIENTATION_FLOAT1,
00093         USER_DATA_UINT1,
00094
00095         MAX_COUNT
00096     };
00097
00101     static PX_INLINE RenderDataFormat::Enum getFormat(Enum element)
00102     {
00103         switch (element)
00104         {
00105         case POSITION_FLOAT3:
00106             return RenderDataFormat::FLOAT3;
00107         case COLOR_RGBA8:
00108             return RenderDataFormat::R8G8B8A8;
00109         case COLOR_BGRA8:
00110             return RenderDataFormat::B8G8R8A8;
00111         case COLOR_FLOAT4:
00112             return RenderDataFormat::FLOAT4;
00113         case VELOCITY_FLOAT3:
00114             return RenderDataFormat::FLOAT3;
00115         case SCALE_FLOAT2:
00116             return RenderDataFormat::FLOAT2;
00117         case LIFE_REMAIN_FLOAT1:
00118             return RenderDataFormat::FLOAT1;
00119         case DENSITY_FLOAT1:
00120             return RenderDataFormat::FLOAT1;
00121         case SUBTEXTURE_FLOAT1:
00122             return RenderDataFormat::FLOAT1;
00123         case ORIENTATION_FLOAT1:
00124             return RenderDataFormat::FLOAT1;
00125         case USER_DATA_UINT1:
00126             return RenderDataFormat::UINT1;
00127         default:
00128             PX_ALWAYS_ASSERT();
00129             return RenderDataFormat::NUM_FORMATS;
00130         }
00131     }
00132 };
00133
00137 struct IofxSpriteRenderLayoutSurfaceElement
00138 {
00142     enum Enum
00143     {
00144         POSITION_FLOAT4,
00145         SCALE_ORIENT_SUBTEX_FLOAT4,
00146         COLOR_RGBA8, //<! COLOR in RGBA8 format
00147         COLOR_BGRA8, //<! COLOR in BGRA8 format
00148         COLOR_FLOAT4, //<! COLOR in FLOAT4 format
00149
00150         MAX_COUNT
00151     };
00152
00156     static PX_INLINE RenderDataFormat::Enum getFormat(Enum element)
00157     {
00158         switch (element)
00159         {
00160         case POSITION_FLOAT4:
00161             return RenderDataFormat::FLOAT4;
00162         case SCALE_ORIENT_SUBTEX_FLOAT4:
00163             return RenderDataFormat::FLOAT4;
00164         case COLOR_RGBA8:
00165             return RenderDataFormat::R8G8B8A8;
00166         case COLOR_BGRA8:
00167             return RenderDataFormat::B8G8R8A8;
00168         case COLOR_FLOAT4:
00169             return RenderDataFormat::R32G32B32A32_FLOAT;
00170         default:
00171             PX_ALWAYS_ASSERT();
00172             return RenderDataFormat::NUM_FORMATS;
00173         }
00174     }
00175 };
00176
00180 struct IofxSpriteRenderLayout
00181 {
00182     IofxSpriteRenderLayout(void)
00183     {
00184         setDefaults();
00185     }
00186
00190     void setDefaults()
00191     {
00192         bufferDesc.setDefaults();
00193         for (uint32_t i = 0; i < IofxSpriteRenderLayoutElement::MAX_COUNT; i++)
00194         {
00195             offsets[i] = uint32_t(-1);
00196         }
00197         stride = 0;
00198         surfaceCount = 0;
00199         for (uint32_t i = 0; i < MAX_SURFACE_COUNT; i++)
00200         {
00201             surfaceElements[i] = IofxSpriteRenderLayoutSurfaceElement::MAX_COUNT;
00202         }
00203     }
00204
00208     bool isValid(void) const
00209     {
00210         uint32_t numFailed = 0;
00211
00212         numFailed += (surfaceCount == 0) && !bufferDesc.isValid();
00213         numFailed += (surfaceCount == 0) && (stride == 0);
00214         numFailed += (surfaceCount == 0) && (offsets[IofxSpriteRenderLayoutElement::POSITION_FLOAT3] == uint32_t(-1));
00215
00216         numFailed += ((stride & 0x03) != 0);
00217         for (uint32_t i = 0; i < IofxSpriteRenderLayoutElement::MAX_COUNT; i++)
00218         {
00219             if (offsets[i] != static_cast<uint32_t>(-1))
00220             {
00221                 numFailed += (offsets[i] >= stride);
00222                 numFailed += ((offsets[i] & 0x03) != 0);
00223             }
00224         }
00225         for (uint32_t i= 0; i < surfaceCount; ++i)
00226         {
00227             numFailed += (surfaceElements[i] >= IofxSpriteRenderLayoutSurfaceElement::MAX_COUNT);
00228             numFailed += !surfaceDescs[i].isValid();
00229             numFailed += (surfaceDescs[i].width == 0) || (surfaceDescs[i].height == 0);
00230             numFailed += (IofxSpriteRenderLayoutSurfaceElement::getFormat(surfaceElements[i]) != surfaceDescs[i].format);
00231         }
00232
00233         return (numFailed == 0);
00234     }
00235
00239     bool isTheSameAs(const IofxSpriteRenderLayout& other) const
00240     {
00241         if (surfaceCount != other.surfaceCount) return false;
00242         if (surfaceCount == 0)
00243         {
00244             if (!bufferDesc.isTheSameAs(other.bufferDesc)) return false;
00245             if (stride != other.stride) return false;
00246             for (uint32_t i = 0; i < IofxSpriteRenderLayoutElement::MAX_COUNT; i++)
00247             {
00248                 if (offsets[i] != other.offsets[i]) return false;
00249             }
00250         }
00251         else
00252         {
00253             for (uint32_t i = 0; i < surfaceCount; ++i)
00254             {
00255                 if (surfaceElements[i] != other.surfaceElements[i]) return false;
00256                 if (!surfaceDescs[i].isTheSameAs(other.surfaceDescs[i])) return false;
00257             }
00258         }
00259         return true;
00260     }
00261
00262 public:
00263     UserRenderBufferDesc        bufferDesc;
00264
00268     uint32_t                    offsets[IofxSpriteRenderLayoutElement::MAX_COUNT];
00269     uint32_t                    stride;
00270
00271     uint32_t                    surfaceCount;
00272
00276     static const uint32_t MAX_SURFACE_COUNT = 4;
00277
00281     IofxSpriteRenderLayoutSurfaceElement::Enum  surfaceElements[MAX_SURFACE_COUNT];
00285     UserRenderSurfaceDesc                           surfaceDescs[MAX_SURFACE_COUNT];
00286 };
00287
00288
00292 struct IofxMeshRenderLayoutElement
00293 {
00297     enum Enum
00298     {
00299         POSITION_FLOAT3,
00300         ROTATION_SCALE_FLOAT3x3,
00301         POSE_FLOAT3x4,
00302         VELOCITY_LIFE_FLOAT4,
00303         DENSITY_FLOAT1,
00304         COLOR_RGBA8,
00305         COLOR_BGRA8,
00306         COLOR_FLOAT4,
00307         USER_DATA_UINT1,
00308
00309         MAX_COUNT
00310     };
00311
00315     static PX_INLINE RenderDataFormat::Enum getFormat(Enum element)
00316     {
00317         switch (element)
00318         {
00319         case POSITION_FLOAT3:
00320             return RenderDataFormat::FLOAT3;
00321         case ROTATION_SCALE_FLOAT3x3:
00322             return RenderDataFormat::FLOAT3x3;
00323         case POSE_FLOAT3x4:
00324             return RenderDataFormat::FLOAT3x4;
00325         case VELOCITY_LIFE_FLOAT4:
00326             return RenderDataFormat::FLOAT4;
00327         case DENSITY_FLOAT1:
00328             return RenderDataFormat::FLOAT1;
00329         case COLOR_RGBA8:
00330             return RenderDataFormat::R8G8B8A8;
00331         case COLOR_BGRA8:
00332             return RenderDataFormat::B8G8R8A8;
00333         case COLOR_FLOAT4:
00334             return RenderDataFormat::FLOAT4;
00335         case USER_DATA_UINT1:
00336             return RenderDataFormat::UINT1;
00337         default:
00338             PX_ALWAYS_ASSERT();
00339             return RenderDataFormat::NUM_FORMATS;
00340         }
00341     }
00342 };
00343
00347 struct IofxMeshRenderLayout
00348 {
00349     IofxMeshRenderLayout(void)
00350     {
00351         setDefaults();
00352     }
00353
00357     void setDefaults()
00358     {
00359         bufferDesc.setDefaults();
00360         for (uint32_t i = 0; i < IofxMeshRenderLayoutElement::MAX_COUNT; i++)
00361         {
00362             offsets[i] = uint32_t(-1);
00363         }
00364         stride = 0;
00365     }
00366
00370     bool isValid(void) const
00371     {
00372         uint32_t numFailed = 0;
00373
00374         numFailed += !bufferDesc.isValid();
00375         numFailed += (stride == 0);
00376         numFailed += (offsets[IofxMeshRenderLayoutElement::POSITION_FLOAT3] == uint32_t(-1))
00377             && (offsets[IofxMeshRenderLayoutElement::POSE_FLOAT3x4] == uint32_t(-1));
00378
00379         numFailed += ((stride & 0x03) != 0);
00380         for (uint32_t i = 0; i < IofxMeshRenderLayoutElement::MAX_COUNT; i++)
00381         {
00382             if (offsets[i] != static_cast<uint32_t>(-1))
00383             {
00384                 numFailed += (offsets[i] >= stride);
00385                 numFailed += ((offsets[i] & 0x03) != 0);
00386             }
00387         }
00388
00389         return (numFailed == 0);
00390     }
00391
00395     bool isTheSameAs(const IofxMeshRenderLayout& other) const
00396     {
00397         if (!bufferDesc.isTheSameAs(other.bufferDesc)) return false;
00398         if (stride != other.stride) return false;
00399         for (uint32_t i = 0; i < IofxMeshRenderLayoutElement::MAX_COUNT; i++)
00400         {
00401             if (offsets[i] != other.offsets[i]) return false;
00402         }
00403         return true;
00404     }
00405
00406 public:
00407     UserRenderBufferDesc        bufferDesc;
00408
00412     uint32_t                    offsets[IofxMeshRenderLayoutElement::MAX_COUNT];
00413     uint32_t                    stride;
00414 };
00415
00416
00420 class IofxRenderCallback : public UserRenderCallback
00421 {
00422 public:
00426     virtual void onCreatedIofxRenderable(IofxRenderable& ) {}
00427
00431     virtual void onUpdatedIofxRenderable(IofxRenderable& ) {}
00432
00436     virtual void onReleasingIofxRenderable(IofxRenderable& ) {}
00437
00445     virtual bool getIofxSpriteRenderLayout(IofxSpriteRenderLayout& spriteRenderLayout, uint32_t spriteCount, uint32_t spriteSemanticsBitmap, RenderInteropFlags::Enum interopFlags)
00446     {
00447         PX_UNUSED(spriteRenderLayout);
00448         PX_UNUSED(spriteCount);
00449         PX_UNUSED(spriteSemanticsBitmap);
00450         PX_UNUSED(interopFlags);
00451         return false;
00452     }
00453
00461     virtual bool getIofxMeshRenderLayout(IofxMeshRenderLayout& meshRenderLayout, uint32_t meshCount, uint32_t meshSemanticsBitmap, RenderInteropFlags::Enum interopFlags)
00462     {
00463         PX_UNUSED(meshRenderLayout);
00464         PX_UNUSED(meshCount);
00465         PX_UNUSED(meshSemanticsBitmap);
00466         PX_UNUSED(interopFlags);
00467         return false;
00468     }
00469
00470 };
00471
00472 PX_POP_PACK
00473
00474 }
00475 } // end namespace nvidia
00476
00477 #endif // IOFX_RENDER_CALLBACK_H
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Modifier.h File Reference

  • File List
  • File Members
Classes | Namespaces | Functions
Modifier.h File Reference
#include "Apex.h"
#include "Curve.h"
#include "IofxAsset.h"
#include "IofxRenderCallback.h"
#include "ModifierDefs.h"

Go to the source code of this file.

Classes

class | nvidia::apex::Modifier
Modifier contains all of the data necessary to apply a single modifier type to a particle system. More...
class | nvidia::apex::ModifierT< T >
ModifierT is a helper class to handle the mapping of Type->Enum and Enum->Type. More...
class | nvidia::apex::RotationModifier
RotationModifier applies rotation to the particles using one of several rotation models. More...
class | nvidia::apex::SimpleScaleModifier
SimpleScaleModifier just applies a simple scale factor to each of the X, Y and Z aspects of the model. Each scalefactor can be applied independently. More...
class | nvidia::apex::ScaleByMassModifier
ScaleByMassModifier scales by mass of the particle. More...
class | nvidia::apex::RandomScaleModifier
RandomScaleModifier applies a random scale uniformly to all three dimensions. Currently, the scale is a uniform in the range specified. More...
class | nvidia::apex::ColorVsLifeModifier
ColorVsLifeModifier modifies the color constants associated with a particle depending on the life remaining of the particle. More...
class | nvidia::apex::ColorVsDensityModifier
ColorVsDensityModifier modifies the color constants associated with a particle depending on the density of the particle. More...
class | nvidia::apex::SubtextureVsLifeModifier
SubtextureVsLifeModifier is a modifier to adjust the subtexture id versus the life remaining of a particular particle. More...
class | nvidia::apex::OrientAlongVelocityModifier
OrientAlongVelocity is a modifier to orient a mesh so that a particular axis coincides with the velocity vector. More...
class | nvidia::apex::ScaleAlongVelocityModifier
ScaleAlongVelocityModifier is a modifier to apply a scale factor along the current velocity vector. More...
class | nvidia::apex::RandomSubtextureModifier
RandomSubtextureModifier generates a random subtexture ID and places it in the subTextureId field. More...
class | nvidia::apex::RandomRotationModifier
RandomRotationModifier will choose a random orientation for a sprite particle within the range as specified below. More...
class | nvidia::apex::ScaleVsLifeModifier
ScaleVsLifeModifier applies a scale factor function against a single axis versus the life remaining. More...
class | nvidia::apex::ScaleVsDensityModifier
ScaleVsDensityModifier applies a scale factor function against a single axis versus the density of the particle. More...
class | nvidia::apex::ScaleVsCameraDistanceModifier
ScaleVsCameraDistance applies a scale factor against a specific axis based on distance from the camera to the particle. More...
class | nvidia::apex::ViewDirectionSortingModifier
ViewDirectionSortingModifier sorts sprite particles along view direction back to front. More...
class | nvidia::apex::RotationRateModifier
RotationRateModifier is a modifier to apply a continuous rotation for sprites. More...
class | nvidia::apex::RotationRateVsLifeModifier
RotationRateVsLifeModifier is a modifier to adjust the rotation rate versus the life remaining of a particular particle. More...
class | nvidia::apex::OrientScaleAlongScreenVelocityModifier
OrientScaleAlongScreenVelocityModifier is a modifier to orient & scale sprites along the current screen velocity vector. More...
class | nvidia::apex::ColorVsVelocityModifier
ColorVsVelocityModifier modifies the color constants associated with a particle depending on the velocity of the particle. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Functions

PX_PUSH_PACK_DEFAULT uint32_t | nvidia::apex::ModifierUsageFromStage (ModifierStage stage)
Converts ModifierStage to bitmap.
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Modifier.h Source File

  • File List
  • File Members
Modifier.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODIFIER_H
00031 #define MODIFIER_H
00032
00033 #include "Apex.h"
00034 #include "Curve.h"
00035 #include "IofxAsset.h"
00036 #include "IofxRenderCallback.h"
00037
00038 #include "ModifierDefs.h"
00039
00040 namespace nvidia
00041 {
00042 namespace apex
00043 {
00044
00045 PX_PUSH_PACK_DEFAULT
00046
00048 inline uint32_t ModifierUsageFromStage(ModifierStage stage)
00049 {
00050     return 1u << stage;
00051 }
00052
00053 // Disable the unused arguments warning for this header.
00054 #pragma warning( disable: 4100 )
00055
00062 class Modifier
00063 {
00064 public:
00065
00067     virtual ModifierTypeEnum getModifierType() const = 0;
00068
00070     virtual uint32_t getModifierUsage() const = 0;
00071
00073     virtual uint32_t getModifierSpriteSemantics()
00074     {
00075         return 0;
00076     }
00077
00079     virtual uint32_t getModifierMeshSemantics()
00080     {
00081         return 0;
00082     }
00083
00084     virtual ~Modifier() { }
00085
00086 };
00087
00094 template <typename T>
00095 class ModifierT : public Modifier
00096 {
00097 public:
00098
00100     virtual ModifierTypeEnum getModifierType() const
00101     {
00102         return T::ModifierType;
00103     }
00104
00106     virtual uint32_t getModifierUsage() const
00107     {
00108         return T::ModifierUsage;
00109     }
00110 };
00111
00112
00116 class RotationModifier : public ModifierT<RotationModifier>
00117 {
00118 public:
00119
00121     static const ModifierTypeEnum ModifierType = ModifierType_Rotation;
00122
00124     static const uint32_t ModifierUsage = ModifierUsage_Spawn | ModifierUsage_Continuous
00125             | ModifierUsage_Mesh;
00126
00127
00129     virtual ApexMeshParticleRollType::Enum getRollType() const = 0;
00130
00132     virtual void setRollType(ApexMeshParticleRollType::Enum rollType) = 0;
00133
00135     virtual float getMaxSettleRate() const = 0;
00136
00138     virtual void setMaxSettleRate(float settleRate) = 0;
00139
00141     virtual float getMaxRotationRate() const = 0;
00142
00144     virtual void setMaxRotationRate(float rotationRate) = 0;
00145
00146 };
00147
00152 class SimpleScaleModifier : public ModifierT<SimpleScaleModifier>
00153 {
00154 public:
00155
00157     static const ModifierTypeEnum ModifierType = ModifierType_SimpleScale;
00158
00160     static const uint32_t ModifierUsage = ModifierUsage_Spawn | ModifierUsage_Continuous
00161             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00162
00163
00165     virtual PxVec3 getScaleFactor() const = 0;
00166
00168     virtual void setScaleFactor(const PxVec3& s) = 0;
00169 };
00170
00174 class ScaleByMassModifier : public ModifierT<ScaleByMassModifier>
00175 {
00176 public:
00177
00179     static const ModifierTypeEnum ModifierType = ModifierType_ScaleByMass;
00180
00182     static const uint32_t ModifierUsage = ModifierUsage_Spawn | ModifierUsage_Continuous
00183             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00184 };
00185
00190 class RandomScaleModifier : public ModifierT<RandomScaleModifier>
00191 {
00192 public:
00193
00195     static const ModifierTypeEnum ModifierType = ModifierType_RandomScale;
00196
00198     static const uint32_t ModifierUsage = ModifierUsage_Spawn
00199             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00200
00201
00203     virtual Range<float> getScaleFactor() const = 0;
00204
00206     virtual void setScaleFactor(const Range<float>& s) = 0;
00207 };
00208
00213 class ColorVsLifeModifier : public ModifierT<ColorVsLifeModifier>
00214 {
00215 public:
00216
00218     static const ModifierTypeEnum ModifierType = ModifierType_ColorVsLife;
00219
00221     static const uint32_t ModifierUsage = ModifierUsage_Spawn | ModifierUsage_Continuous
00222             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00223
00224
00226     virtual ColorChannel getColorChannel() const = 0;
00227
00229     virtual void setColorChannel(ColorChannel colorChannel) = 0;
00230
00232     virtual const Curve* getFunction() const = 0;
00233
00235     virtual void setFunction(const Curve* f) = 0;
00236 };
00237
00242 class ColorVsDensityModifier : public ModifierT<ColorVsDensityModifier>
00243 {
00244 public:
00245
00247     static const ModifierTypeEnum ModifierType = ModifierType_ColorVsDensity;
00248
00250     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00251             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00252
00253
00255     virtual ColorChannel getColorChannel() const = 0;
00256
00258     virtual void setColorChannel(ColorChannel colorChannel) = 0;
00259
00261     virtual const Curve* getFunction() const = 0;
00262
00264     virtual void setFunction(const Curve* f) = 0;
00265 };
00266
00272 class SubtextureVsLifeModifier : public ModifierT<SubtextureVsLifeModifier>
00273 {
00274 public:
00275
00277     static const ModifierTypeEnum ModifierType = ModifierType_SubtextureVsLife;
00278
00280     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00281             | ModifierUsage_Sprite;
00282
00283
00285     virtual const Curve* getFunction() const = 0;
00286
00288     virtual void setFunction(const Curve* f) = 0;
00289 };
00290
00294 class OrientAlongVelocityModifier : public ModifierT<OrientAlongVelocityModifier>
00295 {
00296 public:
00297
00299     static const ModifierTypeEnum ModifierType = ModifierType_OrientAlongVelocity;
00300
00302     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00303             | ModifierUsage_Mesh;
00304
00305
00307     virtual PxVec3 getModelForward() const = 0;
00308
00310     virtual void setModelForward(const PxVec3& s) = 0;
00311 };
00312
00313
00319 class ScaleAlongVelocityModifier : public ModifierT<ScaleAlongVelocityModifier>
00320 {
00321 public:
00322
00324     static const ModifierTypeEnum ModifierType = ModifierType_ScaleAlongVelocity;
00325
00327     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00328             | ModifierUsage_Mesh;
00329
00330
00332     virtual float getScaleFactor() const = 0;
00333
00335     virtual void setScaleFactor(const float& s) = 0;
00336 };
00337
00341 class RandomSubtextureModifier : public ModifierT<RandomSubtextureModifier>
00342 {
00343 public:
00344
00346     static const ModifierTypeEnum ModifierType = ModifierType_RandomSubtexture;
00347
00349     static const uint32_t ModifierUsage = ModifierUsage_Spawn
00350             | ModifierUsage_Sprite;
00351
00352
00354     virtual Range<float> getSubtextureRange() const = 0;
00355
00357     virtual void setSubtextureRange(const Range<float>& s) = 0;
00358 };
00359
00365 class RandomRotationModifier : public ModifierT<RandomRotationModifier>
00366 {
00367 public:
00368
00370     static const ModifierTypeEnum ModifierType = ModifierType_RandomRotation;
00371
00373     static const uint32_t ModifierUsage = ModifierUsage_Spawn
00374             | ModifierUsage_Sprite;
00375
00376
00378     virtual Range<float> getRotationRange() const = 0;
00379
00381     virtual void setRotationRange(const Range<float>& s) = 0;
00382 };
00383
00387 class ScaleVsLifeModifier : public ModifierT<ScaleVsLifeModifier>
00388 {
00389 public:
00390
00392     static const ModifierTypeEnum ModifierType = ModifierType_ScaleVsLife;
00393
00395     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00396             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00397
00398
00400     virtual ScaleAxis getScaleAxis() const = 0;
00401
00403     virtual void setScaleAxis(ScaleAxis a) = 0;
00404
00406     virtual const Curve* getFunction() const = 0;
00407
00409     virtual void setFunction(const Curve* f) = 0;
00410 };
00411
00415 class ScaleVsDensityModifier : public ModifierT<ScaleVsDensityModifier>
00416 {
00417 public:
00418
00420     static const ModifierTypeEnum ModifierType = ModifierType_ScaleVsDensity;
00421
00423     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00424             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00425
00426
00428     virtual ScaleAxis getScaleAxis() const = 0;
00429
00431     virtual void setScaleAxis(ScaleAxis a) = 0;
00432
00434     virtual const Curve* getFunction() const = 0;
00435
00437     virtual void setFunction(const Curve* f) = 0;
00438 };
00439
00443 class ScaleVsCameraDistanceModifier : public ModifierT<ScaleVsCameraDistanceModifier>
00444 {
00445 public:
00446
00448     static const ModifierTypeEnum ModifierType = ModifierType_ScaleVsCameraDistance;
00449
00451     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00452             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00453
00454
00456     virtual ScaleAxis getScaleAxis() const = 0;
00457
00459     virtual void setScaleAxis(ScaleAxis a) = 0;
00460
00462     virtual const Curve* getFunction() const = 0;
00463
00465     virtual void setFunction(const Curve* f) = 0;
00466 };
00467
00471 class ViewDirectionSortingModifier : public ModifierT<ViewDirectionSortingModifier>
00472 {
00473 public:
00474
00476     static const ModifierTypeEnum ModifierType = ModifierType_ViewDirectionSorting;
00477
00479     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00480             | ModifierUsage_Sprite;
00481
00482 };
00483
00487 class RotationRateModifier : public ModifierT<RotationRateModifier>
00488 {
00489 public:
00490
00492     static const ModifierTypeEnum ModifierType = ModifierType_RotationRate;
00493
00495     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00496             | ModifierUsage_Sprite;
00497
00498
00500     virtual float getRotationRate() const = 0;
00501
00503     virtual void setRotationRate(const float& rate) = 0;
00504 };
00505
00509 class RotationRateVsLifeModifier : public ModifierT<RotationRateVsLifeModifier>
00510 {
00511 public:
00512
00514     static const ModifierTypeEnum ModifierType = ModifierType_RotationRateVsLife;
00515
00517     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00518             | ModifierUsage_Sprite;
00519
00520
00522     virtual const Curve* getFunction() const = 0;
00523
00525     virtual void setFunction(const Curve* f) = 0;
00526 };
00527
00531 class OrientScaleAlongScreenVelocityModifier : public ModifierT<OrientScaleAlongScreenVelocityModifier>
00532 {
00533 public:
00534
00536     static const ModifierTypeEnum ModifierType = ModifierType_OrientScaleAlongScreenVelocity;
00537
00539     static const uint32_t ModifierUsage = ModifierUsage_Continuous
00540             | ModifierUsage_Sprite;
00541
00542
00544     virtual float getScalePerVelocity() const = 0;
00545
00547     virtual void setScalePerVelocity(const float& s) = 0;
00548
00550     virtual float getScaleChangeLimit() const = 0;
00551
00553     virtual void setScaleChangeLimit(const float& s) = 0;
00554
00556     virtual float getScaleChangeDelay() const = 0;
00557
00559     virtual void setScaleChangeDelay(const float& s) = 0;
00560 };
00561
00566 class ColorVsVelocityModifier : public ModifierT<ColorVsVelocityModifier>
00567 {
00568 public:
00569
00571     static const ModifierTypeEnum ModifierType = ModifierType_ColorVsVelocity;
00572
00574     static const uint32_t ModifierUsage = ModifierUsage_Spawn | ModifierUsage_Continuous
00575             | ModifierUsage_Sprite | ModifierUsage_Mesh;
00576
00577
00579     virtual ColorChannel getColorChannel() const = 0;
00580
00582     virtual void setColorChannel(ColorChannel colorChannel) = 0;
00583
00585     virtual const Curve* getFunction() const = 0;
00586
00588     virtual void setFunction(const Curve* f) = 0;
00589
00591     virtual float getVelocity0() const = 0;
00592
00594     virtual void setVelocity0(float value) = 0;
00595
00597     virtual float getVelocity1() const = 0;
00598
00600     virtual void setVelocity1(float value) = 0;
00601 };
00602
00603 #pragma warning( default: 4100 )
00604
00605 PX_POP_PACK
00606
00607 }
00608 } // namespace nvidia
00609
00610 #endif // MODIFIER_H
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: ModifierDefs.h File Reference

  • File List
  • File Members
Classes | Namespaces | Enumerations
ModifierDefs.h File Reference
#include "ApexUsingNamespace.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::ApexMeshParticleRollType
Roll type of a particle. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Enumerations

enum nvidia::apex::ModifierTypeEnum {
nvidia::apex::ModifierType_Invalid = 0,
nvidia::apex::ModifierType_Rotation = 1,
nvidia::apex::ModifierType_SimpleScale = 2,
nvidia::apex::ModifierType_RandomScale = 3,
nvidia::apex::ModifierType_ColorVsLife = 4,
nvidia::apex::ModifierType_ColorVsDensity = 5,
nvidia::apex::ModifierType_SubtextureVsLife = 6,
nvidia::apex::ModifierType_OrientAlongVelocity = 7,
nvidia::apex::ModifierType_ScaleAlongVelocity = 8,
nvidia::apex::ModifierType_RandomSubtexture = 9,
nvidia::apex::ModifierType_RandomRotation = 10,
nvidia::apex::ModifierType_ScaleVsLife = 11,
nvidia::apex::ModifierType_ScaleVsDensity = 12,
nvidia::apex::ModifierType_ScaleVsCameraDistance = 13,
nvidia::apex::ModifierType_ViewDirectionSorting = 14,
nvidia::apex::ModifierType_RotationRate = 15,
nvidia::apex::ModifierType_RotationRateVsLife = 16,
nvidia::apex::ModifierType_OrientScaleAlongScreenVelocity = 17,
nvidia::apex::ModifierType_ScaleByMass = 18,
nvidia::apex::ModifierType_ColorVsVelocity = 19,
nvidia::apex::ModifierType_Count
}
Modifiers list. More...
enum nvidia::apex::ModifierStage {
nvidia::apex::ModifierStage_Spawn = 0,
nvidia::apex::ModifierStage_Continuous = 1,
nvidia::apex::ModifierStage_Count
}
Stage at which the modifier is applied. More...
enum nvidia::apex::ColorChannel {
nvidia::apex::ColorChannel_Red = 0,
nvidia::apex::ColorChannel_Green = 1,
nvidia::apex::ColorChannel_Blue = 2,
nvidia::apex::ColorChannel_Alpha = 3
}
Color channel. More...
enum nvidia::apex::ScaleAxis {
nvidia::apex::ScaleAxis_X = 0,
nvidia::apex::ScaleAxis_Y = 1,
nvidia::apex::ScaleAxis_Z = 2
}
Scale axis. More...
enum nvidia::apex::ModifierUsage {
nvidia::apex::ModifierUsage_Spawn = 0x01,
nvidia::apex::ModifierUsage_Continuous = 0x02,
nvidia::apex::ModifierUsage_Sprite = 0x04,
nvidia::apex::ModifierUsage_Mesh = 0x08
}
Modifier usage. More...
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: ModifierDefs.h Source File

  • File List
  • File Members
ModifierDefs.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODIFIER_DEFS_H
00031 #define MODIFIER_DEFS_H
00032
00033 #include "ApexUsingNamespace.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00045 struct ApexMeshParticleRollType
00046 {
00050     enum Enum
00051     {
00052         SPHERICAL = 0,
00053         CUBIC,
00054         FLAT_X,
00055         FLAT_Y,
00056         FLAT_Z,
00057         LONG_X,
00058         LONG_Y,
00059         LONG_Z,
00060         SPRITE,
00061
00062         COUNT
00063     };
00064 };
00065
00072 enum ModifierTypeEnum
00073 {
00074     ModifierType_Invalid                        = 0,
00075     ModifierType_Rotation                       = 1,
00076     ModifierType_SimpleScale                    = 2,
00077     ModifierType_RandomScale                    = 3,
00078     ModifierType_ColorVsLife                    = 4,
00079     ModifierType_ColorVsDensity                 = 5,
00080     ModifierType_SubtextureVsLife               = 6,
00081     ModifierType_OrientAlongVelocity            = 7,
00082     ModifierType_ScaleAlongVelocity             = 8,
00083     ModifierType_RandomSubtexture               = 9,
00084     ModifierType_RandomRotation                 = 10,
00085     ModifierType_ScaleVsLife                    = 11,
00086     ModifierType_ScaleVsDensity                 = 12,
00087     ModifierType_ScaleVsCameraDistance          = 13,
00088     ModifierType_ViewDirectionSorting           = 14,
00089     ModifierType_RotationRate                   = 15,
00090     ModifierType_RotationRateVsLife             = 16,
00091     ModifierType_OrientScaleAlongScreenVelocity = 17,
00092     ModifierType_ScaleByMass                    = 18,
00093     ModifierType_ColorVsVelocity                = 19,
00094
00095     ModifierType_Count
00096 };
00097
00101 enum ModifierStage
00102 {
00103     ModifierStage_Spawn = 0,
00104     ModifierStage_Continuous = 1,
00105
00106     ModifierStage_Count
00107 };
00108
00112 enum ColorChannel
00113 {
00114     ColorChannel_Red    = 0,
00115     ColorChannel_Green  = 1,
00116     ColorChannel_Blue   = 2,
00117     ColorChannel_Alpha  = 3
00118 };
00119
00123 enum ScaleAxis
00124 {
00125     ScaleAxis_X         = 0,
00126     ScaleAxis_Y         = 1,
00127     ScaleAxis_Z         = 2
00128 };
00129
00133 enum ModifierUsage
00134 {
00135     ModifierUsage_Spawn         = 0x01,
00136     ModifierUsage_Continuous    = 0x02,
00137
00138     ModifierUsage_Sprite        = 0x04,
00139     ModifierUsage_Mesh          = 0x08,
00140 };
00141
00142 PX_POP_PACK
00143
00144 }
00145 } // namespace nvidia
00146
00147 #endif // MODIFIER_DEFS_H
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: ModuleIofx.h File Reference

  • File List
  • File Members
Classes | Namespaces
ModuleIofx.h File Reference
#include "Apex.h"
#include "TestBase.h"

Go to the source code of this file.

Classes

class | nvidia::apex::IofxRenderableIterator
Iterate over all renderables in IOFX module. IMPORTANT: release() should be called for each returned not-NULL renderable! More...
class | nvidia::apex::ModuleIofx
IOFX Module. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: ModuleIofx.h Source File

  • File List
  • File Members
ModuleIofx.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_IOFX_H
00031 #define MODULE_IOFX_H
00032
00033 #include "Apex.h"
00034 #include "TestBase.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class IofxAsset;
00044 class IofxAssetAuthoring;
00045 class RenderVolume;
00046 class IofxRenderCallback;
00047 class IofxRenderable;
00048
00049
00053 class IofxRenderableIterator : public ApexInterface
00054 {
00055 public:
00056
00058     virtual IofxRenderable* getFirst() = 0;
00059
00061     virtual IofxRenderable* getNext() = 0;
00062 };
00063
00064
00072 class ModuleIofx : public Module
00073 {
00074 protected:
00075     virtual                         ~ModuleIofx() {}
00076
00077 public:
00079     virtual void                    disableCudaInterop() = 0;
00080
00082     virtual void                    disableCudaModifiers() = 0;
00083
00089     virtual void                    disableDeferredRenderableAllocation() = 0;
00090
00097     virtual RenderVolume*           createRenderVolume(const Scene& apexScene, const PxBounds3& b, uint32_t priority, bool allIofx) = 0;
00098
00105     virtual void                    releaseRenderVolume(RenderVolume& volume) = 0;
00106
00108     virtual const TestBase*         getTestBase(Scene* apexScene) const = 0;
00109
00114     virtual bool                    setIofxRenderCallback(const Scene& apexScene, IofxRenderCallback* ) = 0;
00115
00120     virtual IofxRenderCallback*     getIofxRenderCallback(const Scene& apexScene) const = 0;
00121
00125     virtual IofxRenderableIterator* createIofxRenderableIterator(const Scene&) = 0;
00126
00130     virtual void                    prepareRenderables(const Scene&) = 0;
00131 };
00132
00133
00134 PX_POP_PACK
00135
00136 }
00137 } // namespace nvidia
00138
00139 #endif // MODULE_IOFX_H
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • c
  • m
  • s
Here is a list of all namespace members with links to the namespace documentation for each member:

- c -

  • ColorChannel : nvidia::apex
  • ColorChannel_Alpha : nvidia::apex
  • ColorChannel_Blue : nvidia::apex
  • ColorChannel_Green : nvidia::apex
  • ColorChannel_Red : nvidia::apex

- m -

  • ModifierStage : nvidia::apex
  • ModifierStage_Continuous : nvidia::apex
  • ModifierStage_Count : nvidia::apex
  • ModifierStage_Spawn : nvidia::apex
  • ModifierType_ColorVsDensity : nvidia::apex
  • ModifierType_ColorVsLife : nvidia::apex
  • ModifierType_ColorVsVelocity : nvidia::apex
  • ModifierType_Count : nvidia::apex
  • ModifierType_Invalid : nvidia::apex
  • ModifierType_OrientAlongVelocity : nvidia::apex
  • ModifierType_OrientScaleAlongScreenVelocity : nvidia::apex
  • ModifierType_RandomRotation : nvidia::apex
  • ModifierType_RandomScale : nvidia::apex
  • ModifierType_RandomSubtexture : nvidia::apex
  • ModifierType_Rotation : nvidia::apex
  • ModifierType_RotationRate : nvidia::apex
  • ModifierType_RotationRateVsLife : nvidia::apex
  • ModifierType_ScaleAlongVelocity : nvidia::apex
  • ModifierType_ScaleByMass : nvidia::apex
  • ModifierType_ScaleVsCameraDistance : nvidia::apex
  • ModifierType_ScaleVsDensity : nvidia::apex
  • ModifierType_ScaleVsLife : nvidia::apex
  • ModifierType_SimpleScale : nvidia::apex
  • ModifierType_SubtextureVsLife : nvidia::apex
  • ModifierType_ViewDirectionSorting : nvidia::apex
  • ModifierTypeEnum : nvidia::apex
  • ModifierUsage : nvidia::apex
  • ModifierUsage_Continuous : nvidia::apex
  • ModifierUsage_Mesh : nvidia::apex
  • ModifierUsage_Spawn : nvidia::apex
  • ModifierUsage_Sprite : nvidia::apex
  • ModifierUsageFromStage() : nvidia::apex

- s -

  • ScaleAxis : nvidia::apex
  • ScaleAxis_X : nvidia::apex
  • ScaleAxis_Y : nvidia::apex
  • ScaleAxis_Z : nvidia::apex
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • ColorChannel : nvidia::apex
  • ModifierStage : nvidia::apex
  • ModifierTypeEnum : nvidia::apex
  • ModifierUsage : nvidia::apex
  • ScaleAxis : nvidia::apex
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • c
  • m
  • s

- c -

  • ColorChannel_Alpha : nvidia::apex
  • ColorChannel_Blue : nvidia::apex
  • ColorChannel_Green : nvidia::apex
  • ColorChannel_Red : nvidia::apex

- m -

  • ModifierStage_Continuous : nvidia::apex
  • ModifierStage_Count : nvidia::apex
  • ModifierStage_Spawn : nvidia::apex
  • ModifierType_ColorVsDensity : nvidia::apex
  • ModifierType_ColorVsLife : nvidia::apex
  • ModifierType_ColorVsVelocity : nvidia::apex
  • ModifierType_Count : nvidia::apex
  • ModifierType_Invalid : nvidia::apex
  • ModifierType_OrientAlongVelocity : nvidia::apex
  • ModifierType_OrientScaleAlongScreenVelocity : nvidia::apex
  • ModifierType_RandomRotation : nvidia::apex
  • ModifierType_RandomScale : nvidia::apex
  • ModifierType_RandomSubtexture : nvidia::apex
  • ModifierType_Rotation : nvidia::apex
  • ModifierType_RotationRate : nvidia::apex
  • ModifierType_RotationRateVsLife : nvidia::apex
  • ModifierType_ScaleAlongVelocity : nvidia::apex
  • ModifierType_ScaleByMass : nvidia::apex
  • ModifierType_ScaleVsCameraDistance : nvidia::apex
  • ModifierType_ScaleVsDensity : nvidia::apex
  • ModifierType_ScaleVsLife : nvidia::apex
  • ModifierType_SimpleScale : nvidia::apex
  • ModifierType_SubtextureVsLife : nvidia::apex
  • ModifierType_ViewDirectionSorting : nvidia::apex
  • ModifierUsage_Continuous : nvidia::apex
  • ModifierUsage_Mesh : nvidia::apex
  • ModifierUsage_Spawn : nvidia::apex
  • ModifierUsage_Sprite : nvidia::apex

- s -

  • ScaleAxis_X : nvidia::apex
  • ScaleAxis_Y : nvidia::apex
  • ScaleAxis_Z : nvidia::apex
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • ModifierUsageFromStage() : nvidia::apex
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces
nvidia Namespace Reference

Namespaces

namespace apex
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex Namespace Reference

  • Namespace List
  • Namespace Members
  • nvidia
  • apex
Classes | Enumerations | Functions
nvidia::apex Namespace Reference

Classes

class | IofxActor
IOFX actor public interface. More...
class | IofxAsset
IOFX Asset public interface. Used to define the way the visual parameters are created from physical parameters of a particle. More...
class | IofxAssetAuthoring
IOFX Asset Authoring public interface. More...
struct | IofxSharedRenderData
IofxSharedRenderData stores common render data shared by several IOFX Renderables. More...
struct | IofxSpriteSharedRenderData
IofxSpriteSharedRenderData stores sprite render data shared by several IOFX Renderables. More...
struct | IofxMeshSharedRenderData
IofxMeshSharedRenderData stores mesh render data shared by several IOFX Renderables. More...
struct | IofxCommonRenderData
IofxCommonRenderData stores common render data for one IOFX Renderable. More...
struct | IofxSpriteRenderData
IofxSpriteRenderData stores sprite render data for one IOFX Renderable. More...
struct | IofxMeshRenderData
IofxMeshRenderData stores mesh render data for one IOFX Renderable. More...
class | IofxRenderable
The IOFX renderable represents a unit of rendering. It contains complete information to render a batch of particles with the same material/mesh in the same render volume. More...
struct | IofxRenderSemantic
Enumerates the potential IOFX render semantics. More...
struct | IofxSpriteRenderLayoutElement
Enumerates the potential IOFX mesh render layout elements. More...
struct | IofxSpriteRenderLayoutSurfaceElement
Enumerates the potential IOFX sprite render layout surface elements. More...
struct | IofxSpriteRenderLayout
Describes the layout for sprite rendering. More...
struct | IofxMeshRenderLayoutElement
Enumerates the potential IOFX mesh render layout elements. More...
struct | IofxMeshRenderLayout
Describes the layout for mesh rendering. More...
class | IofxRenderCallback
User defined callback for IOFX rendering. More...
class | Modifier
Modifier contains all of the data necessary to apply a single modifier type to a particle system. More...
class | ModifierT
ModifierT is a helper class to handle the mapping of Type->Enum and Enum->Type. More...
class | RotationModifier
RotationModifier applies rotation to the particles using one of several rotation models. More...
class | SimpleScaleModifier
SimpleScaleModifier just applies a simple scale factor to each of the X, Y and Z aspects of the model. Each scalefactor can be applied independently. More...
class | ScaleByMassModifier
ScaleByMassModifier scales by mass of the particle. More...
class | RandomScaleModifier
RandomScaleModifier applies a random scale uniformly to all three dimensions. Currently, the scale is a uniform in the range specified. More...
class | ColorVsLifeModifier
ColorVsLifeModifier modifies the color constants associated with a particle depending on the life remaining of the particle. More...
class | ColorVsDensityModifier
ColorVsDensityModifier modifies the color constants associated with a particle depending on the density of the particle. More...
class | SubtextureVsLifeModifier
SubtextureVsLifeModifier is a modifier to adjust the subtexture id versus the life remaining of a particular particle. More...
class | OrientAlongVelocityModifier
OrientAlongVelocity is a modifier to orient a mesh so that a particular axis coincides with the velocity vector. More...
class | ScaleAlongVelocityModifier
ScaleAlongVelocityModifier is a modifier to apply a scale factor along the current velocity vector. More...
class | RandomSubtextureModifier
RandomSubtextureModifier generates a random subtexture ID and places it in the subTextureId field. More...
class | RandomRotationModifier
RandomRotationModifier will choose a random orientation for a sprite particle within the range as specified below. More...
class | ScaleVsLifeModifier
ScaleVsLifeModifier applies a scale factor function against a single axis versus the life remaining. More...
class | ScaleVsDensityModifier
ScaleVsDensityModifier applies a scale factor function against a single axis versus the density of the particle. More...
class | ScaleVsCameraDistanceModifier
ScaleVsCameraDistance applies a scale factor against a specific axis based on distance from the camera to the particle. More...
class | ViewDirectionSortingModifier
ViewDirectionSortingModifier sorts sprite particles along view direction back to front. More...
class | RotationRateModifier
RotationRateModifier is a modifier to apply a continuous rotation for sprites. More...
class | RotationRateVsLifeModifier
RotationRateVsLifeModifier is a modifier to adjust the rotation rate versus the life remaining of a particular particle. More...
class | OrientScaleAlongScreenVelocityModifier
OrientScaleAlongScreenVelocityModifier is a modifier to orient & scale sprites along the current screen velocity vector. More...
class | ColorVsVelocityModifier
ColorVsVelocityModifier modifies the color constants associated with a particle depending on the velocity of the particle. More...
struct | ApexMeshParticleRollType
Roll type of a particle. More...
class | IofxRenderableIterator
Iterate over all renderables in IOFX module. IMPORTANT: release() should be called for each returned not-NULL renderable! More...
class | ModuleIofx
IOFX Module. More...
class | RenderVolume
An object which "owns" a volume of world space. More...

Enumerations

enum ModifierTypeEnum {
ModifierType_Invalid = 0,
ModifierType_Rotation = 1,
ModifierType_SimpleScale = 2,
ModifierType_RandomScale = 3,
ModifierType_ColorVsLife = 4,
ModifierType_ColorVsDensity = 5,
ModifierType_SubtextureVsLife = 6,
ModifierType_OrientAlongVelocity = 7,
ModifierType_ScaleAlongVelocity = 8,
ModifierType_RandomSubtexture = 9,
ModifierType_RandomRotation = 10,
ModifierType_ScaleVsLife = 11,
ModifierType_ScaleVsDensity = 12,
ModifierType_ScaleVsCameraDistance = 13,
ModifierType_ViewDirectionSorting = 14,
ModifierType_RotationRate = 15,
ModifierType_RotationRateVsLife = 16,
ModifierType_OrientScaleAlongScreenVelocity = 17,
ModifierType_ScaleByMass = 18,
ModifierType_ColorVsVelocity = 19,
ModifierType_Count
}
Modifiers list. More...
enum ModifierStage {
ModifierStage_Spawn = 0,
ModifierStage_Continuous = 1,
ModifierStage_Count
}
Stage at which the modifier is applied. More...
enum ColorChannel {
ColorChannel_Red = 0,
ColorChannel_Green = 1,
ColorChannel_Blue = 2,
ColorChannel_Alpha = 3
}
Color channel. More...
enum ScaleAxis {
ScaleAxis_X = 0,
ScaleAxis_Y = 1,
ScaleAxis_Z = 2
}
Scale axis. More...
enum ModifierUsage {
ModifierUsage_Spawn = 0x01,
ModifierUsage_Continuous = 0x02,
ModifierUsage_Sprite = 0x04,
ModifierUsage_Mesh = 0x08
}
Modifier usage. More...

Functions

PX_PUSH_PACK_DEFAULT uint32_t | ModifierUsageFromStage (ModifierStage stage)
Converts ModifierStage to bitmap.

Enumeration Type Documentation

enum nvidia::apex::ColorChannel

Color channel.

Enumerator:
ColorChannel_Red
ColorChannel_Green
ColorChannel_Blue
ColorChannel_Alpha
enum nvidia::apex::ModifierStage

Stage at which the modifier is applied.

Enumerator:
ModifierStage_Spawn

at the spawn

ModifierStage_Continuous

on every frame

ModifierStage_Count
enum nvidia::apex::ModifierTypeEnum

Modifiers list.

Note:
These are serialized to disk, so if you reorder them or change existing modifier types, you will need to version the stream and map the old values to the new values. If new values are just appended, no other special care needs to be handled.
Enumerator:
ModifierType_Invalid
ModifierType_Rotation
ModifierType_SimpleScale
ModifierType_RandomScale
ModifierType_ColorVsLife
ModifierType_ColorVsDensity
ModifierType_SubtextureVsLife
ModifierType_OrientAlongVelocity
ModifierType_ScaleAlongVelocity
ModifierType_RandomSubtexture
ModifierType_RandomRotation
ModifierType_ScaleVsLife
ModifierType_ScaleVsDensity
ModifierType_ScaleVsCameraDistance
ModifierType_ViewDirectionSorting
ModifierType_RotationRate
ModifierType_RotationRateVsLife
ModifierType_OrientScaleAlongScreenVelocity
ModifierType_ScaleByMass
ModifierType_ColorVsVelocity
ModifierType_Count
enum nvidia::apex::ModifierUsage

Modifier usage.

Enumerator:
ModifierUsage_Spawn
ModifierUsage_Continuous
ModifierUsage_Sprite
ModifierUsage_Mesh
enum nvidia::apex::ScaleAxis

Scale axis.

Enumerator:
ScaleAxis_X
ScaleAxis_Y
ScaleAxis_Z

Function Documentation

PX_PUSH_PACK_DEFAULT uint32_t nvidia::apex::ModifierUsageFromStage ( ModifierStage stage ) [inline]

Converts ModifierStage to bitmap.

Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
nvidia
nvidia::apex
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: RenderVolume.h File Reference

  • File List
  • File Members
Classes | Namespaces
RenderVolume.h File Reference
#include "Apex.h"

Go to the source code of this file.

Classes

class | nvidia::apex::RenderVolume
An object which "owns" a volume of world space. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: RenderVolume.h Source File

  • File List
  • File Members
RenderVolume.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef RENDER_VOLUME_H
00031 #define RENDER_VOLUME_H
00032
00033 #include "Apex.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class IofxAsset;
00043 class IofxActor;
00044
00055 class RenderVolume : public ApexInterface
00056 {
00057 public:
00059     virtual physx::PxBounds3    getBounds() const = 0;
00060
00062     virtual bool                getAffectsAllIofx() const = 0;
00063
00065     virtual bool                addIofxAsset(IofxAsset& iofx) = 0;
00066
00068     virtual void                setPosition(const PxVec3& pos) = 0;
00069
00071     virtual void                setOwnershipBounds(const PxBounds3& b) = 0;
00072
00074     virtual PxBounds3           getOwnershipBounds() const = 0;
00075
00091     virtual IofxActor* const*   lockIofxActorList(uint32_t& count) = 0;
00092
00097     virtual void                unlockIofxActorList() = 0;
00098
00107     virtual IofxAsset* const*   getIofxAssetList(uint32_t& count) const = 0;
00108
00109     virtual PxVec3              getPosition() const = 0;
00110     virtual uint32_t            getPriority() const = 0;
00111
00117     virtual bool                affectsIofxAsset(const IofxAsset& iofx) const = 0;
00118
00119 protected:
00120     virtual ~RenderVolume() {}
00121 };
00122
00123 PX_POP_PACK
00124
00125 }
00126 } // namespace nvidia
00127
00128 #endif // RENDER_VOLUME_H
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::ApexMeshParticleRollType Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexMeshParticleRollType
Public Types
nvidia::apex::ApexMeshParticleRollType Struct Reference

Roll type of a particle. More...

#include <ModifierDefs.h>

List of all members.

Public Types

enum Enum {
SPHERICAL = 0,
CUBIC,
FLAT_X,
FLAT_Y,
FLAT_Z,
LONG_X,
LONG_Y,
LONG_Z,
SPRITE,
COUNT
}
Enum of roll type of a particle. More...

Detailed Description

Roll type of a particle.

Member Enumeration Documentation

enum nvidia::apex::ApexMeshParticleRollType::Enum

Enum of roll type of a particle.

Enumerator:
SPHERICAL

roll as a sphere

CUBIC

as a cubical object

FLAT_X

as a flat object (shortest axis is x)

FLAT_Y

as a flat object (shortest axis is y)

FLAT_Z

as a flat object (shortest axis is z)

LONG_X

as a long object (longest axis is x)

LONG_Y

as a long object (longest axis is y)

LONG_Z

as a long object (longest axis is z)

SPRITE

as a sprite

COUNT
The documentation for this struct was generated from the following file:
  • ModifierDefs.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • ApexMeshParticleRollType
nvidia::apex::ApexMeshParticleRollType Member List
This is the complete list of members for nvidia::apex::ApexMeshParticleRollType, including all inherited members.
COUNT enum value | nvidia::apex::ApexMeshParticleRollType
CUBIC enum value | nvidia::apex::ApexMeshParticleRollType
Enum enum name | nvidia::apex::ApexMeshParticleRollType
FLAT_X enum value | nvidia::apex::ApexMeshParticleRollType
FLAT_Y enum value | nvidia::apex::ApexMeshParticleRollType
FLAT_Z enum value | nvidia::apex::ApexMeshParticleRollType
LONG_X enum value | nvidia::apex::ApexMeshParticleRollType
LONG_Y enum value | nvidia::apex::ApexMeshParticleRollType
LONG_Z enum value | nvidia::apex::ApexMeshParticleRollType
SPHERICAL enum value | nvidia::apex::ApexMeshParticleRollType
SPRITE enum value | nvidia::apex::ApexMeshParticleRollType
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::IofxCommonRenderData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxCommonRenderData
Public Attributes
nvidia::apex::IofxCommonRenderData Struct Reference

IofxCommonRenderData stores common render data for one IOFX Renderable. More...

#include <IofxRenderable.h>

Inheritance diagram for nvidia::apex::IofxCommonRenderData:
nvidia::apex::IofxMeshRenderData nvidia::apex::IofxSpriteRenderData

List of all members.

Public Attributes

uint32_t | startIndex
index of the first particle in render buffer
uint32_t | objectCount
number of particles in render buffer
const char * | renderResourceNameSpace
render resource name space
const char * | renderResourceName
render resource name
void * | renderResource
render resource

Detailed Description

IofxCommonRenderData stores common render data for one IOFX Renderable.

Member Data Documentation

uint32_t nvidia::apex::IofxCommonRenderData::objectCount

number of particles in render buffer

void* nvidia::apex::IofxCommonRenderData::renderResource

render resource

const char* nvidia::apex::IofxCommonRenderData::renderResourceName

render resource name

const char* nvidia::apex::IofxCommonRenderData::renderResourceNameSpace

render resource name space

uint32_t nvidia::apex::IofxCommonRenderData::startIndex

index of the first particle in render buffer

The documentation for this struct was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxCommonRenderData
nvidia::apex::IofxCommonRenderData Member List
This is the complete list of members for nvidia::apex::IofxCommonRenderData, including all inherited members.
objectCount | nvidia::apex::IofxCommonRenderData
renderResource | nvidia::apex::IofxCommonRenderData
renderResourceName | nvidia::apex::IofxCommonRenderData
renderResourceNameSpace | nvidia::apex::IofxCommonRenderData
startIndex | nvidia::apex::IofxCommonRenderData
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxMeshRenderData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshRenderData
Public Attributes
nvidia::apex::IofxMeshRenderData Struct Reference

IofxMeshRenderData stores mesh render data for one IOFX Renderable. More...

#include <IofxRenderable.h>

Inheritance diagram for nvidia::apex::IofxMeshRenderData:
nvidia::apex::IofxCommonRenderData

List of all members.

Public Attributes

const IofxMeshSharedRenderData * sharedRenderData
reference to Mesh shared render data

Detailed Description

IofxMeshRenderData stores mesh render data for one IOFX Renderable.

Member Data Documentation

const IofxMeshSharedRenderData* nvidia::apex::IofxMeshRenderData::sharedRenderData

reference to Mesh shared render data

The documentation for this struct was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshRenderData
nvidia::apex::IofxMeshRenderData Member List
This is the complete list of members for nvidia::apex::IofxMeshRenderData, including all inherited members.
objectCount | nvidia::apex::IofxCommonRenderData
renderResource | nvidia::apex::IofxCommonRenderData
renderResourceName | nvidia::apex::IofxCommonRenderData
renderResourceNameSpace | nvidia::apex::IofxCommonRenderData
sharedRenderData | nvidia::apex::IofxMeshRenderData
startIndex | nvidia::apex::IofxCommonRenderData
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxMeshRenderLayout Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshRenderLayout
Public Member Functions | Public Attributes
nvidia::apex::IofxMeshRenderLayout Struct Reference

Describes the layout for mesh rendering. More...

#include <IofxRenderCallback.h>

List of all members.

Public Member Functions

IofxMeshRenderLayout (void)
void | setDefaults ()
Reset to default values.
bool | isValid (void) const
Check if parameter's values are correct.
bool | isTheSameAs (const IofxMeshRenderLayout &other) const
Check if this object is the same as other.

Public Attributes

UserRenderBufferDesc | bufferDesc
Render buffer desc.
uint32_t | offsets [IofxMeshRenderLayoutElement::MAX_COUNT]
Array of the corresponding offsets (in bytes) for each layout element.
uint32_t | stride
The stride between objects in render buffer.

Detailed Description

Describes the layout for mesh rendering.

Constructor & Destructor Documentation

nvidia::apex::IofxMeshRenderLayout::IofxMeshRenderLayout ( void ) [inline]

Member Function Documentation

bool nvidia::apex::IofxMeshRenderLayout::isTheSameAs ( const IofxMeshRenderLayout & other ) const [inline]

Check if this object is the same as other.

bool nvidia::apex::IofxMeshRenderLayout::isValid ( void ) const [inline]

Check if parameter's values are correct.

void nvidia::apex::IofxMeshRenderLayout::setDefaults ( ) [inline]

Reset to default values.

Member Data Documentation

UserRenderBufferDesc nvidia::apex::IofxMeshRenderLayout::bufferDesc

Render buffer desc.

uint32_t nvidia::apex::IofxMeshRenderLayout::offsets[IofxMeshRenderLayoutElement::MAX_COUNT]

Array of the corresponding offsets (in bytes) for each layout element.

uint32_t nvidia::apex::IofxMeshRenderLayout::stride

The stride between objects in render buffer.

The documentation for this struct was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshRenderLayout
nvidia::apex::IofxMeshRenderLayout Member List
This is the complete list of members for nvidia::apex::IofxMeshRenderLayout, including all inherited members.
bufferDesc | nvidia::apex::IofxMeshRenderLayout |
IofxMeshRenderLayout(void) | nvidia::apex::IofxMeshRenderLayout | [inline]
isTheSameAs(const IofxMeshRenderLayout &other) const | nvidia::apex::IofxMeshRenderLayout | [inline]
isValid(void) const | nvidia::apex::IofxMeshRenderLayout | [inline]
offsets | nvidia::apex::IofxMeshRenderLayout |
setDefaults() | nvidia::apex::IofxMeshRenderLayout | [inline]
stride | nvidia::apex::IofxMeshRenderLayout |
Generated on Sat Dec 1 2018 10:18:49


APEX IOFX Module: nvidia::apex::IofxMeshRenderLayoutElement Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshRenderLayoutElement
Public Types | Static Public Member Functions
nvidia::apex::IofxMeshRenderLayoutElement Struct Reference

Enumerates the potential IOFX mesh render layout elements. More...

#include <IofxRenderCallback.h>

List of all members.

Public Types

enum Enum {
POSITION_FLOAT3,
ROTATION_SCALE_FLOAT3x3,
POSE_FLOAT3x4,
VELOCITY_LIFE_FLOAT4,
DENSITY_FLOAT1,
COLOR_RGBA8,
COLOR_BGRA8,
COLOR_FLOAT4,
USER_DATA_UINT1,
MAX_COUNT
}
Enum of IOFX mesh render layout elements. More...

Static Public Member Functions

static PX_INLINE
RenderDataFormat::Enum 		getFormat (Enum element)
Get layout element format.

Detailed Description

Enumerates the potential IOFX mesh render layout elements.

Member Enumeration Documentation

enum nvidia::apex::IofxMeshRenderLayoutElement::Enum

Enum of IOFX mesh render layout elements.

Enumerator:
POSITION_FLOAT3
ROTATION_SCALE_FLOAT3x3
POSE_FLOAT3x4
VELOCITY_LIFE_FLOAT4
DENSITY_FLOAT1
COLOR_RGBA8
COLOR_BGRA8
COLOR_FLOAT4
USER_DATA_UINT1
MAX_COUNT

Member Function Documentation

static PX_INLINE RenderDataFormat::Enum nvidia::apex::IofxMeshRenderLayoutElement::getFormat ( Enum element ) [inline, static]

Get layout element format.

The documentation for this struct was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshRenderLayoutElement
nvidia::apex::IofxMeshRenderLayoutElement Member List
This is the complete list of members for nvidia::apex::IofxMeshRenderLayoutElement, including all inherited members.
COLOR_BGRA8 enum value | nvidia::apex::IofxMeshRenderLayoutElement |
COLOR_FLOAT4 enum value | nvidia::apex::IofxMeshRenderLayoutElement |
COLOR_RGBA8 enum value | nvidia::apex::IofxMeshRenderLayoutElement |
DENSITY_FLOAT1 enum value | nvidia::apex::IofxMeshRenderLayoutElement |
Enum enum name | nvidia::apex::IofxMeshRenderLayoutElement |
getFormat(Enum element) | nvidia::apex::IofxMeshRenderLayoutElement | [inline, static]
MAX_COUNT enum value | nvidia::apex::IofxMeshRenderLayoutElement |
POSE_FLOAT3x4 enum value | nvidia::apex::IofxMeshRenderLayoutElement |
POSITION_FLOAT3 enum value | nvidia::apex::IofxMeshRenderLayoutElement |
ROTATION_SCALE_FLOAT3x3 enum value | nvidia::apex::IofxMeshRenderLayoutElement |
USER_DATA_UINT1 enum value | nvidia::apex::IofxMeshRenderLayoutElement |
VELOCITY_LIFE_FLOAT4 enum value | nvidia::apex::IofxMeshRenderLayoutElement |
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxMeshSharedRenderData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshSharedRenderData
Public Attributes
nvidia::apex::IofxMeshSharedRenderData Struct Reference

IofxMeshSharedRenderData stores mesh render data shared by several IOFX Renderables. More...

#include <IofxRenderable.h>

Inheritance diagram for nvidia::apex::IofxMeshSharedRenderData:
nvidia::apex::IofxSharedRenderData

List of all members.

Public Attributes

IofxMeshRenderLayout meshRenderLayout
mesh render layout
UserRenderBuffer * meshRenderBuffer
mesh render buffer

Detailed Description

IofxMeshSharedRenderData stores mesh render data shared by several IOFX Renderables.

Member Data Documentation

UserRenderBuffer* nvidia::apex::IofxMeshSharedRenderData::meshRenderBuffer

mesh render buffer

IofxMeshRenderLayout nvidia::apex::IofxMeshSharedRenderData::meshRenderLayout

mesh render layout

The documentation for this struct was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxMeshSharedRenderData
nvidia::apex::IofxMeshSharedRenderData Member List
This is the complete list of members for nvidia::apex::IofxMeshSharedRenderData, including all inherited members.
activeObjectCount | nvidia::apex::IofxSharedRenderData
maxObjectCount | nvidia::apex::IofxSharedRenderData
meshRenderBuffer | nvidia::apex::IofxMeshSharedRenderData
meshRenderLayout | nvidia::apex::IofxMeshSharedRenderData
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxRenderSemantic Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderSemantic
Public Types
nvidia::apex::IofxRenderSemantic Struct Reference

Enumerates the potential IOFX render semantics. More...

#include <IofxRenderCallback.h>

List of all members.

Public Types

enum Enum {
POSITION = 0,
COLOR,
VELOCITY,
SCALE,
LIFE_REMAIN,
DENSITY,
SUBTEXTURE,
ORIENTATION,
ROTATION,
USER_DATA,
NUM_SEMANTICS
}
Enum of IOFX render semantics. More...

Detailed Description

Enumerates the potential IOFX render semantics.

Member Enumeration Documentation

enum nvidia::apex::IofxRenderSemantic::Enum

Enum of IOFX render semantics.

Enumerator:
POSITION

Position of particle.

COLOR

Color of particle.

VELOCITY

Linear velocity of particle.

SCALE

Scale of particle.

LIFE_REMAIN

1.0 (new) .. 0.0 (dead)

DENSITY

Particle density.

SUBTEXTURE

Sub-texture index of particle.

ORIENTATION

2D particle orientation (angle in radians, CCW in screen plane)

ROTATION

3D particle rotation

USER_DATA

User data - 32 bits (passed from Emitter)

NUM_SEMANTICS

Count of semantics, not a valid semantic.

The documentation for this struct was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxRenderSemantic
nvidia::apex::IofxRenderSemantic Member List
This is the complete list of members for nvidia::apex::IofxRenderSemantic, including all inherited members.
COLOR enum value | nvidia::apex::IofxRenderSemantic
DENSITY enum value | nvidia::apex::IofxRenderSemantic
Enum enum name | nvidia::apex::IofxRenderSemantic
LIFE_REMAIN enum value | nvidia::apex::IofxRenderSemantic
NUM_SEMANTICS enum value | nvidia::apex::IofxRenderSemantic
ORIENTATION enum value | nvidia::apex::IofxRenderSemantic
POSITION enum value | nvidia::apex::IofxRenderSemantic
ROTATION enum value | nvidia::apex::IofxRenderSemantic
SCALE enum value | nvidia::apex::IofxRenderSemantic
SUBTEXTURE enum value | nvidia::apex::IofxRenderSemantic
USER_DATA enum value | nvidia::apex::IofxRenderSemantic
VELOCITY enum value | nvidia::apex::IofxRenderSemantic
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxSharedRenderData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSharedRenderData
Public Attributes
nvidia::apex::IofxSharedRenderData Struct Reference

IofxSharedRenderData stores common render data shared by several IOFX Renderables. More...

#include <IofxRenderable.h>

Inheritance diagram for nvidia::apex::IofxSharedRenderData:
nvidia::apex::IofxMeshSharedRenderData nvidia::apex::IofxSpriteSharedRenderData

List of all members.

Public Attributes

uint32_t | maxObjectCount
maximum number of particles
uint32_t | activeObjectCount
currently active number of particles

Detailed Description

IofxSharedRenderData stores common render data shared by several IOFX Renderables.

Member Data Documentation

uint32_t nvidia::apex::IofxSharedRenderData::activeObjectCount

currently active number of particles

uint32_t nvidia::apex::IofxSharedRenderData::maxObjectCount

maximum number of particles

The documentation for this struct was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSharedRenderData
nvidia::apex::IofxSharedRenderData Member List
This is the complete list of members for nvidia::apex::IofxSharedRenderData, including all inherited members.
activeObjectCount | nvidia::apex::IofxSharedRenderData
maxObjectCount | nvidia::apex::IofxSharedRenderData
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxSpriteRenderData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderData
Public Attributes
nvidia::apex::IofxSpriteRenderData Struct Reference

IofxSpriteRenderData stores sprite render data for one IOFX Renderable. More...

#include <IofxRenderable.h>

Inheritance diagram for nvidia::apex::IofxSpriteRenderData:
nvidia::apex::IofxCommonRenderData

List of all members.

Public Attributes

uint32_t | visibleCount
number of visible particles (if sprite depth sorting is enabled, includes only particles in front of the view frustrum)
const IofxSpriteSharedRenderData * | sharedRenderData
reference to Sprite shared render data

Detailed Description

IofxSpriteRenderData stores sprite render data for one IOFX Renderable.

Member Data Documentation

const IofxSpriteSharedRenderData* nvidia::apex::IofxSpriteRenderData::sharedRenderData

reference to Sprite shared render data

uint32_t nvidia::apex::IofxSpriteRenderData::visibleCount

number of visible particles (if sprite depth sorting is enabled, includes only particles in front of the view frustrum)

The documentation for this struct was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderData
nvidia::apex::IofxSpriteRenderData Member List
This is the complete list of members for nvidia::apex::IofxSpriteRenderData, including all inherited members.
objectCount | nvidia::apex::IofxCommonRenderData
renderResource | nvidia::apex::IofxCommonRenderData
renderResourceName | nvidia::apex::IofxCommonRenderData
renderResourceNameSpace | nvidia::apex::IofxCommonRenderData
sharedRenderData | nvidia::apex::IofxSpriteRenderData
startIndex | nvidia::apex::IofxCommonRenderData
visibleCount | nvidia::apex::IofxSpriteRenderData
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxSpriteRenderLayout Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderLayout
Public Member Functions | Public Attributes | Static Public Attributes
nvidia::apex::IofxSpriteRenderLayout Struct Reference

Describes the layout for sprite rendering. More...

#include <IofxRenderCallback.h>

List of all members.

Public Member Functions

IofxSpriteRenderLayout (void)
void | setDefaults ()
Reset to default values.
bool | isValid (void) const
Check if parameter's values are correct.
bool | isTheSameAs (const IofxSpriteRenderLayout &other) const
Check if this object is the same as other.

Public Attributes

UserRenderBufferDesc | bufferDesc
Render buffer desc.
uint32_t | offsets [IofxSpriteRenderLayoutElement::MAX_COUNT]
Array of the corresponding offsets (in bytes) for each layout element.
uint32_t | stride
The stride between objects in render buffer.
uint32_t | surfaceCount
Number of render surfaces (if zero render buffer is used)
IofxSpriteRenderLayoutSurfaceElement::Enum surfaceElements [MAX_SURFACE_COUNT]
Layout element for each render surface (should be valid for all indices < surfaceCount)
UserRenderSurfaceDesc | surfaceDescs [MAX_SURFACE_COUNT]
Description for each render surface (should be valid for all indices < surfaceCount)

Static Public Attributes

static const uint32_t | MAX_SURFACE_COUNT = 4
Max number of supported render surfaces.

Detailed Description

Describes the layout for sprite rendering.

Constructor & Destructor Documentation

nvidia::apex::IofxSpriteRenderLayout::IofxSpriteRenderLayout ( void ) [inline]

Member Function Documentation

bool nvidia::apex::IofxSpriteRenderLayout::isTheSameAs ( const IofxSpriteRenderLayout & other ) const [inline]

Check if this object is the same as other.

bool nvidia::apex::IofxSpriteRenderLayout::isValid ( void ) const [inline]

Check if parameter's values are correct.

void nvidia::apex::IofxSpriteRenderLayout::setDefaults ( ) [inline]

Reset to default values.

Member Data Documentation

UserRenderBufferDesc nvidia::apex::IofxSpriteRenderLayout::bufferDesc

Render buffer desc.

const uint32_t nvidia::apex::IofxSpriteRenderLayout::MAX_SURFACE_COUNT = 4 [static]

Max number of supported render surfaces.

uint32_t nvidia::apex::IofxSpriteRenderLayout::offsets[IofxSpriteRenderLayoutElement::MAX_COUNT]

Array of the corresponding offsets (in bytes) for each layout element.

uint32_t nvidia::apex::IofxSpriteRenderLayout::stride

The stride between objects in render buffer.

uint32_t nvidia::apex::IofxSpriteRenderLayout::surfaceCount

Number of render surfaces (if zero render buffer is used)

UserRenderSurfaceDesc nvidia::apex::IofxSpriteRenderLayout::surfaceDescs[MAX_SURFACE_COUNT]

Description for each render surface (should be valid for all indices < surfaceCount)

IofxSpriteRenderLayoutSurfaceElement::Enum nvidia::apex::IofxSpriteRenderLayout::surfaceElements[MAX_SURFACE_COUNT]

Layout element for each render surface (should be valid for all indices < surfaceCount)

The documentation for this struct was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderLayout
nvidia::apex::IofxSpriteRenderLayout Member List
This is the complete list of members for nvidia::apex::IofxSpriteRenderLayout, including all inherited members.
bufferDesc | nvidia::apex::IofxSpriteRenderLayout |
IofxSpriteRenderLayout(void) | nvidia::apex::IofxSpriteRenderLayout | [inline]
isTheSameAs(const IofxSpriteRenderLayout &other) const | nvidia::apex::IofxSpriteRenderLayout | [inline]
isValid(void) const | nvidia::apex::IofxSpriteRenderLayout | [inline]
MAX_SURFACE_COUNT | nvidia::apex::IofxSpriteRenderLayout | [static]
offsets | nvidia::apex::IofxSpriteRenderLayout |
setDefaults() | nvidia::apex::IofxSpriteRenderLayout | [inline]
stride | nvidia::apex::IofxSpriteRenderLayout |
surfaceCount | nvidia::apex::IofxSpriteRenderLayout |
surfaceDescs | nvidia::apex::IofxSpriteRenderLayout |
surfaceElements | nvidia::apex::IofxSpriteRenderLayout |
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxSpriteRenderLayoutElement Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderLayoutElement
Public Types | Static Public Member Functions
nvidia::apex::IofxSpriteRenderLayoutElement Struct Reference

Enumerates the potential IOFX mesh render layout elements. More...

#include <IofxRenderCallback.h>

List of all members.

Public Types

enum Enum {
POSITION_FLOAT3,
COLOR_RGBA8,
COLOR_BGRA8,
COLOR_FLOAT4,
VELOCITY_FLOAT3,
SCALE_FLOAT2,
LIFE_REMAIN_FLOAT1,
DENSITY_FLOAT1,
SUBTEXTURE_FLOAT1,
ORIENTATION_FLOAT1,
USER_DATA_UINT1,
MAX_COUNT
}
Enum of IOFX sprite render layout elements. More...

Static Public Member Functions

static PX_INLINE
RenderDataFormat::Enum 		getFormat (Enum element)
Get layout element format.

Detailed Description

Enumerates the potential IOFX mesh render layout elements.

Member Enumeration Documentation

enum nvidia::apex::IofxSpriteRenderLayoutElement::Enum

Enum of IOFX sprite render layout elements.

Enumerator:
POSITION_FLOAT3
COLOR_RGBA8
COLOR_BGRA8
COLOR_FLOAT4
VELOCITY_FLOAT3
SCALE_FLOAT2
LIFE_REMAIN_FLOAT1
DENSITY_FLOAT1
SUBTEXTURE_FLOAT1
ORIENTATION_FLOAT1
USER_DATA_UINT1
MAX_COUNT

Member Function Documentation

static PX_INLINE RenderDataFormat::Enum nvidia::apex::IofxSpriteRenderLayoutElement::getFormat ( Enum element ) [inline, static]

Get layout element format.

The documentation for this struct was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderLayoutElement
nvidia::apex::IofxSpriteRenderLayoutElement Member List
This is the complete list of members for nvidia::apex::IofxSpriteRenderLayoutElement, including all inherited members.
COLOR_BGRA8 enum value | nvidia::apex::IofxSpriteRenderLayoutElement |
COLOR_FLOAT4 enum value | nvidia::apex::IofxSpriteRenderLayoutElement |
COLOR_RGBA8 enum value | nvidia::apex::IofxSpriteRenderLayoutElement |
DENSITY_FLOAT1 enum value | nvidia::apex::IofxSpriteRenderLayoutElement |
Enum enum name | nvidia::apex::IofxSpriteRenderLayoutElement |
getFormat(Enum element) | nvidia::apex::IofxSpriteRenderLayoutElement | [inline, static]
LIFE_REMAIN_FLOAT1 enum value | nvidia::apex::IofxSpriteRenderLayoutElement |
MAX_COUNT enum value | nvidia::apex::IofxSpriteRenderLayoutElement |
ORIENTATION_FLOAT1 enum value | nvidia::apex::IofxSpriteRenderLayoutElement |
POSITION_FLOAT3 enum value | nvidia::apex::IofxSpriteRenderLayoutElement |
SCALE_FLOAT2 enum value | nvidia::apex::IofxSpriteRenderLayoutElement |
SUBTEXTURE_FLOAT1 enum value | nvidia::apex::IofxSpriteRenderLayoutElement |
USER_DATA_UINT1 enum value | nvidia::apex::IofxSpriteRenderLayoutElement |
VELOCITY_FLOAT3 enum value | nvidia::apex::IofxSpriteRenderLayoutElement |
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxSpriteRenderLayoutSurfaceElement Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderLayoutSurfaceElement
Public Types | Static Public Member Functions
nvidia::apex::IofxSpriteRenderLayoutSurfaceElement Struct Reference

Enumerates the potential IOFX sprite render layout surface elements. More...

#include <IofxRenderCallback.h>

List of all members.

Public Types

enum Enum {
POSITION_FLOAT4,
SCALE_ORIENT_SUBTEX_FLOAT4,
COLOR_RGBA8,
COLOR_BGRA8,
COLOR_FLOAT4,
MAX_COUNT
}
Enum of IOFX sprite render layout surface elements. More...

Static Public Member Functions

static PX_INLINE
RenderDataFormat::Enum 		getFormat (Enum element)
Get layout element format.

Detailed Description

Enumerates the potential IOFX sprite render layout surface elements.

Member Enumeration Documentation

enum nvidia::apex::IofxSpriteRenderLayoutSurfaceElement::Enum

Enum of IOFX sprite render layout surface elements.

Enumerator:
POSITION_FLOAT4

float4(POSITION.x, POSITION.y, POSITION.z, 1)

SCALE_ORIENT_SUBTEX_FLOAT4

float4(SCALE.x, SCALE.y, ORIENTATION, SUBTEXTURE)

COLOR_RGBA8
COLOR_BGRA8
COLOR_FLOAT4
MAX_COUNT

Member Function Documentation

static PX_INLINE RenderDataFormat::Enum nvidia::apex::IofxSpriteRenderLayoutSurfaceElement::getFormat ( Enum element ) [inline, static]

Get layout element format.

The documentation for this struct was generated from the following file:
  • IofxRenderCallback.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteRenderLayoutSurfaceElement
nvidia::apex::IofxSpriteRenderLayoutSurfaceElement Member List
This is the complete list of members for nvidia::apex::IofxSpriteRenderLayoutSurfaceElement, including all inherited members.
COLOR_BGRA8 enum value | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
COLOR_FLOAT4 enum value | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
COLOR_RGBA8 enum value | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
Enum enum name | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
getFormat(Enum element) | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement | [inline, static]
MAX_COUNT enum value | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
POSITION_FLOAT4 enum value | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
SCALE_ORIENT_SUBTEX_FLOAT4 enum value | nvidia::apex::IofxSpriteRenderLayoutSurfaceElement |
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: nvidia::apex::IofxSpriteSharedRenderData Struct Reference

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteSharedRenderData
Public Attributes
nvidia::apex::IofxSpriteSharedRenderData Struct Reference

IofxSpriteSharedRenderData stores sprite render data shared by several IOFX Renderables. More...

#include <IofxRenderable.h>

Inheritance diagram for nvidia::apex::IofxSpriteSharedRenderData:
nvidia::apex::IofxSharedRenderData

List of all members.

Public Attributes

IofxSpriteRenderLayout spriteRenderLayout
sprite render layout
UserRenderBuffer * | spriteRenderBuffer
sprite render buffer
UserRenderSurface * | spriteRenderSurfaces [IofxSpriteRenderLayout::MAX_SURFACE_COUNT]
sprite render surfaces

Detailed Description

IofxSpriteSharedRenderData stores sprite render data shared by several IOFX Renderables.

Member Data Documentation

UserRenderBuffer* nvidia::apex::IofxSpriteSharedRenderData::spriteRenderBuffer

sprite render buffer

IofxSpriteRenderLayout nvidia::apex::IofxSpriteSharedRenderData::spriteRenderLayout

sprite render layout

UserRenderSurface* nvidia::apex::IofxSpriteSharedRenderData::spriteRenderSurfaces[IofxSpriteRenderLayout::MAX_SURFACE_COUNT]

sprite render surfaces

The documentation for this struct was generated from the following file:
  • IofxRenderable.h
Generated on Sat Dec 1 2018 10:18:48


APEX IOFX Module: Member List

  • Class List
  • Class Hierarchy
  • Class Members
  • nvidia
  • apex
  • IofxSpriteSharedRenderData
nvidia::apex::IofxSpriteSharedRenderData Member List
This is the complete list of members for nvidia::apex::IofxSpriteSharedRenderData, including all inherited members.
activeObjectCount | nvidia::apex::IofxSharedRenderData
maxObjectCount | nvidia::apex::IofxSharedRenderData
spriteRenderBuffer | nvidia::apex::IofxSpriteSharedRenderData
spriteRenderLayout | nvidia::apex::IofxSpriteSharedRenderData
spriteRenderSurfaces | nvidia::apex::IofxSpriteSharedRenderData
Generated on Sat Dec 1 2018 10:18:48


APEX NvParameterized Schemas: Class List

  • Class List
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
ApexEmitterActorParameters | Describes the NxParameterized::Interface for 'ApexEmitterActorParameters' : This class is used for creating NxApexEmitterActor instances
ApexEmitterAssetParameters | Describes the NxParameterized::Interface for 'ApexEmitterAssetParameters' : APEX Emitter Asset Parameters
AttractorFieldSamplerData | Describes the NxParameterized::Interface for 'AttractorFieldSamplerData' : Containst he asset properties for this attractor field sampler
AttractorFieldSamplerEffect | Describes the NxParameterized::Interface for 'AttractorFieldSamplerEffect' : An attractor effect
AttractorFSActorParams | Describes the NxParameterized::Interface for 'AttractorFSActorParams' :
AttractorFSAssetParams | Describes the NxParameterized::Interface for 'AttractorFSAssetParams' : Contains the asset properties for this Attractor Field Sampler
AttractorFSPreviewParams | Describes the NxParameterized::Interface for 'AttractorFSPreviewParams' :
BasicFSDebugRenderParams | Describes the NxParameterized::Interface for 'BasicFSDebugRenderParams' :
BasicFSModuleParameters | Describes the NxParameterized::Interface for 'BasicFSModuleParameters' : This class is used for initializing the NxModuleFieldBoundary
BasicIOSAssetParam | Describes the NxParameterized::Interface for 'BasicIOSAssetParam' :
BasicIosDebugRenderParams | Describes the NxParameterized::Interface for 'BasicIosDebugRenderParams' :
BasicIosModuleParameters | Describes the NxParameterized::Interface for 'BasicIosModuleParameters' : This class is used for initializing the NxModuleBasicIos
SurfaceBufferParameters::Buffer |
BufferF32x1 | Describes the NxParameterized::Interface for 'BufferF32x1' :
BufferF32x2 | Describes the NxParameterized::Interface for 'BufferF32x2' :
BufferF32x3 | Describes the NxParameterized::Interface for 'BufferF32x3' :
BufferF32x4 | Describes the NxParameterized::Interface for 'BufferF32x4' :
VertexBufferParameters::Buffers |
BufferU16x1 | Describes the NxParameterized::Interface for 'BufferU16x1' :
BufferU16x2 | Describes the NxParameterized::Interface for 'BufferU16x2' :
BufferU16x3 | Describes the NxParameterized::Interface for 'BufferU16x3' :
BufferU16x4 | Describes the NxParameterized::Interface for 'BufferU16x4' :
BufferU32x1 | Describes the NxParameterized::Interface for 'BufferU32x1' :
BufferU32x2 | Describes the NxParameterized::Interface for 'BufferU32x2' :
BufferU32x3 | Describes the NxParameterized::Interface for 'BufferU32x3' :
BufferU32x4 | Describes the NxParameterized::Interface for 'BufferU32x4' :
BufferU8x1 | Describes the NxParameterized::Interface for 'BufferU8x1' :
BufferU8x2 | Describes the NxParameterized::Interface for 'BufferU8x2' :
BufferU8x3 | Describes the NxParameterized::Interface for 'BufferU8x3' :
BufferU8x4 | Describes the NxParameterized::Interface for 'BufferU8x4' :
CachedOverlaps | Describes the NxParameterized::Interface for 'CachedOverlaps' :
ClothingActorParam | Describes the NxParameterized::Interface for 'ClothingActorParam' :
ClothingAssetParameters | Describes the NxParameterized::Interface for 'ClothingAssetParameters' :
ClothingCookedParam | Describes the NxParameterized::Interface for 'ClothingCookedParam' :
ClothingCookedPhysX3Param | Describes the NxParameterized::Interface for 'ClothingCookedPhysX3Param' :
ClothingDebugRenderParams | Describes the NxParameterized::Interface for 'ClothingDebugRenderParams' :
ClothingGraphicalLodParameters | Describes the NxParameterized::Interface for 'ClothingGraphicalLodParameters' :
ClothingMaterialLibraryParameters | Describes the NxParameterized::Interface for 'ClothingMaterialLibraryParameters' :
ClothingModuleParameters | Describes the NxParameterized::Interface for 'ClothingModuleParameters' : This class is used for initializing the NxModuleClothing
ClothingPhysicalMeshParameters | Describes the NxParameterized::Interface for 'ClothingPhysicalMeshParameters' :
ClothingPreviewParam | Describes the NxParameterized::Interface for 'ClothingPreviewParam' :
ColorVsDensityCompositeModifierParams | Describes the NxParameterized::Interface for 'ColorVsDensityCompositeModifierParams' : ColorVsDensityComposite modifier parameters
ColorVsDensityModifierParams | Describes the NxParameterized::Interface for 'ColorVsDensityModifierParams' : ColorVsDensity modifier parameters
ColorVsLifeCompositeModifierParams | Describes the NxParameterized::Interface for 'ColorVsLifeCompositeModifierParams' : ColorVsLifeComposite modifier parameters
ColorVsLifeModifierParams | Describes the NxParameterized::Interface for 'ColorVsLifeModifierParams' : ColorVsLife modifier parameters
ColorVsTemperatureCompositeModifierParams | Describes the NxParameterized::Interface for 'ColorVsTemperatureCompositeModifierParams' : ColorVsTemperatureComposite modifier parameters
ColorVsTemperatureModifierParams | Describes the NxParameterized::Interface for 'ColorVsTemperatureModifierParams' : ColorVsTemperature modifier parameters
ColorVsVelocityCompositeModifierParams | Describes the NxParameterized::Interface for 'ColorVsVelocityCompositeModifierParams' : ColorVsVelocityComposite modifier parameters
ColorVsVelocityModifierParams | Describes the NxParameterized::Interface for 'ColorVsVelocityModifierParams' : ColorVsVelocity modifier parameters
MeshIofxParameters::ContinuousModifierList |
SpriteIofxParameters::ContinuousModifierList |
ConvexHullParameters | Describes the NxParameterized::Interface for 'ConvexHullParameters' :
ClothingAssetParameters::CookedData |
DebugColorParams | Describes the NxParameterized::Interface for 'DebugColorParams' :
DebugRenderParams | Describes the NxParameterized::Interface for 'DebugRenderParams' :
DestructibleActorChunks | Describes the NxParameterized::Interface for 'DestructibleActorChunks' :
DestructibleActorParam | Describes the NxParameterized::Interface for 'DestructibleActorParam' :
DestructibleActorState | Describes the NxParameterized::Interface for 'DestructibleActorState' :
DestructibleAssetCollisionDataSet | Describes the NxParameterized::Interface for 'DestructibleAssetCollisionDataSet' :
DestructibleAssetParameters | Describes the NxParameterized::Interface for 'DestructibleAssetParameters' :
DestructibleDebugRenderParams | Describes the NxParameterized::Interface for 'DestructibleDebugRenderParams' :
DestructibleModuleParameters | Describes the NxParameterized::Interface for 'DestructibleModuleParameters' : This class is used for initializing the NxModuleDestructible
DestructiblePreviewParam | Describes the NxParameterized::Interface for 'DestructiblePreviewParam' :
EffectPackageActorParams | Describes the NxParameterized::Interface for 'EffectPackageActorParams' : The individual effect package actor properties
EffectPackageAssetParams | Describes the NxParameterized::Interface for 'EffectPackageAssetParams' : The effect package asset
EffectPackageData | Describes the NxParameterized::Interface for 'EffectPackageData' : Contains the Effect Package Properties
EffectPackageDatabaseParams | Describes the NxParameterized::Interface for 'EffectPackageDatabaseParams' : The collection of all effect packages
EffectPackageEmitterDatabaseParams | Describes the NxParameterized::Interface for 'EffectPackageEmitterDatabaseParams' : The collection of all emitter assets
EffectPackageFieldSamplerDatabaseParams | Describes the NxParameterized::Interface for 'EffectPackageFieldSamplerDatabaseParams' : The collection of all field sampler assets
EffectPackageGraphicsMaterialsParams | Describes the NxParameterized::Interface for 'EffectPackageGraphicsMaterialsParams' : The collection of graphics and volumetric material assets
EffectPackageIOFXDatabaseParams | Describes the NxParameterized::Interface for 'EffectPackageIOFXDatabaseParams' : The collection of graphics effect assets (IOFX)
EffectPackageIOSDatabaseParams | Describes the NxParameterized::Interface for 'EffectPackageIOSDatabaseParams' : The collection of particle simulation assets (IOS)
EffectPackageAssetParams::Effects |
EmitterAssetPreviewParameters | Describes the NxParameterized::Interface for 'EmitterAssetPreviewParameters' : This class is used for creating APEX Emitter Preview instances (shaped, ground, or impact emitters)
EmitterData | Describes the NxParameterized::Interface for 'EmitterData' : Contains the asset properties for this emitter
EmitterDebugRenderParams | Describes the NxParameterized::Interface for 'EmitterDebugRenderParams' : This class contains debug rendering parameters for the emitter module
EmitterEffect | Describes the NxParameterized::Interface for 'EmitterEffect' : An emitter effect
EmitterGeomBoxParams | Describes the NxParameterized::Interface for 'EmitterGeomBoxParams' :
EmitterGeomCylinderParams | Describes the NxParameterized::Interface for 'EmitterGeomCylinderParams' :
EmitterGeomExplicitParams | Describes the NxParameterized::Interface for 'EmitterGeomExplicitParams' :
EmitterGeomSphereParams | Describes the NxParameterized::Interface for 'EmitterGeomSphereParams' :
EmitterGeomSphereShellParams | Describes the NxParameterized::Interface for 'EmitterGeomSphereShellParams' :
EmitterModuleParameters | Describes the NxParameterized::Interface for 'EmitterModuleParameters' : This class is used for initializing the NxModuleEmitter
ImpactEmitterAssetParameters::EventSetList |
FieldSamplerModuleParameters | Describes the NxParameterized::Interface for 'FieldSamplerModuleParameters' : This class is used for initializing the NxModuleFieldBoundary
FieldSamplerPhysXMonitorParams | Describes the NxParameterized::Interface for 'FieldSamplerPhysXMonitorParams' :
EffectPackageFieldSamplerDatabaseParams::FieldSamplers |
FluidParticleSystemParams | Describes the NxParameterized::Interface for 'FluidParticleSystemParams' :
ForceFieldActorParams | Describes the NxParameterized::Interface for 'ForceFieldActorParams' :
ForceFieldAssetParams | Describes the NxParameterized::Interface for 'ForceFieldAssetParams' : Contains the asset properties for ForceField
ForceFieldAssetPreviewParams | Describes the NxParameterized::Interface for 'ForceFieldAssetPreviewParams' :
ForceFieldData | Describes the NxParameterized::Interface for 'ForceFieldData' : Contains the asset properties for this force field sampler
ForceFieldDebugRenderParams | Describes the NxParameterized::Interface for 'ForceFieldDebugRenderParams' :
ForceFieldEffect | Describes the NxParameterized::Interface for 'ForceFieldEffect' : A forcefield effect
ForceFieldFalloffParams | Describes the NxParameterized::Interface for 'ForceFieldFalloffParams' :
ForceFieldAssetParams::ForceFieldKernelType |
ForceFieldModuleParams | Describes the NxParameterized::Interface for 'ForceFieldModuleParams' :
ForceFieldNoiseParams | Describes the NxParameterized::Interface for 'ForceFieldNoiseParams' :
GenericForceFieldKernelParams | Describes the NxParameterized::Interface for 'GenericForceFieldKernelParams' : Generic force field kernel is needed for backward compatibility with NxForceFieldKernel (PhysX 2.8.4)
SubstanceSourceAssetParams::GeometryType |
SubstanceSourceActorParams::GeometryType |
VelocitySourceActorParams::GeometryType |
ApexEmitterAssetParameters::GeometryType |
VelocitySourceAssetParams::GeometryType |
HeatSourceActorParams::GeometryType |
HeatSourceAssetParams::GeometryType |
GraphicsEffectData | Describes the NxParameterized::Interface for 'GraphicsEffectData' : Contains the asset properties for this graphics effect (IOFX)
GraphicsMaterialData | Describes the NxParameterized::Interface for 'GraphicsMaterialData' : Contains the asset properties for this graphics material
EffectPackageGraphicsMaterialsParams::GraphicsMaterials |
GroundEmitterActorParameters | Describes the NxParameterized::Interface for 'GroundEmitterActorParameters' : This class is used for creating NxGroundEmitterActor instances
GroundEmitterAssetParameters | Describes the NxParameterized::Interface for 'GroundEmitterAssetParameters' : This class is parameter storage for the NxGroundEmitterAsset
HeatSourceActorParams | Describes the NxParameterized::Interface for 'HeatSourceActorParams' :
HeatSourceAssetParams | Describes the NxParameterized::Interface for 'HeatSourceAssetParams' : Contains the asset properties for this HeatSource
HeatSourceData | Describes the NxParameterized::Interface for 'HeatSourceData' : Contains the asset properties for this heat source asset
HeatSourceEffect | Describes the NxParameterized::Interface for 'HeatSourceEffect' : A heat source effect
HeatSourceGeomBoxParams | Describes the NxParameterized::Interface for 'HeatSourceGeomBoxParams' : Contains the asset properties for this HeatSource Geometry
HeatSourceGeomSphereParams | Describes the NxParameterized::Interface for 'HeatSourceGeomSphereParams' :
HeatSourcePreviewParams | Describes the NxParameterized::Interface for 'HeatSourcePreviewParams' :
ImpactEmitterActorParameters | Describes the NxParameterized::Interface for 'ImpactEmitterActorParameters' : This class is used for creating NxImpactEmitterActor instances
ImpactEmitterAssetParameters | Describes the NxParameterized::Interface for 'ImpactEmitterAssetParameters' : This class is parameter storage for the Impact Emitter
ImpactExplosionEvent | Describes the NxParameterized::Interface for 'ImpactExplosionEvent' :
ImpactObjectEvent | Describes the NxParameterized::Interface for 'ImpactObjectEvent' :
InitialColorModifierParams | Describes the NxParameterized::Interface for 'InitialColorModifierParams' : InitialColor modifier parameters
IofxAssetParameters | Describes the NxParameterized::Interface for 'IofxAssetParameters' : Contains the asset properties for an IOFX
IofxDebugRenderParams | Describes the NxParameterized::Interface for 'IofxDebugRenderParams' :
IofxModuleParameters | Describes the NxParameterized::Interface for 'IofxModuleParameters' : This class is used for initializing the NxModuleIofx
IofxAssetParameters::IofxType |
ParticleSimulationData::IOS |
JetFieldSamplerData | Describes the NxParameterized::Interface for 'JetFieldSamplerData' : Contains the asset properties for this jet field sampler
JetFieldSamplerEffect | Describes the NxParameterized::Interface for 'JetFieldSamplerEffect' : A jet field sampler effect
JetFSActorParams | Describes the NxParameterized::Interface for 'JetFSActorParams' :
JetFSAssetParams | Describes the NxParameterized::Interface for 'JetFSAssetParams' : Contains the asset properties for this Jet Field Sampler
JetFSPreviewParams | Describes the NxParameterized::Interface for 'JetFSPreviewParams' :
MeshCookedCollisionStream | Describes the NxParameterized::Interface for 'MeshCookedCollisionStream' :
MeshCookedCollisionStreamsAtScale | Describes the NxParameterized::Interface for 'MeshCookedCollisionStreamsAtScale' :
MeshIofxParameters | Describes the NxParameterized::Interface for 'MeshIofxParameters' :
DebugRenderParams::ModuleName |
NoiseFieldSamplerData | Describes the NxParameterized::Interface for 'NoiseFieldSamplerData' : Contains the asset properties for this noise field sampler
NoiseFieldSamplerEffect | Describes the NxParameterized::Interface for 'NoiseFieldSamplerEffect' : A noise field sampler effect
NoiseFSActorParams | Describes the NxParameterized::Interface for 'NoiseFSActorParams' :
NoiseFSAssetParams | Describes the NxParameterized::Interface for 'NoiseFSAssetParams' : Contains the asset properties for this Noise Field Sampler
NoiseFSPreviewParams | Describes the NxParameterized::Interface for 'NoiseFSPreviewParams' :
OrientAlongVelocityModifierParams | Describes the NxParameterized::Interface for 'OrientAlongVelocityModifierParams' : OrientAlongVelocity modifier parameters
OrientScaleAlongScreenVelocityModifierParams | Describes the NxParameterized::Interface for 'OrientScaleAlongScreenVelocityModifierParams' : OrientScaleAlongScreenVelocity modifier parameters
ParticleIosAssetParam | Describes the NxParameterized::Interface for 'ParticleIosAssetParam' : Contains the asset properties for an IOS
ParticleIosDebugRenderParams | Describes the NxParameterized::Interface for 'ParticleIosDebugRenderParams' :
ParticleIosModuleParameters | Describes the NxParameterized::Interface for 'ParticleIosModuleParameters' : This class is used for initializing the NxModuleParticleIos
ParticlesDebugRenderParams | Describes the NxParameterized::Interface for 'ParticlesDebugRenderParams' :
ParticleSimulationData | Describes the NxParameterized::Interface for 'ParticleSimulationData' : Contains the asset properties for this particle simulation (IOS)
ParticlesModuleParameters | Describes the NxParameterized::Interface for 'ParticlesModuleParameters' : This class is used for initializing the NxModuleParticles
ParticleIosAssetParam::ParticleType |
RadialForceFieldKernelParams | Describes the NxParameterized::Interface for 'RadialForceFieldKernelParams' : Radial force field kernel correspond to APEX 1.3 Force Field implementation
RandomRotationModifierParams | Describes the NxParameterized::Interface for 'RandomRotationModifierParams' : RandomRotation modifier parameters
RandomScaleModifierParams | Describes the NxParameterized::Interface for 'RandomScaleModifierParams' : RandomScale modifier parameters
RandomSubtextureModifierParams | Describes the NxParameterized::Interface for 'RandomSubtextureModifierParams' : RandomSubtexture modifier parameters
RenderMeshAssetParameters | Describes the NxParameterized::Interface for 'RenderMeshAssetParameters' :
RigidBodyEffect | Describes the NxParameterized::Interface for 'RigidBodyEffect' : An effect comprised of a primitive rigid body shape
RotationModifierParams | Describes the NxParameterized::Interface for 'RotationModifierParams' : Rotation modifier parameters
RotationRateModifierParams | Describes the NxParameterized::Interface for 'RotationRateModifierParams' : RotationRate modifier parameters
RotationRateVsLifeModifierParams | Describes the NxParameterized::Interface for 'RotationRateVsLifeModifierParams' : RotationRateVsLife modifier parameters
ScaleAlongVelocityModifierParams | Describes the NxParameterized::Interface for 'ScaleAlongVelocityModifierParams' : ScaleAlongVelocity modifier parameters
ScaleByMassModifierParams | Describes the NxParameterized::Interface for 'ScaleByMassModifierParams' : ScaleByMass modifier parameters
ScaleVsCameraDistance2DModifierParams | Describes the NxParameterized::Interface for 'ScaleVsCameraDistance2DModifierParams' : ScaleVsCameraDistance2D modifier parameters
ScaleVsCameraDistance3DModifierParams | Describes the NxParameterized::Interface for 'ScaleVsCameraDistance3DModifierParams' : ScaleVsCameraDistance3D modifier parameters
ScaleVsCameraDistanceModifierParams | Describes the NxParameterized::Interface for 'ScaleVsCameraDistanceModifierParams' : ScaleVsCameraDistance modifier parameters
ScaleVsDensity2DModifierParams | Describes the NxParameterized::Interface for 'ScaleVsDensity2DModifierParams' : ScaleVsDensity2D modifier parameters
ScaleVsDensity3DModifierParams | Describes the NxParameterized::Interface for 'ScaleVsDensity3DModifierParams' : ScaleVsDensity3D modifier parameters
ScaleVsDensityModifierParams | Describes the NxParameterized::Interface for 'ScaleVsDensityModifierParams' : ScaleVsDensity modifier parameters
ScaleVsLife2DModifierParams | Describes the NxParameterized::Interface for 'ScaleVsLife2DModifierParams' : ScaleVsLife2D modifier parameters
ScaleVsLife3DModifierParams | Describes the NxParameterized::Interface for 'ScaleVsLife3DModifierParams' : ScaleVsLife3D modifier parameters
ScaleVsLifeModifierParams | Describes the NxParameterized::Interface for 'ScaleVsLifeModifierParams' : ScaleVsLife modifier parameters
ScaleVsTemperature2DModifierParams | Describes the NxParameterized::Interface for 'ScaleVsTemperature2DModifierParams' : ScaleVsTemperature2D modifier parameters
ScaleVsTemperature3DModifierParams | Describes the NxParameterized::Interface for 'ScaleVsTemperature3DModifierParams' : ScaleVsTemperature3D modifier parameters
ScaleVsTemperatureModifierParams | Describes the NxParameterized::Interface for 'ScaleVsTemperatureModifierParams' : ScaleVsTemperature modifier parameters
SimpleParticleSystemParams | Describes the NxParameterized::Interface for 'SimpleParticleSystemParams' :
SimpleScaleModifierParams | Describes the NxParameterized::Interface for 'SimpleScaleModifierParams' : SimpleScale modifier parameters
MeshIofxParameters::SpawnModifierList |
SpriteIofxParameters::SpawnModifierList |
SpriteIofxParameters | Describes the NxParameterized::Interface for 'SpriteIofxParameters' :
SubmeshParameters | Describes the NxParameterized::Interface for 'SubmeshParameters' :
SubstanceSourceActorParams | Describes the NxParameterized::Interface for 'SubstanceSourceActorParams' :
SubstanceSourceAssetParams | Describes the NxParameterized::Interface for 'SubstanceSourceAssetParams' : Contains the asset properties for this SubstanceSource
SubstanceSourceData | Describes the NxParameterized::Interface for 'SubstanceSourceData' : Contains the asset properties for this substance source
SubstanceSourceEffect | Describes the NxParameterized::Interface for 'SubstanceSourceEffect' : A substance source effect
SubtextureVsLifeModifierParams | Describes the NxParameterized::Interface for 'SubtextureVsLifeModifierParams' : SubtextureVsLife modifier parameters
SurfaceBufferParameters | Describes the NxParameterized::Interface for 'SurfaceBufferParameters' :
SurfaceTraceParameters | Describes the NxParameterized::Interface for 'SurfaceTraceParameters' :
SurfaceTraceSetParameters | Describes the NxParameterized::Interface for 'SurfaceTraceSetParameters' :
TurbulenceFieldSamplerData | Describes the NxParameterized::Interface for 'TurbulenceFieldSamplerData' : Contains the asset properties for this turbulence field sampler
TurbulenceFieldSamplerEffect | Describes the NxParameterized::Interface for 'TurbulenceFieldSamplerEffect' : A turbulence effect
TurbulenceFSActorParams | Describes the NxParameterized::Interface for 'TurbulenceFSActorParams' :
TurbulenceFSAssetParams | Describes the NxParameterized::Interface for 'TurbulenceFSAssetParams' : Contains the asset properties for this Turbulence field sampler
TurbulenceFSDebugRenderParams | Describes the NxParameterized::Interface for 'TurbulenceFSDebugRenderParams' :
TurbulenceFSModuleParameters | Describes the NxParameterized::Interface for 'TurbulenceFSModuleParameters' : This class is used for initializing the NxModuleFieldBoundary
TurbulenceFSPreviewParams | Describes the NxParameterized::Interface for 'TurbulenceFSPreviewParams' :
VelocitySourceActorParams | Describes the NxParameterized::Interface for 'VelocitySourceActorParams' :
VelocitySourceAssetParams | Describes the NxParameterized::Interface for 'VelocitySourceAssetParams' : Contains the asset properties for this VelocitySource
VelocitySourceData | Describes the NxParameterized::Interface for 'VelocitySourceData' : Contains the asset properties for this velocity source
VelocitySourceEffect | Describes the NxParameterized::Interface for 'VelocitySourceEffect' : A velocity source effect
VelocitySourcePreviewParams | Describes the NxParameterized::Interface for 'VelocitySourcePreviewParams' :
VertexBufferParameters | Describes the NxParameterized::Interface for 'VertexBufferParameters' :
VertexFormatParameters | Describes the NxParameterized::Interface for 'VertexFormatParameters' :
ViewDirectionSortingModifierParams | Describes the NxParameterized::Interface for 'ViewDirectionSortingModifierParams' : ViewDirectionSorting modifier parameters
VolumeRenderMaterialData | Describes the NxParameterized::Interface for 'VolumeRenderMaterialData' : Contains the volume render material properties for this asset
VortexFieldSamplerData | Describes the NxParameterized::Interface for 'VortexFieldSamplerData' : Contains the asset properties for this vortex field sampler
VortexFieldSamplerEffect | Describes the NxParameterized::Interface for 'VortexFieldSamplerEffect' : A vortex field sampler effect
VortexFSActorParams | Describes the NxParameterized::Interface for 'VortexFSActorParams' :
VortexFSAssetParams | Describes the NxParameterized::Interface for 'VortexFSAssetParams' : Contains the asset properties for this Vortex Field Sampler
VortexFSPreviewParams | Describes the NxParameterized::Interface for 'VortexFSPreviewParams' :
WindFieldSamplerData | Describes the NxParameterized::Interface for 'WindFieldSamplerData' : Contains the asset properties for this wind field sampler
WindFieldSamplerEffect | Describes the NxParameterized::Interface for 'WindFieldSamplerEffect' : A wind field sampler effect
WindFSActorParams | Describes the NxParameterized::Interface for 'WindFSActorParams' :
WindFSAssetParams | Describes the NxParameterized::Interface for 'WindFSAssetParams' : Contains the asset properties for this Wind Field Sampler
WindFSPreviewParams | Describes the NxParameterized::Interface for 'WindFSPreviewParams' :
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Index

  • Class List
  • Class Members
Class Index
A | B | C | D | E | F | G | H | I | J | M | N | O | P | R | S | T | V | W
A
ColorVsLifeModifierParams ForceFieldActorParams JetFSAssetParams ScaleVsTemperature2DModifierParams
ApexEmitterActorParameters ColorVsTemperatureCompositeModifierParams ForceFieldAssetParams JetFSPreviewParams ScaleVsTemperature3DModifierParams
ApexEmitterAssetParameters ColorVsTemperatureModifierParams ForceFieldAssetPreviewParams
M
ScaleVsTemperatureModifierParams
AttractorFieldSamplerData ColorVsVelocityCompositeModifierParams ForceFieldData MeshCookedCollisionStream SimpleParticleSystemParams
AttractorFieldSamplerEffect ColorVsVelocityModifierParams ForceFieldDebugRenderParams MeshCookedCollisionStreamsAtScale SimpleScaleModifierParams
AttractorFSActorParams SpriteIofxParameters::ContinuousModifierList ForceFieldEffect MeshIofxParameters SpriteIofxParameters::SpawnModifierList
AttractorFSAssetParams MeshIofxParameters::ContinuousModifierList ForceFieldFalloffParams DebugRenderParams::ModuleName MeshIofxParameters::SpawnModifierList
AttractorFSPreviewParams ConvexHullParameters ForceFieldAssetParams::ForceFieldKernelType
N
SpriteIofxParameters
B
ClothingAssetParameters::CookedData ForceFieldModuleParams NoiseFieldSamplerData SubmeshParameters
BasicFSDebugRenderParams
D
ForceFieldNoiseParams NoiseFieldSamplerEffect SubstanceSourceActorParams
BasicFSModuleParameters DebugColorParams
G
NoiseFSActorParams SubstanceSourceAssetParams
BasicIOSAssetParam DebugRenderParams GenericForceFieldKernelParams NoiseFSAssetParams SubstanceSourceData
BasicIosDebugRenderParams DestructibleActorChunks HeatSourceAssetParams::GeometryType NoiseFSPreviewParams SubstanceSourceEffect
BasicIosModuleParameters DestructibleActorParam HeatSourceActorParams::GeometryType
O
SubtextureVsLifeModifierParams
SurfaceBufferParameters::Buffer DestructibleActorState VelocitySourceAssetParams::GeometryType OrientAlongVelocityModifierParams SurfaceBufferParameters
BufferF32x1 DestructibleAssetCollisionDataSet ApexEmitterAssetParameters::GeometryType OrientScaleAlongScreenVelocityModifierParams SurfaceTraceParameters
BufferF32x2 DestructibleAssetParameters VelocitySourceActorParams::GeometryType
P
SurfaceTraceSetParameters
BufferF32x3 DestructibleDebugRenderParams SubstanceSourceActorParams::GeometryType ParticleIosAssetParam
T
BufferF32x4 DestructibleModuleParameters SubstanceSourceAssetParams::GeometryType ParticleIosDebugRenderParams TurbulenceFieldSamplerData
VertexBufferParameters::Buffers DestructiblePreviewParam GraphicsEffectData ParticleIosModuleParameters TurbulenceFieldSamplerEffect
BufferU16x1
E
GraphicsMaterialData ParticlesDebugRenderParams TurbulenceFSActorParams
BufferU16x2 EffectPackageActorParams EffectPackageGraphicsMaterialsParams::GraphicsMaterials ParticleSimulationData TurbulenceFSAssetParams
BufferU16x3 EffectPackageAssetParams GroundEmitterActorParameters ParticlesModuleParameters TurbulenceFSDebugRenderParams
BufferU16x4 EffectPackageData GroundEmitterAssetParameters ParticleIosAssetParam::ParticleType TurbulenceFSModuleParameters
BufferU32x1 EffectPackageDatabaseParams
H
R
TurbulenceFSPreviewParams
BufferU32x2 EffectPackageEmitterDatabaseParams HeatSourceActorParams RadialForceFieldKernelParams
V
BufferU32x3 EffectPackageFieldSamplerDatabaseParams HeatSourceAssetParams RandomRotationModifierParams VelocitySourceActorParams
BufferU32x4 EffectPackageGraphicsMaterialsParams HeatSourceData RandomScaleModifierParams VelocitySourceAssetParams
BufferU8x1 EffectPackageIOFXDatabaseParams HeatSourceEffect RandomSubtextureModifierParams VelocitySourceData
BufferU8x2 EffectPackageIOSDatabaseParams HeatSourceGeomBoxParams RenderMeshAssetParameters VelocitySourceEffect
BufferU8x3 EffectPackageAssetParams::Effects HeatSourceGeomSphereParams RigidBodyEffect VelocitySourcePreviewParams
BufferU8x4 EmitterAssetPreviewParameters HeatSourcePreviewParams RotationModifierParams VertexBufferParameters
C
EmitterData
I
RotationRateModifierParams VertexFormatParameters
CachedOverlaps EmitterDebugRenderParams ImpactEmitterActorParameters RotationRateVsLifeModifierParams ViewDirectionSortingModifierParams
ClothingActorParam EmitterEffect ImpactEmitterAssetParameters
S
VolumeRenderMaterialData
ClothingAssetParameters EmitterGeomBoxParams ImpactExplosionEvent ScaleAlongVelocityModifierParams VortexFieldSamplerData
ClothingCookedParam EmitterGeomCylinderParams ImpactObjectEvent ScaleByMassModifierParams VortexFieldSamplerEffect
ClothingCookedPhysX3Param EmitterGeomExplicitParams InitialColorModifierParams ScaleVsCameraDistance2DModifierParams VortexFSActorParams
ClothingDebugRenderParams EmitterGeomSphereParams IofxAssetParameters ScaleVsCameraDistance3DModifierParams VortexFSAssetParams
ClothingGraphicalLodParameters EmitterGeomSphereShellParams IofxDebugRenderParams ScaleVsCameraDistanceModifierParams VortexFSPreviewParams
ClothingMaterialLibraryParameters EmitterModuleParameters IofxModuleParameters ScaleVsDensity2DModifierParams
W
ClothingModuleParameters ImpactEmitterAssetParameters::EventSetList IofxAssetParameters::IofxType ScaleVsDensity3DModifierParams WindFieldSamplerData
ClothingPhysicalMeshParameters
F
ParticleSimulationData::IOS ScaleVsDensityModifierParams WindFieldSamplerEffect
ClothingPreviewParam FieldSamplerModuleParameters
J
ScaleVsLife2DModifierParams WindFSActorParams
ColorVsDensityCompositeModifierParams FieldSamplerPhysXMonitorParams JetFieldSamplerData ScaleVsLife3DModifierParams WindFSAssetParams
ColorVsDensityModifierParams EffectPackageFieldSamplerDatabaseParams::FieldSamplers JetFieldSamplerEffect ScaleVsLifeModifierParams WindFSPreviewParams
ColorVsLifeCompositeModifierParams FluidParticleSystemParams JetFSActorParams
A | B | C | D | E | F | G | H | I | J | M | N | O | P | R | S | T | V | W
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
params.h [code]
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- a -

  • actorChunks : DestructibleActorState
  • actorDescTemplate.actorCollisionGroup : DestructibleActorParam
  • actorDescTemplate.compartment : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_IGNORE_PAIR : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_CONTACT_MODIFICATION : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_FORCES : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH_FORCE_THRESHOLD : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_IMPACT : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_ROLL : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_SLIDE : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH_FORCE_THRESHOLD : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH_FORCE_THRESHOLD : DestructibleActorParam
  • actorDescTemplate.density : DestructibleActorParam
  • actorDescTemplate.dominanceGroup : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_CONTACT_MODIFICATION : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_DISABLE_COLLISION : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_DISABLE_RESPONSE : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_FLUID_DISABLE_COLLISION : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_FORCE_CONE_FRICTION : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_LOCK_COM : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_USER_ACTOR_PAIR_FILTERING : DestructibleActorParam
  • actorDescTemplate.forceFieldMaterial : DestructibleActorParam
  • actorDescTemplate.name : ClothingActorParam , DestructibleActorParam
  • actorDescTemplate.userData : ClothingActorParam , DestructibleActorParam
  • actorParameters : DestructibleActorState
  • Actors : ClothingDebugRenderParams
  • actorScale : ClothingActorParam , ClothingCookedParam
  • actorTransforms[] : DestructibleAssetParameters
  • adjacentFaces[] : ConvexHullParameters
  • allowAdaptiveTargetFrequency : ClothingActorParam
  • allowApexWorkBetweenSubsteps : ClothingModuleParameters
  • allowAsyncCooking : ClothingModuleParameters
  • angleRange.max : ImpactObjectEvent
  • angleRange.min : ImpactObjectEvent
  • AngularDamping : RigidBodyEffect
  • angularVelocityClamp : TurbulenceFSAssetParams
  • angularVelocityMultiplier : TurbulenceFSAssetParams
  • apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_NAME : EmitterDebugRenderParams
  • apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_POSE : EmitterDebugRenderParams
  • apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR : EmitterDebugRenderParams
  • apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_NAME : EmitterDebugRenderParams
  • apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_POSE : EmitterDebugRenderParams
  • apexEmitterParameters.VISUALIZE_TOTAL_INJECTED_AABB : EmitterDebugRenderParams
  • ApplicationMaterialName : VolumeRenderMaterialData , GraphicsMaterialData
  • assetName : DestructibleAssetCollisionDataSet
  • asyncFetchResults : ClothingModuleParameters
  • attachRelativePose : ApexEmitterActorParameters
  • attachRelativePosition : GroundEmitterActorParameters
  • AttractorFieldSampler : AttractorFieldSamplerData , AttractorFieldSamplerEffect
  • averageDensity : SubstanceSourceActorParams , SubstanceSourceAssetParams
  • averageEndDistance : JetFSAssetParams
  • averageStartDistance : JetFSAssetParams
  • averageTemperature : HeatSourceAssetParams , HeatSourceActorParams
  • averageVelocity : VelocitySourceActorParams , VelocitySourceAssetParams
  • avgSimFrequencyWindow : ClothingModuleParameters
  • axis : VortexFSAssetParams
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- j -

  • JET_FS_FIELD_SCALE : BasicFSDebugRenderParams
  • JetFieldSampler : JetFieldSamplerEffect , JetFieldSamplerData
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- k -

  • keepPreviousFrameBoneBuffer : DestructibleActorParam
  • keepVisibleBonesPacked : DestructibleActorParam
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- l -

  • LengthFibers : ClothingDebugRenderParams
  • lifeRange.max : ImpactObjectEvent
  • lifeRange.min : ImpactObjectEvent
  • lifetime : ForceFieldAssetParams
  • lifetimeRange.max : ApexEmitterAssetParameters , GroundEmitterAssetParameters
  • lifetimeRange.min : GroundEmitterAssetParameters , ApexEmitterAssetParameters
  • liftStrength : VortexFSAssetParams
  • LightBlue : DebugColorParams
  • LightColor : VolumeRenderMaterialData
  • LightDir : VolumeRenderMaterialData
  • LightGray : DebugColorParams
  • LightGreen : DebugColorParams
  • LightRed : DebugColorParams
  • LinearDamping : RigidBodyEffect
  • linearVelocityClamp : TurbulenceFSAssetParams
  • linearVelocityMultiplier : TurbulenceFSAssetParams
  • localSpaceSim : ClothingActorParam
  • lod : ClothingGraphicalLodParameters , DestructibleActorState
  • LodBenefits : DebugRenderParams
  • LodDistanceScale : DebugRenderParams
  • lodParamDesc.bias : ApexEmitterAssetParameters , ImpactObjectEvent
  • lodParamDesc.distanceWeight : ApexEmitterAssetParameters , ImpactObjectEvent
  • lodParamDesc.lifeWeight : ApexEmitterAssetParameters , ImpactObjectEvent
  • lodParamDesc.maxDistance : ApexEmitterAssetParameters , ImpactObjectEvent
  • lodParamDesc.separationWeight : ApexEmitterAssetParameters , ImpactObjectEvent
  • lodParamDesc.speedWeight : ApexEmitterAssetParameters , ImpactObjectEvent
  • lodParamDesc.version : ApexEmitterAssetParameters , ImpactObjectEvent
  • LODSettings.CullByDistance : EffectPackageAssetParams
  • LODSettings.CullOffScreen : EffectPackageAssetParams
  • LODSettings.FadeAttractorFieldStrength : EffectPackageAssetParams
  • LODSettings.FadeDistanceBegin : EffectPackageAssetParams
  • LODSettings.FadeDistanceEnd : EffectPackageAssetParams
  • LODSettings.FadeEmitterRate : EffectPackageAssetParams
  • LODSettings.FadeForceFieldScale : EffectPackageAssetParams
  • LODSettings.FadeForceFieldStrength : EffectPackageAssetParams
  • LODSettings.FadeHeatSourceTemperature : EffectPackageAssetParams
  • LODSettings.FadeJetFieldStrength : EffectPackageAssetParams
  • LODSettings.FadeOutRate : EffectPackageAssetParams
  • LODSettings.FadeTurbulenceExternalVelocity : EffectPackageAssetParams
  • LODSettings.FadeTurbulenceNoise : EffectPackageAssetParams
  • LODSettings.FadeTurbulenceVelocity : EffectPackageAssetParams
  • LODSettings.FadeTurbulenceVelocityWeight : EffectPackageAssetParams
  • LODSettings.NonVisibleDeleteTime : EffectPackageAssetParams
  • LODSettings.OffScreenCullTime : EffectPackageAssetParams
  • LODSettings.RandomizeEmitterRate : EffectPackageAssetParams
  • LODSettings.ScreenCullDistance : EffectPackageAssetParams
  • LODSettings.ScreenCullSize : EffectPackageAssetParams
  • LODSettings.UniqueRenderVolume : EffectPackageAssetParams
  • lodWeights.benefitBias : TurbulenceFSAssetParams
  • lodWeights.benefitsBias : ClothingActorParam
  • lodWeights.benefitWeight : TurbulenceFSAssetParams
  • lodWeights.bias : TurbulenceFSAssetParams , ClothingActorParam
  • lodWeights.distanceWeight : ClothingActorParam , TurbulenceFSAssetParams
  • lodWeights.maxDistance : TurbulenceFSAssetParams , ClothingActorParam
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- m -

  • Mass : RigidBodyEffect
  • MassScale : ClothingDebugRenderParams
  • massScale : DestructibleModuleParameters
  • materialFactoryMapList[].iofxAssetName : GroundEmitterAssetParameters
  • materialFactoryMapList[].iosAssetName : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.bias : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.distanceWeight : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.lifeWeight : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.maxDistance : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.separationWeight : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.speedWeight : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.version : GroundEmitterAssetParameters
  • materialFactoryMapList[].maxSlopeAngle : GroundEmitterAssetParameters
  • materialFactoryMapList[].physMatName : GroundEmitterAssetParameters
  • materialFactoryMapList[].weight : GroundEmitterAssetParameters
  • materialIndex : ClothingAssetParameters
  • materialLibrary : ClothingAssetParameters
  • materialNames[] : RenderMeshAssetParameters
  • materials[].bendingStiffness : ClothingMaterialLibraryParameters
  • materials[].bendingStiffnessScaling.compressionRange : ClothingMaterialLibraryParameters
  • materials[].bendingStiffnessScaling.scale : ClothingMaterialLibraryParameters
  • materials[].bendingStiffnessScaling.stretchRange : ClothingMaterialLibraryParameters
  • materials[].comDamping : ClothingMaterialLibraryParameters
  • materials[].damping : ClothingMaterialLibraryParameters
  • materials[].drag : ClothingMaterialLibraryParameters
  • materials[].friction : ClothingMaterialLibraryParameters
  • materials[].gravityScale : ClothingMaterialLibraryParameters
  • materials[].hardStretchLimitation : ClothingMaterialLibraryParameters
  • materials[].hierarchicalSolverIterations : ClothingMaterialLibraryParameters
  • materials[].horizontalStiffnessScaling.compressionRange : ClothingMaterialLibraryParameters
  • materials[].horizontalStiffnessScaling.scale : ClothingMaterialLibraryParameters
  • materials[].horizontalStiffnessScaling.stretchRange : ClothingMaterialLibraryParameters
  • materials[].horizontalStretchingStiffness : ClothingMaterialLibraryParameters
  • materials[].inertiaScale : ClothingMaterialLibraryParameters
  • materials[].massScale : ClothingMaterialLibraryParameters
  • materials[].materialName : ClothingMaterialLibraryParameters
  • materials[].maxDistanceBias : ClothingMaterialLibraryParameters
  • materials[].orthoBending : ClothingMaterialLibraryParameters
  • materials[].selfcollisionSquashScale : ClothingMaterialLibraryParameters
  • materials[].selfcollisionStiffness : ClothingMaterialLibraryParameters
  • materials[].selfcollisionThickness : ClothingMaterialLibraryParameters
  • materials[].shearingStiffness : ClothingMaterialLibraryParameters
  • materials[].shearingStiffnessScaling.compressionRange : ClothingMaterialLibraryParameters
  • materials[].shearingStiffnessScaling.scale : ClothingMaterialLibraryParameters
  • materials[].shearingStiffnessScaling.stretchRange : ClothingMaterialLibraryParameters
  • materials[].solverFrequency : ClothingMaterialLibraryParameters
  • materials[].solverIterations : ClothingMaterialLibraryParameters
  • materials[].stiffnessFrequency : ClothingMaterialLibraryParameters
  • materials[].tetherLimit : ClothingMaterialLibraryParameters
  • materials[].tetherStiffness : ClothingMaterialLibraryParameters
  • materials[].verticalStiffnessScaling.compressionRange : ClothingMaterialLibraryParameters
  • materials[].verticalStiffnessScaling.scale : ClothingMaterialLibraryParameters
  • materials[].verticalStiffnessScaling.stretchRange : ClothingMaterialLibraryParameters
  • materials[].verticalStretchingStiffness : ClothingMaterialLibraryParameters
  • maxActorCreatesPerFrame : DestructibleModuleParameters
  • maxChunkDepthOffset : DestructibleModuleParameters
  • maxChunkSeparationLOD : DestructibleModuleParameters
  • maxCollidingObjects : TurbulenceFSAssetParams , BasicIOSAssetParam
  • MaxDistance : ClothingDebugRenderParams
  • maxDistanceBlendTime : ClothingActorParam
  • MaxDistanceInwards : ClothingDebugRenderParams
  • maxDistanceScale.Multipliable : ClothingActorParam
  • maxDistanceScale.Scale : ClothingActorParam
  • maxDynamicChunkIslandCount : DestructibleModuleParameters
  • maxHeatSources : TurbulenceFSAssetParams
  • maxInjectedParticleCount : BasicIOSAssetParam , ParticleIosAssetParam
  • maxMotionDistance : ParticleIosAssetParam
  • maxNumCompartments : ClothingModuleParameters
  • maxParticleCount : FieldSamplerPhysXMonitorParams , ParticleIosAssetParam , BasicIOSAssetParam
  • maxPSCount : FieldSamplerPhysXMonitorParams
  • maxRaycastsPerFrame : GroundEmitterAssetParameters , GroundEmitterActorParameters
  • maxRBCount : FieldSamplerPhysXMonitorParams
  • maxRotation : RandomRotationModifierParams
  • maxRotationRatePerSec : RotationModifierParams
  • maxSamples : ApexEmitterAssetParameters
  • maxScaleFactor : RandomScaleModifierParams
  • maxSettleRatePerSec : RotationModifierParams
  • maxSubstanceSources : TurbulenceFSAssetParams
  • maxSubtexture : RandomSubtextureModifierParams
  • maxTimeRenderProxyInPool : ClothingModuleParameters
  • maxUnusedPhysXResources : ClothingModuleParameters
  • maxVelocitySources : TurbulenceFSAssetParams
  • meshCookedCollisionStreams[] : MeshCookedCollisionStreamsAtScale
  • meshCookedCollisionStreamsAtScale[] : DestructibleAssetCollisionDataSet
  • MeshDynamic : DebugColorParams
  • MeshStatic : DebugColorParams
  • minRotation : RandomRotationModifierParams
  • minSamplingFPS : ApexEmitterAssetParameters
  • minScaleFactor : RandomScaleModifierParams
  • minSubtexture : RandomSubtextureModifierParams
  • modelForward : OrientAlongVelocityModifierParams
  • moduleName[] : DebugRenderParams::ModuleName , DebugRenderParams , DebugRenderParams::ModuleName
  • morphDisplacements[] : ClothingActorParam
  • morphGraphicalMeshNewPositions[] : ClothingActorParam
  • morphPhysicalMeshNewPositions[] : ClothingActorParam
  • multiplier : ForceFieldFalloffParams
  • multiplyGlobalPoseIntoBones : ClothingActorParam
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- n -

  • Name : AttractorFieldSamplerData , EffectPackageData , ForceFieldData , JetFieldSamplerData , WindFieldSamplerData , NoiseFieldSamplerData , GraphicsEffectData , ParticleSimulationData , SubstanceSourceData , EmitterData , GraphicsMaterialData , TurbulenceFieldSamplerData , VelocitySourceData , HeatSourceData , VolumeRenderMaterialData , VortexFieldSamplerData
  • nearRadius : JetFSAssetParams
  • neighborPadding : DestructibleAssetParameters
  • nextCookedData : ClothingCookedPhysX3Param
  • noise : GenericForceFieldKernelParams
  • NoiseFieldSampler : NoiseFieldSamplerData , NoiseFieldSamplerEffect
  • noiseOctaves : JetFSAssetParams , NoiseFSAssetParams
  • noiseParameters : RadialForceFieldKernelParams
  • noiseParams.noiseOctaves : TurbulenceFSAssetParams
  • noiseParams.noiseSpacePeriod : TurbulenceFSAssetParams
  • noiseParams.noiseStrength : TurbulenceFSAssetParams
  • noiseParams.noiseTimePeriod : TurbulenceFSAssetParams
  • noisePercentage : JetFSAssetParams
  • noiseSeed : NoiseFSAssetParams
  • noiseSpacePeriod : NoiseFSAssetParams
  • noiseSpacePeriodOctaveMultiplier : NoiseFSAssetParams
  • noiseSpaceScale : JetFSAssetParams
  • noiseStrength : NoiseFSAssetParams
  • noiseStrengthOctaveMultiplier : NoiseFSAssetParams
  • noiseTimePeriod : NoiseFSAssetParams
  • noiseTimePeriodOctaveMultiplier : NoiseFSAssetParams
  • noiseTimeScale : JetFSAssetParams
  • noiseType : NoiseFSAssetParams
  • numVertices : ClothingCookedPhysX3Param
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- o -

  • objectScale : EffectPackageActorParams
  • octaves : ForceFieldNoiseParams
  • OpacityThreshold : VolumeRenderMaterialData
  • Orange : DebugColorParams
  • originalDepthCount : DestructibleAssetParameters
  • outletPressureBC : TurbulenceFSActorParams
  • overlaps[].i0 : CachedOverlaps
  • overlaps[].i1 : CachedOverlaps
  • overlapsAtDepth[] : DestructibleAssetParameters
  • overlapTestGroupMaskName : ApexEmitterActorParameters
  • overlapTestGroupsMask128Name : ApexEmitterActorParameters
  • overrideMaterialNames[] : ClothingActorParam
  • overrideSkinnedMaterialNames[] : DestructibleActorParam , DestructiblePreviewParam
  • overrideStaticMaterialNames[] : DestructibleActorParam , DestructiblePreviewParam
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZerostretchFibers : ClothingDebugRenderParams
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- b -

  • Backstop : ClothingDebugRenderParams
  • BackstopPrecise : ClothingDebugRenderParams
  • behaviorGroups[].damageColorChange : DestructibleAssetParameters , DestructibleActorParam
  • behaviorGroups[].damageColorSpread.falloffExponent : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].damageColorSpread.minimumRadius : DestructibleAssetParameters , DestructibleActorParam
  • behaviorGroups[].damageColorSpread.radiusMultiplier : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].damageSpread.falloffExponent : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].damageSpread.minimumRadius : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].damageSpread.radiusMultiplier : DestructibleAssetParameters , DestructibleActorParam
  • behaviorGroups[].damageThreshold : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].damageToRadius : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].density : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].fadeOut : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].groupsMask.bits0 : DestructibleActorParam
  • behaviorGroups[].groupsMask.bits1 : DestructibleActorParam
  • behaviorGroups[].groupsMask.bits2 : DestructibleActorParam
  • behaviorGroups[].groupsMask.bits3 : DestructibleActorParam
  • behaviorGroups[].groupsMask.useGroupsMask : DestructibleActorParam
  • behaviorGroups[].materialStrength : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].maxDepenetrationVelocity : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].name : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].userData : DestructibleActorParam , DestructibleAssetParameters
  • BendingFibers : ClothingDebugRenderParams
  • Black : DebugColorParams
  • BlockEmptyThreshold : VolumeRenderMaterialData
  • Blue : DebugColorParams
  • BlurShadows : VolumeRenderMaterialData
  • bodyDescTemplate.angularDamping : DestructibleActorParam
  • bodyDescTemplate.CCDMotionThreshold : DestructibleActorParam
  • bodyDescTemplate.contactReportThreshold : DestructibleActorParam
  • bodyDescTemplate.flags.NX_BF_DISABLE_GRAVITY : DestructibleActorParam
  • bodyDescTemplate.flags.NX_BF_ENERGY_SLEEP_TEST : DestructibleActorParam
  • bodyDescTemplate.flags.NX_BF_FILTER_SLEEP_VEL : DestructibleActorParam
  • bodyDescTemplate.flags.NX_BF_VISUALIZATION : DestructibleActorParam
  • bodyDescTemplate.linearDamping : DestructibleActorParam
  • bodyDescTemplate.maxAngularVelocity : DestructibleActorParam
  • bodyDescTemplate.sleepAngularVelocity : DestructibleActorParam
  • bodyDescTemplate.sleepDamping : DestructibleActorParam
  • bodyDescTemplate.sleepEnergyThreshold : DestructibleActorParam
  • bodyDescTemplate.sleepLinearVelocity : DestructibleActorParam
  • bodyDescTemplate.solverIterationCount : DestructibleActorParam
  • bodyDescTemplate.wakeUpCounter : DestructibleActorParam
  • boneActors[].boneIndex : ClothingAssetParameters
  • boneActors[].capsuleHeight : ClothingAssetParameters
  • boneActors[].capsuleRadius : ClothingAssetParameters
  • boneActors[].convexVerticesCount : ClothingAssetParameters
  • boneActors[].convexVerticesStart : ClothingAssetParameters
  • boneActors[].localPose : ClothingAssetParameters
  • boneCount : RenderMeshAssetParameters
  • BoneFrames : ClothingDebugRenderParams
  • boneMatrices[] : ClothingActorParam , ClothingPreviewParam
  • BoneNames : ClothingDebugRenderParams
  • bonePlanes[].boneIndex : ClothingAssetParameters
  • bonePlanes[].d : ClothingAssetParameters
  • bonePlanes[].n : ClothingAssetParameters
  • bones[].bindPose : ClothingAssetParameters
  • bones[].externalIndex : ClothingAssetParameters
  • bones[].internalIndex : ClothingAssetParameters
  • bones[].name : ClothingAssetParameters
  • bones[].numMeshReferenced : ClothingAssetParameters
  • bones[].numRigidBodiesReferenced : ClothingAssetParameters
  • bones[].parentIndex : ClothingAssetParameters
  • boneSphereConnections[] : ClothingAssetParameters
  • boneSpheres[].boneIndex : ClothingAssetParameters
  • boneSpheres[].localPos : ClothingAssetParameters
  • boneSpheres[].radius : ClothingAssetParameters
  • bonesReferenced : ClothingAssetParameters
  • bonesReferencedByMesh : ClothingAssetParameters
  • boneVertices[] : ClothingAssetParameters
  • bottomRadius : VortexFSAssetParams
  • bottomSphericalForce : VortexFSAssetParams
  • boundaryFadePercentage : AttractorFSAssetParams , JetFSAssetParams , NoiseFSAssetParams , VortexFSAssetParams , TurbulenceFSAssetParams
  • boundarySize : NoiseFSAssetParams
  • boundarySizePercentage : TurbulenceFSAssetParams
  • boundingBox : ClothingAssetParameters
  • bounds : ConvexHullParameters , DestructibleAssetParameters
  • Bounds : DebugRenderParams
  • buffer : SurfaceBufferParameters::Buffer , SurfaceBufferParameters , SurfaceBufferParameters::Buffer
  • bufferFormats[].access : VertexFormatParameters
  • bufferFormats[].format : VertexFormatParameters
  • bufferFormats[].id : VertexFormatParameters
  • bufferFormats[].name : VertexFormatParameters
  • bufferFormats[].semantic : VertexFormatParameters
  • bufferFormats[].serialize : VertexFormatParameters
  • buffers[] : VertexBufferParameters::Buffers , VertexBufferParameters , VertexBufferParameters::Buffers
  • bytes[] : MeshCookedCollisionStream
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- c -

  • CellColumn : GraphicsMaterialData
  • CellCount : GraphicsMaterialData
  • CellRow : GraphicsMaterialData
  • chunkConvexHulls[] : DestructibleAssetParameters
  • chunkConvexHullStartIndices[] : DestructibleAssetParameters
  • chunkDepth : DestructiblePreviewParam
  • chunkInstanceInfo[].chunkPositionOffset : DestructibleAssetParameters
  • chunkInstanceInfo[].chunkUVOffset : DestructibleAssetParameters
  • chunkInstanceInfo[].partIndex : DestructibleAssetParameters
  • chunks[].behaviorGroupIndex : DestructibleAssetParameters
  • chunks[].depth : DestructibleAssetParameters
  • chunks[].firstChildIndex : DestructibleAssetParameters
  • chunks[].firstScatterMesh : DestructibleAssetParameters
  • chunks[].flags : DestructibleAssetParameters
  • chunks[].meshPartIndex : DestructibleAssetParameters
  • chunks[].numChildren : DestructibleAssetParameters
  • chunks[].parentIndex : DestructibleAssetParameters
  • chunks[].scatterMeshCount : DestructibleAssetParameters
  • chunks[].surfaceNormal : DestructibleAssetParameters
  • clothDescTemplate.collisionGroup : ClothingActorParam
  • clothDescTemplate.collisionResponseCoefficient : ClothingActorParam
  • clothDescTemplate.compartment : ClothingActorParam
  • clothDescTemplate.groupsMask.bits0 : ClothingActorParam
  • clothDescTemplate.groupsMask.bits1 : ClothingActorParam
  • clothDescTemplate.groupsMask.bits2 : ClothingActorParam
  • clothDescTemplate.groupsMask.bits3 : ClothingActorParam
  • clothDescTemplate.userData : ClothingActorParam
  • clothDescTemplate.validBounds : ClothingActorParam
  • clothingMaterialIndex : ClothingActorParam
  • collisionConvexes[] : ClothingAssetParameters
  • collisionData : DestructibleAssetParameters
  • collisionDistanceMultiplier : BasicIOSAssetParam
  • CollisionFilterDataName : RigidBodyEffect
  • collisionFilterDataName : BasicIOSAssetParam , TurbulenceFSActorParams , TurbulenceFSAssetParams
  • collisionRotationMultiplier : RotationModifierParams
  • CollisionShapes : ClothingDebugRenderParams
  • CollisionShapesWire : ClothingDebugRenderParams
  • collisionThreshold : BasicIOSAssetParam
  • CollisionTwoway : ParticleIosAssetParam
  • collisionWithConvex : BasicIOSAssetParam
  • CollisionWithDynamicActors : ParticleIosAssetParam
  • collisionWithTriangleMesh : BasicIOSAssetParam
  • color : InitialColorModifierParams
  • Color0 : DebugColorParams
  • Color1 : DebugColorParams
  • Color2 : DebugColorParams
  • Color3 : DebugColorParams
  • Color4 : DebugColorParams
  • Color5 : DebugColorParams
  • colorChannel : ColorVsDensityModifierParams , ColorVsLifeModifierParams , ColorVsTemperatureModifierParams , ColorVsVelocityModifierParams
  • ColorMap[].color : VolumeRenderMaterialData
  • ColorMap[].density : VolumeRenderMaterialData
  • ColorMapOffset : VolumeRenderMaterialData
  • ColorMapScale : VolumeRenderMaterialData
  • ColorMultiplier : GraphicsMaterialData
  • comments : DestructibleAssetParameters
  • constant : GenericForceFieldKernelParams
  • constFieldStrength : AttractorFSAssetParams
  • contactOffset : ParticleIosAssetParam
  • continuousModifierList[]
: MeshIofxParameters::ContinuousModifierList
, SpriteIofxParameters::ContinuousModifierList
, MeshIofxParameters::ContinuousModifierList
, SpriteIofxParameters::ContinuousModifierList
, MeshIofxParameters
, SpriteIofxParameters::ContinuousModifierList
, SpriteIofxParameters
  • controlPoints[].cameraDistance : ScaleVsCameraDistance3DModifierParams , ScaleVsCameraDistance2DModifierParams
  • controlPoints[].color : ColorVsVelocityCompositeModifierParams , ColorVsDensityCompositeModifierParams , ColorVsLifeCompositeModifierParams , ColorVsTemperatureCompositeModifierParams
  • controlPoints[].density : ColorVsDensityCompositeModifierParams , ScaleVsDensity2DModifierParams , ScaleVsDensity3DModifierParams
  • controlPoints[].lifeRemaining : ScaleVsLife2DModifierParams , ScaleVsLife3DModifierParams , ColorVsLifeCompositeModifierParams
  • controlPoints[].scale : ScaleVsDensity3DModifierParams , ScaleVsLife2DModifierParams , ScaleVsLife3DModifierParams , ScaleVsTemperature3DModifierParams , ScaleVsCameraDistance3DModifierParams , ScaleVsCameraDistance2DModifierParams , ScaleVsDensity2DModifierParams , ScaleVsTemperature2DModifierParams
  • controlPoints[].temperature : ScaleVsTemperature2DModifierParams , ColorVsTemperatureCompositeModifierParams , ScaleVsTemperature3DModifierParams
  • controlPoints[].velocity : ColorVsVelocityCompositeModifierParams
  • controlPoints[].x : ColorVsTemperatureModifierParams , ColorVsVelocityModifierParams , RotationRateVsLifeModifierParams , ScaleVsDensityModifierParams , SubtextureVsLifeModifierParams , ScaleVsCameraDistanceModifierParams , ColorVsDensityModifierParams , ScaleVsLifeModifierParams , ColorVsLifeModifierParams , ScaleVsTemperatureModifierParams
  • controlPoints[].y : RotationRateVsLifeModifierParams , ColorVsDensityModifierParams , ColorVsTemperatureModifierParams , ScaleVsLifeModifierParams , ColorVsVelocityModifierParams , ScaleVsTemperatureModifierParams , ColorVsLifeModifierParams , ScaleVsCameraDistanceModifierParams , SubtextureVsLifeModifierParams , ScaleVsDensityModifierParams
  • convexCookedData[] : ClothingCookedParam
  • cookedData : ClothingAssetParameters , ClothingAssetParameters::CookedData
  • cookedData[].scale : ClothingAssetParameters
  • cookedDataVersion : ClothingCookedPhysX3Param , ClothingCookedParam
  • cookedPhysicalSubmeshes[].cookedDataLength : ClothingCookedParam
  • cookedPhysicalSubmeshes[].cookedDataOffset : ClothingCookedParam
  • cookedPhysicalSubmeshes[].deformableInvParticleWeightsOffset : ClothingCookedParam
  • cookedPhysicalSubmeshes[].physicalMeshId : ClothingCookedParam
  • cookedPhysicalSubmeshes[].submeshId : ClothingCookedParam
  • cookedPhysicalSubmeshes[].virtualParticleIndicesLength : ClothingCookedParam
  • cookedPhysicalSubmeshes[].virtualParticleIndicesOffset : ClothingCookedParam
  • cookingPlatform : DestructibleAssetCollisionDataSet
  • cookingVersionNum : DestructibleAssetCollisionDataSet
  • coordinateSystemParameters.torusRadius : GenericForceFieldKernelParams
  • coordinateSystemParameters.type : GenericForceFieldKernelParams
  • createChunkEvents : DestructibleActorParam
  • CrossBlend : GraphicsMaterialData
  • CrossSectionFibers : ClothingDebugRenderParams
  • crumbleEmitterName : DestructibleActorParam , DestructibleAssetParameters
  • crumbleParticleSpacing : DestructibleActorParam
  • customLOD : TurbulenceFSAssetParams
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- d -

  • damping : ParticleIosAssetParam
  • DarkBlue : DebugColorParams
  • DarkGray : DebugColorParams
  • DarkGreen : DebugColorParams
  • DarkPurple : DebugColorParams
  • DarkRed : DebugColorParams
  • data[] : BufferF32x3 , BufferU16x1 , BufferU32x1 , BufferU8x1 , BufferF32x1
  • data[].angularVelocity : DestructibleActorChunks
  • data[].damage : DestructibleActorChunks
  • data[].flags : DestructibleActorChunks
  • data[].globalPose : DestructibleActorChunks
  • data[].islandID : DestructibleActorChunks
  • data[].linearVelocity : DestructibleActorChunks
  • data[].localOffset : DestructibleActorChunks
  • data[].localSphere : DestructibleActorChunks
  • data[].shapesCount : DestructibleActorChunks
  • data[].state : DestructibleActorChunks
  • data[].visibleAncestorIndex : DestructibleActorChunks
  • data[].w : BufferF32x4 , BufferU16x4 , BufferU32x4 , BufferU8x4
  • data[].x : BufferU32x2 , BufferU32x3 , BufferU32x4 , BufferU8x2 , BufferU8x3 , BufferU8x4 , BufferF32x2 , BufferF32x4 , BufferU16x2 , BufferU16x3 , BufferU16x4
  • data[].y : BufferF32x2 , BufferF32x4 , BufferU16x2 , BufferU16x3 , BufferU16x4 , BufferU32x2 , BufferU32x3 , BufferU32x4 , BufferU8x2 , BufferU8x3 , BufferU8x4
  • data[].z : BufferF32x4 , BufferU16x3 , BufferU16x4 , BufferU32x3 , BufferU32x4 , BufferU8x3 , BufferU8x4
  • Default : DebugColorParams
  • defaultBehaviorGroup.damageColorChange : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageColorSpread.falloffExponent : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageColorSpread.minimumRadius : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageColorSpread.radiusMultiplier : DestructibleAssetParameters , DestructibleActorParam
  • defaultBehaviorGroup.damageSpread.falloffExponent : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageSpread.minimumRadius : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageSpread.radiusMultiplier : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageThreshold : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageToRadius : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.density : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.fadeOut : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.groupsMask.bits0 : DestructibleActorParam
  • defaultBehaviorGroup.groupsMask.bits1 : DestructibleActorParam
  • defaultBehaviorGroup.groupsMask.bits2 : DestructibleActorParam
  • defaultBehaviorGroup.groupsMask.bits3 : DestructibleActorParam
  • defaultBehaviorGroup.groupsMask.useGroupsMask : DestructibleActorParam
  • defaultBehaviorGroup.materialStrength : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.maxDepenetrationVelocity : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.name : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.userData : DestructibleActorParam , DestructibleAssetParameters
  • defaultNormal : SurfaceTraceParameters
  • defaultScale : JetFSAssetParams , NoiseFSAssetParams
  • deformableCookedData[] : ClothingCookedParam
  • deformableIndices[] : ClothingCookedPhysX3Param
  • deformableInvParticleWeights[] : ClothingCookedParam
  • deformableInvVertexWeights[] : ClothingCookedPhysX3Param
  • deformablePhaseDescs[].phaseType : ClothingCookedPhysX3Param
  • deformablePhaseDescs[].restValueOffset : ClothingCookedPhysX3Param
  • deformablePhaseDescs[].setIndex : ClothingCookedPhysX3Param
  • deformableRestLengths[] : ClothingCookedPhysX3Param
  • deformableSets[].avgEdgeLength : ClothingCookedPhysX3Param
  • deformableSets[].avgFiberLength : ClothingCookedPhysX3Param
  • deformableSets[].fiberEnd : ClothingCookedPhysX3Param
  • deformableSets[].longestFiber : ClothingCookedPhysX3Param
  • deformableSets[].numEdges : ClothingCookedPhysX3Param
  • deformableSets[].shortestFiber : ClothingCookedPhysX3Param
  • defScale : ForceFieldAssetParams
  • delay : ImpactExplosionEvent , ImpactObjectEvent
  • deleteChunksEnteringUserDefinedBB : DestructibleActorParam
  • deleteChunksLeavingUserDefinedBB : DestructibleActorParam
  • deleteStaticBuffersAfterUse : RenderMeshAssetParameters
  • Density : VolumeRenderMaterialData
  • DensityBuffer : ParticleIosAssetParam
  • densityParams.densityFieldFade : TurbulenceFSAssetParams
  • densityParams.densityGridMultiplier : TurbulenceFSAssetParams
  • densityParams.diffusionCoef : TurbulenceFSAssetParams
  • densityRange.max : ApexEmitterAssetParameters , GroundEmitterActorParameters , GroundEmitterAssetParameters
  • densityRange.min : ApexEmitterAssetParameters , GroundEmitterActorParameters , GroundEmitterAssetParameters
  • depthCount : DestructibleAssetParameters
  • depthParameters[].IGNORE_CONTACT_CALLBACKS : DestructibleAssetParameters , DestructibleActorParam
  • depthParameters[].IGNORE_POSE_UPDATES : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].IGNORE_RAYCAST_CALLBACKS : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].OVERRIDE_IMPACT_DAMAGE : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].USER_FLAG_0 : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].USER_FLAG_1 : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].USER_FLAG_2 : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].USER_FLAG_3 : DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.damageCap : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.damageDepthLimit : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.debrisDepth : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.debrisDestructionProbability : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.debrisLifetimeMax : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.debrisLifetimeMin : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.debrisMaxSeparationMax : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.debrisMaxSeparationMin : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.dynamicChunkDominanceGroup : DestructibleAssetParameters , DestructibleActorParam , DestructibleActorState
  • destructibleParameters.dynamicChunksGroupsMask.bits0 : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.dynamicChunksGroupsMask.bits1 : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.dynamicChunksGroupsMask.bits2 : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.dynamicChunksGroupsMask.bits3 : DestructibleAssetParameters , DestructibleActorParam , DestructibleActorState
  • destructibleParameters.dynamicChunksGroupsMask.useGroupsMask : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.essentialDepth : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.flags.ACCUMULATE_DAMAGE : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.flags.ACCURATE_RAYCASTS : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.flags.DEBRIS_MAX_SEPARATION : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.flags.DEBRIS_TIMEOUT : DestructibleAssetParameters , DestructibleActorParam , DestructibleActorState
  • destructibleParameters.flags.USE_VALID_BOUNDS : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.forceToDamage : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.fractureImpulseScale : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.impactDamageDefaultDepth : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.impactVelocityThreshold : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.legacyChunkBoundsTestSetting : DestructibleActorState , DestructibleAssetParameters , DestructibleActorParam
  • destructibleParameters.legacyDamageRadiusSpreadSetting : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.maxChunkSpeed : DestructibleActorState , DestructibleAssetParameters , DestructibleActorParam
  • destructibleParameters.minimumFractureDepth : DestructibleAssetParameters , DestructibleActorParam , DestructibleActorState
  • destructibleParameters.runtimeFracture.attachment.negX : DestructibleAssetParameters , DestructibleActorParam , DestructibleActorState
  • destructibleParameters.runtimeFracture.attachment.negY : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.attachment.negZ : DestructibleAssetParameters , DestructibleActorState , DestructibleActorParam
  • destructibleParameters.runtimeFracture.attachment.posX : DestructibleActorState , DestructibleAssetParameters , DestructibleActorParam
  • destructibleParameters.runtimeFracture.attachment.posY : DestructibleAssetParameters , DestructibleActorParam , DestructibleActorState
  • destructibleParameters.runtimeFracture.attachment.posZ : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.depthLimit : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.destroyIfAtDepthLimit : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.glass.firstSegmentSize : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.glass.numSectors : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.runtimeFracture.glass.sectorRand : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.glass.segmentRand : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.glass.segmentScale : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.impulseScale : DestructibleAssetParameters , DestructibleActorState , DestructibleActorParam
  • destructibleParameters.runtimeFracture.minConvexSize : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.RuntimeFractureType : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.runtimeFracture.sheetFracture : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.runtimeFracture.voronoi.biasExp : DestructibleAssetParameters , DestructibleActorState , DestructibleActorParam
  • destructibleParameters.runtimeFracture.voronoi.dimensions : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.runtimeFracture.voronoi.maxDist : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.runtimeFracture.voronoi.numCells : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.supportStrength : DestructibleAssetParameters , DestructibleActorState , DestructibleActorParam
  • destructibleParameters.validBounds : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • DiffuseTexture : GraphicsMaterialData
  • directionalStretch : JetFSAssetParams
  • distance : EmitterGeomExplicitParams
  • doNotCreateRenderable : DestructibleActorParam
  • dragCoeff : TurbulenceFSAssetParams
  • dragCoeffForRigidBody : TurbulenceFSActorParams , TurbulenceFSAssetParams
  • drawAssetInfo : WindFSPreviewParams , AttractorFSPreviewParams , TurbulenceFSPreviewParams , VortexFSPreviewParams , NoiseFSPreviewParams , JetFSPreviewParams
  • drawBold : ForceFieldAssetPreviewParams
  • drawBoundaries : ForceFieldAssetPreviewParams
  • drawBox : TurbulenceFSPreviewParams
  • drawGrid : TurbulenceFSPreviewParams
  • drawIcon : TurbulenceFSPreviewParams , ForceFieldAssetPreviewParams
  • drawShape : AttractorFSPreviewParams , JetFSPreviewParams , NoiseFSPreviewParams , VortexFSPreviewParams
  • duration : ImpactExplosionEvent
  • dustEmitterName : DestructibleAssetParameters , DestructibleActorParam
  • dustParticleSpacing : DestructibleActorParam
  • dynamic : DestructibleActorParam
  • Dynamic : RigidBodyEffect
  • dynamicCollision : BasicIOSAssetParam
  • dynamicFriction : ParticleIosAssetParam
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- e -

  • EdgeFade : VolumeRenderMaterialData
  • edges[] : ConvexHullParameters
  • EffectPackage : EffectPackageData
  • EffectPackages[] : EffectPackageDatabaseParams
  • EffectProperties.Duration : HeatSourceEffect , WindFieldSamplerEffect , JetFieldSamplerEffect , AttractorFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , EmitterEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , ForceFieldEffect , VelocitySourceEffect , VortexFieldSamplerEffect
  • EffectProperties.Enable : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.InitialDelayTime : HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect , AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect
  • EffectProperties.Orientation.RotateX : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Orientation.RotateY : WindFieldSamplerEffect , AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect
  • EffectProperties.Orientation.RotateZ : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.ControlPoints[] : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.LoopIndex : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.PathDuration : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.PlaybackMode : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.Scale[].x : HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect , AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect
  • EffectProperties.Path.Scale[].y : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.Speed[].x : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.Speed[].y : VortexFieldSamplerEffect , RigidBodyEffect , AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , WindFieldSamplerEffect
  • EffectProperties.Position.TranslateX : VortexFieldSamplerEffect , ForceFieldEffect , AttractorFieldSamplerEffect , EmitterEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , WindFieldSamplerEffect
  • EffectProperties.Position.TranslateY : RigidBodyEffect , ForceFieldEffect , AttractorFieldSamplerEffect , EmitterEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Position.TranslateZ : AttractorFieldSamplerEffect , EmitterEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , WindFieldSamplerEffect , RigidBodyEffect , VortexFieldSamplerEffect , ForceFieldEffect
  • EffectProperties.RandomizeRepeatTime : VortexFieldSamplerEffect , WindFieldSamplerEffect , VelocitySourceEffect , ForceFieldEffect , AttractorFieldSamplerEffect , EmitterEffect , TurbulenceFieldSamplerEffect , HeatSourceEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , JetFieldSamplerEffect
  • EffectProperties.RepeatCount : TurbulenceFieldSamplerEffect , RigidBodyEffect , VortexFieldSamplerEffect , EmitterEffect , ForceFieldEffect , NoiseFieldSamplerEffect , VelocitySourceEffect , HeatSourceEffect , JetFieldSamplerEffect , SubstanceSourceEffect , WindFieldSamplerEffect , AttractorFieldSamplerEffect
  • EffectProperties.RepeatDelay : AttractorFieldSamplerEffect , VortexFieldSamplerEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , ForceFieldEffect , RigidBodyEffect , HeatSourceEffect , VelocitySourceEffect , EmitterEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.UserString : WindFieldSamplerEffect , RigidBodyEffect , VortexFieldSamplerEffect , TurbulenceFieldSamplerEffect , JetFieldSamplerEffect , ForceFieldEffect , AttractorFieldSamplerEffect , VelocitySourceEffect , EmitterEffect , HeatSourceEffect , NoiseFieldSamplerEffect , SubstanceSourceEffect
  • Effects[] : EffectPackageAssetParams::Effects , EffectPackageAssetParams
  • ellipsoids.positions[].center : EmitterGeomExplicitParams
  • ellipsoids.positions[].doDetectOverlaps : EmitterGeomExplicitParams
  • ellipsoids.positions[].normal : EmitterGeomExplicitParams
  • ellipsoids.positions[].polarRadius : EmitterGeomExplicitParams
  • ellipsoids.positions[].radius : EmitterGeomExplicitParams
  • ellipsoids.velocities[] : EmitterGeomExplicitParams
  • Emerald : DebugColorParams
  • emitAssetParticles : ApexEmitterActorParameters
  • Emitter : EmitterData , EmitterEffect
  • emitterDuration : ApexEmitterActorParameters , ApexEmitterAssetParameters
  • Emitters[] : EffectPackageEmitterDatabaseParams
  • emitterType : EmitterGeomSphereShellParams , EmitterGeomCylinderParams , EmitterGeomSphereParams , EmitterGeomBoxParams
  • EmitterVelocityChanges.AdjustEmitterRate.AdjustEnabled : EmitterEffect
  • EmitterVelocityChanges.AdjustEmitterRate.HighValue : EmitterEffect
  • EmitterVelocityChanges.AdjustEmitterRate.LowValue : EmitterEffect
  • EmitterVelocityChanges.AdjustEmitterRate.VelocityHigh : EmitterEffect
  • EmitterVelocityChanges.AdjustEmitterRate.VelocityLow : EmitterEffect
  • EmitterVelocityChanges.AdjustLifetime.AdjustEnabled : EmitterEffect
  • EmitterVelocityChanges.AdjustLifetime.HighValue : EmitterEffect
  • EmitterVelocityChanges.AdjustLifetime.LowValue : EmitterEffect
  • EmitterVelocityChanges.AdjustLifetime.VelocityHigh : EmitterEffect
  • EmitterVelocityChanges.AdjustLifetime.VelocityLow : EmitterEffect
  • Enable : ParticleIosAssetParam , DebugRenderParams
  • enableCrumbleEmitter : DestructibleActorState
  • Enabled : EffectPackageActorParams
  • enableDustEmitter : DestructibleActorState
  • EnableStencilOpt : VolumeRenderMaterialData
  • enableTemperatureBuffer : ParticleIosAssetParam , BasicIOSAssetParam
  • end : ForceFieldFalloffParams
  • eventSetList[] : ImpactEmitterAssetParameters , ImpactEmitterAssetParameters::EventSetList
  • eventSetName : ImpactObjectEvent , ImpactExplosionEvent
  • explodeAmount : DestructiblePreviewParam
  • explosionAssetName : ImpactExplosionEvent
  • extents : EmitterGeomBoxParams , HeatSourceGeomBoxParams
  • Extents : RigidBodyEffect
  • externalAcceleration : ParticleIosAssetParam , BasicIOSAssetParam
  • externalVelocity : TurbulenceFSAssetParams
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- f -

  • fallbackSkinning : ClothingActorParam , ClothingPreviewParam
  • falloffLinear : GenericForceFieldKernelParams
  • falloffParameters : RadialForceFieldKernelParams
  • falloffQuadratic : GenericForceFieldKernelParams
  • farRadius : JetFSAssetParams
  • FiberRange : ClothingDebugRenderParams
  • fieldBoundaryFilterDataName : AttractorFSActorParams , TurbulenceFSActorParams , TurbulenceFSAssetParams , AttractorFSAssetParams , VortexFSActorParams , VortexFSAssetParams , ForceFieldActorParams , WindFSActorParams , WindFSAssetParams , ForceFieldAssetParams , JetFSActorParams , JetFSAssetParams , NoiseFSActorParams , NoiseFSAssetParams
  • fieldDirection : JetFSAssetParams , WindFSAssetParams
  • fieldDirectionDeviationAngle : JetFSAssetParams , WindFSAssetParams
  • fieldDirectionOscillationPeriod : JetFSAssetParams , WindFSAssetParams
  • fieldDragCoeff : WindFSAssetParams , AttractorFSAssetParams , JetFSAssetParams , NoiseFSAssetParams , VortexFSAssetParams
  • fieldSamplerFilterData : ParticleIosAssetParam
  • fieldSamplerFilterDataName : AttractorFSActorParams , AttractorFSAssetParams , BasicIOSAssetParam , ForceFieldActorParams , ForceFieldAssetParams , HeatSourceActorParams , HeatSourceAssetParams , JetFSActorParams , JetFSAssetParams , NoiseFSActorParams , NoiseFSAssetParams , SubstanceSourceActorParams , SubstanceSourceAssetParams , TurbulenceFSActorParams , TurbulenceFSAssetParams , VelocitySourceActorParams , VelocitySourceAssetParams , VortexFSActorParams , VortexFSAssetParams , WindFSActorParams , WindFSAssetParams
  • FieldSamplers[] : EffectPackageFieldSamplerDatabaseParams::FieldSamplers , EffectPackageFieldSamplerDatabaseParams , EffectPackageFieldSamplerDatabaseParams::FieldSamplers
  • fieldStrength : WindFSAssetParams , JetFSAssetParams
  • fieldStrengthDeviationPercentage : JetFSAssetParams , WindFSAssetParams
  • fieldStrengthOscillationPeriod : JetFSAssetParams , WindFSAssetParams
  • fieldType : NoiseFSAssetParams
  • fieldVelocityMultiplier : TurbulenceFSAssetParams
  • fieldVelocityWeight : TurbulenceFSAssetParams
  • fieldWeight : JetFSAssetParams , NoiseFSAssetParams , AttractorFSAssetParams , WindFSAssetParams , VortexFSAssetParams
  • FillMode : VolumeRenderMaterialData
  • firstChunkAtDepth[] : DestructibleAssetParameters
  • flags.ComputePhysicsMeshNormals : ClothingActorParam
  • flags.ComputeRenderData : ClothingActorParam
  • flags.CorrectSimulationNormals : ClothingActorParam
  • flags.ParallelCpuSkinning : ClothingActorParam
  • flags.RecomputeNormals : ClothingActorParam
  • flags.RecomputeTangents : ClothingActorParam
  • flags.Visualize : ClothingActorParam
  • fluidViscosity : TurbulenceFSAssetParams , TurbulenceFSActorParams
  • ForceArrowsHigh : DebugColorParams
  • ForceArrowsLow : DebugColorParams
  • ForceArrowsNorm : DebugColorParams
  • ForceField : ForceFieldEffect , ForceFieldData
  • forceFieldKernelType : ForceFieldAssetParams::ForceFieldKernelType , ForceFieldAssetParams , ForceFieldAssetParams::ForceFieldKernelType
  • forceLod : DestructibleActorState
  • formExtendedStructures : DestructibleActorParam , DestructibleAssetParameters
  • freezeByLOD : ClothingActorParam
  • FullResPercent : GraphicsMaterialData
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- g -

  • GenerateMipmaps : VolumeRenderMaterialData
  • GenerateShadows : VolumeRenderMaterialData
  • geometryType
: ApexEmitterAssetParameters::GeometryType
, ApexEmitterAssetParameters
, SubstanceSourceActorParams::GeometryType
, SubstanceSourceActorParams
, HeatSourceActorParams::GeometryType
, SubstanceSourceAssetParams::GeometryType
, ApexEmitterAssetParameters::GeometryType
, HeatSourceActorParams::GeometryType
, SubstanceSourceAssetParams
, VelocitySourceActorParams::GeometryType
, HeatSourceActorParams
, VelocitySourceActorParams::GeometryType
, VelocitySourceActorParams
, ApexEmitterAssetParameters::GeometryType
, HeatSourceAssetParams::GeometryType
, VelocitySourceAssetParams::GeometryType
, HeatSourceAssetParams::GeometryType
, VelocitySourceAssetParams
, ApexEmitterAssetParameters::GeometryType
, HeatSourceAssetParams
, SubstanceSourceActorParams::GeometryType
  • globalPose : DestructiblePreviewParam , GroundEmitterActorParameters , JetFSPreviewParams , NoiseFSPreviewParams , TurbulenceFSPreviewParams , VortexFSPreviewParams , WindFSPreviewParams
  • GlobalPose : ClothingDebugRenderParams
  • globalPose : AttractorFSPreviewParams , ClothingActorParam , ClothingPreviewParam , DestructibleActorParam
  • Gold : DebugColorParams
  • graphicalLods[] : ClothingAssetParameters
  • GraphicalVertexBones : ClothingDebugRenderParams
  • GraphicsEffects[] : EffectPackageIOFXDatabaseParams
  • GraphicsMaterials[] : EffectPackageGraphicsMaterialsParams::GraphicsMaterials , EffectPackageGraphicsMaterialsParams
  • Gravity : RigidBodyEffect
  • Gray : DebugColorParams
  • Green : DebugColorParams
  • gridBoundaryFadePercentage : JetFSAssetParams
  • GridDensity.Enabled : BasicIOSAssetParam , SimpleParticleSystemParams
  • GridDensity.GridSize : BasicIOSAssetParam , SimpleParticleSystemParams
  • GridDensity.MaxCellCount : SimpleParticleSystemParams , BasicIOSAssetParam
  • GridDensity.Resolution : SimpleParticleSystemParams , BasicIOSAssetParam
  • gridShapeHeight : JetFSAssetParams
  • gridShapeRadius : JetFSAssetParams
  • gridSize : ParticleIosAssetParam
  • gridSizeWorld : TurbulenceFSAssetParams , TurbulenceFSActorParams
  • gridXRange.max : TurbulenceFSAssetParams
  • gridXRange.min : TurbulenceFSAssetParams
  • gridYRange.max : TurbulenceFSAssetParams
  • gridYRange.min : TurbulenceFSAssetParams
  • gridZRange.max : TurbulenceFSAssetParams
  • gridZRange.min : TurbulenceFSAssetParams
  • groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR : EmitterDebugRenderParams
  • groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_NAME : EmitterDebugRenderParams
  • groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_POSE : EmitterDebugRenderParams
  • groundEmitterParameters.VISUALIZE_GROUND_EMITTER_GRID : EmitterDebugRenderParams
  • groundEmitterParameters.VISUALIZE_GROUND_EMITTER_RAYCAST : EmitterDebugRenderParams
  • groundEmitterParameters.VISUALIZE_GROUND_EMITTER_SPHERE : EmitterDebugRenderParams
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- h -

  • HalfResPercent : GraphicsMaterialData
  • hasSeparateBoneBuffer : VertexFormatParameters
  • heatParams.ambientTemperature : TurbulenceFSAssetParams
  • heatParams.heatForceDirection : TurbulenceFSAssetParams
  • heatParams.temperatureBasedForceMultiplier : TurbulenceFSAssetParams
  • heatParams.thermalConductivity : TurbulenceFSAssetParams
  • HeatSource : HeatSourceEffect , HeatSourceData
  • height : SurfaceBufferParameters , VortexFSAssetParams , EmitterGeomCylinderParams
  • hemisphere : EmitterGeomSphereShellParams , EmitterGeomSphereParams
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- i -

  • iconScale : ForceFieldAssetPreviewParams , TurbulenceFSPreviewParams
  • immediateClothMap[] : ClothingGraphicalLodParameters
  • impactAxis : ImpactObjectEvent
  • impactEmitterParameters.THRESHOLD_DISTANCE_IMPACT_EMITTER_ACTOR_NAME : EmitterDebugRenderParams
  • impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR : EmitterDebugRenderParams
  • impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR_NAME : EmitterDebugRenderParams
  • impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_RAYCAST : EmitterDebugRenderParams
  • inAirRotationMultiplier : RotationModifierParams
  • includeShapeParameters.dimensions : ForceFieldAssetParams
  • includeShapeParameters.forceFieldToShape : ForceFieldAssetParams
  • includeShapeParameters.shape : ForceFieldAssetParams
  • includeVerticalDirection : RotationModifierParams
  • indexBuffer[] : SubmeshParameters
  • indexPartition[] : SubmeshParameters
  • InitialAngularVelocity : RigidBodyEffect
  • initialDestructibleActorAllowanceForInstancing : DestructibleAssetParameters
  • InitialLinearVelocity : RigidBodyEffect
  • initialPose : ApexEmitterActorParameters , AttractorFSActorParams , ForceFieldActorParams , HeatSourceActorParams , JetFSActorParams , NoiseFSActorParams , SubstanceSourceActorParams , TurbulenceFSActorParams , VelocitySourceActorParams , VortexFSActorParams , WindFSActorParams
  • InitialPose : EffectPackageActorParams
  • initialScale : AttractorFSActorParams , HeatSourceActorParams , JetFSActorParams , NoiseFSActorParams , SubstanceSourceActorParams , TurbulenceFSActorParams , VelocitySourceActorParams , WindFSActorParams , VortexFSActorParams , ApexEmitterActorParameters
  • interCollisionChannels : ClothingAssetParameters
  • interCollisionDistance : ClothingModuleParameters
  • interCollisionIterations : ClothingModuleParameters
  • interCollisionStiffness : ClothingModuleParameters
  • internalLODWeights.ageWeight : DestructibleActorState
  • internalLODWeights.bias : DestructibleActorState
  • internalLODWeights.distanceWeight : DestructibleActorState
  • internalLODWeights.maxAge : DestructibleActorState
  • internalLODWeights.maxDistance : DestructibleActorState
  • IOFX : GraphicsEffectData
  • iofxAssetName : ApexEmitterAssetParameters , ImpactObjectEvent
  • iofxType : IofxAssetParameters::IofxType , IofxAssetParameters
  • IOS : ParticleSimulationData::IOS , ParticleSimulationData , ParticleSimulationData::IOS
  • iosAssetName : ApexEmitterAssetParameters , ImpactObjectEvent
  • isAutoSwitchingBC : TurbulenceFSActorParams
  • isCached : CachedOverlaps
  • isEnabledOptimizedLOD : TurbulenceFSAssetParams
  • IsoValue : VolumeRenderMaterialData
  • IsoValueSign : VolumeRenderMaterialData
  • isReferenced : RenderMeshAssetParameters
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- p -

  • p3ActorDescTemplate.clientBehaviorBits : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eCCD_LINEAR : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eCONTACT_DEFAULT : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eMODIFY_CONTACTS : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FEATURE_INDICES_PER_POINT : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCE_PER_POINT : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCES : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_POINTS : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_FOUND : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_LOST : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_PERSISTS : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_FOUND : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_LOST : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_PERSISTS : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eRESOLVE_CONTACTS : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eTRIGGER_DEFAULT : DestructibleActorParam
  • p3ActorDescTemplate.dominanceGroup : DestructibleActorParam
  • p3ActorDescTemplate.flags.eDISABLE_GRAVITY : DestructibleActorParam
  • p3ActorDescTemplate.flags.eSEND_SLEEP_NOTIFIES : DestructibleActorParam
  • p3ActorDescTemplate.flags.eVISUALIZATION : DestructibleActorParam
  • p3ActorDescTemplate.name : DestructibleActorParam
  • p3ActorDescTemplate.ownerClient : DestructibleActorParam
  • p3ActorDescTemplate.userData : DestructibleActorParam
  • p3BodyDescTemplate.angularDamping : DestructibleActorParam
  • p3BodyDescTemplate.contactReportThreshold : DestructibleActorParam
  • p3BodyDescTemplate.density : DestructibleActorParam
  • p3BodyDescTemplate.flags.eENABLE_CCD : DestructibleActorParam
  • p3BodyDescTemplate.flags.eKINEMATIC : DestructibleActorParam
  • p3BodyDescTemplate.linearDamping : DestructibleActorParam
  • p3BodyDescTemplate.maxAngularVelocity : DestructibleActorParam
  • p3BodyDescTemplate.sleepLinearVelocity : DestructibleActorParam
  • p3BodyDescTemplate.sleepThreshold : DestructibleActorParam
  • p3BodyDescTemplate.solverIterationCount : DestructibleActorParam
  • p3BodyDescTemplate.velocityIterationCount : DestructibleActorParam
  • p3BodyDescTemplate.wakeUpCounter : DestructibleActorParam
  • p3ShapeDescTemplate.contactOffset : DestructibleActorParam
  • p3ShapeDescTemplate.flags.eDEFORMABLE_DRAIN : DestructibleActorParam
  • p3ShapeDescTemplate.flags.ePARTICLE_DRAIN : DestructibleActorParam
  • p3ShapeDescTemplate.flags.eSCENE_QUERY_SHAPE : DestructibleActorParam
  • p3ShapeDescTemplate.flags.eSIMULATION_SHAPE : DestructibleActorParam
  • p3ShapeDescTemplate.flags.eTRIGGER_SHAPE : DestructibleActorParam
  • p3ShapeDescTemplate.flags.eVISUALIZATION : DestructibleActorParam
  • p3ShapeDescTemplate.material : DestructibleActorParam
  • p3ShapeDescTemplate.name : DestructibleActorParam
  • p3ShapeDescTemplate.queryFilterData.word0 : DestructibleActorParam
  • p3ShapeDescTemplate.queryFilterData.word1 : DestructibleActorParam
  • p3ShapeDescTemplate.queryFilterData.word2 : DestructibleActorParam
  • p3ShapeDescTemplate.queryFilterData.word3 : DestructibleActorParam
  • p3ShapeDescTemplate.restOffset : DestructibleActorParam
  • p3ShapeDescTemplate.simulationFilterData.word0 : DestructibleActorParam
  • p3ShapeDescTemplate.simulationFilterData.word1 : DestructibleActorParam
  • p3ShapeDescTemplate.simulationFilterData.word2 : DestructibleActorParam
  • p3ShapeDescTemplate.simulationFilterData.word3 : DestructibleActorParam
  • p3ShapeDescTemplate.userData : DestructibleActorParam
  • partBounds[] : RenderMeshAssetParameters
  • particleMass : ParticleIosAssetParam
  • particleMass.center : BasicIOSAssetParam
  • particleMass.spread : BasicIOSAssetParam
  • particleMass.type : BasicIOSAssetParam
  • particleRadius : BasicIOSAssetParam , ParticleIosAssetParam
  • ParticleSimulations[] : EffectPackageIOSDatabaseParams
  • particleSpawnCount : ImpactObjectEvent
  • particleType : ParticleIosAssetParam::ParticleType , ParticleIosAssetParam
  • Path.ControlPoints[] : EffectPackageAssetParams
  • Path.LoopIndex : EffectPackageAssetParams
  • Path.PathDuration : EffectPackageAssetParams
  • Path.PlaybackMode : EffectPackageAssetParams
  • Path.Scale[].x : EffectPackageAssetParams
  • Path.Scale[].y : EffectPackageAssetParams
  • Path.Speed[].x : EffectPackageAssetParams
  • Path.Speed[].y : EffectPackageAssetParams
  • performDetailedOverlapTestForExtendedStructures : DestructibleActorParam
  • PerParticleCollisionCacheHint : ParticleIosAssetParam
  • PerParticleRestOffset : ParticleIosAssetParam
  • physicalLods[].costWithoutIterations : ClothingPhysicalMeshParameters
  • physicalLods[].maxDistanceReduction : ClothingPhysicalMeshParameters
  • physicalLods[].solverIterationScale : ClothingPhysicalMeshParameters
  • physicalLods[].submeshId : ClothingPhysicalMeshParameters
  • physicalMesh.averageEdgeLength : ClothingPhysicalMeshParameters
  • physicalMesh.boneIndices[] : ClothingPhysicalMeshParameters
  • physicalMesh.boneWeights[] : ClothingPhysicalMeshParameters
  • physicalMesh.constrainCoefficients[].collisionSphereDistance : ClothingPhysicalMeshParameters
  • physicalMesh.constrainCoefficients[].collisionSphereRadius : ClothingPhysicalMeshParameters
  • physicalMesh.constrainCoefficients[].maxDistance : ClothingPhysicalMeshParameters
  • physicalMesh.flipNormals : ClothingPhysicalMeshParameters
  • physicalMesh.hasNegativeBackstop : ClothingPhysicalMeshParameters
  • physicalMesh.indices[] : ClothingPhysicalMeshParameters
  • physicalMesh.isClosed : ClothingPhysicalMeshParameters
  • physicalMesh.isTetrahedralMesh : ClothingPhysicalMeshParameters
  • physicalMesh.maximumMaxDistance : ClothingPhysicalMeshParameters
  • physicalMesh.normals[] : ClothingPhysicalMeshParameters
  • physicalMesh.numBonesPerVertex : ClothingPhysicalMeshParameters
  • physicalMesh.numIndices : ClothingPhysicalMeshParameters
  • physicalMesh.numVertices : ClothingPhysicalMeshParameters
  • physicalMesh.optimizationData[] : ClothingPhysicalMeshParameters
  • physicalMesh.physicalMeshSorting : ClothingPhysicalMeshParameters
  • physicalMesh.shortestEdgeLength : ClothingPhysicalMeshParameters
  • physicalMesh.skinningNormals[] : ClothingPhysicalMeshParameters
  • physicalMesh.vertices[] : ClothingPhysicalMeshParameters
  • physicalMeshes[] : ClothingAssetParameters
  • physicalMeshId : ClothingGraphicalLodParameters , ClothingCookedPhysX3Param
  • physicalSubMeshId : ClothingCookedPhysX3Param
  • PhysicalVertexBones : ClothingDebugRenderParams
  • PhysicsMeshIndices : ClothingDebugRenderParams
  • PhysicsMeshNormals : ClothingDebugRenderParams
  • PhysicsMeshSolid : ClothingDebugRenderParams
  • PhysicsMeshWire : ClothingDebugRenderParams
  • physicsSubmeshPartitioning[].graphicalSubmesh : ClothingGraphicalLodParameters
  • physicsSubmeshPartitioning[].numSimulatedIndices : ClothingGraphicalLodParameters
  • physicsSubmeshPartitioning[].numSimulatedVertices : ClothingGraphicalLodParameters
  • physicsSubmeshPartitioning[].numSimulatedVerticesAdditional : ClothingGraphicalLodParameters
  • physicsSubmeshPartitioning[].physicalSubmesh : ClothingGraphicalLodParameters
  • pivotRadius : JetFSAssetParams
  • planeCount : ConvexHullParameters
  • platforms[] : ClothingGraphicalLodParameters
  • points.positions[].doDetectOverlaps : EmitterGeomExplicitParams
  • points.positions[].position : EmitterGeomExplicitParams
  • points.velocities[] : EmitterGeomExplicitParams
  • pose : ForceFieldAssetPreviewParams , VelocitySourcePreviewParams , HeatSourcePreviewParams , EmitterAssetPreviewParameters
  • PoseArrows : DebugColorParams
  • position : SubstanceSourceAssetParams
  • positionMultiplier : GenericForceFieldKernelParams
  • positionOffset : SurfaceTraceSetParameters
  • positionTarget : GenericForceFieldKernelParams
  • pressure : ClothingActorParam
  • projectionPlaneDistance : ParticleIosAssetParam
  • projectionPlaneNormal : ParticleIosAssetParam
  • ProjectToPlane : ParticleIosAssetParam
  • PSM_Frustum.FrustumDepth : GraphicsMaterialData
  • PSM_Frustum.FrustumSize : GraphicsMaterialData
  • PSM_Frustum.ShowFrustum : GraphicsMaterialData
  • PSM_ShadowBias : GraphicsMaterialData
  • Purple : DebugColorParams
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- r -

  • radialStrength : VortexFSAssetParams
  • radius : AttractorFSAssetParams , EmitterGeomSphereParams , HeatSourceGeomSphereParams , RadialForceFieldKernelParams , EmitterGeomSphereShellParams , EmitterGeomCylinderParams , GroundEmitterActorParameters , GroundEmitterAssetParameters
  • rateRange.max : ApexEmitterAssetParameters
  • rateRange.min : ApexEmitterAssetParameters
  • rateVsTimeCurvePoints[].x : ApexEmitterAssetParameters
  • rateVsTimeCurvePoints[].y : ApexEmitterAssetParameters
  • raycastCollisionGroupMaskName : GroundEmitterActorParameters , GroundEmitterAssetParameters
  • raycastHeight : GroundEmitterActorParameters , GroundEmitterAssetParameters
  • RayJitter : VolumeRenderMaterialData
  • ReadDepth : VolumeRenderMaterialData
  • RecomputeSubmeshes : ClothingDebugRenderParams
  • RecomputeVertices : ClothingDebugRenderParams
  • Red : DebugColorParams
  • referenceCount : ClothingPhysicalMeshParameters
  • RelativeLodBenefitsScreenPos : DebugRenderParams
  • RelativeLodBenefitsThickness : DebugRenderParams
  • RenderBitangents : DebugRenderParams
  • renderMeshAsset : ClothingGraphicalLodParameters , DestructibleAssetParameters
  • renderMeshAssetSorting : ClothingGraphicalLodParameters
  • renderMeshList[].meshAssetName : MeshIofxParameters
  • renderMeshList[].weight : MeshIofxParameters
  • RenderMethod : VolumeRenderMaterialData
  • RenderMode : VolumeRenderMaterialData
  • RenderNormals : DebugRenderParams
  • renderOutput.useFloat4Color : IofxAssetParameters
  • renderOutput.useUserSemantic : IofxAssetParameters
  • renderStaticChunksSeparately : DestructibleActorParam
  • RenderTangents : DebugRenderParams
  • RenderTechnique : GraphicsMaterialData
  • renderUnexplodedChunksStatically : DestructiblePreviewParam
  • Resolution : GraphicsMaterialData
  • ResolutionScale : VolumeRenderMaterialData
  • restDensity : BasicIOSAssetParam
  • restitution : ParticleIosAssetParam
  • restitutionForDynamicShapes : BasicIOSAssetParam
  • restitutionForStaticShapes : BasicIOSAssetParam
  • restOffset : ParticleIosAssetParam
  • restParticleDistance : FluidParticleSystemParams
  • rollType : RotationModifierParams
  • rootBoneIndex : ClothingAssetParameters
  • rotationalStrength : VortexFSAssetParams
  • rotationRate : RotationRateModifierParams
  • RTFractureBehaviorGroup : DestructibleAssetParameters
  • runtimeCooked : ClothingActorParam
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- s -

  • scale : DestructibleActorParam , EmitterAssetPreviewParameters , HeatSourcePreviewParams , VelocitySourcePreviewParams , ForceFieldActorParams
  • Scale : DebugRenderParams
  • scaleAxis : ScaleVsDensityModifierParams , ScaleVsLifeModifierParams , ScaleVsTemperatureModifierParams , ScaleVsCameraDistanceModifierParams
  • scaleChangeDelay : OrientScaleAlongScreenVelocityModifierParams
  • scaleChangeLimit : OrientScaleAlongScreenVelocityModifierParams
  • scaledMassExponent : DestructibleModuleParameters
  • scaleFactor : ScaleAlongVelocityModifierParams , SimpleScaleModifierParams
  • scalePerVelocity : OrientScaleAlongScreenVelocityModifierParams
  • scales[] : DestructibleAssetCollisionDataSet
  • scatterMeshAssets[] : DestructibleAssetParameters
  • scatterMeshIndices[] : DestructibleAssetParameters
  • scatterMeshTransforms[].matrix : DestructibleAssetParameters
  • scatterMeshTransforms[].vector : DestructibleAssetParameters
  • sceneGravityScale : BasicIOSAssetParam
  • SelfCollision : ClothingDebugRenderParams
  • SelfCollisionAttenuation : ClothingDebugRenderParams
  • selfCollisionIndices[] : ClothingCookedPhysX3Param
  • selfCollisionNormalIndices[] : ClothingCookedPhysX3Param
  • selfCollisionNormalSetSizes[] : ClothingCookedPhysX3Param
  • SelfCollisionWire : ClothingDebugRenderParams
  • ShadowAmount : VolumeRenderMaterialData
  • ShadowDensity : VolumeRenderMaterialData
  • ShadowDistance : VolumeRenderMaterialData
  • ShadowJitter : VolumeRenderMaterialData
  • ShadowSamples : VolumeRenderMaterialData
  • Shape : DebugColorParams
  • shapeDescTemplate.collisionGroup : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.density : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_CLOTH_DISABLE_COLLISION : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_CLOTH_DRAIN : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_CLOTH_TWOWAY : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_DISABLE_RESPONSE : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_FEATURE_INDICES : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_FLUID_DISABLE_COLLISION : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_FLUID_DRAIN : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_FLUID_TWOWAY : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_POINT_CONTACT_FORCE : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_SOFTBODY_DISABLE_COLLISION : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_SOFTBODY_DRAIN : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_SOFTBODY_TWOWAY : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_VISUALIZATION : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.flags.NX_TRIGGER_ON_ENTER : DestructibleActorParam
  • shapeDescTemplate.flags.NX_TRIGGER_ON_LEAVE : DestructibleActorParam
  • shapeDescTemplate.flags.NX_TRIGGER_ON_STAY : DestructibleActorParam
  • shapeDescTemplate.groupsMask.bits0 : DestructibleActorParam , ClothingActorParam
  • shapeDescTemplate.groupsMask.bits1 : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.groupsMask.bits2 : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.groupsMask.bits3 : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.groupsMask.useGroupsMask : DestructibleActorParam
  • shapeDescTemplate.materialIndex : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.name : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.skinWidth : DestructibleActorParam
  • shapeDescTemplate.userData : ClothingActorParam , DestructibleActorParam
  • ShearingFibers : ClothingDebugRenderParams
  • shellThickness : EmitterGeomSphereShellParams
  • ShowInLocalSpace : ClothingDebugRenderParams
  • simulation.disableCCD : ClothingAssetParameters
  • simulation.gravityDirection : ClothingAssetParameters
  • simulation.hierarchicalLevels : ClothingAssetParameters
  • simulation.restLengthScale : ClothingAssetParameters
  • simulation.sleepLinearVelocity : ClothingAssetParameters
  • simulation.thickness : ClothingAssetParameters
  • simulation.twowayInteraction : ClothingAssetParameters
  • simulation.untangling : ClothingAssetParameters
  • simulation.virtualParticleDensity : ClothingAssetParameters
  • simulationBackend : ClothingActorParam
  • simulationFilterData : ParticleIosAssetParam
  • Skeleton : ClothingDebugRenderParams
  • skinClothMap[].normalBary : ClothingGraphicalLodParameters
  • skinClothMap[].tangentBary : ClothingGraphicalLodParameters
  • skinClothMap[].vertexBary : ClothingGraphicalLodParameters
  • skinClothMap[].vertexIndex0 : ClothingGraphicalLodParameters
  • skinClothMap[].vertexIndex1 : ClothingGraphicalLodParameters
  • skinClothMap[].vertexIndex2 : ClothingGraphicalLodParameters
  • skinClothMap[].vertexIndexPlusOffset : ClothingGraphicalLodParameters
  • skinClothMapB[].faceIndex0 : ClothingGraphicalLodParameters
  • skinClothMapB[].nrmTetraBary : ClothingGraphicalLodParameters
  • skinClothMapB[].submeshIndex : ClothingGraphicalLodParameters
  • skinClothMapB[].tetraIndex : ClothingGraphicalLodParameters
  • skinClothMapB[].vertexIndexPlusOffset : ClothingGraphicalLodParameters
  • skinClothMapB[].vtxTetraBary : ClothingGraphicalLodParameters
  • skinClothMapOffset : ClothingGraphicalLodParameters
  • skinClothMapThickness : ClothingGraphicalLodParameters
  • SkinMapActual : ClothingDebugRenderParams
  • SkinMapAll : ClothingDebugRenderParams
  • SkinMapBad : ClothingDebugRenderParams
  • SkinMapInvalidBary : ClothingDebugRenderParams
  • SkinnedPositions : ClothingDebugRenderParams
  • sleepVelocityFrameDecayConstant : DestructibleActorParam
  • slowStart : ClothingActorParam
  • smoothingGroups[] : SubmeshParameters
  • SolverMode : ClothingDebugRenderParams
  • sortFIFOByBenefit : DestructibleModuleParameters
  • sortType : ViewDirectionSortingModifierParams
  • spaceScale : ForceFieldNoiseParams
  • sparseSelfCollision : ClothingModuleParameters
  • spawnHeight : GroundEmitterAssetParameters , GroundEmitterActorParameters
  • spawnModifierList[]
: SpriteIofxParameters::SpawnModifierList
, MeshIofxParameters::SpawnModifierList
, MeshIofxParameters
, SpriteIofxParameters::SpawnModifierList
, MeshIofxParameters::SpawnModifierList
, SpriteIofxParameters::SpawnModifierList
, MeshIofxParameters::SpawnModifierList
, SpriteIofxParameters
, MeshIofxParameters::SpawnModifierList
, SpriteIofxParameters::SpawnModifierList
, MeshIofxParameters::SpawnModifierList
  • speedRange.max : ImpactObjectEvent
  • speedRange.min : ImpactObjectEvent
  • spheres.positions[].center : EmitterGeomExplicitParams
  • spheres.positions[].doDetectOverlaps : EmitterGeomExplicitParams
  • spheres.positions[].radius : EmitterGeomExplicitParams
  • spheres.velocities[] : EmitterGeomExplicitParams
  • spriteMaterialName : SpriteIofxParameters
  • start : ForceFieldFalloffParams
  • staticCollision : BasicIOSAssetParam
  • staticFriction : ParticleIosAssetParam
  • staticMaterialNames[] : DestructibleAssetParameters
  • stdDensity : SubstanceSourceAssetParams , SubstanceSourceActorParams
  • stdTemperature : HeatSourceAssetParams , HeatSourceActorParams
  • stdVelocity : VelocitySourceActorParams , VelocitySourceAssetParams
  • StepScale : VolumeRenderMaterialData
  • stiffness : FluidParticleSystemParams
  • strength : ForceFieldAssetParams , ForceFieldNoiseParams
  • structureSettings.stressSolverMassThreshold : DestructibleActorParam
  • structureSettings.stressSolverTimeDelay : DestructibleActorParam
  • structureSettings.useStressSolver : DestructibleActorParam
  • submeshes[] : RenderMeshAssetParameters
  • submeshes[].numIndices : ClothingPhysicalMeshParameters
  • submeshes[].numMaxDistance0Vertices : ClothingPhysicalMeshParameters
  • submeshes[].numVertices : ClothingPhysicalMeshParameters
  • submeshIndices[] : SurfaceTraceParameters
  • SubstanceSource : SubstanceSourceEffect , SubstanceSourceData
  • supportDepth : DestructibleActorParam , DestructibleAssetParameters
  • surfaceFormat : SurfaceBufferParameters
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- t -

  • teleportMode : ClothingActorParam
  • temperatureRange.max : ApexEmitterAssetParameters
  • temperatureRange.min : ApexEmitterAssetParameters
  • tetherAnchors[] : ClothingCookedPhysX3Param
  • tetherLengths[] : ClothingCookedPhysX3Param
  • TethersActive : ClothingDebugRenderParams
  • TethersInactive : ClothingDebugRenderParams
  • tetraMap[]._dummyForAlignment : ClothingGraphicalLodParameters
  • tetraMap[].normalBary : ClothingGraphicalLodParameters
  • tetraMap[].tetraIndex0 : ClothingGraphicalLodParameters
  • tetraMap[].vertexBary : ClothingGraphicalLodParameters
  • Text0 : DebugColorParams
  • Text1 : DebugColorParams
  • TextureRangeMax : VolumeRenderMaterialData
  • TextureRangeMin : VolumeRenderMaterialData
  • textureUVOrigin : RenderMeshAssetParameters
  • THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_NAME : DestructibleDebugRenderParams
  • THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_POSE : DestructibleDebugRenderParams
  • THRESHOLD_DISTANCE_DESTRUCTIBLE_FRAGMENT_POSE : DestructibleDebugRenderParams
  • timeScale : ForceFieldNoiseParams
  • toolString : ClothingAssetParameters
  • topRadius : VortexFSAssetParams
  • topSphericalForce : VortexFSAssetParams
  • traces[] : SurfaceTraceSetParameters
  • transitionDown[].normalBary : ClothingPhysicalMeshParameters
  • transitionDown[].tangentBary : ClothingPhysicalMeshParameters
  • transitionDown[].vertexBary : ClothingPhysicalMeshParameters
  • transitionDown[].vertexIndex0 : ClothingPhysicalMeshParameters
  • transitionDown[].vertexIndex1 : ClothingPhysicalMeshParameters
  • transitionDown[].vertexIndex2 : ClothingPhysicalMeshParameters
  • transitionDown[].vertexIndexPlusOffset : ClothingPhysicalMeshParameters
  • transitionDownB[].faceIndex0 : ClothingPhysicalMeshParameters
  • transitionDownB[].nrmTetraBary : ClothingPhysicalMeshParameters
  • transitionDownB[].submeshIndex : ClothingPhysicalMeshParameters
  • transitionDownB[].tetraIndex : ClothingPhysicalMeshParameters
  • transitionDownB[].vertexIndexPlusOffset : ClothingPhysicalMeshParameters
  • transitionDownB[].vtxTetraBary : ClothingPhysicalMeshParameters
  • transitionDownOffset : ClothingPhysicalMeshParameters
  • transitionDownThickness : ClothingPhysicalMeshParameters
  • transitionUp[].normalBary : ClothingPhysicalMeshParameters
  • transitionUp[].tangentBary : ClothingPhysicalMeshParameters
  • transitionUp[].vertexBary : ClothingPhysicalMeshParameters
  • transitionUp[].vertexIndex0 : ClothingPhysicalMeshParameters
  • transitionUp[].vertexIndex1 : ClothingPhysicalMeshParameters
  • transitionUp[].vertexIndex2 : ClothingPhysicalMeshParameters
  • transitionUp[].vertexIndexPlusOffset : ClothingPhysicalMeshParameters
  • transitionUpB[].faceIndex0 : ClothingPhysicalMeshParameters
  • transitionUpB[].nrmTetraBary : ClothingPhysicalMeshParameters
  • transitionUpB[].submeshIndex : ClothingPhysicalMeshParameters
  • transitionUpB[].tetraIndex : ClothingPhysicalMeshParameters
  • transitionUpB[].vertexIndexPlusOffset : ClothingPhysicalMeshParameters
  • transitionUpB[].vtxTetraBary : ClothingPhysicalMeshParameters
  • transitionUpOffset : ClothingPhysicalMeshParameters
  • transitionUpThickness : ClothingPhysicalMeshParameters
  • TURBULENCE_FS_LOD : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_PLANE.normal : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_PLANE.offset : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_SCALAR_FIELD_SCALE : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_SCALAR_FIELD_SPACING : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_STREAMLINES.grid : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_STREAMLINES.tmax : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_STREAMLINES.tstep : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_VELOCITY_FIELD_SCALE : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_VELOCITY_FIELD_SPACING : TurbulenceFSDebugRenderParams
  • TurbulenceFieldSampler : TurbulenceFieldSamplerEffect , TurbulenceFieldSamplerData
  • Type : RigidBodyEffect
  • type : ForceFieldFalloffParams
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- u -

  • uniqueEdgeDirectionCount : ConvexHullParameters
  • uniquePlanes[].d : ConvexHullParameters
  • uniquePlanes[].normal : ConvexHullParameters
  • unused : BasicFSModuleParameters , ForceFieldModuleParams , IofxModuleParameters , BasicIosModuleParameters , ParticleIosModuleParameters , ParticlesModuleParameters , EmitterModuleParameters , TurbulenceFSModuleParameters , FieldSamplerModuleParameters
  • updatesPerFrameRange.max : TurbulenceFSAssetParams
  • updatesPerFrameRange.min : TurbulenceFSAssetParams
  • updateStateWithGlobalMatrices : ClothingPreviewParam , ClothingActorParam
  • upDirection : GroundEmitterActorParameters
  • useAssetDefinedSupport : DestructibleActorParam , DestructibleAssetParameters
  • useDensity : TurbulenceFSAssetParams
  • useHardSleeping : DestructibleActorParam
  • useHardwareCloth : ClothingActorParam
  • useHeat : TurbulenceFSAssetParams
  • useInternalBoneOrder : ClothingActorParam , ClothingPreviewParam
  • useLocalSpace : NoiseFSAssetParams
  • UsePSM : GraphicsMaterialData
  • userData : DestructiblePreviewParam , JetFSPreviewParams , ClothingPreviewParam , AttractorFSPreviewParams , NoiseFSPreviewParams , VortexFSPreviewParams , TurbulenceFSPreviewParams , WindFSPreviewParams , ClothingActorParam , DestructibleActorState
  • UserProperties : GraphicsMaterialData , VolumeRenderMaterialData
  • useVelocityClamping : ClothingActorParam
  • useWorldSupport : DestructibleAssetParameters , DestructibleActorParam
  • uvChannelForTangentUpdate : ClothingActorParam
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- v -

  • validBoundsPadding : DestructibleModuleParameters
  • variableFieldStrength : AttractorFSAssetParams
  • Velocities : ClothingDebugRenderParams
  • velocity0 : ColorVsVelocityCompositeModifierParams , ColorVsVelocityModifierParams
  • velocity1 : ColorVsVelocityCompositeModifierParams , ColorVsVelocityModifierParams
  • velocityFieldFadeDelay : TurbulenceFSAssetParams
  • velocityFieldFadeIntensity : TurbulenceFSAssetParams
  • velocityFieldFadeTime : TurbulenceFSAssetParams
  • velocityMultiplier : GenericForceFieldKernelParams
  • velocityRange.max : ApexEmitterAssetParameters , GroundEmitterAssetParameters
  • velocityRange.min : ApexEmitterAssetParameters , GroundEmitterAssetParameters
  • VelocitySource : VelocitySourceData , VelocitySourceEffect
  • velocityTarget : GenericForceFieldKernelParams
  • vertexBuffer : SubmeshParameters
  • vertexCount : VertexBufferParameters
  • vertexFormat : VertexBufferParameters
  • vertexIndices[] : SurfaceTraceParameters
  • vertexPartition[] : SubmeshParameters
  • vertexVelocityClamp : ClothingActorParam
  • vertices[] : ConvexHullParameters
  • VirtualCollision : ClothingDebugRenderParams
  • virtualParticleIndices[] : ClothingCookedParam , ClothingCookedPhysX3Param
  • virtualParticleWeights[] : ClothingCookedParam , ClothingCookedPhysX3Param
  • viscosity : FluidParticleSystemParams
  • VISUALIZE_ATTRACTOR_FS_ACTOR : BasicFSDebugRenderParams
  • VISUALIZE_ATTRACTOR_FS_ACTOR_NAME : BasicFSDebugRenderParams
  • VISUALIZE_ATTRACTOR_FS_FIELD : BasicFSDebugRenderParams
  • VISUALIZE_ATTRACTOR_FS_POSE : BasicFSDebugRenderParams
  • VISUALIZE_ATTRACTOR_FS_SHAPE : BasicFSDebugRenderParams
  • VISUALIZE_BASIC_IOS_ACTOR : BasicIosDebugRenderParams
  • VISUALIZE_BASIC_IOS_COLLIDE_SHAPES : BasicIosDebugRenderParams
  • VISUALIZE_BASIC_IOS_GRID_DENSITY : BasicIosDebugRenderParams
  • VISUALIZE_DESTRUCTIBLE_ACTOR : DestructibleDebugRenderParams
  • VISUALIZE_DESTRUCTIBLE_ACTOR_NAME : DestructibleDebugRenderParams
  • VISUALIZE_DESTRUCTIBLE_ACTOR_POSE : DestructibleDebugRenderParams
  • VISUALIZE_DESTRUCTIBLE_BOUNDS : DestructibleDebugRenderParams
  • VISUALIZE_DESTRUCTIBLE_FRAGMENT_POSE : DestructibleDebugRenderParams
  • VISUALIZE_DESTRUCTIBLE_SUPPORT : DestructibleDebugRenderParams
  • VISUALIZE_EFFECT_PACKAGE_ACTOR : ParticlesDebugRenderParams
  • VISUALIZE_FORCEFIELD_ACTOR : ForceFieldDebugRenderParams
  • VISUALIZE_HEAT_SOURCE_ACTOR : ParticlesDebugRenderParams , TurbulenceFSDebugRenderParams
  • VISUALIZE_IOFX_ACTOR : IofxDebugRenderParams
  • VISUALIZE_IOFX_ACTOR_NAME : IofxDebugRenderParams
  • VISUALIZE_IOFX_BOUNDING_BOX : IofxDebugRenderParams
  • VISUALIZE_JET_FS_ACTOR : BasicFSDebugRenderParams
  • VISUALIZE_JET_FS_ACTOR_NAME : BasicFSDebugRenderParams
  • VISUALIZE_JET_FS_FIELD : BasicFSDebugRenderParams
  • VISUALIZE_JET_FS_POSE : BasicFSDebugRenderParams
  • VISUALIZE_JET_FS_SHAPE : BasicFSDebugRenderParams
  • VISUALIZE_NOISE_FS_ACTOR : BasicFSDebugRenderParams
  • VISUALIZE_NOISE_FS_ACTOR_NAME : BasicFSDebugRenderParams
  • VISUALIZE_NOISE_FS_POSE : BasicFSDebugRenderParams
  • VISUALIZE_NOISE_FS_SHAPE : BasicFSDebugRenderParams
  • VISUALIZE_PARTICLE_IOS_ACTOR : ParticleIosDebugRenderParams
  • VISUALIZE_PARTICLE_IOS_GRID_DENSITY : ParticleIosDebugRenderParams
  • VISUALIZE_SUBSTANCE_SOURCE_ACTOR : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_ACTOR : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_ACTOR_NAME : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_BBOX : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_DENSITY_FIELD : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_GRID : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_LOD : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_PLANE : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_POSE : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_PRESSURE_FIELD : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_STREAMLINES : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_TEMPERATURE_FIELD : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_VELOCITY : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_VELOCITY_FIELD : TurbulenceFSDebugRenderParams
  • VISUALIZE_VELOCITY_SOURCE_ACTOR : TurbulenceFSDebugRenderParams
  • VISUALIZE_VORTEX_FS_ACTOR : BasicFSDebugRenderParams
  • VISUALIZE_VORTEX_FS_ACTOR_NAME : BasicFSDebugRenderParams
  • VISUALIZE_VORTEX_FS_FIELD : BasicFSDebugRenderParams
  • VISUALIZE_VORTEX_FS_POSE : BasicFSDebugRenderParams
  • VISUALIZE_VORTEX_FS_SHAPE : BasicFSDebugRenderParams
  • VISUALIZE_WIND_FS_ACTOR : BasicFSDebugRenderParams
  • VISUALIZE_WIND_FS_ACTOR_NAME : BasicFSDebugRenderParams
  • volume : ConvexHullParameters
  • volumeRenderMaterialName : TurbulenceFSAssetParams
  • VortexFieldSampler : VortexFieldSamplerData , VortexFieldSamplerEffect
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- w -

  • White : DebugColorParams
  • width : SurfaceBufferParameters
  • widths[] : ConvexHullParameters
  • Wind : ClothingDebugRenderParams
  • WindFieldSampler : WindFieldSamplerData , WindFieldSamplerEffect
  • winding : VertexFormatParameters
  • windParams.Adaption : ClothingActorParam
  • windParams.Velocity : ClothingActorParam
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- y -

  • Yellow : DebugColorParams
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- a -

  • actorChunks : DestructibleActorState
  • actorDescTemplate.actorCollisionGroup : DestructibleActorParam
  • actorDescTemplate.compartment : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_IGNORE_PAIR : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_CONTACT_MODIFICATION : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_FORCES : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH_FORCE_THRESHOLD : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_IMPACT : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_ROLL : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_SLIDE : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH_FORCE_THRESHOLD : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH : DestructibleActorParam
  • actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH_FORCE_THRESHOLD : DestructibleActorParam
  • actorDescTemplate.density : DestructibleActorParam
  • actorDescTemplate.dominanceGroup : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_CONTACT_MODIFICATION : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_DISABLE_COLLISION : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_DISABLE_RESPONSE : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_FLUID_DISABLE_COLLISION : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_FORCE_CONE_FRICTION : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_LOCK_COM : DestructibleActorParam
  • actorDescTemplate.flags.NX_AF_USER_ACTOR_PAIR_FILTERING : DestructibleActorParam
  • actorDescTemplate.forceFieldMaterial : DestructibleActorParam
  • actorDescTemplate.name : ClothingActorParam , DestructibleActorParam
  • actorDescTemplate.userData : ClothingActorParam , DestructibleActorParam
  • actorParameters : DestructibleActorState
  • Actors : ClothingDebugRenderParams
  • actorScale : ClothingActorParam , ClothingCookedParam
  • actorTransforms[] : DestructibleAssetParameters
  • adjacentFaces[] : ConvexHullParameters
  • allowAdaptiveTargetFrequency : ClothingActorParam
  • allowApexWorkBetweenSubsteps : ClothingModuleParameters
  • allowAsyncCooking : ClothingModuleParameters
  • angleRange.max : ImpactObjectEvent
  • angleRange.min : ImpactObjectEvent
  • AngularDamping : RigidBodyEffect
  • angularVelocityClamp : TurbulenceFSAssetParams
  • angularVelocityMultiplier : TurbulenceFSAssetParams
  • apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_NAME : EmitterDebugRenderParams
  • apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_POSE : EmitterDebugRenderParams
  • apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR : EmitterDebugRenderParams
  • apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_NAME : EmitterDebugRenderParams
  • apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_POSE : EmitterDebugRenderParams
  • apexEmitterParameters.VISUALIZE_TOTAL_INJECTED_AABB : EmitterDebugRenderParams
  • ApplicationMaterialName : VolumeRenderMaterialData , GraphicsMaterialData
  • assetName : DestructibleAssetCollisionDataSet
  • asyncFetchResults : ClothingModuleParameters
  • attachRelativePose : ApexEmitterActorParameters
  • attachRelativePosition : GroundEmitterActorParameters
  • AttractorFieldSampler : AttractorFieldSamplerData , AttractorFieldSamplerEffect
  • averageDensity : SubstanceSourceActorParams , SubstanceSourceAssetParams
  • averageEndDistance : JetFSAssetParams
  • averageStartDistance : JetFSAssetParams
  • averageTemperature : HeatSourceAssetParams , HeatSourceActorParams
  • averageVelocity : VelocitySourceActorParams , VelocitySourceAssetParams
  • avgSimFrequencyWindow : ClothingModuleParameters
  • axis : VortexFSAssetParams
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- j -

  • JET_FS_FIELD_SCALE : BasicFSDebugRenderParams
  • JetFieldSampler : JetFieldSamplerEffect , JetFieldSamplerData
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- k -

  • keepPreviousFrameBoneBuffer : DestructibleActorParam
  • keepVisibleBonesPacked : DestructibleActorParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- l -

  • LengthFibers : ClothingDebugRenderParams
  • lifeRange.max : ImpactObjectEvent
  • lifeRange.min : ImpactObjectEvent
  • lifetime : ForceFieldAssetParams
  • lifetimeRange.max : ApexEmitterAssetParameters , GroundEmitterAssetParameters
  • lifetimeRange.min : GroundEmitterAssetParameters , ApexEmitterAssetParameters
  • liftStrength : VortexFSAssetParams
  • LightBlue : DebugColorParams
  • LightColor : VolumeRenderMaterialData
  • LightDir : VolumeRenderMaterialData
  • LightGray : DebugColorParams
  • LightGreen : DebugColorParams
  • LightRed : DebugColorParams
  • LinearDamping : RigidBodyEffect
  • linearVelocityClamp : TurbulenceFSAssetParams
  • linearVelocityMultiplier : TurbulenceFSAssetParams
  • localSpaceSim : ClothingActorParam
  • lod : ClothingGraphicalLodParameters , DestructibleActorState
  • LodBenefits : DebugRenderParams
  • LodDistanceScale : DebugRenderParams
  • lodParamDesc.bias : ApexEmitterAssetParameters , ImpactObjectEvent
  • lodParamDesc.distanceWeight : ApexEmitterAssetParameters , ImpactObjectEvent
  • lodParamDesc.lifeWeight : ApexEmitterAssetParameters , ImpactObjectEvent
  • lodParamDesc.maxDistance : ApexEmitterAssetParameters , ImpactObjectEvent
  • lodParamDesc.separationWeight : ApexEmitterAssetParameters , ImpactObjectEvent
  • lodParamDesc.speedWeight : ApexEmitterAssetParameters , ImpactObjectEvent
  • lodParamDesc.version : ApexEmitterAssetParameters , ImpactObjectEvent
  • LODSettings.CullByDistance : EffectPackageAssetParams
  • LODSettings.CullOffScreen : EffectPackageAssetParams
  • LODSettings.FadeAttractorFieldStrength : EffectPackageAssetParams
  • LODSettings.FadeDistanceBegin : EffectPackageAssetParams
  • LODSettings.FadeDistanceEnd : EffectPackageAssetParams
  • LODSettings.FadeEmitterRate : EffectPackageAssetParams
  • LODSettings.FadeForceFieldScale : EffectPackageAssetParams
  • LODSettings.FadeForceFieldStrength : EffectPackageAssetParams
  • LODSettings.FadeHeatSourceTemperature : EffectPackageAssetParams
  • LODSettings.FadeJetFieldStrength : EffectPackageAssetParams
  • LODSettings.FadeOutRate : EffectPackageAssetParams
  • LODSettings.FadeTurbulenceExternalVelocity : EffectPackageAssetParams
  • LODSettings.FadeTurbulenceNoise : EffectPackageAssetParams
  • LODSettings.FadeTurbulenceVelocity : EffectPackageAssetParams
  • LODSettings.FadeTurbulenceVelocityWeight : EffectPackageAssetParams
  • LODSettings.NonVisibleDeleteTime : EffectPackageAssetParams
  • LODSettings.OffScreenCullTime : EffectPackageAssetParams
  • LODSettings.RandomizeEmitterRate : EffectPackageAssetParams
  • LODSettings.ScreenCullDistance : EffectPackageAssetParams
  • LODSettings.ScreenCullSize : EffectPackageAssetParams
  • LODSettings.UniqueRenderVolume : EffectPackageAssetParams
  • lodWeights.benefitBias : TurbulenceFSAssetParams
  • lodWeights.benefitsBias : ClothingActorParam
  • lodWeights.benefitWeight : TurbulenceFSAssetParams
  • lodWeights.bias : TurbulenceFSAssetParams , ClothingActorParam
  • lodWeights.distanceWeight : ClothingActorParam , TurbulenceFSAssetParams
  • lodWeights.maxDistance : TurbulenceFSAssetParams , ClothingActorParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- m -

  • Mass : RigidBodyEffect
  • MassScale : ClothingDebugRenderParams
  • massScale : DestructibleModuleParameters
  • materialFactoryMapList[].iofxAssetName : GroundEmitterAssetParameters
  • materialFactoryMapList[].iosAssetName : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.bias : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.distanceWeight : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.lifeWeight : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.maxDistance : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.separationWeight : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.speedWeight : GroundEmitterAssetParameters
  • materialFactoryMapList[].lodParamDesc.version : GroundEmitterAssetParameters
  • materialFactoryMapList[].maxSlopeAngle : GroundEmitterAssetParameters
  • materialFactoryMapList[].physMatName : GroundEmitterAssetParameters
  • materialFactoryMapList[].weight : GroundEmitterAssetParameters
  • materialIndex : ClothingAssetParameters
  • materialLibrary : ClothingAssetParameters
  • materialNames[] : RenderMeshAssetParameters
  • materials[].bendingStiffness : ClothingMaterialLibraryParameters
  • materials[].bendingStiffnessScaling.compressionRange : ClothingMaterialLibraryParameters
  • materials[].bendingStiffnessScaling.scale : ClothingMaterialLibraryParameters
  • materials[].bendingStiffnessScaling.stretchRange : ClothingMaterialLibraryParameters
  • materials[].comDamping : ClothingMaterialLibraryParameters
  • materials[].damping : ClothingMaterialLibraryParameters
  • materials[].drag : ClothingMaterialLibraryParameters
  • materials[].friction : ClothingMaterialLibraryParameters
  • materials[].gravityScale : ClothingMaterialLibraryParameters
  • materials[].hardStretchLimitation : ClothingMaterialLibraryParameters
  • materials[].hierarchicalSolverIterations : ClothingMaterialLibraryParameters
  • materials[].horizontalStiffnessScaling.compressionRange : ClothingMaterialLibraryParameters
  • materials[].horizontalStiffnessScaling.scale : ClothingMaterialLibraryParameters
  • materials[].horizontalStiffnessScaling.stretchRange : ClothingMaterialLibraryParameters
  • materials[].horizontalStretchingStiffness : ClothingMaterialLibraryParameters
  • materials[].inertiaScale : ClothingMaterialLibraryParameters
  • materials[].massScale : ClothingMaterialLibraryParameters
  • materials[].materialName : ClothingMaterialLibraryParameters
  • materials[].maxDistanceBias : ClothingMaterialLibraryParameters
  • materials[].orthoBending : ClothingMaterialLibraryParameters
  • materials[].selfcollisionSquashScale : ClothingMaterialLibraryParameters
  • materials[].selfcollisionStiffness : ClothingMaterialLibraryParameters
  • materials[].selfcollisionThickness : ClothingMaterialLibraryParameters
  • materials[].shearingStiffness : ClothingMaterialLibraryParameters
  • materials[].shearingStiffnessScaling.compressionRange : ClothingMaterialLibraryParameters
  • materials[].shearingStiffnessScaling.scale : ClothingMaterialLibraryParameters
  • materials[].shearingStiffnessScaling.stretchRange : ClothingMaterialLibraryParameters
  • materials[].solverFrequency : ClothingMaterialLibraryParameters
  • materials[].solverIterations : ClothingMaterialLibraryParameters
  • materials[].stiffnessFrequency : ClothingMaterialLibraryParameters
  • materials[].tetherLimit : ClothingMaterialLibraryParameters
  • materials[].tetherStiffness : ClothingMaterialLibraryParameters
  • materials[].verticalStiffnessScaling.compressionRange : ClothingMaterialLibraryParameters
  • materials[].verticalStiffnessScaling.scale : ClothingMaterialLibraryParameters
  • materials[].verticalStiffnessScaling.stretchRange : ClothingMaterialLibraryParameters
  • materials[].verticalStretchingStiffness : ClothingMaterialLibraryParameters
  • maxActorCreatesPerFrame : DestructibleModuleParameters
  • maxChunkDepthOffset : DestructibleModuleParameters
  • maxChunkSeparationLOD : DestructibleModuleParameters
  • maxCollidingObjects : TurbulenceFSAssetParams , BasicIOSAssetParam
  • MaxDistance : ClothingDebugRenderParams
  • maxDistanceBlendTime : ClothingActorParam
  • MaxDistanceInwards : ClothingDebugRenderParams
  • maxDistanceScale.Multipliable : ClothingActorParam
  • maxDistanceScale.Scale : ClothingActorParam
  • maxDynamicChunkIslandCount : DestructibleModuleParameters
  • maxHeatSources : TurbulenceFSAssetParams
  • maxInjectedParticleCount : BasicIOSAssetParam , ParticleIosAssetParam
  • maxMotionDistance : ParticleIosAssetParam
  • maxNumCompartments : ClothingModuleParameters
  • maxParticleCount : FieldSamplerPhysXMonitorParams , ParticleIosAssetParam , BasicIOSAssetParam
  • maxPSCount : FieldSamplerPhysXMonitorParams
  • maxRaycastsPerFrame : GroundEmitterAssetParameters , GroundEmitterActorParameters
  • maxRBCount : FieldSamplerPhysXMonitorParams
  • maxRotation : RandomRotationModifierParams
  • maxRotationRatePerSec : RotationModifierParams
  • maxSamples : ApexEmitterAssetParameters
  • maxScaleFactor : RandomScaleModifierParams
  • maxSettleRatePerSec : RotationModifierParams
  • maxSubstanceSources : TurbulenceFSAssetParams
  • maxSubtexture : RandomSubtextureModifierParams
  • maxTimeRenderProxyInPool : ClothingModuleParameters
  • maxUnusedPhysXResources : ClothingModuleParameters
  • maxVelocitySources : TurbulenceFSAssetParams
  • meshCookedCollisionStreams[] : MeshCookedCollisionStreamsAtScale
  • meshCookedCollisionStreamsAtScale[] : DestructibleAssetCollisionDataSet
  • MeshDynamic : DebugColorParams
  • MeshStatic : DebugColorParams
  • minRotation : RandomRotationModifierParams
  • minSamplingFPS : ApexEmitterAssetParameters
  • minScaleFactor : RandomScaleModifierParams
  • minSubtexture : RandomSubtextureModifierParams
  • modelForward : OrientAlongVelocityModifierParams
  • moduleName[] : DebugRenderParams::ModuleName , DebugRenderParams , DebugRenderParams::ModuleName
  • morphDisplacements[] : ClothingActorParam
  • morphGraphicalMeshNewPositions[] : ClothingActorParam
  • morphPhysicalMeshNewPositions[] : ClothingActorParam
  • multiplier : ForceFieldFalloffParams
  • multiplyGlobalPoseIntoBones : ClothingActorParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- n -

  • Name : AttractorFieldSamplerData , EffectPackageData , ForceFieldData , JetFieldSamplerData , WindFieldSamplerData , NoiseFieldSamplerData , GraphicsEffectData , ParticleSimulationData , SubstanceSourceData , EmitterData , GraphicsMaterialData , TurbulenceFieldSamplerData , VelocitySourceData , HeatSourceData , VolumeRenderMaterialData , VortexFieldSamplerData
  • nearRadius : JetFSAssetParams
  • neighborPadding : DestructibleAssetParameters
  • nextCookedData : ClothingCookedPhysX3Param
  • noise : GenericForceFieldKernelParams
  • NoiseFieldSampler : NoiseFieldSamplerData , NoiseFieldSamplerEffect
  • noiseOctaves : JetFSAssetParams , NoiseFSAssetParams
  • noiseParameters : RadialForceFieldKernelParams
  • noiseParams.noiseOctaves : TurbulenceFSAssetParams
  • noiseParams.noiseSpacePeriod : TurbulenceFSAssetParams
  • noiseParams.noiseStrength : TurbulenceFSAssetParams
  • noiseParams.noiseTimePeriod : TurbulenceFSAssetParams
  • noisePercentage : JetFSAssetParams
  • noiseSeed : NoiseFSAssetParams
  • noiseSpacePeriod : NoiseFSAssetParams
  • noiseSpacePeriodOctaveMultiplier : NoiseFSAssetParams
  • noiseSpaceScale : JetFSAssetParams
  • noiseStrength : NoiseFSAssetParams
  • noiseStrengthOctaveMultiplier : NoiseFSAssetParams
  • noiseTimePeriod : NoiseFSAssetParams
  • noiseTimePeriodOctaveMultiplier : NoiseFSAssetParams
  • noiseTimeScale : JetFSAssetParams
  • noiseType : NoiseFSAssetParams
  • numVertices : ClothingCookedPhysX3Param
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- o -

  • objectScale : EffectPackageActorParams
  • octaves : ForceFieldNoiseParams
  • OpacityThreshold : VolumeRenderMaterialData
  • Orange : DebugColorParams
  • originalDepthCount : DestructibleAssetParameters
  • outletPressureBC : TurbulenceFSActorParams
  • overlaps[].i0 : CachedOverlaps
  • overlaps[].i1 : CachedOverlaps
  • overlapsAtDepth[] : DestructibleAssetParameters
  • overlapTestGroupMaskName : ApexEmitterActorParameters
  • overlapTestGroupsMask128Name : ApexEmitterActorParameters
  • overrideMaterialNames[] : ClothingActorParam
  • overrideSkinnedMaterialNames[] : DestructibleActorParam , DestructiblePreviewParam
  • overrideStaticMaterialNames[] : DestructibleActorParam , DestructiblePreviewParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- z -

  • ZerostretchFibers : ClothingDebugRenderParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- b -

  • Backstop : ClothingDebugRenderParams
  • BackstopPrecise : ClothingDebugRenderParams
  • behaviorGroups[].damageColorChange : DestructibleAssetParameters , DestructibleActorParam
  • behaviorGroups[].damageColorSpread.falloffExponent : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].damageColorSpread.minimumRadius : DestructibleAssetParameters , DestructibleActorParam
  • behaviorGroups[].damageColorSpread.radiusMultiplier : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].damageSpread.falloffExponent : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].damageSpread.minimumRadius : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].damageSpread.radiusMultiplier : DestructibleAssetParameters , DestructibleActorParam
  • behaviorGroups[].damageThreshold : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].damageToRadius : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].density : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].fadeOut : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].groupsMask.bits0 : DestructibleActorParam
  • behaviorGroups[].groupsMask.bits1 : DestructibleActorParam
  • behaviorGroups[].groupsMask.bits2 : DestructibleActorParam
  • behaviorGroups[].groupsMask.bits3 : DestructibleActorParam
  • behaviorGroups[].groupsMask.useGroupsMask : DestructibleActorParam
  • behaviorGroups[].materialStrength : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].maxDepenetrationVelocity : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].name : DestructibleActorParam , DestructibleAssetParameters
  • behaviorGroups[].userData : DestructibleActorParam , DestructibleAssetParameters
  • BendingFibers : ClothingDebugRenderParams
  • Black : DebugColorParams
  • BlockEmptyThreshold : VolumeRenderMaterialData
  • Blue : DebugColorParams
  • BlurShadows : VolumeRenderMaterialData
  • bodyDescTemplate.angularDamping : DestructibleActorParam
  • bodyDescTemplate.CCDMotionThreshold : DestructibleActorParam
  • bodyDescTemplate.contactReportThreshold : DestructibleActorParam
  • bodyDescTemplate.flags.NX_BF_DISABLE_GRAVITY : DestructibleActorParam
  • bodyDescTemplate.flags.NX_BF_ENERGY_SLEEP_TEST : DestructibleActorParam
  • bodyDescTemplate.flags.NX_BF_FILTER_SLEEP_VEL : DestructibleActorParam
  • bodyDescTemplate.flags.NX_BF_VISUALIZATION : DestructibleActorParam
  • bodyDescTemplate.linearDamping : DestructibleActorParam
  • bodyDescTemplate.maxAngularVelocity : DestructibleActorParam
  • bodyDescTemplate.sleepAngularVelocity : DestructibleActorParam
  • bodyDescTemplate.sleepDamping : DestructibleActorParam
  • bodyDescTemplate.sleepEnergyThreshold : DestructibleActorParam
  • bodyDescTemplate.sleepLinearVelocity : DestructibleActorParam
  • bodyDescTemplate.solverIterationCount : DestructibleActorParam
  • bodyDescTemplate.wakeUpCounter : DestructibleActorParam
  • boneActors[].boneIndex : ClothingAssetParameters
  • boneActors[].capsuleHeight : ClothingAssetParameters
  • boneActors[].capsuleRadius : ClothingAssetParameters
  • boneActors[].convexVerticesCount : ClothingAssetParameters
  • boneActors[].convexVerticesStart : ClothingAssetParameters
  • boneActors[].localPose : ClothingAssetParameters
  • boneCount : RenderMeshAssetParameters
  • BoneFrames : ClothingDebugRenderParams
  • boneMatrices[] : ClothingActorParam , ClothingPreviewParam
  • BoneNames : ClothingDebugRenderParams
  • bonePlanes[].boneIndex : ClothingAssetParameters
  • bonePlanes[].d : ClothingAssetParameters
  • bonePlanes[].n : ClothingAssetParameters
  • bones[].bindPose : ClothingAssetParameters
  • bones[].externalIndex : ClothingAssetParameters
  • bones[].internalIndex : ClothingAssetParameters
  • bones[].name : ClothingAssetParameters
  • bones[].numMeshReferenced : ClothingAssetParameters
  • bones[].numRigidBodiesReferenced : ClothingAssetParameters
  • bones[].parentIndex : ClothingAssetParameters
  • boneSphereConnections[] : ClothingAssetParameters
  • boneSpheres[].boneIndex : ClothingAssetParameters
  • boneSpheres[].localPos : ClothingAssetParameters
  • boneSpheres[].radius : ClothingAssetParameters
  • bonesReferenced : ClothingAssetParameters
  • bonesReferencedByMesh : ClothingAssetParameters
  • boneVertices[] : ClothingAssetParameters
  • bottomRadius : VortexFSAssetParams
  • bottomSphericalForce : VortexFSAssetParams
  • boundaryFadePercentage : AttractorFSAssetParams , JetFSAssetParams , NoiseFSAssetParams , VortexFSAssetParams , TurbulenceFSAssetParams
  • boundarySize : NoiseFSAssetParams
  • boundarySizePercentage : TurbulenceFSAssetParams
  • boundingBox : ClothingAssetParameters
  • bounds : ConvexHullParameters , DestructibleAssetParameters
  • Bounds : DebugRenderParams
  • buffer : SurfaceBufferParameters::Buffer , SurfaceBufferParameters , SurfaceBufferParameters::Buffer
  • bufferFormats[].access : VertexFormatParameters
  • bufferFormats[].format : VertexFormatParameters
  • bufferFormats[].id : VertexFormatParameters
  • bufferFormats[].name : VertexFormatParameters
  • bufferFormats[].semantic : VertexFormatParameters
  • bufferFormats[].serialize : VertexFormatParameters
  • buffers[] : VertexBufferParameters::Buffers , VertexBufferParameters , VertexBufferParameters::Buffers
  • bytes[] : MeshCookedCollisionStream
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- c -

  • CellColumn : GraphicsMaterialData
  • CellCount : GraphicsMaterialData
  • CellRow : GraphicsMaterialData
  • chunkConvexHulls[] : DestructibleAssetParameters
  • chunkConvexHullStartIndices[] : DestructibleAssetParameters
  • chunkDepth : DestructiblePreviewParam
  • chunkInstanceInfo[].chunkPositionOffset : DestructibleAssetParameters
  • chunkInstanceInfo[].chunkUVOffset : DestructibleAssetParameters
  • chunkInstanceInfo[].partIndex : DestructibleAssetParameters
  • chunks[].behaviorGroupIndex : DestructibleAssetParameters
  • chunks[].depth : DestructibleAssetParameters
  • chunks[].firstChildIndex : DestructibleAssetParameters
  • chunks[].firstScatterMesh : DestructibleAssetParameters
  • chunks[].flags : DestructibleAssetParameters
  • chunks[].meshPartIndex : DestructibleAssetParameters
  • chunks[].numChildren : DestructibleAssetParameters
  • chunks[].parentIndex : DestructibleAssetParameters
  • chunks[].scatterMeshCount : DestructibleAssetParameters
  • chunks[].surfaceNormal : DestructibleAssetParameters
  • clothDescTemplate.collisionGroup : ClothingActorParam
  • clothDescTemplate.collisionResponseCoefficient : ClothingActorParam
  • clothDescTemplate.compartment : ClothingActorParam
  • clothDescTemplate.groupsMask.bits0 : ClothingActorParam
  • clothDescTemplate.groupsMask.bits1 : ClothingActorParam
  • clothDescTemplate.groupsMask.bits2 : ClothingActorParam
  • clothDescTemplate.groupsMask.bits3 : ClothingActorParam
  • clothDescTemplate.userData : ClothingActorParam
  • clothDescTemplate.validBounds : ClothingActorParam
  • clothingMaterialIndex : ClothingActorParam
  • collisionConvexes[] : ClothingAssetParameters
  • collisionData : DestructibleAssetParameters
  • collisionDistanceMultiplier : BasicIOSAssetParam
  • CollisionFilterDataName : RigidBodyEffect
  • collisionFilterDataName : BasicIOSAssetParam , TurbulenceFSActorParams , TurbulenceFSAssetParams
  • collisionRotationMultiplier : RotationModifierParams
  • CollisionShapes : ClothingDebugRenderParams
  • CollisionShapesWire : ClothingDebugRenderParams
  • collisionThreshold : BasicIOSAssetParam
  • CollisionTwoway : ParticleIosAssetParam
  • collisionWithConvex : BasicIOSAssetParam
  • CollisionWithDynamicActors : ParticleIosAssetParam
  • collisionWithTriangleMesh : BasicIOSAssetParam
  • color : InitialColorModifierParams
  • Color0 : DebugColorParams
  • Color1 : DebugColorParams
  • Color2 : DebugColorParams
  • Color3 : DebugColorParams
  • Color4 : DebugColorParams
  • Color5 : DebugColorParams
  • colorChannel : ColorVsDensityModifierParams , ColorVsLifeModifierParams , ColorVsTemperatureModifierParams , ColorVsVelocityModifierParams
  • ColorMap[].color : VolumeRenderMaterialData
  • ColorMap[].density : VolumeRenderMaterialData
  • ColorMapOffset : VolumeRenderMaterialData
  • ColorMapScale : VolumeRenderMaterialData
  • ColorMultiplier : GraphicsMaterialData
  • comments : DestructibleAssetParameters
  • constant : GenericForceFieldKernelParams
  • constFieldStrength : AttractorFSAssetParams
  • contactOffset : ParticleIosAssetParam
  • continuousModifierList[]
: MeshIofxParameters::ContinuousModifierList
, SpriteIofxParameters::ContinuousModifierList
, MeshIofxParameters::ContinuousModifierList
, SpriteIofxParameters::ContinuousModifierList
, MeshIofxParameters
, SpriteIofxParameters::ContinuousModifierList
, SpriteIofxParameters
  • controlPoints[].cameraDistance : ScaleVsCameraDistance3DModifierParams , ScaleVsCameraDistance2DModifierParams
  • controlPoints[].color : ColorVsVelocityCompositeModifierParams , ColorVsDensityCompositeModifierParams , ColorVsLifeCompositeModifierParams , ColorVsTemperatureCompositeModifierParams
  • controlPoints[].density : ColorVsDensityCompositeModifierParams , ScaleVsDensity2DModifierParams , ScaleVsDensity3DModifierParams
  • controlPoints[].lifeRemaining : ScaleVsLife2DModifierParams , ScaleVsLife3DModifierParams , ColorVsLifeCompositeModifierParams
  • controlPoints[].scale : ScaleVsDensity3DModifierParams , ScaleVsLife2DModifierParams , ScaleVsLife3DModifierParams , ScaleVsTemperature3DModifierParams , ScaleVsCameraDistance3DModifierParams , ScaleVsCameraDistance2DModifierParams , ScaleVsDensity2DModifierParams , ScaleVsTemperature2DModifierParams
  • controlPoints[].temperature : ScaleVsTemperature2DModifierParams , ColorVsTemperatureCompositeModifierParams , ScaleVsTemperature3DModifierParams
  • controlPoints[].velocity : ColorVsVelocityCompositeModifierParams
  • controlPoints[].x : ColorVsTemperatureModifierParams , ColorVsVelocityModifierParams , RotationRateVsLifeModifierParams , ScaleVsDensityModifierParams , SubtextureVsLifeModifierParams , ScaleVsCameraDistanceModifierParams , ColorVsDensityModifierParams , ScaleVsLifeModifierParams , ColorVsLifeModifierParams , ScaleVsTemperatureModifierParams
  • controlPoints[].y : RotationRateVsLifeModifierParams , ColorVsDensityModifierParams , ColorVsTemperatureModifierParams , ScaleVsLifeModifierParams , ColorVsVelocityModifierParams , ScaleVsTemperatureModifierParams , ColorVsLifeModifierParams , ScaleVsCameraDistanceModifierParams , SubtextureVsLifeModifierParams , ScaleVsDensityModifierParams
  • convexCookedData[] : ClothingCookedParam
  • cookedData : ClothingAssetParameters , ClothingAssetParameters::CookedData
  • cookedData[].scale : ClothingAssetParameters
  • cookedDataVersion : ClothingCookedPhysX3Param , ClothingCookedParam
  • cookedPhysicalSubmeshes[].cookedDataLength : ClothingCookedParam
  • cookedPhysicalSubmeshes[].cookedDataOffset : ClothingCookedParam
  • cookedPhysicalSubmeshes[].deformableInvParticleWeightsOffset : ClothingCookedParam
  • cookedPhysicalSubmeshes[].physicalMeshId : ClothingCookedParam
  • cookedPhysicalSubmeshes[].submeshId : ClothingCookedParam
  • cookedPhysicalSubmeshes[].virtualParticleIndicesLength : ClothingCookedParam
  • cookedPhysicalSubmeshes[].virtualParticleIndicesOffset : ClothingCookedParam
  • cookingPlatform : DestructibleAssetCollisionDataSet
  • cookingVersionNum : DestructibleAssetCollisionDataSet
  • coordinateSystemParameters.torusRadius : GenericForceFieldKernelParams
  • coordinateSystemParameters.type : GenericForceFieldKernelParams
  • createChunkEvents : DestructibleActorParam
  • CrossBlend : GraphicsMaterialData
  • CrossSectionFibers : ClothingDebugRenderParams
  • crumbleEmitterName : DestructibleActorParam , DestructibleAssetParameters
  • crumbleParticleSpacing : DestructibleActorParam
  • customLOD : TurbulenceFSAssetParams
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- d -

  • damping : ParticleIosAssetParam
  • DarkBlue : DebugColorParams
  • DarkGray : DebugColorParams
  • DarkGreen : DebugColorParams
  • DarkPurple : DebugColorParams
  • DarkRed : DebugColorParams
  • data[] : BufferF32x3 , BufferU16x1 , BufferU32x1 , BufferU8x1 , BufferF32x1
  • data[].angularVelocity : DestructibleActorChunks
  • data[].damage : DestructibleActorChunks
  • data[].flags : DestructibleActorChunks
  • data[].globalPose : DestructibleActorChunks
  • data[].islandID : DestructibleActorChunks
  • data[].linearVelocity : DestructibleActorChunks
  • data[].localOffset : DestructibleActorChunks
  • data[].localSphere : DestructibleActorChunks
  • data[].shapesCount : DestructibleActorChunks
  • data[].state : DestructibleActorChunks
  • data[].visibleAncestorIndex : DestructibleActorChunks
  • data[].w : BufferF32x4 , BufferU16x4 , BufferU32x4 , BufferU8x4
  • data[].x : BufferU32x2 , BufferU32x3 , BufferU32x4 , BufferU8x2 , BufferU8x3 , BufferU8x4 , BufferF32x2 , BufferF32x4 , BufferU16x2 , BufferU16x3 , BufferU16x4
  • data[].y : BufferF32x2 , BufferF32x4 , BufferU16x2 , BufferU16x3 , BufferU16x4 , BufferU32x2 , BufferU32x3 , BufferU32x4 , BufferU8x2 , BufferU8x3 , BufferU8x4
  • data[].z : BufferF32x4 , BufferU16x3 , BufferU16x4 , BufferU32x3 , BufferU32x4 , BufferU8x3 , BufferU8x4
  • Default : DebugColorParams
  • defaultBehaviorGroup.damageColorChange : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageColorSpread.falloffExponent : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageColorSpread.minimumRadius : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageColorSpread.radiusMultiplier : DestructibleAssetParameters , DestructibleActorParam
  • defaultBehaviorGroup.damageSpread.falloffExponent : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageSpread.minimumRadius : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageSpread.radiusMultiplier : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageThreshold : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.damageToRadius : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.density : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.fadeOut : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.groupsMask.bits0 : DestructibleActorParam
  • defaultBehaviorGroup.groupsMask.bits1 : DestructibleActorParam
  • defaultBehaviorGroup.groupsMask.bits2 : DestructibleActorParam
  • defaultBehaviorGroup.groupsMask.bits3 : DestructibleActorParam
  • defaultBehaviorGroup.groupsMask.useGroupsMask : DestructibleActorParam
  • defaultBehaviorGroup.materialStrength : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.maxDepenetrationVelocity : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.name : DestructibleActorParam , DestructibleAssetParameters
  • defaultBehaviorGroup.userData : DestructibleActorParam , DestructibleAssetParameters
  • defaultNormal : SurfaceTraceParameters
  • defaultScale : JetFSAssetParams , NoiseFSAssetParams
  • deformableCookedData[] : ClothingCookedParam
  • deformableIndices[] : ClothingCookedPhysX3Param
  • deformableInvParticleWeights[] : ClothingCookedParam
  • deformableInvVertexWeights[] : ClothingCookedPhysX3Param
  • deformablePhaseDescs[].phaseType : ClothingCookedPhysX3Param
  • deformablePhaseDescs[].restValueOffset : ClothingCookedPhysX3Param
  • deformablePhaseDescs[].setIndex : ClothingCookedPhysX3Param
  • deformableRestLengths[] : ClothingCookedPhysX3Param
  • deformableSets[].avgEdgeLength : ClothingCookedPhysX3Param
  • deformableSets[].avgFiberLength : ClothingCookedPhysX3Param
  • deformableSets[].fiberEnd : ClothingCookedPhysX3Param
  • deformableSets[].longestFiber : ClothingCookedPhysX3Param
  • deformableSets[].numEdges : ClothingCookedPhysX3Param
  • deformableSets[].shortestFiber : ClothingCookedPhysX3Param
  • defScale : ForceFieldAssetParams
  • delay : ImpactExplosionEvent , ImpactObjectEvent
  • deleteChunksEnteringUserDefinedBB : DestructibleActorParam
  • deleteChunksLeavingUserDefinedBB : DestructibleActorParam
  • deleteStaticBuffersAfterUse : RenderMeshAssetParameters
  • Density : VolumeRenderMaterialData
  • DensityBuffer : ParticleIosAssetParam
  • densityParams.densityFieldFade : TurbulenceFSAssetParams
  • densityParams.densityGridMultiplier : TurbulenceFSAssetParams
  • densityParams.diffusionCoef : TurbulenceFSAssetParams
  • densityRange.max : ApexEmitterAssetParameters , GroundEmitterActorParameters , GroundEmitterAssetParameters
  • densityRange.min : ApexEmitterAssetParameters , GroundEmitterActorParameters , GroundEmitterAssetParameters
  • depthCount : DestructibleAssetParameters
  • depthParameters[].IGNORE_CONTACT_CALLBACKS : DestructibleAssetParameters , DestructibleActorParam
  • depthParameters[].IGNORE_POSE_UPDATES : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].IGNORE_RAYCAST_CALLBACKS : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].OVERRIDE_IMPACT_DAMAGE : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].USER_FLAG_0 : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].USER_FLAG_1 : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].USER_FLAG_2 : DestructibleActorParam , DestructibleAssetParameters
  • depthParameters[].USER_FLAG_3 : DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.damageCap : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.damageDepthLimit : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.debrisDepth : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.debrisDestructionProbability : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.debrisLifetimeMax : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.debrisLifetimeMin : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.debrisMaxSeparationMax : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.debrisMaxSeparationMin : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.dynamicChunkDominanceGroup : DestructibleAssetParameters , DestructibleActorParam , DestructibleActorState
  • destructibleParameters.dynamicChunksGroupsMask.bits0 : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.dynamicChunksGroupsMask.bits1 : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.dynamicChunksGroupsMask.bits2 : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.dynamicChunksGroupsMask.bits3 : DestructibleAssetParameters , DestructibleActorParam , DestructibleActorState
  • destructibleParameters.dynamicChunksGroupsMask.useGroupsMask : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.essentialDepth : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.flags.ACCUMULATE_DAMAGE : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.flags.ACCURATE_RAYCASTS : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.flags.DEBRIS_MAX_SEPARATION : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.flags.DEBRIS_TIMEOUT : DestructibleAssetParameters , DestructibleActorParam , DestructibleActorState
  • destructibleParameters.flags.USE_VALID_BOUNDS : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.forceToDamage : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.fractureImpulseScale : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.impactDamageDefaultDepth : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.impactVelocityThreshold : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.legacyChunkBoundsTestSetting : DestructibleActorState , DestructibleAssetParameters , DestructibleActorParam
  • destructibleParameters.legacyDamageRadiusSpreadSetting : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.maxChunkSpeed : DestructibleActorState , DestructibleAssetParameters , DestructibleActorParam
  • destructibleParameters.minimumFractureDepth : DestructibleAssetParameters , DestructibleActorParam , DestructibleActorState
  • destructibleParameters.runtimeFracture.attachment.negX : DestructibleAssetParameters , DestructibleActorParam , DestructibleActorState
  • destructibleParameters.runtimeFracture.attachment.negY : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.attachment.negZ : DestructibleAssetParameters , DestructibleActorState , DestructibleActorParam
  • destructibleParameters.runtimeFracture.attachment.posX : DestructibleActorState , DestructibleAssetParameters , DestructibleActorParam
  • destructibleParameters.runtimeFracture.attachment.posY : DestructibleAssetParameters , DestructibleActorParam , DestructibleActorState
  • destructibleParameters.runtimeFracture.attachment.posZ : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.depthLimit : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.destroyIfAtDepthLimit : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.glass.firstSegmentSize : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.glass.numSectors : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.runtimeFracture.glass.sectorRand : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.glass.segmentRand : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.glass.segmentScale : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.impulseScale : DestructibleAssetParameters , DestructibleActorState , DestructibleActorParam
  • destructibleParameters.runtimeFracture.minConvexSize : DestructibleActorState , DestructibleActorParam , DestructibleAssetParameters
  • destructibleParameters.runtimeFracture.RuntimeFractureType : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.runtimeFracture.sheetFracture : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.runtimeFracture.voronoi.biasExp : DestructibleAssetParameters , DestructibleActorState , DestructibleActorParam
  • destructibleParameters.runtimeFracture.voronoi.dimensions : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.runtimeFracture.voronoi.maxDist : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.runtimeFracture.voronoi.numCells : DestructibleActorParam , DestructibleAssetParameters , DestructibleActorState
  • destructibleParameters.supportStrength : DestructibleAssetParameters , DestructibleActorState , DestructibleActorParam
  • destructibleParameters.validBounds : DestructibleActorParam , DestructibleActorState , DestructibleAssetParameters
  • DiffuseTexture : GraphicsMaterialData
  • directionalStretch : JetFSAssetParams
  • distance : EmitterGeomExplicitParams
  • doNotCreateRenderable : DestructibleActorParam
  • dragCoeff : TurbulenceFSAssetParams
  • dragCoeffForRigidBody : TurbulenceFSActorParams , TurbulenceFSAssetParams
  • drawAssetInfo : WindFSPreviewParams , AttractorFSPreviewParams , TurbulenceFSPreviewParams , VortexFSPreviewParams , NoiseFSPreviewParams , JetFSPreviewParams
  • drawBold : ForceFieldAssetPreviewParams
  • drawBoundaries : ForceFieldAssetPreviewParams
  • drawBox : TurbulenceFSPreviewParams
  • drawGrid : TurbulenceFSPreviewParams
  • drawIcon : TurbulenceFSPreviewParams , ForceFieldAssetPreviewParams
  • drawShape : AttractorFSPreviewParams , JetFSPreviewParams , NoiseFSPreviewParams , VortexFSPreviewParams
  • duration : ImpactExplosionEvent
  • dustEmitterName : DestructibleAssetParameters , DestructibleActorParam
  • dustParticleSpacing : DestructibleActorParam
  • dynamic : DestructibleActorParam
  • Dynamic : RigidBodyEffect
  • dynamicCollision : BasicIOSAssetParam
  • dynamicFriction : ParticleIosAssetParam
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- e -

  • EdgeFade : VolumeRenderMaterialData
  • edges[] : ConvexHullParameters
  • EffectPackage : EffectPackageData
  • EffectPackages[] : EffectPackageDatabaseParams
  • EffectProperties.Duration : HeatSourceEffect , WindFieldSamplerEffect , JetFieldSamplerEffect , AttractorFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , EmitterEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , ForceFieldEffect , VelocitySourceEffect , VortexFieldSamplerEffect
  • EffectProperties.Enable : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.InitialDelayTime : HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect , AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect
  • EffectProperties.Orientation.RotateX : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Orientation.RotateY : WindFieldSamplerEffect , AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect
  • EffectProperties.Orientation.RotateZ : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.ControlPoints[] : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.LoopIndex : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.PathDuration : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.PlaybackMode : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.Scale[].x : HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect , AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect
  • EffectProperties.Path.Scale[].y : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.Speed[].x : AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Path.Speed[].y : VortexFieldSamplerEffect , RigidBodyEffect , AttractorFieldSamplerEffect , EmitterEffect , ForceFieldEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , WindFieldSamplerEffect
  • EffectProperties.Position.TranslateX : VortexFieldSamplerEffect , ForceFieldEffect , AttractorFieldSamplerEffect , EmitterEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , WindFieldSamplerEffect
  • EffectProperties.Position.TranslateY : RigidBodyEffect , ForceFieldEffect , AttractorFieldSamplerEffect , EmitterEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , VortexFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.Position.TranslateZ : AttractorFieldSamplerEffect , EmitterEffect , HeatSourceEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , VelocitySourceEffect , WindFieldSamplerEffect , RigidBodyEffect , VortexFieldSamplerEffect , ForceFieldEffect
  • EffectProperties.RandomizeRepeatTime : VortexFieldSamplerEffect , WindFieldSamplerEffect , VelocitySourceEffect , ForceFieldEffect , AttractorFieldSamplerEffect , EmitterEffect , TurbulenceFieldSamplerEffect , HeatSourceEffect , NoiseFieldSamplerEffect , RigidBodyEffect , SubstanceSourceEffect , JetFieldSamplerEffect
  • EffectProperties.RepeatCount : TurbulenceFieldSamplerEffect , RigidBodyEffect , VortexFieldSamplerEffect , EmitterEffect , ForceFieldEffect , NoiseFieldSamplerEffect , VelocitySourceEffect , HeatSourceEffect , JetFieldSamplerEffect , SubstanceSourceEffect , WindFieldSamplerEffect , AttractorFieldSamplerEffect
  • EffectProperties.RepeatDelay : AttractorFieldSamplerEffect , VortexFieldSamplerEffect , JetFieldSamplerEffect , NoiseFieldSamplerEffect , ForceFieldEffect , RigidBodyEffect , HeatSourceEffect , VelocitySourceEffect , EmitterEffect , SubstanceSourceEffect , TurbulenceFieldSamplerEffect , WindFieldSamplerEffect
  • EffectProperties.UserString : WindFieldSamplerEffect , RigidBodyEffect , VortexFieldSamplerEffect , TurbulenceFieldSamplerEffect , JetFieldSamplerEffect , ForceFieldEffect , AttractorFieldSamplerEffect , VelocitySourceEffect , EmitterEffect , HeatSourceEffect , NoiseFieldSamplerEffect , SubstanceSourceEffect
  • Effects[] : EffectPackageAssetParams::Effects , EffectPackageAssetParams
  • ellipsoids.positions[].center : EmitterGeomExplicitParams
  • ellipsoids.positions[].doDetectOverlaps : EmitterGeomExplicitParams
  • ellipsoids.positions[].normal : EmitterGeomExplicitParams
  • ellipsoids.positions[].polarRadius : EmitterGeomExplicitParams
  • ellipsoids.positions[].radius : EmitterGeomExplicitParams
  • ellipsoids.velocities[] : EmitterGeomExplicitParams
  • Emerald : DebugColorParams
  • emitAssetParticles : ApexEmitterActorParameters
  • Emitter : EmitterData , EmitterEffect
  • emitterDuration : ApexEmitterActorParameters , ApexEmitterAssetParameters
  • Emitters[] : EffectPackageEmitterDatabaseParams
  • emitterType : EmitterGeomSphereShellParams , EmitterGeomCylinderParams , EmitterGeomSphereParams , EmitterGeomBoxParams
  • EmitterVelocityChanges.AdjustEmitterRate.AdjustEnabled : EmitterEffect
  • EmitterVelocityChanges.AdjustEmitterRate.HighValue : EmitterEffect
  • EmitterVelocityChanges.AdjustEmitterRate.LowValue : EmitterEffect
  • EmitterVelocityChanges.AdjustEmitterRate.VelocityHigh : EmitterEffect
  • EmitterVelocityChanges.AdjustEmitterRate.VelocityLow : EmitterEffect
  • EmitterVelocityChanges.AdjustLifetime.AdjustEnabled : EmitterEffect
  • EmitterVelocityChanges.AdjustLifetime.HighValue : EmitterEffect
  • EmitterVelocityChanges.AdjustLifetime.LowValue : EmitterEffect
  • EmitterVelocityChanges.AdjustLifetime.VelocityHigh : EmitterEffect
  • EmitterVelocityChanges.AdjustLifetime.VelocityLow : EmitterEffect
  • Enable : ParticleIosAssetParam , DebugRenderParams
  • enableCrumbleEmitter : DestructibleActorState
  • Enabled : EffectPackageActorParams
  • enableDustEmitter : DestructibleActorState
  • EnableStencilOpt : VolumeRenderMaterialData
  • enableTemperatureBuffer : ParticleIosAssetParam , BasicIOSAssetParam
  • end : ForceFieldFalloffParams
  • eventSetList[] : ImpactEmitterAssetParameters , ImpactEmitterAssetParameters::EventSetList
  • eventSetName : ImpactObjectEvent , ImpactExplosionEvent
  • explodeAmount : DestructiblePreviewParam
  • explosionAssetName : ImpactExplosionEvent
  • extents : EmitterGeomBoxParams , HeatSourceGeomBoxParams
  • Extents : RigidBodyEffect
  • externalAcceleration : ParticleIosAssetParam , BasicIOSAssetParam
  • externalVelocity : TurbulenceFSAssetParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- f -

  • fallbackSkinning : ClothingActorParam , ClothingPreviewParam
  • falloffLinear : GenericForceFieldKernelParams
  • falloffParameters : RadialForceFieldKernelParams
  • falloffQuadratic : GenericForceFieldKernelParams
  • farRadius : JetFSAssetParams
  • FiberRange : ClothingDebugRenderParams
  • fieldBoundaryFilterDataName : AttractorFSActorParams , TurbulenceFSActorParams , TurbulenceFSAssetParams , AttractorFSAssetParams , VortexFSActorParams , VortexFSAssetParams , ForceFieldActorParams , WindFSActorParams , WindFSAssetParams , ForceFieldAssetParams , JetFSActorParams , JetFSAssetParams , NoiseFSActorParams , NoiseFSAssetParams
  • fieldDirection : JetFSAssetParams , WindFSAssetParams
  • fieldDirectionDeviationAngle : JetFSAssetParams , WindFSAssetParams
  • fieldDirectionOscillationPeriod : JetFSAssetParams , WindFSAssetParams
  • fieldDragCoeff : WindFSAssetParams , AttractorFSAssetParams , JetFSAssetParams , NoiseFSAssetParams , VortexFSAssetParams
  • fieldSamplerFilterData : ParticleIosAssetParam
  • fieldSamplerFilterDataName : AttractorFSActorParams , AttractorFSAssetParams , BasicIOSAssetParam , ForceFieldActorParams , ForceFieldAssetParams , HeatSourceActorParams , HeatSourceAssetParams , JetFSActorParams , JetFSAssetParams , NoiseFSActorParams , NoiseFSAssetParams , SubstanceSourceActorParams , SubstanceSourceAssetParams , TurbulenceFSActorParams , TurbulenceFSAssetParams , VelocitySourceActorParams , VelocitySourceAssetParams , VortexFSActorParams , VortexFSAssetParams , WindFSActorParams , WindFSAssetParams
  • FieldSamplers[] : EffectPackageFieldSamplerDatabaseParams::FieldSamplers , EffectPackageFieldSamplerDatabaseParams , EffectPackageFieldSamplerDatabaseParams::FieldSamplers
  • fieldStrength : WindFSAssetParams , JetFSAssetParams
  • fieldStrengthDeviationPercentage : JetFSAssetParams , WindFSAssetParams
  • fieldStrengthOscillationPeriod : JetFSAssetParams , WindFSAssetParams
  • fieldType : NoiseFSAssetParams
  • fieldVelocityMultiplier : TurbulenceFSAssetParams
  • fieldVelocityWeight : TurbulenceFSAssetParams
  • fieldWeight : JetFSAssetParams , NoiseFSAssetParams , AttractorFSAssetParams , WindFSAssetParams , VortexFSAssetParams
  • FillMode : VolumeRenderMaterialData
  • firstChunkAtDepth[] : DestructibleAssetParameters
  • flags.ComputePhysicsMeshNormals : ClothingActorParam
  • flags.ComputeRenderData : ClothingActorParam
  • flags.CorrectSimulationNormals : ClothingActorParam
  • flags.ParallelCpuSkinning : ClothingActorParam
  • flags.RecomputeNormals : ClothingActorParam
  • flags.RecomputeTangents : ClothingActorParam
  • flags.Visualize : ClothingActorParam
  • fluidViscosity : TurbulenceFSAssetParams , TurbulenceFSActorParams
  • ForceArrowsHigh : DebugColorParams
  • ForceArrowsLow : DebugColorParams
  • ForceArrowsNorm : DebugColorParams
  • ForceField : ForceFieldEffect , ForceFieldData
  • forceFieldKernelType : ForceFieldAssetParams::ForceFieldKernelType , ForceFieldAssetParams , ForceFieldAssetParams::ForceFieldKernelType
  • forceLod : DestructibleActorState
  • formExtendedStructures : DestructibleActorParam , DestructibleAssetParameters
  • freezeByLOD : ClothingActorParam
  • FullResPercent : GraphicsMaterialData
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- g -

  • GenerateMipmaps : VolumeRenderMaterialData
  • GenerateShadows : VolumeRenderMaterialData
  • geometryType
: ApexEmitterAssetParameters::GeometryType
, ApexEmitterAssetParameters
, SubstanceSourceActorParams::GeometryType
, SubstanceSourceActorParams
, HeatSourceActorParams::GeometryType
, SubstanceSourceAssetParams::GeometryType
, ApexEmitterAssetParameters::GeometryType
, HeatSourceActorParams::GeometryType
, SubstanceSourceAssetParams
, VelocitySourceActorParams::GeometryType
, HeatSourceActorParams
, VelocitySourceActorParams::GeometryType
, VelocitySourceActorParams
, ApexEmitterAssetParameters::GeometryType
, HeatSourceAssetParams::GeometryType
, VelocitySourceAssetParams::GeometryType
, HeatSourceAssetParams::GeometryType
, VelocitySourceAssetParams
, ApexEmitterAssetParameters::GeometryType
, HeatSourceAssetParams
, SubstanceSourceActorParams::GeometryType
  • globalPose : DestructiblePreviewParam , GroundEmitterActorParameters , JetFSPreviewParams , NoiseFSPreviewParams , TurbulenceFSPreviewParams , VortexFSPreviewParams , WindFSPreviewParams
  • GlobalPose : ClothingDebugRenderParams
  • globalPose : AttractorFSPreviewParams , ClothingActorParam , ClothingPreviewParam , DestructibleActorParam
  • Gold : DebugColorParams
  • graphicalLods[] : ClothingAssetParameters
  • GraphicalVertexBones : ClothingDebugRenderParams
  • GraphicsEffects[] : EffectPackageIOFXDatabaseParams
  • GraphicsMaterials[] : EffectPackageGraphicsMaterialsParams::GraphicsMaterials , EffectPackageGraphicsMaterialsParams
  • Gravity : RigidBodyEffect
  • Gray : DebugColorParams
  • Green : DebugColorParams
  • gridBoundaryFadePercentage : JetFSAssetParams
  • GridDensity.Enabled : BasicIOSAssetParam , SimpleParticleSystemParams
  • GridDensity.GridSize : BasicIOSAssetParam , SimpleParticleSystemParams
  • GridDensity.MaxCellCount : SimpleParticleSystemParams , BasicIOSAssetParam
  • GridDensity.Resolution : SimpleParticleSystemParams , BasicIOSAssetParam
  • gridShapeHeight : JetFSAssetParams
  • gridShapeRadius : JetFSAssetParams
  • gridSize : ParticleIosAssetParam
  • gridSizeWorld : TurbulenceFSAssetParams , TurbulenceFSActorParams
  • gridXRange.max : TurbulenceFSAssetParams
  • gridXRange.min : TurbulenceFSAssetParams
  • gridYRange.max : TurbulenceFSAssetParams
  • gridYRange.min : TurbulenceFSAssetParams
  • gridZRange.max : TurbulenceFSAssetParams
  • gridZRange.min : TurbulenceFSAssetParams
  • groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR : EmitterDebugRenderParams
  • groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_NAME : EmitterDebugRenderParams
  • groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_POSE : EmitterDebugRenderParams
  • groundEmitterParameters.VISUALIZE_GROUND_EMITTER_GRID : EmitterDebugRenderParams
  • groundEmitterParameters.VISUALIZE_GROUND_EMITTER_RAYCAST : EmitterDebugRenderParams
  • groundEmitterParameters.VISUALIZE_GROUND_EMITTER_SPHERE : EmitterDebugRenderParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- h -

  • HalfResPercent : GraphicsMaterialData
  • hasSeparateBoneBuffer : VertexFormatParameters
  • heatParams.ambientTemperature : TurbulenceFSAssetParams
  • heatParams.heatForceDirection : TurbulenceFSAssetParams
  • heatParams.temperatureBasedForceMultiplier : TurbulenceFSAssetParams
  • heatParams.thermalConductivity : TurbulenceFSAssetParams
  • HeatSource : HeatSourceEffect , HeatSourceData
  • height : SurfaceBufferParameters , VortexFSAssetParams , EmitterGeomCylinderParams
  • hemisphere : EmitterGeomSphereShellParams , EmitterGeomSphereParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- i -

  • iconScale : ForceFieldAssetPreviewParams , TurbulenceFSPreviewParams
  • immediateClothMap[] : ClothingGraphicalLodParameters
  • impactAxis : ImpactObjectEvent
  • impactEmitterParameters.THRESHOLD_DISTANCE_IMPACT_EMITTER_ACTOR_NAME : EmitterDebugRenderParams
  • impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR : EmitterDebugRenderParams
  • impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR_NAME : EmitterDebugRenderParams
  • impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_RAYCAST : EmitterDebugRenderParams
  • inAirRotationMultiplier : RotationModifierParams
  • includeShapeParameters.dimensions : ForceFieldAssetParams
  • includeShapeParameters.forceFieldToShape : ForceFieldAssetParams
  • includeShapeParameters.shape : ForceFieldAssetParams
  • includeVerticalDirection : RotationModifierParams
  • indexBuffer[] : SubmeshParameters
  • indexPartition[] : SubmeshParameters
  • InitialAngularVelocity : RigidBodyEffect
  • initialDestructibleActorAllowanceForInstancing : DestructibleAssetParameters
  • InitialLinearVelocity : RigidBodyEffect
  • initialPose : ApexEmitterActorParameters , AttractorFSActorParams , ForceFieldActorParams , HeatSourceActorParams , JetFSActorParams , NoiseFSActorParams , SubstanceSourceActorParams , TurbulenceFSActorParams , VelocitySourceActorParams , VortexFSActorParams , WindFSActorParams
  • InitialPose : EffectPackageActorParams
  • initialScale : AttractorFSActorParams , HeatSourceActorParams , JetFSActorParams , NoiseFSActorParams , SubstanceSourceActorParams , TurbulenceFSActorParams , VelocitySourceActorParams , WindFSActorParams , VortexFSActorParams , ApexEmitterActorParameters
  • interCollisionChannels : ClothingAssetParameters
  • interCollisionDistance : ClothingModuleParameters
  • interCollisionIterations : ClothingModuleParameters
  • interCollisionStiffness : ClothingModuleParameters
  • internalLODWeights.ageWeight : DestructibleActorState
  • internalLODWeights.bias : DestructibleActorState
  • internalLODWeights.distanceWeight : DestructibleActorState
  • internalLODWeights.maxAge : DestructibleActorState
  • internalLODWeights.maxDistance : DestructibleActorState
  • IOFX : GraphicsEffectData
  • iofxAssetName : ApexEmitterAssetParameters , ImpactObjectEvent
  • iofxType : IofxAssetParameters::IofxType , IofxAssetParameters
  • IOS : ParticleSimulationData::IOS , ParticleSimulationData , ParticleSimulationData::IOS
  • iosAssetName : ApexEmitterAssetParameters , ImpactObjectEvent
  • isAutoSwitchingBC : TurbulenceFSActorParams
  • isCached : CachedOverlaps
  • isEnabledOptimizedLOD : TurbulenceFSAssetParams
  • IsoValue : VolumeRenderMaterialData
  • IsoValueSign : VolumeRenderMaterialData
  • isReferenced : RenderMeshAssetParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- p -

  • p3ActorDescTemplate.clientBehaviorBits : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eCCD_LINEAR : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eCONTACT_DEFAULT : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eMODIFY_CONTACTS : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FEATURE_INDICES_PER_POINT : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCE_PER_POINT : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCES : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_POINTS : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_FOUND : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_LOST : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_PERSISTS : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_FOUND : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_LOST : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_PERSISTS : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eRESOLVE_CONTACTS : DestructibleActorParam
  • p3ActorDescTemplate.contactReportFlags.eTRIGGER_DEFAULT : DestructibleActorParam
  • p3ActorDescTemplate.dominanceGroup : DestructibleActorParam
  • p3ActorDescTemplate.flags.eDISABLE_GRAVITY : DestructibleActorParam
  • p3ActorDescTemplate.flags.eSEND_SLEEP_NOTIFIES : DestructibleActorParam
  • p3ActorDescTemplate.flags.eVISUALIZATION : DestructibleActorParam
  • p3ActorDescTemplate.name : DestructibleActorParam
  • p3ActorDescTemplate.ownerClient : DestructibleActorParam
  • p3ActorDescTemplate.userData : DestructibleActorParam
  • p3BodyDescTemplate.angularDamping : DestructibleActorParam
  • p3BodyDescTemplate.contactReportThreshold : DestructibleActorParam
  • p3BodyDescTemplate.density : DestructibleActorParam
  • p3BodyDescTemplate.flags.eENABLE_CCD : DestructibleActorParam
  • p3BodyDescTemplate.flags.eKINEMATIC : DestructibleActorParam
  • p3BodyDescTemplate.linearDamping : DestructibleActorParam
  • p3BodyDescTemplate.maxAngularVelocity : DestructibleActorParam
  • p3BodyDescTemplate.sleepLinearVelocity : DestructibleActorParam
  • p3BodyDescTemplate.sleepThreshold : DestructibleActorParam
  • p3BodyDescTemplate.solverIterationCount : DestructibleActorParam
  • p3BodyDescTemplate.velocityIterationCount : DestructibleActorParam
  • p3BodyDescTemplate.wakeUpCounter : DestructibleActorParam
  • p3ShapeDescTemplate.contactOffset : DestructibleActorParam
  • p3ShapeDescTemplate.flags.eDEFORMABLE_DRAIN : DestructibleActorParam
  • p3ShapeDescTemplate.flags.ePARTICLE_DRAIN : DestructibleActorParam
  • p3ShapeDescTemplate.flags.eSCENE_QUERY_SHAPE : DestructibleActorParam
  • p3ShapeDescTemplate.flags.eSIMULATION_SHAPE : DestructibleActorParam
  • p3ShapeDescTemplate.flags.eTRIGGER_SHAPE : DestructibleActorParam
  • p3ShapeDescTemplate.flags.eVISUALIZATION : DestructibleActorParam
  • p3ShapeDescTemplate.material : DestructibleActorParam
  • p3ShapeDescTemplate.name : DestructibleActorParam
  • p3ShapeDescTemplate.queryFilterData.word0 : DestructibleActorParam
  • p3ShapeDescTemplate.queryFilterData.word1 : DestructibleActorParam
  • p3ShapeDescTemplate.queryFilterData.word2 : DestructibleActorParam
  • p3ShapeDescTemplate.queryFilterData.word3 : DestructibleActorParam
  • p3ShapeDescTemplate.restOffset : DestructibleActorParam
  • p3ShapeDescTemplate.simulationFilterData.word0 : DestructibleActorParam
  • p3ShapeDescTemplate.simulationFilterData.word1 : DestructibleActorParam
  • p3ShapeDescTemplate.simulationFilterData.word2 : DestructibleActorParam
  • p3ShapeDescTemplate.simulationFilterData.word3 : DestructibleActorParam
  • p3ShapeDescTemplate.userData : DestructibleActorParam
  • partBounds[] : RenderMeshAssetParameters
  • particleMass : ParticleIosAssetParam
  • particleMass.center : BasicIOSAssetParam
  • particleMass.spread : BasicIOSAssetParam
  • particleMass.type : BasicIOSAssetParam
  • particleRadius : BasicIOSAssetParam , ParticleIosAssetParam
  • ParticleSimulations[] : EffectPackageIOSDatabaseParams
  • particleSpawnCount : ImpactObjectEvent
  • particleType : ParticleIosAssetParam::ParticleType , ParticleIosAssetParam
  • Path.ControlPoints[] : EffectPackageAssetParams
  • Path.LoopIndex : EffectPackageAssetParams
  • Path.PathDuration : EffectPackageAssetParams
  • Path.PlaybackMode : EffectPackageAssetParams
  • Path.Scale[].x : EffectPackageAssetParams
  • Path.Scale[].y : EffectPackageAssetParams
  • Path.Speed[].x : EffectPackageAssetParams
  • Path.Speed[].y : EffectPackageAssetParams
  • performDetailedOverlapTestForExtendedStructures : DestructibleActorParam
  • PerParticleCollisionCacheHint : ParticleIosAssetParam
  • PerParticleRestOffset : ParticleIosAssetParam
  • physicalLods[].costWithoutIterations : ClothingPhysicalMeshParameters
  • physicalLods[].maxDistanceReduction : ClothingPhysicalMeshParameters
  • physicalLods[].solverIterationScale : ClothingPhysicalMeshParameters
  • physicalLods[].submeshId : ClothingPhysicalMeshParameters
  • physicalMesh.averageEdgeLength : ClothingPhysicalMeshParameters
  • physicalMesh.boneIndices[] : ClothingPhysicalMeshParameters
  • physicalMesh.boneWeights[] : ClothingPhysicalMeshParameters
  • physicalMesh.constrainCoefficients[].collisionSphereDistance : ClothingPhysicalMeshParameters
  • physicalMesh.constrainCoefficients[].collisionSphereRadius : ClothingPhysicalMeshParameters
  • physicalMesh.constrainCoefficients[].maxDistance : ClothingPhysicalMeshParameters
  • physicalMesh.flipNormals : ClothingPhysicalMeshParameters
  • physicalMesh.hasNegativeBackstop : ClothingPhysicalMeshParameters
  • physicalMesh.indices[] : ClothingPhysicalMeshParameters
  • physicalMesh.isClosed : ClothingPhysicalMeshParameters
  • physicalMesh.isTetrahedralMesh : ClothingPhysicalMeshParameters
  • physicalMesh.maximumMaxDistance : ClothingPhysicalMeshParameters
  • physicalMesh.normals[] : ClothingPhysicalMeshParameters
  • physicalMesh.numBonesPerVertex : ClothingPhysicalMeshParameters
  • physicalMesh.numIndices : ClothingPhysicalMeshParameters
  • physicalMesh.numVertices : ClothingPhysicalMeshParameters
  • physicalMesh.optimizationData[] : ClothingPhysicalMeshParameters
  • physicalMesh.physicalMeshSorting : ClothingPhysicalMeshParameters
  • physicalMesh.shortestEdgeLength : ClothingPhysicalMeshParameters
  • physicalMesh.skinningNormals[] : ClothingPhysicalMeshParameters
  • physicalMesh.vertices[] : ClothingPhysicalMeshParameters
  • physicalMeshes[] : ClothingAssetParameters
  • physicalMeshId : ClothingGraphicalLodParameters , ClothingCookedPhysX3Param
  • physicalSubMeshId : ClothingCookedPhysX3Param
  • PhysicalVertexBones : ClothingDebugRenderParams
  • PhysicsMeshIndices : ClothingDebugRenderParams
  • PhysicsMeshNormals : ClothingDebugRenderParams
  • PhysicsMeshSolid : ClothingDebugRenderParams
  • PhysicsMeshWire : ClothingDebugRenderParams
  • physicsSubmeshPartitioning[].graphicalSubmesh : ClothingGraphicalLodParameters
  • physicsSubmeshPartitioning[].numSimulatedIndices : ClothingGraphicalLodParameters
  • physicsSubmeshPartitioning[].numSimulatedVertices : ClothingGraphicalLodParameters
  • physicsSubmeshPartitioning[].numSimulatedVerticesAdditional : ClothingGraphicalLodParameters
  • physicsSubmeshPartitioning[].physicalSubmesh : ClothingGraphicalLodParameters
  • pivotRadius : JetFSAssetParams
  • planeCount : ConvexHullParameters
  • platforms[] : ClothingGraphicalLodParameters
  • points.positions[].doDetectOverlaps : EmitterGeomExplicitParams
  • points.positions[].position : EmitterGeomExplicitParams
  • points.velocities[] : EmitterGeomExplicitParams
  • pose : ForceFieldAssetPreviewParams , VelocitySourcePreviewParams , HeatSourcePreviewParams , EmitterAssetPreviewParameters
  • PoseArrows : DebugColorParams
  • position : SubstanceSourceAssetParams
  • positionMultiplier : GenericForceFieldKernelParams
  • positionOffset : SurfaceTraceSetParameters
  • positionTarget : GenericForceFieldKernelParams
  • pressure : ClothingActorParam
  • projectionPlaneDistance : ParticleIosAssetParam
  • projectionPlaneNormal : ParticleIosAssetParam
  • ProjectToPlane : ParticleIosAssetParam
  • PSM_Frustum.FrustumDepth : GraphicsMaterialData
  • PSM_Frustum.FrustumSize : GraphicsMaterialData
  • PSM_Frustum.ShowFrustum : GraphicsMaterialData
  • PSM_ShadowBias : GraphicsMaterialData
  • Purple : DebugColorParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- r -

  • radialStrength : VortexFSAssetParams
  • radius : AttractorFSAssetParams , EmitterGeomSphereParams , HeatSourceGeomSphereParams , RadialForceFieldKernelParams , EmitterGeomSphereShellParams , EmitterGeomCylinderParams , GroundEmitterActorParameters , GroundEmitterAssetParameters
  • rateRange.max : ApexEmitterAssetParameters
  • rateRange.min : ApexEmitterAssetParameters
  • rateVsTimeCurvePoints[].x : ApexEmitterAssetParameters
  • rateVsTimeCurvePoints[].y : ApexEmitterAssetParameters
  • raycastCollisionGroupMaskName : GroundEmitterActorParameters , GroundEmitterAssetParameters
  • raycastHeight : GroundEmitterActorParameters , GroundEmitterAssetParameters
  • RayJitter : VolumeRenderMaterialData
  • ReadDepth : VolumeRenderMaterialData
  • RecomputeSubmeshes : ClothingDebugRenderParams
  • RecomputeVertices : ClothingDebugRenderParams
  • Red : DebugColorParams
  • referenceCount : ClothingPhysicalMeshParameters
  • RelativeLodBenefitsScreenPos : DebugRenderParams
  • RelativeLodBenefitsThickness : DebugRenderParams
  • RenderBitangents : DebugRenderParams
  • renderMeshAsset : ClothingGraphicalLodParameters , DestructibleAssetParameters
  • renderMeshAssetSorting : ClothingGraphicalLodParameters
  • renderMeshList[].meshAssetName : MeshIofxParameters
  • renderMeshList[].weight : MeshIofxParameters
  • RenderMethod : VolumeRenderMaterialData
  • RenderMode : VolumeRenderMaterialData
  • RenderNormals : DebugRenderParams
  • renderOutput.useFloat4Color : IofxAssetParameters
  • renderOutput.useUserSemantic : IofxAssetParameters
  • renderStaticChunksSeparately : DestructibleActorParam
  • RenderTangents : DebugRenderParams
  • RenderTechnique : GraphicsMaterialData
  • renderUnexplodedChunksStatically : DestructiblePreviewParam
  • Resolution : GraphicsMaterialData
  • ResolutionScale : VolumeRenderMaterialData
  • restDensity : BasicIOSAssetParam
  • restitution : ParticleIosAssetParam
  • restitutionForDynamicShapes : BasicIOSAssetParam
  • restitutionForStaticShapes : BasicIOSAssetParam
  • restOffset : ParticleIosAssetParam
  • restParticleDistance : FluidParticleSystemParams
  • rollType : RotationModifierParams
  • rootBoneIndex : ClothingAssetParameters
  • rotationalStrength : VortexFSAssetParams
  • rotationRate : RotationRateModifierParams
  • RTFractureBehaviorGroup : DestructibleAssetParameters
  • runtimeCooked : ClothingActorParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- s -

  • scale : DestructibleActorParam , EmitterAssetPreviewParameters , HeatSourcePreviewParams , VelocitySourcePreviewParams , ForceFieldActorParams
  • Scale : DebugRenderParams
  • scaleAxis : ScaleVsDensityModifierParams , ScaleVsLifeModifierParams , ScaleVsTemperatureModifierParams , ScaleVsCameraDistanceModifierParams
  • scaleChangeDelay : OrientScaleAlongScreenVelocityModifierParams
  • scaleChangeLimit : OrientScaleAlongScreenVelocityModifierParams
  • scaledMassExponent : DestructibleModuleParameters
  • scaleFactor : ScaleAlongVelocityModifierParams , SimpleScaleModifierParams
  • scalePerVelocity : OrientScaleAlongScreenVelocityModifierParams
  • scales[] : DestructibleAssetCollisionDataSet
  • scatterMeshAssets[] : DestructibleAssetParameters
  • scatterMeshIndices[] : DestructibleAssetParameters
  • scatterMeshTransforms[].matrix : DestructibleAssetParameters
  • scatterMeshTransforms[].vector : DestructibleAssetParameters
  • sceneGravityScale : BasicIOSAssetParam
  • SelfCollision : ClothingDebugRenderParams
  • SelfCollisionAttenuation : ClothingDebugRenderParams
  • selfCollisionIndices[] : ClothingCookedPhysX3Param
  • selfCollisionNormalIndices[] : ClothingCookedPhysX3Param
  • selfCollisionNormalSetSizes[] : ClothingCookedPhysX3Param
  • SelfCollisionWire : ClothingDebugRenderParams
  • ShadowAmount : VolumeRenderMaterialData
  • ShadowDensity : VolumeRenderMaterialData
  • ShadowDistance : VolumeRenderMaterialData
  • ShadowJitter : VolumeRenderMaterialData
  • ShadowSamples : VolumeRenderMaterialData
  • Shape : DebugColorParams
  • shapeDescTemplate.collisionGroup : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.density : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_CLOTH_DISABLE_COLLISION : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_CLOTH_DRAIN : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_CLOTH_TWOWAY : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_DISABLE_RESPONSE : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_FEATURE_INDICES : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_FLUID_DISABLE_COLLISION : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_FLUID_DRAIN : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_FLUID_TWOWAY : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_POINT_CONTACT_FORCE : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_SOFTBODY_DISABLE_COLLISION : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_SOFTBODY_DRAIN : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_SOFTBODY_TWOWAY : DestructibleActorParam
  • shapeDescTemplate.flags.NX_SF_VISUALIZATION : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.flags.NX_TRIGGER_ON_ENTER : DestructibleActorParam
  • shapeDescTemplate.flags.NX_TRIGGER_ON_LEAVE : DestructibleActorParam
  • shapeDescTemplate.flags.NX_TRIGGER_ON_STAY : DestructibleActorParam
  • shapeDescTemplate.groupsMask.bits0 : DestructibleActorParam , ClothingActorParam
  • shapeDescTemplate.groupsMask.bits1 : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.groupsMask.bits2 : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.groupsMask.bits3 : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.groupsMask.useGroupsMask : DestructibleActorParam
  • shapeDescTemplate.materialIndex : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.name : ClothingActorParam , DestructibleActorParam
  • shapeDescTemplate.skinWidth : DestructibleActorParam
  • shapeDescTemplate.userData : ClothingActorParam , DestructibleActorParam
  • ShearingFibers : ClothingDebugRenderParams
  • shellThickness : EmitterGeomSphereShellParams
  • ShowInLocalSpace : ClothingDebugRenderParams
  • simulation.disableCCD : ClothingAssetParameters
  • simulation.gravityDirection : ClothingAssetParameters
  • simulation.hierarchicalLevels : ClothingAssetParameters
  • simulation.restLengthScale : ClothingAssetParameters
  • simulation.sleepLinearVelocity : ClothingAssetParameters
  • simulation.thickness : ClothingAssetParameters
  • simulation.twowayInteraction : ClothingAssetParameters
  • simulation.untangling : ClothingAssetParameters
  • simulation.virtualParticleDensity : ClothingAssetParameters
  • simulationBackend : ClothingActorParam
  • simulationFilterData : ParticleIosAssetParam
  • Skeleton : ClothingDebugRenderParams
  • skinClothMap[].normalBary : ClothingGraphicalLodParameters
  • skinClothMap[].tangentBary : ClothingGraphicalLodParameters
  • skinClothMap[].vertexBary : ClothingGraphicalLodParameters
  • skinClothMap[].vertexIndex0 : ClothingGraphicalLodParameters
  • skinClothMap[].vertexIndex1 : ClothingGraphicalLodParameters
  • skinClothMap[].vertexIndex2 : ClothingGraphicalLodParameters
  • skinClothMap[].vertexIndexPlusOffset : ClothingGraphicalLodParameters
  • skinClothMapB[].faceIndex0 : ClothingGraphicalLodParameters
  • skinClothMapB[].nrmTetraBary : ClothingGraphicalLodParameters
  • skinClothMapB[].submeshIndex : ClothingGraphicalLodParameters
  • skinClothMapB[].tetraIndex : ClothingGraphicalLodParameters
  • skinClothMapB[].vertexIndexPlusOffset : ClothingGraphicalLodParameters
  • skinClothMapB[].vtxTetraBary : ClothingGraphicalLodParameters
  • skinClothMapOffset : ClothingGraphicalLodParameters
  • skinClothMapThickness : ClothingGraphicalLodParameters
  • SkinMapActual : ClothingDebugRenderParams
  • SkinMapAll : ClothingDebugRenderParams
  • SkinMapBad : ClothingDebugRenderParams
  • SkinMapInvalidBary : ClothingDebugRenderParams
  • SkinnedPositions : ClothingDebugRenderParams
  • sleepVelocityFrameDecayConstant : DestructibleActorParam
  • slowStart : ClothingActorParam
  • smoothingGroups[] : SubmeshParameters
  • SolverMode : ClothingDebugRenderParams
  • sortFIFOByBenefit : DestructibleModuleParameters
  • sortType : ViewDirectionSortingModifierParams
  • spaceScale : ForceFieldNoiseParams
  • sparseSelfCollision : ClothingModuleParameters
  • spawnHeight : GroundEmitterAssetParameters , GroundEmitterActorParameters
  • spawnModifierList[]
: SpriteIofxParameters::SpawnModifierList
, MeshIofxParameters::SpawnModifierList
, MeshIofxParameters
, SpriteIofxParameters::SpawnModifierList
, MeshIofxParameters::SpawnModifierList
, SpriteIofxParameters::SpawnModifierList
, MeshIofxParameters::SpawnModifierList
, SpriteIofxParameters
, MeshIofxParameters::SpawnModifierList
, SpriteIofxParameters::SpawnModifierList
, MeshIofxParameters::SpawnModifierList
  • speedRange.max : ImpactObjectEvent
  • speedRange.min : ImpactObjectEvent
  • spheres.positions[].center : EmitterGeomExplicitParams
  • spheres.positions[].doDetectOverlaps : EmitterGeomExplicitParams
  • spheres.positions[].radius : EmitterGeomExplicitParams
  • spheres.velocities[] : EmitterGeomExplicitParams
  • spriteMaterialName : SpriteIofxParameters
  • start : ForceFieldFalloffParams
  • staticCollision : BasicIOSAssetParam
  • staticFriction : ParticleIosAssetParam
  • staticMaterialNames[] : DestructibleAssetParameters
  • stdDensity : SubstanceSourceAssetParams , SubstanceSourceActorParams
  • stdTemperature : HeatSourceAssetParams , HeatSourceActorParams
  • stdVelocity : VelocitySourceActorParams , VelocitySourceAssetParams
  • StepScale : VolumeRenderMaterialData
  • stiffness : FluidParticleSystemParams
  • strength : ForceFieldAssetParams , ForceFieldNoiseParams
  • structureSettings.stressSolverMassThreshold : DestructibleActorParam
  • structureSettings.stressSolverTimeDelay : DestructibleActorParam
  • structureSettings.useStressSolver : DestructibleActorParam
  • submeshes[] : RenderMeshAssetParameters
  • submeshes[].numIndices : ClothingPhysicalMeshParameters
  • submeshes[].numMaxDistance0Vertices : ClothingPhysicalMeshParameters
  • submeshes[].numVertices : ClothingPhysicalMeshParameters
  • submeshIndices[] : SurfaceTraceParameters
  • SubstanceSource : SubstanceSourceEffect , SubstanceSourceData
  • supportDepth : DestructibleActorParam , DestructibleAssetParameters
  • surfaceFormat : SurfaceBufferParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- t -

  • teleportMode : ClothingActorParam
  • temperatureRange.max : ApexEmitterAssetParameters
  • temperatureRange.min : ApexEmitterAssetParameters
  • tetherAnchors[] : ClothingCookedPhysX3Param
  • tetherLengths[] : ClothingCookedPhysX3Param
  • TethersActive : ClothingDebugRenderParams
  • TethersInactive : ClothingDebugRenderParams
  • tetraMap[]._dummyForAlignment : ClothingGraphicalLodParameters
  • tetraMap[].normalBary : ClothingGraphicalLodParameters
  • tetraMap[].tetraIndex0 : ClothingGraphicalLodParameters
  • tetraMap[].vertexBary : ClothingGraphicalLodParameters
  • Text0 : DebugColorParams
  • Text1 : DebugColorParams
  • TextureRangeMax : VolumeRenderMaterialData
  • TextureRangeMin : VolumeRenderMaterialData
  • textureUVOrigin : RenderMeshAssetParameters
  • THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_NAME : DestructibleDebugRenderParams
  • THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_POSE : DestructibleDebugRenderParams
  • THRESHOLD_DISTANCE_DESTRUCTIBLE_FRAGMENT_POSE : DestructibleDebugRenderParams
  • timeScale : ForceFieldNoiseParams
  • toolString : ClothingAssetParameters
  • topRadius : VortexFSAssetParams
  • topSphericalForce : VortexFSAssetParams
  • traces[] : SurfaceTraceSetParameters
  • transitionDown[].normalBary : ClothingPhysicalMeshParameters
  • transitionDown[].tangentBary : ClothingPhysicalMeshParameters
  • transitionDown[].vertexBary : ClothingPhysicalMeshParameters
  • transitionDown[].vertexIndex0 : ClothingPhysicalMeshParameters
  • transitionDown[].vertexIndex1 : ClothingPhysicalMeshParameters
  • transitionDown[].vertexIndex2 : ClothingPhysicalMeshParameters
  • transitionDown[].vertexIndexPlusOffset : ClothingPhysicalMeshParameters
  • transitionDownB[].faceIndex0 : ClothingPhysicalMeshParameters
  • transitionDownB[].nrmTetraBary : ClothingPhysicalMeshParameters
  • transitionDownB[].submeshIndex : ClothingPhysicalMeshParameters
  • transitionDownB[].tetraIndex : ClothingPhysicalMeshParameters
  • transitionDownB[].vertexIndexPlusOffset : ClothingPhysicalMeshParameters
  • transitionDownB[].vtxTetraBary : ClothingPhysicalMeshParameters
  • transitionDownOffset : ClothingPhysicalMeshParameters
  • transitionDownThickness : ClothingPhysicalMeshParameters
  • transitionUp[].normalBary : ClothingPhysicalMeshParameters
  • transitionUp[].tangentBary : ClothingPhysicalMeshParameters
  • transitionUp[].vertexBary : ClothingPhysicalMeshParameters
  • transitionUp[].vertexIndex0 : ClothingPhysicalMeshParameters
  • transitionUp[].vertexIndex1 : ClothingPhysicalMeshParameters
  • transitionUp[].vertexIndex2 : ClothingPhysicalMeshParameters
  • transitionUp[].vertexIndexPlusOffset : ClothingPhysicalMeshParameters
  • transitionUpB[].faceIndex0 : ClothingPhysicalMeshParameters
  • transitionUpB[].nrmTetraBary : ClothingPhysicalMeshParameters
  • transitionUpB[].submeshIndex : ClothingPhysicalMeshParameters
  • transitionUpB[].tetraIndex : ClothingPhysicalMeshParameters
  • transitionUpB[].vertexIndexPlusOffset : ClothingPhysicalMeshParameters
  • transitionUpB[].vtxTetraBary : ClothingPhysicalMeshParameters
  • transitionUpOffset : ClothingPhysicalMeshParameters
  • transitionUpThickness : ClothingPhysicalMeshParameters
  • TURBULENCE_FS_LOD : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_PLANE.normal : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_PLANE.offset : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_SCALAR_FIELD_SCALE : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_SCALAR_FIELD_SPACING : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_STREAMLINES.grid : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_STREAMLINES.tmax : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_STREAMLINES.tstep : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_VELOCITY_FIELD_SCALE : TurbulenceFSDebugRenderParams
  • TURBULENCE_FS_VELOCITY_FIELD_SPACING : TurbulenceFSDebugRenderParams
  • TurbulenceFieldSampler : TurbulenceFieldSamplerEffect , TurbulenceFieldSamplerData
  • Type : RigidBodyEffect
  • type : ForceFieldFalloffParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- u -

  • uniqueEdgeDirectionCount : ConvexHullParameters
  • uniquePlanes[].d : ConvexHullParameters
  • uniquePlanes[].normal : ConvexHullParameters
  • unused : BasicFSModuleParameters , ForceFieldModuleParams , IofxModuleParameters , BasicIosModuleParameters , ParticleIosModuleParameters , ParticlesModuleParameters , EmitterModuleParameters , TurbulenceFSModuleParameters , FieldSamplerModuleParameters
  • updatesPerFrameRange.max : TurbulenceFSAssetParams
  • updatesPerFrameRange.min : TurbulenceFSAssetParams
  • updateStateWithGlobalMatrices : ClothingPreviewParam , ClothingActorParam
  • upDirection : GroundEmitterActorParameters
  • useAssetDefinedSupport : DestructibleActorParam , DestructibleAssetParameters
  • useDensity : TurbulenceFSAssetParams
  • useHardSleeping : DestructibleActorParam
  • useHardwareCloth : ClothingActorParam
  • useHeat : TurbulenceFSAssetParams
  • useInternalBoneOrder : ClothingActorParam , ClothingPreviewParam
  • useLocalSpace : NoiseFSAssetParams
  • UsePSM : GraphicsMaterialData
  • userData : DestructiblePreviewParam , JetFSPreviewParams , ClothingPreviewParam , AttractorFSPreviewParams , NoiseFSPreviewParams , VortexFSPreviewParams , TurbulenceFSPreviewParams , WindFSPreviewParams , ClothingActorParam , DestructibleActorState
  • UserProperties : GraphicsMaterialData , VolumeRenderMaterialData
  • useVelocityClamping : ClothingActorParam
  • useWorldSupport : DestructibleAssetParameters , DestructibleActorParam
  • uvChannelForTangentUpdate : ClothingActorParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- v -

  • validBoundsPadding : DestructibleModuleParameters
  • variableFieldStrength : AttractorFSAssetParams
  • Velocities : ClothingDebugRenderParams
  • velocity0 : ColorVsVelocityCompositeModifierParams , ColorVsVelocityModifierParams
  • velocity1 : ColorVsVelocityCompositeModifierParams , ColorVsVelocityModifierParams
  • velocityFieldFadeDelay : TurbulenceFSAssetParams
  • velocityFieldFadeIntensity : TurbulenceFSAssetParams
  • velocityFieldFadeTime : TurbulenceFSAssetParams
  • velocityMultiplier : GenericForceFieldKernelParams
  • velocityRange.max : ApexEmitterAssetParameters , GroundEmitterAssetParameters
  • velocityRange.min : ApexEmitterAssetParameters , GroundEmitterAssetParameters
  • VelocitySource : VelocitySourceData , VelocitySourceEffect
  • velocityTarget : GenericForceFieldKernelParams
  • vertexBuffer : SubmeshParameters
  • vertexCount : VertexBufferParameters
  • vertexFormat : VertexBufferParameters
  • vertexIndices[] : SurfaceTraceParameters
  • vertexPartition[] : SubmeshParameters
  • vertexVelocityClamp : ClothingActorParam
  • vertices[] : ConvexHullParameters
  • VirtualCollision : ClothingDebugRenderParams
  • virtualParticleIndices[] : ClothingCookedParam , ClothingCookedPhysX3Param
  • virtualParticleWeights[] : ClothingCookedParam , ClothingCookedPhysX3Param
  • viscosity : FluidParticleSystemParams
  • VISUALIZE_ATTRACTOR_FS_ACTOR : BasicFSDebugRenderParams
  • VISUALIZE_ATTRACTOR_FS_ACTOR_NAME : BasicFSDebugRenderParams
  • VISUALIZE_ATTRACTOR_FS_FIELD : BasicFSDebugRenderParams
  • VISUALIZE_ATTRACTOR_FS_POSE : BasicFSDebugRenderParams
  • VISUALIZE_ATTRACTOR_FS_SHAPE : BasicFSDebugRenderParams
  • VISUALIZE_BASIC_IOS_ACTOR : BasicIosDebugRenderParams
  • VISUALIZE_BASIC_IOS_COLLIDE_SHAPES : BasicIosDebugRenderParams
  • VISUALIZE_BASIC_IOS_GRID_DENSITY : BasicIosDebugRenderParams
  • VISUALIZE_DESTRUCTIBLE_ACTOR : DestructibleDebugRenderParams
  • VISUALIZE_DESTRUCTIBLE_ACTOR_NAME : DestructibleDebugRenderParams
  • VISUALIZE_DESTRUCTIBLE_ACTOR_POSE : DestructibleDebugRenderParams
  • VISUALIZE_DESTRUCTIBLE_BOUNDS : DestructibleDebugRenderParams
  • VISUALIZE_DESTRUCTIBLE_FRAGMENT_POSE : DestructibleDebugRenderParams
  • VISUALIZE_DESTRUCTIBLE_SUPPORT : DestructibleDebugRenderParams
  • VISUALIZE_EFFECT_PACKAGE_ACTOR : ParticlesDebugRenderParams
  • VISUALIZE_FORCEFIELD_ACTOR : ForceFieldDebugRenderParams
  • VISUALIZE_HEAT_SOURCE_ACTOR : ParticlesDebugRenderParams , TurbulenceFSDebugRenderParams
  • VISUALIZE_IOFX_ACTOR : IofxDebugRenderParams
  • VISUALIZE_IOFX_ACTOR_NAME : IofxDebugRenderParams
  • VISUALIZE_IOFX_BOUNDING_BOX : IofxDebugRenderParams
  • VISUALIZE_JET_FS_ACTOR : BasicFSDebugRenderParams
  • VISUALIZE_JET_FS_ACTOR_NAME : BasicFSDebugRenderParams
  • VISUALIZE_JET_FS_FIELD : BasicFSDebugRenderParams
  • VISUALIZE_JET_FS_POSE : BasicFSDebugRenderParams
  • VISUALIZE_JET_FS_SHAPE : BasicFSDebugRenderParams
  • VISUALIZE_NOISE_FS_ACTOR : BasicFSDebugRenderParams
  • VISUALIZE_NOISE_FS_ACTOR_NAME : BasicFSDebugRenderParams
  • VISUALIZE_NOISE_FS_POSE : BasicFSDebugRenderParams
  • VISUALIZE_NOISE_FS_SHAPE : BasicFSDebugRenderParams
  • VISUALIZE_PARTICLE_IOS_ACTOR : ParticleIosDebugRenderParams
  • VISUALIZE_PARTICLE_IOS_GRID_DENSITY : ParticleIosDebugRenderParams
  • VISUALIZE_SUBSTANCE_SOURCE_ACTOR : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_ACTOR : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_ACTOR_NAME : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_BBOX : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_DENSITY_FIELD : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_GRID : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_LOD : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_PLANE : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_POSE : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_PRESSURE_FIELD : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_STREAMLINES : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_TEMPERATURE_FIELD : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_VELOCITY : TurbulenceFSDebugRenderParams
  • VISUALIZE_TURBULENCE_FS_VELOCITY_FIELD : TurbulenceFSDebugRenderParams
  • VISUALIZE_VELOCITY_SOURCE_ACTOR : TurbulenceFSDebugRenderParams
  • VISUALIZE_VORTEX_FS_ACTOR : BasicFSDebugRenderParams
  • VISUALIZE_VORTEX_FS_ACTOR_NAME : BasicFSDebugRenderParams
  • VISUALIZE_VORTEX_FS_FIELD : BasicFSDebugRenderParams
  • VISUALIZE_VORTEX_FS_POSE : BasicFSDebugRenderParams
  • VISUALIZE_VORTEX_FS_SHAPE : BasicFSDebugRenderParams
  • VISUALIZE_WIND_FS_ACTOR : BasicFSDebugRenderParams
  • VISUALIZE_WIND_FS_ACTOR_NAME : BasicFSDebugRenderParams
  • volume : ConvexHullParameters
  • volumeRenderMaterialName : TurbulenceFSAssetParams
  • VortexFieldSampler : VortexFieldSamplerData , VortexFieldSamplerEffect
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- w -

  • White : DebugColorParams
  • width : SurfaceBufferParameters
  • widths[] : ConvexHullParameters
  • Wind : ClothingDebugRenderParams
  • WindFieldSampler : WindFieldSamplerData , WindFieldSamplerEffect
  • winding : VertexFormatParameters
  • windParams.Adaption : ClothingActorParam
  • windParams.Velocity : ClothingActorParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- y -

  • Yellow : DebugColorParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: File Members

  • File List
  • File Members
  • All
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- a -

  • ADVECTION_LINEAR : params.h
  • ADVECTION_MACCORMACK : params.h
  • alpha : params.h

- b -

  • blue : params.h
  • box : params.h

- c -

  • capsule : params.h
  • ColorChannel : params.h
  • cone : params.h
  • CUBIC : params.h
  • CURL : params.h
  • cylinder : params.h

- d -

  • Default : params.h
  • default : params.h
  • DensityAdvection : params.h
  • densityBrush : params.h
  • densityOnce : params.h

- e -

  • EGR_12 : params.h
  • EGR_128 : params.h
  • EGR_16 : params.h
  • EGR_24 : params.h
  • EGR_32 : params.h
  • EGR_48 : params.h
  • EGR_64 : params.h
  • EGR_96 : params.h
  • EmitterType : params.h

- f -

  • FieldFormat : params.h
  • FieldType : params.h
  • fill : params.h
  • FillMode : params.h
  • FLAT_X : params.h
  • FLAT_Y : params.h
  • FLAT_Z : params.h
  • FLOAT : params.h
  • FLOAT4 : params.h
  • FORCE : params.h
  • ForceEmbedded : params.h
  • ForceNative : params.h

- g -

  • GDG_128 : params.h
  • GDG_16 : params.h
  • GDG_256 : params.h
  • GDG_32 : params.h
  • GDG_64 : params.h
  • GDG_8 : params.h
  • GLASS : params.h
  • green : params.h

- h -

  • HALF : params.h
  • HALF4 : params.h
  • HALF_SCALE : params.h

- i -

  • ImpactAxis : params.h
  • incident : params.h
  • ISOSURFACE : params.h

- l -

  • LONG_X : params.h
  • LONG_Y : params.h
  • LONG_Z : params.h
  • LOOP : params.h

- m -

  • Max : params.h
  • Min : params.h

- n -

  • NO_SCALE : params.h
  • NoiseType : params.h
  • none : params.h
  • normal : params.h

- p -

  • PING_PONG : params.h
  • PLAY_ONCE : params.h
  • PlaybackMode : params.h

- q -

  • QUARTER_SCALE : params.h

- r -

  • rate : params.h
  • RAYCASTING : params.h
  • red : params.h
  • reflection : params.h
  • RenderMethod : params.h
  • RenderMode : params.h
  • RenderTechnique : params.h
  • Resolution : params.h
  • ResolutionScale : params.h
  • RollType : params.h
  • RuntimeFractureType : params.h

- s -

  • ScaleAxis : params.h
  • Shape : params.h
  • SIMPLEX : params.h
  • SimulationBackend : params.h
  • SLICE_BASED : params.h
  • SOLID : params.h
  • SOLVER_JACOBI : params.h
  • SOLVER_MULTIGRID : params.h
  • SolverMode : params.h
  • SortType : params.h
  • sphere : params.h
  • SPHERICAL : params.h
  • SPRITE_ALPHA : params.h
  • SPRITE_ONE : params.h
  • SPRITE_SOLID : params.h
  • SPRITE_TEXTURE : params.h
  • SPRITE_WIREFRAME : params.h

- t -

  • Type : params.h

- u -

  • UCHAR : params.h
  • UCHAR4 : params.h
  • uniform : params.h

- v -

  • VELOCITY_DIRECT : params.h
  • VELOCITY_DRAG : params.h
  • VelocityAdvection : params.h
  • VOLUME : params.h
  • VOLUME_COLORMAP : params.h
  • VOLUME_SHADOWED : params.h
  • VORONOI : params.h
  • VOXELS : params.h

- w -

  • WIREFRAME : params.h

- x -

  • xAxis : params.h

- y -

  • yAxis : params.h

- z -

  • zAxis : params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: File Members

  • File List
  • File Members
  • All
  • Enumerations
  • Enumerator
  • ColorChannel : params.h
  • DensityAdvection : params.h
  • EmitterType : params.h
  • FieldFormat : params.h
  • FieldType : params.h
  • FillMode : params.h
  • ImpactAxis : params.h
  • Max : params.h
  • Min : params.h
  • NoiseType : params.h
  • PlaybackMode : params.h
  • RenderMethod : params.h
  • RenderMode : params.h
  • RenderTechnique : params.h
  • Resolution : params.h
  • ResolutionScale : params.h
  • RollType : params.h
  • RuntimeFractureType : params.h
  • ScaleAxis : params.h
  • Shape : params.h
  • SimulationBackend : params.h
  • SolverMode : params.h
  • SortType : params.h
  • Type : params.h
  • VelocityAdvection : params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: File Members

  • File List
  • File Members
  • All
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • q
  • r
  • s
  • u
  • v
  • w
  • x
  • y
  • z

- a -

  • ADVECTION_LINEAR : params.h
  • ADVECTION_MACCORMACK : params.h
  • alpha : params.h

- b -

  • blue : params.h
  • box : params.h

- c -

  • capsule : params.h
  • cone : params.h
  • CUBIC : params.h
  • CURL : params.h
  • cylinder : params.h

- d -

  • Default : params.h
  • default : params.h
  • densityBrush : params.h
  • densityOnce : params.h

- e -

  • EGR_12 : params.h
  • EGR_128 : params.h
  • EGR_16 : params.h
  • EGR_24 : params.h
  • EGR_32 : params.h
  • EGR_48 : params.h
  • EGR_64 : params.h
  • EGR_96 : params.h

- f -

  • fill : params.h
  • FLAT_X : params.h
  • FLAT_Y : params.h
  • FLAT_Z : params.h
  • FLOAT : params.h
  • FLOAT4 : params.h
  • FORCE : params.h
  • ForceEmbedded : params.h
  • ForceNative : params.h

- g -

  • GDG_128 : params.h
  • GDG_16 : params.h
  • GDG_256 : params.h
  • GDG_32 : params.h
  • GDG_64 : params.h
  • GDG_8 : params.h
  • GLASS : params.h
  • green : params.h

- h -

  • HALF : params.h
  • HALF4 : params.h
  • HALF_SCALE : params.h

- i -

  • incident : params.h
  • ISOSURFACE : params.h

- l -

  • LONG_X : params.h
  • LONG_Y : params.h
  • LONG_Z : params.h
  • LOOP : params.h

- n -

  • NO_SCALE : params.h
  • none : params.h
  • normal : params.h

- p -

  • PING_PONG : params.h
  • PLAY_ONCE : params.h

- q -

  • QUARTER_SCALE : params.h

- r -

  • rate : params.h
  • RAYCASTING : params.h
  • red : params.h
  • reflection : params.h

- s -

  • SIMPLEX : params.h
  • SLICE_BASED : params.h
  • SOLID : params.h
  • SOLVER_JACOBI : params.h
  • SOLVER_MULTIGRID : params.h
  • sphere : params.h
  • SPHERICAL : params.h
  • SPRITE_ALPHA : params.h
  • SPRITE_ONE : params.h
  • SPRITE_SOLID : params.h
  • SPRITE_TEXTURE : params.h
  • SPRITE_WIREFRAME : params.h

- u -

  • UCHAR : params.h
  • UCHAR4 : params.h
  • uniform : params.h

- v -

  • VELOCITY_DIRECT : params.h
  • VELOCITY_DRAG : params.h
  • VOLUME : params.h
  • VOLUME_COLORMAP : params.h
  • VOLUME_SHADOWED : params.h
  • VORONOI : params.h
  • VOXELS : params.h

- w -

  • WIREFRAME : params.h

- x -

  • xAxis : params.h

- y -

  • yAxis : params.h

- z -

  • zAxis : params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Main Page

APEX NvParameterized Schemas Documentation
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: physx Namespace Reference

  • Namespace List
physx Namespace Reference
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Namespace List

  • Namespace List
Namespace List
Here is a list of all namespaces with brief descriptions:
physx
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: params.h File Reference

  • File List
  • File Members
Classes | Namespaces | Enumerations
params.h File Reference

Go to the source code of this file.

Classes

struct | ApexEmitterActorParameters
Describes the NxParameterized::Interface for 'ApexEmitterActorParameters' : This class is used for creating NxApexEmitterActor instances. More...
struct | ApexEmitterAssetParameters
Describes the NxParameterized::Interface for 'ApexEmitterAssetParameters' : APEX Emitter Asset Parameters. More...
union | ApexEmitterAssetParameters::GeometryType
struct | AttractorFSActorParams
Describes the NxParameterized::Interface for 'AttractorFSActorParams' : More...
struct | AttractorFSAssetParams
Describes the NxParameterized::Interface for 'AttractorFSAssetParams' : Contains the asset properties for this Attractor Field Sampler. More...
struct | AttractorFSPreviewParams
Describes the NxParameterized::Interface for 'AttractorFSPreviewParams' : More...
struct | AttractorFieldSamplerData
Describes the NxParameterized::Interface for 'AttractorFieldSamplerData' : Containst he asset properties for this attractor field sampler. More...
struct | AttractorFieldSamplerEffect
Describes the NxParameterized::Interface for 'AttractorFieldSamplerEffect' : An attractor effect. More...
struct | BasicFSDebugRenderParams
Describes the NxParameterized::Interface for 'BasicFSDebugRenderParams' : More...
struct | BasicFSModuleParameters
Describes the NxParameterized::Interface for 'BasicFSModuleParameters' : This class is used for initializing the NxModuleFieldBoundary. More...
struct | BasicIOSAssetParam
Describes the NxParameterized::Interface for 'BasicIOSAssetParam' : More...
struct | BasicIosDebugRenderParams
Describes the NxParameterized::Interface for 'BasicIosDebugRenderParams' : More...
struct | BasicIosModuleParameters
Describes the NxParameterized::Interface for 'BasicIosModuleParameters' : This class is used for initializing the NxModuleBasicIos. More...
struct | BufferF32x1
Describes the NxParameterized::Interface for 'BufferF32x1' : More...
struct | BufferF32x2
Describes the NxParameterized::Interface for 'BufferF32x2' : More...
struct | BufferF32x3
Describes the NxParameterized::Interface for 'BufferF32x3' : More...
struct | BufferF32x4
Describes the NxParameterized::Interface for 'BufferF32x4' : More...
struct | BufferU16x1
Describes the NxParameterized::Interface for 'BufferU16x1' : More...
struct | BufferU16x2
Describes the NxParameterized::Interface for 'BufferU16x2' : More...
struct | BufferU16x3
Describes the NxParameterized::Interface for 'BufferU16x3' : More...
struct | BufferU16x4
Describes the NxParameterized::Interface for 'BufferU16x4' : More...
struct | BufferU32x1
Describes the NxParameterized::Interface for 'BufferU32x1' : More...
struct | BufferU32x2
Describes the NxParameterized::Interface for 'BufferU32x2' : More...
struct | BufferU32x3
Describes the NxParameterized::Interface for 'BufferU32x3' : More...
struct | BufferU32x4
Describes the NxParameterized::Interface for 'BufferU32x4' : More...
struct | BufferU8x1
Describes the NxParameterized::Interface for 'BufferU8x1' : More...
struct | BufferU8x2
Describes the NxParameterized::Interface for 'BufferU8x2' : More...
struct | BufferU8x3
Describes the NxParameterized::Interface for 'BufferU8x3' : More...
struct | BufferU8x4
Describes the NxParameterized::Interface for 'BufferU8x4' : More...
struct | CachedOverlaps
Describes the NxParameterized::Interface for 'CachedOverlaps' : More...
struct | ClothingActorParam
Describes the NxParameterized::Interface for 'ClothingActorParam' : More...
struct | ClothingAssetParameters
Describes the NxParameterized::Interface for 'ClothingAssetParameters' : More...
union | ClothingAssetParameters::CookedData
struct | ClothingCookedParam
Describes the NxParameterized::Interface for 'ClothingCookedParam' : More...
struct | ClothingCookedPhysX3Param
Describes the NxParameterized::Interface for 'ClothingCookedPhysX3Param' : More...
struct | ClothingDebugRenderParams
Describes the NxParameterized::Interface for 'ClothingDebugRenderParams' : More...
struct | ClothingGraphicalLodParameters
Describes the NxParameterized::Interface for 'ClothingGraphicalLodParameters' : More...
struct | ClothingMaterialLibraryParameters
Describes the NxParameterized::Interface for 'ClothingMaterialLibraryParameters' : More...
struct | ClothingModuleParameters
Describes the NxParameterized::Interface for 'ClothingModuleParameters' : This class is used for initializing the NxModuleClothing. More...
struct | ClothingPhysicalMeshParameters
Describes the NxParameterized::Interface for 'ClothingPhysicalMeshParameters' : More...
struct | ClothingPreviewParam
Describes the NxParameterized::Interface for 'ClothingPreviewParam' : More...
struct | ColorVsDensityCompositeModifierParams
Describes the NxParameterized::Interface for 'ColorVsDensityCompositeModifierParams' : ColorVsDensityComposite modifier parameters. More...
struct | ColorVsDensityModifierParams
Describes the NxParameterized::Interface for 'ColorVsDensityModifierParams' : ColorVsDensity modifier parameters. More...
struct | ColorVsLifeCompositeModifierParams
Describes the NxParameterized::Interface for 'ColorVsLifeCompositeModifierParams' : ColorVsLifeComposite modifier parameters. More...
struct | ColorVsLifeModifierParams
Describes the NxParameterized::Interface for 'ColorVsLifeModifierParams' : ColorVsLife modifier parameters. More...
struct | ColorVsTemperatureCompositeModifierParams
Describes the NxParameterized::Interface for 'ColorVsTemperatureCompositeModifierParams' : ColorVsTemperatureComposite modifier parameters. More...
struct | ColorVsTemperatureModifierParams
Describes the NxParameterized::Interface for 'ColorVsTemperatureModifierParams' : ColorVsTemperature modifier parameters. More...
struct | ColorVsVelocityCompositeModifierParams
Describes the NxParameterized::Interface for 'ColorVsVelocityCompositeModifierParams' : ColorVsVelocityComposite modifier parameters. More...
struct | ColorVsVelocityModifierParams
Describes the NxParameterized::Interface for 'ColorVsVelocityModifierParams' : ColorVsVelocity modifier parameters. More...
struct | ConvexHullParameters
Describes the NxParameterized::Interface for 'ConvexHullParameters' : More...
struct | DebugColorParams
Describes the NxParameterized::Interface for 'DebugColorParams' : More...
struct | DebugRenderParams
Describes the NxParameterized::Interface for 'DebugRenderParams' : More...
union | DebugRenderParams::ModuleName
struct | DestructibleActorChunks
Describes the NxParameterized::Interface for 'DestructibleActorChunks' : More...
struct | DestructibleActorParam
Describes the NxParameterized::Interface for 'DestructibleActorParam' : More...
struct | DestructibleActorState
Describes the NxParameterized::Interface for 'DestructibleActorState' : More...
struct | DestructibleAssetCollisionDataSet
Describes the NxParameterized::Interface for 'DestructibleAssetCollisionDataSet' : More...
struct | DestructibleAssetParameters
Describes the NxParameterized::Interface for 'DestructibleAssetParameters' : More...
struct | DestructibleDebugRenderParams
Describes the NxParameterized::Interface for 'DestructibleDebugRenderParams' : More...
struct | DestructibleModuleParameters
Describes the NxParameterized::Interface for 'DestructibleModuleParameters' : This class is used for initializing the NxModuleDestructible. More...
struct | DestructiblePreviewParam
Describes the NxParameterized::Interface for 'DestructiblePreviewParam' : More...
struct | EffectPackageActorParams
Describes the NxParameterized::Interface for 'EffectPackageActorParams' : The individual effect package actor properties. More...
struct | EffectPackageAssetParams
Describes the NxParameterized::Interface for 'EffectPackageAssetParams' : The effect package asset. More...
union | EffectPackageAssetParams::Effects
struct | EffectPackageData
Describes the NxParameterized::Interface for 'EffectPackageData' : Contains the Effect Package Properties. More...
struct | EffectPackageDatabaseParams
Describes the NxParameterized::Interface for 'EffectPackageDatabaseParams' : The collection of all effect packages. More...
struct | EffectPackageEmitterDatabaseParams
Describes the NxParameterized::Interface for 'EffectPackageEmitterDatabaseParams' : The collection of all emitter assets. More...
struct | EffectPackageFieldSamplerDatabaseParams
Describes the NxParameterized::Interface for 'EffectPackageFieldSamplerDatabaseParams' : The collection of all field sampler assets. More...
union | EffectPackageFieldSamplerDatabaseParams::FieldSamplers
struct | EffectPackageGraphicsMaterialsParams
Describes the NxParameterized::Interface for 'EffectPackageGraphicsMaterialsParams' : The collection of graphics and volumetric material assets. More...
union | EffectPackageGraphicsMaterialsParams::GraphicsMaterials
struct | EffectPackageIOFXDatabaseParams
Describes the NxParameterized::Interface for 'EffectPackageIOFXDatabaseParams' : The collection of graphics effect assets (IOFX) More...
struct | EffectPackageIOSDatabaseParams
Describes the NxParameterized::Interface for 'EffectPackageIOSDatabaseParams' : The collection of particle simulation assets (IOS) More...
struct | EmitterAssetPreviewParameters
Describes the NxParameterized::Interface for 'EmitterAssetPreviewParameters' : This class is used for creating APEX Emitter Preview instances (shaped, ground, or impact emitters) More...
struct | EmitterData
Describes the NxParameterized::Interface for 'EmitterData' : Contains the asset properties for this emitter. More...
struct | EmitterDebugRenderParams
Describes the NxParameterized::Interface for 'EmitterDebugRenderParams' : This class contains debug rendering parameters for the emitter module. More...
struct | EmitterEffect
Describes the NxParameterized::Interface for 'EmitterEffect' : An emitter effect. More...
struct | EmitterGeomBoxParams
Describes the NxParameterized::Interface for 'EmitterGeomBoxParams' : More...
struct | EmitterGeomCylinderParams
Describes the NxParameterized::Interface for 'EmitterGeomCylinderParams' : More...
struct | EmitterGeomExplicitParams
Describes the NxParameterized::Interface for 'EmitterGeomExplicitParams' : More...
struct | EmitterGeomSphereParams
Describes the NxParameterized::Interface for 'EmitterGeomSphereParams' : More...
struct | EmitterGeomSphereShellParams
Describes the NxParameterized::Interface for 'EmitterGeomSphereShellParams' : More...
struct | EmitterModuleParameters
Describes the NxParameterized::Interface for 'EmitterModuleParameters' : This class is used for initializing the NxModuleEmitter. More...
struct | FieldSamplerModuleParameters
Describes the NxParameterized::Interface for 'FieldSamplerModuleParameters' : This class is used for initializing the NxModuleFieldBoundary. More...
struct | FieldSamplerPhysXMonitorParams
Describes the NxParameterized::Interface for 'FieldSamplerPhysXMonitorParams' : More...
struct | FluidParticleSystemParams
Describes the NxParameterized::Interface for 'FluidParticleSystemParams' : More...
struct | ForceFieldActorParams
Describes the NxParameterized::Interface for 'ForceFieldActorParams' : More...
struct | ForceFieldAssetParams
Describes the NxParameterized::Interface for 'ForceFieldAssetParams' : Contains the asset properties for ForceField. More...
union | ForceFieldAssetParams::ForceFieldKernelType
struct | ForceFieldAssetPreviewParams
Describes the NxParameterized::Interface for 'ForceFieldAssetPreviewParams' : More...
struct | ForceFieldData
Describes the NxParameterized::Interface for 'ForceFieldData' : Contains the asset properties for this force field sampler. More...
struct | ForceFieldDebugRenderParams
Describes the NxParameterized::Interface for 'ForceFieldDebugRenderParams' : More...
struct | ForceFieldEffect
Describes the NxParameterized::Interface for 'ForceFieldEffect' : A forcefield effect. More...
struct | ForceFieldFalloffParams
Describes the NxParameterized::Interface for 'ForceFieldFalloffParams' : More...
struct | ForceFieldModuleParams
Describes the NxParameterized::Interface for 'ForceFieldModuleParams' : More...
struct | ForceFieldNoiseParams
Describes the NxParameterized::Interface for 'ForceFieldNoiseParams' : More...
struct | GenericForceFieldKernelParams
Describes the NxParameterized::Interface for 'GenericForceFieldKernelParams' : Generic force field kernel is needed for backward compatibility with NxForceFieldKernel (PhysX 2.8.4). More...
struct | GraphicsEffectData
Describes the NxParameterized::Interface for 'GraphicsEffectData' : Contains the asset properties for this graphics effect (IOFX) More...
struct | GraphicsMaterialData
Describes the NxParameterized::Interface for 'GraphicsMaterialData' : Contains the asset properties for this graphics material. More...
struct | GroundEmitterActorParameters
Describes the NxParameterized::Interface for 'GroundEmitterActorParameters' : This class is used for creating NxGroundEmitterActor instances. More...
struct | GroundEmitterAssetParameters
Describes the NxParameterized::Interface for 'GroundEmitterAssetParameters' : This class is parameter storage for the NxGroundEmitterAsset. More...
struct | HeatSourceActorParams
Describes the NxParameterized::Interface for 'HeatSourceActorParams' : More...
union | HeatSourceActorParams::GeometryType
struct | HeatSourceAssetParams
Describes the NxParameterized::Interface for 'HeatSourceAssetParams' : Contains the asset properties for this HeatSource. More...
union | HeatSourceAssetParams::GeometryType
struct | HeatSourceData
Describes the NxParameterized::Interface for 'HeatSourceData' : Contains the asset properties for this heat source asset. More...
struct | HeatSourceEffect
Describes the NxParameterized::Interface for 'HeatSourceEffect' : A heat source effect. More...
struct | HeatSourceGeomBoxParams
Describes the NxParameterized::Interface for 'HeatSourceGeomBoxParams' : Contains the asset properties for this HeatSource Geometry. More...
struct | HeatSourceGeomSphereParams
Describes the NxParameterized::Interface for 'HeatSourceGeomSphereParams' : More...
struct | HeatSourcePreviewParams
Describes the NxParameterized::Interface for 'HeatSourcePreviewParams' : More...
struct | ImpactEmitterActorParameters
Describes the NxParameterized::Interface for 'ImpactEmitterActorParameters' : This class is used for creating NxImpactEmitterActor instances. More...
struct | ImpactEmitterAssetParameters
Describes the NxParameterized::Interface for 'ImpactEmitterAssetParameters' : This class is parameter storage for the Impact Emitter. More...
union | ImpactEmitterAssetParameters::EventSetList
struct | ImpactExplosionEvent
Describes the NxParameterized::Interface for 'ImpactExplosionEvent' : More...
struct | ImpactObjectEvent
Describes the NxParameterized::Interface for 'ImpactObjectEvent' : More...
struct | InitialColorModifierParams
Describes the NxParameterized::Interface for 'InitialColorModifierParams' : InitialColor modifier parameters. More...
struct | IofxAssetParameters
Describes the NxParameterized::Interface for 'IofxAssetParameters' : Contains the asset properties for an IOFX. More...
union | IofxAssetParameters::IofxType
struct | IofxDebugRenderParams
Describes the NxParameterized::Interface for 'IofxDebugRenderParams' : More...
struct | IofxModuleParameters
Describes the NxParameterized::Interface for 'IofxModuleParameters' : This class is used for initializing the NxModuleIofx. More...
struct | JetFSActorParams
Describes the NxParameterized::Interface for 'JetFSActorParams' : More...
struct | JetFSAssetParams
Describes the NxParameterized::Interface for 'JetFSAssetParams' : Contains the asset properties for this Jet Field Sampler. More...
struct | JetFSPreviewParams
Describes the NxParameterized::Interface for 'JetFSPreviewParams' : More...
struct | JetFieldSamplerData
Describes the NxParameterized::Interface for 'JetFieldSamplerData' : Contains the asset properties for this jet field sampler. More...
struct | JetFieldSamplerEffect
Describes the NxParameterized::Interface for 'JetFieldSamplerEffect' : A jet field sampler effect. More...
struct | MeshCookedCollisionStream
Describes the NxParameterized::Interface for 'MeshCookedCollisionStream' : More...
struct | MeshCookedCollisionStreamsAtScale
Describes the NxParameterized::Interface for 'MeshCookedCollisionStreamsAtScale' : More...
struct | MeshIofxParameters
Describes the NxParameterized::Interface for 'MeshIofxParameters' : More...
union | MeshIofxParameters::SpawnModifierList
union | MeshIofxParameters::ContinuousModifierList
struct | NoiseFSActorParams
Describes the NxParameterized::Interface for 'NoiseFSActorParams' : More...
struct | NoiseFSAssetParams
Describes the NxParameterized::Interface for 'NoiseFSAssetParams' : Contains the asset properties for this Noise Field Sampler. More...
struct | NoiseFSPreviewParams
Describes the NxParameterized::Interface for 'NoiseFSPreviewParams' : More...
struct | NoiseFieldSamplerData
Describes the NxParameterized::Interface for 'NoiseFieldSamplerData' : Contains the asset properties for this noise field sampler. More...
struct | NoiseFieldSamplerEffect
Describes the NxParameterized::Interface for 'NoiseFieldSamplerEffect' : A noise field sampler effect. More...
struct | OrientAlongVelocityModifierParams
Describes the NxParameterized::Interface for 'OrientAlongVelocityModifierParams' : OrientAlongVelocity modifier parameters. More...
struct | OrientScaleAlongScreenVelocityModifierParams
Describes the NxParameterized::Interface for 'OrientScaleAlongScreenVelocityModifierParams' : OrientScaleAlongScreenVelocity modifier parameters. More...
struct | ParticleIosAssetParam
Describes the NxParameterized::Interface for 'ParticleIosAssetParam' : Contains the asset properties for an IOS. More...
union | ParticleIosAssetParam::ParticleType
struct | ParticleIosDebugRenderParams
Describes the NxParameterized::Interface for 'ParticleIosDebugRenderParams' : More...
struct | ParticleIosModuleParameters
Describes the NxParameterized::Interface for 'ParticleIosModuleParameters' : This class is used for initializing the NxModuleParticleIos. More...
struct | ParticleSimulationData
Describes the NxParameterized::Interface for 'ParticleSimulationData' : Contains the asset properties for this particle simulation (IOS) More...
union | ParticleSimulationData::IOS
struct | ParticlesDebugRenderParams
Describes the NxParameterized::Interface for 'ParticlesDebugRenderParams' : More...
struct | ParticlesModuleParameters
Describes the NxParameterized::Interface for 'ParticlesModuleParameters' : This class is used for initializing the NxModuleParticles. More...
struct | RadialForceFieldKernelParams
Describes the NxParameterized::Interface for 'RadialForceFieldKernelParams' : Radial force field kernel correspond to APEX 1.3 Force Field implementation. More...
struct | RandomRotationModifierParams
Describes the NxParameterized::Interface for 'RandomRotationModifierParams' : RandomRotation modifier parameters. More...
struct | RandomScaleModifierParams
Describes the NxParameterized::Interface for 'RandomScaleModifierParams' : RandomScale modifier parameters. More...
struct | RandomSubtextureModifierParams
Describes the NxParameterized::Interface for 'RandomSubtextureModifierParams' : RandomSubtexture modifier parameters. More...
struct | RenderMeshAssetParameters
Describes the NxParameterized::Interface for 'RenderMeshAssetParameters' : More...
struct | RigidBodyEffect
Describes the NxParameterized::Interface for 'RigidBodyEffect' : An effect comprised of a primitive rigid body shape. More...
struct | RotationModifierParams
Describes the NxParameterized::Interface for 'RotationModifierParams' : Rotation modifier parameters. More...
struct | RotationRateModifierParams
Describes the NxParameterized::Interface for 'RotationRateModifierParams' : RotationRate modifier parameters. More...
struct | RotationRateVsLifeModifierParams
Describes the NxParameterized::Interface for 'RotationRateVsLifeModifierParams' : RotationRateVsLife modifier parameters. More...
struct | ScaleAlongVelocityModifierParams
Describes the NxParameterized::Interface for 'ScaleAlongVelocityModifierParams' : ScaleAlongVelocity modifier parameters. More...
struct | ScaleByMassModifierParams
Describes the NxParameterized::Interface for 'ScaleByMassModifierParams' : ScaleByMass modifier parameters. More...
struct | ScaleVsCameraDistance2DModifierParams
Describes the NxParameterized::Interface for 'ScaleVsCameraDistance2DModifierParams' : ScaleVsCameraDistance2D modifier parameters. More...
struct | ScaleVsCameraDistance3DModifierParams
Describes the NxParameterized::Interface for 'ScaleVsCameraDistance3DModifierParams' : ScaleVsCameraDistance3D modifier parameters. More...
struct | ScaleVsCameraDistanceModifierParams
Describes the NxParameterized::Interface for 'ScaleVsCameraDistanceModifierParams' : ScaleVsCameraDistance modifier parameters. More...
struct | ScaleVsDensity2DModifierParams
Describes the NxParameterized::Interface for 'ScaleVsDensity2DModifierParams' : ScaleVsDensity2D modifier parameters. More...
struct | ScaleVsDensity3DModifierParams
Describes the NxParameterized::Interface for 'ScaleVsDensity3DModifierParams' : ScaleVsDensity3D modifier parameters. More...
struct | ScaleVsDensityModifierParams
Describes the NxParameterized::Interface for 'ScaleVsDensityModifierParams' : ScaleVsDensity modifier parameters. More...
struct | ScaleVsLife2DModifierParams
Describes the NxParameterized::Interface for 'ScaleVsLife2DModifierParams' : ScaleVsLife2D modifier parameters. More...
struct | ScaleVsLife3DModifierParams
Describes the NxParameterized::Interface for 'ScaleVsLife3DModifierParams' : ScaleVsLife3D modifier parameters. More...
struct | ScaleVsLifeModifierParams
Describes the NxParameterized::Interface for 'ScaleVsLifeModifierParams' : ScaleVsLife modifier parameters. More...
struct | ScaleVsTemperature2DModifierParams
Describes the NxParameterized::Interface for 'ScaleVsTemperature2DModifierParams' : ScaleVsTemperature2D modifier parameters. More...
struct | ScaleVsTemperature3DModifierParams
Describes the NxParameterized::Interface for 'ScaleVsTemperature3DModifierParams' : ScaleVsTemperature3D modifier parameters. More...
struct | ScaleVsTemperatureModifierParams
Describes the NxParameterized::Interface for 'ScaleVsTemperatureModifierParams' : ScaleVsTemperature modifier parameters. More...
struct | SimpleParticleSystemParams
Describes the NxParameterized::Interface for 'SimpleParticleSystemParams' : More...
struct | SimpleScaleModifierParams
Describes the NxParameterized::Interface for 'SimpleScaleModifierParams' : SimpleScale modifier parameters. More...
struct | SpriteIofxParameters
Describes the NxParameterized::Interface for 'SpriteIofxParameters' : More...
union | SpriteIofxParameters::SpawnModifierList
union | SpriteIofxParameters::ContinuousModifierList
struct | SubmeshParameters
Describes the NxParameterized::Interface for 'SubmeshParameters' : More...
struct | SubstanceSourceActorParams
Describes the NxParameterized::Interface for 'SubstanceSourceActorParams' : More...
union | SubstanceSourceActorParams::GeometryType
struct | SubstanceSourceAssetParams
Describes the NxParameterized::Interface for 'SubstanceSourceAssetParams' : Contains the asset properties for this SubstanceSource. More...
union | SubstanceSourceAssetParams::GeometryType
struct | SubstanceSourceData
Describes the NxParameterized::Interface for 'SubstanceSourceData' : Contains the asset properties for this substance source. More...
struct | SubstanceSourceEffect
Describes the NxParameterized::Interface for 'SubstanceSourceEffect' : A substance source effect. More...
struct | SubtextureVsLifeModifierParams
Describes the NxParameterized::Interface for 'SubtextureVsLifeModifierParams' : SubtextureVsLife modifier parameters. More...
struct | SurfaceBufferParameters
Describes the NxParameterized::Interface for 'SurfaceBufferParameters' : More...
union | SurfaceBufferParameters::Buffer
struct | SurfaceTraceParameters
Describes the NxParameterized::Interface for 'SurfaceTraceParameters' : More...
struct | SurfaceTraceSetParameters
Describes the NxParameterized::Interface for 'SurfaceTraceSetParameters' : More...
struct | TurbulenceFSActorParams
Describes the NxParameterized::Interface for 'TurbulenceFSActorParams' : More...
struct | TurbulenceFSAssetParams
Describes the NxParameterized::Interface for 'TurbulenceFSAssetParams' : Contains the asset properties for this Turbulence field sampler. More...
struct | TurbulenceFSDebugRenderParams
Describes the NxParameterized::Interface for 'TurbulenceFSDebugRenderParams' : More...
struct | TurbulenceFSModuleParameters
Describes the NxParameterized::Interface for 'TurbulenceFSModuleParameters' : This class is used for initializing the NxModuleFieldBoundary. More...
struct | TurbulenceFSPreviewParams
Describes the NxParameterized::Interface for 'TurbulenceFSPreviewParams' : More...
struct | TurbulenceFieldSamplerData
Describes the NxParameterized::Interface for 'TurbulenceFieldSamplerData' : Contains the asset properties for this turbulence field sampler. More...
struct | TurbulenceFieldSamplerEffect
Describes the NxParameterized::Interface for 'TurbulenceFieldSamplerEffect' : A turbulence effect. More...
struct | VelocitySourceActorParams
Describes the NxParameterized::Interface for 'VelocitySourceActorParams' : More...
union | VelocitySourceActorParams::GeometryType
struct | VelocitySourceAssetParams
Describes the NxParameterized::Interface for 'VelocitySourceAssetParams' : Contains the asset properties for this VelocitySource. More...
union | VelocitySourceAssetParams::GeometryType
struct | VelocitySourceData
Describes the NxParameterized::Interface for 'VelocitySourceData' : Contains the asset properties for this velocity source. More...
struct | VelocitySourceEffect
Describes the NxParameterized::Interface for 'VelocitySourceEffect' : A velocity source effect. More...
struct | VelocitySourcePreviewParams
Describes the NxParameterized::Interface for 'VelocitySourcePreviewParams' : More...
struct | VertexBufferParameters
Describes the NxParameterized::Interface for 'VertexBufferParameters' : More...
union | VertexBufferParameters::Buffers
struct | VertexFormatParameters
Describes the NxParameterized::Interface for 'VertexFormatParameters' : More...
struct | ViewDirectionSortingModifierParams
Describes the NxParameterized::Interface for 'ViewDirectionSortingModifierParams' : ViewDirectionSorting modifier parameters. More...
struct | VolumeRenderMaterialData
Describes the NxParameterized::Interface for 'VolumeRenderMaterialData' : Contains the volume render material properties for this asset. More...
struct | VortexFSActorParams
Describes the NxParameterized::Interface for 'VortexFSActorParams' : More...
struct | VortexFSAssetParams
Describes the NxParameterized::Interface for 'VortexFSAssetParams' : Contains the asset properties for this Vortex Field Sampler. More...
struct | VortexFSPreviewParams
Describes the NxParameterized::Interface for 'VortexFSPreviewParams' : More...
struct | VortexFieldSamplerData
Describes the NxParameterized::Interface for 'VortexFieldSamplerData' : Contains the asset properties for this vortex field sampler. More...
struct | VortexFieldSamplerEffect
Describes the NxParameterized::Interface for 'VortexFieldSamplerEffect' : A vortex field sampler effect. More...
struct | WindFSActorParams
Describes the NxParameterized::Interface for 'WindFSActorParams' : More...
struct | WindFSAssetParams
Describes the NxParameterized::Interface for 'WindFSAssetParams' : Contains the asset properties for this Wind Field Sampler. More...
struct | WindFSPreviewParams
Describes the NxParameterized::Interface for 'WindFSPreviewParams' : More...
struct | WindFieldSamplerData
Describes the NxParameterized::Interface for 'WindFieldSamplerData' : Contains the asset properties for this wind field sampler. More...
struct | WindFieldSamplerEffect
Describes the NxParameterized::Interface for 'WindFieldSamplerEffect' : A wind field sampler effect. More...

Namespaces

namespace | physx

Enumerations

enum ColorChannel {
red,
green,
blue,
alpha
}
'ColorChannel' : enumerated values More...
enum DensityAdvection {
ADVECTION_LINEAR,
ADVECTION_MACCORMACK
}
'DensityAdvection' : enumerated values More...
enum EmitterType {
rate,
densityOnce,
densityBrush,
fill
}
'EmitterType' : enumerated values More...
enum FieldFormat {
FLOAT,
HALF,
UCHAR,
FLOAT4,
HALF4,
UCHAR4
}
'FieldFormat' : enumerated values More...
enum FieldType {
FORCE,
VELOCITY_DRAG,
VELOCITY_DIRECT
}
'FieldType' : enumerated values More...
enum FillMode {
SOLID,
WIREFRAME
}
'FillMode' : enumerated values More...
enum ImpactAxis {
incident,
normal,
reflection
}
'ImpactAxis' : enumerated values More...
enum Max {
EGR_12,
EGR_16,
EGR_24,
EGR_32,
EGR_48,
EGR_64,
EGR_96,
EGR_128
}
'Max' : enumerated values More...
enum Min {
EGR_12,
EGR_16,
EGR_24,
EGR_32,
EGR_48,
EGR_64,
EGR_96,
EGR_128
}
'Min' : enumerated values More...
enum NoiseType {
SIMPLEX,
CURL
}
'NoiseType' : enumerated values More...
enum PlaybackMode {
LOOP,
PLAY_ONCE,
PING_PONG
}
'PlaybackMode' : enumerated values More...
enum RenderMethod {
RAYCASTING,
SLICE_BASED
}
'RenderMethod' : enumerated values More...
enum RenderMode {
VOLUME,
VOLUME_COLORMAP,
VOLUME_SHADOWED,
VOXELS,
ISOSURFACE
}
'RenderMode' : enumerated values More...
enum RenderTechnique {
SPRITE_ONE,
SPRITE_ONE,
SPRITE_ALPHA,
SPRITE_SOLID,
SPRITE_TEXTURE,
SPRITE_WIREFRAME
}
'RenderTechnique' : enumerated values More...
enum Resolution {
GDG_8,
GDG_16,
GDG_32,
GDG_64,
GDG_128,
GDG_256
}
'Resolution' : enumerated values More...
enum ResolutionScale {
NO_SCALE,
HALF_SCALE,
QUARTER_SCALE
}
'ResolutionScale' : enumerated values More...
enum RollType {
SPHERICAL,
CUBIC,
FLAT_X,
FLAT_Y,
FLAT_Z,
LONG_X,
LONG_Y,
LONG_Z
}
'RollType' : enumerated values More...
enum RuntimeFractureType {
VORONOI,
GLASS
}
'RuntimeFractureType' : enumerated values More...
enum ScaleAxis {
xAxis,
yAxis,
zAxis
}
'ScaleAxis' : enumerated values More...
enum Shape {
sphere,
capsule,
cylinder,
cone,
box,
none
}
'Shape' : enumerated values More...
enum SimulationBackend {
Default,
ForceNative,
ForceEmbedded
}
'SimulationBackend' : enumerated values More...
enum SolverMode {
SOLVER_JACOBI,
SOLVER_MULTIGRID
}
'SolverMode' : enumerated values More...
enum | SortType { default }
'SortType' : enumerated values More...
enum Type {
uniform,
normal
}
'Type' : enumerated values More...
enum VelocityAdvection {
ADVECTION_LINEAR,
ADVECTION_MACCORMACK
}
'VelocityAdvection' : enumerated values More...

Enumeration Type Documentation

enum ColorChannel

'ColorChannel' : enumerated values

Indicates the name to use to find the array size for this set parameters.

Enumerator:
red
green
blue
alpha
enum DensityAdvection

'DensityAdvection' : enumerated values

Enumerator:
ADVECTION_LINEAR
ADVECTION_MACCORMACK
enum EmitterType

'EmitterType' : enumerated values

Enumerator:
rate
densityOnce
densityBrush
fill
enum FieldFormat

'FieldFormat' : enumerated values

Enumerator:
FLOAT
HALF
UCHAR
FLOAT4
HALF4
UCHAR4
enum FieldType

'FieldType' : enumerated values

Enumerator:
FORCE
VELOCITY_DRAG
VELOCITY_DIRECT
enum FillMode

'FillMode' : enumerated values

Enumerator:
SOLID
WIREFRAME
enum ImpactAxis

'ImpactAxis' : enumerated values

Enumerator:
incident
normal
reflection
enum Max

'Max' : enumerated values

Enumerator:
EGR_12
EGR_16
EGR_24
EGR_32
EGR_48
EGR_64
EGR_96
EGR_128
enum Min

'Min' : enumerated values

Enumerator:
EGR_12
EGR_16
EGR_24
EGR_32
EGR_48
EGR_64
EGR_96
EGR_128
enum NoiseType

'NoiseType' : enumerated values

Enumerator:
SIMPLEX
CURL
enum PlaybackMode

'PlaybackMode' : enumerated values

Enumerator:
LOOP
PLAY_ONCE
PING_PONG
enum RenderMethod

'RenderMethod' : enumerated values

Enumerator:
RAYCASTING
SLICE_BASED
enum RenderMode

'RenderMode' : enumerated values

Enumerator:
VOLUME
VOLUME_COLORMAP
VOLUME_SHADOWED
VOXELS
ISOSURFACE
enum RenderTechnique

'RenderTechnique' : enumerated values

Enumerator:
SPRITE_ONE
SPRITE_ONE
SPRITE_ALPHA
SPRITE_SOLID
SPRITE_TEXTURE
SPRITE_WIREFRAME
enum Resolution

'Resolution' : enumerated values

Enumerator:
GDG_8
GDG_16
GDG_32
GDG_64
GDG_128
GDG_256
enum ResolutionScale

'ResolutionScale' : enumerated values

Enumerator:
NO_SCALE
HALF_SCALE
QUARTER_SCALE
enum RollType

'RollType' : enumerated values

Enumerator:
SPHERICAL
CUBIC
FLAT_X
FLAT_Y
FLAT_Z
LONG_X
LONG_Y
LONG_Z
enum RuntimeFractureType

'RuntimeFractureType' : enumerated values

Enumerator:
VORONOI
GLASS
enum ScaleAxis

'ScaleAxis' : enumerated values

Enumerator:
xAxis
yAxis
zAxis
enum Shape

'Shape' : enumerated values

Enumerator:
sphere
capsule
cylinder
cone
box
none
enum SimulationBackend

'SimulationBackend' : enumerated values

Enumerator:
Default
ForceNative
ForceEmbedded
enum SolverMode

'SolverMode' : enumerated values

Enumerator:
SOLVER_JACOBI
SOLVER_MULTIGRID
enum SortType

'SortType' : enumerated values

Enumerator:
default
enum Type

'Type' : enumerated values

Enumerator:
uniform
normal
enum VelocityAdvection

'VelocityAdvection' : enumerated values

Enumerator:
ADVECTION_LINEAR
ADVECTION_MACCORMACK
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: params.h Source File

  • File List
  • File Members
params.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef PARAMETERIZED_H
00030 #define PARAMETERIZED_H
00031
00032 namespace physx
00033 {
00034 class physx::PxVec3;
00035 class physx::PxQuat;
00036 class physx::PxMat33Legacy;
00037 class physx::PxMat34Legacy;
00038 class physx::PxBounds3;
00039 };
00040
00041 class       physx::PxI64;
00042 class           physx::PxI32;
00043 class       physx::PxI16;
00044 class           physx::PxI8;
00045
00046 class   PxU64;
00047 class       physx::PxU32;
00048 class       PxU16;
00049 class       PxU8;
00050
00051 class               physx::PxF32;
00052 class               physx::PxF64;
00053
00062 enum ColorChannel
00063 {
00064     red,
00065     green,
00066     blue,
00067     alpha,
00068 };
00069
00070
00074 enum DensityAdvection
00075 {
00076     ADVECTION_LINEAR,
00077     ADVECTION_MACCORMACK,
00078 };
00079
00080
00084 enum EmitterType
00085 {
00086     rate,
00087     densityOnce,
00088     densityBrush,
00089     fill,
00090 };
00091
00092
00096 enum FieldFormat
00097 {
00098     FLOAT,
00099     HALF,
00100     UCHAR,
00101     FLOAT4,
00102     HALF4,
00103     UCHAR4,
00104 };
00105
00106
00110 enum FieldType
00111 {
00112     FORCE,
00113     VELOCITY_DRAG,
00114     VELOCITY_DIRECT,
00115 };
00116
00117
00121 enum FillMode
00122 {
00123     SOLID,
00124     WIREFRAME,
00125 };
00126
00127
00131 enum ImpactAxis
00132 {
00133     incident,
00134     normal,
00135     reflection,
00136 };
00137
00138
00142 enum Max
00143 {
00144     EGR_12,
00145     EGR_16,
00146     EGR_24,
00147     EGR_32,
00148     EGR_48,
00149     EGR_64,
00150     EGR_96,
00151     EGR_128,
00152 };
00153
00154
00158 enum Min
00159 {
00160     EGR_12,
00161     EGR_16,
00162     EGR_24,
00163     EGR_32,
00164     EGR_48,
00165     EGR_64,
00166     EGR_96,
00167     EGR_128,
00168 };
00169
00170
00174 enum NoiseType
00175 {
00176     SIMPLEX,
00177     CURL,
00178 };
00179
00180
00184 enum PlaybackMode
00185 {
00186     LOOP,
00187     PLAY_ONCE,
00188     PING_PONG,
00189 };
00190
00191
00195 enum RenderMethod
00196 {
00197     RAYCASTING,
00198     SLICE_BASED,
00199 };
00200
00201
00205 enum RenderMode
00206 {
00207     VOLUME,
00208     VOLUME_COLORMAP,
00209     VOLUME_SHADOWED,
00210     VOXELS,
00211     ISOSURFACE,
00212 };
00213
00214
00218 enum RenderTechnique
00219 {
00220     SPRITE_ONE,
00221     SPRITE_ONE,
00222     SPRITE_ALPHA,
00223     SPRITE_SOLID,
00224     SPRITE_TEXTURE,
00225     SPRITE_WIREFRAME,
00226 };
00227
00228
00232 enum Resolution
00233 {
00234     GDG_8,
00235     GDG_16,
00236     GDG_32,
00237     GDG_64,
00238     GDG_128,
00239     GDG_256,
00240 };
00241
00242
00246 enum ResolutionScale
00247 {
00248     NO_SCALE,
00249     HALF_SCALE,
00250     QUARTER_SCALE,
00251 };
00252
00253
00257 enum RollType
00258 {
00259     SPHERICAL,
00260     CUBIC,
00261     FLAT_X,
00262     FLAT_Y,
00263     FLAT_Z,
00264     LONG_X,
00265     LONG_Y,
00266     LONG_Z,
00267 };
00268
00269
00273 enum RuntimeFractureType
00274 {
00275     VORONOI,
00276     GLASS,
00277 };
00278
00279
00283 enum ScaleAxis
00284 {
00285     xAxis,
00286     yAxis,
00287     zAxis,
00288 };
00289
00290
00294 enum Shape
00295 {
00296     sphere,
00297     capsule,
00298     cylinder,
00299     cone,
00300     box,
00301     none,
00302 };
00303
00304
00308 enum SimulationBackend
00309 {
00310     Default,
00311     ForceNative,
00312     ForceEmbedded,
00313 };
00314
00315
00319 enum SolverMode
00320 {
00321     SOLVER_JACOBI,
00322     SOLVER_MULTIGRID,
00323 };
00324
00325
00329 enum SortType
00330 {
00331     default,
00332 };
00333
00334
00338 enum Type
00339 {
00340     uniform,
00341     normal,
00342 };
00343
00344
00348 enum VelocityAdvection
00349 {
00350     ADVECTION_LINEAR,
00351     ADVECTION_MACCORMACK,
00352 };
00353
00371 struct ApexEmitterActorParameters
00372 {
00376     Mat34               initialPose;
00380     F32                 initialScale;
00384     Mat34               attachRelativePose;
00391     Bool                emitAssetParticles;
00398     String              overlapTestGroupMaskName;
00405     String              overlapTestGroupsMask128Name;
00412     F32                 emitterDuration;
00413 };
00414
00415
00487 struct ApexEmitterAssetParameters
00488 {
00492     F32                 densityRange.min;
00496     F32                 densityRange.max;
00500     F32                 rateRange.min;
00504     F32                 rateRange.max;
00508     F32                 lifetimeRange.min;
00512     F32                 lifetimeRange.max;
00516     Vec3                velocityRange.min;
00520     Vec3                velocityRange.max;
00524     F32                 temperatureRange.min;
00528     F32                 temperatureRange.max;
00535     U32                 maxSamples;
00539     U32                 lodParamDesc.version;
00543     F32                 lodParamDesc.maxDistance;
00547     F32                 lodParamDesc.distanceWeight;
00551     F32                 lodParamDesc.speedWeight;
00555     F32                 lodParamDesc.lifeWeight;
00559     F32                 lodParamDesc.separationWeight;
00563     F32                 lodParamDesc.bias;
00567     Ref                 iofxAssetName;
00571     Ref                 iosAssetName;
00572 union GeometryType {
00576     EmitterGeomBoxParams    geometryType;
00580     EmitterGeomSphereParams geometryType;
00584     EmitterGeomSphereShellParams    geometryType;
00588     EmitterGeomCylinderParams   geometryType;
00592     EmitterGeomExplicitParams   geometryType;
00593 };
00594 GeometryType    geometryType;
00601     F32                 emitterDuration;
00608     U32                 minSamplingFPS;
00612     F32                 rateVsTimeCurvePoints[].x;
00616     F32                 rateVsTimeCurvePoints[].y;
00617 };
00618
00619
00634 struct AttractorFSActorParams
00635 {
00642     Mat34               initialPose;
00646     F32                 initialScale;
00650     String              fieldBoundaryFilterDataName;
00654     String              fieldSamplerFilterDataName;
00655 };
00656
00657
00676 struct AttractorFSAssetParams
00677 {
00681     F32                 boundaryFadePercentage;
00685     F32                 radius;
00689     F32                 constFieldStrength;
00696     F32                 variableFieldStrength;
00700     F32                 fieldDragCoeff;
00704     F32                 fieldWeight;
00708     String              fieldBoundaryFilterDataName;
00712     String              fieldSamplerFilterDataName;
00713 };
00714
00715
00730 struct AttractorFSPreviewParams
00731 {
00735     Mat44               globalPose;
00739     Bool                drawShape;
00743     Bool                drawAssetInfo;
00747     U64                 userData;
00748 };
00749
00750
00770 struct AttractorFieldSamplerData
00771 {
00775     String              Name;
00779     AttractorFSAssetParams  AttractorFieldSampler;
00780 };
00781
00782
00818 struct AttractorFieldSamplerEffect
00819 {
00823     String              EffectProperties.UserString;
00827     Bool                EffectProperties.Enable;
00831     F32                 EffectProperties.Position.TranslateX;
00835     F32                 EffectProperties.Position.TranslateY;
00839     F32                 EffectProperties.Position.TranslateZ;
00843     F32                 EffectProperties.Orientation.RotateX;
00847     F32                 EffectProperties.Orientation.RotateY;
00851     F32                 EffectProperties.Orientation.RotateZ;
00855     F32                 EffectProperties.InitialDelayTime;
00859     F32                 EffectProperties.Duration;
00863     U32                 EffectProperties.RepeatCount;
00867     F32                 EffectProperties.RepeatDelay;
00871     F32                 EffectProperties.RandomizeRepeatTime;
00875     PlaybackMode        EffectProperties.Path.PlaybackMode;
00879     F32                 EffectProperties.Path.PathDuration;
00883     U32                 EffectProperties.Path.LoopIndex;
00887     Transform           EffectProperties.Path.ControlPoints[];
00891     F32                 EffectProperties.Path.Scale[].x;
00895     F32                 EffectProperties.Path.Scale[].y;
00899     F32                 EffectProperties.Path.Speed[].x;
00903     F32                 EffectProperties.Path.Speed[].y;
00907     Ref                 AttractorFieldSampler;
00908 };
00909
00910
00943 struct BasicFSDebugRenderParams
00944 {
00948     Bool                VISUALIZE_JET_FS_ACTOR;
00952     Bool                VISUALIZE_JET_FS_ACTOR_NAME;
00956     Bool                VISUALIZE_JET_FS_SHAPE;
00960     Bool                VISUALIZE_JET_FS_FIELD;
00964     Bool                VISUALIZE_JET_FS_POSE;
00968     F32                 JET_FS_FIELD_SCALE;
00972     Bool                VISUALIZE_ATTRACTOR_FS_ACTOR;
00976     Bool                VISUALIZE_ATTRACTOR_FS_ACTOR_NAME;
00980     Bool                VISUALIZE_ATTRACTOR_FS_SHAPE;
00984     Bool                VISUALIZE_ATTRACTOR_FS_FIELD;
00988     Bool                VISUALIZE_ATTRACTOR_FS_POSE;
00992     Bool                VISUALIZE_VORTEX_FS_ACTOR;
00996     Bool                VISUALIZE_VORTEX_FS_ACTOR_NAME;
01000     Bool                VISUALIZE_VORTEX_FS_SHAPE;
01004     Bool                VISUALIZE_VORTEX_FS_FIELD;
01008     Bool                VISUALIZE_VORTEX_FS_POSE;
01012     Bool                VISUALIZE_NOISE_FS_ACTOR;
01016     Bool                VISUALIZE_NOISE_FS_ACTOR_NAME;
01020     Bool                VISUALIZE_NOISE_FS_SHAPE;
01024     Bool                VISUALIZE_NOISE_FS_POSE;
01028     Bool                VISUALIZE_WIND_FS_ACTOR;
01032     Bool                VISUALIZE_WIND_FS_ACTOR_NAME;
01033 };
01034
01035
01047 struct BasicFSModuleParameters
01048 {
01052     U32                 unused;
01053 };
01054
01055
01091 struct BasicIOSAssetParam
01092 {
01099     F32                 restDensity;
01106     F32                 particleRadius;
01110     U32                 maxParticleCount;
01117     F32                 maxInjectedParticleCount;
01124     U32                 maxCollidingObjects;
01128     F32                 sceneGravityScale;
01132     Vec3                externalAcceleration;
01136     F32                 particleMass.center;
01143     F32                 particleMass.spread;
01150     Type                particleMass.type;
01154     String              collisionFilterDataName;
01158     String              fieldSamplerFilterDataName;
01162     Bool                staticCollision;
01166     F32                 restitutionForStaticShapes;
01170     Bool                dynamicCollision;
01174     F32                 restitutionForDynamicShapes;
01178     F32                 collisionDistanceMultiplier;
01182     F32                 collisionThreshold;
01186     Bool                collisionWithConvex;
01190     Bool                collisionWithTriangleMesh;
01197     Bool                GridDensity.Enabled;
01204     Resolution          GridDensity.Resolution;
01211     F32                 GridDensity.GridSize;
01218     U32                 GridDensity.MaxCellCount;
01222     Bool                enableTemperatureBuffer;
01223 };
01224
01225
01239 struct BasicIosDebugRenderParams
01240 {
01244     Bool                VISUALIZE_BASIC_IOS_ACTOR;
01248     Bool                VISUALIZE_BASIC_IOS_COLLIDE_SHAPES;
01252     Bool                VISUALIZE_BASIC_IOS_GRID_DENSITY;
01253 };
01254
01255
01267 struct BasicIosModuleParameters
01268 {
01272     U32                 unused;
01273 };
01274
01275
01288 struct BufferF32x1
01289 {
01293     F32                 data[];
01294 };
01295
01296
01310 struct BufferF32x2
01311 {
01315     F32                 data[].x;
01319     F32                 data[].y;
01320 };
01321
01322
01335 struct BufferF32x3
01336 {
01340     Vec3                data[];
01341 };
01342
01343
01359 struct BufferF32x4
01360 {
01364     F32                 data[].x;
01368     F32                 data[].y;
01372     F32                 data[].z;
01376     F32                 data[].w;
01377 };
01378
01379
01392 struct BufferU16x1
01393 {
01397     U16                 data[];
01398 };
01399
01400
01414 struct BufferU16x2
01415 {
01419     U16                 data[].x;
01423     U16                 data[].y;
01424 };
01425
01426
01441 struct BufferU16x3
01442 {
01446     U16                 data[].x;
01450     U16                 data[].y;
01454     U16                 data[].z;
01455 };
01456
01457
01473 struct BufferU16x4
01474 {
01478     U16                 data[].x;
01482     U16                 data[].y;
01486     U16                 data[].z;
01490     U16                 data[].w;
01491 };
01492
01493
01506 struct BufferU32x1
01507 {
01511     U32                 data[];
01512 };
01513
01514
01528 struct BufferU32x2
01529 {
01533     U32                 data[].x;
01537     U32                 data[].y;
01538 };
01539
01540
01555 struct BufferU32x3
01556 {
01560     U32                 data[].x;
01564     U32                 data[].y;
01568     U32                 data[].z;
01569 };
01570
01571
01587 struct BufferU32x4
01588 {
01592     U32                 data[].x;
01596     U32                 data[].y;
01600     U32                 data[].z;
01604     U32                 data[].w;
01605 };
01606
01607
01620 struct BufferU8x1
01621 {
01625     U8                  data[];
01626 };
01627
01628
01642 struct BufferU8x2
01643 {
01647     U8                  data[].x;
01651     U8                  data[].y;
01652 };
01653
01654
01669 struct BufferU8x3
01670 {
01674     U8                  data[].x;
01678     U8                  data[].y;
01682     U8                  data[].z;
01683 };
01684
01685
01701 struct BufferU8x4
01702 {
01706     U8                  data[].x;
01710     U8                  data[].y;
01714     U8                  data[].z;
01718     U8                  data[].w;
01719 };
01720
01721
01736 struct CachedOverlaps
01737 {
01744     Bool                isCached;
01748     I32                 overlaps[].i0;
01752     I32                 overlaps[].i1;
01753 };
01754
01755
01856 struct ClothingActorParam
01857 {
01861     Mat44               globalPose;
01865     Bool                useHardwareCloth;
01872     Bool                flags.ParallelCpuSkinning;
01879     Bool                flags.RecomputeNormals;
01886     Bool                flags.RecomputeTangents;
01890     Bool                flags.Visualize;
01897     Bool                flags.CorrectSimulationNormals;
01901     Bool                flags.ComputeRenderData;
01905     Bool                flags.ComputePhysicsMeshNormals;
01912     Bool                fallbackSkinning;
01919     Bool                slowStart;
01926     Bool                useInternalBoneOrder;
01933     Bool                updateStateWithGlobalMatrices;
01940     U32                 uvChannelForTangentUpdate;
01947     F32                 maxDistanceBlendTime;
01951     U32                 clothingMaterialIndex;
01955     F32                 lodWeights.maxDistance;
01959     F32                 lodWeights.distanceWeight;
01963     F32                 lodWeights.bias;
01967     F32                 lodWeights.benefitsBias;
01971     Vec3                windParams.Velocity;
01978     F32                 windParams.Adaption;
01982     F32                 maxDistanceScale.Scale;
01986     Bool                maxDistanceScale.Multipliable;
01990     U64                 userData;
01997     Mat44               boneMatrices[];
02004     F32                 clothDescTemplate.collisionResponseCoefficient;
02008     U16                 clothDescTemplate.collisionGroup;
02012     U32                 clothDescTemplate.groupsMask.bits0;
02016     U32                 clothDescTemplate.groupsMask.bits1;
02020     U32                 clothDescTemplate.groupsMask.bits2;
02024     U32                 clothDescTemplate.groupsMask.bits3;
02031     Bounds3             clothDescTemplate.validBounds;
02038     U64                 clothDescTemplate.compartment;
02042     U64                 clothDescTemplate.userData;
02046     Bool                shapeDescTemplate.flags.NX_SF_VISUALIZATION;
02050     Bool                shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION;
02054     Bool                shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING;
02058     Bool                shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD;
02065     Bool                shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES;
02072     U16                 shapeDescTemplate.collisionGroup;
02076     U32                 shapeDescTemplate.groupsMask.bits0;
02080     U32                 shapeDescTemplate.groupsMask.bits1;
02084     U32                 shapeDescTemplate.groupsMask.bits2;
02088     U32                 shapeDescTemplate.groupsMask.bits3;
02092     U16                 shapeDescTemplate.materialIndex;
02096     U64                 shapeDescTemplate.userData;
02100     U64                 shapeDescTemplate.name;
02104     U64                 actorDescTemplate.userData;
02108     U64                 actorDescTemplate.name;
02112     F32                 actorScale;
02116     ClothingCookedParam runtimeCooked;
02120     Vec3                morphDisplacements[];
02124     Vec3                morphPhysicalMeshNewPositions[];
02128     Vec3                morphGraphicalMeshNewPositions[];
02132     Bool                allowAdaptiveTargetFrequency;
02136     Bool                useVelocityClamping;
02140     Bounds3             vertexVelocityClamp;
02144     F32                 pressure;
02148     Bool                multiplyGlobalPoseIntoBones;
02152     String              overrideMaterialNames[];
02156     SimulationBackend   simulationBackend;
02160     Bool                freezeByLOD;
02167     Bool                localSpaceSim;
02174     I32                 teleportMode;
02175 };
02176
02177
02521 struct ClothingAssetParameters
02522 {
02526     ClothingPhysicalMeshParameters  physicalMeshes[];
02530     ClothingGraphicalLodParameters  graphicalLods[];
02537     U32                 simulation.hierarchicalLevels;
02544     F32                 simulation.thickness;
02551     F32                 simulation.virtualParticleDensity;
02555     Vec3                simulation.gravityDirection;
02562     F32                 simulation.sleepLinearVelocity;
02569     Bool                simulation.disableCCD;
02576     Bool                simulation.untangling;
02583     Bool                simulation.twowayInteraction;
02587     F32                 simulation.restLengthScale;
02594     I32                 bones[].internalIndex;
02598     I32                 bones[].externalIndex;
02602     U32                 bones[].numMeshReferenced;
02606     U32                 bones[].numRigidBodiesReferenced;
02610     I32                 bones[].parentIndex;
02614     Mat34               bones[].bindPose;
02618     String              bones[].name;
02625     U32                 bonesReferenced;
02632     U32                 bonesReferencedByMesh;
02636     U32                 rootBoneIndex;
02640     I32                 boneActors[].boneIndex;
02644     U32                 boneActors[].convexVerticesStart;
02648     U32                 boneActors[].convexVerticesCount;
02652     F32                 boneActors[].capsuleRadius;
02656     F32                 boneActors[].capsuleHeight;
02660     Mat34               boneActors[].localPose;
02667     Vec3                boneVertices[];
02671     I32                 boneSpheres[].boneIndex;
02675     F32                 boneSpheres[].radius;
02679     Vec3                boneSpheres[].localPos;
02686     U16                 boneSphereConnections[];
02690     I32                 bonePlanes[].boneIndex;
02694     Vec3                bonePlanes[].n;
02698     F32                 bonePlanes[].d;
02702     U32                 collisionConvexes[];
02706     F32                 cookedData[].scale;
02707 union CookedData {
02711     ClothingCookedParam cookedData;
02715     ClothingCookedPhysX3Param   cookedData;
02716 };
02717 CookedData  cookedData;
02724     Bounds3             boundingBox;
02728     ClothingMaterialLibraryParameters   materialLibrary;
02732     U32                 materialIndex;
02739     U32                 interCollisionChannels;
02743     String              toolString;
02744 };
02745
02746
02778 struct ClothingCookedParam
02779 {
02783     F32                 actorScale;
02790     U8                  convexCookedData[];
02794     U32                 cookedPhysicalSubmeshes[].physicalMeshId;
02798     U32                 cookedPhysicalSubmeshes[].submeshId;
02802     U32                 cookedPhysicalSubmeshes[].cookedDataOffset;
02806     U32                 cookedPhysicalSubmeshes[].cookedDataLength;
02810     U32                 cookedPhysicalSubmeshes[].deformableInvParticleWeightsOffset;
02814     U32                 cookedPhysicalSubmeshes[].virtualParticleIndicesOffset;
02818     U32                 cookedPhysicalSubmeshes[].virtualParticleIndicesLength;
02822     U8                  deformableCookedData[];
02829     U32                 cookedDataVersion;
02833     F32                 deformableInvParticleWeights[];
02837     U32                 virtualParticleIndices[];
02841     Vec3                virtualParticleWeights[];
02842 };
02843
02844
02891 struct ClothingCookedPhysX3Param
02892 {
02896     U32                 physicalMeshId;
02900     U32                 physicalSubMeshId;
02904     U32                 numVertices;
02908     F32                 deformableRestLengths[];
02912     U32                 deformableIndices[];
02916     U32                 selfCollisionIndices[];
02920     U32                 selfCollisionNormalIndices[];
02924     U32                 selfCollisionNormalSetSizes[];
02928     U32                 deformableSets[].fiberEnd;
02932     U32                 deformableSets[].longestFiber;
02936     U32                 deformableSets[].shortestFiber;
02940     U32                 deformableSets[].numEdges;
02944     F32                 deformableSets[].avgEdgeLength;
02948     U32                 deformableSets[].avgFiberLength;
02952     U32                 deformablePhaseDescs[].phaseType;
02956     U32                 deformablePhaseDescs[].setIndex;
02960     U32                 deformablePhaseDescs[].restValueOffset;
02964     U32                 tetherAnchors[];
02968     F32                 tetherLengths[];
02972     F32                 deformableInvVertexWeights[];
02976     U32                 virtualParticleIndices[];
02980     F32                 virtualParticleWeights[];
02984     U32                 cookedDataVersion;
02988     ClothingCookedPhysX3Param   nextCookedData;
02989 };
02990
02991
03043 struct ClothingDebugRenderParams
03044 {
03048     Bool                Actors;
03052     F32                 SkinnedPositions;
03056     Bool                Backstop;
03060     F32                 BackstopPrecise;
03064     Bool                MaxDistance;
03068     Bool                MaxDistanceInwards;
03072     Bool                SkinMapAll;
03076     Bool                SkinMapBad;
03080     Bool                SkinMapActual;
03084     Bool                SkinMapInvalidBary;
03088     F32                 PhysicsMeshWire;
03092     F32                 PhysicsMeshSolid;
03096     F32                 PhysicsMeshNormals;
03100     Bool                Skeleton;
03104     F32                 BoneFrames;
03108     F32                 BoneNames;
03112     F32                 Velocities;
03116     F32                 Wind;
03120     Bool                GraphicalVertexBones;
03124     Bool                PhysicalVertexBones;
03128     Bool                CollisionShapes;
03132     Bool                CollisionShapesWire;
03136     Bool                LengthFibers;
03140     Bool                CrossSectionFibers;
03144     Bool                BendingFibers;
03148     Bool                ShearingFibers;
03152     Bool                ZerostretchFibers;
03156     Bool                TethersActive;
03160     Bool                TethersInactive;
03164     Bool                VirtualCollision;
03168     Bool                FiberRange;
03172     Bool                ShowInLocalSpace;
03176     Bool                GlobalPose;
03180     Bool                RecomputeSubmeshes;
03184     Bool                RecomputeVertices;
03188     Bool                PhysicsMeshIndices;
03192     Bool                MassScale;
03196     Bool                SelfCollision;
03200     Bool                SelfCollisionWire;
03207     F32                 SelfCollisionAttenuation;
03214     Bool                SolverMode;
03215 };
03216
03217
03345 struct ClothingGraphicalLodParameters
03346 {
03353     String              platforms[];
03360     U32                 lod;
03367     U32                 physicalMeshId;
03371     RenderMeshAssetParameters   renderMeshAsset;
03378     U32                 immediateClothMap[];
03382     Vec3                skinClothMapB[].vtxTetraBary;
03386     U32                 skinClothMapB[].vertexIndexPlusOffset;
03390     Vec3                skinClothMapB[].nrmTetraBary;
03394     U32                 skinClothMapB[].faceIndex0;
03398     U32                 skinClothMapB[].tetraIndex;
03405     U32                 skinClothMapB[].submeshIndex;
03409     Vec3                skinClothMap[].vertexBary;
03413     U32                 skinClothMap[].vertexIndex0;
03417     Vec3                skinClothMap[].normalBary;
03421     U32                 skinClothMap[].vertexIndex1;
03425     Vec3                skinClothMap[].tangentBary;
03429     U32                 skinClothMap[].vertexIndex2;
03433     U32                 skinClothMap[].vertexIndexPlusOffset;
03440     F32                 skinClothMapThickness;
03447     F32                 skinClothMapOffset;
03451     Vec3                tetraMap[].vertexBary;
03455     U32                 tetraMap[].tetraIndex0;
03459     Vec3                tetraMap[].normalBary;
03463     U32                 tetraMap[]._dummyForAlignment;
03467     U32                 renderMeshAssetSorting;
03471     U32                 physicsSubmeshPartitioning[].graphicalSubmesh;
03475     U32                 physicsSubmeshPartitioning[].physicalSubmesh;
03479     U32                 physicsSubmeshPartitioning[].numSimulatedVertices;
03483     U32                 physicsSubmeshPartitioning[].numSimulatedVerticesAdditional;
03487     U32                 physicsSubmeshPartitioning[].numSimulatedIndices;
03488 };
03489
03490
03538 struct ClothingMaterialLibraryParameters
03539 {
03543     String              materials[].materialName;
03547     F32                 materials[].verticalStretchingStiffness;
03551     F32                 materials[].horizontalStretchingStiffness;
03555     F32                 materials[].bendingStiffness;
03559     F32                 materials[].shearingStiffness;
03563     F32                 materials[].tetherStiffness;
03567     F32                 materials[].tetherLimit;
03574     Bool                materials[].orthoBending;
03581     F32                 materials[].verticalStiffnessScaling.compressionRange;
03588     F32                 materials[].verticalStiffnessScaling.stretchRange;
03592     F32                 materials[].verticalStiffnessScaling.scale;
03599     F32                 materials[].horizontalStiffnessScaling.compressionRange;
03606     F32                 materials[].horizontalStiffnessScaling.stretchRange;
03610     F32                 materials[].horizontalStiffnessScaling.scale;
03617     F32                 materials[].bendingStiffnessScaling.compressionRange;
03624     F32                 materials[].bendingStiffnessScaling.stretchRange;
03628     F32                 materials[].bendingStiffnessScaling.scale;
03635     F32                 materials[].shearingStiffnessScaling.compressionRange;
03642     F32                 materials[].shearingStiffnessScaling.stretchRange;
03646     F32                 materials[].shearingStiffnessScaling.scale;
03650     F32                 materials[].damping;
03654     F32                 materials[].stiffnessFrequency;
03661     F32                 materials[].drag;
03668     Bool                materials[].comDamping;
03675     F32                 materials[].friction;
03679     F32                 materials[].massScale;
03686     U32                 materials[].solverIterations;
03693     F32                 materials[].solverFrequency;
03700     F32                 materials[].gravityScale;
03707     F32                 materials[].inertiaScale;
03714     F32                 materials[].hardStretchLimitation;
03721     F32                 materials[].maxDistanceBias;
03725     U32                 materials[].hierarchicalSolverIterations;
03732     F32                 materials[].selfcollisionThickness;
03739     F32                 materials[].selfcollisionSquashScale;
03746     F32                 materials[].selfcollisionStiffness;
03747 };
03748
03749
03771 struct ClothingModuleParameters
03772 {
03779     U32                 maxNumCompartments;
03786     U32                 maxUnusedPhysXResources;
03793     Bool                allowAsyncCooking;
03800     Bool                asyncFetchResults;
03804     U32                 avgSimFrequencyWindow;
03811     Bool                allowApexWorkBetweenSubsteps;
03818     F32                 interCollisionDistance;
03822     F32                 interCollisionStiffness;
03826     U32                 interCollisionIterations;
03833     Bool                sparseSelfCollision;
03837     U32                 maxTimeRenderProxyInPool;
03838 };
03839
03840
03924 struct ClothingPhysicalMeshParameters
03925 {
03929     U32                 physicalMesh.numVertices;
03933     U32                 physicalMesh.numIndices;
03937     U32                 physicalMesh.numBonesPerVertex;
03941     Vec3                physicalMesh.vertices[];
03948     Vec3                physicalMesh.normals[];
03955     Vec3                physicalMesh.skinningNormals[];
03959     F32                 physicalMesh.constrainCoefficients[].maxDistance;
03963     F32                 physicalMesh.constrainCoefficients[].collisionSphereRadius;
03967     F32                 physicalMesh.constrainCoefficients[].collisionSphereDistance;
03974     U16                 physicalMesh.boneIndices[];
03981     F32                 physicalMesh.boneWeights[];
03988     U8                  physicalMesh.optimizationData[];
03992     Bool                physicalMesh.hasNegativeBackstop;
03996     Bool                physicalMesh.isClosed;
04000     U32                 physicalMesh.indices[];
04007     F32                 physicalMesh.maximumMaxDistance;
04011     U32                 physicalMesh.physicalMeshSorting;
04015     F32                 physicalMesh.shortestEdgeLength;
04019     F32                 physicalMesh.averageEdgeLength;
04023     Bool                physicalMesh.isTetrahedralMesh;
04027     Bool                physicalMesh.flipNormals;
04034     U32                 submeshes[].numIndices;
04041     U32                 submeshes[].numVertices;
04045     U32                 submeshes[].numMaxDistance0Vertices;
04049     U32                 physicalLods[].costWithoutIterations;
04053     U32                 physicalLods[].submeshId;
04057     F32                 physicalLods[].solverIterationScale;
04061     F32                 physicalLods[].maxDistanceReduction;
04065     Vec3                transitionUpB[].vtxTetraBary;
04069     U32                 transitionUpB[].vertexIndexPlusOffset;
04073     Vec3                transitionUpB[].nrmTetraBary;
04077     U32                 transitionUpB[].faceIndex0;
04081     U32                 transitionUpB[].tetraIndex;
04088     U32                 transitionUpB[].submeshIndex;
04092     Vec3                transitionUp[].vertexBary;
04096     U32                 transitionUp[].vertexIndex0;
04100     Vec3                transitionUp[].normalBary;
04104     U32                 transitionUp[].vertexIndex1;
04108     Vec3                transitionUp[].tangentBary;
04112     U32                 transitionUp[].vertexIndex2;
04116     U32                 transitionUp[].vertexIndexPlusOffset;
04120     F32                 transitionUpThickness;
04124     F32                 transitionUpOffset;
04128     Vec3                transitionDownB[].vtxTetraBary;
04132     U32                 transitionDownB[].vertexIndexPlusOffset;
04136     Vec3                transitionDownB[].nrmTetraBary;
04140     U32                 transitionDownB[].faceIndex0;
04144     U32                 transitionDownB[].tetraIndex;
04151     U32                 transitionDownB[].submeshIndex;
04155     Vec3                transitionDown[].vertexBary;
04159     U32                 transitionDown[].vertexIndex0;
04163     Vec3                transitionDown[].normalBary;
04167     U32                 transitionDown[].vertexIndex1;
04171     Vec3                transitionDown[].tangentBary;
04175     U32                 transitionDown[].vertexIndex2;
04179     U32                 transitionDown[].vertexIndexPlusOffset;
04183     F32                 transitionDownThickness;
04187     F32                 transitionDownOffset;
04191     U32                 referenceCount;
04192 };
04193
04194
04212 struct ClothingPreviewParam
04213 {
04217     Mat44               globalPose;
04224     Bool                fallbackSkinning;
04231     Bool                useInternalBoneOrder;
04238     Bool                updateStateWithGlobalMatrices;
04242     U64                 userData;
04249     Mat44               boneMatrices[];
04250 };
04251
04252
04266 struct ColorVsDensityCompositeModifierParams
04267 {
04271     F32                 controlPoints[].density;
04275     Vec4                controlPoints[].color;
04276 };
04277
04278
04293 struct ColorVsDensityModifierParams
04294 {
04298     ColorChannel        colorChannel;
04302     F32                 controlPoints[].x;
04306     F32                 controlPoints[].y;
04307 };
04308
04309
04323 struct ColorVsLifeCompositeModifierParams
04324 {
04328     F32                 controlPoints[].lifeRemaining;
04332     Vec4                controlPoints[].color;
04333 };
04334
04335
04350 struct ColorVsLifeModifierParams
04351 {
04355     ColorChannel        colorChannel;
04359     F32                 controlPoints[].x;
04363     F32                 controlPoints[].y;
04364 };
04365
04366
04380 struct ColorVsTemperatureCompositeModifierParams
04381 {
04385     F32                 controlPoints[].temperature;
04389     Vec4                controlPoints[].color;
04390 };
04391
04392
04407 struct ColorVsTemperatureModifierParams
04408 {
04412     ColorChannel        colorChannel;
04416     F32                 controlPoints[].x;
04420     F32                 controlPoints[].y;
04421 };
04422
04423
04439 struct ColorVsVelocityCompositeModifierParams
04440 {
04444     F32                 velocity0;
04448     F32                 velocity1;
04452     F32                 controlPoints[].velocity;
04456     Vec4                controlPoints[].color;
04457 };
04458
04459
04476 struct ColorVsVelocityModifierParams
04477 {
04481     ColorChannel        colorChannel;
04485     F32                 velocity0;
04489     F32                 velocity1;
04493     F32                 controlPoints[].x;
04497     F32                 controlPoints[].y;
04498 };
04499
04500
04526 struct ConvexHullParameters
04527 {
04534     Vec3                vertices[];
04541     Vec3                uniquePlanes[].normal;
04548     F32                 uniquePlanes[].d;
04555     F32                 widths[];
04562     U32                 edges[];
04569     U32                 adjacentFaces[];
04576     Bounds3             bounds;
04583     F32                 volume;
04590     U32                 uniqueEdgeDirectionCount;
04597     U32                 planeCount;
04598 };
04599
04600
04647 struct DebugColorParams
04648 {
04652     U32                 Default;
04656     U32                 PoseArrows;
04660     U32                 MeshStatic;
04664     U32                 MeshDynamic;
04668     U32                 Shape;
04672     U32                 Text0;
04676     U32                 Text1;
04680     U32                 ForceArrowsLow;
04684     U32                 ForceArrowsNorm;
04688     U32                 ForceArrowsHigh;
04692     U32                 Color0;
04696     U32                 Color1;
04700     U32                 Color2;
04704     U32                 Color3;
04708     U32                 Color4;
04712     U32                 Color5;
04716     U32                 Red;
04720     U32                 Green;
04724     U32                 Blue;
04728     U32                 DarkRed;
04732     U32                 DarkGreen;
04736     U32                 DarkBlue;
04740     U32                 LightRed;
04744     U32                 LightGreen;
04748     U32                 LightBlue;
04752     U32                 Purple;
04756     U32                 DarkPurple;
04760     U32                 Yellow;
04764     U32                 Orange;
04768     U32                 Gold;
04772     U32                 Emerald;
04776     U32                 White;
04780     U32                 Black;
04784     U32                 Gray;
04788     U32                 LightGray;
04792     U32                 DarkGray;
04793 };
04794
04795
04942 struct DebugRenderParams
04943 {
04947     Bool                Enable;
04951     F32                 Scale;
04955     F32                 LodBenefits;
04959     F32                 RelativeLodBenefitsScreenPos;
04963     F32                 RelativeLodBenefitsThickness;
04967     F32                 LodDistanceScale;
04971     F32                 RenderNormals;
04975     F32                 RenderTangents;
04979     F32                 RenderBitangents;
04983     Bool                Bounds;
04984 union ModuleName {
04988     BasicFSDebugRenderParams    moduleName[];
04992     BasicIosDebugRenderParams   moduleName[];
04996     ParticleIosDebugRenderParams    moduleName[];
05000     ClothingDebugRenderParams   moduleName[];
05004     DestructibleDebugRenderParams   moduleName[];
05008     EmitterDebugRenderParams    moduleName[];
05012     ForceFieldDebugRenderParams moduleName[];
05016     IofxDebugRenderParams   moduleName[];
05020     TurbulenceFSDebugRenderParams   moduleName[];
05024     ParticlesDebugRenderParams  moduleName[];
05025 };
05026 ModuleName  moduleName[];
05027 };
05028
05029
05052 struct DestructibleActorChunks
05053 {
05060     U8                  data[].state;
05067     U8                  data[].flags;
05074     U32                 data[].islandID;
05081     F32                 data[].damage;
05088     Vec4                data[].localSphere;
05095     Vec3                data[].localOffset;
05102     I32                 data[].visibleAncestorIndex;
05109     U32                 data[].shapesCount;
05116     Transform           data[].globalPose;
05123     Vec3                data[].linearVelocity;
05130     Vec3                data[].angularVelocity;
05131 };
05132
05133
05402 struct DestructibleActorParam
05403 {
05410     String              crumbleEmitterName;
05417     F32                 crumbleParticleSpacing;
05424     String              dustEmitterName;
05431     F32                 dustParticleSpacing;
05438     Mat34               globalPose;
05445     Vec3                scale;
05452     Bool                dynamic;
05459     U32                 supportDepth;
05466     Bool                formExtendedStructures;
05473     Bool                performDetailedOverlapTestForExtendedStructures;
05480     Bool                keepPreviousFrameBoneBuffer;
05487     Bool                doNotCreateRenderable;
05494     Bool                useAssetDefinedSupport;
05501     Bool                useWorldSupport;
05508     Bool                renderStaticChunksSeparately;
05515     Bool                keepVisibleBonesPacked;
05522     Bool                createChunkEvents;
05529     String              overrideSkinnedMaterialNames[];
05536     String              overrideStaticMaterialNames[];
05543     F32                 sleepVelocityFrameDecayConstant;
05550     Bool                useHardSleeping;
05557     F32                 destructibleParameters.damageCap;
05564     F32                 destructibleParameters.forceToDamage;
05571     F32                 destructibleParameters.impactVelocityThreshold;
05578     U32                 destructibleParameters.minimumFractureDepth;
05585     I32                 destructibleParameters.impactDamageDefaultDepth;
05592     I32                 destructibleParameters.debrisDepth;
05599     U32                 destructibleParameters.essentialDepth;
05606     F32                 destructibleParameters.debrisLifetimeMin;
05613     F32                 destructibleParameters.debrisLifetimeMax;
05620     F32                 destructibleParameters.debrisMaxSeparationMin;
05627     F32                 destructibleParameters.debrisMaxSeparationMax;
05634     F32                 destructibleParameters.debrisDestructionProbability;
05641     Bounds3             destructibleParameters.validBounds;
05648     F32                 destructibleParameters.maxChunkSpeed;
05655     Bool                destructibleParameters.flags.ACCUMULATE_DAMAGE;
05662     Bool                destructibleParameters.flags.DEBRIS_TIMEOUT;
05669     Bool                destructibleParameters.flags.DEBRIS_MAX_SEPARATION;
05676     Bool                destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS;
05683     Bool                destructibleParameters.flags.ACCURATE_RAYCASTS;
05690     Bool                destructibleParameters.flags.USE_VALID_BOUNDS;
05697     Bool                destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE;
05704     F32                 destructibleParameters.fractureImpulseScale;
05711     U16                 destructibleParameters.damageDepthLimit;
05718     U16                 destructibleParameters.dynamicChunkDominanceGroup;
05725     Bool                destructibleParameters.dynamicChunksGroupsMask.useGroupsMask;
05732     U32                 destructibleParameters.dynamicChunksGroupsMask.bits0;
05739     U32                 destructibleParameters.dynamicChunksGroupsMask.bits1;
05746     U32                 destructibleParameters.dynamicChunksGroupsMask.bits2;
05753     U32                 destructibleParameters.dynamicChunksGroupsMask.bits3;
05757     RuntimeFractureType destructibleParameters.runtimeFracture.RuntimeFractureType;
05764     Bool                destructibleParameters.runtimeFracture.sheetFracture;
05771     U32                 destructibleParameters.runtimeFracture.depthLimit;
05778     Bool                destructibleParameters.runtimeFracture.destroyIfAtDepthLimit;
05785     F32                 destructibleParameters.runtimeFracture.minConvexSize;
05792     F32                 destructibleParameters.runtimeFracture.impulseScale;
05799     U32                 destructibleParameters.runtimeFracture.glass.numSectors;
05806     F32                 destructibleParameters.runtimeFracture.glass.sectorRand;
05813     F32                 destructibleParameters.runtimeFracture.glass.firstSegmentSize;
05820     F32                 destructibleParameters.runtimeFracture.glass.segmentScale;
05827     F32                 destructibleParameters.runtimeFracture.glass.segmentRand;
05834     Vec3                destructibleParameters.runtimeFracture.voronoi.dimensions;
05841     U32                 destructibleParameters.runtimeFracture.voronoi.numCells;
05848     F32                 destructibleParameters.runtimeFracture.voronoi.biasExp;
05855     F32                 destructibleParameters.runtimeFracture.voronoi.maxDist;
05862     Bool                destructibleParameters.runtimeFracture.attachment.posX;
05869     Bool                destructibleParameters.runtimeFracture.attachment.negX;
05876     Bool                destructibleParameters.runtimeFracture.attachment.posY;
05883     Bool                destructibleParameters.runtimeFracture.attachment.negY;
05890     Bool                destructibleParameters.runtimeFracture.attachment.posZ;
05897     Bool                destructibleParameters.runtimeFracture.attachment.negZ;
05904     F32                 destructibleParameters.supportStrength;
05911     I8                  destructibleParameters.legacyChunkBoundsTestSetting;
05918     I8                  destructibleParameters.legacyDamageRadiusSpreadSetting;
05925     Bool                depthParameters[].OVERRIDE_IMPACT_DAMAGE;
05932     Bool                depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE;
05939     Bool                depthParameters[].IGNORE_POSE_UPDATES;
05946     Bool                depthParameters[].IGNORE_RAYCAST_CALLBACKS;
05953     Bool                depthParameters[].IGNORE_CONTACT_CALLBACKS;
05960     Bool                depthParameters[].USER_FLAG_0;
05967     Bool                depthParameters[].USER_FLAG_1;
05974     Bool                depthParameters[].USER_FLAG_2;
05981     Bool                depthParameters[].USER_FLAG_3;
05988     Bool                shapeDescTemplate.flags.NX_TRIGGER_ON_ENTER;
05995     Bool                shapeDescTemplate.flags.NX_TRIGGER_ON_LEAVE;
06002     Bool                shapeDescTemplate.flags.NX_TRIGGER_ON_STAY;
06009     Bool                shapeDescTemplate.flags.NX_SF_VISUALIZATION;
06016     Bool                shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION;
06023     Bool                shapeDescTemplate.flags.NX_SF_FEATURE_INDICES;
06030     Bool                shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING;
06037     Bool                shapeDescTemplate.flags.NX_SF_POINT_CONTACT_FORCE;
06044     Bool                shapeDescTemplate.flags.NX_SF_FLUID_DRAIN;
06051     Bool                shapeDescTemplate.flags.NX_SF_FLUID_DISABLE_COLLISION;
06058     Bool                shapeDescTemplate.flags.NX_SF_FLUID_TWOWAY;
06065     Bool                shapeDescTemplate.flags.NX_SF_DISABLE_RESPONSE;
06072     Bool                shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD;
06079     Bool                shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES;
06086     Bool                shapeDescTemplate.flags.NX_SF_CLOTH_DRAIN;
06093     Bool                shapeDescTemplate.flags.NX_SF_CLOTH_DISABLE_COLLISION;
06100     Bool                shapeDescTemplate.flags.NX_SF_CLOTH_TWOWAY;
06107     Bool                shapeDescTemplate.flags.NX_SF_SOFTBODY_DRAIN;
06114     Bool                shapeDescTemplate.flags.NX_SF_SOFTBODY_DISABLE_COLLISION;
06121     Bool                shapeDescTemplate.flags.NX_SF_SOFTBODY_TWOWAY;
06128     U16                 shapeDescTemplate.collisionGroup;
06135     Bool                shapeDescTemplate.groupsMask.useGroupsMask;
06142     U32                 shapeDescTemplate.groupsMask.bits0;
06149     U32                 shapeDescTemplate.groupsMask.bits1;
06156     U32                 shapeDescTemplate.groupsMask.bits2;
06163     U32                 shapeDescTemplate.groupsMask.bits3;
06170     U16                 shapeDescTemplate.materialIndex;
06177     F32                 shapeDescTemplate.density;
06184     F32                 shapeDescTemplate.skinWidth;
06191     U64                 shapeDescTemplate.userData;
06198     U64                 shapeDescTemplate.name;
06205     Bool                actorDescTemplate.flags.NX_AF_DISABLE_COLLISION;
06212     Bool                actorDescTemplate.flags.NX_AF_DISABLE_RESPONSE;
06219     Bool                actorDescTemplate.flags.NX_AF_LOCK_COM;
06226     Bool                actorDescTemplate.flags.NX_AF_FLUID_DISABLE_COLLISION;
06233     Bool                actorDescTemplate.flags.NX_AF_CONTACT_MODIFICATION;
06240     Bool                actorDescTemplate.flags.NX_AF_FORCE_CONE_FRICTION;
06247     Bool                actorDescTemplate.flags.NX_AF_USER_ACTOR_PAIR_FILTERING;
06254     F32                 actorDescTemplate.density;
06261     U16                 actorDescTemplate.actorCollisionGroup;
06268     U16                 actorDescTemplate.dominanceGroup;
06275     Bool                actorDescTemplate.contactReportFlags.NX_IGNORE_PAIR;
06282     Bool                actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH;
06289     Bool                actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH;
06296     Bool                actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH;
06303     Bool                actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_IMPACT;
06310     Bool                actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_ROLL;
06317     Bool                actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_SLIDE;
06324     Bool                actorDescTemplate.contactReportFlags.NX_NOTIFY_FORCES;
06331     Bool                actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH_FORCE_THRESHOLD;
06338     Bool                actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH_FORCE_THRESHOLD;
06345     Bool                actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH_FORCE_THRESHOLD;
06352     Bool                actorDescTemplate.contactReportFlags.NX_NOTIFY_CONTACT_MODIFICATION;
06359     U16                 actorDescTemplate.forceFieldMaterial;
06366     U64                 actorDescTemplate.userData;
06373     U64                 actorDescTemplate.name;
06380     U64                 actorDescTemplate.compartment;
06387     Bool                bodyDescTemplate.flags.NX_BF_DISABLE_GRAVITY;
06394     Bool                bodyDescTemplate.flags.NX_BF_FILTER_SLEEP_VEL;
06401     Bool                bodyDescTemplate.flags.NX_BF_ENERGY_SLEEP_TEST;
06408     Bool                bodyDescTemplate.flags.NX_BF_VISUALIZATION;
06415     F32                 bodyDescTemplate.wakeUpCounter;
06422     F32                 bodyDescTemplate.linearDamping;
06429     F32                 bodyDescTemplate.angularDamping;
06436     F32                 bodyDescTemplate.maxAngularVelocity;
06443     F32                 bodyDescTemplate.CCDMotionThreshold;
06450     F32                 bodyDescTemplate.sleepLinearVelocity;
06457     F32                 bodyDescTemplate.sleepAngularVelocity;
06464     U32                 bodyDescTemplate.solverIterationCount;
06471     F32                 bodyDescTemplate.sleepEnergyThreshold;
06478     F32                 bodyDescTemplate.sleepDamping;
06485     F32                 bodyDescTemplate.contactReportThreshold;
06489     Bool                p3ShapeDescTemplate.flags.eSIMULATION_SHAPE;
06493     Bool                p3ShapeDescTemplate.flags.eSCENE_QUERY_SHAPE;
06500     Bool                p3ShapeDescTemplate.flags.eTRIGGER_SHAPE;
06504     Bool                p3ShapeDescTemplate.flags.eVISUALIZATION;
06508     Bool                p3ShapeDescTemplate.flags.ePARTICLE_DRAIN;
06512     Bool                p3ShapeDescTemplate.flags.eDEFORMABLE_DRAIN;
06516     U32                 p3ShapeDescTemplate.simulationFilterData.word0;
06520     U32                 p3ShapeDescTemplate.simulationFilterData.word1;
06524     U32                 p3ShapeDescTemplate.simulationFilterData.word2;
06528     U32                 p3ShapeDescTemplate.simulationFilterData.word3;
06532     U32                 p3ShapeDescTemplate.queryFilterData.word0;
06536     U32                 p3ShapeDescTemplate.queryFilterData.word1;
06540     U32                 p3ShapeDescTemplate.queryFilterData.word2;
06544     U32                 p3ShapeDescTemplate.queryFilterData.word3;
06551     U64                 p3ShapeDescTemplate.material;
06558     F32                 p3ShapeDescTemplate.contactOffset;
06565     F32                 p3ShapeDescTemplate.restOffset;
06572     U64                 p3ShapeDescTemplate.userData;
06579     U64                 p3ShapeDescTemplate.name;
06586     Bool                p3ActorDescTemplate.flags.eVISUALIZATION;
06593     Bool                p3ActorDescTemplate.flags.eDISABLE_GRAVITY;
06600     Bool                p3ActorDescTemplate.flags.eSEND_SLEEP_NOTIFIES;
06607     U8                  p3ActorDescTemplate.dominanceGroup;
06614     U8                  p3ActorDescTemplate.ownerClient;
06621     U32                 p3ActorDescTemplate.clientBehaviorBits;
06628     Bool                p3ActorDescTemplate.contactReportFlags.eRESOLVE_CONTACTS;
06635     Bool                p3ActorDescTemplate.contactReportFlags.eMODIFY_CONTACTS;
06642     Bool                p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_FOUND;
06649     Bool                p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_PERSISTS;
06656     Bool                p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_LOST;
06663     Bool                p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_FOUND;
06670     Bool                p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_PERSISTS;
06677     Bool                p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_LOST;
06684     Bool                p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_POINTS;
06691     Bool                p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCES;
06698     Bool                p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCE_PER_POINT;
06705     Bool                p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FEATURE_INDICES_PER_POINT;
06712     Bool                p3ActorDescTemplate.contactReportFlags.eCCD_LINEAR;
06716     Bool                p3ActorDescTemplate.contactReportFlags.eCONTACT_DEFAULT;
06720     Bool                p3ActorDescTemplate.contactReportFlags.eTRIGGER_DEFAULT;
06727     U64                 p3ActorDescTemplate.userData;
06734     U64                 p3ActorDescTemplate.name;
06741     F32                 p3BodyDescTemplate.density;
06748     Bool                p3BodyDescTemplate.flags.eKINEMATIC;
06755     Bool                p3BodyDescTemplate.flags.eENABLE_CCD;
06762     F32                 p3BodyDescTemplate.sleepThreshold;
06769     F32                 p3BodyDescTemplate.wakeUpCounter;
06776     F32                 p3BodyDescTemplate.linearDamping;
06783     F32                 p3BodyDescTemplate.angularDamping;
06790     F32                 p3BodyDescTemplate.maxAngularVelocity;
06797     U32                 p3BodyDescTemplate.solverIterationCount;
06804     U32                 p3BodyDescTemplate.velocityIterationCount;
06811     F32                 p3BodyDescTemplate.contactReportThreshold;
06818     F32                 p3BodyDescTemplate.sleepLinearVelocity;
06825     Bool                structureSettings.useStressSolver;
06832     F32                 structureSettings.stressSolverTimeDelay;
06839     F32                 structureSettings.stressSolverMassThreshold;
06846     String              defaultBehaviorGroup.name;
06853     F32                 defaultBehaviorGroup.damageThreshold;
06860     F32                 defaultBehaviorGroup.damageToRadius;
06867     F32                 defaultBehaviorGroup.damageSpread.minimumRadius;
06874     F32                 defaultBehaviorGroup.damageSpread.radiusMultiplier;
06881     F32                 defaultBehaviorGroup.damageSpread.falloffExponent;
06888     F32                 defaultBehaviorGroup.damageColorSpread.minimumRadius;
06895     F32                 defaultBehaviorGroup.damageColorSpread.radiusMultiplier;
06902     F32                 defaultBehaviorGroup.damageColorSpread.falloffExponent;
06909     Vec4                defaultBehaviorGroup.damageColorChange;
06916     F32                 defaultBehaviorGroup.materialStrength;
06923     F32                 defaultBehaviorGroup.density;
06930     F32                 defaultBehaviorGroup.fadeOut;
06937     F32                 defaultBehaviorGroup.maxDepenetrationVelocity;
06944     Bool                defaultBehaviorGroup.groupsMask.useGroupsMask;
06951     U32                 defaultBehaviorGroup.groupsMask.bits0;
06958     U32                 defaultBehaviorGroup.groupsMask.bits1;
06965     U32                 defaultBehaviorGroup.groupsMask.bits2;
06972     U32                 defaultBehaviorGroup.groupsMask.bits3;
06979     U64                 defaultBehaviorGroup.userData;
06986     String              behaviorGroups[].name;
06993     F32                 behaviorGroups[].damageThreshold;
07000     F32                 behaviorGroups[].damageToRadius;
07007     F32                 behaviorGroups[].damageSpread.minimumRadius;
07014     F32                 behaviorGroups[].damageSpread.radiusMultiplier;
07021     F32                 behaviorGroups[].damageSpread.falloffExponent;
07028     F32                 behaviorGroups[].damageColorSpread.minimumRadius;
07035     F32                 behaviorGroups[].damageColorSpread.radiusMultiplier;
07042     F32                 behaviorGroups[].damageColorSpread.falloffExponent;
07049     Vec4                behaviorGroups[].damageColorChange;
07056     F32                 behaviorGroups[].materialStrength;
07063     F32                 behaviorGroups[].density;
07070     F32                 behaviorGroups[].fadeOut;
07077     F32                 behaviorGroups[].maxDepenetrationVelocity;
07084     Bool                behaviorGroups[].groupsMask.useGroupsMask;
07091     U32                 behaviorGroups[].groupsMask.bits0;
07098     U32                 behaviorGroups[].groupsMask.bits1;
07105     U32                 behaviorGroups[].groupsMask.bits2;
07112     U32                 behaviorGroups[].groupsMask.bits3;
07119     U64                 behaviorGroups[].userData;
07126     Bool                deleteChunksLeavingUserDefinedBB;
07133     Bool                deleteChunksEnteringUserDefinedBB;
07134 };
07135
07136
07480 struct DestructibleActorState
07481 {
07488     Bool                enableCrumbleEmitter;
07495     Bool                enableDustEmitter;
07499     F32                 internalLODWeights.maxDistance;
07503     F32                 internalLODWeights.distanceWeight;
07507     F32                 internalLODWeights.maxAge;
07511     F32                 internalLODWeights.ageWeight;
07515     F32                 internalLODWeights.bias;
07522     U32                 lod;
07529     Bool                forceLod;
07536     F32                 destructibleParameters.damageCap;
07543     F32                 destructibleParameters.forceToDamage;
07550     F32                 destructibleParameters.impactVelocityThreshold;
07557     U32                 destructibleParameters.minimumFractureDepth;
07564     I32                 destructibleParameters.impactDamageDefaultDepth;
07571     I32                 destructibleParameters.debrisDepth;
07578     U32                 destructibleParameters.essentialDepth;
07585     F32                 destructibleParameters.debrisLifetimeMin;
07592     F32                 destructibleParameters.debrisLifetimeMax;
07599     F32                 destructibleParameters.debrisMaxSeparationMin;
07606     F32                 destructibleParameters.debrisMaxSeparationMax;
07613     F32                 destructibleParameters.debrisDestructionProbability;
07620     Bounds3             destructibleParameters.validBounds;
07627     F32                 destructibleParameters.maxChunkSpeed;
07634     Bool                destructibleParameters.flags.ACCUMULATE_DAMAGE;
07641     Bool                destructibleParameters.flags.DEBRIS_TIMEOUT;
07648     Bool                destructibleParameters.flags.DEBRIS_MAX_SEPARATION;
07655     Bool                destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS;
07662     Bool                destructibleParameters.flags.ACCURATE_RAYCASTS;
07669     Bool                destructibleParameters.flags.USE_VALID_BOUNDS;
07676     Bool                destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE;
07683     F32                 destructibleParameters.fractureImpulseScale;
07690     U16                 destructibleParameters.damageDepthLimit;
07697     U16                 destructibleParameters.dynamicChunkDominanceGroup;
07704     Bool                destructibleParameters.dynamicChunksGroupsMask.useGroupsMask;
07711     U32                 destructibleParameters.dynamicChunksGroupsMask.bits0;
07718     U32                 destructibleParameters.dynamicChunksGroupsMask.bits1;
07725     U32                 destructibleParameters.dynamicChunksGroupsMask.bits2;
07732     U32                 destructibleParameters.dynamicChunksGroupsMask.bits3;
07736     RuntimeFractureType destructibleParameters.runtimeFracture.RuntimeFractureType;
07743     Bool                destructibleParameters.runtimeFracture.sheetFracture;
07750     U32                 destructibleParameters.runtimeFracture.depthLimit;
07757     Bool                destructibleParameters.runtimeFracture.destroyIfAtDepthLimit;
07764     F32                 destructibleParameters.runtimeFracture.minConvexSize;
07771     F32                 destructibleParameters.runtimeFracture.impulseScale;
07778     U32                 destructibleParameters.runtimeFracture.glass.numSectors;
07785     F32                 destructibleParameters.runtimeFracture.glass.sectorRand;
07792     F32                 destructibleParameters.runtimeFracture.glass.firstSegmentSize;
07799     F32                 destructibleParameters.runtimeFracture.glass.segmentScale;
07806     F32                 destructibleParameters.runtimeFracture.glass.segmentRand;
07813     Vec3                destructibleParameters.runtimeFracture.voronoi.dimensions;
07820     U32                 destructibleParameters.runtimeFracture.voronoi.numCells;
07827     F32                 destructibleParameters.runtimeFracture.voronoi.biasExp;
07834     F32                 destructibleParameters.runtimeFracture.voronoi.maxDist;
07841     Bool                destructibleParameters.runtimeFracture.attachment.posX;
07848     Bool                destructibleParameters.runtimeFracture.attachment.negX;
07855     Bool                destructibleParameters.runtimeFracture.attachment.posY;
07862     Bool                destructibleParameters.runtimeFracture.attachment.negY;
07869     Bool                destructibleParameters.runtimeFracture.attachment.posZ;
07876     Bool                destructibleParameters.runtimeFracture.attachment.negZ;
07883     F32                 destructibleParameters.supportStrength;
07890     I8                  destructibleParameters.legacyChunkBoundsTestSetting;
07897     I8                  destructibleParameters.legacyDamageRadiusSpreadSetting;
07904     U64                 userData;
07908     DestructibleActorParam  actorParameters;
07912     DestructibleActorChunks actorChunks;
07913 };
07914
07915
07935 struct DestructibleAssetCollisionDataSet
07936 {
07943     String              assetName;
07950     U32                 cookingPlatform;
07957     U32                 cookingVersionNum;
07964     Vec3                scales[];
07968     MeshCookedCollisionStreamsAtScale   meshCookedCollisionStreamsAtScale[];
07969 };
07970
07971
08312 struct DestructibleAssetParameters
08313 {
08320     String              comments;
08327     U32                 depthCount;
08334     U32                 originalDepthCount;
08341     Bounds3             bounds;
08348     String              defaultBehaviorGroup.name;
08355     F32                 defaultBehaviorGroup.damageThreshold;
08362     F32                 defaultBehaviorGroup.damageToRadius;
08369     F32                 defaultBehaviorGroup.damageSpread.minimumRadius;
08376     F32                 defaultBehaviorGroup.damageSpread.radiusMultiplier;
08383     F32                 defaultBehaviorGroup.damageSpread.falloffExponent;
08390     F32                 defaultBehaviorGroup.damageColorSpread.minimumRadius;
08397     F32                 defaultBehaviorGroup.damageColorSpread.radiusMultiplier;
08404     F32                 defaultBehaviorGroup.damageColorSpread.falloffExponent;
08411     Vec4                defaultBehaviorGroup.damageColorChange;
08418     F32                 defaultBehaviorGroup.materialStrength;
08425     F32                 defaultBehaviorGroup.density;
08432     F32                 defaultBehaviorGroup.fadeOut;
08439     F32                 defaultBehaviorGroup.maxDepenetrationVelocity;
08446     U64                 defaultBehaviorGroup.userData;
08453     String              behaviorGroups[].name;
08460     F32                 behaviorGroups[].damageThreshold;
08467     F32                 behaviorGroups[].damageToRadius;
08474     F32                 behaviorGroups[].damageSpread.minimumRadius;
08481     F32                 behaviorGroups[].damageSpread.radiusMultiplier;
08488     F32                 behaviorGroups[].damageSpread.falloffExponent;
08495     F32                 behaviorGroups[].damageColorSpread.minimumRadius;
08502     F32                 behaviorGroups[].damageColorSpread.radiusMultiplier;
08509     F32                 behaviorGroups[].damageColorSpread.falloffExponent;
08516     Vec4                behaviorGroups[].damageColorChange;
08523     F32                 behaviorGroups[].materialStrength;
08530     F32                 behaviorGroups[].density;
08537     F32                 behaviorGroups[].fadeOut;
08544     F32                 behaviorGroups[].maxDepenetrationVelocity;
08551     U64                 behaviorGroups[].userData;
08558     I8                  RTFractureBehaviorGroup;
08565     U16                 chunks[].depth;
08572     U16                 chunks[].parentIndex;
08579     U16                 chunks[].firstChildIndex;
08586     U16                 chunks[].numChildren;
08593     U16                 chunks[].meshPartIndex;
08600     U16                 chunks[].flags;
08607     Vec3                chunks[].surfaceNormal;
08614     I8                  chunks[].behaviorGroupIndex;
08621     U16                 chunks[].firstScatterMesh;
08628     U16                 chunks[].scatterMeshCount;
08632     ConvexHullParameters    chunkConvexHulls[];
08639     U32                 chunkConvexHullStartIndices[];
08646     F32                 destructibleParameters.damageCap;
08653     F32                 destructibleParameters.forceToDamage;
08660     F32                 destructibleParameters.impactVelocityThreshold;
08667     U32                 destructibleParameters.minimumFractureDepth;
08674     I32                 destructibleParameters.impactDamageDefaultDepth;
08681     I32                 destructibleParameters.debrisDepth;
08688     U32                 destructibleParameters.essentialDepth;
08695     F32                 destructibleParameters.debrisLifetimeMin;
08702     F32                 destructibleParameters.debrisLifetimeMax;
08709     F32                 destructibleParameters.debrisMaxSeparationMin;
08716     F32                 destructibleParameters.debrisMaxSeparationMax;
08723     F32                 destructibleParameters.debrisDestructionProbability;
08730     Bounds3             destructibleParameters.validBounds;
08737     F32                 destructibleParameters.maxChunkSpeed;
08744     Bool                destructibleParameters.flags.ACCUMULATE_DAMAGE;
08751     Bool                destructibleParameters.flags.DEBRIS_TIMEOUT;
08758     Bool                destructibleParameters.flags.DEBRIS_MAX_SEPARATION;
08765     Bool                destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS;
08772     Bool                destructibleParameters.flags.ACCURATE_RAYCASTS;
08779     Bool                destructibleParameters.flags.USE_VALID_BOUNDS;
08786     Bool                destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE;
08793     F32                 destructibleParameters.fractureImpulseScale;
08800     U16                 destructibleParameters.damageDepthLimit;
08807     U16                 destructibleParameters.dynamicChunkDominanceGroup;
08814     Bool                destructibleParameters.dynamicChunksGroupsMask.useGroupsMask;
08821     U32                 destructibleParameters.dynamicChunksGroupsMask.bits0;
08828     U32                 destructibleParameters.dynamicChunksGroupsMask.bits1;
08835     U32                 destructibleParameters.dynamicChunksGroupsMask.bits2;
08842     U32                 destructibleParameters.dynamicChunksGroupsMask.bits3;
08846     RuntimeFractureType destructibleParameters.runtimeFracture.RuntimeFractureType;
08853     Bool                destructibleParameters.runtimeFracture.sheetFracture;
08860     U32                 destructibleParameters.runtimeFracture.depthLimit;
08867     Bool                destructibleParameters.runtimeFracture.destroyIfAtDepthLimit;
08874     F32                 destructibleParameters.runtimeFracture.minConvexSize;
08881     F32                 destructibleParameters.runtimeFracture.impulseScale;
08888     U32                 destructibleParameters.runtimeFracture.glass.numSectors;
08895     F32                 destructibleParameters.runtimeFracture.glass.sectorRand;
08902     F32                 destructibleParameters.runtimeFracture.glass.firstSegmentSize;
08909     F32                 destructibleParameters.runtimeFracture.glass.segmentScale;
08916     F32                 destructibleParameters.runtimeFracture.glass.segmentRand;
08923     Vec3                destructibleParameters.runtimeFracture.voronoi.dimensions;
08930     U32                 destructibleParameters.runtimeFracture.voronoi.numCells;
08937     F32                 destructibleParameters.runtimeFracture.voronoi.biasExp;
08944     F32                 destructibleParameters.runtimeFracture.voronoi.maxDist;
08951     Bool                destructibleParameters.runtimeFracture.attachment.posX;
08958     Bool                destructibleParameters.runtimeFracture.attachment.negX;
08965     Bool                destructibleParameters.runtimeFracture.attachment.posY;
08972     Bool                destructibleParameters.runtimeFracture.attachment.negY;
08979     Bool                destructibleParameters.runtimeFracture.attachment.posZ;
08986     Bool                destructibleParameters.runtimeFracture.attachment.negZ;
08993     F32                 destructibleParameters.supportStrength;
09000     I8                  destructibleParameters.legacyChunkBoundsTestSetting;
09007     I8                  destructibleParameters.legacyDamageRadiusSpreadSetting;
09014     Bool                depthParameters[].OVERRIDE_IMPACT_DAMAGE;
09021     Bool                depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE;
09028     Bool                depthParameters[].IGNORE_POSE_UPDATES;
09035     Bool                depthParameters[].IGNORE_RAYCAST_CALLBACKS;
09042     Bool                depthParameters[].IGNORE_CONTACT_CALLBACKS;
09049     Bool                depthParameters[].USER_FLAG_0;
09056     Bool                depthParameters[].USER_FLAG_1;
09063     Bool                depthParameters[].USER_FLAG_2;
09070     Bool                depthParameters[].USER_FLAG_3;
09077     String              crumbleEmitterName;
09084     String              dustEmitterName;
09088     DestructibleAssetCollisionDataSet   collisionData;
09092     RenderMeshAssetParameters   renderMeshAsset;
09099     U32                 initialDestructibleActorAllowanceForInstancing;
09106     U16                 chunkInstanceInfo[].partIndex;
09113     Vec3                chunkInstanceInfo[].chunkPositionOffset;
09120     Vec2                chunkInstanceInfo[].chunkUVOffset;
09127     String              staticMaterialNames[];
09134     F32                 neighborPadding;
09138     CachedOverlaps      overlapsAtDepth[];
09145     U32                 firstChunkAtDepth[];
09152     U32                 supportDepth;
09159     Bool                formExtendedStructures;
09166     Bool                useAssetDefinedSupport;
09173     Bool                useWorldSupport;
09180     Mat44               actorTransforms[];
09184     RenderMeshAssetParameters   scatterMeshAssets[];
09191     U8                  scatterMeshIndices[];
09198     Mat33               scatterMeshTransforms[].matrix;
09205     Vec3                scatterMeshTransforms[].vector;
09206 };
09207
09208
09228 struct DestructibleDebugRenderParams
09229 {
09233     Bool                VISUALIZE_DESTRUCTIBLE_ACTOR;
09237     F32                 VISUALIZE_DESTRUCTIBLE_BOUNDS;
09241     F32                 VISUALIZE_DESTRUCTIBLE_SUPPORT;
09245     Bool                VISUALIZE_DESTRUCTIBLE_ACTOR_POSE;
09249     F32                 THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_POSE;
09253     Bool                VISUALIZE_DESTRUCTIBLE_ACTOR_NAME;
09257     F32                 THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_NAME;
09261     Bool                VISUALIZE_DESTRUCTIBLE_FRAGMENT_POSE;
09265     F32                 THRESHOLD_DISTANCE_DESTRUCTIBLE_FRAGMENT_POSE;
09266 };
09267
09268
09287 struct DestructibleModuleParameters
09288 {
09292     U32                 maxDynamicChunkIslandCount;
09296     Bool                sortFIFOByBenefit;
09300     F32                 validBoundsPadding;
09307     F32                 maxChunkSeparationLOD;
09311     U32                 maxActorCreatesPerFrame;
09318     U32                 maxChunkDepthOffset;
09325     F32                 massScale;
09332     F32                 scaledMassExponent;
09333 };
09334
09335
09355 struct DestructiblePreviewParam
09356 {
09363     Mat44               globalPose;
09370     U32                 chunkDepth;
09377     F32                 explodeAmount;
09384     Bool                renderUnexplodedChunksStatically;
09391     String              overrideSkinnedMaterialNames[];
09398     String              overrideStaticMaterialNames[];
09402     U64                 userData;
09403 };
09404
09405
09419 struct EffectPackageActorParams
09420 {
09424     Transform           InitialPose;
09428     F32                 objectScale;
09432     Bool                Enabled;
09433 };
09434
09435
09798 struct EffectPackageAssetParams
09799 {
09803     Bool                LODSettings.UniqueRenderVolume;
09807     F32                 LODSettings.FadeDistanceBegin;
09811     F32                 LODSettings.FadeDistanceEnd;
09815     Bool                LODSettings.RandomizeEmitterRate;
09819     F32                 LODSettings.FadeOutRate;
09823     Bool                LODSettings.CullByDistance;
09827     Bool                LODSettings.CullOffScreen;
09831     F32                 LODSettings.OffScreenCullTime;
09835     F32                 LODSettings.NonVisibleDeleteTime;
09839     F32                 LODSettings.ScreenCullSize;
09843     F32                 LODSettings.ScreenCullDistance;
09847     Bool                LODSettings.FadeEmitterRate;
09851     Bool                LODSettings.FadeAttractorFieldStrength;
09855     Bool                LODSettings.FadeJetFieldStrength;
09859     Bool                LODSettings.FadeTurbulenceVelocity;
09863     Bool                LODSettings.FadeTurbulenceNoise;
09867     Bool                LODSettings.FadeTurbulenceExternalVelocity;
09871     Bool                LODSettings.FadeTurbulenceVelocityWeight;
09875     Bool                LODSettings.FadeHeatSourceTemperature;
09879     Bool                LODSettings.FadeForceFieldStrength;
09883     Bool                LODSettings.FadeForceFieldScale;
09887     PlaybackMode        Path.PlaybackMode;
09891     F32                 Path.PathDuration;
09895     U32                 Path.LoopIndex;
09899     Transform           Path.ControlPoints[];
09903     F32                 Path.Scale[].x;
09907     F32                 Path.Scale[].y;
09911     F32                 Path.Speed[].x;
09915     F32                 Path.Speed[].y;
09916 union Effects {
09920     EmitterEffect       Effects[];
09924     HeatSourceEffect    Effects[];
09928     JetFieldSamplerEffect   Effects[];
09932     AttractorFieldSamplerEffect Effects[];
09936     TurbulenceFieldSamplerEffect    Effects[];
09940     ForceFieldEffect    Effects[];
09944     NoiseFieldSamplerEffect Effects[];
09948     VortexFieldSamplerEffect    Effects[];
09952     SubstanceSourceEffect   Effects[];
09956     WindFieldSamplerEffect  Effects[];
09960     RigidBodyEffect     Effects[];
09964     VelocitySourceEffect    Effects[];
09965 };
09966 Effects Effects[];
09967 };
09968
09969
10333 struct EffectPackageData
10334 {
10338     String              Name;
10342     EffectPackageAssetParams    EffectPackage;
10343 };
10344
10345
10710 struct EffectPackageDatabaseParams
10711 {
10715     EffectPackageData   EffectPackages[];
10716 };
10717
10718
10788 struct EffectPackageEmitterDatabaseParams
10789 {
10793     EmitterData         Emitters[];
10794 };
10795
10796
10988 struct EffectPackageFieldSamplerDatabaseParams
10989 {
10990 union FieldSamplers {
10994     AttractorFieldSamplerData   FieldSamplers[];
10998     ForceFieldData      FieldSamplers[];
11002     HeatSourceData      FieldSamplers[];
11006     JetFieldSamplerData FieldSamplers[];
11010     TurbulenceFieldSamplerData  FieldSamplers[];
11014     VortexFieldSamplerData  FieldSamplers[];
11018     NoiseFieldSamplerData   FieldSamplers[];
11022     SubstanceSourceData FieldSamplers[];
11026     WindFieldSamplerData    FieldSamplers[];
11030     VelocitySourceData  FieldSamplers[];
11031 };
11032 FieldSamplers   FieldSamplers[];
11033 };
11034
11035
11099 struct EffectPackageGraphicsMaterialsParams
11100 {
11101 union GraphicsMaterials {
11105     GraphicsMaterialData    GraphicsMaterials[];
11109     VolumeRenderMaterialData    GraphicsMaterials[];
11110 };
11111 GraphicsMaterials   GraphicsMaterials[];
11112 };
11113
11114
11274 struct EffectPackageIOFXDatabaseParams
11275 {
11279     GraphicsEffectData  GraphicsEffects[];
11280 };
11281
11282
11352 struct EffectPackageIOSDatabaseParams
11353 {
11357     ParticleSimulationData  ParticleSimulations[];
11358 };
11359
11360
11373 struct EmitterAssetPreviewParameters
11374 {
11378     Mat34               pose;
11382     F32                 scale;
11383 };
11384
11385
11454 struct EmitterData
11455 {
11459     String              Name;
11463     ApexEmitterAssetParameters  Emitter;
11464 };
11465
11466
11493 struct EmitterDebugRenderParams
11494 {
11498     Bool                apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR;
11502     Bool                apexEmitterParameters.VISUALIZE_TOTAL_INJECTED_AABB;
11506     Bool                apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_POSE;
11510     F32                 apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_POSE;
11514     Bool                apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_NAME;
11518     F32                 apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_NAME;
11522     Bool                groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR;
11526     Bool                groundEmitterParameters.VISUALIZE_GROUND_EMITTER_SPHERE;
11530     Bool                groundEmitterParameters.VISUALIZE_GROUND_EMITTER_GRID;
11534     Bool                groundEmitterParameters.VISUALIZE_GROUND_EMITTER_RAYCAST;
11538     Bool                groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_POSE;
11542     Bool                groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_NAME;
11546     Bool                impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR;
11550     Bool                impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_RAYCAST;
11554     Bool                impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR_NAME;
11558     F32                 impactEmitterParameters.THRESHOLD_DISTANCE_IMPACT_EMITTER_ACTOR_NAME;
11559 };
11560
11561
11607 struct EmitterEffect
11608 {
11612     String              EffectProperties.UserString;
11616     Bool                EffectProperties.Enable;
11620     F32                 EffectProperties.Position.TranslateX;
11624     F32                 EffectProperties.Position.TranslateY;
11628     F32                 EffectProperties.Position.TranslateZ;
11632     F32                 EffectProperties.Orientation.RotateX;
11636     F32                 EffectProperties.Orientation.RotateY;
11640     F32                 EffectProperties.Orientation.RotateZ;
11644     F32                 EffectProperties.InitialDelayTime;
11648     F32                 EffectProperties.Duration;
11652     U32                 EffectProperties.RepeatCount;
11656     F32                 EffectProperties.RepeatDelay;
11660     F32                 EffectProperties.RandomizeRepeatTime;
11664     PlaybackMode        EffectProperties.Path.PlaybackMode;
11668     F32                 EffectProperties.Path.PathDuration;
11672     U32                 EffectProperties.Path.LoopIndex;
11676     Transform           EffectProperties.Path.ControlPoints[];
11680     F32                 EffectProperties.Path.Scale[].x;
11684     F32                 EffectProperties.Path.Scale[].y;
11688     F32                 EffectProperties.Path.Speed[].x;
11692     F32                 EffectProperties.Path.Speed[].y;
11696     Bool                EmitterVelocityChanges.AdjustLifetime.AdjustEnabled;
11700     F32                 EmitterVelocityChanges.AdjustLifetime.VelocityLow;
11704     F32                 EmitterVelocityChanges.AdjustLifetime.VelocityHigh;
11708     F32                 EmitterVelocityChanges.AdjustLifetime.LowValue;
11712     F32                 EmitterVelocityChanges.AdjustLifetime.HighValue;
11716     Bool                EmitterVelocityChanges.AdjustEmitterRate.AdjustEnabled;
11720     F32                 EmitterVelocityChanges.AdjustEmitterRate.VelocityLow;
11724     F32                 EmitterVelocityChanges.AdjustEmitterRate.VelocityHigh;
11728     F32                 EmitterVelocityChanges.AdjustEmitterRate.LowValue;
11732     F32                 EmitterVelocityChanges.AdjustEmitterRate.HighValue;
11736     Ref                 Emitter;
11737 };
11738
11739
11752 struct EmitterGeomBoxParams
11753 {
11760     EmitterType         emitterType;
11764     Vec3                extents;
11765 };
11766
11767
11781 struct EmitterGeomCylinderParams
11782 {
11789     EmitterType         emitterType;
11793     F32                 radius;
11797     F32                 height;
11798 };
11799
11800
11831 struct EmitterGeomExplicitParams
11832 {
11836     F32                 distance;
11840     Vec3                points.positions[].position;
11844     Bool                points.positions[].doDetectOverlaps;
11848     Vec3                points.velocities[];
11852     Vec3                spheres.positions[].center;
11856     F32                 spheres.positions[].radius;
11860     Bool                spheres.positions[].doDetectOverlaps;
11864     Vec3                spheres.velocities[];
11868     Vec3                ellipsoids.positions[].center;
11872     F32                 ellipsoids.positions[].radius;
11876     Vec3                ellipsoids.positions[].normal;
11880     F32                 ellipsoids.positions[].polarRadius;
11884     Bool                ellipsoids.positions[].doDetectOverlaps;
11888     Vec3                ellipsoids.velocities[];
11889 };
11890
11891
11905 struct EmitterGeomSphereParams
11906 {
11913     EmitterType         emitterType;
11917     F32                 radius;
11921     F32                 hemisphere;
11922 };
11923
11924
11939 struct EmitterGeomSphereShellParams
11940 {
11947     EmitterType         emitterType;
11951     F32                 radius;
11955     F32                 shellThickness;
11959     F32                 hemisphere;
11960 };
11961
11962
11974 struct EmitterModuleParameters
11975 {
11979     U32                 unused;
11980 };
11981
11982
11994 struct FieldSamplerModuleParameters
11995 {
11999     U32                 unused;
12000 };
12001
12002
12016 struct FieldSamplerPhysXMonitorParams
12017 {
12021     U32                 maxRBCount;
12025     U32                 maxPSCount;
12029     U32                 maxParticleCount;
12030 };
12031
12045 struct FluidParticleSystemParams
12046 {
12053     F32                 restParticleDistance;
12060     F32                 stiffness;
12067     F32                 viscosity;
12068 };
12069
12070
12085 struct ForceFieldActorParams
12086 {
12090     Mat44               initialPose;
12094     F32                 scale;
12098     String              fieldBoundaryFilterDataName;
12102     String              fieldSamplerFilterDataName;
12103 };
12104
12105
12143 struct ForceFieldAssetParams
12144 {
12145 union ForceFieldKernelType {
12149     GenericForceFieldKernelParams   forceFieldKernelType;
12153     RadialForceFieldKernelParams    forceFieldKernelType;
12154 };
12155 ForceFieldKernelType    forceFieldKernelType;
12159     F32                 defScale;
12163     F32                 strength;
12167     F32                 lifetime;
12171     Shape               includeShapeParameters.shape;
12175     Mat44               includeShapeParameters.forceFieldToShape;
12179     Vec3                includeShapeParameters.dimensions;
12183     String              fieldBoundaryFilterDataName;
12187     String              fieldSamplerFilterDataName;
12188 };
12189
12190
12206 struct ForceFieldAssetPreviewParams
12207 {
12211     Mat44               pose;
12215     F32                 iconScale;
12219     Bool                drawIcon;
12223     Bool                drawBoundaries;
12227     Bool                drawBold;
12228 };
12229
12230
12269 struct ForceFieldData
12270 {
12274     String              Name;
12278     ForceFieldAssetParams   ForceField;
12279 };
12280
12281
12293 struct ForceFieldDebugRenderParams
12294 {
12298     Bool                VISUALIZE_FORCEFIELD_ACTOR;
12299 };
12300
12301
12337 struct ForceFieldEffect
12338 {
12342     String              EffectProperties.UserString;
12346     Bool                EffectProperties.Enable;
12350     F32                 EffectProperties.Position.TranslateX;
12354     F32                 EffectProperties.Position.TranslateY;
12358     F32                 EffectProperties.Position.TranslateZ;
12362     F32                 EffectProperties.Orientation.RotateX;
12366     F32                 EffectProperties.Orientation.RotateY;
12370     F32                 EffectProperties.Orientation.RotateZ;
12374     F32                 EffectProperties.InitialDelayTime;
12378     F32                 EffectProperties.Duration;
12382     U32                 EffectProperties.RepeatCount;
12386     F32                 EffectProperties.RepeatDelay;
12390     F32                 EffectProperties.RandomizeRepeatTime;
12394     PlaybackMode        EffectProperties.Path.PlaybackMode;
12398     F32                 EffectProperties.Path.PathDuration;
12402     U32                 EffectProperties.Path.LoopIndex;
12406     Transform           EffectProperties.Path.ControlPoints[];
12410     F32                 EffectProperties.Path.Scale[].x;
12414     F32                 EffectProperties.Path.Scale[].y;
12418     F32                 EffectProperties.Path.Speed[].x;
12422     F32                 EffectProperties.Path.Speed[].y;
12426     Ref                 ForceField;
12427 };
12428
12429
12444 struct ForceFieldFalloffParams
12445 {
12449     Type                type;
12453     F32                 multiplier;
12457     F32                 start;
12461     F32                 end;
12462 };
12463
12464
12476 struct ForceFieldModuleParams
12477 {
12481     U32                 unused;
12482 };
12483
12484
12499 struct ForceFieldNoiseParams
12500 {
12504     F32                 strength;
12508     F32                 spaceScale;
12512     F32                 timeScale;
12516     U32                 octaves;
12517 };
12518
12519
12540 struct GenericForceFieldKernelParams
12541 {
12545     Type                coordinateSystemParameters.type;
12549     F32                 coordinateSystemParameters.torusRadius;
12553     Vec3                constant;
12557     Mat33               positionMultiplier;
12561     Vec3                positionTarget;
12565     Mat33               velocityMultiplier;
12569     Vec3                velocityTarget;
12573     Vec3                noise;
12577     Vec3                falloffLinear;
12581     Vec3                falloffQuadratic;
12582 };
12583
12584
12743 struct GraphicsEffectData
12744 {
12748     String              Name;
12752     IofxAssetParameters IOFX;
12753 };
12754
12755
12784 struct GraphicsMaterialData
12785 {
12789     String              Name;
12793     String              ApplicationMaterialName;
12797     String              UserProperties;
12801     RenderTechnique     RenderTechnique;
12805     String              DiffuseTexture;
12809     U32                 CellColumn;
12813     U32                 CellRow;
12817     U32                 CellCount;
12821     Bool                CrossBlend;
12825     F32                 ColorMultiplier;
12829     Bool                UsePSM;
12833     Resolution          Resolution;
12837     U32                 FullResPercent;
12841     U32                 HalfResPercent;
12845     F32                 PSM_ShadowBias;
12849     Bool                PSM_Frustum.ShowFrustum;
12853     F32                 PSM_Frustum.FrustumDepth;
12857     F32                 PSM_Frustum.FrustumSize;
12858 };
12859
12860
12881 struct GroundEmitterActorParameters
12882 {
12886     F32                 densityRange.min;
12890     F32                 densityRange.max;
12897     F32                 radius;
12904     Vec3                upDirection;
12911     F32                 raycastHeight;
12918     F32                 spawnHeight;
12925     U32                 maxRaycastsPerFrame;
12932     String              raycastCollisionGroupMaskName;
12939     Vec3                attachRelativePosition;
12946     Mat34               globalPose;
12947 };
12948
12949
12984 struct GroundEmitterAssetParameters
12985 {
12989     F32                 densityRange.min;
12993     F32                 densityRange.max;
12997     Vec3                velocityRange.min;
13001     Vec3                velocityRange.max;
13005     F32                 lifetimeRange.min;
13009     F32                 lifetimeRange.max;
13016     F32                 radius;
13023     F32                 raycastHeight;
13030     F32                 spawnHeight;
13037     U32                 maxRaycastsPerFrame;
13044     String              raycastCollisionGroupMaskName;
13048     Ref                 materialFactoryMapList[].iofxAssetName;
13052     Ref                 materialFactoryMapList[].iosAssetName;
13056     String              materialFactoryMapList[].physMatName;
13060     F32                 materialFactoryMapList[].weight;
13064     F32                 materialFactoryMapList[].maxSlopeAngle;
13068     U32                 materialFactoryMapList[].lodParamDesc.version;
13072     F32                 materialFactoryMapList[].lodParamDesc.maxDistance;
13076     F32                 materialFactoryMapList[].lodParamDesc.distanceWeight;
13080     F32                 materialFactoryMapList[].lodParamDesc.speedWeight;
13084     F32                 materialFactoryMapList[].lodParamDesc.lifeWeight;
13088     F32                 materialFactoryMapList[].lodParamDesc.separationWeight;
13092     F32                 materialFactoryMapList[].lodParamDesc.bias;
13093 };
13094
13095
13113 struct HeatSourceActorParams
13114 {
13118     Mat34               initialPose;
13122     F32                 initialScale;
13126     F32                 averageTemperature;
13130     F32                 stdTemperature;
13131 union GeometryType {
13135     HeatSourceGeomBoxParams geometryType;
13139     HeatSourceGeomSphereParams  geometryType;
13140 };
13141 GeometryType    geometryType;
13145     String              fieldSamplerFilterDataName;
13146 };
13147
13148
13164 struct HeatSourceAssetParams
13165 {
13169     F32                 averageTemperature;
13173     F32                 stdTemperature;
13174 union GeometryType {
13178     HeatSourceGeomBoxParams geometryType;
13182     HeatSourceGeomSphereParams  geometryType;
13183 };
13184 GeometryType    geometryType;
13188     String              fieldSamplerFilterDataName;
13189 };
13190
13191
13208 struct HeatSourceData
13209 {
13213     String              Name;
13217     HeatSourceAssetParams   HeatSource;
13218 };
13219
13220
13256 struct HeatSourceEffect
13257 {
13261     String              EffectProperties.UserString;
13265     Bool                EffectProperties.Enable;
13269     F32                 EffectProperties.Position.TranslateX;
13273     F32                 EffectProperties.Position.TranslateY;
13277     F32                 EffectProperties.Position.TranslateZ;
13281     F32                 EffectProperties.Orientation.RotateX;
13285     F32                 EffectProperties.Orientation.RotateY;
13289     F32                 EffectProperties.Orientation.RotateZ;
13293     F32                 EffectProperties.InitialDelayTime;
13297     F32                 EffectProperties.Duration;
13301     U32                 EffectProperties.RepeatCount;
13305     F32                 EffectProperties.RepeatDelay;
13309     F32                 EffectProperties.RandomizeRepeatTime;
13313     PlaybackMode        EffectProperties.Path.PlaybackMode;
13317     F32                 EffectProperties.Path.PathDuration;
13321     U32                 EffectProperties.Path.LoopIndex;
13325     Transform           EffectProperties.Path.ControlPoints[];
13329     F32                 EffectProperties.Path.Scale[].x;
13333     F32                 EffectProperties.Path.Scale[].y;
13337     F32                 EffectProperties.Path.Speed[].x;
13341     F32                 EffectProperties.Path.Speed[].y;
13345     Ref                 HeatSource;
13346 };
13347
13348
13360 struct HeatSourceGeomBoxParams
13361 {
13365     Vec3                extents;
13366 };
13367
13368
13380 struct HeatSourceGeomSphereParams
13381 {
13385     F32                 radius;
13386 };
13387
13388
13401 struct HeatSourcePreviewParams
13402 {
13406     Mat34               pose;
13410     F32                 scale;
13411 };
13412
13413
13424 struct ImpactEmitterActorParameters
13425 {
13426 };
13427
13428
13463 struct ImpactEmitterAssetParameters
13464 {
13465 union EventSetList {
13469     ImpactObjectEvent   eventSetList[];
13473     ImpactExplosionEvent    eventSetList[];
13474 };
13475 EventSetList    eventSetList[];
13476 };
13477
13478
13493 struct ImpactExplosionEvent
13494 {
13498     String              eventSetName;
13502     Ref                 explosionAssetName;
13506     F32                 delay;
13510     F32                 duration;
13511 };
13512
13513
13543 struct ImpactObjectEvent
13544 {
13548     String              eventSetName;
13552     Ref                 iofxAssetName;
13556     Ref                 iosAssetName;
13560     F32                 angleRange.min;
13564     F32                 angleRange.max;
13568     F32                 speedRange.min;
13572     F32                 speedRange.max;
13576     F32                 lifeRange.min;
13580     F32                 lifeRange.max;
13584     F32                 delay;
13588     U32                 particleSpawnCount;
13592     ImpactAxis          impactAxis;
13596     U32                 lodParamDesc.version;
13600     F32                 lodParamDesc.maxDistance;
13604     F32                 lodParamDesc.distanceWeight;
13608     F32                 lodParamDesc.speedWeight;
13612     F32                 lodParamDesc.lifeWeight;
13616     F32                 lodParamDesc.separationWeight;
13620     F32                 lodParamDesc.bias;
13621 };
13622
13623
13635 struct InitialColorModifierParams
13636 {
13640     Vec4                color;
13641 };
13642
13643
13801 struct IofxAssetParameters
13802 {
13803 union IofxType {
13807     MeshIofxParameters  iofxType;
13811     SpriteIofxParameters    iofxType;
13812 };
13813 IofxType    iofxType;
13817     Bool                renderOutput.useUserSemantic;
13821     Bool                renderOutput.useFloat4Color;
13822 };
13823
13824
13838 struct IofxDebugRenderParams
13839 {
13843     Bool                VISUALIZE_IOFX_ACTOR;
13847     Bool                VISUALIZE_IOFX_BOUNDING_BOX;
13851     Bool                VISUALIZE_IOFX_ACTOR_NAME;
13852 };
13853
13854
13866 struct IofxModuleParameters
13867 {
13871     U32                 unused;
13872 };
13873
13874
13889 struct JetFSActorParams
13890 {
13897     Mat34               initialPose;
13901     F32                 initialScale;
13905     String              fieldBoundaryFilterDataName;
13909     String              fieldSamplerFilterDataName;
13910 };
13911
13912
13948 struct JetFSAssetParams
13949 {
13956     F32                 defaultScale;
13960     F32                 boundaryFadePercentage;
13964     Vec3                fieldDirection;
13971     F32                 fieldDirectionDeviationAngle;
13978     F32                 fieldDirectionOscillationPeriod;
13982     F32                 fieldStrength;
13989     F32                 fieldStrengthDeviationPercentage;
13996     F32                 fieldStrengthOscillationPeriod;
14000     F32                 gridShapeRadius;
14004     F32                 gridShapeHeight;
14008     F32                 gridBoundaryFadePercentage;
14012     F32                 nearRadius;
14016     F32                 pivotRadius;
14020     F32                 farRadius;
14024     F32                 directionalStretch;
14028     F32                 averageStartDistance;
14032     F32                 averageEndDistance;
14036     F32                 noisePercentage;
14040     F32                 noiseSpaceScale;
14044     F32                 noiseTimeScale;
14048     U32                 noiseOctaves;
14052     F32                 fieldDragCoeff;
14056     F32                 fieldWeight;
14060     String              fieldBoundaryFilterDataName;
14064     String              fieldSamplerFilterDataName;
14065 };
14066
14067
14082 struct JetFSPreviewParams
14083 {
14087     Mat44               globalPose;
14091     Bool                drawShape;
14095     Bool                drawAssetInfo;
14099     U64                 userData;
14100 };
14101
14102
14139 struct JetFieldSamplerData
14140 {
14144     String              Name;
14148     JetFSAssetParams    JetFieldSampler;
14149 };
14150
14151
14187 struct JetFieldSamplerEffect
14188 {
14192     String              EffectProperties.UserString;
14196     Bool                EffectProperties.Enable;
14200     F32                 EffectProperties.Position.TranslateX;
14204     F32                 EffectProperties.Position.TranslateY;
14208     F32                 EffectProperties.Position.TranslateZ;
14212     F32                 EffectProperties.Orientation.RotateX;
14216     F32                 EffectProperties.Orientation.RotateY;
14220     F32                 EffectProperties.Orientation.RotateZ;
14224     F32                 EffectProperties.InitialDelayTime;
14228     F32                 EffectProperties.Duration;
14232     U32                 EffectProperties.RepeatCount;
14236     F32                 EffectProperties.RepeatDelay;
14240     F32                 EffectProperties.RandomizeRepeatTime;
14244     PlaybackMode        EffectProperties.Path.PlaybackMode;
14248     F32                 EffectProperties.Path.PathDuration;
14252     U32                 EffectProperties.Path.LoopIndex;
14256     Transform           EffectProperties.Path.ControlPoints[];
14260     F32                 EffectProperties.Path.Scale[].x;
14264     F32                 EffectProperties.Path.Scale[].y;
14268     F32                 EffectProperties.Path.Speed[].x;
14272     F32                 EffectProperties.Path.Speed[].y;
14276     Ref                 JetFieldSampler;
14277 };
14278
14279
14292 struct MeshCookedCollisionStream
14293 {
14300     U8                  bytes[];
14301 };
14302
14303
14317 struct MeshCookedCollisionStreamsAtScale
14318 {
14322     MeshCookedCollisionStream   meshCookedCollisionStreams[];
14323 };
14324
14325
14401 struct MeshIofxParameters
14402 {
14406     Ref                 renderMeshList[].meshAssetName;
14410     U32                 renderMeshList[].weight;
14411 union SpawnModifierList {
14415     RotationModifierParams  spawnModifierList[];
14419     SimpleScaleModifierParams   spawnModifierList[];
14423     RandomScaleModifierParams   spawnModifierList[];
14427     InitialColorModifierParams  spawnModifierList[];
14431     ScaleByMassModifierParams   spawnModifierList[];
14432 };
14433 SpawnModifierList   spawnModifierList[];
14434 union ContinuousModifierList {
14438     RotationModifierParams  continuousModifierList[];
14442     ScaleVsLife3DModifierParams continuousModifierList[];
14446     ScaleVsDensity3DModifierParams  continuousModifierList[];
14450     ScaleVsTemperature3DModifierParams  continuousModifierList[];
14454     ScaleVsCameraDistance3DModifierParams   continuousModifierList[];
14458     OrientAlongVelocityModifierParams   continuousModifierList[];
14462     ScaleAlongVelocityModifierParams    continuousModifierList[];
14466     ColorVsLifeCompositeModifierParams  continuousModifierList[];
14470     ColorVsDensityCompositeModifierParams   continuousModifierList[];
14474     ColorVsTemperatureCompositeModifierParams   continuousModifierList[];
14478     ScaleVsLifeModifierParams   continuousModifierList[];
14482     ScaleVsDensityModifierParams    continuousModifierList[];
14486     ScaleVsTemperatureModifierParams    continuousModifierList[];
14490     ScaleVsCameraDistanceModifierParams continuousModifierList[];
14494     ColorVsVelocityCompositeModifierParams  continuousModifierList[];
14495 };
14496 ContinuousModifierList  continuousModifierList[];
14497 };
14498
14499
14514 struct NoiseFSActorParams
14515 {
14522     Mat34               initialPose;
14526     F32                 initialScale;
14530     String              fieldBoundaryFilterDataName;
14534     String              fieldSamplerFilterDataName;
14535 };
14536
14537
14566 struct NoiseFSAssetParams
14567 {
14574     F32                 defaultScale;
14578     Vec3                boundarySize;
14582     F32                 boundaryFadePercentage;
14586     FieldType           fieldType;
14590     F32                 fieldDragCoeff;
14594     F32                 fieldWeight;
14598     NoiseType           noiseType;
14602     U32                 noiseSeed;
14606     F32                 noiseStrength;
14610     Vec3                noiseSpacePeriod;
14614     F32                 noiseTimePeriod;
14618     U32                 noiseOctaves;
14622     F32                 noiseStrengthOctaveMultiplier;
14626     Vec3                noiseSpacePeriodOctaveMultiplier;
14630     F32                 noiseTimePeriodOctaveMultiplier;
14634     String              fieldBoundaryFilterDataName;
14638     String              fieldSamplerFilterDataName;
14642     Bool                useLocalSpace;
14643 };
14644
14645
14660 struct NoiseFSPreviewParams
14661 {
14665     Mat44               globalPose;
14669     Bool                drawShape;
14673     Bool                drawAssetInfo;
14677     U64                 userData;
14678 };
14679
14680
14710 struct NoiseFieldSamplerData
14711 {
14715     String              Name;
14719     NoiseFSAssetParams  NoiseFieldSampler;
14720 };
14721
14722
14758 struct NoiseFieldSamplerEffect
14759 {
14763     String              EffectProperties.UserString;
14767     Bool                EffectProperties.Enable;
14771     F32                 EffectProperties.Position.TranslateX;
14775     F32                 EffectProperties.Position.TranslateY;
14779     F32                 EffectProperties.Position.TranslateZ;
14783     F32                 EffectProperties.Orientation.RotateX;
14787     F32                 EffectProperties.Orientation.RotateY;
14791     F32                 EffectProperties.Orientation.RotateZ;
14795     F32                 EffectProperties.InitialDelayTime;
14799     F32                 EffectProperties.Duration;
14803     U32                 EffectProperties.RepeatCount;
14807     F32                 EffectProperties.RepeatDelay;
14811     F32                 EffectProperties.RandomizeRepeatTime;
14815     PlaybackMode        EffectProperties.Path.PlaybackMode;
14819     F32                 EffectProperties.Path.PathDuration;
14823     U32                 EffectProperties.Path.LoopIndex;
14827     Transform           EffectProperties.Path.ControlPoints[];
14831     F32                 EffectProperties.Path.Scale[].x;
14835     F32                 EffectProperties.Path.Scale[].y;
14839     F32                 EffectProperties.Path.Speed[].x;
14843     F32                 EffectProperties.Path.Speed[].y;
14847     Ref                 NoiseFieldSampler;
14848 };
14849
14850
14862 struct OrientAlongVelocityModifierParams
14863 {
14867     Vec3                modelForward;
14868 };
14869
14870
14884 struct OrientScaleAlongScreenVelocityModifierParams
14885 {
14892     F32                 scalePerVelocity;
14899     F32                 scaleChangeLimit;
14906     F32                 scaleChangeDelay;
14907 };
14908
14909
14952 struct ParticleIosAssetParam
14953 {
14954 union ParticleType {
14958     SimpleParticleSystemParams  particleType;
14962     FluidParticleSystemParams   particleType;
14963 };
14964 ParticleType    particleType;
14968     U32                 maxParticleCount;
14975     F32                 particleRadius;
14982     F32                 maxInjectedParticleCount;
14989     F32                 maxMotionDistance;
14996     F32                 contactOffset;
15003     F32                 restOffset;
15010     F32                 gridSize;
15017     F32                 damping;
15024     Vec3                externalAcceleration;
15031     Vec3                projectionPlaneNormal;
15038     F32                 projectionPlaneDistance;
15045     F32                 particleMass;
15052     F32                 restitution;
15059     F32                 dynamicFriction;
15066     F32                 staticFriction;
15073     String              simulationFilterData;
15080     String              fieldSamplerFilterData;
15087     Bool                CollisionTwoway;
15094     Bool                CollisionWithDynamicActors;
15098     Bool                Enable;
15105     Bool                ProjectToPlane;
15112     Bool                PerParticleRestOffset;
15119     Bool                PerParticleCollisionCacheHint;
15123     Bool                DensityBuffer;
15127     Bool                enableTemperatureBuffer;
15128 };
15129
15130
15143 struct ParticleIosDebugRenderParams
15144 {
15148     Bool                VISUALIZE_PARTICLE_IOS_ACTOR;
15152     Bool                VISUALIZE_PARTICLE_IOS_GRID_DENSITY;
15153 };
15154
15155
15167 struct ParticleIosModuleParameters
15168 {
15172     U32                 unused;
15173 };
15174
15175
15244 struct ParticleSimulationData
15245 {
15249     String              Name;
15250 union IOS {
15254     BasicIOSAssetParam  IOS;
15258     ParticleIosAssetParam   IOS;
15259 };
15260 IOS IOS;
15261 };
15262
15263
15276 struct ParticlesDebugRenderParams
15277 {
15281     Bool                VISUALIZE_HEAT_SOURCE_ACTOR;
15285     Bool                VISUALIZE_EFFECT_PACKAGE_ACTOR;
15286 };
15287
15288
15300 struct ParticlesModuleParameters
15301 {
15305     U32                 unused;
15306 };
15307
15308
15328 struct RadialForceFieldKernelParams
15329 {
15333     ForceFieldFalloffParams falloffParameters;
15337     ForceFieldNoiseParams   noiseParameters;
15341     F32                 radius;
15342 };
15343
15344
15357 struct RandomRotationModifierParams
15358 {
15362     F32                 minRotation;
15366     F32                 maxRotation;
15367 };
15368
15369
15382 struct RandomScaleModifierParams
15383 {
15387     F32                 minScaleFactor;
15391     F32                 maxScaleFactor;
15392 };
15393
15394
15407 struct RandomSubtextureModifierParams
15408 {
15412     F32                 minSubtexture;
15416     F32                 maxSubtexture;
15417 };
15418
15419
15512 struct RenderMeshAssetParameters
15513 {
15517     SubmeshParameters   submeshes[];
15524     String              materialNames[];
15531     Bounds3             partBounds[];
15538     U32                 textureUVOrigin;
15545     U32                 boneCount;
15552     Bool                deleteStaticBuffersAfterUse;
15556     Bool                isReferenced;
15557 };
15558
15559
15604 struct RigidBodyEffect
15605 {
15609     String              EffectProperties.UserString;
15613     Bool                EffectProperties.Enable;
15617     F32                 EffectProperties.Position.TranslateX;
15621     F32                 EffectProperties.Position.TranslateY;
15625     F32                 EffectProperties.Position.TranslateZ;
15629     F32                 EffectProperties.Orientation.RotateX;
15633     F32                 EffectProperties.Orientation.RotateY;
15637     F32                 EffectProperties.Orientation.RotateZ;
15641     F32                 EffectProperties.InitialDelayTime;
15645     F32                 EffectProperties.Duration;
15649     U32                 EffectProperties.RepeatCount;
15653     F32                 EffectProperties.RepeatDelay;
15657     F32                 EffectProperties.RandomizeRepeatTime;
15661     PlaybackMode        EffectProperties.Path.PlaybackMode;
15665     F32                 EffectProperties.Path.PathDuration;
15669     U32                 EffectProperties.Path.LoopIndex;
15673     Transform           EffectProperties.Path.ControlPoints[];
15677     F32                 EffectProperties.Path.Scale[].x;
15681     F32                 EffectProperties.Path.Scale[].y;
15685     F32                 EffectProperties.Path.Speed[].x;
15689     F32                 EffectProperties.Path.Speed[].y;
15693     Type                Type;
15697     String              CollisionFilterDataName;
15701     Bool                Dynamic;
15705     Bool                Gravity;
15709     Vec3                Extents;
15713     F32                 Mass;
15717     Vec3                InitialLinearVelocity;
15721     Vec3                InitialAngularVelocity;
15725     F32                 LinearDamping;
15729     F32                 AngularDamping;
15730 };
15731
15732
15749 struct RotationModifierParams
15750 {
15754     RollType            rollType;
15758     F32                 maxRotationRatePerSec;
15762     F32                 maxSettleRatePerSec;
15766     F32                 inAirRotationMultiplier;
15770     F32                 collisionRotationMultiplier;
15774     Bool                includeVerticalDirection;
15775 };
15776
15777
15789 struct RotationRateModifierParams
15790 {
15794     F32                 rotationRate;
15795 };
15796
15797
15811 struct RotationRateVsLifeModifierParams
15812 {
15816     F32                 controlPoints[].x;
15820     F32                 controlPoints[].y;
15821 };
15822
15823
15835 struct ScaleAlongVelocityModifierParams
15836 {
15840     F32                 scaleFactor;
15841 };
15842
15843
15854 struct ScaleByMassModifierParams
15855 {
15856 };
15857
15858
15872 struct ScaleVsCameraDistance2DModifierParams
15873 {
15877     F32                 controlPoints[].cameraDistance;
15881     Vec2                controlPoints[].scale;
15882 };
15883
15884
15898 struct ScaleVsCameraDistance3DModifierParams
15899 {
15903     F32                 controlPoints[].cameraDistance;
15907     Vec3                controlPoints[].scale;
15908 };
15909
15910
15925 struct ScaleVsCameraDistanceModifierParams
15926 {
15930     ScaleAxis           scaleAxis;
15934     F32                 controlPoints[].x;
15938     F32                 controlPoints[].y;
15939 };
15940
15941
15955 struct ScaleVsDensity2DModifierParams
15956 {
15960     F32                 controlPoints[].density;
15964     Vec2                controlPoints[].scale;
15965 };
15966
15967
15981 struct ScaleVsDensity3DModifierParams
15982 {
15986     F32                 controlPoints[].density;
15990     Vec3                controlPoints[].scale;
15991 };
15992
15993
16008 struct ScaleVsDensityModifierParams
16009 {
16013     ScaleAxis           scaleAxis;
16017     F32                 controlPoints[].x;
16021     F32                 controlPoints[].y;
16022 };
16023
16024
16038 struct ScaleVsLife2DModifierParams
16039 {
16043     F32                 controlPoints[].lifeRemaining;
16047     Vec2                controlPoints[].scale;
16048 };
16049
16050
16064 struct ScaleVsLife3DModifierParams
16065 {
16069     F32                 controlPoints[].lifeRemaining;
16073     Vec3                controlPoints[].scale;
16074 };
16075
16076
16091 struct ScaleVsLifeModifierParams
16092 {
16096     ScaleAxis           scaleAxis;
16100     F32                 controlPoints[].x;
16104     F32                 controlPoints[].y;
16105 };
16106
16107
16121 struct ScaleVsTemperature2DModifierParams
16122 {
16126     F32                 controlPoints[].temperature;
16130     Vec2                controlPoints[].scale;
16131 };
16132
16133
16147 struct ScaleVsTemperature3DModifierParams
16148 {
16152     F32                 controlPoints[].temperature;
16156     Vec3                controlPoints[].scale;
16157 };
16158
16159
16174 struct ScaleVsTemperatureModifierParams
16175 {
16179     ScaleAxis           scaleAxis;
16183     F32                 controlPoints[].x;
16187     F32                 controlPoints[].y;
16188 };
16189
16190
16205 struct SimpleParticleSystemParams
16206 {
16213     Bool                GridDensity.Enabled;
16220     Resolution          GridDensity.Resolution;
16227     F32                 GridDensity.GridSize;
16234     U32                 GridDensity.MaxCellCount;
16235 };
16236
16237
16249 struct SimpleScaleModifierParams
16250 {
16254     Vec3                scaleFactor;
16255 };
16256
16257
16348 struct SpriteIofxParameters
16349 {
16353     Ref                 spriteMaterialName;
16354 union SpawnModifierList {
16358     SimpleScaleModifierParams   spawnModifierList[];
16362     RandomScaleModifierParams   spawnModifierList[];
16366     InitialColorModifierParams  spawnModifierList[];
16370     RandomSubtextureModifierParams  spawnModifierList[];
16374     RandomRotationModifierParams    spawnModifierList[];
16378     ColorVsLifeModifierParams   spawnModifierList[];
16382     ScaleByMassModifierParams   spawnModifierList[];
16383 };
16384 SpawnModifierList   spawnModifierList[];
16385 union ContinuousModifierList {
16389     ColorVsLifeCompositeModifierParams  continuousModifierList[];
16393     ColorVsDensityCompositeModifierParams   continuousModifierList[];
16397     ColorVsTemperatureCompositeModifierParams   continuousModifierList[];
16401     ScaleVsLife2DModifierParams continuousModifierList[];
16405     ScaleVsDensity2DModifierParams  continuousModifierList[];
16409     ScaleVsTemperature2DModifierParams  continuousModifierList[];
16413     ScaleVsCameraDistance2DModifierParams   continuousModifierList[];
16417     SubtextureVsLifeModifierParams  continuousModifierList[];
16421     ViewDirectionSortingModifierParams  continuousModifierList[];
16425     ColorVsLifeModifierParams   continuousModifierList[];
16429     ColorVsDensityModifierParams    continuousModifierList[];
16433     ColorVsTemperatureModifierParams    continuousModifierList[];
16437     ScaleVsLifeModifierParams   continuousModifierList[];
16441     ScaleVsDensityModifierParams    continuousModifierList[];
16445     ScaleVsTemperatureModifierParams    continuousModifierList[];
16449     ScaleVsCameraDistanceModifierParams continuousModifierList[];
16453     RotationRateModifierParams  continuousModifierList[];
16457     RotationRateVsLifeModifierParams    continuousModifierList[];
16461     OrientScaleAlongScreenVelocityModifierParams    continuousModifierList[];
16465     ColorVsVelocityCompositeModifierParams  continuousModifierList[];
16466 };
16467 ContinuousModifierList  continuousModifierList[];
16468 };
16469
16470
16554 struct SubmeshParameters
16555 {
16559     VertexBufferParameters  vertexBuffer;
16566     U32                 indexBuffer[];
16573     U32                 vertexPartition[];
16580     U32                 indexPartition[];
16587     U32                 smoothingGroups[];
16588 };
16589
16590
16608 struct SubstanceSourceActorParams
16609 {
16613     Mat34               initialPose;
16617     F32                 initialScale;
16621     F32                 averageDensity;
16625     F32                 stdDensity;
16626 union GeometryType {
16630     HeatSourceGeomBoxParams geometryType;
16634     HeatSourceGeomSphereParams  geometryType;
16635 };
16636 GeometryType    geometryType;
16640     String              fieldSamplerFilterDataName;
16641 };
16642
16643
16660 struct SubstanceSourceAssetParams
16661 {
16665     Vec3                position;
16669     F32                 averageDensity;
16673     F32                 stdDensity;
16674 union GeometryType {
16678     HeatSourceGeomBoxParams geometryType;
16682     HeatSourceGeomSphereParams  geometryType;
16683 };
16684 GeometryType    geometryType;
16688     String              fieldSamplerFilterDataName;
16689 };
16690
16691
16709 struct SubstanceSourceData
16710 {
16714     String              Name;
16718     SubstanceSourceAssetParams  SubstanceSource;
16719 };
16720
16721
16757 struct SubstanceSourceEffect
16758 {
16762     String              EffectProperties.UserString;
16766     Bool                EffectProperties.Enable;
16770     F32                 EffectProperties.Position.TranslateX;
16774     F32                 EffectProperties.Position.TranslateY;
16778     F32                 EffectProperties.Position.TranslateZ;
16782     F32                 EffectProperties.Orientation.RotateX;
16786     F32                 EffectProperties.Orientation.RotateY;
16790     F32                 EffectProperties.Orientation.RotateZ;
16794     F32                 EffectProperties.InitialDelayTime;
16798     F32                 EffectProperties.Duration;
16802     U32                 EffectProperties.RepeatCount;
16806     F32                 EffectProperties.RepeatDelay;
16810     F32                 EffectProperties.RandomizeRepeatTime;
16814     PlaybackMode        EffectProperties.Path.PlaybackMode;
16818     F32                 EffectProperties.Path.PathDuration;
16822     U32                 EffectProperties.Path.LoopIndex;
16826     Transform           EffectProperties.Path.ControlPoints[];
16830     F32                 EffectProperties.Path.Scale[].x;
16834     F32                 EffectProperties.Path.Scale[].y;
16838     F32                 EffectProperties.Path.Speed[].x;
16842     F32                 EffectProperties.Path.Speed[].y;
16846     Ref                 SubstanceSource;
16847 };
16848
16849
16863 struct SubtextureVsLifeModifierParams
16864 {
16868     F32                 controlPoints[].x;
16872     F32                 controlPoints[].y;
16873 };
16874
16875
16943 struct SurfaceBufferParameters
16944 {
16948     U32                 width;
16952     U32                 height;
16956     U32                 surfaceFormat;
16957 union Buffer {
16961     BufferU8x1          buffer;
16965     BufferU8x2          buffer;
16969     BufferU8x3          buffer;
16973     BufferU8x4          buffer;
16977     BufferU16x1         buffer;
16981     BufferU16x2         buffer;
16985     BufferU16x3         buffer;
16989     BufferU16x4         buffer;
16993     BufferU32x1         buffer;
16997     BufferU32x2         buffer;
17001     BufferU32x3         buffer;
17005     BufferU32x4         buffer;
17009     BufferF32x1         buffer;
17013     BufferF32x2         buffer;
17017     BufferF32x3         buffer;
17021     BufferF32x4         buffer;
17022 };
17023 Buffer  buffer;
17024 };
17025
17026
17042 struct SurfaceTraceParameters
17043 {
17050     U8                  submeshIndices[];
17057     U32                 vertexIndices[];
17064     Vec3                defaultNormal;
17065 };
17066
17067
17085 struct SurfaceTraceSetParameters
17086 {
17090     SurfaceTraceParameters  traces[];
17097     Vec3                positionOffset;
17098 };
17099
17100
17121 struct TurbulenceFSActorParams
17122 {
17126     Mat34               initialPose;
17130     F32                 initialScale;
17134     Vec3                gridSizeWorld;
17138     String              collisionFilterDataName;
17142     String              fieldBoundaryFilterDataName;
17146     String              fieldSamplerFilterDataName;
17150     Bool                isAutoSwitchingBC;
17154     F32                 outletPressureBC;
17158     F32                 dragCoeffForRigidBody;
17162     F32                 fluidViscosity;
17163 };
17164
17165
17228 struct TurbulenceFSAssetParams
17229 {
17233     Min                 gridXRange.min;
17237     Max                 gridXRange.max;
17241     Min                 gridYRange.min;
17245     Max                 gridYRange.max;
17249     Min                 gridZRange.min;
17253     Max                 gridZRange.max;
17257     Vec3                gridSizeWorld;
17261     F32                 updatesPerFrameRange.min;
17265     F32                 updatesPerFrameRange.max;
17269     F32                 angularVelocityMultiplier;
17273     F32                 angularVelocityClamp;
17277     F32                 linearVelocityMultiplier;
17281     F32                 linearVelocityClamp;
17285     F32                 velocityFieldFadeTime;
17289     F32                 velocityFieldFadeDelay;
17293     F32                 velocityFieldFadeIntensity;
17297     F32                 boundaryFadePercentage;
17301     F32                 boundarySizePercentage;
17305     String              collisionFilterDataName;
17309     String              fieldBoundaryFilterDataName;
17313     String              fieldSamplerFilterDataName;
17317     U32                 maxCollidingObjects;
17321     U32                 maxVelocitySources;
17325     U32                 maxHeatSources;
17329     U32                 maxSubstanceSources;
17333     F32                 dragCoeff;
17337     Vec3                externalVelocity;
17341     F32                 fieldVelocityMultiplier;
17345     F32                 fieldVelocityWeight;
17349     Bool                useHeat;
17353     F32                 heatParams.temperatureBasedForceMultiplier;
17357     F32                 heatParams.ambientTemperature;
17361     Vec3                heatParams.heatForceDirection;
17365     F32                 heatParams.thermalConductivity;
17369     Bool                useDensity;
17373     F32                 densityParams.diffusionCoef;
17377     F32                 densityParams.densityFieldFade;
17381     U32                 densityParams.densityGridMultiplier;
17385     Bool                isEnabledOptimizedLOD;
17389     F32                 customLOD;
17393     F32                 lodWeights.maxDistance;
17397     F32                 lodWeights.distanceWeight;
17401     F32                 lodWeights.bias;
17405     F32                 lodWeights.benefitBias;
17409     F32                 lodWeights.benefitWeight;
17413     F32                 noiseParams.noiseStrength;
17417     Vec3                noiseParams.noiseSpacePeriod;
17421     F32                 noiseParams.noiseTimePeriod;
17425     U32                 noiseParams.noiseOctaves;
17429     F32                 dragCoeffForRigidBody;
17433     F32                 fluidViscosity;
17437     Ref                 volumeRenderMaterialName;
17438 };
17439
17440
17477 struct TurbulenceFSDebugRenderParams
17478 {
17482     Bool                VISUALIZE_TURBULENCE_FS_ACTOR;
17486     Bool                VISUALIZE_HEAT_SOURCE_ACTOR;
17490     Bool                VISUALIZE_SUBSTANCE_SOURCE_ACTOR;
17494     Bool                VISUALIZE_VELOCITY_SOURCE_ACTOR;
17498     Bool                VISUALIZE_TURBULENCE_FS_VELOCITY;
17502     Bool                VISUALIZE_TURBULENCE_FS_BBOX;
17506     Bool                VISUALIZE_TURBULENCE_FS_ACTOR_NAME;
17510     Bool                VISUALIZE_TURBULENCE_FS_VELOCITY_FIELD;
17514     F32                 TURBULENCE_FS_VELOCITY_FIELD_SCALE;
17518     U32                 TURBULENCE_FS_VELOCITY_FIELD_SPACING;
17522     Bool                VISUALIZE_TURBULENCE_FS_TEMPERATURE_FIELD;
17526     Bool                VISUALIZE_TURBULENCE_FS_PRESSURE_FIELD;
17530     Bool                VISUALIZE_TURBULENCE_FS_DENSITY_FIELD;
17534     F32                 TURBULENCE_FS_SCALAR_FIELD_SCALE;
17538     U32                 TURBULENCE_FS_SCALAR_FIELD_SPACING;
17542     Bool                VISUALIZE_TURBULENCE_FS_STREAMLINES;
17546     F32                 TURBULENCE_FS_STREAMLINES.tmax;
17550     F32                 TURBULENCE_FS_STREAMLINES.tstep;
17554     Vec3                TURBULENCE_FS_STREAMLINES.grid;
17558     Bool                VISUALIZE_TURBULENCE_FS_PLANE;
17562     Vec3                TURBULENCE_FS_PLANE.normal;
17566     F32                 TURBULENCE_FS_PLANE.offset;
17570     Bool                VISUALIZE_TURBULENCE_FS_GRID;
17574     Bool                VISUALIZE_TURBULENCE_FS_LOD;
17578     Bool                VISUALIZE_TURBULENCE_FS_POSE;
17582     F32                 TURBULENCE_FS_LOD;
17583 };
17584
17585
17597 struct TurbulenceFSModuleParameters
17598 {
17602     U32                 unused;
17603 };
17604
17605
17623 struct TurbulenceFSPreviewParams
17624 {
17628     Mat44               globalPose;
17632     F32                 iconScale;
17636     Bool                drawIcon;
17640     Bool                drawBox;
17644     Bool                drawGrid;
17648     Bool                drawAssetInfo;
17652     U64                 userData;
17653 };
17654
17655
17719 struct TurbulenceFieldSamplerData
17720 {
17724     String              Name;
17728     TurbulenceFSAssetParams TurbulenceFieldSampler;
17729 };
17730
17731
17767 struct TurbulenceFieldSamplerEffect
17768 {
17772     String              EffectProperties.UserString;
17776     Bool                EffectProperties.Enable;
17780     F32                 EffectProperties.Position.TranslateX;
17784     F32                 EffectProperties.Position.TranslateY;
17788     F32                 EffectProperties.Position.TranslateZ;
17792     F32                 EffectProperties.Orientation.RotateX;
17796     F32                 EffectProperties.Orientation.RotateY;
17800     F32                 EffectProperties.Orientation.RotateZ;
17804     F32                 EffectProperties.InitialDelayTime;
17808     F32                 EffectProperties.Duration;
17812     U32                 EffectProperties.RepeatCount;
17816     F32                 EffectProperties.RepeatDelay;
17820     F32                 EffectProperties.RandomizeRepeatTime;
17824     PlaybackMode        EffectProperties.Path.PlaybackMode;
17828     F32                 EffectProperties.Path.PathDuration;
17832     U32                 EffectProperties.Path.LoopIndex;
17836     Transform           EffectProperties.Path.ControlPoints[];
17840     F32                 EffectProperties.Path.Scale[].x;
17844     F32                 EffectProperties.Path.Scale[].y;
17848     F32                 EffectProperties.Path.Speed[].x;
17852     F32                 EffectProperties.Path.Speed[].y;
17856     Ref                 TurbulenceFieldSampler;
17857 };
17858
17859
17877 struct VelocitySourceActorParams
17878 {
17882     Mat34               initialPose;
17886     F32                 initialScale;
17890     F32                 averageVelocity;
17894     F32                 stdVelocity;
17895 union GeometryType {
17899     HeatSourceGeomBoxParams geometryType;
17903     HeatSourceGeomSphereParams  geometryType;
17904 };
17905 GeometryType    geometryType;
17909     String              fieldSamplerFilterDataName;
17910 };
17911
17912
17928 struct VelocitySourceAssetParams
17929 {
17933     F32                 averageVelocity;
17937     F32                 stdVelocity;
17938 union GeometryType {
17942     HeatSourceGeomBoxParams geometryType;
17946     HeatSourceGeomSphereParams  geometryType;
17947 };
17948 GeometryType    geometryType;
17952     String              fieldSamplerFilterDataName;
17953 };
17954
17955
17972 struct VelocitySourceData
17973 {
17977     String              Name;
17981     VelocitySourceAssetParams   VelocitySource;
17982 };
17983
17984
18020 struct VelocitySourceEffect
18021 {
18025     String              EffectProperties.UserString;
18029     Bool                EffectProperties.Enable;
18033     F32                 EffectProperties.Position.TranslateX;
18037     F32                 EffectProperties.Position.TranslateY;
18041     F32                 EffectProperties.Position.TranslateZ;
18045     F32                 EffectProperties.Orientation.RotateX;
18049     F32                 EffectProperties.Orientation.RotateY;
18053     F32                 EffectProperties.Orientation.RotateZ;
18057     F32                 EffectProperties.InitialDelayTime;
18061     F32                 EffectProperties.Duration;
18065     U32                 EffectProperties.RepeatCount;
18069     F32                 EffectProperties.RepeatDelay;
18073     F32                 EffectProperties.RandomizeRepeatTime;
18077     PlaybackMode        EffectProperties.Path.PlaybackMode;
18081     F32                 EffectProperties.Path.PathDuration;
18085     U32                 EffectProperties.Path.LoopIndex;
18089     Transform           EffectProperties.Path.ControlPoints[];
18093     F32                 EffectProperties.Path.Scale[].x;
18097     F32                 EffectProperties.Path.Scale[].y;
18101     F32                 EffectProperties.Path.Speed[].x;
18105     F32                 EffectProperties.Path.Speed[].y;
18109     Ref                 VelocitySource;
18110 };
18111
18112
18125 struct VelocitySourcePreviewParams
18126 {
18130     Mat34               pose;
18134     F32                 scale;
18135 };
18136
18137
18213 struct VertexBufferParameters
18214 {
18221     U32                 vertexCount;
18225     VertexFormatParameters  vertexFormat;
18226 union Buffers {
18230     BufferU8x1          buffers[];
18234     BufferU8x2          buffers[];
18238     BufferU8x3          buffers[];
18242     BufferU8x4          buffers[];
18246     BufferU16x1         buffers[];
18250     BufferU16x2         buffers[];
18254     BufferU16x3         buffers[];
18258     BufferU16x4         buffers[];
18262     BufferU32x1         buffers[];
18266     BufferU32x2         buffers[];
18270     BufferU32x3         buffers[];
18274     BufferU32x4         buffers[];
18278     BufferF32x1         buffers[];
18282     BufferF32x2         buffers[];
18286     BufferF32x3         buffers[];
18290     BufferF32x4         buffers[];
18291 };
18292 Buffers buffers[];
18293 };
18294
18295
18315 struct VertexFormatParameters
18316 {
18323     U32                 winding;
18330     Bool                hasSeparateBoneBuffer;
18337     String              bufferFormats[].name;
18344     I32                 bufferFormats[].semantic;
18351     U32                 bufferFormats[].id;
18358     U32                 bufferFormats[].format;
18365     U32                 bufferFormats[].access;
18372     Bool                bufferFormats[].serialize;
18373 };
18374
18375
18387 struct ViewDirectionSortingModifierParams
18388 {
18392     SortType            sortType;
18393 };
18394
18395
18440 struct VolumeRenderMaterialData
18441 {
18445     String              Name;
18449     String              ApplicationMaterialName;
18453     String              UserProperties;
18457     RenderMode          RenderMode;
18461     RenderMethod        RenderMethod;
18465     ResolutionScale     ResolutionScale;
18469     FillMode            FillMode;
18473     Bool                GenerateShadows;
18477     Bool                BlurShadows;
18481     Bool                GenerateMipmaps;
18485     Bool                EnableStencilOpt;
18489     F32                 StepScale;
18493     F32                 Density;
18497     F32                 EdgeFade;
18501     F32                 OpacityThreshold;
18505     F32                 RayJitter;
18509     F32                 IsoValue;
18513     F32                 IsoValueSign;
18517     U32                 ShadowSamples;
18521     F32                 ShadowDistance;
18525     F32                 ShadowDensity;
18529     F32                 ShadowJitter;
18533     F32                 ShadowAmount;
18537     Vec3                LightDir;
18541     Vec4                LightColor;
18545     F32                 BlockEmptyThreshold;
18549     Bool                ReadDepth;
18553     F32                 ColorMapScale;
18557     F32                 ColorMapOffset;
18561     F32                 ColorMap[].density;
18565     Vec4                ColorMap[].color;
18569     F32                 TextureRangeMin;
18573     F32                 TextureRangeMax;
18574 };
18575
18576
18591 struct VortexFSActorParams
18592 {
18599     Mat34               initialPose;
18603     F32                 initialScale;
18607     String              fieldBoundaryFilterDataName;
18611     String              fieldSamplerFilterDataName;
18612 };
18613
18614
18639 struct VortexFSAssetParams
18640 {
18644     F32                 boundaryFadePercentage;
18648     Vec3                axis;
18652     Bool                bottomSphericalForce;
18656     Bool                topSphericalForce;
18660     F32                 height;
18664     F32                 bottomRadius;
18668     F32                 topRadius;
18672     F32                 rotationalStrength;
18676     F32                 radialStrength;
18680     F32                 liftStrength;
18684     F32                 fieldDragCoeff;
18688     F32                 fieldWeight;
18692     String              fieldBoundaryFilterDataName;
18696     String              fieldSamplerFilterDataName;
18697 };
18698
18699
18714 struct VortexFSPreviewParams
18715 {
18719     Mat44               globalPose;
18723     Bool                drawShape;
18727     Bool                drawAssetInfo;
18731     U64                 userData;
18732 };
18733
18734
18760 struct VortexFieldSamplerData
18761 {
18765     String              Name;
18769     VortexFSAssetParams VortexFieldSampler;
18770 };
18771
18772
18808 struct VortexFieldSamplerEffect
18809 {
18813     String              EffectProperties.UserString;
18817     Bool                EffectProperties.Enable;
18821     F32                 EffectProperties.Position.TranslateX;
18825     F32                 EffectProperties.Position.TranslateY;
18829     F32                 EffectProperties.Position.TranslateZ;
18833     F32                 EffectProperties.Orientation.RotateX;
18837     F32                 EffectProperties.Orientation.RotateY;
18841     F32                 EffectProperties.Orientation.RotateZ;
18845     F32                 EffectProperties.InitialDelayTime;
18849     F32                 EffectProperties.Duration;
18853     U32                 EffectProperties.RepeatCount;
18857     F32                 EffectProperties.RepeatDelay;
18861     F32                 EffectProperties.RandomizeRepeatTime;
18865     PlaybackMode        EffectProperties.Path.PlaybackMode;
18869     F32                 EffectProperties.Path.PathDuration;
18873     U32                 EffectProperties.Path.LoopIndex;
18877     Transform           EffectProperties.Path.ControlPoints[];
18881     F32                 EffectProperties.Path.Scale[].x;
18885     F32                 EffectProperties.Path.Scale[].y;
18889     F32                 EffectProperties.Path.Speed[].x;
18893     F32                 EffectProperties.Path.Speed[].y;
18897     Ref                 VortexFieldSampler;
18898 };
18899
18900
18915 struct WindFSActorParams
18916 {
18923     Mat34               initialPose;
18927     F32                 initialScale;
18931     String              fieldBoundaryFilterDataName;
18935     String              fieldSamplerFilterDataName;
18936 };
18937
18938
18959 struct WindFSAssetParams
18960 {
18964     Vec3                fieldDirection;
18971     F32                 fieldDirectionDeviationAngle;
18978     F32                 fieldDirectionOscillationPeriod;
18982     F32                 fieldStrength;
18989     F32                 fieldStrengthDeviationPercentage;
18996     F32                 fieldStrengthOscillationPeriod;
19000     F32                 fieldDragCoeff;
19004     F32                 fieldWeight;
19008     String              fieldBoundaryFilterDataName;
19012     String              fieldSamplerFilterDataName;
19013 };
19014
19015
19029 struct WindFSPreviewParams
19030 {
19034     Mat44               globalPose;
19038     Bool                drawAssetInfo;
19042     U64                 userData;
19043 };
19044
19045
19067 struct WindFieldSamplerData
19068 {
19072     String              Name;
19076     WindFSAssetParams   WindFieldSampler;
19077 };
19078
19079
19115 struct WindFieldSamplerEffect
19116 {
19120     String              EffectProperties.UserString;
19124     Bool                EffectProperties.Enable;
19128     F32                 EffectProperties.Position.TranslateX;
19132     F32                 EffectProperties.Position.TranslateY;
19136     F32                 EffectProperties.Position.TranslateZ;
19140     F32                 EffectProperties.Orientation.RotateX;
19144     F32                 EffectProperties.Orientation.RotateY;
19148     F32                 EffectProperties.Orientation.RotateZ;
19152     F32                 EffectProperties.InitialDelayTime;
19156     F32                 EffectProperties.Duration;
19160     U32                 EffectProperties.RepeatCount;
19164     F32                 EffectProperties.RepeatDelay;
19168     F32                 EffectProperties.RandomizeRepeatTime;
19172     PlaybackMode        EffectProperties.Path.PlaybackMode;
19176     F32                 EffectProperties.Path.PathDuration;
19180     U32                 EffectProperties.Path.LoopIndex;
19184     Transform           EffectProperties.Path.ControlPoints[];
19188     F32                 EffectProperties.Path.Scale[].x;
19192     F32                 EffectProperties.Path.Scale[].y;
19196     F32                 EffectProperties.Path.Speed[].x;
19200     F32                 EffectProperties.Path.Speed[].y;
19204     Ref                 WindFieldSampler;
19205 };
19206
19207
19208
19209 #endif
Generated on Sat Dec 1 2018 10:18:54


APEX NvParameterized Schemas: ApexEmitterActorParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
ApexEmitterActorParameters Struct Reference

Describes the NxParameterized::Interface for 'ApexEmitterActorParameters' : This class is used for creating NxApexEmitterActor instances. More...

#include <params.h>

List of all members.

Public Attributes

Mat34 | initialPose
'initialPose' : The initial pose where the emitter actor will be put into the scene
F32 | initialScale
'initialScale' : The space scale of the emitter
Mat34 | attachRelativePose
'attachRelativePose' : The emitter will offset this value from the attach actor pose.
Bool | emitAssetParticles
'emitAssetParticles' : Indicates whether authored asset particle list will be emitted, defaults to true (Used only in case of EmitterGeomExplicit type)
String | overlapTestGroupMaskName
'overlapTestGroupMaskName' : Overlap Test Collision Group Mask Name
String | overlapTestGroupsMask128Name
'overlapTestGroupsMask128Name' : Overlap Test 128-bit Collision Groups Mask
F32 | emitterDuration
'emitterDuration' : Emitter duration time (in seconds)

Detailed Description

Describes the NxParameterized::Interface for 'ApexEmitterActorParameters' : This class is used for creating NxApexEmitterActor instances.

ApexEmitterActorParameters contains 7 fully qualified names
---------------------------------------------
  1 : Mat34   initialPose
  2 : F32     initialScale
  3 : Mat34   attachRelativePose
  4 : Bool    emitAssetParticles
  5 : String  overlapTestGroupMaskName
  6 : String  overlapTestGroupsMask128Name
  7 : F32     emitterDuration

Member Data Documentation

Mat34 ApexEmitterActorParameters::attachRelativePose

'attachRelativePose' : The emitter will offset this value from the attach actor pose.

Bool ApexEmitterActorParameters::emitAssetParticles

'emitAssetParticles' : Indicates whether authored asset particle list will be emitted, defaults to true (Used only in case of EmitterGeomExplicit type)

In case this emitter has EmitterGeomExplicit geometry type, it can store a particle list in its asset and also in its actor instance. So if this parameter equals to true, then both particle lists from asset and actor instance will be emitted. And if this paramater equals to false, then only particle list from actor instance will be emitterd.

F32 ApexEmitterActorParameters::emitterDuration

'emitterDuration' : Emitter duration time (in seconds)

Specifies a duration (in seconds) that the emitter will emit for after being enabled. After the specified duration, the emitter will turn off, unless it has already been explicitly turned off via an API call. The special value 0.0f means there is no duration, and the emitter will remain on until explicitly turned off.

Mat34 ApexEmitterActorParameters::initialPose

'initialPose' : The initial pose where the emitter actor will be put into the scene

F32 ApexEmitterActorParameters::initialScale

'initialScale' : The space scale of the emitter

String ApexEmitterActorParameters::overlapTestGroupMaskName

'overlapTestGroupMaskName' : Overlap Test Collision Group Mask Name

This name resolves to a 32-bit bitmask of collision groups for overlap tests when particles are spawned. It is resolved by a call to the named resource provider using the 'NSCollisionGroupMask' namespace. If none is provided, the raycast will hit everything in the scene. This avoids storing fragile enums in asset files.

String ApexEmitterActorParameters::overlapTestGroupsMask128Name

'overlapTestGroupsMask128Name' : Overlap Test 128-bit Collision Groups Mask

This name resolves to a 128-bit NxGroupsMask used for overlap tests when particles are spawned. It is resolved by a call to the named resource provider using the 'NSCollisionGroup128'

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ApexEmitterActorParameters Member List
This is the complete list of members for ApexEmitterActorParameters, including all inherited members.
attachRelativePose | ApexEmitterActorParameters
emitAssetParticles | ApexEmitterActorParameters
emitterDuration | ApexEmitterActorParameters
initialPose | ApexEmitterActorParameters
initialScale | ApexEmitterActorParameters
overlapTestGroupMaskName | ApexEmitterActorParameters
overlapTestGroupsMask128Name | ApexEmitterActorParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ApexEmitterAssetParameters Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
ApexEmitterAssetParameters Struct Reference

Describes the NxParameterized::Interface for 'ApexEmitterAssetParameters' : APEX Emitter Asset Parameters. More...

#include <params.h>

List of all members.

Classes

union | GeometryType

Public Attributes

F32 | densityRange.min
'densityRange.min' : Helpful documentation goes here
F32 | densityRange.max
'densityRange.max' : Helpful documentation goes here
F32 | rateRange.min
'rateRange.min' : Helpful documentation goes here
F32 | rateRange.max
'rateRange.max' : Helpful documentation goes here
F32 | lifetimeRange.min
'lifetimeRange.min' : Helpful documentation goes here
F32 | lifetimeRange.max
'lifetimeRange.max' : Helpful documentation goes here
Vec3 | velocityRange.min
'velocityRange.min' : Helpful documentation goes here
Vec3 | velocityRange.max
'velocityRange.max' : Helpful documentation goes here
F32 | temperatureRange.min
'temperatureRange.min' : Helpful documentation goes here
F32 | temperatureRange.max
'temperatureRange.max' : Helpful documentation goes here
U32 | maxSamples
'maxSamples' : Shaped emitter only. Max particles spawned each step.
U32 | lodParamDesc.version
'lodParamDesc.version' : Helpful documentation goes here
F32 | lodParamDesc.maxDistance
'lodParamDesc.maxDistance' : Objects greater than this distance from the player will be culled more aggressively
F32 | lodParamDesc.distanceWeight
'lodParamDesc.distanceWeight' : Weight given to distance parameter in LOD function
F32 | lodParamDesc.speedWeight
'lodParamDesc.speedWeight' : Weight given to velocity parameter in LOD function
F32 | lodParamDesc.lifeWeight
'lodParamDesc.lifeWeight' : Weight given to life remain parameter in LOD function
F32 | lodParamDesc.separationWeight
'lodParamDesc.separationWeight' : Weight given to separation parameter in LOD function
F32 | lodParamDesc.bias
'lodParamDesc.bias' : Bias given to objects spawned by this emitter, relative to other emitters in the same IOS
Ref | iofxAssetName
'iofxAssetName' : The name of the instanced object effects asset that will render particles
Ref | iosAssetName
'iosAssetName' : The asset name of the IOS and the type of IOS that will simulate particles
GeometryType geometryType
F32 | emitterDuration
'emitterDuration' : Emitter duration time (in seconds)
U32 | minSamplingFPS
'minSamplingFPS' : Defines minimum FPS at which particles are generating (0-value means no limit in FPS)
F32 | rateVsTimeCurvePoints[].x
'rateVsTimeCurvePoints[].x' : Time
F32 | rateVsTimeCurvePoints[].y
'rateVsTimeCurvePoints[].y' : Rate

Detailed Description

Describes the NxParameterized::Interface for 'ApexEmitterAssetParameters' : APEX Emitter Asset Parameters.

This class contains the parameters for the APEX Emitter asset. The APEX Emitter is sometimes described as a shaped APEX Emitter because it contains the box, sphere, and sphere shell shapes. It also includes an explicit shape that allows for preauthored particles positions and velocities and runtime particle injections.

ApexEmitterAssetParameters contains 57 fully qualified names
---------------------------------------------
  1 : F32            densityRange.min
  2 : F32            densityRange.max
  3 : F32            rateRange.min
  4 : F32            rateRange.max
  5 : F32            lifetimeRange.min
  6 : F32            lifetimeRange.max
  7 : Vec3           velocityRange.min
  8 : Vec3           velocityRange.max
  9 : F32            temperatureRange.min
 10 : F32            temperatureRange.max
 11 : U32            maxSamples
 12 : U32            lodParamDesc.version
 13 : F32            lodParamDesc.maxDistance
 14 : F32            lodParamDesc.distanceWeight
 15 : F32            lodParamDesc.speedWeight
 16 : F32            lodParamDesc.lifeWeight
 17 : F32            lodParamDesc.separationWeight
 18 : F32            lodParamDesc.bias
 19 : Ref            iofxAssetName
 20 : Ref            iosAssetName
 21 : EmitterType    geometryType.emitterType                              RefVariant[EmitterGeomBoxParams]
 22 : Vec3           geometryType.extents                                  RefVariant[EmitterGeomBoxParams]
 23 : EmitterType    geometryType.emitterType                              RefVariant[EmitterGeomSphereParams]
 24 : F32            geometryType.radius                                   RefVariant[EmitterGeomSphereParams]
 25 : F32            geometryType.hemisphere                               RefVariant[EmitterGeomSphereParams]
 26 : EmitterType    geometryType.emitterType                              RefVariant[EmitterGeomSphereShellParams]
 27 : F32            geometryType.radius                                   RefVariant[EmitterGeomSphereShellParams]
 28 : F32            geometryType.shellThickness                           RefVariant[EmitterGeomSphereShellParams]
 29 : F32            geometryType.hemisphere                               RefVariant[EmitterGeomSphereShellParams]
 30 : EmitterType    geometryType.emitterType                              RefVariant[EmitterGeomCylinderParams]
 31 : F32            geometryType.radius                                   RefVariant[EmitterGeomCylinderParams]
 32 : F32            geometryType.height                                   RefVariant[EmitterGeomCylinderParams]
 33 : F32            geometryType.distance                                 RefVariant[EmitterGeomExplicitParams]
 34 : ArraySizeName  geometryType.positions                                RefVariant[EmitterGeomExplicitParams]
 35 : Vec3           geometryType.points.positions[].position              RefVariant[EmitterGeomExplicitParams]
 36 : Bool           geometryType.points.positions[].doDetectOverlaps      RefVariant[EmitterGeomExplicitParams]
 37 : ArraySizeName  geometryType.velocities                               RefVariant[EmitterGeomExplicitParams]
 38 : Vec3           geometryType.points.velocities[]                      RefVariant[EmitterGeomExplicitParams]
 39 : ArraySizeName  geometryType.positions                                RefVariant[EmitterGeomExplicitParams]
 40 : Vec3           geometryType.spheres.positions[].center               RefVariant[EmitterGeomExplicitParams]
 41 : F32            geometryType.spheres.positions[].radius               RefVariant[EmitterGeomExplicitParams]
 42 : Bool           geometryType.spheres.positions[].doDetectOverlaps     RefVariant[EmitterGeomExplicitParams]
 43 : ArraySizeName  geometryType.velocities                               RefVariant[EmitterGeomExplicitParams]
 44 : Vec3           geometryType.spheres.velocities[]                     RefVariant[EmitterGeomExplicitParams]
 45 : ArraySizeName  geometryType.positions                                RefVariant[EmitterGeomExplicitParams]
 46 : Vec3           geometryType.ellipsoids.positions[].center            RefVariant[EmitterGeomExplicitParams]
 47 : F32            geometryType.ellipsoids.positions[].radius            RefVariant[EmitterGeomExplicitParams]
 48 : Vec3           geometryType.ellipsoids.positions[].normal            RefVariant[EmitterGeomExplicitParams]
 49 : F32            geometryType.ellipsoids.positions[].polarRadius       RefVariant[EmitterGeomExplicitParams]
 50 : Bool           geometryType.ellipsoids.positions[].doDetectOverlaps  RefVariant[EmitterGeomExplicitParams]
 51 : ArraySizeName  geometryType.velocities                               RefVariant[EmitterGeomExplicitParams]
 52 : Vec3           geometryType.ellipsoids.velocities[]                  RefVariant[EmitterGeomExplicitParams]
 53 : F32            emitterDuration
 54 : U32            minSamplingFPS
 55 : ArraySizeName  rateVsTimeCurvePoints
 56 : F32            rateVsTimeCurvePoints[].x
 57 : F32            rateVsTimeCurvePoints[].y

Member Data Documentation

F32 ApexEmitterAssetParameters::densityRange.max

'densityRange.max' : Helpful documentation goes here

F32 ApexEmitterAssetParameters::densityRange.min

'densityRange.min' : Helpful documentation goes here

F32 ApexEmitterAssetParameters::emitterDuration

'emitterDuration' : Emitter duration time (in seconds)

Specifies a duration (in seconds) that the emitter will emit for after being enabled. After the specified duration, the emitter will turn off, unless it has already been explicitly turned off via an API call. The special value 0.0f means there is no duration, and the emitter will remain on until explicitly turned off.

GeometryType ApexEmitterAssetParameters::geometryType
Ref ApexEmitterAssetParameters::iofxAssetName

'iofxAssetName' : The name of the instanced object effects asset that will render particles

Ref ApexEmitterAssetParameters::iosAssetName

'iosAssetName' : The asset name of the IOS and the type of IOS that will simulate particles

F32 ApexEmitterAssetParameters::lifetimeRange.max

'lifetimeRange.max' : Helpful documentation goes here

F32 ApexEmitterAssetParameters::lifetimeRange.min

'lifetimeRange.min' : Helpful documentation goes here

F32 ApexEmitterAssetParameters::lodParamDesc.bias

'lodParamDesc.bias' : Bias given to objects spawned by this emitter, relative to other emitters in the same IOS

F32 ApexEmitterAssetParameters::lodParamDesc.distanceWeight

'lodParamDesc.distanceWeight' : Weight given to distance parameter in LOD function

F32 ApexEmitterAssetParameters::lodParamDesc.lifeWeight

'lodParamDesc.lifeWeight' : Weight given to life remain parameter in LOD function

F32 ApexEmitterAssetParameters::lodParamDesc.maxDistance

'lodParamDesc.maxDistance' : Objects greater than this distance from the player will be culled more aggressively

F32 ApexEmitterAssetParameters::lodParamDesc.separationWeight

'lodParamDesc.separationWeight' : Weight given to separation parameter in LOD function

F32 ApexEmitterAssetParameters::lodParamDesc.speedWeight

'lodParamDesc.speedWeight' : Weight given to velocity parameter in LOD function

U32 ApexEmitterAssetParameters::lodParamDesc.version

'lodParamDesc.version' : Helpful documentation goes here

U32 ApexEmitterAssetParameters::maxSamples

'maxSamples' : Shaped emitter only. Max particles spawned each step.

For an explicit emitter, Max Samples is ignored. For shaped emitters, it is the maximum number of particles spawned in a step.

U32 ApexEmitterAssetParameters::minSamplingFPS

'minSamplingFPS' : Defines minimum FPS at which particles are generating (0-value means no limit in FPS)

It is used to reduce discontinuity in case of fast moving Emitters, by limiting particles generation step max. time by inverse of this value.

F32 ApexEmitterAssetParameters::rateRange.max

'rateRange.max' : Helpful documentation goes here

F32 ApexEmitterAssetParameters::rateRange.min

'rateRange.min' : Helpful documentation goes here

F32 ApexEmitterAssetParameters::rateVsTimeCurvePoints[].x

'rateVsTimeCurvePoints[].x' : Time

F32 ApexEmitterAssetParameters::rateVsTimeCurvePoints[].y

'rateVsTimeCurvePoints[].y' : Rate

F32 ApexEmitterAssetParameters::temperatureRange.max

'temperatureRange.max' : Helpful documentation goes here

F32 ApexEmitterAssetParameters::temperatureRange.min

'temperatureRange.min' : Helpful documentation goes here

Vec3 ApexEmitterAssetParameters::velocityRange.max

'velocityRange.max' : Helpful documentation goes here

Vec3 ApexEmitterAssetParameters::velocityRange.min

'velocityRange.min' : Helpful documentation goes here

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ApexEmitterAssetParameters Member List
This is the complete list of members for ApexEmitterAssetParameters, including all inherited members.
densityRange.max | ApexEmitterAssetParameters
densityRange.min | ApexEmitterAssetParameters
emitterDuration | ApexEmitterAssetParameters
geometryType | ApexEmitterAssetParameters
iofxAssetName | ApexEmitterAssetParameters
iosAssetName | ApexEmitterAssetParameters
lifetimeRange.max | ApexEmitterAssetParameters
lifetimeRange.min | ApexEmitterAssetParameters
lodParamDesc.bias | ApexEmitterAssetParameters
lodParamDesc.distanceWeight | ApexEmitterAssetParameters
lodParamDesc.lifeWeight | ApexEmitterAssetParameters
lodParamDesc.maxDistance | ApexEmitterAssetParameters
lodParamDesc.separationWeight | ApexEmitterAssetParameters
lodParamDesc.speedWeight | ApexEmitterAssetParameters
lodParamDesc.version | ApexEmitterAssetParameters
maxSamples | ApexEmitterAssetParameters
minSamplingFPS | ApexEmitterAssetParameters
rateRange.max | ApexEmitterAssetParameters
rateRange.min | ApexEmitterAssetParameters
rateVsTimeCurvePoints[].x | ApexEmitterAssetParameters
rateVsTimeCurvePoints[].y | ApexEmitterAssetParameters
temperatureRange.max | ApexEmitterAssetParameters
temperatureRange.min | ApexEmitterAssetParameters
velocityRange.max | ApexEmitterAssetParameters
velocityRange.min | ApexEmitterAssetParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: AttractorFieldSamplerData Struct Reference

  • Class List
  • Class Members
Public Attributes
AttractorFieldSamplerData Struct Reference

Describes the NxParameterized::Interface for 'AttractorFieldSamplerData' : Containst he asset properties for this attractor field sampler. More...

#include <params.h>

List of all members.

Public Attributes

String Name
'Name' : Attractor FS Name
AttractorFSAssetParams AttractorFieldSampler
'AttractorFieldSampler' :

Detailed Description

Describes the NxParameterized::Interface for 'AttractorFieldSamplerData' : Containst he asset properties for this attractor field sampler.

AttractorFieldSamplerData contains 9 fully qualified names
---------------------------------------------
  1 : String  Name
  2 : F32     AttractorFieldSampler.boundaryFadePercentage       RefVariant[AttractorFSAssetParams]
  3 : F32     AttractorFieldSampler.radius                       RefVariant[AttractorFSAssetParams]
  4 : F32     AttractorFieldSampler.constFieldStrength           RefVariant[AttractorFSAssetParams]
  5 : F32     AttractorFieldSampler.variableFieldStrength        RefVariant[AttractorFSAssetParams]
  6 : F32     AttractorFieldSampler.fieldDragCoeff               RefVariant[AttractorFSAssetParams]
  7 : F32     AttractorFieldSampler.fieldWeight                  RefVariant[AttractorFSAssetParams]
  8 : String  AttractorFieldSampler.fieldBoundaryFilterDataName  RefVariant[AttractorFSAssetParams]
  9 : String  AttractorFieldSampler.fieldSamplerFilterDataName   RefVariant[AttractorFSAssetParams]

Member Data Documentation

AttractorFSAssetParams AttractorFieldSamplerData::AttractorFieldSampler

'AttractorFieldSampler' :

String AttractorFieldSamplerData::Name

'Name' : Attractor FS Name

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
AttractorFieldSamplerData Member List
This is the complete list of members for AttractorFieldSamplerData, including all inherited members.
AttractorFieldSampler | AttractorFieldSamplerData
Name | AttractorFieldSamplerData
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: AttractorFieldSamplerEffect Struct Reference

  • Class List
  • Class Members
Public Attributes
AttractorFieldSamplerEffect Struct Reference

Describes the NxParameterized::Interface for 'AttractorFieldSamplerEffect' : An attractor effect. More...

#include <params.h>

List of all members.

Public Attributes

String | EffectProperties.UserString
'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer
Bool | EffectProperties.Enable
'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup
F32 | EffectProperties.Position.TranslateX
'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateY
'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateZ
'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Orientation.RotateX
'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateY
'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateZ
'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)
F32 | EffectProperties.InitialDelayTime
'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect
F32 | EffectProperties.Duration
'EffectProperties.Duration' : The duration of the effect in secontds
U32 | EffectProperties.RepeatCount
'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever
F32 | EffectProperties.RepeatDelay
'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time
F32 | EffectProperties.RandomizeRepeatTime
'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.
PlaybackMode EffectProperties.Path.PlaybackMode
'EffectProperties.Path.PlaybackMode' : The mode to play back the path
F32 | EffectProperties.Path.PathDuration
'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided
U32 | EffectProperties.Path.LoopIndex
'EffectProperties.Path.LoopIndex' : The array index to loop back to
Transform | EffectProperties.Path.ControlPoints[]
'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to
F32 | EffectProperties.Path.Scale[].x
'EffectProperties.Path.Scale[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Scale[].y
'EffectProperties.Path.Scale[].y' : The y-axis value for this vector
F32 | EffectProperties.Path.Speed[].x
'EffectProperties.Path.Speed[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Speed[].y
'EffectProperties.Path.Speed[].y' : The y-axis value for this vector
Ref | AttractorFieldSampler
'AttractorFieldSampler' : Attractor FS Asset

Detailed Description

Describes the NxParameterized::Interface for 'AttractorFieldSamplerEffect' : An attractor effect.

AttractorFieldSamplerEffect contains 25 fully qualified names
---------------------------------------------
  1 : String         EffectProperties.UserString
  2 : Bool           EffectProperties.Enable
  3 : F32            EffectProperties.Position.TranslateX
  4 : F32            EffectProperties.Position.TranslateY
  5 : F32            EffectProperties.Position.TranslateZ
  6 : F32            EffectProperties.Orientation.RotateX
  7 : F32            EffectProperties.Orientation.RotateY
  8 : F32            EffectProperties.Orientation.RotateZ
  9 : F32            EffectProperties.InitialDelayTime
 10 : F32            EffectProperties.Duration
 11 : U32            EffectProperties.RepeatCount
 12 : F32            EffectProperties.RepeatDelay
 13 : F32            EffectProperties.RandomizeRepeatTime
 14 : PlaybackMode   EffectProperties.Path.PlaybackMode
 15 : F32            EffectProperties.Path.PathDuration
 16 : U32            EffectProperties.Path.LoopIndex
 17 : ArraySizeName  ControlPoints
 18 : Transform      EffectProperties.Path.ControlPoints[]
 19 : ArraySizeName  Scale
 20 : F32            EffectProperties.Path.Scale[].x
 21 : F32            EffectProperties.Path.Scale[].y
 22 : ArraySizeName  Speed
 23 : F32            EffectProperties.Path.Speed[].x
 24 : F32            EffectProperties.Path.Speed[].y
 25 : Ref            AttractorFieldSampler

Member Data Documentation

Ref AttractorFieldSamplerEffect::AttractorFieldSampler

'AttractorFieldSampler' : Attractor FS Asset

F32 AttractorFieldSamplerEffect::EffectProperties.Duration

'EffectProperties.Duration' : The duration of the effect in secontds

Bool AttractorFieldSamplerEffect::EffectProperties.Enable

'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup

F32 AttractorFieldSamplerEffect::EffectProperties.InitialDelayTime

'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect

F32 AttractorFieldSamplerEffect::EffectProperties.Orientation.RotateX

'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)

F32 AttractorFieldSamplerEffect::EffectProperties.Orientation.RotateY

'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)

F32 AttractorFieldSamplerEffect::EffectProperties.Orientation.RotateZ

'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)

Transform AttractorFieldSamplerEffect::EffectProperties.Path.ControlPoints[]

'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to

U32 AttractorFieldSamplerEffect::EffectProperties.Path.LoopIndex

'EffectProperties.Path.LoopIndex' : The array index to loop back to

F32 AttractorFieldSamplerEffect::EffectProperties.Path.PathDuration

'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided

PlaybackMode AttractorFieldSamplerEffect::EffectProperties.Path.PlaybackMode

'EffectProperties.Path.PlaybackMode' : The mode to play back the path

F32 AttractorFieldSamplerEffect::EffectProperties.Path.Scale[].x

'EffectProperties.Path.Scale[].x' : The x-axis value for this vector

F32 AttractorFieldSamplerEffect::EffectProperties.Path.Scale[].y

'EffectProperties.Path.Scale[].y' : The y-axis value for this vector

F32 AttractorFieldSamplerEffect::EffectProperties.Path.Speed[].x

'EffectProperties.Path.Speed[].x' : The x-axis value for this vector

F32 AttractorFieldSamplerEffect::EffectProperties.Path.Speed[].y

'EffectProperties.Path.Speed[].y' : The y-axis value for this vector

F32 AttractorFieldSamplerEffect::EffectProperties.Position.TranslateX

'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction

F32 AttractorFieldSamplerEffect::EffectProperties.Position.TranslateY

'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction

F32 AttractorFieldSamplerEffect::EffectProperties.Position.TranslateZ

'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction

F32 AttractorFieldSamplerEffect::EffectProperties.RandomizeRepeatTime

'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.

U32 AttractorFieldSamplerEffect::EffectProperties.RepeatCount

'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever

F32 AttractorFieldSamplerEffect::EffectProperties.RepeatDelay

'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time

String AttractorFieldSamplerEffect::EffectProperties.UserString

'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
AttractorFieldSamplerEffect Member List
This is the complete list of members for AttractorFieldSamplerEffect, including all inherited members.
AttractorFieldSampler | AttractorFieldSamplerEffect
EffectProperties.Duration | AttractorFieldSamplerEffect
EffectProperties.Enable | AttractorFieldSamplerEffect
EffectProperties.InitialDelayTime | AttractorFieldSamplerEffect
EffectProperties.Orientation.RotateX | AttractorFieldSamplerEffect
EffectProperties.Orientation.RotateY | AttractorFieldSamplerEffect
EffectProperties.Orientation.RotateZ | AttractorFieldSamplerEffect
EffectProperties.Path.ControlPoints[] | AttractorFieldSamplerEffect
EffectProperties.Path.LoopIndex | AttractorFieldSamplerEffect
EffectProperties.Path.PathDuration | AttractorFieldSamplerEffect
EffectProperties.Path.PlaybackMode | AttractorFieldSamplerEffect
EffectProperties.Path.Scale[].x | AttractorFieldSamplerEffect
EffectProperties.Path.Scale[].y | AttractorFieldSamplerEffect
EffectProperties.Path.Speed[].x | AttractorFieldSamplerEffect
EffectProperties.Path.Speed[].y | AttractorFieldSamplerEffect
EffectProperties.Position.TranslateX | AttractorFieldSamplerEffect
EffectProperties.Position.TranslateY | AttractorFieldSamplerEffect
EffectProperties.Position.TranslateZ | AttractorFieldSamplerEffect
EffectProperties.RandomizeRepeatTime | AttractorFieldSamplerEffect
EffectProperties.RepeatCount | AttractorFieldSamplerEffect
EffectProperties.RepeatDelay | AttractorFieldSamplerEffect
EffectProperties.UserString | AttractorFieldSamplerEffect
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: AttractorFSActorParams Struct Reference

  • Class List
  • Class Members
Public Attributes
AttractorFSActorParams Struct Reference

Describes the NxParameterized::Interface for 'AttractorFSActorParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat34 | initialPose
'initialPose' : The initial pose of the actor.
F32 | initialScale
'initialScale' : The initial space scale of the actor
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for AttractorFS vs Field Boundaries interaction. Overrides asset's value.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for AttractorFS vs other Field Samplers interaction. Overrides asset's value.

Detailed Description

Describes the NxParameterized::Interface for 'AttractorFSActorParams' :

AttractorFSActorParams contains 4 fully qualified names
---------------------------------------------
  1 : Mat34   initialPose
  2 : F32     initialScale
  3 : String  fieldBoundaryFilterDataName
  4 : String  fieldSamplerFilterDataName

Member Data Documentation

String AttractorFSActorParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for AttractorFS vs Field Boundaries interaction. Overrides asset's value.

String AttractorFSActorParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for AttractorFS vs other Field Samplers interaction. Overrides asset's value.

Mat34 AttractorFSActorParams::initialPose

'initialPose' : The initial pose of the actor.

The initial pose of the actor. This includes both translation and rotation.

F32 AttractorFSActorParams::initialScale

'initialScale' : The initial space scale of the actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
AttractorFSActorParams Member List
This is the complete list of members for AttractorFSActorParams, including all inherited members.
fieldBoundaryFilterDataName | AttractorFSActorParams
fieldSamplerFilterDataName | AttractorFSActorParams
initialPose | AttractorFSActorParams
initialScale | AttractorFSActorParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: AttractorFSAssetParams Struct Reference

  • Class List
  • Class Members
Public Attributes
AttractorFSAssetParams Struct Reference

Describes the NxParameterized::Interface for 'AttractorFSAssetParams' : Contains the asset properties for this Attractor Field Sampler. More...

#include <params.h>

List of all members.

Public Attributes

F32 | boundaryFadePercentage
'boundaryFadePercentage' : Percentage of distance from boundary to center where fade out starts.
F32 | radius
'radius' : Radius of the sphere where attracting force is acting.
F32 | constFieldStrength
'constFieldStrength' : Coefficient that sets strength of the constant part of attracting force.
F32 | variableFieldStrength
'variableFieldStrength' : Coefficient that sets strength of the variable part of attracting force.
F32 | fieldDragCoeff
'fieldDragCoeff' : Field drag coefficient. When it equals to 0, then the field is applied as a direct velocity.
F32 | fieldWeight
'fieldWeight' : A weight for the field, it controls how strongly the field affects particles
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for AttractorFS vs Field Boundaries interaction.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for AttractorFS vs other Field Samplers interaction.

Detailed Description

Describes the NxParameterized::Interface for 'AttractorFSAssetParams' : Contains the asset properties for this Attractor Field Sampler.

AttractorFSAssetParams contains 8 fully qualified names
---------------------------------------------
  1 : F32     boundaryFadePercentage
  2 : F32     radius
  3 : F32     constFieldStrength
  4 : F32     variableFieldStrength
  5 : F32     fieldDragCoeff
  6 : F32     fieldWeight
  7 : String  fieldBoundaryFilterDataName
  8 : String  fieldSamplerFilterDataName

Member Data Documentation

F32 AttractorFSAssetParams::boundaryFadePercentage

'boundaryFadePercentage' : Percentage of distance from boundary to center where fade out starts.

F32 AttractorFSAssetParams::constFieldStrength

'constFieldStrength' : Coefficient that sets strength of the constant part of attracting force.

String AttractorFSAssetParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for AttractorFS vs Field Boundaries interaction.

F32 AttractorFSAssetParams::fieldDragCoeff

'fieldDragCoeff' : Field drag coefficient. When it equals to 0, then the field is applied as a direct velocity.

String AttractorFSAssetParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for AttractorFS vs other Field Samplers interaction.

F32 AttractorFSAssetParams::fieldWeight

'fieldWeight' : A weight for the field, it controls how strongly the field affects particles

F32 AttractorFSAssetParams::radius

'radius' : Radius of the sphere where attracting force is acting.

F32 AttractorFSAssetParams::variableFieldStrength

'variableFieldStrength' : Coefficient that sets strength of the variable part of attracting force.

Variable part of the force is proportional to this coefficient and inverse proportional to distance from the senter of attractor.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
AttractorFSAssetParams Member List
This is the complete list of members for AttractorFSAssetParams, including all inherited members.
boundaryFadePercentage | AttractorFSAssetParams
constFieldStrength | AttractorFSAssetParams
fieldBoundaryFilterDataName | AttractorFSAssetParams
fieldDragCoeff | AttractorFSAssetParams
fieldSamplerFilterDataName | AttractorFSAssetParams
fieldWeight | AttractorFSAssetParams
radius | AttractorFSAssetParams
variableFieldStrength | AttractorFSAssetParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: AttractorFSPreviewParams Struct Reference

  • Class List
  • Class Members
Public Attributes
AttractorFSPreviewParams Struct Reference

Describes the NxParameterized::Interface for 'AttractorFSPreviewParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat44 | globalPose
'globalPose' : The pose that translates from turbulence preview coordinates to world coordinates
Bool | drawShape
'drawShape' : Draw the box
Bool | drawAssetInfo
'drawAssetInfo' : Display asset info
U64 | userData
'userData' : Optional user data pointer associated with the attractor actor

Detailed Description

Describes the NxParameterized::Interface for 'AttractorFSPreviewParams' :

AttractorFSPreviewParams contains 4 fully qualified names
---------------------------------------------
  1 : Mat44  globalPose
  2 : Bool   drawShape
  3 : Bool   drawAssetInfo
  4 : U64    userData

Member Data Documentation

Bool AttractorFSPreviewParams::drawAssetInfo

'drawAssetInfo' : Display asset info

Bool AttractorFSPreviewParams::drawShape

'drawShape' : Draw the box

Mat44 AttractorFSPreviewParams::globalPose

'globalPose' : The pose that translates from turbulence preview coordinates to world coordinates

U64 AttractorFSPreviewParams::userData

'userData' : Optional user data pointer associated with the attractor actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
AttractorFSPreviewParams Member List
This is the complete list of members for AttractorFSPreviewParams, including all inherited members.
drawAssetInfo | AttractorFSPreviewParams
drawShape | AttractorFSPreviewParams
globalPose | AttractorFSPreviewParams
userData | AttractorFSPreviewParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BasicFSDebugRenderParams Struct Reference

  • Class List
  • Class Members
Public Attributes
BasicFSDebugRenderParams Struct Reference

Describes the NxParameterized::Interface for 'BasicFSDebugRenderParams' : More...

#include <params.h>

List of all members.

Public Attributes

Bool | VISUALIZE_JET_FS_ACTOR
'VISUALIZE_JET_FS_ACTOR' : Enables/Disables visualization of all JetFS actors.
Bool | VISUALIZE_JET_FS_ACTOR_NAME
'VISUALIZE_JET_FS_ACTOR_NAME' : Displays the name of each JetFS actor.
Bool | VISUALIZE_JET_FS_SHAPE
'VISUALIZE_JET_FS_SHAPE' : Enables/Disables visualization of the toroidal field shape (blue closed lattice).
Bool | VISUALIZE_JET_FS_FIELD
'VISUALIZE_JET_FS_FIELD' : Enables/Disables visualization of the toroidal field itself (streaklines).
Bool | VISUALIZE_JET_FS_POSE
'VISUALIZE_JET_FS_POSE' : For visualizing the position of the field itself. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.
F32 | JET_FS_FIELD_SCALE
'JET_FS_FIELD_SCALE' : Changes toroidal field arrows' length. The larger parameter, the longer each arrow.
Bool | VISUALIZE_ATTRACTOR_FS_ACTOR
'VISUALIZE_ATTRACTOR_FS_ACTOR' : Enables/Disables visualization of all AttractorFS actors.
Bool | VISUALIZE_ATTRACTOR_FS_ACTOR_NAME
'VISUALIZE_ATTRACTOR_FS_ACTOR_NAME' : Displays the name of each AttractorFS actor.
Bool | VISUALIZE_ATTRACTOR_FS_SHAPE
'VISUALIZE_ATTRACTOR_FS_SHAPE' : Enables/Disables visualization of the field shape (blue closed lattice).
Bool | VISUALIZE_ATTRACTOR_FS_FIELD
'VISUALIZE_ATTRACTOR_FS_FIELD' : Enables/Disables visualization of the field itself (streaklines).
Bool | VISUALIZE_ATTRACTOR_FS_POSE
'VISUALIZE_ATTRACTOR_FS_POSE' : For visualizing the position of the field itself. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.
Bool | VISUALIZE_VORTEX_FS_ACTOR
'VISUALIZE_VORTEX_FS_ACTOR' : Enables/Disables visualization of all VortexFS actors.
Bool | VISUALIZE_VORTEX_FS_ACTOR_NAME
'VISUALIZE_VORTEX_FS_ACTOR_NAME' : Displays the name of each VortexFS actor.
Bool | VISUALIZE_VORTEX_FS_SHAPE
'VISUALIZE_VORTEX_FS_SHAPE' : Enables/Disables visualization of the field shape (blue closed lattice).
Bool | VISUALIZE_VORTEX_FS_FIELD
'VISUALIZE_VORTEX_FS_FIELD' : Enables/Disables visualization of the field itself (streaklines).
Bool | VISUALIZE_VORTEX_FS_POSE
'VISUALIZE_VORTEX_FS_POSE' : For visualizing the position of the field itself. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.
Bool | VISUALIZE_NOISE_FS_ACTOR
'VISUALIZE_NOISE_FS_ACTOR' : Enables/Disables visualization of all NoiseFS actors.
Bool | VISUALIZE_NOISE_FS_ACTOR_NAME
'VISUALIZE_NOISE_FS_ACTOR_NAME' : Displays the name of each NoiseFS actor.
Bool | VISUALIZE_NOISE_FS_SHAPE
'VISUALIZE_NOISE_FS_SHAPE' : Enables/Disables visualization of each NoiseFS actor shape.
Bool | VISUALIZE_NOISE_FS_POSE
'VISUALIZE_NOISE_FS_POSE' : For visualizing the position of the field itself. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.
Bool | VISUALIZE_WIND_FS_ACTOR
'VISUALIZE_WIND_FS_ACTOR' : Enables/Disables visualization of all WindFS actors.
Bool | VISUALIZE_WIND_FS_ACTOR_NAME
'VISUALIZE_WIND_FS_ACTOR_NAME' : Displays the name of each WindFS actor.

Detailed Description

Describes the NxParameterized::Interface for 'BasicFSDebugRenderParams' :

BasicFSDebugRenderParams contains 22 fully qualified names
---------------------------------------------
  1 : Bool  VISUALIZE_JET_FS_ACTOR
  2 : Bool  VISUALIZE_JET_FS_ACTOR_NAME
  3 : Bool  VISUALIZE_JET_FS_SHAPE
  4 : Bool  VISUALIZE_JET_FS_FIELD
  5 : Bool  VISUALIZE_JET_FS_POSE
  6 : F32   JET_FS_FIELD_SCALE
  7 : Bool  VISUALIZE_ATTRACTOR_FS_ACTOR
  8 : Bool  VISUALIZE_ATTRACTOR_FS_ACTOR_NAME
  9 : Bool  VISUALIZE_ATTRACTOR_FS_SHAPE
 10 : Bool  VISUALIZE_ATTRACTOR_FS_FIELD
 11 : Bool  VISUALIZE_ATTRACTOR_FS_POSE
 12 : Bool  VISUALIZE_VORTEX_FS_ACTOR
 13 : Bool  VISUALIZE_VORTEX_FS_ACTOR_NAME
 14 : Bool  VISUALIZE_VORTEX_FS_SHAPE
 15 : Bool  VISUALIZE_VORTEX_FS_FIELD
 16 : Bool  VISUALIZE_VORTEX_FS_POSE
 17 : Bool  VISUALIZE_NOISE_FS_ACTOR
 18 : Bool  VISUALIZE_NOISE_FS_ACTOR_NAME
 19 : Bool  VISUALIZE_NOISE_FS_SHAPE
 20 : Bool  VISUALIZE_NOISE_FS_POSE
 21 : Bool  VISUALIZE_WIND_FS_ACTOR
 22 : Bool  VISUALIZE_WIND_FS_ACTOR_NAME

Member Data Documentation

F32 BasicFSDebugRenderParams::JET_FS_FIELD_SCALE

'JET_FS_FIELD_SCALE' : Changes toroidal field arrows' length. The larger parameter, the longer each arrow.

Bool BasicFSDebugRenderParams::VISUALIZE_ATTRACTOR_FS_ACTOR

'VISUALIZE_ATTRACTOR_FS_ACTOR' : Enables/Disables visualization of all AttractorFS actors.

Bool BasicFSDebugRenderParams::VISUALIZE_ATTRACTOR_FS_ACTOR_NAME

'VISUALIZE_ATTRACTOR_FS_ACTOR_NAME' : Displays the name of each AttractorFS actor.

Bool BasicFSDebugRenderParams::VISUALIZE_ATTRACTOR_FS_FIELD

'VISUALIZE_ATTRACTOR_FS_FIELD' : Enables/Disables visualization of the field itself (streaklines).

Bool BasicFSDebugRenderParams::VISUALIZE_ATTRACTOR_FS_POSE

'VISUALIZE_ATTRACTOR_FS_POSE' : For visualizing the position of the field itself. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.

Bool BasicFSDebugRenderParams::VISUALIZE_ATTRACTOR_FS_SHAPE

'VISUALIZE_ATTRACTOR_FS_SHAPE' : Enables/Disables visualization of the field shape (blue closed lattice).

Bool BasicFSDebugRenderParams::VISUALIZE_JET_FS_ACTOR

'VISUALIZE_JET_FS_ACTOR' : Enables/Disables visualization of all JetFS actors.

Bool BasicFSDebugRenderParams::VISUALIZE_JET_FS_ACTOR_NAME

'VISUALIZE_JET_FS_ACTOR_NAME' : Displays the name of each JetFS actor.

Bool BasicFSDebugRenderParams::VISUALIZE_JET_FS_FIELD

'VISUALIZE_JET_FS_FIELD' : Enables/Disables visualization of the toroidal field itself (streaklines).

Bool BasicFSDebugRenderParams::VISUALIZE_JET_FS_POSE

'VISUALIZE_JET_FS_POSE' : For visualizing the position of the field itself. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.

Bool BasicFSDebugRenderParams::VISUALIZE_JET_FS_SHAPE

'VISUALIZE_JET_FS_SHAPE' : Enables/Disables visualization of the toroidal field shape (blue closed lattice).

Bool BasicFSDebugRenderParams::VISUALIZE_NOISE_FS_ACTOR

'VISUALIZE_NOISE_FS_ACTOR' : Enables/Disables visualization of all NoiseFS actors.

Bool BasicFSDebugRenderParams::VISUALIZE_NOISE_FS_ACTOR_NAME

'VISUALIZE_NOISE_FS_ACTOR_NAME' : Displays the name of each NoiseFS actor.

Bool BasicFSDebugRenderParams::VISUALIZE_NOISE_FS_POSE

'VISUALIZE_NOISE_FS_POSE' : For visualizing the position of the field itself. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.

Bool BasicFSDebugRenderParams::VISUALIZE_NOISE_FS_SHAPE

'VISUALIZE_NOISE_FS_SHAPE' : Enables/Disables visualization of each NoiseFS actor shape.

Bool BasicFSDebugRenderParams::VISUALIZE_VORTEX_FS_ACTOR

'VISUALIZE_VORTEX_FS_ACTOR' : Enables/Disables visualization of all VortexFS actors.

Bool BasicFSDebugRenderParams::VISUALIZE_VORTEX_FS_ACTOR_NAME

'VISUALIZE_VORTEX_FS_ACTOR_NAME' : Displays the name of each VortexFS actor.

Bool BasicFSDebugRenderParams::VISUALIZE_VORTEX_FS_FIELD

'VISUALIZE_VORTEX_FS_FIELD' : Enables/Disables visualization of the field itself (streaklines).

Bool BasicFSDebugRenderParams::VISUALIZE_VORTEX_FS_POSE

'VISUALIZE_VORTEX_FS_POSE' : For visualizing the position of the field itself. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.

Bool BasicFSDebugRenderParams::VISUALIZE_VORTEX_FS_SHAPE

'VISUALIZE_VORTEX_FS_SHAPE' : Enables/Disables visualization of the field shape (blue closed lattice).

Bool BasicFSDebugRenderParams::VISUALIZE_WIND_FS_ACTOR

'VISUALIZE_WIND_FS_ACTOR' : Enables/Disables visualization of all WindFS actors.

Bool BasicFSDebugRenderParams::VISUALIZE_WIND_FS_ACTOR_NAME

'VISUALIZE_WIND_FS_ACTOR_NAME' : Displays the name of each WindFS actor.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BasicFSDebugRenderParams Member List
This is the complete list of members for BasicFSDebugRenderParams, including all inherited members.
JET_FS_FIELD_SCALE | BasicFSDebugRenderParams
VISUALIZE_ATTRACTOR_FS_ACTOR | BasicFSDebugRenderParams
VISUALIZE_ATTRACTOR_FS_ACTOR_NAME | BasicFSDebugRenderParams
VISUALIZE_ATTRACTOR_FS_FIELD | BasicFSDebugRenderParams
VISUALIZE_ATTRACTOR_FS_POSE | BasicFSDebugRenderParams
VISUALIZE_ATTRACTOR_FS_SHAPE | BasicFSDebugRenderParams
VISUALIZE_JET_FS_ACTOR | BasicFSDebugRenderParams
VISUALIZE_JET_FS_ACTOR_NAME | BasicFSDebugRenderParams
VISUALIZE_JET_FS_FIELD | BasicFSDebugRenderParams
VISUALIZE_JET_FS_POSE | BasicFSDebugRenderParams
VISUALIZE_JET_FS_SHAPE | BasicFSDebugRenderParams
VISUALIZE_NOISE_FS_ACTOR | BasicFSDebugRenderParams
VISUALIZE_NOISE_FS_ACTOR_NAME | BasicFSDebugRenderParams
VISUALIZE_NOISE_FS_POSE | BasicFSDebugRenderParams
VISUALIZE_NOISE_FS_SHAPE | BasicFSDebugRenderParams
VISUALIZE_VORTEX_FS_ACTOR | BasicFSDebugRenderParams
VISUALIZE_VORTEX_FS_ACTOR_NAME | BasicFSDebugRenderParams
VISUALIZE_VORTEX_FS_FIELD | BasicFSDebugRenderParams
VISUALIZE_VORTEX_FS_POSE | BasicFSDebugRenderParams
VISUALIZE_VORTEX_FS_SHAPE | BasicFSDebugRenderParams
VISUALIZE_WIND_FS_ACTOR | BasicFSDebugRenderParams
VISUALIZE_WIND_FS_ACTOR_NAME | BasicFSDebugRenderParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BasicFSModuleParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
BasicFSModuleParameters Struct Reference

Describes the NxParameterized::Interface for 'BasicFSModuleParameters' : This class is used for initializing the NxModuleFieldBoundary. More...

#include <params.h>

List of all members.

Public Attributes

U32 unused
'unused' : No parameters necessary

Detailed Description

Describes the NxParameterized::Interface for 'BasicFSModuleParameters' : This class is used for initializing the NxModuleFieldBoundary.

BasicFSModuleParameters contains 1 fully qualified names
---------------------------------------------
  1 : U32  unused

Member Data Documentation

U32 BasicFSModuleParameters::unused

'unused' : No parameters necessary

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BasicFSModuleParameters Member List
This is the complete list of members for BasicFSModuleParameters, including all inherited members.
unused BasicFSModuleParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BasicIOSAssetParam Struct Reference

  • Class List
  • Class Members
Public Attributes
BasicIOSAssetParam Struct Reference

Describes the NxParameterized::Interface for 'BasicIOSAssetParam' : More...

#include <params.h>

List of all members.

Public Attributes

F32 | restDensity
'restDensity' : Rest density of particles
F32 | particleRadius
'particleRadius' : Radius of a particle
U32 | maxParticleCount
'maxParticleCount' : Maximum particle count
F32 | maxInjectedParticleCount
'maxInjectedParticleCount' : Maximum number of newly created particles on each frame
U32 | maxCollidingObjects
'maxCollidingObjects' : Maximum number of particles that are able to collide with each other.
F32 | sceneGravityScale
'sceneGravityScale' : Used to scale, or even disable the basic IOS's gravity
Vec3 | externalAcceleration
'externalAcceleration' : Acceleration (m/s^2) applied to all particles at all time steps (added to the scaled scene gravity).
F32 | particleMass.center
'particleMass.center' : Center of distribution
F32 | particleMass.spread
'particleMass.spread' : Spread of distribution
Type particleMass.type
'particleMass.type' : Distribution type
String | collisionFilterDataName
'collisionFilterDataName' : The filter data (group/groupsMask) name for IOS vs PhysX interaction.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for IOS vs FieldSampler interaction.
Bool | staticCollision
'staticCollision' : Enables collision with static shapes
F32 | restitutionForStaticShapes
'restitutionForStaticShapes' : Defines the restitution coefficient used for collisions with static shapes.
Bool | dynamicCollision
'dynamicCollision' : Enables collision with dynamic shapes
F32 | restitutionForDynamicShapes
'restitutionForDynamicShapes' : Defines the restitution coefficient used for collisions with dynamic shapes.
F32 | collisionDistanceMultiplier
'collisionDistanceMultiplier' : Defines the distance (= collisionDistanceMultiplier*particleRadius) between particles and collision geometry, which is maintained during simulation.
F32 | collisionThreshold
'collisionThreshold' : Defines the threshold for collision between particles and collision geometry, inside this threshold collision contact is generated without a response.
Bool | collisionWithConvex
'collisionWithConvex' : Enables collision with convex shapes
Bool | collisionWithTriangleMesh
'collisionWithTriangleMesh' : Enables collision with triangle mesh shapes
Bool | GridDensity.Enabled
'GridDensity.Enabled' : Compute Density Using a Grid
Resolution GridDensity.Resolution
'GridDensity.Resolution' : Number of cells in a 3D grid, used to calculate particles positions. Higher values divide the grid into more cells.
F32 | GridDensity.GridSize
'GridDensity.GridSize' : Depth of grid.
U32 | GridDensity.MaxCellCount
'GridDensity.MaxCellCount' : This is the number of particles within a gridcell for a density of 1
Bool | enableTemperatureBuffer
'enableTemperatureBuffer' : Enables temperature buffer.

Detailed Description

Describes the NxParameterized::Interface for 'BasicIOSAssetParam' :

BasicIOSAssetParam contains 25 fully qualified names
---------------------------------------------
  1 : F32         restDensity
  2 : F32         particleRadius
  3 : U32         maxParticleCount
  4 : F32         maxInjectedParticleCount
  5 : U32         maxCollidingObjects
  6 : F32         sceneGravityScale
  7 : Vec3        externalAcceleration
  8 : F32         particleMass.center
  9 : F32         particleMass.spread
 10 : Type        particleMass.type
 11 : String      collisionFilterDataName
 12 : String      fieldSamplerFilterDataName
 13 : Bool        staticCollision
 14 : F32         restitutionForStaticShapes
 15 : Bool        dynamicCollision
 16 : F32         restitutionForDynamicShapes
 17 : F32         collisionDistanceMultiplier
 18 : F32         collisionThreshold
 19 : Bool        collisionWithConvex
 20 : Bool        collisionWithTriangleMesh
 21 : Bool        GridDensity.Enabled
 22 : Resolution  GridDensity.Resolution
 23 : F32         GridDensity.GridSize
 24 : U32         GridDensity.MaxCellCount
 25 : Bool        enableTemperatureBuffer

Member Data Documentation

F32 BasicIOSAssetParam::collisionDistanceMultiplier

'collisionDistanceMultiplier' : Defines the distance (= collisionDistanceMultiplier*particleRadius) between particles and collision geometry, which is maintained during simulation.

String BasicIOSAssetParam::collisionFilterDataName

'collisionFilterDataName' : The filter data (group/groupsMask) name for IOS vs PhysX interaction.

F32 BasicIOSAssetParam::collisionThreshold

'collisionThreshold' : Defines the threshold for collision between particles and collision geometry, inside this threshold collision contact is generated without a response.

Bool BasicIOSAssetParam::collisionWithConvex

'collisionWithConvex' : Enables collision with convex shapes

Bool BasicIOSAssetParam::collisionWithTriangleMesh

'collisionWithTriangleMesh' : Enables collision with triangle mesh shapes

Bool BasicIOSAssetParam::dynamicCollision

'dynamicCollision' : Enables collision with dynamic shapes

Bool BasicIOSAssetParam::enableTemperatureBuffer

'enableTemperatureBuffer' : Enables temperature buffer.

Vec3 BasicIOSAssetParam::externalAcceleration

'externalAcceleration' : Acceleration (m/s^2) applied to all particles at all time steps (added to the scaled scene gravity).

String BasicIOSAssetParam::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for IOS vs FieldSampler interaction.

Bool BasicIOSAssetParam::GridDensity.Enabled

'GridDensity.Enabled' : Compute Density Using a Grid

If this option is true; density will be computed based on the grouping of particles in a 3d grid

F32 BasicIOSAssetParam::GridDensity.GridSize

'GridDensity.GridSize' : Depth of grid.

The default value is a 10 units Must be positive.

U32 BasicIOSAssetParam::GridDensity.MaxCellCount

'GridDensity.MaxCellCount' : This is the number of particles within a gridcell for a density of 1

This is the integer count representing how many particles reside in a single grid cell before the density is considered 1. It is valid for the density to be greater than one. For example, if there were 32 particles in a grid cell with a max-cell count of 16, then the density would be equal to 2.

Resolution BasicIOSAssetParam::GridDensity.Resolution

'GridDensity.Resolution' : Number of cells in a 3D grid, used to calculate particles positions. Higher values divide the grid into more cells.

This enumeration defines the 3d resolution of the grid.

U32 BasicIOSAssetParam::maxCollidingObjects

'maxCollidingObjects' : Maximum number of particles that are able to collide with each other.

Maximum number of objects that are able to collide with each other (boxes, spheres, capsules, hspaces, convexmeshes, trimeshes).

F32 BasicIOSAssetParam::maxInjectedParticleCount

'maxInjectedParticleCount' : Maximum number of newly created particles on each frame

The maximum number of new particles to be spawned on each frame. Use values >1 to provide the absolute value, or 0 <= x <= 1 to provide the percentage rate to overall number of particles.

U32 BasicIOSAssetParam::maxParticleCount

'maxParticleCount' : Maximum particle count

F32 BasicIOSAssetParam::particleMass.center

'particleMass.center' : Center of distribution

F32 BasicIOSAssetParam::particleMass.spread

'particleMass.spread' : Spread of distribution

Spread is std deviation for normal distribution or halfwidth for uniform distribution.

Type BasicIOSAssetParam::particleMass.type

'particleMass.type' : Distribution type

Type of probability distribution (currently only normal and uniform are supported).

F32 BasicIOSAssetParam::particleRadius

'particleRadius' : Radius of a particle

Radius of a particle.

F32 BasicIOSAssetParam::restDensity

'restDensity' : Rest density of particles

Authored density of the instanced objects simulated by this IOS. Emitters need this value for constant density emitter effects.

F32 BasicIOSAssetParam::restitutionForDynamicShapes

'restitutionForDynamicShapes' : Defines the restitution coefficient used for collisions with dynamic shapes.

F32 BasicIOSAssetParam::restitutionForStaticShapes

'restitutionForStaticShapes' : Defines the restitution coefficient used for collisions with static shapes.

F32 BasicIOSAssetParam::sceneGravityScale

'sceneGravityScale' : Used to scale, or even disable the basic IOS's gravity

Bool BasicIOSAssetParam::staticCollision

'staticCollision' : Enables collision with static shapes

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BasicIOSAssetParam Member List
This is the complete list of members for BasicIOSAssetParam, including all inherited members.
collisionDistanceMultiplier | BasicIOSAssetParam
collisionFilterDataName | BasicIOSAssetParam
collisionThreshold | BasicIOSAssetParam
collisionWithConvex | BasicIOSAssetParam
collisionWithTriangleMesh | BasicIOSAssetParam
dynamicCollision | BasicIOSAssetParam
enableTemperatureBuffer | BasicIOSAssetParam
externalAcceleration | BasicIOSAssetParam
fieldSamplerFilterDataName | BasicIOSAssetParam
GridDensity.Enabled | BasicIOSAssetParam
GridDensity.GridSize | BasicIOSAssetParam
GridDensity.MaxCellCount | BasicIOSAssetParam
GridDensity.Resolution | BasicIOSAssetParam
maxCollidingObjects | BasicIOSAssetParam
maxInjectedParticleCount | BasicIOSAssetParam
maxParticleCount | BasicIOSAssetParam
particleMass.center | BasicIOSAssetParam
particleMass.spread | BasicIOSAssetParam
particleMass.type | BasicIOSAssetParam
particleRadius | BasicIOSAssetParam
restDensity | BasicIOSAssetParam
restitutionForDynamicShapes | BasicIOSAssetParam
restitutionForStaticShapes | BasicIOSAssetParam
sceneGravityScale | BasicIOSAssetParam
staticCollision | BasicIOSAssetParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BasicIosDebugRenderParams Struct Reference

  • Class List
  • Class Members
Public Attributes
BasicIosDebugRenderParams Struct Reference

Describes the NxParameterized::Interface for 'BasicIosDebugRenderParams' : More...

#include <params.h>

List of all members.

Public Attributes

Bool | VISUALIZE_BASIC_IOS_ACTOR
'VISUALIZE_BASIC_IOS_ACTOR' : Render the IOS Actor in view window
Bool | VISUALIZE_BASIC_IOS_COLLIDE_SHAPES
'VISUALIZE_BASIC_IOS_COLLIDE_SHAPES' : Render the IOS collision shapes in view window
Bool | VISUALIZE_BASIC_IOS_GRID_DENSITY
'VISUALIZE_BASIC_IOS_GRID_DENSITY' : Render the IOS Grid Density in the view window

Detailed Description

Describes the NxParameterized::Interface for 'BasicIosDebugRenderParams' :

BasicIosDebugRenderParams contains 3 fully qualified names
---------------------------------------------
  1 : Bool  VISUALIZE_BASIC_IOS_ACTOR
  2 : Bool  VISUALIZE_BASIC_IOS_COLLIDE_SHAPES
  3 : Bool  VISUALIZE_BASIC_IOS_GRID_DENSITY

Member Data Documentation

Bool BasicIosDebugRenderParams::VISUALIZE_BASIC_IOS_ACTOR

'VISUALIZE_BASIC_IOS_ACTOR' : Render the IOS Actor in view window

Bool BasicIosDebugRenderParams::VISUALIZE_BASIC_IOS_COLLIDE_SHAPES

'VISUALIZE_BASIC_IOS_COLLIDE_SHAPES' : Render the IOS collision shapes in view window

Bool BasicIosDebugRenderParams::VISUALIZE_BASIC_IOS_GRID_DENSITY

'VISUALIZE_BASIC_IOS_GRID_DENSITY' : Render the IOS Grid Density in the view window

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BasicIosDebugRenderParams Member List
This is the complete list of members for BasicIosDebugRenderParams, including all inherited members.
VISUALIZE_BASIC_IOS_ACTOR | BasicIosDebugRenderParams
VISUALIZE_BASIC_IOS_COLLIDE_SHAPES | BasicIosDebugRenderParams
VISUALIZE_BASIC_IOS_GRID_DENSITY | BasicIosDebugRenderParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BasicIosModuleParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
BasicIosModuleParameters Struct Reference

Describes the NxParameterized::Interface for 'BasicIosModuleParameters' : This class is used for initializing the NxModuleBasicIos. More...

#include <params.h>

List of all members.

Public Attributes

U32 unused
'unused' : No parameters necessary

Detailed Description

Describes the NxParameterized::Interface for 'BasicIosModuleParameters' : This class is used for initializing the NxModuleBasicIos.

BasicIosModuleParameters contains 1 fully qualified names
---------------------------------------------
  1 : U32  unused

Member Data Documentation

U32 BasicIosModuleParameters::unused

'unused' : No parameters necessary

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BasicIosModuleParameters Member List
This is the complete list of members for BasicIosModuleParameters, including all inherited members.
unused BasicIosModuleParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferF32x1 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferF32x1 Struct Reference

Describes the NxParameterized::Interface for 'BufferF32x1' : More...

#include <params.h>

List of all members.

Public Attributes

F32 data[]
'data[]' : Container for FLOAT1 formats

Detailed Description

Describes the NxParameterized::Interface for 'BufferF32x1' :

BufferF32x1 contains 2 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : F32            data[]

Member Data Documentation

F32 BufferF32x1::data[]

'data[]' : Container for FLOAT1 formats

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferF32x1 Member List
This is the complete list of members for BufferF32x1, including all inherited members.
data[] BufferF32x1
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferF32x2 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferF32x2 Struct Reference

Describes the NxParameterized::Interface for 'BufferF32x2' : More...

#include <params.h>

List of all members.

Public Attributes

F32 | data[].x
'data[].x' : X
F32 | data[].y
'data[].y' : Y

Detailed Description

Describes the NxParameterized::Interface for 'BufferF32x2' :

BufferF32x2 contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : F32            data[].x
  3 : F32            data[].y

Member Data Documentation

F32 BufferF32x2::data[].x

'data[].x' : X

F32 BufferF32x2::data[].y

'data[].y' : Y

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferF32x2 Member List
This is the complete list of members for BufferF32x2, including all inherited members.
data[].x | BufferF32x2
data[].y | BufferF32x2
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferF32x3 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferF32x3 Struct Reference

Describes the NxParameterized::Interface for 'BufferF32x3' : More...

#include <params.h>

List of all members.

Public Attributes

Vec3 data[]
'data[]' : Container for FLOAT3 formats

Detailed Description

Describes the NxParameterized::Interface for 'BufferF32x3' :

BufferF32x3 contains 2 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : Vec3           data[]

Member Data Documentation

Vec3 BufferF32x3::data[]

'data[]' : Container for FLOAT3 formats

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferF32x3 Member List
This is the complete list of members for BufferF32x3, including all inherited members.
data[] BufferF32x3
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferF32x4 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferF32x4 Struct Reference

Describes the NxParameterized::Interface for 'BufferF32x4' : More...

#include <params.h>

List of all members.

Public Attributes

F32 | data[].x
'data[].x' : X
F32 | data[].y
'data[].y' : Y
F32 | data[].z
'data[].z' : Z
F32 | data[].w
'data[].w' : W

Detailed Description

Describes the NxParameterized::Interface for 'BufferF32x4' :

BufferF32x4 contains 5 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : F32            data[].x
  3 : F32            data[].y
  4 : F32            data[].z
  5 : F32            data[].w

Member Data Documentation

F32 BufferF32x4::data[].w

'data[].w' : W

F32 BufferF32x4::data[].x

'data[].x' : X

F32 BufferF32x4::data[].y

'data[].y' : Y

F32 BufferF32x4::data[].z

'data[].z' : Z

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferF32x4 Member List
This is the complete list of members for BufferF32x4, including all inherited members.
data[].w | BufferF32x4
data[].x | BufferF32x4
data[].y | BufferF32x4
data[].z | BufferF32x4
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferU8x1 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferU8x1 Struct Reference

Describes the NxParameterized::Interface for 'BufferU8x1' : More...

#include <params.h>

List of all members.

Public Attributes

U8 data[]
'data[]' : Container for BYTE1 formats

Detailed Description

Describes the NxParameterized::Interface for 'BufferU8x1' :

BufferU8x1 contains 2 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : U8             data[]

Member Data Documentation

U8 BufferU8x1::data[]

'data[]' : Container for BYTE1 formats

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferU8x1 Member List
This is the complete list of members for BufferU8x1, including all inherited members.
data[] BufferU8x1
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferU8x2 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferU8x2 Struct Reference

Describes the NxParameterized::Interface for 'BufferU8x2' : More...

#include <params.h>

List of all members.

Public Attributes

U8 | data[].x
'data[].x' : X
U8 | data[].y
'data[].y' : Y

Detailed Description

Describes the NxParameterized::Interface for 'BufferU8x2' :

BufferU8x2 contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : U8             data[].x
  3 : U8             data[].y

Member Data Documentation

U8 BufferU8x2::data[].x

'data[].x' : X

U8 BufferU8x2::data[].y

'data[].y' : Y

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferU8x2 Member List
This is the complete list of members for BufferU8x2, including all inherited members.
data[].x | BufferU8x2
data[].y | BufferU8x2
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferU8x3 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferU8x3 Struct Reference

Describes the NxParameterized::Interface for 'BufferU8x3' : More...

#include <params.h>

List of all members.

Public Attributes

U8 | data[].x
'data[].x' : X
U8 | data[].y
'data[].y' : Y
U8 | data[].z
'data[].z' : Z

Detailed Description

Describes the NxParameterized::Interface for 'BufferU8x3' :

BufferU8x3 contains 4 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : U8             data[].x
  3 : U8             data[].y
  4 : U8             data[].z

Member Data Documentation

U8 BufferU8x3::data[].x

'data[].x' : X

U8 BufferU8x3::data[].y

'data[].y' : Y

U8 BufferU8x3::data[].z

'data[].z' : Z

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferU8x3 Member List
This is the complete list of members for BufferU8x3, including all inherited members.
data[].x | BufferU8x3
data[].y | BufferU8x3
data[].z | BufferU8x3
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferU8x4 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferU8x4 Struct Reference

Describes the NxParameterized::Interface for 'BufferU8x4' : More...

#include <params.h>

List of all members.

Public Attributes

U8 | data[].x
'data[].x' : X
U8 | data[].y
'data[].y' : Y
U8 | data[].z
'data[].z' : Z
U8 | data[].w
'data[].w' : W

Detailed Description

Describes the NxParameterized::Interface for 'BufferU8x4' :

BufferU8x4 contains 5 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : U8             data[].x
  3 : U8             data[].y
  4 : U8             data[].z
  5 : U8             data[].w

Member Data Documentation

U8 BufferU8x4::data[].w

'data[].w' : W

U8 BufferU8x4::data[].x

'data[].x' : X

U8 BufferU8x4::data[].y

'data[].y' : Y

U8 BufferU8x4::data[].z

'data[].z' : Z

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferU8x4 Member List
This is the complete list of members for BufferU8x4, including all inherited members.
data[].w | BufferU8x4
data[].x | BufferU8x4
data[].y | BufferU8x4
data[].z | BufferU8x4
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferU16x1 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferU16x1 Struct Reference

Describes the NxParameterized::Interface for 'BufferU16x1' : More...

#include <params.h>

List of all members.

Public Attributes

U16 data[]
'data[]' : Container for SHORT1 formats

Detailed Description

Describes the NxParameterized::Interface for 'BufferU16x1' :

BufferU16x1 contains 2 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : U16            data[]

Member Data Documentation

U16 BufferU16x1::data[]

'data[]' : Container for SHORT1 formats

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferU16x1 Member List
This is the complete list of members for BufferU16x1, including all inherited members.
data[] BufferU16x1
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferU16x2 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferU16x2 Struct Reference

Describes the NxParameterized::Interface for 'BufferU16x2' : More...

#include <params.h>

List of all members.

Public Attributes

U16 | data[].x
'data[].x' : X
U16 | data[].y
'data[].y' : Y

Detailed Description

Describes the NxParameterized::Interface for 'BufferU16x2' :

BufferU16x2 contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : U16            data[].x
  3 : U16            data[].y

Member Data Documentation

U16 BufferU16x2::data[].x

'data[].x' : X

U16 BufferU16x2::data[].y

'data[].y' : Y

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferU16x2 Member List
This is the complete list of members for BufferU16x2, including all inherited members.
data[].x | BufferU16x2
data[].y | BufferU16x2
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferU16x3 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferU16x3 Struct Reference

Describes the NxParameterized::Interface for 'BufferU16x3' : More...

#include <params.h>

List of all members.

Public Attributes

U16 | data[].x
'data[].x' : X
U16 | data[].y
'data[].y' : Y
U16 | data[].z
'data[].z' : Z

Detailed Description

Describes the NxParameterized::Interface for 'BufferU16x3' :

BufferU16x3 contains 4 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : U16            data[].x
  3 : U16            data[].y
  4 : U16            data[].z

Member Data Documentation

U16 BufferU16x3::data[].x

'data[].x' : X

U16 BufferU16x3::data[].y

'data[].y' : Y

U16 BufferU16x3::data[].z

'data[].z' : Z

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferU16x3 Member List
This is the complete list of members for BufferU16x3, including all inherited members.
data[].x | BufferU16x3
data[].y | BufferU16x3
data[].z | BufferU16x3
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferU16x4 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferU16x4 Struct Reference

Describes the NxParameterized::Interface for 'BufferU16x4' : More...

#include <params.h>

List of all members.

Public Attributes

U16 | data[].x
'data[].x' : X
U16 | data[].y
'data[].y' : Y
U16 | data[].z
'data[].z' : Z
U16 | data[].w
'data[].w' : W

Detailed Description

Describes the NxParameterized::Interface for 'BufferU16x4' :

BufferU16x4 contains 5 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : U16            data[].x
  3 : U16            data[].y
  4 : U16            data[].z
  5 : U16            data[].w

Member Data Documentation

U16 BufferU16x4::data[].w

'data[].w' : W

U16 BufferU16x4::data[].x

'data[].x' : X

U16 BufferU16x4::data[].y

'data[].y' : Y

U16 BufferU16x4::data[].z

'data[].z' : Z

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferU16x4 Member List
This is the complete list of members for BufferU16x4, including all inherited members.
data[].w | BufferU16x4
data[].x | BufferU16x4
data[].y | BufferU16x4
data[].z | BufferU16x4
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferU32x1 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferU32x1 Struct Reference

Describes the NxParameterized::Interface for 'BufferU32x1' : More...

#include <params.h>

List of all members.

Public Attributes

U32 data[]
'data[]' : Container for INT1 formats

Detailed Description

Describes the NxParameterized::Interface for 'BufferU32x1' :

BufferU32x1 contains 2 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : U32            data[]

Member Data Documentation

U32 BufferU32x1::data[]

'data[]' : Container for INT1 formats

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferU32x1 Member List
This is the complete list of members for BufferU32x1, including all inherited members.
data[] BufferU32x1
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferU32x2 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferU32x2 Struct Reference

Describes the NxParameterized::Interface for 'BufferU32x2' : More...

#include <params.h>

List of all members.

Public Attributes

U32 | data[].x
'data[].x' : X
U32 | data[].y
'data[].y' : Y

Detailed Description

Describes the NxParameterized::Interface for 'BufferU32x2' :

BufferU32x2 contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : U32            data[].x
  3 : U32            data[].y

Member Data Documentation

U32 BufferU32x2::data[].x

'data[].x' : X

U32 BufferU32x2::data[].y

'data[].y' : Y

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferU32x2 Member List
This is the complete list of members for BufferU32x2, including all inherited members.
data[].x | BufferU32x2
data[].y | BufferU32x2
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferU32x3 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferU32x3 Struct Reference

Describes the NxParameterized::Interface for 'BufferU32x3' : More...

#include <params.h>

List of all members.

Public Attributes

U32 | data[].x
'data[].x' : X
U32 | data[].y
'data[].y' : Y
U32 | data[].z
'data[].z' : Z

Detailed Description

Describes the NxParameterized::Interface for 'BufferU32x3' :

BufferU32x3 contains 4 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : U32            data[].x
  3 : U32            data[].y
  4 : U32            data[].z

Member Data Documentation

U32 BufferU32x3::data[].x

'data[].x' : X

U32 BufferU32x3::data[].y

'data[].y' : Y

U32 BufferU32x3::data[].z

'data[].z' : Z

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferU32x3 Member List
This is the complete list of members for BufferU32x3, including all inherited members.
data[].x | BufferU32x3
data[].y | BufferU32x3
data[].z | BufferU32x3
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: BufferU32x4 Struct Reference

  • Class List
  • Class Members
Public Attributes
BufferU32x4 Struct Reference

Describes the NxParameterized::Interface for 'BufferU32x4' : More...

#include <params.h>

List of all members.

Public Attributes

U32 | data[].x
'data[].x' : X
U32 | data[].y
'data[].y' : Y
U32 | data[].z
'data[].z' : Z
U32 | data[].w
'data[].w' : W

Detailed Description

Describes the NxParameterized::Interface for 'BufferU32x4' :

BufferU32x4 contains 5 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : U32            data[].x
  3 : U32            data[].y
  4 : U32            data[].z
  5 : U32            data[].w

Member Data Documentation

U32 BufferU32x4::data[].w

'data[].w' : W

U32 BufferU32x4::data[].x

'data[].x' : X

U32 BufferU32x4::data[].y

'data[].y' : Y

U32 BufferU32x4::data[].z

'data[].z' : Z

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
BufferU32x4 Member List
This is the complete list of members for BufferU32x4, including all inherited members.
data[].w | BufferU32x4
data[].x | BufferU32x4
data[].y | BufferU32x4
data[].z | BufferU32x4
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: CachedOverlaps Struct Reference

  • Class List
  • Class Members
Public Attributes
CachedOverlaps Struct Reference

Describes the NxParameterized::Interface for 'CachedOverlaps' : More...

#include <params.h>

List of all members.

Public Attributes

Bool | isCached
'isCached' : Whether or not chunk overlaps are cached at a particular hierarchy depth
I32 | overlaps[].i0
'overlaps[].i0' : First element
I32 | overlaps[].i1
'overlaps[].i1' : Second element

Detailed Description

Describes the NxParameterized::Interface for 'CachedOverlaps' :

CachedOverlaps contains 4 fully qualified names
---------------------------------------------
  1 : Bool           isCached
  2 : ArraySizeName  overlaps
  3 : I32            overlaps[].i0
  4 : I32            overlaps[].i1

Member Data Documentation

Bool CachedOverlaps::isCached

'isCached' : Whether or not chunk overlaps are cached at a particular hierarchy depth

Whether or not chunk overlaps are cached at a particular hierarchy depth. In this case, overlap really means adjacency.

I32 CachedOverlaps::overlaps[].i0

'overlaps[].i0' : First element

I32 CachedOverlaps::overlaps[].i1

'overlaps[].i1' : Second element

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
CachedOverlaps Member List
This is the complete list of members for CachedOverlaps, including all inherited members.
isCached | CachedOverlaps
overlaps[].i0 | CachedOverlaps
overlaps[].i1 | CachedOverlaps
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ClothingActorParam Struct Reference

  • Class List
  • Class Members
Public Attributes
ClothingActorParam Struct Reference

Describes the NxParameterized::Interface for 'ClothingActorParam' : More...

#include <params.h>

List of all members.

Public Attributes

Mat44 | globalPose
'globalPose' : The pose where the clothing asset will be put into the scene
Bool | useHardwareCloth
'useHardwareCloth' : Turns on hardware acceleration for the cloth simulation
Bool | flags.ParallelCpuSkinning
'flags.ParallelCpuSkinning' : Determines whether or not to perform CPU skinning in parallel
Bool | flags.RecomputeNormals
'flags.RecomputeNormals' : Fully recomputes the normals on the final mesh.
Bool | flags.RecomputeTangents
'flags.RecomputeTangents' : Fully recomputes the tangents on the final mesh.
Bool | flags.Visualize
'flags.Visualize' : Determines whether or not to display debug visualization for this clothing actor
Bool | flags.CorrectSimulationNormals
'flags.CorrectSimulationNormals' :
Bool | flags.ComputeRenderData
'flags.ComputeRenderData' : If set to false no skinning is done for this actor. Disable if all skinning is done outside of APEX.
Bool | flags.ComputePhysicsMeshNormals
'flags.ComputePhysicsMeshNormals' : If set to false the normals on the physics mesh are not computed. Disable skinning and normal calculation is done outside of APEX.
Bool | fallbackSkinning
'fallbackSkinning' : Performs skinning in software
Bool | slowStart
'slowStart' : Prevents from having full max distance right from the start
Bool | useInternalBoneOrder
'useInternalBoneOrder' : Expect internally ordered bone arrays in updateState call.
Bool | updateStateWithGlobalMatrices
'updateStateWithGlobalMatrices' : Use world space matrices instead of composite (relative to bind pose) in NxClothingActor::updateState().
U32 | uvChannelForTangentUpdate
'uvChannelForTangentUpdate' : This UV channel is used for updating tangent space
F32 | maxDistanceBlendTime
'maxDistanceBlendTime' : Time in seconds how long it takes to go from zero maxDistance to full maxDistance
U32 | clothingMaterialIndex
'clothingMaterialIndex' : Use this material from the assets material library
F32 | lodWeights.maxDistance
'lodWeights.maxDistance' : Maximum distance
F32 | lodWeights.distanceWeight
'lodWeights.distanceWeight' : Distance weight
F32 | lodWeights.bias
'lodWeights.bias' : Bias
F32 | lodWeights.benefitsBias
'lodWeights.benefitsBias' : Benefits bias
Vec3 | windParams.Velocity
'windParams.Velocity' : The target velocity each vertex tries to achieve.
F32 | windParams.Adaption
'windParams.Adaption' : The rate of adaption. The higher this value, the faster the cloth reaches the wind velocity. Set to 0 to turn off wind.
F32 | maxDistanceScale.Scale
'maxDistanceScale.Scale' : Scale
Bool | maxDistanceScale.Multipliable
'maxDistanceScale.Multipliable' : Multipliable
U64 | userData
'userData' : Optional user data pointer associated with the clothing actor
Mat44 | boneMatrices[]
'boneMatrices[]' : An Array of matrices with the full transform for each bone
F32 | clothDescTemplate.collisionResponseCoefficient
'clothDescTemplate.collisionResponseCoefficient' : Defines a factor for the impulse transfer from cloth to colliding rigid bodies.
U16 | clothDescTemplate.collisionGroup
'clothDescTemplate.collisionGroup' : Sets which collision group this cloth is part of.
U32 | clothDescTemplate.groupsMask.bits0
'clothDescTemplate.groupsMask.bits0' : First part of 128-bit group mask
U32 | clothDescTemplate.groupsMask.bits1
'clothDescTemplate.groupsMask.bits1' : Second part of 128-bit group mask
U32 | clothDescTemplate.groupsMask.bits2
'clothDescTemplate.groupsMask.bits2' : Third part of 128-bit group mask
U32 | clothDescTemplate.groupsMask.bits3
'clothDescTemplate.groupsMask.bits3' : Fourth part of 128-bit group mask
Bounds3 | clothDescTemplate.validBounds
'clothDescTemplate.validBounds' : Defines the volume outside of which cloth particle are automatically removed from the simulation.
U64 | clothDescTemplate.compartment
'clothDescTemplate.compartment' : The compartment to place the cloth in.
U64 | clothDescTemplate.userData
'clothDescTemplate.userData' : Optional user data pointer.
Bool | shapeDescTemplate.flags.NX_SF_VISUALIZATION
'shapeDescTemplate.flags.NX_SF_VISUALIZATION' : Enable debug renderer for this shape
Bool | shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION
'shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION' : Disable collision detection for this shape (counterpart of NX_AF_DISABLE_COLLISION)
Bool | shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING
'shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING' : Disable raycasting for this shape
Bool | shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD
'shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD' : Enable dynamic-dynamic CCD for this shape. Used only when CCD is globally enabled and shape have a CCD skeleton.
Bool | shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES
'shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES' : Disable participation in ray casts, overlap tests and sweeps.
U16 | shapeDescTemplate.collisionGroup
'shapeDescTemplate.collisionGroup' : Sets which collision group this shape is part of.
U32 | shapeDescTemplate.groupsMask.bits0
'shapeDescTemplate.groupsMask.bits0' : First part of 128-bit group mask
U32 | shapeDescTemplate.groupsMask.bits1
'shapeDescTemplate.groupsMask.bits1' : Second part of 128-bit group mask
U32 | shapeDescTemplate.groupsMask.bits2
'shapeDescTemplate.groupsMask.bits2' : Third part of 128-bit group mask
U32 | shapeDescTemplate.groupsMask.bits3
'shapeDescTemplate.groupsMask.bits3' : Fourth part of 128-bit group mask
U16 | shapeDescTemplate.materialIndex
'shapeDescTemplate.materialIndex' : The material index of the shape.
U64 | shapeDescTemplate.userData
'shapeDescTemplate.userData' : Optional user data pointer
U64 | shapeDescTemplate.name
'shapeDescTemplate.name' : Name of the shapes; must be set by the application and must be a persistent pointer.
U64 | actorDescTemplate.userData
'actorDescTemplate.userData' : Optional user data pointer
U64 | actorDescTemplate.name
'actorDescTemplate.name' : Optional name string for the shape; must be set by the application and must be a persistent pointer.
F32 | actorScale
'actorScale' : Scale the actor differently than the asset.
ClothingCookedParam runtimeCooked
'runtimeCooked' :
Vec3 | morphDisplacements[]
'morphDisplacements[]' : Displacements according to the current morph target.
Vec3 | morphPhysicalMeshNewPositions[]
'morphPhysicalMeshNewPositions[]' : New positions for the physical meshes and convex collision volumes.
Vec3 | morphGraphicalMeshNewPositions[]
'morphGraphicalMeshNewPositions[]' : New positions of all submeshes of all graphical meshes.
Bool | allowAdaptiveTargetFrequency
'allowAdaptiveTargetFrequency' : Slightly modifies gravity to avoid high frequency jittering due to variable time steps.
Bool | useVelocityClamping
'useVelocityClamping' : Enable/disable velocity clamping
Bounds3 | vertexVelocityClamp
'vertexVelocityClamp' : Vertex velocity clamping values
F32 | pressure
'pressure' : Set pressure of cloth, only works on closed meshes.
Bool | multiplyGlobalPoseIntoBones
'multiplyGlobalPoseIntoBones' : Enable/disable multiplying global pose into bones
String | overrideMaterialNames[]
'overrideMaterialNames[]' : Replacement material names for the ones provided by the render mesh asset inside the clothing asset.
SimulationBackend simulationBackend
'simulationBackend' : Select which backend should be used. 'ForceNative' will only work when running with the 2.8.x PhysX SDK
Bool | freezeByLOD
'freezeByLOD' : Cloth state frozen when LoD turns off simulation of the actor, instead of returning to the animated state.
Bool | localSpaceSim
'localSpaceSim' : Do simulation in local space.
I32 | teleportMode
'teleportMode' : Buffered teleport state for the next simulate call, gets set in updateState, is reset to Continuous during simulate().

Detailed Description

Describes the NxParameterized::Interface for 'ClothingActorParam' :

ClothingActorParam contains 90 fully qualified names
---------------------------------------------
  1 : Mat44              globalPose
  2 : Bool               useHardwareCloth
  3 : Bool               flags.ParallelCpuSkinning
  4 : Bool               flags.RecomputeNormals
  5 : Bool               flags.RecomputeTangents
  6 : Bool               flags.Visualize
  7 : Bool               flags.CorrectSimulationNormals
  8 : Bool               flags.ComputeRenderData
  9 : Bool               flags.ComputePhysicsMeshNormals
 10 : Bool               fallbackSkinning
 11 : Bool               slowStart
 12 : Bool               useInternalBoneOrder
 13 : Bool               updateStateWithGlobalMatrices
 14 : U32                uvChannelForTangentUpdate
 15 : F32                maxDistanceBlendTime
 16 : U32                clothingMaterialIndex
 17 : F32                lodWeights.maxDistance
 18 : F32                lodWeights.distanceWeight
 19 : F32                lodWeights.bias
 20 : F32                lodWeights.benefitsBias
 21 : Vec3               windParams.Velocity
 22 : F32                windParams.Adaption
 23 : F32                maxDistanceScale.Scale
 24 : Bool               maxDistanceScale.Multipliable
 25 : U64                userData
 26 : ArraySizeName      boneMatrices
 27 : Mat44              boneMatrices[]
 28 : F32                clothDescTemplate.collisionResponseCoefficient
 29 : U16                clothDescTemplate.collisionGroup
 30 : U32                clothDescTemplate.groupsMask.bits0
 31 : U32                clothDescTemplate.groupsMask.bits1
 32 : U32                clothDescTemplate.groupsMask.bits2
 33 : U32                clothDescTemplate.groupsMask.bits3
 34 : Bounds3            clothDescTemplate.validBounds
 35 : U64                clothDescTemplate.compartment
 36 : U64                clothDescTemplate.userData
 37 : Bool               shapeDescTemplate.flags.NX_SF_VISUALIZATION
 38 : Bool               shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION
 39 : Bool               shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING
 40 : Bool               shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD
 41 : Bool               shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES
 42 : U16                shapeDescTemplate.collisionGroup
 43 : U32                shapeDescTemplate.groupsMask.bits0
 44 : U32                shapeDescTemplate.groupsMask.bits1
 45 : U32                shapeDescTemplate.groupsMask.bits2
 46 : U32                shapeDescTemplate.groupsMask.bits3
 47 : U16                shapeDescTemplate.materialIndex
 48 : U64                shapeDescTemplate.userData
 49 : U64                shapeDescTemplate.name
 50 : U64                actorDescTemplate.userData
 51 : U64                actorDescTemplate.name
 52 : F32                actorScale
 53 : F32                runtimeCooked.actorScale                                                    RefVariant[ClothingCookedParam]
 54 : ArraySizeName      runtimeCooked.convexCookedData                                              RefVariant[ClothingCookedParam]
 55 : U8                 runtimeCooked.convexCookedData[]                                            RefVariant[ClothingCookedParam]
 56 : ArraySizeName      runtimeCooked.convexMeshPointers                                            RefVariant[ClothingCookedParam]
 57 : ArraySizeName      runtimeCooked.cookedPhysicalSubmeshes                                       RefVariant[ClothingCookedParam]
 58 : U32                runtimeCooked.cookedPhysicalSubmeshes[].physicalMeshId                      RefVariant[ClothingCookedParam]
 59 : U32                runtimeCooked.cookedPhysicalSubmeshes[].submeshId                           RefVariant[ClothingCookedParam]
 60 : U32                runtimeCooked.cookedPhysicalSubmeshes[].cookedDataOffset                    RefVariant[ClothingCookedParam]
 61 : U32                runtimeCooked.cookedPhysicalSubmeshes[].cookedDataLength                    RefVariant[ClothingCookedParam]
 62 : U32                runtimeCooked.cookedPhysicalSubmeshes[].deformableInvParticleWeightsOffset  RefVariant[ClothingCookedParam]
 63 : U32                runtimeCooked.cookedPhysicalSubmeshes[].virtualParticleIndicesOffset        RefVariant[ClothingCookedParam]
 64 : U32                runtimeCooked.cookedPhysicalSubmeshes[].virtualParticleIndicesLength        RefVariant[ClothingCookedParam]
 65 : ArraySizeName      runtimeCooked.deformableCookedData                                          RefVariant[ClothingCookedParam]
 66 : U8                 runtimeCooked.deformableCookedData[]                                        RefVariant[ClothingCookedParam]
 67 : U32                runtimeCooked.cookedDataVersion                                             RefVariant[ClothingCookedParam]
 68 : ArraySizeName      runtimeCooked.deformableInvParticleWeights                                  RefVariant[ClothingCookedParam]
 69 : F32                runtimeCooked.deformableInvParticleWeights[]                                RefVariant[ClothingCookedParam]
 70 : ArraySizeName      runtimeCooked.virtualParticleIndices                                        RefVariant[ClothingCookedParam]
 71 : U32                runtimeCooked.virtualParticleIndices[]                                      RefVariant[ClothingCookedParam]
 72 : ArraySizeName      runtimeCooked.virtualParticleWeights                                        RefVariant[ClothingCookedParam]
 73 : Vec3               runtimeCooked.virtualParticleWeights[]                                      RefVariant[ClothingCookedParam]
 74 : ArraySizeName      morphDisplacements
 75 : Vec3               morphDisplacements[]
 76 : ArraySizeName      morphPhysicalMeshNewPositions
 77 : Vec3               morphPhysicalMeshNewPositions[]
 78 : ArraySizeName      morphGraphicalMeshNewPositions
 79 : Vec3               morphGraphicalMeshNewPositions[]
 80 : Bool               allowAdaptiveTargetFrequency
 81 : Bool               useVelocityClamping
 82 : Bounds3            vertexVelocityClamp
 83 : F32                pressure
 84 : Bool               multiplyGlobalPoseIntoBones
 85 : ArraySizeName      overrideMaterialNames
 86 : String             overrideMaterialNames[]
 87 : SimulationBackend  simulationBackend
 88 : Bool               freezeByLOD
 89 : Bool               localSpaceSim
 90 : I32                teleportMode

Member Data Documentation

U64 ClothingActorParam::actorDescTemplate.name

'actorDescTemplate.name' : Optional name string for the shape; must be set by the application and must be a persistent pointer.

U64 ClothingActorParam::actorDescTemplate.userData

'actorDescTemplate.userData' : Optional user data pointer

F32 ClothingActorParam::actorScale

'actorScale' : Scale the actor differently than the asset.

Bool ClothingActorParam::allowAdaptiveTargetFrequency

'allowAdaptiveTargetFrequency' : Slightly modifies gravity to avoid high frequency jittering due to variable time steps.

Mat44 ClothingActorParam::boneMatrices[]

'boneMatrices[]' : An Array of matrices with the full transform for each bone

These matrices are sometimes referred to as composite matrices. They are the multiplication of the current world space bone pose with the inverse bind pose in world space. Note: If 'updateStateWithGlobalMatrices' is set to true, these must be global poses instead.

U16 ClothingActorParam::clothDescTemplate.collisionGroup

'clothDescTemplate.collisionGroup' : Sets which collision group this cloth is part of.

F32 ClothingActorParam::clothDescTemplate.collisionResponseCoefficient

'clothDescTemplate.collisionResponseCoefficient' : Defines a factor for the impulse transfer from cloth to colliding rigid bodies.

This is only needed if the twoway interaction flag is set in the clothing asset.

U64 ClothingActorParam::clothDescTemplate.compartment

'clothDescTemplate.compartment' : The compartment to place the cloth in.

Must be either a pointer to an NxCompartment of type NX_SCT_CLOTH or NX_SCT_SOFTBODY, or NULL. A NULL compartment means creating NX_CLF_HARDWARE cloth in the first available cloth compartment (a default cloth compartment is created if none exists). Software cloth with a NULL compartment is created in the scene proper.

U32 ClothingActorParam::clothDescTemplate.groupsMask.bits0

'clothDescTemplate.groupsMask.bits0' : First part of 128-bit group mask

U32 ClothingActorParam::clothDescTemplate.groupsMask.bits1

'clothDescTemplate.groupsMask.bits1' : Second part of 128-bit group mask

U32 ClothingActorParam::clothDescTemplate.groupsMask.bits2

'clothDescTemplate.groupsMask.bits2' : Third part of 128-bit group mask

U32 ClothingActorParam::clothDescTemplate.groupsMask.bits3

'clothDescTemplate.groupsMask.bits3' : Fourth part of 128-bit group mask

U64 ClothingActorParam::clothDescTemplate.userData

'clothDescTemplate.userData' : Optional user data pointer.

Bounds3 ClothingActorParam::clothDescTemplate.validBounds

'clothDescTemplate.validBounds' : Defines the volume outside of which cloth particle are automatically removed from the simulation.

Only works if the flag NX_CLF_VALIDBOUNDS is set.

U32 ClothingActorParam::clothingMaterialIndex

'clothingMaterialIndex' : Use this material from the assets material library

Bool ClothingActorParam::fallbackSkinning

'fallbackSkinning' : Performs skinning in software

Performs the regular boneweighted skinning on the CPU before giving the data out through the rendering API.

Bool ClothingActorParam::flags.ComputePhysicsMeshNormals

'flags.ComputePhysicsMeshNormals' : If set to false the normals on the physics mesh are not computed. Disable skinning and normal calculation is done outside of APEX.

Bool ClothingActorParam::flags.ComputeRenderData

'flags.ComputeRenderData' : If set to false no skinning is done for this actor. Disable if all skinning is done outside of APEX.

Bool ClothingActorParam::flags.CorrectSimulationNormals

'flags.CorrectSimulationNormals' :

The MaxDistance=0 vertices can have a perturbed simulation normal. This usually happens only for meshes where the MaxDistance=0 vertices are somewhere in the middle separating a simulated and non-simulated region. The normal for those vertices will be computed only by the simulated triangles which can lead to wrong results. This solution will use the normals from the original simulation mesh and skin them with respect to the local pose.

Bool ClothingActorParam::flags.ParallelCpuSkinning

'flags.ParallelCpuSkinning' : Determines whether or not to perform CPU skinning in parallel

All graphical vertices without correspondence to physical vertices or triangles are skinned normally. This flag specifies whether this happens during Physics scene simulation, or after. Note: If this flag is set, an inconsistency can arise when calling NxClothingActor::updateRenderResource in between NxApexScene::simulate and NxApexScene::fetchResults. As a workaround, you should only call NxClothingActor::updateRenderResources _after_ NxApexScene::fetchResults has terminated.

Bool ClothingActorParam::flags.RecomputeNormals

'flags.RecomputeNormals' : Fully recomputes the normals on the final mesh.

This usually leads to better looking results, but is more expensive to compute. Default is off.

Bool ClothingActorParam::flags.RecomputeTangents

'flags.RecomputeTangents' : Fully recomputes the tangents on the final mesh.

RecomputeTangents can only be set to false if less than half of the graphics mesh vertices have an exact match in the physics mesh. Otherwise it's always on.

Bool ClothingActorParam::flags.Visualize

'flags.Visualize' : Determines whether or not to display debug visualization for this clothing actor

Bool ClothingActorParam::freezeByLOD

'freezeByLOD' : Cloth state frozen when LoD turns off simulation of the actor, instead of returning to the animated state.

Mat44 ClothingActorParam::globalPose

'globalPose' : The pose where the clothing asset will be put into the scene

Bool ClothingActorParam::localSpaceSim

'localSpaceSim' : Do simulation in local space.

If this flag is enabled the simulation is done at origin, however the cloth is rendered at its global position. The simulation of the actor is transformed such that the root bone ends up at origin. The scale of the actor is maintained during the simulation. If a 3.x physX simulation backend is used, it is possible to add the inertia effects to the simulation, through the inertiaScale parameter of the clothing material. So with an inertiaScale of 1.0 there should be no visible difference between local space and global space simulation. Known issues: - PhysX 2.8.4 does not support inertiaScale (it corresponds to inertiaScale=0.0f). So if localSpaceSim is enabled there's no inertia effect when the global pose of the clothing actor changes. - With 2.8.4 this only works for clothing on 1 character, without world collision. This is because collision volumes would interfere with the cloth that is simulated at origin. This is not a problem in 3.x because there collision only happens with the collision volumes specifically defined for the clothing actor.

F32 ClothingActorParam::lodWeights.benefitsBias

'lodWeights.benefitsBias' : Benefits bias

F32 ClothingActorParam::lodWeights.bias

'lodWeights.bias' : Bias

F32 ClothingActorParam::lodWeights.distanceWeight

'lodWeights.distanceWeight' : Distance weight

F32 ClothingActorParam::lodWeights.maxDistance

'lodWeights.maxDistance' : Maximum distance

F32 ClothingActorParam::maxDistanceBlendTime

'maxDistanceBlendTime' : Time in seconds how long it takes to go from zero maxDistance to full maxDistance

Note: This also influences how quickly different physical LoDs can be switched

Bool ClothingActorParam::maxDistanceScale.Multipliable

'maxDistanceScale.Multipliable' : Multipliable

F32 ClothingActorParam::maxDistanceScale.Scale

'maxDistanceScale.Scale' : Scale

Vec3 ClothingActorParam::morphDisplacements[]

'morphDisplacements[]' : Displacements according to the current morph target.

Vec3 ClothingActorParam::morphGraphicalMeshNewPositions[]

'morphGraphicalMeshNewPositions[]' : New positions of all submeshes of all graphical meshes.

Vec3 ClothingActorParam::morphPhysicalMeshNewPositions[]

'morphPhysicalMeshNewPositions[]' : New positions for the physical meshes and convex collision volumes.

Bool ClothingActorParam::multiplyGlobalPoseIntoBones

'multiplyGlobalPoseIntoBones' : Enable/disable multiplying global pose into bones

String ClothingActorParam::overrideMaterialNames[]

'overrideMaterialNames[]' : Replacement material names for the ones provided by the render mesh asset inside the clothing asset.

F32 ClothingActorParam::pressure

'pressure' : Set pressure of cloth, only works on closed meshes.

ClothingCookedParam ClothingActorParam::runtimeCooked

'runtimeCooked' :

U16 ClothingActorParam::shapeDescTemplate.collisionGroup

'shapeDescTemplate.collisionGroup' : Sets which collision group this shape is part of.

Default group is 0. Maximum possible group is 31. Collision groups are sets of shapes which may or may not be set to collision detect with each other; this can be set using NxScene::setGroupCollisionFlag() Sleeping: Does NOT wake the associated actor up automatically.

Bool ClothingActorParam::shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION

'shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION' : Disable collision detection for this shape (counterpart of NX_AF_DISABLE_COLLISION)

Bool ClothingActorParam::shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING

'shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING' : Disable raycasting for this shape

Bool ClothingActorParam::shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES

'shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES' : Disable participation in ray casts, overlap tests and sweeps.

Setting this to true will make the non-compartment CPU cloth not work.

Bool ClothingActorParam::shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD

'shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD' : Enable dynamic-dynamic CCD for this shape. Used only when CCD is globally enabled and shape have a CCD skeleton.

Bool ClothingActorParam::shapeDescTemplate.flags.NX_SF_VISUALIZATION

'shapeDescTemplate.flags.NX_SF_VISUALIZATION' : Enable debug renderer for this shape

U32 ClothingActorParam::shapeDescTemplate.groupsMask.bits0

'shapeDescTemplate.groupsMask.bits0' : First part of 128-bit group mask

U32 ClothingActorParam::shapeDescTemplate.groupsMask.bits1

'shapeDescTemplate.groupsMask.bits1' : Second part of 128-bit group mask

U32 ClothingActorParam::shapeDescTemplate.groupsMask.bits2

'shapeDescTemplate.groupsMask.bits2' : Third part of 128-bit group mask

U32 ClothingActorParam::shapeDescTemplate.groupsMask.bits3

'shapeDescTemplate.groupsMask.bits3' : Fourth part of 128-bit group mask

U16 ClothingActorParam::shapeDescTemplate.materialIndex

'shapeDescTemplate.materialIndex' : The material index of the shape.

U64 ClothingActorParam::shapeDescTemplate.name

'shapeDescTemplate.name' : Name of the shapes; must be set by the application and must be a persistent pointer.

U64 ClothingActorParam::shapeDescTemplate.userData

'shapeDescTemplate.userData' : Optional user data pointer

SimulationBackend ClothingActorParam::simulationBackend

'simulationBackend' : Select which backend should be used. 'ForceNative' will only work when running with the 2.8.x PhysX SDK

Bool ClothingActorParam::slowStart

'slowStart' : Prevents from having full max distance right from the start

The first time a NxClothingActor starts to be simulated is with full max distance. This prevents starting with full max distance and instead blending in as it will do the second time.

I32 ClothingActorParam::teleportMode

'teleportMode' : Buffered teleport state for the next simulate call, gets set in updateState, is reset to Continuous during simulate().

0 = ClothingTeleportMode::Continuous 1 = ClothingTeleportMode::Teleport 2 = ClothingTeleportMode::TeleportAndReset

Bool ClothingActorParam::updateStateWithGlobalMatrices

'updateStateWithGlobalMatrices' : Use world space matrices instead of composite (relative to bind pose) in NxClothingActor::updateState().

Depending on what matrices are present, the state can be updated using global world or object space bone matrices or composite matrices. The composite matrix can be generated by multiplying the world or object space matrix by the inverse bone bine pose. Note: If there are problems which might be caused by bind poses being different in the ClothingAsset and in the game's animation system, changing this to true (and thus providing global pose matrices) might fix the problem.

Bool ClothingActorParam::useHardwareCloth

'useHardwareCloth' : Turns on hardware acceleration for the cloth simulation

Bool ClothingActorParam::useInternalBoneOrder

'useInternalBoneOrder' : Expect internally ordered bone arrays in updateState call.

If this is set to true the bone buffers in updateState and the actor descriptor have to be given in the same order as the bones are stored internally in the asset. This can be queried using NxClothingAsset::getNumUsedBones and NxClothingAsset::getBoneName or NxClothingAsset::getBoneMapping. If this is set to false, the bone buffers can be provided in the order as they are stored in the application. This is either the bone order at authoring time, or NxClothingAsset::remapBoneIndex can be called for each bone to let APEX know about the current ordering in the game. Note that this is only recommended if the application already uses physx::PxMat44 (or something binary equivalent) and does not have to convert the matrices.

U64 ClothingActorParam::userData

'userData' : Optional user data pointer associated with the clothing actor

Bool ClothingActorParam::useVelocityClamping

'useVelocityClamping' : Enable/disable velocity clamping

U32 ClothingActorParam::uvChannelForTangentUpdate

'uvChannelForTangentUpdate' : This UV channel is used for updating tangent space

Tangent update is done based on one UV channel. This allows selection of what UV channel is being used.

Bounds3 ClothingActorParam::vertexVelocityClamp

'vertexVelocityClamp' : Vertex velocity clamping values

F32 ClothingActorParam::windParams.Adaption

'windParams.Adaption' : The rate of adaption. The higher this value, the faster the cloth reaches the wind velocity. Set to 0 to turn off wind.

This is roughly the inverse of the time in seconds it takes to adapt to the wind velocity.

Vec3 ClothingActorParam::windParams.Velocity

'windParams.Velocity' : The target velocity each vertex tries to achieve.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ClothingActorParam Member List
This is the complete list of members for ClothingActorParam, including all inherited members.
actorDescTemplate.name | ClothingActorParam
actorDescTemplate.userData | ClothingActorParam
actorScale | ClothingActorParam
allowAdaptiveTargetFrequency | ClothingActorParam
boneMatrices[] | ClothingActorParam
clothDescTemplate.collisionGroup | ClothingActorParam
clothDescTemplate.collisionResponseCoefficient | ClothingActorParam
clothDescTemplate.compartment | ClothingActorParam
clothDescTemplate.groupsMask.bits0 | ClothingActorParam
clothDescTemplate.groupsMask.bits1 | ClothingActorParam
clothDescTemplate.groupsMask.bits2 | ClothingActorParam
clothDescTemplate.groupsMask.bits3 | ClothingActorParam
clothDescTemplate.userData | ClothingActorParam
clothDescTemplate.validBounds | ClothingActorParam
clothingMaterialIndex | ClothingActorParam
fallbackSkinning | ClothingActorParam
flags.ComputePhysicsMeshNormals | ClothingActorParam
flags.ComputeRenderData | ClothingActorParam
flags.CorrectSimulationNormals | ClothingActorParam
flags.ParallelCpuSkinning | ClothingActorParam
flags.RecomputeNormals | ClothingActorParam
flags.RecomputeTangents | ClothingActorParam
flags.Visualize | ClothingActorParam
freezeByLOD | ClothingActorParam
globalPose | ClothingActorParam
localSpaceSim | ClothingActorParam
lodWeights.benefitsBias | ClothingActorParam
lodWeights.bias | ClothingActorParam
lodWeights.distanceWeight | ClothingActorParam
lodWeights.maxDistance | ClothingActorParam
maxDistanceBlendTime | ClothingActorParam
maxDistanceScale.Multipliable | ClothingActorParam
maxDistanceScale.Scale | ClothingActorParam
morphDisplacements[] | ClothingActorParam
morphGraphicalMeshNewPositions[] | ClothingActorParam
morphPhysicalMeshNewPositions[] | ClothingActorParam
multiplyGlobalPoseIntoBones | ClothingActorParam
overrideMaterialNames[] | ClothingActorParam
pressure | ClothingActorParam
runtimeCooked | ClothingActorParam
shapeDescTemplate.collisionGroup | ClothingActorParam
shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION | ClothingActorParam
shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING | ClothingActorParam
shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES | ClothingActorParam
shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD | ClothingActorParam
shapeDescTemplate.flags.NX_SF_VISUALIZATION | ClothingActorParam
shapeDescTemplate.groupsMask.bits0 | ClothingActorParam
shapeDescTemplate.groupsMask.bits1 | ClothingActorParam
shapeDescTemplate.groupsMask.bits2 | ClothingActorParam
shapeDescTemplate.groupsMask.bits3 | ClothingActorParam
shapeDescTemplate.materialIndex | ClothingActorParam
shapeDescTemplate.name | ClothingActorParam
shapeDescTemplate.userData | ClothingActorParam
simulationBackend | ClothingActorParam
slowStart | ClothingActorParam
teleportMode | ClothingActorParam
updateStateWithGlobalMatrices | ClothingActorParam
useHardwareCloth | ClothingActorParam
useInternalBoneOrder | ClothingActorParam
userData | ClothingActorParam
useVelocityClamping | ClothingActorParam
uvChannelForTangentUpdate | ClothingActorParam
vertexVelocityClamp | ClothingActorParam
windParams.Adaption | ClothingActorParam
windParams.Velocity | ClothingActorParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ClothingAssetParameters Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
ClothingAssetParameters Struct Reference

Describes the NxParameterized::Interface for 'ClothingAssetParameters' : More...

#include <params.h>

List of all members.

Classes

union | CookedData

Public Attributes

ClothingPhysicalMeshParameters physicalMeshes[]
'physicalMeshes[]' :
ClothingGraphicalLodParameters graphicalLods[]
'graphicalLods[]' :
U32 | simulation.hierarchicalLevels
'simulation.hierarchicalLevels' : The number of cloth hierarhies. Only used to prevent stretching
F32 | simulation.thickness
'simulation.thickness' : Minimal amount of separation between cloth particles and collision volumes.
F32 | simulation.virtualParticleDensity
'simulation.virtualParticleDensity' : Select the amount of virtual particles generated.
Vec3 | simulation.gravityDirection
'simulation.gravityDirection' : Direction of gravity for this asset.
F32 | simulation.sleepLinearVelocity
'simulation.sleepLinearVelocity' : Clothing will fall asleep if every vertex is slower than this velocity
Bool | simulation.disableCCD
'simulation.disableCCD' : Turn off CCD when colliding cloth particles with collision volumes
Bool | simulation.untangling
'simulation.untangling' : EXPERIMENTAL: Untangle Cloth when it's entangled.
Bool | simulation.twowayInteraction
'simulation.twowayInteraction' : Make use of twoway interaction
F32 | simulation.restLengthScale
'simulation.restLengthScale' : Scale for cloth rest lengths.
I32 | bones[].internalIndex
'bones[].internalIndex' : The index used internally for this bone.
I32 | bones[].externalIndex
'bones[].externalIndex' : The index that was given by the application
U32 | bones[].numMeshReferenced
'bones[].numMeshReferenced' : The number of mesh vertices that have a non-zero weight to this bone.
U32 | bones[].numRigidBodiesReferenced
'bones[].numRigidBodiesReferenced' : The number of collision volumes attached to this bone
I32 | bones[].parentIndex
'bones[].parentIndex' : The (internal) index of the parent bone
Mat34 | bones[].bindPose
'bones[].bindPose' : The matrix this bone has in the default pose
String | bones[].name
'bones[].name' : The name of this bone
U32 | bonesReferenced
'bonesReferenced' : Number of bones actually used by any of the meshes or collision volumes.
U32 | bonesReferencedByMesh
'bonesReferencedByMesh' : Number of bones actually used by any of the meshes
U32 | rootBoneIndex
'rootBoneIndex' : Internal bone index with either parent=-1 or one bone with minimal distance to root when root is not inside the used bones
I32 | boneActors[].boneIndex
'boneActors[].boneIndex' : The (internal) index this collision volume is attached to
U32 | boneActors[].convexVerticesStart
'boneActors[].convexVerticesStart' : Index into the boneVertices array where the list of vertices for this shape starts.
U32 | boneActors[].convexVerticesCount
'boneActors[].convexVerticesCount' : The number vertices that make up this convex.
F32 | boneActors[].capsuleRadius
'boneActors[].capsuleRadius' : The radius of the capsule that describes this collision volume.
F32 | boneActors[].capsuleHeight
'boneActors[].capsuleHeight' : The height of the capsule that describes this collision volume.
Mat34 | boneActors[].localPose
'boneActors[].localPose' : The pose this collision volume has relative to the bone.
Vec3 | boneVertices[]
'boneVertices[]' : Array of vertices that belong to one or more convex collision volumes
I32 | boneSpheres[].boneIndex
'boneSpheres[].boneIndex' : The (internal) index this collision volume is attached to
F32 | boneSpheres[].radius
'boneSpheres[].radius' : The radius of the sphere that describes this collision volume.
Vec3 | boneSpheres[].localPos
'boneSpheres[].localPos' : The position this collision volume has relative to the bone.
U16 | boneSphereConnections[]
'boneSphereConnections[]' : Array of indices into the boneSpheres array to describe pairs of spheres that form a capsule.
I32 | bonePlanes[].boneIndex
'bonePlanes[].boneIndex' : The (internal) index this collision volume is attached to
Vec3 | bonePlanes[].n
'bonePlanes[].n' : Plane normal.
F32 | bonePlanes[].d
'bonePlanes[].d' : Plane distance from origin.
U32 | collisionConvexes[]
'collisionConvexes[]' : Each entry is a bitmap that describes which bonePlanes are used to define a convex.
F32 | cookedData[].scale
'cookedData[].scale' :
CookedData cookedData
Bounds3 | boundingBox
'boundingBox' : The Bounding-Box of the Asset
ClothingMaterialLibraryParameters materialLibrary
'materialLibrary' :
U32 | materialIndex
'materialIndex' : Default index for the material in the library
U32 | interCollisionChannels
'interCollisionChannels' : Experimental. Collision Channels for inter-collision
String | toolString
'toolString' : Describes the authoring tool.

Detailed Description

Describes the NxParameterized::Interface for 'ClothingAssetParameters' :

ClothingAssetParameters contains 333 fully qualified names
---------------------------------------------
  1 : ArraySizeName  physicalMeshes
  2 : U32            physicalMeshes[].physicalMesh.numVertices                                                        RefVariant[ClothingPhysicalMeshParameters]
  3 : U32            physicalMeshes[].physicalMesh.numIndices                                                         RefVariant[ClothingPhysicalMeshParameters]
  4 : U32            physicalMeshes[].physicalMesh.numBonesPerVertex                                                  RefVariant[ClothingPhysicalMeshParameters]
  5 : ArraySizeName  physicalMeshes[].vertices                                                                        RefVariant[ClothingPhysicalMeshParameters]
  6 : Vec3           physicalMeshes[].physicalMesh.vertices[]                                                         RefVariant[ClothingPhysicalMeshParameters]
  7 : ArraySizeName  physicalMeshes[].normals                                                                         RefVariant[ClothingPhysicalMeshParameters]
  8 : Vec3           physicalMeshes[].physicalMesh.normals[]                                                          RefVariant[ClothingPhysicalMeshParameters]
  9 : ArraySizeName  physicalMeshes[].skinningNormals                                                                 RefVariant[ClothingPhysicalMeshParameters]
 10 : Vec3           physicalMeshes[].physicalMesh.skinningNormals[]                                                  RefVariant[ClothingPhysicalMeshParameters]
 11 : ArraySizeName  physicalMeshes[].constrainCoefficients                                                           RefVariant[ClothingPhysicalMeshParameters]
 12 : F32            physicalMeshes[].physicalMesh.constrainCoefficients[].maxDistance                                RefVariant[ClothingPhysicalMeshParameters]
 13 : F32            physicalMeshes[].physicalMesh.constrainCoefficients[].collisionSphereRadius                      RefVariant[ClothingPhysicalMeshParameters]
 14 : F32            physicalMeshes[].physicalMesh.constrainCoefficients[].collisionSphereDistance                    RefVariant[ClothingPhysicalMeshParameters]
 15 : ArraySizeName  physicalMeshes[].boneIndices                                                                     RefVariant[ClothingPhysicalMeshParameters]
 16 : U16            physicalMeshes[].physicalMesh.boneIndices[]                                                      RefVariant[ClothingPhysicalMeshParameters]
 17 : ArraySizeName  physicalMeshes[].boneWeights                                                                     RefVariant[ClothingPhysicalMeshParameters]
 18 : F32            physicalMeshes[].physicalMesh.boneWeights[]                                                      RefVariant[ClothingPhysicalMeshParameters]
 19 : ArraySizeName  physicalMeshes[].optimizationData                                                                RefVariant[ClothingPhysicalMeshParameters]
 20 : U8             physicalMeshes[].physicalMesh.optimizationData[]                                                 RefVariant[ClothingPhysicalMeshParameters]
 21 : Bool           physicalMeshes[].physicalMesh.hasNegativeBackstop                                                RefVariant[ClothingPhysicalMeshParameters]
 22 : Bool           physicalMeshes[].physicalMesh.isClosed                                                           RefVariant[ClothingPhysicalMeshParameters]
 23 : ArraySizeName  physicalMeshes[].indices                                                                         RefVariant[ClothingPhysicalMeshParameters]
 24 : U32            physicalMeshes[].physicalMesh.indices[]                                                          RefVariant[ClothingPhysicalMeshParameters]
 25 : F32            physicalMeshes[].physicalMesh.maximumMaxDistance                                                 RefVariant[ClothingPhysicalMeshParameters]
 26 : U32            physicalMeshes[].physicalMesh.physicalMeshSorting                                                RefVariant[ClothingPhysicalMeshParameters]
 27 : F32            physicalMeshes[].physicalMesh.shortestEdgeLength                                                 RefVariant[ClothingPhysicalMeshParameters]
 28 : F32            physicalMeshes[].physicalMesh.averageEdgeLength                                                  RefVariant[ClothingPhysicalMeshParameters]
 29 : Bool           physicalMeshes[].physicalMesh.isTetrahedralMesh                                                  RefVariant[ClothingPhysicalMeshParameters]
 30 : Bool           physicalMeshes[].physicalMesh.flipNormals                                                        RefVariant[ClothingPhysicalMeshParameters]
 31 : ArraySizeName  physicalMeshes[].submeshes                                                                       RefVariant[ClothingPhysicalMeshParameters]
 32 : U32            physicalMeshes[].submeshes[].numIndices                                                          RefVariant[ClothingPhysicalMeshParameters]
 33 : U32            physicalMeshes[].submeshes[].numVertices                                                         RefVariant[ClothingPhysicalMeshParameters]
 34 : U32            physicalMeshes[].submeshes[].numMaxDistance0Vertices                                             RefVariant[ClothingPhysicalMeshParameters]
 35 : ArraySizeName  physicalMeshes[].physicalLods                                                                    RefVariant[ClothingPhysicalMeshParameters]
 36 : U32            physicalMeshes[].physicalLods[].costWithoutIterations                                            RefVariant[ClothingPhysicalMeshParameters]
 37 : U32            physicalMeshes[].physicalLods[].submeshId                                                        RefVariant[ClothingPhysicalMeshParameters]
 38 : F32            physicalMeshes[].physicalLods[].solverIterationScale                                             RefVariant[ClothingPhysicalMeshParameters]
 39 : F32            physicalMeshes[].physicalLods[].maxDistanceReduction                                             RefVariant[ClothingPhysicalMeshParameters]
 40 : ArraySizeName  physicalMeshes[].transitionUpB                                                                   RefVariant[ClothingPhysicalMeshParameters]
 41 : Vec3           physicalMeshes[].transitionUpB[].vtxTetraBary                                                    RefVariant[ClothingPhysicalMeshParameters]
 42 : U32            physicalMeshes[].transitionUpB[].vertexIndexPlusOffset                                           RefVariant[ClothingPhysicalMeshParameters]
 43 : Vec3           physicalMeshes[].transitionUpB[].nrmTetraBary                                                    RefVariant[ClothingPhysicalMeshParameters]
 44 : U32            physicalMeshes[].transitionUpB[].faceIndex0                                                      RefVariant[ClothingPhysicalMeshParameters]
 45 : U32            physicalMeshes[].transitionUpB[].tetraIndex                                                      RefVariant[ClothingPhysicalMeshParameters]
 46 : U32            physicalMeshes[].transitionUpB[].submeshIndex                                                    RefVariant[ClothingPhysicalMeshParameters]
 47 : ArraySizeName  physicalMeshes[].transitionUp                                                                    RefVariant[ClothingPhysicalMeshParameters]
 48 : Vec3           physicalMeshes[].transitionUp[].vertexBary                                                       RefVariant[ClothingPhysicalMeshParameters]
 49 : U32            physicalMeshes[].transitionUp[].vertexIndex0                                                     RefVariant[ClothingPhysicalMeshParameters]
 50 : Vec3           physicalMeshes[].transitionUp[].normalBary                                                       RefVariant[ClothingPhysicalMeshParameters]
 51 : U32            physicalMeshes[].transitionUp[].vertexIndex1                                                     RefVariant[ClothingPhysicalMeshParameters]
 52 : Vec3           physicalMeshes[].transitionUp[].tangentBary                                                      RefVariant[ClothingPhysicalMeshParameters]
 53 : U32            physicalMeshes[].transitionUp[].vertexIndex2                                                     RefVariant[ClothingPhysicalMeshParameters]
 54 : U32            physicalMeshes[].transitionUp[].vertexIndexPlusOffset                                            RefVariant[ClothingPhysicalMeshParameters]
 55 : F32            physicalMeshes[].transitionUpThickness                                                           RefVariant[ClothingPhysicalMeshParameters]
 56 : F32            physicalMeshes[].transitionUpOffset                                                              RefVariant[ClothingPhysicalMeshParameters]
 57 : ArraySizeName  physicalMeshes[].transitionDownB                                                                 RefVariant[ClothingPhysicalMeshParameters]
 58 : Vec3           physicalMeshes[].transitionDownB[].vtxTetraBary                                                  RefVariant[ClothingPhysicalMeshParameters]
 59 : U32            physicalMeshes[].transitionDownB[].vertexIndexPlusOffset                                         RefVariant[ClothingPhysicalMeshParameters]
 60 : Vec3           physicalMeshes[].transitionDownB[].nrmTetraBary                                                  RefVariant[ClothingPhysicalMeshParameters]
 61 : U32            physicalMeshes[].transitionDownB[].faceIndex0                                                    RefVariant[ClothingPhysicalMeshParameters]
 62 : U32            physicalMeshes[].transitionDownB[].tetraIndex                                                    RefVariant[ClothingPhysicalMeshParameters]
 63 : U32            physicalMeshes[].transitionDownB[].submeshIndex                                                  RefVariant[ClothingPhysicalMeshParameters]
 64 : ArraySizeName  physicalMeshes[].transitionDown                                                                  RefVariant[ClothingPhysicalMeshParameters]
 65 : Vec3           physicalMeshes[].transitionDown[].vertexBary                                                     RefVariant[ClothingPhysicalMeshParameters]
 66 : U32            physicalMeshes[].transitionDown[].vertexIndex0                                                   RefVariant[ClothingPhysicalMeshParameters]
 67 : Vec3           physicalMeshes[].transitionDown[].normalBary                                                     RefVariant[ClothingPhysicalMeshParameters]
 68 : U32            physicalMeshes[].transitionDown[].vertexIndex1                                                   RefVariant[ClothingPhysicalMeshParameters]
 69 : Vec3           physicalMeshes[].transitionDown[].tangentBary                                                    RefVariant[ClothingPhysicalMeshParameters]
 70 : U32            physicalMeshes[].transitionDown[].vertexIndex2                                                   RefVariant[ClothingPhysicalMeshParameters]
 71 : U32            physicalMeshes[].transitionDown[].vertexIndexPlusOffset                                          RefVariant[ClothingPhysicalMeshParameters]
 72 : F32            physicalMeshes[].transitionDownThickness                                                         RefVariant[ClothingPhysicalMeshParameters]
 73 : F32            physicalMeshes[].transitionDownOffset                                                            RefVariant[ClothingPhysicalMeshParameters]
 74 : U32            physicalMeshes[].referenceCount                                                                  RefVariant[ClothingPhysicalMeshParameters]
 75 : ArraySizeName  graphicalLods
 76 : ArraySizeName  graphicalLods[].platforms                                                                        RefVariant[ClothingGraphicalLodParameters]
 77 : String         graphicalLods[].platforms[]                                                                      RefVariant[ClothingGraphicalLodParameters]
 78 : U32            graphicalLods[].lod                                                                              RefVariant[ClothingGraphicalLodParameters]
 79 : U32            graphicalLods[].physicalMeshId                                                                   RefVariant[ClothingGraphicalLodParameters]
 80 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes                                                        RefVariant[RenderMeshAssetParameters]
 81 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.vertexCount                             RefVariant[VertexBufferParameters]
 82 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.winding                    RefVariant[VertexFormatParameters]
 83 : Bool           graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.hasSeparateBoneBuffer      RefVariant[VertexFormatParameters]
 84 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats              RefVariant[VertexFormatParameters]
 85 : String         graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].name       RefVariant[VertexFormatParameters]
 86 : I32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].semantic   RefVariant[VertexFormatParameters]
 87 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].id         RefVariant[VertexFormatParameters]
 88 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].format     RefVariant[VertexFormatParameters]
 89 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].access     RefVariant[VertexFormatParameters]
 90 : Bool           graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].serialize  RefVariant[VertexFormatParameters]
 91 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers                                 RefVariant[VertexBufferParameters]
 92 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU8x1]
 93 : U8             graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferU8x1]
 94 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU8x2]
 95 : U8             graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU8x2]
 96 : U8             graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU8x2]
 97 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU8x3]
 98 : U8             graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU8x3]
 99 : U8             graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU8x3]
100 : U8             graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU8x3]
101 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU8x4]
102 : U8             graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU8x4]
103 : U8             graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU8x4]
104 : U8             graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU8x4]
105 : U8             graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].w                      RefVariant[BufferU8x4]
106 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU16x1]
107 : U16            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferU16x1]
108 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU16x2]
109 : U16            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU16x2]
110 : U16            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU16x2]
111 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU16x3]
112 : U16            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU16x3]
113 : U16            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU16x3]
114 : U16            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU16x3]
115 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU16x4]
116 : U16            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU16x4]
117 : U16            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU16x4]
118 : U16            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU16x4]
119 : U16            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].w                      RefVariant[BufferU16x4]
120 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU32x1]
121 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferU32x1]
122 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU32x2]
123 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU32x2]
124 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU32x2]
125 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU32x3]
126 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU32x3]
127 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU32x3]
128 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU32x3]
129 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU32x4]
130 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU32x4]
131 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU32x4]
132 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU32x4]
133 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].w                      RefVariant[BufferU32x4]
134 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferF32x1]
135 : F32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferF32x1]
136 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferF32x2]
137 : F32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferF32x2]
138 : F32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferF32x2]
139 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferF32x3]
140 : Vec3           graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferF32x3]
141 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferF32x4]
142 : F32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferF32x4]
143 : F32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferF32x4]
144 : F32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferF32x4]
145 : F32            graphicalLods[].renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].w                      RefVariant[BufferF32x4]
146 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].indexBuffer                                          RefVariant[SubmeshParameters]
147 : U32            graphicalLods[].renderMeshAsset.submeshes[].indexBuffer[]                                        RefVariant[SubmeshParameters]
148 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].vertexPartition                                      RefVariant[SubmeshParameters]
149 : U32            graphicalLods[].renderMeshAsset.submeshes[].vertexPartition[]                                    RefVariant[SubmeshParameters]
150 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].indexPartition                                       RefVariant[SubmeshParameters]
151 : U32            graphicalLods[].renderMeshAsset.submeshes[].indexPartition[]                                     RefVariant[SubmeshParameters]
152 : ArraySizeName  graphicalLods[].renderMeshAsset.submeshes[].smoothingGroups                                      RefVariant[SubmeshParameters]
153 : U32            graphicalLods[].renderMeshAsset.submeshes[].smoothingGroups[]                                    RefVariant[SubmeshParameters]
154 : ArraySizeName  graphicalLods[].renderMeshAsset.materialNames                                                    RefVariant[RenderMeshAssetParameters]
155 : String         graphicalLods[].renderMeshAsset.materialNames[]                                                  RefVariant[RenderMeshAssetParameters]
156 : ArraySizeName  graphicalLods[].renderMeshAsset.partBounds                                                       RefVariant[RenderMeshAssetParameters]
157 : Bounds3        graphicalLods[].renderMeshAsset.partBounds[]                                                     RefVariant[RenderMeshAssetParameters]
158 : U32            graphicalLods[].renderMeshAsset.textureUVOrigin                                                  RefVariant[RenderMeshAssetParameters]
159 : U32            graphicalLods[].renderMeshAsset.boneCount                                                        RefVariant[RenderMeshAssetParameters]
160 : Bool           graphicalLods[].renderMeshAsset.deleteStaticBuffersAfterUse                                      RefVariant[RenderMeshAssetParameters]
161 : Bool           graphicalLods[].renderMeshAsset.isReferenced                                                     RefVariant[RenderMeshAssetParameters]
162 : ArraySizeName  graphicalLods[].immediateClothMap                                                                RefVariant[ClothingGraphicalLodParameters]
163 : U32            graphicalLods[].immediateClothMap[]                                                              RefVariant[ClothingGraphicalLodParameters]
164 : ArraySizeName  graphicalLods[].skinClothMapB                                                                    RefVariant[ClothingGraphicalLodParameters]
165 : Vec3           graphicalLods[].skinClothMapB[].vtxTetraBary                                                     RefVariant[ClothingGraphicalLodParameters]
166 : U32            graphicalLods[].skinClothMapB[].vertexIndexPlusOffset                                            RefVariant[ClothingGraphicalLodParameters]
167 : Vec3           graphicalLods[].skinClothMapB[].nrmTetraBary                                                     RefVariant[ClothingGraphicalLodParameters]
168 : U32            graphicalLods[].skinClothMapB[].faceIndex0                                                       RefVariant[ClothingGraphicalLodParameters]
169 : U32            graphicalLods[].skinClothMapB[].tetraIndex                                                       RefVariant[ClothingGraphicalLodParameters]
170 : U32            graphicalLods[].skinClothMapB[].submeshIndex                                                     RefVariant[ClothingGraphicalLodParameters]
171 : ArraySizeName  graphicalLods[].skinClothMap                                                                     RefVariant[ClothingGraphicalLodParameters]
172 : Vec3           graphicalLods[].skinClothMap[].vertexBary                                                        RefVariant[ClothingGraphicalLodParameters]
173 : U32            graphicalLods[].skinClothMap[].vertexIndex0                                                      RefVariant[ClothingGraphicalLodParameters]
174 : Vec3           graphicalLods[].skinClothMap[].normalBary                                                        RefVariant[ClothingGraphicalLodParameters]
175 : U32            graphicalLods[].skinClothMap[].vertexIndex1                                                      RefVariant[ClothingGraphicalLodParameters]
176 : Vec3           graphicalLods[].skinClothMap[].tangentBary                                                       RefVariant[ClothingGraphicalLodParameters]
177 : U32            graphicalLods[].skinClothMap[].vertexIndex2                                                      RefVariant[ClothingGraphicalLodParameters]
178 : U32            graphicalLods[].skinClothMap[].vertexIndexPlusOffset                                             RefVariant[ClothingGraphicalLodParameters]
179 : F32            graphicalLods[].skinClothMapThickness                                                            RefVariant[ClothingGraphicalLodParameters]
180 : F32            graphicalLods[].skinClothMapOffset                                                               RefVariant[ClothingGraphicalLodParameters]
181 : ArraySizeName  graphicalLods[].tetraMap                                                                         RefVariant[ClothingGraphicalLodParameters]
182 : Vec3           graphicalLods[].tetraMap[].vertexBary                                                            RefVariant[ClothingGraphicalLodParameters]
183 : U32            graphicalLods[].tetraMap[].tetraIndex0                                                           RefVariant[ClothingGraphicalLodParameters]
184 : Vec3           graphicalLods[].tetraMap[].normalBary                                                            RefVariant[ClothingGraphicalLodParameters]
185 : U32            graphicalLods[].tetraMap[]._dummyForAlignment                                                    RefVariant[ClothingGraphicalLodParameters]
186 : U32            graphicalLods[].renderMeshAssetSorting                                                           RefVariant[ClothingGraphicalLodParameters]
187 : ArraySizeName  graphicalLods[].physicsSubmeshPartitioning                                                       RefVariant[ClothingGraphicalLodParameters]
188 : U32            graphicalLods[].physicsSubmeshPartitioning[].graphicalSubmesh                                    RefVariant[ClothingGraphicalLodParameters]
189 : U32            graphicalLods[].physicsSubmeshPartitioning[].physicalSubmesh                                     RefVariant[ClothingGraphicalLodParameters]
190 : U32            graphicalLods[].physicsSubmeshPartitioning[].numSimulatedVertices                                RefVariant[ClothingGraphicalLodParameters]
191 : U32            graphicalLods[].physicsSubmeshPartitioning[].numSimulatedVerticesAdditional                      RefVariant[ClothingGraphicalLodParameters]
192 : U32            graphicalLods[].physicsSubmeshPartitioning[].numSimulatedIndices                                 RefVariant[ClothingGraphicalLodParameters]
193 : U32            simulation.hierarchicalLevels
194 : F32            simulation.thickness
195 : F32            simulation.virtualParticleDensity
196 : Vec3           simulation.gravityDirection
197 : F32            simulation.sleepLinearVelocity
198 : Bool           simulation.disableCCD
199 : Bool           simulation.untangling
200 : Bool           simulation.twowayInteraction
201 : F32            simulation.restLengthScale
202 : ArraySizeName  bones
203 : I32            bones[].internalIndex
204 : I32            bones[].externalIndex
205 : U32            bones[].numMeshReferenced
206 : U32            bones[].numRigidBodiesReferenced
207 : I32            bones[].parentIndex
208 : Mat34          bones[].bindPose
209 : String         bones[].name
210 : U32            bonesReferenced
211 : U32            bonesReferencedByMesh
212 : U32            rootBoneIndex
213 : ArraySizeName  boneActors
214 : I32            boneActors[].boneIndex
215 : U32            boneActors[].convexVerticesStart
216 : U32            boneActors[].convexVerticesCount
217 : F32            boneActors[].capsuleRadius
218 : F32            boneActors[].capsuleHeight
219 : Mat34          boneActors[].localPose
220 : ArraySizeName  boneVertices
221 : Vec3           boneVertices[]
222 : ArraySizeName  boneSpheres
223 : I32            boneSpheres[].boneIndex
224 : F32            boneSpheres[].radius
225 : Vec3           boneSpheres[].localPos
226 : ArraySizeName  boneSphereConnections
227 : U16            boneSphereConnections[]
228 : ArraySizeName  bonePlanes
229 : I32            bonePlanes[].boneIndex
230 : Vec3           bonePlanes[].n
231 : F32            bonePlanes[].d
232 : ArraySizeName  collisionConvexes
233 : U32            collisionConvexes[]
234 : ArraySizeName  cookedData
235 : F32            cookedData[].scale
236 : F32            cookedData[].cookedData.actorScale                                                               RefVariant[ClothingCookedParam]
237 : ArraySizeName  cookedData[].cookedData.convexCookedData                                                         RefVariant[ClothingCookedParam]
238 : U8             cookedData[].cookedData.convexCookedData[]                                                       RefVariant[ClothingCookedParam]
239 : ArraySizeName  cookedData[].cookedData.convexMeshPointers                                                       RefVariant[ClothingCookedParam]
240 : ArraySizeName  cookedData[].cookedData.cookedPhysicalSubmeshes                                                  RefVariant[ClothingCookedParam]
241 : U32            cookedData[].cookedData.cookedPhysicalSubmeshes[].physicalMeshId                                 RefVariant[ClothingCookedParam]
242 : U32            cookedData[].cookedData.cookedPhysicalSubmeshes[].submeshId                                      RefVariant[ClothingCookedParam]
243 : U32            cookedData[].cookedData.cookedPhysicalSubmeshes[].cookedDataOffset                               RefVariant[ClothingCookedParam]
244 : U32            cookedData[].cookedData.cookedPhysicalSubmeshes[].cookedDataLength                               RefVariant[ClothingCookedParam]
245 : U32            cookedData[].cookedData.cookedPhysicalSubmeshes[].deformableInvParticleWeightsOffset             RefVariant[ClothingCookedParam]
246 : U32            cookedData[].cookedData.cookedPhysicalSubmeshes[].virtualParticleIndicesOffset                   RefVariant[ClothingCookedParam]
247 : U32            cookedData[].cookedData.cookedPhysicalSubmeshes[].virtualParticleIndicesLength                   RefVariant[ClothingCookedParam]
248 : ArraySizeName  cookedData[].cookedData.deformableCookedData                                                     RefVariant[ClothingCookedParam]
249 : U8             cookedData[].cookedData.deformableCookedData[]                                                   RefVariant[ClothingCookedParam]
250 : U32            cookedData[].cookedData.cookedDataVersion                                                        RefVariant[ClothingCookedParam]
251 : ArraySizeName  cookedData[].cookedData.deformableInvParticleWeights                                             RefVariant[ClothingCookedParam]
252 : F32            cookedData[].cookedData.deformableInvParticleWeights[]                                           RefVariant[ClothingCookedParam]
253 : ArraySizeName  cookedData[].cookedData.virtualParticleIndices                                                   RefVariant[ClothingCookedParam]
254 : U32            cookedData[].cookedData.virtualParticleIndices[]                                                 RefVariant[ClothingCookedParam]
255 : ArraySizeName  cookedData[].cookedData.virtualParticleWeights                                                   RefVariant[ClothingCookedParam]
256 : Vec3           cookedData[].cookedData.virtualParticleWeights[]                                                 RefVariant[ClothingCookedParam]
257 : U32            cookedData[].cookedData.physicalMeshId                                                           RefVariant[ClothingCookedPhysX3Param]
258 : U32            cookedData[].cookedData.physicalSubMeshId                                                        RefVariant[ClothingCookedPhysX3Param]
259 : U32            cookedData[].cookedData.numVertices                                                              RefVariant[ClothingCookedPhysX3Param]
260 : ArraySizeName  cookedData[].cookedData.deformableRestLengths                                                    RefVariant[ClothingCookedPhysX3Param]
261 : F32            cookedData[].cookedData.deformableRestLengths[]                                                  RefVariant[ClothingCookedPhysX3Param]
262 : ArraySizeName  cookedData[].cookedData.deformableIndices                                                        RefVariant[ClothingCookedPhysX3Param]
263 : U32            cookedData[].cookedData.deformableIndices[]                                                      RefVariant[ClothingCookedPhysX3Param]
264 : ArraySizeName  cookedData[].cookedData.selfCollisionIndices                                                     RefVariant[ClothingCookedPhysX3Param]
265 : U32            cookedData[].cookedData.selfCollisionIndices[]                                                   RefVariant[ClothingCookedPhysX3Param]
266 : ArraySizeName  cookedData[].cookedData.selfCollisionNormalIndices                                               RefVariant[ClothingCookedPhysX3Param]
267 : U32            cookedData[].cookedData.selfCollisionNormalIndices[]                                             RefVariant[ClothingCookedPhysX3Param]
268 : ArraySizeName  cookedData[].cookedData.selfCollisionNormalSetSizes                                              RefVariant[ClothingCookedPhysX3Param]
269 : U32            cookedData[].cookedData.selfCollisionNormalSetSizes[]                                            RefVariant[ClothingCookedPhysX3Param]
270 : ArraySizeName  cookedData[].cookedData.deformableSets                                                           RefVariant[ClothingCookedPhysX3Param]
271 : U32            cookedData[].cookedData.deformableSets[].fiberEnd                                                RefVariant[ClothingCookedPhysX3Param]
272 : U32            cookedData[].cookedData.deformableSets[].longestFiber                                            RefVariant[ClothingCookedPhysX3Param]
273 : U32            cookedData[].cookedData.deformableSets[].shortestFiber                                           RefVariant[ClothingCookedPhysX3Param]
274 : U32            cookedData[].cookedData.deformableSets[].numEdges                                                RefVariant[ClothingCookedPhysX3Param]
275 : F32            cookedData[].cookedData.deformableSets[].avgEdgeLength                                           RefVariant[ClothingCookedPhysX3Param]
276 : U32            cookedData[].cookedData.deformableSets[].avgFiberLength                                          RefVariant[ClothingCookedPhysX3Param]
277 : ArraySizeName  cookedData[].cookedData.deformablePhaseDescs                                                     RefVariant[ClothingCookedPhysX3Param]
278 : U32            cookedData[].cookedData.deformablePhaseDescs[].phaseType                                         RefVariant[ClothingCookedPhysX3Param]
279 : U32            cookedData[].cookedData.deformablePhaseDescs[].setIndex                                          RefVariant[ClothingCookedPhysX3Param]
280 : U32            cookedData[].cookedData.deformablePhaseDescs[].restValueOffset                                   RefVariant[ClothingCookedPhysX3Param]
281 : ArraySizeName  cookedData[].cookedData.tetherAnchors                                                            RefVariant[ClothingCookedPhysX3Param]
282 : U32            cookedData[].cookedData.tetherAnchors[]                                                          RefVariant[ClothingCookedPhysX3Param]
283 : ArraySizeName  cookedData[].cookedData.tetherLengths                                                            RefVariant[ClothingCookedPhysX3Param]
284 : F32            cookedData[].cookedData.tetherLengths[]                                                          RefVariant[ClothingCookedPhysX3Param]
285 : ArraySizeName  cookedData[].cookedData.deformableInvVertexWeights                                               RefVariant[ClothingCookedPhysX3Param]
286 : F32            cookedData[].cookedData.deformableInvVertexWeights[]                                             RefVariant[ClothingCookedPhysX3Param]
287 : ArraySizeName  cookedData[].cookedData.virtualParticleIndices                                                   RefVariant[ClothingCookedPhysX3Param]
288 : U32            cookedData[].cookedData.virtualParticleIndices[]                                                 RefVariant[ClothingCookedPhysX3Param]
289 : ArraySizeName  cookedData[].cookedData.virtualParticleWeights                                                   RefVariant[ClothingCookedPhysX3Param]
290 : F32            cookedData[].cookedData.virtualParticleWeights[]                                                 RefVariant[ClothingCookedPhysX3Param]
291 : U32            cookedData[].cookedData.cookedDataVersion                                                        RefVariant[ClothingCookedPhysX3Param]
292 : ArraySizeName  cookedData[].cookedData.fabricGPU                                                                RefVariant[ClothingCookedPhysX3Param]
293 : Bounds3        boundingBox
294 : ArraySizeName  materialLibrary.materials                                                                        RefVariant[ClothingMaterialLibraryParameters]
295 : String         materialLibrary.materials[].materialName                                                         RefVariant[ClothingMaterialLibraryParameters]
296 : F32            materialLibrary.materials[].verticalStretchingStiffness                                          RefVariant[ClothingMaterialLibraryParameters]
297 : F32            materialLibrary.materials[].horizontalStretchingStiffness                                        RefVariant[ClothingMaterialLibraryParameters]
298 : F32            materialLibrary.materials[].bendingStiffness                                                     RefVariant[ClothingMaterialLibraryParameters]
299 : F32            materialLibrary.materials[].shearingStiffness                                                    RefVariant[ClothingMaterialLibraryParameters]
300 : F32            materialLibrary.materials[].tetherStiffness                                                      RefVariant[ClothingMaterialLibraryParameters]
301 : F32            materialLibrary.materials[].tetherLimit                                                          RefVariant[ClothingMaterialLibraryParameters]
302 : Bool           materialLibrary.materials[].orthoBending                                                         RefVariant[ClothingMaterialLibraryParameters]
303 : F32            materialLibrary.materials[].verticalStiffnessScaling.compressionRange                            RefVariant[ClothingMaterialLibraryParameters]
304 : F32            materialLibrary.materials[].verticalStiffnessScaling.stretchRange                                RefVariant[ClothingMaterialLibraryParameters]
305 : F32            materialLibrary.materials[].verticalStiffnessScaling.scale                                       RefVariant[ClothingMaterialLibraryParameters]
306 : F32            materialLibrary.materials[].horizontalStiffnessScaling.compressionRange                          RefVariant[ClothingMaterialLibraryParameters]
307 : F32            materialLibrary.materials[].horizontalStiffnessScaling.stretchRange                              RefVariant[ClothingMaterialLibraryParameters]
308 : F32            materialLibrary.materials[].horizontalStiffnessScaling.scale                                     RefVariant[ClothingMaterialLibraryParameters]
309 : F32            materialLibrary.materials[].bendingStiffnessScaling.compressionRange                             RefVariant[ClothingMaterialLibraryParameters]
310 : F32            materialLibrary.materials[].bendingStiffnessScaling.stretchRange                                 RefVariant[ClothingMaterialLibraryParameters]
311 : F32            materialLibrary.materials[].bendingStiffnessScaling.scale                                        RefVariant[ClothingMaterialLibraryParameters]
312 : F32            materialLibrary.materials[].shearingStiffnessScaling.compressionRange                            RefVariant[ClothingMaterialLibraryParameters]
313 : F32            materialLibrary.materials[].shearingStiffnessScaling.stretchRange                                RefVariant[ClothingMaterialLibraryParameters]
314 : F32            materialLibrary.materials[].shearingStiffnessScaling.scale                                       RefVariant[ClothingMaterialLibraryParameters]
315 : F32            materialLibrary.materials[].damping                                                              RefVariant[ClothingMaterialLibraryParameters]
316 : F32            materialLibrary.materials[].stiffnessFrequency                                                   RefVariant[ClothingMaterialLibraryParameters]
317 : F32            materialLibrary.materials[].drag                                                                 RefVariant[ClothingMaterialLibraryParameters]
318 : Bool           materialLibrary.materials[].comDamping                                                           RefVariant[ClothingMaterialLibraryParameters]
319 : F32            materialLibrary.materials[].friction                                                             RefVariant[ClothingMaterialLibraryParameters]
320 : F32            materialLibrary.materials[].massScale                                                            RefVariant[ClothingMaterialLibraryParameters]
321 : U32            materialLibrary.materials[].solverIterations                                                     RefVariant[ClothingMaterialLibraryParameters]
322 : F32            materialLibrary.materials[].solverFrequency                                                      RefVariant[ClothingMaterialLibraryParameters]
323 : F32            materialLibrary.materials[].gravityScale                                                         RefVariant[ClothingMaterialLibraryParameters]
324 : F32            materialLibrary.materials[].inertiaScale                                                         RefVariant[ClothingMaterialLibraryParameters]
325 : F32            materialLibrary.materials[].hardStretchLimitation                                                RefVariant[ClothingMaterialLibraryParameters]
326 : F32            materialLibrary.materials[].maxDistanceBias                                                      RefVariant[ClothingMaterialLibraryParameters]
327 : U32            materialLibrary.materials[].hierarchicalSolverIterations                                         RefVariant[ClothingMaterialLibraryParameters]
328 : F32            materialLibrary.materials[].selfcollisionThickness                                               RefVariant[ClothingMaterialLibraryParameters]
329 : F32            materialLibrary.materials[].selfcollisionSquashScale                                             RefVariant[ClothingMaterialLibraryParameters]
330 : F32            materialLibrary.materials[].selfcollisionStiffness                                               RefVariant[ClothingMaterialLibraryParameters]
331 : U32            materialIndex
332 : U32            interCollisionChannels
333 : String         toolString

Member Data Documentation

I32 ClothingAssetParameters::boneActors[].boneIndex

'boneActors[].boneIndex' : The (internal) index this collision volume is attached to

F32 ClothingAssetParameters::boneActors[].capsuleHeight

'boneActors[].capsuleHeight' : The height of the capsule that describes this collision volume.

F32 ClothingAssetParameters::boneActors[].capsuleRadius

'boneActors[].capsuleRadius' : The radius of the capsule that describes this collision volume.

U32 ClothingAssetParameters::boneActors[].convexVerticesCount

'boneActors[].convexVerticesCount' : The number vertices that make up this convex.

U32 ClothingAssetParameters::boneActors[].convexVerticesStart

'boneActors[].convexVerticesStart' : Index into the boneVertices array where the list of vertices for this shape starts.

Mat34 ClothingAssetParameters::boneActors[].localPose

'boneActors[].localPose' : The pose this collision volume has relative to the bone.

I32 ClothingAssetParameters::bonePlanes[].boneIndex

'bonePlanes[].boneIndex' : The (internal) index this collision volume is attached to

F32 ClothingAssetParameters::bonePlanes[].d

'bonePlanes[].d' : Plane distance from origin.

Vec3 ClothingAssetParameters::bonePlanes[].n

'bonePlanes[].n' : Plane normal.

Mat34 ClothingAssetParameters::bones[].bindPose

'bones[].bindPose' : The matrix this bone has in the default pose

I32 ClothingAssetParameters::bones[].externalIndex

'bones[].externalIndex' : The index that was given by the application

I32 ClothingAssetParameters::bones[].internalIndex

'bones[].internalIndex' : The index used internally for this bone.

This usually corresponds to the array position this element is at.

String ClothingAssetParameters::bones[].name

'bones[].name' : The name of this bone

U32 ClothingAssetParameters::bones[].numMeshReferenced

'bones[].numMeshReferenced' : The number of mesh vertices that have a non-zero weight to this bone.

U32 ClothingAssetParameters::bones[].numRigidBodiesReferenced

'bones[].numRigidBodiesReferenced' : The number of collision volumes attached to this bone

I32 ClothingAssetParameters::bones[].parentIndex

'bones[].parentIndex' : The (internal) index of the parent bone

U16 ClothingAssetParameters::boneSphereConnections[]

'boneSphereConnections[]' : Array of indices into the boneSpheres array to describe pairs of spheres that form a capsule.

This is an array of pairs, so the size must be dividible by 2.

I32 ClothingAssetParameters::boneSpheres[].boneIndex

'boneSpheres[].boneIndex' : The (internal) index this collision volume is attached to

Vec3 ClothingAssetParameters::boneSpheres[].localPos

'boneSpheres[].localPos' : The position this collision volume has relative to the bone.

F32 ClothingAssetParameters::boneSpheres[].radius

'boneSpheres[].radius' : The radius of the sphere that describes this collision volume.

U32 ClothingAssetParameters::bonesReferenced

'bonesReferenced' : Number of bones actually used by any of the meshes or collision volumes.

Any bone in the bones array beyond this number is completely useless.

U32 ClothingAssetParameters::bonesReferencedByMesh

'bonesReferencedByMesh' : Number of bones actually used by any of the meshes

Bones beyond this index can be used for collision volumes or not at all. This number is smaller or equal the 'bonesReferenced' number.

Vec3 ClothingAssetParameters::boneVertices[]

'boneVertices[]' : Array of vertices that belong to one or more convex collision volumes

All convexes use the same array but different parts of it.

Bounds3 ClothingAssetParameters::boundingBox

'boundingBox' : The Bounding-Box of the Asset

This contains the simulated as well as the animated vertices.

U32 ClothingAssetParameters::collisionConvexes[]

'collisionConvexes[]' : Each entry is a bitmap that describes which bonePlanes are used to define a convex.

CookedData ClothingAssetParameters::cookedData
F32 ClothingAssetParameters::cookedData[].scale

'cookedData[].scale' :

ClothingGraphicalLodParameters ClothingAssetParameters::graphicalLods[]

'graphicalLods[]' :

U32 ClothingAssetParameters::interCollisionChannels

'interCollisionChannels' : Experimental. Collision Channels for inter-collision

Experimental. Each bit of the represents a channel, so there can be a maximum of 32 channels. ClothingActors that have at least one channel in common will collide, if inter-collision is enabled in the module. (3.x simulation only)

U32 ClothingAssetParameters::materialIndex

'materialIndex' : Default index for the material in the library

ClothingMaterialLibraryParameters ClothingAssetParameters::materialLibrary

'materialLibrary' :

ClothingPhysicalMeshParameters ClothingAssetParameters::physicalMeshes[]

'physicalMeshes[]' :

U32 ClothingAssetParameters::rootBoneIndex

'rootBoneIndex' : Internal bone index with either parent=-1 or one bone with minimal distance to root when root is not inside the used bones

Bool ClothingAssetParameters::simulation.disableCCD

'simulation.disableCCD' : Turn off CCD when colliding cloth particles with collision volumes

When turning off CCD, cloth particles can tunnel through fast moving collision volumes. But sometimes ill turning collision volumes can excert large velocities on particles. This can help prevent it.

Vec3 ClothingAssetParameters::simulation.gravityDirection

'simulation.gravityDirection' : Direction of gravity for this asset.

U32 ClothingAssetParameters::simulation.hierarchicalLevels

'simulation.hierarchicalLevels' : The number of cloth hierarhies. Only used to prevent stretching

Corresponds to NxClothMeshDesc::numHierarchyLevels. This is orthogonal to the Hard Stretch Limitation in the Clothing Material.

F32 ClothingAssetParameters::simulation.restLengthScale

'simulation.restLengthScale' : Scale for cloth rest lengths.

F32 ClothingAssetParameters::simulation.sleepLinearVelocity

'simulation.sleepLinearVelocity' : Clothing will fall asleep if every vertex is slower than this velocity

Most clothing doesn't need it, but it might be useful for smaller assets like flags and the like.

F32 ClothingAssetParameters::simulation.thickness

'simulation.thickness' : Minimal amount of separation between cloth particles and collision volumes.

Each cloth particle will minimaly have as much distance to any collision volume. Most stable when this value corresponds roughly half the average edge length. Can be increased to prevent penetration artifacts.

Bool ClothingAssetParameters::simulation.twowayInteraction

'simulation.twowayInteraction' : Make use of twoway interaction

For clothing this is normally not needed, as clothing should only follow the kinematic shapes. Needed when interacting with dynamic rigid bodies that need to be influenced by clothing.

Bool ClothingAssetParameters::simulation.untangling

'simulation.untangling' : EXPERIMENTAL: Untangle Cloth when it's entangled.

This feature is highly experimental and still rather slow. Only use when self-collision could not help adequately.

F32 ClothingAssetParameters::simulation.virtualParticleDensity

'simulation.virtualParticleDensity' : Select the amount of virtual particles generated.

0 will create no virtual particles. 1 will create 3 virtual particles for every triangle. Everything else is in between.

String ClothingAssetParameters::toolString

'toolString' : Describes the authoring tool.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ClothingAssetParameters Member List
This is the complete list of members for ClothingAssetParameters, including all inherited members.
boneActors[].boneIndex | ClothingAssetParameters
boneActors[].capsuleHeight | ClothingAssetParameters
boneActors[].capsuleRadius | ClothingAssetParameters
boneActors[].convexVerticesCount | ClothingAssetParameters
boneActors[].convexVerticesStart | ClothingAssetParameters
boneActors[].localPose | ClothingAssetParameters
bonePlanes[].boneIndex | ClothingAssetParameters
bonePlanes[].d | ClothingAssetParameters
bonePlanes[].n | ClothingAssetParameters
bones[].bindPose | ClothingAssetParameters
bones[].externalIndex | ClothingAssetParameters
bones[].internalIndex | ClothingAssetParameters
bones[].name | ClothingAssetParameters
bones[].numMeshReferenced | ClothingAssetParameters
bones[].numRigidBodiesReferenced | ClothingAssetParameters
bones[].parentIndex | ClothingAssetParameters
boneSphereConnections[] | ClothingAssetParameters
boneSpheres[].boneIndex | ClothingAssetParameters
boneSpheres[].localPos | ClothingAssetParameters
boneSpheres[].radius | ClothingAssetParameters
bonesReferenced | ClothingAssetParameters
bonesReferencedByMesh | ClothingAssetParameters
boneVertices[] | ClothingAssetParameters
boundingBox | ClothingAssetParameters
collisionConvexes[] | ClothingAssetParameters
cookedData | ClothingAssetParameters
cookedData[].scale | ClothingAssetParameters
graphicalLods[] | ClothingAssetParameters
interCollisionChannels | ClothingAssetParameters
materialIndex | ClothingAssetParameters
materialLibrary | ClothingAssetParameters
physicalMeshes[] | ClothingAssetParameters
rootBoneIndex | ClothingAssetParameters
simulation.disableCCD | ClothingAssetParameters
simulation.gravityDirection | ClothingAssetParameters
simulation.hierarchicalLevels | ClothingAssetParameters
simulation.restLengthScale | ClothingAssetParameters
simulation.sleepLinearVelocity | ClothingAssetParameters
simulation.thickness | ClothingAssetParameters
simulation.twowayInteraction | ClothingAssetParameters
simulation.untangling | ClothingAssetParameters
simulation.virtualParticleDensity | ClothingAssetParameters
toolString | ClothingAssetParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ClothingCookedParam Struct Reference

  • Class List
  • Class Members
Public Attributes
ClothingCookedParam Struct Reference

Describes the NxParameterized::Interface for 'ClothingCookedParam' : More...

#include <params.h>

List of all members.

Public Attributes

F32 | actorScale
'actorScale' : Actor scale
U8 | convexCookedData[]
'convexCookedData[]' : The cooked data for all the convex meshes.
U32 | cookedPhysicalSubmeshes[].physicalMeshId
'cookedPhysicalSubmeshes[].physicalMeshId' : Physical mesh ID
U32 | cookedPhysicalSubmeshes[].submeshId
'cookedPhysicalSubmeshes[].submeshId' : Submesh ID
U32 | cookedPhysicalSubmeshes[].cookedDataOffset
'cookedPhysicalSubmeshes[].cookedDataOffset' : Cooked data offset
U32 | cookedPhysicalSubmeshes[].cookedDataLength
'cookedPhysicalSubmeshes[].cookedDataLength' : Cooked data length
U32 | cookedPhysicalSubmeshes[].deformableInvParticleWeightsOffset
'cookedPhysicalSubmeshes[].deformableInvParticleWeightsOffset' : Deformable inverse particle weights offset
U32 | cookedPhysicalSubmeshes[].virtualParticleIndicesOffset
'cookedPhysicalSubmeshes[].virtualParticleIndicesOffset' : Virtual particle indices offset
U32 | cookedPhysicalSubmeshes[].virtualParticleIndicesLength
'cookedPhysicalSubmeshes[].virtualParticleIndicesLength' : Virtual particle indices length
U8 | deformableCookedData[]
'deformableCookedData[]' : Deformable cooked data
U32 | cookedDataVersion
'cookedDataVersion' : The PhysX SDK Version this data was cooked from
F32 | deformableInvParticleWeights[]
'deformableInvParticleWeights[]' : Deformable inverse particle weights
U32 | virtualParticleIndices[]
'virtualParticleIndices[]' : Virtual particle indices
Vec3 | virtualParticleWeights[]
'virtualParticleWeights[]' : Virtual particle weights

Detailed Description

Describes the NxParameterized::Interface for 'ClothingCookedParam' :

ClothingCookedParam contains 21 fully qualified names
---------------------------------------------
  1 : F32            actorScale
  2 : ArraySizeName  convexCookedData
  3 : U8             convexCookedData[]
  4 : ArraySizeName  convexMeshPointers
  5 : ArraySizeName  cookedPhysicalSubmeshes
  6 : U32            cookedPhysicalSubmeshes[].physicalMeshId
  7 : U32            cookedPhysicalSubmeshes[].submeshId
  8 : U32            cookedPhysicalSubmeshes[].cookedDataOffset
  9 : U32            cookedPhysicalSubmeshes[].cookedDataLength
 10 : U32            cookedPhysicalSubmeshes[].deformableInvParticleWeightsOffset
 11 : U32            cookedPhysicalSubmeshes[].virtualParticleIndicesOffset
 12 : U32            cookedPhysicalSubmeshes[].virtualParticleIndicesLength
 13 : ArraySizeName  deformableCookedData
 14 : U8             deformableCookedData[]
 15 : U32            cookedDataVersion
 16 : ArraySizeName  deformableInvParticleWeights
 17 : F32            deformableInvParticleWeights[]
 18 : ArraySizeName  virtualParticleIndices
 19 : U32            virtualParticleIndices[]
 20 : ArraySizeName  virtualParticleWeights
 21 : Vec3           virtualParticleWeights[]

Member Data Documentation

F32 ClothingCookedParam::actorScale

'actorScale' : Actor scale

U8 ClothingCookedParam::convexCookedData[]

'convexCookedData[]' : The cooked data for all the convex meshes.

All convexes are checked into the same buffer, one after the other.

U32 ClothingCookedParam::cookedDataVersion

'cookedDataVersion' : The PhysX SDK Version this data was cooked from

When loading into a different PhysX version, it will cook again on loading.

U32 ClothingCookedParam::cookedPhysicalSubmeshes[].cookedDataLength

'cookedPhysicalSubmeshes[].cookedDataLength' : Cooked data length

U32 ClothingCookedParam::cookedPhysicalSubmeshes[].cookedDataOffset

'cookedPhysicalSubmeshes[].cookedDataOffset' : Cooked data offset

U32 ClothingCookedParam::cookedPhysicalSubmeshes[].deformableInvParticleWeightsOffset

'cookedPhysicalSubmeshes[].deformableInvParticleWeightsOffset' : Deformable inverse particle weights offset

U32 ClothingCookedParam::cookedPhysicalSubmeshes[].physicalMeshId

'cookedPhysicalSubmeshes[].physicalMeshId' : Physical mesh ID

U32 ClothingCookedParam::cookedPhysicalSubmeshes[].submeshId

'cookedPhysicalSubmeshes[].submeshId' : Submesh ID

U32 ClothingCookedParam::cookedPhysicalSubmeshes[].virtualParticleIndicesLength

'cookedPhysicalSubmeshes[].virtualParticleIndicesLength' : Virtual particle indices length

U32 ClothingCookedParam::cookedPhysicalSubmeshes[].virtualParticleIndicesOffset

'cookedPhysicalSubmeshes[].virtualParticleIndicesOffset' : Virtual particle indices offset

U8 ClothingCookedParam::deformableCookedData[]

'deformableCookedData[]' : Deformable cooked data

F32 ClothingCookedParam::deformableInvParticleWeights[]

'deformableInvParticleWeights[]' : Deformable inverse particle weights

U32 ClothingCookedParam::virtualParticleIndices[]

'virtualParticleIndices[]' : Virtual particle indices

Vec3 ClothingCookedParam::virtualParticleWeights[]

'virtualParticleWeights[]' : Virtual particle weights

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ClothingCookedParam Member List
This is the complete list of members for ClothingCookedParam, including all inherited members.
actorScale | ClothingCookedParam
convexCookedData[] | ClothingCookedParam
cookedDataVersion | ClothingCookedParam
cookedPhysicalSubmeshes[].cookedDataLength | ClothingCookedParam
cookedPhysicalSubmeshes[].cookedDataOffset | ClothingCookedParam
cookedPhysicalSubmeshes[].deformableInvParticleWeightsOffset | ClothingCookedParam
cookedPhysicalSubmeshes[].physicalMeshId | ClothingCookedParam
cookedPhysicalSubmeshes[].submeshId | ClothingCookedParam
cookedPhysicalSubmeshes[].virtualParticleIndicesLength | ClothingCookedParam
cookedPhysicalSubmeshes[].virtualParticleIndicesOffset | ClothingCookedParam
deformableCookedData[] | ClothingCookedParam
deformableInvParticleWeights[] | ClothingCookedParam
virtualParticleIndices[] | ClothingCookedParam
virtualParticleWeights[] | ClothingCookedParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ClothingCookedPhysX3Param Struct Reference

  • Class List
  • Class Members
Public Attributes
ClothingCookedPhysX3Param Struct Reference

Describes the NxParameterized::Interface for 'ClothingCookedPhysX3Param' : More...

#include <params.h>

List of all members.

Public Attributes

U32 | physicalMeshId
'physicalMeshId' : Physical mesh ID
U32 | physicalSubMeshId
'physicalSubMeshId' : Physical submesh ID
U32 | numVertices
'numVertices' : Vertex count
F32 | deformableRestLengths[]
'deformableRestLengths[]' : Deformable rest lengths
U32 | deformableIndices[]
'deformableIndices[]' : Deformable indices
U32 | selfCollisionIndices[]
'selfCollisionIndices[]' : Self collision indices
U32 | selfCollisionNormalIndices[]
'selfCollisionNormalIndices[]' : Self collision normal indices
U32 | selfCollisionNormalSetSizes[]
'selfCollisionNormalSetSizes[]' : Self collision normal set sizes
U32 | deformableSets[].fiberEnd
'deformableSets[].fiberEnd' : Fiber end
U32 | deformableSets[].longestFiber
'deformableSets[].longestFiber' : Longest fiber
U32 | deformableSets[].shortestFiber
'deformableSets[].shortestFiber' : Shortest fiber
U32 | deformableSets[].numEdges
'deformableSets[].numEdges' : Edge count
F32 | deformableSets[].avgEdgeLength
'deformableSets[].avgEdgeLength' : Average edge length
U32 | deformableSets[].avgFiberLength
'deformableSets[].avgFiberLength' : Average fiber length
U32 | deformablePhaseDescs[].phaseType
'deformablePhaseDescs[].phaseType' : Phase type
U32 | deformablePhaseDescs[].setIndex
'deformablePhaseDescs[].setIndex' : Set index
U32 | deformablePhaseDescs[].restValueOffset
'deformablePhaseDescs[].restValueOffset' : Rest value offset
U32 | tetherAnchors[]
'tetherAnchors[]' : Tether anchors
F32 | tetherLengths[]
'tetherLengths[]' : Tether lengths
F32 | deformableInvVertexWeights[]
'deformableInvVertexWeights[]' : Deformable inverse vertex weights
U32 | virtualParticleIndices[]
'virtualParticleIndices[]' : Virtual particle indices
F32 | virtualParticleWeights[]
'virtualParticleWeights[]' : Virtual particle weights
U32 | cookedDataVersion
'cookedDataVersion' : Cooked data version
ClothingCookedPhysX3Param nextCookedData
'nextCookedData' :

Detailed Description

Describes the NxParameterized::Interface for 'ClothingCookedPhysX3Param' :

ClothingCookedPhysX3Param contains 36 fully qualified names
---------------------------------------------
  1 : U32            physicalMeshId
  2 : U32            physicalSubMeshId
  3 : U32            numVertices
  4 : ArraySizeName  deformableRestLengths
  5 : F32            deformableRestLengths[]
  6 : ArraySizeName  deformableIndices
  7 : U32            deformableIndices[]
  8 : ArraySizeName  selfCollisionIndices
  9 : U32            selfCollisionIndices[]
 10 : ArraySizeName  selfCollisionNormalIndices
 11 : U32            selfCollisionNormalIndices[]
 12 : ArraySizeName  selfCollisionNormalSetSizes
 13 : U32            selfCollisionNormalSetSizes[]
 14 : ArraySizeName  deformableSets
 15 : U32            deformableSets[].fiberEnd
 16 : U32            deformableSets[].longestFiber
 17 : U32            deformableSets[].shortestFiber
 18 : U32            deformableSets[].numEdges
 19 : F32            deformableSets[].avgEdgeLength
 20 : U32            deformableSets[].avgFiberLength
 21 : ArraySizeName  deformablePhaseDescs
 22 : U32            deformablePhaseDescs[].phaseType
 23 : U32            deformablePhaseDescs[].setIndex
 24 : U32            deformablePhaseDescs[].restValueOffset
 25 : ArraySizeName  tetherAnchors
 26 : U32            tetherAnchors[]
 27 : ArraySizeName  tetherLengths
 28 : F32            tetherLengths[]
 29 : ArraySizeName  deformableInvVertexWeights
 30 : F32            deformableInvVertexWeights[]
 31 : ArraySizeName  virtualParticleIndices
 32 : U32            virtualParticleIndices[]
 33 : ArraySizeName  virtualParticleWeights
 34 : F32            virtualParticleWeights[]
 35 : U32            cookedDataVersion
 36 : ArraySizeName  fabricGPU

Member Data Documentation

U32 ClothingCookedPhysX3Param::cookedDataVersion

'cookedDataVersion' : Cooked data version

U32 ClothingCookedPhysX3Param::deformableIndices[]

'deformableIndices[]' : Deformable indices

F32 ClothingCookedPhysX3Param::deformableInvVertexWeights[]

'deformableInvVertexWeights[]' : Deformable inverse vertex weights

U32 ClothingCookedPhysX3Param::deformablePhaseDescs[].phaseType

'deformablePhaseDescs[].phaseType' : Phase type

U32 ClothingCookedPhysX3Param::deformablePhaseDescs[].restValueOffset

'deformablePhaseDescs[].restValueOffset' : Rest value offset

U32 ClothingCookedPhysX3Param::deformablePhaseDescs[].setIndex

'deformablePhaseDescs[].setIndex' : Set index

F32 ClothingCookedPhysX3Param::deformableRestLengths[]

'deformableRestLengths[]' : Deformable rest lengths

F32 ClothingCookedPhysX3Param::deformableSets[].avgEdgeLength

'deformableSets[].avgEdgeLength' : Average edge length

U32 ClothingCookedPhysX3Param::deformableSets[].avgFiberLength

'deformableSets[].avgFiberLength' : Average fiber length

U32 ClothingCookedPhysX3Param::deformableSets[].fiberEnd

'deformableSets[].fiberEnd' : Fiber end

U32 ClothingCookedPhysX3Param::deformableSets[].longestFiber

'deformableSets[].longestFiber' : Longest fiber

U32 ClothingCookedPhysX3Param::deformableSets[].numEdges

'deformableSets[].numEdges' : Edge count

U32 ClothingCookedPhysX3Param::deformableSets[].shortestFiber

'deformableSets[].shortestFiber' : Shortest fiber

ClothingCookedPhysX3Param ClothingCookedPhysX3Param::nextCookedData

'nextCookedData' :

U32 ClothingCookedPhysX3Param::numVertices

'numVertices' : Vertex count

U32 ClothingCookedPhysX3Param::physicalMeshId

'physicalMeshId' : Physical mesh ID

U32 ClothingCookedPhysX3Param::physicalSubMeshId

'physicalSubMeshId' : Physical submesh ID

U32 ClothingCookedPhysX3Param::selfCollisionIndices[]

'selfCollisionIndices[]' : Self collision indices

U32 ClothingCookedPhysX3Param::selfCollisionNormalIndices[]

'selfCollisionNormalIndices[]' : Self collision normal indices

U32 ClothingCookedPhysX3Param::selfCollisionNormalSetSizes[]

'selfCollisionNormalSetSizes[]' : Self collision normal set sizes

U32 ClothingCookedPhysX3Param::tetherAnchors[]

'tetherAnchors[]' : Tether anchors

F32 ClothingCookedPhysX3Param::tetherLengths[]

'tetherLengths[]' : Tether lengths

U32 ClothingCookedPhysX3Param::virtualParticleIndices[]

'virtualParticleIndices[]' : Virtual particle indices

F32 ClothingCookedPhysX3Param::virtualParticleWeights[]

'virtualParticleWeights[]' : Virtual particle weights

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ClothingCookedPhysX3Param Member List
This is the complete list of members for ClothingCookedPhysX3Param, including all inherited members.
cookedDataVersion | ClothingCookedPhysX3Param
deformableIndices[] | ClothingCookedPhysX3Param
deformableInvVertexWeights[] | ClothingCookedPhysX3Param
deformablePhaseDescs[].phaseType | ClothingCookedPhysX3Param
deformablePhaseDescs[].restValueOffset | ClothingCookedPhysX3Param
deformablePhaseDescs[].setIndex | ClothingCookedPhysX3Param
deformableRestLengths[] | ClothingCookedPhysX3Param
deformableSets[].avgEdgeLength | ClothingCookedPhysX3Param
deformableSets[].avgFiberLength | ClothingCookedPhysX3Param
deformableSets[].fiberEnd | ClothingCookedPhysX3Param
deformableSets[].longestFiber | ClothingCookedPhysX3Param
deformableSets[].numEdges | ClothingCookedPhysX3Param
deformableSets[].shortestFiber | ClothingCookedPhysX3Param
nextCookedData | ClothingCookedPhysX3Param
numVertices | ClothingCookedPhysX3Param
physicalMeshId | ClothingCookedPhysX3Param
physicalSubMeshId | ClothingCookedPhysX3Param
selfCollisionIndices[] | ClothingCookedPhysX3Param
selfCollisionNormalIndices[] | ClothingCookedPhysX3Param
selfCollisionNormalSetSizes[] | ClothingCookedPhysX3Param
tetherAnchors[] | ClothingCookedPhysX3Param
tetherLengths[] | ClothingCookedPhysX3Param
virtualParticleIndices[] | ClothingCookedPhysX3Param
virtualParticleWeights[] | ClothingCookedPhysX3Param
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ClothingDebugRenderParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ClothingDebugRenderParams Struct Reference

Describes the NxParameterized::Interface for 'ClothingDebugRenderParams' : More...

#include <params.h>

List of all members.

Public Attributes

Bool | Actors
'Actors' : Enables/Disables visualization of all clothing actors
F32 | SkinnedPositions
'SkinnedPositions' : Marks each animation position with a small cross as the centers of the spheres in which the simulated vertices are allowed to move. Blue for static vertices, black to white for increasing max distance.
Bool | Backstop
'Backstop' : The part of the mesh with backstop is solidly rendered. Red for front faces, blue for back faces.
F32 | BackstopPrecise
'BackstopPrecise' : Draws small segments of the backstop sphere for each simulation vertex. (scalable)
Bool | MaxDistance
'MaxDistance' : Draws a line from the skinned position along the skinned normal with the length of the max distance this vertex is allowed to move. Note that the LoD mechanism can scale down the Max Distance of the asset.
Bool | MaxDistanceInwards
'MaxDistanceInwards' : Same as MaxDistance but to the other side. Bounded by backstop. The length of the line is either Max Distance or sphere collision distance, depending on which is smaller and restricts the motion of the vertex.
Bool | SkinMapAll
'SkinMapAll' : Draws the full support mesh for mesh-mesh skinning.
Bool | SkinMapBad
'SkinMapBad' : Draws the support mesh for mesh-mesh skinning. But only for vertices that actually lie outside of the support mesh and could cause problems
Bool | SkinMapActual
'SkinMapActual' : Draws the actual support mesh for mesh-mesh skinning (only the parts that are effectively used).
Bool | SkinMapInvalidBary
'SkinMapInvalidBary' : Draws physical triangles and corresponding graphical vertices that have invalid barycentric coordinates in the mesh skinning map. Red: invalid position bary. Purple: invalid normal bary. Blue: invalid tangent bary.
F32 | PhysicsMeshWire
'PhysicsMeshWire' : Draws the simulation mesh, only the active region. From yellow to red, the closer a vertex gets to its max distance. (scalable)
F32 | PhysicsMeshSolid
'PhysicsMeshSolid' : Same as PhysicsMeshWire but with solid triangles.
F32 | PhysicsMeshNormals
'PhysicsMeshNormals' : Displays the normals of the physics mesh (base for mesh-mesh skinning).
Bool | Skeleton
'Skeleton' : Draws lines from parent to child bones. Active bones are displayed in purple, passive in blue. Only the subset of bones that have a vertex from any of the meshes or a collision volume bound to them will be visible.
F32 | BoneFrames
'BoneFrames' : Draws the frame of each bone. (scalable)
F32 | BoneNames
'BoneNames' : Displays the name of each bone. (scalable)
F32 | Velocities
'Velocities' : Draws lines for each simulated vertex' velocity. (scalable)
F32 | Wind
'Wind' : Draws lines for each simulated vertex' velocity change due to wind, velocity callback or pressure. (scalable)
Bool | GraphicalVertexBones
'GraphicalVertexBones' : Draws colored lines from each graphical vertex to the bones it uses for skinning. White to black for decreasing weights.
Bool | PhysicalVertexBones
'PhysicalVertexBones' : Draws colored lines from each simulation vertex to the bones it uses for skinning. White to black for decreasing weights.
Bool | CollisionShapes
'CollisionShapes' : Draws solid capsules and spheres for the collision shapes.
Bool | CollisionShapesWire
'CollisionShapesWire' : Draws wire capsules and spheres for the collision shapes.
Bool | LengthFibers
'LengthFibers' : Show the vertical stretching fibers.
Bool | CrossSectionFibers
'CrossSectionFibers' : Show the horizontal stretching fibers.
Bool | BendingFibers
'BendingFibers' : Show the bending fibers.
Bool | ShearingFibers
'ShearingFibers' : Show the shearing fibers.
Bool | ZerostretchFibers
'ZerostretchFibers' : Show the zero-stretch phases.
Bool | TethersActive
'TethersActive' : Show the tether constraitns, only active ones (0.99 their length and longer).
Bool | TethersInactive
'TethersInactive' : Show the tether constraints, only inactive ones (less than 0.99 their length).
Bool | VirtualCollision
'VirtualCollision' : Show the virtual particles. Each has 3 lines to the vertices it connects to.
Bool | FiberRange
'FiberRange' : Combined with fiber debug rendering this visualizes the range where the stiffness of the chosen fiber type is scaled down. It shows how much the cloth is allowed to compress/stretch.
Bool | ShowInLocalSpace
'ShowInLocalSpace' : Enables/Disables debug rendering in local space (experts only!)
Bool | GlobalPose
'GlobalPose' : Shows the internally stored global pose transform
Bool | RecomputeSubmeshes
'RecomputeSubmeshes' : Shows the internal reordering of the render mesh asset into physical submeshes and non-simulated parts in shades of gray. This is used to split the cpu skinned part from the skinned part that is skinned the physics mesh.
Bool | RecomputeVertices
'RecomputeVertices' : Shows the position of the reordered render vertices that are being skinned to the physics mesh. Vertices attached to simulated triangles are rendered orange. Additional vertices along the border are rendered purple, they are needed to prevent visible seams from normal and tangent calculations.
Bool | PhysicsMeshIndices
'PhysicsMeshIndices' : Shows the indices of the physics mesh
Bool | MassScale
'MassScale' : Shows red crosses for particles where the mass is scaled for collision purpose
Bool | SelfCollision
'SelfCollision' : Shows spheres that represent the self collision thickness
Bool | SelfCollisionWire
'SelfCollisionWire' : Shows spheres that represent the self collision thickness
F32 | SelfCollisionAttenuation
'SelfCollisionAttenuation' : Draws a line between vertices where selfcollision is reduced or turned off.
Bool | SolverMode
'SolverMode' : Displays which solver is used (2.x or 3.x), wether it runs on GPU, and if the simulation data fits into shared memory.

Detailed Description

Describes the NxParameterized::Interface for 'ClothingDebugRenderParams' :

ClothingDebugRenderParams contains 41 fully qualified names
---------------------------------------------
  1 : Bool  Actors
  2 : F32   SkinnedPositions
  3 : Bool  Backstop
  4 : F32   BackstopPrecise
  5 : Bool  MaxDistance
  6 : Bool  MaxDistanceInwards
  7 : Bool  SkinMapAll
  8 : Bool  SkinMapBad
  9 : Bool  SkinMapActual
 10 : Bool  SkinMapInvalidBary
 11 : F32   PhysicsMeshWire
 12 : F32   PhysicsMeshSolid
 13 : F32   PhysicsMeshNormals
 14 : Bool  Skeleton
 15 : F32   BoneFrames
 16 : F32   BoneNames
 17 : F32   Velocities
 18 : F32   Wind
 19 : Bool  GraphicalVertexBones
 20 : Bool  PhysicalVertexBones
 21 : Bool  CollisionShapes
 22 : Bool  CollisionShapesWire
 23 : Bool  LengthFibers
 24 : Bool  CrossSectionFibers
 25 : Bool  BendingFibers
 26 : Bool  ShearingFibers
 27 : Bool  ZerostretchFibers
 28 : Bool  TethersActive
 29 : Bool  TethersInactive
 30 : Bool  VirtualCollision
 31 : Bool  FiberRange
 32 : Bool  ShowInLocalSpace
 33 : Bool  GlobalPose
 34 : Bool  RecomputeSubmeshes
 35 : Bool  RecomputeVertices
 36 : Bool  PhysicsMeshIndices
 37 : Bool  MassScale
 38 : Bool  SelfCollision
 39 : Bool  SelfCollisionWire
 40 : F32   SelfCollisionAttenuation
 41 : Bool  SolverMode

Member Data Documentation

Bool ClothingDebugRenderParams::Actors

'Actors' : Enables/Disables visualization of all clothing actors

Bool ClothingDebugRenderParams::Backstop

'Backstop' : The part of the mesh with backstop is solidly rendered. Red for front faces, blue for back faces.

F32 ClothingDebugRenderParams::BackstopPrecise

'BackstopPrecise' : Draws small segments of the backstop sphere for each simulation vertex. (scalable)

Bool ClothingDebugRenderParams::BendingFibers

'BendingFibers' : Show the bending fibers.

F32 ClothingDebugRenderParams::BoneFrames

'BoneFrames' : Draws the frame of each bone. (scalable)

F32 ClothingDebugRenderParams::BoneNames

'BoneNames' : Displays the name of each bone. (scalable)

Bool ClothingDebugRenderParams::CollisionShapes

'CollisionShapes' : Draws solid capsules and spheres for the collision shapes.

Bool ClothingDebugRenderParams::CollisionShapesWire

'CollisionShapesWire' : Draws wire capsules and spheres for the collision shapes.

Bool ClothingDebugRenderParams::CrossSectionFibers

'CrossSectionFibers' : Show the horizontal stretching fibers.

Bool ClothingDebugRenderParams::FiberRange

'FiberRange' : Combined with fiber debug rendering this visualizes the range where the stiffness of the chosen fiber type is scaled down. It shows how much the cloth is allowed to compress/stretch.

Bool ClothingDebugRenderParams::GlobalPose

'GlobalPose' : Shows the internally stored global pose transform

Bool ClothingDebugRenderParams::GraphicalVertexBones

'GraphicalVertexBones' : Draws colored lines from each graphical vertex to the bones it uses for skinning. White to black for decreasing weights.

Bool ClothingDebugRenderParams::LengthFibers

'LengthFibers' : Show the vertical stretching fibers.

Bool ClothingDebugRenderParams::MassScale

'MassScale' : Shows red crosses for particles where the mass is scaled for collision purpose

Bool ClothingDebugRenderParams::MaxDistance

'MaxDistance' : Draws a line from the skinned position along the skinned normal with the length of the max distance this vertex is allowed to move. Note that the LoD mechanism can scale down the Max Distance of the asset.

Bool ClothingDebugRenderParams::MaxDistanceInwards

'MaxDistanceInwards' : Same as MaxDistance but to the other side. Bounded by backstop. The length of the line is either Max Distance or sphere collision distance, depending on which is smaller and restricts the motion of the vertex.

Bool ClothingDebugRenderParams::PhysicalVertexBones

'PhysicalVertexBones' : Draws colored lines from each simulation vertex to the bones it uses for skinning. White to black for decreasing weights.

Bool ClothingDebugRenderParams::PhysicsMeshIndices

'PhysicsMeshIndices' : Shows the indices of the physics mesh

F32 ClothingDebugRenderParams::PhysicsMeshNormals

'PhysicsMeshNormals' : Displays the normals of the physics mesh (base for mesh-mesh skinning).

F32 ClothingDebugRenderParams::PhysicsMeshSolid

'PhysicsMeshSolid' : Same as PhysicsMeshWire but with solid triangles.

F32 ClothingDebugRenderParams::PhysicsMeshWire

'PhysicsMeshWire' : Draws the simulation mesh, only the active region. From yellow to red, the closer a vertex gets to its max distance. (scalable)

Bool ClothingDebugRenderParams::RecomputeSubmeshes

'RecomputeSubmeshes' : Shows the internal reordering of the render mesh asset into physical submeshes and non-simulated parts in shades of gray. This is used to split the cpu skinned part from the skinned part that is skinned the physics mesh.

Bool ClothingDebugRenderParams::RecomputeVertices

'RecomputeVertices' : Shows the position of the reordered render vertices that are being skinned to the physics mesh. Vertices attached to simulated triangles are rendered orange. Additional vertices along the border are rendered purple, they are needed to prevent visible seams from normal and tangent calculations.

Bool ClothingDebugRenderParams::SelfCollision

'SelfCollision' : Shows spheres that represent the self collision thickness

F32 ClothingDebugRenderParams::SelfCollisionAttenuation

'SelfCollisionAttenuation' : Draws a line between vertices where selfcollision is reduced or turned off.

All connections are drawn that have an attenuation smaller than the given value. 0.0f disables the visualization, 1.0f shows all attenuated pairs.

Bool ClothingDebugRenderParams::SelfCollisionWire

'SelfCollisionWire' : Shows spheres that represent the self collision thickness

Bool ClothingDebugRenderParams::ShearingFibers

'ShearingFibers' : Show the shearing fibers.

Bool ClothingDebugRenderParams::ShowInLocalSpace

'ShowInLocalSpace' : Enables/Disables debug rendering in local space (experts only!)

Bool ClothingDebugRenderParams::Skeleton

'Skeleton' : Draws lines from parent to child bones. Active bones are displayed in purple, passive in blue. Only the subset of bones that have a vertex from any of the meshes or a collision volume bound to them will be visible.

Bool ClothingDebugRenderParams::SkinMapActual

'SkinMapActual' : Draws the actual support mesh for mesh-mesh skinning (only the parts that are effectively used).

Bool ClothingDebugRenderParams::SkinMapAll

'SkinMapAll' : Draws the full support mesh for mesh-mesh skinning.

Bool ClothingDebugRenderParams::SkinMapBad

'SkinMapBad' : Draws the support mesh for mesh-mesh skinning. But only for vertices that actually lie outside of the support mesh and could cause problems

Bool ClothingDebugRenderParams::SkinMapInvalidBary

'SkinMapInvalidBary' : Draws physical triangles and corresponding graphical vertices that have invalid barycentric coordinates in the mesh skinning map. Red: invalid position bary. Purple: invalid normal bary. Blue: invalid tangent bary.

F32 ClothingDebugRenderParams::SkinnedPositions

'SkinnedPositions' : Marks each animation position with a small cross as the centers of the spheres in which the simulated vertices are allowed to move. Blue for static vertices, black to white for increasing max distance.

Bool ClothingDebugRenderParams::SolverMode

'SolverMode' : Displays which solver is used (2.x or 3.x), wether it runs on GPU, and if the simulation data fits into shared memory.

Shared: Fastest path. It means previous and current positions fit onto shared memory on the GPU. Mixed: Only slightly slower than Shared. Current positions fit onto shared memory, previous positions need to be streamed in. Global: Significantly slower than Shared and Mixed. All data is read from global GPU memory. Try to reduce the vertex count and/or split up the asset.

Bool ClothingDebugRenderParams::TethersActive

'TethersActive' : Show the tether constraitns, only active ones (0.99 their length and longer).

Bool ClothingDebugRenderParams::TethersInactive

'TethersInactive' : Show the tether constraints, only inactive ones (less than 0.99 their length).

F32 ClothingDebugRenderParams::Velocities

'Velocities' : Draws lines for each simulated vertex' velocity. (scalable)

Bool ClothingDebugRenderParams::VirtualCollision

'VirtualCollision' : Show the virtual particles. Each has 3 lines to the vertices it connects to.

F32 ClothingDebugRenderParams::Wind

'Wind' : Draws lines for each simulated vertex' velocity change due to wind, velocity callback or pressure. (scalable)

Bool ClothingDebugRenderParams::ZerostretchFibers

'ZerostretchFibers' : Show the zero-stretch phases.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ClothingDebugRenderParams Member List
This is the complete list of members for ClothingDebugRenderParams, including all inherited members.
Actors | ClothingDebugRenderParams
Backstop | ClothingDebugRenderParams
BackstopPrecise | ClothingDebugRenderParams
BendingFibers | ClothingDebugRenderParams
BoneFrames | ClothingDebugRenderParams
BoneNames | ClothingDebugRenderParams
CollisionShapes | ClothingDebugRenderParams
CollisionShapesWire | ClothingDebugRenderParams
CrossSectionFibers | ClothingDebugRenderParams
FiberRange | ClothingDebugRenderParams
GlobalPose | ClothingDebugRenderParams
GraphicalVertexBones | ClothingDebugRenderParams
LengthFibers | ClothingDebugRenderParams
MassScale | ClothingDebugRenderParams
MaxDistance | ClothingDebugRenderParams
MaxDistanceInwards | ClothingDebugRenderParams
PhysicalVertexBones | ClothingDebugRenderParams
PhysicsMeshIndices | ClothingDebugRenderParams
PhysicsMeshNormals | ClothingDebugRenderParams
PhysicsMeshSolid | ClothingDebugRenderParams
PhysicsMeshWire | ClothingDebugRenderParams
RecomputeSubmeshes | ClothingDebugRenderParams
RecomputeVertices | ClothingDebugRenderParams
SelfCollision | ClothingDebugRenderParams
SelfCollisionAttenuation | ClothingDebugRenderParams
SelfCollisionWire | ClothingDebugRenderParams
ShearingFibers | ClothingDebugRenderParams
ShowInLocalSpace | ClothingDebugRenderParams
Skeleton | ClothingDebugRenderParams
SkinMapActual | ClothingDebugRenderParams
SkinMapAll | ClothingDebugRenderParams
SkinMapBad | ClothingDebugRenderParams
SkinMapInvalidBary | ClothingDebugRenderParams
SkinnedPositions | ClothingDebugRenderParams
SolverMode | ClothingDebugRenderParams
TethersActive | ClothingDebugRenderParams
TethersInactive | ClothingDebugRenderParams
Velocities | ClothingDebugRenderParams
VirtualCollision | ClothingDebugRenderParams
Wind | ClothingDebugRenderParams
ZerostretchFibers | ClothingDebugRenderParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ClothingGraphicalLodParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
ClothingGraphicalLodParameters Struct Reference

Describes the NxParameterized::Interface for 'ClothingGraphicalLodParameters' : More...

#include <params.h>

List of all members.

Public Attributes

String | platforms[]
'platforms[]' : Platforms on this lod is used.
U32 | lod
'lod' : The actual LoD value
U32 | physicalMeshId
'physicalMeshId' : Index of the physical mesh used for this graphical mesh.
RenderMeshAssetParameters renderMeshAsset
'renderMeshAsset' :
U32 | immediateClothMap[]
'immediateClothMap[]' : Directly map some of the physically simulated vertices on the graphical mesh
Vec3 | skinClothMapB[].vtxTetraBary
'skinClothMapB[].vtxTetraBary' : The barycentric coordinate into the implicit tetrahedron.
U32 | skinClothMapB[].vertexIndexPlusOffset
'skinClothMapB[].vertexIndexPlusOffset' : The vertex index in the graphical mesh (the target index).
Vec3 | skinClothMapB[].nrmTetraBary
'skinClothMapB[].nrmTetraBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.
U32 | skinClothMapB[].faceIndex0
'skinClothMapB[].faceIndex0' : First index of the 3 consecutive indices making the physical triangle.
U32 | skinClothMapB[].tetraIndex
'skinClothMapB[].tetraIndex' : Selects which of the 6 implicit tetrahedrons is used for the mapping.
U32 | skinClothMapB[].submeshIndex
'skinClothMapB[].submeshIndex' : Index into which Physical Submesh/LoD this element of the mapping belongs to.
Vec3 | skinClothMap[].vertexBary
'skinClothMap[].vertexBary' : The barycentric coordinate into the triangle.
U32 | skinClothMap[].vertexIndex0
'skinClothMap[].vertexIndex0' : Vertex index of the physics triangle.
Vec3 | skinClothMap[].normalBary
'skinClothMap[].normalBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.
U32 | skinClothMap[].vertexIndex1
'skinClothMap[].vertexIndex1' : Vertex index of the physics triangle.
Vec3 | skinClothMap[].tangentBary
'skinClothMap[].tangentBary' : The barycentric coordinate of (position+tangent). When position is subtracted this will result in the tangent again.
U32 | skinClothMap[].vertexIndex2
'skinClothMap[].vertexIndex2' : Vertex index of the physics triangle.
U32 | skinClothMap[].vertexIndexPlusOffset
'skinClothMap[].vertexIndexPlusOffset' : The vertex index in the graphical mesh (the target index).
F32 | skinClothMapThickness
'skinClothMapThickness' : Thickness of the mesh implicitly defined around the flat physical (triangle) mesh.
F32 | skinClothMapOffset
'skinClothMapOffset' : Normal offset of the mesh implicitly defined around the flat physical (triangle) mesh.
Vec3 | tetraMap[].vertexBary
'tetraMap[].vertexBary' : The barycentric coordinate into the tetrahedron.
U32 | tetraMap[].tetraIndex0
'tetraMap[].tetraIndex0' : First index of the 4 consecutive indices making the physical tetrahedron.
Vec3 | tetraMap[].normalBary
'tetraMap[].normalBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.
U32 | tetraMap[]._dummyForAlignment
'tetraMap[]._dummyForAlignment' : Does not hold any data, only helps the alignment of the struct.
U32 | renderMeshAssetSorting
'renderMeshAssetSorting' : Render mesh asset sorting
U32 | physicsSubmeshPartitioning[].graphicalSubmesh
'physicsSubmeshPartitioning[].graphicalSubmesh' : Graphical submesh
U32 | physicsSubmeshPartitioning[].physicalSubmesh
'physicsSubmeshPartitioning[].physicalSubmesh' : Physical submesh
U32 | physicsSubmeshPartitioning[].numSimulatedVertices
'physicsSubmeshPartitioning[].numSimulatedVertices' : Simulated vertex count
U32 | physicsSubmeshPartitioning[].numSimulatedVerticesAdditional
'physicsSubmeshPartitioning[].numSimulatedVerticesAdditional' : Simulated additional vertex count
U32 | physicsSubmeshPartitioning[].numSimulatedIndices
'physicsSubmeshPartitioning[].numSimulatedIndices' : Simulated index count

Detailed Description

Describes the NxParameterized::Interface for 'ClothingGraphicalLodParameters' :

ClothingGraphicalLodParameters contains 117 fully qualified names
---------------------------------------------
  1 : ArraySizeName  platforms
  2 : String         platforms[]
  3 : U32            lod
  4 : U32            physicalMeshId
  5 : ArraySizeName  renderMeshAsset.submeshes                                                        RefVariant[RenderMeshAssetParameters]
  6 : U32            renderMeshAsset.submeshes[].vertexBuffer.vertexCount                             RefVariant[VertexBufferParameters]
  7 : U32            renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.winding                    RefVariant[VertexFormatParameters]
  8 : Bool           renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.hasSeparateBoneBuffer      RefVariant[VertexFormatParameters]
  9 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats              RefVariant[VertexFormatParameters]
 10 : String         renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].name       RefVariant[VertexFormatParameters]
 11 : I32            renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].semantic   RefVariant[VertexFormatParameters]
 12 : U32            renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].id         RefVariant[VertexFormatParameters]
 13 : U32            renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].format     RefVariant[VertexFormatParameters]
 14 : U32            renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].access     RefVariant[VertexFormatParameters]
 15 : Bool           renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].serialize  RefVariant[VertexFormatParameters]
 16 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers                                 RefVariant[VertexBufferParameters]
 17 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU8x1]
 18 : U8             renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferU8x1]
 19 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU8x2]
 20 : U8             renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU8x2]
 21 : U8             renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU8x2]
 22 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU8x3]
 23 : U8             renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU8x3]
 24 : U8             renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU8x3]
 25 : U8             renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU8x3]
 26 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU8x4]
 27 : U8             renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU8x4]
 28 : U8             renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU8x4]
 29 : U8             renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU8x4]
 30 : U8             renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].w                      RefVariant[BufferU8x4]
 31 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU16x1]
 32 : U16            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferU16x1]
 33 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU16x2]
 34 : U16            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU16x2]
 35 : U16            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU16x2]
 36 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU16x3]
 37 : U16            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU16x3]
 38 : U16            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU16x3]
 39 : U16            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU16x3]
 40 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU16x4]
 41 : U16            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU16x4]
 42 : U16            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU16x4]
 43 : U16            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU16x4]
 44 : U16            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].w                      RefVariant[BufferU16x4]
 45 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU32x1]
 46 : U32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferU32x1]
 47 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU32x2]
 48 : U32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU32x2]
 49 : U32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU32x2]
 50 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU32x3]
 51 : U32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU32x3]
 52 : U32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU32x3]
 53 : U32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU32x3]
 54 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU32x4]
 55 : U32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU32x4]
 56 : U32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU32x4]
 57 : U32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU32x4]
 58 : U32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].w                      RefVariant[BufferU32x4]
 59 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferF32x1]
 60 : F32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferF32x1]
 61 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferF32x2]
 62 : F32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferF32x2]
 63 : F32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferF32x2]
 64 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferF32x3]
 65 : Vec3           renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferF32x3]
 66 : ArraySizeName  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferF32x4]
 67 : F32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferF32x4]
 68 : F32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferF32x4]
 69 : F32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferF32x4]
 70 : F32            renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].w                      RefVariant[BufferF32x4]
 71 : ArraySizeName  renderMeshAsset.submeshes[].indexBuffer                                          RefVariant[SubmeshParameters]
 72 : U32            renderMeshAsset.submeshes[].indexBuffer[]                                        RefVariant[SubmeshParameters]
 73 : ArraySizeName  renderMeshAsset.submeshes[].vertexPartition                                      RefVariant[SubmeshParameters]
 74 : U32            renderMeshAsset.submeshes[].vertexPartition[]                                    RefVariant[SubmeshParameters]
 75 : ArraySizeName  renderMeshAsset.submeshes[].indexPartition                                       RefVariant[SubmeshParameters]
 76 : U32            renderMeshAsset.submeshes[].indexPartition[]                                     RefVariant[SubmeshParameters]
 77 : ArraySizeName  renderMeshAsset.submeshes[].smoothingGroups                                      RefVariant[SubmeshParameters]
 78 : U32            renderMeshAsset.submeshes[].smoothingGroups[]                                    RefVariant[SubmeshParameters]
 79 : ArraySizeName  renderMeshAsset.materialNames                                                    RefVariant[RenderMeshAssetParameters]
 80 : String         renderMeshAsset.materialNames[]                                                  RefVariant[RenderMeshAssetParameters]
 81 : ArraySizeName  renderMeshAsset.partBounds                                                       RefVariant[RenderMeshAssetParameters]
 82 : Bounds3        renderMeshAsset.partBounds[]                                                     RefVariant[RenderMeshAssetParameters]
 83 : U32            renderMeshAsset.textureUVOrigin                                                  RefVariant[RenderMeshAssetParameters]
 84 : U32            renderMeshAsset.boneCount                                                        RefVariant[RenderMeshAssetParameters]
 85 : Bool           renderMeshAsset.deleteStaticBuffersAfterUse                                      RefVariant[RenderMeshAssetParameters]
 86 : Bool           renderMeshAsset.isReferenced                                                     RefVariant[RenderMeshAssetParameters]
 87 : ArraySizeName  immediateClothMap
 88 : U32            immediateClothMap[]
 89 : ArraySizeName  skinClothMapB
 90 : Vec3           skinClothMapB[].vtxTetraBary
 91 : U32            skinClothMapB[].vertexIndexPlusOffset
 92 : Vec3           skinClothMapB[].nrmTetraBary
 93 : U32            skinClothMapB[].faceIndex0
 94 : U32            skinClothMapB[].tetraIndex
 95 : U32            skinClothMapB[].submeshIndex
 96 : ArraySizeName  skinClothMap
 97 : Vec3           skinClothMap[].vertexBary
 98 : U32            skinClothMap[].vertexIndex0
 99 : Vec3           skinClothMap[].normalBary
100 : U32            skinClothMap[].vertexIndex1
101 : Vec3           skinClothMap[].tangentBary
102 : U32            skinClothMap[].vertexIndex2
103 : U32            skinClothMap[].vertexIndexPlusOffset
104 : F32            skinClothMapThickness
105 : F32            skinClothMapOffset
106 : ArraySizeName  tetraMap
107 : Vec3           tetraMap[].vertexBary
108 : U32            tetraMap[].tetraIndex0
109 : Vec3           tetraMap[].normalBary
110 : U32            tetraMap[]._dummyForAlignment
111 : U32            renderMeshAssetSorting
112 : ArraySizeName  physicsSubmeshPartitioning
113 : U32            physicsSubmeshPartitioning[].graphicalSubmesh
114 : U32            physicsSubmeshPartitioning[].physicalSubmesh
115 : U32            physicsSubmeshPartitioning[].numSimulatedVertices
116 : U32            physicsSubmeshPartitioning[].numSimulatedVerticesAdditional
117 : U32            physicsSubmeshPartitioning[].numSimulatedIndices

Member Data Documentation

U32 ClothingGraphicalLodParameters::immediateClothMap[]

'immediateClothMap[]' : Directly map some of the physically simulated vertices on the graphical mesh

If some vertices can not be mapped properly, they will use the skinClothMapB to tie to the physical mesh.

U32 ClothingGraphicalLodParameters::lod

'lod' : The actual LoD value

Even for a small number of LoDs, the LoD value does not have to be continuous. An Asset can have 3 LoDs at leve 0, 3 and 6.

U32 ClothingGraphicalLodParameters::physicalMeshId

'physicalMeshId' : Index of the physical mesh used for this graphical mesh.

This indexes a physical mesh from the physicalMesh Array in the ClothingAsset. Different graphical LoDs can share a physical mesh.

U32 ClothingGraphicalLodParameters::physicsSubmeshPartitioning[].graphicalSubmesh

'physicsSubmeshPartitioning[].graphicalSubmesh' : Graphical submesh

U32 ClothingGraphicalLodParameters::physicsSubmeshPartitioning[].numSimulatedIndices

'physicsSubmeshPartitioning[].numSimulatedIndices' : Simulated index count

U32 ClothingGraphicalLodParameters::physicsSubmeshPartitioning[].numSimulatedVertices

'physicsSubmeshPartitioning[].numSimulatedVertices' : Simulated vertex count

U32 ClothingGraphicalLodParameters::physicsSubmeshPartitioning[].numSimulatedVerticesAdditional

'physicsSubmeshPartitioning[].numSimulatedVerticesAdditional' : Simulated additional vertex count

U32 ClothingGraphicalLodParameters::physicsSubmeshPartitioning[].physicalSubmesh

'physicsSubmeshPartitioning[].physicalSubmesh' : Physical submesh

String ClothingGraphicalLodParameters::platforms[]

'platforms[]' : Platforms on this lod is used.

The assets can be prepared for different platforms. This string specifies for which platforms this LOD is kept in the asset.

RenderMeshAssetParameters ClothingGraphicalLodParameters::renderMeshAsset

'renderMeshAsset' :

U32 ClothingGraphicalLodParameters::renderMeshAssetSorting

'renderMeshAssetSorting' : Render mesh asset sorting

Vec3 ClothingGraphicalLodParameters::skinClothMap[].normalBary

'skinClothMap[].normalBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.

Vec3 ClothingGraphicalLodParameters::skinClothMap[].tangentBary

'skinClothMap[].tangentBary' : The barycentric coordinate of (position+tangent). When position is subtracted this will result in the tangent again.

Vec3 ClothingGraphicalLodParameters::skinClothMap[].vertexBary

'skinClothMap[].vertexBary' : The barycentric coordinate into the triangle.

U32 ClothingGraphicalLodParameters::skinClothMap[].vertexIndex0

'skinClothMap[].vertexIndex0' : Vertex index of the physics triangle.

U32 ClothingGraphicalLodParameters::skinClothMap[].vertexIndex1

'skinClothMap[].vertexIndex1' : Vertex index of the physics triangle.

U32 ClothingGraphicalLodParameters::skinClothMap[].vertexIndex2

'skinClothMap[].vertexIndex2' : Vertex index of the physics triangle.

U32 ClothingGraphicalLodParameters::skinClothMap[].vertexIndexPlusOffset

'skinClothMap[].vertexIndexPlusOffset' : The vertex index in the graphical mesh (the target index).

U32 ClothingGraphicalLodParameters::skinClothMapB[].faceIndex0

'skinClothMapB[].faceIndex0' : First index of the 3 consecutive indices making the physical triangle.

Vec3 ClothingGraphicalLodParameters::skinClothMapB[].nrmTetraBary

'skinClothMapB[].nrmTetraBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.

U32 ClothingGraphicalLodParameters::skinClothMapB[].submeshIndex

'skinClothMapB[].submeshIndex' : Index into which Physical Submesh/LoD this element of the mapping belongs to.

This is only needed during the authoring stage and thus does not need to be serialized.

U32 ClothingGraphicalLodParameters::skinClothMapB[].tetraIndex

'skinClothMapB[].tetraIndex' : Selects which of the 6 implicit tetrahedrons is used for the mapping.

U32 ClothingGraphicalLodParameters::skinClothMapB[].vertexIndexPlusOffset

'skinClothMapB[].vertexIndexPlusOffset' : The vertex index in the graphical mesh (the target index).

Vec3 ClothingGraphicalLodParameters::skinClothMapB[].vtxTetraBary

'skinClothMapB[].vtxTetraBary' : The barycentric coordinate into the implicit tetrahedron.

F32 ClothingGraphicalLodParameters::skinClothMapOffset

'skinClothMapOffset' : Normal offset of the mesh implicitly defined around the flat physical (triangle) mesh.

The length of the normals when added to the vertex to generate the barycentric coordinates.

F32 ClothingGraphicalLodParameters::skinClothMapThickness

'skinClothMapThickness' : Thickness of the mesh implicitly defined around the flat physical (triangle) mesh.

The physical mesh is expanded to both directions with this thickness, resulting in the doubled thickness. Only used for Mesh-Mesh Skinning.

U32 ClothingGraphicalLodParameters::tetraMap[]._dummyForAlignment

'tetraMap[]._dummyForAlignment' : Does not hold any data, only helps the alignment of the struct.

Vec3 ClothingGraphicalLodParameters::tetraMap[].normalBary

'tetraMap[].normalBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.

U32 ClothingGraphicalLodParameters::tetraMap[].tetraIndex0

'tetraMap[].tetraIndex0' : First index of the 4 consecutive indices making the physical tetrahedron.

Vec3 ClothingGraphicalLodParameters::tetraMap[].vertexBary

'tetraMap[].vertexBary' : The barycentric coordinate into the tetrahedron.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ClothingGraphicalLodParameters Member List
This is the complete list of members for ClothingGraphicalLodParameters, including all inherited members.
immediateClothMap[] | ClothingGraphicalLodParameters
lod | ClothingGraphicalLodParameters
physicalMeshId | ClothingGraphicalLodParameters
physicsSubmeshPartitioning[].graphicalSubmesh | ClothingGraphicalLodParameters
physicsSubmeshPartitioning[].numSimulatedIndices | ClothingGraphicalLodParameters
physicsSubmeshPartitioning[].numSimulatedVertices | ClothingGraphicalLodParameters
physicsSubmeshPartitioning[].numSimulatedVerticesAdditional | ClothingGraphicalLodParameters
physicsSubmeshPartitioning[].physicalSubmesh | ClothingGraphicalLodParameters
platforms[] | ClothingGraphicalLodParameters
renderMeshAsset | ClothingGraphicalLodParameters
renderMeshAssetSorting | ClothingGraphicalLodParameters
skinClothMap[].normalBary | ClothingGraphicalLodParameters
skinClothMap[].tangentBary | ClothingGraphicalLodParameters
skinClothMap[].vertexBary | ClothingGraphicalLodParameters
skinClothMap[].vertexIndex0 | ClothingGraphicalLodParameters
skinClothMap[].vertexIndex1 | ClothingGraphicalLodParameters
skinClothMap[].vertexIndex2 | ClothingGraphicalLodParameters
skinClothMap[].vertexIndexPlusOffset | ClothingGraphicalLodParameters
skinClothMapB[].faceIndex0 | ClothingGraphicalLodParameters
skinClothMapB[].nrmTetraBary | ClothingGraphicalLodParameters
skinClothMapB[].submeshIndex | ClothingGraphicalLodParameters
skinClothMapB[].tetraIndex | ClothingGraphicalLodParameters
skinClothMapB[].vertexIndexPlusOffset | ClothingGraphicalLodParameters
skinClothMapB[].vtxTetraBary | ClothingGraphicalLodParameters
skinClothMapOffset | ClothingGraphicalLodParameters
skinClothMapThickness | ClothingGraphicalLodParameters
tetraMap[]._dummyForAlignment | ClothingGraphicalLodParameters
tetraMap[].normalBary | ClothingGraphicalLodParameters
tetraMap[].tetraIndex0 | ClothingGraphicalLodParameters
tetraMap[].vertexBary | ClothingGraphicalLodParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ClothingMaterialLibraryParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
ClothingMaterialLibraryParameters Struct Reference

Describes the NxParameterized::Interface for 'ClothingMaterialLibraryParameters' : More...

#include <params.h>

List of all members.

Public Attributes

String | materials[].materialName
'materials[].materialName' : Material name
F32 | materials[].verticalStretchingStiffness
'materials[].verticalStretchingStiffness' : Vertical stretching stiffness of the cloth in the range (0, 1]. This parameter is ignored by the PhysX 2.8.4 solver.
F32 | materials[].horizontalStretchingStiffness
'materials[].horizontalStretchingStiffness' : Horizontal Stretching stiffness of the cloth in the range (0, 1].
F32 | materials[].bendingStiffness
'materials[].bendingStiffness' : Bending stiffness of the cloth in the range [0, 1].
F32 | materials[].shearingStiffness
'materials[].shearingStiffness' : Shearing stiffness of the cloth in the range [0, 1].
F32 | materials[].tetherStiffness
'materials[].tetherStiffness' : Range [0, 1], but should be 0. The higher this value, the more the piece of clothing is allowed to stretch.
F32 | materials[].tetherLimit
'materials[].tetherLimit' : Range [1, 4], but should be 1. This scales the restlength of the tether constraints.
Bool | materials[].orthoBending
'materials[].orthoBending' : Enable/disable orthogonal bending resistance.
F32 | materials[].verticalStiffnessScaling.compressionRange
'materials[].verticalStiffnessScaling.compressionRange' : Multiplier relative to rest length that defines where the stiffness is scaled down to allow compression.
F32 | materials[].verticalStiffnessScaling.stretchRange
'materials[].verticalStiffnessScaling.stretchRange' : Multiplier relative to rest length that defines the range where the stiffness is scaled down to allow stretching.
F32 | materials[].verticalStiffnessScaling.scale
'materials[].verticalStiffnessScaling.scale' : Stiffness scale [0, 1] applied when inside the scaling range.
F32 | materials[].horizontalStiffnessScaling.compressionRange
'materials[].horizontalStiffnessScaling.compressionRange' : Multiplier relative to rest length that defines where the stiffness is scaled down to allow compression.
F32 | materials[].horizontalStiffnessScaling.stretchRange
'materials[].horizontalStiffnessScaling.stretchRange' : Multiplier relative to rest length that defines the range where the stiffness is scaled down to allow stretching.
F32 | materials[].horizontalStiffnessScaling.scale
'materials[].horizontalStiffnessScaling.scale' : Stiffness scale [0, 1] applied when inside the scaling range.
F32 | materials[].bendingStiffnessScaling.compressionRange
'materials[].bendingStiffnessScaling.compressionRange' : Multiplier relative to rest length that defines where the stiffness is scaled down to allow compression.
F32 | materials[].bendingStiffnessScaling.stretchRange
'materials[].bendingStiffnessScaling.stretchRange' : Multiplier relative to rest length that defines the range where the stiffness is scaled down to allow stretching.
F32 | materials[].bendingStiffnessScaling.scale
'materials[].bendingStiffnessScaling.scale' : Stiffness scale [0, 1] applied when inside the scaling range.
F32 | materials[].shearingStiffnessScaling.compressionRange
'materials[].shearingStiffnessScaling.compressionRange' : Multiplier relative to rest length that defines where the stiffness is scaled down to allow compression.
F32 | materials[].shearingStiffnessScaling.stretchRange
'materials[].shearingStiffnessScaling.stretchRange' : Multiplier relative to rest length that defines the range where the stiffness is scaled down to allow stretching.
F32 | materials[].shearingStiffnessScaling.scale
'materials[].shearingStiffnessScaling.scale' : Stiffness scale [0, 1] applied when inside the scaling range.
F32 | materials[].damping
'materials[].damping' : Spring damping of the cloth in the range [0, 1]
F32 | materials[].stiffnessFrequency
'materials[].stiffnessFrequency' : Scales linearity of behavior for the varous stiffness values in the interval (0, 1)
F32 | materials[].drag
'materials[].drag' : Drag coefficient n the range [0, 1]
Bool | materials[].comDamping
'materials[].comDamping' : Enable/disable center of mass damping of internal velocities.
F32 | materials[].friction
'materials[].friction' : Friction coefficient in the range [0, 1]
F32 | materials[].massScale
'materials[].massScale' : Controls the amount of mass scaling during collision [0, 100]
U32 | materials[].solverIterations
'materials[].solverIterations' : Number of solver iterations. For 2.x cloth
F32 | materials[].solverFrequency
'materials[].solverFrequency' : Number of solver iterations per second. For 3.x cloth
F32 | materials[].gravityScale
'materials[].gravityScale' : Amount of gravity that is applied to the cloth.
F32 | materials[].inertiaScale
'materials[].inertiaScale' : Amount of inertia that is kept when using local space simulation.
F32 | materials[].hardStretchLimitation
'materials[].hardStretchLimitation' : Make cloth simulation less stretchy. A value smaller than 1 will turn it off.
F32 | materials[].maxDistanceBias
'materials[].maxDistanceBias' : Deform the max distance sphere into a capsule or a disc.
U32 | materials[].hierarchicalSolverIterations
'materials[].hierarchicalSolverIterations' : Number of iterations of the hierarchical cloth solver.
F32 | materials[].selfcollisionThickness
'materials[].selfcollisionThickness' : Minimal amount of distance particles will keep of each other.
F32 | materials[].selfcollisionSquashScale
'materials[].selfcollisionSquashScale' : Amount of thickness scaling along surface normal.
F32 | materials[].selfcollisionStiffness
'materials[].selfcollisionStiffness' : Stiffness of self collision solver.

Detailed Description

Describes the NxParameterized::Interface for 'ClothingMaterialLibraryParameters' :

ClothingMaterialLibraryParameters contains 37 fully qualified names
---------------------------------------------
  1 : ArraySizeName  materials
  2 : String         materials[].materialName
  3 : F32            materials[].verticalStretchingStiffness
  4 : F32            materials[].horizontalStretchingStiffness
  5 : F32            materials[].bendingStiffness
  6 : F32            materials[].shearingStiffness
  7 : F32            materials[].tetherStiffness
  8 : F32            materials[].tetherLimit
  9 : Bool           materials[].orthoBending
 10 : F32            materials[].verticalStiffnessScaling.compressionRange
 11 : F32            materials[].verticalStiffnessScaling.stretchRange
 12 : F32            materials[].verticalStiffnessScaling.scale
 13 : F32            materials[].horizontalStiffnessScaling.compressionRange
 14 : F32            materials[].horizontalStiffnessScaling.stretchRange
 15 : F32            materials[].horizontalStiffnessScaling.scale
 16 : F32            materials[].bendingStiffnessScaling.compressionRange
 17 : F32            materials[].bendingStiffnessScaling.stretchRange
 18 : F32            materials[].bendingStiffnessScaling.scale
 19 : F32            materials[].shearingStiffnessScaling.compressionRange
 20 : F32            materials[].shearingStiffnessScaling.stretchRange
 21 : F32            materials[].shearingStiffnessScaling.scale
 22 : F32            materials[].damping
 23 : F32            materials[].stiffnessFrequency
 24 : F32            materials[].drag
 25 : Bool           materials[].comDamping
 26 : F32            materials[].friction
 27 : F32            materials[].massScale
 28 : U32            materials[].solverIterations
 29 : F32            materials[].solverFrequency
 30 : F32            materials[].gravityScale
 31 : F32            materials[].inertiaScale
 32 : F32            materials[].hardStretchLimitation
 33 : F32            materials[].maxDistanceBias
 34 : U32            materials[].hierarchicalSolverIterations
 35 : F32            materials[].selfcollisionThickness
 36 : F32            materials[].selfcollisionSquashScale
 37 : F32            materials[].selfcollisionStiffness

Member Data Documentation

F32 ClothingMaterialLibraryParameters::materials[].bendingStiffness

'materials[].bendingStiffness' : Bending stiffness of the cloth in the range [0, 1].

F32 ClothingMaterialLibraryParameters::materials[].bendingStiffnessScaling.compressionRange

'materials[].bendingStiffnessScaling.compressionRange' : Multiplier relative to rest length that defines where the stiffness is scaled down to allow compression.

For any edge where the simulated length is within the range [restlength, compressionRange*restlength], the scale will be multiplied on top of the regular stiffness. This is can be used to allow the cloth to compress more easily up to a certain limit.

F32 ClothingMaterialLibraryParameters::materials[].bendingStiffnessScaling.scale

'materials[].bendingStiffnessScaling.scale' : Stiffness scale [0, 1] applied when inside the scaling range.

F32 ClothingMaterialLibraryParameters::materials[].bendingStiffnessScaling.stretchRange

'materials[].bendingStiffnessScaling.stretchRange' : Multiplier relative to rest length that defines the range where the stiffness is scaled down to allow stretching.

For any edge where the simulated length is within the range [restlength, stretchRange*restlength], the scale will be multiplied on top of the regular stiffness. This is can be used to allow the cloth to stretch more easily up to a certain limit.

Bool ClothingMaterialLibraryParameters::materials[].comDamping

'materials[].comDamping' : Enable/disable center of mass damping of internal velocities.

If set, the global rigid body modes (translation and rotation) are extracted from damping. This way, the cloth can freely move and rotate even under high damping.

F32 ClothingMaterialLibraryParameters::materials[].damping

'materials[].damping' : Spring damping of the cloth in the range [0, 1]

F32 ClothingMaterialLibraryParameters::materials[].drag

'materials[].drag' : Drag coefficient n the range [0, 1]

The drag coefficient is the portion of local frame velocity that is applied to each particle.

F32 ClothingMaterialLibraryParameters::materials[].friction

'materials[].friction' : Friction coefficient in the range [0, 1]

Currently only spheres and capsules impose friction on the colliding particles.

F32 ClothingMaterialLibraryParameters::materials[].gravityScale

'materials[].gravityScale' : Amount of gravity that is applied to the cloth.

A value of 0 will make the cloth ignore gravity, a value of 10 will apply 10 times the gravity.

F32 ClothingMaterialLibraryParameters::materials[].hardStretchLimitation

'materials[].hardStretchLimitation' : Make cloth simulation less stretchy. A value smaller than 1 will turn it off.

Good values are usually between 1 and 1.1. Any value >= 1 will guarantee that a certain set of edges is not longer than that value times the initial rest length.

U32 ClothingMaterialLibraryParameters::materials[].hierarchicalSolverIterations

'materials[].hierarchicalSolverIterations' : Number of iterations of the hierarchical cloth solver.

F32 ClothingMaterialLibraryParameters::materials[].horizontalStiffnessScaling.compressionRange

'materials[].horizontalStiffnessScaling.compressionRange' : Multiplier relative to rest length that defines where the stiffness is scaled down to allow compression.

For any edge where the simulated length is within the range [restlength, compressionRange*restlength], the scale will be multiplied on top of the regular stiffness. This is can be used to allow the cloth to compress more easily up to a certain limit.

F32 ClothingMaterialLibraryParameters::materials[].horizontalStiffnessScaling.scale

'materials[].horizontalStiffnessScaling.scale' : Stiffness scale [0, 1] applied when inside the scaling range.

F32 ClothingMaterialLibraryParameters::materials[].horizontalStiffnessScaling.stretchRange

'materials[].horizontalStiffnessScaling.stretchRange' : Multiplier relative to rest length that defines the range where the stiffness is scaled down to allow stretching.

For any edge where the simulated length is within the range [restlength, stretchRange*restlength], the scale will be multiplied on top of the regular stiffness. This is can be used to allow the cloth to stretch more easily up to a certain limit.

F32 ClothingMaterialLibraryParameters::materials[].horizontalStretchingStiffness

'materials[].horizontalStretchingStiffness' : Horizontal Stretching stiffness of the cloth in the range (0, 1].

F32 ClothingMaterialLibraryParameters::materials[].inertiaScale

'materials[].inertiaScale' : Amount of inertia that is kept when using local space simulation.

A value of 0 will make the cloth move in global space without inertia, a value of 1 will keep all inertia.

F32 ClothingMaterialLibraryParameters::materials[].massScale

'materials[].massScale' : Controls the amount of mass scaling during collision [0, 100]

String ClothingMaterialLibraryParameters::materials[].materialName

'materials[].materialName' : Material name

F32 ClothingMaterialLibraryParameters::materials[].maxDistanceBias

'materials[].maxDistanceBias' : Deform the max distance sphere into a capsule or a disc.

A value smaller than 0 will turn the sphere into a capsule and eventually a line (at value -1) along the normal of the vertex. A value bigger than 0 will turn the sphere into a disc.

Bool ClothingMaterialLibraryParameters::materials[].orthoBending

'materials[].orthoBending' : Enable/disable orthogonal bending resistance.

Bending is modeled via an angular spring between adjacent triangles. This mode is slower but independent of stretching resistance.

F32 ClothingMaterialLibraryParameters::materials[].selfcollisionSquashScale

'materials[].selfcollisionSquashScale' : Amount of thickness scaling along surface normal.

This feature prevents self collision thickness becoming too high for low resolution cloth.

F32 ClothingMaterialLibraryParameters::materials[].selfcollisionStiffness

'materials[].selfcollisionStiffness' : Stiffness of self collision solver.

This feature prevents meshes from self-intersecting. Only works properly when configured properly.

F32 ClothingMaterialLibraryParameters::materials[].selfcollisionThickness

'materials[].selfcollisionThickness' : Minimal amount of distance particles will keep of each other.

This feature prevents meshes from self-intersecting. Only works properly when configured properly.

F32 ClothingMaterialLibraryParameters::materials[].shearingStiffness

'materials[].shearingStiffness' : Shearing stiffness of the cloth in the range [0, 1].

F32 ClothingMaterialLibraryParameters::materials[].shearingStiffnessScaling.compressionRange

'materials[].shearingStiffnessScaling.compressionRange' : Multiplier relative to rest length that defines where the stiffness is scaled down to allow compression.

For any edge where the simulated length is within the range [restlength, compressionRange*restlength], the scale will be multiplied on top of the regular stiffness. This is can be used to allow the cloth to compress more easily up to a certain limit.

F32 ClothingMaterialLibraryParameters::materials[].shearingStiffnessScaling.scale

'materials[].shearingStiffnessScaling.scale' : Stiffness scale [0, 1] applied when inside the scaling range.

F32 ClothingMaterialLibraryParameters::materials[].shearingStiffnessScaling.stretchRange

'materials[].shearingStiffnessScaling.stretchRange' : Multiplier relative to rest length that defines the range where the stiffness is scaled down to allow stretching.

For any edge where the simulated length is within the range [restlength, stretchRange*restlength], the scale will be multiplied on top of the regular stiffness. This is can be used to allow the cloth to stretch more easily up to a certain limit.

F32 ClothingMaterialLibraryParameters::materials[].solverFrequency

'materials[].solverFrequency' : Number of solver iterations per second. For 3.x cloth

Small numbers make the simulation faster while the cloth gets less stiff.

U32 ClothingMaterialLibraryParameters::materials[].solverIterations

'materials[].solverIterations' : Number of solver iterations. For 2.x cloth

Small numbers make the simulation faster while the cloth gets less stiff.

F32 ClothingMaterialLibraryParameters::materials[].stiffnessFrequency

'materials[].stiffnessFrequency' : Scales linearity of behavior for the varous stiffness values in the interval (0, 1)

F32 ClothingMaterialLibraryParameters::materials[].tetherLimit

'materials[].tetherLimit' : Range [1, 4], but should be 1. This scales the restlength of the tether constraints.

F32 ClothingMaterialLibraryParameters::materials[].tetherStiffness

'materials[].tetherStiffness' : Range [0, 1], but should be 0. The higher this value, the more the piece of clothing is allowed to stretch.

F32 ClothingMaterialLibraryParameters::materials[].verticalStiffnessScaling.compressionRange

'materials[].verticalStiffnessScaling.compressionRange' : Multiplier relative to rest length that defines where the stiffness is scaled down to allow compression.

For any edge where the simulated length is within the range [restlength, compressionRange*restlength], the scale will be multiplied on top of the regular stiffness. This is can be used to allow the cloth to compress more easily up to a certain limit.

F32 ClothingMaterialLibraryParameters::materials[].verticalStiffnessScaling.scale

'materials[].verticalStiffnessScaling.scale' : Stiffness scale [0, 1] applied when inside the scaling range.

F32 ClothingMaterialLibraryParameters::materials[].verticalStiffnessScaling.stretchRange

'materials[].verticalStiffnessScaling.stretchRange' : Multiplier relative to rest length that defines the range where the stiffness is scaled down to allow stretching.

For any edge where the simulated length is within the range [restlength, stretchRange*restlength], the scale will be multiplied on top of the regular stiffness. This is can be used to allow the cloth to stretch more easily up to a certain limit.

F32 ClothingMaterialLibraryParameters::materials[].verticalStretchingStiffness

'materials[].verticalStretchingStiffness' : Vertical stretching stiffness of the cloth in the range (0, 1]. This parameter is ignored by the PhysX 2.8.4 solver.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ClothingMaterialLibraryParameters Member List
This is the complete list of members for ClothingMaterialLibraryParameters, including all inherited members.
materials[].bendingStiffness | ClothingMaterialLibraryParameters
materials[].bendingStiffnessScaling.compressionRange | ClothingMaterialLibraryParameters
materials[].bendingStiffnessScaling.scale | ClothingMaterialLibraryParameters
materials[].bendingStiffnessScaling.stretchRange | ClothingMaterialLibraryParameters
materials[].comDamping | ClothingMaterialLibraryParameters
materials[].damping | ClothingMaterialLibraryParameters
materials[].drag | ClothingMaterialLibraryParameters
materials[].friction | ClothingMaterialLibraryParameters
materials[].gravityScale | ClothingMaterialLibraryParameters
materials[].hardStretchLimitation | ClothingMaterialLibraryParameters
materials[].hierarchicalSolverIterations | ClothingMaterialLibraryParameters
materials[].horizontalStiffnessScaling.compressionRange | ClothingMaterialLibraryParameters
materials[].horizontalStiffnessScaling.scale | ClothingMaterialLibraryParameters
materials[].horizontalStiffnessScaling.stretchRange | ClothingMaterialLibraryParameters
materials[].horizontalStretchingStiffness | ClothingMaterialLibraryParameters
materials[].inertiaScale | ClothingMaterialLibraryParameters
materials[].massScale | ClothingMaterialLibraryParameters
materials[].materialName | ClothingMaterialLibraryParameters
materials[].maxDistanceBias | ClothingMaterialLibraryParameters
materials[].orthoBending | ClothingMaterialLibraryParameters
materials[].selfcollisionSquashScale | ClothingMaterialLibraryParameters
materials[].selfcollisionStiffness | ClothingMaterialLibraryParameters
materials[].selfcollisionThickness | ClothingMaterialLibraryParameters
materials[].shearingStiffness | ClothingMaterialLibraryParameters
materials[].shearingStiffnessScaling.compressionRange | ClothingMaterialLibraryParameters
materials[].shearingStiffnessScaling.scale | ClothingMaterialLibraryParameters
materials[].shearingStiffnessScaling.stretchRange | ClothingMaterialLibraryParameters
materials[].solverFrequency | ClothingMaterialLibraryParameters
materials[].solverIterations | ClothingMaterialLibraryParameters
materials[].stiffnessFrequency | ClothingMaterialLibraryParameters
materials[].tetherLimit | ClothingMaterialLibraryParameters
materials[].tetherStiffness | ClothingMaterialLibraryParameters
materials[].verticalStiffnessScaling.compressionRange | ClothingMaterialLibraryParameters
materials[].verticalStiffnessScaling.scale | ClothingMaterialLibraryParameters
materials[].verticalStiffnessScaling.stretchRange | ClothingMaterialLibraryParameters
materials[].verticalStretchingStiffness | ClothingMaterialLibraryParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ClothingModuleParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
ClothingModuleParameters Struct Reference

Describes the NxParameterized::Interface for 'ClothingModuleParameters' : This class is used for initializing the NxModuleClothing. More...

#include <params.h>

List of all members.

Public Attributes

U32 | maxNumCompartments
'maxNumCompartments' : Maximum number of compartments to distribute the cloths and softbodies of the same type. Works only with PhysX 2.8.4
U32 | maxUnusedPhysXResources
'maxUnusedPhysXResources' : Maximum number of NxCloth/NxSoftBody instances that are not used.
Bool | allowAsyncCooking
'allowAsyncCooking' : ClothingActors will cook in a background thread to speed up creation time.
Bool | asyncFetchResults
'asyncFetchResults' : Let fetch results tasks run longer than the fetchResults call, they will block at the next updateRenderResource call.
U32 | avgSimFrequencyWindow
'avgSimFrequencyWindow' : Average Simulation Frequency is estimated with the last n frames
Bool | allowApexWorkBetweenSubsteps
'allowApexWorkBetweenSubsteps' : Allow APEX SDK to interpolate clothing matrices between the substeps.
F32 | interCollisionDistance
'interCollisionDistance' : Experimental. Radius of the collision between different clothing actors. (3.x solver mode)
F32 | interCollisionStiffness
'interCollisionStiffness' : Experimental. Stiffness of the collision between different clothing actors. (3.x solver mode)
U32 | interCollisionIterations
'interCollisionIterations' : Experimental. Number of Iterations for the collision between different clothing actors. (3.x solver mode)
Bool | sparseSelfCollision
'sparseSelfCollision' : Experimental. Only use a subset of particles for self-collision. (3.x solver mode)
U32 | maxTimeRenderProxyInPool
'maxTimeRenderProxyInPool' : Maximum number of frames a RenderProxy object can stay the object pool before the memory is released

Detailed Description

Describes the NxParameterized::Interface for 'ClothingModuleParameters' : This class is used for initializing the NxModuleClothing.

ClothingModuleParameters contains 11 fully qualified names
---------------------------------------------
  1 : U32   maxNumCompartments
  2 : U32   maxUnusedPhysXResources
  3 : Bool  allowAsyncCooking
  4 : Bool  asyncFetchResults
  5 : U32   avgSimFrequencyWindow
  6 : Bool  allowApexWorkBetweenSubsteps
  7 : F32   interCollisionDistance
  8 : F32   interCollisionStiffness
  9 : U32   interCollisionIterations
 10 : Bool  sparseSelfCollision
 11 : U32   maxTimeRenderProxyInPool

Member Data Documentation

Bool ClothingModuleParameters::allowApexWorkBetweenSubsteps

'allowApexWorkBetweenSubsteps' : Allow APEX SDK to interpolate clothing matrices between the substeps.

The clothing module can interpolate matrices between substeps. However, for this APEX needs to call simulate/fetchResults several times per frame. This causes problems if physX particles are handled by the application in the same scene. The application needs to be able to read particle buffers with deletion IDs after each fetchResults, which is not possible in that case. Use allowApexWorkBetweenSubsteps to enable matrix interpolation between substeps.

Bool ClothingModuleParameters::allowAsyncCooking

'allowAsyncCooking' : ClothingActors will cook in a background thread to speed up creation time.

This can be turned off if unexpected bugs/crashes occur.

Bool ClothingModuleParameters::asyncFetchResults

'asyncFetchResults' : Let fetch results tasks run longer than the fetchResults call, they will block at the next updateRenderResource call.

Note that ApexPostTickTime from the scene stats will not be correct if true. Caution: Do not set this to false when simulate and/or fetchResults is called from a PxTask. fetchResults can block and wait for other tasks in this case, which can cause a deadlock if the dispatcher is using only 1 workerthread.

U32 ClothingModuleParameters::avgSimFrequencyWindow

'avgSimFrequencyWindow' : Average Simulation Frequency is estimated with the last n frames

F32 ClothingModuleParameters::interCollisionDistance

'interCollisionDistance' : Experimental. Radius of the collision between different clothing actors. (3.x solver mode)

Experimental. Set the radius to 0.0 to disable inter-collision.

U32 ClothingModuleParameters::interCollisionIterations

'interCollisionIterations' : Experimental. Number of Iterations for the collision between different clothing actors. (3.x solver mode)

F32 ClothingModuleParameters::interCollisionStiffness

'interCollisionStiffness' : Experimental. Stiffness of the collision between different clothing actors. (3.x solver mode)

U32 ClothingModuleParameters::maxNumCompartments

'maxNumCompartments' : Maximum number of compartments to distribute the cloths and softbodies of the same type. Works only with PhysX 2.8.4

To parallelize work hw cloth, sw cloth, hw softbodies and sw softbodies are distributed into different compartments. For each type maximally maxNumCompartments compartments are created in a scene.

U32 ClothingModuleParameters::maxTimeRenderProxyInPool

'maxTimeRenderProxyInPool' : Maximum number of frames a RenderProxy object can stay the object pool before the memory is released

U32 ClothingModuleParameters::maxUnusedPhysXResources

'maxUnusedPhysXResources' : Maximum number of NxCloth/NxSoftBody instances that are not used.

Not used instances are generated when NxClothingActors are released or their benefit is not high enough to allow simulation. Then they will return the NxCloth/NxSoftBody and the list of NxActors to their asset where it will be cached until another NxClothingActor needs them.

Bool ClothingModuleParameters::sparseSelfCollision

'sparseSelfCollision' : Experimental. Only use a subset of particles for self-collision. (3.x solver mode)

Experimental. The particle subset is part of the cooked data and depends on the assets selfCollision radius.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ClothingModuleParameters Member List
This is the complete list of members for ClothingModuleParameters, including all inherited members.
allowApexWorkBetweenSubsteps | ClothingModuleParameters
allowAsyncCooking | ClothingModuleParameters
asyncFetchResults | ClothingModuleParameters
avgSimFrequencyWindow | ClothingModuleParameters
interCollisionDistance | ClothingModuleParameters
interCollisionIterations | ClothingModuleParameters
interCollisionStiffness | ClothingModuleParameters
maxNumCompartments | ClothingModuleParameters
maxTimeRenderProxyInPool | ClothingModuleParameters
maxUnusedPhysXResources | ClothingModuleParameters
sparseSelfCollision | ClothingModuleParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ClothingPhysicalMeshParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
ClothingPhysicalMeshParameters Struct Reference

Describes the NxParameterized::Interface for 'ClothingPhysicalMeshParameters' : More...

#include <params.h>

List of all members.

Public Attributes

U32 | physicalMesh.numVertices
'physicalMesh.numVertices' : Number of vertices of this mesh
U32 | physicalMesh.numIndices
'physicalMesh.numIndices' : Number of indices of this mesh
U32 | physicalMesh.numBonesPerVertex
'physicalMesh.numBonesPerVertex' : Number of bone weights/indices per vertex
Vec3 | physicalMesh.vertices[]
'physicalMesh.vertices[]' : Array of vertices
Vec3 | physicalMesh.normals[]
'physicalMesh.normals[]' : Array of normals
Vec3 | physicalMesh.skinningNormals[]
'physicalMesh.skinningNormals[]' : Array of skinning normals
F32 | physicalMesh.constrainCoefficients[].maxDistance
'physicalMesh.constrainCoefficients[].maxDistance' : Maximum distance this vertex is allowed to travel from its skinned position.
F32 | physicalMesh.constrainCoefficients[].collisionSphereRadius
'physicalMesh.constrainCoefficients[].collisionSphereRadius' : Size of the Backstop collision sphere.
F32 | physicalMesh.constrainCoefficients[].collisionSphereDistance
'physicalMesh.constrainCoefficients[].collisionSphereDistance' : Distance of the Backstop collision sphere.
U16 | physicalMesh.boneIndices[]
'physicalMesh.boneIndices[]' : The bone indices per vertex
F32 | physicalMesh.boneWeights[]
'physicalMesh.boneWeights[]' : The bone weights per vertex
U8 | physicalMesh.optimizationData[]
'physicalMesh.optimizationData[]' : Per Vertex Number of boneweights > 0, bool if it has negative collision distance
Bool | physicalMesh.hasNegativeBackstop
'physicalMesh.hasNegativeBackstop' : True if at least 1 has negative collision distance
Bool | physicalMesh.isClosed
'physicalMesh.isClosed' : True if all edges have two adjacent triangles
U32 | physicalMesh.indices[]
'physicalMesh.indices[]' : The index buffer
F32 | physicalMesh.maximumMaxDistance
'physicalMesh.maximumMaxDistance' : The maximum max-distance value for all the vertices.
U32 | physicalMesh.physicalMeshSorting
'physicalMesh.physicalMeshSorting' : Physical mesh sorting
F32 | physicalMesh.shortestEdgeLength
'physicalMesh.shortestEdgeLength' : Mesh statistic, only needed for debug rendering.
F32 | physicalMesh.averageEdgeLength
'physicalMesh.averageEdgeLength' : Mesh statistic, useful for selecting the thickness of the mesh-mesh skinning.
Bool | physicalMesh.isTetrahedralMesh
'physicalMesh.isTetrahedralMesh' : Are we storing triangles or tetrahedrons in this mesh.
Bool | physicalMesh.flipNormals
'physicalMesh.flipNormals' : True when the model has been transformed to left-handed space.
U32 | submeshes[].numIndices
'submeshes[].numIndices' : Size of the index buffer
U32 | submeshes[].numVertices
'submeshes[].numVertices' : Size of the vertex buffers
U32 | submeshes[].numMaxDistance0Vertices
'submeshes[].numMaxDistance0Vertices' : Number of vertices that have max distance set to 0 in this submesh.
U32 | physicalLods[].costWithoutIterations
'physicalLods[].costWithoutIterations' : costs are numVertices * numSolverIterations. This is numVertices
U32 | physicalLods[].submeshId
'physicalLods[].submeshId' : Index of the Submesh that belongs to this LoD.
F32 | physicalLods[].solverIterationScale
'physicalLods[].solverIterationScale' : Take only a fraction of the Mesh's solver iterations for this LoD.
F32 | physicalLods[].maxDistanceReduction
'physicalLods[].maxDistanceReduction' : The amount of maxDistance that gets subtracted when this LoD is active.
Vec3 | transitionUpB[].vtxTetraBary
'transitionUpB[].vtxTetraBary' : The barycentric coordinate into the implicit tetrahedron.
U32 | transitionUpB[].vertexIndexPlusOffset
'transitionUpB[].vertexIndexPlusOffset' : The vertex index in the graphical mesh (the target index).
Vec3 | transitionUpB[].nrmTetraBary
'transitionUpB[].nrmTetraBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.
U32 | transitionUpB[].faceIndex0
'transitionUpB[].faceIndex0' : First index of the 3 consecutive indices making the physical triangle.
U32 | transitionUpB[].tetraIndex
'transitionUpB[].tetraIndex' : Selects which of the 6 implicit tetrahedrons is used for the mapping.
U32 | transitionUpB[].submeshIndex
'transitionUpB[].submeshIndex' : Index into which Physical Submesh/LoD this element of the mapping belongs to.
Vec3 | transitionUp[].vertexBary
'transitionUp[].vertexBary' : The barycentric coordinate into the triangle.
U32 | transitionUp[].vertexIndex0
'transitionUp[].vertexIndex0' : Vertex index of the physics triangle.
Vec3 | transitionUp[].normalBary
'transitionUp[].normalBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.
U32 | transitionUp[].vertexIndex1
'transitionUp[].vertexIndex1' : Vertex index of the physics triangle.
Vec3 | transitionUp[].tangentBary
'transitionUp[].tangentBary' : The barycentric coordinate of (position+tangent). When position is subtracted this will result in the tangent again.
U32 | transitionUp[].vertexIndex2
'transitionUp[].vertexIndex2' : Vertex index of the physics triangle.
U32 | transitionUp[].vertexIndexPlusOffset
'transitionUp[].vertexIndexPlusOffset' : The vertex index in the graphical mesh (the target index).
F32 | transitionUpThickness
'transitionUpThickness' : The thickness of the transition map
F32 | transitionUpOffset
'transitionUpOffset' : The normal offset of the transition map
Vec3 | transitionDownB[].vtxTetraBary
'transitionDownB[].vtxTetraBary' : The barycentric coordinate into the implicit tetrahedron.
U32 | transitionDownB[].vertexIndexPlusOffset
'transitionDownB[].vertexIndexPlusOffset' : The vertex index in the graphical mesh (the target index).
Vec3 | transitionDownB[].nrmTetraBary
'transitionDownB[].nrmTetraBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.
U32 | transitionDownB[].faceIndex0
'transitionDownB[].faceIndex0' : First index of the 3 consecutive indices making the physical triangle.
U32 | transitionDownB[].tetraIndex
'transitionDownB[].tetraIndex' : Selects which of the 6 implicit tetrahedrons is used for the mapping.
U32 | transitionDownB[].submeshIndex
'transitionDownB[].submeshIndex' : Index into which Physical Submesh/LoD this element of the mapping belongs to.
Vec3 | transitionDown[].vertexBary
'transitionDown[].vertexBary' : The barycentric coordinate into the triangle.
U32 | transitionDown[].vertexIndex0
'transitionDown[].vertexIndex0' : Vertex index of the physics triangle.
Vec3 | transitionDown[].normalBary
'transitionDown[].normalBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.
U32 | transitionDown[].vertexIndex1
'transitionDown[].vertexIndex1' : Vertex index of the physics triangle.
Vec3 | transitionDown[].tangentBary
'transitionDown[].tangentBary' : The barycentric coordinate of (position+tangent). When position is subtracted this will result in the tangent again.
U32 | transitionDown[].vertexIndex2
'transitionDown[].vertexIndex2' : Vertex index of the physics triangle.
U32 | transitionDown[].vertexIndexPlusOffset
'transitionDown[].vertexIndexPlusOffset' : The vertex index in the graphical mesh (the target index).
F32 | transitionDownThickness
'transitionDownThickness' : The thickness of the transition map
F32 | transitionDownOffset
'transitionDownOffset' : The normal offset of the transition map
U32 | referenceCount
'referenceCount' : Only used internally, do not modify

Detailed Description

Describes the NxParameterized::Interface for 'ClothingPhysicalMeshParameters' :

ClothingPhysicalMeshParameters contains 73 fully qualified names
---------------------------------------------
  1 : U32            physicalMesh.numVertices
  2 : U32            physicalMesh.numIndices
  3 : U32            physicalMesh.numBonesPerVertex
  4 : ArraySizeName  vertices
  5 : Vec3           physicalMesh.vertices[]
  6 : ArraySizeName  normals
  7 : Vec3           physicalMesh.normals[]
  8 : ArraySizeName  skinningNormals
  9 : Vec3           physicalMesh.skinningNormals[]
 10 : ArraySizeName  constrainCoefficients
 11 : F32            physicalMesh.constrainCoefficients[].maxDistance
 12 : F32            physicalMesh.constrainCoefficients[].collisionSphereRadius
 13 : F32            physicalMesh.constrainCoefficients[].collisionSphereDistance
 14 : ArraySizeName  boneIndices
 15 : U16            physicalMesh.boneIndices[]
 16 : ArraySizeName  boneWeights
 17 : F32            physicalMesh.boneWeights[]
 18 : ArraySizeName  optimizationData
 19 : U8             physicalMesh.optimizationData[]
 20 : Bool           physicalMesh.hasNegativeBackstop
 21 : Bool           physicalMesh.isClosed
 22 : ArraySizeName  indices
 23 : U32            physicalMesh.indices[]
 24 : F32            physicalMesh.maximumMaxDistance
 25 : U32            physicalMesh.physicalMeshSorting
 26 : F32            physicalMesh.shortestEdgeLength
 27 : F32            physicalMesh.averageEdgeLength
 28 : Bool           physicalMesh.isTetrahedralMesh
 29 : Bool           physicalMesh.flipNormals
 30 : ArraySizeName  submeshes
 31 : U32            submeshes[].numIndices
 32 : U32            submeshes[].numVertices
 33 : U32            submeshes[].numMaxDistance0Vertices
 34 : ArraySizeName  physicalLods
 35 : U32            physicalLods[].costWithoutIterations
 36 : U32            physicalLods[].submeshId
 37 : F32            physicalLods[].solverIterationScale
 38 : F32            physicalLods[].maxDistanceReduction
 39 : ArraySizeName  transitionUpB
 40 : Vec3           transitionUpB[].vtxTetraBary
 41 : U32            transitionUpB[].vertexIndexPlusOffset
 42 : Vec3           transitionUpB[].nrmTetraBary
 43 : U32            transitionUpB[].faceIndex0
 44 : U32            transitionUpB[].tetraIndex
 45 : U32            transitionUpB[].submeshIndex
 46 : ArraySizeName  transitionUp
 47 : Vec3           transitionUp[].vertexBary
 48 : U32            transitionUp[].vertexIndex0
 49 : Vec3           transitionUp[].normalBary
 50 : U32            transitionUp[].vertexIndex1
 51 : Vec3           transitionUp[].tangentBary
 52 : U32            transitionUp[].vertexIndex2
 53 : U32            transitionUp[].vertexIndexPlusOffset
 54 : F32            transitionUpThickness
 55 : F32            transitionUpOffset
 56 : ArraySizeName  transitionDownB
 57 : Vec3           transitionDownB[].vtxTetraBary
 58 : U32            transitionDownB[].vertexIndexPlusOffset
 59 : Vec3           transitionDownB[].nrmTetraBary
 60 : U32            transitionDownB[].faceIndex0
 61 : U32            transitionDownB[].tetraIndex
 62 : U32            transitionDownB[].submeshIndex
 63 : ArraySizeName  transitionDown
 64 : Vec3           transitionDown[].vertexBary
 65 : U32            transitionDown[].vertexIndex0
 66 : Vec3           transitionDown[].normalBary
 67 : U32            transitionDown[].vertexIndex1
 68 : Vec3           transitionDown[].tangentBary
 69 : U32            transitionDown[].vertexIndex2
 70 : U32            transitionDown[].vertexIndexPlusOffset
 71 : F32            transitionDownThickness
 72 : F32            transitionDownOffset
 73 : U32            referenceCount

Member Data Documentation

U32 ClothingPhysicalMeshParameters::physicalLods[].costWithoutIterations

'physicalLods[].costWithoutIterations' : costs are numVertices * numSolverIterations. This is numVertices

F32 ClothingPhysicalMeshParameters::physicalLods[].maxDistanceReduction

'physicalLods[].maxDistanceReduction' : The amount of maxDistance that gets subtracted when this LoD is active.

F32 ClothingPhysicalMeshParameters::physicalLods[].solverIterationScale

'physicalLods[].solverIterationScale' : Take only a fraction of the Mesh's solver iterations for this LoD.

U32 ClothingPhysicalMeshParameters::physicalLods[].submeshId

'physicalLods[].submeshId' : Index of the Submesh that belongs to this LoD.

F32 ClothingPhysicalMeshParameters::physicalMesh.averageEdgeLength

'physicalMesh.averageEdgeLength' : Mesh statistic, useful for selecting the thickness of the mesh-mesh skinning.

U16 ClothingPhysicalMeshParameters::physicalMesh.boneIndices[]

'physicalMesh.boneIndices[]' : The bone indices per vertex

Note: contains numVertices * numBonesPerVertex elements.

F32 ClothingPhysicalMeshParameters::physicalMesh.boneWeights[]

'physicalMesh.boneWeights[]' : The bone weights per vertex

Note: contains numVertices * numBonesPerVertex elements.

F32 ClothingPhysicalMeshParameters::physicalMesh.constrainCoefficients[].collisionSphereDistance

'physicalMesh.constrainCoefficients[].collisionSphereDistance' : Distance of the Backstop collision sphere.

F32 ClothingPhysicalMeshParameters::physicalMesh.constrainCoefficients[].collisionSphereRadius

'physicalMesh.constrainCoefficients[].collisionSphereRadius' : Size of the Backstop collision sphere.

F32 ClothingPhysicalMeshParameters::physicalMesh.constrainCoefficients[].maxDistance

'physicalMesh.constrainCoefficients[].maxDistance' : Maximum distance this vertex is allowed to travel from its skinned position.

Bool ClothingPhysicalMeshParameters::physicalMesh.flipNormals

'physicalMesh.flipNormals' : True when the model has been transformed to left-handed space.

Bool ClothingPhysicalMeshParameters::physicalMesh.hasNegativeBackstop

'physicalMesh.hasNegativeBackstop' : True if at least 1 has negative collision distance

U32 ClothingPhysicalMeshParameters::physicalMesh.indices[]

'physicalMesh.indices[]' : The index buffer

Bool ClothingPhysicalMeshParameters::physicalMesh.isClosed

'physicalMesh.isClosed' : True if all edges have two adjacent triangles

Bool ClothingPhysicalMeshParameters::physicalMesh.isTetrahedralMesh

'physicalMesh.isTetrahedralMesh' : Are we storing triangles or tetrahedrons in this mesh.

F32 ClothingPhysicalMeshParameters::physicalMesh.maximumMaxDistance

'physicalMesh.maximumMaxDistance' : The maximum max-distance value for all the vertices.

This is used to deduct how much a physical LoD can reduce the max distance.

Vec3 ClothingPhysicalMeshParameters::physicalMesh.normals[]

'physicalMesh.normals[]' : Array of normals

These are the normals provided by the user. The mesh-mesh skinning will try to restore them as good as possible throughout simulation. Note, they can differ from the skinningNormals quite drastically.

U32 ClothingPhysicalMeshParameters::physicalMesh.numBonesPerVertex

'physicalMesh.numBonesPerVertex' : Number of bone weights/indices per vertex

U32 ClothingPhysicalMeshParameters::physicalMesh.numIndices

'physicalMesh.numIndices' : Number of indices of this mesh

U32 ClothingPhysicalMeshParameters::physicalMesh.numVertices

'physicalMesh.numVertices' : Number of vertices of this mesh

U8 ClothingPhysicalMeshParameters::physicalMesh.optimizationData[]

'physicalMesh.optimizationData[]' : Per Vertex Number of boneweights > 0, bool if it has negative collision distance

Each byte contains info for 2 vertices. bits 0-3: number of actual bones for that vertex (with boneWeight > 0) bit 4: set if that vertex has a negative backstop bits 5-7: same data for next vertex

U32 ClothingPhysicalMeshParameters::physicalMesh.physicalMeshSorting

'physicalMesh.physicalMeshSorting' : Physical mesh sorting

F32 ClothingPhysicalMeshParameters::physicalMesh.shortestEdgeLength

'physicalMesh.shortestEdgeLength' : Mesh statistic, only needed for debug rendering.

Vec3 ClothingPhysicalMeshParameters::physicalMesh.skinningNormals[]

'physicalMesh.skinningNormals[]' : Array of skinning normals

These are the normals of the original mesh. They reflect what should come out of physics but the output can be distorted because parts of the simulation mesh are turned off, resulting in wrong normal computation. They are needed for the flags.CorrectSimulationNormals actorflag.

Vec3 ClothingPhysicalMeshParameters::physicalMesh.vertices[]

'physicalMesh.vertices[]' : Array of vertices

U32 ClothingPhysicalMeshParameters::referenceCount

'referenceCount' : Only used internally, do not modify

U32 ClothingPhysicalMeshParameters::submeshes[].numIndices

'submeshes[].numIndices' : Size of the index buffer

This is only a part of the mesh where all max distances exceed a certain value.

U32 ClothingPhysicalMeshParameters::submeshes[].numMaxDistance0Vertices

'submeshes[].numMaxDistance0Vertices' : Number of vertices that have max distance set to 0 in this submesh.

U32 ClothingPhysicalMeshParameters::submeshes[].numVertices

'submeshes[].numVertices' : Size of the vertex buffers

This is only a part of the mesh where all max distances exceed a certain value.

Vec3 ClothingPhysicalMeshParameters::transitionDown[].normalBary

'transitionDown[].normalBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.

Vec3 ClothingPhysicalMeshParameters::transitionDown[].tangentBary

'transitionDown[].tangentBary' : The barycentric coordinate of (position+tangent). When position is subtracted this will result in the tangent again.

Vec3 ClothingPhysicalMeshParameters::transitionDown[].vertexBary

'transitionDown[].vertexBary' : The barycentric coordinate into the triangle.

U32 ClothingPhysicalMeshParameters::transitionDown[].vertexIndex0

'transitionDown[].vertexIndex0' : Vertex index of the physics triangle.

U32 ClothingPhysicalMeshParameters::transitionDown[].vertexIndex1

'transitionDown[].vertexIndex1' : Vertex index of the physics triangle.

U32 ClothingPhysicalMeshParameters::transitionDown[].vertexIndex2

'transitionDown[].vertexIndex2' : Vertex index of the physics triangle.

U32 ClothingPhysicalMeshParameters::transitionDown[].vertexIndexPlusOffset

'transitionDown[].vertexIndexPlusOffset' : The vertex index in the graphical mesh (the target index).

U32 ClothingPhysicalMeshParameters::transitionDownB[].faceIndex0

'transitionDownB[].faceIndex0' : First index of the 3 consecutive indices making the physical triangle.

Vec3 ClothingPhysicalMeshParameters::transitionDownB[].nrmTetraBary

'transitionDownB[].nrmTetraBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.

U32 ClothingPhysicalMeshParameters::transitionDownB[].submeshIndex

'transitionDownB[].submeshIndex' : Index into which Physical Submesh/LoD this element of the mapping belongs to.

This is only needed during the authoring stage and thus does not need to be serialized.

U32 ClothingPhysicalMeshParameters::transitionDownB[].tetraIndex

'transitionDownB[].tetraIndex' : Selects which of the 6 implicit tetrahedrons is used for the mapping.

U32 ClothingPhysicalMeshParameters::transitionDownB[].vertexIndexPlusOffset

'transitionDownB[].vertexIndexPlusOffset' : The vertex index in the graphical mesh (the target index).

Vec3 ClothingPhysicalMeshParameters::transitionDownB[].vtxTetraBary

'transitionDownB[].vtxTetraBary' : The barycentric coordinate into the implicit tetrahedron.

F32 ClothingPhysicalMeshParameters::transitionDownOffset

'transitionDownOffset' : The normal offset of the transition map

F32 ClothingPhysicalMeshParameters::transitionDownThickness

'transitionDownThickness' : The thickness of the transition map

Vec3 ClothingPhysicalMeshParameters::transitionUp[].normalBary

'transitionUp[].normalBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.

Vec3 ClothingPhysicalMeshParameters::transitionUp[].tangentBary

'transitionUp[].tangentBary' : The barycentric coordinate of (position+tangent). When position is subtracted this will result in the tangent again.

Vec3 ClothingPhysicalMeshParameters::transitionUp[].vertexBary

'transitionUp[].vertexBary' : The barycentric coordinate into the triangle.

U32 ClothingPhysicalMeshParameters::transitionUp[].vertexIndex0

'transitionUp[].vertexIndex0' : Vertex index of the physics triangle.

U32 ClothingPhysicalMeshParameters::transitionUp[].vertexIndex1

'transitionUp[].vertexIndex1' : Vertex index of the physics triangle.

U32 ClothingPhysicalMeshParameters::transitionUp[].vertexIndex2

'transitionUp[].vertexIndex2' : Vertex index of the physics triangle.

U32 ClothingPhysicalMeshParameters::transitionUp[].vertexIndexPlusOffset

'transitionUp[].vertexIndexPlusOffset' : The vertex index in the graphical mesh (the target index).

U32 ClothingPhysicalMeshParameters::transitionUpB[].faceIndex0

'transitionUpB[].faceIndex0' : First index of the 3 consecutive indices making the physical triangle.

Vec3 ClothingPhysicalMeshParameters::transitionUpB[].nrmTetraBary

'transitionUpB[].nrmTetraBary' : The barycentric coordinate of (vertex+normal). When vertex is subtracted this will result in the normal again.

U32 ClothingPhysicalMeshParameters::transitionUpB[].submeshIndex

'transitionUpB[].submeshIndex' : Index into which Physical Submesh/LoD this element of the mapping belongs to.

This is only needed during the authoring stage and thus does not need to be serialized.

U32 ClothingPhysicalMeshParameters::transitionUpB[].tetraIndex

'transitionUpB[].tetraIndex' : Selects which of the 6 implicit tetrahedrons is used for the mapping.

U32 ClothingPhysicalMeshParameters::transitionUpB[].vertexIndexPlusOffset

'transitionUpB[].vertexIndexPlusOffset' : The vertex index in the graphical mesh (the target index).

Vec3 ClothingPhysicalMeshParameters::transitionUpB[].vtxTetraBary

'transitionUpB[].vtxTetraBary' : The barycentric coordinate into the implicit tetrahedron.

F32 ClothingPhysicalMeshParameters::transitionUpOffset

'transitionUpOffset' : The normal offset of the transition map

F32 ClothingPhysicalMeshParameters::transitionUpThickness

'transitionUpThickness' : The thickness of the transition map

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ClothingPhysicalMeshParameters Member List
This is the complete list of members for ClothingPhysicalMeshParameters, including all inherited members.
physicalLods[].costWithoutIterations | ClothingPhysicalMeshParameters
physicalLods[].maxDistanceReduction | ClothingPhysicalMeshParameters
physicalLods[].solverIterationScale | ClothingPhysicalMeshParameters
physicalLods[].submeshId | ClothingPhysicalMeshParameters
physicalMesh.averageEdgeLength | ClothingPhysicalMeshParameters
physicalMesh.boneIndices[] | ClothingPhysicalMeshParameters
physicalMesh.boneWeights[] | ClothingPhysicalMeshParameters
physicalMesh.constrainCoefficients[].collisionSphereDistance | ClothingPhysicalMeshParameters
physicalMesh.constrainCoefficients[].collisionSphereRadius | ClothingPhysicalMeshParameters
physicalMesh.constrainCoefficients[].maxDistance | ClothingPhysicalMeshParameters
physicalMesh.flipNormals | ClothingPhysicalMeshParameters
physicalMesh.hasNegativeBackstop | ClothingPhysicalMeshParameters
physicalMesh.indices[] | ClothingPhysicalMeshParameters
physicalMesh.isClosed | ClothingPhysicalMeshParameters
physicalMesh.isTetrahedralMesh | ClothingPhysicalMeshParameters
physicalMesh.maximumMaxDistance | ClothingPhysicalMeshParameters
physicalMesh.normals[] | ClothingPhysicalMeshParameters
physicalMesh.numBonesPerVertex | ClothingPhysicalMeshParameters
physicalMesh.numIndices | ClothingPhysicalMeshParameters
physicalMesh.numVertices | ClothingPhysicalMeshParameters
physicalMesh.optimizationData[] | ClothingPhysicalMeshParameters
physicalMesh.physicalMeshSorting | ClothingPhysicalMeshParameters
physicalMesh.shortestEdgeLength | ClothingPhysicalMeshParameters
physicalMesh.skinningNormals[] | ClothingPhysicalMeshParameters
physicalMesh.vertices[] | ClothingPhysicalMeshParameters
referenceCount | ClothingPhysicalMeshParameters
submeshes[].numIndices | ClothingPhysicalMeshParameters
submeshes[].numMaxDistance0Vertices | ClothingPhysicalMeshParameters
submeshes[].numVertices | ClothingPhysicalMeshParameters
transitionDown[].normalBary | ClothingPhysicalMeshParameters
transitionDown[].tangentBary | ClothingPhysicalMeshParameters
transitionDown[].vertexBary | ClothingPhysicalMeshParameters
transitionDown[].vertexIndex0 | ClothingPhysicalMeshParameters
transitionDown[].vertexIndex1 | ClothingPhysicalMeshParameters
transitionDown[].vertexIndex2 | ClothingPhysicalMeshParameters
transitionDown[].vertexIndexPlusOffset | ClothingPhysicalMeshParameters
transitionDownB[].faceIndex0 | ClothingPhysicalMeshParameters
transitionDownB[].nrmTetraBary | ClothingPhysicalMeshParameters
transitionDownB[].submeshIndex | ClothingPhysicalMeshParameters
transitionDownB[].tetraIndex | ClothingPhysicalMeshParameters
transitionDownB[].vertexIndexPlusOffset | ClothingPhysicalMeshParameters
transitionDownB[].vtxTetraBary | ClothingPhysicalMeshParameters
transitionDownOffset | ClothingPhysicalMeshParameters
transitionDownThickness | ClothingPhysicalMeshParameters
transitionUp[].normalBary | ClothingPhysicalMeshParameters
transitionUp[].tangentBary | ClothingPhysicalMeshParameters
transitionUp[].vertexBary | ClothingPhysicalMeshParameters
transitionUp[].vertexIndex0 | ClothingPhysicalMeshParameters
transitionUp[].vertexIndex1 | ClothingPhysicalMeshParameters
transitionUp[].vertexIndex2 | ClothingPhysicalMeshParameters
transitionUp[].vertexIndexPlusOffset | ClothingPhysicalMeshParameters
transitionUpB[].faceIndex0 | ClothingPhysicalMeshParameters
transitionUpB[].nrmTetraBary | ClothingPhysicalMeshParameters
transitionUpB[].submeshIndex | ClothingPhysicalMeshParameters
transitionUpB[].tetraIndex | ClothingPhysicalMeshParameters
transitionUpB[].vertexIndexPlusOffset | ClothingPhysicalMeshParameters
transitionUpB[].vtxTetraBary | ClothingPhysicalMeshParameters
transitionUpOffset | ClothingPhysicalMeshParameters
transitionUpThickness | ClothingPhysicalMeshParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ClothingPreviewParam Struct Reference

  • Class List
  • Class Members
Public Attributes
ClothingPreviewParam Struct Reference

Describes the NxParameterized::Interface for 'ClothingPreviewParam' : More...

#include <params.h>

List of all members.

Public Attributes

Mat44 | globalPose
'globalPose' : The pose where the clothing asset will be put into the scene
Bool | fallbackSkinning
'fallbackSkinning' : Performs skinning in software
Bool | useInternalBoneOrder
'useInternalBoneOrder' : Expect internally ordered bone arrays in updateState call.
Bool | updateStateWithGlobalMatrices
'updateStateWithGlobalMatrices' : Use world space matrices instead of composite (relative to bind pose) in NxClothingActor::updateState().
U64 | userData
'userData' : Optional user data pointer associated with the clothing actor
Mat44 | boneMatrices[]
'boneMatrices[]' : An Array of matrices with the full transform for each bone

Detailed Description

Describes the NxParameterized::Interface for 'ClothingPreviewParam' :

ClothingPreviewParam contains 7 fully qualified names
---------------------------------------------
  1 : Mat44          globalPose
  2 : Bool           fallbackSkinning
  3 : Bool           useInternalBoneOrder
  4 : Bool           updateStateWithGlobalMatrices
  5 : U64            userData
  6 : ArraySizeName  boneMatrices
  7 : Mat44          boneMatrices[]

Member Data Documentation

Mat44 ClothingPreviewParam::boneMatrices[]

'boneMatrices[]' : An Array of matrices with the full transform for each bone

These matrices are sometimes referred to as composite matrices. They are the multiplication of the current world space bone pose with the inverse bind pose in world space. Note: If 'updateStateWithGlobalMatrices' is set to true, these must be global poses instead.

Bool ClothingPreviewParam::fallbackSkinning

'fallbackSkinning' : Performs skinning in software

Performs the regular boneweighted skinning on the CPU before giving the data out through the rendering API.

Mat44 ClothingPreviewParam::globalPose

'globalPose' : The pose where the clothing asset will be put into the scene

Bool ClothingPreviewParam::updateStateWithGlobalMatrices

'updateStateWithGlobalMatrices' : Use world space matrices instead of composite (relative to bind pose) in NxClothingActor::updateState().

Depending on what matrices are present, the state can be updated using global world or object space bone matrices or composite matrices. The composite matrix can be generated by multiplying the world or object space matrix by the inverse bone bine pose. Note: If there are problems which might be caused by bind poses being different in the ClothingAsset and in the game's animation system, changing this to true (and thus providing global pose matrices) might fix the problem.

Bool ClothingPreviewParam::useInternalBoneOrder

'useInternalBoneOrder' : Expect internally ordered bone arrays in updateState call.

If this is set to true the bone buffers in updateState and the actor descriptor have to be given in the same order as the bones are stored internally in the asset. This can be queried using NxClothingAsset::getNumUsedBones and NxClothingAsset::getBoneName or NxClothingAsset::getBoneMapping. If this is set to false, the bone buffers can be provided in the order as they are stored in the application. This is either the bone order at authoring time, or NxClothingAsset::remapBoneIndex can be called for each bone to let APEX know about the current ordering in the game. Note that this is only recommended if the application already uses physx::PxMat44 (or something binary equivalent) and does not have to convert the matrices.

U64 ClothingPreviewParam::userData

'userData' : Optional user data pointer associated with the clothing actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ClothingPreviewParam Member List
This is the complete list of members for ClothingPreviewParam, including all inherited members.
boneMatrices[] | ClothingPreviewParam
fallbackSkinning | ClothingPreviewParam
globalPose | ClothingPreviewParam
updateStateWithGlobalMatrices | ClothingPreviewParam
useInternalBoneOrder | ClothingPreviewParam
userData | ClothingPreviewParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ColorVsDensityCompositeModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ColorVsDensityCompositeModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ColorVsDensityCompositeModifierParams' : ColorVsDensityComposite modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | controlPoints[].density
'controlPoints[].density' : Density
Vec4 | controlPoints[].color
'controlPoints[].color' : Color is formatted x=R, y=G, z=B, w=A

Detailed Description

Describes the NxParameterized::Interface for 'ColorVsDensityCompositeModifierParams' : ColorVsDensityComposite modifier parameters.

ColorVsDensityCompositeModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  controlPoints
  2 : F32            controlPoints[].density
  3 : Vec4           controlPoints[].color

Member Data Documentation

Vec4 ColorVsDensityCompositeModifierParams::controlPoints[].color

'controlPoints[].color' : Color is formatted x=R, y=G, z=B, w=A

F32 ColorVsDensityCompositeModifierParams::controlPoints[].density

'controlPoints[].density' : Density

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ColorVsDensityCompositeModifierParams Member List
This is the complete list of members for ColorVsDensityCompositeModifierParams, including all inherited members.
controlPoints[].color | ColorVsDensityCompositeModifierParams
controlPoints[].density | ColorVsDensityCompositeModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ColorVsDensityModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ColorVsDensityModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ColorVsDensityModifierParams' : ColorVsDensity modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

ColorChannel colorChannel
'colorChannel' : Color channel
F32 | controlPoints[].x
'controlPoints[].x' : Density
F32 | controlPoints[].y
'controlPoints[].y' : Color

Detailed Description

Describes the NxParameterized::Interface for 'ColorVsDensityModifierParams' : ColorVsDensity modifier parameters.

ColorVsDensityModifierParams contains 4 fully qualified names
---------------------------------------------
  1 : ColorChannel   colorChannel
  2 : ArraySizeName  controlPoints
  3 : F32            controlPoints[].x
  4 : F32            controlPoints[].y

Member Data Documentation

ColorChannel ColorVsDensityModifierParams::colorChannel

'colorChannel' : Color channel

F32 ColorVsDensityModifierParams::controlPoints[].x

'controlPoints[].x' : Density

F32 ColorVsDensityModifierParams::controlPoints[].y

'controlPoints[].y' : Color

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ColorVsDensityModifierParams Member List
This is the complete list of members for ColorVsDensityModifierParams, including all inherited members.
colorChannel | ColorVsDensityModifierParams
controlPoints[].x | ColorVsDensityModifierParams
controlPoints[].y | ColorVsDensityModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ColorVsLifeCompositeModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ColorVsLifeCompositeModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ColorVsLifeCompositeModifierParams' : ColorVsLifeComposite modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | controlPoints[].lifeRemaining
'controlPoints[].lifeRemaining' : Life remaining
Vec4 | controlPoints[].color
'controlPoints[].color' : Color is formatted x=R, y=G, z=B, w=A

Detailed Description

Describes the NxParameterized::Interface for 'ColorVsLifeCompositeModifierParams' : ColorVsLifeComposite modifier parameters.

ColorVsLifeCompositeModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  controlPoints
  2 : F32            controlPoints[].lifeRemaining
  3 : Vec4           controlPoints[].color

Member Data Documentation

Vec4 ColorVsLifeCompositeModifierParams::controlPoints[].color

'controlPoints[].color' : Color is formatted x=R, y=G, z=B, w=A

F32 ColorVsLifeCompositeModifierParams::controlPoints[].lifeRemaining

'controlPoints[].lifeRemaining' : Life remaining

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ColorVsLifeCompositeModifierParams Member List
This is the complete list of members for ColorVsLifeCompositeModifierParams, including all inherited members.
controlPoints[].color | ColorVsLifeCompositeModifierParams
controlPoints[].lifeRemaining | ColorVsLifeCompositeModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ColorVsLifeModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ColorVsLifeModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ColorVsLifeModifierParams' : ColorVsLife modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

ColorChannel colorChannel
'colorChannel' : Color channel
F32 | controlPoints[].x
'controlPoints[].x' : Life
F32 | controlPoints[].y
'controlPoints[].y' : Color

Detailed Description

Describes the NxParameterized::Interface for 'ColorVsLifeModifierParams' : ColorVsLife modifier parameters.

ColorVsLifeModifierParams contains 4 fully qualified names
---------------------------------------------
  1 : ColorChannel   colorChannel
  2 : ArraySizeName  controlPoints
  3 : F32            controlPoints[].x
  4 : F32            controlPoints[].y

Member Data Documentation

ColorChannel ColorVsLifeModifierParams::colorChannel

'colorChannel' : Color channel

F32 ColorVsLifeModifierParams::controlPoints[].x

'controlPoints[].x' : Life

F32 ColorVsLifeModifierParams::controlPoints[].y

'controlPoints[].y' : Color

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ColorVsLifeModifierParams Member List
This is the complete list of members for ColorVsLifeModifierParams, including all inherited members.
colorChannel | ColorVsLifeModifierParams
controlPoints[].x | ColorVsLifeModifierParams
controlPoints[].y | ColorVsLifeModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ColorVsTemperatureCompositeModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ColorVsTemperatureCompositeModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ColorVsTemperatureCompositeModifierParams' : ColorVsTemperatureComposite modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | controlPoints[].temperature
'controlPoints[].temperature' : Temperature
Vec4 | controlPoints[].color
'controlPoints[].color' : Color is formatted x=R, y=G, z=B, w=A

Detailed Description

Describes the NxParameterized::Interface for 'ColorVsTemperatureCompositeModifierParams' : ColorVsTemperatureComposite modifier parameters.

ColorVsTemperatureCompositeModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  controlPoints
  2 : F32            controlPoints[].temperature
  3 : Vec4           controlPoints[].color

Member Data Documentation

Vec4 ColorVsTemperatureCompositeModifierParams::controlPoints[].color

'controlPoints[].color' : Color is formatted x=R, y=G, z=B, w=A

F32 ColorVsTemperatureCompositeModifierParams::controlPoints[].temperature

'controlPoints[].temperature' : Temperature

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ColorVsTemperatureCompositeModifierParams Member List
This is the complete list of members for ColorVsTemperatureCompositeModifierParams, including all inherited members.
controlPoints[].color | ColorVsTemperatureCompositeModifierParams
controlPoints[].temperature | ColorVsTemperatureCompositeModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ColorVsTemperatureModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ColorVsTemperatureModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ColorVsTemperatureModifierParams' : ColorVsTemperature modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

ColorChannel colorChannel
'colorChannel' : Color channel
F32 | controlPoints[].x
'controlPoints[].x' : Temperature
F32 | controlPoints[].y
'controlPoints[].y' : Color

Detailed Description

Describes the NxParameterized::Interface for 'ColorVsTemperatureModifierParams' : ColorVsTemperature modifier parameters.

ColorVsTemperatureModifierParams contains 4 fully qualified names
---------------------------------------------
  1 : ColorChannel   colorChannel
  2 : ArraySizeName  controlPoints
  3 : F32            controlPoints[].x
  4 : F32            controlPoints[].y

Member Data Documentation

ColorChannel ColorVsTemperatureModifierParams::colorChannel

'colorChannel' : Color channel

F32 ColorVsTemperatureModifierParams::controlPoints[].x

'controlPoints[].x' : Temperature

F32 ColorVsTemperatureModifierParams::controlPoints[].y

'controlPoints[].y' : Color

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ColorVsTemperatureModifierParams Member List
This is the complete list of members for ColorVsTemperatureModifierParams, including all inherited members.
colorChannel | ColorVsTemperatureModifierParams
controlPoints[].x | ColorVsTemperatureModifierParams
controlPoints[].y | ColorVsTemperatureModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ColorVsVelocityCompositeModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ColorVsVelocityCompositeModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ColorVsVelocityCompositeModifierParams' : ColorVsVelocityComposite modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | velocity0
'velocity0' : First velocity point
F32 | velocity1
'velocity1' : Second velocity point
F32 | controlPoints[].velocity
'controlPoints[].velocity' : Velocity
Vec4 | controlPoints[].color
'controlPoints[].color' : Color is formatted x=R, y=G, z=B, w=A

Detailed Description

Describes the NxParameterized::Interface for 'ColorVsVelocityCompositeModifierParams' : ColorVsVelocityComposite modifier parameters.

ColorVsVelocityCompositeModifierParams contains 5 fully qualified names
---------------------------------------------
  1 : F32            velocity0
  2 : F32            velocity1
  3 : ArraySizeName  controlPoints
  4 : F32            controlPoints[].velocity
  5 : Vec4           controlPoints[].color

Member Data Documentation

Vec4 ColorVsVelocityCompositeModifierParams::controlPoints[].color

'controlPoints[].color' : Color is formatted x=R, y=G, z=B, w=A

F32 ColorVsVelocityCompositeModifierParams::controlPoints[].velocity

'controlPoints[].velocity' : Velocity

F32 ColorVsVelocityCompositeModifierParams::velocity0

'velocity0' : First velocity point

F32 ColorVsVelocityCompositeModifierParams::velocity1

'velocity1' : Second velocity point

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ColorVsVelocityCompositeModifierParams Member List
This is the complete list of members for ColorVsVelocityCompositeModifierParams, including all inherited members.
controlPoints[].color | ColorVsVelocityCompositeModifierParams
controlPoints[].velocity | ColorVsVelocityCompositeModifierParams
velocity0 | ColorVsVelocityCompositeModifierParams
velocity1 | ColorVsVelocityCompositeModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ColorVsVelocityModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ColorVsVelocityModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ColorVsVelocityModifierParams' : ColorVsVelocity modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

ColorChannel colorChannel
'colorChannel' : Color channel
F32 | velocity0
'velocity0' : Helpful documentation goes here
F32 | velocity1
'velocity1' : Helpful documentation goes here
F32 | controlPoints[].x
'controlPoints[].x' : Velocity
F32 | controlPoints[].y
'controlPoints[].y' : Color

Detailed Description

Describes the NxParameterized::Interface for 'ColorVsVelocityModifierParams' : ColorVsVelocity modifier parameters.

ColorVsVelocityModifierParams contains 6 fully qualified names
---------------------------------------------
  1 : ColorChannel   colorChannel
  2 : F32            velocity0
  3 : F32            velocity1
  4 : ArraySizeName  controlPoints
  5 : F32            controlPoints[].x
  6 : F32            controlPoints[].y

Member Data Documentation

ColorChannel ColorVsVelocityModifierParams::colorChannel

'colorChannel' : Color channel

F32 ColorVsVelocityModifierParams::controlPoints[].x

'controlPoints[].x' : Velocity

F32 ColorVsVelocityModifierParams::controlPoints[].y

'controlPoints[].y' : Color

F32 ColorVsVelocityModifierParams::velocity0

'velocity0' : Helpful documentation goes here

F32 ColorVsVelocityModifierParams::velocity1

'velocity1' : Helpful documentation goes here

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ColorVsVelocityModifierParams Member List
This is the complete list of members for ColorVsVelocityModifierParams, including all inherited members.
colorChannel | ColorVsVelocityModifierParams
controlPoints[].x | ColorVsVelocityModifierParams
controlPoints[].y | ColorVsVelocityModifierParams
velocity0 | ColorVsVelocityModifierParams
velocity1 | ColorVsVelocityModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ConvexHullParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
ConvexHullParameters Struct Reference

Describes the NxParameterized::Interface for 'ConvexHullParameters' : More...

#include <params.h>

List of all members.

Public Attributes

Vec3 | vertices[]
'vertices[]' : Convex hull vertices
Vec3 | uniquePlanes[].normal
'uniquePlanes[].normal' : A plane normal
F32 | uniquePlanes[].d
'uniquePlanes[].d' : A plane displacement
F32 | widths[]
'widths[]' : For each unique plane (see uniquePlanes), this is the width of the convex polytope
U32 | edges[]
'edges[]' : All edges of the convex polytope, stored in a compressed index format
U32 | adjacentFaces[]
'adjacentFaces[]' : Face (plane) indices which are adjacent to each edge in the edges array.
Bounds3 | bounds
'bounds' : The AABB of the convex hull
F32 | volume
'volume' : The volume of the convex hull
U32 | uniqueEdgeDirectionCount
'uniqueEdgeDirectionCount' : The number of unique edge directions
U32 | planeCount
'planeCount' : The total number of faces

Detailed Description

Describes the NxParameterized::Interface for 'ConvexHullParameters' :

ConvexHullParameters contains 15 fully qualified names
---------------------------------------------
  1 : ArraySizeName  vertices
  2 : Vec3           vertices[]
  3 : ArraySizeName  uniquePlanes
  4 : Vec3           uniquePlanes[].normal
  5 : F32            uniquePlanes[].d
  6 : ArraySizeName  widths
  7 : F32            widths[]
  8 : ArraySizeName  edges
  9 : U32            edges[]
 10 : ArraySizeName  adjacentFaces
 11 : U32            adjacentFaces[]
 12 : Bounds3        bounds
 13 : F32            volume
 14 : U32            uniqueEdgeDirectionCount
 15 : U32            planeCount

Member Data Documentation

U32 ConvexHullParameters::adjacentFaces[]

'adjacentFaces[]' : Face (plane) indices which are adjacent to each edge in the edges array.

Face (plane) indices which are adjacent to each edge in the edges array. Each 32-bit integer stores the indices of two faces, in the high and low words. The indices refer to the face planes, and will be in the range [0, planeCount). To interpret the indices correctly, see the description of planeCount. If a "dangling edge" is generated, the face index stored in the high word will be 0xFFFF. (Invalid value.)

Bounds3 ConvexHullParameters::bounds

'bounds' : The AABB of the convex hull

The AABB of the convex hull.

U32 ConvexHullParameters::edges[]

'edges[]' : All edges of the convex polytope, stored in a compressed index format

All edges of the convex polytope, stored in a compressed index format. Each 32-bit integer stores the indices of two endpoints, in the high and low words. The indices refer to the vertices array. The edges are stored such that all unique edge directions are represented by the first uniqueEdgeDirectionCount entries.

U32 ConvexHullParameters::planeCount

'planeCount' : The total number of faces

The total number of faces. This includes parallel opposite faces, so may be larger than the array size of uniquePlanes. For plane indices i less than uniquePlanes.size(), simply use uniquePlanes[i] to find the corresponding plane. For plane indicies i in the range [uniquePlanes.size(), planeCount), the uniquePlanes array is arranged such that you obtain the correct plane by starting with the plane p = uniquePlanes[index-uniquePlanes.size()]. Then, add widths[index-uniquePlanes.size()] to the plane displacement p.d, and finally negate both the plane normal p.n and the displacement p.d.

U32 ConvexHullParameters::uniqueEdgeDirectionCount

'uniqueEdgeDirectionCount' : The number of unique edge directions

The number of unique edge directions. The first uniqueEdgeDirectionCount elements of the edges array represent these directions.

F32 ConvexHullParameters::uniquePlanes[].d

'uniquePlanes[].d' : A plane displacement

A plane displacement, defined by the negative of the plane normal dotted with a point in the plane. This plane is used to define convex volumes.

Vec3 ConvexHullParameters::uniquePlanes[].normal

'uniquePlanes[].normal' : A plane normal

A plane normal. This plane is used to define convex volumes.

Vec3 ConvexHullParameters::vertices[]

'vertices[]' : Convex hull vertices

The vertices of a convex polytope.

F32 ConvexHullParameters::volume

'volume' : The volume of the convex hull

The volume of the convex hull.

F32 ConvexHullParameters::widths[]

'widths[]' : For each unique plane (see uniquePlanes), this is the width of the convex polytope

For each unique plane (see uniquePlanes), this is the width of the convex polytope. That is, if an opposing face exists, it is the distance between the faces. If no opposing face exists, it is the maximum distance below the unique plane over all vertices.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ConvexHullParameters Member List
This is the complete list of members for ConvexHullParameters, including all inherited members.
adjacentFaces[] | ConvexHullParameters
bounds | ConvexHullParameters
edges[] | ConvexHullParameters
planeCount | ConvexHullParameters
uniqueEdgeDirectionCount | ConvexHullParameters
uniquePlanes[].d | ConvexHullParameters
uniquePlanes[].normal | ConvexHullParameters
vertices[] | ConvexHullParameters
volume | ConvexHullParameters
widths[] | ConvexHullParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: DebugColorParams Struct Reference

  • Class List
  • Class Members
Public Attributes
DebugColorParams Struct Reference

Describes the NxParameterized::Interface for 'DebugColorParams' : More...

#include <params.h>

List of all members.

Public Attributes

U32 | Default
'Default' : Default color value
U32 | PoseArrows
'PoseArrows' : Pose arrows color value
U32 | MeshStatic
'MeshStatic' : Static mesh color value
U32 | MeshDynamic
'MeshDynamic' : Dynamic mesh color value
U32 | Shape
'Shape' : Shape color value
U32 | Text0
'Text0' : Text0 color value
U32 | Text1
'Text1' : Text1 color value
U32 | ForceArrowsLow
'ForceArrowsLow' : Force arrows color value (low value)
U32 | ForceArrowsNorm
'ForceArrowsNorm' : Force arrows color value (normal value)
U32 | ForceArrowsHigh
'ForceArrowsHigh' : Force arrows color value (high value)
U32 | Color0
'Color0' : Color0 value
U32 | Color1
'Color1' : Color1 value
U32 | Color2
'Color2' : Color2 value
U32 | Color3
'Color3' : Color3 value
U32 | Color4
'Color4' : Color4 value
U32 | Color5
'Color5' : Color5 value
U32 | Red
'Red' : Red color value
U32 | Green
'Green' : Green color value
U32 | Blue
'Blue' : Blue color value
U32 | DarkRed
'DarkRed' : Dark red value
U32 | DarkGreen
'DarkGreen' : Dark green value
U32 | DarkBlue
'DarkBlue' : Dark blue value
U32 | LightRed
'LightRed' : Light red value
U32 | LightGreen
'LightGreen' : Light green value
U32 | LightBlue
'LightBlue' : Light blue value
U32 | Purple
'Purple' : Purple value
U32 | DarkPurple
'DarkPurple' : Dark purple value
U32 | Yellow
'Yellow' : Yellow value
U32 | Orange
'Orange' : Orange value
U32 | Gold
'Gold' : Gold value
U32 | Emerald
'Emerald' : Emerald value
U32 | White
'White' : White value
U32 | Black
'Black' : Black value
U32 | Gray
'Gray' : Gray value
U32 | LightGray
'LightGray' : Light gray value
U32 | DarkGray
'DarkGray' : Dark gray value

Detailed Description

Describes the NxParameterized::Interface for 'DebugColorParams' :

DebugColorParams contains 36 fully qualified names
---------------------------------------------
  1 : U32  Default
  2 : U32  PoseArrows
  3 : U32  MeshStatic
  4 : U32  MeshDynamic
  5 : U32  Shape
  6 : U32  Text0
  7 : U32  Text1
  8 : U32  ForceArrowsLow
  9 : U32  ForceArrowsNorm
 10 : U32  ForceArrowsHigh
 11 : U32  Color0
 12 : U32  Color1
 13 : U32  Color2
 14 : U32  Color3
 15 : U32  Color4
 16 : U32  Color5
 17 : U32  Red
 18 : U32  Green
 19 : U32  Blue
 20 : U32  DarkRed
 21 : U32  DarkGreen
 22 : U32  DarkBlue
 23 : U32  LightRed
 24 : U32  LightGreen
 25 : U32  LightBlue
 26 : U32  Purple
 27 : U32  DarkPurple
 28 : U32  Yellow
 29 : U32  Orange
 30 : U32  Gold
 31 : U32  Emerald
 32 : U32  White
 33 : U32  Black
 34 : U32  Gray
 35 : U32  LightGray
 36 : U32  DarkGray

Member Data Documentation

U32 DebugColorParams::Black

'Black' : Black value

U32 DebugColorParams::Blue

'Blue' : Blue color value

U32 DebugColorParams::Color0

'Color0' : Color0 value

U32 DebugColorParams::Color1

'Color1' : Color1 value

U32 DebugColorParams::Color2

'Color2' : Color2 value

U32 DebugColorParams::Color3

'Color3' : Color3 value

U32 DebugColorParams::Color4

'Color4' : Color4 value

U32 DebugColorParams::Color5

'Color5' : Color5 value

U32 DebugColorParams::DarkBlue

'DarkBlue' : Dark blue value

U32 DebugColorParams::DarkGray

'DarkGray' : Dark gray value

U32 DebugColorParams::DarkGreen

'DarkGreen' : Dark green value

U32 DebugColorParams::DarkPurple

'DarkPurple' : Dark purple value

U32 DebugColorParams::DarkRed

'DarkRed' : Dark red value

U32 DebugColorParams::Default

'Default' : Default color value

U32 DebugColorParams::Emerald

'Emerald' : Emerald value

U32 DebugColorParams::ForceArrowsHigh

'ForceArrowsHigh' : Force arrows color value (high value)

U32 DebugColorParams::ForceArrowsLow

'ForceArrowsLow' : Force arrows color value (low value)

U32 DebugColorParams::ForceArrowsNorm

'ForceArrowsNorm' : Force arrows color value (normal value)

U32 DebugColorParams::Gold

'Gold' : Gold value

U32 DebugColorParams::Gray

'Gray' : Gray value

U32 DebugColorParams::Green

'Green' : Green color value

U32 DebugColorParams::LightBlue

'LightBlue' : Light blue value

U32 DebugColorParams::LightGray

'LightGray' : Light gray value

U32 DebugColorParams::LightGreen

'LightGreen' : Light green value

U32 DebugColorParams::LightRed

'LightRed' : Light red value

U32 DebugColorParams::MeshDynamic

'MeshDynamic' : Dynamic mesh color value

U32 DebugColorParams::MeshStatic

'MeshStatic' : Static mesh color value

U32 DebugColorParams::Orange

'Orange' : Orange value

U32 DebugColorParams::PoseArrows

'PoseArrows' : Pose arrows color value

U32 DebugColorParams::Purple

'Purple' : Purple value

U32 DebugColorParams::Red

'Red' : Red color value

U32 DebugColorParams::Shape

'Shape' : Shape color value

U32 DebugColorParams::Text0

'Text0' : Text0 color value

U32 DebugColorParams::Text1

'Text1' : Text1 color value

U32 DebugColorParams::White

'White' : White value

U32 DebugColorParams::Yellow

'Yellow' : Yellow value

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
DebugColorParams Member List
This is the complete list of members for DebugColorParams, including all inherited members.
Black | DebugColorParams
Blue | DebugColorParams
Color0 | DebugColorParams
Color1 | DebugColorParams
Color2 | DebugColorParams
Color3 | DebugColorParams
Color4 | DebugColorParams
Color5 | DebugColorParams
DarkBlue | DebugColorParams
DarkGray | DebugColorParams
DarkGreen | DebugColorParams
DarkPurple | DebugColorParams
DarkRed | DebugColorParams
Default | DebugColorParams
Emerald | DebugColorParams
ForceArrowsHigh | DebugColorParams
ForceArrowsLow | DebugColorParams
ForceArrowsNorm | DebugColorParams
Gold | DebugColorParams
Gray | DebugColorParams
Green | DebugColorParams
LightBlue | DebugColorParams
LightGray | DebugColorParams
LightGreen | DebugColorParams
LightRed | DebugColorParams
MeshDynamic | DebugColorParams
MeshStatic | DebugColorParams
Orange | DebugColorParams
PoseArrows | DebugColorParams
Purple | DebugColorParams
Red | DebugColorParams
Shape | DebugColorParams
Text0 | DebugColorParams
Text1 | DebugColorParams
White | DebugColorParams
Yellow | DebugColorParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: DebugRenderParams Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
DebugRenderParams Struct Reference

Describes the NxParameterized::Interface for 'DebugRenderParams' : More...

#include <params.h>

List of all members.

Classes

union | ModuleName

Public Attributes

Bool | Enable
'Enable' : Enable/disable debug rendering
F32 | Scale
'Scale' : Debug rendering scale
F32 | LodBenefits
'LodBenefits' : LOD benefit debug visualization
F32 | RelativeLodBenefitsScreenPos
'RelativeLodBenefitsScreenPos' : The y-axis value of the relative benefits bar (-1.0 - 1.0)
F32 | RelativeLodBenefitsThickness
'RelativeLodBenefitsThickness' : The thickness scale of the relative benefits bar
F32 | LodDistanceScale
'LodDistanceScale' : LOD distance debug visualization
F32 | RenderNormals
'RenderNormals' : Draws the normals (blue) of the rendered mesh. (scalable)
F32 | RenderTangents
'RenderTangents' : Draws the tangents (red) of the rendered mesh. (scalable)
F32 | RenderBitangents
'RenderBitangents' : Draws the bitangents (green) of the rendered mesh. (scalable)
Bool | Bounds
'Bounds' : Draws the bounds of every apex actor
ModuleName moduleName[]

Detailed Description

Describes the NxParameterized::Interface for 'DebugRenderParams' :

DebugRenderParams contains 136 fully qualified names
---------------------------------------------
  1 : Bool           Enable
  2 : F32            Scale
  3 : F32            LodBenefits
  4 : F32            RelativeLodBenefitsScreenPos
  5 : F32            RelativeLodBenefitsThickness
  6 : F32            LodDistanceScale
  7 : F32            RenderNormals
  8 : F32            RenderTangents
  9 : F32            RenderBitangents
 10 : Bool           Bounds
 11 : ArraySizeName  moduleName
 12 : Bool           moduleName[].VISUALIZE_JET_FS_ACTOR                                                RefVariant[BasicFSDebugRenderParams]
 13 : Bool           moduleName[].VISUALIZE_JET_FS_ACTOR_NAME                                           RefVariant[BasicFSDebugRenderParams]
 14 : Bool           moduleName[].VISUALIZE_JET_FS_SHAPE                                                RefVariant[BasicFSDebugRenderParams]
 15 : Bool           moduleName[].VISUALIZE_JET_FS_FIELD                                                RefVariant[BasicFSDebugRenderParams]
 16 : Bool           moduleName[].VISUALIZE_JET_FS_POSE                                                 RefVariant[BasicFSDebugRenderParams]
 17 : F32            moduleName[].JET_FS_FIELD_SCALE                                                    RefVariant[BasicFSDebugRenderParams]
 18 : Bool           moduleName[].VISUALIZE_ATTRACTOR_FS_ACTOR                                          RefVariant[BasicFSDebugRenderParams]
 19 : Bool           moduleName[].VISUALIZE_ATTRACTOR_FS_ACTOR_NAME                                     RefVariant[BasicFSDebugRenderParams]
 20 : Bool           moduleName[].VISUALIZE_ATTRACTOR_FS_SHAPE                                          RefVariant[BasicFSDebugRenderParams]
 21 : Bool           moduleName[].VISUALIZE_ATTRACTOR_FS_FIELD                                          RefVariant[BasicFSDebugRenderParams]
 22 : Bool           moduleName[].VISUALIZE_ATTRACTOR_FS_POSE                                           RefVariant[BasicFSDebugRenderParams]
 23 : Bool           moduleName[].VISUALIZE_VORTEX_FS_ACTOR                                             RefVariant[BasicFSDebugRenderParams]
 24 : Bool           moduleName[].VISUALIZE_VORTEX_FS_ACTOR_NAME                                        RefVariant[BasicFSDebugRenderParams]
 25 : Bool           moduleName[].VISUALIZE_VORTEX_FS_SHAPE                                             RefVariant[BasicFSDebugRenderParams]
 26 : Bool           moduleName[].VISUALIZE_VORTEX_FS_FIELD                                             RefVariant[BasicFSDebugRenderParams]
 27 : Bool           moduleName[].VISUALIZE_VORTEX_FS_POSE                                              RefVariant[BasicFSDebugRenderParams]
 28 : Bool           moduleName[].VISUALIZE_NOISE_FS_ACTOR                                              RefVariant[BasicFSDebugRenderParams]
 29 : Bool           moduleName[].VISUALIZE_NOISE_FS_ACTOR_NAME                                         RefVariant[BasicFSDebugRenderParams]
 30 : Bool           moduleName[].VISUALIZE_NOISE_FS_SHAPE                                              RefVariant[BasicFSDebugRenderParams]
 31 : Bool           moduleName[].VISUALIZE_NOISE_FS_POSE                                               RefVariant[BasicFSDebugRenderParams]
 32 : Bool           moduleName[].VISUALIZE_WIND_FS_ACTOR                                               RefVariant[BasicFSDebugRenderParams]
 33 : Bool           moduleName[].VISUALIZE_WIND_FS_ACTOR_NAME                                          RefVariant[BasicFSDebugRenderParams]
 34 : Bool           moduleName[].VISUALIZE_BASIC_IOS_ACTOR                                             RefVariant[BasicIosDebugRenderParams]
 35 : Bool           moduleName[].VISUALIZE_BASIC_IOS_COLLIDE_SHAPES                                    RefVariant[BasicIosDebugRenderParams]
 36 : Bool           moduleName[].VISUALIZE_BASIC_IOS_GRID_DENSITY                                      RefVariant[BasicIosDebugRenderParams]
 37 : Bool           moduleName[].VISUALIZE_PARTICLE_IOS_ACTOR                                          RefVariant[ParticleIosDebugRenderParams]
 38 : Bool           moduleName[].VISUALIZE_PARTICLE_IOS_GRID_DENSITY                                   RefVariant[ParticleIosDebugRenderParams]
 39 : Bool           moduleName[].Actors                                                                RefVariant[ClothingDebugRenderParams]
 40 : F32            moduleName[].SkinnedPositions                                                      RefVariant[ClothingDebugRenderParams]
 41 : Bool           moduleName[].Backstop                                                              RefVariant[ClothingDebugRenderParams]
 42 : F32            moduleName[].BackstopPrecise                                                       RefVariant[ClothingDebugRenderParams]
 43 : Bool           moduleName[].MaxDistance                                                           RefVariant[ClothingDebugRenderParams]
 44 : Bool           moduleName[].MaxDistanceInwards                                                    RefVariant[ClothingDebugRenderParams]
 45 : Bool           moduleName[].SkinMapAll                                                            RefVariant[ClothingDebugRenderParams]
 46 : Bool           moduleName[].SkinMapBad                                                            RefVariant[ClothingDebugRenderParams]
 47 : Bool           moduleName[].SkinMapActual                                                         RefVariant[ClothingDebugRenderParams]
 48 : Bool           moduleName[].SkinMapInvalidBary                                                    RefVariant[ClothingDebugRenderParams]
 49 : F32            moduleName[].PhysicsMeshWire                                                       RefVariant[ClothingDebugRenderParams]
 50 : F32            moduleName[].PhysicsMeshSolid                                                      RefVariant[ClothingDebugRenderParams]
 51 : F32            moduleName[].PhysicsMeshNormals                                                    RefVariant[ClothingDebugRenderParams]
 52 : Bool           moduleName[].Skeleton                                                              RefVariant[ClothingDebugRenderParams]
 53 : F32            moduleName[].BoneFrames                                                            RefVariant[ClothingDebugRenderParams]
 54 : F32            moduleName[].BoneNames                                                             RefVariant[ClothingDebugRenderParams]
 55 : F32            moduleName[].Velocities                                                            RefVariant[ClothingDebugRenderParams]
 56 : F32            moduleName[].Wind                                                                  RefVariant[ClothingDebugRenderParams]
 57 : Bool           moduleName[].GraphicalVertexBones                                                  RefVariant[ClothingDebugRenderParams]
 58 : Bool           moduleName[].PhysicalVertexBones                                                   RefVariant[ClothingDebugRenderParams]
 59 : Bool           moduleName[].CollisionShapes                                                       RefVariant[ClothingDebugRenderParams]
 60 : Bool           moduleName[].CollisionShapesWire                                                   RefVariant[ClothingDebugRenderParams]
 61 : Bool           moduleName[].LengthFibers                                                          RefVariant[ClothingDebugRenderParams]
 62 : Bool           moduleName[].CrossSectionFibers                                                    RefVariant[ClothingDebugRenderParams]
 63 : Bool           moduleName[].BendingFibers                                                         RefVariant[ClothingDebugRenderParams]
 64 : Bool           moduleName[].ShearingFibers                                                        RefVariant[ClothingDebugRenderParams]
 65 : Bool           moduleName[].ZerostretchFibers                                                     RefVariant[ClothingDebugRenderParams]
 66 : Bool           moduleName[].TethersActive                                                         RefVariant[ClothingDebugRenderParams]
 67 : Bool           moduleName[].TethersInactive                                                       RefVariant[ClothingDebugRenderParams]
 68 : Bool           moduleName[].VirtualCollision                                                      RefVariant[ClothingDebugRenderParams]
 69 : Bool           moduleName[].FiberRange                                                            RefVariant[ClothingDebugRenderParams]
 70 : Bool           moduleName[].ShowInLocalSpace                                                      RefVariant[ClothingDebugRenderParams]
 71 : Bool           moduleName[].GlobalPose                                                            RefVariant[ClothingDebugRenderParams]
 72 : Bool           moduleName[].RecomputeSubmeshes                                                    RefVariant[ClothingDebugRenderParams]
 73 : Bool           moduleName[].RecomputeVertices                                                     RefVariant[ClothingDebugRenderParams]
 74 : Bool           moduleName[].PhysicsMeshIndices                                                    RefVariant[ClothingDebugRenderParams]
 75 : Bool           moduleName[].MassScale                                                             RefVariant[ClothingDebugRenderParams]
 76 : Bool           moduleName[].SelfCollision                                                         RefVariant[ClothingDebugRenderParams]
 77 : Bool           moduleName[].SelfCollisionWire                                                     RefVariant[ClothingDebugRenderParams]
 78 : F32            moduleName[].SelfCollisionAttenuation                                              RefVariant[ClothingDebugRenderParams]
 79 : Bool           moduleName[].SolverMode                                                            RefVariant[ClothingDebugRenderParams]
 80 : Bool           moduleName[].VISUALIZE_DESTRUCTIBLE_ACTOR                                          RefVariant[DestructibleDebugRenderParams]
 81 : F32            moduleName[].VISUALIZE_DESTRUCTIBLE_BOUNDS                                         RefVariant[DestructibleDebugRenderParams]
 82 : F32            moduleName[].VISUALIZE_DESTRUCTIBLE_SUPPORT                                        RefVariant[DestructibleDebugRenderParams]
 83 : Bool           moduleName[].VISUALIZE_DESTRUCTIBLE_ACTOR_POSE                                     RefVariant[DestructibleDebugRenderParams]
 84 : F32            moduleName[].THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_POSE                            RefVariant[DestructibleDebugRenderParams]
 85 : Bool           moduleName[].VISUALIZE_DESTRUCTIBLE_ACTOR_NAME                                     RefVariant[DestructibleDebugRenderParams]
 86 : F32            moduleName[].THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_NAME                            RefVariant[DestructibleDebugRenderParams]
 87 : Bool           moduleName[].VISUALIZE_DESTRUCTIBLE_FRAGMENT_POSE                                  RefVariant[DestructibleDebugRenderParams]
 88 : F32            moduleName[].THRESHOLD_DISTANCE_DESTRUCTIBLE_FRAGMENT_POSE                         RefVariant[DestructibleDebugRenderParams]
 89 : Bool           moduleName[].apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR                    RefVariant[EmitterDebugRenderParams]
 90 : Bool           moduleName[].apexEmitterParameters.VISUALIZE_TOTAL_INJECTED_AABB                   RefVariant[EmitterDebugRenderParams]
 91 : Bool           moduleName[].apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_POSE               RefVariant[EmitterDebugRenderParams]
 92 : F32            moduleName[].apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_POSE      RefVariant[EmitterDebugRenderParams]
 93 : Bool           moduleName[].apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_NAME               RefVariant[EmitterDebugRenderParams]
 94 : F32            moduleName[].apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_NAME      RefVariant[EmitterDebugRenderParams]
 95 : Bool           moduleName[].groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR                RefVariant[EmitterDebugRenderParams]
 96 : Bool           moduleName[].groundEmitterParameters.VISUALIZE_GROUND_EMITTER_SPHERE               RefVariant[EmitterDebugRenderParams]
 97 : Bool           moduleName[].groundEmitterParameters.VISUALIZE_GROUND_EMITTER_GRID                 RefVariant[EmitterDebugRenderParams]
 98 : Bool           moduleName[].groundEmitterParameters.VISUALIZE_GROUND_EMITTER_RAYCAST              RefVariant[EmitterDebugRenderParams]
 99 : Bool           moduleName[].groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_POSE           RefVariant[EmitterDebugRenderParams]
100 : Bool           moduleName[].groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_NAME           RefVariant[EmitterDebugRenderParams]
101 : Bool           moduleName[].impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR                RefVariant[EmitterDebugRenderParams]
102 : Bool           moduleName[].impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_RAYCAST              RefVariant[EmitterDebugRenderParams]
103 : Bool           moduleName[].impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR_NAME           RefVariant[EmitterDebugRenderParams]
104 : F32            moduleName[].impactEmitterParameters.THRESHOLD_DISTANCE_IMPACT_EMITTER_ACTOR_NAME  RefVariant[EmitterDebugRenderParams]
105 : Bool           moduleName[].VISUALIZE_FORCEFIELD_ACTOR                                            RefVariant[ForceFieldDebugRenderParams]
106 : Bool           moduleName[].VISUALIZE_IOFX_ACTOR                                                  RefVariant[IofxDebugRenderParams]
107 : Bool           moduleName[].VISUALIZE_IOFX_BOUNDING_BOX                                           RefVariant[IofxDebugRenderParams]
108 : Bool           moduleName[].VISUALIZE_IOFX_ACTOR_NAME                                             RefVariant[IofxDebugRenderParams]
109 : Bool           moduleName[].VISUALIZE_TURBULENCE_FS_ACTOR                                         RefVariant[TurbulenceFSDebugRenderParams]
110 : Bool           moduleName[].VISUALIZE_HEAT_SOURCE_ACTOR                                           RefVariant[TurbulenceFSDebugRenderParams]
111 : Bool           moduleName[].VISUALIZE_SUBSTANCE_SOURCE_ACTOR                                      RefVariant[TurbulenceFSDebugRenderParams]
112 : Bool           moduleName[].VISUALIZE_VELOCITY_SOURCE_ACTOR                                       RefVariant[TurbulenceFSDebugRenderParams]
113 : Bool           moduleName[].VISUALIZE_TURBULENCE_FS_VELOCITY                                      RefVariant[TurbulenceFSDebugRenderParams]
114 : Bool           moduleName[].VISUALIZE_TURBULENCE_FS_BBOX                                          RefVariant[TurbulenceFSDebugRenderParams]
115 : Bool           moduleName[].VISUALIZE_TURBULENCE_FS_ACTOR_NAME                                    RefVariant[TurbulenceFSDebugRenderParams]
116 : Bool           moduleName[].VISUALIZE_TURBULENCE_FS_VELOCITY_FIELD                                RefVariant[TurbulenceFSDebugRenderParams]
117 : F32            moduleName[].TURBULENCE_FS_VELOCITY_FIELD_SCALE                                    RefVariant[TurbulenceFSDebugRenderParams]
118 : U32            moduleName[].TURBULENCE_FS_VELOCITY_FIELD_SPACING                                  RefVariant[TurbulenceFSDebugRenderParams]
119 : Bool           moduleName[].VISUALIZE_TURBULENCE_FS_TEMPERATURE_FIELD                             RefVariant[TurbulenceFSDebugRenderParams]
120 : Bool           moduleName[].VISUALIZE_TURBULENCE_FS_PRESSURE_FIELD                                RefVariant[TurbulenceFSDebugRenderParams]
121 : Bool           moduleName[].VISUALIZE_TURBULENCE_FS_DENSITY_FIELD                                 RefVariant[TurbulenceFSDebugRenderParams]
122 : F32            moduleName[].TURBULENCE_FS_SCALAR_FIELD_SCALE                                      RefVariant[TurbulenceFSDebugRenderParams]
123 : U32            moduleName[].TURBULENCE_FS_SCALAR_FIELD_SPACING                                    RefVariant[TurbulenceFSDebugRenderParams]
124 : Bool           moduleName[].VISUALIZE_TURBULENCE_FS_STREAMLINES                                   RefVariant[TurbulenceFSDebugRenderParams]
125 : F32            moduleName[].TURBULENCE_FS_STREAMLINES.tmax                                        RefVariant[TurbulenceFSDebugRenderParams]
126 : F32            moduleName[].TURBULENCE_FS_STREAMLINES.tstep                                       RefVariant[TurbulenceFSDebugRenderParams]
127 : Vec3           moduleName[].TURBULENCE_FS_STREAMLINES.grid                                        RefVariant[TurbulenceFSDebugRenderParams]
128 : Bool           moduleName[].VISUALIZE_TURBULENCE_FS_PLANE                                         RefVariant[TurbulenceFSDebugRenderParams]
129 : Vec3           moduleName[].TURBULENCE_FS_PLANE.normal                                            RefVariant[TurbulenceFSDebugRenderParams]
130 : F32            moduleName[].TURBULENCE_FS_PLANE.offset                                            RefVariant[TurbulenceFSDebugRenderParams]
131 : Bool           moduleName[].VISUALIZE_TURBULENCE_FS_GRID                                          RefVariant[TurbulenceFSDebugRenderParams]
132 : Bool           moduleName[].VISUALIZE_TURBULENCE_FS_LOD                                           RefVariant[TurbulenceFSDebugRenderParams]
133 : Bool           moduleName[].VISUALIZE_TURBULENCE_FS_POSE                                          RefVariant[TurbulenceFSDebugRenderParams]
134 : F32            moduleName[].TURBULENCE_FS_LOD                                                     RefVariant[TurbulenceFSDebugRenderParams]
135 : Bool           moduleName[].VISUALIZE_HEAT_SOURCE_ACTOR                                           RefVariant[ParticlesDebugRenderParams]
136 : Bool           moduleName[].VISUALIZE_EFFECT_PACKAGE_ACTOR                                        RefVariant[ParticlesDebugRenderParams]

Member Data Documentation

Bool DebugRenderParams::Bounds

'Bounds' : Draws the bounds of every apex actor

Bool DebugRenderParams::Enable

'Enable' : Enable/disable debug rendering

F32 DebugRenderParams::LodBenefits

'LodBenefits' : LOD benefit debug visualization

F32 DebugRenderParams::LodDistanceScale

'LodDistanceScale' : LOD distance debug visualization

ModuleName DebugRenderParams::moduleName[]
F32 DebugRenderParams::RelativeLodBenefitsScreenPos

'RelativeLodBenefitsScreenPos' : The y-axis value of the relative benefits bar (-1.0 - 1.0)

F32 DebugRenderParams::RelativeLodBenefitsThickness

'RelativeLodBenefitsThickness' : The thickness scale of the relative benefits bar

F32 DebugRenderParams::RenderBitangents

'RenderBitangents' : Draws the bitangents (green) of the rendered mesh. (scalable)

F32 DebugRenderParams::RenderNormals

'RenderNormals' : Draws the normals (blue) of the rendered mesh. (scalable)

F32 DebugRenderParams::RenderTangents

'RenderTangents' : Draws the tangents (red) of the rendered mesh. (scalable)

F32 DebugRenderParams::Scale

'Scale' : Debug rendering scale

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
DebugRenderParams Member List
This is the complete list of members for DebugRenderParams, including all inherited members.
Bounds | DebugRenderParams
Enable | DebugRenderParams
LodBenefits | DebugRenderParams
LodDistanceScale | DebugRenderParams
moduleName[] | DebugRenderParams
RelativeLodBenefitsScreenPos | DebugRenderParams
RelativeLodBenefitsThickness | DebugRenderParams
RenderBitangents | DebugRenderParams
RenderNormals | DebugRenderParams
RenderTangents | DebugRenderParams
Scale | DebugRenderParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: DestructibleActorChunks Struct Reference

  • Class List
  • Class Members
Public Attributes
DestructibleActorChunks Struct Reference

Describes the NxParameterized::Interface for 'DestructibleActorChunks' : More...

#include <params.h>

List of all members.

Public Attributes

U8 | data[].state
'data[].state' : Bit flags indicating the state of the chunk
U8 | data[].flags
'data[].flags' : Overall chunk flags
U32 | data[].islandID
'data[].islandID' : Island ID (if any) to which the chunk is attached
F32 | data[].damage
'data[].damage' : How damaged the chunk is
Vec4 | data[].localSphere
'data[].localSphere' : A local bounding sphere for the chunk
Vec3 | data[].localOffset
'data[].localOffset' : A local bounding sphere for the chunk
I32 | data[].visibleAncestorIndex
'data[].visibleAncestorIndex' : Index (in structure) of this chunks' visible ancestor, if any
U32 | data[].shapesCount
'data[].shapesCount' : Number of shapes for this chunk
Transform | data[].globalPose
'data[].globalPose' : Chunk global transform
Vec3 | data[].linearVelocity
'data[].linearVelocity' : Chunk linear velocity
Vec3 | data[].angularVelocity
'data[].angularVelocity' : Chunk angular velocity

Detailed Description

Describes the NxParameterized::Interface for 'DestructibleActorChunks' :

DestructibleActorChunks contains 12 fully qualified names
---------------------------------------------
  1 : ArraySizeName  data
  2 : U8             data[].state
  3 : U8             data[].flags
  4 : U32            data[].islandID
  5 : F32            data[].damage
  6 : Vec4           data[].localSphere
  7 : Vec3           data[].localOffset
  8 : I32            data[].visibleAncestorIndex
  9 : U32            data[].shapesCount
 10 : Transform      data[].globalPose
 11 : Vec3           data[].linearVelocity
 12 : Vec3           data[].angularVelocity

Member Data Documentation

Vec3 DestructibleActorChunks::data[].angularVelocity

'data[].angularVelocity' : Chunk angular velocity

Chunk angular velocity.

F32 DestructibleActorChunks::data[].damage

'data[].damage' : How damaged the chunk is

How damaged the chunk is.

U8 DestructibleActorChunks::data[].flags

'data[].flags' : Overall chunk flags

Overall chunk flags.

Transform DestructibleActorChunks::data[].globalPose

'data[].globalPose' : Chunk global transform

Chunk global transform.

U32 DestructibleActorChunks::data[].islandID

'data[].islandID' : Island ID (if any) to which the chunk is attached

Island ID (if any) to which the chunk is attached.

Vec3 DestructibleActorChunks::data[].linearVelocity

'data[].linearVelocity' : Chunk linear velocity

Chunk linear velocity.

Vec3 DestructibleActorChunks::data[].localOffset

'data[].localOffset' : A local bounding sphere for the chunk

A local bounding sphere for the chunk.

Vec4 DestructibleActorChunks::data[].localSphere

'data[].localSphere' : A local bounding sphere for the chunk

A local bounding sphere for the chunk.

U32 DestructibleActorChunks::data[].shapesCount

'data[].shapesCount' : Number of shapes for this chunk

Number of shapes for this chunk.

U8 DestructibleActorChunks::data[].state

'data[].state' : Bit flags indicating the state of the chunk

Bit flags indicating the state of the chunk.

I32 DestructibleActorChunks::data[].visibleAncestorIndex

'data[].visibleAncestorIndex' : Index (in structure) of this chunks' visible ancestor, if any

Index (in structure) of this chunks' visible ancestor, if any. If none exists, it's InvalidChunkIndex.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
DestructibleActorChunks Member List
This is the complete list of members for DestructibleActorChunks, including all inherited members.
data[].angularVelocity | DestructibleActorChunks
data[].damage | DestructibleActorChunks
data[].flags | DestructibleActorChunks
data[].globalPose | DestructibleActorChunks
data[].islandID | DestructibleActorChunks
data[].linearVelocity | DestructibleActorChunks
data[].localOffset | DestructibleActorChunks
data[].localSphere | DestructibleActorChunks
data[].shapesCount | DestructibleActorChunks
data[].state | DestructibleActorChunks
data[].visibleAncestorIndex | DestructibleActorChunks
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: DestructibleActorParam Struct Reference

  • Class List
  • Class Members
Public Attributes
DestructibleActorParam Struct Reference

Describes the NxParameterized::Interface for 'DestructibleActorParam' : More...

#include <params.h>

List of all members.

Public Attributes

String | crumbleEmitterName
'crumbleEmitterName' : The name of the NxMeshParticleSystem to use for crumbling
F32 | crumbleParticleSpacing
'crumbleParticleSpacing' : How far apart to space the particles when crumbling
String | dustEmitterName
'dustEmitterName' : The name of the NxMeshParticleSystem to use for fracture-line dust
F32 | dustParticleSpacing
'dustParticleSpacing' : How far apart to space the particles when creating dust particles
Mat34 | globalPose
'globalPose' : The initial pose where the destructible actor will be put into the scene
Vec3 | scale
'scale' : 3D Scale
Bool | dynamic
'dynamic' : Whether or not the destructible starts life as a dynamic actor
U32 | supportDepth
'supportDepth' : The chunk hierarchy depth at which to create a support graph.
Bool | formExtendedStructures
'formExtendedStructures' : If initially static, the destructible will become part of an extended support structure if it is in contact with another static destructible that also has this flag set.
Bool | performDetailedOverlapTestForExtendedStructures
'performDetailedOverlapTestForExtendedStructures' : When testing for chunk overlap with other destructibles, perform detailed collision test. Otherwise, just test AABBs.
Bool | keepPreviousFrameBoneBuffer
'keepPreviousFrameBoneBuffer' : If true, the skinned mesh will hold a bone buffer for the last frame
Bool | doNotCreateRenderable
'doNotCreateRenderable' : If true, a renderable will not be created for the destructible actor
Bool | useAssetDefinedSupport
'useAssetDefinedSupport' : If set, then chunks which are tagged as 'support' chunks
Bool | useWorldSupport
'useWorldSupport' : If set, then chunks which overlap the NxScene's static geometry will have environmental support
Bool | renderStaticChunksSeparately
'renderStaticChunksSeparately' : Whether or not to render static chunks in a separate mesh
Bool | keepVisibleBonesPacked
'keepVisibleBonesPacked' : Parameter passed into skinned ApexRenderMeshActor
Bool | createChunkEvents
'createChunkEvents' : Whether or not to create an event buffer for chunks
String | overrideSkinnedMaterialNames[]
'overrideSkinnedMaterialNames[]' : Per-actor material names, to override those in the asset, for skinned rendering
String | overrideStaticMaterialNames[]
'overrideStaticMaterialNames[]' : Per-actor material names, to override those in the asset, for static rendering
F32 | sleepVelocityFrameDecayConstant
'sleepVelocityFrameDecayConstant' : Frame memory decay constant used for actor velocity smoothing. Valid range: [1.0,infinity).
Bool | useHardSleeping
'useHardSleeping' : If true, turn chunk islands kinematic when they sleep.
F32 | destructibleParameters.damageCap
'destructibleParameters.damageCap' : Limits the amount of damage applied to a chunk.
F32 | destructibleParameters.forceToDamage
'destructibleParameters.forceToDamage' : Multiplier to calculate applied damage from an impact.
F32 | destructibleParameters.impactVelocityThreshold
'destructibleParameters.impactVelocityThreshold' : Large impact force may be reported if rigid bodies are spawned inside one another.
U32 | destructibleParameters.minimumFractureDepth
'destructibleParameters.minimumFractureDepth' : The chunks will not be broken free below this depth.
I32 | destructibleParameters.impactDamageDefaultDepth
'destructibleParameters.impactDamageDefaultDepth' : The default depth to which chunks will take impact damage.
I32 | destructibleParameters.debrisDepth
'destructibleParameters.debrisDepth' : The chunk hierarchy depth at which chunks are considered to be 'debris.'
U32 | destructibleParameters.essentialDepth
'destructibleParameters.essentialDepth' : The chunk hierarchy depth up to which chunks will always be processed
F32 | destructibleParameters.debrisLifetimeMin
'destructibleParameters.debrisLifetimeMin' : Minimum time to destroy debris
F32 | destructibleParameters.debrisLifetimeMax
'destructibleParameters.debrisLifetimeMax' : Maximum time to destroy debris
F32 | destructibleParameters.debrisMaxSeparationMin
'destructibleParameters.debrisMaxSeparationMin' : Minimum separation distance
F32 | destructibleParameters.debrisMaxSeparationMax
'destructibleParameters.debrisMaxSeparationMax' : Minimum separation distance
F32 | destructibleParameters.debrisDestructionProbability
'destructibleParameters.debrisDestructionProbability' : The probablity that a debris chunk, when fractured, will simply be destroyed
Bounds3 | destructibleParameters.validBounds
'destructibleParameters.validBounds' : valid bounding region for debris
F32 | destructibleParameters.maxChunkSpeed
'destructibleParameters.maxChunkSpeed' : Maximum speed of a chunk
Bool | destructibleParameters.flags.ACCUMULATE_DAMAGE
'destructibleParameters.flags.ACCUMULATE_DAMAGE' : Determines if chunks accumulate damage
Bool | destructibleParameters.flags.DEBRIS_TIMEOUT
'destructibleParameters.flags.DEBRIS_TIMEOUT' : Whether or not chunks at or deeper than the 'debris' depth will timeout
Bool | destructibleParameters.flags.DEBRIS_MAX_SEPARATION
'destructibleParameters.flags.DEBRIS_MAX_SEPARATION' : Whether or not chunks at or deeper than the 'debris' depth will be removed if separated too far
Bool | destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS
'destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS' : If set, the smallest chunks may be further broken down
Bool | destructibleParameters.flags.ACCURATE_RAYCASTS
'destructibleParameters.flags.ACCURATE_RAYCASTS' : If set, the NxDestructibleActor::rayCast function will search within the nearest visible chunk hit
Bool | destructibleParameters.flags.USE_VALID_BOUNDS
'destructibleParameters.flags.USE_VALID_BOUNDS' : If set, the validBounds field of NxDestructibleParameters will be used.
Bool | destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE
'destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE' : If set, crumbled chunks will use the runtime fracture pipeline.
F32 | destructibleParameters.fractureImpulseScale
'destructibleParameters.fractureImpulseScale' : Scale factor used to apply an impulse force along the normal of chunk when fractured.
U16 | destructibleParameters.damageDepthLimit
'destructibleParameters.damageDepthLimit' : How deep in the hierarchy damage will be propagated, relative to the chunk hit.
U16 | destructibleParameters.dynamicChunkDominanceGroup
'destructibleParameters.dynamicChunkDominanceGroup' : Optional dominance group for dynamic chunks created when fractured.
Bool | destructibleParameters.dynamicChunksGroupsMask.useGroupsMask
'destructibleParameters.dynamicChunksGroupsMask.useGroupsMask' : Whether or not the groupsMask should be used
U32 | destructibleParameters.dynamicChunksGroupsMask.bits0
'destructibleParameters.dynamicChunksGroupsMask.bits0' : bits0 of the groups mask
U32 | destructibleParameters.dynamicChunksGroupsMask.bits1
'destructibleParameters.dynamicChunksGroupsMask.bits1' : bits1 of the groups mask
U32 | destructibleParameters.dynamicChunksGroupsMask.bits2
'destructibleParameters.dynamicChunksGroupsMask.bits2' : bits2 of the groups mask
U32 | destructibleParameters.dynamicChunksGroupsMask.bits3
'destructibleParameters.dynamicChunksGroupsMask.bits3' : bits3 of the groups mask
RuntimeFractureType destructibleParameters.runtimeFracture.RuntimeFractureType
'destructibleParameters.runtimeFracture.RuntimeFractureType' : Which type of fracture pattern to choose
Bool | destructibleParameters.runtimeFracture.sheetFracture
'destructibleParameters.runtimeFracture.sheetFracture' : If true, align fracture pattern to largest face
U32 | destructibleParameters.runtimeFracture.depthLimit
'destructibleParameters.runtimeFracture.depthLimit' : Number of times deep a chunk can be fractured.
Bool | destructibleParameters.runtimeFracture.destroyIfAtDepthLimit
'destructibleParameters.runtimeFracture.destroyIfAtDepthLimit' : Destroy chunk if at depth limit
F32 | destructibleParameters.runtimeFracture.minConvexSize
'destructibleParameters.runtimeFracture.minConvexSize' : Minimum Convex Size.
F32 | destructibleParameters.runtimeFracture.impulseScale
'destructibleParameters.runtimeFracture.impulseScale' : Scales impulse applied by a fracture.
U32 | destructibleParameters.runtimeFracture.glass.numSectors
'destructibleParameters.runtimeFracture.glass.numSectors' : Number of angular slices.
F32 | destructibleParameters.runtimeFracture.glass.sectorRand
'destructibleParameters.runtimeFracture.glass.sectorRand' : Creates variance in the angle of slices.
F32 | destructibleParameters.runtimeFracture.glass.firstSegmentSize
'destructibleParameters.runtimeFracture.glass.firstSegmentSize' : The minimum shard size.
F32 | destructibleParameters.runtimeFracture.glass.segmentScale
'destructibleParameters.runtimeFracture.glass.segmentScale' : Scales the radial spacing.
F32 | destructibleParameters.runtimeFracture.glass.segmentRand
'destructibleParameters.runtimeFracture.glass.segmentRand' : Creates variance in the radial size of shards.
Vec3 | destructibleParameters.runtimeFracture.voronoi.dimensions
'destructibleParameters.runtimeFracture.voronoi.dimensions' : The size of the entire block
U32 | destructibleParameters.runtimeFracture.voronoi.numCells
'destructibleParameters.runtimeFracture.voronoi.numCells' : Max Number of Cells to create.
F32 | destructibleParameters.runtimeFracture.voronoi.biasExp
'destructibleParameters.runtimeFracture.voronoi.biasExp' : Bias Exponential value.
F32 | destructibleParameters.runtimeFracture.voronoi.maxDist
'destructibleParameters.runtimeFracture.voronoi.maxDist' : The max distance a Voronoi point away from origin.
Bool | destructibleParameters.runtimeFracture.attachment.posX
'destructibleParameters.runtimeFracture.attachment.posX' : Attach to positive x side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.negX
'destructibleParameters.runtimeFracture.attachment.negX' : Attach to negative x side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.posY
'destructibleParameters.runtimeFracture.attachment.posY' : Attach to positive y side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.negY
'destructibleParameters.runtimeFracture.attachment.negY' : Attach to negative y side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.posZ
'destructibleParameters.runtimeFracture.attachment.posZ' : Attach to positive z side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.negZ
'destructibleParameters.runtimeFracture.attachment.negZ' : Attach to negative z side of sheet.
F32 | destructibleParameters.supportStrength
'destructibleParameters.supportStrength' : The support strength threshold for breaking chunks in stressSolver
I8 | destructibleParameters.legacyChunkBoundsTestSetting
'destructibleParameters.legacyChunkBoundsTestSetting' : Whether or not to use the old chunk bounds testing for damage, or use the module setting.
I8 | destructibleParameters.legacyDamageRadiusSpreadSetting
'destructibleParameters.legacyDamageRadiusSpreadSetting' : Whether or not to use the old damage spread method, or use the module setting.
Bool | depthParameters[].OVERRIDE_IMPACT_DAMAGE
'depthParameters[].OVERRIDE_IMPACT_DAMAGE' : If true, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE_VALUE = TRUE, no matter the setting of impactDamageDefaultDepth.
Bool | depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE
'depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE' : If OVERRIDE_IMPACT_DAMAGE = TRUE, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE_VALUE = TRUE.
Bool | depthParameters[].IGNORE_POSE_UPDATES
'depthParameters[].IGNORE_POSE_UPDATES' : Chunks at this depth should have pose updates ignored.
Bool | depthParameters[].IGNORE_RAYCAST_CALLBACKS
'depthParameters[].IGNORE_RAYCAST_CALLBACKS' : Chunks at this depth should be ignored in raycast callbacks.
Bool | depthParameters[].IGNORE_CONTACT_CALLBACKS
'depthParameters[].IGNORE_CONTACT_CALLBACKS' : Chunks at this depth should be ignored in contact callbacks.
Bool | depthParameters[].USER_FLAG_0
'depthParameters[].USER_FLAG_0' : User defined flag.
Bool | depthParameters[].USER_FLAG_1
'depthParameters[].USER_FLAG_1' : User defined flag.
Bool | depthParameters[].USER_FLAG_2
'depthParameters[].USER_FLAG_2' : User defined flag.
Bool | depthParameters[].USER_FLAG_3
'depthParameters[].USER_FLAG_3' : User defined flag.
Bool | shapeDescTemplate.flags.NX_TRIGGER_ON_ENTER
'shapeDescTemplate.flags.NX_TRIGGER_ON_ENTER' : Trigger callback will be called when a shape enters the trigger volume.
Bool | shapeDescTemplate.flags.NX_TRIGGER_ON_LEAVE
'shapeDescTemplate.flags.NX_TRIGGER_ON_LEAVE' : Trigger callback will be called after a shape leaves the trigger volume.
Bool | shapeDescTemplate.flags.NX_TRIGGER_ON_STAY
'shapeDescTemplate.flags.NX_TRIGGER_ON_STAY' : Trigger callback will be called while a shape is intersecting the trigger volume.
Bool | shapeDescTemplate.flags.NX_SF_VISUALIZATION
'shapeDescTemplate.flags.NX_SF_VISUALIZATION' : Enable debug renderer for shapes
Bool | shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION
'shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION' : Disable collision detection for shapes (counterpart of NX_AF_DISABLE_COLLISION)
Bool | shapeDescTemplate.flags.NX_SF_FEATURE_INDICES
'shapeDescTemplate.flags.NX_SF_FEATURE_INDICES' : Enable feature indices in contact stream.
Bool | shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING
'shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING' : Disable raycasting for shapes
Bool | shapeDescTemplate.flags.NX_SF_POINT_CONTACT_FORCE
'shapeDescTemplate.flags.NX_SF_POINT_CONTACT_FORCE' : Enable contact force reporting per contact point in contact stream (otherwise we only report force per actor pair)
Bool | shapeDescTemplate.flags.NX_SF_FLUID_DRAIN
'shapeDescTemplate.flags.NX_SF_FLUID_DRAIN' : Sets a shape to be a fluid drain.
Bool | shapeDescTemplate.flags.NX_SF_FLUID_DISABLE_COLLISION
'shapeDescTemplate.flags.NX_SF_FLUID_DISABLE_COLLISION' : Disable collision with fluids.
Bool | shapeDescTemplate.flags.NX_SF_FLUID_TWOWAY
'shapeDescTemplate.flags.NX_SF_FLUID_TWOWAY' : Enables the reaction of a shapes actor on fluid collision.
Bool | shapeDescTemplate.flags.NX_SF_DISABLE_RESPONSE
'shapeDescTemplate.flags.NX_SF_DISABLE_RESPONSE' : Disable collision response for shapes (counterpart of NX_AF_DISABLE_RESPONSE)
Bool | shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD
'shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD' : Enable dynamic-dynamic CCD for shapes. Used only when CCD is globally enabled and shape have a CCD skeleton.
Bool | shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES
'shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES' : Disable participation in ray casts, overlap tests and sweeps.
Bool | shapeDescTemplate.flags.NX_SF_CLOTH_DRAIN
'shapeDescTemplate.flags.NX_SF_CLOTH_DRAIN' : Sets a shape to be a cloth drain.
Bool | shapeDescTemplate.flags.NX_SF_CLOTH_DISABLE_COLLISION
'shapeDescTemplate.flags.NX_SF_CLOTH_DISABLE_COLLISION' : Disable collision with cloths.
Bool | shapeDescTemplate.flags.NX_SF_CLOTH_TWOWAY
'shapeDescTemplate.flags.NX_SF_CLOTH_TWOWAY' : Enables the reaction of a shapes actor on cloth collision.
Bool | shapeDescTemplate.flags.NX_SF_SOFTBODY_DRAIN
'shapeDescTemplate.flags.NX_SF_SOFTBODY_DRAIN' : Sets a shape to be a soft body drain.
Bool | shapeDescTemplate.flags.NX_SF_SOFTBODY_DISABLE_COLLISION
'shapeDescTemplate.flags.NX_SF_SOFTBODY_DISABLE_COLLISION' : Disable collision with soft bodies.
Bool | shapeDescTemplate.flags.NX_SF_SOFTBODY_TWOWAY
'shapeDescTemplate.flags.NX_SF_SOFTBODY_TWOWAY' : Enables the reaction of a shape's actor on soft body collision.
U16 | shapeDescTemplate.collisionGroup
'shapeDescTemplate.collisionGroup' : Sets which collision group shapes are part of.
Bool | shapeDescTemplate.groupsMask.useGroupsMask
'shapeDescTemplate.groupsMask.useGroupsMask' : Whether or not the groupsMask should be used
U32 | shapeDescTemplate.groupsMask.bits0
'shapeDescTemplate.groupsMask.bits0' : bits0 of the groups mask
U32 | shapeDescTemplate.groupsMask.bits1
'shapeDescTemplate.groupsMask.bits1' : bits1 of the groups mask
U32 | shapeDescTemplate.groupsMask.bits2
'shapeDescTemplate.groupsMask.bits2' : bits2 of the groups mask
U32 | shapeDescTemplate.groupsMask.bits3
'shapeDescTemplate.groupsMask.bits3' : bits3 of the groups mask
U16 | shapeDescTemplate.materialIndex
'shapeDescTemplate.materialIndex' : The material index of a shape.
F32 | shapeDescTemplate.density
'shapeDescTemplate.density' : The density of an individual shape.
F32 | shapeDescTemplate.skinWidth
'shapeDescTemplate.skinWidth' : Specifies by how much shapes can interpenetrate; if -1 it uses the global default
U64 | shapeDescTemplate.userData
'shapeDescTemplate.userData' : Optional user data pointer
U64 | shapeDescTemplate.name
'shapeDescTemplate.name' : Optional name string for a shape.
Bool | actorDescTemplate.flags.NX_AF_DISABLE_COLLISION
'actorDescTemplate.flags.NX_AF_DISABLE_COLLISION' : Enable/disable collision detection
Bool | actorDescTemplate.flags.NX_AF_DISABLE_RESPONSE
'actorDescTemplate.flags.NX_AF_DISABLE_RESPONSE' : Enable/disable collision response (reports contacts but dont use them)
Bool | actorDescTemplate.flags.NX_AF_LOCK_COM
'actorDescTemplate.flags.NX_AF_LOCK_COM' : Disables COM update when computing inertial properties at creation time.
Bool | actorDescTemplate.flags.NX_AF_FLUID_DISABLE_COLLISION
'actorDescTemplate.flags.NX_AF_FLUID_DISABLE_COLLISION' : Disables COM update when computing inertial properties at creation time.
Bool | actorDescTemplate.flags.NX_AF_CONTACT_MODIFICATION
'actorDescTemplate.flags.NX_AF_CONTACT_MODIFICATION' : Turn on contact modification callback for the actor.
Bool | actorDescTemplate.flags.NX_AF_FORCE_CONE_FRICTION
'actorDescTemplate.flags.NX_AF_FORCE_CONE_FRICTION' : Force cone friction to be used for this actor.
Bool | actorDescTemplate.flags.NX_AF_USER_ACTOR_PAIR_FILTERING
'actorDescTemplate.flags.NX_AF_USER_ACTOR_PAIR_FILTERING' : Enable/disable custom contact filtering.
F32 | actorDescTemplate.density
'actorDescTemplate.density' : Density to be applied to the whole actor.
U16 | actorDescTemplate.actorCollisionGroup
'actorDescTemplate.actorCollisionGroup' : Sets which NxActorGroup an actor is part of
U16 | actorDescTemplate.dominanceGroup
'actorDescTemplate.dominanceGroup' : Dominance group for an actor.
Bool | actorDescTemplate.contactReportFlags.NX_IGNORE_PAIR
'actorDescTemplate.contactReportFlags.NX_IGNORE_PAIR' : Disable contact generation for this pair
Bool | actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH
'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH' : Pair callback will be called when the pair starts to be in contact
Bool | actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH
'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH' : Pair callback will be called when the pair stops to be in contact
Bool | actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH
'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH' : Pair callback will keep getting called while the pair is in contact
Bool | actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_IMPACT
'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_IMPACT' : [Not yet implemented] pair callback will be called when it may be appropriate for the pair to play an impact sound
Bool | actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_ROLL
'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_ROLL' : [Not yet implemented] pair callback will be called when the pair is in contact and rolling.
Bool | actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_SLIDE
'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_SLIDE' : [Not yet implemented] pair callback will be called when the pair is in contact and sliding (and not rolling).
Bool | actorDescTemplate.contactReportFlags.NX_NOTIFY_FORCES
'actorDescTemplate.contactReportFlags.NX_NOTIFY_FORCES' : The (summed total) friction force and normal force will be given in the NxContactPair variable in the contact report.
Bool | actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH_FORCE_THRESHOLD
'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH_FORCE_THRESHOLD' : Pair callback will be called when the contact force between two actors falls below the actor-defined force thresholds
Bool | actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH_FORCE_THRESHOLD
'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH_FORCE_THRESHOLD' : Pair callback will be called when the contact force between two actors falls below the actor-defined force thresholds
Bool | actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH_FORCE_THRESHOLD
'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH_FORCE_THRESHOLD' : Pair callback will keep getting called while the contact force between two actors exceeds one of the actor-defined force thresholds
Bool | actorDescTemplate.contactReportFlags.NX_NOTIFY_CONTACT_MODIFICATION
'actorDescTemplate.contactReportFlags.NX_NOTIFY_CONTACT_MODIFICATION' : Generate a callback for all associated contact constraints, making it possible to edit the constraint. This flag is not included in NX_NOTIFY_ALL for performance reasons. see NxUserContactModify.
U16 | actorDescTemplate.forceFieldMaterial
'actorDescTemplate.forceFieldMaterial' : Force Field Material Index
U64 | actorDescTemplate.userData
'actorDescTemplate.userData' : Optional user data pointer
U64 | actorDescTemplate.name
'actorDescTemplate.name' : Optional name string for a shape; must be set by the application and must be a persistent pointer.
U64 | actorDescTemplate.compartment
'actorDescTemplate.compartment' : Optional compartment pointer
Bool | bodyDescTemplate.flags.NX_BF_DISABLE_GRAVITY
'bodyDescTemplate.flags.NX_BF_DISABLE_GRAVITY' : Set if gravity should not be applied on this body
Bool | bodyDescTemplate.flags.NX_BF_FILTER_SLEEP_VEL
'bodyDescTemplate.flags.NX_BF_FILTER_SLEEP_VEL' : Filter velocities used keep body awake. The filter reduces rapid oscillations and transient spikes
Bool | bodyDescTemplate.flags.NX_BF_ENERGY_SLEEP_TEST
'bodyDescTemplate.flags.NX_BF_ENERGY_SLEEP_TEST' : Enables energy-based sleeping algorithm
Bool | bodyDescTemplate.flags.NX_BF_VISUALIZATION
'bodyDescTemplate.flags.NX_BF_VISUALIZATION' : Enables debug visualization for this body
F32 | bodyDescTemplate.wakeUpCounter
'bodyDescTemplate.wakeUpCounter' : The bodys initial wake up counter
F32 | bodyDescTemplate.linearDamping
'bodyDescTemplate.linearDamping' : Linear damping applied to the body
F32 | bodyDescTemplate.angularDamping
'bodyDescTemplate.angularDamping' : Angular damping applied to the body
F32 | bodyDescTemplate.maxAngularVelocity
'bodyDescTemplate.maxAngularVelocity' : Maximum allowed angular velocity
F32 | bodyDescTemplate.CCDMotionThreshold
'bodyDescTemplate.CCDMotionThreshold' : Distance threshold for CCD
F32 | bodyDescTemplate.sleepLinearVelocity
'bodyDescTemplate.sleepLinearVelocity' : Maximum linear velocity at which body can go to sleep
F32 | bodyDescTemplate.sleepAngularVelocity
'bodyDescTemplate.sleepAngularVelocity' : Maximum angular velocity at which body can go to sleep
U32 | bodyDescTemplate.solverIterationCount
'bodyDescTemplate.solverIterationCount' : Number of solver iterations performed when processing joint/contacts connected to this body
F32 | bodyDescTemplate.sleepEnergyThreshold
'bodyDescTemplate.sleepEnergyThreshold' : Threshold for the energy-based sleeping algorithm. Only used when the NX_BF_ENERGY_SLEEP_TEST flag is set
F32 | bodyDescTemplate.sleepDamping
'bodyDescTemplate.sleepDamping' : Damping factor for bodies that are about to sleep
F32 | bodyDescTemplate.contactReportThreshold
'bodyDescTemplate.contactReportThreshold' : The force threshold for contact reports
Bool | p3ShapeDescTemplate.flags.eSIMULATION_SHAPE
'p3ShapeDescTemplate.flags.eSIMULATION_SHAPE' : The shape will partake in collision in the physical simulation.
Bool | p3ShapeDescTemplate.flags.eSCENE_QUERY_SHAPE
'p3ShapeDescTemplate.flags.eSCENE_QUERY_SHAPE' : The shape will partake in scene queries (ray casts, overlap tests, sweeps, ...).
Bool | p3ShapeDescTemplate.flags.eTRIGGER_SHAPE
'p3ShapeDescTemplate.flags.eTRIGGER_SHAPE' : The shape is a trigger which can send reports whenever other shapes enter/leave its volume.
Bool | p3ShapeDescTemplate.flags.eVISUALIZATION
'p3ShapeDescTemplate.flags.eVISUALIZATION' : Enable debug renderer for this shape
Bool | p3ShapeDescTemplate.flags.ePARTICLE_DRAIN
'p3ShapeDescTemplate.flags.ePARTICLE_DRAIN' : Sets the shape to be a particle drain
Bool | p3ShapeDescTemplate.flags.eDEFORMABLE_DRAIN
'p3ShapeDescTemplate.flags.eDEFORMABLE_DRAIN' : Sets the shape to be a deformable drain
U32 | p3ShapeDescTemplate.simulationFilterData.word0
'p3ShapeDescTemplate.simulationFilterData.word0' : word0 of the filter data
U32 | p3ShapeDescTemplate.simulationFilterData.word1
'p3ShapeDescTemplate.simulationFilterData.word1' : word1 of the filter data
U32 | p3ShapeDescTemplate.simulationFilterData.word2
'p3ShapeDescTemplate.simulationFilterData.word2' : word2 of the filter data
U32 | p3ShapeDescTemplate.simulationFilterData.word3
'p3ShapeDescTemplate.simulationFilterData.word3' : word3 of the filter data
U32 | p3ShapeDescTemplate.queryFilterData.word0
'p3ShapeDescTemplate.queryFilterData.word0' : word0 of the filter data
U32 | p3ShapeDescTemplate.queryFilterData.word1
'p3ShapeDescTemplate.queryFilterData.word1' : word1 of the filter data
U32 | p3ShapeDescTemplate.queryFilterData.word2
'p3ShapeDescTemplate.queryFilterData.word2' : word2 of the filter data
U32 | p3ShapeDescTemplate.queryFilterData.word3
'p3ShapeDescTemplate.queryFilterData.word3' : word3 of the filter data
U64 | p3ShapeDescTemplate.material
'p3ShapeDescTemplate.material' : A PxMaterial pointer for the shape
F32 | p3ShapeDescTemplate.contactOffset
'p3ShapeDescTemplate.contactOffset' : Sets the contact offset
F32 | p3ShapeDescTemplate.restOffset
'p3ShapeDescTemplate.restOffset' : Sets the rest offset
U64 | p3ShapeDescTemplate.userData
'p3ShapeDescTemplate.userData' : Optional user data pointer
U64 | p3ShapeDescTemplate.name
'p3ShapeDescTemplate.name' : Optional name string for a shape.
Bool | p3ActorDescTemplate.flags.eVISUALIZATION
'p3ActorDescTemplate.flags.eVISUALIZATION' : Enable debug renderer for this actor
Bool | p3ActorDescTemplate.flags.eDISABLE_GRAVITY
'p3ActorDescTemplate.flags.eDISABLE_GRAVITY' : Disables scene gravity for this actor
Bool | p3ActorDescTemplate.flags.eSEND_SLEEP_NOTIFIES
'p3ActorDescTemplate.flags.eSEND_SLEEP_NOTIFIES' : Enables the sending of PxSimulationEventCallback::onWake() and PxSimulationEventCallback::onSleep() notify events
U8 | p3ActorDescTemplate.dominanceGroup
'p3ActorDescTemplate.dominanceGroup' : Assigns dynamic actors a dominance group identifier.
U8 | p3ActorDescTemplate.ownerClient
'p3ActorDescTemplate.ownerClient' : Sets the owner client of an actor.
U32 | p3ActorDescTemplate.clientBehaviorBits
'p3ActorDescTemplate.clientBehaviorBits' : Changes the behavior bits initially specified with PxActorDesc::clientBehaviorBits.
Bool | p3ActorDescTemplate.contactReportFlags.eRESOLVE_CONTACTS
'p3ActorDescTemplate.contactReportFlags.eRESOLVE_CONTACTS' : Process the contacts of this collision pair in the dynamics solver.
Bool | p3ActorDescTemplate.contactReportFlags.eMODIFY_CONTACTS
'p3ActorDescTemplate.contactReportFlags.eMODIFY_CONTACTS' : Call contact modification callback for this collision pair.
Bool | p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_FOUND
'p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_FOUND' : Call contact report callback or trigger callback when this collision pair starts to be in contact
Bool | p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_PERSISTS
'p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_PERSISTS' : Call contact report callback or trigger callback while this collision pair is in contact
Bool | p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_LOST
'p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_LOST' : Call contact report callback or trigger callback when this collision pair stops to be in contact.
Bool | p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_FOUND
'p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_FOUND' : Call contact report callback when the contact force between the actors of this collision pair exceeds one of the actor-defined force thresholds.
Bool | p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_PERSISTS
'p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_PERSISTS' : Call contact report callback when the contact force between the actors of this collision pair continues to exceed one of the actor-defined force thresholds
Bool | p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_LOST
'p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_LOST' : Call contact report callback when the contact force between the actors of this collision pair falls below one of the actor-defined force thresholds (includes the case where this collision pair stops being in contact).
Bool | p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_POINTS
'p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_POINTS' : Provide contact points in contact reports for this collision pair.
Bool | p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCES
'p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCES' : Provide the (summed total) friction force and normal force in contact reports for this collision pair (see PxContactPair).
Bool | p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCE_PER_POINT
'p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCE_PER_POINT' : Provide contact forces per contact point in contact reports for this collision pair.
Bool | p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FEATURE_INDICES_PER_POINT
'p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FEATURE_INDICES_PER_POINT' : Provide feature indices per contact point in contact reports for this collision pair.
Bool | p3ActorDescTemplate.contactReportFlags.eCCD_LINEAR
'p3ActorDescTemplate.contactReportFlags.eCCD_LINEAR' : A less expensive approximation of eSWEPT_INTEGRATION_FULL, where the rotational motion of the objects is neglected. Should be used when performance is of the essence, for objects where angular motion is unlikely to lead to tunneling.
Bool | p3ActorDescTemplate.contactReportFlags.eCONTACT_DEFAULT
'p3ActorDescTemplate.contactReportFlags.eCONTACT_DEFAULT' : Provided default flag to do simple contact processing for this collision pair.
Bool | p3ActorDescTemplate.contactReportFlags.eTRIGGER_DEFAULT
'p3ActorDescTemplate.contactReportFlags.eTRIGGER_DEFAULT' : Provided default flag to get commonly used trigger behavior for this collision pair.
U64 | p3ActorDescTemplate.userData
'p3ActorDescTemplate.userData' : Optional user data pointer
U64 | p3ActorDescTemplate.name
'p3ActorDescTemplate.name' : Optional name string for a shape; must be set by the application and must be a persistent pointer.
F32 | p3BodyDescTemplate.density
'p3BodyDescTemplate.density' : The density of the body. Used to compute the mass of the body.
Bool | p3BodyDescTemplate.flags.eKINEMATIC
'p3BodyDescTemplate.flags.eKINEMATIC' : Enables kinematic mode for the actor
Bool | p3BodyDescTemplate.flags.eENABLE_CCD
'p3BodyDescTemplate.flags.eENABLE_CCD' : Enables swept integration for the actor.
F32 | p3BodyDescTemplate.sleepThreshold
'p3BodyDescTemplate.sleepThreshold' : Sets the mass-normalized kinetic energy threshold below which an actor may go to sleep.
F32 | p3BodyDescTemplate.wakeUpCounter
'p3BodyDescTemplate.wakeUpCounter' : The bodys initial wake up counter
F32 | p3BodyDescTemplate.linearDamping
'p3BodyDescTemplate.linearDamping' : Linear damping applied to the body
F32 | p3BodyDescTemplate.angularDamping
'p3BodyDescTemplate.angularDamping' : Sets the angular damping coefficient
F32 | p3BodyDescTemplate.maxAngularVelocity
'p3BodyDescTemplate.maxAngularVelocity' : Maximum allowed angular velocity
U32 | p3BodyDescTemplate.solverIterationCount
'p3BodyDescTemplate.solverIterationCount' : Sets the solver iteration counts for the body
U32 | p3BodyDescTemplate.velocityIterationCount
'p3BodyDescTemplate.velocityIterationCount' : Sets the velocity solver iteration counts for the body
F32 | p3BodyDescTemplate.contactReportThreshold
'p3BodyDescTemplate.contactReportThreshold' : The force threshold for contact reports
F32 | p3BodyDescTemplate.sleepLinearVelocity
'p3BodyDescTemplate.sleepLinearVelocity' : Maximum linear velocity at which body can go to sleep
Bool | structureSettings.useStressSolver
'structureSettings.useStressSolver' : If true, the structure containing this actor will use the stress solver.
F32 | structureSettings.stressSolverTimeDelay
'structureSettings.stressSolverTimeDelay' : The structure containing this actor will use the minimum stressSolverTimeDelay of all actors in the structure.
F32 | structureSettings.stressSolverMassThreshold
'structureSettings.stressSolverMassThreshold' : The structure containing this actor will use the minimum stressSolverMassThreshold of all actors in the structure.
String | defaultBehaviorGroup.name
'defaultBehaviorGroup.name' : Name of behavior group
F32 | defaultBehaviorGroup.damageThreshold
'defaultBehaviorGroup.damageThreshold' : The damage amount which will cause a chunk to fracture (break free) from the destructible.
F32 | defaultBehaviorGroup.damageToRadius
'defaultBehaviorGroup.damageToRadius' : Controls the distance into the destructible to propagate damage.
F32 | defaultBehaviorGroup.damageSpread.minimumRadius
'defaultBehaviorGroup.damageSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.
F32 | defaultBehaviorGroup.damageSpread.radiusMultiplier
'defaultBehaviorGroup.damageSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.
F32 | defaultBehaviorGroup.damageSpread.falloffExponent
'defaultBehaviorGroup.damageSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.
F32 | defaultBehaviorGroup.damageColorSpread.minimumRadius
'defaultBehaviorGroup.damageColorSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.
F32 | defaultBehaviorGroup.damageColorSpread.radiusMultiplier
'defaultBehaviorGroup.damageColorSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.
F32 | defaultBehaviorGroup.damageColorSpread.falloffExponent
'defaultBehaviorGroup.damageColorSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.
Vec4 | defaultBehaviorGroup.damageColorChange
'defaultBehaviorGroup.damageColorChange' : Describes how damage changes the color of vertices in the render mesh.
F32 | defaultBehaviorGroup.materialStrength
'defaultBehaviorGroup.materialStrength' : When a chunk takes impact, this is the maximum impulse the contact can generate.
F32 | defaultBehaviorGroup.density
'defaultBehaviorGroup.density' : Chunk density
F32 | defaultBehaviorGroup.fadeOut
'defaultBehaviorGroup.fadeOut' : Chunk fade out
F32 | defaultBehaviorGroup.maxDepenetrationVelocity
'defaultBehaviorGroup.maxDepenetrationVelocity' : Chunk maximum depenetration velocity
Bool | defaultBehaviorGroup.groupsMask.useGroupsMask
'defaultBehaviorGroup.groupsMask.useGroupsMask' : Whether or not the groupsMask should be used
U32 | defaultBehaviorGroup.groupsMask.bits0
'defaultBehaviorGroup.groupsMask.bits0' : bits0 of the groups mask
U32 | defaultBehaviorGroup.groupsMask.bits1
'defaultBehaviorGroup.groupsMask.bits1' : bits1 of the groups mask
U32 | defaultBehaviorGroup.groupsMask.bits2
'defaultBehaviorGroup.groupsMask.bits2' : bits2 of the groups mask
U32 | defaultBehaviorGroup.groupsMask.bits3
'defaultBehaviorGroup.groupsMask.bits3' : bits3 of the groups mask
U64 | defaultBehaviorGroup.userData
'defaultBehaviorGroup.userData' : User data field.
String | behaviorGroups[].name
'behaviorGroups[].name' : Name of behavior group
F32 | behaviorGroups[].damageThreshold
'behaviorGroups[].damageThreshold' : The damage amount which will cause a chunk to fracture (break free) from the destructible.
F32 | behaviorGroups[].damageToRadius
'behaviorGroups[].damageToRadius' : Controls the distance into the destructible to propagate damage.
F32 | behaviorGroups[].damageSpread.minimumRadius
'behaviorGroups[].damageSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.
F32 | behaviorGroups[].damageSpread.radiusMultiplier
'behaviorGroups[].damageSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.
F32 | behaviorGroups[].damageSpread.falloffExponent
'behaviorGroups[].damageSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.
F32 | behaviorGroups[].damageColorSpread.minimumRadius
'behaviorGroups[].damageColorSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.
F32 | behaviorGroups[].damageColorSpread.radiusMultiplier
'behaviorGroups[].damageColorSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.
F32 | behaviorGroups[].damageColorSpread.falloffExponent
'behaviorGroups[].damageColorSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.
Vec4 | behaviorGroups[].damageColorChange
'behaviorGroups[].damageColorChange' : Describes how damage changes the color of vertices in the render mesh.
F32 | behaviorGroups[].materialStrength
'behaviorGroups[].materialStrength' : When a chunk takes impact, this is the maximum impulse the contact can generate.
F32 | behaviorGroups[].density
'behaviorGroups[].density' : Chunk density
F32 | behaviorGroups[].fadeOut
'behaviorGroups[].fadeOut' : Chunk fade out
F32 | behaviorGroups[].maxDepenetrationVelocity
'behaviorGroups[].maxDepenetrationVelocity' : Chunk maximum depenetration velocity
Bool | behaviorGroups[].groupsMask.useGroupsMask
'behaviorGroups[].groupsMask.useGroupsMask' : Whether or not the groupsMask should be used
U32 | behaviorGroups[].groupsMask.bits0
'behaviorGroups[].groupsMask.bits0' : bits0 of the groups mask
U32 | behaviorGroups[].groupsMask.bits1
'behaviorGroups[].groupsMask.bits1' : bits1 of the groups mask
U32 | behaviorGroups[].groupsMask.bits2
'behaviorGroups[].groupsMask.bits2' : bits2 of the groups mask
U32 | behaviorGroups[].groupsMask.bits3
'behaviorGroups[].groupsMask.bits3' : bits3 of the groups mask
U64 | behaviorGroups[].userData
'behaviorGroups[].userData' : User data field.
Bool | deleteChunksLeavingUserDefinedBB
'deleteChunksLeavingUserDefinedBB' : Whether or not the destructible chunks are going to be deleted upon leaving any user-defined bounding box.
Bool | deleteChunksEnteringUserDefinedBB
'deleteChunksEnteringUserDefinedBB' : Whether or not the destructible chunks are going to be deleted upon entering any user-defined bounding box.

Detailed Description

Describes the NxParameterized::Interface for 'DestructibleActorParam' :

DestructibleActorParam contains 258 fully qualified names
---------------------------------------------
  1 : String               crumbleEmitterName
  2 : F32                  crumbleParticleSpacing
  3 : String               dustEmitterName
  4 : F32                  dustParticleSpacing
  5 : Mat34                globalPose
  6 : Vec3                 scale
  7 : Bool                 dynamic
  8 : U32                  supportDepth
  9 : Bool                 formExtendedStructures
 10 : Bool                 performDetailedOverlapTestForExtendedStructures
 11 : Bool                 keepPreviousFrameBoneBuffer
 12 : Bool                 doNotCreateRenderable
 13 : Bool                 useAssetDefinedSupport
 14 : Bool                 useWorldSupport
 15 : Bool                 renderStaticChunksSeparately
 16 : Bool                 keepVisibleBonesPacked
 17 : Bool                 createChunkEvents
 18 : ArraySizeName        overrideSkinnedMaterialNames
 19 : String               overrideSkinnedMaterialNames[]
 20 : ArraySizeName        overrideStaticMaterialNames
 21 : String               overrideStaticMaterialNames[]
 22 : F32                  sleepVelocityFrameDecayConstant
 23 : Bool                 useHardSleeping
 24 : F32                  destructibleParameters.damageCap
 25 : F32                  destructibleParameters.forceToDamage
 26 : F32                  destructibleParameters.impactVelocityThreshold
 27 : U32                  destructibleParameters.minimumFractureDepth
 28 : I32                  destructibleParameters.impactDamageDefaultDepth
 29 : I32                  destructibleParameters.debrisDepth
 30 : U32                  destructibleParameters.essentialDepth
 31 : F32                  destructibleParameters.debrisLifetimeMin
 32 : F32                  destructibleParameters.debrisLifetimeMax
 33 : F32                  destructibleParameters.debrisMaxSeparationMin
 34 : F32                  destructibleParameters.debrisMaxSeparationMax
 35 : F32                  destructibleParameters.debrisDestructionProbability
 36 : Bounds3              destructibleParameters.validBounds
 37 : F32                  destructibleParameters.maxChunkSpeed
 38 : Bool                 destructibleParameters.flags.ACCUMULATE_DAMAGE
 39 : Bool                 destructibleParameters.flags.DEBRIS_TIMEOUT
 40 : Bool                 destructibleParameters.flags.DEBRIS_MAX_SEPARATION
 41 : Bool                 destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS
 42 : Bool                 destructibleParameters.flags.ACCURATE_RAYCASTS
 43 : Bool                 destructibleParameters.flags.USE_VALID_BOUNDS
 44 : Bool                 destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE
 45 : F32                  destructibleParameters.fractureImpulseScale
 46 : U16                  destructibleParameters.damageDepthLimit
 47 : U16                  destructibleParameters.dynamicChunkDominanceGroup
 48 : Bool                 destructibleParameters.dynamicChunksGroupsMask.useGroupsMask
 49 : U32                  destructibleParameters.dynamicChunksGroupsMask.bits0
 50 : U32                  destructibleParameters.dynamicChunksGroupsMask.bits1
 51 : U32                  destructibleParameters.dynamicChunksGroupsMask.bits2
 52 : U32                  destructibleParameters.dynamicChunksGroupsMask.bits3
 53 : RuntimeFractureType  destructibleParameters.runtimeFracture.RuntimeFractureType
 54 : Bool                 destructibleParameters.runtimeFracture.sheetFracture
 55 : U32                  destructibleParameters.runtimeFracture.depthLimit
 56 : Bool                 destructibleParameters.runtimeFracture.destroyIfAtDepthLimit
 57 : F32                  destructibleParameters.runtimeFracture.minConvexSize
 58 : F32                  destructibleParameters.runtimeFracture.impulseScale
 59 : U32                  destructibleParameters.runtimeFracture.glass.numSectors
 60 : F32                  destructibleParameters.runtimeFracture.glass.sectorRand
 61 : F32                  destructibleParameters.runtimeFracture.glass.firstSegmentSize
 62 : F32                  destructibleParameters.runtimeFracture.glass.segmentScale
 63 : F32                  destructibleParameters.runtimeFracture.glass.segmentRand
 64 : Vec3                 destructibleParameters.runtimeFracture.voronoi.dimensions
 65 : U32                  destructibleParameters.runtimeFracture.voronoi.numCells
 66 : F32                  destructibleParameters.runtimeFracture.voronoi.biasExp
 67 : F32                  destructibleParameters.runtimeFracture.voronoi.maxDist
 68 : Bool                 destructibleParameters.runtimeFracture.attachment.posX
 69 : Bool                 destructibleParameters.runtimeFracture.attachment.negX
 70 : Bool                 destructibleParameters.runtimeFracture.attachment.posY
 71 : Bool                 destructibleParameters.runtimeFracture.attachment.negY
 72 : Bool                 destructibleParameters.runtimeFracture.attachment.posZ
 73 : Bool                 destructibleParameters.runtimeFracture.attachment.negZ
 74 : F32                  destructibleParameters.supportStrength
 75 : I8                   destructibleParameters.legacyChunkBoundsTestSetting
 76 : I8                   destructibleParameters.legacyDamageRadiusSpreadSetting
 77 : ArraySizeName        depthParameters
 78 : Bool                 depthParameters[].OVERRIDE_IMPACT_DAMAGE
 79 : Bool                 depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE
 80 : Bool                 depthParameters[].IGNORE_POSE_UPDATES
 81 : Bool                 depthParameters[].IGNORE_RAYCAST_CALLBACKS
 82 : Bool                 depthParameters[].IGNORE_CONTACT_CALLBACKS
 83 : Bool                 depthParameters[].USER_FLAG_0
 84 : Bool                 depthParameters[].USER_FLAG_1
 85 : Bool                 depthParameters[].USER_FLAG_2
 86 : Bool                 depthParameters[].USER_FLAG_3
 87 : Bool                 shapeDescTemplate.flags.NX_TRIGGER_ON_ENTER
 88 : Bool                 shapeDescTemplate.flags.NX_TRIGGER_ON_LEAVE
 89 : Bool                 shapeDescTemplate.flags.NX_TRIGGER_ON_STAY
 90 : Bool                 shapeDescTemplate.flags.NX_SF_VISUALIZATION
 91 : Bool                 shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION
 92 : Bool                 shapeDescTemplate.flags.NX_SF_FEATURE_INDICES
 93 : Bool                 shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING
 94 : Bool                 shapeDescTemplate.flags.NX_SF_POINT_CONTACT_FORCE
 95 : Bool                 shapeDescTemplate.flags.NX_SF_FLUID_DRAIN
 96 : Bool                 shapeDescTemplate.flags.NX_SF_FLUID_DISABLE_COLLISION
 97 : Bool                 shapeDescTemplate.flags.NX_SF_FLUID_TWOWAY
 98 : Bool                 shapeDescTemplate.flags.NX_SF_DISABLE_RESPONSE
 99 : Bool                 shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD
100 : Bool                 shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES
101 : Bool                 shapeDescTemplate.flags.NX_SF_CLOTH_DRAIN
102 : Bool                 shapeDescTemplate.flags.NX_SF_CLOTH_DISABLE_COLLISION
103 : Bool                 shapeDescTemplate.flags.NX_SF_CLOTH_TWOWAY
104 : Bool                 shapeDescTemplate.flags.NX_SF_SOFTBODY_DRAIN
105 : Bool                 shapeDescTemplate.flags.NX_SF_SOFTBODY_DISABLE_COLLISION
106 : Bool                 shapeDescTemplate.flags.NX_SF_SOFTBODY_TWOWAY
107 : U16                  shapeDescTemplate.collisionGroup
108 : Bool                 shapeDescTemplate.groupsMask.useGroupsMask
109 : U32                  shapeDescTemplate.groupsMask.bits0
110 : U32                  shapeDescTemplate.groupsMask.bits1
111 : U32                  shapeDescTemplate.groupsMask.bits2
112 : U32                  shapeDescTemplate.groupsMask.bits3
113 : U16                  shapeDescTemplate.materialIndex
114 : F32                  shapeDescTemplate.density
115 : F32                  shapeDescTemplate.skinWidth
116 : U64                  shapeDescTemplate.userData
117 : U64                  shapeDescTemplate.name
118 : Bool                 actorDescTemplate.flags.NX_AF_DISABLE_COLLISION
119 : Bool                 actorDescTemplate.flags.NX_AF_DISABLE_RESPONSE
120 : Bool                 actorDescTemplate.flags.NX_AF_LOCK_COM
121 : Bool                 actorDescTemplate.flags.NX_AF_FLUID_DISABLE_COLLISION
122 : Bool                 actorDescTemplate.flags.NX_AF_CONTACT_MODIFICATION
123 : Bool                 actorDescTemplate.flags.NX_AF_FORCE_CONE_FRICTION
124 : Bool                 actorDescTemplate.flags.NX_AF_USER_ACTOR_PAIR_FILTERING
125 : F32                  actorDescTemplate.density
126 : U16                  actorDescTemplate.actorCollisionGroup
127 : U16                  actorDescTemplate.dominanceGroup
128 : Bool                 actorDescTemplate.contactReportFlags.NX_IGNORE_PAIR
129 : Bool                 actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH
130 : Bool                 actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH
131 : Bool                 actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH
132 : Bool                 actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_IMPACT
133 : Bool                 actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_ROLL
134 : Bool                 actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_SLIDE
135 : Bool                 actorDescTemplate.contactReportFlags.NX_NOTIFY_FORCES
136 : Bool                 actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH_FORCE_THRESHOLD
137 : Bool                 actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH_FORCE_THRESHOLD
138 : Bool                 actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH_FORCE_THRESHOLD
139 : Bool                 actorDescTemplate.contactReportFlags.NX_NOTIFY_CONTACT_MODIFICATION
140 : U16                  actorDescTemplate.forceFieldMaterial
141 : U64                  actorDescTemplate.userData
142 : U64                  actorDescTemplate.name
143 : U64                  actorDescTemplate.compartment
144 : Bool                 bodyDescTemplate.flags.NX_BF_DISABLE_GRAVITY
145 : Bool                 bodyDescTemplate.flags.NX_BF_FILTER_SLEEP_VEL
146 : Bool                 bodyDescTemplate.flags.NX_BF_ENERGY_SLEEP_TEST
147 : Bool                 bodyDescTemplate.flags.NX_BF_VISUALIZATION
148 : F32                  bodyDescTemplate.wakeUpCounter
149 : F32                  bodyDescTemplate.linearDamping
150 : F32                  bodyDescTemplate.angularDamping
151 : F32                  bodyDescTemplate.maxAngularVelocity
152 : F32                  bodyDescTemplate.CCDMotionThreshold
153 : F32                  bodyDescTemplate.sleepLinearVelocity
154 : F32                  bodyDescTemplate.sleepAngularVelocity
155 : U32                  bodyDescTemplate.solverIterationCount
156 : F32                  bodyDescTemplate.sleepEnergyThreshold
157 : F32                  bodyDescTemplate.sleepDamping
158 : F32                  bodyDescTemplate.contactReportThreshold
159 : Bool                 p3ShapeDescTemplate.flags.eSIMULATION_SHAPE
160 : Bool                 p3ShapeDescTemplate.flags.eSCENE_QUERY_SHAPE
161 : Bool                 p3ShapeDescTemplate.flags.eTRIGGER_SHAPE
162 : Bool                 p3ShapeDescTemplate.flags.eVISUALIZATION
163 : Bool                 p3ShapeDescTemplate.flags.ePARTICLE_DRAIN
164 : Bool                 p3ShapeDescTemplate.flags.eDEFORMABLE_DRAIN
165 : U32                  p3ShapeDescTemplate.simulationFilterData.word0
166 : U32                  p3ShapeDescTemplate.simulationFilterData.word1
167 : U32                  p3ShapeDescTemplate.simulationFilterData.word2
168 : U32                  p3ShapeDescTemplate.simulationFilterData.word3
169 : U32                  p3ShapeDescTemplate.queryFilterData.word0
170 : U32                  p3ShapeDescTemplate.queryFilterData.word1
171 : U32                  p3ShapeDescTemplate.queryFilterData.word2
172 : U32                  p3ShapeDescTemplate.queryFilterData.word3
173 : U64                  p3ShapeDescTemplate.material
174 : F32                  p3ShapeDescTemplate.contactOffset
175 : F32                  p3ShapeDescTemplate.restOffset
176 : U64                  p3ShapeDescTemplate.userData
177 : U64                  p3ShapeDescTemplate.name
178 : Bool                 p3ActorDescTemplate.flags.eVISUALIZATION
179 : Bool                 p3ActorDescTemplate.flags.eDISABLE_GRAVITY
180 : Bool                 p3ActorDescTemplate.flags.eSEND_SLEEP_NOTIFIES
181 : U8                   p3ActorDescTemplate.dominanceGroup
182 : U8                   p3ActorDescTemplate.ownerClient
183 : U32                  p3ActorDescTemplate.clientBehaviorBits
184 : Bool                 p3ActorDescTemplate.contactReportFlags.eRESOLVE_CONTACTS
185 : Bool                 p3ActorDescTemplate.contactReportFlags.eMODIFY_CONTACTS
186 : Bool                 p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_FOUND
187 : Bool                 p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_PERSISTS
188 : Bool                 p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_LOST
189 : Bool                 p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_FOUND
190 : Bool                 p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_PERSISTS
191 : Bool                 p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_LOST
192 : Bool                 p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_POINTS
193 : Bool                 p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCES
194 : Bool                 p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCE_PER_POINT
195 : Bool                 p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FEATURE_INDICES_PER_POINT
196 : Bool                 p3ActorDescTemplate.contactReportFlags.eCCD_LINEAR
197 : Bool                 p3ActorDescTemplate.contactReportFlags.eCONTACT_DEFAULT
198 : Bool                 p3ActorDescTemplate.contactReportFlags.eTRIGGER_DEFAULT
199 : U64                  p3ActorDescTemplate.userData
200 : U64                  p3ActorDescTemplate.name
201 : F32                  p3BodyDescTemplate.density
202 : Bool                 p3BodyDescTemplate.flags.eKINEMATIC
203 : Bool                 p3BodyDescTemplate.flags.eENABLE_CCD
204 : F32                  p3BodyDescTemplate.sleepThreshold
205 : F32                  p3BodyDescTemplate.wakeUpCounter
206 : F32                  p3BodyDescTemplate.linearDamping
207 : F32                  p3BodyDescTemplate.angularDamping
208 : F32                  p3BodyDescTemplate.maxAngularVelocity
209 : U32                  p3BodyDescTemplate.solverIterationCount
210 : U32                  p3BodyDescTemplate.velocityIterationCount
211 : F32                  p3BodyDescTemplate.contactReportThreshold
212 : F32                  p3BodyDescTemplate.sleepLinearVelocity
213 : Bool                 structureSettings.useStressSolver
214 : F32                  structureSettings.stressSolverTimeDelay
215 : F32                  structureSettings.stressSolverMassThreshold
216 : String               defaultBehaviorGroup.name
217 : F32                  defaultBehaviorGroup.damageThreshold
218 : F32                  defaultBehaviorGroup.damageToRadius
219 : F32                  defaultBehaviorGroup.damageSpread.minimumRadius
220 : F32                  defaultBehaviorGroup.damageSpread.radiusMultiplier
221 : F32                  defaultBehaviorGroup.damageSpread.falloffExponent
222 : F32                  defaultBehaviorGroup.damageColorSpread.minimumRadius
223 : F32                  defaultBehaviorGroup.damageColorSpread.radiusMultiplier
224 : F32                  defaultBehaviorGroup.damageColorSpread.falloffExponent
225 : Vec4                 defaultBehaviorGroup.damageColorChange
226 : F32                  defaultBehaviorGroup.materialStrength
227 : F32                  defaultBehaviorGroup.density
228 : F32                  defaultBehaviorGroup.fadeOut
229 : F32                  defaultBehaviorGroup.maxDepenetrationVelocity
230 : Bool                 defaultBehaviorGroup.groupsMask.useGroupsMask
231 : U32                  defaultBehaviorGroup.groupsMask.bits0
232 : U32                  defaultBehaviorGroup.groupsMask.bits1
233 : U32                  defaultBehaviorGroup.groupsMask.bits2
234 : U32                  defaultBehaviorGroup.groupsMask.bits3
235 : U64                  defaultBehaviorGroup.userData
236 : ArraySizeName        behaviorGroups
237 : String               behaviorGroups[].name
238 : F32                  behaviorGroups[].damageThreshold
239 : F32                  behaviorGroups[].damageToRadius
240 : F32                  behaviorGroups[].damageSpread.minimumRadius
241 : F32                  behaviorGroups[].damageSpread.radiusMultiplier
242 : F32                  behaviorGroups[].damageSpread.falloffExponent
243 : F32                  behaviorGroups[].damageColorSpread.minimumRadius
244 : F32                  behaviorGroups[].damageColorSpread.radiusMultiplier
245 : F32                  behaviorGroups[].damageColorSpread.falloffExponent
246 : Vec4                 behaviorGroups[].damageColorChange
247 : F32                  behaviorGroups[].materialStrength
248 : F32                  behaviorGroups[].density
249 : F32                  behaviorGroups[].fadeOut
250 : F32                  behaviorGroups[].maxDepenetrationVelocity
251 : Bool                 behaviorGroups[].groupsMask.useGroupsMask
252 : U32                  behaviorGroups[].groupsMask.bits0
253 : U32                  behaviorGroups[].groupsMask.bits1
254 : U32                  behaviorGroups[].groupsMask.bits2
255 : U32                  behaviorGroups[].groupsMask.bits3
256 : U64                  behaviorGroups[].userData
257 : Bool                 deleteChunksLeavingUserDefinedBB
258 : Bool                 deleteChunksEnteringUserDefinedBB

Member Data Documentation

U16 DestructibleActorParam::actorDescTemplate.actorCollisionGroup

'actorDescTemplate.actorCollisionGroup' : Sets which NxActorGroup an actor is part of

Sets which NxActorGroup an actor is part of. This will be applied to all NxActors generated for this destructible's chunks.

U64 DestructibleActorParam::actorDescTemplate.compartment

'actorDescTemplate.compartment' : Optional compartment pointer

Optional compartment pointer; must be set by the application. This will be applied to all NxActors generated for this destructible's chunks.

Bool DestructibleActorParam::actorDescTemplate.contactReportFlags.NX_IGNORE_PAIR

'actorDescTemplate.contactReportFlags.NX_IGNORE_PAIR' : Disable contact generation for this pair

Disable contact generation for this pair. See the PhysX documentation for more about contact reporting.

Bool DestructibleActorParam::actorDescTemplate.contactReportFlags.NX_NOTIFY_CONTACT_MODIFICATION

'actorDescTemplate.contactReportFlags.NX_NOTIFY_CONTACT_MODIFICATION' : Generate a callback for all associated contact constraints, making it possible to edit the constraint. This flag is not included in NX_NOTIFY_ALL for performance reasons. see NxUserContactModify.

Generate a callback for all associated contact constraints, making it possible to edit the constraint. This flag is not included in NX_NOTIFY_ALL for performance reasons. see NxUserContactModify. See the PhysX documentation for more about contact reporting.

Bool DestructibleActorParam::actorDescTemplate.contactReportFlags.NX_NOTIFY_FORCES

'actorDescTemplate.contactReportFlags.NX_NOTIFY_FORCES' : The (summed total) friction force and normal force will be given in the NxContactPair variable in the contact report.

The (summed total) friction force and normal force will be given in the NxContactPair variable in the contact report. See the PhysX documentation for more about contact reporting.

Bool DestructibleActorParam::actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH

'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH' : Pair callback will be called when the pair stops to be in contact

Pair callback will be called when the pair stops to be in contact. See the PhysX documentation for more about contact reporting.

Bool DestructibleActorParam::actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH_FORCE_THRESHOLD

'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH_FORCE_THRESHOLD' : Pair callback will be called when the contact force between two actors falls below the actor-defined force thresholds

Pair callback will be called when the contact force between two actors falls below the actor-defined force thresholds. See the PhysX documentation for more about contact reporting.

Bool DestructibleActorParam::actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_IMPACT

'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_IMPACT' : [Not yet implemented] pair callback will be called when it may be appropriate for the pair to play an impact sound

[Not yet implemented] pair callback will be called when it may be appropriate for the pair to play an impact sound. See the PhysX documentation for more about contact reporting.

Bool DestructibleActorParam::actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_ROLL

'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_ROLL' : [Not yet implemented] pair callback will be called when the pair is in contact and rolling.

[Not yet implemented] pair callback will be called when the pair is in contact and rolling. See the PhysX documentation for more about contact reporting.

Bool DestructibleActorParam::actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_SLIDE

'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_SLIDE' : [Not yet implemented] pair callback will be called when the pair is in contact and sliding (and not rolling).

[Not yet implemented] pair callback will be called when the pair is in contact and sliding (and not rolling). See the PhysX documentation for more about contact reporting.

Bool DestructibleActorParam::actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH

'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH' : Pair callback will be called when the pair starts to be in contact

Pair callback will be called when the pair starts to be in contact. See the PhysX documentation for more about contact reporting.

Bool DestructibleActorParam::actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH_FORCE_THRESHOLD

'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH_FORCE_THRESHOLD' : Pair callback will be called when the contact force between two actors falls below the actor-defined force thresholds

Pair callback will be called when the contact force between two actors falls below the actor-defined force thresholds. See the PhysX documentation for more about contact reporting.

Bool DestructibleActorParam::actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH

'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH' : Pair callback will keep getting called while the pair is in contact

Pair callback will keep getting called while the pair is in contact. See the PhysX documentation for more about contact reporting.

Bool DestructibleActorParam::actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH_FORCE_THRESHOLD

'actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH_FORCE_THRESHOLD' : Pair callback will keep getting called while the contact force between two actors exceeds one of the actor-defined force thresholds

Pair callback will keep getting called while the contact force between two actors exceeds one of the actor-defined force thresholds. See the PhysX documentation for more about contact reporting.

F32 DestructibleActorParam::actorDescTemplate.density

'actorDescTemplate.density' : Density to be applied to the whole actor.

Density to be applied to the whole actor. If the body descriptor contains a zero mass but the actor descriptor contains a non-zero density, we compute a new mass automatically from the density and a shapes. This will be applied to all NxActors generated for this destructible's chunks.

U16 DestructibleActorParam::actorDescTemplate.dominanceGroup

'actorDescTemplate.dominanceGroup' : Dominance group for an actor.

Dominance group for an actor. This will be applied to all NxActors generated for this destructible's chunks.

Bool DestructibleActorParam::actorDescTemplate.flags.NX_AF_CONTACT_MODIFICATION

'actorDescTemplate.flags.NX_AF_CONTACT_MODIFICATION' : Turn on contact modification callback for the actor.

Turn on contact modification callback for the actor. This flag will be applied to all NxActors generated for this destructible's chunks.

Bool DestructibleActorParam::actorDescTemplate.flags.NX_AF_DISABLE_COLLISION

'actorDescTemplate.flags.NX_AF_DISABLE_COLLISION' : Enable/disable collision detection

Enable/disable collision detection. This flag will be applied to all NxActors generated for this destructible's chunks.

Bool DestructibleActorParam::actorDescTemplate.flags.NX_AF_DISABLE_RESPONSE

'actorDescTemplate.flags.NX_AF_DISABLE_RESPONSE' : Enable/disable collision response (reports contacts but dont use them)

Enable/disable collision response (reports contacts but dont use them). This flag will be applied to all NxActors generated for this destructible's chunks.

Bool DestructibleActorParam::actorDescTemplate.flags.NX_AF_FLUID_DISABLE_COLLISION

'actorDescTemplate.flags.NX_AF_FLUID_DISABLE_COLLISION' : Disables COM update when computing inertial properties at creation time.

Disables COM update when computing inertial properties at creation time. This flag will be applied to all NxActors generated for this destructible's chunks.

Bool DestructibleActorParam::actorDescTemplate.flags.NX_AF_FORCE_CONE_FRICTION

'actorDescTemplate.flags.NX_AF_FORCE_CONE_FRICTION' : Force cone friction to be used for this actor.

Force cone friction to be used for this actor. This flag will be applied to all NxActors generated for this destructible's chunks.

Bool DestructibleActorParam::actorDescTemplate.flags.NX_AF_LOCK_COM

'actorDescTemplate.flags.NX_AF_LOCK_COM' : Disables COM update when computing inertial properties at creation time.

Disables COM update when computing inertial properties at creation time. This flag will be applied to all NxActors generated for this destructible's chunks.

Bool DestructibleActorParam::actorDescTemplate.flags.NX_AF_USER_ACTOR_PAIR_FILTERING

'actorDescTemplate.flags.NX_AF_USER_ACTOR_PAIR_FILTERING' : Enable/disable custom contact filtering.

Enable/disable custom contact filtering. This flag will be applied to all NxActors generated for this destructible's chunks.

U16 DestructibleActorParam::actorDescTemplate.forceFieldMaterial

'actorDescTemplate.forceFieldMaterial' : Force Field Material Index

Force Field Material Index, index != 0 has to be created. This will be applied to all NxActors generated for this destructible's chunks.

U64 DestructibleActorParam::actorDescTemplate.name

'actorDescTemplate.name' : Optional name string for a shape; must be set by the application and must be a persistent pointer.

Optional name string for a shape; must be set by the application and must be a persistent pointer. This will be applied to all NxActors generated for this destructible's chunks.

U64 DestructibleActorParam::actorDescTemplate.userData

'actorDescTemplate.userData' : Optional user data pointer

Optional user data pointer. This will be applied to all NxActors generated for this destructible's chunks.

Vec4 DestructibleActorParam::behaviorGroups[].damageColorChange

'behaviorGroups[].damageColorChange' : Describes how damage changes the color of vertices in the render mesh.

Describes how damage changes the color of vertices in the render mesh. If this vector is non-zero, then a dynamic (per-actor) color channel will be created and initialized to the asset's color channel, if it exists. Damage taken will go through the spread and envelope function described by damageColorSpread, and each color will be modified by the resulting damage, scaled by the values in damageColorChange. The change to color channel C is given by color[C] = clamp(color[C] + damageColorChange[C]*255*min(1.0, damage/damageThreshold), 0, 255).

F32 DestructibleActorParam::behaviorGroups[].damageColorSpread.falloffExponent

'behaviorGroups[].damageColorSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.

How damage varies between the minimum radius and the calculated damage radius. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier. Within the minimumRadius, the full damage is applied to chunks. Past the minimumRadius, the formla for damage is: damage = (input damage) * ((radius - distance)/(radius - minimumRadius))^falloffExponent. Note: falloffExponent = 0.0 gives no falloff, so that damage = (input damage) over the entire range [0, radius). falloffExponent = 1.0 gives linear falloff.

F32 DestructibleActorParam::behaviorGroups[].damageColorSpread.minimumRadius

'behaviorGroups[].damageColorSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.

The minimum radius of damage spread when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleActorParam::behaviorGroups[].damageColorSpread.radiusMultiplier

'behaviorGroups[].damageColorSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.

A scale to apply to the input damage radius when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleActorParam::behaviorGroups[].damageSpread.falloffExponent

'behaviorGroups[].damageSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.

How damage varies between the minimum radius and the calculated damage radius. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier. Within the minimumRadius, the full damage is applied to chunks. Past the minimumRadius, the formla for damage is: damage = (input damage) * ((radius - distance)/(radius - minimumRadius))^falloffExponent. Note: falloffExponent = 0.0 gives no falloff, so that damage = (input damage) over the entire range [0, radius). falloffExponent = 1.0 gives linear falloff.

F32 DestructibleActorParam::behaviorGroups[].damageSpread.minimumRadius

'behaviorGroups[].damageSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.

The minimum radius of damage spread when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleActorParam::behaviorGroups[].damageSpread.radiusMultiplier

'behaviorGroups[].damageSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.

A scale to apply to the input damage radius when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleActorParam::behaviorGroups[].damageThreshold

'behaviorGroups[].damageThreshold' : The damage amount which will cause a chunk to fracture (break free) from the destructible.

The damage amount which will cause a chunk to fracture (break free) from the destructible. This is obtained from the damage value passed into the NxDestructibleActor::applyDamage, or NxDestructibleActor::applyRadiusDamage, or via impact (see 'forceToDamage', below).

F32 DestructibleActorParam::behaviorGroups[].damageToRadius

'behaviorGroups[].damageToRadius' : Controls the distance into the destructible to propagate damage.

Controls the distance into the destructible to propagate damage. The damage applied to the chunk is multiplied by damageToRadius, to get the propagation distance. All chunks within the radius will have damage applied to them. The damage applied to each chunk varies with distance to the damage application position. Full damage is taken at zero distance, and zero damage at the damage radius. NOTE: This parameter is deprecated for point and radius damage. It will be used for those types of damage if legacy damage behavior is enabled with NxModuleDestructible::setUseLegacyDamageRadiusSpread. Otherwise, the new parameters damageSpread.minimumRadius, damageSpread.radiusMultiplier, and damageSpread.falloffExponent are used. For impact damage, this parameter will continue to be used, however the radius will no longer scale with object size. The radius will continue to scale with the damage as a fraction of damageThreshold, however. If legacy damage behavior is used, this parameter will behave as before with respect to impact damage as well (scaling with object size).

F32 DestructibleActorParam::behaviorGroups[].density

'behaviorGroups[].density' : Chunk density

Chunk density. (TODO: better description)

F32 DestructibleActorParam::behaviorGroups[].fadeOut

'behaviorGroups[].fadeOut' : Chunk fade out

Chunk fade out. (TODO: better description)

U32 DestructibleActorParam::behaviorGroups[].groupsMask.bits0

'behaviorGroups[].groupsMask.bits0' : bits0 of the groups mask

If useGroupsMask is true, this is bits0 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorParam::behaviorGroups[].groupsMask.bits1

'behaviorGroups[].groupsMask.bits1' : bits1 of the groups mask

If useGroupsMask is true, this is bits1 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorParam::behaviorGroups[].groupsMask.bits2

'behaviorGroups[].groupsMask.bits2' : bits2 of the groups mask

If useGroupsMask is true, this is bits2 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorParam::behaviorGroups[].groupsMask.bits3

'behaviorGroups[].groupsMask.bits3' : bits3 of the groups mask

If useGroupsMask is true, this is bits3 of the groups mask. See the PhysX documentation for more on groups masks.

Bool DestructibleActorParam::behaviorGroups[].groupsMask.useGroupsMask

'behaviorGroups[].groupsMask.useGroupsMask' : Whether or not the groupsMask should be used

Whether or not the groupsMask should be used. If so, then this will be applied to all NxShapes created to represent this destructible's chunks.

F32 DestructibleActorParam::behaviorGroups[].materialStrength

'behaviorGroups[].materialStrength' : When a chunk takes impact, this is the maximum impulse the contact can generate.

When a chunk takes impact damage due to physical contact (see see NxDestructibleDepthParameters), this parameter is the maximum impulse the contact can generate. Weak materials such as glass may have this set to a low value, so that heavier objects will pass through them during fracture. N.B.: Setting this parameter to 0 disables the impulse cap; that is, zero is interpreted as infinite. Default value = 0.0f.

F32 DestructibleActorParam::behaviorGroups[].maxDepenetrationVelocity

'behaviorGroups[].maxDepenetrationVelocity' : Chunk maximum depenetration velocity

In case some chunk is created inside static geometry it will be pushed out of it without limiting it's velocity. Sometimes it's not desirable, so this parameter can limit depenetration velocity. Keep in mind, that for low values you can see chunks 'floating' off the static meshes, which is also not always desirable.

String DestructibleActorParam::behaviorGroups[].name

'behaviorGroups[].name' : Name of behavior group

Name of behavior group, eg Concrete or Glass.

U64 DestructibleActorParam::behaviorGroups[].userData

'behaviorGroups[].userData' : User data field.

User data field. This 64-bit field can be set and retrieved by the user at runtime.

F32 DestructibleActorParam::bodyDescTemplate.angularDamping

'bodyDescTemplate.angularDamping' : Angular damping applied to the body

Angular damping applied to the body. This will be applied to all NxActors generated for this destructible's chunks.

F32 DestructibleActorParam::bodyDescTemplate.CCDMotionThreshold

'bodyDescTemplate.CCDMotionThreshold' : Distance threshold for CCD

When CCD is globally enabled, it is still not performed if the motion distance of all points on the body is below this threshold. This will be applied to all NxActors generated for this destructible's chunks.

F32 DestructibleActorParam::bodyDescTemplate.contactReportThreshold

'bodyDescTemplate.contactReportThreshold' : The force threshold for contact reports

The force threshold for contact reports. This will be applied to all NxActors generated for this destructible's chunks.

Bool DestructibleActorParam::bodyDescTemplate.flags.NX_BF_DISABLE_GRAVITY

'bodyDescTemplate.flags.NX_BF_DISABLE_GRAVITY' : Set if gravity should not be applied on this body

Set if gravity should not be applied on this body. This will be applied to all NxActors generated for this destructible's chunks.

Bool DestructibleActorParam::bodyDescTemplate.flags.NX_BF_ENERGY_SLEEP_TEST

'bodyDescTemplate.flags.NX_BF_ENERGY_SLEEP_TEST' : Enables energy-based sleeping algorithm

Enables energy-based sleeping algorithm. This will be applied to all NxActors generated for this destructible's chunks.

Bool DestructibleActorParam::bodyDescTemplate.flags.NX_BF_FILTER_SLEEP_VEL

'bodyDescTemplate.flags.NX_BF_FILTER_SLEEP_VEL' : Filter velocities used keep body awake. The filter reduces rapid oscillations and transient spikes

Filter velocities used keep body awake. The filter reduces rapid oscillations and transient spikes. This will be applied to all NxActors generated for this destructible's chunks.

Bool DestructibleActorParam::bodyDescTemplate.flags.NX_BF_VISUALIZATION

'bodyDescTemplate.flags.NX_BF_VISUALIZATION' : Enables debug visualization for this body

Enables debug visualization for this body. This will be applied to all NxActors generated for this destructible's chunks.

F32 DestructibleActorParam::bodyDescTemplate.linearDamping

'bodyDescTemplate.linearDamping' : Linear damping applied to the body

Linear damping applied to the body. This will be applied to all NxActors generated for this destructible's chunks.

F32 DestructibleActorParam::bodyDescTemplate.maxAngularVelocity

'bodyDescTemplate.maxAngularVelocity' : Maximum allowed angular velocity

Maximum allowed angular velocity. This will be applied to all NxActors generated for this destructible's chunks.

F32 DestructibleActorParam::bodyDescTemplate.sleepAngularVelocity

'bodyDescTemplate.sleepAngularVelocity' : Maximum angular velocity at which body can go to sleep

Maximum angular velocity at which body can go to sleep. This will be applied to all NxActors generated for this destructible's chunks.

F32 DestructibleActorParam::bodyDescTemplate.sleepDamping

'bodyDescTemplate.sleepDamping' : Damping factor for bodies that are about to sleep

Damping factor for bodies that are about to sleep. This will be applied to all NxActors generated for this destructible's chunks.

F32 DestructibleActorParam::bodyDescTemplate.sleepEnergyThreshold

'bodyDescTemplate.sleepEnergyThreshold' : Threshold for the energy-based sleeping algorithm. Only used when the NX_BF_ENERGY_SLEEP_TEST flag is set

Threshold for the energy-based sleeping algorithm. Only used when the NX_BF_ENERGY_SLEEP_TEST flag is set. This will be applied to all NxActors generated for this destructible's chunks.

F32 DestructibleActorParam::bodyDescTemplate.sleepLinearVelocity

'bodyDescTemplate.sleepLinearVelocity' : Maximum linear velocity at which body can go to sleep

Maximum linear velocity at which body can go to sleep. This will be applied to all NxActors generated for this destructible's chunks.

U32 DestructibleActorParam::bodyDescTemplate.solverIterationCount

'bodyDescTemplate.solverIterationCount' : Number of solver iterations performed when processing joint/contacts connected to this body

Number of solver iterations performed when processing joint/contacts connected to this body. This will be applied to all NxActors generated for this destructible's chunks.

F32 DestructibleActorParam::bodyDescTemplate.wakeUpCounter

'bodyDescTemplate.wakeUpCounter' : The bodys initial wake up counter

The bodys initial wake up counter. This will be applied to all NxActors generated for this destructible's chunks.

Bool DestructibleActorParam::createChunkEvents

'createChunkEvents' : Whether or not to create an event buffer for chunks

Whether or not to create an event buffer for chunk. If true, the user has access to a chunk event buffer, which currently holds visibility state change events. The user must empty this buffer themselves after reading, otherwise it will continue to grow as new events are added. Default value = false.

String DestructibleActorParam::crumbleEmitterName

'crumbleEmitterName' : The name of the NxMeshParticleSystem to use for crumbling

The name of the NxMeshParticleSystem to use for crumbling. This overrides the crumble system defined in the NxDestructibleAsset if specified.

F32 DestructibleActorParam::crumbleParticleSpacing

'crumbleParticleSpacing' : How far apart to space the particles when crumbling

How far apart to space the particles when crumling. If set to zero or a negative value, then the spacing is taken to be the crumble emitter's particle radius, if the crumble emitter exists. This spacing will be used when placing particle positions in the crumble emitter and the crumble buffer callback. Note - if there is no crumble emitter but there is a crumble buffer callback, then this value must be positive in order to have a proper spacing for the callback. Otherwise, the callback will not be called. The default value is 0.

Vec4 DestructibleActorParam::defaultBehaviorGroup.damageColorChange

'defaultBehaviorGroup.damageColorChange' : Describes how damage changes the color of vertices in the render mesh.

Describes how damage changes the color of vertices in the render mesh. If this vector is non-zero, then a dynamic (per-actor) color channel will be created and initialized to the asset's color channel, if it exists. Damage taken will go through the spread and envelope function described by damageColorSpread, and each color will be modified by the resulting damage, scaled by the values in damageColorChange. The change to color channel C is given by color[C] = clamp(color[C] + damageColorChange[C]*255*min(1.0, damage/damageThreshold), 0, 255).

F32 DestructibleActorParam::defaultBehaviorGroup.damageColorSpread.falloffExponent

'defaultBehaviorGroup.damageColorSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.

How damage varies between the minimum radius and the calculated damage radius. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier. Within the minimumRadius, the full damage is applied to chunks. Past the minimumRadius, the formla for damage is: damage = (input damage) * ((radius - distance)/(radius - minimumRadius))^falloffExponent. Note: falloffExponent = 0.0 gives no falloff, so that damage = (input damage) over the entire range [0, radius). falloffExponent = 1.0 gives linear falloff.

F32 DestructibleActorParam::defaultBehaviorGroup.damageColorSpread.minimumRadius

'defaultBehaviorGroup.damageColorSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.

The minimum radius of damage spread when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleActorParam::defaultBehaviorGroup.damageColorSpread.radiusMultiplier

'defaultBehaviorGroup.damageColorSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.

A scale to apply to the input damage radius when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleActorParam::defaultBehaviorGroup.damageSpread.falloffExponent

'defaultBehaviorGroup.damageSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.

How damage varies between the minimum radius and the calculated damage radius. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier. Within the minimumRadius, the full damage is applied to chunks. Past the minimumRadius, the formla for damage is: damage = (input damage) * ((radius - distance)/(radius - minimumRadius))^falloffExponent. Note: falloffExponent = 0.0 gives no falloff, so that damage = (input damage) over the entire range [0, radius). falloffExponent = 1.0 gives linear falloff.

F32 DestructibleActorParam::defaultBehaviorGroup.damageSpread.minimumRadius

'defaultBehaviorGroup.damageSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.

The minimum radius of damage spread when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleActorParam::defaultBehaviorGroup.damageSpread.radiusMultiplier

'defaultBehaviorGroup.damageSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.

A scale to apply to the input damage radius when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleActorParam::defaultBehaviorGroup.damageThreshold

'defaultBehaviorGroup.damageThreshold' : The damage amount which will cause a chunk to fracture (break free) from the destructible.

The damage amount which will cause a chunk to fracture (break free) from the destructible. This is obtained from the damage value passed into the NxDestructibleActor::applyDamage, or NxDestructibleActor::applyRadiusDamage, or via impact (see 'forceToDamage', below).

F32 DestructibleActorParam::defaultBehaviorGroup.damageToRadius

'defaultBehaviorGroup.damageToRadius' : Controls the distance into the destructible to propagate damage.

Controls the distance into the destructible to propagate damage. The damage applied to the chunk is multiplied by damageToRadius, to get the propagation distance. All chunks within the radius will have damage applied to them. The damage applied to each chunk varies with distance to the damage application position. Full damage is taken at zero distance, and zero damage at the damage radius. NOTE: This parameter is deprecated for point and radius damage. It will be used for those types of damage if legacy damage behavior is enabled with NxModuleDestructible::setUseLegacyDamageRadiusSpread. Otherwise, the new parameters damageSpread.minimumRadius, damageSpread.radiusMultiplier, and damageSpread.falloffExponent are used. For impact damage, this parameter will continue to be used, however the radius will no longer scale with object size. The radius will continue to scale with the damage as a fraction of damageThreshold, however. If legacy damage behavior is used, this parameter will behave as before with respect to impact damage as well (scaling with object size).

F32 DestructibleActorParam::defaultBehaviorGroup.density

'defaultBehaviorGroup.density' : Chunk density

Chunk density. (TODO: better description)

F32 DestructibleActorParam::defaultBehaviorGroup.fadeOut

'defaultBehaviorGroup.fadeOut' : Chunk fade out

Chunk fade out. (TODO: better description)

U32 DestructibleActorParam::defaultBehaviorGroup.groupsMask.bits0

'defaultBehaviorGroup.groupsMask.bits0' : bits0 of the groups mask

If useGroupsMask is true, this is bits0 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorParam::defaultBehaviorGroup.groupsMask.bits1

'defaultBehaviorGroup.groupsMask.bits1' : bits1 of the groups mask

If useGroupsMask is true, this is bits1 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorParam::defaultBehaviorGroup.groupsMask.bits2

'defaultBehaviorGroup.groupsMask.bits2' : bits2 of the groups mask

If useGroupsMask is true, this is bits2 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorParam::defaultBehaviorGroup.groupsMask.bits3

'defaultBehaviorGroup.groupsMask.bits3' : bits3 of the groups mask

If useGroupsMask is true, this is bits3 of the groups mask. See the PhysX documentation for more on groups masks.

Bool DestructibleActorParam::defaultBehaviorGroup.groupsMask.useGroupsMask

'defaultBehaviorGroup.groupsMask.useGroupsMask' : Whether or not the groupsMask should be used

Whether or not the groupsMask should be used. If so, then this will be applied to all NxShapes created to represent this destructible's chunks.

F32 DestructibleActorParam::defaultBehaviorGroup.materialStrength

'defaultBehaviorGroup.materialStrength' : When a chunk takes impact, this is the maximum impulse the contact can generate.

When a chunk takes impact damage due to physical contact (see see NxDestructibleDepthParameters), this parameter is the maximum impulse the contact can generate. Weak materials such as glass may have this set to a low value, so that heavier objects will pass through them during fracture. N.B.: Setting this parameter to 0 disables the impulse cap; that is, zero is interpreted as infinite. Default value = 0.0f.

F32 DestructibleActorParam::defaultBehaviorGroup.maxDepenetrationVelocity

'defaultBehaviorGroup.maxDepenetrationVelocity' : Chunk maximum depenetration velocity

In case some chunk is created inside static geometry it will be pushed out of it without limiting it's velocity. Sometimes it's not desirable, so this parameter can limit depenetration velocity. Keep in mind, that for low values you can see chunks 'floating' off the static meshes, which is also not always desirable.

String DestructibleActorParam::defaultBehaviorGroup.name

'defaultBehaviorGroup.name' : Name of behavior group

Name of behavior group, eg Concrete or Glass.

U64 DestructibleActorParam::defaultBehaviorGroup.userData

'defaultBehaviorGroup.userData' : User data field.

User data field. This 64-bit field can be set and retrieved by the user at runtime.

Bool DestructibleActorParam::deleteChunksEnteringUserDefinedBB

'deleteChunksEnteringUserDefinedBB' : Whether or not the destructible chunks are going to be deleted upon entering any user-defined bounding box.

The user can specify arbitrary number of bounding boxes in the scene using NxApexScene::addBoundingBox interface along with the flag, which marks a bounding box as either UserBoundingBoxFlags::ENTER or UserBoundingBoxFlags::LEAVE. If user also specifies 'deleteChunksEnteringUserDefinedBB' flag to true, then chunks that are entering a bounding box marked as UserBoundingBoxFlags::ENTER are going to be deleted. User can specify more complex deletion volumes by combining 2 types of bounding boxes.

Bool DestructibleActorParam::deleteChunksLeavingUserDefinedBB

'deleteChunksLeavingUserDefinedBB' : Whether or not the destructible chunks are going to be deleted upon leaving any user-defined bounding box.

The user can specify arbitrary number of bounding boxes in the scene using NxApexScene::addBoundingBox interface along with the flag, which marks a bounding box as either UserBoundingBoxFlags::ENTER or UserBoundingBoxFlags::LEAVE. If user also specifies 'deleteChunksLeavingUserDefinedBB' flag to true, then chunks that are leaving a bounding box marked as UserBoundingBoxFlags::LEAVE are going to be deleted. User can specify more complex deletion volumes by combining 2 types of bounding boxes.

Bool DestructibleActorParam::depthParameters[].IGNORE_CONTACT_CALLBACKS

'depthParameters[].IGNORE_CONTACT_CALLBACKS' : Chunks at this depth should be ignored in contact callbacks.

Chunks at this depth should be ignored in contact callbacks.

Bool DestructibleActorParam::depthParameters[].IGNORE_POSE_UPDATES

'depthParameters[].IGNORE_POSE_UPDATES' : Chunks at this depth should have pose updates ignored.

Chunks at this depth should have pose updates ignored.

Bool DestructibleActorParam::depthParameters[].IGNORE_RAYCAST_CALLBACKS

'depthParameters[].IGNORE_RAYCAST_CALLBACKS' : Chunks at this depth should be ignored in raycast callbacks.

Chunks at this depth should be ignored in raycast callbacks.

Bool DestructibleActorParam::depthParameters[].OVERRIDE_IMPACT_DAMAGE

'depthParameters[].OVERRIDE_IMPACT_DAMAGE' : If true, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE_VALUE = TRUE, no matter the setting of impactDamageDefaultDepth.

Chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE_VALUE = TRUE, no matter the setting of impactDamageDefaultDepth.

Bool DestructibleActorParam::depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE

'depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE' : If OVERRIDE_IMPACT_DAMAGE = TRUE, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE_VALUE = TRUE.

If OVERRIDE_IMPACT_DAMAGE = TRUE, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE_VALUE = TRUE.

Bool DestructibleActorParam::depthParameters[].USER_FLAG_0

'depthParameters[].USER_FLAG_0' : User defined flag.

User defined flag.

Bool DestructibleActorParam::depthParameters[].USER_FLAG_1

'depthParameters[].USER_FLAG_1' : User defined flag.

User defined flag.

Bool DestructibleActorParam::depthParameters[].USER_FLAG_2

'depthParameters[].USER_FLAG_2' : User defined flag.

User defined flag.

Bool DestructibleActorParam::depthParameters[].USER_FLAG_3

'depthParameters[].USER_FLAG_3' : User defined flag.

User defined flag.

F32 DestructibleActorParam::destructibleParameters.damageCap

'destructibleParameters.damageCap' : Limits the amount of damage applied to a chunk.

Limits the amount of damage applied to a chunk. This is useful for preventing the entire destructible from getting pulverized by a very large application of damage. This can easily happen when impact damage is used, and the damage amount is proportional to the impact force (see forceToDamage).

U16 DestructibleActorParam::destructibleParameters.damageDepthLimit

'destructibleParameters.damageDepthLimit' : How deep in the hierarchy damage will be propagated, relative to the chunk hit.

How deep in the hierarchy damage will be propagated, relative to the chunk hit.

I32 DestructibleActorParam::destructibleParameters.debrisDepth

'destructibleParameters.debrisDepth' : The chunk hierarchy depth at which chunks are considered to be 'debris.'

The chunk hierarchy depth at which chunks are considered to be 'debris.' Chunks at this depth or below will be considered for various debris settings, such as debrisLifetime. Negative values indicate that no chunk depth is considered debris. Default value is -1.

F32 DestructibleActorParam::destructibleParameters.debrisDestructionProbability

'destructibleParameters.debrisDestructionProbability' : The probablity that a debris chunk, when fractured, will simply be destroyed

The probablity that a debris chunk, when fractured, will simply be destroyed instead of becoming dynamic or breaking down further into child chunks. Valid range = [0.0,1.0]. Default value = 0.0.

F32 DestructibleActorParam::destructibleParameters.debrisLifetimeMax

'destructibleParameters.debrisLifetimeMax' : Maximum time to destroy debris

'Debris chunks' (see debrisDepth, above) will be destroyed after a time (in seconds) separated from non-debris chunks. The actual lifetime is interpolated between debrisLifetimeMin (see above) and debrisLifetimeMax, based upon the module's LOD setting. To disable lifetime, clear the NxDestructibleDepthParametersFlag::DEBRIS_TIMEOUT flag in the flags field. If debrisLifetimeMax < debrisLifetimeMin, the mean of the two is used for both. Default debrisLifetimeMin = 1.0, debrisLifetimeMax = 10.0f.

F32 DestructibleActorParam::destructibleParameters.debrisLifetimeMin

'destructibleParameters.debrisLifetimeMin' : Minimum time to destroy debris

'Debris chunks' (see debrisDepth, above) will be destroyed after a time (in seconds) separated from non-debris chunks. The actual lifetime is interpolated between debrisLifetimeMin and debrisLifetimeMax (see below), based upon the module's LOD setting. To disable lifetime, clear the NxDestructibleDepthParametersFlag::DEBRIS_TIMEOUT flag in the flags field. If debrisLifetimeMax < debrisLifetimeMin, the mean of the two is used for both. Default debrisLifetimeMin = 1.0, debrisLifetimeMax = 10.0f.

F32 DestructibleActorParam::destructibleParameters.debrisMaxSeparationMax

'destructibleParameters.debrisMaxSeparationMax' : Minimum separation distance

'Debris chunks' (see debrisDepth, above) will be destroyed if they are separated from their origin by a distance greater than maxSeparation. The actual maxSeparation is interpolated between debrisMaxSeparationMin (see above) and debrisMaxSeparationMax, based upon the module's LOD setting. To disable maxSeparation, clear the NX_DESTRUCTIBLE_DEBRIS_MAX_SEPARATION flag in the flags field. If debrisMaxSeparationMax < debrisMaxSeparationMin, the mean of the two is used for both. Default debrisMaxSeparationMin = 1.0, debrisMaxSeparationMax = 10.0f.

F32 DestructibleActorParam::destructibleParameters.debrisMaxSeparationMin

'destructibleParameters.debrisMaxSeparationMin' : Minimum separation distance

'Debris chunks' (see debrisDepth, above) will be destroyed if they are separated from their origin by a distance greater than maxSeparation. The actual maxSeparation is interpolated between debrisMaxSeparationMin and debrisMaxSeparationMax (see below), based upon the module's LOD setting. To disable maxSeparation, clear the NX_DESTRUCTIBLE_DEBRIS_MAX_SEPARATION flag in the flags field. If debrisMaxSeparationMax < debrisMaxSeparationMin, the mean of the two is used for both. Default debrisMaxSeparationMin = 1.0, debrisMaxSeparationMax = 10.0f.

U16 DestructibleActorParam::destructibleParameters.dynamicChunkDominanceGroup

'destructibleParameters.dynamicChunkDominanceGroup' : Optional dominance group for dynamic chunks created when fractured.

Optional dominance group for dynamic chunks created when fractured. (ignored if > 31)

U32 DestructibleActorParam::destructibleParameters.dynamicChunksGroupsMask.bits0

'destructibleParameters.dynamicChunksGroupsMask.bits0' : bits0 of the groups mask

If useGroupsMask is true, this is bits0 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorParam::destructibleParameters.dynamicChunksGroupsMask.bits1

'destructibleParameters.dynamicChunksGroupsMask.bits1' : bits1 of the groups mask

If useGroupsMask is true, this is bits1 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorParam::destructibleParameters.dynamicChunksGroupsMask.bits2

'destructibleParameters.dynamicChunksGroupsMask.bits2' : bits2 of the groups mask

If useGroupsMask is true, this is bits2 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorParam::destructibleParameters.dynamicChunksGroupsMask.bits3

'destructibleParameters.dynamicChunksGroupsMask.bits3' : bits3 of the groups mask

If useGroupsMask is true, this is bits3 of the groups mask. See the PhysX documentation for more on groups masks.

Bool DestructibleActorParam::destructibleParameters.dynamicChunksGroupsMask.useGroupsMask

'destructibleParameters.dynamicChunksGroupsMask.useGroupsMask' : Whether or not the groupsMask should be used

Whether or not the groupsMask should be used. If so, then this will be applied to all NxShapes created to represent this destructible's chunks.

U32 DestructibleActorParam::destructibleParameters.essentialDepth

'destructibleParameters.essentialDepth' : The chunk hierarchy depth up to which chunks will always be processed

The chunk hierarchy depth up to which chunks will always be processed. These chunks are considered to be essential either for gameplay or visually. The minimum value is 0, meaning the level 0 chunk is always considered essential. Default value is 0.

Bool DestructibleActorParam::destructibleParameters.flags.ACCUMULATE_DAMAGE

'destructibleParameters.flags.ACCUMULATE_DAMAGE' : Determines if chunks accumulate damage

If set, chunks will 'remember' damage applied to them, so that many applications of a damage amount below damageThreshold will eventually fracture the chunk. If not set, a single application of damage must exceed damageThreshold in order to fracture the chunk.

Bool DestructibleActorParam::destructibleParameters.flags.ACCURATE_RAYCASTS

'destructibleParameters.flags.ACCURATE_RAYCASTS' : If set, the NxDestructibleActor::rayCast function will search within the nearest visible chunk hit

If set, the NxDestructibleActor::rayCast function will search within the nearest visible chunk hit for collisions with child chunks. This is used to get a better raycast position and normal, in case the parent collision volume does not tightly fit the graphics mesh. The returned chunk index will always be that of the visible parent that is intersected, however.

Bool DestructibleActorParam::destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS

'destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS' : If set, the smallest chunks may be further broken down

If set, the smallest chunks may be further broken down, either by fluid crumbles (if a crumble particle system is specified in the NxDestructibleActorDesc), or by simply removing the chunk if no crumble particle system is specified. Note: the 'smallest chunks' are normally defined to be the deepest level of the fracture hierarchy. However, they may be taken from higher levels of the hierarchy if NxModuleDestructible::setMaxChunkDepthOffset is called with a non-zero value.

Bool DestructibleActorParam::destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE

'destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE' : If set, crumbled chunks will use the runtime fracture pipeline.

If set, crumbled chunks will use the runtime fracture pipeline. The chunk will be procedurally broken destroyed using either the default or a specified fracture pattern.

Bool DestructibleActorParam::destructibleParameters.flags.DEBRIS_MAX_SEPARATION

'destructibleParameters.flags.DEBRIS_MAX_SEPARATION' : Whether or not chunks at or deeper than the 'debris' depth will be removed if separated too far

Whether or not chunks at or deeper than the 'debris' depth (see NxDestructibleParameters::debrisDepth) will be removed if they separate too far from their origins. The maxSeparation is a value between NxDestructibleParameters::debrisMaxSeparationMin and NxDestructibleParameters::debrisMaxSeparationMax, based upon the destructible module's LOD setting.

Bool DestructibleActorParam::destructibleParameters.flags.DEBRIS_TIMEOUT

'destructibleParameters.flags.DEBRIS_TIMEOUT' : Whether or not chunks at or deeper than the 'debris' depth will timeout

Whether or not chunks at or deeper than the 'debris' depth (see NxDestructibleParameters::debrisDepth) will time out. The lifetime is a value between NxDestructibleParameters::debrisLifetimeMin and NxDestructibleParameters::debrisLifetimeMax, based upon the destructible module's LOD setting.

Bool DestructibleActorParam::destructibleParameters.flags.USE_VALID_BOUNDS

'destructibleParameters.flags.USE_VALID_BOUNDS' : If set, the validBounds field of NxDestructibleParameters will be used.

If set, the validBounds field of NxDestructibleParameters will be used. These bounds are translated (but not scaled or rotated) to the origin of the destructible actor. If a chunk or chunk island moves outside of those bounds, it is destroyed.

F32 DestructibleActorParam::destructibleParameters.forceToDamage

'destructibleParameters.forceToDamage' : Multiplier to calculate applied damage from an impact.

If a chunk is at a depth which takes impact damage (see NxDestructibleDepthParameters), then when a chunk has a collision in the NxScene, it will take damage equal to forceToDamage mulitplied by the impact force. The default value is zero, which effectively disables impact damage.

F32 DestructibleActorParam::destructibleParameters.fractureImpulseScale

'destructibleParameters.fractureImpulseScale' : Scale factor used to apply an impulse force along the normal of chunk when fractured.

Scale factor used to apply an impulse force along the normal of chunk when fractured. This is used in order to 'push' the pieces out as they fracture.

I32 DestructibleActorParam::destructibleParameters.impactDamageDefaultDepth

'destructibleParameters.impactDamageDefaultDepth' : The default depth to which chunks will take impact damage.

The default depth to which chunks will take impact damage. This default may be overridden in the depth settings.

F32 DestructibleActorParam::destructibleParameters.impactVelocityThreshold

'destructibleParameters.impactVelocityThreshold' : Large impact force may be reported if rigid bodies are spawned inside one another.

Large impact force may be reported if rigid bodies are spawned inside one another. In this case the relative velocity of the two objects will be low. This variable allows the user to set a minimum velocity threshold for impacts to ensure that the objects are moving at a min velocity in order for the impact force to be considered.

I8 DestructibleActorParam::destructibleParameters.legacyChunkBoundsTestSetting

'destructibleParameters.legacyChunkBoundsTestSetting' : Whether or not to use the old chunk bounds testing for damage, or use the module setting.

Whether or not to use the old chunk bounds testing for damage, or use the module setting. A value of 0 forces the new method to be used. A positive value forces the old method to be used. Negative values cause the global (NxModuleDestructible) setting to be used.

I8 DestructibleActorParam::destructibleParameters.legacyDamageRadiusSpreadSetting

'destructibleParameters.legacyDamageRadiusSpreadSetting' : Whether or not to use the old damage spread method, or use the module setting.

Whether or not to use the old damage spread method, or use the module setting. A value of 0 forces the new method to be used. A positive value forces the old method to be used. Negative values cause the global (NxModuleDestructible) setting to be used.

F32 DestructibleActorParam::destructibleParameters.maxChunkSpeed

'destructibleParameters.maxChunkSpeed' : Maximum speed of a chunk

If greater than 0, the chunks' speeds will not be allowed to exceed this value. Use 0 to disable this feature (this is the default).

U32 DestructibleActorParam::destructibleParameters.minimumFractureDepth

'destructibleParameters.minimumFractureDepth' : The chunks will not be broken free below this depth.

Chunks will not be broken free below this depth.

Bool DestructibleActorParam::destructibleParameters.runtimeFracture.attachment.negX

'destructibleParameters.runtimeFracture.attachment.negX' : Attach to negative x side of sheet.

If true, make the negative x side of the sheet an attachment point.

Bool DestructibleActorParam::destructibleParameters.runtimeFracture.attachment.negY

'destructibleParameters.runtimeFracture.attachment.negY' : Attach to negative y side of sheet.

If true, make the negative y side of the sheet an attachment point.

Bool DestructibleActorParam::destructibleParameters.runtimeFracture.attachment.negZ

'destructibleParameters.runtimeFracture.attachment.negZ' : Attach to negative z side of sheet.

If true, make the negative z side of the sheet an attachment point.

Bool DestructibleActorParam::destructibleParameters.runtimeFracture.attachment.posX

'destructibleParameters.runtimeFracture.attachment.posX' : Attach to positive x side of sheet.

If true, make the positive x side of the sheet an attachment point.

Bool DestructibleActorParam::destructibleParameters.runtimeFracture.attachment.posY

'destructibleParameters.runtimeFracture.attachment.posY' : Attach to positive y side of sheet.

If true, make the positive y side of the sheet an attachment point.

Bool DestructibleActorParam::destructibleParameters.runtimeFracture.attachment.posZ

'destructibleParameters.runtimeFracture.attachment.posZ' : Attach to positive z side of sheet.

If true, make the positive z side of the sheet an attachment point.

U32 DestructibleActorParam::destructibleParameters.runtimeFracture.depthLimit

'destructibleParameters.runtimeFracture.depthLimit' : Number of times deep a chunk can be fractured.

Number of times deep a chunk can be fractured. Can help limit the number of chunks produced by runtime fracture.

Bool DestructibleActorParam::destructibleParameters.runtimeFracture.destroyIfAtDepthLimit

'destructibleParameters.runtimeFracture.destroyIfAtDepthLimit' : Destroy chunk if at depth limit

If true, destroy chunks when they hit their depth limit. If false, then chunks at their depth limit will not fracture but will have a force applied.

F32 DestructibleActorParam::destructibleParameters.runtimeFracture.glass.firstSegmentSize

'destructibleParameters.runtimeFracture.glass.firstSegmentSize' : The minimum shard size.

The minimum shard size. Shards below this size will not be created and thus not visible.

U32 DestructibleActorParam::destructibleParameters.runtimeFracture.glass.numSectors

'destructibleParameters.runtimeFracture.glass.numSectors' : Number of angular slices.

Number of angular slices in the glass fracture pattern.

F32 DestructibleActorParam::destructibleParameters.runtimeFracture.glass.sectorRand

'destructibleParameters.runtimeFracture.glass.sectorRand' : Creates variance in the angle of slices.

Creates variance in the angle of slices. A value of zero results in all angular slices having the same angle.

F32 DestructibleActorParam::destructibleParameters.runtimeFracture.glass.segmentRand

'destructibleParameters.runtimeFracture.glass.segmentRand' : Creates variance in the radial size of shards.

Creates variance in the radial size of shards. A value of zero results in a low noise circular pattern.

F32 DestructibleActorParam::destructibleParameters.runtimeFracture.glass.segmentScale

'destructibleParameters.runtimeFracture.glass.segmentScale' : Scales the radial spacing.

Scales the radial spacing in the glass fracture pattern. A larger value results in radially longer shards.

F32 DestructibleActorParam::destructibleParameters.runtimeFracture.impulseScale

'destructibleParameters.runtimeFracture.impulseScale' : Scales impulse applied by a fracture.

Scales impulse applied by a fracture.

F32 DestructibleActorParam::destructibleParameters.runtimeFracture.minConvexSize

'destructibleParameters.runtimeFracture.minConvexSize' : Minimum Convex Size.

Minimum Convex Size. Minimum size of convex produced by a fracture.

RuntimeFractureType DestructibleActorParam::destructibleParameters.runtimeFracture.RuntimeFractureType

'destructibleParameters.runtimeFracture.RuntimeFractureType' : Which type of fracture pattern to choose

Bool DestructibleActorParam::destructibleParameters.runtimeFracture.sheetFracture

'destructibleParameters.runtimeFracture.sheetFracture' : If true, align fracture pattern to largest face

If true, align fracture pattern to largest face. If false, the fracture pattern will be aligned to the hit normal with each fracture.

F32 DestructibleActorParam::destructibleParameters.runtimeFracture.voronoi.biasExp

'destructibleParameters.runtimeFracture.voronoi.biasExp' : Bias Exponential value.

Bias Exponential value is used in distributing voronoi points which is used to fracture the original chunk.

Vec3 DestructibleActorParam::destructibleParameters.runtimeFracture.voronoi.dimensions

'destructibleParameters.runtimeFracture.voronoi.dimensions' : The size of the entire block

The size of the entire block.

F32 DestructibleActorParam::destructibleParameters.runtimeFracture.voronoi.maxDist

'destructibleParameters.runtimeFracture.voronoi.maxDist' : The max distance a Voronoi point away from origin.

This is to prevent a illegal voronoi point that's used to generate voronoi chunks.

U32 DestructibleActorParam::destructibleParameters.runtimeFracture.voronoi.numCells

'destructibleParameters.runtimeFracture.voronoi.numCells' : Max Number of Cells to create.

Number of Cells corresponds to the number of chunks to create during the fracture, default value is only one chunk.

F32 DestructibleActorParam::destructibleParameters.supportStrength

'destructibleParameters.supportStrength' : The support strength threshold for breaking chunks in stressSolver

The larger the supportStrength is, the harder it will break under stressSolver. SupportStrength should be larger than 0.0 so that it is not extremely fragile. Default supportStrength = -1.0 which means strength is turned off initially.

Bounds3 DestructibleActorParam::destructibleParameters.validBounds

'destructibleParameters.validBounds' : valid bounding region for debris

A bounding box around each NxDestructibleActor created, defining a range of validity for chunks that break free. These bounds are scaled and translated with the NxDestructibleActor's scale and position, but they are not rotated with the NxDestructibleActor.

Bool DestructibleActorParam::doNotCreateRenderable

'doNotCreateRenderable' : If true, a renderable will not be created for the destructible actor

If true, a renderable will not be created for the destructible actor. This prevents unnecessary updates when the APEX render API is not being used.

String DestructibleActorParam::dustEmitterName

'dustEmitterName' : The name of the NxMeshParticleSystem to use for fracture-line dust

The name of the NxMeshParticleSystem to use for fracture-line dust. This overrides the dust system defined in the NxDestructibleAsset if specified.

F32 DestructibleActorParam::dustParticleSpacing

'dustParticleSpacing' : How far apart to space the particles when creating dust particles

How far apart to space the particles when crumling. If set to zero or a negative value, then the spacing is taken to be the dust emitter's particle radius, if the dust emitter exists. This spacing will be used when placing particle positions in the dust emitter and the dust particle buffer callback. Note - if there is no dust emitter but there is a dust particle buffer callback, then this value must be positive in order to have a proper spacing for the callback. Otherwise, the callback will not be called. The default value is 0.

Bool DestructibleActorParam::dynamic

'dynamic' : Whether or not the destructible starts life as a dynamic actor

Whether or not the destructible starts life as a dynamic actor

Bool DestructibleActorParam::formExtendedStructures

'formExtendedStructures' : If initially static, the destructible will become part of an extended support structure if it is in contact with another static destructible that also has this flag set.

If initially static, the destructible will become part of an extended support structure if it is in contact with another static destructible that also has this flag set.

Mat34 DestructibleActorParam::globalPose

'globalPose' : The initial pose where the destructible actor will be put into the scene

Initial global pose of undamaged destructible

Bool DestructibleActorParam::keepPreviousFrameBoneBuffer

'keepPreviousFrameBoneBuffer' : If true, the skinned mesh will hold a bone buffer for the last frame

If true, the skinned mesh will hold a bone buffer for the last frame. The poses in the new buffer correspond the poses in the current frame buffer, chunk was not visible in the last frame.

Bool DestructibleActorParam::keepVisibleBonesPacked

'keepVisibleBonesPacked' : Parameter passed into skinned ApexRenderMeshActor

Parameter passed into skinned ApexRenderMeshActor. If true, visible bone matrices are packed into the bone render buffer, and a per-actor vertex buffer is created to handle re-indexed bones. Default value = true.

String DestructibleActorParam::overrideSkinnedMaterialNames[]

'overrideSkinnedMaterialNames[]' : Per-actor material names, to override those in the asset, for skinned rendering

Per-actor material names, to override those in the asset, for skinned rendering.

String DestructibleActorParam::overrideStaticMaterialNames[]

'overrideStaticMaterialNames[]' : Per-actor material names, to override those in the asset, for static rendering

Per-actor material names, to override those in the asset, for static rendering.

U32 DestructibleActorParam::p3ActorDescTemplate.clientBehaviorBits

'p3ActorDescTemplate.clientBehaviorBits' : Changes the behavior bits initially specified with PxActorDesc::clientBehaviorBits.

Changes the behavior bits initially specified with PxActorDesc::clientBehaviorBits. This will be applied to all actors generated for this destructible's chunks.

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eCCD_LINEAR

'p3ActorDescTemplate.contactReportFlags.eCCD_LINEAR' : A less expensive approximation of eSWEPT_INTEGRATION_FULL, where the rotational motion of the objects is neglected. Should be used when performance is of the essence, for objects where angular motion is unlikely to lead to tunneling.

A less expensive approximation of eSWEPT_INTEGRATION_FULL, where the rotational motion of the objects is neglected. Should be used when performance is of the essence, for objects where angular motion is unlikely to lead to tunneling. Note: The scene must have PxSceneFlag::eENABLE_CCD enabled to use this feature.

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eCONTACT_DEFAULT

'p3ActorDescTemplate.contactReportFlags.eCONTACT_DEFAULT' : Provided default flag to do simple contact processing for this collision pair.

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eMODIFY_CONTACTS

'p3ActorDescTemplate.contactReportFlags.eMODIFY_CONTACTS' : Call contact modification callback for this collision pair.

Call contact modification callback for this collision pair. Note: Only takes effect if the colliding actors are rigid bodies.

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FEATURE_INDICES_PER_POINT

'p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FEATURE_INDICES_PER_POINT' : Provide feature indices per contact point in contact reports for this collision pair.

Provide feature indices per contact point in contact reports for this collision pair. Note: Only takes effect if the colliding actors are rigid bodies.

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCE_PER_POINT

'p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCE_PER_POINT' : Provide contact forces per contact point in contact reports for this collision pair.

Provide contact forces per contact point in contact reports for this collision pair. Note: Only takes effect if the colliding actors are rigid bodies.

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCES

'p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCES' : Provide the (summed total) friction force and normal force in contact reports for this collision pair (see PxContactPair).

Provide the (summed total) friction force and normal force in contact reports for this collision pair (see PxContactPair). Note: Only takes effect if the colliding actors are rigid bodies

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_POINTS

'p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_POINTS' : Provide contact points in contact reports for this collision pair.

Provide contact points in contact reports for this collision pair. Note: Only takes effect if the colliding actors are rigid bodies.

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_FOUND

'p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_FOUND' : Call contact report callback when the contact force between the actors of this collision pair exceeds one of the actor-defined force thresholds.

Call contact report callback when the contact force between the actors of this collision pair exceeds one of the actor-defined force thresholds. Note: Only takes effect if the colliding actors are rigid bodies

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_LOST

'p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_LOST' : Call contact report callback when the contact force between the actors of this collision pair falls below one of the actor-defined force thresholds (includes the case where this collision pair stops being in contact).

Call contact report callback when the contact force between the actors of this collision pair falls below one of the actor-defined force thresholds (includes the case where this collision pair stops being in contact). Note: Only takes effect if the colliding actors are rigid bodies

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_PERSISTS

'p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_PERSISTS' : Call contact report callback when the contact force between the actors of this collision pair continues to exceed one of the actor-defined force thresholds

Call contact report callback when the contact force between the actors of this collision pair continues to exceed one of the actor-defined force thresholds. Note: Only takes effect if the colliding actors are rigid bodies.

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_FOUND

'p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_FOUND' : Call contact report callback or trigger callback when this collision pair starts to be in contact

Call contact report callback or trigger callback when this collision pair starts to be in contact. If one of the two collision objects is a trigger shape (see PxShapeFlag::eTRIGGER_SHAPE) then the trigger callback will get called as soon as the other object enters the trigger volume. If none of the two collision objects is a trigger shape then the contact report callback will get called when the actors of this collision pair start to be in contact. Note: Only takes effect if the colliding actors are rigid bodies.

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_LOST

'p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_LOST' : Call contact report callback or trigger callback when this collision pair stops to be in contact.

Call contact report callback or trigger callback when this collision pair stops to be in contact. If one of the two collision objects is a trigger shape (see PxShapeFlag::eTRIGGER_SHAPE) then the trigger callback will get called as soon as the other object leaves the trigger volume. If none of the two collision objects is a trigger shape then the contact report callback will get called when the actors of this collision pair stop to be in contact. Note: Only takes effect if the colliding actors are rigid bodies.

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_PERSISTS

'p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_PERSISTS' : Call contact report callback or trigger callback while this collision pair is in contact

Process the contacts of this collision pair in the dynamics solver. Note: Only takes effect if the colliding actors are rigid bodies.

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eRESOLVE_CONTACTS

'p3ActorDescTemplate.contactReportFlags.eRESOLVE_CONTACTS' : Process the contacts of this collision pair in the dynamics solver.

Process the contacts of this collision pair in the dynamics solver. Note: Only takes effect if the colliding actors are rigid bodies.

Bool DestructibleActorParam::p3ActorDescTemplate.contactReportFlags.eTRIGGER_DEFAULT

'p3ActorDescTemplate.contactReportFlags.eTRIGGER_DEFAULT' : Provided default flag to get commonly used trigger behavior for this collision pair.

U8 DestructibleActorParam::p3ActorDescTemplate.dominanceGroup

'p3ActorDescTemplate.dominanceGroup' : Assigns dynamic actors a dominance group identifier.

Assigns dynamic actors a dominance group identifier. This will be applied to all actors generated for this destructible's chunks.

Bool DestructibleActorParam::p3ActorDescTemplate.flags.eDISABLE_GRAVITY

'p3ActorDescTemplate.flags.eDISABLE_GRAVITY' : Disables scene gravity for this actor

Disables scene gravity for this actor. This flag will be applied to all actors generated for this destructible's chunks.

Bool DestructibleActorParam::p3ActorDescTemplate.flags.eSEND_SLEEP_NOTIFIES

'p3ActorDescTemplate.flags.eSEND_SLEEP_NOTIFIES' : Enables the sending of PxSimulationEventCallback::onWake() and PxSimulationEventCallback::onSleep() notify events

Enables the sending of PxSimulationEventCallback::onWake() and PxSimulationEventCallback::onSleep() notify events. This flag will be applied to all actors generated for this destructible's chunks.

Bool DestructibleActorParam::p3ActorDescTemplate.flags.eVISUALIZATION

'p3ActorDescTemplate.flags.eVISUALIZATION' : Enable debug renderer for this actor

Enable debug renderer for this actor. This flag will be applied to all actors generated for this destructible's chunks.

U64 DestructibleActorParam::p3ActorDescTemplate.name

'p3ActorDescTemplate.name' : Optional name string for a shape; must be set by the application and must be a persistent pointer.

Optional name string for a shape; must be set by the application and must be a persistent pointer. This will be applied to all actors generated for this destructible's chunks.

U8 DestructibleActorParam::p3ActorDescTemplate.ownerClient

'p3ActorDescTemplate.ownerClient' : Sets the owner client of an actor.

Sets the owner client of an actor. This will be applied to all actors generated for this destructible's chunks.

U64 DestructibleActorParam::p3ActorDescTemplate.userData

'p3ActorDescTemplate.userData' : Optional user data pointer

Optional user data pointer. This will be applied to all actors generated for this destructible's chunks.

F32 DestructibleActorParam::p3BodyDescTemplate.angularDamping

'p3BodyDescTemplate.angularDamping' : Sets the angular damping coefficient

Sets the angular damping coefficient. This will be applied to all actors generated for this destructible's chunks.

F32 DestructibleActorParam::p3BodyDescTemplate.contactReportThreshold

'p3BodyDescTemplate.contactReportThreshold' : The force threshold for contact reports

The force threshold for contact reports. This will be applied to all actors generated for this destructible's chunks.

F32 DestructibleActorParam::p3BodyDescTemplate.density

'p3BodyDescTemplate.density' : The density of the body. Used to compute the mass of the body.

The density of the body. Used to compute the mass of the body. If the body descriptor contains a zero mass but the actor descriptor contains a non-zero density, we compute a new mass automatically from the density and a shapes. This will be applied to all actors generated for this destructible's chunks.

Bool DestructibleActorParam::p3BodyDescTemplate.flags.eENABLE_CCD

'p3BodyDescTemplate.flags.eENABLE_CCD' : Enables swept integration for the actor.

Enables swept integration for the actor. If this flag is raised and swept integration is enabled on the scene, then this body will be simulated by the CCD system to ensure that collisions are not missed due to high-speed motion. Note, individual shape pairs still need to enable PxPairFlag::eCCD_LINEAR in the collision filtering to enable the CCD to respond to individual interactions.

Bool DestructibleActorParam::p3BodyDescTemplate.flags.eKINEMATIC

'p3BodyDescTemplate.flags.eKINEMATIC' : Enables kinematic mode for the actor

Kinematic actors are special dynamic actors that are not influenced by forces (such as gravity), and have no momentum. They are considered to have infinite mass and can be moved around the world using the moveKinematic() method. They will push regular dynamic actors out of the way. Kinematics will not collide with static or other kinematic objects. Kinematic actors are great for moving platforms or characters, where direct motion control is desired. You can not connect Reduced joints to kinematic actors. Lagrange joints work ok if the platform is moving with a relatively low, uniform velocity. This will be applied to all actors generated for this destructible's chunks.

F32 DestructibleActorParam::p3BodyDescTemplate.linearDamping

'p3BodyDescTemplate.linearDamping' : Linear damping applied to the body

Linear damping applied to the body. This will be applied to all actors generated for this destructible's chunks.

F32 DestructibleActorParam::p3BodyDescTemplate.maxAngularVelocity

'p3BodyDescTemplate.maxAngularVelocity' : Maximum allowed angular velocity

Maximum allowed angular velocity. This will be applied to all actors generated for this destructible's chunks.

F32 DestructibleActorParam::p3BodyDescTemplate.sleepLinearVelocity

'p3BodyDescTemplate.sleepLinearVelocity' : Maximum linear velocity at which body can go to sleep

Maximum linear velocity at which body can go to sleep. This will be applied to all actors generated for this destructible's chunks.

F32 DestructibleActorParam::p3BodyDescTemplate.sleepThreshold

'p3BodyDescTemplate.sleepThreshold' : Sets the mass-normalized kinetic energy threshold below which an actor may go to sleep.

Sets the mass-normalized kinetic energy threshold below which an actor may go to sleep. This will be applied to all actors generated for this destructible's chunks.

U32 DestructibleActorParam::p3BodyDescTemplate.solverIterationCount

'p3BodyDescTemplate.solverIterationCount' : Sets the solver iteration counts for the body

Sets the solver iteration counts for the body. The solver iteration count determines how accurately joints and contacts are resolved. If you are having trouble with jointed bodies oscillating and behaving erratically, then setting a higher position iteration count may improve their stability. If intersecting bodies are being depenetrated too violently, increase the number of velocity iterations.

U32 DestructibleActorParam::p3BodyDescTemplate.velocityIterationCount

'p3BodyDescTemplate.velocityIterationCount' : Sets the velocity solver iteration counts for the body

Sets the velocity solver iteration counts for the body. The solver iteration count determines how accurately joints and contacts are resolved. If you are having trouble with jointed bodies oscillating and behaving erratically, then setting a higher position iteration count may improve their stability. If intersecting bodies are being depenetrated too violently, increase the number of velocity iterations.

F32 DestructibleActorParam::p3BodyDescTemplate.wakeUpCounter

'p3BodyDescTemplate.wakeUpCounter' : The bodys initial wake up counter

The bodys initial wake up counter. This will be applied to all actors generated for this destructible's chunks.

F32 DestructibleActorParam::p3ShapeDescTemplate.contactOffset

'p3ShapeDescTemplate.contactOffset' : Sets the contact offset

Sets the contact offset; if -1 it uses the global default. This is applied to all shapes generated for this destructible's chunks.

Bool DestructibleActorParam::p3ShapeDescTemplate.flags.eDEFORMABLE_DRAIN

'p3ShapeDescTemplate.flags.eDEFORMABLE_DRAIN' : Sets the shape to be a deformable drain

Bool DestructibleActorParam::p3ShapeDescTemplate.flags.ePARTICLE_DRAIN

'p3ShapeDescTemplate.flags.ePARTICLE_DRAIN' : Sets the shape to be a particle drain

Bool DestructibleActorParam::p3ShapeDescTemplate.flags.eSCENE_QUERY_SHAPE

'p3ShapeDescTemplate.flags.eSCENE_QUERY_SHAPE' : The shape will partake in scene queries (ray casts, overlap tests, sweeps, ...).

Bool DestructibleActorParam::p3ShapeDescTemplate.flags.eSIMULATION_SHAPE

'p3ShapeDescTemplate.flags.eSIMULATION_SHAPE' : The shape will partake in collision in the physical simulation.

Bool DestructibleActorParam::p3ShapeDescTemplate.flags.eTRIGGER_SHAPE

'p3ShapeDescTemplate.flags.eTRIGGER_SHAPE' : The shape is a trigger which can send reports whenever other shapes enter/leave its volume.

The shape is a trigger which can send reports whenever other shapes enter/leave its volume. Note: Triangle meshes and heightfields can not be triggers. Shape creation will fail in these cases. Shapes marked as triggers do not collide with other objects. If an object should act both as a trigger shape and a collision shape then create a rigid body with two shapes, one being a trigger shape and the other a collision shape.

Bool DestructibleActorParam::p3ShapeDescTemplate.flags.eVISUALIZATION

'p3ShapeDescTemplate.flags.eVISUALIZATION' : Enable debug renderer for this shape

U64 DestructibleActorParam::p3ShapeDescTemplate.material

'p3ShapeDescTemplate.material' : A PxMaterial pointer for the shape

A PxMaterial pointer for the shape. This is applied to all shapes generated for this destructible's chunks.

U64 DestructibleActorParam::p3ShapeDescTemplate.name

'p3ShapeDescTemplate.name' : Optional name string for a shape.

Optional name string for a shape; must be set by the application and must be a persistent pointer. This is applied to all shapes generated for this destructible's chunks.

U32 DestructibleActorParam::p3ShapeDescTemplate.queryFilterData.word0

'p3ShapeDescTemplate.queryFilterData.word0' : word0 of the filter data

U32 DestructibleActorParam::p3ShapeDescTemplate.queryFilterData.word1

'p3ShapeDescTemplate.queryFilterData.word1' : word1 of the filter data

U32 DestructibleActorParam::p3ShapeDescTemplate.queryFilterData.word2

'p3ShapeDescTemplate.queryFilterData.word2' : word2 of the filter data

U32 DestructibleActorParam::p3ShapeDescTemplate.queryFilterData.word3

'p3ShapeDescTemplate.queryFilterData.word3' : word3 of the filter data

F32 DestructibleActorParam::p3ShapeDescTemplate.restOffset

'p3ShapeDescTemplate.restOffset' : Sets the rest offset

Sets the rest offset; if -1 it uses the global default. This is applied to all shapes generated for this destructible's chunks.

U32 DestructibleActorParam::p3ShapeDescTemplate.simulationFilterData.word0

'p3ShapeDescTemplate.simulationFilterData.word0' : word0 of the filter data

U32 DestructibleActorParam::p3ShapeDescTemplate.simulationFilterData.word1

'p3ShapeDescTemplate.simulationFilterData.word1' : word1 of the filter data

U32 DestructibleActorParam::p3ShapeDescTemplate.simulationFilterData.word2

'p3ShapeDescTemplate.simulationFilterData.word2' : word2 of the filter data

U32 DestructibleActorParam::p3ShapeDescTemplate.simulationFilterData.word3

'p3ShapeDescTemplate.simulationFilterData.word3' : word3 of the filter data

U64 DestructibleActorParam::p3ShapeDescTemplate.userData

'p3ShapeDescTemplate.userData' : Optional user data pointer

Optional user data pointer. This is applied to all shapes generated for this destructible's chunks.

Bool DestructibleActorParam::performDetailedOverlapTestForExtendedStructures

'performDetailedOverlapTestForExtendedStructures' : When testing for chunk overlap with other destructibles, perform detailed collision test. Otherwise, just test AABBs.

When testing for chunk overlap with other destructibles in an extended structure (see formExtendedStructures), perform detailed collision test. Otherwise, just test AABBs. Default = TRUE.

Bool DestructibleActorParam::renderStaticChunksSeparately

'renderStaticChunksSeparately' : Whether or not to render static chunks in a separate mesh

If true, static chunks will be renderered separately from dynamic chunks, as a single mesh (not using skinning). This parameter is ignored if the 'dynamic' parameter is true. Default value = false.

Vec3 DestructibleActorParam::scale

'scale' : 3D Scale

3D Scale

U16 DestructibleActorParam::shapeDescTemplate.collisionGroup

'shapeDescTemplate.collisionGroup' : Sets which collision group shapes are part of.

Sets which collision group shapes are part of. Default group is 0. Maximum possible group is 31. Collision groups are sets of shapes which may or may not be set to collision detect with each other; this can be set using NxScene::setGroupCollisionFlag() Sleeping: Does NOT wake the associated actor up automatically. param[in] collisionGroup The collision group for shapes. This is applied to all NxShapes generated for this destructible's chunks.

F32 DestructibleActorParam::shapeDescTemplate.density

'shapeDescTemplate.density' : The density of an individual shape.

The density of this individual shape when computing mass inertial properties for a rigidbody (unless a valid mass >0.0 is provided). Note that this will only be used if the body has a zero inertia tensor, or if you call NxActor::updateMassFromShapes explicitly. This is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_CLOTH_DISABLE_COLLISION

'shapeDescTemplate.flags.NX_SF_CLOTH_DISABLE_COLLISION' : Disable collision with cloths.

Disable collision with cloths. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_CLOTH_DRAIN

'shapeDescTemplate.flags.NX_SF_CLOTH_DRAIN' : Sets a shape to be a cloth drain.

Sets a shape to be a cloth drain. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_CLOTH_TWOWAY

'shapeDescTemplate.flags.NX_SF_CLOTH_TWOWAY' : Enables the reaction of a shapes actor on cloth collision.

Enables the reaction of a shapes actor on cloth collision. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION

'shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION' : Disable collision detection for shapes (counterpart of NX_AF_DISABLE_COLLISION)

Disable collision detection for shapes (counterpart of NX_AF_DISABLE_COLLISION). This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING

'shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING' : Disable raycasting for shapes

Disable raycasting for shapes. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_DISABLE_RESPONSE

'shapeDescTemplate.flags.NX_SF_DISABLE_RESPONSE' : Disable collision response for shapes (counterpart of NX_AF_DISABLE_RESPONSE)

Disable collision response for shapes (counterpart of NX_AF_DISABLE_RESPONSE). This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES

'shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES' : Disable participation in ray casts, overlap tests and sweeps.

Disable participation in ray casts, overlap tests and sweeps. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD

'shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD' : Enable dynamic-dynamic CCD for shapes. Used only when CCD is globally enabled and shape have a CCD skeleton.

Enable dynamic-dynamic CCD for shapes. Used only when CCD is globally enabled and shape have a CCD skeleton. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_FEATURE_INDICES

'shapeDescTemplate.flags.NX_SF_FEATURE_INDICES' : Enable feature indices in contact stream.

Enable feature indices in contact stream. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_FLUID_DISABLE_COLLISION

'shapeDescTemplate.flags.NX_SF_FLUID_DISABLE_COLLISION' : Disable collision with fluids.

Disable collision with fluids. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_FLUID_DRAIN

'shapeDescTemplate.flags.NX_SF_FLUID_DRAIN' : Sets a shape to be a fluid drain.

Sets a shape to be a fluid drain. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_FLUID_TWOWAY

'shapeDescTemplate.flags.NX_SF_FLUID_TWOWAY' : Enables the reaction of a shapes actor on fluid collision.

Enables the reaction of a shapes actor on fluid collision. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_POINT_CONTACT_FORCE

'shapeDescTemplate.flags.NX_SF_POINT_CONTACT_FORCE' : Enable contact force reporting per contact point in contact stream (otherwise we only report force per actor pair)

Enable contact force reporting per contact point in contact stream (otherwise we only report force per actor pair). This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_SOFTBODY_DISABLE_COLLISION

'shapeDescTemplate.flags.NX_SF_SOFTBODY_DISABLE_COLLISION' : Disable collision with soft bodies.

Disable collision with soft bodies. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_SOFTBODY_DRAIN

'shapeDescTemplate.flags.NX_SF_SOFTBODY_DRAIN' : Sets a shape to be a soft body drain.

Sets a shape to be a soft body drain. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_SOFTBODY_TWOWAY

'shapeDescTemplate.flags.NX_SF_SOFTBODY_TWOWAY' : Enables the reaction of a shape's actor on soft body collision.

Enables the reaction of a shape's actor on soft body collision. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_SF_VISUALIZATION

'shapeDescTemplate.flags.NX_SF_VISUALIZATION' : Enable debug renderer for shapes

Enable debug renderer for shapes. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_TRIGGER_ON_ENTER

'shapeDescTemplate.flags.NX_TRIGGER_ON_ENTER' : Trigger callback will be called when a shape enters the trigger volume.

Trigger callback will be called when a shape enters the trigger volume. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_TRIGGER_ON_LEAVE

'shapeDescTemplate.flags.NX_TRIGGER_ON_LEAVE' : Trigger callback will be called after a shape leaves the trigger volume.

Trigger callback will be called after a shape leaves the trigger volume. This flag is applied to all NxShapes generated for this destructible's chunks.

Bool DestructibleActorParam::shapeDescTemplate.flags.NX_TRIGGER_ON_STAY

'shapeDescTemplate.flags.NX_TRIGGER_ON_STAY' : Trigger callback will be called while a shape is intersecting the trigger volume.

Trigger callback will be called while a shape is intersecting the trigger volume. This flag is applied to all NxShapes generated for this destructible's chunks.

U32 DestructibleActorParam::shapeDescTemplate.groupsMask.bits0

'shapeDescTemplate.groupsMask.bits0' : bits0 of the groups mask

If useGroupsMask is true, this is bits0 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorParam::shapeDescTemplate.groupsMask.bits1

'shapeDescTemplate.groupsMask.bits1' : bits1 of the groups mask

If useGroupsMask is true, this is bits1 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorParam::shapeDescTemplate.groupsMask.bits2

'shapeDescTemplate.groupsMask.bits2' : bits2 of the groups mask

If useGroupsMask is true, this is bits2 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorParam::shapeDescTemplate.groupsMask.bits3

'shapeDescTemplate.groupsMask.bits3' : bits3 of the groups mask

If useGroupsMask is true, this is bits3 of the groups mask. See the PhysX documentation for more on groups masks.

Bool DestructibleActorParam::shapeDescTemplate.groupsMask.useGroupsMask

'shapeDescTemplate.groupsMask.useGroupsMask' : Whether or not the groupsMask should be used

Whether or not the groupsMask should be used. If so, then this will be applied to all NxShapes created to represent this destructible's chunks.

U16 DestructibleActorParam::shapeDescTemplate.materialIndex

'shapeDescTemplate.materialIndex' : The material index of a shape.

The material index of a shape. This is applied to all NxShapes generated for this destructible's chunks.

U64 DestructibleActorParam::shapeDescTemplate.name

'shapeDescTemplate.name' : Optional name string for a shape.

Optional name string for a shape; must be set by the application and must be a persistent pointer. This is applied to all NxShapes generated for this destructible's chunks.

F32 DestructibleActorParam::shapeDescTemplate.skinWidth

'shapeDescTemplate.skinWidth' : Specifies by how much shapes can interpenetrate; if -1 it uses the global default

Specifies by how much shapes can interpenetrate; if -1 it uses the global default. This is applied to all NxShapes generated for this destructible's chunks.

U64 DestructibleActorParam::shapeDescTemplate.userData

'shapeDescTemplate.userData' : Optional user data pointer

Optional user data pointer. This is applied to all NxShapes generated for this destructible's chunks.

F32 DestructibleActorParam::sleepVelocityFrameDecayConstant

'sleepVelocityFrameDecayConstant' : Frame memory decay constant used for actor velocity smoothing. Valid range: [1.0,infinity).

Frame memory decay constant used for actor velocity smoothing. Valid range: [1.0,infinity). Roughly speaking, the number of frames for which past velocities have significance. A value of 1.0 (or less) gives no smoothing.

F32 DestructibleActorParam::structureSettings.stressSolverMassThreshold

'structureSettings.stressSolverMassThreshold' : The structure containing this actor will use the minimum stressSolverMassThreshold of all actors in the structure.

Determines the minimum threshold mass to meet before an indentified overly-strained link breaks. This mass threshold is part of the condition that the stress solver uses to qualify whether a link is overly-strained. The accumulated sum of the chunk masses that the link is supporting will be used against this value. This should always be some positive value.

F32 DestructibleActorParam::structureSettings.stressSolverTimeDelay

'structureSettings.stressSolverTimeDelay' : The structure containing this actor will use the minimum stressSolverTimeDelay of all actors in the structure.

Determines the amount of time to run down until an identified overly-strained link breaks. From the time the stress solver qualifies a link as being overly-strained, this value will be used to count down to the actual breaking-off event being executed. This should always be some positive value.

Bool DestructibleActorParam::structureSettings.useStressSolver

'structureSettings.useStressSolver' : If true, the structure containing this actor will use the stress solver.

Determines whether to invoke the use of the stress solver. The stress solver is a self-checking mechanism employed within the structure, with the purpose of detecting and breaking off overly-strained links to masses of chunks. Its behavior can be tweaked by customizing the parameters stressSolverTimeDelay and stressSolverMassThreshold.

U32 DestructibleActorParam::supportDepth

'supportDepth' : The chunk hierarchy depth at which to create a support graph.

The chunk hierarchy depth at which to create a support graph. Higher depth levels give more detailed support, but will give a higher computational load. Chunks below the support depth will never be supported.

Bool DestructibleActorParam::useAssetDefinedSupport

'useAssetDefinedSupport' : If set, then chunks which are tagged as 'support' chunks

If set, then chunks which are tagged as 'support' chunks (via NxDestructibleChunkDesc::isSupportChunk) will have environmental support in static destructibles. Note: if both ASSET_DEFINED_SUPPORT and WORLD_SUPPORT are set, then chunks must be tagged as 'support' chunks AND overlap the NxScene's static geometry in order to be environmentally supported.

Bool DestructibleActorParam::useHardSleeping

'useHardSleeping' : If true, turn chunk islands kinematic when they sleep.

If true, turn chunk islands kinematic when they sleep. These islands may be turned dynamic again if enough damage is applied.

Bool DestructibleActorParam::useWorldSupport

'useWorldSupport' : If set, then chunks which overlap the NxScene's static geometry will have environmental support

If set, then chunks which overlap the NxScene's static geometry will have environmental support in static destructibles. Note: if both ASSET_DEFINED_SUPPORT and WORLD_SUPPORT are set, then chunks must be tagged as 'support' chunks AND overlap the NxScene's static geometry in order to be environmentally supported.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
DestructibleActorParam Member List
This is the complete list of members for DestructibleActorParam, including all inherited members.
actorDescTemplate.actorCollisionGroup | DestructibleActorParam
actorDescTemplate.compartment | DestructibleActorParam
actorDescTemplate.contactReportFlags.NX_IGNORE_PAIR | DestructibleActorParam
actorDescTemplate.contactReportFlags.NX_NOTIFY_CONTACT_MODIFICATION | DestructibleActorParam
actorDescTemplate.contactReportFlags.NX_NOTIFY_FORCES | DestructibleActorParam
actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH | DestructibleActorParam
actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH_FORCE_THRESHOLD | DestructibleActorParam
actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_IMPACT | DestructibleActorParam
actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_ROLL | DestructibleActorParam
actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_SLIDE | DestructibleActorParam
actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH | DestructibleActorParam
actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH_FORCE_THRESHOLD | DestructibleActorParam
actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH | DestructibleActorParam
actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH_FORCE_THRESHOLD | DestructibleActorParam
actorDescTemplate.density | DestructibleActorParam
actorDescTemplate.dominanceGroup | DestructibleActorParam
actorDescTemplate.flags.NX_AF_CONTACT_MODIFICATION | DestructibleActorParam
actorDescTemplate.flags.NX_AF_DISABLE_COLLISION | DestructibleActorParam
actorDescTemplate.flags.NX_AF_DISABLE_RESPONSE | DestructibleActorParam
actorDescTemplate.flags.NX_AF_FLUID_DISABLE_COLLISION | DestructibleActorParam
actorDescTemplate.flags.NX_AF_FORCE_CONE_FRICTION | DestructibleActorParam
actorDescTemplate.flags.NX_AF_LOCK_COM | DestructibleActorParam
actorDescTemplate.flags.NX_AF_USER_ACTOR_PAIR_FILTERING | DestructibleActorParam
actorDescTemplate.forceFieldMaterial | DestructibleActorParam
actorDescTemplate.name | DestructibleActorParam
actorDescTemplate.userData | DestructibleActorParam
behaviorGroups[].damageColorChange | DestructibleActorParam
behaviorGroups[].damageColorSpread.falloffExponent | DestructibleActorParam
behaviorGroups[].damageColorSpread.minimumRadius | DestructibleActorParam
behaviorGroups[].damageColorSpread.radiusMultiplier | DestructibleActorParam
behaviorGroups[].damageSpread.falloffExponent | DestructibleActorParam
behaviorGroups[].damageSpread.minimumRadius | DestructibleActorParam
behaviorGroups[].damageSpread.radiusMultiplier | DestructibleActorParam
behaviorGroups[].damageThreshold | DestructibleActorParam
behaviorGroups[].damageToRadius | DestructibleActorParam
behaviorGroups[].density | DestructibleActorParam
behaviorGroups[].fadeOut | DestructibleActorParam
behaviorGroups[].groupsMask.bits0 | DestructibleActorParam
behaviorGroups[].groupsMask.bits1 | DestructibleActorParam
behaviorGroups[].groupsMask.bits2 | DestructibleActorParam
behaviorGroups[].groupsMask.bits3 | DestructibleActorParam
behaviorGroups[].groupsMask.useGroupsMask | DestructibleActorParam
behaviorGroups[].materialStrength | DestructibleActorParam
behaviorGroups[].maxDepenetrationVelocity | DestructibleActorParam
behaviorGroups[].name | DestructibleActorParam
behaviorGroups[].userData | DestructibleActorParam
bodyDescTemplate.angularDamping | DestructibleActorParam
bodyDescTemplate.CCDMotionThreshold | DestructibleActorParam
bodyDescTemplate.contactReportThreshold | DestructibleActorParam
bodyDescTemplate.flags.NX_BF_DISABLE_GRAVITY | DestructibleActorParam
bodyDescTemplate.flags.NX_BF_ENERGY_SLEEP_TEST | DestructibleActorParam
bodyDescTemplate.flags.NX_BF_FILTER_SLEEP_VEL | DestructibleActorParam
bodyDescTemplate.flags.NX_BF_VISUALIZATION | DestructibleActorParam
bodyDescTemplate.linearDamping | DestructibleActorParam
bodyDescTemplate.maxAngularVelocity | DestructibleActorParam
bodyDescTemplate.sleepAngularVelocity | DestructibleActorParam
bodyDescTemplate.sleepDamping | DestructibleActorParam
bodyDescTemplate.sleepEnergyThreshold | DestructibleActorParam
bodyDescTemplate.sleepLinearVelocity | DestructibleActorParam
bodyDescTemplate.solverIterationCount | DestructibleActorParam
bodyDescTemplate.wakeUpCounter | DestructibleActorParam
createChunkEvents | DestructibleActorParam
crumbleEmitterName | DestructibleActorParam
crumbleParticleSpacing | DestructibleActorParam
defaultBehaviorGroup.damageColorChange | DestructibleActorParam
defaultBehaviorGroup.damageColorSpread.falloffExponent | DestructibleActorParam
defaultBehaviorGroup.damageColorSpread.minimumRadius | DestructibleActorParam
defaultBehaviorGroup.damageColorSpread.radiusMultiplier | DestructibleActorParam
defaultBehaviorGroup.damageSpread.falloffExponent | DestructibleActorParam
defaultBehaviorGroup.damageSpread.minimumRadius | DestructibleActorParam
defaultBehaviorGroup.damageSpread.radiusMultiplier | DestructibleActorParam
defaultBehaviorGroup.damageThreshold | DestructibleActorParam
defaultBehaviorGroup.damageToRadius | DestructibleActorParam
defaultBehaviorGroup.density | DestructibleActorParam
defaultBehaviorGroup.fadeOut | DestructibleActorParam
defaultBehaviorGroup.groupsMask.bits0 | DestructibleActorParam
defaultBehaviorGroup.groupsMask.bits1 | DestructibleActorParam
defaultBehaviorGroup.groupsMask.bits2 | DestructibleActorParam
defaultBehaviorGroup.groupsMask.bits3 | DestructibleActorParam
defaultBehaviorGroup.groupsMask.useGroupsMask | DestructibleActorParam
defaultBehaviorGroup.materialStrength | DestructibleActorParam
defaultBehaviorGroup.maxDepenetrationVelocity | DestructibleActorParam
defaultBehaviorGroup.name | DestructibleActorParam
defaultBehaviorGroup.userData | DestructibleActorParam
deleteChunksEnteringUserDefinedBB | DestructibleActorParam
deleteChunksLeavingUserDefinedBB | DestructibleActorParam
depthParameters[].IGNORE_CONTACT_CALLBACKS | DestructibleActorParam
depthParameters[].IGNORE_POSE_UPDATES | DestructibleActorParam
depthParameters[].IGNORE_RAYCAST_CALLBACKS | DestructibleActorParam
depthParameters[].OVERRIDE_IMPACT_DAMAGE | DestructibleActorParam
depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE | DestructibleActorParam
depthParameters[].USER_FLAG_0 | DestructibleActorParam
depthParameters[].USER_FLAG_1 | DestructibleActorParam
depthParameters[].USER_FLAG_2 | DestructibleActorParam
depthParameters[].USER_FLAG_3 | DestructibleActorParam
destructibleParameters.damageCap | DestructibleActorParam
destructibleParameters.damageDepthLimit | DestructibleActorParam
destructibleParameters.debrisDepth | DestructibleActorParam
destructibleParameters.debrisDestructionProbability | DestructibleActorParam
destructibleParameters.debrisLifetimeMax | DestructibleActorParam
destructibleParameters.debrisLifetimeMin | DestructibleActorParam
destructibleParameters.debrisMaxSeparationMax | DestructibleActorParam
destructibleParameters.debrisMaxSeparationMin | DestructibleActorParam
destructibleParameters.dynamicChunkDominanceGroup | DestructibleActorParam
destructibleParameters.dynamicChunksGroupsMask.bits0 | DestructibleActorParam
destructibleParameters.dynamicChunksGroupsMask.bits1 | DestructibleActorParam
destructibleParameters.dynamicChunksGroupsMask.bits2 | DestructibleActorParam
destructibleParameters.dynamicChunksGroupsMask.bits3 | DestructibleActorParam
destructibleParameters.dynamicChunksGroupsMask.useGroupsMask | DestructibleActorParam
destructibleParameters.essentialDepth | DestructibleActorParam
destructibleParameters.flags.ACCUMULATE_DAMAGE | DestructibleActorParam
destructibleParameters.flags.ACCURATE_RAYCASTS | DestructibleActorParam
destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS | DestructibleActorParam
destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE | DestructibleActorParam
destructibleParameters.flags.DEBRIS_MAX_SEPARATION | DestructibleActorParam
destructibleParameters.flags.DEBRIS_TIMEOUT | DestructibleActorParam
destructibleParameters.flags.USE_VALID_BOUNDS | DestructibleActorParam
destructibleParameters.forceToDamage | DestructibleActorParam
destructibleParameters.fractureImpulseScale | DestructibleActorParam
destructibleParameters.impactDamageDefaultDepth | DestructibleActorParam
destructibleParameters.impactVelocityThreshold | DestructibleActorParam
destructibleParameters.legacyChunkBoundsTestSetting | DestructibleActorParam
destructibleParameters.legacyDamageRadiusSpreadSetting | DestructibleActorParam
destructibleParameters.maxChunkSpeed | DestructibleActorParam
destructibleParameters.minimumFractureDepth | DestructibleActorParam
destructibleParameters.runtimeFracture.attachment.negX | DestructibleActorParam
destructibleParameters.runtimeFracture.attachment.negY | DestructibleActorParam
destructibleParameters.runtimeFracture.attachment.negZ | DestructibleActorParam
destructibleParameters.runtimeFracture.attachment.posX | DestructibleActorParam
destructibleParameters.runtimeFracture.attachment.posY | DestructibleActorParam
destructibleParameters.runtimeFracture.attachment.posZ | DestructibleActorParam
destructibleParameters.runtimeFracture.depthLimit | DestructibleActorParam
destructibleParameters.runtimeFracture.destroyIfAtDepthLimit | DestructibleActorParam
destructibleParameters.runtimeFracture.glass.firstSegmentSize | DestructibleActorParam
destructibleParameters.runtimeFracture.glass.numSectors | DestructibleActorParam
destructibleParameters.runtimeFracture.glass.sectorRand | DestructibleActorParam
destructibleParameters.runtimeFracture.glass.segmentRand | DestructibleActorParam
destructibleParameters.runtimeFracture.glass.segmentScale | DestructibleActorParam
destructibleParameters.runtimeFracture.impulseScale | DestructibleActorParam
destructibleParameters.runtimeFracture.minConvexSize | DestructibleActorParam
destructibleParameters.runtimeFracture.RuntimeFractureType | DestructibleActorParam
destructibleParameters.runtimeFracture.sheetFracture | DestructibleActorParam
destructibleParameters.runtimeFracture.voronoi.biasExp | DestructibleActorParam
destructibleParameters.runtimeFracture.voronoi.dimensions | DestructibleActorParam
destructibleParameters.runtimeFracture.voronoi.maxDist | DestructibleActorParam
destructibleParameters.runtimeFracture.voronoi.numCells | DestructibleActorParam
destructibleParameters.supportStrength | DestructibleActorParam
destructibleParameters.validBounds | DestructibleActorParam
doNotCreateRenderable | DestructibleActorParam
dustEmitterName | DestructibleActorParam
dustParticleSpacing | DestructibleActorParam
dynamic | DestructibleActorParam
formExtendedStructures | DestructibleActorParam
globalPose | DestructibleActorParam
keepPreviousFrameBoneBuffer | DestructibleActorParam
keepVisibleBonesPacked | DestructibleActorParam
overrideSkinnedMaterialNames[] | DestructibleActorParam
overrideStaticMaterialNames[] | DestructibleActorParam
p3ActorDescTemplate.clientBehaviorBits | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eCCD_LINEAR | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eCONTACT_DEFAULT | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eMODIFY_CONTACTS | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FEATURE_INDICES_PER_POINT | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCE_PER_POINT | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCES | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_POINTS | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_FOUND | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_LOST | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_PERSISTS | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_FOUND | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_LOST | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_PERSISTS | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eRESOLVE_CONTACTS | DestructibleActorParam
p3ActorDescTemplate.contactReportFlags.eTRIGGER_DEFAULT | DestructibleActorParam
p3ActorDescTemplate.dominanceGroup | DestructibleActorParam
p3ActorDescTemplate.flags.eDISABLE_GRAVITY | DestructibleActorParam
p3ActorDescTemplate.flags.eSEND_SLEEP_NOTIFIES | DestructibleActorParam
p3ActorDescTemplate.flags.eVISUALIZATION | DestructibleActorParam
p3ActorDescTemplate.name | DestructibleActorParam
p3ActorDescTemplate.ownerClient | DestructibleActorParam
p3ActorDescTemplate.userData | DestructibleActorParam
p3BodyDescTemplate.angularDamping | DestructibleActorParam
p3BodyDescTemplate.contactReportThreshold | DestructibleActorParam
p3BodyDescTemplate.density | DestructibleActorParam
p3BodyDescTemplate.flags.eENABLE_CCD | DestructibleActorParam
p3BodyDescTemplate.flags.eKINEMATIC | DestructibleActorParam
p3BodyDescTemplate.linearDamping | DestructibleActorParam
p3BodyDescTemplate.maxAngularVelocity | DestructibleActorParam
p3BodyDescTemplate.sleepLinearVelocity | DestructibleActorParam
p3BodyDescTemplate.sleepThreshold | DestructibleActorParam
p3BodyDescTemplate.solverIterationCount | DestructibleActorParam
p3BodyDescTemplate.velocityIterationCount | DestructibleActorParam
p3BodyDescTemplate.wakeUpCounter | DestructibleActorParam
p3ShapeDescTemplate.contactOffset | DestructibleActorParam
p3ShapeDescTemplate.flags.eDEFORMABLE_DRAIN | DestructibleActorParam
p3ShapeDescTemplate.flags.ePARTICLE_DRAIN | DestructibleActorParam
p3ShapeDescTemplate.flags.eSCENE_QUERY_SHAPE | DestructibleActorParam
p3ShapeDescTemplate.flags.eSIMULATION_SHAPE | DestructibleActorParam
p3ShapeDescTemplate.flags.eTRIGGER_SHAPE | DestructibleActorParam
p3ShapeDescTemplate.flags.eVISUALIZATION | DestructibleActorParam
p3ShapeDescTemplate.material | DestructibleActorParam
p3ShapeDescTemplate.name | DestructibleActorParam
p3ShapeDescTemplate.queryFilterData.word0 | DestructibleActorParam
p3ShapeDescTemplate.queryFilterData.word1 | DestructibleActorParam
p3ShapeDescTemplate.queryFilterData.word2 | DestructibleActorParam
p3ShapeDescTemplate.queryFilterData.word3 | DestructibleActorParam
p3ShapeDescTemplate.restOffset | DestructibleActorParam
p3ShapeDescTemplate.simulationFilterData.word0 | DestructibleActorParam
p3ShapeDescTemplate.simulationFilterData.word1 | DestructibleActorParam
p3ShapeDescTemplate.simulationFilterData.word2 | DestructibleActorParam
p3ShapeDescTemplate.simulationFilterData.word3 | DestructibleActorParam
p3ShapeDescTemplate.userData | DestructibleActorParam
performDetailedOverlapTestForExtendedStructures | DestructibleActorParam
renderStaticChunksSeparately | DestructibleActorParam
scale | DestructibleActorParam
shapeDescTemplate.collisionGroup | DestructibleActorParam
shapeDescTemplate.density | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_CLOTH_DISABLE_COLLISION | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_CLOTH_DRAIN | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_CLOTH_TWOWAY | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_DISABLE_RESPONSE | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_FEATURE_INDICES | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_FLUID_DISABLE_COLLISION | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_FLUID_DRAIN | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_FLUID_TWOWAY | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_POINT_CONTACT_FORCE | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_SOFTBODY_DISABLE_COLLISION | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_SOFTBODY_DRAIN | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_SOFTBODY_TWOWAY | DestructibleActorParam
shapeDescTemplate.flags.NX_SF_VISUALIZATION | DestructibleActorParam
shapeDescTemplate.flags.NX_TRIGGER_ON_ENTER | DestructibleActorParam
shapeDescTemplate.flags.NX_TRIGGER_ON_LEAVE | DestructibleActorParam
shapeDescTemplate.flags.NX_TRIGGER_ON_STAY | DestructibleActorParam
shapeDescTemplate.groupsMask.bits0 | DestructibleActorParam
shapeDescTemplate.groupsMask.bits1 | DestructibleActorParam
shapeDescTemplate.groupsMask.bits2 | DestructibleActorParam
shapeDescTemplate.groupsMask.bits3 | DestructibleActorParam
shapeDescTemplate.groupsMask.useGroupsMask | DestructibleActorParam
shapeDescTemplate.materialIndex | DestructibleActorParam
shapeDescTemplate.name | DestructibleActorParam
shapeDescTemplate.skinWidth | DestructibleActorParam
shapeDescTemplate.userData | DestructibleActorParam
sleepVelocityFrameDecayConstant | DestructibleActorParam
structureSettings.stressSolverMassThreshold | DestructibleActorParam
structureSettings.stressSolverTimeDelay | DestructibleActorParam
structureSettings.useStressSolver | DestructibleActorParam
supportDepth | DestructibleActorParam
useAssetDefinedSupport | DestructibleActorParam
useHardSleeping | DestructibleActorParam
useWorldSupport | DestructibleActorParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: DestructibleActorState Struct Reference

  • Class List
  • Class Members
Public Attributes
DestructibleActorState Struct Reference

Describes the NxParameterized::Interface for 'DestructibleActorState' : More...

#include <params.h>

List of all members.

Public Attributes

Bool | enableCrumbleEmitter
'enableCrumbleEmitter' : Whether or not the crumble emitter is active
Bool | enableDustEmitter
'enableDustEmitter' : Whether or not the dust emitter is active
F32 | internalLODWeights.maxDistance
'internalLODWeights.maxDistance' : Helpful documentation goes here
F32 | internalLODWeights.distanceWeight
'internalLODWeights.distanceWeight' : Helpful documentation goes here
F32 | internalLODWeights.maxAge
'internalLODWeights.maxAge' : Helpful documentation goes here
F32 | internalLODWeights.ageWeight
'internalLODWeights.ageWeight' : Helpful documentation goes here
F32 | internalLODWeights.bias
'internalLODWeights.bias' : Helpful documentation goes here
U32 | lod
'lod' : Destructible actor LOD
Bool | forceLod
'forceLod' : Whether or not to force LOD behavior on the actor
F32 | destructibleParameters.damageCap
'destructibleParameters.damageCap' : Limits the amount of damage applied to a chunk.
F32 | destructibleParameters.forceToDamage
'destructibleParameters.forceToDamage' : Multiplier to calculate applied damage from an impact.
F32 | destructibleParameters.impactVelocityThreshold
'destructibleParameters.impactVelocityThreshold' : Large impact force may be reported if rigid bodies are spawned inside one another.
U32 | destructibleParameters.minimumFractureDepth
'destructibleParameters.minimumFractureDepth' : The chunks will not be broken free below this depth.
I32 | destructibleParameters.impactDamageDefaultDepth
'destructibleParameters.impactDamageDefaultDepth' : The default depth to which chunks will take impact damage.
I32 | destructibleParameters.debrisDepth
'destructibleParameters.debrisDepth' : The chunk hierarchy depth at which chunks are considered to be 'debris.'
U32 | destructibleParameters.essentialDepth
'destructibleParameters.essentialDepth' : The chunk hierarchy depth up to which chunks will always be processed
F32 | destructibleParameters.debrisLifetimeMin
'destructibleParameters.debrisLifetimeMin' : Minimum time to destroy debris
F32 | destructibleParameters.debrisLifetimeMax
'destructibleParameters.debrisLifetimeMax' : Maximum time to destroy debris
F32 | destructibleParameters.debrisMaxSeparationMin
'destructibleParameters.debrisMaxSeparationMin' : Minimum separation distance
F32 | destructibleParameters.debrisMaxSeparationMax
'destructibleParameters.debrisMaxSeparationMax' : Minimum separation distance
F32 | destructibleParameters.debrisDestructionProbability
'destructibleParameters.debrisDestructionProbability' : The probablity that a debris chunk, when fractured, will simply be destroyed
Bounds3 | destructibleParameters.validBounds
'destructibleParameters.validBounds' : valid bounding region for debris
F32 | destructibleParameters.maxChunkSpeed
'destructibleParameters.maxChunkSpeed' : Maximum speed of a chunk
Bool | destructibleParameters.flags.ACCUMULATE_DAMAGE
'destructibleParameters.flags.ACCUMULATE_DAMAGE' : Determines if chunks accumulate damage
Bool | destructibleParameters.flags.DEBRIS_TIMEOUT
'destructibleParameters.flags.DEBRIS_TIMEOUT' : Whether or not chunks at or deeper than the 'debris' depth will timeout
Bool | destructibleParameters.flags.DEBRIS_MAX_SEPARATION
'destructibleParameters.flags.DEBRIS_MAX_SEPARATION' : Whether or not chunks at or deeper than the 'debris' depth will be removed if separated too far
Bool | destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS
'destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS' : If set, the smallest chunks may be further broken down
Bool | destructibleParameters.flags.ACCURATE_RAYCASTS
'destructibleParameters.flags.ACCURATE_RAYCASTS' : If set, the NxDestructibleActor::rayCast function will search within the nearest visible chunk hit
Bool | destructibleParameters.flags.USE_VALID_BOUNDS
'destructibleParameters.flags.USE_VALID_BOUNDS' : If set, the validBounds field of NxDestructibleParameters will be used.
Bool | destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE
'destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE' : If set, crumbled chunks will use the runtime fracture pipeline.
F32 | destructibleParameters.fractureImpulseScale
'destructibleParameters.fractureImpulseScale' : Scale factor used to apply an impulse force along the normal of chunk when fractured.
U16 | destructibleParameters.damageDepthLimit
'destructibleParameters.damageDepthLimit' : How deep in the hierarchy damage will be propagated, relative to the chunk hit.
U16 | destructibleParameters.dynamicChunkDominanceGroup
'destructibleParameters.dynamicChunkDominanceGroup' : Optional dominance group for dynamic chunks created when fractured.
Bool | destructibleParameters.dynamicChunksGroupsMask.useGroupsMask
'destructibleParameters.dynamicChunksGroupsMask.useGroupsMask' : Whether or not the groupsMask should be used
U32 | destructibleParameters.dynamicChunksGroupsMask.bits0
'destructibleParameters.dynamicChunksGroupsMask.bits0' : bits0 of the groups mask
U32 | destructibleParameters.dynamicChunksGroupsMask.bits1
'destructibleParameters.dynamicChunksGroupsMask.bits1' : bits1 of the groups mask
U32 | destructibleParameters.dynamicChunksGroupsMask.bits2
'destructibleParameters.dynamicChunksGroupsMask.bits2' : bits2 of the groups mask
U32 | destructibleParameters.dynamicChunksGroupsMask.bits3
'destructibleParameters.dynamicChunksGroupsMask.bits3' : bits3 of the groups mask
RuntimeFractureType destructibleParameters.runtimeFracture.RuntimeFractureType
'destructibleParameters.runtimeFracture.RuntimeFractureType' : Which type of fracture pattern to choose
Bool | destructibleParameters.runtimeFracture.sheetFracture
'destructibleParameters.runtimeFracture.sheetFracture' : If true, align fracture pattern to largest face
U32 | destructibleParameters.runtimeFracture.depthLimit
'destructibleParameters.runtimeFracture.depthLimit' : Number of times deep a chunk can be fractured.
Bool | destructibleParameters.runtimeFracture.destroyIfAtDepthLimit
'destructibleParameters.runtimeFracture.destroyIfAtDepthLimit' : Destroy chunk if at depth limit
F32 | destructibleParameters.runtimeFracture.minConvexSize
'destructibleParameters.runtimeFracture.minConvexSize' : Minimum Convex Size.
F32 | destructibleParameters.runtimeFracture.impulseScale
'destructibleParameters.runtimeFracture.impulseScale' : Scales impulse applied by a fracture.
U32 | destructibleParameters.runtimeFracture.glass.numSectors
'destructibleParameters.runtimeFracture.glass.numSectors' : Number of angular slices.
F32 | destructibleParameters.runtimeFracture.glass.sectorRand
'destructibleParameters.runtimeFracture.glass.sectorRand' : Creates variance in the angle of slices.
F32 | destructibleParameters.runtimeFracture.glass.firstSegmentSize
'destructibleParameters.runtimeFracture.glass.firstSegmentSize' : The minimum shard size.
F32 | destructibleParameters.runtimeFracture.glass.segmentScale
'destructibleParameters.runtimeFracture.glass.segmentScale' : Scales the radial spacing.
F32 | destructibleParameters.runtimeFracture.glass.segmentRand
'destructibleParameters.runtimeFracture.glass.segmentRand' : Creates variance in the radial size of shards.
Vec3 | destructibleParameters.runtimeFracture.voronoi.dimensions
'destructibleParameters.runtimeFracture.voronoi.dimensions' : The size of the entire block
U32 | destructibleParameters.runtimeFracture.voronoi.numCells
'destructibleParameters.runtimeFracture.voronoi.numCells' : Max Number of Cells to create.
F32 | destructibleParameters.runtimeFracture.voronoi.biasExp
'destructibleParameters.runtimeFracture.voronoi.biasExp' : Bias Exponential value.
F32 | destructibleParameters.runtimeFracture.voronoi.maxDist
'destructibleParameters.runtimeFracture.voronoi.maxDist' : The max distance a Voronoi point away from origin.
Bool | destructibleParameters.runtimeFracture.attachment.posX
'destructibleParameters.runtimeFracture.attachment.posX' : Attach to positive x side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.negX
'destructibleParameters.runtimeFracture.attachment.negX' : Attach to negative x side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.posY
'destructibleParameters.runtimeFracture.attachment.posY' : Attach to positive y side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.negY
'destructibleParameters.runtimeFracture.attachment.negY' : Attach to negative y side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.posZ
'destructibleParameters.runtimeFracture.attachment.posZ' : Attach to positive z side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.negZ
'destructibleParameters.runtimeFracture.attachment.negZ' : Attach to negative z side of sheet.
F32 | destructibleParameters.supportStrength
'destructibleParameters.supportStrength' : The support strength threshold for breaking chunks in stressSolver
I8 | destructibleParameters.legacyChunkBoundsTestSetting
'destructibleParameters.legacyChunkBoundsTestSetting' : Whether or not to use the old chunk bounds testing for damage, or use the module setting.
I8 | destructibleParameters.legacyDamageRadiusSpreadSetting
'destructibleParameters.legacyDamageRadiusSpreadSetting' : Whether or not to use the old damage spread method, or use the module setting.
U64 | userData
'userData' : Optional user data pointer
DestructibleActorParam actorParameters
'actorParameters' :
DestructibleActorChunks actorChunks
'actorChunks' :

Detailed Description

Describes the NxParameterized::Interface for 'DestructibleActorState' :

DestructibleActorState contains 333 fully qualified names
---------------------------------------------
  1 : Bool                 enableCrumbleEmitter
  2 : Bool                 enableDustEmitter
  3 : F32                  internalLODWeights.maxDistance
  4 : F32                  internalLODWeights.distanceWeight
  5 : F32                  internalLODWeights.maxAge
  6 : F32                  internalLODWeights.ageWeight
  7 : F32                  internalLODWeights.bias
  8 : U32                  lod
  9 : Bool                 forceLod
 10 : F32                  destructibleParameters.damageCap
 11 : F32                  destructibleParameters.forceToDamage
 12 : F32                  destructibleParameters.impactVelocityThreshold
 13 : U32                  destructibleParameters.minimumFractureDepth
 14 : I32                  destructibleParameters.impactDamageDefaultDepth
 15 : I32                  destructibleParameters.debrisDepth
 16 : U32                  destructibleParameters.essentialDepth
 17 : F32                  destructibleParameters.debrisLifetimeMin
 18 : F32                  destructibleParameters.debrisLifetimeMax
 19 : F32                  destructibleParameters.debrisMaxSeparationMin
 20 : F32                  destructibleParameters.debrisMaxSeparationMax
 21 : F32                  destructibleParameters.debrisDestructionProbability
 22 : Bounds3              destructibleParameters.validBounds
 23 : F32                  destructibleParameters.maxChunkSpeed
 24 : Bool                 destructibleParameters.flags.ACCUMULATE_DAMAGE
 25 : Bool                 destructibleParameters.flags.DEBRIS_TIMEOUT
 26 : Bool                 destructibleParameters.flags.DEBRIS_MAX_SEPARATION
 27 : Bool                 destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS
 28 : Bool                 destructibleParameters.flags.ACCURATE_RAYCASTS
 29 : Bool                 destructibleParameters.flags.USE_VALID_BOUNDS
 30 : Bool                 destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE
 31 : F32                  destructibleParameters.fractureImpulseScale
 32 : U16                  destructibleParameters.damageDepthLimit
 33 : U16                  destructibleParameters.dynamicChunkDominanceGroup
 34 : Bool                 destructibleParameters.dynamicChunksGroupsMask.useGroupsMask
 35 : U32                  destructibleParameters.dynamicChunksGroupsMask.bits0
 36 : U32                  destructibleParameters.dynamicChunksGroupsMask.bits1
 37 : U32                  destructibleParameters.dynamicChunksGroupsMask.bits2
 38 : U32                  destructibleParameters.dynamicChunksGroupsMask.bits3
 39 : RuntimeFractureType  destructibleParameters.runtimeFracture.RuntimeFractureType
 40 : Bool                 destructibleParameters.runtimeFracture.sheetFracture
 41 : U32                  destructibleParameters.runtimeFracture.depthLimit
 42 : Bool                 destructibleParameters.runtimeFracture.destroyIfAtDepthLimit
 43 : F32                  destructibleParameters.runtimeFracture.minConvexSize
 44 : F32                  destructibleParameters.runtimeFracture.impulseScale
 45 : U32                  destructibleParameters.runtimeFracture.glass.numSectors
 46 : F32                  destructibleParameters.runtimeFracture.glass.sectorRand
 47 : F32                  destructibleParameters.runtimeFracture.glass.firstSegmentSize
 48 : F32                  destructibleParameters.runtimeFracture.glass.segmentScale
 49 : F32                  destructibleParameters.runtimeFracture.glass.segmentRand
 50 : Vec3                 destructibleParameters.runtimeFracture.voronoi.dimensions
 51 : U32                  destructibleParameters.runtimeFracture.voronoi.numCells
 52 : F32                  destructibleParameters.runtimeFracture.voronoi.biasExp
 53 : F32                  destructibleParameters.runtimeFracture.voronoi.maxDist
 54 : Bool                 destructibleParameters.runtimeFracture.attachment.posX
 55 : Bool                 destructibleParameters.runtimeFracture.attachment.negX
 56 : Bool                 destructibleParameters.runtimeFracture.attachment.posY
 57 : Bool                 destructibleParameters.runtimeFracture.attachment.negY
 58 : Bool                 destructibleParameters.runtimeFracture.attachment.posZ
 59 : Bool                 destructibleParameters.runtimeFracture.attachment.negZ
 60 : F32                  destructibleParameters.supportStrength
 61 : I8                   destructibleParameters.legacyChunkBoundsTestSetting
 62 : I8                   destructibleParameters.legacyDamageRadiusSpreadSetting
 63 : U64                  userData
 64 : String               actorParameters.crumbleEmitterName                                                                RefVariant[DestructibleActorParam]
 65 : F32                  actorParameters.crumbleParticleSpacing                                                            RefVariant[DestructibleActorParam]
 66 : String               actorParameters.dustEmitterName                                                                   RefVariant[DestructibleActorParam]
 67 : F32                  actorParameters.dustParticleSpacing                                                               RefVariant[DestructibleActorParam]
 68 : Mat34                actorParameters.globalPose                                                                        RefVariant[DestructibleActorParam]
 69 : Vec3                 actorParameters.scale                                                                             RefVariant[DestructibleActorParam]
 70 : Bool                 actorParameters.dynamic                                                                           RefVariant[DestructibleActorParam]
 71 : U32                  actorParameters.supportDepth                                                                      RefVariant[DestructibleActorParam]
 72 : Bool                 actorParameters.formExtendedStructures                                                            RefVariant[DestructibleActorParam]
 73 : Bool                 actorParameters.performDetailedOverlapTestForExtendedStructures                                   RefVariant[DestructibleActorParam]
 74 : Bool                 actorParameters.keepPreviousFrameBoneBuffer                                                       RefVariant[DestructibleActorParam]
 75 : Bool                 actorParameters.doNotCreateRenderable                                                             RefVariant[DestructibleActorParam]
 76 : Bool                 actorParameters.useAssetDefinedSupport                                                            RefVariant[DestructibleActorParam]
 77 : Bool                 actorParameters.useWorldSupport                                                                   RefVariant[DestructibleActorParam]
 78 : Bool                 actorParameters.renderStaticChunksSeparately                                                      RefVariant[DestructibleActorParam]
 79 : Bool                 actorParameters.keepVisibleBonesPacked                                                            RefVariant[DestructibleActorParam]
 80 : Bool                 actorParameters.createChunkEvents                                                                 RefVariant[DestructibleActorParam]
 81 : ArraySizeName        actorParameters.overrideSkinnedMaterialNames                                                      RefVariant[DestructibleActorParam]
 82 : String               actorParameters.overrideSkinnedMaterialNames[]                                                    RefVariant[DestructibleActorParam]
 83 : ArraySizeName        actorParameters.overrideStaticMaterialNames                                                       RefVariant[DestructibleActorParam]
 84 : String               actorParameters.overrideStaticMaterialNames[]                                                     RefVariant[DestructibleActorParam]
 85 : F32                  actorParameters.sleepVelocityFrameDecayConstant                                                   RefVariant[DestructibleActorParam]
 86 : Bool                 actorParameters.useHardSleeping                                                                   RefVariant[DestructibleActorParam]
 87 : F32                  actorParameters.destructibleParameters.damageCap                                                  RefVariant[DestructibleActorParam]
 88 : F32                  actorParameters.destructibleParameters.forceToDamage                                              RefVariant[DestructibleActorParam]
 89 : F32                  actorParameters.destructibleParameters.impactVelocityThreshold                                    RefVariant[DestructibleActorParam]
 90 : U32                  actorParameters.destructibleParameters.minimumFractureDepth                                       RefVariant[DestructibleActorParam]
 91 : I32                  actorParameters.destructibleParameters.impactDamageDefaultDepth                                   RefVariant[DestructibleActorParam]
 92 : I32                  actorParameters.destructibleParameters.debrisDepth                                                RefVariant[DestructibleActorParam]
 93 : U32                  actorParameters.destructibleParameters.essentialDepth                                             RefVariant[DestructibleActorParam]
 94 : F32                  actorParameters.destructibleParameters.debrisLifetimeMin                                          RefVariant[DestructibleActorParam]
 95 : F32                  actorParameters.destructibleParameters.debrisLifetimeMax                                          RefVariant[DestructibleActorParam]
 96 : F32                  actorParameters.destructibleParameters.debrisMaxSeparationMin                                     RefVariant[DestructibleActorParam]
 97 : F32                  actorParameters.destructibleParameters.debrisMaxSeparationMax                                     RefVariant[DestructibleActorParam]
 98 : F32                  actorParameters.destructibleParameters.debrisDestructionProbability                               RefVariant[DestructibleActorParam]
 99 : Bounds3              actorParameters.destructibleParameters.validBounds                                                RefVariant[DestructibleActorParam]
100 : F32                  actorParameters.destructibleParameters.maxChunkSpeed                                              RefVariant[DestructibleActorParam]
101 : Bool                 actorParameters.destructibleParameters.flags.ACCUMULATE_DAMAGE                                    RefVariant[DestructibleActorParam]
102 : Bool                 actorParameters.destructibleParameters.flags.DEBRIS_TIMEOUT                                       RefVariant[DestructibleActorParam]
103 : Bool                 actorParameters.destructibleParameters.flags.DEBRIS_MAX_SEPARATION                                RefVariant[DestructibleActorParam]
104 : Bool                 actorParameters.destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS                              RefVariant[DestructibleActorParam]
105 : Bool                 actorParameters.destructibleParameters.flags.ACCURATE_RAYCASTS                                    RefVariant[DestructibleActorParam]
106 : Bool                 actorParameters.destructibleParameters.flags.USE_VALID_BOUNDS                                     RefVariant[DestructibleActorParam]
107 : Bool                 actorParameters.destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE                         RefVariant[DestructibleActorParam]
108 : F32                  actorParameters.destructibleParameters.fractureImpulseScale                                       RefVariant[DestructibleActorParam]
109 : U16                  actorParameters.destructibleParameters.damageDepthLimit                                           RefVariant[DestructibleActorParam]
110 : U16                  actorParameters.destructibleParameters.dynamicChunkDominanceGroup                                 RefVariant[DestructibleActorParam]
111 : Bool                 actorParameters.destructibleParameters.dynamicChunksGroupsMask.useGroupsMask                      RefVariant[DestructibleActorParam]
112 : U32                  actorParameters.destructibleParameters.dynamicChunksGroupsMask.bits0                              RefVariant[DestructibleActorParam]
113 : U32                  actorParameters.destructibleParameters.dynamicChunksGroupsMask.bits1                              RefVariant[DestructibleActorParam]
114 : U32                  actorParameters.destructibleParameters.dynamicChunksGroupsMask.bits2                              RefVariant[DestructibleActorParam]
115 : U32                  actorParameters.destructibleParameters.dynamicChunksGroupsMask.bits3                              RefVariant[DestructibleActorParam]
116 : RuntimeFractureType  actorParameters.destructibleParameters.runtimeFracture.RuntimeFractureType                        RefVariant[DestructibleActorParam]
117 : Bool                 actorParameters.destructibleParameters.runtimeFracture.sheetFracture                              RefVariant[DestructibleActorParam]
118 : U32                  actorParameters.destructibleParameters.runtimeFracture.depthLimit                                 RefVariant[DestructibleActorParam]
119 : Bool                 actorParameters.destructibleParameters.runtimeFracture.destroyIfAtDepthLimit                      RefVariant[DestructibleActorParam]
120 : F32                  actorParameters.destructibleParameters.runtimeFracture.minConvexSize                              RefVariant[DestructibleActorParam]
121 : F32                  actorParameters.destructibleParameters.runtimeFracture.impulseScale                               RefVariant[DestructibleActorParam]
122 : U32                  actorParameters.destructibleParameters.runtimeFracture.glass.numSectors                           RefVariant[DestructibleActorParam]
123 : F32                  actorParameters.destructibleParameters.runtimeFracture.glass.sectorRand                           RefVariant[DestructibleActorParam]
124 : F32                  actorParameters.destructibleParameters.runtimeFracture.glass.firstSegmentSize                     RefVariant[DestructibleActorParam]
125 : F32                  actorParameters.destructibleParameters.runtimeFracture.glass.segmentScale                         RefVariant[DestructibleActorParam]
126 : F32                  actorParameters.destructibleParameters.runtimeFracture.glass.segmentRand                          RefVariant[DestructibleActorParam]
127 : Vec3                 actorParameters.destructibleParameters.runtimeFracture.voronoi.dimensions                         RefVariant[DestructibleActorParam]
128 : U32                  actorParameters.destructibleParameters.runtimeFracture.voronoi.numCells                           RefVariant[DestructibleActorParam]
129 : F32                  actorParameters.destructibleParameters.runtimeFracture.voronoi.biasExp                            RefVariant[DestructibleActorParam]
130 : F32                  actorParameters.destructibleParameters.runtimeFracture.voronoi.maxDist                            RefVariant[DestructibleActorParam]
131 : Bool                 actorParameters.destructibleParameters.runtimeFracture.attachment.posX                            RefVariant[DestructibleActorParam]
132 : Bool                 actorParameters.destructibleParameters.runtimeFracture.attachment.negX                            RefVariant[DestructibleActorParam]
133 : Bool                 actorParameters.destructibleParameters.runtimeFracture.attachment.posY                            RefVariant[DestructibleActorParam]
134 : Bool                 actorParameters.destructibleParameters.runtimeFracture.attachment.negY                            RefVariant[DestructibleActorParam]
135 : Bool                 actorParameters.destructibleParameters.runtimeFracture.attachment.posZ                            RefVariant[DestructibleActorParam]
136 : Bool                 actorParameters.destructibleParameters.runtimeFracture.attachment.negZ                            RefVariant[DestructibleActorParam]
137 : F32                  actorParameters.destructibleParameters.supportStrength                                            RefVariant[DestructibleActorParam]
138 : I8                   actorParameters.destructibleParameters.legacyChunkBoundsTestSetting                               RefVariant[DestructibleActorParam]
139 : I8                   actorParameters.destructibleParameters.legacyDamageRadiusSpreadSetting                            RefVariant[DestructibleActorParam]
140 : ArraySizeName        actorParameters.depthParameters                                                                   RefVariant[DestructibleActorParam]
141 : Bool                 actorParameters.depthParameters[].OVERRIDE_IMPACT_DAMAGE                                          RefVariant[DestructibleActorParam]
142 : Bool                 actorParameters.depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE                                    RefVariant[DestructibleActorParam]
143 : Bool                 actorParameters.depthParameters[].IGNORE_POSE_UPDATES                                             RefVariant[DestructibleActorParam]
144 : Bool                 actorParameters.depthParameters[].IGNORE_RAYCAST_CALLBACKS                                        RefVariant[DestructibleActorParam]
145 : Bool                 actorParameters.depthParameters[].IGNORE_CONTACT_CALLBACKS                                        RefVariant[DestructibleActorParam]
146 : Bool                 actorParameters.depthParameters[].USER_FLAG_0                                                     RefVariant[DestructibleActorParam]
147 : Bool                 actorParameters.depthParameters[].USER_FLAG_1                                                     RefVariant[DestructibleActorParam]
148 : Bool                 actorParameters.depthParameters[].USER_FLAG_2                                                     RefVariant[DestructibleActorParam]
149 : Bool                 actorParameters.depthParameters[].USER_FLAG_3                                                     RefVariant[DestructibleActorParam]
150 : Bool                 actorParameters.shapeDescTemplate.flags.NX_TRIGGER_ON_ENTER                                       RefVariant[DestructibleActorParam]
151 : Bool                 actorParameters.shapeDescTemplate.flags.NX_TRIGGER_ON_LEAVE                                       RefVariant[DestructibleActorParam]
152 : Bool                 actorParameters.shapeDescTemplate.flags.NX_TRIGGER_ON_STAY                                        RefVariant[DestructibleActorParam]
153 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_VISUALIZATION                                       RefVariant[DestructibleActorParam]
154 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_DISABLE_COLLISION                                   RefVariant[DestructibleActorParam]
155 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_FEATURE_INDICES                                     RefVariant[DestructibleActorParam]
156 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_DISABLE_RAYCASTING                                  RefVariant[DestructibleActorParam]
157 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_POINT_CONTACT_FORCE                                 RefVariant[DestructibleActorParam]
158 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_FLUID_DRAIN                                         RefVariant[DestructibleActorParam]
159 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_FLUID_DISABLE_COLLISION                             RefVariant[DestructibleActorParam]
160 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_FLUID_TWOWAY                                        RefVariant[DestructibleActorParam]
161 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_DISABLE_RESPONSE                                    RefVariant[DestructibleActorParam]
162 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_DYNAMIC_DYNAMIC_CCD                                 RefVariant[DestructibleActorParam]
163 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_DISABLE_SCENE_QUERIES                               RefVariant[DestructibleActorParam]
164 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_CLOTH_DRAIN                                         RefVariant[DestructibleActorParam]
165 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_CLOTH_DISABLE_COLLISION                             RefVariant[DestructibleActorParam]
166 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_CLOTH_TWOWAY                                        RefVariant[DestructibleActorParam]
167 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_SOFTBODY_DRAIN                                      RefVariant[DestructibleActorParam]
168 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_SOFTBODY_DISABLE_COLLISION                          RefVariant[DestructibleActorParam]
169 : Bool                 actorParameters.shapeDescTemplate.flags.NX_SF_SOFTBODY_TWOWAY                                     RefVariant[DestructibleActorParam]
170 : U16                  actorParameters.shapeDescTemplate.collisionGroup                                                  RefVariant[DestructibleActorParam]
171 : Bool                 actorParameters.shapeDescTemplate.groupsMask.useGroupsMask                                        RefVariant[DestructibleActorParam]
172 : U32                  actorParameters.shapeDescTemplate.groupsMask.bits0                                                RefVariant[DestructibleActorParam]
173 : U32                  actorParameters.shapeDescTemplate.groupsMask.bits1                                                RefVariant[DestructibleActorParam]
174 : U32                  actorParameters.shapeDescTemplate.groupsMask.bits2                                                RefVariant[DestructibleActorParam]
175 : U32                  actorParameters.shapeDescTemplate.groupsMask.bits3                                                RefVariant[DestructibleActorParam]
176 : U16                  actorParameters.shapeDescTemplate.materialIndex                                                   RefVariant[DestructibleActorParam]
177 : F32                  actorParameters.shapeDescTemplate.density                                                         RefVariant[DestructibleActorParam]
178 : F32                  actorParameters.shapeDescTemplate.skinWidth                                                       RefVariant[DestructibleActorParam]
179 : U64                  actorParameters.shapeDescTemplate.userData                                                        RefVariant[DestructibleActorParam]
180 : U64                  actorParameters.shapeDescTemplate.name                                                            RefVariant[DestructibleActorParam]
181 : Bool                 actorParameters.actorDescTemplate.flags.NX_AF_DISABLE_COLLISION                                   RefVariant[DestructibleActorParam]
182 : Bool                 actorParameters.actorDescTemplate.flags.NX_AF_DISABLE_RESPONSE                                    RefVariant[DestructibleActorParam]
183 : Bool                 actorParameters.actorDescTemplate.flags.NX_AF_LOCK_COM                                            RefVariant[DestructibleActorParam]
184 : Bool                 actorParameters.actorDescTemplate.flags.NX_AF_FLUID_DISABLE_COLLISION                             RefVariant[DestructibleActorParam]
185 : Bool                 actorParameters.actorDescTemplate.flags.NX_AF_CONTACT_MODIFICATION                                RefVariant[DestructibleActorParam]
186 : Bool                 actorParameters.actorDescTemplate.flags.NX_AF_FORCE_CONE_FRICTION                                 RefVariant[DestructibleActorParam]
187 : Bool                 actorParameters.actorDescTemplate.flags.NX_AF_USER_ACTOR_PAIR_FILTERING                           RefVariant[DestructibleActorParam]
188 : F32                  actorParameters.actorDescTemplate.density                                                         RefVariant[DestructibleActorParam]
189 : U16                  actorParameters.actorDescTemplate.actorCollisionGroup                                             RefVariant[DestructibleActorParam]
190 : U16                  actorParameters.actorDescTemplate.dominanceGroup                                                  RefVariant[DestructibleActorParam]
191 : Bool                 actorParameters.actorDescTemplate.contactReportFlags.NX_IGNORE_PAIR                               RefVariant[DestructibleActorParam]
192 : Bool                 actorParameters.actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH                     RefVariant[DestructibleActorParam]
193 : Bool                 actorParameters.actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH                       RefVariant[DestructibleActorParam]
194 : Bool                 actorParameters.actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH                           RefVariant[DestructibleActorParam]
195 : Bool                 actorParameters.actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_IMPACT                          RefVariant[DestructibleActorParam]
196 : Bool                 actorParameters.actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_ROLL                            RefVariant[DestructibleActorParam]
197 : Bool                 actorParameters.actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_SLIDE                           RefVariant[DestructibleActorParam]
198 : Bool                 actorParameters.actorDescTemplate.contactReportFlags.NX_NOTIFY_FORCES                             RefVariant[DestructibleActorParam]
199 : Bool                 actorParameters.actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_START_TOUCH_FORCE_THRESHOLD     RefVariant[DestructibleActorParam]
200 : Bool                 actorParameters.actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_END_TOUCH_FORCE_THRESHOLD       RefVariant[DestructibleActorParam]
201 : Bool                 actorParameters.actorDescTemplate.contactReportFlags.NX_NOTIFY_ON_TOUCH_FORCE_THRESHOLD           RefVariant[DestructibleActorParam]
202 : Bool                 actorParameters.actorDescTemplate.contactReportFlags.NX_NOTIFY_CONTACT_MODIFICATION               RefVariant[DestructibleActorParam]
203 : U16                  actorParameters.actorDescTemplate.forceFieldMaterial                                              RefVariant[DestructibleActorParam]
204 : U64                  actorParameters.actorDescTemplate.userData                                                        RefVariant[DestructibleActorParam]
205 : U64                  actorParameters.actorDescTemplate.name                                                            RefVariant[DestructibleActorParam]
206 : U64                  actorParameters.actorDescTemplate.compartment                                                     RefVariant[DestructibleActorParam]
207 : Bool                 actorParameters.bodyDescTemplate.flags.NX_BF_DISABLE_GRAVITY                                      RefVariant[DestructibleActorParam]
208 : Bool                 actorParameters.bodyDescTemplate.flags.NX_BF_FILTER_SLEEP_VEL                                     RefVariant[DestructibleActorParam]
209 : Bool                 actorParameters.bodyDescTemplate.flags.NX_BF_ENERGY_SLEEP_TEST                                    RefVariant[DestructibleActorParam]
210 : Bool                 actorParameters.bodyDescTemplate.flags.NX_BF_VISUALIZATION                                        RefVariant[DestructibleActorParam]
211 : F32                  actorParameters.bodyDescTemplate.wakeUpCounter                                                    RefVariant[DestructibleActorParam]
212 : F32                  actorParameters.bodyDescTemplate.linearDamping                                                    RefVariant[DestructibleActorParam]
213 : F32                  actorParameters.bodyDescTemplate.angularDamping                                                   RefVariant[DestructibleActorParam]
214 : F32                  actorParameters.bodyDescTemplate.maxAngularVelocity                                               RefVariant[DestructibleActorParam]
215 : F32                  actorParameters.bodyDescTemplate.CCDMotionThreshold                                               RefVariant[DestructibleActorParam]
216 : F32                  actorParameters.bodyDescTemplate.sleepLinearVelocity                                              RefVariant[DestructibleActorParam]
217 : F32                  actorParameters.bodyDescTemplate.sleepAngularVelocity                                             RefVariant[DestructibleActorParam]
218 : U32                  actorParameters.bodyDescTemplate.solverIterationCount                                             RefVariant[DestructibleActorParam]
219 : F32                  actorParameters.bodyDescTemplate.sleepEnergyThreshold                                             RefVariant[DestructibleActorParam]
220 : F32                  actorParameters.bodyDescTemplate.sleepDamping                                                     RefVariant[DestructibleActorParam]
221 : F32                  actorParameters.bodyDescTemplate.contactReportThreshold                                           RefVariant[DestructibleActorParam]
222 : Bool                 actorParameters.p3ShapeDescTemplate.flags.eSIMULATION_SHAPE                                       RefVariant[DestructibleActorParam]
223 : Bool                 actorParameters.p3ShapeDescTemplate.flags.eSCENE_QUERY_SHAPE                                      RefVariant[DestructibleActorParam]
224 : Bool                 actorParameters.p3ShapeDescTemplate.flags.eTRIGGER_SHAPE                                          RefVariant[DestructibleActorParam]
225 : Bool                 actorParameters.p3ShapeDescTemplate.flags.eVISUALIZATION                                          RefVariant[DestructibleActorParam]
226 : Bool                 actorParameters.p3ShapeDescTemplate.flags.ePARTICLE_DRAIN                                         RefVariant[DestructibleActorParam]
227 : Bool                 actorParameters.p3ShapeDescTemplate.flags.eDEFORMABLE_DRAIN                                       RefVariant[DestructibleActorParam]
228 : U32                  actorParameters.p3ShapeDescTemplate.simulationFilterData.word0                                    RefVariant[DestructibleActorParam]
229 : U32                  actorParameters.p3ShapeDescTemplate.simulationFilterData.word1                                    RefVariant[DestructibleActorParam]
230 : U32                  actorParameters.p3ShapeDescTemplate.simulationFilterData.word2                                    RefVariant[DestructibleActorParam]
231 : U32                  actorParameters.p3ShapeDescTemplate.simulationFilterData.word3                                    RefVariant[DestructibleActorParam]
232 : U32                  actorParameters.p3ShapeDescTemplate.queryFilterData.word0                                         RefVariant[DestructibleActorParam]
233 : U32                  actorParameters.p3ShapeDescTemplate.queryFilterData.word1                                         RefVariant[DestructibleActorParam]
234 : U32                  actorParameters.p3ShapeDescTemplate.queryFilterData.word2                                         RefVariant[DestructibleActorParam]
235 : U32                  actorParameters.p3ShapeDescTemplate.queryFilterData.word3                                         RefVariant[DestructibleActorParam]
236 : U64                  actorParameters.p3ShapeDescTemplate.material                                                      RefVariant[DestructibleActorParam]
237 : F32                  actorParameters.p3ShapeDescTemplate.contactOffset                                                 RefVariant[DestructibleActorParam]
238 : F32                  actorParameters.p3ShapeDescTemplate.restOffset                                                    RefVariant[DestructibleActorParam]
239 : U64                  actorParameters.p3ShapeDescTemplate.userData                                                      RefVariant[DestructibleActorParam]
240 : U64                  actorParameters.p3ShapeDescTemplate.name                                                          RefVariant[DestructibleActorParam]
241 : Bool                 actorParameters.p3ActorDescTemplate.flags.eVISUALIZATION                                          RefVariant[DestructibleActorParam]
242 : Bool                 actorParameters.p3ActorDescTemplate.flags.eDISABLE_GRAVITY                                        RefVariant[DestructibleActorParam]
243 : Bool                 actorParameters.p3ActorDescTemplate.flags.eSEND_SLEEP_NOTIFIES                                    RefVariant[DestructibleActorParam]
244 : U8                   actorParameters.p3ActorDescTemplate.dominanceGroup                                                RefVariant[DestructibleActorParam]
245 : U8                   actorParameters.p3ActorDescTemplate.ownerClient                                                   RefVariant[DestructibleActorParam]
246 : U32                  actorParameters.p3ActorDescTemplate.clientBehaviorBits                                            RefVariant[DestructibleActorParam]
247 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eRESOLVE_CONTACTS                          RefVariant[DestructibleActorParam]
248 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eMODIFY_CONTACTS                           RefVariant[DestructibleActorParam]
249 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_FOUND                        RefVariant[DestructibleActorParam]
250 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_PERSISTS                     RefVariant[DestructibleActorParam]
251 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eNOTIFY_TOUCH_LOST                         RefVariant[DestructibleActorParam]
252 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_FOUND              RefVariant[DestructibleActorParam]
253 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_PERSISTS           RefVariant[DestructibleActorParam]
254 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eNOTIFY_THRESHOLD_FORCE_LOST               RefVariant[DestructibleActorParam]
255 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_POINTS                     RefVariant[DestructibleActorParam]
256 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCES                     RefVariant[DestructibleActorParam]
257 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FORCE_PER_POINT            RefVariant[DestructibleActorParam]
258 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eNOTIFY_CONTACT_FEATURE_INDICES_PER_POINT  RefVariant[DestructibleActorParam]
259 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eCCD_LINEAR                                RefVariant[DestructibleActorParam]
260 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eCONTACT_DEFAULT                           RefVariant[DestructibleActorParam]
261 : Bool                 actorParameters.p3ActorDescTemplate.contactReportFlags.eTRIGGER_DEFAULT                           RefVariant[DestructibleActorParam]
262 : U64                  actorParameters.p3ActorDescTemplate.userData                                                      RefVariant[DestructibleActorParam]
263 : U64                  actorParameters.p3ActorDescTemplate.name                                                          RefVariant[DestructibleActorParam]
264 : F32                  actorParameters.p3BodyDescTemplate.density                                                        RefVariant[DestructibleActorParam]
265 : Bool                 actorParameters.p3BodyDescTemplate.flags.eKINEMATIC                                               RefVariant[DestructibleActorParam]
266 : Bool                 actorParameters.p3BodyDescTemplate.flags.eENABLE_CCD                                              RefVariant[DestructibleActorParam]
267 : F32                  actorParameters.p3BodyDescTemplate.sleepThreshold                                                 RefVariant[DestructibleActorParam]
268 : F32                  actorParameters.p3BodyDescTemplate.wakeUpCounter                                                  RefVariant[DestructibleActorParam]
269 : F32                  actorParameters.p3BodyDescTemplate.linearDamping                                                  RefVariant[DestructibleActorParam]
270 : F32                  actorParameters.p3BodyDescTemplate.angularDamping                                                 RefVariant[DestructibleActorParam]
271 : F32                  actorParameters.p3BodyDescTemplate.maxAngularVelocity                                             RefVariant[DestructibleActorParam]
272 : U32                  actorParameters.p3BodyDescTemplate.solverIterationCount                                           RefVariant[DestructibleActorParam]
273 : U32                  actorParameters.p3BodyDescTemplate.velocityIterationCount                                         RefVariant[DestructibleActorParam]
274 : F32                  actorParameters.p3BodyDescTemplate.contactReportThreshold                                         RefVariant[DestructibleActorParam]
275 : F32                  actorParameters.p3BodyDescTemplate.sleepLinearVelocity                                            RefVariant[DestructibleActorParam]
276 : Bool                 actorParameters.structureSettings.useStressSolver                                                 RefVariant[DestructibleActorParam]
277 : F32                  actorParameters.structureSettings.stressSolverTimeDelay                                           RefVariant[DestructibleActorParam]
278 : F32                  actorParameters.structureSettings.stressSolverMassThreshold                                       RefVariant[DestructibleActorParam]
279 : String               actorParameters.defaultBehaviorGroup.name                                                         RefVariant[DestructibleActorParam]
280 : F32                  actorParameters.defaultBehaviorGroup.damageThreshold                                              RefVariant[DestructibleActorParam]
281 : F32                  actorParameters.defaultBehaviorGroup.damageToRadius                                               RefVariant[DestructibleActorParam]
282 : F32                  actorParameters.defaultBehaviorGroup.damageSpread.minimumRadius                                   RefVariant[DestructibleActorParam]
283 : F32                  actorParameters.defaultBehaviorGroup.damageSpread.radiusMultiplier                                RefVariant[DestructibleActorParam]
284 : F32                  actorParameters.defaultBehaviorGroup.damageSpread.falloffExponent                                 RefVariant[DestructibleActorParam]
285 : F32                  actorParameters.defaultBehaviorGroup.damageColorSpread.minimumRadius                              RefVariant[DestructibleActorParam]
286 : F32                  actorParameters.defaultBehaviorGroup.damageColorSpread.radiusMultiplier                           RefVariant[DestructibleActorParam]
287 : F32                  actorParameters.defaultBehaviorGroup.damageColorSpread.falloffExponent                            RefVariant[DestructibleActorParam]
288 : Vec4                 actorParameters.defaultBehaviorGroup.damageColorChange                                            RefVariant[DestructibleActorParam]
289 : F32                  actorParameters.defaultBehaviorGroup.materialStrength                                             RefVariant[DestructibleActorParam]
290 : F32                  actorParameters.defaultBehaviorGroup.density                                                      RefVariant[DestructibleActorParam]
291 : F32                  actorParameters.defaultBehaviorGroup.fadeOut                                                      RefVariant[DestructibleActorParam]
292 : F32                  actorParameters.defaultBehaviorGroup.maxDepenetrationVelocity                                     RefVariant[DestructibleActorParam]
293 : Bool                 actorParameters.defaultBehaviorGroup.groupsMask.useGroupsMask                                     RefVariant[DestructibleActorParam]
294 : U32                  actorParameters.defaultBehaviorGroup.groupsMask.bits0                                             RefVariant[DestructibleActorParam]
295 : U32                  actorParameters.defaultBehaviorGroup.groupsMask.bits1                                             RefVariant[DestructibleActorParam]
296 : U32                  actorParameters.defaultBehaviorGroup.groupsMask.bits2                                             RefVariant[DestructibleActorParam]
297 : U32                  actorParameters.defaultBehaviorGroup.groupsMask.bits3                                             RefVariant[DestructibleActorParam]
298 : U64                  actorParameters.defaultBehaviorGroup.userData                                                     RefVariant[DestructibleActorParam]
299 : ArraySizeName        actorParameters.behaviorGroups                                                                    RefVariant[DestructibleActorParam]
300 : String               actorParameters.behaviorGroups[].name                                                             RefVariant[DestructibleActorParam]
301 : F32                  actorParameters.behaviorGroups[].damageThreshold                                                  RefVariant[DestructibleActorParam]
302 : F32                  actorParameters.behaviorGroups[].damageToRadius                                                   RefVariant[DestructibleActorParam]
303 : F32                  actorParameters.behaviorGroups[].damageSpread.minimumRadius                                       RefVariant[DestructibleActorParam]
304 : F32                  actorParameters.behaviorGroups[].damageSpread.radiusMultiplier                                    RefVariant[DestructibleActorParam]
305 : F32                  actorParameters.behaviorGroups[].damageSpread.falloffExponent                                     RefVariant[DestructibleActorParam]
306 : F32                  actorParameters.behaviorGroups[].damageColorSpread.minimumRadius                                  RefVariant[DestructibleActorParam]
307 : F32                  actorParameters.behaviorGroups[].damageColorSpread.radiusMultiplier                               RefVariant[DestructibleActorParam]
308 : F32                  actorParameters.behaviorGroups[].damageColorSpread.falloffExponent                                RefVariant[DestructibleActorParam]
309 : Vec4                 actorParameters.behaviorGroups[].damageColorChange                                                RefVariant[DestructibleActorParam]
310 : F32                  actorParameters.behaviorGroups[].materialStrength                                                 RefVariant[DestructibleActorParam]
311 : F32                  actorParameters.behaviorGroups[].density                                                          RefVariant[DestructibleActorParam]
312 : F32                  actorParameters.behaviorGroups[].fadeOut                                                          RefVariant[DestructibleActorParam]
313 : F32                  actorParameters.behaviorGroups[].maxDepenetrationVelocity                                         RefVariant[DestructibleActorParam]
314 : Bool                 actorParameters.behaviorGroups[].groupsMask.useGroupsMask                                         RefVariant[DestructibleActorParam]
315 : U32                  actorParameters.behaviorGroups[].groupsMask.bits0                                                 RefVariant[DestructibleActorParam]
316 : U32                  actorParameters.behaviorGroups[].groupsMask.bits1                                                 RefVariant[DestructibleActorParam]
317 : U32                  actorParameters.behaviorGroups[].groupsMask.bits2                                                 RefVariant[DestructibleActorParam]
318 : U32                  actorParameters.behaviorGroups[].groupsMask.bits3                                                 RefVariant[DestructibleActorParam]
319 : U64                  actorParameters.behaviorGroups[].userData                                                         RefVariant[DestructibleActorParam]
320 : Bool                 actorParameters.deleteChunksLeavingUserDefinedBB                                                  RefVariant[DestructibleActorParam]
321 : Bool                 actorParameters.deleteChunksEnteringUserDefinedBB                                                 RefVariant[DestructibleActorParam]
322 : ArraySizeName        actorChunks.data                                                                                  RefVariant[DestructibleActorChunks]
323 : U8                   actorChunks.data[].state                                                                          RefVariant[DestructibleActorChunks]
324 : U8                   actorChunks.data[].flags                                                                          RefVariant[DestructibleActorChunks]
325 : U32                  actorChunks.data[].islandID                                                                       RefVariant[DestructibleActorChunks]
326 : F32                  actorChunks.data[].damage                                                                         RefVariant[DestructibleActorChunks]
327 : Vec4                 actorChunks.data[].localSphere                                                                    RefVariant[DestructibleActorChunks]
328 : Vec3                 actorChunks.data[].localOffset                                                                    RefVariant[DestructibleActorChunks]
329 : I32                  actorChunks.data[].visibleAncestorIndex                                                           RefVariant[DestructibleActorChunks]
330 : U32                  actorChunks.data[].shapesCount                                                                    RefVariant[DestructibleActorChunks]
331 : Transform            actorChunks.data[].globalPose                                                                     RefVariant[DestructibleActorChunks]
332 : Vec3                 actorChunks.data[].linearVelocity                                                                 RefVariant[DestructibleActorChunks]
333 : Vec3                 actorChunks.data[].angularVelocity                                                                RefVariant[DestructibleActorChunks]

Member Data Documentation

DestructibleActorChunks DestructibleActorState::actorChunks

'actorChunks' :

DestructibleActorParam DestructibleActorState::actorParameters

'actorParameters' :

F32 DestructibleActorState::destructibleParameters.damageCap

'destructibleParameters.damageCap' : Limits the amount of damage applied to a chunk.

Limits the amount of damage applied to a chunk. This is useful for preventing the entire destructible from getting pulverized by a very large application of damage. This can easily happen when impact damage is used, and the damage amount is proportional to the impact force (see forceToDamage).

U16 DestructibleActorState::destructibleParameters.damageDepthLimit

'destructibleParameters.damageDepthLimit' : How deep in the hierarchy damage will be propagated, relative to the chunk hit.

How deep in the hierarchy damage will be propagated, relative to the chunk hit.

I32 DestructibleActorState::destructibleParameters.debrisDepth

'destructibleParameters.debrisDepth' : The chunk hierarchy depth at which chunks are considered to be 'debris.'

The chunk hierarchy depth at which chunks are considered to be 'debris.' Chunks at this depth or below will be considered for various debris settings, such as debrisLifetime. Negative values indicate that no chunk depth is considered debris. Default value is -1.

F32 DestructibleActorState::destructibleParameters.debrisDestructionProbability

'destructibleParameters.debrisDestructionProbability' : The probablity that a debris chunk, when fractured, will simply be destroyed

The probablity that a debris chunk, when fractured, will simply be destroyed instead of becoming dynamic or breaking down further into child chunks. Valid range = [0.0,1.0]. Default value = 0.0.

F32 DestructibleActorState::destructibleParameters.debrisLifetimeMax

'destructibleParameters.debrisLifetimeMax' : Maximum time to destroy debris

'Debris chunks' (see debrisDepth, above) will be destroyed after a time (in seconds) separated from non-debris chunks. The actual lifetime is interpolated between debrisLifetimeMin (see above) and debrisLifetimeMax, based upon the module's LOD setting. To disable lifetime, clear the NxDestructibleDepthParametersFlag::DEBRIS_TIMEOUT flag in the flags field. If debrisLifetimeMax < debrisLifetimeMin, the mean of the two is used for both. Default debrisLifetimeMin = 1.0, debrisLifetimeMax = 10.0f.

F32 DestructibleActorState::destructibleParameters.debrisLifetimeMin

'destructibleParameters.debrisLifetimeMin' : Minimum time to destroy debris

'Debris chunks' (see debrisDepth, above) will be destroyed after a time (in seconds) separated from non-debris chunks. The actual lifetime is interpolated between debrisLifetimeMin and debrisLifetimeMax (see below), based upon the module's LOD setting. To disable lifetime, clear the NxDestructibleDepthParametersFlag::DEBRIS_TIMEOUT flag in the flags field. If debrisLifetimeMax < debrisLifetimeMin, the mean of the two is used for both. Default debrisLifetimeMin = 1.0, debrisLifetimeMax = 10.0f.

F32 DestructibleActorState::destructibleParameters.debrisMaxSeparationMax

'destructibleParameters.debrisMaxSeparationMax' : Minimum separation distance

'Debris chunks' (see debrisDepth, above) will be destroyed if they are separated from their origin by a distance greater than maxSeparation. The actual maxSeparation is interpolated between debrisMaxSeparationMin (see above) and debrisMaxSeparationMax, based upon the module's LOD setting. To disable maxSeparation, clear the NX_DESTRUCTIBLE_DEBRIS_MAX_SEPARATION flag in the flags field. If debrisMaxSeparationMax < debrisMaxSeparationMin, the mean of the two is used for both. Default debrisMaxSeparationMin = 1.0, debrisMaxSeparationMax = 10.0f.

F32 DestructibleActorState::destructibleParameters.debrisMaxSeparationMin

'destructibleParameters.debrisMaxSeparationMin' : Minimum separation distance

'Debris chunks' (see debrisDepth, above) will be destroyed if they are separated from their origin by a distance greater than maxSeparation. The actual maxSeparation is interpolated between debrisMaxSeparationMin and debrisMaxSeparationMax (see below), based upon the module's LOD setting. To disable maxSeparation, clear the NX_DESTRUCTIBLE_DEBRIS_MAX_SEPARATION flag in the flags field. If debrisMaxSeparationMax < debrisMaxSeparationMin, the mean of the two is used for both. Default debrisMaxSeparationMin = 1.0, debrisMaxSeparationMax = 10.0f.

U16 DestructibleActorState::destructibleParameters.dynamicChunkDominanceGroup

'destructibleParameters.dynamicChunkDominanceGroup' : Optional dominance group for dynamic chunks created when fractured.

Optional dominance group for dynamic chunks created when fractured. (ignored if > 31)

U32 DestructibleActorState::destructibleParameters.dynamicChunksGroupsMask.bits0

'destructibleParameters.dynamicChunksGroupsMask.bits0' : bits0 of the groups mask

If useGroupsMask is true, this is bits0 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorState::destructibleParameters.dynamicChunksGroupsMask.bits1

'destructibleParameters.dynamicChunksGroupsMask.bits1' : bits1 of the groups mask

If useGroupsMask is true, this is bits1 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorState::destructibleParameters.dynamicChunksGroupsMask.bits2

'destructibleParameters.dynamicChunksGroupsMask.bits2' : bits2 of the groups mask

If useGroupsMask is true, this is bits2 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleActorState::destructibleParameters.dynamicChunksGroupsMask.bits3

'destructibleParameters.dynamicChunksGroupsMask.bits3' : bits3 of the groups mask

If useGroupsMask is true, this is bits3 of the groups mask. See the PhysX documentation for more on groups masks.

Bool DestructibleActorState::destructibleParameters.dynamicChunksGroupsMask.useGroupsMask

'destructibleParameters.dynamicChunksGroupsMask.useGroupsMask' : Whether or not the groupsMask should be used

Whether or not the groupsMask should be used. If so, then this will be applied to all NxShapes created to represent this destructible's chunks.

U32 DestructibleActorState::destructibleParameters.essentialDepth

'destructibleParameters.essentialDepth' : The chunk hierarchy depth up to which chunks will always be processed

The chunk hierarchy depth up to which chunks will always be processed. These chunks are considered to be essential either for gameplay or visually. The minimum value is 0, meaning the level 0 chunk is always considered essential. Default value is 0.

Bool DestructibleActorState::destructibleParameters.flags.ACCUMULATE_DAMAGE

'destructibleParameters.flags.ACCUMULATE_DAMAGE' : Determines if chunks accumulate damage

If set, chunks will 'remember' damage applied to them, so that many applications of a damage amount below damageThreshold will eventually fracture the chunk. If not set, a single application of damage must exceed damageThreshold in order to fracture the chunk.

Bool DestructibleActorState::destructibleParameters.flags.ACCURATE_RAYCASTS

'destructibleParameters.flags.ACCURATE_RAYCASTS' : If set, the NxDestructibleActor::rayCast function will search within the nearest visible chunk hit

If set, the NxDestructibleActor::rayCast function will search within the nearest visible chunk hit for collisions with child chunks. This is used to get a better raycast position and normal, in case the parent collision volume does not tightly fit the graphics mesh. The returned chunk index will always be that of the visible parent that is intersected, however.

Bool DestructibleActorState::destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS

'destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS' : If set, the smallest chunks may be further broken down

If set, the smallest chunks may be further broken down, either by fluid crumbles (if a crumble particle system is specified in the NxDestructibleActorDesc), or by simply removing the chunk if no crumble particle system is specified. Note: the 'smallest chunks' are normally defined to be the deepest level of the fracture hierarchy. However, they may be taken from higher levels of the hierarchy if NxModuleDestructible::setMaxChunkDepthOffset is called with a non-zero value.

Bool DestructibleActorState::destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE

'destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE' : If set, crumbled chunks will use the runtime fracture pipeline.

If set, crumbled chunks will use the runtime fracture pipeline. The chunk will be procedurally broken destroyed using either the default or a specified fracture pattern.

Bool DestructibleActorState::destructibleParameters.flags.DEBRIS_MAX_SEPARATION

'destructibleParameters.flags.DEBRIS_MAX_SEPARATION' : Whether or not chunks at or deeper than the 'debris' depth will be removed if separated too far

Whether or not chunks at or deeper than the 'debris' depth (see NxDestructibleParameters::debrisDepth) will be removed if they separate too far from their origins. The maxSeparation is a value between NxDestructibleParameters::debrisMaxSeparationMin and NxDestructibleParameters::debrisMaxSeparationMax, based upon the destructible module's LOD setting.

Bool DestructibleActorState::destructibleParameters.flags.DEBRIS_TIMEOUT

'destructibleParameters.flags.DEBRIS_TIMEOUT' : Whether or not chunks at or deeper than the 'debris' depth will timeout

Whether or not chunks at or deeper than the 'debris' depth (see NxDestructibleParameters::debrisDepth) will time out. The lifetime is a value between NxDestructibleParameters::debrisLifetimeMin and NxDestructibleParameters::debrisLifetimeMax, based upon the destructible module's LOD setting.

Bool DestructibleActorState::destructibleParameters.flags.USE_VALID_BOUNDS

'destructibleParameters.flags.USE_VALID_BOUNDS' : If set, the validBounds field of NxDestructibleParameters will be used.

If set, the validBounds field of NxDestructibleParameters will be used. These bounds are translated (but not scaled or rotated) to the origin of the destructible actor. If a chunk or chunk island moves outside of those bounds, it is destroyed.

F32 DestructibleActorState::destructibleParameters.forceToDamage

'destructibleParameters.forceToDamage' : Multiplier to calculate applied damage from an impact.

If a chunk is at a depth which takes impact damage (see NxDestructibleDepthParameters), then when a chunk has a collision in the NxScene, it will take damage equal to forceToDamage mulitplied by the impact force. The default value is zero, which effectively disables impact damage.

F32 DestructibleActorState::destructibleParameters.fractureImpulseScale

'destructibleParameters.fractureImpulseScale' : Scale factor used to apply an impulse force along the normal of chunk when fractured.

Scale factor used to apply an impulse force along the normal of chunk when fractured. This is used in order to 'push' the pieces out as they fracture.

I32 DestructibleActorState::destructibleParameters.impactDamageDefaultDepth

'destructibleParameters.impactDamageDefaultDepth' : The default depth to which chunks will take impact damage.

The default depth to which chunks will take impact damage. This default may be overridden in the depth settings.

F32 DestructibleActorState::destructibleParameters.impactVelocityThreshold

'destructibleParameters.impactVelocityThreshold' : Large impact force may be reported if rigid bodies are spawned inside one another.

Large impact force may be reported if rigid bodies are spawned inside one another. In this case the relative velocity of the two objects will be low. This variable allows the user to set a minimum velocity threshold for impacts to ensure that the objects are moving at a min velocity in order for the impact force to be considered.

I8 DestructibleActorState::destructibleParameters.legacyChunkBoundsTestSetting

'destructibleParameters.legacyChunkBoundsTestSetting' : Whether or not to use the old chunk bounds testing for damage, or use the module setting.

Whether or not to use the old chunk bounds testing for damage, or use the module setting. A value of 0 forces the new method to be used. A positive value forces the old method to be used. Negative values cause the global (NxModuleDestructible) setting to be used.

I8 DestructibleActorState::destructibleParameters.legacyDamageRadiusSpreadSetting

'destructibleParameters.legacyDamageRadiusSpreadSetting' : Whether or not to use the old damage spread method, or use the module setting.

Whether or not to use the old damage spread method, or use the module setting. A value of 0 forces the new method to be used. A positive value forces the old method to be used. Negative values cause the global (NxModuleDestructible) setting to be used.

F32 DestructibleActorState::destructibleParameters.maxChunkSpeed

'destructibleParameters.maxChunkSpeed' : Maximum speed of a chunk

If greater than 0, the chunks' speeds will not be allowed to exceed this value. Use 0 to disable this feature (this is the default).

U32 DestructibleActorState::destructibleParameters.minimumFractureDepth

'destructibleParameters.minimumFractureDepth' : The chunks will not be broken free below this depth.

Chunks will not be broken free below this depth.

Bool DestructibleActorState::destructibleParameters.runtimeFracture.attachment.negX

'destructibleParameters.runtimeFracture.attachment.negX' : Attach to negative x side of sheet.

If true, make the negative x side of the sheet an attachment point.

Bool DestructibleActorState::destructibleParameters.runtimeFracture.attachment.negY

'destructibleParameters.runtimeFracture.attachment.negY' : Attach to negative y side of sheet.

If true, make the negative y side of the sheet an attachment point.

Bool DestructibleActorState::destructibleParameters.runtimeFracture.attachment.negZ

'destructibleParameters.runtimeFracture.attachment.negZ' : Attach to negative z side of sheet.

If true, make the negative z side of the sheet an attachment point.

Bool DestructibleActorState::destructibleParameters.runtimeFracture.attachment.posX

'destructibleParameters.runtimeFracture.attachment.posX' : Attach to positive x side of sheet.

If true, make the positive x side of the sheet an attachment point.

Bool DestructibleActorState::destructibleParameters.runtimeFracture.attachment.posY

'destructibleParameters.runtimeFracture.attachment.posY' : Attach to positive y side of sheet.

If true, make the positive y side of the sheet an attachment point.

Bool DestructibleActorState::destructibleParameters.runtimeFracture.attachment.posZ

'destructibleParameters.runtimeFracture.attachment.posZ' : Attach to positive z side of sheet.

If true, make the positive z side of the sheet an attachment point.

U32 DestructibleActorState::destructibleParameters.runtimeFracture.depthLimit

'destructibleParameters.runtimeFracture.depthLimit' : Number of times deep a chunk can be fractured.

Number of times deep a chunk can be fractured. Can help limit the number of chunks produced by runtime fracture.

Bool DestructibleActorState::destructibleParameters.runtimeFracture.destroyIfAtDepthLimit

'destructibleParameters.runtimeFracture.destroyIfAtDepthLimit' : Destroy chunk if at depth limit

If true, destroy chunks when they hit their depth limit. If false, then chunks at their depth limit will not fracture but will have a force applied.

F32 DestructibleActorState::destructibleParameters.runtimeFracture.glass.firstSegmentSize

'destructibleParameters.runtimeFracture.glass.firstSegmentSize' : The minimum shard size.

The minimum shard size. Shards below this size will not be created and thus not visible.

U32 DestructibleActorState::destructibleParameters.runtimeFracture.glass.numSectors

'destructibleParameters.runtimeFracture.glass.numSectors' : Number of angular slices.

Number of angular slices in the glass fracture pattern.

F32 DestructibleActorState::destructibleParameters.runtimeFracture.glass.sectorRand

'destructibleParameters.runtimeFracture.glass.sectorRand' : Creates variance in the angle of slices.

Creates variance in the angle of slices. A value of zero results in all angular slices having the same angle.

F32 DestructibleActorState::destructibleParameters.runtimeFracture.glass.segmentRand

'destructibleParameters.runtimeFracture.glass.segmentRand' : Creates variance in the radial size of shards.

Creates variance in the radial size of shards. A value of zero results in a low noise circular pattern.

F32 DestructibleActorState::destructibleParameters.runtimeFracture.glass.segmentScale

'destructibleParameters.runtimeFracture.glass.segmentScale' : Scales the radial spacing.

Scales the radial spacing in the glass fracture pattern. A larger value results in radially longer shards.

F32 DestructibleActorState::destructibleParameters.runtimeFracture.impulseScale

'destructibleParameters.runtimeFracture.impulseScale' : Scales impulse applied by a fracture.

Scales impulse applied by a fracture.

F32 DestructibleActorState::destructibleParameters.runtimeFracture.minConvexSize

'destructibleParameters.runtimeFracture.minConvexSize' : Minimum Convex Size.

Minimum Convex Size. Minimum size of convex produced by a fracture.

RuntimeFractureType DestructibleActorState::destructibleParameters.runtimeFracture.RuntimeFractureType

'destructibleParameters.runtimeFracture.RuntimeFractureType' : Which type of fracture pattern to choose

Bool DestructibleActorState::destructibleParameters.runtimeFracture.sheetFracture

'destructibleParameters.runtimeFracture.sheetFracture' : If true, align fracture pattern to largest face

If true, align fracture pattern to largest face. If false, the fracture pattern will be aligned to the hit normal with each fracture.

F32 DestructibleActorState::destructibleParameters.runtimeFracture.voronoi.biasExp

'destructibleParameters.runtimeFracture.voronoi.biasExp' : Bias Exponential value.

Bias Exponential value is used in distributing voronoi points which is used to fracture the original chunk.

Vec3 DestructibleActorState::destructibleParameters.runtimeFracture.voronoi.dimensions

'destructibleParameters.runtimeFracture.voronoi.dimensions' : The size of the entire block

The size of the entire block.

F32 DestructibleActorState::destructibleParameters.runtimeFracture.voronoi.maxDist

'destructibleParameters.runtimeFracture.voronoi.maxDist' : The max distance a Voronoi point away from origin.

This is to prevent a illegal voronoi point that's used to generate voronoi chunks.

U32 DestructibleActorState::destructibleParameters.runtimeFracture.voronoi.numCells

'destructibleParameters.runtimeFracture.voronoi.numCells' : Max Number of Cells to create.

Number of Cells corresponds to the number of chunks to create during the fracture, default value is only one chunk.

F32 DestructibleActorState::destructibleParameters.supportStrength

'destructibleParameters.supportStrength' : The support strength threshold for breaking chunks in stressSolver

The larger the supportStrength is, the harder it will break under stressSolver. SupportStrength should be larger than 0.0 so that it is not extremely fragile. Default supportStrength = -1.0 which means strength is turned off initially.

Bounds3 DestructibleActorState::destructibleParameters.validBounds

'destructibleParameters.validBounds' : valid bounding region for debris

A bounding box around each NxDestructibleActor created, defining a range of validity for chunks that break free. These bounds are scaled and translated with the NxDestructibleActor's scale and position, but they are not rotated with the NxDestructibleActor.

Bool DestructibleActorState::enableCrumbleEmitter

'enableCrumbleEmitter' : Whether or not the crumble emitter is active

Whether or not the crumble emitter is active.

Bool DestructibleActorState::enableDustEmitter

'enableDustEmitter' : Whether or not the dust emitter is active

Whether or not the dust emitter is active.

Bool DestructibleActorState::forceLod

'forceLod' : Whether or not to force LOD behavior on the actor

Whether or not to force LOD behavior on the actor.

F32 DestructibleActorState::internalLODWeights.ageWeight

'internalLODWeights.ageWeight' : Helpful documentation goes here

F32 DestructibleActorState::internalLODWeights.bias

'internalLODWeights.bias' : Helpful documentation goes here

F32 DestructibleActorState::internalLODWeights.distanceWeight

'internalLODWeights.distanceWeight' : Helpful documentation goes here

F32 DestructibleActorState::internalLODWeights.maxAge

'internalLODWeights.maxAge' : Helpful documentation goes here

F32 DestructibleActorState::internalLODWeights.maxDistance

'internalLODWeights.maxDistance' : Helpful documentation goes here

U32 DestructibleActorState::lod

'lod' : Destructible actor LOD

Destructible actor LOD.

U64 DestructibleActorState::userData

'userData' : Optional user data pointer

Optional user data pointer. Note: Any pointer references will not be properly serialized.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
DestructibleActorState Member List
This is the complete list of members for DestructibleActorState, including all inherited members.
actorChunks | DestructibleActorState
actorParameters | DestructibleActorState
destructibleParameters.damageCap | DestructibleActorState
destructibleParameters.damageDepthLimit | DestructibleActorState
destructibleParameters.debrisDepth | DestructibleActorState
destructibleParameters.debrisDestructionProbability | DestructibleActorState
destructibleParameters.debrisLifetimeMax | DestructibleActorState
destructibleParameters.debrisLifetimeMin | DestructibleActorState
destructibleParameters.debrisMaxSeparationMax | DestructibleActorState
destructibleParameters.debrisMaxSeparationMin | DestructibleActorState
destructibleParameters.dynamicChunkDominanceGroup | DestructibleActorState
destructibleParameters.dynamicChunksGroupsMask.bits0 | DestructibleActorState
destructibleParameters.dynamicChunksGroupsMask.bits1 | DestructibleActorState
destructibleParameters.dynamicChunksGroupsMask.bits2 | DestructibleActorState
destructibleParameters.dynamicChunksGroupsMask.bits3 | DestructibleActorState
destructibleParameters.dynamicChunksGroupsMask.useGroupsMask | DestructibleActorState
destructibleParameters.essentialDepth | DestructibleActorState
destructibleParameters.flags.ACCUMULATE_DAMAGE | DestructibleActorState
destructibleParameters.flags.ACCURATE_RAYCASTS | DestructibleActorState
destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS | DestructibleActorState
destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE | DestructibleActorState
destructibleParameters.flags.DEBRIS_MAX_SEPARATION | DestructibleActorState
destructibleParameters.flags.DEBRIS_TIMEOUT | DestructibleActorState
destructibleParameters.flags.USE_VALID_BOUNDS | DestructibleActorState
destructibleParameters.forceToDamage | DestructibleActorState
destructibleParameters.fractureImpulseScale | DestructibleActorState
destructibleParameters.impactDamageDefaultDepth | DestructibleActorState
destructibleParameters.impactVelocityThreshold | DestructibleActorState
destructibleParameters.legacyChunkBoundsTestSetting | DestructibleActorState
destructibleParameters.legacyDamageRadiusSpreadSetting | DestructibleActorState
destructibleParameters.maxChunkSpeed | DestructibleActorState
destructibleParameters.minimumFractureDepth | DestructibleActorState
destructibleParameters.runtimeFracture.attachment.negX | DestructibleActorState
destructibleParameters.runtimeFracture.attachment.negY | DestructibleActorState
destructibleParameters.runtimeFracture.attachment.negZ | DestructibleActorState
destructibleParameters.runtimeFracture.attachment.posX | DestructibleActorState
destructibleParameters.runtimeFracture.attachment.posY | DestructibleActorState
destructibleParameters.runtimeFracture.attachment.posZ | DestructibleActorState
destructibleParameters.runtimeFracture.depthLimit | DestructibleActorState
destructibleParameters.runtimeFracture.destroyIfAtDepthLimit | DestructibleActorState
destructibleParameters.runtimeFracture.glass.firstSegmentSize | DestructibleActorState
destructibleParameters.runtimeFracture.glass.numSectors | DestructibleActorState
destructibleParameters.runtimeFracture.glass.sectorRand | DestructibleActorState
destructibleParameters.runtimeFracture.glass.segmentRand | DestructibleActorState
destructibleParameters.runtimeFracture.glass.segmentScale | DestructibleActorState
destructibleParameters.runtimeFracture.impulseScale | DestructibleActorState
destructibleParameters.runtimeFracture.minConvexSize | DestructibleActorState
destructibleParameters.runtimeFracture.RuntimeFractureType | DestructibleActorState
destructibleParameters.runtimeFracture.sheetFracture | DestructibleActorState
destructibleParameters.runtimeFracture.voronoi.biasExp | DestructibleActorState
destructibleParameters.runtimeFracture.voronoi.dimensions | DestructibleActorState
destructibleParameters.runtimeFracture.voronoi.maxDist | DestructibleActorState
destructibleParameters.runtimeFracture.voronoi.numCells | DestructibleActorState
destructibleParameters.supportStrength | DestructibleActorState
destructibleParameters.validBounds | DestructibleActorState
enableCrumbleEmitter | DestructibleActorState
enableDustEmitter | DestructibleActorState
forceLod | DestructibleActorState
internalLODWeights.ageWeight | DestructibleActorState
internalLODWeights.bias | DestructibleActorState
internalLODWeights.distanceWeight | DestructibleActorState
internalLODWeights.maxAge | DestructibleActorState
internalLODWeights.maxDistance | DestructibleActorState
lod | DestructibleActorState
userData | DestructibleActorState
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: DestructibleAssetCollisionDataSet Struct Reference

  • Class List
  • Class Members
Public Attributes
DestructibleAssetCollisionDataSet Struct Reference

Describes the NxParameterized::Interface for 'DestructibleAssetCollisionDataSet' : More...

#include <params.h>

List of all members.

Public Attributes

String | assetName
'assetName' : The name of the asset for which convex hulls are cooked
U32 | cookingPlatform
'cookingPlatform' : Currently unused
U32 | cookingVersionNum
'cookingVersionNum' : Currently unused
Vec3 | scales[]
'scales[]' : An array of scales at which chunks in the asset are cooked
MeshCookedCollisionStreamsAtScale meshCookedCollisionStreamsAtScale[]
'meshCookedCollisionStreamsAtScale[]' :

Detailed Description

Describes the NxParameterized::Interface for 'DestructibleAssetCollisionDataSet' :

DestructibleAssetCollisionDataSet contains 9 fully qualified names
---------------------------------------------
  1 : String         assetName
  2 : U32            cookingPlatform
  3 : U32            cookingVersionNum
  4 : ArraySizeName  scales
  5 : Vec3           scales[]
  6 : ArraySizeName  meshCookedCollisionStreamsAtScale
  7 : ArraySizeName  meshCookedCollisionStreamsAtScale[].meshCookedCollisionStreams            RefVariant[MeshCookedCollisionStreamsAtScale]
  8 : ArraySizeName  meshCookedCollisionStreamsAtScale[].meshCookedCollisionStreams[].bytes    RefVariant[MeshCookedCollisionStream]
  9 : U8             meshCookedCollisionStreamsAtScale[].meshCookedCollisionStreams[].bytes[]  RefVariant[MeshCookedCollisionStream]

Member Data Documentation

String DestructibleAssetCollisionDataSet::assetName

'assetName' : The name of the asset for which convex hulls are cooked

The name of the asset for which convex hulls are cooked. A convex hull may be cooked for each chunk in the asset, for each scale in the scales array.

U32 DestructibleAssetCollisionDataSet::cookingPlatform

'cookingPlatform' : Currently unused

The cooking platform for convex cooking. Currently unused.

U32 DestructibleAssetCollisionDataSet::cookingVersionNum

'cookingVersionNum' : Currently unused

A version number for convex cooking. Currently unused.

MeshCookedCollisionStreamsAtScale DestructibleAssetCollisionDataSet::meshCookedCollisionStreamsAtScale[]

'meshCookedCollisionStreamsAtScale[]' :

Vec3 DestructibleAssetCollisionDataSet::scales[]

'scales[]' : An array of scales at which chunks in the asset are cooked

An array of scales at which chunks in the asset are cooked. The size of the outer array of meshCookedCollisionStreamsAtScale and scales must be equal.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
DestructibleAssetCollisionDataSet Member List
This is the complete list of members for DestructibleAssetCollisionDataSet, including all inherited members.
assetName | DestructibleAssetCollisionDataSet
cookingPlatform | DestructibleAssetCollisionDataSet
cookingVersionNum | DestructibleAssetCollisionDataSet
meshCookedCollisionStreamsAtScale[] | DestructibleAssetCollisionDataSet
scales[] | DestructibleAssetCollisionDataSet
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: DestructibleAssetParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
DestructibleAssetParameters Struct Reference

Describes the NxParameterized::Interface for 'DestructibleAssetParameters' : More...

#include <params.h>

List of all members.

Public Attributes

String | comments
'comments' : Human-readable string which describes which tool created this asset, its version, etc.
U32 | depthCount
'depthCount' : The number of chunk depth levels
U32 | originalDepthCount
'originalDepthCount' : The depth count when authored
Bounds3 | bounds
'bounds' : The AABB of the destructible asset
String | defaultBehaviorGroup.name
'defaultBehaviorGroup.name' : Name of behavior group
F32 | defaultBehaviorGroup.damageThreshold
'defaultBehaviorGroup.damageThreshold' : The damage amount which will cause a chunk to fracture (break free) from the destructible.
F32 | defaultBehaviorGroup.damageToRadius
'defaultBehaviorGroup.damageToRadius' : Controls the distance into the destructible to propagate damage.
F32 | defaultBehaviorGroup.damageSpread.minimumRadius
'defaultBehaviorGroup.damageSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.
F32 | defaultBehaviorGroup.damageSpread.radiusMultiplier
'defaultBehaviorGroup.damageSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.
F32 | defaultBehaviorGroup.damageSpread.falloffExponent
'defaultBehaviorGroup.damageSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.
F32 | defaultBehaviorGroup.damageColorSpread.minimumRadius
'defaultBehaviorGroup.damageColorSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.
F32 | defaultBehaviorGroup.damageColorSpread.radiusMultiplier
'defaultBehaviorGroup.damageColorSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.
F32 | defaultBehaviorGroup.damageColorSpread.falloffExponent
'defaultBehaviorGroup.damageColorSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.
Vec4 | defaultBehaviorGroup.damageColorChange
'defaultBehaviorGroup.damageColorChange' : Describes how damage changes the color of vertices in the render mesh.
F32 | defaultBehaviorGroup.materialStrength
'defaultBehaviorGroup.materialStrength' : When a chunk takes impact, this is the maximum impulse the contact can generate.
F32 | defaultBehaviorGroup.density
'defaultBehaviorGroup.density' : Chunk density
F32 | defaultBehaviorGroup.fadeOut
'defaultBehaviorGroup.fadeOut' : Chunk fade out
F32 | defaultBehaviorGroup.maxDepenetrationVelocity
'defaultBehaviorGroup.maxDepenetrationVelocity' : Chunk maximum depenetration velocity
U64 | defaultBehaviorGroup.userData
'defaultBehaviorGroup.userData' : User data field.
String | behaviorGroups[].name
'behaviorGroups[].name' : Name of behavior group
F32 | behaviorGroups[].damageThreshold
'behaviorGroups[].damageThreshold' : The damage amount which will cause a chunk to fracture (break free) from the destructible.
F32 | behaviorGroups[].damageToRadius
'behaviorGroups[].damageToRadius' : Controls the distance into the destructible to propagate damage.
F32 | behaviorGroups[].damageSpread.minimumRadius
'behaviorGroups[].damageSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.
F32 | behaviorGroups[].damageSpread.radiusMultiplier
'behaviorGroups[].damageSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.
F32 | behaviorGroups[].damageSpread.falloffExponent
'behaviorGroups[].damageSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.
F32 | behaviorGroups[].damageColorSpread.minimumRadius
'behaviorGroups[].damageColorSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.
F32 | behaviorGroups[].damageColorSpread.radiusMultiplier
'behaviorGroups[].damageColorSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.
F32 | behaviorGroups[].damageColorSpread.falloffExponent
'behaviorGroups[].damageColorSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.
Vec4 | behaviorGroups[].damageColorChange
'behaviorGroups[].damageColorChange' : Describes how damage changes the color of vertices in the render mesh.
F32 | behaviorGroups[].materialStrength
'behaviorGroups[].materialStrength' : When a chunk takes impact, this is the maximum impulse the contact can generate.
F32 | behaviorGroups[].density
'behaviorGroups[].density' : Chunk density
F32 | behaviorGroups[].fadeOut
'behaviorGroups[].fadeOut' : Chunk fade out
F32 | behaviorGroups[].maxDepenetrationVelocity
'behaviorGroups[].maxDepenetrationVelocity' : Chunk maximum depenetration velocity
U64 | behaviorGroups[].userData
'behaviorGroups[].userData' : User data field.
I8 | RTFractureBehaviorGroup
'RTFractureBehaviorGroup' : The array of behavior groups referenced by chunks
U16 | chunks[].depth
'chunks[].depth' : The depth of the chunk in the hierarchy
U16 | chunks[].parentIndex
'chunks[].parentIndex' : The index of the chunk's parent in the hierarchy
U16 | chunks[].firstChildIndex
'chunks[].firstChildIndex' : The index of this chunk's first child in the hierarchy
U16 | chunks[].numChildren
'chunks[].numChildren' : This chunk's number of children
U16 | chunks[].meshPartIndex
'chunks[].meshPartIndex' : The corresponding mesh part for this chunk
U16 | chunks[].flags
'chunks[].flags' : Flags which define individual chunk attributes
Vec3 | chunks[].surfaceNormal
'chunks[].surfaceNormal' : The average surface normal of this chunk
I8 | chunks[].behaviorGroupIndex
'chunks[].behaviorGroupIndex' : Behavior group this chunk is associated with
U16 | chunks[].firstScatterMesh
'chunks[].firstScatterMesh' : Index of first scatter mesh (in scatterMeshIndices and scatterMeshTransforms)
U16 | chunks[].scatterMeshCount
'chunks[].scatterMeshCount' : Number of scatter meshes (in scatterMeshIndices and scatterMeshTransforms)
ConvexHullParameters chunkConvexHulls[]
'chunkConvexHulls[]' :
U32 | chunkConvexHullStartIndices[]
'chunkConvexHullStartIndices[]' : Map into array of convex hulls
F32 | destructibleParameters.damageCap
'destructibleParameters.damageCap' : Limits the amount of damage applied to a chunk.
F32 | destructibleParameters.forceToDamage
'destructibleParameters.forceToDamage' : Multiplier to calculate applied damage from an impact.
F32 | destructibleParameters.impactVelocityThreshold
'destructibleParameters.impactVelocityThreshold' : Large impact force may be reported if rigid bodies are spawned inside one another.
U32 | destructibleParameters.minimumFractureDepth
'destructibleParameters.minimumFractureDepth' : The chunks will not be broken free below this depth.
I32 | destructibleParameters.impactDamageDefaultDepth
'destructibleParameters.impactDamageDefaultDepth' : The default depth to which chunks will take impact damage.
I32 | destructibleParameters.debrisDepth
'destructibleParameters.debrisDepth' : The chunk hierarchy depth at which chunks are considered to be 'debris.'
U32 | destructibleParameters.essentialDepth
'destructibleParameters.essentialDepth' : The chunk hierarchy depth up to which chunks will always be processed
F32 | destructibleParameters.debrisLifetimeMin
'destructibleParameters.debrisLifetimeMin' : Minimum time to destroy debris
F32 | destructibleParameters.debrisLifetimeMax
'destructibleParameters.debrisLifetimeMax' : Maximum time to destroy debris
F32 | destructibleParameters.debrisMaxSeparationMin
'destructibleParameters.debrisMaxSeparationMin' : Minimum separation distance
F32 | destructibleParameters.debrisMaxSeparationMax
'destructibleParameters.debrisMaxSeparationMax' : Minimum separation distance
F32 | destructibleParameters.debrisDestructionProbability
'destructibleParameters.debrisDestructionProbability' : The probablity that a debris chunk, when fractured, will simply be destroyed
Bounds3 | destructibleParameters.validBounds
'destructibleParameters.validBounds' : valid bounding region for debris
F32 | destructibleParameters.maxChunkSpeed
'destructibleParameters.maxChunkSpeed' : Maximum speed of a chunk
Bool | destructibleParameters.flags.ACCUMULATE_DAMAGE
'destructibleParameters.flags.ACCUMULATE_DAMAGE' : Determines if chunks accumulate damage
Bool | destructibleParameters.flags.DEBRIS_TIMEOUT
'destructibleParameters.flags.DEBRIS_TIMEOUT' : Whether or not chunks at or deeper than the 'debris' depth will timeout
Bool | destructibleParameters.flags.DEBRIS_MAX_SEPARATION
'destructibleParameters.flags.DEBRIS_MAX_SEPARATION' : Whether or not chunks at or deeper than the 'debris' depth will be removed if separated too far
Bool | destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS
'destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS' : If set, the smallest chunks may be further broken down
Bool | destructibleParameters.flags.ACCURATE_RAYCASTS
'destructibleParameters.flags.ACCURATE_RAYCASTS' : If set, the NxDestructibleActor::rayCast function will search within the nearest visible chunk hit
Bool | destructibleParameters.flags.USE_VALID_BOUNDS
'destructibleParameters.flags.USE_VALID_BOUNDS' : If set, the validBounds field of NxDestructibleParameters will be used.
Bool | destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE
'destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE' : If set, crumbled chunks will use the runtime fracture pipeline.
F32 | destructibleParameters.fractureImpulseScale
'destructibleParameters.fractureImpulseScale' : Scale factor used to apply an impulse force along the normal of chunk when fractured.
U16 | destructibleParameters.damageDepthLimit
'destructibleParameters.damageDepthLimit' : How deep in the hierarchy damage will be propagated, relative to the chunk hit.
U16 | destructibleParameters.dynamicChunkDominanceGroup
'destructibleParameters.dynamicChunkDominanceGroup' : Optional dominance group for dynamic chunks created when fractured.
Bool | destructibleParameters.dynamicChunksGroupsMask.useGroupsMask
'destructibleParameters.dynamicChunksGroupsMask.useGroupsMask' : Whether or not the groupsMask should be used
U32 | destructibleParameters.dynamicChunksGroupsMask.bits0
'destructibleParameters.dynamicChunksGroupsMask.bits0' : bits0 of the groups mask
U32 | destructibleParameters.dynamicChunksGroupsMask.bits1
'destructibleParameters.dynamicChunksGroupsMask.bits1' : bits1 of the groups mask
U32 | destructibleParameters.dynamicChunksGroupsMask.bits2
'destructibleParameters.dynamicChunksGroupsMask.bits2' : bits2 of the groups mask
U32 | destructibleParameters.dynamicChunksGroupsMask.bits3
'destructibleParameters.dynamicChunksGroupsMask.bits3' : bits3 of the groups mask
RuntimeFractureType destructibleParameters.runtimeFracture.RuntimeFractureType
'destructibleParameters.runtimeFracture.RuntimeFractureType' : Which type of fracture pattern to choose
Bool | destructibleParameters.runtimeFracture.sheetFracture
'destructibleParameters.runtimeFracture.sheetFracture' : If true, align fracture pattern to largest face
U32 | destructibleParameters.runtimeFracture.depthLimit
'destructibleParameters.runtimeFracture.depthLimit' : Number of times deep a chunk can be fractured.
Bool | destructibleParameters.runtimeFracture.destroyIfAtDepthLimit
'destructibleParameters.runtimeFracture.destroyIfAtDepthLimit' : Destroy chunk if at depth limit
F32 | destructibleParameters.runtimeFracture.minConvexSize
'destructibleParameters.runtimeFracture.minConvexSize' : Minimum Convex Size.
F32 | destructibleParameters.runtimeFracture.impulseScale
'destructibleParameters.runtimeFracture.impulseScale' : Scales impulse applied by a fracture.
U32 | destructibleParameters.runtimeFracture.glass.numSectors
'destructibleParameters.runtimeFracture.glass.numSectors' : Number of angular slices.
F32 | destructibleParameters.runtimeFracture.glass.sectorRand
'destructibleParameters.runtimeFracture.glass.sectorRand' : Creates variance in the angle of slices.
F32 | destructibleParameters.runtimeFracture.glass.firstSegmentSize
'destructibleParameters.runtimeFracture.glass.firstSegmentSize' : The minimum shard size.
F32 | destructibleParameters.runtimeFracture.glass.segmentScale
'destructibleParameters.runtimeFracture.glass.segmentScale' : Scales the radial spacing.
F32 | destructibleParameters.runtimeFracture.glass.segmentRand
'destructibleParameters.runtimeFracture.glass.segmentRand' : Creates variance in the radial size of shards.
Vec3 | destructibleParameters.runtimeFracture.voronoi.dimensions
'destructibleParameters.runtimeFracture.voronoi.dimensions' : The size of the entire block
U32 | destructibleParameters.runtimeFracture.voronoi.numCells
'destructibleParameters.runtimeFracture.voronoi.numCells' : Max Number of Cells to create.
F32 | destructibleParameters.runtimeFracture.voronoi.biasExp
'destructibleParameters.runtimeFracture.voronoi.biasExp' : Bias Exponential value.
F32 | destructibleParameters.runtimeFracture.voronoi.maxDist
'destructibleParameters.runtimeFracture.voronoi.maxDist' : The max distance a Voronoi point away from origin.
Bool | destructibleParameters.runtimeFracture.attachment.posX
'destructibleParameters.runtimeFracture.attachment.posX' : Attach to positive x side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.negX
'destructibleParameters.runtimeFracture.attachment.negX' : Attach to negative x side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.posY
'destructibleParameters.runtimeFracture.attachment.posY' : Attach to positive y side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.negY
'destructibleParameters.runtimeFracture.attachment.negY' : Attach to negative y side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.posZ
'destructibleParameters.runtimeFracture.attachment.posZ' : Attach to positive z side of sheet.
Bool | destructibleParameters.runtimeFracture.attachment.negZ
'destructibleParameters.runtimeFracture.attachment.negZ' : Attach to negative z side of sheet.
F32 | destructibleParameters.supportStrength
'destructibleParameters.supportStrength' : The support strength threshold for breaking chunks in stressSolver
I8 | destructibleParameters.legacyChunkBoundsTestSetting
'destructibleParameters.legacyChunkBoundsTestSetting' : Whether or not to use the old chunk bounds testing for damage, or use the module setting.
I8 | destructibleParameters.legacyDamageRadiusSpreadSetting
'destructibleParameters.legacyDamageRadiusSpreadSetting' : Whether or not to use the old damage spread method, or use the module setting.
Bool | depthParameters[].OVERRIDE_IMPACT_DAMAGE
'depthParameters[].OVERRIDE_IMPACT_DAMAGE' : If true, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE_VALUE = TRUE, no matter the setting of impactDamageDefaultDepth.
Bool | depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE
'depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE' : If OVERRIDE_IMPACT_DAMAGE = TRUE, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE_VALUE = TRUE.
Bool | depthParameters[].IGNORE_POSE_UPDATES
'depthParameters[].IGNORE_POSE_UPDATES' : Chunks at this depth should have pose updates ignored.
Bool | depthParameters[].IGNORE_RAYCAST_CALLBACKS
'depthParameters[].IGNORE_RAYCAST_CALLBACKS' : Chunks at this depth should be ignored in raycast callbacks.
Bool | depthParameters[].IGNORE_CONTACT_CALLBACKS
'depthParameters[].IGNORE_CONTACT_CALLBACKS' : Chunks at this depth should be ignored in contact callbacks.
Bool | depthParameters[].USER_FLAG_0
'depthParameters[].USER_FLAG_0' : User defined flag.
Bool | depthParameters[].USER_FLAG_1
'depthParameters[].USER_FLAG_1' : User defined flag.
Bool | depthParameters[].USER_FLAG_2
'depthParameters[].USER_FLAG_2' : User defined flag.
Bool | depthParameters[].USER_FLAG_3
'depthParameters[].USER_FLAG_3' : User defined flag.
String | crumbleEmitterName
'crumbleEmitterName' : The name of the crumble emitter to use
String | dustEmitterName
'dustEmitterName' : The name of the dust emitter to use
DestructibleAssetCollisionDataSet collisionData
'collisionData' :
RenderMeshAssetParameters renderMeshAsset
'renderMeshAsset' :
U32 | initialDestructibleActorAllowanceForInstancing
'initialDestructibleActorAllowanceForInstancing' : Initial actor estimate for instance buffer allocation
U16 | chunkInstanceInfo[].partIndex
'chunkInstanceInfo[].partIndex' : The part instanced for this chunk
Vec3 | chunkInstanceInfo[].chunkPositionOffset
'chunkInstanceInfo[].chunkPositionOffset' : Translation for this chunk mesh within the asset
Vec2 | chunkInstanceInfo[].chunkUVOffset
'chunkInstanceInfo[].chunkUVOffset' : UV translation for this chunk mesh's vertices
String | staticMaterialNames[]
'staticMaterialNames[]' : Alternative material names for the static render mesh, if it's created
F32 | neighborPadding
'neighborPadding' : Padding used for chunk neighbor tests.
CachedOverlaps overlapsAtDepth[]
'overlapsAtDepth[]' :
U32 | firstChunkAtDepth[]
'firstChunkAtDepth[]' : The first index of chunks at each depth
U32 | supportDepth
'supportDepth' : The chunk hierarchy depth at which to create a support graph.
Bool | formExtendedStructures
'formExtendedStructures' : If initially static, the destructible will become part of an extended support structure if it is in contact with another static destructible that also has this flag set.
Bool | useAssetDefinedSupport
'useAssetDefinedSupport' : If set, then chunks which are tagged as 'support' chunks
Bool | useWorldSupport
'useWorldSupport' : If set, then chunks which overlap the NxScene's static geometry will have environmental support
Mat44 | actorTransforms[]
'actorTransforms[]' : List of actor poses (that may contain scaling) which may be saved in the asset for convenience
RenderMeshAssetParameters scatterMeshAssets[]
'scatterMeshAssets[]' :
U8 | scatterMeshIndices[]
'scatterMeshIndices[]' : Array of indices for scatter meshes defined in the asset
Mat33 | scatterMeshTransforms[].matrix
'scatterMeshTransforms[].matrix' : The matrix part of the transform, containing the (possibly scaled axis-unaligned) rotation
Vec3 | scatterMeshTransforms[].vector
'scatterMeshTransforms[].vector' : The vector part of the transform, containing a translation

Detailed Description

Describes the NxParameterized::Interface for 'DestructibleAssetParameters' :

DestructibleAssetParameters contains 330 fully qualified names
---------------------------------------------
  1 : String               comments
  2 : U32                  depthCount
  3 : U32                  originalDepthCount
  4 : Bounds3              bounds
  5 : String               defaultBehaviorGroup.name
  6 : F32                  defaultBehaviorGroup.damageThreshold
  7 : F32                  defaultBehaviorGroup.damageToRadius
  8 : F32                  defaultBehaviorGroup.damageSpread.minimumRadius
  9 : F32                  defaultBehaviorGroup.damageSpread.radiusMultiplier
 10 : F32                  defaultBehaviorGroup.damageSpread.falloffExponent
 11 : F32                  defaultBehaviorGroup.damageColorSpread.minimumRadius
 12 : F32                  defaultBehaviorGroup.damageColorSpread.radiusMultiplier
 13 : F32                  defaultBehaviorGroup.damageColorSpread.falloffExponent
 14 : Vec4                 defaultBehaviorGroup.damageColorChange
 15 : F32                  defaultBehaviorGroup.materialStrength
 16 : F32                  defaultBehaviorGroup.density
 17 : F32                  defaultBehaviorGroup.fadeOut
 18 : F32                  defaultBehaviorGroup.maxDepenetrationVelocity
 19 : U64                  defaultBehaviorGroup.userData
 20 : ArraySizeName        behaviorGroups
 21 : String               behaviorGroups[].name
 22 : F32                  behaviorGroups[].damageThreshold
 23 : F32                  behaviorGroups[].damageToRadius
 24 : F32                  behaviorGroups[].damageSpread.minimumRadius
 25 : F32                  behaviorGroups[].damageSpread.radiusMultiplier
 26 : F32                  behaviorGroups[].damageSpread.falloffExponent
 27 : F32                  behaviorGroups[].damageColorSpread.minimumRadius
 28 : F32                  behaviorGroups[].damageColorSpread.radiusMultiplier
 29 : F32                  behaviorGroups[].damageColorSpread.falloffExponent
 30 : Vec4                 behaviorGroups[].damageColorChange
 31 : F32                  behaviorGroups[].materialStrength
 32 : F32                  behaviorGroups[].density
 33 : F32                  behaviorGroups[].fadeOut
 34 : F32                  behaviorGroups[].maxDepenetrationVelocity
 35 : U64                  behaviorGroups[].userData
 36 : I8                   RTFractureBehaviorGroup
 37 : ArraySizeName        chunks
 38 : U16                  chunks[].depth
 39 : U16                  chunks[].parentIndex
 40 : U16                  chunks[].firstChildIndex
 41 : U16                  chunks[].numChildren
 42 : U16                  chunks[].meshPartIndex
 43 : U16                  chunks[].flags
 44 : Vec3                 chunks[].surfaceNormal
 45 : I8                   chunks[].behaviorGroupIndex
 46 : U16                  chunks[].firstScatterMesh
 47 : U16                  chunks[].scatterMeshCount
 48 : ArraySizeName        chunkConvexHulls
 49 : ArraySizeName        chunkConvexHulls[].vertices                                                             RefVariant[ConvexHullParameters]
 50 : Vec3                 chunkConvexHulls[].vertices[]                                                           RefVariant[ConvexHullParameters]
 51 : ArraySizeName        chunkConvexHulls[].uniquePlanes                                                         RefVariant[ConvexHullParameters]
 52 : Vec3                 chunkConvexHulls[].uniquePlanes[].normal                                                RefVariant[ConvexHullParameters]
 53 : F32                  chunkConvexHulls[].uniquePlanes[].d                                                     RefVariant[ConvexHullParameters]
 54 : ArraySizeName        chunkConvexHulls[].widths                                                               RefVariant[ConvexHullParameters]
 55 : F32                  chunkConvexHulls[].widths[]                                                             RefVariant[ConvexHullParameters]
 56 : ArraySizeName        chunkConvexHulls[].edges                                                                RefVariant[ConvexHullParameters]
 57 : U32                  chunkConvexHulls[].edges[]                                                              RefVariant[ConvexHullParameters]
 58 : ArraySizeName        chunkConvexHulls[].adjacentFaces                                                        RefVariant[ConvexHullParameters]
 59 : U32                  chunkConvexHulls[].adjacentFaces[]                                                      RefVariant[ConvexHullParameters]
 60 : Bounds3              chunkConvexHulls[].bounds                                                               RefVariant[ConvexHullParameters]
 61 : F32                  chunkConvexHulls[].volume                                                               RefVariant[ConvexHullParameters]
 62 : U32                  chunkConvexHulls[].uniqueEdgeDirectionCount                                             RefVariant[ConvexHullParameters]
 63 : U32                  chunkConvexHulls[].planeCount                                                           RefVariant[ConvexHullParameters]
 64 : ArraySizeName        chunkConvexHullStartIndices
 65 : U32                  chunkConvexHullStartIndices[]
 66 : F32                  destructibleParameters.damageCap
 67 : F32                  destructibleParameters.forceToDamage
 68 : F32                  destructibleParameters.impactVelocityThreshold
 69 : U32                  destructibleParameters.minimumFractureDepth
 70 : I32                  destructibleParameters.impactDamageDefaultDepth
 71 : I32                  destructibleParameters.debrisDepth
 72 : U32                  destructibleParameters.essentialDepth
 73 : F32                  destructibleParameters.debrisLifetimeMin
 74 : F32                  destructibleParameters.debrisLifetimeMax
 75 : F32                  destructibleParameters.debrisMaxSeparationMin
 76 : F32                  destructibleParameters.debrisMaxSeparationMax
 77 : F32                  destructibleParameters.debrisDestructionProbability
 78 : Bounds3              destructibleParameters.validBounds
 79 : F32                  destructibleParameters.maxChunkSpeed
 80 : Bool                 destructibleParameters.flags.ACCUMULATE_DAMAGE
 81 : Bool                 destructibleParameters.flags.DEBRIS_TIMEOUT
 82 : Bool                 destructibleParameters.flags.DEBRIS_MAX_SEPARATION
 83 : Bool                 destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS
 84 : Bool                 destructibleParameters.flags.ACCURATE_RAYCASTS
 85 : Bool                 destructibleParameters.flags.USE_VALID_BOUNDS
 86 : Bool                 destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE
 87 : F32                  destructibleParameters.fractureImpulseScale
 88 : U16                  destructibleParameters.damageDepthLimit
 89 : U16                  destructibleParameters.dynamicChunkDominanceGroup
 90 : Bool                 destructibleParameters.dynamicChunksGroupsMask.useGroupsMask
 91 : U32                  destructibleParameters.dynamicChunksGroupsMask.bits0
 92 : U32                  destructibleParameters.dynamicChunksGroupsMask.bits1
 93 : U32                  destructibleParameters.dynamicChunksGroupsMask.bits2
 94 : U32                  destructibleParameters.dynamicChunksGroupsMask.bits3
 95 : RuntimeFractureType  destructibleParameters.runtimeFracture.RuntimeFractureType
 96 : Bool                 destructibleParameters.runtimeFracture.sheetFracture
 97 : U32                  destructibleParameters.runtimeFracture.depthLimit
 98 : Bool                 destructibleParameters.runtimeFracture.destroyIfAtDepthLimit
 99 : F32                  destructibleParameters.runtimeFracture.minConvexSize
100 : F32                  destructibleParameters.runtimeFracture.impulseScale
101 : U32                  destructibleParameters.runtimeFracture.glass.numSectors
102 : F32                  destructibleParameters.runtimeFracture.glass.sectorRand
103 : F32                  destructibleParameters.runtimeFracture.glass.firstSegmentSize
104 : F32                  destructibleParameters.runtimeFracture.glass.segmentScale
105 : F32                  destructibleParameters.runtimeFracture.glass.segmentRand
106 : Vec3                 destructibleParameters.runtimeFracture.voronoi.dimensions
107 : U32                  destructibleParameters.runtimeFracture.voronoi.numCells
108 : F32                  destructibleParameters.runtimeFracture.voronoi.biasExp
109 : F32                  destructibleParameters.runtimeFracture.voronoi.maxDist
110 : Bool                 destructibleParameters.runtimeFracture.attachment.posX
111 : Bool                 destructibleParameters.runtimeFracture.attachment.negX
112 : Bool                 destructibleParameters.runtimeFracture.attachment.posY
113 : Bool                 destructibleParameters.runtimeFracture.attachment.negY
114 : Bool                 destructibleParameters.runtimeFracture.attachment.posZ
115 : Bool                 destructibleParameters.runtimeFracture.attachment.negZ
116 : F32                  destructibleParameters.supportStrength
117 : I8                   destructibleParameters.legacyChunkBoundsTestSetting
118 : I8                   destructibleParameters.legacyDamageRadiusSpreadSetting
119 : ArraySizeName        depthParameters
120 : Bool                 depthParameters[].OVERRIDE_IMPACT_DAMAGE
121 : Bool                 depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE
122 : Bool                 depthParameters[].IGNORE_POSE_UPDATES
123 : Bool                 depthParameters[].IGNORE_RAYCAST_CALLBACKS
124 : Bool                 depthParameters[].IGNORE_CONTACT_CALLBACKS
125 : Bool                 depthParameters[].USER_FLAG_0
126 : Bool                 depthParameters[].USER_FLAG_1
127 : Bool                 depthParameters[].USER_FLAG_2
128 : Bool                 depthParameters[].USER_FLAG_3
129 : String               crumbleEmitterName
130 : String               dustEmitterName
131 : String               collisionData.assetName                                                                 RefVariant[DestructibleAssetCollisionDataSet]
132 : U32                  collisionData.cookingPlatform                                                           RefVariant[DestructibleAssetCollisionDataSet]
133 : U32                  collisionData.cookingVersionNum                                                         RefVariant[DestructibleAssetCollisionDataSet]
134 : ArraySizeName        collisionData.scales                                                                    RefVariant[DestructibleAssetCollisionDataSet]
135 : Vec3                 collisionData.scales[]                                                                  RefVariant[DestructibleAssetCollisionDataSet]
136 : ArraySizeName        collisionData.meshCookedCollisionStreamsAtScale                                         RefVariant[DestructibleAssetCollisionDataSet]
137 : ArraySizeName        collisionData.meshCookedCollisionStreamsAtScale[].meshCookedCollisionStreams            RefVariant[MeshCookedCollisionStreamsAtScale]
138 : ArraySizeName        collisionData.meshCookedCollisionStreamsAtScale[].meshCookedCollisionStreams[].bytes    RefVariant[MeshCookedCollisionStream]
139 : U8                   collisionData.meshCookedCollisionStreamsAtScale[].meshCookedCollisionStreams[].bytes[]  RefVariant[MeshCookedCollisionStream]
140 : ArraySizeName        renderMeshAsset.submeshes                                                               RefVariant[RenderMeshAssetParameters]
141 : U32                  renderMeshAsset.submeshes[].vertexBuffer.vertexCount                                    RefVariant[VertexBufferParameters]
142 : U32                  renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.winding                           RefVariant[VertexFormatParameters]
143 : Bool                 renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.hasSeparateBoneBuffer             RefVariant[VertexFormatParameters]
144 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats                     RefVariant[VertexFormatParameters]
145 : String               renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].name              RefVariant[VertexFormatParameters]
146 : I32                  renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].semantic          RefVariant[VertexFormatParameters]
147 : U32                  renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].id                RefVariant[VertexFormatParameters]
148 : U32                  renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].format            RefVariant[VertexFormatParameters]
149 : U32                  renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].access            RefVariant[VertexFormatParameters]
150 : Bool                 renderMeshAsset.submeshes[].vertexBuffer.vertexFormat.bufferFormats[].serialize         RefVariant[VertexFormatParameters]
151 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers                                        RefVariant[VertexBufferParameters]
152 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferU8x1]
153 : U8                   renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                               RefVariant[BufferU8x1]
154 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferU8x2]
155 : U8                   renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                             RefVariant[BufferU8x2]
156 : U8                   renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                             RefVariant[BufferU8x2]
157 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferU8x3]
158 : U8                   renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                             RefVariant[BufferU8x3]
159 : U8                   renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                             RefVariant[BufferU8x3]
160 : U8                   renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                             RefVariant[BufferU8x3]
161 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferU8x4]
162 : U8                   renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                             RefVariant[BufferU8x4]
163 : U8                   renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                             RefVariant[BufferU8x4]
164 : U8                   renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                             RefVariant[BufferU8x4]
165 : U8                   renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].w                             RefVariant[BufferU8x4]
166 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferU16x1]
167 : U16                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                               RefVariant[BufferU16x1]
168 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferU16x2]
169 : U16                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                             RefVariant[BufferU16x2]
170 : U16                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                             RefVariant[BufferU16x2]
171 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferU16x3]
172 : U16                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                             RefVariant[BufferU16x3]
173 : U16                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                             RefVariant[BufferU16x3]
174 : U16                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                             RefVariant[BufferU16x3]
175 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferU16x4]
176 : U16                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                             RefVariant[BufferU16x4]
177 : U16                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                             RefVariant[BufferU16x4]
178 : U16                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                             RefVariant[BufferU16x4]
179 : U16                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].w                             RefVariant[BufferU16x4]
180 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferU32x1]
181 : U32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                               RefVariant[BufferU32x1]
182 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferU32x2]
183 : U32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                             RefVariant[BufferU32x2]
184 : U32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                             RefVariant[BufferU32x2]
185 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferU32x3]
186 : U32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                             RefVariant[BufferU32x3]
187 : U32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                             RefVariant[BufferU32x3]
188 : U32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                             RefVariant[BufferU32x3]
189 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferU32x4]
190 : U32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                             RefVariant[BufferU32x4]
191 : U32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                             RefVariant[BufferU32x4]
192 : U32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                             RefVariant[BufferU32x4]
193 : U32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].w                             RefVariant[BufferU32x4]
194 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferF32x1]
195 : F32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                               RefVariant[BufferF32x1]
196 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferF32x2]
197 : F32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                             RefVariant[BufferF32x2]
198 : F32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                             RefVariant[BufferF32x2]
199 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferF32x3]
200 : Vec3                 renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[]                               RefVariant[BufferF32x3]
201 : ArraySizeName        renderMeshAsset.submeshes[].vertexBuffer.buffers[].data                                 RefVariant[BufferF32x4]
202 : F32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].x                             RefVariant[BufferF32x4]
203 : F32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].y                             RefVariant[BufferF32x4]
204 : F32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].z                             RefVariant[BufferF32x4]
205 : F32                  renderMeshAsset.submeshes[].vertexBuffer.buffers[].data[].w                             RefVariant[BufferF32x4]
206 : ArraySizeName        renderMeshAsset.submeshes[].indexBuffer                                                 RefVariant[SubmeshParameters]
207 : U32                  renderMeshAsset.submeshes[].indexBuffer[]                                               RefVariant[SubmeshParameters]
208 : ArraySizeName        renderMeshAsset.submeshes[].vertexPartition                                             RefVariant[SubmeshParameters]
209 : U32                  renderMeshAsset.submeshes[].vertexPartition[]                                           RefVariant[SubmeshParameters]
210 : ArraySizeName        renderMeshAsset.submeshes[].indexPartition                                              RefVariant[SubmeshParameters]
211 : U32                  renderMeshAsset.submeshes[].indexPartition[]                                            RefVariant[SubmeshParameters]
212 : ArraySizeName        renderMeshAsset.submeshes[].smoothingGroups                                             RefVariant[SubmeshParameters]
213 : U32                  renderMeshAsset.submeshes[].smoothingGroups[]                                           RefVariant[SubmeshParameters]
214 : ArraySizeName        renderMeshAsset.materialNames                                                           RefVariant[RenderMeshAssetParameters]
215 : String               renderMeshAsset.materialNames[]                                                         RefVariant[RenderMeshAssetParameters]
216 : ArraySizeName        renderMeshAsset.partBounds                                                              RefVariant[RenderMeshAssetParameters]
217 : Bounds3              renderMeshAsset.partBounds[]                                                            RefVariant[RenderMeshAssetParameters]
218 : U32                  renderMeshAsset.textureUVOrigin                                                         RefVariant[RenderMeshAssetParameters]
219 : U32                  renderMeshAsset.boneCount                                                               RefVariant[RenderMeshAssetParameters]
220 : Bool                 renderMeshAsset.deleteStaticBuffersAfterUse                                             RefVariant[RenderMeshAssetParameters]
221 : Bool                 renderMeshAsset.isReferenced                                                            RefVariant[RenderMeshAssetParameters]
222 : U32                  initialDestructibleActorAllowanceForInstancing
223 : ArraySizeName        chunkInstanceInfo
224 : U16                  chunkInstanceInfo[].partIndex
225 : Vec3                 chunkInstanceInfo[].chunkPositionOffset
226 : Vec2                 chunkInstanceInfo[].chunkUVOffset
227 : ArraySizeName        staticMaterialNames
228 : String               staticMaterialNames[]
229 : F32                  neighborPadding
230 : ArraySizeName        overlapsAtDepth
231 : Bool                 overlapsAtDepth[].isCached                                                              RefVariant[CachedOverlaps]
232 : ArraySizeName        overlapsAtDepth[].overlaps                                                              RefVariant[CachedOverlaps]
233 : I32                  overlapsAtDepth[].overlaps[].i0                                                         RefVariant[CachedOverlaps]
234 : I32                  overlapsAtDepth[].overlaps[].i1                                                         RefVariant[CachedOverlaps]
235 : ArraySizeName        firstChunkAtDepth
236 : U32                  firstChunkAtDepth[]
237 : U32                  supportDepth
238 : Bool                 formExtendedStructures
239 : Bool                 useAssetDefinedSupport
240 : Bool                 useWorldSupport
241 : ArraySizeName        actorTransforms
242 : Mat44                actorTransforms[]
243 : ArraySizeName        scatterMeshAssets
244 : ArraySizeName        scatterMeshAssets[].submeshes                                                           RefVariant[RenderMeshAssetParameters]
245 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.vertexCount                                RefVariant[VertexBufferParameters]
246 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.vertexFormat.winding                       RefVariant[VertexFormatParameters]
247 : Bool                 scatterMeshAssets[].submeshes[].vertexBuffer.vertexFormat.hasSeparateBoneBuffer         RefVariant[VertexFormatParameters]
248 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.vertexFormat.bufferFormats                 RefVariant[VertexFormatParameters]
249 : String               scatterMeshAssets[].submeshes[].vertexBuffer.vertexFormat.bufferFormats[].name          RefVariant[VertexFormatParameters]
250 : I32                  scatterMeshAssets[].submeshes[].vertexBuffer.vertexFormat.bufferFormats[].semantic      RefVariant[VertexFormatParameters]
251 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.vertexFormat.bufferFormats[].id            RefVariant[VertexFormatParameters]
252 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.vertexFormat.bufferFormats[].format        RefVariant[VertexFormatParameters]
253 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.vertexFormat.bufferFormats[].access        RefVariant[VertexFormatParameters]
254 : Bool                 scatterMeshAssets[].submeshes[].vertexBuffer.vertexFormat.bufferFormats[].serialize     RefVariant[VertexFormatParameters]
255 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers                                    RefVariant[VertexBufferParameters]
256 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferU8x1]
257 : U8                   scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[]                           RefVariant[BufferU8x1]
258 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferU8x2]
259 : U8                   scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].x                         RefVariant[BufferU8x2]
260 : U8                   scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].y                         RefVariant[BufferU8x2]
261 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferU8x3]
262 : U8                   scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].x                         RefVariant[BufferU8x3]
263 : U8                   scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].y                         RefVariant[BufferU8x3]
264 : U8                   scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].z                         RefVariant[BufferU8x3]
265 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferU8x4]
266 : U8                   scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].x                         RefVariant[BufferU8x4]
267 : U8                   scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].y                         RefVariant[BufferU8x4]
268 : U8                   scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].z                         RefVariant[BufferU8x4]
269 : U8                   scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].w                         RefVariant[BufferU8x4]
270 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferU16x1]
271 : U16                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[]                           RefVariant[BufferU16x1]
272 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferU16x2]
273 : U16                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].x                         RefVariant[BufferU16x2]
274 : U16                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].y                         RefVariant[BufferU16x2]
275 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferU16x3]
276 : U16                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].x                         RefVariant[BufferU16x3]
277 : U16                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].y                         RefVariant[BufferU16x3]
278 : U16                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].z                         RefVariant[BufferU16x3]
279 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferU16x4]
280 : U16                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].x                         RefVariant[BufferU16x4]
281 : U16                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].y                         RefVariant[BufferU16x4]
282 : U16                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].z                         RefVariant[BufferU16x4]
283 : U16                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].w                         RefVariant[BufferU16x4]
284 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferU32x1]
285 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[]                           RefVariant[BufferU32x1]
286 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferU32x2]
287 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].x                         RefVariant[BufferU32x2]
288 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].y                         RefVariant[BufferU32x2]
289 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferU32x3]
290 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].x                         RefVariant[BufferU32x3]
291 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].y                         RefVariant[BufferU32x3]
292 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].z                         RefVariant[BufferU32x3]
293 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferU32x4]
294 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].x                         RefVariant[BufferU32x4]
295 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].y                         RefVariant[BufferU32x4]
296 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].z                         RefVariant[BufferU32x4]
297 : U32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].w                         RefVariant[BufferU32x4]
298 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferF32x1]
299 : F32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[]                           RefVariant[BufferF32x1]
300 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferF32x2]
301 : F32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].x                         RefVariant[BufferF32x2]
302 : F32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].y                         RefVariant[BufferF32x2]
303 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferF32x3]
304 : Vec3                 scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[]                           RefVariant[BufferF32x3]
305 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data                             RefVariant[BufferF32x4]
306 : F32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].x                         RefVariant[BufferF32x4]
307 : F32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].y                         RefVariant[BufferF32x4]
308 : F32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].z                         RefVariant[BufferF32x4]
309 : F32                  scatterMeshAssets[].submeshes[].vertexBuffer.buffers[].data[].w                         RefVariant[BufferF32x4]
310 : ArraySizeName        scatterMeshAssets[].submeshes[].indexBuffer                                             RefVariant[SubmeshParameters]
311 : U32                  scatterMeshAssets[].submeshes[].indexBuffer[]                                           RefVariant[SubmeshParameters]
312 : ArraySizeName        scatterMeshAssets[].submeshes[].vertexPartition                                         RefVariant[SubmeshParameters]
313 : U32                  scatterMeshAssets[].submeshes[].vertexPartition[]                                       RefVariant[SubmeshParameters]
314 : ArraySizeName        scatterMeshAssets[].submeshes[].indexPartition                                          RefVariant[SubmeshParameters]
315 : U32                  scatterMeshAssets[].submeshes[].indexPartition[]                                        RefVariant[SubmeshParameters]
316 : ArraySizeName        scatterMeshAssets[].submeshes[].smoothingGroups                                         RefVariant[SubmeshParameters]
317 : U32                  scatterMeshAssets[].submeshes[].smoothingGroups[]                                       RefVariant[SubmeshParameters]
318 : ArraySizeName        scatterMeshAssets[].materialNames                                                       RefVariant[RenderMeshAssetParameters]
319 : String               scatterMeshAssets[].materialNames[]                                                     RefVariant[RenderMeshAssetParameters]
320 : ArraySizeName        scatterMeshAssets[].partBounds                                                          RefVariant[RenderMeshAssetParameters]
321 : Bounds3              scatterMeshAssets[].partBounds[]                                                        RefVariant[RenderMeshAssetParameters]
322 : U32                  scatterMeshAssets[].textureUVOrigin                                                     RefVariant[RenderMeshAssetParameters]
323 : U32                  scatterMeshAssets[].boneCount                                                           RefVariant[RenderMeshAssetParameters]
324 : Bool                 scatterMeshAssets[].deleteStaticBuffersAfterUse                                         RefVariant[RenderMeshAssetParameters]
325 : Bool                 scatterMeshAssets[].isReferenced                                                        RefVariant[RenderMeshAssetParameters]
326 : ArraySizeName        scatterMeshIndices
327 : U8                   scatterMeshIndices[]
328 : ArraySizeName        scatterMeshTransforms
329 : Mat33                scatterMeshTransforms[].matrix
330 : Vec3                 scatterMeshTransforms[].vector

Member Data Documentation

Mat44 DestructibleAssetParameters::actorTransforms[]

'actorTransforms[]' : List of actor poses (that may contain scaling) which may be saved in the asset for convenience

List of actor poses (that may contain scaling) which may be saved in the asset for convenience.

Vec4 DestructibleAssetParameters::behaviorGroups[].damageColorChange

'behaviorGroups[].damageColorChange' : Describes how damage changes the color of vertices in the render mesh.

Describes how damage changes the color of vertices in the render mesh. If this vector is non-zero, then a dynamic (per-actor) color channel will be created and initialized to the asset's color channel, if it exists. Damage taken will go through the spread and envelope function described by damageColoring, and each color will be modified by the resulting damage, scaled by the values in damageColorChange. The change to color channel C is given by color[C] = clamp(color[C] + damageColorChange[C]*255*min(1.0, damage/damageThreshold), 0, 255).

F32 DestructibleAssetParameters::behaviorGroups[].damageColorSpread.falloffExponent

'behaviorGroups[].damageColorSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.

How damage varies between the minimum radius and the calculated damage radius. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier. Within the minimumRadius, the full damage is applied to chunks. Past the minimumRadius, the formla for damage is: damage = (input damage) * ((radius - distance)/(radius - minimumRadius))^falloffExponent. Note: falloffExponent = 0.0 gives no falloff, so that damage = (input damage) over the entire range [0, radius). falloffExponent = 1.0 gives linear falloff.

F32 DestructibleAssetParameters::behaviorGroups[].damageColorSpread.minimumRadius

'behaviorGroups[].damageColorSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.

The minimum radius of damage spread when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleAssetParameters::behaviorGroups[].damageColorSpread.radiusMultiplier

'behaviorGroups[].damageColorSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.

A scale to apply to the input damage radius when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleAssetParameters::behaviorGroups[].damageSpread.falloffExponent

'behaviorGroups[].damageSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.

How damage varies between the minimum radius and the calculated damage radius. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier. Within the minimumRadius, the full damage is applied to chunks. Past the minimumRadius, the formla for damage is: damage = (input damage) * ((radius - distance)/(radius - minimumRadius))^falloffExponent. Note: falloffExponent = 0.0 gives no falloff, so that damage = (input damage) over the entire range [0, radius). falloffExponent = 1.0 gives linear falloff.

F32 DestructibleAssetParameters::behaviorGroups[].damageSpread.minimumRadius

'behaviorGroups[].damageSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.

The minimum radius of damage spread when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleAssetParameters::behaviorGroups[].damageSpread.radiusMultiplier

'behaviorGroups[].damageSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.

A scale to apply to the input damage radius when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleAssetParameters::behaviorGroups[].damageThreshold

'behaviorGroups[].damageThreshold' : The damage amount which will cause a chunk to fracture (break free) from the destructible.

The damage amount which will cause a chunk to fracture (break free) from the destructible. This is obtained from the damage value passed into the NxDestructibleActor::applyDamage, or NxDestructibleActor::applyRadiusDamage, or via impact (see 'forceToDamage', below).

F32 DestructibleAssetParameters::behaviorGroups[].damageToRadius

'behaviorGroups[].damageToRadius' : Controls the distance into the destructible to propagate damage.

Controls the distance into the destructible to propagate damage. The damage applied to the chunk is multiplied by damageToRadius, to get the propagation distance. All chunks within the radius will have damage applied to them. The damage applied to each chunk varies with distance to the damage application position. Full damage is taken at zero distance, and zero damage at the damage radius. NOTE: This parameter is deprecated for point and radius damage. It will be used for those types of damage if legacy damage behavior is enabled with NxModuleDestructible::setUseLegacyDamageRadiusSpread. Otherwise, the new parameters damageSpread.minimumRadius, damageSpread.radiusMultiplier, and damageSpread.falloffExponent are used. For impact damage, this parameter will continue to be used, however the radius will no longer scale with object size. The radius will continue to scale with the damage as a fraction of damageThreshold, however. If legacy damage behavior is used, this parameter will behave as before with respect to impact damage as well (scaling with object size).

F32 DestructibleAssetParameters::behaviorGroups[].density

'behaviorGroups[].density' : Chunk density

Chunk density. (TODO: better description)

F32 DestructibleAssetParameters::behaviorGroups[].fadeOut

'behaviorGroups[].fadeOut' : Chunk fade out

Chunk fade out. (TODO: better description)

F32 DestructibleAssetParameters::behaviorGroups[].materialStrength

'behaviorGroups[].materialStrength' : When a chunk takes impact, this is the maximum impulse the contact can generate.

When a chunk takes impact damage due to physical contact (see see NxDestructibleDepthParameters), this parameter is the maximum impulse the contact can generate. Weak materials such as glass may have this set to a low value, so that heavier objects will pass through them during fracture. N.B.: Setting this parameter to 0 disables the impulse cap; that is, zero is interpreted as infinite. Default value = 0.0f.

F32 DestructibleAssetParameters::behaviorGroups[].maxDepenetrationVelocity

'behaviorGroups[].maxDepenetrationVelocity' : Chunk maximum depenetration velocity

In case some chunk is created inside static geometry it will be pushed out of it without limiting it's velocity. Sometimes it's not desirable, so this parameter can limit depenetration velocity. Keep in mind, that for low values you can see chunks 'floating' off the static meshes, which is also not always desirable.

String DestructibleAssetParameters::behaviorGroups[].name

'behaviorGroups[].name' : Name of behavior group

Name of behavior group, eg Concrete or Glass.

U64 DestructibleAssetParameters::behaviorGroups[].userData

'behaviorGroups[].userData' : User data field.

User data field. This 64-bit field can be set and retrieved by the user at runtime.

Bounds3 DestructibleAssetParameters::bounds

'bounds' : The AABB of the destructible asset

The axis-aligned bounding box of the destructible asset. This is the smallest AABB which contains all chunk AABBs.

ConvexHullParameters DestructibleAssetParameters::chunkConvexHulls[]

'chunkConvexHulls[]' :

U32 DestructibleAssetParameters::chunkConvexHullStartIndices[]

'chunkConvexHullStartIndices[]' : Map into array of convex hulls

Map into array of convex hulls. The convex hulls for chunk i are in the chunkConvexHulls array, starting at chunkConvexHulls[i], and ending at chunkConvexHulls[i+1]-1. The array length is one greater than that of chunkConvexHulls.

Vec3 DestructibleAssetParameters::chunkInstanceInfo[].chunkPositionOffset

'chunkInstanceInfo[].chunkPositionOffset' : Translation for this chunk mesh within the asset

Translation for this chunk mesh within the asset. Normally a chunk needs no translation, but if a chunk is instanced within the asset, then this translation is needed.

Vec2 DestructibleAssetParameters::chunkInstanceInfo[].chunkUVOffset

'chunkInstanceInfo[].chunkUVOffset' : UV translation for this chunk mesh's vertices

UV translation for this chunk mesh's vertices.

U16 DestructibleAssetParameters::chunkInstanceInfo[].partIndex

'chunkInstanceInfo[].partIndex' : The part instanced for this chunk

The part instanced for this chunk.

I8 DestructibleAssetParameters::chunks[].behaviorGroupIndex

'chunks[].behaviorGroupIndex' : Behavior group this chunk is associated with

Behavior group this chunk is associated with. This includes flags, damage threshold, density, impact resistance, and collision mask.

U16 DestructibleAssetParameters::chunks[].depth

'chunks[].depth' : The depth of the chunk in the hierarchy

The depth of the chunk in the hierarchy. Level 0 chunks correspond to the unfractured (original) mesh. Level 1 chunks are their children, formed by splitting level 0 chunks, etc.

U16 DestructibleAssetParameters::chunks[].firstChildIndex

'chunks[].firstChildIndex' : The index of this chunk's first child in the hierarchy

The index of this chunk's first child in the hierarchy. All children have contiguous chunk indices, and lie in the range [firstChildIndex,firstChildIndex+numChildren-1]. If the chunk has no children, this value is undefined.

U16 DestructibleAssetParameters::chunks[].firstScatterMesh

'chunks[].firstScatterMesh' : Index of first scatter mesh (in scatterMeshIndices and scatterMeshTransforms)

Index of first scatter mesh (in scatterMeshIndices and scatterMeshTransforms).

U16 DestructibleAssetParameters::chunks[].flags

'chunks[].flags' : Flags which define individual chunk attributes

Flags which define individual chunk attributes, such as support, fractureability, etc.

U16 DestructibleAssetParameters::chunks[].meshPartIndex

'chunks[].meshPartIndex' : The corresponding mesh part for this chunk

If this chunk is not instanced, this is the corresponding mesh part for this chunk, in the NxApexRenderMeshAsset included within this destructible asset. If this chunk is instanced, this refers to the InstanceInfo in the asset (see InstanceInfo).

U16 DestructibleAssetParameters::chunks[].numChildren

'chunks[].numChildren' : This chunk's number of children

This chunk's number of children. If not 0, firstChildIndex is valid (see firstChildIndex).

U16 DestructibleAssetParameters::chunks[].parentIndex

'chunks[].parentIndex' : The index of the chunk's parent in the hierarchy

The index of the chunk's parent in the hierarchy. If the chunk has no parent (its depth is 0), then the parentIndex is -1.

U16 DestructibleAssetParameters::chunks[].scatterMeshCount

'chunks[].scatterMeshCount' : Number of scatter meshes (in scatterMeshIndices and scatterMeshTransforms)

Number of scatter meshes (in scatterMeshIndices and scatterMeshTransforms).

Vec3 DestructibleAssetParameters::chunks[].surfaceNormal

'chunks[].surfaceNormal' : The average surface normal of this chunk

The average surface normal of this chunk. This is the normalized average of all triangle normals which are part of the original (unfractured) mesh.

DestructibleAssetCollisionDataSet DestructibleAssetParameters::collisionData

'collisionData' :

String DestructibleAssetParameters::comments

'comments' : Human-readable string which describes which tool created this asset, its version, etc.

Human-readable string which describes which tool created this asset, its version, etc.

String DestructibleAssetParameters::crumbleEmitterName

'crumbleEmitterName' : The name of the crumble emitter to use

The name of the crumble emitter to use when crumbling the smallest chunks.

Vec4 DestructibleAssetParameters::defaultBehaviorGroup.damageColorChange

'defaultBehaviorGroup.damageColorChange' : Describes how damage changes the color of vertices in the render mesh.

Describes how damage changes the color of vertices in the render mesh. If this vector is non-zero, then a dynamic (per-actor) color channel will be created and initialized to the asset's color channel, if it exists. Damage taken will go through the spread and envelope function described by damageColoring, and each color will be modified by the resulting damage, scaled by the values in damageColorChange. The change to color channel C is given by color[C] = clamp(color[C] + damageColorChange[C]*255*min(1.0, damage/damageThreshold), 0, 255).

F32 DestructibleAssetParameters::defaultBehaviorGroup.damageColorSpread.falloffExponent

'defaultBehaviorGroup.damageColorSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.

How damage varies between the minimum radius and the calculated damage radius. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier. Within the minimumRadius, the full damage is applied to chunks. Past the minimumRadius, the formla for damage is: damage = (input damage) * ((radius - distance)/(radius - minimumRadius))^falloffExponent. Note: falloffExponent = 0.0 gives no falloff, so that damage = (input damage) over the entire range [0, radius). falloffExponent = 1.0 gives linear falloff.

F32 DestructibleAssetParameters::defaultBehaviorGroup.damageColorSpread.minimumRadius

'defaultBehaviorGroup.damageColorSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.

The minimum radius of damage spread when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleAssetParameters::defaultBehaviorGroup.damageColorSpread.radiusMultiplier

'defaultBehaviorGroup.damageColorSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.

A scale to apply to the input damage radius when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleAssetParameters::defaultBehaviorGroup.damageSpread.falloffExponent

'defaultBehaviorGroup.damageSpread.falloffExponent' : How damage varies between the minimum radius and the calculated damage radius.

How damage varies between the minimum radius and the calculated damage radius. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier. Within the minimumRadius, the full damage is applied to chunks. Past the minimumRadius, the formla for damage is: damage = (input damage) * ((radius - distance)/(radius - minimumRadius))^falloffExponent. Note: falloffExponent = 0.0 gives no falloff, so that damage = (input damage) over the entire range [0, radius). falloffExponent = 1.0 gives linear falloff.

F32 DestructibleAssetParameters::defaultBehaviorGroup.damageSpread.minimumRadius

'defaultBehaviorGroup.damageSpread.minimumRadius' : The minimum radius of damage spread when damage is applied.

The minimum radius of damage spread when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleAssetParameters::defaultBehaviorGroup.damageSpread.radiusMultiplier

'defaultBehaviorGroup.damageSpread.radiusMultiplier' : A scale to apply to the input damage radius when damage is applied.

A scale to apply to the input damage radius when damage is applied. The formula for the damage radius is radius = minimumRadius + (input radius) * radiusMultiplier.

F32 DestructibleAssetParameters::defaultBehaviorGroup.damageThreshold

'defaultBehaviorGroup.damageThreshold' : The damage amount which will cause a chunk to fracture (break free) from the destructible.

The damage amount which will cause a chunk to fracture (break free) from the destructible. This is obtained from the damage value passed into the NxDestructibleActor::applyDamage, or NxDestructibleActor::applyRadiusDamage, or via impact (see 'forceToDamage', below).

F32 DestructibleAssetParameters::defaultBehaviorGroup.damageToRadius

'defaultBehaviorGroup.damageToRadius' : Controls the distance into the destructible to propagate damage.

Controls the distance into the destructible to propagate damage. The damage applied to the chunk is multiplied by damageToRadius, to get the propagation distance. All chunks within the radius will have damage applied to them. The damage applied to each chunk varies with distance to the damage application position. Full damage is taken at zero distance, and zero damage at the damage radius. NOTE: This parameter is deprecated for point and radius damage. It will be used for those types of damage if legacy damage behavior is enabled with NxModuleDestructible::setUseLegacyDamageRadiusSpread. Otherwise, the new parameters damageSpread.minimumRadius, damageSpread.radiusMultiplier, and damageSpread.falloffExponent are used. For impact damage, this parameter will continue to be used, however the radius will no longer scale with object size. The radius will continue to scale with the damage as a fraction of damageThreshold, however. If legacy damage behavior is used, this parameter will behave as before with respect to impact damage as well (scaling with object size).

F32 DestructibleAssetParameters::defaultBehaviorGroup.density

'defaultBehaviorGroup.density' : Chunk density

Chunk density. (TODO: better description)

F32 DestructibleAssetParameters::defaultBehaviorGroup.fadeOut

'defaultBehaviorGroup.fadeOut' : Chunk fade out

Chunk fade out. (TODO: better description)

F32 DestructibleAssetParameters::defaultBehaviorGroup.materialStrength

'defaultBehaviorGroup.materialStrength' : When a chunk takes impact, this is the maximum impulse the contact can generate.

When a chunk takes impact damage due to physical contact (see see NxDestructibleDepthParameters), this parameter is the maximum impulse the contact can generate. Weak materials such as glass may have this set to a low value, so that heavier objects will pass through them during fracture. N.B.: Setting this parameter to 0 disables the impulse cap; that is, zero is interpreted as infinite. Default value = 0.0f.

F32 DestructibleAssetParameters::defaultBehaviorGroup.maxDepenetrationVelocity

'defaultBehaviorGroup.maxDepenetrationVelocity' : Chunk maximum depenetration velocity

In case some chunk is created inside static geometry it will be pushed out of it without limiting it's velocity. Sometimes it's not desirable, so this parameter can limit depenetration velocity. Keep in mind, that for low values you can see chunks 'floating' off the static meshes, which is also not always desirable.

String DestructibleAssetParameters::defaultBehaviorGroup.name

'defaultBehaviorGroup.name' : Name of behavior group

Name of behavior group, eg Concrete or Glass.

U64 DestructibleAssetParameters::defaultBehaviorGroup.userData

'defaultBehaviorGroup.userData' : User data field.

User data field. This 64-bit field can be set and retrieved by the user at runtime.

U32 DestructibleAssetParameters::depthCount

'depthCount' : The number of chunk depth levels

The number of chunk depth levels. This is 1 for an unfractured mesh.

Bool DestructibleAssetParameters::depthParameters[].IGNORE_CONTACT_CALLBACKS

'depthParameters[].IGNORE_CONTACT_CALLBACKS' : Chunks at this depth should be ignored in contact callbacks.

Chunks at this depth should be ignored in contact callbacks.

Bool DestructibleAssetParameters::depthParameters[].IGNORE_POSE_UPDATES

'depthParameters[].IGNORE_POSE_UPDATES' : Chunks at this depth should have pose updates ignored.

Chunks at this depth should have pose updates ignored.

Bool DestructibleAssetParameters::depthParameters[].IGNORE_RAYCAST_CALLBACKS

'depthParameters[].IGNORE_RAYCAST_CALLBACKS' : Chunks at this depth should be ignored in raycast callbacks.

Chunks at this depth should be ignored in raycast callbacks.

Bool DestructibleAssetParameters::depthParameters[].OVERRIDE_IMPACT_DAMAGE

'depthParameters[].OVERRIDE_IMPACT_DAMAGE' : If true, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE_VALUE = TRUE, no matter the setting of impactDamageDefaultDepth.

Chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE_VALUE = TRUE, no matter the setting of impactDamageDefaultDepth.

Bool DestructibleAssetParameters::depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE

'depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE' : If OVERRIDE_IMPACT_DAMAGE = TRUE, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE_VALUE = TRUE.

If OVERRIDE_IMPACT_DAMAGE = TRUE, chunks at this hierarchy depth level will take impact damage iff OVERRIDE_IMPACT_DAMAGE_VALUE = TRUE.

Bool DestructibleAssetParameters::depthParameters[].USER_FLAG_0

'depthParameters[].USER_FLAG_0' : User defined flag.

User defined flag.

Bool DestructibleAssetParameters::depthParameters[].USER_FLAG_1

'depthParameters[].USER_FLAG_1' : User defined flag.

User defined flag.

Bool DestructibleAssetParameters::depthParameters[].USER_FLAG_2

'depthParameters[].USER_FLAG_2' : User defined flag.

User defined flag.

Bool DestructibleAssetParameters::depthParameters[].USER_FLAG_3

'depthParameters[].USER_FLAG_3' : User defined flag.

User defined flag.

F32 DestructibleAssetParameters::destructibleParameters.damageCap

'destructibleParameters.damageCap' : Limits the amount of damage applied to a chunk.

Limits the amount of damage applied to a chunk. This is useful for preventing the entire destructible from getting pulverized by a very large application of damage. This can easily happen when impact damage is used, and the damage amount is proportional to the impact force (see forceToDamage).

U16 DestructibleAssetParameters::destructibleParameters.damageDepthLimit

'destructibleParameters.damageDepthLimit' : How deep in the hierarchy damage will be propagated, relative to the chunk hit.

How deep in the hierarchy damage will be propagated, relative to the chunk hit.

I32 DestructibleAssetParameters::destructibleParameters.debrisDepth

'destructibleParameters.debrisDepth' : The chunk hierarchy depth at which chunks are considered to be 'debris.'

The chunk hierarchy depth at which chunks are considered to be 'debris.' Chunks at this depth or below will be considered for various debris settings, such as debrisLifetime. Negative values indicate that no chunk depth is considered debris. Default value is -1.

F32 DestructibleAssetParameters::destructibleParameters.debrisDestructionProbability

'destructibleParameters.debrisDestructionProbability' : The probablity that a debris chunk, when fractured, will simply be destroyed

The probablity that a debris chunk, when fractured, will simply be destroyed instead of becoming dynamic or breaking down further into child chunks. Valid range = [0.0,1.0]. Default value = 0.0.

F32 DestructibleAssetParameters::destructibleParameters.debrisLifetimeMax

'destructibleParameters.debrisLifetimeMax' : Maximum time to destroy debris

'Debris chunks' (see debrisDepth, above) will be destroyed after a time (in seconds) separated from non-debris chunks. The actual lifetime is interpolated between debrisLifetimeMin (see above) and debrisLifetimeMax, based upon the module's LOD setting. To disable lifetime, clear the NxDestructibleDepthParametersFlag::DEBRIS_TIMEOUT flag in the flags field. If debrisLifetimeMax < debrisLifetimeMin, the mean of the two is used for both. Default debrisLifetimeMin = 1.0, debrisLifetimeMax = 10.0f.

F32 DestructibleAssetParameters::destructibleParameters.debrisLifetimeMin

'destructibleParameters.debrisLifetimeMin' : Minimum time to destroy debris

'Debris chunks' (see debrisDepth, above) will be destroyed after a time (in seconds) separated from non-debris chunks. The actual lifetime is interpolated between debrisLifetimeMin and debrisLifetimeMax (see below), based upon the module's LOD setting. To disable lifetime, clear the NxDestructibleDepthParametersFlag::DEBRIS_TIMEOUT flag in the flags field. If debrisLifetimeMax < debrisLifetimeMin, the mean of the two is used for both. Default debrisLifetimeMin = 1.0, debrisLifetimeMax = 10.0f.

F32 DestructibleAssetParameters::destructibleParameters.debrisMaxSeparationMax

'destructibleParameters.debrisMaxSeparationMax' : Minimum separation distance

'Debris chunks' (see debrisDepth, above) will be destroyed if they are separated from their origin by a distance greater than maxSeparation. The actual maxSeparation is interpolated between debrisMaxSeparationMin (see above) and debrisMaxSeparationMax, based upon the module's LOD setting. To disable maxSeparation, clear the NX_DESTRUCTIBLE_DEBRIS_MAX_SEPARATION flag in the flags field. If debrisMaxSeparationMax < debrisMaxSeparationMin, the mean of the two is used for both. Default debrisMaxSeparationMin = 1.0, debrisMaxSeparationMax = 10.0f.

F32 DestructibleAssetParameters::destructibleParameters.debrisMaxSeparationMin

'destructibleParameters.debrisMaxSeparationMin' : Minimum separation distance

'Debris chunks' (see debrisDepth, above) will be destroyed if they are separated from their origin by a distance greater than maxSeparation. The actual maxSeparation is interpolated between debrisMaxSeparationMin and debrisMaxSeparationMax (see below), based upon the module's LOD setting. To disable maxSeparation, clear the NX_DESTRUCTIBLE_DEBRIS_MAX_SEPARATION flag in the flags field. If debrisMaxSeparationMax < debrisMaxSeparationMin, the mean of the two is used for both. Default debrisMaxSeparationMin = 1.0, debrisMaxSeparationMax = 10.0f.

U16 DestructibleAssetParameters::destructibleParameters.dynamicChunkDominanceGroup

'destructibleParameters.dynamicChunkDominanceGroup' : Optional dominance group for dynamic chunks created when fractured.

Optional dominance group for dynamic chunks created when fractured. (ignored if > 31)

U32 DestructibleAssetParameters::destructibleParameters.dynamicChunksGroupsMask.bits0

'destructibleParameters.dynamicChunksGroupsMask.bits0' : bits0 of the groups mask

If useGroupsMask is true, this is bits0 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleAssetParameters::destructibleParameters.dynamicChunksGroupsMask.bits1

'destructibleParameters.dynamicChunksGroupsMask.bits1' : bits1 of the groups mask

If useGroupsMask is true, this is bits1 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleAssetParameters::destructibleParameters.dynamicChunksGroupsMask.bits2

'destructibleParameters.dynamicChunksGroupsMask.bits2' : bits2 of the groups mask

If useGroupsMask is true, this is bits2 of the groups mask. See the PhysX documentation for more on groups masks.

U32 DestructibleAssetParameters::destructibleParameters.dynamicChunksGroupsMask.bits3

'destructibleParameters.dynamicChunksGroupsMask.bits3' : bits3 of the groups mask

If useGroupsMask is true, this is bits3 of the groups mask. See the PhysX documentation for more on groups masks.

Bool DestructibleAssetParameters::destructibleParameters.dynamicChunksGroupsMask.useGroupsMask

'destructibleParameters.dynamicChunksGroupsMask.useGroupsMask' : Whether or not the groupsMask should be used

Whether or not the groupsMask should be used. If so, then this will be applied to all NxShapes created to represent this destructible's chunks.

U32 DestructibleAssetParameters::destructibleParameters.essentialDepth

'destructibleParameters.essentialDepth' : The chunk hierarchy depth up to which chunks will always be processed

The chunk hierarchy depth up to which chunks will always be processed. These chunks are considered to be essential either for gameplay or visually. The minimum value is 0, meaning the level 0 chunk is always considered essential. Default value is 0.

Bool DestructibleAssetParameters::destructibleParameters.flags.ACCUMULATE_DAMAGE

'destructibleParameters.flags.ACCUMULATE_DAMAGE' : Determines if chunks accumulate damage

If set, chunks will 'remember' damage applied to them, so that many applications of a damage amount below damageThreshold will eventually fracture the chunk. If not set, a single application of damage must exceed damageThreshold in order to fracture the chunk.

Bool DestructibleAssetParameters::destructibleParameters.flags.ACCURATE_RAYCASTS

'destructibleParameters.flags.ACCURATE_RAYCASTS' : If set, the NxDestructibleActor::rayCast function will search within the nearest visible chunk hit

If set, the NxDestructibleActor::rayCast function will search within the nearest visible chunk hit for collisions with child chunks. This is used to get a better raycast position and normal, in case the parent collision volume does not tightly fit the graphics mesh. The returned chunk index will always be that of the visible parent that is intersected, however.

Bool DestructibleAssetParameters::destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS

'destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS' : If set, the smallest chunks may be further broken down

If set, the smallest chunks may be further broken down, either by fluid crumbles (if a crumble particle system is specified in the NxDestructibleActorDesc), or by simply removing the chunk if no crumble particle system is specified. Note: the 'smallest chunks' are normally defined to be the deepest level of the fracture hierarchy. However, they may be taken from higher levels of the hierarchy if NxModuleDestructible::setMaxChunkDepthOffset is called with a non-zero value.

Bool DestructibleAssetParameters::destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE

'destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE' : If set, crumbled chunks will use the runtime fracture pipeline.

If set, crumbled chunks will use the runtime fracture pipeline. The chunk will be procedurally broken destroyed using either the default or a specified fracture pattern.

Bool DestructibleAssetParameters::destructibleParameters.flags.DEBRIS_MAX_SEPARATION

'destructibleParameters.flags.DEBRIS_MAX_SEPARATION' : Whether or not chunks at or deeper than the 'debris' depth will be removed if separated too far

Whether or not chunks at or deeper than the 'debris' depth (see NxDestructibleParameters::debrisDepth) will be removed if they separate too far from their origins. The maxSeparation is a value between NxDestructibleParameters::debrisMaxSeparationMin and NxDestructibleParameters::debrisMaxSeparationMax, based upon the destructible module's LOD setting.

Bool DestructibleAssetParameters::destructibleParameters.flags.DEBRIS_TIMEOUT

'destructibleParameters.flags.DEBRIS_TIMEOUT' : Whether or not chunks at or deeper than the 'debris' depth will timeout

Whether or not chunks at or deeper than the 'debris' depth (see NxDestructibleParameters::debrisDepth) will time out. The lifetime is a value between NxDestructibleParameters::debrisLifetimeMin and NxDestructibleParameters::debrisLifetimeMax, based upon the destructible module's LOD setting.

Bool DestructibleAssetParameters::destructibleParameters.flags.USE_VALID_BOUNDS

'destructibleParameters.flags.USE_VALID_BOUNDS' : If set, the validBounds field of NxDestructibleParameters will be used.

If set, the validBounds field of NxDestructibleParameters will be used. These bounds are translated (but not scaled or rotated) to the origin of the destructible actor. If a chunk or chunk island moves outside of those bounds, it is destroyed.

F32 DestructibleAssetParameters::destructibleParameters.forceToDamage

'destructibleParameters.forceToDamage' : Multiplier to calculate applied damage from an impact.

If a chunk is at a depth which takes impact damage (see NxDestructibleDepthParameters), then when a chunk has a collision in the NxScene, it will take damage equal to forceToDamage mulitplied by the impact force. The default value is zero, which effectively disables impact damage.

F32 DestructibleAssetParameters::destructibleParameters.fractureImpulseScale

'destructibleParameters.fractureImpulseScale' : Scale factor used to apply an impulse force along the normal of chunk when fractured.

Scale factor used to apply an impulse force along the normal of chunk when fractured. This is used in order to 'push' the pieces out as they fracture.

I32 DestructibleAssetParameters::destructibleParameters.impactDamageDefaultDepth

'destructibleParameters.impactDamageDefaultDepth' : The default depth to which chunks will take impact damage.

The default depth to which chunks will take impact damage. This default may be overridden in the depth settings.

F32 DestructibleAssetParameters::destructibleParameters.impactVelocityThreshold

'destructibleParameters.impactVelocityThreshold' : Large impact force may be reported if rigid bodies are spawned inside one another.

Large impact force may be reported if rigid bodies are spawned inside one another. In this case the relative velocity of the two objects will be low. This variable allows the user to set a minimum velocity threshold for impacts to ensure that the objects are moving at a min velocity in order for the impact force to be considered.

I8 DestructibleAssetParameters::destructibleParameters.legacyChunkBoundsTestSetting

'destructibleParameters.legacyChunkBoundsTestSetting' : Whether or not to use the old chunk bounds testing for damage, or use the module setting.

Whether or not to use the old chunk bounds testing for damage, or use the module setting. A value of 0 forces the new method to be used. A positive value forces the old method to be used. Negative values cause the global (NxModuleDestructible) setting to be used.

I8 DestructibleAssetParameters::destructibleParameters.legacyDamageRadiusSpreadSetting

'destructibleParameters.legacyDamageRadiusSpreadSetting' : Whether or not to use the old damage spread method, or use the module setting.

Whether or not to use the old damage spread method, or use the module setting. A value of 0 forces the new method to be used. A positive value forces the old method to be used. Negative values cause the global (NxModuleDestructible) setting to be used.

F32 DestructibleAssetParameters::destructibleParameters.maxChunkSpeed

'destructibleParameters.maxChunkSpeed' : Maximum speed of a chunk

If greater than 0, the chunks' speeds will not be allowed to exceed this value. Use 0 to disable this feature (this is the default).

U32 DestructibleAssetParameters::destructibleParameters.minimumFractureDepth

'destructibleParameters.minimumFractureDepth' : The chunks will not be broken free below this depth.

Chunks will not be broken free below this depth.

Bool DestructibleAssetParameters::destructibleParameters.runtimeFracture.attachment.negX

'destructibleParameters.runtimeFracture.attachment.negX' : Attach to negative x side of sheet.

If true, make the negative x side of the sheet an attachment point.

Bool DestructibleAssetParameters::destructibleParameters.runtimeFracture.attachment.negY

'destructibleParameters.runtimeFracture.attachment.negY' : Attach to negative y side of sheet.

If true, make the negative y side of the sheet an attachment point.

Bool DestructibleAssetParameters::destructibleParameters.runtimeFracture.attachment.negZ

'destructibleParameters.runtimeFracture.attachment.negZ' : Attach to negative z side of sheet.

If true, make the negative z side of the sheet an attachment point.

Bool DestructibleAssetParameters::destructibleParameters.runtimeFracture.attachment.posX

'destructibleParameters.runtimeFracture.attachment.posX' : Attach to positive x side of sheet.

If true, make the positive x side of the sheet an attachment point.

Bool DestructibleAssetParameters::destructibleParameters.runtimeFracture.attachment.posY

'destructibleParameters.runtimeFracture.attachment.posY' : Attach to positive y side of sheet.

If true, make the positive y side of the sheet an attachment point.

Bool DestructibleAssetParameters::destructibleParameters.runtimeFracture.attachment.posZ

'destructibleParameters.runtimeFracture.attachment.posZ' : Attach to positive z side of sheet.

If true, make the positive z side of the sheet an attachment point.

U32 DestructibleAssetParameters::destructibleParameters.runtimeFracture.depthLimit

'destructibleParameters.runtimeFracture.depthLimit' : Number of times deep a chunk can be fractured.

Number of times deep a chunk can be fractured. Can help limit the number of chunks produced by runtime fracture.

Bool DestructibleAssetParameters::destructibleParameters.runtimeFracture.destroyIfAtDepthLimit

'destructibleParameters.runtimeFracture.destroyIfAtDepthLimit' : Destroy chunk if at depth limit

If true, destroy chunks when they hit their depth limit. If false, then chunks at their depth limit will not fracture but will have a force applied.

F32 DestructibleAssetParameters::destructibleParameters.runtimeFracture.glass.firstSegmentSize

'destructibleParameters.runtimeFracture.glass.firstSegmentSize' : The minimum shard size.

The minimum shard size. Shards below this size will not be created and thus not visible.

U32 DestructibleAssetParameters::destructibleParameters.runtimeFracture.glass.numSectors

'destructibleParameters.runtimeFracture.glass.numSectors' : Number of angular slices.

Number of angular slices in the glass fracture pattern.

F32 DestructibleAssetParameters::destructibleParameters.runtimeFracture.glass.sectorRand

'destructibleParameters.runtimeFracture.glass.sectorRand' : Creates variance in the angle of slices.

Creates variance in the angle of slices. A value of zero results in all angular slices having the same angle.

F32 DestructibleAssetParameters::destructibleParameters.runtimeFracture.glass.segmentRand

'destructibleParameters.runtimeFracture.glass.segmentRand' : Creates variance in the radial size of shards.

Creates variance in the radial size of shards. A value of zero results in a low noise circular pattern.

F32 DestructibleAssetParameters::destructibleParameters.runtimeFracture.glass.segmentScale

'destructibleParameters.runtimeFracture.glass.segmentScale' : Scales the radial spacing.

Scales the radial spacing in the glass fracture pattern. A larger value results in radially longer shards.

F32 DestructibleAssetParameters::destructibleParameters.runtimeFracture.impulseScale

'destructibleParameters.runtimeFracture.impulseScale' : Scales impulse applied by a fracture.

Scales impulse applied by a fracture.

F32 DestructibleAssetParameters::destructibleParameters.runtimeFracture.minConvexSize

'destructibleParameters.runtimeFracture.minConvexSize' : Minimum Convex Size.

Minimum Convex Size. Minimum size of convex produced by a fracture.

RuntimeFractureType DestructibleAssetParameters::destructibleParameters.runtimeFracture.RuntimeFractureType

'destructibleParameters.runtimeFracture.RuntimeFractureType' : Which type of fracture pattern to choose

Bool DestructibleAssetParameters::destructibleParameters.runtimeFracture.sheetFracture

'destructibleParameters.runtimeFracture.sheetFracture' : If true, align fracture pattern to largest face

If true, align fracture pattern to largest face. If false, the fracture pattern will be aligned to the hit normal with each fracture.

F32 DestructibleAssetParameters::destructibleParameters.runtimeFracture.voronoi.biasExp

'destructibleParameters.runtimeFracture.voronoi.biasExp' : Bias Exponential value.

Bias Exponential value is used in distributing voronoi points which is used to fracture the original chunk.

Vec3 DestructibleAssetParameters::destructibleParameters.runtimeFracture.voronoi.dimensions

'destructibleParameters.runtimeFracture.voronoi.dimensions' : The size of the entire block

The size of the entire block.

F32 DestructibleAssetParameters::destructibleParameters.runtimeFracture.voronoi.maxDist

'destructibleParameters.runtimeFracture.voronoi.maxDist' : The max distance a Voronoi point away from origin.

This is to prevent a illegal voronoi point that's used to generate voronoi chunks.

U32 DestructibleAssetParameters::destructibleParameters.runtimeFracture.voronoi.numCells

'destructibleParameters.runtimeFracture.voronoi.numCells' : Max Number of Cells to create.

Number of Cells corresponds to the number of chunks to create during the fracture, default value is only one chunk.

F32 DestructibleAssetParameters::destructibleParameters.supportStrength

'destructibleParameters.supportStrength' : The support strength threshold for breaking chunks in stressSolver

The larger the supportStrength is, the harder it will break under stressSolver. SupportStrength should be larger than 0.0 so that it is not extremely fragile. Default supportStrength = -1.0 which means strength is turned off initially.

Bounds3 DestructibleAssetParameters::destructibleParameters.validBounds

'destructibleParameters.validBounds' : valid bounding region for debris

A bounding box around each NxDestructibleActor created, defining a range of validity for chunks that break free. These bounds are scaled and translated with the NxDestructibleActor's scale and position, but they are not rotated with the NxDestructibleActor.

String DestructibleAssetParameters::dustEmitterName

'dustEmitterName' : The name of the dust emitter to use

The name of the dust emitter to use. If defined, dust particles will be spawned above the chunk surface traces when a chunk is fractured.

U32 DestructibleAssetParameters::firstChunkAtDepth[]

'firstChunkAtDepth[]' : The first index of chunks at each depth

The first index of chunks at each depth in the hierarchy. All chunks at a given depth are stored contiguously.

Bool DestructibleAssetParameters::formExtendedStructures

'formExtendedStructures' : If initially static, the destructible will become part of an extended support structure if it is in contact with another static destructible that also has this flag set.

If initially static, the destructible will become part of an extended support structure if it is in contact with another static destructible that also has this flag set.

U32 DestructibleAssetParameters::initialDestructibleActorAllowanceForInstancing

'initialDestructibleActorAllowanceForInstancing' : Initial actor estimate for instance buffer allocation

Initial actor estimate for instance buffer allocation. Used for setting instance buffer sizes.

F32 DestructibleAssetParameters::neighborPadding

'neighborPadding' : Padding used for chunk neighbor tests.

Padding used for chunk neighbor tests. This padding is relative to the largest diagonal of the asset's local bounding box. This value must be non-negative. Default value = 0.001f.

U32 DestructibleAssetParameters::originalDepthCount

'originalDepthCount' : The depth count when authored

The depth count when authored - this way we can tell how far it's been reduced.

CachedOverlaps DestructibleAssetParameters::overlapsAtDepth[]

'overlapsAtDepth[]' :

RenderMeshAssetParameters DestructibleAssetParameters::renderMeshAsset

'renderMeshAsset' :

I8 DestructibleAssetParameters::RTFractureBehaviorGroup

'RTFractureBehaviorGroup' : The array of behavior groups referenced by chunks

The array of behavior groups referenced by chunks. Each chunk references a behavior group for chunk-specific reactions.

RenderMeshAssetParameters DestructibleAssetParameters::scatterMeshAssets[]

'scatterMeshAssets[]' :

U8 DestructibleAssetParameters::scatterMeshIndices[]

'scatterMeshIndices[]' : Array of indices for scatter meshes defined in the asset

Array of indices for scatter meshes defined in the asset. Valid indices must be in the range [0,N), where N is the size of the scatterMeshAssets array.

Mat33 DestructibleAssetParameters::scatterMeshTransforms[].matrix

'scatterMeshTransforms[].matrix' : The matrix part of the transform, containing the (possibly scaled axis-unaligned) rotation

The matrix part of the transform, containing the (possibly scaled axis-unaligned) rotation.

Vec3 DestructibleAssetParameters::scatterMeshTransforms[].vector

'scatterMeshTransforms[].vector' : The vector part of the transform, containing a translation

The vector part of the transform, containing a translation.

String DestructibleAssetParameters::staticMaterialNames[]

'staticMaterialNames[]' : Alternative material names for the static render mesh, if it's created

Alternative material names for the static render mesh, if it's created.

U32 DestructibleAssetParameters::supportDepth

'supportDepth' : The chunk hierarchy depth at which to create a support graph.

The chunk hierarchy depth at which to create a support graph. Higher depth levels give more detailed support, but will give a higher computational load. Chunks below the support depth will never be supported.

Bool DestructibleAssetParameters::useAssetDefinedSupport

'useAssetDefinedSupport' : If set, then chunks which are tagged as 'support' chunks

If set, then chunks which are tagged as 'support' chunks (via NxDestructibleChunkDesc::isSupportChunk) will have environmental support in static destructibles. Note: if both ASSET_DEFINED_SUPPORT and WORLD_SUPPORT are set, then chunks must be tagged as 'support' chunks AND overlap the NxScene's static geometry in order to be environmentally supported.

Bool DestructibleAssetParameters::useWorldSupport

'useWorldSupport' : If set, then chunks which overlap the NxScene's static geometry will have environmental support

If set, then chunks which overlap the NxScene's static geometry will have environmental support in static destructibles. Note: if both ASSET_DEFINED_SUPPORT and WORLD_SUPPORT are set, then chunks must be tagged as 'support' chunks AND overlap the NxScene's static geometry in order to be environmentally supported.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
DestructibleAssetParameters Member List
This is the complete list of members for DestructibleAssetParameters, including all inherited members.
actorTransforms[] | DestructibleAssetParameters
behaviorGroups[].damageColorChange | DestructibleAssetParameters
behaviorGroups[].damageColorSpread.falloffExponent | DestructibleAssetParameters
behaviorGroups[].damageColorSpread.minimumRadius | DestructibleAssetParameters
behaviorGroups[].damageColorSpread.radiusMultiplier | DestructibleAssetParameters
behaviorGroups[].damageSpread.falloffExponent | DestructibleAssetParameters
behaviorGroups[].damageSpread.minimumRadius | DestructibleAssetParameters
behaviorGroups[].damageSpread.radiusMultiplier | DestructibleAssetParameters
behaviorGroups[].damageThreshold | DestructibleAssetParameters
behaviorGroups[].damageToRadius | DestructibleAssetParameters
behaviorGroups[].density | DestructibleAssetParameters
behaviorGroups[].fadeOut | DestructibleAssetParameters
behaviorGroups[].materialStrength | DestructibleAssetParameters
behaviorGroups[].maxDepenetrationVelocity | DestructibleAssetParameters
behaviorGroups[].name | DestructibleAssetParameters
behaviorGroups[].userData | DestructibleAssetParameters
bounds | DestructibleAssetParameters
chunkConvexHulls[] | DestructibleAssetParameters
chunkConvexHullStartIndices[] | DestructibleAssetParameters
chunkInstanceInfo[].chunkPositionOffset | DestructibleAssetParameters
chunkInstanceInfo[].chunkUVOffset | DestructibleAssetParameters
chunkInstanceInfo[].partIndex | DestructibleAssetParameters
chunks[].behaviorGroupIndex | DestructibleAssetParameters
chunks[].depth | DestructibleAssetParameters
chunks[].firstChildIndex | DestructibleAssetParameters
chunks[].firstScatterMesh | DestructibleAssetParameters
chunks[].flags | DestructibleAssetParameters
chunks[].meshPartIndex | DestructibleAssetParameters
chunks[].numChildren | DestructibleAssetParameters
chunks[].parentIndex | DestructibleAssetParameters
chunks[].scatterMeshCount | DestructibleAssetParameters
chunks[].surfaceNormal | DestructibleAssetParameters
collisionData | DestructibleAssetParameters
comments | DestructibleAssetParameters
crumbleEmitterName | DestructibleAssetParameters
defaultBehaviorGroup.damageColorChange | DestructibleAssetParameters
defaultBehaviorGroup.damageColorSpread.falloffExponent | DestructibleAssetParameters
defaultBehaviorGroup.damageColorSpread.minimumRadius | DestructibleAssetParameters
defaultBehaviorGroup.damageColorSpread.radiusMultiplier | DestructibleAssetParameters
defaultBehaviorGroup.damageSpread.falloffExponent | DestructibleAssetParameters
defaultBehaviorGroup.damageSpread.minimumRadius | DestructibleAssetParameters
defaultBehaviorGroup.damageSpread.radiusMultiplier | DestructibleAssetParameters
defaultBehaviorGroup.damageThreshold | DestructibleAssetParameters
defaultBehaviorGroup.damageToRadius | DestructibleAssetParameters
defaultBehaviorGroup.density | DestructibleAssetParameters
defaultBehaviorGroup.fadeOut | DestructibleAssetParameters
defaultBehaviorGroup.materialStrength | DestructibleAssetParameters
defaultBehaviorGroup.maxDepenetrationVelocity | DestructibleAssetParameters
defaultBehaviorGroup.name | DestructibleAssetParameters
defaultBehaviorGroup.userData | DestructibleAssetParameters
depthCount | DestructibleAssetParameters
depthParameters[].IGNORE_CONTACT_CALLBACKS | DestructibleAssetParameters
depthParameters[].IGNORE_POSE_UPDATES | DestructibleAssetParameters
depthParameters[].IGNORE_RAYCAST_CALLBACKS | DestructibleAssetParameters
depthParameters[].OVERRIDE_IMPACT_DAMAGE | DestructibleAssetParameters
depthParameters[].OVERRIDE_IMPACT_DAMAGE_VALUE | DestructibleAssetParameters
depthParameters[].USER_FLAG_0 | DestructibleAssetParameters
depthParameters[].USER_FLAG_1 | DestructibleAssetParameters
depthParameters[].USER_FLAG_2 | DestructibleAssetParameters
depthParameters[].USER_FLAG_3 | DestructibleAssetParameters
destructibleParameters.damageCap | DestructibleAssetParameters
destructibleParameters.damageDepthLimit | DestructibleAssetParameters
destructibleParameters.debrisDepth | DestructibleAssetParameters
destructibleParameters.debrisDestructionProbability | DestructibleAssetParameters
destructibleParameters.debrisLifetimeMax | DestructibleAssetParameters
destructibleParameters.debrisLifetimeMin | DestructibleAssetParameters
destructibleParameters.debrisMaxSeparationMax | DestructibleAssetParameters
destructibleParameters.debrisMaxSeparationMin | DestructibleAssetParameters
destructibleParameters.dynamicChunkDominanceGroup | DestructibleAssetParameters
destructibleParameters.dynamicChunksGroupsMask.bits0 | DestructibleAssetParameters
destructibleParameters.dynamicChunksGroupsMask.bits1 | DestructibleAssetParameters
destructibleParameters.dynamicChunksGroupsMask.bits2 | DestructibleAssetParameters
destructibleParameters.dynamicChunksGroupsMask.bits3 | DestructibleAssetParameters
destructibleParameters.dynamicChunksGroupsMask.useGroupsMask | DestructibleAssetParameters
destructibleParameters.essentialDepth | DestructibleAssetParameters
destructibleParameters.flags.ACCUMULATE_DAMAGE | DestructibleAssetParameters
destructibleParameters.flags.ACCURATE_RAYCASTS | DestructibleAssetParameters
destructibleParameters.flags.CRUMBLE_SMALLEST_CHUNKS | DestructibleAssetParameters
destructibleParameters.flags.CRUMBLE_VIA_RUNTIME_FRACTURE | DestructibleAssetParameters
destructibleParameters.flags.DEBRIS_MAX_SEPARATION | DestructibleAssetParameters
destructibleParameters.flags.DEBRIS_TIMEOUT | DestructibleAssetParameters
destructibleParameters.flags.USE_VALID_BOUNDS | DestructibleAssetParameters
destructibleParameters.forceToDamage | DestructibleAssetParameters
destructibleParameters.fractureImpulseScale | DestructibleAssetParameters
destructibleParameters.impactDamageDefaultDepth | DestructibleAssetParameters
destructibleParameters.impactVelocityThreshold | DestructibleAssetParameters
destructibleParameters.legacyChunkBoundsTestSetting | DestructibleAssetParameters
destructibleParameters.legacyDamageRadiusSpreadSetting | DestructibleAssetParameters
destructibleParameters.maxChunkSpeed | DestructibleAssetParameters
destructibleParameters.minimumFractureDepth | DestructibleAssetParameters
destructibleParameters.runtimeFracture.attachment.negX | DestructibleAssetParameters
destructibleParameters.runtimeFracture.attachment.negY | DestructibleAssetParameters
destructibleParameters.runtimeFracture.attachment.negZ | DestructibleAssetParameters
destructibleParameters.runtimeFracture.attachment.posX | DestructibleAssetParameters
destructibleParameters.runtimeFracture.attachment.posY | DestructibleAssetParameters
destructibleParameters.runtimeFracture.attachment.posZ | DestructibleAssetParameters
destructibleParameters.runtimeFracture.depthLimit | DestructibleAssetParameters
destructibleParameters.runtimeFracture.destroyIfAtDepthLimit | DestructibleAssetParameters
destructibleParameters.runtimeFracture.glass.firstSegmentSize | DestructibleAssetParameters
destructibleParameters.runtimeFracture.glass.numSectors | DestructibleAssetParameters
destructibleParameters.runtimeFracture.glass.sectorRand | DestructibleAssetParameters
destructibleParameters.runtimeFracture.glass.segmentRand | DestructibleAssetParameters
destructibleParameters.runtimeFracture.glass.segmentScale | DestructibleAssetParameters
destructibleParameters.runtimeFracture.impulseScale | DestructibleAssetParameters
destructibleParameters.runtimeFracture.minConvexSize | DestructibleAssetParameters
destructibleParameters.runtimeFracture.RuntimeFractureType | DestructibleAssetParameters
destructibleParameters.runtimeFracture.sheetFracture | DestructibleAssetParameters
destructibleParameters.runtimeFracture.voronoi.biasExp | DestructibleAssetParameters
destructibleParameters.runtimeFracture.voronoi.dimensions | DestructibleAssetParameters
destructibleParameters.runtimeFracture.voronoi.maxDist | DestructibleAssetParameters
destructibleParameters.runtimeFracture.voronoi.numCells | DestructibleAssetParameters
destructibleParameters.supportStrength | DestructibleAssetParameters
destructibleParameters.validBounds | DestructibleAssetParameters
dustEmitterName | DestructibleAssetParameters
firstChunkAtDepth[] | DestructibleAssetParameters
formExtendedStructures | DestructibleAssetParameters
initialDestructibleActorAllowanceForInstancing | DestructibleAssetParameters
neighborPadding | DestructibleAssetParameters
originalDepthCount | DestructibleAssetParameters
overlapsAtDepth[] | DestructibleAssetParameters
renderMeshAsset | DestructibleAssetParameters
RTFractureBehaviorGroup | DestructibleAssetParameters
scatterMeshAssets[] | DestructibleAssetParameters
scatterMeshIndices[] | DestructibleAssetParameters
scatterMeshTransforms[].matrix | DestructibleAssetParameters
scatterMeshTransforms[].vector | DestructibleAssetParameters
staticMaterialNames[] | DestructibleAssetParameters
supportDepth | DestructibleAssetParameters
useAssetDefinedSupport | DestructibleAssetParameters
useWorldSupport | DestructibleAssetParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: DestructibleDebugRenderParams Struct Reference

  • Class List
  • Class Members
Public Attributes
DestructibleDebugRenderParams Struct Reference

Describes the NxParameterized::Interface for 'DestructibleDebugRenderParams' : More...

#include <params.h>

List of all members.

Public Attributes

Bool | VISUALIZE_DESTRUCTIBLE_ACTOR
'VISUALIZE_DESTRUCTIBLE_ACTOR' : Module switch - whether or not to visualize destruction.
F32 | VISUALIZE_DESTRUCTIBLE_BOUNDS
'VISUALIZE_DESTRUCTIBLE_BOUNDS' : Shows the axis-aligned bounding box which contains all chunks for each destructible actor.
F32 | VISUALIZE_DESTRUCTIBLE_SUPPORT
'VISUALIZE_DESTRUCTIBLE_SUPPORT' : Shows the support graph as lines and support chunks' bounding boxes.
Bool | VISUALIZE_DESTRUCTIBLE_ACTOR_POSE
'VISUALIZE_DESTRUCTIBLE_ACTOR_POSE' : Shows the coordinate frame representing the local origin for unfractured destructibles.
F32 | THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_POSE
'THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_POSE' : If VISUALIZE_DESTRUCTIBLE_ACTOR_POSE is true, the maximum object-to-eye distance to draw the chunk poses.
Bool | VISUALIZE_DESTRUCTIBLE_ACTOR_NAME
'VISUALIZE_DESTRUCTIBLE_ACTOR_NAME' : Shows the name of each destructible.
F32 | THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_NAME
'THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_NAME' : If VISUALIZE_DESTRUCTIBLE_ACTOR_NAME is true, the maximum object-to-eye distance to draw the actor names.
Bool | VISUALIZE_DESTRUCTIBLE_FRAGMENT_POSE
'VISUALIZE_DESTRUCTIBLE_FRAGMENT_POSE' : Shows the coordinate frame representing the local origin for each chunk island.
F32 | THRESHOLD_DISTANCE_DESTRUCTIBLE_FRAGMENT_POSE
'THRESHOLD_DISTANCE_DESTRUCTIBLE_FRAGMENT_POSE' : If VISUALIZE_DESTRUCTIBLE_FRAGMENT_POSE is true, the maximum object-to-eye distance to draw the fragment poses

Detailed Description

Describes the NxParameterized::Interface for 'DestructibleDebugRenderParams' :

DestructibleDebugRenderParams contains 9 fully qualified names
---------------------------------------------
  1 : Bool  VISUALIZE_DESTRUCTIBLE_ACTOR
  2 : F32   VISUALIZE_DESTRUCTIBLE_BOUNDS
  3 : F32   VISUALIZE_DESTRUCTIBLE_SUPPORT
  4 : Bool  VISUALIZE_DESTRUCTIBLE_ACTOR_POSE
  5 : F32   THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_POSE
  6 : Bool  VISUALIZE_DESTRUCTIBLE_ACTOR_NAME
  7 : F32   THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_NAME
  8 : Bool  VISUALIZE_DESTRUCTIBLE_FRAGMENT_POSE
  9 : F32   THRESHOLD_DISTANCE_DESTRUCTIBLE_FRAGMENT_POSE

Member Data Documentation

F32 DestructibleDebugRenderParams::THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_NAME

'THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_NAME' : If VISUALIZE_DESTRUCTIBLE_ACTOR_NAME is true, the maximum object-to-eye distance to draw the actor names.

F32 DestructibleDebugRenderParams::THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_POSE

'THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_POSE' : If VISUALIZE_DESTRUCTIBLE_ACTOR_POSE is true, the maximum object-to-eye distance to draw the chunk poses.

F32 DestructibleDebugRenderParams::THRESHOLD_DISTANCE_DESTRUCTIBLE_FRAGMENT_POSE

'THRESHOLD_DISTANCE_DESTRUCTIBLE_FRAGMENT_POSE' : If VISUALIZE_DESTRUCTIBLE_FRAGMENT_POSE is true, the maximum object-to-eye distance to draw the fragment poses

Bool DestructibleDebugRenderParams::VISUALIZE_DESTRUCTIBLE_ACTOR

'VISUALIZE_DESTRUCTIBLE_ACTOR' : Module switch - whether or not to visualize destruction.

Bool DestructibleDebugRenderParams::VISUALIZE_DESTRUCTIBLE_ACTOR_NAME

'VISUALIZE_DESTRUCTIBLE_ACTOR_NAME' : Shows the name of each destructible.

Bool DestructibleDebugRenderParams::VISUALIZE_DESTRUCTIBLE_ACTOR_POSE

'VISUALIZE_DESTRUCTIBLE_ACTOR_POSE' : Shows the coordinate frame representing the local origin for unfractured destructibles.

F32 DestructibleDebugRenderParams::VISUALIZE_DESTRUCTIBLE_BOUNDS

'VISUALIZE_DESTRUCTIBLE_BOUNDS' : Shows the axis-aligned bounding box which contains all chunks for each destructible actor.

Bool DestructibleDebugRenderParams::VISUALIZE_DESTRUCTIBLE_FRAGMENT_POSE

'VISUALIZE_DESTRUCTIBLE_FRAGMENT_POSE' : Shows the coordinate frame representing the local origin for each chunk island.

F32 DestructibleDebugRenderParams::VISUALIZE_DESTRUCTIBLE_SUPPORT

'VISUALIZE_DESTRUCTIBLE_SUPPORT' : Shows the support graph as lines and support chunks' bounding boxes.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
DestructibleDebugRenderParams Member List
This is the complete list of members for DestructibleDebugRenderParams, including all inherited members.
THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_NAME | DestructibleDebugRenderParams
THRESHOLD_DISTANCE_DESTRUCTIBLE_ACTOR_POSE | DestructibleDebugRenderParams
THRESHOLD_DISTANCE_DESTRUCTIBLE_FRAGMENT_POSE | DestructibleDebugRenderParams
VISUALIZE_DESTRUCTIBLE_ACTOR | DestructibleDebugRenderParams
VISUALIZE_DESTRUCTIBLE_ACTOR_NAME | DestructibleDebugRenderParams
VISUALIZE_DESTRUCTIBLE_ACTOR_POSE | DestructibleDebugRenderParams
VISUALIZE_DESTRUCTIBLE_BOUNDS | DestructibleDebugRenderParams
VISUALIZE_DESTRUCTIBLE_FRAGMENT_POSE | DestructibleDebugRenderParams
VISUALIZE_DESTRUCTIBLE_SUPPORT | DestructibleDebugRenderParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: DestructibleModuleParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
DestructibleModuleParameters Struct Reference

Describes the NxParameterized::Interface for 'DestructibleModuleParameters' : This class is used for initializing the NxModuleDestructible. More...

#include <params.h>

List of all members.

Public Attributes

U32 | maxDynamicChunkIslandCount
'maxDynamicChunkIslandCount' : The maximum number of dynamic NxActors that will be allowed to be active per NxApexScene. A value of 0 (the default) is interpreted as no limit.
Bool | sortFIFOByBenefit
'sortFIFOByBenefit' : Instead of keeping the maxCount youngest, use maxCount largest benefit if this is true.
F32 | validBoundsPadding
'validBoundsPadding' : The padding applied to the combined scene valid bounds and NxDestructible actor bounds. The final combined and passed bounds is used to cull NxActors
F32 | maxChunkSeparationLOD
'maxChunkSeparationLOD' : Every destructible asset defines a min and max lifetime, and maximum separation distance for its chunks.
U32 | maxActorCreatesPerFrame
'maxActorCreatesPerFrame' : Lets the user throttle the number of SDK actor creates per frame (per scene) due to destruction, as this can be quite costly. The default is 0xffffffff (unlimited).
U32 | maxChunkDepthOffset
'maxChunkDepthOffset' : Effectively eliminates the higher level (smaller) chunks from NxDestructibleAssets (see NxDestructibleAsset).
F32 | massScale
'massScale' : Used with scaledMassExponent for scaling dynamic chunk masses.
F32 | scaledMassExponent
'scaledMassExponent' : Used with massScale for scaling dynamic chunk masses.

Detailed Description

Describes the NxParameterized::Interface for 'DestructibleModuleParameters' : This class is used for initializing the NxModuleDestructible.

DestructibleModuleParameters contains 8 fully qualified names
---------------------------------------------
  1 : U32   maxDynamicChunkIslandCount
  2 : Bool  sortFIFOByBenefit
  3 : F32   validBoundsPadding
  4 : F32   maxChunkSeparationLOD
  5 : U32   maxActorCreatesPerFrame
  6 : U32   maxChunkDepthOffset
  7 : F32   massScale
  8 : F32   scaledMassExponent

Member Data Documentation

F32 DestructibleModuleParameters::massScale

'massScale' : Used with scaledMassExponent for scaling dynamic chunk masses.

Used with scaledMassExponent for scaling dynamic chunk masses. The 'real' mass m of a chunk is calculated by the destructible actor's density multiplied by the total volume of the chunk's (scaled) collision shapes. The mass used in the simulation is massScale*pow(m/massScale,scaledMassExponent). Values less than 1 have the effect of reducing the ratio of different masses. The closer scaledMassExponent is to zero, the more the ratio will be 'flattened.' This helps PhysX converge when there is a very large number of interacting rigid bodies (such as a pile of destructible chunks). Valid range: (0,infinity). Default = 1.0.

U32 DestructibleModuleParameters::maxActorCreatesPerFrame

'maxActorCreatesPerFrame' : Lets the user throttle the number of SDK actor creates per frame (per scene) due to destruction, as this can be quite costly. The default is 0xffffffff (unlimited).

U32 DestructibleModuleParameters::maxChunkDepthOffset

'maxChunkDepthOffset' : Effectively eliminates the higher level (smaller) chunks from NxDestructibleAssets (see NxDestructibleAsset).

If maxChunkDepthOffset = 0, all chunks can be fractured. If maxChunkDepthOffset = 1, the highest level (smallest) chunks are eliminated, etc. This prevents too many chunks from being formed. In other words, the higher maxChunkDepthOffset, the lower the LOD.

F32 DestructibleModuleParameters::maxChunkSeparationLOD

'maxChunkSeparationLOD' : Every destructible asset defines a min and max lifetime, and maximum separation distance for its chunks.

Chunk islands are destroyed after this time or separation from their origins. This parameter sets the lifetimes and max separations within their min-max ranges. The valid range is [0,1]. Default is 0.5.

U32 DestructibleModuleParameters::maxDynamicChunkIslandCount

'maxDynamicChunkIslandCount' : The maximum number of dynamic NxActors that will be allowed to be active per NxApexScene. A value of 0 (the default) is interpreted as no limit.

F32 DestructibleModuleParameters::scaledMassExponent

'scaledMassExponent' : Used with massScale for scaling dynamic chunk masses.

Used with massScale for scaling dynamic chunk masses. The 'real' mass m of a chunk is calculated by the destructible actor's density multiplied by the total volume of the chunk's (scaled) collision shapes. The mass used in the simulation is massScale*pow(m/massScale,scaledMassExponent). Values less than 1 have the effect of reducing the ratio of different masses. The closer scaledMassExponent is to zero, the more the ratio will be 'flattened.' This helps PhysX converge when there is a very large number of interacting rigid bodies (such as a pile of destructible chunks). Valid range: (0,1]. Default = 0.5.

Bool DestructibleModuleParameters::sortFIFOByBenefit

'sortFIFOByBenefit' : Instead of keeping the maxCount youngest, use maxCount largest benefit if this is true.

F32 DestructibleModuleParameters::validBoundsPadding

'validBoundsPadding' : The padding applied to the combined scene valid bounds and NxDestructible actor bounds. The final combined and passed bounds is used to cull NxActors

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
DestructibleModuleParameters Member List
This is the complete list of members for DestructibleModuleParameters, including all inherited members.
massScale | DestructibleModuleParameters
maxActorCreatesPerFrame | DestructibleModuleParameters
maxChunkDepthOffset | DestructibleModuleParameters
maxChunkSeparationLOD | DestructibleModuleParameters
maxDynamicChunkIslandCount | DestructibleModuleParameters
scaledMassExponent | DestructibleModuleParameters
sortFIFOByBenefit | DestructibleModuleParameters
validBoundsPadding | DestructibleModuleParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: DestructiblePreviewParam Struct Reference

  • Class List
  • Class Members
Public Attributes
DestructiblePreviewParam Struct Reference

Describes the NxParameterized::Interface for 'DestructiblePreviewParam' : More...

#include <params.h>

List of all members.

Public Attributes

Mat44 | globalPose
'globalPose' : The pose for the destructible preview
U32 | chunkDepth
'chunkDepth' : Which chunk depth to render.
F32 | explodeAmount
'explodeAmount' : How far apart to 'explode' the chunks rendered.
Bool | renderUnexplodedChunksStatically
'renderUnexplodedChunksStatically' : Whether or not to render unexploded chunks statically (without skinning)
String | overrideSkinnedMaterialNames[]
'overrideSkinnedMaterialNames[]' : Per-actor material names, to override those in the asset, for skinned rendering
String | overrideStaticMaterialNames[]
'overrideStaticMaterialNames[]' : Per-actor material names, to override those in the asset, for static rendering
U64 | userData
'userData' : Optional user data pointer associated with the destructible preview

Detailed Description

Describes the NxParameterized::Interface for 'DestructiblePreviewParam' :

DestructiblePreviewParam contains 9 fully qualified names
---------------------------------------------
  1 : Mat44          globalPose
  2 : U32            chunkDepth
  3 : F32            explodeAmount
  4 : Bool           renderUnexplodedChunksStatically
  5 : ArraySizeName  overrideSkinnedMaterialNames
  6 : String         overrideSkinnedMaterialNames[]
  7 : ArraySizeName  overrideStaticMaterialNames
  8 : String         overrideStaticMaterialNames[]
  9 : U64            userData

Member Data Documentation

U32 DestructiblePreviewParam::chunkDepth

'chunkDepth' : Which chunk depth to render.

Which chunk depth to render.

F32 DestructiblePreviewParam::explodeAmount

'explodeAmount' : How far apart to 'explode' the chunks rendered.

How far apart to 'explode' the chunks rendered. The value is relative to the chunk's initial offset from the origin.

Mat44 DestructiblePreviewParam::globalPose

'globalPose' : The pose for the destructible preview

The pose for the destructible preview, including scaling.

String DestructiblePreviewParam::overrideSkinnedMaterialNames[]

'overrideSkinnedMaterialNames[]' : Per-actor material names, to override those in the asset, for skinned rendering

Per-actor material names, to override those in the asset, for skinned rendering.

String DestructiblePreviewParam::overrideStaticMaterialNames[]

'overrideStaticMaterialNames[]' : Per-actor material names, to override those in the asset, for static rendering

Per-actor material names, to override those in the asset, for static rendering.

Bool DestructiblePreviewParam::renderUnexplodedChunksStatically

'renderUnexplodedChunksStatically' : Whether or not to render unexploded chunks statically (without skinning)

If true, unexploded chunks (see explodeAmount) will be renderered statically (without skinning). Default value = false.

U64 DestructiblePreviewParam::userData

'userData' : Optional user data pointer associated with the destructible preview

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
DestructiblePreviewParam Member List
This is the complete list of members for DestructiblePreviewParam, including all inherited members.
chunkDepth | DestructiblePreviewParam
explodeAmount | DestructiblePreviewParam
globalPose | DestructiblePreviewParam
overrideSkinnedMaterialNames[] | DestructiblePreviewParam
overrideStaticMaterialNames[] | DestructiblePreviewParam
renderUnexplodedChunksStatically | DestructiblePreviewParam
userData | DestructiblePreviewParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EffectPackageActorParams Struct Reference

  • Class List
  • Class Members
Public Attributes
EffectPackageActorParams Struct Reference

Describes the NxParameterized::Interface for 'EffectPackageActorParams' : The individual effect package actor properties. More...

#include <params.h>

List of all members.

Public Attributes

Transform | InitialPose
'InitialPose' : Helpful tooltip information goes here
F32 | objectScale
'objectScale' : A uniform overall scale factor for this effect actor
Bool | Enabled
'Enabled' : Helpful tooltip information goes here

Detailed Description

Describes the NxParameterized::Interface for 'EffectPackageActorParams' : The individual effect package actor properties.

EffectPackageActorParams contains 3 fully qualified names
---------------------------------------------
  1 : Transform  InitialPose
  2 : F32        objectScale
  3 : Bool       Enabled

Member Data Documentation

Bool EffectPackageActorParams::Enabled

'Enabled' : Helpful tooltip information goes here

Transform EffectPackageActorParams::InitialPose

'InitialPose' : Helpful tooltip information goes here

F32 EffectPackageActorParams::objectScale

'objectScale' : A uniform overall scale factor for this effect actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EffectPackageActorParams Member List
This is the complete list of members for EffectPackageActorParams, including all inherited members.
Enabled | EffectPackageActorParams
InitialPose | EffectPackageActorParams
objectScale | EffectPackageActorParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EffectPackageAssetParams Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
EffectPackageAssetParams Struct Reference

Describes the NxParameterized::Interface for 'EffectPackageAssetParams' : The effect package asset. More...

#include <params.h>

List of all members.

Classes

union | Effects

Public Attributes

Bool | LODSettings.UniqueRenderVolume
'LODSettings.UniqueRenderVolume' : Set to true if this effect should have a unique render volume; to get a separate draw call from all other instances of this effect
F32 | LODSettings.FadeDistanceBegin
'LODSettings.FadeDistanceBegin' : Distance to begin fading out the effect
F32 | LODSettings.FadeDistanceEnd
'LODSettings.FadeDistanceEnd' : Distance to finish fading out the effect
Bool | LODSettings.RandomizeEmitterRate
'LODSettings.RandomizeEmitterRate' : If true the emitter rate is randomized from the min to max values
F32 | LODSettings.FadeOutRate
'LODSettings.FadeOutRate' : Time over which to fade out effect completely
Bool | LODSettings.CullByDistance
'LODSettings.CullByDistance' : Whether or not to cull effects based on their distance from the camera; requires a valid view matrix
Bool | LODSettings.CullOffScreen
'LODSettings.CullOffScreen' : Whether or not to cull this effect if it is off screen
F32 | LODSettings.OffScreenCullTime
'LODSettings.OffScreenCullTime' : Time the effect should be offscreen before it is disabled
F32 | LODSettings.NonVisibleDeleteTime
'LODSettings.NonVisibleDeleteTime' : The time an effect is non-visible before we delete it, rathern than just disabling it's state
F32 | LODSettings.ScreenCullSize
'LODSettings.ScreenCullSize' : Bounding volme to cull the effect when near the edge of the screen
F32 | LODSettings.ScreenCullDistance
'LODSettings.ScreenCullDistance' : Radius to camera that we bypass screen culling entirely because the effect is too close to the screen; default is 3 meters
Bool | LODSettings.FadeEmitterRate
'LODSettings.FadeEmitterRate' : Control the emitter rate with Fade Distance LOD setting
Bool | LODSettings.FadeAttractorFieldStrength
'LODSettings.FadeAttractorFieldStrength' : Helpful tooltip information goes here
Bool | LODSettings.FadeJetFieldStrength
'LODSettings.FadeJetFieldStrength' : Helpful tooltip information goes here
Bool | LODSettings.FadeTurbulenceVelocity
'LODSettings.FadeTurbulenceVelocity' : Helpful tooltip information goes here
Bool | LODSettings.FadeTurbulenceNoise
'LODSettings.FadeTurbulenceNoise' : Helpful tooltip information goes here
Bool | LODSettings.FadeTurbulenceExternalVelocity
'LODSettings.FadeTurbulenceExternalVelocity' : Helpful tooltip information goes here
Bool | LODSettings.FadeTurbulenceVelocityWeight
'LODSettings.FadeTurbulenceVelocityWeight' : Helpful tooltip information goes here
Bool | LODSettings.FadeHeatSourceTemperature
'LODSettings.FadeHeatSourceTemperature' : Helpful tooltip information goes here
Bool | LODSettings.FadeForceFieldStrength
'LODSettings.FadeForceFieldStrength' : Helpful tooltip information goes here
Bool | LODSettings.FadeForceFieldScale
'LODSettings.FadeForceFieldScale' : Helpful tooltip information goes here
PlaybackMode Path.PlaybackMode
'Path.PlaybackMode' : The mode to play back the path
F32 | Path.PathDuration
'Path.PathDuration' : The duration of the path if one is not otherwise provided
U32 | Path.LoopIndex
'Path.LoopIndex' : The array index to loop back to
Transform | Path.ControlPoints[]
'Path.ControlPoints[]' : The array of control points to fit the curve to
F32 | Path.Scale[].x
'Path.Scale[].x' : The x-axis value for this vector
F32 | Path.Scale[].y
'Path.Scale[].y' : The y-axis value for this vector
F32 | Path.Speed[].x
'Path.Speed[].x' : The x-axis value for this vector
F32 | Path.Speed[].y
'Path.Speed[].y' : The y-axis value for this vector
Effects Effects[]

Detailed Description

Describes the NxParameterized::Interface for 'EffectPackageAssetParams' : The effect package asset.

EffectPackageAssetParams contains 402 fully qualified names
---------------------------------------------
  1 : Bool           LODSettings.UniqueRenderVolume
  2 : F32            LODSettings.FadeDistanceBegin
  3 : F32            LODSettings.FadeDistanceEnd
  4 : Bool           LODSettings.RandomizeEmitterRate
  5 : F32            LODSettings.FadeOutRate
  6 : Bool           LODSettings.CullByDistance
  7 : Bool           LODSettings.CullOffScreen
  8 : F32            LODSettings.OffScreenCullTime
  9 : F32            LODSettings.NonVisibleDeleteTime
 10 : F32            LODSettings.ScreenCullSize
 11 : F32            LODSettings.ScreenCullDistance
 12 : Bool           LODSettings.FadeEmitterRate
 13 : Bool           LODSettings.FadeAttractorFieldStrength
 14 : Bool           LODSettings.FadeJetFieldStrength
 15 : Bool           LODSettings.FadeTurbulenceVelocity
 16 : Bool           LODSettings.FadeTurbulenceNoise
 17 : Bool           LODSettings.FadeTurbulenceExternalVelocity
 18 : Bool           LODSettings.FadeTurbulenceVelocityWeight
 19 : Bool           LODSettings.FadeHeatSourceTemperature
 20 : Bool           LODSettings.FadeForceFieldStrength
 21 : Bool           LODSettings.FadeForceFieldScale
 22 : PlaybackMode   Path.PlaybackMode
 23 : F32            Path.PathDuration
 24 : U32            Path.LoopIndex
 25 : ArraySizeName  ControlPoints
 26 : Transform      Path.ControlPoints[]
 27 : ArraySizeName  Scale
 28 : F32            Path.Scale[].x
 29 : F32            Path.Scale[].y
 30 : ArraySizeName  Speed
 31 : F32            Path.Speed[].x
 32 : F32            Path.Speed[].y
 33 : ArraySizeName  Effects
 34 : String         Effects[].EffectProperties.UserString                             RefVariant[EmitterEffect]
 35 : Bool           Effects[].EffectProperties.Enable                                 RefVariant[EmitterEffect]
 36 : F32            Effects[].EffectProperties.Position.TranslateX                    RefVariant[EmitterEffect]
 37 : F32            Effects[].EffectProperties.Position.TranslateY                    RefVariant[EmitterEffect]
 38 : F32            Effects[].EffectProperties.Position.TranslateZ                    RefVariant[EmitterEffect]
 39 : F32            Effects[].EffectProperties.Orientation.RotateX                    RefVariant[EmitterEffect]
 40 : F32            Effects[].EffectProperties.Orientation.RotateY                    RefVariant[EmitterEffect]
 41 : F32            Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[EmitterEffect]
 42 : F32            Effects[].EffectProperties.InitialDelayTime                       RefVariant[EmitterEffect]
 43 : F32            Effects[].EffectProperties.Duration                               RefVariant[EmitterEffect]
 44 : U32            Effects[].EffectProperties.RepeatCount                            RefVariant[EmitterEffect]
 45 : F32            Effects[].EffectProperties.RepeatDelay                            RefVariant[EmitterEffect]
 46 : F32            Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[EmitterEffect]
 47 : PlaybackMode   Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[EmitterEffect]
 48 : F32            Effects[].EffectProperties.Path.PathDuration                      RefVariant[EmitterEffect]
 49 : U32            Effects[].EffectProperties.Path.LoopIndex                         RefVariant[EmitterEffect]
 50 : ArraySizeName  Effects[].ControlPoints                                           RefVariant[EmitterEffect]
 51 : Transform      Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[EmitterEffect]
 52 : ArraySizeName  Effects[].Scale                                                   RefVariant[EmitterEffect]
 53 : F32            Effects[].EffectProperties.Path.Scale[].x                         RefVariant[EmitterEffect]
 54 : F32            Effects[].EffectProperties.Path.Scale[].y                         RefVariant[EmitterEffect]
 55 : ArraySizeName  Effects[].Speed                                                   RefVariant[EmitterEffect]
 56 : F32            Effects[].EffectProperties.Path.Speed[].x                         RefVariant[EmitterEffect]
 57 : F32            Effects[].EffectProperties.Path.Speed[].y                         RefVariant[EmitterEffect]
 58 : Bool           Effects[].EmitterVelocityChanges.AdjustLifetime.AdjustEnabled     RefVariant[EmitterEffect]
 59 : F32            Effects[].EmitterVelocityChanges.AdjustLifetime.VelocityLow       RefVariant[EmitterEffect]
 60 : F32            Effects[].EmitterVelocityChanges.AdjustLifetime.VelocityHigh      RefVariant[EmitterEffect]
 61 : F32            Effects[].EmitterVelocityChanges.AdjustLifetime.LowValue          RefVariant[EmitterEffect]
 62 : F32            Effects[].EmitterVelocityChanges.AdjustLifetime.HighValue         RefVariant[EmitterEffect]
 63 : Bool           Effects[].EmitterVelocityChanges.AdjustEmitterRate.AdjustEnabled  RefVariant[EmitterEffect]
 64 : F32            Effects[].EmitterVelocityChanges.AdjustEmitterRate.VelocityLow    RefVariant[EmitterEffect]
 65 : F32            Effects[].EmitterVelocityChanges.AdjustEmitterRate.VelocityHigh   RefVariant[EmitterEffect]
 66 : F32            Effects[].EmitterVelocityChanges.AdjustEmitterRate.LowValue       RefVariant[EmitterEffect]
 67 : F32            Effects[].EmitterVelocityChanges.AdjustEmitterRate.HighValue      RefVariant[EmitterEffect]
 68 : Ref            Effects[].Emitter                                                 RefVariant[EmitterEffect]
 69 : String         Effects[].EffectProperties.UserString                             RefVariant[HeatSourceEffect]
 70 : Bool           Effects[].EffectProperties.Enable                                 RefVariant[HeatSourceEffect]
 71 : F32            Effects[].EffectProperties.Position.TranslateX                    RefVariant[HeatSourceEffect]
 72 : F32            Effects[].EffectProperties.Position.TranslateY                    RefVariant[HeatSourceEffect]
 73 : F32            Effects[].EffectProperties.Position.TranslateZ                    RefVariant[HeatSourceEffect]
 74 : F32            Effects[].EffectProperties.Orientation.RotateX                    RefVariant[HeatSourceEffect]
 75 : F32            Effects[].EffectProperties.Orientation.RotateY                    RefVariant[HeatSourceEffect]
 76 : F32            Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[HeatSourceEffect]
 77 : F32            Effects[].EffectProperties.InitialDelayTime                       RefVariant[HeatSourceEffect]
 78 : F32            Effects[].EffectProperties.Duration                               RefVariant[HeatSourceEffect]
 79 : U32            Effects[].EffectProperties.RepeatCount                            RefVariant[HeatSourceEffect]
 80 : F32            Effects[].EffectProperties.RepeatDelay                            RefVariant[HeatSourceEffect]
 81 : F32            Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[HeatSourceEffect]
 82 : PlaybackMode   Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[HeatSourceEffect]
 83 : F32            Effects[].EffectProperties.Path.PathDuration                      RefVariant[HeatSourceEffect]
 84 : U32            Effects[].EffectProperties.Path.LoopIndex                         RefVariant[HeatSourceEffect]
 85 : ArraySizeName  Effects[].ControlPoints                                           RefVariant[HeatSourceEffect]
 86 : Transform      Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[HeatSourceEffect]
 87 : ArraySizeName  Effects[].Scale                                                   RefVariant[HeatSourceEffect]
 88 : F32            Effects[].EffectProperties.Path.Scale[].x                         RefVariant[HeatSourceEffect]
 89 : F32            Effects[].EffectProperties.Path.Scale[].y                         RefVariant[HeatSourceEffect]
 90 : ArraySizeName  Effects[].Speed                                                   RefVariant[HeatSourceEffect]
 91 : F32            Effects[].EffectProperties.Path.Speed[].x                         RefVariant[HeatSourceEffect]
 92 : F32            Effects[].EffectProperties.Path.Speed[].y                         RefVariant[HeatSourceEffect]
 93 : Ref            Effects[].HeatSource                                              RefVariant[HeatSourceEffect]
 94 : String         Effects[].EffectProperties.UserString                             RefVariant[JetFieldSamplerEffect]
 95 : Bool           Effects[].EffectProperties.Enable                                 RefVariant[JetFieldSamplerEffect]
 96 : F32            Effects[].EffectProperties.Position.TranslateX                    RefVariant[JetFieldSamplerEffect]
 97 : F32            Effects[].EffectProperties.Position.TranslateY                    RefVariant[JetFieldSamplerEffect]
 98 : F32            Effects[].EffectProperties.Position.TranslateZ                    RefVariant[JetFieldSamplerEffect]
 99 : F32            Effects[].EffectProperties.Orientation.RotateX                    RefVariant[JetFieldSamplerEffect]
100 : F32            Effects[].EffectProperties.Orientation.RotateY                    RefVariant[JetFieldSamplerEffect]
101 : F32            Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[JetFieldSamplerEffect]
102 : F32            Effects[].EffectProperties.InitialDelayTime                       RefVariant[JetFieldSamplerEffect]
103 : F32            Effects[].EffectProperties.Duration                               RefVariant[JetFieldSamplerEffect]
104 : U32            Effects[].EffectProperties.RepeatCount                            RefVariant[JetFieldSamplerEffect]
105 : F32            Effects[].EffectProperties.RepeatDelay                            RefVariant[JetFieldSamplerEffect]
106 : F32            Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[JetFieldSamplerEffect]
107 : PlaybackMode   Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[JetFieldSamplerEffect]
108 : F32            Effects[].EffectProperties.Path.PathDuration                      RefVariant[JetFieldSamplerEffect]
109 : U32            Effects[].EffectProperties.Path.LoopIndex                         RefVariant[JetFieldSamplerEffect]
110 : ArraySizeName  Effects[].ControlPoints                                           RefVariant[JetFieldSamplerEffect]
111 : Transform      Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[JetFieldSamplerEffect]
112 : ArraySizeName  Effects[].Scale                                                   RefVariant[JetFieldSamplerEffect]
113 : F32            Effects[].EffectProperties.Path.Scale[].x                         RefVariant[JetFieldSamplerEffect]
114 : F32            Effects[].EffectProperties.Path.Scale[].y                         RefVariant[JetFieldSamplerEffect]
115 : ArraySizeName  Effects[].Speed                                                   RefVariant[JetFieldSamplerEffect]
116 : F32            Effects[].EffectProperties.Path.Speed[].x                         RefVariant[JetFieldSamplerEffect]
117 : F32            Effects[].EffectProperties.Path.Speed[].y                         RefVariant[JetFieldSamplerEffect]
118 : Ref            Effects[].JetFieldSampler                                         RefVariant[JetFieldSamplerEffect]
119 : String         Effects[].EffectProperties.UserString                             RefVariant[AttractorFieldSamplerEffect]
120 : Bool           Effects[].EffectProperties.Enable                                 RefVariant[AttractorFieldSamplerEffect]
121 : F32            Effects[].EffectProperties.Position.TranslateX                    RefVariant[AttractorFieldSamplerEffect]
122 : F32            Effects[].EffectProperties.Position.TranslateY                    RefVariant[AttractorFieldSamplerEffect]
123 : F32            Effects[].EffectProperties.Position.TranslateZ                    RefVariant[AttractorFieldSamplerEffect]
124 : F32            Effects[].EffectProperties.Orientation.RotateX                    RefVariant[AttractorFieldSamplerEffect]
125 : F32            Effects[].EffectProperties.Orientation.RotateY                    RefVariant[AttractorFieldSamplerEffect]
126 : F32            Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[AttractorFieldSamplerEffect]
127 : F32            Effects[].EffectProperties.InitialDelayTime                       RefVariant[AttractorFieldSamplerEffect]
128 : F32            Effects[].EffectProperties.Duration                               RefVariant[AttractorFieldSamplerEffect]
129 : U32            Effects[].EffectProperties.RepeatCount                            RefVariant[AttractorFieldSamplerEffect]
130 : F32            Effects[].EffectProperties.RepeatDelay                            RefVariant[AttractorFieldSamplerEffect]
131 : F32            Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[AttractorFieldSamplerEffect]
132 : PlaybackMode   Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[AttractorFieldSamplerEffect]
133 : F32            Effects[].EffectProperties.Path.PathDuration                      RefVariant[AttractorFieldSamplerEffect]
134 : U32            Effects[].EffectProperties.Path.LoopIndex                         RefVariant[AttractorFieldSamplerEffect]
135 : ArraySizeName  Effects[].ControlPoints                                           RefVariant[AttractorFieldSamplerEffect]
136 : Transform      Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[AttractorFieldSamplerEffect]
137 : ArraySizeName  Effects[].Scale                                                   RefVariant[AttractorFieldSamplerEffect]
138 : F32            Effects[].EffectProperties.Path.Scale[].x                         RefVariant[AttractorFieldSamplerEffect]
139 : F32            Effects[].EffectProperties.Path.Scale[].y                         RefVariant[AttractorFieldSamplerEffect]
140 : ArraySizeName  Effects[].Speed                                                   RefVariant[AttractorFieldSamplerEffect]
141 : F32            Effects[].EffectProperties.Path.Speed[].x                         RefVariant[AttractorFieldSamplerEffect]
142 : F32            Effects[].EffectProperties.Path.Speed[].y                         RefVariant[AttractorFieldSamplerEffect]
143 : Ref            Effects[].AttractorFieldSampler                                   RefVariant[AttractorFieldSamplerEffect]
144 : String         Effects[].EffectProperties.UserString                             RefVariant[TurbulenceFieldSamplerEffect]
145 : Bool           Effects[].EffectProperties.Enable                                 RefVariant[TurbulenceFieldSamplerEffect]
146 : F32            Effects[].EffectProperties.Position.TranslateX                    RefVariant[TurbulenceFieldSamplerEffect]
147 : F32            Effects[].EffectProperties.Position.TranslateY                    RefVariant[TurbulenceFieldSamplerEffect]
148 : F32            Effects[].EffectProperties.Position.TranslateZ                    RefVariant[TurbulenceFieldSamplerEffect]
149 : F32            Effects[].EffectProperties.Orientation.RotateX                    RefVariant[TurbulenceFieldSamplerEffect]
150 : F32            Effects[].EffectProperties.Orientation.RotateY                    RefVariant[TurbulenceFieldSamplerEffect]
151 : F32            Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[TurbulenceFieldSamplerEffect]
152 : F32            Effects[].EffectProperties.InitialDelayTime                       RefVariant[TurbulenceFieldSamplerEffect]
153 : F32            Effects[].EffectProperties.Duration                               RefVariant[TurbulenceFieldSamplerEffect]
154 : U32            Effects[].EffectProperties.RepeatCount                            RefVariant[TurbulenceFieldSamplerEffect]
155 : F32            Effects[].EffectProperties.RepeatDelay                            RefVariant[TurbulenceFieldSamplerEffect]
156 : F32            Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[TurbulenceFieldSamplerEffect]
157 : PlaybackMode   Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[TurbulenceFieldSamplerEffect]
158 : F32            Effects[].EffectProperties.Path.PathDuration                      RefVariant[TurbulenceFieldSamplerEffect]
159 : U32            Effects[].EffectProperties.Path.LoopIndex                         RefVariant[TurbulenceFieldSamplerEffect]
160 : ArraySizeName  Effects[].ControlPoints                                           RefVariant[TurbulenceFieldSamplerEffect]
161 : Transform      Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[TurbulenceFieldSamplerEffect]
162 : ArraySizeName  Effects[].Scale                                                   RefVariant[TurbulenceFieldSamplerEffect]
163 : F32            Effects[].EffectProperties.Path.Scale[].x                         RefVariant[TurbulenceFieldSamplerEffect]
164 : F32            Effects[].EffectProperties.Path.Scale[].y                         RefVariant[TurbulenceFieldSamplerEffect]
165 : ArraySizeName  Effects[].Speed                                                   RefVariant[TurbulenceFieldSamplerEffect]
166 : F32            Effects[].EffectProperties.Path.Speed[].x                         RefVariant[TurbulenceFieldSamplerEffect]
167 : F32            Effects[].EffectProperties.Path.Speed[].y                         RefVariant[TurbulenceFieldSamplerEffect]
168 : Ref            Effects[].TurbulenceFieldSampler                                  RefVariant[TurbulenceFieldSamplerEffect]
169 : String         Effects[].EffectProperties.UserString                             RefVariant[ForceFieldEffect]
170 : Bool           Effects[].EffectProperties.Enable                                 RefVariant[ForceFieldEffect]
171 : F32            Effects[].EffectProperties.Position.TranslateX                    RefVariant[ForceFieldEffect]
172 : F32            Effects[].EffectProperties.Position.TranslateY                    RefVariant[ForceFieldEffect]
173 : F32            Effects[].EffectProperties.Position.TranslateZ                    RefVariant[ForceFieldEffect]
174 : F32            Effects[].EffectProperties.Orientation.RotateX                    RefVariant[ForceFieldEffect]
175 : F32            Effects[].EffectProperties.Orientation.RotateY                    RefVariant[ForceFieldEffect]
176 : F32            Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[ForceFieldEffect]
177 : F32            Effects[].EffectProperties.InitialDelayTime                       RefVariant[ForceFieldEffect]
178 : F32            Effects[].EffectProperties.Duration                               RefVariant[ForceFieldEffect]
179 : U32            Effects[].EffectProperties.RepeatCount                            RefVariant[ForceFieldEffect]
180 : F32            Effects[].EffectProperties.RepeatDelay                            RefVariant[ForceFieldEffect]
181 : F32            Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[ForceFieldEffect]
182 : PlaybackMode   Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[ForceFieldEffect]
183 : F32            Effects[].EffectProperties.Path.PathDuration                      RefVariant[ForceFieldEffect]
184 : U32            Effects[].EffectProperties.Path.LoopIndex                         RefVariant[ForceFieldEffect]
185 : ArraySizeName  Effects[].ControlPoints                                           RefVariant[ForceFieldEffect]
186 : Transform      Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[ForceFieldEffect]
187 : ArraySizeName  Effects[].Scale                                                   RefVariant[ForceFieldEffect]
188 : F32            Effects[].EffectProperties.Path.Scale[].x                         RefVariant[ForceFieldEffect]
189 : F32            Effects[].EffectProperties.Path.Scale[].y                         RefVariant[ForceFieldEffect]
190 : ArraySizeName  Effects[].Speed                                                   RefVariant[ForceFieldEffect]
191 : F32            Effects[].EffectProperties.Path.Speed[].x                         RefVariant[ForceFieldEffect]
192 : F32            Effects[].EffectProperties.Path.Speed[].y                         RefVariant[ForceFieldEffect]
193 : Ref            Effects[].ForceField                                              RefVariant[ForceFieldEffect]
194 : String         Effects[].EffectProperties.UserString                             RefVariant[NoiseFieldSamplerEffect]
195 : Bool           Effects[].EffectProperties.Enable                                 RefVariant[NoiseFieldSamplerEffect]
196 : F32            Effects[].EffectProperties.Position.TranslateX                    RefVariant[NoiseFieldSamplerEffect]
197 : F32            Effects[].EffectProperties.Position.TranslateY                    RefVariant[NoiseFieldSamplerEffect]
198 : F32            Effects[].EffectProperties.Position.TranslateZ                    RefVariant[NoiseFieldSamplerEffect]
199 : F32            Effects[].EffectProperties.Orientation.RotateX                    RefVariant[NoiseFieldSamplerEffect]
200 : F32            Effects[].EffectProperties.Orientation.RotateY                    RefVariant[NoiseFieldSamplerEffect]
201 : F32            Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[NoiseFieldSamplerEffect]
202 : F32            Effects[].EffectProperties.InitialDelayTime                       RefVariant[NoiseFieldSamplerEffect]
203 : F32            Effects[].EffectProperties.Duration                               RefVariant[NoiseFieldSamplerEffect]
204 : U32            Effects[].EffectProperties.RepeatCount                            RefVariant[NoiseFieldSamplerEffect]
205 : F32            Effects[].EffectProperties.RepeatDelay                            RefVariant[NoiseFieldSamplerEffect]
206 : F32            Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[NoiseFieldSamplerEffect]
207 : PlaybackMode   Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[NoiseFieldSamplerEffect]
208 : F32            Effects[].EffectProperties.Path.PathDuration                      RefVariant[NoiseFieldSamplerEffect]
209 : U32            Effects[].EffectProperties.Path.LoopIndex                         RefVariant[NoiseFieldSamplerEffect]
210 : ArraySizeName  Effects[].ControlPoints                                           RefVariant[NoiseFieldSamplerEffect]
211 : Transform      Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[NoiseFieldSamplerEffect]
212 : ArraySizeName  Effects[].Scale                                                   RefVariant[NoiseFieldSamplerEffect]
213 : F32            Effects[].EffectProperties.Path.Scale[].x                         RefVariant[NoiseFieldSamplerEffect]
214 : F32            Effects[].EffectProperties.Path.Scale[].y                         RefVariant[NoiseFieldSamplerEffect]
215 : ArraySizeName  Effects[].Speed                                                   RefVariant[NoiseFieldSamplerEffect]
216 : F32            Effects[].EffectProperties.Path.Speed[].x                         RefVariant[NoiseFieldSamplerEffect]
217 : F32            Effects[].EffectProperties.Path.Speed[].y                         RefVariant[NoiseFieldSamplerEffect]
218 : Ref            Effects[].NoiseFieldSampler                                       RefVariant[NoiseFieldSamplerEffect]
219 : String         Effects[].EffectProperties.UserString                             RefVariant[VortexFieldSamplerEffect]
220 : Bool           Effects[].EffectProperties.Enable                                 RefVariant[VortexFieldSamplerEffect]
221 : F32            Effects[].EffectProperties.Position.TranslateX                    RefVariant[VortexFieldSamplerEffect]
222 : F32            Effects[].EffectProperties.Position.TranslateY                    RefVariant[VortexFieldSamplerEffect]
223 : F32            Effects[].EffectProperties.Position.TranslateZ                    RefVariant[VortexFieldSamplerEffect]
224 : F32            Effects[].EffectProperties.Orientation.RotateX                    RefVariant[VortexFieldSamplerEffect]
225 : F32            Effects[].EffectProperties.Orientation.RotateY                    RefVariant[VortexFieldSamplerEffect]
226 : F32            Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[VortexFieldSamplerEffect]
227 : F32            Effects[].EffectProperties.InitialDelayTime                       RefVariant[VortexFieldSamplerEffect]
228 : F32            Effects[].EffectProperties.Duration                               RefVariant[VortexFieldSamplerEffect]
229 : U32            Effects[].EffectProperties.RepeatCount                            RefVariant[VortexFieldSamplerEffect]
230 : F32            Effects[].EffectProperties.RepeatDelay                            RefVariant[VortexFieldSamplerEffect]
231 : F32            Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[VortexFieldSamplerEffect]
232 : PlaybackMode   Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[VortexFieldSamplerEffect]
233 : F32            Effects[].EffectProperties.Path.PathDuration                      RefVariant[VortexFieldSamplerEffect]
234 : U32            Effects[].EffectProperties.Path.LoopIndex                         RefVariant[VortexFieldSamplerEffect]
235 : ArraySizeName  Effects[].ControlPoints                                           RefVariant[VortexFieldSamplerEffect]
236 : Transform      Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[VortexFieldSamplerEffect]
237 : ArraySizeName  Effects[].Scale                                                   RefVariant[VortexFieldSamplerEffect]
238 : F32            Effects[].EffectProperties.Path.Scale[].x                         RefVariant[VortexFieldSamplerEffect]
239 : F32            Effects[].EffectProperties.Path.Scale[].y                         RefVariant[VortexFieldSamplerEffect]
240 : ArraySizeName  Effects[].Speed                                                   RefVariant[VortexFieldSamplerEffect]
241 : F32            Effects[].EffectProperties.Path.Speed[].x                         RefVariant[VortexFieldSamplerEffect]
242 : F32            Effects[].EffectProperties.Path.Speed[].y                         RefVariant[VortexFieldSamplerEffect]
243 : Ref            Effects[].VortexFieldSampler                                      RefVariant[VortexFieldSamplerEffect]
244 : String         Effects[].EffectProperties.UserString                             RefVariant[SubstanceSourceEffect]
245 : Bool           Effects[].EffectProperties.Enable                                 RefVariant[SubstanceSourceEffect]
246 : F32            Effects[].EffectProperties.Position.TranslateX                    RefVariant[SubstanceSourceEffect]
247 : F32            Effects[].EffectProperties.Position.TranslateY                    RefVariant[SubstanceSourceEffect]
248 : F32            Effects[].EffectProperties.Position.TranslateZ                    RefVariant[SubstanceSourceEffect]
249 : F32            Effects[].EffectProperties.Orientation.RotateX                    RefVariant[SubstanceSourceEffect]
250 : F32            Effects[].EffectProperties.Orientation.RotateY                    RefVariant[SubstanceSourceEffect]
251 : F32            Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[SubstanceSourceEffect]
252 : F32            Effects[].EffectProperties.InitialDelayTime                       RefVariant[SubstanceSourceEffect]
253 : F32            Effects[].EffectProperties.Duration                               RefVariant[SubstanceSourceEffect]
254 : U32            Effects[].EffectProperties.RepeatCount                            RefVariant[SubstanceSourceEffect]
255 : F32            Effects[].EffectProperties.RepeatDelay                            RefVariant[SubstanceSourceEffect]
256 : F32            Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[SubstanceSourceEffect]
257 : PlaybackMode   Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[SubstanceSourceEffect]
258 : F32            Effects[].EffectProperties.Path.PathDuration                      RefVariant[SubstanceSourceEffect]
259 : U32            Effects[].EffectProperties.Path.LoopIndex                         RefVariant[SubstanceSourceEffect]
260 : ArraySizeName  Effects[].ControlPoints                                           RefVariant[SubstanceSourceEffect]
261 : Transform      Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[SubstanceSourceEffect]
262 : ArraySizeName  Effects[].Scale                                                   RefVariant[SubstanceSourceEffect]
263 : F32            Effects[].EffectProperties.Path.Scale[].x                         RefVariant[SubstanceSourceEffect]
264 : F32            Effects[].EffectProperties.Path.Scale[].y                         RefVariant[SubstanceSourceEffect]
265 : ArraySizeName  Effects[].Speed                                                   RefVariant[SubstanceSourceEffect]
266 : F32            Effects[].EffectProperties.Path.Speed[].x                         RefVariant[SubstanceSourceEffect]
267 : F32            Effects[].EffectProperties.Path.Speed[].y                         RefVariant[SubstanceSourceEffect]
268 : Ref            Effects[].SubstanceSource                                         RefVariant[SubstanceSourceEffect]
269 : String         Effects[].EffectProperties.UserString                             RefVariant[WindFieldSamplerEffect]
270 : Bool           Effects[].EffectProperties.Enable                                 RefVariant[WindFieldSamplerEffect]
271 : F32            Effects[].EffectProperties.Position.TranslateX                    RefVariant[WindFieldSamplerEffect]
272 : F32            Effects[].EffectProperties.Position.TranslateY                    RefVariant[WindFieldSamplerEffect]
273 : F32            Effects[].EffectProperties.Position.TranslateZ                    RefVariant[WindFieldSamplerEffect]
274 : F32            Effects[].EffectProperties.Orientation.RotateX                    RefVariant[WindFieldSamplerEffect]
275 : F32            Effects[].EffectProperties.Orientation.RotateY                    RefVariant[WindFieldSamplerEffect]
276 : F32            Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[WindFieldSamplerEffect]
277 : F32            Effects[].EffectProperties.InitialDelayTime                       RefVariant[WindFieldSamplerEffect]
278 : F32            Effects[].EffectProperties.Duration                               RefVariant[WindFieldSamplerEffect]
279 : U32            Effects[].EffectProperties.RepeatCount                            RefVariant[WindFieldSamplerEffect]
280 : F32            Effects[].EffectProperties.RepeatDelay                            RefVariant[WindFieldSamplerEffect]
281 : F32            Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[WindFieldSamplerEffect]
282 : PlaybackMode   Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[WindFieldSamplerEffect]
283 : F32            Effects[].EffectProperties.Path.PathDuration                      RefVariant[WindFieldSamplerEffect]
284 : U32            Effects[].EffectProperties.Path.LoopIndex                         RefVariant[WindFieldSamplerEffect]
285 : ArraySizeName  Effects[].ControlPoints                                           RefVariant[WindFieldSamplerEffect]
286 : Transform      Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[WindFieldSamplerEffect]
287 : ArraySizeName  Effects[].Scale                                                   RefVariant[WindFieldSamplerEffect]
288 : F32            Effects[].EffectProperties.Path.Scale[].x                         RefVariant[WindFieldSamplerEffect]
289 : F32            Effects[].EffectProperties.Path.Scale[].y                         RefVariant[WindFieldSamplerEffect]
290 : ArraySizeName  Effects[].Speed                                                   RefVariant[WindFieldSamplerEffect]
291 : F32            Effects[].EffectProperties.Path.Speed[].x                         RefVariant[WindFieldSamplerEffect]
292 : F32            Effects[].EffectProperties.Path.Speed[].y                         RefVariant[WindFieldSamplerEffect]
293 : Ref            Effects[].WindFieldSampler                                        RefVariant[WindFieldSamplerEffect]
294 : String         Effects[].EffectProperties.UserString                             RefVariant[RigidBodyEffect]
295 : Bool           Effects[].EffectProperties.Enable                                 RefVariant[RigidBodyEffect]
296 : F32            Effects[].EffectProperties.Position.TranslateX                    RefVariant[RigidBodyEffect]
297 : F32            Effects[].EffectProperties.Position.TranslateY                    RefVariant[RigidBodyEffect]
298 : F32            Effects[].EffectProperties.Position.TranslateZ                    RefVariant[RigidBodyEffect]
299 : F32            Effects[].EffectProperties.Orientation.RotateX                    RefVariant[RigidBodyEffect]
300 : F32            Effects[].EffectProperties.Orientation.RotateY                    RefVariant[RigidBodyEffect]
301 : F32            Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[RigidBodyEffect]
302 : F32            Effects[].EffectProperties.InitialDelayTime                       RefVariant[RigidBodyEffect]
303 : F32            Effects[].EffectProperties.Duration                               RefVariant[RigidBodyEffect]
304 : U32            Effects[].EffectProperties.RepeatCount                            RefVariant[RigidBodyEffect]
305 : F32            Effects[].EffectProperties.RepeatDelay                            RefVariant[RigidBodyEffect]
306 : F32            Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[RigidBodyEffect]
307 : PlaybackMode   Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[RigidBodyEffect]
308 : F32            Effects[].EffectProperties.Path.PathDuration                      RefVariant[RigidBodyEffect]
309 : U32            Effects[].EffectProperties.Path.LoopIndex                         RefVariant[RigidBodyEffect]
310 : ArraySizeName  Effects[].ControlPoints                                           RefVariant[RigidBodyEffect]
311 : Transform      Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[RigidBodyEffect]
312 : ArraySizeName  Effects[].Scale                                                   RefVariant[RigidBodyEffect]
313 : F32            Effects[].EffectProperties.Path.Scale[].x                         RefVariant[RigidBodyEffect]
314 : F32            Effects[].EffectProperties.Path.Scale[].y                         RefVariant[RigidBodyEffect]
315 : ArraySizeName  Effects[].Speed                                                   RefVariant[RigidBodyEffect]
316 : F32            Effects[].EffectProperties.Path.Speed[].x                         RefVariant[RigidBodyEffect]
317 : F32            Effects[].EffectProperties.Path.Speed[].y                         RefVariant[RigidBodyEffect]
318 : Type           Effects[].Type                                                    RefVariant[RigidBodyEffect]
319 : String         Effects[].CollisionFilterDataName                                 RefVariant[RigidBodyEffect]
320 : Bool           Effects[].Dynamic                                                 RefVariant[RigidBodyEffect]
321 : Bool           Effects[].Gravity                                                 RefVariant[RigidBodyEffect]
322 : Vec3           Effects[].Extents                                                 RefVariant[RigidBodyEffect]
323 : F32            Effects[].Mass                                                    RefVariant[RigidBodyEffect]
324 : Vec3           Effects[].InitialLinearVelocity                                   RefVariant[RigidBodyEffect]
325 : Vec3           Effects[].InitialAngularVelocity                                  RefVariant[RigidBodyEffect]
326 : F32            Effects[].LinearDamping                                           RefVariant[RigidBodyEffect]
327 : F32            Effects[].AngularDamping                                          RefVariant[RigidBodyEffect]
328 : String         Effects[].EffectProperties.UserString                             RefVariant[VelocitySourceEffect]
329 : Bool           Effects[].EffectProperties.Enable                                 RefVariant[VelocitySourceEffect]
330 : F32            Effects[].EffectProperties.Position.TranslateX                    RefVariant[VelocitySourceEffect]
331 : F32            Effects[].EffectProperties.Position.TranslateY                    RefVariant[VelocitySourceEffect]
332 : F32            Effects[].EffectProperties.Position.TranslateZ                    RefVariant[VelocitySourceEffect]
333 : F32            Effects[].EffectProperties.Orientation.RotateX                    RefVariant[VelocitySourceEffect]
334 : F32            Effects[].EffectProperties.Orientation.RotateY                    RefVariant[VelocitySourceEffect]
335 : F32            Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[VelocitySourceEffect]
336 : F32            Effects[].EffectProperties.InitialDelayTime                       RefVariant[VelocitySourceEffect]
337 : F32            Effects[].EffectProperties.Duration                               RefVariant[VelocitySourceEffect]
338 : U32            Effects[].EffectProperties.RepeatCount                            RefVariant[VelocitySourceEffect]
339 : F32            Effects[].EffectProperties.RepeatDelay                            RefVariant[VelocitySourceEffect]
340 : F32            Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[VelocitySourceEffect]
341 : PlaybackMode   Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[VelocitySourceEffect]
342 : F32            Effects[].EffectProperties.Path.PathDuration                      RefVariant[VelocitySourceEffect]
343 : U32            Effects[].EffectProperties.Path.LoopIndex                         RefVariant[VelocitySourceEffect]
344 : ArraySizeName  Effects[].ControlPoints                                           RefVariant[VelocitySourceEffect]
345 : Transform      Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[VelocitySourceEffect]
346 : ArraySizeName  Effects[].Scale                                                   RefVariant[VelocitySourceEffect]
347 : F32            Effects[].EffectProperties.Path.Scale[].x                         RefVariant[VelocitySourceEffect]
348 : F32            Effects[].EffectProperties.Path.Scale[].y                         RefVariant[VelocitySourceEffect]
349 : ArraySizeName  Effects[].Speed                                                   RefVariant[VelocitySourceEffect]
350 : F32            Effects[].EffectProperties.Path.Speed[].x                         RefVariant[VelocitySourceEffect]
351 : F32            Effects[].EffectProperties.Path.Speed[].y                         RefVariant[VelocitySourceEffect]
352 : Ref            Effects[].VelocitySource                                          RefVariant[VelocitySourceEffect]

Member Data Documentation

Effects EffectPackageAssetParams::Effects[]
Bool EffectPackageAssetParams::LODSettings.CullByDistance

'LODSettings.CullByDistance' : Whether or not to cull effects based on their distance from the camera; requires a valid view matrix

Bool EffectPackageAssetParams::LODSettings.CullOffScreen

'LODSettings.CullOffScreen' : Whether or not to cull this effect if it is off screen

Bool EffectPackageAssetParams::LODSettings.FadeAttractorFieldStrength

'LODSettings.FadeAttractorFieldStrength' : Helpful tooltip information goes here

F32 EffectPackageAssetParams::LODSettings.FadeDistanceBegin

'LODSettings.FadeDistanceBegin' : Distance to begin fading out the effect

F32 EffectPackageAssetParams::LODSettings.FadeDistanceEnd

'LODSettings.FadeDistanceEnd' : Distance to finish fading out the effect

Bool EffectPackageAssetParams::LODSettings.FadeEmitterRate

'LODSettings.FadeEmitterRate' : Control the emitter rate with Fade Distance LOD setting

Bool EffectPackageAssetParams::LODSettings.FadeForceFieldScale

'LODSettings.FadeForceFieldScale' : Helpful tooltip information goes here

Bool EffectPackageAssetParams::LODSettings.FadeForceFieldStrength

'LODSettings.FadeForceFieldStrength' : Helpful tooltip information goes here

Bool EffectPackageAssetParams::LODSettings.FadeHeatSourceTemperature

'LODSettings.FadeHeatSourceTemperature' : Helpful tooltip information goes here

Bool EffectPackageAssetParams::LODSettings.FadeJetFieldStrength

'LODSettings.FadeJetFieldStrength' : Helpful tooltip information goes here

F32 EffectPackageAssetParams::LODSettings.FadeOutRate

'LODSettings.FadeOutRate' : Time over which to fade out effect completely

Bool EffectPackageAssetParams::LODSettings.FadeTurbulenceExternalVelocity

'LODSettings.FadeTurbulenceExternalVelocity' : Helpful tooltip information goes here

Bool EffectPackageAssetParams::LODSettings.FadeTurbulenceNoise

'LODSettings.FadeTurbulenceNoise' : Helpful tooltip information goes here

Bool EffectPackageAssetParams::LODSettings.FadeTurbulenceVelocity

'LODSettings.FadeTurbulenceVelocity' : Helpful tooltip information goes here

Bool EffectPackageAssetParams::LODSettings.FadeTurbulenceVelocityWeight

'LODSettings.FadeTurbulenceVelocityWeight' : Helpful tooltip information goes here

F32 EffectPackageAssetParams::LODSettings.NonVisibleDeleteTime

'LODSettings.NonVisibleDeleteTime' : The time an effect is non-visible before we delete it, rathern than just disabling it's state

F32 EffectPackageAssetParams::LODSettings.OffScreenCullTime

'LODSettings.OffScreenCullTime' : Time the effect should be offscreen before it is disabled

Bool EffectPackageAssetParams::LODSettings.RandomizeEmitterRate

'LODSettings.RandomizeEmitterRate' : If true the emitter rate is randomized from the min to max values

F32 EffectPackageAssetParams::LODSettings.ScreenCullDistance

'LODSettings.ScreenCullDistance' : Radius to camera that we bypass screen culling entirely because the effect is too close to the screen; default is 3 meters

F32 EffectPackageAssetParams::LODSettings.ScreenCullSize

'LODSettings.ScreenCullSize' : Bounding volme to cull the effect when near the edge of the screen

Bool EffectPackageAssetParams::LODSettings.UniqueRenderVolume

'LODSettings.UniqueRenderVolume' : Set to true if this effect should have a unique render volume; to get a separate draw call from all other instances of this effect

Transform EffectPackageAssetParams::Path.ControlPoints[]

'Path.ControlPoints[]' : The array of control points to fit the curve to

U32 EffectPackageAssetParams::Path.LoopIndex

'Path.LoopIndex' : The array index to loop back to

F32 EffectPackageAssetParams::Path.PathDuration

'Path.PathDuration' : The duration of the path if one is not otherwise provided

PlaybackMode EffectPackageAssetParams::Path.PlaybackMode

'Path.PlaybackMode' : The mode to play back the path

F32 EffectPackageAssetParams::Path.Scale[].x

'Path.Scale[].x' : The x-axis value for this vector

F32 EffectPackageAssetParams::Path.Scale[].y

'Path.Scale[].y' : The y-axis value for this vector

F32 EffectPackageAssetParams::Path.Speed[].x

'Path.Speed[].x' : The x-axis value for this vector

F32 EffectPackageAssetParams::Path.Speed[].y

'Path.Speed[].y' : The y-axis value for this vector

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EffectPackageAssetParams Member List
This is the complete list of members for EffectPackageAssetParams, including all inherited members.
Effects[] | EffectPackageAssetParams
LODSettings.CullByDistance | EffectPackageAssetParams
LODSettings.CullOffScreen | EffectPackageAssetParams
LODSettings.FadeAttractorFieldStrength | EffectPackageAssetParams
LODSettings.FadeDistanceBegin | EffectPackageAssetParams
LODSettings.FadeDistanceEnd | EffectPackageAssetParams
LODSettings.FadeEmitterRate | EffectPackageAssetParams
LODSettings.FadeForceFieldScale | EffectPackageAssetParams
LODSettings.FadeForceFieldStrength | EffectPackageAssetParams
LODSettings.FadeHeatSourceTemperature | EffectPackageAssetParams
LODSettings.FadeJetFieldStrength | EffectPackageAssetParams
LODSettings.FadeOutRate | EffectPackageAssetParams
LODSettings.FadeTurbulenceExternalVelocity | EffectPackageAssetParams
LODSettings.FadeTurbulenceNoise | EffectPackageAssetParams
LODSettings.FadeTurbulenceVelocity | EffectPackageAssetParams
LODSettings.FadeTurbulenceVelocityWeight | EffectPackageAssetParams
LODSettings.NonVisibleDeleteTime | EffectPackageAssetParams
LODSettings.OffScreenCullTime | EffectPackageAssetParams
LODSettings.RandomizeEmitterRate | EffectPackageAssetParams
LODSettings.ScreenCullDistance | EffectPackageAssetParams
LODSettings.ScreenCullSize | EffectPackageAssetParams
LODSettings.UniqueRenderVolume | EffectPackageAssetParams
Path.ControlPoints[] | EffectPackageAssetParams
Path.LoopIndex | EffectPackageAssetParams
Path.PathDuration | EffectPackageAssetParams
Path.PlaybackMode | EffectPackageAssetParams
Path.Scale[].x | EffectPackageAssetParams
Path.Scale[].y | EffectPackageAssetParams
Path.Speed[].x | EffectPackageAssetParams
Path.Speed[].y | EffectPackageAssetParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EffectPackageData Struct Reference

  • Class List
  • Class Members
Public Attributes
EffectPackageData Struct Reference

Describes the NxParameterized::Interface for 'EffectPackageData' : Contains the Effect Package Properties. More...

#include <params.h>

List of all members.

Public Attributes

String Name
'Name' : Effect package name
EffectPackageAssetParams EffectPackage
'EffectPackage' :

Detailed Description

Describes the NxParameterized::Interface for 'EffectPackageData' : Contains the Effect Package Properties.

EffectPackageData contains 403 fully qualified names
---------------------------------------------
  1 : String         Name
  2 : Bool           EffectPackage.LODSettings.UniqueRenderVolume                                    RefVariant[EffectPackageAssetParams]
  3 : F32            EffectPackage.LODSettings.FadeDistanceBegin                                     RefVariant[EffectPackageAssetParams]
  4 : F32            EffectPackage.LODSettings.FadeDistanceEnd                                       RefVariant[EffectPackageAssetParams]
  5 : Bool           EffectPackage.LODSettings.RandomizeEmitterRate                                  RefVariant[EffectPackageAssetParams]
  6 : F32            EffectPackage.LODSettings.FadeOutRate                                           RefVariant[EffectPackageAssetParams]
  7 : Bool           EffectPackage.LODSettings.CullByDistance                                        RefVariant[EffectPackageAssetParams]
  8 : Bool           EffectPackage.LODSettings.CullOffScreen                                         RefVariant[EffectPackageAssetParams]
  9 : F32            EffectPackage.LODSettings.OffScreenCullTime                                     RefVariant[EffectPackageAssetParams]
 10 : F32            EffectPackage.LODSettings.NonVisibleDeleteTime                                  RefVariant[EffectPackageAssetParams]
 11 : F32            EffectPackage.LODSettings.ScreenCullSize                                        RefVariant[EffectPackageAssetParams]
 12 : F32            EffectPackage.LODSettings.ScreenCullDistance                                    RefVariant[EffectPackageAssetParams]
 13 : Bool           EffectPackage.LODSettings.FadeEmitterRate                                       RefVariant[EffectPackageAssetParams]
 14 : Bool           EffectPackage.LODSettings.FadeAttractorFieldStrength                            RefVariant[EffectPackageAssetParams]
 15 : Bool           EffectPackage.LODSettings.FadeJetFieldStrength                                  RefVariant[EffectPackageAssetParams]
 16 : Bool           EffectPackage.LODSettings.FadeTurbulenceVelocity                                RefVariant[EffectPackageAssetParams]
 17 : Bool           EffectPackage.LODSettings.FadeTurbulenceNoise                                   RefVariant[EffectPackageAssetParams]
 18 : Bool           EffectPackage.LODSettings.FadeTurbulenceExternalVelocity                        RefVariant[EffectPackageAssetParams]
 19 : Bool           EffectPackage.LODSettings.FadeTurbulenceVelocityWeight                          RefVariant[EffectPackageAssetParams]
 20 : Bool           EffectPackage.LODSettings.FadeHeatSourceTemperature                             RefVariant[EffectPackageAssetParams]
 21 : Bool           EffectPackage.LODSettings.FadeForceFieldStrength                                RefVariant[EffectPackageAssetParams]
 22 : Bool           EffectPackage.LODSettings.FadeForceFieldScale                                   RefVariant[EffectPackageAssetParams]
 23 : PlaybackMode   EffectPackage.Path.PlaybackMode                                                 RefVariant[EffectPackageAssetParams]
 24 : F32            EffectPackage.Path.PathDuration                                                 RefVariant[EffectPackageAssetParams]
 25 : U32            EffectPackage.Path.LoopIndex                                                    RefVariant[EffectPackageAssetParams]
 26 : ArraySizeName  EffectPackage.ControlPoints                                                     RefVariant[EffectPackageAssetParams]
 27 : Transform      EffectPackage.Path.ControlPoints[]                                              RefVariant[EffectPackageAssetParams]
 28 : ArraySizeName  EffectPackage.Scale                                                             RefVariant[EffectPackageAssetParams]
 29 : F32            EffectPackage.Path.Scale[].x                                                    RefVariant[EffectPackageAssetParams]
 30 : F32            EffectPackage.Path.Scale[].y                                                    RefVariant[EffectPackageAssetParams]
 31 : ArraySizeName  EffectPackage.Speed                                                             RefVariant[EffectPackageAssetParams]
 32 : F32            EffectPackage.Path.Speed[].x                                                    RefVariant[EffectPackageAssetParams]
 33 : F32            EffectPackage.Path.Speed[].y                                                    RefVariant[EffectPackageAssetParams]
 34 : ArraySizeName  EffectPackage.Effects                                                           RefVariant[EffectPackageAssetParams]
 35 : String         EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[EmitterEffect]
 36 : Bool           EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[EmitterEffect]
 37 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[EmitterEffect]
 38 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[EmitterEffect]
 39 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[EmitterEffect]
 40 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[EmitterEffect]
 41 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[EmitterEffect]
 42 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[EmitterEffect]
 43 : F32            EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[EmitterEffect]
 44 : F32            EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[EmitterEffect]
 45 : U32            EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[EmitterEffect]
 46 : F32            EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[EmitterEffect]
 47 : F32            EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[EmitterEffect]
 48 : PlaybackMode   EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[EmitterEffect]
 49 : F32            EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[EmitterEffect]
 50 : U32            EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[EmitterEffect]
 51 : ArraySizeName  EffectPackage.Effects[].ControlPoints                                           RefVariant[EmitterEffect]
 52 : Transform      EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[EmitterEffect]
 53 : ArraySizeName  EffectPackage.Effects[].Scale                                                   RefVariant[EmitterEffect]
 54 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[EmitterEffect]
 55 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[EmitterEffect]
 56 : ArraySizeName  EffectPackage.Effects[].Speed                                                   RefVariant[EmitterEffect]
 57 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[EmitterEffect]
 58 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[EmitterEffect]
 59 : Bool           EffectPackage.Effects[].EmitterVelocityChanges.AdjustLifetime.AdjustEnabled     RefVariant[EmitterEffect]
 60 : F32            EffectPackage.Effects[].EmitterVelocityChanges.AdjustLifetime.VelocityLow       RefVariant[EmitterEffect]
 61 : F32            EffectPackage.Effects[].EmitterVelocityChanges.AdjustLifetime.VelocityHigh      RefVariant[EmitterEffect]
 62 : F32            EffectPackage.Effects[].EmitterVelocityChanges.AdjustLifetime.LowValue          RefVariant[EmitterEffect]
 63 : F32            EffectPackage.Effects[].EmitterVelocityChanges.AdjustLifetime.HighValue         RefVariant[EmitterEffect]
 64 : Bool           EffectPackage.Effects[].EmitterVelocityChanges.AdjustEmitterRate.AdjustEnabled  RefVariant[EmitterEffect]
 65 : F32            EffectPackage.Effects[].EmitterVelocityChanges.AdjustEmitterRate.VelocityLow    RefVariant[EmitterEffect]
 66 : F32            EffectPackage.Effects[].EmitterVelocityChanges.AdjustEmitterRate.VelocityHigh   RefVariant[EmitterEffect]
 67 : F32            EffectPackage.Effects[].EmitterVelocityChanges.AdjustEmitterRate.LowValue       RefVariant[EmitterEffect]
 68 : F32            EffectPackage.Effects[].EmitterVelocityChanges.AdjustEmitterRate.HighValue      RefVariant[EmitterEffect]
 69 : Ref            EffectPackage.Effects[].Emitter                                                 RefVariant[EmitterEffect]
 70 : String         EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[HeatSourceEffect]
 71 : Bool           EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[HeatSourceEffect]
 72 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[HeatSourceEffect]
 73 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[HeatSourceEffect]
 74 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[HeatSourceEffect]
 75 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[HeatSourceEffect]
 76 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[HeatSourceEffect]
 77 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[HeatSourceEffect]
 78 : F32            EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[HeatSourceEffect]
 79 : F32            EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[HeatSourceEffect]
 80 : U32            EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[HeatSourceEffect]
 81 : F32            EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[HeatSourceEffect]
 82 : F32            EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[HeatSourceEffect]
 83 : PlaybackMode   EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[HeatSourceEffect]
 84 : F32            EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[HeatSourceEffect]
 85 : U32            EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[HeatSourceEffect]
 86 : ArraySizeName  EffectPackage.Effects[].ControlPoints                                           RefVariant[HeatSourceEffect]
 87 : Transform      EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[HeatSourceEffect]
 88 : ArraySizeName  EffectPackage.Effects[].Scale                                                   RefVariant[HeatSourceEffect]
 89 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[HeatSourceEffect]
 90 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[HeatSourceEffect]
 91 : ArraySizeName  EffectPackage.Effects[].Speed                                                   RefVariant[HeatSourceEffect]
 92 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[HeatSourceEffect]
 93 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[HeatSourceEffect]
 94 : Ref            EffectPackage.Effects[].HeatSource                                              RefVariant[HeatSourceEffect]
 95 : String         EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[JetFieldSamplerEffect]
 96 : Bool           EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[JetFieldSamplerEffect]
 97 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[JetFieldSamplerEffect]
 98 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[JetFieldSamplerEffect]
 99 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[JetFieldSamplerEffect]
100 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[JetFieldSamplerEffect]
101 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[JetFieldSamplerEffect]
102 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[JetFieldSamplerEffect]
103 : F32            EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[JetFieldSamplerEffect]
104 : F32            EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[JetFieldSamplerEffect]
105 : U32            EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[JetFieldSamplerEffect]
106 : F32            EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[JetFieldSamplerEffect]
107 : F32            EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[JetFieldSamplerEffect]
108 : PlaybackMode   EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[JetFieldSamplerEffect]
109 : F32            EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[JetFieldSamplerEffect]
110 : U32            EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[JetFieldSamplerEffect]
111 : ArraySizeName  EffectPackage.Effects[].ControlPoints                                           RefVariant[JetFieldSamplerEffect]
112 : Transform      EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[JetFieldSamplerEffect]
113 : ArraySizeName  EffectPackage.Effects[].Scale                                                   RefVariant[JetFieldSamplerEffect]
114 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[JetFieldSamplerEffect]
115 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[JetFieldSamplerEffect]
116 : ArraySizeName  EffectPackage.Effects[].Speed                                                   RefVariant[JetFieldSamplerEffect]
117 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[JetFieldSamplerEffect]
118 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[JetFieldSamplerEffect]
119 : Ref            EffectPackage.Effects[].JetFieldSampler                                         RefVariant[JetFieldSamplerEffect]
120 : String         EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[AttractorFieldSamplerEffect]
121 : Bool           EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[AttractorFieldSamplerEffect]
122 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[AttractorFieldSamplerEffect]
123 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[AttractorFieldSamplerEffect]
124 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[AttractorFieldSamplerEffect]
125 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[AttractorFieldSamplerEffect]
126 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[AttractorFieldSamplerEffect]
127 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[AttractorFieldSamplerEffect]
128 : F32            EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[AttractorFieldSamplerEffect]
129 : F32            EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[AttractorFieldSamplerEffect]
130 : U32            EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[AttractorFieldSamplerEffect]
131 : F32            EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[AttractorFieldSamplerEffect]
132 : F32            EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[AttractorFieldSamplerEffect]
133 : PlaybackMode   EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[AttractorFieldSamplerEffect]
134 : F32            EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[AttractorFieldSamplerEffect]
135 : U32            EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[AttractorFieldSamplerEffect]
136 : ArraySizeName  EffectPackage.Effects[].ControlPoints                                           RefVariant[AttractorFieldSamplerEffect]
137 : Transform      EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[AttractorFieldSamplerEffect]
138 : ArraySizeName  EffectPackage.Effects[].Scale                                                   RefVariant[AttractorFieldSamplerEffect]
139 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[AttractorFieldSamplerEffect]
140 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[AttractorFieldSamplerEffect]
141 : ArraySizeName  EffectPackage.Effects[].Speed                                                   RefVariant[AttractorFieldSamplerEffect]
142 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[AttractorFieldSamplerEffect]
143 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[AttractorFieldSamplerEffect]
144 : Ref            EffectPackage.Effects[].AttractorFieldSampler                                   RefVariant[AttractorFieldSamplerEffect]
145 : String         EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[TurbulenceFieldSamplerEffect]
146 : Bool           EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[TurbulenceFieldSamplerEffect]
147 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[TurbulenceFieldSamplerEffect]
148 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[TurbulenceFieldSamplerEffect]
149 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[TurbulenceFieldSamplerEffect]
150 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[TurbulenceFieldSamplerEffect]
151 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[TurbulenceFieldSamplerEffect]
152 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[TurbulenceFieldSamplerEffect]
153 : F32            EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[TurbulenceFieldSamplerEffect]
154 : F32            EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[TurbulenceFieldSamplerEffect]
155 : U32            EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[TurbulenceFieldSamplerEffect]
156 : F32            EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[TurbulenceFieldSamplerEffect]
157 : F32            EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[TurbulenceFieldSamplerEffect]
158 : PlaybackMode   EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[TurbulenceFieldSamplerEffect]
159 : F32            EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[TurbulenceFieldSamplerEffect]
160 : U32            EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[TurbulenceFieldSamplerEffect]
161 : ArraySizeName  EffectPackage.Effects[].ControlPoints                                           RefVariant[TurbulenceFieldSamplerEffect]
162 : Transform      EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[TurbulenceFieldSamplerEffect]
163 : ArraySizeName  EffectPackage.Effects[].Scale                                                   RefVariant[TurbulenceFieldSamplerEffect]
164 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[TurbulenceFieldSamplerEffect]
165 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[TurbulenceFieldSamplerEffect]
166 : ArraySizeName  EffectPackage.Effects[].Speed                                                   RefVariant[TurbulenceFieldSamplerEffect]
167 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[TurbulenceFieldSamplerEffect]
168 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[TurbulenceFieldSamplerEffect]
169 : Ref            EffectPackage.Effects[].TurbulenceFieldSampler                                  RefVariant[TurbulenceFieldSamplerEffect]
170 : String         EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[ForceFieldEffect]
171 : Bool           EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[ForceFieldEffect]
172 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[ForceFieldEffect]
173 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[ForceFieldEffect]
174 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[ForceFieldEffect]
175 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[ForceFieldEffect]
176 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[ForceFieldEffect]
177 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[ForceFieldEffect]
178 : F32            EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[ForceFieldEffect]
179 : F32            EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[ForceFieldEffect]
180 : U32            EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[ForceFieldEffect]
181 : F32            EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[ForceFieldEffect]
182 : F32            EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[ForceFieldEffect]
183 : PlaybackMode   EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[ForceFieldEffect]
184 : F32            EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[ForceFieldEffect]
185 : U32            EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[ForceFieldEffect]
186 : ArraySizeName  EffectPackage.Effects[].ControlPoints                                           RefVariant[ForceFieldEffect]
187 : Transform      EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[ForceFieldEffect]
188 : ArraySizeName  EffectPackage.Effects[].Scale                                                   RefVariant[ForceFieldEffect]
189 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[ForceFieldEffect]
190 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[ForceFieldEffect]
191 : ArraySizeName  EffectPackage.Effects[].Speed                                                   RefVariant[ForceFieldEffect]
192 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[ForceFieldEffect]
193 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[ForceFieldEffect]
194 : Ref            EffectPackage.Effects[].ForceField                                              RefVariant[ForceFieldEffect]
195 : String         EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[NoiseFieldSamplerEffect]
196 : Bool           EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[NoiseFieldSamplerEffect]
197 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[NoiseFieldSamplerEffect]
198 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[NoiseFieldSamplerEffect]
199 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[NoiseFieldSamplerEffect]
200 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[NoiseFieldSamplerEffect]
201 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[NoiseFieldSamplerEffect]
202 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[NoiseFieldSamplerEffect]
203 : F32            EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[NoiseFieldSamplerEffect]
204 : F32            EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[NoiseFieldSamplerEffect]
205 : U32            EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[NoiseFieldSamplerEffect]
206 : F32            EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[NoiseFieldSamplerEffect]
207 : F32            EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[NoiseFieldSamplerEffect]
208 : PlaybackMode   EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[NoiseFieldSamplerEffect]
209 : F32            EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[NoiseFieldSamplerEffect]
210 : U32            EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[NoiseFieldSamplerEffect]
211 : ArraySizeName  EffectPackage.Effects[].ControlPoints                                           RefVariant[NoiseFieldSamplerEffect]
212 : Transform      EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[NoiseFieldSamplerEffect]
213 : ArraySizeName  EffectPackage.Effects[].Scale                                                   RefVariant[NoiseFieldSamplerEffect]
214 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[NoiseFieldSamplerEffect]
215 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[NoiseFieldSamplerEffect]
216 : ArraySizeName  EffectPackage.Effects[].Speed                                                   RefVariant[NoiseFieldSamplerEffect]
217 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[NoiseFieldSamplerEffect]
218 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[NoiseFieldSamplerEffect]
219 : Ref            EffectPackage.Effects[].NoiseFieldSampler                                       RefVariant[NoiseFieldSamplerEffect]
220 : String         EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[VortexFieldSamplerEffect]
221 : Bool           EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[VortexFieldSamplerEffect]
222 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[VortexFieldSamplerEffect]
223 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[VortexFieldSamplerEffect]
224 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[VortexFieldSamplerEffect]
225 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[VortexFieldSamplerEffect]
226 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[VortexFieldSamplerEffect]
227 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[VortexFieldSamplerEffect]
228 : F32            EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[VortexFieldSamplerEffect]
229 : F32            EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[VortexFieldSamplerEffect]
230 : U32            EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[VortexFieldSamplerEffect]
231 : F32            EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[VortexFieldSamplerEffect]
232 : F32            EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[VortexFieldSamplerEffect]
233 : PlaybackMode   EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[VortexFieldSamplerEffect]
234 : F32            EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[VortexFieldSamplerEffect]
235 : U32            EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[VortexFieldSamplerEffect]
236 : ArraySizeName  EffectPackage.Effects[].ControlPoints                                           RefVariant[VortexFieldSamplerEffect]
237 : Transform      EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[VortexFieldSamplerEffect]
238 : ArraySizeName  EffectPackage.Effects[].Scale                                                   RefVariant[VortexFieldSamplerEffect]
239 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[VortexFieldSamplerEffect]
240 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[VortexFieldSamplerEffect]
241 : ArraySizeName  EffectPackage.Effects[].Speed                                                   RefVariant[VortexFieldSamplerEffect]
242 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[VortexFieldSamplerEffect]
243 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[VortexFieldSamplerEffect]
244 : Ref            EffectPackage.Effects[].VortexFieldSampler                                      RefVariant[VortexFieldSamplerEffect]
245 : String         EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[SubstanceSourceEffect]
246 : Bool           EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[SubstanceSourceEffect]
247 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[SubstanceSourceEffect]
248 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[SubstanceSourceEffect]
249 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[SubstanceSourceEffect]
250 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[SubstanceSourceEffect]
251 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[SubstanceSourceEffect]
252 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[SubstanceSourceEffect]
253 : F32            EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[SubstanceSourceEffect]
254 : F32            EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[SubstanceSourceEffect]
255 : U32            EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[SubstanceSourceEffect]
256 : F32            EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[SubstanceSourceEffect]
257 : F32            EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[SubstanceSourceEffect]
258 : PlaybackMode   EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[SubstanceSourceEffect]
259 : F32            EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[SubstanceSourceEffect]
260 : U32            EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[SubstanceSourceEffect]
261 : ArraySizeName  EffectPackage.Effects[].ControlPoints                                           RefVariant[SubstanceSourceEffect]
262 : Transform      EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[SubstanceSourceEffect]
263 : ArraySizeName  EffectPackage.Effects[].Scale                                                   RefVariant[SubstanceSourceEffect]
264 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[SubstanceSourceEffect]
265 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[SubstanceSourceEffect]
266 : ArraySizeName  EffectPackage.Effects[].Speed                                                   RefVariant[SubstanceSourceEffect]
267 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[SubstanceSourceEffect]
268 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[SubstanceSourceEffect]
269 : Ref            EffectPackage.Effects[].SubstanceSource                                         RefVariant[SubstanceSourceEffect]
270 : String         EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[WindFieldSamplerEffect]
271 : Bool           EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[WindFieldSamplerEffect]
272 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[WindFieldSamplerEffect]
273 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[WindFieldSamplerEffect]
274 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[WindFieldSamplerEffect]
275 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[WindFieldSamplerEffect]
276 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[WindFieldSamplerEffect]
277 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[WindFieldSamplerEffect]
278 : F32            EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[WindFieldSamplerEffect]
279 : F32            EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[WindFieldSamplerEffect]
280 : U32            EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[WindFieldSamplerEffect]
281 : F32            EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[WindFieldSamplerEffect]
282 : F32            EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[WindFieldSamplerEffect]
283 : PlaybackMode   EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[WindFieldSamplerEffect]
284 : F32            EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[WindFieldSamplerEffect]
285 : U32            EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[WindFieldSamplerEffect]
286 : ArraySizeName  EffectPackage.Effects[].ControlPoints                                           RefVariant[WindFieldSamplerEffect]
287 : Transform      EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[WindFieldSamplerEffect]
288 : ArraySizeName  EffectPackage.Effects[].Scale                                                   RefVariant[WindFieldSamplerEffect]
289 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[WindFieldSamplerEffect]
290 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[WindFieldSamplerEffect]
291 : ArraySizeName  EffectPackage.Effects[].Speed                                                   RefVariant[WindFieldSamplerEffect]
292 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[WindFieldSamplerEffect]
293 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[WindFieldSamplerEffect]
294 : Ref            EffectPackage.Effects[].WindFieldSampler                                        RefVariant[WindFieldSamplerEffect]
295 : String         EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[RigidBodyEffect]
296 : Bool           EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[RigidBodyEffect]
297 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[RigidBodyEffect]
298 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[RigidBodyEffect]
299 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[RigidBodyEffect]
300 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[RigidBodyEffect]
301 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[RigidBodyEffect]
302 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[RigidBodyEffect]
303 : F32            EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[RigidBodyEffect]
304 : F32            EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[RigidBodyEffect]
305 : U32            EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[RigidBodyEffect]
306 : F32            EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[RigidBodyEffect]
307 : F32            EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[RigidBodyEffect]
308 : PlaybackMode   EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[RigidBodyEffect]
309 : F32            EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[RigidBodyEffect]
310 : U32            EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[RigidBodyEffect]
311 : ArraySizeName  EffectPackage.Effects[].ControlPoints                                           RefVariant[RigidBodyEffect]
312 : Transform      EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[RigidBodyEffect]
313 : ArraySizeName  EffectPackage.Effects[].Scale                                                   RefVariant[RigidBodyEffect]
314 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[RigidBodyEffect]
315 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[RigidBodyEffect]
316 : ArraySizeName  EffectPackage.Effects[].Speed                                                   RefVariant[RigidBodyEffect]
317 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[RigidBodyEffect]
318 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[RigidBodyEffect]
319 : Type           EffectPackage.Effects[].Type                                                    RefVariant[RigidBodyEffect]
320 : String         EffectPackage.Effects[].CollisionFilterDataName                                 RefVariant[RigidBodyEffect]
321 : Bool           EffectPackage.Effects[].Dynamic                                                 RefVariant[RigidBodyEffect]
322 : Bool           EffectPackage.Effects[].Gravity                                                 RefVariant[RigidBodyEffect]
323 : Vec3           EffectPackage.Effects[].Extents                                                 RefVariant[RigidBodyEffect]
324 : F32            EffectPackage.Effects[].Mass                                                    RefVariant[RigidBodyEffect]
325 : Vec3           EffectPackage.Effects[].InitialLinearVelocity                                   RefVariant[RigidBodyEffect]
326 : Vec3           EffectPackage.Effects[].InitialAngularVelocity                                  RefVariant[RigidBodyEffect]
327 : F32            EffectPackage.Effects[].LinearDamping                                           RefVariant[RigidBodyEffect]
328 : F32            EffectPackage.Effects[].AngularDamping                                          RefVariant[RigidBodyEffect]
329 : String         EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[VelocitySourceEffect]
330 : Bool           EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[VelocitySourceEffect]
331 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[VelocitySourceEffect]
332 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[VelocitySourceEffect]
333 : F32            EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[VelocitySourceEffect]
334 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[VelocitySourceEffect]
335 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[VelocitySourceEffect]
336 : F32            EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[VelocitySourceEffect]
337 : F32            EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[VelocitySourceEffect]
338 : F32            EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[VelocitySourceEffect]
339 : U32            EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[VelocitySourceEffect]
340 : F32            EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[VelocitySourceEffect]
341 : F32            EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[VelocitySourceEffect]
342 : PlaybackMode   EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[VelocitySourceEffect]
343 : F32            EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[VelocitySourceEffect]
344 : U32            EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[VelocitySourceEffect]
345 : ArraySizeName  EffectPackage.Effects[].ControlPoints                                           RefVariant[VelocitySourceEffect]
346 : Transform      EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[VelocitySourceEffect]
347 : ArraySizeName  EffectPackage.Effects[].Scale                                                   RefVariant[VelocitySourceEffect]
348 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[VelocitySourceEffect]
349 : F32            EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[VelocitySourceEffect]
350 : ArraySizeName  EffectPackage.Effects[].Speed                                                   RefVariant[VelocitySourceEffect]
351 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[VelocitySourceEffect]
352 : F32            EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[VelocitySourceEffect]
353 : Ref            EffectPackage.Effects[].VelocitySource                                          RefVariant[VelocitySourceEffect]

Member Data Documentation

EffectPackageAssetParams EffectPackageData::EffectPackage

'EffectPackage' :

String EffectPackageData::Name

'Name' : Effect package name

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EffectPackageData Member List
This is the complete list of members for EffectPackageData, including all inherited members.
EffectPackage | EffectPackageData
Name | EffectPackageData
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EffectPackageDatabaseParams Struct Reference

  • Class List
  • Class Members
Public Attributes
EffectPackageDatabaseParams Struct Reference

Describes the NxParameterized::Interface for 'EffectPackageDatabaseParams' : The collection of all effect packages. More...

#include <params.h>

List of all members.

Public Attributes

EffectPackageData EffectPackages[]
'EffectPackages[]' :

Detailed Description

Describes the NxParameterized::Interface for 'EffectPackageDatabaseParams' : The collection of all effect packages.

EffectPackageDatabaseParams contains 404 fully qualified names
---------------------------------------------
  1 : ArraySizeName  EffectPackages
  2 : String         EffectPackages[].Name                                                                            RefVariant[EffectPackageData]
  3 : Bool           EffectPackages[].EffectPackage.LODSettings.UniqueRenderVolume                                    RefVariant[EffectPackageAssetParams]
  4 : F32            EffectPackages[].EffectPackage.LODSettings.FadeDistanceBegin                                     RefVariant[EffectPackageAssetParams]
  5 : F32            EffectPackages[].EffectPackage.LODSettings.FadeDistanceEnd                                       RefVariant[EffectPackageAssetParams]
  6 : Bool           EffectPackages[].EffectPackage.LODSettings.RandomizeEmitterRate                                  RefVariant[EffectPackageAssetParams]
  7 : F32            EffectPackages[].EffectPackage.LODSettings.FadeOutRate                                           RefVariant[EffectPackageAssetParams]
  8 : Bool           EffectPackages[].EffectPackage.LODSettings.CullByDistance                                        RefVariant[EffectPackageAssetParams]
  9 : Bool           EffectPackages[].EffectPackage.LODSettings.CullOffScreen                                         RefVariant[EffectPackageAssetParams]
 10 : F32            EffectPackages[].EffectPackage.LODSettings.OffScreenCullTime                                     RefVariant[EffectPackageAssetParams]
 11 : F32            EffectPackages[].EffectPackage.LODSettings.NonVisibleDeleteTime                                  RefVariant[EffectPackageAssetParams]
 12 : F32            EffectPackages[].EffectPackage.LODSettings.ScreenCullSize                                        RefVariant[EffectPackageAssetParams]
 13 : F32            EffectPackages[].EffectPackage.LODSettings.ScreenCullDistance                                    RefVariant[EffectPackageAssetParams]
 14 : Bool           EffectPackages[].EffectPackage.LODSettings.FadeEmitterRate                                       RefVariant[EffectPackageAssetParams]
 15 : Bool           EffectPackages[].EffectPackage.LODSettings.FadeAttractorFieldStrength                            RefVariant[EffectPackageAssetParams]
 16 : Bool           EffectPackages[].EffectPackage.LODSettings.FadeJetFieldStrength                                  RefVariant[EffectPackageAssetParams]
 17 : Bool           EffectPackages[].EffectPackage.LODSettings.FadeTurbulenceVelocity                                RefVariant[EffectPackageAssetParams]
 18 : Bool           EffectPackages[].EffectPackage.LODSettings.FadeTurbulenceNoise                                   RefVariant[EffectPackageAssetParams]
 19 : Bool           EffectPackages[].EffectPackage.LODSettings.FadeTurbulenceExternalVelocity                        RefVariant[EffectPackageAssetParams]
 20 : Bool           EffectPackages[].EffectPackage.LODSettings.FadeTurbulenceVelocityWeight                          RefVariant[EffectPackageAssetParams]
 21 : Bool           EffectPackages[].EffectPackage.LODSettings.FadeHeatSourceTemperature                             RefVariant[EffectPackageAssetParams]
 22 : Bool           EffectPackages[].EffectPackage.LODSettings.FadeForceFieldStrength                                RefVariant[EffectPackageAssetParams]
 23 : Bool           EffectPackages[].EffectPackage.LODSettings.FadeForceFieldScale                                   RefVariant[EffectPackageAssetParams]
 24 : PlaybackMode   EffectPackages[].EffectPackage.Path.PlaybackMode                                                 RefVariant[EffectPackageAssetParams]
 25 : F32            EffectPackages[].EffectPackage.Path.PathDuration                                                 RefVariant[EffectPackageAssetParams]
 26 : U32            EffectPackages[].EffectPackage.Path.LoopIndex                                                    RefVariant[EffectPackageAssetParams]
 27 : ArraySizeName  EffectPackages[].EffectPackage.ControlPoints                                                     RefVariant[EffectPackageAssetParams]
 28 : Transform      EffectPackages[].EffectPackage.Path.ControlPoints[]                                              RefVariant[EffectPackageAssetParams]
 29 : ArraySizeName  EffectPackages[].EffectPackage.Scale                                                             RefVariant[EffectPackageAssetParams]
 30 : F32            EffectPackages[].EffectPackage.Path.Scale[].x                                                    RefVariant[EffectPackageAssetParams]
 31 : F32            EffectPackages[].EffectPackage.Path.Scale[].y                                                    RefVariant[EffectPackageAssetParams]
 32 : ArraySizeName  EffectPackages[].EffectPackage.Speed                                                             RefVariant[EffectPackageAssetParams]
 33 : F32            EffectPackages[].EffectPackage.Path.Speed[].x                                                    RefVariant[EffectPackageAssetParams]
 34 : F32            EffectPackages[].EffectPackage.Path.Speed[].y                                                    RefVariant[EffectPackageAssetParams]
 35 : ArraySizeName  EffectPackages[].EffectPackage.Effects                                                           RefVariant[EffectPackageAssetParams]
 36 : String         EffectPackages[].EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[EmitterEffect]
 37 : Bool           EffectPackages[].EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[EmitterEffect]
 38 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[EmitterEffect]
 39 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[EmitterEffect]
 40 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[EmitterEffect]
 41 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[EmitterEffect]
 42 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[EmitterEffect]
 43 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[EmitterEffect]
 44 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[EmitterEffect]
 45 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[EmitterEffect]
 46 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[EmitterEffect]
 47 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[EmitterEffect]
 48 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[EmitterEffect]
 49 : PlaybackMode   EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[EmitterEffect]
 50 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[EmitterEffect]
 51 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[EmitterEffect]
 52 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].ControlPoints                                           RefVariant[EmitterEffect]
 53 : Transform      EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[EmitterEffect]
 54 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Scale                                                   RefVariant[EmitterEffect]
 55 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[EmitterEffect]
 56 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[EmitterEffect]
 57 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Speed                                                   RefVariant[EmitterEffect]
 58 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[EmitterEffect]
 59 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[EmitterEffect]
 60 : Bool           EffectPackages[].EffectPackage.Effects[].EmitterVelocityChanges.AdjustLifetime.AdjustEnabled     RefVariant[EmitterEffect]
 61 : F32            EffectPackages[].EffectPackage.Effects[].EmitterVelocityChanges.AdjustLifetime.VelocityLow       RefVariant[EmitterEffect]
 62 : F32            EffectPackages[].EffectPackage.Effects[].EmitterVelocityChanges.AdjustLifetime.VelocityHigh      RefVariant[EmitterEffect]
 63 : F32            EffectPackages[].EffectPackage.Effects[].EmitterVelocityChanges.AdjustLifetime.LowValue          RefVariant[EmitterEffect]
 64 : F32            EffectPackages[].EffectPackage.Effects[].EmitterVelocityChanges.AdjustLifetime.HighValue         RefVariant[EmitterEffect]
 65 : Bool           EffectPackages[].EffectPackage.Effects[].EmitterVelocityChanges.AdjustEmitterRate.AdjustEnabled  RefVariant[EmitterEffect]
 66 : F32            EffectPackages[].EffectPackage.Effects[].EmitterVelocityChanges.AdjustEmitterRate.VelocityLow    RefVariant[EmitterEffect]
 67 : F32            EffectPackages[].EffectPackage.Effects[].EmitterVelocityChanges.AdjustEmitterRate.VelocityHigh   RefVariant[EmitterEffect]
 68 : F32            EffectPackages[].EffectPackage.Effects[].EmitterVelocityChanges.AdjustEmitterRate.LowValue       RefVariant[EmitterEffect]
 69 : F32            EffectPackages[].EffectPackage.Effects[].EmitterVelocityChanges.AdjustEmitterRate.HighValue      RefVariant[EmitterEffect]
 70 : Ref            EffectPackages[].EffectPackage.Effects[].Emitter                                                 RefVariant[EmitterEffect]
 71 : String         EffectPackages[].EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[HeatSourceEffect]
 72 : Bool           EffectPackages[].EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[HeatSourceEffect]
 73 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[HeatSourceEffect]
 74 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[HeatSourceEffect]
 75 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[HeatSourceEffect]
 76 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[HeatSourceEffect]
 77 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[HeatSourceEffect]
 78 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[HeatSourceEffect]
 79 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[HeatSourceEffect]
 80 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[HeatSourceEffect]
 81 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[HeatSourceEffect]
 82 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[HeatSourceEffect]
 83 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[HeatSourceEffect]
 84 : PlaybackMode   EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[HeatSourceEffect]
 85 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[HeatSourceEffect]
 86 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[HeatSourceEffect]
 87 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].ControlPoints                                           RefVariant[HeatSourceEffect]
 88 : Transform      EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[HeatSourceEffect]
 89 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Scale                                                   RefVariant[HeatSourceEffect]
 90 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[HeatSourceEffect]
 91 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[HeatSourceEffect]
 92 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Speed                                                   RefVariant[HeatSourceEffect]
 93 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[HeatSourceEffect]
 94 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[HeatSourceEffect]
 95 : Ref            EffectPackages[].EffectPackage.Effects[].HeatSource                                              RefVariant[HeatSourceEffect]
 96 : String         EffectPackages[].EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[JetFieldSamplerEffect]
 97 : Bool           EffectPackages[].EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[JetFieldSamplerEffect]
 98 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[JetFieldSamplerEffect]
 99 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[JetFieldSamplerEffect]
100 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[JetFieldSamplerEffect]
101 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[JetFieldSamplerEffect]
102 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[JetFieldSamplerEffect]
103 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[JetFieldSamplerEffect]
104 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[JetFieldSamplerEffect]
105 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[JetFieldSamplerEffect]
106 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[JetFieldSamplerEffect]
107 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[JetFieldSamplerEffect]
108 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[JetFieldSamplerEffect]
109 : PlaybackMode   EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[JetFieldSamplerEffect]
110 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[JetFieldSamplerEffect]
111 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[JetFieldSamplerEffect]
112 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].ControlPoints                                           RefVariant[JetFieldSamplerEffect]
113 : Transform      EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[JetFieldSamplerEffect]
114 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Scale                                                   RefVariant[JetFieldSamplerEffect]
115 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[JetFieldSamplerEffect]
116 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[JetFieldSamplerEffect]
117 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Speed                                                   RefVariant[JetFieldSamplerEffect]
118 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[JetFieldSamplerEffect]
119 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[JetFieldSamplerEffect]
120 : Ref            EffectPackages[].EffectPackage.Effects[].JetFieldSampler                                         RefVariant[JetFieldSamplerEffect]
121 : String         EffectPackages[].EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[AttractorFieldSamplerEffect]
122 : Bool           EffectPackages[].EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[AttractorFieldSamplerEffect]
123 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[AttractorFieldSamplerEffect]
124 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[AttractorFieldSamplerEffect]
125 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[AttractorFieldSamplerEffect]
126 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[AttractorFieldSamplerEffect]
127 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[AttractorFieldSamplerEffect]
128 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[AttractorFieldSamplerEffect]
129 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[AttractorFieldSamplerEffect]
130 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[AttractorFieldSamplerEffect]
131 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[AttractorFieldSamplerEffect]
132 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[AttractorFieldSamplerEffect]
133 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[AttractorFieldSamplerEffect]
134 : PlaybackMode   EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[AttractorFieldSamplerEffect]
135 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[AttractorFieldSamplerEffect]
136 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[AttractorFieldSamplerEffect]
137 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].ControlPoints                                           RefVariant[AttractorFieldSamplerEffect]
138 : Transform      EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[AttractorFieldSamplerEffect]
139 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Scale                                                   RefVariant[AttractorFieldSamplerEffect]
140 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[AttractorFieldSamplerEffect]
141 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[AttractorFieldSamplerEffect]
142 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Speed                                                   RefVariant[AttractorFieldSamplerEffect]
143 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[AttractorFieldSamplerEffect]
144 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[AttractorFieldSamplerEffect]
145 : Ref            EffectPackages[].EffectPackage.Effects[].AttractorFieldSampler                                   RefVariant[AttractorFieldSamplerEffect]
146 : String         EffectPackages[].EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[TurbulenceFieldSamplerEffect]
147 : Bool           EffectPackages[].EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[TurbulenceFieldSamplerEffect]
148 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[TurbulenceFieldSamplerEffect]
149 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[TurbulenceFieldSamplerEffect]
150 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[TurbulenceFieldSamplerEffect]
151 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[TurbulenceFieldSamplerEffect]
152 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[TurbulenceFieldSamplerEffect]
153 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[TurbulenceFieldSamplerEffect]
154 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[TurbulenceFieldSamplerEffect]
155 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[TurbulenceFieldSamplerEffect]
156 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[TurbulenceFieldSamplerEffect]
157 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[TurbulenceFieldSamplerEffect]
158 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[TurbulenceFieldSamplerEffect]
159 : PlaybackMode   EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[TurbulenceFieldSamplerEffect]
160 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[TurbulenceFieldSamplerEffect]
161 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[TurbulenceFieldSamplerEffect]
162 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].ControlPoints                                           RefVariant[TurbulenceFieldSamplerEffect]
163 : Transform      EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[TurbulenceFieldSamplerEffect]
164 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Scale                                                   RefVariant[TurbulenceFieldSamplerEffect]
165 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[TurbulenceFieldSamplerEffect]
166 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[TurbulenceFieldSamplerEffect]
167 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Speed                                                   RefVariant[TurbulenceFieldSamplerEffect]
168 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[TurbulenceFieldSamplerEffect]
169 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[TurbulenceFieldSamplerEffect]
170 : Ref            EffectPackages[].EffectPackage.Effects[].TurbulenceFieldSampler                                  RefVariant[TurbulenceFieldSamplerEffect]
171 : String         EffectPackages[].EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[ForceFieldEffect]
172 : Bool           EffectPackages[].EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[ForceFieldEffect]
173 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[ForceFieldEffect]
174 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[ForceFieldEffect]
175 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[ForceFieldEffect]
176 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[ForceFieldEffect]
177 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[ForceFieldEffect]
178 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[ForceFieldEffect]
179 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[ForceFieldEffect]
180 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[ForceFieldEffect]
181 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[ForceFieldEffect]
182 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[ForceFieldEffect]
183 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[ForceFieldEffect]
184 : PlaybackMode   EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[ForceFieldEffect]
185 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[ForceFieldEffect]
186 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[ForceFieldEffect]
187 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].ControlPoints                                           RefVariant[ForceFieldEffect]
188 : Transform      EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[ForceFieldEffect]
189 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Scale                                                   RefVariant[ForceFieldEffect]
190 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[ForceFieldEffect]
191 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[ForceFieldEffect]
192 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Speed                                                   RefVariant[ForceFieldEffect]
193 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[ForceFieldEffect]
194 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[ForceFieldEffect]
195 : Ref            EffectPackages[].EffectPackage.Effects[].ForceField                                              RefVariant[ForceFieldEffect]
196 : String         EffectPackages[].EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[NoiseFieldSamplerEffect]
197 : Bool           EffectPackages[].EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[NoiseFieldSamplerEffect]
198 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[NoiseFieldSamplerEffect]
199 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[NoiseFieldSamplerEffect]
200 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[NoiseFieldSamplerEffect]
201 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[NoiseFieldSamplerEffect]
202 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[NoiseFieldSamplerEffect]
203 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[NoiseFieldSamplerEffect]
204 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[NoiseFieldSamplerEffect]
205 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[NoiseFieldSamplerEffect]
206 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[NoiseFieldSamplerEffect]
207 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[NoiseFieldSamplerEffect]
208 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[NoiseFieldSamplerEffect]
209 : PlaybackMode   EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[NoiseFieldSamplerEffect]
210 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[NoiseFieldSamplerEffect]
211 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[NoiseFieldSamplerEffect]
212 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].ControlPoints                                           RefVariant[NoiseFieldSamplerEffect]
213 : Transform      EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[NoiseFieldSamplerEffect]
214 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Scale                                                   RefVariant[NoiseFieldSamplerEffect]
215 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[NoiseFieldSamplerEffect]
216 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[NoiseFieldSamplerEffect]
217 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Speed                                                   RefVariant[NoiseFieldSamplerEffect]
218 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[NoiseFieldSamplerEffect]
219 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[NoiseFieldSamplerEffect]
220 : Ref            EffectPackages[].EffectPackage.Effects[].NoiseFieldSampler                                       RefVariant[NoiseFieldSamplerEffect]
221 : String         EffectPackages[].EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[VortexFieldSamplerEffect]
222 : Bool           EffectPackages[].EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[VortexFieldSamplerEffect]
223 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[VortexFieldSamplerEffect]
224 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[VortexFieldSamplerEffect]
225 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[VortexFieldSamplerEffect]
226 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[VortexFieldSamplerEffect]
227 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[VortexFieldSamplerEffect]
228 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[VortexFieldSamplerEffect]
229 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[VortexFieldSamplerEffect]
230 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[VortexFieldSamplerEffect]
231 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[VortexFieldSamplerEffect]
232 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[VortexFieldSamplerEffect]
233 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[VortexFieldSamplerEffect]
234 : PlaybackMode   EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[VortexFieldSamplerEffect]
235 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[VortexFieldSamplerEffect]
236 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[VortexFieldSamplerEffect]
237 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].ControlPoints                                           RefVariant[VortexFieldSamplerEffect]
238 : Transform      EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[VortexFieldSamplerEffect]
239 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Scale                                                   RefVariant[VortexFieldSamplerEffect]
240 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[VortexFieldSamplerEffect]
241 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[VortexFieldSamplerEffect]
242 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Speed                                                   RefVariant[VortexFieldSamplerEffect]
243 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[VortexFieldSamplerEffect]
244 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[VortexFieldSamplerEffect]
245 : Ref            EffectPackages[].EffectPackage.Effects[].VortexFieldSampler                                      RefVariant[VortexFieldSamplerEffect]
246 : String         EffectPackages[].EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[SubstanceSourceEffect]
247 : Bool           EffectPackages[].EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[SubstanceSourceEffect]
248 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[SubstanceSourceEffect]
249 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[SubstanceSourceEffect]
250 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[SubstanceSourceEffect]
251 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[SubstanceSourceEffect]
252 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[SubstanceSourceEffect]
253 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[SubstanceSourceEffect]
254 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[SubstanceSourceEffect]
255 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[SubstanceSourceEffect]
256 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[SubstanceSourceEffect]
257 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[SubstanceSourceEffect]
258 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[SubstanceSourceEffect]
259 : PlaybackMode   EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[SubstanceSourceEffect]
260 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[SubstanceSourceEffect]
261 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[SubstanceSourceEffect]
262 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].ControlPoints                                           RefVariant[SubstanceSourceEffect]
263 : Transform      EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[SubstanceSourceEffect]
264 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Scale                                                   RefVariant[SubstanceSourceEffect]
265 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[SubstanceSourceEffect]
266 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[SubstanceSourceEffect]
267 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Speed                                                   RefVariant[SubstanceSourceEffect]
268 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[SubstanceSourceEffect]
269 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[SubstanceSourceEffect]
270 : Ref            EffectPackages[].EffectPackage.Effects[].SubstanceSource                                         RefVariant[SubstanceSourceEffect]
271 : String         EffectPackages[].EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[WindFieldSamplerEffect]
272 : Bool           EffectPackages[].EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[WindFieldSamplerEffect]
273 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[WindFieldSamplerEffect]
274 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[WindFieldSamplerEffect]
275 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[WindFieldSamplerEffect]
276 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[WindFieldSamplerEffect]
277 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[WindFieldSamplerEffect]
278 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[WindFieldSamplerEffect]
279 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[WindFieldSamplerEffect]
280 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[WindFieldSamplerEffect]
281 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[WindFieldSamplerEffect]
282 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[WindFieldSamplerEffect]
283 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[WindFieldSamplerEffect]
284 : PlaybackMode   EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[WindFieldSamplerEffect]
285 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[WindFieldSamplerEffect]
286 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[WindFieldSamplerEffect]
287 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].ControlPoints                                           RefVariant[WindFieldSamplerEffect]
288 : Transform      EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[WindFieldSamplerEffect]
289 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Scale                                                   RefVariant[WindFieldSamplerEffect]
290 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[WindFieldSamplerEffect]
291 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[WindFieldSamplerEffect]
292 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Speed                                                   RefVariant[WindFieldSamplerEffect]
293 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[WindFieldSamplerEffect]
294 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[WindFieldSamplerEffect]
295 : Ref            EffectPackages[].EffectPackage.Effects[].WindFieldSampler                                        RefVariant[WindFieldSamplerEffect]
296 : String         EffectPackages[].EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[RigidBodyEffect]
297 : Bool           EffectPackages[].EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[RigidBodyEffect]
298 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[RigidBodyEffect]
299 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[RigidBodyEffect]
300 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[RigidBodyEffect]
301 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[RigidBodyEffect]
302 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[RigidBodyEffect]
303 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[RigidBodyEffect]
304 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[RigidBodyEffect]
305 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[RigidBodyEffect]
306 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[RigidBodyEffect]
307 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[RigidBodyEffect]
308 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[RigidBodyEffect]
309 : PlaybackMode   EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[RigidBodyEffect]
310 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[RigidBodyEffect]
311 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[RigidBodyEffect]
312 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].ControlPoints                                           RefVariant[RigidBodyEffect]
313 : Transform      EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[RigidBodyEffect]
314 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Scale                                                   RefVariant[RigidBodyEffect]
315 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[RigidBodyEffect]
316 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[RigidBodyEffect]
317 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Speed                                                   RefVariant[RigidBodyEffect]
318 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[RigidBodyEffect]
319 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[RigidBodyEffect]
320 : Type           EffectPackages[].EffectPackage.Effects[].Type                                                    RefVariant[RigidBodyEffect]
321 : String         EffectPackages[].EffectPackage.Effects[].CollisionFilterDataName                                 RefVariant[RigidBodyEffect]
322 : Bool           EffectPackages[].EffectPackage.Effects[].Dynamic                                                 RefVariant[RigidBodyEffect]
323 : Bool           EffectPackages[].EffectPackage.Effects[].Gravity                                                 RefVariant[RigidBodyEffect]
324 : Vec3           EffectPackages[].EffectPackage.Effects[].Extents                                                 RefVariant[RigidBodyEffect]
325 : F32            EffectPackages[].EffectPackage.Effects[].Mass                                                    RefVariant[RigidBodyEffect]
326 : Vec3           EffectPackages[].EffectPackage.Effects[].InitialLinearVelocity                                   RefVariant[RigidBodyEffect]
327 : Vec3           EffectPackages[].EffectPackage.Effects[].InitialAngularVelocity                                  RefVariant[RigidBodyEffect]
328 : F32            EffectPackages[].EffectPackage.Effects[].LinearDamping                                           RefVariant[RigidBodyEffect]
329 : F32            EffectPackages[].EffectPackage.Effects[].AngularDamping                                          RefVariant[RigidBodyEffect]
330 : String         EffectPackages[].EffectPackage.Effects[].EffectProperties.UserString                             RefVariant[VelocitySourceEffect]
331 : Bool           EffectPackages[].EffectPackage.Effects[].EffectProperties.Enable                                 RefVariant[VelocitySourceEffect]
332 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateX                    RefVariant[VelocitySourceEffect]
333 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateY                    RefVariant[VelocitySourceEffect]
334 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Position.TranslateZ                    RefVariant[VelocitySourceEffect]
335 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateX                    RefVariant[VelocitySourceEffect]
336 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateY                    RefVariant[VelocitySourceEffect]
337 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Orientation.RotateZ                    RefVariant[VelocitySourceEffect]
338 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.InitialDelayTime                       RefVariant[VelocitySourceEffect]
339 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Duration                               RefVariant[VelocitySourceEffect]
340 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatCount                            RefVariant[VelocitySourceEffect]
341 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RepeatDelay                            RefVariant[VelocitySourceEffect]
342 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.RandomizeRepeatTime                    RefVariant[VelocitySourceEffect]
343 : PlaybackMode   EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PlaybackMode                      RefVariant[VelocitySourceEffect]
344 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.PathDuration                      RefVariant[VelocitySourceEffect]
345 : U32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.LoopIndex                         RefVariant[VelocitySourceEffect]
346 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].ControlPoints                                           RefVariant[VelocitySourceEffect]
347 : Transform      EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.ControlPoints[]                   RefVariant[VelocitySourceEffect]
348 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Scale                                                   RefVariant[VelocitySourceEffect]
349 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].x                         RefVariant[VelocitySourceEffect]
350 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Scale[].y                         RefVariant[VelocitySourceEffect]
351 : ArraySizeName  EffectPackages[].EffectPackage.Effects[].Speed                                                   RefVariant[VelocitySourceEffect]
352 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].x                         RefVariant[VelocitySourceEffect]
353 : F32            EffectPackages[].EffectPackage.Effects[].EffectProperties.Path.Speed[].y                         RefVariant[VelocitySourceEffect]
354 : Ref            EffectPackages[].EffectPackage.Effects[].VelocitySource                                          RefVariant[VelocitySourceEffect]

Member Data Documentation

EffectPackageData EffectPackageDatabaseParams::EffectPackages[]

'EffectPackages[]' :

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EffectPackageDatabaseParams Member List
This is the complete list of members for EffectPackageDatabaseParams, including all inherited members.
EffectPackages[] EffectPackageDatabaseParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EffectPackageEmitterDatabaseParams Struct Reference

  • Class List
  • Class Members
Public Attributes
EffectPackageEmitterDatabaseParams Struct Reference

Describes the NxParameterized::Interface for 'EffectPackageEmitterDatabaseParams' : The collection of all emitter assets. More...

#include <params.h>

List of all members.

Public Attributes

EmitterData Emitters[]
'Emitters[]' :

Detailed Description

Describes the NxParameterized::Interface for 'EffectPackageEmitterDatabaseParams' : The collection of all emitter assets.

EffectPackageEmitterDatabaseParams contains 59 fully qualified names
---------------------------------------------
  1 : ArraySizeName  Emitters
  2 : String         Emitters[].Name                                                          RefVariant[EmitterData]
  3 : F32            Emitters[].Emitter.densityRange.min                                      RefVariant[ApexEmitterAssetParameters]
  4 : F32            Emitters[].Emitter.densityRange.max                                      RefVariant[ApexEmitterAssetParameters]
  5 : F32            Emitters[].Emitter.rateRange.min                                         RefVariant[ApexEmitterAssetParameters]
  6 : F32            Emitters[].Emitter.rateRange.max                                         RefVariant[ApexEmitterAssetParameters]
  7 : F32            Emitters[].Emitter.lifetimeRange.min                                     RefVariant[ApexEmitterAssetParameters]
  8 : F32            Emitters[].Emitter.lifetimeRange.max                                     RefVariant[ApexEmitterAssetParameters]
  9 : Vec3           Emitters[].Emitter.velocityRange.min                                     RefVariant[ApexEmitterAssetParameters]
 10 : Vec3           Emitters[].Emitter.velocityRange.max                                     RefVariant[ApexEmitterAssetParameters]
 11 : F32            Emitters[].Emitter.temperatureRange.min                                  RefVariant[ApexEmitterAssetParameters]
 12 : F32            Emitters[].Emitter.temperatureRange.max                                  RefVariant[ApexEmitterAssetParameters]
 13 : U32            Emitters[].Emitter.maxSamples                                            RefVariant[ApexEmitterAssetParameters]
 14 : U32            Emitters[].Emitter.lodParamDesc.version                                  RefVariant[ApexEmitterAssetParameters]
 15 : F32            Emitters[].Emitter.lodParamDesc.maxDistance                              RefVariant[ApexEmitterAssetParameters]
 16 : F32            Emitters[].Emitter.lodParamDesc.distanceWeight                           RefVariant[ApexEmitterAssetParameters]
 17 : F32            Emitters[].Emitter.lodParamDesc.speedWeight                              RefVariant[ApexEmitterAssetParameters]
 18 : F32            Emitters[].Emitter.lodParamDesc.lifeWeight                               RefVariant[ApexEmitterAssetParameters]
 19 : F32            Emitters[].Emitter.lodParamDesc.separationWeight                         RefVariant[ApexEmitterAssetParameters]
 20 : F32            Emitters[].Emitter.lodParamDesc.bias                                     RefVariant[ApexEmitterAssetParameters]
 21 : Ref            Emitters[].Emitter.iofxAssetName                                         RefVariant[ApexEmitterAssetParameters]
 22 : Ref            Emitters[].Emitter.iosAssetName                                          RefVariant[ApexEmitterAssetParameters]
 23 : EmitterType    Emitters[].Emitter.geometryType.emitterType                              RefVariant[EmitterGeomBoxParams]
 24 : Vec3           Emitters[].Emitter.geometryType.extents                                  RefVariant[EmitterGeomBoxParams]
 25 : EmitterType    Emitters[].Emitter.geometryType.emitterType                              RefVariant[EmitterGeomSphereParams]
 26 : F32            Emitters[].Emitter.geometryType.radius                                   RefVariant[EmitterGeomSphereParams]
 27 : F32            Emitters[].Emitter.geometryType.hemisphere                               RefVariant[EmitterGeomSphereParams]
 28 : EmitterType    Emitters[].Emitter.geometryType.emitterType                              RefVariant[EmitterGeomSphereShellParams]
 29 : F32            Emitters[].Emitter.geometryType.radius                                   RefVariant[EmitterGeomSphereShellParams]
 30 : F32            Emitters[].Emitter.geometryType.shellThickness                           RefVariant[EmitterGeomSphereShellParams]
 31 : F32            Emitters[].Emitter.geometryType.hemisphere                               RefVariant[EmitterGeomSphereShellParams]
 32 : EmitterType    Emitters[].Emitter.geometryType.emitterType                              RefVariant[EmitterGeomCylinderParams]
 33 : F32            Emitters[].Emitter.geometryType.radius                                   RefVariant[EmitterGeomCylinderParams]
 34 : F32            Emitters[].Emitter.geometryType.height                                   RefVariant[EmitterGeomCylinderParams]
 35 : F32            Emitters[].Emitter.geometryType.distance                                 RefVariant[EmitterGeomExplicitParams]
 36 : ArraySizeName  Emitters[].Emitter.geometryType.positions                                RefVariant[EmitterGeomExplicitParams]
 37 : Vec3           Emitters[].Emitter.geometryType.points.positions[].position              RefVariant[EmitterGeomExplicitParams]
 38 : Bool           Emitters[].Emitter.geometryType.points.positions[].doDetectOverlaps      RefVariant[EmitterGeomExplicitParams]
 39 : ArraySizeName  Emitters[].Emitter.geometryType.velocities                               RefVariant[EmitterGeomExplicitParams]
 40 : Vec3           Emitters[].Emitter.geometryType.points.velocities[]                      RefVariant[EmitterGeomExplicitParams]
 41 : ArraySizeName  Emitters[].Emitter.geometryType.positions                                RefVariant[EmitterGeomExplicitParams]
 42 : Vec3           Emitters[].Emitter.geometryType.spheres.positions[].center               RefVariant[EmitterGeomExplicitParams]
 43 : F32            Emitters[].Emitter.geometryType.spheres.positions[].radius               RefVariant[EmitterGeomExplicitParams]
 44 : Bool           Emitters[].Emitter.geometryType.spheres.positions[].doDetectOverlaps     RefVariant[EmitterGeomExplicitParams]
 45 : ArraySizeName  Emitters[].Emitter.geometryType.velocities                               RefVariant[EmitterGeomExplicitParams]
 46 : Vec3           Emitters[].Emitter.geometryType.spheres.velocities[]                     RefVariant[EmitterGeomExplicitParams]
 47 : ArraySizeName  Emitters[].Emitter.geometryType.positions                                RefVariant[EmitterGeomExplicitParams]
 48 : Vec3           Emitters[].Emitter.geometryType.ellipsoids.positions[].center            RefVariant[EmitterGeomExplicitParams]
 49 : F32            Emitters[].Emitter.geometryType.ellipsoids.positions[].radius            RefVariant[EmitterGeomExplicitParams]
 50 : Vec3           Emitters[].Emitter.geometryType.ellipsoids.positions[].normal            RefVariant[EmitterGeomExplicitParams]
 51 : F32            Emitters[].Emitter.geometryType.ellipsoids.positions[].polarRadius       RefVariant[EmitterGeomExplicitParams]
 52 : Bool           Emitters[].Emitter.geometryType.ellipsoids.positions[].doDetectOverlaps  RefVariant[EmitterGeomExplicitParams]
 53 : ArraySizeName  Emitters[].Emitter.geometryType.velocities                               RefVariant[EmitterGeomExplicitParams]
 54 : Vec3           Emitters[].Emitter.geometryType.ellipsoids.velocities[]                  RefVariant[EmitterGeomExplicitParams]
 55 : F32            Emitters[].Emitter.emitterDuration                                       RefVariant[ApexEmitterAssetParameters]
 56 : U32            Emitters[].Emitter.minSamplingFPS                                        RefVariant[ApexEmitterAssetParameters]
 57 : ArraySizeName  Emitters[].Emitter.rateVsTimeCurvePoints                                 RefVariant[ApexEmitterAssetParameters]
 58 : F32            Emitters[].Emitter.rateVsTimeCurvePoints[].x                             RefVariant[ApexEmitterAssetParameters]
 59 : F32            Emitters[].Emitter.rateVsTimeCurvePoints[].y                             RefVariant[ApexEmitterAssetParameters]

Member Data Documentation

EmitterData EffectPackageEmitterDatabaseParams::Emitters[]

'Emitters[]' :

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EffectPackageEmitterDatabaseParams Member List
This is the complete list of members for EffectPackageEmitterDatabaseParams, including all inherited members.
Emitters[] EffectPackageEmitterDatabaseParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EffectPackageFieldSamplerDatabaseParams Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
EffectPackageFieldSamplerDatabaseParams Struct Reference

Describes the NxParameterized::Interface for 'EffectPackageFieldSamplerDatabaseParams' : The collection of all field sampler assets. More...

#include <params.h>

List of all members.

Classes

union FieldSamplers

Public Attributes

FieldSamplers FieldSamplers[]

Detailed Description

Describes the NxParameterized::Interface for 'EffectPackageFieldSamplerDatabaseParams' : The collection of all field sampler assets.

EffectPackageFieldSamplerDatabaseParams contains 238 fully qualified names
---------------------------------------------
  1 : ArraySizeName      FieldSamplers
  2 : String             FieldSamplers[].Name                                                                    RefVariant[AttractorFieldSamplerData]
  3 : F32                FieldSamplers[].AttractorFieldSampler.boundaryFadePercentage                            RefVariant[AttractorFSAssetParams]
  4 : F32                FieldSamplers[].AttractorFieldSampler.radius                                            RefVariant[AttractorFSAssetParams]
  5 : F32                FieldSamplers[].AttractorFieldSampler.constFieldStrength                                RefVariant[AttractorFSAssetParams]
  6 : F32                FieldSamplers[].AttractorFieldSampler.variableFieldStrength                             RefVariant[AttractorFSAssetParams]
  7 : F32                FieldSamplers[].AttractorFieldSampler.fieldDragCoeff                                    RefVariant[AttractorFSAssetParams]
  8 : F32                FieldSamplers[].AttractorFieldSampler.fieldWeight                                       RefVariant[AttractorFSAssetParams]
  9 : String             FieldSamplers[].AttractorFieldSampler.fieldBoundaryFilterDataName                       RefVariant[AttractorFSAssetParams]
 10 : String             FieldSamplers[].AttractorFieldSampler.fieldSamplerFilterDataName                        RefVariant[AttractorFSAssetParams]
 11 : String             FieldSamplers[].Name                                                                    RefVariant[ForceFieldData]
 12 : Type               FieldSamplers[].ForceField.forceFieldKernelType.coordinateSystemParameters.type         RefVariant[GenericForceFieldKernelParams]
 13 : F32                FieldSamplers[].ForceField.forceFieldKernelType.coordinateSystemParameters.torusRadius  RefVariant[GenericForceFieldKernelParams]
 14 : Vec3               FieldSamplers[].ForceField.forceFieldKernelType.constant                                RefVariant[GenericForceFieldKernelParams]
 15 : Mat33              FieldSamplers[].ForceField.forceFieldKernelType.positionMultiplier                      RefVariant[GenericForceFieldKernelParams]
 16 : Vec3               FieldSamplers[].ForceField.forceFieldKernelType.positionTarget                          RefVariant[GenericForceFieldKernelParams]
 17 : Mat33              FieldSamplers[].ForceField.forceFieldKernelType.velocityMultiplier                      RefVariant[GenericForceFieldKernelParams]
 18 : Vec3               FieldSamplers[].ForceField.forceFieldKernelType.velocityTarget                          RefVariant[GenericForceFieldKernelParams]
 19 : Vec3               FieldSamplers[].ForceField.forceFieldKernelType.noise                                   RefVariant[GenericForceFieldKernelParams]
 20 : Vec3               FieldSamplers[].ForceField.forceFieldKernelType.falloffLinear                           RefVariant[GenericForceFieldKernelParams]
 21 : Vec3               FieldSamplers[].ForceField.forceFieldKernelType.falloffQuadratic                        RefVariant[GenericForceFieldKernelParams]
 22 : Type               FieldSamplers[].ForceField.forceFieldKernelType.falloffParameters.type                  RefVariant[ForceFieldFalloffParams]
 23 : F32                FieldSamplers[].ForceField.forceFieldKernelType.falloffParameters.multiplier            RefVariant[ForceFieldFalloffParams]
 24 : F32                FieldSamplers[].ForceField.forceFieldKernelType.falloffParameters.start                 RefVariant[ForceFieldFalloffParams]
 25 : F32                FieldSamplers[].ForceField.forceFieldKernelType.falloffParameters.end                   RefVariant[ForceFieldFalloffParams]
 26 : F32                FieldSamplers[].ForceField.forceFieldKernelType.noiseParameters.strength                RefVariant[ForceFieldNoiseParams]
 27 : F32                FieldSamplers[].ForceField.forceFieldKernelType.noiseParameters.spaceScale              RefVariant[ForceFieldNoiseParams]
 28 : F32                FieldSamplers[].ForceField.forceFieldKernelType.noiseParameters.timeScale               RefVariant[ForceFieldNoiseParams]
 29 : U32                FieldSamplers[].ForceField.forceFieldKernelType.noiseParameters.octaves                 RefVariant[ForceFieldNoiseParams]
 30 : F32                FieldSamplers[].ForceField.forceFieldKernelType.radius                                  RefVariant[RadialForceFieldKernelParams]
 31 : F32                FieldSamplers[].ForceField.defScale                                                     RefVariant[ForceFieldAssetParams]
 32 : F32                FieldSamplers[].ForceField.strength                                                     RefVariant[ForceFieldAssetParams]
 33 : F32                FieldSamplers[].ForceField.lifetime                                                     RefVariant[ForceFieldAssetParams]
 34 : Shape              FieldSamplers[].ForceField.includeShapeParameters.shape                                 RefVariant[ForceFieldAssetParams]
 35 : Mat44              FieldSamplers[].ForceField.includeShapeParameters.forceFieldToShape                     RefVariant[ForceFieldAssetParams]
 36 : Vec3               FieldSamplers[].ForceField.includeShapeParameters.dimensions                            RefVariant[ForceFieldAssetParams]
 37 : String             FieldSamplers[].ForceField.fieldBoundaryFilterDataName                                  RefVariant[ForceFieldAssetParams]
 38 : String             FieldSamplers[].ForceField.fieldSamplerFilterDataName                                   RefVariant[ForceFieldAssetParams]
 39 : String             FieldSamplers[].Name                                                                    RefVariant[HeatSourceData]
 40 : F32                FieldSamplers[].HeatSource.averageTemperature                                           RefVariant[HeatSourceAssetParams]
 41 : F32                FieldSamplers[].HeatSource.stdTemperature                                               RefVariant[HeatSourceAssetParams]
 42 : Vec3               FieldSamplers[].HeatSource.geometryType.extents                                         RefVariant[HeatSourceGeomBoxParams]
 43 : F32                FieldSamplers[].HeatSource.geometryType.radius                                          RefVariant[HeatSourceGeomSphereParams]
 44 : String             FieldSamplers[].HeatSource.fieldSamplerFilterDataName                                   RefVariant[HeatSourceAssetParams]
 45 : String             FieldSamplers[].Name                                                                    RefVariant[JetFieldSamplerData]
 46 : F32                FieldSamplers[].JetFieldSampler.defaultScale                                            RefVariant[JetFSAssetParams]
 47 : F32                FieldSamplers[].JetFieldSampler.boundaryFadePercentage                                  RefVariant[JetFSAssetParams]
 48 : Vec3               FieldSamplers[].JetFieldSampler.fieldDirection                                          RefVariant[JetFSAssetParams]
 49 : F32                FieldSamplers[].JetFieldSampler.fieldDirectionDeviationAngle                            RefVariant[JetFSAssetParams]
 50 : F32                FieldSamplers[].JetFieldSampler.fieldDirectionOscillationPeriod                         RefVariant[JetFSAssetParams]
 51 : F32                FieldSamplers[].JetFieldSampler.fieldStrength                                           RefVariant[JetFSAssetParams]
 52 : F32                FieldSamplers[].JetFieldSampler.fieldStrengthDeviationPercentage                        RefVariant[JetFSAssetParams]
 53 : F32                FieldSamplers[].JetFieldSampler.fieldStrengthOscillationPeriod                          RefVariant[JetFSAssetParams]
 54 : F32                FieldSamplers[].JetFieldSampler.gridShapeRadius                                         RefVariant[JetFSAssetParams]
 55 : F32                FieldSamplers[].JetFieldSampler.gridShapeHeight                                         RefVariant[JetFSAssetParams]
 56 : F32                FieldSamplers[].JetFieldSampler.gridBoundaryFadePercentage                              RefVariant[JetFSAssetParams]
 57 : F32                FieldSamplers[].JetFieldSampler.nearRadius                                              RefVariant[JetFSAssetParams]
 58 : F32                FieldSamplers[].JetFieldSampler.pivotRadius                                             RefVariant[JetFSAssetParams]
 59 : F32                FieldSamplers[].JetFieldSampler.farRadius                                               RefVariant[JetFSAssetParams]
 60 : F32                FieldSamplers[].JetFieldSampler.directionalStretch                                      RefVariant[JetFSAssetParams]
 61 : F32                FieldSamplers[].JetFieldSampler.averageStartDistance                                    RefVariant[JetFSAssetParams]
 62 : F32                FieldSamplers[].JetFieldSampler.averageEndDistance                                      RefVariant[JetFSAssetParams]
 63 : F32                FieldSamplers[].JetFieldSampler.noisePercentage                                         RefVariant[JetFSAssetParams]
 64 : F32                FieldSamplers[].JetFieldSampler.noiseSpaceScale                                         RefVariant[JetFSAssetParams]
 65 : F32                FieldSamplers[].JetFieldSampler.noiseTimeScale                                          RefVariant[JetFSAssetParams]
 66 : U32                FieldSamplers[].JetFieldSampler.noiseOctaves                                            RefVariant[JetFSAssetParams]
 67 : F32                FieldSamplers[].JetFieldSampler.fieldDragCoeff                                          RefVariant[JetFSAssetParams]
 68 : F32                FieldSamplers[].JetFieldSampler.fieldWeight                                             RefVariant[JetFSAssetParams]
 69 : String             FieldSamplers[].JetFieldSampler.fieldBoundaryFilterDataName                             RefVariant[JetFSAssetParams]
 70 : String             FieldSamplers[].JetFieldSampler.fieldSamplerFilterDataName                              RefVariant[JetFSAssetParams]
 71 : String             FieldSamplers[].Name                                                                    RefVariant[TurbulenceFieldSamplerData]
 72 : Min                FieldSamplers[].TurbulenceFieldSampler.gridXRange.min                                   RefVariant[TurbulenceFSAssetParams]
 73 : Max                FieldSamplers[].TurbulenceFieldSampler.gridXRange.max                                   RefVariant[TurbulenceFSAssetParams]
 74 : Min                FieldSamplers[].TurbulenceFieldSampler.gridYRange.min                                   RefVariant[TurbulenceFSAssetParams]
 75 : Max                FieldSamplers[].TurbulenceFieldSampler.gridYRange.max                                   RefVariant[TurbulenceFSAssetParams]
 76 : Min                FieldSamplers[].TurbulenceFieldSampler.gridZRange.min                                   RefVariant[TurbulenceFSAssetParams]
 77 : Max                FieldSamplers[].TurbulenceFieldSampler.gridZRange.max                                   RefVariant[TurbulenceFSAssetParams]
 78 : Vec3               FieldSamplers[].TurbulenceFieldSampler.gridSizeWorld                                    RefVariant[TurbulenceFSAssetParams]
 79 : F32                FieldSamplers[].TurbulenceFieldSampler.updatesPerFrameRange.min                         RefVariant[TurbulenceFSAssetParams]
 80 : F32                FieldSamplers[].TurbulenceFieldSampler.updatesPerFrameRange.max                         RefVariant[TurbulenceFSAssetParams]
 81 : F32                FieldSamplers[].TurbulenceFieldSampler.angularVelocityMultiplier                        RefVariant[TurbulenceFSAssetParams]
 82 : F32                FieldSamplers[].TurbulenceFieldSampler.angularVelocityClamp                             RefVariant[TurbulenceFSAssetParams]
 83 : F32                FieldSamplers[].TurbulenceFieldSampler.linearVelocityMultiplier                         RefVariant[TurbulenceFSAssetParams]
 84 : F32                FieldSamplers[].TurbulenceFieldSampler.linearVelocityClamp                              RefVariant[TurbulenceFSAssetParams]
 85 : F32                FieldSamplers[].TurbulenceFieldSampler.velocityFieldFadeTime                            RefVariant[TurbulenceFSAssetParams]
 86 : F32                FieldSamplers[].TurbulenceFieldSampler.velocityFieldFadeDelay                           RefVariant[TurbulenceFSAssetParams]
 87 : F32                FieldSamplers[].TurbulenceFieldSampler.velocityFieldFadeIntensity                       RefVariant[TurbulenceFSAssetParams]
 88 : F32                FieldSamplers[].TurbulenceFieldSampler.boundaryFadePercentage                           RefVariant[TurbulenceFSAssetParams]
 89 : F32                FieldSamplers[].TurbulenceFieldSampler.boundarySizePercentage                           RefVariant[TurbulenceFSAssetParams]
 90 : String             FieldSamplers[].TurbulenceFieldSampler.collisionFilterDataName                          RefVariant[TurbulenceFSAssetParams]
 91 : String             FieldSamplers[].TurbulenceFieldSampler.fieldBoundaryFilterDataName                      RefVariant[TurbulenceFSAssetParams]
 92 : String             FieldSamplers[].TurbulenceFieldSampler.fieldSamplerFilterDataName                       RefVariant[TurbulenceFSAssetParams]
 93 : U32                FieldSamplers[].TurbulenceFieldSampler.maxCollidingObjects                              RefVariant[TurbulenceFSAssetParams]
 94 : U32                FieldSamplers[].TurbulenceFieldSampler.maxVelocitySources                               RefVariant[TurbulenceFSAssetParams]
 95 : U32                FieldSamplers[].TurbulenceFieldSampler.maxHeatSources                                   RefVariant[TurbulenceFSAssetParams]
 96 : U32                FieldSamplers[].TurbulenceFieldSampler.maxSubstanceSources                              RefVariant[TurbulenceFSAssetParams]
 97 : F32                FieldSamplers[].TurbulenceFieldSampler.dragCoeff                                        RefVariant[TurbulenceFSAssetParams]
 98 : Vec3               FieldSamplers[].TurbulenceFieldSampler.externalVelocity                                 RefVariant[TurbulenceFSAssetParams]
 99 : F32                FieldSamplers[].TurbulenceFieldSampler.fieldVelocityMultiplier                          RefVariant[TurbulenceFSAssetParams]
100 : F32                FieldSamplers[].TurbulenceFieldSampler.fieldVelocityWeight                              RefVariant[TurbulenceFSAssetParams]
101 : Bool               FieldSamplers[].TurbulenceFieldSampler.useHeat                                          RefVariant[TurbulenceFSAssetParams]
102 : F32                FieldSamplers[].TurbulenceFieldSampler.heatParams.temperatureBasedForceMultiplier       RefVariant[TurbulenceFSAssetParams]
103 : F32                FieldSamplers[].TurbulenceFieldSampler.heatParams.ambientTemperature                    RefVariant[TurbulenceFSAssetParams]
104 : Vec3               FieldSamplers[].TurbulenceFieldSampler.heatParams.heatForceDirection                    RefVariant[TurbulenceFSAssetParams]
105 : F32                FieldSamplers[].TurbulenceFieldSampler.heatParams.thermalConductivity                   RefVariant[TurbulenceFSAssetParams]
106 : Bool               FieldSamplers[].TurbulenceFieldSampler.useDensity                                       RefVariant[TurbulenceFSAssetParams]
107 : F32                FieldSamplers[].TurbulenceFieldSampler.densityParams.diffusionCoef                      RefVariant[TurbulenceFSAssetParams]
108 : F32                FieldSamplers[].TurbulenceFieldSampler.densityParams.densityFieldFade                   RefVariant[TurbulenceFSAssetParams]
109 : U32                FieldSamplers[].TurbulenceFieldSampler.densityParams.densityGridMultiplier              RefVariant[TurbulenceFSAssetParams]
110 : Bool               FieldSamplers[].TurbulenceFieldSampler.isEnabledOptimizedLOD                            RefVariant[TurbulenceFSAssetParams]
111 : F32                FieldSamplers[].TurbulenceFieldSampler.customLOD                                        RefVariant[TurbulenceFSAssetParams]
112 : F32                FieldSamplers[].TurbulenceFieldSampler.lodWeights.maxDistance                           RefVariant[TurbulenceFSAssetParams]
113 : F32                FieldSamplers[].TurbulenceFieldSampler.lodWeights.distanceWeight                        RefVariant[TurbulenceFSAssetParams]
114 : F32                FieldSamplers[].TurbulenceFieldSampler.lodWeights.bias                                  RefVariant[TurbulenceFSAssetParams]
115 : F32                FieldSamplers[].TurbulenceFieldSampler.lodWeights.benefitBias                           RefVariant[TurbulenceFSAssetParams]
116 : F32                FieldSamplers[].TurbulenceFieldSampler.lodWeights.benefitWeight                         RefVariant[TurbulenceFSAssetParams]
117 : F32                FieldSamplers[].TurbulenceFieldSampler.noiseParams.noiseStrength                        RefVariant[TurbulenceFSAssetParams]
118 : Vec3               FieldSamplers[].TurbulenceFieldSampler.noiseParams.noiseSpacePeriod                     RefVariant[TurbulenceFSAssetParams]
119 : F32                FieldSamplers[].TurbulenceFieldSampler.noiseParams.noiseTimePeriod                      RefVariant[TurbulenceFSAssetParams]
120 : U32                FieldSamplers[].TurbulenceFieldSampler.noiseParams.noiseOctaves                         RefVariant[TurbulenceFSAssetParams]
121 : F32                FieldSamplers[].TurbulenceFieldSampler.dragCoeffForRigidBody                            RefVariant[TurbulenceFSAssetParams]
122 : F32                FieldSamplers[].TurbulenceFieldSampler.fluidViscosity                                   RefVariant[TurbulenceFSAssetParams]
123 : Ref                FieldSamplers[].TurbulenceFieldSampler.volumeRenderMaterialName                         RefVariant[TurbulenceFSAssetParams]
124 : String             FieldSamplers[].Name                                                                    RefVariant[VortexFieldSamplerData]
125 : F32                FieldSamplers[].VortexFieldSampler.boundaryFadePercentage                               RefVariant[VortexFSAssetParams]
126 : Vec3               FieldSamplers[].VortexFieldSampler.axis                                                 RefVariant[VortexFSAssetParams]
127 : Bool               FieldSamplers[].VortexFieldSampler.bottomSphericalForce                                 RefVariant[VortexFSAssetParams]
128 : Bool               FieldSamplers[].VortexFieldSampler.topSphericalForce                                    RefVariant[VortexFSAssetParams]
129 : F32                FieldSamplers[].VortexFieldSampler.height                                               RefVariant[VortexFSAssetParams]
130 : F32                FieldSamplers[].VortexFieldSampler.bottomRadius                                         RefVariant[VortexFSAssetParams]
131 : F32                FieldSamplers[].VortexFieldSampler.topRadius                                            RefVariant[VortexFSAssetParams]
132 : F32                FieldSamplers[].VortexFieldSampler.rotationalStrength                                   RefVariant[VortexFSAssetParams]
133 : F32                FieldSamplers[].VortexFieldSampler.radialStrength                                       RefVariant[VortexFSAssetParams]
134 : F32                FieldSamplers[].VortexFieldSampler.liftStrength                                         RefVariant[VortexFSAssetParams]
135 : F32                FieldSamplers[].VortexFieldSampler.fieldDragCoeff                                       RefVariant[VortexFSAssetParams]
136 : F32                FieldSamplers[].VortexFieldSampler.fieldWeight                                          RefVariant[VortexFSAssetParams]
137 : String             FieldSamplers[].VortexFieldSampler.fieldBoundaryFilterDataName                          RefVariant[VortexFSAssetParams]
138 : String             FieldSamplers[].VortexFieldSampler.fieldSamplerFilterDataName                           RefVariant[VortexFSAssetParams]
139 : String             FieldSamplers[].Name                                                                    RefVariant[NoiseFieldSamplerData]
140 : F32                FieldSamplers[].NoiseFieldSampler.defaultScale                                          RefVariant[NoiseFSAssetParams]
141 : Vec3               FieldSamplers[].NoiseFieldSampler.boundarySize                                          RefVariant[NoiseFSAssetParams]
142 : F32                FieldSamplers[].NoiseFieldSampler.boundaryFadePercentage                                RefVariant[NoiseFSAssetParams]
143 : FieldType          FieldSamplers[].NoiseFieldSampler.fieldType                                             RefVariant[NoiseFSAssetParams]
144 : F32                FieldSamplers[].NoiseFieldSampler.fieldDragCoeff                                        RefVariant[NoiseFSAssetParams]
145 : F32                FieldSamplers[].NoiseFieldSampler.fieldWeight                                           RefVariant[NoiseFSAssetParams]
146 : NoiseType          FieldSamplers[].NoiseFieldSampler.noiseType                                             RefVariant[NoiseFSAssetParams]
147 : U32                FieldSamplers[].NoiseFieldSampler.noiseSeed                                             RefVariant[NoiseFSAssetParams]
148 : F32                FieldSamplers[].NoiseFieldSampler.noiseStrength                                         RefVariant[NoiseFSAssetParams]
149 : Vec3               FieldSamplers[].NoiseFieldSampler.noiseSpacePeriod                                      RefVariant[NoiseFSAssetParams]
150 : F32                FieldSamplers[].NoiseFieldSampler.noiseTimePeriod                                       RefVariant[NoiseFSAssetParams]
151 : U32                FieldSamplers[].NoiseFieldSampler.noiseOctaves                                          RefVariant[NoiseFSAssetParams]
152 : F32                FieldSamplers[].NoiseFieldSampler.noiseStrengthOctaveMultiplier                         RefVariant[NoiseFSAssetParams]
153 : Vec3               FieldSamplers[].NoiseFieldSampler.noiseSpacePeriodOctaveMultiplier                      RefVariant[NoiseFSAssetParams]
154 : F32                FieldSamplers[].NoiseFieldSampler.noiseTimePeriodOctaveMultiplier                       RefVariant[NoiseFSAssetParams]
155 : String             FieldSamplers[].NoiseFieldSampler.fieldBoundaryFilterDataName                           RefVariant[NoiseFSAssetParams]
156 : String             FieldSamplers[].NoiseFieldSampler.fieldSamplerFilterDataName                            RefVariant[NoiseFSAssetParams]
157 : Bool               FieldSamplers[].NoiseFieldSampler.useLocalSpace                                         RefVariant[NoiseFSAssetParams]
158 : String             FieldSamplers[].Name                                                                    RefVariant[SubstanceSourceData]
159 : Vec3               FieldSamplers[].SubstanceSource.position                                                RefVariant[SubstanceSourceAssetParams]
160 : F32                FieldSamplers[].SubstanceSource.averageDensity                                          RefVariant[SubstanceSourceAssetParams]
161 : F32                FieldSamplers[].SubstanceSource.stdDensity                                              RefVariant[SubstanceSourceAssetParams]
162 : Vec3               FieldSamplers[].SubstanceSource.geometryType.extents                                    RefVariant[HeatSourceGeomBoxParams]
163 : F32                FieldSamplers[].SubstanceSource.geometryType.radius                                     RefVariant[HeatSourceGeomSphereParams]
164 : String             FieldSamplers[].SubstanceSource.fieldSamplerFilterDataName                              RefVariant[SubstanceSourceAssetParams]
165 : String             FieldSamplers[].Name                                                                    RefVariant[WindFieldSamplerData]
166 : Vec3               FieldSamplers[].WindFieldSampler.fieldDirection                                         RefVariant[WindFSAssetParams]
167 : F32                FieldSamplers[].WindFieldSampler.fieldDirectionDeviationAngle                           RefVariant[WindFSAssetParams]
168 : F32                FieldSamplers[].WindFieldSampler.fieldDirectionOscillationPeriod                        RefVariant[WindFSAssetParams]
169 : F32                FieldSamplers[].WindFieldSampler.fieldStrength                                          RefVariant[WindFSAssetParams]
170 : F32                FieldSamplers[].WindFieldSampler.fieldStrengthDeviationPercentage                       RefVariant[WindFSAssetParams]
171 : F32                FieldSamplers[].WindFieldSampler.fieldStrengthOscillationPeriod                         RefVariant[WindFSAssetParams]
172 : F32                FieldSamplers[].WindFieldSampler.fieldDragCoeff                                         RefVariant[WindFSAssetParams]
173 : F32                FieldSamplers[].WindFieldSampler.fieldWeight                                            RefVariant[WindFSAssetParams]
174 : String             FieldSamplers[].WindFieldSampler.fieldBoundaryFilterDataName                            RefVariant[WindFSAssetParams]
175 : String             FieldSamplers[].WindFieldSampler.fieldSamplerFilterDataName                             RefVariant[WindFSAssetParams]
176 : String             FieldSamplers[].Name                                                                    RefVariant[VelocitySourceData]
177 : F32                FieldSamplers[].VelocitySource.averageVelocity                                          RefVariant[VelocitySourceAssetParams]
178 : F32                FieldSamplers[].VelocitySource.stdVelocity                                              RefVariant[VelocitySourceAssetParams]
179 : Vec3               FieldSamplers[].VelocitySource.geometryType.extents                                     RefVariant[HeatSourceGeomBoxParams]
180 : F32                FieldSamplers[].VelocitySource.geometryType.radius                                      RefVariant[HeatSourceGeomSphereParams]
181 : String             FieldSamplers[].VelocitySource.fieldSamplerFilterDataName                               RefVariant[VelocitySourceAssetParams]

Member Data Documentation

FieldSamplers EffectPackageFieldSamplerDatabaseParams::FieldSamplers[]
The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EffectPackageFieldSamplerDatabaseParams Member List
This is the complete list of members for EffectPackageFieldSamplerDatabaseParams, including all inherited members.
FieldSamplers[] EffectPackageFieldSamplerDatabaseParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EffectPackageGraphicsMaterialsParams Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
EffectPackageGraphicsMaterialsParams Struct Reference

Describes the NxParameterized::Interface for 'EffectPackageGraphicsMaterialsParams' : The collection of graphics and volumetric material assets. More...

#include <params.h>

List of all members.

Classes

union GraphicsMaterials

Public Attributes

GraphicsMaterials GraphicsMaterials[]

Detailed Description

Describes the NxParameterized::Interface for 'EffectPackageGraphicsMaterialsParams' : The collection of graphics and volumetric material assets.

EffectPackageGraphicsMaterialsParams contains 53 fully qualified names
---------------------------------------------
  1 : ArraySizeName    GraphicsMaterials
  2 : String           GraphicsMaterials[].Name                      RefVariant[GraphicsMaterialData]
  3 : String           GraphicsMaterials[].ApplicationMaterialName   RefVariant[GraphicsMaterialData]
  4 : String           GraphicsMaterials[].UserProperties            RefVariant[GraphicsMaterialData]
  5 : RenderTechnique  GraphicsMaterials[].RenderTechnique           RefVariant[GraphicsMaterialData]
  6 : String           GraphicsMaterials[].DiffuseTexture            RefVariant[GraphicsMaterialData]
  7 : U32              GraphicsMaterials[].CellColumn                RefVariant[GraphicsMaterialData]
  8 : U32              GraphicsMaterials[].CellRow                   RefVariant[GraphicsMaterialData]
  9 : U32              GraphicsMaterials[].CellCount                 RefVariant[GraphicsMaterialData]
 10 : Bool             GraphicsMaterials[].CrossBlend                RefVariant[GraphicsMaterialData]
 11 : F32              GraphicsMaterials[].ColorMultiplier           RefVariant[GraphicsMaterialData]
 12 : Bool             GraphicsMaterials[].UsePSM                    RefVariant[GraphicsMaterialData]
 13 : Resolution       GraphicsMaterials[].Resolution                RefVariant[GraphicsMaterialData]
 14 : U32              GraphicsMaterials[].FullResPercent            RefVariant[GraphicsMaterialData]
 15 : U32              GraphicsMaterials[].HalfResPercent            RefVariant[GraphicsMaterialData]
 16 : F32              GraphicsMaterials[].PSM_ShadowBias            RefVariant[GraphicsMaterialData]
 17 : Bool             GraphicsMaterials[].PSM_Frustum.ShowFrustum   RefVariant[GraphicsMaterialData]
 18 : F32              GraphicsMaterials[].PSM_Frustum.FrustumDepth  RefVariant[GraphicsMaterialData]
 19 : F32              GraphicsMaterials[].PSM_Frustum.FrustumSize   RefVariant[GraphicsMaterialData]
 20 : String           GraphicsMaterials[].Name                      RefVariant[VolumeRenderMaterialData]
 21 : String           GraphicsMaterials[].ApplicationMaterialName   RefVariant[VolumeRenderMaterialData]
 22 : String           GraphicsMaterials[].UserProperties            RefVariant[VolumeRenderMaterialData]
 23 : RenderMode       GraphicsMaterials[].RenderMode                RefVariant[VolumeRenderMaterialData]
 24 : RenderMethod     GraphicsMaterials[].RenderMethod              RefVariant[VolumeRenderMaterialData]
 25 : ResolutionScale  GraphicsMaterials[].ResolutionScale           RefVariant[VolumeRenderMaterialData]
 26 : FillMode         GraphicsMaterials[].FillMode                  RefVariant[VolumeRenderMaterialData]
 27 : Bool             GraphicsMaterials[].GenerateShadows           RefVariant[VolumeRenderMaterialData]
 28 : Bool             GraphicsMaterials[].BlurShadows               RefVariant[VolumeRenderMaterialData]
 29 : Bool             GraphicsMaterials[].GenerateMipmaps           RefVariant[VolumeRenderMaterialData]
 30 : Bool             GraphicsMaterials[].EnableStencilOpt          RefVariant[VolumeRenderMaterialData]
 31 : F32              GraphicsMaterials[].StepScale                 RefVariant[VolumeRenderMaterialData]
 32 : F32              GraphicsMaterials[].Density                   RefVariant[VolumeRenderMaterialData]
 33 : F32              GraphicsMaterials[].EdgeFade                  RefVariant[VolumeRenderMaterialData]
 34 : F32              GraphicsMaterials[].OpacityThreshold          RefVariant[VolumeRenderMaterialData]
 35 : F32              GraphicsMaterials[].RayJitter                 RefVariant[VolumeRenderMaterialData]
 36 : F32              GraphicsMaterials[].IsoValue                  RefVariant[VolumeRenderMaterialData]
 37 : F32              GraphicsMaterials[].IsoValueSign              RefVariant[VolumeRenderMaterialData]
 38 : U32              GraphicsMaterials[].ShadowSamples             RefVariant[VolumeRenderMaterialData]
 39 : F32              GraphicsMaterials[].ShadowDistance            RefVariant[VolumeRenderMaterialData]
 40 : F32              GraphicsMaterials[].ShadowDensity             RefVariant[VolumeRenderMaterialData]
 41 : F32              GraphicsMaterials[].ShadowJitter              RefVariant[VolumeRenderMaterialData]
 42 : F32              GraphicsMaterials[].ShadowAmount              RefVariant[VolumeRenderMaterialData]
 43 : Vec3             GraphicsMaterials[].LightDir                  RefVariant[VolumeRenderMaterialData]
 44 : Vec4             GraphicsMaterials[].LightColor                RefVariant[VolumeRenderMaterialData]
 45 : F32              GraphicsMaterials[].BlockEmptyThreshold       RefVariant[VolumeRenderMaterialData]
 46 : Bool             GraphicsMaterials[].ReadDepth                 RefVariant[VolumeRenderMaterialData]
 47 : F32              GraphicsMaterials[].ColorMapScale             RefVariant[VolumeRenderMaterialData]
 48 : F32              GraphicsMaterials[].ColorMapOffset            RefVariant[VolumeRenderMaterialData]
 49 : ArraySizeName    GraphicsMaterials[].ColorMap                  RefVariant[VolumeRenderMaterialData]
 50 : F32              GraphicsMaterials[].ColorMap[].density        RefVariant[VolumeRenderMaterialData]
 51 : Vec4             GraphicsMaterials[].ColorMap[].color          RefVariant[VolumeRenderMaterialData]
 52 : F32              GraphicsMaterials[].TextureRangeMin           RefVariant[VolumeRenderMaterialData]
 53 : F32              GraphicsMaterials[].TextureRangeMax           RefVariant[VolumeRenderMaterialData]

Member Data Documentation

GraphicsMaterials EffectPackageGraphicsMaterialsParams::GraphicsMaterials[]
The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EffectPackageGraphicsMaterialsParams Member List
This is the complete list of members for EffectPackageGraphicsMaterialsParams, including all inherited members.
GraphicsMaterials[] EffectPackageGraphicsMaterialsParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EffectPackageIOFXDatabaseParams Struct Reference

  • Class List
  • Class Members
Public Attributes
EffectPackageIOFXDatabaseParams Struct Reference

Describes the NxParameterized::Interface for 'EffectPackageIOFXDatabaseParams' : The collection of graphics effect assets (IOFX) More...

#include <params.h>

List of all members.

Public Attributes

GraphicsEffectData GraphicsEffects[]
'GraphicsEffects[]' :

Detailed Description

Describes the NxParameterized::Interface for 'EffectPackageIOFXDatabaseParams' : The collection of graphics effect assets (IOFX)

EffectPackageIOFXDatabaseParams contains 149 fully qualified names
---------------------------------------------
  1 : ArraySizeName  GraphicsEffects
  2 : String         GraphicsEffects[].Name                                                                   RefVariant[GraphicsEffectData]
  3 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.renderMeshList                                           RefVariant[MeshIofxParameters]
  4 : Ref            GraphicsEffects[].IOFX.iofxType.renderMeshList[].meshAssetName                           RefVariant[MeshIofxParameters]
  5 : U32            GraphicsEffects[].IOFX.iofxType.renderMeshList[].weight                                  RefVariant[MeshIofxParameters]
  6 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.spawnModifierList                                        RefVariant[MeshIofxParameters]
  7 : RollType       GraphicsEffects[].IOFX.iofxType.spawnModifierList[].rollType                             RefVariant[RotationModifierParams]
  8 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].maxRotationRatePerSec                RefVariant[RotationModifierParams]
  9 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].maxSettleRatePerSec                  RefVariant[RotationModifierParams]
 10 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].inAirRotationMultiplier              RefVariant[RotationModifierParams]
 11 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].collisionRotationMultiplier          RefVariant[RotationModifierParams]
 12 : Bool           GraphicsEffects[].IOFX.iofxType.spawnModifierList[].includeVerticalDirection             RefVariant[RotationModifierParams]
 13 : Vec3           GraphicsEffects[].IOFX.iofxType.spawnModifierList[].scaleFactor                          RefVariant[SimpleScaleModifierParams]
 14 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].minScaleFactor                       RefVariant[RandomScaleModifierParams]
 15 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].maxScaleFactor                       RefVariant[RandomScaleModifierParams]
 16 : Vec4           GraphicsEffects[].IOFX.iofxType.spawnModifierList[].color                                RefVariant[InitialColorModifierParams]
 17 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList                                   RefVariant[MeshIofxParameters]
 18 : RollType       GraphicsEffects[].IOFX.iofxType.continuousModifierList[].rollType                        RefVariant[RotationModifierParams]
 19 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].maxRotationRatePerSec           RefVariant[RotationModifierParams]
 20 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].maxSettleRatePerSec             RefVariant[RotationModifierParams]
 21 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].inAirRotationMultiplier         RefVariant[RotationModifierParams]
 22 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].collisionRotationMultiplier     RefVariant[RotationModifierParams]
 23 : Bool           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].includeVerticalDirection        RefVariant[RotationModifierParams]
 24 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsLife3DModifierParams]
 25 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ScaleVsLife3DModifierParams]
 26 : Vec3           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsLife3DModifierParams]
 27 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensity3DModifierParams]
 28 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].density         RefVariant[ScaleVsDensity3DModifierParams]
 29 : Vec3           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsDensity3DModifierParams]
 30 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperature3DModifierParams]
 31 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].temperature     RefVariant[ScaleVsTemperature3DModifierParams]
 32 : Vec3           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsTemperature3DModifierParams]
 33 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistance3DModifierParams]
 34 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].cameraDistance  RefVariant[ScaleVsCameraDistance3DModifierParams]
 35 : Vec3           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsCameraDistance3DModifierParams]
 36 : Vec3           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].modelForward                    RefVariant[OrientAlongVelocityModifierParams]
 37 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].scaleFactor                     RefVariant[ScaleAlongVelocityModifierParams]
 38 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsLifeCompositeModifierParams]
 39 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ColorVsLifeCompositeModifierParams]
 40 : Vec4           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsLifeCompositeModifierParams]
 41 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsDensityCompositeModifierParams]
 42 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].density         RefVariant[ColorVsDensityCompositeModifierParams]
 43 : Vec4           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsDensityCompositeModifierParams]
 44 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsTemperatureCompositeModifierParams]
 45 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].temperature     RefVariant[ColorVsTemperatureCompositeModifierParams]
 46 : Vec4           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsTemperatureCompositeModifierParams]
 47 : ScaleAxis      GraphicsEffects[].IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsLifeModifierParams]
 48 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsLifeModifierParams]
 49 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsLifeModifierParams]
 50 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsLifeModifierParams]
 51 : ScaleAxis      GraphicsEffects[].IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsDensityModifierParams]
 52 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensityModifierParams]
 53 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsDensityModifierParams]
 54 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsDensityModifierParams]
 55 : ScaleAxis      GraphicsEffects[].IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsTemperatureModifierParams]
 56 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperatureModifierParams]
 57 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsTemperatureModifierParams]
 58 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsTemperatureModifierParams]
 59 : ScaleAxis      GraphicsEffects[].IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsCameraDistanceModifierParams]
 60 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistanceModifierParams]
 61 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsCameraDistanceModifierParams]
 62 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsCameraDistanceModifierParams]
 63 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].velocity0                       RefVariant[ColorVsVelocityCompositeModifierParams]
 64 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].velocity1                       RefVariant[ColorVsVelocityCompositeModifierParams]
 65 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsVelocityCompositeModifierParams]
 66 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].velocity        RefVariant[ColorVsVelocityCompositeModifierParams]
 67 : Vec4           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsVelocityCompositeModifierParams]
 68 : Ref            GraphicsEffects[].IOFX.iofxType.spriteMaterialName                                       RefVariant[SpriteIofxParameters]
 69 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.spawnModifierList                                        RefVariant[SpriteIofxParameters]
 70 : Vec3           GraphicsEffects[].IOFX.iofxType.spawnModifierList[].scaleFactor                          RefVariant[SimpleScaleModifierParams]
 71 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].minScaleFactor                       RefVariant[RandomScaleModifierParams]
 72 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].maxScaleFactor                       RefVariant[RandomScaleModifierParams]
 73 : Vec4           GraphicsEffects[].IOFX.iofxType.spawnModifierList[].color                                RefVariant[InitialColorModifierParams]
 74 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].minSubtexture                        RefVariant[RandomSubtextureModifierParams]
 75 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].maxSubtexture                        RefVariant[RandomSubtextureModifierParams]
 76 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].minRotation                          RefVariant[RandomRotationModifierParams]
 77 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].maxRotation                          RefVariant[RandomRotationModifierParams]
 78 : ColorChannel   GraphicsEffects[].IOFX.iofxType.spawnModifierList[].colorChannel                         RefVariant[ColorVsLifeModifierParams]
 79 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.spawnModifierList[].controlPoints                        RefVariant[ColorVsLifeModifierParams]
 80 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].controlPoints[].x                    RefVariant[ColorVsLifeModifierParams]
 81 : F32            GraphicsEffects[].IOFX.iofxType.spawnModifierList[].controlPoints[].y                    RefVariant[ColorVsLifeModifierParams]
 82 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList                                   RefVariant[SpriteIofxParameters]
 83 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsLifeCompositeModifierParams]
 84 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ColorVsLifeCompositeModifierParams]
 85 : Vec4           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsLifeCompositeModifierParams]
 86 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsDensityCompositeModifierParams]
 87 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].density         RefVariant[ColorVsDensityCompositeModifierParams]
 88 : Vec4           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsDensityCompositeModifierParams]
 89 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsTemperatureCompositeModifierParams]
 90 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].temperature     RefVariant[ColorVsTemperatureCompositeModifierParams]
 91 : Vec4           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsTemperatureCompositeModifierParams]
 92 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsLife2DModifierParams]
 93 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ScaleVsLife2DModifierParams]
 94 : Vec2           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsLife2DModifierParams]
 95 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensity2DModifierParams]
 96 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].density         RefVariant[ScaleVsDensity2DModifierParams]
 97 : Vec2           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsDensity2DModifierParams]
 98 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperature2DModifierParams]
 99 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].temperature     RefVariant[ScaleVsTemperature2DModifierParams]
100 : Vec2           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsTemperature2DModifierParams]
101 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistance2DModifierParams]
102 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].cameraDistance  RefVariant[ScaleVsCameraDistance2DModifierParams]
103 : Vec2           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsCameraDistance2DModifierParams]
104 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[SubtextureVsLifeModifierParams]
105 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[SubtextureVsLifeModifierParams]
106 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[SubtextureVsLifeModifierParams]
107 : SortType       GraphicsEffects[].IOFX.iofxType.continuousModifierList[].sortType                        RefVariant[ViewDirectionSortingModifierParams]
108 : ColorChannel   GraphicsEffects[].IOFX.iofxType.continuousModifierList[].colorChannel                    RefVariant[ColorVsLifeModifierParams]
109 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsLifeModifierParams]
110 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ColorVsLifeModifierParams]
111 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ColorVsLifeModifierParams]
112 : ColorChannel   GraphicsEffects[].IOFX.iofxType.continuousModifierList[].colorChannel                    RefVariant[ColorVsDensityModifierParams]
113 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsDensityModifierParams]
114 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ColorVsDensityModifierParams]
115 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ColorVsDensityModifierParams]
116 : ColorChannel   GraphicsEffects[].IOFX.iofxType.continuousModifierList[].colorChannel                    RefVariant[ColorVsTemperatureModifierParams]
117 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsTemperatureModifierParams]
118 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ColorVsTemperatureModifierParams]
119 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ColorVsTemperatureModifierParams]
120 : ScaleAxis      GraphicsEffects[].IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsLifeModifierParams]
121 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsLifeModifierParams]
122 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsLifeModifierParams]
123 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsLifeModifierParams]
124 : ScaleAxis      GraphicsEffects[].IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsDensityModifierParams]
125 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensityModifierParams]
126 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsDensityModifierParams]
127 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsDensityModifierParams]
128 : ScaleAxis      GraphicsEffects[].IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsTemperatureModifierParams]
129 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperatureModifierParams]
130 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsTemperatureModifierParams]
131 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsTemperatureModifierParams]
132 : ScaleAxis      GraphicsEffects[].IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsCameraDistanceModifierParams]
133 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistanceModifierParams]
134 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsCameraDistanceModifierParams]
135 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsCameraDistanceModifierParams]
136 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].rotationRate                    RefVariant[RotationRateModifierParams]
137 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[RotationRateVsLifeModifierParams]
138 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[RotationRateVsLifeModifierParams]
139 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[RotationRateVsLifeModifierParams]
140 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].scalePerVelocity                RefVariant[OrientScaleAlongScreenVelocityModifierParams]
141 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].scaleChangeLimit                RefVariant[OrientScaleAlongScreenVelocityModifierParams]
142 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].scaleChangeDelay                RefVariant[OrientScaleAlongScreenVelocityModifierParams]
143 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].velocity0                       RefVariant[ColorVsVelocityCompositeModifierParams]
144 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].velocity1                       RefVariant[ColorVsVelocityCompositeModifierParams]
145 : ArraySizeName  GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsVelocityCompositeModifierParams]
146 : F32            GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].velocity        RefVariant[ColorVsVelocityCompositeModifierParams]
147 : Vec4           GraphicsEffects[].IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsVelocityCompositeModifierParams]
148 : Bool           GraphicsEffects[].IOFX.renderOutput.useUserSemantic                                      RefVariant[IofxAssetParameters]
149 : Bool           GraphicsEffects[].IOFX.renderOutput.useFloat4Color                                       RefVariant[IofxAssetParameters]

Member Data Documentation

GraphicsEffectData EffectPackageIOFXDatabaseParams::GraphicsEffects[]

'GraphicsEffects[]' :

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EffectPackageIOFXDatabaseParams Member List
This is the complete list of members for EffectPackageIOFXDatabaseParams, including all inherited members.
GraphicsEffects[] EffectPackageIOFXDatabaseParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EffectPackageIOSDatabaseParams Struct Reference

  • Class List
  • Class Members
Public Attributes
EffectPackageIOSDatabaseParams Struct Reference

Describes the NxParameterized::Interface for 'EffectPackageIOSDatabaseParams' : The collection of particle simulation assets (IOS) More...

#include <params.h>

List of all members.

Public Attributes

ParticleSimulationData ParticleSimulations[]
'ParticleSimulations[]' :

Detailed Description

Describes the NxParameterized::Interface for 'EffectPackageIOSDatabaseParams' : The collection of particle simulation assets (IOS)

EffectPackageIOSDatabaseParams contains 59 fully qualified names
---------------------------------------------
  1 : ArraySizeName  ParticleSimulations
  2 : String         ParticleSimulations[].Name                                       RefVariant[ParticleSimulationData]
  3 : F32            ParticleSimulations[].IOS.restDensity                            RefVariant[BasicIOSAssetParam]
  4 : F32            ParticleSimulations[].IOS.particleRadius                         RefVariant[BasicIOSAssetParam]
  5 : U32            ParticleSimulations[].IOS.maxParticleCount                       RefVariant[BasicIOSAssetParam]
  6 : F32            ParticleSimulations[].IOS.maxInjectedParticleCount               RefVariant[BasicIOSAssetParam]
  7 : U32            ParticleSimulations[].IOS.maxCollidingObjects                    RefVariant[BasicIOSAssetParam]
  8 : F32            ParticleSimulations[].IOS.sceneGravityScale                      RefVariant[BasicIOSAssetParam]
  9 : Vec3           ParticleSimulations[].IOS.externalAcceleration                   RefVariant[BasicIOSAssetParam]
 10 : F32            ParticleSimulations[].IOS.particleMass.center                    RefVariant[BasicIOSAssetParam]
 11 : F32            ParticleSimulations[].IOS.particleMass.spread                    RefVariant[BasicIOSAssetParam]
 12 : Type           ParticleSimulations[].IOS.particleMass.type                      RefVariant[BasicIOSAssetParam]
 13 : String         ParticleSimulations[].IOS.collisionFilterDataName                RefVariant[BasicIOSAssetParam]
 14 : String         ParticleSimulations[].IOS.fieldSamplerFilterDataName             RefVariant[BasicIOSAssetParam]
 15 : Bool           ParticleSimulations[].IOS.staticCollision                        RefVariant[BasicIOSAssetParam]
 16 : F32            ParticleSimulations[].IOS.restitutionForStaticShapes             RefVariant[BasicIOSAssetParam]
 17 : Bool           ParticleSimulations[].IOS.dynamicCollision                       RefVariant[BasicIOSAssetParam]
 18 : F32            ParticleSimulations[].IOS.restitutionForDynamicShapes            RefVariant[BasicIOSAssetParam]
 19 : F32            ParticleSimulations[].IOS.collisionDistanceMultiplier            RefVariant[BasicIOSAssetParam]
 20 : F32            ParticleSimulations[].IOS.collisionThreshold                     RefVariant[BasicIOSAssetParam]
 21 : Bool           ParticleSimulations[].IOS.collisionWithConvex                    RefVariant[BasicIOSAssetParam]
 22 : Bool           ParticleSimulations[].IOS.collisionWithTriangleMesh              RefVariant[BasicIOSAssetParam]
 23 : Bool           ParticleSimulations[].IOS.GridDensity.Enabled                    RefVariant[BasicIOSAssetParam]
 24 : Resolution     ParticleSimulations[].IOS.GridDensity.Resolution                 RefVariant[BasicIOSAssetParam]
 25 : F32            ParticleSimulations[].IOS.GridDensity.GridSize                   RefVariant[BasicIOSAssetParam]
 26 : U32            ParticleSimulations[].IOS.GridDensity.MaxCellCount               RefVariant[BasicIOSAssetParam]
 27 : Bool           ParticleSimulations[].IOS.enableTemperatureBuffer                RefVariant[BasicIOSAssetParam]
 28 : Bool           ParticleSimulations[].IOS.particleType.GridDensity.Enabled       RefVariant[SimpleParticleSystemParams]
 29 : Resolution     ParticleSimulations[].IOS.particleType.GridDensity.Resolution    RefVariant[SimpleParticleSystemParams]
 30 : F32            ParticleSimulations[].IOS.particleType.GridDensity.GridSize      RefVariant[SimpleParticleSystemParams]
 31 : U32            ParticleSimulations[].IOS.particleType.GridDensity.MaxCellCount  RefVariant[SimpleParticleSystemParams]
 32 : F32            ParticleSimulations[].IOS.particleType.restParticleDistance      RefVariant[FluidParticleSystemParams]
 33 : F32            ParticleSimulations[].IOS.particleType.stiffness                 RefVariant[FluidParticleSystemParams]
 34 : F32            ParticleSimulations[].IOS.particleType.viscosity                 RefVariant[FluidParticleSystemParams]
 35 : U32            ParticleSimulations[].IOS.maxParticleCount                       RefVariant[ParticleIosAssetParam]
 36 : F32            ParticleSimulations[].IOS.particleRadius                         RefVariant[ParticleIosAssetParam]
 37 : F32            ParticleSimulations[].IOS.maxInjectedParticleCount               RefVariant[ParticleIosAssetParam]
 38 : F32            ParticleSimulations[].IOS.maxMotionDistance                      RefVariant[ParticleIosAssetParam]
 39 : F32            ParticleSimulations[].IOS.contactOffset                          RefVariant[ParticleIosAssetParam]
 40 : F32            ParticleSimulations[].IOS.restOffset                             RefVariant[ParticleIosAssetParam]
 41 : F32            ParticleSimulations[].IOS.gridSize                               RefVariant[ParticleIosAssetParam]
 42 : F32            ParticleSimulations[].IOS.damping                                RefVariant[ParticleIosAssetParam]
 43 : Vec3           ParticleSimulations[].IOS.externalAcceleration                   RefVariant[ParticleIosAssetParam]
 44 : Vec3           ParticleSimulations[].IOS.projectionPlaneNormal                  RefVariant[ParticleIosAssetParam]
 45 : F32            ParticleSimulations[].IOS.projectionPlaneDistance                RefVariant[ParticleIosAssetParam]
 46 : F32            ParticleSimulations[].IOS.particleMass                           RefVariant[ParticleIosAssetParam]
 47 : F32            ParticleSimulations[].IOS.restitution                            RefVariant[ParticleIosAssetParam]
 48 : F32            ParticleSimulations[].IOS.dynamicFriction                        RefVariant[ParticleIosAssetParam]
 49 : F32            ParticleSimulations[].IOS.staticFriction                         RefVariant[ParticleIosAssetParam]
 50 : String         ParticleSimulations[].IOS.simulationFilterData                   RefVariant[ParticleIosAssetParam]
 51 : String         ParticleSimulations[].IOS.fieldSamplerFilterData                 RefVariant[ParticleIosAssetParam]
 52 : Bool           ParticleSimulations[].IOS.CollisionTwoway                        RefVariant[ParticleIosAssetParam]
 53 : Bool           ParticleSimulations[].IOS.CollisionWithDynamicActors             RefVariant[ParticleIosAssetParam]
 54 : Bool           ParticleSimulations[].IOS.Enable                                 RefVariant[ParticleIosAssetParam]
 55 : Bool           ParticleSimulations[].IOS.ProjectToPlane                         RefVariant[ParticleIosAssetParam]
 56 : Bool           ParticleSimulations[].IOS.PerParticleRestOffset                  RefVariant[ParticleIosAssetParam]
 57 : Bool           ParticleSimulations[].IOS.PerParticleCollisionCacheHint          RefVariant[ParticleIosAssetParam]
 58 : Bool           ParticleSimulations[].IOS.DensityBuffer                          RefVariant[ParticleIosAssetParam]
 59 : Bool           ParticleSimulations[].IOS.enableTemperatureBuffer                RefVariant[ParticleIosAssetParam]

Member Data Documentation

ParticleSimulationData EffectPackageIOSDatabaseParams::ParticleSimulations[]

'ParticleSimulations[]' :

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EffectPackageIOSDatabaseParams Member List
This is the complete list of members for EffectPackageIOSDatabaseParams, including all inherited members.
ParticleSimulations[] EffectPackageIOSDatabaseParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EmitterAssetPreviewParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
EmitterAssetPreviewParameters Struct Reference

Describes the NxParameterized::Interface for 'EmitterAssetPreviewParameters' : This class is used for creating APEX Emitter Preview instances (shaped, ground, or impact emitters) More...

#include <params.h>

List of all members.

Public Attributes

Mat34 | pose
'pose' : The preview actor's position and rotation
F32 | scale
'scale' : The preview actor's scale

Detailed Description

Describes the NxParameterized::Interface for 'EmitterAssetPreviewParameters' : This class is used for creating APEX Emitter Preview instances (shaped, ground, or impact emitters)

EmitterAssetPreviewParameters contains 2 fully qualified names
---------------------------------------------
  1 : Mat34  pose
  2 : F32    scale

Member Data Documentation

Mat34 EmitterAssetPreviewParameters::pose

'pose' : The preview actor's position and rotation

F32 EmitterAssetPreviewParameters::scale

'scale' : The preview actor's scale

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EmitterAssetPreviewParameters Member List
This is the complete list of members for EmitterAssetPreviewParameters, including all inherited members.
pose | EmitterAssetPreviewParameters
scale | EmitterAssetPreviewParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EmitterData Struct Reference

  • Class List
  • Class Members
Public Attributes
EmitterData Struct Reference

Describes the NxParameterized::Interface for 'EmitterData' : Contains the asset properties for this emitter. More...

#include <params.h>

List of all members.

Public Attributes

String Name
'Name' : Emitter name
ApexEmitterAssetParameters Emitter
'Emitter' :

Detailed Description

Describes the NxParameterized::Interface for 'EmitterData' : Contains the asset properties for this emitter.

EmitterData contains 58 fully qualified names
---------------------------------------------
  1 : String         Name
  2 : F32            Emitter.densityRange.min                                      RefVariant[ApexEmitterAssetParameters]
  3 : F32            Emitter.densityRange.max                                      RefVariant[ApexEmitterAssetParameters]
  4 : F32            Emitter.rateRange.min                                         RefVariant[ApexEmitterAssetParameters]
  5 : F32            Emitter.rateRange.max                                         RefVariant[ApexEmitterAssetParameters]
  6 : F32            Emitter.lifetimeRange.min                                     RefVariant[ApexEmitterAssetParameters]
  7 : F32            Emitter.lifetimeRange.max                                     RefVariant[ApexEmitterAssetParameters]
  8 : Vec3           Emitter.velocityRange.min                                     RefVariant[ApexEmitterAssetParameters]
  9 : Vec3           Emitter.velocityRange.max                                     RefVariant[ApexEmitterAssetParameters]
 10 : F32            Emitter.temperatureRange.min                                  RefVariant[ApexEmitterAssetParameters]
 11 : F32            Emitter.temperatureRange.max                                  RefVariant[ApexEmitterAssetParameters]
 12 : U32            Emitter.maxSamples                                            RefVariant[ApexEmitterAssetParameters]
 13 : U32            Emitter.lodParamDesc.version                                  RefVariant[ApexEmitterAssetParameters]
 14 : F32            Emitter.lodParamDesc.maxDistance                              RefVariant[ApexEmitterAssetParameters]
 15 : F32            Emitter.lodParamDesc.distanceWeight                           RefVariant[ApexEmitterAssetParameters]
 16 : F32            Emitter.lodParamDesc.speedWeight                              RefVariant[ApexEmitterAssetParameters]
 17 : F32            Emitter.lodParamDesc.lifeWeight                               RefVariant[ApexEmitterAssetParameters]
 18 : F32            Emitter.lodParamDesc.separationWeight                         RefVariant[ApexEmitterAssetParameters]
 19 : F32            Emitter.lodParamDesc.bias                                     RefVariant[ApexEmitterAssetParameters]
 20 : Ref            Emitter.iofxAssetName                                         RefVariant[ApexEmitterAssetParameters]
 21 : Ref            Emitter.iosAssetName                                          RefVariant[ApexEmitterAssetParameters]
 22 : EmitterType    Emitter.geometryType.emitterType                              RefVariant[EmitterGeomBoxParams]
 23 : Vec3           Emitter.geometryType.extents                                  RefVariant[EmitterGeomBoxParams]
 24 : EmitterType    Emitter.geometryType.emitterType                              RefVariant[EmitterGeomSphereParams]
 25 : F32            Emitter.geometryType.radius                                   RefVariant[EmitterGeomSphereParams]
 26 : F32            Emitter.geometryType.hemisphere                               RefVariant[EmitterGeomSphereParams]
 27 : EmitterType    Emitter.geometryType.emitterType                              RefVariant[EmitterGeomSphereShellParams]
 28 : F32            Emitter.geometryType.radius                                   RefVariant[EmitterGeomSphereShellParams]
 29 : F32            Emitter.geometryType.shellThickness                           RefVariant[EmitterGeomSphereShellParams]
 30 : F32            Emitter.geometryType.hemisphere                               RefVariant[EmitterGeomSphereShellParams]
 31 : EmitterType    Emitter.geometryType.emitterType                              RefVariant[EmitterGeomCylinderParams]
 32 : F32            Emitter.geometryType.radius                                   RefVariant[EmitterGeomCylinderParams]
 33 : F32            Emitter.geometryType.height                                   RefVariant[EmitterGeomCylinderParams]
 34 : F32            Emitter.geometryType.distance                                 RefVariant[EmitterGeomExplicitParams]
 35 : ArraySizeName  Emitter.geometryType.positions                                RefVariant[EmitterGeomExplicitParams]
 36 : Vec3           Emitter.geometryType.points.positions[].position              RefVariant[EmitterGeomExplicitParams]
 37 : Bool           Emitter.geometryType.points.positions[].doDetectOverlaps      RefVariant[EmitterGeomExplicitParams]
 38 : ArraySizeName  Emitter.geometryType.velocities                               RefVariant[EmitterGeomExplicitParams]
 39 : Vec3           Emitter.geometryType.points.velocities[]                      RefVariant[EmitterGeomExplicitParams]
 40 : ArraySizeName  Emitter.geometryType.positions                                RefVariant[EmitterGeomExplicitParams]
 41 : Vec3           Emitter.geometryType.spheres.positions[].center               RefVariant[EmitterGeomExplicitParams]
 42 : F32            Emitter.geometryType.spheres.positions[].radius               RefVariant[EmitterGeomExplicitParams]
 43 : Bool           Emitter.geometryType.spheres.positions[].doDetectOverlaps     RefVariant[EmitterGeomExplicitParams]
 44 : ArraySizeName  Emitter.geometryType.velocities                               RefVariant[EmitterGeomExplicitParams]
 45 : Vec3           Emitter.geometryType.spheres.velocities[]                     RefVariant[EmitterGeomExplicitParams]
 46 : ArraySizeName  Emitter.geometryType.positions                                RefVariant[EmitterGeomExplicitParams]
 47 : Vec3           Emitter.geometryType.ellipsoids.positions[].center            RefVariant[EmitterGeomExplicitParams]
 48 : F32            Emitter.geometryType.ellipsoids.positions[].radius            RefVariant[EmitterGeomExplicitParams]
 49 : Vec3           Emitter.geometryType.ellipsoids.positions[].normal            RefVariant[EmitterGeomExplicitParams]
 50 : F32            Emitter.geometryType.ellipsoids.positions[].polarRadius       RefVariant[EmitterGeomExplicitParams]
 51 : Bool           Emitter.geometryType.ellipsoids.positions[].doDetectOverlaps  RefVariant[EmitterGeomExplicitParams]
 52 : ArraySizeName  Emitter.geometryType.velocities                               RefVariant[EmitterGeomExplicitParams]
 53 : Vec3           Emitter.geometryType.ellipsoids.velocities[]                  RefVariant[EmitterGeomExplicitParams]
 54 : F32            Emitter.emitterDuration                                       RefVariant[ApexEmitterAssetParameters]
 55 : U32            Emitter.minSamplingFPS                                        RefVariant[ApexEmitterAssetParameters]
 56 : ArraySizeName  Emitter.rateVsTimeCurvePoints                                 RefVariant[ApexEmitterAssetParameters]
 57 : F32            Emitter.rateVsTimeCurvePoints[].x                             RefVariant[ApexEmitterAssetParameters]
 58 : F32            Emitter.rateVsTimeCurvePoints[].y                             RefVariant[ApexEmitterAssetParameters]

Member Data Documentation

ApexEmitterAssetParameters EmitterData::Emitter

'Emitter' :

String EmitterData::Name

'Name' : Emitter name

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EmitterData Member List
This is the complete list of members for EmitterData, including all inherited members.
Emitter | EmitterData
Name | EmitterData
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EmitterDebugRenderParams Struct Reference

  • Class List
  • Class Members
Public Attributes
EmitterDebugRenderParams Struct Reference

Describes the NxParameterized::Interface for 'EmitterDebugRenderParams' : This class contains debug rendering parameters for the emitter module. More...

#include <params.h>

List of all members.

Public Attributes

Bool | apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR
'apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR' : Enables/Disables visualization of all emitter actors. This parameter also switches on visualization of emitter's shape (each green grid encompasses emitter).
Bool | apexEmitterParameters.VISUALIZE_TOTAL_INJECTED_AABB
'apexEmitterParameters.VISUALIZE_TOTAL_INJECTED_AABB' : Draws red box which represents AABB boundary. All new particles are injected inside it.
Bool | apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_POSE
'apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_POSE' : For visualizing emitter's position. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.
F32 | apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_POSE
'apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_POSE' : Defines maximum distance, from which actor's position's visualization could be seen.
Bool | apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_NAME
'apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_NAME' : Draws the emitter's asset's name next to the emitter.
F32 | apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_NAME
'apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_NAME' : Defines maximum distance, from which actor name's visualization could be seen.
Bool | groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR
'groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR' : Enables/Disables visualization of all ground emitter actors
Bool | groundEmitterParameters.VISUALIZE_GROUND_EMITTER_SPHERE
'groundEmitterParameters.VISUALIZE_GROUND_EMITTER_SPHERE' : Draws green sphere which bounds ground emitter.
Bool | groundEmitterParameters.VISUALIZE_GROUND_EMITTER_GRID
'groundEmitterParameters.VISUALIZE_GROUND_EMITTER_GRID' : Draws yellow grid which bounds ground emitter.
Bool | groundEmitterParameters.VISUALIZE_GROUND_EMITTER_RAYCAST
'groundEmitterParameters.VISUALIZE_GROUND_EMITTER_RAYCAST' : Draws vertical green lines where new particles are generated.
Bool | groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_POSE
'groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_POSE' : For visualizing emitter's position. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.
Bool | groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_NAME
'groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_NAME' : Draws the emitter's asset's name next to the emitter.
Bool | impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR
'impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR' : Enables/Disables visualization of all impact emitter actors
Bool | impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_RAYCAST
'impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_RAYCAST' : Draws vertical line on the point of impact.
Bool | impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR_NAME
'impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR_NAME' : Draws the emitter's asset's name next to the emitter.
F32 | impactEmitterParameters.THRESHOLD_DISTANCE_IMPACT_EMITTER_ACTOR_NAME
'impactEmitterParameters.THRESHOLD_DISTANCE_IMPACT_EMITTER_ACTOR_NAME' : Defines maximum distance, from which actor's names's visualization could be seen.

Detailed Description

Describes the NxParameterized::Interface for 'EmitterDebugRenderParams' : This class contains debug rendering parameters for the emitter module.

EmitterDebugRenderParams contains 16 fully qualified names
---------------------------------------------
  1 : Bool  apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR
  2 : Bool  apexEmitterParameters.VISUALIZE_TOTAL_INJECTED_AABB
  3 : Bool  apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_POSE
  4 : F32   apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_POSE
  5 : Bool  apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_NAME
  6 : F32   apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_NAME
  7 : Bool  groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR
  8 : Bool  groundEmitterParameters.VISUALIZE_GROUND_EMITTER_SPHERE
  9 : Bool  groundEmitterParameters.VISUALIZE_GROUND_EMITTER_GRID
 10 : Bool  groundEmitterParameters.VISUALIZE_GROUND_EMITTER_RAYCAST
 11 : Bool  groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_POSE
 12 : Bool  groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_NAME
 13 : Bool  impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR
 14 : Bool  impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_RAYCAST
 15 : Bool  impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR_NAME
 16 : F32   impactEmitterParameters.THRESHOLD_DISTANCE_IMPACT_EMITTER_ACTOR_NAME

Member Data Documentation

F32 EmitterDebugRenderParams::apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_NAME

'apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_NAME' : Defines maximum distance, from which actor name's visualization could be seen.

F32 EmitterDebugRenderParams::apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_POSE

'apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_POSE' : Defines maximum distance, from which actor's position's visualization could be seen.

Bool EmitterDebugRenderParams::apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR

'apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR' : Enables/Disables visualization of all emitter actors. This parameter also switches on visualization of emitter's shape (each green grid encompasses emitter).

Bool EmitterDebugRenderParams::apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_NAME

'apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_NAME' : Draws the emitter's asset's name next to the emitter.

Bool EmitterDebugRenderParams::apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_POSE

'apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_POSE' : For visualizing emitter's position. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.

Bool EmitterDebugRenderParams::apexEmitterParameters.VISUALIZE_TOTAL_INJECTED_AABB

'apexEmitterParameters.VISUALIZE_TOTAL_INJECTED_AABB' : Draws red box which represents AABB boundary. All new particles are injected inside it.

Bool EmitterDebugRenderParams::groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR

'groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR' : Enables/Disables visualization of all ground emitter actors

Bool EmitterDebugRenderParams::groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_NAME

'groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_NAME' : Draws the emitter's asset's name next to the emitter.

Bool EmitterDebugRenderParams::groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_POSE

'groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_POSE' : For visualizing emitter's position. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.

Bool EmitterDebugRenderParams::groundEmitterParameters.VISUALIZE_GROUND_EMITTER_GRID

'groundEmitterParameters.VISUALIZE_GROUND_EMITTER_GRID' : Draws yellow grid which bounds ground emitter.

Bool EmitterDebugRenderParams::groundEmitterParameters.VISUALIZE_GROUND_EMITTER_RAYCAST

'groundEmitterParameters.VISUALIZE_GROUND_EMITTER_RAYCAST' : Draws vertical green lines where new particles are generated.

Bool EmitterDebugRenderParams::groundEmitterParameters.VISUALIZE_GROUND_EMITTER_SPHERE

'groundEmitterParameters.VISUALIZE_GROUND_EMITTER_SPHERE' : Draws green sphere which bounds ground emitter.

F32 EmitterDebugRenderParams::impactEmitterParameters.THRESHOLD_DISTANCE_IMPACT_EMITTER_ACTOR_NAME

'impactEmitterParameters.THRESHOLD_DISTANCE_IMPACT_EMITTER_ACTOR_NAME' : Defines maximum distance, from which actor's names's visualization could be seen.

Bool EmitterDebugRenderParams::impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR

'impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR' : Enables/Disables visualization of all impact emitter actors

Bool EmitterDebugRenderParams::impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR_NAME

'impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR_NAME' : Draws the emitter's asset's name next to the emitter.

Bool EmitterDebugRenderParams::impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_RAYCAST

'impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_RAYCAST' : Draws vertical line on the point of impact.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EmitterDebugRenderParams Member List
This is the complete list of members for EmitterDebugRenderParams, including all inherited members.
apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_NAME | EmitterDebugRenderParams
apexEmitterParameters.THRESHOLD_DISTANCE_APEX_EMITTER_ACTOR_POSE | EmitterDebugRenderParams
apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR | EmitterDebugRenderParams
apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_NAME | EmitterDebugRenderParams
apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR_POSE | EmitterDebugRenderParams
apexEmitterParameters.VISUALIZE_TOTAL_INJECTED_AABB | EmitterDebugRenderParams
groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR | EmitterDebugRenderParams
groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_NAME | EmitterDebugRenderParams
groundEmitterParameters.VISUALIZE_GROUND_EMITTER_ACTOR_POSE | EmitterDebugRenderParams
groundEmitterParameters.VISUALIZE_GROUND_EMITTER_GRID | EmitterDebugRenderParams
groundEmitterParameters.VISUALIZE_GROUND_EMITTER_RAYCAST | EmitterDebugRenderParams
groundEmitterParameters.VISUALIZE_GROUND_EMITTER_SPHERE | EmitterDebugRenderParams
impactEmitterParameters.THRESHOLD_DISTANCE_IMPACT_EMITTER_ACTOR_NAME | EmitterDebugRenderParams
impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR | EmitterDebugRenderParams
impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_ACTOR_NAME | EmitterDebugRenderParams
impactEmitterParameters.VISUALIZE_IMPACT_EMITTER_RAYCAST | EmitterDebugRenderParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EmitterEffect Struct Reference

  • Class List
  • Class Members
Public Attributes
EmitterEffect Struct Reference

Describes the NxParameterized::Interface for 'EmitterEffect' : An emitter effect. More...

#include <params.h>

List of all members.

Public Attributes

String | EffectProperties.UserString
'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer
Bool | EffectProperties.Enable
'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup
F32 | EffectProperties.Position.TranslateX
'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateY
'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateZ
'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Orientation.RotateX
'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateY
'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateZ
'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)
F32 | EffectProperties.InitialDelayTime
'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect
F32 | EffectProperties.Duration
'EffectProperties.Duration' : The duration of the effect in secontds
U32 | EffectProperties.RepeatCount
'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever
F32 | EffectProperties.RepeatDelay
'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time
F32 | EffectProperties.RandomizeRepeatTime
'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.
PlaybackMode EffectProperties.Path.PlaybackMode
'EffectProperties.Path.PlaybackMode' : The mode to play back the path
F32 | EffectProperties.Path.PathDuration
'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided
U32 | EffectProperties.Path.LoopIndex
'EffectProperties.Path.LoopIndex' : The array index to loop back to
Transform | EffectProperties.Path.ControlPoints[]
'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to
F32 | EffectProperties.Path.Scale[].x
'EffectProperties.Path.Scale[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Scale[].y
'EffectProperties.Path.Scale[].y' : The y-axis value for this vector
F32 | EffectProperties.Path.Speed[].x
'EffectProperties.Path.Speed[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Speed[].y
'EffectProperties.Path.Speed[].y' : The y-axis value for this vector
Bool | EmitterVelocityChanges.AdjustLifetime.AdjustEnabled
'EmitterVelocityChanges.AdjustLifetime.AdjustEnabled' : True if adjusting emitter properties based on velocity
F32 | EmitterVelocityChanges.AdjustLifetime.VelocityLow
'EmitterVelocityChanges.AdjustLifetime.VelocityLow' : Low velocity range to match the low
F32 | EmitterVelocityChanges.AdjustLifetime.VelocityHigh
'EmitterVelocityChanges.AdjustLifetime.VelocityHigh' : High velocity range to match the high value
F32 | EmitterVelocityChanges.AdjustLifetime.LowValue
'EmitterVelocityChanges.AdjustLifetime.LowValue' : The multiplier when the velocity equals VelocityLow
F32 | EmitterVelocityChanges.AdjustLifetime.HighValue
'EmitterVelocityChanges.AdjustLifetime.HighValue' : The multiplier when the velocity equals VelocityHigh
Bool | EmitterVelocityChanges.AdjustEmitterRate.AdjustEnabled
'EmitterVelocityChanges.AdjustEmitterRate.AdjustEnabled' : True if adjusting emitter properties based on velocity
F32 | EmitterVelocityChanges.AdjustEmitterRate.VelocityLow
'EmitterVelocityChanges.AdjustEmitterRate.VelocityLow' : Low velocity range to match the low
F32 | EmitterVelocityChanges.AdjustEmitterRate.VelocityHigh
'EmitterVelocityChanges.AdjustEmitterRate.VelocityHigh' : High velocity range to match the high value
F32 | EmitterVelocityChanges.AdjustEmitterRate.LowValue
'EmitterVelocityChanges.AdjustEmitterRate.LowValue' : The multiplier when the velocity equals VelocityLow
F32 | EmitterVelocityChanges.AdjustEmitterRate.HighValue
'EmitterVelocityChanges.AdjustEmitterRate.HighValue' : The multiplier when the velocity equals VelocityHigh
Ref | Emitter
'Emitter' : Emitter Asset

Detailed Description

Describes the NxParameterized::Interface for 'EmitterEffect' : An emitter effect.

EmitterEffect contains 35 fully qualified names
---------------------------------------------
  1 : String         EffectProperties.UserString
  2 : Bool           EffectProperties.Enable
  3 : F32            EffectProperties.Position.TranslateX
  4 : F32            EffectProperties.Position.TranslateY
  5 : F32            EffectProperties.Position.TranslateZ
  6 : F32            EffectProperties.Orientation.RotateX
  7 : F32            EffectProperties.Orientation.RotateY
  8 : F32            EffectProperties.Orientation.RotateZ
  9 : F32            EffectProperties.InitialDelayTime
 10 : F32            EffectProperties.Duration
 11 : U32            EffectProperties.RepeatCount
 12 : F32            EffectProperties.RepeatDelay
 13 : F32            EffectProperties.RandomizeRepeatTime
 14 : PlaybackMode   EffectProperties.Path.PlaybackMode
 15 : F32            EffectProperties.Path.PathDuration
 16 : U32            EffectProperties.Path.LoopIndex
 17 : ArraySizeName  ControlPoints
 18 : Transform      EffectProperties.Path.ControlPoints[]
 19 : ArraySizeName  Scale
 20 : F32            EffectProperties.Path.Scale[].x
 21 : F32            EffectProperties.Path.Scale[].y
 22 : ArraySizeName  Speed
 23 : F32            EffectProperties.Path.Speed[].x
 24 : F32            EffectProperties.Path.Speed[].y
 25 : Bool           EmitterVelocityChanges.AdjustLifetime.AdjustEnabled
 26 : F32            EmitterVelocityChanges.AdjustLifetime.VelocityLow
 27 : F32            EmitterVelocityChanges.AdjustLifetime.VelocityHigh
 28 : F32            EmitterVelocityChanges.AdjustLifetime.LowValue
 29 : F32            EmitterVelocityChanges.AdjustLifetime.HighValue
 30 : Bool           EmitterVelocityChanges.AdjustEmitterRate.AdjustEnabled
 31 : F32            EmitterVelocityChanges.AdjustEmitterRate.VelocityLow
 32 : F32            EmitterVelocityChanges.AdjustEmitterRate.VelocityHigh
 33 : F32            EmitterVelocityChanges.AdjustEmitterRate.LowValue
 34 : F32            EmitterVelocityChanges.AdjustEmitterRate.HighValue
 35 : Ref            Emitter

Member Data Documentation

F32 EmitterEffect::EffectProperties.Duration

'EffectProperties.Duration' : The duration of the effect in secontds

Bool EmitterEffect::EffectProperties.Enable

'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup

F32 EmitterEffect::EffectProperties.InitialDelayTime

'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect

F32 EmitterEffect::EffectProperties.Orientation.RotateX

'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)

F32 EmitterEffect::EffectProperties.Orientation.RotateY

'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)

F32 EmitterEffect::EffectProperties.Orientation.RotateZ

'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)

Transform EmitterEffect::EffectProperties.Path.ControlPoints[]

'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to

U32 EmitterEffect::EffectProperties.Path.LoopIndex

'EffectProperties.Path.LoopIndex' : The array index to loop back to

F32 EmitterEffect::EffectProperties.Path.PathDuration

'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided

PlaybackMode EmitterEffect::EffectProperties.Path.PlaybackMode

'EffectProperties.Path.PlaybackMode' : The mode to play back the path

F32 EmitterEffect::EffectProperties.Path.Scale[].x

'EffectProperties.Path.Scale[].x' : The x-axis value for this vector

F32 EmitterEffect::EffectProperties.Path.Scale[].y

'EffectProperties.Path.Scale[].y' : The y-axis value for this vector

F32 EmitterEffect::EffectProperties.Path.Speed[].x

'EffectProperties.Path.Speed[].x' : The x-axis value for this vector

F32 EmitterEffect::EffectProperties.Path.Speed[].y

'EffectProperties.Path.Speed[].y' : The y-axis value for this vector

F32 EmitterEffect::EffectProperties.Position.TranslateX

'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction

F32 EmitterEffect::EffectProperties.Position.TranslateY

'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction

F32 EmitterEffect::EffectProperties.Position.TranslateZ

'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction

F32 EmitterEffect::EffectProperties.RandomizeRepeatTime

'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.

U32 EmitterEffect::EffectProperties.RepeatCount

'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever

F32 EmitterEffect::EffectProperties.RepeatDelay

'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time

String EmitterEffect::EffectProperties.UserString

'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer

Ref EmitterEffect::Emitter

'Emitter' : Emitter Asset

Bool EmitterEffect::EmitterVelocityChanges.AdjustEmitterRate.AdjustEnabled

'EmitterVelocityChanges.AdjustEmitterRate.AdjustEnabled' : True if adjusting emitter properties based on velocity

F32 EmitterEffect::EmitterVelocityChanges.AdjustEmitterRate.HighValue

'EmitterVelocityChanges.AdjustEmitterRate.HighValue' : The multiplier when the velocity equals VelocityHigh

F32 EmitterEffect::EmitterVelocityChanges.AdjustEmitterRate.LowValue

'EmitterVelocityChanges.AdjustEmitterRate.LowValue' : The multiplier when the velocity equals VelocityLow

F32 EmitterEffect::EmitterVelocityChanges.AdjustEmitterRate.VelocityHigh

'EmitterVelocityChanges.AdjustEmitterRate.VelocityHigh' : High velocity range to match the high value

F32 EmitterEffect::EmitterVelocityChanges.AdjustEmitterRate.VelocityLow

'EmitterVelocityChanges.AdjustEmitterRate.VelocityLow' : Low velocity range to match the low

Bool EmitterEffect::EmitterVelocityChanges.AdjustLifetime.AdjustEnabled

'EmitterVelocityChanges.AdjustLifetime.AdjustEnabled' : True if adjusting emitter properties based on velocity

F32 EmitterEffect::EmitterVelocityChanges.AdjustLifetime.HighValue

'EmitterVelocityChanges.AdjustLifetime.HighValue' : The multiplier when the velocity equals VelocityHigh

F32 EmitterEffect::EmitterVelocityChanges.AdjustLifetime.LowValue

'EmitterVelocityChanges.AdjustLifetime.LowValue' : The multiplier when the velocity equals VelocityLow

F32 EmitterEffect::EmitterVelocityChanges.AdjustLifetime.VelocityHigh

'EmitterVelocityChanges.AdjustLifetime.VelocityHigh' : High velocity range to match the high value

F32 EmitterEffect::EmitterVelocityChanges.AdjustLifetime.VelocityLow

'EmitterVelocityChanges.AdjustLifetime.VelocityLow' : Low velocity range to match the low

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EmitterEffect Member List
This is the complete list of members for EmitterEffect, including all inherited members.
EffectProperties.Duration | EmitterEffect
EffectProperties.Enable | EmitterEffect
EffectProperties.InitialDelayTime | EmitterEffect
EffectProperties.Orientation.RotateX | EmitterEffect
EffectProperties.Orientation.RotateY | EmitterEffect
EffectProperties.Orientation.RotateZ | EmitterEffect
EffectProperties.Path.ControlPoints[] | EmitterEffect
EffectProperties.Path.LoopIndex | EmitterEffect
EffectProperties.Path.PathDuration | EmitterEffect
EffectProperties.Path.PlaybackMode | EmitterEffect
EffectProperties.Path.Scale[].x | EmitterEffect
EffectProperties.Path.Scale[].y | EmitterEffect
EffectProperties.Path.Speed[].x | EmitterEffect
EffectProperties.Path.Speed[].y | EmitterEffect
EffectProperties.Position.TranslateX | EmitterEffect
EffectProperties.Position.TranslateY | EmitterEffect
EffectProperties.Position.TranslateZ | EmitterEffect
EffectProperties.RandomizeRepeatTime | EmitterEffect
EffectProperties.RepeatCount | EmitterEffect
EffectProperties.RepeatDelay | EmitterEffect
EffectProperties.UserString | EmitterEffect
Emitter | EmitterEffect
EmitterVelocityChanges.AdjustEmitterRate.AdjustEnabled | EmitterEffect
EmitterVelocityChanges.AdjustEmitterRate.HighValue | EmitterEffect
EmitterVelocityChanges.AdjustEmitterRate.LowValue | EmitterEffect
EmitterVelocityChanges.AdjustEmitterRate.VelocityHigh | EmitterEffect
EmitterVelocityChanges.AdjustEmitterRate.VelocityLow | EmitterEffect
EmitterVelocityChanges.AdjustLifetime.AdjustEnabled | EmitterEffect
EmitterVelocityChanges.AdjustLifetime.HighValue | EmitterEffect
EmitterVelocityChanges.AdjustLifetime.LowValue | EmitterEffect
EmitterVelocityChanges.AdjustLifetime.VelocityHigh | EmitterEffect
EmitterVelocityChanges.AdjustLifetime.VelocityLow | EmitterEffect
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EmitterGeomBoxParams Struct Reference

  • Class List
  • Class Members
Public Attributes
EmitterGeomBoxParams Struct Reference

Describes the NxParameterized::Interface for 'EmitterGeomBoxParams' : More...

#include <params.h>

List of all members.

Public Attributes

EmitterType emitterType
'emitterType' : Emitter Type
Vec3 extents
'extents' : Box Extents

Detailed Description

Describes the NxParameterized::Interface for 'EmitterGeomBoxParams' :

EmitterGeomBoxParams contains 2 fully qualified names
---------------------------------------------
  1 : EmitterType  emitterType
  2 : Vec3         extents

Member Data Documentation

EmitterType EmitterGeomBoxParams::emitterType

'emitterType' : Emitter Type

rate - The emitter will emit at the rate specified by the asset's rateRange
densityOnce - The emitter will fill the geometry according to the asset's densityRange
densityBrush - As the emitter moves, the emitter will fill the volume that is not already covered by the previous position
fill - The emitter will fill the volume with particles based on the particle size

Vec3 EmitterGeomBoxParams::extents

'extents' : Box Extents

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EmitterGeomBoxParams Member List
This is the complete list of members for EmitterGeomBoxParams, including all inherited members.
emitterType | EmitterGeomBoxParams
extents | EmitterGeomBoxParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EmitterGeomCylinderParams Struct Reference

  • Class List
  • Class Members
Public Attributes
EmitterGeomCylinderParams Struct Reference

Describes the NxParameterized::Interface for 'EmitterGeomCylinderParams' : More...

#include <params.h>

List of all members.

Public Attributes

EmitterType emitterType
'emitterType' : Emitter Type
F32 | radius
'radius' : Cylinder Radius
F32 | height
'height' : Cylinder Height

Detailed Description

Describes the NxParameterized::Interface for 'EmitterGeomCylinderParams' :

EmitterGeomCylinderParams contains 3 fully qualified names
---------------------------------------------
  1 : EmitterType  emitterType
  2 : F32          radius
  3 : F32          height

Member Data Documentation

EmitterType EmitterGeomCylinderParams::emitterType

'emitterType' : Emitter Type

rate - The emitter will emit at the rate specified by the asset's rateRange
densityOnce - The emitter will fill the geometry according to the asset's densityRange
densityBrush - As the emitter moves, the emitter will fill the volume that is not already covered by the previous position
fill - The emitter will fill the volume with particles based on the particle size

F32 EmitterGeomCylinderParams::height

'height' : Cylinder Height

F32 EmitterGeomCylinderParams::radius

'radius' : Cylinder Radius

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EmitterGeomCylinderParams Member List
This is the complete list of members for EmitterGeomCylinderParams, including all inherited members.
emitterType | EmitterGeomCylinderParams
height | EmitterGeomCylinderParams
radius | EmitterGeomCylinderParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EmitterGeomExplicitParams Struct Reference

  • Class List
  • Class Members
Public Attributes
EmitterGeomExplicitParams Struct Reference

Describes the NxParameterized::Interface for 'EmitterGeomExplicitParams' : More...

#include <params.h>

List of all members.

Public Attributes

F32 | distance
'distance' : Average distance between particles
Vec3 | points.positions[].position
'points.positions[].position' : Initial position
Bool | points.positions[].doDetectOverlaps
'points.positions[].doDetectOverlaps' : Avoid overlaps with other shapes?
Vec3 | points.velocities[]
'points.velocities[]' : List of initial velocities
Vec3 | spheres.positions[].center
'spheres.positions[].center' : Sphere centers
F32 | spheres.positions[].radius
'spheres.positions[].radius' : Sphere radiuses
Bool | spheres.positions[].doDetectOverlaps
'spheres.positions[].doDetectOverlaps' : Avoid overlaps with other shapes?
Vec3 | spheres.velocities[]
'spheres.velocities[]' : List of initial velocities for particles in sphere
Vec3 | ellipsoids.positions[].center
'ellipsoids.positions[].center' : Sphere centers
F32 | ellipsoids.positions[].radius
'ellipsoids.positions[].radius' : Sphere radiuses
Vec3 | ellipsoids.positions[].normal
'ellipsoids.positions[].normal' : Normal to equatorial planes
F32 | ellipsoids.positions[].polarRadius
'ellipsoids.positions[].polarRadius' : Polar radius
Bool | ellipsoids.positions[].doDetectOverlaps
'ellipsoids.positions[].doDetectOverlaps' : Avoid overlaps with other shapes?
Vec3 | ellipsoids.velocities[]
'ellipsoids.velocities[]' : List of initial velocities for particles in ellipsoid

Detailed Description

Describes the NxParameterized::Interface for 'EmitterGeomExplicitParams' :

EmitterGeomExplicitParams contains 20 fully qualified names
---------------------------------------------
  1 : F32            distance
  2 : ArraySizeName  positions
  3 : Vec3           points.positions[].position
  4 : Bool           points.positions[].doDetectOverlaps
  5 : ArraySizeName  velocities
  6 : Vec3           points.velocities[]
  7 : ArraySizeName  positions
  8 : Vec3           spheres.positions[].center
  9 : F32            spheres.positions[].radius
 10 : Bool           spheres.positions[].doDetectOverlaps
 11 : ArraySizeName  velocities
 12 : Vec3           spheres.velocities[]
 13 : ArraySizeName  positions
 14 : Vec3           ellipsoids.positions[].center
 15 : F32            ellipsoids.positions[].radius
 16 : Vec3           ellipsoids.positions[].normal
 17 : F32            ellipsoids.positions[].polarRadius
 18 : Bool           ellipsoids.positions[].doDetectOverlaps
 19 : ArraySizeName  velocities
 20 : Vec3           ellipsoids.velocities[]

Member Data Documentation

F32 EmitterGeomExplicitParams::distance

'distance' : Average distance between particles

Vec3 EmitterGeomExplicitParams::ellipsoids.positions[].center

'ellipsoids.positions[].center' : Sphere centers

Bool EmitterGeomExplicitParams::ellipsoids.positions[].doDetectOverlaps

'ellipsoids.positions[].doDetectOverlaps' : Avoid overlaps with other shapes?

Vec3 EmitterGeomExplicitParams::ellipsoids.positions[].normal

'ellipsoids.positions[].normal' : Normal to equatorial planes

F32 EmitterGeomExplicitParams::ellipsoids.positions[].polarRadius

'ellipsoids.positions[].polarRadius' : Polar radius

F32 EmitterGeomExplicitParams::ellipsoids.positions[].radius

'ellipsoids.positions[].radius' : Sphere radiuses

Vec3 EmitterGeomExplicitParams::ellipsoids.velocities[]

'ellipsoids.velocities[]' : List of initial velocities for particles in ellipsoid

Bool EmitterGeomExplicitParams::points.positions[].doDetectOverlaps

'points.positions[].doDetectOverlaps' : Avoid overlaps with other shapes?

Vec3 EmitterGeomExplicitParams::points.positions[].position

'points.positions[].position' : Initial position

Vec3 EmitterGeomExplicitParams::points.velocities[]

'points.velocities[]' : List of initial velocities

Vec3 EmitterGeomExplicitParams::spheres.positions[].center

'spheres.positions[].center' : Sphere centers

Bool EmitterGeomExplicitParams::spheres.positions[].doDetectOverlaps

'spheres.positions[].doDetectOverlaps' : Avoid overlaps with other shapes?

F32 EmitterGeomExplicitParams::spheres.positions[].radius

'spheres.positions[].radius' : Sphere radiuses

Vec3 EmitterGeomExplicitParams::spheres.velocities[]

'spheres.velocities[]' : List of initial velocities for particles in sphere

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EmitterGeomExplicitParams Member List
This is the complete list of members for EmitterGeomExplicitParams, including all inherited members.
distance | EmitterGeomExplicitParams
ellipsoids.positions[].center | EmitterGeomExplicitParams
ellipsoids.positions[].doDetectOverlaps | EmitterGeomExplicitParams
ellipsoids.positions[].normal | EmitterGeomExplicitParams
ellipsoids.positions[].polarRadius | EmitterGeomExplicitParams
ellipsoids.positions[].radius | EmitterGeomExplicitParams
ellipsoids.velocities[] | EmitterGeomExplicitParams
points.positions[].doDetectOverlaps | EmitterGeomExplicitParams
points.positions[].position | EmitterGeomExplicitParams
points.velocities[] | EmitterGeomExplicitParams
spheres.positions[].center | EmitterGeomExplicitParams
spheres.positions[].doDetectOverlaps | EmitterGeomExplicitParams
spheres.positions[].radius | EmitterGeomExplicitParams
spheres.velocities[] | EmitterGeomExplicitParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EmitterGeomSphereParams Struct Reference

  • Class List
  • Class Members
Public Attributes
EmitterGeomSphereParams Struct Reference

Describes the NxParameterized::Interface for 'EmitterGeomSphereParams' : More...

#include <params.h>

List of all members.

Public Attributes

EmitterType emitterType
'emitterType' : Emitter Type
F32 | radius
'radius' : Sphere Radius
F32 | hemisphere
'hemisphere' : Sphere Hemisphere

Detailed Description

Describes the NxParameterized::Interface for 'EmitterGeomSphereParams' :

EmitterGeomSphereParams contains 3 fully qualified names
---------------------------------------------
  1 : EmitterType  emitterType
  2 : F32          radius
  3 : F32          hemisphere

Member Data Documentation

EmitterType EmitterGeomSphereParams::emitterType

'emitterType' : Emitter Type

rate - The emitter will emit at the rate specified by the asset's rateRange
densityOnce - The emitter will fill the geometry according to the asset's densityRange
densityBrush - As the emitter moves, the emitter will fill the volume that is not already covered by the previous position
fill - The emitter will fill the volume with particles based on the particle size

F32 EmitterGeomSphereParams::hemisphere

'hemisphere' : Sphere Hemisphere

F32 EmitterGeomSphereParams::radius

'radius' : Sphere Radius

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EmitterGeomSphereParams Member List
This is the complete list of members for EmitterGeomSphereParams, including all inherited members.
emitterType | EmitterGeomSphereParams
hemisphere | EmitterGeomSphereParams
radius | EmitterGeomSphereParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EmitterGeomSphereShellParams Struct Reference

  • Class List
  • Class Members
Public Attributes
EmitterGeomSphereShellParams Struct Reference

Describes the NxParameterized::Interface for 'EmitterGeomSphereShellParams' : More...

#include <params.h>

List of all members.

Public Attributes

EmitterType emitterType
'emitterType' : Emitter Type
F32 | radius
'radius' : Sphere Radius
F32 | shellThickness
'shellThickness' : Sphere Shell Thickness
F32 | hemisphere
'hemisphere' : Sphere Shell Hemisphere

Detailed Description

Describes the NxParameterized::Interface for 'EmitterGeomSphereShellParams' :

EmitterGeomSphereShellParams contains 4 fully qualified names
---------------------------------------------
  1 : EmitterType  emitterType
  2 : F32          radius
  3 : F32          shellThickness
  4 : F32          hemisphere

Member Data Documentation

EmitterType EmitterGeomSphereShellParams::emitterType

'emitterType' : Emitter Type

rate - The emitter will emit at the rate specified by the asset's rateRange
densityOnce - The emitter will fill the geometry according to the asset's densityRange
densityBrush - As the emitter moves, the emitter will fill the volume that is not already covered by the previous position
fill - The emitter will fill the volume with particles based on the particle size

F32 EmitterGeomSphereShellParams::hemisphere

'hemisphere' : Sphere Shell Hemisphere

F32 EmitterGeomSphereShellParams::radius

'radius' : Sphere Radius

F32 EmitterGeomSphereShellParams::shellThickness

'shellThickness' : Sphere Shell Thickness

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EmitterGeomSphereShellParams Member List
This is the complete list of members for EmitterGeomSphereShellParams, including all inherited members.
emitterType | EmitterGeomSphereShellParams
hemisphere | EmitterGeomSphereShellParams
radius | EmitterGeomSphereShellParams
shellThickness | EmitterGeomSphereShellParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EmitterModuleParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
EmitterModuleParameters Struct Reference

Describes the NxParameterized::Interface for 'EmitterModuleParameters' : This class is used for initializing the NxModuleEmitter. More...

#include <params.h>

List of all members.

Public Attributes

U32 unused
'unused' : No parameters necessary

Detailed Description

Describes the NxParameterized::Interface for 'EmitterModuleParameters' : This class is used for initializing the NxModuleEmitter.

EmitterModuleParameters contains 1 fully qualified names
---------------------------------------------
  1 : U32  unused

Member Data Documentation

U32 EmitterModuleParameters::unused

'unused' : No parameters necessary

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
EmitterModuleParameters Member List
This is the complete list of members for EmitterModuleParameters, including all inherited members.
unused EmitterModuleParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: FieldSamplerModuleParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
FieldSamplerModuleParameters Struct Reference

Describes the NxParameterized::Interface for 'FieldSamplerModuleParameters' : This class is used for initializing the NxModuleFieldBoundary. More...

#include <params.h>

List of all members.

Public Attributes

U32 unused
'unused' : No parameters necessary

Detailed Description

Describes the NxParameterized::Interface for 'FieldSamplerModuleParameters' : This class is used for initializing the NxModuleFieldBoundary.

FieldSamplerModuleParameters contains 1 fully qualified names
---------------------------------------------
  1 : U32  unused

Member Data Documentation

U32 FieldSamplerModuleParameters::unused

'unused' : No parameters necessary

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
FieldSamplerModuleParameters Member List
This is the complete list of members for FieldSamplerModuleParameters, including all inherited members.
unused FieldSamplerModuleParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: FieldSamplerPhysXMonitorParams Struct Reference

  • Class List
  • Class Members
Public Attributes
FieldSamplerPhysXMonitorParams Struct Reference

Describes the NxParameterized::Interface for 'FieldSamplerPhysXMonitorParams' : More...

#include <params.h>

List of all members.

Public Attributes

U32 | maxRBCount
'maxRBCount' : Maximum number of rigid bodies in scene
U32 | maxPSCount
'maxPSCount' : Maximum number of particle systems in scene
U32 | maxParticleCount
'maxParticleCount' : Maximum number of particles in scene

Detailed Description

Describes the NxParameterized::Interface for 'FieldSamplerPhysXMonitorParams' :

FieldSamplerPhysXMonitorParams contains 3 fully qualified names
---------------------------------------------
  1 : U32  maxRBCount
  2 : U32  maxPSCount
  3 : U32  maxParticleCount

Member Data Documentation

U32 FieldSamplerPhysXMonitorParams::maxParticleCount

'maxParticleCount' : Maximum number of particles in scene

U32 FieldSamplerPhysXMonitorParams::maxPSCount

'maxPSCount' : Maximum number of particle systems in scene

U32 FieldSamplerPhysXMonitorParams::maxRBCount

'maxRBCount' : Maximum number of rigid bodies in scene

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
FieldSamplerPhysXMonitorParams Member List
This is the complete list of members for FieldSamplerPhysXMonitorParams, including all inherited members.
maxParticleCount | FieldSamplerPhysXMonitorParams
maxPSCount | FieldSamplerPhysXMonitorParams
maxRBCount | FieldSamplerPhysXMonitorParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: FluidParticleSystemParams Struct Reference

  • Class List
  • Class Members
Public Attributes
FluidParticleSystemParams Struct Reference

Describes the NxParameterized::Interface for 'FluidParticleSystemParams' : More...

#include <params.h>

List of all members.

Public Attributes

F32 | restParticleDistance
'restParticleDistance' : Rest distance of particles
F32 | stiffness
'stiffness' : The stiffness of the particle interaction related to the pressure
F32 | viscosity
'viscosity' : The viscosity of the fluid defines its viscous behavior

Detailed Description

Describes the NxParameterized::Interface for 'FluidParticleSystemParams' :

FluidParticleSystemParams contains 3 fully qualified names
---------------------------------------------
  1 : F32  restParticleDistance
  2 : F32  stiffness
  3 : F32  viscosity

Member Data Documentation

F32 FluidParticleSystemParams::restParticleDistance

'restParticleDistance' : Rest distance of particles

The typical particle distance of particles in the rest state (relaxed). Defines the particle resolution of the fluid. This property can't be changed after the particle fluid has been created. Must be positive.

F32 FluidParticleSystemParams::stiffness

'stiffness' : The stiffness of the particle interaction related to the pressure

This factor linearly scales the force which acts on particles which are closer to each other than the rest spacing. Setting this parameter appropriately is crucial for the simulation. The right value depends on many factors such as viscosity and damping. Values which are too high will result in an unstable simulation, whereas too low values will make the fluid appear "springy" (the fluid acts more compressible). Must be positive.

F32 FluidParticleSystemParams::viscosity

'viscosity' : The viscosity of the fluid defines its viscous behavior

Higher values will result in a honey-like behavior. Viscosity is an effect which depends on the relative velocity of neighboring particles; it reduces the magnitude of the relative velocity. Must be positive.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
FluidParticleSystemParams Member List
This is the complete list of members for FluidParticleSystemParams, including all inherited members.
restParticleDistance | FluidParticleSystemParams
stiffness | FluidParticleSystemParams
viscosity | FluidParticleSystemParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ForceFieldActorParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ForceFieldActorParams Struct Reference

Describes the NxParameterized::Interface for 'ForceFieldActorParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat44 | initialPose
'initialPose' : The initial pose where the forcefield actor will be put into the scene
F32 | scale
'scale' : Forcefield actor scale
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for AttractorFS vs Field Boundaries interaction. Overrides asset's value.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for AttractorFS vs other Field Samplers interaction. Overrides asset's value.

Detailed Description

Describes the NxParameterized::Interface for 'ForceFieldActorParams' :

ForceFieldActorParams contains 4 fully qualified names
---------------------------------------------
  1 : Mat44   initialPose
  2 : F32     scale
  3 : String  fieldBoundaryFilterDataName
  4 : String  fieldSamplerFilterDataName

Member Data Documentation

String ForceFieldActorParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for AttractorFS vs Field Boundaries interaction. Overrides asset's value.

String ForceFieldActorParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for AttractorFS vs other Field Samplers interaction. Overrides asset's value.

Mat44 ForceFieldActorParams::initialPose

'initialPose' : The initial pose where the forcefield actor will be put into the scene

F32 ForceFieldActorParams::scale

'scale' : Forcefield actor scale

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ForceFieldActorParams Member List
This is the complete list of members for ForceFieldActorParams, including all inherited members.
fieldBoundaryFilterDataName | ForceFieldActorParams
fieldSamplerFilterDataName | ForceFieldActorParams
initialPose | ForceFieldActorParams
scale | ForceFieldActorParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ForceFieldAssetParams Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
ForceFieldAssetParams Struct Reference

Describes the NxParameterized::Interface for 'ForceFieldAssetParams' : Contains the asset properties for ForceField. More...

#include <params.h>

List of all members.

Classes

union | ForceFieldKernelType

Public Attributes

ForceFieldKernelType forceFieldKernelType
F32 | defScale
'defScale' : Default scale of the force field
F32 | strength
'strength' : Constant part of force field function
F32 | lifetime
'lifetime' : Lifetime of force field
Shape includeShapeParameters.shape
'includeShapeParameters.shape' : Include shape type for force field
Mat44 | includeShapeParameters.forceFieldToShape
'includeShapeParameters.forceFieldToShape' : Transform to convert force field to local shape coordinates
Vec3 | includeShapeParameters.dimensions
'includeShapeParameters.dimensions' : x,y,z values dependent on shape type
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for ForceField vs Field Boundaries interaction. Overrides asset's value.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for ForceField vs other Field Samplers interaction. Overrides asset's value.

Detailed Description

Describes the NxParameterized::Interface for 'ForceFieldAssetParams' : Contains the asset properties for ForceField.

ForceFieldAssetParams contains 27 fully qualified names
---------------------------------------------
  1 : Type    forceFieldKernelType.coordinateSystemParameters.type         RefVariant[GenericForceFieldKernelParams]
  2 : F32     forceFieldKernelType.coordinateSystemParameters.torusRadius  RefVariant[GenericForceFieldKernelParams]
  3 : Vec3    forceFieldKernelType.constant                                RefVariant[GenericForceFieldKernelParams]
  4 : Mat33   forceFieldKernelType.positionMultiplier                      RefVariant[GenericForceFieldKernelParams]
  5 : Vec3    forceFieldKernelType.positionTarget                          RefVariant[GenericForceFieldKernelParams]
  6 : Mat33   forceFieldKernelType.velocityMultiplier                      RefVariant[GenericForceFieldKernelParams]
  7 : Vec3    forceFieldKernelType.velocityTarget                          RefVariant[GenericForceFieldKernelParams]
  8 : Vec3    forceFieldKernelType.noise                                   RefVariant[GenericForceFieldKernelParams]
  9 : Vec3    forceFieldKernelType.falloffLinear                           RefVariant[GenericForceFieldKernelParams]
 10 : Vec3    forceFieldKernelType.falloffQuadratic                        RefVariant[GenericForceFieldKernelParams]
 11 : Type    forceFieldKernelType.falloffParameters.type                  RefVariant[ForceFieldFalloffParams]
 12 : F32     forceFieldKernelType.falloffParameters.multiplier            RefVariant[ForceFieldFalloffParams]
 13 : F32     forceFieldKernelType.falloffParameters.start                 RefVariant[ForceFieldFalloffParams]
 14 : F32     forceFieldKernelType.falloffParameters.end                   RefVariant[ForceFieldFalloffParams]
 15 : F32     forceFieldKernelType.noiseParameters.strength                RefVariant[ForceFieldNoiseParams]
 16 : F32     forceFieldKernelType.noiseParameters.spaceScale              RefVariant[ForceFieldNoiseParams]
 17 : F32     forceFieldKernelType.noiseParameters.timeScale               RefVariant[ForceFieldNoiseParams]
 18 : U32     forceFieldKernelType.noiseParameters.octaves                 RefVariant[ForceFieldNoiseParams]
 19 : F32     forceFieldKernelType.radius                                  RefVariant[RadialForceFieldKernelParams]
 20 : F32     defScale
 21 : F32     strength
 22 : F32     lifetime
 23 : Shape   includeShapeParameters.shape
 24 : Mat44   includeShapeParameters.forceFieldToShape
 25 : Vec3    includeShapeParameters.dimensions
 26 : String  fieldBoundaryFilterDataName
 27 : String  fieldSamplerFilterDataName

Member Data Documentation

F32 ForceFieldAssetParams::defScale

'defScale' : Default scale of the force field

String ForceFieldAssetParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for ForceField vs Field Boundaries interaction. Overrides asset's value.

String ForceFieldAssetParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for ForceField vs other Field Samplers interaction. Overrides asset's value.

ForceFieldKernelType ForceFieldAssetParams::forceFieldKernelType
Vec3 ForceFieldAssetParams::includeShapeParameters.dimensions

'includeShapeParameters.dimensions' : x,y,z values dependent on shape type

Mat44 ForceFieldAssetParams::includeShapeParameters.forceFieldToShape

'includeShapeParameters.forceFieldToShape' : Transform to convert force field to local shape coordinates

Shape ForceFieldAssetParams::includeShapeParameters.shape

'includeShapeParameters.shape' : Include shape type for force field

F32 ForceFieldAssetParams::lifetime

'lifetime' : Lifetime of force field

F32 ForceFieldAssetParams::strength

'strength' : Constant part of force field function

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ForceFieldAssetParams Member List
This is the complete list of members for ForceFieldAssetParams, including all inherited members.
defScale | ForceFieldAssetParams
fieldBoundaryFilterDataName | ForceFieldAssetParams
fieldSamplerFilterDataName | ForceFieldAssetParams
forceFieldKernelType | ForceFieldAssetParams
includeShapeParameters.dimensions | ForceFieldAssetParams
includeShapeParameters.forceFieldToShape | ForceFieldAssetParams
includeShapeParameters.shape | ForceFieldAssetParams
lifetime | ForceFieldAssetParams
strength | ForceFieldAssetParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ForceFieldAssetPreviewParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ForceFieldAssetPreviewParams Struct Reference

Describes the NxParameterized::Interface for 'ForceFieldAssetPreviewParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat44 | pose
'pose' : The preview actor's position and rotation
F32 | iconScale
'iconScale' : The preview actor's icon scale
Bool | drawIcon
'drawIcon' : Draw the icon
Bool | drawBoundaries
'drawBoundaries' : Draw the explosion field boundaries
Bool | drawBold
'drawBold' : Draw everything using thick lines

Detailed Description

Describes the NxParameterized::Interface for 'ForceFieldAssetPreviewParams' :

ForceFieldAssetPreviewParams contains 5 fully qualified names
---------------------------------------------
  1 : Mat44  pose
  2 : F32    iconScale
  3 : Bool   drawIcon
  4 : Bool   drawBoundaries
  5 : Bool   drawBold

Member Data Documentation

Bool ForceFieldAssetPreviewParams::drawBold

'drawBold' : Draw everything using thick lines

Bool ForceFieldAssetPreviewParams::drawBoundaries

'drawBoundaries' : Draw the explosion field boundaries

Bool ForceFieldAssetPreviewParams::drawIcon

'drawIcon' : Draw the icon

F32 ForceFieldAssetPreviewParams::iconScale

'iconScale' : The preview actor's icon scale

Mat44 ForceFieldAssetPreviewParams::pose

'pose' : The preview actor's position and rotation

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ForceFieldAssetPreviewParams Member List
This is the complete list of members for ForceFieldAssetPreviewParams, including all inherited members.
drawBold | ForceFieldAssetPreviewParams
drawBoundaries | ForceFieldAssetPreviewParams
drawIcon | ForceFieldAssetPreviewParams
iconScale | ForceFieldAssetPreviewParams
pose | ForceFieldAssetPreviewParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ForceFieldData Struct Reference

  • Class List
  • Class Members
Public Attributes
ForceFieldData Struct Reference

Describes the NxParameterized::Interface for 'ForceFieldData' : Contains the asset properties for this force field sampler. More...

#include <params.h>

List of all members.

Public Attributes

String Name
'Name' : Forcefield Name
ForceFieldAssetParams ForceField
'ForceField' :

Detailed Description

Describes the NxParameterized::Interface for 'ForceFieldData' : Contains the asset properties for this force field sampler.

ForceFieldData contains 28 fully qualified names
---------------------------------------------
  1 : String  Name
  2 : Type    ForceField.forceFieldKernelType.coordinateSystemParameters.type         RefVariant[GenericForceFieldKernelParams]
  3 : F32     ForceField.forceFieldKernelType.coordinateSystemParameters.torusRadius  RefVariant[GenericForceFieldKernelParams]
  4 : Vec3    ForceField.forceFieldKernelType.constant                                RefVariant[GenericForceFieldKernelParams]
  5 : Mat33   ForceField.forceFieldKernelType.positionMultiplier                      RefVariant[GenericForceFieldKernelParams]
  6 : Vec3    ForceField.forceFieldKernelType.positionTarget                          RefVariant[GenericForceFieldKernelParams]
  7 : Mat33   ForceField.forceFieldKernelType.velocityMultiplier                      RefVariant[GenericForceFieldKernelParams]
  8 : Vec3    ForceField.forceFieldKernelType.velocityTarget                          RefVariant[GenericForceFieldKernelParams]
  9 : Vec3    ForceField.forceFieldKernelType.noise                                   RefVariant[GenericForceFieldKernelParams]
 10 : Vec3    ForceField.forceFieldKernelType.falloffLinear                           RefVariant[GenericForceFieldKernelParams]
 11 : Vec3    ForceField.forceFieldKernelType.falloffQuadratic                        RefVariant[GenericForceFieldKernelParams]
 12 : Type    ForceField.forceFieldKernelType.falloffParameters.type                  RefVariant[ForceFieldFalloffParams]
 13 : F32     ForceField.forceFieldKernelType.falloffParameters.multiplier            RefVariant[ForceFieldFalloffParams]
 14 : F32     ForceField.forceFieldKernelType.falloffParameters.start                 RefVariant[ForceFieldFalloffParams]
 15 : F32     ForceField.forceFieldKernelType.falloffParameters.end                   RefVariant[ForceFieldFalloffParams]
 16 : F32     ForceField.forceFieldKernelType.noiseParameters.strength                RefVariant[ForceFieldNoiseParams]
 17 : F32     ForceField.forceFieldKernelType.noiseParameters.spaceScale              RefVariant[ForceFieldNoiseParams]
 18 : F32     ForceField.forceFieldKernelType.noiseParameters.timeScale               RefVariant[ForceFieldNoiseParams]
 19 : U32     ForceField.forceFieldKernelType.noiseParameters.octaves                 RefVariant[ForceFieldNoiseParams]
 20 : F32     ForceField.forceFieldKernelType.radius                                  RefVariant[RadialForceFieldKernelParams]
 21 : F32     ForceField.defScale                                                     RefVariant[ForceFieldAssetParams]
 22 : F32     ForceField.strength                                                     RefVariant[ForceFieldAssetParams]
 23 : F32     ForceField.lifetime                                                     RefVariant[ForceFieldAssetParams]
 24 : Shape   ForceField.includeShapeParameters.shape                                 RefVariant[ForceFieldAssetParams]
 25 : Mat44   ForceField.includeShapeParameters.forceFieldToShape                     RefVariant[ForceFieldAssetParams]
 26 : Vec3    ForceField.includeShapeParameters.dimensions                            RefVariant[ForceFieldAssetParams]
 27 : String  ForceField.fieldBoundaryFilterDataName                                  RefVariant[ForceFieldAssetParams]
 28 : String  ForceField.fieldSamplerFilterDataName                                   RefVariant[ForceFieldAssetParams]

Member Data Documentation

ForceFieldAssetParams ForceFieldData::ForceField

'ForceField' :

String ForceFieldData::Name

'Name' : Forcefield Name

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ForceFieldData Member List
This is the complete list of members for ForceFieldData, including all inherited members.
ForceField | ForceFieldData
Name | ForceFieldData
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ForceFieldDebugRenderParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ForceFieldDebugRenderParams Struct Reference

Describes the NxParameterized::Interface for 'ForceFieldDebugRenderParams' : More...

#include <params.h>

List of all members.

Public Attributes

Bool VISUALIZE_FORCEFIELD_ACTOR
'VISUALIZE_FORCEFIELD_ACTOR' : Draws the include shape of the forcefield actor.

Detailed Description

Describes the NxParameterized::Interface for 'ForceFieldDebugRenderParams' :

ForceFieldDebugRenderParams contains 1 fully qualified names
---------------------------------------------
  1 : Bool  VISUALIZE_FORCEFIELD_ACTOR

Member Data Documentation

Bool ForceFieldDebugRenderParams::VISUALIZE_FORCEFIELD_ACTOR

'VISUALIZE_FORCEFIELD_ACTOR' : Draws the include shape of the forcefield actor.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ForceFieldDebugRenderParams Member List
This is the complete list of members for ForceFieldDebugRenderParams, including all inherited members.
VISUALIZE_FORCEFIELD_ACTOR ForceFieldDebugRenderParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ForceFieldEffect Struct Reference

  • Class List
  • Class Members
Public Attributes
ForceFieldEffect Struct Reference

Describes the NxParameterized::Interface for 'ForceFieldEffect' : A forcefield effect. More...

#include <params.h>

List of all members.

Public Attributes

String | EffectProperties.UserString
'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer
Bool | EffectProperties.Enable
'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup
F32 | EffectProperties.Position.TranslateX
'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateY
'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateZ
'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Orientation.RotateX
'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateY
'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateZ
'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)
F32 | EffectProperties.InitialDelayTime
'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect
F32 | EffectProperties.Duration
'EffectProperties.Duration' : The duration of the effect in secontds
U32 | EffectProperties.RepeatCount
'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever
F32 | EffectProperties.RepeatDelay
'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time
F32 | EffectProperties.RandomizeRepeatTime
'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.
PlaybackMode EffectProperties.Path.PlaybackMode
'EffectProperties.Path.PlaybackMode' : The mode to play back the path
F32 | EffectProperties.Path.PathDuration
'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided
U32 | EffectProperties.Path.LoopIndex
'EffectProperties.Path.LoopIndex' : The array index to loop back to
Transform | EffectProperties.Path.ControlPoints[]
'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to
F32 | EffectProperties.Path.Scale[].x
'EffectProperties.Path.Scale[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Scale[].y
'EffectProperties.Path.Scale[].y' : The y-axis value for this vector
F32 | EffectProperties.Path.Speed[].x
'EffectProperties.Path.Speed[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Speed[].y
'EffectProperties.Path.Speed[].y' : The y-axis value for this vector
Ref | ForceField
'ForceField' : Forcefield Asset

Detailed Description

Describes the NxParameterized::Interface for 'ForceFieldEffect' : A forcefield effect.

ForceFieldEffect contains 25 fully qualified names
---------------------------------------------
  1 : String         EffectProperties.UserString
  2 : Bool           EffectProperties.Enable
  3 : F32            EffectProperties.Position.TranslateX
  4 : F32            EffectProperties.Position.TranslateY
  5 : F32            EffectProperties.Position.TranslateZ
  6 : F32            EffectProperties.Orientation.RotateX
  7 : F32            EffectProperties.Orientation.RotateY
  8 : F32            EffectProperties.Orientation.RotateZ
  9 : F32            EffectProperties.InitialDelayTime
 10 : F32            EffectProperties.Duration
 11 : U32            EffectProperties.RepeatCount
 12 : F32            EffectProperties.RepeatDelay
 13 : F32            EffectProperties.RandomizeRepeatTime
 14 : PlaybackMode   EffectProperties.Path.PlaybackMode
 15 : F32            EffectProperties.Path.PathDuration
 16 : U32            EffectProperties.Path.LoopIndex
 17 : ArraySizeName  ControlPoints
 18 : Transform      EffectProperties.Path.ControlPoints[]
 19 : ArraySizeName  Scale
 20 : F32            EffectProperties.Path.Scale[].x
 21 : F32            EffectProperties.Path.Scale[].y
 22 : ArraySizeName  Speed
 23 : F32            EffectProperties.Path.Speed[].x
 24 : F32            EffectProperties.Path.Speed[].y
 25 : Ref            ForceField

Member Data Documentation

F32 ForceFieldEffect::EffectProperties.Duration

'EffectProperties.Duration' : The duration of the effect in secontds

Bool ForceFieldEffect::EffectProperties.Enable

'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup

F32 ForceFieldEffect::EffectProperties.InitialDelayTime

'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect

F32 ForceFieldEffect::EffectProperties.Orientation.RotateX

'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)

F32 ForceFieldEffect::EffectProperties.Orientation.RotateY

'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)

F32 ForceFieldEffect::EffectProperties.Orientation.RotateZ

'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)

Transform ForceFieldEffect::EffectProperties.Path.ControlPoints[]

'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to

U32 ForceFieldEffect::EffectProperties.Path.LoopIndex

'EffectProperties.Path.LoopIndex' : The array index to loop back to

F32 ForceFieldEffect::EffectProperties.Path.PathDuration

'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided

PlaybackMode ForceFieldEffect::EffectProperties.Path.PlaybackMode

'EffectProperties.Path.PlaybackMode' : The mode to play back the path

F32 ForceFieldEffect::EffectProperties.Path.Scale[].x

'EffectProperties.Path.Scale[].x' : The x-axis value for this vector

F32 ForceFieldEffect::EffectProperties.Path.Scale[].y

'EffectProperties.Path.Scale[].y' : The y-axis value for this vector

F32 ForceFieldEffect::EffectProperties.Path.Speed[].x

'EffectProperties.Path.Speed[].x' : The x-axis value for this vector

F32 ForceFieldEffect::EffectProperties.Path.Speed[].y

'EffectProperties.Path.Speed[].y' : The y-axis value for this vector

F32 ForceFieldEffect::EffectProperties.Position.TranslateX

'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction

F32 ForceFieldEffect::EffectProperties.Position.TranslateY

'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction

F32 ForceFieldEffect::EffectProperties.Position.TranslateZ

'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction

F32 ForceFieldEffect::EffectProperties.RandomizeRepeatTime

'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.

U32 ForceFieldEffect::EffectProperties.RepeatCount

'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever

F32 ForceFieldEffect::EffectProperties.RepeatDelay

'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time

String ForceFieldEffect::EffectProperties.UserString

'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer

Ref ForceFieldEffect::ForceField

'ForceField' : Forcefield Asset

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ForceFieldEffect Member List
This is the complete list of members for ForceFieldEffect, including all inherited members.
EffectProperties.Duration | ForceFieldEffect
EffectProperties.Enable | ForceFieldEffect
EffectProperties.InitialDelayTime | ForceFieldEffect
EffectProperties.Orientation.RotateX | ForceFieldEffect
EffectProperties.Orientation.RotateY | ForceFieldEffect
EffectProperties.Orientation.RotateZ | ForceFieldEffect
EffectProperties.Path.ControlPoints[] | ForceFieldEffect
EffectProperties.Path.LoopIndex | ForceFieldEffect
EffectProperties.Path.PathDuration | ForceFieldEffect
EffectProperties.Path.PlaybackMode | ForceFieldEffect
EffectProperties.Path.Scale[].x | ForceFieldEffect
EffectProperties.Path.Scale[].y | ForceFieldEffect
EffectProperties.Path.Speed[].x | ForceFieldEffect
EffectProperties.Path.Speed[].y | ForceFieldEffect
EffectProperties.Position.TranslateX | ForceFieldEffect
EffectProperties.Position.TranslateY | ForceFieldEffect
EffectProperties.Position.TranslateZ | ForceFieldEffect
EffectProperties.RandomizeRepeatTime | ForceFieldEffect
EffectProperties.RepeatCount | ForceFieldEffect
EffectProperties.RepeatDelay | ForceFieldEffect
EffectProperties.UserString | ForceFieldEffect
ForceField | ForceFieldEffect
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ForceFieldFalloffParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ForceFieldFalloffParams Struct Reference

Describes the NxParameterized::Interface for 'ForceFieldFalloffParams' : More...

#include <params.h>

List of all members.

Public Attributes

Type type
'type' : Falloff type for force field
F32 | multiplier
'multiplier' : Falloff multiplier value
F32 | start
'start' : Falloff start value
F32 | end
'end' : Falloff end value

Detailed Description

Describes the NxParameterized::Interface for 'ForceFieldFalloffParams' :

ForceFieldFalloffParams contains 4 fully qualified names
---------------------------------------------
  1 : Type  type
  2 : F32   multiplier
  3 : F32   start
  4 : F32   end

Member Data Documentation

F32 ForceFieldFalloffParams::end

'end' : Falloff end value

F32 ForceFieldFalloffParams::multiplier

'multiplier' : Falloff multiplier value

F32 ForceFieldFalloffParams::start

'start' : Falloff start value

Type ForceFieldFalloffParams::type

'type' : Falloff type for force field

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ForceFieldFalloffParams Member List
This is the complete list of members for ForceFieldFalloffParams, including all inherited members.
end | ForceFieldFalloffParams
multiplier | ForceFieldFalloffParams
start | ForceFieldFalloffParams
type | ForceFieldFalloffParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ForceFieldModuleParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ForceFieldModuleParams Struct Reference

Describes the NxParameterized::Interface for 'ForceFieldModuleParams' : More...

#include <params.h>

List of all members.

Public Attributes

U32 unused
'unused' : No parameters necessary

Detailed Description

Describes the NxParameterized::Interface for 'ForceFieldModuleParams' :

ForceFieldModuleParams contains 1 fully qualified names
---------------------------------------------
  1 : U32  unused

Member Data Documentation

U32 ForceFieldModuleParams::unused

'unused' : No parameters necessary

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ForceFieldModuleParams Member List
This is the complete list of members for ForceFieldModuleParams, including all inherited members.
unused ForceFieldModuleParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ForceFieldNoiseParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ForceFieldNoiseParams Struct Reference

Describes the NxParameterized::Interface for 'ForceFieldNoiseParams' : More...

#include <params.h>

List of all members.

Public Attributes

F32 | strength
'strength' : Noise strength value
F32 | spaceScale
'spaceScale' : Noise space scale value
F32 | timeScale
'timeScale' : Noise time scale value
U32 | octaves
'octaves' : Number of noise octaves

Detailed Description

Describes the NxParameterized::Interface for 'ForceFieldNoiseParams' :

ForceFieldNoiseParams contains 4 fully qualified names
---------------------------------------------
  1 : F32  strength
  2 : F32  spaceScale
  3 : F32  timeScale
  4 : U32  octaves

Member Data Documentation

U32 ForceFieldNoiseParams::octaves

'octaves' : Number of noise octaves

F32 ForceFieldNoiseParams::spaceScale

'spaceScale' : Noise space scale value

F32 ForceFieldNoiseParams::strength

'strength' : Noise strength value

F32 ForceFieldNoiseParams::timeScale

'timeScale' : Noise time scale value

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ForceFieldNoiseParams Member List
This is the complete list of members for ForceFieldNoiseParams, including all inherited members.
octaves | ForceFieldNoiseParams
spaceScale | ForceFieldNoiseParams
strength | ForceFieldNoiseParams
timeScale | ForceFieldNoiseParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: GenericForceFieldKernelParams Struct Reference

  • Class List
  • Class Members
Public Attributes
GenericForceFieldKernelParams Struct Reference

Describes the NxParameterized::Interface for 'GenericForceFieldKernelParams' : Generic force field kernel is needed for backward compatibility with NxForceFieldKernel (PhysX 2.8.4). More...

#include <params.h>

List of all members.

Public Attributes

Type coordinateSystemParameters.type
'coordinateSystemParameters.type' : Coordinate system type
F32 | coordinateSystemParameters.torusRadius
'coordinateSystemParameters.torusRadius' : Radius for toroidal type coordinates. For other types of coordinates not used.
Vec3 | constant
'constant' : Constant part of force field function
Mat33 | positionMultiplier
'positionMultiplier' : Coefficient of force field function position term
Vec3 | positionTarget
'positionTarget' : Force field position target
Mat33 | velocityMultiplier
'velocityMultiplier' : Coefficient of force field function velocity term
Vec3 | velocityTarget
'velocityTarget' : Force field velocity target
Vec3 | noise
'noise' : Noise scaling
Vec3 | falloffLinear
'falloffLinear' : Linear term in magnitude falloff factor. Range (each component): [0, inf)
Vec3 | falloffQuadratic
'falloffQuadratic' : Quadratic term in magnitude falloff factor. Range (each component): [0, inf)

Detailed Description

Describes the NxParameterized::Interface for 'GenericForceFieldKernelParams' : Generic force field kernel is needed for backward compatibility with NxForceFieldKernel (PhysX 2.8.4).

GenericForceFieldKernelParams contains 10 fully qualified names
---------------------------------------------
  1 : Type   coordinateSystemParameters.type
  2 : F32    coordinateSystemParameters.torusRadius
  3 : Vec3   constant
  4 : Mat33  positionMultiplier
  5 : Vec3   positionTarget
  6 : Mat33  velocityMultiplier
  7 : Vec3   velocityTarget
  8 : Vec3   noise
  9 : Vec3   falloffLinear
 10 : Vec3   falloffQuadratic

Member Data Documentation

Vec3 GenericForceFieldKernelParams::constant

'constant' : Constant part of force field function

F32 GenericForceFieldKernelParams::coordinateSystemParameters.torusRadius

'coordinateSystemParameters.torusRadius' : Radius for toroidal type coordinates. For other types of coordinates not used.

Type GenericForceFieldKernelParams::coordinateSystemParameters.type

'coordinateSystemParameters.type' : Coordinate system type

Vec3 GenericForceFieldKernelParams::falloffLinear

'falloffLinear' : Linear term in magnitude falloff factor. Range (each component): [0, inf)

Vec3 GenericForceFieldKernelParams::falloffQuadratic

'falloffQuadratic' : Quadratic term in magnitude falloff factor. Range (each component): [0, inf)

Vec3 GenericForceFieldKernelParams::noise

'noise' : Noise scaling

Mat33 GenericForceFieldKernelParams::positionMultiplier

'positionMultiplier' : Coefficient of force field function position term

Vec3 GenericForceFieldKernelParams::positionTarget

'positionTarget' : Force field position target

Mat33 GenericForceFieldKernelParams::velocityMultiplier

'velocityMultiplier' : Coefficient of force field function velocity term

Vec3 GenericForceFieldKernelParams::velocityTarget

'velocityTarget' : Force field velocity target

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
GenericForceFieldKernelParams Member List
This is the complete list of members for GenericForceFieldKernelParams, including all inherited members.
constant | GenericForceFieldKernelParams
coordinateSystemParameters.torusRadius | GenericForceFieldKernelParams
coordinateSystemParameters.type | GenericForceFieldKernelParams
falloffLinear | GenericForceFieldKernelParams
falloffQuadratic | GenericForceFieldKernelParams
noise | GenericForceFieldKernelParams
positionMultiplier | GenericForceFieldKernelParams
positionTarget | GenericForceFieldKernelParams
velocityMultiplier | GenericForceFieldKernelParams
velocityTarget | GenericForceFieldKernelParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: GraphicsEffectData Struct Reference

  • Class List
  • Class Members
Public Attributes
GraphicsEffectData Struct Reference

Describes the NxParameterized::Interface for 'GraphicsEffectData' : Contains the asset properties for this graphics effect (IOFX) More...

#include <params.h>

List of all members.

Public Attributes

String Name
'Name' : Sprite IOFX Name
IofxAssetParameters IOFX
'IOFX' :

Detailed Description

Describes the NxParameterized::Interface for 'GraphicsEffectData' : Contains the asset properties for this graphics effect (IOFX)

GraphicsEffectData contains 148 fully qualified names
---------------------------------------------
  1 : String         Name
  2 : ArraySizeName  IOFX.iofxType.renderMeshList                                           RefVariant[MeshIofxParameters]
  3 : Ref            IOFX.iofxType.renderMeshList[].meshAssetName                           RefVariant[MeshIofxParameters]
  4 : U32            IOFX.iofxType.renderMeshList[].weight                                  RefVariant[MeshIofxParameters]
  5 : ArraySizeName  IOFX.iofxType.spawnModifierList                                        RefVariant[MeshIofxParameters]
  6 : RollType       IOFX.iofxType.spawnModifierList[].rollType                             RefVariant[RotationModifierParams]
  7 : F32            IOFX.iofxType.spawnModifierList[].maxRotationRatePerSec                RefVariant[RotationModifierParams]
  8 : F32            IOFX.iofxType.spawnModifierList[].maxSettleRatePerSec                  RefVariant[RotationModifierParams]
  9 : F32            IOFX.iofxType.spawnModifierList[].inAirRotationMultiplier              RefVariant[RotationModifierParams]
 10 : F32            IOFX.iofxType.spawnModifierList[].collisionRotationMultiplier          RefVariant[RotationModifierParams]
 11 : Bool           IOFX.iofxType.spawnModifierList[].includeVerticalDirection             RefVariant[RotationModifierParams]
 12 : Vec3           IOFX.iofxType.spawnModifierList[].scaleFactor                          RefVariant[SimpleScaleModifierParams]
 13 : F32            IOFX.iofxType.spawnModifierList[].minScaleFactor                       RefVariant[RandomScaleModifierParams]
 14 : F32            IOFX.iofxType.spawnModifierList[].maxScaleFactor                       RefVariant[RandomScaleModifierParams]
 15 : Vec4           IOFX.iofxType.spawnModifierList[].color                                RefVariant[InitialColorModifierParams]
 16 : ArraySizeName  IOFX.iofxType.continuousModifierList                                   RefVariant[MeshIofxParameters]
 17 : RollType       IOFX.iofxType.continuousModifierList[].rollType                        RefVariant[RotationModifierParams]
 18 : F32            IOFX.iofxType.continuousModifierList[].maxRotationRatePerSec           RefVariant[RotationModifierParams]
 19 : F32            IOFX.iofxType.continuousModifierList[].maxSettleRatePerSec             RefVariant[RotationModifierParams]
 20 : F32            IOFX.iofxType.continuousModifierList[].inAirRotationMultiplier         RefVariant[RotationModifierParams]
 21 : F32            IOFX.iofxType.continuousModifierList[].collisionRotationMultiplier     RefVariant[RotationModifierParams]
 22 : Bool           IOFX.iofxType.continuousModifierList[].includeVerticalDirection        RefVariant[RotationModifierParams]
 23 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsLife3DModifierParams]
 24 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ScaleVsLife3DModifierParams]
 25 : Vec3           IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsLife3DModifierParams]
 26 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensity3DModifierParams]
 27 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].density         RefVariant[ScaleVsDensity3DModifierParams]
 28 : Vec3           IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsDensity3DModifierParams]
 29 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperature3DModifierParams]
 30 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].temperature     RefVariant[ScaleVsTemperature3DModifierParams]
 31 : Vec3           IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsTemperature3DModifierParams]
 32 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistance3DModifierParams]
 33 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].cameraDistance  RefVariant[ScaleVsCameraDistance3DModifierParams]
 34 : Vec3           IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsCameraDistance3DModifierParams]
 35 : Vec3           IOFX.iofxType.continuousModifierList[].modelForward                    RefVariant[OrientAlongVelocityModifierParams]
 36 : F32            IOFX.iofxType.continuousModifierList[].scaleFactor                     RefVariant[ScaleAlongVelocityModifierParams]
 37 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsLifeCompositeModifierParams]
 38 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ColorVsLifeCompositeModifierParams]
 39 : Vec4           IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsLifeCompositeModifierParams]
 40 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsDensityCompositeModifierParams]
 41 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].density         RefVariant[ColorVsDensityCompositeModifierParams]
 42 : Vec4           IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsDensityCompositeModifierParams]
 43 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsTemperatureCompositeModifierParams]
 44 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].temperature     RefVariant[ColorVsTemperatureCompositeModifierParams]
 45 : Vec4           IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsTemperatureCompositeModifierParams]
 46 : ScaleAxis      IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsLifeModifierParams]
 47 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsLifeModifierParams]
 48 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsLifeModifierParams]
 49 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsLifeModifierParams]
 50 : ScaleAxis      IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsDensityModifierParams]
 51 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensityModifierParams]
 52 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsDensityModifierParams]
 53 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsDensityModifierParams]
 54 : ScaleAxis      IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsTemperatureModifierParams]
 55 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperatureModifierParams]
 56 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsTemperatureModifierParams]
 57 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsTemperatureModifierParams]
 58 : ScaleAxis      IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsCameraDistanceModifierParams]
 59 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistanceModifierParams]
 60 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsCameraDistanceModifierParams]
 61 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsCameraDistanceModifierParams]
 62 : F32            IOFX.iofxType.continuousModifierList[].velocity0                       RefVariant[ColorVsVelocityCompositeModifierParams]
 63 : F32            IOFX.iofxType.continuousModifierList[].velocity1                       RefVariant[ColorVsVelocityCompositeModifierParams]
 64 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsVelocityCompositeModifierParams]
 65 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].velocity        RefVariant[ColorVsVelocityCompositeModifierParams]
 66 : Vec4           IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsVelocityCompositeModifierParams]
 67 : Ref            IOFX.iofxType.spriteMaterialName                                       RefVariant[SpriteIofxParameters]
 68 : ArraySizeName  IOFX.iofxType.spawnModifierList                                        RefVariant[SpriteIofxParameters]
 69 : Vec3           IOFX.iofxType.spawnModifierList[].scaleFactor                          RefVariant[SimpleScaleModifierParams]
 70 : F32            IOFX.iofxType.spawnModifierList[].minScaleFactor                       RefVariant[RandomScaleModifierParams]
 71 : F32            IOFX.iofxType.spawnModifierList[].maxScaleFactor                       RefVariant[RandomScaleModifierParams]
 72 : Vec4           IOFX.iofxType.spawnModifierList[].color                                RefVariant[InitialColorModifierParams]
 73 : F32            IOFX.iofxType.spawnModifierList[].minSubtexture                        RefVariant[RandomSubtextureModifierParams]
 74 : F32            IOFX.iofxType.spawnModifierList[].maxSubtexture                        RefVariant[RandomSubtextureModifierParams]
 75 : F32            IOFX.iofxType.spawnModifierList[].minRotation                          RefVariant[RandomRotationModifierParams]
 76 : F32            IOFX.iofxType.spawnModifierList[].maxRotation                          RefVariant[RandomRotationModifierParams]
 77 : ColorChannel   IOFX.iofxType.spawnModifierList[].colorChannel                         RefVariant[ColorVsLifeModifierParams]
 78 : ArraySizeName  IOFX.iofxType.spawnModifierList[].controlPoints                        RefVariant[ColorVsLifeModifierParams]
 79 : F32            IOFX.iofxType.spawnModifierList[].controlPoints[].x                    RefVariant[ColorVsLifeModifierParams]
 80 : F32            IOFX.iofxType.spawnModifierList[].controlPoints[].y                    RefVariant[ColorVsLifeModifierParams]
 81 : ArraySizeName  IOFX.iofxType.continuousModifierList                                   RefVariant[SpriteIofxParameters]
 82 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsLifeCompositeModifierParams]
 83 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ColorVsLifeCompositeModifierParams]
 84 : Vec4           IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsLifeCompositeModifierParams]
 85 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsDensityCompositeModifierParams]
 86 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].density         RefVariant[ColorVsDensityCompositeModifierParams]
 87 : Vec4           IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsDensityCompositeModifierParams]
 88 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsTemperatureCompositeModifierParams]
 89 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].temperature     RefVariant[ColorVsTemperatureCompositeModifierParams]
 90 : Vec4           IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsTemperatureCompositeModifierParams]
 91 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsLife2DModifierParams]
 92 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ScaleVsLife2DModifierParams]
 93 : Vec2           IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsLife2DModifierParams]
 94 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensity2DModifierParams]
 95 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].density         RefVariant[ScaleVsDensity2DModifierParams]
 96 : Vec2           IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsDensity2DModifierParams]
 97 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperature2DModifierParams]
 98 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].temperature     RefVariant[ScaleVsTemperature2DModifierParams]
 99 : Vec2           IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsTemperature2DModifierParams]
100 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistance2DModifierParams]
101 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].cameraDistance  RefVariant[ScaleVsCameraDistance2DModifierParams]
102 : Vec2           IOFX.iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsCameraDistance2DModifierParams]
103 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[SubtextureVsLifeModifierParams]
104 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[SubtextureVsLifeModifierParams]
105 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[SubtextureVsLifeModifierParams]
106 : SortType       IOFX.iofxType.continuousModifierList[].sortType                        RefVariant[ViewDirectionSortingModifierParams]
107 : ColorChannel   IOFX.iofxType.continuousModifierList[].colorChannel                    RefVariant[ColorVsLifeModifierParams]
108 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsLifeModifierParams]
109 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ColorVsLifeModifierParams]
110 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ColorVsLifeModifierParams]
111 : ColorChannel   IOFX.iofxType.continuousModifierList[].colorChannel                    RefVariant[ColorVsDensityModifierParams]
112 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsDensityModifierParams]
113 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ColorVsDensityModifierParams]
114 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ColorVsDensityModifierParams]
115 : ColorChannel   IOFX.iofxType.continuousModifierList[].colorChannel                    RefVariant[ColorVsTemperatureModifierParams]
116 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsTemperatureModifierParams]
117 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ColorVsTemperatureModifierParams]
118 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ColorVsTemperatureModifierParams]
119 : ScaleAxis      IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsLifeModifierParams]
120 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsLifeModifierParams]
121 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsLifeModifierParams]
122 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsLifeModifierParams]
123 : ScaleAxis      IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsDensityModifierParams]
124 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensityModifierParams]
125 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsDensityModifierParams]
126 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsDensityModifierParams]
127 : ScaleAxis      IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsTemperatureModifierParams]
128 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperatureModifierParams]
129 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsTemperatureModifierParams]
130 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsTemperatureModifierParams]
131 : ScaleAxis      IOFX.iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsCameraDistanceModifierParams]
132 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistanceModifierParams]
133 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsCameraDistanceModifierParams]
134 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsCameraDistanceModifierParams]
135 : F32            IOFX.iofxType.continuousModifierList[].rotationRate                    RefVariant[RotationRateModifierParams]
136 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[RotationRateVsLifeModifierParams]
137 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].x               RefVariant[RotationRateVsLifeModifierParams]
138 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].y               RefVariant[RotationRateVsLifeModifierParams]
139 : F32            IOFX.iofxType.continuousModifierList[].scalePerVelocity                RefVariant[OrientScaleAlongScreenVelocityModifierParams]
140 : F32            IOFX.iofxType.continuousModifierList[].scaleChangeLimit                RefVariant[OrientScaleAlongScreenVelocityModifierParams]
141 : F32            IOFX.iofxType.continuousModifierList[].scaleChangeDelay                RefVariant[OrientScaleAlongScreenVelocityModifierParams]
142 : F32            IOFX.iofxType.continuousModifierList[].velocity0                       RefVariant[ColorVsVelocityCompositeModifierParams]
143 : F32            IOFX.iofxType.continuousModifierList[].velocity1                       RefVariant[ColorVsVelocityCompositeModifierParams]
144 : ArraySizeName  IOFX.iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsVelocityCompositeModifierParams]
145 : F32            IOFX.iofxType.continuousModifierList[].controlPoints[].velocity        RefVariant[ColorVsVelocityCompositeModifierParams]
146 : Vec4           IOFX.iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsVelocityCompositeModifierParams]
147 : Bool           IOFX.renderOutput.useUserSemantic                                      RefVariant[IofxAssetParameters]
148 : Bool           IOFX.renderOutput.useFloat4Color                                       RefVariant[IofxAssetParameters]

Member Data Documentation

IofxAssetParameters GraphicsEffectData::IOFX

'IOFX' :

String GraphicsEffectData::Name

'Name' : Sprite IOFX Name

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
GraphicsEffectData Member List
This is the complete list of members for GraphicsEffectData, including all inherited members.
IOFX | GraphicsEffectData
Name | GraphicsEffectData
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: GraphicsMaterialData Struct Reference

  • Class List
  • Class Members
Public Attributes
GraphicsMaterialData Struct Reference

Describes the NxParameterized::Interface for 'GraphicsMaterialData' : Contains the asset properties for this graphics material. More...

#include <params.h>

List of all members.

Public Attributes

String | Name
'Name' : The name of this graphics material
String | ApplicationMaterialName
'ApplicationMaterialName' : The name of the material to match up with the application's material system
String | UserProperties
'UserProperties' : Optional user properties string
RenderTechnique RenderTechnique
'RenderTechnique' : Which sprite rendering technique to apply
String | DiffuseTexture
'DiffuseTexture' : The diffuse source texture to render the sprite with.
U32 | CellColumn
'CellColumn' : The number of columns in the celled texture
U32 | CellRow
'CellRow' : The number of rows in the celled texture
U32 | CellCount
'CellCount' : The total number of frames in the celled animation
Bool | CrossBlend
'CrossBlend' : True if cross blending celled animated sprites
F32 | ColorMultiplier
'ColorMultiplier' : Multiply this constant times the output color
Bool | UsePSM
'UsePSM' : Whether or not to use the PSM pipeline or not
Resolution Resolution
'Resolution' : Whether or not to use full-res, half-res, quarter res, or multi-resoluation particle rendering
U32 | FullResPercent
'FullResPercent' : Percentage of particles to render at full resolution, is using the multi-res feature
U32 | HalfResPercent
'HalfResPercent' : Percentage of particles to reunder at half-resolution; remaining percentage maps to quarter resolution if rendering using the multi-res feature
F32 | PSM_ShadowBias
'PSM_ShadowBias' : Helpful ToolTip goes here
Bool | PSM_Frustum.ShowFrustum
'PSM_Frustum.ShowFrustum' : Debug visualize the frustum
F32 | PSM_Frustum.FrustumDepth
'PSM_Frustum.FrustumDepth' : The depth to use to build the non-orthographic projection
F32 | PSM_Frustum.FrustumSize
'PSM_Frustum.FrustumSize' : The overall bounding volume width/height to use to compute the PSM view frustum

Detailed Description

Describes the NxParameterized::Interface for 'GraphicsMaterialData' : Contains the asset properties for this graphics material.

GraphicsMaterialData contains 18 fully qualified names
---------------------------------------------
  1 : String           Name
  2 : String           ApplicationMaterialName
  3 : String           UserProperties
  4 : RenderTechnique  RenderTechnique
  5 : String           DiffuseTexture
  6 : U32              CellColumn
  7 : U32              CellRow
  8 : U32              CellCount
  9 : Bool             CrossBlend
 10 : F32              ColorMultiplier
 11 : Bool             UsePSM
 12 : Resolution       Resolution
 13 : U32              FullResPercent
 14 : U32              HalfResPercent
 15 : F32              PSM_ShadowBias
 16 : Bool             PSM_Frustum.ShowFrustum
 17 : F32              PSM_Frustum.FrustumDepth
 18 : F32              PSM_Frustum.FrustumSize

Member Data Documentation

String GraphicsMaterialData::ApplicationMaterialName

'ApplicationMaterialName' : The name of the material to match up with the application's material system

U32 GraphicsMaterialData::CellColumn

'CellColumn' : The number of columns in the celled texture

U32 GraphicsMaterialData::CellCount

'CellCount' : The total number of frames in the celled animation

U32 GraphicsMaterialData::CellRow

'CellRow' : The number of rows in the celled texture

F32 GraphicsMaterialData::ColorMultiplier

'ColorMultiplier' : Multiply this constant times the output color

Bool GraphicsMaterialData::CrossBlend

'CrossBlend' : True if cross blending celled animated sprites

String GraphicsMaterialData::DiffuseTexture

'DiffuseTexture' : The diffuse source texture to render the sprite with.

U32 GraphicsMaterialData::FullResPercent

'FullResPercent' : Percentage of particles to render at full resolution, is using the multi-res feature

U32 GraphicsMaterialData::HalfResPercent

'HalfResPercent' : Percentage of particles to reunder at half-resolution; remaining percentage maps to quarter resolution if rendering using the multi-res feature

String GraphicsMaterialData::Name

'Name' : The name of this graphics material

F32 GraphicsMaterialData::PSM_Frustum.FrustumDepth

'PSM_Frustum.FrustumDepth' : The depth to use to build the non-orthographic projection

F32 GraphicsMaterialData::PSM_Frustum.FrustumSize

'PSM_Frustum.FrustumSize' : The overall bounding volume width/height to use to compute the PSM view frustum

Bool GraphicsMaterialData::PSM_Frustum.ShowFrustum

'PSM_Frustum.ShowFrustum' : Debug visualize the frustum

F32 GraphicsMaterialData::PSM_ShadowBias

'PSM_ShadowBias' : Helpful ToolTip goes here

RenderTechnique GraphicsMaterialData::RenderTechnique

'RenderTechnique' : Which sprite rendering technique to apply

Resolution GraphicsMaterialData::Resolution

'Resolution' : Whether or not to use full-res, half-res, quarter res, or multi-resoluation particle rendering

Bool GraphicsMaterialData::UsePSM

'UsePSM' : Whether or not to use the PSM pipeline or not

String GraphicsMaterialData::UserProperties

'UserProperties' : Optional user properties string

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
GraphicsMaterialData Member List
This is the complete list of members for GraphicsMaterialData, including all inherited members.
ApplicationMaterialName | GraphicsMaterialData
CellColumn | GraphicsMaterialData
CellCount | GraphicsMaterialData
CellRow | GraphicsMaterialData
ColorMultiplier | GraphicsMaterialData
CrossBlend | GraphicsMaterialData
DiffuseTexture | GraphicsMaterialData
FullResPercent | GraphicsMaterialData
HalfResPercent | GraphicsMaterialData
Name | GraphicsMaterialData
PSM_Frustum.FrustumDepth | GraphicsMaterialData
PSM_Frustum.FrustumSize | GraphicsMaterialData
PSM_Frustum.ShowFrustum | GraphicsMaterialData
PSM_ShadowBias | GraphicsMaterialData
RenderTechnique | GraphicsMaterialData
Resolution | GraphicsMaterialData
UsePSM | GraphicsMaterialData
UserProperties | GraphicsMaterialData
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: GroundEmitterActorParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
GroundEmitterActorParameters Struct Reference

Describes the NxParameterized::Interface for 'GroundEmitterActorParameters' : This class is used for creating NxGroundEmitterActor instances. More...

#include <params.h>

List of all members.

Public Attributes

F32 | densityRange.min
'densityRange.min' : Minimum (scalar value)
F32 | densityRange.max
'densityRange.max' : Maximum (scalar value)
F32 | radius
'radius' : Radius
Vec3 | upDirection
'upDirection' : Up Direction
F32 | raycastHeight
'raycastHeight' : Raycast Height
F32 | spawnHeight
'spawnHeight' : Spawn Height
U32 | maxRaycastsPerFrame
'maxRaycastsPerFrame' : Maximum Raycasts per Frame
String | raycastCollisionGroupMaskName
'raycastCollisionGroupMaskName' : Raycast Collision Group Mask Name
Vec3 | attachRelativePosition
'attachRelativePosition' : Attach Relative Position
Mat34 | globalPose
'globalPose' : The actor's pose

Detailed Description

Describes the NxParameterized::Interface for 'GroundEmitterActorParameters' : This class is used for creating NxGroundEmitterActor instances.

GroundEmitterActorParameters contains 10 fully qualified names
---------------------------------------------
  1 : F32     densityRange.min
  2 : F32     densityRange.max
  3 : F32     radius
  4 : Vec3    upDirection
  5 : F32     raycastHeight
  6 : F32     spawnHeight
  7 : U32     maxRaycastsPerFrame
  8 : String  raycastCollisionGroupMaskName
  9 : Vec3    attachRelativePosition
 10 : Mat34   globalPose

Member Data Documentation

Vec3 GroundEmitterActorParameters::attachRelativePosition

'attachRelativePosition' : Attach Relative Position

The ground emitter will offset this value from the attach actor position.

F32 GroundEmitterActorParameters::densityRange.max

'densityRange.max' : Maximum (scalar value)

F32 GroundEmitterActorParameters::densityRange.min

'densityRange.min' : Minimum (scalar value)

Mat34 GroundEmitterActorParameters::globalPose

'globalPose' : The actor's pose

An identity rotation matrix will result in a +Y up ground emitter, provide a rotation if another orientation is desired.

U32 GroundEmitterActorParameters::maxRaycastsPerFrame

'maxRaycastsPerFrame' : Maximum Raycasts per Frame

The maximum raycasts per frame.

F32 GroundEmitterActorParameters::radius

'radius' : Radius

The ground emitter actor will create objects within a circle of size 'radius'.

String GroundEmitterActorParameters::raycastCollisionGroupMaskName

'raycastCollisionGroupMaskName' : Raycast Collision Group Mask Name

This name resolves to a 32-bit bitmask of collision groups for raycasts around the player. It is resolved by a call to the named resource provider using the 'NSCollisionGroupMask' and 'NSCollisionGroup128' namespaces. If none is provided, the raycast will hit everything in the scene. This avoids storing fragile enums in asset files.

F32 GroundEmitterActorParameters::raycastHeight

'raycastHeight' : Raycast Height

The height from which the ground emitter will cast rays at terrain/objects opposite of the 'upDirection'.

F32 GroundEmitterActorParameters::spawnHeight

'spawnHeight' : Spawn Height

The height above the ground to emit particles. If greater than 0, the ground emitter will refresh a disc above the player's position rather than refreshing a circle around the player's position.

Vec3 GroundEmitterActorParameters::upDirection

'upDirection' : Up Direction

The ground emitter asset needs to know what direction is 'up'.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
GroundEmitterActorParameters Member List
This is the complete list of members for GroundEmitterActorParameters, including all inherited members.
attachRelativePosition | GroundEmitterActorParameters
densityRange.max | GroundEmitterActorParameters
densityRange.min | GroundEmitterActorParameters
globalPose | GroundEmitterActorParameters
maxRaycastsPerFrame | GroundEmitterActorParameters
radius | GroundEmitterActorParameters
raycastCollisionGroupMaskName | GroundEmitterActorParameters
raycastHeight | GroundEmitterActorParameters
spawnHeight | GroundEmitterActorParameters
upDirection | GroundEmitterActorParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: GroundEmitterAssetParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
GroundEmitterAssetParameters Struct Reference

Describes the NxParameterized::Interface for 'GroundEmitterAssetParameters' : This class is parameter storage for the NxGroundEmitterAsset. More...

#include <params.h>

List of all members.

Public Attributes

F32 | densityRange.min
'densityRange.min' : Helpful documentation goes here
F32 | densityRange.max
'densityRange.max' : Helpful documentation goes here
Vec3 | velocityRange.min
'velocityRange.min' : Helpful documentation goes here
Vec3 | velocityRange.max
'velocityRange.max' : Helpful documentation goes here
F32 | lifetimeRange.min
'lifetimeRange.min' : Helpful documentation goes here
F32 | lifetimeRange.max
'lifetimeRange.max' : Helpful documentation goes here
F32 | radius
'radius' : Radius
F32 | raycastHeight
'raycastHeight' : Raycast Height
F32 | spawnHeight
'spawnHeight' : Spawn Height
U32 | maxRaycastsPerFrame
'maxRaycastsPerFrame' : Maximum Raycasts per Frame
String | raycastCollisionGroupMaskName
'raycastCollisionGroupMaskName' : Raycast Collision Group Mask Name
Ref | materialFactoryMapList[].iofxAssetName
'materialFactoryMapList[].iofxAssetName' : The name of the instanced object effects asset that will render your particles
Ref | materialFactoryMapList[].iosAssetName
'materialFactoryMapList[].iosAssetName' : The asset name of the particle system that will simulate your particles
String | materialFactoryMapList[].physMatName
'materialFactoryMapList[].physMatName' : User defined material name. The ground emitter will convert this name into an * NxMaterialID at runtime by a getResource() call to the named resource provider under the namespace "NSPhysicalMaterial" * Note this is the physical material, not rendering material.
F32 | materialFactoryMapList[].weight
'materialFactoryMapList[].weight' : The weight of this factory relative to other factories on the same material
F32 | materialFactoryMapList[].maxSlopeAngle
'materialFactoryMapList[].maxSlopeAngle' : The maximum slope at which particles will be added to the surface in degrees where 0 is horizontal and 90 is vertical.
U32 | materialFactoryMapList[].lodParamDesc.version
'materialFactoryMapList[].lodParamDesc.version' : Helpful documentation goes here
F32 | materialFactoryMapList[].lodParamDesc.maxDistance
'materialFactoryMapList[].lodParamDesc.maxDistance' : Objects greater than this distance from the player will be culled more aggressively
F32 | materialFactoryMapList[].lodParamDesc.distanceWeight
'materialFactoryMapList[].lodParamDesc.distanceWeight' : Weight given to distance parameter in LOD function
F32 | materialFactoryMapList[].lodParamDesc.speedWeight
'materialFactoryMapList[].lodParamDesc.speedWeight' : Weight given to velocity parameter in LOD function
F32 | materialFactoryMapList[].lodParamDesc.lifeWeight
'materialFactoryMapList[].lodParamDesc.lifeWeight' : Weight given to life remain parameter in LOD function
F32 | materialFactoryMapList[].lodParamDesc.separationWeight
'materialFactoryMapList[].lodParamDesc.separationWeight' : Weight given to separation parameter in LOD function
F32 | materialFactoryMapList[].lodParamDesc.bias
'materialFactoryMapList[].lodParamDesc.bias' : Bias given to objects spawned by this emitter, relative to other emitters in the same IOS

Detailed Description

Describes the NxParameterized::Interface for 'GroundEmitterAssetParameters' : This class is parameter storage for the NxGroundEmitterAsset.

GroundEmitterAssetParameters contains 24 fully qualified names
---------------------------------------------
  1 : F32            densityRange.min
  2 : F32            densityRange.max
  3 : Vec3           velocityRange.min
  4 : Vec3           velocityRange.max
  5 : F32            lifetimeRange.min
  6 : F32            lifetimeRange.max
  7 : F32            radius
  8 : F32            raycastHeight
  9 : F32            spawnHeight
 10 : U32            maxRaycastsPerFrame
 11 : String         raycastCollisionGroupMaskName
 12 : ArraySizeName  materialFactoryMapList
 13 : Ref            materialFactoryMapList[].iofxAssetName
 14 : Ref            materialFactoryMapList[].iosAssetName
 15 : String         materialFactoryMapList[].physMatName
 16 : F32            materialFactoryMapList[].weight
 17 : F32            materialFactoryMapList[].maxSlopeAngle
 18 : U32            materialFactoryMapList[].lodParamDesc.version
 19 : F32            materialFactoryMapList[].lodParamDesc.maxDistance
 20 : F32            materialFactoryMapList[].lodParamDesc.distanceWeight
 21 : F32            materialFactoryMapList[].lodParamDesc.speedWeight
 22 : F32            materialFactoryMapList[].lodParamDesc.lifeWeight
 23 : F32            materialFactoryMapList[].lodParamDesc.separationWeight
 24 : F32            materialFactoryMapList[].lodParamDesc.bias

Member Data Documentation

F32 GroundEmitterAssetParameters::densityRange.max

'densityRange.max' : Helpful documentation goes here

F32 GroundEmitterAssetParameters::densityRange.min

'densityRange.min' : Helpful documentation goes here

F32 GroundEmitterAssetParameters::lifetimeRange.max

'lifetimeRange.max' : Helpful documentation goes here

F32 GroundEmitterAssetParameters::lifetimeRange.min

'lifetimeRange.min' : Helpful documentation goes here

Ref GroundEmitterAssetParameters::materialFactoryMapList[].iofxAssetName

'materialFactoryMapList[].iofxAssetName' : The name of the instanced object effects asset that will render your particles

Ref GroundEmitterAssetParameters::materialFactoryMapList[].iosAssetName

'materialFactoryMapList[].iosAssetName' : The asset name of the particle system that will simulate your particles

F32 GroundEmitterAssetParameters::materialFactoryMapList[].lodParamDesc.bias

'materialFactoryMapList[].lodParamDesc.bias' : Bias given to objects spawned by this emitter, relative to other emitters in the same IOS

F32 GroundEmitterAssetParameters::materialFactoryMapList[].lodParamDesc.distanceWeight

'materialFactoryMapList[].lodParamDesc.distanceWeight' : Weight given to distance parameter in LOD function

F32 GroundEmitterAssetParameters::materialFactoryMapList[].lodParamDesc.lifeWeight

'materialFactoryMapList[].lodParamDesc.lifeWeight' : Weight given to life remain parameter in LOD function

F32 GroundEmitterAssetParameters::materialFactoryMapList[].lodParamDesc.maxDistance

'materialFactoryMapList[].lodParamDesc.maxDistance' : Objects greater than this distance from the player will be culled more aggressively

F32 GroundEmitterAssetParameters::materialFactoryMapList[].lodParamDesc.separationWeight

'materialFactoryMapList[].lodParamDesc.separationWeight' : Weight given to separation parameter in LOD function

F32 GroundEmitterAssetParameters::materialFactoryMapList[].lodParamDesc.speedWeight

'materialFactoryMapList[].lodParamDesc.speedWeight' : Weight given to velocity parameter in LOD function

U32 GroundEmitterAssetParameters::materialFactoryMapList[].lodParamDesc.version

'materialFactoryMapList[].lodParamDesc.version' : Helpful documentation goes here

F32 GroundEmitterAssetParameters::materialFactoryMapList[].maxSlopeAngle

'materialFactoryMapList[].maxSlopeAngle' : The maximum slope at which particles will be added to the surface in degrees where 0 is horizontal and 90 is vertical.

String GroundEmitterAssetParameters::materialFactoryMapList[].physMatName

'materialFactoryMapList[].physMatName' : User defined material name. The ground emitter will convert this name into an * NxMaterialID at runtime by a getResource() call to the named resource provider under the namespace "NSPhysicalMaterial" * Note this is the physical material, not rendering material.

F32 GroundEmitterAssetParameters::materialFactoryMapList[].weight

'materialFactoryMapList[].weight' : The weight of this factory relative to other factories on the same material

U32 GroundEmitterAssetParameters::maxRaycastsPerFrame

'maxRaycastsPerFrame' : Maximum Raycasts per Frame

The maximum raycasts per frame.

F32 GroundEmitterAssetParameters::radius

'radius' : Radius

The ground emitter actor will create objects within a circle of size 'radius'.

String GroundEmitterAssetParameters::raycastCollisionGroupMaskName

'raycastCollisionGroupMaskName' : Raycast Collision Group Mask Name

Defines a bitmask of collision groups for the raycasts around the player. If none is provided, the raycast will hit everything in the scene. This name will be resolved into a bitmask of collision group IDs by a call to the named resource provider using both the 'NSCollisionGroupMask' and 'NSCollisionGroup128' namespaces. This avoids storing fragile enums in asset files. The collision groups and collision group mask and 128 bit NxGroupsMask can be set directly on NxGroundEmitterActors.

F32 GroundEmitterAssetParameters::raycastHeight

'raycastHeight' : Raycast Height

The height from which the ground emitter will cast rays at terrain/objects opposite of the 'upDirection'.

F32 GroundEmitterAssetParameters::spawnHeight

'spawnHeight' : Spawn Height

The height above the ground to emit particles. If greater than 0, the ground emitter will refresh a disc above the player's position rather than refreshing a circle around the player's position.

Vec3 GroundEmitterAssetParameters::velocityRange.max

'velocityRange.max' : Helpful documentation goes here

Vec3 GroundEmitterAssetParameters::velocityRange.min

'velocityRange.min' : Helpful documentation goes here

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
GroundEmitterAssetParameters Member List
This is the complete list of members for GroundEmitterAssetParameters, including all inherited members.
densityRange.max | GroundEmitterAssetParameters
densityRange.min | GroundEmitterAssetParameters
lifetimeRange.max | GroundEmitterAssetParameters
lifetimeRange.min | GroundEmitterAssetParameters
materialFactoryMapList[].iofxAssetName | GroundEmitterAssetParameters
materialFactoryMapList[].iosAssetName | GroundEmitterAssetParameters
materialFactoryMapList[].lodParamDesc.bias | GroundEmitterAssetParameters
materialFactoryMapList[].lodParamDesc.distanceWeight | GroundEmitterAssetParameters
materialFactoryMapList[].lodParamDesc.lifeWeight | GroundEmitterAssetParameters
materialFactoryMapList[].lodParamDesc.maxDistance | GroundEmitterAssetParameters
materialFactoryMapList[].lodParamDesc.separationWeight | GroundEmitterAssetParameters
materialFactoryMapList[].lodParamDesc.speedWeight | GroundEmitterAssetParameters
materialFactoryMapList[].lodParamDesc.version | GroundEmitterAssetParameters
materialFactoryMapList[].maxSlopeAngle | GroundEmitterAssetParameters
materialFactoryMapList[].physMatName | GroundEmitterAssetParameters
materialFactoryMapList[].weight | GroundEmitterAssetParameters
maxRaycastsPerFrame | GroundEmitterAssetParameters
radius | GroundEmitterAssetParameters
raycastCollisionGroupMaskName | GroundEmitterAssetParameters
raycastHeight | GroundEmitterAssetParameters
spawnHeight | GroundEmitterAssetParameters
velocityRange.max | GroundEmitterAssetParameters
velocityRange.min | GroundEmitterAssetParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: HeatSourceActorParams Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
HeatSourceActorParams Struct Reference

Describes the NxParameterized::Interface for 'HeatSourceActorParams' : More...

#include <params.h>

List of all members.

Classes

union | GeometryType

Public Attributes

Mat34 | initialPose
'initialPose' : The global pose for the actor.
F32 | initialScale
'initialScale' : The space scale of the actor
F32 | averageTemperature
'averageTemperature' : The arithmetic mean of a sample. Normal distribution parameter.
F32 | stdTemperature
'stdTemperature' : Standard deviation. Normal distribution parameter.
GeometryType geometryType
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for HeatSource vs TurbulenceFS interaction. Overrides asset's value.

Detailed Description

Describes the NxParameterized::Interface for 'HeatSourceActorParams' :

HeatSourceActorParams contains 7 fully qualified names
---------------------------------------------
  1 : Mat34   initialPose
  2 : F32     initialScale
  3 : F32     averageTemperature
  4 : F32     stdTemperature
  5 : Vec3    geometryType.extents        RefVariant[HeatSourceGeomBoxParams]
  6 : F32     geometryType.radius         RefVariant[HeatSourceGeomSphereParams]
  7 : String  fieldSamplerFilterDataName

Member Data Documentation

F32 HeatSourceActorParams::averageTemperature

'averageTemperature' : The arithmetic mean of a sample. Normal distribution parameter.

String HeatSourceActorParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for HeatSource vs TurbulenceFS interaction. Overrides asset's value.

GeometryType HeatSourceActorParams::geometryType
Mat34 HeatSourceActorParams::initialPose

'initialPose' : The global pose for the actor.

F32 HeatSourceActorParams::initialScale

'initialScale' : The space scale of the actor

F32 HeatSourceActorParams::stdTemperature

'stdTemperature' : Standard deviation. Normal distribution parameter.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
HeatSourceActorParams Member List
This is the complete list of members for HeatSourceActorParams, including all inherited members.
averageTemperature | HeatSourceActorParams
fieldSamplerFilterDataName | HeatSourceActorParams
geometryType | HeatSourceActorParams
initialPose | HeatSourceActorParams
initialScale | HeatSourceActorParams
stdTemperature | HeatSourceActorParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: HeatSourceAssetParams Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
HeatSourceAssetParams Struct Reference

Describes the NxParameterized::Interface for 'HeatSourceAssetParams' : Contains the asset properties for this HeatSource. More...

#include <params.h>

List of all members.

Classes

union | GeometryType

Public Attributes

F32 | averageTemperature
'averageTemperature' : The arithmetic mean of a sample. Normal distribution parameter.
F32 | stdTemperature
'stdTemperature' : Standard deviation. Normal distribution parameter.
GeometryType geometryType
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for HeatSource vs TurbulenceFS interaction.

Detailed Description

Describes the NxParameterized::Interface for 'HeatSourceAssetParams' : Contains the asset properties for this HeatSource.

HeatSourceAssetParams contains 5 fully qualified names
---------------------------------------------
  1 : F32     averageTemperature
  2 : F32     stdTemperature
  3 : Vec3    geometryType.extents        RefVariant[HeatSourceGeomBoxParams]
  4 : F32     geometryType.radius         RefVariant[HeatSourceGeomSphereParams]
  5 : String  fieldSamplerFilterDataName

Member Data Documentation

F32 HeatSourceAssetParams::averageTemperature

'averageTemperature' : The arithmetic mean of a sample. Normal distribution parameter.

String HeatSourceAssetParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for HeatSource vs TurbulenceFS interaction.

GeometryType HeatSourceAssetParams::geometryType
F32 HeatSourceAssetParams::stdTemperature

'stdTemperature' : Standard deviation. Normal distribution parameter.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
HeatSourceAssetParams Member List
This is the complete list of members for HeatSourceAssetParams, including all inherited members.
averageTemperature | HeatSourceAssetParams
fieldSamplerFilterDataName | HeatSourceAssetParams
geometryType | HeatSourceAssetParams
stdTemperature | HeatSourceAssetParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: HeatSourceData Struct Reference

  • Class List
  • Class Members
Public Attributes
HeatSourceData Struct Reference

Describes the NxParameterized::Interface for 'HeatSourceData' : Contains the asset properties for this heat source asset. More...

#include <params.h>

List of all members.

Public Attributes

String Name
'Name' : Heat Source name
HeatSourceAssetParams HeatSource
'HeatSource' :

Detailed Description

Describes the NxParameterized::Interface for 'HeatSourceData' : Contains the asset properties for this heat source asset.

HeatSourceData contains 6 fully qualified names
---------------------------------------------
  1 : String  Name
  2 : F32     HeatSource.averageTemperature          RefVariant[HeatSourceAssetParams]
  3 : F32     HeatSource.stdTemperature              RefVariant[HeatSourceAssetParams]
  4 : Vec3    HeatSource.geometryType.extents        RefVariant[HeatSourceGeomBoxParams]
  5 : F32     HeatSource.geometryType.radius         RefVariant[HeatSourceGeomSphereParams]
  6 : String  HeatSource.fieldSamplerFilterDataName  RefVariant[HeatSourceAssetParams]

Member Data Documentation

HeatSourceAssetParams HeatSourceData::HeatSource

'HeatSource' :

String HeatSourceData::Name

'Name' : Heat Source name

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
HeatSourceData Member List
This is the complete list of members for HeatSourceData, including all inherited members.
HeatSource | HeatSourceData
Name | HeatSourceData
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: HeatSourceEffect Struct Reference

  • Class List
  • Class Members
Public Attributes
HeatSourceEffect Struct Reference

Describes the NxParameterized::Interface for 'HeatSourceEffect' : A heat source effect. More...

#include <params.h>

List of all members.

Public Attributes

String | EffectProperties.UserString
'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer
Bool | EffectProperties.Enable
'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup
F32 | EffectProperties.Position.TranslateX
'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateY
'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateZ
'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Orientation.RotateX
'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateY
'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateZ
'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)
F32 | EffectProperties.InitialDelayTime
'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect
F32 | EffectProperties.Duration
'EffectProperties.Duration' : The duration of the effect in secontds
U32 | EffectProperties.RepeatCount
'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever
F32 | EffectProperties.RepeatDelay
'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time
F32 | EffectProperties.RandomizeRepeatTime
'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.
PlaybackMode EffectProperties.Path.PlaybackMode
'EffectProperties.Path.PlaybackMode' : The mode to play back the path
F32 | EffectProperties.Path.PathDuration
'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided
U32 | EffectProperties.Path.LoopIndex
'EffectProperties.Path.LoopIndex' : The array index to loop back to
Transform | EffectProperties.Path.ControlPoints[]
'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to
F32 | EffectProperties.Path.Scale[].x
'EffectProperties.Path.Scale[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Scale[].y
'EffectProperties.Path.Scale[].y' : The y-axis value for this vector
F32 | EffectProperties.Path.Speed[].x
'EffectProperties.Path.Speed[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Speed[].y
'EffectProperties.Path.Speed[].y' : The y-axis value for this vector
Ref | HeatSource
'HeatSource' : Heat Source Asset

Detailed Description

Describes the NxParameterized::Interface for 'HeatSourceEffect' : A heat source effect.

HeatSourceEffect contains 25 fully qualified names
---------------------------------------------
  1 : String         EffectProperties.UserString
  2 : Bool           EffectProperties.Enable
  3 : F32            EffectProperties.Position.TranslateX
  4 : F32            EffectProperties.Position.TranslateY
  5 : F32            EffectProperties.Position.TranslateZ
  6 : F32            EffectProperties.Orientation.RotateX
  7 : F32            EffectProperties.Orientation.RotateY
  8 : F32            EffectProperties.Orientation.RotateZ
  9 : F32            EffectProperties.InitialDelayTime
 10 : F32            EffectProperties.Duration
 11 : U32            EffectProperties.RepeatCount
 12 : F32            EffectProperties.RepeatDelay
 13 : F32            EffectProperties.RandomizeRepeatTime
 14 : PlaybackMode   EffectProperties.Path.PlaybackMode
 15 : F32            EffectProperties.Path.PathDuration
 16 : U32            EffectProperties.Path.LoopIndex
 17 : ArraySizeName  ControlPoints
 18 : Transform      EffectProperties.Path.ControlPoints[]
 19 : ArraySizeName  Scale
 20 : F32            EffectProperties.Path.Scale[].x
 21 : F32            EffectProperties.Path.Scale[].y
 22 : ArraySizeName  Speed
 23 : F32            EffectProperties.Path.Speed[].x
 24 : F32            EffectProperties.Path.Speed[].y
 25 : Ref            HeatSource

Member Data Documentation

F32 HeatSourceEffect::EffectProperties.Duration

'EffectProperties.Duration' : The duration of the effect in secontds

Bool HeatSourceEffect::EffectProperties.Enable

'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup

F32 HeatSourceEffect::EffectProperties.InitialDelayTime

'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect

F32 HeatSourceEffect::EffectProperties.Orientation.RotateX

'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)

F32 HeatSourceEffect::EffectProperties.Orientation.RotateY

'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)

F32 HeatSourceEffect::EffectProperties.Orientation.RotateZ

'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)

Transform HeatSourceEffect::EffectProperties.Path.ControlPoints[]

'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to

U32 HeatSourceEffect::EffectProperties.Path.LoopIndex

'EffectProperties.Path.LoopIndex' : The array index to loop back to

F32 HeatSourceEffect::EffectProperties.Path.PathDuration

'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided

PlaybackMode HeatSourceEffect::EffectProperties.Path.PlaybackMode

'EffectProperties.Path.PlaybackMode' : The mode to play back the path

F32 HeatSourceEffect::EffectProperties.Path.Scale[].x

'EffectProperties.Path.Scale[].x' : The x-axis value for this vector

F32 HeatSourceEffect::EffectProperties.Path.Scale[].y

'EffectProperties.Path.Scale[].y' : The y-axis value for this vector

F32 HeatSourceEffect::EffectProperties.Path.Speed[].x

'EffectProperties.Path.Speed[].x' : The x-axis value for this vector

F32 HeatSourceEffect::EffectProperties.Path.Speed[].y

'EffectProperties.Path.Speed[].y' : The y-axis value for this vector

F32 HeatSourceEffect::EffectProperties.Position.TranslateX

'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction

F32 HeatSourceEffect::EffectProperties.Position.TranslateY

'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction

F32 HeatSourceEffect::EffectProperties.Position.TranslateZ

'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction

F32 HeatSourceEffect::EffectProperties.RandomizeRepeatTime

'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.

U32 HeatSourceEffect::EffectProperties.RepeatCount

'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever

F32 HeatSourceEffect::EffectProperties.RepeatDelay

'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time

String HeatSourceEffect::EffectProperties.UserString

'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer

Ref HeatSourceEffect::HeatSource

'HeatSource' : Heat Source Asset

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
HeatSourceEffect Member List
This is the complete list of members for HeatSourceEffect, including all inherited members.
EffectProperties.Duration | HeatSourceEffect
EffectProperties.Enable | HeatSourceEffect
EffectProperties.InitialDelayTime | HeatSourceEffect
EffectProperties.Orientation.RotateX | HeatSourceEffect
EffectProperties.Orientation.RotateY | HeatSourceEffect
EffectProperties.Orientation.RotateZ | HeatSourceEffect
EffectProperties.Path.ControlPoints[] | HeatSourceEffect
EffectProperties.Path.LoopIndex | HeatSourceEffect
EffectProperties.Path.PathDuration | HeatSourceEffect
EffectProperties.Path.PlaybackMode | HeatSourceEffect
EffectProperties.Path.Scale[].x | HeatSourceEffect
EffectProperties.Path.Scale[].y | HeatSourceEffect
EffectProperties.Path.Speed[].x | HeatSourceEffect
EffectProperties.Path.Speed[].y | HeatSourceEffect
EffectProperties.Position.TranslateX | HeatSourceEffect
EffectProperties.Position.TranslateY | HeatSourceEffect
EffectProperties.Position.TranslateZ | HeatSourceEffect
EffectProperties.RandomizeRepeatTime | HeatSourceEffect
EffectProperties.RepeatCount | HeatSourceEffect
EffectProperties.RepeatDelay | HeatSourceEffect
EffectProperties.UserString | HeatSourceEffect
HeatSource | HeatSourceEffect
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: HeatSourceGeomBoxParams Struct Reference

  • Class List
  • Class Members
Public Attributes
HeatSourceGeomBoxParams Struct Reference

Describes the NxParameterized::Interface for 'HeatSourceGeomBoxParams' : Contains the asset properties for this HeatSource Geometry. More...

#include <params.h>

List of all members.

Public Attributes

Vec3 extents
'extents' : Box Extents

Detailed Description

Describes the NxParameterized::Interface for 'HeatSourceGeomBoxParams' : Contains the asset properties for this HeatSource Geometry.

HeatSourceGeomBoxParams contains 1 fully qualified names
---------------------------------------------
  1 : Vec3  extents

Member Data Documentation

Vec3 HeatSourceGeomBoxParams::extents

'extents' : Box Extents

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
HeatSourceGeomBoxParams Member List
This is the complete list of members for HeatSourceGeomBoxParams, including all inherited members.
extents HeatSourceGeomBoxParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: HeatSourceGeomSphereParams Struct Reference

  • Class List
  • Class Members
Public Attributes
HeatSourceGeomSphereParams Struct Reference

Describes the NxParameterized::Interface for 'HeatSourceGeomSphereParams' : More...

#include <params.h>

List of all members.

Public Attributes

F32 radius
'radius' : Sphere Radius

Detailed Description

Describes the NxParameterized::Interface for 'HeatSourceGeomSphereParams' :

HeatSourceGeomSphereParams contains 1 fully qualified names
---------------------------------------------
  1 : F32  radius

Member Data Documentation

F32 HeatSourceGeomSphereParams::radius

'radius' : Sphere Radius

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
HeatSourceGeomSphereParams Member List
This is the complete list of members for HeatSourceGeomSphereParams, including all inherited members.
radius HeatSourceGeomSphereParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: HeatSourcePreviewParams Struct Reference

  • Class List
  • Class Members
Public Attributes
HeatSourcePreviewParams Struct Reference

Describes the NxParameterized::Interface for 'HeatSourcePreviewParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat34 | pose
'pose' : The preview actor's position and rotation
F32 | scale
'scale' : The preview actor's scale

Detailed Description

Describes the NxParameterized::Interface for 'HeatSourcePreviewParams' :

HeatSourcePreviewParams contains 2 fully qualified names
---------------------------------------------
  1 : Mat34  pose
  2 : F32    scale

Member Data Documentation

Mat34 HeatSourcePreviewParams::pose

'pose' : The preview actor's position and rotation

F32 HeatSourcePreviewParams::scale

'scale' : The preview actor's scale

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
HeatSourcePreviewParams Member List
This is the complete list of members for HeatSourcePreviewParams, including all inherited members.
pose | HeatSourcePreviewParams
scale | HeatSourcePreviewParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ImpactEmitterActorParameters Struct Reference

  • Class List
  • Class Members
ImpactEmitterActorParameters Struct Reference

Describes the NxParameterized::Interface for 'ImpactEmitterActorParameters' : This class is used for creating NxImpactEmitterActor instances. More...

#include <params.h>

Detailed Description

Describes the NxParameterized::Interface for 'ImpactEmitterActorParameters' : This class is used for creating NxImpactEmitterActor instances.

ImpactEmitterActorParameters contains 0 fully qualified names
---------------------------------------------
The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ImpactEmitterAssetParameters Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
ImpactEmitterAssetParameters Struct Reference

Describes the NxParameterized::Interface for 'ImpactEmitterAssetParameters' : This class is parameter storage for the Impact Emitter. More...

#include <params.h>

List of all members.

Classes

union EventSetList

Public Attributes

EventSetList eventSetList[]

Detailed Description

Describes the NxParameterized::Interface for 'ImpactEmitterAssetParameters' : This class is parameter storage for the Impact Emitter.

ImpactEmitterAssetParameters contains 24 fully qualified names
---------------------------------------------
  1 : ArraySizeName  eventSetList
  2 : String         eventSetList[].eventSetName                   RefVariant[ImpactObjectEvent]
  3 : Ref            eventSetList[].iofxAssetName                  RefVariant[ImpactObjectEvent]
  4 : Ref            eventSetList[].iosAssetName                   RefVariant[ImpactObjectEvent]
  5 : F32            eventSetList[].angleRange.min                 RefVariant[ImpactObjectEvent]
  6 : F32            eventSetList[].angleRange.max                 RefVariant[ImpactObjectEvent]
  7 : F32            eventSetList[].speedRange.min                 RefVariant[ImpactObjectEvent]
  8 : F32            eventSetList[].speedRange.max                 RefVariant[ImpactObjectEvent]
  9 : F32            eventSetList[].lifeRange.min                  RefVariant[ImpactObjectEvent]
 10 : F32            eventSetList[].lifeRange.max                  RefVariant[ImpactObjectEvent]
 11 : F32            eventSetList[].delay                          RefVariant[ImpactObjectEvent]
 12 : U32            eventSetList[].particleSpawnCount             RefVariant[ImpactObjectEvent]
 13 : ImpactAxis     eventSetList[].impactAxis                     RefVariant[ImpactObjectEvent]
 14 : U32            eventSetList[].lodParamDesc.version           RefVariant[ImpactObjectEvent]
 15 : F32            eventSetList[].lodParamDesc.maxDistance       RefVariant[ImpactObjectEvent]
 16 : F32            eventSetList[].lodParamDesc.distanceWeight    RefVariant[ImpactObjectEvent]
 17 : F32            eventSetList[].lodParamDesc.speedWeight       RefVariant[ImpactObjectEvent]
 18 : F32            eventSetList[].lodParamDesc.lifeWeight        RefVariant[ImpactObjectEvent]
 19 : F32            eventSetList[].lodParamDesc.separationWeight  RefVariant[ImpactObjectEvent]
 20 : F32            eventSetList[].lodParamDesc.bias              RefVariant[ImpactObjectEvent]
 21 : String         eventSetList[].eventSetName                   RefVariant[ImpactExplosionEvent]
 22 : Ref            eventSetList[].explosionAssetName             RefVariant[ImpactExplosionEvent]
 23 : F32            eventSetList[].delay                          RefVariant[ImpactExplosionEvent]
 24 : F32            eventSetList[].duration                       RefVariant[ImpactExplosionEvent]

Member Data Documentation

EventSetList ImpactEmitterAssetParameters::eventSetList[]
The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ImpactEmitterAssetParameters Member List
This is the complete list of members for ImpactEmitterAssetParameters, including all inherited members.
eventSetList[] ImpactEmitterAssetParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ImpactExplosionEvent Struct Reference

  • Class List
  • Class Members
Public Attributes
ImpactExplosionEvent Struct Reference

Describes the NxParameterized::Interface for 'ImpactExplosionEvent' : More...

#include <params.h>

List of all members.

Public Attributes

String | eventSetName
'eventSetName' : The name of the event set (you can put multiple events in an event set)
Ref | explosionAssetName
'explosionAssetName' : The asset name of the explosion that will optionally accompany the impact event
F32 | delay
'delay' : The delay (in seconds) after impact to wait before triggering
F32 | duration
'duration' : The length (in seconds) of the explosion

Detailed Description

Describes the NxParameterized::Interface for 'ImpactExplosionEvent' :

ImpactExplosionEvent contains 4 fully qualified names
---------------------------------------------
  1 : String  eventSetName
  2 : Ref     explosionAssetName
  3 : F32     delay
  4 : F32     duration

Member Data Documentation

F32 ImpactExplosionEvent::delay

'delay' : The delay (in seconds) after impact to wait before triggering

F32 ImpactExplosionEvent::duration

'duration' : The length (in seconds) of the explosion

String ImpactExplosionEvent::eventSetName

'eventSetName' : The name of the event set (you can put multiple events in an event set)

Ref ImpactExplosionEvent::explosionAssetName

'explosionAssetName' : The asset name of the explosion that will optionally accompany the impact event

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ImpactExplosionEvent Member List
This is the complete list of members for ImpactExplosionEvent, including all inherited members.
delay | ImpactExplosionEvent
duration | ImpactExplosionEvent
eventSetName | ImpactExplosionEvent
explosionAssetName | ImpactExplosionEvent
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ImpactObjectEvent Struct Reference

  • Class List
  • Class Members
Public Attributes
ImpactObjectEvent Struct Reference

Describes the NxParameterized::Interface for 'ImpactObjectEvent' : More...

#include <params.h>

List of all members.

Public Attributes

String | eventSetName
'eventSetName' : The name of the event set (you can put multiple events in an event set)
Ref | iofxAssetName
'iofxAssetName' : The name of the instanced object effects asset that will render the particles
Ref | iosAssetName
'iosAssetName' : The asset name of the particle system that will simulate the particles
F32 | angleRange.min
'angleRange.min' : Helpful documentation goes here
F32 | angleRange.max
'angleRange.max' : Helpful documentation goes here
F32 | speedRange.min
'speedRange.min' : Helpful documentation goes here
F32 | speedRange.max
'speedRange.max' : Helpful documentation goes here
F32 | lifeRange.min
'lifeRange.min' : Helpful documentation goes here
F32 | lifeRange.max
'lifeRange.max' : Helpful documentation goes here
F32 | delay
'delay' : The delay (in seconds) after impact to wait before triggering
U32 | particleSpawnCount
'particleSpawnCount' : The number of particles emitted per impact
ImpactAxis impactAxis
'impactAxis' : The method used to emit particles at the point of impact
U32 | lodParamDesc.version
'lodParamDesc.version' : Helpful documentation goes here
F32 | lodParamDesc.maxDistance
'lodParamDesc.maxDistance' : Objects greater than this distance from the player will be culled more aggressively
F32 | lodParamDesc.distanceWeight
'lodParamDesc.distanceWeight' : Weight given to distance parameter in LOD function
F32 | lodParamDesc.speedWeight
'lodParamDesc.speedWeight' : Weight given to velocity parameter in LOD function
F32 | lodParamDesc.lifeWeight
'lodParamDesc.lifeWeight' : Weight given to life remain parameter in LOD function
F32 | lodParamDesc.separationWeight
'lodParamDesc.separationWeight' : Weight given to separation parameter in LOD function
F32 | lodParamDesc.bias
'lodParamDesc.bias' : Bias given to objects spawned by this emitter, relative to other emitters in the same IOS

Detailed Description

Describes the NxParameterized::Interface for 'ImpactObjectEvent' :

ImpactObjectEvent contains 19 fully qualified names
---------------------------------------------
  1 : String      eventSetName
  2 : Ref         iofxAssetName
  3 : Ref         iosAssetName
  4 : F32         angleRange.min
  5 : F32         angleRange.max
  6 : F32         speedRange.min
  7 : F32         speedRange.max
  8 : F32         lifeRange.min
  9 : F32         lifeRange.max
 10 : F32         delay
 11 : U32         particleSpawnCount
 12 : ImpactAxis  impactAxis
 13 : U32         lodParamDesc.version
 14 : F32         lodParamDesc.maxDistance
 15 : F32         lodParamDesc.distanceWeight
 16 : F32         lodParamDesc.speedWeight
 17 : F32         lodParamDesc.lifeWeight
 18 : F32         lodParamDesc.separationWeight
 19 : F32         lodParamDesc.bias

Member Data Documentation

F32 ImpactObjectEvent::angleRange.max

'angleRange.max' : Helpful documentation goes here

F32 ImpactObjectEvent::angleRange.min

'angleRange.min' : Helpful documentation goes here

F32 ImpactObjectEvent::delay

'delay' : The delay (in seconds) after impact to wait before triggering

String ImpactObjectEvent::eventSetName

'eventSetName' : The name of the event set (you can put multiple events in an event set)

ImpactAxis ImpactObjectEvent::impactAxis

'impactAxis' : The method used to emit particles at the point of impact

Ref ImpactObjectEvent::iofxAssetName

'iofxAssetName' : The name of the instanced object effects asset that will render the particles

Ref ImpactObjectEvent::iosAssetName

'iosAssetName' : The asset name of the particle system that will simulate the particles

F32 ImpactObjectEvent::lifeRange.max

'lifeRange.max' : Helpful documentation goes here

F32 ImpactObjectEvent::lifeRange.min

'lifeRange.min' : Helpful documentation goes here

F32 ImpactObjectEvent::lodParamDesc.bias

'lodParamDesc.bias' : Bias given to objects spawned by this emitter, relative to other emitters in the same IOS

F32 ImpactObjectEvent::lodParamDesc.distanceWeight

'lodParamDesc.distanceWeight' : Weight given to distance parameter in LOD function

F32 ImpactObjectEvent::lodParamDesc.lifeWeight

'lodParamDesc.lifeWeight' : Weight given to life remain parameter in LOD function

F32 ImpactObjectEvent::lodParamDesc.maxDistance

'lodParamDesc.maxDistance' : Objects greater than this distance from the player will be culled more aggressively

F32 ImpactObjectEvent::lodParamDesc.separationWeight

'lodParamDesc.separationWeight' : Weight given to separation parameter in LOD function

F32 ImpactObjectEvent::lodParamDesc.speedWeight

'lodParamDesc.speedWeight' : Weight given to velocity parameter in LOD function

U32 ImpactObjectEvent::lodParamDesc.version

'lodParamDesc.version' : Helpful documentation goes here

U32 ImpactObjectEvent::particleSpawnCount

'particleSpawnCount' : The number of particles emitted per impact

F32 ImpactObjectEvent::speedRange.max

'speedRange.max' : Helpful documentation goes here

F32 ImpactObjectEvent::speedRange.min

'speedRange.min' : Helpful documentation goes here

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ImpactObjectEvent Member List
This is the complete list of members for ImpactObjectEvent, including all inherited members.
angleRange.max | ImpactObjectEvent
angleRange.min | ImpactObjectEvent
delay | ImpactObjectEvent
eventSetName | ImpactObjectEvent
impactAxis | ImpactObjectEvent
iofxAssetName | ImpactObjectEvent
iosAssetName | ImpactObjectEvent
lifeRange.max | ImpactObjectEvent
lifeRange.min | ImpactObjectEvent
lodParamDesc.bias | ImpactObjectEvent
lodParamDesc.distanceWeight | ImpactObjectEvent
lodParamDesc.lifeWeight | ImpactObjectEvent
lodParamDesc.maxDistance | ImpactObjectEvent
lodParamDesc.separationWeight | ImpactObjectEvent
lodParamDesc.speedWeight | ImpactObjectEvent
lodParamDesc.version | ImpactObjectEvent
particleSpawnCount | ImpactObjectEvent
speedRange.max | ImpactObjectEvent
speedRange.min | ImpactObjectEvent
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: InitialColorModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
InitialColorModifierParams Struct Reference

Describes the NxParameterized::Interface for 'InitialColorModifierParams' : InitialColor modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

Vec4 color
'color' : Color is formatted x=R, y=G, z=B, w=A

Detailed Description

Describes the NxParameterized::Interface for 'InitialColorModifierParams' : InitialColor modifier parameters.

InitialColorModifierParams contains 1 fully qualified names
---------------------------------------------
  1 : Vec4  color

Member Data Documentation

Vec4 InitialColorModifierParams::color

'color' : Color is formatted x=R, y=G, z=B, w=A

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
InitialColorModifierParams Member List
This is the complete list of members for InitialColorModifierParams, including all inherited members.
color InitialColorModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: IofxAssetParameters Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
IofxAssetParameters Struct Reference

Describes the NxParameterized::Interface for 'IofxAssetParameters' : Contains the asset properties for an IOFX. More...

#include <params.h>

List of all members.

Classes

union | IofxType

Public Attributes

IofxType iofxType
Bool | renderOutput.useUserSemantic
'renderOutput.useUserSemantic' : use user semantic in render output
Bool | renderOutput.useFloat4Color
'renderOutput.useFloat4Color' : use float4 color in render output

Detailed Description

Describes the NxParameterized::Interface for 'IofxAssetParameters' : Contains the asset properties for an IOFX.

IofxAssetParameters contains 147 fully qualified names
---------------------------------------------
  1 : ArraySizeName  iofxType.renderMeshList                                           RefVariant[MeshIofxParameters]
  2 : Ref            iofxType.renderMeshList[].meshAssetName                           RefVariant[MeshIofxParameters]
  3 : U32            iofxType.renderMeshList[].weight                                  RefVariant[MeshIofxParameters]
  4 : ArraySizeName  iofxType.spawnModifierList                                        RefVariant[MeshIofxParameters]
  5 : RollType       iofxType.spawnModifierList[].rollType                             RefVariant[RotationModifierParams]
  6 : F32            iofxType.spawnModifierList[].maxRotationRatePerSec                RefVariant[RotationModifierParams]
  7 : F32            iofxType.spawnModifierList[].maxSettleRatePerSec                  RefVariant[RotationModifierParams]
  8 : F32            iofxType.spawnModifierList[].inAirRotationMultiplier              RefVariant[RotationModifierParams]
  9 : F32            iofxType.spawnModifierList[].collisionRotationMultiplier          RefVariant[RotationModifierParams]
 10 : Bool           iofxType.spawnModifierList[].includeVerticalDirection             RefVariant[RotationModifierParams]
 11 : Vec3           iofxType.spawnModifierList[].scaleFactor                          RefVariant[SimpleScaleModifierParams]
 12 : F32            iofxType.spawnModifierList[].minScaleFactor                       RefVariant[RandomScaleModifierParams]
 13 : F32            iofxType.spawnModifierList[].maxScaleFactor                       RefVariant[RandomScaleModifierParams]
 14 : Vec4           iofxType.spawnModifierList[].color                                RefVariant[InitialColorModifierParams]
 15 : ArraySizeName  iofxType.continuousModifierList                                   RefVariant[MeshIofxParameters]
 16 : RollType       iofxType.continuousModifierList[].rollType                        RefVariant[RotationModifierParams]
 17 : F32            iofxType.continuousModifierList[].maxRotationRatePerSec           RefVariant[RotationModifierParams]
 18 : F32            iofxType.continuousModifierList[].maxSettleRatePerSec             RefVariant[RotationModifierParams]
 19 : F32            iofxType.continuousModifierList[].inAirRotationMultiplier         RefVariant[RotationModifierParams]
 20 : F32            iofxType.continuousModifierList[].collisionRotationMultiplier     RefVariant[RotationModifierParams]
 21 : Bool           iofxType.continuousModifierList[].includeVerticalDirection        RefVariant[RotationModifierParams]
 22 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsLife3DModifierParams]
 23 : F32            iofxType.continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ScaleVsLife3DModifierParams]
 24 : Vec3           iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsLife3DModifierParams]
 25 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensity3DModifierParams]
 26 : F32            iofxType.continuousModifierList[].controlPoints[].density         RefVariant[ScaleVsDensity3DModifierParams]
 27 : Vec3           iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsDensity3DModifierParams]
 28 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperature3DModifierParams]
 29 : F32            iofxType.continuousModifierList[].controlPoints[].temperature     RefVariant[ScaleVsTemperature3DModifierParams]
 30 : Vec3           iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsTemperature3DModifierParams]
 31 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistance3DModifierParams]
 32 : F32            iofxType.continuousModifierList[].controlPoints[].cameraDistance  RefVariant[ScaleVsCameraDistance3DModifierParams]
 33 : Vec3           iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsCameraDistance3DModifierParams]
 34 : Vec3           iofxType.continuousModifierList[].modelForward                    RefVariant[OrientAlongVelocityModifierParams]
 35 : F32            iofxType.continuousModifierList[].scaleFactor                     RefVariant[ScaleAlongVelocityModifierParams]
 36 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsLifeCompositeModifierParams]
 37 : F32            iofxType.continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ColorVsLifeCompositeModifierParams]
 38 : Vec4           iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsLifeCompositeModifierParams]
 39 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsDensityCompositeModifierParams]
 40 : F32            iofxType.continuousModifierList[].controlPoints[].density         RefVariant[ColorVsDensityCompositeModifierParams]
 41 : Vec4           iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsDensityCompositeModifierParams]
 42 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsTemperatureCompositeModifierParams]
 43 : F32            iofxType.continuousModifierList[].controlPoints[].temperature     RefVariant[ColorVsTemperatureCompositeModifierParams]
 44 : Vec4           iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsTemperatureCompositeModifierParams]
 45 : ScaleAxis      iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsLifeModifierParams]
 46 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsLifeModifierParams]
 47 : F32            iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsLifeModifierParams]
 48 : F32            iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsLifeModifierParams]
 49 : ScaleAxis      iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsDensityModifierParams]
 50 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensityModifierParams]
 51 : F32            iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsDensityModifierParams]
 52 : F32            iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsDensityModifierParams]
 53 : ScaleAxis      iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsTemperatureModifierParams]
 54 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperatureModifierParams]
 55 : F32            iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsTemperatureModifierParams]
 56 : F32            iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsTemperatureModifierParams]
 57 : ScaleAxis      iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsCameraDistanceModifierParams]
 58 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistanceModifierParams]
 59 : F32            iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsCameraDistanceModifierParams]
 60 : F32            iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsCameraDistanceModifierParams]
 61 : F32            iofxType.continuousModifierList[].velocity0                       RefVariant[ColorVsVelocityCompositeModifierParams]
 62 : F32            iofxType.continuousModifierList[].velocity1                       RefVariant[ColorVsVelocityCompositeModifierParams]
 63 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsVelocityCompositeModifierParams]
 64 : F32            iofxType.continuousModifierList[].controlPoints[].velocity        RefVariant[ColorVsVelocityCompositeModifierParams]
 65 : Vec4           iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsVelocityCompositeModifierParams]
 66 : Ref            iofxType.spriteMaterialName                                       RefVariant[SpriteIofxParameters]
 67 : ArraySizeName  iofxType.spawnModifierList                                        RefVariant[SpriteIofxParameters]
 68 : Vec3           iofxType.spawnModifierList[].scaleFactor                          RefVariant[SimpleScaleModifierParams]
 69 : F32            iofxType.spawnModifierList[].minScaleFactor                       RefVariant[RandomScaleModifierParams]
 70 : F32            iofxType.spawnModifierList[].maxScaleFactor                       RefVariant[RandomScaleModifierParams]
 71 : Vec4           iofxType.spawnModifierList[].color                                RefVariant[InitialColorModifierParams]
 72 : F32            iofxType.spawnModifierList[].minSubtexture                        RefVariant[RandomSubtextureModifierParams]
 73 : F32            iofxType.spawnModifierList[].maxSubtexture                        RefVariant[RandomSubtextureModifierParams]
 74 : F32            iofxType.spawnModifierList[].minRotation                          RefVariant[RandomRotationModifierParams]
 75 : F32            iofxType.spawnModifierList[].maxRotation                          RefVariant[RandomRotationModifierParams]
 76 : ColorChannel   iofxType.spawnModifierList[].colorChannel                         RefVariant[ColorVsLifeModifierParams]
 77 : ArraySizeName  iofxType.spawnModifierList[].controlPoints                        RefVariant[ColorVsLifeModifierParams]
 78 : F32            iofxType.spawnModifierList[].controlPoints[].x                    RefVariant[ColorVsLifeModifierParams]
 79 : F32            iofxType.spawnModifierList[].controlPoints[].y                    RefVariant[ColorVsLifeModifierParams]
 80 : ArraySizeName  iofxType.continuousModifierList                                   RefVariant[SpriteIofxParameters]
 81 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsLifeCompositeModifierParams]
 82 : F32            iofxType.continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ColorVsLifeCompositeModifierParams]
 83 : Vec4           iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsLifeCompositeModifierParams]
 84 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsDensityCompositeModifierParams]
 85 : F32            iofxType.continuousModifierList[].controlPoints[].density         RefVariant[ColorVsDensityCompositeModifierParams]
 86 : Vec4           iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsDensityCompositeModifierParams]
 87 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsTemperatureCompositeModifierParams]
 88 : F32            iofxType.continuousModifierList[].controlPoints[].temperature     RefVariant[ColorVsTemperatureCompositeModifierParams]
 89 : Vec4           iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsTemperatureCompositeModifierParams]
 90 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsLife2DModifierParams]
 91 : F32            iofxType.continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ScaleVsLife2DModifierParams]
 92 : Vec2           iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsLife2DModifierParams]
 93 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensity2DModifierParams]
 94 : F32            iofxType.continuousModifierList[].controlPoints[].density         RefVariant[ScaleVsDensity2DModifierParams]
 95 : Vec2           iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsDensity2DModifierParams]
 96 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperature2DModifierParams]
 97 : F32            iofxType.continuousModifierList[].controlPoints[].temperature     RefVariant[ScaleVsTemperature2DModifierParams]
 98 : Vec2           iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsTemperature2DModifierParams]
 99 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistance2DModifierParams]
100 : F32            iofxType.continuousModifierList[].controlPoints[].cameraDistance  RefVariant[ScaleVsCameraDistance2DModifierParams]
101 : Vec2           iofxType.continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsCameraDistance2DModifierParams]
102 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[SubtextureVsLifeModifierParams]
103 : F32            iofxType.continuousModifierList[].controlPoints[].x               RefVariant[SubtextureVsLifeModifierParams]
104 : F32            iofxType.continuousModifierList[].controlPoints[].y               RefVariant[SubtextureVsLifeModifierParams]
105 : SortType       iofxType.continuousModifierList[].sortType                        RefVariant[ViewDirectionSortingModifierParams]
106 : ColorChannel   iofxType.continuousModifierList[].colorChannel                    RefVariant[ColorVsLifeModifierParams]
107 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsLifeModifierParams]
108 : F32            iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ColorVsLifeModifierParams]
109 : F32            iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ColorVsLifeModifierParams]
110 : ColorChannel   iofxType.continuousModifierList[].colorChannel                    RefVariant[ColorVsDensityModifierParams]
111 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsDensityModifierParams]
112 : F32            iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ColorVsDensityModifierParams]
113 : F32            iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ColorVsDensityModifierParams]
114 : ColorChannel   iofxType.continuousModifierList[].colorChannel                    RefVariant[ColorVsTemperatureModifierParams]
115 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsTemperatureModifierParams]
116 : F32            iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ColorVsTemperatureModifierParams]
117 : F32            iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ColorVsTemperatureModifierParams]
118 : ScaleAxis      iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsLifeModifierParams]
119 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsLifeModifierParams]
120 : F32            iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsLifeModifierParams]
121 : F32            iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsLifeModifierParams]
122 : ScaleAxis      iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsDensityModifierParams]
123 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensityModifierParams]
124 : F32            iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsDensityModifierParams]
125 : F32            iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsDensityModifierParams]
126 : ScaleAxis      iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsTemperatureModifierParams]
127 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperatureModifierParams]
128 : F32            iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsTemperatureModifierParams]
129 : F32            iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsTemperatureModifierParams]
130 : ScaleAxis      iofxType.continuousModifierList[].scaleAxis                       RefVariant[ScaleVsCameraDistanceModifierParams]
131 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistanceModifierParams]
132 : F32            iofxType.continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsCameraDistanceModifierParams]
133 : F32            iofxType.continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsCameraDistanceModifierParams]
134 : F32            iofxType.continuousModifierList[].rotationRate                    RefVariant[RotationRateModifierParams]
135 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[RotationRateVsLifeModifierParams]
136 : F32            iofxType.continuousModifierList[].controlPoints[].x               RefVariant[RotationRateVsLifeModifierParams]
137 : F32            iofxType.continuousModifierList[].controlPoints[].y               RefVariant[RotationRateVsLifeModifierParams]
138 : F32            iofxType.continuousModifierList[].scalePerVelocity                RefVariant[OrientScaleAlongScreenVelocityModifierParams]
139 : F32            iofxType.continuousModifierList[].scaleChangeLimit                RefVariant[OrientScaleAlongScreenVelocityModifierParams]
140 : F32            iofxType.continuousModifierList[].scaleChangeDelay                RefVariant[OrientScaleAlongScreenVelocityModifierParams]
141 : F32            iofxType.continuousModifierList[].velocity0                       RefVariant[ColorVsVelocityCompositeModifierParams]
142 : F32            iofxType.continuousModifierList[].velocity1                       RefVariant[ColorVsVelocityCompositeModifierParams]
143 : ArraySizeName  iofxType.continuousModifierList[].controlPoints                   RefVariant[ColorVsVelocityCompositeModifierParams]
144 : F32            iofxType.continuousModifierList[].controlPoints[].velocity        RefVariant[ColorVsVelocityCompositeModifierParams]
145 : Vec4           iofxType.continuousModifierList[].controlPoints[].color           RefVariant[ColorVsVelocityCompositeModifierParams]
146 : Bool           renderOutput.useUserSemantic
147 : Bool           renderOutput.useFloat4Color

Member Data Documentation

IofxType IofxAssetParameters::iofxType
Bool IofxAssetParameters::renderOutput.useFloat4Color

'renderOutput.useFloat4Color' : use float4 color in render output

Bool IofxAssetParameters::renderOutput.useUserSemantic

'renderOutput.useUserSemantic' : use user semantic in render output

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
IofxAssetParameters Member List
This is the complete list of members for IofxAssetParameters, including all inherited members.
iofxType | IofxAssetParameters
renderOutput.useFloat4Color | IofxAssetParameters
renderOutput.useUserSemantic | IofxAssetParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: IofxDebugRenderParams Struct Reference

  • Class List
  • Class Members
Public Attributes
IofxDebugRenderParams Struct Reference

Describes the NxParameterized::Interface for 'IofxDebugRenderParams' : More...

#include <params.h>

List of all members.

Public Attributes

Bool | VISUALIZE_IOFX_ACTOR
'VISUALIZE_IOFX_ACTOR' : Render IOFX actor in view window
Bool | VISUALIZE_IOFX_BOUNDING_BOX
'VISUALIZE_IOFX_BOUNDING_BOX' : Render IOFX bounding box in view window
Bool | VISUALIZE_IOFX_ACTOR_NAME
'VISUALIZE_IOFX_ACTOR_NAME' : Render IOFX actor name in view window

Detailed Description

Describes the NxParameterized::Interface for 'IofxDebugRenderParams' :

IofxDebugRenderParams contains 3 fully qualified names
---------------------------------------------
  1 : Bool  VISUALIZE_IOFX_ACTOR
  2 : Bool  VISUALIZE_IOFX_BOUNDING_BOX
  3 : Bool  VISUALIZE_IOFX_ACTOR_NAME

Member Data Documentation

Bool IofxDebugRenderParams::VISUALIZE_IOFX_ACTOR

'VISUALIZE_IOFX_ACTOR' : Render IOFX actor in view window

Bool IofxDebugRenderParams::VISUALIZE_IOFX_ACTOR_NAME

'VISUALIZE_IOFX_ACTOR_NAME' : Render IOFX actor name in view window

Bool IofxDebugRenderParams::VISUALIZE_IOFX_BOUNDING_BOX

'VISUALIZE_IOFX_BOUNDING_BOX' : Render IOFX bounding box in view window

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
IofxDebugRenderParams Member List
This is the complete list of members for IofxDebugRenderParams, including all inherited members.
VISUALIZE_IOFX_ACTOR | IofxDebugRenderParams
VISUALIZE_IOFX_ACTOR_NAME | IofxDebugRenderParams
VISUALIZE_IOFX_BOUNDING_BOX | IofxDebugRenderParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: IofxModuleParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
IofxModuleParameters Struct Reference

Describes the NxParameterized::Interface for 'IofxModuleParameters' : This class is used for initializing the NxModuleIofx. More...

#include <params.h>

List of all members.

Public Attributes

U32 unused
'unused' : No parameters necessary

Detailed Description

Describes the NxParameterized::Interface for 'IofxModuleParameters' : This class is used for initializing the NxModuleIofx.

IofxModuleParameters contains 1 fully qualified names
---------------------------------------------
  1 : U32  unused

Member Data Documentation

U32 IofxModuleParameters::unused

'unused' : No parameters necessary

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
IofxModuleParameters Member List
This is the complete list of members for IofxModuleParameters, including all inherited members.
unused IofxModuleParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: JetFieldSamplerData Struct Reference

  • Class List
  • Class Members
Public Attributes
JetFieldSamplerData Struct Reference

Describes the NxParameterized::Interface for 'JetFieldSamplerData' : Contains the asset properties for this jet field sampler. More...

#include <params.h>

List of all members.

Public Attributes

String Name
'Name' : Jet FS Name
JetFSAssetParams JetFieldSampler
'JetFieldSampler' :

Detailed Description

Describes the NxParameterized::Interface for 'JetFieldSamplerData' : Contains the asset properties for this jet field sampler.

JetFieldSamplerData contains 26 fully qualified names
---------------------------------------------
  1 : String  Name
  2 : F32     JetFieldSampler.defaultScale                      RefVariant[JetFSAssetParams]
  3 : F32     JetFieldSampler.boundaryFadePercentage            RefVariant[JetFSAssetParams]
  4 : Vec3    JetFieldSampler.fieldDirection                    RefVariant[JetFSAssetParams]
  5 : F32     JetFieldSampler.fieldDirectionDeviationAngle      RefVariant[JetFSAssetParams]
  6 : F32     JetFieldSampler.fieldDirectionOscillationPeriod   RefVariant[JetFSAssetParams]
  7 : F32     JetFieldSampler.fieldStrength                     RefVariant[JetFSAssetParams]
  8 : F32     JetFieldSampler.fieldStrengthDeviationPercentage  RefVariant[JetFSAssetParams]
  9 : F32     JetFieldSampler.fieldStrengthOscillationPeriod    RefVariant[JetFSAssetParams]
 10 : F32     JetFieldSampler.gridShapeRadius                   RefVariant[JetFSAssetParams]
 11 : F32     JetFieldSampler.gridShapeHeight                   RefVariant[JetFSAssetParams]
 12 : F32     JetFieldSampler.gridBoundaryFadePercentage        RefVariant[JetFSAssetParams]
 13 : F32     JetFieldSampler.nearRadius                        RefVariant[JetFSAssetParams]
 14 : F32     JetFieldSampler.pivotRadius                       RefVariant[JetFSAssetParams]
 15 : F32     JetFieldSampler.farRadius                         RefVariant[JetFSAssetParams]
 16 : F32     JetFieldSampler.directionalStretch                RefVariant[JetFSAssetParams]
 17 : F32     JetFieldSampler.averageStartDistance              RefVariant[JetFSAssetParams]
 18 : F32     JetFieldSampler.averageEndDistance                RefVariant[JetFSAssetParams]
 19 : F32     JetFieldSampler.noisePercentage                   RefVariant[JetFSAssetParams]
 20 : F32     JetFieldSampler.noiseSpaceScale                   RefVariant[JetFSAssetParams]
 21 : F32     JetFieldSampler.noiseTimeScale                    RefVariant[JetFSAssetParams]
 22 : U32     JetFieldSampler.noiseOctaves                      RefVariant[JetFSAssetParams]
 23 : F32     JetFieldSampler.fieldDragCoeff                    RefVariant[JetFSAssetParams]
 24 : F32     JetFieldSampler.fieldWeight                       RefVariant[JetFSAssetParams]
 25 : String  JetFieldSampler.fieldBoundaryFilterDataName       RefVariant[JetFSAssetParams]
 26 : String  JetFieldSampler.fieldSamplerFilterDataName        RefVariant[JetFSAssetParams]

Member Data Documentation

JetFSAssetParams JetFieldSamplerData::JetFieldSampler

'JetFieldSampler' :

String JetFieldSamplerData::Name

'Name' : Jet FS Name

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
JetFieldSamplerData Member List
This is the complete list of members for JetFieldSamplerData, including all inherited members.
JetFieldSampler | JetFieldSamplerData
Name | JetFieldSamplerData
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: JetFieldSamplerEffect Struct Reference

  • Class List
  • Class Members
Public Attributes
JetFieldSamplerEffect Struct Reference

Describes the NxParameterized::Interface for 'JetFieldSamplerEffect' : A jet field sampler effect. More...

#include <params.h>

List of all members.

Public Attributes

String | EffectProperties.UserString
'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer
Bool | EffectProperties.Enable
'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup
F32 | EffectProperties.Position.TranslateX
'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateY
'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateZ
'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Orientation.RotateX
'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateY
'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateZ
'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)
F32 | EffectProperties.InitialDelayTime
'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect
F32 | EffectProperties.Duration
'EffectProperties.Duration' : The duration of the effect in secontds
U32 | EffectProperties.RepeatCount
'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever
F32 | EffectProperties.RepeatDelay
'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time
F32 | EffectProperties.RandomizeRepeatTime
'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.
PlaybackMode EffectProperties.Path.PlaybackMode
'EffectProperties.Path.PlaybackMode' : The mode to play back the path
F32 | EffectProperties.Path.PathDuration
'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided
U32 | EffectProperties.Path.LoopIndex
'EffectProperties.Path.LoopIndex' : The array index to loop back to
Transform | EffectProperties.Path.ControlPoints[]
'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to
F32 | EffectProperties.Path.Scale[].x
'EffectProperties.Path.Scale[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Scale[].y
'EffectProperties.Path.Scale[].y' : The y-axis value for this vector
F32 | EffectProperties.Path.Speed[].x
'EffectProperties.Path.Speed[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Speed[].y
'EffectProperties.Path.Speed[].y' : The y-axis value for this vector
Ref | JetFieldSampler
'JetFieldSampler' : Jet FS Asset

Detailed Description

Describes the NxParameterized::Interface for 'JetFieldSamplerEffect' : A jet field sampler effect.

JetFieldSamplerEffect contains 25 fully qualified names
---------------------------------------------
  1 : String         EffectProperties.UserString
  2 : Bool           EffectProperties.Enable
  3 : F32            EffectProperties.Position.TranslateX
  4 : F32            EffectProperties.Position.TranslateY
  5 : F32            EffectProperties.Position.TranslateZ
  6 : F32            EffectProperties.Orientation.RotateX
  7 : F32            EffectProperties.Orientation.RotateY
  8 : F32            EffectProperties.Orientation.RotateZ
  9 : F32            EffectProperties.InitialDelayTime
 10 : F32            EffectProperties.Duration
 11 : U32            EffectProperties.RepeatCount
 12 : F32            EffectProperties.RepeatDelay
 13 : F32            EffectProperties.RandomizeRepeatTime
 14 : PlaybackMode   EffectProperties.Path.PlaybackMode
 15 : F32            EffectProperties.Path.PathDuration
 16 : U32            EffectProperties.Path.LoopIndex
 17 : ArraySizeName  ControlPoints
 18 : Transform      EffectProperties.Path.ControlPoints[]
 19 : ArraySizeName  Scale
 20 : F32            EffectProperties.Path.Scale[].x
 21 : F32            EffectProperties.Path.Scale[].y
 22 : ArraySizeName  Speed
 23 : F32            EffectProperties.Path.Speed[].x
 24 : F32            EffectProperties.Path.Speed[].y
 25 : Ref            JetFieldSampler

Member Data Documentation

F32 JetFieldSamplerEffect::EffectProperties.Duration

'EffectProperties.Duration' : The duration of the effect in secontds

Bool JetFieldSamplerEffect::EffectProperties.Enable

'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup

F32 JetFieldSamplerEffect::EffectProperties.InitialDelayTime

'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect

F32 JetFieldSamplerEffect::EffectProperties.Orientation.RotateX

'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)

F32 JetFieldSamplerEffect::EffectProperties.Orientation.RotateY

'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)

F32 JetFieldSamplerEffect::EffectProperties.Orientation.RotateZ

'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)

Transform JetFieldSamplerEffect::EffectProperties.Path.ControlPoints[]

'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to

U32 JetFieldSamplerEffect::EffectProperties.Path.LoopIndex

'EffectProperties.Path.LoopIndex' : The array index to loop back to

F32 JetFieldSamplerEffect::EffectProperties.Path.PathDuration

'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided

PlaybackMode JetFieldSamplerEffect::EffectProperties.Path.PlaybackMode

'EffectProperties.Path.PlaybackMode' : The mode to play back the path

F32 JetFieldSamplerEffect::EffectProperties.Path.Scale[].x

'EffectProperties.Path.Scale[].x' : The x-axis value for this vector

F32 JetFieldSamplerEffect::EffectProperties.Path.Scale[].y

'EffectProperties.Path.Scale[].y' : The y-axis value for this vector

F32 JetFieldSamplerEffect::EffectProperties.Path.Speed[].x

'EffectProperties.Path.Speed[].x' : The x-axis value for this vector

F32 JetFieldSamplerEffect::EffectProperties.Path.Speed[].y

'EffectProperties.Path.Speed[].y' : The y-axis value for this vector

F32 JetFieldSamplerEffect::EffectProperties.Position.TranslateX

'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction

F32 JetFieldSamplerEffect::EffectProperties.Position.TranslateY

'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction

F32 JetFieldSamplerEffect::EffectProperties.Position.TranslateZ

'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction

F32 JetFieldSamplerEffect::EffectProperties.RandomizeRepeatTime

'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.

U32 JetFieldSamplerEffect::EffectProperties.RepeatCount

'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever

F32 JetFieldSamplerEffect::EffectProperties.RepeatDelay

'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time

String JetFieldSamplerEffect::EffectProperties.UserString

'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer

Ref JetFieldSamplerEffect::JetFieldSampler

'JetFieldSampler' : Jet FS Asset

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
JetFieldSamplerEffect Member List
This is the complete list of members for JetFieldSamplerEffect, including all inherited members.
EffectProperties.Duration | JetFieldSamplerEffect
EffectProperties.Enable | JetFieldSamplerEffect
EffectProperties.InitialDelayTime | JetFieldSamplerEffect
EffectProperties.Orientation.RotateX | JetFieldSamplerEffect
EffectProperties.Orientation.RotateY | JetFieldSamplerEffect
EffectProperties.Orientation.RotateZ | JetFieldSamplerEffect
EffectProperties.Path.ControlPoints[] | JetFieldSamplerEffect
EffectProperties.Path.LoopIndex | JetFieldSamplerEffect
EffectProperties.Path.PathDuration | JetFieldSamplerEffect
EffectProperties.Path.PlaybackMode | JetFieldSamplerEffect
EffectProperties.Path.Scale[].x | JetFieldSamplerEffect
EffectProperties.Path.Scale[].y | JetFieldSamplerEffect
EffectProperties.Path.Speed[].x | JetFieldSamplerEffect
EffectProperties.Path.Speed[].y | JetFieldSamplerEffect
EffectProperties.Position.TranslateX | JetFieldSamplerEffect
EffectProperties.Position.TranslateY | JetFieldSamplerEffect
EffectProperties.Position.TranslateZ | JetFieldSamplerEffect
EffectProperties.RandomizeRepeatTime | JetFieldSamplerEffect
EffectProperties.RepeatCount | JetFieldSamplerEffect
EffectProperties.RepeatDelay | JetFieldSamplerEffect
EffectProperties.UserString | JetFieldSamplerEffect
JetFieldSampler | JetFieldSamplerEffect
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: JetFSActorParams Struct Reference

  • Class List
  • Class Members
Public Attributes
JetFSActorParams Struct Reference

Describes the NxParameterized::Interface for 'JetFSActorParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat34 | initialPose
'initialPose' : The initial pose of the actor.
F32 | initialScale
'initialScale' : The initial space scale of the actor
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for JetFS vs Field Boundaries interaction. Overrides asset's value.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for JetFS vs other Field Samplers interaction. Overrides asset's value.

Detailed Description

Describes the NxParameterized::Interface for 'JetFSActorParams' :

JetFSActorParams contains 4 fully qualified names
---------------------------------------------
  1 : Mat34   initialPose
  2 : F32     initialScale
  3 : String  fieldBoundaryFilterDataName
  4 : String  fieldSamplerFilterDataName

Member Data Documentation

String JetFSActorParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for JetFS vs Field Boundaries interaction. Overrides asset's value.

String JetFSActorParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for JetFS vs other Field Samplers interaction. Overrides asset's value.

Mat34 JetFSActorParams::initialPose

'initialPose' : The initial pose of the actor.

The initial pose of the actor. This includes both translation and rotation.

F32 JetFSActorParams::initialScale

'initialScale' : The initial space scale of the actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
JetFSActorParams Member List
This is the complete list of members for JetFSActorParams, including all inherited members.
fieldBoundaryFilterDataName | JetFSActorParams
fieldSamplerFilterDataName | JetFSActorParams
initialPose | JetFSActorParams
initialScale | JetFSActorParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: JetFSAssetParams Struct Reference

  • Class List
  • Class Members
Public Attributes
JetFSAssetParams Struct Reference

Describes the NxParameterized::Interface for 'JetFSAssetParams' : Contains the asset properties for this Jet Field Sampler. More...

#include <params.h>

List of all members.

Public Attributes

F32 | defaultScale
'defaultScale' : The default scale factor of the boundary shape.
F32 | boundaryFadePercentage
'boundaryFadePercentage' : Percentage of distance from boundary to center where fade out starts
Vec3 | fieldDirection
'fieldDirection' : field direction.
F32 | fieldDirectionDeviationAngle
'fieldDirectionDeviationAngle' : field direction deviation angle (in degrees).
F32 | fieldDirectionOscillationPeriod
'fieldDirectionOscillationPeriod' : field direction oscillation period in seconds.
F32 | fieldStrength
'fieldStrength' : field strength.
F32 | fieldStrengthDeviationPercentage
'fieldStrengthDeviationPercentage' : +/- field strength deviation percentage.
F32 | fieldStrengthOscillationPeriod
'fieldStrengthOscillationPeriod' : field strength oscillation period in seconds.
F32 | gridShapeRadius
'gridShapeRadius' : Radius of sphere or capsule shape inside of the grid
F32 | gridShapeHeight
'gridShapeHeight' : Height of capsule shape inside of the grid
F32 | gridBoundaryFadePercentage
'gridBoundaryFadePercentage' : Percentage of distance from boundary to center where fade out starts
F32 | nearRadius
'nearRadius' : near radius of the toroidal field. (inside this radius there's the strongest field)
F32 | pivotRadius
'pivotRadius' : pivot radiues of the toroidal field. (this is the center of the field where it reaches zero)
F32 | farRadius
'farRadius' : far radius of the toroidal field. (outside this radius the field is empty)
F32 | directionalStretch
'directionalStretch' : stretch of the field along the direction
F32 | averageStartDistance
'averageStartDistance' : start distance of blending between averaged & oscilating fields
F32 | averageEndDistance
'averageEndDistance' : end distance of blending between averaged & oscilating fields
F32 | noisePercentage
'noisePercentage' : noise level in percentage of field strength
F32 | noiseSpaceScale
'noiseSpaceScale' : space scale of the noise function
F32 | noiseTimeScale
'noiseTimeScale' : time scale of the noise function
U32 | noiseOctaves
'noiseOctaves' : number of the noise octaves (more octaves give more turbulent noise, but increase computational time)
F32 | fieldDragCoeff
'fieldDragCoeff' : Field drag coefficient. When it equals to 0, then the field is applied as a direct velocity.
F32 | fieldWeight
'fieldWeight' : A weight for the field, it controls how strongly the field affects particles
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for JetFS vs Field Boundaries interaction.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for JetFS vs other Field Samplers interaction.

Detailed Description

Describes the NxParameterized::Interface for 'JetFSAssetParams' : Contains the asset properties for this Jet Field Sampler.

JetFSAssetParams contains 25 fully qualified names
---------------------------------------------
  1 : F32     defaultScale
  2 : F32     boundaryFadePercentage
  3 : Vec3    fieldDirection
  4 : F32     fieldDirectionDeviationAngle
  5 : F32     fieldDirectionOscillationPeriod
  6 : F32     fieldStrength
  7 : F32     fieldStrengthDeviationPercentage
  8 : F32     fieldStrengthOscillationPeriod
  9 : F32     gridShapeRadius
 10 : F32     gridShapeHeight
 11 : F32     gridBoundaryFadePercentage
 12 : F32     nearRadius
 13 : F32     pivotRadius
 14 : F32     farRadius
 15 : F32     directionalStretch
 16 : F32     averageStartDistance
 17 : F32     averageEndDistance
 18 : F32     noisePercentage
 19 : F32     noiseSpaceScale
 20 : F32     noiseTimeScale
 21 : U32     noiseOctaves
 22 : F32     fieldDragCoeff
 23 : F32     fieldWeight
 24 : String  fieldBoundaryFilterDataName
 25 : String  fieldSamplerFilterDataName

Member Data Documentation

F32 JetFSAssetParams::averageEndDistance

'averageEndDistance' : end distance of blending between averaged & oscilating fields

F32 JetFSAssetParams::averageStartDistance

'averageStartDistance' : start distance of blending between averaged & oscilating fields

F32 JetFSAssetParams::boundaryFadePercentage

'boundaryFadePercentage' : Percentage of distance from boundary to center where fade out starts

F32 JetFSAssetParams::defaultScale

'defaultScale' : The default scale factor of the boundary shape.

The default scale factor of the boundary shape. The default value is 1.0.

F32 JetFSAssetParams::directionalStretch

'directionalStretch' : stretch of the field along the direction

F32 JetFSAssetParams::farRadius

'farRadius' : far radius of the toroidal field. (outside this radius the field is empty)

String JetFSAssetParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for JetFS vs Field Boundaries interaction.

Vec3 JetFSAssetParams::fieldDirection

'fieldDirection' : field direction.

F32 JetFSAssetParams::fieldDirectionDeviationAngle

'fieldDirectionDeviationAngle' : field direction deviation angle (in degrees).

The fieldDirectionDeviationAngle parameter controls the deviation in angle of the field direction.

F32 JetFSAssetParams::fieldDirectionOscillationPeriod

'fieldDirectionOscillationPeriod' : field direction oscillation period in seconds.

The fieldDirectionOscillationPeriod defines the period of the field direction oscillation. If the fieldDirectionDeviationAngle is non-zero the period of each sinusoidal cycle will be this parameter in seconds.

F32 JetFSAssetParams::fieldDragCoeff

'fieldDragCoeff' : Field drag coefficient. When it equals to 0, then the field is applied as a direct velocity.

String JetFSAssetParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for JetFS vs other Field Samplers interaction.

F32 JetFSAssetParams::fieldStrength

'fieldStrength' : field strength.

F32 JetFSAssetParams::fieldStrengthDeviationPercentage

'fieldStrengthDeviationPercentage' : +/- field strength deviation percentage.

The fieldStrengthDeviationPercentage parameter controls the deviation in % of the field strength.

F32 JetFSAssetParams::fieldStrengthOscillationPeriod

'fieldStrengthOscillationPeriod' : field strength oscillation period in seconds.

The fieldStrengthOscillationPeriod defines the period of the field strength oscillation. If the fieldStrengthDeviationPercentage is non-zero the period of each sinusoidal cycle will be this parameter in seconds.

F32 JetFSAssetParams::fieldWeight

'fieldWeight' : A weight for the field, it controls how strongly the field affects particles

F32 JetFSAssetParams::gridBoundaryFadePercentage

'gridBoundaryFadePercentage' : Percentage of distance from boundary to center where fade out starts

F32 JetFSAssetParams::gridShapeHeight

'gridShapeHeight' : Height of capsule shape inside of the grid

F32 JetFSAssetParams::gridShapeRadius

'gridShapeRadius' : Radius of sphere or capsule shape inside of the grid

F32 JetFSAssetParams::nearRadius

'nearRadius' : near radius of the toroidal field. (inside this radius there's the strongest field)

U32 JetFSAssetParams::noiseOctaves

'noiseOctaves' : number of the noise octaves (more octaves give more turbulent noise, but increase computational time)

F32 JetFSAssetParams::noisePercentage

'noisePercentage' : noise level in percentage of field strength

F32 JetFSAssetParams::noiseSpaceScale

'noiseSpaceScale' : space scale of the noise function

F32 JetFSAssetParams::noiseTimeScale

'noiseTimeScale' : time scale of the noise function

F32 JetFSAssetParams::pivotRadius

'pivotRadius' : pivot radiues of the toroidal field. (this is the center of the field where it reaches zero)

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
JetFSAssetParams Member List
This is the complete list of members for JetFSAssetParams, including all inherited members.
averageEndDistance | JetFSAssetParams
averageStartDistance | JetFSAssetParams
boundaryFadePercentage | JetFSAssetParams
defaultScale | JetFSAssetParams
directionalStretch | JetFSAssetParams
farRadius | JetFSAssetParams
fieldBoundaryFilterDataName | JetFSAssetParams
fieldDirection | JetFSAssetParams
fieldDirectionDeviationAngle | JetFSAssetParams
fieldDirectionOscillationPeriod | JetFSAssetParams
fieldDragCoeff | JetFSAssetParams
fieldSamplerFilterDataName | JetFSAssetParams
fieldStrength | JetFSAssetParams
fieldStrengthDeviationPercentage | JetFSAssetParams
fieldStrengthOscillationPeriod | JetFSAssetParams
fieldWeight | JetFSAssetParams
gridBoundaryFadePercentage | JetFSAssetParams
gridShapeHeight | JetFSAssetParams
gridShapeRadius | JetFSAssetParams
nearRadius | JetFSAssetParams
noiseOctaves | JetFSAssetParams
noisePercentage | JetFSAssetParams
noiseSpaceScale | JetFSAssetParams
noiseTimeScale | JetFSAssetParams
pivotRadius | JetFSAssetParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: JetFSPreviewParams Struct Reference

  • Class List
  • Class Members
Public Attributes
JetFSPreviewParams Struct Reference

Describes the NxParameterized::Interface for 'JetFSPreviewParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat44 | globalPose
'globalPose' : The pose that translates from turbulence preview coordinates to world coordinates
Bool | drawShape
'drawShape' : Draw shapes of JetFS
Bool | drawAssetInfo
'drawAssetInfo' : Display asset info
U64 | userData
'userData' : Optional user data pointer associated with the turbulence actor

Detailed Description

Describes the NxParameterized::Interface for 'JetFSPreviewParams' :

JetFSPreviewParams contains 4 fully qualified names
---------------------------------------------
  1 : Mat44  globalPose
  2 : Bool   drawShape
  3 : Bool   drawAssetInfo
  4 : U64    userData

Member Data Documentation

Bool JetFSPreviewParams::drawAssetInfo

'drawAssetInfo' : Display asset info

Bool JetFSPreviewParams::drawShape

'drawShape' : Draw shapes of JetFS

Mat44 JetFSPreviewParams::globalPose

'globalPose' : The pose that translates from turbulence preview coordinates to world coordinates

U64 JetFSPreviewParams::userData

'userData' : Optional user data pointer associated with the turbulence actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
JetFSPreviewParams Member List
This is the complete list of members for JetFSPreviewParams, including all inherited members.
drawAssetInfo | JetFSPreviewParams
drawShape | JetFSPreviewParams
globalPose | JetFSPreviewParams
userData | JetFSPreviewParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: MeshCookedCollisionStream Struct Reference

  • Class List
  • Class Members
Public Attributes
MeshCookedCollisionStream Struct Reference

Describes the NxParameterized::Interface for 'MeshCookedCollisionStream' : More...

#include <params.h>

List of all members.

Public Attributes

U8 bytes[]
'bytes[]' : A byte stream used to store cooked convex collision data

Detailed Description

Describes the NxParameterized::Interface for 'MeshCookedCollisionStream' :

MeshCookedCollisionStream contains 2 fully qualified names
---------------------------------------------
  1 : ArraySizeName  bytes
  2 : U8             bytes[]

Member Data Documentation

U8 MeshCookedCollisionStream::bytes[]

'bytes[]' : A byte stream used to store cooked convex collision data

A byte stream used to store cooked convex collision data. One is needed for every chunk at every scale which will be instanced.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
MeshCookedCollisionStream Member List
This is the complete list of members for MeshCookedCollisionStream, including all inherited members.
bytes[] MeshCookedCollisionStream
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: MeshCookedCollisionStreamsAtScale Struct Reference

  • Class List
  • Class Members
Public Attributes
MeshCookedCollisionStreamsAtScale Struct Reference

Describes the NxParameterized::Interface for 'MeshCookedCollisionStreamsAtScale' : More...

#include <params.h>

List of all members.

Public Attributes

MeshCookedCollisionStream meshCookedCollisionStreams[]
'meshCookedCollisionStreams[]' :

Detailed Description

Describes the NxParameterized::Interface for 'MeshCookedCollisionStreamsAtScale' :

MeshCookedCollisionStreamsAtScale contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  meshCookedCollisionStreams
  2 : ArraySizeName  meshCookedCollisionStreams[].bytes    RefVariant[MeshCookedCollisionStream]
  3 : U8             meshCookedCollisionStreams[].bytes[]  RefVariant[MeshCookedCollisionStream]

Member Data Documentation

MeshCookedCollisionStream MeshCookedCollisionStreamsAtScale::meshCookedCollisionStreams[]

'meshCookedCollisionStreams[]' :

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
MeshCookedCollisionStreamsAtScale Member List
This is the complete list of members for MeshCookedCollisionStreamsAtScale, including all inherited members.
meshCookedCollisionStreams[] MeshCookedCollisionStreamsAtScale
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: MeshIofxParameters Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
MeshIofxParameters Struct Reference

Describes the NxParameterized::Interface for 'MeshIofxParameters' : More...

#include <params.h>

List of all members.

Classes

union | ContinuousModifierList
union | SpawnModifierList

Public Attributes

Ref | renderMeshList[].meshAssetName
'renderMeshList[].meshAssetName' : The render mesh asset name or opaque mesh name
U32 | renderMeshList[].weight
'renderMeshList[].weight' : The weight for this mesh (weighed against other meshes)
SpawnModifierList spawnModifierList[]
ContinuousModifierList continuousModifierList[]

Detailed Description

Describes the NxParameterized::Interface for 'MeshIofxParameters' :

MeshIofxParameters contains 65 fully qualified names
---------------------------------------------
  1 : ArraySizeName  renderMeshList
  2 : Ref            renderMeshList[].meshAssetName
  3 : U32            renderMeshList[].weight
  4 : ArraySizeName  spawnModifierList
  5 : RollType       spawnModifierList[].rollType                             RefVariant[RotationModifierParams]
  6 : F32            spawnModifierList[].maxRotationRatePerSec                RefVariant[RotationModifierParams]
  7 : F32            spawnModifierList[].maxSettleRatePerSec                  RefVariant[RotationModifierParams]
  8 : F32            spawnModifierList[].inAirRotationMultiplier              RefVariant[RotationModifierParams]
  9 : F32            spawnModifierList[].collisionRotationMultiplier          RefVariant[RotationModifierParams]
 10 : Bool           spawnModifierList[].includeVerticalDirection             RefVariant[RotationModifierParams]
 11 : Vec3           spawnModifierList[].scaleFactor                          RefVariant[SimpleScaleModifierParams]
 12 : F32            spawnModifierList[].minScaleFactor                       RefVariant[RandomScaleModifierParams]
 13 : F32            spawnModifierList[].maxScaleFactor                       RefVariant[RandomScaleModifierParams]
 14 : Vec4           spawnModifierList[].color                                RefVariant[InitialColorModifierParams]
 15 : ArraySizeName  continuousModifierList
 16 : RollType       continuousModifierList[].rollType                        RefVariant[RotationModifierParams]
 17 : F32            continuousModifierList[].maxRotationRatePerSec           RefVariant[RotationModifierParams]
 18 : F32            continuousModifierList[].maxSettleRatePerSec             RefVariant[RotationModifierParams]
 19 : F32            continuousModifierList[].inAirRotationMultiplier         RefVariant[RotationModifierParams]
 20 : F32            continuousModifierList[].collisionRotationMultiplier     RefVariant[RotationModifierParams]
 21 : Bool           continuousModifierList[].includeVerticalDirection        RefVariant[RotationModifierParams]
 22 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsLife3DModifierParams]
 23 : F32            continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ScaleVsLife3DModifierParams]
 24 : Vec3           continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsLife3DModifierParams]
 25 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensity3DModifierParams]
 26 : F32            continuousModifierList[].controlPoints[].density         RefVariant[ScaleVsDensity3DModifierParams]
 27 : Vec3           continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsDensity3DModifierParams]
 28 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperature3DModifierParams]
 29 : F32            continuousModifierList[].controlPoints[].temperature     RefVariant[ScaleVsTemperature3DModifierParams]
 30 : Vec3           continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsTemperature3DModifierParams]
 31 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistance3DModifierParams]
 32 : F32            continuousModifierList[].controlPoints[].cameraDistance  RefVariant[ScaleVsCameraDistance3DModifierParams]
 33 : Vec3           continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsCameraDistance3DModifierParams]
 34 : Vec3           continuousModifierList[].modelForward                    RefVariant[OrientAlongVelocityModifierParams]
 35 : F32            continuousModifierList[].scaleFactor                     RefVariant[ScaleAlongVelocityModifierParams]
 36 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ColorVsLifeCompositeModifierParams]
 37 : F32            continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ColorVsLifeCompositeModifierParams]
 38 : Vec4           continuousModifierList[].controlPoints[].color           RefVariant[ColorVsLifeCompositeModifierParams]
 39 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ColorVsDensityCompositeModifierParams]
 40 : F32            continuousModifierList[].controlPoints[].density         RefVariant[ColorVsDensityCompositeModifierParams]
 41 : Vec4           continuousModifierList[].controlPoints[].color           RefVariant[ColorVsDensityCompositeModifierParams]
 42 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ColorVsTemperatureCompositeModifierParams]
 43 : F32            continuousModifierList[].controlPoints[].temperature     RefVariant[ColorVsTemperatureCompositeModifierParams]
 44 : Vec4           continuousModifierList[].controlPoints[].color           RefVariant[ColorVsTemperatureCompositeModifierParams]
 45 : ScaleAxis      continuousModifierList[].scaleAxis                       RefVariant[ScaleVsLifeModifierParams]
 46 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsLifeModifierParams]
 47 : F32            continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsLifeModifierParams]
 48 : F32            continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsLifeModifierParams]
 49 : ScaleAxis      continuousModifierList[].scaleAxis                       RefVariant[ScaleVsDensityModifierParams]
 50 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensityModifierParams]
 51 : F32            continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsDensityModifierParams]
 52 : F32            continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsDensityModifierParams]
 53 : ScaleAxis      continuousModifierList[].scaleAxis                       RefVariant[ScaleVsTemperatureModifierParams]
 54 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperatureModifierParams]
 55 : F32            continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsTemperatureModifierParams]
 56 : F32            continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsTemperatureModifierParams]
 57 : ScaleAxis      continuousModifierList[].scaleAxis                       RefVariant[ScaleVsCameraDistanceModifierParams]
 58 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistanceModifierParams]
 59 : F32            continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsCameraDistanceModifierParams]
 60 : F32            continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsCameraDistanceModifierParams]
 61 : F32            continuousModifierList[].velocity0                       RefVariant[ColorVsVelocityCompositeModifierParams]
 62 : F32            continuousModifierList[].velocity1                       RefVariant[ColorVsVelocityCompositeModifierParams]
 63 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ColorVsVelocityCompositeModifierParams]
 64 : F32            continuousModifierList[].controlPoints[].velocity        RefVariant[ColorVsVelocityCompositeModifierParams]
 65 : Vec4           continuousModifierList[].controlPoints[].color           RefVariant[ColorVsVelocityCompositeModifierParams]

Member Data Documentation

ContinuousModifierList MeshIofxParameters::continuousModifierList[]
Ref MeshIofxParameters::renderMeshList[].meshAssetName

'renderMeshList[].meshAssetName' : The render mesh asset name or opaque mesh name

U32 MeshIofxParameters::renderMeshList[].weight

'renderMeshList[].weight' : The weight for this mesh (weighed against other meshes)

SpawnModifierList MeshIofxParameters::spawnModifierList[]
The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
MeshIofxParameters Member List
This is the complete list of members for MeshIofxParameters, including all inherited members.
continuousModifierList[] | MeshIofxParameters
renderMeshList[].meshAssetName | MeshIofxParameters
renderMeshList[].weight | MeshIofxParameters
spawnModifierList[] | MeshIofxParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: NoiseFieldSamplerData Struct Reference

  • Class List
  • Class Members
Public Attributes
NoiseFieldSamplerData Struct Reference

Describes the NxParameterized::Interface for 'NoiseFieldSamplerData' : Contains the asset properties for this noise field sampler. More...

#include <params.h>

List of all members.

Public Attributes

String Name
'Name' : Noise FS Name
NoiseFSAssetParams NoiseFieldSampler
'NoiseFieldSampler' :

Detailed Description

Describes the NxParameterized::Interface for 'NoiseFieldSamplerData' : Contains the asset properties for this noise field sampler.

NoiseFieldSamplerData contains 19 fully qualified names
---------------------------------------------
  1 : String     Name
  2 : F32        NoiseFieldSampler.defaultScale                      RefVariant[NoiseFSAssetParams]
  3 : Vec3       NoiseFieldSampler.boundarySize                      RefVariant[NoiseFSAssetParams]
  4 : F32        NoiseFieldSampler.boundaryFadePercentage            RefVariant[NoiseFSAssetParams]
  5 : FieldType  NoiseFieldSampler.fieldType                         RefVariant[NoiseFSAssetParams]
  6 : F32        NoiseFieldSampler.fieldDragCoeff                    RefVariant[NoiseFSAssetParams]
  7 : F32        NoiseFieldSampler.fieldWeight                       RefVariant[NoiseFSAssetParams]
  8 : NoiseType  NoiseFieldSampler.noiseType                         RefVariant[NoiseFSAssetParams]
  9 : U32        NoiseFieldSampler.noiseSeed                         RefVariant[NoiseFSAssetParams]
 10 : F32        NoiseFieldSampler.noiseStrength                     RefVariant[NoiseFSAssetParams]
 11 : Vec3       NoiseFieldSampler.noiseSpacePeriod                  RefVariant[NoiseFSAssetParams]
 12 : F32        NoiseFieldSampler.noiseTimePeriod                   RefVariant[NoiseFSAssetParams]
 13 : U32        NoiseFieldSampler.noiseOctaves                      RefVariant[NoiseFSAssetParams]
 14 : F32        NoiseFieldSampler.noiseStrengthOctaveMultiplier     RefVariant[NoiseFSAssetParams]
 15 : Vec3       NoiseFieldSampler.noiseSpacePeriodOctaveMultiplier  RefVariant[NoiseFSAssetParams]
 16 : F32        NoiseFieldSampler.noiseTimePeriodOctaveMultiplier   RefVariant[NoiseFSAssetParams]
 17 : String     NoiseFieldSampler.fieldBoundaryFilterDataName       RefVariant[NoiseFSAssetParams]
 18 : String     NoiseFieldSampler.fieldSamplerFilterDataName        RefVariant[NoiseFSAssetParams]
 19 : Bool       NoiseFieldSampler.useLocalSpace                     RefVariant[NoiseFSAssetParams]

Member Data Documentation

String NoiseFieldSamplerData::Name

'Name' : Noise FS Name

NoiseFSAssetParams NoiseFieldSamplerData::NoiseFieldSampler

'NoiseFieldSampler' :

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
NoiseFieldSamplerData Member List
This is the complete list of members for NoiseFieldSamplerData, including all inherited members.
Name | NoiseFieldSamplerData
NoiseFieldSampler | NoiseFieldSamplerData
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: NoiseFieldSamplerEffect Struct Reference

  • Class List
  • Class Members
Public Attributes
NoiseFieldSamplerEffect Struct Reference

Describes the NxParameterized::Interface for 'NoiseFieldSamplerEffect' : A noise field sampler effect. More...

#include <params.h>

List of all members.

Public Attributes

String | EffectProperties.UserString
'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer
Bool | EffectProperties.Enable
'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup
F32 | EffectProperties.Position.TranslateX
'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateY
'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateZ
'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Orientation.RotateX
'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateY
'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateZ
'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)
F32 | EffectProperties.InitialDelayTime
'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect
F32 | EffectProperties.Duration
'EffectProperties.Duration' : The duration of the effect in secontds
U32 | EffectProperties.RepeatCount
'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever
F32 | EffectProperties.RepeatDelay
'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time
F32 | EffectProperties.RandomizeRepeatTime
'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.
PlaybackMode EffectProperties.Path.PlaybackMode
'EffectProperties.Path.PlaybackMode' : The mode to play back the path
F32 | EffectProperties.Path.PathDuration
'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided
U32 | EffectProperties.Path.LoopIndex
'EffectProperties.Path.LoopIndex' : The array index to loop back to
Transform | EffectProperties.Path.ControlPoints[]
'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to
F32 | EffectProperties.Path.Scale[].x
'EffectProperties.Path.Scale[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Scale[].y
'EffectProperties.Path.Scale[].y' : The y-axis value for this vector
F32 | EffectProperties.Path.Speed[].x
'EffectProperties.Path.Speed[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Speed[].y
'EffectProperties.Path.Speed[].y' : The y-axis value for this vector
Ref | NoiseFieldSampler
'NoiseFieldSampler' : Noise FS Asset

Detailed Description

Describes the NxParameterized::Interface for 'NoiseFieldSamplerEffect' : A noise field sampler effect.

NoiseFieldSamplerEffect contains 25 fully qualified names
---------------------------------------------
  1 : String         EffectProperties.UserString
  2 : Bool           EffectProperties.Enable
  3 : F32            EffectProperties.Position.TranslateX
  4 : F32            EffectProperties.Position.TranslateY
  5 : F32            EffectProperties.Position.TranslateZ
  6 : F32            EffectProperties.Orientation.RotateX
  7 : F32            EffectProperties.Orientation.RotateY
  8 : F32            EffectProperties.Orientation.RotateZ
  9 : F32            EffectProperties.InitialDelayTime
 10 : F32            EffectProperties.Duration
 11 : U32            EffectProperties.RepeatCount
 12 : F32            EffectProperties.RepeatDelay
 13 : F32            EffectProperties.RandomizeRepeatTime
 14 : PlaybackMode   EffectProperties.Path.PlaybackMode
 15 : F32            EffectProperties.Path.PathDuration
 16 : U32            EffectProperties.Path.LoopIndex
 17 : ArraySizeName  ControlPoints
 18 : Transform      EffectProperties.Path.ControlPoints[]
 19 : ArraySizeName  Scale
 20 : F32            EffectProperties.Path.Scale[].x
 21 : F32            EffectProperties.Path.Scale[].y
 22 : ArraySizeName  Speed
 23 : F32            EffectProperties.Path.Speed[].x
 24 : F32            EffectProperties.Path.Speed[].y
 25 : Ref            NoiseFieldSampler

Member Data Documentation

F32 NoiseFieldSamplerEffect::EffectProperties.Duration

'EffectProperties.Duration' : The duration of the effect in secontds

Bool NoiseFieldSamplerEffect::EffectProperties.Enable

'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup

F32 NoiseFieldSamplerEffect::EffectProperties.InitialDelayTime

'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect

F32 NoiseFieldSamplerEffect::EffectProperties.Orientation.RotateX

'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)

F32 NoiseFieldSamplerEffect::EffectProperties.Orientation.RotateY

'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)

F32 NoiseFieldSamplerEffect::EffectProperties.Orientation.RotateZ

'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)

Transform NoiseFieldSamplerEffect::EffectProperties.Path.ControlPoints[]

'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to

U32 NoiseFieldSamplerEffect::EffectProperties.Path.LoopIndex

'EffectProperties.Path.LoopIndex' : The array index to loop back to

F32 NoiseFieldSamplerEffect::EffectProperties.Path.PathDuration

'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided

PlaybackMode NoiseFieldSamplerEffect::EffectProperties.Path.PlaybackMode

'EffectProperties.Path.PlaybackMode' : The mode to play back the path

F32 NoiseFieldSamplerEffect::EffectProperties.Path.Scale[].x

'EffectProperties.Path.Scale[].x' : The x-axis value for this vector

F32 NoiseFieldSamplerEffect::EffectProperties.Path.Scale[].y

'EffectProperties.Path.Scale[].y' : The y-axis value for this vector

F32 NoiseFieldSamplerEffect::EffectProperties.Path.Speed[].x

'EffectProperties.Path.Speed[].x' : The x-axis value for this vector

F32 NoiseFieldSamplerEffect::EffectProperties.Path.Speed[].y

'EffectProperties.Path.Speed[].y' : The y-axis value for this vector

F32 NoiseFieldSamplerEffect::EffectProperties.Position.TranslateX

'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction

F32 NoiseFieldSamplerEffect::EffectProperties.Position.TranslateY

'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction

F32 NoiseFieldSamplerEffect::EffectProperties.Position.TranslateZ

'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction

F32 NoiseFieldSamplerEffect::EffectProperties.RandomizeRepeatTime

'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.

U32 NoiseFieldSamplerEffect::EffectProperties.RepeatCount

'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever

F32 NoiseFieldSamplerEffect::EffectProperties.RepeatDelay

'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time

String NoiseFieldSamplerEffect::EffectProperties.UserString

'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer

Ref NoiseFieldSamplerEffect::NoiseFieldSampler

'NoiseFieldSampler' : Noise FS Asset

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
NoiseFieldSamplerEffect Member List
This is the complete list of members for NoiseFieldSamplerEffect, including all inherited members.
EffectProperties.Duration | NoiseFieldSamplerEffect
EffectProperties.Enable | NoiseFieldSamplerEffect
EffectProperties.InitialDelayTime | NoiseFieldSamplerEffect
EffectProperties.Orientation.RotateX | NoiseFieldSamplerEffect
EffectProperties.Orientation.RotateY | NoiseFieldSamplerEffect
EffectProperties.Orientation.RotateZ | NoiseFieldSamplerEffect
EffectProperties.Path.ControlPoints[] | NoiseFieldSamplerEffect
EffectProperties.Path.LoopIndex | NoiseFieldSamplerEffect
EffectProperties.Path.PathDuration | NoiseFieldSamplerEffect
EffectProperties.Path.PlaybackMode | NoiseFieldSamplerEffect
EffectProperties.Path.Scale[].x | NoiseFieldSamplerEffect
EffectProperties.Path.Scale[].y | NoiseFieldSamplerEffect
EffectProperties.Path.Speed[].x | NoiseFieldSamplerEffect
EffectProperties.Path.Speed[].y | NoiseFieldSamplerEffect
EffectProperties.Position.TranslateX | NoiseFieldSamplerEffect
EffectProperties.Position.TranslateY | NoiseFieldSamplerEffect
EffectProperties.Position.TranslateZ | NoiseFieldSamplerEffect
EffectProperties.RandomizeRepeatTime | NoiseFieldSamplerEffect
EffectProperties.RepeatCount | NoiseFieldSamplerEffect
EffectProperties.RepeatDelay | NoiseFieldSamplerEffect
EffectProperties.UserString | NoiseFieldSamplerEffect
NoiseFieldSampler | NoiseFieldSamplerEffect
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: NoiseFSActorParams Struct Reference

  • Class List
  • Class Members
Public Attributes
NoiseFSActorParams Struct Reference

Describes the NxParameterized::Interface for 'NoiseFSActorParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat34 | initialPose
'initialPose' : The initial pose of the actor.
F32 | initialScale
'initialScale' : The initial space scale of the actor
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for NoiseFS vs Field Boundaries interaction. Overrides asset's value.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for NoiseFS vs other Field Samplers interaction. Overrides asset's value.

Detailed Description

Describes the NxParameterized::Interface for 'NoiseFSActorParams' :

NoiseFSActorParams contains 4 fully qualified names
---------------------------------------------
  1 : Mat34   initialPose
  2 : F32     initialScale
  3 : String  fieldBoundaryFilterDataName
  4 : String  fieldSamplerFilterDataName

Member Data Documentation

String NoiseFSActorParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for NoiseFS vs Field Boundaries interaction. Overrides asset's value.

String NoiseFSActorParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for NoiseFS vs other Field Samplers interaction. Overrides asset's value.

Mat34 NoiseFSActorParams::initialPose

'initialPose' : The initial pose of the actor.

The initial pose of the actor. This includes both translation and rotation.

F32 NoiseFSActorParams::initialScale

'initialScale' : The initial space scale of the actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
NoiseFSActorParams Member List
This is the complete list of members for NoiseFSActorParams, including all inherited members.
fieldBoundaryFilterDataName | NoiseFSActorParams
fieldSamplerFilterDataName | NoiseFSActorParams
initialPose | NoiseFSActorParams
initialScale | NoiseFSActorParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: NoiseFSAssetParams Struct Reference

  • Class List
  • Class Members
Public Attributes
NoiseFSAssetParams Struct Reference

Describes the NxParameterized::Interface for 'NoiseFSAssetParams' : Contains the asset properties for this Noise Field Sampler. More...

#include <params.h>

List of all members.

Public Attributes

F32 | defaultScale
'defaultScale' : The default scale factor of the boundary shape.
Vec3 | boundarySize
'boundarySize' : Size of the boundary box.
F32 | boundaryFadePercentage
'boundaryFadePercentage' : Percentage of distance from boundary to center where fade out starts.
FieldType fieldType
'fieldType' : Type of field.
F32 | fieldDragCoeff
'fieldDragCoeff' : Field drag coefficient (only for VELOCITY_DRAG field type).
F32 | fieldWeight
'fieldWeight' : A weight for the field, it controls how strongly the field affects particles
NoiseType noiseType
'noiseType' : Type of noise (simplex, curl and etc.).
U32 | noiseSeed
'noiseSeed' : Seed for the noise random generator.
F32 | noiseStrength
'noiseStrength' : Noise strength.
Vec3 | noiseSpacePeriod
'noiseSpacePeriod' : Noise period in space.
F32 | noiseTimePeriod
'noiseTimePeriod' : Noise period in time.
U32 | noiseOctaves
'noiseOctaves' : Number of the noise octaves (more octaves give more turbulent noise, but increase computational time).
F32 | noiseStrengthOctaveMultiplier
'noiseStrengthOctaveMultiplier' : Noise strength multiplier from one octave to the next.
Vec3 | noiseSpacePeriodOctaveMultiplier
'noiseSpacePeriodOctaveMultiplier' : Noise period in space multiplier from one octave to the next.
F32 | noiseTimePeriodOctaveMultiplier
'noiseTimePeriodOctaveMultiplier' : Noise period in time multiplier from one octave to the next.
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for NoiseFS vs Field Boundaries interaction.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for NoiseFS vs other Field Samplers interaction.
Bool | useLocalSpace
'useLocalSpace' : when enabled, noise calculation is done in the local space.

Detailed Description

Describes the NxParameterized::Interface for 'NoiseFSAssetParams' : Contains the asset properties for this Noise Field Sampler.

NoiseFSAssetParams contains 18 fully qualified names
---------------------------------------------
  1 : F32        defaultScale
  2 : Vec3       boundarySize
  3 : F32        boundaryFadePercentage
  4 : FieldType  fieldType
  5 : F32        fieldDragCoeff
  6 : F32        fieldWeight
  7 : NoiseType  noiseType
  8 : U32        noiseSeed
  9 : F32        noiseStrength
 10 : Vec3       noiseSpacePeriod
 11 : F32        noiseTimePeriod
 12 : U32        noiseOctaves
 13 : F32        noiseStrengthOctaveMultiplier
 14 : Vec3       noiseSpacePeriodOctaveMultiplier
 15 : F32        noiseTimePeriodOctaveMultiplier
 16 : String     fieldBoundaryFilterDataName
 17 : String     fieldSamplerFilterDataName
 18 : Bool       useLocalSpace

Member Data Documentation

F32 NoiseFSAssetParams::boundaryFadePercentage

'boundaryFadePercentage' : Percentage of distance from boundary to center where fade out starts.

Vec3 NoiseFSAssetParams::boundarySize

'boundarySize' : Size of the boundary box.

F32 NoiseFSAssetParams::defaultScale

'defaultScale' : The default scale factor of the boundary shape.

The default scale factor of the boundary shape. The default value is 1.0.

String NoiseFSAssetParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for NoiseFS vs Field Boundaries interaction.

F32 NoiseFSAssetParams::fieldDragCoeff

'fieldDragCoeff' : Field drag coefficient (only for VELOCITY_DRAG field type).

String NoiseFSAssetParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for NoiseFS vs other Field Samplers interaction.

FieldType NoiseFSAssetParams::fieldType

'fieldType' : Type of field.

F32 NoiseFSAssetParams::fieldWeight

'fieldWeight' : A weight for the field, it controls how strongly the field affects particles

U32 NoiseFSAssetParams::noiseOctaves

'noiseOctaves' : Number of the noise octaves (more octaves give more turbulent noise, but increase computational time).

U32 NoiseFSAssetParams::noiseSeed

'noiseSeed' : Seed for the noise random generator.

Vec3 NoiseFSAssetParams::noiseSpacePeriod

'noiseSpacePeriod' : Noise period in space.

Vec3 NoiseFSAssetParams::noiseSpacePeriodOctaveMultiplier

'noiseSpacePeriodOctaveMultiplier' : Noise period in space multiplier from one octave to the next.

F32 NoiseFSAssetParams::noiseStrength

'noiseStrength' : Noise strength.

F32 NoiseFSAssetParams::noiseStrengthOctaveMultiplier

'noiseStrengthOctaveMultiplier' : Noise strength multiplier from one octave to the next.

F32 NoiseFSAssetParams::noiseTimePeriod

'noiseTimePeriod' : Noise period in time.

F32 NoiseFSAssetParams::noiseTimePeriodOctaveMultiplier

'noiseTimePeriodOctaveMultiplier' : Noise period in time multiplier from one octave to the next.

NoiseType NoiseFSAssetParams::noiseType

'noiseType' : Type of noise (simplex, curl and etc.).

Bool NoiseFSAssetParams::useLocalSpace

'useLocalSpace' : when enabled, noise calculation is done in the local space.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
NoiseFSAssetParams Member List
This is the complete list of members for NoiseFSAssetParams, including all inherited members.
boundaryFadePercentage | NoiseFSAssetParams
boundarySize | NoiseFSAssetParams
defaultScale | NoiseFSAssetParams
fieldBoundaryFilterDataName | NoiseFSAssetParams
fieldDragCoeff | NoiseFSAssetParams
fieldSamplerFilterDataName | NoiseFSAssetParams
fieldType | NoiseFSAssetParams
fieldWeight | NoiseFSAssetParams
noiseOctaves | NoiseFSAssetParams
noiseSeed | NoiseFSAssetParams
noiseSpacePeriod | NoiseFSAssetParams
noiseSpacePeriodOctaveMultiplier | NoiseFSAssetParams
noiseStrength | NoiseFSAssetParams
noiseStrengthOctaveMultiplier | NoiseFSAssetParams
noiseTimePeriod | NoiseFSAssetParams
noiseTimePeriodOctaveMultiplier | NoiseFSAssetParams
noiseType | NoiseFSAssetParams
useLocalSpace | NoiseFSAssetParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: NoiseFSPreviewParams Struct Reference

  • Class List
  • Class Members
Public Attributes
NoiseFSPreviewParams Struct Reference

Describes the NxParameterized::Interface for 'NoiseFSPreviewParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat44 | globalPose
'globalPose' : The pose that translates from preview coordinates to world coordinates
Bool | drawShape
'drawShape' : Draw shapes of NoiseFS
Bool | drawAssetInfo
'drawAssetInfo' : Display asset info
U64 | userData
'userData' : Optional user data pointer associated with the actor

Detailed Description

Describes the NxParameterized::Interface for 'NoiseFSPreviewParams' :

NoiseFSPreviewParams contains 4 fully qualified names
---------------------------------------------
  1 : Mat44  globalPose
  2 : Bool   drawShape
  3 : Bool   drawAssetInfo
  4 : U64    userData

Member Data Documentation

Bool NoiseFSPreviewParams::drawAssetInfo

'drawAssetInfo' : Display asset info

Bool NoiseFSPreviewParams::drawShape

'drawShape' : Draw shapes of NoiseFS

Mat44 NoiseFSPreviewParams::globalPose

'globalPose' : The pose that translates from preview coordinates to world coordinates

U64 NoiseFSPreviewParams::userData

'userData' : Optional user data pointer associated with the actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
NoiseFSPreviewParams Member List
This is the complete list of members for NoiseFSPreviewParams, including all inherited members.
drawAssetInfo | NoiseFSPreviewParams
drawShape | NoiseFSPreviewParams
globalPose | NoiseFSPreviewParams
userData | NoiseFSPreviewParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: OrientAlongVelocityModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
OrientAlongVelocityModifierParams Struct Reference

Describes the NxParameterized::Interface for 'OrientAlongVelocityModifierParams' : OrientAlongVelocity modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

Vec3 modelForward
'modelForward' : Model forward

Detailed Description

Describes the NxParameterized::Interface for 'OrientAlongVelocityModifierParams' : OrientAlongVelocity modifier parameters.

OrientAlongVelocityModifierParams contains 1 fully qualified names
---------------------------------------------
  1 : Vec3  modelForward

Member Data Documentation

Vec3 OrientAlongVelocityModifierParams::modelForward

'modelForward' : Model forward

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
OrientAlongVelocityModifierParams Member List
This is the complete list of members for OrientAlongVelocityModifierParams, including all inherited members.
modelForward OrientAlongVelocityModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: OrientScaleAlongScreenVelocityModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
OrientScaleAlongScreenVelocityModifierParams Struct Reference

Describes the NxParameterized::Interface for 'OrientScaleAlongScreenVelocityModifierParams' : OrientScaleAlongScreenVelocity modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | scalePerVelocity
'scalePerVelocity' : Scale per velocity
F32 | scaleChangeLimit
'scaleChangeLimit' : Scale change limimt
F32 | scaleChangeDelay
'scaleChangeDelay' : Scale change delay

Detailed Description

Describes the NxParameterized::Interface for 'OrientScaleAlongScreenVelocityModifierParams' : OrientScaleAlongScreenVelocity modifier parameters.

OrientScaleAlongScreenVelocityModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : F32  scalePerVelocity
  2 : F32  scaleChangeLimit
  3 : F32  scaleChangeDelay

Member Data Documentation

F32 OrientScaleAlongScreenVelocityModifierParams::scaleChangeDelay

'scaleChangeDelay' : Scale change delay

This value is proportional to a delay in time of the scale change, set to 0 to disable the delay

F32 OrientScaleAlongScreenVelocityModifierParams::scaleChangeLimit

'scaleChangeLimit' : Scale change limimt

This value limits the scale change per unit time, set to 0 to disable the limit

F32 OrientScaleAlongScreenVelocityModifierParams::scalePerVelocity

'scalePerVelocity' : Scale per velocity

Scale(Velocity) = 1 + |Velocity| * scalePerVelocity

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
OrientScaleAlongScreenVelocityModifierParams Member List
This is the complete list of members for OrientScaleAlongScreenVelocityModifierParams, including all inherited members.
scaleChangeDelay | OrientScaleAlongScreenVelocityModifierParams
scaleChangeLimit | OrientScaleAlongScreenVelocityModifierParams
scalePerVelocity | OrientScaleAlongScreenVelocityModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ParticleIosAssetParam Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
ParticleIosAssetParam Struct Reference

Describes the NxParameterized::Interface for 'ParticleIosAssetParam' : Contains the asset properties for an IOS. More...

#include <params.h>

List of all members.

Classes

union | ParticleType

Public Attributes

ParticleType particleType
U32 | maxParticleCount
'maxParticleCount' : Maximum particle count
F32 | particleRadius
'particleRadius' : Particle radius
F32 | maxInjectedParticleCount
'maxInjectedParticleCount' : Maximum number of newly created particles on each frame
F32 | maxMotionDistance
'maxMotionDistance' : Max motion distance
F32 | contactOffset
'contactOffset' : Contact offset
F32 | restOffset
'restOffset' : Rest offset
F32 | gridSize
'gridSize' : Grid size
F32 | damping
'damping' : Velocity damping constant
Vec3 | externalAcceleration
'externalAcceleration' : External acceleration
Vec3 | projectionPlaneNormal
'projectionPlaneNormal' : The normal of the plane the particles are projected to
F32 | projectionPlaneDistance
'projectionPlaneDistance' : Constant term of the plane the particles are projected to
F32 | particleMass
'particleMass' : Mass of a particle
F32 | restitution
'restitution' : Restitution coefficient
F32 | dynamicFriction
'dynamicFriction' : Dynamic friction
F32 | staticFriction
'staticFriction' : Static friction
String | simulationFilterData
'simulationFilterData' : The name for the collision filtering data for PhysX object interaction.
String | fieldSamplerFilterData
'fieldSamplerFilterData' : The name for collision filtering data for APEX FieldSampler interaction.
Bool | CollisionTwoway
'CollisionTwoway' : Enable/disable two way collision of particles with the rigid body scene
Bool | CollisionWithDynamicActors
'CollisionWithDynamicActors' : Enable/disable collision of particles with dynamic actors
Bool | Enable
'Enable' : Enables collision with static shapes
Bool | ProjectToPlane
'ProjectToPlane' : Whether the particles of this particle system should be projected to a plane
Bool | PerParticleRestOffset
'PerParticleRestOffset' : Enable/disable per particle rest offsets
Bool | PerParticleCollisionCacheHint
'PerParticleCollisionCacheHint' : Ename/disable per particle collision caches
Bool | DensityBuffer
'DensityBuffer' : Enables reading particle densities from the SDK. (PxParticleFluid only)
Bool | enableTemperatureBuffer
'enableTemperatureBuffer' : Enables temperature buffer.

Detailed Description

Describes the NxParameterized::Interface for 'ParticleIosAssetParam' : Contains the asset properties for an IOS.

ParticleIosAssetParam contains 32 fully qualified names
---------------------------------------------
  1 : Bool        particleType.GridDensity.Enabled       RefVariant[SimpleParticleSystemParams]
  2 : Resolution  particleType.GridDensity.Resolution    RefVariant[SimpleParticleSystemParams]
  3 : F32         particleType.GridDensity.GridSize      RefVariant[SimpleParticleSystemParams]
  4 : U32         particleType.GridDensity.MaxCellCount  RefVariant[SimpleParticleSystemParams]
  5 : F32         particleType.restParticleDistance      RefVariant[FluidParticleSystemParams]
  6 : F32         particleType.stiffness                 RefVariant[FluidParticleSystemParams]
  7 : F32         particleType.viscosity                 RefVariant[FluidParticleSystemParams]
  8 : U32         maxParticleCount
  9 : F32         particleRadius
 10 : F32         maxInjectedParticleCount
 11 : F32         maxMotionDistance
 12 : F32         contactOffset
 13 : F32         restOffset
 14 : F32         gridSize
 15 : F32         damping
 16 : Vec3        externalAcceleration
 17 : Vec3        projectionPlaneNormal
 18 : F32         projectionPlaneDistance
 19 : F32         particleMass
 20 : F32         restitution
 21 : F32         dynamicFriction
 22 : F32         staticFriction
 23 : String      simulationFilterData
 24 : String      fieldSamplerFilterData
 25 : Bool        CollisionTwoway
 26 : Bool        CollisionWithDynamicActors
 27 : Bool        Enable
 28 : Bool        ProjectToPlane
 29 : Bool        PerParticleRestOffset
 30 : Bool        PerParticleCollisionCacheHint
 31 : Bool        DensityBuffer
 32 : Bool        enableTemperatureBuffer

Member Data Documentation

Bool ParticleIosAssetParam::CollisionTwoway

'CollisionTwoway' : Enable/disable two way collision of particles with the rigid body scene

In either case, particles are influenced by colliding rigid bodies. If eCOLLISION_TWOWAY is not set, rigid bodies are not influenced by colliding particles. Use PxParticleBaseDesc.particleMass to control the strength of the feedback force on rigid bodies. Switching this flag while the particle system is part of a scene will fail.

Bool ParticleIosAssetParam::CollisionWithDynamicActors

'CollisionWithDynamicActors' : Enable/disable collision of particles with dynamic actors

The flag can be turned off as a hint to the sdk to save memory space and execution time. In principle any collisions can be turned off using filters but without or reduced memory and performance benefits. Switching this flag while the particle system is part of a scene might have a negative impact on performance.

F32 ParticleIosAssetParam::contactOffset

'contactOffset' : Contact offset

Specifies a skin around the particles within which contacts will be generated Objects that come within contactOffset distance of the particles will count as being in contact (the contactOffset of the other object has no influence). The contactOffset has to be greater than zero and also be greater than the particle systems restOffset. Having a contactOffset bigger than the restOffset is important to avoid jittering and sticking. The contactOffset needs to be positive and the sum maxMotionDistance + contactOffset must not be higher than gridSize.

F32 ParticleIosAssetParam::damping

'damping' : Velocity damping constant

It generally reduces the velocity of the particles. Setting the damping to 0 will leave the particles unaffected.

Bool ParticleIosAssetParam::DensityBuffer

'DensityBuffer' : Enables reading particle densities from the SDK. (PxParticleFluid only)

F32 ParticleIosAssetParam::dynamicFriction

'dynamicFriction' : Dynamic friction

A value of 1 will cause the particle to lose its velocity tangential to the surface normal of the shape at the collision location; i.e. it will not slide along the surface. A value of 0 will preserve the particle's velocity in the tangential surface direction; i.e. it will slide without resistance on the surface.

Bool ParticleIosAssetParam::Enable

'Enable' : Enables collision with static shapes

Bool ParticleIosAssetParam::enableTemperatureBuffer

'enableTemperatureBuffer' : Enables temperature buffer.

Vec3 ParticleIosAssetParam::externalAcceleration

'externalAcceleration' : External acceleration

Acceleration (m/s^2) applied to all particles at all time steps. Useful to simulate smoke or fire. This acceleration is additive to the scene gravity. The scene gravity can be turned off for the particle system, using the flag PxActorFlag::eDISABLE_GRAVITY.

String ParticleIosAssetParam::fieldSamplerFilterData

'fieldSamplerFilterData' : The name for collision filtering data for APEX FieldSampler interaction.

The namespace is NSCollisionGroup64, the type returned should be NxGroupsMask64.

F32 ParticleIosAssetParam::gridSize

'gridSize' : Grid size

This parameter controls the parallelization of the particle system. The spatial domain is divided into equal sized cubes, aligned in a grid. The parameter given defines the scale of the grid. The sdk may internally choose a different, larger value which can be queried with PxParticleBase.getGridSize(). Therefore the parameter has to be considered as a hint only. Large values will have a negative effect on performance, while too small values are problematic due to spatial data structure buffer limits. Balancing this value is important to achieve a good effect while maintaining good performance.

F32 ParticleIosAssetParam::maxInjectedParticleCount

'maxInjectedParticleCount' : Maximum number of newly created particles on each frame

The maximum number of new particles to be spawned on each frame. Use values >1 to provide the absolute value, or 0 <= x <= 1 to provide the percentage rate to overall number of particles.

F32 ParticleIosAssetParam::maxMotionDistance

'maxMotionDistance' : Max motion distance

Max distance a particle can travel in a single simulation step

U32 ParticleIosAssetParam::maxParticleCount

'maxParticleCount' : Maximum particle count

F32 ParticleIosAssetParam::particleMass

'particleMass' : Mass of a particle

The mass is used to translate force or impulses to velocities for collisions (in case PxParticleBaseFlag::eCOLLISION_TWOWAY is set) or for particle updates.

F32 ParticleIosAssetParam::particleRadius

'particleRadius' : Particle radius

Query the authored radius of the instanced objects simulated by this IOS. Emitters need this value for volume fill effects and an IOFX may need it for rendering purposes

ParticleType ParticleIosAssetParam::particleType
Bool ParticleIosAssetParam::PerParticleCollisionCacheHint

'PerParticleCollisionCacheHint' : Ename/disable per particle collision caches

Per particle collision caches improve collision detection performance at the cost of increased memory usage. Switching this flag while the particle system is part of a scene might have a negative impact on performance.

Bool ParticleIosAssetParam::PerParticleRestOffset

'PerParticleRestOffset' : Enable/disable per particle rest offsets

Per particle rest offsets can be used to support particles having different sizes with respect to collision. This configuration cannot be changed after the particle system was created.

F32 ParticleIosAssetParam::projectionPlaneDistance

'projectionPlaneDistance' : Constant term of the plane the particles are projected to

This parameter is only used if PxParticleBaseFlag::ePROJECT_TO_PLANE is set. Together with the parameter projectionPlaneNormal a plane is formed. For each point p on the plane the following equation has to hold: (projectionPlaneNormal.x * p.x) + (projectionPlaneNormal.y * p.y) + (projectionPlaneNormal.z * p.z) + projectionPlaneDistance = 0

Vec3 ParticleIosAssetParam::projectionPlaneNormal

'projectionPlaneNormal' : The normal of the plane the particles are projected to

This parameter is only used if PxParticleBaseFlag::ePROJECT_TO_PLANE is set. Together with the parameter projectionPlaneDistance a plane is formed. For each point p on the plane the following equation has to hold: (projectionPlaneNormal.x * p.x) + (projectionPlaneNormal.y * p.y) + (projectionPlaneNormal.z * p.z) + projectionPlaneDistance = 0

Bool ParticleIosAssetParam::ProjectToPlane

'ProjectToPlane' : Whether the particles of this particle system should be projected to a plane

This can be used to build 2D applications, for instance. The projection plane is defined by the parameter PxParticleBaseDesc.projectionPlaneNormal and PxParticleBaseDesc.projectionPlaneDistance.

F32 ParticleIosAssetParam::restitution

'restitution' : Restitution coefficient

A value of 0 causes the colliding particle to get a zero velocity component in the direction of the surface normal of the shape at the collision location; i.e. it will not bounce. A value of 1 causes a particle's velocity component in the direction of the surface normal to invert; i.e. the particle bounces off the surface with the same velocity magnitude as it had before collision. (Caution: values near 1 may have a negative impact on stability)

F32 ParticleIosAssetParam::restOffset

'restOffset' : Rest offset

Specifies an offset at which particles will come to rest relative to an objects surface Particles will maintain a distance equal to the restOffset to rigid bodies (the restOffset of the rigid body has no influence). If the restOffset is zero the particles should rest exactly on the object surface. The restOffset can alternatively be specified per particle. However the per particle restOffset needs to be smaller or equal to the PxParticleBaseDesc.restOffset.

String ParticleIosAssetParam::simulationFilterData

'simulationFilterData' : The name for the collision filtering data for PhysX object interaction.

The namespace is NSCollisionGroup128, the type returned should be physx::PxFilterData.

F32 ParticleIosAssetParam::staticFriction

'staticFriction' : Static friction

The value defines a limit at which a particle starts to slide along a surface depending on relative tangential and normal velocity components of the particle. A value of 0 will turn off static friction.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ParticleIosAssetParam Member List
This is the complete list of members for ParticleIosAssetParam, including all inherited members.
CollisionTwoway | ParticleIosAssetParam
CollisionWithDynamicActors | ParticleIosAssetParam
contactOffset | ParticleIosAssetParam
damping | ParticleIosAssetParam
DensityBuffer | ParticleIosAssetParam
dynamicFriction | ParticleIosAssetParam
Enable | ParticleIosAssetParam
enableTemperatureBuffer | ParticleIosAssetParam
externalAcceleration | ParticleIosAssetParam
fieldSamplerFilterData | ParticleIosAssetParam
gridSize | ParticleIosAssetParam
maxInjectedParticleCount | ParticleIosAssetParam
maxMotionDistance | ParticleIosAssetParam
maxParticleCount | ParticleIosAssetParam
particleMass | ParticleIosAssetParam
particleRadius | ParticleIosAssetParam
particleType | ParticleIosAssetParam
PerParticleCollisionCacheHint | ParticleIosAssetParam
PerParticleRestOffset | ParticleIosAssetParam
projectionPlaneDistance | ParticleIosAssetParam
projectionPlaneNormal | ParticleIosAssetParam
ProjectToPlane | ParticleIosAssetParam
restitution | ParticleIosAssetParam
restOffset | ParticleIosAssetParam
simulationFilterData | ParticleIosAssetParam
staticFriction | ParticleIosAssetParam
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ParticleIosDebugRenderParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ParticleIosDebugRenderParams Struct Reference

Describes the NxParameterized::Interface for 'ParticleIosDebugRenderParams' : More...

#include <params.h>

List of all members.

Public Attributes

Bool | VISUALIZE_PARTICLE_IOS_ACTOR
'VISUALIZE_PARTICLE_IOS_ACTOR' : Render IOS actor in view window
Bool | VISUALIZE_PARTICLE_IOS_GRID_DENSITY
'VISUALIZE_PARTICLE_IOS_GRID_DENSITY' : Reder IOS Grid density in view window

Detailed Description

Describes the NxParameterized::Interface for 'ParticleIosDebugRenderParams' :

ParticleIosDebugRenderParams contains 2 fully qualified names
---------------------------------------------
  1 : Bool  VISUALIZE_PARTICLE_IOS_ACTOR
  2 : Bool  VISUALIZE_PARTICLE_IOS_GRID_DENSITY

Member Data Documentation

Bool ParticleIosDebugRenderParams::VISUALIZE_PARTICLE_IOS_ACTOR

'VISUALIZE_PARTICLE_IOS_ACTOR' : Render IOS actor in view window

Bool ParticleIosDebugRenderParams::VISUALIZE_PARTICLE_IOS_GRID_DENSITY

'VISUALIZE_PARTICLE_IOS_GRID_DENSITY' : Reder IOS Grid density in view window

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ParticleIosDebugRenderParams Member List
This is the complete list of members for ParticleIosDebugRenderParams, including all inherited members.
VISUALIZE_PARTICLE_IOS_ACTOR | ParticleIosDebugRenderParams
VISUALIZE_PARTICLE_IOS_GRID_DENSITY | ParticleIosDebugRenderParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ParticleIosModuleParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
ParticleIosModuleParameters Struct Reference

Describes the NxParameterized::Interface for 'ParticleIosModuleParameters' : This class is used for initializing the NxModuleParticleIos. More...

#include <params.h>

List of all members.

Public Attributes

U32 unused
'unused' : No parameters necessary

Detailed Description

Describes the NxParameterized::Interface for 'ParticleIosModuleParameters' : This class is used for initializing the NxModuleParticleIos.

ParticleIosModuleParameters contains 1 fully qualified names
---------------------------------------------
  1 : U32  unused

Member Data Documentation

U32 ParticleIosModuleParameters::unused

'unused' : No parameters necessary

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ParticleIosModuleParameters Member List
This is the complete list of members for ParticleIosModuleParameters, including all inherited members.
unused ParticleIosModuleParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ParticlesDebugRenderParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ParticlesDebugRenderParams Struct Reference

Describes the NxParameterized::Interface for 'ParticlesDebugRenderParams' : More...

#include <params.h>

List of all members.

Public Attributes

Bool | VISUALIZE_HEAT_SOURCE_ACTOR
'VISUALIZE_HEAT_SOURCE_ACTOR' : This option allows user to enable or disable debug visualization of a heat source actor
Bool | VISUALIZE_EFFECT_PACKAGE_ACTOR
'VISUALIZE_EFFECT_PACKAGE_ACTOR' : This option allows user to enable or disable debug visualization of an effect package actor

Detailed Description

Describes the NxParameterized::Interface for 'ParticlesDebugRenderParams' :

ParticlesDebugRenderParams contains 2 fully qualified names
---------------------------------------------
  1 : Bool  VISUALIZE_HEAT_SOURCE_ACTOR
  2 : Bool  VISUALIZE_EFFECT_PACKAGE_ACTOR

Member Data Documentation

Bool ParticlesDebugRenderParams::VISUALIZE_EFFECT_PACKAGE_ACTOR

'VISUALIZE_EFFECT_PACKAGE_ACTOR' : This option allows user to enable or disable debug visualization of an effect package actor

Bool ParticlesDebugRenderParams::VISUALIZE_HEAT_SOURCE_ACTOR

'VISUALIZE_HEAT_SOURCE_ACTOR' : This option allows user to enable or disable debug visualization of a heat source actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ParticlesDebugRenderParams Member List
This is the complete list of members for ParticlesDebugRenderParams, including all inherited members.
VISUALIZE_EFFECT_PACKAGE_ACTOR | ParticlesDebugRenderParams
VISUALIZE_HEAT_SOURCE_ACTOR | ParticlesDebugRenderParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ParticleSimulationData Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
ParticleSimulationData Struct Reference

Describes the NxParameterized::Interface for 'ParticleSimulationData' : Contains the asset properties for this particle simulation (IOS) More...

#include <params.h>

List of all members.

Classes

union | IOS

Public Attributes

String | Name
'Name' : Basic IOS Name
IOS IOS

Detailed Description

Describes the NxParameterized::Interface for 'ParticleSimulationData' : Contains the asset properties for this particle simulation (IOS)

ParticleSimulationData contains 58 fully qualified names
---------------------------------------------
  1 : String      Name
  2 : F32         IOS.restDensity                            RefVariant[BasicIOSAssetParam]
  3 : F32         IOS.particleRadius                         RefVariant[BasicIOSAssetParam]
  4 : U32         IOS.maxParticleCount                       RefVariant[BasicIOSAssetParam]
  5 : F32         IOS.maxInjectedParticleCount               RefVariant[BasicIOSAssetParam]
  6 : U32         IOS.maxCollidingObjects                    RefVariant[BasicIOSAssetParam]
  7 : F32         IOS.sceneGravityScale                      RefVariant[BasicIOSAssetParam]
  8 : Vec3        IOS.externalAcceleration                   RefVariant[BasicIOSAssetParam]
  9 : F32         IOS.particleMass.center                    RefVariant[BasicIOSAssetParam]
 10 : F32         IOS.particleMass.spread                    RefVariant[BasicIOSAssetParam]
 11 : Type        IOS.particleMass.type                      RefVariant[BasicIOSAssetParam]
 12 : String      IOS.collisionFilterDataName                RefVariant[BasicIOSAssetParam]
 13 : String      IOS.fieldSamplerFilterDataName             RefVariant[BasicIOSAssetParam]
 14 : Bool        IOS.staticCollision                        RefVariant[BasicIOSAssetParam]
 15 : F32         IOS.restitutionForStaticShapes             RefVariant[BasicIOSAssetParam]
 16 : Bool        IOS.dynamicCollision                       RefVariant[BasicIOSAssetParam]
 17 : F32         IOS.restitutionForDynamicShapes            RefVariant[BasicIOSAssetParam]
 18 : F32         IOS.collisionDistanceMultiplier            RefVariant[BasicIOSAssetParam]
 19 : F32         IOS.collisionThreshold                     RefVariant[BasicIOSAssetParam]
 20 : Bool        IOS.collisionWithConvex                    RefVariant[BasicIOSAssetParam]
 21 : Bool        IOS.collisionWithTriangleMesh              RefVariant[BasicIOSAssetParam]
 22 : Bool        IOS.GridDensity.Enabled                    RefVariant[BasicIOSAssetParam]
 23 : Resolution  IOS.GridDensity.Resolution                 RefVariant[BasicIOSAssetParam]
 24 : F32         IOS.GridDensity.GridSize                   RefVariant[BasicIOSAssetParam]
 25 : U32         IOS.GridDensity.MaxCellCount               RefVariant[BasicIOSAssetParam]
 26 : Bool        IOS.enableTemperatureBuffer                RefVariant[BasicIOSAssetParam]
 27 : Bool        IOS.particleType.GridDensity.Enabled       RefVariant[SimpleParticleSystemParams]
 28 : Resolution  IOS.particleType.GridDensity.Resolution    RefVariant[SimpleParticleSystemParams]
 29 : F32         IOS.particleType.GridDensity.GridSize      RefVariant[SimpleParticleSystemParams]
 30 : U32         IOS.particleType.GridDensity.MaxCellCount  RefVariant[SimpleParticleSystemParams]
 31 : F32         IOS.particleType.restParticleDistance      RefVariant[FluidParticleSystemParams]
 32 : F32         IOS.particleType.stiffness                 RefVariant[FluidParticleSystemParams]
 33 : F32         IOS.particleType.viscosity                 RefVariant[FluidParticleSystemParams]
 34 : U32         IOS.maxParticleCount                       RefVariant[ParticleIosAssetParam]
 35 : F32         IOS.particleRadius                         RefVariant[ParticleIosAssetParam]
 36 : F32         IOS.maxInjectedParticleCount               RefVariant[ParticleIosAssetParam]
 37 : F32         IOS.maxMotionDistance                      RefVariant[ParticleIosAssetParam]
 38 : F32         IOS.contactOffset                          RefVariant[ParticleIosAssetParam]
 39 : F32         IOS.restOffset                             RefVariant[ParticleIosAssetParam]
 40 : F32         IOS.gridSize                               RefVariant[ParticleIosAssetParam]
 41 : F32         IOS.damping                                RefVariant[ParticleIosAssetParam]
 42 : Vec3        IOS.externalAcceleration                   RefVariant[ParticleIosAssetParam]
 43 : Vec3        IOS.projectionPlaneNormal                  RefVariant[ParticleIosAssetParam]
 44 : F32         IOS.projectionPlaneDistance                RefVariant[ParticleIosAssetParam]
 45 : F32         IOS.particleMass                           RefVariant[ParticleIosAssetParam]
 46 : F32         IOS.restitution                            RefVariant[ParticleIosAssetParam]
 47 : F32         IOS.dynamicFriction                        RefVariant[ParticleIosAssetParam]
 48 : F32         IOS.staticFriction                         RefVariant[ParticleIosAssetParam]
 49 : String      IOS.simulationFilterData                   RefVariant[ParticleIosAssetParam]
 50 : String      IOS.fieldSamplerFilterData                 RefVariant[ParticleIosAssetParam]
 51 : Bool        IOS.CollisionTwoway                        RefVariant[ParticleIosAssetParam]
 52 : Bool        IOS.CollisionWithDynamicActors             RefVariant[ParticleIosAssetParam]
 53 : Bool        IOS.Enable                                 RefVariant[ParticleIosAssetParam]
 54 : Bool        IOS.ProjectToPlane                         RefVariant[ParticleIosAssetParam]
 55 : Bool        IOS.PerParticleRestOffset                  RefVariant[ParticleIosAssetParam]
 56 : Bool        IOS.PerParticleCollisionCacheHint          RefVariant[ParticleIosAssetParam]
 57 : Bool        IOS.DensityBuffer                          RefVariant[ParticleIosAssetParam]
 58 : Bool        IOS.enableTemperatureBuffer                RefVariant[ParticleIosAssetParam]

Member Data Documentation

IOS ParticleSimulationData::IOS
String ParticleSimulationData::Name

'Name' : Basic IOS Name

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ParticleSimulationData Member List
This is the complete list of members for ParticleSimulationData, including all inherited members.
IOS | ParticleSimulationData
Name | ParticleSimulationData
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ParticlesModuleParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
ParticlesModuleParameters Struct Reference

Describes the NxParameterized::Interface for 'ParticlesModuleParameters' : This class is used for initializing the NxModuleParticles. More...

#include <params.h>

List of all members.

Public Attributes

U32 unused
'unused' : No parameters necessary

Detailed Description

Describes the NxParameterized::Interface for 'ParticlesModuleParameters' : This class is used for initializing the NxModuleParticles.

ParticlesModuleParameters contains 1 fully qualified names
---------------------------------------------
  1 : U32  unused

Member Data Documentation

U32 ParticlesModuleParameters::unused

'unused' : No parameters necessary

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ParticlesModuleParameters Member List
This is the complete list of members for ParticlesModuleParameters, including all inherited members.
unused ParticlesModuleParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: RadialForceFieldKernelParams Struct Reference

  • Class List
  • Class Members
Public Attributes
RadialForceFieldKernelParams Struct Reference

Describes the NxParameterized::Interface for 'RadialForceFieldKernelParams' : Radial force field kernel correspond to APEX 1.3 Force Field implementation. More...

#include <params.h>

List of all members.

Public Attributes

ForceFieldFalloffParams falloffParameters
'falloffParameters' :
ForceFieldNoiseParams noiseParameters
'noiseParameters' :
F32 radius
'radius' : Sphere Radius

Detailed Description

Describes the NxParameterized::Interface for 'RadialForceFieldKernelParams' : Radial force field kernel correspond to APEX 1.3 Force Field implementation.

RadialForceFieldKernelParams contains 9 fully qualified names
---------------------------------------------
  1 : Type  falloffParameters.type        RefVariant[ForceFieldFalloffParams]
  2 : F32   falloffParameters.multiplier  RefVariant[ForceFieldFalloffParams]
  3 : F32   falloffParameters.start       RefVariant[ForceFieldFalloffParams]
  4 : F32   falloffParameters.end         RefVariant[ForceFieldFalloffParams]
  5 : F32   noiseParameters.strength      RefVariant[ForceFieldNoiseParams]
  6 : F32   noiseParameters.spaceScale    RefVariant[ForceFieldNoiseParams]
  7 : F32   noiseParameters.timeScale     RefVariant[ForceFieldNoiseParams]
  8 : U32   noiseParameters.octaves       RefVariant[ForceFieldNoiseParams]
  9 : F32   radius

Member Data Documentation

ForceFieldFalloffParams RadialForceFieldKernelParams::falloffParameters

'falloffParameters' :

ForceFieldNoiseParams RadialForceFieldKernelParams::noiseParameters

'noiseParameters' :

F32 RadialForceFieldKernelParams::radius

'radius' : Sphere Radius

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
RadialForceFieldKernelParams Member List
This is the complete list of members for RadialForceFieldKernelParams, including all inherited members.
falloffParameters | RadialForceFieldKernelParams
noiseParameters | RadialForceFieldKernelParams
radius | RadialForceFieldKernelParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: RandomRotationModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
RandomRotationModifierParams Struct Reference

Describes the NxParameterized::Interface for 'RandomRotationModifierParams' : RandomRotation modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | minRotation
'minRotation' : Minimum rotation in degrees
F32 | maxRotation
'maxRotation' : Maximum rotation in degrees

Detailed Description

Describes the NxParameterized::Interface for 'RandomRotationModifierParams' : RandomRotation modifier parameters.

RandomRotationModifierParams contains 2 fully qualified names
---------------------------------------------
  1 : F32  minRotation
  2 : F32  maxRotation

Member Data Documentation

F32 RandomRotationModifierParams::maxRotation

'maxRotation' : Maximum rotation in degrees

F32 RandomRotationModifierParams::minRotation

'minRotation' : Minimum rotation in degrees

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
RandomRotationModifierParams Member List
This is the complete list of members for RandomRotationModifierParams, including all inherited members.
maxRotation | RandomRotationModifierParams
minRotation | RandomRotationModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: RandomScaleModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
RandomScaleModifierParams Struct Reference

Describes the NxParameterized::Interface for 'RandomScaleModifierParams' : RandomScale modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | minScaleFactor
'minScaleFactor' : Scale factor
F32 | maxScaleFactor
'maxScaleFactor' : Scale factor

Detailed Description

Describes the NxParameterized::Interface for 'RandomScaleModifierParams' : RandomScale modifier parameters.

RandomScaleModifierParams contains 2 fully qualified names
---------------------------------------------
  1 : F32  minScaleFactor
  2 : F32  maxScaleFactor

Member Data Documentation

F32 RandomScaleModifierParams::maxScaleFactor

'maxScaleFactor' : Scale factor

F32 RandomScaleModifierParams::minScaleFactor

'minScaleFactor' : Scale factor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
RandomScaleModifierParams Member List
This is the complete list of members for RandomScaleModifierParams, including all inherited members.
maxScaleFactor | RandomScaleModifierParams
minScaleFactor | RandomScaleModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: RandomSubtextureModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
RandomSubtextureModifierParams Struct Reference

Describes the NxParameterized::Interface for 'RandomSubtextureModifierParams' : RandomSubtexture modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | minSubtexture
'minSubtexture' : Minimum subtexture index
F32 | maxSubtexture
'maxSubtexture' : Maximum subtexture index

Detailed Description

Describes the NxParameterized::Interface for 'RandomSubtextureModifierParams' : RandomSubtexture modifier parameters.

RandomSubtextureModifierParams contains 2 fully qualified names
---------------------------------------------
  1 : F32  minSubtexture
  2 : F32  maxSubtexture

Member Data Documentation

F32 RandomSubtextureModifierParams::maxSubtexture

'maxSubtexture' : Maximum subtexture index

F32 RandomSubtextureModifierParams::minSubtexture

'minSubtexture' : Minimum subtexture index

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
RandomSubtextureModifierParams Member List
This is the complete list of members for RandomSubtextureModifierParams, including all inherited members.
maxSubtexture | RandomSubtextureModifierParams
minSubtexture | RandomSubtextureModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: RenderMeshAssetParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
RenderMeshAssetParameters Struct Reference

Describes the NxParameterized::Interface for 'RenderMeshAssetParameters' : More...

#include <params.h>

List of all members.

Public Attributes

SubmeshParameters submeshes[]
'submeshes[]' :
String | materialNames[]
'materialNames[]' : Array of material names
Bounds3 | partBounds[]
'partBounds[]' : The AABBs of each mesh part
U32 | textureUVOrigin
'textureUVOrigin' : Texture origin convention
U32 | boneCount
'boneCount' : The number of mesh-skinning bones
Bool | deleteStaticBuffersAfterUse
'deleteStaticBuffersAfterUse' : If set, static data buffers will be deleted after they are used in createRenderResources.
Bool | isReferenced
'isReferenced' : Is the render mesh asset referenced in other assets

Detailed Description

Describes the NxParameterized::Interface for 'RenderMeshAssetParameters' :

RenderMeshAssetParameters contains 82 fully qualified names
---------------------------------------------
  1 : ArraySizeName  submeshes
  2 : U32            submeshes[].vertexBuffer.vertexCount                             RefVariant[VertexBufferParameters]
  3 : U32            submeshes[].vertexBuffer.vertexFormat.winding                    RefVariant[VertexFormatParameters]
  4 : Bool           submeshes[].vertexBuffer.vertexFormat.hasSeparateBoneBuffer      RefVariant[VertexFormatParameters]
  5 : ArraySizeName  submeshes[].vertexBuffer.vertexFormat.bufferFormats              RefVariant[VertexFormatParameters]
  6 : String         submeshes[].vertexBuffer.vertexFormat.bufferFormats[].name       RefVariant[VertexFormatParameters]
  7 : I32            submeshes[].vertexBuffer.vertexFormat.bufferFormats[].semantic   RefVariant[VertexFormatParameters]
  8 : U32            submeshes[].vertexBuffer.vertexFormat.bufferFormats[].id         RefVariant[VertexFormatParameters]
  9 : U32            submeshes[].vertexBuffer.vertexFormat.bufferFormats[].format     RefVariant[VertexFormatParameters]
 10 : U32            submeshes[].vertexBuffer.vertexFormat.bufferFormats[].access     RefVariant[VertexFormatParameters]
 11 : Bool           submeshes[].vertexBuffer.vertexFormat.bufferFormats[].serialize  RefVariant[VertexFormatParameters]
 12 : ArraySizeName  submeshes[].vertexBuffer.buffers                                 RefVariant[VertexBufferParameters]
 13 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU8x1]
 14 : U8             submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferU8x1]
 15 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU8x2]
 16 : U8             submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU8x2]
 17 : U8             submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU8x2]
 18 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU8x3]
 19 : U8             submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU8x3]
 20 : U8             submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU8x3]
 21 : U8             submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU8x3]
 22 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU8x4]
 23 : U8             submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU8x4]
 24 : U8             submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU8x4]
 25 : U8             submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU8x4]
 26 : U8             submeshes[].vertexBuffer.buffers[].data[].w                      RefVariant[BufferU8x4]
 27 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU16x1]
 28 : U16            submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferU16x1]
 29 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU16x2]
 30 : U16            submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU16x2]
 31 : U16            submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU16x2]
 32 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU16x3]
 33 : U16            submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU16x3]
 34 : U16            submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU16x3]
 35 : U16            submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU16x3]
 36 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU16x4]
 37 : U16            submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU16x4]
 38 : U16            submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU16x4]
 39 : U16            submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU16x4]
 40 : U16            submeshes[].vertexBuffer.buffers[].data[].w                      RefVariant[BufferU16x4]
 41 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU32x1]
 42 : U32            submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferU32x1]
 43 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU32x2]
 44 : U32            submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU32x2]
 45 : U32            submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU32x2]
 46 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU32x3]
 47 : U32            submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU32x3]
 48 : U32            submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU32x3]
 49 : U32            submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU32x3]
 50 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferU32x4]
 51 : U32            submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferU32x4]
 52 : U32            submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferU32x4]
 53 : U32            submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferU32x4]
 54 : U32            submeshes[].vertexBuffer.buffers[].data[].w                      RefVariant[BufferU32x4]
 55 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferF32x1]
 56 : F32            submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferF32x1]
 57 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferF32x2]
 58 : F32            submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferF32x2]
 59 : F32            submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferF32x2]
 60 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferF32x3]
 61 : Vec3           submeshes[].vertexBuffer.buffers[].data[]                        RefVariant[BufferF32x3]
 62 : ArraySizeName  submeshes[].vertexBuffer.buffers[].data                          RefVariant[BufferF32x4]
 63 : F32            submeshes[].vertexBuffer.buffers[].data[].x                      RefVariant[BufferF32x4]
 64 : F32            submeshes[].vertexBuffer.buffers[].data[].y                      RefVariant[BufferF32x4]
 65 : F32            submeshes[].vertexBuffer.buffers[].data[].z                      RefVariant[BufferF32x4]
 66 : F32            submeshes[].vertexBuffer.buffers[].data[].w                      RefVariant[BufferF32x4]
 67 : ArraySizeName  submeshes[].indexBuffer                                          RefVariant[SubmeshParameters]
 68 : U32            submeshes[].indexBuffer[]                                        RefVariant[SubmeshParameters]
 69 : ArraySizeName  submeshes[].vertexPartition                                      RefVariant[SubmeshParameters]
 70 : U32            submeshes[].vertexPartition[]                                    RefVariant[SubmeshParameters]
 71 : ArraySizeName  submeshes[].indexPartition                                       RefVariant[SubmeshParameters]
 72 : U32            submeshes[].indexPartition[]                                     RefVariant[SubmeshParameters]
 73 : ArraySizeName  submeshes[].smoothingGroups                                      RefVariant[SubmeshParameters]
 74 : U32            submeshes[].smoothingGroups[]                                    RefVariant[SubmeshParameters]
 75 : ArraySizeName  materialNames
 76 : String         materialNames[]
 77 : ArraySizeName  partBounds
 78 : Bounds3        partBounds[]
 79 : U32            textureUVOrigin
 80 : U32            boneCount
 81 : Bool           deleteStaticBuffersAfterUse
 82 : Bool           isReferenced

Member Data Documentation

U32 RenderMeshAssetParameters::boneCount

'boneCount' : The number of mesh-skinning bones

The number of mesh-skinning bones. For destructible assets, this is the same as the number of parts.

Bool RenderMeshAssetParameters::deleteStaticBuffersAfterUse

'deleteStaticBuffersAfterUse' : If set, static data buffers will be deleted after they are used in createRenderResources.

If set, static data buffers will be deleted after they are used in createRenderResources.

Bool RenderMeshAssetParameters::isReferenced

'isReferenced' : Is the render mesh asset referenced in other assets

String RenderMeshAssetParameters::materialNames[]

'materialNames[]' : Array of material names

The material names which distinguish the submeshes (see submeshes).

Bounds3 RenderMeshAssetParameters::partBounds[]

'partBounds[]' : The AABBs of each mesh part

Array of axis-aligned bounding boxes for each part. The bounds for part i are in partBounds[i].

SubmeshParameters RenderMeshAssetParameters::submeshes[]

'submeshes[]' :

U32 RenderMeshAssetParameters::textureUVOrigin

'textureUVOrigin' : Texture origin convention

The texture origin convention to use for this mesh. See NxTextureUVOrigin.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
RenderMeshAssetParameters Member List
This is the complete list of members for RenderMeshAssetParameters, including all inherited members.
boneCount | RenderMeshAssetParameters
deleteStaticBuffersAfterUse | RenderMeshAssetParameters
isReferenced | RenderMeshAssetParameters
materialNames[] | RenderMeshAssetParameters
partBounds[] | RenderMeshAssetParameters
submeshes[] | RenderMeshAssetParameters
textureUVOrigin | RenderMeshAssetParameters
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: RigidBodyEffect Struct Reference

  • Class List
  • Class Members
Public Attributes
RigidBodyEffect Struct Reference

Describes the NxParameterized::Interface for 'RigidBodyEffect' : An effect comprised of a primitive rigid body shape. More...

#include <params.h>

List of all members.

Public Attributes

String | EffectProperties.UserString
'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer
Bool | EffectProperties.Enable
'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup
F32 | EffectProperties.Position.TranslateX
'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateY
'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateZ
'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Orientation.RotateX
'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateY
'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateZ
'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)
F32 | EffectProperties.InitialDelayTime
'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect
F32 | EffectProperties.Duration
'EffectProperties.Duration' : The duration of the effect in secontds
U32 | EffectProperties.RepeatCount
'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever
F32 | EffectProperties.RepeatDelay
'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time
F32 | EffectProperties.RandomizeRepeatTime
'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.
PlaybackMode EffectProperties.Path.PlaybackMode
'EffectProperties.Path.PlaybackMode' : The mode to play back the path
F32 | EffectProperties.Path.PathDuration
'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided
U32 | EffectProperties.Path.LoopIndex
'EffectProperties.Path.LoopIndex' : The array index to loop back to
Transform | EffectProperties.Path.ControlPoints[]
'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to
F32 | EffectProperties.Path.Scale[].x
'EffectProperties.Path.Scale[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Scale[].y
'EffectProperties.Path.Scale[].y' : The y-axis value for this vector
F32 | EffectProperties.Path.Speed[].x
'EffectProperties.Path.Speed[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Speed[].y
'EffectProperties.Path.Speed[].y' : The y-axis value for this vector
Type Type
'Type' : What type of rigid body primitive this is
String | CollisionFilterDataName
'CollisionFilterDataName' : The collision filter data name
Bool | Dynamic
'Dynamic' : Whether the rigid body is dynamic or kinematic
Bool | Gravity
'Gravity' : A flag to determine if the object responds to gravity or not
Vec3 | Extents
'Extents' : The extents of the primitve, radius, height, or box dimensions XYZ
F32 | Mass
'Mass' : The mass of the object
Vec3 | InitialLinearVelocity
'InitialLinearVelocity' : The initial linear velocity (if dynamic)
Vec3 | InitialAngularVelocity
'InitialAngularVelocity' : The initial angular velocity (if dynamic)
F32 | LinearDamping
'LinearDamping' : The linear damping on the rigid body
F32 | AngularDamping
'AngularDamping' : The angular damping on the rigid body

Detailed Description

Describes the NxParameterized::Interface for 'RigidBodyEffect' : An effect comprised of a primitive rigid body shape.

RigidBodyEffect contains 34 fully qualified names
---------------------------------------------
  1 : String         EffectProperties.UserString
  2 : Bool           EffectProperties.Enable
  3 : F32            EffectProperties.Position.TranslateX
  4 : F32            EffectProperties.Position.TranslateY
  5 : F32            EffectProperties.Position.TranslateZ
  6 : F32            EffectProperties.Orientation.RotateX
  7 : F32            EffectProperties.Orientation.RotateY
  8 : F32            EffectProperties.Orientation.RotateZ
  9 : F32            EffectProperties.InitialDelayTime
 10 : F32            EffectProperties.Duration
 11 : U32            EffectProperties.RepeatCount
 12 : F32            EffectProperties.RepeatDelay
 13 : F32            EffectProperties.RandomizeRepeatTime
 14 : PlaybackMode   EffectProperties.Path.PlaybackMode
 15 : F32            EffectProperties.Path.PathDuration
 16 : U32            EffectProperties.Path.LoopIndex
 17 : ArraySizeName  ControlPoints
 18 : Transform      EffectProperties.Path.ControlPoints[]
 19 : ArraySizeName  Scale
 20 : F32            EffectProperties.Path.Scale[].x
 21 : F32            EffectProperties.Path.Scale[].y
 22 : ArraySizeName  Speed
 23 : F32            EffectProperties.Path.Speed[].x
 24 : F32            EffectProperties.Path.Speed[].y
 25 : Type           Type
 26 : String         CollisionFilterDataName
 27 : Bool           Dynamic
 28 : Bool           Gravity
 29 : Vec3           Extents
 30 : F32            Mass
 31 : Vec3           InitialLinearVelocity
 32 : Vec3           InitialAngularVelocity
 33 : F32            LinearDamping
 34 : F32            AngularDamping

Member Data Documentation

F32 RigidBodyEffect::AngularDamping

'AngularDamping' : The angular damping on the rigid body

String RigidBodyEffect::CollisionFilterDataName

'CollisionFilterDataName' : The collision filter data name

Bool RigidBodyEffect::Dynamic

'Dynamic' : Whether the rigid body is dynamic or kinematic

F32 RigidBodyEffect::EffectProperties.Duration

'EffectProperties.Duration' : The duration of the effect in secontds

Bool RigidBodyEffect::EffectProperties.Enable

'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup

F32 RigidBodyEffect::EffectProperties.InitialDelayTime

'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect

F32 RigidBodyEffect::EffectProperties.Orientation.RotateX

'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)

F32 RigidBodyEffect::EffectProperties.Orientation.RotateY

'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)

F32 RigidBodyEffect::EffectProperties.Orientation.RotateZ

'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)

Transform RigidBodyEffect::EffectProperties.Path.ControlPoints[]

'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to

U32 RigidBodyEffect::EffectProperties.Path.LoopIndex

'EffectProperties.Path.LoopIndex' : The array index to loop back to

F32 RigidBodyEffect::EffectProperties.Path.PathDuration

'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided

PlaybackMode RigidBodyEffect::EffectProperties.Path.PlaybackMode

'EffectProperties.Path.PlaybackMode' : The mode to play back the path

F32 RigidBodyEffect::EffectProperties.Path.Scale[].x

'EffectProperties.Path.Scale[].x' : The x-axis value for this vector

F32 RigidBodyEffect::EffectProperties.Path.Scale[].y

'EffectProperties.Path.Scale[].y' : The y-axis value for this vector

F32 RigidBodyEffect::EffectProperties.Path.Speed[].x

'EffectProperties.Path.Speed[].x' : The x-axis value for this vector

F32 RigidBodyEffect::EffectProperties.Path.Speed[].y

'EffectProperties.Path.Speed[].y' : The y-axis value for this vector

F32 RigidBodyEffect::EffectProperties.Position.TranslateX

'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction

F32 RigidBodyEffect::EffectProperties.Position.TranslateY

'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction

F32 RigidBodyEffect::EffectProperties.Position.TranslateZ

'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction

F32 RigidBodyEffect::EffectProperties.RandomizeRepeatTime

'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.

U32 RigidBodyEffect::EffectProperties.RepeatCount

'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever

F32 RigidBodyEffect::EffectProperties.RepeatDelay

'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time

String RigidBodyEffect::EffectProperties.UserString

'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer

Vec3 RigidBodyEffect::Extents

'Extents' : The extents of the primitve, radius, height, or box dimensions XYZ

Bool RigidBodyEffect::Gravity

'Gravity' : A flag to determine if the object responds to gravity or not

Vec3 RigidBodyEffect::InitialAngularVelocity

'InitialAngularVelocity' : The initial angular velocity (if dynamic)

Vec3 RigidBodyEffect::InitialLinearVelocity

'InitialLinearVelocity' : The initial linear velocity (if dynamic)

F32 RigidBodyEffect::LinearDamping

'LinearDamping' : The linear damping on the rigid body

F32 RigidBodyEffect::Mass

'Mass' : The mass of the object

Type RigidBodyEffect::Type

'Type' : What type of rigid body primitive this is

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
RigidBodyEffect Member List
This is the complete list of members for RigidBodyEffect, including all inherited members.
AngularDamping | RigidBodyEffect
CollisionFilterDataName | RigidBodyEffect
Dynamic | RigidBodyEffect
EffectProperties.Duration | RigidBodyEffect
EffectProperties.Enable | RigidBodyEffect
EffectProperties.InitialDelayTime | RigidBodyEffect
EffectProperties.Orientation.RotateX | RigidBodyEffect
EffectProperties.Orientation.RotateY | RigidBodyEffect
EffectProperties.Orientation.RotateZ | RigidBodyEffect
EffectProperties.Path.ControlPoints[] | RigidBodyEffect
EffectProperties.Path.LoopIndex | RigidBodyEffect
EffectProperties.Path.PathDuration | RigidBodyEffect
EffectProperties.Path.PlaybackMode | RigidBodyEffect
EffectProperties.Path.Scale[].x | RigidBodyEffect
EffectProperties.Path.Scale[].y | RigidBodyEffect
EffectProperties.Path.Speed[].x | RigidBodyEffect
EffectProperties.Path.Speed[].y | RigidBodyEffect
EffectProperties.Position.TranslateX | RigidBodyEffect
EffectProperties.Position.TranslateY | RigidBodyEffect
EffectProperties.Position.TranslateZ | RigidBodyEffect
EffectProperties.RandomizeRepeatTime | RigidBodyEffect
EffectProperties.RepeatCount | RigidBodyEffect
EffectProperties.RepeatDelay | RigidBodyEffect
EffectProperties.UserString | RigidBodyEffect
Extents | RigidBodyEffect
Gravity | RigidBodyEffect
InitialAngularVelocity | RigidBodyEffect
InitialLinearVelocity | RigidBodyEffect
LinearDamping | RigidBodyEffect
Mass | RigidBodyEffect
Type | RigidBodyEffect
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: RotationModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
RotationModifierParams Struct Reference

Describes the NxParameterized::Interface for 'RotationModifierParams' : Rotation modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

RollType rollType
'rollType' : Roll type
F32 | maxRotationRatePerSec
'maxRotationRatePerSec' : Maximum rotation rate for instanced mesh objects
F32 | maxSettleRatePerSec
'maxSettleRatePerSec' : Maximum settle rate for instanced mesh objects
F32 | inAirRotationMultiplier
'inAirRotationMultiplier' : This value is multiplied by the rotation delta to increase or decrease rotations/frame if there are no particle collisions
F32 | collisionRotationMultiplier
'collisionRotationMultiplier' : This value is multiplied by the rotation delta to increase or decrease rotations/frame while colliding objects
Bool | includeVerticalDirection
'includeVerticalDirection' : If false, the vertical speed of the object does not affect the rotation

Detailed Description

Describes the NxParameterized::Interface for 'RotationModifierParams' : Rotation modifier parameters.

RotationModifierParams contains 6 fully qualified names
---------------------------------------------
  1 : RollType  rollType
  2 : F32       maxRotationRatePerSec
  3 : F32       maxSettleRatePerSec
  4 : F32       inAirRotationMultiplier
  5 : F32       collisionRotationMultiplier
  6 : Bool      includeVerticalDirection

Member Data Documentation

F32 RotationModifierParams::collisionRotationMultiplier

'collisionRotationMultiplier' : This value is multiplied by the rotation delta to increase or decrease rotations/frame while colliding objects

F32 RotationModifierParams::inAirRotationMultiplier

'inAirRotationMultiplier' : This value is multiplied by the rotation delta to increase or decrease rotations/frame if there are no particle collisions

Bool RotationModifierParams::includeVerticalDirection

'includeVerticalDirection' : If false, the vertical speed of the object does not affect the rotation

F32 RotationModifierParams::maxRotationRatePerSec

'maxRotationRatePerSec' : Maximum rotation rate for instanced mesh objects

F32 RotationModifierParams::maxSettleRatePerSec

'maxSettleRatePerSec' : Maximum settle rate for instanced mesh objects

RollType RotationModifierParams::rollType

'rollType' : Roll type

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
RotationModifierParams Member List
This is the complete list of members for RotationModifierParams, including all inherited members.
collisionRotationMultiplier | RotationModifierParams
inAirRotationMultiplier | RotationModifierParams
includeVerticalDirection | RotationModifierParams
maxRotationRatePerSec | RotationModifierParams
maxSettleRatePerSec | RotationModifierParams
rollType | RotationModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: RotationRateModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
RotationRateModifierParams Struct Reference

Describes the NxParameterized::Interface for 'RotationRateModifierParams' : RotationRate modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 rotationRate
'rotationRate' : Rotation Rate (revs/sec) for sprite objects

Detailed Description

Describes the NxParameterized::Interface for 'RotationRateModifierParams' : RotationRate modifier parameters.

RotationRateModifierParams contains 1 fully qualified names
---------------------------------------------
  1 : F32  rotationRate

Member Data Documentation

F32 RotationRateModifierParams::rotationRate

'rotationRate' : Rotation Rate (revs/sec) for sprite objects

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
RotationRateModifierParams Member List
This is the complete list of members for RotationRateModifierParams, including all inherited members.
rotationRate RotationRateModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: RotationRateVsLifeModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
RotationRateVsLifeModifierParams Struct Reference

Describes the NxParameterized::Interface for 'RotationRateVsLifeModifierParams' : RotationRateVsLife modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | controlPoints[].x
'controlPoints[].x' : Life time
F32 | controlPoints[].y
'controlPoints[].y' : Rotation rate (revs/sec)

Detailed Description

Describes the NxParameterized::Interface for 'RotationRateVsLifeModifierParams' : RotationRateVsLife modifier parameters.

RotationRateVsLifeModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  controlPoints
  2 : F32            controlPoints[].x
  3 : F32            controlPoints[].y

Member Data Documentation

F32 RotationRateVsLifeModifierParams::controlPoints[].x

'controlPoints[].x' : Life time

F32 RotationRateVsLifeModifierParams::controlPoints[].y

'controlPoints[].y' : Rotation rate (revs/sec)

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
RotationRateVsLifeModifierParams Member List
This is the complete list of members for RotationRateVsLifeModifierParams, including all inherited members.
controlPoints[].x | RotationRateVsLifeModifierParams
controlPoints[].y | RotationRateVsLifeModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ScaleAlongVelocityModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ScaleAlongVelocityModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleAlongVelocityModifierParams' : ScaleAlongVelocity modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 scaleFactor
'scaleFactor' : Scale factor

Detailed Description

Describes the NxParameterized::Interface for 'ScaleAlongVelocityModifierParams' : ScaleAlongVelocity modifier parameters.

ScaleAlongVelocityModifierParams contains 1 fully qualified names
---------------------------------------------
  1 : F32  scaleFactor

Member Data Documentation

F32 ScaleAlongVelocityModifierParams::scaleFactor

'scaleFactor' : Scale factor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ScaleAlongVelocityModifierParams Member List
This is the complete list of members for ScaleAlongVelocityModifierParams, including all inherited members.
scaleFactor ScaleAlongVelocityModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ScaleByMassModifierParams Struct Reference

  • Class List
  • Class Members
ScaleByMassModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleByMassModifierParams' : ScaleByMass modifier parameters. More...

#include <params.h>

Detailed Description

Describes the NxParameterized::Interface for 'ScaleByMassModifierParams' : ScaleByMass modifier parameters.

ScaleByMassModifierParams contains 0 fully qualified names
---------------------------------------------
The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ScaleVsCameraDistance2DModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ScaleVsCameraDistance2DModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleVsCameraDistance2DModifierParams' : ScaleVsCameraDistance2D modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | controlPoints[].cameraDistance
'controlPoints[].cameraDistance' : Camera distance
Vec2 | controlPoints[].scale
'controlPoints[].scale' : Scale

Detailed Description

Describes the NxParameterized::Interface for 'ScaleVsCameraDistance2DModifierParams' : ScaleVsCameraDistance2D modifier parameters.

ScaleVsCameraDistance2DModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  controlPoints
  2 : F32            controlPoints[].cameraDistance
  3 : Vec2           controlPoints[].scale

Member Data Documentation

F32 ScaleVsCameraDistance2DModifierParams::controlPoints[].cameraDistance

'controlPoints[].cameraDistance' : Camera distance

Vec2 ScaleVsCameraDistance2DModifierParams::controlPoints[].scale

'controlPoints[].scale' : Scale

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ScaleVsCameraDistance2DModifierParams Member List
This is the complete list of members for ScaleVsCameraDistance2DModifierParams, including all inherited members.
controlPoints[].cameraDistance | ScaleVsCameraDistance2DModifierParams
controlPoints[].scale | ScaleVsCameraDistance2DModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ScaleVsCameraDistance3DModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ScaleVsCameraDistance3DModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleVsCameraDistance3DModifierParams' : ScaleVsCameraDistance3D modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | controlPoints[].cameraDistance
'controlPoints[].cameraDistance' : Camera distance
Vec3 | controlPoints[].scale
'controlPoints[].scale' : Scale

Detailed Description

Describes the NxParameterized::Interface for 'ScaleVsCameraDistance3DModifierParams' : ScaleVsCameraDistance3D modifier parameters.

ScaleVsCameraDistance3DModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  controlPoints
  2 : F32            controlPoints[].cameraDistance
  3 : Vec3           controlPoints[].scale

Member Data Documentation

F32 ScaleVsCameraDistance3DModifierParams::controlPoints[].cameraDistance

'controlPoints[].cameraDistance' : Camera distance

Vec3 ScaleVsCameraDistance3DModifierParams::controlPoints[].scale

'controlPoints[].scale' : Scale

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ScaleVsCameraDistance3DModifierParams Member List
This is the complete list of members for ScaleVsCameraDistance3DModifierParams, including all inherited members.
controlPoints[].cameraDistance | ScaleVsCameraDistance3DModifierParams
controlPoints[].scale | ScaleVsCameraDistance3DModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ScaleVsCameraDistanceModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ScaleVsCameraDistanceModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleVsCameraDistanceModifierParams' : ScaleVsCameraDistance modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

ScaleAxis scaleAxis
'scaleAxis' : Scale axis to which the curve will be applied
F32 | controlPoints[].x
'controlPoints[].x' : Camera distance
F32 | controlPoints[].y
'controlPoints[].y' : Scale

Detailed Description

Describes the NxParameterized::Interface for 'ScaleVsCameraDistanceModifierParams' : ScaleVsCameraDistance modifier parameters.

ScaleVsCameraDistanceModifierParams contains 4 fully qualified names
---------------------------------------------
  1 : ScaleAxis      scaleAxis
  2 : ArraySizeName  controlPoints
  3 : F32            controlPoints[].x
  4 : F32            controlPoints[].y

Member Data Documentation

F32 ScaleVsCameraDistanceModifierParams::controlPoints[].x

'controlPoints[].x' : Camera distance

F32 ScaleVsCameraDistanceModifierParams::controlPoints[].y

'controlPoints[].y' : Scale

ScaleAxis ScaleVsCameraDistanceModifierParams::scaleAxis

'scaleAxis' : Scale axis to which the curve will be applied

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ScaleVsCameraDistanceModifierParams Member List
This is the complete list of members for ScaleVsCameraDistanceModifierParams, including all inherited members.
controlPoints[].x | ScaleVsCameraDistanceModifierParams
controlPoints[].y | ScaleVsCameraDistanceModifierParams
scaleAxis | ScaleVsCameraDistanceModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ScaleVsDensity2DModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ScaleVsDensity2DModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleVsDensity2DModifierParams' : ScaleVsDensity2D modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | controlPoints[].density
'controlPoints[].density' : Density
Vec2 | controlPoints[].scale
'controlPoints[].scale' : Scale

Detailed Description

Describes the NxParameterized::Interface for 'ScaleVsDensity2DModifierParams' : ScaleVsDensity2D modifier parameters.

ScaleVsDensity2DModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  controlPoints
  2 : F32            controlPoints[].density
  3 : Vec2           controlPoints[].scale

Member Data Documentation

F32 ScaleVsDensity2DModifierParams::controlPoints[].density

'controlPoints[].density' : Density

Vec2 ScaleVsDensity2DModifierParams::controlPoints[].scale

'controlPoints[].scale' : Scale

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ScaleVsDensity2DModifierParams Member List
This is the complete list of members for ScaleVsDensity2DModifierParams, including all inherited members.
controlPoints[].density | ScaleVsDensity2DModifierParams
controlPoints[].scale | ScaleVsDensity2DModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ScaleVsDensity3DModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ScaleVsDensity3DModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleVsDensity3DModifierParams' : ScaleVsDensity3D modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | controlPoints[].density
'controlPoints[].density' : Density
Vec3 | controlPoints[].scale
'controlPoints[].scale' : Scale

Detailed Description

Describes the NxParameterized::Interface for 'ScaleVsDensity3DModifierParams' : ScaleVsDensity3D modifier parameters.

ScaleVsDensity3DModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  controlPoints
  2 : F32            controlPoints[].density
  3 : Vec3           controlPoints[].scale

Member Data Documentation

F32 ScaleVsDensity3DModifierParams::controlPoints[].density

'controlPoints[].density' : Density

Vec3 ScaleVsDensity3DModifierParams::controlPoints[].scale

'controlPoints[].scale' : Scale

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ScaleVsDensity3DModifierParams Member List
This is the complete list of members for ScaleVsDensity3DModifierParams, including all inherited members.
controlPoints[].density | ScaleVsDensity3DModifierParams
controlPoints[].scale | ScaleVsDensity3DModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ScaleVsDensityModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ScaleVsDensityModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleVsDensityModifierParams' : ScaleVsDensity modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

ScaleAxis scaleAxis
'scaleAxis' : Scale axis to which the curve will be applied
F32 | controlPoints[].x
'controlPoints[].x' : Density
F32 | controlPoints[].y
'controlPoints[].y' : Scale

Detailed Description

Describes the NxParameterized::Interface for 'ScaleVsDensityModifierParams' : ScaleVsDensity modifier parameters.

ScaleVsDensityModifierParams contains 4 fully qualified names
---------------------------------------------
  1 : ScaleAxis      scaleAxis
  2 : ArraySizeName  controlPoints
  3 : F32            controlPoints[].x
  4 : F32            controlPoints[].y

Member Data Documentation

F32 ScaleVsDensityModifierParams::controlPoints[].x

'controlPoints[].x' : Density

F32 ScaleVsDensityModifierParams::controlPoints[].y

'controlPoints[].y' : Scale

ScaleAxis ScaleVsDensityModifierParams::scaleAxis

'scaleAxis' : Scale axis to which the curve will be applied

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ScaleVsDensityModifierParams Member List
This is the complete list of members for ScaleVsDensityModifierParams, including all inherited members.
controlPoints[].x | ScaleVsDensityModifierParams
controlPoints[].y | ScaleVsDensityModifierParams
scaleAxis | ScaleVsDensityModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ScaleVsLife2DModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ScaleVsLife2DModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleVsLife2DModifierParams' : ScaleVsLife2D modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | controlPoints[].lifeRemaining
'controlPoints[].lifeRemaining' : Life remaining
Vec2 | controlPoints[].scale
'controlPoints[].scale' : Scale

Detailed Description

Describes the NxParameterized::Interface for 'ScaleVsLife2DModifierParams' : ScaleVsLife2D modifier parameters.

ScaleVsLife2DModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  controlPoints
  2 : F32            controlPoints[].lifeRemaining
  3 : Vec2           controlPoints[].scale

Member Data Documentation

F32 ScaleVsLife2DModifierParams::controlPoints[].lifeRemaining

'controlPoints[].lifeRemaining' : Life remaining

Vec2 ScaleVsLife2DModifierParams::controlPoints[].scale

'controlPoints[].scale' : Scale

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ScaleVsLife2DModifierParams Member List
This is the complete list of members for ScaleVsLife2DModifierParams, including all inherited members.
controlPoints[].lifeRemaining | ScaleVsLife2DModifierParams
controlPoints[].scale | ScaleVsLife2DModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ScaleVsLife3DModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ScaleVsLife3DModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleVsLife3DModifierParams' : ScaleVsLife3D modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | controlPoints[].lifeRemaining
'controlPoints[].lifeRemaining' : Life remaining
Vec3 | controlPoints[].scale
'controlPoints[].scale' : Scale

Detailed Description

Describes the NxParameterized::Interface for 'ScaleVsLife3DModifierParams' : ScaleVsLife3D modifier parameters.

ScaleVsLife3DModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  controlPoints
  2 : F32            controlPoints[].lifeRemaining
  3 : Vec3           controlPoints[].scale

Member Data Documentation

F32 ScaleVsLife3DModifierParams::controlPoints[].lifeRemaining

'controlPoints[].lifeRemaining' : Life remaining

Vec3 ScaleVsLife3DModifierParams::controlPoints[].scale

'controlPoints[].scale' : Scale

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ScaleVsLife3DModifierParams Member List
This is the complete list of members for ScaleVsLife3DModifierParams, including all inherited members.
controlPoints[].lifeRemaining | ScaleVsLife3DModifierParams
controlPoints[].scale | ScaleVsLife3DModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ScaleVsLifeModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ScaleVsLifeModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleVsLifeModifierParams' : ScaleVsLife modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

ScaleAxis scaleAxis
'scaleAxis' : Scale axis to which the curve will be applied
F32 | controlPoints[].x
'controlPoints[].x' : Life
F32 | controlPoints[].y
'controlPoints[].y' : Scale

Detailed Description

Describes the NxParameterized::Interface for 'ScaleVsLifeModifierParams' : ScaleVsLife modifier parameters.

ScaleVsLifeModifierParams contains 4 fully qualified names
---------------------------------------------
  1 : ScaleAxis      scaleAxis
  2 : ArraySizeName  controlPoints
  3 : F32            controlPoints[].x
  4 : F32            controlPoints[].y

Member Data Documentation

F32 ScaleVsLifeModifierParams::controlPoints[].x

'controlPoints[].x' : Life

F32 ScaleVsLifeModifierParams::controlPoints[].y

'controlPoints[].y' : Scale

ScaleAxis ScaleVsLifeModifierParams::scaleAxis

'scaleAxis' : Scale axis to which the curve will be applied

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ScaleVsLifeModifierParams Member List
This is the complete list of members for ScaleVsLifeModifierParams, including all inherited members.
controlPoints[].x | ScaleVsLifeModifierParams
controlPoints[].y | ScaleVsLifeModifierParams
scaleAxis | ScaleVsLifeModifierParams
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ScaleVsTemperature2DModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ScaleVsTemperature2DModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleVsTemperature2DModifierParams' : ScaleVsTemperature2D modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | controlPoints[].temperature
'controlPoints[].temperature' : Temperature
Vec2 | controlPoints[].scale
'controlPoints[].scale' : Scale

Detailed Description

Describes the NxParameterized::Interface for 'ScaleVsTemperature2DModifierParams' : ScaleVsTemperature2D modifier parameters.

ScaleVsTemperature2DModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  controlPoints
  2 : F32            controlPoints[].temperature
  3 : Vec2           controlPoints[].scale

Member Data Documentation

Vec2 ScaleVsTemperature2DModifierParams::controlPoints[].scale

'controlPoints[].scale' : Scale

F32 ScaleVsTemperature2DModifierParams::controlPoints[].temperature

'controlPoints[].temperature' : Temperature

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ScaleVsTemperature2DModifierParams Member List
This is the complete list of members for ScaleVsTemperature2DModifierParams, including all inherited members.
controlPoints[].scale | ScaleVsTemperature2DModifierParams
controlPoints[].temperature | ScaleVsTemperature2DModifierParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: ScaleVsTemperature3DModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ScaleVsTemperature3DModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleVsTemperature3DModifierParams' : ScaleVsTemperature3D modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | controlPoints[].temperature
'controlPoints[].temperature' : Temperature
Vec3 | controlPoints[].scale
'controlPoints[].scale' : Scale

Detailed Description

Describes the NxParameterized::Interface for 'ScaleVsTemperature3DModifierParams' : ScaleVsTemperature3D modifier parameters.

ScaleVsTemperature3DModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  controlPoints
  2 : F32            controlPoints[].temperature
  3 : Vec3           controlPoints[].scale

Member Data Documentation

Vec3 ScaleVsTemperature3DModifierParams::controlPoints[].scale

'controlPoints[].scale' : Scale

F32 ScaleVsTemperature3DModifierParams::controlPoints[].temperature

'controlPoints[].temperature' : Temperature

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ScaleVsTemperature3DModifierParams Member List
This is the complete list of members for ScaleVsTemperature3DModifierParams, including all inherited members.
controlPoints[].scale | ScaleVsTemperature3DModifierParams
controlPoints[].temperature | ScaleVsTemperature3DModifierParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: ScaleVsTemperatureModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ScaleVsTemperatureModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ScaleVsTemperatureModifierParams' : ScaleVsTemperature modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

ScaleAxis scaleAxis
'scaleAxis' : Scale axis to which the curve will be applied
F32 | controlPoints[].x
'controlPoints[].x' : Temperature
F32 | controlPoints[].y
'controlPoints[].y' : Scale

Detailed Description

Describes the NxParameterized::Interface for 'ScaleVsTemperatureModifierParams' : ScaleVsTemperature modifier parameters.

ScaleVsTemperatureModifierParams contains 4 fully qualified names
---------------------------------------------
  1 : ScaleAxis      scaleAxis
  2 : ArraySizeName  controlPoints
  3 : F32            controlPoints[].x
  4 : F32            controlPoints[].y

Member Data Documentation

F32 ScaleVsTemperatureModifierParams::controlPoints[].x

'controlPoints[].x' : Temperature

F32 ScaleVsTemperatureModifierParams::controlPoints[].y

'controlPoints[].y' : Scale

ScaleAxis ScaleVsTemperatureModifierParams::scaleAxis

'scaleAxis' : Scale axis to which the curve will be applied

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ScaleVsTemperatureModifierParams Member List
This is the complete list of members for ScaleVsTemperatureModifierParams, including all inherited members.
controlPoints[].x | ScaleVsTemperatureModifierParams
controlPoints[].y | ScaleVsTemperatureModifierParams
scaleAxis | ScaleVsTemperatureModifierParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SimpleParticleSystemParams Struct Reference

  • Class List
  • Class Members
Public Attributes
SimpleParticleSystemParams Struct Reference

Describes the NxParameterized::Interface for 'SimpleParticleSystemParams' : More...

#include <params.h>

List of all members.

Public Attributes

Bool | GridDensity.Enabled
'GridDensity.Enabled' : Compute a Density Using a Grid
Resolution GridDensity.Resolution
'GridDensity.Resolution' : Number of cells in a 3D grid, used to calculate particles positions. Higher values divide the grid into more cells.
F32 | GridDensity.GridSize
'GridDensity.GridSize' : Depth of grid
U32 | GridDensity.MaxCellCount
'GridDensity.MaxCellCount' : This is the number of particles within a grid cell for a density of 1

Detailed Description

Describes the NxParameterized::Interface for 'SimpleParticleSystemParams' :

SimpleParticleSystemParams contains 4 fully qualified names
---------------------------------------------
  1 : Bool        GridDensity.Enabled
  2 : Resolution  GridDensity.Resolution
  3 : F32         GridDensity.GridSize
  4 : U32         GridDensity.MaxCellCount

Member Data Documentation

Bool SimpleParticleSystemParams::GridDensity.Enabled

'GridDensity.Enabled' : Compute a Density Using a Grid

If this option is true; a density will be computed based on the grouping of particles in a 3d grid

F32 SimpleParticleSystemParams::GridDensity.GridSize

'GridDensity.GridSize' : Depth of grid

The default value is 10 units Must be positive.

U32 SimpleParticleSystemParams::GridDensity.MaxCellCount

'GridDensity.MaxCellCount' : This is the number of particles within a grid cell for a density of 1

This is the integer count representing how many particles reside in a single grid cell before the density is considered 1. It is valid for the density to be greater than one. For example, if there were 32 particles in a grid cell with a max-cell count of 16, then the density would be equal to 2.

Resolution SimpleParticleSystemParams::GridDensity.Resolution

'GridDensity.Resolution' : Number of cells in a 3D grid, used to calculate particles positions. Higher values divide the grid into more cells.

This enumeration defines the 3d resolution of the grid.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
SimpleParticleSystemParams Member List
This is the complete list of members for SimpleParticleSystemParams, including all inherited members.
GridDensity.Enabled | SimpleParticleSystemParams
GridDensity.GridSize | SimpleParticleSystemParams
GridDensity.MaxCellCount | SimpleParticleSystemParams
GridDensity.Resolution | SimpleParticleSystemParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SimpleScaleModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
SimpleScaleModifierParams Struct Reference

Describes the NxParameterized::Interface for 'SimpleScaleModifierParams' : SimpleScale modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

Vec3 scaleFactor
'scaleFactor' : Scale factor

Detailed Description

Describes the NxParameterized::Interface for 'SimpleScaleModifierParams' : SimpleScale modifier parameters.

SimpleScaleModifierParams contains 1 fully qualified names
---------------------------------------------
  1 : Vec3  scaleFactor

Member Data Documentation

Vec3 SimpleScaleModifierParams::scaleFactor

'scaleFactor' : Scale factor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
SimpleScaleModifierParams Member List
This is the complete list of members for SimpleScaleModifierParams, including all inherited members.
scaleFactor SimpleScaleModifierParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SpriteIofxParameters Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
SpriteIofxParameters Struct Reference

Describes the NxParameterized::Interface for 'SpriteIofxParameters' : More...

#include <params.h>

List of all members.

Classes

union | ContinuousModifierList
union | SpawnModifierList

Public Attributes

Ref | spriteMaterialName
'spriteMaterialName' : The sprite material name (if this is a sprite IOFX)
SpawnModifierList spawnModifierList[]
ContinuousModifierList continuousModifierList[]

Detailed Description

Describes the NxParameterized::Interface for 'SpriteIofxParameters' :

SpriteIofxParameters contains 80 fully qualified names
---------------------------------------------
  1 : Ref            spriteMaterialName
  2 : ArraySizeName  spawnModifierList
  3 : Vec3           spawnModifierList[].scaleFactor                          RefVariant[SimpleScaleModifierParams]
  4 : F32            spawnModifierList[].minScaleFactor                       RefVariant[RandomScaleModifierParams]
  5 : F32            spawnModifierList[].maxScaleFactor                       RefVariant[RandomScaleModifierParams]
  6 : Vec4           spawnModifierList[].color                                RefVariant[InitialColorModifierParams]
  7 : F32            spawnModifierList[].minSubtexture                        RefVariant[RandomSubtextureModifierParams]
  8 : F32            spawnModifierList[].maxSubtexture                        RefVariant[RandomSubtextureModifierParams]
  9 : F32            spawnModifierList[].minRotation                          RefVariant[RandomRotationModifierParams]
 10 : F32            spawnModifierList[].maxRotation                          RefVariant[RandomRotationModifierParams]
 11 : ColorChannel   spawnModifierList[].colorChannel                         RefVariant[ColorVsLifeModifierParams]
 12 : ArraySizeName  spawnModifierList[].controlPoints                        RefVariant[ColorVsLifeModifierParams]
 13 : F32            spawnModifierList[].controlPoints[].x                    RefVariant[ColorVsLifeModifierParams]
 14 : F32            spawnModifierList[].controlPoints[].y                    RefVariant[ColorVsLifeModifierParams]
 15 : ArraySizeName  continuousModifierList
 16 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ColorVsLifeCompositeModifierParams]
 17 : F32            continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ColorVsLifeCompositeModifierParams]
 18 : Vec4           continuousModifierList[].controlPoints[].color           RefVariant[ColorVsLifeCompositeModifierParams]
 19 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ColorVsDensityCompositeModifierParams]
 20 : F32            continuousModifierList[].controlPoints[].density         RefVariant[ColorVsDensityCompositeModifierParams]
 21 : Vec4           continuousModifierList[].controlPoints[].color           RefVariant[ColorVsDensityCompositeModifierParams]
 22 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ColorVsTemperatureCompositeModifierParams]
 23 : F32            continuousModifierList[].controlPoints[].temperature     RefVariant[ColorVsTemperatureCompositeModifierParams]
 24 : Vec4           continuousModifierList[].controlPoints[].color           RefVariant[ColorVsTemperatureCompositeModifierParams]
 25 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsLife2DModifierParams]
 26 : F32            continuousModifierList[].controlPoints[].lifeRemaining   RefVariant[ScaleVsLife2DModifierParams]
 27 : Vec2           continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsLife2DModifierParams]
 28 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensity2DModifierParams]
 29 : F32            continuousModifierList[].controlPoints[].density         RefVariant[ScaleVsDensity2DModifierParams]
 30 : Vec2           continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsDensity2DModifierParams]
 31 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperature2DModifierParams]
 32 : F32            continuousModifierList[].controlPoints[].temperature     RefVariant[ScaleVsTemperature2DModifierParams]
 33 : Vec2           continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsTemperature2DModifierParams]
 34 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistance2DModifierParams]
 35 : F32            continuousModifierList[].controlPoints[].cameraDistance  RefVariant[ScaleVsCameraDistance2DModifierParams]
 36 : Vec2           continuousModifierList[].controlPoints[].scale           RefVariant[ScaleVsCameraDistance2DModifierParams]
 37 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[SubtextureVsLifeModifierParams]
 38 : F32            continuousModifierList[].controlPoints[].x               RefVariant[SubtextureVsLifeModifierParams]
 39 : F32            continuousModifierList[].controlPoints[].y               RefVariant[SubtextureVsLifeModifierParams]
 40 : SortType       continuousModifierList[].sortType                        RefVariant[ViewDirectionSortingModifierParams]
 41 : ColorChannel   continuousModifierList[].colorChannel                    RefVariant[ColorVsLifeModifierParams]
 42 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ColorVsLifeModifierParams]
 43 : F32            continuousModifierList[].controlPoints[].x               RefVariant[ColorVsLifeModifierParams]
 44 : F32            continuousModifierList[].controlPoints[].y               RefVariant[ColorVsLifeModifierParams]
 45 : ColorChannel   continuousModifierList[].colorChannel                    RefVariant[ColorVsDensityModifierParams]
 46 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ColorVsDensityModifierParams]
 47 : F32            continuousModifierList[].controlPoints[].x               RefVariant[ColorVsDensityModifierParams]
 48 : F32            continuousModifierList[].controlPoints[].y               RefVariant[ColorVsDensityModifierParams]
 49 : ColorChannel   continuousModifierList[].colorChannel                    RefVariant[ColorVsTemperatureModifierParams]
 50 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ColorVsTemperatureModifierParams]
 51 : F32            continuousModifierList[].controlPoints[].x               RefVariant[ColorVsTemperatureModifierParams]
 52 : F32            continuousModifierList[].controlPoints[].y               RefVariant[ColorVsTemperatureModifierParams]
 53 : ScaleAxis      continuousModifierList[].scaleAxis                       RefVariant[ScaleVsLifeModifierParams]
 54 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsLifeModifierParams]
 55 : F32            continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsLifeModifierParams]
 56 : F32            continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsLifeModifierParams]
 57 : ScaleAxis      continuousModifierList[].scaleAxis                       RefVariant[ScaleVsDensityModifierParams]
 58 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsDensityModifierParams]
 59 : F32            continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsDensityModifierParams]
 60 : F32            continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsDensityModifierParams]
 61 : ScaleAxis      continuousModifierList[].scaleAxis                       RefVariant[ScaleVsTemperatureModifierParams]
 62 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsTemperatureModifierParams]
 63 : F32            continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsTemperatureModifierParams]
 64 : F32            continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsTemperatureModifierParams]
 65 : ScaleAxis      continuousModifierList[].scaleAxis                       RefVariant[ScaleVsCameraDistanceModifierParams]
 66 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ScaleVsCameraDistanceModifierParams]
 67 : F32            continuousModifierList[].controlPoints[].x               RefVariant[ScaleVsCameraDistanceModifierParams]
 68 : F32            continuousModifierList[].controlPoints[].y               RefVariant[ScaleVsCameraDistanceModifierParams]
 69 : F32            continuousModifierList[].rotationRate                    RefVariant[RotationRateModifierParams]
 70 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[RotationRateVsLifeModifierParams]
 71 : F32            continuousModifierList[].controlPoints[].x               RefVariant[RotationRateVsLifeModifierParams]
 72 : F32            continuousModifierList[].controlPoints[].y               RefVariant[RotationRateVsLifeModifierParams]
 73 : F32            continuousModifierList[].scalePerVelocity                RefVariant[OrientScaleAlongScreenVelocityModifierParams]
 74 : F32            continuousModifierList[].scaleChangeLimit                RefVariant[OrientScaleAlongScreenVelocityModifierParams]
 75 : F32            continuousModifierList[].scaleChangeDelay                RefVariant[OrientScaleAlongScreenVelocityModifierParams]
 76 : F32            continuousModifierList[].velocity0                       RefVariant[ColorVsVelocityCompositeModifierParams]
 77 : F32            continuousModifierList[].velocity1                       RefVariant[ColorVsVelocityCompositeModifierParams]
 78 : ArraySizeName  continuousModifierList[].controlPoints                   RefVariant[ColorVsVelocityCompositeModifierParams]
 79 : F32            continuousModifierList[].controlPoints[].velocity        RefVariant[ColorVsVelocityCompositeModifierParams]
 80 : Vec4           continuousModifierList[].controlPoints[].color           RefVariant[ColorVsVelocityCompositeModifierParams]

Member Data Documentation

ContinuousModifierList SpriteIofxParameters::continuousModifierList[]
SpawnModifierList SpriteIofxParameters::spawnModifierList[]
Ref SpriteIofxParameters::spriteMaterialName

'spriteMaterialName' : The sprite material name (if this is a sprite IOFX)

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
SpriteIofxParameters Member List
This is the complete list of members for SpriteIofxParameters, including all inherited members.
continuousModifierList[] | SpriteIofxParameters
spawnModifierList[] | SpriteIofxParameters
spriteMaterialName | SpriteIofxParameters
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SubmeshParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
SubmeshParameters Struct Reference

Describes the NxParameterized::Interface for 'SubmeshParameters' : More...

#include <params.h>

List of all members.

Public Attributes

VertexBufferParameters vertexBuffer
'vertexBuffer' :
U32 | indexBuffer[]
'indexBuffer[]' : The index buffer for this submesh
U32 | vertexPartition[]
'vertexPartition[]' : Part lookup into vertexBuffer
U32 | indexPartition[]
'indexPartition[]' : Part lookup into indexBuffer
U32 | smoothingGroups[]
'smoothingGroups[]' : Per-triangle smoothing group masks

Detailed Description

Describes the NxParameterized::Interface for 'SubmeshParameters' :

SubmeshParameters contains 73 fully qualified names
---------------------------------------------
  1 : U32            vertexBuffer.vertexCount                             RefVariant[VertexBufferParameters]
  2 : U32            vertexBuffer.vertexFormat.winding                    RefVariant[VertexFormatParameters]
  3 : Bool           vertexBuffer.vertexFormat.hasSeparateBoneBuffer      RefVariant[VertexFormatParameters]
  4 : ArraySizeName  vertexBuffer.vertexFormat.bufferFormats              RefVariant[VertexFormatParameters]
  5 : String         vertexBuffer.vertexFormat.bufferFormats[].name       RefVariant[VertexFormatParameters]
  6 : I32            vertexBuffer.vertexFormat.bufferFormats[].semantic   RefVariant[VertexFormatParameters]
  7 : U32            vertexBuffer.vertexFormat.bufferFormats[].id         RefVariant[VertexFormatParameters]
  8 : U32            vertexBuffer.vertexFormat.bufferFormats[].format     RefVariant[VertexFormatParameters]
  9 : U32            vertexBuffer.vertexFormat.bufferFormats[].access     RefVariant[VertexFormatParameters]
 10 : Bool           vertexBuffer.vertexFormat.bufferFormats[].serialize  RefVariant[VertexFormatParameters]
 11 : ArraySizeName  vertexBuffer.buffers                                 RefVariant[VertexBufferParameters]
 12 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferU8x1]
 13 : U8             vertexBuffer.buffers[].data[]                        RefVariant[BufferU8x1]
 14 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferU8x2]
 15 : U8             vertexBuffer.buffers[].data[].x                      RefVariant[BufferU8x2]
 16 : U8             vertexBuffer.buffers[].data[].y                      RefVariant[BufferU8x2]
 17 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferU8x3]
 18 : U8             vertexBuffer.buffers[].data[].x                      RefVariant[BufferU8x3]
 19 : U8             vertexBuffer.buffers[].data[].y                      RefVariant[BufferU8x3]
 20 : U8             vertexBuffer.buffers[].data[].z                      RefVariant[BufferU8x3]
 21 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferU8x4]
 22 : U8             vertexBuffer.buffers[].data[].x                      RefVariant[BufferU8x4]
 23 : U8             vertexBuffer.buffers[].data[].y                      RefVariant[BufferU8x4]
 24 : U8             vertexBuffer.buffers[].data[].z                      RefVariant[BufferU8x4]
 25 : U8             vertexBuffer.buffers[].data[].w                      RefVariant[BufferU8x4]
 26 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferU16x1]
 27 : U16            vertexBuffer.buffers[].data[]                        RefVariant[BufferU16x1]
 28 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferU16x2]
 29 : U16            vertexBuffer.buffers[].data[].x                      RefVariant[BufferU16x2]
 30 : U16            vertexBuffer.buffers[].data[].y                      RefVariant[BufferU16x2]
 31 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferU16x3]
 32 : U16            vertexBuffer.buffers[].data[].x                      RefVariant[BufferU16x3]
 33 : U16            vertexBuffer.buffers[].data[].y                      RefVariant[BufferU16x3]
 34 : U16            vertexBuffer.buffers[].data[].z                      RefVariant[BufferU16x3]
 35 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferU16x4]
 36 : U16            vertexBuffer.buffers[].data[].x                      RefVariant[BufferU16x4]
 37 : U16            vertexBuffer.buffers[].data[].y                      RefVariant[BufferU16x4]
 38 : U16            vertexBuffer.buffers[].data[].z                      RefVariant[BufferU16x4]
 39 : U16            vertexBuffer.buffers[].data[].w                      RefVariant[BufferU16x4]
 40 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferU32x1]
 41 : U32            vertexBuffer.buffers[].data[]                        RefVariant[BufferU32x1]
 42 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferU32x2]
 43 : U32            vertexBuffer.buffers[].data[].x                      RefVariant[BufferU32x2]
 44 : U32            vertexBuffer.buffers[].data[].y                      RefVariant[BufferU32x2]
 45 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferU32x3]
 46 : U32            vertexBuffer.buffers[].data[].x                      RefVariant[BufferU32x3]
 47 : U32            vertexBuffer.buffers[].data[].y                      RefVariant[BufferU32x3]
 48 : U32            vertexBuffer.buffers[].data[].z                      RefVariant[BufferU32x3]
 49 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferU32x4]
 50 : U32            vertexBuffer.buffers[].data[].x                      RefVariant[BufferU32x4]
 51 : U32            vertexBuffer.buffers[].data[].y                      RefVariant[BufferU32x4]
 52 : U32            vertexBuffer.buffers[].data[].z                      RefVariant[BufferU32x4]
 53 : U32            vertexBuffer.buffers[].data[].w                      RefVariant[BufferU32x4]
 54 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferF32x1]
 55 : F32            vertexBuffer.buffers[].data[]                        RefVariant[BufferF32x1]
 56 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferF32x2]
 57 : F32            vertexBuffer.buffers[].data[].x                      RefVariant[BufferF32x2]
 58 : F32            vertexBuffer.buffers[].data[].y                      RefVariant[BufferF32x2]
 59 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferF32x3]
 60 : Vec3           vertexBuffer.buffers[].data[]                        RefVariant[BufferF32x3]
 61 : ArraySizeName  vertexBuffer.buffers[].data                          RefVariant[BufferF32x4]
 62 : F32            vertexBuffer.buffers[].data[].x                      RefVariant[BufferF32x4]
 63 : F32            vertexBuffer.buffers[].data[].y                      RefVariant[BufferF32x4]
 64 : F32            vertexBuffer.buffers[].data[].z                      RefVariant[BufferF32x4]
 65 : F32            vertexBuffer.buffers[].data[].w                      RefVariant[BufferF32x4]
 66 : ArraySizeName  indexBuffer
 67 : U32            indexBuffer[]
 68 : ArraySizeName  vertexPartition
 69 : U32            vertexPartition[]
 70 : ArraySizeName  indexPartition
 71 : U32            indexPartition[]
 72 : ArraySizeName  smoothingGroups
 73 : U32            smoothingGroups[]

Member Data Documentation

U32 SubmeshParameters::indexBuffer[]

'indexBuffer[]' : The index buffer for this submesh

This is the vertex buffer included with this submesh. The submesh is defined by a index buffer and an vertex buffer (see vertexBuffer). The indices for different mesh parts are stored in contiguous subsets of the whole index buffer. The indexPartition array holds the offsets into the indexBuffer for each part.

U32 SubmeshParameters::indexPartition[]

'indexPartition[]' : Part lookup into indexBuffer

Index offset into indexBuffer for each part. The first index location in indexPartition for part i is indexPartition[i]. The indexPartition array size is N+1, where N = the number of mesh parts, and indexPartition[N] = the size of the indexBuffer. This way, the number of indices for part i can be always be obtained with indexPartition[i+1]-indexPartition[i].

U32 SubmeshParameters::smoothingGroups[]

'smoothingGroups[]' : Per-triangle smoothing group masks

Per-triangle smoothing group masks

VertexBufferParameters SubmeshParameters::vertexBuffer

'vertexBuffer' :

U32 SubmeshParameters::vertexPartition[]

'vertexPartition[]' : Part lookup into vertexBuffer

Index offset into vertexBuffer for each part. The first vertex index for part i is vertexPartition[i]. The vertexPartition array size is N+1, where N = the number of mesh parts, and vertexPartition[N] = vertexBuffer.vertexCount (the size of the vertex buffer). This way, the number of vertices for part i can be always be obtained with vertexPartition[i+1]-vertexPartition[i].

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
SubmeshParameters Member List
This is the complete list of members for SubmeshParameters, including all inherited members.
indexBuffer[] | SubmeshParameters
indexPartition[] | SubmeshParameters
smoothingGroups[] | SubmeshParameters
vertexBuffer | SubmeshParameters
vertexPartition[] | SubmeshParameters
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SubstanceSourceActorParams Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
SubstanceSourceActorParams Struct Reference

Describes the NxParameterized::Interface for 'SubstanceSourceActorParams' : More...

#include <params.h>

List of all members.

Classes

union | GeometryType

Public Attributes

Mat34 | initialPose
'initialPose' : The global pose for the actor.
F32 | initialScale
'initialScale' : The space scale of the actor
F32 | averageDensity
'averageDensity' : The arithmetic mean of a sample. Normal distribution parameter.
F32 | stdDensity
'stdDensity' : Standard deviation. Normal distribution parameter.
GeometryType geometryType
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for SubstanceSource vs TurbulenceFS interaction. Overrides asset's value.

Detailed Description

Describes the NxParameterized::Interface for 'SubstanceSourceActorParams' :

SubstanceSourceActorParams contains 7 fully qualified names
---------------------------------------------
  1 : Mat34   initialPose
  2 : F32     initialScale
  3 : F32     averageDensity
  4 : F32     stdDensity
  5 : Vec3    geometryType.extents        RefVariant[HeatSourceGeomBoxParams]
  6 : F32     geometryType.radius         RefVariant[HeatSourceGeomSphereParams]
  7 : String  fieldSamplerFilterDataName

Member Data Documentation

F32 SubstanceSourceActorParams::averageDensity

'averageDensity' : The arithmetic mean of a sample. Normal distribution parameter.

String SubstanceSourceActorParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for SubstanceSource vs TurbulenceFS interaction. Overrides asset's value.

GeometryType SubstanceSourceActorParams::geometryType
Mat34 SubstanceSourceActorParams::initialPose

'initialPose' : The global pose for the actor.

F32 SubstanceSourceActorParams::initialScale

'initialScale' : The space scale of the actor

F32 SubstanceSourceActorParams::stdDensity

'stdDensity' : Standard deviation. Normal distribution parameter.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
SubstanceSourceActorParams Member List
This is the complete list of members for SubstanceSourceActorParams, including all inherited members.
averageDensity | SubstanceSourceActorParams
fieldSamplerFilterDataName | SubstanceSourceActorParams
geometryType | SubstanceSourceActorParams
initialPose | SubstanceSourceActorParams
initialScale | SubstanceSourceActorParams
stdDensity | SubstanceSourceActorParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SubstanceSourceAssetParams Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
SubstanceSourceAssetParams Struct Reference

Describes the NxParameterized::Interface for 'SubstanceSourceAssetParams' : Contains the asset properties for this SubstanceSource. More...

#include <params.h>

List of all members.

Classes

union | GeometryType

Public Attributes

Vec3 | position
'position' : Initial position for substance sorce.
F32 | averageDensity
'averageDensity' : The arithmetic mean of a sample. Normal distribution parameter.
F32 | stdDensity
'stdDensity' : Standard deviation. Normal distribution parameter.
GeometryType geometryType
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for SubstanceSource vs TurbulenceFS interaction.

Detailed Description

Describes the NxParameterized::Interface for 'SubstanceSourceAssetParams' : Contains the asset properties for this SubstanceSource.

SubstanceSourceAssetParams contains 6 fully qualified names
---------------------------------------------
  1 : Vec3    position
  2 : F32     averageDensity
  3 : F32     stdDensity
  4 : Vec3    geometryType.extents        RefVariant[HeatSourceGeomBoxParams]
  5 : F32     geometryType.radius         RefVariant[HeatSourceGeomSphereParams]
  6 : String  fieldSamplerFilterDataName

Member Data Documentation

F32 SubstanceSourceAssetParams::averageDensity

'averageDensity' : The arithmetic mean of a sample. Normal distribution parameter.

String SubstanceSourceAssetParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for SubstanceSource vs TurbulenceFS interaction.

GeometryType SubstanceSourceAssetParams::geometryType
Vec3 SubstanceSourceAssetParams::position

'position' : Initial position for substance sorce.

F32 SubstanceSourceAssetParams::stdDensity

'stdDensity' : Standard deviation. Normal distribution parameter.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
SubstanceSourceAssetParams Member List
This is the complete list of members for SubstanceSourceAssetParams, including all inherited members.
averageDensity | SubstanceSourceAssetParams
fieldSamplerFilterDataName | SubstanceSourceAssetParams
geometryType | SubstanceSourceAssetParams
position | SubstanceSourceAssetParams
stdDensity | SubstanceSourceAssetParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SubstanceSourceData Struct Reference

  • Class List
  • Class Members
Public Attributes
SubstanceSourceData Struct Reference

Describes the NxParameterized::Interface for 'SubstanceSourceData' : Contains the asset properties for this substance source. More...

#include <params.h>

List of all members.

Public Attributes

String Name
'Name' : Substance Source Name
SubstanceSourceAssetParams SubstanceSource
'SubstanceSource' :

Detailed Description

Describes the NxParameterized::Interface for 'SubstanceSourceData' : Contains the asset properties for this substance source.

SubstanceSourceData contains 7 fully qualified names
---------------------------------------------
  1 : String  Name
  2 : Vec3    SubstanceSource.position                    RefVariant[SubstanceSourceAssetParams]
  3 : F32     SubstanceSource.averageDensity              RefVariant[SubstanceSourceAssetParams]
  4 : F32     SubstanceSource.stdDensity                  RefVariant[SubstanceSourceAssetParams]
  5 : Vec3    SubstanceSource.geometryType.extents        RefVariant[HeatSourceGeomBoxParams]
  6 : F32     SubstanceSource.geometryType.radius         RefVariant[HeatSourceGeomSphereParams]
  7 : String  SubstanceSource.fieldSamplerFilterDataName  RefVariant[SubstanceSourceAssetParams]

Member Data Documentation

String SubstanceSourceData::Name

'Name' : Substance Source Name

SubstanceSourceAssetParams SubstanceSourceData::SubstanceSource

'SubstanceSource' :

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
SubstanceSourceData Member List
This is the complete list of members for SubstanceSourceData, including all inherited members.
Name | SubstanceSourceData
SubstanceSource | SubstanceSourceData
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SubstanceSourceEffect Struct Reference

  • Class List
  • Class Members
Public Attributes
SubstanceSourceEffect Struct Reference

Describes the NxParameterized::Interface for 'SubstanceSourceEffect' : A substance source effect. More...

#include <params.h>

List of all members.

Public Attributes

String | EffectProperties.UserString
'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer
Bool | EffectProperties.Enable
'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup
F32 | EffectProperties.Position.TranslateX
'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateY
'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateZ
'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Orientation.RotateX
'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateY
'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateZ
'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)
F32 | EffectProperties.InitialDelayTime
'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect
F32 | EffectProperties.Duration
'EffectProperties.Duration' : The duration of the effect in secontds
U32 | EffectProperties.RepeatCount
'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever
F32 | EffectProperties.RepeatDelay
'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time
F32 | EffectProperties.RandomizeRepeatTime
'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.
PlaybackMode EffectProperties.Path.PlaybackMode
'EffectProperties.Path.PlaybackMode' : The mode to play back the path
F32 | EffectProperties.Path.PathDuration
'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided
U32 | EffectProperties.Path.LoopIndex
'EffectProperties.Path.LoopIndex' : The array index to loop back to
Transform | EffectProperties.Path.ControlPoints[]
'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to
F32 | EffectProperties.Path.Scale[].x
'EffectProperties.Path.Scale[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Scale[].y
'EffectProperties.Path.Scale[].y' : The y-axis value for this vector
F32 | EffectProperties.Path.Speed[].x
'EffectProperties.Path.Speed[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Speed[].y
'EffectProperties.Path.Speed[].y' : The y-axis value for this vector
Ref | SubstanceSource
'SubstanceSource' : Substance Source Asset

Detailed Description

Describes the NxParameterized::Interface for 'SubstanceSourceEffect' : A substance source effect.

SubstanceSourceEffect contains 25 fully qualified names
---------------------------------------------
  1 : String         EffectProperties.UserString
  2 : Bool           EffectProperties.Enable
  3 : F32            EffectProperties.Position.TranslateX
  4 : F32            EffectProperties.Position.TranslateY
  5 : F32            EffectProperties.Position.TranslateZ
  6 : F32            EffectProperties.Orientation.RotateX
  7 : F32            EffectProperties.Orientation.RotateY
  8 : F32            EffectProperties.Orientation.RotateZ
  9 : F32            EffectProperties.InitialDelayTime
 10 : F32            EffectProperties.Duration
 11 : U32            EffectProperties.RepeatCount
 12 : F32            EffectProperties.RepeatDelay
 13 : F32            EffectProperties.RandomizeRepeatTime
 14 : PlaybackMode   EffectProperties.Path.PlaybackMode
 15 : F32            EffectProperties.Path.PathDuration
 16 : U32            EffectProperties.Path.LoopIndex
 17 : ArraySizeName  ControlPoints
 18 : Transform      EffectProperties.Path.ControlPoints[]
 19 : ArraySizeName  Scale
 20 : F32            EffectProperties.Path.Scale[].x
 21 : F32            EffectProperties.Path.Scale[].y
 22 : ArraySizeName  Speed
 23 : F32            EffectProperties.Path.Speed[].x
 24 : F32            EffectProperties.Path.Speed[].y
 25 : Ref            SubstanceSource

Member Data Documentation

F32 SubstanceSourceEffect::EffectProperties.Duration

'EffectProperties.Duration' : The duration of the effect in secontds

Bool SubstanceSourceEffect::EffectProperties.Enable

'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup

F32 SubstanceSourceEffect::EffectProperties.InitialDelayTime

'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect

F32 SubstanceSourceEffect::EffectProperties.Orientation.RotateX

'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)

F32 SubstanceSourceEffect::EffectProperties.Orientation.RotateY

'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)

F32 SubstanceSourceEffect::EffectProperties.Orientation.RotateZ

'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)

Transform SubstanceSourceEffect::EffectProperties.Path.ControlPoints[]

'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to

U32 SubstanceSourceEffect::EffectProperties.Path.LoopIndex

'EffectProperties.Path.LoopIndex' : The array index to loop back to

F32 SubstanceSourceEffect::EffectProperties.Path.PathDuration

'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided

PlaybackMode SubstanceSourceEffect::EffectProperties.Path.PlaybackMode

'EffectProperties.Path.PlaybackMode' : The mode to play back the path

F32 SubstanceSourceEffect::EffectProperties.Path.Scale[].x

'EffectProperties.Path.Scale[].x' : The x-axis value for this vector

F32 SubstanceSourceEffect::EffectProperties.Path.Scale[].y

'EffectProperties.Path.Scale[].y' : The y-axis value for this vector

F32 SubstanceSourceEffect::EffectProperties.Path.Speed[].x

'EffectProperties.Path.Speed[].x' : The x-axis value for this vector

F32 SubstanceSourceEffect::EffectProperties.Path.Speed[].y

'EffectProperties.Path.Speed[].y' : The y-axis value for this vector

F32 SubstanceSourceEffect::EffectProperties.Position.TranslateX

'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction

F32 SubstanceSourceEffect::EffectProperties.Position.TranslateY

'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction

F32 SubstanceSourceEffect::EffectProperties.Position.TranslateZ

'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction

F32 SubstanceSourceEffect::EffectProperties.RandomizeRepeatTime

'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.

U32 SubstanceSourceEffect::EffectProperties.RepeatCount

'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever

F32 SubstanceSourceEffect::EffectProperties.RepeatDelay

'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time

String SubstanceSourceEffect::EffectProperties.UserString

'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer

Ref SubstanceSourceEffect::SubstanceSource

'SubstanceSource' : Substance Source Asset

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
SubstanceSourceEffect Member List
This is the complete list of members for SubstanceSourceEffect, including all inherited members.
EffectProperties.Duration | SubstanceSourceEffect
EffectProperties.Enable | SubstanceSourceEffect
EffectProperties.InitialDelayTime | SubstanceSourceEffect
EffectProperties.Orientation.RotateX | SubstanceSourceEffect
EffectProperties.Orientation.RotateY | SubstanceSourceEffect
EffectProperties.Orientation.RotateZ | SubstanceSourceEffect
EffectProperties.Path.ControlPoints[] | SubstanceSourceEffect
EffectProperties.Path.LoopIndex | SubstanceSourceEffect
EffectProperties.Path.PathDuration | SubstanceSourceEffect
EffectProperties.Path.PlaybackMode | SubstanceSourceEffect
EffectProperties.Path.Scale[].x | SubstanceSourceEffect
EffectProperties.Path.Scale[].y | SubstanceSourceEffect
EffectProperties.Path.Speed[].x | SubstanceSourceEffect
EffectProperties.Path.Speed[].y | SubstanceSourceEffect
EffectProperties.Position.TranslateX | SubstanceSourceEffect
EffectProperties.Position.TranslateY | SubstanceSourceEffect
EffectProperties.Position.TranslateZ | SubstanceSourceEffect
EffectProperties.RandomizeRepeatTime | SubstanceSourceEffect
EffectProperties.RepeatCount | SubstanceSourceEffect
EffectProperties.RepeatDelay | SubstanceSourceEffect
EffectProperties.UserString | SubstanceSourceEffect
SubstanceSource | SubstanceSourceEffect
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SubtextureVsLifeModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
SubtextureVsLifeModifierParams Struct Reference

Describes the NxParameterized::Interface for 'SubtextureVsLifeModifierParams' : SubtextureVsLife modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

F32 | controlPoints[].x
'controlPoints[].x' : Life time
F32 | controlPoints[].y
'controlPoints[].y' : Subtexture id

Detailed Description

Describes the NxParameterized::Interface for 'SubtextureVsLifeModifierParams' : SubtextureVsLife modifier parameters.

SubtextureVsLifeModifierParams contains 3 fully qualified names
---------------------------------------------
  1 : ArraySizeName  controlPoints
  2 : F32            controlPoints[].x
  3 : F32            controlPoints[].y

Member Data Documentation

F32 SubtextureVsLifeModifierParams::controlPoints[].x

'controlPoints[].x' : Life time

F32 SubtextureVsLifeModifierParams::controlPoints[].y

'controlPoints[].y' : Subtexture id

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
SubtextureVsLifeModifierParams Member List
This is the complete list of members for SubtextureVsLifeModifierParams, including all inherited members.
controlPoints[].x | SubtextureVsLifeModifierParams
controlPoints[].y | SubtextureVsLifeModifierParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SurfaceBufferParameters Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
SurfaceBufferParameters Struct Reference

Describes the NxParameterized::Interface for 'SurfaceBufferParameters' : More...

#include <params.h>

List of all members.

Classes

union | Buffer

Public Attributes

U32 | width
'width' : Number of point in U-dimension
U32 | height
'height' : Number of point in V-dimension
U32 | surfaceFormat
'surfaceFormat' : Attributes of the vertex buffer
Buffer buffer

Detailed Description

Describes the NxParameterized::Interface for 'SurfaceBufferParameters' :

SurfaceBufferParameters contains 57 fully qualified names
---------------------------------------------
  1 : U32            width
  2 : U32            height
  3 : U32            surfaceFormat
  4 : ArraySizeName  buffer.data      RefVariant[BufferU8x1]
  5 : U8             buffer.data[]    RefVariant[BufferU8x1]
  6 : ArraySizeName  buffer.data      RefVariant[BufferU8x2]
  7 : U8             buffer.data[].x  RefVariant[BufferU8x2]
  8 : U8             buffer.data[].y  RefVariant[BufferU8x2]
  9 : ArraySizeName  buffer.data      RefVariant[BufferU8x3]
 10 : U8             buffer.data[].x  RefVariant[BufferU8x3]
 11 : U8             buffer.data[].y  RefVariant[BufferU8x3]
 12 : U8             buffer.data[].z  RefVariant[BufferU8x3]
 13 : ArraySizeName  buffer.data      RefVariant[BufferU8x4]
 14 : U8             buffer.data[].x  RefVariant[BufferU8x4]
 15 : U8             buffer.data[].y  RefVariant[BufferU8x4]
 16 : U8             buffer.data[].z  RefVariant[BufferU8x4]
 17 : U8             buffer.data[].w  RefVariant[BufferU8x4]
 18 : ArraySizeName  buffer.data      RefVariant[BufferU16x1]
 19 : U16            buffer.data[]    RefVariant[BufferU16x1]
 20 : ArraySizeName  buffer.data      RefVariant[BufferU16x2]
 21 : U16            buffer.data[].x  RefVariant[BufferU16x2]
 22 : U16            buffer.data[].y  RefVariant[BufferU16x2]
 23 : ArraySizeName  buffer.data      RefVariant[BufferU16x3]
 24 : U16            buffer.data[].x  RefVariant[BufferU16x3]
 25 : U16            buffer.data[].y  RefVariant[BufferU16x3]
 26 : U16            buffer.data[].z  RefVariant[BufferU16x3]
 27 : ArraySizeName  buffer.data      RefVariant[BufferU16x4]
 28 : U16            buffer.data[].x  RefVariant[BufferU16x4]
 29 : U16            buffer.data[].y  RefVariant[BufferU16x4]
 30 : U16            buffer.data[].z  RefVariant[BufferU16x4]
 31 : U16            buffer.data[].w  RefVariant[BufferU16x4]
 32 : ArraySizeName  buffer.data      RefVariant[BufferU32x1]
 33 : U32            buffer.data[]    RefVariant[BufferU32x1]
 34 : ArraySizeName  buffer.data      RefVariant[BufferU32x2]
 35 : U32            buffer.data[].x  RefVariant[BufferU32x2]
 36 : U32            buffer.data[].y  RefVariant[BufferU32x2]
 37 : ArraySizeName  buffer.data      RefVariant[BufferU32x3]
 38 : U32            buffer.data[].x  RefVariant[BufferU32x3]
 39 : U32            buffer.data[].y  RefVariant[BufferU32x3]
 40 : U32            buffer.data[].z  RefVariant[BufferU32x3]
 41 : ArraySizeName  buffer.data      RefVariant[BufferU32x4]
 42 : U32            buffer.data[].x  RefVariant[BufferU32x4]
 43 : U32            buffer.data[].y  RefVariant[BufferU32x4]
 44 : U32            buffer.data[].z  RefVariant[BufferU32x4]
 45 : U32            buffer.data[].w  RefVariant[BufferU32x4]
 46 : ArraySizeName  buffer.data      RefVariant[BufferF32x1]
 47 : F32            buffer.data[]    RefVariant[BufferF32x1]
 48 : ArraySizeName  buffer.data      RefVariant[BufferF32x2]
 49 : F32            buffer.data[].x  RefVariant[BufferF32x2]
 50 : F32            buffer.data[].y  RefVariant[BufferF32x2]
 51 : ArraySizeName  buffer.data      RefVariant[BufferF32x3]
 52 : Vec3           buffer.data[]    RefVariant[BufferF32x3]
 53 : ArraySizeName  buffer.data      RefVariant[BufferF32x4]
 54 : F32            buffer.data[].x  RefVariant[BufferF32x4]
 55 : F32            buffer.data[].y  RefVariant[BufferF32x4]
 56 : F32            buffer.data[].z  RefVariant[BufferF32x4]
 57 : F32            buffer.data[].w  RefVariant[BufferF32x4]

Member Data Documentation

Buffer SurfaceBufferParameters::buffer
U32 SurfaceBufferParameters::height

'height' : Number of point in V-dimension

U32 SurfaceBufferParameters::surfaceFormat

'surfaceFormat' : Attributes of the vertex buffer

U32 SurfaceBufferParameters::width

'width' : Number of point in U-dimension

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
SurfaceBufferParameters Member List
This is the complete list of members for SurfaceBufferParameters, including all inherited members.
buffer | SurfaceBufferParameters
height | SurfaceBufferParameters
surfaceFormat | SurfaceBufferParameters
width | SurfaceBufferParameters
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SurfaceTraceParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
SurfaceTraceParameters Struct Reference

Describes the NxParameterized::Interface for 'SurfaceTraceParameters' : More...

#include <params.h>

List of all members.

Public Attributes

U8 | submeshIndices[]
'submeshIndices[]' : The submeshes to which the corresponding vertices (in vertexIndices) belong
U32 | vertexIndices[]
'vertexIndices[]' : The vertex indices defining the surface trace.
Vec3 | defaultNormal
'defaultNormal' : The average surface normal for this trace

Detailed Description

Describes the NxParameterized::Interface for 'SurfaceTraceParameters' :

SurfaceTraceParameters contains 5 fully qualified names
---------------------------------------------
  1 : ArraySizeName  submeshIndices
  2 : U8             submeshIndices[]
  3 : ArraySizeName  vertexIndices
  4 : U32            vertexIndices[]
  5 : Vec3           defaultNormal

Member Data Documentation

Vec3 SurfaceTraceParameters::defaultNormal

'defaultNormal' : The average surface normal for this trace

The average surface normal for this trace. A surface trace is a single closed loop on the surface of the mesh, along triangle boundaries. This normal is the normalized average of the surface triangles enclosed by the loop.

U8 SurfaceTraceParameters::submeshIndices[]

'submeshIndices[]' : The submeshes to which the corresponding vertices (in vertexIndices) belong

The submeshes to which the corresponding vertices (in vertexIndices) belong. The surface traces are defined as a set of vertex indices, but these indices are relative to a submesh. The size of submeshIndices must be equal to the size of vertexIndices.

U32 SurfaceTraceParameters::vertexIndices[]

'vertexIndices[]' : The vertex indices defining the surface trace.

The vertex indices defining the surface trace. The surface traces are defined as a set of vertex indices, but these indices are relative to a submesh. The size of submeshIndices must be equal to the size of vertexIndices.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
SurfaceTraceParameters Member List
This is the complete list of members for SurfaceTraceParameters, including all inherited members.
defaultNormal | SurfaceTraceParameters
submeshIndices[] | SurfaceTraceParameters
vertexIndices[] | SurfaceTraceParameters
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SurfaceTraceSetParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
SurfaceTraceSetParameters Struct Reference

Describes the NxParameterized::Interface for 'SurfaceTraceSetParameters' : More...

#include <params.h>

List of all members.

Public Attributes

SurfaceTraceParameters traces[]
'traces[]' :
Vec3 positionOffset
'positionOffset' : Chunk-local offset for this trace, needed for instanced chunks

Detailed Description

Describes the NxParameterized::Interface for 'SurfaceTraceSetParameters' :

SurfaceTraceSetParameters contains 7 fully qualified names
---------------------------------------------
  1 : ArraySizeName  traces
  2 : ArraySizeName  traces[].submeshIndices    RefVariant[SurfaceTraceParameters]
  3 : U8             traces[].submeshIndices[]  RefVariant[SurfaceTraceParameters]
  4 : ArraySizeName  traces[].vertexIndices     RefVariant[SurfaceTraceParameters]
  5 : U32            traces[].vertexIndices[]   RefVariant[SurfaceTraceParameters]
  6 : Vec3           traces[].defaultNormal     RefVariant[SurfaceTraceParameters]
  7 : Vec3           positionOffset

Member Data Documentation

Vec3 SurfaceTraceSetParameters::positionOffset

'positionOffset' : Chunk-local offset for this trace, needed for instanced chunks

Chunk-local offset for this trace, needed for instanced chunks.

SurfaceTraceParameters SurfaceTraceSetParameters::traces[]

'traces[]' :

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
SurfaceTraceSetParameters Member List
This is the complete list of members for SurfaceTraceSetParameters, including all inherited members.
positionOffset | SurfaceTraceSetParameters
traces[] | SurfaceTraceSetParameters
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: TurbulenceFieldSamplerData Struct Reference

  • Class List
  • Class Members
Public Attributes
TurbulenceFieldSamplerData Struct Reference

Describes the NxParameterized::Interface for 'TurbulenceFieldSamplerData' : Contains the asset properties for this turbulence field sampler. More...

#include <params.h>

List of all members.

Public Attributes

String Name
'Name' : Turbulence FS Name
TurbulenceFSAssetParams TurbulenceFieldSampler
'TurbulenceFieldSampler' :

Detailed Description

Describes the NxParameterized::Interface for 'TurbulenceFieldSamplerData' : Contains the asset properties for this turbulence field sampler.

TurbulenceFieldSamplerData contains 53 fully qualified names
---------------------------------------------
  1 : String  Name
  2 : Min     TurbulenceFieldSampler.gridXRange.min                              RefVariant[TurbulenceFSAssetParams]
  3 : Max     TurbulenceFieldSampler.gridXRange.max                              RefVariant[TurbulenceFSAssetParams]
  4 : Min     TurbulenceFieldSampler.gridYRange.min                              RefVariant[TurbulenceFSAssetParams]
  5 : Max     TurbulenceFieldSampler.gridYRange.max                              RefVariant[TurbulenceFSAssetParams]
  6 : Min     TurbulenceFieldSampler.gridZRange.min                              RefVariant[TurbulenceFSAssetParams]
  7 : Max     TurbulenceFieldSampler.gridZRange.max                              RefVariant[TurbulenceFSAssetParams]
  8 : Vec3    TurbulenceFieldSampler.gridSizeWorld                               RefVariant[TurbulenceFSAssetParams]
  9 : F32     TurbulenceFieldSampler.updatesPerFrameRange.min                    RefVariant[TurbulenceFSAssetParams]
 10 : F32     TurbulenceFieldSampler.updatesPerFrameRange.max                    RefVariant[TurbulenceFSAssetParams]
 11 : F32     TurbulenceFieldSampler.angularVelocityMultiplier                   RefVariant[TurbulenceFSAssetParams]
 12 : F32     TurbulenceFieldSampler.angularVelocityClamp                        RefVariant[TurbulenceFSAssetParams]
 13 : F32     TurbulenceFieldSampler.linearVelocityMultiplier                    RefVariant[TurbulenceFSAssetParams]
 14 : F32     TurbulenceFieldSampler.linearVelocityClamp                         RefVariant[TurbulenceFSAssetParams]
 15 : F32     TurbulenceFieldSampler.velocityFieldFadeTime                       RefVariant[TurbulenceFSAssetParams]
 16 : F32     TurbulenceFieldSampler.velocityFieldFadeDelay                      RefVariant[TurbulenceFSAssetParams]
 17 : F32     TurbulenceFieldSampler.velocityFieldFadeIntensity                  RefVariant[TurbulenceFSAssetParams]
 18 : F32     TurbulenceFieldSampler.boundaryFadePercentage                      RefVariant[TurbulenceFSAssetParams]
 19 : F32     TurbulenceFieldSampler.boundarySizePercentage                      RefVariant[TurbulenceFSAssetParams]
 20 : String  TurbulenceFieldSampler.collisionFilterDataName                     RefVariant[TurbulenceFSAssetParams]
 21 : String  TurbulenceFieldSampler.fieldBoundaryFilterDataName                 RefVariant[TurbulenceFSAssetParams]
 22 : String  TurbulenceFieldSampler.fieldSamplerFilterDataName                  RefVariant[TurbulenceFSAssetParams]
 23 : U32     TurbulenceFieldSampler.maxCollidingObjects                         RefVariant[TurbulenceFSAssetParams]
 24 : U32     TurbulenceFieldSampler.maxVelocitySources                          RefVariant[TurbulenceFSAssetParams]
 25 : U32     TurbulenceFieldSampler.maxHeatSources                              RefVariant[TurbulenceFSAssetParams]
 26 : U32     TurbulenceFieldSampler.maxSubstanceSources                         RefVariant[TurbulenceFSAssetParams]
 27 : F32     TurbulenceFieldSampler.dragCoeff                                   RefVariant[TurbulenceFSAssetParams]
 28 : Vec3    TurbulenceFieldSampler.externalVelocity                            RefVariant[TurbulenceFSAssetParams]
 29 : F32     TurbulenceFieldSampler.fieldVelocityMultiplier                     RefVariant[TurbulenceFSAssetParams]
 30 : F32     TurbulenceFieldSampler.fieldVelocityWeight                         RefVariant[TurbulenceFSAssetParams]
 31 : Bool    TurbulenceFieldSampler.useHeat                                     RefVariant[TurbulenceFSAssetParams]
 32 : F32     TurbulenceFieldSampler.heatParams.temperatureBasedForceMultiplier  RefVariant[TurbulenceFSAssetParams]
 33 : F32     TurbulenceFieldSampler.heatParams.ambientTemperature               RefVariant[TurbulenceFSAssetParams]
 34 : Vec3    TurbulenceFieldSampler.heatParams.heatForceDirection               RefVariant[TurbulenceFSAssetParams]
 35 : F32     TurbulenceFieldSampler.heatParams.thermalConductivity              RefVariant[TurbulenceFSAssetParams]
 36 : Bool    TurbulenceFieldSampler.useDensity                                  RefVariant[TurbulenceFSAssetParams]
 37 : F32     TurbulenceFieldSampler.densityParams.diffusionCoef                 RefVariant[TurbulenceFSAssetParams]
 38 : F32     TurbulenceFieldSampler.densityParams.densityFieldFade              RefVariant[TurbulenceFSAssetParams]
 39 : U32     TurbulenceFieldSampler.densityParams.densityGridMultiplier         RefVariant[TurbulenceFSAssetParams]
 40 : Bool    TurbulenceFieldSampler.isEnabledOptimizedLOD                       RefVariant[TurbulenceFSAssetParams]
 41 : F32     TurbulenceFieldSampler.customLOD                                   RefVariant[TurbulenceFSAssetParams]
 42 : F32     TurbulenceFieldSampler.lodWeights.maxDistance                      RefVariant[TurbulenceFSAssetParams]
 43 : F32     TurbulenceFieldSampler.lodWeights.distanceWeight                   RefVariant[TurbulenceFSAssetParams]
 44 : F32     TurbulenceFieldSampler.lodWeights.bias                             RefVariant[TurbulenceFSAssetParams]
 45 : F32     TurbulenceFieldSampler.lodWeights.benefitBias                      RefVariant[TurbulenceFSAssetParams]
 46 : F32     TurbulenceFieldSampler.lodWeights.benefitWeight                    RefVariant[TurbulenceFSAssetParams]
 47 : F32     TurbulenceFieldSampler.noiseParams.noiseStrength                   RefVariant[TurbulenceFSAssetParams]
 48 : Vec3    TurbulenceFieldSampler.noiseParams.noiseSpacePeriod                RefVariant[TurbulenceFSAssetParams]
 49 : F32     TurbulenceFieldSampler.noiseParams.noiseTimePeriod                 RefVariant[TurbulenceFSAssetParams]
 50 : U32     TurbulenceFieldSampler.noiseParams.noiseOctaves                    RefVariant[TurbulenceFSAssetParams]
 51 : F32     TurbulenceFieldSampler.dragCoeffForRigidBody                       RefVariant[TurbulenceFSAssetParams]
 52 : F32     TurbulenceFieldSampler.fluidViscosity                              RefVariant[TurbulenceFSAssetParams]
 53 : Ref     TurbulenceFieldSampler.volumeRenderMaterialName                    RefVariant[TurbulenceFSAssetParams]

Member Data Documentation

String TurbulenceFieldSamplerData::Name

'Name' : Turbulence FS Name

TurbulenceFSAssetParams TurbulenceFieldSamplerData::TurbulenceFieldSampler

'TurbulenceFieldSampler' :

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
TurbulenceFieldSamplerData Member List
This is the complete list of members for TurbulenceFieldSamplerData, including all inherited members.
Name | TurbulenceFieldSamplerData
TurbulenceFieldSampler | TurbulenceFieldSamplerData
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: TurbulenceFieldSamplerEffect Struct Reference

  • Class List
  • Class Members
Public Attributes
TurbulenceFieldSamplerEffect Struct Reference

Describes the NxParameterized::Interface for 'TurbulenceFieldSamplerEffect' : A turbulence effect. More...

#include <params.h>

List of all members.

Public Attributes

String | EffectProperties.UserString
'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer
Bool | EffectProperties.Enable
'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup
F32 | EffectProperties.Position.TranslateX
'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateY
'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateZ
'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Orientation.RotateX
'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateY
'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateZ
'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)
F32 | EffectProperties.InitialDelayTime
'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect
F32 | EffectProperties.Duration
'EffectProperties.Duration' : The duration of the effect in secontds
U32 | EffectProperties.RepeatCount
'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever
F32 | EffectProperties.RepeatDelay
'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time
F32 | EffectProperties.RandomizeRepeatTime
'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.
PlaybackMode EffectProperties.Path.PlaybackMode
'EffectProperties.Path.PlaybackMode' : The mode to play back the path
F32 | EffectProperties.Path.PathDuration
'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided
U32 | EffectProperties.Path.LoopIndex
'EffectProperties.Path.LoopIndex' : The array index to loop back to
Transform | EffectProperties.Path.ControlPoints[]
'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to
F32 | EffectProperties.Path.Scale[].x
'EffectProperties.Path.Scale[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Scale[].y
'EffectProperties.Path.Scale[].y' : The y-axis value for this vector
F32 | EffectProperties.Path.Speed[].x
'EffectProperties.Path.Speed[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Speed[].y
'EffectProperties.Path.Speed[].y' : The y-axis value for this vector
Ref | TurbulenceFieldSampler
'TurbulenceFieldSampler' : Turbulence FS Asset

Detailed Description

Describes the NxParameterized::Interface for 'TurbulenceFieldSamplerEffect' : A turbulence effect.

TurbulenceFieldSamplerEffect contains 25 fully qualified names
---------------------------------------------
  1 : String         EffectProperties.UserString
  2 : Bool           EffectProperties.Enable
  3 : F32            EffectProperties.Position.TranslateX
  4 : F32            EffectProperties.Position.TranslateY
  5 : F32            EffectProperties.Position.TranslateZ
  6 : F32            EffectProperties.Orientation.RotateX
  7 : F32            EffectProperties.Orientation.RotateY
  8 : F32            EffectProperties.Orientation.RotateZ
  9 : F32            EffectProperties.InitialDelayTime
 10 : F32            EffectProperties.Duration
 11 : U32            EffectProperties.RepeatCount
 12 : F32            EffectProperties.RepeatDelay
 13 : F32            EffectProperties.RandomizeRepeatTime
 14 : PlaybackMode   EffectProperties.Path.PlaybackMode
 15 : F32            EffectProperties.Path.PathDuration
 16 : U32            EffectProperties.Path.LoopIndex
 17 : ArraySizeName  ControlPoints
 18 : Transform      EffectProperties.Path.ControlPoints[]
 19 : ArraySizeName  Scale
 20 : F32            EffectProperties.Path.Scale[].x
 21 : F32            EffectProperties.Path.Scale[].y
 22 : ArraySizeName  Speed
 23 : F32            EffectProperties.Path.Speed[].x
 24 : F32            EffectProperties.Path.Speed[].y
 25 : Ref            TurbulenceFieldSampler

Member Data Documentation

F32 TurbulenceFieldSamplerEffect::EffectProperties.Duration

'EffectProperties.Duration' : The duration of the effect in secontds

Bool TurbulenceFieldSamplerEffect::EffectProperties.Enable

'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup

F32 TurbulenceFieldSamplerEffect::EffectProperties.InitialDelayTime

'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect

F32 TurbulenceFieldSamplerEffect::EffectProperties.Orientation.RotateX

'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)

F32 TurbulenceFieldSamplerEffect::EffectProperties.Orientation.RotateY

'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)

F32 TurbulenceFieldSamplerEffect::EffectProperties.Orientation.RotateZ

'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)

Transform TurbulenceFieldSamplerEffect::EffectProperties.Path.ControlPoints[]

'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to

U32 TurbulenceFieldSamplerEffect::EffectProperties.Path.LoopIndex

'EffectProperties.Path.LoopIndex' : The array index to loop back to

F32 TurbulenceFieldSamplerEffect::EffectProperties.Path.PathDuration

'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided

PlaybackMode TurbulenceFieldSamplerEffect::EffectProperties.Path.PlaybackMode

'EffectProperties.Path.PlaybackMode' : The mode to play back the path

F32 TurbulenceFieldSamplerEffect::EffectProperties.Path.Scale[].x

'EffectProperties.Path.Scale[].x' : The x-axis value for this vector

F32 TurbulenceFieldSamplerEffect::EffectProperties.Path.Scale[].y

'EffectProperties.Path.Scale[].y' : The y-axis value for this vector

F32 TurbulenceFieldSamplerEffect::EffectProperties.Path.Speed[].x

'EffectProperties.Path.Speed[].x' : The x-axis value for this vector

F32 TurbulenceFieldSamplerEffect::EffectProperties.Path.Speed[].y

'EffectProperties.Path.Speed[].y' : The y-axis value for this vector

F32 TurbulenceFieldSamplerEffect::EffectProperties.Position.TranslateX

'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction

F32 TurbulenceFieldSamplerEffect::EffectProperties.Position.TranslateY

'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction

F32 TurbulenceFieldSamplerEffect::EffectProperties.Position.TranslateZ

'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction

F32 TurbulenceFieldSamplerEffect::EffectProperties.RandomizeRepeatTime

'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.

U32 TurbulenceFieldSamplerEffect::EffectProperties.RepeatCount

'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever

F32 TurbulenceFieldSamplerEffect::EffectProperties.RepeatDelay

'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time

String TurbulenceFieldSamplerEffect::EffectProperties.UserString

'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer

Ref TurbulenceFieldSamplerEffect::TurbulenceFieldSampler

'TurbulenceFieldSampler' : Turbulence FS Asset

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
TurbulenceFieldSamplerEffect Member List
This is the complete list of members for TurbulenceFieldSamplerEffect, including all inherited members.
EffectProperties.Duration | TurbulenceFieldSamplerEffect
EffectProperties.Enable | TurbulenceFieldSamplerEffect
EffectProperties.InitialDelayTime | TurbulenceFieldSamplerEffect
EffectProperties.Orientation.RotateX | TurbulenceFieldSamplerEffect
EffectProperties.Orientation.RotateY | TurbulenceFieldSamplerEffect
EffectProperties.Orientation.RotateZ | TurbulenceFieldSamplerEffect
EffectProperties.Path.ControlPoints[] | TurbulenceFieldSamplerEffect
EffectProperties.Path.LoopIndex | TurbulenceFieldSamplerEffect
EffectProperties.Path.PathDuration | TurbulenceFieldSamplerEffect
EffectProperties.Path.PlaybackMode | TurbulenceFieldSamplerEffect
EffectProperties.Path.Scale[].x | TurbulenceFieldSamplerEffect
EffectProperties.Path.Scale[].y | TurbulenceFieldSamplerEffect
EffectProperties.Path.Speed[].x | TurbulenceFieldSamplerEffect
EffectProperties.Path.Speed[].y | TurbulenceFieldSamplerEffect
EffectProperties.Position.TranslateX | TurbulenceFieldSamplerEffect
EffectProperties.Position.TranslateY | TurbulenceFieldSamplerEffect
EffectProperties.Position.TranslateZ | TurbulenceFieldSamplerEffect
EffectProperties.RandomizeRepeatTime | TurbulenceFieldSamplerEffect
EffectProperties.RepeatCount | TurbulenceFieldSamplerEffect
EffectProperties.RepeatDelay | TurbulenceFieldSamplerEffect
EffectProperties.UserString | TurbulenceFieldSamplerEffect
TurbulenceFieldSampler | TurbulenceFieldSamplerEffect
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: TurbulenceFSActorParams Struct Reference

  • Class List
  • Class Members
Public Attributes
TurbulenceFSActorParams Struct Reference

Describes the NxParameterized::Interface for 'TurbulenceFSActorParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat34 | initialPose
'initialPose' : The global pose for the actor.
F32 | initialScale
'initialScale' : The space scale of the turbulence actor
Vec3 | gridSizeWorld
'gridSizeWorld' : size of the grid in world space.
String | collisionFilterDataName
'collisionFilterDataName' : The filter data (group/groupsMask) name for TurbulenceFS vs PhysX interaction. Overrides asset's value.
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for TurbulenceFS vs Field Boundaries interaction. Overrides asset's value.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for TurbulenceFS vs other Field Samplers interaction. Overrides asset's value.
Bool | isAutoSwitchingBC
'isAutoSwitchingBC' : Enable/disable auto switching boundary conditions to inlet/outlet depend on velocity through the boundary.
F32 | outletPressureBC
'outletPressureBC' : The pressure on the outlet boundary.
F32 | dragCoeffForRigidBody
'dragCoeffForRigidBody' : It is not true drag coef just mixing coefficient for slip and no-slip boundary condition. If set to zero supposed slip boundary condition on rigid bodies. If set to 1 supposed no-slip boundary condition else mixed (partly slip)
F32 | fluidViscosity
'fluidViscosity' : Viscosity is the coefficient for velocity diffusion. If 0. there is no diffusion.

Detailed Description

Describes the NxParameterized::Interface for 'TurbulenceFSActorParams' :

TurbulenceFSActorParams contains 10 fully qualified names
---------------------------------------------
  1 : Mat34   initialPose
  2 : F32     initialScale
  3 : Vec3    gridSizeWorld
  4 : String  collisionFilterDataName
  5 : String  fieldBoundaryFilterDataName
  6 : String  fieldSamplerFilterDataName
  7 : Bool    isAutoSwitchingBC
  8 : F32     outletPressureBC
  9 : F32     dragCoeffForRigidBody
 10 : F32     fluidViscosity

Member Data Documentation

String TurbulenceFSActorParams::collisionFilterDataName

'collisionFilterDataName' : The filter data (group/groupsMask) name for TurbulenceFS vs PhysX interaction. Overrides asset's value.

F32 TurbulenceFSActorParams::dragCoeffForRigidBody

'dragCoeffForRigidBody' : It is not true drag coef just mixing coefficient for slip and no-slip boundary condition. If set to zero supposed slip boundary condition on rigid bodies. If set to 1 supposed no-slip boundary condition else mixed (partly slip)

String TurbulenceFSActorParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for TurbulenceFS vs Field Boundaries interaction. Overrides asset's value.

String TurbulenceFSActorParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for TurbulenceFS vs other Field Samplers interaction. Overrides asset's value.

F32 TurbulenceFSActorParams::fluidViscosity

'fluidViscosity' : Viscosity is the coefficient for velocity diffusion. If 0. there is no diffusion.

Vec3 TurbulenceFSActorParams::gridSizeWorld

'gridSizeWorld' : size of the grid in world space.

Mat34 TurbulenceFSActorParams::initialPose

'initialPose' : The global pose for the actor.

F32 TurbulenceFSActorParams::initialScale

'initialScale' : The space scale of the turbulence actor

Bool TurbulenceFSActorParams::isAutoSwitchingBC

'isAutoSwitchingBC' : Enable/disable auto switching boundary conditions to inlet/outlet depend on velocity through the boundary.

F32 TurbulenceFSActorParams::outletPressureBC

'outletPressureBC' : The pressure on the outlet boundary.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
TurbulenceFSActorParams Member List
This is the complete list of members for TurbulenceFSActorParams, including all inherited members.
collisionFilterDataName | TurbulenceFSActorParams
dragCoeffForRigidBody | TurbulenceFSActorParams
fieldBoundaryFilterDataName | TurbulenceFSActorParams
fieldSamplerFilterDataName | TurbulenceFSActorParams
fluidViscosity | TurbulenceFSActorParams
gridSizeWorld | TurbulenceFSActorParams
initialPose | TurbulenceFSActorParams
initialScale | TurbulenceFSActorParams
isAutoSwitchingBC | TurbulenceFSActorParams
outletPressureBC | TurbulenceFSActorParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: TurbulenceFSAssetParams Struct Reference

  • Class List
  • Class Members
Public Attributes
TurbulenceFSAssetParams Struct Reference

Describes the NxParameterized::Interface for 'TurbulenceFSAssetParams' : Contains the asset properties for this Turbulence field sampler. More...

#include <params.h>

List of all members.

Public Attributes

Min gridXRange.min
'gridXRange.min' : Turbulence resolution. The higher resolution, the higher precision, but the simulation time is also longer. This is the lower bound of possible turbulence grid resolution, depending on the LOD settings
Max gridXRange.max
'gridXRange.max' : Turbulence resolution. The higher resolution, the higher precision, but the simulation time is also longer. This is the higher bound of possible turbulence grid resolution, depending on the LOD settings
Min gridYRange.min
'gridYRange.min' : Turbulence resolution. The higher resolution, the higher precision, but the simulation time is also longer. This is the lower bound of possible turbulence grid resolution, depending on the LOD settings
Max gridYRange.max
'gridYRange.max' : Turbulence resolution. The higher resolution, the higher precision, but the simulation time is also longer. This is the higher bound of possible turbulence grid resolution, depending on the LOD settings
Min gridZRange.min
'gridZRange.min' : Turbulence resolution. The higher resolution, the higher precision, but the simulation time is also longer. This is the lower bound of possible turbulence grid resolution, depending on the LOD settings
Max gridZRange.max
'gridZRange.max' : Turbulence resolution. The higher resolution, the higher precision, but the simulation time is also longer. This is the higher bound of possible turbulence grid resolution, depending on the LOD settings
Vec3 | gridSizeWorld
'gridSizeWorld' : Size of the grid in world space.
F32 | updatesPerFrameRange.min
'updatesPerFrameRange.min' : Minimum value
F32 | updatesPerFrameRange.max
'updatesPerFrameRange.max' : Maximum value
F32 | angularVelocityMultiplier
'angularVelocityMultiplier' : a multiplier for the angular velocity set by the user.
F32 | angularVelocityClamp
'angularVelocityClamp' : a clamp for the angular velocity set by the user.
F32 | linearVelocityMultiplier
'linearVelocityMultiplier' : a multiplier for the linear velocity set by the user.
F32 | linearVelocityClamp
'linearVelocityClamp' : a clamp for the linear velocity set by the user.
F32 | velocityFieldFadeTime
'velocityFieldFadeTime' : Time of velocity field cleaning process [sec]. Cleaning disabled by default.
F32 | velocityFieldFadeDelay
'velocityFieldFadeDelay' : Time without activity before velocity field cleaning process starts [sec].
F32 | velocityFieldFadeIntensity
'velocityFieldFadeIntensity' : This parameter sets how much each velocity vector should be damped, so (1 - velocityFieldFadeIntensity) of original velocity vector magnitude will be left after the fade process finishes.
F32 | boundaryFadePercentage
'boundaryFadePercentage' : Percentage of distance from boundary to center where fade out starts.
F32 | boundarySizePercentage
'boundarySizePercentage' : Boundary size as the percentage of grid size.
String | collisionFilterDataName
'collisionFilterDataName' : The filter data (group/groupsMask) name for TurbulenceFS vs PhysX interaction.
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for TurbulenceFS vs Field Boundaries interaction.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for TurbulenceFS vs other Field Samplers interaction.
U32 | maxCollidingObjects
'maxCollidingObjects' : The maximum number of colliding objects.
U32 | maxVelocitySources
'maxVelocitySources' : The maximum number of velocity source.
U32 | maxHeatSources
'maxHeatSources' : The maximum number of heat source.
U32 | maxSubstanceSources
'maxSubstanceSources' : The maximum number of substance source (computed if density enabled).
F32 | dragCoeff
'dragCoeff' : Coefficient for deriving drag force from velocity (if equals to zero, direct grid velocity is used).
Vec3 | externalVelocity
'externalVelocity' : Adds a single directional velocity to the grid.
F32 | fieldVelocityMultiplier
'fieldVelocityMultiplier' : A multiplier for the field velocity.
F32 | fieldVelocityWeight
'fieldVelocityWeight' : The effect of the field velocity on objects. A value of 1 causes objects to only be affected by the grid, a value of 0 allows objects to be controlled by other field samplers.
Bool | useHeat
'useHeat' : Enable whether or not to use heat in the simulation.
F32 | heatParams.temperatureBasedForceMultiplier
'heatParams.temperatureBasedForceMultiplier' : Multiplier for force induced by heat source.
F32 | heatParams.ambientTemperature
'heatParams.ambientTemperature' : Environment temperature.
Vec3 | heatParams.heatForceDirection
'heatParams.heatForceDirection' : Direction of the force induced by heat source.
F32 | heatParams.thermalConductivity
'heatParams.thermalConductivity' : Thermal conductivity. Default value is set for air.
Bool | useDensity
'useDensity' : Enable whether or not to use density in the simulation.
F32 | densityParams.diffusionCoef
'densityParams.diffusionCoef' : Diffusion coefficient for density (analog for viscosity in velocity equation.
F32 | densityParams.densityFieldFade
'densityParams.densityFieldFade' : Each cell in density field are multiplied by (1 - densityFieldFade) every frame.
U32 | densityParams.densityGridMultiplier
'densityParams.densityGridMultiplier' : Density grid resolution multiplier.
Bool | isEnabledOptimizedLOD
'isEnabledOptimizedLOD' : Enable more aggressive LOD.
F32 | customLOD
'customLOD' : Force the current LOD to a particular value, range is 0-1: 1.0f is maximum, 0.0f is minimum simulation quality.
F32 | lodWeights.maxDistance
'lodWeights.maxDistance' : Objects greater than this distance from the player will be culled more aggressively
F32 | lodWeights.distanceWeight
'lodWeights.distanceWeight' : Weight given to distance parameter in LOD function
F32 | lodWeights.bias
'lodWeights.bias' : benefit = ((distanceWeight * distanceFactor + bias) * SimulationCost + benefitBias) * benefitWeight
F32 | lodWeights.benefitBias
'lodWeights.benefitBias' : benefit = ((distanceWeight * distanceFactor + bias) * SimulationCost + benefitBias) * benefitWeight
F32 | lodWeights.benefitWeight
'lodWeights.benefitWeight' : benefit = ((distanceWeight * distanceFactor + bias) * SimulationCost + benefitBias) * benefitWeight
F32 | noiseParams.noiseStrength
'noiseParams.noiseStrength' : The strength of the noise added to the simulation.
Vec3 | noiseParams.noiseSpacePeriod
'noiseParams.noiseSpacePeriod' : Noise period in space.
F32 | noiseParams.noiseTimePeriod
'noiseParams.noiseTimePeriod' : Noise time period.
U32 | noiseParams.noiseOctaves
'noiseParams.noiseOctaves' : Number of the noise octaves (more octaves give more turbulent noise, but increase computational time).
F32 | dragCoeffForRigidBody
'dragCoeffForRigidBody' : It is not true drag coef just mixing coefficient for slip and no-slip boundary condition. If set to zero supposed slip boundary condition on rigid bodies. If set to 1 supposed no-slip boundary condition else mixed (partly slip)
F32 | fluidViscosity
'fluidViscosity' : Viscosity is the coefficient for velocity diffusion. If 0. there is no diffusion.
Ref | volumeRenderMaterialName
'volumeRenderMaterialName' : The optional volume render material name

Detailed Description

Describes the NxParameterized::Interface for 'TurbulenceFSAssetParams' : Contains the asset properties for this Turbulence field sampler.

TurbulenceFSAssetParams contains 52 fully qualified names
---------------------------------------------
  1 : Min     gridXRange.min
  2 : Max     gridXRange.max
  3 : Min     gridYRange.min
  4 : Max     gridYRange.max
  5 : Min     gridZRange.min
  6 : Max     gridZRange.max
  7 : Vec3    gridSizeWorld
  8 : F32     updatesPerFrameRange.min
  9 : F32     updatesPerFrameRange.max
 10 : F32     angularVelocityMultiplier
 11 : F32     angularVelocityClamp
 12 : F32     linearVelocityMultiplier
 13 : F32     linearVelocityClamp
 14 : F32     velocityFieldFadeTime
 15 : F32     velocityFieldFadeDelay
 16 : F32     velocityFieldFadeIntensity
 17 : F32     boundaryFadePercentage
 18 : F32     boundarySizePercentage
 19 : String  collisionFilterDataName
 20 : String  fieldBoundaryFilterDataName
 21 : String  fieldSamplerFilterDataName
 22 : U32     maxCollidingObjects
 23 : U32     maxVelocitySources
 24 : U32     maxHeatSources
 25 : U32     maxSubstanceSources
 26 : F32     dragCoeff
 27 : Vec3    externalVelocity
 28 : F32     fieldVelocityMultiplier
 29 : F32     fieldVelocityWeight
 30 : Bool    useHeat
 31 : F32     heatParams.temperatureBasedForceMultiplier
 32 : F32     heatParams.ambientTemperature
 33 : Vec3    heatParams.heatForceDirection
 34 : F32     heatParams.thermalConductivity
 35 : Bool    useDensity
 36 : F32     densityParams.diffusionCoef
 37 : F32     densityParams.densityFieldFade
 38 : U32     densityParams.densityGridMultiplier
 39 : Bool    isEnabledOptimizedLOD
 40 : F32     customLOD
 41 : F32     lodWeights.maxDistance
 42 : F32     lodWeights.distanceWeight
 43 : F32     lodWeights.bias
 44 : F32     lodWeights.benefitBias
 45 : F32     lodWeights.benefitWeight
 46 : F32     noiseParams.noiseStrength
 47 : Vec3    noiseParams.noiseSpacePeriod
 48 : F32     noiseParams.noiseTimePeriod
 49 : U32     noiseParams.noiseOctaves
 50 : F32     dragCoeffForRigidBody
 51 : F32     fluidViscosity
 52 : Ref     volumeRenderMaterialName

Member Data Documentation

F32 TurbulenceFSAssetParams::angularVelocityClamp

'angularVelocityClamp' : a clamp for the angular velocity set by the user.

F32 TurbulenceFSAssetParams::angularVelocityMultiplier

'angularVelocityMultiplier' : a multiplier for the angular velocity set by the user.

F32 TurbulenceFSAssetParams::boundaryFadePercentage

'boundaryFadePercentage' : Percentage of distance from boundary to center where fade out starts.

F32 TurbulenceFSAssetParams::boundarySizePercentage

'boundarySizePercentage' : Boundary size as the percentage of grid size.

String TurbulenceFSAssetParams::collisionFilterDataName

'collisionFilterDataName' : The filter data (group/groupsMask) name for TurbulenceFS vs PhysX interaction.

F32 TurbulenceFSAssetParams::customLOD

'customLOD' : Force the current LOD to a particular value, range is 0-1: 1.0f is maximum, 0.0f is minimum simulation quality.

F32 TurbulenceFSAssetParams::densityParams.densityFieldFade

'densityParams.densityFieldFade' : Each cell in density field are multiplied by (1 - densityFieldFade) every frame.

U32 TurbulenceFSAssetParams::densityParams.densityGridMultiplier

'densityParams.densityGridMultiplier' : Density grid resolution multiplier.

F32 TurbulenceFSAssetParams::densityParams.diffusionCoef

'densityParams.diffusionCoef' : Diffusion coefficient for density (analog for viscosity in velocity equation.

F32 TurbulenceFSAssetParams::dragCoeff

'dragCoeff' : Coefficient for deriving drag force from velocity (if equals to zero, direct grid velocity is used).

F32 TurbulenceFSAssetParams::dragCoeffForRigidBody

'dragCoeffForRigidBody' : It is not true drag coef just mixing coefficient for slip and no-slip boundary condition. If set to zero supposed slip boundary condition on rigid bodies. If set to 1 supposed no-slip boundary condition else mixed (partly slip)

Vec3 TurbulenceFSAssetParams::externalVelocity

'externalVelocity' : Adds a single directional velocity to the grid.

String TurbulenceFSAssetParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for TurbulenceFS vs Field Boundaries interaction.

String TurbulenceFSAssetParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for TurbulenceFS vs other Field Samplers interaction.

F32 TurbulenceFSAssetParams::fieldVelocityMultiplier

'fieldVelocityMultiplier' : A multiplier for the field velocity.

F32 TurbulenceFSAssetParams::fieldVelocityWeight

'fieldVelocityWeight' : The effect of the field velocity on objects. A value of 1 causes objects to only be affected by the grid, a value of 0 allows objects to be controlled by other field samplers.

F32 TurbulenceFSAssetParams::fluidViscosity

'fluidViscosity' : Viscosity is the coefficient for velocity diffusion. If 0. there is no diffusion.

Vec3 TurbulenceFSAssetParams::gridSizeWorld

'gridSizeWorld' : Size of the grid in world space.

Max TurbulenceFSAssetParams::gridXRange.max

'gridXRange.max' : Turbulence resolution. The higher resolution, the higher precision, but the simulation time is also longer. This is the higher bound of possible turbulence grid resolution, depending on the LOD settings

Min TurbulenceFSAssetParams::gridXRange.min

'gridXRange.min' : Turbulence resolution. The higher resolution, the higher precision, but the simulation time is also longer. This is the lower bound of possible turbulence grid resolution, depending on the LOD settings

Max TurbulenceFSAssetParams::gridYRange.max

'gridYRange.max' : Turbulence resolution. The higher resolution, the higher precision, but the simulation time is also longer. This is the higher bound of possible turbulence grid resolution, depending on the LOD settings

Min TurbulenceFSAssetParams::gridYRange.min

'gridYRange.min' : Turbulence resolution. The higher resolution, the higher precision, but the simulation time is also longer. This is the lower bound of possible turbulence grid resolution, depending on the LOD settings

Max TurbulenceFSAssetParams::gridZRange.max

'gridZRange.max' : Turbulence resolution. The higher resolution, the higher precision, but the simulation time is also longer. This is the higher bound of possible turbulence grid resolution, depending on the LOD settings

Min TurbulenceFSAssetParams::gridZRange.min

'gridZRange.min' : Turbulence resolution. The higher resolution, the higher precision, but the simulation time is also longer. This is the lower bound of possible turbulence grid resolution, depending on the LOD settings

F32 TurbulenceFSAssetParams::heatParams.ambientTemperature

'heatParams.ambientTemperature' : Environment temperature.

Vec3 TurbulenceFSAssetParams::heatParams.heatForceDirection

'heatParams.heatForceDirection' : Direction of the force induced by heat source.

F32 TurbulenceFSAssetParams::heatParams.temperatureBasedForceMultiplier

'heatParams.temperatureBasedForceMultiplier' : Multiplier for force induced by heat source.

F32 TurbulenceFSAssetParams::heatParams.thermalConductivity

'heatParams.thermalConductivity' : Thermal conductivity. Default value is set for air.

Bool TurbulenceFSAssetParams::isEnabledOptimizedLOD

'isEnabledOptimizedLOD' : Enable more aggressive LOD.

F32 TurbulenceFSAssetParams::linearVelocityClamp

'linearVelocityClamp' : a clamp for the linear velocity set by the user.

F32 TurbulenceFSAssetParams::linearVelocityMultiplier

'linearVelocityMultiplier' : a multiplier for the linear velocity set by the user.

F32 TurbulenceFSAssetParams::lodWeights.benefitBias

'lodWeights.benefitBias' : benefit = ((distanceWeight * distanceFactor + bias) * SimulationCost + benefitBias) * benefitWeight

F32 TurbulenceFSAssetParams::lodWeights.benefitWeight

'lodWeights.benefitWeight' : benefit = ((distanceWeight * distanceFactor + bias) * SimulationCost + benefitBias) * benefitWeight

F32 TurbulenceFSAssetParams::lodWeights.bias

'lodWeights.bias' : benefit = ((distanceWeight * distanceFactor + bias) * SimulationCost + benefitBias) * benefitWeight

F32 TurbulenceFSAssetParams::lodWeights.distanceWeight

'lodWeights.distanceWeight' : Weight given to distance parameter in LOD function

F32 TurbulenceFSAssetParams::lodWeights.maxDistance

'lodWeights.maxDistance' : Objects greater than this distance from the player will be culled more aggressively

U32 TurbulenceFSAssetParams::maxCollidingObjects

'maxCollidingObjects' : The maximum number of colliding objects.

U32 TurbulenceFSAssetParams::maxHeatSources

'maxHeatSources' : The maximum number of heat source.

U32 TurbulenceFSAssetParams::maxSubstanceSources

'maxSubstanceSources' : The maximum number of substance source (computed if density enabled).

U32 TurbulenceFSAssetParams::maxVelocitySources

'maxVelocitySources' : The maximum number of velocity source.

U32 TurbulenceFSAssetParams::noiseParams.noiseOctaves

'noiseParams.noiseOctaves' : Number of the noise octaves (more octaves give more turbulent noise, but increase computational time).

Vec3 TurbulenceFSAssetParams::noiseParams.noiseSpacePeriod

'noiseParams.noiseSpacePeriod' : Noise period in space.

F32 TurbulenceFSAssetParams::noiseParams.noiseStrength

'noiseParams.noiseStrength' : The strength of the noise added to the simulation.

F32 TurbulenceFSAssetParams::noiseParams.noiseTimePeriod

'noiseParams.noiseTimePeriod' : Noise time period.

F32 TurbulenceFSAssetParams::updatesPerFrameRange.max

'updatesPerFrameRange.max' : Maximum value

F32 TurbulenceFSAssetParams::updatesPerFrameRange.min

'updatesPerFrameRange.min' : Minimum value

Bool TurbulenceFSAssetParams::useDensity

'useDensity' : Enable whether or not to use density in the simulation.

Bool TurbulenceFSAssetParams::useHeat

'useHeat' : Enable whether or not to use heat in the simulation.

F32 TurbulenceFSAssetParams::velocityFieldFadeDelay

'velocityFieldFadeDelay' : Time without activity before velocity field cleaning process starts [sec].

F32 TurbulenceFSAssetParams::velocityFieldFadeIntensity

'velocityFieldFadeIntensity' : This parameter sets how much each velocity vector should be damped, so (1 - velocityFieldFadeIntensity) of original velocity vector magnitude will be left after the fade process finishes.

F32 TurbulenceFSAssetParams::velocityFieldFadeTime

'velocityFieldFadeTime' : Time of velocity field cleaning process [sec]. Cleaning disabled by default.

Ref TurbulenceFSAssetParams::volumeRenderMaterialName

'volumeRenderMaterialName' : The optional volume render material name

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
TurbulenceFSAssetParams Member List
This is the complete list of members for TurbulenceFSAssetParams, including all inherited members.
angularVelocityClamp | TurbulenceFSAssetParams
angularVelocityMultiplier | TurbulenceFSAssetParams
boundaryFadePercentage | TurbulenceFSAssetParams
boundarySizePercentage | TurbulenceFSAssetParams
collisionFilterDataName | TurbulenceFSAssetParams
customLOD | TurbulenceFSAssetParams
densityParams.densityFieldFade | TurbulenceFSAssetParams
densityParams.densityGridMultiplier | TurbulenceFSAssetParams
densityParams.diffusionCoef | TurbulenceFSAssetParams
dragCoeff | TurbulenceFSAssetParams
dragCoeffForRigidBody | TurbulenceFSAssetParams
externalVelocity | TurbulenceFSAssetParams
fieldBoundaryFilterDataName | TurbulenceFSAssetParams
fieldSamplerFilterDataName | TurbulenceFSAssetParams
fieldVelocityMultiplier | TurbulenceFSAssetParams
fieldVelocityWeight | TurbulenceFSAssetParams
fluidViscosity | TurbulenceFSAssetParams
gridSizeWorld | TurbulenceFSAssetParams
gridXRange.max | TurbulenceFSAssetParams
gridXRange.min | TurbulenceFSAssetParams
gridYRange.max | TurbulenceFSAssetParams
gridYRange.min | TurbulenceFSAssetParams
gridZRange.max | TurbulenceFSAssetParams
gridZRange.min | TurbulenceFSAssetParams
heatParams.ambientTemperature | TurbulenceFSAssetParams
heatParams.heatForceDirection | TurbulenceFSAssetParams
heatParams.temperatureBasedForceMultiplier | TurbulenceFSAssetParams
heatParams.thermalConductivity | TurbulenceFSAssetParams
isEnabledOptimizedLOD | TurbulenceFSAssetParams
linearVelocityClamp | TurbulenceFSAssetParams
linearVelocityMultiplier | TurbulenceFSAssetParams
lodWeights.benefitBias | TurbulenceFSAssetParams
lodWeights.benefitWeight | TurbulenceFSAssetParams
lodWeights.bias | TurbulenceFSAssetParams
lodWeights.distanceWeight | TurbulenceFSAssetParams
lodWeights.maxDistance | TurbulenceFSAssetParams
maxCollidingObjects | TurbulenceFSAssetParams
maxHeatSources | TurbulenceFSAssetParams
maxSubstanceSources | TurbulenceFSAssetParams
maxVelocitySources | TurbulenceFSAssetParams
noiseParams.noiseOctaves | TurbulenceFSAssetParams
noiseParams.noiseSpacePeriod | TurbulenceFSAssetParams
noiseParams.noiseStrength | TurbulenceFSAssetParams
noiseParams.noiseTimePeriod | TurbulenceFSAssetParams
updatesPerFrameRange.max | TurbulenceFSAssetParams
updatesPerFrameRange.min | TurbulenceFSAssetParams
useDensity | TurbulenceFSAssetParams
useHeat | TurbulenceFSAssetParams
velocityFieldFadeDelay | TurbulenceFSAssetParams
velocityFieldFadeIntensity | TurbulenceFSAssetParams
velocityFieldFadeTime | TurbulenceFSAssetParams
volumeRenderMaterialName | TurbulenceFSAssetParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: TurbulenceFSDebugRenderParams Struct Reference

  • Class List
  • Class Members
Public Attributes
TurbulenceFSDebugRenderParams Struct Reference

Describes the NxParameterized::Interface for 'TurbulenceFSDebugRenderParams' : More...

#include <params.h>

List of all members.

Public Attributes

Bool | VISUALIZE_TURBULENCE_FS_ACTOR
'VISUALIZE_TURBULENCE_FS_ACTOR' : Enables/Disables visualization of all turbulence actors
Bool | VISUALIZE_HEAT_SOURCE_ACTOR
'VISUALIZE_HEAT_SOURCE_ACTOR' : Enables/Disables visualization of all heat source actors
Bool | VISUALIZE_SUBSTANCE_SOURCE_ACTOR
'VISUALIZE_SUBSTANCE_SOURCE_ACTOR' : Enables/Disables visualization of all heat source actors
Bool | VISUALIZE_VELOCITY_SOURCE_ACTOR
'VISUALIZE_VELOCITY_SOURCE_ACTOR' : Enables/Disables visualization of all velocity source actors
Bool | VISUALIZE_TURBULENCE_FS_VELOCITY
'VISUALIZE_TURBULENCE_FS_VELOCITY' : Draws a ray for the grid's velocity
Bool | VISUALIZE_TURBULENCE_FS_BBOX
'VISUALIZE_TURBULENCE_FS_BBOX' : Draw a bounding box for the turbulence grid
Bool | VISUALIZE_TURBULENCE_FS_ACTOR_NAME
'VISUALIZE_TURBULENCE_FS_ACTOR_NAME' : Displays the name of the turbulence actor
Bool | VISUALIZE_TURBULENCE_FS_VELOCITY_FIELD
'VISUALIZE_TURBULENCE_FS_VELOCITY_FIELD' : Draws shaded lines originating from the simulation grid centers and extending in the direction of the local velocity
F32 | TURBULENCE_FS_VELOCITY_FIELD_SCALE
'TURBULENCE_FS_VELOCITY_FIELD_SCALE' : Controls the size of the velocity vectors
U32 | TURBULENCE_FS_VELOCITY_FIELD_SPACING
'TURBULENCE_FS_VELOCITY_FIELD_SPACING' : Controls the grid spacing (density) of the velocity samples
Bool | VISUALIZE_TURBULENCE_FS_TEMPERATURE_FIELD
'VISUALIZE_TURBULENCE_FS_TEMPERATURE_FIELD' : Determine the temperature for visualization
Bool | VISUALIZE_TURBULENCE_FS_PRESSURE_FIELD
'VISUALIZE_TURBULENCE_FS_PRESSURE_FIELD' : Determine the pressure for visualization
Bool | VISUALIZE_TURBULENCE_FS_DENSITY_FIELD
'VISUALIZE_TURBULENCE_FS_DENSITY_FIELD' : Determine the density for visualization
F32 | TURBULENCE_FS_SCALAR_FIELD_SCALE
'TURBULENCE_FS_SCALAR_FIELD_SCALE' : Controls the size of debug spheres for scalar field
U32 | TURBULENCE_FS_SCALAR_FIELD_SPACING
'TURBULENCE_FS_SCALAR_FIELD_SPACING' : Controls the grid spacing (density) of scalar field samples
Bool | VISUALIZE_TURBULENCE_FS_STREAMLINES
'VISUALIZE_TURBULENCE_FS_STREAMLINES' : Draws the streamlines as white curved lines
F32 | TURBULENCE_FS_STREAMLINES.tmax
'TURBULENCE_FS_STREAMLINES.tmax' : Determines the number of points in each streamline, using the formula npoints = (int)(_tmax / _tstep)
F32 | TURBULENCE_FS_STREAMLINES.tstep
'TURBULENCE_FS_STREAMLINES.tstep' : The step size for the number of points in the streamline
Vec3 | TURBULENCE_FS_STREAMLINES.grid
'TURBULENCE_FS_STREAMLINES.grid' : Sets the number of stream lines in the x, y, and z dimension
Bool | VISUALIZE_TURBULENCE_FS_PLANE
'VISUALIZE_TURBULENCE_FS_PLANE' : Draws the intersecting plane in the field's bounding box
Vec3 | TURBULENCE_FS_PLANE.normal
'TURBULENCE_FS_PLANE.normal' : Sets the normal for the plane
F32 | TURBULENCE_FS_PLANE.offset
'TURBULENCE_FS_PLANE.offset' : Sets the offset for the plane from the center of the grid
Bool | VISUALIZE_TURBULENCE_FS_GRID
'VISUALIZE_TURBULENCE_FS_GRID' : Draws the intersection of the simulation grid on the plane
Bool | VISUALIZE_TURBULENCE_FS_LOD
'VISUALIZE_TURBULENCE_FS_LOD' : Draws the LOD sphere
Bool | VISUALIZE_TURBULENCE_FS_POSE
'VISUALIZE_TURBULENCE_FS_POSE' : For visualizing the position of the field itself. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.
F32 | TURBULENCE_FS_LOD
'TURBULENCE_FS_LOD' : Draws the LOD value for the turbulence simulation

Detailed Description

Describes the NxParameterized::Interface for 'TurbulenceFSDebugRenderParams' :

TurbulenceFSDebugRenderParams contains 26 fully qualified names
---------------------------------------------
  1 : Bool  VISUALIZE_TURBULENCE_FS_ACTOR
  2 : Bool  VISUALIZE_HEAT_SOURCE_ACTOR
  3 : Bool  VISUALIZE_SUBSTANCE_SOURCE_ACTOR
  4 : Bool  VISUALIZE_VELOCITY_SOURCE_ACTOR
  5 : Bool  VISUALIZE_TURBULENCE_FS_VELOCITY
  6 : Bool  VISUALIZE_TURBULENCE_FS_BBOX
  7 : Bool  VISUALIZE_TURBULENCE_FS_ACTOR_NAME
  8 : Bool  VISUALIZE_TURBULENCE_FS_VELOCITY_FIELD
  9 : F32   TURBULENCE_FS_VELOCITY_FIELD_SCALE
 10 : U32   TURBULENCE_FS_VELOCITY_FIELD_SPACING
 11 : Bool  VISUALIZE_TURBULENCE_FS_TEMPERATURE_FIELD
 12 : Bool  VISUALIZE_TURBULENCE_FS_PRESSURE_FIELD
 13 : Bool  VISUALIZE_TURBULENCE_FS_DENSITY_FIELD
 14 : F32   TURBULENCE_FS_SCALAR_FIELD_SCALE
 15 : U32   TURBULENCE_FS_SCALAR_FIELD_SPACING
 16 : Bool  VISUALIZE_TURBULENCE_FS_STREAMLINES
 17 : F32   TURBULENCE_FS_STREAMLINES.tmax
 18 : F32   TURBULENCE_FS_STREAMLINES.tstep
 19 : Vec3  TURBULENCE_FS_STREAMLINES.grid
 20 : Bool  VISUALIZE_TURBULENCE_FS_PLANE
 21 : Vec3  TURBULENCE_FS_PLANE.normal
 22 : F32   TURBULENCE_FS_PLANE.offset
 23 : Bool  VISUALIZE_TURBULENCE_FS_GRID
 24 : Bool  VISUALIZE_TURBULENCE_FS_LOD
 25 : Bool  VISUALIZE_TURBULENCE_FS_POSE
 26 : F32   TURBULENCE_FS_LOD

Member Data Documentation

F32 TurbulenceFSDebugRenderParams::TURBULENCE_FS_LOD

'TURBULENCE_FS_LOD' : Draws the LOD value for the turbulence simulation

Vec3 TurbulenceFSDebugRenderParams::TURBULENCE_FS_PLANE.normal

'TURBULENCE_FS_PLANE.normal' : Sets the normal for the plane

F32 TurbulenceFSDebugRenderParams::TURBULENCE_FS_PLANE.offset

'TURBULENCE_FS_PLANE.offset' : Sets the offset for the plane from the center of the grid

F32 TurbulenceFSDebugRenderParams::TURBULENCE_FS_SCALAR_FIELD_SCALE

'TURBULENCE_FS_SCALAR_FIELD_SCALE' : Controls the size of debug spheres for scalar field

U32 TurbulenceFSDebugRenderParams::TURBULENCE_FS_SCALAR_FIELD_SPACING

'TURBULENCE_FS_SCALAR_FIELD_SPACING' : Controls the grid spacing (density) of scalar field samples

Vec3 TurbulenceFSDebugRenderParams::TURBULENCE_FS_STREAMLINES.grid

'TURBULENCE_FS_STREAMLINES.grid' : Sets the number of stream lines in the x, y, and z dimension

F32 TurbulenceFSDebugRenderParams::TURBULENCE_FS_STREAMLINES.tmax

'TURBULENCE_FS_STREAMLINES.tmax' : Determines the number of points in each streamline, using the formula npoints = (int)(_tmax / _tstep)

F32 TurbulenceFSDebugRenderParams::TURBULENCE_FS_STREAMLINES.tstep

'TURBULENCE_FS_STREAMLINES.tstep' : The step size for the number of points in the streamline

F32 TurbulenceFSDebugRenderParams::TURBULENCE_FS_VELOCITY_FIELD_SCALE

'TURBULENCE_FS_VELOCITY_FIELD_SCALE' : Controls the size of the velocity vectors

U32 TurbulenceFSDebugRenderParams::TURBULENCE_FS_VELOCITY_FIELD_SPACING

'TURBULENCE_FS_VELOCITY_FIELD_SPACING' : Controls the grid spacing (density) of the velocity samples

Bool TurbulenceFSDebugRenderParams::VISUALIZE_HEAT_SOURCE_ACTOR

'VISUALIZE_HEAT_SOURCE_ACTOR' : Enables/Disables visualization of all heat source actors

Bool TurbulenceFSDebugRenderParams::VISUALIZE_SUBSTANCE_SOURCE_ACTOR

'VISUALIZE_SUBSTANCE_SOURCE_ACTOR' : Enables/Disables visualization of all heat source actors

Bool TurbulenceFSDebugRenderParams::VISUALIZE_TURBULENCE_FS_ACTOR

'VISUALIZE_TURBULENCE_FS_ACTOR' : Enables/Disables visualization of all turbulence actors

Bool TurbulenceFSDebugRenderParams::VISUALIZE_TURBULENCE_FS_ACTOR_NAME

'VISUALIZE_TURBULENCE_FS_ACTOR_NAME' : Displays the name of the turbulence actor

Bool TurbulenceFSDebugRenderParams::VISUALIZE_TURBULENCE_FS_BBOX

'VISUALIZE_TURBULENCE_FS_BBOX' : Draw a bounding box for the turbulence grid

Bool TurbulenceFSDebugRenderParams::VISUALIZE_TURBULENCE_FS_DENSITY_FIELD

'VISUALIZE_TURBULENCE_FS_DENSITY_FIELD' : Determine the density for visualization

Bool TurbulenceFSDebugRenderParams::VISUALIZE_TURBULENCE_FS_GRID

'VISUALIZE_TURBULENCE_FS_GRID' : Draws the intersection of the simulation grid on the plane

Bool TurbulenceFSDebugRenderParams::VISUALIZE_TURBULENCE_FS_LOD

'VISUALIZE_TURBULENCE_FS_LOD' : Draws the LOD sphere

Bool TurbulenceFSDebugRenderParams::VISUALIZE_TURBULENCE_FS_PLANE

'VISUALIZE_TURBULENCE_FS_PLANE' : Draws the intersecting plane in the field's bounding box

Bool TurbulenceFSDebugRenderParams::VISUALIZE_TURBULENCE_FS_POSE

'VISUALIZE_TURBULENCE_FS_POSE' : For visualizing the position of the field itself. Draws arrows which represent axes. Blue arrow stands for Z axis, green - for Y and red - X.

Bool TurbulenceFSDebugRenderParams::VISUALIZE_TURBULENCE_FS_PRESSURE_FIELD

'VISUALIZE_TURBULENCE_FS_PRESSURE_FIELD' : Determine the pressure for visualization

Bool TurbulenceFSDebugRenderParams::VISUALIZE_TURBULENCE_FS_STREAMLINES

'VISUALIZE_TURBULENCE_FS_STREAMLINES' : Draws the streamlines as white curved lines

Bool TurbulenceFSDebugRenderParams::VISUALIZE_TURBULENCE_FS_TEMPERATURE_FIELD

'VISUALIZE_TURBULENCE_FS_TEMPERATURE_FIELD' : Determine the temperature for visualization

Bool TurbulenceFSDebugRenderParams::VISUALIZE_TURBULENCE_FS_VELOCITY

'VISUALIZE_TURBULENCE_FS_VELOCITY' : Draws a ray for the grid's velocity

Bool TurbulenceFSDebugRenderParams::VISUALIZE_TURBULENCE_FS_VELOCITY_FIELD

'VISUALIZE_TURBULENCE_FS_VELOCITY_FIELD' : Draws shaded lines originating from the simulation grid centers and extending in the direction of the local velocity

Bool TurbulenceFSDebugRenderParams::VISUALIZE_VELOCITY_SOURCE_ACTOR

'VISUALIZE_VELOCITY_SOURCE_ACTOR' : Enables/Disables visualization of all velocity source actors

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
TurbulenceFSDebugRenderParams Member List
This is the complete list of members for TurbulenceFSDebugRenderParams, including all inherited members.
TURBULENCE_FS_LOD | TurbulenceFSDebugRenderParams
TURBULENCE_FS_PLANE.normal | TurbulenceFSDebugRenderParams
TURBULENCE_FS_PLANE.offset | TurbulenceFSDebugRenderParams
TURBULENCE_FS_SCALAR_FIELD_SCALE | TurbulenceFSDebugRenderParams
TURBULENCE_FS_SCALAR_FIELD_SPACING | TurbulenceFSDebugRenderParams
TURBULENCE_FS_STREAMLINES.grid | TurbulenceFSDebugRenderParams
TURBULENCE_FS_STREAMLINES.tmax | TurbulenceFSDebugRenderParams
TURBULENCE_FS_STREAMLINES.tstep | TurbulenceFSDebugRenderParams
TURBULENCE_FS_VELOCITY_FIELD_SCALE | TurbulenceFSDebugRenderParams
TURBULENCE_FS_VELOCITY_FIELD_SPACING | TurbulenceFSDebugRenderParams
VISUALIZE_HEAT_SOURCE_ACTOR | TurbulenceFSDebugRenderParams
VISUALIZE_SUBSTANCE_SOURCE_ACTOR | TurbulenceFSDebugRenderParams
VISUALIZE_TURBULENCE_FS_ACTOR | TurbulenceFSDebugRenderParams
VISUALIZE_TURBULENCE_FS_ACTOR_NAME | TurbulenceFSDebugRenderParams
VISUALIZE_TURBULENCE_FS_BBOX | TurbulenceFSDebugRenderParams
VISUALIZE_TURBULENCE_FS_DENSITY_FIELD | TurbulenceFSDebugRenderParams
VISUALIZE_TURBULENCE_FS_GRID | TurbulenceFSDebugRenderParams
VISUALIZE_TURBULENCE_FS_LOD | TurbulenceFSDebugRenderParams
VISUALIZE_TURBULENCE_FS_PLANE | TurbulenceFSDebugRenderParams
VISUALIZE_TURBULENCE_FS_POSE | TurbulenceFSDebugRenderParams
VISUALIZE_TURBULENCE_FS_PRESSURE_FIELD | TurbulenceFSDebugRenderParams
VISUALIZE_TURBULENCE_FS_STREAMLINES | TurbulenceFSDebugRenderParams
VISUALIZE_TURBULENCE_FS_TEMPERATURE_FIELD | TurbulenceFSDebugRenderParams
VISUALIZE_TURBULENCE_FS_VELOCITY | TurbulenceFSDebugRenderParams
VISUALIZE_TURBULENCE_FS_VELOCITY_FIELD | TurbulenceFSDebugRenderParams
VISUALIZE_VELOCITY_SOURCE_ACTOR | TurbulenceFSDebugRenderParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: TurbulenceFSModuleParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
TurbulenceFSModuleParameters Struct Reference

Describes the NxParameterized::Interface for 'TurbulenceFSModuleParameters' : This class is used for initializing the NxModuleFieldBoundary. More...

#include <params.h>

List of all members.

Public Attributes

U32 unused
'unused' : No parameters necessary

Detailed Description

Describes the NxParameterized::Interface for 'TurbulenceFSModuleParameters' : This class is used for initializing the NxModuleFieldBoundary.

TurbulenceFSModuleParameters contains 1 fully qualified names
---------------------------------------------
  1 : U32  unused

Member Data Documentation

U32 TurbulenceFSModuleParameters::unused

'unused' : No parameters necessary

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
TurbulenceFSModuleParameters Member List
This is the complete list of members for TurbulenceFSModuleParameters, including all inherited members.
unused TurbulenceFSModuleParameters
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: TurbulenceFSPreviewParams Struct Reference

  • Class List
  • Class Members
Public Attributes
TurbulenceFSPreviewParams Struct Reference

Describes the NxParameterized::Interface for 'TurbulenceFSPreviewParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat44 | globalPose
'globalPose' : The pose that translates from turbulence preview coordinates to world coordinates
F32 | iconScale
'iconScale' : The scale of the icon
Bool | drawIcon
'drawIcon' : Draw the icon
Bool | drawBox
'drawBox' : Draw the box
Bool | drawGrid
'drawGrid' : Draw the grid
Bool | drawAssetInfo
'drawAssetInfo' : Display asset info
U64 | userData
'userData' : Optional user data pointer associated with the turbulence actor

Detailed Description

Describes the NxParameterized::Interface for 'TurbulenceFSPreviewParams' :

TurbulenceFSPreviewParams contains 7 fully qualified names
---------------------------------------------
  1 : Mat44  globalPose
  2 : F32    iconScale
  3 : Bool   drawIcon
  4 : Bool   drawBox
  5 : Bool   drawGrid
  6 : Bool   drawAssetInfo
  7 : U64    userData

Member Data Documentation

Bool TurbulenceFSPreviewParams::drawAssetInfo

'drawAssetInfo' : Display asset info

Bool TurbulenceFSPreviewParams::drawBox

'drawBox' : Draw the box

Bool TurbulenceFSPreviewParams::drawGrid

'drawGrid' : Draw the grid

Bool TurbulenceFSPreviewParams::drawIcon

'drawIcon' : Draw the icon

Mat44 TurbulenceFSPreviewParams::globalPose

'globalPose' : The pose that translates from turbulence preview coordinates to world coordinates

F32 TurbulenceFSPreviewParams::iconScale

'iconScale' : The scale of the icon

U64 TurbulenceFSPreviewParams::userData

'userData' : Optional user data pointer associated with the turbulence actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
TurbulenceFSPreviewParams Member List
This is the complete list of members for TurbulenceFSPreviewParams, including all inherited members.
drawAssetInfo | TurbulenceFSPreviewParams
drawBox | TurbulenceFSPreviewParams
drawGrid | TurbulenceFSPreviewParams
drawIcon | TurbulenceFSPreviewParams
globalPose | TurbulenceFSPreviewParams
iconScale | TurbulenceFSPreviewParams
userData | TurbulenceFSPreviewParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VelocitySourceActorParams Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
VelocitySourceActorParams Struct Reference

Describes the NxParameterized::Interface for 'VelocitySourceActorParams' : More...

#include <params.h>

List of all members.

Classes

union | GeometryType

Public Attributes

Mat34 | initialPose
'initialPose' : The global pose for the actor.
F32 | initialScale
'initialScale' : The space scale of the actor
F32 | averageVelocity
'averageVelocity' : The arithmetic mean of a sample. Normal distribution parameter.
F32 | stdVelocity
'stdVelocity' : Standard deviation. Normal distribution parameter.
GeometryType geometryType
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for VelocitySource vs TurbulenceFS interaction. Overrides asset's value.

Detailed Description

Describes the NxParameterized::Interface for 'VelocitySourceActorParams' :

VelocitySourceActorParams contains 7 fully qualified names
---------------------------------------------
  1 : Mat34   initialPose
  2 : F32     initialScale
  3 : F32     averageVelocity
  4 : F32     stdVelocity
  5 : Vec3    geometryType.extents        RefVariant[HeatSourceGeomBoxParams]
  6 : F32     geometryType.radius         RefVariant[HeatSourceGeomSphereParams]
  7 : String  fieldSamplerFilterDataName

Member Data Documentation

F32 VelocitySourceActorParams::averageVelocity

'averageVelocity' : The arithmetic mean of a sample. Normal distribution parameter.

String VelocitySourceActorParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for VelocitySource vs TurbulenceFS interaction. Overrides asset's value.

GeometryType VelocitySourceActorParams::geometryType
Mat34 VelocitySourceActorParams::initialPose

'initialPose' : The global pose for the actor.

F32 VelocitySourceActorParams::initialScale

'initialScale' : The space scale of the actor

F32 VelocitySourceActorParams::stdVelocity

'stdVelocity' : Standard deviation. Normal distribution parameter.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
VelocitySourceActorParams Member List
This is the complete list of members for VelocitySourceActorParams, including all inherited members.
averageVelocity | VelocitySourceActorParams
fieldSamplerFilterDataName | VelocitySourceActorParams
geometryType | VelocitySourceActorParams
initialPose | VelocitySourceActorParams
initialScale | VelocitySourceActorParams
stdVelocity | VelocitySourceActorParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VelocitySourceAssetParams Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
VelocitySourceAssetParams Struct Reference

Describes the NxParameterized::Interface for 'VelocitySourceAssetParams' : Contains the asset properties for this VelocitySource. More...

#include <params.h>

List of all members.

Classes

union | GeometryType

Public Attributes

F32 | averageVelocity
'averageVelocity' : The arithmetic mean of a sample. Normal distribution parameter.
F32 | stdVelocity
'stdVelocity' : Standard deviation. Normal distribution parameter.
GeometryType geometryType
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for VelocitySource vs TurbulenceFS interaction.

Detailed Description

Describes the NxParameterized::Interface for 'VelocitySourceAssetParams' : Contains the asset properties for this VelocitySource.

VelocitySourceAssetParams contains 5 fully qualified names
---------------------------------------------
  1 : F32     averageVelocity
  2 : F32     stdVelocity
  3 : Vec3    geometryType.extents        RefVariant[HeatSourceGeomBoxParams]
  4 : F32     geometryType.radius         RefVariant[HeatSourceGeomSphereParams]
  5 : String  fieldSamplerFilterDataName

Member Data Documentation

F32 VelocitySourceAssetParams::averageVelocity

'averageVelocity' : The arithmetic mean of a sample. Normal distribution parameter.

String VelocitySourceAssetParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for VelocitySource vs TurbulenceFS interaction.

GeometryType VelocitySourceAssetParams::geometryType
F32 VelocitySourceAssetParams::stdVelocity

'stdVelocity' : Standard deviation. Normal distribution parameter.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
VelocitySourceAssetParams Member List
This is the complete list of members for VelocitySourceAssetParams, including all inherited members.
averageVelocity | VelocitySourceAssetParams
fieldSamplerFilterDataName | VelocitySourceAssetParams
geometryType | VelocitySourceAssetParams
stdVelocity | VelocitySourceAssetParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VelocitySourceData Struct Reference

  • Class List
  • Class Members
Public Attributes
VelocitySourceData Struct Reference

Describes the NxParameterized::Interface for 'VelocitySourceData' : Contains the asset properties for this velocity source. More...

#include <params.h>

List of all members.

Public Attributes

String Name
'Name' : Velocity Source Name
VelocitySourceAssetParams VelocitySource
'VelocitySource' :

Detailed Description

Describes the NxParameterized::Interface for 'VelocitySourceData' : Contains the asset properties for this velocity source.

VelocitySourceData contains 6 fully qualified names
---------------------------------------------
  1 : String  Name
  2 : F32     VelocitySource.averageVelocity             RefVariant[VelocitySourceAssetParams]
  3 : F32     VelocitySource.stdVelocity                 RefVariant[VelocitySourceAssetParams]
  4 : Vec3    VelocitySource.geometryType.extents        RefVariant[HeatSourceGeomBoxParams]
  5 : F32     VelocitySource.geometryType.radius         RefVariant[HeatSourceGeomSphereParams]
  6 : String  VelocitySource.fieldSamplerFilterDataName  RefVariant[VelocitySourceAssetParams]

Member Data Documentation

String VelocitySourceData::Name

'Name' : Velocity Source Name

VelocitySourceAssetParams VelocitySourceData::VelocitySource

'VelocitySource' :

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
VelocitySourceData Member List
This is the complete list of members for VelocitySourceData, including all inherited members.
Name | VelocitySourceData
VelocitySource | VelocitySourceData
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VelocitySourceEffect Struct Reference

  • Class List
  • Class Members
Public Attributes
VelocitySourceEffect Struct Reference

Describes the NxParameterized::Interface for 'VelocitySourceEffect' : A velocity source effect. More...

#include <params.h>

List of all members.

Public Attributes

String | EffectProperties.UserString
'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer
Bool | EffectProperties.Enable
'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup
F32 | EffectProperties.Position.TranslateX
'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateY
'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateZ
'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Orientation.RotateX
'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateY
'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateZ
'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)
F32 | EffectProperties.InitialDelayTime
'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect
F32 | EffectProperties.Duration
'EffectProperties.Duration' : The duration of the effect in secontds
U32 | EffectProperties.RepeatCount
'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever
F32 | EffectProperties.RepeatDelay
'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time
F32 | EffectProperties.RandomizeRepeatTime
'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.
PlaybackMode EffectProperties.Path.PlaybackMode
'EffectProperties.Path.PlaybackMode' : The mode to play back the path
F32 | EffectProperties.Path.PathDuration
'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided
U32 | EffectProperties.Path.LoopIndex
'EffectProperties.Path.LoopIndex' : The array index to loop back to
Transform | EffectProperties.Path.ControlPoints[]
'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to
F32 | EffectProperties.Path.Scale[].x
'EffectProperties.Path.Scale[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Scale[].y
'EffectProperties.Path.Scale[].y' : The y-axis value for this vector
F32 | EffectProperties.Path.Speed[].x
'EffectProperties.Path.Speed[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Speed[].y
'EffectProperties.Path.Speed[].y' : The y-axis value for this vector
Ref | VelocitySource
'VelocitySource' : Velocity Source Asset

Detailed Description

Describes the NxParameterized::Interface for 'VelocitySourceEffect' : A velocity source effect.

VelocitySourceEffect contains 25 fully qualified names
---------------------------------------------
  1 : String         EffectProperties.UserString
  2 : Bool           EffectProperties.Enable
  3 : F32            EffectProperties.Position.TranslateX
  4 : F32            EffectProperties.Position.TranslateY
  5 : F32            EffectProperties.Position.TranslateZ
  6 : F32            EffectProperties.Orientation.RotateX
  7 : F32            EffectProperties.Orientation.RotateY
  8 : F32            EffectProperties.Orientation.RotateZ
  9 : F32            EffectProperties.InitialDelayTime
 10 : F32            EffectProperties.Duration
 11 : U32            EffectProperties.RepeatCount
 12 : F32            EffectProperties.RepeatDelay
 13 : F32            EffectProperties.RandomizeRepeatTime
 14 : PlaybackMode   EffectProperties.Path.PlaybackMode
 15 : F32            EffectProperties.Path.PathDuration
 16 : U32            EffectProperties.Path.LoopIndex
 17 : ArraySizeName  ControlPoints
 18 : Transform      EffectProperties.Path.ControlPoints[]
 19 : ArraySizeName  Scale
 20 : F32            EffectProperties.Path.Scale[].x
 21 : F32            EffectProperties.Path.Scale[].y
 22 : ArraySizeName  Speed
 23 : F32            EffectProperties.Path.Speed[].x
 24 : F32            EffectProperties.Path.Speed[].y
 25 : Ref            VelocitySource

Member Data Documentation

F32 VelocitySourceEffect::EffectProperties.Duration

'EffectProperties.Duration' : The duration of the effect in secontds

Bool VelocitySourceEffect::EffectProperties.Enable

'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup

F32 VelocitySourceEffect::EffectProperties.InitialDelayTime

'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect

F32 VelocitySourceEffect::EffectProperties.Orientation.RotateX

'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)

F32 VelocitySourceEffect::EffectProperties.Orientation.RotateY

'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)

F32 VelocitySourceEffect::EffectProperties.Orientation.RotateZ

'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)

Transform VelocitySourceEffect::EffectProperties.Path.ControlPoints[]

'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to

U32 VelocitySourceEffect::EffectProperties.Path.LoopIndex

'EffectProperties.Path.LoopIndex' : The array index to loop back to

F32 VelocitySourceEffect::EffectProperties.Path.PathDuration

'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided

PlaybackMode VelocitySourceEffect::EffectProperties.Path.PlaybackMode

'EffectProperties.Path.PlaybackMode' : The mode to play back the path

F32 VelocitySourceEffect::EffectProperties.Path.Scale[].x

'EffectProperties.Path.Scale[].x' : The x-axis value for this vector

F32 VelocitySourceEffect::EffectProperties.Path.Scale[].y

'EffectProperties.Path.Scale[].y' : The y-axis value for this vector

F32 VelocitySourceEffect::EffectProperties.Path.Speed[].x

'EffectProperties.Path.Speed[].x' : The x-axis value for this vector

F32 VelocitySourceEffect::EffectProperties.Path.Speed[].y

'EffectProperties.Path.Speed[].y' : The y-axis value for this vector

F32 VelocitySourceEffect::EffectProperties.Position.TranslateX

'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction

F32 VelocitySourceEffect::EffectProperties.Position.TranslateY

'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction

F32 VelocitySourceEffect::EffectProperties.Position.TranslateZ

'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction

F32 VelocitySourceEffect::EffectProperties.RandomizeRepeatTime

'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.

U32 VelocitySourceEffect::EffectProperties.RepeatCount

'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever

F32 VelocitySourceEffect::EffectProperties.RepeatDelay

'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time

String VelocitySourceEffect::EffectProperties.UserString

'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer

Ref VelocitySourceEffect::VelocitySource

'VelocitySource' : Velocity Source Asset

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
VelocitySourceEffect Member List
This is the complete list of members for VelocitySourceEffect, including all inherited members.
EffectProperties.Duration | VelocitySourceEffect
EffectProperties.Enable | VelocitySourceEffect
EffectProperties.InitialDelayTime | VelocitySourceEffect
EffectProperties.Orientation.RotateX | VelocitySourceEffect
EffectProperties.Orientation.RotateY | VelocitySourceEffect
EffectProperties.Orientation.RotateZ | VelocitySourceEffect
EffectProperties.Path.ControlPoints[] | VelocitySourceEffect
EffectProperties.Path.LoopIndex | VelocitySourceEffect
EffectProperties.Path.PathDuration | VelocitySourceEffect
EffectProperties.Path.PlaybackMode | VelocitySourceEffect
EffectProperties.Path.Scale[].x | VelocitySourceEffect
EffectProperties.Path.Scale[].y | VelocitySourceEffect
EffectProperties.Path.Speed[].x | VelocitySourceEffect
EffectProperties.Path.Speed[].y | VelocitySourceEffect
EffectProperties.Position.TranslateX | VelocitySourceEffect
EffectProperties.Position.TranslateY | VelocitySourceEffect
EffectProperties.Position.TranslateZ | VelocitySourceEffect
EffectProperties.RandomizeRepeatTime | VelocitySourceEffect
EffectProperties.RepeatCount | VelocitySourceEffect
EffectProperties.RepeatDelay | VelocitySourceEffect
EffectProperties.UserString | VelocitySourceEffect
VelocitySource | VelocitySourceEffect
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VelocitySourcePreviewParams Struct Reference

  • Class List
  • Class Members
Public Attributes
VelocitySourcePreviewParams Struct Reference

Describes the NxParameterized::Interface for 'VelocitySourcePreviewParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat34 | pose
'pose' : The preview actor's position and rotation
F32 | scale
'scale' : The preview actor's scale

Detailed Description

Describes the NxParameterized::Interface for 'VelocitySourcePreviewParams' :

VelocitySourcePreviewParams contains 2 fully qualified names
---------------------------------------------
  1 : Mat34  pose
  2 : F32    scale

Member Data Documentation

Mat34 VelocitySourcePreviewParams::pose

'pose' : The preview actor's position and rotation

F32 VelocitySourcePreviewParams::scale

'scale' : The preview actor's scale

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
VelocitySourcePreviewParams Member List
This is the complete list of members for VelocitySourcePreviewParams, including all inherited members.
pose | VelocitySourcePreviewParams
scale | VelocitySourcePreviewParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VertexBufferParameters Struct Reference

  • Class List
  • Class Members
Classes | Public Attributes
VertexBufferParameters Struct Reference

Describes the NxParameterized::Interface for 'VertexBufferParameters' : More...

#include <params.h>

List of all members.

Classes

union | Buffers

Public Attributes

U32 | vertexCount
'vertexCount' : Number of vertices
VertexFormatParameters vertexFormat
'vertexFormat' :
Buffers buffers[]

Detailed Description

Describes the NxParameterized::Interface for 'VertexBufferParameters' :

VertexBufferParameters contains 65 fully qualified names
---------------------------------------------
  1 : U32            vertexCount
  2 : U32            vertexFormat.winding                    RefVariant[VertexFormatParameters]
  3 : Bool           vertexFormat.hasSeparateBoneBuffer      RefVariant[VertexFormatParameters]
  4 : ArraySizeName  vertexFormat.bufferFormats              RefVariant[VertexFormatParameters]
  5 : String         vertexFormat.bufferFormats[].name       RefVariant[VertexFormatParameters]
  6 : I32            vertexFormat.bufferFormats[].semantic   RefVariant[VertexFormatParameters]
  7 : U32            vertexFormat.bufferFormats[].id         RefVariant[VertexFormatParameters]
  8 : U32            vertexFormat.bufferFormats[].format     RefVariant[VertexFormatParameters]
  9 : U32            vertexFormat.bufferFormats[].access     RefVariant[VertexFormatParameters]
 10 : Bool           vertexFormat.bufferFormats[].serialize  RefVariant[VertexFormatParameters]
 11 : ArraySizeName  buffers
 12 : ArraySizeName  buffers[].data                          RefVariant[BufferU8x1]
 13 : U8             buffers[].data[]                        RefVariant[BufferU8x1]
 14 : ArraySizeName  buffers[].data                          RefVariant[BufferU8x2]
 15 : U8             buffers[].data[].x                      RefVariant[BufferU8x2]
 16 : U8             buffers[].data[].y                      RefVariant[BufferU8x2]
 17 : ArraySizeName  buffers[].data                          RefVariant[BufferU8x3]
 18 : U8             buffers[].data[].x                      RefVariant[BufferU8x3]
 19 : U8             buffers[].data[].y                      RefVariant[BufferU8x3]
 20 : U8             buffers[].data[].z                      RefVariant[BufferU8x3]
 21 : ArraySizeName  buffers[].data                          RefVariant[BufferU8x4]
 22 : U8             buffers[].data[].x                      RefVariant[BufferU8x4]
 23 : U8             buffers[].data[].y                      RefVariant[BufferU8x4]
 24 : U8             buffers[].data[].z                      RefVariant[BufferU8x4]
 25 : U8             buffers[].data[].w                      RefVariant[BufferU8x4]
 26 : ArraySizeName  buffers[].data                          RefVariant[BufferU16x1]
 27 : U16            buffers[].data[]                        RefVariant[BufferU16x1]
 28 : ArraySizeName  buffers[].data                          RefVariant[BufferU16x2]
 29 : U16            buffers[].data[].x                      RefVariant[BufferU16x2]
 30 : U16            buffers[].data[].y                      RefVariant[BufferU16x2]
 31 : ArraySizeName  buffers[].data                          RefVariant[BufferU16x3]
 32 : U16            buffers[].data[].x                      RefVariant[BufferU16x3]
 33 : U16            buffers[].data[].y                      RefVariant[BufferU16x3]
 34 : U16            buffers[].data[].z                      RefVariant[BufferU16x3]
 35 : ArraySizeName  buffers[].data                          RefVariant[BufferU16x4]
 36 : U16            buffers[].data[].x                      RefVariant[BufferU16x4]
 37 : U16            buffers[].data[].y                      RefVariant[BufferU16x4]
 38 : U16            buffers[].data[].z                      RefVariant[BufferU16x4]
 39 : U16            buffers[].data[].w                      RefVariant[BufferU16x4]
 40 : ArraySizeName  buffers[].data                          RefVariant[BufferU32x1]
 41 : U32            buffers[].data[]                        RefVariant[BufferU32x1]
 42 : ArraySizeName  buffers[].data                          RefVariant[BufferU32x2]
 43 : U32            buffers[].data[].x                      RefVariant[BufferU32x2]
 44 : U32            buffers[].data[].y                      RefVariant[BufferU32x2]
 45 : ArraySizeName  buffers[].data                          RefVariant[BufferU32x3]
 46 : U32            buffers[].data[].x                      RefVariant[BufferU32x3]
 47 : U32            buffers[].data[].y                      RefVariant[BufferU32x3]
 48 : U32            buffers[].data[].z                      RefVariant[BufferU32x3]
 49 : ArraySizeName  buffers[].data                          RefVariant[BufferU32x4]
 50 : U32            buffers[].data[].x                      RefVariant[BufferU32x4]
 51 : U32            buffers[].data[].y                      RefVariant[BufferU32x4]
 52 : U32            buffers[].data[].z                      RefVariant[BufferU32x4]
 53 : U32            buffers[].data[].w                      RefVariant[BufferU32x4]
 54 : ArraySizeName  buffers[].data                          RefVariant[BufferF32x1]
 55 : F32            buffers[].data[]                        RefVariant[BufferF32x1]
 56 : ArraySizeName  buffers[].data                          RefVariant[BufferF32x2]
 57 : F32            buffers[].data[].x                      RefVariant[BufferF32x2]
 58 : F32            buffers[].data[].y                      RefVariant[BufferF32x2]
 59 : ArraySizeName  buffers[].data                          RefVariant[BufferF32x3]
 60 : Vec3           buffers[].data[]                        RefVariant[BufferF32x3]
 61 : ArraySizeName  buffers[].data                          RefVariant[BufferF32x4]
 62 : F32            buffers[].data[].x                      RefVariant[BufferF32x4]
 63 : F32            buffers[].data[].y                      RefVariant[BufferF32x4]
 64 : F32            buffers[].data[].z                      RefVariant[BufferF32x4]
 65 : F32            buffers[].data[].w                      RefVariant[BufferF32x4]

Member Data Documentation

Buffers VertexBufferParameters::buffers[]
U32 VertexBufferParameters::vertexCount

'vertexCount' : Number of vertices

The number of vertices in the verrtex buffer. All vertex data channels (positions, normals, etc.) will contain this many items.

VertexFormatParameters VertexBufferParameters::vertexFormat

'vertexFormat' :

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
VertexBufferParameters Member List
This is the complete list of members for VertexBufferParameters, including all inherited members.
buffers[] | VertexBufferParameters
vertexCount | VertexBufferParameters
vertexFormat | VertexBufferParameters
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VertexFormatParameters Struct Reference

  • Class List
  • Class Members
Public Attributes
VertexFormatParameters Struct Reference

Describes the NxParameterized::Interface for 'VertexFormatParameters' : More...

#include <params.h>

List of all members.

Public Attributes

U32 | winding
'winding' : Vertex orders to be rendered
Bool | hasSeparateBoneBuffer
'hasSeparateBoneBuffer' : Whether or not there exists a separate bone buffer
String | bufferFormats[].name
'bufferFormats[].name' : Name by which this buffer is referenced
I32 | bufferFormats[].semantic
'bufferFormats[].semantic' : This buffer's semantic.
U32 | bufferFormats[].id
'bufferFormats[].id' : This buffer's id.
U32 | bufferFormats[].format
'bufferFormats[].format' : The format of this buffer
U32 | bufferFormats[].access
'bufferFormats[].access' : The access type for this buffer
Bool | bufferFormats[].serialize
'bufferFormats[].serialize' : Serialize this buffer

Detailed Description

Describes the NxParameterized::Interface for 'VertexFormatParameters' :

VertexFormatParameters contains 9 fully qualified names
---------------------------------------------
  1 : U32            winding
  2 : Bool           hasSeparateBoneBuffer
  3 : ArraySizeName  bufferFormats
  4 : String         bufferFormats[].name
  5 : I32            bufferFormats[].semantic
  6 : U32            bufferFormats[].id
  7 : U32            bufferFormats[].format
  8 : U32            bufferFormats[].access
  9 : Bool           bufferFormats[].serialize

Member Data Documentation

U32 VertexFormatParameters::bufferFormats[].access

'bufferFormats[].access' : The access type for this buffer

The access type for this buffer. Must be one of the NxVertexDataAccess::Enum values.

U32 VertexFormatParameters::bufferFormats[].format

'bufferFormats[].format' : The format of this buffer

The format of this buffer. Must be one of the NxRenderDataFormat::Enum values.

U32 VertexFormatParameters::bufferFormats[].id

'bufferFormats[].id' : This buffer's id.

This buffer's id. See NxVertexFormat::getSemanticID and NxVertexFormat::getID.

String VertexFormatParameters::bufferFormats[].name

'bufferFormats[].name' : Name by which this buffer is referenced

Name by which this buffer is referenced, for custom semantics. For standard semantics, NxVertexFormat::getSemanticName() is used

I32 VertexFormatParameters::bufferFormats[].semantic

'bufferFormats[].semantic' : This buffer's semantic.

This buffer's semantic. If it's a custom buffer, it will be NxRenderVertexSemantic::CUSTOM.

Bool VertexFormatParameters::bufferFormats[].serialize

'bufferFormats[].serialize' : Serialize this buffer

This is only needed if this buffer needs to be rendered, clothing custom buffer MAX_DISTANCE for example doesn't need it.

Bool VertexFormatParameters::hasSeparateBoneBuffer

'hasSeparateBoneBuffer' : Whether or not there exists a separate bone buffer

Whether or not there exists a separate bone buffer.

U32 VertexFormatParameters::winding

'winding' : Vertex orders to be rendered

This value defines which vertex winding orders will be rendered. See NxRenderCullMode.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
VertexFormatParameters Member List
This is the complete list of members for VertexFormatParameters, including all inherited members.
bufferFormats[].access | VertexFormatParameters
bufferFormats[].format | VertexFormatParameters
bufferFormats[].id | VertexFormatParameters
bufferFormats[].name | VertexFormatParameters
bufferFormats[].semantic | VertexFormatParameters
bufferFormats[].serialize | VertexFormatParameters
hasSeparateBoneBuffer | VertexFormatParameters
winding | VertexFormatParameters
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: ViewDirectionSortingModifierParams Struct Reference

  • Class List
  • Class Members
Public Attributes
ViewDirectionSortingModifierParams Struct Reference

Describes the NxParameterized::Interface for 'ViewDirectionSortingModifierParams' : ViewDirectionSorting modifier parameters. More...

#include <params.h>

List of all members.

Public Attributes

SortType sortType
'sortType' : Sort type

Detailed Description

Describes the NxParameterized::Interface for 'ViewDirectionSortingModifierParams' : ViewDirectionSorting modifier parameters.

ViewDirectionSortingModifierParams contains 1 fully qualified names
---------------------------------------------
  1 : SortType  sortType

Member Data Documentation

SortType ViewDirectionSortingModifierParams::sortType

'sortType' : Sort type

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
ViewDirectionSortingModifierParams Member List
This is the complete list of members for ViewDirectionSortingModifierParams, including all inherited members.
sortType ViewDirectionSortingModifierParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VolumeRenderMaterialData Struct Reference

  • Class List
  • Class Members
Public Attributes
VolumeRenderMaterialData Struct Reference

Describes the NxParameterized::Interface for 'VolumeRenderMaterialData' : Contains the volume render material properties for this asset. More...

#include <params.h>

List of all members.

Public Attributes

String | Name
'Name' : The name of this volume render material
String | ApplicationMaterialName
'ApplicationMaterialName' : The name of the material to match up with the application's material system
String | UserProperties
'UserProperties' : Optional user properties string
RenderMode RenderMode
'RenderMode' : Volume rendering mode
RenderMethod RenderMethod
'RenderMethod' : Determines whether to do raycasting or slice based rendering, default is raycasting
ResolutionScale ResolutionScale
'ResolutionScale' : Resolution scale to use
FillMode FillMode
'FillMode' : Debugging option to render the volume in wireframe mode; default is solid of course
Bool | GenerateShadows
'GenerateShadows' : Generate shadow volume
Bool | BlurShadows
'BlurShadows' : Blur shadow volume
Bool | GenerateMipmaps
'GenerateMipmaps' : The maximum clamp range to use when copying velocity/desnity to the 3d volume texture; this range will be scaled 0-255; it's important to tune the proper range value
Bool | EnableStencilOpt
'EnableStencilOpt' : Enable stencil optimization
F32 | StepScale
'StepScale' : Scale ray march step - e.g. 1.0 == voxel size, 0.5 == half voxel size
F32 | Density
'Density' : Volume density [0, 1000.0]
F32 | EdgeFade
'EdgeFade' : Edge fade distance [0, 1]
F32 | OpacityThreshold
'OpacityThreshold' : Stop ray marching once opacity has reached this threshold [0, 1]
F32 | RayJitter
'RayJitter' : Amount to jitter view rays [0, 1]
F32 | IsoValue
'IsoValue' : Surface Isovalue for Isovalue render mode
F32 | IsoValueSign
'IsoValueSign' : Isovalue sign, density is multiplied by this value before comparison (usually 1.0 or -1.0)
U32 | ShadowSamples
'ShadowSamples' : Number of samples for shadows [0, 256]
F32 | ShadowDistance
'ShadowDistance' : Distance to ray march shadows [0, 1]
F32 | ShadowDensity
'ShadowDensity' : Shadow density [0, 1000]
F32 | ShadowJitter
'ShadowJitter' : Amount to jitter shadow rays [0, 1]
F32 | ShadowAmount
'ShadowAmount' : Amount of shadowing [0, 1]
Vec3 | LightDir
'LightDir' : Normalized light direction
Vec4 | LightColor
'LightColor' : The color to use for the 'light' on this volume render
F32 | BlockEmptyThreshold
'BlockEmptyThreshold' : Threshold above which block is considered non-empty for empty space skipping (typically close to 0.0)
Bool | ReadDepth
'ReadDepth' : Read background depth during compositing
F32 | ColorMapScale
'ColorMapScale' : Color map scale
F32 | ColorMapOffset
'ColorMapOffset' : Color map offset
F32 | ColorMap[].density
'ColorMap[].density' : Density
Vec4 | ColorMap[].color
'ColorMap[].color' : Color is formated x=R, y=G, z=B, w=A
F32 | TextureRangeMin
'TextureRangeMin' : For APEX turbulence, controls the minimum density range to copy to the density texture
F32 | TextureRangeMax
'TextureRangeMax' : For APEX turbulence, controls the maximum density range to copy to the density texture

Detailed Description

Describes the NxParameterized::Interface for 'VolumeRenderMaterialData' : Contains the volume render material properties for this asset.

VolumeRenderMaterialData contains 34 fully qualified names
---------------------------------------------
  1 : String           Name
  2 : String           ApplicationMaterialName
  3 : String           UserProperties
  4 : RenderMode       RenderMode
  5 : RenderMethod     RenderMethod
  6 : ResolutionScale  ResolutionScale
  7 : FillMode         FillMode
  8 : Bool             GenerateShadows
  9 : Bool             BlurShadows
 10 : Bool             GenerateMipmaps
 11 : Bool             EnableStencilOpt
 12 : F32              StepScale
 13 : F32              Density
 14 : F32              EdgeFade
 15 : F32              OpacityThreshold
 16 : F32              RayJitter
 17 : F32              IsoValue
 18 : F32              IsoValueSign
 19 : U32              ShadowSamples
 20 : F32              ShadowDistance
 21 : F32              ShadowDensity
 22 : F32              ShadowJitter
 23 : F32              ShadowAmount
 24 : Vec3             LightDir
 25 : Vec4             LightColor
 26 : F32              BlockEmptyThreshold
 27 : Bool             ReadDepth
 28 : F32              ColorMapScale
 29 : F32              ColorMapOffset
 30 : ArraySizeName    ColorMap
 31 : F32              ColorMap[].density
 32 : Vec4             ColorMap[].color
 33 : F32              TextureRangeMin
 34 : F32              TextureRangeMax

Member Data Documentation

String VolumeRenderMaterialData::ApplicationMaterialName

'ApplicationMaterialName' : The name of the material to match up with the application's material system

F32 VolumeRenderMaterialData::BlockEmptyThreshold

'BlockEmptyThreshold' : Threshold above which block is considered non-empty for empty space skipping (typically close to 0.0)

Bool VolumeRenderMaterialData::BlurShadows

'BlurShadows' : Blur shadow volume

Vec4 VolumeRenderMaterialData::ColorMap[].color

'ColorMap[].color' : Color is formated x=R, y=G, z=B, w=A

F32 VolumeRenderMaterialData::ColorMap[].density

'ColorMap[].density' : Density

F32 VolumeRenderMaterialData::ColorMapOffset

'ColorMapOffset' : Color map offset

F32 VolumeRenderMaterialData::ColorMapScale

'ColorMapScale' : Color map scale

F32 VolumeRenderMaterialData::Density

'Density' : Volume density [0, 1000.0]

F32 VolumeRenderMaterialData::EdgeFade

'EdgeFade' : Edge fade distance [0, 1]

Bool VolumeRenderMaterialData::EnableStencilOpt

'EnableStencilOpt' : Enable stencil optimization

FillMode VolumeRenderMaterialData::FillMode

'FillMode' : Debugging option to render the volume in wireframe mode; default is solid of course

Bool VolumeRenderMaterialData::GenerateMipmaps

'GenerateMipmaps' : The maximum clamp range to use when copying velocity/desnity to the 3d volume texture; this range will be scaled 0-255; it's important to tune the proper range value

Bool VolumeRenderMaterialData::GenerateShadows

'GenerateShadows' : Generate shadow volume

F32 VolumeRenderMaterialData::IsoValue

'IsoValue' : Surface Isovalue for Isovalue render mode

F32 VolumeRenderMaterialData::IsoValueSign

'IsoValueSign' : Isovalue sign, density is multiplied by this value before comparison (usually 1.0 or -1.0)

Vec4 VolumeRenderMaterialData::LightColor

'LightColor' : The color to use for the 'light' on this volume render

Vec3 VolumeRenderMaterialData::LightDir

'LightDir' : Normalized light direction

String VolumeRenderMaterialData::Name

'Name' : The name of this volume render material

F32 VolumeRenderMaterialData::OpacityThreshold

'OpacityThreshold' : Stop ray marching once opacity has reached this threshold [0, 1]

F32 VolumeRenderMaterialData::RayJitter

'RayJitter' : Amount to jitter view rays [0, 1]

Bool VolumeRenderMaterialData::ReadDepth

'ReadDepth' : Read background depth during compositing

RenderMethod VolumeRenderMaterialData::RenderMethod

'RenderMethod' : Determines whether to do raycasting or slice based rendering, default is raycasting

RenderMode VolumeRenderMaterialData::RenderMode

'RenderMode' : Volume rendering mode

ResolutionScale VolumeRenderMaterialData::ResolutionScale

'ResolutionScale' : Resolution scale to use

F32 VolumeRenderMaterialData::ShadowAmount

'ShadowAmount' : Amount of shadowing [0, 1]

F32 VolumeRenderMaterialData::ShadowDensity

'ShadowDensity' : Shadow density [0, 1000]

F32 VolumeRenderMaterialData::ShadowDistance

'ShadowDistance' : Distance to ray march shadows [0, 1]

F32 VolumeRenderMaterialData::ShadowJitter

'ShadowJitter' : Amount to jitter shadow rays [0, 1]

U32 VolumeRenderMaterialData::ShadowSamples

'ShadowSamples' : Number of samples for shadows [0, 256]

F32 VolumeRenderMaterialData::StepScale

'StepScale' : Scale ray march step - e.g. 1.0 == voxel size, 0.5 == half voxel size

F32 VolumeRenderMaterialData::TextureRangeMax

'TextureRangeMax' : For APEX turbulence, controls the maximum density range to copy to the density texture

F32 VolumeRenderMaterialData::TextureRangeMin

'TextureRangeMin' : For APEX turbulence, controls the minimum density range to copy to the density texture

String VolumeRenderMaterialData::UserProperties

'UserProperties' : Optional user properties string

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
VolumeRenderMaterialData Member List
This is the complete list of members for VolumeRenderMaterialData, including all inherited members.
ApplicationMaterialName | VolumeRenderMaterialData
BlockEmptyThreshold | VolumeRenderMaterialData
BlurShadows | VolumeRenderMaterialData
ColorMap[].color | VolumeRenderMaterialData
ColorMap[].density | VolumeRenderMaterialData
ColorMapOffset | VolumeRenderMaterialData
ColorMapScale | VolumeRenderMaterialData
Density | VolumeRenderMaterialData
EdgeFade | VolumeRenderMaterialData
EnableStencilOpt | VolumeRenderMaterialData
FillMode | VolumeRenderMaterialData
GenerateMipmaps | VolumeRenderMaterialData
GenerateShadows | VolumeRenderMaterialData
IsoValue | VolumeRenderMaterialData
IsoValueSign | VolumeRenderMaterialData
LightColor | VolumeRenderMaterialData
LightDir | VolumeRenderMaterialData
Name | VolumeRenderMaterialData
OpacityThreshold | VolumeRenderMaterialData
RayJitter | VolumeRenderMaterialData
ReadDepth | VolumeRenderMaterialData
RenderMethod | VolumeRenderMaterialData
RenderMode | VolumeRenderMaterialData
ResolutionScale | VolumeRenderMaterialData
ShadowAmount | VolumeRenderMaterialData
ShadowDensity | VolumeRenderMaterialData
ShadowDistance | VolumeRenderMaterialData
ShadowJitter | VolumeRenderMaterialData
ShadowSamples | VolumeRenderMaterialData
StepScale | VolumeRenderMaterialData
TextureRangeMax | VolumeRenderMaterialData
TextureRangeMin | VolumeRenderMaterialData
UserProperties | VolumeRenderMaterialData
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VortexFieldSamplerData Struct Reference

  • Class List
  • Class Members
Public Attributes
VortexFieldSamplerData Struct Reference

Describes the NxParameterized::Interface for 'VortexFieldSamplerData' : Contains the asset properties for this vortex field sampler. More...

#include <params.h>

List of all members.

Public Attributes

String Name
'Name' : Vortex FS Name
VortexFSAssetParams VortexFieldSampler
'VortexFieldSampler' :

Detailed Description

Describes the NxParameterized::Interface for 'VortexFieldSamplerData' : Contains the asset properties for this vortex field sampler.

VortexFieldSamplerData contains 15 fully qualified names
---------------------------------------------
  1 : String  Name
  2 : F32     VortexFieldSampler.boundaryFadePercentage       RefVariant[VortexFSAssetParams]
  3 : Vec3    VortexFieldSampler.axis                         RefVariant[VortexFSAssetParams]
  4 : Bool    VortexFieldSampler.bottomSphericalForce         RefVariant[VortexFSAssetParams]
  5 : Bool    VortexFieldSampler.topSphericalForce            RefVariant[VortexFSAssetParams]
  6 : F32     VortexFieldSampler.height                       RefVariant[VortexFSAssetParams]
  7 : F32     VortexFieldSampler.bottomRadius                 RefVariant[VortexFSAssetParams]
  8 : F32     VortexFieldSampler.topRadius                    RefVariant[VortexFSAssetParams]
  9 : F32     VortexFieldSampler.rotationalStrength           RefVariant[VortexFSAssetParams]
 10 : F32     VortexFieldSampler.radialStrength               RefVariant[VortexFSAssetParams]
 11 : F32     VortexFieldSampler.liftStrength                 RefVariant[VortexFSAssetParams]
 12 : F32     VortexFieldSampler.fieldDragCoeff               RefVariant[VortexFSAssetParams]
 13 : F32     VortexFieldSampler.fieldWeight                  RefVariant[VortexFSAssetParams]
 14 : String  VortexFieldSampler.fieldBoundaryFilterDataName  RefVariant[VortexFSAssetParams]
 15 : String  VortexFieldSampler.fieldSamplerFilterDataName   RefVariant[VortexFSAssetParams]

Member Data Documentation

String VortexFieldSamplerData::Name

'Name' : Vortex FS Name

VortexFSAssetParams VortexFieldSamplerData::VortexFieldSampler

'VortexFieldSampler' :

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
VortexFieldSamplerData Member List
This is the complete list of members for VortexFieldSamplerData, including all inherited members.
Name | VortexFieldSamplerData
VortexFieldSampler | VortexFieldSamplerData
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VortexFieldSamplerEffect Struct Reference

  • Class List
  • Class Members
Public Attributes
VortexFieldSamplerEffect Struct Reference

Describes the NxParameterized::Interface for 'VortexFieldSamplerEffect' : A vortex field sampler effect. More...

#include <params.h>

List of all members.

Public Attributes

String | EffectProperties.UserString
'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer
Bool | EffectProperties.Enable
'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup
F32 | EffectProperties.Position.TranslateX
'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateY
'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateZ
'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Orientation.RotateX
'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateY
'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateZ
'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)
F32 | EffectProperties.InitialDelayTime
'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect
F32 | EffectProperties.Duration
'EffectProperties.Duration' : The duration of the effect in secontds
U32 | EffectProperties.RepeatCount
'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever
F32 | EffectProperties.RepeatDelay
'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time
F32 | EffectProperties.RandomizeRepeatTime
'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.
PlaybackMode EffectProperties.Path.PlaybackMode
'EffectProperties.Path.PlaybackMode' : The mode to play back the path
F32 | EffectProperties.Path.PathDuration
'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided
U32 | EffectProperties.Path.LoopIndex
'EffectProperties.Path.LoopIndex' : The array index to loop back to
Transform | EffectProperties.Path.ControlPoints[]
'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to
F32 | EffectProperties.Path.Scale[].x
'EffectProperties.Path.Scale[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Scale[].y
'EffectProperties.Path.Scale[].y' : The y-axis value for this vector
F32 | EffectProperties.Path.Speed[].x
'EffectProperties.Path.Speed[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Speed[].y
'EffectProperties.Path.Speed[].y' : The y-axis value for this vector
Ref | VortexFieldSampler
'VortexFieldSampler' : Vortex FS Asset

Detailed Description

Describes the NxParameterized::Interface for 'VortexFieldSamplerEffect' : A vortex field sampler effect.

VortexFieldSamplerEffect contains 25 fully qualified names
---------------------------------------------
  1 : String         EffectProperties.UserString
  2 : Bool           EffectProperties.Enable
  3 : F32            EffectProperties.Position.TranslateX
  4 : F32            EffectProperties.Position.TranslateY
  5 : F32            EffectProperties.Position.TranslateZ
  6 : F32            EffectProperties.Orientation.RotateX
  7 : F32            EffectProperties.Orientation.RotateY
  8 : F32            EffectProperties.Orientation.RotateZ
  9 : F32            EffectProperties.InitialDelayTime
 10 : F32            EffectProperties.Duration
 11 : U32            EffectProperties.RepeatCount
 12 : F32            EffectProperties.RepeatDelay
 13 : F32            EffectProperties.RandomizeRepeatTime
 14 : PlaybackMode   EffectProperties.Path.PlaybackMode
 15 : F32            EffectProperties.Path.PathDuration
 16 : U32            EffectProperties.Path.LoopIndex
 17 : ArraySizeName  ControlPoints
 18 : Transform      EffectProperties.Path.ControlPoints[]
 19 : ArraySizeName  Scale
 20 : F32            EffectProperties.Path.Scale[].x
 21 : F32            EffectProperties.Path.Scale[].y
 22 : ArraySizeName  Speed
 23 : F32            EffectProperties.Path.Speed[].x
 24 : F32            EffectProperties.Path.Speed[].y
 25 : Ref            VortexFieldSampler

Member Data Documentation

F32 VortexFieldSamplerEffect::EffectProperties.Duration

'EffectProperties.Duration' : The duration of the effect in secontds

Bool VortexFieldSamplerEffect::EffectProperties.Enable

'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup

F32 VortexFieldSamplerEffect::EffectProperties.InitialDelayTime

'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect

F32 VortexFieldSamplerEffect::EffectProperties.Orientation.RotateX

'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)

F32 VortexFieldSamplerEffect::EffectProperties.Orientation.RotateY

'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)

F32 VortexFieldSamplerEffect::EffectProperties.Orientation.RotateZ

'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)

Transform VortexFieldSamplerEffect::EffectProperties.Path.ControlPoints[]

'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to

U32 VortexFieldSamplerEffect::EffectProperties.Path.LoopIndex

'EffectProperties.Path.LoopIndex' : The array index to loop back to

F32 VortexFieldSamplerEffect::EffectProperties.Path.PathDuration

'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided

PlaybackMode VortexFieldSamplerEffect::EffectProperties.Path.PlaybackMode

'EffectProperties.Path.PlaybackMode' : The mode to play back the path

F32 VortexFieldSamplerEffect::EffectProperties.Path.Scale[].x

'EffectProperties.Path.Scale[].x' : The x-axis value for this vector

F32 VortexFieldSamplerEffect::EffectProperties.Path.Scale[].y

'EffectProperties.Path.Scale[].y' : The y-axis value for this vector

F32 VortexFieldSamplerEffect::EffectProperties.Path.Speed[].x

'EffectProperties.Path.Speed[].x' : The x-axis value for this vector

F32 VortexFieldSamplerEffect::EffectProperties.Path.Speed[].y

'EffectProperties.Path.Speed[].y' : The y-axis value for this vector

F32 VortexFieldSamplerEffect::EffectProperties.Position.TranslateX

'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction

F32 VortexFieldSamplerEffect::EffectProperties.Position.TranslateY

'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction

F32 VortexFieldSamplerEffect::EffectProperties.Position.TranslateZ

'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction

F32 VortexFieldSamplerEffect::EffectProperties.RandomizeRepeatTime

'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.

U32 VortexFieldSamplerEffect::EffectProperties.RepeatCount

'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever

F32 VortexFieldSamplerEffect::EffectProperties.RepeatDelay

'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time

String VortexFieldSamplerEffect::EffectProperties.UserString

'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer

Ref VortexFieldSamplerEffect::VortexFieldSampler

'VortexFieldSampler' : Vortex FS Asset

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
VortexFieldSamplerEffect Member List
This is the complete list of members for VortexFieldSamplerEffect, including all inherited members.
EffectProperties.Duration | VortexFieldSamplerEffect
EffectProperties.Enable | VortexFieldSamplerEffect
EffectProperties.InitialDelayTime | VortexFieldSamplerEffect
EffectProperties.Orientation.RotateX | VortexFieldSamplerEffect
EffectProperties.Orientation.RotateY | VortexFieldSamplerEffect
EffectProperties.Orientation.RotateZ | VortexFieldSamplerEffect
EffectProperties.Path.ControlPoints[] | VortexFieldSamplerEffect
EffectProperties.Path.LoopIndex | VortexFieldSamplerEffect
EffectProperties.Path.PathDuration | VortexFieldSamplerEffect
EffectProperties.Path.PlaybackMode | VortexFieldSamplerEffect
EffectProperties.Path.Scale[].x | VortexFieldSamplerEffect
EffectProperties.Path.Scale[].y | VortexFieldSamplerEffect
EffectProperties.Path.Speed[].x | VortexFieldSamplerEffect
EffectProperties.Path.Speed[].y | VortexFieldSamplerEffect
EffectProperties.Position.TranslateX | VortexFieldSamplerEffect
EffectProperties.Position.TranslateY | VortexFieldSamplerEffect
EffectProperties.Position.TranslateZ | VortexFieldSamplerEffect
EffectProperties.RandomizeRepeatTime | VortexFieldSamplerEffect
EffectProperties.RepeatCount | VortexFieldSamplerEffect
EffectProperties.RepeatDelay | VortexFieldSamplerEffect
EffectProperties.UserString | VortexFieldSamplerEffect
VortexFieldSampler | VortexFieldSamplerEffect
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VortexFSActorParams Struct Reference

  • Class List
  • Class Members
Public Attributes
VortexFSActorParams Struct Reference

Describes the NxParameterized::Interface for 'VortexFSActorParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat34 | initialPose
'initialPose' : The initial pose of the actor.
F32 | initialScale
'initialScale' : The initial space scale of the actor
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for AttractorFS vs Field Boundaries interaction. Overrides asset's value.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for AttractorFS vs other Field Samplers interaction. Overrides asset's value.

Detailed Description

Describes the NxParameterized::Interface for 'VortexFSActorParams' :

VortexFSActorParams contains 4 fully qualified names
---------------------------------------------
  1 : Mat34   initialPose
  2 : F32     initialScale
  3 : String  fieldBoundaryFilterDataName
  4 : String  fieldSamplerFilterDataName

Member Data Documentation

String VortexFSActorParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for AttractorFS vs Field Boundaries interaction. Overrides asset's value.

String VortexFSActorParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for AttractorFS vs other Field Samplers interaction. Overrides asset's value.

Mat34 VortexFSActorParams::initialPose

'initialPose' : The initial pose of the actor.

The initial pose of the actor. This includes both translation and rotation.

F32 VortexFSActorParams::initialScale

'initialScale' : The initial space scale of the actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
VortexFSActorParams Member List
This is the complete list of members for VortexFSActorParams, including all inherited members.
fieldBoundaryFilterDataName | VortexFSActorParams
fieldSamplerFilterDataName | VortexFSActorParams
initialPose | VortexFSActorParams
initialScale | VortexFSActorParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VortexFSAssetParams Struct Reference

  • Class List
  • Class Members
Public Attributes
VortexFSAssetParams Struct Reference

Describes the NxParameterized::Interface for 'VortexFSAssetParams' : Contains the asset properties for this Vortex Field Sampler. More...

#include <params.h>

List of all members.

Public Attributes

F32 | boundaryFadePercentage
'boundaryFadePercentage' : Percentage of distance from boundary to center where fade out starts.
Vec3 | axis
'axis' : The primary axis of the vortex around which the particles will rotate.
Bool | bottomSphericalForce
'bottomSphericalForce' : If this parameter true, radial forces in bottom sphere of the capsule will point to the center of sphere.
Bool | topSphericalForce
'topSphericalForce' : If this parameter true, radial forces in top sphere of the capsule will point to the center of sphere.
F32 | height
'height' : The height of the capsule volume of the vortex.
F32 | bottomRadius
'bottomRadius' : The radius of the bottom sphere of the capsule.
F32 | topRadius
'topRadius' : The radius of the top sphere of the capsule.
F32 | rotationalStrength
'rotationalStrength' : Coefficient that sets strength of the rotational part of force.
F32 | radialStrength
'radialStrength' : Coefficient that sets strength of the radial part of force.
F32 | liftStrength
'liftStrength' : Coefficient that sets strength of the lifting part of force.
F32 | fieldDragCoeff
'fieldDragCoeff' : Field drag coefficient. When it equals to 0, then the field is applied as a direct velocity.
F32 | fieldWeight
'fieldWeight' : A weight for the field, it controls how strongly the field affects particles
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for AttractorFS vs Field Boundaries interaction.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for AttractorFS vs other Field Samplers interaction.

Detailed Description

Describes the NxParameterized::Interface for 'VortexFSAssetParams' : Contains the asset properties for this Vortex Field Sampler.

VortexFSAssetParams contains 14 fully qualified names
---------------------------------------------
  1 : F32     boundaryFadePercentage
  2 : Vec3    axis
  3 : Bool    bottomSphericalForce
  4 : Bool    topSphericalForce
  5 : F32     height
  6 : F32     bottomRadius
  7 : F32     topRadius
  8 : F32     rotationalStrength
  9 : F32     radialStrength
 10 : F32     liftStrength
 11 : F32     fieldDragCoeff
 12 : F32     fieldWeight
 13 : String  fieldBoundaryFilterDataName
 14 : String  fieldSamplerFilterDataName

Member Data Documentation

Vec3 VortexFSAssetParams::axis

'axis' : The primary axis of the vortex around which the particles will rotate.

F32 VortexFSAssetParams::bottomRadius

'bottomRadius' : The radius of the bottom sphere of the capsule.

Bool VortexFSAssetParams::bottomSphericalForce

'bottomSphericalForce' : If this parameter true, radial forces in bottom sphere of the capsule will point to the center of sphere.

F32 VortexFSAssetParams::boundaryFadePercentage

'boundaryFadePercentage' : Percentage of distance from boundary to center where fade out starts.

String VortexFSAssetParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for AttractorFS vs Field Boundaries interaction.

F32 VortexFSAssetParams::fieldDragCoeff

'fieldDragCoeff' : Field drag coefficient. When it equals to 0, then the field is applied as a direct velocity.

String VortexFSAssetParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for AttractorFS vs other Field Samplers interaction.

F32 VortexFSAssetParams::fieldWeight

'fieldWeight' : A weight for the field, it controls how strongly the field affects particles

F32 VortexFSAssetParams::height

'height' : The height of the capsule volume of the vortex.

F32 VortexFSAssetParams::liftStrength

'liftStrength' : Coefficient that sets strength of the lifting part of force.

F32 VortexFSAssetParams::radialStrength

'radialStrength' : Coefficient that sets strength of the radial part of force.

F32 VortexFSAssetParams::rotationalStrength

'rotationalStrength' : Coefficient that sets strength of the rotational part of force.

F32 VortexFSAssetParams::topRadius

'topRadius' : The radius of the top sphere of the capsule.

Bool VortexFSAssetParams::topSphericalForce

'topSphericalForce' : If this parameter true, radial forces in top sphere of the capsule will point to the center of sphere.

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
VortexFSAssetParams Member List
This is the complete list of members for VortexFSAssetParams, including all inherited members.
axis | VortexFSAssetParams
bottomRadius | VortexFSAssetParams
bottomSphericalForce | VortexFSAssetParams
boundaryFadePercentage | VortexFSAssetParams
fieldBoundaryFilterDataName | VortexFSAssetParams
fieldDragCoeff | VortexFSAssetParams
fieldSamplerFilterDataName | VortexFSAssetParams
fieldWeight | VortexFSAssetParams
height | VortexFSAssetParams
liftStrength | VortexFSAssetParams
radialStrength | VortexFSAssetParams
rotationalStrength | VortexFSAssetParams
topRadius | VortexFSAssetParams
topSphericalForce | VortexFSAssetParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VortexFSPreviewParams Struct Reference

  • Class List
  • Class Members
Public Attributes
VortexFSPreviewParams Struct Reference

Describes the NxParameterized::Interface for 'VortexFSPreviewParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat44 | globalPose
'globalPose' : The pose that translates from turbulence preview coordinates to world coordinates
Bool | drawShape
'drawShape' : Draw the box
Bool | drawAssetInfo
'drawAssetInfo' : Display asset info
U64 | userData
'userData' : Optional user data pointer associated with the attractor actor

Detailed Description

Describes the NxParameterized::Interface for 'VortexFSPreviewParams' :

VortexFSPreviewParams contains 4 fully qualified names
---------------------------------------------
  1 : Mat44  globalPose
  2 : Bool   drawShape
  3 : Bool   drawAssetInfo
  4 : U64    userData

Member Data Documentation

Bool VortexFSPreviewParams::drawAssetInfo

'drawAssetInfo' : Display asset info

Bool VortexFSPreviewParams::drawShape

'drawShape' : Draw the box

Mat44 VortexFSPreviewParams::globalPose

'globalPose' : The pose that translates from turbulence preview coordinates to world coordinates

U64 VortexFSPreviewParams::userData

'userData' : Optional user data pointer associated with the attractor actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
VortexFSPreviewParams Member List
This is the complete list of members for VortexFSPreviewParams, including all inherited members.
drawAssetInfo | VortexFSPreviewParams
drawShape | VortexFSPreviewParams
globalPose | VortexFSPreviewParams
userData | VortexFSPreviewParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: WindFieldSamplerData Struct Reference

  • Class List
  • Class Members
Public Attributes
WindFieldSamplerData Struct Reference

Describes the NxParameterized::Interface for 'WindFieldSamplerData' : Contains the asset properties for this wind field sampler. More...

#include <params.h>

List of all members.

Public Attributes

String Name
'Name' : Wind FS Name
WindFSAssetParams WindFieldSampler
'WindFieldSampler' :

Detailed Description

Describes the NxParameterized::Interface for 'WindFieldSamplerData' : Contains the asset properties for this wind field sampler.

WindFieldSamplerData contains 11 fully qualified names
---------------------------------------------
  1 : String  Name
  2 : Vec3    WindFieldSampler.fieldDirection                    RefVariant[WindFSAssetParams]
  3 : F32     WindFieldSampler.fieldDirectionDeviationAngle      RefVariant[WindFSAssetParams]
  4 : F32     WindFieldSampler.fieldDirectionOscillationPeriod   RefVariant[WindFSAssetParams]
  5 : F32     WindFieldSampler.fieldStrength                     RefVariant[WindFSAssetParams]
  6 : F32     WindFieldSampler.fieldStrengthDeviationPercentage  RefVariant[WindFSAssetParams]
  7 : F32     WindFieldSampler.fieldStrengthOscillationPeriod    RefVariant[WindFSAssetParams]
  8 : F32     WindFieldSampler.fieldDragCoeff                    RefVariant[WindFSAssetParams]
  9 : F32     WindFieldSampler.fieldWeight                       RefVariant[WindFSAssetParams]
 10 : String  WindFieldSampler.fieldBoundaryFilterDataName       RefVariant[WindFSAssetParams]
 11 : String  WindFieldSampler.fieldSamplerFilterDataName        RefVariant[WindFSAssetParams]

Member Data Documentation

String WindFieldSamplerData::Name

'Name' : Wind FS Name

WindFSAssetParams WindFieldSamplerData::WindFieldSampler

'WindFieldSampler' :

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
WindFieldSamplerData Member List
This is the complete list of members for WindFieldSamplerData, including all inherited members.
Name | WindFieldSamplerData
WindFieldSampler | WindFieldSamplerData
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: WindFieldSamplerEffect Struct Reference

  • Class List
  • Class Members
Public Attributes
WindFieldSamplerEffect Struct Reference

Describes the NxParameterized::Interface for 'WindFieldSamplerEffect' : A wind field sampler effect. More...

#include <params.h>

List of all members.

Public Attributes

String | EffectProperties.UserString
'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer
Bool | EffectProperties.Enable
'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup
F32 | EffectProperties.Position.TranslateX
'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateY
'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Position.TranslateZ
'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction
F32 | EffectProperties.Orientation.RotateX
'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateY
'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)
F32 | EffectProperties.Orientation.RotateZ
'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)
F32 | EffectProperties.InitialDelayTime
'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect
F32 | EffectProperties.Duration
'EffectProperties.Duration' : The duration of the effect in secontds
U32 | EffectProperties.RepeatCount
'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever
F32 | EffectProperties.RepeatDelay
'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time
F32 | EffectProperties.RandomizeRepeatTime
'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.
PlaybackMode EffectProperties.Path.PlaybackMode
'EffectProperties.Path.PlaybackMode' : The mode to play back the path
F32 | EffectProperties.Path.PathDuration
'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided
U32 | EffectProperties.Path.LoopIndex
'EffectProperties.Path.LoopIndex' : The array index to loop back to
Transform | EffectProperties.Path.ControlPoints[]
'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to
F32 | EffectProperties.Path.Scale[].x
'EffectProperties.Path.Scale[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Scale[].y
'EffectProperties.Path.Scale[].y' : The y-axis value for this vector
F32 | EffectProperties.Path.Speed[].x
'EffectProperties.Path.Speed[].x' : The x-axis value for this vector
F32 | EffectProperties.Path.Speed[].y
'EffectProperties.Path.Speed[].y' : The y-axis value for this vector
Ref | WindFieldSampler
'WindFieldSampler' : Wind FS Asset

Detailed Description

Describes the NxParameterized::Interface for 'WindFieldSamplerEffect' : A wind field sampler effect.

WindFieldSamplerEffect contains 25 fully qualified names
---------------------------------------------
  1 : String         EffectProperties.UserString
  2 : Bool           EffectProperties.Enable
  3 : F32            EffectProperties.Position.TranslateX
  4 : F32            EffectProperties.Position.TranslateY
  5 : F32            EffectProperties.Position.TranslateZ
  6 : F32            EffectProperties.Orientation.RotateX
  7 : F32            EffectProperties.Orientation.RotateY
  8 : F32            EffectProperties.Orientation.RotateZ
  9 : F32            EffectProperties.InitialDelayTime
 10 : F32            EffectProperties.Duration
 11 : U32            EffectProperties.RepeatCount
 12 : F32            EffectProperties.RepeatDelay
 13 : F32            EffectProperties.RandomizeRepeatTime
 14 : PlaybackMode   EffectProperties.Path.PlaybackMode
 15 : F32            EffectProperties.Path.PathDuration
 16 : U32            EffectProperties.Path.LoopIndex
 17 : ArraySizeName  ControlPoints
 18 : Transform      EffectProperties.Path.ControlPoints[]
 19 : ArraySizeName  Scale
 20 : F32            EffectProperties.Path.Scale[].x
 21 : F32            EffectProperties.Path.Scale[].y
 22 : ArraySizeName  Speed
 23 : F32            EffectProperties.Path.Speed[].x
 24 : F32            EffectProperties.Path.Speed[].y
 25 : Ref            WindFieldSampler

Member Data Documentation

F32 WindFieldSamplerEffect::EffectProperties.Duration

'EffectProperties.Duration' : The duration of the effect in secontds

Bool WindFieldSamplerEffect::EffectProperties.Enable

'EffectProperties.Enable' : Whether or not this effect is to be initially enabled on startup

F32 WindFieldSamplerEffect::EffectProperties.InitialDelayTime

'EffectProperties.InitialDelayTime' : Initial time to delay before spawning this effect

F32 WindFieldSamplerEffect::EffectProperties.Orientation.RotateX

'EffectProperties.Orientation.RotateX' : Rotate on the X axis (0-360 degrees)

F32 WindFieldSamplerEffect::EffectProperties.Orientation.RotateY

'EffectProperties.Orientation.RotateY' : Rotate on the Y axis (0-360 degrees)

F32 WindFieldSamplerEffect::EffectProperties.Orientation.RotateZ

'EffectProperties.Orientation.RotateZ' : Rotate on the Z axis (0-360 degrees)

Transform WindFieldSamplerEffect::EffectProperties.Path.ControlPoints[]

'EffectProperties.Path.ControlPoints[]' : The array of control points to fit the curve to

U32 WindFieldSamplerEffect::EffectProperties.Path.LoopIndex

'EffectProperties.Path.LoopIndex' : The array index to loop back to

F32 WindFieldSamplerEffect::EffectProperties.Path.PathDuration

'EffectProperties.Path.PathDuration' : The duration of the path if one is not otherwise provided

PlaybackMode WindFieldSamplerEffect::EffectProperties.Path.PlaybackMode

'EffectProperties.Path.PlaybackMode' : The mode to play back the path

F32 WindFieldSamplerEffect::EffectProperties.Path.Scale[].x

'EffectProperties.Path.Scale[].x' : The x-axis value for this vector

F32 WindFieldSamplerEffect::EffectProperties.Path.Scale[].y

'EffectProperties.Path.Scale[].y' : The y-axis value for this vector

F32 WindFieldSamplerEffect::EffectProperties.Path.Speed[].x

'EffectProperties.Path.Speed[].x' : The x-axis value for this vector

F32 WindFieldSamplerEffect::EffectProperties.Path.Speed[].y

'EffectProperties.Path.Speed[].y' : The y-axis value for this vector

F32 WindFieldSamplerEffect::EffectProperties.Position.TranslateX

'EffectProperties.Position.TranslateX' : Nudge up to +/- one meter in each direction

F32 WindFieldSamplerEffect::EffectProperties.Position.TranslateY

'EffectProperties.Position.TranslateY' : Nudge up to +/- one meter in each direction

F32 WindFieldSamplerEffect::EffectProperties.Position.TranslateZ

'EffectProperties.Position.TranslateZ' : Nudge up to +/- one meter in each direction

F32 WindFieldSamplerEffect::EffectProperties.RandomizeRepeatTime

'EffectProperties.RandomizeRepeatTime' : Amount of randomization to the repeat cycle; a value of zero (default) means no random and a value of one means completely random.

U32 WindFieldSamplerEffect::EffectProperties.RepeatCount

'EffectProperties.RepeatCount' : The number of times to repeat the effect; 9999 means repeate forever

F32 WindFieldSamplerEffect::EffectProperties.RepeatDelay

'EffectProperties.RepeatDelay' : The time to delay activation each time the effect repeats in seconds; this can be different than the initial delay time

String WindFieldSamplerEffect::EffectProperties.UserString

'EffectProperties.UserString' : An aribtrary user string that can be set by an artist/designer/programmer

Ref WindFieldSamplerEffect::WindFieldSampler

'WindFieldSampler' : Wind FS Asset

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
WindFieldSamplerEffect Member List
This is the complete list of members for WindFieldSamplerEffect, including all inherited members.
EffectProperties.Duration | WindFieldSamplerEffect
EffectProperties.Enable | WindFieldSamplerEffect
EffectProperties.InitialDelayTime | WindFieldSamplerEffect
EffectProperties.Orientation.RotateX | WindFieldSamplerEffect
EffectProperties.Orientation.RotateY | WindFieldSamplerEffect
EffectProperties.Orientation.RotateZ | WindFieldSamplerEffect
EffectProperties.Path.ControlPoints[] | WindFieldSamplerEffect
EffectProperties.Path.LoopIndex | WindFieldSamplerEffect
EffectProperties.Path.PathDuration | WindFieldSamplerEffect
EffectProperties.Path.PlaybackMode | WindFieldSamplerEffect
EffectProperties.Path.Scale[].x | WindFieldSamplerEffect
EffectProperties.Path.Scale[].y | WindFieldSamplerEffect
EffectProperties.Path.Speed[].x | WindFieldSamplerEffect
EffectProperties.Path.Speed[].y | WindFieldSamplerEffect
EffectProperties.Position.TranslateX | WindFieldSamplerEffect
EffectProperties.Position.TranslateY | WindFieldSamplerEffect
EffectProperties.Position.TranslateZ | WindFieldSamplerEffect
EffectProperties.RandomizeRepeatTime | WindFieldSamplerEffect
EffectProperties.RepeatCount | WindFieldSamplerEffect
EffectProperties.RepeatDelay | WindFieldSamplerEffect
EffectProperties.UserString | WindFieldSamplerEffect
WindFieldSampler | WindFieldSamplerEffect
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: WindFSActorParams Struct Reference

  • Class List
  • Class Members
Public Attributes
WindFSActorParams Struct Reference

Describes the NxParameterized::Interface for 'WindFSActorParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat34 | initialPose
'initialPose' : The initial pose of the actor.
F32 | initialScale
'initialScale' : The initial space scale of the actor
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for WindFS vs Field Boundaries interaction. Overrides asset's value.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for WindFS vs other Field Samplers interaction. Overrides asset's value.

Detailed Description

Describes the NxParameterized::Interface for 'WindFSActorParams' :

WindFSActorParams contains 4 fully qualified names
---------------------------------------------
  1 : Mat34   initialPose
  2 : F32     initialScale
  3 : String  fieldBoundaryFilterDataName
  4 : String  fieldSamplerFilterDataName

Member Data Documentation

String WindFSActorParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for WindFS vs Field Boundaries interaction. Overrides asset's value.

String WindFSActorParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for WindFS vs other Field Samplers interaction. Overrides asset's value.

Mat34 WindFSActorParams::initialPose

'initialPose' : The initial pose of the actor.

The initial pose of the actor. This includes both translation and rotation.

F32 WindFSActorParams::initialScale

'initialScale' : The initial space scale of the actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
WindFSActorParams Member List
This is the complete list of members for WindFSActorParams, including all inherited members.
fieldBoundaryFilterDataName | WindFSActorParams
fieldSamplerFilterDataName | WindFSActorParams
initialPose | WindFSActorParams
initialScale | WindFSActorParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: WindFSAssetParams Struct Reference

  • Class List
  • Class Members
Public Attributes
WindFSAssetParams Struct Reference

Describes the NxParameterized::Interface for 'WindFSAssetParams' : Contains the asset properties for this Wind Field Sampler. More...

#include <params.h>

List of all members.

Public Attributes

Vec3 | fieldDirection
'fieldDirection' : field direction.
F32 | fieldDirectionDeviationAngle
'fieldDirectionDeviationAngle' : field direction deviation angle (in degrees).
F32 | fieldDirectionOscillationPeriod
'fieldDirectionOscillationPeriod' : field direction oscillation period in seconds.
F32 | fieldStrength
'fieldStrength' : field strength.
F32 | fieldStrengthDeviationPercentage
'fieldStrengthDeviationPercentage' : +/- field strength deviation percentage.
F32 | fieldStrengthOscillationPeriod
'fieldStrengthOscillationPeriod' : field strength oscillation period in seconds.
F32 | fieldDragCoeff
'fieldDragCoeff' : Field drag coefficient. When it equals to 0, then the field is applied as a direct velocity.
F32 | fieldWeight
'fieldWeight' : A weight for the field, it controls how strongly the field affects particles
String | fieldBoundaryFilterDataName
'fieldBoundaryFilterDataName' : The filter data name for WindFS vs Field Boundaries interaction.
String | fieldSamplerFilterDataName
'fieldSamplerFilterDataName' : The filter data name for WindFS vs other Field Samplers interaction.

Detailed Description

Describes the NxParameterized::Interface for 'WindFSAssetParams' : Contains the asset properties for this Wind Field Sampler.

WindFSAssetParams contains 10 fully qualified names
---------------------------------------------
  1 : Vec3    fieldDirection
  2 : F32     fieldDirectionDeviationAngle
  3 : F32     fieldDirectionOscillationPeriod
  4 : F32     fieldStrength
  5 : F32     fieldStrengthDeviationPercentage
  6 : F32     fieldStrengthOscillationPeriod
  7 : F32     fieldDragCoeff
  8 : F32     fieldWeight
  9 : String  fieldBoundaryFilterDataName
 10 : String  fieldSamplerFilterDataName

Member Data Documentation

String WindFSAssetParams::fieldBoundaryFilterDataName

'fieldBoundaryFilterDataName' : The filter data name for WindFS vs Field Boundaries interaction.

Vec3 WindFSAssetParams::fieldDirection

'fieldDirection' : field direction.

F32 WindFSAssetParams::fieldDirectionDeviationAngle

'fieldDirectionDeviationAngle' : field direction deviation angle (in degrees).

The fieldDirectionDeviationAngle parameter controls the deviation in angle of the field direction.

F32 WindFSAssetParams::fieldDirectionOscillationPeriod

'fieldDirectionOscillationPeriod' : field direction oscillation period in seconds.

The fieldDirectionOscillationPeriod defines the period of the field direction oscillation. If the fieldDirectionDeviationAngle is non-zero the period of each sinusoidal cycle will be this parameter in seconds.

F32 WindFSAssetParams::fieldDragCoeff

'fieldDragCoeff' : Field drag coefficient. When it equals to 0, then the field is applied as a direct velocity.

String WindFSAssetParams::fieldSamplerFilterDataName

'fieldSamplerFilterDataName' : The filter data name for WindFS vs other Field Samplers interaction.

F32 WindFSAssetParams::fieldStrength

'fieldStrength' : field strength.

F32 WindFSAssetParams::fieldStrengthDeviationPercentage

'fieldStrengthDeviationPercentage' : +/- field strength deviation percentage.

The fieldStrengthDeviationPercentage parameter controls the deviation in % of the field strength.

F32 WindFSAssetParams::fieldStrengthOscillationPeriod

'fieldStrengthOscillationPeriod' : field strength oscillation period in seconds.

The fieldStrengthOscillationPeriod defines the period of the field strength oscillation. If the fieldStrengthDeviationPercentage is non-zero the period of each sinusoidal cycle will be this parameter in seconds.

F32 WindFSAssetParams::fieldWeight

'fieldWeight' : A weight for the field, it controls how strongly the field affects particles

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
WindFSAssetParams Member List
This is the complete list of members for WindFSAssetParams, including all inherited members.
fieldBoundaryFilterDataName | WindFSAssetParams
fieldDirection | WindFSAssetParams
fieldDirectionDeviationAngle | WindFSAssetParams
fieldDirectionOscillationPeriod | WindFSAssetParams
fieldDragCoeff | WindFSAssetParams
fieldSamplerFilterDataName | WindFSAssetParams
fieldStrength | WindFSAssetParams
fieldStrengthDeviationPercentage | WindFSAssetParams
fieldStrengthOscillationPeriod | WindFSAssetParams
fieldWeight | WindFSAssetParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: WindFSPreviewParams Struct Reference

  • Class List
  • Class Members
Public Attributes
WindFSPreviewParams Struct Reference

Describes the NxParameterized::Interface for 'WindFSPreviewParams' : More...

#include <params.h>

List of all members.

Public Attributes

Mat44 | globalPose
'globalPose' : The pose that translates from preview coordinates to world coordinates
Bool | drawAssetInfo
'drawAssetInfo' : Display asset info
U64 | userData
'userData' : Optional user data pointer associated with the actor

Detailed Description

Describes the NxParameterized::Interface for 'WindFSPreviewParams' :

WindFSPreviewParams contains 3 fully qualified names
---------------------------------------------
  1 : Mat44  globalPose
  2 : Bool   drawAssetInfo
  3 : U64    userData

Member Data Documentation

Bool WindFSPreviewParams::drawAssetInfo

'drawAssetInfo' : Display asset info

Mat44 WindFSPreviewParams::globalPose

'globalPose' : The pose that translates from preview coordinates to world coordinates

U64 WindFSPreviewParams::userData

'userData' : Optional user data pointer associated with the actor

The documentation for this struct was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
WindFSPreviewParams Member List
This is the complete list of members for WindFSPreviewParams, including all inherited members.
drawAssetInfo | WindFSPreviewParams
globalPose | WindFSPreviewParams
userData | WindFSPreviewParams
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: ApexEmitterAssetParameters::GeometryType Union Reference

  • Class List
  • Class Members
  • ApexEmitterAssetParameters
  • GeometryType
Public Attributes
ApexEmitterAssetParameters::GeometryType Union Reference

#include <params.h>

List of all members.

Public Attributes

EmitterGeomBoxParams geometryType
'geometryType' :
EmitterGeomSphereParams geometryType
'geometryType' :
EmitterGeomSphereShellParams geometryType
'geometryType' :
EmitterGeomCylinderParams geometryType
'geometryType' :
EmitterGeomExplicitParams geometryType
'geometryType' :

Member Data Documentation

EmitterGeomBoxParams ApexEmitterAssetParameters::GeometryType::geometryType

'geometryType' :

EmitterGeomExplicitParams ApexEmitterAssetParameters::GeometryType::geometryType

'geometryType' :

EmitterGeomCylinderParams ApexEmitterAssetParameters::GeometryType::geometryType

'geometryType' :

EmitterGeomSphereShellParams ApexEmitterAssetParameters::GeometryType::geometryType

'geometryType' :

EmitterGeomSphereParams ApexEmitterAssetParameters::GeometryType::geometryType

'geometryType' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • ApexEmitterAssetParameters
  • GeometryType
ApexEmitterAssetParameters::GeometryType Member List
This is the complete list of members for ApexEmitterAssetParameters::GeometryType, including all inherited members.
geometryType | ApexEmitterAssetParameters::GeometryType
geometryType | ApexEmitterAssetParameters::GeometryType
geometryType | ApexEmitterAssetParameters::GeometryType
geometryType | ApexEmitterAssetParameters::GeometryType
geometryType | ApexEmitterAssetParameters::GeometryType
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ClothingAssetParameters::CookedData Union Reference

  • Class List
  • Class Members
  • ClothingAssetParameters
  • CookedData
Public Attributes
ClothingAssetParameters::CookedData Union Reference

#include <params.h>

List of all members.

Public Attributes

ClothingCookedParam cookedData
'cookedData' :
ClothingCookedPhysX3Param cookedData
'cookedData' :

Member Data Documentation

ClothingCookedParam ClothingAssetParameters::CookedData::cookedData

'cookedData' :

ClothingCookedPhysX3Param ClothingAssetParameters::CookedData::cookedData

'cookedData' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • ClothingAssetParameters
  • CookedData
ClothingAssetParameters::CookedData Member List
This is the complete list of members for ClothingAssetParameters::CookedData, including all inherited members.
cookedData | ClothingAssetParameters::CookedData
cookedData | ClothingAssetParameters::CookedData
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: DebugRenderParams::ModuleName Union Reference

  • Class List
  • Class Members
  • DebugRenderParams
  • ModuleName
Public Attributes
DebugRenderParams::ModuleName Union Reference

#include <params.h>

List of all members.

Public Attributes

BasicFSDebugRenderParams moduleName[]
'moduleName[]' :
BasicIosDebugRenderParams moduleName[]
'moduleName[]' :
ParticleIosDebugRenderParams moduleName[]
'moduleName[]' :
ClothingDebugRenderParams moduleName[]
'moduleName[]' :
DestructibleDebugRenderParams moduleName[]
'moduleName[]' :
EmitterDebugRenderParams moduleName[]
'moduleName[]' :
ForceFieldDebugRenderParams moduleName[]
'moduleName[]' :
IofxDebugRenderParams moduleName[]
'moduleName[]' :
TurbulenceFSDebugRenderParams moduleName[]
'moduleName[]' :
ParticlesDebugRenderParams moduleName[]
'moduleName[]' :

Member Data Documentation

BasicFSDebugRenderParams DebugRenderParams::ModuleName::moduleName[]

'moduleName[]' :

ParticlesDebugRenderParams DebugRenderParams::ModuleName::moduleName[]

'moduleName[]' :

TurbulenceFSDebugRenderParams DebugRenderParams::ModuleName::moduleName[]

'moduleName[]' :

IofxDebugRenderParams DebugRenderParams::ModuleName::moduleName[]

'moduleName[]' :

ForceFieldDebugRenderParams DebugRenderParams::ModuleName::moduleName[]

'moduleName[]' :

EmitterDebugRenderParams DebugRenderParams::ModuleName::moduleName[]

'moduleName[]' :

DestructibleDebugRenderParams DebugRenderParams::ModuleName::moduleName[]

'moduleName[]' :

ClothingDebugRenderParams DebugRenderParams::ModuleName::moduleName[]

'moduleName[]' :

ParticleIosDebugRenderParams DebugRenderParams::ModuleName::moduleName[]

'moduleName[]' :

BasicIosDebugRenderParams DebugRenderParams::ModuleName::moduleName[]

'moduleName[]' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • DebugRenderParams
  • ModuleName
DebugRenderParams::ModuleName Member List
This is the complete list of members for DebugRenderParams::ModuleName, including all inherited members.
moduleName[] | DebugRenderParams::ModuleName
moduleName[] | DebugRenderParams::ModuleName
moduleName[] | DebugRenderParams::ModuleName
moduleName[] | DebugRenderParams::ModuleName
moduleName[] | DebugRenderParams::ModuleName
moduleName[] | DebugRenderParams::ModuleName
moduleName[] | DebugRenderParams::ModuleName
moduleName[] | DebugRenderParams::ModuleName
moduleName[] | DebugRenderParams::ModuleName
moduleName[] | DebugRenderParams::ModuleName
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EffectPackageAssetParams::Effects Union Reference

  • Class List
  • Class Members
  • EffectPackageAssetParams
  • Effects
Public Attributes
EffectPackageAssetParams::Effects Union Reference

#include <params.h>

List of all members.

Public Attributes

EmitterEffect Effects[]
'Effects[]' :
HeatSourceEffect Effects[]
'Effects[]' :
JetFieldSamplerEffect Effects[]
'Effects[]' :
AttractorFieldSamplerEffect Effects[]
'Effects[]' :
TurbulenceFieldSamplerEffect Effects[]
'Effects[]' :
ForceFieldEffect Effects[]
'Effects[]' :
NoiseFieldSamplerEffect Effects[]
'Effects[]' :
VortexFieldSamplerEffect Effects[]
'Effects[]' :
SubstanceSourceEffect Effects[]
'Effects[]' :
WindFieldSamplerEffect Effects[]
'Effects[]' :
RigidBodyEffect Effects[]
'Effects[]' :
VelocitySourceEffect Effects[]
'Effects[]' :

Member Data Documentation

EmitterEffect EffectPackageAssetParams::Effects::Effects[]

'Effects[]' :

VelocitySourceEffect EffectPackageAssetParams::Effects::Effects[]

'Effects[]' :

RigidBodyEffect EffectPackageAssetParams::Effects::Effects[]

'Effects[]' :

WindFieldSamplerEffect EffectPackageAssetParams::Effects::Effects[]

'Effects[]' :

SubstanceSourceEffect EffectPackageAssetParams::Effects::Effects[]

'Effects[]' :

VortexFieldSamplerEffect EffectPackageAssetParams::Effects::Effects[]

'Effects[]' :

NoiseFieldSamplerEffect EffectPackageAssetParams::Effects::Effects[]

'Effects[]' :

ForceFieldEffect EffectPackageAssetParams::Effects::Effects[]

'Effects[]' :

TurbulenceFieldSamplerEffect EffectPackageAssetParams::Effects::Effects[]

'Effects[]' :

AttractorFieldSamplerEffect EffectPackageAssetParams::Effects::Effects[]

'Effects[]' :

JetFieldSamplerEffect EffectPackageAssetParams::Effects::Effects[]

'Effects[]' :

HeatSourceEffect EffectPackageAssetParams::Effects::Effects[]

'Effects[]' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • EffectPackageAssetParams
  • Effects
EffectPackageAssetParams::Effects Member List
This is the complete list of members for EffectPackageAssetParams::Effects, including all inherited members.
Effects[] | EffectPackageAssetParams::Effects
Effects[] | EffectPackageAssetParams::Effects
Effects[] | EffectPackageAssetParams::Effects
Effects[] | EffectPackageAssetParams::Effects
Effects[] | EffectPackageAssetParams::Effects
Effects[] | EffectPackageAssetParams::Effects
Effects[] | EffectPackageAssetParams::Effects
Effects[] | EffectPackageAssetParams::Effects
Effects[] | EffectPackageAssetParams::Effects
Effects[] | EffectPackageAssetParams::Effects
Effects[] | EffectPackageAssetParams::Effects
Effects[] | EffectPackageAssetParams::Effects
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EffectPackageFieldSamplerDatabaseParams::FieldSamplers Union Reference

  • Class List
  • Class Members
  • EffectPackageFieldSamplerDatabaseParams
  • FieldSamplers
Public Attributes
EffectPackageFieldSamplerDatabaseParams::FieldSamplers Union Reference

#include <params.h>

List of all members.

Public Attributes

AttractorFieldSamplerData FieldSamplers[]
'FieldSamplers[]' :
ForceFieldData FieldSamplers[]
'FieldSamplers[]' :
HeatSourceData FieldSamplers[]
'FieldSamplers[]' :
JetFieldSamplerData FieldSamplers[]
'FieldSamplers[]' :
TurbulenceFieldSamplerData FieldSamplers[]
'FieldSamplers[]' :
VortexFieldSamplerData FieldSamplers[]
'FieldSamplers[]' :
NoiseFieldSamplerData FieldSamplers[]
'FieldSamplers[]' :
SubstanceSourceData FieldSamplers[]
'FieldSamplers[]' :
WindFieldSamplerData FieldSamplers[]
'FieldSamplers[]' :
VelocitySourceData FieldSamplers[]
'FieldSamplers[]' :

Member Data Documentation

AttractorFieldSamplerData EffectPackageFieldSamplerDatabaseParams::FieldSamplers::FieldSamplers[]

'FieldSamplers[]' :

VelocitySourceData EffectPackageFieldSamplerDatabaseParams::FieldSamplers::FieldSamplers[]

'FieldSamplers[]' :

WindFieldSamplerData EffectPackageFieldSamplerDatabaseParams::FieldSamplers::FieldSamplers[]

'FieldSamplers[]' :

SubstanceSourceData EffectPackageFieldSamplerDatabaseParams::FieldSamplers::FieldSamplers[]

'FieldSamplers[]' :

NoiseFieldSamplerData EffectPackageFieldSamplerDatabaseParams::FieldSamplers::FieldSamplers[]

'FieldSamplers[]' :

VortexFieldSamplerData EffectPackageFieldSamplerDatabaseParams::FieldSamplers::FieldSamplers[]

'FieldSamplers[]' :

TurbulenceFieldSamplerData EffectPackageFieldSamplerDatabaseParams::FieldSamplers::FieldSamplers[]

'FieldSamplers[]' :

JetFieldSamplerData EffectPackageFieldSamplerDatabaseParams::FieldSamplers::FieldSamplers[]

'FieldSamplers[]' :

HeatSourceData EffectPackageFieldSamplerDatabaseParams::FieldSamplers::FieldSamplers[]

'FieldSamplers[]' :

ForceFieldData EffectPackageFieldSamplerDatabaseParams::FieldSamplers::FieldSamplers[]

'FieldSamplers[]' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • EffectPackageFieldSamplerDatabaseParams
  • FieldSamplers
EffectPackageFieldSamplerDatabaseParams::FieldSamplers Member List
This is the complete list of members for EffectPackageFieldSamplerDatabaseParams::FieldSamplers, including all inherited members.
FieldSamplers[] | EffectPackageFieldSamplerDatabaseParams::FieldSamplers
FieldSamplers[] | EffectPackageFieldSamplerDatabaseParams::FieldSamplers
FieldSamplers[] | EffectPackageFieldSamplerDatabaseParams::FieldSamplers
FieldSamplers[] | EffectPackageFieldSamplerDatabaseParams::FieldSamplers
FieldSamplers[] | EffectPackageFieldSamplerDatabaseParams::FieldSamplers
FieldSamplers[] | EffectPackageFieldSamplerDatabaseParams::FieldSamplers
FieldSamplers[] | EffectPackageFieldSamplerDatabaseParams::FieldSamplers
FieldSamplers[] | EffectPackageFieldSamplerDatabaseParams::FieldSamplers
FieldSamplers[] | EffectPackageFieldSamplerDatabaseParams::FieldSamplers
FieldSamplers[] | EffectPackageFieldSamplerDatabaseParams::FieldSamplers
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: EffectPackageGraphicsMaterialsParams::GraphicsMaterials Union Reference

  • Class List
  • Class Members
  • EffectPackageGraphicsMaterialsParams
  • GraphicsMaterials
Public Attributes
EffectPackageGraphicsMaterialsParams::GraphicsMaterials Union Reference

#include <params.h>

List of all members.

Public Attributes

GraphicsMaterialData GraphicsMaterials[]
'GraphicsMaterials[]' :
VolumeRenderMaterialData GraphicsMaterials[]
'GraphicsMaterials[]' :

Member Data Documentation

GraphicsMaterialData EffectPackageGraphicsMaterialsParams::GraphicsMaterials::GraphicsMaterials[]

'GraphicsMaterials[]' :

VolumeRenderMaterialData EffectPackageGraphicsMaterialsParams::GraphicsMaterials::GraphicsMaterials[]

'GraphicsMaterials[]' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • EffectPackageGraphicsMaterialsParams
  • GraphicsMaterials
EffectPackageGraphicsMaterialsParams::GraphicsMaterials Member List
This is the complete list of members for EffectPackageGraphicsMaterialsParams::GraphicsMaterials, including all inherited members.
GraphicsMaterials[] | EffectPackageGraphicsMaterialsParams::GraphicsMaterials
GraphicsMaterials[] | EffectPackageGraphicsMaterialsParams::GraphicsMaterials
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ForceFieldAssetParams::ForceFieldKernelType Union Reference

  • Class List
  • Class Members
  • ForceFieldAssetParams
  • ForceFieldKernelType
Public Attributes
ForceFieldAssetParams::ForceFieldKernelType Union Reference

#include <params.h>

List of all members.

Public Attributes

GenericForceFieldKernelParams forceFieldKernelType
'forceFieldKernelType' :
RadialForceFieldKernelParams forceFieldKernelType
'forceFieldKernelType' :

Member Data Documentation

GenericForceFieldKernelParams ForceFieldAssetParams::ForceFieldKernelType::forceFieldKernelType

'forceFieldKernelType' :

RadialForceFieldKernelParams ForceFieldAssetParams::ForceFieldKernelType::forceFieldKernelType

'forceFieldKernelType' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • ForceFieldAssetParams
  • ForceFieldKernelType
ForceFieldAssetParams::ForceFieldKernelType Member List
This is the complete list of members for ForceFieldAssetParams::ForceFieldKernelType, including all inherited members.
forceFieldKernelType | ForceFieldAssetParams::ForceFieldKernelType
forceFieldKernelType | ForceFieldAssetParams::ForceFieldKernelType
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: HeatSourceActorParams::GeometryType Union Reference

  • Class List
  • Class Members
  • HeatSourceActorParams
  • GeometryType
Public Attributes
HeatSourceActorParams::GeometryType Union Reference

#include <params.h>

List of all members.

Public Attributes

HeatSourceGeomBoxParams geometryType
'geometryType' :
HeatSourceGeomSphereParams geometryType
'geometryType' :

Member Data Documentation

HeatSourceGeomBoxParams HeatSourceActorParams::GeometryType::geometryType

'geometryType' :

HeatSourceGeomSphereParams HeatSourceActorParams::GeometryType::geometryType

'geometryType' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • HeatSourceActorParams
  • GeometryType
HeatSourceActorParams::GeometryType Member List
This is the complete list of members for HeatSourceActorParams::GeometryType, including all inherited members.
geometryType | HeatSourceActorParams::GeometryType
geometryType | HeatSourceActorParams::GeometryType
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: HeatSourceAssetParams::GeometryType Union Reference

  • Class List
  • Class Members
  • HeatSourceAssetParams
  • GeometryType
Public Attributes
HeatSourceAssetParams::GeometryType Union Reference

#include <params.h>

List of all members.

Public Attributes

HeatSourceGeomBoxParams geometryType
'geometryType' :
HeatSourceGeomSphereParams geometryType
'geometryType' :

Member Data Documentation

HeatSourceGeomBoxParams HeatSourceAssetParams::GeometryType::geometryType

'geometryType' :

HeatSourceGeomSphereParams HeatSourceAssetParams::GeometryType::geometryType

'geometryType' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • HeatSourceAssetParams
  • GeometryType
HeatSourceAssetParams::GeometryType Member List
This is the complete list of members for HeatSourceAssetParams::GeometryType, including all inherited members.
geometryType | HeatSourceAssetParams::GeometryType
geometryType | HeatSourceAssetParams::GeometryType
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ImpactEmitterAssetParameters::EventSetList Union Reference

  • Class List
  • Class Members
  • ImpactEmitterAssetParameters
  • EventSetList
Public Attributes
ImpactEmitterAssetParameters::EventSetList Union Reference

#include <params.h>

List of all members.

Public Attributes

ImpactObjectEvent eventSetList[]
'eventSetList[]' :
ImpactExplosionEvent eventSetList[]
'eventSetList[]' :

Member Data Documentation

ImpactObjectEvent ImpactEmitterAssetParameters::EventSetList::eventSetList[]

'eventSetList[]' :

ImpactExplosionEvent ImpactEmitterAssetParameters::EventSetList::eventSetList[]

'eventSetList[]' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • ImpactEmitterAssetParameters
  • EventSetList
ImpactEmitterAssetParameters::EventSetList Member List
This is the complete list of members for ImpactEmitterAssetParameters::EventSetList, including all inherited members.
eventSetList[] | ImpactEmitterAssetParameters::EventSetList
eventSetList[] | ImpactEmitterAssetParameters::EventSetList
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: IofxAssetParameters::IofxType Union Reference

  • Class List
  • Class Members
  • IofxAssetParameters
  • IofxType
Public Attributes
IofxAssetParameters::IofxType Union Reference

#include <params.h>

List of all members.

Public Attributes

MeshIofxParameters iofxType
'iofxType' :
SpriteIofxParameters iofxType
'iofxType' :

Member Data Documentation

MeshIofxParameters IofxAssetParameters::IofxType::iofxType

'iofxType' :

SpriteIofxParameters IofxAssetParameters::IofxType::iofxType

'iofxType' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • IofxAssetParameters
  • IofxType
IofxAssetParameters::IofxType Member List
This is the complete list of members for IofxAssetParameters::IofxType, including all inherited members.
iofxType | IofxAssetParameters::IofxType
iofxType | IofxAssetParameters::IofxType
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: MeshIofxParameters::ContinuousModifierList Union Reference

  • Class List
  • Class Members
  • MeshIofxParameters
  • ContinuousModifierList
Public Attributes
MeshIofxParameters::ContinuousModifierList Union Reference

#include <params.h>

List of all members.

Public Attributes

RotationModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsLife3DModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsDensity3DModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsTemperature3DModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsCameraDistance3DModifierParams continuousModifierList[]
'continuousModifierList[]' :
OrientAlongVelocityModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleAlongVelocityModifierParams continuousModifierList[]
'continuousModifierList[]' :
ColorVsLifeCompositeModifierParams continuousModifierList[]
'continuousModifierList[]' :
ColorVsDensityCompositeModifierParams continuousModifierList[]
'continuousModifierList[]' :
ColorVsTemperatureCompositeModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsLifeModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsDensityModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsTemperatureModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsCameraDistanceModifierParams continuousModifierList[]
'continuousModifierList[]' :
ColorVsVelocityCompositeModifierParams continuousModifierList[]
'continuousModifierList[]' :

Member Data Documentation

RotationModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ColorVsVelocityCompositeModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsCameraDistanceModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsTemperatureModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsDensityModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsLifeModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ColorVsTemperatureCompositeModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ColorVsDensityCompositeModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ColorVsLifeCompositeModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleAlongVelocityModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

OrientAlongVelocityModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsCameraDistance3DModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsTemperature3DModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsDensity3DModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsLife3DModifierParams MeshIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • MeshIofxParameters
  • ContinuousModifierList
MeshIofxParameters::ContinuousModifierList Member List
This is the complete list of members for MeshIofxParameters::ContinuousModifierList, including all inherited members.
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
continuousModifierList[] | MeshIofxParameters::ContinuousModifierList
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: MeshIofxParameters::SpawnModifierList Union Reference

  • Class List
  • Class Members
  • MeshIofxParameters
  • SpawnModifierList
Public Attributes
MeshIofxParameters::SpawnModifierList Union Reference

#include <params.h>

List of all members.

Public Attributes

RotationModifierParams spawnModifierList[]
'spawnModifierList[]' :
SimpleScaleModifierParams spawnModifierList[]
'spawnModifierList[]' :
RandomScaleModifierParams spawnModifierList[]
'spawnModifierList[]' :
InitialColorModifierParams spawnModifierList[]
'spawnModifierList[]' :
ScaleByMassModifierParams spawnModifierList[]
'spawnModifierList[]' :

Member Data Documentation

RotationModifierParams MeshIofxParameters::SpawnModifierList::spawnModifierList[]

'spawnModifierList[]' :

ScaleByMassModifierParams MeshIofxParameters::SpawnModifierList::spawnModifierList[]

'spawnModifierList[]' :

InitialColorModifierParams MeshIofxParameters::SpawnModifierList::spawnModifierList[]

'spawnModifierList[]' :

RandomScaleModifierParams MeshIofxParameters::SpawnModifierList::spawnModifierList[]

'spawnModifierList[]' :

SimpleScaleModifierParams MeshIofxParameters::SpawnModifierList::spawnModifierList[]

'spawnModifierList[]' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • MeshIofxParameters
  • SpawnModifierList
MeshIofxParameters::SpawnModifierList Member List
This is the complete list of members for MeshIofxParameters::SpawnModifierList, including all inherited members.
spawnModifierList[] | MeshIofxParameters::SpawnModifierList
spawnModifierList[] | MeshIofxParameters::SpawnModifierList
spawnModifierList[] | MeshIofxParameters::SpawnModifierList
spawnModifierList[] | MeshIofxParameters::SpawnModifierList
spawnModifierList[] | MeshIofxParameters::SpawnModifierList
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ParticleIosAssetParam::ParticleType Union Reference

  • Class List
  • Class Members
  • ParticleIosAssetParam
  • ParticleType
Public Attributes
ParticleIosAssetParam::ParticleType Union Reference

#include <params.h>

List of all members.

Public Attributes

SimpleParticleSystemParams particleType
'particleType' :
FluidParticleSystemParams particleType
'particleType' :

Member Data Documentation

SimpleParticleSystemParams ParticleIosAssetParam::ParticleType::particleType

'particleType' :

FluidParticleSystemParams ParticleIosAssetParam::ParticleType::particleType

'particleType' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • ParticleIosAssetParam
  • ParticleType
ParticleIosAssetParam::ParticleType Member List
This is the complete list of members for ParticleIosAssetParam::ParticleType, including all inherited members.
particleType | ParticleIosAssetParam::ParticleType
particleType | ParticleIosAssetParam::ParticleType
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: ParticleSimulationData::IOS Union Reference

  • Class List
  • Class Members
  • ParticleSimulationData
  • IOS
Public Attributes
ParticleSimulationData::IOS Union Reference

#include <params.h>

List of all members.

Public Attributes

BasicIOSAssetParam IOS
'IOS' :
ParticleIosAssetParam IOS
'IOS' :

Member Data Documentation

BasicIOSAssetParam ParticleSimulationData::IOS::IOS

'IOS' :

ParticleIosAssetParam ParticleSimulationData::IOS::IOS

'IOS' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • ParticleSimulationData
  • IOS
ParticleSimulationData::IOS Member List
This is the complete list of members for ParticleSimulationData::IOS, including all inherited members.
IOS | ParticleSimulationData::IOS
IOS | ParticleSimulationData::IOS
Generated on Sat Dec 1 2018 10:18:55


APEX NvParameterized Schemas: SpriteIofxParameters::ContinuousModifierList Union Reference

  • Class List
  • Class Members
  • SpriteIofxParameters
  • ContinuousModifierList
Public Attributes
SpriteIofxParameters::ContinuousModifierList Union Reference

#include <params.h>

List of all members.

Public Attributes

ColorVsLifeCompositeModifierParams continuousModifierList[]
'continuousModifierList[]' :
ColorVsDensityCompositeModifierParams continuousModifierList[]
'continuousModifierList[]' :
ColorVsTemperatureCompositeModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsLife2DModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsDensity2DModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsTemperature2DModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsCameraDistance2DModifierParams continuousModifierList[]
'continuousModifierList[]' :
SubtextureVsLifeModifierParams continuousModifierList[]
'continuousModifierList[]' :
ViewDirectionSortingModifierParams continuousModifierList[]
'continuousModifierList[]' :
ColorVsLifeModifierParams continuousModifierList[]
'continuousModifierList[]' :
ColorVsDensityModifierParams continuousModifierList[]
'continuousModifierList[]' :
ColorVsTemperatureModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsLifeModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsDensityModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsTemperatureModifierParams continuousModifierList[]
'continuousModifierList[]' :
ScaleVsCameraDistanceModifierParams continuousModifierList[]
'continuousModifierList[]' :
RotationRateModifierParams continuousModifierList[]
'continuousModifierList[]' :
RotationRateVsLifeModifierParams continuousModifierList[]
'continuousModifierList[]' :
OrientScaleAlongScreenVelocityModifierParams continuousModifierList[]
'continuousModifierList[]' :
ColorVsVelocityCompositeModifierParams continuousModifierList[]
'continuousModifierList[]' :

Member Data Documentation

ColorVsLifeCompositeModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ColorVsVelocityCompositeModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

OrientScaleAlongScreenVelocityModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

RotationRateVsLifeModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

RotationRateModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsCameraDistanceModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsTemperatureModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsDensityModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsLifeModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ColorVsTemperatureModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ColorVsDensityModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ColorVsLifeModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ViewDirectionSortingModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

SubtextureVsLifeModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsCameraDistance2DModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsTemperature2DModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsDensity2DModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ScaleVsLife2DModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ColorVsTemperatureCompositeModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

ColorVsDensityCompositeModifierParams SpriteIofxParameters::ContinuousModifierList::continuousModifierList[]

'continuousModifierList[]' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • SpriteIofxParameters
  • ContinuousModifierList
SpriteIofxParameters::ContinuousModifierList Member List
This is the complete list of members for SpriteIofxParameters::ContinuousModifierList, including all inherited members.
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
continuousModifierList[] | SpriteIofxParameters::ContinuousModifierList
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SpriteIofxParameters::SpawnModifierList Union Reference

  • Class List
  • Class Members
  • SpriteIofxParameters
  • SpawnModifierList
Public Attributes
SpriteIofxParameters::SpawnModifierList Union Reference

#include <params.h>

List of all members.

Public Attributes

SimpleScaleModifierParams spawnModifierList[]
'spawnModifierList[]' :
RandomScaleModifierParams spawnModifierList[]
'spawnModifierList[]' :
InitialColorModifierParams spawnModifierList[]
'spawnModifierList[]' :
RandomSubtextureModifierParams spawnModifierList[]
'spawnModifierList[]' :
RandomRotationModifierParams spawnModifierList[]
'spawnModifierList[]' :
ColorVsLifeModifierParams spawnModifierList[]
'spawnModifierList[]' :
ScaleByMassModifierParams spawnModifierList[]
'spawnModifierList[]' :

Member Data Documentation

SimpleScaleModifierParams SpriteIofxParameters::SpawnModifierList::spawnModifierList[]

'spawnModifierList[]' :

ScaleByMassModifierParams SpriteIofxParameters::SpawnModifierList::spawnModifierList[]

'spawnModifierList[]' :

ColorVsLifeModifierParams SpriteIofxParameters::SpawnModifierList::spawnModifierList[]

'spawnModifierList[]' :

RandomRotationModifierParams SpriteIofxParameters::SpawnModifierList::spawnModifierList[]

'spawnModifierList[]' :

RandomSubtextureModifierParams SpriteIofxParameters::SpawnModifierList::spawnModifierList[]

'spawnModifierList[]' :

InitialColorModifierParams SpriteIofxParameters::SpawnModifierList::spawnModifierList[]

'spawnModifierList[]' :

RandomScaleModifierParams SpriteIofxParameters::SpawnModifierList::spawnModifierList[]

'spawnModifierList[]' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • SpriteIofxParameters
  • SpawnModifierList
SpriteIofxParameters::SpawnModifierList Member List
This is the complete list of members for SpriteIofxParameters::SpawnModifierList, including all inherited members.
spawnModifierList[] | SpriteIofxParameters::SpawnModifierList
spawnModifierList[] | SpriteIofxParameters::SpawnModifierList
spawnModifierList[] | SpriteIofxParameters::SpawnModifierList
spawnModifierList[] | SpriteIofxParameters::SpawnModifierList
spawnModifierList[] | SpriteIofxParameters::SpawnModifierList
spawnModifierList[] | SpriteIofxParameters::SpawnModifierList
spawnModifierList[] | SpriteIofxParameters::SpawnModifierList
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SubstanceSourceActorParams::GeometryType Union Reference

  • Class List
  • Class Members
  • SubstanceSourceActorParams
  • GeometryType
Public Attributes
SubstanceSourceActorParams::GeometryType Union Reference

#include <params.h>

List of all members.

Public Attributes

HeatSourceGeomBoxParams geometryType
'geometryType' :
HeatSourceGeomSphereParams geometryType
'geometryType' :

Member Data Documentation

HeatSourceGeomBoxParams SubstanceSourceActorParams::GeometryType::geometryType

'geometryType' :

HeatSourceGeomSphereParams SubstanceSourceActorParams::GeometryType::geometryType

'geometryType' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • SubstanceSourceActorParams
  • GeometryType
SubstanceSourceActorParams::GeometryType Member List
This is the complete list of members for SubstanceSourceActorParams::GeometryType, including all inherited members.
geometryType | SubstanceSourceActorParams::GeometryType
geometryType | SubstanceSourceActorParams::GeometryType
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SubstanceSourceAssetParams::GeometryType Union Reference

  • Class List
  • Class Members
  • SubstanceSourceAssetParams
  • GeometryType
Public Attributes
SubstanceSourceAssetParams::GeometryType Union Reference

#include <params.h>

List of all members.

Public Attributes

HeatSourceGeomBoxParams geometryType
'geometryType' :
HeatSourceGeomSphereParams geometryType
'geometryType' :

Member Data Documentation

HeatSourceGeomBoxParams SubstanceSourceAssetParams::GeometryType::geometryType

'geometryType' :

HeatSourceGeomSphereParams SubstanceSourceAssetParams::GeometryType::geometryType

'geometryType' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • SubstanceSourceAssetParams
  • GeometryType
SubstanceSourceAssetParams::GeometryType Member List
This is the complete list of members for SubstanceSourceAssetParams::GeometryType, including all inherited members.
geometryType | SubstanceSourceAssetParams::GeometryType
geometryType | SubstanceSourceAssetParams::GeometryType
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: SurfaceBufferParameters::Buffer Union Reference

  • Class List
  • Class Members
  • SurfaceBufferParameters
  • Buffer
Public Attributes
SurfaceBufferParameters::Buffer Union Reference

#include <params.h>

List of all members.

Public Attributes

BufferU8x1 buffer
'buffer' :
BufferU8x2 buffer
'buffer' :
BufferU8x3 buffer
'buffer' :
BufferU8x4 buffer
'buffer' :
BufferU16x1 buffer
'buffer' :
BufferU16x2 buffer
'buffer' :
BufferU16x3 buffer
'buffer' :
BufferU16x4 buffer
'buffer' :
BufferU32x1 buffer
'buffer' :
BufferU32x2 buffer
'buffer' :
BufferU32x3 buffer
'buffer' :
BufferU32x4 buffer
'buffer' :
BufferF32x1 buffer
'buffer' :
BufferF32x2 buffer
'buffer' :
BufferF32x3 buffer
'buffer' :
BufferF32x4 buffer
'buffer' :

Member Data Documentation

BufferU8x1 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferF32x4 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferF32x3 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferF32x2 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferF32x1 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferU32x4 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferU32x3 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferU32x2 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferU32x1 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferU16x4 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferU16x3 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferU16x2 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferU16x1 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferU8x4 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferU8x3 SurfaceBufferParameters::Buffer::buffer

'buffer' :

BufferU8x2 SurfaceBufferParameters::Buffer::buffer

'buffer' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • SurfaceBufferParameters
  • Buffer
SurfaceBufferParameters::Buffer Member List
This is the complete list of members for SurfaceBufferParameters::Buffer, including all inherited members.
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
buffer | SurfaceBufferParameters::Buffer
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VelocitySourceActorParams::GeometryType Union Reference

  • Class List
  • Class Members
  • VelocitySourceActorParams
  • GeometryType
Public Attributes
VelocitySourceActorParams::GeometryType Union Reference

#include <params.h>

List of all members.

Public Attributes

HeatSourceGeomBoxParams geometryType
'geometryType' :
HeatSourceGeomSphereParams geometryType
'geometryType' :

Member Data Documentation

HeatSourceGeomBoxParams VelocitySourceActorParams::GeometryType::geometryType

'geometryType' :

HeatSourceGeomSphereParams VelocitySourceActorParams::GeometryType::geometryType

'geometryType' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • VelocitySourceActorParams
  • GeometryType
VelocitySourceActorParams::GeometryType Member List
This is the complete list of members for VelocitySourceActorParams::GeometryType, including all inherited members.
geometryType | VelocitySourceActorParams::GeometryType
geometryType | VelocitySourceActorParams::GeometryType
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VelocitySourceAssetParams::GeometryType Union Reference

  • Class List
  • Class Members
  • VelocitySourceAssetParams
  • GeometryType
Public Attributes
VelocitySourceAssetParams::GeometryType Union Reference

#include <params.h>

List of all members.

Public Attributes

HeatSourceGeomBoxParams geometryType
'geometryType' :
HeatSourceGeomSphereParams geometryType
'geometryType' :

Member Data Documentation

HeatSourceGeomBoxParams VelocitySourceAssetParams::GeometryType::geometryType

'geometryType' :

HeatSourceGeomSphereParams VelocitySourceAssetParams::GeometryType::geometryType

'geometryType' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • VelocitySourceAssetParams
  • GeometryType
VelocitySourceAssetParams::GeometryType Member List
This is the complete list of members for VelocitySourceAssetParams::GeometryType, including all inherited members.
geometryType | VelocitySourceAssetParams::GeometryType
geometryType | VelocitySourceAssetParams::GeometryType
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: VertexBufferParameters::Buffers Union Reference

  • Class List
  • Class Members
  • VertexBufferParameters
  • Buffers
Public Attributes
VertexBufferParameters::Buffers Union Reference

#include <params.h>

List of all members.

Public Attributes

BufferU8x1 buffers[]
'buffers[]' :
BufferU8x2 buffers[]
'buffers[]' :
BufferU8x3 buffers[]
'buffers[]' :
BufferU8x4 buffers[]
'buffers[]' :
BufferU16x1 buffers[]
'buffers[]' :
BufferU16x2 buffers[]
'buffers[]' :
BufferU16x3 buffers[]
'buffers[]' :
BufferU16x4 buffers[]
'buffers[]' :
BufferU32x1 buffers[]
'buffers[]' :
BufferU32x2 buffers[]
'buffers[]' :
BufferU32x3 buffers[]
'buffers[]' :
BufferU32x4 buffers[]
'buffers[]' :
BufferF32x1 buffers[]
'buffers[]' :
BufferF32x2 buffers[]
'buffers[]' :
BufferF32x3 buffers[]
'buffers[]' :
BufferF32x4 buffers[]
'buffers[]' :

Member Data Documentation

BufferU8x1 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferF32x4 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferF32x3 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferF32x2 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferF32x1 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferU32x4 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferU32x3 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferU32x2 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferU32x1 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferU16x4 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferU16x3 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferU16x2 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferU16x1 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferU8x4 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferU8x3 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

BufferU8x2 VertexBufferParameters::Buffers::buffers[]

'buffers[]' :

The documentation for this union was generated from the following file:
  • params.h
Generated on Sat Dec 1 2018 10:18:56


APEX NvParameterized Schemas: Member List

  • Class List
  • Class Members
  • VertexBufferParameters
  • Buffers
VertexBufferParameters::Buffers Member List
This is the complete list of members for VertexBufferParameters::Buffers, including all inherited members.
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
buffers[] | VertexBufferParameters::Buffers
Generated on Sat Dec 1 2018 10:18:56


APEX Particles IOS Module: Class List

  • Class List
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
nvidia::apex::ModuleParticleIos | ParticleIOS Module - Manages PhysX 3.0 PxParticleSystem and PxParticleFluid simulations
nvidia::apex::ParticleIosActor | ParticleIOS Actor. A simple actor that simulates a particle system
nvidia::apex::ParticleIosAsset | APEX Particle System Asset
nvidia::apex::ParticleIosAssetAuthoring | APEX Particle System Asset Authoring class
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: Class Index

  • Class List
  • Class Members
Class Index
M | P
M
P
ParticleIosActor (nvidia::apex) ParticleIosAsset (nvidia::apex) ParticleIosAssetAuthoring (nvidia::apex)
ModuleParticleIos (nvidia::apex)
M | P
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: nvidia::apex::ModuleParticleIos Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • ModuleParticleIos
Public Member Functions | Protected Member Functions
nvidia::apex::ModuleParticleIos Class Reference

ParticleIOS Module - Manages PhysX 3.0 PxParticleSystem and PxParticleFluid simulations. More...

#include <ModuleParticleIos.h>

List of all members.

Public Member Functions

virtual const char * | getParticleIosTypeName ()=0
Get ParticleIOS authoring type name.

Protected Member Functions

virtual | ~ModuleParticleIos ()

Detailed Description

ParticleIOS Module - Manages PhysX 3.0 PxParticleSystem and PxParticleFluid simulations.

Constructor & Destructor Documentation

virtual nvidia::apex::ModuleParticleIos::~ModuleParticleIos ( ) [inline, protected, virtual]

Member Function Documentation

virtual const char* nvidia::apex::ModuleParticleIos::getParticleIosTypeName ( ) [pure virtual]

Get ParticleIOS authoring type name.

The documentation for this class was generated from the following file:
  • ModuleParticleIos.h
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • ModuleParticleIos
nvidia::apex::ModuleParticleIos Member List
This is the complete list of members for nvidia::apex::ModuleParticleIos, including all inherited members.
getParticleIosTypeName()=0 | nvidia::apex::ModuleParticleIos | [pure virtual]
~ModuleParticleIos() | nvidia::apex::ModuleParticleIos | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: nvidia::apex::ParticleIosActor Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • ParticleIosActor
Protected Member Functions
nvidia::apex::ParticleIosActor Class Reference

ParticleIOS Actor. A simple actor that simulates a particle system. More...

#include <ParticleIosActor.h>

List of all members.

Protected Member Functions

virtual ~ParticleIosActor ()

Detailed Description

ParticleIOS Actor. A simple actor that simulates a particle system.

Constructor & Destructor Documentation

virtual nvidia::apex::ParticleIosActor::~ParticleIosActor ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • ParticleIosActor.h
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • ParticleIosActor
nvidia::apex::ParticleIosActor Member List
This is the complete list of members for nvidia::apex::ParticleIosActor, including all inherited members.
~ParticleIosActor() nvidia::apex::ParticleIosActor [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: nvidia::apex::ParticleIosAsset Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • ParticleIosAsset
Public Member Functions | Protected Member Functions
nvidia::apex::ParticleIosAsset Class Reference

APEX Particle System Asset. More...

#include <ParticleIosAsset.h>

List of all members.

Public Member Functions

virtual float | getParticleRadius () const =0
Get the radius of a particle.
virtual float | getMaxInjectedParticleCount () const =0
Get the maximum number of particles that are allowed to be newly created on each frame.
virtual uint32_t | getMaxParticleCount () const =0
Get the maximum number of particles that this IOS can simulate.
virtual float | getParticleMass () const =0
Get the mass of a particle.

Protected Member Functions

virtual | ~ParticleIosAsset ()

Detailed Description

APEX Particle System Asset.

Constructor & Destructor Documentation

virtual nvidia::apex::ParticleIosAsset::~ParticleIosAsset ( ) [inline, protected, virtual]

Member Function Documentation

virtual float nvidia::apex::ParticleIosAsset::getMaxInjectedParticleCount ( ) const [pure virtual]

Get the maximum number of particles that are allowed to be newly created on each frame.

virtual uint32_t nvidia::apex::ParticleIosAsset::getMaxParticleCount ( ) const [pure virtual]

Get the maximum number of particles that this IOS can simulate.

virtual float nvidia::apex::ParticleIosAsset::getParticleMass ( ) const [pure virtual]

Get the mass of a particle.

virtual float nvidia::apex::ParticleIosAsset::getParticleRadius ( ) const [pure virtual]

Get the radius of a particle.

The documentation for this class was generated from the following file:
  • ParticleIosAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • ParticleIosAsset
nvidia::apex::ParticleIosAsset Member List
This is the complete list of members for nvidia::apex::ParticleIosAsset, including all inherited members.
getMaxInjectedParticleCount() const =0 | nvidia::apex::ParticleIosAsset | [pure virtual]
getMaxParticleCount() const =0 | nvidia::apex::ParticleIosAsset | [pure virtual]
getParticleMass() const =0 | nvidia::apex::ParticleIosAsset | [pure virtual]
getParticleRadius() const =0 | nvidia::apex::ParticleIosAsset | [pure virtual]
~ParticleIosAsset() | nvidia::apex::ParticleIosAsset | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: nvidia::apex::ParticleIosAssetAuthoring Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • ParticleIosAssetAuthoring
Public Member Functions | Protected Member Functions
nvidia::apex::ParticleIosAssetAuthoring Class Reference

APEX Particle System Asset Authoring class. More...

#include <ParticleIosAsset.h>

List of all members.

Public Member Functions

virtual void | setParticleRadius (float)=0
Set the radius of a particle.
virtual void | setMaxInjectedParticleCount (float count)=0
Set the maximum number of particles that are allowed to be newly created on each frame.
virtual void | setMaxParticleCount (uint32_t count)=0
Set the maximum number of particles that this IOS can simulate.
virtual void | setParticleMass (float)=0
Set the mass of a particle.
virtual void | setCollisionGroupName (const char *collisionGroupName)=0
Set the (NRP) name for the collision group.
virtual void | setCollisionGroupMaskName (const char *collisionGroupMaskName)=0
Set the (NRP) name for the collision group mask.

Protected Member Functions

virtual | ~ParticleIosAssetAuthoring ()

Detailed Description

APEX Particle System Asset Authoring class.

Constructor & Destructor Documentation

virtual nvidia::apex::ParticleIosAssetAuthoring::~ParticleIosAssetAuthoring ( ) [inline, protected, virtual]

Member Function Documentation

virtual void nvidia::apex::ParticleIosAssetAuthoring::setCollisionGroupMaskName ( const char * collisionGroupMaskName ) [pure virtual]

Set the (NRP) name for the collision group mask.

virtual void nvidia::apex::ParticleIosAssetAuthoring::setCollisionGroupName ( const char * collisionGroupName ) [pure virtual]

Set the (NRP) name for the collision group.

virtual void nvidia::apex::ParticleIosAssetAuthoring::setMaxInjectedParticleCount ( float count ) [pure virtual]

Set the maximum number of particles that are allowed to be newly created on each frame.

virtual void nvidia::apex::ParticleIosAssetAuthoring::setMaxParticleCount ( uint32_t count ) [pure virtual]

Set the maximum number of particles that this IOS can simulate.

virtual void nvidia::apex::ParticleIosAssetAuthoring::setParticleMass ( float ) [pure virtual]

Set the mass of a particle.

virtual void nvidia::apex::ParticleIosAssetAuthoring::setParticleRadius ( float ) [pure virtual]

Set the radius of a particle.

The documentation for this class was generated from the following file:
  • ParticleIosAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • ParticleIosAssetAuthoring
nvidia::apex::ParticleIosAssetAuthoring Member List
This is the complete list of members for nvidia::apex::ParticleIosAssetAuthoring, including all inherited members.
setCollisionGroupMaskName(const char *collisionGroupMaskName)=0 | nvidia::apex::ParticleIosAssetAuthoring | [pure virtual]
setCollisionGroupName(const char *collisionGroupName)=0 | nvidia::apex::ParticleIosAssetAuthoring | [pure virtual]
setMaxInjectedParticleCount(float count)=0 | nvidia::apex::ParticleIosAssetAuthoring | [pure virtual]
setMaxParticleCount(uint32_t count)=0 | nvidia::apex::ParticleIosAssetAuthoring | [pure virtual]
setParticleMass(float)=0 | nvidia::apex::ParticleIosAssetAuthoring | [pure virtual]
setParticleRadius(float)=0 | nvidia::apex::ParticleIosAssetAuthoring | [pure virtual]
~ParticleIosAssetAuthoring() | nvidia::apex::ParticleIosAssetAuthoring | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
ModuleParticleIos.h [code]
ParticleIosActor.h [code]
ParticleIosAsset.h [code]
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: Class Members

  • Class List
  • Class Members
  • All
  • Functions
Here is a list of all class members with links to the classes they belong to:
  • getMaxInjectedParticleCount() : nvidia::apex::ParticleIosAsset
  • getMaxParticleCount() : nvidia::apex::ParticleIosAsset
  • getParticleIosTypeName() : nvidia::apex::ModuleParticleIos
  • getParticleMass() : nvidia::apex::ParticleIosAsset
  • getParticleRadius() : nvidia::apex::ParticleIosAsset
  • setCollisionGroupMaskName() : nvidia::apex::ParticleIosAssetAuthoring
  • setCollisionGroupName() : nvidia::apex::ParticleIosAssetAuthoring
  • setMaxInjectedParticleCount() : nvidia::apex::ParticleIosAssetAuthoring
  • setMaxParticleCount() : nvidia::apex::ParticleIosAssetAuthoring
  • setParticleMass() : nvidia::apex::ParticleIosAssetAuthoring
  • setParticleRadius() : nvidia::apex::ParticleIosAssetAuthoring
  • ~ModuleParticleIos() : nvidia::apex::ModuleParticleIos
  • ~ParticleIosActor() : nvidia::apex::ParticleIosActor
  • ~ParticleIosAsset() : nvidia::apex::ParticleIosAsset
  • ~ParticleIosAssetAuthoring() : nvidia::apex::ParticleIosAssetAuthoring
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: Class Members - Functions

  • Class List
  • Class Members
  • All
  • Functions
  • getMaxInjectedParticleCount() : nvidia::apex::ParticleIosAsset
  • getMaxParticleCount() : nvidia::apex::ParticleIosAsset
  • getParticleIosTypeName() : nvidia::apex::ModuleParticleIos
  • getParticleMass() : nvidia::apex::ParticleIosAsset
  • getParticleRadius() : nvidia::apex::ParticleIosAsset
  • setCollisionGroupMaskName() : nvidia::apex::ParticleIosAssetAuthoring
  • setCollisionGroupName() : nvidia::apex::ParticleIosAssetAuthoring
  • setMaxInjectedParticleCount() : nvidia::apex::ParticleIosAssetAuthoring
  • setMaxParticleCount() : nvidia::apex::ParticleIosAssetAuthoring
  • setParticleMass() : nvidia::apex::ParticleIosAssetAuthoring
  • setParticleRadius() : nvidia::apex::ParticleIosAssetAuthoring
  • ~ModuleParticleIos() : nvidia::apex::ModuleParticleIos
  • ~ParticleIosActor() : nvidia::apex::ParticleIosActor
  • ~ParticleIosAsset() : nvidia::apex::ParticleIosAsset
  • ~ParticleIosAssetAuthoring() : nvidia::apex::ParticleIosAssetAuthoring
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: File Members

  • File List
  • File Members
  • All
  • Defines
Here is a list of all file members with links to the files they belong to:
  • PARTICLE_IOS_AUTHORING_TYPE_NAME : ParticleIosAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: File Members

  • File List
  • File Members
  • All
  • Defines
  • PARTICLE_IOS_AUTHORING_TYPE_NAME : ParticleIosAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: Main Page

APEX Particles IOS Module Documentation
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: ModuleParticleIos.h File Reference

  • File List
  • File Members
Classes | Namespaces
ModuleParticleIos.h File Reference
#include "Apex.h"
#include <limits.h>

Go to the source code of this file.

Classes

class | nvidia::apex::ModuleParticleIos
ParticleIOS Module - Manages PhysX 3.0 PxParticleSystem and PxParticleFluid simulations. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: ModuleParticleIos.h Source File

  • File List
  • File Members
ModuleParticleIos.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_PARTICLE_IOS_H
00031 #define MODULE_PARTICLE_IOS_H
00032
00033 #include "Apex.h"
00034 #include <limits.h>
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class ParticleIosAsset;
00044 class ParticleIosAssetAuthoring;
00045 class CudaTestManager;
00046 class Scene;
00047
00051 class ModuleParticleIos : public Module
00052 {
00053 protected:
00054     virtual                                         ~ModuleParticleIos() {}
00055
00056 public:
00058     virtual const char*                             getParticleIosTypeName() = 0;
00059 };
00060
00061
00062 PX_POP_PACK
00063
00064 }
00065 } // namespace nvidia
00066
00067 #endif // MODULE_PARTICLE_IOS_H
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: nvidia Namespace Reference

  • Namespace List
Namespaces
nvidia Namespace Reference

Namespaces

namespace apex
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: nvidia::apex Namespace Reference

  • Namespace List
  • nvidia
  • apex
Classes
nvidia::apex Namespace Reference

Classes

class | ModuleParticleIos
ParticleIOS Module - Manages PhysX 3.0 PxParticleSystem and PxParticleFluid simulations. More...
class | ParticleIosActor
ParticleIOS Actor. A simple actor that simulates a particle system. More...
class | ParticleIosAsset
APEX Particle System Asset. More...
class | ParticleIosAssetAuthoring
APEX Particle System Asset Authoring class. More...
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: Namespace List

  • Namespace List
Namespace List
Here is a list of all namespaces with brief descriptions:
nvidia
nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: ParticleIosActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
ParticleIosActor.h File Reference
#include "Apex.h"
#include "ScopedPhysXLock.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ParticleIosActor
ParticleIOS Actor. A simple actor that simulates a particle system. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: ParticleIosActor.h Source File

  • File List
  • File Members
ParticleIosActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef PARTICLE_IOS_ACTOR_H
00031 #define PARTICLE_IOS_ACTOR_H
00032
00033 #include "Apex.h"
00034
00035 #if PX_PHYSICS_VERSION_MAJOR == 3
00036 #include "ScopedPhysXLock.h"
00037 #endif
00038
00039 namespace nvidia
00040 {
00041 namespace apex
00042 {
00043
00044 PX_PUSH_PACK_DEFAULT
00045
00049 class ParticleIosActor : public Actor
00050 {
00051 public:
00052     // This actor is not publically visible
00053
00054 protected:
00055     virtual ~ParticleIosActor() {}
00056 };
00057
00058 PX_POP_PACK
00059
00060 }
00061 } // namespace nvidia
00062
00063 #endif // PARTICLE_IOS_ACTOR_H
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: ParticleIosAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
ParticleIosAsset.h File Reference
#include "Apex.h"
#include <limits.h>

Go to the source code of this file.

Classes

class | nvidia::apex::ParticleIosAsset
APEX Particle System Asset. More...
class | nvidia::apex::ParticleIosAssetAuthoring
APEX Particle System Asset Authoring class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | PARTICLE_IOS_AUTHORING_TYPE_NAME "ParticleIosAsset"

Define Documentation

#define PARTICLE_IOS_AUTHORING_TYPE_NAME "ParticleIosAsset"
Generated on Sat Dec 1 2018 10:19:03


APEX Particles IOS Module: ParticleIosAsset.h Source File

  • File List
  • File Members
ParticleIosAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef PARTICLE_IOS_ASSET_H
00031 #define PARTICLE_IOS_ASSET_H
00032
00033 #include "Apex.h"
00034 #include <limits.h>
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 #define PARTICLE_IOS_AUTHORING_TYPE_NAME "ParticleIosAsset"
00044
00048 class ParticleIosAsset : public IosAsset
00049 {
00050 public:
00052     virtual float                       getParticleRadius() const = 0;
00053
00055     virtual float                       getMaxInjectedParticleCount() const = 0;
00056
00058     virtual uint32_t                    getMaxParticleCount() const = 0;
00059
00061     virtual float                       getParticleMass() const = 0;
00062
00063 protected:
00064     virtual ~ParticleIosAsset() {}
00065 };
00066
00070 class ParticleIosAssetAuthoring : public AssetAuthoring
00071 {
00072 public:
00074     virtual void setParticleRadius(float) = 0;
00075
00077     virtual void setMaxInjectedParticleCount(float count) = 0;
00078
00080     virtual void setMaxParticleCount(uint32_t count) = 0;
00081
00083     virtual void setParticleMass(float) = 0;
00084
00086     virtual void setCollisionGroupName(const char* collisionGroupName) = 0;
00087
00089     virtual void setCollisionGroupMaskName(const char* collisionGroupMaskName) = 0;
00090
00091 protected:
00092     virtual ~ParticleIosAssetAuthoring()    {}
00093 };
00094
00095 PX_POP_PACK
00096
00097 }
00098 } // namespace nvidia
00099
00100 #endif // PARTICLE_IOS_ASSET_H
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Class List

  • Class List
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
nvidia::apex::FlameEmitterActor | Flame Emitter Actor class
nvidia::apex::FlameEmitterAsset | Flame Emitter Asset class
nvidia::apex::FlameEmitterAssetAuthoring | Flame Emitter Asset Authoring class
nvidia::apex::FlameEmitterPreview | This class provides the asset preview for APEX Flame Emitter Assets
nvidia::apex::HeatSourceActor | Turbulence HeatSource Actor class
nvidia::apex::HeatSourceAsset | Turbulence FieldSampler Asset class
nvidia::apex::HeatSourceAssetAuthoring | Turbulence FieldSampler Asset Authoring class
nvidia::apex::HeatSourcePreview | This class provides the asset preview for APEX HeatSource Assets
nvidia::apex::ModuleTurbulenceFS | Class for TurbulenceFS module
nvidia::apex::SubstanceSourceActor | Turbulence ScalarSource Actor class
nvidia::apex::SubstanceSourceAsset | Turbulence FieldSampler Asset class
nvidia::apex::SubstanceSourceAssetAuthoring | Turbulence FieldSampler Asset Authoring class
nvidia::apex::TurbulenceDensityFormat | Density format for Turbulence rendering
nvidia::apex::TurbulenceFieldType | Render surface field type
nvidia::apex::TurbulenceFlameFormat | Flame format for Turbulence rendering
nvidia::apex::TurbulenceFSActor | Turbulence FieldSampler Actor class
nvidia::apex::TurbulenceFSAsset | Turbulence FieldSampler Asset class
nvidia::apex::TurbulenceFSAssetAuthoring | Turbulence FieldSampler Asset Authoring class
nvidia::apex::TurbulenceFSPreview | This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually
nvidia::apex::TurbulenceRenderable | The Turbulence renderable represents a unit of rendering
nvidia::apex::TurbulenceRenderCallback | User defined callback for Turbulence rendering
nvidia::apex::TurbulenceRenderData | TurbulenceRenderData stores render data for one Turbulence Renderable
nvidia::apex::TurbulenceRenderLayout | Render layout for Turbulence rendering
nvidia::apex::TurbulenceVelocityFormat | Velocity format for Turbulence rendering
nvidia::apex::VelocitySourceActor | Turbulence VelocitySource Actor class
nvidia::apex::VelocitySourceAsset | Turbulence FieldSampler Asset class
nvidia::apex::VelocitySourceAssetAuthoring | Turbulence FieldSampler Asset Authoring class
nvidia::apex::VelocitySourcePreview | This class provides the asset preview for APEX VelocitySource Assets
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Class Index

  • Class List
  • Class Members
Class Index
F | H | M | S | T | V
F
HeatSourceAsset (nvidia::apex) SubstanceSourceAsset (nvidia::apex) TurbulenceFSAsset (nvidia::apex) TurbulenceVelocityFormat (nvidia::apex)
FlameEmitterActor (nvidia::apex) HeatSourceAssetAuthoring (nvidia::apex) SubstanceSourceAssetAuthoring (nvidia::apex) TurbulenceFSAssetAuthoring (nvidia::apex)
V
FlameEmitterAsset (nvidia::apex) HeatSourcePreview (nvidia::apex)
T
TurbulenceFSPreview (nvidia::apex) VelocitySourceActor (nvidia::apex)
FlameEmitterAssetAuthoring (nvidia::apex)
M
TurbulenceDensityFormat (nvidia::apex) TurbulenceRenderable (nvidia::apex) VelocitySourceAsset (nvidia::apex)
FlameEmitterPreview (nvidia::apex) ModuleTurbulenceFS (nvidia::apex) TurbulenceFieldType (nvidia::apex) TurbulenceRenderCallback (nvidia::apex) VelocitySourceAssetAuthoring (nvidia::apex)
H
S
TurbulenceFlameFormat (nvidia::apex) TurbulenceRenderData (nvidia::apex) VelocitySourcePreview (nvidia::apex)
HeatSourceActor (nvidia::apex) SubstanceSourceActor (nvidia::apex) TurbulenceFSActor (nvidia::apex) TurbulenceRenderLayout (nvidia::apex)
F | H | M | S | T | V
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::FlameEmitterActor Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • FlameEmitterActor
Public Member Functions | Protected Member Functions
nvidia::apex::FlameEmitterActor Class Reference

Flame Emitter Actor class. More...

#include <FlameEmitterActor.h>

List of all members.

Public Member Functions

virtual FlameEmitterAsset * | getFlameEmitterAsset () const =0
Returns the asset the instance has been created from.
virtual void | setEnabled (bool enable)=0
enable/disable flame emitter
virtual bool | isEnabled () const =0
Returns true if flame emitter enabled.
virtual bool | intersectAgainstAABB (const PxBounds3 &) const =0
intersect the collision shape against a given AABB
virtual PxMat44 | getPose () const =0
get the global pose
virtual void | setPose (PxMat44 pose)=0
set the global pose
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.
virtual void | release ()=0

Protected Member Functions

virtual | ~FlameEmitterActor ()

Detailed Description

Flame Emitter Actor class.

Constructor & Destructor Documentation

virtual nvidia::apex::FlameEmitterActor::~FlameEmitterActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual float nvidia::apex::FlameEmitterActor::getCurrentScale ( void ) const [pure virtual]

Retrieves the uniform overall object scale.

virtual FlameEmitterAsset* nvidia::apex::FlameEmitterActor::getFlameEmitterAsset ( ) const [pure virtual]

Returns the asset the instance has been created from.

virtual PxMat44 nvidia::apex::FlameEmitterActor::getPose ( ) const [pure virtual]

get the global pose

virtual bool nvidia::apex::FlameEmitterActor::intersectAgainstAABB ( const PxBounds3 & ) const [pure virtual]

intersect the collision shape against a given AABB

virtual bool nvidia::apex::FlameEmitterActor::isEnabled ( ) const [pure virtual]

Returns true if flame emitter enabled.

virtual void nvidia::apex::FlameEmitterActor::release ( ) [pure virtual]
virtual void nvidia::apex::FlameEmitterActor::setCurrentScale ( float scale ) [pure virtual]

Sets the uniform overall object scale.

virtual void nvidia::apex::FlameEmitterActor::setEnabled ( bool enable ) [pure virtual]

enable/disable flame emitter

virtual void nvidia::apex::FlameEmitterActor::setPose ( PxMat44 pose ) [pure virtual]

set the global pose

The documentation for this class was generated from the following file:
  • FlameEmitterActor.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • FlameEmitterActor
nvidia::apex::FlameEmitterActor Member List
This is the complete list of members for nvidia::apex::FlameEmitterActor, including all inherited members.
getCurrentScale(void) const =0 | nvidia::apex::FlameEmitterActor | [pure virtual]
getFlameEmitterAsset() const =0 | nvidia::apex::FlameEmitterActor | [pure virtual]
getPose() const =0 | nvidia::apex::FlameEmitterActor | [pure virtual]
intersectAgainstAABB(const PxBounds3 &) const =0 | nvidia::apex::FlameEmitterActor | [pure virtual]
isEnabled() const =0 | nvidia::apex::FlameEmitterActor | [pure virtual]
release()=0 | nvidia::apex::FlameEmitterActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::FlameEmitterActor | [pure virtual]
setEnabled(bool enable)=0 | nvidia::apex::FlameEmitterActor | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::FlameEmitterActor | [pure virtual]
~FlameEmitterActor() | nvidia::apex::FlameEmitterActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::FlameEmitterAsset Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • FlameEmitterAsset
Protected Member Functions
nvidia::apex::FlameEmitterAsset Class Reference

Flame Emitter Asset class. More...

#include <FlameEmitterAsset.h>

List of all members.

Protected Member Functions

virtual ~FlameEmitterAsset ()

Detailed Description

Flame Emitter Asset class.

Constructor & Destructor Documentation

virtual nvidia::apex::FlameEmitterAsset::~FlameEmitterAsset ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • FlameEmitterAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • FlameEmitterAsset
nvidia::apex::FlameEmitterAsset Member List
This is the complete list of members for nvidia::apex::FlameEmitterAsset, including all inherited members.
~FlameEmitterAsset() nvidia::apex::FlameEmitterAsset [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::FlameEmitterAssetAuthoring Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • FlameEmitterAssetAuthoring
Protected Member Functions
nvidia::apex::FlameEmitterAssetAuthoring Class Reference

Flame Emitter Asset Authoring class. More...

#include <FlameEmitterAsset.h>

List of all members.

Protected Member Functions

virtual ~FlameEmitterAssetAuthoring ()

Detailed Description

Flame Emitter Asset Authoring class.

Constructor & Destructor Documentation

virtual nvidia::apex::FlameEmitterAssetAuthoring::~FlameEmitterAssetAuthoring ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • FlameEmitterAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • FlameEmitterAssetAuthoring
nvidia::apex::FlameEmitterAssetAuthoring Member List
This is the complete list of members for nvidia::apex::FlameEmitterAssetAuthoring, including all inherited members.
~FlameEmitterAssetAuthoring() nvidia::apex::FlameEmitterAssetAuthoring [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::FlameEmitterPreview Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • FlameEmitterPreview
Public Member Functions | Protected Member Functions
nvidia::apex::FlameEmitterPreview Class Reference

This class provides the asset preview for APEX Flame Emitter Assets. More...

#include <FlameEmitterPreview.h>

List of all members.

Public Member Functions

virtual void | drawFlameEmitterPreview ()=0
Draws the emitter.
virtual void | setScale (float scale)=0
Sets the scaling factor of the renderable.

Protected Member Functions

FlameEmitterPreview ()

Detailed Description

This class provides the asset preview for APEX Flame Emitter Assets.

Constructor & Destructor Documentation

nvidia::apex::FlameEmitterPreview::FlameEmitterPreview ( ) [inline, protected]

Member Function Documentation

virtual void nvidia::apex::FlameEmitterPreview::drawFlameEmitterPreview ( ) [pure virtual]

Draws the emitter.

virtual void nvidia::apex::FlameEmitterPreview::setScale ( float scale ) [pure virtual]

Sets the scaling factor of the renderable.

The documentation for this class was generated from the following file:
  • FlameEmitterPreview.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • FlameEmitterPreview
nvidia::apex::FlameEmitterPreview Member List
This is the complete list of members for nvidia::apex::FlameEmitterPreview, including all inherited members.
drawFlameEmitterPreview()=0 | nvidia::apex::FlameEmitterPreview | [pure virtual]
FlameEmitterPreview() | nvidia::apex::FlameEmitterPreview | [inline, protected]
setScale(float scale)=0 | nvidia::apex::FlameEmitterPreview | [pure virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::HeatSourceActor Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • HeatSourceActor
Public Member Functions | Protected Member Functions
nvidia::apex::HeatSourceActor Class Reference

Turbulence HeatSource Actor class. More...

#include <HeatSourceActor.h>

List of all members.

Public Member Functions

virtual HeatSourceAsset * | getHeatSourceAsset () const =0
Returns the asset the instance has been created from.
virtual void | setEnabled (bool enable)=0
enable/disable the heating
virtual bool | isEnabled () const =0
Returns true if heating enabled.
virtual bool | intersectAgainstAABB (PxBounds3)=0
intersect the collision shape against a given AABB
virtual Shape * | getShape () const =0
Returns pointer to Shape of heat source.
virtual BoxShape * | getBoxShape ()=0
If it is a box, cast to box class, return NULL otherwise.
virtual SphereShape * | getSphereShape ()=0
If it is a sphere, cast to sphere class, return NULL otherwise.
virtual float | getAverageTemperature () const =0
Return average value of temperature.
virtual float | getStdTemperature () const =0
Return STD value of temperature.
virtual PxMat44 | getPose () const =0
get the pose of a heat source shape
virtual void | setTemperature (float averageTemperature, float stdTemperature)=0
Set average and STD values for temperature.
virtual void | setPose (PxMat44 pose)=0
set the pose of a heat source shape
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.
virtual void | release ()=0

Protected Member Functions

virtual | ~HeatSourceActor ()

Detailed Description

Turbulence HeatSource Actor class.

Constructor & Destructor Documentation

virtual nvidia::apex::HeatSourceActor::~HeatSourceActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual float nvidia::apex::HeatSourceActor::getAverageTemperature ( ) const [pure virtual]

Return average value of temperature.

virtual BoxShape* nvidia::apex::HeatSourceActor::getBoxShape ( ) [pure virtual]

If it is a box, cast to box class, return NULL otherwise.

virtual float nvidia::apex::HeatSourceActor::getCurrentScale ( void ) const [pure virtual]

Retrieves the uniform overall object scale.

virtual HeatSourceAsset* nvidia::apex::HeatSourceActor::getHeatSourceAsset ( ) const [pure virtual]

Returns the asset the instance has been created from.

virtual PxMat44 nvidia::apex::HeatSourceActor::getPose ( ) const [pure virtual]

get the pose of a heat source shape

virtual Shape* nvidia::apex::HeatSourceActor::getShape ( ) const [pure virtual]

Returns pointer to Shape of heat source.

virtual SphereShape* nvidia::apex::HeatSourceActor::getSphereShape ( ) [pure virtual]

If it is a sphere, cast to sphere class, return NULL otherwise.

virtual float nvidia::apex::HeatSourceActor::getStdTemperature ( ) const [pure virtual]

Return STD value of temperature.

virtual bool nvidia::apex::HeatSourceActor::intersectAgainstAABB ( PxBounds3 ) [pure virtual]

intersect the collision shape against a given AABB

virtual bool nvidia::apex::HeatSourceActor::isEnabled ( ) const [pure virtual]

Returns true if heating enabled.

virtual void nvidia::apex::HeatSourceActor::release ( ) [pure virtual]
virtual void nvidia::apex::HeatSourceActor::setCurrentScale ( float scale ) [pure virtual]

Sets the uniform overall object scale.

virtual void nvidia::apex::HeatSourceActor::setEnabled ( bool enable ) [pure virtual]

enable/disable the heating

virtual void nvidia::apex::HeatSourceActor::setPose ( PxMat44 pose ) [pure virtual]

set the pose of a heat source shape

virtual void nvidia::apex::HeatSourceActor::setTemperature | ( | float | averageTemperature,
 |  | float | stdTemperature
 | ) |  | [pure virtual]

Set average and STD values for temperature.

The documentation for this class was generated from the following file:
  • HeatSourceActor.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • HeatSourceActor
nvidia::apex::HeatSourceActor Member List
This is the complete list of members for nvidia::apex::HeatSourceActor, including all inherited members.
getAverageTemperature() const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
getBoxShape()=0 | nvidia::apex::HeatSourceActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
getHeatSourceAsset() const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
getPose() const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
getShape() const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
getSphereShape()=0 | nvidia::apex::HeatSourceActor | [pure virtual]
getStdTemperature() const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
intersectAgainstAABB(PxBounds3)=0 | nvidia::apex::HeatSourceActor | [pure virtual]
isEnabled() const =0 | nvidia::apex::HeatSourceActor | [pure virtual]
release()=0 | nvidia::apex::HeatSourceActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::HeatSourceActor | [pure virtual]
setEnabled(bool enable)=0 | nvidia::apex::HeatSourceActor | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::HeatSourceActor | [pure virtual]
setTemperature(float averageTemperature, float stdTemperature)=0 | nvidia::apex::HeatSourceActor | [pure virtual]
~HeatSourceActor() | nvidia::apex::HeatSourceActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::HeatSourceAsset Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • HeatSourceAsset
Protected Member Functions
nvidia::apex::HeatSourceAsset Class Reference

Turbulence FieldSampler Asset class. More...

#include <HeatSourceAsset.h>

List of all members.

Protected Member Functions

virtual ~HeatSourceAsset ()

Detailed Description

Turbulence FieldSampler Asset class.

Constructor & Destructor Documentation

virtual nvidia::apex::HeatSourceAsset::~HeatSourceAsset ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • HeatSourceAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • HeatSourceAsset
nvidia::apex::HeatSourceAsset Member List
This is the complete list of members for nvidia::apex::HeatSourceAsset, including all inherited members.
~HeatSourceAsset() nvidia::apex::HeatSourceAsset [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::HeatSourceAssetAuthoring Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • HeatSourceAssetAuthoring
Protected Member Functions
nvidia::apex::HeatSourceAssetAuthoring Class Reference

Turbulence FieldSampler Asset Authoring class. More...

#include <HeatSourceAsset.h>

List of all members.

Protected Member Functions

virtual ~HeatSourceAssetAuthoring ()

Detailed Description

Turbulence FieldSampler Asset Authoring class.

Constructor & Destructor Documentation

virtual nvidia::apex::HeatSourceAssetAuthoring::~HeatSourceAssetAuthoring ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • HeatSourceAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • HeatSourceAssetAuthoring
nvidia::apex::HeatSourceAssetAuthoring Member List
This is the complete list of members for nvidia::apex::HeatSourceAssetAuthoring, including all inherited members.
~HeatSourceAssetAuthoring() nvidia::apex::HeatSourceAssetAuthoring [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::HeatSourcePreview Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • HeatSourcePreview
Public Member Functions | Protected Member Functions
nvidia::apex::HeatSourcePreview Class Reference

This class provides the asset preview for APEX HeatSource Assets. More...

#include <HeatSourcePreview.h>

List of all members.

Public Member Functions

virtual void | drawHeatSourcePreview ()=0
Draws the emitter.
virtual void | setScale (float scale)=0
Sets the scaling factor of the renderable.

Protected Member Functions

HeatSourcePreview ()

Detailed Description

This class provides the asset preview for APEX HeatSource Assets.

Constructor & Destructor Documentation

nvidia::apex::HeatSourcePreview::HeatSourcePreview ( ) [inline, protected]

Member Function Documentation

virtual void nvidia::apex::HeatSourcePreview::drawHeatSourcePreview ( ) [pure virtual]

Draws the emitter.

virtual void nvidia::apex::HeatSourcePreview::setScale ( float scale ) [pure virtual]

Sets the scaling factor of the renderable.

The documentation for this class was generated from the following file:
  • HeatSourcePreview.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • HeatSourcePreview
nvidia::apex::HeatSourcePreview Member List
This is the complete list of members for nvidia::apex::HeatSourcePreview, including all inherited members.
drawHeatSourcePreview()=0 | nvidia::apex::HeatSourcePreview | [pure virtual]
HeatSourcePreview() | nvidia::apex::HeatSourcePreview | [inline, protected]
setScale(float scale)=0 | nvidia::apex::HeatSourcePreview | [pure virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::ModuleTurbulenceFS Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • ModuleTurbulenceFS
Public Member Functions | Protected Member Functions
nvidia::apex::ModuleTurbulenceFS Class Reference

Class for TurbulenceFS module. More...

#include <ModuleTurbulenceFS.h>

List of all members.

Public Member Functions

virtual bool | setCustomTimestep (const Scene &apexScene, float timestep, int numIterations)=0
Set custom timestep parameters for the specified scene (only for one simulation call)
virtual bool | setMultiSolveEnabled (const Scene &apexScene, bool enabled)=0
Enable/disable multi-solve feature for the specified scene (disable by default)
virtual void | enableOutputVelocityField ()=0
Enable output velocity field to UserRenderSurfaceBuffer.
virtual void | enableOutputDensityField ()=0
Enable output density field to UserRenderSurfaceBuffer.
virtual void | enableOutputFlameField ()=0
Enable output flame field to UserRenderSurfaceBuffer.
virtual void | setCustomFilterShader (physx::PxSimulationFilterShader shader, const void *shaderData, uint32_t shaderDataSize)=0
Set custum filter shader to filter collision shapes interacting with Turbulence grids.
virtual const TestBase * | getTestBase (Scene *apexScene) const =0
Returns pointer to TestBase. Internal feature, return NULL for distribution builds.
virtual int32_t | getGridSizePow () const =0
get grid size power. Grid size of all actors will be multiplied by 2^(grid size power). But final grid size restricted by defined values
virtual void | setGridSizePow (int32_t power)=0
set grid size power. Grid size of all actors will be multiplied by 2^(grid size power). But final grid size restricted by defined values
virtual void | prepareRenderables (const Scene &)=0
Prepare renderables for rendering, should be called each frame before using renderables to update them with the most recent data.
virtual bool | setTurbulenceRenderCallback (const Scene &apexScene, TurbulenceRenderCallback *)=0
Set TurbulenceRenderCallback.
virtual TurbulenceRenderCallback * | getTurbulenceRenderCallback (const Scene &apexScene) const =0
Get TurbulenceRenderCallback.

Protected Member Functions

virtual | ~ModuleTurbulenceFS ()

Detailed Description

Class for TurbulenceFS module.

Constructor & Destructor Documentation

virtual nvidia::apex::ModuleTurbulenceFS::~ModuleTurbulenceFS ( ) [inline, protected, virtual]

Member Function Documentation

virtual void nvidia::apex::ModuleTurbulenceFS::enableOutputDensityField ( ) [pure virtual]

Enable output density field to UserRenderSurfaceBuffer.

virtual void nvidia::apex::ModuleTurbulenceFS::enableOutputFlameField ( ) [pure virtual]

Enable output flame field to UserRenderSurfaceBuffer.

virtual void nvidia::apex::ModuleTurbulenceFS::enableOutputVelocityField ( ) [pure virtual]

Enable output velocity field to UserRenderSurfaceBuffer.

virtual int32_t nvidia::apex::ModuleTurbulenceFS::getGridSizePow ( ) const [pure virtual]

get grid size power. Grid size of all actors will be multiplied by 2^(grid size power). But final grid size restricted by defined values

virtual const TestBase* nvidia::apex::ModuleTurbulenceFS::getTestBase ( Scene * apexScene ) const [pure virtual]

Returns pointer to TestBase. Internal feature, return NULL for distribution builds.

virtual TurbulenceRenderCallback* nvidia::apex::ModuleTurbulenceFS::getTurbulenceRenderCallback ( const Scene & apexScene ) const [pure virtual]

Get TurbulenceRenderCallback.

See also:
TurbulenceRenderCallback
virtual void nvidia::apex::ModuleTurbulenceFS::prepareRenderables ( const Scene & ) [pure virtual]

Prepare renderables for rendering, should be called each frame before using renderables to update them with the most recent data.

virtual void nvidia::apex::ModuleTurbulenceFS::setCustomFilterShader | ( | physx::PxSimulationFilterShader | shader,
 |  | const void * | shaderData,
 |  | uint32_t | shaderDataSize
 | ) |  | [pure virtual]

Set custum filter shader to filter collision shapes interacting with Turbulence grids.

virtual bool nvidia::apex::ModuleTurbulenceFS::setCustomTimestep | ( | const Scene & | apexScene,
 |  | float | timestep,
 |  | int | numIterations
 | ) |  | [pure virtual]

Set custom timestep parameters for the specified scene (only for one simulation call)

virtual void nvidia::apex::ModuleTurbulenceFS::setGridSizePow ( int32_t power ) [pure virtual]

set grid size power. Grid size of all actors will be multiplied by 2^(grid size power). But final grid size restricted by defined values

virtual bool nvidia::apex::ModuleTurbulenceFS::setMultiSolveEnabled | ( | const Scene & | apexScene,
 |  | bool | enabled
 | ) |  | [pure virtual]

Enable/disable multi-solve feature for the specified scene (disable by default)

virtual bool nvidia::apex::ModuleTurbulenceFS::setTurbulenceRenderCallback | ( | const Scene & | apexScene,
 |  | TurbulenceRenderCallback * |
 | ) |  | [pure virtual]

Set TurbulenceRenderCallback.

See also:
TurbulenceRenderCallback
The documentation for this class was generated from the following file:
  • ModuleTurbulenceFS.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • ModuleTurbulenceFS
nvidia::apex::ModuleTurbulenceFS Member List
This is the complete list of members for nvidia::apex::ModuleTurbulenceFS, including all inherited members.
enableOutputDensityField()=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
enableOutputFlameField()=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
enableOutputVelocityField()=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
getGridSizePow() const =0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
getTestBase(Scene *apexScene) const =0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
getTurbulenceRenderCallback(const Scene &apexScene) const =0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
prepareRenderables(const Scene &)=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
setCustomFilterShader(physx::PxSimulationFilterShader shader, const void *shaderData, uint32_t shaderDataSize)=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
setCustomTimestep(const Scene &apexScene, float timestep, int numIterations)=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
setGridSizePow(int32_t power)=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
setMultiSolveEnabled(const Scene &apexScene, bool enabled)=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
setTurbulenceRenderCallback(const Scene &apexScene, TurbulenceRenderCallback *)=0 | nvidia::apex::ModuleTurbulenceFS | [pure virtual]
~ModuleTurbulenceFS() | nvidia::apex::ModuleTurbulenceFS | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::SubstanceSourceActor Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • SubstanceSourceActor
Public Member Functions | Protected Member Functions
nvidia::apex::SubstanceSourceActor Class Reference

Turbulence ScalarSource Actor class. More...

#include <SubstanceSourceActor.h>

List of all members.

Public Member Functions

virtual SubstanceSourceAsset * | getSubstanceSourceAsset () const =0
Returns the asset the instance has been created from.
virtual void | setEnabled (bool enable)=0
enable whether or not to use density in the simulation (enabling density reduces performance).
virtual bool | isEnabled () const =0
Returns true if substance source enabled.
virtual bool | intersectAgainstAABB (PxBounds3)=0
intersect the collision shape against a given AABB
virtual Shape * | getShape () const =0
Returns pointer to Shape of substance source.
virtual BoxShape * | getBoxShape ()=0
If it is a box, cast to box class, return NULL otherwise.
virtual SphereShape * | getSphereShape ()=0
If it is a sphere, cast to sphere class, return NULL otherwise.
virtual float | getAverageDensity () const =0
Return average value of density.
virtual float | getStdDensity () const =0
Return STD value of density.
virtual void | setDensity (float averageDensity, float stdDensity)=0
Set average and STD values for density.
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.
virtual void | release ()=0

Protected Member Functions

virtual | ~SubstanceSourceActor ()

Detailed Description

Turbulence ScalarSource Actor class.

Constructor & Destructor Documentation

virtual nvidia::apex::SubstanceSourceActor::~SubstanceSourceActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual float nvidia::apex::SubstanceSourceActor::getAverageDensity ( ) const [pure virtual]

Return average value of density.

virtual BoxShape* nvidia::apex::SubstanceSourceActor::getBoxShape ( ) [pure virtual]

If it is a box, cast to box class, return NULL otherwise.

virtual float nvidia::apex::SubstanceSourceActor::getCurrentScale ( void ) const [pure virtual]

Retrieves the uniform overall object scale.

virtual Shape* nvidia::apex::SubstanceSourceActor::getShape ( ) const [pure virtual]

Returns pointer to Shape of substance source.

virtual SphereShape* nvidia::apex::SubstanceSourceActor::getSphereShape ( ) [pure virtual]

If it is a sphere, cast to sphere class, return NULL otherwise.

virtual float nvidia::apex::SubstanceSourceActor::getStdDensity ( ) const [pure virtual]

Return STD value of density.

virtual SubstanceSourceAsset* nvidia::apex::SubstanceSourceActor::getSubstanceSourceAsset ( ) const [pure virtual]

Returns the asset the instance has been created from.

virtual bool nvidia::apex::SubstanceSourceActor::intersectAgainstAABB ( PxBounds3 ) [pure virtual]

intersect the collision shape against a given AABB

virtual bool nvidia::apex::SubstanceSourceActor::isEnabled ( ) const [pure virtual]

Returns true if substance source enabled.

virtual void nvidia::apex::SubstanceSourceActor::release ( ) [pure virtual]
virtual void nvidia::apex::SubstanceSourceActor::setCurrentScale ( float scale ) [pure virtual]

Sets the uniform overall object scale.

virtual void nvidia::apex::SubstanceSourceActor::setDensity | ( | float | averageDensity,
 |  | float | stdDensity
 | ) |  | [pure virtual]

Set average and STD values for density.

virtual void nvidia::apex::SubstanceSourceActor::setEnabled ( bool enable ) [pure virtual]

enable whether or not to use density in the simulation (enabling density reduces performance).

If you are enabling density then you also need to add substance sources (without substance sources you will see no effect of density on the simulation, except a drop in performance)

The documentation for this class was generated from the following file:
  • SubstanceSourceActor.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • SubstanceSourceActor
nvidia::apex::SubstanceSourceActor Member List
This is the complete list of members for nvidia::apex::SubstanceSourceActor, including all inherited members.
getAverageDensity() const =0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
getBoxShape()=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
getShape() const =0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
getSphereShape()=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
getStdDensity() const =0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
getSubstanceSourceAsset() const =0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
intersectAgainstAABB(PxBounds3)=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
isEnabled() const =0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
release()=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
setDensity(float averageDensity, float stdDensity)=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
setEnabled(bool enable)=0 | nvidia::apex::SubstanceSourceActor | [pure virtual]
~SubstanceSourceActor() | nvidia::apex::SubstanceSourceActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::SubstanceSourceAsset Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • SubstanceSourceAsset
Protected Member Functions
nvidia::apex::SubstanceSourceAsset Class Reference

Turbulence FieldSampler Asset class. More...

#include <SubstanceSourceAsset.h>

List of all members.

Protected Member Functions

virtual ~SubstanceSourceAsset ()

Detailed Description

Turbulence FieldSampler Asset class.

Constructor & Destructor Documentation

virtual nvidia::apex::SubstanceSourceAsset::~SubstanceSourceAsset ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • SubstanceSourceAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • SubstanceSourceAsset
nvidia::apex::SubstanceSourceAsset Member List
This is the complete list of members for nvidia::apex::SubstanceSourceAsset, including all inherited members.
~SubstanceSourceAsset() nvidia::apex::SubstanceSourceAsset [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::SubstanceSourceAssetAuthoring Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • SubstanceSourceAssetAuthoring
Protected Member Functions
nvidia::apex::SubstanceSourceAssetAuthoring Class Reference

Turbulence FieldSampler Asset Authoring class. More...

#include <SubstanceSourceAsset.h>

List of all members.

Protected Member Functions

virtual ~SubstanceSourceAssetAuthoring ()

Detailed Description

Turbulence FieldSampler Asset Authoring class.

Constructor & Destructor Documentation

virtual nvidia::apex::SubstanceSourceAssetAuthoring::~SubstanceSourceAssetAuthoring ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • SubstanceSourceAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • SubstanceSourceAssetAuthoring
nvidia::apex::SubstanceSourceAssetAuthoring Member List
This is the complete list of members for nvidia::apex::SubstanceSourceAssetAuthoring, including all inherited members.
~SubstanceSourceAssetAuthoring() nvidia::apex::SubstanceSourceAssetAuthoring [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::TurbulenceFSActor Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSActor
Public Member Functions | Protected Member Functions
nvidia::apex::TurbulenceFSActor Class Reference

Turbulence FieldSampler Actor class. More...

#include <TurbulenceFSActor.h>

List of all members.

Public Member Functions

virtual TurbulenceFSAsset * | getTurbulenceFSAsset () const =0
Returns the asset the instance has been created from.
virtual void | setEnabled (bool enable)=0
enable/disable the fluid simulation
virtual void | setPose (PxMat44 pose)=0
set the pose of the grid - this includes only the position and rotation.
virtual PxMat44 | getPose () const =0
get the pose of the grid - this includes only the position and rotation.
virtual PxVec3 | getGridBoundingBoxMin ()=0
get the grid bounding box min point
virtual PxVec3 | getGridBoundingBoxMax ()=0
get the grid bounding box max point
virtual PxVec3 | getGridSize ()=0
get the grid size vector
virtual void | getGridDimensions (uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ)=0
get the grid dimensions
virtual void | setGridDimensions (const uint32_t &gridX, const uint32_t &gridY, const uint32_t &gridZ)=0
set the grid dimensions
virtual void | setUpdatesPerFrame (float upd)=0
force the current updates per frame to a particular value.
virtual float | getUpdatesPerFrame () const =0
get the current value of the updates per frame
virtual void | getVelocityField (void **x, void **y, void **z, uint32_t &sizeX, uint32_t &sizeY, uint32_t &sizeZ)=0
methods to get the velocity field sampled at grid centers.
virtual void | setSampleVelocityFieldEnabled (bool enabled)=0
enable/disable sample velocity field
virtual void | setAngularVelocityMultiplierAndClamp (float angularVelocityMultiplier, float angularVelocityClamp)=0
set a multiplier and a clamp on the total angular velocity induced in the system by the internal collision obstacle or by external collision objects
virtual void | setLinearVelocityMultiplierAndClamp (float linearVelocityMultiplier, float linearVelocityClamp)=0
set a multiplier and a clamp on the total linear velocity induced in the system by a collision obstacle
virtual void | setVelocityFieldFade (float fade)=0
set velocity field fade. All cells in the field multiplies by (1 - fade) on each frame
virtual void | setFluidViscosity (float viscosity)=0
set fluid viscosity (diffusion) for velocity
virtual void | setVelocityFieldCleaningTime (float time)=0
set time of velocity field cleaning process [sec]
virtual void | setVelocityFieldCleaningDelay (float time)=0
set time without activity before velocity field cleaning process starts [sec].
virtual void | setVelocityFieldCleaningIntensity (float a)=0
virtual void | setUseHeat (bool enable)=0
enable whether or not to use heat in the simulation (enabling heat reduces performance).

virtual void | setHeatBasedParameters (float forceMultiplier, float ambientTemperature, PxVec3 heatForceDirection, float thermalConductivity)=0
set heat specific parameters for the simulation
virtual void | setUseDensity (bool enable)=0
enable whether or not to use density in the simulation (enabling density reduces performance).

virtual bool | getUseDensity (void) const =0
Returns true if turbulence actor is in density mode.
virtual void | setDensityBasedParameters (float diffusionCoef, float densityFieldFade)=0
set density specific parameters for the simulation
virtual void | getDensityGridDimensions (uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ)=0
get the density grid dimensions
virtual void | setExternalVelocity (PxVec3 vel)=0
allows external actors like wind or explosion to add a single directional velocity to the grid.

virtual void | setFieldVelocityMultiplier (float value)=0
set a multiplier for the field velocity
virtual void | setFieldVelocityWeight (float value)=0
set a weight for the field velocity
virtual void | setNoiseParameters (float noiseStrength, PxVec3 noiseSpacePeriod, float noiseTimePeriod, uint32_t noiseOctaves)=0
set noise parameters
virtual void | setDensityTextureRange (float minValue, float maxValue)=0
set density texture range
virtual const char * | getVolumeRenderMaterialName (void) const =0
Returns the optional volume render material name specified for this turbulence actor.
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.
virtual bool | getUseFlame (void) const =0
Returns true if turbulence actor is in flame mode.
virtual void | getFlameGridDimensions (uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ) const =0
Returns flame grid dimensions.
virtual TurbulenceRenderable * | acquireRenderableReference ()=0
Acquire a pointer to the Turbulence renderable proxy and increment its reference count.

Protected Member Functions

virtual | ~TurbulenceFSActor ()

Detailed Description

Turbulence FieldSampler Actor class.

Constructor & Destructor Documentation

virtual nvidia::apex::TurbulenceFSActor::~TurbulenceFSActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual TurbulenceRenderable* nvidia::apex::TurbulenceFSActor::acquireRenderableReference ( ) [pure virtual]

Acquire a pointer to the Turbulence renderable proxy and increment its reference count.

The TurbulenceRenderable will only be deleted when its reference count is zero. Calls to TurbulenceRenderable::release decrement the reference count, as does a call to TurbulenceFSActor::release().

virtual float nvidia::apex::TurbulenceFSActor::getCurrentScale ( void ) const [pure virtual]

Retrieves the uniform overall object scale.

virtual void nvidia::apex::TurbulenceFSActor::getDensityGridDimensions | ( | uint32_t & | gridX,
 |  | uint32_t & | gridY,
 |  | uint32_t & | gridZ
 | ) |  | [pure virtual]

get the density grid dimensions

virtual void nvidia::apex::TurbulenceFSActor::getFlameGridDimensions | ( | uint32_t & | gridX,
 |  | uint32_t & | gridY,
 |  | uint32_t & | gridZ
 | ) |  | const [pure virtual]

Returns flame grid dimensions.

virtual PxVec3 nvidia::apex::TurbulenceFSActor::getGridBoundingBoxMax ( ) [pure virtual]

get the grid bounding box max point

virtual PxVec3 nvidia::apex::TurbulenceFSActor::getGridBoundingBoxMin ( ) [pure virtual]

get the grid bounding box min point

virtual void nvidia::apex::TurbulenceFSActor::getGridDimensions | ( | uint32_t & | gridX,
 |  | uint32_t & | gridY,
 |  | uint32_t & | gridZ
 | ) |  | [pure virtual]

get the grid dimensions

virtual PxVec3 nvidia::apex::TurbulenceFSActor::getGridSize ( ) [pure virtual]

get the grid size vector

virtual PxMat44 nvidia::apex::TurbulenceFSActor::getPose ( ) const [pure virtual]

get the pose of the grid - this includes only the position and rotation.

the position is that of the center of the grid, as is determined as (pose.column3.x, pose.column3.y, pose.column3.z)
the rotation is the rotation of the object that the grid is centered on
(the grid does not rotate, but we use this pose for rotating the collision obstacle, the jets and imparting angular momentum)

virtual TurbulenceFSAsset* nvidia::apex::TurbulenceFSActor::getTurbulenceFSAsset ( ) const [pure virtual]

Returns the asset the instance has been created from.

virtual float nvidia::apex::TurbulenceFSActor::getUpdatesPerFrame ( ) const [pure virtual]

get the current value of the updates per frame

virtual bool nvidia::apex::TurbulenceFSActor::getUseDensity ( void ) const [pure virtual]

Returns true if turbulence actor is in density mode.

virtual bool nvidia::apex::TurbulenceFSActor::getUseFlame ( void ) const [pure virtual]

Returns true if turbulence actor is in flame mode.

virtual void nvidia::apex::TurbulenceFSActor::getVelocityField | ( | void ** | x,
 |  | void ** | y,
 |  | void ** | z,
 |  | uint32_t & | sizeX,
 |  | uint32_t & | sizeY,
 |  | uint32_t & | sizeZ
 | ) |  | [pure virtual]

methods to get the velocity field sampled at grid centers.

call setSampleVelocityFieldEnabled(true) to enable the sampling and call getVelocityField to get back the sampled results

virtual const char* nvidia::apex::TurbulenceFSActor::getVolumeRenderMaterialName ( void ) const [pure virtual]

Returns the optional volume render material name specified for this turbulence actor.

virtual void nvidia::apex::TurbulenceFSActor::setAngularVelocityMultiplierAndClamp | ( | float | angularVelocityMultiplier,
 |  | float | angularVelocityClamp
 | ) |  | [pure virtual]

set a multiplier and a clamp on the total angular velocity induced in the system by the internal collision obstacle or by external collision objects

virtual void nvidia::apex::TurbulenceFSActor::setCurrentScale ( float scale ) [pure virtual]

Sets the uniform overall object scale.

virtual void nvidia::apex::TurbulenceFSActor::setDensityBasedParameters | ( | float | diffusionCoef,
 |  | float | densityFieldFade
 | ) |  | [pure virtual]

set density specific parameters for the simulation

virtual void nvidia::apex::TurbulenceFSActor::setDensityTextureRange | ( | float | minValue,
 |  | float | maxValue
 | ) |  | [pure virtual]

set density texture range

virtual void nvidia::apex::TurbulenceFSActor::setEnabled ( bool enable ) [pure virtual]

enable/disable the fluid simulation

virtual void nvidia::apex::TurbulenceFSActor::setExternalVelocity ( PxVec3 vel ) [pure virtual]

allows external actors like wind or explosion to add a single directional velocity to the grid.

Note:
if multiple calls to this function are made only the last call is honored (i.e. the velocities are not accumulated)
virtual void nvidia::apex::TurbulenceFSActor::setFieldVelocityMultiplier ( float value ) [pure virtual]

set a multiplier for the field velocity

virtual void nvidia::apex::TurbulenceFSActor::setFieldVelocityWeight ( float value ) [pure virtual]

set a weight for the field velocity

virtual void nvidia::apex::TurbulenceFSActor::setFluidViscosity ( float viscosity ) [pure virtual]

set fluid viscosity (diffusion) for velocity

virtual void nvidia::apex::TurbulenceFSActor::setGridDimensions | ( | const uint32_t & | gridX,
 |  | const uint32_t & | gridY,
 |  | const uint32_t & | gridZ
 | ) |  | [pure virtual]

set the grid dimensions

virtual void nvidia::apex::TurbulenceFSActor::setHeatBasedParameters | ( | float | forceMultiplier,
 |  | float | ambientTemperature,
 |  | PxVec3 | heatForceDirection,
 |  | float | thermalConductivity
 | ) |  | [pure virtual]

set heat specific parameters for the simulation

virtual void nvidia::apex::TurbulenceFSActor::setLinearVelocityMultiplierAndClamp | ( | float | linearVelocityMultiplier,
 |  | float | linearVelocityClamp
 | ) |  | [pure virtual]

set a multiplier and a clamp on the total linear velocity induced in the system by a collision obstacle

virtual void nvidia::apex::TurbulenceFSActor::setNoiseParameters | ( | float | noiseStrength,
 |  | PxVec3 | noiseSpacePeriod,
 |  | float | noiseTimePeriod,
 |  | uint32_t | noiseOctaves
 | ) |  | [pure virtual]

set noise parameters

virtual void nvidia::apex::TurbulenceFSActor::setPose ( PxMat44 pose ) [pure virtual]

set the pose of the grid - this includes only the position and rotation.

the position is that of the center of the grid, as is determined as (pose.column3.x, pose.column3.y, pose.column3.z)
the rotation is the rotation of the object that the grid is centered on
(the grid does not rotate, but we use this pose for rotating the collision obstacle, the jets and imparting angular momentum)

virtual void nvidia::apex::TurbulenceFSActor::setSampleVelocityFieldEnabled ( bool enabled ) [pure virtual]

enable/disable sample velocity field

virtual void nvidia::apex::TurbulenceFSActor::setUpdatesPerFrame ( float upd ) [pure virtual]

force the current updates per frame to a particular value.

Range is 0-1:
1.0f is maximum simulation quality
0.0f is minimum simulation quality

virtual void nvidia::apex::TurbulenceFSActor::setUseDensity ( bool enable ) [pure virtual]

enable whether or not to use density in the simulation (enabling density reduces performance).

Note:
If you are enabling density then you also need to add substance sources (without substance sources you will see no effect of density on the simulation, except a drop in performance)
virtual void nvidia::apex::TurbulenceFSActor::setUseHeat ( bool enable ) [pure virtual]

enable whether or not to use heat in the simulation (enabling heat reduces performance).

Note:
If you are enabling heat then you also need to add temperature sources (without temperature sources you will see no effect of heat on the simulation, except a drop in performance)
virtual void nvidia::apex::TurbulenceFSActor::setVelocityFieldCleaningDelay ( float time ) [pure virtual]

set time without activity before velocity field cleaning process starts [sec].

virtual void nvidia::apex::TurbulenceFSActor::setVelocityFieldCleaningIntensity ( float a ) [pure virtual]

set parameter which correspond to 'a' in erf(a*(cleaning_timer/velocityFieldCleaningTime)). for full cleaning it should be greater then 2. If you want just decrease velocity magitude use smaller value

virtual void nvidia::apex::TurbulenceFSActor::setVelocityFieldCleaningTime ( float time ) [pure virtual]

set time of velocity field cleaning process [sec]

virtual void nvidia::apex::TurbulenceFSActor::setVelocityFieldFade ( float fade ) [pure virtual]

set velocity field fade. All cells in the field multiplies by (1 - fade) on each frame

The documentation for this class was generated from the following file:
  • TurbulenceFSActor.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSActor
nvidia::apex::TurbulenceFSActor Member List
This is the complete list of members for nvidia::apex::TurbulenceFSActor, including all inherited members.
acquireRenderableReference()=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getDensityGridDimensions(uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getFlameGridDimensions(uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ) const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getGridBoundingBoxMax()=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getGridBoundingBoxMin()=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getGridDimensions(uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getGridSize()=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getPose() const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getTurbulenceFSAsset() const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getUpdatesPerFrame() const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getUseDensity(void) const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getUseFlame(void) const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getVelocityField(void **x, void **y, void **z, uint32_t &sizeX, uint32_t &sizeY, uint32_t &sizeZ)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
getVolumeRenderMaterialName(void) const =0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setAngularVelocityMultiplierAndClamp(float angularVelocityMultiplier, float angularVelocityClamp)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setDensityBasedParameters(float diffusionCoef, float densityFieldFade)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setDensityTextureRange(float minValue, float maxValue)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setEnabled(bool enable)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setExternalVelocity(PxVec3 vel)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setFieldVelocityMultiplier(float value)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setFieldVelocityWeight(float value)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setFluidViscosity(float viscosity)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setGridDimensions(const uint32_t &gridX, const uint32_t &gridY, const uint32_t &gridZ)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setHeatBasedParameters(float forceMultiplier, float ambientTemperature, PxVec3 heatForceDirection, float thermalConductivity)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setLinearVelocityMultiplierAndClamp(float linearVelocityMultiplier, float linearVelocityClamp)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setNoiseParameters(float noiseStrength, PxVec3 noiseSpacePeriod, float noiseTimePeriod, uint32_t noiseOctaves)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setSampleVelocityFieldEnabled(bool enabled)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setUpdatesPerFrame(float upd)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setUseDensity(bool enable)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setUseHeat(bool enable)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setVelocityFieldCleaningDelay(float time)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setVelocityFieldCleaningIntensity(float a)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setVelocityFieldCleaningTime(float time)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
setVelocityFieldFade(float fade)=0 | nvidia::apex::TurbulenceFSActor | [pure virtual]
~TurbulenceFSActor() | nvidia::apex::TurbulenceFSActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::TurbulenceFSAsset Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSAsset
Protected Member Functions
nvidia::apex::TurbulenceFSAsset Class Reference

Turbulence FieldSampler Asset class. More...

#include <TurbulenceFSAsset.h>

List of all members.

Protected Member Functions

virtual ~TurbulenceFSAsset ()

Detailed Description

Turbulence FieldSampler Asset class.

Constructor & Destructor Documentation

virtual nvidia::apex::TurbulenceFSAsset::~TurbulenceFSAsset ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • TurbulenceFSAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSAsset
nvidia::apex::TurbulenceFSAsset Member List
This is the complete list of members for nvidia::apex::TurbulenceFSAsset, including all inherited members.
~TurbulenceFSAsset() nvidia::apex::TurbulenceFSAsset [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::TurbulenceFSAssetAuthoring Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSAssetAuthoring
Protected Member Functions
nvidia::apex::TurbulenceFSAssetAuthoring Class Reference

Turbulence FieldSampler Asset Authoring class. More...

#include <TurbulenceFSAsset.h>

List of all members.

Protected Member Functions

virtual ~TurbulenceFSAssetAuthoring ()

Detailed Description

Turbulence FieldSampler Asset Authoring class.

Constructor & Destructor Documentation

virtual nvidia::apex::TurbulenceFSAssetAuthoring::~TurbulenceFSAssetAuthoring ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • TurbulenceFSAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSAssetAuthoring
nvidia::apex::TurbulenceFSAssetAuthoring Member List
This is the complete list of members for nvidia::apex::TurbulenceFSAssetAuthoring, including all inherited members.
~TurbulenceFSAssetAuthoring() nvidia::apex::TurbulenceFSAssetAuthoring [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::TurbulenceFSPreview Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSPreview
Public Member Functions
nvidia::apex::TurbulenceFSPreview Class Reference

This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

#include <TurbulenceFSPreview.h>

List of all members.

Public Member Functions

virtual void | setHalfLengthDimensions (PxVec3 halfLengthDimensions)=0
Set the half length dimensions of the actor thus resizing the box.
virtual void | setNumGrids (PxVec3 numGrids)=0
Set number of grid cells in the box.
virtual void | setIconScale (float scale)=0
Set the scale of the icon.
virtual void | setDetailLevel (uint32_t detail)=0
Set the detail level of the preview rendering by selecting which features to enable.

Detailed Description

This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually.

Member Function Documentation

virtual void nvidia::apex::TurbulenceFSPreview::setDetailLevel ( uint32_t detail ) [pure virtual]

Set the detail level of the preview rendering by selecting which features to enable.

Any, all, or none of the following masks may be added together to select what should be drawn.
The defines for the individual items are:
TURBO_DRAW_NOTHING - draw nothing
TURBO_DRAW_ICON - draw the APEX TurbulenceFS Icon
TURBO_DRAW_BOX - draw the box
TURBO_DRAW_COLLISION_IMPLICIT - draw the collision implicit
TURBO_DRAW_GRIDS - draw the top and bottom grids of the box
TURBO_DRAW_ASSET_INFO - draw the turbulencefs asset info in the screen space
TURBO_DRAW_FULL_DETAIL - draw all components of the turbulencefs preview
All items may be drawn using the macro DRAW_FULL_DETAIL.

virtual void nvidia::apex::TurbulenceFSPreview::setHalfLengthDimensions ( PxVec3 halfLengthDimensions ) [pure virtual]

Set the half length dimensions of the actor thus resizing the box.

virtual void nvidia::apex::TurbulenceFSPreview::setIconScale ( float scale ) [pure virtual]

Set the scale of the icon.

The unscaled icon has is 1.0x1.0 game units.
By default the scale of the icon is 1.0. (unscaled)

virtual void nvidia::apex::TurbulenceFSPreview::setNumGrids ( PxVec3 numGrids ) [pure virtual]

Set number of grid cells in the box.

The documentation for this class was generated from the following file:
  • TurbulenceFSPreview.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceFSPreview
nvidia::apex::TurbulenceFSPreview Member List
This is the complete list of members for nvidia::apex::TurbulenceFSPreview, including all inherited members.
setDetailLevel(uint32_t detail)=0 | nvidia::apex::TurbulenceFSPreview | [pure virtual]
setHalfLengthDimensions(PxVec3 halfLengthDimensions)=0 | nvidia::apex::TurbulenceFSPreview | [pure virtual]
setIconScale(float scale)=0 | nvidia::apex::TurbulenceFSPreview | [pure virtual]
setNumGrids(PxVec3 numGrids)=0 | nvidia::apex::TurbulenceFSPreview | [pure virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::TurbulenceRenderable Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderable
Public Member Functions | Protected Member Functions
nvidia::apex::TurbulenceRenderable Class Reference

The Turbulence renderable represents a unit of rendering. More...

#include <TurbulenceRenderable.h>

List of all members.

Public Member Functions

virtual const
TurbulenceRenderData * 		getRenderData () const =0
Return render data.
virtual const physx::PxBounds3 & | getBounds () const =0
Return AABB of this renderable.

Protected Member Functions

virtual | ~TurbulenceRenderable ()

Detailed Description

The Turbulence renderable represents a unit of rendering.

It contains complete information to render one Turbulence Actor.

Constructor & Destructor Documentation

virtual nvidia::apex::TurbulenceRenderable::~TurbulenceRenderable ( ) [inline, protected, virtual]

Member Function Documentation

virtual const physx::PxBounds3& nvidia::apex::TurbulenceRenderable::getBounds ( ) const [pure virtual]

Return AABB of this renderable.

virtual const TurbulenceRenderData* nvidia::apex::TurbulenceRenderable::getRenderData ( ) const [pure virtual]

Return render data.

The documentation for this class was generated from the following file:
  • TurbulenceRenderable.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderable
nvidia::apex::TurbulenceRenderable Member List
This is the complete list of members for nvidia::apex::TurbulenceRenderable, including all inherited members.
getBounds() const =0 | nvidia::apex::TurbulenceRenderable | [pure virtual]
getRenderData() const =0 | nvidia::apex::TurbulenceRenderable | [pure virtual]
~TurbulenceRenderable() | nvidia::apex::TurbulenceRenderable | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::TurbulenceRenderCallback Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderCallback
Public Member Functions
nvidia::apex::TurbulenceRenderCallback Class Reference

User defined callback for Turbulence rendering. More...

#include <TurbulenceRenderCallback.h>

List of all members.

Public Member Functions

virtual void | onCreatedTurbulenceRenderable (TurbulenceRenderable &)
Called just after a new Turbulence renderable was created.
virtual void | onUpdatedTurbulenceRenderable (TurbulenceRenderable &)
Called just after an Turbulence renderable was updated.
virtual void | onReleasingTurbulenceRenderable (TurbulenceRenderable &)
Called just before an Turbulence renderable is going to be released.
virtual bool | getTurbulenceRenderLayout (TurbulenceRenderLayout &renderLayout, uint32_t sizeX, uint32_t sizeY, uint32_t sizeZ, uint32_t densitySizeMultiplier, uint32_t flameSizeMultiplier)
Returns render layout.

Detailed Description

User defined callback for Turbulence rendering.

Member Function Documentation

virtual bool nvidia::apex::TurbulenceRenderCallback::getTurbulenceRenderLayout | ( | TurbulenceRenderLayout & | renderLayout,
 |  | uint32_t | sizeX,
 |  | uint32_t | sizeY,
 |  | uint32_t | sizeZ,
 |  | uint32_t | densitySizeMultiplier,
 |  | uint32_t | flameSizeMultiplier
 | ) |  | [inline, virtual]

Returns render layout.

virtual void nvidia::apex::TurbulenceRenderCallback::onCreatedTurbulenceRenderable ( TurbulenceRenderable & ) [inline, virtual]

Called just after a new Turbulence renderable was created.

virtual void nvidia::apex::TurbulenceRenderCallback::onReleasingTurbulenceRenderable ( TurbulenceRenderable & ) [inline, virtual]

Called just before an Turbulence renderable is going to be released.

virtual void nvidia::apex::TurbulenceRenderCallback::onUpdatedTurbulenceRenderable ( TurbulenceRenderable & ) [inline, virtual]

Called just after an Turbulence renderable was updated.

The documentation for this class was generated from the following file:
  • TurbulenceRenderCallback.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderCallback
nvidia::apex::TurbulenceRenderCallback Member List
This is the complete list of members for nvidia::apex::TurbulenceRenderCallback, including all inherited members.
getTurbulenceRenderLayout(TurbulenceRenderLayout &renderLayout, uint32_t sizeX, uint32_t sizeY, uint32_t sizeZ, uint32_t densitySizeMultiplier, uint32_t flameSizeMultiplier) | nvidia::apex::TurbulenceRenderCallback | [inline, virtual]
onCreatedTurbulenceRenderable(TurbulenceRenderable &) | nvidia::apex::TurbulenceRenderCallback | [inline, virtual]
onReleasingTurbulenceRenderable(TurbulenceRenderable &) | nvidia::apex::TurbulenceRenderCallback | [inline, virtual]
onUpdatedTurbulenceRenderable(TurbulenceRenderable &) | nvidia::apex::TurbulenceRenderCallback | [inline, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::VelocitySourceActor Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • VelocitySourceActor
Public Member Functions | Protected Member Functions
nvidia::apex::VelocitySourceActor Class Reference

Turbulence VelocitySource Actor class. More...

#include <VelocitySourceActor.h>

List of all members.

Public Member Functions

virtual VelocitySourceAsset * | getVelocitySourceAsset () const =0
Returns the asset the instance has been created from.
virtual void | setEnabled (bool enable)=0
enable/disable the velocity source
virtual bool | isEnabled () const =0
Returns true if velocity source enabled.
virtual bool | intersectAgainstAABB (PxBounds3)=0
intersect the collision shape against a given AABB
virtual Shape * | getShape () const =0
Returns pointer to Shape of velocity source.
virtual BoxShape * | getBoxShape ()=0
If it is a box, cast to box class, return NULL otherwise.
virtual SphereShape * | getSphereShape ()=0
If it is a sphere, cast to sphere class, return NULL otherwise.
virtual float | getAverageVelocity () const =0
Return average value of velocity.
virtual float | getStdVelocity () const =0
Return STD value of velocity.
virtual PxMat44 | getPose () const =0
get the pose of a velocity source shape
virtual void | setVelocity (float averageVelocity, float stdVelocity)=0
Set average and STD values for velocity.
virtual void | setPose (PxMat44 pose)=0
set the pose of a velocity source shape
virtual void | setCurrentScale (float scale)=0
Sets the uniform overall object scale.
virtual float | getCurrentScale (void) const =0
Retrieves the uniform overall object scale.
virtual void | release ()=0

Protected Member Functions

virtual | ~VelocitySourceActor ()

Detailed Description

Turbulence VelocitySource Actor class.

Constructor & Destructor Documentation

virtual nvidia::apex::VelocitySourceActor::~VelocitySourceActor ( ) [inline, protected, virtual]

Member Function Documentation

virtual float nvidia::apex::VelocitySourceActor::getAverageVelocity ( ) const [pure virtual]

Return average value of velocity.

virtual BoxShape* nvidia::apex::VelocitySourceActor::getBoxShape ( ) [pure virtual]

If it is a box, cast to box class, return NULL otherwise.

virtual float nvidia::apex::VelocitySourceActor::getCurrentScale ( void ) const [pure virtual]

Retrieves the uniform overall object scale.

virtual PxMat44 nvidia::apex::VelocitySourceActor::getPose ( ) const [pure virtual]

get the pose of a velocity source shape

virtual Shape* nvidia::apex::VelocitySourceActor::getShape ( ) const [pure virtual]

Returns pointer to Shape of velocity source.

virtual SphereShape* nvidia::apex::VelocitySourceActor::getSphereShape ( ) [pure virtual]

If it is a sphere, cast to sphere class, return NULL otherwise.

virtual float nvidia::apex::VelocitySourceActor::getStdVelocity ( ) const [pure virtual]

Return STD value of velocity.

virtual VelocitySourceAsset* nvidia::apex::VelocitySourceActor::getVelocitySourceAsset ( ) const [pure virtual]

Returns the asset the instance has been created from.

virtual bool nvidia::apex::VelocitySourceActor::intersectAgainstAABB ( PxBounds3 ) [pure virtual]

intersect the collision shape against a given AABB

virtual bool nvidia::apex::VelocitySourceActor::isEnabled ( ) const [pure virtual]

Returns true if velocity source enabled.

virtual void nvidia::apex::VelocitySourceActor::release ( ) [pure virtual]
virtual void nvidia::apex::VelocitySourceActor::setCurrentScale ( float scale ) [pure virtual]

Sets the uniform overall object scale.

virtual void nvidia::apex::VelocitySourceActor::setEnabled ( bool enable ) [pure virtual]

enable/disable the velocity source

virtual void nvidia::apex::VelocitySourceActor::setPose ( PxMat44 pose ) [pure virtual]

set the pose of a velocity source shape

virtual void nvidia::apex::VelocitySourceActor::setVelocity | ( | float | averageVelocity,
 |  | float | stdVelocity
 | ) |  | [pure virtual]

Set average and STD values for velocity.

The documentation for this class was generated from the following file:
  • VelocitySourceActor.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • VelocitySourceActor
nvidia::apex::VelocitySourceActor Member List
This is the complete list of members for nvidia::apex::VelocitySourceActor, including all inherited members.
getAverageVelocity() const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getBoxShape()=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getCurrentScale(void) const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getPose() const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getShape() const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getSphereShape()=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getStdVelocity() const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
getVelocitySourceAsset() const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
intersectAgainstAABB(PxBounds3)=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
isEnabled() const =0 | nvidia::apex::VelocitySourceActor | [pure virtual]
release()=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
setCurrentScale(float scale)=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
setEnabled(bool enable)=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
setPose(PxMat44 pose)=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
setVelocity(float averageVelocity, float stdVelocity)=0 | nvidia::apex::VelocitySourceActor | [pure virtual]
~VelocitySourceActor() | nvidia::apex::VelocitySourceActor | [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::VelocitySourceAsset Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • VelocitySourceAsset
Protected Member Functions
nvidia::apex::VelocitySourceAsset Class Reference

Turbulence FieldSampler Asset class. More...

#include <VelocitySourceAsset.h>

List of all members.

Protected Member Functions

virtual ~VelocitySourceAsset ()

Detailed Description

Turbulence FieldSampler Asset class.

Constructor & Destructor Documentation

virtual nvidia::apex::VelocitySourceAsset::~VelocitySourceAsset ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • VelocitySourceAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • VelocitySourceAsset
nvidia::apex::VelocitySourceAsset Member List
This is the complete list of members for nvidia::apex::VelocitySourceAsset, including all inherited members.
~VelocitySourceAsset() nvidia::apex::VelocitySourceAsset [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::VelocitySourceAssetAuthoring Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • VelocitySourceAssetAuthoring
Protected Member Functions
nvidia::apex::VelocitySourceAssetAuthoring Class Reference

Turbulence FieldSampler Asset Authoring class. More...

#include <VelocitySourceAsset.h>

List of all members.

Protected Member Functions

virtual ~VelocitySourceAssetAuthoring ()

Detailed Description

Turbulence FieldSampler Asset Authoring class.

Constructor & Destructor Documentation

virtual nvidia::apex::VelocitySourceAssetAuthoring::~VelocitySourceAssetAuthoring ( ) [inline, protected, virtual]
The documentation for this class was generated from the following file:
  • VelocitySourceAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • VelocitySourceAssetAuthoring
nvidia::apex::VelocitySourceAssetAuthoring Member List
This is the complete list of members for nvidia::apex::VelocitySourceAssetAuthoring, including all inherited members.
~VelocitySourceAssetAuthoring() nvidia::apex::VelocitySourceAssetAuthoring [inline, protected, virtual]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::VelocitySourcePreview Class Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • VelocitySourcePreview
Public Member Functions | Protected Member Functions
nvidia::apex::VelocitySourcePreview Class Reference

This class provides the asset preview for APEX VelocitySource Assets. More...

#include <VelocitySourcePreview.h>

List of all members.

Public Member Functions

virtual void | drawVelocitySourcePreview ()=0
Draws the emitter.
virtual void | setScale (float scale)=0
Sets the scaling factor of the renderable.

Protected Member Functions

VelocitySourcePreview ()

Detailed Description

This class provides the asset preview for APEX VelocitySource Assets.

Constructor & Destructor Documentation

nvidia::apex::VelocitySourcePreview::VelocitySourcePreview ( ) [inline, protected]

Member Function Documentation

virtual void nvidia::apex::VelocitySourcePreview::drawVelocitySourcePreview ( ) [pure virtual]

Draws the emitter.

virtual void nvidia::apex::VelocitySourcePreview::setScale ( float scale ) [pure virtual]

Sets the scaling factor of the renderable.

The documentation for this class was generated from the following file:
  • VelocitySourcePreview.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • VelocitySourcePreview
nvidia::apex::VelocitySourcePreview Member List
This is the complete list of members for nvidia::apex::VelocitySourcePreview, including all inherited members.
drawVelocitySourcePreview()=0 | nvidia::apex::VelocitySourcePreview | [pure virtual]
setScale(float scale)=0 | nvidia::apex::VelocitySourcePreview | [pure virtual]
VelocitySourcePreview() | nvidia::apex::VelocitySourcePreview | [inline, protected]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
FlameEmitterActor.h [code]
FlameEmitterAsset.h [code]
FlameEmitterPreview.h [code]
HeatSourceActor.h [code]
HeatSourceAsset.h [code]
HeatSourcePreview.h [code]
ModuleTurbulenceFS.h [code]
SubstanceSourceActor.h [code]
SubstanceSourceAsset.h [code]
TurbulenceFSActor.h [code]
TurbulenceFSAsset.h [code]
TurbulenceFSPreview.h [code]
TurbulenceRenderable.h [code]
TurbulenceRenderCallback.h [code]
VelocitySourceActor.h [code]
VelocitySourceAsset.h [code]
VelocitySourcePreview.h [code]
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: FlameEmitterActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
FlameEmitterActor.h File Reference
#include "Apex.h"
#include "Shape.h"

Go to the source code of this file.

Classes

class | nvidia::apex::FlameEmitterActor
Flame Emitter Actor class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: FlameEmitterActor.h Source File

  • File List
  • File Members
FlameEmitterActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef FLAME_EMITTER_ACTOR_H
00030 #define FLAME_EMITTER_ACTOR_H
00031
00032 #include "Apex.h"
00033 #include "Shape.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 class FlameEmitterAsset;
00041
00042
00046 class FlameEmitterActor : public Actor
00047 {
00048 protected:
00049     virtual ~FlameEmitterActor() {}
00050
00051 public:
00053     virtual FlameEmitterAsset*          getFlameEmitterAsset() const = 0;
00054
00055
00057     virtual void                        setEnabled(bool enable) = 0;
00058
00060     virtual bool                        isEnabled() const = 0;
00061
00063     virtual bool                        intersectAgainstAABB(const PxBounds3&) const = 0;
00064
00066     virtual PxMat44                     getPose() const = 0;
00067
00069     virtual void                        setPose(PxMat44 pose) = 0;
00070
00072     virtual void                        setCurrentScale(float scale) = 0;
00073
00075     virtual float                       getCurrentScale(void) const = 0;
00076
00077     virtual void                        release() = 0;
00078 };
00079
00080
00081 }
00082 } // end namespace nvidia
00083
00084 #endif
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: FlameEmitterAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
FlameEmitterAsset.h File Reference
#include "Apex.h"
#include "CustomBufferIterator.h"

Go to the source code of this file.

Classes

class | nvidia::apex::FlameEmitterAsset
Flame Emitter Asset class. More...
class | nvidia::apex::FlameEmitterAssetAuthoring
Flame Emitter Asset Authoring class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | FLAME_EMITTER_AUTHORING_TYPE_NAME "FlameEmitterAsset"

Define Documentation

#define FLAME_EMITTER_AUTHORING_TYPE_NAME "FlameEmitterAsset"
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: FlameEmitterAsset.h Source File

  • File List
  • File Members
FlameEmitterAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef FLAME_EMITTER_ASSET_H
00030 #define FLAME_EMITTER_ASSET_H
00031
00032 #include "Apex.h"
00033 #include "CustomBufferIterator.h"
00034
00035 #define FLAME_EMITTER_AUTHORING_TYPE_NAME "FlameEmitterAsset"
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00045 class FlameEmitterAsset : public Asset
00046 {
00047 protected:
00048     virtual ~FlameEmitterAsset() {}
00049 };
00050
00051
00055 class FlameEmitterAssetAuthoring : public AssetAuthoring
00056 {
00057 protected:
00058     virtual ~FlameEmitterAssetAuthoring() {}
00059 };
00060
00061
00062 }
00063 } // end namespace nvidia
00064
00065 #endif // FLAME_EMITTER_ASSET_H
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: FlameEmitterPreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
FlameEmitterPreview.h File Reference
#include "Apex.h"
#include "AssetPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::FlameEmitterPreview
This class provides the asset preview for APEX Flame Emitter Assets. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: FlameEmitterPreview.h Source File

  • File List
  • File Members
FlameEmitterPreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef FLAME_EMITTER_PREVIEW_H
00030 #define FLAME_EMITTER_PREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00045 class FlameEmitterPreview : public AssetPreview
00046 {
00047 public:
00048     public:
00050     virtual void    drawFlameEmitterPreview() = 0;
00052     virtual void    setScale(float scale) = 0;
00053
00054 protected:
00055     FlameEmitterPreview() {}
00056 };
00057
00058
00059 PX_POP_PACK
00060
00061 }
00062 } // namespace nvidia
00063
00064 #endif // FLAME_EMITTER_PREVIEW_H
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Class Members

  • Class List
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • acquireRenderableReference() : nvidia::apex::TurbulenceFSActor

- d -

  • DEFAULT
: nvidia::apex::TurbulenceVelocityFormat
, nvidia::apex::TurbulenceDensityFormat
, nvidia::apex::TurbulenceFlameFormat
  • DENSITY : nvidia::apex::TurbulenceFieldType
  • densityFormat : nvidia::apex::TurbulenceRenderLayout
  • drawFlameEmitterPreview() : nvidia::apex::FlameEmitterPreview
  • drawHeatSourcePreview() : nvidia::apex::HeatSourcePreview
  • drawVelocitySourcePreview() : nvidia::apex::VelocitySourcePreview

- e -

  • enableOutputDensityField() : nvidia::apex::ModuleTurbulenceFS
  • enableOutputFlameField() : nvidia::apex::ModuleTurbulenceFS
  • enableOutputVelocityField() : nvidia::apex::ModuleTurbulenceFS
  • Enum
: nvidia::apex::TurbulenceVelocityFormat
, nvidia::apex::TurbulenceFieldType
, nvidia::apex::TurbulenceDensityFormat
, nvidia::apex::TurbulenceFlameFormat

- f -

  • fieldSurfaceDescs : nvidia::apex::TurbulenceRenderData
  • fieldSurfaces : nvidia::apex::TurbulenceRenderData
  • FLAME : nvidia::apex::TurbulenceFieldType
  • FlameEmitterPreview() : nvidia::apex::FlameEmitterPreview
  • flameFormat : nvidia::apex::TurbulenceRenderLayout
  • FLOAT1 : nvidia::apex::TurbulenceDensityFormat
  • FLOAT4 : nvidia::apex::TurbulenceFlameFormat , nvidia::apex::TurbulenceVelocityFormat

- g -

  • getAverageDensity() : nvidia::apex::SubstanceSourceActor
  • getAverageTemperature() : nvidia::apex::HeatSourceActor
  • getAverageVelocity() : nvidia::apex::VelocitySourceActor
  • getBounds() : nvidia::apex::TurbulenceRenderable
  • getBoxShape()
: nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::VelocitySourceActor
  • getCurrentScale()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::VelocitySourceActor
  • getDensityGridDimensions() : nvidia::apex::TurbulenceFSActor
  • getFlameEmitterAsset() : nvidia::apex::FlameEmitterActor
  • getFlameGridDimensions() : nvidia::apex::TurbulenceFSActor
  • getGridBoundingBoxMax() : nvidia::apex::TurbulenceFSActor
  • getGridBoundingBoxMin() : nvidia::apex::TurbulenceFSActor
  • getGridDimensions() : nvidia::apex::TurbulenceFSActor
  • getGridSize() : nvidia::apex::TurbulenceFSActor
  • getGridSizePow() : nvidia::apex::ModuleTurbulenceFS
  • getHeatSourceAsset() : nvidia::apex::HeatSourceActor
  • getPose()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::VelocitySourceActor
  • getRenderData() : nvidia::apex::TurbulenceRenderable
  • getShape()
: nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::VelocitySourceActor
  • getSphereShape()
: nvidia::apex::VelocitySourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::HeatSourceActor
  • getStdDensity() : nvidia::apex::SubstanceSourceActor
  • getStdTemperature() : nvidia::apex::HeatSourceActor
  • getStdVelocity() : nvidia::apex::VelocitySourceActor
  • getSubstanceSourceAsset() : nvidia::apex::SubstanceSourceActor
  • getTestBase() : nvidia::apex::ModuleTurbulenceFS
  • getTurbulenceFSAsset() : nvidia::apex::TurbulenceFSActor
  • getTurbulenceRenderCallback() : nvidia::apex::ModuleTurbulenceFS
  • getTurbulenceRenderLayout() : nvidia::apex::TurbulenceRenderCallback
  • getUpdatesPerFrame() : nvidia::apex::TurbulenceFSActor
  • getUseDensity() : nvidia::apex::TurbulenceFSActor
  • getUseFlame() : nvidia::apex::TurbulenceFSActor
  • getVelocityField() : nvidia::apex::TurbulenceFSActor
  • getVelocitySourceAsset() : nvidia::apex::VelocitySourceActor
  • getVolumeRenderMaterialName() : nvidia::apex::TurbulenceFSActor

- h -

  • HALF1 : nvidia::apex::TurbulenceDensityFormat
  • HALF4 : nvidia::apex::TurbulenceVelocityFormat , nvidia::apex::TurbulenceFlameFormat
  • HeatSourcePreview() : nvidia::apex::HeatSourcePreview

- i -

  • intersectAgainstAABB()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::SubstanceSourceActor
  • isEnabled()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor

- m -

  • MAX_COUNT : nvidia::apex::TurbulenceFieldType

- o -

  • onCreatedTurbulenceRenderable() : nvidia::apex::TurbulenceRenderCallback
  • onReleasingTurbulenceRenderable() : nvidia::apex::TurbulenceRenderCallback
  • onUpdatedTurbulenceRenderable() : nvidia::apex::TurbulenceRenderCallback

- p -

  • prepareRenderables() : nvidia::apex::ModuleTurbulenceFS

- r -

  • release()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::HeatSourceActor

- s -

  • setAngularVelocityMultiplierAndClamp() : nvidia::apex::TurbulenceFSActor
  • setCurrentScale()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::VelocitySourceActor
  • setCustomFilterShader() : nvidia::apex::ModuleTurbulenceFS
  • setCustomTimestep() : nvidia::apex::ModuleTurbulenceFS
  • setDefaults() : nvidia::apex::TurbulenceRenderLayout
  • setDensity() : nvidia::apex::SubstanceSourceActor
  • setDensityBasedParameters() : nvidia::apex::TurbulenceFSActor
  • setDensityTextureRange() : nvidia::apex::TurbulenceFSActor
  • setDetailLevel() : nvidia::apex::TurbulenceFSPreview
  • setEnabled()
: nvidia::apex::SubstanceSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
  • setExternalVelocity() : nvidia::apex::TurbulenceFSActor
  • setFieldVelocityMultiplier() : nvidia::apex::TurbulenceFSActor
  • setFieldVelocityWeight() : nvidia::apex::TurbulenceFSActor
  • setFluidViscosity() : nvidia::apex::TurbulenceFSActor
  • setGridDimensions() : nvidia::apex::TurbulenceFSActor
  • setGridSizePow() : nvidia::apex::ModuleTurbulenceFS
  • setHalfLengthDimensions() : nvidia::apex::TurbulenceFSPreview
  • setHeatBasedParameters() : nvidia::apex::TurbulenceFSActor
  • setIconScale() : nvidia::apex::TurbulenceFSPreview
  • setLinearVelocityMultiplierAndClamp() : nvidia::apex::TurbulenceFSActor
  • setMultiSolveEnabled() : nvidia::apex::ModuleTurbulenceFS
  • setNoiseParameters() : nvidia::apex::TurbulenceFSActor
  • setNumGrids() : nvidia::apex::TurbulenceFSPreview
  • setPose()
: nvidia::apex::VelocitySourceActor
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::TurbulenceFSActor
  • setSampleVelocityFieldEnabled() : nvidia::apex::TurbulenceFSActor
  • setScale()
: nvidia::apex::FlameEmitterPreview
, nvidia::apex::HeatSourcePreview
, nvidia::apex::VelocitySourcePreview
  • setTemperature() : nvidia::apex::HeatSourceActor
  • setTurbulenceRenderCallback() : nvidia::apex::ModuleTurbulenceFS
  • setUpdatesPerFrame() : nvidia::apex::TurbulenceFSActor
  • setUseDensity() : nvidia::apex::TurbulenceFSActor
  • setUseHeat() : nvidia::apex::TurbulenceFSActor
  • setVelocity() : nvidia::apex::VelocitySourceActor
  • setVelocityFieldCleaningDelay() : nvidia::apex::TurbulenceFSActor
  • setVelocityFieldCleaningIntensity() : nvidia::apex::TurbulenceFSActor
  • setVelocityFieldCleaningTime() : nvidia::apex::TurbulenceFSActor
  • setVelocityFieldFade() : nvidia::apex::TurbulenceFSActor

- t -

  • TurbulenceRenderLayout() : nvidia::apex::TurbulenceRenderLayout

- u -

  • UBYTE1 : nvidia::apex::TurbulenceDensityFormat

- v -

  • VELOCITY : nvidia::apex::TurbulenceFieldType
  • velocityFormat : nvidia::apex::TurbulenceRenderLayout
  • VelocitySourcePreview() : nvidia::apex::VelocitySourcePreview

- ~ -

  • ~FlameEmitterActor() : nvidia::apex::FlameEmitterActor
  • ~FlameEmitterAsset() : nvidia::apex::FlameEmitterAsset
  • ~FlameEmitterAssetAuthoring() : nvidia::apex::FlameEmitterAssetAuthoring
  • ~HeatSourceActor() : nvidia::apex::HeatSourceActor
  • ~HeatSourceAsset() : nvidia::apex::HeatSourceAsset
  • ~HeatSourceAssetAuthoring() : nvidia::apex::HeatSourceAssetAuthoring
  • ~ModuleTurbulenceFS() : nvidia::apex::ModuleTurbulenceFS
  • ~SubstanceSourceActor() : nvidia::apex::SubstanceSourceActor
  • ~SubstanceSourceAsset() : nvidia::apex::SubstanceSourceAsset
  • ~SubstanceSourceAssetAuthoring() : nvidia::apex::SubstanceSourceAssetAuthoring
  • ~TurbulenceFSActor() : nvidia::apex::TurbulenceFSActor
  • ~TurbulenceFSAsset() : nvidia::apex::TurbulenceFSAsset
  • ~TurbulenceFSAssetAuthoring() : nvidia::apex::TurbulenceFSAssetAuthoring
  • ~TurbulenceRenderable() : nvidia::apex::TurbulenceRenderable
  • ~VelocitySourceActor() : nvidia::apex::VelocitySourceActor
  • ~VelocitySourceAsset() : nvidia::apex::VelocitySourceAsset
  • ~VelocitySourceAssetAuthoring() : nvidia::apex::VelocitySourceAssetAuthoring
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Class Members - Enumerations

  • Class List
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Enum
: nvidia::apex::TurbulenceFieldType
, nvidia::apex::TurbulenceFlameFormat
, nvidia::apex::TurbulenceDensityFormat
, nvidia::apex::TurbulenceVelocityFormat
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Class Members - Enumerator

  • Class List
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • DEFAULT
: nvidia::apex::TurbulenceVelocityFormat
, nvidia::apex::TurbulenceDensityFormat
, nvidia::apex::TurbulenceFlameFormat
  • DENSITY : nvidia::apex::TurbulenceFieldType
  • FLAME : nvidia::apex::TurbulenceFieldType
  • FLOAT1 : nvidia::apex::TurbulenceDensityFormat
  • FLOAT4 : nvidia::apex::TurbulenceVelocityFormat , nvidia::apex::TurbulenceFlameFormat
  • HALF1 : nvidia::apex::TurbulenceDensityFormat
  • HALF4 : nvidia::apex::TurbulenceFlameFormat , nvidia::apex::TurbulenceVelocityFormat
  • MAX_COUNT : nvidia::apex::TurbulenceFieldType
  • UBYTE1 : nvidia::apex::TurbulenceDensityFormat
  • VELOCITY : nvidia::apex::TurbulenceFieldType
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Class Members - Functions

  • Class List
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • d
  • e
  • f
  • g
  • h
  • i
  • o
  • p
  • r
  • s
  • t
  • v
  • ~

- a -

  • acquireRenderableReference() : nvidia::apex::TurbulenceFSActor

- d -

  • drawFlameEmitterPreview() : nvidia::apex::FlameEmitterPreview
  • drawHeatSourcePreview() : nvidia::apex::HeatSourcePreview
  • drawVelocitySourcePreview() : nvidia::apex::VelocitySourcePreview

- e -

  • enableOutputDensityField() : nvidia::apex::ModuleTurbulenceFS
  • enableOutputFlameField() : nvidia::apex::ModuleTurbulenceFS
  • enableOutputVelocityField() : nvidia::apex::ModuleTurbulenceFS

- f -

  • FlameEmitterPreview() : nvidia::apex::FlameEmitterPreview

- g -

  • getAverageDensity() : nvidia::apex::SubstanceSourceActor
  • getAverageTemperature() : nvidia::apex::HeatSourceActor
  • getAverageVelocity() : nvidia::apex::VelocitySourceActor
  • getBounds() : nvidia::apex::TurbulenceRenderable
  • getBoxShape()
: nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::VelocitySourceActor
  • getCurrentScale()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::VelocitySourceActor
  • getDensityGridDimensions() : nvidia::apex::TurbulenceFSActor
  • getFlameEmitterAsset() : nvidia::apex::FlameEmitterActor
  • getFlameGridDimensions() : nvidia::apex::TurbulenceFSActor
  • getGridBoundingBoxMax() : nvidia::apex::TurbulenceFSActor
  • getGridBoundingBoxMin() : nvidia::apex::TurbulenceFSActor
  • getGridDimensions() : nvidia::apex::TurbulenceFSActor
  • getGridSize() : nvidia::apex::TurbulenceFSActor
  • getGridSizePow() : nvidia::apex::ModuleTurbulenceFS
  • getHeatSourceAsset() : nvidia::apex::HeatSourceActor
  • getPose()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::VelocitySourceActor
  • getRenderData() : nvidia::apex::TurbulenceRenderable
  • getShape()
: nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::VelocitySourceActor
  • getSphereShape()
: nvidia::apex::VelocitySourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::HeatSourceActor
  • getStdDensity() : nvidia::apex::SubstanceSourceActor
  • getStdTemperature() : nvidia::apex::HeatSourceActor
  • getStdVelocity() : nvidia::apex::VelocitySourceActor
  • getSubstanceSourceAsset() : nvidia::apex::SubstanceSourceActor
  • getTestBase() : nvidia::apex::ModuleTurbulenceFS
  • getTurbulenceFSAsset() : nvidia::apex::TurbulenceFSActor
  • getTurbulenceRenderCallback() : nvidia::apex::ModuleTurbulenceFS
  • getTurbulenceRenderLayout() : nvidia::apex::TurbulenceRenderCallback
  • getUpdatesPerFrame() : nvidia::apex::TurbulenceFSActor
  • getUseDensity() : nvidia::apex::TurbulenceFSActor
  • getUseFlame() : nvidia::apex::TurbulenceFSActor
  • getVelocityField() : nvidia::apex::TurbulenceFSActor
  • getVelocitySourceAsset() : nvidia::apex::VelocitySourceActor
  • getVolumeRenderMaterialName() : nvidia::apex::TurbulenceFSActor

- h -

  • HeatSourcePreview() : nvidia::apex::HeatSourcePreview

- i -

  • intersectAgainstAABB()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::SubstanceSourceActor
  • isEnabled()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::SubstanceSourceActor

- o -

  • onCreatedTurbulenceRenderable() : nvidia::apex::TurbulenceRenderCallback
  • onReleasingTurbulenceRenderable() : nvidia::apex::TurbulenceRenderCallback
  • onUpdatedTurbulenceRenderable() : nvidia::apex::TurbulenceRenderCallback

- p -

  • prepareRenderables() : nvidia::apex::ModuleTurbulenceFS

- r -

  • release()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::HeatSourceActor

- s -

  • setAngularVelocityMultiplierAndClamp() : nvidia::apex::TurbulenceFSActor
  • setCurrentScale()
: nvidia::apex::FlameEmitterActor
, nvidia::apex::SubstanceSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::VelocitySourceActor
  • setCustomFilterShader() : nvidia::apex::ModuleTurbulenceFS
  • setCustomTimestep() : nvidia::apex::ModuleTurbulenceFS
  • setDefaults() : nvidia::apex::TurbulenceRenderLayout
  • setDensity() : nvidia::apex::SubstanceSourceActor
  • setDensityBasedParameters() : nvidia::apex::TurbulenceFSActor
  • setDensityTextureRange() : nvidia::apex::TurbulenceFSActor
  • setDetailLevel() : nvidia::apex::TurbulenceFSPreview
  • setEnabled()
: nvidia::apex::SubstanceSourceActor
, nvidia::apex::TurbulenceFSActor
, nvidia::apex::VelocitySourceActor
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
  • setExternalVelocity() : nvidia::apex::TurbulenceFSActor
  • setFieldVelocityMultiplier() : nvidia::apex::TurbulenceFSActor
  • setFieldVelocityWeight() : nvidia::apex::TurbulenceFSActor
  • setFluidViscosity() : nvidia::apex::TurbulenceFSActor
  • setGridDimensions() : nvidia::apex::TurbulenceFSActor
  • setGridSizePow() : nvidia::apex::ModuleTurbulenceFS
  • setHalfLengthDimensions() : nvidia::apex::TurbulenceFSPreview
  • setHeatBasedParameters() : nvidia::apex::TurbulenceFSActor
  • setIconScale() : nvidia::apex::TurbulenceFSPreview
  • setLinearVelocityMultiplierAndClamp() : nvidia::apex::TurbulenceFSActor
  • setMultiSolveEnabled() : nvidia::apex::ModuleTurbulenceFS
  • setNoiseParameters() : nvidia::apex::TurbulenceFSActor
  • setNumGrids() : nvidia::apex::TurbulenceFSPreview
  • setPose()
: nvidia::apex::VelocitySourceActor
, nvidia::apex::FlameEmitterActor
, nvidia::apex::HeatSourceActor
, nvidia::apex::TurbulenceFSActor
  • setSampleVelocityFieldEnabled() : nvidia::apex::TurbulenceFSActor
  • setScale()
: nvidia::apex::FlameEmitterPreview
, nvidia::apex::HeatSourcePreview
, nvidia::apex::VelocitySourcePreview
  • setTemperature() : nvidia::apex::HeatSourceActor
  • setTurbulenceRenderCallback() : nvidia::apex::ModuleTurbulenceFS
  • setUpdatesPerFrame() : nvidia::apex::TurbulenceFSActor
  • setUseDensity() : nvidia::apex::TurbulenceFSActor
  • setUseHeat() : nvidia::apex::TurbulenceFSActor
  • setVelocity() : nvidia::apex::VelocitySourceActor
  • setVelocityFieldCleaningDelay() : nvidia::apex::TurbulenceFSActor
  • setVelocityFieldCleaningIntensity() : nvidia::apex::TurbulenceFSActor
  • setVelocityFieldCleaningTime() : nvidia::apex::TurbulenceFSActor
  • setVelocityFieldFade() : nvidia::apex::TurbulenceFSActor

- t -

  • TurbulenceRenderLayout() : nvidia::apex::TurbulenceRenderLayout

- v -

  • VelocitySourcePreview() : nvidia::apex::VelocitySourcePreview

- ~ -

  • ~FlameEmitterActor() : nvidia::apex::FlameEmitterActor
  • ~FlameEmitterAsset() : nvidia::apex::FlameEmitterAsset
  • ~FlameEmitterAssetAuthoring() : nvidia::apex::FlameEmitterAssetAuthoring
  • ~HeatSourceActor() : nvidia::apex::HeatSourceActor
  • ~HeatSourceAsset() : nvidia::apex::HeatSourceAsset
  • ~HeatSourceAssetAuthoring() : nvidia::apex::HeatSourceAssetAuthoring
  • ~ModuleTurbulenceFS() : nvidia::apex::ModuleTurbulenceFS
  • ~SubstanceSourceActor() : nvidia::apex::SubstanceSourceActor
  • ~SubstanceSourceAsset() : nvidia::apex::SubstanceSourceAsset
  • ~SubstanceSourceAssetAuthoring() : nvidia::apex::SubstanceSourceAssetAuthoring
  • ~TurbulenceFSActor() : nvidia::apex::TurbulenceFSActor
  • ~TurbulenceFSAsset() : nvidia::apex::TurbulenceFSAsset
  • ~TurbulenceFSAssetAuthoring() : nvidia::apex::TurbulenceFSAssetAuthoring
  • ~TurbulenceRenderable() : nvidia::apex::TurbulenceRenderable
  • ~VelocitySourceActor() : nvidia::apex::VelocitySourceActor
  • ~VelocitySourceAsset() : nvidia::apex::VelocitySourceAsset
  • ~VelocitySourceAssetAuthoring() : nvidia::apex::VelocitySourceAssetAuthoring
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Class Members - Variables

  • Class List
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • densityFormat : nvidia::apex::TurbulenceRenderLayout
  • fieldSurfaceDescs : nvidia::apex::TurbulenceRenderData
  • fieldSurfaces : nvidia::apex::TurbulenceRenderData
  • flameFormat : nvidia::apex::TurbulenceRenderLayout
  • velocityFormat : nvidia::apex::TurbulenceRenderLayout
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: File Members

  • File List
  • File Members
  • All
  • Defines
Here is a list of all file members with links to the files they belong to:
  • FLAME_EMITTER_AUTHORING_TYPE_NAME : FlameEmitterAsset.h
  • HEAT_SOURCE_AUTHORING_TYPE_NAME : HeatSourceAsset.h
  • SUBSTANCE_SOURCE_AUTHORING_TYPE_NAME : SubstanceSourceAsset.h
  • TURBULENCE_FS_AUTHORING_TYPE_NAME : TurbulenceFSAsset.h
  • VELOCITY_SOURCE_AUTHORING_TYPE_NAME : VelocitySourceAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: File Members

  • File List
  • File Members
  • All
  • Defines
  • FLAME_EMITTER_AUTHORING_TYPE_NAME : FlameEmitterAsset.h
  • HEAT_SOURCE_AUTHORING_TYPE_NAME : HeatSourceAsset.h
  • SUBSTANCE_SOURCE_AUTHORING_TYPE_NAME : SubstanceSourceAsset.h
  • TURBULENCE_FS_AUTHORING_TYPE_NAME : TurbulenceFSAsset.h
  • VELOCITY_SOURCE_AUTHORING_TYPE_NAME : VelocitySourceAsset.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: HeatSourceActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
HeatSourceActor.h File Reference
#include "Apex.h"
#include "Shape.h"

Go to the source code of this file.

Classes

class | nvidia::apex::HeatSourceActor
Turbulence HeatSource Actor class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: HeatSourceActor.h Source File

  • File List
  • File Members
HeatSourceActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef HEAT_SOURCE_ACTOR_H
00030 #define HEAT_SOURCE_ACTOR_H
00031
00032 #include "Apex.h"
00033 #include "Shape.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 class HeatSourceAsset;
00041
00042
00046 class HeatSourceActor : public Actor
00047 {
00048 protected:
00049     virtual ~HeatSourceActor() {}
00050
00051 public:
00053     virtual HeatSourceAsset*            getHeatSourceAsset() const = 0;
00054
00056     virtual void                        setEnabled(bool enable) = 0;
00057
00059     virtual bool                        isEnabled() const = 0;
00060
00062     virtual bool                        intersectAgainstAABB(PxBounds3) = 0;
00063
00065     virtual  Shape*                     getShape() const = 0;
00066
00068     virtual BoxShape*                   getBoxShape() = 0;
00069
00071     virtual SphereShape*                getSphereShape() = 0;
00072
00074     virtual float                       getAverageTemperature() const = 0;
00075
00077     virtual float                       getStdTemperature() const = 0;
00078
00080     virtual PxMat44                     getPose() const = 0;
00081
00083     virtual void                        setTemperature(float averageTemperature, float stdTemperature) = 0;
00084
00086     virtual void                        setPose(PxMat44 pose) = 0;
00087
00089     virtual void                        setCurrentScale(float scale) = 0;
00090
00092     virtual float                       getCurrentScale(void) const = 0;
00093
00094     virtual void                        release() = 0;
00095 };
00096
00097
00098 }
00099 } // end namespace nvidia
00100
00101 #endif
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: HeatSourceAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
HeatSourceAsset.h File Reference
#include "Apex.h"
#include "CustomBufferIterator.h"

Go to the source code of this file.

Classes

class | nvidia::apex::HeatSourceAsset
Turbulence FieldSampler Asset class. More...
class | nvidia::apex::HeatSourceAssetAuthoring
Turbulence FieldSampler Asset Authoring class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | HEAT_SOURCE_AUTHORING_TYPE_NAME "HeatSourceAsset"

Define Documentation

#define HEAT_SOURCE_AUTHORING_TYPE_NAME "HeatSourceAsset"
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: HeatSourceAsset.h Source File

  • File List
  • File Members
HeatSourceAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef HEAT_SOURCE_ASSET_H
00030 #define HEAT_SOURCE_ASSET_H
00031
00032 #include "Apex.h"
00033 #include "CustomBufferIterator.h"
00034
00035 #define HEAT_SOURCE_AUTHORING_TYPE_NAME "HeatSourceAsset"
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00042 class TurbulenceFSActorParams;
00043 class TurbulenceFSActor;
00044 class TurbulenceFSPreview;
00045
00049 class HeatSourceAsset : public Asset
00050 {
00051 protected:
00052     virtual ~HeatSourceAsset() {}
00053 };
00054
00055
00059 class HeatSourceAssetAuthoring : public AssetAuthoring
00060 {
00061 protected:
00062     virtual ~HeatSourceAssetAuthoring() {}
00063 };
00064
00065
00066 }
00067 } // end namespace nvidia
00068
00069 #endif // HEAT_SOURCE_ASSET_H
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: HeatSourcePreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
HeatSourcePreview.h File Reference
#include "Apex.h"
#include "AssetPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::HeatSourcePreview
This class provides the asset preview for APEX HeatSource Assets. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: HeatSourcePreview.h Source File

  • File List
  • File Members
HeatSourcePreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef HEAT_SOURCE_PREVIEW_H
00030 #define HEAT_SOURCE_PREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00045 class HeatSourcePreview : public AssetPreview
00046 {
00047 public:
00048     public:
00050     virtual void    drawHeatSourcePreview() = 0;
00052     virtual void    setScale(float scale) = 0;
00053
00054 protected:
00055     HeatSourcePreview() {}
00056 };
00057
00058
00059 PX_POP_PACK
00060
00061 }
00062 } // namespace nvidia
00063
00064 #endif // HEAT_SOURCE_PREVIEW_H
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Main Page

APEX TurbulenceFS Module Documentation
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: ModuleTurbulenceFS.h File Reference

  • File List
  • File Members
Classes | Namespaces | Functions
ModuleTurbulenceFS.h File Reference
#include "Apex.h"
#include "Shape.h"
#include "VelocitySourceActor.h"
#include "HeatSourceActor.h"
#include "SubstanceSourceActor.h"
#include "FlameEmitterActor.h"
#include "TestBase.h"
#include "PxFiltering.h"

Go to the source code of this file.

Classes

class | nvidia::apex::ModuleTurbulenceFS
Class for TurbulenceFS module. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Functions

void | nvidia::apex::instantiateModuleTurbulenceFS ()
If this module is distributed as a static library, the user must call this function before calling ApexSDK::createModule("Turbulence")
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: ModuleTurbulenceFS.h Source File

  • File List
  • File Members
ModuleTurbulenceFS.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef MODULE_TURBULENCE_FS_H
00031 #define MODULE_TURBULENCE_FS_H
00032
00033 #include "Apex.h"
00034 #include "Shape.h"
00035 #include "VelocitySourceActor.h"
00036 #include "HeatSourceActor.h"
00037 #include "SubstanceSourceActor.h"
00038 #include "FlameEmitterActor.h"
00039 #include "TestBase.h"
00040 #include "PxFiltering.h"
00041
00042 namespace nvidia
00043 {
00044 namespace apex
00045 {
00046
00047 class TurbulenceFSAsset;
00048 class TurbulenceFSAssetAuthoring;
00049
00050 class TurbulenceRenderCallback;
00051
00055 class ModuleTurbulenceFS : public Module
00056 {
00057 public:
00058
00060     virtual bool                        setCustomTimestep(const Scene& apexScene, float timestep, int numIterations) = 0;
00061
00063     virtual bool                        setMultiSolveEnabled(const Scene& apexScene, bool enabled) = 0;
00064
00066     virtual void                        enableOutputVelocityField() = 0;
00067
00069     virtual void                        enableOutputDensityField() = 0;
00070
00072     virtual void                        enableOutputFlameField() = 0;
00073
00075     virtual void                        setCustomFilterShader(physx::PxSimulationFilterShader shader, const void* shaderData, uint32_t shaderDataSize) = 0;
00076
00078     virtual const TestBase*             getTestBase(Scene* apexScene) const = 0;
00079
00081     virtual int32_t                     getGridSizePow() const = 0;
00082
00084     virtual void                        setGridSizePow(int32_t power) = 0;
00085
00087     virtual void                        prepareRenderables(const Scene&) = 0;
00088
00093     virtual bool                        setTurbulenceRenderCallback(const Scene& apexScene, TurbulenceRenderCallback* ) = 0;
00094
00099     virtual TurbulenceRenderCallback*   getTurbulenceRenderCallback(const Scene& apexScene) const = 0;
00100
00101 protected:
00102     virtual ~ModuleTurbulenceFS() {}
00103 };
00104
00105 #if !defined(_USRDLL)
00106
00110 void instantiateModuleTurbulenceFS();
00111 #endif
00112
00113 }
00114 } // end namespace nvidia
00115
00116 #endif // MODULE_TURBULENCE_FS_H
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
Here is a list of all namespace members with links to the namespace documentation for each member:
  • instantiateModuleTurbulenceFS() : nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • instantiateModuleTurbulenceFS() : nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces
nvidia Namespace Reference

Namespaces

namespace apex
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex Namespace Reference

  • Namespace List
  • Namespace Members
  • nvidia
  • apex
Namespaces | Classes | Functions
nvidia::apex Namespace Reference

Namespaces

namespace | APEX_TURBO

The APEX_TURBO namespace contains the defines for setting the preview detail levels.

Classes

class | FlameEmitterActor
Flame Emitter Actor class. More...
class | FlameEmitterAsset
Flame Emitter Asset class. More...
class | FlameEmitterAssetAuthoring
Flame Emitter Asset Authoring class. More...
class | FlameEmitterPreview
This class provides the asset preview for APEX Flame Emitter Assets. More...
class | HeatSourceActor
Turbulence HeatSource Actor class. More...
class | HeatSourceAsset
Turbulence FieldSampler Asset class. More...
class | HeatSourceAssetAuthoring
Turbulence FieldSampler Asset Authoring class. More...
class | HeatSourcePreview
This class provides the asset preview for APEX HeatSource Assets. More...
class | ModuleTurbulenceFS
Class for TurbulenceFS module. More...
class | SubstanceSourceActor
Turbulence ScalarSource Actor class. More...
class | SubstanceSourceAsset
Turbulence FieldSampler Asset class. More...
class | SubstanceSourceAssetAuthoring
Turbulence FieldSampler Asset Authoring class. More...
class | TurbulenceFSActor
Turbulence FieldSampler Actor class. More...
class | TurbulenceFSAsset
Turbulence FieldSampler Asset class. More...
class | TurbulenceFSAssetAuthoring
Turbulence FieldSampler Asset Authoring class. More...
class | TurbulenceFSPreview
This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...
struct | TurbulenceFieldType
Render surface field type. More...
struct | TurbulenceRenderData
TurbulenceRenderData stores render data for one Turbulence Renderable. More...
class | TurbulenceRenderable
The Turbulence renderable represents a unit of rendering. More...
struct | TurbulenceVelocityFormat
Velocity format for Turbulence rendering. More...
struct | TurbulenceDensityFormat
Density format for Turbulence rendering. More...
struct | TurbulenceFlameFormat
Flame format for Turbulence rendering. More...
struct | TurbulenceRenderLayout
Render layout for Turbulence rendering. More...
class | TurbulenceRenderCallback
User defined callback for Turbulence rendering. More...
class | VelocitySourceActor
Turbulence VelocitySource Actor class. More...
class | VelocitySourceAsset
Turbulence FieldSampler Asset class. More...
class | VelocitySourceAssetAuthoring
Turbulence FieldSampler Asset Authoring class. More...
class | VelocitySourcePreview
This class provides the asset preview for APEX VelocitySource Assets. More...

Functions

void | instantiateModuleTurbulenceFS ()
If this module is distributed as a static library, the user must call this function before calling ApexSDK::createModule("Turbulence")

Function Documentation

void nvidia::apex::instantiateModuleTurbulenceFS ( )

If this module is distributed as a static library, the user must call this function before calling ApexSDK::createModule("Turbulence")

Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::APEX_TURBO Namespace Reference

  • Namespace List
  • Namespace Members
  • nvidia
  • apex
  • APEX_TURBO
nvidia::apex::APEX_TURBO Namespace Reference

The APEX_TURBO namespace contains the defines for setting the preview detail levels. More...

Detailed Description

The APEX_TURBO namespace contains the defines for setting the preview detail levels.

TURBO_DRAW_NOTHING - draw nothing
TURBO_DRAW_ICON - draw the APEX TurbulenceFS Icon
TURBO_DRAW_BOX - draw the box
TURBO_DRAW_GRIDS - draw the top and bottom grids of the box
TURBO_DRAW_ASSET_INFO - draw the asset info in the screen space
TURBO_DRAW_FULL_DETAIL - draw all components of the preview

Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
nvidia |
nvidia::apex |
nvidia::apex::APEX_TURBO | The APEX_TURBO namespace contains the defines for setting the preview detail levels
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::TurbulenceDensityFormat Struct Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceDensityFormat
Public Types
nvidia::apex::TurbulenceDensityFormat Struct Reference

Density format for Turbulence rendering. More...

#include <TurbulenceRenderCallback.h>

List of all members.

Public Types

enum Enum {
DEFAULT = 0,
UBYTE1 = RenderDataFormat::UBYTE1,
HALF1 = RenderDataFormat::HALF1,
FLOAT1 = RenderDataFormat::FLOAT1
}
Enum of density format for Turbulence rendering. More...

Detailed Description

Density format for Turbulence rendering.

Member Enumeration Documentation

enum nvidia::apex::TurbulenceDensityFormat::Enum

Enum of density format for Turbulence rendering.

Enumerator:
DEFAULT
UBYTE1
HALF1
FLOAT1
The documentation for this struct was generated from the following file:
  • TurbulenceRenderCallback.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceDensityFormat
nvidia::apex::TurbulenceDensityFormat Member List
This is the complete list of members for nvidia::apex::TurbulenceDensityFormat, including all inherited members.
DEFAULT enum value | nvidia::apex::TurbulenceDensityFormat
Enum enum name | nvidia::apex::TurbulenceDensityFormat
FLOAT1 enum value | nvidia::apex::TurbulenceDensityFormat
HALF1 enum value | nvidia::apex::TurbulenceDensityFormat
UBYTE1 enum value | nvidia::apex::TurbulenceDensityFormat
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::TurbulenceFieldType Struct Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceFieldType
Public Types
nvidia::apex::TurbulenceFieldType Struct Reference

Render surface field type. More...

#include <TurbulenceRenderable.h>

List of all members.

Public Types

enum Enum {
VELOCITY = 0,
DENSITY,
FLAME,
MAX_COUNT
}
Enum of render surface field types. More...

Detailed Description

Render surface field type.

Member Enumeration Documentation

enum nvidia::apex::TurbulenceFieldType::Enum

Enum of render surface field types.

Enumerator:
VELOCITY
DENSITY
FLAME
MAX_COUNT
The documentation for this struct was generated from the following file:
  • TurbulenceRenderable.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceFieldType
nvidia::apex::TurbulenceFieldType Member List
This is the complete list of members for nvidia::apex::TurbulenceFieldType, including all inherited members.
DENSITY enum value | nvidia::apex::TurbulenceFieldType
Enum enum name | nvidia::apex::TurbulenceFieldType
FLAME enum value | nvidia::apex::TurbulenceFieldType
MAX_COUNT enum value | nvidia::apex::TurbulenceFieldType
VELOCITY enum value | nvidia::apex::TurbulenceFieldType
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::TurbulenceFlameFormat Struct Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceFlameFormat
Public Types
nvidia::apex::TurbulenceFlameFormat Struct Reference

Flame format for Turbulence rendering. More...

#include <TurbulenceRenderCallback.h>

List of all members.

Public Types

enum Enum {
DEFAULT = 0,
HALF4 = RenderDataFormat::HALF4,
FLOAT4 = RenderDataFormat::FLOAT4
}
Enum of flame format for Turbulence rendering. More...

Detailed Description

Flame format for Turbulence rendering.

Member Enumeration Documentation

enum nvidia::apex::TurbulenceFlameFormat::Enum

Enum of flame format for Turbulence rendering.

Enumerator:
DEFAULT
HALF4
FLOAT4
The documentation for this struct was generated from the following file:
  • TurbulenceRenderCallback.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceFlameFormat
nvidia::apex::TurbulenceFlameFormat Member List
This is the complete list of members for nvidia::apex::TurbulenceFlameFormat, including all inherited members.
DEFAULT enum value | nvidia::apex::TurbulenceFlameFormat
Enum enum name | nvidia::apex::TurbulenceFlameFormat
FLOAT4 enum value | nvidia::apex::TurbulenceFlameFormat
HALF4 enum value | nvidia::apex::TurbulenceFlameFormat
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::TurbulenceRenderData Struct Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderData
Public Attributes
nvidia::apex::TurbulenceRenderData Struct Reference

TurbulenceRenderData stores render data for one Turbulence Renderable. More...

#include <TurbulenceRenderable.h>

List of all members.

Public Attributes

UserRenderSurfaceDesc | fieldSurfaceDescs [TurbulenceFieldType::MAX_COUNT]
UserRenderSurfaceDesc array for all field types.
UserRenderSurface * | fieldSurfaces [TurbulenceFieldType::MAX_COUNT]
UserRenderSurface array for all field types.

Detailed Description

TurbulenceRenderData stores render data for one Turbulence Renderable.

Member Data Documentation

UserRenderSurfaceDesc nvidia::apex::TurbulenceRenderData::fieldSurfaceDescs[TurbulenceFieldType::MAX_COUNT]

UserRenderSurfaceDesc array for all field types.

UserRenderSurface* nvidia::apex::TurbulenceRenderData::fieldSurfaces[TurbulenceFieldType::MAX_COUNT]

UserRenderSurface array for all field types.

The documentation for this struct was generated from the following file:
  • TurbulenceRenderable.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderData
nvidia::apex::TurbulenceRenderData Member List
This is the complete list of members for nvidia::apex::TurbulenceRenderData, including all inherited members.
fieldSurfaceDescs | nvidia::apex::TurbulenceRenderData
fieldSurfaces | nvidia::apex::TurbulenceRenderData
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::TurbulenceRenderLayout Struct Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderLayout
Public Member Functions | Public Attributes
nvidia::apex::TurbulenceRenderLayout Struct Reference

Render layout for Turbulence rendering. More...

#include <TurbulenceRenderCallback.h>

List of all members.

Public Member Functions

TurbulenceRenderLayout ()
void setDefaults ()
set default formats

Public Attributes

TurbulenceVelocityFormat::Enum velocityFormat
Velocity format.
TurbulenceDensityFormat::Enum densityFormat
Density format.
TurbulenceFlameFormat::Enum flameFormat
Flame format.

Detailed Description

Render layout for Turbulence rendering.

Constructor & Destructor Documentation

nvidia::apex::TurbulenceRenderLayout::TurbulenceRenderLayout ( ) [inline]

Member Function Documentation

void nvidia::apex::TurbulenceRenderLayout::setDefaults ( ) [inline]

set default formats

Member Data Documentation

TurbulenceDensityFormat::Enum nvidia::apex::TurbulenceRenderLayout::densityFormat

Density format.

TurbulenceFlameFormat::Enum nvidia::apex::TurbulenceRenderLayout::flameFormat

Flame format.

TurbulenceVelocityFormat::Enum nvidia::apex::TurbulenceRenderLayout::velocityFormat

Velocity format.

The documentation for this struct was generated from the following file:
  • TurbulenceRenderCallback.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceRenderLayout
nvidia::apex::TurbulenceRenderLayout Member List
This is the complete list of members for nvidia::apex::TurbulenceRenderLayout, including all inherited members.
densityFormat | nvidia::apex::TurbulenceRenderLayout |
flameFormat | nvidia::apex::TurbulenceRenderLayout |
setDefaults() | nvidia::apex::TurbulenceRenderLayout | [inline]
TurbulenceRenderLayout() | nvidia::apex::TurbulenceRenderLayout | [inline]
velocityFormat | nvidia::apex::TurbulenceRenderLayout |
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: nvidia::apex::TurbulenceVelocityFormat Struct Reference

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceVelocityFormat
Public Types
nvidia::apex::TurbulenceVelocityFormat Struct Reference

Velocity format for Turbulence rendering. More...

#include <TurbulenceRenderCallback.h>

List of all members.

Public Types

enum Enum {
DEFAULT = 0,
HALF4 = RenderDataFormat::HALF4,
FLOAT4 = RenderDataFormat::FLOAT4
}
Enum of velocity format for Turbulence rendering. More...

Detailed Description

Velocity format for Turbulence rendering.

Member Enumeration Documentation

enum nvidia::apex::TurbulenceVelocityFormat::Enum

Enum of velocity format for Turbulence rendering.

Enumerator:
DEFAULT
HALF4
FLOAT4
The documentation for this struct was generated from the following file:
  • TurbulenceRenderCallback.h
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: Member List

  • Class List
  • Class Members
  • nvidia
  • apex
  • TurbulenceVelocityFormat
nvidia::apex::TurbulenceVelocityFormat Member List
This is the complete list of members for nvidia::apex::TurbulenceVelocityFormat, including all inherited members.
DEFAULT enum value | nvidia::apex::TurbulenceVelocityFormat
Enum enum name | nvidia::apex::TurbulenceVelocityFormat
FLOAT4 enum value | nvidia::apex::TurbulenceVelocityFormat
HALF4 enum value | nvidia::apex::TurbulenceVelocityFormat
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: SubstanceSourceActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
SubstanceSourceActor.h File Reference
#include "Apex.h"
#include "Shape.h"

Go to the source code of this file.

Classes

class | nvidia::apex::SubstanceSourceActor
Turbulence ScalarSource Actor class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: SubstanceSourceActor.h Source File

  • File List
  • File Members
SubstanceSourceActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef SUBSTANCE_SOURCE_ACTOR_H
00030 #define SUBSTANCE_SOURCE_ACTOR_H
00031
00032 #include "Apex.h"
00033 #include "Shape.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 class SubstanceSourceAsset;
00041
00042
00046 class SubstanceSourceActor : public Actor
00047 {
00048 protected:
00049     virtual ~SubstanceSourceActor() {}
00050
00051 public:
00053     virtual SubstanceSourceAsset*       getSubstanceSourceAsset() const = 0;
00054
00060     virtual void                        setEnabled(bool enable) = 0;
00061
00063     virtual bool                        isEnabled() const = 0;
00064
00066     virtual bool                        intersectAgainstAABB(PxBounds3) = 0;
00067
00069     virtual  Shape*                     getShape() const = 0;
00070
00072     virtual BoxShape*                   getBoxShape() = 0;
00073
00075     virtual SphereShape*                getSphereShape() = 0;
00076
00078     virtual float                       getAverageDensity() const = 0;
00079
00081     virtual float                       getStdDensity() const = 0;
00082
00084     virtual void                        setDensity(float averageDensity, float stdDensity) = 0;
00085
00087     virtual void                        setCurrentScale(float scale) = 0;
00088
00090     virtual float                       getCurrentScale(void) const = 0;
00091
00092     virtual void                        release() = 0;
00093 };
00094
00095
00096 }
00097 } // end namespace nvidia
00098
00099 #endif
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: SubstanceSourceAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
SubstanceSourceAsset.h File Reference
#include "Apex.h"
#include "CustomBufferIterator.h"

Go to the source code of this file.

Classes

class | nvidia::apex::SubstanceSourceAsset
Turbulence FieldSampler Asset class. More...
class | nvidia::apex::SubstanceSourceAssetAuthoring
Turbulence FieldSampler Asset Authoring class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | SUBSTANCE_SOURCE_AUTHORING_TYPE_NAME "SubstanceSourceAsset"

Define Documentation

#define SUBSTANCE_SOURCE_AUTHORING_TYPE_NAME "SubstanceSourceAsset"
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: SubstanceSourceAsset.h Source File

  • File List
  • File Members
SubstanceSourceAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef SUBSTANCE_SOURCE_ASSET_H
00030 #define SUBSTANCE_SOURCE_ASSET_H
00031
00032 #include "Apex.h"
00033 #include "CustomBufferIterator.h"
00034
00035 #define SUBSTANCE_SOURCE_AUTHORING_TYPE_NAME "SubstanceSourceAsset"
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00042 class TurbulenceFSActorParams;
00043 class TurbulenceFSActor;
00044 class TurbulenceFSPreview;
00045
00049 class SubstanceSourceAsset : public Asset
00050 {
00051 protected:
00052     virtual ~SubstanceSourceAsset() {}
00053 };
00054
00055
00059 class SubstanceSourceAssetAuthoring : public AssetAuthoring
00060 {
00061 protected:
00062     virtual ~SubstanceSourceAssetAuthoring() {}
00063 };
00064
00065
00066 }
00067 } // end namespace nvidia
00068
00069 #endif // SUBSTANCE_SOURCE_ASSET_H
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: TurbulenceFSActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
TurbulenceFSActor.h File Reference
#include "Apex.h"
#include "Shape.h"

Go to the source code of this file.

Classes

class | nvidia::apex::TurbulenceFSActor
Turbulence FieldSampler Actor class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: TurbulenceFSActor.h Source File

  • File List
  • File Members
TurbulenceFSActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef TURBULENCE_FSACTOR_H
00030 #define TURBULENCE_FSACTOR_H
00031
00032 #include "Apex.h"
00033 #include "Shape.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 class TurbulenceFSAsset;
00041 class TurbulenceRenderable;
00042
00046 class TurbulenceFSActor : public Actor, public Renderable
00047 {
00048 protected:
00049     virtual ~TurbulenceFSActor() {}
00050
00051 public:
00052
00054     virtual TurbulenceFSAsset* getTurbulenceFSAsset() const = 0;
00055
00057     virtual void setEnabled(bool enable) = 0;
00058
00066     virtual void setPose(PxMat44 pose) = 0;
00067
00075     virtual PxMat44 getPose() const = 0;
00076
00078     virtual PxVec3 getGridBoundingBoxMin() = 0;
00080     virtual PxVec3 getGridBoundingBoxMax() = 0;
00081
00083     virtual PxVec3 getGridSize() = 0;
00084
00086     virtual void getGridDimensions(uint32_t &gridX,uint32_t &gridY,uint32_t &gridZ) = 0;
00087
00089     virtual void setGridDimensions(const uint32_t &gridX, const uint32_t &gridY, const uint32_t &gridZ) = 0;
00090
00098     virtual void setUpdatesPerFrame(float upd) = 0;
00100     virtual float getUpdatesPerFrame() const = 0;
00101
00107     virtual void getVelocityField(void** x, void** y, void** z, uint32_t& sizeX, uint32_t& sizeY, uint32_t& sizeZ) = 0;
00108
00110     virtual void setSampleVelocityFieldEnabled(bool enabled) = 0;
00111
00113     virtual void setAngularVelocityMultiplierAndClamp(float angularVelocityMultiplier, float angularVelocityClamp) = 0;
00114
00116     virtual void setLinearVelocityMultiplierAndClamp(float linearVelocityMultiplier, float linearVelocityClamp) = 0;
00117
00119     virtual void setVelocityFieldFade(float fade) = 0;
00120
00122     virtual void setFluidViscosity(float viscosity) = 0;
00123
00125     virtual void setVelocityFieldCleaningTime(float time) = 0;
00126
00128     virtual void setVelocityFieldCleaningDelay(float time) = 0;
00129
00134     virtual void setVelocityFieldCleaningIntensity(float a) = 0;
00135
00140     virtual void setUseHeat(bool enable) = 0;
00141
00143     virtual void setHeatBasedParameters(float forceMultiplier, float ambientTemperature, PxVec3 heatForceDirection, float thermalConductivity) = 0;
00144
00149     virtual void setUseDensity(bool enable) = 0;
00150
00152     virtual bool getUseDensity(void) const = 0;
00153
00155     virtual void setDensityBasedParameters(float diffusionCoef, float densityFieldFade) = 0;
00156
00158     virtual void getDensityGridDimensions(uint32_t &gridX,uint32_t &gridY,uint32_t &gridZ) = 0;
00159
00164     virtual void setExternalVelocity(PxVec3 vel) = 0;
00165
00167     virtual void setFieldVelocityMultiplier(float value) = 0;
00168
00170     virtual void setFieldVelocityWeight(float value) = 0;
00171
00173     virtual void setNoiseParameters(float noiseStrength, PxVec3 noiseSpacePeriod, float noiseTimePeriod, uint32_t noiseOctaves) = 0;
00174
00176     virtual void setDensityTextureRange(float minValue, float maxValue) = 0;
00177
00179     virtual const char *getVolumeRenderMaterialName(void) const = 0;
00180
00182     virtual void setCurrentScale(float scale) = 0;
00183
00185     virtual float getCurrentScale(void) const = 0;
00186
00188     virtual bool getUseFlame(void) const = 0;
00189
00191     virtual void getFlameGridDimensions(uint32_t &gridX, uint32_t &gridY, uint32_t &gridZ) const = 0;
00192
00199     virtual TurbulenceRenderable* acquireRenderableReference() = 0;
00200
00201 };
00202
00203 }
00204 } // end namespace nvidia
00205
00206 #endif // TURBULENCE_FSACTOR_H
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: TurbulenceFSAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
TurbulenceFSAsset.h File Reference
#include "Apex.h"
#include "CustomBufferIterator.h"

Go to the source code of this file.

Classes

class | nvidia::apex::TurbulenceFSAsset
Turbulence FieldSampler Asset class. More...
class | nvidia::apex::TurbulenceFSAssetAuthoring
Turbulence FieldSampler Asset Authoring class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | TURBULENCE_FS_AUTHORING_TYPE_NAME "TurbulenceFSAsset"

Define Documentation

#define TURBULENCE_FS_AUTHORING_TYPE_NAME "TurbulenceFSAsset"
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: TurbulenceFSAsset.h Source File

  • File List
  • File Members
TurbulenceFSAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef TURBULENCE_FSASSET_H
00030 #define TURBULENCE_FSASSET_H
00031
00032 #include "Apex.h"
00033 #include "CustomBufferIterator.h"
00034
00035 #define TURBULENCE_FS_AUTHORING_TYPE_NAME "TurbulenceFSAsset"
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00042 class TurbulenceFSActorParams;
00043 class TurbulenceFSActor;
00044 class TurbulenceFSPreview;
00045
00049 class TurbulenceFSAsset : public Asset
00050 {
00051 protected:
00052     virtual ~TurbulenceFSAsset() {}
00053
00054 };
00055
00059 class TurbulenceFSAssetAuthoring : public AssetAuthoring
00060 {
00061 protected:
00062     virtual ~TurbulenceFSAssetAuthoring() {}
00063
00064 };
00065
00066 }
00067 } // end namespace nvidia
00068
00069 #endif // TURBULENCE_FSASSET_H
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: TurbulenceFSPreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
TurbulenceFSPreview.h File Reference
#include "Apex.h"
#include "AssetPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::TurbulenceFSPreview
This class provides the asset preview for APEX TurbulenceFS Assets. The class provides multiple levels of prevew detail that can be selected individually. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
namespace | nvidia::apex::APEX_TURBO

The APEX_TURBO namespace contains the defines for setting the preview detail levels.

Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: TurbulenceFSPreview.h Source File

  • File List
  • File Members
TurbulenceFSPreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef TURBULENCE_FSPREVIEW_H
00030 #define TURBULENCE_FSPREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00042 class RenderDebugInterface;
00043
00054 namespace APEX_TURBO
00055 {
00060 static const uint32_t TURBO_DRAW_NOTHING = 0x00;
00065 static const uint32_t TURBO_DRAW_ICON = 0x01;
00070 static const uint32_t TURBO_DRAW_BOX = 0x02;
00076 static const uint32_t TURBO_DRAW_GRIDS = 0x04;
00082 static const uint32_t TURBO_DRAW_ASSET_INFO = 0x20;
00087 static const uint32_t TURBO_DRAW_FULL_DETAIL = (TURBO_DRAW_ICON + TURBO_DRAW_BOX + TURBO_DRAW_GRIDS + TURBO_DRAW_ASSET_INFO);
00088 }
00089
00094 class TurbulenceFSPreview : public AssetPreview
00095 {
00096 public:
00100     virtual void    setHalfLengthDimensions(PxVec3 halfLengthDimensions) = 0;
00104     virtual void    setNumGrids(PxVec3 numGrids) = 0;
00111     virtual void    setIconScale(float scale) = 0;
00126     virtual void    setDetailLevel(uint32_t detail) = 0;
00127 };
00128
00129
00130 PX_POP_PACK
00131
00132 }
00133 } // namespace nvidia
00134
00135 #endif // TURBULENCE_FSPREVIEW_H
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: TurbulenceRenderable.h File Reference

  • File List
  • File Members
Classes | Namespaces
TurbulenceRenderable.h File Reference
#include "foundation/Px.h"
#include "ApexInterface.h"
#include "Renderable.h"
#include "TurbulenceRenderCallback.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::TurbulenceFieldType
Render surface field type. More...
struct | nvidia::apex::TurbulenceRenderData
TurbulenceRenderData stores render data for one Turbulence Renderable. More...
class | nvidia::apex::TurbulenceRenderable
The Turbulence renderable represents a unit of rendering. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: TurbulenceRenderable.h Source File

  • File List
  • File Members
TurbulenceRenderable.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef TURBULENCE_RENDERABLE_H
00031 #define TURBULENCE_RENDERABLE_H
00032
00033 #include "foundation/Px.h"
00034 #include "ApexInterface.h"
00035 #include "Renderable.h"
00036 #include "TurbulenceRenderCallback.h"
00037
00038 namespace nvidia
00039 {
00040 namespace apex
00041 {
00042
00043 PX_PUSH_PACK_DEFAULT
00044
00048 struct TurbulenceFieldType
00049 {
00053     enum Enum
00054     {
00055         VELOCITY = 0,
00056         DENSITY,
00057         FLAME,
00058
00059         MAX_COUNT
00060     };
00061 };
00062
00066 struct TurbulenceRenderData
00067 {
00069     UserRenderSurfaceDesc   fieldSurfaceDescs[TurbulenceFieldType::MAX_COUNT];
00070
00072     UserRenderSurface*      fieldSurfaces[TurbulenceFieldType::MAX_COUNT];
00073 };
00074
00080 class TurbulenceRenderable : public ApexInterface
00081 {
00082 public:
00084     virtual const TurbulenceRenderData* getRenderData() const = 0;
00085
00087     virtual const physx::PxBounds3&     getBounds() const = 0;
00088
00089 protected:
00090     virtual ~TurbulenceRenderable() {}
00091
00092 };
00093
00094 PX_POP_PACK
00095
00096 }
00097 } // end namespace nvidia
00098
00099 #endif // TURBULENCE_RENDERABLE_H
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: TurbulenceRenderCallback.h File Reference

  • File List
  • File Members
Classes | Namespaces
TurbulenceRenderCallback.h File Reference
#include "foundation/Px.h"
#include "UserRenderCallback.h"

Go to the source code of this file.

Classes

struct | nvidia::apex::TurbulenceVelocityFormat
Velocity format for Turbulence rendering. More...
struct | nvidia::apex::TurbulenceDensityFormat
Density format for Turbulence rendering. More...
struct | nvidia::apex::TurbulenceFlameFormat
Flame format for Turbulence rendering. More...
struct | nvidia::apex::TurbulenceRenderLayout
Render layout for Turbulence rendering. More...
class | nvidia::apex::TurbulenceRenderCallback
User defined callback for Turbulence rendering. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: TurbulenceRenderCallback.h Source File

  • File List
  • File Members
TurbulenceRenderCallback.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029
00030 #ifndef TURBULENCE_RENDER_CALLBACK_H
00031 #define TURBULENCE_RENDER_CALLBACK_H
00032
00033 #include "foundation/Px.h"
00034 #include "UserRenderCallback.h"
00035
00036 namespace nvidia
00037 {
00038 namespace apex
00039 {
00040
00041 PX_PUSH_PACK_DEFAULT
00042
00043 class TurbulenceRenderable;
00044
00048 struct TurbulenceVelocityFormat
00049 {
00053     enum Enum
00054     {
00055         DEFAULT = 0,
00056         HALF4 = RenderDataFormat::HALF4,
00057         FLOAT4 = RenderDataFormat::FLOAT4,
00058     };
00059 };
00060
00064 struct TurbulenceDensityFormat
00065 {
00069     enum Enum
00070     {
00071         DEFAULT = 0,
00072         UBYTE1 = RenderDataFormat::UBYTE1,
00073         HALF1 = RenderDataFormat::HALF1,
00074         FLOAT1 = RenderDataFormat::FLOAT1,
00075     };
00076 };
00077
00081 struct TurbulenceFlameFormat
00082 {
00086     enum Enum
00087     {
00088         DEFAULT = 0,
00089         HALF4 = RenderDataFormat::HALF4,
00090         FLOAT4 = RenderDataFormat::FLOAT4,
00091     };
00092 };
00093
00097 struct TurbulenceRenderLayout
00098 {
00099     TurbulenceRenderLayout()
00100     {
00101         setDefaults();
00102     }
00103
00105     void setDefaults()
00106     {
00107         velocityFormat = TurbulenceVelocityFormat::DEFAULT;
00108         densityFormat = TurbulenceDensityFormat::DEFAULT;
00109         flameFormat = TurbulenceFlameFormat::DEFAULT;
00110     }
00111
00113     TurbulenceVelocityFormat::Enum  velocityFormat;
00114
00116     TurbulenceDensityFormat::Enum   densityFormat;
00117
00119     TurbulenceFlameFormat::Enum     flameFormat;
00120 };
00121
00125 class TurbulenceRenderCallback : public UserRenderCallback
00126 {
00127 public:
00129     virtual void onCreatedTurbulenceRenderable(TurbulenceRenderable& ) {}
00130
00132     virtual void onUpdatedTurbulenceRenderable(TurbulenceRenderable& ) {}
00133
00135     virtual void onReleasingTurbulenceRenderable(TurbulenceRenderable& ) {}
00136
00138     virtual bool getTurbulenceRenderLayout(TurbulenceRenderLayout& renderLayout, uint32_t sizeX, uint32_t sizeY, uint32_t sizeZ, uint32_t densitySizeMultiplier, uint32_t flameSizeMultiplier)
00139     {
00140         PX_UNUSED(renderLayout);
00141         PX_UNUSED(sizeX);
00142         PX_UNUSED(sizeY);
00143         PX_UNUSED(sizeZ);
00144         PX_UNUSED(densitySizeMultiplier);
00145         PX_UNUSED(flameSizeMultiplier);
00146         return false;
00147     }
00148 };
00149
00150 PX_POP_PACK
00151
00152 }
00153 } // end namespace nvidia
00154
00155 #endif // TURBULENCE_RENDER_CALLBACK_H
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: VelocitySourceActor.h File Reference

  • File List
  • File Members
Classes | Namespaces
VelocitySourceActor.h File Reference
#include "Apex.h"
#include "Shape.h"

Go to the source code of this file.

Classes

class | nvidia::apex::VelocitySourceActor
Turbulence VelocitySource Actor class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: VelocitySourceActor.h Source File

  • File List
  • File Members
VelocitySourceActor.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef VELOCITY_SOURCE_ACTOR_H
00030 #define VELOCITY_SOURCE_ACTOR_H
00031
00032 #include "Apex.h"
00033 #include "Shape.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 class VelocitySourceAsset;
00041
00042
00046 class VelocitySourceActor : public Actor
00047 {
00048 protected:
00049     virtual ~VelocitySourceActor() {}
00050
00051 public:
00053     virtual VelocitySourceAsset*        getVelocitySourceAsset() const = 0;
00054
00056     virtual void                        setEnabled(bool enable) = 0;
00057
00059     virtual bool                        isEnabled() const = 0;
00060
00062     virtual bool                        intersectAgainstAABB(PxBounds3) = 0;
00063
00065     virtual  Shape*                     getShape() const = 0;
00066
00068     virtual BoxShape*                   getBoxShape() = 0;
00069
00071     virtual SphereShape*                getSphereShape() = 0;
00072
00074     virtual float                       getAverageVelocity() const = 0;
00075
00077     virtual float                       getStdVelocity() const = 0;
00078
00080     virtual PxMat44                     getPose() const = 0;
00081
00083     virtual void                        setVelocity(float averageVelocity, float stdVelocity) = 0;
00084
00086     virtual void                        setPose(PxMat44 pose) = 0;
00087
00089     virtual void                        setCurrentScale(float scale) = 0;
00090
00092     virtual float                       getCurrentScale(void) const = 0;
00093
00094     virtual void                        release() = 0;
00095 };
00096
00097
00098 }
00099 } // end namespace nvidia
00100
00101 #endif
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: VelocitySourceAsset.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
VelocitySourceAsset.h File Reference
#include "Apex.h"
#include "CustomBufferIterator.h"

Go to the source code of this file.

Classes

class | nvidia::apex::VelocitySourceAsset
Turbulence FieldSampler Asset class. More...
class | nvidia::apex::VelocitySourceAssetAuthoring
Turbulence FieldSampler Asset Authoring class. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex

Defines

#define | VELOCITY_SOURCE_AUTHORING_TYPE_NAME "VelocitySourceAsset"

Define Documentation

#define VELOCITY_SOURCE_AUTHORING_TYPE_NAME "VelocitySourceAsset"
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: VelocitySourceAsset.h Source File

  • File List
  • File Members
VelocitySourceAsset.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef VELOCITY_SOURCE_ASSET_H
00030 #define VELOCITY_SOURCE_ASSET_H
00031
00032 #include "Apex.h"
00033 #include "CustomBufferIterator.h"
00034
00035 #define VELOCITY_SOURCE_AUTHORING_TYPE_NAME "VelocitySourceAsset"
00036
00037 namespace nvidia
00038 {
00039 namespace apex
00040 {
00041
00042 class TurbulenceFSActorParams;
00043 class TurbulenceFSActor;
00044 class TurbulenceFSPreview;
00045
00049 class VelocitySourceAsset : public Asset
00050 {
00051 protected:
00052     virtual ~VelocitySourceAsset() {}
00053 };
00054
00055
00059 class VelocitySourceAssetAuthoring : public AssetAuthoring
00060 {
00061 protected:
00062     virtual ~VelocitySourceAssetAuthoring() {}
00063 };
00064
00065
00066 }
00067 } // end namespace nvidia
00068
00069 #endif // VELOCITY_SOURCE_ASSET_H
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: VelocitySourcePreview.h File Reference

  • File List
  • File Members
Classes | Namespaces
VelocitySourcePreview.h File Reference
#include "Apex.h"
#include "AssetPreview.h"

Go to the source code of this file.

Classes

class | nvidia::apex::VelocitySourcePreview
This class provides the asset preview for APEX VelocitySource Assets. More...

Namespaces

namespace | nvidia
namespace | nvidia::apex
Generated on Sat Dec 1 2018 10:19:03


APEX TurbulenceFS Module: VelocitySourcePreview.h Source File

  • File List
  • File Members
VelocitySourcePreview.h
Go to the documentation of this file.
00001 //
00002 // Redistribution and use in source and binary forms, with or without
00003 // modification, are permitted provided that the following conditions
00004 // are met:
00005 //  * Redistributions of source code must retain the above copyright
00006 //    notice, this list of conditions and the following disclaimer.
00007 //  * Redistributions in binary form must reproduce the above copyright
00008 //    notice, this list of conditions and the following disclaimer in the
00009 //    documentation and/or other materials provided with the distribution.
00010 //  * Neither the name of NVIDIA CORPORATION nor the names of its
00011 //    contributors may be used to endorse or promote products derived
00012 //    from this software without specific prior written permission.
00013 //
00014 // THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY
00015 // EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00016 // IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00017 // PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00018 // CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00019 // EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00020 // PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00021 // PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
00022 // OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
00023 // (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00024 // OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00025 //
00026 // Copyright (c) 2018 NVIDIA Corporation. All rights reserved.
00027
00028
00029 #ifndef VELOCITY_SOURCE_PREVIEW_H
00030 #define VELOCITY_SOURCE_PREVIEW_H
00031
00032 #include "Apex.h"
00033 #include "AssetPreview.h"
00034
00035 namespace nvidia
00036 {
00037 namespace apex
00038 {
00039
00040 PX_PUSH_PACK_DEFAULT
00041
00045 class VelocitySourcePreview : public AssetPreview
00046 {
00047 public:
00048     public:
00050     virtual void    drawVelocitySourcePreview() = 0;
00052     virtual void    setScale(float scale) = 0;
00053
00054 protected:
00055     VelocitySourcePreview() {}
00056 };
00057
00058
00059 PX_POP_PACK
00060
00061 }
00062 } // namespace nvidia
00063
00064 #endif // VELOCITY_SOURCE_PREVIEW_H
Generated on Sat Dec 1 2018 10:19:03


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Clothing Module »

Module Documentation

Introduction

The APEX Clothing Module provides an easy way to do real time character clothing. An animated mesh can be transformed into a simulated piece of cloth. Without much artist’s effort it flutters in the wind, produces wrinkles and physically interacts with the animated character and its environment.

The clothing module consists of a run time component and an authoring pipeline to create clothing assets. The run time component simulates a physics mesh, skins a graphics mesh to it and provides a flexible interface for rendering. It also includes an LoD mechanism to enable adaptive scaling of the computation effort depending on both platform and current scene setup. The authoring pipeline consists of an API to create and author assets in a custom tool. Ready to use tools are provided that implement this authoring API. Such tools are the plug-in to Autodesk Max and Maya and a standalone ClothingTool.

Animation and Simulation

Clothing is an essential part of a realistic and believable game character. Animating every little detail of the complex motion of a garment is nearly impossible. Also animation is not flexible enough to cope with physically simulated environments, for example in combination with a character ragdoll. The answer to that is the physical simulation of the cloth itself. However, just wrapping a simulated cloth mesh around an animated character does not lead to good results. The reason is that clothes are usually quite strongly constrained to the body that is wearing them. Normal cloth simulation in combination with collision volumes will not create these kinds of constraints. The Hybrid Clothing approach used in the APEX Clothing Module combines animation and simulation techniques to overcome these problems.

Hybrid Clothing

APEX Clothing gives an artist complete control over the animation of his character and at the same time takes the burden of animating the complex details of cloth motion. The idea is to take an animated character and add the simulation on top. The starting point to Hybrid Clothing involves just the normal components to character animation:

  • An animated character skeleton
  • A rendered graphics mesh that is skinned to the skeleton

Tools are provided to create a physics meshes from the given graphics mesh. The part of the character that is chosen to be simulated cloth is not directly skinned to the animation skeleton anymore. Instead a few steps are performed to constrain the physics mesh to the animation (see illustration below). The created physics mesh is skinned to the animated skeleton. This provides the region within each vertex of the simulated cloth is allowed to move. After simulation the graphics mesh is transformed with the simulated physics mesh. This step is called mesh-mesh skinning.

Cloth Simulation

As mentioned above the simulated vertices are constrained to a region around their skinned positions. The artist can define how much each vertex is allowed to move by painting the maximal allowed distances (Max Distance) onto the mesh. An additional collision sphere can be defined by the artist to further reduce the freedom of the simulated vertex (see section Backstop).

Blue points on line: physics mesh after skinning

Green points on line: physics mesh after simulation

Transparent circle: Max Distance sphere within which the vertex is allowed to move

Red circle: Backstop sphere

Run Time

The ClothingAsset contains all the data coming from the authoring pipeline. It holds the information about bones, the physical mesh(es), the graphical mesh(es), the mapping between the two, the mapping between multiple physical meshes and Clothing material parameters.

The ClothingActor is an instance of the ClothingAsset. It is placed into a scene where it is simulated and rendered. The actor state is updated with the character animation that is provided with the current bone transformations. This will update the skinned positions of the physical mesh as well as the collision volumes that clothing will collide with.

Time stepping

For clothing to behave correctly, the timing has to be treated with some care:

  • When using variable timesteps with differing simulation deltas, the cloth stretchiness can vary drastically. The strength of this effect depends on variance of the timestep sizes. This is very noticeable and highly undesired. When using the Hard Stretch Limitation this effect can be worked around to a certain degree, but in general it is advised to use fixed timesteps. (consult PhysX docs regarding PxScene::setTiming() or PxSceneDesc::timeStepMethod)

    This also affects other Cloth features such as bending etc., but by far not as noticeable as the stretching.

  • When using fixed timesteps simulation deltas that are not the substep size this will lead to multiple substeps per simulation call. Multiple substeps can lead to some jittering in the clothing due to the fact that there is no new animation data for the second substep. The simulation now sees the animation in stop and go. One substep it’s different from the previous one, the next step is not. This makes it very difficult to have consistent vertex velocities.

To summarize, the best scenario is using fixed timesteps with a constant simulation delta. This is in fact identical to using variable timesteps with a constant simulation delta.

Adaptive Target Frequency

As a countermeasure to the first problem with variable timesteps, the Adaptive Target Frequency has been created. This feature adapts the per-cloth gravity slightly. In practice a single value is very hard to find or the difference between target frequency and simulation frequency can get quite large leading to unrealistic simulation artifacts.

As a solution, the target frequency is computed as the average over the real last N (normally 60) simulation steps. This will still allow the cloth to stretch more or less depending on the timestep size, but it will be much less noticeable.

Authoring

The above diagram shows the work-flow to create a clothing asset. The graphics mesh is represented in the RenderMeshAssetAuthoring class. It contains the vertex buffers needed for rendering and also takes the buffers that can be painted on the mesh and are needed later in the clothing module. The render mesh asset is the main input for all the authoring paths. It is stored as the mesh to be rendered in setMeshes. It also serves as input to the creation functions of the physics mesh. There are three different paths to create such a physics mesh:

  • Single Layered Mesh

    The graphics mesh is simple enough to be directly used as a simulation mesh (immediate clothing) or the simulation mesh can be derived through simplification.

  • Multi Layered Mesh

    The physical mesh is created from an intermediate ClothingIsoMesh. It can either create a triangle mesh (cloth) or a tetrahedral mesh (softbody) to be simulated. The iso-mesh provides the functionality of simplification and contraction to create the physical mesh from the iso-surface.

  • Custom Mesh

    The user provides his own mesh directly.

See section ‘Clothing Types’ for more details about the different paths.

Several graphics meshes can be provided for different graphical LoD levels. For each graphical LoD a different physical mesh can be provided. This enables better immediate clothing for each graphical LoD. It is also possible to use the same physical mesh for different graphical LoDs.

Painting Channels

The painting channels contain values that have to be painted by an artist onto the graphics mesh. The values will be interpolated to the physics mesh when the mapping between the meshes is created in the ClothingAssetAuthoring class.

Max Distance

The Max Distance channel defines for each simulated vertex how far it is allowed to move away from its skinned position.

Collision Radius

Collision radius > 0 turns on Backstop for a vertex. The radius defines the size of the collision sphere. See section ‘Backstop’ for more details.

Collision Distance

The collision distance will move the collision sphere inwards, I.E. against the mesh normal. This only has an effect if the collision radius for that vertex is > 0 and a collision sphere exists. If the collision distance is zero the collision sphere exactly touches the skinned position. This means the simulated vertex will collide against the skinned position. Negative values will move the collision sphere outwards. See section ‘Backstop’ for more details.

Master / Slave (Latch-To-Nearest)

Master and Slave are two separate painting channels containing a 32-bit mask. The information of these two arrays belongs together but contains two pieces of information.

  • The slave mask per vertex contains the information whether a vertex is allowed to be simulated. Any vertex with an active slave mask will be excluded from the simulation mesh.
  • The master mask contains the information which slave vertices may be attached to a particular triangle. Only if the master and slave masks overlap the mesh-to-mesh skinning attachment will be generated.

This is a generalization of the on/off painting channel in Apex 1.0. The first information was already contained in the boolean channel, but sometimes the slave vertices would attach to the wrong part of the mesh, usually in places of complex geometry. The master/slave combination allows to express which slave vertices can attach to which master vertices, giving full control to the artist working on these meshes. At the same time it will not be necessary to use it if the vertex-to-triangle attachment is already correct - therefore not increasing the work for clothing that do not suffer from this problem.

Clothing Types

There are several different approaches to put a simulated cloth onto an animated character. The approach that has to be chosen depends on the type and resolution of the graphics mesh that is supposed to be simulated. This chapter explains the different possibilities and explains when to use which approach.

Immediate Clothing

Directly Simulate the Graphics Mesh

Immediate Clothing is the simplest approach to character clothing. The physics mesh is directly created from the graphics mesh. The two meshes match up exactly and no expensive skinning is needed. However this means that either the rendered graphics mesh has to have a relatively low resolution or the physics simulation becomes very expensive. Also the garment should consist of a single layer, as cloth self-collision is too expensive to be used in real time.

Skinned Clothing

The physically simulated mesh does not need to be identical to the originally animated graphics mesh of the character. Instead a simpler physics mesh can be simulated and drive the more detailed rendered graphics mesh. This graphics mesh is updated by a ‘Mesh-Mesh Skinning’ step where the higher resolution graphics mesh is skinned to the lower resolution physics mesh after simulation.

There are different ways to create a lower resolution simulation mesh from the graphics mesh. Either the simulation mesh is derived directly from the graphics mesh, or an intermediate iso-surface is created to handle more complicated cases.

Simplify Graphics Mesh

The following algorithms are provided to derive a lower resolution physics mesh from a graphics mesh:

Welding

Graphical meshes often have duplicated vertices for texture rendering. This is not suitable for a physically simulated mesh where the mesh topology is essential. In a welding step all graphics vertices that are at the same position are merged into one single simulation vertex.

Simplification

A high resolution graphical mesh can be reduced to a lower resolution physical mesh by removing edges.

Hole Closing

Closing holes can help to get a better physical behavior.

Vertex Selection

It is possible to select a subset of the graphical mesh to specify the physical mesh. This can be used to discard parts of a mesh that are not suited for simulation, such as sleeves or double layers of cloth that would cause self-collisions.

The blue line shows the graphics mesh with the blue points as its vertices. Green vertices are selected for simulation, red vertices are discarded. The black points in the last image represent the physics mesh vertices. The discarded vertices of the graphics mesh will move with the closest simulated vertices through mesh-mesh skinning.

Physical Mesh from Iso-Surface

Direct creation of a physics mesh from the graphics mesh does not lead to good simulation results when the garment of the character has a more complicated structure than just a single layer of cloth. It is necessary to simulate such structures with a single simulation layer. An intermediate Iso-Surface can be created around the given graphics mesh to automatically generate a suitable simulation mesh.

Softbody Mesh

From the Iso-Surface a tetrahedral mesh can be generated to use in a softbody simulation. At run time the graphics mesh is skinned to the simulated softbody through mesh-mesh skinning. This works well because the tetrahedral mesh fully encloses the graphics mesh. Therefore the position of each graphical vertex can be described with the barycentric coordinates of a simulated tetrahedron.

Cloth Mesh

Alternatively a cloth triangle mesh can be derived from the iso-surface by contracting it to the medial surface. The skinning of the graphics mesh to the physics mesh only works well when the graphics vertices are close to the physics mesh.

This approach is currently still an experimental feature.

Provide Custom Mesh

Instead of deriving the simulated mesh from the graphical mesh, an artist can provide a custom created simulation mesh to which the graphics mesh is skinned during simulation. This allows complete flexibility to get a well behaving simulation mesh. Of course the quality of the mesh-mesh skinning highly depends on how well the physics mesh fits the graphics mesh.

Examples

a) MRH

b) MRL

a) Immediate Clothing

b) Single Layered Clothing using Mesh-Mesh Skinning

a) HO

b) HIMAX

c) HIMIN

d) HIT

a) Graphics mesh

b) High resolution iso-surface

c) Simplified iso-surface

d) Tetrahedral simulation mesh for softbody

Features

Physical LoD

Adaptive Max Distance

The cost for simulating a cloth depends linearly on the number of simulated vertices. In order to reduce this number when an actor in a scene is far away and is there not so important, the ClothingActor can decrease the Max Distance of the simulated vertices. Triangles that consist of vertices that have all vertices with a Max Distance less or equal to zero do not need to be simulated anymore.

The effect of this mechanism is that by decreasing the level of detail, regions that are allowed to move the least are replaced by animation first. When the camera is close the actor, for example, it is shown in its full detail, but from far away only those parts are still simulated that can actually be distinguished from the normal animation.

The Max Distance are blended smoothly between different LoD levels. It is possible to define the velocity of the Max Distance adaptation.

Reducing Solver Iterations

The cost of a vertex increases linearly with its solver iteration count. A specified simulation budget limits the total simulation cost, I.E. the sum of the simulation mesh vertices multiplied by their solver iteration count.

The physical behavior of a physics mesh changes with different numbers of solver iterations. Reducing solver iterations increases the stretchiness of the cloth. To counter that, the ClothingActor reduces the Max Distance of the cloth vertices at the same time.

Physical LoD Algorithm

see also Updating Actor Benefit for LoD in the Programmers Guide for Details on how the benefit can be set.

Physical LoD is a way of giving Resources to individual Clothing Actors based on a maximal resource budget for the entire scene.

  1. Each APEX Scene has a resource budget that can be changed for machines and platforms with various capabilities.
  2. Each Clothing Actor will have a benefit.
  3. Resources are given to the Actors with with higher benefit.
  4. Some Clothing Actors with more than one Physical LoD provide a set of configurations that require different amounts of resources. Depending on the relative benefit of two actors the LoD system will chose to run both actors at lower Physical LoDs instead of turning on one completely and the other one off.
  5. Transitions between physical LoDs is smooth and governed by the blend time.
  6. A Clothing Actor with zero benefit will be turned off immediately to free the resources as quickly as possible.

A Clothing Actor that is not simulated comes at almost zero overhead, unless the fallback skinning is activated.

Graphical LoD

Usually there are different levels of detail for the meshes of a game character. The APEX clothing assets and actors are able to handle that case. At authoring time each graphical level of detail is provided to the asset together with a matching physical mesh.

It is possible to use the same physical mesh for all graphical levels of detail. This implies that only one graphical LoD can do immediate clothing, I.E. graphical and physical vertices match up exactly. If that approach is used one has to be careful to account for the mesh-mesh skinning effort needed for LoDs without immediate clothing.

Alternatively a physical mesh can be provided for each graphical mesh. This enables immediate skinning for each graphical LoD. The switch between different physical meshes happens seamlessly by interpolating the mesh states between the different LoDs.

At run time the game engine tells the clothing actor at which graphical LoD it wants the actor to be rendered. This gives full control to the game engine about how many triangles are rendered for a character at all times. The graphical LoD is specified in dispatchRenderResources of the actor. Because APEX needs to know which physical mesh to use when skinning the vertices, this has only an effect for the next render call, so there is a one frame delay for switching graphical LoDs.

Graphical LoD vs Physical LoD

There are two orthogonal concepts of LoD in the APEX Clothing Module. Graphical LoD is completely controlled by the game engine. It specifies which graphical mesh is supposed to be rendered and how the corresponding simulated physical mesh looks like.

In addition to that the Physical LoD coexists. It dynamically scales down Max Distance if necessary in order to reduce the size of the simulated mesh for the current graphical LoD. This is based on actor priorities and a per scene simulation budget provided by the game engine.

Rendering

The application renders the simulated part of the animated character by implementing the APEX render interface, while the rest of the character is completely handled by the application.

There are two states of the ClothingActor that need to be rendered:

  • The actor is completely simulated. Vertices are provided at their global position, already skinned.
  • The actor is completely animated. Vertices are provided at their bind pose and bone matrices are provided for GPU skinning.

Collision with the Character

Collision Volumes

As the ClothingActor creates an Cloth or an Softbody it just interacts with any other object in the same PhysX scene. To prevent the simulated clothing from penetrating with the rest of the animated character there needs to be a collision representation of the animated character.

Stored in the Asset

It is possible to store collision volumes directly in the Clothing Assets. Convexes and Capsules can be specified to create collision representation for a character. The Clothing Actor creates instances of those volumes in the physics scene and moves them automatically with the bone skeleton.

Controlled by the Game Engine

Any tool for ragdoll creation, such as the PhysX plug-ins for Autodesk Maya or 3D Studio Max, can be used to create that collision volumes. If the game engine creates those collision volumes, they need to be kept in sync with the animation.

A ragdoll however does not necessarily provide the right collision volumes for clothing collision. Most of the time, ragdoll collision volumes are notably larger than the shape of the ragdoll to prevent any penetration at all costs. This will not look very good for clothing if the cloth is expected to stay within a certain distance of the character.

Also most pieces of cloth only need collision on a reduced set of bones. Collision volumes are expensive and should be minimized in numbers as much as possible.

This can lead to several synchronization problems.

  • Out of sync due to clothing frame delay. When certain optimization flags are set, additional and artificial frame delays are created. The collision volumes need to be updated with the correct frame delay too.
  • It is very important to choose when to call setGlobalPose and moveGlobalPose on Actors. This is non-trivial and will introduce strange effects for certain cases.

All these issues are solved automatically by the Clothing Actor if the collision volumes are stored in the asset.

Simulation Cost

Collision of cloth against convex shapes is relatively time consuming. Therefore it is recommended to use capsules or Backstop (see chapter Backstop) whenever possible. If convexes are needed it is good to make them as simple as possible, as the simulation cost is proportional to the number of convex planes.

Backstop

Sometimes it is difficult to provide a rigid body collision representation for the animated character that fits well over the entire animation. In particular it needs to be very detailed at regions on the character where the cloth mesh is always close to the body, authored to just create small wrinkles. The APEX Clothing Module provides an alternative way to do efficient collision of the simulated mesh with the character.

The idea is to use a sphere under the skinned position of a physics mesh vertex to collide with. A simulated vertex is allowed to move inside a sphere with radius Max Distance that is centered at its skinned position (blue circle in the illustration below). The skinned vertex positions are animated according to the skeleton bones of the character. Backstop defines an additional sphere that further restricts the motion of the simulated vertex (red circle). Two parameters that can be painted for each vertex define Backstop: collision radius and collision distance. Collision radius > 0 enables Backstop for that vertex. It should be some value bigger than Max Distance to prevent the vertex from just passing by the Max Distance-sphere on the side. The collision distance allows moving the collision sphere up or down the mesh normal. Positive collision distance moves the sphere inwards against the normal, a negative value displaces it outwards along the normal. To prevent the (blue) motion area from becoming too small when moving the collision sphere outwards, the Max Distance sphere is also moved along the normal.

a) ABS

b) ABSP

c) ABSN

The images above show an example for one vertex of a physics mesh. The black dots are the vertices at their skinned position. The simulated vertex is allowed to move within the blue circle that shows the Max Distance. The red circle represents the collision sphere that is defined by collision radius and collision distance. The simulation can move the vertex within the blue region.

  1. CollisionSphereDistance = 0:

    Collision sphere touches the skinned position.

  2. CollisionSphereDistance > 0:

    Collision sphere is displaced inwards against the normal.

  3. CollisionSpheredistance < 0:

    Collision sphere and Max Distance sphere are displaced outwards along the normal.

Simulation Normals

Simulation Normals are the direction in which Backstop collision is applied. Max Distance Bias is also affected by the simulation normals. They are valid even for tetrahedral meshes since they are not generated from mesh topology.

Simulation Normals from Graphical Mesh

The normals of the physical mesh are taken from the closest graphical vertex where the physics on/off channel is painted to ‘on’. When having a multi-layered cloth the outer layer can be painted as ‘on’ such that all the normals of the physical mesh will point outwards.

Derive Simulation Normals from Bones

Alternatively there is an option to derive the normals from the bones. A physical vertex will derive the normal from the line between the closest point on the bone segments it is attached to the strongest. The bone segments are the lines that connect the bones to their children.

This option enables easy generation of normals that point outwards, even if the mesh is very complicated, like for hair for example. Normals that point outwards are essential if Backstop is used.

Rendering Normals

The normals generated for rendering vary on what skinning method is used to map the graphical vertex onto the physical mesh.

  • Immediate Skinning

    The normal will be exactly the normal of the simulated mesh.

    Note

    When vertices were merged to form a connected simulation mesh, all the lighting features created through multiple normals per vertex will be gone unless the normals are fully recomputed.

  • Mesh-Mesh Skinning

    The normal as well as the vertex positions get a barycentric coordinate within one of the implicit tetrahedrons. The normal will then be the normalized difference between the normal position and the vertex position.

    Note

    This can lead to some artifacts if the graphical mesh has a much higher resolution than the simulation mesh or the graphical mesh is spatially separated from the physical mesh.

  • Tetra Skinning

    Similar to Mesh-Mesh Skinning, the normal is also stored as the position of the vertex plus the normal.

Recompute Normals at Run Time

When the result of the direct rendering normal generation is not good enough, normals can be fully recomputed after all the skinning took place. This can get rid of some artifacts, but at the same time will make any seam visible, even if a vertex gets split into two only because of texture coordinates.

Normals will be fully recomputed if the flag ClothingFlag::RECOMPUTE_NORMALS is set.

Tangent Space

If the RenderMesh that was sent to the Clothing Asset contains tangents and bi-tangents, the tangent space has to be updated. An algorithm has been implemented to do so, but if it doesn’t fit the needs a custom callback can be implemented to update the tangent space the way the game engine expects them.

Cloth Behavior

There are a different number of settings that influence the behavior of the cloth.

Gravity

Gravity accelerates the cloth vertices. Note that the gravity multiplier parameter changes the mass of the cloth and the vertices. If lowered it will to some degree generate a cloth that feels like a very light fabric with large air resistance.

Topology of the Simulated Cloth

The Resolution of the cloth has a big impact on the behavior. The Higher the resolution with a constant solver iteration count, the more stretchy a cloth becomes. The cloth solver needs to propagate forces further through the mesh. Also bending stiffness has a stronger impact when fewer triangles are simulated.

Solver Settings

There are different solver settings that impact the quality of the simulation result. With more solver iterations the result is closer to the initial state of the cloth. The behavior is therefore stiffer.

The hierarchical solver in the PhysX SDK helps to converge faster. The number of hierarchy levels and the number of hierarchical solver iteration can be specified additionally to the normal cloth solver iterations.

Hard Stretch Limitation

Even with the hierarchical solver the cloth still behaves a bit stretchy. In combination with clothing the PhysX SDK provides the Hard Stretch Limitation feature to create cloth that limits the stretching of the cloth completely by creating a projection tree starting at vertices that have Max Distance = 0.

Stiffness parameters

The parameters that control cloth stretchiness explicitly:

  • Stretching Stiffness: Strength of the cloth distance constraint
  • Bending Stiffness: Strength of the cloth bending constraint (angle between neighboring triangles)
  • Hard Stretch Limitation Factor: Controls the threshold when Hard Stretch Limitation kicks in

Damping

Normal cloth damping reduces the relative velocities between the cloth vertices. This reduces oscillations and makes the simulation more stable. The look of the cloth becomes more ‘viscous’ the more damping is used.

Alternatively COM Damping can be used. This version damps the cloth vertex velocities relative to the frame of the center of mass. This makes the cloth behave more like a piece of metal sheet.

For most clothing pieces the COM Damping is of limited use.

Ortho Bending

If Ortho Bending is enabled the bending constraints are stronger, but the simulation is more expensive.

Collision Thickness

The thickness parameter is used for the collision of the cloth with rigid bodies.

Self-Collision Thickness

Self-Collision enables a collision test between all the vertices of the cloth. The vertices are represented by a sphere with radius of size thickness that is specified in the asset. A bigger thickness reduces the problem of self-entangling the cloth. However setting the thickness too high prevents the cloth from making small wrinkles.

Self collision comes with noticeable performance overhead.

2-Way Interaction

When the cloth is supposed to apply forces to rigid bodies, 2-way interaction has to be enabled. For example this is necessary if the cloth is supposed to slow down rigid bodies that hit the cloth, in order to make it look heavy.

If 2-way interaction is disabled the rigid bodies will just push away the cloth without being affected.

Max-Distance Bias

This will shrink the Max-Distance sphere. If the bias is negative the sphere will become a capsule until at a bias of -1 is reduced to the normal. If the bias is positive, the sphere is gradually reduced to a disc in the tangential plane.

Debug Visualization

The APEX Clothing Module provides different debug visualizations for the Clothing Actors.

Click here for a list of the Clothing debug visualization parameters

For general information on how to use debug visualization within APEX, please see Debug Visualization.

Skinned Positions

SkinnedPositions

Max Distance

MaxDistance
MaxDistanceInwards

Backstop

BackstopPrecise

Collision

CollisionShapes
CollisionShapesWire

Mesh-Mesh Skinning

Only one of these 3 flags will be rendered even if more of them are turned on. Top most will be favored.

SkinMapAll
SkinMapBad
SkinMapActual

Physical Mesh

PhysicsMeshWire
PhysicsMeshSolid
PhysicsMeshNormals

Bones/Animation

Skeleton
BoneFrames
BoneNames

Velocities

Velocities

Per Vertex Skinning Information

GraphicalVertexBones
PhysicalVertexBones

Serialization

The clothing module uses the generalized parameterized object from the APEX framework.

Parameterized Objects

The key concept is to give the user the freedom to create its own serialization classes. The Clothing Assets data can be accessed and then iterated.

A sample implementation is included with APEX and is implemented in the ClothingTool. This sample implementation can generate 2 different file types:

  • .apx

    The xml file represents the entire hierarchy in xml tags. This is a verbose format, but great for debugging and very well human readable. File size is about 3 times bigger than binary.

  • .apb

    Platform specific binary representation. For the matching platform this can even be deserialized in-place. ParamTool can convert between any .apx and .apb files and generate them for each platform.

APEX Streams

This method of serialization (.aca files) was deprecated in Apex 1.0 and is no longer available. Vital files of this format need to be converted to .apx/.apb using Apex 1.0 ParamTool. All versions of parameterized objects can be imported into the latest version of Apex.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Clothing Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Clothing Module »

Programmers Guide

Contents:

  • Introduction
    • Overview
      • Classes
      • Runtime Usage
      • Main Loop
      • Errors and Warnings
  • Runtime Interfaces
    • Initialization
    • Loading the Clothing Module
    • Loading Assets
      • Loading Assets the NRP way
      • Loading Assets the NvParameterized way
      • Loading Assets the old way
    • Instantiating Actors
      • Clothing Preview
    • Stepping the Simulation
      • Updating Actor Benefit for LoD
      • Distribution of simulation resources
      • Turning off the automatic LOD
      • Updating the Animation State
      • Updating the Max Distance Scale
      • Remap Bone Indices
      • Use Internal Bone Order
      • Frame Delay
      • Wind
      • Rendering With Render Proxy
      • Rendering
    • Implementing the Render Interface
      • A simple scenario
    • Buffered calls & Multithreading
    • Using Morph Targets (also known as Blend Shapes)
    • Colliding with the Environment
  • Authoring Interfaces
    • Initialization
    • Graphical Mesh
    • Physics Mesh
      • Singlelayer Cloth
      • Multilayer Clothing Cloth
      • Custom Physics Mesh
    • Creating the Clothing Asset Authoring Object
      • Binding the Graphical and the Physical Mesh
      • Adding Information about Bones
      • Adding Misc Parameters
    • Scaling at Export
    • Saving & Loading the Asset
      • The parameterized way
    • Progress Listener

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Clothing Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Clothing Module »
  • Programmers Guide »

Authoring Interfaces

Different tools are provided to create and author clothing assets that can be loaded at run time. There are plug-ins to the DCC tools Autodesk Maya and 3DS Max and also the standalone ClothingTool that shows how to implement the authoring interface of the Clothing Module. The diagram below shows the work-flow to create a clothing asset. See the clothing module documentation for a more detailed description. This chapter explains the work-flow to create a Clothing Asset taking the ClothingTool as an example.

Initialization

Like for the run time part first an PxPhysics object, a reference to the cooking library, and the APEX objects ApexSDK and ModuleClothing have to be created as a starting point:

#include <NvParamUtils.h>

    // init PhysX
PxPhysics* m_physxSDK;
PxFoundation* m_foundation;
m_foundation = PxCreateFoundation(PX_PHYSICS_VERSION, ...);
m_physxSDK = PxCreatePhysics( ... );
PxInitExtensions(*m_physxSDK);

// init cooking
PxCookingParams params;
PxCooking* m_cooking;
m_cooking = PxCreateCooking(PX_PHYSICS_VERSION, m_physicsSDK->getFoundation(), params);

// init apex sdk
nvidia::apex::ApexSDKDesc apexSdkDesc;

// Let Apex know about our PhysX SDK and cooking library
apexSdkDesc.physXSDK = m_physxSDK;
apexSdkDesc.cooking = m_cooking;

// The output stream is used to report any errors back to the user
apexSdkDesc.outputStream = mErrorReport;

// Our custom render resource manager
apexSdkDesc.renderResourceManager = mRenderResourceManager;

// Our custom named resource handler (NRP)
apexSdkDesc.resourceCallback = mResourceCallback;

// Apex needs an allocator and error stream.
// By default it uses those of the PhysX SDK.
apexSdkDesc.allocator = mApexAllocator;

// Finally, create the Apex SDK
ApexCreateError errorCode;
mApexSDK = nvidia::apex::CreateApexSDK(apexSdkDesc, &errorCode);

// init clothing module
mApexClothingModule = static_cast<nvidia::apex::ModuleClothing*>(mApexSDK->createModule("Clothing"));

if (mApexClothingModule != NULL)
{
    NvParameterized::Interface* moduleDesc = mApexClothingModule->getDefaultModuleDesc();

    // This optimization is only needed for run time, we turn it off for authoring
    NvParameterized::setParamU32(*moduleDesc, "maxUnusedPhysXResources", 0);

    mApexClothingModule->init(moduleDesc);
}

// init conversion module
// this module is only needed to convert older parameterized assets to the latest one
mApexClothingLegacyModule = static_cast<nvidia::apex::ModuleClothing*>(mApexSDK->createModule("Clothing_Legacy"));

Graphical Mesh

APEX uses the RenderMeshAsset as a container for graphics meshes. To provide the graphics mesh of the part of the character that is going to be simulated, an RenderMeshAssetAuthoring class has to be created. For that a descriptor has to be filled:

nvidia::apex::RenderMeshAssetAuthoring::MeshDesc meshDesc;

// a mesh desc must contain one or more submeshes
nvidia::apex::RenderMeshAssetAuthoring::SubmeshDesc submeshDesc;

meshDesc.m_numSubmeshes = 1;
meshDesc.m_submeshes = &submeshDesc;

The mesh has one submesh for each different material name it uses:

// fill out the submeshDesc
submeshDesc.m_numVertices = mVertices.size();

// each submeshDesc must contain one or more vertex buffers
nvidia::apex::RenderMeshAssetAuthoring::VertexBuffer vertexBufferDesc;

submeshDesc.m_materialName = "Submesh Name";
submeshDesc.m_vertexBuffers = &vertexBufferDesc;
submeshDesc.m_numVertexBuffers = 1;

submeshDesc.m_primitive = nvidia::apex::RenderMeshAssetAuthoring::Primitive::TRIANGLE_LIST;
submeshDesc.m_indexType = nvidia::apex::RenderMeshAssetAuthoring::IndexType::UINT;

submeshDesc.m_vertexIndices = &mIndices[0];
submeshDesc.m_numIndices = mIndices.size();
submeshDesc.m_firstVertex = 0;

// we don't use parts for clothing meshes
submeshDesc.m_partIndices = NULL;
submeshDesc.m_numParts = 0;

// set the culling mode
submeshDesc.m_cullMode = nvidia::apex::RenderCullMode::CLOCKWISE;

A vertex buffer stores all vertex related data for that particular submesh:

// add position
vertexBufferDesc.setSemanticData(   nvidia::apex::RenderVertexSemantic::POSITION,  // the semantic
                                    &mVertices[0],                                  // the raw data pointer
                                    sizeof(physx::PxVec3),                          // the raw data stride
                                    nvidia::apex::RenderDataFormat::FLOAT3);       // the raw data format

// [...] similar for normals/tangents/bitangents

// add texcoords
vertexBufferDesc.setSemanticData(   nvidia::apex::RenderVertexSemantic::TEXCOORD0,
                                    &mTexCoords[0],
                                    sizeof(nvidia::apex::VertexUV),
                                    nvidia::apex::RenderDataFormat::FLOAT2);

// add bones
vertexBufferDesc.setSemanticData(   nvidia::apex::RenderVertexSemantic::BONE_INDEX,
                                    &mBoneIndices[0],
                                    sizeof(PxU16) * 4,
                                    nvidia::apex::RenderDataFormat::USHORT4);

vertexBufferDesc.setSemanticData(   nvidia::apex::RenderVertexSemantic::BONE_WEIGHT,
                                    &mBoneWeights[0],
                                    sizeof(physx::PxF32) * 4,
                                    nvidia::apex::RenderDataFormat::FLOAT4);

Add custom buffers to add painting information.

Here the buffers MAX_DISTANCE, COLLISION_SPHERE_DISTANCE, COLLISION_SPHERE_RADIUS and USED_FOR_PHYSICS are added. It is important that the strings that define the custom buffer match exactly these names:

nvidia::apex::RenderSemanticData customBufferSemanticData[4];

// this is for max distance
customBufferSemanticData[0].data = &mMaxDistance[0];
customBufferSemanticData[0].stride = sizeof(float);
customBufferSemanticData[0].format = nvidia::apex::RenderDataFormat::FLOAT1;
customBufferSemanticData[0].ident = "MAX_DISTANCE";

// these two are for backstop
customBufferSemanticData[1].data = &mCollisionSphereDistance[0];
customBufferSemanticData[1].stride = sizeof(float);
customBufferSemanticData[1].format = nvidia::apex::RenderDataFormat::FLOAT1;
customBufferSemanticData[1].ident = "COLLISION_SPHERE_DISTANCE";

customBufferSemanticData[2].data = &mCollisionSphereRadius[0];
customBufferSemanticData[2].stride = sizeof(float);
customBufferSemanticData[2].format = nvidia::apex::RenderDataFormat::FLOAT1;
customBufferSemanticData[2].ident = "COLLISION_SPHERE_RADIUS";

// this one is also known as latch-to-nearest
customBufferSemanticData[3].data = &mUsedForPhysics[0];
customBufferSemanticData[3].stride = sizeof(unsigned char);
customBufferSemanticData[3].format = nvidia::apex::RenderDataFormat::UBYTE1;
customBufferSemanticData[3].ident = "USED_FOR_PHYSICS";

// can add multiple custom semantics to one vertex buffer
vertexBufferDesc.setCustomSemanticData(customBufferSemanticData, 4);

finally, create the render mesh asset authoring:

renderMeshAsset = static_cast<nvidia::apex::RenderMeshAssetAuthoring*>(_mApexSDK->createAssetAuthoring(RENDER_MESH_AUTHORING_TYPE_NAME));

// and apply the descriptor
renderMeshAsset->createRenderMesh(meshDesc, true);

The last parameter in createRenderMesh() creates another custom buffer that contains all the original indices. This allows the application to track where the vertices have been re-shuffled.

Physics Mesh

Now everything is ready for the essential part of the clothing authoring pipeline. A physics mesh has to be provided that is simulated at run time. This simulation mesh can be derived from the graphics data in different approaches or a custom mesh can be provided.

Singlelayer Cloth

With the singlelayer approach the graphics mesh is directly copied and eventually adapted to suit the purpose of cloth simulation:

mApexPhysicalMesh = mModuleClothing->createSingleLayeredMesh(
                        mApexRenderMeshAssetAuthoring, // the RenderMeshAssetAuthoring
                        mSubdivision,                  // the amount of subdivision
                        mWeldVertices,                 // weld vertices together
                        mCloseHoles,                   // close holes in the physical mesh
                        &progress                      // Progress listener
                        );

The createSingleLayeredMesh call returns the pointer to an ClothingPhysicalMesh object. The parameters define if subdivision, vertex merging and hole-closing is supposed to be applied. Also the on/off channel on the graphics mesh (it is stored in the RenderMeshAssetAuthoring object) is considered to choose a subset of the graphics mesh.

The physics mesh provides a simplification algorithm to reduce the number of mesh vertices and triangles:

mApexPhysicalMesh->simplify(subdivSize, maxSteps, -1, &progress);

There is a special case called immediate clothing approach which uses the same mesh for physics as well as for graphics. This requires that the mSubdivision parameter (in createSingleLayeredMesh) is set to 0 and no simplification was used. This has the advantage that mesh-mesh skinning is not necessary.

Multilayer Clothing Cloth

The multilayer approach first creates an intermediate isosurface from the graphics mesh:

mApexIsoMesh = mModuleClothing->createMultiLayeredMesh(
                   mApexRenderMeshAssetAuthorings, // the RenderMeshAssetAuthoring
                   mSubdivision,                   // the amount of subdivision
                   mRemoveInternalMeshes,          // Only keep the largest isomesh
                   &progress                       // Progress listener
                   );

The iso-mesh provides a simplify method. It is highly recommended to simplify the very dense iso meshes. It will improve the quality and speed of the subsequent algorithmic steps:

mApexIsoMesh->simplify(mIsoSimplificationSubdiv, SIMPLIFICATOR_MAX_STEPS, -1, &progress);

Softbody

With the softbody approach a tetrahedral mesh is generated from the iso-mesh:

mApexPhysicalMesh = mApexIsoMesh->generateSoftbodyMesh(mInternalsSubdiv, &progress);

Cloth

The multilayer clothing approach with cloth simulation uses the intermediate iso-surface to derive a triangle mesh from the graphics mesh. The iso-surface is contracted to transform the volumetric surface to a flat triangle mesh:

PxReal volume = mApexIsoMesh->contract(
                    mIsoContractionSteps, // contraction iterations
                    0.01f,                // abortion ratio
                    true,                 // edge expansion after each iteration
                    &progress             // progress listener
                    );

The physics cloth mesh is then generated from the contracted iso-surface:

mApexPhysicalMesh = mApexIsoMesh->generateClothMesh(
                        20,       // remove bubbles up to this size
                        &progress // progress listener
                        );

When doing so you can end up with a mesh that has bubbles, small pieces where the mesh has two layers, which is bad for the cloth simulation. Such bubbles can be detected and will be removed if its number of faces is smaller or equal to the number provided in the function call.

After that the physical mesh can be simplified again:

mApexPhysicalMesh->simplify(subdivSize, maxSteps, -1, &progress);

Custom Physics Mesh

The ClothingTool does not implement the creation of a custom physics mesh. However the Clothing Module provides means to do it, and it is possible using the Maya plug-in.

There is an interface in the ModuleClothing class to create an empty ClothingPhysicalMesh:

mApexPhysicalMesh = mModuleClothing->createEmptyPhysicalMesh();

Then the cloth or softbody mesh can be created by providing a vertex and an index buffer to that physical mesh:

mApexPhysicalMesh->setGeometry(
                       isTetraMesh,
                       numVertices,
                       vertexByteStride,
                       vertices,
                       numIndices,
                       indexByteStride,
                       indices
                       );

Creating the Clothing Asset Authoring Object

The ClothingAsset is the container that combines graphical and physical meshes as well as additional information together. The -Authoring version of this class is needed to actually carry out the combination:

// Any unique name is ok
mApexClothingAssetAuthoring= mModuleClothing->createAssetAuthoring(CLOTHING_AUTHORING_TYPE_NAME, "The authoring asset");

Binding the Graphical and the Physical Mesh

Having created a graphical mesh and physical mesh, they can now be given to the clothing asset authoring object:

mApexClothingAssetAuthoring->setMeshes(
                                 lod,                           // the graphical lod number of the graphical/physical mesh pair
                                 mApexRenderMeshAssetAuthoring, // the RenderMeshAssetAuthoring
                                 mApexPhysicalMesh,             // the ClothingPhysicalMesh
                                 numPhysicalLods,               // size of the array of max distances
                                 physicalLodValues,             // an array of max distances to chop up the physical mesh
                                 &progress                      // progress listener
                                 );

At that point the mapping between the physics and the graphics mesh is created. Also the painting channels are interpolated from the graphical mesh onto the physical mesh.

The meshes are provided together with an LoD value. At run time the game engine can ask the asset to be rendered and simulated with the specified LoD.

In addition to that there is a physical LoD. Optionally a list of values can be provided that specify how much the Max Distances are reduced for different physical LoDs. This specifies which triangles are simulated based on the Max Distance painting of the asset.

Adding Information about Bones

The asset also needs some information about the bones that are used to modify this particular asset. This includes a name, the bind pose and a parentIndex.

mApexClothingAssetAuthoring->setBoneInfo(boneIndex, boneName, bonePose, boneParent);

Additionally, a collision representation can be added to each bone as well.

Note

All the information has to be already in the bone pose space!

// clear all bone collision
mApexClothingAssetAuthoring->clearAllBoneActors();

// a bone can only have either convex collision or capsule collision
mApexClothingAssetAuthoring->addBoneConvex(boneIndex, vertices, numVertices);

// a capsule can have a transform relative to the bone pose
mApexClothingAssetAuthoring->addBoneCapsule(boneIndex, capsuleRadius, capsuleHeight, localPose);

Adding Misc Parameters

Some of the parameters for the Cloth and Softbody that are not already in the ClothingMaterial (such as thickness, self collision thickness, self collision flag, untangling flag) are given to the asset. There is a collection of methods called ClothingAssetAuthoring::setSimulation*(). These values will be constant for the asset and all its actors.

Scaling at Export

To export a parameterized object with scale, a copy of the ClothingAssetAuthoring has to be made and then scaled before serialization:

void serializeWithScale(float scale)
{
    NvParameterized::Interface* copyFrom = mClothingAssetAuthoring->getNvParameterized();
    NvParameterized::Interface* copyTo = mApexSdk->getParameterizedTraits()->createNvParameterized(copyFrom->className());
    PX_ASSERT(copyFrom && copyTo);
    copyTo->copy(copyFrom);

    nvidia::apex::ClothingAssetAuthoring* tempObject = static_cast<nvidia::apex::ClothingAssetAuthoring*>(mApexSdk->createAssetAuthoring(copyTo, "tempObject"));

    physx::PxMat44 id = physx::PxMat44::getIdentity();
    tempObject->applyTransformation(id, scale, true, true);

    serialize(tempObject->getNvParameterized());

    tempObject->release();
}

Saving & Loading the Asset

The clothing asset authoring object is now completely set up and ready to be serialized. There are two ways of serializing an asset. The first

The parameterized way

Every Asset implements the getNvParameterized() method. This will return an object with full reflection. It’s up to the game engine how to serialize this to memory or disc. Sample implementations are provided using the NvParameterized::Serializer class:

 bool saveParameterized(const char* filename, ClothingAsset* asset)
 {
     NvParameterized::Interface* paramObject = asset->getNvParameterized();
     PX_ASSERT(paramObject != NULL);

     NvParameterized::Serializer::SerializeType serializerType = NvParameterized::Serializer::NST_LAST;

     const char* ext = getExtension(filename);

     if (!strcmp(ext, "apx"))
         serializerType = NvParameterized::Serializer::NST_XML;
     else if (!strcmp(ext, "apb"))
         serializerType = NvParameterized::Serializer::NST_BINARY;

     PX_ASSERT(serializerType != NvParameterized::Serializer::NST_LAST)

     physx::PxFileBuf* fileBuffer = mApexSDK->createStream(filename, physx::PxFileBuf::OPEN_WRITE_ONLY);
     if (fileBuffer != NULL)
     {
         if (fileBuffer->isOpen())
         {
             NvParameterized::Serializer* serializer = mApexSDK->createSerializer(serType);
             NvParameterized::Serializer::ErrorType serError = NvParameterized::Serializer::ERROR_NONE;

             serError = serializer->serialize(*fileBuffer, paramObject, 1);
             PX_ASSERT(serError == NvParameterized::Serializer::ERROR_NONE);
         }

         fileBuffer->release();
         fileBuffer = NULL;
     }
}

Vice versa, the game engine has to load the parameterized object prior to create a clothing asset. This is the same code as for creating run time assets. The only difference is to create an authoring asset instead:

nvidia::apex::AssetAuthoring* loadParameterized(const char* fullpath)
{
    nvidia::apex::AssetAuthoring* result = NULL;
    NvParameterized::Serializer::DeserializedData deserializedData;

    // A FileBuffer needs to be created.
    // This can also be a customized subclass of physx::PxFileBuf
    physx::PxFileBuf* fileBuf = mApexSDK->createStream(fullpath, physx::PxFileBuf::OPEN_READ_ONLY);

    if (fileBuf != NULL)
    {
        if (fileBuf->isOpen())
        {
            char peekData[32];
            stream->peek(peekData, 32);

            // The returns either Serializer::NST_BINARY or Serializer::NST_XML
            NvParameterized::Serializer::SerializeType serType = mApexSDK->getSerializeType(peekData, 32);

            NvParameterized::Serializer* serializer = mApexSDK->createSerializer(serType);

            NvParameterized::Serializer::ErrorType serError = NvParameterized::Serializer::ERROR_NONE;
            serError = serializer->deserialize(*fileBuf, deserializedData);

            // do some error checking here
            if (serError != NvParameterized::Serializer::ERROR_NONE)
                processError(serError);

            serializer->release();
        }
        fileBuf->release();
    }

    // Now deserializedData contains one or more NvParameterized objects.
    for (unsigned int i = 0; i < deserializedData.size(); i++)
    {
        NvParameterized::Interface* data = deserializedData[i];
        printf("Creating Asset of type %s\n", data->className());

        if (result == NULL)
        {
            result = mApexSDK->createAssetAuthoring(data, "some unique name");
        }
        else
        {
            // we have to handle files with multiple assets differently, for now, let's get rid of it
            deserializedData[i]->destroy();
        }
    }

    return result;
}

Progress Listener

A lot of the functions in the authoring pipeline take some processing time. They provide a way to show a progress bar during the calculation. The nvidia::apex::IProgressListener interface can be implemented to get callbacks that report the current processing status.

It is perfectly valid to pass NULL for the progress listener:

MyProgressListener progress;
mApexClothingAssetAuthoring->setMeshes( /* all the params */ , &progress);

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Clothing Module »
  • Programmers Guide »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Clothing Module »
  • Programmers Guide »

Introduction

Overview

Classes

The APEX Clothing module primarily deals with the following kinds of objects:

  • ModuleClothing
    • Main hook to the clothing module
  • ClothingAsset
    • Created through the clothing asset authoring pipeline
    • Contains all information to simulate and render one clothing piece
  • ClothingActor
    • Instance of a clothing asset
  • ClothingPreview
    • Like an ClothingActor without simulation

In case of writing a custom authoring tool, the following objects are involved additionally:

  • ClothingAssetAuthoring
    • Creates, edits and serializes clothing assets that can be loaded from a stream at runtime
  • ClothingIsoMesh
    • Intermediate class for the multi layered clothing approach
  • ClothingPhysicalMesh
    • Holds the physics mesh for the simulation
    • Provides mesh simplification
  • RenderMeshAssetAuthoring
    • Part of the APEX framework
    • Used to give graphics meshes to the clothing module
  • RenderMeshBuilder
    • Input to the RenderMeshAssetAuthoring
    • Has to be sub classed and implemented to create the mesh triangles
  • RenderMeshPartData
    • Input to the RenderMeshAssetAuthoring
    • Clothing Asset uses just one part

Deprecated classes

These classes have been deprecated because they are no longer needed. The Material Library has been merged into the ClothingAsset. They are still here for compatibility.

The biggest need for the ClothingMaterialLibrary is to load old .acml files. Whenever you create an ClothingAsset from an old .aca file, it will try to load the referenced .acml file immediately through the NRP.

  • ClothingMaterialLibrary
    • Is an Asset
    • Contains ClothingMaterials
    • Created by loading a stream from ClothingMaterialLibraryAuthoring
    • Referenced by name in the ClothingAsset
    • Gets requested through the named resource provider
  • ClothingMaterialLibraryAuthoring
    • Is an AssetAuthoring
    • Allows adding and removing individual materials
    • Creates and serializes a list of ClothingMaterials
  • ClothingMaterial
    • Stores settings for cloth behavior

Runtime Usage

After loading an ClothingAsset it can be used to instance an ClothingActor from it. A clothing actor simulates exactly one piece of cloth in a scene. It is important that each component of the character is synchronized at all times. Components of a character are:

  • Graphics mesh of the non-simulated part of the character

  • Clothing actor for the simulated part of the character

  • Rigid body collision representation of the character
    • A rigid body skeleton can be stored in the ClothingAsset. It will then be animated with the character automatically by APEX.

  • Animated character bones

Graphics mesh, simulation mesh and rigid body skeletons are all skinned and transformed with the character bone poses when the character is animated.

Main Loop

Roughly the main loop contains the following steps:

  1. Set current LoD settings (not all of this needs to be in the main loop)
    • Scene::setViewMatrix
    • ( Actor::forceLod )
  2. Feed global pose and the current bone poses to the ClothingActor
    • ClothingActor::updateState
  3. Simulate the APEX Scene
    • Scene::simulate
    • Scene::fetchResults
  4. Render the non-simulated part of the character
    • Skin and render through game engine
  5. Render APEX actors
    • RenderDataProvider::lockRenderResources
    • Renderable::updateRenderResources
    • Renderable::dispatchRenderResources
    • RenderDataProvider::unlockRenderResources

Errors and Warnings

Some methods that are deprecated also emit a PxErrorCode::eINVALID_PARAMETER.

PxErrorCode | MESSAGE | Explanation
eINVALID_PARAMETER | <name> is not a valid descriptor class | A clothing actor or asset preview has been created with a wrong descriptor.
eINVALID_PARAMETER | windAdaption must be bigger or equal than 0 | Wind adaption cannot be negative!
eINVALID_PARAMETER | Index must be smaller than materials array | Index out of bounds for setting the clothing material.
eINVALID_PARAMETER | boneMatrices[i] is not finite! | The i’th matrix in the clothing actor descriptor has one or more non-finite elements.
eINVALID_PARAMETER | globalPose is not finite! | The global pose from the clothing actor descriptor is not finite.
eINVALID_PARAMETER | lodWeights must be >= 0 | One or more lodWeight values in the clothing actor descriptor is negative.
eINVALID_PARAMETER | maxDistanceBlendTime must be positive | The maxDistanceBlendTime in the clothing actor descriptor is negative.
eINVALID_PARAMETER | maxDistanceScale.Scale ust be in the [0, 1] interval | The maxDistanceScale.Scale parameter is smaller than 0 or bigger than 1.
eINVALID_PARAMETER | windParams.Adaption must be positive or zero | Wind adaption cannot be negative in the clothing actor description.
eINVALID_PARAMETER | shapeDesc.flags.SF_DISABLE_SCENE_QUERIES must be false when using non-compartment CPU cloth | Scene Queries must not be disabled on non-compartment cloth because they are used internally to determine which Actors are colliding with the cloth.
eINVALID_PARAMETER | ClothingActorDesc is invalid | The clothing actor descriptor is not valid.
eINVALID_PARAMETER | Skew on matrices is not allowed, aborting | A matrix with skew (determinant != 1) has been detected. Invalid input.
eINVALID_PARAMETER | newBindPosesCount must be bigger than n | Not enough new bindposes were provided.
eINVALID_PARAMETER | Max Distance at vertex %d (submesh %d) must be >= 0 or equal to invalid | An invalid painting value has been detected. Max Distances must not be negative unless they are equal to the invalid value.
eINVALID_PARAMETER | The NvParameterized::Interface object is of the wrong type | The Clothing Module was initialized with a descriptor of the wrong type.
eINVALID_PARAMETER | RenderMeshAssetAuthoring has more than one part | For Clothing, the requirement on render mesh assets are exactly 1 part.
eINVALID_PARAMETER | Mesh has no active vertices (see Physics on/off channel) | A render mesh asset has been added to a clothing asset authoring that does not have a single Max Distance value larger than 0.
eINVALID_OPERATION | updateRenderResources needs to be called before dispatchRenderResources. | ClothingActor::dispatchRenderResource() has been called before ClothingActor::updateRenderResource().
eINVALID_OPERATION | ClothDesc/SoftBodyDesc is invalid (error code <c>) | ClothDesc::checkValid() or SoftBodyDesc::chcekValid() returned an error code.
eINVALID_OPERATION | PxScene::createCloth/SoftBody() returned NULL | Cloth/SoftBody was not created by the scene.
eINVALID_OPERATION | Cloth/SoftBody Mesh generation failed, asset won’t be useable | ClothMesh/SoftBodyMesh was not created, maybe a cooking error?
eINVALID_OPERATION | Cannot simplify a tetrahedral mesh | ClothingPhysicalMesh::simplify() cannot be called on a tetrahedral mesh.
eINTERNAL_ERROR | Cannot create ClothingActor while simulation is running | ClothingAsset::createActor() was called while the simulation was running. Scene::fetchResults() must be called first.
eINTERNAL_ERROR | Cannot release ClothingActor while simulation is still running | ClothingActor::release() was called while the simulation was running. Scene::fetchResults() must be called first.
eINTERNAL_ERROR | Render mesh asset does not have either position or normal for submesh i | A Render Mesh asset must have positions as well as normals to be used by clothing.
eDEBUG_INFO | The asset does not contain a bone with name <name> | ClothingAsset::remapBone() was called on a non existing bone.
eDEBUG_WARNING | numMatrices too big | ClothingActor::updateState() was called with a matrix array that is too big. Some matrices were ignored.
eDEBUG_WARNING | No Clothing Material Library present in asset | The corresponding ClothingAsset does not contain a material library. This is an error state.
eDEBUG_WARNING | The asset contains n bones with name <name>. All occurences were mapped. | This happens when bone names are not unique. This could be considered an ill defined asset to start with, but it might still work more or less.
eDEBUG_WARNING | APEX Clothing physx::PxFileBuf serialization is obsolete. Use NvParameterized serialization. | Calling ClothingAsset::serialize() is not supported as of 1.0 anymore. Use the parameterized serialization instead.
eDEBUG_WARNING | Using substeps, this will cause problems with clothing! | Clothing is very time step sensitive. Using substeps will not allow it to progress the animated part in between the substeps. This can lead to jittery cloth.
eDEBUG_WARNING | ModuleClothingDesc.maxNumCompartments > 0! On consoles performance is worse when using compartments for cloth and softbodies | Cloth and Softbody simulation will be noticeably slower when using compartments on the console platforms!

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Clothing Module »
  • Programmers Guide »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Clothing Module »
  • Programmers Guide »

Runtime Interfaces

This chapter shows how to use the Clothing Module by explaining the essential part of the SimpleClothing sample application in APEX/samples. It shows how to load an asset, instance an actor, keep it synchronized with the character and render the simulated clothing part through the clothing actor.

Initialization

An APEX application needs to first initialize PhysX. In the following code samples it is assumed that a PhysX SDK has been created (see the PhysX documentation):

PxPhysics* m_physxSDK;
PxFoundation* m_foundation;
m_foundation = PxCreateFoundation(PX_PHYSICS_VERSION, ...);
m_physxSDK = PxCreatePhysics( ... );
PxInitExtensions(*m_physxSDK);

and that we have a cooking library:

PxCookingParams params;
PxCooking* m_cooking;
m_cooking = PxCreateCooking(PX_PHYSICS_VERSION, m_physicsSDK->getFoundation(), params);

After initializing the PhysX SDK, an APEX application needs to initialize the APEX SDK. See APEX SDK Documentation.

This is done as follows:

nvidia::apex::ApexSDKDesc apexSdkDesc;

// Let Apex know about our PhysX SDK and cooking library
apexSdkDesc.physXSDK = mPhysicsSDK;
apexSdkDesc.cooking = mCookingInterface;

// The output stream is used to report any errors back to the user
apexSdkDesc.outputStream = mErrorReport;

// Our custom render resource manager
apexSdkDesc.renderResourceManager = mRenderResourceManager;

// Our custom named resource handler (NRP)
apexSdkDesc.resourceCallback = mResourceCallback;

// Apex needs an allocator and error stream.
// By default it uses those of the PhysX SDK.
apexSdkDesc.allocator = mApexAllocator;

// Finally, create the Apex SDK
ApexCreateError errorCode;
mApexSDK = nvidia::apex::CreateApexSDK(apexSdkDesc, &errorCode);

The render resource manager SampleApexRenderResourceManager is used. It is common to the APEX samples.

Also an Scene has to be created to hold APEX actors and renderables. It can be initialized with a PhysX scene:

// Create an APEX scene with a PhysX scene
nvidia::apex::SceneDesc sceneDesc;
sceneDesc.scene = mPhysxScene;
nvidia::apex::Scene* apexScene = mApexSDK->createScene( sceneDesc );

An APEX application then needs to create the APEX modules it will use.

Loading the Clothing Module

First the clothing module ModuleClothing is created:

mApexClothingModule = static_cast<nvidia::apex::ModuleClothing*>(mApexSDK->createModule("Clothing"));

Then it is initialized with an ModuleClothingDesc:

#include <NvParamUtils.h>
if (mApexClothingModule != NULL)
{
    NvParameterized::Interface* moduleDesc = mApexClothingModule->getDefaultModuleDesc();

    // Know what you're doing when playing with these values!

    // should not be 0 for every platform except PC.
    NvParameterized::setParamU32(*moduleDesc, "maxNumCompartments", 3);

    // Can be tuned for switching between more memory and more spikes.
    NvParameterized::setParamU32(*moduleDesc, "maxUnusedPhysXResources", 5);

    mApexClothingModule->init(moduleDesc);
}

ModuleClothingDesc holds the field maxNumCompartments that lets you define the number of PxCompartments to which the simulated cloth instances are supposed to be distributed. This is good to parallelize the CPU work of the cloth simulation for both CPU and GPU cloth.

Loading Assets

First a clothing asset (ClothingAsset) needs to be created or loaded. The clothing authoring tool (ClothingTool) or the PhysX plug-in for Autodesk Max and Maya can be used to create and save ClothingAssets.

Loading Assets the NRP way

This will get a callback to the NRP, much as if APEX requests a resource, allowing to gather all resource loading code in one place.

nvidia::apex::Asset* asset = reinterpret_cast<nvidia::apex::Asset*>(mApexSDK->getNamedResourceProvider()->getResource(nameSpace, fullname));
if( asset )
{
    mApexSDK->getNamedResourceProvider()->setResource(nameSpace, fullname, asset, true);
}

The NRP would look something like this:

void* MyResourceCallback::requestResource(const char *nameSpace, const char *filename)
{
    if( !strcmp(nameSpace, CLOTHING_AUTHORING_TYPE_NAME) ||
        !strcmp(nameSpace, <SOME OTHER TYPE>))
    {
        return loadParameterized(filename);
    }
}

Loading Assets the NvParameterized way

nvidia::apex::Asset* loadParameterized(const char* fullpath)
{
    nvidia::apex::Asset* result = NULL;
    NvParameterized::Serializer::DeserializedData deserializedData;

    // A FileBuffer needs to be created.
    // This can also be a customized subclass of physx::PxFileBuf
    physx::PxFileBuf* fileBuf = mApexSDK->createStream(fullpath, physx::PxFileBuf::OPEN_READ_ONLY);

    if (fileBuf != NULL)
    {
        if (fileBuf->isOpen())
        {
            char peekData[32];
            stream->peek(peekData, 32);

            // The method returns either Serializer::NST_BINARY or Serializer::NST_XML, or Serializer::NST_LAST for unknown files.
            NvParameterized::Serializer::SerializeType serType = mApexSDK->getSerializeType(peekData, 32);

            physx::Serializer* serializer = mApexSDK->createSerializer(serType);

            if (serializer != NULL)
            {
                physx::Serializer::ErrorType serError = NvParameterized::Serializer::ERROR_NONE;
                serError = serializer->deserialize(*fileBuf, deserializedData);

                // do some error checking here
                if (serError != NvParameterized::Serializer::ERROR_NONE)
                {
                    processError(serError);
                }

                serializer->release();
            }
        }
        fileBuf->release();
    }

    // Now deserializedData contains one or more NvParameterized objects.
    for (unsigned int i = 0; i < deserializedData.size(); i++)
    {
        NvParameterized::Interface* data = deserializedData[i];
        printf("Creating Asset of type %s\n", data->className());

        if (result == NULL)
        {
            result = mApexSDK->createAsset(data, "some unique name");
        }
        else
        {
            // we have to handle files with multiple assets differently, for now, let's get rid of it
            deserializedData[i]->destroy();
        }
    }

    return result;
}

Loading Assets the old way

Apex versions older than 1.0 used to have per asset file formats. In Clothing this was the .aca file. In the sample there is the function loadClothingAsset to load a stored aca file (Apex Clothing Asset) from disk. These files can no longer be loaded with Apex 1.1. They can be converted to .apx/.apb files using The ParamTool from Apex 1.0.

Instantiating Actors

The clothing assets can be instanced by creating clothing actors. A descriptor has to be provided to the creation function. The descriptor is a NvParameterized object:

#include <NvParamUtils.h>
#define VERIFY_PARAM(_A) { NvParameterized::ErrorType error = _A; PX_ASSERT(error == NvParameterized::ERROR_NONE); }

// Get the (singleton!) default actor descriptor.
NvParameterized::Interface* actorDesc = mAsset->getDefaultActorDesc();
PX_ASSERT(actorDesc != NULL);

// Run Cloth on the GPU
NvParameterized::setParamBool(*actorDesc, "useHardwareCloth", mGpuSimulation));
NvParameterized::setParamBool(*actorDesc, "flags.ParallelPhysXMeshSkinning", true);

// Initialize the global pose
NvParameterized::setParamMat44(*actorDesc, "globalPose", currentPose);

{
    NvParameterized::Handle actorHandle(*actorDesc);

    // No util method for this
    VERIFY_PARAM(actorHandle.getParameter("boneMatrices"));
    VERIFY_PARAM(actorHandle.resizeArray(skinningMatrices.size()));
    VERIFY_PARAM(actorHandle.setParamMat44Array(&skinningMatrices[0], skinningMatrices.size()));
}

// create the actor
nvidia::apex::Actor* apexActor = mAsset->createApexActor(*actorDesc, *mApexScene);
nvidia::apex::ClothingActor* clothingActor = static_cast<nvidia::apex::ClothingActor*>(apexActor);

doSomething(clothingActor);

Clothing Preview

Instead of creating clothing actors, it is also possible to create clothing previews:

NvParameterized::Interface* previewDesc = mAssets->getDefaultAssetPreviewDesc();
PX_ASSERT(previewDesc != NULL);

// Initialize the global pose
NvParameterized::setParamMat44(*previewDesc, "globalPose", currentPose);

nvidia::apex::AssetPreview* apexPreview = mAssets->createApexAssetPreview(*previewDesc);
nvidia::apex::ClothingPreview* clothingPreview = static_cast<nvidia::apex::ClothingPreview*>(apexPreview);

The clothing preview is basically the same as a clothing actor, except that there is no simulation running. So it is possible to show the animated version of the clothing actor without having an PxScene around. Updating the animation state and rendering works just like with the normal clothing actor (updateState, updateRenderResources and dispatchRenderResources).

Stepping the Simulation

When using an APEX application, the simulate and fetchResults functions of the PhysX scene need to be replaced by the corresponding simulate and fetchResults functions of the APEX scene. The APEX scene wraps the PhysX scene and ticks all the APEX actors additionally.

Note

This also applies to the checkResults method.

// start the simulation
mApexScene->simulate(dtime);

doSomethingInBetween();

// finish the simulation
physx::PxU32 errorState = 0;
mApexScene->fetchResults(true, &errorState);

Prior to the simulate call the actor state has to be updated.

Updating Actor Benefit for LoD

For each actor, the benefit is calculated according to this equation:

benefit = lodWeights.distanceWeight * angularImportance(distanceFromEye, assetRadius) + lodWeights.benefitsBias

The angularImportance function just linearly blends down from 1.0 to 0.0 basically measuring screen space size. The size is estimated as the amount the asset’s diagonal (assuming it’s a sphere) is covering across the screen.

If lodWeights.maxDistance is provided, the benefit will reach 0.0 once the actor has said distance, otherwise it will only reach 0.0 for infinitely far away actors.

The lodWeights.distanceWeight marks the importance of a clothing actor relative to others. Actors with a lower weight will be turned off more quickly even if they have the same maxDistance and distanceFromEye. A character having both hair and a cape should have the weight of the hair significantly lower than the weight of the cape as the cape is much more noticeable whether it’s being simulated.

distanceFromEye is the distance from the eye position, as computed in Scene::setViewMatrix() and the center of the bounding box of a clothing actor.

The lodWeights.benefitBias should be a value between 0.0 and 1.0. Benefit is defined as being in the [0.0, 1.0] range across all modules, however larger values still work, they just lead to proportionally larger amounts of simulation resources.

Note

The maxDistance parameter can be changed based on the fact whether a clothing actor is visible. Setting it to 0 for invisible characters however is not recommended at all since it takes a while to enable clothing again once it is disabled. Reducing the maxDistance to half for invisible actors can lead to good results though.

// requests the actors current configuration
// The object does not have to be returned, it is directly modified
NvParameterized::Interface* actorDesc = mActor->getActorDesc();

NvParameterized::setParamF32(*actorDesc, "lodWeights.maxDistance", maxDistance);
NvParameterized::setParamF32(*actorDesc, "lodWeights.distanceWeight", distanceWeight);
NvParameterized::setParamF32(*actorDesc, "lodWeights.benefitsBias", benefitBias);

Distribution of simulation resources

Simulation resources are an abstract unit. They are set through the Scene. Additionally two parameters need to be carefully chosen. The first describes the inter-module importance and the second describes how the abstract resources are then turned into resources allowing the clothing to decide whether it should simulate or not:

Scene* scene = getApexScene();
// assuming the abstract unit is milliseconds, giving the simulation 15ms to run
scene->setLODResourceBudget(15.0f);

ModuleClothing* clothingModule = getClothingModule();

// no special importance to clothing module (relative to other modules)
clothingModule->setLODBenefitValue(1.0f);

// This value needs to be carefully tweaked and will differ for different platforms (or even PC processors).
// Here we assume that each millisecond we can simulate 10'000 vertices.
clothingModule->setLODUnitCost(0.0001f);

Turning off the automatic LOD

This can be done either for the entire clothing module, or for each clothing actor separately:

ModuleClothing* moduleClothing = getClothingModule();

// turn off LOD for all clothing actors
moduleClothing->setLODEnabled(false);

for (unsigned int i = 0; i < getNumClothingActors(); i++)
{
    ClothingActor* clothingActor = getClothingActor(i);

    // turn off automatic LOD for this actor only
    clothingActor->forceLod(0);

    // turn on automatic LOD for this actor only
    clothingActor->forceLod(-1);
}

Updating the Animation State

When a character is animated the animation transforms have to be provided to the Clothing Actor:

physx::PxMat44 globalPose = getGlobalPose();
physx::PxMat44* boneMatrices = getBoneMatrices();
actor->updateState(globalPose, boneMatrices, sizeof(physx::PxMat44), getNumBoneMatrices(), isContinuous);

In updateState a global pose and the current state of the animation bones are provided. In the SimpleClothing sample the asset doesn’t have an animation skeleton, so just the pose is updated. The matrices to provide here are the same as the ones needed to specify the initial state in the ClothingActorDesc if you have animation on that mesh.

The isContinuous flag tells the actor if the motion is smooth or not. If it is set to true the normal simulation procedure is applied. Setting it to false marks a special frame in the animation where the character is teleported to a different location or orientation. In that case the clothing is reset to its animated, skinned state, replacing the simulation. If isContinuous is set to false multiple subsequent frames, it always forces the simulation to the animation and will look very awkward. The flag helps a lot whenever either animation cannot be blended every once in a while or a character is teleported.

Updating the Max Distance Scale

Each Clothing Actor can have an individually changing Max Distance Scale:

NvParameterized::Interface* actorDesc = mActor->getActorDesc();

NvParameterized::setParamF32(*actorDesc, "maxDistanceScale.Scale", scale);
NvParameterized::setParamBool(*actorDesc, "maxDistanceScale.Multipliable", multipliable);

The scale parameter must be in the [0,1] range and denotes the scale applied. The multipliable parameter switches between two modes of scale. Multipliable will multiply all max distances with the scale, otherwise the same fraction of the maximum Max Distance will be subtracted from all vertices, leading to some regions of the mesh not being simulated.

Remap Bone Indices

The function updateState takes an array of transformation matrices representing the current state of the animation skeleton. It is possible that the animation system and the internally stored bones in APEX do not have the same order. Therefore it can be necessary to map the list of animation matrices of the application to the bones stored in APEX using the remapBoneIndex function:

const std::vector<SkeletalBone>& bones = mSkeleton.getBones();
for (PxU32 i = 0; i < bones.size(); i++)
{
    mAsset->remapBoneIndex(bones[i].name.c_str(), i);
}

This needs to be done before the first updateState call.

Use Internal Bone Order

This is the orthogonal feature to Bone Index Remapping. The game engine will provide the skinning matrices in the same order as the Clothing Actor expects it, the same order as the bones are stored in the Clothing Asset.

It needs to be activated in the Clothing Actor Descriptor:

NvParameterized::Interface* actorDesc = mAsset->getDefaultNvParameterizedInterface();
PX_ASSERT(actorDesc != NULL);

NvParameterized::setParamBool(*actorDesc, "useInternalBoneOrder", true); // default is false

Then, the game engine needs to find out what bones are at what location:

const unsigned int boneNumber = mClothingAsset->getNumUsedBones();

for (unsigned int internalIndex = 0; internalIndex < boneNumber; internalIndex++)
{
    const char* boneName = mClothingAsset->getBoneName(internalIndex);

    // create a mapping table now
    // ...
}

This has the advantage that the updateState call can copy the matrices slightly more quickly. Also the number of bone matrices that need to be handed to the clothing actor is reduced to only the set of bones that are active within the clothing actor.

Frame Delay

When the simulation is updated serially in the usual order:
clothingActor->updateState(...)
scene->simulate(...)
scene->fetchResults(...)
clothingActor->updateRenderResources(...)
clothingActor->dispatchRenderResources(...)

there is no frame delay. The clothing actor is rendered corresponding to the matrices provided in the updateState call.

There will be a frame delay when the provided matrices are based on a rigid body simulation, and if these rigid bodies are simulated in the same scene as the cloth. An example for such a scenario would be clothing on a ragdoll, or a simulation based character controller.

There are two ways to handle such situations. One solution is to introduce a matching delay on all rendered objects, or at least on the character with clothing. The second approach is to simulate the cloth in a separate scene later in the frame. The advantages of the former solution are more parallelism and the possibility to simulate interactions with other objects in the scene. However such a frame delay is often hard to handle in a game engine and the latter approach is more practicable. A selection of objects that need to be interacted with can be mirrored into the clothing scene.

Wind

For clothing actors a wind vector can be set:

NvParameterized::Interface* actorDesc = mActor->getActorDesc();

NvParameterized::setParamVec3(*actorDesc, "windParams.Velocity", windVelocity);
NvParameterized::setParamF32(*actorDesc, "windParams.Adaption", windAdaption);

// This alternative code is deprecated with 1.1
mActor->setWind(windAdaption, windVelocity);

The windVelocity parameter represents the target velocity of the wind. Best results can be achieved when the velocity has a small random noise on top. The windAdaption parameter represents how quickly the cloth piece adapts to the wind velocity. With an adaption value of 1.0 it will take the piece of cloth at least 1s to adapt fully to the velocity. If it takes longer than 1s it means the cloth is not perpendicular to the wind direction. Increasing the adaption to 10 will reduce the time to 1/10s whereas lowering the paramter to 0.5 will increase the time to 2s.

Since the wind velocity and adaption is part of the actor descriptor it can be set before actor creation, and it can also be altered when the actor already exists.

Note

For better quality it is very much recommended to slightly vary the wind velocity in strength as well as in direction.

Even wind with zero velocity can be simulated, this will result in air resistance (still modulated by dot product between vertex normal and wind direction).

Note

APEX Clothing has its own implementation of wind. This is orthogonal to the wind module and will work just by itself.

Rendering With Render Proxy

A clothing actor can be rendered by acquiring a render proxy from it, getting the render data through updateRenderResources, and triggering the render callback with dispatchRenderResources. After all render calls are done, the render proxy needs to be released, so that the memory can be reused again. The acquirer of the render proxy has exclusive access to its data, so locking the render resources is not necessary. The render proxy can only be acquired once per frame, otherwise NULL is returned:

SampleApexRenderer apexRenderer;
ClothingRenderProxy* renderProxy = clothingActor->acquireRenderProxy();
if (renderProxy != NULL)
{
    renderProxy->updateRenderResources();
    renderProxy->dispatchRenderResources(apexRenderer);
    renderProxy->release();
}

The render proxy can be acquired at any time, even during simulate, and it contains the latest simulation result. Note that it is better to release the render proxy before the next simulate call so that the memory can be reused. Otherwise, a new render proxy is allocated to double buffer the result. That means it’s good to acquire and release the render proxy after every fetchResults, even if the actor is not rendered this frame.

An acquired render proxy contains valid data that stays unchanged until it is released. A render proxy also stays valid after its corresponding actor has been released. However, releasing the corresponding ClothingAsset will invalidate the render proxy.

It is safe to call updateRenderResources on the render proxy in parallel, for example in the render thread, if the APEX SDK parameter ‘renderMeshActorLoadMaterialsLazily’ is set to false.

Rendering

The old way of rendering a clothing actor is still supported. However note that this way the render data is always double buffered, which allows updateRenderResources to be called during simulate, but which also might waste memory if you don’t need the double buffering. Use the render proxy and release it before the simulate call in order to prevent that.

A clothing actor is rendered by updating the render resources, setting up a renderer and calling dispatchRenderResources with it. The Renderer is the same as for any other APEX module:

SampleApexRenderer apexRenderer;
actor->lockRenderResources();
actor->updateRenderResources();
actor->unlockRenderResources();

// dispatch could also be called later on!
actor->dispatchRenderResources(apexRenderer);

For general information on how to use debug visualization within APEX, please see Debug Visualization.

Implementing the Render Interface

As mentioned above a renderer needs to be set up for the clothing actor rendering. Together with the renderer a bunch of render interface classes need to be sub classed and implemented by the application. See the APEX Programmer’s Guide for details about the APEX render interface. The SimpleClothing sample uses the SampleApexRenderer that is common to the samples.

A simple scenario

These are the buffers typically created when rendering a clothing actor. The order of creation can vary.

The formats specified in this document are an example. For normals it’s also possible to have more compressed formats like BYTE_SNORM3, SHORT_SNORM3, or (in future versions) even a BYTE_SNORM4 containing a quaternion instead of the normal/tangent buffers.

As of Apex 1.2 the tangent is now an FLOAT4 and the binormal semantic is gone. The binormal can be reconstructed as cross(normal, tangent.xyz) * tangent.w but been reduced to a single float. This reduces computational overhead inside apex and less data going through the render API as well.

The hint flags indicate whether a buffer is updated frequently or once.

The fist vertex buffer is created from the clothing actor itself. It always contains a position and normal, and it can contain tangents and bi-normals. The formats are identical to the formats used by the render mesh asset:

createVertexBuffer
  hint                = DYNAMIC
  uvOrigin            = ORIGIN_BOTTOM_LEFT
  Buffers Requested:
    POSITION          = FLOAT3
    NORMAL            = FLOAT3
    TANGENT           = FLOAT4

The next 3 vertex buffers are created by the render mesh asset within the clothing asset. They are split into 3 different ones because the clothing actor only ever needs a subset of them depending on its state.

The first buffer contains all the identical semantics as the buffer from the clothing actor. This static buffer will only be used when the clothing actor is not being simulated, and the fallback skinning flag is not set:

createVertexBuffer
  hint                = STATIC
  uvOrigin            = ORIGIN_BOTTOM_LEFT
  Buffers Requested:
    POSITION          = FLOAT3
    NORMAL            = FLOAT3
    TANGENT           = FLOAT4

The second buffer contains the bone indices and bone weights weights if present. It will only be used when the clothing actor is not simulated and fallback skinning flag is not set:

createVertexBuffer
  hint                = STATIC
  uvOrigin            = ORIGIN_BOTTOM_LEFT
  Buffers Requested:
    BONE_INDEX        = USHORT4
    BONE_WEIGHT       = FLOAT4

The third buffer contains everything else including custom vertex buffers. As an example, VERTEX_ORIGINAL_INDEX is a buffer that contains old vertex indices from the authoring pipeline. This is the order of the vertices in which they were entered into the render mesh asset:

createVertexBuffer
  hint                = STATIC
  uvOrigin            = ORIGIN_BOTTOM_LEFT
  Buffers Requested:
    TEXCOORD0         = FLOAT2
  Custom Buffers Requested:
    VERTEX_ORIGINAL_INDEX = UINT1

The index buffer is fairly straight forward. The hint will remain on STATIC as long as clothing does not support tearing. The format will be one of UBYTE1, USHORT1 or UINT1, the primitives TRIANGLES and registerInCUDA will be false for the time being (as well as no interopContext).

createIndexBuffer
  hint           = STATIC
  format         = UINT1
  primitives     = TRIANGLES
  registerInCUDA = false
  interopContext = 00000000

The render resource will then contain two or more of these vertex buffers. The vertex semantics of those buffers will always be mutually exclusive:

createRenderResource
  Vertex Buffers:
   TEXCOORD0 VERTEX_ORIGINAL_INDEX
   POSITION NORMAL TANGENT

Buffered calls & Multithreading

The API in the Clothing Module is not thread safe. It is not allowed at any time to call two methods on the same or two different APEX objects.

Also, none of the calls inside the clothing module are buffered. For some methods it is safe to call them even while the simulation is running but these methods mention this fact explicitly. Any other method should not be called during simulation.

For example it is allowed to load assets while the simulation is running, but it’s not allowed to create actors from these assets while the simulation is running. Also it’s not allowed to load two assets at the same time.

Using Morph Targets (also known as Blend Shapes)

When characters need to be customized after being exported from DCC tools it is usually for MMO like character customization. These are done by blending between deformed meshes of the original character.

These changes have to be applied on the fly as there is no way to store all possible configurations as pre-backed asset files. Apex Clothing does this by allowing the game engine to provide the displacements of the original positions to each ClothingActor upon creation. It can’t be modified later on because the changes need to be cooked into the simulation mesh.

First, the asset needs to be aware which order those displacements will be applied. To do so, the original positions need to be passed to the asset such that it can create the mapping from external to internal ordering. This requires that the original positions have to be identical to the ones provided by the DCC tool at export time, including the same animation pose:

ClothingAsset* clothingAsset = getClothingAsset();

physx::PxF32 epsilon = 0.0f;

physx::PxU32 numMapped = clothingAsset->prepareMorphTargetMapping(&morphVertices[0], morphVertices.size(), epsilon);

if (numMapped < morphVertices.size())
{
    // The mapping still worked, but some vertices were mapped to an origianl vertex with more than epsilon differences.
    // Either bump the epsilon or, if too many failed, emit an error message about a potentially bad mapping
}

Second, upon actor creation the displaced vertices need to be passed through the actor descriptor:

NvParameterized::Interface* actorDesc = clothingAsset->getDefaultActorDesc();

// [...] Some initialization of the actorDesc

physx::PxU32 numMorphDisplacements = 0;
physx::PxVec3* morphDisplacements = NULL;
getMorphDisplacements(morphDisplacements, numMorphDisplacements);

if (numMorphDisplacements > 0)
{
    NvParameterized::Handle md(*actorDesc, "morphDisplacements");
    md.resizeArray(numMorphDisplacements);
    md.setParamVec3Array(morphDisplacements, numMorphDisplacements);
}

physx::Actor* actor = clothingAsset->createApexActor(*actorDesc, apexScene);

This actor will most likely not immediately start to simulate. It will cook the simulation mesh during the first couple of simulation frames in a background thread. This however can be modified by setting the allowAsyncCooking bool in the Clothing Module Parameters.

The convex volumes are also adapted as good as possible, however the capsule volumes are not. As long as the morph target is only applying moderate changes this is usually no problem.

It is still not allowed to have scales on certain bones.

Colliding with the Environment

The 3x cloth solver does not support automatic collision with a scene. Each clothing actor will just collide with its own collision volumes, specified in the clothing asset. If additional collision is required, for example to collide with the ground, there is an interface on the clothing actor to add this:

ClothingPlane*        createCollisionPlane(const PxPlane& plane)
ClothingConvex*       createCollisionConvex(ClothingPlane** planes, PxU32 numPlanes)
ClothingSphere*       createCollisionSphere(const PxVec3& position, PxF32 radius)
ClothingCapsule*      createCollisionCapsule(ClothingSphere& sphere1, ClothingSphere& sphere2)
ClothingTriangleMesh* createCollisionTriangleMesh()

Each of those collision objects provide functions to release, edit and position the objects.

To implement generic collision with the environment, a scene can be queried around the clothing actor and corresponding clothing collision objects can be created for the actor. Some bookkeeping is required to keep track of the mirrored objects, in order to update and release them in time.

ClothingTriangleMesh has a few limitations. It should be kept small for performance reasons, it should be closed (at least when including the bounding box of the cloth), and it is currently not possible to dynamically remove triangles from it. Therefore it is recommended to use planes or convexes to approximate collision with the ground.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Clothing Module »
  • Programmers Guide »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Clothing Module »

Clothing Tool

The clothing authoring tool, currently called ClothingTool, is a standalone GUI authoring tool for APEX clothing.

The main purpose of the tool is to take user-provided static or animated clothing meshes and allow an artist to specify how the clothing mesh should be simulated using APEX clothing. It also allows the user to playback animations and ensure that the clothing settings are properly selected. The result can be used to generate an APEX Clothing Asset file, which is used by the APEX run time component. The Asset filed contains all the information required in order to simulate a clothing mesh.

Besides exporting APEX file formats, the artist can save the workspace. The entire workspace can be saved into .ctw (“clothing tool workspace”) files. This allows the user to regenerate the APEX clothing asset files at any time.

Getting started

Run ClothingTool.exe. You should see this application

There are 6 different tabs in the main window:

Tab | Description
Input Mesh | Allows the user to load a graphics mesh and author the different sub meshes to enable PhysX clothing simulations.
Deformable Parameters | Provides the user control over PhysX clothing settings.
Single Layered Cloth | Allows the user to create and run PhysX clothing simulations as well as store the APEX clothing asset files (.aca)
Multilayer Cloth | Experimental Tab for multilayer cloth
Multilayer Softbody | Experimental Tab for softbody simulation
Simulation | Controls the simulation window for clothing and softbody simulations.

In addition there is the “View” window for different visualization effects

Tab | Description
Edit | Enable/disable different visualizations for the graphics mesh, skeleton, cloth and softbodies.
Simulation | Enable/disable different visualizations for the graphics mesh and the physics mesh.

Input Mesh

First an input mesh needs to be loaded. This is accomplished through the File/Open Workspace and File/Load Mesh menus. A workspace is a reference to a mesh with all the settings from the tool as it was last used.

There is support for a FBX and various export formats such as Ogre XML (.mesh.xml), EazyMesh (.ezm) and PSK (ActorX export).

Select Sub-mesh

The sub-mesh selection box allows the user to select the different authorable clothing sub-meshes. We recommend using different sub-meshes for different clothing areas to be simulated, e.g. a cape, hair, skirt, jacket, etc.

Each line corresponds to a meshname/materialname pair. Multiple ones may be selected to create one single Clothing Asset from.

Manipulating the View

Normal Viewing mode:

Key Combination | Description
Left-mouse-drag | The model will rotate around the y-axis
Middle-mouse-drag | The model will translate in the x-z plane
Right-mouse-drag | The model will zoom closer or farther (z-axis)

Painting mode:

Key Combination | Description
Left-mouse-drag | Paint value specified in “Painting -> Paint Value”
Right-mouse-drag | Paint value of 0 (disabled). The blue color means that the graphics mesh will only move based on the animation and not based on any physics simulations.
Mouse wheel | Allow the user to change the radius of the painting brush
ALT-Left-mouse-drag | The model will rotate around the y-axis
ALT-Middle-mouse-drag | The model will translate in the x-z plane
ALT-Right-mouse-drag | The model will zoom closer or farther (z-axis)

Simulation mode:

Key Combination | Description
Left-mouse-drag | The model will rotate around the y-axis (only if no clothing is picked)
Left-mouse-drag | Allows the user to move the physical clothing mesh
Middle-mouse-drag | The model will translate in the x-z plane
Right-mouse-drag | The model will zoom closer or farther (z-axis)

Paint Graphics Mesh

The paint tool allows the user to paint different clothing specific parameters on the graphical mesh. In order to enter to actually paint on the mesh the user has to select the painting mode from the Painting radio selection. As soon as the painting mode is active, the actual graphical wire-frame mesh will be visible and the mouse pointer will change to a circle.

There are currently three parameters:

  1. Max Distance

    • The maximum distance specifies how much a clothing particle can move from its animated position. The larger the maximum distance the more freedom the clothing particle has and the more it will move. The default value for the mesh is ‘blue’, which means all vertices will be animated and not simulated. The user can paint a value by specifying it in the ‘Paint Value’ Selector and painting the value by clicking on the left mouse button. Pressing the right mouse button will remove the painted value.

    • The clothing part which is attached to a rigid body should be painted disabled (blue) with the right mouse button. The ‘Smooth All’ button will never change the disabled values, but will change everything else to allow a gradual transition between different max distance values. The distance itself can be visualized by enabling the ‘Painting Visible (Vertices)’ in the ‘View::Edit’ window. The maximum distance can be quickly scaled up and down through the ‘Max Distance Scale’ slider.

    • The distance is visualized as a line along the vertex normal, but in simulation the vertex is allowed to move inside a sphere with this radius around the cloth particle. Visualizing the ‘Painting Visible (Vertices)’, allows the user to visualize roughly where and by how much a clothing vertex can move.

    • The Paint slider will vary between the min and max value selected. Coloring of the vertices will be black for all distances smaller than min and white for all distances larger than max. Blue remains for disabled values.

    • There is three brushes:
      • Flat will only paint connected parts of the mesh from where the mouse pointer hits
      • Volumetric will paint everything inside a sphere around the mouse pointer
      • Smooth is a variation of Flat which will not paint the vertices but smooth them.

    • Falloff allows to select whether the paint value should be applied to all vertices inside the brush directly (falloff = 0), linearly descending with distance (falloff = 1), quadratically with distance (falloff = 2) or something in between. The shape of the brush will display this.

    • The Histogram in the main window displays the distribution of max distance values.

    Note

    For proper clothing animation results, always ensure that the clothing mesh is attached to the character with a motion distance of 0 (blue) with a subset of vertices. This means it is effectively skinned to the character and won’t fall just down.

  2. Backstop

    • The Backstop is used for colliding the mesh with itself. It specifies how far a clothing particle can move based on the underlying animation. If neither Backstop nor Collision volumes are set for the character, the clothing mesh will only obey to gravity and ignore the shape of the character.
    • This can be easily avoided by enabling Backstop. A value of 0 will ensure that the physical clothing mesh can only move towards the positive normal of the animation mesh and therefore avoid penetration. A bigger value will allow the clothing mesh to penetrate the animation mesh slightly based on the configured value. The penetration can be made visible through the ‘Painting Visible (Vertices)’ checkbox in the View window. A value below 0 will add additional thickness between the animation mesh and the actual physical clothing mesh. The Backstop distance from the animation can be scaled with the ‘Collision Distance Scale’ slider.
    • Backstop is disabled for a vertex if the value is bigger than its Max Distance value.
    • The colors indicate the paint value. Black is disabled Backstop. White means collision distance is set to 0, aligning Backstop with the animation. Collision distance larger than zero goes from red to yellow, smaller than zero from blue to cyan.

    Backstop painted to zero (upper part only)

    Backstop painted positive/inwards (lower part only)

    Backstop painted negative/outwards (lower part only)

    BSZ

    BSZS Reverse Angle

    BSP

    BSPS Reverse Angle

    BSN

    BSNS Reverse Angle

  3. Physics On/Off

    • This painting mode can be used to disable physics simulation from part of the mesh. Only two values are possible, either 0, which means Physics is disabled or 1, which means Physics is enabled. By default the physics simulation is enabled.
    • This must not be confused with setting the max distance to 0. On/Off painting will remove vertices from the actual physical mesh and will skin them to the closest remaining simulated triangle.
    • This is particularly useful for small of multilayer pieces in a single layered cloth as for example pockets. The inner layer is fully simulated, the outer layer is just skinned to that simulation. This prevents from unnecessary simulation overhead as well as from simulation artifacts.

Sub-mesh Subdivision

The Clothing tool allows the user to subdivide a graphics mesh further through the ‘Modifications’ interface. Since the clothing physics mesh is generated based on the graphics mesh, subdividing the graphics mesh results in a higher tessellated physics mesh.

If the physics mesh tessellation is pretty high, it is recommended using the ‘Hard Stretch Limitation’ feature provided in the Clothing Material library

Culling

This is used to tell the tool and APEX how to cull a specific mesh. It applies for the entire mesh, and not just for a sub-mesh.

This information will be stored in the asset and given out through the Render API.

Histogram and multiple physics meshes

This will generate a multitude of physical meshes each a subset of all triangles. Additional meshes will have a smaller subset, containing only vertices of high max distance.

The additional physics meshes allow the APEX run time to switch between the different physics meshes when the allocated resources for clothing simulation are exceeded.

Each blue line in the Histogram will generate an additional physical mesh, based on the subset of vertices that have a max distance greater or equal to the blue line.

Histogram and painted Max Distance values | Physical LoD visualization
his1 | his2
Lod 1 | Lod 2 | Lod 3
pLod1 | pLod2 | pLod3

Generate collision volumes

The tool provides the capability to automatically generate primitive and/or convex collision volumes based on the ragdoll mesh. Select ‘Generate Collision Volumes’ which will open a new window for Collision Volume Generation.

The collision volume generation window provides a sub-mesh selection as well as a bone skeleton hierarchy. Only sub-meshes selected here (rendered in blue) will contribute to collision volume generation. One or more collision volumes can be created for each bone.

Automatic Generation

Each bone can have 3 different options for automatic geometry generation:

Include | All vertices that this bone references to with more than <Minimal Weight> weight will contribute to the collision volume
Exclude | This bone will not generate a collision volume.
Collapse

All vertices that this bone references to with more than <Minimal Weight> weight will contribute to the parents collision volume.

This works recursively: If the parent is also marked as ‘Collapse’ they will both collapse one more hierarchy level, until one parent is either marked as ‘Include’ or as ‘Exclude’. The later case will not create any collision geometry for all those bones.

The default value for every bone is ‘Include’. However if the bone name contains either ‘finger’ or ‘toe’ the default will be ‘Exclude’.

Each bone can either have a Convex or a Capsule collision volume.

  • The convex collision volume is generated by computing the convex hull from all the vertices gathered for a certain bone.
  • The capsule collision volume is generated by computing the best fit capsule for the gathered points.

The <Minimal Weight> value can be changed per bone which will trigger an auto update for that particular bone.

If at any state the auto update seems to produce wrong results, the ‘Build Collision’ button can be pressed for full regeneration.

Inflation

After automatic generation, each collision volume can be inflated (or deflated). For capsules this will just modify the radius, for convexes it will move their vertices.

Manual generation

When selecting a single bone, the collision volumes can be altered or even fully regenerated for that bone. Additional volumes can be added, and they can be moved and rotated as well as changed in size.

Note

For performance reasons it is highly recommended to use Backstop instead of collision volumes wherever possible. Also convex collision is notably slower than capsule collision.

Deformable Parameters

Static Parameters

  • Thickness

    Each Cloth Vertex will be simulated as a sphere with half this thickness as the radius. This allows the cloth vertex to keep a minimum distance off from any collision volume.

  • Self-collision Thickness

    When turning on self collision (see Flags section) each particle will be represented as a sphere. Colliding with other spheres will be more likely if they are bigger.

    As usual the rule is. Keep them as small as possible, but as big as needed.

  • Hierarchical Levels

    Number of hierarchical edges the Cloth will create. This is only applicable if the number of hierarchical solver iterations in the Clothing Material is set to larger than 0.

    Note

    Use with care. This will increase the cooking time significantly, use more memory and more CPU at run time. Hard Stretch Limitation might be a better alternative to try first.

Flags

  • Disable CCD

    Never use Continuous Collision Detection. Setting this is not recommended. The ClothingActor will take care when to use and not use this flag upon teleportation or similar situations where continuous collision is not desired.

  • Two-way Interaction

    Enables two-way coupling of clothing and dynamic rigid bodies. This is usually not necessary since regular clothing has very limited influence on most dynamic objects.

  • Self-collision

    Turn on self collision. See also Self Collision Thickness.

    Note

    This comes with some severe performance implications!

  • Untangling

    If self-collision could not prevent the cloth from entangling with itself

    Note

    This comes with big performance implications, use with absolute care!

Clothing Material

Material Libraries

This list box presents the list of all currently loaded clothing materials. Select one to display its list of materials in the next window.

Using the [+] and [-] buttons more material libraries can be added or released.

Materials

Display the list of Materials inside a Material Library. Select one to watch all the settings.

Using [+] and [-] buttons more materials can be added to or removed from the library. The [Select] button will select the current combination of library and material for the next clothing asset that is created.

Clothing material

A series of elements presenting all the contents of a clothing material

Stiffness

  • Stretching

    The amount of stretching an edge can compensate. This can be in the range (0.0, 1.0]

    Note

    If full stretching is not enough, use the Hard Stretch Limitation

  • Bending

    The amount of bending an edge can compensate. This can be in the range of [0.0, 1.0]

  • Ortho Bending

    Using a mathematically more correct version of bending. Comes at some performance cost and rarely with a gain in quality.

Inertia Settings

  • Damping

    Amount of constraint damping. This does not damp absolute velocity, only oscillations in edges.

  • COM Damping

    Damping relative to the Center Of Mass of the mesh. Behaves a bit like a metal plate, but does not work very well on characters.

  • Friction

    The amount of velocity that is removed when sliding over a surface.

  • Gravity Multiplier

    Affects the amount of gravity a cloth gets applied to. 0 means no gravity at all, 1 means regular gravity, larger than 1 means more than regular gravity.

    Note

    By setting this to some value between 0 and 1 the cloth will behave more similar to fabrics that are very light and have a high air resistance.

Misc

  • Solver Iterations

    Directly mapped to Cloth solver iterations. Higher number can reduce some stretching, but scales very linear with performance. A value of 5 is a good start, but if it also works with lower version, performance will be better.

  • Hard Stretch Limitation

    The amount of stretching that is permitted. 1 means no stretching is allowed at all. 1.1 means each edge can be extended up to 1.1 times its original length before this kicks in.

    Note

    Only a subset of all edges can be treated with hard stretch limitation. This can be visualized using the debug rendering flag.

  • Max Distance Bias

    Deforming the max distance sphere

    • [-1.0, 0) sphere is shrunk into a capsule until at -1 becomes the normal
    • (0, 1.0] sphere is shrunk into a disc until at 1 becomes a flat circle in the tangential plane.

  • Hierarchical Solver Iterations

    Amount of iterations done on the hierarchical mesh. This is a workaround for fixing high stretching. Must not be used in conjunction with the hard stretch limitation.

Single Layered Clothing

After the graphics mesh was edited, a physical clothing mesh can be generated by clicking on ‘Create’ in the ‘Use Input Mesh’ group. This will generate a green mesh, which is the physical clothing mesh.

The user can change the physical mesh and generate a higher resolution physics mesh through the subdivide feature or simplify the physical mesh through the ‘Modify Cloth Mesh’ group. If there are no changes to the physical clothing mesh, the physical simulation mesh and the graphical mesh are identical (immediate clothing). As soon as the user changes the physical mesh in the ‘Single Layered Cloth’ tab, the graphical and the physical mesh are differing and therefore a more complicated algorithm has to be used to skin the graphical mesh to the physical mesh.

The actual clothing simulation can be started with the ‘Start Simulation’ button in the ‘Save/Run’ group. There the Clothing Asset can also be stored as either a .aca file (using legacy serialization) or any of the module agnostic serialization formats (.xml, .ini or .abi).

Use Input Mesh

  • Subdivide

    Subdivide the clothing mesh right after import from the graphical mesh.

    Only needed when the graphical mesh has ill-shaped triangles or is tessellated very irregularly.

  • Close Mesh

    If the graphical mesh has holes, they will be closed in the physical mesh.

  • Displacement

    Move each physical vertex along its normal.

  • Derive Normals from bones

    Instead of copying normals from the graphical mesh, the bone hierarchy is consulted and the normal is pointing away from the bones.

  • Generate

    Will actually create the clothing physical mesh according to these parameters.

Modify Cloth Mesh

  • Simplify

    Simplifies the clothing mesh up to a certain edge length.

  • Simplification Step

    Removes around 10% of the edges with each subsequent click.

Save/Run

  • Save Asset

    Writes the clothing asset into a stream (either .aca or .xml/.ini/.abi files).

  • Transmit to External Application

    Some Game Engines such as Unreal Engine 3 support direct transmission to the Editor instead of going through the file system.

  • Start Simulation

    Generate one or more actors from the clothing asset and simulate it.

Multilayer Clothing

Generating Multilayer Clothing is similar to Single Layered Clothing, though it takes a few more steps.

Step 1) Create an Iso Surface

  • The Grid Resolution

    The bounding box of the mesh will be filled with grid cells. The edge length of such a grid cell is the bounding box diagonal divided by the <Grid Resolution>

  • Keep all/some meshes

    There can be multiple disjointed iso meshes. The most frequent case is the inner and outer mesh, usually when the original mesh is closed. This allows to select how many meshes to keep. The meshes with a higher vertex count will be kept longest.

  • Derive Normals From Bones

    Instead of using the mesh normals from import, normals are computed as the direction pointing away from the bone with the largest weight.

  • Create

    Actually create the iso surface according to the parameters.

Step 2) Simplify the Iso Surface

  • Simplify <Number>

    Simplify all edges that are shorter than the bounding box diagonal divided by the selected <Number>

  • Simplify Step

    Each time this button is pressed it will simplify roughly 10% of all the edges.

Step 3) Tetrahedralize

This will fill the iso meshes with tetrahedrons.

Step 4) Start Simulation

  • Alternatively the Asset can be saved or transmitted, identical as for Single Layered Clothing.

Simulation

Actions

  • Restart

    Restarts the simulation, all ClothingActors are released and recreated immediately.

  • PVD

    Initiates a PVD connection

Info

  • Size

    The size of the bounding box

  • Scene scale

    Reference scale which scales most scene parameters such as Gravity, painting, debug rendering etc.

Actor Count

  • The slider allows to create up to 25 ClothingActors that will be independently simulated. Animation will be synchronous.

  • Use Preview Instead

    Creates ClothingPreview classes instead of ClothingActors. This will allow only to animate the Clothing Asset, but not to simulate. Good comparison to what it would look like without clothing.

PhysX run time Parameters

  • Sim Frequency

    Quickly change the Simulation Delta (which is 1 / simFrequency). Use with care, 50Hz and above are recommended. It is not very useful below 30Hz.

  • Gravity

    Quickly play with various gravity values. The range is from 0.1 * ‘Scene Scale’ to 2 * ‘Scene Scale’

  • GPU Cloth Sim

    Run the Cloth simulation on the GPU (CUDA capable GPU is required). Should not affect behavior, but performance will differ.

  • Sequential Primary (Compartment Fix)

    Allows to run the Clothing Compartment before the Rigid Body Compartment. Can lead to more stable simulation, but doesn’t make a difference in most cases.

  • Enable Wind

    Show/Hide Wind window

    • Direction

      Rotate wind origin around the up axis

    • Elevation

      Blow from above or below

    • Velocity

      Modify strength of the wind

  • Groundplane

    Moves the ground plane up and down

APEX run time Parameters

  • Graphical Lod

    If available, select which graphical LoD is taken

  • Budget

    Reduce the available simulation units. Useful to see how load balancing will work on multiple Actors.

  • Lod Overwrite

    Force select which physical LoD is used.

  • Blend Time

    Modify the Time it takes to blend from maximum physical LoD to no simulation at all.

  • Animation uses global poses

    If Bind Poses are not identical in the Clothing Asset and the FBX file providing the animation, this is a workaround.

  • Modify Actor Material

    Pop up a window that allows to modify the current material, or to set a new one per ClothingActor.

    A ClothingActor needs to be selected by clicking it.

Animation

  • Time

    The length of the animation

  • Start/Stop Animation

  • Speed

    Select how fast the Animation is played back

  • Select Animation

    Usually this offers to chose between the Bind Pose or the animation

  • Move Camera with animation

    Lock the camera motion to the root bone motion.

  • Loop Animation

    Jump back to 0 at the end of the animation and keep playing

  • Lock root bone

    Overwrite the root bone translation to Zero all the time

  • Animation is continuous

    Do set the isContinuous flag even when the animation loops back to zero

Visualization

Graphical Mesh

Render graphical mesh textured, solid, wireframe or not at all

Painting

  • Painting Visible (Faces)

    Render the painting on the edges of the mesh

  • Painting Visible (Vertices)

    Draw Lines along the normal of each vertex displaying the paint value

  • Painting, show other sub-meshes

    Display all sub-meshes that are not selected for clothing

Cloth Mesh

Draw the Cloth mesh solid, wireframe or not at all.

Collision

Draw collision volumes solid, wireframe or not at all.

Iso Mesh

Draw Iso Mesh solid, wireframe or not at all.

Tetras

Draw Tetra Meshes solid, wireframe or not at all.

Misc

Render the Skeleton as presented by the imported mesh

Clipping

Clip some of the intermediate meshes.

Animation

Display the animation as loaded from the importer

Original Mesh

Render the imported mesh textured, solid, wireframe or not at all

Apex Mesh

Render the simulated mesh textured, solid, wireframe or not at all

SDK Visualization

  • Collision Shapes

    Wireframe render collision volumes from PhysX

  • Clothing Mesh Solid:

    Render Simulation Mesh solid

  • Clothing Mesh Wire

    Render Simulation Mesh wireframe

  • Clothing Collisions

    Blue arrows for each Cloth vertex that collides with collision volumes.

  • Hard Stretch Limit Graph

    Orange lines showing which edges have hard stretch limitation

APEX PhysX Mesh

  • Skinned Positions

    Skinned positions of the physical mesh according to animation

  • Physical Vertex Bones

    Shows the mapping between physical mesh vertices and the bones they skin to. White means a bone weight of 1.0, black a bone weight of 0.0

  • Vertex Velocities

    Blue lines visualizing vertex velocities on the simulated mesh

  • All Implicit Tetrahedrons

    Draws all implicit tetrahedrons for the entire physical mesh

  • Bad Implicit Tetrahedrons

    Draws all tetrahedrons that have a graphical vertex mapped to them with barycentric coordinates outside the tetrahedrons.

  • Skin Implicit Tetrahedrons

    Draws all tetrahedrons that are being used by the current mix of Mesh-Mesh Skinning and immediate skinning

APEX PhysX Max Distance

  • Backstop Collision

    Visualize a subset of the simulation mesh where Backstop collision will occur. Red is outside, blue is inside.

  • Backstop Umbrellas

    Visualize a small segment of the Backstop sphere at the current vertex location.

  • Max Distance Outwards

    Display a line along the vertex normal that represents the radius of the Max Distance sphere.

  • Max Distance Inwards

    Display a line along the negative vertex normal that represents the radius of the Max Distance sphere.

APEX Skeleton

  • Skeleton

    Draw the subset of skeleton bones that are active in this APEX Asset (active bones are referenced by any of the meshes or have a collision volume)

  • Bone Frames

    Draw the bone axis for each active bone

  • Bone Names

    Draw the bone names for each active bone

APEX Graphical Mesh

  • Render Normals

    Draw blue lines for each vertex displaying its computed normal.

  • Render Tangents

    Draw red and green lines for each vertex displaying its computed tangent and bi-normal/bi-tangent.

  • Graphical Vertex Bones

    The mapping from graphical vertices to bones. white line indicate a weight of 1, black lines a weight of 0.

ClothingActorFlags

  • Parallel PhysX Mesh Skinning

    Skinning of the physics mesh will be done during simulation instead of before.

    Note

    This will cause one frame delay.

  • Parallel Mesh Mesh Skinning

    Skinning of the graphical mesh according to simulation is done during the next time step.

    Note

    This will cause one frame delay.

  • Parallel CPU Skinning

    All vertices with Max Distance 0.0 will be skinned regularly. This can and should be done during simulation already, so it should always be on.

  • Recompute Normals

    Fully recompute the normals after all types of skinning have been done. This will replace the normals that were partly approximated or skinned with freshly computed ones. Some overhead but more quality.

Shaders

  • Default

    Use a shader with per-pixel lighting.

  • APEX Subdivision

    [experimental] Subidive the output mesh. A geometry shader will subdivide each triangle into 4 triangles and compute normals for the 3 new vertices. This can remove some artifacts with lighting, but also add new artifacts.

Misc

  • Vsync

    Wait for screen refresh

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Clothing Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »

APEX Clothing Module

Contents:

  • Module Documentation
    • Introduction
      • Animation and Simulation
      • Run Time
      • Time stepping
      • Authoring
    • Clothing Types
      • Immediate Clothing
      • Skinned Clothing
      • Examples
    • Features
      • Physical LoD
      • Rendering
      • Collision with the Character
      • Simulation Normals
      • Rendering Normals
      • Tangent Space
      • Cloth Behavior
      • Debug Visualization
      • Serialization
  • Programmers Guide
    • Introduction
      • Overview
    • Runtime Interfaces
      • Initialization
      • Loading the Clothing Module
      • Loading Assets
      • Instantiating Actors
      • Stepping the Simulation
      • Implementing the Render Interface
      • Buffered calls & Multithreading
      • Using Morph Targets (also known as Blend Shapes)
      • Colliding with the Environment
    • Authoring Interfaces
      • Initialization
      • Graphical Mesh
      • Physics Mesh
      • Creating the Clothing Asset Authoring Object
      • Scaling at Export
      • Saving & Loading the Asset
      • Progress Listener
  • Clothing Tool
    • Getting started
    • Input Mesh
      • Select Sub-mesh
    • Manipulating the View
    • Paint Graphics Mesh
      • Sub-mesh Subdivision
      • Culling
      • Histogram and multiple physics meshes
    • Generate collision volumes
      • Automatic Generation
      • Inflation
      • Manual generation
    • Deformable Parameters
      • Static Parameters
      • Flags
    • Clothing Material
      • Material Libraries
      • Materials
      • Clothing material
    • Single Layered Clothing
      • Use Input Mesh
      • Modify Cloth Mesh
      • Save/Run
    • Multilayer Clothing
      • Step 1) Create an Iso Surface
      • Step 2) Simplify the Iso Surface
      • Step 3) Tetrahedralize
      • Step 4) Start Simulation
    • Simulation
      • Actions
      • Info
      • Actor Count
      • PhysX run time Parameters
      • APEX run time Parameters
      • Animation
    • Visualization
      • Graphical Mesh
      • Painting
      • Cloth Mesh
      • Collision
      • Iso Mesh
      • Tetras
      • Misc
      • Clipping
      • Animation
      • Original Mesh
      • Apex Mesh
      • SDK Visualization
      • APEX PhysX Mesh
      • APEX PhysX Max Distance
      • APEX Skeleton
      • APEX Graphical Mesh
      • ClothingActorFlags
      • Shaders
      • Misc

API

  • Clothing API

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Destruction Module »

Destruction Authoring with PhysXLab

Please refer to the documentation that ships with PhysXLab for information about APEX Destruction Authoring.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Destruction Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Destruction Module »

Destruction Introduction

The Apex Destruction module deals primarily with three kinds of objects:

  • Destructible assets (class DestructibleAsset), which are destructible template objects that may be generated using tools such as PhysXLab (see the PhysXLab documentation), FractureTool, or in your own application using the fracturing API in DestructibleAssetAuthoring,
  • Destructible actors (class DestructibleActor), which are instances of DestructibleAssets, and
  • Destructible actor joints (class DestructibleActorJoint), which are special wrappers for PhysX joints which may be used to join an DestructibleActor to another DestructibleActor, a PhysX actor, or to the static global reference frame.

After loading an DestructibleAsset, you may use it to instance DestructibleActors. The DestructibleAsset carries with it a template of fracture parameters, the DestructibleParameter structure. These parameters are used by default with an DestructibleActor instance, and you may customize these parameters per-instance. These parameters allow you to specify how much damage it takes to fracture a chunk, whether chunks take damage via impact, whether or not they can deform before breaking, and more.

DestructibleActors may start off life static or dynamic. If static, you may define certain pieces (chunks) to be “support” pieces in various ways. This emulates being “held” by the environment. For example, a destructible wall fixture might have support chunks where it touches the wall. When you break off pieces of the fixture, as long as there is a connected path from a given chunk to a support chunk, then it will remain fixed. Otherwise, the disconnected chunks will break free and become dynamic. A powerful feature of this module is “inter-actor support.” This means that if a static destructible with support touches another static destructible, the support may be extend across the destructibles. In this way you may effectively build large destructible structures out of smaller destructible “building blocks.”

(Note: “static” destructible actors actually create kinematic PhysX actors, instead of truly static PhysX actors. In this way the actors may be easily made dynamic when a fracture event knocks chunks loose.)

The DestructibleActor comes with a damage API, allowing the application to apply damage directly or through impacts (collisions). Scene query functions are also supplied (ray casts and obb sweeps).

The DestructibleActorJoints are intended to act just as you’d expect a PhysX joint to act, when attached to a PhysX actor. They hide the fact that the PhysX actors which compose an DestructibleActor may be changing “under the hood” while fracturing is occuring.

A callback mechanism is provided which notifies the user when chunks are fractured or destroyed, so that sound and graphical effects may be played.

An APEX particle system (see the documentation for the particle system module) may be used by the DestructibleActor to emulate debris when the smallest chunks are broken.

Finally, LOD parameters are supplied to scale the physics computation for a given scene. These parameters are:

  • Smallest chunk size
  • Maximum number of dynamic chunk islands
  • Maximum number of chunks
  • Lifetime and maximum distance from place of origin that chunks may exist
  • Chunk benefit weights: per-chunk, lifetime, and screen area

Through the various parameters and interfaces described above, the destruction module provides a rich variety of physical behaviors to enhance game play experience.

Getting Started

A good place to start is the SimpleDestruction sample application in APEX/samples. This demonstrates asset loading, instancing, fluid debris specification, and very importantly has a sample user renderer implementation (see the APEX Framework documentation).

This section highlights the main points of the SimpleDestruction sample.

An Apex application needs to first initialize PhysX. In what follows, it will be assumed that a PhysX SDK has been created (see the PhysX documentation):

PxPhysics* m_physxSDK;
PxFoundation* m_foundation;
m_foundation = PxCreateFoundation(PX_PHYSICS_VERSION, ...);
m_physxSDK = PxCreatePhysics( ... );
PxInitExtensions(*m_physxSDK);

... and that we have a cooking library:

PxCookingParams params;
PxCooking* m_cooking;
m_cooking = PxCreateCooking(PX_PHYSICS_VERSION, m_physicsSDK->getFoundation(), params);

After initializing the PhysX SDK, an APEX application needs to initialize the Apex SDK. See the APEX Framework documentation.

This is done as follows:

/* Fill out the Apex SDK descriptor */
ApexSDKDesc apexDesc;

/* Apex needs an allocator and error stream.  By default it uses those of the PhysX SDK. */

/* Let Apex know about our PhysX SDK and cooking library */
apexDesc.physXSDK              = m_physxSDK;
apexDesc.cooking               = m_physxCooking;
apexDesc.outputStream          = pxErrorStream;

/* Our custom render resource manager */
apexDesc.renderResourceManager = m_renderResourceManager;

/* Our custom named resource handler */
apexDesc.resourceCallback      = m_resourceCallback;

/* Some debug renderer materials */
apexDesc.wireframeMaterial = "materials/simple_unlit.xml";
apexDesc.solidShadedMaterial = "materials/simple_lit_color.xml";

/* Finally, create the Apex SDK */
m_apexSDK = CreateApexSDK(apexDesc);
PX_ASSERT(m_apexSDK);

In the block above we assume we have a named resource provider m_renderResourceManager. SimpleDestruction is built on top of SampleFramework, which provides a class SampleApexRenderResourceManager for this purpose. It provides a name-to-object look-up for various resources, including destructible assets, apex render mesh assets, and material IDs.

Also, the render resource manager m_resourceCallback is used. This is also provided in SampleFramework. This class allows the user to customize the creation of render resources (such as vertex buffers). If you are using apex in an application that does not render (such as a commandline conversion utility), you may use the APEX-provided class NullRenderResourceManager in shared/external/include/NullRenderer.h.

You must also create an Scene, to hold APEX actors and renderables. This is initialized using the PhysX scene. The PhysX scene is created in the usual manner:

PxScene* m_physxScene;
...
/* Create PhysX scene */
physx::PxSceneDesc sceneDesc(scale);
sceneDesc.gravity = physx::PxVec3(0,-9.8f,0);
...
m_physxScene = m_physxSDK->createScene(sceneDesc);

... and the APEX scene:

/* Create an APEX scene from a PhysX scene */
Scene* m_apexScene;

...

SceneDesc sceneDesc;
sceneDesc.scene = m_physxScene;
m_apexScene = gApexSDK->createScene( sceneDesc );

An Apex application then needs to create the Apex modules it will use. These modules will populate the APEX scene with representations of their objects, and also populate the PhysX scene with corresponding physics objects.

The Destruction Module

This link describles all of the Destruction Module Parameters.

Create the destruction module (class ModuleDestructible) using

ModuleDestructible* m_apexDestructibleModule;

...

m_apexDestructibleModule = static_cast<ModuleDestructible*>(m_apexSDK->createModule("Destructible"));

and then initialize it using its default parameters:

NvParameterized::Interface* params = m_apexDestructibleModule->getDefaultModuleDesc();
m_apexDestructibleModule->init(*params);

Note, if you wish to set some parameters to non-default values, you may do so using the NvParameterized interface.

Destructible actors (DestructibleActor) may use the APEX Particles for particle system debris. This is initialized using the particle, iofx, and emitter modules:

m_apexParticlesModule = static_cast<ModuleParticles*>(m_apexSDK->createModule("BasicIOS"));
NvParameterized::Interface* params = m_apexParticlesModule->getDefaultModuleDesc();
m_apexParticlesModule->init(*params);

m_apexIofxModule = static_cast<ModuleIofx*>(m_apexSDK->createModule("IOFX"));
NvParameterized::Interface* params = m_apexIofxModule->getDefaultModuleDesc();
m_apexIofxModule->init(*params);

m_apexEmitterModule = static_cast<ModuleEmitter*>(m_apexSDK->createModule("Emitter"));
NvParameterized::Interface* params = m_apexEmitterModule->getDefaultModuleDesc();
m_apexEmitterModule->init(*params);

With that, the Apex Destruction is ready to use.

Destructible Assets

This link describles all of the Destructible asset parameters.

To create a destructible, first a destructible asset (DestructibleAsset) needs to be created or loaded. PhysXLab provides an easy way to create DestructibleAssets. These can then be saved in either a binary or an ASCII (XML) format. The asset type may be determined by peeking into the file stream, so the file extension does not matter. The current file name convention is that the .apb extension is used for binary format, and .apx for the ASCII format.

In this example we will load an DestructibleAsset from the file “Wall.apb”. To load APEX assets, create an PxFileBuf using the ApexSDK::createStream method. Assuming we have our working directory set up so that “fullpath” is the path to our asset directory,

physx::PxFileBuf* stream = m_apexSDK->createStream( "fullpath/Wall.apb", physx::PxFileBuf::OPEN_READ_ONLY );

... creates the necessary stream. This function returns NULL if the stream cannot be created. To determine the format from the stream, peek into it using:

char peekData[32];
stream->peek(peekData, 32);
NvParameterized::Serializer::SerializeType iSerType = m_apexSDK->getSerializeType(peekData, 32);

Then create a serializer for the serialization type iSerType:

NvParameterized::Serializer* ser = m_apexSDK->createSerializer(iSerType);

And load the asset using the deserialize method:

NvParameterized::Serializer::DeserializedData data;
NvParameterized::Serializer::ErrorType serError = ser->deserialize(*stream, data);

The data structure now contains pointers to one or more APEX assets, depending on how many were in the stream. Assuming there is only one in the stream, use

NvParameterized::Interface *params = data[0];
Asset* asset = m_apexSDK->createAsset( params, "Asset Name" );

The second parameter a name you can used to refer to the asset later. To use the destructible asset api for this asset, cast the pointer to an DestructibleAsset:

DestructibleAsset* destructibleAsset = static_cast<DestructibleAsset*>( asset );

Destructible Actors

This link describles all of the Destructible actor parameters.

Creating a destructible actor from a destructible asset is very simple if you use the default parameters (class DestructibleParameters) that are stored with the destructible asset.

One piece of additional information that you’re almost certainly going to want to change is the initial global pose for the destructible, which we’ll assume we have in the PxMat44 pose.

First, get the default actor description parameters from the asset:

NvParameterized::Interface* descParams = destructibleAsset->getDefaultActorDesc();

To modify the global pose, use

NvParameterized::setParamMat44( *descParams, "globalPose", pose );

Then simply use the descriptor, along with the APEX scene, to create an DestructibleActor instance of the DestructibleAsset:

Actor* actor = asset->createApexActor( *descParams, apexScene );

Again, to use the DestructibleActor API, typecast actor:

DestructibleActor* destructibleActor = static_cast<DestructibleActor*>( actor );

In general, you’ll need to set more fields of the Destructible actor parameters. Notably,

  • dynamic (BOOL) determines if the destructible starts off life as dynamic (in which case it cannot take part in any support structure). Default is false, giving a static destructible.
  • scale (PxVec3) scales the DestructibleActor instance, possibly non-uniformly. Default is PxVec3(1,1,1), the identity scaling. You’ll probably want to have all scales that the application will use set in the DestructibleAsset’s precached cooking scales before the asset is serialized to file or stream. The Destruction authoring tool can set these scales for you. If you don’t precache the cooking scales, destruction will still work, but the cooking for the collision hulls will happen during run time.

Finally, there are many parameters you may set in destructibleParameters. These set how much damage it takes to fracture a destructible, whether or not damage can come from impact, and many more things. A full description is given in the PhysXLab documentation.

Actor Serialization and Deserialization

At times it may be desirable to save and/or load the state of a destructible actor; saving a fracture sequence for subsequent replay and synchronizing fractured actor states between different PCs are two such scenarios. Serialization and deserialization provide a convenient approach to this end.

Each destructible actor exposes a parameterized interface

const NvParameterized::Interface* stateParams = actor->getNvParameterized( DestructibleParameterizedType::State );

with which we can easily serialize and store the actor’s state:

NvParameterized::Serializer* ser = m_apexSDK->createSerializer( NvParameterized::SerializeType::NST_BINARY );
...
physx::PxFileBuf* outStream      = m_apexSDK->createStream( "fullpath/ActorSavedState.apb", physx::PxFileBuf::OPEN_WRITE_ONLY );
...
NvParameterized::Serializer::ErrorType serError = ser->serialize( *outStream, stateParams, 1 );

For deserialization, there are several options. Rather than creating the actor with a default set of parameters, we can pass the deserialized actor’s state handle to the creation method. We first construct our serializer and an input stream from the serialized actor’s state:

NvParameterized::Serializer* ser = m_apexSDK->createSerializer( NvParameterized::SerializeType::NST_BINARY );
...
physx::PxFileBuf* inStream       = m_apexSDK->createStream( "fullpath/ActorSavedState.apb", physx::PxFileBuf::OPEN_READ_ONLY );

We then deserialize the input stream and provide the parameterized handle to the actor creation method:

NvParameterized::Serializer::DeserializedData data;
NvParameterized::Serializer::ErrorType serError = ser->deserialize( *inStream, data );
...
NvParameterized::Interface* stateParams = data[0];
Actor* actor = asset->createApexActor( *stateParams, apexScene );
...
stateParams->destroy();

With deserialization, a provided optimization allows the created destructible actor to take ownership of the provided parameterized interface. An additional method has been provided that creates the actor while consuming the specified handle:

Actor* actor = asset->createDestructibleActor( stateParams, apexScene );

The alternative to creating a new destructible actor from state is to explicitly set the state an an existing actor:

actor->setNvParameterized( stateParams );

Note that the actor takes ownership of the provided state handle.

Several guidelines should help the user make the most of these features:

  • In general, destructible actors that form islands with other destructible actors should be serialized and deserialized in the same frame. Otherwise, no guarantees can be made that the island structure will be reformed properly.
  • Prefer recreating an actor from it’s deserialized state to setting the actor’s state explicitly. Internally, setting the state via setNvParameterized() does a more or less complete actor recreation from scratch. Recreating the actor manually makes this state change explicit. For lighter weight state synchronization, use explicit damage event, fracture event or pose synchronization.

Setting the default PhysX descriptors

Once the DestructibleActor is in the APEX scene, it will generate PhysX actors and shapes in the PhysX scene as it sees fit. However, the user may want some control over some of the parameters of the generated actors and shapes. For this purpose, fields which are used in the construction of PhysX actors and shapes are represented in the destructible actor descriptor.

Let’s say we wish to specify the shapes’ groupsMask, and the actors’ density. An example of this is:

/* Set the shapes' groupsMask */
NvParameterized::setParamU32( *descParams, "p3ShapeDescTemplate.simulationFilterData.word0", 2 );
NvParameterized::setParamU32( *descParams, "p3ShapeDescTemplate.simulationFilterData.word0", ~0 );

/* Set the shapes' density */
NvParameterized::setParamF32( *descParams, "p3BodyDescTemplate.density", 10.0f );

Destructible Synchronization

For the purpose of allowing synchronization of the destructed state of actors across different processes in real-time, APEX Destruction presents a scaled-down alternative to full actor state serialization and deserialization. This method exposes only enough data to synchronize between actors at a customizable combination of detail.

Module-level semantics

At the module level, the application must implement the type-parameterized interface class provided: class UserDestructibleSyncHandler The type argument would be of the data type that the application wants to synchronize between. There are 3 synchronizable types.

The application should then instantiate and set these callback(s) for APEX via

module->setSyncParams( userDamageEventHandler, userFractureEventHandler, userChunkMotionHandler );

Typically, the application should only use one of either userDamageEventHandler or userFractureEventHandler, plus userChunkMotionHandler optionally. This is the main way by which APEX passes synchronization data back to the application. Note that any shared resource used by the callback classes must be thread-safe.

For write operations (passing data to the application), APEX will call the following 2 methods whenever such data becomes available. This is a request for a writable memory buffer which APEX will use, followed by a notification when APEX is done writing:

callbackFoo->onWriteBegin( bufferStart, bufferSize );
callbackFoo->onWriteDone( headerCount );

APEX does not cache this information - they are computed, used, and then discarded. This information is only available to the application during this window.

For read operations (passing data to APEX), APEX will call the following 4 methods whenever such data is about to be processed. 2 of the methods are used for preparing the memory buffer into a state usable by APEX:

callbackFoo->onPreProcessReadBegin( bufferStart, bufferSize, continuePointerSwizzling );
callbackFoo->onPreProcessReadDone( headerCount );

These methods serve 2 functions. Firstly, to update the pointers into valid values for this memory space, and secondly, to provide a convenient outlet for the application to chain together multiple buffers.

Following that, the actual read request is made through the following 2 methods. This is a request for a readable memory buffer which APEX will use, followed by a notification when APEX is done reading:

callbackFoo->onReadBegin( bufferStart );
callbackFoo->onReadDone( debugMessage );

APEX will only reference this information during this window.

These callbacks contain data for all actors that are marked for synchronization. Marking an actor for synchronization is done at the actor level.

Actor-level semantics

At the actor level, the application needs to mark them as participating synchronizable actors:

actor->setSyncParams( userActorID, actorSyncFlags, actorSyncState, chunkSyncState)

The userActorID is used to match actors across processes to synchronize data between. It must be a non-zero value. For every matched userActorID, the client must set a readFoo flag for every copyFoo flag set by the source, to be passed in as actorSyncFlags. Flag options are presented in the struct DestructibleActorSyncFlags. Using actorSyncState and chunkSyncState will allow for even more fine-grained control over the data to synchronize between.

Additionally, at the per-actor level, APEX also provides an even lower-cost way to track and use chunks that were ever impacted. This is especially useful in situations where detail mattered the least - such as when an actor is far away or when an actor is required to be quickly synchronized to the current environment. Minimizing of computation time and bandwidth used is the goal here. This method also represents a departure from how the other data are synchronized - this data is cached by APEX and is fetchable via an API call, thus relieving the application from the burden of having to save this information until they actually need to use it. There are 4 API calls relating to this feature:

actor->setHitChunkTrackingParams( flushHistory, startTracking, trackingDepth );
actor->getHitChunkHistory( hitChunkContainer, hitChunkCount );
actor->forceChunkHits( hitChunkContainer, hitChunkCount , removeChunks );
actor->setDeleteFracturedChunks( inDeleteChunkMode );

The actor-level parameters can be safely tweaked anytime during runtime. This is in contrast to the callback methods, where memory must be “locked” during the short FooBegin() - FooDone() window.

Example use-cases

Here are some sample use-cases for actor synchronization. Please refer to the sections under Module-level semantics and Actor-level semantics for the how-tos in setting up actors for synchronization. This section only serves to identify and reconcile the tweaking of the parameters responsible for the different use-cases.

  1. Client joining late - updating the client via hit chunk history list.

    1.1) On the source-side, be sure to have the actor track its chunk history:

actor->setHitChunkTrackingParams( flushHistory, startTracking, trackingDepth );

Here, startTracking must be set to true. The trackingDepth should be set at a level less than or equal to the maximum chunk depth for the asset.

1.2) Just before the actor on the destination-side is to be deleted, retrieve the chunk history list for the actor on the source-side:
actor->getHitChunkHistory( hitChunkContainer, hitChunkCount );

The application should then use the returned arguments to supply the destination-side.

1.3) On the destination-side, apply the chunk history list.
actor->forceChunkHits( hitChunkContainer, hitChunkCount , removeChunks );

Here, removeChunks must be set to true.

  2. Actor out-of-sight - Turning on / off actor delete mode in runtime.

    2.1) On the local-side, simply set the actor to delete-mode to have it delete its chunks instead of simulating them when hit:

actor->setDeleteFracturedChunks( inDeleteChunkMode );

Here, inDeleteChunkMode must be set to true. Use this same API to have it return back to the normal simulating state.

  3. Level-of-detail - Changing the filter depth for damage/fracture events in runtime.

    3.1) On the source-side, be sure to set the optional parameters for the actor:

actor->setSyncParams( userActorID, actorSyncFlags, actorSyncState, chunkSyncState);

Here, be sure that the requisite flag is set in actorSyncFlags for the corresponding actorSyncState and/or chunkSyncState parameter. Define and set values for actorSyncState and/or chunkSyncState. For example, if we are filtering the depth of damage events, be sure to have the CopyDamageEvents flag included (OR-ed) as well.

actorSyncFlags |= CopyDamageEvents;
actorSyncState = new DestructibleActorSyncState;
actorSyncState->damageEventFilterDepth = 2;

The optional parameters actorSyncState and chunkSyncState can be tweaked without having to re-call setSyncParams after the first time it is set.

3.2) On the destination-side, be sure to have the corresponding readFoo flag set.
actor->setSyncParams( userActorID, actorSyncFlags, actorSyncState, chunkSyncState);

Here, be sure that the corresponding read flag is set in actorSyncFlags. actorSyncState and chunkSyncState are inconsequential here, thus can be left as NULL. For example, include (OR) the flag ReadDamageEvents if CopyDamageEvents was used in step 3.1).

actorSyncFlags |= ReadDamageEvents;

Guidelines and Caveats

In this section we discuss some of the potential quirkiness associated with destructible synchronization.

  • Filtering is a source-side (write-side / send-side / server) decision. The destination-side (read-side / receive-side / client) actor has no control over filtering.

  • Actor delete-mode is a local decision. The source-side has no control over deletion on the destination-side.

  • Overruled filter level / graphical LOD due to simulation LOD - filter level mismatches

    • Overruled filter level:

      For example,

      sending-side actor LOD = 2, filter = 3,

    Only up till and including level 2 chunks will go into the outgoing synchronization buffer.

    • Overruled graphical LOD:

      For example,

      receiving-side actor LOD = 2, sending-side actor LOD = 3, sending-side filter level = 3

    The level 3 chunks on the receiving-side actor will break off too.

    A simple guideline is to have the filter levels set to the lowest actor LOD level across machines.

  • Ignored chunk deletion during runtime

If an actor had already been fractured into smaller pieces (as can happen midway in a game), the smaller chunks will not be deleted when the deletion list is applied on the actor. This is because only chunks at the tracking depth are tracked as a “hit chunk” in the “hit chunk history” of an actor. This is for cost-savings purposes, consistent with the spirit of minimizing computation costs and bandwidth usage for such usage.

  • Ignored damage events / inaccurate fracture events due to non-determinism of generated dynamic chunk poses.

Due to the non-deterministic nature of physX generating poses (orientation and position), dynamic chunks’ poses will not match on different machines, given the same damage event. As a consequence, due to the way damage events are applied (chunk poses are a factor), this may cause some dynamic chunks to ignore the damage events coming in from synchronization buffer. Similar challenges apply for fracture events. However, they are much less pronounced.

A simplistic guideline is to use fracture events instead of damage events to get a better match across machines. This will come at a higher bandwidth cost though.

  • Local fractures prioritised over synchronization

Fractures initiated by the application locally always takes precedent over synchronized fractures. For any given tick, fractures could be postponed over to the next frame if the computation limit for fracturing is breached. In that event, fractures initiated remotely through synchronization will take a backseat. They will still be processed eventually, but only after all locally-initiated fractures are processed. APEX will make a copy of the outstanding remotely-initiated fracture events (They are usually only being referenced if they can all be processed this frame). This behaviour is by design, so as to allow for better responsiveness to locally-initiated events.

  • Invalid synchronization data (eg. applying further damage on a chunk that has already been destructed) will be skipped over by APEX.
  • Stacked synchronization data (eg. applying damage on the same chunk that has already been damaged in the same frame) does not cause overwrite. They are always being processed FIFO.

Runtime Fracturing

In APEX 1.3 and later, the destruction module includes an option for runtime fracturing. That is, fracturing is performed on the fly, with no precalculation of the fractured pieces. To enable runtime fracturing, set both the CRUMBLE_SMALLEST_CHUNKS and CRUMBLE_VIA_RUNTIME_FRACTURE flags in the destructible parameters. With these flags set, the deepest-level prefractured chunks (those with no children) will continue to be fractured using the runtime system.

If you want the entire destructible to runtime fractured, simple create a destructible asset from a mesh, with no prefracturing, and set the aforementioned flags. One thing to note, however, is that the runtime fracture system is activated exactly when crumbles would be, that is, only when a deepest-level chunk takes enough damage to be fractured further. When there is only one chunk, this means the chunk would need to first take enough damage to break free (if it’s static), then enough to fracture further to crumbles or runtime fracture. This essentially doubles the damage it needs to take to fracture. To prevent this, you may set the minimumFractureDepth (in the destructible parameters) to one more than the deepest depth, meaning fracturing will begin with crumbles or runtime fracture. So, if you import a single-chunk destructible for runtime fracture, set minimumFractureDepth to 1 (since there is only a depth-0 chunk).

This fracture mode also comes in two types: full and partial. Since a fracture pattern is a decomposition of all of space, when applied to a mesh it will cut the entire mesh into pieces. Partial fracture means that beyond a given radius, the pieces are sewn back together, so that the only fragments seen are the ones within the given radius. We have merged this into the prefracture system by using the radius obtained from applyRadiusDamage. This radius is used for the partial fracture mode in realtime fracturing of chunks.

Scene 9 in SimpleDestruction demonstrates runtime fracture on a thin sheet, with a glass fracture pattern.

Fracture Patterns

Runtime fracturing is based upon precomputed fracture patterns that may be applied anywhere (and with any orientation or scale) within a mesh. We plan to support a variety of fracture patterns in subsequent releases of APEX. In the current release we only have one pattern available, a glass fracture pattern.

Parameters

In addition to the flags which enable this feature, mentioned above, there are a number of parameters that control its behavior. these are listed here.

Parameter name | Type | Default value | Description
destructibleParameters.runtimeFracture.sheetFracture | bool | true | If true, align fracture pattern to largest face. If false, the fracture pattern will be aligned to the hit normal with each fracture.
destructibleParameters.runtimeFracture.depthLimit | unsigned | 2 | How many times pieces can be recursively fractured using the runtime fracture system.
destructibleParameters.runtimeFracture.destroyIfAtDepthLimit | bool | false | If true, destroy chunks when they hit their depth limit.
destructibleParameters.runtimeFracture.minConvexSize | float | 0.02 | Minimum size of convex piece produced by a fracture.
destructibleParameters.runtimeFracture.impulseScale | float | 1.0 | Scales impulse applied by a fracture.
destructibleParameters.runtimeFracture.glass | FractureGlass |  | Glass fracture pattern settings. See the table below.
destructibleParameters.runtimeFracture.attachment | FractureAttachment |  | Attachment Settings. Allows the sides of a runtime fracture chunk to be kinematic rather than dynamic. See the description below.

The FractureGlass parameters are described in the following table. The pattern is described by a number of ‘sectors’ and ‘segments’. Sectors are the radial slices, segments the cross-slices within the sectors.

Parameter name | Type | Default value | Description
numSectors | unsigned | 10 | Number of angular slices in the glass fracture pattern.
sectorRand | float | 0.3 | Creates variance in the angle of slices. A value of zero results in all angular slices having the same angle.
firstSegmentSize | float | 0.06 | The minimum shard size. Shards below this size will not be created and thus not visible.
segmentScale | float | 1.4 | Scales the radial spacing in the glass fracture pattern. A larger value results in radially longer shards.
segmentRand | float | 0.3 | Creates variance in the radial size of shards. A value of zero results in a low noise circular pattern.

The FractureAttachment parameters are simply a set of six bools, describing which sides of the destructible are attached to the world. This description is in the local space of the destructible. The fields are posX, negX, posY, etc. In this way, when a local fracture (using radius damage) is done, pieces outside of the damage radius will remain attached if they are joined to an attachment side.

Fracture Callbacks

Sometimes it is useful to have information about chunks which are fractured loose, or destroyed completely. For example the user may wish to generate sound or particle effects associated with the fracture event. APEX Destruction facilitates this with the UserChunkReport. The user must derive their own class from this virtual base class and implement the onDamageNotify function. After doing this, pass an instance of the derived class to the destruction module using the ModuleDestructible method

virtual void         setChunkReport(UserChunkReport* chunkReport) = 0;

Once a frame, if fractures occurred since the last frame, then the onDamageNotify function will be called with information stored in an DamageEventReportData structure. (See DamageEventReportData.) This gives general information about the chunks which broke free or were destroyed, as well as a detailed list of chunks if the chunks’ hierarchical depth is at or below a maximum depth set by the ModuleDestructible method

virtual void         setChunkReportMaxFractureEventDepth(physx::PxU32 chunkReportMaxFractureEventDepth) = 0;

Chunks contribute to the DamageEventReportData for various reasons, enumerated in the ChunkFlag::Enum enum. This not only allows the user to respond to the fracture event based upon the reason (the ChunkFlag is in the ChunkData for each explicitly-listed chunk), but it also allows for filtering of the chunks which contribute to the report. By setting a flag mask using the ModuleDestructible method

virtual void         setChunkReportSendChunkStateEvents(bool chunkReportSendChunkStateEvents) = 0;

If enabled, once a frame during simulate, the onStateChangeNotify callback is called with a list of chunks that have changed their visibility state, including their current state. This allows for event based updates of the chunk representation in the application.

virtual void         setChunkReportBitMask(physx::PxU32 chunkReportBitMask) = 0;

only fracture events with ChunkFlag flags that overlap (boolean ‘and’) the given mask will contribute.

Automatic LOD - Destructible Benefit and Cost Functions

See the APEX Framework documentation section “APEX Automatic LOD” for the general introduction to APEX LOD.

The destruction module uses two factors to determine an DestructibleActor’s benefit: angular size, and age. Unlike the “solid angle” importance function described in the LOD section of the framework documentation, the angular size calculation only takes into account a linear arc size subtended by the actor from the point of view of the camera location. In this way the importance falls off linearly with distance, not with the square of the distance as with the solid angle, and therefore the benefit does not fall off as quickly.

The age benefit is calculated using the linear ramp-down described in the framework LOD section.

The LOD parameters are set through the DestructibleActor function

virtual void setLODWeights(PxF32 maxDistance, PxF32 distanceWeight, PxF32 maxAge, PxF32 ageWeight, PxF32 bias)

The parameters are described below.

  • maxDistance: beyond this distance, the distance importance function D(r) is zero. D(r) is clamped for decreasing r so that it never grows above 1.
  • distanceWeight: the coefficient in front of the distance importance function D(r).
  • maxAge: beyond this time, the distance importance function A(t) is zero. A(t) is clamped so that A(t) = 1.
  • ageWeight: the coefficient in front of the age importance function A(t).
  • bias: a constant bias to increase or decrease an actor’s benefit.

The total benefit for an actor is calculated using:

B(r,t) = distanceWeight*D(r) + ageWeight*A(t) + bias.

The weights should total 1, and the bias should be kept in the unit [0,1] range. This keeps the benefit function B(r,t) “normalized,” so that it’s on the order of one or less.

Rendering Considerations

Render Proxy

The DestructibleActor derives from the APEX rendering API (see Renderable), so that you may simply render the destructible using this API. However, many applications use a separate rendering thread that runs concurrently with a simulation thread that ticks the APEX scene. It’s possible that during this tick, a destructible may be deleted, but a reference to it or its rendering data could still be waiting in the rendering thread. To accomodate this usage, the destructible actor uses a render proxy object to hold all of its rendering data. This object exists separately from the DestructibleActor, and so the actor may be deleted without deleting the render proxy. This way, the rendering thread can hold a reference to the render proxy instead of the actor, and if the actor is deleted the render thread is unaffected.

To acquire a handle to the render proxy, use

virtual DestructibleRenderable* acquireRenderableReference()

The object DestructibleRenderable is also derived from Renderable, so you may use it to render in exactly the same way as you would have rendered the DestructibleActor. This object is reference counted, and the DestructibleActor holds a reference to it while it exists. Once you are through with the proxy, you may use the DestructibleRenderable::release() method to decrement the reference count. If the reference count goes to zero, the proxy is actually deleted. This way the proxy will be properly deleted if the DestructibleActor is deleted before the render thread is through with the proxy.

If there are any external references to the proxy, the DestructibleActor’s render API will no longer function. You must then use the proxy to render the destructible. Once you release all external references, the DestructibleActor’s render API will operate normally.

VTF Rendering

When we use skinning method to render the destructible chunks, each chunk is associated with one bone. Traditional skinning method limits the number of bones per draw call. Therefore the rendering performance is CPU bounded when the number of chunks increase. The Vertex Texture Fetch, known as VTF, rendering method deposits a destructible’s entire rendering bone buffer in a texture whose width is 4 and height is the maximum number of bones of the actor. Thus each row of the texture represents a 4x4 tranform matrix. The vertex shader reads the bones from a texture instead of the constant buffer. In this way, all dynamic chunks require only one draw call per rendering pass and greatly reduce the CPU cycles. Note that this technique only applies to GPUs with shader model 3.0 or later versions. For earlier GPUs that don’t support this feature, the traditional skinning technique is still supported in the sample and can be toggled with the following code in SampleDestructible.cpp

switch(renderer->getDriverType())
{
case SampleRenderer::Renderer::DRIVER_DIRECT3D9:
case SampleRenderer::Renderer::DRIVER_DIRECT3D11:
        renderer->setEnableVTF(true);
}

Debug Visualization

All APEX modules come with debug visualization rendering, to help understand what is happening in an APEX scene. When you hit the V key in SimpleDestruction, default APEX visualization rendering is turned on, as well as default PhysX SDK visualization. In addition to the default settings, APEX Destruction LOD benefits and support visualization are shown.

Click here for a list of the Destructible debug visualization parameters

For general information on how to use debug visualization within APEX, please see Debug Visualization.

Starting SimpleDestruction and repeatedly hitting ‘V’ (for visualization) and ‘G’ (to hide meshes) will show a subset of the debug visualization options for APEX render meshes and destructible actors. The sample may look slightly different in its current form, but the debug visualization walk-through offered here is still valuable.

Here you see the PhysX collision representation of the scene, as well as the destructible’s support structure. The white circles on the ground represent the collision plane, while the orange box represents the collision volume of the wall. It is a single volume since the wall is not yet damaged. The blue boxes on the ground outline the support chunks in the wall. The support depth for this asset is set at depth = 2, and the outlined chunks are the depth-2 chunks that touch a static actor (the ground plane) in the PhysX scene. Since “World overlap” support is selected in the asset, these chunks become support chunks. All chunks touching them, and chunks touching those chunks, and so on, are supported. This is represented by the network of blue lines, drawn between the centers of each chunk that gains support from a supported neighbor, and that supported neighbor’s center.

Once we apply some damage to the wall, freeing chunks at depth 2 or deeper, those chunks cease to be supported, and this modifies the support network:

Once enough chunks have been removed from the support network to form an island of chunks that don’t contain a supported chunk, that island becomes free, and breaks off whole:

Level of Detail (LOD) benefit and cost are also displayed. The green squares represent the benefit of a chunk island. The benefit is proportional to the area. If the square is large enough, the benefit value is shown in the square. Braking off some chunks you can see the benefits changing as the chunk islands age, and as they fill different areas of the screen:

Chunk island benefit is a function of both the age of chunk and the screen area percentage it fills. Both have adjustable prefactors, as well as an exponential decay factor for the age. Therefore each new chunk island that forms starts with a certain benefit which decays over time, settling on a benefit that only depends on screen area percentage.

In LOD calculations the benefit of each chunk is weighed against its cost. The cost is simply the calculated as the number of chunks times a factor which can be set by the user. This cost is compared with a total budget given to the destruction module. That budget and the total cost of the chunks in the scene are plotted in the bar on the bottom. The bar is scaled so that half the width of the screen represents the total budget. Chunk costs are summed up (stacked) on that bar. The cost of all “essential” chunks is shown as a blue bar. These are the chunks that are not deeper than the “essential depth” set for the destructible asset. Essential chunks will never be removed from the scene from LOD considerations. For example, game play logic or experience may require this.

On top of the essential chunk cost is a yellow bar representing the non-essential chunk cost. If the total cost is less than the budget, the remainder of the budget bar is plotted in white. If the total cost exceeds the budget, the overrun is plotted in red and will extend to the right-half of the screen. Budget overrun can occur if the essential chunk cost exceeds the budget. Also, miscalculations (due to approximations in budget prediction) may cause a temporary budget overrun, which will be corrected in subsequent frames.

If the budget is exceeded by non-essential chunks, or is predicted to be (due to a new fracture event), then the destruction LOD system goes to work and either reduces the detail of fracturing from the fracture event, or removes low-benefit chunks. This is done in order of increasing benefit/cost, until the budget is satisfied or all chunks are essential.

When a chunks is removed to satisfy resource budget, a red square with an “X” across it is displayed temporarily in its place, to show where the removal occurred.

Other visualization options are available. For example, you can view the chunk island poses (local coordinate systems), if you set the VISUALIZE_DESTRUCTIBLE_FRAGMENT_POSE visualizer flag. An example of this is shown here:

Errors and Warnings

APEX Destruction outputs the following error and warning messages using the standard APEX error stream.

ERROR CODE | MESSAGE | Explanation
APEX_INVALID_PARAMETER | The NvParameterized::Interface object is the wrong type | The parameterized descriptor passed into ModuleDestructible::init(...) was not a destructible module descriptor.
APEX_INVALID_OPERATION | DestructibleActor does not support this operation | An LOD operation (getLodRange, getActiveLod, or forceLod) has been called which APEX destruction does not support.
APEX_INTERNAL_ERROR | Destructible actors need EmitterExplicitGeom emitters. | A crumble or dust emitter was assigned to a destructible actor which was not an EmitterExplicitGeom emitter.
APEX_INTERNAL_ERROR | DestructibleAssetAuthoring::cookChunks: cookingDesc invalid. | Destructible authoring: DestructibleAssetAuthoring::cookChunks(...) was called with an invalid descriptor.
APEX_INTERNAL_ERROR | Destructible asset render mesh uninitialized or wrong part count. | Destructible authoring: DestructibleAssetAuthoring::cookChunks(...) was called without assigning an RenderMeshAssetAuthoring, or it does not have the correct number of parts.
APEX_DEBUG_WARNING | APEX Destruction physx::PxFileBuf (de)serialization is obsolete. You must use NvParameterized (de)serialization. | A call was made to destructible asset serialize() or deserialize(). This should no longer occur.
APEX_DEBUG_WARNING | Deprecated interface, use ApexSDK::{create,release}Asset or ApexSDK::{create,release}AssetAuthoring. | A call was made to a deprecated asset create or release method. Asset creation and release is handled through the APEX SDK now.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Destruction Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Destruction Module »

FractureTool

FractureTool is a command-utility for generating destructible assets from regular mesh assets. It exposes a subset of options provided by the DestructibleAssetAuthoring API, and can be used for batch processing of simple fracture configurations or as basic alternative to PhysXLab.

Running FractureTool.exe -h, or simply FractureTool.exe without any arguments, results in a full usage description.

Usage: FractureToolDEBUG.exe [OPTIONS]

Fracture and save a mesh given [OPTIONS] control parameters.

-m

-mesh
path to an unfractured mesh (required)

-o

-output
name of output file, placed in same directory as input mesh

-x

-xml
when specified, save the output as xml (default is binary)

-f

-fracture-config

  name of the fracture config file

-vb

-verbose
when specified, enable maximum verbosity

-d

-depth
number of depth levels for fracturing (default = 3)

-s

-slices
number of slices to make at each depth level (default = 1)

-sl

-slice-linear
slice angular variation (relative to mesh size, default = 0)

-sa

-slice-angular
slice angular variation (radians, default = 0.1)

-na

-noise-amplitude

  noise amplitude (relative to mesh size, default = 0)

-nf

-noise-frequency

  noise frequency (relative to 1/(grid spacing, default = 0.25)

-ng

-noise-grid-size

  noise field grid size (# elements across mesh, default = 10)

-nm

-noise-mode
noise mode (0 = planewave (default), 1 = 2d perlin, 2 = 3d perlin

-v

-voronoi
when specified, use voronoi fracture in place of slice fracture

-vs

-voronoi-sites
number of cell sites used in voronoi fracture (default = 15)

-se

-seed
random seed (default = 0)

-iu

-interior-u
interior u scale (default = 1.0)

-iv

-interior-v
interior v scale (default = 1.0)

-im

-interior-material

  interior material name

-om

-override-material

  when specified, mesh materials will be overridden with defaults

-ot

-override-texture

  when specified, mesh textures will be overridden with defaults

-em

-export-material

  when specified, export materials in addition to the asset

-dm

-disp-maps
when specified, use displacement maps in place of geometric noise

-edm

-export-disp-maps

  when specified, export displacement maps as texture

-p

-profile
when specified, display basic timing profile of fracture tool

-sn

-smooth-normals

  when specified, smooth normals of interior vertices

Examples:

FractureTool.exe -m block.obj -x -d 2 -s 1 -sa 0   -na 0.2 -em -dm -edm

Fracture block.obj with tessellated noise and export materials, displacement maps and xml asset.

FractureTool.exe -m block.obj    -d 1 -s 5 -sa 0.2 -na 0.2 -em

Fracture block.obj with noise and export materials and binary asset.

FractureTool.exe -m block.obj    -d 3 -s 2 -sa 0.2

Fracture block.obj without noise and export binary asset.

FractureTool.exe -m block.obj -v -vs=15

Fracture block.obj using voronoi splitting and export binary asset.

Supported input mesh formats:

apx (APEX Xml    - must be a render mesh asset)
apb (APEX Binary - must be a render mesh asset)
obj
fbx
ezm

Supported output asset formats:

apx
apb

Supported fracture modes:

slice
voronoi

For instance, a session to produce a Voronoi-fractured OBJ mesh using 100 Voronoi sites would look as follows:

FractureTool.exe -m block.obj -v -vs=100

APEX Fracture Tool  (Press any key to cancel...)

Loaded     \ [==================================================]  100%
Fractured  | [==================================================]  100%
Saved      | [==================================================]  100%

Success!

Files exported to PATH/TO/OUTPUT/
  Asset:                block.apb

Again, all of the command-line options are fully described by simply running FractureTool.

Tessellation

A natural way to extend the detail of destructible assets is with hardware-accelarated
tessellation.  As a purely graphical effect, run-time tessellation provides additional
visual fidelity without sacrificing simulation performance; it’s a great way to add
roughness and realism to fractured chunks.

By design, the core APEX destruction module provides very little in the way of explicit
tessellation support.  However, FractureTool (and in the future, PhysXLab) offers a simple
way to augment destructible assets with tessellated materials. Together with the
SimpleDestruction example, it provides a rough template of how tessellation can work in a
destructible pipeline.

The following command-line sequence illustrates one such example:

FractureTool.exe -mesh block.obj -output block.apb -noise-amplitude .5 -export-material -disp-maps -export-disp-maps

Run with shorthand, we have the following:

FractureTool.exe -m block.obj -o block.apb -na .5 -em -dm -edm

APEX Fracture Tool  (Press any key to cancel...)

Loaded     \ [==================================================]  100%
Fractured  | [==================================================]  100%
Saved      | [==================================================]  100%

Success!

Files exported to PATH/TO/OUTPUT/
  Displacement Map:     blockDisplacementMap.dds
  Material:             blockMaterial0.xml
  Material:             blockMaterial1.xml
  Asset:                block.apb

This command will perform a slice fracture of block.obj.  However, rather than adding
actual geometric noise, by specifying -disp-maps and -export-disp-maps, and providing a non-zero
-noise-amplitude, FractureTool generates and stores the noise in a 3D texture (blockDisplacementMap.dds).
The -export-material flag outputs materials for the asset that are compatible with SimpleDestruction.

We can view the tessellated result by running

SimpleDestruction.exe -loadasset block.apb -d3d11

The -d3d11 flag loads the DX11 renderer, which is required for tessellation in SimpleDestruction.

Note: For SimpleDestruction to properly import the asset, the exported texture and material files must be in a directory accessible to SimpleDestruction (typically APEX_INSTALL_DIR/media/APEX/1.4/SimpleDestruction)

In the end, most of the tessellation work is performed in the actual domain and hull shaders.  Two such implemenations are included in the Sample framework:

shaders/tessellation/texture_noise.cg
shaders/tessellation/procedural_noise.cg

texture_noise.cg will use the 3D displacement map texture provided by FractureTool.  If the -export-disp-maps option is removed when using FractureTool, the generated material will instead use procedural_noise.cg.  This shader uses a simple 3D Perlin noise generator to add tessellated detail at run-time.

Navigation

  •
          next
    •

  •
          previous |
    •

  • NVIDIA APEX Documentation »
    •

  • APEX Destruction Module »
    •

        © Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved.
      Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »

APEX Destruction Module

Contents:

  • Destruction Introduction
    • Getting Started
    • The Destruction Module
    • Destructible Assets
    • Destructible Actors
      • Actor Serialization and Deserialization
      • Setting the default PhysX descriptors
    • Destructible Synchronization
      • Module-level semantics
      • Actor-level semantics
      • Example use-cases
      • Guidelines and Caveats
    • Runtime Fracturing
      • Fracture Patterns
      • Parameters
    • Fracture Callbacks
    • Automatic LOD - Destructible Benefit and Cost Functions
    • Rendering Considerations
      • Render Proxy
      • VTF Rendering
    • Debug Visualization
    • Errors and Warnings
  • Destruction Authoring with PhysXLab
  • FractureTool
    • Tessellation

API

  • Destruction API

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX ForceField Module »

Force Field Introduction

The APEX ForceField module creates effects with APEX Basic IOS particles and APEX Particle IOS particles (based on PhysX 3 Particles). It will also work with PhysX 3.x objects such as particles and rigid bodies. The combination of APEX ForceField and APEX Particles allows a particle system that can be used to create a wide variety of force field effects. Good targets for APEX ForceField are things like explosions.

Limitations: The APEX Force Field module only supports PhysX 3.x on Windows, so it may not be included in all APEX distributions. ForceFields only interact with particles and rigid bodies at this point. Support for interaction with cloth will be added in a future APEX release.

ForceField Assets

This link describles all of the ForceField asset parameters.

ForceField Actors

This link describles all of the ForceField actor parameters.

Interaction with PhysX Shapes

ForceField actors can interact with PhysX shapes if the collision filtering settings are set correctly (set in the ForceField asset or actor).

Parameters

Lifetime

Force field lifetime determines how long a force field actor is active after creation.

Strength

Force field strength determines the amount of strength the force field applies to objects it interacts with. Strength magnitude is constant in the include shape of the actor, unless a spacial falloff is specified. Direction of force is dependent on the coordinate system type for the force field actor.

Spacial Falloff

Spacial falloff affects the strength of the force field in the include shape, depending on the distance of the point from the center of the force field.

Falloff Types

There are 3 predefined fallof shapes that can be used to configure spacial falloff.

The start and end distances for the falloff can be defined, and the force field strength between these distances will be scaled depending on the falloff type used.

Include Shapes

There are 5 different include shapes that can be used with a force field actor. Currently, only one include shape is supported for each force field actor. The include shape defines the space in which a force field acts in. The pose of the include shape can be used to rotate it, or to position it as an offset from the force field actor’s position.

To define the dimensions of the include shape and to position it relative to the force field actor, refer to the following table:

Shape | x | y | z | position (0,0,0) | orientation
sphere | radius |  |  | center of sphere |
capsule | radius | height |  | half height | vertical
cylinder | radius | height |  | half height | vertical
cone | top radius | height | bottom radius | half height | vertical
box | half dimension | half dimension | half dimension | center of box | as coordinates

Noise

In order to add randomness, noise can be applied to force fields. Simplex noise is used here. Strength value, space scale, time scale and noise octaves parameters can be used to configure the characteristics of noise to be added.

Force Field Types

Spherical Force Field

The only force field type supported for now is the spherical force field. Spherical force fields creates an area where forces act in a direction radially outwards from the center of the force field. Falloff distance is also calculated based on the distance from the center of this force field.

Debug Visualization

All APEX modules come with debug visualization rendering, to help understand what is happening in an APEX scene. When you hit the V key in SimpleForceField, default APEX visualization rendering is turned on, as well as default PhysX SDK visualization.

Click here for a list of the Forcefield debug visualization parameters

For general information on how to use debug visualization within APEX, please see Debug Visualization.

Errors and Warnings

APEX ForceField outputs the following error and warning messages using the standard APEX error stream.

ERROR CODE | MESSAGE | Explanation
APEX_INVALID_OPERATION | Not yet implemented! | The ForceField Module does not support dynamically editing the NvParameterized::Interface
APEX_INVALID_OPERATION | Not implemented! | The ForceField module does not support preparing an asset for another platform
APEX_DEBUG_WARNING | Driver error = %04d from file <%s>, line %i. |
APEX_DEBUG_WARNING | FORCEFIELD FATAL ERROR - invalid value |
APEX_DEBUG_WARNING | FORCEFIELD FATAL ERROR - out of memory |
APEX_DEBUG_WARNING | FORCEFIELD FATAL ERROR - not initialized |
APEX_DEBUG_WARNING | FORCEFIELD FATAL ERROR - launch failure |
APEX_DEBUG_WARNING | FORCEFIELD FATAL ERROR - out of resources |
APEX_DEBUG_WARNING | FORCEFIELD FATAL ERROR - lauch timeout |
APEX_DEBUG_WARNING | FORCEFIELD FATAL ERROR - invalid context |
APEX_DEBUG_WARNING | FORCEFIELD FATAL ERROR - error unknown |
APEX_DEBUG_WARNING | FORCEFIELD FATAL ERROR - error deitialized |
APEX_DEBUG_WARNING | FORCEFIELD FATAL ERROR - error invalid handle |
APEX_DEBUG_WARNING | FORCEFIELD FATAL ERROR - unknown error |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - u dimensions mismatch |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - v dimensions mismatch |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - v dimensions mismatch |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - u,v,w layout mismatch |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - u has no ghost cells |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - v has no ghost cells |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - w has no ghost cells |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - garbage hx,hy,hz value |
APEX_DEBUG_WARNING | [ERROR] AdvectionMacCormack3DDeviceF::initialize_storage - error allocating extra grids |
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDeviceF::invoke_kernel_downsample - bad level = %d |
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDevice::invoke_kernel_downsample - CUDA error “%s” | A CUDA error occurred. A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDeviceF::invoke_kernel_upsample - bad level = %d |
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDevice::invoke_kernel_upsample - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDevice::invoke_kernel_apply_upwind - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | Before BC: Max u at level %d = %f |
APEX_DEBUG_WARNING | After: Max u at level %d = %f |
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDeviceF::solve - garbage req_dt %f! |
APEX_DEBUG_WARNING | level %d |
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDeviceF::solve - too fast level = %d, _num_levels = %d! |
APEX_DEBUG_WARNING | Max u at level %d = %f |
APEX_DEBUG_WARNING | Max deriv_u at level %d = %f |
APEX_DEBUG_WARNING | [ERROR] Advection3D::initialize_storage - error allocating derivative grids |
APEX_DEBUG_WARNING | [ERROR] apply_3d_boundary_conditions_level1_nocorners - invalid boundary condition types %d, %d, %d, %d, %d,%d |
APEX_DEBUG_WARNING | [ERROR] apply_3d_boundary_conditions_level1_nocorners - must have at least 1 ghost point |
APEX_DEBUG_WARNING | [ERROR] apply_3d_boundary_conditions_level1_nocorners - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - invalid boundary condition types %d, %d, %d, %d, %d,%d |
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - layout mismatch |
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - must have at least 1 ghost point |
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - v_grid dimension mismatch (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - w_grid dimension mismatch (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - CUDA error in x “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - CUDA error in y “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - CUDA error in z “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] apply_3d_boundary_conditions_level1_nocorners - invalid boundary condition types %d, %d, %d, %d, %d,%d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDeviceT::clear_zero - cudaMemset failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_interior_data - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_interior_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_all_data - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_all_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_interior_data - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_interior_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_all_data - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_all_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::linear_combination - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDeviceF::linear_combination - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::linear_combination - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::linear_combination - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDeviceF::linear_combination - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::init - gpu buffer alloc failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_interior_data - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_interior_data - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::linear_combination - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::linear_combination - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::linear_combination - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::init - host buffer alloc failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_interior_data - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_interior_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_all_data - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_all_data - cudaMemcpy failed with %s |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_all_data - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost copy_partial_data_async - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid3DDeviceT::clear_zero - cudaMemset failed |
APEX_DEBUG_WARNING | [ERROR] Grid3DDeviceF::clear - CUDA error | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid3DDeviceF::clear - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - non specialized function called |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::linear_combination - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDeviceF::linear_combination - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::linear_combination - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::linear_combination - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDeviceF::linear_combination - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::init - gpu buffer alloc failed |
APEX_DEBUG_WARNING | ERROR: calling base implementation of initCUDAFunction |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::copy_interior_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::copy_interior_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::copy_interior_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::linear_combination - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::linear_combination - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::init - host buffer alloc failed |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::copy_all_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3DDeviceF::invoke_kernel_calculate_relax - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3DDeviceF::invoke_kernel_calculate_residual - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3DDeviceF::invoke_kernel_restrict - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3DDeviceF::invoke_kernel_prolong - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - garbage hx,hy,hz value %f %f %f |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::relax - failed at level %d |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::restrict_residuals - failed at level %d -> %d |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::prolong - failed at level %d -> %d |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::apply_boundary_conditions - failed at level %d |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::apply_boundary_conditions - failed at level %d |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3::initialize_storage - error in grid calculation |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - rhs has invalid ghost cells (%d,%d,%d), must be >= 1 |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - rhs dimension mismatch (%d,%d,%d) != (%d,%d,%d) |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - could not initialize _r_grid[0] |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - could not initialize _u_grid[0] |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - could not initialize _u_grid[%d] |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - could not initialize _b_grid[%d] |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - could not initialize _r_grid[%d] |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - grid dimension mismatch |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DBase::convert_bc_to_poisson_eqn - invalid boundary condition type %d |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DBase::initialize_base_storage - u dimensions mismatch |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DBase::initialize_base_storage - v dimensions mismatch |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DBase::initialize_base_storage - v dimensions mismatch |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DBase::initialize_base_storage - u,v,w layout mismatch |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::initialize_base_storage - must have at least one ghost cell on all sides |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DBase::initialize_base_storage - garbage hx,hy,hz value |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::calculate_divergence - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::subtract_grad_p - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::solve - could not enforce boundary conditions |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::solve - could not calculate divergence |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::solve - could not solve for pressure |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::solve - could not subtract gradient of pressure |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::solve - could not enforce boundary conditions |
APEX_DEBUG_WARNING | Max divergence: before = %.010f, after = %.010f (reduction %fx) |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::initialize_storage - failed to initialize base storage |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::initialize_storage - failed to initialize divergence |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::initialize_storage - divergence layout mismatch |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::initialize_storage - failed to initialize pressure_solver |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::initialize_storage - pressure layout mismatch |
APEX_DEBUG_WARNING | ERROR: calling base implementation of initCUDAFunction |
APEX_DEBUG_WARNING | [ERROR] sample_points_3d - position arrays do not have matching sizes |
APEX_DEBUG_WARNING | [ERROR] sample_points_3d - CUDA error | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] sample_points_3d - position arrays do not have matching sizes |
APEX_DEBUG_WARNING | [ERROR] sample_weighted_points_3d - CUDA error | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] calculate_velocity_weights - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] sample_points_mac_grid_3d - failed on u sampling |
APEX_DEBUG_WARNING | [ERROR] sample_points_mac_grid_3d - failed on v sampling |
APEX_DEBUG_WARNING | [ERROR] sample_points_mac_grid_3d - failed on w sampling |
APEX_DEBUG_WARNING | [ERROR] sample_points_minmax_3d - position arrays do not have matching sizes |
APEX_DEBUG_WARNING | [ERROR] sample_points_minmax_3d - CUDA error “%s” | A CUDA error occurred.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX ForceField Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »

APEX ForceField Module

Contents:

  • Force Field Introduction
    • ForceField Assets
    • ForceField Actors
      • Interaction with PhysX Shapes
    • Parameters
      • Lifetime
      • Strength
      • Spacial Falloff
      • Falloff Types
      • Include Shapes
      • Noise
    • Force Field Types
      • Spherical Force Field
    • Debug Visualization
    • Errors and Warnings

API

  • Forcefield API

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »

APEX Programmers Guide

Contents:

  • Introduction
    • Motivation
    • The NVIDIA APEX Solution
    • Definitions
    • Directory Structure
    • Version Numbers
  • Deployment
    • How to build
    • Build Configurations
    • The legacy module
    • What to ship
    • Application GUID (Windows only)
  • Assets and Actors
    • Authorable Objects
    • Asset Data Flow
    • Level Editor and Level Loading
    • Asset Authoring Class
    • Asset Class
    • Asset Inclusion
    • Asset Referencing
    • Actor Class
    • Actor Context
  • Framework Interfaces
    • Initialization
    • Loading Modules
    • Creating Scenes
      • Using CUDA
    • Loading Assets
      • Asset Authoring
      • Creating an Asset from an Authoring Class
      • Creating an Authoring from an Asset Class
      • Loading All Assets at Once
    • Instantiating Actors
    • Named Resource Provider
      • NRP Well Known Namespaces
    • Render Mesh Asset
    • Render Resources Interface
      • Renderable Actor Interface
      • User Implemented Classes
      • APEX Scene Based Render Resource Updating
      • Ad-Hoc Render Resource Updating
      • Example Overview
    • Materials
      • Default Material Library Implementation
    • Asynchronous Simulation Interface
    • Buffered API
    • View Matrix and the Projection Matrix
    • Level of Detail
    • Scalable Parameters
    • Ownership of PhysX SDK Objects
    • Serialization
    • Asset Preview
      • Asset Preview Colors
    • Errors and Warnings
  • Render Mesh Asset Interfaces
    • RenderMeshAssetAuthoring Interface
      • RenderMeshAssetAuthoring::SubmeshDesc
    • VertexBuffer Interface
    • VertexFormat Interface
  • D3D/OGL CUDA Interop
    • Requirements
    • Detailed Explanation
    • Notes
  • PhysX Visual Debugger
    • Introduction
    • Get PVD
    • Supported Configurations
    • Connecting to PVD
    • Example
    • Android Notes
  • Debug Visualization
    • Introduction
    • Framework Parameters
    • Module List
    • Examples
    • Debug Rendering Colors

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »

Assets and Actors

Authorable Objects

The Authorable Object is the heart of the APEX architecture. It is a data structure, the specification of how it will be authored, the specification of the run time functionality associated with it, and the software which implements this functionality.

APEX Modules implement one or more types of “authorable object”. For each authorable object, the module must implement 3 classes, derived from each of the 3 following base classes: AssetAuthoring, Asset, and Actor. The derived classes should be named: XxxYyyAssetAuthoring, XxxYyyAsset, and XxxYyyActor, where “Xxx” is the module name, and “Yyy” is the object name. The object name (“Yyy”) is optional if the module only contains one authorable object.

Thus, for every Asset class, there must be a corresponding Actor class, and a corresponding AssetAuthoring class.

Asset and AssetAuthoring classes are created, respectively, by the createAssetAuthoring() and createAsset() methods of the APEX SDK, whereas actor classes are created by the asset.

Asset Data Flow

Level Editor and Level Loading

Level editing and loading functionality is outside the scope of what is provided by APEX. The game engine must provide this functionality.

APEX requires that the level loading system be able to instantiate named assets. The level loading system must be able to handle instances with and without a position in the level. For example, particle systems do not have a position, but particle emitters do.

Asset Authoring Class

The classes derived from AssetAuthoring provided advanced methods for authoring asset data.

These public interface classes only derive from the AssetAuthoring base class. However, the implementation classes derive from their corresponding public interface classes, the implementation base class (apexAssetAuthoring), and the corresponding Asset implementation class. Only the implementation class derives from the corresponding Asset implementation class. The Public interface classes, AssetAuthoring and Asset, do not derive from each other. Inheritance from the Asset implementation class is necessary because the Asset implementation class contains all the member data.

The AssetAuthoring class adds various methods that are used (typically by the authoring tool) to provide enhanced authoring functionality. Basic parameters are accessible through the NvParameterized asset classes, which may be retrieved using the getNvParameterized() method.

Asset Class

The classes derived from Asset are containers for authorable data. They always implement the createApexActor() method. The member variables and NvParameterized class in the implementation class contain all the asset data.

All assets must contain a name. When an asset is created or deserialized, the name must be registered with the Named Resource Provider (see below), together with a pointer to the asset (an Asset*). This allows the asset to be referenced by name by other assets.

Asset Inclusion

It is sometimes useful to implement authorable objects that are generic enough to be included in other authorable objects. For example, a render mesh is included in a destructible or clothing asset. These objects may even be located in different modules.

The AssetAuthoring, Asset, or Actor classes of the included object must be automatically created by the corresponding classes of the “including” object when they are created.

The included asset is implemented using an NvParameterized included reference. It is automatically serialized and deserialized when the including asset is serialized or deserialized.

The including Actor must furthermore derive from Context. This will be the context in which the included Actor must be created, as shown above. This will be a different context than the one in which the including actor is created.

Asset Referencing

An alternative to “Asset Inclusion” is “Asset Referencing”. In asset referencing, an asset contains (at authoring time) the name and namespace of another asset. This could be another asset type defined in the same module, an asset type defined in another module, or even an asset type defined in the framework. Asset names can be resolved into a pointer to an asset (Asset*) using the Named Resource Provider. If the named asset has already been created, the pointer is returned immediately, but if the name cannot be resolved, the Named Resource Provider calls back to the application to give it a chance to create the named asset. If the application fails to create the named asset, a failure indication is returned and the name resolution fails. This, in turn, allows the referencing asset to fail actor creation.

Asset references are implemented using an NvParameterized named reference. This will include the name and “class name”, or APEX asset authorable namespace. For example, an APEX Impact Emitter will contain a named reference to an Instanced Object Simulation (IOS). This named reference will contain a name (BouncyPebblesIOS) and a className (BasicIosAsset), retrieved with NvParameterized::Interface::name() and NvParameterized::Interface::className(), respectively.

Actor Class

The Actor class represents a run time instance of the authorable data.

The Asset class is the primary source of configuration data for the Actor. All data that can be authored must come from the Asset. However, run time data may also be provided by the game engine. Run time data that is needed for Actor creation should be provided in an NvParameterized descriptor class passed to the createApexActor() method, for example, initial position. This data is typically provided by the game engine’s level loading code. Run time data that is not needed for Actor creation (i.e.: that can be provided later) should be provided by calling “set” methods of the Actor.

Even in cases where it only makes sense to have a single instance of the Actor class, the run-time functionality of the authorable object must still be placed in an Actor class rather than in the Asset class.

All instances of the Actor class are “owned” by the Asset that created them. (See discussion of ownership in “Actor Context” below.) Thus, the Asset implements the createActor() and releaseActor() methods.

Actor Context

All instances of the Actor class also have a “context”. The concept of a context is completely different than the owner. The “context” is the context in which the Actor is created or instantiated, and it will be a class that derives from Context. A pointer to the context of an Actor is a standard argument to the Asset::createApexActor() method.

For most Actors, the context will be an instance of the Scene class. However, some Actors may be created in other contexts, such as the ApexSdk. Some Actors may even be created in the context of another Actor. The type of an Actor’s context is defined on a Asset/Actor type basis.

The Context class provides a method to remove all actors, removeAllActors(), which removes all actors from the context and calls their release() methods. This allows the context itself to be easily released. Context also provides a method to create and release a renderable iterator, createRenderableIterator(), which provides an iterator to iterate over the set of renderables in the context.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »

Debug Visualization

Introduction

Debug visualization features can be controlled using parameters which are stored using separate NvParameterized classes - one for general debug rendering parameters, and one for each loaded module which stores parameters specific to that module. Specific details on parameters can be found in their respective module’s programmers guides.

To get the NvParameterized object for debug rendering parameters, the following must be done:

//Get APEX framework debug rendering parameters
NvParameterized::Interface &dbgRenderParams = *m_apexScene->getDebugRenderParams();
//Get clothing debug rendering parameters
NvParameterized::Interface &dbgRenderParamsClothing = *m_apexScene->getModuleDebugRenderParams("Clothing");
//Get emitter debug rendering parameters
NvParameterized::Interface &dbgRenderParamsEmitter = *m_apexScene->getModuleDebugRenderParams("Emitter");

Framework Parameters

The APEX Framework has a set of parameters to control debug visualization for items at the framework level:

  • APEX Framework

Module List

Module names must be selected from this list (with links to the parameter descriptions):

  • BasicFS
  • BasicIos
  • Clothing
  • Destructible
  • Emitter
  • ForceField
  • Iofx
  • TurbulenceFS

Examples

After getting the NvParameterized object, parameters can be modified. Sample code which modifies debug rendering parameters are as follows:

// It is important to enable the global debug visualization
NvParameterized::setParamBool(dbgRenderParams, "Enable", true);
// The scale of the debug visualization may be altered globally
NvParameterized::setParamF32(dbgRenderParams, "Scale", 1.0f);
// Draw the simulation mesh for clothing actors, scaled to 90%
NvParameterized::setParamF32(dbgRenderParamsClothing, "PhysicsMeshWire", 0.9f);
// The APEX emitters feature some hierarchy, so the dot notation gets you to the individual parameters
NvParameterized::setParamBool(dbgRenderParamsEmitter, "apexEmitterParameters.VISUALIZE_APEX_EMITTER_ACTOR", true);
NvParameterized::setParamBool(dbgRenderParamsEmitter, "groundEmitterParameters.VISUALIZE_GROUND_EMITTER_RAYCAST", true);

Note

Debug rendering parameters for emitters are further subclassed into apex, ground and impact emitter parameters. Refer to the emitter programmers guide for more details.

The APEX debug rendering is output through the APEX scene’s render resources interface:

// render debug-render scene
m_apexScene->lockRenderResources();
m_apexScene->updateRenderResources();
m_apexScene->dispatchRenderResources(*m_apexRenderer);
m_apexScene->unlockRenderResources();

The application may also tunnel the PhysX debug rendering (DebugRenderable or PxRenderBuffer) through the APEX rendering interface:

nvidia::apex::RenderDebug* m_apexRenderDebug = m_apexSDK->createApexRenderDebug();
#if PX_PHYSICS_VERSION_MAJOR == 2
    const DebugRenderable* debugRenderable = m_apexScene->getPhysXScene()->getDebugRenderable();
    if (debugRenderable)
    {
        m_apexRenderDebug->addDebugRenderable(*debugRenderable);
    }
#elif PX_PHYSICS_VERSION_MAJOR == 3
    const physx::PxRenderBuffer& renderBuffer = m_apexScene->getPhysXScene()->getRenderBuffer();
    if (m_apexRenderDebug != NULL)
    {
        m_apexRenderDebug->addDebugRenderable(renderBuffer);
    }
#endif

Debug Rendering Colors

Debug rendering uses the following table of colors:

Color Parameter | Default (ARGB) | Description
Default | 0x00000000 | Currently unused
PoseArrows | 0x00000000 | Currently unused
MeshStatic | 0x00000000 | Currently unused
MeshDynamic | 0x00000000 | Currently unused
Shape | 0x00000000 | Currently unused
Text0 | 0x00000000 | Currently unused
Text1 | 0x00000000 | Currently unused
ForceArrowsLow | 0xFFFFFF00 | Forcefield arrows in wind/explosion
ForceArrowsNorm | 0xFF00FF00 | Forcefield arrows in wind/explosion
ForceArrowsHigh | 0xFFFF0000 | Forcefield arrows in wind/explosion
Color0 | 0x00000000 | Currently unused
Color1 | 0x00000000 | Currently unused
Color2 | 0x00000000 | Currently unused
Color3 | 0x00000000 | Currently unused
Color4 | 0x00000000 | Currently unused
Color5 | 0x00000000 | Currently unused
Red | 0xFFFF0000 | Standard colors
Green | 0xFF00FF00 | Standard colors
Blue | 0xFF0000FF | Standard colors
DarkRed | 0xFF800000 | Standard colors
DarkGreen | 0xFF008000 | Standard colors
DarkBlue | 0xFF000080 | Standard colors
LightRed | 0xFFFF8080 | Standard colors
LightGreen | 0xFF80FF00 | Standard colors
LightBlue | 0xFF00FFFF | Standard colors
Purple | 0xFFFF00FF | Standard colors
DarkPurple | 0xFF800080 | Standard colors
Yellow | 0xFFFFFF00 | Standard colors
Orange | 0xFFFF8000 | Standard colors
Gold | 0xFF808000 | Standard colors
Emerald | 0xFF008080 | Standard colors
White | 0xFFFFFFFF | Standard colors
Black | 0x00000000 | Standard colors
Gray | 0xFF808080 | Standard colors
LightGray | 0xFFC0C0C0 | Standard colors
DarkGray | 0xFF404040 | Standard colors

Debug rendering colors are stored using NvParameterized, and can be customized by first getting the NvParameterized object, then modifying the parameters as follows:

//Initialize debug colors parameters
NvParameterized::Interface &dbgColorParams = *GetApexSDK()->getDebugColorParams();
NvParameterized::setParamU32(dbgColorParams, "Red", 0xFFFFFF00);
NvParameterized::setParamU32(dbgColorParams, "ForceArrowsNorm", 0xFFFF0000);

The above code will replace any existing red draw code with yellow, and replacing green with red for normal forcefield arrows in wind and explosion modules.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »

Deployment

How to build

APEX 1.4 requires PhysX 3.4 to build when build with PhysX.

To build the APEX projects in this distribution, the PhysX SDK path in the nxpath.vsprops files must be modified. The UpdatePhysXPaths.vbs script is provided for this purpose. It will modify the nxpath.vsprops files under the compiler folders. See the readme.txt at the top level of the APEX distribution for details.

We recommend at least Microsoft Visual Studio 2010 SP1 to build APEX.

Build Configurations

APEX ships in four configurations: release, profile, checked, and debug.

release
The release configuration of APEX is built for minimal footprint and maximum speed. It omits most checks and instrumentation. Debug visualization and asset authoring are not available in the release configuration.
profile
The profile configuration of APEX supports PVD profiling and memory tracking, asset authoring, and debug visualization. It also supports kernel profiling on Windows, which uses 128 MB of video memory for a profiling buffer.
checked
The checked configuration of APEX supports PVD profiling and memory tracking, asset authoring, debug visualization, and runtime assertions. It does not support kernel profiling on Windows. Unlike PhysX, the APEX checked configuration does not contain extra code to detect bad user input, so it should not be significantly slower than other configurations.
debug
The debug configuration of APEX is an unoptimized build that supports PVD profiling and memory tracking, asset authoring, debug visualization, and runtime assertions.

Our recommendation when using PhysX 3.x is to develop with checked, profile with profile, and ship with release.

PhysX 3.x: APEX and PhysX 3.x contain shared code, so it is important that the configurations match. For example, if you link to the checked PhysX build you must also link to the checked APEX build.

PhysX version | PhysX config | Use this APEX config
3.x | release | release
3.x | profile | profile
3.x | checked | checked
3.x | debug | debug

The legacy module

APEX standard modules are only able to load the latest version of APEX assets. The legacy module (APEX_Legacy) is used for loading older versions of APEX assets. For example, the 1.2.0 version of APEX_Clothing can only load APEX 1.2.0 clothing assets, but APEX_Legacy can also load assets from APEX 1.1 or 1.0.

If you upgrade your APEX version during development, you should update all your APEX assets to the latest version before shipping your application. When you serialize an APEX asset it is automatically stored as the latest version, so upgrading is as simple as deserializing and serializing all APEX assets.

The legacy module is typically used during application development, but shouldn’t need to be shipped with the application.

For more information on serializing assets for specific platforms, see nxparam-serialization-label.

What to ship

Typically your application should ship with the release configuration of APEX. An exception would be if you want to give end users the ability to author APEX assets, for example if you include a game editor with your game. In that case you would want to ship with the profile or checked configuration instead, because the release configuration strips out all authoring code.

You do not typically need to ship the legacy module at all.

You do not typically need to link every APEX library with your application. Here are the libraries you need to include with your application for each APEX feature. These examples list the Win32 DLLs, but substitute the equivalent name for your platform. For example, APEX_Clothing_x86.dll could be APEX_Clothing.a or APEX_Clothing.lib.

Clothing

  • ApexFramework_x86.dll
  • APEX_Clothing_x86.dll
  • APEX_ClothingGPU_x86.dll (only needed for GPU support on Windows)
  • PhysX3Gpu_x86.dll (only needed for GPU support on Windows)
  • PhysXDevice.dll (only needed for GPU support on Windows)

Destructibles

  • ApexFramework_x86.dll
  • APEX_Destructible_x86.dll

APEX Particles (Windows only)

  • ApexFramework_x86.dll
  • APEX_Particles_x86.dll
  • PhysX3Gpu_x86.dll
  • PhysXDevice.dll

Turbulence (Windows only)

  • ApexFramework_x86.dll
  • APEX_Particles_x86.dll
  • APEX_Turbulence_x86.dll
  • PhysX3Gpu_x86.dll
  • PhysXDevice.dll

Force Fields (PhysX 3.x only)

  • ApexFramework_x86.dll
  • APEX_Particles_x86.dll
  • PhysX3Gpu_x86.dll
  • PhysXDevice.dll

Application GUID (Windows only)

If your application employs APEX modules that use CUDA and you have made local modifications to your APEX DLLs, you should use a GUID so that patches for new GPU architectures can be released for your application. You can obtain a GUID for your application from NVIDIA. If you do not pass your own GUID into APEX, when future patches are released you will get the default patched version of APEX, which could be problematic if you’ve modified APEX. Also, remember that you should also pass this same GUID to PhysX when you create the PhysX SDK and the CUDA Context Manager.

Give the application GUID to APEX through the nvidia::apex::ApexSDKDesc when creating the APEX SDK.

Give the application GUID to the CUDA Context Manager through the physx::PxCudaContextManagerDesc when creating the CUDA Context Manager.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »

Framework Interfaces

Initialization

In order to use APEX, the first thing that must be done by the application is to create a single instance of the ApexSDK class:

#include "Apex.h"

    extern PxFoundation*            gFoundation;
extern PxPhysics*           gPhysicsSDK;
extern PxCookingInterface*  gCooking;
extern PxUserOutputStream*  gOutputStream;
ApexSDK*                    gApexSDK;

...

ApexSDKDesc                 apexDesc;
ApexCreateError             errorCode;
apexDesc.outputStream = gOutputStream;
    apexDesc.foundation = gFoundation;
apexDesc.physXSDK = gPhysicsSDK;
apexDesc.cooking = gCooking;
apexDesc.renderResourceManager = new UserRenderResourceManager();

gApexSDK = CreateApexSDK(apexDesc, &errorCode);

The PhysX SDK must have already been initialized, so you that you have a PxPhysics*. Most functionality of APEX is provided directly or indirectly through the ApexSDK class. For example, scene creation and APEX module initialization is performed by calling methods of the ApexSDK class.

Loading Modules

The ApexSDK class provides a single generic public API for loading modules, called createModule(). Providing a single generic API makes it possible for third-parties to develop modules and ship module binaries (libs and DLL’s) that are compatible with a particular version of the APEX SDK and of the PhysX SDK.

The module is identified by its filename, without path and without suffix/extension, which is the first argument to createModule(). The second argument to createModule() is a pointer to an error result. The APEX SDK will ensure that the loaded module matches the APEX and PhysX SDK versions. Module specific parameters, if any, must be passed to the module using a subsequent call to the module’s init() method.

Here is an example:

#include "ApexSDK.h"
#include "ModuleDestructible.h"
#include "NvParamUtils.h"

ModuleDestructible*       gModuleDestructible;

...

ApexCreateError            errorCode;
NvParameterized::Interface* moduleDesc;
#if MODULE_STATIC_LINKED
    instantiateModuleDestructible();
#endif

gModuleDestructible = static_cast<ModuleDestructible*> ( GetApexSDK()->createModule("Destructible", &errorCode) );
PX_ASSERT(gModuleDestructible);

moduleDesc = gModuleDestructible->getDefaultModuleDesc();

NvParameterized::setU16( *moduleDesc, "maxActorCreatesPerFrame", 50 ); // 50 is just a random number for demonstration purposes
gModuleDestructible->init( *moduleDesc );

Creating Scenes

The APEX scene (class Scene) represents a unique physics world in which various types of objects can be instantiated. It mirrors the PhysX SDK PxScene class. An instance of the Scene class should be created for each PxScene in which APEX will be used.

The APEX scene provides a centralized interface for advancing the simulation and accessing the rendering data output from APEX.

The Scene derives from Context, and therefore can contain (or be the context for) APEX actors. In fact, all *asset::create*Actor() methods must take an Scene argument.

The Scene operates in similar fashion to the PhysX SDK scene, however, the APEX scene can exist, and even contain APEX actors, without having an associated PhysX SDK scene. But in order to actually perform simulation in the PhysX SDK, an PhysX scene must be associated with the APEX scene, either by providing a pointer to it in the SceneDesc descriptor structure, or by using the setPhysXScene() method.

Using CUDA

An APEX scene will use CUDA if the associated PhysX scene is given a GpuDispatcher. See the PhysX 3.x documentation on GPU Resource Management for more information.

Loading Assets

At run-time, asset creation is typically performed by the game engine’s “level loader” using the Named Resource Provider’s user defined ResourceCallback::requestResource() method. The level loader typically processes a set of asset instances that have been placed in the level. At a minimum, the game engine must be capable of storing the following information for each asset instance in the level: name of the asset, the type of the asset, and position and orientation of the instance. For each asset instance found in a level, the level loader should query the NRP to determine whether or not the named asset has been already loaded. It should use the ResourceProvider::getResource() method to do so. If the asset has not been loaded, a callback to ResourceCallback::requestResource() will be immediately triggered to request that the asset be loaded. Either way, getResource() will return a void pointer to the loaded asset that can subsequently be used to create the instance of the asset: the Actor.

Assets use NvParameterized classes to store all of their serialized data. APEX provides a serializer which will serialize and deserialize to either an ASCII XML format or a binary format.

To load APEX assets, the ResourceCallback::requestResource() callback should first create a PxFileBuf data stream using ApexSDK::createStream() for reading the asset from non-volatile storage. In the APEX samples the assets are mapped to a single file and not bundled into packages, though a game engine can interpret an asset name from ::requestResource() however it wishes.

If the APEX default stream implementation is being used (e.g.: the APEX samples), a stream can be created with the ApexSDK::createStream() method:

physx::PxFileBuf* stream = GetApexSDK()->createStream( "asset.xml", physx::PxFileBuf::OPEN_READ_ONLY );

Otherwise, an instance of a user defined stream class (derived from the pure virtual PxFileBuf base class) should be created.

Create the NvParameterized::Serializer, specifying the serialization format (this may or may not be part of the asset name in the callback):

// NvParameterized::Serializer * ApexSDK::createSerializer(NvParameterized::Serializer::SerializeType type)
NvParameterized::Serializer * ser = GetApexSDK()->createSerializer(serType); // serType is either NST_XML or NST_BINARY

You may also specify custom Traits object if you want to change some aspects of serializer behavior (see NvParameterized Guide for more details):

// NvParameterized::Serializer * ApexSDK::createSerializer(NvParameterized::Serializer::SerializeType type, NvParameterized::Traits *traits)
NvParameterized::Serializer * ser = GetApexSDK()->createSerializer(serType, customTraits);

You may determine stream format using ApexSdk::getSerializeType() method:

NvParameterized::Serializer::SerializeType serType = GetApexSDK()->getSerializeType(*stream);
    PX_ASSERT( serType != NvParameterized::SerializeType::NST_LAST );

You may also check target platform for your binary file (e.g. before you do inplace deserialization):

NvParameterized::SerializePlatform platform;
GetApexSDK()->getSerializePlatform(*stream, platform);

if( platform == NvParameterized::SerializePlatform::GetCurrentPlatform() )
    ...

The NvParameterized asset classes must be deserialized using the NvParameterized::Serializer::deserialize() method. The parameters required are the data stream and an instance of the NvParameterized::Serializer::DeserializedData class. All assets which are serialized in the stream will be deserialized and stored as NvParameterized classes which can be accessed through the DeserializedData object.

The NvParameterized class(es) serialized in the PxFileBuf may be accessed from the DeserializedData object and created using the ApexSDK::createAsset(NvParameterized::Interface parameters, const char * name)* method:

const char *assetName; // input parameter in ::requestResource()
Asset *asset;
NvParameterized::Serializer::DeserializedData data;

serializer->deserialize(*stream, data); // assume there is one asset in the stream for this case
NvParameterized::Interface *params = data[0];
asset = GetApexSDK()->createAsset( params, assetName );

The NvParameterized object(s) retrieved from the serializer should not be released or destroyed by the application. The act of creating an asset from an NvParameterized object passes ownership of the object to the asset.

The asset can be released using ApexSDK::releaseAsset() or Asset::release(). If the asset was loaded as a result of manually calling the ResourceCallback::requestResource() callback, then it should be released using ResourceProvider::releaseResource().

Asset Authoring

Generic asset authoring creation methods are used to create an asset authoring class:

AssetAuthoring * ApexSDK::createAssetAuthoring( const char *authorableTypeName );
AssetAuthoring * ApexSDK::createAssetAuthoring( const char *authorableTypeName, const char *name );

Asset authoring type names are retrieved from the individual APEX asset header files:

// DestructibleAsset.h
#define DESTRUCTIBLE_AUTHORING_TYPE_NAME "DestructibleAsset"

Asset authoring classes should be released using:

void ApexSDK::releaseAssetAuthoring( AssetAuthoring& );

Since all asset data is stored in NvParameterized classes, it is all available to be edited from the NvParameterized object retrieved from the asset author using the AssetAuthoring::getNvParameterized() method.

Creating an Asset from an Authoring Class

An APEX Asset and Asset Authoring basically contain the same NvParameterized class, but ownership must be considered.

If one wanted to keep the Asset Authoring class and create a new Asset, the ApexSDK::createAsset( AssetAuthoring&, const char *name ) method may be used. This will perform a copy of the NvParameterized class data:

AssetAuthoring *author; // initialized elsewhere
Asset *asset = GetApexSDK()->createAsset( *author, "uniqueAssetName" );

If one no longer needed the Asset Authoring class and wanted to create a new Asset, a more efficient process may be used (no NvParameterized data copy required):

AssetAuthoring *author; // initialized elsewhere
NvParameterized::Interface* oldInterface = author->releaseAndReturnNvParameterizedInterface();

Asset *asset = GetApexSDK()->createAsset( oldInterface, "uniqueAssetName" );

Creating an Authoring from an Asset Class

An APEX Asset and Asset Authoring basically contain the same NvParameterized class, but ownership must be considered.

If one wanted to keep the Asset class and create a new Asset Authoring, a copy of the NvParameterized class data must be made:

Asset *asset; // initialized elsewhere
NvParameterized::Interface* oldInterface = asset->getAssetNvParameterized();

// make the copy
NvParameterized::Interface* newInterface = GetApexSDK()->getParameterizedTraits()->createNvParameterized(oldInterface->className());
newInterface->copy( oldInterface );

AssetAuthoring *author = GetApexSDK()->createAssetAuthoring( newInterface, "uniqueAssetAuthoringName" );

If one no longer needed the Asset class and wanted to create a new Asset Authoring, a more efficient process may be used (no NvParameterized data copy required):

Asset *asset; // initialized elsewhere
NvParameterized::Interface* oldInterface = asset->releaseAndReturnNvParameterizedInterface();
AssetAuthoring *author = GetApexSDK()->createAssetAuthoring( oldInterface, "uniqueAssetAuthoringName" );

Loading All Assets at Once

There are several scenarios where a game may require all assets to be loaded at once:

  • Some games may require that APEX loads all of its assets at level load time (possibly in a deterministic order) to avoid asset loading during game play.
  • Some games may require that APEX load all of its assets at one time so that they have information about which asset files to bundle into a “cooked build” of a level.
  • Some games may require assets to be loaded asynchronously (e.g.: over a slow network connection). They need to be able to start streaming all their assets during the “level loading” time.

Since APEX assets can reference other APEX assets by name, it is not normally possible for the level loading code to know, up front, about all assets that are going to be needed. In order to solve this problem, APEX provides an API that can be used to force the immediate loading of all referenced, but not yet loaded assets.

The game engine is responsible for calling ApexSDK::forceLoadAssets() as many times as it returns a number greater than 0. Each time it calls forceLoadAssets() it should expect calls to its registered ResourceCallback::requestResource() callback to load the requested asset:

PxU32 ApexSDK::forceLoadAssets()

This method returns the number of assets force loaded by all of the existing APEX modules. It will also force load Render Mesh assets, which are not contained in a module.

Instantiating Actors

Once an asset has been created, de-serialized, and registered with the Named Resource Provider, instantiating it in a scene is done by calling the Asset::createApexActor() method. Additional information, such as its global pose (position and orientation in the scene), that is commonly available to the level loader can be provided in an NvParameterized descriptor data structure that is passed to the createApexActor() method along with a pointer to the APEX Scene:

NvParameterized::Interface * destructibleDesc = asset->getDefaultActorDesc();

/* Set the actor's pose */
NvParameterized::setParamMat44( *destructibleDesc, "globalPose", pose );

/* Create the destructible actor in the APEX scene */
DestructibleActor* actor = asset->createApexActor( *destructibleDesc, *gApexScene );

The Asset classes own the NvParameterized::Interface object that is retrieved from Asset::getDefaultActorDesc(), so there is no need for the application to destroy it.

Named Resource Provider

The Named Resource Provider (NRP) is a public interface class in the APEX Framework (class ApexResourceProvider). It’s purpose is to provide name to address mapping for APEX assets (Asset and derived classes) and for miscellaneous game engine resources that APEX authorable objects refer to by name, such as materials/textures. It also provides a callback interface to allow the application to load the named asset and thus resolve the mapping.

The NRP maintains mappings from a namespace/name pair to a resource pointer. Namespaces and names are both null terminated character strings (char*), and resource pointers are void pointers (void*).

Internally to APEX, a unique integer is associated with every namespace/name pair. This integer is used to efficiently access the current value of a resource pointer, without requiring the NRP to perform string operations everytime the resource pointer is queried.

Every module, when created, creates a new namespace for each type of authorable object (asset) that it implements. The namespace for an authorable object will not be changed, because it is through this name that game developers, as well as other modules, will reference assets of this type.

Whenever any asset is referenced by name (e.g.: when some other asset is loaded), APEX uses the createResource() method to create a mapping from the namespace/name pair to a unique resource identifier. This only needs to be done once, as resource identifiers are permanently (for the lifetime of the APEX SDK) associated with the namespace/name pair. The referencing object should save the assigned resource identifier for subsequent use with the getResource() method to query the current value of the resource pointer. APEX modules must, however, not save the resource pointer for future use. Rather, they must call getResource() every time they need to access the resource pointer. This allows the application to call setResource() at any time to change the value of the resource pointer. When the referencing object is done referencing the resource (e.g.: when the referencing object is deleted), it must call releaseResource(), which will call the ResourceCallback::releaseResource() callback if the number of references is now zero.

The public interface consists of a single method, setResource(), and two callback functions, requestResource() and releaseResource(), that are implemented in a user defined subclass of the pure virtual base class, ResourceCallback. The application may call setResource() at any time, to create a mapping between a namespace/name pair and a resource pointer. This can be safely done before the createNameSpace() or createResource() calls are made by the APEX modules. If the application has not yet called setResource() to create a mapping (for a particular namespace/name pair) when getResource() is called for the first time from within APEX, then the NRP will call the requestResource() callback to request the resource pointer to use for the mapping. The callback must return a value, however, the value may be 0 (NULL). The callback will only be called once for a given namespace/name pair. If the application wants to subsequently change the mapping, it must call setResource(). This may be done as often as the application wishes, and getResource() will always return the correct (most recent) resource pointer. The user class implementing ResourceCallback must be provided in the descriptor when the APEX SDK is initialized, in the call to CreateApexSDK().

NRP Well Known Namespaces

NSCollisionGroup

A namespace for names of collision groups (CollisionGroup). Each name in this namespace must map to a 5-bit integer in the range [0..31] (stored in a void*). The NRP will not automatically generate release requests for names in this namespace:

#define APEX_COLLISION_GROUP_NAME_SPACE             "NSCollisionGroup"

NSCollisionGroup128

A namespace for names of GroupsMasks. Each name in this namespace must map to a pointer to a persistent 128-bit GroupsMask type. The NRP will not automatically generate release requests for names in this namespace:

#define APEX_COLLISION_GROUP_128_NAME_SPACE         "NSCollisionGroup128"

NSCollisionGroupMask

A namespace for names of collision group masks. Each name in this namespace must map to a 32-bit integer (stored in a void*), wherein each bit represents a collision group (CollisionGroup). The NRP will not automatically generate release requests for names in this namespace:

#define APEX_COLLISION_GROUP_MASK_NAME_SPACE        "NSCollisionGroupMask"

ApexMaterials

A namespace for graphical material names. Each name in this namespace maps to a pointer to a game-engine defined graphical material data structure. APEX does not interpret or dereference this pointer in any way. APEX provides this pointer to the UserRenderResource::setMaterial(void *material) callback to the rendering engine. This mapping allows APEX assets to refer to game engine materials (e.g.: texture maps and shader programs) without imposing any limitations on what a game engine graphical material can contain. The NRP will not automatically generate release requests for names in this namespace:

#define APEX_MATERIALS_NAME_SPACE                   "ApexMaterials"

NSPhysicalMaterial

A namespace for physical material names. Each name in this namespace maps to MaterialID, which is a data type defined by the PhysX SDK. The NRP will not automatically generate release requests for names in this namespace:

#define APEX_PHYSICS_MATERIAL_NAME_SPACE            "NSPhysicalMaterial"

NSCustomVBNames

A namespace for custom vertex buffer semantics names. Each name in this namespace maps to a pointer to a game-engine defined data structure identifying a custom vertex buffer semantic. APEX does not interpret or dereference this pointer in any way. APEX provides an array of these pointers in UserRenderVertexBufferDesc::customBuffersIdents, which is passed the rendering engine when requesting allocation of vertex buffers:

#define APEX_CUSTOM_VB_NAME_SPACE                   "NSCustomVBNames"

Namespaces for Asset names

A new namespace is created for each type of Authorable Object (i.e. Asset).

The names in this namespace will be the names of assets of the specified type. Each entry maps to a pointer to the asset class for the named asset.

The NRP will automatically generate release requests for names in this namespace when the APEX SDK is released.

  • ApexRenderMesh
  • ClothingAsset
  • DestructibleAsset
  • ApexEmitterAsset
  • GroundEmitterAsset
  • ImpactEmitterAsset
  • IofxAsset

Render Mesh Asset

The RenderMeshAsset class, and the associated RenderMeshAssetAuthoring and RenderMeshActor classes, implement a general purpose triangle mesh asset. These classes are provided by the APEX Framework, and can be used, by named reference, or by inclusion by assets in other modules.

The RenderMeshAsset stores a vertex buffer accessible through an VertexBuffer interface. This vertex buffer supports a wide variety of attributes: position, normal, tangent, binormal, color, bone indices, bone weights, and up to 4 sets of [U,V] coordinates. It also supports a variety of formats for each attribute. See Render Mesh Asset Interfaces.

The mesh can be subdivided in two orthogonal ways: by “part” and by “sub-mesh”. Furthermore, each vertex of the mesh can be associated with one or more “bones” (transformation matrices).

Each “part” is a unique subset of the triangles of the mesh for which rendering can be individually enabled or disabled. This is called “visibility”, and is controlled, per instance, using the RenderMeshActor::setVisibility(..) method. A part can span several sub-meshes (see below), such that it can use different materials for different triangles.

Each “sub-mesh” is a unique subset of the vertices and triangles of the mesh that is assigned a particular material name. At run-time, the material name is mapped to a user-defined pointer, using the Named Resource Provider. This pointer is subsequently passed to the rendering engine through the Render Resources Interface. A sub-mesh can contain triangles from many different parts.

Each “bone” is a transform matrix (position, rotation, and scale) that can be used at run-time to transform the position of the vertices of the mesh. Each vertex can be associated with one or more bones using the “bone index” vertex semantic. If a vertex is associated with more than one bone, the “bone weight” semantic is also used to provide a weighting factor that determines the proportion in which the vertex position is transformed by each bone. If all the vertices of a part are associated with a single common bone, the part will be rigid. If they are associated with different bones, the part will be “skinned”.

Render Resources Interface

The APEX Framework provides a standard interface for modules to interface with the game’s rendering engine. The purpose of the interface is to pass data (e.g.: vertex buffers, index buffers, transform buffers) from APEX to the rendering engine for rendering. APEX does not directly render anything (i.e.: no calls to D3D or OpenGL), nor does specify or control how or when things are rendered. It simply seeks to pass data that it generates or updates to the game’s rendering engine in a flexible yet efficient manner.

Renderable Actor Interface

All transactions with the “Interface to Rendering” are initiated by the game calling an APEX API. This interface is thread-safe, and can be called at any time during the frame, including during simulation, and while calls are being made from other game threads to other APEX API’s (assuming the locking semantics described below are respected). These calls are all methods of the Renderable class, which all renderable APEX actors derive from:

class Renderable
{
public:
    const PxBounds3& getBounds() const;
    void updateRenderResources();
    void dispatchRenderResources( UserRenderer &renderer, PxReal lod );
}

Calling updateRenderResources() on an APEX actor allows APEX to issue callbacks to allocate any buffers that need to be allocated, and to update (fill-in) any buffers that need to be updated. Other than issuing these callbacks, updateRenderResources() will not perform any additional computations, so as not to adversely impact the performance of the thread that called it.

Note

By performing these tasks in callbacks from updateRenderResources(), APEX allows the game to control when buffers are allocated and written to, as well as the thread context in which this occurs. These buffers can therefore be directly allocated from the graphics subsystem (e.g.: from D3D), even when the graphics API is not thread-safe, thus avoiding additional buffer copies.

updateRenderResources() must be called before dispatchRenderResources(), but can be skipped entirely if the actor will not be rendered that frame.

Calling dispatchRenderResources() on an APEX actor triggers APEX to call the provided renderer’s renderResource() method for each of the actor’s UserRenderResources. It will not update or allocate any new rendering resources. It can be called as many times as the game wishes to generate the same set of RenderContexts.

Warning

APEX is completely unaware of D3D device resets and will not replay writeBuffer() calls into static vertex or bone buffers. It is the user’s responsibility to request for buffers to be rewritten. For this, updateRenderResources() accepts an optional boolean flag (rewriteBuffers). When set to true, updateRenderResources() will make the necessary writeBuffer() calls to rewrite affected buffer data.

Examples of scenarios that might lead to a device reset include: resizing the application window, switching to full screen mode or changing the screen resolution while the application is running.

There are two important things to note when using the rewriteBuffers flag.

  1. Do not set rewireBuffers to true the first time UpdateRenderResources() is called.

2. UpdateRenderResources should be called twice when the buffers need to be rewritten. First with rewriteBuffers=true, then with rewriteBuffers=false.

User Implemented Classes

APEX interfaces with the game engine via several classes which are implemented by the user. The first class manages the creation and deletion of render resources. A user defined instance of UserRenderResourceManager is provided to the ApexSDK at startup, and is used globally by APEX to request/release render resources from the game.

class UserRenderResourceManager
{
public:
    virtual UserRenderVertexBuffer*   createVertexBuffer( const UserRenderVertexBufferDesc& desc );
    virtual void                        releaseVertexBuffer( UserRenderVertexBuffer& buffer );

    virtual UserRenderIndexBuffer*    createIndexBuffer( const UserRenderIndexBufferDesc& desc );
    virtual void                        releaseIndexBuffer( UserRenderIndexBuffer& buffer );

    virtual UserRenderBoneBuffer*     createBoneBuffer( const UserRenderBoneBufferDesc& desc );
    virtual void                        releaseBoneBuffer( UserRenderBoneBuffer& buffer );

    virtual UserRenderInstanceBuffer* createInstanceBuffer( const UserRenderInstanceBufferDesc& desc );
    virtual void                        releaseInstanceBuffer( UserRenderInstanceBuffer& buffer );

    virtual UserRenderSpriteBuffer*   createSpriteBuffer( const UserRenderSpriteBufferDesc& desc );
    virtual void                        releaseSpriteBuffer( UserRenderSpriteBuffer& buffer );

    virtual UserRenderSurfaceBuffer*  createSurfaceBuffer( const UserRenderSurfaceBufferDesc& desc );
    virtual void                        releaseSurfaceBuffer( UserRenderSurfaceBuffer& buffer );

    virtual UserRenderResource*       createResource( const UserRenderResourceDesc& desc );
    virtual void                        releaseResource( UserRenderResource& resource );
};

APEX only requests new resources from this interface in the context of calls to updateRenderResources(), so those functions generally do not need to be thread safe.

Warning

Any APEX API call that results in actor deletion can result in an immediate callback to UserRenderResourceManager (in the context of the calling thread) to release the associated render resources. Therefore, the release methods of this user implemented class MUST be thread safe.

Each of the UserRender*Buffer classes are also abstract and must be implemented by the user. The buffer descriptor passed to the create methods will describe the data format of each semantic (or member) of that buffer, so the user class has the ability to pack or interleave that data into as many or as few GPU buffers as necessary. The descriptor will also contain a hint from APEX on the usage of that buffer; whether it is static or dynamic. Each render buffer class has a user-implemented write buffer method that can be called by APEX (only from within the context of updateRenderResources()) to update the data in that buffer. The write methods are defined as follows:

// new implementation so the renderer receives all semantics at once
void writeBuffer(const RenderVertexBufferData &data, physx::PxU32 firstVertex, physx::PxU32 numVertices)

APEX provides a pointer to the new source data (srcData) and it’s stride (srcStride), plus the ranges of values in the target buffer to be updated (firstDestElement, numElements). The user is expected to know the size of the APEX data from the descriptor used to create the buffer. If locking and unlocking of buffers is expensive for the game, they can cache the writeBuffer() calls made during updateRenderResources() and then play them back all in a single lock/write/unlock pass. Caching multiple writeBuffer() calls is guaranteed to generate coherent data so long as the actor remains locked until all of the writes are completed.

Next, the user must implement an UserRenderResource class for managing a renderable entity. The descriptor for the UserRenderResource contains pointer to all the various user buffers allocated for this renderable actor. Some of those buffers may be shared with other actors. The public interface of the UserRenderResource has methods to update indices in the various buffers, associate a material, and to retrieve those user buffers. APEX will only call these methods from within updateRenderResources() calls.

Note that when an UserRenderResource instance is released to the UserRenderResourceManager, the resource manager should not implicitly release the render buffers used by that render resource. Instead, APEX will explicitly release those resources as required. Only APEX understands all of the sharing semantics, so the the game should not call any of those release methods itself.

The last class that the user must implement is UserRenderer:

class UserRenderer
{
public:
    virtual void renderResource( const RenderContext &context ) = 0;
};

An instance of this class must be passed to dispatchRenderResources() (described below). From the context of dispatchRenderResources(), APEX will call this renderResource() method a number of times to pass RenderContexts back to the game engine. RenderContext is not user-defined, but it is a simple structure:

class RenderContext
{
public:
    UserRenderResource   *renderResource;
    PxMat44                 local2world;
    PxMat44                 world2local;
};

It essentially informs the game engine that a particular UserRenderResource instance should be rendered at a particular world pose. These render contexts could be rendered immediately by your UserRenderer, or it may cache them for later use. The render contexts are guaranteed to be valid until the next updateRenderResources() call is made on that actor.

APEX Scene Based Render Resource Updating

The ApexScene has an API for creating an iterator for the scene’s renderable actors. It is used in the following manner:

MyCachedRenderer renderer;
RenderableIterator *iter = gApexScene->createRenderableIterator();
for( Renderable *r = iter->getFirst() ; r ; r = iter->getNext() )
{
    if( earlyCullCheck( r->getBounds() ) )
        continue;
    r->updateRenderResources();
    r->dispatchRenderResources( renderer, 0 );
}
iter->release();

renderer.render_pass_1();
renderer.render_pass_2();

When the game is ready to begin rendering, it can acquire an iterator from the ApexScene and use it to call updateRenderResources() and dispatchRenderResources() on all renderables in the scene it wishes to render. The iterator implicitly handles all of the actor locking and will in fact temporarily skip over actors locked by other threads so that the loop can be completed as efficiently as possible. If the same iterator is used to make multiple passes through a scene’s actors, it will also safely deal with actor deletions.

With this method, the game can store all of the RenderContexts passed to it’s renderer and use them safely in as many rendering passes as it needs without any worry of conflicting with the ApexScene or other game threads making calls to the APEX API.

Ad-Hoc Render Resource Updating

Commonly, the game rendering thread will already have a scene graph for it’s rendering purposes and this graph will contain pointers to all the Renderable actors. In this case, the game will not want to use an iterators to access the actors. Instead, it will want to access them in an ad-hoc method.

Renderable *r = getApexRenderable( gameActor );
MyCachedRenderer gRenderer;
r->lockRenderResources();
if ( !earlyCullCheck( r->getBounds() ) )
{
    r->updateRenderResources();
    r->dispatchRenderResources( gRenderer, 0 );
}
r->unlockRenderResources();

With this method, APEX is unable to ensure the actor has not been deleted by another game thread, so the game engine must ensure the actor still exists. While the actor is locked, it cannot be deleted or modified in any way by APEX. It’s rendering data is guaranteed to stay in a consistent state until it is unlocked.

Example Overview

From 1000 feet up, the situation looks like this:

  1. The game allocates an UserRenderResourceManager instance and provides it to the ApexSDK at creation
  2. The main game thread calls Scene::simulate() and Scene::fetchResults() each frame (probably not in that order)
  3. When Scene::fetchResults() is called, the APEX actor states are updated to their new world positions and world bounds.
  4. In the rendering thread, using either an Scene iterator or the ad-hoc locking method, the game finds actors which are close enough to the view frustrum to be renderable and calls their updateRenderResources() methods
  5. Inside updateRenderResources(), APEX (may) call back to the UserRenderResourceManager to allocate new render resources. APEX then calls buffer write methods to pass the latest ApexActor state to the game engine.
  6. Subsequent calls to updateRenderResources() before the next invocation of Scene::fetchResults() should equate to NOOPs
  7. The rendering thread can now call dispatchRenderResources() on any of the ApexActors which have been updated, and it can make this call as many times as it wishes. Each time, dispatchRenderResources() will generate the same list of RenderContexts.

Materials

APEX does not “know” anything about render materials. The details of materials and shaders vary so much one renderer to the next, as well as from one game engine to the next. It would be very difficult, if not impossible, to abstract material handling in an useful way.

However, APEX must know something about materials, to the extent that it groups render vertices according to different materials, and informs the application as to which material is to be used with a vertex buffer when render resources are dispatched (see Render Resources Interface). It accomplishes this via the Named Resource Provider, allowing the application to register all materials (as void* pointers or integer handles) by their names. APEX render mesh assets (RenderMeshAsset) group vertices by material, and refer to the materials by name. Before the rendering resources are dispatched to the user for a draw call, those material names are matched to the user’s material handles (void* or integer) using the Named Resource Provider. In this way APEX has an efficient and meaningful way to refer to the material at runtime.

This would be the end of the section on materials, except that APEX has cases where it is its “own customer,” that is, with applications that need to render. One case is for authoring tools, another is for sample or demo applications.

Default Material Library Implementation

As a utility for tools, samples, and demos, APEX has a common generic material library class, ApexDefaultMaterialLibrary. This class can create simple materials with texture maps (currently a diffuse, bump, and normal map are supported). The texture maps may be read in from a variety of file format (to support authoring), and stores the texture maps in its own generic internal format.

The ApexDefaultMaterialLibrary is used to store material information for fractured mesh authoring in the DestructionTool, and to load materials for rendering in the Destruction module sample applications. Our SimpleRenderer code, used by our tools and demos, interfaces with ApexDefaultMaterialLibrary.

A ApexDefaultMaterialLibrary stores ApexDefaultMaterials, which in turn can refer to ApexDefaultTextureMaps. These three classes are defined in samples/common/include, and are based upon abstract base classes.

Asynchronous Simulation Interface

Simulation is controlled by the APEX scene. The Scene class implements simulate(), checkResults(), and fetchResults() methods that operate in similar fashion to the corresponding methods of the PhysX SDK PxScene class.

Just as with scene creation, these three simulation methods automatically call the corresponding PhysX SDK methods, eliminating the need for the game to make duplicate calls. Taking control of stepping the PhysX SDK simulations allows APEX modules to perform tasks before, during, and after the PhysX SDK simulation.

In order to do all this, each Scene spawns a new simulation thread, the “APEX scene thread”.

When the game thread calls Scene::simulate(), a signal is sent which unblocks the APEX scene thread. The APEX scene thread then passes through three phases. In each phase, each APEX ModuleScene (see above) is allowed to perform any asynchronous processing that it desires. Furthermore, during the second phase, the PhysX SDK simulation is allowed to proceed, by means of a call to PxScene::simulate(), followed by a call to PxScene::checkResults( block=true ).

The APEX scene in turns passes the execution context to each module in turn.

Buffered API

Warning

The buffering feature is NOT AVAILABLE in this release of APEX. Calls to the API to change the simulation state must NOT be made between the calls to simulate() and fetchResults().

Changes to the simulation state (calls to “set” methods of the API) must be made before the call to the simulate() method for the timestep(s) in which the changes are to be effective. Changes that are made after the call to simulate() are buffered until simulation completes (i.e.: until fetchResults()). Changes are applied in the order in which the API calls were originally made. This functionality is similar to what is provided by the PxD wrapper for the PhysX SDK, except that the functionality is built-in to APEX rather than being implemented as a wrapper.

Deletion of scenes is also buffered. Deleting a scene during simulation will not take effect until the simulation completes. Even though the deletion is buffered, the application must not make any more API calls that reference the scene, e.g.: don’t call fetchResults().

Calling fetchResults() before a corresponding simulate() call is allowed but does nothing. This avoids the need for the application to do a first-time check when calling fetchResults() for the previous frame immediately before simulate() for the next frame.

View Matrix and the Projection Matrix

The APEX framework provides the following interfaces to allocate, set and get the View Matrix and the Projection Matrix. Setting the View Matrix and the Projection Matrix is manditory since various APEX features such as the Level of Detail and Debug rendering require the data. This interface has been designed to support multiple sets of matrices in order to provide future APEX capabilities for multi-frame games on consoles. The following API are in the APEX scene and may be found in Scene.h.:

// first space must be allocated for the View Matrix and the Projection Matrix
// These calls must be made one time only.
const physx::PxU32 allocViewMatrix(ViewMatrixType::Enum);
const physx::PxU32 allocProjMatrix(ProjMatrixType::Enum);

// Next the transforms must be updated every time their values change
void               setViewMatrix(const physx::PxMat44 & viewTransform, const physx::PxU32 viewID = 0);
void               setProjMatrix(const physx::PxMat44 & projTransform, const physx::PxU32 projID = 0);

// If the View Matrix type is USER_CUSTOMIZED the following call must be made every time the View Matrix is set.
void               setViewParams(const physx::PxVec3 & eyePosition, const physx::PxVec3 & eyeDirection,
                                 const physx::PxVec3 & worldUpDirection = PxVec3(0,1,0),
                                 const physx::PxU32 viewID = 0);
// SetProjParams must be called every time the Projection Matrix is updated.
void               setProjParams(physx::PxF32 nearPlaneDistance, physx::PxF32 farPlaneDistance,
                                 physx::PxF32 fieldOfViewDegree, physx::PxU32 viewportWidth,
                                 physx::PxU32 viewportHeight, const physx::PxU32 projID = 0)

// setUseViewProjMatrix must be called once.  Presently since only one of each matrix is supported
// this function only needs to be called once.
    void               setUseViewProjMatrix(const physx::PxU32 viewID = 0, const physx::PxU32 projID = 0)

NOTE: Presently only one View Matrix and one Projection matrix may be set in each APEX scene. Consequently the projID values for both of the above calls must presently be set to 0 which is the only handle that the alloc functions will return.

When a view matrix is alocated the type must be specified. It may be one of the following:

struct ViewMatrixType
{
    enum Enum
    {
        USER_CUSTOMIZED = 0,
        LOOK_AT_RH,
        LOOK_AT_LH,
    };
};

struct ProjMatrixType
{
    enum Enum
    {
        USER_CUSTOMIZED = 0,
    };
};

If the matrix type is set to LOOK_AT_RH or LOOK_AT_LH the eye position, direction, and world up direction are automatically computed based on a left handed or right handed world. If the type is set to USER_CUSTOMIZED then the eye position must be set using the setProjMatrix API.

If the above calls are not made or are made incorrectly the following error messages will be output to the error stream.

ERROR CODE | MESSAGE | Explanation
APEX_INVALID_PARAMETER | view matrix for viewID %d is not initialized! see allocViewMatrix() | A view matrix is required but has not yet been set.
APEX_INVALID_PARAMETER | projection matrix for projID %d is not initialized! see allocProjMatrix() | A projection matrix is required but has not yet been set.
APEX_INVALID_PARAMETER | Invalid ViewMatrixType! | View Matrix types must be set to one of the ViewMatrixType enumeration values.
APEX_INVALID_PARAMETER | Invalid ProjMatrixType! | Projection Matrix types must be set to one of the ViewMatrixType enumeration values.
APEX_INVALID_PARAMETER | instantiating more than %d view matrices is not allowed! | Presently only 1 view matrix may be allocated.
APEX_INVALID_PARAMETER | instantiating more than %d projection matrices is not allowed! | Presently only 1 projection matrix may be allocated.

Level of Detail

APEX Modules will frequently implement Level of Detail (LoD) systems. LoD systems are simply algorithms that determine the best way to distribute limited resources over a set of objects in a scene. They typically use criteria such as distance the object from the camera, size of the object, age of the object, or relevance to game-play, to determine the optimal distribution of resources.

APEX LOD defines resources roughly as computational load required to accomplish a task to achieve a certain level of benefit. A high fidelity APEX asset that is near the eye position has greater benefit than one that is located far from the eye position. The APEX modules that participate in the LOD resource distribution calculate sum of the benefits of all of their actors. The LOD system distributes the available resources to the various APEX module scenes based on each modules total benefits and a user supplied weighting for each of the modules. The module weighting feature is provided to allow the LOD system to be tuned based upon the priority that the game developer places on the benefit of the actors that the various modules provide.

The following APIs allows the total resource budget to be set and provides a query to determine the actual resources consumed in the last simulation frame. These functions are in APEX scene and can be found in Scene.h.:

void setLODResourceBudget(physx::PxF32 totalResource);
physx::PxF32 getLODResourceConsumed()

The LOD resource budget should be adjusted based on the system that on which the game is running. On platforms such as Microsoft Windows that support a wide range of CPU and GPU computational capabilities the budget could be set using a slider in a configuration window or perhaps by a benchmark. Since the computational capabilities of any one console type is the same the game developer could set the budget to a fixed value to achieve the desired balance between the fidelity of the simulation and frame rate.

Every APEX module that participates in the APEX LOD resource distribution system computes the benefit of its actors in a module specific way. Setting the module weights both sets the priority and normalizes the benefits. It should be noted that resources and benefit are unique quantities. The resources required to implent an actor at a certain level of fidelity is the same no matter where the actor is located relative to the eye position. However the benefit of the actor will be much higher if it is located directly in front of the user than if the actor was far away and not visible. The resource weight can also be normalized between APEX modules using the same API call. The following APIs allows the benefit and resource weights of a module to be set and retrieved and are defined in Module.h.:

// Sets scaling factors that determine how the units of benefit and resource used by
// this module relate to those of other modules.
void setLODWeights(physx::PxF32 benefitWeight, physx::PxF32 resourceWeight);
// Retrieves the currently used LOD Weights.
void getLODWeights(physx::PxF32 & benefitWeight, physx::PxF32 & resourceWeight);

Further details of how the various APEX modules implement LOD is included in the documentation for each module. Clothing LOD is described here Clothing Physical LOD, and here Clothing Actor Benefit. Destruction LOD features are described in Destruction LOD Scalable Parameters, and Destruction Debug Visualization LOD Features. APEX Particles LOD is documented in APEX Particles LOD.

Scalable Parameters

Each APEX feature has one or more Scalable Parameters. Due to the hierarchical relationship of many Authorable Objects not all Authorable Objects implement a scalable parameter. A Scalable Parameter is the specification of a range of values that is authored and saved in asset. Scalable Parameters may be found in any kind of asset, including those that are only instantiated once per-module or per-module-scene. In other words, a module may define Scalable Parameters that are “global” to the module, or that are authored on a per-scene basis.

Scalable Parameters do not inherently have anything to do with Level of Detail(LoD), but they can be used to configure various LoD settings. For example, a simple LoD system might simulate the N most important widgets in the scene, while leaving the remaining widgets static. In such a scenario N is a Scalable Parameter.

Ownership of PhysX SDK Objects

The APEX SDK provides a mechanism for the application to make queries about PhysX SDK objects, such as Actors, that have been created by APEX. For example:

void myOnContactNotify(ContactPair & pair, PxU32 events)
{
    const PhysXObjectDesc *desc0 = GetApexSDK()->getPhysXObjectInfo(pair[0]);
    const PhysXObjectDesc *desc1 = GetApexSDK()->getPhysXObjectInfo(pair[1]);

    if (desc0)
    {
        if (desc0->getActor()->getOwner()->getObjectTypeID() == gModuleDestructible->getModuleID())
        {
            DestructibleActor *da = static_cast<DestructibleActor*> (desc0->getActor());
            //...
        }
    }
}

Serialization

Serialization is the process by which APEX assets are saved (serialized) by an authoring tool and loaded (de-serialized) by the APEX run-time.

Every APEX Authorable Object defines a set of data that makes up the serialized asset in an NvParameterized class. The NvParameterized::Serializer class serializes and deserializes using the PxFileBuf interface for I/O. APEX provides both a file and memory buffer based implementation of PxFileBuf, retrieved with ApexSDK::createStream() and ApexSDK::createMemory[Read, Write]Stream(), respectively.

The NvParameterized::Serializer can output XML formatted assets, which are useful for smaller assets where a user might want to do hand editing or tweaking. The serializer can also output platform-specific binary assets, which are significantly smaller and deserialize much more quickly. Binary assets can be serialized for any platform and deserialized on any platform, but if the target platform matches the current platform, the Serializer::deserializeInplace() method may be used to perform in-place deserialization, which is significantly faster than the traditional method of processing an asset one parameter at a time.

Asset Preview

Before creating an asset preview, the NvParameterized preview descriptors have to be set. Specific details on descriptor parameters can be found in their respective module’s programmers guides. The following code illustrates the general steps in creating an asset preview.

Note

To modify asset preview parameters after creation, member set functions of the asset preview will have to be used, instead of modifying the NvParameterized descriptor values. Refer to individual modules programmers guides for more details.

Asset Preview Colors

Preview rendering colors are fixed, and cannot be modified by the application.

Errors and Warnings

The APEX Framework outputs the following error and warning messages using the standard APEX error stream.

ERROR CODE | MESSAGE | Explanation
APEX_INTERNAL_ERROR | Cuda Error %d | A CUDA driver API call returned the error number %d.
APEX_INTERNAL_ERROR | Internal Error: GPU device memory allocation failure of %s in file ‘%s’ in line %i. | Memory allocation on the GPU accelerating PhysX & APEX failed.
APEX_INTERNAL_ERROR | Internal Error: CPU host memory allocation failure of %s in file ‘%s’ in line %i. | Memory allocation on the CPU failed.
APEX_INTERNAL_ERROR | Stream version (%d) is newer than this library (%d) | The APEX asset being deserialized has a more recent version number than the corresponding APEX module.
APEX_INTERNAL_ERROR | Asset type name mismatch. File <%s> != asset name <%s> | The named file does not contain the expected asset type
APEX_INTERNAL_ERROR | Stream version (%d) does not contain a universal named asset header, use a specific asset creation method to load this asset | Loading a legacy asset without the universal named asset header is not supported using the APEX generic asset loading. The module specific asset load must be used for this asset.
APEX_INTERNAL_ERROR | Unknown authorable type: %s, please load all required modules. | Attempting to create an asset that is not supported by currently loaded modules.
APEX_INTERNAL_ERROR | Cannot create IOS asset <%s>, its module is not loaded. | The specified IOS module must be loaded before creating an IOS asset.
APEX_INTERNAL_ERROR | Invalid abortionRatio when doing infinite steps (%f) | The abortion ratio for iso meshes must be greater than or equal to 0 and less than 1.
APEX_INTERNAL_ERROR | Several parts and multiple bones per vertex are conflicting! |
APEX_INTERNAL_ERROR | several submeshes have different custom buffers |
APEX_INTERNAL_ERROR | Conflicting parameterized objects! |
APEX_INTERNAL_ERROR | simulation is still running | Unable to query debug visualization while simulation is running, not thread safe.
APEX_INVALID_OPERATION | MeshDesc is not valid! | The mesh data indicates that there are submeshes but there are no submeshes.
APEX_INVALID_OPERATION | instantiating more than %d view matrices is not allowed! |
APEX_INVALID_OPERATION | instantiating more than %d projection matrices is not allowed! |
APEX_INVALID_OPERATION | view-projection matrix is not yet set! see setUseViewProjMatrix() |
APEX_INVALID_OPERATION | no vertices available |
APEX_INVALID_PARAMETER | isoGridSubdivision must be bigger than 0, setting it to 10 |
APEX_INVALID_PARAMETER | Wrong input stream. The provided stream has to contain %s. |
APEX_INVALID_PARAMETER | value is out of range (%d not in [%d, %d]) | The specified parameter is out of range.
APEX_INVALID_PARAMETER | Cannot add (%p), another vertex buffer (%p) is already assigned! |
APEX_INVALID_PARAMETER | Cannot remove (%p), another vertex buffer(%p) is assigned |
APEX_INVALID_PARAMETER | Invalid ViewMatrixType! |
APEX_INVALID_PARAMETER | Invalid ProjMatrixType! |
APEX_INVALID_PARAMETER | view matrix for viewID %d is not initialized! see allocViewMatrix() |
APEX_INVALID_PARAMETER | projection matrix for projID %d is not initialized! see allocProjMatrix() |
APEX_INVALID_PARAMETER | view matrix for viewID %d is not initialized! see allocViewMatrix() |
APEX_INVALID_PARAMETER | view matrix for viewID %d is not a LookAt type! see allocViewMatrix() |
APEX_INVALID_PARAMETER | view matrix for viewID %d is not a user-customized type! see allocViewMatrix() |
APEX_INVALID_PARAMETER | projection matrix for projID %d is not initialized! see allocProjMatrix() |
APEX_INVALID_PARAMETER | projection matrix for projID %d is not a user-customized type! see allocProjMatrix() |
APEX_INVALID_PARAMETER | projection matrix for projID %d is a not a perspective FOV type! see allocProjMatrix() |
APEX_DEBUG_INFO | ApexAssetHelper::getAssetFromName: Could not create resource ID asset: %s |
APEX_DEBUG_WARNING | Asset <%s> already exists | The authorable object specified by <%s> has already been loaded
APEX_DEBUG_WARNING | Deprecated interface, use ApexSDK::createAsset( physx::PxFileBuf&, const char * ) |
APEX_DEBUG_WARNING | Deprecated interface, use ApexSDK::createAsset( AssetAuthoring&, const char * ) |
APEX_DEBUG_WARNING | Deprecated interface, use ApexSDK::releaseAsset( Asset& ) |
APEX_DEBUG_WARNING | Deprecated interface, use ApexSDK::createAssetAuthoring( ) |
APEX_DEBUG_WARNING | Deprecated interface, use ApexSDK::releaseAssetAuthoring( AssetAuthoring& ) |
APEX_DEBUG_WARNING | Removed %d physX actor descriptor(s) still remaining in destroyed ApexScene. |
APEX_DEBUG_WARNING | Removed %d physX softbody descriptor(s) still remaining in destroyed ApexScene. |
APEX_DEBUG_WARNING | createObjectDesc: Px Object already registered |
APEX_DEBUG_WARNING | createObjectDesc: Px Object already registered with the given Actor |
APEX_DEBUG_WARNING | releaseObjectDesc: Unable to release object descriptor |
APEX_DEBUG_WARNING | Asset <%s> already exists |
APEX_DEBUG_WARNING | No NvParameterized::Factory is registered for %s |
APEX_DEBUG_WARNING | Some conversions for class %s were not released |
APEX_DEBUG_WARNING | Some factories for class %s were not released |
APEX_DEBUG_WARNING | NvParameterized::Factory does not have a valid name |
APEX_DEBUG_WARNING | Schema checksum is different, results may be invalid |
APEX_DEBUG_WARNING | NvParameterized ENUM value not correct: %s, substituting: %s |

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »

D3D/OGL CUDA Interop

Warning

CUDA interop is not supported in D3D9.

APEX is capable of writing directly into graphics buffers on the GPU from its CUDA kernels. This is a substantial performance improvement for data that is generated on the GPU. APEX does not have to copy that data to host memory and does not have to call writeBuffer() on your graphics buffer. APEX also does not need to allocate an output buffer for that data, since it is writing directly into your graphics buffer.

Requirements

  1. Your application must implement the UserRenderResource APIs.

2) Your application must provide a CUDA context to the APEX scene at creation. The CUDA context given to the APEX scene must support interop with your chosen graphics API (OGL, D3D10, or D3D11), and it must be bound to your graphics device:

physx::PxCudaContextManagerDesc ctxMgrDesc;
ctxMgrDesc.graphicsDevice = renderer->getDevice();
ctxMgrDesc.interopMode = physx::PxCudaInteropMode::D3D11_INTEROP;
physx::PxCudaContextManager *ctxMgr = nvidia::apex::CreateCudaContextManager(ctxMgrDesc, *nvidia::GetApexSDK()->getErrorCallback());

nvidia::apex::ApexSceneDesc apexSceneDesc;
apexSceneDesc.scene = physxScene;
if( ctxMgr )
  apexSceneDesc.gpuDispatcher = ctxMgr->getGpuDispatcher();
apexScene = apexSDK->createScene(apexSceneDesc);

3) Your UserRenderSpriteBuffer, UserRenderInstanceBuffer, etc implementations must respect the descriptor arguments for registering graphics resources with the specified CUDA context, unregistering those resources before they are deleted, and re-registering them if they are reallocated for any purpose, such as a graphics device reset:

void D3D11RendererInstanceBuffer::onDeviceReset(void)
{
  if(!m_d3dInstanceBuffer)
  {
    m_d3dDevice.CreateBuffer(&m_d3dBufferDesc, NULL, &m_d3dInstanceBuffer);

    if(m_interopContext && m_d3dInstanceBuffer && m_mustBeRegisteredInCUDA)
    {
      m_registeredInCUDA = m_interopContext->registerResourceInCudaD3D(m_InteropHandle, m_d3dInstanceBuffer);
    }
  }
}

Note

All graphics buffers should be unlocked when calling the resource registeration methods. Locked buffers can lead to CUDA errors.

4) Your UserRenderSpriteBuffer, UserRenderInstanceBuffer, etc implementations must return a valid graphics resource pointer from their getInteropResourceHandle() methods:

bool getInteropResourceHandle(CUgraphicsResource &handle)
{
  if(m_registeredInCUDA && m_InteropHandle)
  {
    handle = m_InteropHandle;
    return true;
  }
  return false;
}

5) The render resource allocated for interop purposes much match the size and order of the semantics specified in the creation descriptor’s semanticFormats and semanticOffsets arrays.

6) Once per render frame, the CPU thread holding the graphics device context must call the Scene::prepareRenderResourceContexts() method. More on this below.

Detailed Explanation

When the game render thread calls Scene::prepareRenderResourceContexts(), the scene will collect the list of graphics resources that were previously mapped, written into on the GPU, and are now ready to be rendered. Those buffers must be unmapped before they can be used by the game’s renderer. At the same time, it collects the list of buffers which will be written to on the GPU the next simulation step and maps them into the scene’s CUDA context.

By default, APEX assumes that the game’s render thread is not tied to the thread that is stepping the APEX scene, so when interop is in use it uses a triple buffering scheme that ensures there is always a mapped buffer ready to be used by the simulation thread. If your game can guarantee that the render thread can always call the prepareRenderResourceContexts() method between every fetchResults() and simulate() calls on the game thread, it can safely tell APEX to only use double buffering for interop. See the IOFX module documentation for details.

In the simulation thread, APEX attempts to get a valid CUDA pointer for the mapped graphics buffer. If this succeeds, APEX CUDA kernels will write directly into the mapped buffer and it can be directly rendered after the simulation completes and it is unmapped.

If APEX fails to get a valid CUDA pointer for any reason, it falls back to using a CUDA device allocated buffer (the same format and size of the graphics buffer). This CUDA buffer must be copied to host memory at the end of the simulation and its contents are later copied into the game’s graphics buffer via a writeBuffer() call. In essence, when APEX is unable to get a valid mapped pointer it falls back to the non-interop writeBuffer() path. At times this can make it difficult to tell whether interop is actually working. The only reliable way to tell is to check whether writeBuffer() is being called on your graphics buffers.

Once the simulation begins using mapped buffers again, the temporary CUDA output buffers are no longer necessary and are subsequently released.

In the Scene::fetchResults() method, the “working” set of output buffers is swapped into the “render” set of output buffers. Any call to prepareRenderResourceContexts() after fetchResults() will unmap the output buffer from CUDA so that it can be used by the graphics context.

If triple buffering is in effect (the default when interop is enabled), the previous “render” set of output buffers is swapped into the “deferred” set. APEX will try to map these graphics buffers back into CUDA for use in the next simulation step. The previous “deferred” set is swapped into the “working” set. Working set buffers are also mapped into CUDA if they were not mapped while they were deferred.

If double buffering is in effect, the “working” and “render” sets are simply exchanged during fetchResults. When the render thread calls prepareRenderResourceContexts() the new render set is unmapped and the new working set is mapped.

Notes

If the game engine wishes to disable interop for only a subsection of graphics buffers (perhaps you need instance buffers on the CPU, for instance), it can simply return false from its getInteropResourceHandle() method. APEX will not try to map such buffers into CUDA and thus it will safely fall back to the non-interop/writeBuffer() code path.

Some modules allow interop to be disabled entirely. See the IOFX Module description for details.

Even in a game engine that perfectly implements the APEX graphical interop methods, there will be render frames where a mapped buffer was not available at simulation time and thus a writeBuffer() will be performed during a renderable actor’s updateRenderResouces() call. The most common causes of this are initial startup, where the scene is stepped before it has been rendered, or on frames immediately after graphics buffers were reallocated (aka, device reset). The point of bringing this up is that even if you are using interop properly, you must still implement the writeBuffer() methods of these graphics buffers.

Requirement #2, which states that the CUDA context given to the APEX scene must be bound to your graphics device, implies that APEX CUDA kernels must run on the same GPU as you are rendering with. This can be counter-productive when the user has a dedicated GPU for PhysX/APEX. Your game should probably disable interop if a dedicated GPU is available.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »

Introduction

Motivation

The NVIDIA APEX SDK is designed to address three important issues facing game physics:

  1. Significant programmer involvement is required.
  2. Game physics content typically gets designed to the game’s “min-spec” system.
  3. Game engine performance limitations.

The first problem arises because the traditional interface to middleware physics is an API. It’s designed for programmers. These APIs need to be “general purpose”, so they expose a very “low-level” interface: rigid bodies, shapes, joints, particles, impulses, and collisions. They are basically, a “toolbox” of all the primitive components of a physics simulation. This gives the game programmer a lot of control, but in return, it requires a lot of non-trivial work. This work requires broad physics programming experience, and is often not budgeted by game developers. This is similar, in many ways, to the specialized work of writing an efficient rendering engine on top of D3D. With graphics, artists don’t directly create vertex buffer objects in the editor, but for physics that’s what physics engine integration requires. Even when authoring tools (like plug-ins for Max/Maya) are made available to attempt to reduce the programmer involvement that’s required, it’s the same “low-level toolbox” that is exposed to the artists. If the artists want to create content at a higher level of abstraction - not using these primitive building blocks - then you’re back to requiring a lot of programmer involvement again.

The second problem arises because there are huge performance differences between the consoles, and between different generations of PC CPUs, and GPUs. So, if game developers want their game to take advantage of higher end hardware, when it’s available, to improve the quality, or scale of their game physics, custom authoring is required for each platform or hardware configuration. The result of this is that, in practice, only the “lowest common denominator” content gets created, and users don’t benefit from better hardware.

The third problem arises because many game engines make the assumption that the world is largely static: that there are many static objects, but few dynamic objects Therefore, they tend to use very “heavy weight” data structures for their moving objects: For example: Using an “Actor” class for each and every crate, barrel, or piece of debris flying around the level. So even though the physics system might be able to handle very complex simulations, the overhead of the game engine (the scene graph, the AI, the rendering) makes it impossible, in practice, to use more than a few dozen objects in the level.

The NVIDIA APEX Solution

APEX addresses each of the above problems as follows:

  1. Significant programmer involvement is required to take a relatively abstract PhysX-SDK and create a lot of meaningful content.

    APEX provides a high-level interface to artists and content developers. This reduces the need for programmer time, adds automatic physics behavior to familiar objects, and leverages multiple low-level PhysX-SDK features with a single easy-to-use authoring interface.

  2. Game physics content typically gets designed to the game’s “min-spec” system.

    APEX requires each functional module to provide one or more ways to “scale the content” when running on better-than-min-spec systems, and to do this without requiring a lot of extra work from the game developer (artist or programmer, but especially programmer).

  3. Game engine performance limitations.

    APEX avoids many of the game engine bottlenecks by allowing the designer to identify the physics that is important to the game logic, and what can be sent directly to the renderer, bypassing the fully generic path through the game engine. It also allows the game engine to treat an APEX asset as a single game object, even though it may actually comprise many hundreds or even thousands of low-level physics components.

The APEX SDK comprises a set of C++ header files that define the SDK public API, a set of binary libraries that implement the functionality, as well as documentation of the API and of the functionality provided. Source code to the libraries may be provided to certain developers, according to business considerations. The APEX SDK also includes a set of tools (binary executables and DCC plugins) for content creation.

The APEX architecture is a modular one. Modules implement intuitive, specific purpose, high-level physics technology at a level of abstraction that is appropriate for content creators (artists and level designers). Modules typically manage multiple physics primitive elements (e.g.: rigid bodies, shapes, joints, etc..), and may manage multiple simulation types (e.g.: rigid body, fluid, cloth, soft-body).

Definitions

Scalable Content
In the context of APEX, content is said to be scalable whenever it can adapt to running on a variety of systems with various degrees of physics simulation capability (e.g.: CPU, CPU+PPU, CPU+GPU, PS3, Xbox360), and demonstrate benefit from running on systems with increased physics simulation capability.
APEX Asset
An APEX asset is a data structure that is created at game authoring time, can be serialized to non-volatile storage, loaded by the APEX run-time, and used to create instances (called actors) in the scene.
APEX Authorable Object
An authorable object is a definition of an asset data structure, the specification of how it will be authored, the specification of the runtime functionality, and the software that implements all this. This software includes, at a minimum, an Asset Authoring class, an Asset class, and an Actor (or instance) class.
APEX Module
An APEX module is software component, consisting of a group of related APEX Authorable Objects. It includes a run-time component and an authoring component. The run-time component for each APEX Module is shipped as a separate library or DLL. The authoring component may be provided by multiple tools, and/or may be combined in a single tool with other authoring functionality.
APEX Framework
The APEX Framework comprises all parts of APEX that are not Modules. The Framework may contain Authorable Objects.
APEX Feature
An APEX Feature is a group of inter-related APEX Authorable Objects that provide functionality to the game developer to facilitate the creation of a particular type of scalable content. An APEX Feature may span multiple Modules, and may include subsets of Modules.
Scalability
The degree to which an APEX Feature enables content created for it to adapt to running on a variety of systems with various degrees of physics simulation capability, and to demonstrate benefit from running on systems with increased physics simulation capability.
Scalable Parameter
A member of an APEX asset that is authored as a range of values, rather than as a unique value, in order to provide scalability. At run-time, a value in the authored range is selected based on the capabilities of the system.

Directory Structure

The APEX top level directory contains:

framework: | Everything that’s not a module
module: | APEX module specific code
shared: | Example source code that may be useful to the developer
externals: | SDKs used to build the samples applications
bin: | Platform and SDK version specific DLLs, sample and tool executables
lib: | Platform and SDK version specific libs
docs: | Documentation
samples: | Sample applications
media: | APEX and rendering assets used for the samples
NvParameterized:
 | NvParameterized API
public: | Foundation and PxTask headers

At the lowest level of the directory hierarchy, the following naming conventions are used:

.../public: | This is the set of public (external) interface classes which hide underlying implementation. They can be used by any application, by tools, or internal APEX code.
.../include: | Non-public header files, including classes that implement public interface classes.
.../src: | Source code.

An APEX binary distribution consists of a set of DLL’s (Windows) and libraries (all platforms) as well as the header files of the Public API (APEX/framework/public and APEX/module/xx/public). It will also include tools (executables) and samples (source & executables).

Each APEX Module and the APEX Framework is in a separate library (and Windows DLL). An application can thus link (or load) only the APEX Modules that the application will be using in order to conserve code space. A further benefit of separate libraries is that it is easy for NVIDIA or third-party developers to create new APEX Modules that can be easily used in an existing APEX application.

Version Numbers

The APEX Framework and all APEX Modules are independently versioned using a 2-part version number, consisting of a major number and a minor number, in the format “major.minor”, for example: “1.3”.

Asset definitions within a module may change from version to version of the module, but new versions of the AssetAuthoring and Asset derived classes will support deserializing all old versions of the asset.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »

PhysX Visual Debugger

Introduction

The PhysX Visual Debugger (PVD) provides APEX and PhysX with a mechanism for displaying profiling events, memory tracking, and external debug visualization. APEX does not route any debug visualization to PVD, just profiling and memory data. Many of the APEX framework and module classes contain profiling zones which assist in isolating performance issues.

For convenience, APEX automatically creates a PVD camera from the view matrix the application gives to an Scene. Look for “ApexCamera 0” in the PVD cameras.

APEX also supports limited PVD object debugging to show APEX module, asset, and actor properties. Currently only clothing is supported. When object debugging is enabled, you will also be able to visualize the clothing in PVD by enabling Constraints visualization in the PVD Preferences.

When connecting to PVD with any method (object debugging, profiling, or memory tracking) the APEX error stream will automatically be routed to PVD’s error stream display.

Get PVD

Go to http://developer.nvidia.com/physx-visual-debugger to get PVD.

Supported Configurations

See the Build Configurations section for information on which configurations support PVD connections.

Connecting to PVD

To connect APEX and PhysX to PVD, the application must get APEX’s PVD Binding using the ApexSDK::getPvdBinding() method. The PvdBinding class provides connect and disconnect methods which allow the user to specify the IP address and port of the computer running PVD and the connection flags.

PVD::PvdBinding* ApexSDK::getPvdBinding()

class PvdBinding

Note

The debug visualization connection flag (physx::debugger::PvdConnectionType::eDEBUG) will greatly reduce performance and should not be paired with the profile flag (physx::debugger::PvdConnectionType::ePROFILE) because the profile results will be inflated.

Example

This function will toggle the PVD connection for profiling only:

#include <ApexSDK.h>
#include <PVDBinding.h>

using namespace physx::apex;
using namespace PVD;

void togglePvdConnection()
{
    PvdBinding* theBinding = GetApexSDK()->getPvdBinding();
    if (theBinding != NULL)
    {
        if (theBinding->isConnected())
        {
            theBinding->disconnect();
        }
        else
        {
            theBinding->connect("localhost",
                                DEFAULT_PVD_BINDING_PORT,
                                DEFAULT_PVD_BINDING_TIMEOUT_MS,
                                physx::debugger::PvdConnectionType::ePROFILE);
        }
    }
}

Android Notes

Remotely connecting to PVD from Android is supported via a Wi-Fi connection. But it is preferrable to save PVD information to a file because it works faster and produces more reliable information.

To get PVD information on Android from APEX samples you should uncomment this line from framework\src\PVDBinding.cpp:
getConnectionManager().connect( *this, “/sdcard/media/out.pxd2”, inConnectionType );

The PVD dump will be recorded in the corresponding file - out.pxd2. Note that access to APEX source code is required to make this change.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »

Render Mesh Asset Interfaces

Apex render data is stored in a vertex buffer accessible through the VertexBuffer interface. This vertex buffer supports a wide variety of attributes, and it also supports a variety of formats for each attribute. A format descriptor for the entire buffer is accessible through the VertexFormat interface.

Although every vertex attribute (for example position, normal, etc.) may be given any format (for example float[3], byte[3], etc.), there are some restrictions imposed by the framework and individual modules. There are two overall (framework) restrictions:

  • vertex positions must be stored in the FLOAT3 format
  • vertex color must be stored in the R8G8B8A8 or B8G8R8A8 (PxU8[4]) formats

See the individual module documentation for further per-module restrictions.

One authors an apex render mesh by creating an authoring object with the ApexSDK::createRenderMeshAsset function. This object uses the RenderMeshAssetAuthoring interface.

RenderMeshAssetAuthoring Interface

Apex render mesh assets are built by filling in a descriptor, RenderMeshAssetAuthoring::MeshDesc. See RenderMeshAsset.h. This descriptor is simply an array of “submesh” descriptors, of type RenderMeshAssetAuthoring::SubmeshDesc. Submeshes correspond to individual materials, or shaders, or other render state. The idea is that a submesh can be drawn (ideally) in one draw call.

RenderMeshAssetAuthoring::SubmeshDesc

The SubmeshDesc is set up so that you can point its fields directly to your mesh data, with minimal (or no) need to convert it into an intermediate format.

Vertex Buffers

The SubmeshDesc contains contains an array of VertexBuffer objects, which just contain format descriptors and pointers to your data. You set these pointers using RenderMeshAssetAuthoring::VertexBuffer::setSemanticData(...):

PX_INLINE void setSemanticData(RenderVertexSemantic::Enum semantic, const void *data, physx::PxU32 stride, RenderDataFormat::Enum format, RenderDataFormat::Enum srcFormat = RenderDataFormat::UNSPECIFIED)

The first argument, semantic, is the data channel you are setting. For example, this may be the vertex position, normal, tangent, uv coordinate, etc. The possible “standard semantics” are given below.

Semantic (RenderVertexSemantic::Enum) | Meaning
POSITION | Position of vertex
NORMAL | Normal at vertex
TANGENT | Tangent at vertex
BINORMAL | Binormal at vertex
COLOR | Color at vertex
TEXCOORD0 | Texture coord 0 of vertex
TEXCOORD1 | Texture coord 1 of vertex
TEXCOORD2 | Texture coord 2 of vertex
TEXCOORD3 | Texture coord 3 of vertex
BONE_INDEX | Bone index of vertex
BONE_WEIGHT | Bone weight of vertex

Only these semantics may be set with the setSemanticData function, and only one data channel per semantic is allowed. The data buffer pointer is passed in as a void* pointer in data. The stride field gives the byte difference between one data element and the next. The format field is the format you wish to store the data in, in the created render mesh. If this is same format as the source data (pointed to by data), then you may leave the last parameter at its default. If the source data is a different format, you must specify this format in the last parameter.

The allowed formats are given in RenderDataFormat::Enum (see RenderDataFormat.h). These formats are shown below.

Format (RenderDataFormat::Enum) | Meaning
UNSPECIFIED | No format (semantic not used)
UBYTE1 | One unsigned 8-bit integer (PxU8[1])
UBYTE2 | Two unsigned 8-bit integers (PxU8[2])
UBYTE3 | Three unsigned 8-bit integers (PxU8[3])
UBYTE4 | Four unsigned 8-bit integers (PxU8[4])
USHORT1 | One unsigned 16-bit integer (PxU16[1])
USHORT2 | Two unsigned 16-bit integers (PxU16[2])
USHORT3 | Three unsigned 16-bit integers (PxU16[3])
USHORT4 | Four unsigned 16-bit integers (PxU16[4])
SHORT1 | One signed 16-bit integer (PxI16[1])
SHORT2 | Two signed 16-bit integers (PxI16[2])
SHORT3 | Three signed 16-bit integers (PxI16[3])
SHORT4 | Four signed 16-bit integers (PxI16[4])
UINT1 | One unsigned integer (PxU32[1])
UINT2 | Two unsigned integers (PxU32[2])
UINT3 | Three unsigned integers (PxU32[3])
UINT4 | Four unsigned integers (PxU32[4])
R8G8B8A8 | Four unsigned bytes (PxU8[4]) representing red, green, blue, alpha
B8G8R8A8 | Four unsigned bytes (PxU8[4]) representing blue, green, red, alpha
R32G32B32A32_FLOAT | Four floats (PxF32[4]) representing red, green, blue, alpha
B32G32R32A32_FLOAT | Four floats (PxF32[4]) representing blue, green, red, alpha
BYTE_UNORM1 | One unsigned normalized value in the range [0,1], packed into 8 bits (PxU8[1])
BYTE_UNORM2 | Two unsigned normalized value in the range [0,1], each packed into 8 bits (PxU8[2])
BYTE_UNORM3 | Three unsigned normalized value in the range [0,1], each packed into bits (PxU8[3])
BYTE_UNORM4 | Four unsigned normalized value in the range [0,1], each packed into 8 bits (PxU8[4])
SHORT_UNORM1 | One unsigned normalized value in the range [0,1], packed into 16 bits (PxU16[1])
SHORT_UNORM2 | Two unsigned normalized value in the range [0,1], each packed into 16 bits (PxU16[2])
SHORT_UNORM3 | Three unsigned normalized value in the range [0,1], each packed into 16 bits (PxU16[3])
SHORT_UNORM4 | Four unsigned normalized value in the range [0,1], each packed into 16 bits (PxU16[4])
BYTE_SNORM1 | One signed normalized value in the range [-1,1], packed into 8 bits (PxU8[1])
BYTE_SNORM2 | Two signed normalized value in the range [-1,1], each packed into 8 bits (PxU8[2])
BYTE_SNORM3 | Three signed normalized value in the range [-1,1], each packed into bits (PxU8[3])
BYTE_SNORM4 | Four signed normalized value in the range [-1,1], each packed into 8 bits (PxU8[4])
SHORT_SNORM1 | One signed normalized value in the range [-1,1], packed into 16 bits (PxU16[1])
SHORT_SNORM2 | Two signed normalized value in the range [-1,1], each packed into 16 bits (PxU16[2])
SHORT_SNORM3 | Three signed normalized value in the range [-1,1], each packed into 16 bits (PxU16[3])
SHORT_SNORM4 | Four signed normalized value in the range [-1,1], each packed into 16 bits (PxU16[4])
HALF1 | One 16-bit floating point value
HALF2 | Two 16-bit floating point values
HALF3 | Three 16-bit floating point values
HALF4 | Four 16-bit floating point values
FLOAT1 | One 32-bit floating point value
FLOAT2 | Two 32-bit floating point values
FLOAT3 | Three 32-bit floating point values
FLOAT4 | Four 32-bit floating point values
FLOAT3x4 | A 3x4 matrix (see PxMat34)
FLOAT3x3 | A 3x3 matrix (see PxMat33)
FLOAT4_QUAT | A quaternion (see PxQuat)
BYTE_SNORM4_QUATXYZW | A normalized quaternion with signed byte elements, X,Y,Z,W format (PxU8[4])
SHORT_SNORM4_QUATXYZW | A normalized quaternion with signed short elements, X,Y,Z,W format (PxU16[4])

Source and destination formats may be different only if a conversion is defined between the formats. Currently, these conversions are defined:

  • BYTE_SNORM1 <=> FLOAT1
  • BYTE_SNORM2 <=> FLOAT2
  • BYTE_SNORM3 <=> FLOAT3
  • BYTE_SNORM4 <=> FLOAT4
  • SHORT_SNORM1 <=> FLOAT1
  • SHORT_SNORM2 <=> FLOAT2
  • SHORT_SNORM3 <=> FLOAT3
  • SHORT_SNORM4 <=> FLOAT4
  • BYTE_SNORM4_QUATXYZW <=> FLOAT4_QUAT
  • SHORT_SNORM4_QUATXYZW <=> FLOAT4_QUAT
  • USHORT1 <=> UINT1
  • USHORT2 <=> UINT2
  • USHORT3 <=> UINT3
  • USHORT4 <=> UINT4
  • R8G8B8A8 <=> B8G8R8A8
  • R8G8B8A8 <=> R32G32B32A32_FLOAT
  • R8G8B8A8 <=> B32G32R32A32_FLOAT
  • B8G8R8A8 <=> R32G32B32A32_FLOAT
  • B8G8R8A8 <=> B32G32R32A32_FLOAT
  • R32G32B32A32_FLOAT <=> B32G32R32A32_FLOAT

If you wish to supply other data channels, you may create an array of custom buffer descriptors (RenderMeshAssetAuthoring::VertexBuffer::RenderSemanticData) and pass them into RenderMeshAssetAuthoring::VertexBuffer::setCustomSemanticData(...).

When possible, however, use the standard semantics so that APEX modules which might rely on the data can interpret it correctly. For example, positions should always use the RenderVertexSemantic::POSITION semantic, as many modules rely on vertex positions for various calculations.

Index Buffers

In addition, you supply the mesh’s index buffer in the SubmeshDesc. Currently only triangle primitives (no strips or fans) are supported. If you partition your index buffer(s) into disjoint parts, you can use the SubmeshDesc’s m_partIndices array to specify this partition. The RenderMesh interface allows the user to set visibility on part subsets of the mesh. Note: it is required that the vertex buffer also be similarly partitioned by parts, but this is not enforced in the user’s data. The authoring function will sort the APEX render mesh’s vertex buffer to meet this requirement, however. This means that the final vertex indices may not correspond to your original indices. In order to map the vertices back to your original ordering, you may create a mapping buffer as described below.

The RenderMeshAssetAuthoring::createRenderMesh(...) function takes the MeshDesc descriptor and builds an APEX render mesh asset from it. Its second parameter is the createMappingInformation bool. If this is set to TRUE, then a custom buffer named “VERTEX_ORIGINAL_INDEX” (see VertexBuffer Interface) will be created which is is the original index in the MeshDesc for each vertex. The only time the vertices will be rearranged is when they are made into contiguous parts. There is no further cooking of the mesh data, for example to reduce the vertex buffer by eliminating redundant vertices.

If you wish to reduce your vertex buffer by eliminating redundant vertices, the RenderMeshAssetAuthoring API provides a helper function to do this called createReductionMap(...). It only gives you a map by which you may reduce your vertex data. It will not modify your vertex data for you.

Once you have called RenderMeshAssetAuthoring::createRenderMesh, this authoring class may be used to create an RenderMeshAsset using the standard authorable asset functions (see Loading Assets).

Once you have created an APEX render mesh, you may access it through the RenderMeshAsset interface. This interface gives you the mesh broken into submeshes via the RenderMeshAsset::getSubmesh method. This method returns an RenderSubmesh interface. Through that, you can access the mesh’s vertex buffer using RenderSubmesh::getVertexBuffer, which returns an VertexBuffer interface.

VertexBuffer Interface

The VertexBuffer interface gives you access to the render data, and also allows conversion between render data formats. Every RenderSubmesh has this interface.

The number of vertices is returned by this function:

virtual physx::PxU32            getVertexCount() const = 0;

The format of the vertices is returned by this function:

virtual const VertexFormat&   getFormat() const = 0;

This returns an VertexFormat interface, described below, in VertexFormat Interface .

The VertexFormat interface will give you a buffer index for any data channel (semantic or custom data) in the buffer. You may then use that index to access the buffer, using

virtual const void*             getBuffer( physx::PxU32 bufferIndex ) const = 0;

The data is returned as a void*, which you must cast appropriately based upon the data format (also obtained from the VertexFormat interface). Both of these operations may be done at once using

virtual const void*             getBufferAndFormat( RenderDataFormat::Enum& format, physx::PxU32 bufferIndex ) const = 0;

Finally, there is a utility which will fill a user buffer with render buffer data, and even convert between the render data format and a destination format specified by the user, if that conversion exists. You may also specify a subset of the buffer to copy, using the startVertexIndex and elementCount fields.

virtual bool                    getBufferData( void* buffer, physx::RenderDataFormat::Enum bufferFormat, physx::PxU32 bufferIndex,
                                               physx::PxU32 startVertexIndex, physx::PxU32 elementCount ) const = 0;

Note, regardless of the value of startVertexIndex, the buffer will always be filled starting at the buffer’s beginning. Also note, you may find the size of an element in any format using the function

RenderDataFormat::getFormatDataSize( RenderDataFormat::Enum format );

VertexFormat Interface

This interface accompanies the VertexBuffer interface and may be accessed through VertexBuffer::getFormat.

The various semantics and custom buffers formats, as well as their buffer index (used to retrieve the buffer data using VertexBuffer::getBuffer), are all looked up by a unique buffer ID. This ID is a hash of the buffer name. For a custom buffer, this name is specified by the user. For a standard semantic (RenderVertexSemantic::Enum), this name may be looked up using

virtual const char*                 getSemanticName( RenderVertexSemantic::Enum semantic ) const = 0;

Whatever the name, the buffer ID may be looked up using

virtual BufferID                    getID( const char* name ) const = 0;

In addition there is the shortcut function for semantics,

virtual BufferID                    getSemanticID( RenderVertexSemantic::Enum semantic ) const = 0;

This buffer ID will not change, and so may be serialized, cached, etc. To find a buffer index use

virtual physx::PxI32                getBufferIndexFromID( BufferID id ) const = 0;

All of the format accessors, as well as the VertexBuffer accessors, use this index. Note, this index is volitile. If you add or remove semantics or custom buffers, the index may change.

There are basically three pieces of information associated with each buffer: format, access type, and serialization.

The buffer’s format is enumerated using RenderDataFormat::Enum, and is the data layout. This is accessed using:

virtual RenderDataFormat::Enum    getBufferFormat( physx::PxU32 index ) const = 0;

The buffer’s access type is a hint regarding how the data will be accessed. There are three types, enumerated by RenderDataAccess::Enum. These are STATIC, DYNAMIC, and STREAMING. STATIC buffers are only sent to the application once. DYNAMIC and STREAMING buffers are sent every frame.

Use

virtual RenderDataAccess::Enum    getBufferAccess( physx::PxU32 index ) const = 0;

for the access type.

Finally, you can query a buffer to see whether it will get serialized, using

virtual bool                        getBufferSerialize( physx::PxU32 index ) const = 0;

Corresponding set functions, as well as the rest of the VertexFormat API is documented in the APEX Framework API section.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
  • APEX Programmers Guide »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »

APEX Framework

Contents:

  • APEX Programmers Guide
    • Introduction
      • Motivation
      • The NVIDIA APEX Solution
      • Definitions
      • Directory Structure
      • Version Numbers
    • Deployment
      • How to build
      • Build Configurations
      • The legacy module
      • What to ship
      • Application GUID (Windows only)
    • Assets and Actors
      • Authorable Objects
      • Asset Data Flow
      • Level Editor and Level Loading
      • Asset Authoring Class
      • Asset Class
      • Asset Inclusion
      • Asset Referencing
      • Actor Class
      • Actor Context
    • Framework Interfaces
      • Initialization
      • Loading Modules
      • Creating Scenes
      • Loading Assets
      • Instantiating Actors
      • Named Resource Provider
      • Render Mesh Asset
      • Render Resources Interface
      • Materials
      • Asynchronous Simulation Interface
      • Buffered API
      • View Matrix and the Projection Matrix
      • Level of Detail
      • Scalable Parameters
      • Ownership of PhysX SDK Objects
      • Serialization
      • Asset Preview
      • Errors and Warnings
    • Render Mesh Asset Interfaces
      • RenderMeshAssetAuthoring Interface
      • VertexBuffer Interface
      • VertexFormat Interface
    • D3D/OGL CUDA Interop
      • Requirements
      • Detailed Explanation
      • Notes
    • PhysX Visual Debugger
      • Introduction
      • Get PVD
      • Supported Configurations
      • Connecting to PVD
      • Example
      • Android Notes
    • Debug Visualization
      • Introduction
      • Framework Parameters
      • Module List
      • Examples
      • Debug Rendering Colors
  • ParamTool

API

  • Framework API
  • PxTask API

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »

ParamTool

ParamTool is the universal tool to modify NvParameterized assets. It has the ability to convert from and to different formats and platforms.

Running ParamTool.exe -h results in a full usage description. The examples on the bottom cover the most important usage scenarios:

Usage: ParamTool.exe [OPTIONS] [NAME1...]

Options:
  -c, -convert-asset             convert files NAME1, ... to single NvParameterized file
  -m, -make-asset                make template asset file for specified assets;
                                 asset names may have format 'className' or 'className@classVersion'
                                 (by default the latest version is used)
  -l, -list                      print file summary: target platform, number of objects,
                                 their classes, names and versions
  -o file, -output file          specify name of destination file
  -s fmt, -serial fmt            specifies ouput serialization format
  -t tgt, -target-platform tgt   specifies target platform
  -pt tag, -platform-tag tag     specifies the platform tag used to prepare the assets for
  -i, -inplace                   use inplace deserialization (for debug)
  -v, -verify                    verify serialized data (for debug)
  -h, -help                      print this help message and exit
  -p, -print-classes             -h + print available APEX Authorable and NvParameterized classes
  -d, -diagnostic                turn on diagnostic messages

  -gv, -get-value "name"         try for '-c mode' get parameter from all input files and
                                 prints: parameter name, value, type, valid status
                                 no necessary to provide output file in this case
                                 valid status is info about if parameter is applicable

  -sv, -set-value "name" "value" try for '-c mode' set value for parameter by it's name
                                 do it for all deserialized objects from input files
                                 print status of this action and serialize result to output

Note that this version of ParamTool does not support legacy asset formats (use APEX 1.0 version for that).

Default values:
If none of -c, -m or -l is specified, -c is used. Note that you can't use
-c (or -l) together with -m.
Default output file (-o) is basename of NAME1 + xml/bin extension.
Default target platform (-t) is current platform.
Default serialization format (-s) is derived from extension of destination file.

Supported serialization formats:
  apx (APex Xml, same as xml)
  apb (APex Binary, same as bin)
  xml
  bin

Supported platforms:
  VcWin32 (Vc, x86)
  VcWin64 (Vc, x86_64)
  VcXbox, VcXbox360 (Vc, PPC)
  VcXboxOne (Vc, x86_64)
  GccPs3 (Gcc, Cell)
  GccPs4 (Gcc, x86_64)
  Pib (artificial platform which results in smaller asset files)

Examples:

convert all xml assets in current directory to single bin asset:
  ParamTool *.apx -o allAssets.apb

convert binary asset to xml asset:
  ParamTool -s apx leafMesh.apb

make NvParameterized file with several assets having default values (latest versions):
  ParamTool -m -s apx -o legacyClothing.apb ExplosionEnvParameters ShapeConvexParams

make NvParameterized file with several assets (with explicit versions):
  ParamTool -m -s apx -o legacyClothing.apb ExplosionEnvParameters@0.0 ShapeConvexParams@0.1

prepare an asset for a given platform tag, which has to be stored in the asset:
  ParamTool clothingAsset.apb -pt Xbox -o clothingAsset_Xbox.apb

print file summary: target platform, number of objects, their classes, names and versions:
  ParamTool -l clothingAsset.apb

get 'comment' parameter and prints parameter name, value, type, valid status per concrete input file:
  ParamTool -gv comments Block_Realtime.apx Wall.apb

try to set 'comment' parameter. Save result to Block_RealtimeTemp.apx:
  ParamTool -sv comments "test" Block_Realtime.apx -o Block_RealtimeTemp.apx

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Framework »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

APEX Basic FS Users Guide

Introduction

The Basic FS module provides several kinds of field samplers. Field samplers are used to create forces which move particles along a particular way. Currently Basic FS module contains Attractor, Jet, Noise, Vortex and Wind field samplers. User can combine these field samplers to achieve desired behaviour.

Common Field Sampler Properties

All field samplers share some properties to allow setting up particular interaction mode between them and particles. These properties are Field Drag Coefficient and Field Weight.

If Field Drag Coefficient is 0, then:

newParticleVelocity = fieldWeight * fieldVelocity + (1 - fieldWeight) * oldParticleVelocity;

(so it’s just a linear blending of field velocity and old particle velocity) – this is so called direct velocity mode.

If Field Drag Coefficient is > 0, then:

newParticleVelocity = dragWeight * fieldVelocity + (1 - dragWeight) * oldParticleVelocity, where dragWeight = min(fieldWeight * fieldDragCoeff * elapsedTime / particleMass, 1)

This formula simulates some simple drag force from real physics (this is so called drag force mode – it usually produce some time delay for changing particle velocity and also it should vary with particle mass)

Attractor Field Sampler

Attractor Field Sampler acts as a sphere creating a force which attracts particles to this sphere. These are the parameters for this type of effect:

  • Boundary Fade Percentage - Works similarly as the same property on the grid
  • Radius - Radius of the influence of the attractor
  • Const Field Strength - How strong the attractor is pulling the particles. A negative number will repel particles.

Jet Field Sampler

Jet Field Sampler Actor affects the Turbulence grid’s velocities and causes the particles to be pushed in a single direction. Outside the grid, jets act completely differently. It acts directly on any particles and moves them around in a torus shape. Some of important parameters of a Jet Field Sampler are:

  • Grid Shape Radius - the radius of the jet’s volume of influence (a capsule).
  • Grid Shape Height - the height of the jet’s volume of influence (a capsule).
  • Grid Boundary Fade Percentage - this number controls how the influence of the jet falls off as you travel out from its central axis. For example, a value of 0.01 means that the jet’s field strength is at full strength up until the outermost 1% of the capsule’s volume. Then, in this last 1%, the field strength goes from full strength to zero at the boundary of the capsule. This is useful for “softening the edges” of the jet’s influence.
  • Field Strength - the strength of the jet.

Noise Field Sampler

Noise Field Sampler creates noise in a volume represented by a box. Noise affects particles by applying force or velocity. There are several important parameters to setup noise:

  • Noise Type - CURL or SIMPLEX. By default use CURL type. This is divergence free type noise.
  • Noise Strength - coefficient of the noise strength.
  • Noise Space Period - the size of vortices in the noise field.
  • Noise Time Period - how fast the noise vortices would change direction.
  • Noise Octaves - how many octaves does noise spectrum have.

Vortex Field Sampler

Vortex Field Sampler has a capsule shape. Particles that are inside this shape receive propulsion with a force propotional to a distance between a particle and the capsule axis. There are three components of the velocity - rotational, radial and lift.

Wind Field Sampler

Wind Field Sampler creates a force which represents wind influencing the particles. This field sampler has no shape or volume, hence it affects all particles in case no filtering is set. Wind Field Sampler is able to create a variable direction and strength of wind force. These settings are avaiable through asset properties such as Field Direction, Field Direction Deviation Angle, Field Direction Oscillation Period, Field Strength, Field Strength Deviation Percentage, Field Strength Oscillation Period.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

APEX Basic IOS Programmers Guide

Introduction

Since the Particle emitter spawns the IOS and the IOFx there is nothing that the programmer needs to do with this module. The following error messages are most likely triggered by authoring problems such as invalid asset names or using too many injectors.

Errors and Warnings

The BasicIOS outputs the following error and warning messages using the standard APEX error stream.

ERROR CODE | MESSAGE | Explanation
APEX_INTERNAL_ERROR | Unknown authorable type: %s, please load the IOFX module. | The APEX IOFX module was not loaded.
APEX_INTERNAL_ERROR | Failed to create BasicIOS GPU Injector: out of GPU const memory. | The GPU const memory pool was exhausted.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

APEX Basic IOS Users Guide

Introduction

The Basic IOS provides the ability to control the parameters that are common to all particle systems.

These parameters are described in the document referenced here:

  • APEX Basic IOS Asset Parameters

Example

Here is an example of a basic IOS asset.

Basic IOS Example

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

APEX EffectPackage Programmers Guide

Introduction

APEX Effect Package assets are authored using the ParticleEffectTool (PET). An EffectPackage represents a collection of related particle asset/actors whcih can be instantiated as a single actor and manipulated in real time. A single EffectPackage might contain a number of Emitters, a turbulence grid, a heat source, and some field samplers. Each of these effects can have different timing characteristics, such as a duration and loop counters. Each effect can have a parent relative transform so that when the root actor moves all children actors are revised accordingly.

Loading the EffectPackage databases

If you use the ‘publish’ feature of the ParticleEffectTool you have the option of pre-loading all of the effects which have been authored when your application starts up. This is an optional feature. You can still just load invididual asset files on demand like you would do normally. However, in the case of effects it can easily explode into hundreds of individual files that need to be managed. As a matter of convenience you can use the ‘publish’ feature of the ParticleEffectTool to produce a set of binary serialized data assets which contain all assets that were authored with the tool. Since these assets are largely just composed of a small collection of numeric values they are quite small and would not generally be considered a problem to preload on application startup.

The series of binary serialized files that are produced by the ParticleEffectTool are as follows:

PET Published Binary Output Asset Files

PUBLISH FILE NAME | Purpose
EffectPackageEffectPackagesDatabase.apb | Contains an array of all EffectPackage assets authored in PET
EffectPackageEmittersDatabase.apb | Contains an array of all Emitter assets authored in PET
EffectPackageFieldSamplersDatabase.apb | Contains an array of all FieldSampler related assets authored in PET
EffectPackageGraphicsEffectsDatabase.apb | Contains an arary of all IOFX assets authored in PET
EffectPackageGraphicsMaterialsDatabase.apb | Contains an array of all Graphics Material properties authored in PET; not required
EffectPackageParticleSimulationsDatabase.apb | Contains an array of all BasicIOS and ParticleIOS assets authored in PET

The following code snippet shows how one of these APB files can be loaded into memory:

// This method will load a binary serialized file on disk with the name specified and deserialize it into memory.
NvParameterized::Interface      *loadParams(const char *name)
{
        NvParameterized::Interface *ret = NULL; // The default return value.

        std::string fname = mMediaPath + std::string(name); // Produce the fully qualified path name for the asset.
        FILE *fph = fopen(fname.c_str(), "rb"); // Open the file for read access.
        PX_ASSERT(fph); // Assert if the file open fails; this should always succeed in this sample./
        if ( fph )
        {
                fseek(fph,0L,SEEK_END);
                size_t len = ftell(fph);        // Find out the length of the file.
                fseek(fph,0L,SEEK_SET);
                void *mem = ::malloc(len);      // Allocate memory to hold the file
                PX_ASSERT(mem); // Assert that the memory allocation succeeded.
                if ( mem )
                {
                        size_t r = fread(mem,len,1,fph);        // Read the entire file into memory in a single operation.
                        PX_ASSERT(r==1);        // Assert that the file read succeeded.
                        if ( r == 1 )
                        {
                                // Create a binary deserializer using the APEX SDK
                                NvParameterized::Serializer *ser = mApexSDK->createSerializer(NvParameterized::Serializer::NST_BINARY);
                                if ( ser )
                                {
                                        // Create a memory read stream
                                        physx::PxFileBuf *fb = mApexSDK->createMemoryReadStream(mem,(physx::PxU32)len);
                                        if ( fb )
                                        {
                                                // Deserialize this data.
                                                NvParameterized::Serializer::DeserializedData desData;
                                                NvParameterized::Serializer::ErrorType err = ser->deserialize(*fb,desData);
                                                if ( err == NvParameterized::Serializer::ERROR_NONE )
                                                {
                                                        if ( desData.size() == 1 )
                                                        {
                                                                NvParameterized::Interface *params = desData[0];
                                                                if ( params )
                                                                {
                                                                        ret = params;   // Return the NvParameterized::Interface representing the binary deserialized data.
                                                                }
                                                        }
                                                        else
                                                        {
                                                                PX_ALWAYS_ASSERT();
                                                        }
                                                }
                                                else
                                                {
                                                        PX_ALWAYS_ASSERT();
                                                }
                                                mApexSDK->releaseMemoryReadStream(*fb); // Release the read stream
                                        }
                                        ser->release(); // Release the serializer
                                }
                        }
                        ::free(mem); // Free the temporary memory allocated to hold the source file.
                }
                fclose(fph);    // Close the file
        }

        return ret;     // Return the NvParameterized data
}

Finally, you would register these assets with the particles module as follows:

// This code section loads the published particle related assets authored using the ParticleEffectTool and registers them with the Particles module

// Load the EffectPackage database
iface = loadParams("EffectPackageEffectPackagesDatabase.apb");
PX_ASSERT(iface);
if ( iface )
{
        mModuleParticles->setEffectPackageDatabase(iface);
        iface->destroy();
}

// Load the Emitter database
iface = loadParams("EffectPackageEmittersDatabase.apb");
PX_ASSERT(iface);
if ( iface )
{
        mModuleParticles->setEffectPackageEmitterDatabase(iface);
        iface->destroy();
}
// Load the FieldSampler database
iface = loadParams("EffectPackageFieldSamplersDatabase.apb");
PX_ASSERT(iface);
if ( iface )
{
        mModuleParticles->setEffectPackageForceFieldDatabase(iface);
        iface->destroy();
}
// Load the GraphicsEffects database (IOFX)
iface = loadParams("EffectPackageGraphicsEffectsDatabase.apb");
PX_ASSERT(iface);
if ( iface )
{
        mModuleParticles->setEffectPackageIOFXDatabase(iface);
        iface->destroy();
}

// Load the GraphicsMaterials database
iface = loadParams("EffectPackageGraphicsMaterialsDatabase.apb");
PX_ASSERT(iface);
if ( iface )
{
        mModuleParticles->setEffectPackageGraphicsMaterialsDatabase(iface);
        iface->destroy();
}

// Load the Particle Simulations (IOS) database
iface = loadParams("EffectPackageParticleSimulationsDatabase.apb");
PX_ASSERT(iface);
if ( iface )
{
        mModuleParticles->setEffectPackageIOSDatabase(iface);
        iface->destroy();
}

Creating an Asset based on the pre-registered data in the Particles Module

In the named resource provider callback, you can satisfy request for particle related assets which were predfined in the Particles module using the following snippet of code:

if ( mModuleParticles ) // If we are using the Particles module
{
        // See if this data for this resource was preloaded into the particles module.
        NvParameterized::Interface *iface = mModuleParticles->locateResource(pname,nameSpace);
        if ( iface )
        {
                NvParameterized::Interface *copyInterface;
                iface->clone(copyInterface);    // Create a copy of the parameterized data.
                PX_ASSERT(copyInterface);
                if ( copyInterface )
                {
                        nvidia::apex::Asset *asset = m_apexSDK->createAsset(copyInterface,pname);       // Create the asset using this NvParameterized::Inteface data
                        PX_ASSERT(asset);
                        resource = asset;       // return this resource that we just created
                        if ( asset == NULL )
                        {
                                // If it failed to create the asset, destroy the interface data.
                                copyInterface->destroy();
                        }
                }
        }
}

Creating an EffectPackage Actor

The following code snippet demonstrates how to create an instance of an EffectPackageActor by name:

virtual nvidia::apex::EffectPackageActor *createEffectPackage(const char *effectPackageName,   // The name of the effect package to create
                                                          const physx::PxTransform &p,         // The root transform of the effect package actor
                                                          nvidia::apex::Scene *scene) // The APEX scene to create the effect package actor into
{
       nvidia::apex::EffectPackageActor *ret = NULL;   // Default return value is NULL
       // Use the Named Resource Provider to find the corresponding EffectPackage asset
       nvidia::apex::Asset *effectPackageAsset = (nvidia::apex::Asset *)mApexSDK->getNamedResourceProvider()->getResource(PARTICLES_EFFECT_PACKAGE_AUTHORING_TYPE_NAME,effectPackageName);
       if ( effectPackageAsset && scene )      // If the asset was found and we have a valid scene.
       {
               NvParameterized::Interface *defaultActorDesc=effectPackageAsset->getDefaultActorDesc();
               if ( defaultActorDesc )
               {
                       NvParameterized::setParamTransform(*defaultActorDesc,"InitialPose",p);
                       nvidia::apex::Actor *effectPackageActor = effectPackageAsset->createApexActor(*defaultActorDesc,*scene);
                       ret = static_cast< nvidia::apex::EffectPackageActor *>(effectPackageActor);
               }
       }
       return ret;
}

Modifying an EffectPackageActor : EffectPackageActor.h

Once you have created an EffectPackageActor you can modify its behavior in the following ways:

/**
\brief Fade out the EffectPackageActor over a period of time.
This method will cause the actors within the EffectPackage to be 'faded out' over a period of time.
The EffectPackageAsset will define how this fadeOut operation is to be applied.  Some actors may
simply be turned off over this duration while others are modulated in some way.  For example, by default,
emitter actors will have their emitter rate reduced over this duration so they do not appear to
immediately cut off

\param [in] fadeTime : The duration to fade out the associated effects in seconds
*/
virtual void fadeOut(physx::PxF32 fadetime) = 0;

/**
\brief Fade in the EffectPackageActor over a period of time.
This method will cause the associated effects to be faded in over a period of time.
It will begin the linear interpolation fade process relative to the current fade time.
Meaning if you had previously specified a fadeOut duration of 1 second but then execute
a fadeIn just a 1/2 second later, will will begin fading in from a 50% level; not zero.

\param [in] fadeTime : The duration to fade this effect in, in seconds
*/
virtual void fadeIn(physx::PxF32 fadetime) = 0;

/**
\brief Returns the number of effects within this effect package.
*/
virtual PxU32 getEffectCount(void) const = 0;

/**
\brief Returns the type of effect at this index location

\param [in] effectIndex : The effect number to refer to; must be less than the result of getEffectCount
*/
virtual EffectType getEffectType(PxU32 effectIndex) const = 0;

/**
\brief Returns the base Actor pointer for this effect.
Use this method if you need direct access to the base Actor pointer relative to this
effect.  You must use 'getEffectType' to know what type of actor this is referring to before
you cast it to either an emitter, or heat source, or turblence actor, etc.
It is important to note that the application cannot cache this pointer as it may be deleted in
subsequent frames due to level of detail calculations or timing values such as fade out operations.

\param [in] effectIndex : The effect number to refer to; must be less than the result of getEffectCount

\return Returns the Actor pointer for this effect.  This may be NULL if that effect is not currently active.
*/
virtual Actor *getEffectActor(PxU32 effectIndex) const  = 0;

/**
\brief Forces the state of all emitters associated with this effect package to be on or off.
This method allows the application to manually force all emitters to be active or inactive
based on an explicit call.

\param [state] : Determines whether to set all emitters on or off
*/
virtual void setEmitterState(bool state) = 0;

/**
\brief A helper method to return the active number of particles being simulated by all related effects in this EffectPackageActor

\return Returns the number of particles active relative to this EffectPackageActor
*/
virtual PxU32 getActiveParticleCount(void) const = 0;

/**
\brief This helper method reports if any emitters within this EffectPackageActor are still actively emitting particles.

This method allows the application to determine whether or not any emitters are actively running
relative to this actor.  Typically this would be used to defer deleting an effect while it is still active.

\return Returns true if any emitters in the actor are still active.
*/
virtual bool isStillEmitting(void) const = 0;

/**
\brief Allows the application to manually enable this EffectPackageActor

This method is used by the application to manually force the EffectPackageActor to be enabled.
This is generally used based on some kind of game logic where the EffectPackageActor has been
pre-allocated and placed into the world but is initially inactive until some event occurs.

\param [state] Set the current enabled state to true or false
*/
virtual void setEnabled(bool state) = 0;

/**
\brief Returns the current enabled state for this actor
*/
virtual bool getEnabled(void) const = 0;

/**
\brief Sets the root pose for this EffectPackageActor
It's important to note that child-relative poses for each sub-component in an EffectPackageActor
are authored in the ParticleEffectTool.

\param [pose] : Sets the current root pose for this EffectPackageActor
*/
virtual void setPose(const physx::PxTransform &pose) = 0;

/**
\brief Returns the current root pose for this EffectPackageActor
*/
virtual const PxTransform& getPose(void) const = 0;

/**
\brief This method is used by the ParticleEffectTool to refresh a currently running effect with real-time property changes
*/
virtual void refresh(void) = 0;

/**
\brief Releases this EffectPackageActor and all associated children effects
*/
virtual void release(void) = 0;

/**
\brief A convenient helper method to return the name of the asset used to to create this actor.
*/
virtual const char *getName(void) const = 0;

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

APEX EffectPackage Users Guide

Introduction

An EffectPackageActor represents an instantiation of a collection of related particle actors. An EffectPackage allows for multiple related particle actors to be instantiated as a single unit each relative to a central root pose transform. An effect package can combine one or more emitters as well as associated field samplers, heat sources, and forcefields. The combined EffectPackageActor can be subject to fully customizable level of detail culling and otherwise manipulated as a single unit.

EffectPackages are authored using the ‘ParticleEffectTool’ which allows the developer to rapidly prototype a combined ‘package of effects’ which link to shared resources. This is a PhysX 3.x only feature.

APEX EffectPackage Authoring Parameters Overview

LOD Settings

Each EffectPackageActor can have a set of level of detail optimizations applied to it. These are optional settings but can offer powerful control over how to cull effects within a game. There are two primary ways to cull an effect; based on distance from the camera and based on screen culling.

The following properties control how level of detail is applied to an effect package.

  • FadeDistanceBegin - The distance from the camera to begin fading out this effect package.
  • FadeDistanceEnd - The distance from the camera to completely fade out and then disable this effect package.
  • RandomizeEmitterRate - Whether or not to randomize the emitter rate over time
  • FadeOutRate - The amount of time to fade out an effect when it is disabled.
  • CullOffScreen - Whether or not to cull this effect package if it is considered off screen; requires a valid view and projection matrix
  • OffScreenCullTime - How long the effect is off screen (in seconds) before it is disabled; to prevent an effect from turning on/off immediately when it rapidly spins in and out of view.
  • NonVisibleDeleteTime - How long an effect is considered non-visible before it is completely deleted; rather than simply faded out.
  • ScreenCullSize - Screen culling takes place in 2d where the origin point of the effect is transformed into screen-space. This value determines how far ‘off screen’ this point is before the entire effect is considered non-visible. See detailed notes about screen-space culling.
  • ScreenCullDistance - Because of the nature of how 3d points are projected into 2d; you probably want to disable screen-culling if the effect is very close to the camera. This distance determines a threshold distance an effect must be from the camera before screen culling is enabled.
  • FadeEmitterRate - If true then the emitter rate is faded out over time. Other ‘Fade’ options determine if those properties are faded when the entire effect package is faded out.

Screen Space Culling

When a 3d point is projected into screen space the resulting projection translates as shown in the above image. The projected coordinate ranges from -1,-1 to +1,+1. Any projected point within these bounds can therefore be considered ‘on-screen’. However, an ‘effect’ is more than just a single point; it usually has a volume representing a large number of particles being emitted from a central location. Using the ‘ScreenCullSize’ parameter an additional border can be added to account for this. The artist/designer can adjust this value based on the overall size of the effect they are placing into the environment. In the image above note that even though the center of the effect is considered ‘off screen’ the boundary of the particles still intersects it. By adjusting ‘ScreenCullSize’ this extra border can be taken into account. Due to the nature of 3d to 2d projection you should not use screen space culling for effects which are extremely close to the camera. The value for ‘ScreenCullDistance’ will disable any screen culling for effects which are within this distance from the camera origin.

Not every effect you create necessarily needs screen-space culling. The designer should decide on a case by case basis whether or not this feature makes sense for the type of effect that is being created. In general, though, it is desirable to avoid creating effects that cannot be seen.

To use the screen-culling feature the application must provide the APEX SDK not only with a valid view matrix but a valid projection matrix as well.

One feature of the effect culling system is that it will prevent effects with a fixed lifetime duration from even being created if they are considered non-visible at the time they are spawned.

EffectProperties

Each effect contained within an effect package can have unique properties relative to its instantiation into the scene. Primarily these properties are a parent relative transform and timing values. The user call also specifiy an arbitrary UserProperties field which the application can use for additional annotations if needed.

The following properties can be applied to any effect attached to an effect package.

  • UserString - This is an arbitrary string which can be interpreted by the application to contain user meta-data.
  • Enable - This flag determines whether or not, by default, this effect is enabled when the EffectPackageActor is instantiated.
  • Position - This is the parent relative position of this effect.
  • Orientation - This is the parent relative orientation of this effect; specified as an euler rotation which can be edited using the PET
  • InitialDelayTime - This is an optional time to delay creation of this effect.
  • Duration - This is how long this effect should be alive for; default value is zero, which means to stay alive infinitely.
  • RepeatCount - This value determines how many times this effect should repeat. The default value is one, meaning to just play the effect once for the specified duration. A value of 9999 is a special reserved value which means to repeat forever.
  • RepeatDelay - This is an optional delay value to wait before restarting the effect each time the Duration value expires.
  • RandomizeRepeatTime - This value determines how much to randomize the repeat intervals. A value of zero means no randomness, a value of 1 means completely random between 0 and the entire original duration range specified.

EffectPacakge EmitterProperties

If the effect is an emitter then there is an optional additional feature where the particle lifetime and/or emitter rate can be adjusted based on the velocity of the effect. Sometimes this is a useful feature if the particles need to have a higher rate and longer lifetime if the emitter is moving faster or slower.

For each option, adjusting the lifetime or adjusting the emitter rate, there are five properties that can be edited.

  • AdjustEnabled - Set this flag to true if you want to enable velocity adjustment.
  • VelocityLow - This is the low velocity (in distance units per second) before any modulation is performed.
  • VelocityHigh - This is the high velocity range for corresponding modulation of lifetime or emitter rate.
  • LowValue - This determines how much to modulate the corresponding property. This number is multiplied times the base rate.
  • HighValue - This is the high modulation value for the corresponding property.

The ParticleEffectTool (PET)

The ParticleEffectTool is a standalone Windows application that is designed to author all particle related asset types.

You can configure some defaults for how the PET runs by editing the file ‘ParticleEffectToolPublic.ini’

The first section, DATABASES, controls where the assets authored with the PET are stored. By default all of the raw source APEX assets are stored as XML/APX files into the subdirectory ‘particle_databases’. The combined runtime binary files are stored in ‘publish_particle_databases’.

When using APEX effect packages, binary files representing all of the various interelated assets which were authored for your title are pre-loaded on startup. Details about this process will be covered in the programmer’s guide.

You do not have to use this process or effect packages at all to take advantage of the ParticleEffectTool. If all you want to do is use this tool to author individual particle effect files which you load and manage individually in your project, you can do that too.

Currently the ParticleEffectTool does not yet support organizing assets into sub-directories or browsing files from various locations on a hard drive. Today you simply place all asset files associated with a particular project into a single sub-directory as identified by the configuration .INI file mentioned above. Future releases may introduce the concept of a ‘workspace’, the ability to browse files from any location on a hard drive, and/or subdirectories. The workflow for this, however, introduces a lot more complexity in terms of how fully qualified names are resolved and some other issues. With this initial release, simply organize all related ‘effects’ you might be working on into a single directory for now.

The ‘OPTIONS’ section of the INI file controls the following features.

  • LocalUser - This property determines if the application is running from the formal installer or a version built internally from source code. The version from the installer stores assets into the ‘My Documents’ folder for the current user.
  • UsePerforce - The PET has Perforce integration available. If you use Perforce for your source control system you can enable this and assets will automatically be opened for edit, added, or deleted, to the current default changelist. Only enable this if your asset directories are properly mapped to your Perforce server location.
  • DisableGpu - This is a debug option which allows the PET to run without GPU particles enabled. Used only for debugging.
  • SceneGravity - The default gravity value is -9.8 distance units per second squared, assuming your application’s distance units are meters. However, if you want to experiment with different gravity values you can edit this option.
  • GlobalSpriteSize - This setting allows you to apply a metric to scale sprite sizes in the tool to more closely match sprite sizes for the same assets in your own game engine.
  • UseZup - By default the PET runs with Y as the up-axis. Set this to true if your game engine uses Z as the up-axis.
  • UseSplitWindow - This is a debug feature as this point, as the preferred and supported mechanism for editing assets is using the split-window view.

PET Output Asset Files

When using the PET to edit assets, each is saved out to a unique filename which can be loaded by your own application.

BASE FILE NAME | APEX Module | APEX ASSET PREPROCESSOR NAME | APEX ASSET NXPARAMETERIZED CLASS NAME
EffectPackageEffectPackages | Particles | PARTICLES_EFFECT_PACKAGE_AUTHORING_TYPE_NAME | EffectPackageAssetParams
EffectPackageEmitters | Emitter | APEX_EMITTER_AUTHORING_TYPE_NAME | ApexEmitterAssetParameters
EffectPackageFieldSamplers | ForceField,BasicFS | SEVERAL | SEVERAL
EffectPackageGraphicsEffects | IOFX | IOFX_AUTORING_TYPE_NAME | IofxAssetParameters
EffectPackageGraphicsMaterials | Particles | Not an APEX asset | GraphicsMaterialData
EffectPackageParticleSimulations | ParticlesIOS, BasicIOS | BASIC_IOS_AUTHORING_TYPE_NAME (and PARTICLE_IOS) | BasicIOSAssetParam, ParticleIosAssetParam

Any one of these asset files can be loaded and used by an application as individual discrete assets. However, another way you can use this is to ‘publish’ all of the files authored using PET into binary versions which can combine all of the data into a single resource. These assets are all quite small, comprising little more than a set of numbers defining various properties. If you choose to use the ‘publish’ option you will get, as a result, ten binaries files (.APB) which can be preloaded up front by your project and registered with the Particles module.

When the APEX named resource provider asks for an asset, rather than going out to disk or in some other fashion retreiving the individual asset, you have the option of just immediately returning the version which was preloaded via the published output. You could then combine dozens, or even hundreds, of particle related assets into just these ten files.

PET Published Binary Output Asset Files

PUBLISH FILE NAME | Purpose
EffectPackageEffectPackagesDatabase.apb | Contains an array of all EffectPackage assets authored in PET
EffectPackageEmittersDatabase.apb | Contains an array of all Emitter assets authored in PET
EffectPackageFieldSamplersDatabase.apb | Contains an array of all FieldSampler related assets authored in PET
EffectPackageGraphicsEffectsDatabase.apb | Contains an arary of all IOFX assets authored in PET
EffectPackageGraphicsMaterialsDatabase.apb | Contains an array of all Graphics Material properties authored in PET; not required
EffectPackageParticleSimulationsDatabase.apb | Contains an array of all BasicIOS and ParticleIOS assets authored in PET

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

APEX Emitter Programmers Guide

Introduction

APEX particle emitter actors output particles at the start of the particle pipeline. Presently there are three basic types of Emitter Authorable Objects. They are the Simple Shape Emitter, Air / Ground Emitter, and the Weapon Impact Emitter. The Air / Ground Emitters are special purpose emitters that emit particles relative to the ground. Finally the Weapon Impact Emitter outputs particles in response to a collision or an explosion.

Shaped APEX Emitter

The shape emitters can be one of these geometries, under the NvParameterized included reference, geometryType:

  • Box - PxVec3 extents
  • Cylinder - PxF32 radius, PxF32 height
  • Sphere - PxF32 radius
  • Sphere Shell - PxF32 radius, PxF32 shellThickness
  • Explicit - PxVec3[] positions, PxVec3[] velocities

Within each of the shape geometry types is an emitterType which defines the frequency and position of the particles spawned in the emitter.:

  • rate - The emitter will emit at the rate specified by the asset’s rateRange
  • densityOnce - The emitter will fill the geometry according to the asset’s densityRange
  • densityBrush - As the emitter moves, the emitter will fill the volume that is not already covered by the previous position
  • fill - The emitter will fill the volume with particles based on the particle size

Creating the Shaped Emitter

The ApexEmitterActorParameters NvParameterized class contains the parameters necessary to create an Emitter Actor:

  • initialPose - The shaped emitter may be placed with a particular position and rotation
  • attachRelativePose - Once the shape is created, the Emitter::setAttachActor(Actor*) method is used, if desired, to have the emitter’s pose match that of the Actor’s pose. The attachRelativePose may be set in the actor parameter class during actor creation.
  • emitAssetParticles - A bool which tells the actor whether or not it should emit particles stored in the asset’s particle list.
  • overlapTestGroupMaskName - Before the emitter creates a particle it can test to see if the particle is within a collision volume, preventing particle popping issues. This string is mapped by the Named Resource Provider to a 32-bit mask of multiple collision groups used by the overlap tests.
  • overlapTestGroupsMask128Name - This string is mapped by the Named Resource Provider to a 128-bit mask (GroupsMask) used by the overlap tests.

Please note that the particle emitter state does not reflect emitAssetParticles bool when an ApexEmitterActor is created. The application must still explicitely call ‘startEmit’ to get the emitter started.

Depending on the scene, overlap tests may become expensive. To prevent them from happening, leave both overlap mask strings empty on actor creation. The EmitterActorOverlapAABBSceneQuery profiler event is emitted during the overlap tests.

Emitting Particles

Particles are emitted after the application calls Scene::simulate() if the Emitter::startEmit() has been called. It is possible to emit particles just once by setting the persistent flag in startEmit() to false:

emitterActor->startEmit( false );

If the persistent flag is true, the emitter will emit particles every frame. Make note that the shaped emitter never takes into account particles that it emitted in previous frames for the density calculations.

Using the Explicit Geometry

The explicit geometry type makes the APEX emitter very flexible by allowing the user to create particles at specific positions and velocities. These particle positions and velocities may be stored in the asset where all actors have access to the lists. The actor can also hold its own particle positions and velocities. Note, particles stored in the asset can be emitted by any actor created by the asset, particles stored in the actor’s list may only be accessed by the actor. Example:

During runtime, to access an explicit emitter actor's asset particles:
emitterActor->getEmitterAsset()->getGeom()->isExplicitGeom()->getParticleList(...)

During runtime, to access an explicit emitter actor's particles:
emitterActor->isExplicitGeom()->getParticleList(...)

The emitAssetParticles member of the emitter actor’s NvParameterized parameters (ApexEmitterActorParameters) will switch whether or not the asset’s particle list is emitted by the actor. If this parameter is true, then only the particles added through the actor’s explicit geometry will be emitted.

When the geometry is explicit, the densityRange asset parameter actually becomes a particle spawn probability:

1.0 - all particles in the particle list will be spawned every frame
0.0 - no particles will be spawned

Explicit Particle Velocities

If particle velocites provided are zero, then a random value within the emitter asset’s velocityRange parameter is used.

Explicit Emitter Pose

Since the emitter actor will transform all particle positions to the emitter actor’s position, it is possible to set multiple poses for the emitter in one frame. Every time the EmitterActor::startEmit() method is called, the current pose is stored in an array and each individual pose is used to emit particles during the simulation.

The application can avoid position and velocity transformations on particles by leaving the pose at the non rotated origin and using absolute particle positions and velocities.

Impact Emitter

The impact emitter packages both particle emission events and explosion events into one actor. The application is expected to perform raycasts and determine the correct parameters to pass to the ImpactEmitterActor::registerImpact(...) method. The impact emitter asset and actor do not make any association between the physical material of the hit shape returned from the raycasts and the setID within the emitter.

It is expected that a game engine will already have physical material names, and these names can be stored as the event set name within the asset. All of the event set names (and their corresponding )may be retrieved using the ImpactEmitterAsset::getSetNames() method. To determine the a setID from a particular event set name, use the ImpactEmitterAsset::querySetID( const char * setName ) method.

Ground Emitter

The ground emitter is typically used to position ground debris around a player. As the player moves throughout the level, the emitter deposits particles on the ground. The pose of the ground emitter actor may be updated manually by calling GroundEmitterActor::setPose() or automatically with GroundEimtterActor::setAttachActor().

Ground emitters perform raycasts to determine where to place particles in a scene. If the application has not created its own MaterialLookupCallback class and registered it using GroundEmitterActor::setMaterialLookupCallback(), raycasts will be performed by the PhysX engine. These raycasts can be filtered using both an CollisionGroup bitmask and an GroupsMask.

The Named Resource Provider will callback in the NSCollisionGroupMask and NSCollisionGroup128 namespaces to retrieve both an CollisionGroup bitmask and an GroupsMask for the raycasts. If neither is provided, the raycast should collide with all objects. The application may set the NSCollisionGroup128 resource to NULL if GroupsMasks are not being used.

Every PhysX raycast will return an MaterialIndex (PxU16) for the physical material that was hit. This MaterialIndex needs to be mapped to one of the physical material strings listed in the emitter asset’s materialFactoryMapList. For each different physical material listed in the asset’s materialFactoryMapList, the Named Resource Provider will callback in the NSPhysicalMaterial namespace to fetch an MaterialIndex.

Named Resource Provider Callbacks

Here is a summary of the callbacks that the ground emitter may call:

Namespace | Reason
IOFX | A different IOFX could be used for each physical material listed in the materialFactoryMapList
NSPhysicalMaterial | The physical material names must be mapped to MaterialIndex values by the application
NSCollisionGroupMask | Raycasts may be filtered with a 32-bit bitmask of CollisionGroups (0xffffffff to hit everything)
NSCollisionGroup128 | Raycasts may additionally be filtered with an GroupsMask, return 0 if GroupdsMasks are not used by the application

Emitter Asset Previews

Emitter asset previews are useful if a level editor wishes to place a representation of an emitter actor in a level.

Shaped Emitter

The shaped emitter preview rendering will draw the geometry of the emitter.

Impact Emitter

Because impact emitter actors do not have a pose and simply receive impact locations from the application, they do not implement preview rendering

Ground Emitter

The ground emitter preview rendering will draw a cylinder that describes the refresh radius, upDirection, and spawnHeight.

Asset Preview Creation

To create an emitter preview class, get the default NvParameterized parameters from the asset using Asset::getDefaultAssetPreviewDesc(). Then set the pose and/or scale, then create the preview class using Asset::createApexAssetPreview():

//Initialized elsewhere depending on type of emitter asset being created
EmitterAsset *asset;
GroundEmitterAsset *asset;

//Common code which sets the asset preview descriptors
PxMat44 pose = PxMat44::identity();
pose.setPosition( physx::PxVec3( 0.0f, 10.0f, 0.0f ) );
NvParameterized::Interface* p = asset->getDefaultAssetPreviewDesc();
NvParameterized::setParamMat44(*p, "pose", pose);
NvParameterized::setParamF32(*p, "scale", 1.0f);

//Create emitter asset preview depending on type of emitter asset being created
mApexEmitterPreview = static_cast<EmitterPreview*>(asset.createApexAssetPreview( *p ));
mGroundEmitterPreview = static_cast<GroundEmitterPreview*>(asset.createApexAssetPreview( *p ));

Debug Visualization

The APEX Emitter Module provides different debug visualizations for the emitter actors (shaped, impact, and ground).

Click here for a list of the APEX Emitter debug visualization parameters

For general information on how to use debug visualization within APEX, please see Debug Visualization.

Errors and Warnings

APEX Emitter outputs the following error and warning messages using the standard APEX error stream.

ERROR CODE | MESSAGE
APEX_INVALID_OPERATION | %s is not a valid descriptor class
APEX_INTERNAL_ERROR | Could not create a new APEX Emitter parameter instance
APEX_INTERNAL_ERROR | Cannot get NvParameterized handle for APEX Emitter geometry type.
APEX_INTERNAL_ERROR | Could not initialize NvParameterized type: %s
APEX_INTERNAL_ERROR | No matching NvParameterized type: %s
APEX_INTERNAL_ERROR | IOFX, IOS, or IOS type not initialized
APEX_INTERNAL_ERROR | No emitter geometry specified
APEX_INTERNAL_ERROR | Invalid NvParameterized handle for name: eventSetList
APEX_INTERNAL_ERROR | Cannot get NvParameterized handle for eventSet %d out of %d
APEX_INTERNAL_ERROR | Could not access invalid NvParameterized eventSet
APEX_INTERNAL_ERROR | Could not create a new Impact Emitter parameter instance
APEX_INTERNAL_ERROR | Impact Emitter deserialization does not support versions before NvParameterized was added
APEX_INTERNAL_ERROR | Invalid NvParameterized handle for name: eventSetList
APEX_INTERNAL_ERROR | Cannot get NvParameterized handle for eventSet %d out of %d
APEX_INTERNAL_ERROR | Could not initialize NvParameterized type: %s
APEX_INTERNAL_ERROR | Invalid included NvParameterized type: %s
APEX_DEBUG_INFO | IOS asset retrieval failure: %s
APEX_DEBUG_INFO | IOS injector allocation failure
APEX_DEBUG_WARNING | Not all objects have been emitted:
APEX_DEBUG_WARNING | Unable to serialize an Emitter without a geometry
APEX_DEBUG_WARNING | EmitterLodParamDesc version mismatch
APEX_DEBUG_WARNING | Invalid eventSetName from Impact Emitter event sets

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

APEX Emitter Users Guide

Introduction

The Emitter library allows the artist to control how physical particles are injected into a scene. Presently there are three basic types of Emitter Authorable Objects. They are the Simple Shape Emitter, Air / Ground Emitter, and the Weapon Impact Emitter. The current shape emitters are the box emitter, the sphere emitter, the sphere shell emitter, and the explicit emitter. The box and sphere emitters emit particles (objects) inside their shape. The sphere shell emitter emits particles within the shell of a specified thickness around a sphere. The final shape emitter is the explicit emitter outputs particles at explicit user defined locations. The Air / Ground Emitters are special purpose emitters that emit particles relative to the ground. Finally the Weapon Impact Emitter outputs particles in response to a collision or an explosion.

APEX Emitter Authoring Parameters Overview

Common Parameters

All APEX emitter actors have common parameters that the user may author that control general characteristics of any emitter. These parameters control features of the both the particles and the emitter itself. Most of these parameters are authored as a range. For any particular actor at any one moment the aspect controlled by the parameter can be anywhere within the range controlled by a random value. The level of detail (LOD) parameters are also common among all emitters. All of these parameters are documented further here:

  • APEX Emitter Common Parameters

Shape Emitters

The various shape emitters (box, sphere, sphere shell) emit particles in their shapes. Box emitters can be used to create effects such as water dripping from a ceiling or fog or smoke being emitted from a duct. The sphere emitter and the sphere shell emitter can be used to create symmetric explosion effects with particles emanating outward from the sphere. The sphere shell emitter can also be used to create implosion effects. The explicit emitter provides the greatest flexibility of all of the shape emitters providing the ability to specify on a point by point basis the locations where particles are emitted.

The Simple Shape Emitter Parameters:

  • APEX Box Emitter Parameters
  • APEX Cylinder Emitter Parameters
  • APEX Sphere Emitter Parameters
  • APEX Sphere Shell Emitter Parameters

The Explicit Particle Position (available in the simple shape emitter) Parameters:

  • APEX Explicit Emitter Parameters

Air / Ground Emitters

Air Emitter

Air emitters can be used to produce effects such as leaves falling from trees, or fog.

Ground Emitter

A typical ground emitter emits leaves or debris into an outdoor level. Ground emitter actors can be located at a static location or can be attached to the player actor as he moves around the level. The advantage of attaching ground emitter actors to the player is that the particles will only be emitted around the actor where they can be seen. Attaching the ground emitter actor to the player makes it unnecessary to have a very large actor that emits particles over most or all of a level only to have LOD constantly delete them thus greatly reducing the overhead. Ground emitters ray cast against the terrain every frame to find where to place new particles to maintain the authored particle density. Ground emitters can adapt to the type of terrain that they are in via a callback mechanism. For instance in a forest leaves could be emitted while on a road dust or gravel could be emitted.

The Ground Emitter Parameters are listed and documented here:

  • APEX Air/Ground Emitter Parameters

Weapon/Impact Emitter

The APEX Weapon/Impact Emitter is intended to output particles as a reaction to impacts from weapons. The author may select the typical particle emitter parameters such as density, lifetime, initial speed range and also select the angle that the particles will be emitted at with respect to the weapons impact angle. The angle impact angle may be authored to be either incident, normal, or a reflection of the impact angle.

The Weapon/Impact Emitter Parameters are listed and documented here:

  • APEX Weapon Emitter Parameters

APEX Emitter Preview Rendering

APEX Emitter Preview Rendering consists of a bounding box of the particular emitter and a ray that is used to indicate where the center of the emitter is located.

  • APEX Emitter Preview Rendering Parameters

APEX Emitter Debug Rendering

APEX Emitter Debug Rendering is similar in appearance to the preview rendering for the same type of emitter. The main item displayed for the debug rendering of APEX Emitters is the bounding box of the particular emitter. Thus for a Box emitter a box is drawn and for a sphere emitter a sphere is drawn.

  • APEX Emitter Debug Rendering Parameters

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »

APEX Particles Module

Note

The Particles module is only supported on Windows.

Users Guide

  • APEX Particles Module Users Guide Introduction
  • APEX Emitter Users Guide
  • APEX Basic IOS Users Guide
  • APEX Basic FS Users Guide
  • APEX IOFx Users Guide
  • APEX EffectPackage Users Guide

Programmers Guide

  • APEX Particles Module Programmers Guide Introduction
  • APEX Emitter Programmers Guide
  • APEX Basic IOS Programmers Guide
  • APEX IOFx Programmers Guide
  • APEX EffectPackage Programmers Guide
  • APEX Particle CUDA Memory Usage
  • APEX Particle Integration Guide

Examples

  • Basic IOS Example
  • IOFx Example

API

  • BasicIOS API
  • Emitter API
  • ForceField API
  • Particles API
  • IOFX API

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

APEX Particles Module Programmers Guide Introduction

Introduction

The APEX Particles module is a particle (object) pipeline that is designed to produce a wide range of scalable effects in games. Each stage of the pipeline is an APEX actor derived from an APEX asset whose parameters are authored. The particle pipelines consists of a particle emitter, an Instanced Object Simulation (IOS) that computes the physical movement and life remaining of each particle, and an Instanced Object Effects (IOFX) actor that based on the particles physical characteristics determines how the particles (objects) in the pipeline are rendered. A game level editor can create multiple emitter actors in a game level. They can be of the same type or of different types. The emitter actors can reference any number of IOS or IOFX actors. The IOS and IOFX actors are created automatically by APEX.

APEX Particle Pipeline

APEX Particle Pipeline

APEX particle emitter actors emit particles at the start of the particle pipeline. Presently there are three basic types of Emitter Authorable Objects. They are the Simple Shape Emitter, Air / Ground Emitter, and the Weapon Impact Emitter. The current shape emitters are the box emitter, the sphere emitter, the sphere shell emitter, and the explicit emitter. The box and sphere emitters emit particles (objects) in their shape. The sphere shell emitter emits particles within the shell of a specified thickness around a sphere. Finally the explicit emitter outputs particles at explicit user defined locations. The parameters that control the behavior of each of these emitters is documented here:

  • APEX Emitter Common Parameters

Presently two IOSes have been implemented. They are the BasicIos and the PxParticleIos (Particles Library). The BasicIos provides parameters that control the basics of a stream of particles, such as the resting density, the particle radius and the maximum number of particles. The BasicIos does not interact with PhysX SDK force fields. PxParticleIos is a wrapper for PhysX particle simulation.

There are multiple IOFX modifiers that each provide unique capabilities. Multiple IOFX modifiers can be used by a particle pipeline. Within the IOFX library the modifiers act as elements in the particle pipeline passing the output of one modifier to the input of the next. The following diagram illustrates the internal IOFX pipeline.

APEX IOFX Pipeline

APEX IOFX Pipeline

The IOFX Asset Parameters are documented here:

  • APEX IOFX Asset Parameters
  • APEX Mesh IOFX Continuous Modifier Parameters
  • APEX Sprite IOFX Continuous Modifier Parameters
  • APEX Mesh IOFX Spawn Modifier Parameters
  • APEX Sprite IOFX Spawn Modifier Parameters

All of the currently implemented modifiers are data driven (as opposed to procedural). In the long term, it will be possible to implement a procedural modifier that will allow game developers to write their own modifier subroutines (similar to GPU shader programs). Modifiers will be initially implemented on the CPU, however, the architecture supports an alternative CUDA version for use when running on CUDA enabled GPU’s. On CUDA enabled systems, particle data will be able to be passed from CUDA compatible IOS’es to CUDA compatible IOFX Modifiers while remaining entirely in GPU memory. When support for CUDA/DirectX Interoperability is enabled, data will be able to be passed from CUDA IOFX Modifiers to the game’s rendering engine (through the Render Resources API), while remaining entirely in GPU memory.

Performance Considerations

Particle system run-time performance is primarily linear with the resource budget given to the IOS modules. However, the largest source of overhead is in the number of active fluid simulations. To achieve optimal performance for a given particle budget, you should use the fewest number of IOS actors as possible. The number of emitters and IOFX assets that share an IOS have a relatively small effect on performance.

To limit the number of IOS actors, one can simply limit the number of IOS assets. Also be aware that an IOS actor must operate as either a mesh simulation or a sprite simulation, so if two emitters use an IOS asset with both sprite and mesh IOFX assets, APEX will generate two IOS actors - one for each simulation type.

Per-IOS Actor Resources:

  • particle simulation buffers
  • IOFX modifier state buffers
  • CUDA IOFX modifiers are batched to run on an entire IOS at once
  • double or triple instanced output buffers
  • single sprite or instance render resource
  • one writeBuffer() call per simulation step, when interop is not used

Per-IOFX Actor Resources:

  • one UserRenderResource holding a particle range in its IOS sprite/instance buffer
  • one dispatch (draw call) per render frame
  • CPU IOFX modifiers run in parallel in the APEX thread pool

Per-Emitter Actor Resources:

  • Computation time to emit particles
  • Storage for particles until they are injected into the simulation

PhysX SDK Compatibility

APEX Particles is compatible with all PhysX SDKs that support APEX.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

APEX Particles Module Users Guide Introduction

Introduction

The APEX Particles module is a particle (object) pipeline that is designed to produce a wide range of scalable effects in games. Each stage of the pipeline is an APEX actor derived from an APEX asset whose parameters are authored. The particle pipelines consists of a particle emitter, an Instanced Object Simulation (IOS) that computes the physical movement and life remaining of each particle, and an Instanced Object Effects (IOFX) actor that based on the particles physical characteristics determines how the particles (objects) in the pipeline are rendered. A game level editor can create multiple emitter actors in a game level. They can be of the same type or of different types. The emitter actors can reference any number of IOS or IOFX actors. The IOS and IOFX actors are created automatically by APEX.

APEX Particle Pipeline

APEX Particle Pipeline

The new unified Particles module for APEX 1.3

APEX 1.3 introduces a new module called ‘Particles’. This new singular ‘Particles’ module, which is delivered as a DLL under the Windows platform, now combines all particle related modules (IOFX, Emitter, IOS, etc.) into a single binary. It does not include the Turbulence module due to how the source code for this component is licensed.

The primary reason for this change is to simplify the process of managing these modules as well as to make it easier to create binary distributions. Now, instead of an application loading the IOFX modules, Emitter module, etc. separately, the application simply loads the single ‘Particles’ module. The application now needs only to load the ‘Particles’ module on startup, release it on exit, and when it comes to deployment distribute only this single binary DLL. If the application needs access to the various sub-component modules, such as IOFX, Emitter, etc. they still exist but are now accessed via the ‘ModuleParticles’ class using the method ‘getModule’.

Relatively modest changes are required to existing source code developed against a previous version of the APEX SDK; changes which primarily involve deleting source which used to have to deal with the granular module loading mechanism. In short, it essentially cleans up your startup and shutdown code.

Another feature introduced with the new unified ‘Particles’ module is the ‘EffectPackageActor’ and ‘EffectPackageAsset’. The ‘effect package’ system combines a collection of particle related actors into a single instantiation which can be manipulated as whole unit. Imagine you have an ‘effect’ which involves multiple emitters, a turbulence grid, a heat source, and some jet field samplers. Rather than having to instantiate and manage five or six separate APEX actors you can now instantiate them all as a single ‘effect’ and manage it as a unit. The newly introduced ‘Particle Effect Tool’ (PET) now allows a designer/artist to author ‘effects’ which can be managed in this way. This feature is optional and is not required to work with APEX particles. You can still instantiate and manage APEX particle related actors manually and even use individual assets authored via the ParticleEffectTool as well. One of the additional features afforded by using ‘effect packages’ is a mechanism to perform level of detail operations using artist/designer ‘per effect’ settings.

Emitters

APEX particle emitter actors emit particles at the start of the particle pipeline. Presently there are three basic types of Emitter Authorable Objects. They are the Simple Shape Emitter, Air / Ground Emitter, and the Weapon Impact Emitter. The current shape emitters are the box emitter, the sphere emitter, the sphere shell emitter, and the explicit emitter. The box and sphere emitters emit particles (objects) in their shape. The sphere shell emitter emits particles within the shell of a specified thickness around a sphere. Finally the explicit emitter outputs particles at explicit user defined locations. The parameters that control the behavior of each of these emitters is documented in the following links.

The Simple Shape Emitter Parameters:

  • APEX Box Emitter Parameters
  • APEX Cylinder Emitter Parameters
  • APEX Sphere Emitter Parameters
  • APEX Sphere Shell Emitter Parameters

The Explicit Particle Position (available in the simple shape emitter) Parameters:

  • APEX Explicit Emitter Parameters

The Air/Ground Emitter Parameters:

  • APEX Air/Ground Emitter Parameters

The Weapon/Impact Emitter Parameters:

  • APEX Weapon Emitter Parameters

IOSes

Two IOSes exist, the Basic IOS and the PxParticle IOS. The Basic IOS is implemented within APEX as either a CPU or GPU simulation and its purpose is to be a very high performance simulation with very high particle counts for Turbulence. It supports collision with PhysX static and dynamic shapes, but these are proxied from the PhysX scene and not a native component of the simulation. The PxParticle IOS uses the PhysX 3 particle simulation; either PxParticleSystem or PxParticleFluid, depending on the parameters specified in the asset. If the intent is to have lots of dynamic and static collision between the particles, actors, and the environment then this IOS is intended to be used.

IOFX

There are multiple IOFX modifiers that each provide unique capabilities. Multiple IOFX modifiers can be used by a particle pipeline. Within the IOFX library the modifiers act as elements in the particle pipeline passing the output of one modifier to the input of the next. The following diagram illustrates the internal IOFX pipeline.

APEX IOFX Pipeline

APEX IOFX Pipeline

The IOFX Asset Parameters are documented in APEX IOFx Users Guide

Effect Packages

The EffectPackageActor is only available with the PhysX 3.3 SDK and above. An EffectPacakgeAsset is authored using the new ParticleEffectTool (PET). This asset represents a collection of one or more particle related assets bound into a single easy to use unit. A single ‘EffectPackage’ might contain three emitters, each with different properties, a turbulence grid, and other field samplers such as jets or attractors. It could include heat sources and force fields as well. Each of these sub-elements can have different timing values controlling when they are created and whether or not they loop, for how long, and how many times. Finally an EffectPackage can have artist defined level of detail properties to control how to control the effect based on distance from the camera and even using screen space culling as well.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

APEX IOFx Programmers Guide

Introduction

Since the Particle emitter spawns the IOS and the IOFx actors, most programmer interaction with this module focuses on the rendering side of the IOFX actors and RenderVolumes.

IOFX Semantics and Render Layouts

IOFX can output different render semantics (defined in IofxRenderSemantic enum):

POSITION     - 3D Position of particle
COLOR        - Color of particle
VELOCITY     - 3D Linear velocity of particle
SCALE        - 2D or 3D Scale of particle
LIFE_REMAIN  - Normalized life of particle = 1.0 (spawned) -> 0.0 (dead)
DENSITY      - Particle density
SUBTEXTURE   - Sub-texture index of particle (only Sprites)
ORIENTATION  - Particle screen orientation = angle in radians (CCW in screen plane, only Sprites)
ROTATION     - 3D particle rotation (only Meshes)
USER_DATA    - User data - 32 bits (passed from APEX Emitter)

Each IOS actor operates in either mesh or sprite mode, meaning all of the IOFX assets used with a single IOS actor will either all be mesh IOFX or sprite IOFX. This detail is not exposed to the artist. APEX simply creates two IOS actors if the one IOS asset is used with both sprite and mesh IOFX assets.

The IOS actor will create sprite buffers if it is operating in sprite mode, or mesh instance buffers if it is operating in mesh mode. Mesh instance buffers will have fixed semantics; POSITION, ROTATION, SCALE, VELOCITY, LIFE_REMAIN, and DENSITY if the underlying IOS supplies a density value (currently only 3.x Particle IOSes with SPH enabled, or BasicIOS or 3.x ParticleIOS when grid density is enabled).

Sprite buffers will have semantics for the sum of all IOFX assets currently in use with an IOS actor. This means the semantics output by an IOS actor may change as emitters are added to or removed from a scene. The next time the IOFX actors of that IOS are updated by the render thread, the old sprite buffers will be released and new sprite buffers will be allocated with the new semantics. No rendering data is lost for any frames because the simulation output buffer always has the correct semantics.

Sprite/Mesh render buffer represents an array of structures, like ordinary Vertex buffer in Computer Graphics. Each structure of render buffer is defined by render layout (corresponding to Vertex Declaration in Computer Graphics), consisting of set {semantic, format, offset} and stride.

All available Sprite semantics & format pairs are defined in IofxSpriteRenderLayoutElement enum:

POSITION_FLOAT3
COLOR_RGBA8
COLOR_BGRA8
COLOR_FLOAT4
VELOCITY_FLOAT3
SCALE_FLOAT2
LIFE_REMAIN_FLOAT1
DENSITY_FLOAT1
SUBTEXTURE_FLOAT1
ORIENTATION_FLOAT1
USER_DATA_UINT1

All available Mesh semantics & format pairs are defined in IofxMeshRenderLayoutElement enum:

POSITION_FLOAT3
ROTATION_SCALE_FLOAT3x3
POSE_FLOAT3x4
VELOCITY_LIFE_FLOAT4
DENSITY_FLOAT1
COLOR_RGBA8
COLOR_BGRA8
COLOR_FLOAT4
USER_DATA_UINT1

Render layout for Sprite/Mesh render buffer is defined in IofxSpriteRenderLayout/IofxMeshRenderLayout. It has offsets array indexed by layout element, which encodes render buffer structure: if offset value is -1 the corresponding layout element is not present, otherwise it’s present in the structure at the provided offset. Stride in render layout sets the whole size of the render buffer structure, and should be enough to store all presented layout elements with corresponding offsets.

Sprite render layout also supports render from surfaces. In this case IofxSpriteRenderLayout::surfaceCount value is greater than zero and IofxSpriteRenderLayout::surfaceDescs array describes surfaces and IofxSpriteRenderLayout::surfaceElements array defines layout for each surface.

All available Sprite surface layouts are defined in IofxSpriteRenderLayoutSurfaceElement enum:

POSITION_FLOAT4
SCALE_ORIENT_SUBTEX_FLOAT4
COLOR_RGBA8
COLOR_BGRA8
COLOR_FLOAT4

By default APEX creates Sprite/Mesh render layout based on the current set of semantics, so that all output semantics are presented in the render buffer. User can create its own render layout by implementing IofxRenderCallback and overriding getIofxSpriteRenderLayout and getIofxMeshRenderLayout methods:

class IofxRenderCallbackImpl : public IofxRenderCallback
{
    virtual bool getIofxSpriteRenderLayout(IofxSpriteRenderLayout& spriteRenderLayout, uint32_t spriteCount, uint32_t spriteSemanticsBitmap, RenderInteropFlags::Enum interopFlags)
    {
        //fill spriteRenderLayout here
        return true;
    }
    virtual bool getIofxMeshRenderLayout(IofxMeshRenderLayout& meshRenderLayout, uint32_t meshCount, uint32_t meshSemanticsBitmap, RenderInteropFlags::Enum interopFlags)
    {
        //fill meshRenderLayout here
        return true;
    }
};

Argument spriteCount/meshCount determines the 1D size of render buffer or 2D size of render surfaces. Surface width should be power of two and >= 32. It is a good idea to determine surface width as a square root of spriteCount ceiled to the nearest power of two. Non-zero bits in the spriteSemanticsBitmap/meshSemanticsBitmap argument correspond to the semantics defined in the IofxRenderSemantic enum and describe which semantics are presented in IOFX output. User are free to provide any set of layout elements in the render layout, even if the corresponding semantics are not present in IOFX output, in this case IOFX outputs default values for these semantics. The most common case is to create just one or a few fixed render layout(s) matching user particles shader(s) input.

Renderables

Rendering is implemented using IOFX Renderable object. Each IOFX actor has its own IOFX Renderable which stores all needed rendering information and can live after the original IOFX actor has been released. Before accessing rendering data in IOFX Renderables, it should be updated once for each rendering frame by calling ModuleIofx::prepareRenderables(const Scene&). IOFX module has method ModuleIofx::createIofxRenderableIterator(const Scene&) to create iterator over all IOFX renderables. The following code snipper illustrates how to use it all together:

mIofxModule->prepareRenderables(*mApexScene);
IofxRenderableIterator* iter = mIofxModule->createIofxRenderableIterator(*mApexScene);
for (IofxRenderable* renderable = iter->getFirst(); renderable ; renderable = iter->getNext())
{
    if (visibilityCheck(renderable->getBounds())
    {
        if (const IofxSpriteRenderData* spriteRenderData = renderable->getSpriteRenderData())
        {
            renderSprites(spriteRenderData);
        }
        else
        if (const IofxMeshRenderData* meshRenderData = renderable->getMeshRenderData())
        {
            renderMeshes(meshRenderData);
        }
    }
    renderable->release();
}
iter->release();

There are two kinds of render data in IOFX Renderable, one is unique per Renderable and other is shared across several Renderables. IofxSpriteRenderData has references to shared IofxSpriteSharedRenderData, and IofxMeshRenderData has references to shared IofxMeshSharedRenderData.

Shared render data stores Sprite/Mesh Render Layout and Sprite/Mesh Render Buffer or Sprite Surfaces. Unique render data stores Render Resource information (Sprite material or Mesh from IOFX asset) and a range (defined by startIndex and objectCount) which points to the corresponding shared render buffer.

Note

For convenience IOFX provides a way to associate user data with each renderable object: IofxRenderable interface is derived from ApexInteface, which has userData member, and also IofxRenderCallback has 3 trigger methods onCreatedIofxRenderable, onUpdatedIofxRenderable & onReleasingIofxRenderable, which allows user to monitor renderable life time and updates, so that associated user data can be appropriately managed.

Shared Render Buffers & Surfaces

Shared render buffers for both Sprites & Meshes are implemented using UserRenderBuffer interface, and shared render surfaces for Sprites are implemented using UserRenderSurface interface.

To access render data on CPU for both render buffer & surface user have to use map/unmap methods.

By default APEX creates simple render buffer/surface internally based on given render layout, it just stores render data in CPU memory, and user need to map render buffer/surface, then copy its content to user graphics resource, and finally unmap it. This way is simple but not efficient, so APEX has another way for user to provide its own implementation for render buffer/surface, by overriding createRenderBuffer() & createRenderSurface() methods in IofxRenderCallback.

For CPU access user need to implement map/unmap methods, and can directly map/unmap graphics buffer, eliminating data copy.

When IOS simulation is done on GPU there is still overhead to copy data from GPU (compute) to CPU and back from CPU to GPU (graphics), and to eliminate this overhead IOFX supports compute-graphics interop, when IOFX writes render data directly into user graphics buffer on GPU. In order for interop to work, user have to implement getCUDAgraphicsResource() method in UserRenderBuffer/UserRenderSurface.

Note

IOFX always writes output semantics with exact formats and offsets provided by user-defined or default render layout. So when user graphics buffer is directly mapped or used in interop-mode, its structure have to exactly match IOFX render layout!

Render Volumes

RenderVolumes are the primary renderables of the APEX Particles pipeline. A volume “owns” a portion of world space, though ownership volumes are explictly allowed to overlap. Volumes are created via an IOFx module method:

RenderVolume *createRenderVolume( const Scene& apexScene, const PxBounds3& b, PxU32 priority, bool allIofx );

The bounds argument defines the volume’s ownership bounds. The priority is used to break ties when particles are within multiple volumes. If a particle is within multiple volumes of the same priority, it will prefer its previous volume when possible. The allIofx flag determines whether a volume will take ownership of all particles within its bounds, or only those particles emitted to specific IOFX assets.

The game may create or release render volumes at any time, their insertions and deletions are queued to make them thread-safe. As volumes take ownership of particles, IOFX actors are instantiated on demand to manage the render resources required to draw them. This deferred IOFX actor creation may be disabled via an IOFx module method: disableDeferredRenderableAllocation().

Calling getBounds() on the render volume will return the bounds of all the particles in that render volume that frame. It is usually much smaller than the volume’s ownership bounds and should be used for culling purposes. Culling a render volume implicitly culls all of the IOFX actors it holds.

If a particle is not owned by any volume at the end of a simulation step, it is considered “homeless” and is not rendered. It will be deleted on the next simulation step.

Render Volumes Use Cases

RenderVolumes provide a lot of flexibility in the way particle render resources are managed. Here are just a few use cases.

Simple

A game may allocate just a single RenderVolume with infinite bounds, zero priority, and allIofx set to true.

Renderable Per Emitter

If your game engine prefers to have one renderable per emitter, you may create an RenderVolume for each APEX emitter and set the volume as the emitter’s preferred volume:

PxBounds3 b; b.setInfinite();
vol = IofxModule->createRenderVolume( scene, infBounds, 0, true );
emitterActor->setPreferredRenderVolume( vol );

Since particles stay within the volume they were injected until they encounter a higher priority volume, each emitter’s volume will hold all the particles emitted by this emitter. If the game wished, they could limit the size of the bounds and update its position to follow the emitter, though this is not strictly necessary. In general we prefer you allow our LOD system to delete particles that are no longer “interesting”, so only restrict the bounding volume if you truly require all of the particles drawn by that volume to be spatially coherent.

Lighting Considerations

If your game engine incurs a serious cost penalty for every light that can see any particle in a draw call, you can use volumes per light to collect together all the particles a particular light can see. When used in this way, you will typically have one “world” volume with zero priority and priority one volumes for each light.

Beware that APEX volume migration was optimized for only a few volumes being active at a time (less than a dozen). So the game should try to create and delete volumes as game play progresses to keep the total count low.

Special IOFX Renderers

If your game engine has special rendering code for a small number of IOFX assets, you can create a render volume with non-zero priority and allIofx = false. You then explicitly set the IOFX assets you do want the render volume to affect. That volume will then only take ownership of (and create IOFX actors for) particles created for those IOFX assets.

Note that you could achieve the same effect by querying the IOFX asset of each IOFX actor before rendering this actor.

Explicit Culling

If your game has live “cut scenes” where the camera path is fixed and you want to maximize the number of particles in front of the camera, you can create a single render volume that only covers the visible world and allow all non-visible particles to become homeless and culled. Be aware that finite bounds volumes can create havoc with APEX emitters that try to keep an area of the world covered with particles, aka the Air/Ground emitter. It is best not to combine the two.

Render Volumes At Runtime

In order to render Render Volume user should lock actor list and iterate over it like this:

if (visibilityCheck(mVolume->getBounds())
{
    uint32_t numIofxActors;
    IofxActor* const* iofxActors = mVolume->lockIofxActorList(numIofxActors);
    for (uint32_t i = 0 ; i < numIofxActors ; i++)
    {
        IofxRenderable* renderable = iofxActors[i]->acquireRenderableReference();
        if (renderable)
        {
            if (visibilityCheck(renderable->getBounds())
            {
                if (const IofxSpriteRenderData* spriteRenderData = renderable->getSpriteRenderData())
                {
                    renderSprites(spriteRenderData);
                }
                else
                if (const IofxMeshRenderData* meshRenderData = renderable->getMeshRenderData())
                {
                    renderMeshes(meshRenderData);
                }
            }
            renderable->release();
        }
    }
    mVolume->unlockIofxActorList();
}

Errors and Warnings

APEX IOFx outputs the following error and warning messages using the standard APEX error stream. All are caused by authoring problems.

ERROR CODE | MESSAGE | Explanation
APEX_INVALID_PARAMETER | RenderMeshAsset with name “%s” not found. | The specified mesh asset could not be found.
APEX_INVALID_OPERATION | Unable to set Sprite Material Name (%s). Systems can be either Mesh or Sprite, but not both. This system is already a Mesh. | Authoring problem. The asset is marked as both a sprite and a mesh.
APEX_INVALID_OPERATION | Unable to set Mesh Material Name (%s). Systems can be either Mesh or Sprite, but not both. This system is already a Sprite. | Authoring problem. The asset is marked as both a sprite and a mesh.
APEX_INVALID_OPERATION | Unable to set Mesh Material Weight (%d). Systems can be either Mesh or Sprite, but not both. This system is already a Sprite. | Authoring problem. The asset is marked as both a sprite and a mesh.
APEX_INVALID_OPERATION | Specifying modifiers before specifying the mesh or sprite asset is invalid | Authoring problem. A mesh or sprite must be specified to which the modifier is applied.
APEX_INVALID_OPERATION | The specified modifier doesn’t work on that system type (e.g. Sprite Modifier on a Mesh System or vice-versa). | Authoring problem. Only mesh modifiers can be used on meshes and only sprite modifiers can be applied to sprites.
APEX_INVALID_OPERATION | The specified modifier doesn’t work in that stage. | Authoring problem.
APEX_INVALID_OPERATION | position %d is greater than modifier stack size: %d | APEX internal error

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

APEX IOFx Users Guide

Introduction

The IOFx provides the ability to control the parameters that determine if the particles should be drawn as meshes or as sprites. The parameters that determine how the mesh or sprites are drawn are also in the IOFx asset. These parameters are described in the documents referenced below:

  • APEX Mesh IOFX Asset Parameters
  • APEX Sprite IOFX Asset Parameters

IOFx Modifiers

There are two types of IOFx modifiers, Spawn Modifiers that set the characteristics of the particles when they are emitted and Continuous Modifiers that update the particles over time. Characteristics such as the way the particles move, their size, and color can be set and modified. There are modifiers that change the characteristics over time, particle density, velocity, and in a random manner constrained by authorable limits.

The list of parameters and their descriptions for the various modifiers are described here:

  • APEX Mesh IOFX Continuous Modifier Parameters
  • APEX Sprite IOFX Continuous Modifier Parameters
  • APEX Mesh IOFX Spawn Modifier Parameters
  • APEX Sprite IOFX Spawn Modifier Parameters

Notes:

  • All color channels (RGBA) for a particle are initialized with a value of 1.0 when spawned.
  • If a continuous modifier for color is present, no spawn modifier for color is necessary.
  • Color modifiers in the continuous modifier stack are executed in the order they appear in the stack (0 through n)
  • The first color modifier in the continuouts modifier stack ‘’sets’’ the color, following color modifiers will ‘’multiply’’ the color
  • Using a rotation modifier with an orient along screen velocity modifier (or an orient scale along screen velocity modifier) is not recommended and may result in undetermined particle behavior. If you do use both modifiers together, the modifier nearest to the bottom of the modifier stack will take predominance.

Example

IOFx Example

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

IOFx Example

Introduction

The parameters of an IOFx asset control the type of the asset and select which modifiers are to be used to change how the objects are spawned and behave after they are spawned.

To output 2D sprites, set the spriteMaterialName.

spriteMaterialName = SampleRenderer/1/materials/particle_dust.xml

If instead of sprites instanced 3D meshes are to be used the following parameters are set One or more render mesh assets may be specified. For each mesh you add, you can specify a weight. The relative weights of all added meshes determines the percentage of objects that will be rendered using each mesh.

addRenderMeshAssetName = RenderMeshAssetName
setRenderMeshRelativeWeight = 1
addRenderMeshAssetName = Skull/Skull01
setRenderMeshRelativeWeight = 1

The next step is to decide which modifiers should be applied. There are two types of modifiers, spawn modifiers and continuous modifiers. Spawn modifiers change the behavior of how the objects are spawned while the continuous modifiers alter the objects after they have been spawned.

Examples:
SpawnModifier <ModifierName> <Modifier Parameters>

ContinuousModifier <ModifierName> <Modifier Parameters>
ModifierName and Modifier Parameters will be explained below. Please note that unless otherwise
indicated, all parameters for a given ModifierName are required. Please also note that all
modifiers for a particular stage will be processed in order specified.
Common parameters
Certain parameters are common to multiple types, and are described here:
<colorChannel> should be one of the following:
0 : Red
1 : Green
2 : Blue
3 : Alpha
<function> describes a mathematical function g=f(x). More specifically,
our function consists of a list of points sorted in f, and the return value g that
should be returned for that point. We first must know how many pairs to expect.
ex: 3 0 0 0.5 0.75 1 1
would describe a curve of 3 points: (0, 0), (0.5, 0.75), (1, 1)
NOTE: At least 2 points are required for a function to be valid.
<axis> describes which axis a modifier applies to, and maps as following:
0 : X
1 : Y
2 : Z
Rotation <rollType>
<rollType> is one of the following:
0 : MPR_Spherical
1 : MPR_Cubic
2 : MPR_FlatX
3 : MPR_FlatY
4 : MPR_FlatZ
5 : MPR_LongX
6 : MPR_LongY
7 : MPR_LongZ
8 : Sprite
ContinuousModifier Rotation 1 5 15
SimpleScale <xScale> <yScale> <zScale>
Applies a simple scale factor to all particles
SpawnModifier SimpleScale 0.002 0.002 0.002
RandomScale <scaleMin> <scaleMax>
Applies a random uniform in (scaleMin, scaleMax) to all three dimensions
ColorVsLife <colorChannel> <function>
Modulates the colorChannel specified by the function, using lifeRemains as input.
ColorVsDensity <colorChannel> <function>
Modulates the colorChannel specified by the function, using particle density as input.
SubtextureVsLife <function>
Returns the functional transform, using lifeRemains as input. Note that it is up to
the application to interpret the meaning of the returned value
OrientAlongVelocity <fowardX> <forwardY> <forwardZ>
Orients the specified forward velocity towards the velocity vector.
ScaleAlongVelocity <scale>
Scales the particle in the one dimension that it is currently traveling.
RandomSubtextureModifier <scaleMin> <scaleMax>
Passes a random uniform in (scaleMin, scaleMax) through the subtexture semantic.
RandomRotation <rotMin> <rotMax>
Applies a random uniform rotation (in (rotMin, rotMax)) to a sprite, where 0 is up,
the values are in radians and increase clockwise.
ScaleVsLife <axis> <function>
Applies the functional transform to the specified axis, using lifeRemains as input.
ScaleVsDensity <axis> <function>
Applies the functional transform to the specified axis, using particle density as input.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

Basic IOS Example

Introduction

There are very few parameters that need to be set for a Basic IOS actor since the capabilities are, as the name implies, basic.

The characteristics of the “particles” that are controlled by the restDensity and the particleRadius parameters. The restDensity parameter controls the density of objects. Emitters need this parameter for constant density emitter effects. The particle radius controls the radius of the objects.

restDensity = 1.0
particleRadius = 0.1

The maxparticleCount parameter controls the maximum number of objects that any one Basic IOS actor has at any one time. The maxInjectedParticleCount controls the rate at which particles are spawned on a per frame basis. If the parameter is set to a value that is greater than 1 it is used to control the absolute number of particles that are spawned per frame. If maxInjectedParticleCount is set to a value of 1 or less the number is interpreted as a percentage of the maximum number of objects to be spawned per frame. In the following example that sets maxInjectedParticleCount to 0.1 10% of the maxParticleCount of 16384 objects or 164 objects would be spawned per frame.

maxParticleCount = 16384
maxInjectedParticleCount = 0.1

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

APEX Particle CUDA Memory Usage

Unfortunately APEX simulation does not gracefully handle many of the cases where we can run out of GPU memory. Even handling an out-of-memory condition just means halting simulation since there is no way we can simulate on the GPU if there is not enough memory. So the best course of action is to avoid running out of GPU memory in your shipping application.

You may need to limit how many grids and particles you create in your application to limit the maximum memory usage. You can then measure what the peak memory usage is in your application. Since some users have less video memory than others, you will also want to know up front whether there is enough video memory to meet the peak memory usage. To do that you can pre-allocate the CUDA heaps with CudaMemoryManager::reserve() when the application starts up, and if it fails you can simply disable APEX particle effects in the application.

To figure out the high water mark for memory usage in your application, you can query the CudaMemoryManager for stats. See the APEX samples (OpenAutomateInterface.cpp) for an example of how to do this. We recommend an on-screen display of memory usage you can toggle during development so you can get instant feedback on how expensive your effects are. The two heaps you will want to monitor (and eventually pre-allocate) are CudaBufferMemorySpace::T_GPU and CudaBufferMemorySpace::T_PINNED_HOST. All APEX buffers are of type F_READ_WRITE.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »

APEX Particle Integration Guide

Introduction

This document gives some tips and guidelines for how to integrate APEX particles into a game that uses PhysX 3.x, to get the best performance without sacrificing visual quality.

CUDA Context Manager

  • Do not share a single CudaContextManager between multiple scenes. Although the API does allow you to do this, if you share the CudaContextManager there will be dependencies created between scenes on CUDA work. Most of the time this is not what you want.
  • Do not use a CudaContextManager on scenes that don’t use GPU features. For example, if you have a primary scene for handling standard rigid body interactions in your game, and an effects scene for handling APEX particles, you would only need to give a CudaContextManager to the effects scene.

Second Effects Scene

If your game already uses PhysX 3.x for gameplay-affecting rigid body simulation, it may make sense to simulate APEX particles in a separate scene so your game logic won’t be blocked waiting for the APEX simulation to complete. We recommend keeping your primary PxScene as-is, and creating a second effects PxScene paired with an Scene for APEX particle effects. The effects scene can be stepped whenever convenient. Any rigid bodies or shapes you want to interact with APEX particles must be mirrored into the effects scene.

Second effects scene

Stepping the effects scene

Even if you use multiple simulation steps per frame in your primary scene, we recommend using a single variable-length timestep in the effects scene. In other words, just pass the elapsed time to the effects scene’s simulate() once each frame. If necessary, you could set a minimum and maximum timestep size.

The effects scene does not have to be stepped at the same time as the primary scene. You could call effectsScene->simulate() earlier and effectsScene->fetchResults() later than the primary scene to allow it to simulate in parallel with other game work.

Mirroring shapes to the effects scene

Any rigid bodies or shapes you want to interact with APEX particles must be mirrored into the effects scene from the primary scene. Keep in mind that you should only add objects to the effects scene when the effects scene is not being simulated. You may be able to get away with much simpler primitives in your effects scene. For example, even if you have a very detailed collision model for your character controller (to detect head shots for example) you could probably just mirror it into the effects scene as a single capsule that approximates the size of the character.

You may want to mirror static geometry into the effects scene so that APEX particles interact with the static environment. Static geometry typically doesn’t get updated once it’s created so this could be done once as the geometry is loaded. Dynamic rigid bodies should be mirrored into the effects scene as kinematics. The PhysX 3.x Extensions include PxCloneDynamic and PxCloneStatic helpers to get you started. See the PhysX documentation for more details.

Fully asynchronous effects scene

If you want to be able to add APEX particle effects with minimal impact on the game’s frame rate, you can take it a step further and create a fully asynchronous effects scene. In this model you step the effects scene in a separate thread at whatever rate you can simulate it at. You buffer the render data and in your game’s normal render loop you render the most recently completed APEX particle render data. If the effects scene simulation time falls behind the game’s frame time, you will see a visual artifact of the particles stuttering, but without any large impact on overall frame rate.

The benefit is the minimal impact the particle effects have on frame rate. The downside is that it becomes more complex to manage the effects scene. Here are some of the things you’ll want to check that you’re handling properly:

  • You will need to handle safe communication between your main game thread and the thread managing the effects scene.
  • You will have to handle the case where a shape that gets mirrored is added to the primary scene, queued up to be added to the effects scene, then deleted from the primary before it has been added to the effects scene.
  • You will have to mirror updates to the mirrored objects like pose or collision group changes.
  • You will need to double-buffer the particle rendering data received from APEX in the effects thread and pass it safely to the rendering thread. You will most likely be calling simulate, fetchResults, dispatchRenderResources, and updateRenderResources all from the effects thread.
  • There’s no point in simulating the effects more than once a frame, so you’ll also want to limit how often simulate gets called on the effects scene when simulation time is low.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Particles Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »

APEX Turbulence Module

Contents:

  • Turbulence Introduction
    • Note
    • Turbulence Assets
    • Turbulence Actors
      • Interaction with PhysX Shapes
      • Controlling the effect of PhysX Shapes
      • Definition of BasicFS
      • BasicFS Asset
      • Variables for affecting the shape of basic field samplers in a grid
      • Variables for affecting the shape of the Turbulence shape outside the grid
      • Variables for direction and strength
    • Field Variation Details
    • LOD Support
    • Turbulence Thermodynamics
      • How to Use
      • Heat Sources
      • Heat sources can be manipulated by
      • Extra Parameters
    • Debug Visualization
      • Visualizing Velocity Fields
      • Velocity Vectors
      • Stream Lines
      • Temperature
      • Plane
    • Miscellaneous Features
      • Implicit Collision Transforms
      • Add a Single Direction Velocity to a Grid
    • Accessing Field Data as Render Surfaces
    • Errors and Warnings

API

  • Turbulence Field Sampler API

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Turbulence Module »

Turbulence Introduction

The Apex Turbulence module creates effects using APEX Basic IOS particles. The combination of APEX Turbulence and APEX Particles creates a particle system that can be used to create a wide variety of effects using a light weight particle system allowing a large number of particles to be active simultaneously. The effects that Turbulence is designed to create are local around the user with a high fidelity simulation. Good targets for APEX Turbulence are things like jet packs or jet engine exhaust, steam exhaust from a steam engine, and dry ice effects.

The area where a Turbulence Actor is active is called the Turbulence Grid. APEX Particles within the grid are subjected to forces that vary depending upon where in the grid the particles are located and simulation time. The forces and how they vary are within the grid are authored and are known as a Basic Field Sampler which are authored using the APEX BasicFS module.

To perturb the movements of particles within the Turbulence Grid more than the Basic Field Samplers alone can do the Turbulence module supports adding APEX Shapes that block the movement of particles within the shapes. There can be an unlimited number of APEX Shapes created by the game engine and can be moved both within and outside of the Turbulence Grid to block the particles. When an APEX Shape is added to a Turbulence Actor the particles within the grid the APEX Particles within the Grid can collide with the shape and will not occupy the same sapce. These shapes can be visible or invisible as the game engine renderer implements. Currently the APEX Shapes are Sphere, Box, Plane and Capsule.

Note

The Turbulence module is only supported on Windows.

Turbulence Assets

This link describles all of the Turbulence asset parameters.

Turbulence Actors

This link describles all of the Turbulence actor parameters.

Interaction with PhysX Shapes

Turbulence actors can interact with PhysX shapes if the collision filtering settings are set correctly (set in the Turbulence asset or actor).

Controlling the effect of PhysX Shapes

Colliding PhysX Shapes impart angular and linear velocity onto the grid, and this velocity is determined by the current and previous pose of the shape. There are additionally four parameters that can be set per Turbulence Actor which will affect how colliding shapes affect the grid’s velocity field. These are AngularVelocityMultiplier, AngularVelocityClamp, LinearVelocityMultiplier and LinearVelocityClamp. The Multiplier will be multiplied with the computed velocity, and the resultant velocity will be clamped to the Clamp value. Artists can use these variables to control how much or how little the collision objects affect the grid. To set these values you can use these two API calls on the TurbulenceFS actor:

setAngularVelocityMultiplierAndClamp
setLinearVelocityMultiplierAndClamp

Definition of BasicFS

Turbulence Jets have now been replaced by a new Module called BasicFS. BasicFS acts like a jet force inside the turbulence grid and as a torroidal force directly affecting the particles outside the grid. Both the force direction and amount can be specified and these variables can be animated/oscillated over time. Besides Jets BasicFS provides Attractors which attract particles to specified point with specified force.

BasicFS Asset

BasicFS assets can be authored by artists. Here are some of the important attributes of the BasicFS asset:

Variables for affecting the shape of basic field samplers in a grid

gridShapeRadius(float) Radius of sphere or capsule shape inside of the grid
gridShapeHeight(float) Height of capsule shape inside of the grid
gridBoundaryFadePercentage(float) Percentage of distance from boundary to center where fade out starts. FadePercentage of 0 removes
the fade region, and FadePercentage of 1 makes the fade region take up the entire region of the shape (fade region will start at center of shape)

Variables for affecting the shape of the Turbulence shape outside the grid

nearRadius(float)radius of field core, velocity up to this radius is constant
pivotRadius(float) the center of the toroid
farRadius(float)the outside radius of the toroid
directionalStretch(float) the ratio of the height of the shape to its base

Variables for direction and strength

fieldDirection(VEC3)
fieldDirectionDeviationAngle(float)
fieldDirectionOscillationPeriod(float)
fieldStrength(float)
fieldStrengthDeviationPercentage(float)
fieldStrengthOscillationPeriod(float)
averageStartDistance(float)
averageEndDistance(float)

Field Variation Details

The direction of the field varies with time. This effect fades as a function of the distrance from the center of the field. Inside the grid the oscillating direction is used, and in fake field this oscillation is faded out starting from average start distance. Average start distance and average end distance control the blending of the two fields - the field from fixed direction and the field from variable direction (oscillation). Before start distance there’s only oscillation field & after end distance only fixed field, and there is a smooth-step interpolating between the two (starting from average start distance up to average end distance).

LOD Support

Level Of Detail is not supported anymore.

Turbulence Thermodynamics

By having heat in the system you can create effects such as hot air rising past an obstacle, cold air wafting down off of objects, and mushroom clouds. Users have the ability to add heat sources to a simulation; these heat sources increase the local temperature in the simulation (which is an additional variable that is tracked in addition to velocity in the grid), and this temperature is advected through the grid (as the fluid moves it carries its local temperature with it). At each time step, the temperature in the grid is used to add velocity impulses to the grid in a user specified direction.

Note that using heat is more powerful than using just jet forces for creating certain types of effects. For example, to have smoke rise past a sphere (rising smoke hits a sphere, then flows around it and continues going upwards) jet forces are insufficient, since once the rising fluid hits the sphere obstacle its velocity is set to zero and it has no more force moving it upwards to flow around the sphere.

How to Use

In order to use heat in the simulation you have to:

1. Enable it using: TurbulenceFSActor::setUseHeat(bool). If heat is not enabled the simulation will ignore all heat sources, and the temperature field. Heat is disabled by default since its use does increase workload and decrease performance. 2. Add heat sources to the simulation, covered in “Heat Sources” below. 3. Configure how the simulation should react to the temperature, covered in “Extra Parameters” below.

Heat Sources

Heat is added to the system using two types of heat sources, under the NvParameterized included reference, geometryType:

  • Box - PxVec3 extents
  • Sphere - PxF32 radius

Creating the Heat Source

The HeatSourceActorParams NvParameterized class contains the parameters necessary to create a HeatSource Actor:

  • position - The heat source may be placed with a particular position.
  • averageTemperature - The arithmetic mean of a sample. Normal distribution parameter.
  • stdTemperature - Standard deviation of temperature. Normal distribution parameter.

The heat source actor is created, added and removed to an apex scene like all other actors.

Heat sources can be manipulated by

  1. Modifying their underlying APEXShape properties; you can access the APEXShape by calling the interface HeatSourceActor::getSphereShape()or HeatSourceActor::getBoxShape()
  2. Setting their temperature, defined by an average and a standard deviation. All fluid cells falling inside the heat source will get a random temperature defined by this average and standard deviation.
void HeatSourceActor::setTemperature(float averageTemperature, float stdTemperature);

Extra Parameters

The user has the ability to configure how the simulation should react to the temperature, and these options are set through the interface:

TurbulenceFSActor::setHeatBasedParameters(float forceMultiplier, float ambientTemperature, PxVec3 heatForceDirection);

The ambient temperature provides a cutoff for the minimum temperature that adds velocity in the system - if the temperature of the fluid is less than the ambient temperature no velocity is added to the simulation.

The forceMultiplier controls how much the difference in temperature affects the velocity, based on the simple formula:

Impulse_strength = forceMultiplier*(temp - ambientTemp);

The force direction controls what direction the heat induced velocity is applied in - if we want to create hot air rising up then the axis would be set to the up vector, and if we want to create a cold fluid sinking under gravity we would set this axis to -up. An example of using Turbulence heat is shown in the SimpleTurbulence sample in the scene TurbulenceHeatScene (scene 5).

Debug Visualization

All APEX modules come with debug visualization rendering, to help understand what is happening in an APEX scene. When you hit the V key in SimpleTurbulence, default APEX visualization rendering is turned on, as well as default PhysX SDK visualization. In addition to the default settings, APEX Turbulence LOD benefits and support visualization are shown. All visualization options will be described below.

Click here for a list of the Turbulence debug visualization parameters

For general information on how to use debug visualization within APEX, please see Debug Visualization.

Starting SimpleTurbulence and hitting ‘V’ (for visualization) displays the following:

Visualizing Velocity Fields

Velocity Fields can be visualized in two ways. The first is with 3d veleocity vectors and the second allows visualization of how particles flow through the grid which are termed stream lines. Turbulence debug visualization provides methods of viewing the spatially varying values of velocity fields.

Velocity Vectors

The velocity field can be visualized as shaded lines originating at the simulation grid cell centers and extending in the direction of the local velocity (these lines are shaded white at their beginning and red at their end). These parameters control the visualization of the velocity vectors:

VISUALIZE_TURBULENCE_FS_FIELD
TURBULENCE_FS_FIELD_SCALE
TURBULENCE_FS_FIELD_SPACING

Stream Lines

The velocity field can also be visualized as streamlines. Streamlines render the paths of particles initialized at regular intervals on the grid and traced through the velocity field.

Visualization of a streamline (white curved line is the streamline, and the red arrows are the underlying velocity vector field):

These parameters control the visualization of the streamlines:

VISUALIZE_TURBULENCE_FS_STREAMLINES
TURBULENCE_FS_STREAMLINES.grid
TURBULENCE_FS_STREAMLINES.tstep
TURBULENCE_FS_STREAMLINES.tmax

Temperature

The temperature field is visualized as 3D crosses centered at grid cell centers. The size of the cross denotes the temperature amount at that cell.

These parameters control the visualization of the temperature:

VISUALIZE_TURBULENCE_FS_TEMPERATURE
TURBULENCE_FS_TEMPERATURE_SCALE
TURBULENCE_FS_TEMPERATURE_SPACING

Plane

Hit ‘Z’ on running sample to display the plane which is intersecting the bounding box. Lines where faces of bounding box are intersected by the plane will be highlighted.

After you turn plane visualization on both velocity vectors and streamlines start originate on the plane (but still in the box).

These parameters control the visualization of the temperature:

VISUALIZE_TURBULENCE_FS_PLANE
TURBULENCE_FS_PLANE.normal
TURBULENCE_FS_PLANE.offset

Given plane also intersects Euler’s grid, each box (parallelepiped in common case) at some angle. To visualize this, hit ‘X’ while running sample with debug visualization turned on or set the parameter (but note that enabling this option will significantly affect performance and reduce FPS).

VISUALIZE_TURBULENCE_FS_GRID

Miscellaneous Features

Implicit Collision Transforms

The collision implicit in the Turbulence asset can be arbitrarily transformed using two variables:

implicitCollisionRadius; // 3D radius of collision implicit
                         //implicitXForm a 4x4 column major matrix denoting the orientation and translation of the implicit

For example, to get an object with a 45 degree rotation around the z axis and a translation of (1,0,0) the implicitXForm is set to

<value name="implicitXForm" type="Mat44">(0.707,0.707,0,0, -0.707,0.707,0,0, 0,0,1,0, -1.0,0,0.0,1)</value>

Add a Single Direction Velocity to a Grid

External Actors can add a single directional velocity to the grid using the interface

TurbulenceFSActor::setExternalVelocity(PxVec3 vel);

Note that if multiple calls to this function are made only the last call is honored (i.e. the velocities are not accumulated). Also note that that the value set by this function is persistent across simulation frames (you can call the function once to set the external wind value and until you call this function again with a new value, potentially many frames later, the previous value will continue to get used).

Accessing Field Data as Render Surfaces

Field data access is implemented through renderable object defined in TurbulenceRenderable. It has getRenderData() method, which returns TurbulenceRenderData structure, containing render surfaces and their descriptions. Each TurbulenceFS actor has its own renderable object, which stores all needed information and can live after the original actor has been released. User can get TurbulenceRenderable object from TurbulenceFS actor by calling acquireRenderableReference() method, and after using its render data user should release the renderable object:

TurbulenceRenderable* turbulenceRenderable = turbulenceActor->acquireRenderableReference();
if (turbulenceRenderable)
{
    const TurbulenceRenderData* renderData = turbulenceRenderable->getRenderData();
    //use renderData to access render surfaces
    turbulenceRenderable->release();
}

Note

Before accessing render data in renderables, user should call ModuleTurbulenceFS::prepareRenderables(const Scene&) once for each rendering frame.

There are 3 different types of field data, which user can access, defined in TurbulenceFieldType:

  • VELOCITY (float4: xyz - 3D velocity, w - velocity magnitude)
  • DENSITY (float: density value)
  • FLAME (float4: x - temperature, y - remaining fuel, z - burned fuel, w - density)

Note

User have to call enableOutputVelocityField()/enableOutputDensityField()/enableOutputFlameField() methods in ModuleTurbulenceFS to enable needed field types output!

By default Turbulence uses its own format for each field type, but user has an option to override this by implementing getTurbulenceRenderLayout method in TurbulenceRenderCallback. All supported formats for each field type are defined in TurbulenceVelocityFormat/TurbulenceDensityFormat/TurbulenceFlameFormat enums.

To get field data from render surface on CPU user have to use map/unmap methods of UserRenderSurface. By default APEX creates simple render surface internally based on given field data format, it just stores field data in CPU memory, and user need to map render surface, then copy its content to user graphics resource, and finally unmap it. This way is simple but not efficient, so APEX has another way for user to provide custom implementation for render surface, by overriding createRenderSurface() method in TurbulenceRenderCallback. In this custom implementation for CPU access user need to implement map/unmap methods, and can directly map/unmap graphics surface, eliminating data copy.

Turbulence simulation is done on GPU, and there is overhead to copy data from GPU (compute) to CPU and if needed back from CPU to GPU (graphics), and to eliminate this overhead (in case when data is needed only on GPU) Turbulence supports compute-graphics interop, when Turbulence writes render data directly into user graphics surface on GPU. In order for interop to work, user have to implement getCUDAgraphicsResource() method in custom implementation of UserRenderSurface.

Errors and Warnings

APEX Turbulence outputs the following error and warning messages using the standard APEX error stream.

ERROR CODE | MESSAGE | Explanation
APEX_INVALID_OPERATION | Not yet implemented! | The Turbulence Module does not support dynamically editing the NvParameterized::Interface
APEX_INVALID_OPERATION | Not implemented! | The Turbulence module does not support preparing an asset for another platform
APEX_DEBUG_WARNING | Driver error = %04d from file <%s>, line %i. |
APEX_DEBUG_WARNING | TURBULENCE FATAL ERROR - invalid value |
APEX_DEBUG_WARNING | TURBULENCE FATAL ERROR - out of memory |
APEX_DEBUG_WARNING | TURBULENCE FATAL ERROR - not initialized |
APEX_DEBUG_WARNING | TURBULENCE FATAL ERROR - launch failure |
APEX_DEBUG_WARNING | TURBULENCE FATAL ERROR - out of resources |
APEX_DEBUG_WARNING | TURBULENCE FATAL ERROR - lauch timeout |
APEX_DEBUG_WARNING | TURBULENCE FATAL ERROR - invalid context |
APEX_DEBUG_WARNING | TURBULENCE FATAL ERROR - error unknown |
APEX_DEBUG_WARNING | TURBULENCE FATAL ERROR - error deitialized |
APEX_DEBUG_WARNING | TURBULENCE FATAL ERROR - error invalid handle |
APEX_DEBUG_WARNING | TURBULENCE FATAL ERROR - unknown error |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - u dimensions mismatch |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - v dimensions mismatch |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - v dimensions mismatch |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - u,v,w layout mismatch |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - u has no ghost cells |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - v has no ghost cells |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - w has no ghost cells |
APEX_DEBUG_WARNING | [ERROR] Advection3DDevice::initialize_storage - garbage hx,hy,hz value |
APEX_DEBUG_WARNING | [ERROR] AdvectionMacCormack3DDeviceF::initialize_storage - error allocating extra grids |
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDeviceF::invoke_kernel_downsample - bad level = %d |
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDevice::invoke_kernel_downsample - CUDA error “%s” | A CUDA error occurred. A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDeviceF::invoke_kernel_upsample - bad level = %d |
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDevice::invoke_kernel_upsample - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDevice::invoke_kernel_apply_upwind - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | Before BC: Max u at level %d = %f |
APEX_DEBUG_WARNING | After: Max u at level %d = %f |
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDeviceF::solve - garbage req_dt %f! |
APEX_DEBUG_WARNING | level %d |
APEX_DEBUG_WARNING | [ERROR] AdvectionUpwind3DDeviceF::solve - too fast level = %d, _num_levels = %d! |
APEX_DEBUG_WARNING | Max u at level %d = %f |
APEX_DEBUG_WARNING | Max deriv_u at level %d = %f |
APEX_DEBUG_WARNING | [ERROR] Advection3D::initialize_storage - error allocating derivative grids |
APEX_DEBUG_WARNING | [ERROR] apply_3d_boundary_conditions_level1_nocorners - invalid boundary condition types %d, %d, %d, %d, %d,%d |
APEX_DEBUG_WARNING | [ERROR] apply_3d_boundary_conditions_level1_nocorners - must have at least 1 ghost point |
APEX_DEBUG_WARNING | [ERROR] apply_3d_boundary_conditions_level1_nocorners - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - invalid boundary condition types %d, %d, %d, %d, %d,%d |
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - layout mismatch |
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - must have at least 1 ghost point |
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - v_grid dimension mismatch (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - w_grid dimension mismatch (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - CUDA error in x “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - CUDA error in y “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] apply_3d_mac_boundary_conditions_level1 - CUDA error in z “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] apply_3d_boundary_conditions_level1_nocorners - invalid boundary condition types %d, %d, %d, %d, %d,%d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDeviceT::clear_zero - cudaMemset failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_interior_data - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_interior_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_all_data - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_all_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_interior_data - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_interior_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_all_data - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::copy_all_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::linear_combination - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDeviceF::linear_combination - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::linear_combination - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::linear_combination - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DDeviceF::linear_combination - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid1DDevice::init - gpu buffer alloc failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_interior_data - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_interior_data - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::linear_combination - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::linear_combination - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::linear_combination - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::init - host buffer alloc failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_interior_data - nx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_interior_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_all_data - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_all_data - cudaMemcpy failed with %s |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::copy_all_data - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost copy_partial_data_async - pnx mismatch: %d != %d |
APEX_DEBUG_WARNING | [ERROR] Grid3DDeviceT::clear_zero - cudaMemset failed |
APEX_DEBUG_WARNING | [ERROR] Grid3DDeviceF::clear - CUDA error | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid3DDeviceF::clear - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - non specialized function called |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::linear_combination - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDeviceF::linear_combination - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::linear_combination - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::linear_combination - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DDeviceF::linear_combination - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] Grid3DDevice::init - gpu buffer alloc failed |
APEX_DEBUG_WARNING | ERROR: calling base implementation of initCUDAFunction |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::copy_interior_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::copy_interior_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::copy_interior_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::linear_combination - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid1DHost::linear_combination - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::init - host buffer alloc failed |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::copy_all_data - cudaMemcpy failed |
APEX_DEBUG_WARNING | [ERROR] Grid3DHost::copy_all_data - mismatch: (%d, %d, %d) != (%d, %d, %d) |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3DDeviceF::invoke_kernel_calculate_relax - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3DDeviceF::invoke_kernel_calculate_residual - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3DDeviceF::invoke_kernel_restrict - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3DDeviceF::invoke_kernel_prolong - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - garbage hx,hy,hz value %f %f %f |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::relax - failed at level %d |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::restrict_residuals - failed at level %d -> %d |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::prolong - failed at level %d -> %d |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::apply_boundary_conditions - failed at level %d |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::apply_boundary_conditions - failed at level %d |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3::initialize_storage - error in grid calculation |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - rhs has invalid ghost cells (%d,%d,%d), must be >= 1 |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - rhs dimension mismatch (%d,%d,%d) != (%d,%d,%d) |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - could not initialize _r_grid[0] |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - could not initialize _u_grid[0] |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - could not initialize _u_grid[%d] |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - could not initialize _b_grid[%d] |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - could not initialize _r_grid[%d] |
APEX_DEBUG_WARNING | [ERROR] MultigridPressure3D::initialize_storage - grid dimension mismatch |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DBase::convert_bc_to_poisson_eqn - invalid boundary condition type %d |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DBase::initialize_base_storage - u dimensions mismatch |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DBase::initialize_base_storage - v dimensions mismatch |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DBase::initialize_base_storage - v dimensions mismatch |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DBase::initialize_base_storage - u,v,w layout mismatch |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::initialize_base_storage - must have at least one ghost cell on all sides |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DBase::initialize_base_storage - garbage hx,hy,hz value |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::calculate_divergence - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::subtract_grad_p - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::solve - could not enforce boundary conditions |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::solve - could not calculate divergence |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::solve - could not solve for pressure |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::solve - could not subtract gradient of pressure |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::solve - could not enforce boundary conditions |
APEX_DEBUG_WARNING | Max divergence: before = %.010f, after = %.010f (reduction %fx) |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::initialize_storage - failed to initialize base storage |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::initialize_storage - failed to initialize divergence |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::initialize_storage - divergence layout mismatch |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::initialize_storage - failed to initialize pressure_solver |
APEX_DEBUG_WARNING | [ERROR] ProjectDivergence3DDevice::initialize_storage - pressure layout mismatch |
APEX_DEBUG_WARNING | ERROR: calling base implementation of initCUDAFunction |
APEX_DEBUG_WARNING | [ERROR] sample_points_3d - position arrays do not have matching sizes |
APEX_DEBUG_WARNING | [ERROR] sample_points_3d - CUDA error | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] sample_points_3d - position arrays do not have matching sizes |
APEX_DEBUG_WARNING | [ERROR] sample_weighted_points_3d - CUDA error | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] calculate_velocity_weights - CUDA error “%s” | A CUDA error occurred.
APEX_DEBUG_WARNING | [ERROR] sample_points_mac_grid_3d - failed on u sampling |
APEX_DEBUG_WARNING | [ERROR] sample_points_mac_grid_3d - failed on v sampling |
APEX_DEBUG_WARNING | [ERROR] sample_points_mac_grid_3d - failed on w sampling |
APEX_DEBUG_WARNING | [ERROR] sample_points_minmax_3d - position arrays do not have matching sizes |
APEX_DEBUG_WARNING | [ERROR] sample_points_minmax_3d - CUDA error “%s” | A CUDA error occurred.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
  • APEX Turbulence Module »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • previous
  • NVIDIA APEX Documentation »

NVIDIA Copyright Notice

Copyright (c) 2018 NVIDIA Corporation. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  • Neither the name of NVIDIA CORPORATION nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS’’ AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Navigation

  • previous
  • NVIDIA APEX Documentation »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.


Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »

APEX 1.3 to 1.4 Migration Guide

This guide highlights the significant API changes that have occured between APEX 1.3 and APEX 1.4. This guide is aimed at a developer already using APEX 1.3.x who wants to know the minimum amount of work to upgrade to APEX 1.4. Note that the PhysX API has also changed from PhysX 3.3.x to 3.4. Refer to the PhysX documentation for a description of PhysX API changes.

General

Supported PhysX versions

PhysX 2.* versions not supported in APEX 1.4. Apex supports 2 builds: with PhysX 3.4 for all modules and and without for Clothing module. Due to build APEXSDK and Clothing module without PhysX PxFoundation and some other PhysX modules were moved to PxShared library. APEX 1.4 uses this library.

General public interface changes

APEX 1.4 parental namespace changed from physx::apex to nvidia::apex.

All public interface files were moved to APEXSDK/inlclude library (the same as PhysX file structure) according to rules:
framework/public/* => include/* module/<moduleName>/public/* => include/<moduleName>/* NxParameterized/public/* => include/nvparameterized/*

Nx and NxApex prefixes for public files were removed. For example, NxApexActor.h in APEX 1.4 has name Actor.h. But note that in some cases Apex prefix weren’t removed, for example, NxApexDefs.h in APEX 1.4 has name ApexDefs.h

NxParameterized was refactored and renamed to NvParameterized.

NxMat33Legacy, NxMat34Legacy support were removed and this types were replaced with physx::PxMat33/physx::PxMat44/physx::PxTransform in all public files.

Global LOD feature was removed from APEXSDK. Corresponding methods were removed:
Scene.h: setLODResourceBudget, getLODResourceConsumed Module.h: getLODUnitCost, setLODUnitCost, getLODBenefitValue, setLODBenefitValue, getLODEnabled, setLODEnabled
Physical LOD methods in Actor.h were renamed:
forcePhysicalLod => forceLod
getActivePhysicalLod => getActiveLod
forcePhysicalLod => forceLod
NxApexParameter support was removed from Module.h:
class NxApexParameter Module methods: getNbParameters, getParameters

Removed modules

DynamicSystem, Explosion, FieldBoundary and NxFluidIos modules were removed in APEX 1.4.

Legacy module

In general, assets created with previous versions of APEX should “just work” with APEX 1.4. The application must load the legacy module, which contains all the code that allows APEX to automatically upgrade assets to the latest version.

In APEX 1.4 there is a single legacy module (APEX_Legacy).

apexSDK->createModule(“Legacy”);

Likewise, there is a single legacy module header file ModuleLegacy.h. On platforms that use static linking (consoles for example), the application only needs to include ModuleLegacy.h and make single call:

nvidia::apex::instantiateModuleLegacy();

Rendering interface changes

Removed methods:
Scene.h: prepareRenderResourceContexts

Platforms support

Removed PS3 and xbox3 support. Added PS4 and XboxOne support.

Samples and snippets

Added new samples_v2 and snippets. They are significantly simplier than old samples. Old samples APEXSDK/samples now for internal use only and they removed from distribution.

Navigation

  • next
  • previous |
  • NVIDIA APEX Documentation »
© Copyright 2012-2018, NVIDIA Corporation, All Rights Reserved. Created using Sphinx 1.0.2.